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Chapter 1. Introduction
What is Qfsm?

Qfsmisagraphical editor for finite state machineswritten in C++ using Qt the graphical Toolkit fromTroll-
tech [http://www.trolltech.com].

Finite state machines are models to describe complex objects or systems in terms of the states they may
be in. In practice they can be used to create regular expressions, scanners or other program code as well
asfor integrated curcuit design.

Current features of Qfsm are:

 Drawing, Editing and Printing of states diagrams

* Binary, ASCII and "free text" condition codes

* Integrity check

* Interactive smulation

 Diagram export (EPS, SVG and PNG format)

e AHDL/VHDL/Verilog HDL/KISS/vvvv Automata code export

» Statetable export in Latex, HTML and plain text format

* Ragd file export (used for C/C++, Java or Ruby code generation)
 State Chart XML (SCXML) export

Copyright and license information

Copyright (C) 2000-2010 Stefan Duffner

Thisprogram isfree software; you can redistribute it and/or modify it under the terms of the GNU General
Public License[LICENSE] as published by the Free Software Foundation; either version 2 of the License,
or (at your option) any later version.

This program isdistributed in the hope that it will be useful, but WITHOUT ANY WARRANTY ; without
even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
See the GNU Genera Public License for more details.

Y ou should have received acopy of the GNU General Public License along with this program; if not, write
to the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Installing the Qfsm software

Binary installation

Windows

There exists a (graphical) Windows installer that can be downloaded from here [http://
www.sourceforge.net/projects/gfsm]. The installation should be straightforward and doesn't require any
other software to be installed.
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Introduction

Linux

An RPM packagefor openSUSE is provided here [ http://www.sourceforge.net/projects/qfsm]. RPM pack-
ages for other Linux distributions might be provided on other websites.

Mac OS X

Binary packages for Mac OS X may be provided by third-party websites, for example here [http://
mac.softpedia.com/get/M ath-Scientific/Qf ms.shtml].

Installing from source code

Qfsm has to be compiled using the CMake buildsystem. Among the advantages of CMake are that it pro-
vides excellent cross-platform support, that it can create project files for various IDEs such as KDevelop,
XCode and MS Visual Studio and that it builds out-of-source, keeping the source tree clean of temporary
files.

Requirements
« CMake [http://www.cmake.org], version 2.6 or higher
* Qt SDK [http://gt.nokia.com], version 4.4.3 or higher

See the documentation of these tool/libraries for an explanation how to install them.

Supported Platforms
In principal, Qfsm compiles and runs on any platform supported by the Qt library version 4.4 (or higher),
i.e. Linux/Unix (e.g. AlX, FreeBSD, HP-UX, IRIX, Solaris), Windows (98, NT 4.0, ME, 2000, XP and
Vista) and Mac OS X (version 10.3.9 and higher).

Building under GNU Linux/Unix

1. Unpack the source code into the current directory
tar xvfz gfsm-0.52.0-Sour ce.tar.gz --directory .
and change to that directory.

2. Beforeinvoking CMake you have to make sure that the program gmake isin your global PATH envi-
ronment variable. The location of gmake depends on your operating system or Linux distribution. On
openSUSE for exampleitisunder: /usr/lib/gt4/bin/ Thus, if you are using bash, you would have to type:
export PATH=/usr/lib/qt4/bin:$PATH

3. Type:
cmake.

4. Then:
make

5. Finally, install Qfsm (as root):
makeinstall

Thiswill install the executable "gfsm" to /usr/bin/ and the documentation to /usr/share/doc/qgfsmy/.

If CMake failsto find any of the dependencies but you know you have the development headers/libraries
installed, add -DLIBRARY_SEARCH_DIRS=<path/to/lib> and -DINCLUDE_SEARCH_DIRS=<path/
to/include> to the cmake command.
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If youwant to createaproject filefor your IDE (e.g. KDevelop), add -GK Devel op3 to the cmake command
above. Thiswill create a.kdevelop file in the build directory which can be opened by KDevelop.

Building under Windows

In order to build Qfsm under Windows you have to execute the program CMakeSetup, specify input
(source) and output directory and click on "Configure”. Y ou may choose between different development
environments (e.g. Visual Studio) and CMakewill create the respective project files. Y ou can then compile
Qfsm as usual with your preferred build tool. For more details, refer to the CMake documentation: http:/
www.cmake.org/HTML/Documentation.html.




Chapter 2. Using Qfsm

Using the main menu

This section briefly explains the functions available through the main menu.

File

Edit

To create anew file:

select “New”. For more details, see the section
called “Creating and modifying a Finite State Ma-
chine”

To open an existing Qfsm file: select “Open”.

To open the most recently opened Qfsm files: select “Open Recent”.
To save the current FSM to a Qfsm file: select “ Save’.

To save the current FSM under adifferent name: | select “Save As'.

To export the current FSM to aforeign file format:

select “Export”. For more details, see the section
called “Exporting”

To print the current FSM:

select “Print”.

To open anew window with aseparate working area
where adifferent FSM can be edited:

select “New Window”. Note that you can copy, cut
and paste states and transitions from/to different
FSMs.

To close the current FSM: select “Close”.
To quit Qfsm: select “Quit”.
To undo the last action: select “Undo”.

To cut the currently selected states and transitions
to the clipboard:

select “Cut”.

To copy the currently selected states and transitions
to the clipboard:

select “Copy”.

To paste the clipboard into the current FSM:

select “ Paste”.

To delete the currently selected states and transi-
tions:

select “Delete”.

To switch to the select mode:

select “Select”. For more details, see the section
called “Using the Select mode”

To select all states and transitions of the current
FSM:

select “Select All”.

To deselect al objects:

select “Deselect All”.

To open the options dialog:

select “Options’. For more details, see the section
called “ Setting the options’
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View

To show/hide the state codes inside the states:

select “ State Codes’. Each state has a unique iden-
tifier, called state code, which is an integer that is
automatically determined by Qfsm.

To show/hide the Moore outputs inside the states:

select “Moore Outputs’. Each state defines its
Moore outputs which are the values that are sent to
the outputs of the FSM when the respective state is
reached.

To show/hide the Mealy input conditions on the
transitions:

select “Mealy Inputs’. Mealy inputs are asynchro-
nousinputsto the FSM. They can trigger transitions
from one state to another if the condition of the re-
spective transition is satisfied.

To show/hide the Mealy outputs on the transitions:

select “Mealy Outputs’. Mealy outputs are outputs
of the FSM that were sent when atransition is trig-
gered. Thus, each transition can define the Moore
outputs that are sent when it is triggered.

To show/hide the shadows of the states:

select “ Shadows”.

To show/hide the grid on the working area:

select “Grid”.

To show/hide the window displaying the names of
the inputs and outputs of afinite state machine:

select “1O View”.

To switch to the pan mode:

select “Pan View”. For more details, see the section
called “Using the Pan mode”

To switch to the zoom mode:

select “Zoom”. For more details, see the section
called “Using the Zoom mode’

To zoom the view in:

select “zoom in”. The current zoom value is shown
in the leftmost part of the status bar.

To zoom the view out:

select “zoom out” . The current zoom valueis shown
in the leftmost part of the status bar.

To set the zoom to the original value (100%):

select “Zoom 100%". The current zoom value is
shown in the leftmost part of the status bar.

Machine

To modify the properties of the current FSM:

select “Edit”. It opens a dialog in which you can
maodify the properties of the FSM. For more details,
see the section called “ Creating and modifying aFi-
nite State Machine”

To correct automatically the codes (or identifiers) of
all states such that each state code is unique:

select “ Auto correct State Codes’

To switch to the simulation mode:

select “Simulate”. For more details, see the sec-
tion called “Using the Simulate mode” andthe sec-
tion called “ Simulating a FSM”

To perform an integrity check on the current FSM:

select “Integrity Check”. For more details, see the
section called “ Checking the integrity of a FSM”
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To switch to the "add state" mode and create a new
state:

select “New”. For more details, see the section
called “Using the Add State mode” and the section
called “ Adding and modifying states’

To modify the properties of the currently selected
state:

select “Edit”. It opens a dialog in which you can
modify the properties of the state. For more de-
tails, see the section called “Adding and modifying
states’

To define the currently selected state as the initial
state of the FSM:

select “Set Initial State”.

To define the currently selected state as a final or
non-fina state:

select “Toggle Fina State”.

Transition

To switch to the "add transition” mode and create a
new transition:

select “New”. For more details, see the section
called “Using the Add Transition mode” and the
section called “ Adding and modifying transitions”

To modify the properties of the currently selected
transition:

select “Edit”. It opens a dialog in which you can
modify the properties of the transition. For more de-
tails, see the section called “ Adding and modifying
transitions”

To straighten the currently selected transition:

select “ Straighten”.

Creating and modifying a Finite State Machine

To createanew Finite State Machine (FSM), choosethe menuitem File->New . The"Machineproperties’
dialog opens and lets you specify the properties of the FSM. Here is an explanation of each item of the

dialog.
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Y%= Machine Properties

EIEIRFY

Mame: [I'u'lv Machine

\ersion: [1.0

~ Type

@ Binary O ASCII

() Free Text

~Moore

Outputs: Names: [s_outt, s_outo ]

—Mealy

Inputs: E Mames: [i

Outputs: Names: [0_1,0_0 ]

State Font Helvetica

Transition Font | | Helvetica

Arrow Type:

M%I&

[%| Draw initial transition

(o< [ e

Table 2.1. Attributes of a Finite State Machine

Name

Enter a name for the FSM. The name is used for
example when exporting to the following formats:
VHDL, Verilog HDL or Ragel.

Version

Y ou can enter the version of the FSM. Thisisafree
character string that is only used when printing the
diagram.

Type

Select the type. The type attribute determines which
typeof information is processed by the FSM, i.e. the
inputs, the outputs etc. Binary FSMs process zeros
and ones at the inputs or outputs. This is the main
type used for hardware design.

ASCII FSMs process characters (i.e. letters, digits
etc.). These characters are coded in ASCII format
using 8 bits. Thistype of FSM can be used either for
hardware design or to create string parsers.

The "Free Text" type alows to specify inputs and
outputs using any kind of character string of vari-
able length. This type of FSM cannot be simulated
afterwards because theinput conditionswon't be in-
terpreted.
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Moore outputs and Mealy inputs/outputs

If you are creating a "binary” FSM you can specify
the number of bits of the moore output and mealy
input/output and their respective names. The names
arelistsof character strings separated by commas. If
you do not want to choose the names you can leave
thesefields blank and they will be automatically set.

Fonts Y ou can specify the font to use for the state names
and for the input conditions and outputs displayed
on the transitions.

Arrow Type Y ou can choose the type of arrow to usefor drawing

transitions.

Draw initial transition

You can tick or not this option if you want to draw
or not theinitia transition or if you want to reset or
start the transition.

When you want to modify the properties of an existing FSM you can select Machine->Edit from the main
menu and the same dialog box displays. As soon as you click OK the changes take effect.

Using the Working Area

The working area denotes the area of the Qfsm window that shows the state diagram. Once you have
created anew FSM you see a blank working area and you arein the selectmode.

File Edit View Machine State Transition Help
DEFESG~ 2B N +Qe S AQ
select mode
& working
drea
58% 0 X: 452.7 ¥: 119.2 ﬂ

There are six different modes you can be in and whi
the mouse inside the working area of Qfsm.

1. Select

2. Pan

3. Zoom

4. Add State

5. Add Transition

ch determine what happens when you click or drag
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6. Simulate

Only one mode can be activated at a time. To change the mode, click on one of the icons in the middle
of the toolbar.

When a diagram is larger the working area, you have the possibility to move the view of a diagram. To
move the view of a diagram, click on the middle mouse button and drag the mouse pointer. As soon as
you rel ease the middle mouse button the application reverts to the selected mode.

ANt Qe N ®

Alternatively, you can select the respective menu entry or press the respective short cut. The active mode
isindicated by a highlighted toolbar button. In some modes, the form of the mouse cursor also changes,
e.g. amagnifier for the zoom mode.

Using the Select mode

In this mode you can select, move or modify graphical objects.
To select a state or atransition, click on it with the left mouse button.

To select several states or transitions at the same time, hold down the shift key. You can then apply
further actions on selected graphical objects, i.e. copy or edit, by using the menu.

To unselect all the selected graphical objects, click on the background.

To show the context menu for a state or a transition, click with the right mouse button on the state
or transition.

To modify the properties of a state or a transition, double-click on the state or transition. It opens a
dialog in which you can modify the properties.

To select multiple graphical objects, draw arectangle holding the left mouse button around the graphical
objects you want to select.

To move state or transitions, select them and drag them to the desired position.

To move the transition control points, select the respective transition and then drag one of the control
points. The transition control points are indicated by small red and green points when atransition is se-
lected. The red points control the form of the transition, i.e. the bend. The green ones are used to attach
them to a starting and end state.

Using the Pan mode
+

In this mode, you can move the view to adifferent part of your diagram when your diagram islarger than
the working area of the window.

To move the view, drag the mouse pointer.

Using the Zoom mode
Q
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In this mode you can zoom in the view.
To zoom in the view, click with the left mouse button on the working area.
To zoom out, keep the CTRL key pressed at the same time you click.

Using the Add State mode

+

In this mode you can add states and specify their properties.

To create a new state, click with the left mouse button and fill the dialog with the properties. For more
details, see the section called “ Adding and modifying states”

Using the Add Transition mode
N
In this mode you can add transitions and specify their properties.
To add atransition:
1) click on a state and drag the mouse pointer to another state.
2) fill the dialog with the properties of the transition.

For more details, see the section called “ Adding and modifying transitions’

Using the Simulate mode
§®
In the simulate mode, you can test the behaviour of your state machine with respect to external input.

When you enter this state, the simulator dialog opens and al interaction with the state diagram is disabled
until you close the dialog. For more details, see the section called “ Simulating a FSM”

Adding and modifying states

To create a state:

1) first you need to:

- create anew FSM or;
- open an existing file.

To create anew FSM, select File->New (see the section called “Creating and modifying a Finite State
Machine”)

To open an existing file, select File->Open

10
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and choose the desired file.

2) Switch to the "add state" mode (see the section called “Using the Add State mode”).

3) Click at the position of the working area where you want the new state to be.

The following dialog opens.

To specify or modify the properties of the state, fill the " State properties” dialog:

“""State Properties -©

)

Name: |state_2

Code: 0010
Moore Cutputs: 0010
Radius: 40
Line width: 1
Color
Description:

This is the waiting state

Cancel

Table 2.2. Attributes of a state

Name Enter a name for the state.

Code Normally you do not need to fill thisfield. Thisisa
unique identifier of the state you create, it is filled
automatically.

Moore Outputs Enter the outputs sent by the FSM. In"binary" FSMs
this is a string of zeros and ones and in "ASCII"
FSMsthisisjust one character.

Radius Enter the radius of the drawn circle of the state, in
pixels.

Linewidth Enter the line width of the outline of the state.

Colour If you want to change the colour of the outline of the
state, click on the“Colour” button.

Description Y ou can enter adescription of the state. Thisisonly
for documentation purposes.

To modify an existing state:

1) switch to the "select mode" (see the section called “ Using the Select mode”).

2) double-click on the respective state

11
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Or

2) select one state and select Sate->Edit from the main menu.

Adding and modifying transitions

To create anew transition:
1) you need first to:

- create a FSM or

- open an existing file.

To create a FSM, select File->New (see the section called “ Creating and modifying a Finite State Ma-
chine”)

To open an existing file, select File->Open from the main menu and choose the desired file.
2) create at least one state (see the section called “ Adding and modifying states”).
3) switch to the "add transition" mode (see the section called “ Using the Add Transition mode”).

To create atransition from state A to state B, press and hold the left mouse button on state A and release
it on state B.

To draw loops, i.e. transitions that go from one state to itself, press and release the mouse button on the
same state.

The "Transition properties* dialog opens.To specify or modify the properties of the state, fill the dialog.

o Transition Properties <

Condition Type
[ Binary & ASCI

Input: | d
Any input
Invert condition

Default transition

Qutput: |\n

Description:

This transition is activated when the
character 'd' is pressed

[ oK | cancel

Table 2.3. Attributes of a transition

Condition Type Choose the type of the condition. The type of the
condition determines the format in which you enter
theinput condition in the next field.

12
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Input If the condition typeisbinary, enter astring of zeros
and ones representing the Mealy input that should
trigger thistransition. Y ou can also use the character
‘X' meaning: "don't care". Y ou can also specify sev-
eral aternative sets of inputs linked with "|" (OR).

If the condition type is ASCII enter a character or
specify an expression in a specific format which is
explainedin detail in the section called “ Using input
ASCII conditions’.

For "free text" conditions enter any input character
string. However, it hasno logical meaning and won't
beinterpreted, for examplewhen simulating the ma-
chine.

Output Enter the Mealy output sent from the FSM when the
transition is activated, i.e. the input condition is sat-
isfied. Depending on the type of the condition the
format is either a string of zeros and ones (binary) a
character (ASCII) or any character string (freetext).
Notethat in case of an ASCII character it can also be
an escape sequence. For more details on escape se-
guences, see the section called “ Using input ASCII
conditions’

Description Y ou can enter adescription of thetransition. Thisis
only for documentation purposes.

To modify the properties of an existing transition:

1) switch to the "select mode" (see the section called “ Using the Select mode”).
2) double-click on the respective transition

Or

2) select one transition and selectTransition->Editfrom the main menu.

To change the bend of the transition as well asits start state and end state:

1) switch to the “ Select mode”

2) click on the transition.

Four control points appear. Y ou can drag them around with the left mouse button.

The green ones allow you to change the start and end state. With the red ones you can change the bend
of the transition.

Using input ASCII conditions

When you create atransition of FSM that processes ASCII charactersyou haveto enter an input condition.
This condition can be a simple character, e.g. 'a’, or several characters that are expressed by a special
notation explained in the following.

13
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Single character

Thisisthe most simple form of condition. It contains one ASCII character, e.g.'a' or 'z".

Note that for special characters, e.g. '-' (minus sign) or the space character you need to use an escape
seguence (see the section called “ Escape sequences”).

Multiple characters

If you want the condition to contain multiple characters, i.e. 'a’ or 'f ' or '+' you just enter the string: 'af
+'.Clearly, the order is not important.

Note that it isnotpossible to use a concatenation of characters as input condition, for example'pri nt 'in
order to recognize theword "print". To do this, you haveto create atransition and a state for each character

and build a chain with the respective characters.

Escape sequences

Specia characters like the newline character need to be escaped, i.e. backslash + some character. The
following table shows the recognized escape sequences.

Table 2.4. Recognized escape sequences

escape sequence meaning

\t tab

\n newline

\r carriage return
\'s space

\ - minus

\d digit (0-9)

Note that the last escape sequence '\ d' actually represents 10 characters.

Characters that are neither printable nor in the above table can be specified by "\ 0' (backslash zero) fol-
lowed by their hexadecimal code. For example, "\ 0CF' would represent the ASCII character 207 (decimal).

Ranges

Y ou can further specify ranges by using the minus sign. Thus, 'a- z' means one of the characters between
'a'and 'z’ (including). Any character, even escaped ones, can be used as start or end point of arange.

Mixed formats

Y ou can combine several conditions, each of them in one of the above mentioned notations, into onelong
condition by just concatenating them. Note that you must not separate them by any character, like white
space or comma.

Here are some examples:

14
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« AFO-9

+ +\-\d

\n\r\t XYz

xyz0- 3\ 010A-Z

Checking the integrity of a FSM

To check the integrity of a FSM, select Machine->Integrity Check from the main menu.

Warning
This may take along time for larger FSMs, be careful not to interrupt the procedure.

The following tests are performed:

Unambigous Conditions Checks if the FSM has transitions with conditions
that are ambiguous, i.e. transitions that are activat-
ed simultaniously by the same input (in the same
state). Note that ambiguous transitions are only al-
lowed innon-deter ministicFSMs, which are current-

ly not supported by Qfsm.

Initial state Checksif the FSM has an initial state.

Final state Checksif the FSM has afina state.

No dead locks Checksif the FSM has stateswhereit can get of out,
i.e. states with no transitions going out.

Completeness Checks if for every possible input in every state
there exists atransition that is activated.

States reachable Checksif al the states of the FSM are reachable.

Final statesreachable Checksiif dl the final states of the FSM are reach-
able.

Transitions connected Checksif al the transitions of the diagram are actu-

ally connected to a start end an end state. Note that
sometimesatransition looksasif itisconnectedto a
state but in fact the connection point isslightly away
fromiit.

A log of the checksthat have been performed is printed in the protocol field at the bottom of the window.

Simulating a FSM

Once you have created a FSM with some states and transitions you can simulate its behaviour with respect
to varying input signals.

To start the simulation of an FSM, select Machine-> Smulate from the main menu.

The "simulator" dialog opens allowing you to input data to the machine while displaying its current state
and output.

15
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Y%= Qfsm - ascil_example.fsm —_|o] [x
File Edit View Machine State Transiton Help

Dewd&S&~4BR »+Qa @ Qq s

e/

Reset -4 tov,k

Simulator =]

~Inputs
i |
() Binary () Hexadecimal @ ASCII
[ J(el(s)(e o) e
wofc/a 2-2/%n
—Outputs
[\r
() Binary ) Hexadecimal @ ASCI

State Name: |State_2
State Code: |2

Clock Fregquency: [1.0
[ ese || carce |

100% 0 X: 329.0 ¥: 54.0

Input 1) Enter the input datain the text field

2) select one of the formats: binary, hexadecimal or
ASCII.

3) you can set or unset input bits using the buttons
Oto 15.

When you choosethe ASCII format you can also use
escape sequences as detailed in the section called
“Escape sequences’. However, you can only enter a
single character. Thus,' \ d' or ranges, for example,
are not allowed.

Output Choose the format of the current FSM, i.e. binary,
hexadecimal or ASCII.
Sate Name and Sate Codefields display the current state of the FSM. The red or

green point next to it indicates if the FSM isin afi-
nal state or not, i.e. green for final state and red oth-
erwise.

16



Using Qfsm

There are two modes to send input data:

- click on the Send button or, pressthe Enter key)

- click on the Clock button.

The FSM periodically sends the data in the input text field on the top of the dialog.
Y ou can specify the frequency of the clock in the input field at the bottom right.
To exit the Clock Mode, click once again on the Clock button.

To reset the FSM, click on the Reset Button.

This setsthe FSM to itsinitial state.

Exporting
There are several export functionsin Qfsm.
To export, select File->Export in the main menu.
They can be divided into the following categories:
1. state diagrams,
2. hardware description languages,
3. state tables,
4. code generation languages,
5. hardware test code,
6. 1/0O description,
7. vvwv Automata code
8. State Chart XML (SCXML)
Here are some explanations about the different export functions:

State diagrams

A state diagram asit is seen in the working area can be exported in various graphics formats. The formats
that are supported are:

 Encapsulated Postscript (EPS)
» Scaable Vector Graphics (SVG)
* Portable Network Graphics (PNG)

Hardware description languages

Hardware description languages are high level descriptionsthat can be synthesized into integrated circuits
like FPGAs using special software. The languages supported are the following:

1. AHDL
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2. VHDL
3. Verilog HDL
4. KISS

Some of the export functions open a dialog allowing you to specify additional export options. However,
they should be self-contained for the users having experience with hardware description languages.

State Tables

Code

State tables can be exported in the formats; ASCII (plain text), Latex or HTML. State tables show for each
possible state and input (here calledevent) the respective resulting states.

To change the options concerning the layout of the state table, adialog alows you to change some options.

Include asynchronous output Tick this option if you want the asynchronous out-
puts (Mealy outputs) to be printed in the table cells
together with the resulting states.

Resolve inverted conditions Tick this option if you want the inverted condi-
tions to be printed using the inversion descriptor,
e.g.' NOT a',orwithoutit,i.e. printing every char-
acter (or binary string) except the onesin the condi-
tion.

In the case of' NOT a' this would be the two
ranges \ 000- "' and' b-\ OFF' .

Which one is clearest depends on the respective
FSM.

Orientation Tick the different options in order to determine the
orientation of the table, i.e. if current states repre-
sent the different rows of the table and the eventsthe
columns or vice-versa.

generation languages

For this type of output there is only one option, namely the ragel file format, and only ASCIlI FSMs
can be exported. The resulting file serves as an input for the ragel state machine compiler. The ragel
state machine compiler is acompiler that generates code from a high-level state machine description lan-
guage. In this way, you can create parsers for example. For details refer to the ragel homepage [http://
WWW. CS.queensu.cal~thurston/ragel/].

A dialog allows you to create a so-called action file. That means, the ragel state machine specification
is divided into two files. One that contains the state machine logic (which | will call FSM file here) and
an action file that contains the action definitions and a framework calling the state machine. Thus, the
action file actualy includes the FSM file. The name of the action file is determined automatically by
appending' _acti on' at theend of the file name.

Example: suppose you have created an ASCIl FSM and you export it under thename nyFSM r | . If you
check theoption 'Createactionfile' theactionfilewill be created under the nameny FSM acti ons. rl .

Using ragel you can compile the action file: ragel -C -o myFSM.c myFSM _actionsirl
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This will create a file, called myFSM.c with the C code of the FSM. It will contain a function:i nt

par se(char* string) that parsesaninput string and returns 1 if the FSM acceptsit, i.e. finishesin
afina state, and O otherwise.

Hardware test code

The hardware test code is used together with the output of a hardware description export. The supported
language for test code is VHDL. The VHDL testbench export will create a set of files that enables a
hardware simulation and debugging software to analyse the VHDL code exported by Qfsm.

The following files are generated:

t fsmname.vhd The VHDL testbench instantiating the FSM mod-
ule, aclock generation process, an initial reset and
astimuli_observer process.

p_fsmname.vhd A VHDL package declaration and body with all the
necessary subprograms used in the testbench.

fsmname_stimuli.vec Thefileincludesall the stimuli and expected results
necessary for acomplete verification of afinite state
machine.

fsmname_result.log Errors are documented in thisfile.

Per default, these files can be written to different directories within a clearly structured design directory.
Therefore, in the export options a'Base Directory' input string is asked, first:

Base_directory

|

+-src

| f stmane. f sm
e_fsmmane. vhd
a_fsmmane_architecturenane. vhd
t _fsmmane. vhd
p_f smane. vhd

|

|

|

|

|
+-stinuli
| fsmmane_stimuli.vec
|

+-

| og
fsmane_result. | og

I/O description

When exporting the I/O description of the state diagram a file containing the names of all the inputs and
outputs of the FSM is created. The description is stored in a comma separated value (CSV) format, where
the separator isasemicolon and the values are inside double quotes. Thefirst value of each lineisatextual
description of the valuesin that line, i.e. "Inputs’, "Mealy Outputs' and so on.

The following lines are written:

 "Inputs': the names of the (Mealy) inputs
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e "Mealy Outputs": the names of the Mealy outputs
» "State/Output”: the names of the Moore outputs

» Finally alinefor each state containing its name and its M oore outputs

vvvv Automata code

A "freetext" FSM can be exported to vvvv Automata code. This code can be used in conjunction with the
tool vvvv [http://vvvv.org/tiki-index.php], atoolkit for real-time video synthesis. Thistextual format is a
list of quadrupels, where each item/line describes a transition and is composed of:

» dtart state,
* event,
* end state,
 action.

When selecting this export function from the menu a non-modal dialog box is opened that displays the
resulting code. Thisisautomatically updated as the diagram is modified. An additional reset transition can
optionally be added for each state by checking the box at the bottom of the dialog. There you can aso
specify the name of the reset event and the name of the respective action to be triggered.

State Chart XML

A "free text" FSM can be exported in the State Chart XML format as proposed by the W3C. The speci-
fication of SCXML can be found here [http://www.w3.org/TR/scxml/]. Note that each transition is trig-
gered by an event. And the text that is entered as transition input is used as the name of the event. The
text that is entered as the transition output is interpreted as the name of an event that is to be sent when
the transition is triggered. Thus, if the output linked to a transition is non-empty a corresponding <send>
tag will be written.

Importing

Qfsm can import fileswritten in the DOT language [ http://www.graphviz.org/content/dot-language] using
Graphviz [http://www.graphviz.org].

To import aDOT file (with extension .gv), select File->Import->Graphviz... in the main menu.

Qfsm uses Graphviz to transform the textual description of the FSM into a graphical layout of the state
diagram.

When writing a DOT file make sure you respect the following syntax rules:
« thetype of the diagram needs to be a directed graph (digraph),
* therankdir must be"LR" (left-right) or "TB" (top-bottom).

Here is an example of a dot file describing a binary FSM. The file is included in the Qfsm package in
the examples folder.

di graph binary_finite_state _machi ne {
rankdi r =LR;
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size="8, 5"

node [shape
node [shape
LR O [ | abel
LRO ->LR 1

doubl ecircle]; LR O LR 3;
circle];

"State_ 1" mpore = "01"];

| abel "0000| 0001###11" 1;

LR1 ->LR2 | abel "NOT 0000###00" 1];
" DEF###01" ],
LRO ->LR2 | abel " ANY#H##10" ],

[
[
LR 1 -> LR 3 [ |abel
[
[

LR2 ->LR3 | abel "1111###11" ],

Qfsm automatically determines the type of FSM: binary, ASCII, or Free Text. In the above example,
"LR_0","LR_1", ... denotethe states. It can be given any name by specifying thel abel attribute. If you
don't do this, the node name (here: "LR_1", ...) is used as the state name. The noor e attribute is used
to specify the Moore outputs of a state.

Transitions are written as

Statel -> State2;

or

Statel -> State2 [ |abel = "00###11" ];

wherethel abel attribute specifiesthe Mealy inputs, and optionally the Moore outputs separated by the
string ###. NOT denotes negation, DEF a default transition, and ANY transitions that accept any input.

To define end states, use the shape = doubl eci rcl e node attribute as illustrated in the above
example.

Setting the options

To display the options dialog select Edit->Options from the main menu.
Changing language

To change the language:
1) select Edit>Options>General

2) select the language
3) click on OK
4) restart the application

The language change is now effective.
Changing the display

To change the display, select Edit>Options>Display from the main menu

Grid Y ou can choose the colour and size of the grid dis-
played on the working area. You can activate the
grid viathe main menu entry View->Grid .
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Shadows Y ou can determine if shadows are to be drawn and
the their colour.

Transitions Y ou can determine the appearance of input condi-
tions and outputs drawn on top of the transitions.

Tooltips You can determine if tooltips should be shown or

not when moving the mouse pointer over a state or
atransition.

Initial transition descriptor

Enter thetext that isdisplayed next totheinitia tran-
sition. Default: "Reset".

Inversion descriptor

Enter the text that is displayed before inverted tran-
sition conditions. Default: "NOT".

"Any input" descriptor

Enter the text that is displayed for transitions that
are activated by any input. Default: "any".

Default transition descriptor

Enter the text that is displayed for default transi-

tions. Default: "default”.

Printing

To change the printing options, select Edit>Options>Printing from the main menu.

Print header

Tick this option if you want to print a header with

the FSM name and version at the top of the diagram.
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Chapter 3. Contact

If you have questions or suggestions concerning Qfsm feel free to contact me at:
<qf sn( at) duf f ner (dash) net (dot ) de>

I'm also glad about any contribution you want to make to the project, e.g. code, bug fixes, documentation,
packaging, testing etc.
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