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Welcome 

Welcome to the Microsoft® Windows ™ operating system, the software that trans­
forms the way you use your personal computer. The ability to run more than one 
application at a time with Windows and transfer information between applications, 
the superior way Windows uses the full power of your computer, and the rich 
Windows graphical interface provide a more intuitive, more efficient work 
environment for your personal computer. 

This introductory section of the Microsoft Windows User's Guide provides a 
guide to the documentation-so you know where to find information about work­
ing with Windows. This section also defines typographic conventions used in the 
Windows documentation. 

If You Have a Previous Version of Windows 
Updates are available for some of the Windows applications you may have used 
with previous versions of Windows. The updated versions take full advantage of 
the new features and power of Windows version 3.1. 

If you have not received information about updates for your Windows applica­
tions, check with the manufacturers. Most applications developed for versions 
of Windows earlier than 3.0 do not run correctly with Windows version 3.1. 

About Your Windows Documentation 
The Windows version 3.1 documentation set consists of the Getting Started 
with Microsoft Windows book, this book, an online Tutorial, an extensive online 
Help system, and several online documents (formatted for use with Windows 
Write) that are copied to your hard disk when you set up Windows. The following 
pages outline the contents of the Microsoft Windows User's Guide and define 
terminology that is important to your understanding of Windows. 
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The way you like to learn and how much you already know about Windows and 
about computers will determine how you use the different pieces of the documen­
tation. 

• Getting Started with Microsoft Windows is a guide to setting up Windows 
on your system, and a brief visual introduction to Windows. The book also 
includes a "Troubleshooting" chapter that deals with situations you might 
encounter while setting up or running Windows. 

• The Microsoft Windows User's Guide provides a comprehensive description 
of Windows and the ways you can work with it. It includes explanations and 
procedures for first-time users, in addition to topics for advanced users. 

• The Microsoft Windows Tutorial provides online instructions for using a 
mouse and for performing some basic Windows tasks. To use the Tutorial, 
you need a mouse and a VGA (or better) monitor. 

• Help provides a quick online reference to procedures and commands you need ' 
when using Windows. Context-sensitive help is now available in the main 
Windows applications-to obtain specific information about how to complete 
a dialog box, just press FI or choose the Help button while using the dialog box. 

• Several online documents are copied to your hard disk when you set up 
Windows. You can read (and print) the files by using Write. These files include: 

• SETUP. TXT-Information specific to setting up Windows. Contains 
information about software or hardware configurations that require special 
handling to successfully set up and start Windows. (This file can be viewed 
by using any text editor.) 

• README.WRI-Information updated after the user's guide was printed. 

• PRINTERS.WRI-Information about configuring particular printers and 
fonts for the Windows environment. 

• NETWORKS.WRI-Information about operating Windows with specific 
network configurations. 

• SYSINI.WRI-Procedures for modifying settings in the SYSTEM.INI file 
(for advanced users only). 

• WININI.WRI-Procedures for modifying settings in the WIN.INI file 
(for advanced users only). 
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What's Included in Your Windows User's Guide 
You'll probably find yourself using some Windows applications, such as Program 
Manager, more often than others, such as PIF Editor. The Microsoft Windows 
User's Guide is organized with this in mind. Those features you are likely to use 
most often are described in the early chapters; those you'll probably use less 
frequently appear later. 

To use the procedures in this guide, you must have Windows set up on your 
system. For setup information, see Chapter 1, "Setting Up Windows," in 
Getting Started with Microsoft Windows. 

U sing a mouse is the easiest way to work with Windows. If you have not used 
a mouse before, it is recommended that you run the online Windows Tutorial to 
learn basic mouse techniques. For information about starting this program, see 
"Running the Microsoft Windows Tutorial" in Chapter 2, "Application Basics." 

This book is divided into the following parts: 

Part 1, "Windows Fundamentals"-Chapters in this part explain the basic struc­
ture of Windows and the skills you need to work with Windows. One chapter 
describes how to run non-Windows applications with Windows. Other chapters 
show you how to use the important system-management applications you received 
with Windows. These applications are: 

• Program Manager, which helps you organize your applications. 

• File Manager, which helps you organize and manage the files and directories 
on your disks. 

• Control Panel, which you use to change Windows settings such as screen colors 
and fonts; set up printers, multimedia hardware, and modems; and change the 
appearance of your desktop. 

• Print Manager, which schedules and fills all print requests you send from 
Windows and non-Windows applications. 

• PIF Editor, which you use to create or change program information files (PIFs) 
for non-Windows applications. 

• Task List, which you use at any time to switch quickly between applications on 
your desktop. 

• The Clipboard, which you use to move and copy information from one window 
to another, across applications. 
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Part 2, "Windows Accessories"-Chapters in this part describe the accessory 
applications that are included with the Windows package. You received three 
full-featured accessory applications: 

• Write, a word processor 

• Windows Paintbrush TM, a color painting and drawing application 

• Terminal, a communications application 

You also received two new multimedia applications, Media Player and Sound 
Recorder, in addition to several applications that add convenient capabilities to 
your Windows desktop, including Calculator, Calendar, Cardfile, Character Map, 
Clock, Notepad, Object Packager, and Recorder. 

Part 3, "Getting the Most Out of Windows"-This part contains three chapters of 
information for advanced users. It explains how to integrate information in your 
Windows applications, how to modify Windows to run most efficiently with your 
computer and the applications you want to use, and how to reconfigure Windows 
by using the Setup program. 

Appendixes-The appendixes provide reference material on the following topics: 

• Instructions for using Windows with a network 

• Specifications for terminal emulations 

• Keyboard shortcuts for performing various Windows tasks 

The Microsoft Windows User's Guide also includes a glossary and a compre­
hensive index. 
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To help you locate and interpret information easily, the Microsoft Windows 
User's Guide uses consistent visual cues and a few standard text formats. These 
conventions are explained as follows. 

Visual Cues 
You will find the following typographic conventions throughout this guide. 

This 

bold 

italic 

Represents 

Anything that you must type exactly as it appears. For example, 
if you are asked to type dir \windows, you would type all the 
bold characters exactly as they are printed. 

Placeholders for information you must provide. For example, if 
you are asked to typejilename, you would type the actual name 
for a file instead of the word shown in italic type. 

Italic type also signals a new term. An explanation immediately 
follows the italicized term. 

ALL CAPITALS Directory names, filenames, and acronyms. 

Information that is specific to running Windows in 386 enhanced 
mode. 

Keyboard Formats 
Key combinations and key sequences appear in the following formats. 

Format 

KEYl+KEY2 

KEYl, KEY2 

Meaning 

A plus sign (+) between key names means to press and hold down the 
first key while you press the second key. For example, "press ALT +ESC" 
means to press and hold down the ALT key and press the ESC key. Then 
release both keys. 

A comma (,) between key names means to press and release the keys 
one after the other. For example, "press ALT, F" means to press and 
release the ALT key, and then press and release the F key. 
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Microsoft Product Support Services 
Microsoft offers a variety of support options to help you get the most from your 
Microsoft product. This section summarizes these options. 

If you have a question about your Microsoft product, first look in the printed 
product documentation or consult Help. If you cannot find the answer, contact 
Microsoft Product Support. 

Outside the United States, contact Microsoft Product Support at the Microsoft 
subsidiary office that serves your area. For information about Microsoft subsidiary 
offices, see the following section, "Product Support Worldwide." For information 
about additional support options, you can refer to a card enclosed in your 
Microsoft Windows package. 

Getting Product Support in the United States 
The following means of support are available in the United States. These services 
are provided using the English language. 

• Call the Interactive Voice Support Service 

You can hear recorded responses to common Microsoft Windows questions, 
and order application notes by fax. This automated service is always available 
and requires a touch-tone telephone. For assistance with Microsoft Windows, 
dial (206) 635-7245. 

You can use the following keys on your touch-tone telephone after you reach 
the Interactive Voice Support Service: 

• To advance to the next message, press *. 

• To repeat the current message, press 7. 

• To return to the beginning of the Interactive Voice Support Service, press #. 

• Call Microsoft Product Support Staff 

Call (206) 637-7098 Monday through Friday, between 6:00 A.M. and 6:00 P.M. 

Pacific time. 

When you call, you should be at your computer and have the Microsoft 
Windows documentation at hand. Be prepared to give the following infor­
mation: 

• Your product's serial number. Your serial number label is on the inside 
back cover of Getting Started with Microsoft Windows. 

• The version numbers of Windows and MS-DOS that you are using. 

• The type of hardware you are using. 
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• The exact wording of any messages that appeared on your screen. 

• What happened and what you were doing when the problem occurred. 

• How you tried to solve the problem. 

Microsoft's support services are subject to Microsoft's prices, terms, and 
conditions in place at the time the service is used. 

Product Support Worldwide 
Microsoft provides product support services throughout the world. To receive pro­
duct support or for information about how to receive product support, contact the 
Microsoft subsidiary office that serves your country. Microsoft subsidiary offices 
and the countries they serve are listed in the following table. 

For this country Contact this office Using this number 

Australia Australia (02) 870-2l31 

Austria Austria 0660/65-10 

Argentina Argentina (54-1) 814-0356 

Baltic republics Germany (0049) 089/3176-1110 

Belgium Belgium 02-5l33274 (Dutch) 
02-5023432 (English) 
02-5l32268 (French) 

Bermuda Venezuela 0058.2.914739 

Bolivia Argentina (54-1) 814-0356 

Brazil Brazil 011-533-2922 

Canada Canada 1 (416) 568-3503 

Caribbean countries Venezuela 0058.2.914739 

Central America Venezuela 0058.2.914739 

Chile Argentina (54-1) 814-0356 

Colombia Venezuela 0058.2.914739 

Commonwealth of Germany (0049) 089/3176-1110 
Independent States 

Denmark Sweden (46) (8) 752 6850 (applications) 
(46) (8) 752 60 50 (systems) 

Eastern Europe Germany (0049) 089/3176-1110 

Ecuador Venezuela 0058.2.914739 

England United Kingdom (734) 271000 

Finland Sweden (46) (8) 752 6850 (applications) 
(46) (8) 752 60 50 (systems) 

France France (33) (1) 69-86-10-20 

French Polynesia France (33)(1)69-86-10-20 
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For this country Contact this office Using this number 

Germany Germany (0049) 089/3176-1110 

Iceland Sweden (46) (8) 752 68 50 (applications) 
(46) (8) 752 60 50 (systems) 

Italy Italy (39) (02) 26901363 
(applications) 
(39) (02) 26901354 (SDK) 

Japan Japan (81)(3)3363-0160,3363-0170 

Korea Korea (82) (2) 563-9230 

Liechtenstein Switzerland (0041) 11342-4085 (German) 
(0041) 22/7389688 (French) 

Luxembourg Netherlands (0031) 2503-77877 (Dutch) 
(0031) 2503-77853 (English) 

Mexico Mexico (52) (5) 325-0912 

Netherlands Netherlands 02503-77877 (Dutch) 
02503-77853 (English) 

New Zealand Australia (02) 870-2131 

Northern Ireland United Kingdom (734) 271000 

Norway Norway (47) (2) 183500 

Papua New Guinea Australia (02) 870-2131 

Paraguay Argentina (54-1) 814-0356 

Peru Argentina (54-1) 814-0356 

Portugal Portugal 351 1 4412205 

Puerto Rico Venezuela 0058.2.914739 

Republic of Ireland United Kingdom (734) 271000 

Scotland United Kingdom (734) 271000 

Spain Spain (91) 803 99 60 

Sweden Sweden (46) (8) 752 68 50 (applications) 
(46) (8) 752 60 50 (systems) 

Switzerland Switzerland 11 342-4085 (German) 
(41-22) 738 96 88 (French) 

Uruguay Argentina (54-1) 814-0356 

Venezuela Venezuela 0058.2.914739 

Wales United Kingdom (734) 271000 

Note For product-support information for countries not listed, contact the United 
States office at (206) 936-8661. 
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Windows Basics 

Chapter 1 

Basic Elements of Windows 
If you are new to the Microsoft Windows operating system, this chapter may be 
the most important one to read. It explains the basic skills you need to work with 
Windows. You may want to return to this chapter often as a reference. 

Windows provides everything you need to manage your applications and files 
easily and efficiently. The following illustration shows the rich graphical environ­
ment of Windows. 

11 @ peJ 
Windows PIF Editor Read Me 

Setup 

Accessories Games StartUp Applications 

Note You can learn basic mouse techniques, in addition to some basic Windows 
techniques, by using the online Windows Tutorial. For information about run­
ning this program, see "Running the Microsoft Windows Tutorial" in Chapter 2, 
"Application Basics." To use the Windows Tutorial, you need a mouse and a 
VGA (or better) monitor. 
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When you are running Windows, your work takes place on the desktop, the screen 
space Windows occupies. Think of this area as resembling the surface of a desk. 
You can move work items around on the Windows desktop, bring new ones onto' 
it, and remove those you don't need. 

The first time you start Windows, Program Manager appears on your screen. 
You can use Program Manager to organize your applications and start them. 

After you start an application, it runs in an application window on the desktop. 
You can reduce any open application window to an application icon. An 
application icon is a small picture representing an application. By reducing 
application windows to icons, you can free space on your desktop without 
quitting the applications. For more information about icons, see "Types of 
Icons" later in this chapter. 

The following illustration shows applications running in windows and appli­
cations running as icons on the desktop. For more information about how to start, 
run, switch between, and quit applications, see Chapter 2, "Application Basics." 

TO DO THIS WEEK 

- Do charts for Thursday 
status meeting. 

- Schedule meeting with Jan 
re next month's seminar. 

- Finish writing report by 
Friday. 

- Clean out email mailbox. 

Applications running in windows 

'~------~ / 

1 Applications running as icons 

Desktop 
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Another element of Windows is the dialog box, a rectangular box that supplies or 
requests information about the task you are performing. The following illustration 
is an example of a dialog box commonly used in Windows. For more information, 
see "Using a Dialog Box" later in this chapter. 

........... ~ 

c:\memos 
r::;~=--c:\:------""'~'71I IS·"\:Gi(.a!il;;vt 
~ memos 

home_lxl 
·i1·etw·ork·s.lxl 
review.lxl 
slalrepUxl 

Lisl Files of llpe: Drives: 

',-!_ex_1 F_il_es_("_. T_X_T)_--",I::!:_~ I ~ c: chris ILii 

Windows can run in one of two modes: standard or 386 enhanced. The mode you 
use depends on the hardware you have. When you start Windows by typing win, 
Windows examines your system's configuration and starts in the most appropriate 
mode for your system. 

Standard mode is the basic operating mode for Windows. This mode provides 
access to extended memory and enables you to switch between applications, 
including those not specifically designed to run with Windows (non-Windows 
applications ). 

386 enhanced mode provides access to the virtual memory capabilities of the 
80386 processor. If Windows is running in 386 enhanced mode, applications have 
access to more memory than is physically available on your system, and you can 
still switch between applications. 

For more information about Windows modes, see Getting Started with Microsoft 
Windows. 
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The Parts of a Window 
This section describes the elements of a window that are your tools for working 
with the window and the application or document within the window. Most 
windows have certain elements in common, such as a title bar and menus. Not 
all windows, however, have every element. 

Insertion point 
Control-menu box 

Eile Edit Search Jjelp 

Window corner 

Window title 

Mouse pointer 

Minimize button 
Maximize button 

Menu bar 

Window border 

Vertical 
scroll bar 

Horizontal scroll bar 

You'llieam more about how to use window elements throughout this chapter. 

• The Control-menu box is in the upper-left corner of each window. The Control 
menu is most useful if you use your keyboard to work with Windows. By using 
Control-menu commands, you can resize, move, maximize, minimize, and 
close windows, and switch to other applications. (If you use a mouse, you can 
perform these tasks by clicking and dragging.) 

• The title bar shows the name of the application or document. If more than one 
window is open, the title bar for the active window (the one in which you are 
working) is a different color or intensity than other title bars. 

• The window title, depending on the type of window it appears in, can be the 
name of an application and the name of a document, or the name of a group, 
directory, or file. If a document has not been saved, a placeholder such as 
"(Untitled)" usually appears as part of the window title. 
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• The menu bar lists the available menus. A menu contains a list of commands, 
or actions, you can carry out with Windows. Most applications have a File 
menu, an Edit menu, and a Help menu, in addition to menus unique to the 
application. 

• By using scroll bars, you can move parts of a document into view when the 
entire document doesn't fit in the window. You can also use scroll bars to view 
unseen portions of lists and other information that cannot fit in the allotted 
space. 

• Using a mouse, you can click the Maximize button to enlarge the active appli­
cation window so that it fills the entire desktop, or you can click the Minimize 
button to reduce the window to an icon. 

• After you enlarge a window, the Maximize button is replaced by the Restore 
button, which contains both an up arrow and a down arrow. You can click the 
Restore button to return the window to its previous size. If you are using the 
keyboard rather than a mouse, you can use the Restore command on the 
Control menu. 

• The window border is the outside edge of a window. You can lengthen or 
shorten the border on each side of a window. 

• The window corner can be used to shorten or lengthen two adjoining sides of 
a window border at the same time. 

• The insertion point shows where you are in a document. It marks the place 
where text and graphics appear when you begin typing or drawing. (Some 
applications have insertion points that look different from the one shown in 
the previous illustration.) 

• The mouse pointer appears if you have a mouse installed. When you move the 
mouse, the position of the pointer changes on the screen. (Some applications 
have different mouse pointers from the one shown in the previous illustration.) 

Types of Windows 
As you work with applications, two kinds of windows appear on your desktop: 
application windows, and windows contained within the application window. 

As mentioned earlier, an application window contains a running application. The 
name of the application and any associated document, and the application's menu 
bar, appear at the top of the application window. 
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The following is an example of an application window. 

file .Edit ~earch !:!.elp 

Another window may appear inside an application window. These types of 
windows are sometimes called document windows, because they often contain 
your document or other data files. In Program Manager, they contain groups. In 
File Manager, they contain directories. In many applications, more than one of 
these windows can be open at a time. For example, with Windows File Manager 
(one of the main applications included with Windows), you can open several 
directories at a time. Each directory appears inside its own window. 

These windows share the application window's menu bar. When a document 
window is opened, commands that you choose from the application's menu bar 
affect the document window or the information or items contained in it. 

Windows inside of application windows have their own title bar unless they are 
maximized (expanded to their maximum size within the application window). 
When maximized, they share the application window's title bar. 
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eJ lmI 
Cardfile Calendar 

Applications Games 
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,--------------,- Windows inside of 

• @ 
Windows PIFEditor 

Setup 

StartUp 

application windows do not 
have their own menu bars. 

Print Manager 

~ 
Read Me 

If you use a mouse, there's no difference between the way you manipulate 
application windows and the windows inside them. If you use the keyboard, 
however, you use different keystrokes to manipulate each type of window. 
For more information, see "Working with a Window" later in this chapter. 
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Types of Icons 
Icons are small pictures that represent various types of applications and files. 
In Program Manager, there are a number of different types of icons. 

• An application icon represents an application that is running, but whose 
window is not open. The application window has been reduced to an icon at 
the lower edge of your Windows desktop. 

You can move an application icon (that is, the icon for a running application) 
anywhere on the desktop except into an open window. This is because the icon 
represents an open application, and applications run only on the desktop, not 
inside of documents or other applications. 

Prepare charts for Thursday status meeting. 

Schedule seminar for next month. 

Finish report by Friday. 

Read/clean up email mailbox.1 

''-----------. r---------J~ 
I Application icons 
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• Another type of icon represents a document window that is minimized. These 
icons generally appear along the lower edge of the application window and can 
be moved anywhere within the application window. In Program Manager, these 
icons are called group icons. 

Notice in the following illustration that the icons that represent document 
windows look the same. Only the labels that identify them are different. 

p:\".' 

~ 
tJ:gE 

r:\'.' 

'" calc. hlp 

LJsystem !::lcalendar.exe [2l chimes. 
[2l256color.bmp [2l calendar.hlp [;j chitz.bmp 

D accessor.grp [3j canyon.mid [3j chordwav 

D applicat.grp !::lcardfile.exe !::lclipbrdexe 

[3j arcade. bmp [3j cardfile hlp [;j clipbrd hlp 

[3j arches.bmp [3j cars.bmp !::lclock.exe 

@1l argyle.bmp @1l castle.bmp !::l control. exe 

[3j bootlog.txt :l:i~h~i~~p.~~~! [3j control.hlp 
r::I calc. exe ~ charmap.hlp ~ control.ini 

'----.>.- These icons are distinguished 
only by their labels. 
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• Program-item icons represent the applications you can start from Windows. 
They are contained in Program Manager group windows. You can move or 
copy program-item icons from one group window to another; for example, if 
you want to be able to start an application from a different group. (For more 
information, see "Moving an Icon" later in this chapter.) 

Cardfile 

~ ti:J 
Paintbrush 

lillI 
Calendar 

Games 

Calculator 

....... ........ 
StartUp 

~ 
~ 

Recorder 

5 
Object 

Packager 

Program-item icons are 
contained in group windows. 

Application icon 

Most program-item icons look unique. However, icons for many non-Windows 
applications are identical. Also, for many applications, you can run more than 
one copy of the application. Program-item icons for multiple copies of appli­
cations are identical. Thus, a group window might contain several identical 
program-item icons distinguished only by their labels. 
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Basic Mouse and Keyboard Techniques 
This section explains some of the basic terminology and techniques that are 
referred to throughout this guide. Other terms are explained as they are intro­
duced in the text. (For more information about specific terms, see the Glossary 
at the back of this guide.) 

Term 

Click 

Double-click 

Drag 

Point 

Meaning 

To quickly press and release the mouse button. 

To click the mouse button twice in rapid succession. 

To hold down the mouse button while you move the mouse. 

To move the mouse until the mouse pointer on the screen rests on the 
item of choice. 

Choosing and Selecting Items 
In Windows, the terms choose and select have different, and specific, meanings. 
Selecting an item usually means marking it with the selection cursor, which can 
appear as a highlight, a dotted rectangle, or both. You also select check boxes in 
dialog boxes. Selecting alone does not initiate an action. 

You choose an item to carry out an action. For example, choosing an icon might 
start an application, open a window, or carry out a command. You can also choose 
an item from a menu, or choose a command button in a dialog box. (Menus and 
dialog boxes are discussed in more detail later in this chapter.) You often need to 
select an item before you can choose it. 

You can use a combination of mouse and keyboard techniques. For example, 
you could click an item to select it, and then press ENTER to choose it. When a 
procedure in this guide says to choose an item, generally you can use whichever 
method you prefer. Alternative procedures are often provided as well. 

Keyboard Shortcuts 
Shortcut keys can be used to carry out some menu commands. Shortcut-key 
combinations are listed to the right of a menu item. Instead of opening the menu 
and choosing a command, you simply press the key combination. 
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Using a Menu 
Windows commands are listed on menus. Each application has its own menus, 
which are listed on the menu bar along the upper edge of the application window. 
In addition, each application window has a Control menu. The Control menu 
opens from the small box in the upper-left corner of each window. For more 
information, see "Using the Control Menu" later in this chapter. 

Selecting and Closing a Menu 
In Windows, you select (highlight) a menu and then choose a command from that 
menu. Choosing the command carries out the action. 

~ To select a menu 

Mouse 

• Using the mouse pointer, point to the name of the menu on the menu bar, and 
click the left mouse button. This opens the menu. (To move directly to a menu 
item, you can drag the selection cursor down the menu until the menu item is 
highlighted, and then release the mouse button.) 

Keyboard 

1. Press ALT or FlO to select (highlight) the menu bar. 

2. Press the LEFT ARROW or RIGHT ARROW key to select the menu you want. 

3. Press ENTER to open the selected menu. 

Tip If a name in the menu bar has an underlined letter, you can press ALT to move 
to the menu bar, and then type the letter that's underlined to open the menu. For 
example, to open the File menu in Program Manager, press ALT, F. 

If more than one menu name has the same underlined letter, the first name listed is 
selected. To select the next menu name, press ALT, and then the letter again. 

The following are typical Windows menus. 

Qpen Enter 
Move... Fl 
~opy... FB 
.!lelete Del 
.E!roperties... AIHEnter 

Bun ... 

E:;:s;it Windows ... 



Gut Cttl+x 
i;npy Cir!·le 
paste Ctr!+\f 
Dei.ete De! 

Select All 
Time/Qate F5 

Word Wrap 

Qecrease Volume 

Increase Speed (by 1 ~O%) 
D~crease Speed 

Add Echo 
Beverse 

~ To close a menu 
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• Click the menu name or anywhere outside the menu. 

Or press ALT or FlO to cancel the menu and move back to the application 
workspace. 

Or press ESC to close the menu but remain on the menu bar so that you can 
select another menu. 

Choosing a Menu Command 
Menu items are most often commands. However, they can also be characteristics 
you assign to graphics or text (such as bold or centered), a list of open windows or 
files, or the names of cascading menus, which list additional commands. 

~ To choose an item from a selected menu 

• Click the item. 

Or type the letter that is underlined in the item name. 

Or use the UP ARROW and DOWN ARROW keys until you reach the item you want 
to select, and then press ENTER. 

There are a number of menu conventions used in Windows. For example, some 
menu items may have a check mark, an ellipsis ( ... ), or a key combination next to 
them. Other menu items may be dimmed. 
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The following menu conventions are used in Windows. 

Menu convention 

Dimmed (or not visible) command 

An ellipsis ( ... ) following a command 

A check mark (./) next to a command 

A key combination next to a command 

A triangle (~ ) next to a command 

Using the Control Menu 

Meaning 

You may not be able to use the command 
with your application at the current time. 
(For example, you may need to select 
another item before using this command.) 

A dialog box appears when you choose the 
command. The dialog box contains options 
you need to select before the command can 
be carried out. 

The command is in effect. When you 
remove the check mark (by selecting the 
command), the command is no longer in 
effect. 

The key combination is a shortcut for this 
command. You can use this key combina­
tion to choose the command. 

When you choose this command, a 
cascading menu appears, listing addi­
tional commands. 

Application windows, application icons, document windows and their icons, and 
some dialog boxes have a Control menu. 

You open the Control menu for windows and dialog boxes by selecting the 
Control-menu box in the upper-left comer of the window or dialog box. You 
open the Control menu for an icon by selecting the icon. 

The Control menu for an application window, a document window, and a dialog 
box are somewhat different from each other, as are the Control menus for non­
Windows applications. The following section describes how to use the Control 
menu in these environments. 
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Opening the Control Menu 
How you open the Control menu depends on whether you are working with an 
application window, a document window, a dialog box, or an icon. 

Note In applications that can contain document windows, you may see more 
than one Control-menu box. The one in the far upper-left comer controls the 
application. The others control the windows inside the application window. 

~ To open the Control menu for an application window or application icon 

Mouse 

• Click the Control-menu box in the upper-left corner of the window. 

Or click the application icon. 

Do not double-click; if you do, the window closes or the icon is restored to a 
window. 

Keyboard 

1. Press ALT+ESC repeatedly to cycle through the open application windows and 
icons until you reach the one you want. 

2. Press ALT, SPACEBAR to open the Control menu. (Press ALT if you want to close 
the menu without choosing a menu item.) 
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~ To open the Control menu for a document window or its icon 

Mouse 

• Click the Control-menu box in the document window. 

Or click the icon. 

Do not double-click; if you do, the window closes or the icon is restored to a 
window. 

Keyboard 

1. Press CTRL+F6 or CTRL+TAB repeatedly to cycle through the open windows and 
icons in an application until you reach the one you want. 

2. Press ALT, HYPHEN (-) to open the Control menu. (Press ALT if you want to close 
the menu without choosing a menu item.) 

~ To open the Control menu for a dialog box 

• Click the Control-menu box in the upper-left comer of the dialog box. 

Or press ALT, SPACEBAR. (Press ALT to close the menu without choosing a menu 
item.) 

l:ll;llllR!!i!!11 

I I'iii.llli I 
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The Control Menu in a Non-Windows Application 
A non-Windows application is one that was designed for the Microsoft MS-DOS® 
environment, rather than for Windows. You can use most non-Windows applica­
tions with Windows. 

A non-Windows application running in standard mode does not have an applica­
tion window; it occupies the entire screen. Before you can open the Control menu, 
you must switch back to Windows so that the application is reduced to an icon. 

To find out which mode Windows is running in, choose the About command on 
the Help menu in applications included with Windows (Main or Accessories 
group applications). 

~ To open the Control menu for a non-Windows application running in 
standard mode 

1. Press ALT+ESC to switch from the application to Windows. 

The application is reduced to an application icon at the bottom of the screen. 

2. Click the icon. 

Or press ALT +ESC to select the icon you want, and then press ALT +SPACEBAR to 
open the Control menu. 

~ To open the Control menu for a non-Windows application running in 386 
enhanced mode 

Mouse 

• Click the Control-menu box in the upper-left corner of the application window. 

Or, if the application window has been reduced to an icon, click the icon. 

Do not double-click; if you do, the window closes or the icon is restored to a 
window. 
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Keyboard 

1. Press ALT+ESC repeatedly to cycle through the open application windows and 
icons until you reach the one you want. 

2. Press ALT+SPACEBAR. (Press ALT to close the menu without choosing a menu 
item.) 

Note The Control menu for a non-Windows application running in 386 
enhanced mode includes a cascading/menu. Using a mouse, you open the 
cascading menu by clicking the Edit command. Using a keyboard, you open 
the cascading menu by choosing Edit and then pressing the RIGHT ARROW key 
or ENTER. To use the commands on a cascading menu, you must be running the 
application in a window. For more information about running a non-Windows 
application in a window, see Chapter 7, "Non-Windows Applications." 

Control-Menu Commands 
The following table describes the commands on the Control menu. Some applica­
tions do not have all these commands. 

Use 

Restore 

Move 

Size 

Minimize 

Maximize 

Close 

To 

Restore the window to its former size after you have enlarged it (by 
using the Maximize command) or reduced it to an icon (by using the 
Minimize command). 

Use the keyboard to move the window to another position. 

Use the keyboard to change the size of the window. 

Reduce the window to an icon. 

Enlarge the window to its maximum size. 

Close the window or dialog box. (From an application window, you can 
use this command to quit the application.) 



Use 

Switch To 

Next 

Edit 

Settings 

Fonts 
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To 

Open Task List, which enables you to switch between running applica­
tions and rearrange windows and icons on your desktop. 

Switch between open document windows and icons (available for 
document windows only). 

Display a cascading menu with additional commands (available for 
non-Windows applications running in 386 enhanced mode only). 

Display a dialog box that requests information about multita~king 
options (available for non-Windows applications running in 386 
enhanced mode only). 

Display a dialog box that you can use to specify font information 
(available for non-Windows applications running in 386 enhanced 
mode only). 

Choosing the Edit command opens a menu that has four additional commands, as 
follows. 

Use 

Mark 

Copy 

Paste 

Scroll 

To 

Use your keyboard to select text and move it onto the Clipboard. 

Copy the selected text onto the Clipboard. 

Copy text from the Clipboard to the active window. 

View information not currently visible in the window. 

Working with a Window 
When you work with applications and documents, you often have a number of 
windows open. This section explains how to move and resize windows, scroll 
through their contents, and arrange them on the desktop. 

Moving a Window 
You can move any window to a different location on your desktop. 

~ To move a window 

Mouse 

1. Drag the title bar of the window to the new location. 

As you move the mouse pointer, an outline of the window moves with it. 

2. Release the mouse button. 

To cancel the move, press ESC before you release the mouse button. 
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Keyboard 

1. Select the window you want to move. (Be sure NUM LOCK is turned off.) 

To cycle through the application windows until you reach the one you want, 
press ALT+ESC. 

To cycle through the windows inside an application window, press CTRL+F6 or 
CTRL+TAB. 

2. If you are moving an application window, press ALT, SPACEBAR to open the 
Control menu. 

If you are moving a document window, press ALT, HYPHEN (-) to open the 
Control menu. 

3. From the Control menu, choose Move. 

The pointer changes to a four-headed arrow. 

4. Use the arrow keys to move the window to the new location. 

An outline of the window moves as you use the arrow keys. 

5. Press ENTER. 

To cancel the move, press ESC before you press ENTER. 

Changing the Size of a Window 
You might want to change the size and shape of windows on your desktop. For 
example, to compare the contents of two documents, you can reduce the size of 
both document windows so that they fit side by side. If you are using a mouse, you 
can drag the window's border or corners to adjust the size. If you are using the 
keyboard, you can modify the window's size and shape by using commands on 
the Control menu. 

Note The minimum size for all windows is about 2 inches by 1 inch. Some appli­
cation windows cannot be resized. 

~ To change the size of a window 

Mouse 

1. Select the window you want to resize. 

2. Point to a border or comer. 

The pointer changes to a two-headed arrow. 
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3. Drag the comer or border until the window is the size you want. 

If you drag a border, the window size changes only on the side of the border 
you drag. If you drag a corner, the two adjoining sides that form the comer are 
moved at the same time. 

An outline shows the size and shape you are creating. 

4. Release the mouse button. 

To cancel the resizing, press ESC before you release the mouse button. 

Keyboard 

1. Select the window you want to resize. (Be sure NUM LOCK is turned off.) 

To cycle through application windows until you reach the one you want to 
resize, press ALT+ESC. 

To cycle through the windows inside an application window, press CTRL+F6 or 
CTRL+TAB. 

2. If you are resizing an application window, press ALT, SPACEBAR to open the 
Control menu. 

If you are resizing a document window, press ALT, HYPHEN (-) to open the 
Control menu. 

3. From the Control menu, choose Size. 

The pointer changes to a four-headed arrow. 

4. Use an arrow key to move the pointer to the border you want. 

If you want to change the size both horizontally and vertically, press two arrow 
keys simultaneously to select a corner of the window. Press UP ARROW+RIGHT 

ARROW, for example, to select the upper-right comer of the window. 

5. Use an arrow key to move the border. 

If you are changing the size both horizontally and vertically, press the RIGHT 

ARROW key to stretch the window to the right, and the UP ARROW key to stretch 
the window toward the top of the desktop, until the window is the size you want. 

An outline shows the size and shape as you make cha~ges. 

6. Press ENTER when the window is the size you want. 

To cancel the resizing, press ESC before you press ENTER. 

Reducing a Window to an Icon 
When you finish working with an application, you may want to reduce the applica­
tion window to an icon if you want the application available for later use. When 
you reduce an application window to an icon, the application continues to run but 
its window does not take up space on the desktop. You may also be able to reduce 
a document window to an icon. 
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You can select and move icons on your desktop in the same way you select and 
move windows. 

~ To reduce a window to an icon 

Mouse 

1. Select the window you want to reduce. 

2. Click the Minimize button (the box with a down arrow to the right of the title 
bar) in the upper-right corner of the window. 

The Minimize button 

,Eile .Edit Find !;.haracter .E!aragraph .!locument Help 

Keyboard 

1. Select the window you want to reduce. 

To cycle through application windows until you reach the one you want, press 
ALT+ESC. 

To cycle through document windows, press CTRL+F6 or CTRL+TAB. 

2. If you are reducing an application window, press ALT, SPACEBAR to open the 
Control menu. 

If you are reducing a document window, press ALT, HYPHEN (-) to open the 
Control menu. 

3. From the Control menu, choose Minimize. 

If a document window (for example, the Main group window) has been maxi­
mized, you must restore it to its original size before you can use the Minimize 
button to reduce it to an icon. (The Minimize button does not appear in a 
maximized document window.) Or you can reduce the window by choosing 
Minimize from the window's Control menu. 

Enlarging a Window 
In most cases, you can enlarge an application window to fill a larger portion of the 
desktop or even the entire desktop. A document window can be enlarged to fill an 
entire application window except the menu-bar area. 
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~ To enlarge a window to its maximum size 

Mouse 

1. Select the window you want to enlarge. 

2. Click the Maximize button in the upper-right corner of the window. 

Note You can also maximize a window by double-clicking its title bar. To restore 
an application window to its previous size, double-click the title bar again. To 
restore a document window, click the Restore button in the upper-right corner of 
the window. 

The Maximize button 

Eile .Edit Find !;.haracter Earagraph .Qocument .!::!elp 
II 

Keyboard 

1. Select the window you want to enlarge. 

To cycle through application windows and icons until you reach the one you 
want, press ALT +ESC. 

To cycle through document windows and icons, press CTRL+F6 or CTRL+TAB. 

2. If you are enlarging an application window, press ALT, SPACEBAR to open the 
Control menu. 

If you are enlarging a document window, press ALT, HYPHEN (-) to open the 
Control menu. 

3. From the Control menu, choose Maximize. 

The window enlarges to its maximum size, and the Maximize button is replaced 
by the Restore button. 

A maximized document window no longer has its own title bar. The Minimize and 
Maximize buttons affect the application window, not any windows inside it. Only 
the Restore button affects the document window alone. 

Tip When two or more windows are open inside an application window and you 
enlarge one of them, all the others are covered up by the enlarged window. To 
display the other windows, choose the Restore button to return the enlarged 
window to its previous size or choose Minimize from the document's Control 
menu to reduce the window to an icon. 
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Restoring an Icon or Window 
You can restore an icon or window to its original size by using the Restore 
command. 

~ To restore an icon to a window 

Mouse 

• Double-click the icon. 

Or choose the Restore command from the Control menu. 

Keyboard 

1. Select the icon you want to restore. 

To cycle through application icons until you reach the one you want to restore, 
press ALT +ESC. 

To cycle through document icons until you reach the one you want to restore, 
press CTRL+F6 or CTRL+TAB. 

2. Press ENTER. 

~ To restore an enlarged window to its previous size 

Mouse 

• Click the Restore button in the upper-right corner of the window. 

File Edit Find Character Paragraph Document Help 1\ 
~~--=---~~~----=-~~~~~-=~----------------~~ 

Keyboard 

The Restore button restores 
a window to its previous size. 

1. If you are restoring an application window, press ALT, SPACEBAR to open the 
Control menu. 

If you are restoring a document window, press ALT, HYPHEN (-) to open the 
Control menu. 

2. From the Control menu, choose Restore. 
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Moving an Icon 
You can move an application icon or document icon to a different location on your 
desktop. 

You can move an application icon anywhere on your desktop except into another 
application window. (The application icon may appear to be in the other applica­
tion's window, but if you close the window, the icon remains on the desktop. This 
is because applications cannot run within other applications.) 

You can move a document icon to a different location in its application window, 
but not outside of the application window. 

.. To move an icon 

Mouse 

1. Drag the icon to a new location. 

The mouse pointer changes to an outline of the icon, which moves as you move 
the mouse. 

2. Release the mouse button. 

To cancel the move, press ESC before you release the mouse button. 

Keyboard 

1. Select the icon you want to move. (Be sure NUM LOCK is turned off.) 

To cycle through the application icons until you reach the one you want to 
move, press ALT +ESC. 

To cycle through the document icons until you reach the one you want to move, 
press CTRL+F6 or CTRL+ TAB. 

2. If you are moving an application icon, press ALT, SPACEBAR to open the Control 
menu. 

If you are moving a document icon, press ALT, HYPHEN (-) to open the Control 
menu. 

3. From the Control menu, choose Move. 

4. Use the arrow keys to move the icon to a new location. 

An outline of the icon moves as you use the arrow keys. 

5. Press ENTER. 

To cancel the move, press ESC before you press ENTER. 
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Using Scroll Bars 
Some windows and dialog boxes have scroll bars you can use to view information 
that exists beyond the borders of the window. When you can view all the contents 
of a window or dialog box without scrolling, scroll bars may be absent, or 
dimmed, to indicate they cannot be used. 

Cardfile Calendar Calculator 

~ A 
Character Map Media Player Sound 

Recorder 

Clock Object 
Packager 

Scroll arrow 

Scroll bar 

Scroll box 

~ To scroll through information displayed in a window or dialog box 

Mouse 

• Drag the scroll box to scroll through all the information in a list or document. 

You can also use the following techniques to scroll. 

To scroll 

One line up or down 

One screen 

Continuously 

To any position 

Keyboard 

Do this 

Click the up or down scroll arrow. 

Click the scroll bar above or below the scroll box on verti­
cal scroll bars, and to the left or right of the scroll box on 
horizontal scroll bars. 

Point to one of the scroll arrows, and hold down the mouse 
button until the information you want comes into view. 

Drag the scroll box in the scroll bar to the position you 
want. The section of the document or list that moves into 
view depends on where you position the scroll box. For 
example, if you position the scroll box halfway down the 
vertical scroll bar, the text halfway through the document 
or list appears. 

• Press the arrow key that points in the direction you want to scroll. (Be sure NUM 

LOCK is off.) 

Depending on the application, you may also be able to use the following tech­
niques to scroll. 

To scroll 

One line up or down 

One screen up or down 

Press 

UP ARROW or DOWN ARROW 

PAGE UP or PAGE DOWN 



Closing a Window 

To scroll 

One screen left or right 

To the beginning of a line 

To the end of a line 

To the beginning of the document 

To the end of the document 
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Press 

CTRL+PAGE UP or CTRL+PAGE DOWN 

HOME 

END 

CTRL+HOME 

CTRL+END 

One way to quit an application is to close the application window. Similarly, you 
can close a document by closing the document window. If you made changes to 
your document since you last saved it, a message prompts you to save the docu­
ment before closing the window. 

~ To close a window 

• From the File menu, choose Exit. 

Or choose Close from the Control menu. 

As a shortcut, you can double-click the Control-menu box. 

Using a Dialog Box 
Windows displays a dialog box to request information about a task you are 
performing or to supply information you might need. 

An ellipsis ( ... ) after a menu command indicates a dialog box will appear when 
you choose that command. For example, if you choose the Open command on the 
File menu in Windows Notepad, the Open dialog box appears. In this dialog box, 
you specify the name of the file you want to open. 

'~~r:~~k~:ixt' ............................. I.i 
leview_bd 
stabepl.txt 

c:\memos 

127 c:\ 
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Most dialog boxes contain options you can select. After you specify options, you 
can choose a command button to carry out a command. Other dialog boxes may 
display additional information, warnings, or messages indicating why a requested 
task cannot be accomplished. 

Moving a Dialog Box 
If a dialog box has a title bar, you can move the dialog box to another location on 
your desktop. 

~ To move a dialog box 

Mouse 

1. Drag the title bar of the dialog box to the new location. 

As you move the mouse pointer, an outline of the dialog box moves with it. 

2. Release the mouse button. 

To cancel the move, press ESC before you release the mouse button. 

Keyboard 

1. Select the dialog box you want to move. (Be sure NUM LOCK is turned off.) 

2. Press ALT, SPACEBAR to open the Control menu. 

3. From the Control menu, choose Move. 

The pointer changes to a four-headed arrow. 

4. Use the arrow keys to move the dialog box to the new location. 

5. Press ENTER. 

To cancel the move, press ESC before you press ENTER. 

Moving Within a Dialog Box 
Often you need to move within a dialog box to select one or more options. The cur­
rently selected option is marked by the selection cursor, which appears as a dotted 
rectangle, a highlight, or both. 

~ To move within a dialog box 

Mouse 

• Click the option or area you want to move to. 



Types of Options 
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Keyboard 

1. Press TAB to move forward (generally from left to right and top to bottom), or 
press SHIFf+TAB to move in the opposite direction. 

Or, while you press and hold down ALT, type the letter that is underlined in the 
option name or group name. 

2. Within an area, use the arrow keys to move from one option to another. 
(Be sure NUM LOCK is turned off.) 

There are several types of dialog box options, which are described in the following 
sections. 

Command Buttons 
You choose a command button to initiate an immediate action, such as carrying 
out or canceling a command. The OK, Cancel, and Help buttons are common com­
mand buttons. They are often located along the bottom or on the right side of the 
dialog box. 

Memory: 
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Car!ridges (maH: 2 )--------, 

HP: Pro Collection 
H P: \1/ ordPerfect 
HP: Global TeHt 
HP: Great Start 

I nlij~~~~nl 
lim:u.i,Jp!;;11I1 

The selection cursor indicates 
the currently selected option. 

This button carries out the 
command you choose. 

This button closes the dialog 
box and cancels the command 
you choose. 

This kind of button presents 
additional options. 

A command button followed by an ellipsis ( ... ) opens another dialog box. A com­
mand button marked with greater-than signs (») expands the active dialog box. 
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For example, the Color dialog box in Control Panel has a button labeled Color 
Palette» that expands the Color dialog box to display more options. 

Unavailable buttons are dimmed. The currently selected button has a darker border 
than other buttons. You can choose the selected button simply by pressing ENTER. 

To close a dialog box without completing a command, choose the Cancel button. 

~ To choose a command button 

Mouse 

• Click the command button. 

Keyboard 

1. Press TAB to move to the button you want. 

A dark border marks the selected button. 

2. Press the SPACEBAR or ENTER. 

Tip If the button has an underlined letter in its name, you can choose the com­
mand button in one step. Press and hold down ALT while typing the underlined 
letter. 

Text Boxes 
You type information into a text box. 

:==================~I miilffJKl;iJ)!1 
Start Erom: I c:\windows I 1!liflifliftlii. 

[2J S§.arch All Subdirectories 

l:i!IIWillilll 

When you move to an empty text box, an insertion point (flashing vertical bar) 
appears at the far left side of the box. The text you type starts at the insertion 
point. 

If the box you move to already contains text, this text is selected, and any text 
you type replaces it. You can also delete the existing text by pressing DEL or 
BACKSPACE. For information about editing text, see "Working with Text" in 
Chapter 2, "Application Basics." 
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~ To select text in a text box 

Mouse 

• Drag the pointer across the text you want to select. 

Or double-click on a word to select one word at a time. 

Keyboard 

1. Use the arrow keys to move to the first character you want to select in the box. 
(Be sure NUM LOCK is turned off.) 

2. To extend the selection, press and hold down SHIff while pressing the appro­
priate arrow key. (Press SHIFT +HOME to extend the selection to the first character 
in the box. Press SHIff +END to extend the selection to the last character in the 
box.) 

For more information about selection methods, see "Selecting Text" in Chapter 
2, "Application Basics." 

List Boxes 
A list box displays a list of choices. If there are more choices than can fit in the 
box, scroll bars are provided so you can move quickly through the list. For infor­
mation about scrolling, see "Using Scroll Bars" earlier in this chapter. 

Installed Printers: ---------, 

r""I!!IMl!iUd.1l1 

[Z] .!!se Print Manager 

list of Printers: 

~~~~tmJ'·'mi .... 9·, mJ-~ ..... '41 
Generic I Text Only 
Agfa 9000 Series PS 
Agfa Compugraphic .. OOPS 
Agfa Compugraphic Genics 
Apple Laser ...... riter 
Apple Laser ...... riter II NT 
A Ie Laser ...... riter II NTX 

List boxes present available choices. 

1;1'ii;t;~19~:!ij;11 

lii1!tt!Rd,fiiiilt!U 
Ilt~iti.iutllmE.~.' 
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Usually, you can select only one item in a list box. There are some cases when you 
can select more than one item, as in Windows Setup when you select various appli­
cations to install. 

~ To select a single item from a list box 

Mouse 

1. Click the scroll arrows until the item you want to select appears in the list box. 

2. Click the item, and then choose the appropriate command button. 

Or double-click the item to select it and complete the command all in one step. 

Keyboard 

1. Use the arrow keys to scroll to the item you want. (Be sure NUM LOCK is turned 
off.) 

Or type the first letter of the item you want to select. The selection cursor 
moves to the first item that starts with that letter. 

2. Press ENTER. 

Sometimes you can select more than one item in a list box, whether or not those 
items are sequential. In these cases, you can select or cancel as many items as you 
want. 

~ To select multiple sequential items in a list 

Mouse 

• Click the first item you want to select, and then drag the cursor to the last item 
you want to select. 

To cancel the selection, click any item in the list. 

Or click the first item you want to select, press and hold down SHIFT, and click 
the last item you want to select. Both items, and all items in between, are 
selected. 

To cancel the selections, release SHIFT and click any item. 

Keyboard 

1. Use the UP ARROW or DOWN ARROW key to move the cursor to the first item you 
want to select. (Be sure NUM LOCK is turned off.) 

2. Press and hold down SHIFT. 

3. Continue to press the arrow key repeatedly until all the items you want are 
selected. 

To cancel the selections, release the SHIFT key and press the UP ARROW or DOWN 

ARROW key. 
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~ To select multiple nonsequential items in a list 

• Press and hold down CTRL, and click each item you want to select. 

To cancel a selection, press and hold down CTRL, and click the item again. 

There are no keyboard equivalents for this procedure. 

Note With some applications, you can use other key combinations to extend a 
selection to items that follow sequentially. For information, see the user's guide 
for the application. You may also want to see Appendix C, "Keyboard Shortcuts." 

Drop-Down List Boxes 
A drop-down list box appears initially as a rectangular box with the current selec­
tion marked by the selection cursor. When you select the arrow in the square box 
at the right, a list of available choices appears. If there are more items than can fit 
in the box, scroll bars are provided. 

This type of list box is often found in small or crowded dialog boxes. 

Drop-down list boxes open 
to show available choices. 

~ To open a drop-down list box and select an item 

Mouse 

1. Click the arrow at the right of the box to open the box. 

2. Click the up or down scroll arrow. 

Or drag the scroll box to move to the item you want to select. 

3. Click the item. 
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Keyboard 

1. Press ALT+DOWN ARROW to open the box. (Be sure NUM LOCK is turned off.) 

2. Press the UP ARROW or DOWN ARROW key to move the selection cursor to the 
item you want. 

3. Press ALT +UP ARROW or ALT +DOWN ARROW to select it. 

Option Buttons 
Option buttons represent mutually exclusive options. You can select only one 
option at a time. 

The selected option button contains a black dot. Unavailable options are dimmed. 

This option is selected. 
Option buttons present 
mutually exclusive options. 

~ To select an option button 

Mouse 

• Click the option button. 

Keyboard 

1. Press TAB to move to the group of options you want. 

2. Use the arrow keys to select the option button you want. 

Tip If the option has an underlined letter, you can select the option button by 
pressing and holding down ALT while typing the underlined letter. 
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Check Boxes 
A check box next to an option means you can select or clear the option. You can 
select as many check-box options as needed. When a check box is selected, it con­
tains an X. Names of unavailable options are dimmed. 

These options are selected. 

[8J '-if.ze', 
[8J 'L~~t' Modification Date Cal'lCiel 
D last Modification Time 
D file Attributes - . Help 

Check boxes present 
nonexclusive options. 

Note In some cases, a check box may be shaded. A shaded box often signifies 
that additional choices relate to the option, though the meaning varies with the 
application. For example, in the Add/Remove Windows Components dialog box 
in Windows Setup, you can choose to add only selected README files. When 
you do this, the Readme Files check box is shaded. 

~ To select or clear check boxes 

Mouse 

• Click each blank check box you want to select. 

Click a selected box to clear it. 

Keyboard 

1. Press TAB to move to the check box you want to select or clear. 

2. Press the SPACEBAR to select the box. 

Press the SPACEBAR again to clear the selection. 

Tip If the option name has an underlined letter, press and hold down ALT while 
typing the underlined letter to select or clear the check box. 
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Common Dialog Boxes 
Some menu commands are common to several applications included with 
Windows. An example is the Open command in the File menu. Choosing one of 
these commands opens a dialog box that is the same, regardless of which applica­
tion you are using. These dialog boxes are designed to save you time because you 
can select the drive, directory, file, and file type from the ones displayed in the list 
boxes, instead of having to remember and type the names. 

Common dialog boxes all contain the same basic areas, as shown in the following 
example. Instructions for each area follow. 

File Name: Qirectories: 

Ihom~.txt I c:\memos 

home. txt ........ j..t l27 c:\ ·n·etw·ork·s:iiit····· 11!5 memos 
review. txt 
statrepUxt 

Uf 
list Files of IYpe: Drives: 

IText Files (z.TXT) I~] IIEil c: chris II 

File Name 
The currently selected file, if any, is listed in the box at the top of this area. 
Additional files you can select are shown in the list box. 

~ To select a file 

Mouse 

• Click the filename in the list box. To view more filenames, click the scroll 
arrow at the right of the list box. 

Keyboard 

1. Press TAB to move to the list box. 

2. Press the DOWN ARROW key to move the selection cursor to the filename. 

3. Press the SPACEBAR to select the filename. 

Press the SPACEBAR again if you want to clear the selection. 
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Directories 
The open directory is the one with the "open" file-folder icon to the left of the 
directory name. 

~ To open a different directory 

Mouse 

• Double-click the directory name. To view more directory names, click the 
scroll arrow at the right of the list box. 

Keyboard 

1. Press TAB to move to the list box. 

2. Press the UP ARROW or DOWN ARROW key to move the selection cursor to the 
directory name. 

3. Press ENTER. 

List Files of Type 
This section specifies which files are listed in the File Name area. The current type 
of file and its extension are displayed. 

Note In the Save As dialog box, this area is called Save File As Type. Procedures 
are the same in both cases. 

~ To select a different file type 

Mouse 

1. Click the arrow at the right of the drop-down list box to display more file types. 

2. Click the type of files you want to display. 

Keyboard 

1. Press TAB to move to the list box. 

2. Press the DOWN ARROW or RIGHT ARROW key to display more file types. 

3. Press the UP ARROW or DOWN ARROW key to move the selection cursor to the file 
type. 

4. Press ENTER to complete your selection. 



42 Microsoft Windows User's Guide 

Drives 
This section shows your system's current drive. 

~ To select a different drive 

Mouse 

1. Click the arrow at the right of the drop-down list box to display more drives. 

2. Click the drive you want. 

Keyboard 

1. Press TAB to move to the list box. 

2. Press the DOWN ARROW or RIGHT ARROW key to display more drives. 

3. Press the UP ARROW or DOWN ARROW key to move the selection cursor to the 
drive you want. 

4. Press ENTER to complete your selection. 

Closing a Dialog Box 
When you choose a command button, the dialog box closes and the command is 
carried out. You can also close the dialog box to cancel a command. 

~ To close a dialog box without completing the command 

• Choose the Cancel button. 

Or double-click the Control-menu box. 

Or press ESC. 

If a dialog box does not have a Cancel button, choose the Close command 
(or press ALT+F4) on the Control menu. If a dialog box does not have a Cancel 
button or Control menu, choose the appropriate button. 

Using Windows Help 
Windows online Help is a convenient, quick way to look up information about a 
task you are performing, a feature you would like to know more about, or a com­
mand you want to use. 

Windows Help is available whenever you see a Help command button, or Help as 
an item on a menu bar. 
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The applications and accessories (except Clock) you received with Windows 
include online Help, as described in this section. Other Windows applications and 
non-Windows applications might also have online Help. For information, see the 
documentation for your application. 

Tip You can keep Help readily available by resizing the Help window and moving 
it next to the running application. For information about sizing windows, see 
"Changing the Size of a Window" earlier in this chapter. 

Because Help might be displayed differently, depending on which application you 
are using and what kind of information you need, you can request Windows Help 
in several ways. Not all methods can be used with every application. 

~ To request Help, use one of the following methods 

• From the Help menu, choose a Help category. 

• Press Flo Then choose a topic from the Help Contents for the application you 
are using, or search for a topic by using the Search button. 

• Choose the Help command button that's available in many dialog boxes. This 
method gives you quick access to specific information about the dialog box. 

• Use the keyboard to select an item on a menu, and then press Fl to see a descrip­
tion of the item (available in certain applications). 

• Select a dialog box option or command, and then press Fl or the Help button 
to move directly to an explanation of the option (available in Windows PIF 
Editor). 
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Using the Help Menu 
The Help menu is generally the last menu on the menu bar, as shown in the follow­
ing illustration. When you select Help from the menu bar, a list of Help menu 
items appears. 

Mouse 

~ To get Help from a menu 

1. Click the Help menu. 

2. Click the menu item you want. 

Keyboard 

1. Press ALT, H. 

2. Press the underlined letter for the menu item you want. 

Or press the UP ARROW or DOWN ARROW key to move the selection cursor to the 
item you want, and then press ENTER. 

If this is the first time you've used online Help, you might want to choose How To 
Use Help from the Help menu. 

You can find the following standard items on most Help menus in Windows. 

Menu item 

Contents 

Search For Help On 

How To Use Help 

About (Application) 

Description 

An alphabetic list of all Help topics available for the active 
application. 

A dialog box for locating information about a specific topic. 

Information about how to use Windows Help. 

Information about the active application, such as copyright, 
version, and application name. Generally, also includes a user 
name and company name; the mode Windows is running in; 
and the amount of memory available on your computer. 
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Note The Help menu in Program Manager also contains an item named Windows 
Tutorial. Choose this item to start an online tutorial that teaches basic mouse and 
Windows techniques. To use the Windows Tutorial, you need a mouse and a VGA 
(or better) monitor. For information about how to use the Tutorial, see "Running 
the Microsoft Windows Tutorial" in Chapter 2, "Application Basics." 

Finding Information in Help 
To view a list of all the Help topics related to the application you are working 
with, choose Contents from the Help menu, or press Fl. To search for specific in­
formation, choose Search For Help On from the Help menu, or choose the Search 
button in the Help window. 

Finding Information by Using Search 
The Search feature is an efficient way to find the information you need. When you 
have a topic you want help with, you can select or type it in the Search dialog box 
so that Help can find the information for you. 

~ To search for a Help topic 

1. From the Help menu in your application, choose Search For Help On. 

Or press Fl to open Help, and then choose the Search button. 

The Search dialog box appears. 

2. Select the word or phrase you want to search for. If you start typing, the list box 
scrolls to those keywords that most closely match what you type. 

3. Choose the Show Topics button. 

A list of topics is displayed at the bottom of the dialog box. 

4. Select the topic you want to view, and then choose the Go To button. 

Information about the topic you selected appears on your screen. 

Note You do not have to type an entire word in the Search For box. Help matches 
the characters you type as closely as possible with the available keywords. 

Finding Information by Using Help Contents 
If you are using an application that has a Help item on the menu bar, you can dis­
play all the available Help topics by choosing Contents from the Help menu. The 
Help topics refer to the application you are currently using. 

You can also get to Help Contents by choosing the Contents button in the Help 
window. In most cases, you can display Help Contents by pressing Fl while using 
an application. 
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~ To display Help Contents and choose a topic 

1. From the Help menu, choose Contents. 

Or press Fl. 

The Contents window appears. 

2. Scroll to the topic you want information about. 

3. Click the topic. 

Or press TAB until you reach the topic you want, and then press ENTER. 

Note There may be an additional list of related topics (under "See Also") in the 
Contents window. When you select a related topic, information about that topic 
appears. 

Getting Help for a Dialog Box 
Many dialog boxes contain a Help button. If you press this button (or press FI 

while using the dialog box), a window appears that lists each area of the dialog 
box. 

~ To request Help on a dialog box 

1. While using the dialog box, choose the Help button or press Flo 

The window describing the dialog box appears. If the dialog box contains only 
a few areas, procedural information for the whole dialog box is included. More 
complex dialog boxes have a list of areas to select from. 

2. Select the area you want information about. 

A pop-up window displaying procedural information appears. (If the window 
has no Control menu, you can close it by pressing any key or clicking anywhere 
on your screen.) 

Tip It may be helpful to resize and arrange the Help window so that it does not 
overlap the dialog box. For more information, see "Working with a Window" 
earlier in this chapter. In some cases, resizing the Help window affects the size 
of pop-up windows as well. If you cannot read all the information in a pop-up 
window, enlarge the Help window. 

Additional Methods 
When you finish reading about a topic, you have several choices. If a list of related 
topics follows the information, you can choose from the list. Or you can choose 
one of the buttons along the top of the Help window. 
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Use this button To 

I. H !story I 

View the Help Contents for your application. 

Locate information about a topic (keyword or phrase) you 
select from a list or that you type in the Search For box. 

Return to previously viewed information. When you choose 
the Back button, you retrace your path through the Help topics 
you've already viewed. 

View a complete, sequential list of every Help topic you have 
viewed during the current Windows session. 

View an alphabetic listing of terms used in Windows online 
Help. 

The following buttons may appear in Help for some applications. 

Use this button To 

Displaying Glossary Definitions 

View the previous topic in a series of related topics. When you 
reach the first topic in the series, the button is dimmed. 

View the next topic in a series of related topics. When you 
reach the last topic in the series, the button is dimmed. 

In Help, glossary terms have a dotted underline. If you select a glossary term, a 
definition of that term appears. 

~ To display a glossary definition 

Mouse 

• Click the term. 

A definition appears. 

To remove the definition from your screen, click anywhere. 

Keyboard 

1. Press TAB to move to the term. 

2. Press ENTER. 

A definition appears. 

To remove the definition from your screen, press ESC. 
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Working with Applications 
A major advantage of the Microsoft Windows operating system is that it can run 
two or more applications at the same time. For example, you can have a spread­
sheet calculating complex formulas while you are using a word-processing 
application to prepare an annual report. And at the same time, your computer 
can be receiving the latest information about industry sales trends for you to 
use in the introduction of your report. 

U sing Windows, you can: 

• Quickly start the applications you use every day. 

• Organize your applications into groups that make sense to you. 

• Run more than one application at the same time and easily switch between 
them. 

• Cut and paste information between applications by using the Clipboard. 

Types of Applications 
Various types of applications run with the Windows operating system. Some are 
specifically designed to run with Windows, whereas others are designed to run 
with MS-DOS rather than Windows. This section describes the following four 
types of applications: 

• Windows applications-designed for Windows versions 3.0 and later 

• Older Windows applications-designed for versions earlier than 3.0 

• Non-Windows applications-designed for MS-DOS (most will run with 
Windows) 

• Memory-resident programs 
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Windows Applications 
Windows applications require Windows version 3.0 or later in order to run. They 
are designed to take advantage of Windows features. Windows applications use 
memory cooperatively, which means that Windows distributes your computer's 
memory among applications as efficiently as possible. Windows applications 
generally are highly graphical, and their menus, commands, and dialog boxes are 
visually the same as those in Windows. 

Several Windows applications are included with Windows-applications in the 
Main group (such as File Manager and Control Panel) and Accessories-group 
applications (such as Write, Paintbrush, and Notepad). 

Older Windows Applications 
Some Windows applications were designed for previous versions of Windows and 
do not work correctly with Windows version 3.0 and later. If you have an older 
Windows application, it is best to obtain an updated version of it. 

If your application was designed to be used with versions of Windows earlier than 
3.0, a dialog box similar to the following appears. 

The application you are about to run, 
DRAW.EXE, was designed for a previous 
version of Windows. 

Obtain an updated version of the application that 
is compatible with Windows version 3.0 and 
later. 

If you choose the OK button and start the 
application, compatibility problems could cause 
the application or Windows to quit unexpectedly. 

If you choose the OK button, the application starts running even though it is not 
compatible with this version of Windows. 

Caution Though running, these applications may not perform reliably. 

Non-Windows Applications 
A non-Windows application is designed to run with the MS-DOS operating sys­
tem but not specifically with Windows. It does not take advantage of the Windows 
graphical interface and may not have menus or dialog boxes, or make use of the 
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mouse. However, you can still use most non-Windows applications with 
Windows. For more information, see Chapter 7, "Non-Windows Applications." 

Memory-Resident Programs 
A memory-resident program is a type of non-Windows application; however, it 
runs differently than other applications do. When started from MS-DOS, it is 
loaded into memory and is available even when another application is running. A 
common type of memory-resident program is a pop-up program, which is loaded 
into memory but is not visible until you type a certain key combination. Memory­
resident programs are sometimes referred to as terminate-and-stay-resident 
programs, or TSRs. 

For information about using memory-resident programs with Windows, see 
Chapter 7, "Non-Windows Applications." 

Starting an Application 
With Windows, you can start an application in a number of ways: 

• Choose an application icon from a group in Program Manager. 

• Choose a program file or a program information file (PIF) from a directory 
window in File Manager. (For information about of starting an application from 
its PIF, see Chapter 8, "PIF Editor.") 

• Choose the Run command from the File menu in Program Manager or File 
Manager. 

• Use the MS-DOS command prompt (for non-Windows applications only). 

Remember that when using a mouse, you click to choose menu commands and 
command buttons. When choosing icons, you double-click. 

You can also set up an application to start when Windows starts. For more infor­
mation, see "Starting an Application When You Start Windows" in Chapter 3, 
"Program Manager." 

Starting an Application from Program Manager 
If an application is in a group, the easiest way to start it is to choose its icon from 
the group window. If a document is associated with the application, it is loaded 
into the application workspace. For information about organizing applications 
into groups and setting up a document so that it starts with an application, see 
Chapter 3, "Program Manager." 
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~ To start an application from a group 

Mouse 

1. Open the Program Manager window, if it is not already open. 

2. If the group window that contains the application you want to start is not 
already open, open it by double-clicking the group icon. 

3. Double-click the icon for the application. 

Keyboard 

1. Open the Program Manager window. 

2. Open the group window that contains the application you want to start by 
pressing CTRL+ TAB to move to the group, and then pressing ENTER. 

3. Use the arrow keys to move the selection cursor to the icon representing the 
application, or type the first letter of the application's name (for example, 
"N" for Notepad). 

4. From the File menu, choose Open. 

Or press ENTER. 

Tip You can choose the Minimize On Use command from the Options menu in 
Program Manager if you want to reduce Program Manager to an icon whenever 
you start an application. 

Starting an Application from File Manager 
You can start an application from File Manager by choosing the application's 
program file from a directory window. A program file has a .COM, .EXE, .PIF, or 
.BAT filename extension. If you start an application that can run in a window, the 
window appears in front of the File Manager window. If the application is a full­
screen application, such as MS-DOS Prompt, it replaces the File Manager window. 

Tip If you use an application frequently, you might find it more convenient to add 
it to a group in Program Manager than to start it from File Manager. For informa­
tion about how to add an application to a group, see Chapter 3, "Program 
Manager." 

~ To start an application from File Manager 

Mouse 

1. In the Main group, double-click the File Manager icon. 

2. Click the drive icon for the drive you want. 

3. Click the directory icon for the directory you want. 

4. Double-click the filename. 
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Keyboard 

1. In the Main group, use the arrow keys to move the selection cursor to the File 
Manager icon, and then press ENTER. 

2. Press CTRL plus the drive letter to move to the drive. 

3. Press the UP ARROW or DOWN ARROW key to open the directory you want. 

4. Press TAB to move the selection cursor to the right half of the directory window. 

5. Press the UP ARROW or DOWN ARROW key to select the filename. 

6. From the File menu, choose Open. 

Or press ENTER. 

You can use the Minimize On Use command on the Options menu in File 
Manager if you want File Manager reduced to an icon whenever you start an 
application. 

Tip With File Manager, you can quickly print files and perform various other 
file operations by using a mouse to drag a file's icon onto an application window 
or icon. For example, to print a data file, you can drag the file's icon from File 
Manager to the Print Manager window (or onto Print Manager running as an icon), 
and then release the mouse button. For more information, see "Dragging Icons to 
Perform Tasks" later in this chapter. 

Starting an Application by Using the Run Command 
You can use the Run command to start an application that you run only occa­
sionally or have not yet added to a group. You can also specify that a particular 
document open when you start the application. 

~ To start an application by using the Run command 

1. From the File menu in Program Manager or File Manager, choose Run. 

The Run dialog box appears. 

D Run M.inimized 

2. Type the path and name of the program file, including the extension, if there is 
one. (In File Manager, you don't need to type the path if the program file is in 
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3. the current directory. In Program Manager, you can choose the Browse button 
to display a list of program files to select from.) 

For example, if you want to start Aldus PageMaker and it is in the directory 
C:\P AGEMKR, you would type the following in the Command Line box: 

c: \pagemkr\pm.exe 

In most cases, you can open a document at the same time you start an applica­
tion by typing a space and the document filename (including the path where the 
document is located) after the name of the program file. 

For example, to open a document named NEWSLTR.PM3 in the AUGUST 
subdirectory of C:\P AGEMKR, you would type the following in the Command 
Line box: 

c: \pagemkr\pm.exe c: \pagemkr\august\newsltr .pm3 

4. If you want the application to be reduced to an icon as soon as it starts, select 
the Run Minimized check box. 

5. Choose the OK button. 

Or press ENTER. 

Starting an Application by Using the MS-DOS Command Prompt 
Generally, you can set up your non-Windows applications to run from Program 
Manager. (For more information, see Chapter 7, "Non-Windows Applications.") 
For non-Windows applications that aren't set up, you can start them by using File 
Manager or by using MS-DOS commands. 

MS-DOS Prompt appears as a program item in the Main group in Program 
Manager. You can use it to access the MS-DOS command prompt without 
leaving Windows. 

~ To start MS-DOS Prompt 

1. In Program Manager, choose the Main group icon. 

2. In the Main group, choose the MS-DOS Prompt icon. 

Or use the arrow keys to move the selection cursor to the icon, and then press 
ENTER. 

When the MS-DOS command prompt appears, you can type the necessary 
MS-DOS commands to start your non-Windows application. 
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~ To quit MS-DOS Prompt 

1. At the MS-DOS command prompt, type the following: 

exit 

2. Press ENTER. 

You can also leave MS-DOS running and switch back to Windows to work with 
applications. For more information, see "Switching Between Applications" later in 
this chapter. 

Caution Some MS-DOS commands do not work properly when Windows is 
running. For example, when you use the chkdsk command with the If option, 
chkdsk tries to modify part of the operating system that cannot be modified while 
Windows is running. Other operations you should avoid running from Windows 
include the undelete command and disk-compaction or optimization programs, 
such as the Norton SD.EXE program. If you need to run such operations, quit 
Windows first. 

Running Two or More Applications 
With Windows, you can start an application and then keep it running while you 
start one or more additional applications. 

When applications run at the same time, they share your computer's resources. 
The way they share resources depends on the type of computer you have, the type 
and amount of available memory, whether the applications are Windows or non­
Windows, and which mode Windows is running in. 

Note When Windows is running in 386 enhanced mode rather than in standard 
mode, more applications can run simultaneously. To find out which mode 
Windows is running in, choose the About command from the Help menu in any of 
the applications in the Main or Accessories group (except Windows Setup). 

Switching Between Applications 
When you have more than one application window open at once, the window 
you are currently working with is the active window. The active window always 
appears in the foreground, so it might overlap or completely obscure other 
windows. To work with another application, you must select its window to 
make it active. 
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~ To switch to an application, use one of the following methods 

• If the application is visible, click anywhere in the application's window. If the 
application is running as an icon, choose the icon. 

• To return to the application you last used, press ALT+TAB. 

• To switch quickly to another application, press and hold down ALT, and then 
press TAB repeatedly. As you continue to press TAB, you see the title of each 
open application. 

When the title of the application you want appears in the center of your screen, 
release ALT. The application appears in the foreground. 

• Press ALT+ESC repeatedly to cycle through open application windows and 
application icons until you reach the application you want. 

• Display Task List, and use it to switch to the application you want. (You 
can display and use Task List in several ways. For more information, see 
"Arranging Application Windows and Icons," later in this chapter.) 

Note If you use an application frequently, you may want to create a shortcut key 
to use when switching to it. You can define a shortcut key in the Program Item 
Properties dialog box in Program Manager. For more information, see Chapter 3, 
"Program Manager." 

Using Task list to Switch Between Applications 
Task List is a window that displays a list of all the applications you are currently 
running. You can use Task List to switch to another application. 

~ To switch to an application by using Task List 

Mouse 

1. Double-click anywhere on the desktop (that is, not inside an open window) to 
display Task List. 

Or choose Switch To from the Control menu in Program Manager. 
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2. In Task List, double-click the name of the application you want to switch to. 

Or select the name of the application you want, and then choose the Switch To 
button. 

Control Panel 
Sound Recorder - (Untilled) 
Notepad - README. TXT 
Calculator 
Object Packager - Package 

Keyboard 

1. Press CTRL+ESC to display Task List. 

Or choose Switch To from any Control menu. 

2. Press the UP ARROW or DOWN ARROW key to move the selection cursor to the 
application you want. 

Or type the first letter of the application name. 

3. Press ENTER. 

Note You can close Task List at any time by pressing ESC or by choosing the 
Cancel button. 

Arranging Application Windows and Icons 
You can use the Cascade and Tile buttons in Task List to rearrange application 
windows so that all running applications are visible on your desktop. The Cascade 
command causes the windows to overlap so that each title bar is visible. The Tile 
command arranges the open windows in smaller sizes to fit next to each other on 
the desktop. 

~ To arrange application windows on your desktop 

1. Double-click anywhere on the desktop to open Task List. 

Or press CTRL+ESC. 

2. Choose the Cascade or Tile button. 
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If you have a number of applications running as icons and they are scattered 
across your desktop, follow the next procedure to rearrange them evenly. 

~ To rearrange application icons 

1. Double-click anywhere on the desktop to open Task List. 

Or press CTRL+ESC. 

2. Choose the Arrange Icons button. 

The icons are arranged along the lower edge of the desktop. 

Tip You can also open Task List by choosing Switch To from an application's 
Control menu. 

Dragging Icons to Perform Tasks 
When using File Manager, Program Manager, Print Manager, and certain other 
Windows applications, you can perform some essential tasks by dragging File 
Manager file icons from one place to another with the mouse. This is known as 
"dragging and dropping." 

For example, you can print a file on your default printer by dragging a File 
Manager file icon onto the Print Manager icon (the minimized Print Manager 
window) and then releasing the mouse button. Or you can set up an application to 
run with Windows by dragging a File Manager file icon onto a group window or 
icon in Program Manager. 

For more information about using File Manager, see Chapter 4, "File Manager." 
For more information about using Program Manager, see Chapter 3, "Program 
Manager." 

Note Dragging File Manager icons can only be done by using a mouse. There is 
no keyboard equivalent. 

~ To drag and drop an icon 

1. In the Main group, double-click the File Manager icon to start File Manager. 

2. Open the directory containing the file you want to drag. 

3. Make sure the application where you want to drag the icon is running either as 
a window or an icon. 

4. Arrange the windows on your screen so that both the File Manager file you 
want to drag and the application window or icon you want to move the file onto 
are visible. 

Tip Display Task List, then choose the Tile button. 
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5. Select the file you want. 

6. Press and hold down the left mouse button, drag the file onto the application 
window or icon, and then release the mouse button. 

You can perform the following tasks by dragging File Manager file icons. 

To 

Print a file on your default printer 

Create a Program Manager group item 

Move or copy a file to a File Manager 
directory 

Move or copy a file to a different drive 

Open a file in an application 

Drag the icon onto 

The minimized Print Manager window 
(Print Manager running as an icon) 

A Program Manager group window or icon 

A File Manager directory window or 
directory icon 

A File Manager drive icon 

The application's icon or title bar 

Note The ability to print and open files by dragging and dropping icons depends 
on the application. Some applications may not support these processes. 

Transferring Information Between Applications by USing the Clipboard 
The Clipboard provides temporary storage for information you want to transfer. 
You can cut or copy information from an application onto the Clipboard and then 
transfer that information from the Clipboard into other applications. You can also 
use the Clipboard to share information between files in a powerful new way called 
object linking and embedding. For more information, see Chapter 13, "Integrating 
Your Windows Applications." 

Information you cut or copy onto the Clipboard remains there until you clear the 
Clipboard, cut or copy another piece of information onto it, or quit Windows. 
Because the information remains on the Clipboard, you can paste the information 
into a file as often as you like. 

Cutting or Copying Information onto the Clipboard 
The method you use to transfer information onto the Clipboard depends on 
whether you are using a Windows or non-Windows application and whether it is 
running in a window or a full screen. For information about cutting or copying 
information onto the Clipboard from a non-Windows application, see Chapter 7, 
"Non-Windows Applications." 

If you are using a Windows application, you can cut or copy selected information 
onto the Clipboard. You can also copy an image of the entire desktop or of a 
single window for any application running in a window. 
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~ To cut or copy information onto the Clipboard 

1. Select the information you want to cut or copy. (For information about select­
ing text in Windows, see "Selecting Text" later in this chapter.) 

You can cut or copy text, graphics, or a combination of text and graphics. 

2. From the application's Edit menu, choose Cut or Copy. 

Use the Cut command to remove information from a file and place it onto the 
Clipboard. 

Use the Copy command to place a copy of the information onto the Clipboard, 
leaving the information in its original location as well. 

Copying an Entire Screen You can copy the contents of an entire screen onto 
the Clipboard from applications that support this feature. 

~ To copy the contents of an entire screen onto the Clipboard 

1. Make sure the information you want to copy is on the screen. 

2. Press PRINT SCREEN. 

A "snapshot" (bitmap) of the screen is placed onto the Clipboard. 

Tip If this procedure doesn't work, press ALT+PRINT SCREEN or SHIFT+PRINT 

SCREEN. Some keyboards might not recognize PRINT SCREEN alone. 

Copying an Entire Window To use the following procedure, the application you 
want to copy information from must be running in the active window. 

~ To copy the contents of the active window onto the Clipboard 

1. Make sure the information you want to copy is in the active window. 

2. Press ALT+PRINT SCREEN. 

A "snapshot" (bitmap) of the active window is placed onto the Clipboard. Not 
all applications can read bitmaps (.BMP files). Make sure the application you 
want to paste the information into accepts the bitmap format. 

Tip If this procedure doesn't work, press SHIFT+PRINT SCREEN. Some keyboards 
might not recognize ALT+PRINT SCREEN. 

Pasting Information from the Clipboard 
You can paste information from the Clipboard into an application at any time. 
Make sure the application you want to paste the information into accepts the 
bitmap format if you copied an entire screen or window onto the Clipboard. 
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Information you cut or copy onto the Clipboard remains there until you change it, 
clear it, or quit Windows. The method you use to paste information depends on 
whether you are pasting into a Windows or a non-Windows application. For infor­
mation about pasting information into a non-Windows application, see Chapter 7, 
"Non-Windows Applications." 

~ To paste information into a Windows application 

1. Make sure the information you want to paste is on the Clipboard. (For informa­
tion about viewing the Clipboard's contents, see the following section.) 

2. Start the application. 

3. Place the insertion point at the place you want the information from the 
Clipboard to appear. 

4. From the application's Edit menu, choose Paste. 

Using Clipboard Viewer 
By using Clipboard Viewer, you can view, save, retrieve, and delete the contents 
of the Clipboard. 

~ To view the contents of the Clipboard 

1. Switch to Program Manager. 

2. Open the Main group. 

3. Choose the Clipboard Viewer icon. 

Note Sometimes Windows changes the line length of the information you copy or 
cut so that all of it is included in the Clipboard Viewer window. When you paste 
the information from the Clipboard into the destination application, however, the 
information is intact. 

The Clipboard accepts a number of text and graphics formats. When you transfer 
information from one application to another, the original application places the in­
formation onto the Clipboard in formats the Clipboard recognizes. The application 
you paste the information into then selects the format that is most compatible (the 
application's default format). 

You can view the information on the Clipboard in any of the formats that were 
supplied by the original application. 

~ To view another format 

• From the Display menu, choose a different format. 
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~ To return to the first format that was displayed 

• From the Display menu, choose Auto. 

You can save the contents of the Clipboard in a file. You can later retrieve the file 
and paste its contents into an application. You can view the file you save by using 
Clipboard Viewer. 

~ To save the contents of the Clipboard to a file 

1. Switch to Program Manager. 

2. Open the Main group. 

3. Choose the Clipboard Viewer icon. 

4. From the File menu, choose Save As. 

The Save As dialog box appears. 

5. Type a filename for the contents of the Clipboard. The default extension for a 
Clipboard file is .CLP. 

You can also type a path if you want to store the Clipboard file in a different 
directory. 

6. Choose the OK button. 

You can open a Clipboard file and then paste it into any application. Only files 
with a .CLP extension can be opened in Clipboard Viewer. 

~ To retrieve a Clipboard file 

1. Switch to Program Manager. 

2. Open the Main group. 

3. Choose the Clipboard Viewer icon. 

4. From the File menu, choose Open. 

The Open dialog box appears. 

5. Select the .CLP file you want to retrieve. (For information about using the 
Open dialog box, see Chapter 1, "Windows Basics.") 

6. Choose the OK button. 

Note If the Clipboard already contains information, you are prompted to clear it. 
If you choose the OK button, the current contents of the Clipboard are replaced by 
the contents of the file you specified. 
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If you need more memory to run an application, you can clear the Clipboard. 
Since the Clipboard stores information in multiple formats, clearing it might free 
some memory. 

~ To clear the Clipboard 

1. Switch to Program Manager. 

2. Open the Main group. 

3. Choose the Clipboard Viewer icon. 

4. From the Edit menu, choose Delete. 

Or press DEL. 

5. Choose the OK button. 

Receiving a Message from an Inactive Application 
When an inactive application issues a status or error message, the application's 
title bar or icon flashes, and you may hear a beep. 

~ To receive a status or error message 

• Select the application window or icon. 

The message appears as soon as you select the window or icon. 

Quitting an Application 
There are various ways to quit an application. 

~ To quit a Windows application 

• From the application's File menu, choose Exit. 

Or choose Close from the Control menu. 

Or press ALT+F4. 

Or double-click the Control-menu box. 

If you are working on a document and you haven't yet saved your changes, you 
are prompted to save them. 
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~ To quit a non-Windows application 

• Choose the application's exit or quit command. 

Or, if you are using MS-DOS Prompt, type exit at the command prompt. 

The application closes, and you return to Windows. 

Note When you quit a non-Windows application that is running in a full screen, 
you usually return to the Windows desktop just as you left it. However, you can 
change a setting in the application's program information file (PIF) so that you 
return to what's called an inactive window. 

The inactive window captures information from the application that was displayed 
as you quit the application. Sometimes that type of information stays on the screen 
too briefly to be read, making the inactive window a convenient feature. For infor­
mation about creating and modifying a PIF, see Chapter 8, "PIF Editor." 

Working with Documents 

Opening Files 

This section explains some basic tasks, such as opening, editing, and saving files, 
that are common to many Windows applications. For information about organiz­
ing your applications and documents, see Chapter 3, "Program Manager," and 
Chapter 4, "File Manager." 

Note The procedures in this section apply to the applications supplied with 
Windows. Other applications might work differently. 

Choosing the Open command from an application's File menu opens a dialog box 
that is often the same regardless of which application you are using. This dialog 
box is designed to save you time because you can select the drive, directory, file, 
and file type from the ones displayed in the list boxes. 

~ To open a file 

1. From the application's File menu, choose Open. 

The Open dialog box appears. 
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2. If the file you want to open is on a different drive, select the drive you want 
from the Drives box. 

3. In the Directories box, choose the directory you want to open. (Double-click the 
directory, or press the UP ARROW or DOWN ARROW key to select the directory, 
and then press ENTER.) 

Windows displays the names of all files in that directory that are the type 
selected in the List Files Of Type box. To display a different type of file, select 
the type you want from the List Files Of Type box. 

4. From the list of files, select the file you want to open. 

Some applications provide a check box to specify that the file be read-only 
(which means changes cannot be made to the file). If you want the file to be 
read-only, select this check box. 

5. Double-click the filename. 

Or choose the OK button. 

In many applications, the File menu contains two commands for saving files: Save 
and Save As. You use the Save command to save changes to an existing file. You 
use the Save As command to name and save a new file or to save an existing file 
under a new name. For example, you might want to make changes to a file, yet 
keep a copy of the file as it existed before you began working on it. By using the 
Save As command, you can save another copy of the original file by giving it a 
different name. 
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~ To save an existing file 

• From the application's File menu, choose Save. 

~ To save a new file or an existing file under a new name 

1. From the application's File menu, choose Save As. 

The Save As dialog box appears. 

2. If you want to save the file on a different drive, select the drive you want from 
the Drives box. 

3. In the Directories box, choose the directory in which you want to save the file. 
(Double-click the directory, or press the UP ARROW or DOWN ARROW key to 
select the directory, and then press ENTER.) 

4. In the File Name box, type a name for the file. 

If you don't specify a filename extension, the application may add one. For 
example, Windows Notepad adds the extension .TXT to a filename. 

The default extension is shown in the Save File As Type box. To use a 
different extension, select the extension from the Save File As Type list, 
or type an extension. 

5. Choose the OK button. 

Switching Between Documents 
With some applications, you can open more than one document at a time, each in 
its own window. If you have more than one document window open, you can 
easily switch between them. 

~ To switch to another document window in an application 

• Click anywhere in the document window you want to switch to. 

Or open the application's Window menu, and choose the document you want. 

Tip Press CTRL+F6 or CTRL+TAB repeatedly until the document you want is 
selected. This is a shortcut for using the Next command on the Control menu. 

Working with Text 
With many applications, you type text from time to time. The procedures for 
typing text, correcting errors, and editing text are the same for most Windows 
applications. 
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Typing Text 
When you start typing text, an insertion point (flashing vertical bar) marks the 
place where the text will appear. 

~ To type text in a new document 

• Begin typing the text. 

Press ENTER to move the insertion point to the next line. Press the SPACEBAR to 
move the insertion point one space to the right. 

~ To type text in an existing document 

• Move the mouse pointer to where you want text to appear, click once, and then 
start typing. 

Or use the arrow keys to move the insertion point to the place you want text to 
appear. 

Note To create a blank line, and move the insertion point along that line, you need 
to use ENTER and the SPACEBAR. For example, to type a report title 10 lines from 
the top of a new page and 20 spaces from the left margin, you press ENTER 10 
times and then press the SPACEBAR 20 times before you type the title. 

Moving Within Text 
You can easily move the insertion point wherever you want within text. 

Press 

DOWN ARROW 

UPARROW 

END 

HOME 

PAGE DOWN 

PAGE UP 

CTRL+RIGHT ARROW 

CTRL+LEFT ARROW 

CTRL+END 

CTRL+HOME 

To move to 

The next line 

The previous line 

The end of the line 

The beginning of the line 

The next screen 

The previous screen 

The next word 

The previous word 

The end of the document 

The beginning of the document 
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Correcting Typing Mistakes 
If you make a mistake while typing, you can correct it by using one of the methods 
in the following table. Or, if you need to change more than a few characters, you 
can select the text and edit it. 

Do this 

Press BACKSPACE 

Press DEL 

Type the characters 

Selecting Text 

To 

Delete the character (or selected text) to the left of the 
insertion point. 

Delete the character (or selected text) to the right of the 
insertion point. 

Insert characters at the insertion point. 

You can make changes to blocks of text by selecting (highlighting) the text you 
want to change, and then choosing one of the commands from the application's 
Edit menu. 

~ To select text 

Mouse 

1. Point to the first character you want to select. 

2. Drag the insertion point to the last character you want to select. 

3. Release the mouse button. 

To cancel the selection, click again anywhere in the document. 

Tip With some applications, you can select a single word by double-clicking it. 

Keyboard 

1. Use the arrow keys to move the insertion point to the first character you want to 
select. 

2. Press and hold down SHIFT while you use the arrow keys to move the insertion 
point to the last character you want to select. 

3. Release the keys. 

To cancel the selection, press an arrow key. 

Tip With some applications, you can select all the text in your file. From the Edit 
menu, choose Select All. 
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The following table shows other ways to select text by using the keyboard. Not 
all applications offer all options. In most cases, you can select an area of text 
by pressing and holding down SHIFf while you use the standard movement 
keystrokes. For information about valid key combinations, see the documen­
tation about your application. 

Press To 

SHIFT +DOWN ARROW Extend the selection to the next line. Or, if the next line 
is already selected, use these keys to cancel the selec­
tion. 

SHIFT + UP ARROW Extend the selection to the previous line. Or, if the pre­
vious line is already selected, use these keys to cancel 
the selection. 

SHIFT +END Extend the selection to the end of the line. 

SHIFT +HOME Extend the selection to the beginning of the line. 

SHIFT +PAGE DOWN Extend the selection down one screen. Or, if the next 
screen is already selected, use these keys to cancel the 
selection. 

SHIFT +PAGE UP Extend the selection up one screen. Or, if the previous 
screen is already selected, use these keys to cancel the 
selection. 

CTRL+SHIFT +RIGHT ARROW Extend the selection to the next word. Or, if the next 
word is already selected, use these keys to cancel the 
selection. 

CTRL+SHIFT +LEFT ARROW Extend the selection to the previous word. Or, if the pre­
vious word is already selected, use these keys to cancel 
the selection. 

CTRL+SHIFT +END Extend the selection to the end of the document. 

CTRL+SHIFT +HOME Extend the selection to the beginning of the document. 

Editing Selected Text 
The following table describes ways you can edit text that has been selected. For 
more information, see "Transferring Information Between Applications by Using 
the Clipboard" earlier in this chapter. 

Do this 

Choose Cut from the Edit menu 

Choose Copy from the Edit menu 

Type the new text 

Press DEL or BACKSPACE 

To 

Delete the selected text and place it onto the 
Clipboard. 

Make a copy of the selected text and place it 
onto the Clipboard. 

Replace the text with new text. 

Delete the text. (It is not placed onto the 
Clipboard. ) 
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Do this 

Choose Undo from the Edit menu 

Place the insertion point where 
you want the text to appear, and 
choose Paste from the Edit menu 

Practicing Basic Skills 

To 

Cancel the previous editing operation. 

Paste text from the Clipboard into the active 
window. 

If you are new to Windows or you want to explore some of the newest features in 
Windows, you may want to play Solitaire or Minesweeper to practice some of the 
skills described in this chapter and in Chapter 1, "Windows Basics." These games 
were copied to your hard disk when you set up Windows. 

Both games provide a rich graphical environment that utilizes many of the most 
powerful features in Windows. Play while you learn to use online Help, open 
menus and select items, move and resize application windows, work with dialog 
boxes, and switch between applications. 

You start Solitaire or Minesweeper just as you start any other application. For 
information, see "Starting an Application" earlier in this chapter. 

Running the Microsoft Windows Tutorial 
The Windows Tutorial is an interactive, online program that teaches you the basics 
of using a mouse and Windows. To use the Tutorial, you need a mouse and a 
VGA (or better) monitor. 

~ To run the Tutorial from Windows 

Mouse 

1. Switch to the Program Manager window. 

2. Click the Help menu, and then click the Windows Tutorial command. 

Keyboard 

1. Switch to the Program Manager window: Press and hold down ALT, and then 
press TAB repeatedly until "Program Manager" appears in the small window in 
the middle of your screen. Then release both keys. 

2. Press ALT, H to display the Help menu. 

3. Press w. 

Or press the DOWN ARROW key to select Windows Tutorial, and then press 
ENTER. 
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Chapter 3 

What Is Program Manager? 
Windows Program Manager is an application that is central to the Microsoft 
Windows operating system. It starts whenever you start Windows and continues to 
run as long as you are working with Windows. You can use Program Manager to 
start other applications and organize applications and files into groups that make 
sense to you. 

Starting an application from Program Manager is easy: You choose the icon for 
the application you want to use, and Program Manager does the rest. When you 
run other applications, Program Manager runs either in the background, or as an 
icon on your desktop. 

The first time you start Windows, Program Manager opens on your desktop with 
the Main group window open inside the Program Manager window. 

., 
Windows 

Setup 

@ ~ 
PIF Editor Read Me 

m m [fiE m 
Accessories Games StartUp Applications 
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The StartUp group, the Applications group, the Accessories group, and the 
Games group are represented as group icons along the lower edge of the Program 
Manager window. (If you chose the Custom Setup option and chose not to have 
Windows set up applications from your hard disk, the Applications group icon 
does not appear.) All of these groups contain icons that represent applications, or 
program-item icons. 

Program-item icon 

>@ ~ 
Windows PIF Editor Read Me 

Setup 

Accessories Games StartUp 

Group icons Group window 

The following elements are part of the Program Manager window: 

• A group window is a separate window inside the Program Manager window. It 
contains icons that start applications, or program-item icons. There can be more 
than one group window, each with its own Control menu but no menu bar. 
Group windows are affected by commands from the Program Manager menu 
bar. These windows cannot be moved outside the Program Manager workspace. 

• A group icon is a minimized group window. Group icons are located along the 
lower edge of the Program Manager window and all look alike. However, there 
is a unique label below each icon so that it can be distinguished from the others. 
Like group windows, they cannot be moved outside the Program Manager 
workspace. 

• Program-item icons appear inside a group window and represent the applica­
tions, accessories, and documents you can start from Windows. Choosing a 
program-item icon starts the application that icon represents. Program-item 
icons can be moved between groups but not outside them. 

Most program-item icons have a unique appearance, making them easy to iden­
tify at a glance. However, some applications use identical program-item icons. 
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Also, when you create several program items for one application, the icons look 
the same. 

For example, suppose you want a group to include several documents to be 
loaded whenever you start a particular application. You can add a program item 
for each document. The resulting group contains several program-item icons 
that look like the original icon for the application, but their labels distinguish 
them. For more information, see "Creating a Program Item" later in this 
chapter. 

Working with Groups 
A group contains program items, which are icons that represent an application, an 
accessory, or a document. Choosing a program-item icon from a group can start an 
application or accessory, or start an application and open a related document at the 
same time. When adding a program item to a group, you can specify how you 
want the application to start. 

Windows has several predefined groups, each containing program-item icons, as 
described here: 

• The Main group contains the Windows system applications: File Manager, 
Control Panel, Print Manager, Clipboard Viewer, MS-DOS Prompt, Windows 
Setup, and PIF Editor (a tool for editing program information files). This group 
also contains an item named Read Me, which contains information you should 
know before you start working with Windows. 

Note If you upgraded from Windows version 3.0, PIF Editor remains in the 
Accessories group. 

• The Applications group contains applications found on your hard disk during 
Setup. (If you chose the Custom Setup option and chose not to have Windows 
set up applications from your hard disk, your Program Manager window will 
not contain an Applications group.) 

• The Accessories group includes Windows applications for word processing, 
drawing, and communications, plus several other useful applications, such as a 
clock and a calculator. 

• The Games group offers games you can use to practice the basic skills you 
learn as you operate Windows, or to give yourself a relaxing break from work. 

• The StartUp group contains applications that start when you start Windows. 
You can add any applications you want to this group. This group is empty until 
you add applications to it. 

You start an application from a group by opening the group window and choosing 
the program-item icon for the application you want to run. 
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Program Manager also provides a way to organize groups visually. You can con­
trol how the groups of applications are arranged on your desktop. 

If you remove any of the predefined groups, you can recreate them by running the 
Setup program from Program Manager. 

Opening Group Windows and Reducing Them to Icons 
To start an application from a group, you must first open the group window that 
contains the program-item icon for that application. Once you have started the 
application, you can then reduce the group window to an icon to make room on 
your desktop. 

~ To open a group window 

• Double-click the group icon. 

Or press CTRL+F6 or CTRL+ TAB until the group icon you want is selected. (You 
can also select the group name from the list at the bottom of the Window 
menu.) Then press ENTER. 

~ To reduce a group window to an icon 

• Click the Minimize button. 

Or press ALT, HYPHEN (-) to open the Control menu for the group, and then 
choose Minimize. 

Or double-click the Control-menu box for the group. 

Or choose Close from the Control menu for the group. 

Rearranging Group Windows 
When you open several group windows at a time, some windows are hidden 
beneath others. You can use the Cascade and Tile commands on the Window 
menu to rearrange all the group windows so that some part of each window is 
visible. 

The Cascade command resizes and layers the open group windows within the 
Program Manager workspace so that each title bar is visible, as shown in the 
following illustration. 
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[fill rn 
StartUp Applications 

The Tile command resizes and arranges the open group windows side by side in 
the Program Manager workspace. Not all the program-item icons may be visible in 
the allotted space for each group. The following illustration shows tiled windows. 

Minesweeper 

Windows PIF Editor 
Setup 

StartUp Applications 

If you open another group window after you use the Cascade or Tile command, it 
overlaps the rearranged windows. To include it among the rearranged windows, 
choose the Cascade or Tile command again. 

~ To rearrange all the open group windows 

• From the Window menu, choose Cascade or Tile. 

Or press SHIFT +FS for Cascade or SHIFT +F4 for Tile. 
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Arranging Group Icons 
You can move any group icon within the Program Manager workspace by drag­
ging it with the mouse or by using the Move command on the Control menu for 
the group. 

You can also move program-item icons between group windows or onto group 
icons. For information about copying and moving program-item icons, see 
"Working with Program Items" later in this chapter. 

~ To rearrange group icons 

1. Select any group icon. 

2. From the Window menu, choose Arrange Icons to distribute the group icons 
evenly along the lower edge of the Program Manager window. 

Using the mouse, you can drag individual icons to a new location. Using the 
keyboard, press ALT, HYPHEN (-) to open the Control menu for the group icon. 
Choose the Move command and use the arrow keys to move the icon to the 
location you want, and then press ENTER. 

~ To rearrange program-item icons 

1. Select the group window that contains the program-item icons you want to 
rearrange. 

2. From the Window menu, choose Arrange Icons to distribute the program-item 
icons evenly within the selected group window. 

Or, using the mouse, drag the individual icons to a new location. 

You can also have Windows automatically rearrange program-item icons when­
ever you change the window size, add new items, or move items from place to 
place. 

~ To have Windows automatically rearrange icons 

• From the Options menu, choose Auto Arrange. A check mark beside the 
command means it is in effect. 

Creating and Deleting Groups 
You can add any number of groups to Program Manager to organize your appli­
cations and documents in a way that makes sense to you. If you no longer need a 
group, you can delete it and free some space on your desktop. 
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~ To create a new group 

1. From the File menu, choose New. 

The New Program Object dialog box appears. 

2. Select the Program Group option, and then choose the OK button. 

The Program Group Properties dialog box appears. 

3. In the Description box, type a description for the group you want to create. This 
description will appear in the title bar of the group window and below the group 
icon. 

4. Choose the OK button. 

Because Program Manager creates a .GRP file for the new group, you can leave 
the Group File box blank. 

After creating a group, you can add program items to it. For more information, see 
"Creating a Program Item" later in this chapter. 

~ To delete a group 

1. Make sure the group you want to delete is reduced to an icon. 

2. Click the icon for the group you want to delete. 

Or press CTRL+F6 or CTRL+ T AB repeatedly until you reach the group icon you 
want to delete. 

3. From the File menu, choose Delete. 

Or press DEL. 

A dialog box appears, prompting you to confirm that you want to delete the 
group. 

4. To remove the group, choose the Yes button. 

Program Manager deletes the group you selected and any program-item icons 
in it. However, program and data files for the deleted program items are not 
removed from your hard disk. 
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You can also delete a group by first deleting all of the program items contained in 
it, and then deleting the group. When you use this method, the group doesn't have 
to be reduced to an icon before you delete it. Deleting program items is discussed 
later in this chapter. 

Changing the Description of a Group 
You can change the description of any group. The description is the label for the 
group icon and appears in the title bar of the group window. 

~ To change the description of a group 

1. Make sure the group whose description you want to change is reduced to an 
icon. 

2. Click the icon for the group whose description you want to change. 

Or press CTRL+P6 or CTRL+TAB repeatedly until you reach the group icon. 

3. From the File menu, choose Properties. 

The Program Group Properties dialog box appears. 

4. In the Description box, type a new description, and then choose the OK button. 

Note It is possible to make a group a read-only group. When a group is read-only, 
you cannot make changes to it. For example, you cannot change its description or 
properties, and you cannot delete or add icons. You can make a group read-only 
by switching to File Manager, selecting the group's file (a file with a .GRP 
extension, usually located in your Windows directory), and then choosing 
Properties from the File menu. 

Working with Program Items 
As described earlier, a program item represents an application, accessory, or docu­
ment in a Windows group. By choosing the icon for a program item, you start the 
application or accessory, or open the document. You can create new program 
items, copy or move program items from one group to another, or delete program 
items. 

Creating a Program Item 
When you create a program item for an application, you specify the program 
item's properties. Properties include such things as a description for the item, a 
working directory where any files the application creates are stored, and the icon 
that Windows uses to represent the application. After you create a program item, 
you can go back and change any of its properties. 
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Note The Working Directory, Shortcut Key, and Run Minimized properties are 
new to Windows version 3.1. If you create program items with these properties 
and then use the applications with an earlier version of Windows, these properties 
will be lost. 

You can create a program item by using any of the following methods: 

• Choose the New command from the File menu in Program Manager. 

• Drag files from File Manager. 

• Use Windows Setup. 

Note You cannot include more than 40 program items per group. 

~ To create a program item for an application by using Program Manager 

1. Open the group that you want to add an item to. 

2. From the File menu in Program Manager, choose New. 

The New Program Object dialog box appears. 

3. Select the Program Item option, and then choose the OK button. 

The Program Item Properties dialog box appears. 

Tip When creating a program item, you can quickly open the Program Item 
Properties dialog box by pressing and holding down ALT while double-clicking 
in a blank area of the group window. 

i!.escription: 

,C.ommand line: 

~ork.ing Directory: 

.s.hortcut Key: L-IN_on_e _____ --' 

o Run Minimized 

4. In the Description box, type a description that uniquely identifies the applica­
tion. The description becomes the label that appears under the icon in the group 
window. 

The description is optional. If you leave this box blank, Program Manager 
labels the icon for you. However, a description of your own can be very useful, 
especially if you set up multiple program items for the same application. 

5. In the Command Line box, type the name of the program file, including the 
path (if there is one) and extension. 
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For example, to add Microsoft Excel, located in a directory named C:\EXCEL, 
type c: \excel\excel.exe in the Command Line box. 

If you don't know the name of the program file, choose the Browse button to 
display a list of files and directories. Select the appropriate filename from the 
list. Then choose the OK button to place that filename in the Command Line 
box. (Y ou can use the directory listing to change to a different directory, if 
necessary. ) 

calc_exe 
calendar_ exe 
cardfile_ exe 
charmap_ exe 
clipbrd_ exe 
cloclcexe 
control-exe 
dosprmpLpil 

127 c:\ 
~windows 
LJ system 

List Files of !.I'pe: Drives: 

1-1 P_ro-=-.Qr_am_s ___ ---"Ili_] lliiiii c: chris 

6. In the Working Directory box, type the name of the directory where the 
program files for this application are located and where new files will be 
placed. The directory you specify here becomes the current directory while 
the application is running. 

7. To reserve a shortcut key for use with the application, type the key combination 
in the Shortcut Key box. You use a shortcut key to switch to the application 
when it is running. 

Valid shortcut-key sequences are CTRL+ALT+character, CTRL+SHIFT+character, 
CTRL+SHIFT+ALT+character, and CTRL+ALT+SHIFT+character. Character can be 
any letter, number, or special character. When you simply type a character in 
the Shortcut Key box, Program Manager adds CTRL+ALT in front of it. To 
specify a different control-key sequence, you must type the sequence. 

Note You can reserve shortcut keys for a non-Windows application by using 
Program Manager or PIF Editor. Shortcut-key settings made in Program 
Manager override settings made in PIF Editor. 

8. If you want this application to run as an icon when it starts, select the Run 
Minimized check box. When this box is selected, the application is reduced to 
an icon when it starts. 
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You may want to use this option for applications you have added to the StartUp 
group. If you use this method, the application starts and is reduced to an icon 
whenever you start Windows. 

9. Choose the Change Icon button to see the default icon for this program item. 
You can scroll through other available icons by clicking the scroll arrows or by 
using the LEFT ARROW and RIGHT ARROW keys. To change the icon, select the 
icon you want to use and then choose the OK button. 

For more information about changing an icon for a program item, see 
"Changing an Icon" later in this chapter. 

10. Choose the OK button. The dialog box closes, and the new program item 
appears in the group. 

You can also create a program item for a document. When you choose the 
program item, Windows starts the specified application and opens the specified 
document. 

~ To create a program item for a document by using Program Manager 

1. Follow the same first five steps as you would to create a program item for an 
application by using Program Manager. 

2. After the program's filename in the Command Line box, press the SPACEBAR, 

and type the filename of the document. Include the path required to locate the 
document. 

For example, to specify a spreadsheet named 92BUDGET.XLS, located in the 
C:\ADMIN\FY92 directory, as the document to be opened when you start 
Microsoft Excel, you would type the following: 

c: \excel\excel.exe c: \admin \fy92\92budget.xls 

Note If the document is in the same directory as the application, you do not 
have to repeat the path when you type the filename for the document. If you 
have specified a working directory that is different from the application 
directory, you must still specify a path with the document filename. 

3. Complete the dialog box, and then choose the OK button. 

You can also use File Manager to create program-item icons in Program Manager 
groups. You can move applications and associated documents from File Manager 
directories to Program Manager group windows or group icons. 
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The following procedure requires a mouse and has no keyboard equivalent. 

~ To create a program item by using File Manager 

1. Arrange your desktop so that you can see both File Manager and the group 
where you want to place the new program item. The destination group can be 
either a window or an icon. 

2. Open the File Manager window, and, if necessary, position and resize it. 

Tip If no other application windows are open, press CTRL+ESC to open Task 
List, and then choose the Tile button to arrange the File Manager and Program 
Manager windows. 

3. Locate and select the program or document file in File Manager that you want 
to add. (Y ou can also select multiple items and add them all to a group at the 
same time.) 

4. Drag the file icon from File Manager to Program Manager, and drop it in the 
group window or on the group icon. As you drag the file icon, the mouse 
pointer turns into a replica of a file icon. If you have more than one file or 
document selected, you see a multiple-file icon. 

By using Windows Setup, you can create a program item for an application that is 
already on your hard disk. When you use this method, the program item is added 
to the Applications group. (If you do not have an Applications group, you must 
first create one. For more information, see "Creating and Deleting Groups" earlier 
in this chapter.) 

~ To create a program item for an application by using Windows Setup 

1. In the Main group, choose the Windows Setup icon. 

The Windows Setup dialog box appears. 

2. From the Options menu in the dialog box, choose Set Up Applications. 

The Set Up Applications dialog box appears. 

3. If you want Windows Setup to search the hard disk for applications, select the 
Search For Applications option. To specify a particular application, select the 
Ask You To Specify An Application option. 

4. If you selected the Search For Applications option, another dialog box appears. 
From the Setup Will Search list, select the drive or path you want Setup to 
search. 
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5. Choose the Search Now button. 

Windows Setup searches for applications and lists the ones it recognizes in the 
Applications Found On Hard Disk(s) box. 

6. Select as many applications as you want to add from the Applications Found 
On Hard Disk(s) box. 

Click to select each application. (To clear the selection, click the application 
again.) 

Or use the arrow keys to move to the next application you want, and press the 
SPACEBAR to select it. (To clear the selection, press the SPACEBAR again.) 

7. After you select all the applications you want, choose the Add button to move 
them from the box on the left to the box on the right. 

If you change your mind about setting up an application after you add it, select 
it again, and choose the Remove button to return it to the box on the left. 

8. Choose the OK button. 

For each application you selected, Windows Setup adds a program-item icon to 
the Applications group. 

Deleting a Program Item from a Group 
Using Program Manager, you can easily delete a program item from a group. 
When you delete a program-item icon from a group, the application is not 
removed from your disk. 

~ To delete a program item from a group 

1. Open the group window that contains the item you want to delete. 

2. Select the program-item icon for the item. 

3. From the File menu, choose Delete. 

A confirmation message appears. 

4. Choose the Yes button. 

Copying Program Items from One Group to Another 
The easiest way to copy a program item from one group to another is to use the 
mouse to drag the program-item icon onto the other group icon or into the other 
group window. If you don't have a mouse, you can use the Copy command on the 
File menu. 
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~ To copy a program item to another group 

Mouse 

1. If you're not concerned with where the new program-item icon is placed in the 
group window, open the group window containing the program-item icon you 
want to copy, and leave the destination group reduced to an icon. 

If you want to place the new program-item icon in a particular location in a 
group window, open the group windows for both the source and the destination. 

2. Press and hold down CTRL while you drag the program-item icon from its cur­
rent location to the destination group's icon or window. 

The mouse pointer becomes a replica of the program-item icon you are copying. 

3. When the copied icon is on top of the destination group's icon or inside the 
destination group's window, release the mouse button and the CTRL key. 

Tip You can create a duplicate program item within a group by pressing CTRL 

while dragging the icon to another place in the window. 

Keyboard 

1. Open the group window that contains the program item you want to copy. 

2. Use the arrow keys to select the program-item icon. 

3. From the File menu, choose Copy. 

4. In the To Group box, select the name of the group you want to copy the 
program item to. 

5. Choose the OK button. 

Moving a Program Item to Another Group 
Moving a program item is easiest if you have a mouse. You can simply drag the 
program-item icon onto the other group icon or into a group window. If you don't 
have a mouse, you can use the Move command on the File menu. 

~ To move a program item to another group 

Mouse 

1. Open the group window that contains the program item you want to move. 

2. Drag the program-item icon to the destination group's icon or window. 

The mouse pointer becomes a replica of the program-item icon you are moving. 

3. When the program-item icon is on top of the destination group's icon or inside 
the destination group's window, release the mouse button. 
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Keyboard 

1. Open the group window that contains the program item you want to move. 

2. Use the arrow keys to select the program-item icon. 

3. From the File menu, choose Move. 

4. In the To Group box, select the name of the group you want to move the 
program item to. 

5. Choose the OK button. 

Changing an Icon 
When you add a program item to a group, Program Manager selects an icon for 
that item. You can change an icon in Program Manager by using the following 
methods: 

• If more than one icon is available for a program item, you can select a different 
icon by choosing Properties from the File menu and then choosing Change Icon 
in the Program Item Properties dialog box. You can scroll through the available 
icons by clicking the scroll arrows or by pressing the LEFT ARROW or RIGHT 

ARROW key. 

• You can use one of the many icons provided with Program Manager. First, 
select the program-item icon that you want to change. Choose Properties from 
the File menu, and then choose Change Icon in the Program Item Properties 
dialog box. In the File Name box, type the path for the PROGMAN.EXE file. 
You can now select any of the Program Manager icons to use with the selected 
program item. (If there are no icons available for the program item you 
selected, Windows displays the Change Icon dialog box with PROGMAN.EXE 
already specified.) 

• You can use one of the many icons designed especially for non-Windows 
applications. These are located in the MORICONS.DLL file. First, select the 
program-item icon that you want to change. Choose Properties from the File 
menu, and then choose Change Icon in the Program Item Properties dialog box. 
In the File Name box, type the path for the MORICONS.DLL file (this file is in 
your Windows directory). You can now select from these icons by scrolling 
through the Current Icon area. 

• You can adjust the spacing between icons by choosing the Desktop icon from 
Control Panel and then typing a number in the Icon Spacing box. For more 
information, see Chapter 5, "Control Panel." 
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Starting an Application from Program Manager 
By using Program Manager, you can easily find and start an application. You can 
also start an application from File Manager. For more information, see "Starting 
an Application from File Manager" in Chapter 4, "File Manager." 

Starting an Application from a Group 
If an application is represented by a program-item icon in a group, the easiest way 
to start the application is to choose the program-item icon from the group window. 
If you included a document with the program item, it appears in the application 
workspace. For more information, see "Creating a Program Item" earlier in this 
chapter. 

~ To start an application from a group 

1. Open the group window that contains the program-item icon for the application. 

2. Double-click the icon. 

Or use the arrow keys to select the icon, and then press ENTER. 

When you start an application, Program Manager changes the current directory 
to the directory you specified in the Working Directory box when you added the 
program item to the group. If you are using a non-Windows application, you can 
specify a working directory in either Program Manager or PIF Editor. Settings 
made in Program Manager override PIF Editor settings. For information about the 
working directory setting in Program Manager, see "Creating a Program Item" 
earlier in this chapter. For information about PIF Editor, see Chapter 8, "PIF 
Editor." 

You can use the following procedure to have an application run as an icon when 
you start the application. 

~ To run an application as an icon 

1. Open the group window that contains the program-item icon for the application. 

2. Press and hold down SHIFT while double-clicking the icon. 

Or use the arrow keys to select the icon, and then press SHIff +ENTER. 

You can have Windows reduce Pr()gram Manager to an icon whenever you start 
an application. This is useful because the icon remains visible on the lower edge of 
the desktop when most applications are running, making it easy to find when you 
want to switch to Program Manager. 
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~ To reduce Program Manager to an icon whenever you run an application 

• From the Options menu, choose Minimize On Use. 

A check mark (.I) appears beside the command when it is in effect. To cancel the 
command, choose it again. 

Starting an Application When You Start Windows 
When you install Windows by using the Setup program, Windows creates a 
StartUp group. When you set up a program item for an application in the StartUp 
group, Windows starts the application each time you start Windows. 

For example, if you want Windows to start File Manager whenever you start 
Windows, move the File Manager icon from the Main group to the StartUp group. 
Program items in the StartUp group run in the order their icons appear in the 
window (starting with the top row, and moving left to right). 

You can also have Windows automatically reduce an application in the StartUp 
group to an icon. You do this by selecting the Run Minimized check box when 
you are creating the program item, or by using the Properties command on the File 
menu. 

Returning to Program Manager from an Application 
When you are working with an application or document and you want to start a 
different application, you can do so by returning to Program Manager or by using 
File Manager. For information about using File Manager, see "Starting an 
Application from File Manager" in Chapter 4, "File Manager." 

~ To return to Program Manager, use one of the following methods 

Mouse 

• Click the Program Manager window, or double-click the Program Manager 
icon. 

If the Program Manager window is not visible, press ALT +ESC repeatedly until 
you reach it. 

• Double-click anywhere on the Windows desktop to display Task List, and then 
choose Program Manager from list of running applications. 
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Keyboard 

• Press CTRL+ESC to display Task List, and then choose Program Manager from 
the list of running applications. For more information about using Task List to 
switch between applications, see Chapter 2, "Application Basics." 

• Press and hold down ALT, and then press TAB repeatedly. As you continue to 
press TAB, you see the title of each open application. When Program Manager 
appears in the center of your screen, release ALT. The Program Manager 
window appears in the foreground. 

• If Program Manager appears as an icon, you can press ALT, SPACEBAR to open 
the Control menu. Then press ENTER to restore Program Manager to a window. 
Or first select the icon, and then press ENTER. 

Quitting Program Manager 
Even when you run applications, Program Manager remains running in the back­
ground. You must return to Program Manager before you end your Windows 
session. You cannot quit Program Manager without also quitting Windows. 

Before you quit Windows, you can choose to save any changes you made to the 
layout of Program Manager during your Windows session. If you do, Windows 
starts your next session with the Program Manager windows and icons arranged as 
they were at the end of the previous session. 

If you want to save the arrangement of Program Manager group windows and 
icons, you need to specify this before you quit Program Manager. You can save 
settings at any time, without quitting Program Manager. 

~ To save settings without quitting Program Manager 

• Press and hold down SHIFT, and then choose Exit Windows from the File menu. 

~ To save settings when you quit Program Manager 

• From the Options menu, choose Save Settings On Exit. 

A check mark appears next to the command. The next time you start Windows, 
the Program Manager workspace appears as it did when you last used it. 



Chapter 3 Program Manager 89 

~ To quit Program Manager (and Windows) 

1. Quit all applications that are running. 

2. From the File menu, choose Exit Windows. 

A confirmation dialog box appears, prompting you to confirm that you want to 
end your Windows session. 

3. Choose the OK button. 

Or from the Control menu, choose Close. 

Or double-click the Control-menu box. 





File Manager 

Chapter 4 

What Is File Manager? 
Windows File Manager is a powerful tool that can help you organize your files 
and directories. You can use File Manager to view all your files and directories 
and then build a directory structure that makes sense to you. 

You can use File Manager to move and copy files, start applications, connect to 
networks, print documents, and maintain disks. You can also associate a file with 
an application so that you can easily start the application and open the file at the 
same time. 

When you use File Manager, you work with directory windows. A directory 
window graphically displays the directory structure of your disk and the files and 
directories on the disk. 

~ To start File Manager 

• In the Main group, choose the File Manager icon. (Double-click the icon. Or 
use the arrow keys to move the selection cursor to the File Manager icon, and 
then press ENTER.) 

Note If you find that you run applications from File Manager most of the time, 
you can change the shell setting in your Windows system initialization file to read 
shell=winfile.exe. Then File Manager, instead of Program Manager, appears when­
ever you start the Microsoft Windows operating system. For information about 
changing the system initialization file, start Write (in the Accessories group), and 
open the SYSINLWRI file. 
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Working with a Directory Window 
When you first start File Manager, a directory window appears, displaying the 
contents of the current drive. This directory window is split: The left half displays 
the directory tree, and the right half lists the contents of the current directory . 

.... logo.bmp 

@jmar.wri 
I:'Sl mkreport. exe 

C:ltables @dnotes.txt 
D accounts.bak D sales.dat 
D accounts.dat I:'Sl showart. bat 
@dapr.wri 
~feb.wri 
@djan.wri 
D letters. log 

The directory tree shows the structure of the directories on a disk. The directory 
structure begins at the upper left with the root directory, the first directory on a 
disk. Other directories branch below the root directory. (The directory tree takes 
its name from this branching structure.) 

The root directory is created when you format a disk. It is represented by a 
backslash (\). For example, C:\ is the root directory for drive C. 

The contents list in the right half of the directory window shows the names of files 
and directories within the current directory. Directories within a directory are 
known as subdirectories. 

Note The split window is the default view for a directory window. For informa­
tion about displaying only the directory tree or only the contents of the current 
directory, see "Changing Views" later in this chapter. 

The parts of a directory window are shown in the following illustration. 
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Volume label or 
network name 

Current directory 
Directory icon 

The following table describes the elements in a directory window. 

Element 

Directory path 

Drive icons 

Volume label 

Network name 

Directory icon 

Current directory 

File icons 

Description 

The location of the current directory; it appears in the title bar of 
a directory window. 

Icons that represent the drives on your computer. A drive letter 
follows each icon. Different icons are used to represent the hard 
and floppy disk drives on your computer, network drives you are 
connected to, RAM drives you may have set up in your com­
puter's memory, and CD-ROM drives. 

The name that identifies your disk; it appears in brackets ([ ]) to 
the right of the drive icons. You see this information only if you 
have assigned a label to your disk. 

The name assigned to your network-drive connection. If a net­
work drive is selected, the network name is displayed instead of 
the volume label. 

An icon that represents a directory on your disk. In the directory 
tree, directory icons are connected by a vertical line to the 
directory level above them. In the contents list, directory icons 
represent directories in the current directory. 

The directory you are currently using; represented by an icon that 
looks like an open directory folder in the directory tree. File 
Manager commands affect the current directory or files within it. 

Icons that are next to filenames; they indicate file type. There are 
icons to represent program files, document files, and other types 
of files. For more information, see "Working with Files and 
Directories" later in this chapter. 
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Element 

Up icon 

Split bar 

Description 

The icon (shaped like an arrow) that takes you up one level in the 
directory tree. For more information, see "Changing Directories" 
later in this chapter. 

The bar that divides the window so that you can view both the 
directory tree and the contents list. For information about moving 
this bar to the left or right, see "Moving the Split Bar" later in this 
chapter. 

You can resize and move a directory window in the File Manager workspace. You 
can enlarge it to fill the entire workspace, or you can reduce it to an icon. For more 
information about working with windows, see Chapter 1, "Windows Basics." 

Selecting Files or Directories 
Before you can work with a file or a directory, you must select it. You can 
select a single file or directory, or several. Selecting more than one item is called 
extending a selection. When a file or directory is selected, its name and icon are 
highlighted in the directory window. 

Selecting a Single File or Directory 
In the contents list, you can select a single file or directory and then use File 
Manager commands to work with it. 

~ To select a tile or directory 

Mouse 

• In the contents list, click the filename or directory name you want to select. 

Keyboard 

1. Press TAB to move the selection cursor to the contents list. 

2. Use the following keys to select files and directories. 

Press 

UP ARROW or DOWN 
ARROW 

END 

HOME 

PAGE UP 

PAGE DOWN 

A letter or number 

To select 

A file or directory above or below the current 
selection. 

The last file or directory in the list. 

The first file or directory in the list. 

The file or directory at the top of the previous screen. 

The file or directory at the bottom of the next screen. 

The next file or directory that begins with that letter 
or number. 
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Extending a Selection 
In the contents list, you can select more than one file or directory at a time in order 
to perform a task with several files at once. For example, you may want to select 
several files and move them to another directory. You can select a group of files or 
directories that appear in consecutive order, or you can select items that are not in 
sequence. 

You can use the mouse or keyboard to select a group of files or directories visible 
in the contents list, or you can use the Select Files command to select any group of 
files. 

~ To select two or more items in sequence 

Mouse 

1. Click the first file or directory you want to select. 

2. Press and hold down SHIFT while you click the last item in the group. 

Keyboard 

1. Press TAB to move the selection cursor to the contents list, and then use the 
arrow keys to move to the first item you want to select. 

2. Press and hold down SHIFT while you use the arrow keys to select the remaining 
items in the group. 
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~ To select two or more items out of sequence 

Mouse 

• Press and hold down CTRL while you click each item. 

Keyboard 

1. Press TAB to move the selection cursor to the contents list, and then use the 
arrow keys to move to the first item you want to select. 

2. Press and release SHIFT +F8. 

The selection cursor begins to blink. 

3. Use the arrow keys to move to each remaining item you want to select. 

4. Press the SPACEBAR to select each item. 

5. Press SHIFT+F8 again when you finish extending the selection. 

~ To select more than one group of items 

Mouse 

1. To select the first group of sequential items, click the first item and then press 
and hold down SHIFT while you click the last item in the group. 

2. To select the next group of items, press and hold down CTRL while you click the 
first item. Then press and hold down CTRL+SHIFT while you click the last item in 
the group. 
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Keyboard 

1. Press TAB to move the selection cursor to the contents list. 

2. To select the first group of sequential items, press and hold down SHIFT while 
you use the arrow keys to move from the first to the last item in the group. 

3. Press and release SHIFT +F8. 

The selection cursor begins to blink. 

4. Use the arrow keys to move to the first item in the next group of items. 

5. Press the SPACEBAR to select the first item. 

6. Press SHIFT + an arrow key to select the remaining items in the group. 

7. Press SHIFT +F8 again when you finish extending the selection. 

... To select a group of items by using the Select Files command 

1. From the File menu, choose Select Files. 

The Select Files dialog box appears. 

=lb1i=--' __ -----ll :::: 
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2. In the Files box, type the name of the file you want to select. Use wildcards to 
specify a group of files. For example, to select all files with a . TXT extension, 
type * .txt. Or, to select all files in a directory, leave the default *. * in the Files 
box. 

3. Choose the Select button. 

The Cancel button changes to the Close button. 

4. Repeat steps 2 and 3 until you have selected all the files you want. 

You can choose the Deselect button at any time to cancel a selection. The 
Deselect button cancels the selected files that you specify in the Files box. 

5. Choose the Close button. 

Tip You can select all files in a directory by pressing CTRL+SLASH (I). 
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Canceling a Selection 
To cancel a selection, you can use mouse or keyboard techniques, or the Select 
Files command. You can cancel one selected file or a group of selected files. 

~ To cancel a selection 

Mouse 

• Press and hold down CTRL while you click the item. 

Keyboard 

1. If you have not already done so, press and release SHIFT +FS. 

The selection cursor begins to blink. 

2. Use the arrow keys to move to the selection you want to cancel. 

3. Press the SPACEBAR. 

4. Press SHIFT +FS. 

~ To cancel a group of selected files 

Changing Views 

1. From the File menu, choose Select Files. 

The Select Files dialog box appears. 

2. In the Files box, type the name of one of the selected files you want to cancel. 
You can use wildcards to specify a group of files or all files that are selected in 
a directory. 

3. Choose the Deselect button. 

4. Repeat steps 2 and 3 until you finish canceling selections. 

5. Choose the Close button. 

Tip You can cancel all selections by pressing CTRL+BACKSLASH (\). 

When you first start File Manager, the directory window displays both the 
directory tree for the current drive and the contents of the current directory. By 
using commands on the View menu, you can choose to display only the directory 
tree or only the contents of the current directory. 
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~ To display only the directory tree 

• From the View menu, choose Tree Only. 

The active directory window displays the directory tree for the current drive. 

~ To display only the directory contents 

• From the View menu, choose Directory Only. 

The active directory window displays the filenames and directories in the 
current directory. 

~ To display both the directory tree and the directory contents 

Changing Drives 

• From the View menu, choose Tree And Directory. 

The active directory window displays the directory tree for the current drive 
and the filenames and directories in the current directory. 

A directory window shows the directory structure of the current drive. The icon 
for the current drive is surrounded by a rectangle. 

You can change drives by selecting another drive icon in the directory window 
or by using the Select Drive command on the Disk menu. When you change to a 
different drive, the names of the files and directories on that drive are displayed in 
the directory window. 

~ To select another drive in a directory window 

Mouse 

• Click the drive icon representing the drive you want to use. 

Keyboard 

1. Press TAB or F6 to move to the drive icons. 

If you want to move back to the directory tree or contents area without 
changing drives, press TAB or F6 again. 

2. Use the arrow keys to select the drive icon you want, and then press the 
SPACEBAR. 

Tip You can change drives by pressing and holding down CTRL while typing the 
letter of the drive you want to select. 
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~ To change drives by using the Select Drive command 

1. From the Disk menu, choose Select Drive. 

Or double-click the background of the area where the drive icons are located. 

The Select Drive dialog box appears. 

A: 
B: 
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2. Select the drive you want to change to. 

3. Choose the OK button. 

Note When you change drives, File Manager searches the drive to display its con­
tents. You can press ESC at any time to stop the search. If you stop the search, only 
a partial directory tree is displayed, as indicated by the status bar at the bottom of 
the File Manager window. 

Changing Directories 
In the directory tree, the current directory is marked by the selection cursor, a 
dotted rectangle around the highlighted icon and text. You can select only one 
directory at a time in the directory tree. To change to a different directory, you 
move the selection cursor. 

~ To change to another directory in the directory tree 

Mouse 

• Click the directory name you want to change to. 

Keyboard 

• Use the following keys to change to a different directory. 

Press 

UP ARROW or DOWN 

ARROW 

HOME or BACKSLASH (\) 

END 

To change to 

A directory above or below the current directory. 

The root directory. 

The last directory in the list. 
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Press To change to 

RIGHT ARROW The first subdirectory of the current directory, if 
one exists and is displayed in the directory tree. 

LEFT ARROW or BACKSPACE The next directory level up from the current 
directory, if one exists. 

PAGE UP The directory one screen up from the current 
directory. 

PAGE DOWN The directory one screen down from the current 
directory. 

CTRL+UP ARROW The previous directory at the same level, if one 
exists. 

CTRL+DOWN ARROW 

A character key 

The next directory at the same level, if one exists. 

The next directory that begins with the specified 
letter or number. 

In the contents list, you can move up or down one level in the directory structure. 
You can go up one level by using the Up icon, and you can change to a sub­
directory (go down one level) by using the directory icons in the list. 

~ To change directories by using the contents list 

Mouse 

• Double-click the directory icon next to the name of the subdirectory you want 
to change to. 

Or double-click the Up icon if you want to move up one level. 

Keyboard 

• Use the arrow keys to select the appropriate directory icon or the Up icon, and 
then press ENTER. 

Or press BACKSPACE to go up one level. 

Expanding and Collapsing Directory Levels 
You can control the level of directory information shown in a directory window. 
When you first start File Manager, the directory tree shows the first level of 
directories on the current drive. You can use the commands on the Tree menu 
to expand and collapse the directory information shown. 

Expanding Directory Levels 
When you expand a directory, the names of the subdirectories in that directory are 
displayed in the directory tree. You can expand an entire branch, a single level of 
the branch, or all branches. 
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The following illustration shows a directory tree with the REPORTS directory 
expanded. 
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Expanded directory 

~ To expand one level of a directory 

• In the directory tree, choose the directory icon or the name of the directory you 
want to expand by double-clicking it or by selecting it and pressing ENTER. 

Or select the directory, and then choose Expand One Level from the Tree 
menu. 

~ To expand an entire branch 

1. In the directory tree, select the directory you want to expand. 

2. From the Tree menu, choose Expand Branch. 

Or press the ASTERISK (*) key. 

~ To expand all branches in the directory tree 

• From the Tree menu, choose Expand All. 

Or press CTRL+ASTERISK (*). 

Collapsing Directory levels 
You can collapse a directory so that subdirectories are not listed in the directory 
tree. All directories, except the root directory, are collapsed when you first start 
File Manager. 

~ To collapse a directory 

Mouse 

• In the directory tree, double-click the directory icon or the name of the 
directory you want to collapse. 
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Keyboard 

1. In the directory tree, use the arrow keys to select the name of the directory you 
want to collapse. 

2. From the Tree menu, choose Collapse Branch. 

Or press the HYPHEN (-) key. 

Displaying Expandable Directories 
If you want to know which directories have subdirectories, you can use the 
Indicate Expandable Branches command on the Tree menu. When you use this 
command, a plus sign (+ ) marks each directory that has subdirectories. The plus 
sign means you can expand the directory to display its subdirectories in the 
directory tree. After you expand a directory, the plus sign changes to a minus 
sign (-), indicating that the directory is expanded and can be collapsed. 

The following illustration shows a directory tree with the expandable directories 
marked. 

Expandable directory 

Collapsible directory 
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~ To mark expandable directories in the directory tree 

• From the Tree menu, choose Indicate Expandable Branches. 

File Manager displays the directory tree, marking each expandable directory 
with a plus sign. A check mark appears next to the command in the Tree menu. 

To tum off this feature, choose Indicate Expandable Branches again. 

Note If you choose the Indicate Expandable Branches command, File Manager 
may take longer to create the directory tree. 
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Opening More Than One Directory Window 
You can open additional directory windows that display the contents of the same 
drive or a different drive. It's useful to have more than one directory window dis­
played if you want to copy or move files from one drive to another. 

The following illustration shows File Manager with two directory windows open. 
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You can open a new directory window by choosing a drive icon in the directory 
window, by using the New Window command on the Window menu, or by 
choosing a directory icon in the directory tree. 

If you have two or more windows displaying the same drive and directory infor­
mation, a number appears in the title bar of each window, indicating there is more 
than one window displaying that directory. 

Note The new directory window has the same display options as the one you 
opened it from. For example, if you are working with a directory window that 
shows only the directory tree, and you open a new directory window, the new 
window displays only the directory tree. 
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~ To open a new directory window by using a drive icon 

Mouse 

• Double-click a drive icon. 

A new directory window appears, displaying the names of the files and 
directories on the drive you selected. 

Keyboard 

1. Press TAB to move to the drive icons. 

2. Use the arrow keys to select the drive icon you want, and then press ENTER or 
choose Open from the File menu. 

A new directory window appears, displaying the names of the files and 
directories on the drive you selected. 

~ To open a new directory window by using the New Window command 

• From the Window menu, choose New Window. 

A new directory window appears, displaying the same directory information as 
the previous active window. 

~ To open a new directory window by using the directory tree 

• Press and hold down SHIFT while you double-click a directory icon in the 
directory tree. 

Or select a directory icon in the directory tree, and then press SHIFT +ENTER. For 
information about selecting directories, see "Changing Directories" earlier in 
this chapter. 

The new directory window displays only the contents of the directory you 
selected; the directory tree is not displayed. 
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Selecting an Open Directory Window 
Although many directory windows can be open at the same time, only one of 
them is active. A directory window must be active before you can work in that 
directory. To make an inactive window active, you select it. When the window is 
selected, the title bar changes color or intensity and the window moves in front of 
the other open windows. 

~ To select an open directory window 

Mouse 

• Click anywhere in the window. 

Or choose a window name from the list at the bottom of the Window menu. 

Keyboard 

1. Press ALT, HYPHEN (-) to open the Control menu. 

2. Type t to choose Next. 

3. Repeat steps 1 and 2 until the window you want is selected. 

Or select the name of the window you want from the list at the bottom of the 
Window menu. Then press ENTER to open the window. 

To cycle quickly through the open directory windows, press CTRL+F6 

(or CTRL+ T AB) until the window you want is selected. 

Tip If the window you want to select is hidden by another window, you can use 
the Cascade or Tile command (on the Window menu) to rearrange the open 
directory windows so that all of them are visible. You can also move or resize 
windows that cover the window you want. For more information, see "Arranging 
Directory Windows" later in this chapter. 

Closing a Directory Window 
When you finish working with a directory window, you may want to close the 
window to clear space on your screen and free some of your computer's memory. 
If you have only one directory window open, you cannot close it. 
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~ To close the active directory window 

MOUlse 

• Double-click the Control-menu box, located in the upper-left comer of the 
directory window. 

Keyboard 

1. Press ALT, HYPHEN (-) to open the Control menu. 

2. From the Control menu, choose Close. 

Changing the Information Displayed in a Directory Window 
When you first start File Manager, the names of directories and files are listed 
alphabetically. You can change the order of the directories and files and also list 
details about them by using commands on the View and Options menus. 

The changes you make by using commands on the View menu affect the active 
directory window and any new windows you open from that window. Other open 
windows are not affected. 

Note To save the new settings, make sure the Save Settings On Exit command on 
the Options menu has a check mark next to it. For more information, see "Saving 
Your Settings" later in this chapter. 

Displaying Different Types of File Information 
You can use the commands on the View menu to indicate what kind of file infor­
mation you want displayed in a directory window. File Manager can display the 
name, size, last modification date and time, and attributes of files. 

When you first start File Manager, the Name command on the View menu has a 
check mark next to it, indicating it is in effect. This means that only the names of 
files and directories appear in a directory window. 

~ To display only names of files and directories 

• From the View menu, choose Name. 

Only the names of files and directories are displayed in the active directory 
window. 
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~ To display complete information about each file 

• From the View menu, choose All File Details. 

The file size, last modification date and time, and file attributes are displayed 
next to each filename and directory name in the active directory window. 

~ To display specific information about each file 

1. From the View menu, choose Partial Details. 

The Partial Details dialog box appears. 
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2. Select the check boxes of options you want to display, and clear the check 
boxes of options you don't want to display. The table that follows describes 
each option. 

3. Choose the OK button. 

You can select the following options in the Partial Details dialog box. 

Select 

Size 

Last Modification Date 

Last Modification Time 

File Attributes 

To 

Display the size (in bytes) of each file. 

Display the date each file was last modified, according to 
the system clock. 

Display the time of day each file was last modified, 
according to the system clock. 

Indicate whether files are hidden, system, archive, or 
read-only. (For more information, see "Setting File 
Attributes" later in this chapter.) 

Note The Name, All File Details, and Partial Details commands affect only the 
contents list in the active directory window. If the directory window is displaying 
only the directory tree, the window is not affected by these commands. 
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Sorting the Contents of a Directory 
By default, the contents of a directory are listed alphabetically, with directories 
listed first, followed by filenames. You can sort the files and directories by name, 
type, size, or the date the file was last modified. The Sort commands do not affect 
the directory tree. 

~ To sort files and directories alphabetically 

• From the View menu, choose Sort By Name. 

In the active directory window, first directories are sorted alphabetically, then 
files. 

~ To sort files and directories by type 

• From the View menu, choose Sort By Type. 

Directories and then files are listed alphabetically by extension in the active 
directory window. For example, files ending with .COM appear before files 
ending with .EXE. 

~ To sort files by size 

• From the View menu, choose Sort By Size. 

In the active directory window, directories are listed first; then files are listed 
by size, with the largest files listed first. 

~ To sort files and directories by last modification date 

• From the View menu, choose Sort By Date. 

In the active directory window, directories are listed first, sorted by date. Then 
files are listed by date, with the most recently modified file listed first. 

Choosing the Type of File to Display 
When you first start File Manager, the contents list (the right side of the directory 
window) displays the names of all the files and directories in the current directory, 
except hidden and system files. (For information about hidden and system files, 
see "Setting File Attributes" later in this chapter.) You can specify whether File 
Manager displays only certain types of files, or groups of files with similar 
filenames or extensions. 
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~ To specify which types of files are displayed in a directory window 

1. From the View menu, choose By File Type. 

The By File Type dialog box appears. 

File Tvpe ------, 
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2. To display files with similar names, you can use wildcards in the Name box. 
For example, to display only those files with the extension .TXT, you can type 
* .txt. The default is *. *, meaning all files in the directory are listed. (For more 
information about using wildcards, see your MS-DOS documentation.) 

3. Under File Type, select the types of files you want to display. The table that 
follows describes each option. 

4. To display hidden and system files, select the Show Hidden/System Files check 
box. 

5. Choose the OK button. 

The active directory window displays the types of files you selected. 

Under File Type in the By File Type dialog box, you can select the following 
options. 

Select 

Directories 

Programs 

Documents 

Other Files 

To 

Display the names of directories that are in the current directory. 

Display all filenames that have an .EXE, .COM, .PIF, or .BAT 
extension. 

Display the names of text or graphics files associated with an applica­
tion. For information about associating files, see "Associating Files 
with an Application" later in this chapter. 

Display all filenames not included in the preceding three options. 

Caution If you choose to display your hidden and system files, be careful not to 
rename or delete any of them. Your computer may not start or work properly 
without them. 
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Updating a Directory Window 
In most cases, File Manager updates open directory windows automatically. For 
example, if you save a file by using Write, its filename shows up immediately in 
the appropriate directory window. Sometimes, however, File Manager cannot 
complete an automatic update, especially if you are using network directories or if 
you change floppy disks. In this case, use the Refresh command to update the 
active directory window. 

~ To update a directory window 

• Click the drive icon for the current drive, or choose Refresh from the Window 
menu. 

Customizing and Arranging Directory Windows 
You can custonrize directory windows so that they are easy to find and use. You 
may want to arrange them so that you can see each one, or change fonts to make it 
easier to read the names of files and directories. You can also tum on or off the sta­
tus bar displayed at the bottom of your File Manager window. 

Moving the Split Bar 
In the default view, the directory window has a bar that splits the window into two 
sections. The split bar is located to the right of the directory-tree scroll bar. You 
can move this bar so that you have more room for the contents list or the directory 
tree. 

~ To move the split bar 

Mouse 

1. Move the mouse pointer to the split bar. 

The pointer turns into a double bar with two arrows. 

2. Press and hold down the mouse button, and move the pointer left or right to 
position the split bar. 

3. Release the mouse button. 
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Keyboard 

1. From the View menu, choose Split. 

A vertical bar appears. 
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2. Use the arrow keys to move the selection bar to where you want to place the 
split bar, and then press ENTER. 

If you decide you do not want to move the split bar, press ESC to cancel the 
command. 

Arranging Directory Windows 
The Window menu includes the Cascade and Tile commands, which help you or­
ganize the way directory windows appear on your screen. These commands affect 
all open directory windows. 

~ To arrange open directory windows 

• From the Window menu, choose Cascade. 

Directory windows overlap, starting in the upper-left corner of the File 
Manager workspace. Each window's title remains visible, making it easy for 
you to select any of the directory windows. 

• Or from the Window menu, choose Tile. 

The windows are resized and arranged vertically (on top of each other) so that 
no windows overlap and each window's contents are visible. 

• Or press and hold down SHIFT while choosing Tile from the Window menu. 

The windows are resized and arranged horizontally (side-by-side) so that no 
windows overlap. 
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When you minimize a directory window, it becomes an icon. You can move these 
icons around in the File Manager workspace by dragging them with a mouse. If 
you have many of these icons in your File Manager window, you can arrange them 
so that they are evenly spaced and don't overlap. For information about minimiz­
ing a window, see Chapter 1, "Windows Basics." 

File Manager uses an invisible grid to line up icons. For information about 
changing the size of this grid, see Chapter 5, "Control Panel." 

~ To arrange icons 

• From the Window menu, choose Arrange Icons. 

Changing the Font in File Manager 
You can change the font that File Manager uses to display the names of files and 
directories. When you change the font, all directory windows are affected. 

~ To change the font 

1. From the Options menu, choose Font. 

The Font dialog box appears. 

[8]1.owercase 

Italic 
Bold 
Bold Italic 

AaBbYyZz 

2. In the Font box, select the font you want to use. 

The text in the Sample box changes to reflect the font you select. 

3. In the Font Style box, select any style options you want to use (for example, 
bold or italic). 

The text in the Sample box changes to reflect the style you select. 
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4. In the Size box, select the point size you want to use: the larger the point size, 
the larger the character appears on your screen. 

The text in the Sample box changes to reflect the point size you select. 

5. If you want text to appear all uppercase, clear the Lowercase check box. 

6. Choose the OK button. 

The text in all directory windows is displayed in the new font. 

Displaying the Status Bar 
The status bar at the bottom of the File Manager window supplies information 
about the active directory window or the selected directory-window icon. This in­
formation includes the number of bytes available on the disk, the number of files 
in the current directory and how much disk space they occupy, and the number 
and size of the currently selected files. 

You can tum the status bar on or off by using the Status Bar command. When the 
status bar is on, a check mark appears next to the command on the Options menu. 

~ To turn the status bar on or off 

• From the Options menu, choose Status Bar. 

Saving Your Settings 
Any changes you make by using commands on the Options menu are saved auto­
matically. For example, if you change the font and then quit File Manager, text 
appears in the new font the next time you start File Manager. 

By default, the positions of the open directory windows and icons, and any 
changes you've made by using commands on the View menu, are also saved 
when you quit File Manager. You can tum this option on or off by using the 
Save Settings On Exit command. 
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~ To turn the save settings option on or off 

• From the Options menu, choose Save Settings On Exit. 

When the Save Settings On Exit option is in effect, a check mark appears next 
to the command on the Options menu. 

Using a Network Drive 
When using a network, you can work with any network drive if you know its loca­
tion (and password, if there is one). With some networks, you can browse through 
all the network drives. You should always start the network before you start 
Windows. 

When you start Windows, it recognizes network connections you have made and 
shows the network drives in File Manager as icons different from other drive 
icons. Windows saves any new network connections you make, and if you don't 
disconnect them, sets up the same network connections the next time you start 
Windows. 

With some networks, you can change settings so that your connections are not 
reestablished each time you restart Windows. To change network settings, choose 
the Network icon in Control Panel. For more information, see Chapter 5, "Control 
Panel." 

Connecting to and Disconnecting from a Network Drive 
You can use File Manager to connect to network drives or to disconnect from 
them. If you are not using a network, the network commands are not available. 

Note Depending on your network, you may have different commands and 
dialog boxes available to connect and disconnect your network drives. The 
following procedures are based on your having the Network Connections 
command available. If you have different network commands, such as Connect 
Network Drive and Disconnect Network Drive, substitute those commands for 
Network Connections in the following procedures. If the dialog box for connect­
ing to a network drive is different from the one shown in this procedure, choose 
the Help button in the dialog box for more information. 
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~ To connect to a network drive 

1. From the Disk menu, choose Network Connections. 

The Network Connections dialog box appears. The next available letter to 
assign to a drive appears in the Drive box. 

O!ive: 10: II 
:===::::!!!!!!!:!~----, 

P ass!!ord: I 
Current Ori::te Connections: 

lillRlltiil) 
lilllllili' 
Ii_Iii 
11'!lnWpl'lllll 

2. In the Network Path box, type the path required to locate the network drive. 

With some networks, you can use the Browse button to browse through a list 
of drives until you find the one you want. If your network does not provide this 
capability, the Browse button in the Network Connections dialog box appears 
dimmed. 

3. To assign a different drive, open the Drive list and select the letter you want. 

Or type the drive letter in the Drive box. 

4. In the Password box, type the password, if one is required. 

5. Choose the Connect button. 

Or, if you do not want this connection to be made when you restart Windows, 
press and hold down SHIff while you choose the Connect button. 

6. Repeat steps 2 through 5 if you want to connect to another network drive. 
When you finish setting up your network connections, choose the Close button. 
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File Manager maintains a list of previous network drives you have used so that 
you can easily reconnect to them. 

~ To connect to a network drive you have used previously 

1. From the Disk menu, choose Network Connections. 

The Network Connections dialog box appears. 

2. Choose the Previous button. 

The Previous Network Connections dialog box appears. 

3. Select the network path you want, and then choose the Select button. 

The network path you select appears in the Network Path box. 

4. In the Password box, type the password, if one is required. 

5. Choose the Connect button. 

6. When you finish setting up your network connections, choose the Close button. 

You can connect to network drives while running some applications. If you do 
this, you may need to update the directory windows in File Manager to see the 
drive icon representing the connection. For more information, see "Updating a 
Directory Window" earlier in this chapter. 

~ To disconnect from a network drive 

1. From the Disk menu, choose Network Connections. 

The Network Connections dialog box appears. 

2. In the Current Drive Connections box, select the network drive you want to 
disconnect. 

3. Choose the Disconnect button. 

4. Choose the Close button. 

Note If Windows is running in 386 enhanced mode, you might not be able to 
disconnect from network drives that were active before you started Windows. 
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Working with Files and Directories 
You can use File Manager commands to work with files and directories individu­
ally or in groups. 

To the left of each filename or directory name in the contents list is an icon to help 
you identify its type. The following table describes the icons. 

Icon 

ITl 
D 

Represents 

Directories. These are listed first, in alphabetical order. 

Program files and batch files. Their default filename extensions are .EXE, 
.COM, .PIF, and .BAT. These files start applications. 

Document files. These files are associated with applications. When you open 
one of these files, the associated application starts automatically. For more in­
formation, see "Associating Files with an Application" later in this chapter. 

System or hidden files. These files have system or hidden attributes. For 
more information, see "Setting File Attributes" later in this chapter. 

All other files. 

Naming a File or Directory 
Many File Manager tasks involve naming or renaming files and directories. 
Windows follows MS-DOS conventions for naming files: 

• The name of a file or directory can have two parts: a name and an optional ex­
tension. The two parts are separated by a period. For example, MYFILE.NEW 
is a valid filename; MYFILE is the name of the file, and .NEW is the filename 
extension. 

• The name can contain up to eight characters, and the extension can contain up 
to three characters. 

• The name must start with either a letter or number. It can contain any uppercase 
or lowercase characters except the following: 

period (.) quotation mark (") 

slash (/) backslash (\) 

brackets ([ ]) 

semicolon (;) 

equal sign (=) 

colon (:) 

vertical bar (I) 

comma (,) 

If you use these characters in a filename, you may get unexpected results. 
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• The name cannot contain any spaces. 

• The following names are reserved and cannot be used for files or directories: 
CON, AUX, COM1, COM2, COM3, COM4, LPT1, LPT2, LPT3, PRN, and 
NUL. 

Examples of valid filenames are LETTER.DOC, MEMO.TXT, BUDGET.92, and 
2NDTRY.RPT. For more information about naming files, see your MS-DOS 
documentation. 

Creating a Directory 
You can create a directory by using the Create Directory command. After you 
create a directory, you can copy files and directories to it from other locations by 
using the Move and Copy commands. For more information, see "Moving and 
Copying Files and Directories" later in this chapter. 

~ To create a directory 

1. In the directory tree, select the directory in which you want the new directory to 
appear. 

2. From the File menu, choose Create Directory. 

The Create Directory dialog box appears. 

3. In the Name box, type a name for the new directory. 

Use the same conventions for naming directories as you do for naming files. 
For information, see the previous section, "Naming a File or Directory." 

If you want to create the directory somewhere other than in the current 
directory, type the full path of the new directory. 

4. Choose the OK button. 
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Searching for a File or Directory 
When you want to find a file or directory, you can use the Search command. By 
using wildcards, you can search for a group of files or directories that have related 
filenames or extensions. For example, suppose you gave each of your correspon­
dence files an .L TR extension. To find all of them, you can search for *.L TR. File 
Manager finds all correspondence (.LTR) files in the specified directories on the 
current drive and lists them in the Search Results window. 

You can select files and directories in the Search Results window and use File 
menu commands to print, copy, move, delete, and rename them. You can view file 
details by using commands on the View menu. However, although you can move 
or copy files from the Search Results window, you cannot copy or move files into 
it. 

The Search Results window remains open until you close it or reduce it to an icon. 
The contents of the Search Results window are replaced when you use the Search 
command again. 

~ To search for a file or directory 

1. Select the directory that you want to start the search from. 

2. From the File menu, choose Search. 

The Search dialog box appears. 

~:::c;r:::: :=:~=:\==============================~i := 
l2J S~arch All Subdirectories 

3. In the Search For box, type the name of the file or directory. You can use 
wildcards to search for a group of files or directories with similar names or 
extensions. For example, to search for all files with the extension .WRI, you 
would type *. wri in the Search For box. 

4. In the Start From box, the current directory is listed. If you want to start the 
search from a different directory, type the directory name in the Start From box. 

5. By default, File Manager searches the directory listed in the Start From box, 
and all its subdirectories. If you do not want File Manager to search the sub­
directories, clear the Search All Subdirectories check box. 

6. Choose the OK button. 

To cancel the search, press ESC. 
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File Manager searches the directory and subdirectories you specified. The Search 
Results window appears, displaying all the filenames and directories found. 

c: \project2\readme.wri 
c: \reports\apr. wri 

". c: \reports\feb. wri 
.. c: \reports\jan. wri 

c: \reports\mar. wri 

Note If you modify the drive on which the search was performed and the Search 
Results window is active (or is made active), a dialog box appears, asking whether 
you want to update the Search Results window. If you choose the Yes button, the 
search is performed again on the modified drive. 

Moving and Copying Files and Directories 
You can move and copy files and directories from one File Manager location 
(called the source) to another (called the destination) by dragging them with the 
mouse or by using the Copy or Move command. You can copy and move items 
between directories and between drives. 

By extending your selection, you can move or copy more than one file or directory 
at a time. For information about extending a selection in a directory window, see 
"Extending a Selection" earlier in this chapter. 

~ To move files or directories 

Mouse 

1. Make sure the source and destination are visible. (You can use the Cascade 
or Tile command on the Window menu to rearrange directory windows.) The 
destination can be a directory icon, directory window, or drive icon. If the desti­
nation is a drive icon, the file will be placed in the current directory of that 
drive. 

2. Press and hold down SHIFT while you use the mouse to drag the source file or 
directory icon to the destination. 

The mouse pointer replicates a file icon. 



122 Microsoft Windows User's Guide 

3. Release the mouse button, and then release SHIFT. 

A confirmation message appears. (You can choose not to receive confirmation 
messages. For more information, see "Turning Off Confirmation Messages" 
later in this chapter.) 

4. To complete the move, choose the Yes button. 

If the destination directory contains a file with the same name as the file you 
are moving, a dialog box appears, prompting you to verify that you want to 
replace the existing file. Choose the Yes button to replace the existing file, or if 
you are moving more than one file, choose the Yes To All button. If you choose 
the Yes To All button, File Manager does not prompt you for each file that is 
replaced. 

Tip If you are moving files or directories to a destination on the same drive, you 
can simply drag them with your mouse. You do not have to use SHIFT. 

Keyboard 

1. Select the file or directory you want to move. 

2. From the File menu, choose Move. 

The Move dialog box appears. 

£rom: I accounts. dat 

10: II 
~----------------~ 

3. The name of the selected file or directory appears in the From box. To move a 
different file or directory, type its name in the From box. If the file or directory 
is not in the current directory, include the path. 

4. In the To box, type the destination directory. (If you type a filename, the 
original file or directory is renamed.) 

5. Choose the OK button. 

If the destination directory contains a file with the same name as the file you 
are moving, a dialog box appears, prompting you to verify that you want to 
replace the existing file. Choose the Yes button to replace the existing file, or if 
you are moving more than one file, choose the Yes To All button. If you choose 
the Yes To All button, File Manager does not prompt you for each file that is 
replaced. 

The file or directory disappears from its original location and appears in the 
destination directory you specified. If you move a directory, all the files and 
subdirectories in it move also. 
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~ To copy files or directories 

Mouse 

1. Make sure the source and destination are visible. (You can use the Cascade or 
Tile command on the Window menu to rearrange directory windows.) The 
destination can be a directory window, directory icon, or drive icon. If the 
destination is a drive icon, the file will be placed in the current directory of that 
drive. 

2. Press and hold down CTRL while you use the mouse to drag the source file or 
directory icon to the destination. 

The mouse pointer changes to a file icon with a plus sign to indicate you are 
copying, not moving, files or directories. 

3. Release the mouse button, and then release CTRL. 

A confirmation message appears. (You can choose not to receive confirmation 
messages. For more information, see "Turning Off Confirmation Messages" 
later in this chapter.) 

4. Choose the Yes button. 

If the destination directory contains a file with the same name as the file you 
are copying, a dialog box appears, prompting you to verify that you want to 
replace the existing file. Choose the Yes button to replace the existing file, or 
if you are copying more than one file, choose the Yes To All button. If you 
choose the Yes To All button, File Manager does not prompt you for each file 
that is replaced. 

Tip If you are copying files or directories to a different drive, you can simply drag 
them with the mouse. You do not have to use CTRL. 

Keyboard 

1. In the contents list, select the file or directory you want to copy. 

2. From the File menu, choose Copy. 

The Copy dialog box appears. 

I accounts. dat 

1.0:@ II!....I _________ ---' 

o ~opy to Clipboard 

l!lk!!Rlll~1111 
lillWifililUI 
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3. The name of the selected file or directory appears in the From box. To copy a 
different file or directory, type its name in the From box. If the file is not in the 
current directory, include the path. 
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4. In the To box, type the destination path. 

5. Choose the OK button. 

If the destination directory contains a file with the same name as the file you 
are copying, a dialog box appears, prompting you to verify that you want to re­
place the existing file. Choose the Yes button to replace the existing file, or if 
you are copying more than one file, choose the Yes To All button. If you 
choose the Yes To All button, File Manager does not prompt you for each file 
that is replaced. 

The file or directory is copied to the destination directory and remains in the 
location from which you copied it. If you copy a directory, all the files and 
subdirectories in it are copied also. 

Note You can copy files from a directory window in File Manager to a group 
window or group icon in Program Manager by dragging the files with a mouse. 
For more information, see "Creating a Program Item" in Chapter 3, "Program 
Manager." 

Copying a File onto the Clipboard 
You can use File Manager to copy a file onto the Clipboard so that you can link or 
embed the file into a different document. For more information about object link­
ing and embedding, see Chapter 13, "Integrating Your Windows Applications." 

~ To copy a file onto the Clipboard 

1. Select the file you want to copy. 

2. From the File menu, choose Copy. 

The Copy dialog box appears. 

3. Select the Copy To Clipboard option button. 

4. Choose the OK button. 
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Deleting a File or Directory 
You can use File Manager to delete files and directories. When you delete a 
directory, all files and subdirectories in the directory are deleted. You can extend 
the selection of files or directories to delete more than one. For information about 
extending a selection, see "Extending a Selection" earlier in this chapter. 

Caution Be careful when you delete files and directories. Unless you are running 
MS-DOS version 5.0 or have a file-recovery program, you cannot recover files or 
directories deleted accidentally. For more information, see your MS-DOS 
documentation. 

~ To delete a file or directory 

1. Select the file or directory you want to delete. 

2. From the File menu, choose Delete. 

Or press DEL. 

The Delete dialog box appears. 

Cunent Directory: c:\repolts 

Delete: I&ikMiiMji1ll 

3. Choose the OK button to delete the selected file or directory, or type the name 
of a different file or directory you want to remove. 

File Manager prompts you to confirm the deletion. (Y ou can choose not to re­
ceive confirmation messages. For more information, see the following section, 
"Turning Off Confirmation Messages.") 

4. If you are deleting a single file or directory and are sure you want to delete it, 
choose the Yes button. If you are deleting more than one file or directory and 
you do not want to confirm each deletion, choose the Yes To All button. 
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Turning Off Confirmation Messages 
If you do not want a confirmation message to appear each time you delete or re­
place files and directories, you can change the confirmation settings. You can also 
turn off messages that appear when you perform certain mouse actions, such as 
moving and copying. 

If you turn off confirmation messages, File Manager carries out commands as 
soon as they are issued. 

~ To turn off confirmation messages 

1. From the Options menu, choose Confirmation. 

The Confirmation dialog box appears. 

I2l Directory Delete 

I2l File Replace 

I2l Mouse Action 

I2l Dis.!5,. Commands 

2. Clear the check box for each confirmation option you want to cancel. 

3. Choose the OK button. 

The confirmation options are described in the following table. 

Clear this option 

File Delete 

Directory Delete 

File Replace 

Mouse Action 

Disk Commands 

If you don't want 

A warning message before deleting files. 

A warning message before deleting directories. 

A warning message before writing over existing files. 

A warning message before moving or copying when you 
drag files with a mouse. 

A warning message before formatting or copying a disk. 

Caution If you clear the Directory Delete check box, remember that when you 
delete a directory, all files and subdirectories in that directory are deleted. Also, 
to avoid accidentally writing over files you want to keep, do not clear the File 
Replace check box. 
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Renaming a File or Directory 
You can rename any file or directory by choosing the Rename command on the 
File menu. 

Caution Be careful when you rename files. If you rename a file that your system 
requires (for example, any file that has a .SYS extension), your system may not 
start or run correctly. 

~ To rename a file or directory 

1. Select the file or directory you want to rename. 

2. From the File menu, choose Rename. 

The Rename dialog box appears. 

[rom: I notes. txt 
~================~ 

1.0: L.11 _________ --.J 
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3. The name of the selected file or directory appears in the From box. To rename a 
different file, type the name in the From box. To rename a group of files, use 
wildcards (for example, * .BAK). 

4. In the To box, type the new name. Use a file or directory name that does not 
already exist in the destination directory. You can specify only one filename in 
the To box. If you want to rename a group of files, use wildcards (for example, 
*.TXT). 

5. Choose the OK button. 

Inserting a File into Another File 
If you have applications that support object linking and embedding, you can use 
File Manager to embed a file into another file or link a file to another file. Some 
applications developed prior to this version of Windows may not support embed­
ding and linking through File Manager. 

For information about object linking and embedding, see Chapter 13, "Integrating 
Your Windows Applications." 
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~ To embed a file into another file 

• Drag the file icon into the application window where the other file is open. 

~ To link a file to another file 

• Press and hold down SHIFT +CTRL while you use the mouse to drag the file icon 
to the application window where the other file is open. 

You can also embed or link a file into another file by copying the file onto the 
Clipboard and then pasting it into the destination file. For more information, see 
"Copying a File onto the Clipboard" earlier in this chapter. 

Setting File Attributes 
File attributes are part of the directory information MS-DOS maintains for each 
file. This information helps MS-DOS identify a file and controls the kinds of tasks 
you can perform with the file. The four file attributes are described in the follow­
ing table. 

Abbreviation 

R 

A 

H 

S 

Attribute 

Read-only. Prevents a file from being changed. 

Archive. Identifies a file that has been modified since it was last 
backed up. When you use some MS-DOS commands, such as 
backup and xcopy, the archive attribute is turned off. 

Hidden. Prevents a file from appearing in a directory listing at the 
MS-DOS command prompt. Files that have a hidden attribute 
appear in directory windows only if you select the Show 
Hidden/System Files check box by using the By File Type 
command on the View menu. 

System. Identifies the file as an MS-DOS system file. Files that 
have a system attribute appear in a directory window only if you 
select the Show Hidden/System Files check box by using the By 
File Type command on the View menu. 

You can see file attributes in a directory window by choosing the All File Details 
command on the View menu. This command displays all the information about a 
file. 
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You can change file attributes by using the Properties command on the File menu. 

~ To change file attributes for a single file 

1. Select the file for which you want to set or cancel attributes. 

2. From the File menu, choose Properties. 

The Properties dialog box appears. 

Size: 126.276 bytes 
last Change: 9117191 03:45:04 PM 

e.ath: c:\reports 

Attributes 

o .!lead Only 0 Hidden 

I8J Archive 0 fuJstem 

If you are using a network, more options may be available in the Properties 
dialog box. 

3. Select or clear the check boxes for the attribute settings you want. 

4. Choose the OK button. 

~ To change file attributes for a group of files 

1. Select the files for which you want to set or cancel attributes. 

2. From the File menu, choose Properties. 

The Properties dialog box appears. 

Attributes-------, 

IIl!i~·~.~.JJ..~·iii1 o Hidden 

l8J Archive o fuJstem 

Ill:lUiB!!;;:111' 
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If you are using a network, more options may be available in the Properties 
dialog box. 

3. Select or clear the check boxes, as needed. If a check box is solid gray, it means 
that some of the files you selected have different settings for that particular 
attribute. 

4. Choose the OK button. 
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Associating Files with an Application 
You can use File Manager to help you save time when you want to work with a 
file. Instead of starting your application and then loading a file, you can simply 
choose the file in the directory window; the application starts automatically. To 
do this, a file must be associated with an application. For example, if you associate 
the .ACC extension with your accounting application, you can open any file that 
has an .ACC extension and your accounting application will start with that file 
loaded. 

Some applications, including most Windows applications, are associated 
with a filename extension when you install them. If a file is associated with an 
application, it has a document-file icon next to it. If your application does not 
automatically set up an association, you can associate files with the application 
by using the Associate command. 

~ To associate a file with an application 

1. In a directory window, select a file that has the extension you want to associate. 
For example, to associate files that have a .DAT extension with an application, 
select any file that has a .DAT extension. 

2. From the File menu, choose Associate. 

The Associate dialog box appears. 

files with Extension: 

Associate ...... ith: 

i(None) 

Calendar File (calendar.exe) 
Card File (cardfile.exe) 
Media Player (MPlayer.exe) 
Paintbrush Picture lDbrush.exel 

3. The filename extension of the file you selected appears in the Files With 
Extension box. To associate a different filename extension, or if no file was 
selected when you chose the Associate command, type the extension in the 
Files With Extension box. 

4. In the Associate With box, select the application you want to associate with 
the extension. The Associate With box lists all the applications that registered 
information when they were set up. A description of the type of file that the 
application uses is listed first, followed by the name of the program file. 
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5. If the application is not listed in the Associate With box, you can either type the 
name of a program file or choose the Browse button to select a file from a list 
of program files. You can type only the name of a program file in this box; you 
cannot specify a description of the type of file. 

If you choose the Browse button, the following dialog box appears. 

calc. eKe 
calendar. eKe 
cardfile.eKe 
charmap. eKe 
clipbrd.eKe 
clock. eKe 
controteKe 
dosprmpt.pif 

c:\windows 

i,. IOc:\ 
2l:5 windows 
CJ system 

List Files of I1'pe: 0 riyes: 

1....1 P_ro;::..Qr_am_s ___ ---"'III_: IIiiiiI c: chris 1;11 

Select the program file you want, and then choose the OK button. 

The name of the program file then appears in the Associate With box in the 
Associate dialog box. 

6. Choose the OK button. 

In the directory window, the file icon changes to a document-file icon, indicat­
ing the file is associated with an application. The next time you open that file, 
the application will start also. 

Changing an Association 
You may want to change an association if you have two applications that could be 
associated with the same filename extension. For example, suppose you install a 
word-processing application that is associated with the .DOC extension, and then 
you install another word processor that is also associated with the .DOC extension. 
Because a filename extension can only be associated with one application at a 
time, the most recently installed application is associated with the filename 
extension; in this example, .DOC is associated with the second word processor 
you installed. If you want to be able to use the first word processor when you open 
a .DOC file, you need to change the association back to the first word processor. 
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~ To change an association 

1. In a directory window, select a file that has the extension for which you want to 
change the association. 

2. From the File menu, choose Associate. 

The Associate dialog box appears. 

3. The extension of the selected file appears in the Files With Extension box. To 
change the association for a different filename extension, or if no file was 
selected when you chose the Associate command, type the extension in the 
Files With Extension box. 

4. In the Associate With box, select the new application you want to associate 
with the filename extension. 

5. Choose the OK button. 

Removing an Association 
If you no longer want files associated with an application (for example, if you 
remove the application from your system), you can remove the association by 
using the Associate command. 

~ To remove an association between files and an application 

1. In a directory window, select a file that has the extension for which you want to 
remove the association. 

2. From the File menu, choose Associate. 

The Associate dialog box appears. 

3. The filename extension of the file you selected appears in the Files With 
Extension box. To remove the association for a different extension, or if no file 
was selected when you chose the Associate command, type the extension in the 
Files With Extension box. 

4. In the Associate With box, select None. 

5. Choose the OK button. 
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Using File Manager, you can print files that are associated with applications. You 
can use the Print command, or, if you are using a mouse, you can simply drag the 
file icon onto the minimized Print Manager icon. 

Note Some applications do not support printing through File Manager. If this is 
the case, or if a file is not associated with an application, you must open the appli­
cation and print the file from there. 

~ To print a file by dragging the file icon 

1. Make sure Print Manager is started and reduced to an application icon on the 
desktop. 

2. Drag the document-file icon onto the Print Manager icon. 

~ To print a file by using the Print command 

1. In the directory window, select the file you want to print. 

2. From the File menu, choose Print. 

The Print dialog box appears. 

3. Choose the OK button. 

Starting an Application from File Manager 
You can use File Manager to start your applications. You start an application by 
opening a program file or document file from a directory window. Program files 
almost always have a .COM, .EXE, .PIF, or .BAT filename extension. Document 
files are associated with applications and are represented by document-file icons in 
directory windows. For information about the types of file icons, see "Working 
with Files and Directories" earlier in this chapter. 

When you start an application that runs in a window, the window appears in front 
of any open File Manager windows. When you start an application that uses the 
entire screen, the application replaces the File Manager window. If you want to 
reduce File Manager to an icon each time you start an application, you can choose 
the Minimize On Use command from the Options menu. 

Tip If you use an application frequently, you might find it more convenient to add 
it to a Program Manager group than to start it from File Manager. You can copy 
program and document files from File Manager to Program Manager by dragging 
them with a mouse. For information about how to add items to a Program 
Manager group, see Chapter 3, "Program Manager." 
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~ To start an application from a program file or document file 

Mouse 

• In the directory window, double-click the filename. 

Keyboard 

1. Select the filename in the directory window. 

2. From the File menu, choose Open. 

Or press ENTER. 

~ To start an application and open a file 

Mouse 

• Drag the icon for the data file onto the icon for the program file. 

Keyboard 

1. Select the program file for the application you want to use. 

2. From the File menu, choose Run. 

The Run dialog box appears. 

I;.ommand Line: 

D Run M.inimized 

11;.ljI1dltlBlJiI 

1'!Uij&ijijli~'!111 

lil!!Eiiji11i;U 

3. The name of the program file appears in the Command Line box. If you did not 
select a program file, or if you want to run a different application, type the 
name (and path, if necessary) of the program file in the Command Line box. 

Then, in the Command Line box, add the name of the data file you want to 
open. Include the path if the data file is not in the same directory as the program 
file. 

4. If you want the application to start minimized, select the Run Minimized check 
box. 

5. Choose the OK button. 

~ To reduce File Manager to an icon when you start an application 

• From the Options menu, choose Minimize On Use. 
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Maintaining Floppy Disks 
You can use commands on the Disk menu to prepare floppy disks, copy the 
contents of one disk to another, or label a disk. 

Formatting a Disk 
Formatting prepares a floppy disk so that information can be stored on it and re­
trieved from it. When you format a disk, File Manager removes all the information 
from it, writes new directory information to it, and checks for unusable portions 
(bad sectors). 

~ To format a floppy disk 

1. Insert a disk into a drive. 

2. From the Disk menu, choose Format Disk. 

The Format Disk dialog box appears . 

.!;.apacity: 

Options ----------, 

~abel: L..I ___ -' 

D M.ake System Disk 

D !luick Format 

3. In the Disk In box, select the letter for the drive you want to use. 

4. In the Capacity box, select the size of the disk you want to format. 

5. Under Options, select any options you want. 

If you want to give the disk a volume label, type a name in the Label box. 

If you want to include system files on the disk you are formatting, select the 
Make System Disk check box. (For information about system disks, see the 
next section, "Making a System Disk.") 

If you want to format a disk quickly, select the Quick Format check box. The 
directory information (the file allocation table and root directory of the disk) 
is deleted, but the disk is not scanned for bad sectors. You can use the Quick 
Format option only for disks that have been previously formatted. 
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6. Choose the OK button. 

A confirmation dialog box appears, in which you can verify that you want to 
format the disk. Formatting deletes all information on a disk. Therefore, make 
sure the disk in the drive you selected is the one you want to format. 

You can choose not to receive confirmation messages by using the 
Confirmation command on the Options menu, as explained earlier in this 
chapter. 

7. Choose the Yes button. 

After your disk is formatted, a dialog box appears, prompting you to indicate 
whether you want to format another disk. 

Caution Be careful when you format a disk. Unless you are running MS-DOS 
version 5.0 or have a disk-recovery program, you cannot recover information on a 
disk that is accidentally formatted. For more information, see your MS-DOS 
documentation. 

Making a System Disk 
You can use File Manager to copy MS-DOS operating-system files onto a floppy 
disk. This disk is called a system disk, and you can use it to start your computer. 

~ To copy system files onto a floppy disk 

1. Insert a formatted floppy disk into a drive. 

2. From the Disk menu, choose Make System Disk. 

3. If your computer has two floppy disk drives, a dialog box appears. Select the 
letter for the drive that contains the disk, and then choose the OK button. 

If your computer has only one floppy disk drive, this dialog box does not 
appear. 

Note Not all disks can accept system files. A message notifies you if this is the 
case. 

Copying a Floppy Disk 
You can make a copy of a floppy disk by using the Copy Disk command on the 
Disk menu. When you copy a floppy disk, both disks must have the same storage 
capacity. For example, if the source disk (the disk you are copying from) has a 
capacity of 720K, the destination disk (the disk you are copying to) must also. 
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~ To copy an entire disk 

Labeling a Disk 

1. Insert the source disk in the drive you want to copy from. If you have two 
floppy disk drives of the same size, insert the destination disk in the drive you 
want to copy to. 

2. From the Disk menu, choose Copy Disk. 

3. If your computer has two floppy disk drives, a dialog box appears. Select the 
letter of the source drive and the destination drive, and then choose the OK 
button. 

If your computer has only one floppy disk drive, this dialog box does not 
appear. 

4. A confirmation dialog box appears, in which you can verify that you want to 
copy the disk. When you copy an entire disk, there is no way to recover infor­
mation previously stored on the destination disk. Make sure the disk in the 
destination drive is the one you want to copy to. 

Choose the Yes button. A message appears, informing you of the percentage of 
your disk that has been copied. 

If you have only one floppy disk drive, follow the instructions to switch source 
and destination disks as needed. 

You can assign or change a label for a disk by selecting the Label Disk command 
on the Disk menu. 

~ To assign or change a volume label 

1. Click the drive icon for the disk you want to label. 

Or press TAB to move the selection cursor to the drive icons, use the arrow keys 
to select the icon for the disk you want to label, and then press the SPACEBAR. 

2. From the Disk menu, choose Label Disk. 

The Label Disk dialog box appears. 

3. In the Label box, type the label for the disk. 

The label can contain up to 11 characters. 

4. Choose the OK button. 
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Quitting File Manager 
You can quit File Manager by using the Exit command on the File menu. To save 
the positions and views of your open directory windows, make sure the Save 
Settings On Exit command on the Options menu has a check mark next to it. For 
more information, see "Saving Your Settings" earlier in this chapter. 

~ To quit File Manager 

• From the File menu, choose Exit. 

Or double-click the Control-menu box. 

Or press ALT, SPACEBAR to open the Control menu, and then choose Close. 



Control Panel 

Chapter 5 

What Is Control Panel? 
Windows Control Panel provides you with a visual way of changing the configura­
tion of your system while you're using the Microsoft Windows operating system. 

When you change an option by using Control Panel, the change is stored in the 
WIN.INI file so that it will be in effect the next time you run Windows. 

~ To start Control Panel 

• In the Main group, choose the Control Panel icon. (Double-click the icon. Or 
use the arrow keys to move the selection cursor to the icon, and then press 
ENTER.) 

= p ~ .. 
Ports Mouse Desktop Keyboard 

o " ~ 
Printers International Date/Time Network 386 Enhanced Drivers 

~ J!~ 
MIDI Mapper Sound 

The icons in this window represent the settings you can change by using Control 
Panel. For each icon, there is a corresponding command on the Settings menu. 
These icons represent the options that appear when you are running Windows 
on an 80386 computer using a network, sound, and Musical Instrument Digital 
Interface (MIDI) capabilities. Your Control Panel window may look different, 
depending on the devices you have installed (for example, an extra pointing 
device) and the software that manages them. 
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The following table describes the Control Panel options. 

Choose 

III 
Color 

~ 
Fonts 

~ p 
Ports 

eJ 
Mouse 

Desktop 

Keyboard 

Printers 

International 

Date/Time 

To 

Set the color of the desktop and most of the elements on it. 

Add or remove TrueType fonts, in addition to screen and plotter fonts 
for the Windows screen display. (Some printer fonts must be set up by 
using a font-installation program provided by the font manufacturer.) 

Set the communications options for your serial communications ports. 

Customize the way you use your pointing device. For example, if you 
are using a mouse, you may want to adjust how fast the pointer moves 
across the screen, set the double-click speed, swap functions of the left 
and right mouse buttons, and set any options specific to the type of 
mouse you are using. 

Select patterns or images to decorate the desktop, specify a screen 
saver to run when Windows is running but is not being used, set an 
invisible grid to help you align objects on the desktop, specify icon 
spacing and title wrapping, and set the cursor blink rate. 

Adjust the keyboard repeat rate and delay. 

Install and configure printers. This may include assigning output ports, 
choosing paper sizes and orientation, specifying graphics resolution, 
connecting to network printers, choosing the default printer, installing 
soft and cartridge fonts, and using Print Manager. 

Specify international settings, such as country and language, number 
and currency formats, and date and time formats. This option does not 
change the language of the Windows product itself, only the way appli­
cations sort and manage information that includes these formats. 

Change the system date and time. 



Choose 

Network 

~ 
386 Enhanced 

~ 
Drivers 

~ 
MIDI Mapper 

Jl([ 
Sound 
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To 

Control your connection to the network. Depending on your network, 
this may include signing on and off the network, restoring your net­
work connections when you start Windows, or changing your user 
identification or password. This icon appears only if you have a 
network installed and started. 

Specify settings for swap files, and the use of 32-bit disk access, 
and specify how applications running concurrently in 386 enhanced 
mode compete for use of peripheral devices, and how much of the 
computer's resources are allocated to Windows applications running 
in the foreground and background. This option is available only on 
systems that can run Windows in 386 enhanced mode. 

Install and configure drivers for optional devices, such as sound cards 
and pen tablets. 

Select, change, or create MIDI setups for playing MIDI information on 
a synthesizer connected to your computer. 

Assign sounds to system and application events. You can also use this 
option to tum on or off the warning beep and system sounds. 

~ To choose a Control Panel option 

• In the Control Panel window, double-click the icon for the option you want. 

Or use the arrow keys to move the selection cursor to the icon, and then press 
ENTER. 

Or choose the corresponding command from the Settings menu. 

Customizing Desktop Colors 
In Control Panel, you can customize the colors used for your desktop, the area of 
the screen on which elements such as windows, icons, and dialog boxes appear. 
You can use a color scheme that Windows provides, create a new scheme, and 
define custom colors. 
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Choosing a Color Scheme 
Windows provides several predefined color schemes. A color scheme is a collec­
tion of complementary colors. Some color schemes include only solid colors, 
whereas others include nonsolid colors as well. 

A solid color is directly supported by your display adapter. Video graphics 
adapters (VGAs) support 16 solid colors, and 256-color adapters support 20 solid 
colors. Both types of adapters support hundreds of nonsolid colors. A nonsolid 
color is produced by a pattern of colored dots that simulate a color or pattern. 
Depending on the detail of the screen resolution, non solid colors can look almost 
exactly like solid colors. 

When selecting a color scheme, note the following: 

• Selecting a color scheme that has all solid colors may increase the speed at 
which Windows updates your screen. The Windows Default scheme and 
several others use only solid colors. 

• If you are using a plasma display adapter, you might want to use the Plasma 
Power Saver color scheme. This scheme uses darker colors, which require less 
power than brighter colors. 

• If you are using an LCD display adapter, the colors may appear in reverse 
video. In this case, you might want to use an LCD color scheme. The names 
of these schemes start with LCD. 

• Control Panel uses only the solid color closest to the selected nonsolid color 
for the following screen elements: Window Frame, Window Text, Window 
Background, Menu Bar, Menu Text, Active and Inactive Title Bar Text, Button 
Face, Button Text, Disabled Text, Highlight, and Highlighted Text. 

Note Some LCD monitors have switches you can use to set the screen display so 
that it does not appear in reverse video. On other computers with LCD monitors, 
you need to press a key to change the screen display. In this case, you may need 
to quit Windows before you can change the display. 
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~ To choose a color scheme 

1. In the Control Panel window, choose the Color icon. 

The Color dialog box appears. The Color Schemes box shows the name of the 
current color scheme, and the sample screen shows the colors for the current 
scheme. 

List of saved color schemes 

Sample screen showing 
the current color selections 

2. Open the Color Schemes list, and then select the color scheme you want. 

Click the arrow next to the box to open the list. Or press TAB to move to the 
box, and then press ALT+DOWN ARROW. 

The sample screen changes to reflect your selection. 

3. Choose the OK button at the lower left of the Color dialog box. 

Tip You can select a scheme without opening the Color Schemes list by using the 
UP ARROW and DOWN ARROW keys. Each scheme appears in the Color Schemes box 
and sample screen as you cycle through the schemes. 
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Changing a Color Scheme 
You can change the color assigned to many parts of the Windows screen (also 
referred to as screen elements). The color change is effective until you change 
colors again, and you can save the change for future sessions. 

~ To change the colors of a color scheme 

1. In the Control Panel window, choose the Color icon. 

The Color dialog box appears. 

2. Open the Color Schemes list, and then select the color scheme you want to 
change. 

3. Choose the Color Palette button. 

The Color dialog box expands to include a list of screen elements, a palette 
of basic colors, and a palette titled Custom Colors. 

List of elements whose 
colors you can change 

£ustom Colols: 

DDDDDDDD 
DDDDDDDD 

Basic Colors palette 

Custom Colors palette 

4. In the sample screen, click the part of the screen whose color you want to 
change. 

Or open the Screen Element list, and then select the part of the screen from the 
list. 
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Clicking "Highlighted" in the sample screen alternately selects the "Highlight" 
and "Highlighted Text" elements. Similarly, clicking the OK button in the 
sample screen alternately selects the "Button Face," "Button Shadow," "Button 
Highlight," and "Button Text" elements. You can see which element is selected 
in the Screen Element list. 

5. In the Basic Colors palette, click the color you want. 

Or press TAB to move to the palette, and then use the arrow keys to move the 
selection cursor to the color you want. Press the SPACEBAR to select the color. 

The color is displayed in the sample screen. 

6. Change the color of any other screen elements. 

7. To save the new color selections, choose the Save Scheme button, and then 
type a name for the scheme in the text box. 

If you don't save the scheme, Windows still uses the new color selections 
until you change them again, even if you quit Windows and restart it. However, 
when you make another change or choose an existing scheme, the color selec­
tions are lost. 

8. Choose the OK button. 

Tip You can increase the speed at which Windows updates your screen by select­
ing only solid colors and by selecting the same color for the Active Border and 
Inactive Border. 

If you find that you use only one or two color schemes, you can shorten the list of 
selections by deleting schemes. The only color scheme that cannot be deleted is 
Windows Default, the scheme you see the first time you start Windows. 

~ To remove a color scheme 

1. In the Control Panel window, choose the Color icon. 

The Color dialog box appears. 

2. Open the Color Schemes list, and then select the color scheme you want to 
delete. 

3. Choose the Remove Scheme button. 

A dialog box appears, asking you to confirm the deletion. 

4. Choose the Yes button. 

The Color dialog box appears. 

5. Choose the OK button. 
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Defining Custom Colors 
You can specify up to 16 additional colors at a time and use them in your color 
schemes. Control Panel offers two methods of defining custom colors: 

• You can select colors from a color refiner box that shows the full range of 
possible colors. 

• You can specify numbers for hue, saturation, and luminosity, or for relative 
amounts of red, green, and blue. 

Hue is the position of the color along the color spectrum. Saturation is the purity 
of the hue, moving from gray to the pure color. Luminosity is the brightness of the 
color on a scale from black to white. 

~ To define a custom color 

1. In the Control Panel window, choose the Color icon. 

The Color dialog box appears. 

2. Choose the Color Palette button. 

The Color dialog box expands to include a palette titled Custom Colors. 

3. Choose the Define Custom Colors button. 

The Custom Color Selector dialog box appears. 

C%r refiner cursor 
Vertica//uminosity bar 

Ii 

.0 •••• 111 • 
• 0 •••••• 
• 0 •••••• •••••••• •••••••• ••••••• 0 

Hye:~ fted:1153 Rti 
~ ~ Custom Colols: 
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4. Drag the color refiner cursor to the area of the color refiner box that shows the 
color you want. Then drag the arrow next to the vertical luminosity bar up or 
down to adjust the luminosity. 

Or type values in the Red, Green, and Blue or the Hue, Sat, and Lum boxes. 
You can type values into the boxes or click the arrows to the right of the 
appropriate box to increase or decrease the number. 

As you change the color, the new color is displayed on the left side of the 
Color/Solid box. The right side of the box displays the solid color closest to 
your choice. If you want to select the solid color, double-click the right side of 
the box, or press ALT+O. For more information about solid and nonsolid colors, 
see "Choosing a Color Scheme" earlier in this chapter. 

5. When you are satisfied with the color, select a box in the Custom Colors palette 
for the new color. You can select an empty box or one that contains a color you 
want to change. 

6. Choose the Add Color button to add the new color to the Custom Colors palette. 

7. Define any other custom colors you want to add to the palette. 

8. To close the Custom Color Selector dialog box and return to the Color dialog 
box, choose the Close button. 

Or, to return to the Color dialog box without closing the Custom Color Selector 
dialog box, move the Custom Color Selector dialog box. 

You can now choose the custom colors the same way you would choose a color 
from the Basic Colors palette. 

9. To close the Color dialog box, choose the OK button. 

Changing Desktop Options 
In addition to changing your color scheme, you can customize your desktop in the 
following ways: 

• Specify a pattern or wallpaper for the desktop. 

• Specify a screen saver to display when Windows is running but not being used. 

• Adjust icon spacing. 

• Wrap icon titles. 

• Set an invisible grid to easily align windows and icons. 

• Change window border width. 

• Adjust the cursor blink rate. 
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Displaying Desktop Patterns 
When you set up Windows, the desktop is a solid color. You can replace the solid 
color with a pattern by using the Pattern option. You can choose a predesigned 
desktop pattern or create one of your own. 

The background color for the pattern is the same as the Desktop color. The fore­
ground color (the lines that make up the pattern) is the same as the color of the 
Window Text screen element. For more information, see "Customizing Desktop 
Colors" earlier in this chapter. 

~ To choose a pattern 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

o I.ile 

Sizing Grid Cursor Blink .!late 

§.ranularity: ~ Slow Fast 

.!torder Width: 13 II l'i+li:1;iht;: Hill111!1, :1;*1 

2. In the Pattern area, open the Name list, and then select a pattern. 

Click the arrow next to the box to open the list. Or press TAB to move to the 
box, and then press ALT+DOWN ARROW. 

3. Choose the OK button. 

Tip You can select a pattern without opening the Name list by using the UP ARROW 

and DOWN ARROW keys. 
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If you are using a mouse, you can change an existing desktop pattern or create one 
and save it with a new name. You cannot change a pattern by using the keyboard. 

~ To change an existing pattern 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. Choose the Edit Pattern button. 

The Edit Pattern dialog box appears, displaying a sample of the current pattern 
in the Sample box and a cell in which you can make changes to the pattern. 
(The cell shows an enlarged version of the pattern.) 

3. Open the Name list, and then select a pattern. 

The results of your 
changes appear here. 

Click in this box to 
change the pattern. 
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4. In the cell, click locations where you want to reverse the colors in the pattern. 

5. When the Sample box shows the pattern you want, choose the Change button. 

6. Choose the OK button. 

The Desktop dialog box appears. 

7. Choose the OK button. 
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~ To create a pattern 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. Choose the Edit Pattern button. 

The Edit Pattern dialog box appears, displaying a sample of the current pattern 
in the Sample box, and a cell in which you can make changes to the pattern. 

3. In the Name box, type a name for the new pattern. 

4. Click locations in the cell where you want to reverse the colors in the pattern. 

5. When the cell shows the pattern you want, choose the Add button. 

6. Choose the OK button. 

The Desktop dialog box appears. The new pattern's name appears in the Name 
box. 

7. Choose the OK button. 

The new pattern appears on the desktop. 

The pattern you define is repeated as many times as necessary to completely 
fill the background. Remember, the colors of the pattern are determined by the 
Desktop and Window Text colors you choose. 

If you find that you use only one or two patterns, you can shorten the list of 
selections by removing patterns you no longer use. 

~ To remove a pattern 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. Choose the Edit Pattern button. 

The Edit Pattern dialog box appears. 

3. Open the Name list, and then select the pattern you want to remove. 

4. Choose the Remove button. 

A dialog box appears, asking you to confirm the removal. 

5. Choose the Yes button. 

6. Choose the OK button. 

The Desktop dialog box appears. 

7. Choose the OK button. 
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Displaying Custom Wallpaper 
You can alter the appearance of your desktop by displaying a bitmap graphic as 
wallpaper instead of the desktop color or pattern. You can display any bitmap 
(any file with a .BMP extension), even an elaborate one such as a scanned color 
photograph. 

You can use Windows Paintbrush or another paint application that produces .BMP 
files to create a bitmap to use as wallpaper. After you create the bitmap, copy the· 
.BMP file into the Windows directory. If you put the file into a different directory, 
be sure to specify the full path. 

Not all bitmaps cover the entire desktop when the wallpaper is displayed. You can 
have small bitmaps repeated on your screen by selecting the Tile option. 

~ To choose a bitmap to display as wallpaper 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Wallpaper area, open the File list. 

Click the arrow next to the box to open the list. Or press TAB to move to the 
box, and then press ALT+DOWN ARROW. 

3. Select a bitmap from the list. 

Or type a full path for the bitmap. 

4. Select the Center or Tile option button. 

The Center option positions the bitmap in the center of the desktop. The Tile 
option repeats the bitmap as many times as necessary to cover the desktop. 

5. Choose the OK button. 

If you select both a pattern and custom wallpaper in the Desktop dialog box, the 
wallpaper overlays the pattern. If you select the Center option for the wallpaper 
and the bitmap doesn't cover the entire desktop, you'll see the pattern around the 
edges of the bitmap. If the original bitmap is too large to fit on the screen or takes 
up too much memory, Windows does not display it. 

If you want to remove a wallpaper from the list, delete the bitmap file from the 
Windows directory. 

Note Windows uses more memory when displaying wallpaper than when 
displaying a solid color or a pattern on the desktop. If you run out of memory 
when running an application, you can change to a color or pattern to free some 
memory. 
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Using Fast Application Switching 
You can use fast application switching to switch quickly between applications. 
When fast application switching is active, you can press and hold down the ALT 

key while pressing TAB repeatedly to display the name of each application 
Windows can switch to. 

When you reach the name of the application you want to use, releasing ALT 

switches you to that application. If the application is running as an icon, it is 
restored to a window. 

~ To use fast application switching 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Desktop dialog box, select the Fast "Alt+ Tab" Switching check box. 

3. Choose the OK button. 

If, while using ALT+TAB, you want to return to your original application, continue 
to press and hold down ALT, and then press ESC. 

Using a Screen Saver 
You can select and customize a screen saver to appear on your screen while 
Windows is running. A screen saver is a moving pattern or bitmap that appears 
after you have not used your computer for an amount of time you specify. Screen 
savers can reduce the wear on your screen and provide security for your system. 

You can use one of the several screen savers that Windows provides, or you can 
use the IdleWild screen savers included in the Microsoft Entertainment Pack for 
Windows. If you want to customize your screen saver, see "Customizing a Screen 
Saver" later in this chapter. 

Note To use the IdleWild screen savers, the IWLIB.DLL file and the screen-saver 
files (these have the extension .IW) must be in the same directory. You can place 
these files in any directory you want. If these files are not in your Windows 
directory or in the SYSTEM directory, the directory where they are located must 
be included in your path. For more information about modifying your path, see 
your MS-DOS documentation. 
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~ To select a screen saver 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Screen Saver area, open the Name list. 

Click the arrow next to the box to open the list. Or press TAB to move to the 
box, and then press ALT+DOWN ARROW. 

3. Select a screen saver from the list. 

4. In the Delay box, click the up arrow to increase or the down arrow to decrease 
the number of minutes of inactivity you want to elapse before the screen saver 
appears. 

Or type the number of minutes (larger than zero) you want to elapse. 

5. Choose the OK button. 

~ To return to Windows when the screen saver is on your screen 

• Move the mouse. 

Or press any key. 

Note If a non-Windows application is the active application, the screen saver does 
not appear on your screen, regardless of whether the application is running in a 
window, from the MS-DOS command line, or as an icon. 

Testing a Screen Saver 
After you've selected a screen saver, you can test it to see how it looks on your 
screen. 

~ To test a screen saver 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Screen Saver area, select the screen saver you want to use from the Name 
list. 

3. Choose the Test button. 

The screen saver appears. 

4. To return to Windows, move the mouse. 

Or press any key. 
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Customizing a Screen Saver 
Some screen savers can be customized. For example, you can change the colors of 
the object displayed, the number of lines the object contains, or any text that is dis­
played. The settings that you can change depend on the screen saver you are using. 

~ To customize a screen saver 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Screen Saver area, select the screen saver you want to use from the Name 
list. 

3. Choose the Setup button. 

The Setup dialog box appears, with options specific to the screen saver you 
selected. (If the screen saver cannot be customized, a message appears, notify­
ing you that the screen saver has no options to set.) The following is a sample 
Setup dialog box for a screen saver. 

4. Change any settings you want. 

For information about these settings, choose the Help button or press Fl while 
using the dialog box. 

5. Choose the OK button. 

The Desktop dialog box appears. 

6. Choose the OK button. 

Specifying or Changing a Password for a Screen Saver 
When you use a screen saver provided by Windows, you can specify a password. 
If you have specified a password, you must type the password before you can 
return to Windows from the screen saver. This ensures that unauthorized users 
do not have access to your work. 
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~ To specify or change a password 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Screen Saver area, select the screen saver you want to use from the Name 
list. 

3. Choose the Setup button. 

The Setup dialog box appears. The following is a sample Setup dialog box for a 
screen saver. 

:C~n~l:'l 

:H.I~,:I 

You can set passwords for 
Windows screen savers. 

4. Select the Password Protected check box. 

5. Choose the Set Password button. 

The Change Password dialog box appears. 

Hew Password: 

Retype New Password: 1'--____ ---' 

If you are specifying a password for the first time, skip the following step. 

6. If you are changing your password, type the old password in the Old Password 
box. 

7. In the New Password box, type your new password. 

The password for a screen saver provided by Windows can contain up to 20 
characters. 

8. In the Retype New Password box, type your new password again. 
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9. Choose the OK button. 

The Setup dialog box appears. 

10. Choose the OK button. 

The Desktop dialog box appears. 

11. Choose the OK button. 

~ To turn off the password option 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Screen Saver area, select the screen saver you want to tum off from the 
Name list. 

3. Choose the Setup button. 

The Setup dialog box appears. 

4. Clear the Password Protected check box. 

5. Choose the OK button. 

The Desktop dialog box appears. 

6. Choose the OK button. 

Changing the Spacing Between Icons 
Windows calculates the standard spacing for application, document, and program­
item icons based on the size of the widest icon. Usually this spacing is adequate. 
However, sometimes the title of an icon exceeds the icon's width, causing it to 
overlap adjacent icons. You can prevent icon titles from overlapping by increasing 
the space between icons, by wrapping the title of an icon so that it occupies more 
than one line, or by doing both. 

Icon spacing is measured in pixels (or pels), the smallest unit of measurement 
on the screen. Increments of 10 pixels result in noticeable increases in spacing 
between icons. 

~ To increase icon spacing and wrap the icon title 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Icons area, click the up or down arrow next to the Spacing box to 
increase or decrease the spacing between icons. 

Or type a number. 
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3. Select the Wrap Title check box. 

4. Choose the OK button. 

If you select the Wrap Title check box, the icon titles wrap immediately after you 
close the Desktop dialog box. The change in spacing for application icons occurs 
when you choose the Arrange Icons button in Task List. The change in spacing for 
document and program-item icons occurs when you use the Arrange Icons com­
mand in Windows File Manager or Program Manager. For more information about 
arranging icons in File Manager and Program Manager, see Chapter 3, "Program 
Manager," and Chapter 4, "File Manager." 

Changing the Sizing Grid 
The sizing grid affects both the position and size of windows you manipulate. 
Until you set the granularity of the invisible sizing grid to a number greater than 
zero, the grid is off. When the grid is set to zero, Windows leaves icons and 
windows wherever you place them on the desktop. With the grid set to a number 
greater than zero, all items on your desktop align in an orderly fashion and "snap" 
to the nearest invisible grid line whenever you move any of them. 

Note The sizing grid has no effect on document windows and icons. This option 
only affects application windows and the application icons that appear at the 
bottom of your screen. 

~ To set the grid spacing 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Sizing Grid area, click the up or down arrow next to the Granularity box 
to increase or decrease the size of the grid. 

Or type a number from 0 to 49. 

The grid changes in multiples of 8 pixels. A value of 1 creates a grid with 
"magnetic" points every 8 pixels, 2 places points every 16 pixels, and so forth. 
A value of 0 cancels the grid. 

You may need to experiment with the value you specify. Specifying a value 
that is too high may make it difficult to move windows and icons around on 
the desktop. 

3. Choose the OK button. 
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Changing Border Width 
You can change the border width of all the windows on your desktop, except those 
that have a fixed size (such as most dialog boxes). 

~ To change the border width 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. In the Sizing Grid area, click the up or down arrow next to the Border Width 
box to increase or decrease the border width. 

Or type a number from 1 to 50, with 1 being the narrowest border. 

You may need to experiment with the value you specify. Specifying a value 
that is too low may make it difficult to size windows by using the mouse. 

3. Choose the OK button. 

SeHing the Cursor Blink Rate 
If the cursor blinks faster or slower than you prefer, you can change the rate. 

~ To change the cursor blink rate 

1. In the Control Panel window, choose the Desktop icon. 

The Desktop dialog box appears. 

2. Move to the Cursor Blink Rate area. 

Or press ALT+R. 

3. Drag the scroll box toward Fast or Slow to change the blink rate. 

Or click the right or left scroll arrow to speed up or slow down the rate. 

Or press the RIGHT ARROW or LEFT ARROW key to move the box. 

4. Choose the OK button. 
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Installing and Configuring a Printer 
You can use the Printers option to install a printer or change printer settings. The 
Printers option in Control Panel and the Printer Setup command in Windows Print 
Manager provide the same method for installing and configuring a printer. Both 
display the Printers dialog box, in which you select the printer you want to install 
and then choose other command buttons to connect the printer to a port, connect 
the port to a network printer, and specify printing options. 

However, if Print Manager is not active, you cannot use it to install and configure 
a printer. In this case, you can use the Printers option in Control Panel either to 
install and configure a printer or to activate Print Manager. For instructions on 
how to complete the Printers dialog box, activate Print Manager, and install and 
configure a printer, see Chapter 6, "Print Manager." 

Configuring Communications Ports 
You can specify the communications settings for each serial port your system uses 
by using the Ports option. You use serial ports (the ports named COMI through 
COM4) to connect serial pointing devices, printers, or other serial devices to your 
computer. Most computers include at least two serial ports: COMI and COM2. 
Some devices, such as serial-port adapters, modems, and fax cards, use COM3 
and COM4. The settings you specify determine how information is transferred 
between your computer and the device. 

The communications settings you can specify include standard settings, such as 
those for baud rate, parity, and flow control, and more advanced settings, such 
as those that specify the base port address and interrupt request line (IRQ) that 
Windows uses to send information to a serial port. If you plan on using serial ports 
COMI and COM2 only, you may only need to change the standard settings. If you 
plan on using COM3 and COM4, you may also need to change the advanced 
settings. 

Note Most communications applications that you use to exchange information 
between computers, such as Windows Terminal, require that you specify standard 
port settings within the application. These settings, such as baud rate, parity, and 
data bits, override the settings you specify by using the Ports option in Control 
Panel. 

For details about the standard settings, see the list at the end of the following 
procedure. For details about the advanced settings, see the next section, "Setting 
Advanced Options." 
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~ To specify standard communications settings 

1. In the Control Panel window, choose the Ports icon. 

The Ports dialog box appears, showing icons for the four possible serial ports. 

-= -= 
II? P 
COMl: COM!: 

2. Double-click the icon for the port whose communications settings you want to 
specify. 

Or press TAB to select the icon for the port you want, and then press ALT+S to 
choose the Settings button. 

The Settings dialog box appears. 

D.ala Bits: 18 ItII 

f.arilJ': I None Iii 

lilop Bits: 11 I!i 

[low Control: IXon I Xoff II 

lili:)jilII!1!iH1H' 

l;i;{lUtliHi~~ i:!!l!1 

1!1!~;.~ai;iji 

3. To display the options for each setting, click the arrow to the right of each box. 

Or press TAB to move to each box, and then press ALT+DOWN ARROW. 

4. Set the options to match the device connected to the port. A description of each 
option follows this procedure. For information about the correct settings, see 
the documentation supplied with the device. 

S. When you finish specifying the settings, choose the OK button. 

The Ports dialog box appears. 

6. Choose the Close button. 
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The following table describes the Settings options. 

Use 

Baud Rate 

Data Bits 

Parity 

Stop Bits 

Flow Control 

Setting Advanced Options 

To 

Specify the data-transfer rate of your device. 

Specify the number of data bits you want to use for each character. 
Most characters are transmitted in 7 or 8 data bits. 

Specify the type of error-checking you want to use. 

Specify the time between transmitted characters. Stop bits are not 
actually bits; they are the timing units between characters. 

Specify the method for controlling the flow of data. XoniXoff (also 
known as software handshaking) is the standard software method. 
Select Hardware (or hardware handshaking) if your device controls 
the flow of data. 

Control Panel provides advanced options for specifying the base port address and 
the interrupt request line (IRQ) for each serial port. In most cases, Windows can 
detect the base port address and IRQs used by the serial ports on your computer 
(usually COMl and COM2). 

If you plan on using only COMl and COM2, you probably do not need to change 
the base port address or IRQ settings. However, if you install additional serial 
ports, or if a device connected to a serial port does not use the values that 
Windows detects, you can use the Advanced Options dialog box to change the 
settings so that they match those required by your device. 

Note If you want to use serial ports land 3 or 2 and 4 simultaneously and your 
computer cannot simultaneously access ports that use the same interrupt, you 
need to specify a unique IRQ number for each serial port. First, identify which 
interrupts are not being used by other cards or boards installed in your computer. 
After you have determined this, you may need to adjust your communications 
card in order to use the interrupts. For more information, see the documentation 
supplied with your communications card. 
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~ To specify advanced port settings for a serial port 

1. In the Settings dialog box, choose the Advanced button. 

The Advanced Settings dialog box appears . 

.!l.ase 1/0 Port Address: =il!E!l:=' =--: _--,i [I U!ljjjjKiiiL!I 

interrupt Request line (IRQ): nm'!:~Ff,!iql 
i4 ill 

2. Open the Base I/O Port Address list, and then select an address value from the 
list. 

Or type a value in the box. 

Click the arrow next to the box to open the list. Or press TAB to move to the 
box, and then press ALT+DOWN ARROW. 

3. Open the Interrupt Request Line (IRQ) list, and then select an IRQ number 
from the list. 

Or type a number between 2 and 15 in the box. 

The table following this procedure lists common port address and IRQ settings. 
See the manual that came with your device for information about the interrupt 
and base port address that your device uses. If you are not sure which settings 
to use, select Default. 

4. Choose the OK button. 

Any change you make to the Base I/O Port Address option does not take effect 
until you restart Windows. If you change this option, a dialog box appears, 
asking you whether you want to restart Windows. 

5. To restart Windows, choose the Restart Now button. 
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The following table lists common port address and IRQ settings you can use if 
Windows does not provide settings. 

Port 

COM! 

COM2 

COM3 

COM4 

Address 

03F8 
03E8 
02F8 
02E8 

IRQ 

4 

3 

4 

3 

Setting Network Options 

Using Fonts 

If you installed a network when setting up Windows, the Control Panel window 
includes a Network icon. You can choose this icon to view information about your 
network or to specify settings available for your particular network. 

When you choose the Network icon, a dialog box specific to your network 
appears. The following are some of the tasks you might be able to perform by 
using this dialog box: 

• Sign on and off the network. 

• Change user ID and password. 

• Send messages to other network users. 

• Restore network connections when you start Windows. 

For information about the tasks you can perform by using your network, see your 
network documentation and online Help (if available) in the dialog box. 

Afont, or typeface, is a collection of letters, numerals, symbols, and punctuation 
marks that have common characteristics. Fonts come in different sizes and styles. 
Font sizes indicate the height of a character and are measured in points-a point 
equals 1172 of an inch. Font styles include bold and italic. 

Choosing the right font, font size, and font style can help you create whatever look 
you want for a document-professional, highly visual, draft quality, and so on. 
The right fonts can also make a document easier to read. The font size and type 
determine how much text can fit on one page of a document. 
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Windows Fonts and Printer Fonts 
Windows supplies several fonts that are installed when you set up Windows on 
your computer. These fonts include: 

• Screen fonts, which are used by Windows to display information such as the 
text that appears in application windows and in dialog boxes. Screen fonts 
come in predefined point sizes. Screen fonts also print on some printers 
(for example, on dot-matrix printers). 

• Plotter fonts, which are scalable to any point size and are most often used for 
displaying information on the screen and for plotting graphics with pen plotters. 
Plotter fonts can also be used with some dot-matrix printers. However, the print 
quality may not be as high. 

• True Type fonts, which are scalable to any point size and look exactly the same 
on the screen as they do printed. For information about True Type fonts, see 
"U sing TrueType Fonts" later in this chapter. 

Printers also include built-in fonts for printing. These fonts are referred to as 
printer fonts. The number of printer fonts a printer supports varies according to the 
capabilities of the printer. Dot-matrix and some laser printers include one or two 
printer fonts, whereas PostScript-compatible printers include several printer fonts. 
When you install a printer, the printer fonts appear in your Windows applications 
in the Font list of the Fonts dialog box. 

Cartridge Fonts and Soft Fonts 
In addition to printer fonts, you can also use soft fonts and cartridge fonts. To use 
soft fonts, you need to install them by using the installation program that comes 
with your fonts package. If an installation program was not provided with your 
fonts package and you are using a Hewlett-Packard LaserJet or DeskJet (PCL) 
printer, you can use the Font Installer program provided by Windows. 

To use cartridge fonts, you need to insert one or more font cartridges into the car­
tridge slots on your printer. You might also need to install them if the support for 
the fonts is not built in to the printer driver for your printer. If you need to use 
Font Installer, you can do so while setting printing options. For more information 
about setting printing options and using Font Installer, see Chapter 6, "Print 
Manager." 
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Viewing Printer, Soft, and Cartridge Fonts on the Screen 
Because various printers and screens display information at different resolutions, 
many printer drivers and cartridge- and soft-font packages include matching 
screen fonts so that the fonts look the same on your screen as they do printed. If 
matching screen fonts are not included with your fonts cartridge or soft-fonts 
package, check with your printer or font manufacturer to see if they are available. 

If you format text using a cartridge, soft, or printer font, and no matching screen 
font is available, then one of the screen, plotter, or TrueType fonts supplied by 
Windows is used to display text on the screen. Though the font you see on the 
screen may not look exactly like the font you see in the printed document, the 
substitute font creates line lengths and page breaks on the screen similar to those 
in the printed file. 

Using TrueType Fonts 
If you use TrueType fonts in your documents, Windows and all Windows appli­
cations display the fonts on the screen exactly as they appear when printed: There 
is no need to install matching screen fonts. In addition, by using True Type fonts, 
your documents become more portable: They look the same printed on different 
printers, as long as you use the same application and print at the same resolution. 

Note If you print at a different resolution, or are printing a document from an 
older application, line and page breaks might change. 

Because several TrueType fonts are installed automatically when you set up 
Windows, they are available to your printer and your Windows applications 
immediately. In the applications that come with Windows (such as Write and 
Paintbrush), TrueType fonts appear in the Font list of the Fonts dialog box with a 
TT symbol next to them. If you purchase additional True Type fonts, you can add 
them to Windows and your Windows applications by using the Fonts option in 
Control Panel. 

Adding Screen and TrueType Fonts 
When you install a printer driver, any screen fonts that match the printer fonts 
your printer supports are also installed. If you are using cartridge or soft fonts, 
your font manufacturer usually supplies an installation program for installing 
screen fonts; or the installation program that installs the cartridge or soft fonts 
may install the screen fonts automatically. 

If no installation program is provided for installing screen fonts, you can use 
the Fonts option to install them. You can also use the Fonts option to install any 
additional TrueType fonts that you purchase. 
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All installed fonts are listed in the Fonts dialog box, with the type (for example, 
TrueType or Plotter) displayed in parentheses. Screen fonts are designated by the 
resolution of your screen. For example, (VGA res) screen fonts are used on VGA 
screens, (EGA res) screen fonts are used on EGA screens, and (8514 res) screen 
fonts are used on 8514 screens. 

~ To add a font 

1. In the Control Panel window, choose the Fonts icon. 

The Fonts dialog box appears. 

The Sample box displays the selected font in all available sizes unless the font 
is a plotter font or a TrueType font. Plotter fonts can be scaled to any height, so 
the only size displayed is the size used to design the font. TrueType fonts can 
also be scaled to any height and are displayed in about 24-point size. 

Arial Bold (TrueTvpe) 
Arial Bold Italic (TrueType) 
Arialltalic (TrueType) 
Courier 10.12.15 [VGA res) 
Courier New TrueT e 

This is a scalable TrueType font which can be 
displayed on the screen and printed on your printer. 

Size of Font on Disk: 69 KB 

2. Choose the Add button. 

The Add Fonts dialog box appears. 

3. Open the Drives list, and then select the drive that contains the fonts you want 
to add. 

Click the arrow next to the box to open the list. Or press TAB to move to the 
box, and then press ALT+DOWN ARROW. 

4. Select the directory where the fonts you want to add are located. 

The fonts on the selected drive and in the selected directory appear in the 
List Of Fonts box. 
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5. From the List Of Fonts box, select the fonts you want to add. 

You can extend the selection to include all the fonts you want to add at once. 
(For information about how to extend the selection, see Chapter 2, "Application 
Basics.") 

To add every font in the list, choose the Select All button. 

6. If you have limited disk space, you can clear the Copy Fonts To Windows 
Directory check box. You can then use the fonts directly from the directory in 
which they are located, without copying them to your Windows directory. For 
example, this is useful if you are using a CD-ROM that contains hundreds of 
TrueType fonts. 

If you want to use fonts that are located on a network or on a removable disk 
drive, it is recommended that you select the Copy Fonts To Windows Directory 
check box, if you have enough disk space to store the fonts. This ensures that 
the fonts will always be available, even if the source drive is removed or the 
fonts are removed from the network. 

If you select the Copy Fonts To Windows Directory check box and are running 
Windows from a network, the fonts will be copied to your Windows SYSTEM 
directory. 

7. Choose the OK button to add the font. 

The Fonts dialog box appears. 

8. Choose the Close button. 

Turning TrueType Font Options On or Off 
TrueType fonts require additional memory. If you have a limited amount of 
memory, you may want to turn them off when you are not using them in your 
applications. TrueType fonts are on by default. 

If you find you use only TrueType fonts in your documents, you can prevent all 
other fonts from appearing in the fonts lists of your Windows applications. These 
fonts include screen, plotter, and printer fonts. 

Note Selecting the Show Only TrueType Fonts In Applications check box does 
not turn off non-TrueType fonts. It only prevents them from appearing in the fonts 
lists of your Windows applications. You can still use your Windows applications 
to view and print documents that contain other fonts. Some applications do not 
support listing TrueType fonts exclusively. If you select the Show Only TrueType 
Fonts In Applications check box, and no TrueType fonts appear in your applica­
tion, then do not use this option. 
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~ To set TrueType options 

1. In the Control Panel window, choose the Fonts icon. 

The Fonts dialog box appears. 

2. Choose the TrueType button. 

The TrueType dialog box appears. 

,:j)j( 

I :~jic~ij~~,i: 
I;:riii,i~':' 

3. Clear the Enable TrueType Fonts check box to turn off TrueType fonts, or 
select the Show Only TrueType Fonts In Applications check box to use 
TrueType fonts exclusively. 

If you turn off TrueType fonts, then the Show Only TrueType Fonts In 
Applications option is unavailable. 

4. Choose the OK button. 

Any change you make to the Enable TrueType Fonts option does not take effect 
until you restart Windows. If you change this option, a dialog box appears, 
asking you if you want to restart Windows. 

5. To restart Windows, choose the Restart Now button. 

Removing a Font 
You can remove fonts you do not use from the Installed Fonts list. Because fonts 
occupy memory, removing them frees this memory for use by your applications. 

Caution The MS® Sans Serif font set is used for most Windows dialog boxes. Do 
not remove this font; if you do, the text in the dialog boxes will be difficult to read. 

~ To remove a font 

1. In the Control Panel window, choose the Fonts icon. 

The Fonts dialog box appears. 

2. In the Installed Fonts list, select the font you want to remove. 

You can extend the selection to include all the fonts you want to remove at 
once. (For information about how to extend the selection, see Chapter 2, 
"Application Basics.") 
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3. Choose the Remove button. 

A dialog box appears, asking you to confirm the removal. 

4. If you want to delete the font files from your disk in addition to removing the 
fonts from memory, select the Delete Font File From Disk check box. 

Caution It is recommended that you do not delete fonts from the disk if you 
chose not to copy the fonts to your Windows directory. In this case, you may 
be deleting the original font files, and you may not be able to re-add the fonts 
if you decide to use them later. 

5. Choose the Yes button or, if you are removing several fonts at the same time, 
the Yes To All button. 

The Fonts dialog box appears. 

6. Choose the Close button. 

Specifying International Settings 

Basic Settings 

By using the International option, you can specify settings for Windows and all 
the Windows applications that use international settings. You can also specify the 
format Windows uses to display the date and time in your applications. If you are 
using Windows in English within the United States, you do not need to make any 
changes to the international settings unless you want to change the date and time 
format. 

Note Changing the International settings does not change the language of 
Windows itself. Additional language versions of Windows can be obtained 
separately. 

U sing with the International option, you can specify basic international settings 
such as the country, language, keyboard layout, system of measurement, and the 
list separator you want to use. When you select a country, Windows adjusts the 
date, time, currency, and number formats to reflect those used by the selected 
country. You can also adjust these settings yourself to customize them for your 
particular situation. 
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~ To select international settings 

1. In the Control Panel window, choose the International icon. 

The International dialog box appears. 

.!:.anguage: I English (American) 

Keyboard Layout: Ius 
~--------------~-

.M.easurement: 1.-1 E--=ng=-lis_h __________ ~II_' 

List .s.eparator: 0 
Q.ate Format ----------------, '-Cyrrency Format 

10/15/91 

Tuesday. October 15.1991 

[ I.ime Format 

05:22:31 PM 

$1.22 

($1.22) 

Humber Format 
r=-7'~=1 

2. Specify the settings for Country, Language, Keyboard Layout, Measurement, 
and List Separator. 

A description of each option follows this procedure. 

3. Specify the settings for Date, Time, Currency, and Number formats. 

For information about these options, see the procedures that follow. 

4. Choose the OK button. 

Use 

Country 

Language 

Keyboard Layout 

Measurement 

To 

Specify the country whose standard settings you want to use. 
When you select the country, Windows adjusts the settings for the 
date, time, number, and currency formats, in addition to the Paper 
Size option in the Print Setup dialog box, to match the standard 
formats used by that country. 

Specify the language you want to work in. The language you 
select affects the way applications sort information. For example, 
if the language you are working in includes accented characters, 
setting this option to that language ensures that your applications 
will correctly sort words or phrases that include these characters. 

Specify the keyboard layout of your computer. Keyboard layouts 
vary to accommodate the special characters'and symbols used in 
different languages. Windows uses this setting to interpret the 
keys you press. 

Select the metric or English system of measurement. 
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Use To 

List Separator Specify a symbol to separate elements in a list. In English, the list 
separator is typically a comma and is used to separate words or 
numbers that appear in a series. 

You can change the way the date is displayed in applications that have a date 
function. For example, you can vary the order of month, day, and year, or change 
the punctuation used to separate parts of the date. 

~ To change the date format 

1. In the Control Panel window, choose the International icon. 

The International dialog box appears. 

2. In the Date Format area, choose the Change button. 

The Date Format dialog box appears. 

llrder: OYIdD 

.s.eparator: El 
D I!.ay Leading Zero (07 VII. 7) 

D Month Leading Zero (02 ¥s. 2) 

D !;.entury (1990 VII. 90) 

Long Date Format 
O!der: @ MDY 0 DMY 0 YMO 

ISunday IIDIMarch IIDl05lilDI1991 1iD 

Sunday. March 05.1991 

3. Set the options you want for both the Short Date Format and Long Date Format. 

A description of each option follows this procedure. 

4. Choose the OK button. 

The International dialog box appears. 

5. Choose the OK button. 
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Time Format 

The Short Date Format displays the date as three numbers, representing the month, 
day, and year. You specify the order and number of digits for each part of the date. 
The Long Date Format displays the date as a combination of words and numbers 
(for example, Monday, October 19, 1992) or a variation you specify. Descriptions 
of the options for both formats follow. 

Use 

Order 

Separator 

Day/Month Leading Zero 

Century 

Long Date Format options 

To 

Specify the order of the month (M), day (D), and year 
(Y). This option works the same for Short and Long 
Date Formats. 

Specify a symbol to separate the month, day, and year. 
You can specify any character as the separator, though 
the most common are the slash (/) and the hyphen (-). 

Specify that the day or month appear as two digits. For 
example, February 7 appears as 02-07. 

Specify that the year be displayed as four digits. For 
example, December 10, 1992, appears as 12-10-1992. 

Specify alternative choices for the Long Date Format, 
including abbreviations for the day and month and 
different separators. 

You can select either the 12-hour or 24-hour format and a number of related 
options. For example, you can add suffixes to the date, such as AM for morning 
or PST for Pacific Standard Time. 

~ To change the time format 

1. In the Control Panel window, choose the International icon. 

The International dialog box appears. 

2. In the Time Format area, choose the Change button. 

The Time Format dialog box appears. 

- " International - ;rIme Format 

@rti..·~~.~~.~.1 00:00-11:59 lAM 
~=~ o 2,! hour 12:00-23:59 .... lp_M_---' 

~eparator: 0 
leading Zero: 09:15 @ 09:15 

3. Set the options you want. 

A description of each option follows this procedure. 
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4. Choose the OK button. 

The International dialog box appears. 

5. Choose the OK button. 

The following table describes the Time Format options. 

Use 

12-Hour/24-Hour 

Separator 

Leading Zero 

To 

Display time in numbers representing the hours between 1 and 
12 or between 0 and 23. 

If you use the 12-hour format, specify your country's notation for 
before noon in the upper box next to 00:00-11 :59. 

If you use the 12-hour format, specify your country's notation for 
after noon in the lower box next to 12:00-23:59. 

If you use the 24-hour format, you can only use the lower box to 
specify a special suffix, such as PST. 

Select a character to separate the hours, minutes, and seconds. 
Any character is acceptable, but the most common is the 
colon (:). 

Display the hours before ten 0' clock as a two-digit number, with 
the first digit being a zero. For example, nine o'clock appears as 
09:00. 

You can control the way currency is represented in Windows applications. 

~ To change the currency format 

1. In the Control Panel window, choose the International icon. 

The International dialog box appears. 

2. In the Currency Format area, choose the Change button. 

The Currency Format dialog box appears. 

Symbol ~Iacement: ~In~~~~~ 
H.egalive: <..:..:1 1$_12_3 __ 22-=-1 _--''''''''' 

fuombol: ~ 
.!!.ecimal Digits: II] 

3. Set the options you want. 

A description of each option follows this procedure. 



174 Microsoft Windows User's Guide 

Number Format 

4. Choose the OK button. 

The International dialog box appears. 

5. Choose the OK button. 

The following table describes the Currency Format options. 

Use 

Symbol Placement 

Negative 

Symbol 

Decimal Digits 

To 

Specify the placement and spacing of the currency symbol 
relative to the amount. 

Select the way you want negative numbers to appear. 

Specify a different currency symbol for your country. 

Specify the number of digits you want to appear after the 
decimal separator. 

You can control the way numbers are displayed in Windows and many Windows 
applications. 

~ To change the number format 

1. In the Control Panel window, choose the International icon. 

The International dialog box appears. 

2. In the Number Format area, choose the Change button. 

The Number Format dialog box appears. 

Q.ecimal Separator: 

D.!l.cimal Digits: 

beading Zero: 0.7 @ 0.7 

3. Set the options you want. 

A description of each option follows this procedure. 

4. Choose the OK button. 

The International dialog box appears. 

5. Choose the OK button. 
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The following table describes the Number Format options. 

Use 

1000 Separator 

Decimal Separator 

Decimal Digits 

Leading Zero 

To 

Change the punctuation that separates thousands. 

Change the punctuation that separates the fractional part 
of a decimal number from the whole number part. 

Specify the number of digits to appear after the decimal 
separator. 

Specify whether the decimal is preceded by a zero. 

Customizing the Mouse and Other Pointing Devices 
You can make several adjustments to the way Windows works with your pointing 
devices, depending on the type of pointing device you are using. For example, if 
you are using a mouse, you may be able to switch the functions of the left and 
right buttons and change the speed of the mouse pointer. 

Before customizing your pointing device, you need to install it and its driver. For 
more information, see the documentation for your pointing device. 

~ To customize your pointing device 

1. In the Control Panel window, choose the icon for your pointing device. 

A dialog box appears for the device you are using. The following is the Mouse 
dialog box supplied by Windows. 

Qouble Click Speed 
Slow 

p:I"=i~ 
Fast ~ 

o ~wap left/Righi BuUons 

o Mouse I.rails 

2. Set the options you want, and then choose the OK button. 

The options vary, depending on the pointing device you are using. For details 
about the options and their settings, see the documentation for your pointing 
device and online Help, if available. 
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If you are using a Microsoft Mouse or compatible, Windows provides a standard 
Mouse dialog box. The dialog box has the following options. 

Use 

Mouse Tracking Speed 

Double Click Speed 

Swap Left/Right Buttons 

Mouse Trails 

To 

Change the speed at which the pointer moves across the 
screen. 

Change the speed at which Windows registers a double­
click when you press your mouse button. 

If you increase the speed, double-click the Test button to 
make sure you're clicking fast enough for the new setting. 
The Test box blinks if your double-click is fast enough. 

Switch the functions of the left and right mouse buttons. 

With many applications, you use the left button as the pri­
mary tool for selecting text and choosing items. If you are 
left-handed, you might find it more convenient to use the 
right button. 

Leave a trail of pointer icons as you move the pointer 
across the monitor. If you are using an LCD monitor, this 
option makes the mouse pointer easier to see. 

Note The changes you make to the Swap Left/Right Buttons and Mouse Trails 
options take effect immediately, before you close the dialog box. If you switch 
the buttons, you either need to click the right button to choose the OK or Cancel 
button, or switch the mouse buttons again. If the display driver you are using does 
not support mouse trails, this option is unavailable. 

Setting the System Date and Time 
You can change the system date and time by using the Date/Time option. The 
system date and time are reflected in Clock and Calendar (two Windows applica­
tions in the Accessories group), and in the information kept by File Manager for 
each file you save on your disk. The format of the date and time depends on the 
international settings you choose (for information, see "Specifying International 
Settings" earlier in this chapter). 
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~ To change the date 

1. In the Control Panel window, choose the DateITime icon. 

The Date & Time dialog box appears. 

,Date 
Date 8. Time 

iEJl15/91 I 
If,~~'fB~f&l' 

I Irt~l.fJl 
[I.ime 05: 35: 24 PM II II;i<lifiitf~t 

2. Select the part of the date (day, month, or year) you want to change. 

3. Type the new value, or click the up or down arrow at the right of the Date box 
to change one date element at a time. 

4. Choose the OK button. 

~ To change the time 

1. In the Control Panel window, choose the DateITime icon. 

The Date & Time dialog box appears. 

2. Select the part of the time (hour, minute, second, suffix) you want to change. 

3. Type the new value, or click the up or down arrow at the right of the Time box 
to change the selected part one unit at a time. 

4. Choose the OK button. 
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Adjusting Keyboard Speed 
By using the Keyboard option, you can specify the keyboard delay (how long your 
computer waits after you hold down a key before it repeats that key) and how fast 
a key repeats when you press it and hold it down. 

~ To change the keyboard delay and repeat rate 

1. In the Control Panel window, choose the Keyboard icon. 

The Keyboard dialog box appears. 

lest: 

2. Drag the Delay Before First Repeat scroll box toward Long or Short to increase 
or decrease the delay, or click the appropriate scroll arrow. 

Or press the LEFT ARROW or RIGHT ARROW key to increase or decrease the delay 
time. 

3. Drag the Repeat Rate scroll box toward Fast or Slow to increase or decrease the 
repeat rate, or click the appropriate scroll arrow. 

Or press the RIGHT ARROW or LEFT ARROW key to increase or decrease the rate. 

4. To test the speed, move to the Test box and type or hold down any key on the 
keyboard. 

Adjust the box positions until you reach a delay speed or repeat rate you are 
comfortable with. 

5. Choose the OK button. 
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Installing and Configuring Drivers 
When you add new devices to your system, you need to install the driver that 
controls the device. A device driver is a program that allows a specific piece of 
hardware (or device) to communicate with Windows. Although the device may be 
installed in or connected to your computer, Windows will not recognize the device 
until after you install and configure the driver. 

You can use the Drivers option in Control Panel to install certain device drivers. 
These drivers most often include those for multimedia devices, such as sound 
cards or videodisc players. They may also include other drivers, such as those for 
pens or for pointing devices other than a mouse. Generally your device package 
includes a disk containing the appropriate Windows device driver. Windows also 
provides drivers for some sound cards. If you do not have a driver for your device, 
contact your device manufacturer about providing one. 

To install device drivers for your mouse, keyboard, and printer, and interna-
tional drivers, you need to run the Setup program or use the appropriate option in 
Control Panel. For information about the International option in Control Panel, see 
"Specifying International Settings" earlier in this chapter. For more information 
about using Setup to install display (monitor), keyboard, and mouse drivers, see 
Chapter 15, "Maintaining Windows with Setup." For information about installing 
a printer driver, see Chapter 6, "Print Manager." 

Note You cannot install an updated version of a device driver that is already 
installed on your system until you remove the old driver. If you do not remove the 
old driver, you will receive a message while attempting to install the new one. For 
more information about how to remove a device driver, see "Removing a Driver" 
later in this chapter. 

~ To install a new device driver supplied by Windows 

1. In the Control Panel window, choose the Drivers icon. 

The Drivers dialog box appears, displaying a list of the drivers already installed. 

Jb!,l~~~,N~iJ 
Timer 
[MCI] MIDI Sequencer 
[MCI] Sound 
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2. Choose the Add button. 

The Add dialog box appears, listing devices that Windows provides drivers for. 

If your device is not listed, see "Installing a Driver Not Supplied with 
Windows" following this procedure. 

3. Select the driver you want to install from the list, and then choose the OK 
button. 

A dialog box may appear, prompting you to insert the disk that contains the 
driver. 

4. Insert the disk containing the device driver you want to install into drive A. Or, 
if the driver is located on your hard disk, type the drive and directory where it is 
located. Do not type the filename for the driver. 

If you do not know where the driver is located, you can choose the Browse 
button. This displays the Browse dialog box, in which you can locate and select 
the drive and directory where the driver is located. When you are finished using 
the Browse dialog box, choose the OK button. 

5. In the Install Driver dialog box, choose the OK button. 

If the driver requires additional settings (for example, you might need to change 
the port address and interrupts used by your sound card), a setup dialog box 
appears for the driver. 

6. Select the settings required by the driver. 

It is important that the settings you specify do not conflict with the settings used 
by other devices installed on your system, such as a mouse or network card. For 
example, the interrupts used by each device must be unique. See the manuals 
for your devices to determine the settings they are using. Then see the manual 
that came with the device you are configuring for information about its settings. 

7. When you are finished selecting the settings, choose the OK button. 

When you install a device driver, Windows installs additional related drivers. 
These drivers may also require specific settings. In this case, other setup dialog 
boxes may appear. 

8. Repeat steps 6 and 7 until all related drivers have been configured. 

Any new driver and any changed driver settings do not take effect until you 
restart Windows. A dialog box may appear, asking if you want to restart 
Windows. 

9. To have your changes take effect immediately, choose the Restart Now button. 
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Installing a Driver Not Supplied with Windows 
When you purchase a new device, such as a sound card, the associated driver 
should be included with the device. If you do not have a driver for your device, 
contact the device manufacturer to get one. Follow any instructions the manufac­
turer provides for installing the driver. 

If there are no instructions, complete the following steps to install the device 
driver. 

~ To install a driver provided by the device manufacturer 

1. In the Control Panel window, choose the Drivers icon. 

The Drivers dialog box appears, displaying a list of the drivers already installed. 

2. Choose the Add button. 

The Add dialog box appears. 

3. In the List Of Drivers box, select Add Unlisted Or Updated Driver, and then 
choose the OK button. 

A dialog box appears, instructing you to insert the disk that contains setup infor­
mation for the driver (this may be the same disk that contains the driver file). 

4. Insert the disk containing the setup information into drive A. Or, if the setup 
information is located on your hard disk, type the drive and directory where the 
information is located. Do not type the driver filename. 

If you do not know where the setup information is located, you can choose the 
Browse button. This displays the Browse dialog box, in which you can locate 
and select the drive and directory where the information is located. When you 
are finished using the Browse dialog box, choose the OK button. 

5. In the Install Driver dialog box, choose the OK button. 

Another dialog box appears, listing the drivers you can install. 

6. Select the driver you want to install. 

7. Choose the OK button. 

If the driver is located on a different disk, another dialog box appears asking 
you to insert the disk that contains the driver. If this dialog box does not appear, 
go to step 10. 

8. Insert the disk that contains the driver, or specify the drive and directory where 
the driver is located. You can also use the Browse button. 

9. Choose the OK button. 

If the driver requires additional settings, a setup dialog box appears for the 
driver. 
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10. Select the settings required by the driver. 

It is important that the settings you specify do not conflict with the settings used 
by other devices installed on your system, such as a mouse or network card. For 
example, the interrupts used by each device must be unique. See the manuals 
for your devices to determine the settings they are using. Then see the manual 
that came with the device you are configuring for information about its settings. 

11. When you are finished selecting the settings, choose the OK button. 

When you install a device driver, Windows installs additional related drivers. 
These drivers may also require additional settings. In this case, other setup 
dialog boxes may appear. 

12. Repeat steps 10 and 11 until all related drivers have been configured. 

Any new driver and any changed driver settings do not take effect until you 
restart Windows. A dialog box may appear, asking if you want to restart 
Windows. 

13. To have your changes take effect immediately, choose the Restart Now button. 

Specifying Driver Settings 
After a device driver is installed, you can change any of its settings. For instruc­
tions on how to install a driver, see "Installing and Configuring Drivers" earlier 
in this chapter. 

~ To adjust device-driver settings 

1. In the Control Panel window, choose the Drivers icon. 

The Drivers dialog box appears. 

2. In the Installed Drivers list, select the driver you want to configure. 

3. Choose the Setup button. 

Some drivers do not require specific settings. If you select such a driver, the 
Setup button is unavailable. 

The Setup dialog box appears. The options in this dialog box vary according 
to the driver you are configuring. 

4. Set the options as described in your device's manual. 

5. Choose the OK button. 

The changes you make may not take effect until you restart Windows. If this is 
the case, a dialog box may appear, asking if you want to restart Windows. 

6. To have the new settings take effect immediately, choose the Restart Now 
button. 
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Removing a Driver 
If you are no longer using a device, you can remove its driver from the Installed 
Drivers list. Removing a driver from the Installed Drivers list does not remove the 
driver file from your hard disk. If you need to use the same device later, you can 
add its driver again. 

Caution The device drivers that are automatically installed during Setup are 
required by your system (these are the drivers that are displayed when you first 
opened the Drivers dialog box). If you remove one of these drivers, your system 
may not work properly. 

~ To remove a device driver 

Using Sound 

1. In the Control Panel window, choose the Drivers icon. 

The Drivers dialog box appears. 

2. In the Installed Drivers list, select the driver you want to remove. 

3. Choose the Remove button. 

A dialog box appears, asking you to confirm your decision to remove the driver. 

4. Choose the Yes button. 

A dialog box appears, asking you if you want to restart Windows. 

5. To have the removal take effect immediately, choose the Restart Now button. 

Control Panel provides several options to control how sound works in Windows. 
With these options, you can perform simple sound tasks, such as assigning differ­
ent sounds to system and application events. If you are using a sound device that 
has Musical Instrument Digital Interface (MIDI) capabilities, you can specify 
MIDI settings for your device. For more information about assigning sounds to 
system and application events and specifying MIDI settings for synthesizers, see 
the following sections, "Assigning Sounds to Events" and "Changing MIDI 
Settings." 

To use basic sound in Windows, you should have a sound card installed in your 
computer that conforms to the Multimedia Personal Computer (MPC) specifica­
tions. To use both basic and MIDI sound capabilities, you also need to install the 
sound drivers that control your sound card and other sound devices, such as 
synthesizers. For information about installing and configuring drivers for your 
sound devices, see "Installing and Configuring Drivers" earlier in this chapter. 
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Assigning Sounds to Events 
Control Panel provides a Sound option that you can use to assign sounds to 
different application and system events. For example, you can select a sound to 
play whenever you start Windows. The other sounds playas specified by the 
application you are using. 

For example, some applications play the sound assigned to the Default Beep when­
ever you click the mouse button outside of an open dialog box. Other applications 
may play the sound assigned to Exclamation or Asterisk whenever you encounter 
a warning message. The sounds you can assign to these events are stored in files 
that have the .W A V extension. 

To use sound in Windows, the sound driver that controls your sound card must be 
installed and configured for your system. If you do not have a sound card or if the 
sound driver is not configured properly, Windows will use a warning beep when it 
encounters an error or you attempt to do something your computer does not recog­
nize. For more information about installing and configuring sound drivers, see 
"Installing and Configuring Drivers" earlier in this chapter. 

~ To assign sounds to events 

1. In the Control Panel window, choose the Sound icon. 

The Sound dialog box appears. 

Events: 

Critical Stop 
Default Beep 
Exclamation 
Question 
Windows Exit 
Windows Start 

lZl Enable System Sounds 

<none> 
chimes.wav 

ding.wav 
tada.wav 
( .. ] 
(system] 
(-a-] 

c:\windows 

2. In the Events list, select the event that you want to assign a sound to. 

If a sound file is assigned to that event, it is selected in the Files list. 
Otherwise, None is selected. 

3. In the Files list, select the sound file you want to use. If the file you want is not 
listed, select the drive and directory where the file is located, and then select the 
file. If you don't want to assign a sound to the selected event, select None. 
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4. To hear the sound, choose the Test button or double-click the event or filename. 

5. Repeat steps 2 through 4 until you have assigned a sound to each event you 
want. 

6. When you are finished, choose the OK button. 

Turning Sounds and the Warning Beep On or Off 
If no sounds have been assigned to events or if you do not have a sound driver 
installed, Windows uses a warning beep when it encounters an error or you 
attempt to do something your computer does not recognize. 

You can turn the warning beep and all other sounds, except those assigned to 
Windows Exit and Windows Start, on or off. (If you do not want to playa sound 
when starting or quitting Windows, you must assign None to Windows Start or 
Windows Exit.) 

~ To turn sounds and the warning beep on or off 

1. In the Control Panel window, choose the Sound icon. 

The Sound dialog box appears. 

2. Select or clear the Enable System Sounds check box. 

(If you want to turn off sound for a specific event, select the event from the 
Events list, and then select None from the Files list.) 

3. Choose the OK button. 

Changing MIDI Settings 
If you are using a sound device, such as a synthesizer, that has Musical Instrument 
Digital Interface (MIDI) capabilities, you can specify MIDI settings for your 
device. 

Windows supports two different standards for playing MIDI information 
generated by an application or stored in a MIDI file. These standards, the General 
MIDI guidelines and the Microsoft authoring guidelines for MIDI files, both 
include certain instrument patch settings and key assignments, as defined by the 
General MIDI specification, but differ in the channel settings they require. 

When you set up Windows, the Setup program installs MIDI setups that 
support both standards for playing MIDI information on common sound-card 
and synthesizer combinations. These setups include key maps, patch maps, and 
channel settings that ensure that the MIDI information plays accurately on your 
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synthesizer. You can use MIDI Mapper to select a different MIDI setup, create 
a new setup, edit key assignments, or edit patch or channel mappings for an 
existing setup. 

Caution To use MIDI Mapper, you should have a basic understanding of MIDI 
concepts and terminology. It is recommended that you not use MIDI Mapper to 
edit or create MIDI setups unless you are experienced with MIDI and understand 
the results of the changes you make. 

Selecting a MIDI Setup 
If you are using an application, such as Windows Media Player, that uses MIDI 
setups to play MIDI files, you need to select the MIDI setup for the synthesizer 
that will be playing the file. 

~ To select a MIDI setup 

1. In the Control Panel window, choose the MIDI Mapper icon. 

The MIDI Mapper dialog box appears. 

I\Htti~b'l;lg 
o e.atch Maps 0 .Key Maps II,j:tf\}~+tq, 

N~me: L-IA_d l_ib ______ --"I!1_',····. 1;:tit:ii~~li!:~1 
Description: Base-level setup 

2. In the Show area, select the Setup option button (this button is selected by 
default). 

3. Open the Name list, and then select the setup you want to use. A description of 
the setups provided by Windows follows this procedure. 

4. Choose the Close button. 

The following table lists the MIDI setups provided by Windows, and describes the 
setups you should use with your synthesizer and MIDI output port. 



Use 

Ad Lib 

Ad Lib General 

LAPC1 

MT32 

Proteus/1 

Proteus General 

Extended MIDI 

General MIDI 
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With 

The Ad Lib or Ad Lib-compatible synthesizer included on your 
sound card. This setup uses channels 12-16 (base-level channels). 

The Ad Lib or Ad Lib-compatible synthesizer included on your 
sound card. This setup uses all 16 channels. 

The Roland synthesizer included on your LA PC 1 sound card. This 
setup uses all available LAPC 1 channels. 

The Roland MT-32 synthesizer connected to the Sound Blaster 
MIDI output port. This setup uses all available MT32 channels. 

The E-mu Systems Proteusll synthesizer connected to the Sound 
Blaster MIDI output port. This setup uses channels 1-10 
(extended-level channels). 

The E-mu Systems Proteus/1 synthesizer connected to the Sound 
Blaster MIDI output port. This setup uses all 16 channels. 

Any General MIDI synthesizer, such as the Roland Sound Canvas 
(SC-55), connected to the Sound Blaster MIDI output port. This 
setup uses channels 1-10 (extended-level channels). Use this setup 
to play MIDI files authored according to Microsoft guidelines. 

Any General MIDI synthesizer, such as the Roland Sound Canvas 
(SC-55), connected to the Sound Blaster MIDI output port. This 
setup uses all 16 channels. Use this setup to play MIDI files 
authored according to General MIDI guidelines. 

If you plan on playing MIDI files that are authored according to General MIDI 
guidelines, use a "general" setup for your synthesizer. If you plan on playing 
MIDI files that are authored according to Microsoft guidelines, use the other setup. 

If you are using a synthesizer that is connected to a MIDI output port other than 
Sound Blaster or a Sound Blaster compatible port, you will need to edit the setup 
to change the port assignments. For information about editing MIDI setups, see 
"Editing Key Maps, Patch Maps, and Setups" later in this chapter. If you are using 
a synthesizer that is not included in the list, you may need to create a MIDI setup 
for it. 
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Creating a New MIDI Setup 
You may need to create a MIDI setup if: 

• You connect your computer to a MIDI synthesizer that does not support 
General MIDI and you want to play MIDI files authored according to General 
MIDI guidelines. 

• You connect your computer to a MIDI synthesizer and Windows does not 
supply a setup for it. 

• You are using a MIDI synthesizer or sound card that includes a built-in 
synthesizer and Windows does not supply a MIDI setup for it. 

In this case, check with your MIDI- or sound-card manufacturer to see if an 
updated MIDIMAP.CFG file that includes a MIDI setup for your sound card is 
available. If you are able to obtain this file, quit MIDI Mapper, make a backup 
copy of the original MIDIMAP.CFG file, and then copy the MIDIMAP.CFG 
file you received from the manufacturer into your Windows SYSTEM 
directory. For information about copying files, see Chapter 4, "File Manager." 

There are several steps involved in creating a new MIDI setup. You need to 
perform these steps in the following order: 

1. Set up the synthesizer to receive MIDI messages on multiple MIDI channels. 
Refer to the manual that came with your synthesizer for information about how 
to do this. 

2. Determine whether your synthesizer is a base-level synthesizer, an extended­
level synthesizer, or a synthesizer that has enough voices to play General MIDI 
files. 

Base-level synthesizers meet these minimum requirements: the ability to play 
six notes on three melodic instruments and three notes on three percussion in­
struments simultaneously. Extended-level synthesizers meet these minimum 
requirements: the ability to play 16 notes on nine melodic instruments and 16 
notes on eight percussion instruments simultaneously. Synthesizers that can 
play General MIDI files have 24 voices or can play 16 notes on 15 melodic 
channels and eight notes of percussion. 

3. Create a key map for percussion instruments. Depending on your synthesizer, 
you might also need to create a key map to specify key-registration changes for 
melodic instruments. For example, if your synthesizer plays a certain patch one 
octave higher than General MIDI specifies, you can create a key map to correct 
the octave registration. For information about creating key maps, see the next 
topic, "Creating a Key Map." 
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4. Create two patch maps: one for the melodic instruments and one for the 
percussion instruments. For information about creating patch maps, see 
"Creating a Patch Map" later in this chapter. 

5. Specify the channel mapping for your synthesizer. 

Caution For the settings you specify in a MIDI setup to take effect, the appli­
cation you are using to play MIDI files or send MIDI information must use 
MIDI Mapper. Also, the application must send patch-select and volume-change 
messages, or a MIDI file must include them. MIDI files authored for Windows 
meet these requirements. If you are not sure whether your application supports 
MIDI Mapper, see your documentation or contact the application vendor. 

Creating a Key Map 
General MIDI specifies that certain keys, when played on a percussive channel, 
correspond to certain percussion instruments. General MIDI also specifies that 
each key, when played on a melodic channel, generates sounds within a certain 
octave. If your synthesizer does not support these specifications, you need to 
create a new key map for the percussion instruments. If your synthesizer plays 
certain sounds at registrations that differ from General MIDI definitions (for 
example, playing a patch a fifth higher than General MIDI specifies), you may 
also need to create a melodic key map for registration changes. 

~ To create a key map 

1. In the Control Panel window, choose the MIDI Mapper icon. 

The MIDI Mapper dialog box appears. 

2. In the Show area, select the Key Maps option button. 

3. Choose the New button. 

The New MIDI Key Map dialog box appears. 

Q.escription:1 '-________ -' 

4. In the Name and Description boxes, type a name and description for the new 
key map. 
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5. Choose the OK button. 

A dialog box for the new key map appears, listing the percussive sounds for 
source keys 35 through 81 as defined by General MIDI. 

/ 

Specify the keys your 
synthesizer uses here. 

IRIi1iflfi.il __ 

;~I 
36 ~ ~ 

Src Key Src Key Name 
35 Acoustic Bass Drum 

36 Bass Drum 1 

37 Side Stick 37 

38 Acoustic 5 nare 38 

38 Hand Clap 38 

40 Electric Snare 40 

41 Low Floor Tom 41 

42 Closed Hi Hat 42 

43 High Floor Tom 43 

44 Pedal Hi Hat 44 

45 Low Tom 45 

46 Open Hi Hat 46 

47 Low·Mid Tom 47 

48 High·Mid Tom 48 

49 Crash Cymbal 1 49 

50 High Tom 50 

6. Specify the destination keys required by your synthesizer. 

A detailed description of the options in the MIDI Key Map dialog box follows 
this procedure. 

7. When you are finished, choose the OK button. 

A dialog box appears, asking if you want to save your changes. 

8. Choose the Yes button to confirm the changes. 

9. In the MIDI Mapper dialog box, choose the Close button. 
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The following list describes the options in the MIDI Key Map dialog box. 

Option 

Src Key 

Src Key Name 

Dest Key 

Description 

Lists the MIDI keys that can occur within MIDI messages in a MIDI 
file. You cannot change these values. 

Displays the names of the percussion instruments associated with 
the source keys, as defined by the General MIDI specification. Use 
these names as a reference when creating a key map for percussion 
instruments. If you are creating a key map to correct registration 
changes for melodic instruments, you can ignore these names. 

Specifies the key that is played on your synthesizer when the source 
key number is sent by an application or encountered in a MIDI file. 

To change the destination key, select the Dest Key box, and then 
click the up or down arrow until the destination key number you 
want is displayed. Or select the key number, and then type a new 
number. 

Creating a Patch Map 
If your synthesizer's patch list differs from the General MIDI patch definitions, 
you need to create two patch maps: one for melodic instruments and one for 
percussion instruments. 

~ To create a patch map 

1. In the Control Panel window, choose the MIDI Mapper icon. 

The MIDI Mapper dialog box appears. 

2. In the Show area, select the Patch Maps option button. 

3. Choose the New button. 

The New MIDI Patch Map dialog box appears. 

,t!ame: 

i!.escliplion: IL-_______ -----' 

4. In the Name and Description boxes, type a name and description for the new 
patch map. 
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5. Choose the OK button. 

A dialog box for the new patch map appears, listing the sounds for source 
patches ° through 127 as defined by General MIDI. 

Specify the destination patches here. 
Specify the volume for the patch here. 

Specify the key map 
for each patch here. 

B right Acoustic Piano 

Electric Grand Piano [None] 

Honky-tonk Piano 100 [None] 

Rhodes Piano 100 [None] 

5 Chorused Piano 100 [None] 

6 Harpsichord 100 [None] 

Clavinet 100 [None] 

Celesta 100 [None] 

9 Glockenspiel 100 [None] 

10 Music Box 10 100 [None] 

11 Vibraphone 11 100 [None] 

12 Marimba 12 100 [None] 

13 Xylophone 13 100 [None] 

14 Tubular Bells 14 100 [None] 

15 Dulcimer 15 100 [None] 

li;i.ij~~jjHI l:ii!!H~lpH!11 

6. If the patch numbers for your synthesizer start at 1 rather than at 0, choose the 
"1 based patch #'s" button. 

Or press ALT+l. 

7. Assign a destination patch, volume level, and key map to the source patches. 

A detailed description of the options in the MIDI Patch Map dialog box follow 
this procedure. 

8. When you are finished, choose the OK button. 

A dialog box appears, asking if you want to save your changes. 

9. Choose the Yes button to confirm the changes. 

10. In the MIDI Mapper dialog box, choose the Close button. 

The following list describes the options in the MIDI Patch Map dialog box. 



Option 

Src Patch 

Src Patch Name 

Dest Patch 

Volume % 

Key Map Name 
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Description 

Lists the MIDI patch numbers that can occur within MIDI mes­
sages in a MIDI file. Some synthesizers define patch numbers 
from a through 127; others define patch numbers from 1 through 
128. You cannot change these values. 

Displays the names of the standard sounds or instruments 
associated with the source patch numbers for melodic channels, 
as defined by the General MIDI specification. Use these names as 
a reference when creating a patch map for melodic instruments. If 
you are creating a patch map for percussion instruments, you can 
ignore these names. 

Specifies the patch numbers your synthesizer uses that match the 
sounds or instruments listed in the Src Patch Name box. For syn­
thesizers that support General MIDI, this number is the same as 
the Src Patch number. 

To change the destination patch, select the Dest Patch box, and 
then click the up or down arrow until the destination patch number 
you want is displayed. Or select the number, and then type a new 
number. 

If you are creating the patch map for percussion instruments, 
change all the destination patch numbers to match the patch num­
ber that your synthesizer uses for percussion. 

Specifies the volume for the destination patch. This value is 
measured as a percentage of the volume specified by a MIDI 
volume message in the MIDI file. The default value is 100, which 
specifies that the patch will play at the volume indicated in the 
MIDI file. 

To change the volume setting, select the Volume % box, and then 
click the up or down arrow until the volume percentage you want 
is displayed. Or select the number, and then type a new number. To 
increase the volume, use a number greater than 100. To decrease 
the volume, use a number less than 100. 

Specifies the key map used with the patch. 

To specify a key map, open the Key Map Name list, and then 
select the key map you want. 

If you are creating the patch map for percussion instruments, 
specify the key-map name you created for percussion for all the 
source patches. 

If you are creating the patch map for melodic instruments and 
your synthesizer produces certain sounds using a registration that 
differs from General MIDI definitions, select a key map that maps 
the keys to play at the appropriate registration for the patch corre­
sponding to that sound. For example, if your synthesizer plays 
Chorused Piano one octave higher than defined by General MIDI, 
select the -1 octave key map for the patch that corresponds to 
Chorused Piano. 
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Specifying Channel Mapping 
Once you have created the patch maps and key maps required by your synthesizer, 
you can specify the channel mapping for the new MIDI setup. 

The MIDI Mapper lists 16 channels. Files authored using the Microsoft authoring 
guidelines for General MIDI use source channels 13 through 16 for base-level 
synthesizers and channels 1 through 10 for extended-level synthesizers. On base­
level synthesizers, channels 13 through 15 are the melodic channels and 16 is the 
percussive channel. On extended-level synthesizers, channels 1 through 9 are the 
melodic channels and channel 10 is the percussive channel. 

~ To specify the channel mapping 

1. In the Control Panel window, choose the MIDI Mapper icon. 

The MIDI Mapper dialog box appears. 

2. In the Show area, select the Setups option button. 

3. Choose the New button. 

The New MIDI Setup dialog box appears. 

Harne: 

D.escriplion: L-I _______ ---' 

4. In the Name and Description boxes, type a name and description for the new 
setup. 

5. Choose the OK button. 

A dialog box for the new setup appears. 



Src Chan Dest Chan Port Name 

1 il ~ [None] 

2 2 [None] 

3 3 [None] 

4 4 [None] 

5 5 [None] 

6 6 [ None] 

7 7 [None] 

8 8 [None] 

9 9 [None] 

10 10 [None] 

11 11 [None] 

12 12 [None] 

13 13 [None] 

14 14 [None] 

15 15 [ None] 

16 16 [None] 
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Specify the destination channel here. 

Specify the port to send sounds to here. 

Patch Map Name 

I,! [None] 
[None] 

[None] 

[None] 

[None] 

[ None] 

[None] 

[None] 

[None] 

[None] 

[None] 

[None] 

[None] 

[None] 

[None] 

[None] 

Specify the patch map for 
each channel here. 

L! 
Active 

II! 
II! 
II! 
II! 
II! 
II! 
II! 
II! 
II! 
II! 
II! 
II! 
II! 
II! 
II! 

Activate a channel by 
selecting its check box. 

6. For each source channel used by your synthesizer, specify a destination 
channel, a port name, and a patch map. 

A detailed description of the options in the MIDI Setup dialog box follows 
this procedure. 

7. When you are finished, choose the OK button. 

A dialog box appears, asking if you want to save your changes. 

8. Choose the Yes button to confirm the changes. 

9. In the MIDI Mapper dialog box, choose the Close button. 
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The following list describes the options in the MIDI Setup dialog box. 

Option 

Src Chan 

Dest Chan 

Port Name 

Patch Map Name 

Active 

Description 

Lists the MIDI source channels that can occur within a MIDI 
message in an application or MIDI file. You cannot change these 
values. 

Specifies the channel that your synthesizer will use to play the 
sounds on the source channel. The default value is the same as 
the value for the source channel. If your synthesizer supports 
General MIDI, use the default values. 

To change the value, select the Dest Chan box, and then click the 
up or down arrow until the destination channel number you want 
is displayed. Or select the number, and then type a new number. 

Specifies the name of the MIDI output port that the sounds 
on the source channel are sent to. You do not need to use the 
same port for each channel. For example, if you are using two 
synthesizers, such as an Ad Lib and a synthesizer connected to 
the MIDI output port of your computer, you could send some 
sounds on certain channels to the Ad Lib port, and other sounds 
on other channels to the MIDI output port. 

To specify the port name, open the Port Name list, and then select 
the port you want. 

Specifies the patch map used with a particular channel. To 
specify a patch map, open the Patch Map Name list, and then 
select the patch map you want. 

Which patch map you select depends on whether the source 
channel is melodic or percussive. For melodic source channels, 
select the patch map you created for melodic instruments. For 
percussive source channels, select the patch map you created 
for percussion instruments. On base-level synthesizers, melodic 
channels are 13-15 and the percussive channel is 16. On 
extended-level synthesizers, melodic channels are 1-9 and 
the percussive channel is 10. 

Specifies whether MIDI information for a particular channel is 
sent to the selected port. When you select a port name, this box is 
selected automatically, indicating that MIDI information will be 
sent to the port. 

To change the setting, select the Active check box. 
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Editing Key Maps, Patch Maps, and Setups 
You can edit the key maps, patch maps, and channel mapping for an existing 
MIDI setup. Generally you should not need to do this, unless you are not getting 
the sounds you expect, or you want to use a setup provided by Windows and the 
setup specifies port assignments that differ from those used by your synthesizer. 

~ To edit key maps, patch maps, or setups 

1. In the Control Panel window, choose the MIDI Mapper icon. 

The MIDI Mapper dialog box appears. 

2. In the Show area, select the option button (Key Maps, Patch Maps, or Setups) 
that corresponds to the type of map (key map, patch map, or channel map) that 
you want to edit. 

3. Open the Name list, and then select the name of the map you want to edit. 

4. Choose the Edit button. 

The Edit dialog box for the specified key map, patch map, or setup appears. 

5. Make any changes you want. 

For information about how to edit the settings in the dialog box, see the 
procedures for creating a key map or patch map and for specifying channel 
mapping, earlier in this chapter. 

6. When you are finished, choose the OK button. 

A dialog box appears, asking if you want to save your changes. 

7. To save the changes, choose the Yes button. 

8. In the MIDI Mapper dialog box, choose the Close button. 

Deleting a Key Map, Patch Map, or Setup 
If you are not using a particular key map, patch map, or setup, you can delete 
it. Keep in mind that you cannot delete the current MIDI setup (the setup that is 
displayed in the Name box when the MIDI Mapper dialog box first appears). In 
addition, you cannot delete a key map that is used in a patch map or a patch map 
that is used in a MIDI setup. Before deleting key maps and patch maps, make sure 
that an existing patch map or setup does not reference the key map or patch map 
you want to delete. 
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~ To delete a key map, patch map, or setup 

1. In the Control Panel window, choose the MIDI Mapper icon. 

The MIDI Mapper dialog box appears. 

2. In the Show area, select the option button (Key Maps, Patch Maps, or Setups) 
that corresponds to the type of map (key map, patch map, or channel mapping) 
that you want to delete. 

3. Open the Name list, and then select the name of the map you want to delete. 

4. Choose the Delete button. 

A dialog box appears, asking you to confirm the deletion. 

5. To delete the map, choose the Yes button. 

6. In the MIDI Mapper dialog box, choose the Close button. 

Setting Options for Running Windows in 386 Enhanced Mode 
If Windows is running in 386 enhanced mode, the Control Panel window includes 
a 386 Enhanced icon. When you choose this icon, you can specify how applica­
tions compete for peripheral devices and how much of the computer's resources 
are allocated to Windows and non-Windows applications. For detailed instructions 
on how to specify these options, see Chapter 14, "Optimizing Windows." 



Print Manager 

Chapter 6 

What Is Print Manager? 
Print Manager is an important part of the Microsoft Windows operating system. 
You use Windows Print Manager to install and configure printers, connect to net­
work printers, and control the printing of your files. 

If you print from a Windows application when Print Manager is active, the applica­
tion creates a print file and sends it to Print Manager. Print Manager works in the 
background, sending your files to the printer while you continue working. You can 
check the status of a file in the print queue at any time, and change the status of 
the file until it starts printing. 

Print Manager also works together with your network to provide information 
about network print queues and files you have sent to a particular network printer. 

Before you can use Print Manager to perform printing tasks, you must activate it. 
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~ To activate Print Manager 

1. In the Main group, choose the Control Panel icon. (Double-click the icon. Or 
use the arrow keys to move the selection cursor to the icon, and then press 
ENTER.) 

2. In the Control Panel window, choose the Printers icon. 

The Printers dialog box appears. 

Installed Printers: -----------, r mmu 

lSl.!lse Print Manager 

3. Select the Use Print Manager check box, ifit is not already selected. 

4. Choose the Close button. 

Installing and Configuring a Printer 
Before you can print in Windows, you need to connect your printer to your com­
puter, and then install it. If you did not install a printer when you set up Windows, 
or if you want to add another one, use the procedures described in this section. 

The PRINTERS. WRI file supplied with Windows provides specific information 
about many printers that Windows supports. By using Windows Write, you can 
view this file to determine whether it includes information about your printer. It 
is recommended that you read this file before installing a printer. For additional 
information about your printer, see your printer manual. 

To use a printer with Windows applications, you must first do the following: 

• Install a printer-driver file for the printer you want to use. 

• Select the port you want to assign the printer to. 
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After you install a printer-driver file and assign the printer to a port, you may be 
able to print, but you may not get the results you want. If this is the case, you may 
want to perform some or all of the following procedures: 

• Set the print options that the printer driver will use while printing your 
documents. 

• Specify how much time should elapse before you receive messages about 
printer problems. 

• Select the default printer. 

The following sections explain how to perform each of these tasks. 

Note You can also use the Printers option in Control Panel to perform these tasks. 
The Printers option provides the same method for installing and configuring a 
printer as the method described in the following sections. 

Installing a Printer-Driver File 
A printer-driver file gives Windows important information about your printer, 
including details about printer features and the printing interface, descriptions of 
fonts (such as sizes and styles), character translations, and control sequences the 
printer uses to produce various formats. Windows comes with printer-driver files 
for most of the commonly used printers. 

When you want to install a printer, Windows displays a list of printers to choose 
from. If your printer isn't listed or if you are prompted to insert an unlisted, up­
dated, or vendor-provided printer-driver disk, it means Windows does not have 
a printer-driver file for your specific printer. Your printer might be supported, 
however, through a printer-driver file for another printer, or a driver might have 
been developed after this version of Windows. For more information, see 
"If Your Printer Is Not Listed" later in this chapter. 

~ To install a printer-driver file 

1. In the Main group, choose the Print Manager icon. 

The Print Manager window appears. 

2. From the Options menu, choose Printer Setup. 

The Printers dialog box appears. If you did not install a printer during Setup, 
the dialog box expands and the Add button is dimmed. Continue to step 4. 
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3. Choose the Add button. 

The dialog box expands to display a list of printers supported by the printer­
driver files supplied by Windows. 

Installed Prinlers: -----------, rl l!!l!!l!1!I'IoIltl ••• 

Lisl of Prinlers: 
HP LaserJel500+ 
HP LaserJel2000 
HP LaserJel Series II 

HP LaserJelliD PoslScripl 
HP LaserJel liP 
HP LaserJelliP PostScripl 
HP LaserJel III 

Printers supported by Windows 

4. In the List Of Printers box, select the printer you want to install. 

Note If you are installing a PostScript printer, do not select PostScript 
Printer. If you do, your documents may not print correctly. Select the name 
of the printer model instead. If you are installing a laser printer that supports 
PostScript cartridges or has built-in PostScript capabilities, see the following 
section, "If You Are Using a Laser Printer with a PostScript Cartridge." 

5. Choose the Install button. 

If the printer-driver file for the printer you selected is not already installed, a 
dialog box appears, prompting you to insert the disk that contains the printer­
driver file. This disk may be one of the disks included with Windows or, if the 
message prompts you to "Insert unlisted, updated, or vendor-provided printer 
driver disk," it is the printer-driver disk provided by your printer manufacturer. 

6. If necessary, insert the disk that contains the printer-driver file, and then choose 
the OK button. 

Or, if you know where the file is on your hard disk, type the drive letter and 
directory name where the file is located, and then choose the OK button. 
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If you do not know where the printer-driver file is, you can choose the Browse 
button. This displays the Browse dialog box, in which you can locate and select 
the drive and directory that contain the printer-driver file. When you finish 
using the Browse dialog box, choose the OK button to return to the Printers 
dialog box. 

Another dialog box may appear, prompting you for the disk that contains the 
font files or other files associated with the printer. 

7. If you are prompted for other files, insert the appropriate disk, and then choose 
the OK button. 

Or specify the drive and directory where the additional files are located, using 
one of the methods described under step 6. 

Windows copies the file(s) to your hard disk, and the Printers dialog box 
reappears. 

The name of the printer model you selected appears in the Installed Printers 
box. If it is the first printer you installed, it is assigned as the default printer. 
"LPT 1" appears next to the name indicating the default port assignment. 

Note If this printer is not connected to LPTl, you need to change the port 
assignment. For information about how to change the port assignment, see 
"Selecting a Printer Port" later in this chapter. If you want to change the 
default printer, see "Choosing the Default Printer" later in this chapter. 

8. Choose the Close button. 

If You Are Using a Laser Printer with a PostScript Cartridge 
Some laser printers support PostScript cartridges that can emulate a specific 
PostScript-printer model. If you are installing a laser printer with such a PostScript 
cartridge, select the PostScript printer that your cartridge emulates from the List 
Of Printers box in the Printers dialog box. For example, if you were installing a 
Hewlett-Packard LaserJet lID with a PostScript cartridge that can emulate an 
Apple Laserwriter, you would select the Apple LaserWriter printer and not the 
HP LaserJet lID printer. 

If you are installing a laser printer with a PostScript cartridge that does not 
emulate a specific PostScript-printer model, select the PostScript version of the 
printer model from the List Of Printers box. For example, if you are installing a 
Hewlett-Packard LaserJet lID with a PostScript cartridge, you would select the 
HP LaserJet lID PostScript printer from the List Of Printers box. This also 
applies if you want to print in PostScript mode to a laser printer that has built-in 
PostScript capabilities. 

For information about how to install your printer, see the previous section, 
"Installing a Printer-Driver File." 
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If Your Printer Is Not Listed 
If your printer is not listed in the Printers dialog box, you may still be able to use 
your printer with Windows. 

First, check the Hardware Compatibility List provided in the Windows package. If 
your printer is not on this list, check the printer manual. It might indicate whether 
your printer is IOO-percent compatible or has an emulation mode that is compat­
ible with a printer in the List Of Printers box. Look for DIP-switch settings or 
modes in the index of the printer manual. 

For example, you can change DIP-switch settings on many dot-matrix printers so 
that they emulate an Epson printer. Also, you can change DIP-switch settings or 
use menu commands on many laser printers so that they emulate an HP LaserJet 
printer. However, when you use your printer in emulation mode, you might not be 
able to use all the printer's features. 

If your printer is not 100-percent compatible and does not have an emulation mode 
that is compatible with a printer in the List Of Printers box, you have three options: 

• Contact your printer manufacturer for a printer driver that works with Windows. 

• Request information about additional drivers included on the Microsoft 
Windows Driver Library Disk. Microsoft adds drivers as they become avail­
able. For more information, see "Installing a Device Driver Not Supplied with 
Windows Version 3.1" in Chapter 15, "Maintaining Windows with Setup." 

• For non-U.S. customers, use the Additional Non-USA Printer Drivers disk that 
comes in your Windows package. This disk contains printer-driver files that 
support printers used in countries outside the United States. 

For information about installing an unlisted printer-driver file, see the following 
section. 

If none of these suggestions works for you, select GenericlText Only in the List Of 
Printers box. The Generic/Text Only printer driver works with most printers and 
should be selected for daisy-wheel printers. Using this printer driver, you can print 
text, but not graphics. 
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Installing a Printer Driver Not Supplied with Windows 
If you receive a new printer driver from a printer manufacturer, you should follow 
any instructions the manufacturer provides for installing the printer driver. 

If there are no instructions, carry out the following procedure to install the printer 
driver. 

~ To install a printer driver not supplied with Windows 

1. In the Main group, choose the Print Manager icon. 

2. From the Options menu, choose Printer Setup. 

The Printers dialog box appears. 

3. Choose the Add button. 

The List Of Printers box appears. 

4. In the List Of Printers box, select Install Unlisted Or Updated Printer. 

5. Choose the Install button. 

A dialog box appears, instructing you to insert the disk that has the printer­
driver file on it. 

6. Insert the disk that contains the printer-driver file. If you are a non-U.S. 
customer, insert the the Additional Non-USA Printer Drivers disk that comes 
in your Windows package. 

7. Choose the OK button. 

Another dialog box appears, listing several printers. 

8. In the List Of Printers box, select the printer you want. If your printer still does 
not appear in this list, you need to contact your printer manufacturer for the 
correct printer driver. 

9. Choose the OK button. 

The Printers dialog box appears. 

The new printer is added to the Installed Printers list. 

10. Choose the Close button. 
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Selecting a Printer Port 
When you install a printer-driver file, the printer is assigned to LPT1. If your 
printer is connected to a different port, you need to change the port assignment. 

Note Do not change the port assignment for a printer you are currently printing 
documents to. If you do so, your documents will disappear from the Print Manager 
queue. Your documents will still print, but you will not be able to perform Print 
Manager tasks on them, such as pausing and resuming printing or viewing status 
information. 

~ To select the printer port 

1. If you are not already using the Printers dialog box, choose Printer Setup from 
the Options menu. 

The Printers dialog box appears. 

2. In the Installed Printers box, select the printer whose port assignment you want 
to change. 

3. Choose the Connect button. 

The Connect dialog box appears. 

Local Port Not Present 
Local Port Not Present 
Local Port Not Present 
Local Port Not Present 

[U 
I.ransmission Retry: @] 

[Z] East Printing Direct to Port 

The Ports box 

Iilt::::;:i,)/] 

&~~~ll\;::.:1 
I :.~l:f}M~ri!~!;>llliI 
Ill.it'i:i~inii.1 
Imi::H!il~H;;'H'!1 

4. Select the port you want to assign the printer to. A description of each port 
follows this procedure. 

If you select a serial (COM) port, you may need to change the port's com­
munications settings to match those required by your printer. Windows uses 
the most common communications settings for serial printers; these settings 
should work with most printers. 
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5. If you need to change the communications settings, choose the Settings button, 
and then make any changes you need in the Settings dialog box. (The Settings 
button is unavailable if your printer is assigned to a parallel [LPT] port.) For 
information about the communications settings, see Chapter 5, "Control Panel." 
For information about the settings that your printer requires, see your printer 
manual. 

If you are installing a network printer, you can connect to it by choosing the 
Network button. For more information about connecting to a network printer, 
see "Connecting to a Network Printer" later in this chapter. 

When you are finished, choose the OK button. 

6. In the Connect dialog box, choose the OK button. 

The Printers dialog box appears, with the selected port next to the highlighted 
printer name in the Installed Printers box. 

7. Choose the Close button. 

You can connect your printer to one of the following ports. 

Port Description 

LPT A parallel port. 

COM A serial port. 

EPT Used for the IBM Personal Pageprinter. This port requires that a special card 
be installed in your computer. 

FILE Prints to a file instead of to a printer. If the application you are working with 
supports this feature, you can print to a file even if you don't select this 
option. 

If you are using non-Windows applications in 386 enhanced mode, you can 
specify what happens when several applications compete for access to a printer 
port. For more information, see Chapter 14, "Optimizing Windows." 

Setting the Printing Options 
Printing options are printer-specific settings, such as resolution, color, and text 
quality. These options vary, depending on the capabilities of your printer. 

Windows assigns settings that should work for your printer in most situations. 
You can change these settings to specify different options. 



208 Microsoft Windows User's Guide 

~ To change printer settings 

1. If you are not already in the Printers dialog box, choose Printer Setup from the 
Options menu. 

The Printers dialog box appears. 

2. In the Installed Printers box, select your printer. 

3. Choose the Setup button. 

A printer setup dialog box appears, displaying the options for the selected 
printer. The following is a sample printer setup dialog box. The options dis­
played in these dialog boxes vary, depending on the printer you are using. 

1300 dots per inch II 
Paper Si~e: I letter 8 ':I: x 11 in Il!I 
Paper ~ource: I Upper Tray II 

~================~~ 
!!temory: 1L-1o_6_M_B _______ --"'II_! 

Orientation 

Car!ridges (max: 2) 

HP: ProCollection 
HP: WordPerfect 
HP: Global Text 
HP: Great Start 

4. Make any necessary changes to the options, and then choose the OK button. 

The Printers dialog box appears. 

5. Choose the Close button. 

The following table describes some of the common printing options found in a 
printer setup dialog box. The printer setup dialog box is different for each printer, 
so some options may not be included here. For a description of the options specific 
to your printer, choose the Help button or press Fl while using the printer setup 
dialog box. 



Use 

Paper Source 

Paper Size 

Memory 

Orientation 

Resolution 

Cartridges 

Fonts 

Options 

Help 
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To 

Specify the tray or bin feeder option if your printer uses single sheets 
of paper. Select Tractor if your printer prints on paper that feeds into 
it through a tractor feeder. On some printers, you can choose to feed 
paper manually. 

Specify the paper size you are using. The default paper size de­
pends on the country that is currently selected in the Control Panel 
International dialog box. If United States is selected, the default 
paper size for most printers is letter (8.5 by 11 inches). If a European 
country is selected, the default paper size is A4. If you are using a 
different paper size, you must change this setting. For information 
about customizing Windows for international use, see Chapter 5, 
"Control Panel." 

Specify the amount of printer memory. To find out how much 
memory your printer has, see your printer manual or contact the 
manufacturer. If you cannot find the information, use the default 
setting. 

Specify portrait or landscape orientation. Portrait means the page 
is taller than it is wide when you view the printed text upright. 
Landscape means the page is wider than it is tall when you view 
the printed text upright. 

Specify the resolution you want to use for printing graphics. Resolu­
tion settings may be listed as High, Medium, or Low, but are most 
often listed in dots per inch (DPI). The more dots per inch, the higher 
the resolution. Higher resolutions print more slowly but produce 
higher-quality graphics, whereas lower resolutions print faster but 
produce lower-quality graphics. 

Select the font cartridges you want to use from the list. You can select 
up to the maximum number of cartridges that can be physically 
plugged into your printer. 

Run the Font Installer program to install additional cartridge or 
downloadable soft fonts for your printer. These fonts are supplied 
by printer or font manufacturers, not by Windows. For more infor­
mation about installing these fonts, see the next section, "Installing 
Additional Fonts for Your Printer." 

Display the Options dialog box, which lists additional printing 
options specific to your printer. For more information about these 
options, choose the Help button in the Options dialog box. 

Display information about how to use the printer setup dialog box. 

Note If you change the port assignment for a printer, you should also check 
the print settings to make sure they are still correct. With some printers, certain 
settings no longer apply when you change the port assignment. 
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Installing Additional Fonts for Your Printer 
When setting printing options, you may be able to install additional cartridge or 
soft fonts, or scalable typefaces supplied by a printer or font manufacturer. If your 
printer supports these fonts, the Fonts button and/or the Cartridge list appears in 
the printer setup dialog box. Cartridge fonts are stored in cartridges that must be 
inserted into the cartridge slots on your printer before you can use the fonts. Soft 
fonts and scalable typefaces are stored in font files on disks. Soft fonts have 
predefined point sizes, whereas scalable typefaces can be scaled to any size. 

Some printer drivers supplied by Windows include information about cartridge 
fonts. If you are setting printing options for a printer that uses such a printer 
driver, there is no need to install the fonts. The supported cartridge fonts appear 
in the Cartridges list in the printer setup dialog box. 

~ To use supported cartridge fonts 

1. If you are not already using the Printers dialog box, choose Printer Setup from 
the Options menu. 

The Printers dialog box appears. 

2. Select the printer you want to use, and then choose the Setup button. 

The printer setup dialog box appears. 

3. From the Cartridges list, select the font cartridges you want to use. 

4. Set any other printing options you want. 

5. Choose the OK button. 

The Printers dialog box appears. 

6. Choose the Close button. 

If you want to use scalable typefaces or soft fonts, or if the cartridge fonts do not 
appear in the Cartridges list, you need to install them. 

To install scalable typefaces, or soft or cartridge fonts, use the installation program 
that comes with the fonts package. If no installation program was provided and 
you are using a Hewlett-Packard DeskJet or LaserJet (PCL) printer, you can use 
the Font Installer program provided with Windows. 

After you install cartridge fonts by using Font Installer, the fonts appear in the 
Cartridge list in the printer setup dialog box. If you use another method to install 
cartridge fonts, they do not appear in the Cartridge list, but they are still available 
to your Windows applications. 
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~ To run Font Installer 

1. If you are not already using the Printers dialog box, choose Printer Setup from 
the Options menu. 

The Printers dialog box appears. 

2. Select the printer for which you want to install fonts, and then choose the Setup 
button. 

The printer setup dialog box appears. 

3. Choose the Fonts button. (If you're not using a PCL printer, the Fonts button 
does not appear in the dialog box.) 

The Font Installer dialog box appears. 

HP !..aserJet on LPTl 

No fonts installed 

To install new fonts, click on the [Add fonts] button_ 

There may be additional tasks you need to perform prior to installing your 
fonts. For information about this and other topics, choose the Help button in 
the Font Installer dialog box. 

Note If you change the port a printer is connected to, you need to copy any car­
tridge or soft fonts you have installed to the new port. To do this, use the Copy 
Fonts To New Port button in the Font Installer dialog box. 
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Selecting Timeouts Options 
Timeouts options control the amount of time that elapses before a message appears 
to notify you of printer problems. 

The default settings for the Timeouts options work with all printers, and you 
should use these settings unless you have a specific problem. For example, if 
you are configuring a PostScript printer, you may want to increase the value for 
Transmission Retry significantly, especially if you plan on printing documents 
that contain complicated graphics or several types of fonts. If you print to a net­
work printer and network traffic is heavy, you might also need to increase the 
Transmission Retry setting. 

~ To change the Timeouts options 

1. If you are not already using the Printers dialog box, choose Printer Setup from 
the Options menu. 

The Printers dialog box appears. 

2. In the Installed Printers box, select the printer whose Timeouts settings you 
want to change. 

3. Choose the Connect button. 

The Connect dialog box appears. 

HP laserJet lID 

e.orts: 

lPT2: local Port Not Present 
lPT3: local Port Not Present 
COM1: local Port Not Present 
COM2: local Port Not Present 

Timeouts (seconds) 
D.evice Not Selected: ~ 

lransmission Retrv: ~ 

Inll,'i\\OIM::'iIBl' 
1!1\;14'llWiX\~1.11 
IlnM~'~i~R~;!11 
1;I@tilllt4~:1 

4. Change Timeouts options as needed. The Timeouts options are described in 
the table following this procedure. 
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5. Choose the OK button. 

The Printers dialog box appears. 

6. Choose the Close button. 

Use 

Device Not Selected 

Transmission Retry 

Choosing the Default Printer 

To 

Control the amount of time that Print Manager continues to 
check the printer to determine whether it is online and ready 
to print. If the printer is not ready to print after the amount of 
time specified for this setting has elapsed, a message appears, 
notifying you that the printer is offline. The default setting is 
15 seconds. 

Control the amount of time that elapses before a message 
appears to notify you that your printer cannot accept any 
more information. After the printer finishes processing the 
information it currently has, it clears its memory and is ready 
to accept more information. The default setting is 45 seconds 
for non-PostScript printers and 90 seconds for PostScript 
printers. 

Many Windows applications use the default printer when you choose the Print 
command. Only one default printer can be selected at a time. If you have several 
printers installed, you can use the Printer Setup command whenever you want to 
change the default printer. 

~ To select a default printer 

1. If you are not already using the Printers dialog box, choose Printer Setup from 
the Options menu. 

The Printers dialog box appears. 

2. In the Installed Printers box, select the printer you want to use as the default 
printer. 
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3. Choose the Set As Default Printer button. 

The printer name appears in the Default Printer area of the Printers dialog box. 

The name of the default 
printer appears here. 

Installed Printers: ------------, 

L 
4. Choose the Close button. 

Other Windows applications may have a print setup command that you can use to 
print to any installed printer. In most cases, selecting a different printer does not 
make it the default printer. However, some applications do change the setting for 
the default printer. For information about the print setup command in an applica­
tion, see the documentation for the application. 

Removing an Installed Printer 
If you are no longer using an installed printer, you can remove it from the Installed 
Printers list in the Printers dialog box. 

~ To remove an installed printer 

1. In the Main group, choose the Print Manager icon. 

The Print Manager window appears. 

2. From the Options menu, choose Printer Setup. 

The Printers dialog box appears. 

3. In the Installed Printers box, select the printer you want to remove. 

4. Choose the Remove button. 

A message appears, asking you to confirm the removal. 

5. Choose the Yes button to remove the printer. 

6. Choose the Close button. 
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Removing a printer from the Installed Printers list does not remove the printer­
driver file from your hard disk, because another printer may use the same driver. 
In addition, removing the printer-driver file does not remove any associated fonts 
from memory, because another printer-driver file might use the fonts. For infor­
mation about removing fonts from memory, see "Removing a Font" in Chapter 5, 
"Control Panel." 

Printing Documents 
The way you print documents depends on the application you are using. Most 
Windows applications include a Print command on the File menu that you can use 
to print the current document. You can also use File Manager to print documents 
that are associated with a particular application. (For information about printing 
from File Manager, see Chapter 4, "File Manager.") When you print from a 
Windows application, the application uses the printer drivers for your printer, 
and Print Manager, if Print Manager is active. 

You might find slight differences in the way various Windows applications 
print. To make sure you understand these differences, read the documentation 
on printing that comes with the application. 

Printers differ in their abilities to use fonts, graphics, spacing, alignment, and 
character formats. The appearance of your printed document is affected by three 
factors: whether you can specify fonts and formats in your application, the font 
and format choices you make, and the fonts and formats your printer can print. 

Some applications attempt to display fonts on the screen as you would see them 
on the printed page. However, unless you use TrueType fonts, you may need to 
experiment to get the printed results you want. If you use TrueType fonts, your 
document looks the same when it is printed as it does when it is displayed on the 
screen. For more information about using TrueType fonts, see "Using Fonts" in 
Chapter 5, "Control Panel." 

Printing from Non-Windows Applications 
Non-Windows applications that you start from Windows print the same way they 
would if you started them from MS-DOS. The applications do not use Windows 
printer drivers and do not route print files through Print Manager. 

If you want to use Windows printer drivers and Print Manager when printing 
from a non-Windows application, you must transfer the information to be printed 
into a Windows application. For example, if you are using Microsoft Word for the 
Personal Computer, you need to transfer your documents to Microsoft Word for 
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Windows to take full advantage of the Windows printing features. For more infor­
mation about using non-Windows applications, see Chapter 7, "Non-Windows 
Applications. " 

Looking at the Print Queue 
As you send files to Print Manager, a print queue forms. A print queue lists the 
installed printers that have had files sent to them and shows the status of those 
files. There are two types of print queues: local and network. The local queue 
shows all files sent from a Windows application to a printer connected locally 
to your computer (that is, the computer and the printer are directly connected 
by a cable). 

When Print Manager starts printing to a local printer, the Print Manager icon 
appears at the bottom of your screen. If you enlarge the icon to a window, you can 
view the print queue for any printer connected to your computer. You can use the 
Print Manager window to check the status of files in the print queue or to interrupt 
or cancel the printing of files. 

The network queue refers to the print queue on the network server. This queue 
is generally managed by a network print manager, instead of Windows Print 
Manager. When you print files to a network printer, Print Manager requests status 
information from the network print manager and then displays this information 
in the Print Manager window. For more information about how Print Manager 
handles network printing, see "Managing Network Printing" later in this chapter. 

The Print Manager icon does not appear at the bottom of your screen when you 
print to a network printer. To view the status of your network print job, you must 
start Print Manager from the Main group. 

~ To look at the print queue 

• In the Main group, choose the Print Manager icon. 

Or, if you are printing to a local printer, restore the Print Manager icon. 
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Information for a network print queue 
Information for a local print queue 

ob 1 (Paintbrush" ARTWORK.BMP) is printing on 
\\PRINTROOM\PRINTER 

4% of 458K 1 :43 PM 10/19/1991 

QMS-PS 810 on \\PRINTROOM\PRINTER Active 
Ii W) 

1 Calendar- SCHEDULE.CAL 13K 1:12PM 10/19/1991 

Information for the file 

The print queue displays the following printer information: 

• The name of the printer. 

Message box 

• The port your printer is connected to, and, if it is a network printer, the network 
path. 

• The current status of the printer (such as active or idle). 

Beneath the printer information, the print queue displays the following file 
information: 

• The title of the print job (some network software may not support this option). 

• The file's position in the queue, or a printer icon if the file is printing. 

• The size of the file in kilobytes (if the Print File Size command has a check 
mark next to it). 

• The time and date you sent the file to Print Manager (if the TimelDate Sent has 
a command check mark next to it). If you are connected to a network printer, 
the network time and date are shown, which may differ from your computer's 
time and date. 

• If a file is currently printing, the amount (as a percentage) of the file printed 
so far. 

If you are connected to a network printer, any information the network can 
provide appears in the message box at the upper-right comer of the Print Manager 
window. 
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Print Manager only reports the status of files that you have sent to the network 
printer from your Windows applications. For information about viewing every file 
in a network queue, see "Viewing the Entire Network Queue" later in this chapter. 

Changing the Order of the Queue 
You can change the position of a file in a local queue if it is not the first file in the 
queue or if it has not yet begun to print. However, you cannot change the position 
of files in a network queue. 

~ To change the order of files in the queue 

• Select the file whose position you want to change, drag it to its new position in 
the print queue, and then release the mouse button. 

Or select the file, press and hold down CTRL, and press the UP ARROW or DOWN 

ARROW key to move the file to its new position. Then release CTRL and the 
arrow key. 

The file information in the print queue changes to reflect the new positions of the 
files. 

Pausing and Resuming Printing 
You can interrupt printing on a local print queue by selecting the printer (to inter­
rupt the entire queue), or by selecting an individual file, and then using buttons 
in the Print Manager window. Most networks support the ability to interrupt the 
printing of an individual file. However, your ability to interrupt the entire network 
queue depends on the features the network supports. 

'-----"-----"- Use these buttons to interrupt, 
resume, and cancel printing. 
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~ To temporarily interrupt printing 

1. Select the printer for the print queue, or select the individual file you want to 
pause. 

2. Choose the Pause button. 

Or press ALT+P. 

The information displayed for the printer or file now indicates that printing has 
paused. 

~ To resume printing 

1. Select the printer for the print queue, or select the individual file you want to 
continue printing. 

2. Choose the Resume button. 

Or press ALT+R. 

The information displayed for the printer or file changes to indicate that printing 
has resumed. 

Deleting a File from a Print Queue 
You can use the Delete button in the Print Manager window to delete a file from a 
local print queue at any time. Whether you can delete a file from a network print 
queue depends on the capabilities of the network. 

~ To delete a file from a print queue 

1. From the print queue, select the file you want to delete. 

2. Choose the Delete button. 

Or press ALT+D. 

A message appears, asking you to confirm the deletion. 

3. Choose the OK button. 
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~ To delete all files from all print queues 

1. From the View menu, choose Exit. 

A message appears, asking you to confirm that you want to cancel printing. 

2. Choose the OK button. 

If you do not choose the OK button, Print Manager continues to operate and the 
files continue to print. 

Caution If you delete a file currently printing in graphics mode, you might need to 
reset your printer to ensure that the printer's buffer is clear. (Tum your printer off 
and on again, or select the Reset option, if available. It is most important to do this 
with laser-type printers.) 

Changing the Printing Speed 
You can specify the rate at which information passes from Print Manager to the 
printer by using the Low Priority, Medium Priority, or High Priority command 
on the Options menu. Specifying a priority for Print Manager determines how 
your computer's processor time is divided between Print Manager and your other 
applications. For example, if you specify Low Priority, Print Manager receives 
less processor time than your other applications, causing those applications to 
run faster. 

A check mark next to a Priority command 
indicates the current Priority setting. 

OM Alert Always [Active] 
.,j flash if Inactive 

ignore if Inactive 

Network Settings ... 
Network .konnections ... 

~ To set a priority for Print Manager 

• From the Options menu, choose High, Medium, or Low Priority. 
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Each command is described here. 

Use 

High Priority 

Medium Priority 

Low Priority 

To 

Assign more of your computer's processor time to Print Manager. 
This causes other applications to run more slowly. 

Distribute your computer's processor time as equally as possible 
between Print Manager and other applications that are running. 
This is the default setting. 

Give more of your computer's processor time to your other 
applications. This causes Print Manager to slow down. 

The command you choose remains in effect until you choose a different command 
from the Options menu. 

Displaying Print Manager Messages 
Occasionally, Print Manager displays a message. For example, if your printer is 
set up for manual paper feed, Print Manager requests that you feed in a new sheet 
of paper. 

~ To control how Print Manager displays messages 

• From the Options menu, choose Alert Always, Flash If Inactive, or Ignore If 
Inactive. 

[Active] 

Ignore if Inactive 

These commands determine how 
Print Manager displays messages. 
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Each command is described here. 

Use 

Alert Always 

Flash If Inactive 

Ignore If Inactive 

To 

Display a message when a condition occurs that requires user 
interaction. 

Cause the Print Manager icon or the title bar of the inactive Print 
Manager window to flash until you enlarge the icon or make the 
window active. Then Print Manager displays its message. This is 
the default setting. 

Ignore the condition requiring user interaction when Print 
Manager is an icon or the Print Manager window is inactive. 

The command you choose remains in effect until you use the Options menu to 
change it. 

Note These commands do not control the display of system messages, such as a 
notification that your printer is offline. 

Displaying the Time/Date and File Size 
In the Print Manager window, a print queue displays the time, date, and size of 
any files you sent to Print Manager. You can turn off these options by choosing 
the appropriate command from the View menu. 

~ To turn off the time and date or file-size display 

• From the View menu, choose TimelDate Sent or choose Print File Size. 

The check mark next to the command on the View menu disappears, and the infor­
mation no longer appears in the Print Manager window. If you want to display the 
time and date or file size, choose the appropriate command again from the View 
menu. 
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There may be times when you want to format a spreadsheet, report, or other 
document and print it to a file rather than directly to a printer. You might do this 
when merging two files or when planning to print a file at a later time or different 
location. 

Some applications have an area in their Print dialog box where you can specify 
to print to a file. If your application supports this feature, select the appropriate 
option in the application's Print dialog box. 

If your application does not support this feature, you can print your document to a 
file by specifying FILE as the printer port. You do this by using the Printer Setup 
command. 

~ To print to a file 

1. From the Options menu, choose Printer Setup. 

The Printers dialog box appears. 

2. In the Installed Printers box, select the name of the printer you want to print the 
file to. 

3. Choose the Connect button. 

The Connect dialog box appears. 

4. In the Ports box, select FILE as your port. 

Use this port setting to print to a file. 

[SI Easl Prinling Direcllo Pori 

5. Choose the OK button. 

1:L!:1!:EOK:ii!!;;1 
lii;;q~ij~~iE;1 

li'i~~:¥~\i~!ii,tUnil 
l1:li~ii~~IEHI 
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The Printers dialog box appears. 

6. Choose the Close button. 
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If you choose to print to a file either from your application or by specifying FILE 
as the port your printer is connected to, the Print To File dialog box appears when 
you print. 

In the dialog box, you can specify the name of the file you want to print to, and a 
drive and directory where you want the file to be located. 

Note When you print a document to a file, the document does not appear in the 
Print Manager window. 

Printing Through MS-DOS 
When you print in Windows, print files are sent directly to the port your printer is 
connected to, bypassing MS-DOS printing interrupts. This speeds up printing and 
is the recommended method to use. 

However, in the following situations you may want to print by using MS-DOS 
interrupts: 

• You are using additional printer software that relies on MS-DOS interrupts 
(such as software that accompanies switch boxes). 

• You are trying to print on a network not supported by Windows. 

• You are trying to print to a serial printer and are using a terminate-and-stay­
resident (TSR) program that takes direct control of the COM port. 

~ To print through MS-DOS 

1. From the Options menu, choose Printer Setup. 

The Printers dialog box appears. 



2. Choose the Connect button. 

The Connect dialog box appears. 

f.orts: 
", 

local Pori Nol Presenl 
local Pori Nol Presenl 
local Pori 
local Pori Nol Presenl ;+ 

This check box controls 
printing through MS-DOS. 

: .. :01'. ., 

. Cancel; I 
1.~li(titlgi,,,; ·1 
I ;l!fltw~rk~;.·:1 
I; Help ·1 

3. Clear the Fast Printing Direct To Port check box. 
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4. Choose the OK button to return to the Printers dialog box. 

5. Choose the Close button. 

Printing through MS-DOS may slow down printing, but it ensures that your files 
print correctly. 

Managing Network Printing 
If you want to print to a network printer, Windows must be installed for use with 
a network, and a network must currently be running. If you do not have network 
software installed, you need to run the Setup program from Windows to install it. 
For more information, see Chapter 15, "Maintaining Windows with Setup." 

Print Manager offers several options to assist you when printing to a network 
printer. For example, you can: 

• Connect to and disconnect from a network printer. 

• View all the files in a network printer's queue, not just the files you have sent 
to the printer. 

• View a network queue you are not currently connected to. 

• Route files through Print Manager, instead of printing directly to the network 
printer. 

• Tum off automatic updating of network print queue status. 
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The level of support for these options depends on the capabilities of your network 
software and the support provided by your Windows network driver. Before you 
print to a network printer, it is recommended that you view the NETWORKS.WRI 
online document. This document contains information about how specific net­
works handle printing in Windows. For more information, open the 
NETWORKS.WRI file by using Windows Write. 

Connecting to a Network Printer 
You can connect to a network printer either while installing the printer, or 
afterward by using the Network Connections command. 

~ To connect to a network printer 

1. From the Options menu, choose Network Connections, or if you are currently 
installing a printer from the Printers dialog box, choose the Connect button. 

If you chose the Network Connections command, go to step 3. If you chose 
the Connect button, the Connect dialog box appears. 

2. Choose the Network button. 

The Network Connections dialog box appears, listing any network printer 
connections that have already been made. (The contents of this dialog box 
may vary, depending on the type of network you are using.) 

Por!: ILPn: li!;J 
~==::!!!!!!!L-___ --, 

Pass.!!ord: I 

Current Printer Connections: 

11I!(HvlliUil.!.lrJl 
mli~lli§i;1 

3. In the Network Path box, type the network name. 

For information about the path or password for your network printer, see the 
network documentation. 

4. Click the down arrow to open the Port list. 

Or select the Port box, and then press ALT+DOWN ARROW. 

5. Select the port you want to use. 
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If a network printer is already connected to the port you want to use, dis­
connect the other printer first. For more information, see "Disconnecting 
from a Network Printer" later in this chapter. 

6. In the Password box, type the password, if one is required. 

An asterisk (*) appears for each character you type. 

7. Choose the Connect button. 

The printer connection is added to the list in the dialog box. 

8. Choose the Close button. 

9. The Connect dialog box appears, with the path for the network printer 
displayed next to the port. 

10. Choose the OK button. 

The Printers dialog box appears. 

11. Choose the Close button. 

Note If your network supports the Browse button, you can choose it to look at the 
list of available network printers. For information about the Browse dialog box for 
networks, see Chapter 4, "File Manager." 

Reconnecting to a Network Printer 
You can reconnect to a network printer that was previously installed but is no 
longer connected if your network supports this option. This saves you having to 
specify the path information again. 

~ To reconnect to a network printer 

1. From the Options menu, choose Network Connections. 

The Network Connections dialog box appears. 

2. Choose the Previous button. 

A dialog box appears, listing your previous network printer connections. 

~ : 

\ \room222\prinler 

3. Select the network path for the printer you want to reconnect to. 
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4. Choose the Select button. 

The Network Connection dialog box appears, displaying the network path 
and port. 

S. Select the port you want to use. 

6. In the Password box, type a password, if one is required. 

7. Choose the Connect button. 

8. Choose the Close button. 

Note If your network does not support reconnecting to a printer directly, you may 
be able to browse the network to locate the printer you want to reconnect to. For 
more information, see your network manual or use the network's Help feature. 

Viewing the Entire Network Queue 
When you print a file on a network printer, Print Manager displays a print queue 
that shows only the files you have sent to that printer. By using the Selected Net 
Queue command, you can view every file sent to that printer. 

~ To view the entire queue for a network printer 

1. In the Print Manager window, select the network printer whose queue you want 
to view. 

2. From the View menu, choose Selected Net Queue. 

A dialog box appears, displaying the entire queue for the selected printer. 

(The options available in this dialog box may vary, depending on the network 
you are using. If this is the case, see your network manual or the network's 
Help feature for more information.) 

1 MARIE - 73K 
Paintbrush - ARTWORK.BMP 

2 ROGER - 67K 1:03 PM 10/19/1991 
Write - STATUS.WRI 

3 ANNE - 11K 1:05 PM 10/19/1991 
Card file - ADDRESS.CRD 

U1Jttip'['Ell 
1:,lJiiliil!:i!1 

3. To close the dialog box, choose the Close button. 

You can choose Selected Net Queue from the View menu at any time to display an 
updated queue for a network printer you are connected to. 
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Viewing Other Network Queues 
In addition to viewing queues for network printers you are connected to, you can 
view queues for other network printers. Using the Other Net Queue command, you 
can compare how many files are in the queues for different network printers 
before deciding which one you want to print to. 

Before you can print to a network printer, you must connect to it. For more 
information, see "Connecting to a Network Printer" earlier in this chapter. 

~ To view the queue for a network printer you are not connected to 

1. From the View menu, choose Other Net Queue. 

The Other Net Queue dialog box appears, prompting you for the location and 
name of the network queue you want to view. 

2. In the Network Queue box, type the network path to the network printer. 

For information about how to specify the network path, see your network 
software documentation. 

3. Choose the View button. 

Print Manager displays the status information for the queue in the area above 
the Network Queue box. 

(The options available in the Other Net Queue dialog box may vary, depending 
on the network you are using. If this is the case, see your network manual or the 
network's Help feature for more information.) 

1 JULIE - 19K 
Write - NOTES_WRI 

2 ANNE - 11K 1:38 PM 10/19/1991 
Cardfile - PHONENUM.CRD 

3 ROGER - 67K 1:38 PM 10/1911991 
Write - REPORLWRI 

H.etwork Queue: 1L-\\_IO_o_m2_2_2\-,-pr_in_te_r ____ ----' 

1:.:¥tiiwScl IFl!RblPj!lll.;!cicii~:::,::1 

Status information for the 
specified network queue 
appears here. 

4. In the Network Queue box, type the name of another queue you want to view. 

Or, to close the Other Net Queue dialog box, choose the Close button. 

Note Viewing a queue for a network printer you are not connected to does 
not connect you to that network printer for printing. You must use the Network 
Connections command to connect to the network printer before you can print to it. 
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Manual Updating of the Network Queue Status 
The network queue status is updated on a periodic basis or when a change has 
occurred on the network. The frequency of the updates depends on your net­
work software. In some cases, you may want to update the network queue 
status manually. 

~ To update the network queue status manually 

• From the View menu, choose Refresh. 

Ignoring the Status of the Network Queue 
When running as an icon, Print Manager does not update the status of the files 
in the network print queue. If the Print Manager window is open, Print Manager 
periodically requests updates to the status of the network queue. This can cause 
additional traffic for the network printer, which can slow down printing. 

If you are concerned about network traffic, or you do not need to view the status 
of the network queue, you can turn off automatic updating of the status. 

~ To turn off automatic updating of the network-queue status 

1. From the Options menu, choose Network Settings. 

The Network Options dialog box appears. 

This check box controls the 
display of the network status. 

IZl Jlpdate NetwOIk Display IlliliIIIJ!u.;1 
IZl :f~i~L~~iIQ~~:::QIi:~~:~: li!ii~~~U!1 

Ijjil.;nNp;!rill 

2. Clear the Update Network Display check box. 

3. Choose the OK button. 

The print queue status is not updated until you select this check box again. 
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Routing Files Through Print Manager 
Because routing files through Print Manager adds an extra step that can delay 
printing over a network, Windows is set up to bypass Print Manager and print files 
directly to the network. In most cases, this is the fastest way to print to a network. 

However, sometimes you might prefer to route files through Print Manager; for 
example, you may want to use the error-checking features offered by Print 
Manager. When you route network files through Print Manager, Print Manager 
manages your files as if they were being printed on a local printer instead of a 
network printer. 

~ To route files through Print Manager when using a network printer 

1. From the Options menu, choose Network Settings. 

The Network Options dialog box appears. 

[;g] llPdate Network Display 1:;;i.£~l!'!jH' 
[;g] if!:~~t.::~~f~:Q~~:::p"i:~~Ii H;:.~~~&Lf:',1 

I ::L:,i4~!;n;;:1 

This check box specifies whether to 
route files through Print Manager. 

2. Clear the Print Net Jobs Direct check box. 

3. Choose the OK button. 

Now all the print jobs on your computer are tracked as if they were on a local 
queue. 

~ To bypass Print Manager 

• In the Network Options dialog box, select the Print Net Jobs Direct check box. 

The fine points of how Print Manager controls printing to a network depend on 
the network you are using. You may want to experiment with both methods to 
determine which is best for you. 

When you bypass Print Manager, Print Manager still reports on the status of the 
network print queue, unless you clear the Update Network Display check box. For 
more information, see "Ignoring the Status of the Network Queue" earlier in this 
chapter. 
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Disconnecting from a Network Printer 
When you finish using a network printer, you can disconnect from it. 

~ To disconnect from a network printer 

1. From the Options menu, choose the Network Connections command. 

The Network Connections dialog box appears. (Contents of this dialog box 
vary, depending on the type of network you are using.) 

2. In the Current Printer Connections list, select the network printer you want to 
disconnect from. 

3. Choose the Disconnect button. 

4. Choose the Close button. 

Quitting Print Manager 
When running as an icon, Print Manager quits (and frees the memory it was using) 
as soon as it finishes printing. If the Print Manager window is open, Print Manager 
does not quit automatically. 

~ To quit Print Manager 

1. From the Options menu, choose Exit. 

If there are still files in the print queue, a message appears, asking whether you 
want to cancel printing these files. 

2. Choose the OK button to cancel printing and quit Print Manager. 



Non-Windows Applications 

Chapter 7 

Working with Non-Windows Applications 
Non-Windows applications are applications that are designed to run with 
MS-DOS but not specifically with the Microsoft Windows operating system. 
Most non-Windows applications can run with Windows nonetheless. 

To run a non-Windows application with Windows in the most efficient way, you 
may need to give Windows more information about the application. You do this 
by using a program informationfile (PIF). A PIF contains information about a 
non-Windows application, such as how much memory it needs and how it uses 
various system components. 

Windows provides PIFs for many comnion non-Windows applications. Windows 
also provides a default PIF with settings that work for most applications. If 
Windows does not provide a PIF and the settings in the default file do not work 
for your application, you need to create a PIF. You do this by using PIF Editor, 
a tool included with Windows. 

This chapter explains what you need to know about setting up and running non­
Windows applications, describes how to use PIFs, and introduces Windows PIF 
Editor. For more information about PIF Editor and all of its options, see Chapter 8, 
"PIF Editor." 

Setting Up a Non-Windows Application 
You can set up a non-Windows application just as you would other applications, 
by using the Windows Setup program, Program Manager, or File Manager. 
Regardless of which method you use, Windows sets up a PIF for the application. 

Note If you set up a non-Windows application and it doesn't run properly, you 
might need to modify the PIF. See "Using PIF Editor" later in this chapter. 
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Using the Setup Program 
When you use the Setup program to install Windows, Setup searches your hard 
disk for applications you have installed and creates a PIF and icon for each. Setup 
gets the information it needs for a particular application's PIF by looking at a table 
provided by Windows. 

The following procedure describes how to use the Setup program to set up an 
application after Windows has been installed. You can follow this procedure at 
any time, and you can use it to create a PIF or to set up an application that already 
has a PIP. You can also use this procedure to assign a custom icon to a program 
item, depending on whether one has been provided for your application. 

~ To set up a non-Windows application after Windows is installed 

1. In the Main group, choose the Windows Setup icon. (Double-click the icon. 
Or use the arrow keys to move the selection cursor to the icon, and then press 
ENTER.) 

Setup begins. 

2. From the Options menu, choose Set Up Applications. 

The Set Up Applications dialog box appears. 

3. Select one of the two option buttons, depending on whether you want the 
Setup program to search your hard disk for applications or whether you want 
to specify an application. Then choose the OK button. 

4. If you selected Search For Applications, a dialog box appears, prompting you to 
select the MS-DOS path or individual drives. Make your selection, and then 
choose the OK button. 

If you chose to specify an application, a dialog box appears, prompting you to 
type the application's path and filename. Specify your application, and then 
choose the OK button. 

For each application you select, Setup adds a program-item icon to the Appli­
cations group. If there is no Application group, Setup creates one. 

5. Follow the instructions on the screen to complete the process. 

The Setup program searches for a PIF to use with the application. If it finds 
one, it sets up the application and the PIF to work together. 

If Setup doesn't find a PIF, it searches for the information it needs to create 
one. If it finds the information, a dialog box appears, asking whether you want 
Windows to use the information. When you choose the Yes button, a PIF is 
created for the application. 

If there is no information available, Windows uses the default PIP, named 
_DEFAULT.PIF, when you start the application. 
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Using Program Manager 
You can also set up a non-Windows application by using Program Manager. 

~ To set up a non-Windows application by using Program Manager 

1. Open the group in which you want to set up the application. 

2. From the File menu, choose New. 

The New Program Object dialog box appears. 

3. Select the Program Item option button, and then choose the OK button. 

The Program Item Properties dialog box appears. 

4. In the Description box, type the label you want to appear below the program­
item icon for the application. 

5. In the Command Line box, type the path and filename for the application you 
are adding. 

6. If you like, you can specify a working directory. If you do not specify a 
working directory, Program Manager adds the directory that was specified 
as a start-up directory (if there was one specified) in the application's PIF. 

7. If you want the application to start as an icon, select the Run Minimized 
check box. 

8. Choose the OK button. 

Program Manager searches for a PIF to use with the application. If it finds 
one, it sets up the application and the PIF to work together. When you start this 
application from Program Manager, you are now running the application from 
its PIF rather than from its program file. 

If Program Manager doesn't find a PIF, it searches for information it needs 
to create one. If it finds the information, a dialog box appears, asking whether 
you want Windows to use the information. When you choose the Yes button, 
Program Manager creates a PIF for the application. 

If there is no information available, Windows uses the default PIF, named 
_DEFAULT.PIF, when you start the application. 

A program-item icon for the application appears in the group you selected. 

Note Program Manager does not set up an application's custom icon. To use 
an application's custom icon, you must use the Setup program to set up the 
application. For more information about custom icons, see "Changing an Icon" 
in Chapter 3, "Program Manager." 
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Using File Manager 
You can also set up a non-Windows application by using File Manager. 
(The following procedure requires a mouse and has no keyboard equivalent.) 

~ To set up a non-Windows application by using File Manager 

1. Arrange your desktop so that you can see both File Manager and the group 
where you want to place the non-Windows application icon. The destination 
group can be either a window or an icon. 

2. In File Manager, select the program or document file you want to add. 

3. Drag the file icon from File Manager to Program Manager, and drop it in the 
group window or on the group icon. As you drag the icon, the mouse pointer 
replicates a file icon. 

The non-Windows application is added to the group. If there was no PIF for 
the application, Windows creates one. 

Note When you use File Manager to set up a non-Windows application in a 
Program Manager group, Program Manager does not set up the application's 
custom icon. To set up an application's custom icon, you must use the Setup 
program. 

Using PIF Editor 
After you set up your application, you can start using it with Windows. If the 
application doesn't perform properly, you probably need to modify the applica­
tion's PIF. Make sure you modify the PIF that Windows is using with your 
application. If a PIF has been created for the application, Windows uses it. 
Otherwise, it uses the default PIF. 

You can usually find out which PIF Windows is using with your application by 
using the Properties command on the File menu in Program Manager. The PIF is 
specified in the Command Line box in the Program Item Properties dialog box. 

Caution Changing the PIF settings can affect how, and even whether, the 
application runs. 
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~ To modify or create a PIF 

1. In the Main group, choose the PIP Editor icon. 

If you upgraded from Windows version 3.0, PIP Editor remains in the 
Accessories group. 

Depending on which mode Windows is running in, PIP Editor displays an 
untitled PIP that contains either standard-mode or enhanced-mode settings. 

If Windows is running in 386 enhanced mode, the following dialog box appears. 

file Mode .!::!.elp 

e.rogram Filename: 

Window I.itle: 

Qptional Parameters: 

.[tart-up Directory: 

~ideo Memory: @ Text 0 Low Graphics 0 High Graphics 

Memory Requirements: KB Required ~ KB I!.esired ~ 

EMS Memory: .!S,.B Required EJ KB limit ~ 

XMS Memory: KB Reguired EJ KB Limit ~ 

Display Usage: @ FyI! Screen 

O~indowed 
[3J ~Iose Window on Exit 

Execution: 0 Itackground 

o J;.xclusive 

You can change these settings and name the new file, or continue with the 
next step to modify an existing PIP. 

2. Prom the Pile menu, choose Open. 

The Open dialog box appears. 

3. In the Pile Name box, type the name of the PIP you want to open, or select a 
PIP from the list. Then choose the OK button, or press ENTER. 

The PIP's settings appear. 

4. Change any options that are appropriate for your application. 

You can press the FI key while using PIP Editor to receive Help for a selected 
option. 

5. Prom the Pile menu, choose Save. Use the same base filename as the 
application. 

Por example, if the application filename (program file) is WP .EXE, the PIP 
should be named WP.PIP. 

6. Prom the Pile menu, choose Exit. 

All PIP Editor options are described in Chapter 8, "PIP Editor." 
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Using a Manufacturer-Supplied PIF 
Some software manufacturers provide a PIF for an application so that you can 
run the application with Windows. To determine whether a PIF has been supplied, 
contact the software manufacturer or search the Windows Setup disks for a file 
that uses the same base filename as the application and has a .PIF extension. If 
you have PIFs from both Windows and the software manufacturer, use the PIF 
supplied by the manufacturer. 

To use a PIF supplied with an application, copy the file to the directory where 
the application's files are located or the directory where you set up Windows. 
Then set up a program item so that you can run the application from its PIP. For 
information about setting up a program item, see "Using Program Manager" 
earlier in this chapter. 

Using the Default PIF 
The _DEFAULT.PIF file is located in the Windows SYSTEM directory. This PIF 
contains settings that work with most non-Windows applications. Windows uses 
the _DEFAULT.PIF file when there is no other PIF available for your application. 

Because Windows might use the default PIF with more than one non-Windows 
application, you should not modify it. You can use the default PIF as a starting 
point for creating a new PIP. 

~ To create a PIF, using the default PIF as a starting point 

1. In the Main group, choose the PIF Editor icon. 

If you upgraded from Windows version 3.0, PIF Editor remains in the 
Accessories group. 

2. From the File menu, choose Open. 

3. Select the _DEFAULT.PIF file. 

4. Make any changes you need for your application. 

For example, you can start your application in a window by setting the Display 
U sage option to Windowed. 

5. From the File menu, choose Save As. 

6. In the File Name box, type a new name for the file. Use the application 
filename with .PIF as the extension. For example, if the application filename 
(program file) is SPECIAL.EXE, use SPECIAL.PIF as the PIF filename. 

For more information about PIF Editor, see Chapter 8, "PIF Editor." 
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Using Multiple PIFs for an Application 
You can create more than one PIF for an application. You may find it useful to 
do this if you run an application differently under different circumstances. 

For example, you can specify in a PIF how much EMS (expanded) memory an 
application has access to. By using two PIFs, you could give an application access 
to a large amount of EMS memory when you are using large data files but limit its 
use of memory when you are working with smaller files. 

~ To set up two PIFs for an application 

1. Create two PIFs. For more information, see "Using PIF Editor" earlier in this 
section. 

2. For each PIF, indicate the appropriate settings. In this example, you would set 
the EMS Memory: KB Limit setting to -1 for one PIP. For the other PIF, you 
would set the EMS Memory: KB Limit setting to 1024K. (These options are 
available only in 386 enhanced mode.) 

3. Save each PIF with a unique filename. 

4. Create program-item icons for both PIFs in Program Manager, giving each a 
distinct label. Because you want to start the application from its PIF in this 
case, be sure to specify the PIF filename, not the program file, in the Command 
Line box. 

You can choose either icon to start the application. 

Starting a Non-Windows Application 
You can start a non-Windows application from Program Manager or File Manager 
by choosing the application's program-item icon, its program file, a document 
associated with a program file, or the application's program information file 
(PIF). This section describes each of these methods. 

Note When you start an application from Program Manager or File Manager by 
choosing the filename for the program file, Windows searches for a PIF with the 
same filename. It searches directories for the PIF in the following order: the 
directory where the application's files are located, the current working directory, 
the Windows directory, the SYSTEM subdirectory of the Windows directory, and 
then the directories specified by the path command in the AUTOEXEC.BAT file. 
Make sure the PIF for the application is located in one of these directories and that 
the PIF has the same base filename as the application. For example, if the program 
file is QBASIC.EXE, the PIF should be named QBASIC.PIP. 
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Starting an Application from Program Manager 
If an application is set up as a program item in Program Manager, the easiest 
way to start that application is to double-click its icon. For information about 
using Program Manager to organize your applications into groups and to set up 
applications as program-item icons, see Chapter 3, "Program Manager." 

~ To start an application from its program-item icon 

1. Open the group that contains the program-item icon for the application. 

2. Choose the icon. (Double-click the icon. Or use the arrow keys to move the 
selection cursor to the icon, and then press ENTER.) 

The application appears on your screen. 

You can also start an application from Program Manager by using the Run 
command. 

~ To start an application by using the Run command 

1. From the File menu in Program Manager, choose Run. 

The Run dialog box appears. 

2. In the Command Line box, type the name of the file that starts the application. 
Include the filename extension. 

You can specify the application's PIF, the name of the program file (.EXE, 
.BAT, or .COM extension), or the name of a document associated with the 
program file. 

3. Choose the OK button. 

Starting an Application from File Manager 
Using File Manager, you can start an application by choosing its program file or 
PIF from a directory window. 

~ To start an application from File Manager 

1. In the Main group, choose the File Manager icon. (Double-click the icon. 
Or use the arrow keys to move the selection cursor to the icon, and then press 
ENTER.) 

2. In the File Manager directory window, make sure you have selected the drive 
and directory where the application's PIF is located. 
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3. Double-click the filename for the PIF, program file, or document file associated 
with the application. Or use the arrow keys to select one of these files, and then 
press ENTER. 

You can also use the Run command from the File menu in File Manager. 

Working with Non-Windows Applications in 386 Enhanced 
Mode 

This section describes features of Windows that you use only when you are 
running non-Windows applications in 386 enhanced mode. 

Giving an Application Exclusive Use of Resources 
You can give an application exclusive use of system resources when it is the 
active application. For example, you might want to do this to ensure an application 
runs as quickly as possible, without being slowed down by applications running 
in the background. Also, some applications use hardware in such a way that they 
cannot run at the same time as other applications. 

There are two ways to give an application exclusive use of resources: 

• Use PIF Editor to open the application's PIF, and then select the Exclusive 
check box. When you use this setting, no other applications can run when 
that application is active. This setting takes effect every time you start the 
application. 

• If the application is running in a window or is reduced to an icon, you can use 
the Settings command on the application's Control menu. When you use this 
setting, the application gets exclusive use of resources only until you quit the 
application. The next time you start the application, the setting is not in effect. 

For more information about PIF Editor options, see Chapter 8, "PIF Editor." For 
more information about using the Control menu, see Chapter 1, "Windows 
Basics." 

Running an Application in the Background 
If you want an application to continue running when it is not the active applica­
tion, select the Background check box in the application's PIF. If you select this 
option, the application runs in the background (calculating numbers or reading 
a large file, for example) while another application is in the foreground. If the 
application is running in a window or reduced to an icon, you can also select the 
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Background option (under Tasking Options) by using the Settings command on 
the application's Control menu. 

When you change this setting in the PIF, the application runs in the background 
whenever you start it. When you change the setting by using the Control menu, 
the application runs in the background only until you quit the application. 

Note If an application is running in the background and the Exclusive check box 
is selected in its PIF, other applications do not run in the background (even if the 
Background check box is selected in their PIFs). 

Running a Non-Windows Application in a Window 
You can run most non-Windows applications in a window when Windows is 
running in 386 enhanced mode. You can move and size the window, reduce the 
window to an icon, and share information with other applications by using the 
Clipboard. However, you cannot run a non-Windows application in a window if 
you are running Windows in standard mode. 

~ To make sure Windows is running in 386 enhanced mode 

• From any Help menu in Windows, choose About. 

A dialog box appears. The mode is displayed near the bottom of the dialog box. 

~ To switch a non-Windows application between a window and a full screen 

• While working with a non-Windows application, press ALT+ENTER. 

If the application was running in a full screen, it now appears in a window. If 
the application was running in a window, it now appears in a full screen. 

You can have an application run in a window every time you start it. You do this 
by using PIF Editor. 

~ To start a non-Windows application in a window 

1. Use PIF Editor to open the application's PIF, if it has one. If there is no PIF, 
you need to create one. For information about creating and editing a PIF, see 
"Using PIF Editor" earlier in this chapter. 

2. Set the Display Usage option to Windowed rather than Full Screen. For 
information about the Display Usage options, see Chapter 8, "PIF Editor," 
or press FI when this option is selected. 
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3. Make sure the Display options are set correctly in the Advanced dialog box. 
For information about the Advanced options, see Chapter 8, "PIF Editor," or 
press FI when one of the Display options is selected. 

4. Save the changes you made to the PIF, and quit PIF Editor. 

When you start the application, it appears in a window. 

Using a Mouse with a Non-Windows Application 
With Windows version 3.1, you can use a mouse with a non-Windows application 
that is running in a window. 

~ To use a mouse with a non-Windows application running in a window 

• If you are using a Microsoft mouse, you must set up the mouse driver before 
starting Windows. You need to use either the MOUSE.SYS or MOUSE.COM 
driver, usually located in the Windows directory. You specify MOUSE.SYS in 
the CONFIG.SYS file, or you specify MOUSE.COM in the AUTOEXEC.BAT 
file. For example, to specify the MOUSE.SYS device driver located in the 
Windows directory on drive C, add the following command line to your 
CONFIG.SYS file: 

device = c:\windows\mouse.sys 

If these mouse drivers are not in the Windows directory, you can copy them 
from the Windows Setup disks. To do this, you need to use the expand com­
mand. For more information, see Chapter 4, "Troubleshooting," in Getting 
Started with Microsoft Windows. 

• If you are using a Logitech mouse, follow the procedure in the README.WRI 
file. You can view this file by using Write, an application in the Accessories 
group. 

• If you are using a mouse from another manufacturer, you must get an updated 
mouse driver. Contact the mouse manufacturer. 

Changing Settings for a Running Application 
When Windows is running in 386 enhanced mode, you can make temporary 
changes to the way a non-Windows application runs. To do so, use the Settings 
command on the application's Control menu. (If your application is running in a 
full screen, reduce it to an icon to access the Control menu.) Your changes stay 
in effect until you quit the application. 
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~ To change settings for a running application 

1. From the application's Control menu, choose Settings. 

The following dialog box appears. The title bar reflects the particular 
application you are using. 

DisplaJl Options PrioritJl 

@ls.il.!~:~.~:~.1 foreground: ~ 
o Fyll Screen Bgckground: ~ 

Tasking Options Special------, 

o Exclusive IFflllll'.!11 
o .!!ackground 

2. Change the appropriate setting, and then choose the OK button. The options are 
Display, Tasking, Priority, and Terminate, and are described in the following 
sections. 

Display Options 
Use the Display options to change whether an application appears in a window or 
in a full screen. You can select only one of the following options. 

Use 

Window 
Full Screen 

To 

Run the application in a window. 
Run the application in a full screen. 

You can also switch a running application from a window to a full screen, or vice 
versa, by pressing ALT+ENTER. 



Chapter 7 Non-Windows Applications 245 

Tasking Options 
Use the Tasking options to control how an application shares system resources 
with other applications. You can select one or both of the following options. 

Use 

Exclusive 

Background 

To 

Suspend other applications while the application is the active one. 
(If this application is running in a window, Windows applications 
continue to run, but other non-Windows applications are suspended.) 

Run the application in the background while you work with other 
applications. (However, this application is suspended when you run 
an application that has the Exclusive option set.) 

Priority Options 
Use the Priority options to specify how much processor time the application 
should receive, relative to other applications. Giving the application a high priority 
makes it run faster than applications with lower priorities; conversely, giving it a 
lower priority slows it down. 

You can specify the following options. 

Use 

Foreground 

Background 

To 

Control how fast the application runs, relative to other applications, 
when it is the active application. 

Control how fast the application runs, relative to other applications, 
when it is not the active application. 

For this option to take effect, you must also select the Background 
check box in the Tasking Options box. 

You can also set these options in the application's PIF by using PIF Editor. 
For more information about these and other PIF Editor options, see Chapter 8, 
"PIF Editor." 

Terminate Option 
Use the Terminate button to quit a non-Windows application when you cannot 
use the usual methods from within the application-for example, when the 
application does not respond to the commands you type. Ordinarily, when you 
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run a non-Windows application in a window and the application does not respond 
to your commands, you have to restart your computer to quit the application. 
When you use the Terminate button, you can quit the application and then save 
any open files in other applications before restarting your computer. 

Caution Use the Terminate button only as a last resort, since it can result in lost 
data. If you don't restart your computer after using the Terminate button to quit an 
application, Windows and MS-DOS may become unstable. 

If you cannot open the Control menu in your non-Windows application, you can 
press CTRL+ALT+DEL to quit the application. Windows displays a message confirm­
ing the action. Press ENTER to quit the application. 

Changing the Size of the Font 
When Windows is running in 386 enhanced mode, and you are running a 
non-Windows application in a window, you can change the size of the font 
by using the Fonts command on the Control menu. 

~ To change the size of the font 

1. From the Control menu in your non-Windows application, choose Fonts. 

The Font Selection dialog box appears. 

Eont 

4 X 6 
5 x 12 
6 x 8 
7 x 12 
8 x 8 

10 x 18 
12 x 16 
16 x 8 

[8] ~aye Settings on Exit 

Selected Font-------------------, 

2. Select a font size. 

Each character is: 
8 screen pixels wide 

12 screen pixels high 

The Window Preview and Selected Font areas display the font size. 

3. If you want to use this font whenever you run this non-Windows application 
in a window, select the Save Settings On Exit check box. 

4. Choose the OK button. 
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Handling Device Contention 
When more than one application is running in 386 enhanced mode, the appli­
cations sometimes request the use of a device (such as a printer or modem) at 
the same time. This is called device contention. By using the device-contention 
options, you can specify how Windows should handle those requests. 

These options apply only when a non-Windows application is one of the applica­
tions requesting access to the device. When two Windows applications request 
access to a device, Windows handles their use of the device without these options. 

~ To specify how to handle contention for a device 

1. In the Main group, choose the Control Panel icon. 

2. Choose the 386 Enhanced icon. 

The 386 Enhanced dialog box appears. 

3. Select the port that is connected to the device you want to control. 

4. Set the options you want, and then choose the OK button. 

The device-contention options are described in the following list. Examples of 
when you would change these options are included in the descriptions. 

Use 

Always Warn 

NeverWam 

Idle 

To 

Specify that a message appear every time an application tries to use 
a device that is already in use. The message prompts you to specify 
which application should be given control of the device. In most 
cases, you should select this option. 

Specify that any application can use a device any time, without a 
message. If you select this option, two applications may try to use 
the same device at the same time, which may cause problems. 

Specify the number of seconds after an application stops using a 
device before another application can use the device, without causing 
a message to appear. The range is from 1 to 999 seconds. 

It is a good idea to specify idle time when the device is capable of 
switching between two applications. For example, you might use 
Cardfile to dial an online service and then switch to another appli­
cation to communicate with the service. In this case, you should 
specify a short delay, such as 2 seconds. 
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Transferring Information Between Applications 
The method you use to transfer information onto the Clipboard depends on 
whether you are running a Windows or non-Windows application. This section 
describes how to use the Clipboard with non-Windows applications. For infor­
mation about using the Clipboard with Windows applications, see Chapter 2, 
"Application Basics." You can view the contents of the Clipboard by opening 
Clipboard Viewer in the Main group. 

When a non-Windows application is running in a window or is minimized to an 
icon, its Control menu contains additional commands. You use these commands 
to transfer information to and from non-Windows applications. For information 
about using the Control menu, see Chapter 1, "Windows Basics." 

Note To quickly switch a running non-Windows application between a full screen 
and a window, press ALT+ENTER. 

Copying Information onto the Clipboard 
When you are running a non-Windows application in a window, you can copy 
selected information, the entire desktop, or a single window onto the Clipboard. 
When you are running a non-Windows application in a full screen, you can copy 
the entire screen onto the Clipboard. 

To use the following procedures, the application you want to copy information 
from must be running in a window. 

Copying Selected Information 
When Windows is running in 386 enhanced mode, you can select information 
from a non-Windows application running in a window and copy it onto the 
Clipboard. 

~ To copy selected information from a non-Windows application 

Mouse 

1. If the application you want to copy from is running in a full screen, press 
ALT+ENTER to run it in a window. 

2. Click the Control-menu box to open the Control menu. 

3. From the Control menu, choose Edit. 
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4. From the Edit menu, choose Mark. 

5. In the non-Windows application, select the information you want to copy. 

6. Press the right mouse button to transfer the selected information onto the 
Clipboard. 

Keyboard 

1. If the application you want to copy from is running in a full screen, press 
ALT+ENTER to run it in a window. 

2. Press AL T +SPACEBAR to open the Control menu for the application. 

3. From the Control menu, choose Edit. 

4. From the Edit menu, choose Mark. 

A flashing rectangular cursor appears at the upper-left comer of the window. 

5. Move the cursor to the first character you want to select. 

6. Press SHIFT and an arrow key to mark the information you want to copy. 

7. Press ENTER to transfer the selected information onto the Clipboard. 

Note If your application uses ALT+SPACEBAR for another function, you cannot 
access the Control menu by pressing ALT +SPACEBAR. 

Copying an Entire Screen 
Whether Windows is running in 386 enhanced mode or in standard mode, you can 
copy the contents of an entire screen onto the Clipboard by pressing PRINT SCREEN. 

When Windows is running in standard mode, however, you cannot copy graphics 
from a non-Windows application onto the Clipboard. 

~ To copy the contents of an entire screen onto the Clipboard 

1. Make sure the information you want to copy is on the screen. 

2. Press PRINT SCREEN. 

The contents of the screen is copied onto the Clipboard. 

Note If the preceding procedure does not copy the screen onto the Clipboard, 
you may have an unenhanced keyboard. Try pressing ALT +PRINT SCREEN or 
SHIFT +PRINT SCREEN to copy the screen. 
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The screen contents may be a bitmap or text. To determine which it is, open the 
Display menu in Clipboard Viewer. If the screen contents is a bitmap, the applica­
tion you want to transfer the information to must be able to read bitmap (.BMP) 
files. See the documentation supplied with your application to determine whether 
your application can read bitmap files. 

Copying a Window and Its Contents 
To use the following procedure, you must be running Windows in 386 enhanced 
mode, and the application you are copying from must be running in a window. 

~ To copy a window and its contents onto the Clipboard 

1. Make sure the window you want to copy is the active window. 

2. Press ALT+PRINT SCREEN. 

A bitmap of the active window is created and placed onto the Clipboard. The 
application you want to transfer the information to must be able to read bitmap 
(.BMP) files. See the documentation supplied with your application to deter­
mine whether your application can read bitmap files. 

Pasting Information from the Clipboard into a Non-Windows Application 
To paste information from the Clipboard into a non-Windows application, you 
use the Paste command on the destination application's Control menu. Some 
non-Windows applications accept only unformatted text, others accept formatted 
text and graphics images as well. For more information, see the documentation 
supplied with your application. 

The method you use to paste information depends on whether the non-Windows 
application is running in a window or a full screen. 

To use the following procedure, you must be running Windows in 386 enhanced 
mode. 

~ To paste information into an application running in a window 

1. Make sure the information you want to paste is on the Clipboard. Choose the 
Clipboard Viewer icon in the Main group to view the contents of the Clipboard. 

2. Switch to the destination application. 
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3. Place the insertion point where you want the information from the Clipboard to 
appear. 

4. From the application's Control menu, choose Edit. 

5. From the Edit menu, choose Paste. 

The following procedure can be used in either standard or 386 enhanced mode. 

~ To paste information into an application running in a full screen 

1. Make sure the information you want to paste is on the Clipboard. Choose the 
Clipboard Viewer icon in the Main group to view the contents of the Clipboard. 

2. Switch to the destination application. 

3. Place the insertion point where you want the information from the Clipboard to 
appear. 

4. Press ALT+SPACEBAR to open the the application's Control menu. 

5. From the Control menu, choose Paste. 

If Windows is running in 386 enhanced mode, choose Edit from the Control 
menu, and then choose Paste. 

Note If your application uses ALT +SPACEBAR for another function, you cannot 
open the Control menu by pressing ALT+SPACEBAR. Press CTRL+ESC to switch to 
Task List without quitting the application. The application appears as an icon 
near the bottom of the Windows desktop. Click the icon to open the application's 
Control menu. 

Changing an Application's Default Directory 
A default directory is the directory an application uses while it is running. For 
example, the application searches the default directory for files it needs to access, 
and it also saves files to the default directory. 

You can specify any directory as the application's default directory by using 
Program Manager. For a non-Windows application, you can also use PIF 
Editor. Because settings made in Program Manager override settings made in 
PIF Editor, the recommended method is to use Program Manager. However, if 
you plan to start this application other than through Program Manager, set the 
default directory in the application's PIF. 
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~ To specify a default directory by using Program Manager 

I. Select the application's program-item icon. 

2. From the File menu, choose Properties. 

The Program Item Properties dialog box appears. 

3. In the Working Directory box, type the name of the directory where you want 
the application to look for existing files and place new files. The directory you 
specify becomes the default directory, which is the current directory while this 
application is running. 

4. Choose the OK button. 

Note If you do not specify a working directory, Program Manager changes the 
directory to that which was specified as a start-up directory in the application's 
PIF. 

~ To specify a default directory by using PIF Editor 

I. In the Main group, choose the PIF Editor icon. 

If you upgraded from Windows version 3.0, PIF Editor remains in the 
Accessories group. 

2. From the File menu, choose Open. 

The Open dialog box appears. 

3. In the File Name box, select the application's PIF, and then choose the 
OK button or press ENTER. 

PIF Editor appears. 

4. In the Start-up Directory box, type the path of the default directory. 

5. From the File menu, choose Save. 

6. From the File menu, choose Exit. 

Managing Memory for Non-Windows Applications 
If you have an 80286 system and you use applications that need expanded 
memory, you must have an expanded memory board. Also, your CONFIG.SYS 
file must contain a command line for the expanded memory manager supplied 
with the memory board. 

If you have an 80386 or 80486 system and Windows is running in 386 enhanced 
mode, Windows can simulate expanded memory for applications that require it, 
even if your system does not have expanded memory. 
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You can use an application's PIF to specify how much expanded memory a partic­
ular application needs. You also use the PIF to make sure the application never 
runs with insufficient memory and to prevent it from using all available expanded 
memory (and leaving none for other applications). For information about PIF 
Editor options, see Chapter 8, "PIF Editor." 

Note If you have an 80386 or 80486 system, you can install the expanded­
memory emulator EMM386. This memory manager provides expanded memory 
for applications even when Windows is not running in 386 enhanced mode. For 
information about using EMM386, see Chapter 14, "Optimizing Windows." 

"Out of Memory" Message 
Windows applications use memory cooperatively, but non-Windows applica­
tions often do not. Some non-Windows applications require a certain amount of 
memory when they start, and they keep that memory until you quit the application. 
When there is not enough conventional memory to start or continue running an 
application, you may receive an "out-of-memory" message. 

If you get the "out of memory" message when attempting to run an application, 
try the following: 

• Close any applications you aren't working with. 

• If Windows is running in 386 enhanced mode, try running the non-Windows 
application in a full screen instead of a window. 

• If Windows is running in 386 enhanced mode and you don't need your appli­
cation running when it's in the background, you can set it to run only when 
it's in the foreground. To do this, edit the application's PIF and make sure the 
Execution setting is not set to Background. If the application is running in a 
window or reduced to an icon, you can make this change by using the Settings 
command on the Control menu. 

• Clear or save the contents of the Clipboard. For information about using the 
Clipboard, see Chapter 2, "Application Basics." 

• In Control Panel, choose the Desktop icon. Set the Wallpaper option to None, 
or use a pattern. The Pattern feature uses less memory. 

• Minimize Windows applications (reduce them to icons at the bottom of your 
screen). 

• Free some disk space. Windows and some applications use free disk space to 
temporarily store information that doesn't fit into memory. 
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Using Application Swap Files 
Each time you start a non-Windows application in standard mode, Windows 
creates a temporary application swap file for that application. When you switch 
from the application, Windows moves the application from memory to the appli­
cation swap file. The memory is then available to other applications. To create a 
swap file, there needs to be at least as much free disk space as the amount of 
memory required to start and run the application. 

When you quit Windows, application swap files created during that session are 
deleted. If Windows quits unexpectedly, these files remain on your hard disk but 
are deleted the next time you start Windows. To free disk space, you can delete 
these files by using the MS-DOS command prompt before you restart Windows. 

The amount of available disk space determines how many application swap files 
Windows can create; this, in turn, determines how many non-Windows applica­
tions you can start before running out of memory. For more information about 
using application swap files, see Chapter 14, "Optimizing Windows." 

Using Memory-Resident Programs 
Many applications require memory-resident programs in order to work properly. 
For example, some electronic-mail applications require a memory-resident 
network driver. 

If you want a memory-resident program to be available to all Windows and 
non-Windows applications, start it before you run Windows. The program is then 
available to all applications you run with Windows; however, the memory it uses 
is not available to other applications. In general, most memory-resident programs 
are started from your CONFIG.SYS or AUTOEXEC.BAT file. (These files are 
located in the root directory of your startup drive.) They indicate to MS-DOS 
which commands and programs to run when you start your computer. 

If only one application requires a memory-resident program, you might not want 
to start the program from the CONFIG.SYS or AUTOEXEC.BAT file. Instead, 
you can use one of the following methods so that the program doesn't take up 
memory unless an application is using it. 

• Create an MS-DOS batch program that starts the memory-resident program and 
then the application. You can run that batch program from Windows. For more 
information about using batch programs with Windows, see "Using a Batch 
Program to Run Memory-Resident Programs" later in this chapter. 
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• If Windows is running in 386 enhanced mode, you can start the program 
from the batch program WINSTART.BAT. The program is then available to 
Windows applications but not to non-Windows applications. This prevents the 
program from taking up memory that non-Windows applications could use. For 
more information about using WINSTART.BAT, see Chapter 14, "Optimizing 
Windows." 

Running Pop-up Programs 
A pop-up program is a memory-resident program that is loaded into memory but 
isn't visible until you press a certain key combination. You should start pop-up 
programs, such as Borland SideKick, only after starting Windows. By doing so, 
you can switch to and from that program as you would any non-Windows 
application (rather than using its "pop-up" hot key), and the pop-up program 
can share memory with Windows and other applications. 

~ To use a pop-up program with Windows 

1. If necessary, create a PIF for the pop-up program. For information, see 
"U sing PIF Editor" earlier in this chapter. 

2. Start the pop-up program as you would any application-for example, by 
setting it up as an item in Program Manager and then double-clicking its icon. 
For information about setting up and starting applications, see Chapter 3, 
"Program Manager." 

When you start the pop-up program, Windows displays a message confirming 
that the program has been loaded. 

3. Press the appropriate key combination to make the program appear on your 
screen. 

A few pop-up programs require a key combination that is usually reserved 
for Windows (for example, ALT+ESC). In this case, you can edit the PIF for the 
pop-up program and select the Reserve Shortcut Keys option for that key com­
bination. Then, when you press that key combination, the pop-up program 
appears instead of the usual Windows function being performed. 

You can switch to and from a pop-up program by using Task List (CTRL+ESC) 

rather than by pressing the key combination that usually displays the program. 
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Using a Batch Program to Run Memory-Resident Programs 
Sometimes it may be useful to load a pop-up program only when you use another 
application. For example, you might want to load Borland SideKick in conjunction 
with the Framework II application. SideKick is then available from Framework II 
and does not take up memory that other applications could use. To load a pop-up 
program in conjunction with another application, create a batch program that starts 
first the pop-up program and then the application. 

You can do this by creating an MS-DOS batch program and a PIF for it. An 
MS-DOS batch program is a data file (text file) that contains MS-DOS commands. 
When you run the batch program, MS-DOS carries out each command as if you 
had typed it at the MS-DOS prompt. If you wanted to use SideKick with Frame­
work II, for example, the batch program could first load the pop-up program, 
SideKick, and then run the application, Framework II. The following is a sample 
batch program, named SKFWLOAD.BAT, which you could create by using 
Notepad: 

SK.COM 
FW.EXE 

The first command in the batch program loads the pop-up program SideKick 
(SK.COM). The second command starts the application Framework II (FW.EXE). 

To run the batch program with Windows, you create a PIF for it. 

~ To create a PIF for a batch program 

1. In the Main group, choose the PIF Editor icon. 

If you upgraded from Windows version 3.0, PIF Editor remains in the 
Accessories group. 

2. In the Program Filename box, type the filename of the batch program. 
Include the .BA T extension. 

For example, to use the sample batch program just discussed, type 
skfwload.bat. 

3. Set other PIF options as appropriate. In this example, the options you set affect 
both applications. 

4. From the File menu, choose Save As. 

5. In the File Name box, type a filename for the PIF. Include the .PIF extension. 

If you give the PIF the same base filename as the batch file (in this case, 
SKFWLOAD.PIF), you can run the batch program by choosing the batch file 
or by choosing its PIF. 

You can also add the batch file or PIF to a Program Manager group and then 
choose it from that group. Or you can start File Manager and then double-click 
the batch file or the PIF's filename. 
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Using MS-DOS Prompt 
You can also run non-Windows applications, such as memory-resident programs, 
by using MS-DOS Prompt. However, when you start a non-Windows application 
from the MS-DOS command prompt, the DOSPRMPT.PIF file is used instead of 
the application's PIF. If you have an application that requires unique PIF settings 
and has its own PIF, start that application from Program Manager or File Manager. 
For more information, see "Starting a N on-Windows Application" earlier in this 
chapter. 

~ To start MS-DOS Prompt 

1. In Program Manager, choose the Main group. 

2. Choose the MS-DOS Prompt icon. (Double-click the icon. Or use the arrow 
keys to move the selection cursor to the icon, and then press ENTER.) 

When the MS-DOS command prompt appears, you can type the commands 
necessary to run your non-Windows applications. 

If Windows is running in 386 enhanced mode, you can also run MS-DOS Prompt 
in a window. 

~ To run MS-DOS Prompt in a window 

• Press ALT+ENTER. 

MS-DOS Prompt appears in a window, so you can use the commands on the 
Control menu. 

If you want MS-DOS Prompt to always start in a window, you can change the 
DOSPRMPT.PIF file located in the Windows directory. Using PIF Editor, open 
the file and select the Windowed option under Display Usage. 

To return to a full screen, press ALT+ENTER again. 

~ To quit MS-DOS Prompt 

• Type exit, and then press ENTER. 

Caution Some MS-DOS commands do not work properly with Windows. For 
example, when you use the chkdsk command with the If option, chkdsk tries to 
modify part of the operating system that cannot be modified while Windows is 
running. Also avoid using the undelete command, the chcp (change codepage) 
command, and disk-compaction and optimization programs when running 
Windows. You should quit Windows before using such commands and programs. 
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Chapter 8 

Working with PIFs and PIF Editor 
Whenever you start a non-Windows application, Windows looks for a program 
informationfile (PIF). A PIF contains information about a non-Windows appli­
cation, including how much memory the application needs and how it uses 
components of your computer, such as the communications ports. Windows 
uses this information to run the application in the most efficient way. When 
you set up Windows, PIFs are placed in your Windows directory. 

Note A non-Windows application is designed to run with the MS-DOS operating 
system but not specifically with the Microsoft Windows operating system. Most 
non-Windows applications can, however, run with Windows. 

When a non-Windows application doesn't run properly in Windows, you may 
need to modify its PIF. You do this by using Windows PIF Editor. This chapter 
tells you how to start PIF Editor and describes the PIF Editor options. It first 
describes the options you use for applications running in 386 enhanced mode, 
and then describes the options you use for applications running in standard mode. 

Starting PIF Editor 
You create, modify, and save a PIF just as you would any Windows file. For 
example, to create a new PIF, you start PIF Editor, choose New from the File 
menu, modify the PIF options, and then save the PIF with a new filename. You 
could also create a new PIF by opening an existing PIF, modifying it, and saving 
the changed PIF with a new filename. 

Typically, a PIF has the same filename as the associated application's main 
program file, except that a PIF has a .PIF filename extension. 
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~ To start PIF Editor 

1. In the Main group, choose the PIF Editor icon. (Double-click the icon. Or use 
the arrow keys to move the selection cursor to the icon, and then press ENTER.) 

Note If you upgraded from Windows version 3.0, PIF Editor remains in the 
Accessories group. 

PIF Editor displays anew, untitled window that displays the default settings 
for the mode Windows is currently running in. 

2. To edit an existing PIF, choose Open from the File menu, and then specify the 
PIF you want. 

Caution Changing the PIF settings can affect how, and even whether, the 
application runs. 

Changing PIF Modes 
There are two categories of options in PIF Editor: 

• The standard-mode options apply when you run the application with Windows 
in standard mode. 

• The 386-enhanced-mode options apply when you run the application with 
Windows in 386 enhanced mode. 

When you start PIF Editor, it displays the correct options for the mode Windows 
is currently running in. 

Occasionally, you might want to specify PIF options for an application that runs 
in a mode other than the one Windows is currently running in. For example, if 
Windows is running in 386 enhanced mode, you can set PIF options for an appli­
cation that runs in standard mode. You do this by using commands on the Mode 
menu. 

Note Most options have effect only in the mode for which they are specified. 
For example, you can specify two different values for the Optional Parameters 
option: one for use with standard mode and one for use with 386 enhanced mode. 
However, a few options, such as Program Filename and Window Title, are com­
mon to both modes. 
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~ To change the PIF mode 

• Prom the Mode menu, choose the mode you want (Standard or 386 Enhanced). 

If you choose the mode you are not currently running in, PIP Editor displays a 
message, reminding you that options you specify won't have any effect in the 
current mode. If you are sure you want to set options for the selected mode, 
choose the OK button. 

PIP Editor displays the options for the mode you chose. 

Specifying Basic PIF Options for 386 Enhanced Mode 
There are two types of 386 Enhanced options: basic and advanced. The basic 
options are similar to the PIP options for standard mode. The advanced options 
fine-tune the way the application runs in 386 enhanced mode. This section 
explains each of the basic options for running an application in 386 enhanced 
mode. 

If Windows is running in 386 enhanced mode, PIP Editor displays the 386 
Enhanced options. (If you are running Windows in standard mode, you can 
display the 386 Enhanced options by choosing 386 Enhanced from the Mode 
menu.) The basic options for 386 enhanced mode appear as follows. 

f.rogram Filename: 

Window litle: 

!lPtional Parameters: 

~tart-up Directory: 

!£ideo Memory: @ Text 0 Low Graphics 0 High Graphics 

Memory Requirements: KB Required ~ KB !2esired ~ 

EMS Memory: KB Required ~ KB .limit ~ 

XMS Memory: KB Reguired ~ KB Limit ~ 

Display Usage: @ Fyll Screen Execution: D .!tackground 

o :'tlindowed D ,[xclusive 
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Program Filename 

Window Title 

In the Program Filename box, type the name of the file that starts the application. 
Include the path if necessary. If you start the application from a batch program, 
type its path, including the filename extension (usually .BAT). 

For most applications, you can type the path of the main program file, which 
usually has the extension .EXE or .COM. For example, if the file you use to start 
Microsoft Word is named WORD.EXE and is located in the WORD directory, 
you would type e:\word\word.exe. 

You can also specify an environment variable in this box. By using an environ­
ment variable, you can place a variable name in the PIF and assign it a value by 
using the set command in the AUTOEXEC.BAT file. When you type the variable 
name, enclose it in percent signs (%). For example, in your AUTOEXEC.BAT file 
you could assign the value "c:\word\word.exe" to an environment variable named 
WORDDIR. Then, in PIF Editor, you would specify the environment variable 
%worddir% as the program filename. 

You can type a descriptive name in the Window Title box. For example, you could 
type Lotus 1-2-3 if you are creating a PIF for that application. When the applica­
tion is minimized, the name appears under its icon, and it appears in the title bar 
when the application is running in a window. 

This entry is optional. If you leave the Window Title box blank, the application's 
title bar displays the name of the application without the extension if you start the 
application from the PIP. 

You can also specify an environment variable in this box. By using an environ­
ment variable, you can place a variable name in the PIF and assign it a value by 
using the set command in the AUTOEXEC.BAT file. When you type the variable 
name, enclose it in percent signs (%). 

You can also use Program Manager to specify a title. You do this by choosing the 
Properties command from the File menu in Program Manager, and then specifying 
a name in the Description box. Program Manager settings override PIF Editor 
settings. 

Optional Parameters 
You can type application parameters in the Optional Parameters box. These are 
the same parameters you type after the application's filename when starting the 
program from MS-DOS. For example, if you type word Ie when you start 
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Microsoft Word from the MS-DOS command prompt, type Ie in the Optional 
Parameters box. 

Parameters can be filenames, letters, numbers, or any type of information up to 
62 characters in length. For information about valid parameters, see the applica­
tion's documentation. 

If you want Windows to prompt you for parameters whenever you start the appli­
cation, type a question mark (?) in this box. You can also specify an environment 
variable in this field. By using an environment variable, you can place a variable 
name in the PIF and assign it a value by using the set command in the 
AUTOEXEC.BAT file. When you type the variable name, enclose it in percent 
signs (%). 

This entry is optional. If the application does not require parameters, or if you do 
not want to use any parameters when you start your application, leave this box 
blank. 

The optional parameters you specify when PIF Editor is displaying the 386 
Enhanced options apply to 386 enhanced mode only. If you want to specify 
different ones for your application to use in standard mode, choose the Standard 
command from the Mode menu. 

Note When you start the application by using the Run command in File Manager 
or Program Manager, any optional parameters you specify override the optional 
parameters specified in PIF Editor. 

Start-up Directory 
Some applications require access to files in a particular directory before they can 
run. You can type a path in the Start-up Directory box to specify the directory you 
want to be the current directory when the application starts (usually the directory 
where the application's program file is located). This entry is optional. 

You can also specify an environment variable in this box. By using an environ­
ment variable, you can place a variable name in the PIF and assign it a value by 
using the set command in the AUTOEXEC.BAT file. When you type the variable 
name, enclose it in percent signs (%). 

You can also use Program Manager to specify a start-up directory. You do this 
by choosing the Properties command from the File menu in Program Manager, 
and then specifying a directory in the Working Directory box. Program Manager 
settings override PIF Editor settings. 



264 Microsoft Windows User's Guide 

Video Memory 
Use the Video Memory options to specify how the application appears on the 
screen when you start it. The video mode determines how much memory 
Windows allocates to initially display the application. 

You can select from three video modes: Text, Low Graphics, and High Graphics. 
The following table describes the options. 

Use 

Text 

Low Graphics 

High Graphics 

To 

Reserve enough memory to display the application initially in text 
mode. Text mode requires the least amount of memory (usually less 
than 16K). 

Reserve enough memory to display the application initially in low­
resolution graphics mode. With most display adapters, this mode 
corresponds to eGA-resolution graphics, and requires about 32K 
of memory. 

Reserve enough memory to display the application initially in high­
resolution graphics mode. Enhanced graphics adapters (EGAs) and 
video graphics adapters (VGAs) use high-resolution graphics mode, 
which usually requires about 128K of memory. 

Selecting both this check box and the Retain Video Memory check 
box (in the Advanced dialog box) ensures that there's always 
enough memory to run the application; however, less memory is 
then available for other applications. 

After the application is running, Windows can adjust the application's display 
memory, depending on the application's current video mode. For example, if 
you start the application in graphics mode and later change it to text mode (which 
requires less memory), Windows frees the extra memory for other applications. 
If you change to a video mode that requires more memory, Windows attempts to 
provide the additional memory. 

If you switch to a higher-resolution video mode and there is not enough additional 
memory available, the application could partially or completely disappear from the 
screen. You can prevent this by ensuring that there is always enough display 
memory available for the application. To do this, select the highest-resolution 
video mode that the application can run in. Then, select the Retain Video Memory 
check box in the Advanced dialog box so that extra video memory is not available 
to other applications. For more information about this option, see "Retain Video 
Memory" later in this chapter. 

Note The effects of the Video Memory options depend on the display adapter 
used with your system. For example, some display adapters, such as Hercules 
and color graphics adapters (CGAs), have only one graphics mode. With these 
adapters, there is no difference between the Low Graphics and High Graphics 
options. 
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Memory Requ irements 
Use the Memory Requirements options to allocate conventional memory to the 
application. Conventional memory is the first 640K of memory that MS-DOS uses 
to run applications. Most computers have at least 256K of conventional memory, 
and can accommodate up to 640K. 

Note The Memory Requirements options pertain to the amount of free 
memory the application needs in order to run. When setting these options, do 
not use the memory requirements listed in the application's documentation. Such 
"requirements" usually are an estimate of the total amount of memory your system 
should have, not the amount of memory that must be free for the application to 
run. Application manufacturers usually specify more memory than the application 
needs; this ensures that your system has enough memory to run MS-DOS, the 
utilities in your CONFIG.SYS and AUTOEXEC.BAT files, and the application. 
When specifying memory requirements, use the following guidelines. 

Use 

KB Required 

KB Desired 

To 

Specify how many kilobytes of conventional memory are needed to 
start the application. In general, you should leave this setting at 128. 

Windows starts the application only if there is at least as much free 
memory as the KB Required option specifies. Otherwise, a message 
appears, indicating there is not enough memory to run the applica­
tion. If other applications are running, you can quit one or more of 
them and try running the application again. For information about 
making more memory available, see Chapter 14, "Optimizing 
Windows." 

The KB Required option does not limit how much memory the appli­
cation receives; Windows gives it at least as much as is specified by 
KB Required, plus any available expanded memory up to the amount 
specified by the KB Desired option. 

To start the application using the total amount of conventional 
memory, set the KB Required option to -1. If Windows cannot use 
the total amount of conventional memory, it will not start the appli­
cation. 

Limit the amount of conventional memory the application gets. 
Windows allocates an application up to, but no more than, the amount 
of memory you specify in this box. The maximum amount of conven­
tional memory any application can use is 640K. 

You can set KB Desired to an amount less than 640K to reserve more 
memory for other applications. 

A setting of -1 gives this application as much memory as possible up 
to 640K. 
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EMS Memory 
Although Windows doesn't use expanded memory when running in 386 enhanced 
mode, it simulates expanded memory for applications that use it. Use the EMS 
Memory options to specify how much expanded memory Windows should pro­
vide to an application. Although few applications actually require expanded 
memory, many run better if they can use it. (For more information about the 
different types of memory, see Chapter 14, "Optimizing Windows.") The 
following table describes the options. 

Use 

KB Required 

KB Limit 

To 

Specify how many kilobytes of expanded memory are needed to start 
the application. In general, you can leave this option at the standard 
setting of 0, indicating that the application does not require expanded 
memory. The KB Required option does not limit how much expanded 
memory the application receives; Windows gives it at least as much 
as is specified by KB Required, plus any available expanded memory 
up to the amount specified by the KB Limit option. 

Windows starts the application only if it can provide at least as much 
expanded memory as the KB Required option specifies. Otherwise, 
Windows displays a message indicating there is not enough expanded 
memory to run the application. If other applications are running, you 
can quit one or more of them and then try running the application 
again. For information about making more memory available to the 
application, see Chapter 14, "Optimizing Windows." 

Limit the amount of expanded memory provided to the application. 
Windows gives an application as much expanded memory as it 
requests, up to the amount you type in this box (or until no more 
memory is available). 

Some applications take all available expanded memory whether they 
need it or not. This option is useful for limiting an application's 
access to expanded memory. 

The default setting of 1024 provides the application with as much 
expanded memory as it requests, up to a limit of 1024K, or until no 
more memory is available. 

A setting of -1 allocates as much expanded memory to an application 
as it requests, up to the limit of system memory. This can slow down 
the rest of your system. 

To prevent Windows from providing any expanded memory to the application, 
set both KB Required and KB Limit to O. 
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Use the XMS Memory options to allocate extended memory to an application 
that uses memory according to the LotuslIntellMicrosofti AST eXtended Memory 
Specification (XMS) standard. Because few applications require extended 
memory, you can usually leave these options at their default settings. The 
following table describes the options. 

Use 

KB Required 

KB Limit 

To 

Specify how many kilobytes of extended memory are needed to start 
the application. In general, you can leave this option at the default set­
ting of 0, indicating that this application does not require extended 
memory. 

The KB Required option does not limit how much extended memory 
the application receives; Windows gives it as much extended memory 
as the application requests, up to the limit set by the KB Limit option 
(or until no more memory is available). 

Windows starts the application only if it can provide at least as much 
extended memory as the KB Required option specifies. Otherwise, 
Windows displays a message indicating there is not enough memory 
to run the application. If other applications are running, you can quit 
one or more of them and try running the application again. For infor­
mation about making more memory available to the application, see 
Chapter 14, "Optimizing Windows." 

Limit the amount of extended memory provided to the application. 
Windows gives an application as much extended memory as it 
requests, up to the amount you type in this box (or until no more 
memory is available). 

Some applications take all available extended memory whether they 
need it or not. This option is useful for limiting an application's 
access to extended memory. 

The default setting of 1024 provides the application with as much 
extended memory as it requests, up to a limit of 1024K, or until there 
is no more memory available. 

A setting of -1 allocates as much extended memory to an application 
as it requests, up to the limit of system memory. This can slow down 
the rest of your system. 

To prevent Windows from providing any extended memory to the application, 
set both KB Required and KB Limit to o. 
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Display Usage 

Execution 

Use the Display Usage options to indicate whether you want the application to 
start in a window or in a full screen. The following table describes the options. 

Use 

Full Screen 

Windowed 

To 

Start the application in a full screen. 

Start the application in a window. Running an application in a window 
requires more memory than running it in a full screen. However, you 
gain the advantages of running in a window, including the ability to 
easily share information between applications. 

When the application is running, you can switch between a window and a full 
screen by pressing ALT+ENTER. 

Use the Execution options to control when the application can run and how it 
shares resources with other applications. The following table describes the 
options. 

Use 

Background 

Exclusive 

To 

Specify that the application run while you are using another 
application. For example, a communications program can run in 
the background, accepting information from another computer, while 
you work with a word-processing application. If you do not select 
this option, the application is suspended when you switch to another 
application. 

Suspend other applications while this application is the active appli­
cation (even if the other applications have the Background option 
selected). Selecting this option can give the active application more 
memory and processor time. 

You can set this option both for applications that run in a window and 
for those that run in a full screen. It is best to run exclusive applica­
tions in a full screen because this gives them the full benefit of the 
Exclusive option. When you run an exclusive application in a window, 
Windows reserves some resources for itself and for running Windows 
applications. 

Close Window on Exit 
Clear the Close Window On Exit check box if you want Windows to leave the 
window on the screen after you quit the application. This is especially useful if 
you are running a command or application that displays output on the screen. If 
the window closes too quickly, you won't see the output. 
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If you are running the application in a window, the title bar changes to read 
"Inactive." You can close the application window (quit the application) by 
choosing the Close command from the Control menu. 

Specifying Advanced PIF Options for 386 Enhanced Mode 
You can use the advanced PIP options to fine-tune how the application runs in 
386 enhanced mode and how it uses memory and other system resources. In most 
cases, you do not need to change the advanced options; you can use the default 
settings. If you plan to change these options, it is best to be familiar with memory 
issues, Windows, and the applications you use. For more information about the 
technical concepts discussed in this section, see Chapter 14, "Optimizing 
Windows." 

~ To display the advanced PIF options for 386 enhanced mode 

1. If PIP Editor is not currently displaying the options for 386 enhanced mode, 
choose 386 Enhanced from the Mode menu. 

2. Choose the Advanced button. 

The Advanced Options dialog box appears. 

Mullilasking Oplions--------------, 

.!!.ackground PriorilY: L=:J foreground Priorily: 

[ZJ .!leleclldle Time 

Memory Oplions 

D EMS Memory Locket! D XM S Memory LQ.cked 

[ZJ Uses .!:!igh Memory Area D bock Applicalion Memory 

Display Oplions 
M onilor Por!s: D Texl D Low Graphics [ZJ High Graphics 

[ZJ f.mulale T exl Mode D Relain Video .M.emory 

OIher Oplions 
[ZJ Allow Fasl e.asle D Allow .c.lose When Active 

Reserve ~horlcul Keys: D AII+ Tab D AII+Esc D CIrI+Esc 

D PrlSc D AII+PrISc D AII+Space 

D AII+Enler 

APplicalion Shoricul Key: LI N_o_ne _______ ----' 

The advanced options are divided into four groups: Multitasking Options, Memory 
Options, Display Options, and Other Options. 
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Multitasking Options 
Use the Multitasking options to determine how the application runs in relationship 
to other applications. The Multitasking options appear as follows. 

Multitasking Options-------------, 

.!!ackground Priority: L=:J foreground Priority: ~ 

[S] .!letect Idle Time 

Background Priority 
Use the Background Priority option to specify how much processor time the 
application should receive when it is running in the background. The application 
receives this priority only when its Background check box is selected and the fore­
ground application's Exc1usi ve check box is not selected. You can type a value 
from 0 to 10000; the default background priority is 50. The figure you type is 
meaningful only when compared with other applications' background and 
foreground priorities; it refers to the amount of computer processor time the 
applications use. 

For example, suppose you have four applications running. One application is 
running in the foreground with a foreground priority of 200. The other three appli­
cations are running in the background with a background priority of 50 each. The 
total priority of all four applications is 3 times 50 (the background priorities), plus 
200 (the foreground priority), or 350. Of this total, the foreground application gets 
200 out of 350, or 58 percent of the processor time. Each of the three background 
applications gets 50 out of the total of 350, or 14 percent of the processor time. 

When a non-Windows application is running in a window or when it is minimized, 
you can also change its priorities by using commands on the Control menu. 

Note You set priorities for Windows by using Control Panel. If you have set 
priorities in a PIF that do not give Windows enough priority to perform efficiently, 
Windows changes the settings in Control Panel. 

Foreground Priority 
Use the Foreground Priority option to specify how much processor time you want 
the application to receive when it is the active application. You can type a value 
from 0 to 10000; the default foreground priority is 100. For example, you can 
ensure that an application receives all of the processing time it needs without 
interruption by setting Foreground Priority to 10000. At this setting, no back­
ground applications can run unless the foreground application is idle-that is, 
waiting for input from you. 
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The figure you type is meaningful only when compared with other applications' 
background and foreground priorities; it refers to the amount of computer proces­
sor time the applications use. For information about how Windows interprets 
application priorities, see the preceding section, "Background Priority." 

Detect Idle Time 
Select the Detect Idle Time check box to give resources to other applications 
while your application is idle. Leave this option selected except in rare cases; 
this enhances the performance of the entire system. 

Try clearing this option to speed up an application that is running slowly or not 
working properly. 

The advanced PIF options include options that control how the application uses 
the computer's available memory when running in 386 enhanced mode. The 
Memory options appear as follows. 

Memory Options-----------------, 

o EMS Memory Loc,!>,ed 

IZl Uses .!iigh Memory Area 

EMS Memory locked 

o XMS Memory LQcked 

o l.ock Application Memory 

Use the EMS Memory Locked check box if you don't want the application's 
expanded memory swapped to the hard disk. Locking an application's expanded 
memory can improve that application's performance, but it slows down the rest of 
your system and reduces the amount of available memory. 

XMS Memory locked 
Use the XMS Memory Locked check box if you don't want the application's 
extended memory swapped to the hard disk. Locking an application's extended 
memory can improve that application's performance, but it slows down the rest of 
your system and reduces the amount of available memory. 

Uses High Memory Area 
Select the Uses High Memory Area check box if you want your application to use 
the high memory area (HMA) of RAM. The high memory area is the first 64K of 
extended memory. 
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Display Options 

If the HMA is available when Windows starts, each application can allocate its 
own HMA. However, the HMA is used by some memory-resident programs, such 
as network software. If such a program is using the HMA when you start 
Windows in 386 enhanced mode, no other application can use the HMA. 

Keep this option selected for most applications. If the HMA is available and the 
application uses it, more memory is available to the application. If the application 
does not use the HMA, no memory is wasted. 

Clear this check box if you want to prevent the application from using the HMA 
even when the HMA is available. 

lock Application Memory 
Select the Lock Application Memory check box to speed up some applications. If 
this option is selected, the application stays in memory and is not swapped to the 
hard disk. Although selecting this option can speed up the application, it slows 
down the rest of your system and reduces the amount of available memory. 

Note This option affects how the application's conventional memory is handled. 
The use of its expanded and extended memory is controlled separately by the 
Locked options in the EMS Memory and XMS Memory sections of the Advanced 
Options dialog box. For more information about memory, see Chapter 14, 
"Optimizing Windows." 

Use the Display options to determine how the application appears on the screen 
and how Windows handles memory when it displays the application. The Display 
options appear as follows. 

Display Options-------------------. 

Monitor Por!s: 0 Text 0 Low Graphics 0 High Graphics 

o .!;.mulate Text Mode 0 Retain Video Memory 

Monitor Ports 
Some applications interact directly with input and output ports in order to control 
the display adapter. When one of these applications is running with Windows, 
Windows needs to monitor those interactions. This ensures that when you switch 
from and return to the application, Windows displays the application correctly. 

For most applications, you can leave these options at their default settings. You 
should change these options only if the application is not displayed properly when 
you switch to it. 
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Note If you are running a non-Windows application in 386 enhanced mode, and 
Windows updates the screen too slowly, make sure none of the Monitor Ports 
options are selected in the application's PIP. Clearing these options speeds up the 
screen update. However, you may be unable to switch to and from the application. 
In this case, you must quit the application to return to Windows with a correctly 
restored screen. 

If an application is not displayed properly, open the application's PIF, and then 
select the Monitor Ports option for the mode the application was running in when 
the problem occurred. Then try running the application again. If the application 
is still not displayed correctly, try selecting the other Monitor Ports options. The 
following table describes the options. 

Use 

Text 

Low Graphics 

High Graphics 

To 

Monitor all video operations when the application is running in text 
mode. Few applications require this option. 

Monitor all video operations when the application is running in 
low-resolution graphics mode. Few applications require this option. 

Monitor all video operations when the application is running in 
high-resolution graphics mode. 

Emulate Text Mode 
You can use the Emulate Text Mode option to increase the rate at which the appli­
cation displays text. For most applications, you can leave this check box selected. 

Try clearing this check box if the application's text is garbled, the cursor appears 
in the wrong place, or the application will not run. 

Retain Video Memory 
Select the Retain Video Memory check box if you don't want Windows to release 
the application's extra video memory for use by other applications. 

Some applications can use several video modes. Usually, you can change the 
video mode from within the application itself. For example, in Microsoft Word, 
you can switch between Text and Graphics modes. If you are using such an appli­
cation and the Retain Video Memory check box is not selected, Windows adjusts 
the application's video memory to accommodate the application's current video 
mode. If you change to a video mode that requires less memory, Windows frees 
the extra memory for use by other applications. If you later change back to a mode 
that requires more memory, Windows attempts to provide additional memory to 
the application. 
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Other Options 

This dynamic allocation of video memory works well as long as you do not run 
out of memory. However, if you are running low on memory and then change the 
application to a more memory-intensive video mode, Windows might not be able 
to support that mode, and the application could partially or completely disappear 
from the screen. (At this point the application is still running. You can make the 
application visible again by freeing some memory.) 

Selecting both this check box and the appropriate Video Memory option (in the 
basic PIF options for 386 enhanced mode) ensures that there is always enough 
memory available for Windows to correctly display the application. The Video 
Memory option ensures that there is enough video memory to display the applica­
tion when it starts; the Retain Video Memory option ensures that Windows does 
not release any of the application's video memory to other applications. Note that 
if you select both options, the memory is not available for other applications even 
when the memory is not being used by this application. 

The advanced PIF options include several additional options you can use to 
customize the way the application runs with Windows in 386 enhanced mode. 
The Other options appear as follows. 

Other Options-----------------. 

[2J Allow Fast easte D Allow klose When Active 

Reserve ~hortcut Keys: D Alt+Tab D Alt+Esc D Ctrl+Esc 

D PrtSc D Alt+PrtSc D AIt+Space 

D AIt+Enter 

APplication Shortcut Key: \ '-N_on_e ______ -' 

Allow Fast Paste 
Select this option if the application is capable of accepting information pasted 
from the Clipboard by using the fastest method. Most applications can use the 
fastest pasting method. 

Clear this check box only if you cannot paste information into the application. 
Windows can detect most applications that cannot handle fast pasting and, for 
them, will use the slower pasting method instead. Occasionally, Windows is 
unable to detect an application that cannot accommodate the fastest pasting 
method; in this case, when you choose the Paste command from the application's 
Control menu, nothing happens. To fix this problem, cancel the paste operation 
by pressing ESC, and then quit the application. In the application's PIF, clear the 
Allow Fast Paste check box, save the PIF, and then restart the application. 
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Allow Close When Active 
Select this check box if you want to be able to quit an application without 
choosing the application's exit command. If this option is selected, you can 
quit Windows without having to quit every application separately. 

Use this option only if you are sure the application uses standard MS-DOS file 
handles. If you are unsure, do not select this check box. 

Caution Selecting this option could result in data loss or damage to your files. 
Windows might quit an application before the application closes its open files; as a 
result, you could lose any changes you made to those files. Do not use this option 
for such applications as databases and word processors. 

Reserve Shortcut Keys 
If you select one or more of the shortcut-key check boxes, Windows ignores the 
specified key combination when the application is running in the foreground. 
Instead, the application responds to the key combination. The following table 
describes the shortcut-key combinations. 

Use 

ALT+TAB 

ALT+ESC 

CTRL+ESC 

PRTSC 

ALT+PRTSC 

ALT+SPACE 

ALT+ENTER 

To 

Reserve the ALT + TAB shortcut key for the application. Otherwise, 
Windows switches between applications when you press this key 
combination. 

Reserve the ALT +ESC shortcut key for the application. Otherwise, when 
you press this key combination, Windows cycles you through the appli­
cations in the order each was started. 

Reserve the CTRL+ESC shortcut key for the application. Otherwise, 
Windows displays Task List when you press this key combination. 

Reserve the PRINT SCREEN shortcut key for the application. Otherwise, 
Windows copies an image of the screen onto the Clipboard when you 
press this key. 

Reserve the ALT +PRINT SCREEN shortcut key for the application. 
Otherwise, Windows copies an image of the active window onto the 
Clipboard when you press this key combination. 

Reserve the ALT +SPACEBAR shortcut key for the application. Otherwise, 
Windows displays the application's Control menu when you press this 
key combination. 

Reserve the ALT +ENTER shortcut key for the application. Otherwise, 
when you press this key combination, Windows switches the applica­
tion between a window (if it can run in one) and a full screen. 

The Reserve Shortcut Keys options for 386 enhanced mode are similar to the 
corresponding options for standard mode. For more information, see "Specifying 
PIF Options for Standard Mode" later in this chapter. 
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Application Shortcut Key 
When running in 386 enhanced mode, Windows provides a special feature called 
an application shortcut key. When an application is running in the background 
and you press its application shortcut key, it immediately becomes the foreground 
(active) application. By using an application shortcut key, you can switch to a 
particular application quickly, no matter where you are in Windows or which 
application you are using. 

To assign an application shortcut key to an application, you can use the Properties 
command on the File menu in Program Manager, or you can use the Application 
Shortcut Key option in the application's PIP. Shortcut-key settings made in 
Program Manager override settings made in PIF Editor. 

After you assign an application shortcut key, the key combination works as a short­
cut key only when that application is loaded. No application (including Windows, 
Windows applications, and the application that uses the shortcut key) can use that 
key combination for any other purpose. For this reason, you should select applica­
tion shortcut keys carefully. A void assigning the same shortcut key to more than 
one application. 

For example, suppose you specify ALT+F as the application shortcut key for PFS: 
First Choice. In many Windows applications, ALT+F is a shortcut key: It displays 
the File menu. However, if PFS: First Choice is loaded when you are using 
Windows Notepad, pressing ALT+F makes PFS: First Choice the active application, 
rather than displaying the File menu in Notepad. 

~ To specify a shortcut key by using Program Manager 

1. Switch to Program Manager. 

2. Select the icon of the application for which you want to specify a shortcut key. 

3. From the File menu, choose Properties. 

4. Select the Shortcut Key box, and then press the key combination you want to 
use for this application. 

Valid key sequences are cTRL+ALT+character, CTRL+SHIFT+character, 
cTRL+sHIFT+ALT+character, and CTRL+ALT+SHIFT+character. The character can 
be any letter, number, or special character. When you type a character in the 
Shortcut Key box, Program Manager adds CTRL+ALT in front of it. To specify 
a different control-key sequence, you must type the sequence. 

5. Choose the OK button. 

If you press an invalid key combination, a message appears and Windows 
resets the key definition to its previous value. 
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~ To delete a shortcut-key definition by using Program Manager 

1. Switch to Program Manager. 

2. Select the application's icon. 

3. From the File menu, choose Properties. 

4. Select the Shortcut Key box, and then press BACKSPACE. 

The shortcut key is set to None. 

5. Choose the OK button. 

~ To specify a shortcut key by using PIF Editor 

1. From the File menu, choose Open. 

2. Select the PIF for the application you want to specify a shortcut key for, and 
then choose the OK button. 

3. Choose the Advanced button. 

The Advanced dialog box opens. 

4. Select the Application Shortcut Key box. 

5. Press the key combination you want. 

The key combination you specify must include either the ALT or CTRL key. 
For example, the key combinations CTRL+Y, ALT+F4, CTRL+SHIFT+Fll, and 
CTRL+ALT+7 are all valid application shortcut keys. You cannot specify a key 
combination that includes the ESC, ENTER, TAB, SPACEBAR, PRINT SCREEN, or 
BACKSPACE key. Windows interprets any key combination you press as an appli­
cation shortcut key unless you press keys that move you to another area in the 
dialog box (such as TAB) or keys that are Windows keys not yet reserved for the 
application (such as CTRL+ESC or ALT+TAB). 

6. Choose the OK button. 

If you press an invalid key combination, a message appears, and Windows 
resets the key definition to its previous value. 

Unlike shortcut keys defined by using Program Manager, shortcut keys defined by 
using PIF Editor cannot be used to start an application but only to switch to the 
application while it is running. 



278 Microsoft Windows User's Guide 

~ To delete a shortcut-key definition by using PIF Editor 

1. Open the PIF for the application whose shortcut key you want to delete. 

2. Choose the Advanced button. 

3. Select the Application Shortcut Key box. 

4. Press SHIFT+BACKSPACE to set the shortcut key to None. 

Or, while pressing a key combination, press BACKSPACE to reset the 
shortcut-key definition to its previous value. 

Specifying PIF Options for Standard Mode 
A PIF contains two sets of options: 386 Enhanced and Standard. This section 
explains how to specify the Standard options. You can use these options for 
running an application in standard mode. 

If you are currently running Windows in standard mode, PIF Editor displays the 
Standard options. (If you are running Windows in 386 enhanced mode, you can 
display the Standard options by choosing Standard from the Mode menu.) For 
more information about modes and PIF options, see "Changing PIF Modes" 
earlier in this chapter. 

The Standard options appear as follows. 

Window Litle: 

.Qptional Parameters: 

~tart-up Directory: 

Yideo Mode: @ Tellt 0 Graphics/Multiple Tellt 

Memory Requirements: KB Required ~ 

XMS Memory: KB Reguired E:=J KB Limit E:=J 
Directly Modifies: 0 COM1 0 COMJ. 0 Keyboard 

o COMZ 0 COM! 

o No Screen ~Kchange 0 Prevent Program Sytitch 

l2J !;.Iose Window on Exit 0 Ho Save Screen 

Reserve Shortcyt Keys: 0 AIt+Tab 0 Alt+Esc 0 Ctrl+Esc 

o PrtSc 0 Alt+PrtSc 
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Program Filename 

Window Title 

In the Program Filename box, type the name of the file that starts the applica­
tion (including the path, if necessary). If you start the application from a batch 
program, type its path, including the filename extension (usually .BAT). 

For most applications, you can type the path of the main program file, which 
usually has the extension .EXE or .COM. For example, when creating a PIF for 
Microsoft Word, you would type e:\word\word.exe. 

You can also specify an environment variable in this box. By using an environ­
ment variable, you can place a variable name in the PIF and assign it a value by 
using the set command in the AUTOEXEC.BAT file. When you type the variable 
name, enclose it in percent signs (%). For example, in your AUTOEXEC.BAT file 
you could assign the value "c:\word\word.exe" to an environment variable named 
WORDDIR. Then, in PIF Editor, you would specify the environment variable 
%worddir% as the program filename. 

You can type a descriptive name in the Window Title box. For example, you 
could type Lotus 1-2-3 if you are creating a PIF for that application. When the 
application is minimized, the name you type appears under its icon, and appears 
in the title bar if the application is running in a window. 

This entry is optional. If you leave the Window Title box blank, the application's 
title bar displays the name of the PIF without the extension. 

You can also specify an environment variable in this box. By using an environ­
ment variable, you can place a variable name in the PIF and assign it a value by 
using the set command in the AUTOEXEC.BAT file. When you type the variable 
name, enclose it in percent signs (%). 

Note You can also specify a window title for a non-Windows application by using 
the Properties command on the File menu in Program Manager. Settings made in 
Program Manager override settings made in PIF Editor. 

Optional Parameters 
You can type application parameters in the Optional Parameters box. These are 
the same parameters you type after the application's filename when starting the 
program from MS-DOS. For example, if you type word Ie when you start 
Microsoft Word from the MS-DOS command prompt, type Ie in the Optional 
Parameters box. 
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Parameters can be filenames, letters, numbers, or any type of information up to 
62 characters in length. For information about valid parameters, see the applica­
tion's documentation. 

If you want Windows to prompt you for parameters whenever you start the appli­
cation, type a question mark (?) in this box. You can also specify an environment 
variable in this field. By using an environment variable, you can place a variable 
name in the PIF and assign it a value by using the set command in the 
AUTOEXEC.BAT file. When you type the variable name, enclose it in percent 
signs (%). 

This entry is optional. If the application does not require parameters, or if you do 
not want to use any parameters when you start your application, leave this box 
blank. 

The optional parameters you specify when PIF Editor is displaying Standard 
options apply to standard mode only. If you want to specify different ones for your 
application to use in 386 enhanced mode, use the 386 Enhanced command on the 
Mode menu. 

Note When you start the application by using the Run command in File Manager 
or Program Manager, any optional parameters you specify override the optional 
parameters specified in PIF Editor. 

Start-up Directory 

Video Mode 

Some applications require access to files in a particular directory before they can 
run. You can type a path in the Start-up Directory box to specify the directory you 
want to be the current directory when the application starts (usually the directory 
where the application's program file is located). This entry is optional. 

You can also specify an environment variable in this box. By using an environ­
ment variable, you can place a variable name in the PIF and assign it a value by 
using the set command in the AUTOEXEC.BAT file. When you type the variable 
name, enclose it in percent signs (%). 

You can also use Program Manager to specify a start-up directory. You do this 
by choosing the Properties command from the File menu in Program Manager, 
and then specifying a directory in the Working Directory box. Program Manager 
settings override PIF Editor settings. 

Use the Video Mode options to indicate how much memory is needed to save and 
restore your application's screen contents and to copy the screen contents onto the 
Clipboard. 
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The memory that Windows reserves for the application's screen contents is part of 
the memory allocated to the application. Therefore, the more memory required to 
display the application's screen contents, the less memory there is available for the 
application itself. 

You can select from two video modes: Text mode and Graphics/Multiple Text 
mode. Text mode requires less memory than Graphics/Multiple Text. The follow­
ing table describes the options. 

Use 

Text 

Graphics/ Multiple Text 

To 

Indicate that the application is to run only in text mode. 
Text mode uses the least memory. Therefore, you could 
select this option to make the most memory available to 
the application. 

Indicate that the application is to run in graphics mode, 
or that it is to use more display memory than one text 
screen requires. The Graphics/Multiple Text video mode 
uses more memory than the Text video mode. However, 
selecting this option ensures that enough video memory 
is available when you switch between modes. 

Multiple text refers to text-mode applications that use 
more than one video page to display text, and therefore 
need more video memory than typical text-mode applica­
tions. Some Microsoft Basic programs use this mode. 

You can make more memory available to the application by selecting the Text 
option button. However, if you are not sure which video mode to use, select the 
Graphics/Multiple Text option button. If the application needs the Graphics mode 
but the Text option button is selected, you cannot switch from the application; the 
only way to return to Windows is to quit the application. 

Memory Requirements 
Use the Memory Requirements: KB Required box to indicate how many kilobytes 
of conventional memory must be free to start the application. In general, you 
should leave this setting at 128. 

When you start an application, Windows gives it all available conventional 
memory regardless of what you type in the KB Required box. The number in this 
box simply determines how much memory must be available before Windows 
tries to start the application; it does not limit how much conventional memory 
the application receives. 

If Windows cannot provide as much memory as you specify and you try to start 
the application, a message appears, telling you there is not enough memory to run 
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XMS Memory 

the application. For more information about specifying memory options and fine­
tuning memory requirements, see Chapter 14, "Optimizing Windows." 

Note The Memory Requirements option pertains to the amount of free 
memory the application needs in order to run. When setting this option, do not 
use the memory requirements listed in the application's documentation. Such 
"requirements" usually are an estimate of the total amount of memory your system 
should have, not the amount of memory that must be free for the application to 
run. Application manufacturers usually specify more memory than the application 
needs; this ensures that your system has enough memory to run MS-DOS, the 
utilities in your CONFIG.SYS and AUTOEXEC.BAT files, and the application. 

Use the XMS Memory options to allocate extended memory to an application 
that uses memory according to the LotuslIntellMicrosofti AST eXtended Memory 
Specification (XMS) standard. Because few applications require extended 
memory, you can usually leave these options at their default settings. Lotus 1-2-3 
version 3.1 is an example of a non-Windows application that does use extended 
memory. (For more information about extended memory, see Chapter 14, 
"Optimizing Windows.") The following table describes the options. 

Use 

KB Required 

KB Limit 

To 

Specify how many kilobytes of extended memory must be free in 
order to start the application. 

Leave this setting as it is for most applications. Specifying a value 
other than 0 dramatically increases the time it takes to switch to and 
from the application. You should specify a value only if the applica­
tion requires a certain amount of extended memory in order to run. 

Limit how many kilobytes of extended memory the application 
can use. 

Some applications take all available extended memory whether they 
need it or not. This option is useful for limiting an application's 
access to extended memory. 

Leave this setting at 0 to prevent the application from gaining access 
to any extended memory (except in the high memory area or HMA). 

Setting this option to -1 provides the application with all the 
extended memory it requests (up to the maximum amount available). 
Set this option to -1 only if the application requires large amounts of 
extended memory. In general, it is not a good idea to set this option 
to -1, because it dramatically slows down your system. 

To prevent the application from using any extended memory, leave both XMS 
Memory options at a setting of o. 
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Directly Modifies 
Use the Directly Modifies options to indicate that the application uses certain 
system resources in a way that prevents sharing those resources with other appli­
cations. For example, some communications applications take control of the 
communications port they are using, to the exclusion of other applications. The 
following table describes the options. 

Use 

COMl, COM2, COM3, COM4 

Keyboard 

To 

Specify which communications ports the applica­
tion uses. This prevents two applications from 
trying to use the same communications port at 
once (which can result in garbled or lost data). 

Indicate that the keyboard will be used with the 
application, rather than with Windows or other 
applications. 

Selecting this check box can make more memory 
available to the application, since Windows does 
not need to save the application's current state or 
its display settings. 

Selecting the Keyboard check box is similar to 
selecting the Prevent Program Switch check box; 
you have to quit the application in order to return to 
Windows or other applications. If you are uncer­
tain, do not select these options. 

With either the COM or Keyboard option, Windows cannot respond to any short­
cut keys you press while you're using the application, and you cannot switch from 
the application or copy its screen contents onto the Clipboard. 

No Screen Exchange 
You can conserve memory (thereby making more memory available to the appli­
cation) by selecting the No Screen Exchange check box. If you select this option, 
you cannot copy information from the application's window onto the Clipboard by 
using ALT +PRINT SCREEN or PRINT SCREEN. If you are uncertain, do not select this 
option. 

Selecting this check box has an effect similar to selecting both the PRTSC and 
ALT+PRTSC check boxes in the Reserve Shortcut Keys options. 
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Prevent Program Switch 
Selecting the Prevent Program Switch check box keeps Windows from allocating 
memory for program switching, which leaves the memory available to the applica­
tion. If you select this option, you cannot switch to another application. To use 
Windows or other applications, you have to first quit the application. If you are 
uncertain, do not select this option. 

To conserve memory, select this option if your application does not support 
switching, or when the application is a Microsoft Basic application that uses the 
serial communications port. 

Close Window on Exit 

No Save Screen 

Clear this check box if you want Windows to leave the window displayed after 
you quit the application. This is especially useful if you are running a command or 
application that displays output on the screen. If the window closes too quickly, 
you won't see the output. 

If you clear the Close Window On Exit check box and are running the application 
in text mode, a message reminds you to press any key to return to the Windows 
desktop. If you are running the application in graphics mode, this message does 
not appear; however, you can press any key to clear the screen and continue your 
Windows session. 

When you switch between applications in standard mode, Windows saves in 
memory the information displayed on the screen. By doing this, Windows ensures 
information is displayed correctly when you switch back to an application. 

When you select the No Save Screen check box, Windows no longer retains the 
screen information for that application, and the memory becomes available to the 
application. When the application uses this additional memory, it performs faster. 
However, when you switch to the application, the screen is not restored correctly, 
unless the application has the capability of retaining its own screen information. 

Use this option only when the application you are using can retain its own screen 
information and has a "redraw screen" command. To find out if your application 
has this capability, see the application's documentation. 
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Reserve Shortcut Keys 
Use the Reserve Shortcut Keys options to specify the key combinations you want 
to be used with your application, rather than with Windows. 

Normally, when you type a Windows shortcut-key combination, Windows carries 
out that shortcut key's assigned action; the application never registers that you 
pressed those keys. 

Selecting one or more of the Reserve Shortcut Keys check boxes indicates that 
Windows should ignore the specified key combination when the application is 
active. Instead, the application responds to the key combination. 

For example, suppose your word-processing application uses the key combination 
ALT+TAB to insert a special character into a document. But when you run the word 
processor with Windows, pressing ALT+TAB switches you to another application. 
For ALT+TAB to work in the word processor, you edit the word processor's PIF and 
select the Reserve Shortcut Keys option for the ALT+TAB shortcut key. Thereafter, 
when you use the word processor with Windows, pressing ALT+TAB inserts the 
special character rather than switching you to a different application. (When you 
use other applications, the key combination acts as a Windows shortcut key.) The 
following table describes the shortcut-key combinations. 

Use 

ALT+TAB 

ALT+ESC 

CTRL+ESC 

PRTSC 

ALT+PRTSC 

To 

Reserve the ALT + TAB shortcut key for the application. Otherwise, 
Windows switches between applications when you press this key combi­
nation. 

Reserve the ALT +ESC shortcut key for the application. Otherwise, when 
you press this key combination, Windows cycles you through the appli­
cations in the order each was started. 

Reserve the CTRL+ESC shortcut key for the application. Otherwise, 
Windows displays Task List when you press this key combination. 

Reserve the PRINT SCREEN shortcut key for the application. Otherwise, 
Windows copies an image of the screen onto the Clipboard when you 
press this key. 

Reserve the ALT +PRINT SCREEN shortcut key for the application. 
Otherwise, Windows copies an image of the active window onto the 
Clipboard when you press this key combination. 
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Write 

Chapter 9 

Working with Write 
Microsoft Windows Write is a word-processing application that you can use to 
create and print documents for day-to-day business and personal use. To create 
Write documents, you need to know how to type, edit, and format text in the 
Write window; save the text to a file; and print your documents on your printer. 
The following sections explain each of these tasks. 

~ To start Write 

• In the Accessories group, choose the Write icon. (Double-click the icon. Or use 
the arrow keys to move the selection cursor to the icon, and then press ENTER.) 

The Write window appears, ready for you to begin typing. 

Insertion point 
End mark 

Page-status area 
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Typing Text 

In the Write window, you see the following items: 

• The insertion point indicates where text appears when you start typing. When 
you start Write or open an existing document, the insertion point appears in the 
upper-left corner of the Write window. 

• The end mark indicates the end of a document. When there is no text in a Write 
window, the end mark is directly to the right of the insertion point. 

• The page-status area indicates which page of your text is currently on the 
screen. Until you break a document into pages, you see only "Page I" in the 
page-status area. 

• The mouse pointer appears only if you have a mouse connected to your 
computer. It indicates where the mouse is pointing inside the window and 
where the insertion point will move to if you click a location in a document. 

When you are ready, just start typing. The text that you type starts filling the 
Write window at the insertion point. When you reach the end of the line, Write 
automatically wraps your text to the beginning of the next line. To start a new 
paragraph, press ENTER. If you want to leave a blank line between paragraphs, 
press ENTER twice. 

If you make a mistake while typing, press BACKSPACE to back up the insertion 
point and undo the mistake. For information about editing techniques specific to 
Write, see the following section, "Editing a Document." 

Editing a Document 
Editing is much the same in Write as in any other Windows application (for more 
information, see Chapter 2, "Application Basics"). However, in addition to provid­
ing the same editing features used throughout the Microsoft Windows operating 
system, Write offers various special editing techniques. The following sections 
explain each of these techniques. 
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Moving Around in a Document 
You can use the scroll bars to move around in your Write document (for more 
information, see Chapter 2, "Application Basics"). To move the insertion point, 
use the mouse to point to a location in the document, and then click. Or you can 
use the keyboard. 

Write includes a number of special keys and key combinations for moving quickly 
around a document. These are in addition to the arrow keys, the SPACEBAR, and 
ENTER. The 5 key referred to in the following table is 5 on the numeric keypad. 
Make sure that the NUM LOCK key is off. 

Press To move the insertion point to the 

CTRL+RIGHT ARROW Next word 

CTRL+LEFT ARROW Previous word 

5+RIGHT ARROW Next sentence 

5+LEFT ARROW Previous sentence 

HOME Beginning of a line 

END End of a line 

5+DOWN ARROW Next paragraph 

5+UP ARROW Previous paragraph 

PAGE DOWN Next screen down 

PAGE UP Next screen up 

CTRL+PAGE DOWN Bottom of the window 

CTRL+PAGE UP Top of the window 

5+PAGE DOWN Next page 

5+PAGE UP Previous page 

CTRL+HOME Beginning of the document 

CTRL+END End of the document 

You can move the insertion point continuously by holding down any of the key 
combinations except for the keys that move you to the beginning or end of a line 
or document. 

You can use 5+PAGE DOWN and 5+PAGE UP to move to the next or previous page 
only after you either print your document or use the Repaginate command to 
divide your document into pages. Write stores page breaks with a document 
and remembers them each time you use the document. For more information, 
see "Breaking a Document into Pages" later in this chapter. 
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Selecting Text 

If you have divided a document into pages, you can move to a specific page by 
choosing the Go To Page command from the Find menu. 

~ To move to a specific page 

1. From the Find menu, choose Go To Page. 

Or press F4. 

The Go To dialog box appears. 

eage Number: [:::=J 
1:ljili!iilllli!!llill 

2. In the Page Number box, type the number of the page you want to move to. 

3. Choose the OK button. 

The dialog box disappears, and the insertion point moves to the beginning of 
the selected page. 

Before you edit or format text in a Write document, you need to select it. The 
easiest way to select text is to press and hold down the mouse button, and then 
move the pointer over the text. For information about the general selecting 
techniques used throughout Windows, see Chapter 2, "Application Basics." 

In addition to these general techniques, Write also features a technique for select­
ing by using the selection area and your mouse. The selection area is at the far left 
edge of the Write window, as shown in the following illustration. 

file .Edit Find !;.haracter Earagraph Qocument .!:!.elp 

PREPARING A HOME FOR SALE 

You can understand that showing a home to its best advantage makes the 
buyer want to purchase quickly and at a better price. Here are some 
tested tips to set the stage for a profitable and early sale. 

/l Fix up inside. Badly faded walls or worn woodwork reduce appeal. 
ZZ~.elective painting will help you add a fresh look. Clean windows and 
_~marred walls will create a bright, cheery appearance. 

---------------------

~ The mouse pointer in the selection area 



Chapter 9 Write 295 

In the selection area, the pointer changes to an arrow that slants to the right. You 
can use the selection area to select text in the following ways. 

To select 

By the line 

By the paragraph 

Between points 

The entire document 

~ To cancel a selection 

Do this 

Move the pointer to the selection area and point to a line. 
Click the mouse button once to select the line. To select more 
than one line, drag the pointer. 

Move the pointer to the selection area and point to any line in 
the paragraph. Double-click to select the paragraph. To extend 
the selection one paragraph at a time, hold the mouse button 
down after the second click, and then drag the pointer. 

Move the pointer to the selection area and select a line or 
paragraph. Move along the selection area to another line 
or paragraph, press and hold down SHIFT, and then click. 
Write selects all lines or paragraphs between the two points. 

Move the pointer to the selection area, press and hold down 
CTRL, and then click. 

• Move the pointer to the selected text, and then click. 

Finding and Changing Text 
You can easily search for and edit text in your Write documents by using the 
Find and Replace commands on the Find menu. These commands allow you to: 

• Search for text up to 255 characters in length. 

• Change all occurrences of the text in the document. 

• Change only certain occurrences of text. 

The following sections explain how to use the Find and Replace commands. 

Finding Text 
By using the Find command on the Find menu, you can look for a character, word, 
or group of characters or words in a Write document. 

When you choose the Find command, Write starts a search at the insertion point 
or at the end of any text that is selected. When it reaches the end of the document, 
Write continues searching from the beginning of the document to the point at 
which the search started. 
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~ To find text 

1. Position the insertion point where you want to start your search. 

2. From the Find menu, choose Find. 

The Find dialog box appears. 

o Match ~hole Word Only 

o MatchI;.ase 

3. In the Find What box, type the text you want to find. 

4. To find only entire words, select the Match Whole Word Only check box. 

Otherwise, Write finds, for example, main in remainder. 

5. To match capitalization exactly, select the Match Case check box. 

6. To start the search, choose the Find Next button. 

Write searches for the text and selects the first occurrence. If you want to edit 
the text, point to it and click to switch from the dialog box to the document. 
(If you are using the keyboard, press ALT+P6 to switch between the dialog box 
and the document.) 

If there are no occurrences of the text in the document, Write displays a 
message, telling you that it could not find the text. Choose the OK button. 

7. To find the next occurrence of the text, choose the Find Next button again. 

When Write finds the last occurrence of the text, it displays a message, telling 
you that the search is complete. Choose the OK button. 

8. To close the Find dialog box, choose the Cancel button. 

When searching for text that includes spaces, tabs, paragraph marks, and page 
breaks, type the following characters (where 1\ means the caret symbol) in the 
Find What box. 
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Type To represent 

? Any character in a file (? is called a wildcard). For example, if the search 
text is hea?, Write finds every word with hea followed by at least one 
character, such as headstrong, figurehead, heal, or theater. 

"w A space anywhere in your document-between words, for example. 

"t A tab character. 

"p A paragraph mark. 

"d A manual page break. For more information, see "Breaking Pages 
Manually" later in this chapter. 

Changing Text 
The Replace command on the Find menu allows you to find text and replace 
it with new text. You can find and change all occurrences of the specified text 
automatically, or you can decide whether to change each occurrence as Write 
finds it. 

When you choose the Replace command, Write searches forward from the 
location of the insertion point. When it reaches the end of the document, Write 
continues searching from the beginning of the document to the insertion point. 
If you select a section of your document before choosing Replace, however, the 
command searches only within that selection. 

~ To find and change text 

1. Position the insertion point where you want to start your search. 

If you want to make changes to only part of your document, select that part. 

2. From the Find menu, choose Replace. 

The Replace dialog box appears. 

Re~.IaceWith: L-I _____ ----1 IIIII 
o Match ~hole \IIord Onl, 

o Matchkase 

3. In the Find What box, type the text you want to find, and in the Replace With 
box, type the text you want to replace it with. 

For information about how to search for text that includes spaces, tabs, 
paragraph marks, and page breaks, see the preceding section, "Finding Text." 
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4. To find only entire words, select the Match Whole Word Only check box. 

5. To match capitalization exactly, select the Match Case check box. 

6. Choose one of the following buttons to start the search: Find Next, Replace, or 
Replace All. If you selected a section of your document to make changes in, 
choose the Replace Selection button. For more information about these options, 
see the table that follows this procedure. 

Write displays a message, telling you when a search is complete. Or, if there 
are no occurrences of the text in the document, Write displays a message, 
telling you that it could not find the text. Choose the OK button to close either 
dialog box. 

7. To close the Replace dialog box, choose the Close button. 

The following options are available when you choose the Replace command. 

Use 

Find Next 

Replace 

Replace All 

Replace Selection 

To 

Find the next occurrence of the search text. If you want to 
edit the text, click the text (or press ALT +F6) to switch to the 
document. 

Replace the selected text. Write then waits fQr further 
instructions. 

Automatically change all occurrences of the specified text in 
the document. 

Automatically change all occurrences of the specified text in the 
selected section of the document. The Replace All button 
changes to Replace Selection when you select a section of text. 

Using the Repeat Last Find Command 
You do not have to keep the Find or Replace dialog box on the screen throughout 
the entire search. You can use the Repeat Last Find command on the Find menu 
to continue a search after finding the first occurrence of search text. You cannot, 
however, make automatic changes to text if you use Repeat Last Find to find text. 

~ To repeat the last find 

1. Use the Find or Replace dialog box to find the first occurrence of the search 
text. 

2. Choose the Cancel or Close button to close the Find or Replace dialog box. 

3. From the Find menu, choose Repeat Last Find to find the next occurrence of 
the search text. 

Or press F3 to choose Repeat Last Find quickly. 
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Inserting Optional Hyphens 
As you look over the text in your document, you may occasionally see a large gap 
at the end of a line where a long word has been wrapped to the beginning of the 
next line. You can eliminate such gaps by inserting optional hyphens in long 
words to specify correct hyphenation points. If such a word occurs at the end of a 
line when you print your document, Write breaks it at one of these hyphenation 
points. Optional hyphens are invisible unless they appear at the end of a line. 

~ To insert optional hyphens in a word 

• Press CTRL+SHIFT +HYPHEN (-) at each desired hyphenation point. 

Note If you type a normal hyphen at the end of a line of text, Write will always 
break the line at that hyphen. 

Inserting Pictures in Write 
There are three methods you can use to insert a drawing into a file. You can copy, 
embed, or link a drawing into a Write document. You can link and embed informa­
tion only if the application used to create it supports object linking and embedding. 
Check the application's documentation to find out. 

Method 

Copy 

Embed 

Link 

Description 

You use this method to copy a drawing to a different application, by 
using the Clipboard. Once the drawing is in the new file, you can change 
it only by deleting it and copying a new one in its place. To insert a 
Windows Paintbrush drawing already on the Clipboard, you use the 
Paste Special command on the Edit menu. 

Embedding is similar to copying but with one important difference: 
You can edit an embedded drawing (or object), because you can open 
Paintbrush from within Write. To embed a Paintbrush drawing already 
on the Clipboard, you use the Paste command on the Edit menu. 

Linking dynamically connects two files so that information in one file 
automatically updates when information in the other file changes. To link 
a Paintbrush drawing already on the Clipboard, you use the Paste Link 
command on the Edit menu. Linked drawings are also easily edited from 
within Write. 

When you paste a picture or graph into Write, it always appears at the left margin. 
You can select the picture and move it horizontally or change its size. You can 
also select the picture and cut, copy, or paste it just as you would the text in the 
document. 

Write displays pictures in a screen resolution appropriate for the printer you have 
selected. Because of differences in screen and printer resolutions, pictures may 
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seem slightly distorted on the screen. However, when you print a picture in a 
Write document, the resolution will be correct. 

For more information about object linking and embedding, see Chapter 13, 
"Integrating Your Windows Applications." 

~ To embed a drawing into a Write file 

1. Open the Write document into which you want to embed the drawing. 

2. Place the insertion point at the location you want the drawing to appear. 

3. Switch to Paintbrush. 

4. Create a drawing, or open the file that contains the drawing you want to embed. 

5. If you want to save the drawing, choose Save from the File menu. 

6. Select the drawing using the Pick or Scissors tool. 

7. From the Edit menu, choose Copy. 

A copy of the drawing is placed onto the Clipboard. 

8. Switch to the Write document. 

9. From the Edit menu, choose Paste. 

10. The drawing appears in the Write document. 

For more information about selecting a drawing in Paintbrush, see Chapter 10, 
"Paintbrush. " 

~ To link a drawing to a Write document 

1. Open the Write file that you want to link the drawing to. 

2. Place the insertion point at the location you want the drawing to appear. 

3. Switch to Paintbrush. 

4. Open the file containing the drawing you want to link, or create a new drawing. 

5. If you make any changes to the existing drawing, or create a new one, you need 
to choose Save from the File menu. 

6. Select the drawing using the Pick or Scissors tool. 

7. From the Edit menu, choose Copy. 

A copy of the drawing is placed onto the Clipboard. 

8. Switch to the Write document. 
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9. From the Edit menu, choose Paste Link. 

You now have the original Paintbrush file containing the drawing, and a link to 
it in the Write document. A presentation of the linked drawing appears in the 
Write document. 

10. From the File menu, choose Save. 

Editing Pictures in Write 
To make changes to an embedded or linked drawing, you can start Paintbrush 
from within Write, make your changes, and continue working in your Write 
document. 

For more information about object linking and embedding, see Chapter 13, 
"Integrating Your Windows Applications." 

~ To edit an embedded drawing 

Mouse 

1. In Write, double-click anywhere in the embedded drawing. 

Paintbrush opens, displaying the drawing. 

2. Edit the drawing as needed. 

3. From the File menu, choose Update. 

The embedded drawing is updated to reflect your changes. 

4. From the File menu, choose Exit & Return To (name of document). 

Paintbrush closes. If you forget to update, a dialog box appears, asking if you 
want to update your changes. Choose the Yes button to update. 

Keyboard 

1. In Write, use the arrow keys to move the insertion point to select the embedded 
drawing. 

2. From the Edit menu, choose Edit Paintbrush Picture Object. 

(The Object command changes to reflect the type of object selected.) 

Paintbrush opens, displaying the drawing. 

3. Edit the drawing as needed. 

4. From the File menu, choose Update. 

The embedded drawing is updated to reflect your changes. 

5. From the File menu, choose Exit & Return To (name of document). 

Paintbrush closes. If you forget to update, a dialog box appears, asking if you 
want to update your changes. Choose the Yes button to update. 
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You edit a linked drawing the same way you edit an embedded drawing. 
Remember, though, that any changes you make to a linked drawing appear 
in all the drawings associated with it through links. 

~ To edit a linked drawing 

Mouse 

1. In Write, double-click anywhere in the presentation of the linked drawing. 

Paintbrush opens, displaying the drawing. 

2. Edit the drawing as needed. 

The presentation of the linked drawing is automatically updated to reflect your 
changes if the Update option is set to Automatic. 

3. From the File menu, choose Save. 

4. From the File menu, choose Exit & Return To (name of document). 

Note If you have set the link to update manually, you must update it by 
choosing the Links command on the Edit menu in Write, choosing the Update 
Now button in the Links dialog box, and then choosing the OK button. 

Keyboard 

1. In Write, use the arrow keys to move the insertion point to select the 
presentation of the linked drawing. 

2. From the Edit menu, choose Edit Paintbrush Picture Object. 

(The Object command changes to reflect the type of object selected.) 

Paintbrush opens, displaying the drawing. 

3. Edit the drawing as needed. 

The presentation of the linked drawing is updated to reflect your changes 
automatically if the Update option is set to Automatic. 

4. From the File menu, choose Save. 

5. From the File menu, choose Exit & Return To (name of document). 

Note If you have set the link to update manually, you must update it by 
choosing the Links command on the Edit menu in Write, and then choosing 
the Update Now button in the Links dialog box and the OK button. 
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Moving a Picture 
You can move a picture horizontally in a document by using the Move Picture 
command on the Edit menu. 

~ To move a picture 

1. Click the embedded picture to select it. 

Or use the arrow keys to move the insertion point to select the picture. 

2. From the Edit menu, choose Move Picture. 

A square cursor appears in the center of the picture, and a dotted frame 
surrounds the picture. 

3. Without pressing the mouse button, move the mouse right or left to move 
the dotted frame. 

Or press the RIGHT ARROW or LEFT ARROW key to move the dotted frame. 

To cancel the move, press ESC. 

4. When the frame is where you want it, click the mouse button. 

Or press ENTER. 

If you are not satisfied with the position of your picture, you can choose Undo 
from the Edit menu to return the picture to its original position. 

Tip You can also use the formatting commands (Left, Centered, or Right) on the 
Paragraph menu to move a picture. 

Changing the Size of a Picture 
You can enlarge or reduce a picture in Write by using the Size Picture command 
on the Edit menu. 

~ To change the size of a picture 

1. Click the embedded picture to select it. 

Or use the arrow keys to move the insertion point to select the picture. 

2. From the Edit menu, choose Size Picture. 

A square cursor appears in the center of the picture, and a dotted frame 
surrounds the picture. 
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3. Without pressing the mouse button, move the cursor until it rests halfway 
across the left side, right side, or lower edge of the frame. 

Or press the LEFT ARROW, RIGHT ARROW, or DOWN ARROW key to move the 
cursor. 

To change the length and width of the picture at the same time, move the cursor 
halfway across a lower corner of the frame. 

4. Move the cursor in the direction you want to enlarge or reduce the picture. 

Or press an arrow key to move the cursor. 

To cancel sizing of your picture, press ESC. 

5. When the frame is the size you want, click the mouse button. 

Or press ENTER. 

If you are not satisfied with the size of your picture, you can choose Undo from 
the Edit menu to return the picture to its original size. 

Tip The lower-left corner of the Write window displays sizing information in the 
form of x and y location values. It is best to keep these values as whole numbers 
(for example, 5 rather than 5.5). This will prevent distortion of the picture. 

Breaking a Document into Pages 
When you finish editing your document, you can see where Write proposes to 
break the document into pages for printing. You can have Write break a document 
into pages at any time. 

Breaking Pages Automatically 
When Write automatically breaks your document into pages, it prevents the first 
or last line of a paragraph from being separated from the rest of the paragraph 
by a page break. By breaking a document into pages before printing, you can see 
where automatic page breaks will occur and decide where you might want to insert 
manual page breaks. When you use manual page breaks, Write starts new pages at 
places you designate. 
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By breaking a document into pages before printing, you can also make sure that 
any manual page breaks you have inserted are still in the right place after you edit 
a document. You can choose to confirm or change each page break as Write 
creates it. 

~ To break a document into pages automatically 

1. From the File menu, choose Repaginate. 

The Repaginate Document dialog box appears. 

2. If you want to approve each page break as Write creates it, select the Confirm 
Page Breaks check box. For more information, see "Confirming Page Breaks" 
later in this chapter. 

3. Choose the OK button. 

As Write breaks the document into pages, the page numbers appear in the 
page-status area at the lower-left comer of the window. 

The page breaks that Write automatically assigns to the document look like the 
arrows in the following illustration. 

Eile .Edit Fin.d !;.haracter Earagraph Qocument .!::J.elp 

buyer want to purchase quickly and at a better price. Here are some 
tested tips to set the stage for a profitable and early sale. 

Fix up inside. Badly faded walls or worn woodwork reduce appeal. 
Selective painting will help you add a fresh look. Clean windows and 
unmarred walls will create a bright, cheery appearance. 

~ 

I
~ake minor repairs. Dripping faucets call attention to faulty plumbing. 

ou should make sure all plumbing is in good working order. If you can, 
y should hang your best towels and make sure that the towels, shower 
curt ·n, and floor rugs are color coordinated . 
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~ These arrows indicate the 
first new line of each page. 
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Breaking Pages Manually 
If you know you want a page to end or begin at a certain place, you can insert a 
manual page break at any time. 

~ To insert a manual page break 

1. Position the insertion point where you want the page break to occur. 

2. Press CTRL+ENTER. 

A dotted line appears in the document to show where you inserted the page 
break. 

Automatic page break 
Manual page break 

se quickly and at a better price. Here are some 
the stage for a profitable and early sale. 

Fix up inside. Badly faded walls or worn woodwork reduce appeal. 
Selective painting will help you add a fresh look. Clean windows and 
unmarred walls will create a bright, cheery appearance. 

Make minor repairs. Dripping faucets call attention to faulty plumbing. 
You should make sure all plumbing is in good working order. If you can, 
you should hang your best towels and make sure that the towels, shower 
curtain, and floor rugs are color coordinated. 

Manual page breaks can be selected, deleted, or copied like any other character in 
a document. 

Confirming Page Breaks 
If you select the Confirm Page Breaks check box in the Repaginate Document 
dialog box, Write pauses at each page break that it proposes to insert and at any 
page breaks that you inserted manually. The following dialog box appears every 
time Write pauses at a page break that it proposes to insert. 



Write proposes to break the page here. 

II I~I""C.)U"UII Y faded walls or worn woodwork reduce appeal. 
will help you add a fresh look. Clean windows and 

urlrrlCHf~I~fi'lCllIs will create a bright, cheery appearance. 

or repairs. Dripping faucets call attention to faulty plumbing. 
ould make sure all plumbing is in good working order. If you can, 
ould hang your best towels and make sure that the towels, shower 
and floor rugs are color coordinated. 

I 
Bedrooms are an important focal point. You will find it worth the effort 
to keep them neatly 

First impressions are 
edged, cultivate flower I:IrlfgJU!II HI.IIP' 
yard, sidewalk, and po 
You should pay special liUi'l{Ip,iH .• lililililmi!,,1 
for sale. Shining ovens:, ~~~m~jtm~~~~~m=r"""'~ 
eye and make a good in 

You can confirm the 
page break or move it. 

Chapter 9 Write 307 

You can move an automatic page break up from where Write proposes to put it, 
but you cannot move it down. The Down button in the dialog box allows you to 
move the page break down only if you previously moved it up. You move to the 
next page break by choosing the Confirm button. 

Each time Write pauses at a manual page break, it displays another dialog box so 
that you can confirm or remove the manual break. 

Formatting Your Document 
When you format your Write document, you determine how you want the 
document to look. You can determine the appearance of characters throughout 
the document, the spacing and alignment of lines in each paragraph, and the page 
layout for the entire document. Most of the formats you choose look the same on 
your screen as in the printed document. 
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Formatting Characters 
The commands on the Character menu control how you format the characters in 
your document. You can format characters by: 

• U sing different character styles, such as bold, italic, and underline. 

• Creating superscripts and subscripts. 

• Using different fonts and point sizes. 

Choosing a command from the Character menu affects text that is currently 
selected or text that you are about to type. A new paragraph will have the same 
character formatting as the previous paragraph. 

If possible, Write displays the same fonts and sizes on the screen that you will 
see when you print your document. If Write cannot match the selected font, it 
substitutes a font that resembles the selected font as closely as possible. Whenever 
Write uses a substitute screen font, it still uses the correct line and page breaks. 

Write saves character formats when you save your document. Write also transfers 
character formats when you move or copy formatted text to other parts of the same 
document or to another Write document. 

Applying Character Styles 
Character styles add emphasis to text by making it bold, italic, or underlined. You 
can apply more than one style to the same characters. 

~ To format existing text in bold, italic, or underline 

1. Select the text you want to format. 

2. From the Character menu, choose the style you want to use. 

A check mark appears next to the style on the menu. 

The selected text changes to the style you chose. 

~ To format text that you are about to type in bold, italic, or underline 

1. From the Character menu, choose the style you want to use. 

A check mark appears next to the style on the menu. 

2. Type your text. 

The text appears in the style you chose. 
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~ To cancel a character style 

1. Select the text for which you want to cancel the character style. 

2. From the Character menu, choose the style (except for Regular). 

The check mark next to the style on the menu disappears. 

The style is removed from the selected text. 

~ To cancel all character styles 

1. Select the text whose styles you want to cancel. 

2. From the Character menu, choose Regular. 

A check mark appears next to the Regular command. 

All styles are removed from the selected text. 

~ To format an entire document with a single character style 

1. Select the entire document. 

2. In the Character menu, choose Fonts. 

The Fonts dialog box opens. 

3. In the Font Style box, select the style you want or type the name of the style. 
If there is more than one style included in the selected text, then the text box is 
left blank. 

If you select Regular, all existing styles are removed. 

Note If you have selected text before choosing the Fonts command and if there 
are any formats already in this text, the existing formats and fonts are replaced 
by the selections you make in the Font Style box. If you don't change a selec­
tion, then this format remains unchanged. For example, if you change the font 
style but not the size, then the current size remains but all font styles in the 
selected text are overwritten. 

4. Choose the OK button. 
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Using Fonts 

Creating Superscripts and Subscripts 
Superscript and subscript characters appear slightly above or below other text. 
They are also scaled to a smaller size. 

/ Subscript 
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~ To format text as superscript or subscript 

1. Select the text you want to format as superscript or subscript. 

2. From the Character menu, choose Superscript or Subscript. 

Write resizes and repositions the text you selected. 

A/ont, or typeface, is a graphic design applied to all text, numerals, and other 
characters. If possible, Write displays the same fonts and sizes on the screen that 
you will see when you print your document. If Write cannot, it substitutes a font 
that resembles the selected font as closely as possible. Whenever Write uses a 
substitute screen font, it still uses the correct line and page breaks. 

The currently selected printer determines the fonts that are available. If you plan to 
print the document on a printer other than the selected one, you must set up the 
other printer by using either Windows Control Panel or the Print Setup command 
on the File menu. Then you can use that printer's fonts for text in your document. 
For more information about fonts and the default printer, see Chapter 6, "Print 
Manager." 

Changing Fonts and Font Sizes 
When you start typing text in a new document, Write uses the standard font for the 
default printer. If you want to use a different font, you can choose one of the font 
names displayed in the Fonts dialog box. 
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~ To change a font or font size by using the Fonts command 

1. From the Character menu, choose Fonts. 

The Fonts dialog box appears. 

2. In the Fonts box, select the name of the font you want to use. 

Or type the name of the font in the Font Name box. 

3. In the Font Style box, choose whether you want the text to appear as regular, 
bold, bold italic, or italic. 

Or type the new font style in the Font Style box. 

Note If you have selected text before choosing the Fonts command and if 
there are any formats already in this text, the existing formats and fonts are 
replaced by the selections you make in the Font Style box. If you don't change 
a selection, then this format remains unchanged. For example, if you change the 
font style but not the size, then the current size remains but all font styles in the 
selected text are overwritten. 

4. In the Size box, select a size for the font. 

Or type the new size. 

5. Choose the OK button. 

If you choose a font size that cannot be printed on the default printer, Write 
does not change the size of text on the screen. 

As you select a new font, a sample of that font appears in the Sample box. When 
certain fonts are selected, the phrase "This is a scalable TrueType font" appears 
bel my the box. This means that the font you have selected is scalable to any point 
size and that what you see on the screen is exactly what the printer will print. 

~ To change the font size by using the Character menu 

• From the Character menu, choose Reduce Font or Enlarge Font. 

When you choose the Reduce Font or Enlarge Font command, Write changes 
the font size to the next smaller or larger size. The sizes are determined by Write, 
independent of the default printer. If you choose Reduce Font or Enlarge Font and 
the default printer does not support the next smaller or larger size, the text you 
type does not change size on the screen. 

If you want to change the font or font size for text that is already typed, you must 
select the text before you choose the new font or size. 

TrueType fonts scale more smoothly than other fonts across the entire range of 
sizes available in Write. 
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Formatting Paragraphs 
The format of a paragraph includes the alignment, spacing, and indentation of the 
lines in the paragraph. A new paragraph starts out with the same format as the 
previous paragraph. For example, if you are typing a paragraph that is double­
spaced and you press ENTER to start a new paragraph, the text you type in the 
new paragraph will also be double-spaced. 

You can use either the Ruler or the commands on the Paragraph menu to change 
the format in each paragraph of a document. Before choosing a command from 
the Paragraph menu, position the insertion point inside the paragraph you want to 
format. If you want to format more than one paragraph at the same time, select a 
portion of all the paragraphs you want to format. 

When you copy or move a paragraph, include the paragraph mark in the selection 
to keep the paragraph formats with the paragraph. 

Displaying the Ruler 
If you have a mouse, you can change paragraph formats by using the Ruler. 

~ To display the Ruler 

• From the Document menu, choose Ruler On. 

The Ruler appears at the top of the Write window. 

Left indent marker (with first line -

/ indent marker on top) 
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You can set a different unit of measure on the Ruler by choosing the Page 
Layout command from the Document menu in Write. For more information, 
see "Changing the Page Layout" later in this chapter. 
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~ To hide the Ruler 

• From the Document menu, choose Ruler Off. 

The following sections explain the different ways in which you can format your 
paragraphs. They also explain how to use the Ruler to create each format. 

Adding and Removing Paragraph Marks 
A paragraph mark is not a visible character in a document, but it marks the end of 
a paragraph or a blank line. 

~ To add a paragraph mark 

1. Press ENTER after typing the last character in a paragraph. 

2. If you want a blank line between paragraphs, press ENTER again. 

Although there is no visible character for the paragraph mark, you can select, 
delete, copy, and move a paragraph mark just as you do other characters. You 
can select individual paragraph marks, as shown in the following illustration. 

Eile .Edit Find !;.haracter Earagraph Qocument Help 

You can understand that showing a home to its best advantage makes the 
buyer want to purchase quickly and at a beller price. Here are some 
tested tips to set the stage for a profitable and early sale.1 
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Or you can select both text and paragraph marks. 
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~ To remove a paragraph mark 

1. Place the insertion point at the beginning of the paragraph that follows the mark 
you want to remove. 

2. Press BACKSPACE. 

If your paragraphs have a blank line between them, press BACKSPACE twice. 

Changing Paragraph Alignment 
You can align a paragraph in any of the following ways: 

• At the left margin 

• At the right margin 

• Justified between both margins 

• Centered between both margins 

~ To change paragraph alignment 

1. Place the insertion point inside the paragraph you want to change. 

2. From the Paragraph menu, choose the alignment command you want to use. 

Write realigns the paragraph according to the command you chose. 

~ To change paragraph alignment by using the Ruler 

1. Place the insertion point inside the paragraph you want to change. 

2. To the right above the Ruler, click the appropriate paragraph-alignment icon. 

Changing Paragraph line Spacing 
You can change the line spacing in a paragraph to single-spacing, one-and-one­
half-line spacing, or double-spacing. 

~ To change line spacing 

1. Place the insertion point inside the paragraph you want to change. 

2. From the Paragraph menu, choose a line-spacing command. 

The line spacing in the selected paragraph changes to reflect your choice. 
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~ To change line spacing by using the Ruler 

1. Place the insertion point inside the paragraph you want to change. 

2. In the center above the Ruler, click the appropriate line-spacing icon. 

Changing the Indentation of a Paragraph 
When you first type a paragraph into Write, the text fills the area between the 
left and right margins. You can indent an entire paragraph from the left or right 
margin, or you can indent just the first line of a paragraph from the left margin. 

Indenting the lines of a paragraph differs from changing the left or right margins 
for a paragraph. Write indents paragraph lines from the current margin setting. 
You should set the margins that you want to use for your paper size first (or use 
the standard settings provided by Write), and then indent the paragraphs of your 
document. For more information about margins, see "Changing the Page Layout" 
later in this chapter. 

Note You can also indent pictures or any other embedded information in a 
Write file. 

~ To change the indentation of a paragraph 

1. Place the insertion point inside the paragraph you want to change. 

2. From the Paragraph menu, choose Indents. 

The Indents dialog box appears. 

[ilst line: 

Right Indent: 
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3. Type a measurement for any indentation you want to change. 

The measurement can be in inches or centimeters, depending on the 
Measurements setting in the Page Layout dialog box. For more infor­
mation, see "Changing the Page Layout" later in this chapter. 

4. Choose the OK button. 
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~ To change the indentation of a paragraph by using the Ruler 

1. Place the insertion point inside the paragraph you want to change. 

2. On the Ruler, drag the appropriate indent marker to a new position. 

file Edit 

First-line indent marker 

Left indent marker 

Right indent 
marker 

The indents you create by using the Ruler are reflected in the Indents dialog 
box. 

Creating a Hanging Indent You can also use the Indents command to create a 
hanging indent. In a paragraph with a hanging indent, the first line extends farther 
to the left than the rest of the paragraph, as in a numbered or bulleted list. Another 
example of a hanging indent appears in the following illustration. 

Hanging indent 

Fix up inside. 

Make minor repairs. 

Badlyfaded walls orworn woodwork 
reduce the appeal. Selective painting 
adds a fresh look. 

Dripping faucets call attention to 
faulty plumbing. Make sure all 
plumbing is in good working order. 
If you can correct small items, critical 
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~ To create a hanging indent 

1. Place the insertion point inside the paragraph you want to format. 

2. From the Paragraph menu, choose Indents. 

3. In the Left Indent box, type a positive number to set the indentation for the 
entire paragraph. 

4. In the First Line box, type a negative number to set the indentation for the first 
line. The amount you are indenting must be less than or equal to the amount of 
the left indent. For example, if your left indent is 10, your first-line indent 
should be between -1 and -10. 

Both measurements can be in inches or centimeters, depending on the 
Measurements setting in the Page Layout dialog box. For more information, 
see "Changing the Page Layout" later in this chapter. 

5. Choose the OK button. 

The selected paragraph is reformatted according to the measurements you typed. 

Formatting a Whole Document 
When you start a new document, it is automatically formatted to look like the 
document in the following illustration. 
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You can change these settings at any time as you work in your document. The 
commands on the Document menu affect the document as a whole and apply to 
the following parts of a document: 

• A header is text that appears at the top of every page. The default position of 
the header is .75 inch from the top of the page at the left margin. 

• Afooter is text that appears at the bottom of every page. The default position 
of the footer is .75 inch from the bottom of the page at the left margin. 

• Text is single-spaced by default, and aligned at the left margin without any 
indentations. 

• The standard margins are preset at 1 inch of space at the top and bottom of the 
document and 1.25 inches at the left and right edges. 

For information about changing page-layout settings, see "Changing the Page 
Layout" later in this chapter. 

Using Headers and Footers 
You can have one header and one footer in each Write document. Using the 
Header or Footer commands, you can: 

• Type the text you want to use as a header or footer. 

• Include page numbers in the printed document. 

• Start the header or footer on the first or second page of the document. 

• Change the distance between the header or footer and the top or bottom of 
the page. 

~ To add a header or footer 

1. From the Document menu, choose Header or Footer. 

A blank Header or Footer document window and the Page Header or Page 
Footer dialog box appear. 
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Header document window Page Header dialog box 

2. In the blank Header or Footer window, type the text you want. 

You can format the text as you would any other text. For example, if you want 
to center the text, choose Centered from the Paragraph menu before or after you 
type the text. 

If you make a mistake, you can press BACKSPACE to correct the last few 
characters typed, or you can choose the Clear button in the Page Header or 
Page Footer dialog box to delete all the text in the Header or Footer window 
and start over. 

3. Click the Page Header or Page Footer dialog box. 

Or press ALT+F6 to select the dialog box. 

4. If you want to change the distance between the header or footer and the edge 
of the page, type a measurement in the Distance From Top or Distance From 
Bottom box. 

The measurement can be in inches or centimeters, depending on the 
Measurements setting in the Page Layout dialog box. For more infor­
mation, see "Changing the Page Layout" later in this chapter. 

5. If you want the header or footer to appear on the first page of the printed 
document, select the Print On First Page check box. 

Otherwise, the header or footer starts on the second page. 
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6. Choose the Insert Page # button to print page numbers in the document. For 
more information about using page numbers, see the procedure that follows. 

7. When you finish setting up your header or footer, choose the Return To 
Document button. 

Or press ESC to return to your document. 

When you print your document, you will see the headers and footers. They do not 
appear on the screen. 

Note If the header, footer, or margins are too close to the edge of the page, the 
printer may not print them. If this happens, try moving them farther away from 
the edge. 

~ To use page numbers in headers or footers 

1. From the Document menu, choose Header or Footer, depending on where you 
want your page numbers to appear. 

2. In the Header or Footer window, type any text that you want included with the 
page number. 

3. Move the insertion point to where you want the page number to appear on the 
line. (Choose the Centered or Right command from the Paragraph menu to 
quickly center or right-align the header or footer.) 

4. Click the Page Header or Page Footer dialog box. 

Or press ALT+P6 to select the dialog box. 

5. Choose the Insert Page # button. 

Choosing this button inserts (page) in the Header or Footer window at the 
location of the insertion point. 

6. If you want a page number to appear on the first page of the printed document, 
select the Print On First Page check box. 

If you want your first page to be a cover page without a number, do not select 
the Print On First Page check box. 

7. Choose the Return To Document button. 

Or press ESC. 

When you print your document, consecutive page numbers appear on the printed 
pages. 

Setting Tabs 
Write has tabs preset at every half inch. You can use these preset tabs to create a 
column of items aligned to the left. Preset tabs do not appear in the Tabs dialog 
box or on the Ruler. 
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You can easily set your own tabs for lists or tables by using the Tabs command on 
the Document menu or by using the Ruler. Tabs that you set override the preset 
tabs. You can set up to 12 tabs-either left-aligned tabs or decimal tabs. Decimal 
tabs let you create a column of numbers that line up on their decimal points. 

~ To set tabs 

1. From the Document menu, choose Tabs. 

The Tabs dialog box appears. 

Type a measurement here 
for a tab you want to set. 

J2ecimal: 

~ositions: 

J2ecimal: 

2. Click a position box. 

Select this box to 
create a decimal tab. 

Or press TAB to move to a position box. 

3. Type a measurement. 

This will be the location of the tab stop from the left margin. The number can 
be in inches or centimeters, depending on the Measurements setting in the Page 
Layout dialog box. For more information about the Measurements setting, see 
"Changing the Page Layout" later in this chapter. 

4. If you want a decimal tab, select the Decimal check box below the 
measurement you type. 

5. Choose the OK button. 

The tabs you set in the Tabs dialog box also appear on the Ruler. 

Tip When you type text at a decimal tab stop, the characters you type are inserted 
to the left of the tab stop until you type a decimal point. The decimal point is 
inserted at the tab stop, and any additional characters you type are inserted to the 
right of the decimal point. You can use a decimal tab to line up text to the right, as 
long as you do not use more than one period in the text. 
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~ To delete a tab 

1. From the Document menu, choose Tabs. 

The Tabs dialog box appears. 

2. Select the position box for the tab you want to delete. 

3. Pres DEL or BACKSPACE. 

To delete all tabs at once, choose the Clear All button. 

~ To set tabs by using the Ruler 

1. To the left above the Ruler, click the appropriate tab icon. 

Boron 
Barium 
Beryllium 
Bismuth 

Left-aligned tab icon 
Decimal tab icon 

Decimal tab marker 
Left-aligned tab marker 

2. Click the Ruler where you want to set the tab. 

You can also drag an existing tab marker to a new position. 

The tabs you set by using the Ruler appear in the Tabs dialog box. 

~ To delete a tab by using the Ruler 

• Drag the tab marker off the Ruler. 
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Changing the Page Layout 
When printing a document, Write is preset to: 

• Use inches in measurements. 

• Use I-inch top and bottom margins. 

• Use 1.25-inch side margins. 

• Number the first page as page 1. 

You can use the Page Layout command on the Document menu to change these 
settings. 

~ To change the page-layout settings for a document 

1. From the Document menu, choose Page Layout. 

The Page Layout dialog box appears. 
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2. If you want to start numbering your document with a page number other 
than 1, type the number you want in the Start Page Numbers At box. 

This number appears on the first page of your document if you have a page 
number in your header or footer. For information, see "Using Headers and 
Footers" earlier in this chapter. 

3. In the Margins boxes, type the measurements you want for the margins. 

4. If you want to use metric measurements, select the Cm option button. 

You can also change this setting by using Control Panel. For more information, 
see Chapter 5, "Control Panel." 

5. Choose the OK button. 

If you enter a starting page number, Write adjusts the page numbers displayed in 
the lower-left comer of the window. Write also uses the adjusted page numbers for 
the Go To Page command on the Find menu. 
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Managing Write Files 
Working with Write files is much the same as working with any other Windows 
file. For information about opening and saving Windows files, see Chapter 2, 
"Application Basics." For information about managing Windows files, see 
Chapter 4, "File Manager." 

The maximum size of a Write file is limited only by the amount of memory in 
your computer. Windows assigns the extension .WRI to a document you create 
by using Write and saves the document as a Write file. If you prefer, you can 
choose to save your document in one of several other formats. You can also open 
and work with files that were not created by using Write. The following sections 
discuss these topics. 

Opening a Microsoft Word Document 
If you want to use Write to work with a Microsoft Word document, you must 
first convert the Word document to the Write format. 

When you open a Word document from Write, the Write dialog box appears, 
asking whether you want to convert the text to the Microsoft Write format. 

Caution Be sure you back up a file before you convert it. 

~ To convert a Word document to Write format 

• In the Write dialog box, choose the Convert button. 

Opening a Windows Data File 
Most data files (also called text files) created by using Windows applications are in 
the same format used for Write files. When you choose to open a Windows data 
file in Write, the Write dialog box appears, but you do not need to convert 
Windows data files. 

~ To avoid converting a Windows data file 

• In the Write dialog box, choose the No Conversion button. 

Tip If you make a mistake in selecting Convert or No Conversion, choose New 
from the File menu and choose the No button when asked if you want to save any 
changes. Your file will be left in its original state. Then reopen the file. 
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Opening a Non-Windows Data File 
Most data files (text files) created outside Windows are not created using the 
Windows character format. You must convert these files to Write format. 

When you choose to open a non-Windows data file from Write, the Write dialog 
box appears. 

~ To convert a non-Windows data file to Write format 

• In the Write dialog box, choose the Convert button. 

Caution Be sure you back up a file before you convert it to the Write format. 
Write cannot convert certain MS-DOS or Windows application files. 

In addition, do not convert any files that are not purely text files. In binary files, 
ASCII characters above 127 might be related to the program that created the file 
and, therefore, mayor may not be converted. Other files may contain control 
characters that should not be converted. 

Saving a Document 
When you are working with a Write document-especially a large document­
you should save your document often. Doing so helps Write perform faster and 
minimizes lost work if there is a power failure. 

You have five possible formatting choices when you save a Write document. 

Use 

Write Files (. WRI) 

3.0 Write (.WRI) 

Word for MS-DOS (.DOC) 

Word for MS-DOS/Text Only 

Text Files (. TXT) 

To save your document as 

A Write-formatted document. When you first save 
the file, Write assigns the extension. WRI to the 
filename. 

A file that is compatible with Windows version 3.0. 
This option appears only if you have an embedded 
or linked object in the Write file you are saving. This 
option deletes any embedded or linked objects in the 
file. Static objects remain unchanged. 

A Microsoft Word document. Do not use this format 
if you have any pictures in your document, because 
they will disappear. This format does not work for 
Microsoft Word for Windows documents. 

An unformatted Microsoft Word data file. 

A Windows-format data file. You might want to use 
this option if your document is a program or will 
be telecommunicated. For more information, see 
Chapter 11, "Terminal." 
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Making a Backup Copy 
You can specify that Write automatically make a backup copy of a file when you 
save the file. 

~ To make a backup copy 

• In the Save As dialog box, select the Backup check box. 

Thereafter, Write makes a backup copy each time you save an edited document. 

If you save your document as a Write file, Write assigns the backup copy the 
filename extension .BKP. If you save your document as a Microsoft Word file, 
Write assigns the backup copy the extension .BAK. 

If, before making a backup, you delete the extension from the filename of a Write 
document and save the document in Microsoft Word format, the document and its 
backup are given the extensions .DOC for the document now in Word format and 
.WRI for the backup copy. The backup is the original version of the document in 
Write format. 

Similarly, if you delete the extension of the filename from an existing Word 
document and save it in Write format, the document and its backup are given the 
extensions .WRI for the document now in Write format and .DOC for the backup 
copy. The backup is the original version of the document in Word format. 

Printing a Document 
If you have connected and installed a printer, you can print your Write documents. 
For information about installing a printer, see Chapter 6, "Print Manager." 

~ To print a document 

1. Make sure the document is displayed in the Write window. 

2. From the File menu, choose Print. 

The Print dialog box appears. 
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3. Select the options you want to use. (For more information about these options, 
see the table following this procedure.) 

4. Choose the OK button. 

A dialog box appears, telling you that Write is printing your document. 

You can use the options in the Print dialog box to perform the following tasks. 

Use 

All 

Selection 

Pages: From/To 

Print Quality 

Print To File 

Copies 

Collate Copies 

To 

Print all the pages in your document. This is the default setting. 

Print only the selected text in the document. 

Print a range of pages. After you select this option, type page 
numbers in the From and To boxes. 

Change the quality of graphic images in the file. The change varies 
from printer to printer. If Print Quality is dimmed, this option is 
not available for the selected printer. 

Save the file to another file containing commands that can be sent 
to the printer from MS-DOS. You will be prompted for a filename 
after you choose the OK button to close the Print dialog box. 

Specify the number of copies you want to print. The default setting 
is 1. 

Separate each document page when printing more than one copy 
(if your printer supports this feature). 

When printing, Write uses the margins specified in the Page Layout dialog box. 
If you want to position your document differently on the page, you can use the 
Page Layout command on the Document menu to change these settings. For more 
information, see "Changing the Page Layout" earlier in this chapter. 
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Changing Printers and Printer Option Settings 
Write prints your documents on the default printer. If you want to use another 
installed printer, choose the Print Setup command from the File menu. 

~ To change printers 

1. From the File menu, choose Print Setup. 

The Print Setup dialog box appears. 

2. In the Printer box, select the Default Printer or Specific Printer option. 

If you select Specific Printer, select the printer you want to use from the list. 

3. Change the Orientation and Paper specifications as needed. 

To display options specific to your printer driver, choose the Options button. 
(For more information about setting printer options, see Chapter 6, "Print 
Manager.") 

4. Choose the OK button. 

Write now prints to the newly selected printer unless you specify otherwise. 

Note When you change printers, the appearance of your document may change on 
the screen. This is because Write applies the fonts and character formats available 
with the default printer. These changes may affect the line breaks and page breaks 
in the document. Use the Repaginate command to see the new page breaks. For 
more information, see "Breaking a Document into Pages" earlier in this chapter. 
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Working with Paintbrush 
By using Windows Paintbrush, you can create simple or elaborate color drawings. 

Unlike the other accessories for the Microsoft Windows operating system, 
Paintbrush makes use of both mouse buttons. When you need to use the right 
mouse button, the instructions in this chapter specify that button. If no button is 
specified, you should use the left mouse button-the one most commonly used. 

In Paintbrush, you will probably find that it is much easier to create your drawings 
by using a mouse. For this reason, the instructions in this chapter are directed 
toward mouse users. If you do not have a mouse or prefer using the keyboard, use 
the following keys when the instructions tell you to click, double-click, or press a 
mouse button. 

Press 

INS 

DEL 

F9+INS 

F9+DEL 

INS + an arrow key 

If instructions say to 

Click or press the left mouse button. 

Click or press the right mouse button. 

Double-click using the left mouse button. 

Double-click using the right mouse button. 

Drag the cursor. 

For more information about using the keyboard, see "Moving Around in a Large 
Drawing" later in this chapter. 
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~ To start Paintbrush 

• In the Accessories group, choose the Paintbrush icon. (Double-click the icon. 
Or use the arrow keys to move the selection cursor to the icon, and then press 
ENTER.) 

Toolbox Drawing area 

In the Paintbrush window, you see the following items: 

• The drawing area is where you create your Paintbrush drawings. The size of 
the drawing area varies depending on your display adapter. If you do not have 
enough memory available to create a drawing equal to the size of this drawing 
area, a small drawing area appears in the upper-left corner of the Paintbrush 
window. You need to free some of your computer's memory before Paintbrush 
can create the larger drawing area. 

You can also override this default drawing-area size by using the Image 
Attributes command on the Options menu. For more information, see the 
following section, "Determining the Size of Your Drawing Area." 
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• The cursor indicates where a line or other object appears when you start 
drawing in the drawing area, or what you are pointing to outside the drawing 
area. The cursor moves as you move your mouse (or press TAB or an arrow 
key). Inside the drawing area, the cursor's shape changes depending on which 
tool you are using. Outside the drawing area, the cursor always appears as an 
arrow. 

• The Toolbox contains the tools that you use to create your drawing. The tools 
allow you to draw, fill, airbrush, erase, type text, and select the items in the 
drawing area. 

• The Palette contains the colors and patterns available for use in the background 
of the drawing area and with the drawing tools. 

• The Linesize box contains the available drawing widths. 

Tip If you are using the keyboard, use TAB and SHIFT+TAB to move between the 
different areas of the Paintbrush window. 

Determining the Size of Your Drawing Area 
The first time you start Paintbrush, it establishes a default size for a drawing area 
based on your type of display adapter and the amount of memory available. If 
you want to create a drawing that is larger or smaller than the size established by 
Paintbrush, you can change the default drawing size. 

~ To change the default drawing size 

1. From the Options menu, choose Image Attributes. 

The Image Attributes dialog box appears. 
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2. In the Width and Height boxes, type the new measurements you want to use 
for your drawing. 

If necessary, make changes to the other options in the dialog box. For infor­
mation about these options, see the table that follows this procedure. 
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3. Choose the OK button. 

4. Paintbrush displays a message asking if you want to start a new drawing using 
the new settings. Choose the Yes button to do so. 

Each time you start Paintbrush now, it uses the new settings. 

Tip To start a new Paintbrush drawing quickly, double-click the Eraser tool in the 
Toolbox. (Or move the cursor to the Eraser tool, and then press F9+INS.) For more 
information about using the Eraser tool, see "The Eraser" later in this chapter. 

The settings in the Image Attributes dialog box are used in the following ways. 

Use 

Width 

Height 

Units 

Colors 

Default button 

To 

Change the width of the drawing you want to create. 

Change the height of the drawing you want to create. 

Select the unit of measurement you want to use when you specify 
the width and height of your drawing. The default setting is inches 
(in). You can also choose to work with centimeters (cm) or picture 
elements (pels, also known as pixels)-the smallest unit on the 
screen. 

Choose whether you want to work in color or black and white. 

Return the drawing area to the original size established by 
Paintbrush to accommodate your display adapter. 

The Default button does not affect the colors or units you have 
specified. 

Note You should keep in mind that the larger the drawing and the more colors 
you use, the more memory is required. If you plan to print your drawing at printer 
resolution, be sure that you specify the correct dimensions (in pels) for the printed 
drawing in the Image Attributes dialog box. Also, be sure that the dimensions you 
specify are in proportion to the current screen dimensions of the drawing. Because 
printing at printer resolution requires more memory, you cannot print as large a 
drawing as you can at screen resolution. For more information about printing, see 
"Printing a Drawing" later in this chapter. 

Enlarging the Drawing Area 
You can remove the Toolbox, Linesize box, and Palette from the Paintbrush 
window to increase the size of the drawing area. You will still be able to use the 
selected tool, drawing width, and color, in addition to the menu commands. 
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~ To remove the Toolbox and Linesize box from the drawing area 

• From the View menu, choose Tools And Linesize. 

The Toolbox and Linesize box disappear from the Paintbrush window, and the 
check mark next to the Tools And Linesize command also disappears. 

To return the Toolbox and Linesize box to the window, choose the command 
again. 

~ To remove the Palette from the drawing area 

• From the View menu, choose Palette. 

The Palette disappears from the Paintbrush window, and the check mark next to 
the Palette command also disappears. 

To return the Palette to the window, choose the command again. 

Moving Around in a Large Drawing 
If you create a drawing that is larger than the size of the drawing area, you can use 
the scroll bars to move around in the drawing. If you are using the keyboard, the 
following keys are available for moving around in the drawing. 

Press 

TAB 

SHIFT+TAB 

An arrow key 

HOME 

END 

PAGE UP 

PAGE DOWN 

SHIFT+UPARROW 

SHIFT +DOWN ARROW 

SHIFT+HOME 

SHIFT+END 

SHIFT+PAGE UP 

SHIFT +PAGE DOWN 

SHIFT +LEFT ARROW 

SHIFT+RIGHT ARROW 

To move 

Among the Toolbox, Linesize box, Palette, and drawing area, 
counterclockwise. 

Among the Toolbox, Linesize box, Palette, and drawing area, 
clockwise. 

Around the drawing area. 

To the top of the drawing area. 

To the bottom of the drawing area. 

Up one screen. 

Down one screen. 

Up one line (about 10 pels). 

Down one line (about 10 pels). 

To the left edge of the drawing area. 

To the right edge of the drawing area. 

Left one screen. 

Right one screen. 

To the left one space (about 10 pels). 

To the right one space (about 10 pels). 
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Viewing Your Drawing 
To see more of your drawing, you can remove everything from the screen except 
your drawing. You can also compact a large drawing so that all of it fits inside the 
drawing area. 

Viewing a Picture in a Full Screen 
The View Picture command on the View menu displays as much of your drawing 
as fits on the entire screen, by removing everything but your drawing from the 
screen. Because the menus, Toolbox, Palette, Linesize box, and even the cursor 
disappear when you choose View Picture, you cannot edit your drawing in any 
way. 

~ To use the entire screen to display your drawing 

• From the View menu, choose View Picture. 

Or press CTRL+P. 

Tip To clear the entire screen quickly of everything except your drawing, double­
click the Pick cutout tool in the Toolbox. Or move the cursor to the Pick tool, and 
then press F9+INS. 

~ To cancel the View Picture command 

• Click anywhere on the screen. 

Or press any key. 

The screen returns to its previous state. 

Zooming Out 
If you create a drawing that is larger than the drawing area and the entire screen, it 
is still possible to see all of the drawing on the screen at one time. 

~ To display all of a drawing that is larger than the drawing area 

• From the View menu, choose Zoom Out. 

Or press CTRL+O. 

The drawing shrinks to fit into the drawing area. 

While using the Zoom Out command, you can cut, copy, and paste parts of your 
drawing called cutouts. You create a cutout by using either the Pick or Scissors 
tool (for more information, see "The Cutout Tools" and "Editing Your Drawing" 
later in this chapter). You cannot, however, add anything new to a drawing in 
zoom-out mode by using the drawing tools. 
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~ To cancel the Zoom Out command 

• From the View menu, choose Zoom In. 

Or press ESC. 

The drawing returns to normal resolution size. 

When you use Zoom Out to view a drawing, you might lose some of the line 
detail in the drawing. Generally, the larger the size of your original, the greater 
the amount of line detail you lose when Paintbrush shrinks the drawing. You see 
this loss of detail only in the compacted version of the drawing. It does not affect 
your full-size drawing. 

For more information about the Zoom In command, see "Editing by Using the 
Zoom In Command" later in this chapter. 

Creating a Simple Drawing 
The procedure for creating a simple drawing involves the following steps: 

• Selecting a background color 

• Selecting a foreground color 

• Selecting a drawing width 

• Selecting a drawing tool 

• Drawing your picture 

• Editing your picture 

The following topics describe each of these steps. 

Selecting Background and Foreground Colors 
One of the first things to decide when you create a drawing is what color you 
want to use for the background and what color you want to start drawing with 
(the foreground color). You select your colors from the Palette. 

Note You can change from color to black-and-white patterns by choosing the 
Image Attributes command from the Options menu. Once you have begun a 
drawing in color or in black and white, however, you must stay with that selection. 

You can change the foreground and background colors at any time while creating 
a drawing and, by doing so, create special effects with tools and commands that 
use the background color to draw. For example, you can create shadows around 
different pieces of text in a drawing. 
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You can change the background color for an entire drawing only by choosing the 
color, and then choosing the New command from the File menu to start a new 
drawing. 

r ~~:ected Colors box shows the 
~ors that are currently selected. 

When you start Paintbrush, the selected background color is white and the selected 
foreground color is black. 

~ To select a different background color or pattern 

• In the Palette, point to the color or pattern you want, and then click it using the 
right mouse button. 

Or press TAB to move to the Palette, use the arrow keys to move the cursor to 
the color, and then press DEL. 

The Selected Colors box shows the color you selected. 

If you now choose New from the File menu, Paintbrush opens a new document 
with the newly selected background color or pattern in the drawing area. 

~ To select a different foreground color or pattern 

• In the Palette, point to the color or pattern you want, and then click it using the 
left mouse button. 

Or press TAB to move to the Palette, use the arrow keys to move the cursor to 
the color, and then press INS. 

The Selected Colors box shows the color you selected. 
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Selecting a Drawing Width 
The Linesize box in the lower-left comer of the Paintbrush window displays the 
available drawing widths. The top line represents a width of one pel (pixel). 

L An arrow marks [i the selected width. 

The drawing width determines either the width of a line you draw or the width 
of the border around an object you draw, such as a filled box. You might want to 
experiment with the way different drawing widths work with different tools so that 
you can use the tools most effectively. 

~ To change the width of the drawing line 

• In the Linesize box, point to the width you want, and then click it. 

Or press TAB to move to the Linesize box, use the arrow keys to move the 
cursor to the drawing width, and then press INS. 

An arrow appears next to the drawing width you selected. 

Selecting and Using a Drawing Tool 
Before you begin working in the drawing area, you need to select the tool you 
want to work with from the Toolbox at the left of the Paintbrush window. 

The Brush tool is always selected 
when you start Paintbrush. 
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~ To select a drawing tool 

• In the Toolbox, point to the tool you want to use, and then click it. 

Or press TAB to move to the Toolbox, use the arrow keys to move the cursor 
to the tool, and then press INS. 

~ To draw with the selected tool 

1. Move the cursor to the place you want to start drawing, and then press and hold 
down the mouse button. 

Or press TAB to move to the drawing area, and use the arrow keys to position 
the cursor. 

2. Drag the cursor around the drawing area. 

Or press and hold down INS, and use the arrow keys to move the cursor. 

If you are drawing an item such as a box or circle, a flexible box or circle 
expands and contracts, following the cursor's movements. 

3. When you are satisfied with the item, release the mouse button. 

For more information about each of the available tools, see "Working with the 
Paintbrush Tools" later in this chapter. 

Undoing Your Changes 
If you make a mistake while drawing, you can use the Undo command on the 
Edit menu or the BACKSPACE key to make simple corrections. 

You can use the Undo command and BACKSPACE to make corrections until you do 
any of the following: 

• Select a tool. 

• Use a scroll bar. 

• Switch to another application. 

• Resize the window. 

Once you take any of these actions, the items currently in the drawing area 
are set (pasted down), and the Undo command and BACKSPACE no longer delete 
those items. You must now use an eraser tool, or select and edit a portion of your 
drawing called a cutout. For more information about erasing and editing cutouts, 
see "The Color Eraser," "The Eraser," and "Editing Your Drawing" later in this 
chapter. For more information about defining a cutout, see "The Cutout Tools" 
later in this chapter. 

Note To prevent undoing work that you are satisfied with, protect that 
section of your drawing from Undo and BACKSPACE by reselecting the tool you 
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are currently working with or by taking one of the other actions in the preceding 
list. Then Undo and BACKSPACE can delete only your most recent work. 

~ To edit a drawing by using the Undo command 

• From the Edit menu, choose Undo. 

Or press CTRL+Z. 

Everything you have drawn since selecting the tool you are currently working 
with is deleted. 

U sing just BACKSPACE lets you delete a portion or all of what you have drawn 
since selecting the tool you are currently working with. BACKSPACE is particularly 
handy for small cleanup jobs, such as deleting stray dots made by the Airbrush 
tool. 

~ To edit a drawing by using the BACKSPACE key 

1. Press BACKSPACE. 

The cursor turns into a square with an X inside. The size of the square depends 
on the drawing width selected. 

2. Drag the cursor over the parts of the item you want to delete. 

3. When you finish, release the mouse button. 

4. Drag the cursor again to continue drawing with the selected tool. 

The procedure for using text in your drawing involves the following steps: 

• Selecting the foreground color you want to use for the text 

• Selecting the Text tool from the Toolbox 

• Choosing the font you want to use 

• Choosing a size for the font 

• Choosing a style for the font 

• Positioning and typing your text 

• Editing your text 

For information about selecting a foreground color, see "Selecting Background 
and Foreground Colors" earlier in this chapter. The following sections explain 
the remaining steps. 
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Selecting the Text Tool 
When you select the Text tool, you can type text in the drawing area. 

~ To select the Text tool 

• In the Toolbox, point to the Text tool, and then click it. 

Or press TAB to move to the Toolbox, use the arrow keys to move to the Text 
tool, and then press INS. 

Selecting a Font and Font Size 
You select a font and font size (also known as point size) to modify the appear­
ance of your text. The availability of point sizes depends on your display adapter 
and the fonts you have installed. 

~ To select a font for text 

1. From the Text menu, choose Fonts. 
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2. In the Font dialog box, select a font. 

3. Choose the OK button. 

The font that you select affects any text that is not pasted down in the drawing 
area, in addition to the text that you are about to type. For information about 
pasting down text, see "Basic Text Editing" later in this chapter. 
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~ To select a point size for a font 

1. From the Text menu, choose Fonts. 

2. In the Font dialog box, select a point size. 

3. Choose the OK button. 

Setting Style Options 
In addition to selecting different sizes for fonts, you can select different styles for 
emphasizing text. You can use bold, italic, and underline formats for the text you 
type. You can also outline text and create a shadow around it in a background 
color you specify. 

~ To change the style of text 

• From the Text menu, choose a style. 

A check mark appears next to the style on the Text menu. 

You can also select or cancel a style by using the Font dialog box. 

You can have more than one style for the same text. The styles affect text that is 
not pasted down in the drawing area, in addition to text that you are about to type. 
For information about pasting down text, see "Basic Text Editing" later in this 
chapter. 

~ To cancel a style selection 

• From the Text menu, choose the style (except for Regular) you want to cancel. 

The check mark next to the style on the Text menu disappears. 

~ To cancel all the current style selections 

• From the Text menu, choose Regular. 

A check mark appears next to the Regular command. 

All other check marks on the Text menu disappear. 

Typing and Positioning Text 
Typing text in the Paintbrush drawing area is similar to typing text in a word­
processing application, except that text does not automatically wrap from line to 
line in Paintbrush. Also, the cursor does not realign itself with previously typed 
text if you switch to a different tool and then switch back to the Text tool. 
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~ To type text in the Paintbrush drawing area 

1. Point to the place you want your text to appear, and then click to position the 
cursor. 

Or press TAB to move to the drawing area, and then use the arrow keys to 
position the cursor. 

The Text cursor appears as a vertical line. 

2. Start typing. 

The text you type appears in the drawing area at the position of the text cursor, 
while the cursor moves to the right. 

If you continue typing on the same line, Paintbrush stops entering text when 
you reach the right edge of the drawing area. 

3. Press ENTER when you want to start a new line of text. 

Or reposition the Text cursor by clicking the appropriate location. 

If the size of your drawing is larger than the size of the drawing area, you can 
use the scroll bars or the appropriate arrow keys to move to other parts of your 
drawing, and then type text there. For more information about using the keyboard 
to move around in a drawing, see "Moving Around in a Large Drawing" earlier 
in this chapter. 

Basic Text Editing 
You can correct simple text errors by pressing the BACKSPACE key. BACKSPACE 

works the same with Paintbrush text as it works in any other Windows application. 
For more information, see Chapter 2, "Application Basics." 

You can also select a new foreground color, font, point size, or text style for text 
in the drawing area. You can use BACKSPACE or make other changes to your text 
until you do any of the following: 

• Select a tool. 

• Use a scroll bar. 

• Switch to another application. 

• Reposition the text cursor. 

• Resize the window. 
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Once you take any of these actions, Paintbrush pastes down the text currently in 
the drawing area. BACKSPACE no longer deletes that text, and you cannot change 
the color, font, point size, or style of the text. If you want to change or delete the 
text, you must erase or cut the text out of the drawing and then retype it. For Plore 
information, see "The Color Eraser," "The Eraser," and "Editing Your Drawing" 
later in this chapter. 

Working with the Paintbrush Tools 
The Toolbox appears at the left of the Paintbrush window. 

Scissors --~ [* -- Pick 

Airbrush-- abc -- Texttool 

Color Eraser -- -- Eraser 

Paint Roller--. -- Brush 

Curve --a / -- Line 

Box -- 0 • -- Filled Box 

Rounded Box -- 0 • -- Filled Rounded Box 

Circle/Ellipse --a • -- Filled Circle/Ellipse 

Polygon -- 'h '\. -- Filled Polygon 

You use the tools in the Toolbox to create your drawings. 

~ To select a tool from the Toolbox 

• Point to the tool, and then click it. 

Or press TAB to move to the Toolbox, use the arrow keys to select a tool, and 
then press INS. 

Paintbrush highlights the selected tool in the Toolbox. 

The following sections explain the tools in the order that they appear in the 
Toolbox. 
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The Cutout Tools 

You can define, or select, an area of your picture called a cutout by using the 
cutout tools. When you define a cutout, you outline an area with a dotted line. 
You can then cut, copy, and manipulate that area. 

You can define a free-form cutout with the Scissors tool, or a rectangular cutout 
with the Pick tool. The cutout can be very small or as large as the drawing area. 

Define a free-form cutout when you want the cutout area to closely follow the 
contours of an object in the drawing. 

~ To define a free-form cutout 

1. From the top left of the Toolbox, select the Scissors tool, and then move the 
cursor into the drawing area. 

2. Holding down the mouse button, move the mouse to draw a line around the 
part of your picture you want to define as a cutout. 

3. When you have completely outlined the area, release the mouse button. 

If you make a mistake, click anywhere on the screen to start over. 

Define a rectangular cutout with the Pick tool when the size and shape of the 
cutout area don't need to conform closely to the object's contours. 
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-----------------+ 

~ To define a rectangular cutout 

1. From the top right of the Toolbox, select the Pick tool, and then move the 
cursor into the drawing area. 

2. Drag the cursor until the flexible box encloses the area you want to define. 

3. Release the mouse button. 

If you make a mistake, click anywhere on the screen to start over. 

After you define a cutout, you can use commands from the Edit menu to cut, copy, 
paste, and save the cutout, and commands from the Pick menu to manipulate it in 
various other ways. 

Once you manipulate a cutout, there are three ways you can paste it down 
(anchor it) in its new position. 

~ To paste down a cutout 

• Click outside the cutout. 

Or define a new cutout. 

Or select any tool. 

For more information about ways of working with cutouts, see "Editing Your 
Drawing" and "Advanced Paintbrush Features" later in this chapter. 
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The Airbrush 
The Airbrush tool produces a circular spray of dots. The color of the spray is the 
foreground color. 

~ To use the Airbrush tool 

1. Select a foreground color. 

2. Select a drawing width. 

The drawing width determines the size of the circle of spray. 

3. From the Toolbox, select the Airbrush tool, and then move the cursor into the 
drawing area. 

4. At the location where you want to start the Airbrush spray, press and hold down 
the mouse button and drag the cursor. 

The speed at which you drag the cursor determines the density of the spray. 

5. Release the mouse button to stop the spray. 

The Airbrush tool is particularly useful for shading "3-D" objects. 
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You can add text to your Paintbrush drawings with the Text tool. The text 
appears in the selected foreground color, font, point size, and font style. For 
more information about working with the Text tool, see "Typing Text" earlier 
in this chapter. 

You can use the Color Eraser in two ways to change colors in all or part of your 
drawing. You can: 

• Drag the Color Eraser cursor over an area of a drawing, changing the selected 
foreground color under the cursor to the selected background color. 

• Change every occurrence of one color in the drawing area to another color. 
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~ To change a color by using the Color Eraser 

1. Select the foreground and background colors you want to use the Color Eraser 
with. 

The background color will replace the foreground color. 

2. Select a drawing width. 

The larger the drawing width, the larger the Color Eraser cursor. You can erase 
small or large areas easily by changing drawing widths. 

3. From the Toolbox, select the Color Eraser tool, and then move the cursor into 
the drawing area. 

4. Drag the cursor to change any areas of the selected foreground color under the 
cursor. (The other colors remain the same.) 

To make the Color Eraser move in a straight horizontal or vertical line, press 
and hold down SHIFT as you drag the cursor. 

5. Release the mouse button to stop erasing. 

The selected foreground color remains the same in all areas not touched by the 
Color Eraser cursor. 

~ To change every occurrence of one color to another color 

1. Make sure that every place that has the colors you want to change is displayed 
in the drawing area. 

If the drawing is larger than the drawing area, you can use the scroll bars or 
arrow keys to move to other parts of the drawing. 

2. Select the foreground and background colors you want to use the Color Eraser 
with. 

The background color will replace the foreground color. 

3. In the Toolbox, double-click the Color Eraser tool. 

Every section of the selected foreground color in the drawing area changes to 
the selected background color. 
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The Eraser changes all the foreground colors that it touches to the selected 
background color. 

~ To erase portions of the drawing by using the Eraser 

1. Make sure the selected background color is the same as the background color in 
the area you want to erase. 

If the colors don't match, you will draw with the currently selected background 
color rather than erase to the original background color. 

2. Select a drawing width. 

The larger the drawing width, the larger the Eraser cursor. You can erase small 
or large areas easily by changing drawing widths. 

3. From the Toolbox, select the Eraser tool, and then move the cursor into the 
drawing area. 

4. Drag the cursor to erase the part of the drawing under the cursor. 

To make the Eraser move in a straight horizontal or vertical line, press and hold 
down SHIFT as you drag the cursor. 

5. Release the mouse button to stop erasing. 
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The Paint Roller 
U sing the Paint Roller, you can fill any closed shape or area with the selected 
foreground color. You can fill a hollow area enclosed by a border or fill a solid 
object with a different color or pattern. 

~ To fill an area by using the Paint Roller 

1. Select the foreground color you want to use for the fill. 

If you fill an object with a pattern or nonsolid color rather than a solid color, 
you will not be able to refill the object using the Paint Roller. However, you 
can use the Color Eraser to change the pattern used to fill an object. 

2. From the Toolbox, select the Paint Roller tool, and then move the cursor into 
the drawing area. 

3. Place the cursor inside the area you want to fill, and then click using the left 
mouse button. 

The area fills with the selected foreground color. 
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If the shape being filled has any breaks in its border, the filling color leaks through 
to the rest of the drawing area. If this should happen, wait for the color to stop 
leaking, and then choose Undo from the Edit menu (or press CTRL+Z) to clean it 
up. Note that the drawing area itself defines a border, so color fills will stop at the 
edges of the drawing area. 

You can use the Zoom In command on the View menu to close the opening in 
your object where the color leaked out. For more information, see "Editing by 
Using the Zoom In Command" later in this chapter. 

Tip To prevent undoing work that you are satisfied with, reselect the Paint Roller 
tool each time you perform a fill. 

You can use the Brush tool like a standard bristle paintbrush to draw freehand 
shapes and lines in the selected foreground color and drawing width. 
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~ To draw freehand lines by using the Brush tool 

1. Select a foreground color. 

2. Select a drawing width. 

3. From the Toolbox, select the Brush tool, and then move the cursor to the place 
you want in the drawing area. 

4. Drag the cursor to draw freehand shapes. 

To draw straight horizontal or vertical lines, press and hold down SHIFT as you 
drag the cursor. 

5. Release the mouse button to stop drawing. 

You can change the shape of the Brush cursor to create different effects as you 
paint. 

~ To change the shape of the Brush cursor 

1. From the Options menu, choose Brush Shapes. 

The Brush Shapes dialog box appears. 

The default shape for 
the Brush cursor 

2. Choose a cursor shape by double-clicking it. 

Or use an arrow key to select a shape, and then choose the OK button. 

The Brush Shapes dialog box disappears, and the Brush cursor appears in the 
drawing area in the selected shape. 

Tip To open the Brush Shapes dialog box quickly, double-click the Brush tool in 
the Toolbox. Or move the cursor to the Brush tool in the Toolbox, and then press 
F9+INS. 



The Curve 

Chapter '10 Paintbrush 353 

Using the Curve tool, you can draw curved lines in the selected foreground 
color and drawing width. 

~ To draw a curved line by using the Curve tool 

1. Select a foreground color. 

2. Select a drawing width. 

3. From the Toolbox, select the Curve tool, and then move the cursor into the 
drawing area. 

4. Press the mouse button at the place you want to anchor one end of the curve, 
and then drag the cursor. 

A flexible line stretches from the anchored end of the line to the current cursor 
position. 

5. When the line is the length you want, release the mouse button to anchor the 
second end of your curve. 
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6. Drag the cursor. 

The line curves in the direction you move the mouse. 

7. When you are satisfied with the angle of this first curve, release the mouse 
button. 

If you want to curve the line in only one direction, click the second end point 
of the line. Otherwise, go on to the next step. 

8. Press the mouse button again, and drag the cursor away from the first curve to 
bend your line in another direction. 

9. When you are satisfied with the angle of this curve, release the mouse button. 

Until you click the second end point or release the left mouse button the second 
time, you can click using the right button to undo the curve and start over. 

When you finish your curved line, Paintbrush colors the curve with the foreground 
color. 
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You can easily draw straight lines in the selected foreground color and drawing 
width by using the Line tool. 

-- - -~~- - ----

-- -- ---

~ To draw a straight line by using the Line tool 

1. Select a foreground color. 

2. Select a drawing width. 

3. From the Toolbox, select the Line tool, and then move the cursor into the 
drawing area. 

4. Press the mouse button at the place you want to anchor one end of the line, 
and then drag the cursor. 

A flexible line stretches from the anchored end of the line to the cursor, 
changing length and position as you move the mouse. 

5. When you are satisfied with the length and position of the flexible line, 
release the mouse button to paste the line onto the drawing area. 

Until you release the left mouse button, you can click using the right button 
to undo the line and start over. 

Tip To draw a perfectly horizontal, vertical, or 4S-degree diagonal line, press 
and hold down SHIff as you drag the cursor. 
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The Box and the Filled Box 
You can use the Box tool to draw hollow squares or rectangles in the selected 
foreground color and drawing width. The Filled Box tool produces squares and 
rectangles that are filled with the selected foreground color and bordered by the 
selected background color. 

~ To draw a box or filled box 

1. Select a foreground color. 

2. If you are drawing a filled box, select a background color for the border. 

If you want a filled box with no border, make the foreground and background 
colors the same. 

3. Select a drawing width. 

If you are drawing a filled box, the drawing width determines the thickness of 
the box's border. 

4. From the Toolbox, select the Box or Filled Box tool, and then move the cursor 
into the drawing area. 

5. Press the mouse button at the place you want to anchor the box, and then drag 
the cursor. 

A flexible box stretches from the anchored end of the line to the position of 
the mouse, expanding and contracting as you move the mouse. 
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6. When you are satisfied with the size of the flexible box, release the mouse 
button to paste the box onto the drawing area. 

Until you release the left mouse button, you can click using the right button to 
undo the box and start over. 

Tip If you want to draw a perfect hollow or filled square, press and hold down 
SHIFT as you drag the cursor. 

The Rounded Box and the Filled Rounded Box 
The Rounded Box tool and the Filled Rounded Box tool work exactly the same 
as the Box tool and the Filled Box tool. The only difference is that rounded and 
filled rounded boxes have round corners. 

For information about drawing a box or a filled box, see the preceding section, 
"The Box and the Filled Box." 

Tip If you want to draw a perfect hollow or filled rounded square, press and hold 
down SHIFT as you drag the cursor. 
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The Circle/Ellipse and the Filled Circle/Ellipse 
By using the Circle/Ellipse tool, you can draw hollow circles or ellipses in the 
selected foreground color and drawing width. The Filled Circle/Ellipse tool 
produces circles and ellipses filled with the selected foreground color and 
bordered by the selected background color. 

~ To draw a hollow or filled circle or ellipse 

1. Select a foreground color. 

2. If you are drawing a filled circle or ellipse, select a background color for the 
border. 

If you want no border, make the foreground and background colors the same. 

3. Select a drawing width. 

If you are drawing a filled circle or ellipse, the drawing width determines the 
thickness of the border around the circle or ellipse. 

4. From the Toolbox, select the Circle/Ellipse or Filled Circle/Ellipse tool, and 
then move the cursor into the drawing area. 

S. Press the mouse button at the place you want to anchor the circle, and then drag 
the cursor. 

A flexible circle or ellipse stretches from the anchored end of the line to the 
position of the cursor, expanding and contracting as you move the mouse. 
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6. When you are satisfied with the size and shape of the flexible circle/ellipse, 
release the mouse button to paste it onto the drawing area. 

Until you release the left mouse button, you can click using the right button to 
undo the circle or ellipse and start over. 

Tip If you want to draw a perfect circle or filled circle, press and hold down SHIFT 

as you drag the cursor. 

The Polygon and the Filled Polygon 

l"h I '\.1 Using the Polygon tool, you can draw polygons from connected straight-line 
segments in the selected foreground color and drawing width. The Filled 
Polygon tool produces polygons filled with the selected foreground color and 
bordered by the selected background color. 

ID[o][{] I 

~ To draw a polygon or filled polygon 

1. Select a foreground color. 

2. If you are drawing a filled polygon, select a background color for the border. 

If you want no border, make the foreground and background colors the same. 

3. Select a drawing width. 

If you are drawing a filled polygon, the drawing width determines the thickness 
of the polygon's border. 
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4. From the Toolbox, select the Polygon or Filled Polygon tool, and then move the 
cursor into the drawing area. 

5. Press the mouse button at the place you want to anchor the starting point of the 
polygon, and then drag the cursor. 

A flexible line stretches from the anchored starting point to the position of the 
cursor, expanding and contracting as you move the mouse. 

6. When you reach the point where you want the first side of the polygon to end, 
release the mouse button. 

A line appears from the starting point to the point where you released the 
mouse button. The end of the first line segment then becomes the starting point 
for the next segment. 

7. Continue adding sides until you are ready to add the last side. 

At any time before you add the last side, you can click using the right mouse 
button to undo the polygon and start over. 

8. To add the last side, double-click. 

The polygon is automatically closed. 

Tip To draw a perfectly horizontal, vertical, or 45-degree diagonal line, press and 
hold down SHIFT as you drag the cursor. 

If you prefer, you can draw the lines for your polygon without dragging flexible 
lines. Just move the cursor, without pressing the mouse button, to the position 
where you want the next line to end, and then press the mouse button. A line 
appears between the two points. Before you release the mouse button, you can 
adjust the position of this line. 

Editing Your Drawing 
As you create a Paintbrush drawing, there are a variety of tools and functions 
to help you make changes to your drawing. The BACKSPACE key and the Undo 
command on the Edit menu allow you to delete those parts of a drawing that are 
not pasted down yet. For information about BACKSPACE and Undo, see "Undoing 
Your Changes" earlier in this chapter. 

After you paste down part or all of a drawing, you can use the Eraser tool to erase 
and the Color Eraser tool to change colors. You can also define, or select, an area 
called a cutout, and then cut, copy, move, sweep, or paste that cutout. You can 
save a cutout in a disk file, and then retrieve it to use as part of another drawing. 
The following sections discuss using the two erasers and working with cutouts. 
For information about defining cutouts, see "The Cutout Tools" earlier in this 
chapter. 
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Using the Erasers 
By dragging the Eraser over parts of your drawing, you can change all the fore­
ground colors that the Eraser touches to the selected background color. You can 
use the Color Eraser to change particular colors in part or all of your drawing. 
For more information about using the erasers, see "The Eraser" and "The Color 
Eraser" earlier in this chapter. 

Cutting and Pasting Cutouts 
You can use the Copy, Cut, and Paste commands on the Edit menu to transfer a 
defined cutout to and from the Clipboard, just as you use the Clipboard in other 
Windows applications. When you paste a cutout into Paintbrush, the cutout 
appears in a flexible box in the upper-left comer of the drawing area. (The Pick 
tool at the top right of the Toolbox is automatically selected.) You need to move 
the cutout to the location in the drawing area where you want it to appear 
permanently. 

It is important to remember while cutting and pasting cutouts that you cannot 
paste a cutout larger than the current drawing area unless you have zoomed out 
to display your entire drawing. If you try, Paintbrush pastes only the part of the 
cutout showing in the drawing area. For more information about using the 
Clipboard, see Chapter 2, "Application Basics." For information about defining 
a cutout, see "The Cutout Tools" earlier in this chapter. 

Once you manipulate a cutout, there are three ways you can paste it down 
("anchor" it) in its new position. 

~ To paste down a cutout 

• Click outside the cutout. 

Or define a new cutout. 

Or select any tool. 

Linking and Embedding Cutouts 
You can insert Paintbrush drawings into other files by copying, linking, or 
embedding them. The method you use to insert the drawing determines how you 
make changes to it. You can link and embed information only if the application 
you are transferring the drawing to supports object linking and embedding. 
Check the application's documentation to find out. 
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Method 

Copy 

Embed 

Link 

Description 

You copy a drawing to a document in a different application. Once the 
drawing is in the new document, you can change it only by deleting it 
and copying a new drawing in its place. To copy a drawing, use the Copy 
command on the Edit menu to copy the drawing onto the Clipboard. 

Embedding is similar to copying but with one important difference: 
You can edit embedded drawings from within the other application's 
document. To embed a drawing, use the Copy command on the Edit 
menu to copy the drawing onto the Clipboard. 

Linking dynamically connects two files so that information in one file 
automatically updates when information in the other file changes. To link 
an object, use the Copy command on the Edit menu to copy the drawing 
onto the Clipboard. 

The commands you use to insert, or paste, the drawing or object from the 
Clipboard into the application depend on whether you want the drawing copied, 
embedded, or linked. Check your application's documentation to find out how 
to complete these procedures. 

For more information about linking and embedding Paintbrush drawings, see 
Chapter 13, "Integrating Your Windows Applications." 

Using the Omit Picture Format Command 
When Paintbrush copies a drawing onto the Clipboard, it copies it in various 
formats to ensure that other applications will be able to display the drawing. 

Some applications cannot read all these formats. Before copying a drawing 
between Paintbrush and these applications, you must limit the formats that get 
copied onto the Clipboard. 

Check the documentation of the other applications you are using to see if you 
need to use this option. 
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~ To limit the formats that are copied onto the Clipboard 

Movi ng a Cutout 

1. From the Options menu, choose Omit Picture Format. 

A check mark appears next to the command on the menu. 

2. Select the drawing, and then copy it onto the Clipboard. 

After you define a cutout, you can move it anywhere in the drawing area. For 
information about defining a cutout, see "The Cutout Tools" earlier in this chapter. 

~ To move a cutout 

1. Move the cursor inside the cutout. 

2. Using either mouse button, drag the cutout to where you want it. 

If you want the cutout to appear transparently in its new location, use the left 
mouse button. If you want the cutout to appear opaquely, use the right mouse 
button. For more information, see "Transparent and Opaque Pasting and 
Sweeping" later in this chapter. 

3. When the cutout is where you want to leave it, release the mouse button. 

4. Click outside the cutout to set it in its new position. Or select a tool. 

Copying a Cutout 
When you move a cutout, you can choose to leave a copy of the cutout in its 
original position. 

~ To move a cutout and leave a copy behind 

1. Move the cursor inside the cutout. 

2. Press and hold down CTRL and, using either mouse button, drag the cutout away 
from the copy. 

3. Release CTRL once you have moved the cutout away from the copy. 

4. When the cutout is where you want to leave it, release the mouse button. 

5. Click outside the cutout to set it in its new position. Or select a tool. 
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Sweeping a Cutout 
When you sweep a cutout, you move it across the drawing area, leaving a trail of 
copies behind. 

~ To sweep a cutout 

1. Move the cursor inside the cutout. 

2. Press and hold down SHIFT and, using either mouse button, drag the cutout 
across the drawing area. 

If you want the cutout to appear transparently in its new location, use the left 
mouse button. If you want the cutout to appear opaquely, use the right mouse 
button. For more information, see "Transparent and Opaque Pasting and 
Sweeping" later in this chapter. 

3. When you finish sweeping the cutout, release SHIff and the mouse button. 

4. Click outside the cutout to paste it in the drawing area. Or select a tool. 
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Moving, Sweeping, and Copying a Cutout in Zoom-Out Mode 
When you perform a cutout operation in zoom-out mode, you can only paste the 
cutout opaquely. After you choose the Paste or Paste From command from the 
Edit menu, a shaded box representing the cutout appears in the upper-Jeft corner of 
the drawing area. You can then move the cursor inside the box and drag the box to 
the position you want. To paste it down, click outside the box. You will have to 
click outside the drawing if the cutout is as large as the drawing itself. Any part of 
the box outside the drawing area will be cropped. 

Transparent and Opaque Pasting and Sweeping 
You have the choice of pasting or sweeping transparently or opaquely. If you 
paste or sweep transparently, any part of your drawing covered by the cutout 
shows through. If you paste or sweep opaquely, the entire cutout area covers 
whatever part of the drawing is underneath it. The following illustrates both 
transparent and opaque sweeping. 

Sweeping a cutout 
transparently \ 

, 

~ 

If you want to paste or sweep transparently, the background color for the cutout 
and the currently selected background color must be the same. Otherwise, the 
object you paste or sweep won't be transparent. 

Tip If you want to sweep a cutout opaquely across the screen, you might want to 
define a free-form cutout with the Scissors tool. By creating a cutout that closely 
outlines the object you want to sweep, the shape that you sweep is only the defined 
object. If you define a rectangular cutout, the object appears in a box of back­
ground color. 
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Saving a Cutout 
You can save a cutout as a .PCX file or as a bitmap (.BMP) file. Unless you have 
changed the setting in the Save As dialog box, Windows assigns the extension 
.BMP to save your cutout as a Windows bitmap. 

~ To save a cutout 

1. Define the cutout. 

2. From the Edit menu, choose Copy To. 

3. In the File Name box, type a name for your cutout. 

4. Choose the OK button. 

If you want to save your cutout in a different format, select from the options in 
the Save File As Type list. 

For more information about opening and saving files, see Chapter 2, "Application 
Basics." 

If you are concerned about the amount of disk space needed to store a cutout, you 
can choose the Info button in the Copy To dialog box to see the cutout's size and 
number of colors and planes before you save it. The larger the size of the cutout 
and the more colors used, the more disk space it requires. 

Retrieving a Cutout from a File 
You can use the Paste From command on the Edit menu to retrieve a previously 
saved cutout from a file and place it in the drawing area. The Paste From 
command works much like the Open command on the File menu. For more 
information about opening files, see Chapter 2, "Application Basics." 

If you want to see the cutout's height, width, number of colors, and number of 
planes before pasting it, choose the Info button in the Paste From dialog box. 

You can use the same techniques as when pasting from the Clipboard. When you 
paste a cutout into Paintbrush, the cutout appears in a flexible box in the upper-left 
corner of the drawing area. (The Pick tool at the top right of the Toolbox is auto­
matically selected.) You need to move the cutout to the location in the drawing 
area where you want it to appear permanently. 

Note If you paste a previously saved color drawing into a black-and-white 
drawing, Paintbrush translates the colors into black and white. 
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~ To place a cutout where you want it to appear permanently 

1. Move the cursor inside the flexible box. 

2. Using either mouse button, drag the cutout to the place you want it to appear in 
your drawing, and then release the mouse button. 

If you want to paste the cutout transparently in its new location, use the left 
mouse button. If you want to paste the cutout opaquely, use the right mouse 
button. For more information, see "Transparent and Opaque Pasting and 
Sweeping" earlier in this chapter. 

3. Click outside the cutout to paste it onto the drawing area. Or select a tool. 

Advanced Paintbrush Features 
Paintbrush has a number of other features that allow you to: 

• Shrink, enlarge, flip, and tilt defined cutouts. 

• Invert colors in a cutout. 

• Create drawings containing greater detail. 

• Do detailed editing. 

• Use custom colors in your drawings. 

The following topics explain each of these features. 

Shrinking and Enlarging a Cutout 
After you define a cutout, you can use the Shrink + Grow command on the Pick 
menu to change the size of the cutout. 

~ To change the size of a cutout 

1. From the Pick menu, choose Shrink + Grow. 

2. If you want the original area erased after shrinking or enlarging the cutout, 
choose Clear from the Pick menu. 

Be sure that the current background color matches the background color of the 
area you want to clear. 

3. Move the cursor to the place you want to anchor the upper -left comer of the 
flexible box that you use to change the dimensions of your cutout. Then press 
and hold down the mouse button. 
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4. Drag the cursor until you are satisfied with the box's dimensions. 

To keep the dimensions of the flexible box in proportion to those of the cutout, 
press and hold down SHIFT while dragging the cursor. 

5. When you are satisfied with the dimensions of the flexible box, release the 
mouse button. 

The cutout shrinks or enlarges to fit the dimensions of the box. 

6. Click outside the cutout to paste it onto the drawing area. Or select a tool. 

If you shrink a defined cutout, you can remove what remains of the larger cutout 
by using any of the various ways of editing a drawing. 

Flipping a Cutout 
You can use the Flip Horizontal command on the Pick menu to flip a defined 
cutout from side to side. The Flip Vertical command flips a defined cutout from 
top to bottom. 

~ To flip a cutout horizontally or vertically 

1. From the Pick menu, choose Flip Horizontal or Flip Vertical. 

Paintbrush flips the cutout at the current cutout position. 

2. Click outside the cutout to paste it onto the drawing area. Or select a tool. 

Inverting Colors in a Cutout 
The Inverse command on the Pick menu inverts the colors in a defined cutout. 
For example, in a black-and-white drawing, black becomes white and white 
becomes black. 

~ To invert the colors in a cutout 

1. From the Pick menu, choose Inverse. 

The colors in the cutout are inverted. 

2. Click outside the cutout to paste the inverted colors onto the drawing area. 

Or select a tool. 
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You can use the Tilt command on the Pick menu to tilt a defined cutout on an 
angle that you determine. 

~ To tilt a cutout 

1. From the Pick menu, choose Tilt. 

2. If you want the original area erased after tilting the cutout, choose Clear from 
the Pick menu. 

3. Move the cursor to the place you want to anchor the upper-left comer of the 
flexible box that you use to determine the angle of tilt. Then press and hold 
down the mouse button. 

4. Move the mouse left or right. The bottom of the flexible box shifts with the 
mouse, tilting the sides of the box and changing the comer angles. 

5. When the angle of the box is correct, release the mouse button. 

You can tilt the same cutout as many times as you like. 

6. To paste the tilted cutout onto the drawing area, select any tool. 

Working with Detail 
The Cursor Position command on the View menu displays the current cursor 
position as x-y coordinates. You can use these width and height coordinates to 
accurately align text or lines in your drawings. This is particularly helpful when 
you create charts and tables. 

~ To use the cursor position coordinates 

1. From the View menu, choose Cursor Position. 

The Cursor Position window appears on the right side of the title bar above the 
drawing area. You can move it to any position outside the drawing area, even 
outside the Paintbrush window. For information about moving windows, see 
Chapter 1, "Windows Basics." 

Cursor Position window 

Y:iew Iext Qptions Help 

+ 
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2. Move the cursor around the drawing area. 

The coordinates inside the Cursor Position window change to indicate the 
position of the cursor. The coordinates change only while the cursor is inside 
the drawing area. If you move the cursor outside the drawing area, the last valid 
coordinates remain showing in the window until you move back inside the 
drawing area. 

3. When you finish using the coordinates, choose Cursor Position again to remove 
the window from the screen. 

Editing by Using the Zoom In Command 
You can use the Zoom In command on the View menu to magnify a portion of a 
drawing so that you can make changes one pel (pixel) at a time. 

~ To edit a drawing by using the Zoom In command 

1. From the View menu, choose Zoom In. 

Or press CTRL+N. 

2. Move the cursor into the drawing area. 

The cursor changes to a movable rectangle. 

3. Move the mouse to place the rectangle over the area you want to magnify. 

4. Click to magnify the portion of your drawing enclosed by the rectangle. 

In the small box that appears in the upper-left corner of the drawing area, you 
can see how changes you make to the magnified area look at normal resolution. 

5. Edit the magnified area in any of the following ways: 

• Click using the left mouse button to change a single pel to the selected 
foreground color. 

• Click using the right mouse button to change a single pel to the selected 
background color. 

• U sing either mouse button, drag the cursor to change a wide area of pels. 

• Use the Paint Roller tool to change whole areas of solid color within the 
magnified area. The Paint Roller works the same whether you are working 
with a full-size drawing or a magnified portion of a drawing. For more 
information, see "The Paint Roller" earlier in this chapter. 
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6. If you make a mistake, choose Undo from the Edit menu to return to the normal 
resolution and cancel any changes made to your drawing. 

Or press CTRL+Z. 

7. When you are satisfied with your changes, choose Zoom Out from the View 
menu. 

Tip If you use the Paint Roller tool with a full-size drawing and the paint leaks, 
Zoom In is very useful for patching the areas where the paint has leaked through. 

Creating Custom Colors 
Every color and pattern in Paintbrush is made by varying the amount of each of 
the three primary colors-red, green, and blue-present in the color. This is true 
even in monochrome (black-and-white) mode. For instance, white is made by 
mixing together 255 parts of red, 255 parts of green, and 255 parts of blue. Black, 
on the other hand, is 0 red, 0 green, and 0 blue. 

You can create custom colors and patterns for your drawings by varying the 
amounts of red, green, and blue (or ROB components) present in the colors 
provided by Paintbrush. You can change colors and patterns at any time. 
Changing colors and patterns while you are working on a drawing does not 
affect your drawing in any way other than to provide you with more color 
options. 

You edit colors by using the Edit Colors command on the Options menu. Imagine 
that each scroll bar in the Edit Colors dialog box controls the brightness of a red, 
green, and blue flashlight. Moving the scroll box to the right increases the amount 
of that ROB component present in the color, lightening the color. Moving the 
scroll box to the left decreases the amount of that ROB component, darkening the 
color. 

If you shine the three flashlights on the same point of a piece of paper, the color 
where the beams of light meet is the composite color, which you see in the large 
rectangle to the right of the scroll bars. 
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~ To create a custom color 

1. Select the color you want to modify as the foreground color. 

2. From the Options menu, choose Edit Colors. 

The Edit Colors dialog box appears. 

3. Use the scroll bars to increase or decrease the amount of the primary color 
used, or type a number from 0 to 255 in the Red, Green, and Blue boxes. 

4. When you are satisfied with your new color, choose the OK button. 

If you are not satisfied with your new color, choose the Cancel button to cancel 
your changes and return to the drawing. 

Or, if you have edited a color several times, you can choose the Reset button to 
return the color to the one provided by Paintbrush at the beginning of a session. 

When you choose the OK button, the new color replaces the original color in the 
Palette. 

Tip To move quickly to the Edit Colors dialog box, double-click the color or 
pattern in the Palette that you want to edit. Or move the cursor to the color in the 
Palette, and then press F9+INS. 

If you like the new colors and patterns you create, you might want to save them so 
that they are available the next time you use Paintbrush. Use the Save Colors and 
Get Colors commands on the Options menu to save or retrieve your color palettes. 
You save and retrieve custom color files the same way you save and open any 
other Windows file. Windows assigns the extension .P AL to custom color files. 
You can also save the default palette so that you can easily retrieve it if you are 
currently using a custom palette. For more information about opening and saving 
Windows files, see Chapter 2, "Application Basics." For more information about 
working with Windows files, see Chapter 4, "File Manager." 
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Working with Paintbrush Files 
You can save your Paintbrush drawings as PCX (.PCX) files, or as bitmap (.BMP) 
files in four formats. Unless you change the setting in the Save As dialog box, 
Windows saves a new drawing as a Windows bitmap file. It saves a drawing that 
you open and edit in the same format that it was opened in. Except for selecting 
what kind of a file to save, you save and open Paintbrush files the same way you 
save and open any other Windows file. For more information about opening and 
saving files, see Chapter 2, "Application Basics." 

When you save in the PCX format, you can use Paintbrush with files created using 
some non-Windows applications. Not all PCX files are supported by Paintbrush. 

You should save images in one of the Windows bitmap formats whenever 
possible, in order to maintain the highest possible level of compatibility across 
hardware and future versions of Windows. If you want to save your Paintbrush 
drawing in other than the standard Windows bitmap format for your display 
adapter, open the Save As File Type list in the Save As dialog box, and then 
select from the following options: 

• PCX file 

• Monochrome bitmap 

• 16-color bitmap 

• 256-color bitmap 

• 24-bit bitmap 

Note To avoid using up more memory and disk space than is required, you should 
always use the bitmap format that is closest in size to the number of colors used in 
the picture. 

Converting Microsoft Paint Files 
You can easily convert a Microsoft Paint file to a Paintbrush file. However, you 
cannot use Paintbrush to work with a Paint file and then resave it as a Paint file. 

~ To convert a Microsoft Paint file 

1. From the File menu, choose Open. 

The Open dialog box appears. 

2. In the File Name box, type the name of the Paint file. 

Or, if you do not know the name of the Paint file you want to convert, select 
MSP Files from the List Files Of Type box, select the directory that contains 
the .MSP file, and then select the correct file in the File Name list. 
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3. Choose the OK button. 

A dialog box appears, asking you to confirm that the file should be converted to 
a Paintbrush file. 

4. Choose the OK button. 

The drawing appears on the screen. 

5. Edit the drawing as needed. 

6. When you are finished working with the drawing, choose Save from the 
File menu. 

Paintbrush assigns the extension .BMP to the old filename and saves the 
drawing. 

Printing a Drawing 
If you have connected and installed a printer, you can print your Paintbrush 
drawings. For information about installing a printer, see Chapter 6, "Print 
Manager." 

~ To print the current drawing 

1. From the File menu, choose Print. 

The Print dialog box appears, containing the different print options available. 

Humber of copies: U .s.caling: ~ % 

o .!J..se Printer Resolution 

2. Make any necessary changes to the options. 

For information about the different options, see the table that follows this 
procedure. 

3. Choose the OK button. 

A dialog box appears, displaying the status of the print job. 

If you want to cancel printing, choose the Cancel button. 
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U sing the different options available in the Print dialog box, you can perform the 
following tasks. 

Use 

Draft 

Proof 

Whole 

Partial 

Number Of Copies 

Scaling 

Use Printer Resolution 

Pri nting Part of a Drawing 

To 

Produce an unenhanced copy of your drawing by using the 
fastest speed of your printer. A few printers support only 
one setting for printing, in which case you will not notice 
any difference between Draft and Proof. 

Produce a copy of your drawing that makes use of as many 
of your printer's advanced features as possible. This is the 
default setting. 

Print your entire drawing, including those parts not showing 
in the drawing area. This is the default setting. 

Print part of your drawing. For more information, see the 
following section, "Printing Part of a Drawing." 

Specify the number of copies that you want to print. 

Specify how much to scale the image before sending it to 
the printer. Specify 100 percent to indicate no scaling. 

Print your drawing at printer resolution rather than at 
screen resolution. Since the dimensions of a pel (pixel) 
on a printer may be different from those for a pelon the 
screen, Paintbrush may stretch a drawing to produce the 
same dimensions on the printed page as you see on the 
screen. Selecting this option avoids this stretching process. 
In some cases, the image on the printer will be much 
smaller than the image on the screen because of the 
differences in resolution. 

When you select the Partial option button in the Print dialog box, you must 
determine which part of your drawing you want to print. 

~ To print part of a drawing 

1. From the File menu, choose Print. 

The Print dialog box appears. 

• 2. In the Print dialog box, select the Partial option button. 

3. Choose the OK button. 

Paintbrush adjusts the size of your drawing so that the entire image is displayed 
on the screen. 
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Setting Margins 

4. Move the cursor to the place you want to anchor one corner of the flexible box 
you will use to define your printing area. Then press and hold down the mouse 
button. 

5. Drag the cursor until the box contains the portion of the drawing that you want 
to print. 

6. Release the mouse button. 

Paintbrush prints the selected portion of the drawing. 

Paintbrush prints your drawing by using the margin settings in the Page Setup 
dialog box. If you want to position your drawing differently on the page, you 
can adjust the margins. 

~ To set the margins you want to use for printing 

1. From the File menu, choose Page Setup. 

The Page Setup dialog box appears . 

.!:leader: 

footer: 

Margins-------. 

lop: Inm I !l.ottom: ~ 

left: ~ !light: ~ 
v 

L The standard settings 
for margins 

2. In the Margins area, type the measurements for the margin settings you want 
to use. 

Paintbrush displays a message if your margin settings are too small for the 
size of your drawing. If your margin settings are larger than the size of your 
drawing, Paintbrush positions the upper-left comer of the drawing according 
to the settings in the Top and Left margin boxes. 

3. Choose the OK button. 

When you print, Paintbrush uses the new margin settings to position your 
drawing on the page. 
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Printing Headers and Footers 
When you print a drawing, you can add explanatory text, the date, a page number, 
or the filename as a header or footer on the printed page. You can also choose 
whether you want a header or footer to be left-aligned, right-aligned, or centered 
on the page. 

~ To print a header or footer on a drawing 

1. From the File menu, choose Page Setup. 

The Page Setup dialog box appears. 

2. In the Header and/or Footer box, type the text you want to use as a header 
or footer, along with any of the codes that can be used in these boxes. For 
information about these codes, see the table that follows this procedure. 

The Header and Footer boxes will scroll as you type in text. 

3. Choose the OK button. 

You can type the following codes in the Header and Footer boxes. 

Type For 

&d The current date. 

&p Page numbers. 

&f The current filename. 

&1 Text that follows the code to be aligned at the left margin. 

&r Text that follows the code to be aligned at the right margin. 

&c Text that follows the code to be centered between left and right margins. 
This is the default setting. 

&t The current time. 

You can include these codes in a single header or footer. For example, if you 
specify a header as &IPage &p&cFile &f&rDate &d, the header will print as 
follows: 

Page 1 File FILENAME.BMP Date 12/9/91 

When you print, any assigned headers or footers appear in their designated places 
on the printed pages. Headers always appear in the top margin and footers appear 
in the bottom margin, regardless of how your margins are set. 
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Changing the Printer and Printer Options 
Paintbrush prints your drawings on the default printer. If you want to use another 
printer or change any printer options, choose the Print Setup command on the File 
menu. 

The printer you change to does not need to be physically connected to your com­
puter. You can change to another printer just to format a drawing for that printer. 

~ To change printers or printer options 

1. From the File menu, choose Print Setup. 

The Print Setup dialog box appears. 

2. In the Printer box, select the Default Printer or Specific Printer option button. 

If you select the Specific Printer option button, select the printer you want to 
use from the list. 

3. Change the Orientation and Paper specifications as needed. 

4. To set options specific to your printer driver, choose the Options button, set 
the options as needed, and then choose the OK button. 

5. In the Print Setup dialog box, choose the OK button. 
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Chapter 11 

Working with Terminal 
This chapter describes how to use Windows Terminal, an application that enables 
you to connect your computer to other computers and exchange information. For 
example, with Terminal you can hook up to online information services, such as 
Dow Jones News/Retrieval, and to online bulletin boards, such as CompuServe. 

Before using Terminal, you should be familiar with basic telecommunications 
concepts and terms, such as modem, baud, and protocol. If exchanging infor­
mation between computers is new to you, it might be helpful to consult an 
introductory book on the subject. 

Hardware Requirements 
Besides the basic hardware requirements for the Microsoft Windows operating 
system, you need additional hardware to make full use of Terminal. By using the 
correct hardware with Terminal, you can connect and transfer files to another 
computer in the same room or to computers in different offices or buildings. 

To connect two computers in the same room, a special serial cable, called a null 
modem cable, must be attached to the serial port of each computer. Each computer 
must have its own communications application as well-either Terminal or 
another application. 

To communicate with computers in different locations, you need the following 
hardware: 

• An available serial port 

• A modem and a cable to connect to a serial port 

• A telephone line to connect to the modem 

For more information about these components, see your hardware manual or 
computer dealer. 
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Preparing to Connect 
Once you have started Terminal, you can familiarize yourself with the application 
before you actually connect your computer to another computer. 

~ To start Terminal 

• In the Accessories group, choose the Terminal icon. (Double-click the icon. 

II 

Or use the arrow keys to move the selection cursor to the icon, and then press 
ENTER.) 

The Terminal window appears. 

File Edit Settings Phone Transfers Help 

To use Terminal to exchange information with another computer, you need to 
know the settings required by the remote computer with which you want to 
communicate. 

For example, you need to know the remote computer's basic communications 
settings for baud rate, data bits, stop bits, parity, and flow-control method. If the 
remote machine is an online service, such as CompuServe, you can find informa­
tion about these settings in the package you received when you joined the service. 

Once you know what the required settings are for the remote computer, you can 
modify the default settings in Terminal so that they match those required by the 
remote computer. You can also specify additional settings or preferences to make 
your sessions more convenient. 
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You can save these settings into a unique settings file at any time during your 
Terminal session. Then, you do not have to modify Terminal's default settings 
each time you connect to the same remote computer. Settings files are identified 
by the .TRM extension in the filename. You can open and, if you need to, modify 
an existing settings file whenever you are ready to begin a Terminal session. 
Instructions for opening a settings file you have saved and for specifying new 
settings follow. 

Opening a Settings File 
You can use the New and Open commands on the File menu to create a new 
settings (. TRM) file or to open an existing one. 

~ To create a new settings file 

• From the File menu, choose New. 

The default settings remain in effect, unless you change them to match the 
remote system you are connecting to. 

~ To open a settings file that has already been created and saved 

1. From the File menu, choose Open. 

The Open dialog box appears. 

2. Select the drive or directory where the .TRM file is located, if it is not on the 
current drive or directory. 

3. In the File Name box, select the .TRM file you want to use for this session. 

4. Choose the OK button. 

Specifying Communications Settings 
Before connecting to and exchanging information with another computer, you 
must specify basic communications settings, such as the parity and baud rate, 
by using the Communications command in Terminal. For information about the 
correct settings, see your modem documentation and the remote service package, 
or call the remote system's information number (not the data transmission 
number) and request the settings. 
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The serial port that your modem is connected to also uses communications settings 
for the base port address and the interrupt request line (IRQ). Windows detects 
these settings and displays the values in the Advanced Settings dialog box of the 
Ports option in Control Panel. If your port requires different values than those 
detected by Windows, you can use the Advanced Settings dialog box to change 
these values. For more information about changing advanced port settings, see 
Chapter 5, "Control Panel." 

Note You cannot use Control Panel to change basic communications settings for 
use with Terminal. You must use the Communications command in Terminal to 
do this. 

~ To specify the communications settings 

1. From the Settings menu, choose Communications. 

The Communications dialog box appears . 

.earit, [low Conlrol 

@ None @ XonlXoff 

o Odd 0 Hardware 

o Even 0 None 

o Mark 

o Space D Parit, Checls. D Carrier Detect 

2. Select the options appropriate to your system and the remote computer. Then 
choose the OK button. 

A description of each option follows. 

Use 

Baud Rate 

Data Bits 

To 

Specify the data-transfer rate of your modem. Communicating 
systems must use the same baud rate. The most common settings 
are 1200 and 2400. Some modems can automatically drop back 
to the rate of the remote modem and signal Terminal of the 
change. For information about this feature, see your modem 
manual. 

Specify the number of data bits in each data packet sent between 
the two computers. Most characters are transmitted in 7 or 8 data 
bits, though some computers require a setting of 5 or 6 data bits. 



Use 

Parity 

Flow Control 

Parity Check 

Carrier Detect 

Connector 

Stop Bits 
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To 

Specify the type of parity. If you select 8 data bits (see the 
previous option), select None (no parity). 

Specify the action to be taken if the buffer becomes too full to 
receive more data from the remote system. 

Selecting XoniXoff (also known as software handshaking) 
causes Terminal to pause when the buffer fills. Then, when 
Terminal is ready for more data, it sends a signal to the remote 
computer. Selecting Hardware (or hardware handshaking) causes 
the remote system to control the flow of data. With None, neither 
system uses any method to control the flow of data. 

Select Xon/Xoff if you do not know what type of flow-control 
method to use. However, although Xon/Xoff is the standard 
method for most systems, it cannot be used with a remote system 
that is configured for hardware handshaking. 

Display the byte in which a parity error was encountered. Other­
wise, you see a question mark (?) where the modem detected an 
error. A question mark appears at every character that was not 
transferred correctly. 

Specify that Terminal use the modern signal for detecting a 
carrier signal. If your modem does not connect after you have 
correctly set the other options, tum off this option to use the 
carrier-detection method in Terminal, and then try connecting 
again. 

Select the communications port that your modem uses. If you 
select None, Terminal uses COMl if it is available and then 
checks COM2, and so forth. 

Specify the time between transmitted characters. Stop bits are 
not actually bits; they are the timing units between characters. 

Changing the Modem Command Settings 
Before connecting to a remote computer, you need to specify the modem you are 
using and accept or modify its default commands. You do this by choosing 
Modem Commands from the Settings menu. 

When you choose Modem Commands, Terminal displays several popular modem 
types and their commands. If your modem is not one of these types, you can select 
None, or you can select the modem whose commands most closely match the ones 
for the modem you are using. If you need to, you can then modify the default com­
mands for the selected modem so that they are appropriate for your modem. 
For more information about the commands your modem uses, see your modem 
manual. 
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~ To change modem command settings 

1. From the Settings menu, choose Modem Commands. 

The Modem Commands dialog box appears. 

Prefix: Suffix: 

.Ilial: Imw /I 

.!::!.angup: 1+++ /lATH 

Binarv I.X: I /I 
.M.odem Defaults 

Binarv.!lX: I /I 
@ Haves 

o MultiTech 
.!lriginate: IATQOV1E1S0=O o TrailBlazer 

o None 

2. In the Modem Defaults area, select the modem you are using, or the modem 
whose commands most closely match those for your modem. If none of the 
modem commands closely match those for your modem, then select None. 

3. In the Commands area, make any needed adjustments to the commands or, if 
you selected None, enter the commands for your modem. For example, if the 
Hayes commands are the same ones used by your modem, yet you want to 
pulse dial instead of tone dial, change the Hayes Dial Prefix command from 
ATDT to ATDP. 

For more information about these commands, see your modem manual. 

4. Choose the OK button. 

If you modify the commands incorrectly, you can reset them to the standard 
commands by selecting the appropriate modem type again. 

Entering a Phone Number 
When you choose the Dial command from the Phone menu, Terminal dials a 
phone number to connect to the remote computer. You can specify the number 
for Terminal to dial by choosing the Phone Number command from the Settings 
menu. 
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~ To specify the phone number you want Terminal to dial 

1. From the Settings menu, choose Phone Number. 

The Phone Number dialog box appears. 

I.imeout If Not Connected In ~ Seconds 

D Redial After Timing Out D .s.ignal When Connected 

2. In the Dial box, type the phone number you want Terminal to dial. You can 
type parentheses and dashes, but they are not required. Type commas to provide 
any delays required before the number is processed by the telephone system. 
If you are using a Hayes-compatible modem with the default settings, each 
comma inserts a delay of approximately 2 seconds. If you are not using a 
Hayes-compatible modem, the delays or the character that creates delays may 
be different. 

For Hayes-compatible modems, the following string first dials a 9, then pauses 
for 4 seconds before dialing the number: 

9,,1-800-555-1212 
3. Set the options you want. 

4. Choose the OK button. 

A description of each option follows. 

Use 

Timeout If Not Connected In 

Redial After Timing Out 

Signal When Connected 

To 

Increase the number of seconds Terminal waits for a 
connect signal from the remote computer (30 seconds 
is the minimum waiting time). If a remote modem is 
busy with other calls or is being serviced, it may not 
answer immediately. 

Dial the phone number again if the previous attempt 
did not result in a connection. 

Ring the system bell (beep) when a successful connec­
tion to the remote computer has been made. If you are 
likely to be away from the computer, the bell can be a 
helpful reminder. 

If you want to save phone number settings for a future communications session, 
you must save them in a settings file. For information, see "Saving a Settings File" 
later in this chapter. 
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Setting Terminal Emulation 
U sing Terminal, your computer can emulate the terminal type required by the 
remote computer. You specify the terminal type by using the Terminal Emulation 
command. 

~ To specify the terminal-emulation type 

1. From the Settings menu, choose Terminal Emulation. 

The Terminal Emulation dialog box appears. 

The terminal types displayed are the most common ones used by the large, 
mainframe computers that host online services. If you are not sure which 
terminal to use, select the DEC VT-I00 (ANSI) option button. 

2. Select a terminal type, and then choose the OK button. 

Note To use the function keys for DEC VT -100 (ANSI) terminal emulation, 
SCROLL LOCK must be turned on. If SCROLL LOCK is turned off, the function keys 
and arrow keys have normal Windows (not VT-I00) functionality. 

After you confirm your selection, Terminal adjusts your system so that your 
computer, keyboard, and terminal perform just as the specified terminal does. 
For example, if you selected TTY, the remote system receives formatting codes 
for the carriage return, backspace, and tab characters only. 

For information about how the various configurations compare with the behavior 
of the IBM PC keyboard, see the "VT-52 Terminal-Keyboard" and "VT-I00 
Terminal-Keyboard" tables in Appendix B, "Terminal Emulation Tables." 

Specifying Terminal Preferences 
You can specify how your terminal performs during a communications session by 
using the Terminal Preferences command. You do not have to specify Terminal 
Preference settings for Terminal to work properly with the remote computer, but 
the settings can improve the format of the data you receive and send. 
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~ To specify terminal preferences 

1. From the Settings menu, choose Terminal Preferences. 

The Terminal Preferences dialog box appears. 

[:gI Show Scroll Bars Buffer Lines: ~ 

D Use FunctionArrow,and t.trl Keys for Windows 

2. Select the options you want, and then choose the OK button. 

A description of each option follows. 

Use 

Line Wrap 

Local Echo 

Sound 

Columns 

To 

Wrap incoming characters that exceed the column width of your 
monitor onto the next line. For example, if the host computer 
uses 132-column lines and you have an 80-column monitor, 
select this option. When Line Wrap is not selected, you can view 
incoming characters to the right of your monitor's column by 
using the scroll bars. 

Display the data that you are sending to the remote computer on 
your screen as you type. The remote system may operate in half 
or full duplex. Half-duplex systems cannot echo your keystrokes 
to your screen. Full-duplex systems can echo your typing. 

If the remote system can echo your typing (known as remote 
echo), do not select this option. If the remote system is not 
configured for remote echo, select this option to display the 
outgoing characters as you type them. 

Tum on your computer's bell (or beep) so that it makes a sound 
when instructed to by the remote computer. 

Specify your monitor type-the common 80-column monitor or 
the wide I 32-column monitor. You can specify 132 if you want 
an 80-column monitor to work as though it were a wide monitor, 
and vice versa. If you specify 132, Terminal reserves 132 
columns for text even if 132 columns are not entered or received. 
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Use 

Tenninal Font 

Show Scroll Bars 

CR->CRlLF 

Cursor 

Translations 

IBM to ANSI 

Buffer Lines 

Use Function, 
Arrow, and CTRL 
Keys for Windows 

To 

Select the font and font size (point size) to use for displaying 
both the outgoing characters you type and the incoming data on 
your screen. 

Display the scroll bars. Scroll bars are useful for reviewing 
infonnation you have typed or received that does not fit on your 
screen. 

Specify each carriage return as a carriage return plus a linefeed. 
Linefeeds move text on a printer or monitor down one line, 
whereas carriage returns may only move the print head or cursor 
to the left margin (depending on the computer type). Before 
selecting this option, you need to know whether the remote 
computer already sends linefeeds. 

You can select Inbound, Outbound, both, or neither. If you select 
Inbound, carriage returns coming from the remote computer are 
interpreted as carriage returns followed by linefeeds. If you select 
Outbound, carriage returns are sent to the remote computer as 
carriage returns followed by linefeeds. 

Specify the shape, block or underline, of the cursor and whether 
or not it blinks. 

Specify a country for sending and receiving data in another 
language. By selecting a country name, you specify which 
International Standards Organization (ISO) character set to use. 
Make sure that the host computer recognizes the character set for 
the country you select. 

Receive infonnation that includes accented or extended 
characters so that they are correctly displayed on your screen. 

Specify how much incoming data is saved in the buffer. You can 
set the buffer to store from 25 to 399 lines of infonnation if you 
are using Tenninal in 80-column mode, or from 25 to 244 lines 
of infonnation if you are using Tenninal in 132-column mode. 
If you specify more lines than will fit in the available memory, 
Tenninal sets the buffer to the largest number of lines that the 
memory can accept. If you type fewer than 25 lines, Tenninal 
reserves 25 lines. 

Specify whether the function, arrow, and CTRL keys are recog­
nized by Windows or by the host computer. If this option is 
selected, these keys are recognized by Windows. If this option 
is not selected, these keys are passed to the host computer and 
will perfonn the tasks that they are designed to perfonn by the 
software you are using on the host. If you use CTRL+C frequently 
on a host system, you should clear this option. 
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Assigning Commands to Function Keys 
In Terminal, you can assign frequently used commands to function keys. For 
example, instead of typing a command that performs a common task-such as 
dialing a remote computer, or specifying your logon name and password each time 
you use Terminal-you can assign the command to a function key and then just 
press CTRL+ALT+junction key to quickly carry out the command. 

To assign commands to function keys, you first assign a name to the key that 
describes the task the key will perform. This step is optional, but it helps you 
keep track of the tasks you assign to the function keys. Then you assign the com­
mand(s) to the key. You assign commands to a function key by entering control 
codes that carry out specific Terminal commands, or by typing numbers or text to 
specify time delays or passwords. Each command can contain up to 41 characters. 

For example, you may regularly type a logon command sequence that connects 
you to a remote computer. You can assign the command sequence to a function 
key, and name the function key "Logon." A sample logon command sequence 
might be: 

A$CA$D03A M A$D02mynameA M A$D04passwordA M 

where myname represents your logon name or user ID, and password represents 
your password to the remote computer. The commands would perform these 
actions in the following order: 

1. Dial the number that you specified from the Settings menu (A$C). 

2. Wait 3 seconds (A$D03). 

3. Send a carriage return (AM). 

4. Wait 2 seconds (A$D02). 

5. Send your logon name to the remote computer (myname). 

6. Send a carriage return (AM). 

7. Wait 4 seconds (A$D04). 

8. Send your password (password). 

9. Send a carriage return (AM). 

The delays are required to give the remote computer enough time to respond with 
prompts. For example, an online service would prompt you to enter your logon 
name. 
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To keep track of the commands you have assigned to different function keys, you 
can display the function-key names along the bottom of the Terminal window. 

If you are using a mouse, you can quickly choose the command or sequence 
of commands that you want to carry out by simply clicking the appropriate 
function-key name. 

Function-key assignments are organized into four different levels. You can assign 
up to eight function keys per level. This means that each function key can be 
assigned up to four different functions, and the function that is carried out depends 
on which key level you have selected. You might want to group the eight function 
keys you use most often in Level I, the ones you use less often in Level 2, and so 
on. 

~ To assign commands to function keys and specify key levels 

1. From the Settings menu, choose Function Keys. 

The Function Keys dialog box appears. 

Key Name: Command: 

Fl: 
Fl.: ~==~:===========: 

Fl: :===~:=======~ 
F!: :======::==========: 
F~: 

Fli: ~==~:===========: 

FI: ~==~~======~ 
F.!t: o Keys ~isible 
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2. In the Key Level area of the Function Keys dialog box, select the key level. 

3. In the respective Key Name box, type a name for each function key you want 
to specify. 

For example, you could enter type hello as the name of a prompt command. 

Names are optional. 

4. In the corresponding Command box, type the code(s) or text such as a pass­
word that you want included in the command. 

For example, you could type hello in the Command box that corresponds to 
the Type Hello key name. A list of the control codes you can enter follows this 
procedure. 

5. Repeat steps 2 through 4 to define another level. 

6. To display the function-key pad along the bottom of the Terminal window, 
select the Keys Visible check box. 

7. When you are finished defining all the key levels you want, choose the 
OK button. 

You can assign these control codes to function keys to perform the following 
tasks. 

Control code 

AA 

Action 

Sends control code A through control code Z to the remote 
computer. 

Causes Terminal to delay for nn seconds before continuing. 

Causes Terminal to transmit a break code of 117 milliseconds in 
duration. 

Causes the same action as choosing Dial from the Phone menu. 

Causes the same action as choosing Hangup from the Phone menu. 

Changes to another key level or group of assigned function keys. 

Sends a caret (A) to the remote computer. 

Sends a NULL character to the remote computer. 

Sends one or more escape-code sequences to the remote com­
puter, where n is a variable representing one or more codes. 
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Carrying Out Commands Assigned to Function Keys 
Once you have assigned commands to function keys, you can carry them out 
quickly. 

~ To carry out commands assigned to function keys 

Mouse 

1. If you have assigned commands to several key levels, click the Level button at 
the bottom of the Terminal window until the name for the command you want 
to carry out is displayed on the function-key pad. 

2. Click the name of the command displayed on the function-key pad. 

Keyboard 

• Press CTRL+ALT+function key. 

For example, if the command you want to carry out is assigned to F4, press 
CTRL+ALT+F4. 

Showing and Hiding Function Keys 
You can keep the function-key pad from appearing at the bottom of the Terminal 
window, even if you have selected the Keys Visible check box. 

~ To hide the function-key pad 

• From the Settings menu, choose Hide Function Keys. 

The command changes to Show Function Keys. 

To show the function keys, select the command again. 

Timing Sessions with Timer Mode 
When the function-key pad is displayed (by using the Show Function Keys com­
mand), a timer box in the lower-right comer of the Terminal window also displays 
the system time. You can use this timer box to time your Terminal sessions. 
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When you choose the Timer Mode command from the Settings menu, the timer 
is set to 00:00:00. Terminal then tracks how long you have been connected to the 
remote computer. That way, you can monitor the length of your hook-up time and 
avoid charges you did not anticipate. 

~ To time your communications sessions 

• From the Settings menu, choose Timer Mode. 

When the timer function is active, the Timer Mode command is preceded by a 
check mark. 

~ To reset the timer 

• From the Settings menu, choose Timer Mode again. 

For more information about these commands, see your hardware manual. 

Connecting to the Remote Computer 
Once you specify the settings for a session or open a Settings file, you can use 
Terminal to call the remote system. Terminal uses the phone number and dialing 
information specified with the Phone Number command on the Settings menu, or 
prompts you to supply the information. 

~ To connect to the remote computer 

• From the Phone menu, choose Dial. 

Terminal begins dialing the number. If you did not specify a number by using 
the Phone Number command on the Settings menu, the Phone Number dialog 
box appears. For more information, see "Entering a Phone Number" earlier in 
this chapter. 

Note If your modem is dialing but you cannot get through to the remote computer, 
you might not have specified the correct communications settings for the remote 
computer. For more information, see "Specifying Communications Settings" 
earlier in this chapter. 
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Transferring Files 
Once you have called another computer and the communications link is 
established, you can send or receive text or binary files. Before transferring 
files, make sure that both your modem and the remote modem are using the 
same settings for the following: 

• Data bits 

• Parity type (none, odd, even, mark, and space) 

• Stop bits 

• Flow control 

For more information about the communications settings, see "Specifying 
Communication Settings" earlier in this chapter. 

Setting Up a File Transfer 
Before you send or receive files by using co~ands on the Transfers menu, you 
can specify the transfer rules. You should do sb only if you plan to send or receive 
binary files. It is not necessary to specify these rules for reading or sending elec­
tronic mail or text files. 

Textfiles are prepared with a text editor or word-processing application (such as 
Notepad or Write) and saved unformatted. This type of file is also known as an 
ASCII file and contains only the printable ASCII characters and the few control 
codes needed for minimal formatting, such as carriage returns and linefeeds. 

Binary files can be any kind of files, including executable program files, formatted 
document files, or ASCII files. These files are not converted or translated during 
the transfer process. If you intend to transfer program files, you must use a binary 
transfer. 

The two methods of transfer-text and binary-differ in a number of ways. 
In general, it is preferable to send both text and binary files by using the binary 
transfer method. This method checks more rigorously for errors and loss of data. 
However, if you do not need to send formatting codes and you are not worried 
about the loss of data, the text transfer method can be faster. Other significant 
differences between text and binary transfers are summarized here. 



Binary transfers 

Automatic retransmission if an error is 
detected. 

Suitable for use with any type of file. 

Protocol (XModemlCRC or Kermit) on 
each system makes system type irrelevant. 

Parity is usually not used for error-checking. 

Transfer of entire file contents only. 
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Text transfers 

Possible suspension of transmission if 
an error is detected. 

Suitable for use with ASCII text files 
only. 

Lack of protocol makes system 
specifics important. 

Parity can be used to detect character­
transmission errors. 

Transfer of entire or partial file 
contents. 

Note When communicating with a system that does not recognize either of the 
binary protocols supported by Terminal (XModemlCRC or Kermit), you cannot 
transfer binary files. In this case, only text transfers are supported. 

Preparing to Transfer a Text File 
Text files contain ASCII text, with font, style, and size specifications stripped 
out. Because most applications can work with text alone, this format is useful for 
transfers between vastly different systems. 

~ To prepare for text-file transfers 

1. From the Settings menu, choose Text Transfers. 

The Text Transfers dialog box appears. 

Transfer Using Standard Flow Control 
Selected Flow Control Method: XonlXoff 

D Word ~rap Outgoing Text at Column: 

Use the Communications command to 
specify the flow-control method. 

2. Select the options you want to specify, and then choose the OK button. 



396 Microsoft Windows User's Guide 

A description of each option follows. 

Use 

Standard Flow Control 

Character At A Time 

Line At A Time 

To 

Use the flow-control method you chose with the 
Communications command. For more information, 
see "Specifying Communications Settings" earlier in 
this chapter. 

Specify that text files be sent one character at a time. 
Choosing this option displays these additional options 
in the center of the dialog box: 

Delay Between Characters 

Transmits characters evenly and slowly enough to prevent 
errors. However, there is no true verification of the trans­
mitted data, and no feedback comes from the remote 
system. You can set the delay by typing a value in the 
110 Sec box. 

Wait For Character Echo 

Sends one character (8 bits) at a time and then waits for 
the remote computer to echo the character back. Terminal 
verifies that the two characters are the same before sending 
the next character. The transfer continues in this manner 
until every character in the file has been sent. This method 
is extremely slow and should be used only with a system 
that echoes characters reliably. 

Specify that text be sent one line at a time. If you select 
this option, these additional options appear: 

Delay Between Lines 

Transmits lines evenly and slowly enough to prevent 
errors. However, there is no true verification of the 
transmitted data, and no feedback comes from the 
remote system. You can set the delay by typing a 
value in the /1 0 Sec box. 

Wait For Prompt String 

Sends one line, and then waits until the remote system 
sends a verification string (a message) back to Terminal 
before sending the next line. 

Terminal can automate this process if you specify what 
string of characters you want the remote system to send 
before Terminal sends the next line. 

This method is faster than character echoing and works 
better if your remote character echo is unreliable. You can 
find this out by experimenting or by contacting the admin­
istrator of the remote system. 
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Use To 

Word Wrap Outgoing 
Text At Column 

Use this option if the files you want to send were created 
with a text editor or word-processing application. You can 
specify a column up to 132 characters wide, regardless of 
the size of your terminal. If this option is not selected, out­
going text will be sent as it is currently formatted. To send 
a file to a 132-column terminal, type 131 after selecting 
the check box. Reducing the column size by 1 leaves one 
character space for the end-of-line code (usually "M). 

Preparing to Transfer a Binary File 
Whereas text transfers require you to know the appropriate settings for the remote 
computer, binary transfers rely on standard protocols (sets of rules) for data trans­
mission. You must specify only the protocol the remote computer uses. Terminal 
gives you the choice of two common protocols-XModemlCRC and Kermit. 

~ To prepare for a binary transfer 

1. From the Settings menu, choose Binary Transfers. 

The Binary Transfers dialog box appears. 

@ :&~:~~~~Z~:f.!.~] 
o !.ermit 

2. Select the protocol you want to use, and then choose the OK button. 

You can use these options to perform the following tasks. 

Use 

XModemlCRC 

Kermit 

To 

Specify the XModemlCRC binary protocol, which uses all 8 bits 
as data bits, and thus requires the Parity option to be set to None. 
If the Parity option is not set to None, Terminal will set it to None 
automatically. If you specify 7 bits as data bits and the remote 
computer can reconfigure a 7 -bit path to 8 bits, Terminal will auto­
matically convert the number of data bits and the parity during the 
transfer. 

Terminal initially uses the cyclic redundancy check (CRC) scheme 
for error-checking. If the remote system does not support CRC, 
Terminal automatically switches to the checksum scheme. 

Specify the Kermit protocol, which can use either 7 or 8 bits as 
data bits; thus, Parity can be specified as Even, Odd, or None. 
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Sending a Text File 
If you specified the settings for text transfers by using the Settings menu, you are 
ready to send your file. You can use the Send Text File command on the Transfers 
menu to send files you have saved in ASCII (text) format. 

~ To send a text file 

1. From the Transfers menu, choose Send Text File. 

The Send Text File dialog box appears. 

Select or type the name of 
the file you want to send. 

Or select a drive letter 
or directory name. 

Following CR: 

'---------' ..... D APpend LF 
List Files of !.I'pe: Driyes: (:gJ Strip LF 
I~T_eK_tf_ile~s(_·.T_X~T) __ ~II ..... ' ~I~=-c:-c-hri-s--~II~'\ -

2. In the Directories area, select the drive and directory where the file you want to 
send is located, if it is not in the current drive or directory. 

3. From the File Name list, select the file you want to send, or type the name in 
the text box. 

4. To attach a linefeed to the end of each line of the text you send, select the 
Append LF check box. To strip out linefeeds in the text you send, select the 
Strip LF check box. 

If the remote system adds linefeeds to incoming text, you may need to strip 
them out. For more information about linefeeds, see the CR To CR/LF option 
under "Specifying Terminal Preferences" earlier in this chapter. 

5. Choose the OK button to begin sending the file. 

You will see the file contents scroll in the Terminal window. 
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~ To control transmission of your file 

• Choose from the Pause, Resume, or Stop buttons at the lower edge of the 
Terminal window, or choose a command from the Transfers menu. 

Receiving a Text File 

Stops transmission 
Pauses transmission and then changes to Resume 

Shows the name of the file being sent 
Shows how much of the file has been sent 

If you specified the settings for text transfers by using the Settings menu, you are 
ready to receive a text file. If you want to save the incoming information to a file, 
use the Receive Text File command on the Transfers menu. You can create a new 
text file, append incoming information to an existing file, or replace an existing 
file with the incoming information. Be sure to choose the Receive Text File 
command before actually receiving the information. 

~ To receive a text file 

1. From the Transfers menu, choose Receive Text File. 

The Receive Text File dialog box appears. 

memo. txt 
notes. txt 
setup. txt 

r- 0 APpend File 
L--_____ --"ITIfj .... , 0 Save 

List Files of lYpe: Drives: 0 Table Format 
I~T_ex_tf_ile~s(_*_T_X~T) __ ~II_' ~1~~--c:-c-hr--ls----~II=7" -

Select the drive and directory where you want to store the file or where the file 
you want to append to or replace is located. 
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2. To append to or replace an existing file, select the file from the File Name list. 
To create a new file, type a filename in the text box. 

3. Select any or all of the boxes at the lower-right comer of the dialog box. Then 
choose the OK button. The following table describes the options. 

Use 

Append File 

Save Controls 

Table Format 

To 

Add incoming information to the end of the specified file instead 
of replacing it. 

In the File Name box, specify the file you want to append the 
incoming information to. 

Save all of the formatting codes in an incoming text file. Many 
applications, such as word-processing or spreadsheet programs, 
provide you (or the sender) with an option to save files as text. 
This means most of the formatting codes are stripped out of the 
file, enabling it to be sent as a text file. (However, a file may 
retain some formatting codes.) If you select this option, those 
formatting codes are received by your system. 

Receive the incoming text in a tabular format. Terminal puts tab 
characters between incoming text that is separated by two or 
more consecutive spaces. 

~ To control transmission of the incoming file 

• Choose from the Pause, Resume, or Stop buttons at the lower edge of the 
Terminal window, or choose a command from the Transfers menu. 

Stops transmission 
Pauses transmission and then changes to Resume 

Shows the name of the file being received 
Shows the number of bytes received 
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Viewing a Text File 
If you want to look at a text file before sending it or after receiving it, use the 
View Text File command. 

~ To view a text file 

1. From the Transfers menu, choose View Text File. 

The View Text File dialog box appears. 

Select or type the name of 
the file you want to view. 

Or select a drive letter 
or directory name. 

Following CR: 

'---_____ -liiiiiiiI 0 BPpend lF 
list Files of !ype: Dri~es: D Strip lF 
~IT_eK_tf_ile~s(Z_.T_X~T)_~II_:' I~~=-c:-c-hri-s----~II= -

2. In the Directories area, select the drive and directory where the file you want 
to view is located, if it is not in the current drive or directory. 

3. From the File Name list, select the file you want to view, or type the name. 

4. To attach a linefeed to the end of each line of the text you send, select the 
Append LF check box. To strip out linefeeds in the text you send, select the 
Strip LF check box. 

If you already specified linefeeds when you received the file, you might want 
to ignore these options. For more information about linefeeds, see the CR To 
CR/LF option under "Specifying Terminal Preferences" earlier in this chapter. 

5. Choose the OK button to view the specified file. 

The file contents scroll in the Terminal window. The same buttons appear along 
the lower edge of the window as when you send a text file. 
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~ To control how the file is displayed 

• Choose the Pause, Resume, or Stop button. 

Sending a Binary File 
You can use the Send Binary File command on the Transfers menu to send a file 
in binary format. The file is sent according to the protocol specified by using the 
Binary Transfers command on the Settings menu. 

~ To send a binary file 

1. Signal the remote computer to prepare to receive a binary file, and then indicate 
the type of protocol to use (XModemlCRC or Kermit). 

2. From the Transfers menu, choose Send Binary File. 

The Send Binary File dialog box appears. 

Select or type the name of 
the file you want to send. 

list Files of !vpe: Drives: 

,-lA_II f_ile-,s(,-Z_ z.c-) __ ---'11 ..... 1 I Iii! c: chris II 

Or select a drive letter 
or directory name. 

3. In the Directories area, select the drive and directory where the file you want to 
send is located, if it is not in the current drive or directory. 

4. From the File Name list, select the file you want to send or type the name in the 
text box. 

5. Choose the OK button. 
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The file transfer begins, and the name of the file being transferred appears along 
the lower edge of the Terminal window. A Stop button also appears. 

Stops transmission 

~ To end the file transfer 

Shows the name of the file being sent 
Shows how much of the file has been sent 

• Choose the Stop button. 

You cannot pause or resume a binary-file transfer, so these buttons and commands 
are not available. 

If Terminal is running as an icon during a binary send, the icon flashes when the 
transfer is either completed or fails. To continue your communications session, 
restore Terminal to a window. 

Note If you are having trouble sending a binary file, you might have specified a 
transfer protocol that the remote system does not use. To change the protocol, use 
the Binary Transfers command. For more information, see "Setting Up a File 
Transfer" earlier in this chapter. 

Receiving Binary Files 
The Receive Binary File command on the Transfers menu prepares Terminal to 
receive a file in binary-file format, according to the protocol specified with the 
Binary Transfers command on the Settings menu. 

~ To receive a binary file 

1. Signal the remote computer to send a binary file, and then indicate the type of 
protocol to use (XModemlCRC or Kermit). 

2. From the Transfers menu, choose Receive Binary File. 

The Receive Binary File dialog box appears. 

3. Select the drive and directory where you want to store the file or where the file 
you want to replace is located. 
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4. To replace an existing file, select the file from the File Name list. To create a 
new file, type a filename in the text box. 

If you select an existing file from the File Name list, Terminal requests 
verification that you want to replace the existing file with the incoming one. 

5. Choose the OK button. 

The file transmission begins. Terminal displays the name of the binary file being 
received, the amount of the file already received, and a Stop button. 

Stops transmission 

Shows the name of the file being received 
Shows the number of bytes received 

~ To stop the file transfer 

• Choose the Stop button. 

You cannot pause or resume a binary-file transfer, so those buttons and commands 
are not available. 

Occasionally, a communications error prevents the successful transfer of data. 
When this occurs, the remote system will try again. The Retries box at the bottom 
of the Terminal window displays the number of times the remote system has tried 
to send the data. The maximum number of retries for the XModemlCRC protocol 
is 20. The maximum number of retries for the Kermit protocol is 5. When the 
maximum number of retries has been reached, Terminal cancels the file transfer. 

If Terminal is running as an icon during a binary receive, the icon flashes when 
the transfer is complete (or if the transfer fails). To continue your communications 
session, restore Terminal to a window. 

Note If you are having trouble receiving a binary file, you might have specified a 
transfer protocol that the remote system does not use. To change the protocol, use 
the Binary Transfers command. For more information, see "Setting Up a File 
Transfer" earlier in this chapter. 
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Working with Text in the Terminal Window 
Using commands on the Edit menu, you can modify the contents of the Terminal 
window. You can also send, save, append, or clear the text in the Terminal 
window. Descriptions of the tasks you can perform by using the Edit menu follow. 

Copying Text onto the Clipboard 

~ To copy text onto the Clipboard 

1. Select the text you want to copy. 

2. From the Edit menu, choose Copy. 

Once a selection is copied, you can insert it by using the Paste command. 

Sending Clipboard Contents 
When you paste text from the Clipboard, Terminal sends a copy of the Clipboard 
contents to the remote system. The contents of the Clipboard remain unchanged. 

~ To send the contents of the Clipboard to a remote system 

• From the Edit menu, choose Paste. 

Sending Selected Text 
You can use the Send command to send selected text to the remote system. This 
command is equivalent to choosing the Copy and Paste commands. 

~ To send selected text to a remote system 

1. Select the text you want to send. 

2. From the Edit menu, choose Send. 

Se lecting All Text 
U sing the Select All command has the same result as selecting the entire contents 
of the Terminal buffer by using the mouse or keyboard. After selecting the text, 
you can copy or send it. 

~ To select all the text in the Terminal window and scroll buffer 

• From the Edit menu, choose Select All. 
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Clearing the Buffer 

Printing 

When you type or receive more text than can fit in the window, Terminal places 
that text into a buffer. By using the scroll bars, you can scroll forward and back­
ward to see text you've already typed or received. You might want to clear the 
buffer to free memory. 

~ To clear the contents of the scroll buffer and the window 

• From the Edit menu, choose Clear Buffer. 

Terminal removes the contents of the Terminal window and any text in the 
buffer. 

You can print text (either incoming files or a communications session) in two 
ways: You can save the text currently in the scroll buffer to a file and print it 
from another application such as Write; or you can tum on Printer Echo to have 
incoming text go directly to a printer in addition to your screen. 

SeHing Up the Printer 
If you have connected and installed a printer, you can print text from Terminal. 
For information about installing a printer, see Chapter 6, "Print Manager." 

Printing Incoming Text 
You can use the Printer Echo command on the Settings menu to specify whether 
or not to send incoming information to the printer. When Printer Echo is on, 
all information received by Terminal is sent to the printer. If you want to print 
incoming text while you are receiving it, choose this command before receiving 
the information. 

~ To print incoming text 

• From the Settings menu, choose Printer Echo. 

A check mark appears next to the Printer Echo command, indicating that all 
incoming text is being sent directly to the printer. 
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If the incoming text is less than a page long, you can eject the partial page from 
the printer. 

~ To eject a page from the printer 

• From the Settings menu, choose Printer Echo again. 

Printing Selected Text 
If you want to print selected text from the Terminal window or scroll buffer, it is 
best to wait until you are ready to end your communications session. 

~ To print text you have received or entered 

1. Select the text you want to print. 

If you want to select the entire contents of the window and scroll buffer, 
choose Select All from the Edit menu. 

2. From the Edit menu, choose Copy to place the selected text on the 
Clipboard. 

3. Start a word-processing or text-editor application-preferably a 
Windows-based application such as Write or Notepad. 

4. Paste the contents of the Clipboard into a text file. 

5. Use the application's Print command to print your selection. 

Ending Your Communications Session 
To end a communications session, you save the settings file (if you want to use 
these settings again), disconnect from the remote computer, and quit Terminal. 

Saving a Settings File 
You can save Terminal settings so that you can use them again for the next 
communications session. 

~ To save the settings file 

• From the File menu, choose Save. 

If you have not saved the settings before, a dialog box appears in which you can 
specify the drive, directory, and filename where you want to store your settings 
file. Terminal assigns the extension .TRM to the file if you do not specify an 
extension. You can choose Save As to save the settings under a new filename 
or to replace an existing file. 
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Disconnecting from the Remote Computer 
Disconnecting from the remote computer is an important step in ending your 
Terminal session. 

~ To disconnect from the remote computer 

1. Type the exit command specified by the remote system-typically, bye. 

This command hangs up the remote modem. 

2. From the Phone menu, choose Hangup to hang up your modem. 

Caution It is important to signal the remote computer with an exit command 
before choosing Hangup. If you do not know the exit command assigned for the 
service you are using, see the manual that came with your service package. If 
you choose Hangup first, you disconnect from the remote computer, but its phone 
connection remains off the hook. Your account might continue to be charged for 
connect time until the remote system detects that the connection has been dropped. 

Quitting Terminal 
You can end a communications session by quitting Terminal and returning to the 
Program Manager window. 

~ To quit Terminal 

1. From the File menu, choose Exit. 

2. If you made changes to the current settings file without saving, Terminal 
will ask if you want to save the changes, abandon the changes, or cancel your 
request to quit Terminal. 

3. Choose the appropriate button. 



Additional Accessories 

Calculator 

Chapter 12 

Windows Calculator includes both a standard calculator and a scientific calculator. 
The standard calculator allows you to do simple calculations and store them in 
memory. The scientific calculator allows you to do advanced scientific and 
statistical calculations. 

Both calculators work the same way, so you might want to skim the standard 
calculator section even if you plan to use only the scientific calculator. 

~ To start Calculator 

• In the Accessories group, choose the Calculator icon. 

If you are starting Calculator for the first time, the standard calculator appears. 

These buttons enable you to 
edit the numbers in the display . 

.Edit ~iew !!elp 

These buttons enable you to 
use Calculator's memory. 

This is where Calculator 
displays numbers. 

These are the basic 
mathematical operators. 
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The next time you start Calculator, the last calculator that you used-standard or 
scientific-appears. 

You cannot resize the Calculator window. However, you can reduce Calculator 
to an icon so that it is readily available when you want to perform calculations. 

Performing Calculations 
Calculator is easiest to use with the mouse-just point to a Calculator button 
and click it. You can also use the keyboard, using corresponding keys for each 
Calculator button. (For information about the keyboard equivalent for each Cal­
culator function, see "Standard Calculator Functions" or "Advanced Calculator 
Functions" later in this chapter.) For simple calculations, you can use the numbers 
and basic operators (such as +, -, *, /, =) on your keyboard or numeric keypad. 
(The NUM LOCK key must be active before you can use the numeric keypad.) 

~ To perform a simple calculation 

1. Enter the first number in the calculation. 

The number appears in the Calculator display area. 

2. Choose the operator you want to use in the calculation. 

For information about which operator to use, see "Standard Calculator 
Functions" later in this chapter. 

3. Enter the next number in the calculation. 

If you make a mistake, choose the BACK button (or press the BACKSPACE key) to 
correct a few digits, or choose the CE button (or press DEL) to clear the entire 
number. 

4. Enter any remaining numbers and operators. 

5. Choose the equal sign ( =) button. 

Or press = (equal sign) or ENTER. 

The result appears in the Calculator display area. 

If you make a mistake and want to restart a calculation, choose the C button 
(or press ESC) to clear the entire calculation from Calculator. 
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Using Calculator Memory 
Calculator has its own memory, where you can store a value for future use. The 
following illustration shows the buttons that work with Calculator memory. 

Displays the value stored in memory. 
Clears any value stored in memory. 

1m Calculator II 
.Edit ~iew Help 

-+---+- An M appears here 

Adds the displayed value to any 
value already in memory. 

Stores the displayed value in memory. 

when a value is 
stored in memory. 

When you store a value in memory, the letter M appears in the box below the 
Calculator display area. 

If you store a zero in memory or if a value that you add to memory causes the 
value there to equal zero, M disappears from the box below the Calculator display 
area. If you store another value in memory by using the MS button, that value 
replaces any value currently in memory. 

If you don't have a mouse, you can use the memory functions by using the key­
board. For information, see "Standard Calculator Functions" later in this chapter. 
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Using Calculator with the Clipboard 
U sing the Clipboard, Calculator can supply calculated results to other applications 
and perform calculations on values supplied by other applications. You can use 
Calculator with any application with which you can use the Clipboard. 

~ To copy the value in the display area onto the Clipboard 

• From the Edit menu, choose Copy. 

You can now paste the value into any application with which you can use the 
Clipboard. 

~ To paste a number from the Clipboard into the display area 

1. If you're using the scientific calculator, select a number system. 

2. From the Edit menu, choose Paste. 

Calculator interprets most characters on the Clipboard as if they were typed on 
the keyboard. When you paste from the Clipboard, however, Calculator interprets 
some characters as key sequences or function keys. The following table describes 
the meaning of these characters. 

Characters 

:c 

:e 

:m 

:p 

:q 

:r 

\ 

Meaning in pasted text 

Clears any value stored in memory. Equivalent to CTRL+L. 

Allows entry of numbers in scientific notation in decimal mode. 
This character can optionally be followed by a plus ( + ) or minus (-) 
sign to indicate the sign of the exponent. The plus sign will not work 
if the character is preceded by a colon (:). If no sign is present, then 
+ is assumed. 

Also specifies the number "E" in hexadecimal mode. 

Stores the displayed value in memory. Equivalent to CTRL+M. 

Adds the displayed value to any value in memory. Equivalent to 
CTRL+P. 

Clears the current calculation. Equivalent to the ESC key and the 
C button. 

Displays the value stored in memory. The value also remains in 
memory. Equivalent to CTRL+R. 

Same as the Dat button, which is normally assigned to the INS key. 
You must activate the Statistics Box before using this key. 
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Standard Calculator Functions 
The following table describes each key on the standard calculator, its keyboard 
equivalent, and its function. 

Button Key 

+ + 

* * 
/ / 

sqrt @ 

% % 

lIx r 

= or ENTER 

+/- F9 

. or, 

Back BACKSPACE or 
LEFT ARROW 

CE DEL 

C ESC 

MC CTRL+L 

MR CTRL+R 

MS CTRL+M 

M+ CTRL+P 

Using the Scientific Calculator 

Function 

Adds. 

Subtracts. 

Multiplies. 

Divides. 

Calculates the square root of the displayed value. 

Calculates percentages. 

Calculates the reciprocal of the displayed number. 

Performs any operation between the previous two 
numbers. Choose again to repeat the last operation. 
(For example, 4 + 2 = 6. Pressing = again calculates 
8; again calculates 10; and so on.) 

Changes the sign of the displayed number. 

Inserts a decimal point in the displayed number. The 
period is the standard setting for a decimal separator. 
You can change the decimal separator setting 
by using Windows Control Panel. 

Deletes the rightmost digit of the displayed number. 

Clears the displayed number. 

Clears the current calculation. 

Clears any value stored in memory. 

Displays the value stored in memory. The value also 
remains in memory. 

Stores the displayed value in memory. 

Adds the value that is displayed to any value in 
memory. 

The scientific calculator can perform simple, standard mathematical calculations 
or scientific and statistical calculations. This calculator can also calculate in the 
binary, octal, and hexadecimal number systems in addition to the decimal system 
that we ordinarily use. 



414 Microsoft Windows User's Guide 

~ To use the scientific calculator 

• From the View menu, choose Scientific. 

The scientific calculator appears. 

These buttons indicate the 
number system you want to use. 

;; Galeula1o( II 
Edit Y:iew Help 

o. Values appear here. 
~--------------------~ 

I @ Oeg 0 Rad 0 Grad I 

You perform a simple calculation on the scientific calculator the same way you 
perform a simple calculation on the standard calculator. For information, see 
"Performing Calculations" earlier in this chapter. The following topics provide 
information that applies only to the scientific calculator. 

Working with Different Number Systems 
When you start the scientific calculator, it is set to work in the decimal number 
system-the base 10 system that we are accustomed to. This calculator can also 
work in the binary, octal, and hexadecimal number systems. 

When you enter values into the scientific calculator, it accepts only values that are 
valid for the number system you have selected to work in. For example, if you 
are working in the hexadecimal number system, B is a valid entry, but if you are 
working in the decimal number system, B is not. 
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Converting a Value to Another Number System 
The scientific calculator can convert most values that you are currently working 
with to any of the other available number systems. The following table lists the 
valid ranges for converting numbers. 

Number system 

Hexadecimal 

Decimal 

Octal 

Binary 

Range 

-231-1 to 231-1 

-9.999999999999ge-307 to 9.999999999999ge+307 
-231-1 to 231_1 

-231 _1 to 231_1 

~ To convert a value to another number system 

1. Enter the value you want to convert. 

2. Select the option button for the number system you want to convert 
to-Hex, Dec, Oct, or Bin. 

3. Select the unit of measurement you want Calculator to use to display the result. 

When converting to hexadecimal, octal, or binary numbers, you can select 
the Dword, Word, or Byte option button. For more information about these 
settings, see "Advanced Calculator Functions" later in this chapter. 

The value resulting from the conversion appears in the display area. 

If you convert a decimal number containing decimal places to another number 
system, Calculator shortens the number to its integer. Numbers converted from the 
hexadecimal, octal, or binary number systems to the decimal system also appear as 
integers. 

Copying and Pasting in Different Number Systems 
When you use the Copy command on the Edit menu to copy a value from 
Calculator onto the Clipboard, the Clipboard regards the value as a piece of text. 
It does not distinguish between text and numbers. You can use the Copy command 
to transfer a number in any number system from the scientific calculator into 
another Windows application or accessory. 

You can also paste a value in any number system into the scientific calculator 
from the Clipboard, provided that the number is in the number system that is 
currently active. 
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Using the Calculator Statistical Functions 
In addition to doing simple and programming calculations, the scientific calculator 
does statistical calculations, such as averages and standard deviations. 

fdit Y:iew Jjelp 
o. I 

1 0 Hex @ Dec 0 Oct 0 Bin 1 @ Deg 0 Rad 0 Grad 1 

C 0(Back)IOlnv OHyp ID D D 
Sta @C!JC!JGD00CD0(MOd)(And) 
Ave (dms)(Exp)0(MR)000~G(xor) 

Sum ~( ry )GiJ~000D( Lsh )~ 

s~~0800D8D~ 
Dat ~@JG80000000 

These buttons indicate 
statistical calculations. 

~ To perform a statistical calculation 

1. Choose the Sta button. 

The Statistics Box appears. 

The values you 
enter appear here. 

~---r---r---~-H- These buttons handle 

n=O 

data for statistical 
calculations. 

Indicates the number of 
values currently entered. 
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2. Move the Statistics Box to a position where you can easily work with the 
numbers and statistical functions you want to use. 

3. Enter the first value. 

If you are using the keyboard, choose the RET button in the Statistics Box by 
pressing ALT+R, and then type the number. 

4. Choose the Dat button to enter the value in the Statistics Box. 

5. Enter any other numbers in the calculation, choosing the Dat button each time 
to place the number in the Statistics Box. 

You can enter as many numbers as your computer's memory allows. 

6. Choose the button for the statistical function you want to use in your 
calculation-Ave (average), Sum (total), or s (standard deviation). For more 
information about these functions, see the following section, "Advanced 
Calculator Functions." 

Choose the Dat button to include the results in the Statistics Box. 

7. When you complete your statistical calculations, choose Close from the Control 
menu in the Statistics Box. 

You can use the Statistics Box buttons in the following ways. 

Use 

RET 

LOAD 

CD 

CAD 

To 

Switch to the main calculator and retain the Statistics Box entries. 
(To return to the Statistics Box, choose the Sta button.) 

Change the number in the Calculator display area to the number selected 
in the Statistics Box. 

Delete the selected number from the Statistics Box. 

Delete all numbers from the Statistics Box. 

Advanced Calculator Functions 
The following tables describe each button specific to the scientific calculator and 
its functions. They do not describe buttons that also appear on the standard cal­
culator. For information about those buttons, see "Standard Calculator Functions" 
earlier in this chapter. The tables also provide the keyboard equivalent for each 
function. 
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Operators 
Button 

And 

Int 

Lsh 

Mod 

Not 

Or 

Xor 

Key 

& 

< 

% 

A 

Function 

Starts a new level of parentheses. The current number of levels 
appears below the display area. The maximum number is 25. 

Closes the current level of parentheses. 

Calculates bitwise AND. 

Displays the integer portion of a decimal value. Inv+Int displays 
the fractional portion of a decimal value. For example, if the 
current value is 47.5, Int displays 47 and Inv+Int displays .5. 

Shifts left. Inv+Lsh shifts right. Mter you select this button, 
you must specify how many positions (in binary) to the left or 
right you want to shift the number in the display area, and then 
press = (equal sign). 

Displays the modulus, or remainder, of x/yo For example, 
10 Mod 3 displays 1. 

Calculates bitwise inverse. 

Calculates bitwise OR. 

Calculates bitwise exclusive OR. 

Number-Base Functions 
Button Key Function 

Bin F8 Converts to the binary number system. 

Byte F4 Displays the lower 8 bits of the displayed number, but does not 
change the value. 

Dec F6 Converts to the decimal number system. This is the standard 
setting. Uses Deg, Rad, or Grad in trigonometric functions. 
Dword, Word, and Byte do not apply here. 

Dword F2 Displays the full 32-bit representation of the displayed number. 

Hex F5 Converts to the hexadecimal number system. 

Oct F7 Converts to the octal number system. 

Word F3 Displays the lower 16 bits of the displayed number, but does not 
change the value. 
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Advanced Statistical Functions 
Button Key Function 

Ave CTRL+A Calculates the mean of the values displayed in the Statistics 
Box. Inv+Ave calculates the mean of the squares. 

Dat INS Enters the displayed number in the Statistics Box. 

s CTRL+D Calculates standard deviation with the population parameter 
as n-l. Inv+s calculates standard deviation with the popula-
tion parameter as n. 

Sta CTRL+S Opens the Statistics Box and activates the Ave, Sum, s, and 
Dat buttons. 

Sum CTRL+T Calculates the sum of values in the Statistics Box. Inv+Sum 
calculates the sum of the squares. 

Other Advanced Functions 
Button 

cos 

Deg 

dms 

Exp 

F-E 

Grad 

Hyp 

Key 

o 

F2 

m 

x 

v 

F4 

h 

Function 

Calculates the cosine of the displayed number. Inv+cos calcu­
lates the arc cosine. Hyp+cos calculates the hyperbolic cosine. 
Inv+Hyp+cos calculates the arc hyperbolic cosine. 

Sets trigonometric input for degrees. This function is available 
in decimal mode only. (For example, to calculate the cosine of 
35 degrees, change to Deg, enter 35, and choose the cos button.) 

Converts the displayed number to degree-minute-second format 
(assuming the number is in degrees). Inv+dms converts the dis­
played number to degrees (assuming the number is in degree­
minute-second format). 

Allows entry of scientific notation numbers. The exponent has 
an upper limit of +307. You can continue to enter numbers as 
long as you only use keys 0-9. You can use Exp only with the 
decimal number system. 

Switches between scientific notation and normal notation. 
Calculator always displays numbers larger than 1015 exponen­
tially. You can use F-E only with the decimal number system. 

Sets trigonometric input for gradients in decimal mode. 

Sets the hyperbolic function for sin, cos, and tan. The different 
functions automatically tum off the hyperbolic function after 
a calculation is completed. (For more information, see the 
individual functions.) 
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Calendar 

Button 

Inv 

In 

log 

n! 
PI 

Rad 

sin 

tan 

Key 

n 

P 
F3 

s 

y 

@ 

# 

Function 

Sets the inverse function for sin, cos, tan, PI, xAy, xA2, xA3, 
In, log, Ave, Sum, and s. The different functions automatically 
tum off the inverse function after a calculation is completed. 
(For more information, see the individual functions.) 

Calculates natural (base e) logarithm. Inv+ln calculates e raised 
to the xth power, where x is the current number. 

Calculates common (base 10) logarithm. Inv+log calculates 10 
raised to the xth power. 

Calculates factorial of the displayed number. 

Displays the value of n. Inv+PI displays 6.28 ... (or 2*pi). 

Sets trigonometric input for radians in decimal mode. Input can 
be from 0-2*pi. 

Calculates the sine of the displayed number. Inv+sin 
calculates the arc sine. Hyp+sin calculates the hyperbolic 
sine. Inv+Hyp+sin calculates the arc hyperbolic sine. 

Calculates the tangent of the displayed number. Inv+tan calcu­
lates the arc tangent. Hyp+tan calculates the hyperbolic tangent. 
Inv+Hyp+tan calculates the arc hyperbolic tangent. 

Computes x raised to the yth power. Inv+xAy calculates the yth 
root ofx. 

Squares the displayed number. Inv+xA2 calculates the square 
root. 

Cubes the displayed number. Inv+xA3 calculates the cube root. 

Windows Calendar combines a month-at-a-glance calendar and a daily 
appointment book. 

~ To start Calendar 

• In the Accessories group, choose the Calendar icon. 

An untitled Calendar window appears, displaying one-hour time intervals for 
the current date. The first hour that appears at the top of the window is 7 :00 A.M. 



r~,tatus line r Scroll arrows 

" Eile .Edit ~iew l,S.how Alarm Q.ptions .!::!.elp 

1'12:38 PM I11III Tuesday. December 03. 1991 

7:00 AM 
8:00 
9:00 

10:00 
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il!lll!' 

11 :00 
12:00 PM 
1:00 
2:00 
3:00 
4:00 

-----f!iii-it- Appointment area 

5:00 
6:00 
7:00 
8:00 \ 

\ \ 
\ \ 

~ Scratch pad ~ Insertion point 

Calendar displays the system time and date in the status line. If the time or date is 
wrong or you would like to change the format, you can reset it by using Windows 
Control Panel. For more information, see Chapter 5, "Control Panel." 

Changing Views in Calendar 
Calendar gives you two views of the calendar. When you start Calendar, you see 
one full day (the Day view). You can change to the Month view to see the whole 
month at one time. 

Eile .Edit ~iew ,S.how Alarm Q.ptions .!::!.elp 

Selected date appears 
September 1991 on status line 

S M T W T F S 

2 4 5 6 7 

8 9 12 13 14 

15 16 20 21 

Current date 
Selected date 
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~ To switch between the Day view and the Month view 

• From the View menu, choose Month or Day. 

Tip If you have a mouse, you can quickly switch between the Day view and the 
Month view by double-clicking the date in the status line. You can also change 
back to the Day view by double-clicking a specific date in the Month view 
(or by using the arrow keys to move to the date and then pressing ENTER). 

Entering Appointments 
When you enter an appointment, you move the insertion point to a time in the Day 
view, and then type text that describes the appointment. You can also set an alarm, 
and type notes and reminders in the Calendar scratch pad. 

The Day view contains a list of times that are initially set at one-hour intervals, 
beginning with 12 A.M. The insertion point initially appears at 7 A.M. (the starting 
time). 

~ To enter an appointment 

1. Move the insertion point to the appointment time. 

If the time is not visible, use the scroll bar or arrow keys to move the time onto 
the screen. 

2. Type any information you want. 

You can type up to 80 characters of text describing an appointment. The 
appointment line scrolls horizontally if you continue typing past the end of 
the line initially shown in Calendar. 

If you are using the keyboard, you can use the following keys to move the 
insertion point. 

Press To move to 

UP ARROW The time above. 

DOWN ARROW or ENTER The time below. 

PAGE UP The previous screen. 

PAGE DOWN The next screen. 

CTRL+HOME The starting time (set for 7 A.M. the first time you start 
Calendar). 

CTRL+END Twelve entries below the starting time (this is not 12 hours 
below if special times are added). 

If you want to schedule an appointment for a time not displayed, you need to add a 
special time. For more information, see "Customizing Your Calendar" later in this 
chapter. 
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Editing an Appointment 
You can edit the text that describes an appointment in much the same way that 
you edit text in other Windows applications. For more information, see Chapter 2, 
"Application Basics." When you select Calendar text for editing, however, you 
can select only one appointment line at a time. 

Adding a Note or Reminder 
The daily appointment window has a scratch pad at the bottom in which you can 
type notes and reminders. 

~ To write notes on the scratch pad 

1. Point to the scratch pad and click it. 

Or press TAB to move to the scratch pad. 

2. Type your notes and reminders. 

You can type up to three lines of text in the scratch pad. When your text 
reaches the right border of the scratch pad, Calendar wraps the text to the 
next line. 

3. To return to the appointment area, press TAB. 

Displaying a Different Appointment Day 
You can move to different appointment days by using commands on the 
Show menu. You can also use this menu to return quickly to the current 
day's appointments. 

~ To display the previous or next appointment day 

• From the Show menu, choose Previous or Next. 

~ To return to the current appointment day 

• From the Show menu, choose Today. 

The Previous, Next, and Today commands also apply to months when you are 
using the Month view. 

Tip To move quickly to the previous day, click the left arrow in the Calendar 
status line (or press CTRL+PAGE up). To move quickly to the next day, click the 
right arrow in the Calendar status line (or press CTRL+PAGE DOWN). 



424 Microsoft Windows User's Guide 

~ To change the appointment day to a specific date 

1. From the Show menu, choose Date. 

The Show Date dialog box appears. 

2. In the Show Date box, type the date you want Calendar to display. 

3. Choose the OK button. 

You can type any date between January 1, 1980, and December 31,2099. If you 
have not used Control Panel to change the date format, you can type dates in either 
the mm/dd/yy or mm-dd-yy format. You do not need to type leading zeros for 
days or months. If you are referring to a year in the twentieth century, you need 
to type only a two-digit number. The following examples show some acceptable 
date formats. 

You can type 

3/9/92 

3-9-92 

11112010 

USing the Month View 

For this date 

March 9, 1992 

March 9, 1992 

January 1,2010 

In the Month view, you see at a glance all the dates in the current month. The 
current date is marked by brackets (for example, > 15<). 

~ To move to another date in the Month view 

• Point to the date and click it. 

Or use the arrow keys. 

~ To view the previous or next month 

• From the Show menu, choose Previous or Next. 

Tip To move quickly to the previous month, click the left arrow in the Calendar 
status line (or press PAGE UP). To move quickly to the next month, click the right 
arrow in the Calendar status line (or press PAGE DOWN). 
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~ To move quickly to an appointment day from the Month view 

Setting an Alarm 

• Double-click the date in the Month view. 

Or use the arrow keys to move to the date, and then press ENTER. 

Calendar has an alarm you can set to remind you of appointments. You can set the 
alarm for as many appointments as you want. 

~ To set the alarm for an appointment time 

1. Select the appointment time. 

2. From the Alarm menu, choose Set. 

The alarm symbol appears 
next to the appointment time. 

7:00 AM 
8:00 

D. 9:00 
10:00 
11:00 
12:00 PM 
1:00 
2:00 
3:00 
4:00 
5:00 

A check mark appears next 
to Set on the Alarm menu. 

When the alarm goes off, Calendar alerts you in one of the following ways. 

If Calendar is 

The active window 

An inactive window 

An icon 

This happens 

A dialog box reminds you of the appointment. 

The title bar and borders of the Calendar window flash. 

The icon flashes. 
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Changing the Sound Option 
In addition to visually alerting you about your appointments, the alarm also makes 
a sound. If you do not want to hear the alarm, you can tum off its sound. 

Note If you have turned off the system sounds for Windows by using the Sound 
option in Control Panel, the Calendar alarm will not beep. 

~ To use a silent alarm 

1. From the Alarm menu, choose Controls. 

The Alarm Controls dialog box appears. 

This check box turns 
sound on and off. 

This box sets the 
alarm to go off early. 

2. Clear the Sound check box. 

3. Choose the OK button. 

Setting the Calendar Alarm to Go Off Early 
Once the alarm is set, you can set it to go off up to 10 minutes before the 
appointment time. 

~ To set the alarm to go off early 

1. From the Alarm menu, choose Controls. 

The Alarm Controls dialog box appears. 

2. In the Early Ring box, type a number from 0 to 10. 

3. Choose the OK button. 

Alarms continue to go off early until you change the Early Ring setting. 
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Turning Off the Alarm 
When an alarm goes off, it continues to flash until you tum it off. How you tum 
off an alarm depends on whether Calendar is an icon, or whether the Calendar 
window is active or inactive. 

~ To turn off the alarm 

1. If the Alarm dialog box is not already visible, switch to the Calendar window 
or restore the Calendar icon. 

2. In the Alarm dialog box, choose the OK button. 

Removing an Alarm 
You can remove an alarm before it goes off. 

~ To remove an alarm 

1. Select the time the alarm is set for. 

2. From the Alarm menu, choose Set. 

When you remove an alarm, the check mark next to the Set command disappears. 

Customizing Your Calendar 
You can customize the Day view of your calendar so that it shows other than 
60-minute time intervals, uses a 24-hour clock rather than a 12-hour clock, or uses 
a starting time other than 7 A.M. You can also add special times in the Day view 
and mark special dates in the Month view. 

Changing Settings in the Day View 
The day settings determine the time interval, hour format, and starting time used in 
the Day view. 
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~ To change the settings in the Day view 

1. From the Options menu, choose Day Settings. 

The Day Settings dialog box appears. 

interval: 0 15 0 30 @ f~.Q·j 

!!.our Format: @ 12 0 24 

litarting Time: I 7:00 AM 

2. Select the options you want to use. For more information, see the table of 
options following this procedure. 

3. Choose the OK button. 

You can set the following options in the Day Settings dialog box. 

Use 

Interval 

Hour Format 

Starting Time 

To 

Determine the intervals between daily appointments. You can select 
intervals of 15, 30, or 60 minutes. 

Select either a standard 12-hour clock or a 24-hour clock. 

Specify the time that appears at the upper left of the Calendar 
window when you first view an appointment day. 

Adding a Special Time 
A special time is any time that falls between the 15-, 30-, or 60-minute intervals 
you set in the Day Settings dialog box. For example, no matter what time interval 
you set, 11: 10 is a special time. 

~ To add a special time to an appointment day 

1. From the Options menu, choose Special Time. 

The Special Time dialog box appears. 
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2. In the Special Time box, type the time. 

3. Select the AM or PM option button if you are using a 12-hour clock. 

You can use the Date/Time option in Control Panel to specify a 24- or 12-hour 
clock. 

4. Choose the Insert button. 

~ To delete a special time 

1. Select the time you want to delete. 

2. From the Options menu, choose Special Time. 

The Special Time dialog box appears with the selected time in the Special Time 
box. 

3. Choose the Delete button. 

Marking a Date 
You can call attention to special days such as paydays, holidays, birthdays, and 
anniversaries by marking the days in the Month view. Calendar supplies five 
different symbols for marking dates. By always marking a specific type of day, 
such as payday, with the same symbol, you can tell at a glance when that day 
occurs in the month. 

s Iv! 

6 

13 

October 1991 
T W T F s 

An x designates a 
payday on this calendar. 
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You can mark a special date while in either the Day or Month view, but it is 
displayed only in the Month view. 

~ To mark a date in the Month view 

1. Select the date you want to mark. 

2. From the Options menu, choose Mark. 

The Day Markings dialog box appears. 

Mark Svmbol 

D l$.~·~.~·~.(I·.:If 
D SVmbolZ - ( ) 

D Svmboll-o 

D Svmbol!-x 

D Svmbol~-_ 

/;!::nK!:::';,1 

1.;:g~!w'!i;1 

3. Select the check box for the symbol or symbols you want to use. 

4. Choose the OK button. 

Calendar marks the selected date with the symbol you chose. 

~ To cancel a mark 

1. Select the marked date. 

2. From the Options menu, choose Mark. 

The Day Markings dialog box appears. 

3. Clear the check box of the symbol that marks the selected date. 

4. Choose the OK button. 

Calendar removes the mark. 

Managing Calendar Files 
Windows assigns the extension .CAL to Calendar files. For information about 
opening and saving Windows files, see Chapter 2, "Application Basics." For 
information about working with Windows files and directories, see Chapter 4, 
"File Manager." 
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Opening Read-Only Appointment Files 
If you and your co-workers want to share your daily appointment schedules over 
a network, you can open appointment files as read-only files. That way, you can 
view someone else's appointments without accidentally changing or erasing 
something. 

Note Although you can make changes to read-only files, you cannot save those 
changes. 

~ To open an appointment file as a read-only file 

1. From the File menu, choose Open. 

2. Select or type the name of the file you want to open. 

3. Select the Read Only check box. 

4. Choose the OK button. 

Removing Entries from Appointment Days 
You can remove appointments from a single day or a range of days that you don't 
need anymore from a Calendar file to make room for other appointments. 

~ To remove entries from appointment days 

1. Open the file you want to remove appointments from. 

2. From the Edit menu, choose Remove. 

The Remove dialog box appears. 

Remove Appointments: 

from: IDlliIlm I lilii;.;J~;;;;1 

1.0: I IHo~fi4~i!1 

3. In the From box, type the first date you want to remove. 

4. In the To box, type the last date you want to remove. 

To remove only one day's appointments, leave the To box blank. 

5. Choose the OK button. 
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Printing Appointments 
If you have connected and installed a printer, you can print your appointments. 
For information about how to install a printer, see Chapter 5, "Control Panel." 
Calendar automatically prints to the designated default printer. 

~ To print appointments 

1. From the File menu, choose Print. 

The Print dialog box appears. 

Prinl Appoinlmenls: 

Erom:l~ 
lo: 

2. In the From box, type the date of the first appointment day you want to print. 

3. In the To box, type the date of the last appointment day you want to print. 

To print a single day's appointments, leave the To box blank. 

4. Choose the OK button. 

Calendar prints your documents on the default printer. If you want to use another 
printer, choose the Print Setup command from the File menu. 

Setting Margins 
Calendar automatically prints your appointments using the standard margin 
settings in the Page Setup dialog box. If you want to position your appointments 
differently on the page, adjust the margins before you use the Print command. 

~ To set the margins for printing appointments 

1. From the File menu, choose Page Setup. 

The Page Setup dialog box appears. 

Eooler: ,--IPa-=.g_e &....:....p_-----' 

Margins 

L.efl: ~ RighI: 

lop: ~ 
The default settings 
for margins 
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2. In the Margins area, type the measurements for the margin settings you want 
to use. 

The increment for this measurement is set using the International option in 
Control Panel. If you have this setting set to English, you are using inches. 
For more information, see Chapter 5, "Control Panel." 

3. Choose the OK button. 

Printing Headers and Footers 
When you print your appointments, you can add explanatory text, the date, a page 
number, or the filename as a header or footer on the printed pages. You can also 
choose whether you want a header or footer to be left-aligned, right-aligned, or 
centered on the page. 

~ To print a header or footer on your appointments 

1. From the File menu, choose Page Setup. 

The Page Setup dialog box appears. 

Left: 

Lop: 

The default setting prints 
the filename as a header. 

The default setting prints 
the page number as a footer. 

2. In the Header or Footer box, type the text you want to use as a header or footer, 
along with any of the codes that Calendar allows in these boxes. For more infor­
mation, see the table following this procedure. 

3. Choose the OK button. 
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Cardfile 

The following table explains the codes that you can type in the Header and Footer 
boxes. 

Type For 

&d The current date. 

&p Page numbers. 

&f The current filename. 

&1 Text that follows the code to be aligned at the left margin. 

&r Text that follows the code to be aligned at the right margin. 

&c Text that follows the code to be centered in the top or bottom margin. This is 
the default setting. 

&t The current time. 

You can include several of these codes in a single header or footer. For example, 
if you specify a header as &IPage &p&cFile &f&rDate &d, the header will print 
as follows: 

Page 1 File FILENAME.CAL Date 12/9/91 

When you print, any assigned headers or footers appear in their designated places 
on the printed pages. Headers always appear just above the top margin and footers 
appear just below the bottom margin. 

Windows Cardfile is like a set of index cards. You can use it to keep track of 
names, addresses, phone numbers, directions, or anything else you want quick 
access to. You then save these index cards in files. 

~ To start Cardfile 

• In the Accessories group, choose the Cardfile icon. 
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Edit :!liew .card Search .!::!.elp 
Card View 1 Card 

L----------II-- Scroll arrows 

h:============;r----i- Index line 

Insertion point Information area 

You can change the size of the Cardfile window, but you cannot change the size of 
the cards. 

To create a card file, fill in as many blank cards as you need. This may involve 
typing text in both the index line and information area of the card. Once the cards 
are filled out, you can save them in a file and name the file according to the type 
of information it contains. 

Note The number of cards you can create, and how this amount of information 
affects the speed with which Cardfile loads files and cards, depend on the type of 
computer you have and how much memory it has. 

Filling In and Adding Cards 
The index line is the bar at the top of each card. Cardfile uses the text you put in 
the index line to sort the cards. You could also type a name or brief description of 
the contents of the card on the index line to help you identify the contents. 
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~ To fill in a blank card 

1. From the Edit menu, choose Index. 

You can also double-click the index line or press F6. 

The Index dialog box appears. 

2. In the Index Line box, type the text you want to use to identify the contents 
of the card. An index line can hold up to 39 characters. 

If you make a mistake while typing, press BACKSPACE to correct the text. 

3. Choose the OK button. 

The insertion point returns to the information area of the card. 

4. Type the text for the card. Each card line can contain up to 40 characters. 

The text wraps to the next line. 

For more information about working with text, see Chapter 2, "Application 
Basics." 

~ To add a new card 

1. From the Card menu, choose Add. 

Or press F7. 

The Add dialog box appears. 

Add: 1-1 ___________ .....J Ir,." 111111111 

2. In the Add box, type the text for the new card's index line. 

3. Choose the OK button. 

Cardfile adds the new card to your file in the correct alphabetic order and 
scrolls the file to display the card at the front. 

4. In the card's information area, type the text you want to store. 
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Viewing Cards as a List 
Cardfile has two viewing options-Card view and List view. Card view is active 
when you start Cardfile, and displays your file as a series of cards. In the List 
view, Cardfile displays the index line of every card in the file in alphabetic order. 

~ To display cards as a list 

• From the View menu, choose List. 

Moving Through Your Cards 
You can scroll card by card through a file or bring a specific card directly to the 
front of a file. Cardfile always keeps the cards in alphabetic order based on your 
entries in the index lines. 

~ To scroll through your cards 

• Click the right or left arrow in the status bar at the top of the Cardfile window. 

If you are using the keyboard, use the following keys to move among the cards 
in your card file. 

Press To 

PAGE DOWN Scroll forward one card when you are in Card view. When you 
are in List view, PAGE DOWN moves forward one page of index 
lines. 

PAGE UP Scroll backward one card when you are in Card view. When you 
are in List view, PAGE UP moves back one page of index lines. 

CTRL+HOME Bring the first card in the file to the front. 

CTRL+END Bring the last card in the file to the front. 

DOWN ARROW Scroll one card forward when you are in List view. 

UP ARROW Scroll one card backward when you are in List view. 

~ To bring a specific card to the front of a file 

1. From the Search menu, choose Go To. 

Or press F4. 

The Go To dialog box appears. 
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2. Type a portion of the index line text for the card you want to bring to the front; 
you only need to type enough text to distinguish the card from the other cards. 

3. Choose the OK button. 

Tip If a card's index line is visible, you can quickly bring the card to the front of 
the file by pointing to the index line and clicking it. 

If you are using the keyboard, you can quickly bring a card to the front of a file 
if you know the first letter of the index line text. Press and hold down CTRL and 
SHIFT, and then press the appropriate letter key. Cardfile scrolls to display the first 
card that has that letter at the beginning of its index line. You can now scroll card 
by card to find the card you want. 

Searching for Text in Cardfile 
You can find specific text on cards (not index lines) by using the Find command 
on the Search menu. You can start a search at any point in the file. Cardfile 
searches forward from the selected point and, when it reaches the end of the file, 
automatically continues searching from the beginning of the file. When searching 
for text, you can specify whether you want Cardfile to ignore capitalization. 

~ To search for text 

1. Select the card from which you want to begin the search. 

2. From the Search menu, choose Find. 

The Find dialog box appears. 

Find What: 

o Match t.ase 

3. In the Find What box, type the text you want to find. 

4. Select the Up or Down option button to search forward or backward in the file. 

5. Choose the Find Next button. 

Cardfile searches for the text and selects the first occurrence. If there are no 
occurrences of the text in the file, Cardfile displays a message telling you that 
it could not find the text. Choose the OK button to close the dialog box. 
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6. To find the next occurrence of the same text, choose the Find Next button again. 

You can also close the Find dialog box and choose the Find Next command 
from the Search menu. When you choose the Find Next command (or press F3), 
Cardfile does not display the Find dialog box but immediately searches for the 
text. 

Editing Text on Cards 
You edit text on a card in much the same way that you edit text in other Windows 
applications. For information about basic editing, see Chapter 2, "Application 
Basics." There are a few differences in editing a card file, however, which the 
following sections explain. 

Changing the Index Line 
When you edit a card, you edit the index-line text separately from the rest of 
the card. 

~ To edit the text in the index line 

1. Select the card you want to edit. 

2. From the Edit menu, choose Index. 

You can also double-click the index line or press F6. 

The Index dialog box appears with the current index-line text selected in the 
Index Line box. 

3. If you want to replace all the text in the index line, type the new text. 

The old text disappears as soon as you type the first character of the new text. 

4. If you want to change only a few characters in the index line, click any incor­
rect character (or press the RIGHT ARROW or LEFT ARROW key to move to the 
character) and correct it. 

5. Choose the OK button. 

Cardfile automatically places the card in its correct alphabetic order, and then 
scrolls the file to display the card at the front. 
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Moving or Copying Text to Another Card 
You can use the Clipboard to move or copy text from one card to another in 
Cardfile. 

~ To move or copy text from one card to another 

1. Select the text you want to move or copy. 

2. To move text, choose Cut from the Edit menu. 

Or, to copy text, choose Copy from the Edit menu. 

3. Select the card into which you want to insert the text. 

4. Move the insertion point to the place you want the text to appear. 

Or select the text you want to replace. 

5. From the Edit menu, choose Paste. 

The text appears in the new location. 

You can paste text from the Clipboard to any part of any card. If you paste text 
to the index line, only the first line appears. 

You can continue pasting the text in as many places as you want. 

Inserting a Drawing in a Card 
One of the most useful features in Windows is the ability to transfer artwork from 
another application to a card in Cardfile. For example, you could create a small 
map by using Windows Paintbrush, and then copy it to a card already containing 
an address. Each card can contain only one picture. 

There are three methods you can use to insert a drawing into a card. You can copy, 
embed, or link the drawing. You can link and embed information only if the appli­
cation used to create the drawing supports object linking and embedding. Check 
the application's documentation to find out. 

You use the Paste command when you are copying or embedding information. 
The result of the paste is determined by the application used to create the infor­
mation on the Clipboard at the time you choose the Paste command. If the 
information was created using an application that is a server application (one 
that can supply objects), then information is embedded. If this information was 
created by an application that does not support object linking and embedding, 
the information is copied. 

For more information about linking and embedding objects, see Chapter 13, 
"Integrating Your Windows Applications." 



Method 

Copy 

Embed 

Link 
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Description 

You use this method to copy a drawing to a different application by 
using the Clipboard. Once the drawing is in the new file, you can change 
it only by deleting it and copying a new one in its place. To insert a 
Paintbrush drawing already on the Clipboard, you use the Paste Special 
command on the Edit menu. 

Embedding is similar to copying but with one important difference: 
You can edit an embedded drawing (or object) because you can open 
Paintbrush from within Cardfile. To embed a Paintbrush drawing already 
on the Clipboard, you use the Paste command on the Edit menu. 

Linking dynamically connects two files so that information in one file 
automatically updates when information in the other file changes. To link 
a Paintbrush drawing already on the Clipboard, you use the Paste Link 
command on the Edit menu. Linked drawings are also easily edited from 
within Cardfile. 

~ To embed or link a drawing into a card 

1. Copy the drawing onto the Clipboard. (For more information, see "Editing 
Your Drawing" in Chapter 10, "Paintbrush.") 

The drawing must be saved in a file if you are going to create a link to it from 
another document. 

2. Switch to Cardfile. 

3. Select the card into which you want to insert the drawing. 

4. From the Edit menu, choose Picture. 

A check mark appears next to the command. 

5. To embed the drawing, choose Paste from the Edit menu. 

Or, to link the drawing, choose Paste Link. 

The drawing appears in the upper-left comer of the card. 

6. If text exists on the card, the picture may cover it. Drag the drawing to where 
you want it to appear. 

Or use the arrow keys to move the drawing. 

7. To continue working with text, choose Text from the Edit menu. 

If the drawing you paste is larger than the area available to paste it in, Cardfile 
scales the picture down to fit on the card. 
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Editing a Drawing on a Card 
You can easily make changes to drawings you've created in Paintbrush and 
embedded or linked into cards, because you can open Paintbrush from within 
Cardfile. 

For more information about linking and embedding objects, see Chapter 13, 
"Integrating Your Windows Applications." 

~ To edit an embedded drawing 

1. From the Edit menu, choose Picture, if it is not already checked on the menu. 

2. Double-click anywhere in the embedded drawing. 

Or, from the Edit menu, choose Edit Paintbrush Picture Object. (The Object 
command changes to reflect the type of object selected.) 

Paintbrush opens, displaying the drawing. 

3. Edit the drawing as needed. 

4. From the File menu, choose Update. 

This updates the embedded drawing with the changes you just made. 

5. From the File menu, choose Exit & Return To (name of document). 

Paintbrush closes. If you forget to update, a dialog box appears asking if you 
want to update your changes. Choose the Yes button to update. 

You edit a linked drawing the same way you edit an embedded drawing. 
Remember, though, that any changes you make to a linked drawing appear 
in all the drawings associated to it through links. 

~ To edit a linked drawing 

1. From the Edit menu, choose Picture, if it is not already checked on the menu. 

2. Double-click in the presentation of the linked drawing. 

Or, from the Edit menu, choose Edit Paintbrush Picture Object. (The Object 
command changes to reflect the type of object selected.) 

Paintbrush opens, displaying the drawing. 

3. Edit the drawing as needed. 

The linked drawing is updated automatically if the Update option is set to 
Automatic. 

4. From the File menu, choose Save. 

5. From the File menu, choose Exit & Return To (name of document). 

Paintbrush closes. If you forget to save, a dialog box appears asking if you 
want to save your changes. Choose the Yes button to save. 



Restoring a Card 
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Note If you have set the link to update manually, you must update it by 
choosing the Link command on the Edit menu in Cardfile and then choosing 
the Update Now button in the Link dialog box and the OK button. 

If you change your mind about changes you just made to a card, you can restore 
the card to its original condition as long as it is still at the front of the file. 
However, once you move a card away from the front, the changes become 
permanent and you cannot restore the card. 

~ To restore a card 

• From the Edit menu, choose Restore. 

Deleting a Card 
To delete a single card from a file, use the following procedure. 

~ To delete a card 

1. Select the card you want to delete. 

2. From the Card menu, choose Delete. 

A dialog box appears, asking you to confirm the deletion. 

3. Choose the OK button. 

Cardfile deletes the information. 

Be sure you have the correct card before you delete it. You can replace a deleted 
card only by retyping the information. 

Duplicating a Card 
If the information for several cards is similar, you might want to type the infor­
mation on one card, duplicate the card, and then edit the copies as necessary. 

~ To duplicate a card 

1. Select the card you want to duplicate. 

2. From the Card menu, choose Duplicate. 

Cardfile adds a copy of the card to the front of the file. 
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Managing Cardfile Files 
Windows assigns the extension .CRD to Cardfile files. For information about 
opening and saving Windows files, see Chapter 2, "Application Basics." For 
information about working with Windows files and directories, see Chapter 4, 
"File Manager." 

The following topics provide information specific to working with files in Cardfile. 

Saving a File in Windows Version 3.0 Format 
You can save a card file so that it can be opened if you are using Cardfile in 
Windows version 3.0. 

When you save a card file to the Windows version 3.0 format, any embedded or 
linked objects convert to a static object, which means that you can no longer edit 
these objects from within Cardfile. Also, if the embedded or linked object is a 
color picture, it is converted to a black-and-white picture when the file is closed 
and opened again, or when a new card is added. 

~ To save a file in Windows version 3.0 format 

1. From the File menu, choose Save. 

2. From the Save File As Type list, select 3.0 Card File. 

3. In the File Name box, type a filename. 

4. Choose the OK button. 

Determining File Size 
The number of cards you can store in a Cardfile file depends on the amount of 
memory in your computer and the amount of information on the individual cards. 
As you work on a file, Cardfile keeps track of how many cards are currently in the 
file and displays the number on the status line. The number of cards might give 
you an indication of file size, but it does not tell you the actual size of the file in 
bytes. 
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Merging Files 
If you want to consolidate two sets of cards, you can do so by merging a second 
Cardfile file with the file you are currently using. 

~ To merge two Cardfile files 

1. Open one of the files that you want to merge. 

2. From the File menu, choose Merge. 

The File Merge dialog box appears. 

3. In the Files box, select the file you want to merge with the current file. 

Or type the name of the file in the File Name box. 

4. Choose the OK button. 

Cardfile merges the cards from the two files, placing them in correct alphabetic 
order. 

You can now use the Save As command from the File menu to save the combined 
files under a new name or use the Save command to replace the current file with 
the combined files. 

The file that you selected in step 3 to merge with the current file still exists in its 
original condition. 

Printing a Cardfile File 
If you have connected and installed a printer, you can print a single card or an 
entire file. 

~ To print a single card 

1. Select the card you want to print. 

2. From the File menu, choose Print. 

A dialog box appears. 

If you want to cancel printing, choose the Cancel button. 

~ To print an entire file 

• From the File menu, choose Print All. 

A dialog box appears. 

If you want to cancel printing, choose the Cancel button. 
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When printing, Cardfile uses the default margin settings in the Page Setup dialog 
box. If you want to position your cards differently on the page, you can use the 
Page Setup command on the File menu to change these settings. You can also use 
the Page Setup command to have Cardfile print headers and footers. For more 
information about using this command, see "Setting Margins" and "Printing 
Headers and Footers" in the Calendar section earlier in this chapter. 

Note If you change the standard Cardfile margin settings, be sure to set left and 
right margins that accommodate the size of the cards. 

Cardfile prints your documents on the default printer. If you want to use another 
printer, choose the Print Setup command from the File menu. 

Using Automatic Dialing 
If you have a Hayes or Hayes-compatible modem, Cardfile will automatically dial 
any phone number stored on a card. 

~ To have Cardfile dial a phone number 

1. Select the card containing the phone number you want to dial. 

2. From the Card menu, choose Autodial. 

The Autodial dialog box appears. 

Prefix: ~ 

D .!J..se Prefix 

Igf,j:tlQ~\H ;111 

1·:;!~~;;li::U 
Ills·i~j;;~~Y;J 

3. If you need to set up your modem for dialing, choose the Setup button, and then 
select the appropriate options. For more information about options, see the table 
following this procedure. 

4. If you need to use a prefix in front of the number in the Number box, select the 
Use Prefix check box. 

Change the default setting in the Prefix box if necessary. 

5. Choose the OK button. 
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When you choose the Setup button, the Autodial dialog box expands to display 
the Setup options. 

Prefix: ~ 

D !!se Prefix 

DiallYpe .!l.aud Rate 

@ ft~.~·~) 0 Pulse 0110 04800 
0300 09600 
@ 1200 019200 

02400 

The following table explains the Setup options. 

Use 

Dial Type 

Port 

Baud Rate 

Character Map 

To 

Select the dial type of your telephone. If you hear a tone for each 
number you dial, you have a tone telephone. If you hear a clicking 
sound, you probably have a pulse telephone. 

Select the port to which your modem is connected. 

Specify the correct baud rate for your modem. For information about 
the correct setting, see your modem manual. 

Windows Character Map provides you with extended characters and special 
characters in symbol fonts that you can insert into other applications. 

Character Map only works with Windows applications. If you are running 
non-Windows applications, check the documentation that came with your 
application to see how to insert special characters. 
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~ To start Character Map 

Selecting a Font 

• In the Accessories group, choose the Character Map icon. 

Table of available characters 
in the selected font 
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Displays what key to 
press to select character 

A font is a design for a set of letters, numbers, and symbols. Character Map 
comes with a variety of fonts to select from. Each font contains a different set 
of characters. When you select a font, the character set changes to display the 
characters in the font. 

~ To select a font 

• Open the Font list, and then select the font you want to use. 

Inserting a Character into a Document 
You can insert one character or several characters from one font at a time into a 
document. 

~ To insert a character into a document 

1. Open the Font list, and then select a font. 

The character set changes to display the characters in the selected font. 

2. Move the pointer to a character, and then press and hold down the mouse 
button to see an enlarged picture of the character you want. 

Or press TAB until the cursor is in the character selection area, and then use 
the arrow keys to see an enlarged picture of the character you want. 
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3. Double-click the character to select it. 

Or choose the Select button. 

The character is placed in the Characters To Copy box. 

4. Select as many characters as you want. 

5. To place the characters in the Characters To Copy box onto the Clipboard, 
choose the Copy button. 

6. Switch to the document into which you want to insert the characters. 

7. Select the same font that you previously selected in Character Map. 

8. Position the cursor where you want the characters to appear. 

9. From the application's Edit menu, choose Paste. 

Note Characters may lose the font you selected in Character Map when you paste 
into some applications. To change the characters to the font you want, select them 
and format them for the font within the application. 

To help you keep track of the time, Windows provides an accessory called Clock. 
You can display Windows Clock as an analog or digital clock. 

~ To start Clock 

• In the Accessories group, choose the Clock icon. 

If you are starting Clock for the first time, a window with a standard analog 
clock appears. The clock shows the system time. 
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The next time you start Clock, the last mode that you used-analog or digital­
appears. 

You can change the size of the Clock window and move it wherever you like so 
that the current time-including seconds, if you want-appears on the screen but 
uses little work space. Clock even continues to display the time when you reduce 
it to an icon. 

~ To switch between the analog and digital clocks 

• From the Settings menu in the Clock window, choose Analog or Digital. 

If you need to, you can reset the time by using Control Panel. For more infor­
mation, see Chapter 5, "Control Panel." 

Customizing Clock 
There are various ways you can customize the way Clock appears. You can 
remove the window title and date, specify that Clock run on top of any other 
windows, display hours and minutes only, and change the font. 

~ To customize Clock 

• From the Settings menu in the Clock window, choose Seconds, Date, or No 
Title. 

If you choose No Title, double-click anywhere in the Clock window to make 
the Settings menu reappear, or press ESC. 

If you want to ensure that Clock is never covered by other open windows, you 
can specify that the Clock window run on top at all times. 

~ To display the Clock window on top of other windows 

• From the System menu in the Clock window, choose Always On Top. 

A check mark appears next to the command. 

If Clock is running in digital mode, you can change the font of the numerals. 
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~ To change the font 

1. If Clock is not running in digital mode, choose Digital from the Settings menu. 

2. From the Settings menu, choose Set Font. 

The Font dialog box opens. 

Courier 
1t Courier New 

Fixedsvs 
MS Sans Serif 

l:iilii;\Q51s1lfl 

1';~.lIlt1!lt 

lSAaBb YyZz I 

3. From the Font list box, select a font. 

If you select a True Type font, the characters and numbers on the clock face are 
scaled correctly as you change the size of the Clock window. 

4. Choose the OK button. 

Media Player 
By using Windows Media Player, you can play multimedia files and control 
hardware devices. Media Player can play sounds and Musical Instrument Digital 
Interface (MIDI) sounds, and control any Media Control Interface (MCI) multi­
media device installed on your system. For example, you can use Media Player 
to play audio compact discs or videodiscs. 

To playa multimedia file (sound or animation) or device (such as a videodisc 
player), you first choose the type of device you want to use. Use the Drivers 
option in Control Panel to install drivers for these devices. If the device requires 
a file to play, you must also open the file. Some devices, like CD audio players, 
do not require a file. 

Before Media Player can playa file, you must have the sound hardware installed 
and its driver installed and configured. For information about installing drivers, 
see Chapter 5, "Control Panel." 
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~ To start Media Player 

• From the Accessories group, choose the Media Player icon. 

You use the buttons in Media Player to control the playing of the media piece. 
Use the scroll bar to move to a different part of the media piece (change the 
playback position). 

Specifying a Media Device 

Eject button 
Stop button 

Pause button 
Play button 

When you choose a device from the Device menu in Media Player, you specify 
the Media Control Interface (MCI) device to play. MCI devices include audio 
compact-disc players, MIDI sequencers, and videodisc players. The Device menu 
lists the MCI devices installed on your system. Before Media Player can recognize 
a multimedia device, you must install the hardware and then use Control Panel to 
install the device drivers necessary for the hardware. For more information about 
installing device drivers, see Chapter 5, "Control Panel." 

Media Player plays two types of multimedia devices: compound and simple. 
Compound devices play files, so you must specify the name of a file. For example, 
if you choose the Sound device, you must specify a .WAV file to play. 

Simple devices generally control external hardware devices that do not use disk 
files-for example, an audio compact-disc player. When you choose a simple 
device from the Device menu, Media Player readies itself to start playing 
whatever is currently loaded in the hardware device. 

The selections that appear on the Device menu vary, depending on what you have 
. installed on your system. 
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~ To specify a simple device 

• From the Device menu, choose the media device. 

The names of simple devices are not followed by an ellipsis ( ... ). 

~ To specify a compound device 

1. From the Device menu, choose the media device. 

The names of compound devices are followed by an ellipsis ( ... ). 

The Open dialog box appears. 

2. Select the name of the file you want to play. 

3. Choose the OK button. 

The first time you specify a compound device (such as Sound), Media Player asks 
you to identify the file you want played. Once you have specified the device, you 
can use the Open command to open other files available for use by that device. If 
you want to use a different device, you can choose that device from the Device 
menu, or you can choose a different file type to play from the Open dialog box. 

After you choose a compound device, you can open and play files appropriate for 
that device. For example, if you've specified a MIDI Sequencer device, you can 
open and play MIDI files. If you want to play another type of file, you can change 
devices from within the Open dialog box. 

~ To open a file to play 

1. From the File menu, choose Open. 

The Open dialog box opens. 

2. Type or select the name of the file you want to play. 

3. Choose the OK button. 

Playing a Media File 
Media Player has controls similar to a VCR or audio compact-disc player. You 
can choose a button on the screen to play, pause, restart, or stop playing a media 
file. There is also an Eject button, which works if your media device has an eject 
function. 
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~ To control the media playing 

• Click either the Play, Pause, Stop, or Eject button. 

Or use the TAB key to move to a button, and press the SPACEBAR to choose the 
button. 

If you choose Pause, to start again choose Pause or Play. 

If you choose Stop, to start again choose Play. 

The title bar displays the action you choose and the type of device playing the 
selection (if you are playing a simple device) or the filename (if you are playing 
a compound device). 

Changing and Positioning the Scale 
Media Player provides two scales to help you monitor and control how media are 
played. The Time scale shows time intervals and the Track scale shows tracks. 

The scale appears above the scroll bar. The scale displays track locations or time 
intervals, depending on which you choose. Displaying track locations is useful 
when playing devices oriented around different tracks, such as audio compact-disc 
players. 

~ To change scales 

• From the Scale menu, choose Time or Tracks. 

You can use these scales to select a certain portion of the media to play. 

~ To select a certain position 

1. Move to the time or track position you want by dragging the scroll box or by 
clicking the scroll bar or scroll arrows. 

You can also use the LEFT ARROW, RIGHT ARROW, PAGE UP, PAGE DOWN, HOME, 

and END keys to move around in the file. 

2. Choose the Play button. 

Quitting Media Player 
Simple devices, such as audio compact-disc players and videodisc players, will 
continue to play even after Media Player is closed. 

Compound devices, such as MIDI and other sound files, stop playing when you 
quit the application. 
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~ To quit Media Player 

• From the File menu, choose Exit. 

Windows Notepad is a text editor. You can use Notepad to jot down notes, write 
short memos, and create and edit batch files. 

~ To start Notepad 

• In the Accessories group, choose the Notepad icon. 

The insertion point appears in the upper-left corner of the window. 

You can move the insertion point either by clicking somewhere else in the 
document or by using the arrow keys. When you use the scroll bar to move in 
a document, the insertion point remains where it is until you move it. 

Working with Text 
Working with text in Notepad is much the same as working with text in any other 
Windows application. For more information, see Chapter 2, "Application Basics." 
There are a few differences, however, which the following sections explain. 
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Setting the Word Wrap Option 
Text that you type in the Notepad window can go beyond the right border of the 
window. If you don't want this to happen, you can specify that Notepad automati­
cally wrap text to the beginning of the next line when it reaches the right edge of 
the window. This does not affect your text file, which retains the full line of text. 

~ To set the word wrap option 

• From the Edit menu, choose Word Wrap. 

A check mark appears next to the Word Wrap command on the menu. 

Word wrapping remains in effect until you choose Word Wrap again. If word 
wrapping is off, you must press ENTER to begin a new line of text. 

Moving Around in a Notepad Document 
You can use the scroll bars to move around your Notepad document by using a 
mouse. If you are using the keyboard, you can use the arrow keys, the SPACEBAR, 

and ENTER in addition to the following keys. For information about using the 
keyboard and the scroll bars, see Chapter 2, "Application Basics." 

Press To move to 

HOME The beginning of a line 

END The end of a line 

CTRL+HOME The beginning of the document 

CTRL+END The end of the document 

Selecting Text in Notepad 
In addition to the different ways of selecting text, you can select all the text in a 
Notepad document. You can use this feature to copy an entire Notepad document 
onto the Clipboard, and then merge it with another file. 

~ To select all the text in a Notepad document 

• From the Edit menu, choose Select All. 

Notepad highlights all the text in your document. If you change your mind, click 
anywhere in the text area. 



Chapter 12 Additional Accessories 457 

Searching for Text in Notepad 
You can find specific text in Notepad by using the Find command on the Search 
menu. You can start a search at any point in a document and search either forward 
or backward from that point. You can also specify whether Notepad should match 
the uppercase and lowercase characters of the text. 

When searching for text, Notepad begins the search at the position of the insertion 
point and ends at the beginning or end of the document, depending on whether you 
choose the Up or Down option button. 

~ To search for text in Notepad 

1. Move the insertion point to the place you want to start the search. 

2. From the Search menu, choose Find. 

The Find dialog box appears. 

D Malch£ase 

3. In the Find What box, type the text you want to find. 

4. To match capitalization exactly, select the Match Case check box. 

5. To search from the insertion point to the beginning of the file, select the Up 
option button. 

The default setting is Down. This searches from the insertion point to the end 
of the file. 

6. Choose the Find Next button. 

Notepad searches for the specified text and selects the first occurrence. If there 
are no occurrences of the text in the portion of the document searched, Notepad 
displays a message telling you that it could not find the text. Choose the OK 
button. 

7. To find the next occurrence of the same text, choose the Find Next button again. 

If there are no more occurrences of the text, Notepad displays a message. 
Choose the OK button. 

You can also close the Find dialog box and choose the Find Next command 
from the Search menu. When you choose the Find Next command, Notepad 
does not display the Find dialog box but immediately searches for the text. 
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Managing Notepad Files 
Windows assigns the extension .TXT to Notepad files. For information about 
opening and saving Windows files, see Chapter 2, "Application Basics." For 
information about working with Windows files and directories, see Chapter 4, 
"File Manager." The following sections provide information specific to working 
with Notepad files. 

Creating a Time-Log Document 
You can use Notepad to create a log to keep track of how you spend your time. 

~ To create a time-log document 

1. At the left margin of the first line in a Notepad document, type .LOG in capital 
letters. 

2. Save the document. 

Every time you open this document, Notepad automatically adds the current time 
and date to the end of the document. To keep an accurate log of how you spend 
your day, you can type notes about your daily activities after each time and date. 

file .Edit Search .!::!.elp 
.LOG 

1:14PM 9/11/1991 

Spent morning organizing workshops for October sales meeting. 

5:19PM 9/11/1991 

Worked with artist on design for inuitation to sales meeting. 

Superuised update of address file for sales rep. 

8:23AM 9/12/1991 

~-------------.-----------------.-------.-.----

Note Notepad uses the system time and date. You can reset the time and date by 
using Control Panel. For more information, see Chapter 5, "Control Panel." 
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You can also add the current time and date to any Notepad document that you are 
working with. 

~ To add the current time and date to a Notepad document 

1. Move the insertion point to the place you want the time and date to appear. 

2. From the Edit menu, choose Time/Date. 

Printing a Notepad Document 

Recorder 

If you have connected and installed a printer, you can print your Notepad docu­
ment. Notepad automatically prints to the default printer. For information about 
how to install a printer, see Chapter 6, "Print Manager." 

~ To print the current document 

• From the File menu, choose Print. 

A dialog box appears. 

If you want to cancel printing, choose the Cancel button. 

When printing, Notepad automatically uses the default margin settings in 
the Page Setup dialog box. If you want to position your Notepad text differently 
on the page, you can use the Page Setup command on the File menu to change 
these settings. You can also use the Page Setup command to have Notepad print 
headers and footers. For more information about using this command, see 
"Setting Margins" and "Printing Headers and Footers" in the Calendar section 
earlier in this chapter. 

Notepad prints your documents on the default printer. If you want to use another 
printer, choose the Print Setup command from the File menu. 

By using Windows Recorder, you can record a sequence of keystrokes and mouse 
actions-called a macro-to play back at a later time. You can use macros to auto­
matically type a special phrase or code that you use frequently or to automate the 
steps of any routine task. 

~ To start Recorder 

• In the Accessories group, choose the Recorder icon. 
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Eile Macro Qptions Help 

Recording a Simple Macro 

\ 
Macros that you create 
appear in this window. 

Recorder provides various options that you can set when recording complex 
macros. When you are recording a simple macro, however, the default settings 
for these options should work in most cases. 

Recording a simple macro is a straightforward, simple process. However, the 
Windows environment, which can contain multiple windows and multiple appli­
cations, can be a complex one in which to record a macro. For more information 
about recording macros, see "Using the Record Options" and "Guidelines for 
Creating Macros" later in this chapter. 

~ To record a simple macro 

1. In the application where you are recording the macro, move the cursor to the 
place you want to start recording. 

This will also be the position from which you start playing back the macro. 

2. Switch to Recorder. From the Macro menu, choose Record. 

The Record Macro dialog box appears. 
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elayback 

To: Same Application 

Speed: L-Fa_s_t ___ ---"""'" 

D Continuous Loop 

lSI Enable Shortcut Keys 

Record Mouse: I Clicks + Drags I!~I Relative to: IWindow II~I 
Q.escription 

3. In the Record Macro Name box, type a name of up to 40 characters that 
identifies your macro. 

Or, in the Shortcut Key box, specify the shortcut key that you want to use to 
play back the macro. (You can do both if you want.) 

Although you do not have to assign a shortcut key to a macro, doing so pro­
vides an easy way to play back the macro. You can assign a shortcut key by 
combining the CTRL, SHIFT, or ALT key with virtually any other keyboard key. 
CTRL is the default setting. For more information about shortcut keys, see the 
following section, "Assigning Shortcut Keys." 

4. To begin recording your macro, choose the Start button. 

You probably do not need to change the settings for any of the other options 
when recording a simple macro. For more information about these options, 
see "Using the Record Options" later in this chapter. 

When you choose the Start button, Recorder reduces to a flashing icon. The 
icon continues flashing until recording stops, although the icon may not be 
visible if you move another window in front of it. 

5. Type the keystrokes and perform the mouse actions that you want to record. 

It is best to use few or no mouse actions when recording a macro. For more 
information, see "Deciding What to Record" and "Guidelines for Creating 
Macros" later in this chapter. 

6. When you want to stop recording, click the Recorder icon. 

Or press CTRL+BREAK. 

A dialog box appears, asking if you want to save your macro, resume 
recording, or cancel recording. 
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7. To save your macro and return to what you were doing before you started 
recording, select the Save Macro option button. 

If you want to resume recording where you left off, select the Resume 
Recording option button. To cancel recording and discard what you have 
recorded so far, select the Cancel Recording option button. 

8. Choose the OK button. 

Assigning Shortcut Keys 
It is a good idea to assign a shortcut key to a macro. Doing so provides an easy 
way of using the macro. You just press the shortcut key, and the macro starts 
playing back. However, if you prefer not to assign a shortcut key or if you run out 
of key combinations to use, you can type a name in the Record Macro Name box 
in the Record Macro dialog box instead. For more information about names and 
starting a macro by using its name, see "Using Macro Names and Descriptions" 
and "Playing Back a Macro" later in this chapter. 

Virtually any key on the keyboard can be used with the CTRL, SHIFT, or ALT key to 
create a shortcut key. If you want to use a function or keypad key as a shortcut key 
instead of a basic keyboard key, select the name for the key from the Shortcut Key 
list in the Record Macro dialog box. 

Caution Although Recorder does not prevent you from using ALT as a shortcut 
key, it is best to use it sparingly. Shortcut keys using ALT could easily conflict 
with Windows shortcut keys. 

~ To create a shortcut key using a regular keyboard key 

1. From the Macro menu, choose Record. 

The Record Macro dialog box appears. 

2. In the Shortcut Key box, type the keyboard key that you want to use. 

3. Select the check box for CTRL, SHIFT, or ALT. 

CTRL is the default setting. 

~ To assign a shortcut key using a function or keypad key 

1. From the Macro menu, choose Record. 

The Record Macro dialog box appears. 

2. Open the Shortcut Key list to display a list of function and keypad key names. 
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Names of function and keypad 
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3. Select the name you want to use from the list. 

The selected name appears in the Shortcut Key box at the top of the list. 

You can also use combinations of CTRL, SHIFT, and ALT as shortcut keys. 

Using Macro Names and Descriptions 
You can store many macros in the same Recorder file. To help you remember the 
purpose of a macro, you can type a descriptive name for the macro in the Record 
Macro Name box in the Record Macro dialog box. The name then appears with 
the shortcut key on the list of macros in the main Recorder window. If you do not 
want to assign a shortcut key to a macro, you must type a name in the Record 
Macro Name box. 

A name can contain up to 40 characters. If you want a longer description for your 
macro, you can use the Description box in the Record Macro dialog box. You can 
type an unlimited amount of text describing the macro in this box. 

Playing Back a Macro 
Once you record a macro, you can use it to speed up your work. You must be sure, 
however, to start the macro when and where it can work properly. For example, if 
you want to play back a macro that automatically enters and sets an alarm for a 
standing Wednesday-afternoon appointment, it would not be appropriate to use 
the macro in any application except Calendar. 
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~ To play back a macro by using a shortcut key 

1. Open the Recorder window, and then select from the list the macro you want to 
play back. 

2. Switch to the other application. Move the cursor to the place you want to start 
playing back the macro. 

3. Press the shortcut key assigned to the macro. 

If you have not assigned a shortcut key to the macro, you must use the Run com­
mand on the Macro menu to play back the macro. You can also use this command 
to play back a macro if you don't remember its shortcut key. 

~ To play back a macro by using the Run command 

1. Move the cursor in the application's window to the place you want to start 
playing back the macro. 

2. Switch to Recorder. From the Recorder window, select the macro you want 
to play back. 

3. From the Macro menu, choose Run. 

Or double-click the macro name. 

~ To stop a macro while it is playing back 

1. Press CTRL+BREAK. 

A dialog box appears, confirming the cancellation. 

2. Choose the OK button. 

Maintaining the Recorder Window at Playback 
The Recorder window is preset to reduce to an icon when you start playing back 
a macro by using the Run command. If you want, you can maintain the Recorder 
window in its position on the screen while the macro plays. 

~ To maintain the Recorder window when you use the Run command 

• From the Options menu, choose Minimize On Use. 

The check mark is removed from the menu command. 

To reduce the Recorder window to an icon during playback, choose the Minimize 
On Use command again. 
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Using the Record Options 
When you choose the Record command from the Macro menu, the Record Macro 
dialog box appears. 
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In addition to providing the boxes where you assign a shortcut key or a descriptive 
name to a macro, the Record Macro dialog box provides a number of options that 
you can use when recording a macro. These options allow you to decide such 
things as whether a macro can: 

• Record mouse actions relative to only a window or to the whole screen. 

• Record some or all mouse actions as well as keystrokes, or record only 
keystrokes. 

• Play back only in the application in which you record the macro, or play 
back anywhere. 

• Play back quickly, or at the recorded speed. 

• Use other macros while it is playing back. 

Each time you finish recording a macro, Recorder resets to the default setting 
any option that you changed before recording. For information about permanently 
changing the default setting for an option, see "Setting Permanent Preferences" 
later in this chapter. The following sections explain the options in the Record 
Macro dialog box. 
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Deciding What to Record 
When you record a macro, Recorder records all keystrokes and only mouse clicks 
and drags. You can choose, however, to record as much or as little mouse move­
ment as you want. 

Although you can record as many mouse actions as you want, it is best to keep 
the mouse actions to a minimum. Macros that record keystrokes are generally 
more reliable. This is because mouse actions that you record in one window might 
not be appropriate for the window in which you later want to replay the macro, 
particularly if the windows are not the same size or at the same location on the 
computer screen. 

~ To specify the mouse actions you want to record 

1. From the Macro menu, choose Record. 

The Record Macro dialog box appears. 

2. Open the Record Mouse list to display its options. 

3. Select the option you want to use. 

The option then appears as the setting in the Record Mouse box. 

4. Choose the OK button. 

The following table describes the options available in the Record Mouse box. 

Use 

Clicks + Drags 

Ignore Mouse 

Everything 

To 

Record keystrokes and all mouse actions while a mouse button 
is pressed. This is the default setting. It allows you to record 
most drawing and editing sequences in a program like Windows 
Paintbrush. 

Record only keystrokes. It is best to use this option when you 
want to record a macro to be used on more than one computer. 
Macros containing mouse actions will work properly only on 
machines using a display adapter identical to the one used when 
the macro was recorded. 

Record keystrokes and all mouse actions even when a mouse 
button is not pressed. You should use this option sparingly. 

Caution If you use the Everything option to record keystrokes and all mouse 
actions, you should press CTRL+BREAK when you want to stop recording your 
macro. If you use the mouse to stop recording, the movement of the mouse to the 
Recorder icon can cause the macro to perform incorrectly when played back. For 
example, the Recorder icon could be in a different location, or the Window could 
be a different size. 
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Choosing Where to Record 
Recorder is preset to record a macro relative to the window you are currently work­
ing in. There may be times, however, when you want to record a macro relative to 
the entire screen. For example, you might be using a full-screen application. 

~ To record a macro relative to the entire screen 

1. From the Macro menu, choose Record. 

The Record Macro dialog box appears. 

2. Open the Relative To list to display its options. 

3. Select the Screen option. 

Screen now appears as the setting in the Relative To box. 

The Relative To option that you use to record a macro is the same option you use 
to play back the option. You cannot change this option after the macro is recorded. 

Choosing Where a Macro Plays Back 
Recorder is preset to play back a macro only in the application in which you 
recorded it. The To option in the Record Macro dialog box gives you a choice of 
playing back a macro in any application. Be aware that a macro that makes sense 
in one application might not make sense in another. For example, a macro that 
types a long phrase that you use frequently might be appropriate for your word 
processor, but not for your spreadsheet. 

~ To record a macro that plays back in any application 

1. From the Macro menu, choose Record. 

The Record Macro dialog box appears. 

2. In the Playback area, open the To list to display its options. 

3. Select the Any Application option. 

Any Application now appears as the setting in the To box. 

Including Macros Within a Macro 
You can include-or nest-up to five levels of macros within a macro. In other 
words, Macro 1 can contain a macro called Macro 2, which in turn can contain a 
macro called Macro 3, and so on. The default setting for Recorder includes nested 
macros. However, you can also record macros that cannot nest other macros inside 
themselves. 



468 Microsoft Windows User's Guide 

~ To record a macro that cannot nest other macros 

1. From the Macro menu, choose Record. 

The Record Macro dialog box appears. 

2. In the Playback area, clear the Enable Shortcut Keys check box. 

Caution Because a macro that contains a nested macro records only a shortcut 
key, not the actual sequence of steps represented by the shortcut key, any nested 
macros can be changed at any time. When you change a nested macro, you must 
be sure not to make changes that cause the macro containing the nested macro to 
stop working properly. 

Managing Recorder Files 
Recorder files can contain many macros. The macro name and shortcut key 
(if there is one) identify each macro in the file, as does any description that you 
typed for the macro. You can create Recorder macros of up to 64K in size. Differ­
ent Recorder files can contain groups of macros for use at specific times or with a 
specific application, but you can open only one file at a time. 

Windows assigns the extension .REC when you save your Recorder files. For 
information about saving and opening Windows files, see Chapter 2, "Application 
Basics." For information about working with Windows files, see Chapter 4, "File 
Manager." 

The following sections provide information specific to working with Recorder 
files. 

Changing a Macro's Properties 
You can use the Properties command on the Macro menu to change the following 
properties that you assigned to a macro when you recorded it: 

• The shortcut key 

• The name 

• The description 

• Whether the macro plays back in the same application where it was recorded 
or in any application 
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• The speed at which the macro plays back 

• Whether the macro plays back continuously 

• Whether the macro can contain shortcut keys 

~ To change a macro's properties 

1. From the Recorder window, select the macro you want to modify. 

2. From the Macro menu, choose Properties. 

The Macro Properties dialog box appears. 

You cannot change the Relative To setting. 
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This macro will start Calendar. enter the week.ly staff meeting on llt\ 
Wednesdays at 10:00. and set an alarm to remind me. 

The screen resolution at which the 
selected macro was recorded. 

3. You can change any of the macro settings except Mouse Coordinates Relative 
To. 

4. Choose the OK button. 

The screen-resolution information lets you know what kind of screen the macro 
was recorded on. This is helpful because mouse actions are sensitive to the screen 
resolution, and macros containing mouse actions seldom work properly when they 
are played back using a different type of display adapter. 
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Deleting Macros from a Recorder File 
If you are no longer using a macro, you can delete it from a Recorder file. 

~ To delete a macro 

1. From the Recorder window, select the macro you want to delete. 

2. From the Macro menu, choose Delete. 

A dialog box appears, asking you to confirm the deletion. 

3. Choose the OK button to delete the macro. 

Merging Recorder Files 
If you want to consolidate two Recorder files, you can do so by merging a second 
Recorder file into the file you are currently using. 

~ To merge two Recorder files 

1. Open or create one of the files that you want to merge. 

2. Delete any macros that you know are duplicated in the other file. 

3. From the File menu, choose Merge. 

Recorder displays the File Merge dialog box. 

4. From the File Name list, select the file you want to merge with the current file. 

Or type the name of the file in the File Name box. 

5. Choose the OK button. 

Recorder merges the two files. If Recorder finds duplicate shortcut key assign­
ments in the files, it deletes the duplicate shortcut keys (but not the macros 
themselves) from the file it is merging with the current file. A dialog box 
appears to inform you of this. You can use the Properties command on the 
Macro menu to assign new shortcut keys to the macros. 

6. To save the combined files under a new name, choose Save As from the File 
menu. 

Or, to replace the current file with the combined files, choose Save. 
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Setting Permanent Preferences 
Each time you choose the Record command, the Record Mouse, Relative To, 
Playback To, and Playback Speed recording options are set to record macros in 
the following ways. 

Use 

Record Mouse 

Relative To 

Playback To 

Playback Speed 

To specify 

Which mouse actions are recorded. 

Whether the macro is recorded relative to the window or the screen. 

Whether the macro will play back in any application or only in the 
application in which you recorded it. 

Whether the macro plays back at the recorded speed, or faster. 

You can change the standard settings for these options if you want to. 

~ To change the standard settings for recording 

1. From the Options menu, choose Preferences. 

The Default Preferences dialog box appears. 

Record Mouse: I Clicks + Drags II 
Relative to: I Window II 

2. From each option list, select the setting you want Recorder to use as a default 
setting. 

The options are described in the table preceding this procedure. 

3. Choose the OK button. 

The settings you select in the Default Preferences dialog box become the default 
settings for the appropriate options in the Record Macro dialog box. Recorder 
continues to use these default settings until you use the Preferences command to 
change them again. For more information, see "Changing a Macro's Properties" 
earlier in this chapter. 
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Creating Macros to Use as Demos 
Recorder provides certain options for demonstrating features or applications. For 
example, you can have a macro play back at a speed appropriate for a demonstra­
tion and play back continuously. You can also set a demonstration that runs 
continuously until you turn off the computer. 

Choosing How Fast a Macro Plays Back 
Recorder is preset to playa macro back quickly. However, if you are going to use 
a macro as a demonstration, you will want the macro to play back at the same 
speed at which it was recorded. 

~ To play back a macro at the speed at which it was recorded 

1. From the Macro menu, choose Record. 

The Record Macro dialog box appears. 

2. In the Playback area of the Record Macro dialog box, open the Speed list to 
display its options. 

3. Select the Recorded Speed option. 

Recorded Speed now appears as the setting in the Speed Box. 

Setting Up for a Continuously Running Demo 
If you want to use a macro as a demonstration, you might also want the macro to 
restart itself each time it reaches the end, so that it plays back continuously. 

~ To set a macro to play back continuously 

1. From the Macro menu, choose Record. 

The Record Macro dialog box appears. 

2. In the Playback area of the Record Macro dialog box, select the Continuous 
Loop check box. 

If you select the Continuous Loop check box, YOl,l can still stop a macro by 
pressing CTRL+BREAK. 
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Turning Off Control+Break Checking 
Pressing CTRL+BREAK usually stops the recording or playing back of a macro. If 
you want to use a macro as a continuously running demonstration, you might want 
to turn off Recorder's ability to detect the CTRL+BREAK key combination. This pre­
vents an automated demonstration from being turned off by anyone who uses the 
keyboard. The macro runs until you turn off the computer. 

~ To turn off CTRL+BREAK checking 

• From the Options menu, choose Control+Break Checking. 

The check mark next to the menu command disappears. 

After turning off Control+Break Checking, you must restart your computer to stop 
a continuously running demo. 

Tip You might also want to turn off CTRL+BREAK checking if you want to include a 
CTRL+BREAK key combination in a macro. 

The next time you start Recorder after turning off Control+Break Checking, the 
command is again set to detect CTRL+BREAK. 

Turning Off Shortcut-Key Detection 
There may be times when you want to temporarily turn off Recorder's ability to 
detect shortcut keys. For example, you might want to run an application that uses 
the same shortcut key that one of your macros uses. You can do so without having 
to quit Recorder. 

~ To turn off shortcut-key detection 

• From the Options menu, choose Shortcut Keys. 

The check mark next to the menu command disappears. 

If you want to use macros again before you quit Recorder, choose Shortcut Keys 
again. Otherwise, the next time you start Recorder, the Shortcut Keys command is 
reset automatically to detect when you press shortcut keys. 
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Guidelines for Creating Macros 
To get the best results, follow these guidelines when recording macros: 

• Prepare for recording the macro. 

If there are applications on the screen that should not be involved in the macro, 
quit them or move them out of the way before you start recording. 

• Use the mouse sparingly. 

An application window might be a different size and in a different place when 
you play back a macro. This can create problems with recorded mouse actions. 
For example, the pointer might go outside a window's boundaries when you 
play back the macro, or it might point at something other than it did when you 
were recording the macro. 

• Use the Windows shortcut keys to choose menus and commands. 

If a window is near the bottom of the screen when you play back a macro, a 
menu might pop up instead of down, making the UP ARROW and DOWN ARROW 

keys move the cursor inappropriately. 

• Be aware of system incompatibility issues. 

Recorder is sensitive to the screen resolution of the system that mouse actions 
were recorded on. Macros that use mouse actions may not work properly when 
used on a system that does not use the same display adapter as the system on 
which the macro was recorded. 

Recorder is also sensitive to the keyboard that keystrokes were recorded 
with. Although most keys will play back correctly, it is best not to use a 
macro recorded using a keyboard set up for one country on a system using a 
keyboard set up for another country. For more information about keyboard 
settings, see Chapter 5, "Control Panel." 

• Be aware that Recorder is designed for use with Windows applications only. 

Sound Recorder 
You can use Windows Sound Recorder to play, record, and edit sound files. 
Before Sound Recorder can play, edit, or record a file, you must have the sound 
hardware installed and its driver installed and configured. For information about 
installing drivers, see Chapter 5, "Control Panel." 

There are five buttons that allow you to record and play back files. These buttons 
are Rewind, Forward, Play, Stop, and Record. As the sound plays, the wave box 
graphically displays the sound as if it were being shown on an oscilloscope. 
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~ To start Sound Recorder 

• From the Accessories group, choose the Sound Recorder icon. 

Opening and Playing a Sound File 

Record button 
Stop button 

Play button 

You open sound files to play or edit them. The files you can play are dependent 
on the type of hardware you have installed. 

~ To open a sound file 

1. From the File menu, choose Open. 

The Open dialog box appears. 

2. Type or select the file you want to open. 

3. Choose the OK button. 

After opening a sound file, you can play it. 

~ To start and stop playing a sound file 

1. Click the Play button. 

Or use TAB to move to the button, and then press SPACEBAR to choose it. 

The status bar displays the word "Playing." 

2. When you want to stop playing, choose the Stop button. 

When playing is stopped, the status bar displays the word "Stopped." 

3. To resume playing, choose the Play button again. 
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Each time you choose the Play button, Sound Recorder plays the file from begin­
ning to end unless you have stopped the file somewhere in the middle or moved to 
a particular position by using the scroll bar. In this case, choosing the Play button 
begins playing where the file was stopped. 

Moving Around in a Sound File 
You can move to any point in a sound file by using the scroll bar. 

~ To move to any point in a sound file 

Mouse 

• Move the scroll box by dragging it, clicking a scroll arrow, or clicking the 
scroll bar. 

Clicking a scroll arrow moves the sound back or forward .1 second. Clicking 
the scroll bar moves the sound 1 second. 

Keyboard 

1. Use TAB to move to the scroll bar. 

2. Use the LEFT ARROW and RIGHT ARROW keys to move the sound file forward or 
back. Each time you press a key, the sound moves back or forward .1 second. 

Moving to the Beginning or End of a Sound File 
You can move quickly to the beginning or end of any sound file. 

~ To move to the end of a sound file 

• Choose the Forward button. 

Or press the END key. 

~ To move to the beginning of a sound file 

• Choose the Rewind button. 

Or press the HOME key. 

Creating a Sound File 
You can create a sound file in three ways: recording sound, inserting one sound 
file in another, or mixing one sound file with another. You can also combine the 
methods. 



Chapter 12 Additional Accessories 477 

Recording a Sound File 
You can record sound files only if you have a microphone attached to your 
sound card. See your sound-card documentation for details on configuring the 
microphone. 

You can record a new file, or you can add your recording to an existing file. 
When you record into an existing file, the new sound records over and erases the 
original sound. If you start recording the new sound at the end of the file, it will 
be appended to the file. 

~ To record a new file 

1. From the File menu, choose New. 

2. Choose the Record button. 

3. Speak into the microphone. 

You can record up to one minute of speech. 

4. When you finish, choose the Stop button. 

5. From the File menu, choose Save As. 

~ To record into an existing file 

1. From the File menu, choose Open. 

The Open dialog box appears. 

2. Type or select the file you want to open. 

You may not be able to record into some sound files. Whether you can record 
into a file depends on whether the hardware that plays that file supports this 
feature. The playback and record capabilities differ between sound cards; 
check the documentation for your sound card to see what its capabilities are. 

3. Choose the OK button. 

4. Using the Play and Stop buttons or the scroll bar, go to the place in the file 
where you want to insert your recorded speech. 

5. Choose the Record button. 

6. Speak into the microphone. 

7. When you finish, choose the Stop button. 

8. From the File menu, choose Save. 

The maximum length of a file is determined by how much memory is available. 
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Linking and Embedding Sound Files 
You can insert sound files into other files by copying, linking, or embedding them. 
The method you use to insert the sound file determines how you make changes to 
it. You can link and embed information only if the application you are transferring 
the sound file to supports object linking and embedding. Check the application's 
documentation to find out. 

Method 

Copy 

Embed 

Link 

Description 

You copy a sound file to a document in a different application. After the 
sound file is in the new document, you can change it only by deleting it 
and copying a new sound file in its place. To copy a sound file, use the 
Copy command on the Edit menu to copy the sound file onto the 
Clipboard. 

Embedding is similar to copying but with one important difference: You 
can edit embedded sound files from within the other application's docu­
ment. To embed a sound file, use the Copy command on the Edit menu 
to copy the sound file onto the Clipboard. 

Linking dynamically connects two files so that information in one file 
automatically updates when information in the other file changes. To link 
a sound file, use the Copy command on the Edit menu to copy the sound 
file onto the Clipboard. 

The commands you use to insert, or paste, the sound file or object from the 
Clipboard into the application depend on whether you want the sound file copied, 
embedded, or linked. Check your application's documentation to find out how to 
complete these procedures. 

For more information about linking and embedding sound files, see Chapter 13, 
"Integrating Your Windows Applications." 

Changing an Existing Sound File 
If you have a microphone attached to your computer, you can record new sound 
into a sound file. If you don't have a microphone, there are still many ways you 
can change an existing sound file. 

You can: 

• Insert one sound file into another. 

• Mix together two sound files. 

• Make a sound softer or louder. 
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• Slow down or speed up the sound. 

• Reverse the sound. 

• Add an echo to the sound. 

• Delete part of a sound file. 

Inserting Another Sound File 
You can insert the contents of another sound file into the current sound file. The 
maximum length of the new sound file is dependent on how much memory is 
available. 

~ To insert a sound file into an existing file 

1. Using the Play and Stop buttons or the scroll bar, go to the place in the file 
where you want to insert the other sound file. 

2. From the Edit menu, choose Insert File. 

The Insert File dialog box appears. 

3. Type or select the file you want to insert. 

4. Choose the OK button. 

You can continue inserting as many files as you want until you reach the maxi­
mum time limit. The maximum length of the file is dependent on how much 
memory is available. 

Mixing In Another Sound File 
You can mix the contents of another sound file with the current sound file. The 
sound files will blend together and play simultaneously. The maximum length 
of the file is dependent on how much memory is available. 

~ To mix a sound file into an existing file 

1. Using the Play and Stop buttons or the scroll bar, go to the place in the file 
where you want to mix in the other sound file. 

2. From the Edit menu, choose Mix With File. 

The Mix With File dialog box appears. 

3. Type or select the file you want to mix in. 

4. Choose the OK button. 
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Making a Sound Softer or Louder 
You can increase or decrease the volume by 25 percent. 

~ To decrease the volume of a sound file 

1. Open the sound file whose volume you want to decrease. 

2. From the Effects menu, choose Decrease Volume. 

You can return the file to its previous volume by immediately choosing the 
Increase Volume command. 

~ To increase the volume of a sound file 

• From the Effects menu, choose Increase Volume. 

You can return the file to its previous volume by immediately choosing the 
Decrease Volume command. 

Slowing Down or Speeding Up a Sound 
You can either decrease the speed of a sound file by 50 percent or increase the 
speed by 100 percent. 

~ To decrease the speed of a sound file 

• From the Effects menu, choose Decrease Speed. 

You can return the file to its previous speed by immediately choosing the Increase 
Speed command. 

~ To increase the speed of a sound file 

• From the Effects menu, choose Increase Speed. 

You can return the file to the previous speed by immediately choosing the 
Decrease Speed command. 

Reversing the Sound 
You can reverse a sound file so that it plays backward. 
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~ To reverse a sound file 

• From the Effects menu, choose Reverse. 

To play the file in the normal direction again, choose the Reverse command 
again. 

Adding Echo to the Sound 
You can add an echo to a sound file. Until you save the file, you can undo the echo 
by using the Revert command on the File menu. 

~ To add echo to a sound file 

• From the Effects menu, choose Add Echo. 

Deleting Part of a Sound File 
You can delete the part of a sound file before or after the current playing position. 

Until you save the file, you can undo a deletion by using the Revert command on 
the File menu. 

~ To delete before the current position 

1. Using the Play and Stop buttons or the scroll bar, go to the place in the file 
before which you want to delete sound. 

2. From the Edit menu, choose Delete Before Current Position. 

A dialog box appears, requesting you to confirm the deletion. 

3. Choose the Yes button to confirm the deletion. 

~ To delete after the current position 

1. Using the Play and Stop buttons or the scroll bar, go to the place in the file after 
which you want to delete sound. 

2. From the Edit menu, choose Delete After Current Position. 

A dialog box appears, requesting you to confirm the deletion. 

3. Choose the Yes button to confirm the deletion. 
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Saving a Sound File 
For information about saving Windows files, see Chapter 2, "Application Basics." 
For information about working with Windows files and directories, see Chapter 4, 
"File Manager." 

Restoring a Sound File 
If you want to undo changes you've made, you can restore a file to its last saved 
state. After you save a sound file, you cannot undo any of the changes you've 
made to the file. 

~ To restore a sound file to its last saved state 

1. From the File menu, choose Revert. 

A dialog box appears, requesting you to confirm the restoration. 

2. Choose the Yes button to confirm the restoration. 
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Integrating Your Windows 
App I ications 

Moving Information Between Applications 

Chapter 13 

In this version of the Microsoft Windows operating system, you can use Windows 
Paintbrush, Sound Recorder, Write, Cardfile, and Object Packager to transfer and 
share information in a powerful new way. This new capability is called object 
linking and embedding. When you embed or link objects, your document can 
contain information that was created in different applications, and you can edit 
any of this information from inside your document. 

Applications that support object linking and embedding fall into two categories. 
Applications whose objects can be embedded or linked into other documents are 
called servers. Paintbrush and Sound Recorder are server applications. Applica­
tions that can accept embedded or linked objects are called clients. Write and 
Cardfile are client applications. Some applications may be both a server and a 
client. Others are only one or the other. 

To change information that you have linked or embedded, you do not have to 
delete and copy it again. You can now open one application from within another 
application, make your changes, and keep on working. For example, suppose you 
are working on a report in which you have embedded a drawing. To make changes 
to the drawing, you open it from inside the report. You can make changes to the 
drawing, and save it in the application used to create it. The drawing closes, and 
you are returned to your report. The drawing is updated from within the report. 
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Et tame in bus da ne que imp er ne d libiding gen epu 
qrd on cupidat, im urndnat. Impro b p ary minuiti P otius 
ut coercend magi Lorem ipsurn amet, consectetUf, sed 

Improb pary minuiti potius in mmad ut coercend ma 
ipsurn amet, consectetUf, sed diam nonurny Lorem ips 
Et tame in busda ne que imper ned libiding gen epund 
qrd on cupidat, im urndnat. Impfo b p ary minuiti P otius 
):I: 

D.ocument Help 
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):I: 

When you update, the changes are reflected in the 
Write document. 

You edit the Paintbrush file by choosing 
the object in the Write document. 
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To understand linking and embedding, you should be familiar with the following 
terms: 

• An object is any piece of information created by using a Windows application. 
For example, both a single cell of a spreadsheet and an entire drawing are 
objects. 

• The source document is the document from which the object originates. 

• The destination document is the document into which you place an object. 

This chapter focuses on embedding and linking objects created by Paintbrush 
and Sound Recorder into Cardfile cards and Write files. All these applications are 
included with Windows. You can also embed and link using other applications. 
Check the documentation of your other Windows applications to determine 
whether they support object linking and embedding. 

What Is Object Linking and Embedding? 
When you embed an object, you are inserting information from one document 
(the source document) into a document in a different application (the destination 
document). Embedding is similar to copying using the Clipboard, but with one 
powerful difference. To make changes to an embedded object, you simply choose 
the object in the destination document. The application in which the object was 
created opens, and you can make your changes. You no longer need to switch 
between applications to view or change different kinds of information-you can 
now perform all these operations from within one document. 

When you embed, you make a copy of the information in the source document and 
transfer this copy to the destination document. You no longer have any connection 
to the document from which you transferred the information. So, when you edit an 
embedded object, the source document is not affected. For example, suppose you 
embed a drawing into a rep()rt. Ifyoli change the embedded drawing from inside 
the report, the drawing in the source document is not affected. 

When you link an object, you are not making a copy of the information, you are 
creating a reference, or link, to the document that contains the information (source 
document). So, when you edit a linked object, you are actually editing the informa­
tion in the source document. The destination document only contains a link to 
where the object exists in the source document. 
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Improb P8%Y minuiti potius in rnmad ut coercend magi. 
ipsum amet, consectetur, sed c1iamnonumyLoremipsum 

When you edit an embedded drawing, you 
are editing a copy of the drawing. 

When you edit a linked drawing, you 
are editing the original file. 

Many documents can contain a link to a single source document. For example, if 
you create a link to a drawing in several documents, any changes you make to the 
drawing appear in the source document and in any document that contains a link 
to the drawing. 

You have access to the object from any document that contains a link to it, and 
you can change the object from within any of them. The updated version appears 
in all the documents that have a link to the object. Linking makes it easy to track 
information that appears in more than one place and that must be identical. 

You can link objects only from saved documents. For example, if you open 
Paintbrush and create a drawing, you must save it as a document before linking 
it to another document. 
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There are two ways an object can be embedded or linked within a document. You 
can place either the object itself or an iconic representation of the object into the 
document. This representation is called a package. To create a package, you use 
Windows Object Packager. For information about Object Packager, see "Working 
with Object Packager" later in this chapter. 

Embedding a Drawing 
There are two ways to embed a drawing. The first method is to start from the 
document where you want the embedded drawing to appear, such as a Write docu­
ment or Cardfile card. While you work with the application, you open Paintbrush 
to create a drawing or use an existing one. The second method is to start from 
Paintbrush. 

~ To embed a drawing, starting from Write or Cardfile 

1. Open the Cardfile card or Write document into which you want to embed a 
drawing. 

2. If you are using Write, move the insertion point to the place you want the 
drawing inserted. If you are using Cardfile, the drawing will be inserted in 
the upper-left corner of the card. 

3. If you are using Cardfile, choose Picture from the Edit menu. 

A check mark next to the command means it is in effect. 

4. From the Edit menu in Cardfile or Write, choose Insert Object. 

A dialog box appears. All applications on your computer that support object 
linking and embedding are listed. 

~~~~ie~~~t~~yp~e,:~ ........ ~ Im11~~1 
Paintbrush Picture 
Sound If~~. 

5. Select Paintbrush Picture. 

6. Choose the OK button. 

Paintbrush opens. 
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7. Create a drawing, or use the Paste From command on the Edit menu to open a 
document that contains the drawing you want to use. 

8. From the File menu in Paintbrush, choose Update. 

This places the drawing into the Write document or Cardfile card. 

9. From the File menu, choose Exit & Return To (name of document). 

You are returned to the Write document or Cardfile card so you can continue 
working. 

~ To embed a drawing, starting from Paintbrush 

1. Open Paintbrush. 

2. Create a drawing, or open a document that contains the drawing you want to 
embed. 

3. If you want to save the drawing, choose Save from the File menu. 

4. Select the drawing. 

5. From the Edit menu, choose Copy. 

A copy of the drawing is placed onto the Clipboard. 

6. Open the Write document or Cardfile card into which you want to embed the 
drawing. 

7. If you are embedding a drawing into a card in Cardfile, choose Picture from the 
Edit menu. 

A check mark next to the Picture command indicates the command is in effect. 

8. If you are using Write, place the insertion point at the location you want the 
drawing to appear. If you are using Cardfile, the drawing will be placed in the 
upper-left comer of the card. 

9. From the Edit menu in Write or Cardfile, choose Paste. 

10. The drawing appears in the Write document or Cardfile card. 

For more information about selecting a drawing in Paintbrush, see Chapter 10, 
"Paintbrush. " 
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Editing an Embedded Drawing 
You can edit an embedded drawing from inside its destination document. When 
you choose the drawing, Paintbrush opens and the drawing is displayed inside the 
Paintbrush window. 

~ To edit an embedded drawing 

Mouse 

1. If you are using Cardfile, choose Picture from the Edit menu. 

2. In the Write document or Cardfile card, double-click the linked drawing. 

Paintbrush opens with the drawing displayed. 

3. Edit the drawing as needed. 

4. From the File menu in Paintbrush, choose Update. 

The embedded drawing in the Write document or Cardfile card is updated to 
reflect your changes. 

5. From the File menu in Paintbrush, choose Exit & Return To (name of 
document). 

Paintbrush closes. 

Keyboard 

1. If you are using Cardfile, choose Picture from the Edit menu. 

2. In the Write document, use the arrow keys to move the selection cursor to the 
embedded drawing you want to edit. 

3. From the Edit menu in Write or Cardfile, choose Edit Paintbrush Picture Object. 

Paintbrush opens with the drawing displayed. 

4. Edit the drawing as needed. 

5. From the File menu in Paintbrush, choose Update. 

The embedded drawing in the Write document or Cardfile card is updated to 
reflect your changes. 

6. From the File menu in Paintbrush, choose Exit & Return To (name of 
document). 

Paintbrush closes. 
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Linking a Drawing 
When you create a link to a Paintbrush document, an image of the drawing con­
tained in the Paintbrush document is displayed in the destination document. There 
is a link between the destination and source documents. 

You can link objects only from saved documents. For example, if you open 
Paintbrush and create a drawing, you must save it as a file before linking it to 
another document. 

When you make changes to the drawing, the changes appear in every document 
that contains a link to the drawing. 

~ To link a drawing from Paintbrush 

1. Open Paintbrush. 

2. Create a drawing, or open the document that contains the drawing you want 
to link. 

3. If necessary, save your drawing. 

4. Select the drawing. 

5. From the Edit menu, choose Copy. 

A copy of the drawing is placed onto the Clipboard. 

6. Open the Write document or Cardfile card into which you want to link the 
drawing. 

7. If you are using Cardfile, choose Picture from the Edit menu. 

A check mark next to the Picture command indicates the command is in effect. 

8. If you are using Write, place the insertion point at the location you want the 
drawing to appear. If you are using Cardfile, the drawing will appear in the 
upper-left corner of the card. 

9. From the Edit menu in Write or Cardfile, choose Paste Link. 

10. Save the Write document or Cardfile card. 

You now have the original Paintbrush document containing the drawing, 
plus a link to that document in the Write document or Cardfile card. 

Note For more information about selecting a drawing in Paintbrush, see 
Chapter 10, "Paintbrush." 
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Editing a Linked Drawing 
You edit a linked drawing the same way you edit an embedded drawing. The 
difference is that any changes you make to a linked drawing appear in all the 
drawings associated with it through links, in addition to the original document 
containing the drawing. 

~ To edit a linked drawing from a Write document or Cardfile card 

Mouse 

1. If you are using Cardfile, choose Picture from the Edit menu. 

2. In the Write document or Cardfile card, double-click the linked drawing. 

Paintbrush opens, with the document containing the drawing open. 

3. Edit the drawing as necessary. 

The linked drawing in the Write document or Cardfile card is updated as 
you make your changes. 

4. From the File menu in Paintbrush, choose Save. 

5. From the File menu in Paintbrush, choose Exit. 

Paintbrush closes. 

Keyboard 

1. If you are using Cardfile, choose Picture from the Edit menu. 

2. In the Write document, use the arrow keys to move the selection cursor to the 
linked drawing you want to edit. 

3. From the Edit menu in Write or Cardfile, choose Edit Paintbrush Picture 
Object. 

Paintbrush opens, with the document containing the drawing open. 

4. Edit the drawing as necessary. 

The linked drawing in the Write document or Cardfile card is updated as you 
make your changes. 

5. From the File menu in Paintbrush, choose Save. 

6. From the File menu in Paintbrush, choose Exit. 

Paintbrush closes. 

Note If the Update option is set to Manual, you must update the link by using the 
Links command to see the changes. For more information, see "Maintaining 
Links" later in this chapter. 
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Embedding a Sound Document 
Windows Sound Recorder is an application that plays and records sound files. 
Before you can play, edit, or record a file by using Sound Recorder, you must 
have the sound hardware installed, and its driver installed and configured. For 
more information about installing drivers, see Chapter 5, "Control Panel." 

Sound Recorder plays existing sound files or sound files you have created 
(you need a microphone to record your own sound files). Sound files played 
by Sound Recorder can be embedded and linked. For more information about 
Sound Recorder, see Chapter 12, "Additional Accessories." 

Embedding a Sound Recorder File 
There are two ways to embed a Sound Recorder sound file. The first method is 
to start from the document where you want to embed the sound file, such as a 
Write document or Cardfile card. While you work with the application, you open 
Sound Recorder to select a sound file. The second method is to start from Sound 
Recorder. 

~ To embed a sound file, starting from Write or Cardfile 

1. Open the Cardfile card or Write document into which you want to embed a 
sound file. 

2. If you are using Write, move the insertion point to the place you want the sound 
file inserted. If you are using Cardfile, the sound file will be inserted in the 
upper-left corner of the card. 

3. If you are using Cardfile, choose Picture from the Edit menu. 

A check mark next to the Picture command indicates it is in effect. 

4. From the Edit menu in Cardfile or Write, choose Insert Object. 

A dialog box appears. All applications on your computer that support object 
linking and embedding are listed. 

5. Select Sound. 

6. Choose the OK button. 

Sound Recorder opens. 

7. From the Edit menu in Sound Recorder, choose the Insert File command. 

The Insert File dialog box appears. 

8. Select the sound file you want to embed, and then choose the OK button. 

Or you can record a new sound. (For more information, see Chapter 12, 
"Additional Accessories.") 
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9. From the File menu, choose Update. 

This embeds the sound file you selected into the document. 

10. From the File menu, choose Exit. 

This returns you to the Write document or Cardfile card, where you can 
continue working. 

~ To embed a sound file, starting from Sound Recorder 

1. Open Sound Recorder. 

2. Create a sound file, or open an existing one. 

3. From the Edit menu, choose Copy. 

A copy of the sound file is placed onto the Clipboard. 

4. If you want to save the sound file, choose Save from the File menu. 

5. Open the Write document or Cardfile card into which you want to embed the 
sound file. 

6. If you are using Write, place the insertion point at the location you want the 
sound file to appear. If you are using Cardfile, the sound file will be placed in 
the upper-left comer of the card. 

7. If embedding a sound file into a card in Cardfile, choose Picture from the 
Edit menu. 

A check mark next to the Picture command indicates it is in effect. 

8. From the Edit menu in Write or Cardfile, choose Paste. 

9. The Sound Recorder application icon representing the embedded sound file 
appears in the Write document or Cardfile card. 

To play the embedded sound file, double-click it. Or select the icon, choose Sound 
Object from the Edit menu, and then choose Play from the Sound Object cascad­
ing menu. 

Editing an Embedded Sound File 
You can edit a sound file only by using Sound Recorder. 

~ To edit an embedded sound file 

1. Select the embedded sound file you want to edit. 

2. From the Edit menu in Write or Cardfile, choose Sound Object, and then from 
the cascading menu choose Edit. 

Sound Recorder opens with the sound file displayed. 
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3. Edit the sound file as needed. 

4. From the File menu in Sound Recorder, choose Update. 

This updates the embedded sound file in the Write document or Cardfile card. 

5. From the File menu in Sound Recorder, choose Exit. 

Sound Recorder closes. 

Linking a Sound Recorder File 
When you link or embed a sound file created by using Sound Recorder, the Sound 
Recorder application icon is placed in the destination document. This icon repre­
sents the sound file. When you activate this icon (either by double-clicking it, or 
by choosing the Sound Object command from the Edit menu and then choosing 
Play from the cascading menu), the sound plays. 

~ To link a Sound Recorder file 

1. Open Sound Recorder. 

2. Create a sound file, or open the sound file you want to link. 

3. Save your sound file. 

4. From the Edit menu, choose Copy. 

A copy of the sound file is placed onto the Clipboard. 

5. Open the Write document or Cardfile card into which you want to link the 
sound file. 

6. If you are using Cardfile, choose Picture from the Edit menu. 

A check mark next to the Picture command indicates it is in effect. 

7. If you are using Write, place the insertion point at the location you want the 
sound file to appear. If you are using Cardfile, the sound file will appear in the 
upper-left comer of the card. 

8. From the Edit menu in Write or Cardfile, choose Paste Link. 

9. Save the Write document or Cardfile card. 

You now have the original sound file, plus a link to that sound file in the Write 
document or Cardfile card. 
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Editing a Linked Sound File 
Any changes you make to a linked sound file appear in all files that contain links 
to the sound file. 

~ To edit a linked sound file 

1. Select the linked sound file you want to edit. 

2. From the Edit menu in Write or Cardfile, choose Sound Object, and then 
choose Edit from the cascading menu. 

Sound Recorder opens with the sound file displayed. 

3. Edit the sound file as needed. 

4. From the File menu in Sound Recorder, choose Save. 

This updates the linked sound file to reflect your changes in the Write 
document or Cardfile card. 

5. From the File menu in Sound Recorder, choose Exit. 

Sound Recorder closes. 

Note The linked sound file is updated as soon as the changes are made, regardless 
of whether the link is set to update manually or automatically. The update setting 
affects only the image that represents a linked file in the destination document. 
Since the image that represents a linked sound file is an application icon, there is 
no image to update. 

Maintaining Links 
After you create a linked object, you can do the following: 

• Decide whether the object should be updated manually or automatically. 

• Create a network of links so that one object is in many documents and you can 
change the object from any of the linked documents. 

• Break a link. 

• Delete a link. 

• Fix a broken link. 
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Controlling How Linked Objects Are Updated 
You can update a linked object in two ways: automatically or manually. By 
default, linked objects are updated automatically. 

The image of an object that is linked manually does not change when the object in 
the source document changes. The object's image gets updated in the destination 
document only when you decide to update it. 

When the linked object is represented by an icon instead of by an image of the 
object, as in the case of a link to a sound or animation document, the update 
setting doesn't matter because in these cases there is no image to update. 

~ To change the way a linked object is updated 

1. Open the Write document or Cardfile card that contains the linked object. 

2. If you are using Cardfile, choose Picture from the Edit menu. 

3. From the Edit menu, choose Links. 

The Links dialog box appears. 

Paintbrush Picture CHESS.BMP 
Paintbrush Picture PARTY.BMP ~~ ~~ ~:~ ~ ~~ :~:~::::~ U!~i!lml 
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4. From the list in the Links box, select the link or links whose update option you 
want to change. 

S. Select the Automatic or Manual option button. This option applies to all linked 
drawings you select in the dialog box. 

6. Choose the OK button. 

~ To update a manual link 

1. Open the Write document or Cardfile card that contains the linked object. 

2. If you are using Cardfile, choose Picture from the Edit menu. 

3. From the Edit menu, choose Links. 

The Links dialog box appears. 
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4. Select the link or links you want to update. 

5. Choose the Update Now button. 

6. Choose the OK button. 

Creating Multiple Links 
There are two ways to create more than one link to a source document. You can 
create a link by using the procedure described earlier in this chapter, or you can 
simply copy an existing link. The result is the same-more than one document 
contains a link to the original object. You can change the object from within any 
document that contains a link to the source document, or you can change the 
source document itself. Either way, the changes are reflected everywhere that 
the linked object appears. 

For example, suppose you are writing two articles-one more technical than 
the other-for two publications, and you want both articles to contain the same 
Paintbrush drawing. Each article is a separate Write document. 

You write both articles and then create the drawing in Paintbrush. Next, you link 
the drawing into article A. Then you copy the link from article A to article B. 
Although it appears as if you are copying the drawing, you are copying only the 
link to the original document. The image of the drawing appears in article B. If 
you change the drawing from within either article, or in the original Paintbrush 
file, the drawing changes in both articles and in the Paintbrush file. 

~ To copy an existing link 

1. Open the Write document or Cardfile card containing the object whose link 
you want to copy. 

2. If you are using Cardfile, choose Picture from the Edit menu. 

3. Select the object. 

4. From the Edit menu, choose Copy. 

A copy of the link is placed onto the Clipboard. 

5. Open the Write document or Cardfile card into which you want to insert the 
link. 

6. If you are using Cardfile, choose Picture from the Edit menu. 

7. If you are using Write, move the insertion point to the place you want the 
presentation of the link to appear. In Cardfile, the link will be inserted in the 
upper-left corner of the card. 

8. From the Edit menu, choose Paste. 

The object appears in the Write document or Cardfile card. 
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Breaking a Link 
You can break a link so that a Paintbrush drawing can no longer be changed from 
within the Write document or Cardfile card where it appears. You are breaking the 
connection between the drawing in the original Paintbrush document and the 
linked drawing in the Write document or Cardfile card. The original Paintbrush 
drawing still exists. After you break a link, to change the drawing in the destina­
tion document you must cut and paste it into Paintbrush, make your changes, and 
then copy and paste it back into the destination document. 

~ To break a link 

Deleting a Link 

1. Open the Write document or Cardfile card that contains the object whose link 
you want to break. 

2. If you are using Cardfile, choose Picture from the Edit menu. 

3. Select the object. 

4. From the Edit menu, choose Links. 

The Links dialog box appears, with the link to the selected object highlighted. 

5. Choose the Cancel Link button. 

6. Choose the OK button. 

The drawing is still in the document. Only the link has been removed. 

Deleting a link is different from breaking a link. When you break a link, the draw­
ing still exists in the destination document. When you delete a link, the drawing is 
deleted at the same time. 

~ To delete a link 

1. Open the Write document or Cardfile card that contains the object whose link 
you want to delete. 

2. If you are using Cardfile, choose Picture from the Edit menu. 

3. Select the object. 

4. From the Edit menu, choose Cut. 

Both the link to the drawing and the drawing are removed from the document. 
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Fixing a Broken link 
If you change the name of a source document that contains linked objects, the 
links to those objects break because they are connected to a filename that no 
longer exists. From the destination document, you must change the name of the 
document that the object is linked to so that the link will work properly again. 

If, for any other reason, a link no longer works, try activating the object again to 
open the source document. If this is not successful, you might need to delete the 
linked object and try linking it again. 

~ To fix a broken link 

1. Open the Write document or Cardfile card that contains the object whose link 
you want to change. 

2. If you are using Cardfile, choose Picture from the Edit menu. 

3. Select the object. 

4. From the Edit menu, choose Links. 

The Links dialog box appears. 

5. Choose the Change Link button. 

The Change Link dialog box appears. 
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6. In the File Name list, select the source document you want the object to link to. 

7. Choose the OK button. 

The Links dialog box reappears with the name of the new source document 
selected. 

8. Choose the OK button. 

This closes the Links dialog box. If you changed the link so that it is pointing to 
a different document, the new object now appears in the destination document. 
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Changing Formats 
Information can be stored on the Clipboard in a variety of formats. This facilitates 
the transfer and sharing of information between applications that may use different 
formats. 

When you use the Copy command to send information to the Clipboard, the 
source application actually sends the information in more than one format. Then, 
when you paste the information from the Clipboard, the destination application 
can select the format that is easiest for it to use and display (the application's 
default format). 

You can change the format that the destination application selects from the 
Clipboard by using the Paste Special command. You use this command to select 
a different format before choosing the Paste or Paste Link command. 

When you choose the Paste Special command, a dialog box lists other available 
formats for the information currently on the Clipboard, with the default format for 
the Paste command selected. You can select a different format, and then choose 
the Paste or Paste Link command from this dialog box. If you choose the Paste 
command from the Paste Special dialog box without selecting a different format, 
this is the same as choosing Paste directly from the Edit menu. 

Note Not all applications provide the Paste Special command. Write and Cardfile, 
both applications that support object linking and embedding, provide the Paste 
Special command as described. Check the application's documentation to see 
how the Paste Special command is being used. 

~ To change formats 

1. Copy onto the Clipboard the information you want to embed or link. 

2. Open the document into which you want to embed or link the information. 

If you opened a Cardfile card, choose Picture from the Edit menu. 

If you opened a Write file, position the cursor where you want the object to 
appear. 

3. From the Edit menu, choose Paste Special. 

The Paste Special dialog box appears. 
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4. From the Data Type list, select the format you want to use. 

5. Choose the Paste button to embed the object or the Paste Link button to link it. 

Note Depending on the application used to create the object, or whether the 
object is in a saved document, the Paste Link button may not be available. 

Working with Object Packager 
There is another way to embed or link objects. Instead of embedding or linking 
the object, you can embed an icon that represents the object. This icon is called a 
package. Packages can contain either embedded objects or links to documents, but 
packages themselves are always embedded. 

A package has the same properties as any embedded object. When you activate a 
package, the object it contains is displayed, or played, as in the case of a sound or 
animation package. 

For example, suppose you are writing a report that refers to an article on the report 
topic. You want the article to be available for those who are interested in reading 
it. Placing the article as a package in your report makes the information easily 
accessible. To view the article, you simply open the package. 

By using Object Packager, an application supplied with Windows, you can create 
a package and insert it into a destination document. You can use Object Packager 
to: 

• Insert a complete document as a package into a destination document. 

• Insert part of a document as a package into a destination document. 

• Insert an MS-DOS command line to be carried out in a destination document. 

• Customize the icon that represents a packaged object. 

• Change the label of an icon. 

You can only insert a package into an application that supports object linking and 
embedding. Check the application's documentation to determine whether the appli­
cation supports this functionality. 

Packaging an Entire Document 
A package can contain either an embedded document or a link to a document. 
How you create the package determines its contents. Use Object Packager to pack­
age an embedded document. Use File Manager to package an embedded document 
or a link to a document. 
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~ To package an entire document by using Object Packager 

1. Open Object Packager. 

file .Edit !:!elp 
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Content window 

2. Select the Content window either by clicking the window or pressing TAB. 

3. From the File menu, choose Import. 

The Import dialog box appears. 
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4. Select the directory containing the document you want to insert as a package. 

5. Select the document's filename, or type it in the File Name box. 

6. Choose the OK button. 

The filename appears in the Content window, and the icon of the application 
used to create the document appears in the Appearance window. You can 
change the icon by choosing the Insert Icon button, and you can change the 
label by choosing Label from the Edit menu. 
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7. From the Edit menu in Object Packager, choose Copy Package. 

8. Open the document into which you want to insert the package. 

The application used to create the document must support object linking and 
embedding. 

9. Move the insertion point to the place you want the package to appear. 

10. From the Edit menu in the document, choose Paste. 

The package appears in the document. 
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To view the contents of the package, double-click it. Or from the Edit menu 
choose Package Object, and then from the cascading menu choose Activate 
Contents. 
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Using File Manager 
Using File Manager, you can package an embedded document or a link to a 
document in three ways. You can: 

• Copy the document, using the Clipboard, from File Manager to Object 
Packager, and then to the destination document where you paste it as a 
package. 

• Copy the document, using the Clipboard, from File Manager to the destination 
document, and paste it as a package. 

• Use the mouse to create a package in the destination document. 

The application you use to create the object being linked or embedded determines 
which method you can use to package it. Depending on when the application was 
developed (before or after this version of Windows), some of these methods may 
not be available. Check your application documentation to determine whether the 
application supports object linking and embedding. 

~ To create a package by using File Manager and Object Packager 

1. Open File Manager. 

2. Open the directory containing the document you want to package. 

3. Select the document's filename. 

4. From the File menu, choose Copy. 

The Copy dialog box appears. 
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5. Select the Copy To Clipboard option button. 

6. Choose the OK button. 

7. Open Object Packager. 

8. Select the Content window. 
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9. From the Edit menu in Object Packager, choose Paste Link to package a link 
to a document, or choose Paste to package an embedded document. 

The filename appears in the Content window, and the icon of the application 
used to create this document appears in the Appearance window. You can 
change the icon by choosing the Insert Icon button or change the label by 
choosing Label from the Edit menu. 

10. From the Edit menu, choose Copy Package. 

11. Open the document into which you want to insert the package. 

12. Move the insertion point to the place you want the package to appear. 

13. From the Edit menu in the document, choose Paste. 

The package appears as an icon in the document. To see the contents of the 
package, double-click the icon. Or choose Package Object from the Edit menu, 
and then choose Activate Contents from the Package Object cascading menu. 

With most applications that support object linking and embedding, you do not 
need to use Object Packager to embed a document as a package. Using File 
Manager, you can copy a document onto the Clipboard and then embed it as a 
package directly into the destination document; or you can use the mouse to 
package an embedded or linked object by dragging and dropping the file icon. 

~ To package an entire document by using the Clipboard 

1. Open File Manager. 

2. Open the directory containing the document you want to insert. 

3. Select the document's filename. 

4. From the File menu, choose Copy. 

The Copy dialog box appears. 

5. Select the Copy To Clipboard option button. 

6. Choose the OK button. 

7. Open the document into which you want to insert the package. 

8. Move the insertion point to the place you want the package to appear. 

9. From the Edit menu in the document, choose Paste Link to package a linked 
document, or choose Paste to package an embedded document. 

The package appears as an icon in the document. To see the contents of the 
package, double-click the icon. Or from the Edit menu, choose Package Object, 
and then from the cascading menu choose Activate Contents. 
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~ To package an entire document by dragging and dropping the file icon 

1. Open File Manager. 

2. Select the directory containing the source document. 

3. Open the destination document. Be sure that both the File Manager window 
that contains the source document and the window containing the destination 
document are visible. 

4. Move the insertion point to the place you want the package to appear in the 
destination document. 

S. To package an embedded document, drag the icon of the source document into 
the window containing the destination document. 

To package a linked document, press CTRL+SHIFT while dragging the icon of the 
source document into the window containing the destination document. 

The pointer changes to a file icon, and it moves out of the directory window as 
you move the mouse. 

The package appears at the current insertion-point location. 

Note This feature may not be available in all applications. 

Packaging a Partial Document 
You may want to package only part of a document (such as a paragraph, chart, or 
spreadsheet). After you copy the partial document to Object Packager, it is repre­
sented by an icon that you can paste into the destination document. 

From the destination document, you can choose the icon to view the contents of 
the package. The package contains the object (partial document) you initially 
copied onto the Clipboard from the source document. 

You can only package partial documents that have been created by a server 
application (an application whose objects can be embedded or linked into 
other applications). 

~ To embed or link part of a document as a package 

1. Open the document containing the object you want to package. The object must 
have been created by a server application. 

If you are planning to link this object, the document must be named and saved. 

2. Select the object you want to package. 

3. From the Edit menu, choose Copy. 
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4. Open Object Packager. 

5. Select the Content window by either clicking the window or pressing TAB. 

6. From the Edit menu, choose Paste to embed the object or Paste Link to link it. 

7. From the Edit menu, choose Copy Package. 

8. Open the document into which you want to insert the package. 

9. Move the cursor to the place you want the package to appear. 

10. From the document's Edit menu, choose Paste. 

The package appears as an icon in the document. To see the contents of the 
package, double-click the icon. Or from the Edit menu, choose Package Object, 
and then from the cascading menu choose Activate Contents. 

Packaging an MS-DOS Command-Line Command 
You can insert an MS-DOS command-line command into a document in the form 
of a package in order to run a batch program or start another application. 

~ To insert an MS-DOS command-line command in a document 

1. Open Object Packager. 

2. From the Edit menu, choose Command Line. 

3. Type a command. If you are typing the name of a program file, include the full 
path. 

4. Choose the OK button. 

The command appears in the Content window. 

5. Choose the Insert Icon button. 

6. In the Insert Icon dialog box, select an icon. 

Or choose the Browse button. In the Browse dialog box, select a program file 
(for example, PROGMAN.EXE), and then choose the OK button. Then select 
an icon. 

7. Choose the OK button. 

The icon appears in the Appearance window. 

8. From the Edit menu, choose Copy Package. 

9. Open the document you want to place the package into, and, if applicable, 
move the cursor to the place where you want the package to appear. 

In some applications, the package is automatically placed in the upper-left 
corner of the window. 
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10. From the application's Edit menu, choose Paste. 

The package appears. 

To run the program or carry out the command, double-click the icon. Or from the 
Edit menu, choose Package Object, and then from the cascading menu choose 
Activate Contents. 

Changing the Icon 
When you use Object Packager to create a package, the Appearance window dis­
plays the icon for the package, as it will appear in the destination document. By 
default, the icon is the same as the icon of the application used to create the object. 

For example, if you used Paintbrush to create an object, the Paintbrush icon is 
displayed in the Appearance window in Object Packager. 

If you want to use a different icon, you can either choose another application icon 
(one that is provided with Windows), or create your own custom image. 

~ To change the icon 

1. Open Object Packager. 

2. From the File menu, choose Import. 

The Import dialog box appears. 

3. Select the file you want the package to contain. 

4. Choose the OK button. 

The default icon appears in the Appearance window. 

5. Choose the Insert Icon button. 

The Insert Icon dialog box appears. 
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The name of the program file used to create the document appears in the File 
Name box, and the icons associated with that program file appear in the Current 
Icon box. 
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6. To change the icon, type the name of the program file whose icon you want to 
use into the File Name box. 

If you are not sure which icons are available, choose the Browse button to open 
the Browse dialog box. In the Browse dialog box, select a program file, and 
then choose the OK button. 

From the Windows directory, choose PROGMAN.EXE to see a list of 
additional icons. 

7. In the Current Icon box, select the new icon, if there is more than one to choose 
from. 

8. Choose the OK button. 

The new icon appears in the Appearance window. 

~ To create your own icon 

1. Open the source document. 

2. Copy onto the Clipboard the object you want to insert into the destination file. 

3. Switch to Object Packager. 

4. Select the Content window by clicking the window or pressing TAB. 

5. From the Edit menu, choose Paste to embed the object or Paste Link to link it. 

The default icon appears in the Appearance window. 

6. Select the Appearance window. 

7. From the Edit menu, choose Copy. 

8. Switch to Paintbrush. 

9. From the Edit menu, choose Paste. 

The icon that was in the Appearance window of Object Packager is now pasted 
onto the Paintbrush drawing area. 

10. Make changes to this icon, or start over and create a new design. 

To save your changes, choose Save from the File menu. 

11. Select the drawing. 

12. From the Edit menu, choose Copy. This places a copy of the new icon onto the 
Clipboard. 

13. Switch to Object Packager. 

14. Select the Appearance window by clicking the window or pressing TAB. 

15. From the Edit menu, choose Paste. 

The new image or drawing appears in the Appearance window. When you 
create your own icon image, it has no label. 

16. To embed the package, choose Copy Package from the Edit menu. 
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17. Open the document into which you want to insert the package. 

18. Move the cursor to the place you want the package to appear. 

19. From the Edit menu, choose Paste. 

The package appears in the document with your custom icon. 

Changing the Label of the Package 
Each package has a label (or title) that indicates what document it contains. The 
default label depends on the contents of the package. 

• If you packaged an entire document by using File Manager, the default label is 
the filename of the document. 

• If you packaged a partial document, the default label is the object type and the 
application used to create the object. For example, a label for a drawing from 
Paintbrush would be "Paintbrush Picture." 

Under certain circumstances you cannot add a label, such as when you are using a 
custom image you created. 

~ To change the label 

1. Open Object Packager. 

2. From the Edit menu, choose Label. 

The Label dialog box opens. 

3. Type the text for the new label. 

4. Choose the OK button. 



Optimizing Windows 

Chapter 14 

What Is Optimizing? 
Optimizing is customizing your system so that it uses its resources most efficiently 
for the tasks you usually perform. Typically, optimizing involves improving one 
or more aspects of your system's performance, but sometimes sacrificing some­
thing else. For example, you might be able to run more applications at one time, 
and those applications might run faster, but you may have less disk space available 
as a result. In Microsoft Windows, optimizing your system means working with 
the following resources. 

Resource 

Speed 

Memory 

Available disk space 

Why is it important? 

Your system's speed affects the time it takes for Windows or 
an application to start up, carry out a task, redisplay a window, 
switch between applications, and so on. 

The amount of memory your system has determines how 
many applications you can run simultaneously, and how much 
information applications can store in memory at a time. It can 
also affect the speed at which Windows performs. Windows 
runs more slowly when there is little or no available memory. 

The amount of available hard disk space can affect your 
system's speed and efficiency. Some applications use disk 
space to store temporary files while they run. Windows can 
also use some of your available disk space as virtual memory. 
Virtual memory provides Windows with more memory than 
the computer actually has. 

The most important thing you can do to improve how Windows performs is 
to configure your system memory properly. After you configure your system 
memory for optimum performance with Windows, you can use other procedures 
to improve performance further. The next section will help you understand 
memory. For information about configuring memory, see "Configuring Your 
System" later in this chapter. 
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Understanding Memory 
Memory exists on your computer's main system board or on add-in memory 
boards. Before information is processed by the computer or displayed on the 
screen, it is first placed in memory. For example, application files are usually 
stored on a hard disk. When you run an application, its files are loaded into 
memory for processing. Memory also provides temporary storage for appli­
cations and data. 

In general, the more memory you have, the more applications you can run simul­
taneously in the Windows environment. You can increase the amount of memory 
on your system by plugging a memory board into a slot inside the computer, or by 
adding memory modules to an existing memory board. For example, you might 
add a 2 MB memory board to a system that already has 1 MB of memory, or you 
might add memory chips to an existing board if there is room. 

Your system may have up to four kinds of memory: 

• Conventional memory 

• Extended memory 

• Expanded memory 

• Virtual memory 

The following sections explain each type of memory. 

Identifying Your System Memory Configuration 
Because your system memory configuration significantly affects your system's 
performance, it's important to know how much and what type of memory your 
computer has. On most computers, whenever you turn on the power, you can 
watch the screen for a count of how much memory you have. However, this 
won't show you what type of memory is there. 

If you have MS-DOS version 4.0 or later, you can find out about your memory 
configuration by using the MS-DOS mem command. 

~ To find out about your system's memory configuration 

1. If Windows is running, quit Windows by choosing Exit Windows from the 
File menu in Program Manager. 

2. At the MS-DOS prompt, type mem, and then press ENTER. 

MS-DOS displays information about the type and amount of memory your 
computer has. 

3. To restart Windows, type win, and then press ENTER. 
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Another way to identify your system memory configuration is to use a diagnostics 
tool that is designed specifically for your computer. Most computers and memory 
boards come with such tools that indicate exactly what types of memory you have 
and how much of each type you have. Some programs even assist you in changing 
your memory configuration. For more information about the program(s) that came 
with your computer and any memory boards you have installed, consult the docu­
mentation that accompanied them. 

Conventional Memory 
Conventional memory exists on all personal computers. Most computers have at 
least 256K of conventional memory and can accommodate up to 640K of conven­
tional memory. 

When you start your computer, MS-DOS uses some of your computer's conven­
tional memory. Next, MS-DOS runs the commands listed in your CONFIG.SYS 
and AUTOEXEC.BAT files. Running these commands also uses conventional 
memory. Windows uses the remaining memory to manage your system and run 
your applications. 

Extended Memory 
Extended memory is general-purpose memory beyond 1 MB on 80286, 80386, and 
80486 computers. Windows needs extended memory in order to run. Extended 
memory requires an extended-memory manager. Extended-memory managers 
coordinate the use of your system's extended memory so that several applications 
do not use the same memory at the same time. Windows comes with the extended­
memory manager HIMEM. For more information about using HIMEM, see 
"Using MS-DOS Memory Managers" later in this chapter. 

Note Many 80286 and 80386 computers come with 640K of conventional 
memory and an additional 384K of "upper" memory, for a total of 1 MB of 
conventional memory. The additional 384K is not accessible by all applications 
and is usually used by device drivers, such as display drivers. 

Expanded Memory 
Expanded memory exists separately from your system's conventional and 
extended memory. Most personal computers can accommodate expanded 
memory. 
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Expanded memory is installed on an expanded-memory board and comes with 
an expanded-memory manager. Applications must request access to expanded 
memory from the expanded-memory manager. Most applications are unable to use 
expanded memory because they were not designed to interact with an expanded­
memory manager. Because an expanded-memory manager gives applications 
access to only a limited amount of expanded memory at a time, using expanded 
memory is slower than using extended memory. 

Windows and Windows applications don't use expanded memory. However, if 
you have non-Windows applications that require expanded memory you should 
still be able to run those applications in Windows. When running Windows on an 
80286 computer, most applications that require expanded memory can access it 
only if it physically exists on your computer. On 80386 and 80486 computers, 
expanded-memory emulators can simulate expanded memory for use by appli­
cations that require it. Windows running in 386 enhanced mode can simulate 
expanded memory by using an expanded-memory emulator called EMM386. 
For more information, see "Using Expanded Memory" later in this chapter. 

Some expanded-memory boards, such as the AST RAMpage! AT or Intel Above 
Board, can be set up with extended memory, with expanded memory, or with both. 
For most 80386 systems, Windows runs best if you set up your expanded-memory 
board with all extended memory. For information, see "Configuring Your System" 
later in this chapter. 

For more information about expanded memory, see "Using Expanded Memory" 
later in this chapter. 

Virtual Memory 
Virtual memory is the space on your hard disk that Windows uses as if it were 
actually memory. Windows does this through the use of swap files. For more 
information about swap files, see "How Windows Uses Swap Files" later in this 
chapter. 

The benefit of using virtual memory is that you can run more programs at one time 
than your system's physical memory would usually allow. The drawbacks are the 
disk space required for the virtual-memory swap file, and the decreased execution 
speed when swapping is required. 
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Understanding Disk Space 
Disks provide storage for program files and data files. Information stored on disks 
remains there even when you turn off your computer. The most common types of 
disks are floppy disks and hard disks. Applications and other files are stored mag­
netically on most disks, much as information is stored on a cassette tape. In this 
chapter, disk space refers to space that is available on your hard disk. 

Generally, it's a good idea to keep at least one megabyte of free space on your 
hard disk (that is, space not used by system and data files). There are several 
reasons for this: 

• Applications use disk space to save documents and other data files. 

• Windows and some applications use available disk space to temporarily store 
information that does not fit in memory. 

• Windows uses available disk space to temporarily store information that is 
being printed. 

Checking Your System's Disk Space 
It's a good idea to know how much disk space is available on your system. The 
following procedures describe how to determine this. 

~ To check the amount of free disk space when Windows is running 

1. In the Main group, choose the File Manager icon. 

2. Choose the drive icon for the drive you want to check. 

For example, to find out how much disk space is free on drive D, choose the 
D drive icon. 

A number in the status bar at the bottom of the File Manager window indicates 
how many bytes of disk space are currently available on that disk drive. (If the 
status bar does not appear, you can display it by choosing Status Bar from the 
Options menu.) 

Often, there is less free disk space when you are running Windows than when you 
are not running Windows. This is because Windows uses swap jiles, which take 
up some disk space. (For more information about Windows swap files, see the 
following section, "How Windows Uses Swap Files.") To determine how much 
disk space Windows is using, compare the amount of free disk space when 
Windows is running to the amount of free disk space when Windows is not 
running. 



520 Microsoft Windows User's Guide 

~ To check the amount of free disk space when Windows is not running 

1. Quit Windows. 

2. At the MS-DOS prompt, type: 

dir 

MS-DOS displays information about the files on the current drive, in the cur­
rent directory. The last line of information tells you how many bytes of disk 
space are free on that drive. 

If you need more disk space, you may be able to delete some unnecessary files 
from your hard disk. For information about files that you can delete, see "Deleting 
Unnecessary Files" later in this chapter. 

How Windows Uses Swap Files 
When running in 386 enhanced mode, Windows can make optimal use of memory 
by swapping. Swapping involves temporarily moving information from memory 
to a file on the hard disk, which makes the memory available for other applica­
tions. When Windows swaps information to the hard disk, it stores the information 
in a swap file. A swap file is a hidden file that reserves space on the hard disk. 
When the information temporarily stored in the swap file is needed, Windows 
moves it back into memory. 

The amount of available disk space determines how large your swap file can be. 
The larger the swap file, the more information Windows can temporarily store. 
You can limit the size of the Windows swap file if you need to conserve disk 
space. For more information about swap files, see "Working with Windows 
Swap Files" later in this chapter. 

In standard mode, each time you start a non-Windows application, Windows 
creates a temporary application swap file for that application. When you switch 
from the application, Windows moves some or all of the application from memory 
to the swap file, making the memory available for the application you are switch­
ing to. When you quit the application, Windows deletes any application swap files 
it created. (Windows does not use application swap files when running in 386 
enhanced mode.) 

The amount of available disk space determines how many application swap files 
Windows can create; this, in turn, determines how many non-Windows applica­
tions you can start at one time. For more information about application swap files, 
see "Working with Application Swap Files" later in this chapter. 
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Configuring Your System 
The most effective way to improve how Windows manages your system is to con­
figure your system memory correctly. The best configuration for you depends on 
the type of computer you have, which mode you run Windows in, and the memory 
requirements of the applications you run. 

Your system memory configuration consists of not only the hardware installed on 
your system, but also the software settings, programs, and device drivers listed in 
your CONFIG.SYS file. When you set up Windows on your computer, the Setup 
program checks the settings in your computer's CONFIG.SYS file. During setup, 
you can choose to have the Setup program update your CONFIG.SYS file as 
needed so that it includes the settings and command lines necessary to run 
Windows. 

The following sections provide basic recommendations for configuring different 
types of computers for use with Windows. Each section describes the memory 
your system should have and lists the command lines your CONFIG .SYS file 
should contain. After reading the section that applies to your computer, look for 
ways to further improve performance in Windows by reading the rest of this 
chapter. 

Configuring an 80386 or 80486 Computer 
When you start Windows by typing win at the MS-DOS prompt on an 80386 or 
80486 computer, Windows determines how much memory is available and starts 
in the mode most appropriate for your system. 

To find out what mode Windows is running in, choose the About Program 
Manager command from the Help menu in Program Manager. 

To run Windows most efficiently, your 80386 or 80486 computer should have the 
following memory: 

• 640K of conventional memory. 

• Extended memory. The more extended memory your system has, the better. 

To run Windows in standard mode, you need at least 256K of unused conven­
tional memory and at least 256K of available extended memory. 

To run Windows in 386 enhanced mode, you need at least 200K of unused 
conventional memory and at least 1024K of available extended memory. 

• If you have a memory board that can be configured as either expanded or 
extended memory, configure it as extended memory. (For information about 
how to configure your memory board, see the documentation that came with 
the memory board.) 
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Your CONFIG.SYS file should contain the following command lines: 

• A command line for an extended-memory manager such as HIMEM. 

To use extended memory, Windows requires HIMEM or a compatible memory 
manager. When you install Windows, the Setup program installs HIMEM and 
adds the HIMEM command line to your CONFIG.SYS file. The command line 
for HIMEM must be specified in the CONFIG.SYS file before any specifica­
tions for device drivers that use extended memory. 

• If necessary, a command line for the expanded-memory manager that came 
with your expanded-memory board, if you have one. For information, see the 
documentation supplied with your expanded-memory board. 

• A files command line. In general, if you are running non-Windows applications 
in Windows, make sure files is set to at least 30. 

• The buffers command line. In general, you should set buffers=20 or less. 
If you are using SMARTDrive, you can set buffers=10. If you are using 
MS-DOS version 5.0 or lat~r, you can set buffers=30. 

• If necessary, a command line for the expanded-memory emulator EMM386. 

• If necessary, a command line for the device driver EGA.SYS. 

If your system has an enhanced graphics adapter (EGA) and you run non­
Windows applications with Windows in standard mode, your CONFIG.SYS 
file should contain a command line such as the following: 

device=c: \ windows\ega.sys 

If you set up Windows to use an EGA, Windows places this line in your 
CONFIG.SYS file during the setup process. 

• A shell command specifying which command interpreter is used when you 
switch to the MS-DOS prompt. For example, if your MS-DOS files are located 
in the MSDOS directory on drive C, the shell command line should read as 
follows: 

shell=c:\msdos\command.com /p le:l024 

This specifies COMMAND. COM as the command interpreter, makes the 
command interpreter permanent, and sets an environment size of 1024 bytes. 

Configuring an 80286 Computer 
The 80286 computer can accommodate both expanded and extended memory. 
You can configure most expanded-memory boards so that they provide all 
expanded memory, all extended memory, or a mixture of both. However, you 
cannot reconfigure most extended-memory boards; they provide only extended 
memory. 
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To run Windows most efficiently, your 80286 computer should have the following 
memory: 

• 640K of conventional memory. 

• At least 256K of available extended memory. The more extended memory your 
system has, the better. 

• As much expanded memory as necessary for non-Windows applications that 
require it. 

Some non-Windows applications require expanded memory. To run such an 
application on an 80286 computer-either with Windows or from MS-DOS­
your system must include as much expanded memory as the application needs. 

If your 80286 system has a configurable expanded-memory board, you should 
configure it so that it provides only as much expanded memory as the appli­
cations need. To improve how Windows performs, configure any additional 
memory as extended. (For information about how to reconfigure your 
expanded-memory board, see the documentation that came with it.) 

Your CONFIG.SYS file should contain the same command lines that were listed 
in the previous section for 80386 or 80486 computers, except for the line that 
specifies EMM386.EXE. 

Improving the Efficiency of Your Hard Disk 
The amount of free disk space is one factor that determines your system's perform­
ance. In addition, it is important that the information taking up space on your disk 
be structured as efficiently as possible. This section describes various methods you 
can use to improve hard-disk efficiency. When using these methods, always start 
by making backup copies of your files. 

You can perform the following tasks to improve your hard disk's efficiency: 

• Delete files you don't need. 

• Use the chkdsk command to recover lost disk space. 

• Run a disk -compaction program. 

Caution Always quit Windows before using the chkdsk command with the 
If option; never run chkdsk If from within Windows. Loss of data might result. 

The following sections explain each method. 
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Deleting Unnecessary Files 
If your disk is getting full, you should delete files you don't need or don't use. 
Depending on how you use Windows, you might also be able to delete certain 
Windows files. It is particularly important to delete unnecessary files before run­
ning a disk-compaction program. There are three categories of files you might 
want to delete: 

• Windows files that were installed by the Setup program, but which you do not 
need or plan to use. For details, see the list later in this section. 

• Application files, documents, or programs that you no longer need or use. 

• Temporary files that are left on your hard disk when your computer fails 
unexpectedly. 

Caution Do not delete any Windows files other than the ones listed following 
these procedures. 

~ To delete unnecessary Windows files 

1. If you plan to delete Windows wallpaper or screen-saver files, first use Control 
Panel to change these settings to "None." 

2. While running Windows, quit all applications except Program Manager. 

3. In the Main group, choose the Windows Setup icon. 

4. From the Options menu, choose Add/Remove Windows Components. 

5. Choose the Files button for the Windows component that contains the files you 
want to delete. 

6. Follow the instructions on the screen to remove files from your hard disk. 

You can also delete unnecessary files that don't appear in the Windows Setup 
dialog boxes. Remember that by deleting these files, you make the corresponding 
Windows features unavailable. 

~ To delete other unnecessary files 

1. Quit Windows. 

2. Delete any files that remain in your TEMP directory, the directory that appli­
cations use to store temporary files. To find out which directory is set as your 
TEMP directory, look in your AUTOEXEC.BAT file for the set temp= 
command. 

You should periodically delete the files in your TEMP directory. To avoid 
deleting a temporary file that is in use, quit Windows and any applications 
before you delete files in your TEMP directory. 
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3. Delete any files that start with the characters -WOA. These files are application 
swap files that were created in standard mode. Usually, Windows deletes appli­
cation swap files when you quit the associated applications; however, these 
files might remain on your hard disk if Windows stops running unexpectedly. 
You can safely delete application swap files if Windows is not running. 

4. Delete any file named WIN386.SWP. This file is a temporary Windows swap 
file created in 386 enhanced mode. Usually, Windows deletes it when you quit 
Windows. However, a temporary Windows swap file might be left on your hard 
disk if your computer stops running unexpectedly. You can safely delete 
WIN386.SWP if Windows is not running. (Do not delete files named 
386SP ART.PAR or SPART.PAR.) 

5. If you want, delete any unwanted files or documents. 

You can delete the following Windows files if you do not plan to use them. 
Remember that by deleting files, you make the corresponding Windows features 
unavailable. 

Filename(s) 

*.BMP 

SOL.EXE, SOL.HLP 

WINMINE.EXE, WINMINE.HLP 

PBRUSH.EXE, PBRUSH.HLP, 
PBRUSH.DLL 

WRITE.EXE, WRITE. HLP 

CALENDAREXE, CALENDAR HLP 

CALC.EXE, CALC.HLP 

CARDFILE.EXE, CARDFILE.HLP 

TERMINAL.EXE, TERMINAL.HLP 

RECORDER.EXE, RECORDER HLP, 
RECORDER.DLL 

CLOCK.EXE 

EMM386.EXE 

Description 

Bitmap files with the .BMP filename exten­
sion. The Setup program automatically 
installs several bitmap files for use as 
desktop wallpaper. 

Solitaire game and its Help text. 

Minesweeper game and its Help text. 

Paintbrush accessory, its Help text, and its 
dynamic-link library. 

Write accessory and its Help text. 

Calendar accessory and its Help text. 

Calculator accessory and its Help text. 

Cardfile accessory and its Help text. 

Terminal accessory and its Help text. 

Recorder accessory, its Help text, and its 
dynamic-link library. 

Clock accessory. 

Expanded-memory emulator. (Do not 
delete this file if you're planning to 
reconfigure extended memory.) 
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Using the Chkdsk Command 
The MS-DOS chkdsk command can repair lost clusters that are taking up space 
on your hard disk. Information can get "lost" when an application stops running 
unexpectedly, leaving fragments of files on the hard disk without saving or delet­
ing them properly. Over time, these fragments can accumulate and take up disk 
space. 

When you run the chkdsk command with the If option, it finds and fixes any lost 
clusters. If you want, chkdsk can convert them to visible files that you can first 
examine and then delete if not usable. 

Caution Always quit Windows before running the chkdsk command with the 
If option; never run chkdsk If from Windows. Loss of data might result. 

Basic Recommendations 
• Run chkdsk If occasionally to be sure there are no lost file clusters on your disk. 

• Run chkdsk If before running a disk -compaction program. 

• Run chkdsk If if an application stops running unexpectedly. 

~ To repair lost files by using chkdsk 

1. Quit Windows. 

2. Change to the hard disk you want to clean up. For example, to change to drive 
D, type d: at the MS-DOS prompt. 

3. Type the command chkdsk If and then press ENTER. 

The If option tells chkdsk to fix any lost clusters it finds. 

4. If chkdsk finds any lost clusters, it asks if you want to convert the lost clusters 
to files. If you want chkdsk to place the lost clusters into files, type y for Yes. 

When you type y, chkdsk fixes any lost clusters and then converts them to 
visible files with filenames similar to FILEOOOl.CHK. It puts the files it finds 
in the root directory. The chkdsk program also displays information about the 
disk it just checked. 

If you type n, chkdsk fixes any lost clusters but does not convert them to files. 
If you type n, you can skip the remaining steps in this procedure. 

5. Use the MS-DOS type command to examine the .CHK files. For example, to 
examine the file FILEOOOl.CHK, type type fileOOO1.chk at the MS-DOS 
prompt. (To stop the type command, press CTRL+C. To control the scrolling on 
the screen, press CTRL+S.) 

Sometimes, a .CHK file might contain information you want to keep. For 
example, if a word-processing application stops running before you save 
your edits, you might find your lost edits in a recovered .CHK file. 

6. Delete any .CHK files you don't want. 



Chapter 14 Optimizing Windows 527 

Running a Disk-Compaction Program 
Over time, as applications create and delete files on your hard disk, information 
on your disk can become fragmented. Fragmentation occurs when a file, instead 
of being stored in a single location, is split into fragments that are stored in differ­
ent locations on the disk. Although fragmentation doesn't affect the validity of 
the information-your files are still complete-it takes much longer to read them 
from the disk. It also takes longer for applications to write files back to the disk. 

You can use a disk-compaction program to regroup fragmented files. Compact­
ing your hard disk can significantly speed up the time it takes for Windows and 
applications to start. 

Windows does not include a disk-compaction program. However, various 
disk-compaction programs that you can run with Windows are available. 
(Disk-compaction programs are sometimes called defragmentation utilities 
or disk organizers.) For details, see your local computer store. 

Caution Unless you have a disk-compaction program designed to run from within 
Windows, you should always run these programs directly from MS-DOS, before 
starting Windows. You should also quit all other applications and programs before 
starting a disk-compaction program. 

~ To compact a hard disk 

1. Delete any unnecessary files from the disk by following the steps outlined 
in "Deleting Unnecessary Files" earlier in this chapter. 

2. Quit Windows, and then change to the hard disk you want to compact. 

3. Type the command chkdsk If and then press ENTER. 

Never run chkdsk If from within Windows. For details about running 
chkdsk If, see the previous section, "Using the Chkdsk Command." 

4. Be sure that you are not running any programs that use the hard disk. 

5. Run your disk-compaction program according to the manufacturer's 
instructions. 

Freeing Memory Before Starting Windows 
If you sometimes run out of memory when running applications, you might be 
using too much memory before you start Windows. You can make a larger amount 
of memory available by limiting how much memory is in use before you start 
Windows. If memory-resident software is already using memory, then Windows 
cannot use that memory. 
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The following section explains how to "streamline" your CONFIG .SYS and 
AUTOEXEC.BAT files so that they start only the programs that you really 
need. It also explains how to conserve conventional memory when starting 
memory-resident software. 

Modifying the CONFIG.SYS and AUTOEXEC.BAT Files 
Your CONFIG.SYS and AUTOEXEC.BAT files may contain commands that load 
device drivers and other programs when you start your computer. You can make 
more memory available to Windows by removing unnecessary commands from 
these files. 

This procedure explains how to modify the CONFIG.SYS and AUTOEXEC.BAT 
files. Recommendations for streamlining each file follow this procedure. 

~ To modify the CONFIG.SYS or AUTOEXEC.BAT file 

1. Make a system disk that includes a backup copy of both your CONFIG.SYS 
file and your AUTOEXEC.BAT file. 

You can make a system disk by starting File Manager and then choosing Make 
System Disk from the Disk menu. Then copy your current CONFIG.SYS and 
AUTOEXEC.BAT files to the disk. (These files are usually located in the root 
directory of your first hard disk, which is usually drive C.) For more informa­
tion, see Chapter 4, "File Manager." 

2. Use a text editor such as Notepad to open and edit the files on your hard disk. 
Do not use an application such as Write to edit these files. Such applications 
can add characters that prevent MS-DOS from correctly processing the files. 

3. Edit the command lines in each file. (For specific information about the com­
mand lines in each file, see the sections that follow.) 

4. Disable any command lines for unnecessary device drivers and programs by 
using the rem command. 

When streamlining your CONFIG.SYS and AUTOEXEC.BAT files, it is 
better to simply disable command lines than to delete them. That way, if you 
accidentally disable a command line you really need, you can restore it easily. 
To disable a command line, insert the rem command (for "remark") at the 
beginning of the line. For example, to disable the following CONFIG.SYS 
command line: 

device=c: \device\smartdrv .exe 

type rem in front of it, as follows: 

rem device=c: \device \smartdrv .exe 

5. Save the files. 
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6. When you have finished editing both files, restart your computer. 

If your system does not start properly, insert the system disk you created in step 
1 into drive A, and start your computer again. If you know which command 
line(s) are causing the problem, edit the appropriate file (CONFIG.SYS or 
AUTOEXEC.BAT) on your hard disk, and restart your computer. Or, to start 
over, copy the backup version of the file(s) from the system disk to the root 
directory of your hard disk. 

Note If you use the rem command to disable command lines in your 
CONFIG.SYS file, and you are using a version of MS-DOS earlier than 4.0, 
you'll see a message such as "Unrecognized command in CONFIG.SYS" when 
you start your computer. Once you are sure that your computer works properly 
with the command lines disabled, you might want to delete the disabled command 
lines to avoid the message. 

Streamlining the CONFIG.SYS File 
The CONFIG.SYS file is a text file that defines MS-DOS device drivers and 
specifies your MS-DOS configuration. For example, a typical CONFIG.SYS file 
might specify the location of the MS-DOS file COMMAND.COM, define an 
extended-memory manager, and specify how many files an application can have 
open at once. MS-DOS runs the command lines in CONFIG.SYS whenever you 
start or restart your computer, and runs them before those in your 
AUTOEXEC.BAT file. (Your CONFIG.SYS file is located in the root directory 
of your startup drive, which is usually drive C. If you start your system by using 
a floppy disk, CONFIG.SYS is located in the root directory of that disk.) 

You can make more memory available to Windows by removing unnecessary 
commands from this file. 

~ To streamline the CONFIG.SYS file 

• Disable command lines for any unnecessary device drivers. 

Your CONFIG.SYS file should define only device drivers that you absolutely 
need. (Device drivers are defined by using the DEVICE command.) 

Do not disable the HIMEM.SYS command line. When you install Windows, 
the Setup program adds this command line to your CONFIG.SYS file if your 
system needs this device driver. For information about the device drivers 
your system needs, see the section that applies to your system in "Configuring 
Your System" earlier in this chapter. 

• Make sure the buffers setting is between 10 and 20. 

The buffers command line sets the number of disk buffers that MS-DOS allo­
cates in memory when your computer starts. These buffers allow MS-DOS to 
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improve disk-access time in certain cases. The larger the number you specify 
for buffers, the more conventional memory is used up. 

Setting buffers to a value higher than 20 might improve disk access time in 
some cases. However, doing so might also use more memory. If you are using 
MS-DOS version 5.0 or later, you can set buffers=30 without using more 
memory. 

• If your CONFIG.SYS file includes the lastdrive command, set the last drive to 
a letter such as j or k, rather than to z. (If you use a network, this may limit the 
number of network drives you can use simultaneously.) 

• If your CONFIG.SYS file contains a shell command that specifies your environ­
ment space, try specifying a smaller environment. A small environment limits 
how many environment variables you can define by using the set command in 
MS-DOS, but a large environment could take up memory. Environment space 
should always be at least 1024 bytes. 

Streamlining the AUTOEXEC.BAT File 
The AUTOEXEC.BAT file contains commands that MS-DOS runs when you start 
or restart your computer (immediately after it carries out the commands in your 
CONFIG.SYS file). Your AUTOEXEC.BAT file is located in the root directory of 
your first hard disk, which is usually drive C. If you start your system by using a 
floppy disk, AUTOEXEC.BAT is located in the root directory of that disk. 

Typically, an AUTOEXEC.BAT file starts memory-resident programs (such as 
network software) and sets up environment variables that are used later by appli­
cations. In addition, your AUTOEXEC.BAT file might set your MS-DOS prompt 
or start pop-up programs such as Borland SideKick. You can make more memory 
available to Windows by removing unnecessary commands from this file. 

Leave intact any command lines that start or enable a network. 

~ To streamline the AUTOEXEC.BAT file 

• Disable command lines that start pop-up programs or other memory-
resident software. Instead of starting memory-resident programs from 
AUTOEXEC.BAT, you can start them from within Windows. For more 
information about running memory-resident software, see the following sec­
tion, "Conserving Memory When Starting Memory-Resident Programs," and 
Chapter 7, "N on-Windows Applications." 
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• If you have a RAM drive, you might want to set your TEMP variable to 
the RAM disk. Doing so can speed up applications that store temporary files 
in the directory specified by the TEMP variable. For example, if your RAM 
drive has the drive letter E, you would place the following lines in the 
AUTOEXEC.BAT file: 

mkdir e:\temp 
set temp=e: \temp 

The first command creates the directory \TEMP on the RAM drive. The second 
command sets the TEMP variable to that directory. For more information about 
the TEMP variable, see "Using the TEMP Environment Variable" later in this 
chapter. For more information about RAM drives, see "Using RAMDrive" later 
in this chapter. 

Conserving Memory When Starting Memory-Resident Programs 
You need to start some memory-resident programs (such as network software) 
before starting Windows. This ensures that the programs are available to all 
applications that you run with Windows. However, starting them before starting 
Windows takes memory away from non-Windows applications. 

There are two ways to conserve memory when starting memory-resident programs: 

• If a particular non-Windows application needs a memory-resident program, 
you can start both the program and the application from the same batch file. 
This gives the application access to the program and does not take memory 
away from other applications. For more information about running batch pro­
grams with Windows, see "Using a Batch Program to Run Memory-Resident 
Programs" in Chapter 7, "Non-Windows Applications." 

• If only Windows applications use the memory-resident program, you can start 
it from the WINSTART.BAT file. WINSTART.BAT contains a batch program 
that Windows runs after starting in 386 enhanced mode. It is not created by 
Windows, so if you want to use it, you need to create it and place it in your 
Windows directory. 

When you start a program from WINSTART.BAT, that program is available to 
Windows applications but not to non-Windows applications. This prevents the 
program from taking memory away from non-Windows applications. 

Some memory-resident programs do not work when started from 
WINS TART .BAT. For information, see the documentation that came 
with the program. 
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Setting Multitasking Options 
When Windows is running in 386 enhanced mode, you may need to specify how 
applications share resources. You can do this by using Control Panel. 

You use the Scheduling options in the 386 Enhanced dialog box to determine 
how Windows performs when running more than one application. These options 
are described in the following table. For information about running more than one 
non-Windows application, see Chapter 7, "Non-Windows Applications," and 
Chapter 8, "PIF Editor." 

Use 

Minimum Timeslice 

Windows In Foreground 

Windows In Background 

To 

Specify the minimum number of milliseconds an applica­
tion can run before Windows gives processor control to 
another application. All Windows applications share one 
time slice, whereas each non-Windows application gets 
its own time slice. 

The smaller the time slice, the more frequently Windows 
switches between applications. Frequent switching makes 
running more than one application at a time seem 
smoother. However, overall system performance declines. 
Specifying a larger time slice increases the individual 
application's speed but makes switching between appli­
cations more apparent. 

Specify the amount of processing time (the proportion 
of total time slices) usually shared by all Windows 
applications when a Windows application is the active 
application. The range of numbers is 1 through 10000. 

Windows uses this value, and the value specified for the 
background priority of all non-Windows applications, to 
allocate processor time accordingly. For more information 
about setting the background priority for non-Windows 
applications, see Chapter 8, "PIF Editor." 

When a non-Windows application is the active (foreground) 
application, Windows uses the value specified for the 
Windows In Background option. 

Specify the amount of processing time (the proportion of 
total time slices) usually shared by all Windows applica­
tions when a non-Windows application is running in the 
foreground. The range of numbers is 1 through 10000. 



Use 

Windows In Background 
(continued) 

Exclusive In Foreground 
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To 

Windows uses this value, the value specified for the fore­
ground priority of the active non-Windows application, 
and the value specified for the background priority of all 
non-Windows applications that are currently running in 
the background, to allocate processor time accordingly. 
For more information about setting the foreground and 
background priorities for non-Windows applications, see 
Chapter 8, "PIF Editor." 

Specify that Windows always gets 100 percent of the com­
puter's processing time whenever a Windows application 
is the active application. In other words, if a Windows 
application is active in the foreground, non-Windows 
applications in the background do not run. 

Note If the multitasking values for Windows applications and the foreground and 
background priority values for non-Windows applications do not provide enough 
processor time for your applications to run efficiently, Windows dynamically 
changes the multitasking values in Control Panel. For more information about 
setting the foreground and background priorities for non-Windows applications, 
see Chapter 8, "PIF Editor." 

Working with Windows Swap Files 
When Windows is running in 386 enhanced mode, Windows frees up memory and 
speeds things up by swapping information from memory to a swap file on your 
hard disk. A swap file is a file that reserves space on the hard disk for Windows to 
use for temporarily storing information. During Windows setup, Windows creates 
a swap file based on the type and amount of available space on your hard disk. 
The Setup program will create a permanent swap file if it can. Otherwise, 
Windows creates a temporary swap file whenever you start Windows in 386 
enhanced mode. 

A temporary swap file is named WIN386.SWP.1t is created on your hard disk 
while Windows is running and deleted when you quit Windows. It can shrink or 
grow in size as necessary. 

A permanent swap file consists of two files, SPART.PAR and 386SPART.PAR. 
The SP ART.P AR file is a read-only file and is located in your Windows directory. 
386SPART.PAR is a hidden file and is located in the root directory of the drive 
displayed under Current Settings in the Virtual Memory dialog box. Do not delete, 
move, or rename these files. 
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U sing a permanent swap file improves the speed of Windows because the 
386SPART.PAR file is contiguous, and accessing a contiguous file generally 
takes less time than accessing a noncontiguous file. 

Note If a version of Windows has already been installed on your hard disk, it's 
possible that an old version of the 386SPART.PAR swap file still exists. This file 
takes up hard-disk space that could be utilized as virtual memory. To delete the 
old version of this file and recover the hard-disk space, choose the 386 Enhanced 
icon in the Control Panel window, and then choose the Virtual Memory button. 

When you install Windows, the Windows Setup program checks to determine 
whether your hard-disk controller is compatible with the 32-bit disk-access 
feature. If it is compatible, a check box appears in the Virtual Memory dialog 
box. If you are using a permanent swap file, the Use 32-Bit Disk Access check 
box is selected. This feature provides increased performance when you are using 
MS-DOS Prompt and running non-Windows applications. 

Note The Windows version 3.1 swap-file functionality, provided by the 386 
Enhanced feature of Control Panel, replaces the Windows version 3.0 Swapfile 
program. 

You can determine if you are using a Windows swap file, and its size and type, 
by choosing the 386 Enhanced icon in the Control Panel window. 

~ To display information about your swap file 

1. In the Main group, choose the Control Panel icon. 

2. In the Control Panel window, choose the 386 Enhanced icon. 

The 386 Enhanced dialog box appears. 

3. Choose the Virtual Memory button. 

The Virtual Memory dialog box appears, which displays the current swap-file 
settings. 

Drive: 
Size: 
Type: Temporary (using MS-DOS) 
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Changing Swap-File Settings 
You can change the drive location, size, and type of the swap file that Windows is 
using. Generally, you should leave these set to their default values. However, there 
might be times when you want to change the settings. For example, if you work 
with an application that requires a large amount of memory, you might want to 
create a larger swap file. 

~ To change swap-file settings by using Control Panel 

1. In the Main group, choose the Control Panel icon. 

2. In the Control Panel window, choose the 386 Enhanced icon. 

3. In the 386 Enhanced dialog box, choose the Virtual Memory button. 

The Virtual Memory dialog box appears. 

4. Choose the Change button. 

The Virtual Memory dialog box expands. 

5. From the Drive list, select the drive where you want the swap file to be located. 
For example, if you have a second hard disk drive that has more space, you 
could select its drive letter. 

6. From the Type list, select the type of swap file you want to use. If you choose 
None, Windows will not use a swap file the next time you start Windows. 

7. In the New Size box, type the size in kilobytes for the new swap file, or press 
ENTER to accept the size recommended by Windows. 

8. To turn on or off 32-bit disk access, select the Use 32-Bit Disk Access check 
box. 

Caution Using 32-bit disk access may be unreliable on some battery-powered 
portable computers when the computer's power-saving features are enabled. 

9. Choose the OK button. 

After you make changes in the Virtual Memory dialog box and choose the 
OK button, a dialog box appears telling you to restart Windows so that your 
changes will take effect. 

10. Choose the Restart button. Do not press CTRL+ALT+DEL. 

For help with the Virtual Memory dialog box, choose the Help button or press Fl 

while using the dialog box. 

Note If you run Windows in 386 enhanced mode, you can conserve disk space 
by preventing Windows from swapping any information to the disk. You should 
not prevent swapping unless disk space is at a premium, because swapping can 
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increase the number of applications you can run at one time. To prevent Windows 
from swapping, select None in the Type box in the New Settings area of the 
expanded Virtual Memory dialog box. 

Working with Application Swap Files 
When you start a non-Windows application in standard mode, Windows 
creates a temporary application swap file for that application. (Windows does 
not use application swap files in 386 enhanced mode.) When you switch from 
the application, Windows moves some or all of the application from memory to 
the application swap file. This makes the memory available to other applications. 
When you quit the application, Windows deletes the application swap file. 

Application swap files are hidden files with names that start with the characters 
~ WOA. Windows puts these files in the directory specified by the swap disk set­
ting in your SYSTEM.INI file. If the swap disk setting is not specified, Windows 
places the files in the directory specified by the TEMP environment variable in 
your AUTOEXEC.BAT file. If there is no TEMP environment variable specified, 
Windows places swap files in the root directory of the first hard disk (or first 
floppy disk drive, if you start your system from a floppy disk). For information 
about using the TEMP environment variable, see "Using the TEMP Environment 
V ariable" later in this chapter. 

The location Windows uses to store application swap files can affect the time it 
takes to switch to and from non-Windows applications. 

Basic Recommendations 
• Usually, it is not a good idea to set swap disk to a RAM drive. If the swap disk 

setting or the TEMP environment variable specifies a RAM drive, when 
Windows tries to swap application information from memory to disk, Windows 
instead swaps it to another area of memory. This is only useful if you have 
much more memory than you require for running applications. For more infor­
mation, see "Using RAMDrive" later in this chapter. 

• Set the swapdisk setting to a hard disk with at least 512K of free disk space. 
If you have more than one hard disk, set swap disk to the disk with the most 
free space. 

The more disk space Windows can use for application swap files, the more 
non-Windows applications you can run at one time. 

• If you have more than one hard disk and the disks differ in speed, set the 
swap disk setting to the fastest disk (provided it has enough free space). 
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~ To change the location Windows uses for application swap files 

1. Open your SYSTEM.INI file by using a text editor such as Notepad. Make 
sure that you don't use an application such as Write to edit this file. Such 
applications can add characters that prevent MS-DOS from correctly 
processing the file. 

Your SYSTEM.INI file is located in your Windows directory. 

2. Find or add the [NonWindowsApp] section of the file. 

If you're using Notepad, you can find this section by choosing Find from the 
Search menu, typing [NonWindowsApp] and then choosing the OK button. 

3. Add or change the swap disk setting. 

Set swap disk to the directory and drive you want. 

For example, if you want Windows to create application swap files in the 
TEMPFILE directory on drive D, type the following: 

swapdisk=d:\tempfile 

4. Save your SYSTEM.INI file. 

5. Quit and restart Windows. 

For more information about SYSTEM.INI settings, use Write to open the 
SYSINI.WRI file located in the Windows directory. 

Using SMARTDrive 
SMARTDrive is a disk-caching program provided with Windows. SMARTDrive 
saves information read from your hard disk in a disk cache in your computer's 
extended memory. When an application tries to read that information from the 
hard disk, SMARTDrive supplies the information directly from memory instead. 

SMARTDrive also temporarily stores information to be written to disk in the disk 
cache. SMARTDrive later writes this information to the hard disk, when system 
resources are in less demand. 

You start SMARTDrive by typing the smartdrv command at the MS-DOS 
prompt before you start Windows, or by adding a command line to your 
AUTOEXEC.BAT file. When you install Windows, the Setup program adds 
the smartdrv command to your AUTOEXEC.BAT file. For information about 
using the command, see the following sections, "Installing SMARTDrive" and 
"Using the SMARTDrive Command Line." 
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Windows runs much faster when using a disk cache. It is recommended that 
you use SMARTDrive if your system has a hard disk and at least 2 MB of 
memory. Because how you set up SMARTDrive depends on the applications 
you run and your system memory configuration, there is no single "best setting" 
for SMARTDrive. After installing SMARTDrive, you might want to experiment 
to find the best settings for your system. 

Installing SMARTDrive 
When you install Windows, the Setup program copies the SMAR TDrive file to 
your hard disk and adds the smartdrv command line to your AUTOEXEC.BAT 
file. If, for some reason, Setup did not install SMARTDrive on your system, or 
if you later removed SMARTDrive, you can install it by using the following 
procedure. 

~ To install SMART Drive 

1. Make a backup copy of your AUTOEXEC.BAT file. 

2. Open your AUTOEXEC.BAT file by using a text editor such as Notepad. 

3. Add the command line for SMARTDrive to your AUTOEXEC.BAT file. 

For example, the following command line would work well on a system with 
at least 2 MB of memory. It tells MS-DOS to create a disk cache, the size of 
which depends on your system's memory configuration. 

c:\windows\smartdrv 

When you don't specify any options, SMARTDrive uses the default values. For 
information about SMARTDrive command-line options and default values, see 
the following section, "Using the SMARTDrive Command Line." 

4. Disable or remove any other command lines for disk-caching software. 

5. Save the changes to your AUTOEXEC.BAT file. 

6. Quit Windows, and then restart your computer. 

Note If you have a SCSI (small computer system interface) hard disk, you may 
need to use the double-buffering feature of SMARTDrive. For more information, 
see "Using Double Buffering" later in this chapter. 
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Using the SMARTDrive Command Line 
You can start the SMARTDrive program by typing smartdrv at the MS-DOS 
prompt before you start Windows, or by placing a command line in your 
AUTOEXEC.BAT file. The SMARTDrive command line has the following 
form: 

[drive:] [path ]smartdrv .exe [[drive [+1-]] ... ] [I e:ElementSize] 
[InitCacheSize [WinCacheSize]] [lb:BujferSize] [Ie] [/r] [/1] [lq] [Is] [I?] 

An explanation of each part of the command line follows. 

Use this value 

drive 

path 

+1-

le:ElementSize 

InitCacheSize 

WinCacheSize 

To 

Specify the letter of the disk drive for which you want to control 
caching. If you don't specify a drive letter, floppy disk drives are 
read-cached but not write-cached, hard disk drives are read- and 
write-cached, and CD-ROM and network drives are ignored. 

You can specify multiple disk drives. 

Specify the location of the SMARTDRV.EXE file. 

Enable ( +) or disable (-) caching. Use the plus (+) and minus 
(-) signs to override the default settings. If you specify a drive 
letter without a plus or minus sign, read-caching is enabled and 
write-caching is disabled. If you specify a drive letter followed 
by a plus sign (+), read- and write-caching are enabled. If you 
specify a drive letter followed by a minus sign (-), read- and 
write-caching are disabled. 

Specify in bytes the amount of the cache that SMARTDrive 
moves at a time. Valid values are 1024, 2048,4096, and 8192. 
The default value is 8192. 

Specify the size in kilobytes of the cache when SMARTDrive 
starts (before Windows is running). The size of the disk cache 
affects how efficiently SMARTDrive runs. In general, the larger 
the cache, the less often SMARTDrive needs to read information 
from the disk, which speeds up your system's performance. If 
you do not specify an InitCacheSize value, SMARTDrive sets 
the value according to how much memory your system has 
(see the table below this list). 

Limit to what amount (in kilobytes) Windows can reduce the 
cache size. Windows reduces the size of the cache to recover 
memory for its own use. Windows and SMARTDrive then 
cooperate to provide optimum use of your system memory. 
When you quit Windows, Windows restores the cache to its 
normal size. The default value depends on how much available 
memory your system has (see the table below this list). If you 
specify a value for InitCacheSize that is smaller than the value 
specified for WinCacheSize, InitCacheSize is set to the same 
size as WinCacheSize. 
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Use this value 

Ib :BuJfer Size 

Ie 

Ir 

II 

Iq 
Is 
I? 

To 

Specify the size of the read-ahead buffer. A read-ahead buffer 
is additional information that SMARTDrive reads when an appli­
cation reads information from the hard disk. For example, if an 
application reads 512K of information from a file, SMARTDrive 
then reads the amount of information specified by BuJferSize and 
saves it in memory. The next time the application needs to read 
information from that file, it can read it from memory instead. 
The default size of the read-ahead buffer is 16K. Its value can 
be any multiple of ElementSize. 

Write all cached information from memory to the hard disk. 
SMARTDrive writes information from memory to the hard disk 
at times when other disk activity has slowed. You might use this 
option if you are going to turn off your computer and want to 
make sure all cached information has been written to the hard 
disk. 

Clear the contents of the existing cache and restart 
SMARTDrive. 

Prevent SMARTDrive from loading into upper memory blocks 
(UMBs), even if there are UMBs available. You can use this 
option if you are using MS-DOS version 5.0 or later and UMBs 
are enabled. 

Prevent the display of SMARTDrive information on your screen. 

Display additional information about the status of SMARTDrive. 

Display online Help about the SMARTDrive command and 
options. 

The following table shows what the default values for InitCacheSize and 
WinCacheSize will be, depending on the amount of available extended memory 
your computer has. 

Extended Memory InitCaeheSize WinCaeheSize 

Up to 1 MB All extended memory Zero (no caching) 

Up to 2MB 1MB 256K 

Upto4MB 1MB 512K 

Upto6MB 2MB 1MB 

6 MB or more 2MB 2MB 

Caution Check that SMARTDrive has completed all write-caching before you tum 
off your computer. To make sure this has happened, type smartdrv Ie at the 
MS-DOS prompt. After all disk activity has stopped, you can safely tum off your 
computer. 
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Using Double Buffering 
If you have a SCSI (small computer system interface) hard disk, you may need 
to use the double-buffering feature of SMARTDrive. Double buffering provides 
compatibility for hard-disk controllers that cannot work with virtual memory. 

When you run Setup, it places a SMARTDrive command line in the 
AUTOEXEC.BAT file. The command line in the AUTOEXEC.BAT file 
is required in order for you to use SMARTDrive. If necessary, Setup also 
places a command line in the CONFIG.SYS file. The command line in the 
CONFIG.SYS file is required in order for you to use the double-buffering 
feature of SMARTDrive. The command line in the CONFIG.SYS file takes 
the following form: 

device=c: \windows\smartdrv .exe Idouble_ buffer 

Most hard-disk controllers do not need to use double buffering. Therefore, Setup 
does not add the command to the CONFIG.SYS file in most cases. When Setup 
is unable to determine whether double buffering is required. it adds the command 
line to the CONFIG.SYS file. 

If your computer does not require double buffering, you can remove the command 
line from the CONFIG.SYS file. 

~ To determine whether you can remove the SMARTDrive command line from 
CONFIG.SYS 

1. Make sure the SMARTDrive driver has been loaded using the CONFIG.SYS 
command line and that double buffering is enabled. 

2. In the Main group, choose the MS-DOS Prompt icon. 

3. At the MS-DOS prompt, type smartdrv and then press ENTER. 

SMARTDrive displays information about your system. 

4. Look at the column labeled "Buffering." If every line in this column reads 
"no," you can remove the device=c:\windows\smartdrv.exe Idouble_buffer 
command line from your CONFIG.SYS file. 

Using the TEMP Environment Variable 
Many applications use temporary files to store data while they're running. 
Some applications store temporary files in the directory specified by the TEMP 
(or TMP) environment variables. For information about how a particular applica­
tion stores temporary files, see the documentation that came with the application. 
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You set an environment variable by using the set command in MS-DOS. 
Typically, the set command is in the AUTOEXEC.BAT file. For example, the 
following command line sets the TEMP variable to the C:\TEMPFILE directory: 

set temp=c:\tempfile 

Setting the TEMP variable affects only those applications that check for the value 
of TEMP. 

Note Some applications check for the value of TMP instead of or in addition to 
TEMP. In this case, you would also specify set tmp=c: \tempfile in the 
AUTOEXEC.BAT file. 

Because MS-DOS allows you to create only a limited number of files in the 
root directory of a disk, but lets you create as many files as you need within a 
subdirectory, you should set the TEMP variable to a subdirectory. 

The location you specify for temporary files can affect the speed of applications 
that use the TEMP variable. If you have more than one hard disk, you should 
specify that temporary files be stored on the fastest hard disk. 

If you use RAMDrive, you might want to set the TEMP variable to your RAM 
drive. Because it's much faster to read information from memory than from a 
hard disk, an application that uses temporary files might run faster if it stores 
its temporary files on a RAM drive. Because most applications delete their tem­
porary files when they're finished using them, you don't need to worry about 
saving copies of those files before turning off your computer. However, if your 
applications require large amounts of space for temporary files, making a RAM 
drive large enough for their use might take up too much memory. This could pre­
vent Windows from running or could make your entire system run more slowly. 

Windows sometimes places application swap files in the directory specified by the 
TEMP variable. For more information about application swap files, see "Working 
with Application Swap Files" earlier in this chapter. 

Using MS-DOS Memory Managers 
To use your computer's extended or expanded memory, you must install a 
memory manager. A memory manager is a device driver that provides access to 
a particular type of memory. The following sections describe how to use several 
MS-DOS memory managers. 
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Using the HIMEM Extended-Memory Manager 
HIMEM is an extended-memory manager-a program that coordinates the use of 
your system's extended memory so that no two applications use the same memory 
at the same time. 

You install HIMEM by adding the HIMEM command line to your CONFIG.SYS 
file. The HIMEM command line must come before any command lines for applica­
tions or device drivers that use extended memory. 

Note You should always use the version of HIMEM that came with the version of 
Windows you are using. 

Using the HIMEM Command Line 
The HIMEM command line has the following form: 

device=[ drive:] [path ]himem.sys [lhmamin=m] [lnumhandles=n] [lint15=xxxx] 
[lshadowram:onloff] [lmachine:name] [la20control:onloff] [/ cpuclock:onloff] 

An explanation of each part of the command line follows. In most cases you won't 
need to specify command-line options-the default values are designed to work 
with most hardware. 

Use this value 

device= 

[drive:] [path ]himem.sys 

Ihmamin=m 

To 

Install a device driver-in this case, HIMEM. You must 
include this part of the command line. 

Specify the location of the HIMEM program file. For 
example, if HIMEM.SYS is in the root directory of drive 
C, type c:\himem.sys. HIMEM.SYS should always be 
located on the same drive that contains your MS-DOS 
files. If the HIMEM.SYS file is in the root directory of 
your startup drive, you don't need to include a path. 
However, you must always include the filename 
(HIMEM.SYS). 

Specify how many kilobytes of memory an application 
must require for HIMEM to give that application use of 
the high memory area (HMA). Only one application can 
use the HMA at a time; HIMEM allocates the HMA to the 
first application that meets the memory-use requirements 
set by this option. You can specify a value from 0 to 63. 

Set Ihmamin to the amount of memory required by the 
application that uses the most HMA memory. 
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Use this value 

Ihmamin=m 
( continued) 

Inumhandles=n 

lintlS=xxxx 

Ishadowram:onloff 

To 

The Ihmamin option is not required; the default value is 
zero. Omitting this option (or setting it to zero) specifies 
that HIMEM allocate the HMA to the first application that 
requests it, regardless of how much of the HMA the appli­
cation is going to use. 

The Ihmamin option has no effect when Windows is 
running in 386 enhanced mode. 

Specify the maximum number of extended-memory block 
(EMB) handles that can be used simultaneously. You can 
specify a value from 1 to 128; the default value is 32. 
Each additional handle requires an additional 6 bytes of 
memory. 

The Inumhandles option has no effect when Windows 
is running in 386 enhanced mode. 

Allocate the amount of extended memory (in kilobytes) 
to be reserved for the Interrupt I5h interface. Some older 
applications use the Interrupt I5h interface to allocate 
extended memory rather than using the XMS (eXtended­
Memory Specification) method provided by HIMEM. 
If you use these applications, you can ensure enough 
memory is available to them by setting xxxx to 64 KB 
larger than the amount required by the application. 

You can specify a value from 64 to 65535; however, 
you cannot specify more memory than your system has 
available. If you specify a value less than 64, the value 
becomes O. The default value is O. 

Specify whether to disable shadow RAM. Some com­
puters make ROM code run faster by "shadowing" 
it in RAM-that is, by copying the ROM code into 
faster RAM memory at startup. However, this uses 
some extended memory. Usually, on computers that use 
shadow RAM and have less than 2 MB of RAM, HIMEM 
attempts to disable shadow RAM to recover additional 
extended memory for Windows to use. (HIMEM can 
disable shadow RAM only on certain types of systems.) 
When HIMEM disables shadow RAM, the ROM code 
runs in the slower ROM instead of RAM; therefore, your 
computer might run slightly slower. 

To leave the ROM code running from RAM, even on 
systems with less than 2 MB of memory, include the 
value Ishadowram:on. To have HIMEM disable shadow 
RAM, include the value Ishadowram:off. 
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Use this value To 

Imachine:name Specify what type of computer you are using. Usually, 
HIMEM can detect your system type successfully; 
however, there are a few computers that HIMEM cannot 
detect. On such systems, HIMEM uses the default system 
type (IBM AT or compatible). You might need to include 
the Imachine option if your computer is a type that 
HIMEM cannot detect and if HIMEM does not work 
properly on your system by using the default system type. 

Currently, systems that require this option include Acer 
1100, Wyse, and IBM 7552. 

The value for name can be any of the codes or their 
equivalent numbers listed in the following table. 

Code Number Computer type 

at IBM AT or 100% 
compatible 

ps2 2 IBM PS/2 

ptlcascade 3 Phoenix Cascade BIOS 

hpvectra 4 HP Vectra (A & A+) 

att6300plus 5 AT &T 6300 Plus 

acerllOO 6 Acer 1100 

toshiba 7 Toshiba 1600 & 1200XE 

wyse 8 Wyse 12.5 Mhz 286 

tulip 9 Tulip SX 

zenith 10 Zenith ZBIOS 

atl 11 IBMPC/AT 

at2 12 IBMPC/AT 
(alternative delay) 

css 12 CSS Labs 

at3 13 IBMPC/AT 
(alternative delay) 

philips 13 Philips 

fasthp 14 HPVectra 

ibm7552 15 IBM 7552 Industrial 
Computer 

bullmicral 16 Bull Micral 60 
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Use this value 

la20control:onloff 

Icpuclock:onloff 

To 

Specify whether HIMEM is to take control of the A20 line 
even if A20 was on when HIMEM was loaded. The A20 
handler gives your computer access to the HMA. If you 
specify la20control:off, HIMEM takes control of the A20 
line only if A20 was off when HIMEM was loaded. The 
default setting is la20control:on. 

Specify whether HIMEM is to affect the clock speed of 
your computer. If your computer's clock speed changes 
when you install HIMEM, specifying Icpuclock:on may 
correct the problem; however, enabling this option slows 
down HIMEM. The default setting is Icpuclock:off. 

Sample HIMEM Command Lines 
This section shows three sample HIMEM command lines and explains what 
they do. 

Sample One: Running HIMEM with Default Values The following command 
line runs HIMEM by using the default values: 

device=himem.sys 

The command line does not include a path for HIMEM.SYS; therefore, MS-DOS 
searches for the HIMEM.SYS file only in the root directory of your startup drive. 
Because this command line does not include additional options, HIMEM uses the 
default values for those options. HIMEM allocates the HMA to the first applica­
tion that requests it and allows the simultaneous use of up to 32 extended-memory 
handles. 

Sample Two: Controlling Use of the HMA with HIMEM The following com­
mand line specifies that an application can access the HMA only if that application 
uses at least 40K of memory: 

device=c:\himem.sys Ihmamin=40 

The command line specifies that the HIMEM.SYS file is located in the root 
directory on drive C. Because no other options are specified, HIMEM uses the 
remaining default values. 
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Sample Three: 
Increasing the Number of Memory Handles that HIMEM Provides 
The following command line specifies that up to 128 extended-memory handles 
can be used simultaneously. 

device=c: \devices\himem.sys Inumhandles=128 

The command line specifies that the HIMEM.SYS file is located in the DEVICES 
directory on drive C and that HIMEM supports a maximum of 128 handles. 

RAMDrive is a memory-resident program that enables you to use part of your 
system memory as if it were a hard disk drive. This memory area is called a RAM 
drive because it exists in random access memory (RAM). RAM drives are much 
faster than hard disk drives because your computer can read information faster 
from memory than from a hard disk. A RAM drive appears to be a normal hard 
disk drive; you can use it just as you would any hard disk drive. The most impor­
tant difference between a real disk drive and a RAM drive is that because it exists 
only in memory, information on a RAM drive is lost when you turn off or restart 
your computer. 

Basic Recommendations 
• Install RAMDrive only if you really need a RAM drive. In many cases, using 

the same amount of memory for a disk cache such as SMARTDrive improves 
your system's speed more than RAMDrive would. 

• You might want to install RAMDrive if you use a diskless workstation on a 
network, and the workstation has plenty of memory. 

• You might also want to install RAMDrive if you often run applications that use 
many small temporary files. In that case, set up a RAM drive of about 256K, 
and set your TEMP environment variable to the RAM drive. For more infor­
mation, see "Using the TEMP Environment Variable" earlier in this chapter. 

Note You should always use the version of RAMDrive that came with the version 
of Windows you are using. 
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Setting Up RAMDrive 
When you set up Windows, the Setup program puts a copy of the 
RAMDRIVE.SYS file in your Windows directory. 

~ To set up RAMDrive 

1. Configure your system memory for optimum efficiency with Windows. 
For more information, see "Configuring Your System" earlier in this chapter. 

2. Make a system disk that includes a backup copy of your CONFIG.SYS file. 

You can make a system disk by starting File Manager and then choosing Make 
System Disk from the Disk menu. Then copy your current CONFIG.SYS file 
to the disk. For more information about performing these tasks, see Chapter 4, 
"File Manager." 

3. Open your CONFIG.SYS file by using a text editor such as Notepad. 

Your CONFIG.Sys file is usually located in the root directory of your hard disk. 

4. Add a command line for RAMDRIVE.SYS to your CONFIG.SYS file. 

The command line specifies the location of the RAMDRIVE.SYS file and how 
much memory to allocate to RAMDrive. The following is a typical RAMDrive 
command line: 

device=c:\windows\ramdrive.sys 256 Ie 
This command line allocates 256K of extended memory to RAMDrive and 
specifies that RAMDRIVE.SYS is in the Windows directory on drive C. For 
more information about command-line options, see the following section, 
"Using the RAMDrive Command Line." 

If you run RAMDrive in extended memory, the RAMDRIVE.SYS command 
line must come after the command line that starts HIMEM.SYS. 

5. Save the changes to your CONFIG.SYS file. 

6. Restart your computer. 

Once your computer has started, you can access the RAM drive by typing at 
the MS-DOS prompt the drive letter that was assigned to it. RAM drives are 
assigned the next available drive letter. 

Using the RAMDrive Command Line 
The RAMDrive command line has the following form: 

device=[drive:][path]ramdrive.sys [DiskSize [SectorSize [NumEntries]]] [leila] 
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An explanation of each part of the command line follows. 

Use this value 

device= 

[drive:] [path ]ramdrive.sys 

DiskSize 

SectorSize 

NumEntries 

Ie 

To 

Install a device driver-in this case, RAMDrive. You 
must include this part of the command line. 

Specify the path of the RAMDrive program file. For 
example, if RAMDRIVE.SYS is in the WINDOWS 
directory on drive C, type c:\windows\ramdrive.sys. 
If the RAMDRIVE.SYS file is in the root directory of 
your startup drive, you don't need to include a path. 
However, you must always include the filename 
(RAMDRIVE.SYS). 

Specify how many kilobytes of memory you want to 
use for the RAM disk. For example, to create a 640K 
RAM drive, specify 640. If you don't specify an 
amount, RAMDrive will create a 64K RAM drive. 
You can specify a value from 4 to 32767. However, 
you cannot specify more memory than your system 
has available. 

Specify the sector size in bytes. The size can be 128, 
256, or 512 bytes. (If you include a SectorSize value, 
you must also include a value for DiskSize.) 

Generally, you should use the default sector size of 
512 bytes. 

Limit the number of files and directories you can create 
in the RAM drive's root directory. The limit can be 
from 2 to 1024 entries; the limit you specify is rounded 
up to the nearest sector size boundary. If you do not 
specify a limit, you can create up to 64 entries in the 
RAM drive's root directory. (If you include a value for 
NumEntries, you must also include values for DiskSize 
and SectorSize.) 

If there is not enough memory to create the RAM drive 
as specified, RAMDrive will try to create it with a limit 
of 16 directory entries. This may result in a RAM drive 
with a different limit from the one you specified. 

Create the RAM drive in extended memory. 

For RAMDrive to use extended memory, your sys­
tem must be configured so that it provides extended 
memory, and the command line for the extended­
memory manager (such as HIMEM.SYS) must appear 
in your CONFIG.SYS file before the RAMDrive com­
mand line. In general, it is best to create a RAM drive 
in extended memory if your system has extended 
memory. 
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Use this value 

fa 

To 

Create the RAM drive in expanded memory. 

For RAMDrive to use expanded memory, your 
system must be configured so that it provides 
expanded memory, and the command line for the 
expanded-memory manager (such as EMM386, 
386MAX, CEMM, or QEMM) must appear in 
your CONFIG.SYS file before the RAMDrive 
command line. 

Although specifying a memory type is optional, it is highly recommended. If you 
omit both the la and the Ie options, RAMDrive uses your system's conventional 
memory. It is not a good idea to use conventional memory for a RAM drive, as 
doing so impacts the performance of Windows. 

Using Other Memory-Disk Programs with Windows 
Although you can use other memory-disk programs in conjunction with Windows, 
it is best to use RAMDrive. When you run RAMDrive in extended memory, it 
cooperates with the version of HIMEM that comes with Windows. 

Using Expanded Memory 
If your system has expanded memory that meets the LotuslIntellMicrosoft (LIM) 
Expanded Memory Specification (EMS) standard, Windows running in standard 
mode can use that expanded memory when running non-Windows applications 
that require expanded memory. Windows running in 386 enhanced mode does not 
use expanded memory. If you want to run applications that require expanded 
memory in 386 enhanced mode, you need to convert the expanded memory to 
extended memory and then use the EMM386 expanded-memory emulator. 

If your system has no expanded memory, but you have a non-Windows 
application that requires it, you can do one of the following: 

• You can run the application in 386 enhanced mode. When running in 386 
enhanced mode, Windows can simulate expanded memory for applications 
that need it. 

• You can run the application in standard mode, using EMM386 to simulate 
expanded memory. For more information, see the following section, 
"Installing the EMM386 Expanded-Memory Emulator." 

If you have an 80286 computer and a non-Windows application that requires 
expanded memory, you need an expanded-memory board. You also need to be 
sure that the expanded-memory manager that came with your expanded-memory 
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board is installed. For more information, see the documentation that came with 
your expanded-memory board. 

Installing the EMM386 Expanded-Memory Emulator 
If you are running Windows in standard mode on an 80386 or 80486 computer 
that has no expanded memory, and you have a non-Windows application that re­
quires expanded memory in order to run, you need to install an expanded-memory 
emulator. An expanded-memory emulator is a program that simulates expanded 
memory. Windows includes the expanded-memory emulator EMM386. When 
you set up Windows, the Setup program copies the EMM386.EXE file to your 
Windows directory. 

~ To install EMM386 

1. Configure your system memory for optimum efficiency with Windows. For 
more information, see "Configuring Your System" earlier in this chapter. 

2. Make a system disk that includes a backup copy of your CONFIG.SYS file. 

You can make a system disk by starting File Manager and then choosing Make 
System Disk from the Disk menu. Then copy your current CONFIG.SYS file 
to the disk. For more information about performing these tasks, see Chapter 4, 
"File Manager." 

3. Open your CONFIG.SYS file by using a text editor such as Notepad. 

Your CONFIG.SYS file is usually located in the root directory on your hard 
disk. 

4. Add a command line for EMM386 to your CONFIG.SYS file. 

The following is a typical EMM386 command line: 

device=c:\windows\emm386.exe 512 

This command allocates 512K of memory to EMM386 and specifies that 
EMM386.EXE is in the WINDOWS directory on drive C. For more infor­
mation about command-line options, see the following section, "Using the 
EMM386 Command Line." 

The EMM386 command line must come after the command line that starts 
HIMEM, but before any command lines for programs that use expanded 
memory. 

5. Disable or remove any other command lines for expanded-memory­
management software. 

6. Save the changes to your CONFIG.SYS file. 

7. Restart your computer. 

Note If possible, you should use the version of EMM386 that came with the 
version of Windows you are using. 
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Using the EMM386 Command Line 
The EMM386 command line has the following form in the CONFIG.SYS file: 

device=[ drive:] [path ]emm386.exe [onloff1auto] [/nohigh] [memory] 
[MemoryOptions] 

An explanation of each part of the command line follows. 

Use this value 

device= 

[drive:] [path ]emm386.exe 

[onlomauto] 

Inohigh 

memory 

Memo ryOp tions 

To 

Install a device driver-in this case, EMM386. 
You must include this part of the command line. 

Specify the location of the EMM386 program file. 
For example, if EMM386.EXE is in the WINDOWS 
directory on drive C, type c:\windows\emm386.exe. 
If the EMM386.EXE file is in the root directory of 
your startup drive, you don't need to include a path. 
However, you must always include the filename 
(EMM386.EXE). 

Activate EMM386 if set to on, suspend EMM386 if set 
to off, or place EMM386 in auto mode if set to auto. 
Auto mode enables expanded-memory support only 
when a program calls for it. The default value is on. 
Use the emm386 command at the MS-DOS prompt to 
change this value after EMM386 has started. 

Specify that no part of EMM386 is loaded into upper 
memory blocks (UMBs). By default, a portion of 
EMM386 is loaded into UMBs. If UMB space is at 
a premium, use this option to save approximately 3K 
of UMB space. 

Specify how many kilobytes of memory you want 
EMM386 to use. For example, to give EMM386 640K 
of memory, specify 640. You can specify a value from 
16 to 32768. (EMM386 rounds the value down to the 
nearest multiple of 16.) However, you cannot specify 
more extended memory than your system has available. 

This value is optional; if you don't specify an amount, 
EMM386 uses 256K of memory. 

Fine-tune the way EMM386 uses memory. 

You can use the EMM386 memory options to control 
the location of the EMS page frame, determine how 
EMM386 uses certain addresses, and so on. For more 
information, see the following section, "Specifying 
EMM386 Memory Options." 
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Specifying EMM386 Memory Options Under most circumstances, you don't 
need to specify memory options on the EMM386 command line, because 
EMM386 usually runs properly by using the default values. 

However, in some cases, you may want to control how EMM386 uses memory­
for example, where EMM386 puts the EMS page frame, or which addresses it can 
use for EMS pages. EMM386 provides several command-line options that you can 
use to fine-tune the way it uses memory. You can use as many of these options as 
you want, in any order you want. Be sure to include the options you want after the 
EMM386 path and memory amount (if any). 

An explanation of each EMM386 memory option follows. 

Use this option 

w=onlw=off 

frame=address 

mx 

To 

Enable or disable support for the Weitek Coprocessor. To 
enable support, include the value w=on in the command line. 
To disable support, include the value w=off instead. By default, 
Weitek Coprocessor support is disabled. 

Specify the base address of the 64K page frame. You can 
specify values in the ranges 8000h through 9000h and COOOh 
through EOOOh, in increments of 400h. 

Usually, you do not need to specify a base address; by default, 
EMM386 uses a contiguous 64K region of memory, and does 
not place the page frame below COOO:OOOO. However, some­
times it is not possible to identify adapter memory absolutely. 
If a conflict occurs, you may need to ensure that EMM386 
places the page frame at a particular location. 

You can also use the frame option to specify a more spe-
cific base address. For example, to place the page frame at 
C800:0000, type frame=C800 on the EMM386 command line. 

If you use the frame option, you cannot use the m option or the 
/p option. 

Specify the address of the page frame. You can specify a value 
from 1 through 14. The following list shows each value and its 
associated base address in hexadecimal: 

1 => COOOh 8 =>DCOOh 

2 => C400h 9 =>EOOOh 

3 => C800h 10 => 8000h 

4 => CCOOh 11 => 8400h 

5 => DOOOh 12 => 8800h 

6 => D400h 13 => 8COOh 

7 => D800h 14 => 9000h 
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Use this option 

mx (continued) 

/pmmmm 

pn=address 

x=mmmm-nnnn 

i=mmmm-nnnn 

b=address 

To 

Values ranging from 10 through 14 should be used only on 
computers with 512K of memory. If you use the m option, you 
cannot use the frame option or the /p option. 

Specifies the address of the page frame. Valid values for 
mmmm are in the ranges 8000h through 9000h and COOOh 
through EOOOh, in increments of 400h. 

If you use the /p option, you cannot use the frame option or 
the m option. 

Define the segment address of a specific page. 

The p option has the form pn=address, in which n is the num­
ber of the page you are specifying, and address is the segment 
address. For example, to place page 4 at the address CCOO, 
type p4=CCOO on the EMM386 command line. 

Valid values for n are in the range 0 through 255. Valid values 
for address are in the ranges 8000h through 9COOh and COOOh 
through ECOOh, in increments of 400h. The addresses for pages 
o through 3 must be contiguous in order to maintain compati­
bility with version 3.2 of the LIM EMS. 

If you use the frame, m, or /p option, you cannot use the 
p option to specify addresses for pages 0 through 3. 

Prevent EMM386 from using a particular range of addresses 
for an EMS page. To specify the range, include this option on 
the command line, followed by the range of addresses you 
want to exclude. Valid values for mmmm and nnnn are in the 
range AOOOh through FFFFh and are rounded down to the 
nearest 4-kilobyte boundary. For example, to prevent EMM386 
from using segments AOOO:OOOO through BOOO:OOOO, type the 
value x=AOOO-BOOO on the command line. 

The x option takes precedence over the i option if the two 
ranges overlap. 

Specify a range of segment addresses to be used (included) for 
an EMS page or for RAM. Valid values for mmmm and nnnn 
range from AOOOh through FFFFh and are rounded down to the 
nearest 4-kilobyte boundary. 

The x option takes precedence over the i option if the two 
ranges overlap. 

Specify the lowest address available for EMS "banking" 
(swapping of 16-kilobyte pages). Valid values are in the range 
1000h through 4000h. By default, 4000:0000 is the lowest 
address. To specify a different low address, include this option 
on the command line, followed by the address you want. For 
example, to make 3000:0000 the lowest address, include the 
value b=3000. 
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L=minXMS 

a=altregs 

h=handles 

d=nnn 

ram 

noems 
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To 

Ensure that the specified amount of extended memory will still 
be available after EMM386 is loaded. Specify the amount of 
memory in kilobytes. For example, to ensure that 640K of 
extended memory will be available after loading EMM386, 
type the value L=640 on the command line. 

Specify how many fast alternate register sets you want to 
allocate to EMM386. For example, to allocate 16 register sets 
to EMM386, type the value a=16 on the command line. You 
can specify a number from 0 to 254; the default setting is 7 
sets. Every alternate register set adds about 200 bytes to the 
size in memory of EMM386.EXE. 

Specify how many handles EMM386 can use. For example, 
to let EMM386 use 127 handles, type the value h=127 on the 
command line. You can specify from 1 to 255 handles; the 
default setting is 64. 

Specify how many kilobytes of memory should be reserved 
for buffered direct memory access (DMA). This value should 
reflect the largest DMA transfer that will occur while you use 
EMM386.EXE, not counting floppy disk DMA. You can 
specify from 16 to 256 kilobytes; the default setting is 16. 

Provide access to both expanded memory and the upper 
memory area. This option is valid only if you are running 
MS-DOS version 5.0 or later. 

Provide access to the upper memory area but prevent access 
to expanded memory that conforms to the LIM specification 
version 3.2. This option is valid only if you are running 
MS-DOS version 5.0 or later. 





Maintaining Windows with Setup 

Chapter 15 

When you first set up the Microsoft Windows operating system, you ran the 
Windows Setup program. During this process, you provided Windows with 
information about the hardware and software you use. 

If you make additions or changes to this hardware or software, you need to inform 
Windows by running the Setup program again. In most instances, you can run it 
from within Windows. Other situations require you to run Setup from outside 
Windows. This chapter describes how to use Setup to maintain Windows. 

Running Setup from Windows 
By running the Setup program from within Windows, you can: 

• Change some of the hardware options you specified when you first set up 
Windows. This can include installing a device driver - for a display (monitor), 
keyboard, mouse, or network - that is not supplied with Windows. 

• Install other device drivers not supplied with Windows version 3.1. 

• Set up applications already on your hard disk so that you can use them with 
Windows. 

• Add or remove optional Windows components. 

To install printer drivers, use Windows Print Manager. For more information, see 
Chapter 6, "Print Manager." To install multimedia drivers, use Windows Control 
Panel. For more information, see Chapter 5, "Control Panel." 

Caution Before running a setup program for any other Microsoft application, 
you must quit Windows Setup. Otherwise, the application's setup program may 
fail. Also, it is a good idea to quit all your running applications before you start 
Setup. This is because you must restart Windows or your computer after using 
the Setup program in order for the changes to take effect. 
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~ To run the Setup program from within Windows 

• In the Main group, choose the Windows Setup icon. (Double-click the icon. 

Changing Settings 

Or use the arrow keys to move the selection cursor to the icon, and then press 
ENTER.) 

The Windows Setup window appears. It lists your current hardware and 
software settings. 

Qptions .!::!.elp 

Display: 
Keyboard: 
Mouse: 
Network: 

VGA 
Enhanced 101 or 102 key US and Non US 
Microsoft, or IBM PS/2 
No Network Installed 

You might want to add a mouse to your system, upgrade the display (monitor) you 
specified when you first ran the Setup program, or make other changes to your 
hardware. 

For information about changing to a driver not supplied with Windows, see the 
next section, "Installing a Device Driver Not Supplied with Windows Version 3.1." 

~ To change your display, keyboard, mouse, or network 

1. Be sure your hardware is set up to match the setting to which you are changing. 

2. From the Options menu, choose Change System Settings. 

The Change System Settings dialog box appears. 

Qisplay: 1~i'fJl!~i~~II~~~~~~II!! 
~eyboard: I Enhanced 101 or 102 key US and Non US keyboards IiI 
Mouse: I Microsoft, or IBM PS/2 Il!J 
Network: I No Network Installed 1m 

3. Open the list for the setting that you want to change by clicking the arrow at the 
right of the list. Or press TAB to move to the setting that you want to change, 
and then press ALT+DOWN ARROW to open the list. 

4. Make sure your hardware is listed, and then select the setting you want by using 
the mouse or the arrow keys. 
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5. Choose the OK button. 

If Setup finds the selected device driver already on your system, it asks whether 
you want to use the installed driver or install a new one. 

Setup may request that you insert a Windows disk into drive A. If it does, insert 
the disk, or type the path of the appropriate device-driver file. Then choose the 
OK button. 

A dialog box appears that contains a Restart Windows button and may contain 
a Reboot button. 

6. If no Reboot button appears, choose the Restart Windows button. 

If the Reboot button appears, make sure there are no disks in any drive, and 
then choose the Reboot button. Your system restarts. Then restart Windows. 

Note If you do not want to change drivers, but instead want to update or copy 
a Windows version 3.1 driver, you need to quit Windows and run Setup from 
MS-DOS. For more information, see "Running Setup from MS-DOS" later in 
this chapter. 

Installing a Device Driver Not Supplied with Windows Version 3.1 
A set of device drivers is supplied with Windows version 3.1, and additional 
drivers become available periodically. For information about these drivers, contact 
your hardware manufacturer. 

Microsoft also provides the Windows Driver Library (WDL), which contains 
device drivers made available after Windows version 3.1 was released. Device 
drivers are added to the WDL as they become available. If you have a modem, you 
can download WDL device drivers from network services including CompuServe, 
GEnie, Microsoft OnLine, various user-group bulletin-board services (BBSs on 
the APCUG network), and the electronic downloading service maintained by 
Microsoft (206-637-9009). Users who do not have a modem may obtain disks 
by calling Microsoft Customer Support Services at 1-800-426-9400. 

Note If your copy of Windows was acquired outside the United States, the pack­
age contains a subsidiary information card listing bulletin-board services (BBSs) 
from which you can obtain updated device drivers. The card also lists local sub­
sidiary telephone numbers you can call to obtain drivers if no BBS is available or 
you cannot access a BBS. 

Before running the Setup program to install a device driver, check for any special 
installation instructions that came with the driver. There may be other things you 
need to do to set up the hardware. Some drivers supply setup information files that 
tell Windows Setup what type of files (such as font files) the driver supports. If 
you are not sure what your driver supports, contact the hardware manufacturer. 
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~ To install a device driver not supplied with Windows version 3.1 

1. Be sure your hardware is set up to match the setting to which you are changing. 

2. From the Options menu, choose Change System Settings. 

The Change System Settings dialog box appears. 

3. Open the list for the setting that you want to change by clicking the arrow at the 
right of the list. Or press TAB to move to the setting that you want to change, 
and then press ALT+DOWN ARROW to open the list. 

4. Scroll to the bottom of the list, and then select Other. 

Select Other even if the driver you are updating already appears on the list, so 
Setup will prompt you for the driver file. 

Setup prompts you for the disk containing the device driver. 

5. Insert the disk into drive A. Or, if the driver is located on a hard disk, type the 
path of the driver. Then choose the OK button. 

Setup displays a list of the device drivers on that disk. 

6. Select the appropriate driver, and then choose the OK button. 

You may be prompted for additional disks if more than one disk was provided 
by the hardware manufacturer. You might also be prompted for specific 
Windows version 3.1 disks. 

Setup then copies the appropriate files to your Windows SYSTEM directory 
and displays the updated list of your hardware. 

7. Choose the OK button. 

A dialog box appears that contains a Restart Windows button and may contain 
a Reboot button. 

8. If no Reboot button appears, choose the Restart Windows button. 

If the Reboot button appears, make sure there are no disks in any drive, and 
then choose the Reboot button. Your system restarts. Then restart Windows. 

Note If you installed a device driver and the change prevents Windows from run­
ning correctly (for example, if you chose an incorrect display driver), you need to 
run Setup from MS-DOS to install the correct driver. For more information, see 
"Running Setup from MS-DOS" later in this chapter. 

Setting Up Existing Applications 
After you install an application on your system, you can use Setup to set it up to 
run with Windows. Setup also adds a program-item icon to Windows Program 
Manager so you can start the application by choosing the icon. 
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Note A quick way to set up an application and create a program-item icon 
for it is to drag its program-file icon from Windows File Manager and drop it 
onto a Program Manager group window or icon. For more information, see 
Chapter 3, "Program Manager." 

You can either set up a specific application or have Setup search for and set up 
multiple applications. Procedures for both options follow. 

Setup will set up only those non-Windows applications for which Windows has 
a program information file (PIF). Windows includes setup information (as PIFs) 
for many major applications, but not all. If no PIF exists for the application you 
want, you can create one. For information about creating a PIF, see Chapter 8, 
"PIF Editor." 

~ To have Setup search for and set up applications 

1. From the Options menu, choose Set Up Applications. 

Setup displays a dialog box that asks whether you want Setup to search for 
applications to set up or whether you want to specify an application. 

2. Select the Search For Applications option button, and then choose the 
OK button. 

Setup displays a dialog box where you specify that Setup search for 
applications on one or more specific drives, and/or the current path. 

3. Click the search options you want. Or use the UP ARROW or DOWN ARROW 

key to move to the options, and then press the SPACEBAR to select them. 

4. Choose the Search Now button. 

At the completion of the search, Setup displays a dialog box, listing the 
applications found. 

Applications found on hard disk(s): 

learning Windows 1.0 
Microsoft Help 3.5 

Quick Troubleshooter 
~INCBT 

Microsoft Word 
C:\WINWORD\WINWORD.EXE 

liet up for use with Windows: 
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In the Applications Found On Hard Disk(s) list box, Setup lists the names of all 
the applications it found. (If you cancel the search, the dialog box will display 
applications Setup found before canceling occurred.) When you select one of 
these applications, the path of that application appears in the lower-left comer 
of the dialog box. 

Note In some cases, two or more applications may use the same program 
filename. If Setup finds a naming conflict, it displays a dialog box asking you 
to specify the name of the application you want. For more information, see the 
next section, "PIF Information for Non-Windows Applications." 

5. Select from the list the applications you want to add. 

You can select more than one application. Click each application you want 
to select. Or press TAB to move to the list box, use the UP ARROW or DOWN 

ARROW key to move to the application you want, and then press the SPACEBAR 

to select it. 

If you change your mind about selecting an item, you can cancel the selection 
by clicking it again or, by using the keyboard, moving to it and pressing the 
SPACEBAR again. 

6. After you select all the applications you want, choose the Add button to move 
them to the Set Up For Use With Windows list. Or press ALT+A. 

To add all the listed applications, choose the Add All button. Or press ALT+D. 

If you change your mind about adding an application after you add it, click the 
application name, and then choose the Remove button. Or press TAB to move to 
the application name, press the SPACEBAR to select it, and then press ALT+R to 
move it back to the Applications Found On Hard Disk(s) list. 

7. Once you have selected the applications you want Windows to set up, choose 
the OK button. 

~ To set up a specific application with Windows 

1. From the Options menu, choose Set Up Applications. 

Setup displays a dialog box that asks whether you want Setup to search for 
applications to set up or whether you want to specify an application. 
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2. Select the "specify" option button, and then choose the OK button. 

A dialog box appears. 

Application Path and Filename: 

I C:\EXCEL \EXCELEXE 

Add to Program Group: 

i)ffijt1t:L?il 

Iji.il~~~tit' 

L-IA.:...;;pp_lic_a_tio_ns ______ --"Ji .... !J 1{,m_~,t;~!'41 

I iI'f!Ililli1mI 

3. Type the application's path and filename. 

Or choose the Browse button to select the filename you want. 

4. In the Add To Program Group list, select a program group to add the appli­
cation to. (If you don't select a group, the application will be added to the 
Applications group.) 

5. Choose the OK button. 

PIF Information for Non-Windows Applications 
When you run a non-Windows application, Windows uses a program information 
file (PIF) to determine how to run the application. For more information about 
PIFs, see Chapter 7, "Non-Windows Applications," and Chapter 8,"PIF Editor." 

When the Setup program sets up a non-Windows application for use with 
Windows, it searches for a PIF, based on the application's program filename. 
Sometimes two or more applications have the same program filename, with a 
PIF supplied for each, and Windows cannot determine which PIF to use. When 
this occurs, you will see a dialog box similar to the following. 

Setup needs to know the application name for: 

C:\\IIORD55\WORD.EXE 

lielect the application name from the following lis!. and choose 
OK. or press ENTER to continue. 

Microsoft \IIord 5.0 
None of the above 
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~ To specify an application 

• Select the name of the application you want to set up, and then choose the 
OK button. 

In some cases, a single application will have more than one PIF associated with it. 
For example, there might be one PIF for an older version of the application and 
one for a newer version, or there might be a PIF that specifies that the application 
be run by using certain optional parameters. 

If more than one PIF exists for an application, Setup displays a dialog box where 
you can specify which PIF to use. 

~ To specify a PIF for an application 

• Select the description of the PIF you want to set up, and then choose the 
OK button. 

Adding and Removing Windows Components 
Some parts of Windows are not essential to its operation. To save space on your 
hard disk, you might choose not to set up these components during Setup. Later, 
you might decide you have adequate space for some or all of the optional com­
ponents and want to add them. Or, after you have been using Windows for a time, 
you might decide to delete some optional components in order to free up space on 
your hard disk. 

You can add and remove the following Windows components completely or 
partially by using Windows Setup: 

• Readme Files 

• Windows Accessories 

• Windows Games 

• Screen Savers 

• Wallpapers and Other Miscellaneous Files 

Caution When you remove components, the files are deleted from your system. If 
you want to add them later, you will need to use your Windows version 3.1 disks 
to supply the files. 

Adding or Removing Complete Components 
You can add or remove all of a Windows component at once if you want. For 
example, you might want to add all of the Windows games to your system. 
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~ To add or remove an entire Windows component 

1. From the Options menu, choose Add/Remove Windows Components. 

Setup displays a dialog box that lists all of the optional components and the 
disk space required to set them up on your system. 

The name of each component currently on your system is marked with an "X" 
in its check box. These components can be removed. 

To remove a component. clear its checkbox_ 

To install a component check its checkbox_ 

To remove or install specific files within a component. 
choose Files ___ for that component. 

Add/Remove 
Component Bytes Used Individual Files __ _ 

III Readme files 144.198 

I2J Accessories 1.368.612 

I2J .!iames 240.771 

I2J Screen .s.avers 56.000 

I2J ~allpapers. Misc_ 416.445 

Disk Space Currently Used by Components: 2.226.026 Bytes 

Additional Space Needed by Current Selection: 0 Bytes 

Total Available Disk Space: 21.454.848 Bytes 

Disk Space Currently Used By Components shows the total disk space required 
by all selected components. This number increases or decreases as you select or 
clear the components' check boxes. Total Available Disk Space shows the total 
unused disk space on your system. This number changes after components or 
files have been added or removed. 

2. To add an entire component (for example, all Readme files), select the check 
box next to it. To delete a component, clear the check box. 

If you are using the keyboard, press TAB (or the UP ARROW or DOWN ARROW) to 
move to the component name, and then press the SPACEBAR to select or clear the 
checkbox. 

3. If you are adding a component, a dialog box appears, requesting you to insert 
the appropriate Windows version 3.1 disk. Place the disk in the drive, and then 
choose the OK button. 

4. In the Windows Setup dialog box, choose the OK button. 
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Adding or Removing Partial Components 
If you want, you can add or remove only specific files rather than the entire com­
ponent. For example, you can select certain Windows accessories to add, and omit 
others. 

~ To add or remove part of a component 

1. From the Options menu, choose Add/Remove Windows Components. 

Setup displays a dialog box that lists the optional components and the disk 
space required to set them up on your system. 

The name of each component currently on your system is marked with an "X" 
in its check box. These components can be removed. 

Disk Space Currently Used By Components shows the total disk space required 
by all selected components. This number increases or decreases as you select or 
clear the components' check boxes. Total Available Disk Space shows the total 
unused disk space on your system. This number changes after components or 
files have been added or removed. 

2. To add or delete part of a component (for example, specific Readme files), 
click the Files button next to it. 

Or press TAB to move to the Files button, and then press the SPACEBAR to 
choose it. 

A dialog box appears, listing the component's files. Files on the right are 
currently included on your system and can be removed. Files on the left 
are not included and can be added. 

To install files. select files on the left. then choose Add. 

To remove files. select files on the right then choose Remove. 

When finished selecting. choose 0 K. 

~ Do nol install 
W- Ihe;e files: 

1 file(s) selecled: 40.704 Byles 

~
;;; Networks Readme (36K) Prinlers Readme (19K) 

Selup Readme (376K) 
Syslem.ini Readme (121 K) 
Win.ini Readme (12K) 

1:;;!'ltil~gli>t:;J 

o file( s) selected: o Bytes 

T olal Disk Space Required: 636.608 Bytes 
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3. Select the names of the files you want to add or remove, and then choose the 
Add or Remove button. Total Disk Space Required shows the total disk space 
needed by the files that you want to set up on your system. 

4. Choose the OK button. 

5. In the Windows Setup dialog box, choose the OK button. 

6. If you are adding files, a dialog box may appear, asking you to insert the 
appropriate Windows version 3.1 disk. Place the disk in the drive, and then 
choose the OK button. 

If you are deleting files, a dialog box appears, asking you to confirm the 
deletion. Choose the Yes or Yes To All button to delete. 

Running Setup from MS-DOS 
By running Setup from MS-DOS, you can: 

• Install an updated version of a device driver that you previously installed. 

• Change your Codepage setting for Windows. 

Caution Do not attempt to run Setup from MS-DOS Prompt in Windows. 
To run Setup from MS-DOS, you must first quit Windows. 

Updating an Installed Device Driver 
When you first set up Windows on your system, the appropriate drivers were 
installed for some of the devices on your system, such as your keyboard, mouse, 
and display (monitor). If you want to update one of these device drivers, you can 
do so by running Setup from outside Windows. 

For information about updating other drivers, such as those for multimedia 
devices, see Chapter 5, "Control Panel." 

~ To install an updated version of a Windows device driver 

1. Quit Windows. 

2. In your Windows directory, type setup at the MS-DOS prompt, and then press 
ENTER. 

The System Information screen appears. 
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3. Select the setting for the driver you want to update (use the UP ARROW or DOWN 

ARROW key to move to the setting), and then press ENTER. 

A screen listing the available drivers appears. 

4. Scroll to the bottom of the list (using the UP ARROW or DOWN ARROW key), 
select "Other," and then press ENTER. 

Setup requests the disk containing the updated driver. 

5. Insert the disk or type the path of the driver file, and then press ENTER. 

Setup returns you to the MS-DOS prompt. The new driver will be used the 
next time you start Windows. 

Changing the Code Page 
In Windows, the Codepage setting determines the character set (the characters 
for the language you are using on your system) that will be used by non-Windows 
applications running in a window, in addition to filenames using extended 
characters, and your keyboard layout. When Windows is first set up on your 
system, Setup detects the code page used by MS-DOS and sets up Windows to use 
the same one. If you subsequently change your MS-DOS code page, you will need 
to update the Codepage setting in Windows to match it, as follows. 

~ To change to another code page 

1. Quit Windows. 

2. In your Windows directory, type setup at the MS-DOS prompt, and then press 
ENTER. 

The System Information screen appears. 

3. Select the Codepage setting (use the UP ARROW or DOWN ARROW key to move 
to Codepage), and then press ENTER. 

A screen listing the available code pages appears. 

4. Select the code page you want to use, and then press ENTER. 

5. When the System Information screen appears, press ENTER again. 

Setup requests you to verify that you want to change code pages. 

6. Press F3 to verify the change. 

Setup requests you to supply the disk with the new code-page file. 

7. Insert the disk or type the path of the code-page file, and then press ENTER. 

After copying the file, Setup returns you to the MS-DOS prompt. The new 
code page will take effect the next time you start Windows. 
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Recovering If Things Go Wrong 
Occasionally, changes you have made to your Win,dows configuration may leave 
Windows unable to run. For example, you might have specified the wrong device 
driver when you were updating your system. You can usually correct the problem 
by running Setup from MS-DOS. 

~ To correct an incorrect device-driver installation 

1. Quit Windows. 

2. From your Windows directory, type setup at the MS-DOS prompt, and then 
press ENTER. 

The System Information screen appears. 

3. Select the setting for the driver you want to change (use the UP ARROW or 
DOWN ARROW key to move to the setting), and then press ENTER. 

A screen listing the available drivers appears. 

4. Follow the instructions on the screen, being sure to select the correct driver(s). 

Note If Windows still won't run after you have reinstalled the driver by using this 
procedure, check with your hardware manufacturer to ensure that you have the 
correct driver. 
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Windows and Networks 

Appendix A 

Using Windows with Networks 
The Microsoft Windows operating system provides many features that make it 
easier to work with a network's resources. Before you use these features, you 
should be aware of some basic guidelines for using networks. This appendix 
outlines Windows network features and lists guidelines for using networks. 

For information about setting up Windows from a network, see Getting Started 
with Microsoft Windows. 

Windows Network Features 
The following list describes what you can do with Windows and networks and 
where to find information about the Windows network features. 

You can do the following: 

• Configure Windows for a particular type of network. For information, see 
Chapter 15, "Maintaining Windows with Setup." 

• Connect your system to a particular network drive. On some networks, you can 
browse through network drives to find the one you want. For information, see 
Chapter 4, "File Manager." 

• Set options that are specific to your network. For information, see Chapter 5, 
"Control Panel." 

• Set up network printer connections. On some networks, you can browse 
through network drives to find the printer you want. For information, see 
Chapter 6, "Print Manager." 

• Take advantage of special features offered by Windows Print Manager when 
you use a network printer. For information, see Chapter 6, "Print Manager." 
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Guidelines for Using Networks 
You can avoid many problems when using Windows with a network by following 
these guidelines: 

• Read the NETWORKS.WRI file that is included with this version of Windows 
to make sure your network software is compatible with Windows. This file con­
tains information about running Windows with your specific network. 

• Always start the network before you start Windows. 

You can connect to network drives and printers after you start Windows, 
but the network software must be running on your computer before you start 
Windows. If you try to start your network after you have started Windows, 
your system may not run correctly. 

• Some networks fail if you log in or log out at the MS-DOS prompt while 
running Windows. Some networks support logging in or out by using the 
Network option in Windows Control Panel. If your network does not support 
this feature, log in before you start Windows. 

• If you are using a shared copy of Windows or a shared copy of another appli­
cation, use the same letter to designate the network drive on your system every 
time you connect to that drive. 

For example, if you use the drive letter W when you connect to the network 
drive to set up a shared copy of Windows, Windows records W as the path it 
should use in the future to look for the shared Windows files. If the next time 
you connect to the same network drive you use a letter other than W, you will 
not be able to start Windows correctly. 

If you do need to specify a different drive letter when you connect to a network 
drive in order to use a shared application, be sure to change the path that 
Windows uses to find the application. 

• Every time you connect to a network printer, use the same port for that particu­
lar printer. 

Control Panel retains the printer settings for a particular port. If you change the 
port you are using for a printer, the settings for the new port may not be correct 
for that printer. 

If you do need to change the port your printer is connected to, be sure to use 
Control Panel to change the printer settings. 



Terminal Emulation Tables 

Appendix B 

This appendix defines the technical specifications for terminal emulations when 
you use the Microsoft Windows Terminal application. There are two tables for 
each terminal emulation, which provide the following information: 

• The IBM PC equivalent keystrokes and the corresponding characters 
transmitted 

• The functions supported by Windows and their corresponding escape 
sequences 

Note The letter "1" is italicized ( I ) in all tables to help distinguish it from 
the numeral "1." 

VT-52 Terminal- Keyboard 
The following are the IBM PC equivalent keystrokes and corresponding characters 
transmitted for the Digital Equipment Corporation VT-52 Terminal keystrokes. 

VT-52 keyboard ffiM PC keyboard Characters transmitted 

ASCII HEX 

PFI Fl ESCP 1B 50 

PF2 F2 ESCQ 1B 51 

PF3 F3 ESCR 1B 52 

PF4 F4 ESCS 1B 53 

LEFT ARROW LEFT ARROW ESCD 1B 44 

UPARROW UPARROW ESCA 1B 41 

RIGHT ARROW RIGHT ARROW ESCC 1B 43 

DOWN ARROW DOWN ARROW ESCB 1B 42 
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The host computer may prompt you to put your keyboard in keyboard application 
mode, a terminal-emulation mode required for some applications. The keystrokes 
and characters for keyboard application mode are listed here. 

VT-52 keyboard IBM PC keyboard Characters transmitted 

ASCII HEX 

0 0 ESC ?p IB 3F 70 

ESC ?q IB 3F 71 

2 2 ESC ?r IB 3F72 

3 3 ESC? s IB 3F73 

4 4 ESC ?t IB 3F 74 

5 5 ESC ?u IB 3F75 

6 6 ESC ?v IB 3F 76 

7 7 ESC?w IB 3F77 

8 8 ESC ?x IB 3F78 

9 9 ESC ?y IB 3F79 

ESC?m IB 3F6D 

, (or *) ESC? I IB 3F6C 

ESC ?n IB 3F6E 
ENTER + ESC?M IB 3F4D 

LEFfARROW LEFfARROW ESCOD IB 4F 44 

UPARROW UPARROW ESCOA IB 4F 41 

RIGHT ARROW RIGHT ARROW ESCOC IB 4F 43 

DOWN ARROW DOWN ARROW ESCOB IB 4F 42 

VT-52 Terminal- Functions 
The following are the supported functions for the Digital Equipment Corporation 
VT-52 Terminal and their corresponding escape sequences. 

Function 

ANSI MODE ENTER 

CURSOR MOVE DOWN 

CURSOR MOVE HOME 

CURSOR MOVE LEFT 

CURSOR MOVE RIGHT 

Escape sequence 

ESC < 
ESCB 

ESCH 

ESCD 

ESCC 
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Function Escape sequence 

CURSOR MOVE UP ESC A 

CURSOR POSITION SET ESC Y 1 c 

ERASE TO END OF LINE ESCK 

ERASE TO END OF SCREEN ESC] 

IDENTIFY ESCZ 

KEYPAD APPLICATION ESC = 

KEYPAD NUMERIC ESC> 
LINEFEED REVERSE ESC I 

VT-100 Terminal- Keyboard 
The following are the IBM PC equivalent keystrokes and corresponding characters 
transmitted for the Digital Equipment Corporation VT-100 Terminal keystrokes. 

Note To use the function keys for DEC VT -100 (ANSI) terminal emulation, 
SCROLL LOCK must be turned on. If SCROLL LOCK is turned off, the function keys 
and arrow keys have normal Windows (not VT -100) functionality, such as Fl 

being the key you press for Help. 

VT-IOO keyboard mM PC keyboard Characters transmitted 

ASCII HEX 

PFI Fl ESCOP IB 4F 50 

PF2 F2 ESCOQ IB 4F 51 

PF3 F3 ESCOR IB 4F 52 

PF4 F4 ESCOS IB 4F 53 

LEFT ARROW LEFT ARROW ESC [D IB 5B 44 

UPARROW UPARROW ESC[A IB 5B 41 

RIGHT ARROW RIGHT ARROW ESC [C IB 5B 43 

DOWN ARROW DOWN ARROW ESC [B IB 5B 42 

The host computer may prompt you to put your keyboard in keyboard application 
mode, a terminal-emulation mode required for some applications. The keystrokes 
and characters for keyboard application mode are listed here. 
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VT-IOO keyboard IBM PC keyboard Characters transmitted 

ASCII HEX 

0 0 ESCOp IB 4F70 

ESCOq IB 4F 71 

2 2 ESCOr IB 4F 72 

3 3 ESCOs IB 4F 73 

4 4 ESCOt IB 4F 74 

5 5 ESCOu IB 4F 75 

6 6 ESCOv IB 4F 76 

7 7 ESCOw IB 4F 77 

8 8 ESCOx IB 4F78 

9 9 ESCOy IB 4F79 

ESCOm IB 4F6D 

, (or *) ESCOl IB 4F6C 

ESCOn IB 4F6E 

ENTER + ESCOM IB 4F4D 

LEFT ARROW LEFT ARROW ESCOD IB 4F44 

UPARROW UPARROW ESCOA IB 4F 41 

RIGHT ARROW RIGHT ARROW ESCOC IB 4F 43 

DOWN ARROW DOWN ARROW ESCOB IB 4F 42 

VT-100 Terminal- Functions 
The following are the supported functions for the Digital Equipment Corporation 
VT -100 Terminal and their corresponding escape sequences. 

Substitute one or more values (separated by semicolons) from the specified table 
(* Tn) for the <xl> and <x2> parameters. 

Substitute a value specifying the desired number of characters or lines for the 
<n> parameter. 

Substitute a value specifying the desired line and column number for the <I> and 
<c> parameters. 

Substitute a value specifying the desired row numbers for the top row and bottom 
row of the scrolling region for the <tr> and <hr> parameters. 
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Function 

ANSWER SEQUENCE TO REQUEST 

BACKSPACE 

CARRIAGE RETURN 

CHARACTER DELETE 

CHARACTER INSERT 

CHARACTER WIDTH DOUBLE 

CHARACTER WIDTH SINGLE 

CURSOR MOVE DOWN 

CURSOR MOVE LEFT 

CURSOR MOVE RIGHT 

CURSOR MOVE UP 

CURSOR POSITION SET 

CURSOR POSITION SET (ABSOLUTE) 

CURSOR RESET 

CURSOR SAVE 

ERASE ENTIRE LINE 

ERASE ENTIRE SCREEN 

ERASE FROM START OF LINE 

ERASE FROM START OF SCREEN 

ERASE NORMAL DATA FROM START OF SCREEN 

ERASE NORMAL DATA ON LINE 

ERASE NORMAL DATA ON SCREEN 

ERASE NORMAL DATA TO END OF LINE 

ERASE NORMAL DATA TO END OF SCREEN 

ERASE NORMAL DATA TO START OF LINE 

ERASE TO END OF LINE 

ERASE TO END OF SCREEN 

ESCAPE 

IDENTIFY 

INDEX 

INDEX REVERSE 

KEYPAD APPLICATION 

KEYPAD NUMERIC 

LINE DELETE 

LINEFEED 

LINE HEIGHT DOUBLE (BOTTOM) 

LINE HEIGHT DOUBLE (TOP) 

LINE INSERT 

Escape sequence 

ESC [ <I> ; <c> R 
AH 
AM 

ESC [<n> P 

ESC [<n> @ 

ESC#6 

ESC#5 

ESC [<n> B 

ESC [<n> D 

ESC [<n>C 
ESC [<n>A 
ESC [ <I> ; <c> H 

ESC [ <I> ; <c> f 
ESC 8 

ESC7 

ESC [2 K 

ESC [2 J 

ESC [ 1 K 

ESC [ 1 J 

ESC [? 1 J 

ESC [? 2 K 

ESC [? 2 J 

ESC [? 0 K 

ESC [? 0 J 

ESC [? 1 K 

ESC [0 K 

ESC [0 J 

ESC 

ESCZ 

ESCD 

ESCM 

ESC = 
ESC> 

ESC [<n>M 
AJ 
ESC#4 

ESC#3 

ESC [<n>L 
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Function Escape sequence 

NEXT LINE ESCE 

READ CURSOR POSITION ESC [6 n 

READ STATUS ESC[ 5 n 

RING BELL I\G 

SET SCROLLING REGION ESC [ <tr> ; <hr> r 

TAB CLEAR ESC [g 

TAB CLEAR ALL ESC [3 g 

TAB MOVE-HORIZONTAL 1\1 

TAB SET ESCH 

TERMINAL MODES RESET ESC [ <xl> 1 (* T1) 

TERMINAL MODES SET ESC [ <xl> h (* Tl) 

TERMINAL PARAMETERS REQUEST ESC [ {sol} x 

TRANSMIT DEVICE ATTRIBUTES ESC [c 

SET MEDIA COPY OFF ESC [4i 

SET MEDIA COpy ON ESC [5i 

VIDEO ATTRIBUTE SET ESC [ <x2> m (* T2) 

CHANGE GO CHAR SET UK ESC(A 

CHANGE GO CHAR SET US ASCII ESC(B 

CHANGE G1 CHAR SET UK ESC)A 

CHANGE G 1 CHAR SET US ASCII ESC)B 

CHANGE GO CHAR SET TO GRAPHICS ESC (0 

CHANGE G 1 CHAR SET TO GRAPHICS ESC) 0 

GO ALTERNATE CHARACTER ROM ESC (1 

(Standard Character Set) 

G1ALTERNATECHARACTERROM ESC) 1 

(Standard Character Set) 

GO ALTERNATE CHARACTER ROM ESC (2 

(Special Graphics) 

G 1 ALTERNATE CHARACTER ROM ESC) 2 

(Special Graphics) 



Terminal Modes <xl> 

Function 

LINEFEED/NEWLINE 

APPLICATION/CURSOR KEYS 

ANSI/VT-52 

132/80 COLUMN 

SMOOTH/JUMP SCROLL 

REVERSE/NORMAL SCREEN 

RELATIVE/ABSOLUTE ORIGIN 

CHARACTER WRAP ON/OFF 

AUTO REPEAT ON/OFF 

INTERLACE ON/OFF 

Video Attributes <x2> 
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Escape sequence 

?O 
?l 

?2 

?3 

?4 

?5 

?6 

?7 

?8 

?9 

Function Escape sequence 

ATTRIBUTES OFF 

BOLD 

o 

UNDERSCORE 4 

BLINK 5 

NEGATIVE (REVERSE) 7 





Keyboard Shortcuts 

Appendix C 

This appendix lists key combinations you can use in the Microsoft Windows oper­
ating system. Many commands on menus also have keyboard equivalents; the key 
combinations for these commands are shown next to the commands on the menus. 

General Windows. Keys 

System Keys 

Use the following keys throughout Windows. 

The following keys can be used in a window or a full screen, regardless of the 
application you are using. 

Press 

FI 

CTRL+ESC 

ALT+ESC 

ALT+TAB 

SHIFT +ALT + TAB 

PRINT SCREEN 

To 

Start Help if the application has Help. 

Switch to Task List. 

Switch to the next application, whether it is running in a 
window or running as an icon. 

Switch to the application you last used. 

Or switch to the next application, by pressing and holding 
down ALT while repeatedly pressing TAB. 

To return to your original application, keep holding down 
the ALT key, and press ESC. 

Switch to previous applications by pressing and holding 
down ALT +SHIFT while repeatedly pressing TAB. 

To return to your original application, keep holding down 
the ALT key, and press ESC. 

Copy an image of the screen onto the Clipboard. (This 
works for non-Windows applications only if they are run­
ning in text mode.) 
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Menu Keys 

Press 

ALT +PRINT SCREEN 

ALT,SPACEBAR 

ALT,HYPHEN 

ALT +SPACEBAR 

ALT+F4 

CTRL+F4 

ALT+ENTER 

An arrow key 

To 

Copy an image of the active window onto the Clipboard. 

Open the Control menu for an application window. 

Open the Control menu for a document window. 

Opens the Control menu for a non-Windows application 
running in a window. 

Quit an application or close a window. 

Close the active group window or document window. 

Switch a non-Windows application between running in a 
window and running in a full screen. 

Move a window after you choose Move from the Control 
menu. 

Or change the size of a window after you choose Size 
from the Control menu. 

Use the following keys to select menus and choose commands. 

Press 

ALTorFlO 

A character key 

LEFT ARROW or RIGHT 
ARROW 

UP ARROW or DOWN 

ARROW 

ENTER 

ESC 

To 

Select or cancel selection of the first menu on the menu 
bar. 

Choose the menu or command whose underlined 
letter or number matches the one you type. 

Move between menus. 

Move between commands. 

Choose the selected menu name or command. 

Cancel the selected menu name. 

Or close the open menu. 



Dialog Box Keys 
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Use the following keys when working in a dialog box. 

Press 

TAB 

SHIFT+TAB 

ALT + a character key 

An arrow key 

HOME 

END 

PAGE UP or PAGE DOWN 

ALT+DOWN ARROW 

SPACEBAR 

CTRL+SLASH (/) 

CTRL+BACKSLASH (\) 

SHIFT + an arrow key 

SHIFT+HOME 

SHIFT+END 

ENTER 

ESC or ALT+F4 

To 

Move from option to option (left to right and top to bottom). 

Move from option to option in reverse order. 

Move to the option or group whose underlined letter or 
number matches the one you type. 

Move the selection cursor from option to option within a 
group of options. 

Or move the cursor left, right, up, or down within a list or 
text box. 

Move to the first item or character in a list or text box. 

Move to the last item or character in a list or text box. 

Scroll up or down in a list, one screen at a time. 

Open a list. 

Select an item or cancel a selection in a list. 

Select or clear a check box. 

Select all the items in a list (when you can select multiple 
items). 

Cancel all selections except the current selection. 

Extend or cancel the selection in a text box one character 
at a time. 

Extend or cancel the selection to the first character in a 
text box. 

Extend or cancel the selection to the last character in a 
text box. 

Carry out a command. 

Or choose the selected item in a list, and then carry out 
the command. 

Close a dialog box without completing the command. 
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Cursor Movement Keys 

Editing Keys 

Use the following keys where applicable to move the cursor or insertion point in 
text boxes and other places where you can type text, such as in Windows Notepad 
or Write. 

Press 

UPARROW 

DOWN ARROW 

RIGHT ARROW 

LEFfARROW 

CTRL+RIGHT ARROW 

CTRL+LEFf ARROW 

HOME 

END 

PAGE UP 

PAGE DOWN 

CTRL+HOME 

CTRL+END 

To move the insertion point 

Up one line. 

Down one line. 

Right one character. 

Left one character. 

Right one word. 

Left one word. 

To the beginning of the line. 

To the end of the line. 

Up one screen. 

Down one screen. 

To the beginning of the document. 

To the end of the document. 

Use the following keys to edit text in a dialog box or window. 

Press 

BACKSPACE 

DEL 

CTRL+INS or CTRL+C 

SHIFf+DEL or CTRL+X 

SHIFf+INS or CTRL+V 

CTRL+Zor ALT+BACKSPACE 

To 

Delete the character to the left of the insertion point. 

Or delete selected text. 

Delete the character to the right of the insertion point. 

Or delete selected text. 

Copy the selected text and place it onto the Clipboard. 

Delete the selected text and place it onto the 
Clipboard. 

Paste text from the Clipboard into the active window. 

Undo the last editing action. 
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Text Selection Keys 
The following keys can be used in most Windows applications. However, some of 
the keys listed here might not work in all places where you can select text or in all 
applications. All of the following selections begin at the insertion point. If text is 
already selected, pressing the keys cancels the selection. 

Press 

SHIFT + LEFT or RIGHT 
ARROW 

SHIFT + UP or DOWN ARROW 

SHIFT +PAGE UP 

SHIFT +PAGE DOWN 

SHIFT+HOME 

SHIFT+END 

CTRL+SHIFT +LEFT ARROW 

CTRL+SHIFT +RIGHT ARROW 

CTRL+SHIFT +HOME 

CTRL+SHIFT +END 

Program Manager Keys 

To select or cancel selection of 

One character at a time to the left or right. 

One line of text up or down. 

All text, one screen up. 

All text, one screen down. 

Text to the beginning of the line. 

Text to the end of the line. 

The previous word. 

The next word. 

Text to the beginning of the document. 

Text to the end of the document. 

When working with group windows in Windows Program Manager, use the 
following keys. 

Press 

An arrow key 

CTRL+F6orCTRL+TAB 

ENTER 

SHIFT+F4 

SHIFT+F5 

CTRL+F4 

ALT+F4 

To 

Move between items within a group window. 

Move between group windows and icons. 

Start the selected application. 

Arrange the open group windows side by side 
("tile" them). 

Arrange the open group windows so that each 
title bar is displayed ("cascade" them). 

Close the active group window. 

Quit Windows. 
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File Manager Keys 
Use the following keys in Windows File Manager. 

Directory Tree Keys 
When working with the directory tree, use the following keys. 

Press 

TAB orF6 

LEFT ARROW or BACKSPACE 

RIGHT ARROW 

ENTER 

SHIFT +ENTER 

UP ARROW or DOWN 
ARROW 

CTRL+UP ARROW 

CTRL+DOWN ARROW 

PAGE UP 

PAGE DOWN 

HOME or BACKSLASH (\) 

END 

A character key 

To 

Move between the directory tree, the contents list, 
and the drive icons. 

Select the directory listed above the current 
subdirectory. 

Select the first subdirectory, if one exists, listed 
below the current directory. 

Display or hide any subdirectories. 

Open a new window displaying the contents of 
the selected directory. 

Select a directory listed above or below the current 
directory. 

Select the previous directory at the same level, if 
one exists. 

Select the next directory at the same level, if one exists. 

Select the directory one screen up from the current 
directory. 

Select the directory one screen down from the current 
directory. 

Select the root directory. 

Select the last directory in the list. 

Select the next directory whose name begins with 
the specified letter or number. 
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File and Directory Keys 

Drive Icon Keys 

Use the following keys when working with the list of files and subdirectories in 
the current directory. 

Press 

TAB orF6 

PAGE UP 

PAGE DOWN 

HOME 

END 

A character key 

SHIFT + an arrow key 

CTRL+SLASH (/) 

CTRL+BACKSLASH (\) 

SHIFT+F8 

An arrow key 

SPACEBAR 

ENTER 

SHIFT +ENTER 

To 

Move between the directory tree, the contents list, and 
the drive icons. 

Select the file or directory one screen above the current 
selection. 

Select the file or directory one screen below the current 
selection. 

Select the first file or directory in the list. 

Select the last file or directory in the list. 

Select the next file or directory whose name begins with 
the specified letter or number. 

Select or cancel selection of multiple items. 

Select all items in the list. 

Cancel all selections in the list except the current selection. 

Select nonconsecutive items or cancel the selections. Press 
SHIFT +F8, and then use the arrow keys and the SPACEBAR. 

Move the cursor, or scroll to other items in the window. 

Select or cancel the selection of nonconsecutive items 
marked by a blinking cursor. 

Open a directory or start an application. 

Open a new window displaying the contents of the selected 
directory. 

When working with drive icons, use the following keys. 

Press 

TAB or F6 

CTRL + a drive letter 

LEFT ARROW or RIGHT 
ARROW 

SPACEBAR 

ENTER 

To 

Move between the directory tree, the contents list, and 
the drive icons. 

Change to the drive icon that matches the specified letter. 

Move between drive icons. 

Change drives. 

Open a new directory window. 
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Calculator Keys 
See Chapter 12, "Additional Accessories," for Windows Calculator keyboard 
tables. 

Calendar Keys 

Day View Keys 

Use the following keys in Windows Calendar. 

Use the following keys in the Day view. 

Press 

UPARROW 

DOWN ARROW or ENTER 

PAGE UP 

PAGE DOWN 

CTRL+HOME 

CTRL+END 

TAB 

SHIFf+DEL 

CTRL+INS 

SHIFf+INS 

CTRL+PAGE UP 

CTRL+PAGE DOWN 

To 

Move to the previous time. 

Move to the next time. 

Move to the previous screen. 

Move to the next screen. 

Move to the starting time. 

Move to 12 entries after the starting time. 

Move between the appointment area and the scratch pad. 

Delete the selection and place it onto the Clipboard. 

Copy the selection and place it onto the Clipboard. 

Paste the Clipboard contents into the appointment area or 
scratch pad. 

Move to the previous day. 

Move to the next day. 

Month View Keys 
Use the following keys in the Month view. 

Press 

UPARROW 

DOWN ARROW 

PAGE UP 

PAGE DOWN 

TAB 

ENTER 

To 

Move to the previous week. 

Move to the next week. 

Move to the previous month. 

Move to the next month. 

Move between a date and the scratch pad. 

Change to the Day view. 



Appendix C Keyboard Shortcuts 591 

Cardfile Keys 
Use the following keys in Windows Cardfile. 

Press 

PAGE DOWN 

PAGE UP 

CTRL+HOME 

CTRL+END 

SHIFT +CTRL + 
a character key 

DOWN ARROW 

UPARROW 

Clipboard Viewer Keys 

To 

Scroll forward one card in Card view. 

Move forward one page of index lines in List view. 

Scroll backward one card in Card view. 

Move back one page of index lines in List view. 

Bring the first card in the file to the front. 

Bring the last card in the file to the front. 

Bring a card to the front of the file. Cardfile displays the 
first card whose index line begins with the letter or number 
you press. 

Scroll one card forward in List view. 

Scroll one card backward in List view. 

Use the following keys when using the Windows Clipboard Viewer. 

Press To 

DEL Clear the Clipboard contents. 

SHIFT +DEL In a document, delete a selection and place it onto the Clipboard. 

CTRL+INS In a document, copy a selection and place it onto the Clipboard. 

SHIFT +INS In a document, paste the Clipboard contents into a document. 

PRINT SCREEN Copy an image of the entire screen onto the Clipboard. (This 
works for non-Windows applications only if they are running in 
text mode.) 

ALT +PRINT SCREEN Copy an image of the active window onto the Clipboard. 



592 Microsoft Windows User's Guide 

Control Panel Keys 
Use the following keys in Windows Control Panel. 

Help Keys 

Press 

An arrow key 

SPACEBAR 

RIGHT ARROW or 
LEFfARROW 

TAB 

To 

Move among icons in the Control Panel window. 
Or, in the Color dialog box, move among colors in 
the Basic Colors and Custom Colors palettes. 

In the Color dialog box, select a color in the Basic Colors 
and Custom Colors palettes. 

Move the selected scroll box in the Desktop, Mouse, and 
Keyboard dialog boxes. 

Select a port in the Ports dialog box. Or select a column in 
the MIDI Setup, Key Map, and Patch Map dialog boxes. 

Use the following keys to get Help from any window. 

Press 

FI 

SHIFf+FI 

To 

Display the Help Contents for the application. If the Help 
window is already open, pressing FI displays the Contents 
for How To Use Help. 

In some applications (such as Program Manager and File 
Manager), pressing FI displays a Help topic on the selected 
command, dialog box option, or system message. 

Add a question mark to the pointer. You can then click the 
command, click the screen region, or press the key or key 
combination you want to know more about. 

This feature is available only in certain applications. 



Appendix C Keyboard Shortcuts 593 

Help Window Keys 
Use the following keys while working in Help. 

Press 

TAB 

SHIFT+TAB 

CTRL+TAB 

CTRL+INS 

SHIFT+INS 

ALT+F4 

Media Player Keys 

To 

Move clockwise among jumps in the topic. 

Move counterclockwise among jumps in the topic. 

Select all the jumps in a topic. 

Or cancel selection of a jump. 

Copy the current Help topic onto the Clipboard without displaying 
the Copy dialog box. 

Or copy an entire annotation or a portion of it onto the Clipboard. 

Paste the contents of the Clipboard into the Annotation dialog box. 

Quit Help. 

Use the following keys in Windows Media Player. 

Press To 

TAB Move from button to button (left to right). 

SHIFT + TAB Move from button to button (right to left). 

SPACEBAR Choose a button. 

LEFT ARROW Move the playing position back when the scroll bar is selected. 

RIGHT ARROW Move the playing position forward when the scroll bar is selected. 

PAGE UP Move the playing position back in large increments when the scroll 
bar is selected. 

PAGE DOWN Move the playing position forward in large increments when the 
scroll bar is selected. 

HOME Move the playing position to the beginning when the scroll bar is 
selected. 

END Move the playing position to the end when the scroll bar is selected. 
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Notepad Keys 
See "Cursor Movement Keys" and "Text Selection Keys" in the "General 
Windows Keys" section earlier in this appendix. 

Object Packager Keys 
Use the following key in Windows Object Packager. 

Press To 

TAB Move the selection cursor between the Content and Appearance 
windows. 

Paintbrush Keys 
Use the following keys in Windows Paintbrush. 

Mouse Equivalent Keys 

Undo Keys 

Use the following keys if you do not have a mouse. 

Pressing 

INS 

DEL 

F9+INS 

F9+DEL 

INS + an 
arrow key 

Is equivalent to 

Clicking the left mouse button 

Clicking the right mouse button 

Double-clicking the left mouse button 

Double-clicking the right mouse button 

Dragging the cursor 

Use the following keys to undo your last editing action. 

Press 

BACKSPACE 

CTRL+Z 

To 

Undo all or part of what you have drawn since selecting a tool. Press 
BACKSPACE, and then drag the cursor over the part of the drawing you 
want to undo. 

Undo everything you have drawn since selecting a tool. 



Movement Keys 
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Use the following keys to move around the drawing area. 

Press To move 

TAB Among the Toolbox, Linesize box, Palette, and drawing area 
in a counterclockwise direction. 

SHIFT + TAB Among the Toolbox, Linesize box, Palette, and drawing area 
in a clockwise direction. 

An arrow key Around the drawing area. 

SHIFT+HOME To the left side of the drawing area. 

SHIFT +END To the right side of the drawing area. 

PAGE UP Up one screen. 

PAGE DOWN Down one screen. 

HOME To the top of the drawing area. 

END To the bottom of the drawing area. 

SHIFT +LEFT ARROW To the left one space. 

SHIFT +RIGHT ARROW To the right one space. 

SHIFT +UP ARROW Up one line. 

SHIFT+DOWN ARROW Down one line. 

SHIFT +PAGE UP Left one screen. 

SHIFT +PAGE DOWN Right one screen. 

PIF Editor Keys 
Use the following keys in Windows PIF Editor. 

Press 

TAB 

SHIFT+TAB 

ALT + a letter key 

An arrow key 

SPACEBAR 

To 

Move from option to option (left to right and top to bottom). 

Move from option to option in reverse order. 

Move to the option or group whose underlined letter matches 
the one you type. If the option is a check box, it also sets or 
clears the option. 

Move the selection cursor from option to option within a 
group of options. 

Select or clear a check box. 
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Sound Recorder Keys 

Write Keys 

Movement Keys 

Use the following keys in Windows Sound Recorder. 

Press 

TAB 

SHIFT+TAB 

SPACEBAR 

LEFT ARROW or RIGHT 
ARROW 

PAGE UP 

PAGE DOWN 

HOME 

END 

To 

Move from button to button (left to right). 

Move from button to button (right to left). 

Choose a button. 

Move backward or forward when the scroll bar 
is selected. 

Move back 1 second when the scroll bar is selected. 

Move forward 1 second when the scroll bar is selected. 

Move to the beginning of the sound when the scroll bar 
is selected. 

Move to the end of the sound when the scroll bar is selected. 

Use the following keys in Windows Write. When the key combination includes 
a 5, it refers to the 5 key on the keypad. 

See also "Cursor Movement Keys" and "Text Selection Keys" in the "General 
Windows Keys" section earlier in this appendix. 

Use the following keys to move the insertion point around in a document. 

Press 

5+RIGHT ARROW 

5+LEFT ARROW 

5+DOWN ARROW 

5+UPARROW 

5+PAGEDOWN 

5+PAGE UP 

To 

Move to the next sentence. 

Move to the previous sentence. 

Move to the next paragraph. 

Move to the previous paragraph. 

Move to the next page, according to the last repagination. 

Move to the previous page, according to the last 
repagination. 



Editing Keys 
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Use the following keys to edit text. 

Press 

CTRL+ENTER 

SHIFT+DEL 

CTRL+INS 

SHIFT+INS 

CTRL+Z or ALT +BACK­

SPACE 

DOWN ARROW 

An arrow key 

CTRL+SHIFT +HYPHEN 

ALT+F6 

To 

Insert a manual page break. 

Delete a selection and place it onto the Clipboard. 

Copy a selection and place it onto the Clipboard. 

Paste the Clipboard contents into a document. 

Undo the last typing or editing action. 

Select a picture when the cursor is above the upper-left 
comer of the picture. 

Move the Size Picture cursor. 

Move a selected picture after you choose the Move 
Picture command from the Edit menu. 

Insert an optional hyphen. 

Switch between the document and the Find or Replace 
dialog box. 

Or switch between the Header or Footer window and 
the Page Header or Page Footer dialog box. 
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386 enhanced mode A mode in which Windows 
runs to access the virtual-memory capabilities of 
the 80386 processor. In this mode, Windows 
appears to use more memory than is physically 
available and provides multitasking for non­
Windows applications. See also standard mode, 
virtual memory. 

A 
active The window or icon that you are cur­
rently using or that is currently selected. Only 
one window or icon can be active at a time. 
Keystrokes and commands affect the active 
window or icon. If a window is active, its title 
bar changes color to differentiate it from other 
windows. If an icon is active, its label changes 
color. Windows or icons on the desktop that are 
not selected are inactive. 

ANSI character set The American National 
Standards Institute 8-bit character set. It contains 
256 characters. 

application A computer program used for a 
particular kind of work, such as word processing 
or database management. This term is used inter­
changeably with "program." See also Windows 
application, non-Windows application. 

application icon A graphic that represents a run­
ning application. This icon appears only after you 
start an application and then minimize (reduce) it. 

application shortcut key A key combination that 
brings a running application to the foreground. 
You can assign an application shortcut key in 
Program Manager or in a PIF (program infor­
mation file). 

application swap file A temporary file that 
Windows uses to store a non-Windows appli­
cation when you switch to another application. 
This leaves more room in memory for running 
applications. Windows uses application swap 
files in standard mode only. See also swap file. 

application window The window containing the 
work area and menu bar for an application. The 
name of the application appears at the top of this 
window. An application window may contain 
multiple document windows. 

archive attribute A file characteristic that indi­
cates whether the file has been changed since it 
was last backed up. This attribute is usually set 
when the file is created or modified, and then 
cleared when the file is backed up by using the 
MS-DOS xcopy, backup, or restore command. 

arrow keys On your computer keyboard, the 
keys you use to navigate around your screen. 
Each key is marked with an arrow and is named 
for the direction in which the arrow points: There 
is an UP ARROW, DOWN ARROW, LEFT ARROW, and 
RIGHT ARROW key. Also known as direction keys. 

ASCII character set The American Standard 
Code for Information Interchange 7 -bit character 
set. It consists of the first 128 (0-127) characters 
of the ANSI character set (and most other 8-bit 
character sets). The ASCII character set is the 
most universal character-coding set. 

associate To identify a filename extension 
as "belonging" to a certain application. When 
you open a file with an extension that has been 
associated with an application, the application 
starts automatically. Files that are associated with 
an application are called document files. See also 
document file. 
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attributes Information about a file that indicates 
whether the file is read-only, hidden, or system, 
and whether it has been changed since it was last 
backed up. See also archive attribute, hidden file, 
read-only file, system file. 

AUTOEXEC.BAT file A batch program (set of 
commands) that is automatically carried out by 
the MS-DOS operating system whenever the 
computer is started or restarted. The file contains 
basic startup commands that help configure the 
system. 

automatic link A link whose Update option is 
set to automatic. When you edit a linked object, 
the changes are made to the visual presentation 
(image) of the object in all documents that con­
tain an automatic link to the object. See also 
manual link, link, object linking and embedding. 

B 
background The area behind and outside the 
active window, including the desktop and any 
other application windows or icons. See also 
foreground. 

background application An application that is 
running but is not active. The application cannot 
receive user input. See also foreground applica­
tion. 

batch program A text file that contains MS-DOS 
commands. When you run the batch program, 
MS-DOS carries out the commands in the file as 
if you had typed them at the MS-DOS prompt. 

baud rate The speed at which information can 
be transferred through a COM (serial) port. 

binary file A file containing information that is 
in machine-readable form; it can be read only by 
an application. In Terminal, these files are not 
converted or translated during the transfer 
process. 

binary transfer A method of transferring binary 
files to a remote computer. 

bitmap An image stored as a pattern of dots 
(or pels). 

boot To start or restart your computer, loading 
the MS-DOS operating system from your hard 
disk or floppy disk. See also hard disk, floppy 
disk, system disk. 

branch A segment of the File Manager 
directory tree, representing a directory and 
any subdirectories within it. 

browse To look through files and directories. 
Some dialog boxes have a Browse button, which 
opens another dialog box that lists files and direc­
tories so that you can easily select the file you 
want. 

buffer A temporary storage place for infor­
mation. 

c 
cartridge font A font contained in a cartridge 
that physically plugs into your printer. Font 
cartridges are often used by laser printers such 
as those in the HP LaserJet family, but some 
dot-matrix printers also use font cartridges. 
See also font cartridge. 

cascade A way of arranging open windows on 
the desktop so that they overlap each other, with 
the title bar of each window remaining visible. 

cascading menu A menu that opens from a com­
mand on another menu. A command that opens a 
cascading menu has a right arrow next to it. 

channel map Specifies destination channels, 
output devices, and patch maps for MIDI channel 
messages. 



character set A group of letters, numbers, and 
symbols that have some relationship in common. 
For example, the ASCII character set contains 
characters that make up the ASCII coding 
scheme. 

check box A small, square box that appears in 
a dialog box and that can be selected or cleared. 
When the check box is selected, an X appears in 
the box. A check box represents an option that 
you can tum on or off. 

choose To use a mouse or keyboard to pick 
an item that begins an action in Windows. You 
choose commands on menus to perform tasks, 
and you choose icons to start applications. 

clear To tum off an option by removing the 
X from a check box. You clear a check box 
by clicking it, or selecting it and pressing the 
SPACEBAR. 

click To press and release a mouse button 
quickly. 

client application An application whose 
documents can accept linked or embedded 
objects. 

Clipboard A temporary storage location used 
to transfer data between documents and between 
applications. Typically, you transfer data to the 
Clipboard by using an application's Copy or 
Cut command, and you insert data from the 
Clipboard by using the application's Paste 
command. You use Clipboard Viewer to view 
the contents of the Clipboard. 

close To remove a window or dialog box, or 
quit an application. You can close a window by 
using the Close command on the Control menu. 
When you close an application window, you quit 
the application. 

collapse To "hide" subdirectories below a 
selected directory in File Manager. 
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color scheme A predefined combination of 
colors that Windows uses for its screen elements. 
You can choose a color scheme or create your 
own by using Control Panel. 

COM port See serial port. 

command A word or phrase, usually found in 
a menu, that you choose in order to carry out an 
action. You choose a command from a menu, or 
type a command at the MS-DOS prompt. You 
can also type a command in the Run dialog box 
in File Manager or Program Manager. 

command button In a dialog box, a button that 
carries out an action. A command button often 
has a label that describes the action it carries out 
(for example, Cancel, Help, or Install). Choosing 
a command button that is followed by an ellipsis 
(for example, Browse ... ) causes another dialog 
box to appear. 

command line The commands you type to run 
an application. You can type the commands at 
the MS-DOS prompt or in the Run dialog box 
in File Manager or Program Manager. 

command prompt See MS-DOS prompt. 

communications settings Settings that specify 
how information is transferred from your com­
puter to a device (usually a printer or modem). 
See also serial port. 

compound device An MCI device that uses 
media files, compared to a simple device, which 
does not require media files. For example, to run 
a compound device such as a MID I sequencer, 
you must specify a MIDI file. See also Media 
Control Interface, MIDI. 

compound document A document that contains 
information created by using more than one 
application. 
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CONFIG.SYS file A text file that contains 
configuration commands used when you start 
your computer. Commands in the CONFIG.SYS 
file enable or disable system features, set limits 
on resources, and extend the operating-system 
functionality by loading device drivers. 

confirmation message A message that appears 
after you specify certain actions, prompting you 
to confirm that you want to continue with the 
action or to specify that you want to cancel it. 
For example, File Manager displays a confirma­
tion message before deleting a file. 

control codes In Terminal, codes that specify 
commands or formatting instructions (such as 
linefeeds or carriage returns) in a text file. Con­
trol codes are usually preceded by a caret (A). 
You enter these codes when you are assigning 
Terminal commands or formatting instructions 
to function keys. 

Control menu A menu that contains commands 
you can use to manipulate the window. Applica­
tion icons and some dialog boxes also have a 
Control menu. To open the Control menu, you 
use the Control-menu box at the left of the title 
bar in a window, or you select an application 
icon. See also Control-menu box. 

Control-menu box The icon that opens the 
Control menu for the window. It is always at 
the left of the title bar. 

conventional memory Up to the first 640K of 
memory in your computer. MS-DOS uses this 
memory to run applications. 

copy To put a copy of the selected text or item 
onto the Clipboard so that you can transfer it to 
another location. Most Windows applications 
have a Copy command on the Edit menu that 
performs this task. You can also copy entire 
files from one location to another by using File 
Manager. 

current directory The directory that you are 
currently working in. In File Manager, the cur­
rent directory is selected (highlighted) in the 
directory tree. 

cursor See insertion point. 

cut To move data from a document into a tem­
porary storage area called the Clipboard. Most 
Windows applications have a Cut command 
(on the Edit menu) that performs this task. 

cutout An area of a drawing you select by using 
the Scissors or Pick tool in Paintbrush. 

o 
data file Any file created within an application: 
a word-processing document, a spreadsheet, a 
database file, or a chart, for example. Also known 
as document. See also text file. 

default button In some dialog boxes, the com­
mand button that Windows automatically selects. 
The default button has a bold border, indicating 
that it will be chosen if you press ENTER. You can 
override a default button by choosing Cancel or 
another command button. 

default printer The printer that is used if you 
choose the Print command without first specify­
ing which printer you want to use. You can have 
only one default printer, which you can specify 
by using Control Panel or Print Manager. The 
printer you use most often should be the default 
printer. 

default settings Settings that are supplied with 
Windows. For example, if you print a document 
from Windows without specifying margin set­
tings' Windows uses its preset margins. 

desktop The screen background for Windows 
on which windows, icons, and dialog boxes 
appear. 



desktop pattern A design that appears across the 
desktop. You can use Control Panel to create 
your own pattern or choose a pattern provided 
by Windows. 

destination directory The directory to which you 
intend to copy or move one or more files. 

destination document A document containing a 
link to an object in a source document. 

device A component of the system's hardware 
configuration, such as a modem, printer, mouse, 
sound card, or disk drive. 

device contention Occurs when more than one 
application is trying to use the same device, such 
as a modem, while Windows is running in 386 
enhanced mode. 

device driver Software that controls how a 
computer communicates with a device, such as 
a printer or mouse. For example, a printer driver 
translates information from the computer into 
information the printer can understand. 

dialog box A window that appears temporarily 
to request information. Many dialog boxes have 
options you must choose before Windows can 
carry out a command. 

dimmed Unavailable or disabled. A dimmed 
button or command is displayed in light gray 
instead of black, and it cannot be chosen. 

direction keys See arrow keys. 

directory Part of a structure for organizing your 
files on a disk. A directory can contain files and 
other directories (called subdirectories). The 
structure of directories and subdirectories on a 
disk is called a directory tree. See also directory 
tree, subdirectory. 

directory icon In File Manager, an icon that 
represents a directory on your disk. 
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directory path See path. 

directory tree In File Manager, a graphical 
display of the directory structure of a disk. The 
directories on the disk are shown as a branching 
structure that resembles a tree. The top-level 
directory is known as the root directory. 

directory window A File Manager window that 
displays the directory structure of your disk and 
the files and directories on the disk. 

disk A medium for storing information. Infor­
mation stored on a disk remains there even when 
you turn your computer off, unlike information 
stored in memory (RAM). A floppy disk can be 
inserted and removed from a floppy disk drive, 
whereas a hard disk is permanently mounted 
inside its drive. See also disk drive. 

disk cache A portion of memory set aside for 
temporarily holding information read from a disk. 

disk drive A device used for storing and retriev­
ing information on disks. See also disk, floppy 
disk, hard disk. 

display adapter Hardware that converts (adapts) 
video memory to video output. 

dithered color See nonsolid color. 

document Whatever you create with an applica­
tion, including information you type, edit, view, 
or save. A document may be a business report, a 
spreadsheet, a picture, or a letter, for example, 
and is stored as a file on a disk. 

document file A file that is associated with an 
application. When you open a document file in 
File Manager, the associated application starts 
and loads the file. 

document-file icon In File Manager, represents a 
file that is associated with an application. When 
you choose a document-file icon, the associated 
application starts and loads the file. 
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document window A window within an appli­
cation window. There can be more than one 
document window open at a time. 

double-click To rapidly press and release a 
mouse button twice without moving the mouse. 
Double-clicking carries out an action, such as 
starting an application. 

downloadable font See soft font. 

drag To move an item on the screen by select­
ing the item and then pressing and holding down 
the mouse button while moving the mouse. For 
example, you can move a window to another 
location on the screen by dragging its title bar. 

drive See disk drive, RAM drive. 

drive icon An icon in File Manager that repre­
sents a disk drive. Different icons depict floppy 
disk drives, hard disk drives, network drives, 
RAM drives, and CD-ROM drives. 

drive letter The letter assigned to a drive-for 
example, C. See also disk drive. 

driver See device driver. 

E 
embed To insert information (an object) 
that was created in one document into another 
document (most often the two documents were 
created with different applications). The 
embedded object can be edited directly from 
within the document. To embed, you must be 
using applications that support object linking 
and embedding. See also link, object. 

embedded object Information created in one 
document and inserted into another document 
(most often the two documents were created with 
different applications). Embedded objects can 
be edited from within the destination document. 
See also linked object. 

EMS memory See expanded memory. 

emulation mode A mode in which a device such 
as a printer can emulate the actions of a different 
device. See also terminal emulation. 

environment variable Environment information, 
such as a drive, path, or filename, associated with 
a symbolic name that can be used by MS-DOS. 
You use the MS-DOS set command to define 
environment variables. 

EPT port A port requiring a special card and 
software. Only certain printers, such as the IBM 
Personal Pageprinter, use this port. 

exclusive application A non-Windows appli­
cation that has the sole use of the computer's 
resources while it is the active application and 
Windows is running in 386 enhanced mode. You 
can specify whether an application gets exclusive 
use of resources by modifying the application's 
PIF or by using the Settings command on the 
application's Control menu. When an exclusive 
application is running in a window, it gets most, 
but not all, of the resources. See also PIF. 

expand In File Manager, to show hidden 
directory levels in the directory tree. You can 
expand a single directory level, one branch of 
the directory tree, or all branches at once. 

expanded memory Memory in addition to 
conventional memory that some non-Windows 
applications use. Expanded memory is an older 
standard being replaced by the use of extended 
memory. Only EMS-compatible software can 
use expanded memory. Windows running in 386 
enhanced mode simulates expanded memory for 
applications that need it. Also known as EMS 
memory. 

expanded-memory emulator A program that con­
verts extended memory into expanded memory. 



extend selection To select more than one item. 
For example, in File Manager you can select a 
group of files to be moved or copied. 

extended memory Memory beyond I megabyte 
(MB) in 80286,80386, and 80486 computers. 
Windows uses extended memory to manage and 
run applications. Extended memory typically is 
not available to non-Windows applications or 
MS-DOS. See also XMS memory. 

extended-memory manager A program that pre­
vents different applications from using the same 
part of extended memory at the same time. 

extension The period and up to three characters 
at the end of a filename. An extension usually 
identifies the kind of information a file contains. 
For example, files that you create by using 
Calendar have the extension .CAL. 

F 
file A collection of information that has been 
given a name and is stored on a disk. This infor­
mation can be a document or an application. 

file attribute See attributes. 

file format The way information is structured 
in a file. Applications always store data files 
in a particular format. A format readable by 
one application may not be readable by another 
application. 

filename The name of a file. Windows uses 
MS-DOS naming conventions. 

filename extension See extension. 

fixed disk See hard disk. 

fixed-width font See monospaced font. 

flexible box In Paintbrush, a square box that 
changes shape as you move the mouse. You use 
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a flexible box to define an area of the picture you 
want to change, cut, copy, or move. 

floppy disk A disk that can be inserted in and 
removed from a floppy disk drive. See also hard 
disk, disk drive. 

flow control In Control Panel and Terminal, 
the processes used to regulate the rate at which 
information is transferred from one device to 
another. One device sends a signal to the other 
when information can be transferred. Also 
known as handshake. 

font A set of letters, numbers, punctuation 
marks, and symbols that are a given size and 
design. See also scalable typeface. 

font cartridge A piece of hardware that is 
plugged into a printer to supply one or more 
fonts. See also cartridge font. 

font family A group designation that describes 
the general look of a font. For example, the 
Roman font family contains proportionately 
spaced fonts with serifs. 

font size See point size. 

footer Text that appears at the bottom of 
document pages when they are printed. 

foreground The area of the screen that the 
active window occupies. See also background. 

foreground application The application you 
are working with. The foreground application 
appears in the active window. See also back­
ground application. 

format (I) The way text is set up on a page. 
(2) To prepare a disk for holding information. 
Formatting a disk deletes all information that 
was previously on it. (3) The way information 
is structured in a file, often specific to one 
application. See file format. 
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full-screen application A non-Windows applica­
tion that is displayed in the entire screen-rather 
than a window-when running with Windows. 
You can specify whether a non-Windows 
application runs in a full screen or a window 
by modifying the PIP or using the Control 
menu. See also PIP. 

G 
General MIDI specification Defines a standard 
setup for MIDI files, including channel settings, 
instrument patch settings, and key assignments. 
See also MIDI. 

graphics mode The mode that enables appli­
cations to display images in addition to text. 
Windows applications always run in graphics 
mode, whereas non-Windows applications can 
run in either graphics or text mode. 

graphics resolution The level of quality at which 
Windows prints graphics. The higher the resolu­
tion, the better the quality of the printed graphics. 
Higher-resolution graphics take longer to print 
and use more disk space. 

group A collection of applications, accessories, 
or documents within Program Manager. Group­
ing these items makes them easier to find when 
you want to start them. 

group icon The icon that represents a group in 
Program Manager when the group window is 
minimized (reduced). To open a group and view 
its contents, you choose the group icon. 

group window A window that displays the items 
in a group within Program Manager. These items 
may be applications, accessories, or documents. 

H 
handshake See flow control. 

hard disk A disk that is permanently mounted in 
its drive. Also known as fixed disk. See also disk, 
disk drive, floppy disk. 

hardware The equipment that makes up your 
computer system, including such items as the 
keyboard, mouse, disk drives, and monitor. 

header Text that appears at the top of every 
page of a document when it is printed. 

hidden file A file that is not intended to be 
viewed in a directory listing, such as your 
Windows swap file. The hidden attribute 
specifies whether a file is hidden. See also 
attributes. 

high memory area (HMA) The first 64K of 
extended memory. This area is used by some 
applications and by Windows. 

highlighted Indicates that an object or text is 
selected and will be affected by your next action. 
Highlighted text appears in reverse video on 
monochrome monitors or in color on some color 
monitors. Highlighted objects might change color 
or be surrounded by a selection cursor. You can 
change the color of the highlight by using Con­
trol Panel. 

HMA See high memory area. 

hue In Control Panel, the position of a color 
along the color spectrum. Por example, green is 
between yellow and blue. See also luminosity, 
saturation. 



i/o addresses Locations within the input/output 
address space of your computer used by a device, 
such as a printer or modem. The address is used 
for communication between software and a 
device. 

icons Graphical representations of various 
elements in Windows, such as disk drives, 
applications, embedded and linked objects, 
and documents. 

import To create a package by inserting an 
existing file into Object Packager. When you 
import a file, the icon of the application you 
used to create the file appears in the Appearance 
window, and the name of the file appears in the 
Contents window. 

inactive window Any open window that you 
are not currently working in. Also known as 
background window. 

index line In Cardfile, the bar at the top line 
of each card that contains the title of the card. 

information area In Cardfile, the area below the 
index line, into which you type information. 

initialization files Files with the extension 
.INI that contain information that defines your 
Windows environment. Windows and applica­
tions use the information stored in these files. 

insertion point The place where text will be 
inserted when you type. The insertion point 
usually appears as a flashing vertical bar in 
an application's window or in a dialog box. 
Also known as cursor. 

interrupt A signal that a device sends to the 
computer when the device is ready to accept or 
send information. 
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interrupt request lines (IRQ) Hardware lines 
over which devices can send interrupts (signals 
indicating that the device is ready to accept or 
send information). Typically, each device con­
nected to the computer uses a separate IRQ. 

K 
keyboard buffer A temporary storage area 
in memory that keeps track of keys that you 
typed, even if the computer did not immediately 
respond to the keys when you typed them. 

key map A MIDI patch-map entry that trans­
lates key values for certain MIDI messages-for 
example, the keys used to play the appropriate 
percussion instrument or a melodic instrument 
in the appropriate octave. 

L 
link (n) A reference in a destination document 
to where an object exists in a source document. 

link (v) To create a reference in a destination 
document to an object in a source document. 
When you link an object, you are inserting a 
visual presentation of the object into the desti­
nation document. The linked object can be edited 
directly from within the destination document. 
When the object changes in the source document, 
the changes appear in the destination document. 
See also embed, object. 

linked object In a destination document, a visual 
presentation (such as an icon or bitmap) of an 
object. 

list box Within an application window or dialog 
box, a type of box that lists available choices­
for example, a list of all files in a directory. If all 
the choices do not fit in the list box, there is a 
scroll bar. 
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local printer A printer that is directly connected 
to one of the ports on your computer. See also 
network printer. 

LPT port See parallel port. 

luminosity In Control Panel, the brightness 
of a color on a scale from black to white. For 
example, light blue has a higher luminosity than 
a darker blue or dark red, but may have about the 
same luminosity as a light pink. See also hue, 
saturation. 

M 
macro In Recorder, a series of recorded actions. 
You can use Recorder to create macros. When 
you run a macro, Recorder carries out all the 
recorded actions. 

manual link A link whose Update option is set 
to manual. When the linked object is edited, its 
visual presentation (image) does not reflect the 
changes until you manually update the link. 
See also automatic link, link, object linking 
and embedding. 

mark To select text in a non-Windows applica­
tion so that you can copy it onto the Clipboard. 

Maximize button The small box containing 
an up arrow at the right of the title bar. Mouse 
users can click the Maximize button to enlarge 
a window to its maximum size. Keyboard users 
can use the Maximize command on the Control 
menu. 

Media Control Interface (MCI) A standard control 
interface for multimedia devices and files. Using 
MCI, a multimedia application can control a 
variety of multimedia devices and files. Windows 
provides two MCI drivers: one controls the MIDI 
sequencer, and one controls sound for .W A V 
files. 

media file A file containing multimedia data, 
such as sound or animation. 

memory A temporary storage area for infor­
mation and applications. See also RAM, ROM, 
conventional memory, expanded memory, 
extended memory. 

memory-resident program A program that is 
loaded into memory and is available even when 
another application is active. Also known as a 
terminate-and-stay-resident (TSR) program. 
See also pop-up program. 

menu A list of available commands in an appli­
cation window. Menu names appear in the menu 
bar near the top of the window. You open a menu 
by selecting the menu name. See also Control 
menu. 

menu bar The horizontal bar containing the 
names of the application's menus. It appears 
below the title bar. 

MIDI Acronym for Musical Instrument Digital 
Interface, a standard protocol for communication 
between musical instruments and computers. 

MIDI file A file containing all the information 
required to playa sound by using a MIDI device. 

MIDI sequencer A program that plays or records 
sounds stored as MIDI files. Windows provides 
an MCI MIDI sequencer. See also Media Control 
Interface. 

MIDI setup Specifies the type of MIDI device 
you are using, its channel mappings, and the port 
it is connected to. 

Minimize button The small box containing a 
down arrow at the right of the title bar. Mouse 
users can click the Minimize button to reduce a 
window to an icon. Keyboard users can use the 
Minimize command on the Control menu. 



modem A communications device that enables 
a computer to transmit information over a tele­
phone line. 

monospaced font A font in which all characters 
have uniform widths, such as Courier New. See 
also proportional font. 

mouse pOinter See pointer. 

MS-DOS prompt At the MS-DOS command 
line, the character or characters that appear 
at the beginning of the line, indicating that the 
computer is ready to receive input. Also known 
as command prompt. 

Musical Instrument Digital Interface See MIDI. 

multimedia A combination of various media, 
such as sound, graphics, animation, and video. 

multitasking A computer's ability to run more 
than one application at the same time. 

N 
network A group of computers connected by 
cables or other means and using software that 
enables them to share equipment (such as printers 
and disk drives) and exchange information. 

network drive A disk drive that is available 
to multiple users and computers on a network. 
Network drives often store data files for many 
people in a work group. 

network printer A printer shared by multiple 
computers over a network. See also local printer. 

nonsolid color A color produced by a pattern of 
differently colored dots that simulate the desired 
color. A solid color on one device (such as a 
256-color monitor) may be a nonsolid color on 
another device. Also known as dithered color. 
See also solid color. 
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non-Windows application "Non-Windows 
application" is used in this guide as a shorthand 
term to refer to an application that is designed 
to run with MS-DOS but not specifically with 
Windows and that may not be able to take full 
advantage of all Windows features (such as 
memory management). 

o 
object In the context of object linking and 
embedding, information such as a drawing, chart, 
or sound file that can be linked to or embedded 
into another document. See also link, embed. 

object linking and embedding (OLE) A way 
to transfer and share information between 
applications. See also link, embed, object. 

open To display the contents of a file in a 
window or to enlarge an icon to a window. 

option (1) A choice in a dialog box. (2) In an 
MS-DOS command line, a parameter used to 
control how a command is carried out. Typically, 
an option starts with a slash (I). For example, to 
start Microsoft Word in character mode, you type 
word Ie at the MS-DOS prompt. The Ie is the 
option. See also parameter. 

option button A small, round button that appears 
in a dialog box. Within a group of related option 
buttons, you can select only one. 

p 
package A small drawing (or icon) that repre­
sents an embedded or linked object. When you 
choose the package, the application used to create 
the embedded or linked object either plays the 
object (for example, a sound file) or opens and 
displays the object (for example, text or graphics). 
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parallel interface An interface between a com­
puter and a printer in which the computer sends 
multiple bits of information to the printer simul­
taneously. Parallel and Centronics interfaces are 
the same type. See also serial interface. 

parallel port A connection on a computer, 
usually LPT1, where you plug in the cable for a 
parallel printer. Windows supports parallel ports 
LPT1 through LPT3. 

parallel printer A printer with a parallel inter­
face, which you connect to a parallel port. 

parameter Information added to the command 
that starts an application. A parameter can be a 
filename or any type of information up to 62 
characters in length. See also option. 

parity An error-checking procedure in which the 
number of l' s must always be the same-either 
even or odd-for each group of bits transmitted 
without error. 

paste To copy the contents of the Clipboard 
into an application. Many applications have a 
Paste command on the Edit menu that performs 
this task. 

patch map The part of a channel-map entry that 
translates instrument sounds, volume settings, 
and (optionally) key values for a channel. 

path Specifies the location of a file within the 
directory tree. For example, to specify the path 
of a file named SYSTEM.INI located in the 
WINDOWS directory on drive C, you would 
type c:\windows\system.ini. 

pel The smallest graphic unit that can be 
displayed on the screen, usually a single-colored 
dot. Pel is the abbreviation for picture element. 
Also known as pixel. 

PIF (program information file) A file that provides 
information about how Windows should run a 
non-Windows application. For example, you use 
a PIF to direct Windows to run a non-Windows 
application in a full screen rather than in a 
window, or to specify a start-up directory. 

pixel See pel. 

plotter font A font created by a series of dots 
connected by lines that can be scaled to different 
sizes (used by plotters). Also known as vector 
font. 

point To move the pointer on the screen until 
it rests on the item you want to select. 

point size The height of a printed character 
specified in units called points. A point equals 
1172 of an inch. Also known as font size. 

painter The arrow-shaped cursor on the screen 
that follows the movement of a mouse (or other 
pointing device) and indicates which area of the 
screen will be affected when you press the mouse 
button. The pointer may change shape during 
certain tasks. Also known as mouse pointer. 

pointing device An input device you use to move 
the pointer on the screen, choose commands, 
press buttons, select text, create drawings, and so 
on. For example, a mouse is a pointing device. 

pop-up program A memory-resident program 
that is loaded into memory but isn't visible until 
you press a certain key combination or until a cer­
tain event occurs, such as receiving a message. 
See also memory-resident program. 

port A connection or socket on the computer. 
Ports are used for connecting devices, such as 
printers, monitors, and modems, to your com­
puter, and for sending information from your 
computer to the devices. Serial ports (COM) 
and parallel ports (LPT) are the most commonly 
used ports. 



printer driver A program that controls how your 
computer and printer interact. A printer-driver 
file supplies Windows with such information as 
the printing interface, description of fonts, and 
features of the installed printer. 

printer fonts Fonts that are stored in your 
printer's memory, or soft fonts that are sent 
to your printer before a document is printed. 
Because the font works only with the printer, 
Windows can only approximate the font's 
appearance on the screen. See also screen font, 
soft font, TrueType fonts. 

print queue A list of files that have been sent 
to a printer. The list indicates the file currently 
printing and those waiting to be printed. 

program file An executable file that starts an 
application or program. A program file has an 
.EXE, .PIF, .COM, or .BAT filename extension. 

program information file See PIF. 

program items The applications and documents 
that make up a group in Program Manager. Pro­
gram items are represented as icons in a group 
window. 

program-item icon The icon that represents an 
application or document in Program Manager. 
You can start an application or open a document 
by choosing its program-item icon. (To choose 
the icon, you double-click it. Or you can use the 
arrow keys to move the selection cursor to it, and 
then press ENTER.) 

proportional font A font in which different 
characters have varying widths, such as Times 
New Roman. See also monospaced font. 

protected mode A computer's operating mode 
that is capable of addressing extended memory 
directly. 

protocol A set of rules that define how comput­
ers communicate with each other. 
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o 
queue See print queue. 

quick format Deletes the file allocation table and 
root directory of a disk, making it appear empty, 
but it does not delete the file information on the 
disk or scan the disk for bad areas. This serves as 
a quick way to format a previously formatted 
disk. 

R 
RAM (random access memory) The memory that 
can be used by applications to perform necessary 
tasks while the computer is on. When you tum 
the computer off, all information in RAM is lost. 
See also virtual memory, ROM. 

RAM drive A portion of memory that is used 
as if it were a hard disk drive. RAM drives are 
much faster than hard disks because your com­
puter can read information faster from memory 
than from a hard disk. However, information on a 
RAM drive is lost when you tum off or restart 
your computer. Also known as virtual drive. 

raster font See screen font. 

read-only file A file that you can read but 
cannot make changes to. The read-only attribute 
specifies whether a file is read-only. See also 
attributes. 

reduce To minimize a window to an icon at 
the bottom of the desktop by using the Minimize 
button or the Minimize command. A minimized 
application continues running, and you can select 
the icon to make it the active application. 

resolution Indicates the number of dots that 
make up an image on a screen or printer. The 
larger the number of dots, and thus the higher 
the resolution, the finer and smoother images 
can appear when displayed at a given size. 
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Restore button The small button containing both 
an up and down arrow at the right of the title bar. 
The Restore button appears only after you have 
enlarged a window to its maximum size. Mouse 
users can click the Restore button to return the 
window to its previous size. Keyboard users can 
use the Restore command on the Control menu. 

ROM (read-only memory) Memory that can be 
read, but not modified. The contents of this 
memory is retained even when the computer 
is turned off. 

root directory The top-level directory of a disk. 
The root directory is created when you format the 
disk. From the root directory, you can create files 
and other directories. 

s 
saturation In Control Panel, the purity of a 
color's hue, moving from gray to the pure color. 
For example, a very dark blue may have mostly 
black with only a small amount of blue, and thus 
would have a very low saturation. See also hue, 
luminosity. 

scalable typeface A set of letters, numbers, 
punctuation marks, and symbols that are a given 
design but can be scaled to any size. 

scaled point size A point size that approximates 
a specified point size for use on the screen. For 
example, text that prints at 10 point on the printer 
may be represented by a slightly larger font on 
the screen to make up for the screen's lower 
resolution. 

screen font The font that is displayed on your 
screen, which may approximate a printer font so 
that documents look approximately the same on 
the screen as they do when printed. 

screen saver A moving picture or pattern that 
appears on your screen when you have not 
moved the mouse or pressed a key in Windows 
for a specified period of time. Screen savers 

prevent screen damage that is caused when the 
same areas of light and dark are displayed for 
long periods of time. 

scroll To move through text or graphics 
(up, down, left, or right) in order to see parts of 
the file or list that cannot fit on the screen. 

scroll arrow An arrow on either end of a scroll 
bar that you use to scroll through the contents of 
the window or list box. 

scroll bar A bar that appears at the bottom 
and/or right edge of a window whose contents 
are not entirely visible. Each scroll bar contains 
a scroll box and two scroll arrows. 

scroll box In a scroll bar, the small box that 
shows the position of information currently in the 
window or list box relative to the contents of the 
entire window. 

scroll buffer In Terminal, the buffer that holds 
information that does not fit on the screen. 

select To mark an item so that a subsequent 
action can be carried out on that item. You usu­
ally select an item by clicking it with a mouse 
or pressing a key. After selecting an item, you 
choose the action that you want to affect the item. 
See also choose. 

selection cursor The marking device that shows 
where you are in a window, menu, or dialog box 
and what you have selected. The selection cursor 
can appear as a highlight or as a dotted rectangle 
around text. 

sequencer See MIDI sequencer. 

serial interface An interface between a computer 
and a serial device, such as a printer or modem, 
by which the computer sends single bits of infor­
mation to the device, one after the other. Serial, 
asynchronous, and RS232 interfaces are all the 
same type. See also parallel interface. 



serial printer A printer using a serial interface, 
which you connect to a serial port. 

serial port A connection on a computer, usually 
COM l, where you plug in the cable for a serial 
device. Common serial devices are printers and 
modems. Windows supports COMl through 
COM4. 

server A computer that provides disk space, 
printers, or other services to computers over a 
network. See also network drive, network printer. 

server application A Windows application that 
creates objects that can be linked and embedded 
into other documents. See also client application. 

shortcut key A key or key combination that you 
press to carry out a command or action. If a com­
mand has a shortcut key, the key combination is 
listed to the right of the command name on the 
menu. For example, pressing the shortcut key 
ALT+F4 closes the active application. 

Simple device An MCI device that does not use 
media files. For example, an audio compact-disc 
player is a simple device. See also compound 
device, Media Control Interface. 

soft font A font, usually provided by a font ven­
dor, that must be installed on your computer and 
sent to the printer before it can be printed. Also 
known as downloadable font. 

software The set of instructions that make 
computer hardware perform tasks. Programs, 
operating systems, device drivers, and appli­
cations are all software. 

solid color A color that appears on a display 
when all pels are the same color. On a mono­
chrome display, there are only two solid colors: 
black and white. See also nonsolid color. 
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sound driver A program that applications use 
to play sounds on your computer. 

sound file A file containing audio information 
that an application can play on your computer. 
You can assign a sound file to a system event, 
such as starting Windows, so that you are alerted 
by a sound when the event occurs. 

source directory The directory that contains the 
file or files you intend to copy or move. 

source document The document from which a 
linked object originates. 

special characters Characters not found on 
your computer's keyboard. These are accessible 
through Character Map, an application in the 
Accessories group. 

split bar Divides a window into two parts. In 
File Manager, a directory window is divided by a 
split bar: The directory tree is on the left, and the 
contents of the current directory are on the right. 

standard mode A Windows operating mode that 
can be used with 80286, 80386, and 80486 com­
puters. This mode provides access to extended 
memory and also enables you to switch between 
non-Windows applications, but it does not pro­
vide virtual memory or enable non-Windows 
applications to run in the background or in a 
window. See also 386 enhanced mode. 

status bar A line of information usually located 
at the bottom of a window. In File Manager, the 
status bar shows the number of bytes available 
on the disk and the total disk capacity. Not all 
windows have a status bar, and in many appli­
cations, it is optional. 

subdirectory A directory within another 
directory. 
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swap file An area of your hard disk that is 
set aside for exclusive use by Windows in 386 
enhanced mode. Windows temporarily transfers 
information from memory to the swap file to free 
memory for other information. Swap files can be 
either temporary or permanent. See also applica­
tion swap file. 

switch See option. 

synthesizer A device that produces sound from 
digital instructions rather than from recorded 
sound. 

system disk A disk that contains the MS-DOS 
system files necessary to start MS-DOS. You can 
have more than one system disk; however, the 
disk from which MS-DOS is loaded when you 
start your computer is called the boot disk. 

system file A file that contains information 
required for running the MS-DOS operating 
system. A system file is not shown in the 
directory listing. The system attribute specifies 
whether a file is a system file. See also attributes. 

system time The time according to your 
computer's internal clock. 

SYSTEM.lNI file A Windows initialization file 
that contains settings you can use to customize 
Windows for your system's hardware. 

T 
Task List A window that shows all the appli­
cations you have running and enables you to 
switch between them. You can open Task List 
by choosing Switch To from the Control Menu 
or by pressing CTRL+ESC. 

terminal emulation In Terminal, a setting that 
causes your computer to emulate a hardware 
terminal (a device used to display data received 
from a remote computer). 

terminate-and-stay-resident (TSR) program 
See memory-resident program. 

text box In a dialog box, a box in which you 
type information needed to carry out a command. 
The text box may be blank or may contain text 
when the dialog box opens. 

text editor An application used to create, view, 
and modify text files; for example, Notepad. 

text file A file containing only letters, digits, 
and symbols. A text file usually consists of 
characters coded from the ASCII character set. 
Also known as data file. See also document file, 
binary file. 

text mode The mode that enables applications to 
display text but not graphic images. Many non­
Windows applications run in text mode. See also 
graphics mode. 

text transfer A method for transferring text files 
from Terminal to a remote computer. 

tile A way of arranging open windows so that 
no windows overlap but all windows are visible. 
Each window takes up a portion of the screen. 

timeout If a device is not performing a task, the 
amount of time a computer should wait before 
detecting it as an error. 

time slice The amount of processor time 
allocated to an application, usually measured in 
milliseconds. Each application can run for this 
specified amount of time before the next applica­
tion is given control. 

title bar The horizontal bar (at the top of a 
window) that contains the title of the window or 
dialog box. On many windows, the title bar also 
contains the Control-menu box and Maximize 
and Minimize buttons. 



TrueType fonts Fonts that are scalable and 
sometimes generated as bitmaps or soft fonts, 
depending on the capabilities of your printer. 
True Type fonts can be sized to any height, and 
they print exactly as they appear on the screen. 
See also printer font, screen font. 

TSR Acronym for terminate-and-stay-resident 
program. See memory-resident program. 

u 
upper memory area The 384K area of address 
space adjacent to the 640K of conventional 
memory. This area is usually reserved for 
running your system's hardware, such as your 
monitor, and is not considered part of total 
memory because applications cannot store 
information in this area. In 386 enhanced mode, 
Windows can access unused portions of this area. 

upper memory blocks (UMBs) Areas of the 
upper memory area that contain general-purpose 
memory and that can be used to hold device 
drivers or other memory-resident programs 
in order to leave more conventional memory 
available for applications. 

v 
vector font See plotter font. 

virtual drive See RAM drive. 

virtual memory A memory-management system 
used by Windows in 386 enhanced mode that 
enables Windows to run as if there were more 
memory than is actually present. The amount of 
virtual memory available equals the amount of 
free random-access memory (RAM) plus the 
amount of disk space allocated to a swap file that 
Windows uses to simulate additional RAM. 

volume label A name that identifies a disk. 
The volume label appears in the title bar of a 
directory window in File Manager. 
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w 
wallpaper An image being displayed on the 
desktop background. 

wildcard A character that represents one or 
more other characters. In filenames, you can use 
the question mark (?) to represent any single 
character and the asterisk (*) to represent any 
character or group of characters that might match 
that position in other filenames. For example, 
* .EXE represents all files that end with the .EXE 
filename extension. 

WIN.INI file A Windows initialization file that 
contains settings you can use to customize your 
Windows environment. 

window A rectangular area on your screen in 
which you view an application or document. You 
can open, close, and move windows, and change 
the size of most windows. You can open several 
windows at a time, and you can often reduce a 
window to an icon or enlarge it to fill the entire 
desktop. Sometimes windows are displayed 
within other windows. See also application 
window, document window. 

Windows application "Windows application" 
is used in this guide as a shorthand term to refer 
to an application that is designed to run with 
Windows and does not run without Windows. All 
Windows applications follow similar conventions 
for arrangement of menus, style of dialog boxes, 
and keyboard and mouse use. 

Windows character set The character set used to 
display Windows and Windows applications. It is 
based on the ANSI character set. See also ANSI 
character set. 

word wrap A feature that moves text from the 
end of a line to the beginning of a new line as 
you type. With word wrap, you do not need to 
press ENTER at the end of each line in a paragraph. 
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workspace The area of a window that displays 
the information contained in the application or 
document you are working with. 

x 
XMS memory Extended memory that can be 
accessed by using the eXtended Memory Specifi­
cation from Lotus, Intel, Microsoft, and AST. 
Applications work with an extended-memory 
manager, which makes sure only one application 
is using a portion of memory at anyone time. 
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386 Enhanced command, in PIF Editor, 261 
386 enhanced mode 

About command, checking Windows mode, 242 
defined,7 
network drives, disconnecting from, 117 
non-Windows applications, features, 241-247 
out-of-memory message, 253 
PIF options for 

advanced options, 269-278 
basic options, 261-268 

Scheduling options, 532 
swap files, 533-536 

386SPART.PAR file, 533 
80286 computer, configuring, 522 
80386 or 80486 computer, configuring, 521 

A 
About command, checking Windows mode, 242 
Accessories 

adding or removing by using Setup, 564 
Calculator, 409 
Calendar, 420 
Cardfile, 434 
Character Map, 447 
Clock,449 
Media Player, 451 
Notepad, 455 
Paintbrush,329 
PIF Editor, 259 
Recorder, 459 
Sound Recorder, 474 
Terminal, 379 
Write, 291 

Accessories group, described, 73 
Activate Contents command, Object Packager, 507 
Add command, Cardfile, 436 
Add Echo command, Sound Recorder, 481 
Add Fonts dialog box, 166 
AddlRemove Windows Components command, 

564-567 
Advanced port settings, 161 
Airbrush tool in Paintbrush, 346 
Alarm, in Calendar, 425--427 
Alert Always option, Print Manager, 222 

All File Details command, File Manager, 108, 128 
Allow Close When Active option, PIF Editor, 275 
Allow Fast Paste option, PIF Editor, 274 
Always On Top command, Clock, 450 
Always Warn option, Control Panel, 247 
Analog command, Clock, 450 
ANSI format for Write files, 324 
Append File option, Terminal, 400 
Application Shortcut Key option, PIF Editor, 

276-278 
Application window 

See also Window 
arranging, 57 
Control menu, opening, 19 
described,9 
document window, described, 10 
illustrated, 6 

Applications 
See also Non-Windows applications; Program items 
associating files with, 130-132 
Clipboard, transferring information, 59-60 
dialog boxes, common, 40 
directory for starting, 251-252 
fast application switching, 152 
icons for 

described, 12 
illustrated, 6 
in directory windows, 118 
in group windows, 72 

linking. See Object linking and embedding 
PIFs for. See PIF Editor 
program items for, creating 

by using File Manager, 82 
by using Program Manager, 78 
by using Setup, 82 

quitting 
by quitting Windows, 275 
non-Windows applications, 64 
Windows applications, 63 

reducing to icons when starting, 54, 80 
running simultaneously, 55 
setting up by using the Setup program, 560-563 
settings, changing 

by using PIF Editor. See PIF Editor 
by using the Settings command, 243-246 
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Applications (continued) 
shortcut keys, 276-278 
starting 

by using MS-DOS Prompt, 54 
by using the Run command, 53 
from a directory window, 133 
from a group, 86 
from the StartUp group, 87 
with application parameters, 262, 279 

switching between a window and full screen, 268 
switching between applications, 55-56 
troubleshooting. See Getting Started with 

Microsoft Windows 
types of, described 

memory-resident programs, 51 
non-Windows applications, 50 
older Windows applications, 50 
Windows applications, 50 

Applications group 
creating program items in, 82 
described,73 

Archive file attribute, 128 
Arrange Icons command 

File Manager, 113 
Program Manager, 76 
Task List, 58 

Arranging 
application windows, 57 
directory windows, 112 
group windows, 74-75 
icons 

individually, 76 
using Task List, 58 
using the Arrange Icons command, 76, 113 
using the Auto Arrange command, 76 

Associate command, File Manager, 130-132 
Attributes. See File attributes 
Auto Arrange command, Program Manager, 76 
Auto command, Clipboard, 62 
Autodial command, Cardfile, 446 
AUTOEXEC.BAT file 

editing to free memory, 530-531 
modifying, 528-529 
mouse driver, MOUSE.COM, 243 
SMARTDrive program, installing, 538 
TEMP variable, specifying, 541-542 
troubleshooting. See Getting Started with 

Microsoft Windows 

B 
Background of the desktop 

displaying patterns, 148 
displaying wallpaper, 151 

Background option 
PIF Editor, 268 
Settings command, 242, 245 

Background Priority option, PIF Editor, 270 
Backup copies of Write files, 326 
Base port address, specifying, 161 
.BAT (batch) filename extension, 118 
Batch file 

creating PIFs for, 256 
icon for, in directory windows, 118 
starting memory-resident programs from, 256 
WINSTART.BAT file, 531 

Baud rate option 
Cardfile, 447 
Terminal, 382 

Beep 
default beep, changing, 184 
turning on or off, 185 

Binary file 
described,394 
transferring 

preparing for transfer, 397 
receiving, 403 
sending, 402 

Binary number system, Calculator, 415 
Binary Transfers command, Terminal, 397 
Bitmap 

format, for Paintbrush files, 373 
wallpaper, displaying, 151 

.BMP (bitmap) filename extension, 373 
Bold type 

as a document convention, xxiii 
in Paintbrush drawings, 341 
in Write documents, 308 

Box tools in Paintbrush, 356-357 
Breaking 

lines in Write documents, 299 
links between drawings and documents, 502 
pages in Write documents, 304 

Brush tool in Paintbrush, 351 
Buffer Lines option, Terminal, 388 
Buffers command, CONFIG.SYS file, 522 



Buttons 
command buttons, 33 
mouse, swapping left and right, 176 
for sizing windows (illustrated), 8 

By File Type command, File Manager, 110 

c 
.CAL filename extension, 430 
Calculator 

calculations, performing, 410 
copying and pasting values, 412, 415 
keys 

for advanced functions, 417-420 
for standard functions, 413 

memory, 411 
scientific 

described, 413 
number systems, 415 
statistical calculations, 416 

standard functions, 413 
starting, 409 

Calendar 
alarms 

early ring, 426 
removing, 427 
setting, 425 
sound option, 426 
turning off, 427 

appointments 
editing, 423 
entering, 422 

.CAL filename extension, 430 
dates, marking, 429 
day settings, customizing, 427 
day, displaying specific dates, 423 
files, managing, 430 
headers and footers, printing, 433 
keys for working with, 590 
margins for printed appointments, 432 
month, displaying, 424 
printing appointments, 432 
starting, 420 
times, adding, 428 
views, switching between, 421 

Canceling 
check boxes, 39 
commands, 42 
echos in sound files, 481 
file transmission, 399--400, 403--404 
links, 502 

Canceling (continued) 
menus, 17 
print jobs, 219 
selections 

in application windows, 68 
in dialog boxes, 36 
in directory windows, 98 

Cardfile 
adding cards, 436 
copying text among cards, 440 
.CRD filename extension, 444 
deleting cards, 443 
drawings on cards 

editing drawings, 442 
inserting drawings, 440 

duplicating cards, 443 
editing cards, 439-440 
files 

file size, determining, 444 
merging, 445 
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saving in Windows 3.0 format, 444 
filling in cards, 435 
index line, 439 
keys, 591 
listing cards, 437 
moving text, 440 
phone dialing, 446 
printing, 445 
restoring cards after changing, 443 
scrolling through cards, 437 
searching for text, 438 
sound files 

editing embedded files, 497 
editing linked files, 499 
embedding, 496 
linking, 498 

starting, 434 
Carrier Detect option, Terminal, 383 
Cartridge fonts 

described, 164 
installing, 210 

Cartridges option, Print Manager, 209 
Cascade command 

See also Tile command 
rearranging 

application windows, 57 
directory windows, 112 
group windows, 74-75 

Cascading menu, defined, 18 
Centering text in Write documents, 314 
Change Links dialog box, 503 
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Change System Settings command, Setup, 558-560 
Channel mapping, MIDI, 194-196 
Character At A Time option, Terminal, 396 
Character format 

character styles 
in Paintbrush drawings, 341 
in Write documents, 308 

fonts 
in Clock, 451 
in directory windows, 113 
in Paintbrush drawings, 340 
in Write documents, 310 

subscript or superscript, 310 
Character Map 

characters, inserting, 448 
font, selecting, 448 
starting, 447 

Character set 
See also Character Map 
code page, changing, 568 

Charts, editing in Paintbrush, 369 
Check box, in dialog boxes, 39 
Check mark on menus, meaning of, 18 
.CHK filename extension, 526 
Chkdsk command 

cleaning up lost files, 526 
restrictions on running 

from MS-DOS Prompt, 55 
from Windows, 526 

Choosing vs. selecting, defined, 15 
Circle, drawing perfectly round, 359 
CirclelEllipse tools in Paintbrush, 358 
Clear Buffer command, Terminal, 406 
Clear command, Paintbrush, 369 
Clearing check boxes, 39 
Clicking with the mouse, described, 15 
Client application, defined, 487 
Clipboard 

See also Object linking and embedding 
clearing contents, 63 
Clipboard Viewer 

keys for working with, 591 
using, 61 

copying information 
between non-Windows applications, 248-251 
between Windows applications, 59-60 

display format, changing, 61 
files, retrieving, 62 
formats for linking or embedding, 504 
memory, freeing for applications, 253 

Clipboard (continued) 
pasting information 

into non-Windows applications, 250 
into Windows applications, 61 
to a remote computer, 405 

picture formats, limiting, 362 
saving contents of, 62 
screen contents, copying, 60, 249 
window contents, copying 

Clock 

non-Windows applications, 250 
Windows applications, 60 

customizing, 450 
font, changing, 451 
starting, 449 
switching between analog and digital, 450 

Close command, on Control menus 
closing directory windows, 107 
closing files or windows, 31 
described, 22 

Close Window On Exit option, PIF Editor 
386 enhanced mode, 268 
standard mode, 284 

Closing 
applications 

by quitting Windows, 275 
non-Windows applications, 64 
Windows applications, 63 

dialog boxes, 42 
directory windows, 107 
files, 22 
menus, 17 
windows, 31 

.CLP filename extension, 62 
Code page, changing, 568 
Collapse Branch command, File Manager, 102 
Collapsing a directory, 102 
Color 

desktop color schemes 
changing, 144 
choosing, 142-143 
creating custom colors, 146 
removing, 145 

in drawings 
airbrushing, 346 
creating custom colors, 371 
filling in shapes, 350 
fixing color leaks, 370 
inverting colors in cutouts, 368 
replacing, 347-349 
selecting, 335-336 



Color Eraser tool in Paintbrush, 347 
Colors option, Paintbrush, 332 
Column, creating in a Write document, 321 
Columns option, Terminal, 387 
.COM filename extension, 118 
COM port, selecting, 207 
Command 

choosing from menus, 17 
dimmed commands, meaning of, 18 
Help for dialog boxes, 46 
packaging, 511 

Command buttons, in dialog boxes, 33 
Command Line command, Object Packager, 511 
Command prompt. See MS-DOS Prompt 
Communications command, Terminal, 381-382 
Communications, remote. See Terminal 
Compacting your hard disk, 527 
CONFIG.SYS file 

editing to free memory, 529-530 
EMM386 memory manager 

command line, 552 
installing, 551 
memory options, 553-555 

HIMEM extended memory manager 
command lines, 543-547 
installing, 543 

memory, configuring 
80286 computer, 522 
80386 or 80486 computer, 521 

modifying, 528-529 
mouse driver, MOUSE.SYS, 243 
RAMDrive memory-disk program 

commandline,548-550 
setting up, 548 

SMARTDrive command line, 541 
troubleshooting. See Getting Started with 

Microsoft Windows 
Configuring 

device drivers, 182 
memory, 521-522 
ports 

advanced options, 161-162 
described, 159 
standard settings, 160 

printers, 159 
Confirmation messages, File Manager, 126 
Connect Network Drive command, 115 
Connecting 

to network drives, 115 
to remote computers, 393 

Connector option, Terminal, 383 
Contents feature in Help, 45 
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Control+Break Checking command, Recorder, 473 
Control codes for Terminal function keys, 391 
Control menu 

commands, described, 22 
Control-menu box (illustrated), 8 
opening 

for application windows or icons, 19 
for dialog boxes, 20 
for document windows or icons, 20 
for non-Windows applications, 21 

Control Panel 
386-enhanced-mode options, 198 
color schemes for the desktop 

changing, 144 
choosing, 142-143 
custom colors, 146 
removing, 145 

date and time, system, 176 
desktop options 

border width for windows, 158 
cursor blink rate, 158 
fast application switching, 152 
icon spacing, 156 
patterns, 148-150 
screen savers, 152-154 
sizing grid, 157 
wallpaper, 151 

device-contention options, 247 
drivers 

configuring, 182 
drivers not supplied with Windows, 181 
installing, 179 
removing, 183 

fonts 
described, 164 
installing additional fonts, 165 
removing, 168 
TrueType fonts, 165-168 
viewing on the screen, 165 

icons for settings, described, 139 
international settings 

basic settings, 169 
currency format, 173 
date format, 171 
number format, 174 
time format, 172 

keyboard speed, adjusting, 178 
keys for working with, 592 
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Control Panel (continued) 
MIDI Mapper 

channel maps, creating, 194-196 
deleting maps and setups, 197 
editing maps and setups, 197 
key maps, creating, 189-191 
MIDI setups, creating, 188-197 
MIDI setups, selecting, 186 
patch maps, creating, 191-193 

mouse, customizing, 175 
network options, 163 
ports 

advanced options, 161-162 
described,159 
standard settings, 160 

printers, installing and configuring, 159 
sound options 

assigning sounds to events, 184 
described, 183 
turning sounds on or off, 185 

starting, 139 
Controls command, Calendar, 426 
Conventional memory 

described, 517 
PIF options for allocating 

386 enhanced mode, 265 
standard mode, 281 

Converting files 
Microsoft Paint to Paintbrush format, 373 
non-Write files to Write format, 324-325 

Copy command 
Cardfile, 440 
File Manager, 123-124 
Paintbrush, 361 
Program Manager, 84 
Terminal, 405 
Windows applications, 60 

Copy Disk command, File manager, 137 
Copy Package command, Object Packager 

command-line commands, 511 
entire documents, 507-509 
partial documents, 511 

Copy To command, Paintbrush, 366 
Copying 

See also Object linking and embedding 
cards in Cardfile, 440 
cutouts within drawings, 363 
disks, 136 
files 

onto the Clipboard, 124 
to another directory or disk drive, 123-124 

Copying (continued) 
from non-Windows applications, 248-249 
from Windows applications, 60 
linked objects, 501 
numbers in Calculator, 412, 415 
pictures onto the Clipboard, 361 
program items between groups, 83 
screen contents 

non-Windows applications, 249 
Windows applications, 60 

window contents 
non-Windows applications, 250 
Windows applications, 60 

Correcting typing mistakes, 68 
Country option, Control Panel, 170 
CR to CR/LF option, Terminal, 388 
.CRD filename extension, 444 
Create Directory command, File Manager, 119 
Creating directories, 119 
Creating drawings. See Drawing 
Creating groups, 77 
Currency format, 173 
Current directory 

changing, 100-101 
icon for, 93 

Cursor 
blink rate, changing, 158 
keys, 586 
Paintbrush 

changing brush shapes, 351 
described, 331 
displaying coordinates, 369 

Cursor option, Terminal, 388 
Cursor Position command, Paintbrush, 369 
Curve tool in Paintbrush, 353 
Custom colors, defining, 146 
Customer Support Services 

See also Product Support Services 
obtaining device drivers, 559 

Cut command 
application Edit menu, 60 
Cardfile, 440 
Paintbrush, 361 

Cutout 
cutting and pasting, 361 
defined, 344 
flipping, 368 
free-form, 344 
inverting colors, 368 
linking or embedding, 361 
moving, 363 



Cutout (continued) 
opaque pasting and sweeping, 365 
pasting from a file, 366 
rectangular, 345 
saving, 366 
size, changing, 367 
sweeping, 363-364 
tilting, 369 
transparent pasting and sweeping, 365 
zoom-out mode, working in, 365 

Cutting 

D 

See also Copying; Pasting 
links, deleting, 502 
Windows applications, cutting from, 60 

Data Bits option 
Control Panel, 161 
Terminal, 382 

Data file, opening in Write, 324-325 
Data transfer 

between applications 
non-Windows applications, 248-251 
Windows applications, 59-60 

between computers. See File transfer 
Date 

Calendar, marking in, 429 
format, changing, 171 
Notepad files, adding to, 459 
system date, changing, 176 

Date command 
Calendar, 424 
Clock,450 

Day command, Calendar, 422 
Day Markings dialog box, Calendar, 430 
Day Settings command, Calendar, 427 
Decimal number system, Calculator, 415 
Decrease Speed command, Sound Recorder, 480 
Decrease Volume command, Sound Recorder, 480 
Default option, Paintbrush, 332 
Default printer, selecting, 213 
_DEFAULT.PIF file, 238 
Delete After Current Position command, 481 
Delete Before Current Position command, 481 
Delete command 

Cardfile, 443 
Clipboard Viewer, 63 
File Manager, 125 
Program Manager, 77, 83 
Recorder, 470 

Deleting 
alarms in Calendar, 427 
appointments in Calendar, 431 
cards in Cardfile, 443 
Clipboard contents, 63 
color schemes for the desktop, 145 
device drivers, 183 
drawings, portions of 

using eraser tools, 349 
using Undo or BACKSPACE, 338 

files from print queues, 219 
files or directories, 125 
fonts, 168 
groups, 77 
links, 502 
macros from Recorder files, 470 
MIDI maps and setups, 197 
patterns for the desktop, 150 
program items from a group, 83 
sound files, 481 
Windows components, 564-567 

Desktop 
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border width for windows, changing, 158 
color schemes 

changing, 144 
choosing, 142-143 
custom colors, creating, 146 
removing, 145 

cursor blink rate, changing, 158 
defined,6 
fast application switching, 152 
icon spacing, changing, 156 
patterns 

changing, 149 
creating, 150 
displaying, 148 
removing, 150 

screen savers 
customizing, 154 
password, specifying, 154 
selecting, 152 
testing, 153 

sizing grid, changing, 157 
wallpaper, 151 

Destination 
directory, defined, 121-122 
disk, defined, 136 
document, defined, 489 

Detect Idle Time option, PIF Editor, 271 
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Device command 
EMM386.EXE,551-555 
HIMEM.SYS, 543-547 
RAMDRIVE.SYS, 548 

Device-contention options, Control Panel, 247 
Device driver 

See also Memory manager 
configuring, 182 
installing 

by using Control Panel, 179-181 
by using Setup, 557-560 

removing, 183 
settings, changing, 558 
updating, 567 

Device Not Selected option, Print Manager, 213 
Dial command, Terminal, 393 
Dialing phone numbers, in Terminal 

using a function key, 389 
using the Dial command, 393 

Dialog box 
closing, 42 
command buttons, 33 
common dialog boxes, 40 
Control menu, opening, 20 
described, 31 
directories, selecting, 41 
disk drive, selecting, 42 
file types, selecting, 41 
filenames, selecting, 40 
Help, online, 46 
keys for working with, 585 
list boxes 

drop-down, 37 
illustrated,35 
selecting items from, 36-37 

moving, 32 
options 

check boxes, 39 
moving between options, 32 
option buttons, 38 

scrolling through information in, 30 
text boxes, 34 

Digital command, Clock, 450 
Dir command, checking free disk space, 520 
Directly Modifies option, PIF Editor, 283 
Directories option, File Manager, 110 
Directory 

applications, start-up directory 
specifying in PIF Editor, 263, 280 
specifying in Program Manager, 80 

changing the current directory, 100-101 

Directory (continued) 
collapsing, 102 
copying, 123-124 
creating, 119 
current, 93 
deleting, 125 
expandable, marking with a plus sign, 103 
expanding, 101 
icons for, 93, 118 
keys for working with, 589 
moving, 121-122 
naming conventions for, 118 
renaming, 127 
searching for, 120 
selecting 

in directory windows, 94-97 
in list boxes, 41 

Directory Delete option, File Manager, 126 
Directory icons, described, 93 
Directory Only command, File Manager, 99 
Directory path, in the directory window, 93 
Directory tree 

changing the current directory, 100-101 
collapsing directory levels, 102 
described, 92 
display options, 99 
expandable directories, marking, 103 
expanding directory levels, 101 
opening directory windows, 104-105 
Up icon, described, 94 

Directory windows 
arranging, 112 
arranging when reduced to icons, 113 
canceling selections, 98 
changing the current directory, 100-101 
closing, 107 
described, 92 
display options, 107-109 
displaying 

directories on another drive, 99 
directory contents, 99 
directory tree, 99 

font, changing, 113 
icons in, 93, 118 
opening, 104-105 
selecting files or directories 

more than one group, 96 
one at a time, 94 
one group, 97 
two or more in sequence, 95 
two or more out of sequence, 96 



Directory windows (continued) 
selecting to make active, 106 
sorting the contents of, 109 
split bar, 94, 111 
starting applications from, 133 
status bar, 114 
updating, 111 

Disconnect Network Drive command, 115 
Disconnecting 

from network drives, 117 
from remote computers, 408 

Disk 
copying, 136 
formatting, 135 
labeling, 137 
system disk, creating, 136 
volume label for, described, 93 

Disk caching 
described, 537 
SMARTDrive program 

command line, 539-540 
installing, 538 

Disk Commands option, File Manager, 126 
Disk drive 

displaying directory contents of, 99 
icons for, 93 
selecting in dialog boxes, 42 

Disk space 
amount of, determining, 519 
application swap files, 536-537 
described, 519 
disk caching, 537 
freeing 

by removing unnecessary files, 524-525 
by removing Windows components, 564-567 
by using the Chkdsk command, 526 

out-of-memory message, 253 
swapping to disk, preventing, 535-536 

Display driver 
installing 

by using Control Panel, 179 
by using Setup, 557 

updating, 567 
Display options 

PIF Editor, 272-273 
Settings command, 244 

Display Usage option, PIF Editor, 268 
Document 

closing, 22 
icon for, in directory windows, 118 
opening, 64 

Document (continued) 
packaging 

by using File Manager, 508-509 
by using Object Packager, 505 
partial documents, 510 

program items for, creating, 81-82 
saving, 65 
switching between documents, 66 
text 

correcting typing mistakes, 68 
editing selected text, 69 
entering, 67 
moving within, 67 
selecting, 68 

Write documents. See Write 
Document window 

Control menu, opening, 20 
described, 10 

Documents option, File Manager, 110 
DOSPRMPT .PIF file, 257 
Double-clicking with the mouse 

described, 15 
double-click speed, changing, 176 

Draft option, Paintbrush, 375 
Drag (mouse action), described, 15 
Dragging icons to perform tasks, 58-59 
Drawing 

basic drawing techniques 
colors, selecting, 335-336 
drawing width, selecting, 337 
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text, including in a drawing, 339-341 
tools, selecting and using, 337 
undoing your changes, 338 

custom colors, 371 
cutouts 

copying, 363 
cutting and pasting, 361 
defining, 344 
flipping, 368 
inverting colors, 368 
linking or embedding, 361 
moving, 363 
opaque pasting and sweeping, 365 
pasting from a file, 366 
saving, 366 
size, changing, 367 
sweeping, 364 
tilting, 369 
transparent pasting and sweeping, 365 
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Drawing (continued) 
drawing area 

described,330 
moving around in a large drawing, 333 
size, changing, 331-333 
viewing an entire drawing, 334 

editing drawings 
embedded drawings, 493 
eraser tools, using, 347-349 
linked drawings, 495 
positioning lines and text, 369 
text editing, 342 
Undo or BACKSPACE, using, 338 
Zoom In command, using, 370 

embedding drawings, 491-492 
file formats, 373 
linking drawings, 494 
printing drawings 

changing printer or printer options, 378 
options, described, 374 
printing part of a drawing, 375 

starting a new drawing, 332 
tools 

Airbrush, 346 
Box, 356 
Brush,351 
Circ1elEllipse, 358 
Color Eraser, 347 
Curve, 353 
Eraser, 349 
Line,355 
Paint Roller, 350 
Pick,344-345 
Polygon, 359 
Rounded Box, 357 
Scissors, 344 
Text, 347 

Drive. See Disk drive 
Drive icon 

described, 93 
keys for working with drives, 589 
opening directory windows, 105 

Driver. See Device driver 
Drop-down list box, in dialog boxes, 37 
Duplicate command, Cardfile, 443 

E 
Echo 

adding to sound files, 481 
keystroke echo, 387 

Edit colors command, Paintbrush, 371 
Edit commands, on Control menus, 23 
Edit Paintbrush Picture Object command 

editing embedded drawings, 493 
editing linked drawings, 495 

Editing desktop patterns, 150 
Editing drawings. See Drawing 
Editing text 

basic techniques, 68-69 
in Cardfile, 439-440 
in Paintbrush, 342 
in Terminal, 405-406 
in Write. See Write 
keys for editing text, 586 

Ellipse tools in Paintbrush, 358 
Ellipsis, following a menu command, 18 
Embedding objects 

See also Object linking and embedding 
described, 489-491 
documents, packaging 

entire documents, 505-509 
partial documents, 510 

drawings, 491-492 
file icons, dragging in File Manager, 127 
sound files, 496 

EMM386 memory manager 
command line, 552 
installing, 551 
memory options, 553-555 

EMS Memory Locked option, PIF Editor, 271 
EMS Memory option, PIF Editor, 266 
Emulate Text Mode option, PIF Editor, 273 
Enlarge Font command, Write, 311 
Entering text 

basic techniques, 67 
in Calendar, 422 
in Cardfile, 435 
in Notepad documents, 456 
in Paintbrush drawings, 339 
in Write documents, 292 

Entertainment Pack, screen savers, 152 
Environment variable, specifying in a PIF 

Optional Parameters option, 263, 280 
Program Filename option, 262, 279 
Start-up Directory option, 263, 280 
Window Title option, 262, 279 

EPT port, selecting, 207 
Eraser tool in Paintbrush, 332, 349 
Error messages. See Messages 



Escape sequences 
VT-100 terminals, 578-581 
VT -52 terminals, 576-577 

Exclusive in Foreground option, Control Panel, 533 
Exclusive option 

PIF Editor, 268 
Settings command, 241, 245 

.EXE filename extension, 118 
Execution option, PIF Editor, 268 
Exit command 

File Manager, quitting, 138 
Media Player, quitting, 454 
MS-DOS Prompt, exiting, 54 
Print Manager 

canceling printing, 220 
quitting, 232 

Terminal, quitting, 408 
windows, closing, 31 

Exit Windows command, 88-89 
Expand All command, File Manager, 102 
Expand Branch command, File Manager, 102 
Expand One Level command, File Manager, 

101-102 
Expanded memory 

described, 517 
locking for a non-Windows application, 271 
PIF options for allocating, 266 
simulating, 550-555 

Expanding a directory, 101 
Extended memory 

described, 517 
HIMEM memory manager 

command lines, 543-547 
installing, 543 

locking for a non-Windows application, 271 
PIF options for allocating 

386 enhanced mode, 267 
standard mode, 282 

Extending a selection 
in dialog boxes, 35 
in directory windows, 95-97 

Extension. See Filename extensions 

F 
Fast application switching, 152 
Fast paste option, non-Windows applications, 274 
File 

associating with applications, 130-132 
closing, 22 

File (continued) 
copying 

onto the Clipboard, 124 
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to another directory or disk drive, 123-124 
deleting, 125 
displaying information about, 107 
icons for, in directory windows, 118 
linking. See Object linking and embedding 
moving, 121-122 
naming conventions, 118 
opening 

document files, 64 
when starting an application, 134 

packaging, 505-509 
printing. See Printing 
renaming, 127 
saving, 65 
searching for, 120 
selecting 

in directory windows, 94-97 
in list boxes, 40 

sorting in directory windows, 109 
starting applications from, 134 
transferring. See File transfer 

File attributes 
described, 128 
setting, 129 

File Attributes option, File Manager, 108 
File Delete option, File Manager, 126 
File formats 

Paintbrush files, 373 
Write files, 325 

File icons, described, 93 
File Manager 

See also Directories; Directory windows; Files 
associating files with an application, 130-132 
Clipboard, copying files to, 124 
confirmation messages, turning off, 126 
described, 91-94 
directories and files 

changing directories, 100-101 
copying, 123-124 
creating a directory, 119 
deleting, 125 
expanding or collapsing directories, 101-103 
moving, 121-122 
naming, 118 
renaming, 127 
searching for, 120 
selecting, 94-98 
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File Manager (continued) 
directory windows 

arranging, 112 
closing, 107 
display options, 107-109 
icons in, 118 
opening, 104-105 
selecting, 106 
updating, 111 

disk drives, changing, 99-100 
disk space, checking amount of, 519 
file attributes, setting, 128-129 
floppy disks 

copying, 136 
copying system files to, 136 
formatting, 135 
labeling, 137 

font, changing, 113 
icons, dragging to perform tasks, 58-59 
keys for working with, 588-589 
linking or embedding files, 127 
network drives 

connecting to, 115-117 
disconnecting from, 117 

non-Windows applications, setting up, 236 
packaging documents, 508-509 
printing, 133 
quitting, 138 
saving or canceling settings, 114 
split bar, moving, 111 
starting, 91 
starting applications 

by opening a document or program file, 133 
by using application parameters, 263, 280 
non-Windows applications, 240 
when opening a data file, 134 

starting when Windows starts, 91 
status bar, displaying, 114 
view, changing, 99 

File Replace option, File Manager, 126 
File transfer, Terminal 

binary vs. text transfer, described, 394 
communications settings for, 381-382 
printing text 

incoming text, 406 
selected text, 407 

receiving files 
binary files, 403 
text files, 399 

sending Clipboard contents, 405 

File transfer, Terminal (continued) 
sending files 

binary files, 402 
text files, 398 

sending selected text, 405 
setting up 

binary transfer, 397 
text transfer, 395 

Filename extensions 
associating with applications, 130-132 
.BAT (batch file), 118 
.BMP (bitmap file), 373 
.CAL (Calendar file), 430 
.CHK (Chkdsk command file), 526 
.CLP (Clipboard file), 62 
.COM (program file), 118 
.CRD (Cardfile file), 444 
.EXE (program file), 118 
.GRP (group file), 77 
.MSP (Microsoft Paint file), 373 
.PAL (Paintbrush color file), 372 
.PCX (Paintbrush file), 373 
.PIF (program information file), 259 
.REC (Recorder file), 468 
.TRM (Terminal file), 381 
.TXT (Notepad file), 458 
.WAV (sound file), 184 
.WRI (Write file), 325 

Filenames, conventions for, 118 
Files command, CONFIG.SYS file, 522 
Find command 

Cardfile, 438 
Notepad, 457 
Write, 296 

Find Next option, Write, 298 
Finding information in Help 

by using Help Contents, 45--46 
by using Search, 45 

Finding text 
in Cardfile cards, 438 
in Notepad documents, 457 
in Write documents, 295-298 

Flash If Inactive option, Print Manager, 222 
Flip Horizontal command, Paintbrush, 368 
Flip Vertical command, Paintbrush, 368 
Floppy disk 

copying, 136 
copying system files onto, 136 
formatting, 135 
labeling, 137 



Flow Control options 
Control Panel, 161 
Terminal, 383 

Font 
cartridge and soft fonts 

described, 164 
installing, 210 

changing or selecting 
in Clock, 451 
in directory windows, 113 
in Paintbrush drawings, 340 
in Write documents, 310-311 

Character Map 
inserting characters, 448 
selecting a font, 448 

printer fonts, 164 
removing, 168 
screen fonts, 165 
size, non-Windows applications, 246 
TrueType fonts 

adding, 165 
setting options, 168 
using exclusively, 167 
using, described, 165 

Windows fonts, 164 
Font command, File Manager, 113 
Font Installer, 210-211 
Fonts command 

Control menu, 23 
non-Windows applications, 246 
Paintbrush, 340-341 
Write, 309, 311 

Fonts option, Print Manager, 209 
Footer 

Calendar appointments, 433 
Paintbrush drawings, 377 
Write documents 

adding, 318 
page numbers in, 320 

Foreground option, Settings command, 245 
Foreground Priority option, PIF Editor, 270 
Format Disk command, File Manager, 135 
Format of pasted objects, 504 
Formatting a Write document 

formatting characters 
character styles, 308 
fonts, 310-311 
subscripts and superscripts, 310 
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Formatting a Write document (continued) 
formatting paragraphs 

alignment, 314 
indentation, 315-316 
line spacing, 314 
paragraph marks, 313 

headers and footers, 318-320 
page layout, 323 
tabs, 321-322 

Formatting disks, 135 
Full-duplex system, 387 
Full Screen option 

PIF Editor, 268 
Settings command, 244 
switching between a window and full screen, 242 

Function keys 
Recorder, assigning to macros, 462 
Terminal 

assigning commands to, 390 
control codes for, 391 
hiding or showing, 392 
terminal emulation, 386 

Function Keys command, Terminal, 390 

G 
Games group, described, 73 
Games, adding or removing, 564 
Get Colors command, Paintbrush, 372 
Glossary terms, in Help, 47 
Go To command, Cardfile, 437 
Go To Page command, Write, 294 
Graphics mode 

monitoring video operations, 273 
specifying for non-Windows applications, 264, 281 

Graphics, creating or editing. See Drawing 
GraphicslMultiple Text mode, 281 
Group 

See also Program item 
creating, 77 
deleting, 77 
described,73 
group icons, described, 72 
.GRP filename extension, 77 
label, changing, 78 
opening, 74 
predefined, described, 73 
read-only, 78 
starting applications from, 86 
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Group icons 
adding a program item to a group, 82 
arranging, 76 
described, 72 

Group windows 
arranging, 74-75 
described,72 
opening, 74 
reducing to icons, 74 

.GRP filename extension, 77 

H 
Half-duplex systems, 387 
Handshaking 

specifying in Control Panel, 161 
specifying in Terminal, 383 

Hanging indent, in Write documents, 316 
Hangup command, Terminal, 408 
Hardware Compatibility List, 204 
Header 

Calendar appointments, 433 
Paintbrush drawings, 377 
Write documents 

adding, 318 
page numbers in, 320 

Height option, Paintbrush, 332 
Help on Microsoft products, xxiv-xxvi 
Help, online 

dialog boxes, Help for, 46 
finding information 

by using Help Contents, 45-46 
by using Search, 45 

glossary definitions, displaying, 47 
Help buttons, described, 46-47 
Help menu, using, 44-45 
keys for working with, 592 
starting, 43 

Hexadecimal number system, Calculator, 415 
Hidden file 

displaying in File Manager, 110 
icon for, in directory windows, 118 

Hidden file attribute, 128 
"Hidden" window. See Inactive window 
Hide Function Keys command, Terminal, 392 
High memory area (HMA) 

controlling by using HIMEM, 546 
PIF option for non-Windows applications, 271 

High Priority command, Print Manager, 221 

High-resolution graphics mode 
monitoring video operations, 273 
specifying for non-Windows applications, 264 

HIMEM extended-memory manager 
command lines, 543-547 
installing, 543 

HMA. See High memory area 
Hyphen, for optional line breaks in Write, 299 

IBM to ANSI option, Terminal, 388 
Icons 

application icons 
described, 12 
illustrated, 6 
in directory windows, 118 
in group windows, 72 
running applications as icons, 86 

arranging 
Arrange Icons command, 76, 113 
Auto Arrange command, 76 
individually, 76 
Task List, Arrange Icons button, 58 

directory icons, 118 
directory-window icons, described, 93-94 
dragging to perform tasks, 58-59 
file icons, 118 
flashing, 63 
group icons, 72 
label for, changing 

by using PIF Editor, 262, 279 
by using Program Manager, 79 

MORICONS.DLL file, 85 
moving, 29 
package icons 

changing, 512 
creating, 513 

PROGMAN .EXE file, 85 
program-item icons, 72 
reducing windows to, 25-26 
restoring to windows, 28 
selecting, 85 
spacing between, changing, 156 

Idle option, Control Panel, 247 
Idle Time option, PIF Editor, 271 
IdleWild screen savers, 152 
Ignore If Inactive option, Print Manager, 222 
Image Attributes command, Paintbrush, 331-332 
Import command, Object Packager, 506 



Inacti ve window 
for non-Windows applications 

PIF option for, 268, 284 
returning to, 64 

rearranging to make visible, 74-75 
selecting to make active, 106 

Increase Speed command, Sound Recorder, 480 
Increase Volume command, Sound Recorder, 480 
Indenting paragraphs in Write 

by creating a hanging indent, 316 
by using the Indents command, 315 
by using the Ruler, 316 
vs. changing the margins, 315 

Indents command, Write, 315-316 
Index command, Cardfile, 436, 439 
Indicate Expandable Branches command, 

File Manager, 103 
Insert File command, Sound Recorder, 479, 496 
Insert Object command, Cardfile or Write 

embedding drawings, 491 
embedding sound files, 496 

Inserting files. See Object linking and embedding 
Inserting characters into documents, 448 
Insertion point 

illustrated, 8 
in text boxes, 34 

Installing 
device drivers 

by using Control Panel, 179-181 
by using Setup, 557-560 
drivers not supplied with Windows, 559-560 

fonts, 165-167 
printers, 159 

Interactive Voice Support Service, xxiv 
International settings 

basic settings, 169 
currency format, 173 
date format, 171 
number format, 174 
time format, 172 

Interrupt request line (IRQ), specifying, 161 
Inverse command, Paintbrush, 368 
Italic 

J 

as a document convention, xxiii 
in Paintbrush drawings, 341 
in Write documents, 308 

Justifying text, in Write, 314 
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K 
Kermit option, Terminal, 397 
Key combinations, document convention for, xxiii 
Key map, MIDI 

creating, 189-191 
deleting, 197 
editing, 197 

Key sequences, document convention for, xxiii 
Keyboard 

application mode, keystrokes 
VT-52 terminals, 576 
VT -100 terminals, 577 

delay, adjusting, 178 
driver 

installing by using Control Panel, 179 
installing by using Setup, 557 
updating, 567 

layout, setting in Control Panel, 170 
recording keystrokes, 461, 466 
repeat rate, adjusting, 178 

Keyboard Layout option, Control Panel, 170 
Keyboard option, PIF Editor, 283 
Keys 

Calculator keys, 413-420 
Calendar keys, 590 
Cardfile keys, 591 
Clipboard Viewer keys, 591 
Control Panel keys, 592 
cursor movement keys, 586 
dialog box keys, 585 
editing keys, 586 
File Manager keys, 588-589 
Help keys, 592 
IBM PC equivalent keystrokes 

VT -100 terminals, 577 
VT -52 terminals, 575 

Media Player keys, 593 
menu keys, 584 
Notepad keys, 586-587 
Object Packager keys, 594 
Paintbrush keys, 594 
PIF Editor keys, 595 
Program Manager keys, 587 
scrolling keys, 30 
Sound Recorder keys, 596 
system keys, 583 
text selection keys, 587 
Write keys, 596 
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l 
Label command, Object Packager, 514 
Label Disk command, File Manager, 137 
Labeling disks, 137 
Language option, Control Panel, 170 
Laser printer with PostScript cartridge, 203 
Last Modification Date option, File Manager, 108 
Last Modification Time option, File Manager, 108 
Line At A Time option, Terminal, 396 
Line break, optional, in Write, 299 
Line spacing, in Write documents, 314 
Line tool in Paintbrush, 355 
Line Wrap option, Terminal, 387 
Lines, in Paintbrush drawings 

connecting into polygons, 359 
curves, 353 
freehand lines, 351 
positioning, 369 
straight lines, 355 
vertical, horizontal or diagonal, 355 

Linesize box, in Paintbrush 
described, 331 
removing from view, 333 
selecting a drawing width, 337 

Linking objects 
See aLso Object linking and embedding 
described,489-491 
documents, packaging 

entire documents, 509 
partial documents, 510 

drawings, 494 
file icons, dragging in File Manager, 127 

Links command 
breaking links, 502 
fixing broken links, 503 
updating linked objects, 500 

List box, in dialog boxes 
drop-down list box, 37 
illustrated, 35 
selecting items from, 36-37 

List command, Cardfile, 437 
List Separator option, Control Panel, 171 
Local Echo option, Terminal, 387 
Local print queue, 216-218 
Lock Application Memory option, PIF Editor, 272 
Log file, creating in Notepad, 458 
Logitech mouse, 243 
Low Priority command, Print Manager, 221 

Low-resolution graphics mode 
monitoring video operations, 273 
specifying for non-Windows applications, 264 

LPT port, selecting, 207 

M 
Macro 

continuous playback, 472-473 
defined, 459 
deleting from Recorder files, 470 
demonstration macros, 472 
guidelines for creating, 474 
mouse actions, specifying, 466 
naming, 463 
nesting, 467 
options 

for playing back, 467 
for recording, described, 465-468 

playing back, 463 
preferences for recording, 471 
properties, changing, 468 
recording, 460 
saving in Recorder files, 468 
screen vs. window for recording, 467 
shortcut keys 

assigning, 462 
detection of, disabling, 473 

speed of playback, choosing, 472 
stopping, 464 

Magnifying a Paintbrush drawing, 370 
Main group, described, 73 
Make System Disk command, File Manager, 136 
Margins 

Calendar appointments, 432 
Paintbrush drawings, 376 
Write documents, 318 

Mark command 
Calendar, 430 
Control menu, described, 23 
non-Windows applications, 249 

Maximize button 
enlarging windows to maximum size, 27 
illustrated, 8 

Maximize command, on Control menus 
described, 22 
enlarging windows to maximum size, 27 

MCI. See Media Control Interface 
Measurement option, Control Panel, 170 
Media Control Interface (MCI), 452 



Media Player 
described, 451 
devices, specifying, 452 
keys for working with, 593 
media files, playing, 453 
quitting, 454 
scales, 454 
starting, 452 

Medium Priority command, Print Manager, 221 
Mem command, memory information, 516 
Memory 

See also Memory manager; Optimizing Windows 
configuring 

80286 computer, 522 
80386 or 80486 computer, 521 

conventional. See Conventional memory 
described,516-518 
displaying information about, 516 
expanded. See Expanded memory 
extended. See Extended memory 
freeing 

by simulating expanded memory, 550-555 
by streamlining the AUTOEXEC.BAT file, 

530-531 
by streamlining the CONFIG.SYS file, 529-530 
by using application swap files, 536-537 
by using Windows swap files, 533-534 
when starting memory-resident programs, 531 

non-Windows applications 
management, described, 252 
out-of-memory message, 253 

Paintbrush drawings, large, 332 
PIF options for allocating memory 

386 enhanced mode, 265-267 
standard mode, 281-282 

PIF options for conserving memory, 283-284 
requirements 

80286 computer, 522 
80386 or 80486 computer, 521 

troubleshooting. See Getting Started with 
Microsoft Windows 

video memory, 264, 281 
Memory-disk program 

non-Windows programs, 550 
RAMDrive program, 547-550 

Memory manager 
EMM386 

command line, 552 
installing, 551 
memory options, 553-555 

expanded-memory manager, described, 517 
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Memory manager (continued) 
extended-memory manager, described, 517 
HIMEM 

command lines, 543-547 
installing, 543 

RAMDrive 
command line, 548-550 
setting up, 548 

Memory option, Print Manager, 209 
Memory options, PIF Editor, 271-272 
Memory Requirements option, PIF Editor 

386 enhanced mode, 265 
standard mode, 281 

Memory-resident program 
See also Non-windows applications 
defined,51 
loading 

by creating a batch file, 256 
by using WINSTART.BAT, 531 

pop-up programs, running, 255 
starting, 254 

Menu 
cascading menu, defined, 18 
check marks, meaning of, 18 
closing, 17 
Control menu 

commands,described,22 
Control-menu box (illustrated), 8 
opening, 19-21 

dimmed items, meaning of, 18 
ellipses, meaning of, 18 
illustrated, 16 
keys for working with, 584 
menu bar (illustrated), 8 
menu items, choosing, 17 
selecting (opening), 16 
shortcut-key combinations, 18 
triangles, meaning of, 18 

Menu bar (illustrated), 8 
Merge command 

Cardfile, 445 
Recorder, 470 

Merging files 
See also Object linking and embedding 
Cardfile files, 445 
Recorder files, 470 

Messages 
out of memory, 253 
Print Manager messages, displaying, 221 
received from inactive applications, 63 
when starting incompatible applications, 50 
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Microsoft Customer Support Services 
See also Product Support Services 
obtaining device drivers, 559 

Microsoft Paint file, converting to Paintbrush, 373 
Microsoft Product Support Services, xxiv 
Microsoft Word file, opening in Write, 324 
MIDI driver 

installing 
by using Control Panel, 179 
by using Setup, 557 

updating, 185 
MIDI Mapper 

channel maps, creating, 194-196 
deleting maps and setups, 197 
editing maps and setups, 197 
key maps, creating, 189-191 
MIDI setups 

creating, 188-197 
selecting, 186 

patch maps, creating, 191-193 
Minesweeper. See online Help in Minesweeper 
Minimize button 

illustrated,8 
reducing windows to icons, 26 

Minimize command, on Control menus 
described, 22 
reducing windows to icons, 26, 74 

Minimize On Use command 
File Manager, 134 
Program Manager, 86 
Recorder, 464 

Minimizing applications, running minimized, 54, 80 
Minimum Timeslice option, Control Panel, 532 
Mix With File command, Sound Recorder, 479 
Mixing sound files, 479 
Mode 

386 enhanced. See 386 enhanced mode 
graphics, 264, 281 
standard. See Standard mode 
text, 264, 281 

Modem 
command settings, 383 
hanging up, 408 
phone numbers, entering in Terminal, 384 

Monitor Ports option, PIF Editor, 272 
Month command, Calendar, 422 
MORICONS.DLL file, selecting icons from, 85 
Mouse 

basic techniques for using, 15 
customizing, 175 
double-click speed, adjusting, 176 

Mouse (continued) 
driver 

installing by using Control Panel, 179 
installing by using Setup, 557 
updating, 567 

left and right buttons 
functions in Paintbrush, 329 
swapping, 176 

non-Windows applications, using with, 243 
pointer, illustrated, 8 
recording mouse actions, 461, 466 
tracking speed, adjusting, 176 
trails on the screen, 176 
troubleshooting. See Getting Started with 

Microsoft Windows 
Mouse Action option, in File Manager, 126 
Move command 

Control menu 
described, 22 
moving dialog boxes, 32 
moving icons, 29 
moving windows, 24 

File Manager, 122 
Program Manager, 85 

Move Picture command, Write, 303 
Moving 

cutouts in drawings, 363 
dialog boxes, 32 
files, 121-122 
icons, 29 
pictures in Write documents, 303 
program items, 84 
split bar in a directory window, 111 
windows, 23 

MS-DOS 
application. See Non-Windows applications 
naming conventions for files, 118 
Setup program, running from, 567 

MS-DOS Prompt 
quitting, 257 
restriction with MS-DOS commands, 55 
running in a window, 257 
starting, 257 
starting applications, 54 

.MSP filename extension, 373 
Multimedia 

See also Media Player; Sound 
device drivers, installing, 179 
files, playing, 451 

Multiple Text mode, 281 



Multitasking options 
386 enhanced mode, 532 
PIF Editor, 270-271 

Music. See Sound 

N 
Name command, File Manager, 107 
Naming conventions for files and directories, 118 
Network 

See also Network drives 
configuring Windows for networks, 557 
Control Panel network options, 163 
device drivers 

installing by using Control Panel, 179 
installing by using the Setup program, 557 
updating, 567 

features, listed, 573 
guidelines for using, 574 
port for printing, 574 
printing 

connecting to printers, 226-227 
described, 225 
disconnecting from printers, 232 
network queues, viewing, 228-229 
Print Manager, bypassing, 231 
Print Manager, using, 231 
reconnecting to printers, 227 

setup. See Getting Started with Microsoft Windows 
troubleshooting. See Getting Started with 

Microsoft Windows 
Network Connections command 

File Manager, 116-117 
Print Manager, 226-227, 232 

Network drives 
and 386 enhanced mode, 117 
browsing through a list of, 116 
connecting to, 115 
disconnecting from, 117 
displayed in directory windows, 93 
drive letter for connections, 574 
selecting a previous connection, 117 

Network print queue, 216 
Network Settings command, Print Manager, 

230-231 
NETWORKS.WRI file, xx, 574 
Never Warn option, Control Panel, 247 
New command, on File menus 

groups, creating, 77 
non-Windows applications, setting up, 235 
program items, creating, 79 
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New command, on File menus (continued) 
sound files, recording, 477 

New Program Object dialog box 
creating a group, 77 
creating a program item, 79 

New Window command, File Manager, 105 
Next command 

Calendar, 423--424 
Control menu, 23 

No Save Screen option, PIF Editor, 284 
No Screen Exchange option, PIF Editor, 283 
No Title command, Clock, 450 
N on-Windows applications 

See also PIF Editor 
background, running in, 242 
Clipboard, transferring information, 248-251 
Control menu, opening 

386 enhanced mode, 21-22 
standard mode, 21 

defined,50 
device contention options, 247 
directory for starting, 251-252 
font size, changing, 246 
memory management 

described,252 
out-of-memory message, 253 

memory-resident programs 
batch program for loading, 256 
pop-up programs, 255 
starting, 254 

mouse, using with, 243 
PIFs for 

creating, 236-237 
default, 238 
manufacturer-supplied,238 
multiple versions, 239 

printing from, 215 
quitting, 64 
resource usage, exclusive, 241 
setting up 

by using File Manager, 236 
by using Program Manager, 235 
by using Setup, 234 

Settings command options, 243-246 
starting 

by using File Manager" 240 
by using MS-DOS Prompt, 257 
by using Program Manager, 240 
in a window, 242 

swap files, 536-537 
windowed vs. full screen, 242 
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Notepad 
keys for working with, 586-587 
moving through documents, 456 
printing documents, 459 
searching for text, 457 
selecting text, 456 
starting, 455 
time and date, adding, 459 
time-log file, creating, 458 
.TXT filename extension, 458 
word wrap, 456 

Null modem cable, 379 
Number format, 174 

o 
Object linking and embedding 

described, 487-491 
drawings 

editing embedded drawings, 493 
editing linked drawings, 495 
embedding, 492 
linking, 494 

file icons, dragging in File Manager, 127 
format of objects, changing, 504 
links, maintaining 

automatic updating, 500 
breaking links, 502 
copying links, 501 
deleting links, 502 
fixing broken links, 503 
manual updating, 500 

packaging objects 
described, 505 
documents, entire, 505-509 
documents, partial, 510 
MS-DOS command-line commands, 511 
package icons, changing, 512-513 
package labels, changing, 514 

pictures. See drawings 
sound files 

editing embedded files, 497 
editing linked files, 499 
embedding, 496 
linking, 498 

troubleshooting. See Getting Started with 
Microsoft Windows 

Object Packager 
described, 505 

Object Packager (continued) 
icons for packages 

changing, 512 
creating, 513 

keys for working with, 594 
labels for packages, changing, 514 
packaging 

entire documents, 505-506 
MS-DOS command-line commands, 511 
partial documents, 510 

Object, defined, 489 
Octal number system, Calculator, 415 
Omit Picture Format command, Paintbrush, 362 
Online Help 

dialog boxes, Help for, 46 
finding information 

by using Help Contents, 45-46 
by using Search, 45 

glossary definitions, displaying, 47 
Help buttons, described, 46-47 
Help menu, using, 44-45 
keys for working with, 592 
starting, 43 

Open command, on File menus, 64 
Opening 

See also Starting 
directories, from dialog boxes, 41 
directory windows, 104-105 
document files, 64 
files when starting applications, 134 
group windows, 74 
media files, 453 
menus, 16 
program information files, 237 

Optimizing Windows 
described, 515 
disk caching, described, 537 
disk space, freeing 

removing unnecessary files, 524-525 
running the Chkdsk command, 526 

double buffering, 541 
EMM386 memory manager 

command line, 552 
installing, 551 
memory options, 553-555 

expanded memory, simulating, 550-555 
HIMEM extended-memory manager 

command lines, 543-547 
installing, 543 



Optimizing Windows (continued) 
memory, configuring 

80286 system, 522 
80386 or 80486 system, 521 
identifying the configuration, 516 

memory, freeing 
application swap files, using, 536-537 
AUTOEXEC.BAT file, streamlining, 530-531 
CONFIG.SYS file, streamlining, 529-530 
memory-resident programs, starting, 531 
Windows swap files, using, 533-534 

multitasking options, 532 
RAMDrive memory-disk program 

command line, 548-550 
setting up, 548 

speed, increasing 
compacting your hard disk, 527 
setting multitasking options, 532 
setting TEMP to a RAM drive, 542 
using RAMDrive, 547-550 
using SMARTDrive, 537-540 

swap files 
application swap files, 536-537 
described,520 
using Windows swap files, 533-534 
Windows swap files, 535-536 

TEMP environment variable, 541 
troubleshooting. See Getting Started with 

Microsoft Windows 
Option buttons, in dialog boxes, 38 
Optional hyphen, in Write documents, 299 
Optional Parameters option, PIF Editor 

386 enhanced mode, 262-263 
standard mode, 279 

Orientation option, Print Manager, 209 
Other Files option, File Manager, 110 
Other Net Queue command, Print Manager, 229 
Out-of-memory message, 253 
Outlining text in Paintbrush drawings, 341 
Overlapping windows, rearranging 

p 

directory windows, 112 
group windows, 74-75 

Package 
See also Object Packager 
creating, 508 
defined, 505 

Package Object command, 507 

Page breaks in Write documents 
automatic, 305 
confirming or changing, 306 
manual,306 
searching for, 296 

Page Layout command, Write, 323 
Page numbers in Write documents 

using in headers or footers, 320 
viewing when breaking pages, 305 

Page Setup command 
Calendar, 432 
Paintbrush, 376-377 

Paint file, converting to Paintbrush, 373 
Paint Roller tool in Paintbrush, 350 
Paintbrush 

See also Drawing 
basic drawing techniques, 335-338 
converting Microsoft Paint files, 373 
custom colors, 371 
editing drawings 

cutouts. See Cutouts 
eraser tools, using, 347-349 
positioning lines and text, 369 
text editing, 342 
Undo or BACKSPACE, using, 338 
Zoom In command, using, 370 

file formats, 373 
filename extensions 

.BMP, 373 

.PAL,372 

.PCX, 373 
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keyboard equivalents of mouse actions, 329 
keys for working with, 594 
linking or embedding drawings, 361 
Paintbrush window, working with, 330-334 
printing drawings, 374-378 
starting, 330 
starting a new drawing, 332 
text, including in a drawing, 339-341 
Toolbox 

Airbrush, 346 
Box, 356 
Brush,351 
CirclelEllipse, 358 
Color Eraser, 347 
Curve, 353 
Eraser, 349 
Line, 355 
Paint Roller, 350 
Pick,344-345 
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Paintbrush (continued) 
Toolbox (continued) 

Polygon, 359 
Rounded Box, 357 
Scissors, 344 
Text, 347 

.P AL filename extension, 372 
Palette command, Paintbrush, 333 
Palette, in Paintbrush 

described,331 
removing from view, 333 
selecting colors from, 335-336 

Paper Size option, Print Manager, 209 
Paper Source option, Print Manager, 209 
Paragraph format 

alignment, 314 
described,312 
hanging indents, 316 
indentation, 315-316 
line spacing, 314 

Paragraph marks 
adding, 313 
removing, 314 
searching for, 296 

Parallel port, selecting, 207 
Parameters for applications, specifying, 263, 279 
Parity Check option, Terminal, 383 
Parity option 

Control Panel, 161 
Terminal, 383 

Partial Details command, File Manager, 108 
Partial drawing option, Paintbrush, 375 
Password for screen savers, 154 
Paste command 

Cardfile, 440 
Character Map, 449 
non-Windows applications, 251 
Paintbrush, 361 
Terminal, 405 
Windows applications, 61 
Write, 299 

Paste From command, embedding drawings, 492 
Paste Link command 

linking drawings, 494 
linking sound files, 498 
packaging documents, 509 

Paste Special command, changing formats, 504 

Pasting 
See also Object linking and embedding 
applications, pasting into 

non-Windows applications, 250 
Windows applications, 61 

characters, 448 
cutouts 

described, 361 
linking or embedding, 361 
pasting from a file, 366 
transparent or opaque pasting, 365 

fast pasting in non-Windows applications, 274 
numbers in Calculator, 412, 415 
text to a remote system, 405 

Patch map, MIDI 
creating, 191-193 
deleting, 197 
editing, 197 

Patterns for the desktop 
changing, 149 
creating, 150 
displaying, 148 
removing, 150 

Pausing 
file transmission, 399-400 
printing, 218 

.PCX filename extension, 373 
Pels 

changing the size of the drawing area, 331 
editing one at a time, 370 

Phone number 
dialing 

in Cardfile, 446 
in Terminal, 393 

entering in Terminal, 384-385 
for customer support, 559 
for product support, xxiv, xxvi 

Phone Number command, Terminal, 384-385 
Pick tool in Paintbrush, 344 
Picture 

See also Drawing 
embedding, 491-492 
linking, 494 

Picture command 
drawings 

editing embedded drawings, 493 
editing linked drawings, 495 



Picture command (continued) 
drawings (continued) 

embedding, 491-492 
linking, 494 

format of objects, changing, 504 
links 

breaking, 502 
copying, 50 I 
deleting, 502 
fixing broken links, 503 
updating, 500 

sound files 
embedding, 496 
linking, 498 

PIF. See Program information file 
PIF Editor 

386-enhanced-mode options, described 
advanced options, 269 
basic options, 261 

Allow Close When Active option, 275 
Allow Fast Paste option, 274 
Application Shortcut Key option, 276-278 
Background Priority option, 270 
Close Window On Exit option, 268, 284 
Detect Idle Time option, 271 
Directly Modifies option, 283 
Display Usage option, 268 
EMS Memory Locked option, 271 
EMS Memory option, 266 
Emulate Text Mode option, 273 
Execution option, 268 
Foreground Priority option, 270 
keys for working with, 595 
Lock Application Memory option, 272 
Memory Requirements option, 265, 281 
Monitor Ports option, 272 
No Save Screen option, 284 
No Screen Exchange option, 283 
Optional Parameters option, 262, 279 
PIF modes, changing, 260 
PIFs, creating, 236-237 
Prevent Program Switch option, 284 
Program Filename option, 262, 279 
Reserve Shortcut Keys option, 275, 285 
Retain Video Memory option, 273 
standard mode options, described, 278 
Start-up Directory option, 263, 280 
starting, 260 
Uses High Memory Area option, 271 
Video Memory options, 264 
Video Mode option, 280 

PIF Editor (continued) 
Window Title option, 262, 279 
XMS Memory Locked option, 271 
XMS Memory option, 267, 282 

.PIF filename extension, 259 
Pixel 
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changing the size of the drawing area, 331 
editing one at a time, 370 

Plasma Power Saver color scheme, 142 
Play command, Cardfile or Write, 497 
Playing 

macros, 463 
media files, 453 
sound files, 475 

Plotter fonts, 164 
Point size, changing or selecting 

in File Manager windows, 113 
in Paintbrush drawings, 341 
in Write documents, 311 

Pointer 
illustrated, 8 
speed, adjusting, 175 

Pointing devices, customizing, 175 
Pointing with the mouse, described, 15 
Polygon tools in Paintbrush, 359 
Pop-up program 

batch program for loading, 256 
defined, 51 
running with Windows, 255 

Port 
application port, selecting in a PIF, 283 
configuring 

advanced options, 161-162 
described, 159 
standard communications settings, 160 

MIDI output port, specifying, 196 
network printing, 574 
printer port, selecting, 206 

PostScript printer 
laser printer with PostScript cartridge, 203 
transmission retry, 213 

Preferences command, Recorder, 471 
Prevent Program Switch option, PIF Editor, 284 
Previous command, Calendar, 423-424 
Previous Network Connections dialog box, 117 
Print All command, Cardfile, 445 
Print command 

Calendar, 432 
Cardfile, 445 
File Manager, 133 
Notepad, 459 
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Print command (continued) 
Paintbrush, 374-375 
Write, 326 

Print File Size command, Print Manager, 222 
Print Manager 

See also Printing 
default printer, selecting, 213 
display options, 222 
File Manager, using with, 133 
FILE option, printing to a file, 223-224 
fonts, installing, 210 
messages, displaying, 221 
MS-DOS interrupts, printing with, 224-225 
network printing 

bypassing Print Manager, 231 
connecting to printers, 226-227 
described, 225 
disconnecting from printers, 232 
network queues, viewing, 228-229 
network status, 230 
printing through Print Manager, 231 
reconnecting to printers, 227 

non-Windows applications, printing from, 215 
ports, selecting, 206 
print queue 

changing the order of, 218 
deleting files from, 219 
interrupting printing, 218 
viewing, 216-218 

printer drivers, installing 
drivers from manufacturers, 205 
drivers supplied with Windows, 201-203 
unlisted printers, 204 

printing options, setting, 207 
quitting, 232 
removing printers, 214 
speed of printing, changing, 220 
starting, 199 
Timeouts options, selecting, 212 

Print queue 
deleting files from, 219 
display options, 222 
network queues, viewing, 228-229 
order of files, changing, 218 
viewing, 216-218 

PRINT SCREEN key, copying screen contents 
non-Windows applications, 249-250 
Windows applications, 60 

Print Setup command 
Calendar, 432 
Cardfile, 446 

Print Setup command (continued) 
Notepad,459 
Paintbrush, 378 
Write, 328 

Printer 
connecting to network printers, 226-227 
default printer, selecting, 213 
disconnecting from network printers, 232 
drivers, installing, 201-205 
fonts, 164 
installing printers 

Control Panel installation, 159 
Print Manager installation, 200-214 

port, selecting, 206 
removing, 214 
settings, changing, 207 

Printer Echo command, Terminal, 406 
Printer Setup command, Print Manager 

default printer, selecting, 213 
FILE option, printing to a file, 223-224 
fonts, installing, 210 
ports, selecting, 206 
printer drivers, installing, 201-205 
printing options, setting, 207 
removing printers, 214 
Timeouts options, selecting, 212 

PRINTERS.WRI file, xx 
Printing 

See also Print Manager 
Calendar appointments, 432 
Cardfile cards or files, 445 
dragging file icons to print files, 58 
FILE option, printing to a file, 223-224 
files in File Manager, 133 
MS-DOS interrupts, using, 224-225 
network printing 

bypassing Print Manager, 231 
connecting to printers, 226-227 
described, 225 
disconnecting from printers, 232 
network queues, viewing, 228-229 
printing through Print Manager, 231 
reconnecting to printers, 227 

non-Windows application documents, 215 
Notepad documents, 459 
options, setting, 207 
Paintbrush drawings, 374-378 
pausing and resuming, 218 
speed,changing, 220 
Terminal text, 406-407 



Printing (continued) 
troubleshooting. See Getting Started with 

Microsoft Windows 
Write documents, 326-328 

Priority options 
PIF Editor, 270 
Settings command, 245 

Product Support Services, xxiv-xxvi 
PROGMAN.EXE file, selecting icons from, 85 
Program 

See also Applications; Non-Windows applications; 
Program items 

memory-resident program, defined, 51 
pop-up program, defined, 51 

Program Filename option, PIF Editor 
386 enhanced mode, 262 
standard mode, 279 

Program Group Properties dialog box, 77 
Program information file (PIF) 

See also PIF Editor 
batch files, creating PIFs for, 256 
creating, 236-237 
default PIF, 238 
defined, 259 
DOSPRMPT .PIF file, 257 
manufacturer-supplied,238 
multiple versions per application, 239 
.PIF filename extension, 259 
specifying when running Setup, 563 

Program-item icons 
arranging, 76 
changing, 85 
described,72 

Program Item Properties dialog box, 79 
Program items 

See also Applications 
copying to another group, 83 
creating for applications 

by using File Manager, 82 
by using Program Manager, 78 
by using Setup, 82 

creating for documents 
by using File Manager, 82 
by using Program Manager, 81 

deleting, 83 
icons 

arranging, 76 
changing, 85 
described, 72 

label, changing, 79 

Program items (continued) 
maximum number per group, 79 
moving to another group, 84 
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shortcut keys for. See Shortcut-key combination 
working (start-up) directories for, 80 

Program Manager 
described,71-73 
group windows 

arranging, 74-75 
arranging icons in, 76 
opening, 74 
reducing to icons, 74 

groups 
changing the description of, 78 
creating, 77 
deleting, 77 
described,73 

keys for working with, 587 
minimizing when you start applications, 86 
non-Windows applications, setting up, 235 
program items 

changing an icon, 85 
copying, 83 
creating, 78-81 
deleting, 83 
moving, 84 

quitting, 88 
returning to from an application, 87 
shortcut-key combinations 

assigning an application shortcut key, 276 
deleting an application shortcut key, 277 
reserving for an application's use, 80 

starting applications 
by using application parameters, 263, 280 
from a group, 86 
non-Windows applications, 240 
when you start Windows, 87 

Programs option, File Manager, 110 
Proof option, Paintbrush, 375 
Properties command 

File Manager, 129 
Program Manager 

application window title, changing, 262, 279 
group description, changing, 78 
group, making read-only, 78 
Program Item Properties dialog box, 79 
program-item icons, changing, 85 
start-up directory, specifying, 263, 280 

Recorder, 469 
Protocol for binary transfers, 397 
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a 
Quick format, 135 
Quitting 

R 

applications 
by quitting Windows, 275 
non-Windows applications, 64 
Windows applications, 63 

Windows, 89 

RAM drive 
setting the TEMP variable to, 542 
setting up, 548 
using for application swap files, 536 

RAMDrive memory-disk program 
command line, 548-550 
setting up, 548 

Read-only file attribute, 128 
Read-only group, 78 
Readme file, adding or removing, 564 
README.WRI file, xx 
Rearranging. See Arranging 
.REC filename extension, 468 
Receive Binary File command Terminal 403 
Receive Text File command, Terminal, 399 
Record command, in Recorder 

continuous playback, setting, 472 
nesting of macros, disabling, 467 
options for recording, 465-468 
recording macros, 460 
shortcut keys, assigning, 462 
speed of playback, choosing, 472 

Recorder 
continuous macro playback, 472-473 
deleting macros, 470 
demonstration macros, 472 
guidelines for creating macros, 474 
merging files, 470 
mouse actions, specifying, 466 
naming macros, 463 
nesting macros, 467 
options 

for playing back macros, 467 
for recording macros, 465-468 

playing back macros, 463 
preferences, setting permanently, 471 
properties of macros, changing, 468 
.REC filename extension, 468 
screen vs. window for recording, 467 

Recorder (continued) 
shortcut keys 

assigning to macros, 462 
detection of, disabling, 473 

speed of macro playback, 472 
starting, 459 
stopping macros, 464 

Recording 
macros, 460 
sound files, 476-477 

Redial After Timing Out option, Terminal, 385 
Reduce Font command, Write, 311 
Refresh command 

File Manager, 111 
Print Manager, 230 

Registration. See online Help for Registration 
Information Editor 

Regular command 
Paintbrush, 341 
Write, 309 

Remote computer 
See also Terminal 
connecting to, 393 
disconnecting from, 408 
protocols for file transfer, 397 

Remote echo, defined, 387 
Remove command, Calendar, 431 
Removing 

alarms in Calendar, 427 
appointments in Calendar, 431 
cards in Cardfile, 443 
color schemes for the desktop, 145 
device drivers, 183 
echos in sound files, 481 
files from print queues, 219 
files or directories, 125 
fonts, 168 
links,502 
macros from Recorder files, 470 
MIDI maps and setups, 197 
patterns for the desktop, 150 
printers, 214 
sound files, 481 
Windows components, 564-567 

Rename command, File Manager, 127 
Renaming files or directories, 127 
Repaginate command, Write, 305-306 
Repeat Last Find command, Write, 298 
Replace command, Write, 297-298 



Replacing text 
basic techniques, 69 
in Write documents, 297-298 

Reserve Shortcut Keys option, PIF Editor 
386 enhanced mode, 275 
standard mode, 285 

Resolution option, Print Manager, 209 
Restore button 

illustrated, 8 
restoring windows to previous size, 28 

Restore command 
Cardfile, 443 
described, 22 
restoring an icon to a window, 28 

Restoring sound files, 482 
Retain Video Memory option, PIF Editor, 273 
Reverse command, Sound Recorder, 481 
Revert command, Sound Recorder, 481-482 
Rewinding sound files, 476 
Root directory, described, 92 
Ruler command, Write, 312-313 
Ruler, in Write 

displaying, 312 
line spacing, changing, 315 
paragraph alignment, changing, 314 
paragraph indentation, changing, 316 
tabs, setting, 322 

Run command 
application parameters, using, 263, 280 
applications, starting, 53 
files, opening when starting applications, 134 
macros, playing, 464 

Run Minimized option for applications, 54, 80 
Running. See Starting 

s 
Save As command, on File menus, 65-66 
Save Colors command, Paintbrush, 372 
Save command, on File menus, 65-66 
Save Controls option, Terminal, 400 
Save Settings On Exit command 

File Manager, 114 
Program Manager, 88 

Saving files 
Clipboard contents, 62 
document files, 65-66 

Scalable font. See True Type font 
Scales in Media Player, 454 
Scaling option, Paintbrush, 375 
Scheduling options, 386 enhanced mode, 532 

Scissors tool in Paintbrush, 344 
Screen 

copying onto the Clipboard 
non-Windows applications, 249 
Windows applications, 60 

driver 
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installing by using Control Panel, 179 
installing by using Setup, 557 
updating, 567 

protecting by using screen savers, 152 
Screen exchange option, PIF Editor, 283 
Screen fonts, 164-165 
Screen saver 

adding or removing with Setup, 564 
customizing, 154 
password, specifying, 154 
selecting, 152 
testing, 153 

Scroll bars 
displaying in the Terminal window, 388 
how to use, 30 
illustrated, 8, 30 

Scroll command, non-Windows applications, 23 
Search command, File Manager, 120 
Search feature in Help, 45 
Search Results window in File Manager, 120-121 
Searching 

for files or directories, 120 
for information in Help, 45-46 
for special characters in Write, 296 
for text 

in Cardfile cards, 438 
in Notepad documents, 457 
in Write documents, 295-298 

Seconds command, Clock, 450 
Select All command 

Notepad,456 
Terminal,405 

Select Drive command, File Manager, 100 
Select Files command, File Manager 

canceling a selection, 98 
selecting a group of files, 97 

Selected Net Queue command, Print Manager, 228 
Selecting 

check boxes, 39 
vs. choosing, defined, 15 
current directory, 100-101 
directories or files 

in directory windows, 94-97 
in list boxes, 40-41 

directory windows, 106 
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Selecting (continued) 
file types, in dialog boxes, 41 
icons, 85 
list-box items 

drop-down lists, 37 
multiple nonsequential items, 37 
multiple sequential items, 36 
single item, 36 

menu items, 17 
menus, 16 
option buttons, 38 
text 

basic techniques, 68 
in dialog boxes, 35 
in Notepad documents, 456 
in the Terminal window, 405 
in Write documents, 294 
keys for text selection, 587 

Selection cursor, defined, 32 
Send Binary File command, Terminal, 402 
Send command, Terminal, 405 
Send Text File command, Terminal, 398 
Serial communications, troubleshooting. See 

Getting Started with Microsoft Windows 
Serial port, selecting, 207 
Server application, defined, 487 
Set command, Calendar, 425 
Set Font command, Clock, 451 
Set Up Applications command, Setup, 82, 560, 563 
Settings command, non-Windows applications 

Background option, 242 
described, 23 
Display options, described, 244 
Exclusive option, 241 
Priority options, described, 245 
Tasking options, described, 245 
Terminate option, 245-246 

Settings file in Terminal 
described, 381 
saving, 407 

Setup program 
applications, setting up, 560-563 
code page, changing, 568 
device drivers 

changing settings, 558 
installing, 557 
not supplied with Windows, 559-560 
reinstalling if incorrect, 569 
updating, 567 

networks, configuring Windows for, 557 
non-Windows applications, setting up, 234 

Setup program (continued) 
PIFs for applications, specifying, 563 
program items, creating, 82 
running 

from MS-DOS, 567 
from Windows, 557 

system settings, changing, 558 
troubleshooting. See Getting Started with 

Microsoft Windows 
Windows components, 564-567 

SETUP.TXT file, xx 
Shell command, CONFIG.SYS file, 522 
Shortcut Keys command, Recorder, 473 
Shortcut-key combination 

application shortcut key 
assigning, 276-277 
deleting, 278 

defined,15 
macros 

assigning shortcut keys to, 462 
disabling nesting of macros, 467 
disabling shortcut keys, 473 

menus, shortcuts for commands, 18 
reserving for an application's use, 80,275,285 

Show Function Keys command, Terminal, 392 
Show Scroll Bars option, Terminal, 388 
Shrink + Grow command, Paintbrush, 367 
Signal When Connected option, Terminal, 385 
Size command, on Control menus 

described,22 
window size, changing, 25 

Size of windows, changing, 24-28 
Size option, File Manager, 108 
Size Picture command, Write, 303 
Sizing grid for windows, changing, 157 
SMARTDrive program 

command line, 539-540 
disk caching, described, 537 
double buffering, 541 
installing, 538 

Soft fonts 
described, 164 
installing, 210 

Software handshaking, 383 
Solitaire. See online Help in Solitaire 
Sort By Date command, File Manager, 109 
Sort By Name command, File Manager, 109 
Sort By Size command, File Manager, 109 
Sort By Type command, File Manager, 109 
Sorting contents of directory windows, 109 



Sound 
See also Media Player; Sound file 
assigning to events, 184 
drivers, installing 

by using Control Panel, 179 
by using Setup, 557 

speed,changing,480 
turning on or off, 1 85 
volume, changing, 480 

Sound file 
deleting, 481 
echo, adding, 481 
editing embedded files, 497 
editing linked files, 499 
embedding, 496 
inserting, 479 
linking, 498 
mixing, 479 
moving around in, 476 
opening, 475 
playing, 475 
recording, 476-477 
restoring, 482 
reversing, 481 
saving, 482 
.WAVextension, 184 

Sound Object command, Cardfile or Write 
editing embedded sound files, 497 
editing linked sound files, 499 
playing embedded sound files, 497 

Sound option, Terminal, 387 
Sound Recorder 

See also Sound file 
described,474 
inserting sound files, 479 
keys for working with, 596 
starting, 475 

Source 
directory, defined, 121-122 
disk, defined, 136 
document, defined, 489 

SPART.PAR file, 533 
Special Time command, Calendar, 428 
Speed of computer system 

See also Optimizing Windows 
factors affecting speed, 515 
increasing 

by adjusting Windows swap files, 533-534 
by compacting your hard disk, 527 
by setting multitasking options, 532 
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Speed of computer system (continued) 
increasing (continued) 

by setting TEMP to a RAM drive, 542 
by using RAMDrive, 547-550 
by using SMARTDrive, 537-540 

Speed of printing, changing, 220 
Speed of sound files, changing, 480 
Split bar 

described, 94 
moving, 111 

Split command, File Manager, 112 
Square, drawing perfectly, 357 
Standard command, PIF Editor, 261 
Standard Flow Control option, Terminal, 396 
Standard mode 

application swap files, 536-537 
defined,7 
PIF options for, 278, 285 

Starting 
applications 

by starting an associated file, 130-132 
by using MS-DOS Prompt, 54 
by using the Run command, 53 
from a directory window, 133 
from a document or program file, 134 
from a group, 86 
from the Startup group, 87 
incompatible applications, 50 
non-Windows applications, 240 
with application parameters, 263, 279 

Calculator, 409 
Calendar, 420 
Cardfile, 434 
Clock,449 
Control Panel, 139 
File Manager, 91 
Help, 43 
Media Player, 452 
memory-resident programs, 254 
MS-DOS Prompt, 257 
Notepad, 455 
Paintbrush,330 
PIF Editor, 260 
Print Manager, 199 
Program Manager, 71 
Recorder, 459 
Sound Recorder, 475 
Terminal, 380 
Tutorial,70 
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Starting (continued) 
Windows 

options for starting. See Getting Started with 
Microsoft Windows 

starting with File Manager appearing, 91 
Write, 291 

Start-up Directory option, PIF Editor 
386 enhanced mode, 263 
standard mode, 280 

StartUp group 
described,73 
starting applications, 87 

Status Bar command, File Manager, 114 
Status bar, in directory windows, 114 
Stop Bits option 

Control Panel, 161 
Terminal, 383 

Stopping 
See also Canceling; Quitting 
macros, 464 
sound files, 475 

Subscript, in Write documents, 310 
Superscript, in Write documents, 310 
Support services 

customer support, 559 
product support, xxiv-xxvi 

Swap file 
application swap files, 536-537 
described,520 . 
Windows swap files, 533-536 

Swapfile program, 534 
Swapping memory, described, 520 
Sweeping cutouts 

described,364 
transparently or opaquely, 365 

Switch To command, on Control menus 
described, 23 
opening Task List, 56 

Switching 
between applications, 55-56 
between documents, 66 
from a non-Windows application 

No Screen Save option, 284 
Prevent Program Switch option, 284 

to Program Manager, 87 
Synthesizer, MIDI setups 

channel maps, creating, 194-196 
creating, 188-197 
key maps, creating, 189-191 
patch maps, creating, 191-193 
selecting, 186 

SYSINI.WRI file, xx 
System date and time, changing, 176 
System disk, creating, 136 
System file 

displaying in File Manager, 110 
icon for, in directory windows, 118 

System file attribute, 128 
System keys, 583 
System menu. See Control menu 
System requirements. See Getting Started with 

Microsoft Windows 
SYSTEM.lNI file, swapdisk setting, 536-537 

T 
Table Format option, Terminal, 400 
Table, editing in Paintbrush, 369 
Tabs, in Write documents 

deleting, 322 
preset, 321 
searching for, 296 
setting 

by using the Ruler, 322 
by using the Tabs command, 321 

Task List 
arranging icons, 58 
arranging windows, 57 
switching between applications, 56 

Tasking options, Settings command, 245 
Technical support, xxiv-xxvi 
Telecommunications. See Terminal 
TEMP environment variable, 541-542 
Temporary files, removing, 524-525 
Terminal 

buffer, clearing, 406 
communications settings, 381-382 
connecting to a remote computer, 393 
disconnecting from a remote computer, 408 
editing text in the Terminal window 

clearing from the window, 406 
copying onto the Clipboard, 405 
pasting to a remote system, 405 
selecting all text, 405 
sending selected text, 405 

function keys 
assigning commands to, 389-391 
hiding or showing, 392 

hardware requirements, 379 
modem settings, 383 



Terminal (continued) 
phone number 

dialing, 393 
entering, 384-385 

printing 
incoming text, 406 
selected text, 407 

quitting, 408 
settings files 

described, 381 
saving, 407 

starting, 380 
terminal emulation, 386 
terminal emulation tables, 575 
terminal preferences, 386 
timing your sessions, 392 
transferring binary files 

preparing for, 397 
receiving, 403 
sending, 402 

transferring text files 
preparing for, 395 
receiving, 399 
sending, 398 
viewing, 401 

.TRM filename extension, 381 
troubleshooting. See Getting Started with 

Microsoft Windows 
Terminal Emulation command, 386 
Terminal Font option, Terminal, 388 
Terminal Preferences command, Terminal, 386 
Terminate option, Settings command, 245-246 
Terminate-and-stay-resident program (TSR), 51 
Text 

breaking into pages, 304 
editing 

basic techniques, 68-69 
in Cardfile, 439-440 
in Paintbrush drawings, 342 
in Terminal, 405-406 
in Write. See Write 

entering 
basic techniques, 67 
in Calendar, 422 
in Cardfile, 435 
in Notepad documents, 456 
in Paintbrush drawings, 339-341 
in Write documents, 292 

Text (continued) 
finding 

in Cardfile cards, 438 
in Notepad documents, 457 
in Write documents, 295-298 

formatting 
characters, 308-311 
paragraphs, 312-316 

moving within, 67 
printing. See Printing 
replacing 

basic techniques, 69 
in Write documents, 297 

selecting. See Selecting text 
sending to a remote computer, 405 

Text box, in dialog boxes, 34 
Text command, Cardfile, 441 
Text file 

described,394 
opening in Write, 324-325 
transferring 

preparing for, 395 
receiving, 399 
sending, 398 
viewing, 401 

Text mode 
monitoring video operations, 273 

Index 647 

specifying for non-Windows applications, 264, 281 
Text tool in Paintbrush, 347 
Text Transfers command, Terminal, 395 
Tile command 

See also Cascade command 
rearranging 

application windows, 57 
directory windows, 112 
group windows, 74-75 

Tilt command, Paintbrush, 369 
Time 

format, changing, 172 
Notepad files, adding to, 459 
system time, changing, 176 

Time command, Media Player, 454 
Time-log file, creating in Notepad, 458 
TimelDate command, Notepad, 459 
TimelDate Sent command, Print Manager, 222 
Timeout If Not Connected option, Terminal, 385 
Timeouts options, Print Manager, 212 
Timer Mode command, Terminal, 392 
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Title bar 
flashing, 63 
illustrated, 8 

Today command, Calendar, 423 
Toolbox, in Paintbrush 

See also Paintbrush 
described, 331 
removing from view, 333 
selecting and using tools, 337 

Tools and Linesize command, Paintbrush, 333 
Tracks command, Media Player, 454 
Transferring information 

See also Object linking and embedding 
between applications 

non-Windows applications, 248-251 
Windows applications, 59 

between computers. See Terminal 
Translation option, Terminal, 388 
Transmission Retry option, Print Manager, 213 
Tree And Directory command, File Manager, 99 
Tree Only command, File Manager, 99 
Triangle on menus, meaning of, 18 
.TRM filename extension, 381 
Troubleshooting 

See also Getting Started with Microsoft Windows 
device driver, reinstalling, 569 
networks, guidelines for using, 574 

TrueType fonts 
adding, 165 
described, 164 
removing, 168 
setting options, 168 
using, 165 
using exclusively, 167 
Write documents, 311 

TSR (terminate-and-stay-resident program), 51 
TSR program. See Memory-resident program 
Tutorial, running, 70 
. TXT filename extension, 458 

u 
Underlining 

in Paintbrush drawings, 341 
in Write documents, 308 

Undo command 
application Edit menus, 70 
Paintbrush,338 

Undoing changes 
in drawings, 338 
in sound files, 482 
in text, 69 

Units option, in Paintbrush, 332 
Up icon, 94, 101 
Update command 

editing 
embedded drawings, 493 
embedded sound files, 497 

embedding 
drawings, 492 
sound files, 497 

Updating directory windows, 111 
Upgrading from Windows 3.0. See Getting Started 

with Microsoft Windows 
Use Printer Resolution option, Paintbrush, 375 
Uses High Memory Area option, PIF Editor, 271 

v 
Video drivers, installing, 179 
Video Memory options, PIF Editor, 264, 273 
Video Mode option, PIF Editor, 280 
Video modes, specifying, 264, 280 
View Picture command, Paintbrush, 334 
View Text File command, Terminal, 401 
Virtual memory 

defined, 515 
swap files, 533-536 

Volume label 
creating or changing, 137 
described, 93 

Volume of sound files, changing, 480 
VT-52 terminals 

functions, 576-577 
IBM PC equivalent keystrokes, 575-576 

VT -100 terminals 

w 

functions and escape sequences, 578-581 
IBM PC equivalent keystrokes, 577-578 

Wallpaper 
adding or removing with Setup, 564 
displaying, 151 

Warning beep 
default beep, changing, 184 
turning on or off, 185 



.WAV filename extension, 184 
Whole drawing option, Paintbrush, 375 
Width option, Paintbrush, 332 
Wildcard 

displaying a group of files, 110 
searching for files or directories, 120 
selecting a group of files, 97 

Win command-line options. See Getting Started 
with Microsoft Windows 

WIN386.SWP file, 533 
Window 

application windows 
arranging, 57 
described, 9 

border 
changing width, 158 
illustrated, 8 

closing, 31 
copying onto the Clipboard 

non-Windows applications, 250 
Windows applications, 60 

document window, described, 10 
elements of 

described, 8 
illustrated, 8 

group. See Group windows 
inactive. See Inactive window 
moving, 23 
running non-Windows applications in, 242 
scrolling through information in, 30 
size, changing 

by dragging a border or comer, 24 
by enlarging to maximum size, 27 
by reducing to an icon, 25 
by restoring to previous size, 28 

sizing grid, changing, 157 
title (illustrated), 8 

Window option, Settings command, 244 
Window Title option, PIF Editor 

386 enhanced mode, 262 
standard mode, 279 

Window title, changing 
by using PIF Editor, 262, 279 
by using Program Manager, 79 

Windowed option, PIF Editor, 268 
Windows operating system 

quitting, 89 
starting 

options for starting. See Getting Started with 
Microsoft Windows 

starting with File Manager appearing, 91 

Index 649 

Windows operating system (continued) 
troubleshooting. See Getting Started with 

Microsoft Windows 
Windows applications. See Applications 
Windows In Background option, Control Panel, 532 
Windows In Foreground option, Control Panel, 532 
Windows Setup dialog box, 82 
WININI.WRI file, xx 
WINSTART.BAT file, 531 
Word break, optional, 299 
Word processing. See Write 
Word wrap 

in Notepad documents, 456 
in Terminal 

for text transfers, 397 
Terminal Line Wrap option, 387 

in Write documents, 292 
Word Wrap command, Notepad, 456 
Word Wrap Outgoing Text option, Terminal, 397 
Word, Microsoft, opening files in Write, 324 
Working directory for an application 

specifying in PIF Editor, 263, 280 
specifying in Program Manager, 80 

.WRI filename extension, 325 
Write 

backup copies of files, 326 
character format 

character styles, 308 
fonts, 310-311 
subscripts and superscripts, 310 

converting files to Write format, 324-325 
creating a document, 291 
file formats, 325 
file size, 324 
finding and changing text, 295-298 
headers and footers, 318-320 
hyphens for optional line breaks, 299 
keys for working with, 293, 596 
moving around in a document, 293 
page breaking, 304 
page layout, 323 
paragraph format 

alignment, 314 
indentation, 315-316 
line spacing, 314 
paragraph marks, 313 
Ruler, displaying, 312 

pictures 
changing picture size, 303 
editing, 301-302 
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Write (continued) 
pictures (continued) 

inserting, 299 
moving, 303 

x 

printing a document, 326-328 
saving a document, 325 
selecting text, 294 
sound files 

editing embedded files, 497 
editing linked files, 499 
embedding, 496 
linking, 498 

starting, 291 
tabs, setting, 321-322 
window, described, 291-292 
.WRI filename extension, 325 

XModemfCRC option, Terminal, 397 
XMS Memory Locked option, PIF Editor, 271 
XMS Memory option, PIF Editor 

z 

386 enhanced mode, 267 
standard mode, 282 

Zoom command, Paintbrush, 334-335, 370 
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