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Getting started

This guide covers the fundamentals of 
Visio® 2000 Technical Edition, focusing on the 
drawing types and methods you’re likely to use 
most often. 

Installing the Visio 2000 
Technical Edition Test Drive
You must be running Microsoft Windows 95, 
Microsoft Windows 98, or Microsoft Windows 
NT 4.0 or later to install Visio 2000 from the 
Visio 2000 Technical Edition Test Drive CD. 

NOTE To prepare for installation, close all pro-
grams and turn off virus-protection software to 
prevent installation conflicts.

On most Windows-based systems, installation 
starts automatically when you insert the Tech-
nical Edition Test Drive CD into your CD-
ROM drive. If installation does not start auto-
matically, you can install the Technical Edition 
Test Drive using the following procedure.

To install the Visio 2000 Technical Edition 

Test Drive

1 Insert the Visio 2000 Technical Edition 
Test Drive CD into your CD-ROM drive.

2 From the Start menu, choose Run.

3 In the Run dialog box, type d:\setup, where 
d is the letter assigned to your CD-ROM 
drive.

4 Click OK.

The Visio Installation Manager guides you 
through the installation process. 

Visio on the Web
To reach Visio Corporation and the Visio 
Knowledge Base using the World Wide Web, 
in Visio 2000, choose Help > Visio On The 
Web. The Visio Knowledge Base offers the lat-
est tips on using Visio 2000 products and 
includes articles that answer frequently asked 
questions (FAQs). 

You can also visit the Visio Web site 
(www.visio.com), which contains information 
on service releases, support forums, and train-
ing opportunities. To contact customer service 
or technical support, visit www.visio.com/
visioontheweb, and then follow the links to 
locate support information for your geo-
graphic area.
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What’s new in Visio 2000 

New and powerful additions to Visio® 2000 
Technical Edition make it easier than ever to 
create technical drawings and diagrams. 

Common tasks made easy 
You can work faster and smarter using a core 
group of enhanced features that all of the 
Visio 2000 products share.

• Easily create custom data for shapes that 
you can later use for reports.

• Set tabs, margins, and hanging indents 
using a text editing ruler.

• Nudge selected shapes using the arrow keys 
for precise placement in your drawing.

• Easily navigate, rearrange, and rename 
pages using page tabs.

• Edit groups of shapes the same way you edit 
individual shapes.

• Edit stencils directly in the drawing 
window.

• Customize menus and toolbars.

• Perform tasks right in the drawing window 
using quick editing windows. 

For CAD users: Drawing in 
Visio 2000
Because you work with intelligent shapes in 
Visio 2000, many of the CAD (computer-aided 
design) operations you might have used in 
CAD programs do not exist. Other CAD oper-
ations are slightly different (and easier) in 
Visio 2000. The following table matches some 
common CAD operations to the Visio 2000 
equivalents. 

New and enhanced technical 
solutions
Visio 2000 offers new and enhanced technical 
solutions that make it easy to assemble draw-
ings by dragging industry-standard shapes 
onto a page.

Precision drawing tools
• Draw shapes using the shape extension 

lines, which provide visual feedback about 
shape angles, tangents, and other geometric 
relationships.

• Position and align shapes instantly with the 
dynamic grid, which provides visual cues to 
help you align shapes.

• Snap lines to geometric points, such as end 
points, tangents, and line intersections, for 
more accurate drawing.

You can view the 
Technical Edition 
User Guide in PDF 
format, or view online 
Help on the Visio 2000 
Technical Edition 
Test Drive CD.
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CAD actions in Visio 2000

To perform this CAD action Do this in Visio 2000

Set drawing scale Choose File > Page Setup, click the Drawing Scale 
tab, and then select a scale. Unlike CAD drawings, 
you generally set the scale for a Visio drawing before 
you begin.

Move an object Select the shape and drag it.

Move an object a specific distance Select the shape and choose Tools > Macros > Visio 
Extras > Move.

Copy an object Select the shape and use Ctrl+C and Ctrl+V to copy 
and paste the shape, or press Ctrl and drag the 
shape to copy it.

Plot a diagram Choose File > Print.

Create a block Use the Visio drawing tools to create a shape, and 
then drag the shape to a stencil.

Pan and zoom a drawing Choose View > Windows > Pan & Zoom to open a 
window in which you can adjust the view of a 
drawing.

Create objects by using operations such as 
Union, Fragment, and Join

Choose Shape > Operations, and then choose an 
action.

Add a hatch pattern to an object Select the shape and choose Format > Fill. Choose 
options from the Color, Pattern, and Pattern Color 
lists. You can also create your own patterns.

Use entity snaps or object snaps Choose Tools > Snap & Glue and check Shape 
Extensions. On the Advanced Tab, check the shape 
extension options you want (for example, Segment 
Midpoint).
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DWG and DGN support
• Insert CAD drawings created in Autodesk 

AutoCAD DWG or DXF format or Bentley 
MicroStation DGN format.

• Convert CAD drawings into Visio format 
easily by using the new Convert Wizard.

• Choose an industry-standard scale for 
inserted CAD drawings that either matches 
the Visio drawing scale or is independent of 
the Visio drawing scale.

• Snap shapes, such as electrical outlets, 
HVAC ducts, and furniture, to inserted 
CAD floor plans.

Process Engineering
• Draw P&IDs (piping and instrumentation 

diagrams) and PFDs (process flow dia-
grams) faster using intelligent pipeline 
connections that automatically reroute.

• Store specification data about process com-
ponents in customizable datasheets.

• Quickly and easily generate component lists 
from the data stored in your diagrams.

• Convert your legacy CAD symbols or block 
libraries into intelligent Process Engineer-
ing shapes.

• New Print datasheets for many compo-
nents simultaneously.

• New Edit data for multiple components in 
the Datasheet window, which you can keep 
open for ease of data entry.

Facilities Management
• Graphically manage office moves and track 

your facilities assets and employees.

• View relational information about your 
facilities in the easy-to-navigate Visio 
CAFM Explorer, which can now be docked 
so that you can view the Explorer and your 
drawing at the same time.

• Easily add configured Steelcase 9000 furni-
ture to your facility plan.

• New Link to enterprise data in existing cor-
porate databases.

Building Architecture
• Quickly lay out a floor plan by using room 

and space shapes that you can easily convert 
to fully dimensioned walls.

• Quickly add dimension lines and guides to 
any wall, and resize rooms by dragging 
guides.

• Use space shapes inside rooms to show the 
room area, which you can update with a 
single command when you resize the room.

Building Services
• Create HVAC diagrams by using ductwork 

shapes that automatically rotate, align, and 
snap to each other.

Office layouts
• Quickly lay out office floor plans by using 

room and space shapes to automatically 
create walls and dimension lines. 
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Visio basics

The Visio® 2000  products share a core set of 
features. This means that you can use the same 
basic methods to work with all of the 
Visio 2000 programs to create your drawings. 

The following illustration shows five steps that 
are common to making any Visio 2000 draw-
ing. The next illustration shows the actual 
workspace you’ll use to create Visio drawings.      

Five steps to 

making a Visio 

drawing

1 Start a drawing or diagram by 
opening a drawing type, or template.

2 Add shapes by dragging them from 
the stencil and dropping them onto 
the drawing page.

3 Connect the shapes in your 
drawing.

4 Add text to shapes in your 
drawing, and add independent text 
for titles.

5 Publish your drawing to the Web, or print your drawing to share it with 
others.
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The Visio 2000

workspace

Each drawing type
opens with stencils,

shapes, and toolbars
appropriate to that

drawing type.

A Tools are grouped in functional sets on toolbars. You 
can specify which toolbars you want to display by 
choosing View > Toolbars. 

B The drawing page opens with size, orientation, 
scale, grid, and measurements appropriate for the 
drawing type.

C You can find additional related tools by clicking the 
arrows next to the button.

D You can use the drawing page grid to align shapes 
to each other.

E ScreenTips appear when you pause the mouse 
pointer over a toolbar button. 

F Stencils, or collections of masters, dock to the left of 
the drawing page, by default. 

G With page tabs you can quickly insert new pages, 
navigate multiple-page drawings, delete pages, 
rename pages, and reorder pages. 

H Masters are shapes you can add to your drawings. 
To quickly view information about a shape, pause 
the mouse pointer over a shape.

I When your drawing has multiple pages, you can 
move the horizontal scroll bar to view all of the page 
tabs. 

CA EB D

F G H I
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Starting a drawing

When you base a drawing or diagram on a 
Visio drawing type (also called a template) in 
Visio® 2000 Technical Edition, you automati-
cally get all the tools and features you need to 
create that type of drawing. For example, to 
create an organization chart, open the Organi-
zation Chart drawing type. 

To start a drawing 

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click a category name, such as Block Dia-
gram.

3 In the Drawing Type box, double-click the 
template you want to open, such as Basic 
Diagram.

A drawing page appears, with the stencils 
and tools you need to begin your drawing.

Working with stencils and shapes
When you start a new drawing or diagram by 
opening a template, Visio 2000 opens one or 
more task-related stencils. Stencils contain 
shapes that you can drag onto the drawing page 
to create your drawing. You can move stencils 
in the drawing window to create more work-
space by floating, minimizing, or docking them 
somewhere else. 

You can dock or “float”—make movable—stencils as 
you work on your drawing. 

TIP To open additional stencils, choose File > 
Stencils > Open Stencil, choose the stencil you 
want to open, and then click OK.

To add a shape to your drawing 

1 On a stencil, point to the shape you want to 
add to your drawing.

2 Hold down the mouse button and drag the 
shape to the location you want on the draw-
ing page, and then release the mouse button.

For quick access to 
stencil menu 
commands, use the 
Stencil toolbar. 
Choose View > 
Toolbars > Stencil.
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Using 1-D and 2-D shapes
Visio shapes can be one-dimensional (1-D) or 
two-dimensional (2-D).  

Aligning shapes with the 
dynamic grid
You can use a dynamic grid (dashed lines) to 
indicate the location for the next shape you 
drag onto the page, based on the location of 
shapes already on the page. As you move a 
shape on the page, you can place it precisely 
using dynamic grid lines to align the shape 
with other shapes in your drawing.

To turn on the dynamic grid

• Choose Tools > Snap & Glue, and then 
check Dynamic Grid.

When you drop a shape onto the drawing 
page, Visio 2000 snaps the shape to the 
nearest grid line so you can position it pre-
cisely in your drawing. 

Using shape handles 
Visio shapes have handles you can use to resize 
or move a shape or to change a shape’s appear-
ance, position, or behavior. You use selection 
handles ( ) to resize shapes and control han-
dles ( ) to perform actions that are unique to 
a particular shape.

For example, you might use a control handle to 
adjust the position of a shape or move a line in 
a shape. 

1-D shapes behave like lines and display endpoints you 
can drag to resize the shapes when you select them 
with the pointer tool.

2-D shapes have corner handles you can drag to resize 
the shapes proportionally and side selection handles 
you can drag to resize them horizontally or vertically.

To locate a specific 
shape quickly, use 
the Shape Explorer™ 
window. Choose 
Tools > Macros > 
Shape Explorer.

The control handle looks 
just like a selection 
handle, but has darker 
shading.

To see a ScreenTip for 
what a control handle 
does, pause the pointer 
over the control handle.

Adjust line spacing
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Moving and resizing shapes
Moving Visio shapes is as easy as selecting the 
shapes and then dragging the selection to the 
new location in your drawing or diagram. You 
can resize shapes quickly by simply dragging 
selection handles. 

NOTE When you drag a shape to resize it, you 
can see exactly how the shape changes as you 
drag. If the shape has text associated with it, the 
text resizes accordingly.

To move or resize a shape

1 To move a shape, select it with the pointer 
tool ( ), hold down the mouse button 
while dragging the shape to the location you 
want, and then release the mouse button. 

The pointer turns white when the shape 
is movable.

2 To resize a selected shape, point to a selec-
tion handle ( ) until the pointer changes to 
a four-headed arrow ( ), and then drag 
the handle to change the size.

To move multiple shapes at once 

1 Click to select a shape, and then hold down 
the Shift key and click the other shapes you 
want to select.

2 Place the pointer over one of the shapes 
until the pointer turns white. 

3 Drag the shape to its new position. 

All selected shapes move the same distance 
and direction from their original positions.

TIP To limit the movement of shapes to horizon-
tal or vertical, hold down the Shift key while you 
drag the shapes.

Quick editing with anchored 
windows
You can perform quick editing tasks such as 
changing a shape’s size and position or editing 
a shape’s custom properties directly in the 
drawing window using anchored windows. 
You can set anchored windows to AutoHide 
when you’re not using them, and conveniently 
tuck them away until you want to use them 
again.  

To open an anchored window 

• Choose View > Windows, and then click 
the name of the anchored window you want 
to open.

To nudge a shape 
slightly in one 
direction, select the 
shape, and then click 
the up, down, left, or 
right arrow key.

Anchored windows in Visio 2000

Window Purpose

Pan & Zoom Easily zoom in or out with 
increased precision.

Custom Properties View and edit a shape’s 
custom properties.

Size & Position Change a shape’s size, 
position, or rotation.

Drawing Explorer View all of the elements 
in your document.
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Connecting shapes
Flowcharts, organization charts, block dia-
grams, and network diagrams are all connected 
drawings—drawings that show relationships 
between shapes.

You can use two types of connections in 
Visio 2000:  shape-to-shape and point-to-
point. The type of connection you use depends 
on how much control you want over your 
drawing.

With shape-to-shape connections, Visio 2000 
maintains the most direct connection between 
the shapes. This means that the actual points of 
connection might change when you move the 
connected shapes in relation to each other.

With point-to-point connections, the points of 
connection stay the same no matter how you 
move the connected shapes. 

Shape-to-shape

connections

When you move shapes that have shape-to-shape connections, the connector attaches at the closest point between 
the shapes, which might be different from the original connection points.

Point-to-point

connections

When you move shapes that have point-to-point connections, no matter how you arrange the shapes in relation to 
each other on the drawing page, the shapes maintain their original connection points. 
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To connect shapes automatically, 

shape-to-shape

1 Click the connector tool ( ) on the 
Standard toolbar.

2 Drag a shape from a stencil onto the 
drawing page.

3 While the shape is still selected, drag 
another shape from a stencil onto the draw-
ing page.

The shapes are automatically connected 
shape-to-shape.

To connect shapes automatically, point-to-point

1 Use the pointer tool to drag two shapes, 
one at a time, from a stencil onto the 
drawing page.

2 On the Standard toolbar, click the connec-
tor tool, and then drag from a connection 
point on the first shape to a connection 
point on the second shape. 

The connection points turn red, and the 
shapes are connected point-to-point.

Adding and changing text
You can use text to clarify the meaning of your 
Visio drawings or diagrams and to document 
changes you or other Visio users make to a 
drawing. You can turn on the text ruler to help 
you format text in a shape. 

To add text to a shape 

• Select the shape, and then type the text you 
want.

To edit existing text 

• Double-click the shape to open its text 
block, and then type. You can also click the 
Text tool ( ) on the Standard toolbar, 
click the text, and then type. 

To turn on the text ruler

1 Double-click a shape to open its text block.

2 Right-click the shape with its text block 
selected, and then choose Text Ruler from 
the shortcut menu.

The text ruler appears above the shape.

You can quickly change the settings for the selected 
text by dragging the tab stops and indent markers to the 
location on the scale you want in the text editing 
window. 

Visio
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Adding color and line styles to 
shapes
You can add color to shapes and instantly 
make your drawings more visually dynamic. 
You can also change the format of lines and 
line ends in your drawings. By applying line 
ends, you can turn any line into an arrow.

To view the fill color palette

• On the Format toolbar, click the arrow next 
to the Fill Color button.

Click More Fill Colors on the fill color palette for 
additional colors.

To apply color to a shape

• Select the shape and choose the fill color 
you want to use from the fill color palette. 

To format a line style 

• Select the shape and choose the Line 
Weight, Line Pattern, and Line Ends but-
tons on the Format toolbar to select the for-
matting you want to use.

Flipping and rotating shapes
You can change the direction and angle shapes 
face in your drawings by flipping and rotating 
them. Select shapes and then use commands 
on the Tools menu or buttons on the Action 
toolbar to flip and rotate shapes.

To view the Action toolbar

• Choose View > Toolbars > Action. 

Grouping shapes
You can group shapes so they function as a 
unit and so that you can regularly use them 
together.

To create a group

1 Drag the shapes you want to group, one at a 
time, from a stencil onto the drawing page.

2 Select the first shape, hold down the Shift 
key, and then click to select the other shapes 
one at a time. 

3 Choose Shape > Grouping > Group.

Flip and rotate shapes with Action tools

Action Tool

Flip a shape horizontally    

Flip a shape vertically
   

Rotate a shape right
   

Rotate a shape left
   

You can import a 
graphic from another 
program to use in 
your drawing. Choose 
Insert > Picture, 
select the file format 
or type the path and 
name of the file you 
want to import, and 
then click Open.
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Using background pages to 
display common page elements
If you want a common element to appear on 
more than one drawing, you can create a back-
ground page that contains a logo, and then 
assign it to the foreground page.

To create a background for a drawing

1 Right-click a page tab ( ) in the 
lower left corner of the drawing window, 
and then choose Insert > Page from the 
shortcut menu. 

2 On the Page Properties tab, for Type, click 
Background.

3 If necessary, click the Drawing Scale tab to 
change the scale or the Page Size tab to 
change the page size for the new page, and 
then click OK.

4 Place the design element you want to use as 
a background onto the drawing page.

To assign a background to a drawing 

1 Display the page to which you want to 
assign a background.

2 Choose File > Page Setup, and then click the 
Page Properties tab.

3 In the Background list, select the name of 
the background that you want to assign, and 
then click OK.

The background appears behind the shapes 
on the foreground page.

To display a background so you can edit it

• Display the page to which the background is 
assigned, and then choose Edit > Go To > 
Background.   

Using background 

pages

Use backgrounds to repeat a common element on several drawings. For example, the sailboat appears on each of 
these three pages.



14 V I S I O  2 0 0 0  T E C H N I C A L  E D I T I O N
Saving and printing your 
drawings
The first time you save a drawing, Visio 2000 
prompts you for document properties, such as 
whether or not to save a preview, a small 
thumbnail version of the drawing. The proper-
ties you specify appear in the Open dialog box 
when you select the drawing file name.

To save a drawing for the first time

1 Choose File > Save or Save As.

2 For File Name, type a name for the drawing 
file.

3 Under Save In, open the folder in which you 
want to save the file.

4 Click Save.

5 In the Properties dialog box, enter the 
information you want, and then click OK.

6 Click Save.

To print your drawings, choose File > Print or 
click the Print button ( ) on the toolbar.
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Creating your own shapes, stencils, styles, and templates

As well as providing you with ready-to-use 
solutions, Visio® 2000 Technical Edition gives 
you the flexibility to build your own. You can 
create your own shapes, stencils, styles, and 
templates that you and others can reuse. You 
can even build toolbars and menus that con-
tain the tools and commands you use most 
frequently.

Creating your own shapes
There are several ways you can create your own 
shapes in Visio 2000. You can use Visio draw-
ing tools to create a shape from scratch, merge 
a shape with other shapes to create a new 
shape, or revise an existing shape. 

To draw a shape from scratch using the Visio 

drawing tools

• On the Standard toolbar, choose a drawing 
tool, and then click and drag on the drawing 
page to create the shape you want. 

Click the arrows next to the rectangle tool and the line 
tool to see more Visio drawing tools.

To merge existing shapes to create a new shape

1 Select the shapes in your drawing that you 
want to use to create a new shape.

2 Choose Shape > Operations, and then 
choose the appropriate command. 

NOTE The new shape you create using any shape 
operations command inherits the formatting of 
the first shape you selected.    
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Using shape operations commands

Command Result Example

Fragment Breaks a shape into smaller parts or creates new 
shapes from intersecting lines or from 2-D shapes 
that overlap.

Combine Creates a new shape from selected shapes. If the 
selected shapes overlap, the area where they 
overlap is cut out (discarded), creating a cookie-
cutter effect.

Union Creates a new shape from the perimeter of two 
or more overlapping shapes.

Subtract Creates a new shape by subtracting the area 
where selections overlap from the primary 
selection.

Intersect Creates a new shape from the area where the 
selected shapes overlap, eliminating non-
overlapping areas.

Offset Creates a set of parallel lines or curves to the right 
and left of the original shape.

When you use the 
pencil, line, rectangle, 
or ellipse tool, try 
holding down the 
Shift key while you 
draw to see how that 
constrains the 
drawing behavior.
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Adding your own shapes to 
stencils
If you want to reuse your own shapes the next 
time you open a particular drawing type, you 
can save them to existing stencils in your draw-
ing, and then save the file as a template (.vst). 

You can also create a new stencil, and then add 
your own shapes to it as well as any existing 
Visio shapes. Then, you can save the stencil in a 
template file so that you and others can reuse it 
in other drawings. 

To add your own shape to an existing stencil

1 Open the template containing the stencil to 
which you want to add your shape.

2 Click the icon on the stencil title bar ( ), 
and then choose Edit from the menu.

A red asterisk appears on the stencil icon 
( ) to indicate that the stencil is editable. 

3 Hold down the Ctrl key, and then drag your 
shape from the drawing page onto the stencil.

A new icon representing your shape appears 
on the stencil with a generic name, such as 
Master.01.

4 Click the new master on the stencil, click it 
again, and then type the name you want for 
the new shape.

5 Click the stencil icon ( ), and then choose 
File > Save As to open the Save As dialog 
box. Navigate to the Solutions folder in 
which you want to save the stencil, and then 
type a name for it in the File Name box. 

6 For Save As Type, choose Stencil (*.vss), 
and then click Save to save your stencil.

When you open the stencil again, you can 
use the new shape as you do any other 
Visio 2000 master.

To add your own shape to a new stencil

1 Choose File > Stencil > New Stencil. You 
can also choose View > Toolbars > Stencil, 
and then click the New Stencil button on 
the Stencil toolbar.

The new stencil appears docked to the left 
side of the drawing window. The stencil 
icon has a red asterisk ( ) to indicate that 
it is editable.

2 Hold down the Ctrl key, and then drag your 
own shapes, one at a time, from the drawing 
page onto the new stencil.

3 Click the Save icon ( ) on the right side of 
the stencil title bar.

4 In the Save As dialog box, navigate to the 
folder where you want to save the stencil, 
and then type a name for the stencil in the 
File Name box. 

5 Make sure Save As Type is Stencil (*.vss), 
and then click Save.

You can view the 
Technical Edition 
User Guide in PDF 
format, or view online 
Help on the Visio 2000 
Technical Edition 
Test Drive CD.
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Defining and editing styles
A style in Visio 2000 is a named collection of 
formatting attributes that you can apply to 
your shapes. You can create styles that format 
the elements of a shape: fill, line, and text. For 
example, you might create a style that gives 
shapes a black outline, a green fill, and black 
bold italic text.

When you define or edit styles in a drawing file, 
the changes you make are available only in the 
current drawing or diagram. To make a style 
available for future drawings, you can define or 
edit it in an existing template. The style is 
included in every new drawing you create.

To define a new style 

1 Choose Format > Define Styles.

2 In the Style list, type a name for the new 
style.

3 If you want to base the new style on an 
existing style, select that style from the 
Based On list.

4 Under Includes, check the attributes that 
your style includes. A style can include for-
matting from any combination of the three 
attributes.

5 Under Change, click Text, Line, or Fill to 
change the settings for each attribute you 
included in Step 4.

6 When the style contains the settings you 
want, click Apply to add the new style and 
apply it to selected shapes.

To change a style

1 Choose Format > Define Styles.

2 In the Style list, select the style you want to 
change.

3 To rename the style, click the Rename but-
ton, type a new name in the Rename Style 
dialog box, and then click OK.

4 To change style settings, click the Change 
button. When you have finished changing 
the attributes, do one of the following:

• Click Apply.

• Click Change to add the changes and 
continue working in the dialog box.

Creating your own template
You might want to create your own template 
when your drawings

• Require customized settings such as page 
size or scale, window size and position, or 
shape or text styles.

• Often include a particular background or 
set of layers. For example, if you place your 
company logo in every drawing, you can 
create a template with that background or 
set of layers in place.
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To create and save your own template 

1 Open a drawing or start a new drawing 
based on the template you want to modify.

2 Open any additional stencils you want to 
save with the template by choosing File > 
Stencils > Open Stencil and then choosing 
the stencils you want. 

3 Change drawing page settings and styles to 
those you want to use in future drawings 
that are based on this template.

4 Choose File > Save As, and then do the fol-
lowing:

• For Save As Type, select Template (*.vst).

• For File Name, type a name for your 
template.

• For Save, make sure Workspace is 
checked.

• For Save In, select the folder in which you 
want to save the template.

5 Click Save.

Creating your own toolbars
To work more efficiently, you can create your 
own toolbars that contain only the tools you 
need as you create your drawings. 

To create your own toolbar

1 Choose View > Toolbars > Customize.

2 On the Toolbars tab, click New, type a name 
for your new toolbar, and then click OK.

3 A new, small toolbar appears. 

4 Click the Commands tab, and then from the 
Categories list, select the category that con-
tains the command for which you want to 
create a button. 

5 Drag the commands you want to include, 
one at a time, from the Commands list to 
the toolbar. 

To attach a custom menu or toolbar to the 

drawing file so others can use it

1 Choose View > Toolbars > Customize, and 
then click Attach.

2 In the Custom Toolbars list, select a toolbar 
to include in the drawing file, and then click 
Copy.

3 When all of the toolbars you want in the 
drawing file are listed in the Toolbars In 
Document list, click OK.

To show or hide 
toolbars while you 
work, choose View > 
Toolbars, and then 
click to add or 
remove a check 
mark next to the 
toolbar you want to 
show or hide.
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Drawing precisely

Engineering and architectural diagrams and 
drawings require accurate measurements and 
precise positioning of shapes. Visio® 2000 
Technical Edition provides drawing and posi-
tioning tools that are easy to use but powerful 
enough for the most complex drawings.

Setting the drawing scale
Many engineering or architectural drawings 
require a drawing scale that makes it possible 
to represent very large or very small objects on 
a sheet of paper.

When you begin a measured drawing in 
Visio 2000, the drawing page opens with a 
default drawing scale. You can change the 
drawing scale at any time, and you can set a 
different drawing scale for each page of your 
drawing. 

To change the drawing scale for a page

1 Display the page whose scale you want 
to change.

2 Choose File > Page Setup, and then click the 
Drawing Scale tab.

3 Click Pre-Defined Scale, and then select an 
engineering or architectural scale. 

Or, click Custom Scale, and then type a cus-
tom scale. When you type a custom scale, 
enter the measurement units or click the 
Page Properties tab and select the appropri-
ate measurement units.

4 Click OK.

As the drawing scale changes, shapes take up more or 
less space on the page. The rulers in each drawing 
show the actual size of the objects the drawing 
represents in the measurement units you have selected.

Setting measurement units
Measurement units are the measurements that 
appear on the ruler and in dimensions. Mea-
surement units represent sizes in the real 
world. For example, in an architectural draw-
ing, the measurement units might be feet and 
inches.

Selecting a predefined drawing scale automati-
cally sets the measurement units. If you are 
creating a custom scale, you might need to 
specify the measurement units. For example, if 
you want 1 inch on a landscape layout to repre-
sent 3 yards in the real world, set your 
measurement units to yards.

1/4" = 1'0"

1:25



E V A L U A T I O N  G U I D E 21
To set measurement units for a page

1 Display the page for which you want to set 
the measurement units.

2 Choose File > Page Setup, and then click the 
Page Properties tab.

3 From the Measurement Units list, select the 
units you want.

Showing size by using 
dimension lines
Visio 2000 provides dimension lines that calcu-
late and display linear and angular dimensions. 
When you resize a shape that has attached 
dimension lines, the dimensions are automati-
cally updated.

You dimension a shape by dragging a dimen-
sion shape onto your drawing and connecting 
its endpoints to geometric points on the shape 
you want to measure. You can choose from a 
variety of dimensioning shapes, including hori-
zontal and vertical baselines, horizontal and 
vertical outside dimensions, and diameter and 
radius dimensions. 

Snapping to grids, guides, and 
guide points
To position shapes quickly and accurately, you 
can snap them into position. Snapping pulls 
shapes to rulers, grids, or guides and is useful 
for positioning and aligning shapes. 

To set snap settings for grids, guides, and rulers

1 Choose Tools > Snap & Glue.

2 Under Currently Active, make sure Snap is 
checked.

3 Under Snap To, check Ruler Subdivisions, 
Grid, and Guides, and then click OK.

A Linear dimension line
B Angle dimension line

C Radius dimension line

A

B

C
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Snapping to shapes
When you are drawing shapes, you can snap to 
points on other shapes by using extension lines 
that appear when your pointer is positioned 
near the target point. For example, you can 
snap to the endpoint of a line or the center of 
an ellipse.

Use extension lines to snap to points on shapes, such as 
the midpoint of a line.

To turn on shape extensions

1 Choose Tools > Snap & Glue.

2 On the General tab, under Snap To, check 
Shape Extensions.

3 On the Advanced tab, under Shape Exten-
sion Options, check the ones you want, and 
then click OK. Click the Help button ( ) 
to see an explanation of the options.

4 While using a drawing tool, move the 
pointer toward or along a shape to see an 
extension line that pinpoints your target.

Shape extensions work with the line, arc, free-
form, pencil, ellipse, rectangle, and connection 
point tools.

Positioning shapes by using the 
dynamic grid
When you turn on the dynamic grid, dotted 
lines show the most desirable position of a 
shape in relation to the shapes near it. 

To turn on the dynamic grid

1 Choose Tools > Snap & Glue.

2 Under Currently Active, check Dynamic 
Grid, and then click OK.

Use the dynamic grid to align shapes at their center 
points.

Using the Snap & Glue toolbar
You can change your snap and glue settings 
quickly by using the Snap & Glue toolbar. To 
view the toolbar, choose View > Toolbars > 
Snap & Glue.

Use the Snap & Glue toolbar to quickly change snap 
settings.
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Positioning shapes by using 
coordinates
You can position shapes at exact x- and y-coor-
dinates in your drawing. The x- and y-
coordinate values determine the position of a 
shape’s reference point, or pin, on the page. 

Position a shape by entering coordinates in the Size & 
Position window.

To position a shape by using coordinates

1 Drag a shape to the approximate location 
you want on the page. 

2 Choose View > Windows > Size & Position, 
or click the status bar.

3 Enter values for the new location in the X 
and Y boxes, and then click OK. 

Panning and zooming drawings
Instead of frequently zooming in and zooming 
out of a drawing, you can use the Pan & Zoom 
window to quickly locate and magnify an area 
of a large drawing. 

To pan and zoom a drawing

1 Choose View > Windows > Pan & Zoom.

2 In the Pan & Zoom window, drag a box 
around the area you want to magnify.

3 To pan to a different part of the drawing, 
drag the box.

Pan & Zoom 

window

View in Pan & Zoom window View in drawing page
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Working with CAD drawings

You can insert existing CAD drawings into 
your Visio® 2000 Technical Edition drawings 
to use as background images or as detail 
images. For example, you might want to insert 
a floor plan drawn in Autodesk AutoCAD and 
add HVAC shapes on top of the floor plan. Or 
you might want to insert an equipment draw-
ing into a Process Engineering document. 

You can insert CAD files in the following 
formats:

• Autodesk AutoCAD DWG and DXF file 
formats

• Bentley MicroStation DGN file format

Inserting CAD floor plans as 
background images
You can insert a floor plan drawn in a CAD 
program into your Visio drawing to use as a 
background page or as a reference layer. 

After you have inserted the floor plan, you can 
drag Visio shapes onto it, add comments, or 
hide layers. Visio shapes will snap to objects in 
an inserted DWG drawing.

CAD floor plan

You can drag Visio shapes onto an inserted CAD drawing. Shapes automatically snap to the lines in a CAD drawing. 
For example, workstation shapes snap to wall lines in a floor plan.
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To insert a floor plan as a background image

1 Create a blank Visio drawing that has the 
page size and drawing scale you want. 

2 In the Visio drawing, choose Insert > CAD 
Drawing. 

3 Under Files Of Type, select the CAD draw-
ing file format you want. Locate the CAD 
file containing the background image and 
click Open.

If you plan to drag shapes such as office fur-
niture onto the CAD drawing, set the CAD 
drawing and the Visio drawing to the same 
scale. For details, see “Changing the scale of 
an inserted drawing” on page 26. 

4 On the General tab of the CAD Drawing 
Properties dialog box, check Lock Position 
and Lock Cropping so that you don’t acci-
dentally move or resize the drawing while 
you are working with it. 

5 Click OK to begin working with the inserted 
drawing.

6 To lock the Visio layer that contains the 
inserted drawing, right-click the inserted 
drawing and choose View > Layer Proper-
ties. Click the Lock column for the CAD 
Drawing layer, and then click OK.

Inserting CAD drawings as detail 
images
You can insert a CAD drawing into an existing 
Visio drawing to show a detail of a floor plan or 
of a mechanical part. 

After you have inserted the detail image, you 
can add comments to it, crop it, change its 
scale, or hide layers.

You can insert a CAD drawing to show a detail of a 
mechanical part, a portion of a floor plan, or an alternate 
view of an object.

To insert a CAD drawing as a detail image

1 Open the Visio drawing into which you 
want to insert the CAD drawing.

2 Choose Insert > CAD Drawing. 

3 Under Files Of Type, select the CAD draw-
ing file format you want. Locate the CAD 
file you want and click Open.

4 To reduce or enlarge the image, set the CAD 
drawing scale on the General tab of the 
CAD Drawing Properties dialog box. 

If you are not planning to drag Visio shapes 
onto the inserted image, you can set the 
CAD drawing to a scale different from that 
of the Visio drawing. For details, see 
“Changing the scale of an inserted drawing” 
on page 26. 
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5 On the General tab, uncheck Lock Position 
and Lock Cropping so that you can move 
and crop the inserted CAD drawing, and 
then click OK.

6 To position the CAD drawing on the Visio 
page, select the drawing and drag it.

Changing the scale of an 
inserted drawing
When you insert a CAD drawing, Visio 2000 
chooses a drawing scale that fits the CAD 
drawing onto the Visio drawing page. You can 
change the scale of the CAD drawing to make it 
larger or smaller, and you can match the scale 
of the CAD drawing to the Visio drawing scale.

To change the scale of a CAD drawing

1 Right-click an inserted CAD drawing and 
choose CAD Drawing Object > Properties.

2 Click the General tab and choose a CAD 
Drawing Scale option. For details about 
these options, see the following table. 

3 Verify the size of the CAD drawing on the 
Visio drawing page by looking at the pre-
view. If the CAD drawing does not fit on the 
Visio drawing page, try the following 
actions:

• Choose a smaller CAD drawing scale 
or Visio drawing scale. For example, 
3/32 inch = 1 foot is a smaller scale than 
1/4 inch = 1 foot and will show more of 
the inserted CAD drawing.

• Choose a larger page size. For example, 
the ANSI Architectural page size of 36 
inches by 24 inches might be large 
enough to display an entire floor plan. 
Click Page Setup. On the Page Size tab, 
select a page size, and then click OK.

4 Click OK to accept your changes. If you 
have set the CAD drawing to a scale differ-
ent from that of the Visio drawing, click 
Continue Without Matching Scale in the 
dialog box, and then click OK. 

CAD drawing scale options

If you want to do this... Choose this CAD scale option...

Drag Visio shapes onto an inserted 
CAD drawing.

Click Pre-defined Scale, and then select Page Scale. This option 
matches the CAD drawing scale to the Visio drawing scale so 
that shapes are sized correctly when you place them on the 
CAD drawing.

Set the CAD drawing scale to a 
smaller or larger scale than the Visio 
drawing scale.

Click Pre-defined Scale, and then select an industry and a 
specific scale from the list. When you select this option, Visio 
shapes that represent physical objects (such as desks and 
chairs) are not sized correctly when you place them on the CAD 
drawing. You can, however, use annotation shapes or add text 
blocks to the inserted drawing.

Set your own scale. Click Custom Scale, and then type in a scale. CAD drawings 
generally have a custom scale when you first insert them. 
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Hiding layers or levels
You can hide layers or levels to hide objects in 
an inserted CAD drawing. For example, you 
might want to turn off all the layers containing 
office furniture in a CAD floor plan so that you 
can drag Visio office furniture shapes onto the 
floor plan.

To hide layers or levels

1 In Visio 2000, right-click the CAD drawing 
and choose CAD Drawing Object > Proper-
ties. Click the Layer tab or the Level tab.

2 To hide a layer or level, uncheck it, and then 
click OK. 

Converting CAD drawings into 
Visio format
When you insert a CAD drawing, you get an 
image of the CAD drawing that you cannot 
alter by deleting, resizing, or modifying the 
objects in the drawing. If you need to modify 
the CAD objects in a drawing, you must con-
vert those objects into Visio shapes. 

For example, if you want to move an interior 
wall in a floor plan, you must convert the CAD 
objects that represent the wall into Visio shapes. 
You select the objects to convert by selecting the 
CAD layer or level on which they appear.

To convert CAD objects

1 In Visio 2000, right-click the CAD drawing 
and choose CAD Drawing Object > Convert.

2 In the Convert Wizard, press Ctrl+click to 
select the layers or levels containing the 
objects you want to convert, and then click 
Next.

3 Choose whether to delete or hide the origi-
nal layers or levels. 

4 For DWG files, specify how you want to 
convert dimensions:

• To get dimension lines that are updated 
when you resize the associated Visio 
shapes, click Convert Into Visio’s 
Dimension Shapes. Converted 
dimension lines lose their original CAD 
font and line style.

• To preserve the CAD formatting of 
dimensions, including the font and line 
style, click Convert Into Lines And Text.

5 Click Finish to convert the objects on the 
selected CAD layers or levels.

Converting Visio drawings into 
CAD format 
You can convert, or export, a Visio drawing 
into CAD format by choosing the Save As com-
mand. You must convert each page of a 
multipage drawing separately.

You can convert files into the following 
formats:

• Autodesk AutoCAD DWG and DXF file 
formats

• Bentley MicroStation DGN file format

To convert a Visio page

1 Go to the Visio drawing page you want to 
convert, and then choose File > Save As.

2 Under Save As Type, select the CAD draw-
ing file format (for example, AutoCAD 
Drawing [*.dwg]), and then click Save.
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Process Engineering: Drawing PFDs and P&IDs

Industries of all kinds rely on process plants to 
manufacture and deliver products or refined 
materials. Effectively managing the design of 
processes and the systems that support them is 
critical to the success of these plants.

The Process Engineering solution provides the 
drawing tools you need to create PFDs (process 
flow diagrams) and P&IDs (piping and instru-
mentation diagrams) and tools for creating 
process component specifications.

Working in projects
In the Process Engineering solution, you work 
in projects where you create and edit the PFDs, 
P&IDs, datasheets, and equipment lists (or bills 
of materials) for your process plant. The 
Project Explorer makes it easy to manage 
project-related documents.

Visio® 2000 Technical Edition includes a full 
sample Process Engineering project that you 
can explore, which includes sample P&IDs, 
datasheets, and lists. 

     

Project view shows all 
of the diagrams in a 
Process Engineering 
project.

Components view shows 
the datasheets of all the 
components in a project. 
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Try it: Explore the sample project

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click Open Existing 
File, and then double-click Browse Existing 
Files. In the Open dialog box, navigate to 
Visio\Samples\Process Engineering\Process 
Engineering Project. Select Sample 
Project.vsd, and then click Open. 

2 In the Project Explorer, click the Project 
tab, and then double-click SamplePID1 to 
open the sample P&ID. 

3 Select the Centrifugal Pump shape in the 
diagram, and then choose Process 
Engineering > Datasheets > Edit Datasheet 
to see the specifications for the pump. 
Choose File > Close to close the datasheet.

4 In the Project Explorer, click the Compo-
nents tab to see a list of all the datasheets in 
the sample project. Click the plus sign (+) 
next to Valves to see the Valve datasheet, 
and then click the plus sign next to Valve to 
see the tags of all of the valves in the project 
that use that datasheet. Right-click any valve 
and choose Edit Datasheet to open its 
datasheet. 

5 In the Components tab, right-click any 
valve and choose Go To Shape. The valve is 
highlighted in the drawing.

6 When you have finished exploring, choose 
Process Engineering > Close Project.

Starting a new project    

To use the Process Engineering intelligent 
shapes and to access process component data, 
you must work in a project. Starting a new 
project is as easy as starting any new drawing in 
Visio 2000. 

Try it: Start a new project 

1 Create a project folder on your computer 
named Heat Project. 

Create a separate folder for each Process 
Engineering project.

2 In Visio 2000, choose File > New > Process 
Engineering > Process Engineering. Click 
the Create A New Project option, and then 
click the Browse button to locate and open 
the Heat Project folder. 

3 Name the project Heat_Proj.vsd, and then 
click Save. Click OK to open the new 
project.

TIP To make it easier to distinguish project files 
from diagrams, indicate in the file name whether 
a .vsd file is a project file or a diagram.
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Creating PFDs and P&IDs
You create PFDs and P&IDs by dragging Pro-
cess Engineering shapes from stencils onto 
your drawing page. The Process Engineering 
solution comes with a library of SmartShapes® 
symbols that are specifically designed for pro-
cess engineering schematics, making it easy to 
create and modify them.

Pipelines connect equipment shapes on a P&ID. 
Pipelines are drawn with Visio connectors that stretch 
and contract as you move equipment shapes.

Valves rotate into position and glue themselves to a 
pipeline as you drag them onto the pipeline.

Try it: Draw a P&ID

1 Open the Heat_Proj.vsd project file you cre-
ated in “Starting a new project.” If the 
default blank drawing page is open, choose 
File > Close to close it.

2 Choose Process Engineering > New Project 
Document > Drawing. Name the drawing 
Steam1.vsd, and choose a sheet format from 
the Based On list to determine the page size, 
border, and title block format of the new 
diagram. Click OK.

3 Click the Equipment - Pumps stencil to see 
the pump shapes, and then drag the Cen-
trifugal Pump shape from the stencil onto 
the drawing page. 

4 From the Equipment - Heat Exchangers 
stencil, drag the Shell And Tube shape to 
the right of the pump shape, and then 
choose Shape > Rotate Left. If necessary, 
press Ctrl+Shift+click to zoom in.

5 Click the connector tool ( ) on the Stan-
dard toolbar to draw a pipeline. On the Cen-
trifugal Pump shape, click the outlet arrow, 
and then drag the connector tool to any con-
nection point on the Shell And Tube shape. 

TIP You can connect a pipeline to any point 
on the outside of an equipment shape. 
Visio 2000 creates a new connection point 
wherever you attach the pipeline.

6 Click the pointer tool ( ), and then from 
the Valves And Fittings stencil, drag the 
Check Valve shape onto the pipeline. 

The valve is now associated with this pipe-
line and moves with it. 

7 From the Instruments stencil, drag the Indi-
cator shape and place it above the pipeline 
to the right of the Check Valve.
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8 Drag the association control handle ( ) 
from the instrument to the pipeline. 

A red dashed line appears, indicating that 
the instrument is now associated with the 
pipeline it monitors and will move with the 
pipeline.

9 Choose File > Save.

You can quickly change some Process Engineering 
shapes by right-clicking the shape and choosing a 
different shape variation from the shortcut menu.      

A P&ID drawing

The Process Engineering solution provides drawing tools with which you can quickly and efficiently create and 
modify PFDs and P&IDs.
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Associating components in 
diagrams
A P&ID shows how physical components are 
functionally or mechanically related. In a 
Visio 2000 P&ID, this relationship is called an 
association. You can associate shapes when you 
want the shapes to stay together in a drawing. 
You can also associate shapes when the compo-
nents they represent are functionally 
dependent. For example, because a valve is 
physically mounted on a pipeline, the valve is 
functionally dependent on the pipeline.

Drag the association control handle from an 
instrument (A) to a valve (B) to manually associate 
the two components. 

A

B

Associating a valve

with a pipeline

Some components in a P&ID are automatically associated to show the relationship between them. The association 
control handle (A) turns red to show that this valve is associated with the pipeline.

A
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Modifying your diagrams
As you design and refine a process, you need to 
be able to manipulate components on your 
diagrams quickly and easily. The intelligent 
shapes in Visio 2000 make it easy for you to 
modify diagrams. 

To move an equipment shape, simply select it 
and move it. All of the pipelines connected to 
the shape move with it. Pipelines stretch or 
contract as needed; pipelines can even jump 
over other pipelines. Branched pipelines retain 
their branches.

Valve shapes move with the pipeline with 
which they are associated. To move a valve 
shape along a pipeline, select it and slide it. If 
you move the valve around a bend in the line, 
the valve will reorient itself to match the line.

To change a pipeline’s appearance, select the 
pipeline, and then select a new style from the 
Line Style list on the Format Shape toolbar. 

Moving equipment 

shapes

As you move equipment shapes, the connecting pipelines are rerouted and valves are repositioned.
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Entering component data
From the piping and fittings you order from 
standard vendor catalogs to the custom equip-
ment you have manufactured for your plant, 
you specify and track large amounts of data 
about the components in your process plant. 
In the Process Engineering solution, you can 
add data directly to components in the dia-
gram without calling up a separate database or 
spreadsheet program. 

Each component in a diagram has a related 
datasheet, an electronic form that contains 
fields of data for the component. For example, 
the datasheet for a pipeline generally specifies 
the line size, material, and design temperature 
and pressure.

You can enter all the data for one component 
at a time or finish a portion of a diagram and 
enter data for several components at once. 

Add data to a diagram by filling out a datasheet for each 
Process Engineering component in your diagram. To 
access a shape’s datasheet, right-click the shape and 
choose Edit Datasheet.

The Datasheet window stays open so that you can add 
data to or edit data for several shapes at once.

VALVE

Tag V--1 Description

Physical Data

Valve Size inch End Connection* *

Line Size inch Minimum Wall Thickness* *
Schedule Diameter* *

inch

inch

Design Data

Design Temperature *

Design Pressure *
ANSI Class *

psig

deg F

Power *
Material *

Manufacturer Data

Manufacturer *

Model Number *

Type *

SubType *

General

Remarks

Default ProjectANSI

Visio

Seattle

SIZE

SCALE

FSCM NO DWG NO

SHEET1 : 1

A Def Proj 1

1 of 1
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Try it: Enter data for several components 

at once

1 In the Steam1.vsd diagram, choose Process 
Engineering > Datasheet Window. 

2 Select several valves in the diagram and, in 
the Datasheet window, set some values that 
are typical for these types of valves. The 
datasheet is automatically updated as you 
type values into the Datasheet window.

Numbering or tagging 
components
Component tags often provide information 
about components. A pipeline tag might indi-
cate the line size, pressure rating, material, and 
type of fluid carried. 

To make entering tags faster, you can set up 
datasheets so that component tags are con-
structed directly from certain fields in a 
datasheet. These intelligent tags appear on the 
diagram when you enter data into the 
datasheet for the component. The default 
datasheets for components have intelligent 
tags, and you can create intelligent tags for 
your own datasheets. 

You edit an intelligent tag by changing the datasheet 
fields from which the tag is constructed. You can also 
override an intelligent tag and manually type the tag 
number.

Tagging a pipeline

1 Open the Steam1.vsd diagram you created 
in “Drawing PFDs and P&IDs.”

2 Right-click the major pipeline between the 
pump and the heat exchanger, and then 
choose Edit Tag Number.

3 In the Line Size field, type 4, and then click 
OK. The pipeline tag is updated to show the 
new line size.

4 To move the tag on the diagram, select the 
tag’s green control handle ( ) and move it. 
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Generating equipment, line, and 
valve lists
You can generate lists of equipment, pipelines, 
valves, and instruments directly from the data 
in datasheets. As you modify diagrams, you can 
quickly generate a new list from the updated 
datasheets. You can create lists in Microsoft 
Excel format or plain text format, or you can 
create a list in a new Visio drawing. 

Try it: Generate a list of all valves in a diagram

1 Open SamplePID1.vsd in Visio\Samples\
Process Engineering\Process Engineering 
Project. 

2 Choose Process Engineering > Lists > 
Generate List. From the List box, select 
Valve List. 

3 Under Include In List, choose Entire Docu-
ment. 

4 Under Output File, name the file. Click 
Write To Visio Drawing, and then click OK 
to generate the list.

Visio 2000 opens a new drawing page that 
contains the generated list. You can save, 
print, or copy the list to another Visio 2000 
drawing.

Creating your own datasheet
Visio 2000 provides default datasheets for 
equipment, pipelines, valves, and instruments. 
You can modify the default datasheets, or you 
can create your own datasheets. You can also 
create your own lists and sheet formats.

Personalized

datasheets

When you create your own datasheet forms, you specify the label, format, and default unit for each field. 

VALVE

Tag V--1 Description

Physical Data

Valve Size inch End Connection* *

Line Size inch Minimum Wall Thickness6 *
Schedule Diameter* *

inch

inch

Design Data

Design Temperature 120

Design Pressure * psig

deg C

Power *
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Try it: Create a new datasheet

1 Open the Steam1.vsd diagram you created 
in “Drawing PFDs and P&IDs.”

2 Choose Process Engineering > New Project 
Document > Datasheet. In the New 
Datasheet dialog box, name the datasheet 
MyPump, and select Equipment from the 
Based On list and from the Category list. 
Click OK.

3 In the Datasheet Builder dialog box, type 
Motor in the Field Name box. The Label box 
is updated to use the same name. 

The field name is a unique identifier for the 
datasheet field; the label is the name that 
appears on the datasheet. 

4 For Unit Type, select Power. Accept the 
default settings for the rest of the dialog 
box, and click Add Field.

A field shape is added to the datasheet page, 
and the dialog box is cleared so that you can 
create the next datasheet field.

5 Add more fields, and then click OK to exit 
the dialog box. When you have finished, 
choose File > Save to save the new 
datasheet, and then close it.

To use the new datasheet, you use the Assign 
Datasheet Wizard to assign it to some compo-
nents in your project. For example, you could 
assign this MyPump datasheet to all of the 
shapes on the Equipment - Pumps stencil. 

Creating intelligent tags
You can create component tags that are auto-
matically constructed from fields in the 
component’s datasheet. These intelligent tags 
are useful for component tagging schemes that 
provide information about the component, 
such as the line size, material, and fluid.

You can set up intelligent tags that substitute 
codes for values in a datasheet field. For exam-
ple, if the fluid carried by a pipeline is 
designated as Waste Water in the datasheet, the 
tag can substitute the code WW for that value. 
You can also create tags that are automatically 
incremented as components are added to a 
diagram. 

You use the Tag Builder dialog box to create intelligent 
component tags that are constructed from fields in a 
datasheet.
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Facilities Management: Drawing facilities plans and 
tracking assets

The Facilities Management solution in 
Visio® 2000 Standard Edition combines space-
planning and asset-tracking capabilities in one 
easy-to-use software package. This solution 
offers two different views of your facility infor-
mation: a spatial view when you use the 
facilities plan, and an organizational view when 
you use Visio CAFM Explorer. 

You can

• Create and revise facility plans based on 
head count, workstation configuration, and 
other space requirements.

• Locate and list assets, such as furniture, 
equipment, and fixtures.

• Graphically view room assignments and 
quickly update them. 

Sample

facilities plan

If you followed the procedures in this chapter, your facilities plan should look similar to this one. After you create a 
facilities plan, you can use it as a tool to list, locate, and print your facilities information.
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Starting a facilities plan
When you start your facilities plan, you con-
nect to a facilities database that contains the 
information you want to track. To get started 
quickly, you can use the basic Microsoft Access 
database that is created by default when you 
start a facilities plan. 

You can also create a custom facilities database 
in Microsoft SQL Server format instead of 
Microsoft Access format. A custom database 
can be located on a network server.

Try it: Start a facilities plan and connect it to the 

default database

1 Start Visio 2000, and then choose File > 
New > Facilities Management > Facilities 
Plan.

2 On the first screen of the Facilities Manage-
ment Setup Wizard, click Next. On the next 
screen, click Yes to track information in 
your drawing. Click Basic: Facilities 
Data.mdb to track information in the basic 
database, and then click Next.

3 Enter a company name, location, building, 
and floor name. 

4 Click Finish until you exit the wizard.

Creating a building shell
Each page in your Visio drawing represents a 
floor or a section of a floor in your facility. You 
can represent an entire floor on one page or 
sections of a floor on different pages. You can-
not, however, represent more than one floor 
on the same page.

With the Facilities Management solution, you 
can

• Create a building shell from scratch using 
the shapes on the Walls, Shell And Structure 
and the Building Core stencils. You can also 
insert a building shell you’ve already created 
using these shapes. 

• Insert a building shell from a CAD 
(computer-aided design) program such 
as Autodesk AutoCAD or Bentley 
MicroStation. 

• Convert an existing facilities plan created in 
a CAD program into Visio format. Doing 
this converts the CAD objects that represent 
assets into Visio SmartShapes® symbols. 
You can then convert symbols that repre-
sent assets into Facilities Management 
shapes that have asset-tracking capabilities. 

Designating spaces
You need to designate spaces in your facilities 
plan so you can associate people and assets 
with a particular space, such as an office or 
conference room. 

Try it: Designate office spaces in your 

facilities plan

1 From the Resources stencil, drag the Space 
shape into the top-left office in your facili-
ties plan. The Space shape automatically 
resizes to fit the office.
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2 To specify information (properties) for the 
space, double-click the Space shape. In the 
Properties dialog box, select the area beside 
the property in the Value column, and then

• Type Office 101 for the Name property.

• Type Yes for the Is Occupied property.

• Type Office for the Space Type property.

3 Click OK.

4 Copy and paste the Space shape into the 
other similarly shaped spaces, and then 
enter properties for each office, including 
office numbers.

Double-click a shape to view its category and 
properties. Values in the Properties dialog box are 
saved as soon as you change them, as is the case when 
you change the fields in a database.

Once you size a shape to fit a particular space, you can 
copy and paste the shape into other spaces. 

Resizing spaces
The Space shape is automatically resized when 
you drag the shape into an office created with 
Visio wall, door, and window shapes. If you 
move a wall, you can fit the Space shape to the 
new office by using the Auto Size command.

If you are working with an inserted CAD build-
ing shell (one that you have not converted into 
Visio format) or with rooms that are not com-
pletely enclosed by Visio wall, door, and 
window shapes, you must resize the Space 
shape manually. For irregularly shaped rooms, 
use the Edit command to modify the Space 
shape.

To resize a Space shape by using the Auto Size 

command

• If the Space shape is completely bounded by 
Visio wall and door shapes, right-click the 
Space shape and choose Auto Size. The 
Space shape is automatically resized to fit 
the new room.
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• If the Space shape is bounded by shapes 
converted from a CAD drawing or by any 
other Visio shapes, such as lines, right-click 
the Space shape and choose Auto Size. Press 
Ctrl+click to select each bounding wall of 
the room. Be sure to select any shapes or 
lines that represent interior structural fea-
tures, such as interior columns. Click OK to 
resize the Space shape.

Assigning people to spaces
You assign people to spaces to associate them 
with that location. In many organizations, a 
manager might occupy offices in several build-
ings or locations, and two people might share 
an office. With the Facilities Management  
solution, you can assign a person to more than 
one space, and you can assign more than one 
person to a single space. 

Try it: Assign a person to each office space in 

your facilities plan

1 From the Resources stencil, drag the Person 
shape onto the Space shape for Office 101.

2 To specify information (properties) about 
the person, double-click the Person shape. 
In the Properties dialog box, select the area 
beside the property in the Value column, 
and then

• Type Eileen Adams for the Name 
property.

• To add Eileen’s manager, type Jillian 
Elliot for the Manager property.

• Type Accountant for the Title property.

3 Drag Person shapes onto the Space shapes 
for the rest of the offices in your facilities 
plan, and enter properties for each person.

NOTE You can use Visio CAFM Explorer to 
organize people within departments. For more 
information, see “Tracking organizational data 
by using Visio CAFM Explorer” on page 46. 

Tracking data by using asset 
shapes
To track your assets, just drag an asset shape 
from the appropriate stencil onto a Space 
shape to associate it with that space, and then 
double-click the asset shape to specify 
properties. 

Try it: Add assets to your facilities plan and 

track data for each asset

1 From the Office Furniture stencil, drag a 
Corner 2, Chair, and File shape onto the 
Space shape for Office 101. Size them to fit 
the office. To rotate the chair, drag the con-
trol handle ( ) on the shape.

To resize a Space shape 
completely bounded by 
Visio wall shapes, right-
click the Space shape 
and choose Auto Size.

The Space shape expands 
to fill the room.
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2 Double-click each furniture shape, and then 
specify properties.

Shapes belong to different categories and have 
different properties. To find out which category a shape 
belongs to, double-click it.

3 Repeat steps 1 and 2 for Offices 102 and 103 
in your facilities plan.

4 Choose File > Save.

Designating new tracking 
information
The facilities information that you decide to 
track is organized into categories—the groups 
to which shapes belong—and properties—the 
information you can track for a given category. 
For example, furniture shapes belong to the 
Furniture category, and office equipment 
shapes belong to the Equipment category.

Every category has Name, Ref (user-defined reference 
word or number), and Notes properties and other 
properties specific to that category. 

You can customize the default categories to 
track information specific to your organization 
by adding your own properties to the default 
categories or by adding your own subcategories 
and properties. 

Try it: Add new categories and properties

1 Choose Facilities > Customize > Categories.

2 In the Categories dialog box, add the fol-
lowing subcategories and properties in this 
order: 

• Computer subcategory (base this subcat-
egory on the Equipment category) and 
these properties: Manufacturer, Part 
Number, Processor, RAM, and Hard 
Drive Size

• Cost Center Number property for the 
Person category

• Contractor and Employee subcategories 
(base these subcategories on the Person 
category)
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Assigning a category to a shape
The Facilities Management solution offers the 
flexibility to track any information you want 
for your facility. To track facilities information 
with a shape, you must assign the shape to a 
category that has properties for the informa-
tion you want to track. 

You can create your own shapes and assign a 
category to them as well as change or assign a 
category to any shape on the drawing page or 
on a Visio stencil.

Try it: Assign a category to shapes on a stencil

1 Make sure nothing is selected on the 
drawing page, and then choose Facilities > 
Convert Shapes. Click Next.

2 In the second screen of the wizard, choose 
the Office Equipment - Electronic stencil 
from the list, click Next, and then click Yes 
to open the original stencil.

3 In the next screen, uncheck Show Only 
Unassigned Shapes so that you can see all of 
the shapes.

4 From the Categories list, select Computers.

5 Under Shapes, select PC, and then press 
Ctrl+click to select Tower PC. Click Add.

6 Click Finish to reassign the shapes. Click No 
to indicate that you are finished assigning 
categories.

7 From the Office Equipment - Electronic 
stencil, drag a PC shape onto the desk in 
Office 101 of your facilities plan.

8 Double-click the PC shape to enter infor-
mation for the Manufacturer, Part Number, 
Processor, RAM, and Hard Drive Size prop-
erties.

9 Repeat steps 7 and 8 to add PC shapes to the 
remaining offices in your facilities plan.

10 For the purpose of this exercise, don’t save 
the changes you made to the stencil. How-
ever, if you were creating a real facilities 
plan, you would click the stencil title bar of 
the stencil you changed and then choose 
File > Save.

11 With the drawing window active, choose 
File > Save to save your facilities plan.

Using data from existing 
databases
Much of the information you would track in a 
facilities plan already exists in databases within 
your organization. For example, a Human 
Resources database might contain employee 
information such as a social security number 
or manager’s name. 

You can link properties in your facilities plan 
to fields in existing databases so that you do 
not need to reenter the existing data into your 
facilities plan. Whenever the external database 
is updated, your facilities plan is also updated.
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You can link properties to fields in existing databases to 
reuse your organization’s data. 

To access an external database, you must know 
its data source name. If the database is pro-
tected, you also need a user name and 
password. Contact the database administrator 
for that information. 

To connect to an existing database and 

choose data

1 Choose Facilities > Customize > Get Exter-
nal Data. 

2 Click Create to create a new connection, or 
link, to the existing database.

3 Type a connection name for this connection 
to the database. 

You create a unique connection name for 
each Facilities Management category you 
link to a table or view in the external data-
base. For example, if you were accessing a 
Human Resources database, you could 
name the connection Employees.

4 Select the data source that points to the 
existing database, and then click Next.

5 Under Object Types, click the type of data-
base objects you want to view, and then 
under Database Objects, select the particu-
lar table or view you want. Click Next.

6 Choose one or more columns (database 
fields) to use as the primary key to identify 
each record in the table, and then click 
Next.

A primary key is one field or a set of fields 
that uniquely identify the records stored in 
a table. You can use up to five columns as 
the primary key for a table.

7 Select the Facilities Management category 
that will use data from the existing database.

For example, if you were connecting to an 
existing Human Resources database, you 
would choose Person from the categories 
list.

Facilities
database

Corporate
database
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8 Select a Facilities Management property and 
a database field to link together, and then 
click Add.

For example, you could link the Hire Date 
property with a Hire Date field from an 
employee table in a database.

9 When you have finished linking Facilities 
Management properties to database fields, 
click Finish.

To use linked data in your facilities plan

1 Double-click the asset or the Person shape 
in your facilities plan.

2 In the Properties dialog box, click Use Exist-
ing Item.

3 In the Search For box, type text to locate the 
correct record in the external database.

For example, to locate the record associated 
with an employee, type the person’s first 
name or last name. 

4 Select the record you want, and then click 
OK.

Any property that is linked to a database 
field is automatically filled in. You cannot 
edit linked properties in the Properties dia-
log box.

5 Click OK to save your changes and close the 
Properties dialog box.

Listing and locating assets in 
your facilities plan
One of the most important uses of your facili-
ties plan is to list assets and track their location 
in your facilities plan. For example, you can 
locate a person in your facilities plan or list all 
of the copiers on a particular floor.

Try it: List and locate the chairs in your 

facilities plan

1 Choose Facilities > Find.

To find Steelcase furniture that has particu-
lar specifications, choose Facilities > 
Furniture > Find.

2 In the Find Facilities Data dialog box, on 
the Name & Location tab, type chair in the 
Search For box and select the Furniture 
category.

3 Click Find Now.

All shapes that match the criteria appear in 
the list at the bottom of the dialog box. 

4 From the list of shapes, select the chairs you 
want to locate in your facilities plan, right-
click any one of the selected chairs, and then 
choose Add-Ons > Locate.

Visio 2000 selects the chair in your 
facilities plan.

5 Click Close.
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Tracking organizational data by 
using Visio CAFM Explorer
Visio CAFM Explorer offers a hierarchical view 
of your facilities data. You can set up depart-
ments and organize people within departments 
so that you can quickly view the structure of 
your company. Or, you can enter information 
for a department that you wouldn’t track in 
your facilities plan, such as the total budget for 
a department.

Visio CAFM Explorer complements your facilities plan by 
offering a hierarchical view of your organization and 
facilities information.

You can also use Visio CAFM Explorer as a 
holding place for information about resources 
or assets that you haven’t placed in your facili-
ties plan yet. For example, suppose the Human 
Resources department just hired an employee, 
but the manager doesn’t know where the 
employee will sit yet. 

Try it: Add new employee information to 

Visio CAFM Explorer

1 In Visio CAFM Explorer, navigate to the 
department to which the new employee 
belongs.

2 Right-click the People folder, choose 
New > Person, type the new employee’s 
name, and then press Enter.

3 Right-click the new employee name, and 
then choose Properties to enter information 
you know about the new employee.

When you determine where the new employee 
sits, you can add a Person shape to your facili-
ties plan. You can then associate the Person 
shape with the employee information you 
added using Visio CAFM Explorer.
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Building Architecture: Drawing floor plans and site plans

Whether you are an architect designing a 
commercial building or a facilities manager 
planning interior spaces, Visio® 2000 Technical 
Edition provides the drawing tools you need to 
quickly and easily draw floor plans and site 
plans.

Drawing a space plan
In Visio 2000, you can start a floor plan from a 
space plan, a conceptual design sketch that 
shows the required spaces in a building and the 
relationship between spaces. When you have 
finalized the layout of your building, you can 
convert the spaces into rooms outlined by fully 
dimensioned wall shapes. You can then con-
tinue to create a full floor plan with as much 
detail as necessary. 

Join two space shapes by 
right-clicking the shapes 
and choosing Union.

Choose Architecture > 
Convert To Walls to 
convert the space shape 
into wall shapes.    

To resize the room, drag a 
guide.

To resize the space shape, 
right-click the shape and 
choose Auto Size.
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To start your space plan

1 Start Visio 2000, and then choose File > 
New > Building Architecture > Floor Plans. 

2 To change the page size or drawing scale, 
choose File > Page Setup.

3 Click the Page Size tab and choose a page 
size, and then click the Drawing Scale tab to 
choose a drawing scale. 

4 Click OK to accept the new settings and 
begin working on your space plan.

To create rooms by using space shapes

1 From the Walls, Shell And Structure stencil, 
drag a space shape onto the drawing page.

2 To resize the space shape, drag any corner 
of the shape. 

The shape is updated to show its new area.

3 To create a room that is not rectangular, 
position several space shapes to represent 
the room. Select all of the shapes, right-click 
them, and then choose Union, Subtract, or 
Intersection to combine them.

4 Position shapes to represent all of the rooms 
and common areas in your space plan.

5 To convert a space shape into a room, right-
click the shape and choose Convert To Walls.

6 In the Convert To Walls dialog box, check 
Add Dimensions and Add Guides so that 
you can reposition the walls easily after they 
are created.

7 Under Original Geometry, click Retain to 
keep the original space shape. 

TIP  If your floor plan will be used with the 
Facilities Management solution, keep the 
space shape.

8 Click OK to create the room. 

To create rooms by drawing lines

1 Use the line tool ( ) or the rectangle tool 
( ) on the Standard toolbar to draw an 
outline of a room.

2 Draw the outlines of all of the rooms and 
common areas in your space plan.

3 To convert lines into walls, select the lines 
that represent the rooms, and then choose 
Architecture > Convert To Walls.

4 In the Convert To Walls dialog box, check 
Add Dimensions and Add Guides so that 
you can easily reposition the walls after they 
are created.

5 Under Original Geometry, click Convert To 
Space Shape to delete the original lines and 
insert a space shape into the converted 
room.

6 Click OK to create the room.

To resize rooms

1 To change the size of a room, drag the 
guides to which the walls are attached.

2 If the room contains a space shape, update 
the space shape by right-clicking it and 
choosing Auto Size.
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Starting a floor plan
Floor plans are the core drawings in a set of 
construction documents and are frequently 
used as background images in a wide range of 
drawings, from office furniture layouts to elec-
trical wiring diagrams.

You use wall shapes from the Floor Plans sten-
cils to draw a detailed floor plan. You can also 
create a floor plan by creating a space plan and 
then converting the spaces into walls. For 
details, see “Drawing a space plan” on page 47. 

To start a floor plan

1 Start Visio 2000, and then choose File > 
New > Building Architecture > Floor Plans. 

2 To change the page size or drawing scale, 
choose File > Page Setup.

3 Click the Page Size tab and choose a page 
size, and then click the Drawing Scale tab to 
choose a drawing scale. For details, see 
“Setting the drawing scale” on page 20. 

4 Click OK to accept the new settings and 
begin working on your floor plan.

Floor plan

The Building Architecture solution simplifies the complex task of drawing scaled floor plans.
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Drawing the building shell
The building shell includes exterior and inte-
rior walls and columns and major structural 
features, such as stairways and elevators. 
Visio 2000 provides wall shapes that you can 
glue together to form exterior or interior walls. 
When wall shapes that form a T-joint or corner 
joint are glued together, the joint is automati-
cally redrawn so that it is displayed correctly. 

Wall joints are displayed correctly when you glue the 
endpoints of walls together.

To draw the building shell

1 Drag guides from the horizontal and vertical 
rulers, and position the guides on the page 
so that they indicate the perimeter of the 
building.

2 For each exterior wall, drag a wall shape onto 
the page. Drag the endpoints of the wall shape 
to the intersections of the horizontal and ver-
tical guides to glue them to the guides.

3 To reposition exterior walls, drag the guides 
to which they are attached.

4 Add columns or other structural shapes 
from the Walls, Shell And Structure stencil 
or the Building Core stencil.

5 Position interior and cubicle walls by drag-
ging the wall shapes onto the page. Drag the 
endpoint of one wall to another wall to join 
them.

6 Add guides to interior walls by right-click-
ing a wall and choosing Add A Guide.

7 To reposition interior walls, drag the guides 
to which they are glued. 

8 To change wall properties, such as thick-
ness, right-click a wall and choose Set Wall 
Properties.

Adding doors, windows, and 
openings
It’s easy to add the shapes for doors, windows, 
and other openings to your floor plan. When 
you drag a door or window shape onto a wall, 
the door or window automatically rotates to 
align with the wall and glues itself to the wall. 
Door and window shapes also acquire the 
wall’s thickness.

To add doors, windows, and openings to walls

1 Drag a door, window, or opening shape 
from the Walls, Shell And Structure stencil 
onto a wall. 

2 To reposition a door or window, drag it 
along the wall.

3 To change door or window properties, such 
as width or offset within a wall, right-click a 
door or window and choose Set Door Prop-
erties or Set Window Properties. 
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Measuring and dimensioning
In Visio 2000, you can add dimension lines to 
walls at any time. As you refine your plan, the 
dimensions are automatically updated. You 
can also find out the area and perimeter of 
rooms in your floor plan.

To add dimension lines to a wall

1 Select the walls to which you want to add 
dimensions.

2 Right-click the walls, and then choose Add 
A Dimension.

To measure the area and perimeter of rooms

1 Select the shapes.

2 Choose Tools > Macros > Visio Extras > 
Shape Area And Perimeter.

Additional architecture drawings
You can use the Building Architecture solution 
to draw home plans and site plans.

Use home plans for remodeling your house or for a complete residential floor plan. Use site plans to show how a building is situated on a piece 
of property or to show how a site will be landscaped.
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Building Services: Drawing HVAC diagrams

Visio® 2000 Technical Edition provides shapes 
for creating HVAC control logic diagrams that 
show a schematic view of the equipment, wir-
ing, and sensors used to control an HVAC 
system.

To create an HVAC control logic diagram

1 Start Visio 2000, and then choose File > 
New > Building Services > HVAC Control 
Logic Diagram. 

2 Drag HVAC shapes onto the drawing page. 

You can configure many shapes by right-
clicking them and choosing Set Properties 
from the shortcut menu. For example, you 
can change ducts from double line to single 
line.

HVAC plan

Using the Building Services solution, you can draw HVAC plans to show ductwork for heating, ventilation, and air 
conditioning systems.



E V A L U A T I O N  G U I D E 53
3 To label a shape, select it and type the label 
text. You can reposition a label by dragging 
the label’s control handle ( ).

4 Save your drawing.   

To create an HVAC plan

1 Start Visio 2000, and then choose File > 
New > Building Services > HVAC Plans. 

2 Drag ductwork shapes onto the drawing 
page. Ductwork shapes rotate into position 
and glue to other ductwork shapes.

You can configure many shapes by right-
clicking them and choosing the appropriate 
command from the shortcut menu. For 
example, you can change the angle and 
radius of a Variable Bend shape.

3 To label a shape, select it and type the label 
text. You can reposition a label by dragging 
the label’s control handle ( ).

4 Save your drawing.

Using an existing floor plan
Many HVAC, electrical, and plumbing draw-
ings are created on a floor plan or building 
shell to show the location of the components in 
the building. You can insert an existing floor 
plan in DWG, DXF, or DGN format. For 
details, see “Drawing precisely” on page 20. 

To use a floor plan saved in a Visio product 
format, open the floor plan, and then open the 
Building Services stencils you want.

To use a floor plan saved in a Visio product 

format

1 Choose File > Open. In the Open dialog 
box, navigate to the folder that contains 
your Visio drawing, select the Visio drawing 
file you want to use, and then click Open.

2 Choose View > Layer Properties. Select each 
floor plan layer and check Lock.

3 Choose File > Stencils > Open Stencil. In 
the Open Stencil dialog box, navigate to the 
folder that contains the stencils you want.  
For each stencil you want to use, press 
Ctrl+click, and then click Open.

For example, to open the stencil for electri-
cal and telecom plans, navigate to 
Visio\Solutions\Building Services and open 
the file Electrical And Telecom.vss.

4 Begin working with your drawing.



54 V I S I O  2 0 0 0  T E C H N I C A L  E D I T I O N
Additional industry drawings    
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Sharing your drawings with others

With Visio® 2000 Technical Edition, publish-
ing your drawings or diagrams to the Internet 
or an intranet site is as easy as saving a file. 
Visio 2000 automatically adds the HTML 
codes necessary to display the drawing in a 
Web browser, so all you have to do is make 
sure your drawing looks the way you want.

You can make your drawing a launching point 
for users who want more detail and related 
information by adding hyperlinks to shapes. 
When users click a “hot” shape, they jump to 
the linked location. 

Adding hyperlinks to drawings
You can add one or more hyperlinks to Visio 
shapes and drawing pages. A link can jump to 
another page in the same Visio drawing or dia-
gram, another Visio drawing, or a non-Visio 
document. 

When you add hyperlinks to other pages in 
the same drawing, you can use them to move 
among pages in the Visio drawing. For 
example, you can link a Process shape in a 
flowchart to Total Quality Management 
(TQM) documentation in a Microsoft Word 
document for that process.

When you link a shape or page to a file, you 
can decide whether the path to the link should 
be a relative path or an absolute path.

• Relative path A relative path describes the 
location of the linked file in relation to the 
Visio drawing or another path, which you 
can set on the Summary tab of the Proper-
ties dialog box (choose File > Properties). 
You can move the Visio drawing and the 
linked file together (that is, move the entire 
path structure) without breaking the link, 
but if you move the drawing or file sepa-
rately, you break the link. 

Converting Visio

drawings to

Web pages

You can easily convert Visio drawings to Web pages by saving them in HTML format.
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• Absolute path An absolute path identifies 
the exact location of the linked file in terms 
of drive, folder, and file name. You can 
move the Visio drawing file without affect-
ing the link, but if you move the linked file, 
you must reset the path.

To link a shape or page to another Visio 

drawing page, a Web page, or a non-Visio file 

1 Create or open a Visio drawing. To add a 
link to a page, display the page with nothing 
selected. To add a link to a shape, select the 
shape.

NOTE If you are linking to a Visio 2000 
drawing, make sure to save the drawing so 
that you can open the source to which you are 
linking.

2 Choose Insert > Hyperlink.

3 Do one of the following:

• To link to a Web site, for Address, type 
the Web site’s URL. If you don’t know 
the URL, click Browse, and then choose 
Internet Address to open your default 
Web browser.

• To link to a file, for Address, click 
Browse, and then click Local File. 
Navigate to the file you want, and then 
click Open. (If necessary, change the type 
of file in Files Of Type.)

4 If you are linking to a file and you want to 
display a particular page, click Browse next 
to Sub-Address, select the page you want, 
and then click OK.

5 Under description, type a name for the link 
that identifies the location you’re linking to.

6 Do one of the following:

• To specify an absolute path, uncheck Use 
Relative Path For Hyperlink. 

• To specify a relative path, check Use 
Relative Path For Hyperlink. To set a 
path that is not based on the location of 
the Visio drawing, choose File > 
Properties. For Hyperlink Base, type the 
base path that you want.

7 To add another hyperlink for the selected 
shape or page, click New, and then repeat 
steps 3 through 6.

8 To link to another page within the docu-
ment, or to a shape in the document, click 
the Browse button to the right of Sub-
Address, specify the page, shape and zoom 
level you want, and then click OK. 

Converting drawings to HTML
After you create Visio 2000 drawings, you 
can convert them into Web pages with links 
to other Web pages by saving them as 
HTML files.

To convert a drawing to an HTML file 

1 Open the drawing you want to save as an 
HTML file, and then choose File > Save As.

2 Type a name for the HTML file, using the 
.htm extension, such as Drawing.htm. 

3 For Save As Type, choose HTML Files 
(*.htm, *.html), and then click Save.

4 In the Save As HTML dialog box, accept the 
default settings, and then click OK.

You are prompted to view the HTML pages.



58 V I S I O  2 0 0 0  T E C H N I C A L  E D I T I O N
5 Click Yes to view the new Web pages in 
your default browser. 

NOTE Visio 2000 provides support for VML 
(Vector Markup Language), which facilitates the 
exchange, delivery, and editing of high-quality 
vector graphics on the Web. You must have 
Microsoft Internet Explorer 5.0 installed to save a 
drawing in VML format. 

Routing your drawings for 
comments
You can use e-mail to send a Visio drawing or 
diagram to another user. For example, if you 
need information from coworkers to complete 
your drawing, you can route the drawing to 
them electronically and ask for their 
comments. 

The Visio program also lets you take advantage 
of Microsoft Office routing features, including 
sending drawings to Microsoft Exchange fold-
ers, adding routing slips to drawings you send 
by means of e-mail, and adding journal entries 
to Microsoft Outlook.

NOTE Visio products are compatible with e-mail 
programs that support the Messaging Application 
Programming Interface (MAPI) protocol. 

To send a drawing with a routing slip

1 Display the drawing you want to send, and 
then choose File > Send To > Routing 
Recipient.

2 In the Routing Slip dialog box, click 
Address to open your address list, select the 
individuals or groups to which you want to 
route your diagram, and then click OK.

3 To route the drawing to people in a specific 
order, select a person’s name, and then click 
the up or down arrow in the Move section 
to change that person’s position in the list.

4 Under Route To Recipients, specify whether 
to route the drawing to one person at a time 
or to everyone at once.

If you choose to route the drawing to one 
person at a time, the first person on the list 
views or updates the drawing, routes the 
drawing to the next person, and so on.

If you route the drawing to a designated 
group (called a group alias), all group 
members will receive the drawing at the 
same time.

5 Check Track Status to receive an update as 
each person on the list passes the drawing to 
the next person, or check Return When 
Done if you’d rather not see the drawing 
again until everyone has seen it.

6 Under Message Text, type the text you want 
in the e-mail message, and then click Add 
Slip.

7 Choose File > Send To > Next Routing 
Recipient to send the drawing to the first 
person on the routing list.



0300 Part No. 098-88453



Copyright © 1999 Visio Corporation. All rights reserved. 

Information in these materials is furnished for informational use only, is subject to change without notice and does not represent a commitment on the
part of Visio Corporation. These materials, as well as the software described herein (“Software”), are furnished under license;  there is no transfer of title.
The Software is subject to the license agreement that accompanies or is included with the Software, which specifies the permitted and prohibited uses of
the Software. Any unauthorized duplication or use of Visio Corporation Software, in whole or in part, in print, or in any other storage and retrieval sys-
tem is prohibited. No part of these materials may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language in
any form or by any means (electronic, mechanical, recording or otherwise) for any purpose other than the purchaser’s personal use without the express
written permission of Visio Corporation. Visio Corporation assumes no responsibility or liability for any errors or inaccuracies that may appear in these
materials. Use these materials at your own risk.

The Software, as with all technical software, computer-aided design software and other drawing and diagramming software, is a tool intended to be used
by trained professionals only.  It is not a substitute for the professional judgment of trained professionals.  The Software is intended to assist with product
design and is not a substitute for independent testing of product stress, safety and utility.  Due to the large variety of potential applications for the Soft-
ware, the Software has not been tested in all situations under which it may be used.  Visio Corporation shall not be liable in any manner whatsoever for
results obtained through the use of the Software.  You agree that you are solely responsible for determining whether the Software is appropriate in your
specific situation in order to achieve your intended results. You are also responsible for establishing the adequacy of independent procedures for testing
the reliability and accuracy of any items designed by using the Software.

THESE MATERIALS ARE PROVIDED “AS IS” WITHOUT WARRANTY OF ANY KIND.  TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW,
VISIO CORPORATION AND ITS SUPPLIERS DISCLAIM ANY AND ALL WARRANTIES AND CONDITIONS, EITHER EXPRESS OR IMPLIED, INCLUD-
ING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND NON-
INFRINGEMENT, AND THOSE ARISING OUT OF USAGE OF TRADE OR COURSE OF DEALING, CONCERNING THESE MATERIALS. 

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL VISIO CORPORATION OR ITS SUPPLIERS (OR THEIR
RESPECTIVE AGENTS, DIRECTORS, EMPLOYEES OR REPRESENTATIVES) BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT
LIMITATION, CONSEQUENTIAL, INCIDENTAL, DIRECT, INDIRECT, SPECIAL, ECONOMIC, PUNITIVE OR SIMILAR DAMAGES, OR DAMAGES FOR
LOSS OF BUSINESS PROFITS, LOSS OF GOODWILL, BUSINESS INTERRUPTION, COMPUTER FAILURE OR MALFUNCTION, LOSS OF BUSINESS
INFORMATION OR ANY AND ALL OTHER COMMERCIAL OR PECUNIARY DAMAGES OR LOSSES) ARISING OUT OF THE PURCHASE OR USE OF
THESE MATERIALS, HOWEVER CAUSED AND ON ANY LEGAL THEORY OF LIABILITY (WHETHER IN TORT, CONTRACT OR OTHERWISE), EVEN IF
VISIO CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY OTHER PARTY. Because some
jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.

Unless otherwise noted, all names of companies, products, street addresses, data, characters and persons contained in the Software or in these materials
are part of a completely fictitious scenario or scenarios, are designed solely to document the use of a Visio Corporation product, and are in no way
intended to represent any real individual, company, product or event.

Third-Party Technology Credits:

ImageStream Graphics Filters copyright © 1998 by INSO Corporation. All rights reserved. 

International CorrectSpell spelling correction system copyright © 1995 by Lernout & Hauspie Speech Products N.V. All rights reserved. 

Certain LZW graphics capability licensed from Unisys Corporation under U.S. Patent No. 4,558,302 and foreign counterparts.

Some of the clip art used in this product is derived from images copyrighted ©1988-1995 3G Graphics, Inc. from their IMAGES WITH IMPACT!® FOR
WINDOWS® Vol. 1. These images are used here under a non-exclusive licensing agreement between Visio Corporation and 3G Graphics , Inc., 114 Sec-
ond Avenue South, Suite 104, Edmonds, WA 98020, USA, (425) 774-3518 or (800) 456-0234.

Some of the maps incorporated into this product are extracted from data provided courtesy of Environmental Systems Research Institute, Inc., 380 New
York Street, Redlands, CA 92373-8100, USA, (909) 793-2853. 

Visio Corporation Trademarks: Visio, eVisio, SmartShapes, ShapeSheet, SmartConnectors, SmartLayers, Shape Explorer, the Visio logo, and Visio Corpo-
ration’s other marks, names and logos are the property of Visio Corporation and are either registered trademarks or trademarks of Visio Corporation in
the United States and/or other countries.  

Third-Party Trademarks: All other trademarks, trade names or company names referenced herein are used for identification only and are the property of
their respective owners. 

US Government Restricted Rights:  If used or acquired by the US Government, the US Government acknowledges that (a) the Software and these materials
constitute "commercial computer software" or "commercial computer software documentation" for purposes of 48 C.F.R. 12.212 and 48 C.F.R. 227.7202-3,
as applicable, and (b) the US Government's rights are limited to those specifically granted pursuant to the license agreement that accompanies or is
included with the Software and these materials.  The contractor/manufacturer is Visio Corporation, 2211 Elliott Avenue, Seattle, WA  98121-1691, USA. 

Visio Corporation 
2211 Elliott Avenue
Seattle
Washington  98121-1691
USA

Corporate telephone: (206) 956-6000 
Corporate fax: (206) 956-6001

Printed in USA. 
Part No. 14539-0899

Visio International Limited
European Operations

The Visio Building
1 Grand Canal Plaza

Grand Canal Street Upper
Dublin 4

Ireland

International telephone: +353 1 2464000
International fax: +353 1 2464001


	Contents
	Getting started
	Installing the Visio�2000 Technical Edition Test Drive
	Visio on the Web

	What’s new in Visio�2000
	Common tasks made easy
	For CAD users: Drawing in Visio�2000
	New and enhanced technical solutions

	Visio basics
	Starting a drawing
	Working with stencils and shapes
	Using 1-D and 2-D shapes
	Aligning shapes with the dynamic grid
	Using shape handles
	Moving and resizing shapes
	Quick editing with anchored windows
	Connecting shapes
	Adding and changing text
	Adding color and line styles to shapes
	Flipping and rotating shapes
	Grouping shapes
	Using background pages to display common page elements
	Saving and printing your drawings

	Creating your own shapes, stencils, styles, and templates
	Creating your own shapes
	Adding your own shapes to stencils
	Defining and editing styles
	Creating your own template
	Creating your own toolbars

	Drawing precisely
	Setting the drawing scale
	Setting measurement units
	Showing size by using dimension�lines
	Snapping to grids, guides, and guide�points
	Snapping to shapes
	Positioning shapes by using the dynamic grid
	Using the Snap & Glue toolbar
	Positioning shapes by using coordinates
	Panning and zooming drawings

	Working with CAD drawings
	Inserting CAD floor plans as background images
	Inserting CAD drawings as detail images
	Changing the scale of an inserted�drawing
	Hiding layers or levels
	Converting CAD drawings into Visio�format
	Converting Visio drawings into CAD�format

	Process Engineering: Drawing�PFDs�and�P&IDs
	Working in projects
	Starting a new project
	Creating PFDs and P&IDs
	Associating components in diagrams
	Modifying your diagrams
	Entering component data
	Numbering or tagging components
	Generating equipment, line, and valve�lists
	Creating your own datasheet
	Creating intelligent tags

	Facilities Management: Drawing facilities plans and tracking�assets
	Starting a facilities plan
	Creating a building shell
	Designating spaces
	Resizing spaces
	Assigning people to spaces
	Tracking data by using asset shapes
	Designating new tracking information
	Assigning a category to a shape
	Using data from existing databases
	Listing and locating assets in your facilities plan
	Tracking organizational data by using Visio CAFM Explorer

	Building Architecture: Drawing floor plans and site plans
	Drawing a space plan
	Starting a floor plan
	Drawing the building shell
	Adding doors, windows, and openings
	Measuring and dimensioning
	Additional architecture drawings

	Building Services: Drawing HVAC diagrams
	Using an existing floor plan

	Additional industry drawings
	Sharing your drawings with others
	Adding hyperlinks to drawings
	Converting drawings to HTML
	Routing your drawings for comments


