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Lab 1. iSeries Navigator setup

This lab explains how to set up iSeries Navigator.

Introduction
If you completed the Piloting DB2 UDB with iSeries Navigator in V5R2 lab, you do
not need to recreate the environment necessary to complete this lab. If this is the
case, you can proceed to Lab 2. Otherwise, you have to complete this lab to
create the necessary environment for these labs.

The notation XX that appears in library names, profile names, and so on refers to
your Team Number (for example, DBNAVXX, SAMPLEDBXX and LIBXX). Refer
to your lab worksheet for details.

Objectives
This lab teaches you how to:

• Create a sample Database (SAMPLEDBXX)
• Display the Database using iSeries Navigator
• Display the contents of the sample database using iSeries Navigator

Lab prerequisites
Before you begin this lab, be sure the following prerequisites are available:

• An IBM~ iSeries or AS/400e server with OS/400 V5R2, or higher, with:

– 5722-SS1 Option 12: Host Servers
– 5722-TC1: TCP/IP Connectivity Utilities

• A PC with iSeries Access for Windows V5R2M0 with the latest Service Pack
applied

• User profile DBNAVXX created in the iSeries server

Time required
The time required to efficiently complete this lab is 20 minutes.

Task 1: Getting connected

In this task, you create a connection definition from iSeries Navigator on your PC
to the iSeries server.

__ 1. If you have a connection to iSeries server using iSeries Navigator, go to
Task 2, ”Creating a sample schema (database)” on page 3.

__ 2. Double-click the iSeries Navigator icon on your desktop. If this is your first
time running this application, a message box appears stating that there are

As part of iSeries Navigator in V5R2, the SQL Script Center uses JDBC instead
of an ODBC connection to the server. Connection parameters used by JDBC
are similar to those used by ODBC.

Note
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no connections to the iSeries server. Click Yes. The Add iSeries
Connection dialog appears.

__ 3. In the iSeries server text box, enter I400WS. Click Next. The iSeries Signon
Information dialog appears as shown in Figure 1. Select the Use default
User ID, prompt as needed radio button. In the text box shown in Figure
1, enter DBNAVXX.

Figure 1. iSeries Signon Information

__ 4. Click Next. The Verify Connection dialog appears. Click the Verify
Connection button. Make sure that the host servers on the iSeries server
are up and running. Click OK and then click Finish.

__ 5. Right-click the My iSeries Connections object in the main iSeries
Navigator window. Select Add iSeries Connection. The Add iSeries
Connection - Welcome dialog appears.

__ 6. In the iSeries Navigator window, click the I400WS connection. A window
prompts you to enter a username and password as shown in Figure 2.
Consult your iSeries lab worksheet for your profile name and password.
When you are finished, click OK. Because this is the first time you are
signing on to the iSeries server, the system has to update iSeries Navigator
with its capabilities.

Figure 2. Signon to iSeries
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__ 7. Click the plus sign (+) in front of the Databases icon to expand it. Then
click the plus sign (+) in front of the Named Database icon (I400ws in this
case). The Libraries, Database Navigator, SQL Performance monitors, and
Transactions options appear in the expanded list as shown in Figure 3.

Figure 3. Main iSeries Navigator panel

In iSeries Navigator, there are three places from which to access the functions for
an object:

• The File menu
• An icon from the toolbar
• An object’s right-click menu

In the remaining labs, use the right-click menu to access these functions.

Task 2: Creating a sample schema (database)

In this task, you run a system-provided stored procedure to create a sample
schema (database) from which to work:

__ 1. If you already created a sample schema SAMPLEDBxx, go to Task 3,
”Displaying properties and descriptions of DB objects” on page 5.

You see a different name for the Named Database icon if you let the
system create it automatically.

Note
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__ 2. Invoke the SQL Script Center by right-clicking the Database Name
(I400WS icon under your Databases icon). Select Run SQL Scripts. A
new Run SQL Scripts window appears.

__ 3. Click the Options menu item and select the following items (one at a time)
as shown in Figure 4:

• Stop on Error
• Smart Statement Selection
• Run Statement on Double-Click

Figure 4. Run SQL Scripts: Options menu item

__ 4. Invoke the V5R2-supplied stored procedure that creates a sample
database that you use in subsequent tasks. In the SQL statement working
area, type the following statement:

CALL QSYS.CREATE_SQL_SAMPLE(’SAMPLEDBXX’);

Be sure to replace XX with your team number.

__ 5. Move the text cursor anywhere into the statement and double-click to run it.
Watch the Messages tab for a completion notification informing you that
you have a sample database with which to work.

If an error message appears, notify your lab supervisor.

You now have a sample database to use during the next lab.

__ 6. Close the Run SQL Script window.

When the Smart Statement Selection option is selected, all highlighted
SQL statements run in sequence. If this option is not selected, the
highlighted SQL statements are executed as a single statement. This
option also ensures that complete statements are run even if one or
more statements are only partially highlighted.

Note

Always type a semicolon (;) at the end of every SQL statement so the
Smart Statement Selection feature knows where each statement ends.

Note
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Task 3: Displaying properties and descriptions of DB objects

In this task, you use iSeries Navigator to explore the sample database that you
created in the previous task:

__ 1. In the left panel of the main iSeries Navigator window, click the plus (+)
sign next to the Database icon.

__ 2. Right-click the Libraries icon and select Select Libraries to Display from
the pop-up context menu as shown in Figure 5. The Select Libraries to
Display window appears.

Figure 5. Select Libraries to Display to include iSeries Navigator

__ 3. In the Enter Libraries input field, type SAMPLEDBXX and click Add as shown in
Figure 6. The SAMPLEDBXX library is added to the list in the right panel of
the window. Click the OK button.

Be sure to replace XX with your team number.
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Figure 6. Select Libraries to Display window

__ 4. Right-click your SAMPLEDBXX library and select Properties. A new
SAMPLEDBXX Properties window appears.

__ 5. Explore the information in this window and answer the following questions:

• How large is this library? _____________ megabytes

Hint: General->Total allocated size

• How many objects are in this library? ___________

Hint: Storage->Contents

• When was this library last-saved? ____________

Hint: Save->Last saved

• When was this library created? By whom? ________________

Hint: Creation->Created

Click OK when you are finished.

__ 6. Double-click your SAMPLEDBXX library to see all the database objects of
this library displayed in the right panel.

__ 7. Locate and right-click the EMPLOYEE table. Select Description. This
option is a new function added in V4R5. A new Description window
appears with six different information tabs.

This option is used in the same manner as the CL commands Display File
Description (DSPFD), Change Physical File (CHGPF), and Change Logical
File (CHGLF).

Click each different tab and then click Help to see detailed information of
all table description attributes in the corresponding tab that you are in.

__ 8. Explore the information in this window and answer the following questions:

• How large is this table? _____________ kilobytes

• How many rows are in this table? ____________

• Is the Reuse deleted rows feature active? ____________
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Hint: General Tab

• How many bytes is the longest row in this table? ____________ bytes

Hint: Details->Maximum row length

Click OK when you are finished.

__ 9. In the previous step, you found that there are two indexes built for the
EMPLOYEE table. How do you identify its indexes?

Hint: Right-click the EMPLOYEE table and select Properties. Find the
correct tab that shows you this information.

Click the Indexes tab. Two index names (XEMP1 and XEMP2) appear.
Click OK when you are finished.

__ 10.Click OK to go back to the iSeries Navigator main window. Locate and
right-click the VEMPDPT1 view. Select Description.

__ 11.Click the Details tab and note the Allowed activities attribute. Why is it
read-only? Notice the check mark in front of Read, while there is none for
Update, Write, and Delete. Why is this?

Click OK when you are finished.

Normally, a joined view is a read-only object. You can prove that
VEMPDPT1 is a joined view by right-clicking VEMPDPT1 and selecting
Properties. The SQL DDL statement that joins DEPARTMENT and
EMPLOYEE tables appears. Click OK when you are finished.

At this point, you are ready to run the second lab, which introduces a new feature
called Database Navigator (included with iSeries Navigator in V5R2).

You have now completed this lab!
7
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Lab 2. Database Navigator: General tasks

This lab outlines some of the general tasks that are available with Database
Navigator.

Introduction
Database Navigator enables you to visually depict the relationship of database
objects on your system. The visual depiction you create for your database is
called a Database Navigator Map. In essence, the Database Navigator Map is a
"snapshot" of your database and the relationships that exist between all of the
objects in the database.

Using iSeries Navigator, you can explore the complex relationships of your
database objects using graphical representations that present the tables in your
database and the relationship between tables, indexes, and constraints that are
attached to tables. After you connect to your system, you can use iSeries
Navigator to:

• Generate a map of a set of tables and the relationships between them.

• Manipulate the map to show items of interest, without changing objects on the
system.

• Generate SQL for all the objects in the map.

• Print maps.

• Save maps and view them later.

In this lab, you use the example database SAMPLEDBXX. Remember that XX in
library names, profile names, and so on refers to your team number (for example,
DBNAVXX). Refer to your lab worksheet for details.

Objectives
This lab teaches you how to:

• Generate a MAP from some tables and view the relationship between such
database objects as tables, views, indexes, referential constraints, and
primary keys

• Add Primary Key Constraints

• Zoom and Arrange objects

• Save the MAP

Lab prerequisites
Before you begin this lab, be sure the following prerequisites are available:

• An IBM~ iSeries or AS/400 server with OS/400 V5R2, or higher, with:

– 5722-SS1: Host Servers
– 5722-TC1: TCP/IP Connectivity Utilities

• Client Access Express V5R2M0 with the latest Service Pack applied

• Sample Database SAMPLEDBXX created
© Copyright IBM Corp. 2002. All rights reserved. 9



Time required
The time required to efficiently complete this lab is 30 minutes.

Task 1: Creating the Database Navigator Map

In this lab, you create your first Database Navigator Map and work with the
components. You also learn general navigation operations using the map.

__ 1. In the Navigator window, click the I400WS connection. A window prompts
you to enter a username and password as shown in Figure 7. Consult your
lab worksheet for your profile name and password. When you are finished,
click OK. Because this may be your first time signing on to the iSeries
server, the system has to update Navigator with its capabilities.

Figure 7. iSeries Sign on information

__ 2. Click the plus (+) sign next to the Database icon to expand it. The
Libraries, Database Navigator, and SQL Performance Monitor functions
should appear in the expanded list as shown in Figure 8.

__ 3. Click the Database Navigator icon. All of the existing maps on the iSeries
or AS/400 server should appear as shown in Figure 8.
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Figure 8. Database Navigator option

__ 4. Click the plus sign (+) sign in front of the Libraries icon to expand the
Navigator library list.

__ 5. Check whether your SAMPLEDBXX library is included in the list. If it does
not exist, change the iSeries Navigator Library List to include it. Refer to
step 2 in Task 3, ”Displaying properties and descriptions of DB objects” on
page 5, in Lab 1.

__ 6. Right-click the Database Navigator object and select New to create your
Map as shown in Figure 9. A new Database Navigator window appears as
shown in Figure 10 on page 14.
11



Figure 9. Selecting New to build a new map
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__ 7. The iSeries Navigator library list appears in the left side of the Database
Navigator Window. Double-click your SAMPLEDBXX library to expand the
objects (XX is your team number) as shown in Figure 10.

__ 8. Double-click Tables in the Locator Pane to expand all the tables in a
database.

__ 9. Double-click the EMPLOYEE table on the lower Locator Pane to start
building a map. This table is added to the map and all its related objects.

The primary workspace for Database Navigator is a window that is
divided into four main areas. These four areas allow you to find the
objects to include in a map, show and hide items in a map, view the map,
and check the status of pending changes for a map. The following list
briefly describes the main areas of the database navigator window:

• Locator Pane: The Locator Pane is located on the left side of the
Database Navigator window. It is used to find the objects that you
want to include in your new map or to locate objects that are part of
an open map. The upper Location Pane is a search facility that can
be used to specify the Name, Type, and Library of the objects that
you want to include in the map. The results of the search are
displayed in the lower Locator Pane under the Library Tree and
Library Table tabs.

• Map Pane: The Map Pane is located on the right side of the Database
Navigator window. It graphically displays the database objects and
their relationships.

• Object Status Bar: The Object Status Bar is located on the bottom
left of the Database Navigator window. It displays the number of
visible and eligible objects in the map.

• Action Status Bar: The Action Status Bar is located on the bottom
center of the Database Navigator window. It provides a clear
description of what has taken place in the map and whether
modifications are pending.

• Modification Status Bar: The Modification Status Bar indicates
whether a modification has been made or is pending.

Exploring the Database Navigator window
13



Figure 10. Selecting a database to build a map

The Map is built from the cross reference files (XREF) on the iSeries. The
relationship and statistics are based from the table that you selected to
generate a map as shown in Figure 11.

Upper Locator Pane

Lower Locator Pane
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Figure 11. Building a Database Navigator Map

__ 10.Click the minus (-) sign next to the SAMPLEDBXX database object to
collapse the tree view.

__ 11.Use the vertical and horizontal scroll bars to navigate the map. Use the
Zoom icons on the toolbar to zoom in and zoom out the MAP as shown in
Figure 12.
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Figure 12. Database Navigator Map

The default view of a map only shows tables and referential constraints.

__ 12.Click Options and select the User Preferences option to open a new
window to include or remove the defaults user preferences as shown in
Figure 13.

Figure 13. Viewing or Changing the user preference for Database Navigator Map
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__ 13.You can see that the User Preference window shows you the various
objects that may be included on the map, click OK to return to Database
Navigator Map as shown in Figure 14.

Figure 14. Database Navigator user preference

The map is generated based on default user references. In V5R2, support for
Trigger objects in the MAP was added. You can change the default option to
remove or add extra objects.

Task 2: General tasks using the Database Navigator window

In this task, you select some general functions on the Locator Pane on the left
side of the Database Navigator to find and include objects in the map that are part
of an open map.

__ 1. Use the criteria selection in the Upper Locator Pane to select only your
SAMPLEDBXX library. Click and select the library parameter as shown in
Figure 15.

__ 2. Click the Search button to execute. The result is shown on the bottom
pane, under the Library Tree and Library Tables tabs.

When you open your database, the default search process is the list of
libraries on the iSeries Navigator window. Therefore, you always can see
the list of libraries on the Library Tree tabs.

Note
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Figure 15. Search criteria on the locator pane

__ 3. Click the plus (+) sign next to your SAMPLEDBXX database on the Lower
location Pane to show the objects found, such as Tables, Indexes, and
Views.

__ 4. Click the (+) sign next to the Tables database object to expand it.

__ 5. All of the tables in the map should appear as shown in Figure 16. Do an
advanced search using the criteria selection in the Upper Location Pane to
select all tables that begin with the literal ‘EMP’.
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Figure 16. Using the Locator pane

__ 6. In the Name input field, type EMP*. In the Type input field, select Table as
shown in Figure 17.

__ 7. Click Search to execute. The search results are shown on the bottom pane
under the Library Tree and Library Tables tabs.
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Figure 17. Advance search using the Locator pane

__ 8. Use the criteria selection again to show all of the tables on the Lower
Location Pane. Click in the Name input field and select All names to view
all of the tables in the schema. Click the Search button. In the next step,
you use the Find objects in the map function.

__ 9. Right-click the PROJECT table from the list of tables and select the Find in
Map option to find this table in the map as shown in Figure 18.
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Figure 18. Selecting a specific object to locate in a map

__ 10.Move the pointer over the PROJECT table on the map. The general
description about it (flyover window) should appear as shown in Figure 19.

__ 11.Use the criteria selection again to show the tables, Indexes and views on
the Lower Location pane. Click in the Type field and select All types. Click
the Search button.
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Figure 19. Locate specific object in a map

You can see the Object Status bar at the bottom left of the Database
Navigator window as shown in Figure 20. This displays the number of
visible and eligible objects in the map. As shown in Figure 20, only 23 of 68
objects qualify as eligible objects and are included on the map. This is
because only the tables and constraints are included in the map.

Figure 20. Status bar code

__ 12.Select the Library Table tab on the Locator Pane to show the complete list
of tables, indexes, and views on the database selected as shown in Figure
21.
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__ 13.Use the vertical and horizontal scroll bars to view all of the objects in the
Library Table list.

__ 14.Click Objects In Map in the lower locator pane and a list of objects in the
map should appear. Only the selected objects in the list are included in a
MAP.

__ 15.Click the Type tab on the Object In Map field to organize the objects by
Type.

__ 16.Use the vertical and horizontal scroll bars to search the index objects in the
Objects In Map list.

__ 17.Select all of the indexes (one by one) in the list to include them in a map.

Figure 21. Including a new object in a map

Each time you select an index or another object from the Library Table, the
map and the Status bar message is updated.

__ 18.Right-click in a free space on the Map Pane in the Database Navigator
window.

__ 19.Select Zoom and then select the To Fit Window option to fit the map in the
window as shown in Figure 22.
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Figure 22. Selecting To Fit Window

You can see all objects in the current window as shown in Figure 23.

When the objects are shown under the Library Tree and Library Table tabs,
you can also add objects to the map by right-clicking an object and
selecting Add to Map, or double-clicking the object name.
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Figure 23. Sizing a map to fit the display window

Notice the Object Status Bar in the bottom left of the Database Navigator
window. This displays the number of visible objects in the map of the total
found.

__ 20.Click File and select Save As... to save the Map.

__ 21.From the Save As... window, click the Libraries parameter and select your
SAMPLEDBXX library.

__ 22.In the Name input field (Figure 24), type:

SAMPLEDBMAPXX

__ 23.In the Description input field (Figure 24), type:

’MAP created by DBNAVXX’

__ 24. Click OK to save your map.
25



Figure 24. Saving the database map

Task 3: General task using print capability to print a MAP

In this task, you select some general functions on the Locator Pane on the left
side of the Database Navigator. These functions help to find and include objects
in the map that are part of an open map. You also select the print options to setup
different ways to print a MAP.

__ 1. Click Objects In Map in the lower locator pane, and a list of objects in the
map should appear. Only the selected objects in the list are included in a
MAP.

__ 2. Click the Type tab on the Object In Map field to organize the objects by
Type.

__ 3. Use the vertical and horizontal scroll bars to search the index objects in the
Objects In Map list.

__ 4. Select all objects (one by one) in the list to include them in a map.

__ 5. Right-click in a free space on the Map Pane in the Database Navigator
window.

__ 6. Click Zoom and then select the To Fit Window option to fit the map in the
window. Now you can see all the objects included in a MAP.

You can see the Object Status bar at the bottom left of the Database
Navigator window as shown in Figure 20 on page 22. This displays the
number of visible and eligible objects in the map. As shown in Figure 25, 68
of 68 objects in the map are available.

The Database Navigator Maps are stored on the iSeries server. After you open
a Database Navigator Map, it is locked from other users to prevent conflicts
where other users try to update the same map at the same time.

Note
26 Database Navigator and Generate SQL in DB2 UDB for iSeries on V5R2



Figure 25. Including all objects in a map

Each time you select an index or another object from the Library Table, the
map and the Status bar message is updated.

__ 7. Click File and select Print Preview to open a new window to preview and
customize different options to print a MAP as shown in Figure 26.
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Figure 26. Selecting the Print Preview option

__ 8. Click Print Setup to customize the printout to be on 2 x 2 matrix (two lines
by two columns).

__ 9. Select Print Entire Graph. On Scale Box, select Pages to print the output
across several pages.

__ 10.In the Page Columns input field, type 2.

__ 11.In the Page Rows input field, type 2 as shown in Figure 27.

Figure 27. Printing map using Scale by Page
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__ 12.Click OK to see your map split on a 2 by 2 matrix as shown in Figure 28.

Figure 28. Printing a Map using Scale by Page

With this option, you can split your map across many pages to see the
entire object in a Map.

__ 13.If a printer is available in the Lab, click the Print button and select the
printer to print your Map. Otherwise, click close to return a Database
Navigator Windows.

__ 14.Click File and select Print Preview to open a new window to preview.
Customize the Scale by Actual size option to print a MAP.

__ 15.Click Print Setup... to customize the printout automatically based on the
number objects in a map.

__ 16.Select Print Entire Graph. On Scale Box, select Actual Size to set the
printout to print automatically as shown in Figure 29.
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Figure 29. Printing using Actual Size Scale

__ 17.In the Caption section, replace the name Untitled with Project Database MAP

(try now to enter a title for the printer map).

__ 18.Click Position and select Top left option.

__ 19.Click Font button to customize printout to automatically print based on the
number objects in a map.

__ 20.On the Choose Font window, select the font ScanSerif Bold and size 18
as shown in Figure 30.

Figure 30. Choose Font window

__ 21.Click OK to return printer setup see your preview printing Map as shown in
Figure 31.
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Figure 31. Printing using Actual Size scale

__ 22.If you a printer is available in the Lab, click the Print button. Then select
the printer to print your map. Otherwise, click close to return to the
Database Navigator window.

You have now completed this lab!

On V5R2, the print options have been enhanced to provide different
options to print MAP. This gives the user good documentation about the
logical design of the database.

Note
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Lab 3. Changing the Database Navigator Map

The lab explains how to change a Database Navigator Map.

Introduction
This exercise teaches you how to manage a Database Navigator Map,
manipulate the map, and show specific objects in the map (this includes showing
you the different alternatives for including objects such as views, remove objects,
change object placement, and so on). In this lab, you manipulate the map in more
detail and you use a mix function from the menu bar and toolbar.

You use the SAMPLEDBXX example database. Remember, XX in library names,
profile names, and so on refers to your team number (for example, DBNAVXX).
Refer to your lab worksheet for details.

Objectives
This lab teaches you how to:

• Add Views, Primary Key Constraints, etc., that exist on the iSeries server but
that are not included in the Database Navigator Map

• View a different Map layouts: Symmetric (default), Circular, and hierarchic
design

• Analyze a map relationship for a specific object

• Remove objects from the map

• Change object placement in the map

• Create a user-defined relationship (UDR)

• Expand and collapse tables in a map

• Save the map

Lab prerequisites
Before you begin this lab, be sure the following prerequisites are available:

• An IBM~ iSeries or AS/400 server with OS/400 V5R2, or higher, with:

– 5722-SS1: Host Servers
– 5722-TC1: TCP/IP Connectivity Utilities

• Client Access Express V5R2M0 with the latest Service Pack applied

• Sample Database SAMPLEDBXX created

• Sample Database Navigator Map SAMPLEDBMAPXX created

In the Database Navigator Map window, there are two places from which to
access map functions. You can use either the File menu or an icon from the
toolbar. For a specific object, use the right-click menu. In the remaining labs,
the right-click menu is used to access these functions.

Note
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Time required
The time required to efficiently complete this lab is 30 minutes.

Task 1: Selecting the Database Navigator Map

In this task, you select the map that you want to manage:

__ 1. Click the plus (+) sign next to the database object to expand the different
options.

__ 2. Click the Database Navigator to display the maps in the right panel that
exist on the iSeries server as shown in Figure 32.

Figure 32. Opening the Database Navigator Map

__ 3. Double-click the Database Map that you created in Lab 2, “Database
Navigator: General tasks” on page 9, to open it. If it does not appear,
refresh the window.

__ 4. Click View. From the pull-down menu, select Zoom-> To Fit Window to fit
all objects on the map in this window as shown in Figure 33.
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Figure 33. Fitting all objects in a map

__ 5. Use the toolbar to select the icons Zoom In, Zoom Out, and Zoom to fit
for the object size on the map in this window as shown in Figure 34. It also
shows the different options that are available on the toolbar.

Figure 34. Toolbar options

__ 6. Use the vertical and horizontal scroll bars to navigate to the top of the map.

__ 7. You can see the Objects Status Bar in the bottom left of the Database
Navigator window. This displays the number of visible objects in the map
and the total found. Write the number of visible objects in the Map: ______.

Task 2: Adding views in the map

__ 1. Click View-> Show Objects of Type-> Views to include all Views in the
map as shown in Figure 35. In the bottom left of the Database Navigator
window, the Object Status Bar that was updated with the new objects
included in the map appears.

Zoom Icons

Adjust Icons

Aliases

Primary Key Constraints

Check Constraints

Views

Indexes

Overview Window
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Figure 35. Selecting the Views object type to appear in the Map

__ 2. Write the number of visible objects in the Map: _______

__ 3. Use the toolbar to select the Zoom icons (including Zoom in, Zoom Out
and Zoom to fit Window) to fit all objects on the map in this window.

__ 4. Use the vertical and horizontal scroll bars to navigate to the top of the map
as shown in Figure 36.

You can change the zoom level of the Database Navigator Map to manage how
much of the map you can see in the map pane on the Database Navigator
window.
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Figure 36. Using scroll bars to navigate to the top of the map

Task 3: Showing the relationships of a specific object

__ 1. Use the criteria selection in the locator pane to select only your
SAMPLEDBXX library. Click the Library parameter and select your
SAMPLEDBXX library.

__ 2. Click the Search button.

__ 3. Click the plus (+) sign next your SAMPLEDBXX database to expand the
objects for Tables, Indexes, and Views.

__ 4. Click the (+) sign next to the Tables database object to expand it.

__ 5. Double-click the PROJECT table from the list of tables to find this table in a
map.

__ 6. Click the zoom icons (Zoom in, Zoom Out, and Zoom to fit window) in
the toolbar to focus the PROJECT table in the map pane.

__ 7. Use the vertical and horizontal scroll bars to navigate and focus on every
relationship object of the PROJECT table as shown in Figure 37.
37



Figure 37. Fitting the object in a map

__ 8. Place the cursor over every relationship to view a brief description (Object
Name and Type of Relationship) and fill in Table 1 with all the relationships
of the Project table.

Table 1. Relationship objects

Original table Relationship object name Type of relationship

Project
38 Database Navigator and Generate SQL in DB2 UDB for iSeries on V5R2



Task 4: Removing objects from the map using the toolbar

__ 1. Click the Index and Views icons on the toolbar to remove indexes and
views from the map as shown in Figure 38.

__ 2. Click the zoom icons (Zoom in, Zoom Out, and Zoom to fit window) from
the toolbar to fit the objects in a Database Navigator window.

__ 3. Use the vertical and horizontal scroll bars to navigate to the top of the map
on the Database Navigator window.

__ 4. Write the number of visible object in the Map: _______

Figure 38. Removing objects from the map

__ 5. Click File-> Save to save the changes in the map.

Task 5: Changing object placement and arranging objects in a map

In this task, you learn how to arrange and move objects in the map. You also
learn how to remove the bends that appear on the relationship lines after the
object is moved to the new location.

__ 1. Double-click the EMPLOYEE table from the list of tables to find this table in
the map.

__ 2. Click the zoom icon options in the toolbar to see all of the objects in the
map pane.
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__ 3. Use the vertical and horizontal scroll bars to navigate on the Map on the
Database Navigator Windows.

__ 4. Drag-and-drop the EMPLOYEE table to the left as shown in Figure 39.

Figure 39. Changing object placement

__ 5. Repeat steps 2, 3, and 4 to move the DEPARTMENT table to the right.

A window similar to the example in Figure 40 appears.
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Figure 40. Moving the Department object in a map

When objects are moved or added to a map, you usually use the Arrange
function to reorganize the Map in Map Pane.

__ 6. Right-click in a free space on the map pane in the Database Navigator
window. The Arrange function appears.

__ 7. Select Arrange to chose the Symmetric (default) option to put the Map in
its original state as shown in Figure 41.

The arrange option was enhancement in V5R2 to provide additional Map
layout: Circular, Hierarchic, and Symmetric (default). The Arrange layout
option puts the map in the Default state.

Arrange option
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Figure 41. Selecting the Symmetric layout option

__ 8. Use the icons in the toolbar in the Database Navigator windows to include
the Indexes, Views, and Primary Key Constrained to gain a good view of
different layout Maps.

__ 9. Click the zoom icons (Zoom in, Zoom Out, and Zoom to fit window) from
the toolbar to fit the objects in a Database Navigator window.

__ 10.Use the scroll bar to go to the top of the map. You can see the Symmetric
(Default) layout as shown in Figure 42.
42 Database Navigator and Generate SQL in DB2 UDB for iSeries on V5R2



Figure 42. Symmetric (Default) layout or the map

__ 11.Right-click in a free space on the Map Pane in the Database Navigator
windows.

__ 12.Select Arrange and then select the Circular option to see the Circular
layout as shown in Figure 43.

__ 13.Repeat steps 11 and 12 to see the Hierarchic layout map and then return to
the Symmetric (Default) layout.

__ 14.Use the icons in the toolbar in the Database Navigator windows to remove
the Indexes, Views, and Primary Key Constrained.

__ 15.Click File-> Save to save the changes in the map.
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Figure 43. Circular layout of the map

Task 6: Expanding and collapsing a table object

This task shows you how to expand a table icon in your Database Navigator Map.
This allows you to view essential data about the table. The data that appears in
the expanded table is a subset of the data you can see in Table Properties.

__ 1. Double-click the PROJACT table from the list of tables to find this table in
the map.

__ 2. Click the Zoom Icons in the toolbar to see all the objects in the map pane.

__ 3. Right-click the PROJACT table on the Database Navigator window and
select Expand as shown in Figure 44.
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Figure 44. Selecting the Expand table option in a map

__ 4. Resize the PROJACT table to increase the size as shown in Figure 45.
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Figure 45. Expanding the table in a map

__ 5. Click the Columns tab on the table.

__ 6. Use the cursor to widen the header of the second column on the column
table. This column contains the fields that comprise the primary key (if any)
for this table.

__ 7. Fill in Table 2, in the correct order, with the columns that have a primary
key on them.

__ 8. Click the Indexes tab on the table.

__ 9. Use the vertical and horizontal scroll bars to view the Indexes.

__ 10.Enter the Index Name in the following field and, in the correct order, fill in
Table 2 with the columns that include an index.

Index Name: _____________________

Table 2. Primary Key and Indexes

Table Primary key columns Index columns

PROJACT
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__ 11.Right-click the PROJACT table and select the Collapse function to
compress the table to its original size in the map (iconify the table) as
shown in Figure 46.

__ 12.Click File-> Save to save the changes in the map.

Figure 46. Collapsing the table in the map

You can now see the entire map in the Database Navigator window.

Task 7: Creating a user-defined relationship (UDR)

In this task, you to create a user-defined relationship in a map.

__ 1. Right-click in a free space on the map pane in the Database Navigator
window. Select the Create function as shown in Figure 47.

__ 2. Select Create-> User Defined Relationship to create the new object
(UDR).

When you have a relationship that is defined by your program, you can create
a user-defined relationship. An example of this is when the referential integrity
is controlled by the application and is not defined in the database.

User-defined relationship
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Figure 47. Selecting the function to create a User Defined Relationship

__ 3. In the Name input field, type SAMPLEUDRXX. In the Description field, type ’UDR

created by DBNAVXX’ as shown in Figure 48.

__ 4. Click Type on the Select Object in Relationship to organize the objects by
type.

__ 5. Select the PROJECT and DEPARTMENT tables from the list of objects.

__ 6. Select Square for Shape and Blue for Color for this relationship.

It is important to provide a meaningful description for your user-defined
relationship since it is the only way for you to indicate what the
user-defined relationship represents.

Important
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Figure 48. Creating a user-defined relationship

__ 7. Click OK to create the user-defined relationship and return to the map.

__ 8. Click the zoom icons in the toolbar to see all the objects in the map pane
(Figure 49).

__ 9. Click File-> Save to save the changes in the map.
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Figure 49. The user-defined relationship in a map

Task 8: Overview window function

The Overview window is a small window that shows the map on a reduced scale.
It has a highlighted area that represents the parts of the image that are currently
displayed in the main window.

In the Overview window, you can move to specific areas of the map by
right-clicking the highlighted area and moving the highlighted area to the area you
want to view.

This task shows you to how to view the map in the Overview window and invoke
the both function from the toolbar and the view menu. You add the Indexes,
Views, Primary Key Constraints, and Check Constraints to gain a better idea of
how this function is useful.

__ 1. Use the icons in the toolbar in the Database Navigator window to include
the Indexes, Views, Primary Key Constraints, and Check Constraints.

__ 2. Click the zoom icons in the toolbar to see all the objects in the map pane.

__ 3. Use the scroll bar to go to the top of the map as shown in Figure 50.
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Figure 50. Adding objects in the map

__ 4. Click the Show Overview Window icon in the toolbar to open the
Overview window as shown in Figure 51.

Figure 51. Overview window

__ 5. Click the highlighted area and move the blue box to the right of the
Overview window as shown in Figure 52.
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Figure 52. Moving the Overview window

The map pane should include a highlighted part of the map on the
Overview window as shown in Figure 53.

Figure 53. A map using the Overview window

The Overview window contains all of the objects in the map. You can move
to specific areas of the map by moving the highlighted area to the area you
want to view. In addition, you can reduce or widen the highlighted area to
include a specific area.

__ 6. Close the Overview window and the Database Navigator window.

You have now completed this lab!
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Lab 4. Generating SQL using iSeries Navigator

This lab explains how to generate the SQL statements from existing database
objects via iSeries Navigator. This process is often referred to as Reverse
Engineering.

The notation XX that appears in library names, profile names, directories in your
PC, and so on refers to your team number.

Objectives
This lab teaches you how to:

• Generate SQL statements from a map
• Generate SQL statements from an object in a Library
• Save the SQL Script in a Database Source File and PC file

Lab prerequisites
Before you begin this lab, be sure the following prerequisites are available:

• An IBM~ iSeries or AS/400 server with OS/400 V5R2, or higher, with:

– 5722-SS1: Host Servers
– 5722-TC1: TCP/IP Connectivity Utilities

• Client Access Express, V5R2M0, with the latest Service Pack applied

• You must have completed Lab 1, “iSeries Navigator setup” on page 1, before
generating the SAMPLEDBXX sample database.

• You must have completed Lab 2, “Database Navigator: General tasks” on
page 9, to generate the SAMPLEDBMAPXX map used in this lab.

• You must have completed Lab 3, “Changing the Database Navigator Map” on
page 33, to obtain the necessary skills.

• The DDSLIBXX library must be available because it contains the physical and
logical files created with DDS.

Time required
The time required to efficiently complete this lab is 60 minutes.

Introduction
The new Generate SQL function for iSeries Navigator provides a GUI interface
that allows you to reverse engineer several types of database objects. The results
are SQL create statements (often referred as DDL statements).

After you select one or more objects to be reverse engineered, you have the
option to view the resulting SQL in the Run SQL Scripts Dialog. Or, it can be
saved to a file on the PC or a Source physical file on the iSeries server.

The new Generate SQL Database Object supports the following objects:

• Aliases
• Distinct types
• Functions
• Indexes
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• Procedures
• Schemas (Collections) and libraries
• Tables and Physical files
• Views and logical files

Task 1: Generating SQL from the library in the iSeries Navigator window

In this task, you learn how to invoke the Generate SQL option from your
SAMPLEDBXX library in the iSeries Navigator window to generate the SQL DDL
statement for some objects:

__ 1. Start iSeries Navigator and expand Database-> I400WS-> Libraries.

You should see the SAMPLEDBXX library in the active library list under the
Libraries icon. If not, add it by right-clicking Libraries and select Select
Libraries to Display. Refer to Task 3, ”Displaying properties and
descriptions of DB objects” on page 5, in Lab 1, for information on how to
do this.

__ 2. Click the SAMPLEDBXX library to display the current content in the right
window panel.

__ 3. Click Type in the right window panel to organize all objects.

__ 4. Use the scroll bar to show the Table objects.

__ 5. Press the Ctrl key on the right panel, and locate and select the following
tables:

• ACT
• CL_SCHED
• DEPARTMENT
• EMP_PHOTO
• EMP_RESUME
• EMPLOYEE

__ 6. Right-click and select Generate SQL as shown in Figure 54.
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Figure 54. Selecting objects from the library to generate SQL

When the Generate SQL function is invoked, the new Generate SQL
window appears as shown in Figure 55. This window provides a list of the
objects initially selected and the Output, Options, and Format tabs that are
used for the generated SQL.
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Figure 55. Generate SQL window

__ 7. In the Generate SQL window, click the Output, Options, and Format tabs
to see and accept the default values. Explore the information in this
window and answer the following questions:

• Where will it Generate SQL? _______________________________
• Which is the Standards Option? ______________________
• Which is the Naming Convention? ______________________

__ 8. Click Generate to accept the default values as shown in Figure 56.

The initial list of objects in the Generate SQL window could be modified
using the Add and Remove buttons to add new objects or remove
objects from the initial list.

Note
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Figure 56. Generating SQL statements

__ 9. Switch to the new Run SQL Scripts window to see the generated SQL
statement. Use the scroll bar to navigate as shown in Figure 57.
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Figure 57. SQL generated in the Run SQL Scripts window

__ 10.After the Run SQL Scripts window is created, explain the reasons for the
ALTER table statements to be added to the create table window.

__ 11.Click File-> Save As... to save the SQL script as shown in Figure 58.

You can generate SQL for a Schema, Table, Type, View, Procedure
Function, Alias, and Index. When you generate SQL for a table that
contains constraints or triggers associated with it, the SQL Generate is
generated for those as well.

Note
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Figure 58. Saving the Script SQL

__ 12.A Save window appears. Click Look in to select your directory
(C:\DBNAV\SQLScript) from the pull-down menu to save your file as shown
in Figure 59.

__ 13.In the File name input field, type GENSQLXX1. In the Files of type input field,
leave the default as SQL files(.SQL) as shown in Figure 59.

You can use the SQL file to replicate your Database files on another
system (for example, a development system). On the GENSQLXXn file
name, the XX refers a your team number and the n is a sequential number.

__ 14. Click Save to save the SQL script file.

Figure 59. Saving the SQL script
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__ 15.Click File-> Exit to close the Run SQL Script window.

Task 2: Generating SQL to PC and data source files on the iSeries server

In this task, you generate the SQL statements to a PC file and to a source
member on the iSeries server. You start by generating all the SQL statements of
all the objects in your library from the iSeries Navigator window:

__ 1. Click the SAMPLEDBXX library to display its content in the right window
panel.

__ 2. Right-click the SAMPLEDBXX library and then select Generate SQL as
shown in Figure 60.

Figure 60. Generate SQL library in the Operation Navigator window

__ 3. In the Generate SQL window, select the Write to file option on the Output
tab as shown in Figure 61. The generated SQL is saved to a PC file.
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Figure 61. Selecting Generate SQL to PC

__ 4. Click File type and select the PC file option.

__ 5. In the Location file, click Browse, and then select your directory
(C:\DBNAV\SQLScript) to save your file.

__ 6. In the File name input field, type GENSQLXX2.SQL In the Files of type input
field, leave the default SQL files (.SQL) as shown in Figure 62.

__ 7. Click the Select button to return to the Generate SQL Output tab.

Figure 62. Saving the SQL script to PC file
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__ 8. Click the Generate button to start generating the SQL DDL statements for
all the objects in the library.

A status window appears showing the progress of the generate SQL as a
percentage as shown in Figure 63.

Figure 63. Generating SQL window

__ 9. In the iSeries Navigator window, click the Run an SQL script icon in the
database task pad. Explore the SQL file saved previously as shown in
Figure 64.

Figure 64. Selecting Run SQL script from the Taskpad option

__ 10.In the Run SQL scripts window, click File-> Open to open your SQL Script
file (GENSQLXX2).

The task pad (located in the lower part of the iSeries Navigator window)
was introduced in V5R1. If you click the various higher level options,
such as Security, Users and Groups, Database, etc., this task pad
changes accordingly. One of the database tasks of the task pad is Run
an SQL Script (among others).

Note
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__ 11.Click Look in and select your directory (C:\DBNAV\SQLScript) from the
pull-down menu to save your file.

__ 12.Select your GENSQLXX2 file and click the Open button as shown in Figure
65.

Figure 65. Restoring an SQL script file from a PC

__ 13.View the SQL statements generated on the Run SQL Script window as
shown in Figure 66. Take some time to analyze the order of the statements.

Once the statements are generated, they can be edited to, for example,
create a new copy in another library and optionally saved, or run using the
SQL Script facility. If multiple objects were selected to be SQL Generated,
you have the option to run one, some, or all of the statements after any
required editing.
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Figure 66. SQL Script Statement generated

__ 14.Click File-> Exit to close the Run SQL Scripts window. If you made
changes in the SQL script statement, do not save.

You now generate the SQL statement directly to a Source physical file
member on the iSeries server from the iSeries Navigator window using the
File menu.

__ 15.Click the SAMPLEDBXX library to display the content in the right window
panel.

__ 16.Click File-> Generate SQL... to view the Generate SQL window as shown
in Figure 67.
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Figure 67. Selecting Generate SQL from the File menu

__ 17.In the Generate SQL window, click the Write to file option in the Output
tab as shown in Figure 68.

__ 18.Click File type and select the database source file.

__ 19.Click Library and select your SAMPLEDBXX library.

__ 20.In the File Name input field, type GENSQLXX3. In the Member input field, type
GENSQLXX3.

__ 21.Click the Generate button to start Generate SQL on the iSeries server.

You can use the SQL file to replicate your schema tables on another
system, such as a development system. For the GENSQLXXn file name,
the XX refers to your team number and the n is a sequential number.

Note
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Figure 68. Generating SQL to the iSeries server

For existing files, the option to append to the file is provided. If an existing
file is selected, and the append option is not chosen, you are asked if you
want to overwrite the existing file.

__ 22.Double-click GENSQLXX3 to see the script on the iSeries Navigator
window as shown in Figure 69.

Figure 69. Selecting the source physical file to show the generate SQL script
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__ 23.Expand the window and use the scroll bar to explore the script file as
shown in Figure 70.

Figure 70. Exploring the SQL script file from iSeries Navigator

__ 24.Close the window of the SQL script file to return to the iSeries Navigator
window.

Task 3: Generating SQL from the Database Navigator Map

In this task, you learn how to generate the SQL DDL statement from some and all
objects in a map:

__ 1. Click the Database Navigator to display the maps on the right that exist on
the iSeries server as shown in Figure 71.
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Figure 71. Opening the Database Navigator Map

__ 2. Double-click to open the database map that you created in the last
exercise. If it does not appear, refresh the window.

__ 3. Click the View menu and click Zoom-> To Fit Window to fit all objects on
the map in this window as shown in Figure 72.

Figure 72. Fitting all objects in a map
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__ 4. Use the toolbar to select the Zoom In and Zoom Out icons to fit the object
size on the map in this window.

__ 5. Use the vertical and horizontal scroll bars to navigate to the top of the map
as shown in Figure 73.

Figure 73. Showing all objects included in the map

__ 6. Use the criteria selection in the locator pane and select only your
SAMPLEDBXX library. Click the Library parameter and select it as shown
in Figure 74.

__ 7. Click the Search button.
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Figure 74. Selecting only your sample library to appear in the Database Navigator Map

__ 8. Click the plus (+) sign next your SAMPLEDBXX database to see the
objects found, such as Tables, Indexes, and Views.

__ 9. Click the (+) sign next to the Tables database object to expand it.

__ 10.Double-click the EMPLOYEE table in the list of tables to find this table in
the map.

__ 11.Click the zoom icons (Zoom in, Zoom out, and Zoom to fit window) from
the toolbar to focus the EMPLOYEE table in a Map Pane.

__ 12.Right-click the EMPLOYEE table and select Generate SQL as shown in
Figure 75.
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Figure 75. Generating SQL of a specific object from the map

__ 13.In the Run SQL Script window, explore the generated SQL statements,
using the scroll bar to navigate as shown in Figure 76.
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Figure 76. Generating SQL from the employee table

You can see that two Constraint rules were generated in addition to the
EMPLOYEE table. One of them, the Referential Constraint Key, is
represented as RED in the map to show the relationship between the
EMPLOYEE and DEPARTMENT tables as shown in Figure 77.
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Figure 77. Showing a Referential Constraints Key in the map

__ 14.Click File-> Save As... to save the SQL script as shown in Figure 78.



Figure 78. Selecting save Script SQL

__ 15.On the Save window, click Look in to select your directory
(C:\DBNAV\SQLScript) from the pull-down menu to save your file.

__ 16.In the Name input field, type GENSQLXX4. In the Type input field, leave the
default SQL files (.SQL) as shown in Figure 79.

__ 17.Click Save to save SQL script file.

Figure 79. Saving the SQL script

__ 18.Click File-> Exit to close the Run SQL Script window.
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__ 19.Switch to the Database Navigator window. You are now going to generate
the SQL statement for all objects in a library.

__ 20.Click Map-> Generate SQL-> All Objects... to generate the SQL
statement for all objects in your library as shown in Figure 80.

Figure 80. Generate SQL for all objects in a library.

A status window appears showing the progress of the generate SQL as a
percentage (Figure 81).

Figure 81. Generating the SQL window

__ 21.In the Run SQL Script window, use the scroll bar to navigate to see the
generated SQL statements.

__ 22.Explore all the generated statements and enter the order in which they
were created (example, views, constraints, tables, Schema, alias....) in
Table 3.

Table 3. SQL Generate order

SQL statements Objects 
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__ 23.Click File-> Save As... to save the map.

__ 24.In the Save window, click Look in to select your directory
(C:\DBNAV\SQLScript) from the pull-down menu to save your file.

__ 25.In the File name input field, type GENSQLXX5. In the File of type input field,
leave the default as SQL files(.SQL).

__ 26.Click Save to save the SQL script file.

__ 27.Click File-> Exit to close the Run SQL Script window.

__ 28.Return to the iSeries Navigator main window.

Task 4: Generating SQL from DDS

The generate SQL function works with objects created using SQL and using
DDS. These objects can also be reverse engineered into an SQL create
statement.

However, there are options that allow the user to specify that the generated
statement should adhere to certain standards. Depending on the standard
selected, some objects created through native OS/400 interfaces may not be
compatible for use with this functions.

In this task, you generate the SQL statements for physical files that were created
using a DDS source file member. You use the DB2 UDB Family standard to
generate this SQL statement.

Figure 82. Generate SQL and Database Navigator combined

__ 1. Click the plus (+) sign next to the Libraries object to expand the list of
libraries.

__ 2. Change the list of libraries in iSeries Navigator to include the DDSLIBXX
Library. Refer to the first step in Task 3, ”Displaying properties and
descriptions of DB objects” on page 5, in Lab 1.

The objective of this exercise is to combine Generate SQL with the Database
Navigator feature. You create two maps of the same schema while following
different steps.

Comment

DDS (PF)

SQL DDL

Create
SCHEMA

Generate
MAP

DDS (PF)

Generate
MAP

Compare MAPS
????

DDSLIBxx

DDSLIBxxC

DDSLIBxxh
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__ 3. Click DDSLIBXX (on the right side of the window).

__ 4. Right-click the DDSLIBXX library and select Generate SQL as shown in
Figure 83.

Figure 83. Selecting physical files to generate an SQL statement

__ 5. Leave the default options. Click the Generate button in the Generate SQL
window.

__ 6. The SQL Script Center appears with the generated SQL DDL statements
posted in the working area as shown in Figure 84.

__ 7. Use the vertical scroll bar to explore the SQL statements.
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Figure 84. Exploring SQL script generated from a physical file

__ 8. Click Edit and select Replace. A Replace window like the one shown on
Figure 85 appears.

Figure 85. Replace window

Previously, you generated SQL statements that can recreate your
existing database (for example, on another iSeries server). In this case,
you are going to recreate an existing database on the same iSeries
server. For this reason, you must change the schema (database) name
from DDSLIBxx to DDSLIBxxC. There are some DDS-specific keywords
that cannot be converted to SQL. This appears in the code as messages
(see SQL150C and SQL509 in Figure 84).

Note
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__ 9. Review all of the SQL statements. Before you run the script to generate the
new schema (DDSLIBxxC), you must move the ALTER TABLE ORDERDTL
statement to follow the CREATE TABLE ORDERHDR. You must do this
because, in the ALTER TABLE statement, you are trying to define a
Referential Integrity constraint, which involves ORDERHDR, that has not
been created yet. For this reason, you must move it after the creation of the
ORDERHDR table. Figure 86 shows the ALTER statement that you must
move to appear after the CREATE TABLE ORDERHDR.

Figure 86. Altering a table after table creation

__ 10.Click the Edit->Cut and Edit->Paste options to move the text.

__ 11.Run all the SQL statements and verify that they run successfully. You just
created a schema (DDSLIBxxC) from the SQL statements that you created
from the original DDS created database (DDSLIBxx).

__ 12.You now create a Database Navigator Map of the generated SQL DDSLIB.
In the main iSeries Navigator window, expand the Database icon.

__ 13.Right-click the Database Navigator object and select New to create a new
map.

__ 14.Use the criteria selection in the upper locator pane to select your new
schema (DDSLIBxxC).

__ 15.Click Search to execute. The result appears on the bottom pane under the
Library Tree and Library Tables tabs.

__ 16.Click the plus (+) sign next to your DDSLIBxxC schema to show objects,
such as Tables, Indexes, and Views.

__ 17.Click the (+) sign next to the Tables object to expand it.

__ 18.Double-click the CUSTOMER table on the lower locator pane to start
building a map. This table is added to the map and all of the related objects
as shown in Figure 87.
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Figure 87. Map of DDSLIBxxC

__ 19.Click File-> Save As... to save the Map.

__ 20.From the Save As... window, click the Libraries parameter and select your
DDSLIBxxC library from the pull-down menu.

__ 21.In the Name input field, type DDSLIBxxMAP.

__ 22.In the Description input field, type Map created for the DDSLIBxxC.

__ 23.Click OK to save the map.

Task 5: Generating a map from DDS

In this task, you learn to generate a Map from a DDS-created database. Then you
generate the SQL statement from the Map.

__ 1. In the left panel of the main iSeries Navigator window, expand Database->
I400WS-> Libraries.

__ 2. Double-click your DDSLIBXX library. All the objects in this library appear in
the right panel.

__ 3. Right-click the Database Navigator object and select New to create your
Map as shown in Figure 88.
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Figure 88. Creating a map from physical files

__ 4. Use the criteria selection in the upper locator pane to select only your
DDSLIBXX library. Click the Library parameter and select your library.
Refer to the second step in Task 2, ”General tasks using the Database
Navigator window” on page 17, in Lab 2.

__ 5. Click Search to execute. The results appear on the bottom pane under the
Library Tree and Library Tables tabs.

__ 6. Click the plus (+) sign next to your DDSLIBXX database to show the
objects found, such as Tables, Indexes, and Views.

__ 7. Click the (+) sign next to the Tables database object to expand it.

__ 8. Double-click the CUSTOMER table in the lower locator pane to start
building a map. At this time, this Table is added to the map and all related
objects.

__ 9. Use the toolbar to select the Zoom In and Zoom Out icons to fit the object
size on the map in this window.

__ 10.Use the vertical and horizontal scroll bars to navigate to the top of the map
as shown in Figure 89.
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Figure 89. Displaying a map from physical files

__ 11.Take a few moments to analyze the map. Compare it with the one you
created in the previous task (GENSQLxx6). Are the maps the same?

__ 12.As an optional step, generate an SQL statement from a the map and
compare the SQL statement with the one generated in Lab 2, “Database
Navigator: General tasks” on page 9.

You have now completed this lab!
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