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IBM Host Access Transformation Services (HATS) Version 6 lab 

Abstract 

The objective of this lab is to provide you with a basic understanding of creating and 
previewing an IBM® WebSphere® Host Access Transformation Services (HATS) 
application on the IBM iSeries™ platform. This will be done through the use of the 
WebSphere Development Studio Client with the HATS plug-in and the integrated 
WebSphere Application Server test environment. 

What you will learn 

At the end of the lab, you will be able to: 
 Create a HATS application 
 Preview your HATS project in the WebSphere Application Server test 

environment. 
 Customize the HATS application by modifying the default template, changing the 

default rendering, customizing a screen, and working with macros and integration 
objects. 

 Create a HATS portlet application. 

Introduction 

In this lab, you will create a HATS application in WebSphere Development Studio Client. 
After creating the HATS application, you will customize and enhance HATS while 
previewing it in the WebSphere Application Server test environment.  
 
Also, you will create HATS portlet and preview it in WebSphere Portal Server Test 
Environment. 
 
The steps in this lab are:  

1. Creating a HATS application 
2. Previewing the HATS project using Run On Server 
3. Modifying the template 
4. Changing the default rendering 
5. Customizing a screen 
6. Working with macros and integration objects 
7. Creating a HATS portlet application 
8. Testing the HATS portlet in WebSphere Portal Server 
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Required materials 

The following information will be referred to in the lab: 
 <team_number>:  Team number of your choice 
 <iSeries_Server>:  Your iSeries system hostname  
 <iSeries_userid>:  iSeries system user ID 
 <iSeries_password>:  iSeries system password 

 
The list of systems and software required to complete the lab are: 

 An iSeries system and a PC 
 The FLGHT400 library restored and on the library list of the iSeries system  

Note: The code is available from the iSeries Developer Roadmap: End-to-end 
demo Web site (www.ibm.com/servers/enable/site/ideveloper_j2ee/etoe/ ). This site is 
also listed in Appendix B. 

 WebSphere Development Studio Client V6 installed on the PC 
 HATS Studio V6 installed into WebSphere Development Studio Client on the PC 

 
Tips:  Here are a few things to keep in mind as you are completing this lab: 

 WebSphere Development Studio Client is a very dynamic development 
environment capable of a large amount of user customization. Because of this, 
the screen captures in this lab might not exactly match what you see when you 
follow the steps of this lab.  

 Host Access Transformation Services (HATS) comes with a wealth of 
documentation covering everything from getting started to advanced 
programming in HATS. This documentation can be accessed in WebSphere 
Development Studio Client through the HELP interface. It can be found on your 
PC in IBM WebSphere HATS > Library from the Start menu in the form of 
PDFs. This information is also available in the Welcome to HATS tab in 
WebSphere Development Studio Client in the View the library of online 
information for HATS section. In addition to the information that is shipped with 
HATS, there is additional information on the HATS V6 Information Center Web 
site (http://publib.boulder.ibm.com/infocenter/hatsv6/index.jsp ). (This site is also listed 
in Appendix B.) 

 Throughout this lab, different actions will cause the HATS Tip windows to pop 
up. These windows can provide useful information to the HATS novice. You can 
select to have a specific tip not show again as well as chose to not show any tips. 

 In the lab instructions, substitute your <team_number> for xx. 
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Creating a HATS application 

In this section you will start HATS Studio (WebSphere Development Studio Client) and 
create a basic HATS project. Afterward, the project will be previewed in the next section.  

Starting WebSphere Development Studio Client  
To initiate the WebSphere Development Studio Client, do the following steps: 

1. Go to Start > All Programs > IBM WebSphere HATS 6.0 > HATS Studio 6.0.  
2. In the workplace launcher window (Figure 1), enter: 

C:\WDSC\WorkSpaces\teamxx (Where xx is your <team_number>) in the 
workspace field and press OK. (Please make sure that Use this as a default 
and do not ask again are not checked.)  

 

 
Figure 1: Workplace Launcher screen 
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3. After WebSphere Development Studio Client starts, you are greeted by the 
Welcome to HATS pop-up window (Figure 2).  

4. Click OK in the HATS Tip pop-up.  
 

 
Figure 2: Welcome to HATS window 

 
5. If you do not see the Welcome to HATS page, then open the HATS perspective.  
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Creating a HATS project 
Once you have gotten into the HATS tool, do the following: 

1. Click launch the Create HATS Project wizard. This will open the Create a 
Project window.  

2. In the Name field, enter Flight400HATS. 
3. Select WebSphere Application Server V6.0 as the target server. The rest of the 

fields will remain at the default values.  
4. Click Next. 
5. Within the Connection Settings dialog box (Figure 3), in the Host name field, 

enter iSeriesServer for your iSeries server name.  
6. In the Type field, select 5250 from the Type drop-down box.  
7. Select 27 x 132 from the Screen size drop-down box.  
8. Click Next.  

 

 
Figure 3: Connection Settings screen 

 
9. Choose the template that best fits your taste by selecting it from the Template 

drop-down box.  
10. Click Finish.  

 

Page 5 of 46 



IBM Host Access Transformation Services (HATS) Version 6 lab 

You have just created a basic HATS project ready to run in the WebSphere Application 
Server test environment or export for deployment (Figure 4). 
 

 
Figure 4: Basic HATS project 
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Previewing the HATS project using Run On Server 

In this section, you will use the Run On Server command to preview your HATS 
application in the integrated WebSphere Application Server test environment in 
WebSphere Development Studio Client. After verifying the project functions, you will 
enhance and customize it. 

Running the application in a WebSphere Application Server test 
environment 
To start your application in the WebSphere Application Server test environment, do the 
following:  

1. Right-click your project in the HATS Project View window and select Run on 
Server (Figure 5). 

 

 
Figure 5: HATS project view; selecting Run on Server 

 
2. Having selected Run on Server, the Display Terminal window opens.  
3. Click Yes to see the host view in the display terminal.  
4. In the Server selection window, choose an existing server and select 

WebSphere Application Server V6.0 under localhost. 
5. Click Finish.  
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Your HATS application will be displayed in the Web Browser tab created by the 
Run on Server command (Figure 6).  
 

 
Figure 6: Web Browser tab 

 
6. You can double-click the Web Browser tab to maximize it, double-clicking the 

tab again will reduce it to normal size.  
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7. You will see a host view in the display terminal window. As you execute 
commands on the HATS application, they will also appear in the display terminal 
window (Figure 7). 

 

  
Figure 7: Display terminal window 

 
8. Log into your HATS application by filling in the <iSeries_userid> and 

<iSeries_password>.  
9. Once you have entered the values, push the Enter key on your keyboard.  
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10. You are now previewing your HATS application running in the test environment. 
Remember that this is just a default transformation of the 5250 green screen. 
Take a look around and see what the default transformation gives you.  
In the screen shot below, the Work with Active Jobs screen is shown where the 
options have been transformed into a drop-down list, by default (Figure 8). 
 

 
Figure 8: Work with Active Jobs screen 
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11. Press ALT-TAB to switch to the display terminal window. You will see the same 
command displayed in that window (Figure 9). 

 

 
Figure 9: Work with Active Jobs display terminal window 
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Reviewing the Flight Reservation System application 
To take a look at the Flight Reservation System application on the iSeries system, do the 
following:  

1. In the command line, type: GO FLGHT400/FRSMAIN to start the Flight 
Reservation System application.  

2. Try Create New Reservation and Reports options and see the HATS default 
transformation (Figure 10). (Use for Agent Name: Mark, and for Password: 
mercury.) You will customize some of the defaults later on in this exercise.  

 

 
Figure 10: HATS default transformation 

 
3. Exit the Flight Reservation System application.  
4. Sign off from your iSeries system.  
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Modifying the template 

The template you selected in the Create HATS Project wizard is the default used for 
each screen. In this section, you will locate the templates and then modify the default 
template.  

Modifying the default template 
Do the following:  

1. Expand your HATS project, Flight400HATS. 
2. Expand the Web Content folder. 
3. Expand the Templates folder.  

 
The template you selected during the creation of your HATS project will display 
(default) to the right of it. In the screenshot in Figure 11 below, the default 
template was TropicalFlight (default).  
 

4. Double-click your (default) template. This will open the template in the editor.  
 

 
Figure 11: The default template 
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5. You will now see your default template in the editor. Notice that the editor has a 
Design, Source, and Preview view (see red circle in Figure 12). Take some time 
to familiarize yourself with the different views.  

6. Return to the Design view by clicking Design.  
 

 
Figure 12: Editor views 

 
7. Click anywhere on My Company in the editor. Using the keyboard, replace the 

text with your company name. This example uses IBM eServer iSeries.  
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8. Click anywhere on My Company Slogan in the editor. Using the keyboard, 
replace the text with a slogan of your choice. This example uses “i” Stands for 
Integrated (Figure 13). 

 

 
Figure 13: Changing company name and slogan 

 
9. Save the modifications done by going to File > Save or by pressing CTRL+S.  

 
So far, you have only done a simple text change. On the default template, there 
are many other attributes for the fields.  
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10. Right-click My Company Home Page and select Properties from the list. The 
bottom section will then show the Attributes for a HTML Link field. Notice that 
there is a Link, Anchor, and Others tab (Figure 14). 
 
By selecting different fields, you will see the attributes change, depending upon 
the field selected. Try clicking different parts of the template to study the 
attributes. 

 

  
Figure 14: My Company Home Page properties list 

 
Next you will insert an image into the template.  
 

11. Click the Gallery tab at the bottom of the Web browser.  
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12. In the Gallery window, expand Multimedia and click Animation. This will 
automatically change you to the Thumbnails view (Figure 15) where you can see 
the contents of the Multimedia folder.  

 

 
Figure 15: Thumbnail view 

 
13. Scroll to the bottom of the Thumbnails window and locate u011ani.gif.  
14. Click u011ani.gif, drag it onto your template, and drop it above My Company 

Links.  
 
You can view how the template will be displayed by clicking the Preview tab at 
the bottom of the editor window (Figure 16). 

 

 
Figure 16: Preview thumbnail 

 
15. Select File > Save, or press CTRL+S.  

 
This will save the work you have completed so far. Once you have saved your 
work you can test the changes made.  
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Previewing your HATS application 
Now you can glance at your HATS application by doing the following:  
 

1. Right-click your project in the HATS Project View window and select Run on 
Server to open the Display Terminal window.  

2. Click Yes to see the host view in the display terminal.  
3. In the Server selection window, choose an existing server and under localhost 

select WebSphere Application Server V6.0. 
4. Click Finish.  

 
This will publish your modified application to the WebSphere Application Server 
test environment (Figure 17). 
 

 
Figure 17: Modified application 

 
You have now seen how the template can be easily modified and enhanced. 
New templates can even be created based on an existing Web site using the 
Create HATS Template wizard, allowing easy use of company style and content. 
Working with the template is the simplest method of changing the look of your 
HATS application. Much more powerful and dramatic enhancements are 
available working with the default rendering and global rules. 
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Changing the default rendering 

The default rendering is an ordered set of conversion pairings and is used by the default 
transformation to change host components into HTML widgets. You saw the results in 
the previous steps when you ran your HATS application in the WebSphere Application 
Server test environment. In this section, you will view and modify the default renderings.  

Project settings 
Project settings can be modified by doing the following:  
 

1. Expand your Flight400HATS project and double-click Project Settings (Figure 
18). This will open the Flight400HATS settings to be viewed and modified.  

 

 
Figure 18: Project Settings view and tabs 

 
Notice that like other windows in WebSphere Development Studio Client, the 
Flight400HATS Settings window has a set of tabs in the lower left corner of the 
window. In this example, the tabs are: Overview, Connections, Template, 
Rendering, Events, Other, and Source.  
 

2. Click through the tabs and take some time to review the information available in 
each tab (shown at the bottom of Figure 18).  
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Changing the default rendering 
The rendering that is produced by default can be modified. To do this, follow these 
steps:  
 

1. Click the Rendering tab to work with the default rendering.  
 
The default rendering works with the default transformation to change host 
components on the screen to widgets on the Web page. Certain host 
components map to specific widgets for conversion in the default transformation. 
A default list of mapping items is defined for projects. You can modify the list of 
items to suit your needs. These items are processed in the order in which they 
are listed. After a rendering item has been applied to a region of the host screen, 
that region is considered consumed and will not be processed again.  
 

2. Double-click the Flight400HATS Settings window title to expand the window.  
 

3. You will now change the default rendering for function keys. Click the Transform 
function keys box in the Description column (Figure 19). 

 

 
Figure 19: Select Transform function keys 
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4. Click the Edit button.  

 
A window will pop up stating that you need to have a screen capture to add or 
edit a host component.  
 

5. Click Yes to open the main Host Terminal window.  
6. Click OK on the HATS Tip popup if displayed.  

 
To work with function key transformation, you need to capture a screen with 
function keys (Figure 20). 
 

 
Figure 20: Screen with function keys 

 
7. Sign on to the iSeries system using your <iSeries_userid> and 

<iSeries_password>.  
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After logging on to the iSeries system, you will see the IBM OS/400® Main Menu 
screen.  
 

8. Click the Create Screen Capture button (Figure 21). 
 

  
Figure 21: OS/400 Main Menu screen and Create Screen Capture button 

 
9. Accept the defaults on the Create Screen Capture window. 

10. Click Finish.  
11. Sign off of the iSeries Host Terminal session. 
12. Close the main Host Terminal window.  

 
Now you can edit the Transform function keys’ default rendering.  
 

13. Select the Transform function keys box.  
14. Click the Edit button (Figure 22). 

 

 
Figure 22: Configure the currently selected rendering set 
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15. Accept the default description in the Edit a Default Rendering Item window. 
16. Click Next. 
17. Accept the defaults in the Select Screen Region.  
18. Click Next. 

 
The Rendering Options screen is where you make the connection between 
components on the iSeries host screen and widgets that are displayed in the 
browser. 
 

19. Click Function key under Components. You can then preview these in the 
Component Preview section (Figure 23). 

 

 
Figure 23: Function key component preview 
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20. Under Widgets, click Button, Link, Button table, Drop-down (selection), and 
Radio button (selection) one after another.  

 
A preview of each will be shown under the Widget Preview (Figure 24). 
 

21. Select your preferred method for displaying Function Keys, then click Finish.  
 

 
Figure 24: Widget component preview 

 
22. Save the Flight400HATS Settings by going to File > Save or by pressing 

CTRL+S. 
23. Double-click the Flight400HATS Settings window title to go back to the original 

size.  
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Previewing your HATS application 
To visually experience your new HATS application, do the following:  

1. Right-click your project in the HATS Project View window and select Run on 
Server to open the Display Terminal window.  

2. Click Yes to see the host view in the display terminal.  
3. In the Server Selection window, choose an existing server and select 

WebSphere Application Server V6.0 under localhost.  
4. Click Finish.  

 
This will publish your modified application to the WebSphere Application Server 
test environment. 
 

5. Sign on to the iSeries system using your <iSeries_userid> and 
<iSeries_password>.  

6. On the command line type: GO FLGHT400/FRSMAIN to start the Flight 
Reservation System application.  

7. Try the Create new reservation and Reports options and see the modified 
transformation for the function keys. (Use for the Agent Name: Mark and for the 
Password: mercury.)  

 
Function keys are now transformed into buttons instead of hyperlinks (default) 
(Figure 25).  

 

 
Figure 25: Transformed function keys 
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You have now changed the default rendering for function keys. As you saw working 
through the steps in this section, there are far more options than are presented in this 
lab.  
 
In addition to default rendering, there are global rules. As default rendering works with 
the default transformation, global rules enable you to define component-to-widget 
mappings for all your transformations.  
 
Although the mappings are similar to default rendering, global rules apply only to input 
field components. There are no default mapping items defined. When you define global 
rules, they take precedence over any default rendering items and components-to-widget 
mappings defined in specific transformations. 

Customizing a screen 

A screen customization has two parts:  
• A set of criteria for matching host screens 
• A list of actions to be taken when a host screen matches these criteria.  

 
The screen customization is at the heart of the HATS application's rules-based 
processing of host screens. Each screen customization includes a set of criteria that 
determine which host screens are to be applied. When a host screen matches these 
criteria, the HATS application executes the actions that are defined in the screen 
customization. These actions can include the following: 

 Applying a transformation to the host screen  
 Extracting, setting, or inserting data or the value of a global variable  
 Running a macro or macro transaction  
 Calling Java™ methods to execute business logic  
 Displaying a specified Web page (URL)  
 Sending a key to the host application  
 Forwarding control to a URL 

 
In this section, you are going to customize the Sign On screen. You will do this by 
creating a set of criteria to recognize the screen and then develop a list of actions to be 
taken when the Sign On screen is recognized. 

Creating a screen customization 
You can customize the screen by doing the following:  

1. Open the HATS Host Terminal by clicking the icon in the toolbar (Figure 26). 

 
Figure 26: Open HATS Host Terminal 
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2. The main Host Terminal window will open to the Sign On screen of the iSeries 
system. (This is the screen that needs to be customized.)  

3. Click the Create HATS Screen Customization icon (Figure 27).  
 

 
Figure 27: Create HATS Screen Customization 

 
4. Accept the defaults on the New Screen Customization screen. 
5. Click Next.  
6. The next step in the wizard is Select Screen Recognition Criteria. You will 

identify your Sign On screen by the string value Sign On.  
7. Under Within a rectangular region (Figure 28), enter the row and column 

values. Enter these values in their corresponding fields: Starting row 1,Starting 
column 36, Ending row 1, Ending column 42.  

8. Click Next. (You can also use guides on the yellow dotted line box to change the 
size to match the coordinates.)  

 

 
Figure 28: Define the rectangular region settings 
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9. Click the Prepopulated host components radio button (Figure 29). 

 

 
Figure 29: Prepopulated component 

 
10. Click Finish.  
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11. SignOn.jsp  is a JavaServer Page™ (JSP™) that opens up in the JSP editor with 
a view (Figure 30) of the HATS palette on the right side. 

12. Click HATS Components to open that drawer. 
 

 
Figure 30: HATS components 

 
13. In the JSP editor window, you can click any screen component (for example, the 

Sign On text). 
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14. Click the Properties view at the bottom to see the properties for that screen 
component. In the properties view, you can see components and the widget 
applied to that screen component (Figure 31). 

 

 
Figure 31: Screen component properties view 

 
15. To replace the Sign On text click the Text Replacement icon (Figure 32). 

 

 
Figure 32: Replacing component text 
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16. Click Add in the Text Replacement window.  
17. In the Replace text field, enter Sign On (Figure 33). 
18. In the text field under Text or HTML enter <h3>Welcome to the IBM eServer 

iSeries Sign On page, please log in.</h3> . 
19. Click OK.  

 

 
Figure 33: Replacing text 

 

Page 31 of 46 



IBM Host Access Transformation Services (HATS) Version 6 lab 

20. In the Text Replacement window, click OK. You will see the text replaced with 
new text (Figure 34). 

 

  
Figure 34: The new text 

 
21. Save SignOn.jsp by going to File > Save or by pressing CTRL+S.  
22. Click X to close the SignOn.jsp window.  
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Previewing your HATS application 
Now you can look at you HATS application by doing the following:  

1. Right-click your project in the HATS Project View window and select Run on 
Server to open the Display Terminal window.  

2. Click Yes to see the host view in the display terminal.  
3. In the Server selection window, choose an existing server and select 

WebSphere Application Server V6.0 under localhost. 
4. Click Finish. This will publish your modified application to the WebSphere 

Application Server test environment. 
 

You will see the iSeries sign-on screen with the replacement text (Figure 35).  
 

 
Figure 35: iSeries sign-on screen with new text 
 

With Screen Customization, you can affect a single screen or sets of screens 
depending on the Screen Recognition Criteria. This very powerful technique 
combined with Transformation and other functions in HATS allows almost 
limitless customization of your application.  
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Working with macros and integration objects 

Macros can be used for many useful purposes, such as:  
 Skipping host screens  
 Automating common user paths (including repetitive looping)  
 Combining data from many host screens into one JSP  
 Prompting for and extracting data  

 
Integration objects are macros in a Java wrapper. You can create one by right-clicking 
over a macro in the navigation pane and selecting from the context menu. Macros and 
integration objects can be created on secondary connections rather than the HATS 
default (or primary) connection, which is used for all transformations. Secondary 
connections allow back-end data operations to be specified as actions in screen 
customizations or other events.  
 
You will now create a simple macro logon macro.  

Recording a macro 
You can record a macro by doing the following:  

1. Open the main Host Terminal by clicking the Open HATS Host Terminal icon in 
the toolbar (Figure 36). 

 

 
Figure 36: HATS Host Terminal 

 
2. Click the Record Macro Icon (Figure 37). 

 

 
Figure 37: Record Macro icon 

 
3. The Record Macro window will pop up.  
4. Accept the defaults and click Finish.  
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5. On the Define Screen Recognition Criteria screen (Figure 38), define the 
starting screen of the macro window and accept the defaults.  

6. Click Finish.  
 

 
Figure 38: Define Screen Recognition Criteria screen 
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7. HATS is now recording what you do in the terminal session. Enter the following 
information (Figure 39):  
 User: enter your <iSeries_userid>. Check the macro information getting 

recorded in the Macro Navigator window.  
 Password: enter your <iSeries_password> 
 Menu: enter FRSMAIN 
 Current library: enter FLGHT400  

 

 
Figure 39: Enter sign-on information 
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8. Press the Enter key.  
9. Click the Stop Macro icon (Figure 40). 

 

 
Figure 40: Stop Macro icon 

 
After you click the Stop Macro icon, the Define Screen Recognition Criteria / 
Define the Exit Screen of the macro window pops up. You will identify the sign-on 
screen by the string value Flight Reservation System.  
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10. Under Within a rectangular region (Figure 41) enter the row and column 
values. Enter these values in their corresponding fields: Starting row 1, Starting 
column 28, Ending row 1, and Ending column 52. (You can also use the guides 
on the yellow dotted line box to change the size to match the coordinates.)  

11. Click Finish.  
 

 
Figure 41: Enter the row and column values 

 
12. Click the Save Macro icon (Figure 42).  

 

 
Figure 42: The save Macro icon 

 
13. Sign off the 5250 session. 
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Testing the macro 
At last, it is time to test the macro to ensure that it is working as expected. Do the 
following:  

1. Sign off the 5250 session and then click the Play Macro icon (Figure 43). It will 
log you on to the iSeries system and take you to the Flight Reservation System 
main menu.  

 

 
Figure 43: Play Macro icon 

 
2. Click the Host Screen Preview tab to see the transformation preview (Figure 44). 

 
Figure 44: Host Screen Preview tab 

 
3. Sign off from the iSeries system.  
4. Close the main Host Terminal window. 
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Adding your macro to the screen customization 
You will now add your macro to your SignOn Screen Customization with these steps:  

1. Navigate to SignOn under Flight400HATS > Screen Customizations. 
2. Double-click SignOn (Figure 45). 

 

 
Figure 45: Screen Customizations SignOn tab 

 
3. Click the Actions tab. Then select Apply a transformation (Figure 46). 
4. Click the Remove button. 

 

 
Figure 46: Apply a transformation check box 
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5. Click the Add button as shown in Figure 47. 
6. Select the Play macro radio button. Then click Next.  
7. Select SignOn from the Play a macro drop down list. Then click Finish.  

 

 
Figure 47: Adding an action 

 
8. Save SignOn.evnt by going to File > Save or pressing CTRL+S.  
9. Click X to close the SignOn.evnt window. 
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Previewing your HATS application 
To take a look at the customized HATS application, do the following:  

1. Right-click your project in the HATS Project View window and select Run on 
Server to open the Display Terminal window.  

2. Click Yes to see the host view in the display terminal.  
3. In the Server selection window, choose an existing server and select 

WebSphere Application Server V6.0 under localhost. 
4. Click Finish. This will publish your modified application to WebSphere 

Application Server test environment. 
5. Your application can run using the macro logging you created. You will see the 

Flight Reservation System application main menu (Figure 48).  
 

 
Figure 48: Flight Reservation System application 

 
6. You have just used a macro to change the flow of a 5250 application.  

 
It took only a few steps to create a macro and only a few more to integrate that 
macro into your screen customization. Not only are macros easy to use in HATS 
but the power of macros allow you to change the flow of your application. For 
example, you can export and deploy the HATS Portlet in WebSphere Portal 
Server on iSeries.  
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Summary 

IBM WebSphere Host Access Transformation Services (HATS) gives you all the tools 
you need to quickly and easily extend your back-office applications to solution providers, 
customers, and employees. HATS makes your 3270 and 5250 applications available as 
HTML through the most popular Web browsers, while converting your host screens to a 
Web look and feel. This lab only touched on a small amount of the function available in 
HATS. With HATS it is easy to improve the workflow and navigation of your host 
applications without any access or modification to source code. The HATS rules-based 
transformation engine makes it possible to extend your host applications to the Web 
within hours of installing the software. HATS is a zero-footprint, zero-download, Web-to-
host solution. The only software needed on the client is a Web browser. 
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Appendix A: iSeries Access for Windows and NetServer 

IBM iSeries Access for Windows relies on iSeries Support for Windows Network 
Neighborhood (also known as IBM iSeries NetServer™) for Network Drive support. It is 
part of IBM i5/OS®, and is not part of iSeries Access for Windows. iSeries NetServer 
enables an iSeries system to perform file serving in a Windows network without the need 
to install additional hardware or software on an iSeries system. iSeries NetServer uses 
the Server Message Block (SMB) protocol to communicate with the network. Below, are 
steps to set up NetServer shares through iSeries Navigator to share network drives with 
a Microsoft® Windows® PC Network.  
 
For more information on iSeries NetServer, see Appendix B.  
 
For information on installing and configuring iSeries NetServer, see Configuring iSeries 
NetServer on the iSeries server at the iSeries Information Center Web site also found in 
Appendix B. 
 

Creating a file share 
A file share is a directory path that iSeries NetServer shares with PC clients on the 
iSeries network. A file share can consist of any integrated file system directory on 
iSeries. For this lab exercise, create a share to a directory somewhere under the root 
directory (‘/’). For details, see the iSeries Information Center Web site. 
 

Mapping a network drive 
To access the file share created above using Windows, you can map a file share to 
logical drive. For details, see the iSeries Information Center Web site. 
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Appendix B: Resources 

These Web sites provide useful reference materials to supplement the information 
contained within this document.  
 

 IBM eServer iSeries Information Center 
http://publib.boulder.ibm.com/infocenter/iseries/v5r3/ic2924/index.htm?info/icmain.htm 
 

 iSeries Developer Roadmap: End-to-end demo 
ibm.com/servers/enable/site/ideveloper_j2ee/etoe 
 

 IBM Host Application Transformation Server (HATS) V6 Information Center 
http://publib.boulder.ibm.com/infocenter/hatsv6/index.jsp 
 

 iSeries Access for Windows and NetServer 
ibm.com/eserver/iseries/netserver 

 
 iSeries Tools for Developers (5799-PTL) 

ibm.com/servers/enable/site/porting/tools 
 

 Creating a file share under i5/OS and OS/400 
http://publib.boulder.ibm.com/infocenter/iseries/v5r3/ic2924/info/ifs/rzaaxcrtfileshare.htm 

 
 Mapping a network drive 

http://publib.boulder.ibm.com/infocenter/iseries/v5r3/ic2924/info/rzahl/rzahlwinnsflshr.htm 
 

 IBM eServer iSeries Tools for Developers 
ibm.com/servers/enable/site/porting/tools 

 
 Configure iSeries NetServer on the iSeries server 

http://publib.boulder.ibm.com/infocenter/iseries/v5r3/ic2924/info/rzaij/rzaijconnetas.htm 
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