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Using the IBM WebFacing Tool with FLGHT400 lab 

Abstract 
The objective of this lab is to work with an existing 5250 application and use the IBM® WebFacing Tool 
and IBM WebSphere® Developer Studio Client to create a browser-based user interface, and then run 
this application as an e-business application. At the end of the lab, you will know how to use the IBM 
WebFacing Tool. The lab will guide you through most of the steps involved in the Web-facing process.   

Introduction 
The IBM WebFacing Tool creates Web front ends to IBM iSeries™ system applications that use data 
description specifications (DDS) for their green-screen transactions. You choose a Web style for the 
new graphical interface, generate a set of JavaServer™ Pages (JSPs™) and XML files that interact 
with the program logic, and then easily test your application in the test environment provided by the IBM 
WebSphere Studio Workbench. When you are ready to deploy the application, you can generate 
standard Java 2 Enterprise Edition (J2EE™) Web archive (WAR) and enterprise archive (EAR) files 
that you can install on a WebSphere Application Server.  
 
The steps in this lab are:  

1. Reviewing the Flight Reservation System application components 
2. Creating a Web-faced application 
3. Testing the Web-faced application 
4. Packaging, installing, and testing the Web-faced application on the iSeries system 
5. Customizing the Web-faced application 
6. Creating a Web-faced portlet 
7. Testing the Web-faced portlet 

Prerequisites 
The following information will be listed on the lab information sheet:  

 <team_number>: Team number of your choice 
 <iSeries_Server>: Your iSeries system host name  
 <iSeries_userid>: Your iSeries user ID 
 <iSeries_password>: Your iSeries password 

 
The list of systems and software required to complete the lab are: 

 An iSeries system and a PC 
 The FLGHT400 library restored and on the iSeries library list  

 
Note: The code is available from the iSeries Developer Roadmap: End-to-end demo Web site listed in the 
Resources section. 
 
 WebSphere Development Studio Client Version 6 installed on the PC 
 Optional: WebSphere Application Server installed and configured on the iSeries system 

 
Tips: Here are a few things to keep in mind as you are completing this lab:  

1. WebSphere Development Studio Client is a dynamic development environment capable of a 
large amount of user customization. Because of this, the screen captures in this document 
might not exactly match what you see when following the steps in this lab. 

2. In the lab instructions, substitute your <team_number> for xx. 
3. All exercises depend on the availability of specific software on your PC and iSeries system. 
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Reviewing the Flight Reservation System application components 
In this section, you will review the Flight Reservation System application components through opening 
a perspective, defining a connection, and reviewing the system components.   

Part 1: Starting WebSphere Development Studio Client  
Follow these steps: 

1. Go to Start > All Programs > IBM Rational >  
IBM WebSphere Development Studio Client Advanced Edition for iSeries V6.0 > 
WebSphere Development Studio Client Advanced Edition for iSeries. 

2. In the Workspace Launcher window (Figure 1), enter c:\teamxx (Where xx is your 
<team_number>) in the workspace field and press OK. (Make sure that Use this as a default 
and do not ask again is not checked.) 

  
Figure 1: Select a workspace 

   
You will see a Welcome page (Figure 2) if you have not used WebSphere Development Studio 
Client before.  

3. Click X to close the Welcome page. 

 
Figure 2: Welcome page 
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Part 2: Opening the Remote System Explorer perspective 
Open the Remote System Explorer perspective by following these steps: 

1. Click the Open perspective icon on the right-hand side or go to Window > Open Perspective.  
 

 
Figure 3: Select Perspective 

2. Select Other. 

3. In the Select Perspective window, select Remote System Explorer (Figure 3) and click OK.  

Part 3: Defining a connection to the iSeries system  
Now you will define a connection to the iSeries system by following these steps: 

1. Click the + sign next to iSeries under New connection in the Remote Systems view. 

2. If WebSphere Development Studio Client has not been used before, you will see the  
name personal profile screen.  

3. Enter teamxx as the profile (Where xx is your <team_number>) and press Next.  

4. On the Define connection information screen, enter the host name as <iSeries_Server> 
(where <iSeries_Server> is your iSeries system). 
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5. Enter the connection name (Figure 4) as <iSeries_Server> connection and click Finish. 

 
Figure 4: Enter connection name 

6. You will see a new connection defined in the Remote Systems view. 

7. Right-click iSeries Objects under New Connection.  

8. Select Connect (Figure 5) to connect to the iSeries system.  

 
Figure 5: Remote Systems view 
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9. In the Enter password window, type your <iSeries_userid> and <iSeries_password>.  

10. Select the Save user ID and Save password check boxes and click OK. 

11. After a successful connection, you will see a green arrow next to the iSeries connection as well 
as the iSeries objects and other subsystems.  

Part 4: Reviewing the Flight Reservation System application components 
In this section of the lab, you will review the application components by following these steps: 

1. Click the + sign next to iSeries Objects. 

2. Click the + sign next to Library list. 

3. Right-click Library list and select Add Library List Entry (Figure 6).  

 
Figure 6: Add Library List Entry screen 

4. In the Add Library List Entry window, enter FLGHT400 and click OK.  

5. Click the + sign next to FLGHT400. 

6. You will see RPG, CL program objects from FLGHT400. 
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7. Scroll down and click the + sign next to the QDDSSRCD *file pf-src object (Figure 7) to see 
DSPF source members used in the Flight Reservation System application.  

 
Figure 7: DSPF source members 

8. You can double-click any member to open it in the editor view. Note: Do not make any changes 
or save the changes. 

9. Scroll down and click the + sign next to QMNUSRC *file pf-src to see the MNUDDS source 
members used in the Flight Reservation System application. 
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Creating the Web-faced application 
In this section, you will create the Web-faced application by opening, creating, and converting the 
project. 

Part 1: Opening the IBM WebFacing Tool perspective 
Follow these steps to open the IBM WebFacing Tool perspective: 

1. Click the Open perspective icon on the right-hand side or go to Window > Open Perspective. 

2. Select WebFacing. 

3. You will see the WebFacing Project view on the left-hand side. 

Part 2: Creating an IBM WebFacing Tool Project 
Follow these steps to create the IBM WebFacing Tool project: 

1. Select File > New > WebFacing Web Project. 

2. In the WebFacing Web Project window, enter the project name Flght400 (Figure 8). 

3. Click the Show advanced button (Figure 8) to see the advanced options and click Next.  

 
Figure 8: WebFacing Web Project 

4. In the WebFacing Features window, check Add system screen support and click Next. 

5. In the Select display file members to convert window, select the previously defined 
connection as <iSeries_Server> connection. 

6. In the Library field, enter FLGHT400, and click the Refresh DDS list button. 

7. Click the + sign next to FLGHT400 to expand the tree.  
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8. Click the + sign next to QDDSSRCD to display all DSPF members. 

9. Select all display file members under QDDSSRCD.  

10. Click the first member. 

11. Scroll down, press the SHIFT key and click the last member. (Alternatively, you can select 
individual display file members by pressing the CTRL key and clicking the individual members.)  

12. Click the arrow button to move to the right hand side box (Figure 9).   

13. You can also select all the MNUDDS members under QMNUSRC.  

14. Click Next.  

 
Figure 9: Select display file members 

15. In the Select UIM source members to convert window, click Next.  
(There are no UIM help members as a part of this application.) 

16. In the Specify CL command window, enter the command line go FLGHT400/FRSMAIN. 
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17. Change the command label to Flight Reservation System (Figure 10) and click Add.  

 
Figure 10: Specify command label information 

18. Click Next. 

19. In the Choose a Web Style window, select any Classic WebFacing Style of your choice and 
click Next.  

20. In the Complete WebFacing project window, select the default option  
(No. I only want to create project now) and click Finish.  

21. After a while, you will see your project in the IBM WebFacing Tool projects view.  

22. Click the + sign next to your project to see the project details.  
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23. When you select an item in the WebFacing Projects view (Figure 11), 
it shows properties in the properties view. 

 
Figure 11: WebFacing Projects view 

Part 3: Converting the project 
In this part, you will convert the project by following these steps: 

1. In the WebFacing Projects view, right-click DDS and select the Convert option.  

 
Figure 12: WebFacing Projects view, Convert option 
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2. Conversion might take a while as the IBM WebFacing Tool retrieves the source code from the 
iSeries system and creates all Web application components (namely the JSPs and XML 
documents for each record format). 

3. After conversion, the DSPF Conversion Log is displayed in the log view.  

4. Select any Display File (Figure 11) to look at the record formats.  

 
Figure 13: Select display file 

5. To look at the referenced keywords, click the Referenced Keywords tab. 
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6. Click any display file member to display the keywords (Figure 12).  

 
Figure 14: Display keywords 
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Testing the Web-faced application 
In this section, you will test the Web-faced application in a WebSphere Application Server test 
environment by following these steps:  

1. In the WebFacing Projects view, right-click your project and  
select the Run > Run on Server option (Figure 15).  

 
Figure 15: Run on Server option 

2. In the Server Selection window, choose an existing server.  

3. Select WebSphere Application Server V6.0 under local host and click Finish.  

4. After a while, you will see a browser displaying the index page of your Web-faced application.  
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5. Click Launch (Figure 16) to invoke the Web-faced application.  

 
Figure 16: Select program 

6. When prompted for user ID and password, enter <iSeries_userid> and <iSeries_password> 
and click Logon.  

7. You will see a Flight Reservation System logon screen.  
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8. Double-click the Web Browser tab (Figure 17) to expand the window.  

 
Figure 17: Expand Flight Reservation System window 

9. Press Enter to continue. 
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10. You will see the main menu (Figure 18) of the Flight Reservation System application.  

 
Figure 18: Flight Reservation System application screen 

11. Go back to the Personal Communications Session to look at the interactive job.  

12. Sign on using <iSeries_userid> and <iSeries_password>.  
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13. In Personal Communications Session, enter the command line WRKSBSJOB SBS(QINTER) 
(Figure 19). The QQF job is supporting the Web-faced application. 

 
Figure 19: Enter command line information 

14. Try various options in the Flight Reservation System application.  

15. Try Report options to see system screen support (option 2 under the Reports menu). 

16. Click 90 to sign off and exit the Flight Reservation System application.  

17. Double-click the Web Browser tab to go back to the original window size. 
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Optional: Packaging, installing, and testing the Web-faced 
application on an iSeries system 
The objective of this section of the lab is to show how to package a Web-faced application into a 
required J2EE format (EAR file) as well as how to install the application to your WebSphere Application 
Server instance via the iSeries Web Administration console.  
 
Note: To complete this section you must have WebSphere Application Server installed and configured 
on your iSeries system. 

Part 1: Exporting the EAR file 
Export the EAR file by following these steps: 

1. Make sure you have mapped the network drive to the iSeries system so that you can create the 
EAR file in your team directory on the iSeries system. 

2. Select Flight400 project under WebFacing Projects, from the menu option select File > 
Export.  

3. In the Export window, select EAR file (Enterprise Archive file option) and click Next. 

4. In the EAR Export window (Figure 20), select Flight400EAR in the EAR project field. 

 
Figure 20: EAR Export window 

5. Click browse next to the Destination field (Figure 20)  

6. Select a location on your iSeries system using the mapped network drive to the iSeries system.  
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In this example:  

\QIBM\UserData\WebSphere\AppServer\V6\Base\profiles\WAS60AppSvr\installableApps\ 

Flght400EAR.ear  

is used, where WAS60AppSvr is the name of the WebSphere Application Server profile created 
to run the IBM WebFacing Tool application.  

7. Check the Export source files option and click Finish. 

The export process might take awhile, depending on the network speed. 

Part 2: Checking the contents of the EAR file 
Verify the contents of the EAR file by following these steps: 

1. Using Microsoft® Windows® Internet Explorer, go to where you exported the EAR file on the 
mapped network drive (Figure 21).  

 
Figure 21: The EAR file on the mapped network drive 

2. Optional: Right-click the Flight400EAR.ear file and open it with any ZIP utility to see the 
contents of the EAR file. You will see a Flght400.war modules and application descriptor 
(application.xml) file (Figure 22).  

 
Figure 22: Flght400.war module 

3. Exit the ZIP utility. 
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Part 3: Installing the Web-faced application using the IBM Web 
Administration for iSeries console 
To install the Web-faced application with the IBM Web Administration for iSeries console, follow these 
steps: 

1. Go to the iSeries task menu:  

2. In Windows Internet Explorer, type http://<iSeries_Server>:2001.  

3. When prompted, enter your <iSeries_userid> and <iSeries_password>. 

4. Click IBM Web Administration for iSeries. 

5. Click the Manage > Application Servers tab (Figure 23).  

6. Select your WebSphere Application Server profile in the Server list box (Figure 23) where you 
want to deploy your Web-faced application.  

 
Figure 23: Select WebSphere Application Server profile 

7. Click Install New Application under WAS Wizards in the left-hand panel (Figure 23). 
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8. Delete the default path shown and navigate to the location where you deployed your EAR file in 
the integrated file system (IFS).  
In this example the path is: 
/QIBM/UserData/WebSphere/AppServer/V6/Base/profiles/WAS60AppSvr/ 

installableApps/Flght400EAR.ear 

9. Select the Flght400EAR.ear file (Figure 24) and click OK.  

 
Figure 24: Install New Application window 

10. In the Install new application wizard, click Next (Figure 24). 

11. On the Application deployment options step, take the defaults and click Next.  

12. On the Map virtual host to Web modules step, click Next.  
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13. On the Summary screen (Figure 25), click Finish.  

 
Figure 25: Summary screen 

14. A yellow hourglass will indicate that the application is currently being installed. Wait until the 
installation is complete. 

15. You can press the Refresh button to update the status.  
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16. Wait until the status changes (Figure 26) to a red dot (stopped status).  

 
Figure 26: Stopped status 
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Part 4: Starting the Web-faced application 
To start the newly Web-faced application, follow these steps: 

1. Click the Managed Installed Applications link under Applications.  

2. Click the check box next to Flght400 (Figure 27) and click the Start button.  

 
Figure 27: Select Flght400 

3. You will see a green dot next to the application once it starts.  

Part 5: Testing the Web-faced application 
Test the Web-faced application by following these steps: 

1. In Windows Internet Explorer, type http:// <iSeries_Server>:<http_port>/Flight400 and press 
Enter. 

2. You will see the index page of your Web-faced application.  

3. Click Launch to invoke the application.  

4. On the logon page, enter your <iSeries_userid> and <iSeries_password> and click Logon.  

5. On the Flight Reservation System logon page, press Enter.  
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6. Try the Create a New Reservation report option (Figure 28).  

 
Figure 28: Create a New Reservation report option 

7. Click 90 to signoff and exit the Flight Reservation System application. 
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Customizing the Web-faced application  
This lab is an extension of the IBM WebFacing Tool Conversion and Testing Lab, which demonstrates 
how to use the IBM WebFacing Tool to generate the base application. You will learn customization 
techniques that you can employ to enhance the base application. This lab assumes that you already 
have or are familiar with how to use the IBM WebFacing Tool to create this base application.  

Changing style properties 
The style wizard changes the Web-faced application user interface. During this exercise you will 
change the user interface of your application by using the Style properties that are part of the IBM 
WebFacing Tool environment. You will apply the style changes on a project level, so all pages in a 
project will contain the changes. In this lab you will change the text color and font for all highlighted 
fields.  

1. Right-click the Flght400 Web-facing project and select the properties option. 

2. Select the Style > DDS field display attributes node in the list on the left side. 

3. Click the .. option in the High intensity box (Figure 29).  

 
Figure 29: High intensity box option 
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4. In the font dialog: select Comic Sans MS as the font, make the font style Bold,  
select the font size as 14, and click OK (Figure 30).  

 
Figure 30: Select font options 

5. Click OK on the properties dialog. 

6. In the WebFacing projects view, right-click your project and  
select the Run > Run on Server option.  

7. In the Server selection window, choose an existing server,  
select WebSphere Application Server V6.0 under local host, and click Finish.  

8. On the index page display, click the launch button to launch  
the Flight Reservation System application.  

9. When prompted, enter your <iSeries_userid> and <iSeries_password>.  
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10. Notice the different fonts and font sizes of some of the text in the highlighted areas of your new 
graphical screen (Figure 31).  

 
Figure 31: New font name and font size 
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Employing Web settings (hyperlinks) 
In this exercise, you will use Web settings to change the user interface of the Web-faced application. In 
WebSphere Development Studio Client V6.0, Web settings are part of the LPEX editor (an earlier part 
of WebSphere CODE designer). Web settings are stored as comment lines in the DDS source. The 
conversion picks up these specific DDS source comment lines and applies them to the Web-faced user 
interface.  

 
During this exercise, you will use the LPEX editor to add some Web settings to the DDS source. You 
will improve the Web user interface for the city selection window. In this window, currently users must 
enter a 1 in the options field to select a specific city from the subfile. You will change this because it is 
not how things are typically selected in a Web interface. On a Web page, a link will be more natural in 
the way it allows the selection of a record to happen. You will change the second column (city name) in 
the subfile, from a simple text field to a link. The conversion will add logic to the user interface to 
accomplish the following: When the user clicks this link, under the covers of the screen interface, the 
options field will be filled with a 1, indicating that the Enter key has been pressed (Figure 32).  

 
Figure 32: Invoke Enter key 

1. The changed user interface still returns to the application the same information as before the 
Web setting was applied, but the user interface appears more Web-like to the user. The 
application itself does not have to be changed. 

2. The DDS source for city selection subfile is FRS402DF. 

3. In the WebFacing projects view, click the + sign next to DDS to expand DDS members.  
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4. Scroll down to locate FRS402DF and double-click DDS to open it in the LPEX editor (Figure 33).  

 
Figure 33: Locate and open DDS in the LPEX editor 

5. In the outline view, click the + sign next to FRS402DF to expand the DSPF node.  
 

 

6. Expand SFL node to display fields in the subfile.  
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7. Select the SFCTYN 16 field under SFL in the Outline box. You will see the Web Settings view 
in the lower part of the window (Figure 34).  

 
Figure 34: Web settings view 

8. Click Hyperlink in the Web Settings view (Figure 34).  

9. Select the Enable hyperlink check box.  
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10. Notice the change in the DDS source line as you select the Enable hyperlink check box 
(Figure 35).  

 
Figure 35: DDS source line change 
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11. Under On Click, select the Perform actions check box (Figure 36). 

12. Select the Position cursor to field check box and choose &{SFL.SELIO.REF} in the list box 
(Figure 36). 

13. Select the Set field value to check box and enter 1 in the field (Figure 36).  

14. Select the More actions check box (Figure 36).  

15. Select the Submit function key radio button and choose Enter from the list (Figure 36).  

 
Figure 36: Select Web Settings 

16. Go to File > Save (or CTRL+S) to save the DSPF source.  
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17. As the SELIO field is not required for selection, select the SELIO 1 field in the outline view.  
 

 

18. Select Appearance in the Web Settings view and choose the Hidden radio button under 
visibility (Figure 37). 

 
Figure 37: Hide SELIO view 

19. To hide 1, select the text (Figure 38).  

20. Select 1=Select (outlined in red in Figure 38) under SFLCTL node.  

21. Select Appearance in the Web Settings view (Figure 38).  

22. Select the Hidden radio button under visibility (Figure 38).  
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Figure 38: Select and hide text 

23. Choose File > Save (or CTRL+S) to save the DSPF source.  

24. Click X to close the DPSF editor window. 

Reconvert the modified DSPF member:  

25. Right-click FRS402DF and select convert.  
26. In the WebFacing projects view, right-click your project and select the Run > Run on Server 

option to test the modifications.  
 
The city selection subfile will show the hyperlink selection, which includes hidden selection fields 
and text (Figure 39).  
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Figure 39: City Selection Window 
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Using JavaScript to add a clock 
During this exercise, you will use the Web tools in the WebSphere Studio Workbench to add a clock to 
the status bar of the browser window of the Web-faced application. 
 
Execute all JavaScript™ in the Client Script\usr folder at the time of loading the page. This makes it 
easy to add JavaScript to an application that has been enhanced by the IBM WebFacing Tool. For this 
example, you will add Clock.js to the \ClientScript\usr folder of the project. Clock.js will display the 
current date and time in the status bar of the browser. 

1. Go to the WebFacing perspective.  

2. Switch to the Navigator view by selecting the Navigator tab.  

3. Expand the Flght400 project. 

4. Go to the following folders: WebContent > webfacing > ClientScript > usr (shown in Figure 40).  

 
Figure 40: Flght400 folders 

5. Right-click the WebContent/webfacing/ClientScript/usr directory.  

6. From the Pop-up menu select New > Other. 
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7. In the select wizard window, select Web > JavaScript File and click Next. 

8. For the filename enter clock and click Finish. 

9. Change the clock.js file source code EXACTLY as shown below: 

// clock.js 
 
// newFunction 
function doClock() { 
 window.setTimeout("doClock()",1000); 
 today = new Date(); 
 self.status = today.toString(); 
 } 
doClock() 

10. Save the changes by clicking File > Save from the menu bar. 

11. Close the clock.js file in editor by clicking the X on the clock.js window. 

12. Click the WebFacing projects view.  
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13. Right-click your project and select the Run > Run on Server option to test the modifications.  
 
Notice that in the status bar of the browser window the clock is displayed and is updated every 
second (Figure 41).  

 
Figure 41: Display clock 

14. If you do not see the date and time displayed at the bottom of the window, it will be because of 
the page caching. To overcome this you might re-start the project.  

15. Select the Servers view from the bottom tabs on the right-hand side window.  

16. Right-click the WebSphere Application Server V6.0 and select Restart project > Flight400EAR 
(your project).  

17. You will see lot of messages in the console view indicating that the application is started.  

18. Run the application again.  
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Creating a Web-facing portlet  
This section of the lab will take you through the Web-facing portlet wizard to create a Web-facing portlet 
project. The WebSphere Portal Test Environment must be installed into WebSphere Development 
Studio Client for iSeries to complete this lab. 

Creating a Web-facing portlet project 
In this part you will create the Web-facing portlet project by following these steps: 

1. In the WebSphere Development Studio Client window, go to the WebFacing perspective.  

2. Select File > New > WebFacing Portlet Project.  

3. In the WebFacing Portlet Project window (Figure 42), enter the project name 
Flight400portlet. 

4. Click the Show advanced button to see advanced options. In the target server field select 
WebSphere Portal V5.1 stub and click Next.  

 
Figure 42: WebFacing Portlet Project window 

5. In the WebFacing Features window, check Add system screen support and click Next. 

Page 42 of 53 



Using the IBM WebFacing Tool with FLGHT400 lab 

6. In the Select Display File Members To Convert window, select previously defined connection:  
<iSeries_Server> connection.  

7. In the Library field, enter FLGHT400 and click the Refresh DDS list button. 

8. Click the + sign next to FLGHT400 to expand the tree.  

9. Click the + sign next to QDDSSRCD to display all DSPF members. 

10. Select all display file members under QDDSSRCD.  
 
To do this, click the first member, scroll down, press Shift, and select the last member. 
(Alternatively, you can select individual display file members by pressing the Ctrl key while 
picking the individual members.)  

11. Click the arrow button to move these to the right-hand side box (Figure 42).  

 
Figure 43: Select QDDSSRCD display file members 

12. Similarly, select all MNUDDS members under QMNUSRC and click Next. 

13. In the Select UIM Source Members To Convert window, click Next.  
(Note: There are no UIM help members as a part of this application.) 

Page 43 of 53 



Using the IBM WebFacing Tool with FLGHT400 lab 

14. In the Specify CL Commands window (Figure 44), enter the command:  
go FLGHT400/FRSMAIN  

15. Change the command label to Flight Reservation System and click Add.  

 
Figure 44: Specify CL Commands window 

16. Click Next. 

17. In the Choose a Web Style window, select the Web style of your choice and click Next.  

18. In the Complete WebFacing project window, select the default option  
(No. I only want to create project now) and click Finish.  

19. After awhile, you will see your Web-facing portlet project in the WebFacing Projects view.  

20. Click the + sign next to your portlet project to see the project details.  
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Converting the Web-facing project 
1. In the WebFacing Projects view, right-click DDS and select Convert (Figure 45). 

  
Figure 45: Select the Convert option 

2. Conversion might take awhile because, during conversion, the IBM WebFacing Tool retrieves 
the source code from the iSeries system and creates all the portlet application components  
(namely JSPs and XML documents) for each record format. 
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3. After conversion, you will see the DSPF Conversion Log displayed in the log view. Select any 
display file to review the record formats (Figure 46).  

 
Figure 46: DSPF Conversion Log window 

4. To look at the referenced keywords, select the Referenced Keywords tab at the bottom of the 
conversion log window. 
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5. In the Referenced Keywords window, click any display file member to display the keywords 
(Figure 47).  

 
Figure 47: Referenced Keywords window 
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Testing the Web-facing portlet  
In this section, you will test the Web-facing portlet you created in the previous step in the WebSphere 
Portal Server test environment.  

Testing the Web-facing portlet in the WebSphere Portal test environment 
1. In the WebFacing Projects view, right-click your portlet project and select the Run > Run on 

Server option.  

2. In the Server Selection window (Figure 48), check Manually define a server and select 
WebSphere Portal Server V5.0 Test Environment (below server type) and click Finish.  

 
Figure 48: Server Selection window 

3. After awhile, you will see a browser displaying the index page of your Web-faced portlet 
application.  
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4. Click Launch (Figure 49) to invoke the Web-faced application.  

 
Figure 49: Launch the Web-faced application 

5. When prompted for the user ID and password, enter the <iSeries_userid> and 
<iSeries_password> and click Logon. 
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6. You will see a Flight Reservation System logon screen.  

7. Double-click the Web Browser tab (Figure 50) to expand the window.  

 
Figure 50: Web Browser tab 

8. Go back to Personal Communications Session to look at the interactive job. Sign on with your 
<iSeries_userid> and <iSeries_password>.  

9. In the Personal Communications Session window, enter on the command line: 
WRKSBSJOB SBS(QINTER). The QQF job is supporting the Web-faced application.  

10. In the WebSphere Development Studio Client window, try various options in the Flight 
Reservation System application. (Try Report options to see system screen support  
[option 2 under the Reports menu].) 

11. Click 90 to sign off  and exit the Flight Reservation System application.  

12. Double-click the Web Browser tab to go back to the original window size. 

 
END OF LAB 
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Summary 
In this lab, you practiced the following:  

 Created and tested a Web-faced application with the IBM WebFacing Tool 

 Packaged and installed the Web-faced application on an iSeries system using the IBM Web 
Administration for iSeries console 

 Customized the Web-faced application with tools in WebSphere Development Studio Client 

 Created and tested the Web-faced portlet using the Web-facing portlet project wizard 

 
 

Page 51 of 53 



Using the IBM WebFacing Tool with FLGHT400 lab 

Resources 
These Web sites provide reference materials to supplement the information contained within this lab: 
 

 IBM eServer™ i5 Information Center 
publib.boulder.ibm.com/infocenter/iseries/v5r3/ic2924/index.htm 

 IBM eServer p5 Information Center 
publib.boulder.ibm.com/infocenter/pseries/index.jsp 

 IBM Publications Center 
www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi.cgi?CTY=US 

 IBM Redbooks™ 
ibm.com/redbooks 

 Follow a roadmap: iSeries Developer Roadmap: End to End Demo 
ibm.com/servers/enable/site/ideveloper_j2ee/etoe 
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Trademarks 
 
© IBM Corporation 1994-2005. All rights reserved. 
 
References in this document to IBM products or services do not imply that IBM intends to make them 
available in every country. 
 
The following terms are trademarks or registered trademarks of International Business Machines 
Corporation in the United States, other countries, or both:  
 

IBM iSeries WebSphere i5/OS
the IBM logo ibm.com OS/400 Redbooks

 
Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, 
other countries, or both. 
 
Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in 
the United States, other countries, or both. 
 
Other company, product, or service names may be trademarks or service marks of others. 
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