
Configuring the Halftone Calibration
Management System

IBM





Configuring the Halftone Calibration
Management System

IBM



ii Configuring the Halftone Calibration Management System



Contents

Configuring the Halftone Management
System . . . . . . . . . . . . . . . 1
Halftone Management System Overview . . . . . 1

Starting the Halftone Management System . . . 2
Calibrating a Densitometer . . . . . . . . 3

Calibrating a Printer Using the Halftone Management
System . . . . . . . . . . . . . . . . 4

Defining Infoprint Servers to the Halftone
Management System Client . . . . . . . . 4

Defining Custom Patch Sets . . . . . . . . 7
Calibrating a Halftone . . . . . . . . . . 8
Measuring Optical Density with a Densitometer 12

Specifying a Halftone for Printing on the Infoprint
AIX Server . . . . . . . . . . . . . . 12

Printing from Infoprint Submit . . . . . . . 12
Printing from the AIX Command Line . . . . 12

iii



iv Configuring the Halftone Calibration Management System



Configuring the Halftone Management System

Halftone Management System Overview
To support printer calibration on devices such as the IBM Infoprint 20 and the IBM
Infoprint 4000, use the Halftone Management System. The Halftone Management
System gives you the ability to calibrate halftones for each screen frequency on all
your Intelligent Printer Data Stream (IPDS) printers. The result is consistent
grayscale for each appearance selection.

With the Halftone Management System, you can run multiple IBM Infoprint 4000
printers and calibrate each system. For two-engine duplex print systems, the
Halftone Management System also allows you to calibrate each print engine
separately, so that whatever document you print , the various levels of gray
(grayscale) used to print the document will look the same on both engines. Note
that this applies to input file types of TIFF, GIF, or JPEG; for both PostScript and
Portable Document Format (PDF) files, a single calibration applies to both engines.

From the smallest network printer to the largest production printer, you can either
use the halftone provided with Infoprint Manager or create your own. You can
calibrate for different paper types to account for differences between supplies.
Infoprint Manager will save and manage these calibrations, allowing you to select
them on a job-by-job basis.

The Halftone Management System consists of two parts:
1. A daemon process (runcalibd) that runs on all Infoprint AIX servers.
2. A client process (runcalib) that can be run from any Infoprint AIX server.

You can calibrate printers on any Infoprint AIX server by using the client from
another Infoprint AIX server. For example, if you have installed Infoprint servers
A, B and C, you can calibrate printers on A using the client on either A, B or C.
The daemon must be running on server A.

You invoke the Halftone Management System through the Printer Calibration icon
(the page embossed with a lower-case "i" that is the fourth icon from the right) on
the toolbar of the Infoprint Manager desktop (note that the Printer Calibration
icon is available through the Infoprint Basic Configuration only; to use the
Halftone Management System in an Infoprint Advanced configuration, you must
use the command described in “Starting the Halftone Management System” on
page 2):

This topic describes the following two procedures that you should ensure have
been completed before attempting to use the Halftone Management System:

Figure 1. Printer Calibration icon
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1. “Starting the Halftone Management System”
2. “Calibrating a Densitometer” on page 3

Starting the Halftone Management System
If you find the Halftone Management System icon in the tool bar on your Infoprint
Manager desktop and it starts, you do not need to perform this procedure and
should go to “Calibrating a Densitometer” on page 3. If you do not see the
Halftone Management System icon on your Infoprint Manager desktop or it does
not start, you can use the following procedure to start the Halftone Management
System:
1. From your Infoprint AIX server’s command line, ensure that your Infoprint AIX

server is running by specifying:
ps -ef | grep server where server is the name of your Infoprint AIX server.
You should see a response that shows the server running. Note that the
following response example has been split across two lines for clarity:

ID Process # Time

root 26078 "1" "0"
"Mar 20 -
11:24:36"

Process and Server Name
ksh /usr/lpp/pd/ipcal/bin/runcalibd

Note: The server must be running before you start the Halftone Management
System client.

2. If the Calibration daemon (runcalibd) is not running, start it by specifying:
/usr/lpp/pd/ipcal/bin/runcalibd&

3. From the toolbar that displays at the bottom of the Basic Infoprint
Administrator’s GUI (displayed below), double-click on the Printer Calibration
icon (fourth icon from the right).

This icon starts the Halftone Management System client.

If your system uses the Infoprint Advanced Configuration, you must do the
following from the command line:
a. Select a directory to start it from and always start from that directory. This

is because a file will be created in that directory that contains information
about the servers defined: cd /calibration-client

Note: If you start from a different directory you have to redefine the
servers to which you want to connect. Multiple Halftone
Management System clients can be started on the same AIX server,

Figure 2. Printer Calibration icon
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but they must be started from different directories. Because the
clients would try to share the calibgui.db file, you cannot start two
clients from the same directory.

b. Invoke the client: /usr/lpp/pd/ipcal/bin/runcalib&

From the client screen, a pop-up Halftone Management System window
announces Starting the Halftone Management System Client.

To open this window, the client has created a calibgui.db file in the directory
from which you entered the command.

If you either press the Printer Calibration icon or invoke the client from the
command line before starting the Halftone Management System daemon, but
after defining your Infoprint AIX server, Infoprint Manager provides an Error
pop-up dialog with the following message:
Error in connecting to host fully_qualified_server_name -- A remote host refused an attempted

To resolve this problem, you must close the Halftone Management System
client window and restart the daemon. Once you have completed these steps,
go to “Defining Infoprint Servers to the Halftone Management System Client”
on page 4.

Calibrating a Densitometer
The reflection densitometer must be calibrated to provide accurate density
readings. Prior to using, you must follow the instructions that are provided by the
manufacturer to calibrate the densitometer. The densitometer used must comply to
the spectral responses defined by ANSI PH2.18 - 1985 and ISO 5/3 - 1984. The
densitometer should not have a polarizing filter. The Greytag Macbeth model
D19C has a polarizing filter and should not be used. Densitometers which are
appropriate to use include the X-Rite Model 504, 508, or 400B.

The densitometer should be used in Absolute Density mode for measurements.
The following procedure describes how to calibrate the X-RITE 400B (1060)
densitometer, using the Reflection Reference Card (part number 400-62). Since the
X-RITE 400B is now obsolete, the following information is provided as reference.

The Reflection Reference is the card that is used to calibrate the densitometer. You
will use only the circular patches labeled 1 (white reference) and 3 (black
reference). The densitometer should be calibrated periodically, or whenever the
instrument displays RECAL. You should store the Reflection Reference Card in its
envelope.
1. Press the FUNCTION and ENTER keys in sequence, then release.

After the version and copyright notices appear, the display will show N cal O
Y.

2. Press the ZERO key and release.
After the version and copyright notices appear, the display will show N qcal Y.

3. Press the FUNCTION key and release.
SET LO is displayed momentarily, followed by X.XX, where X.XX should be the
white patch ORTHO value from the Reflection Reference card.

4. If X.XX matches the white patch ORTHO value for your reflection reference,
press the ENTER key. If X.XX does not match, hold down the ZERO key and
press either the FUNCTION or the ENTER key. Decrease (FUNCTION) or
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increase (ENTER) the value until the correct number is displayed. When
finished, release the keys and press Enter.
SET HI is displayed momentarily, followed by Y.YYH , where the Y.YY part of
the value should be the black patch ORTHO value from the Reflection
Reference card.

5. If Y.YY matches the black patch ORTHO value for your reflection reference,
press the ENTER key. If Y.YY does not match, hold down the ZERO key and
press either the FUNCTION or the ENTER key. Decrease (FUNCTION) or
increase (ENTER) the value until the correct number is displayed. When
finished, release the keys and press Enter.

6. When you see READ WHT displayed, center the circle on the base of the
densitometer over the white patch (the one labeled ″1″) on the Reflection
Reference. Push the head down and then release it to establish the white patch
Optical Density.
If INVALID displays, repeat the measurement.

7. When you see READ BLK displayed, center the circle on the base of the
densitometer over the white patch (the one labeled ″3″) on the Reflection
Reference. Push the head down and then release it to establish the black patch
Optical Density.
If INVALID displays, repeat the measurement.

Verify the calibration by measuring the black, gray, and white patches. If they
agree within 0.02 OD to the reflection reference values on the card, density is
accurately calibrated. If not, repeat this process until the measurements are
accurate.

To find out how you can calibrate and set output appearances, see “Calibrating a
Printer Using the Halftone Management System”.

Calibrating a Printer Using the Halftone Management System
The Halftone Management System allows you to calibrate each of your printers to
achieve a consistent tone curve for a set of generic halftone screens. The system
also allows you to define additional calibrations for specific paper types. When
calibrated the dot gain for a fifty percent dot will be nominally zero percent for
Standard appearance, fourteen percent for Highlight Midtown appearance, and
thirty-four percent for Dark appearance.

To use this tool to calibrate your printers, perform the following procedures in
sequence:
1. Defining Infoprint Servers to the Halftone Management System Client
2. Defining Custom Patch Sets
3. Calibrating a Halftone
4. Measuring Optical Density with a Densitometer

Defining Infoprint Servers to the Halftone Management System
Client

The first time you start the Halftone Management System client, you will see an
empty window. You must connect to the Infoprint AIX server to see a list of the
printers that are available for calibration:
1. From the Halftone Management System (or Main) window, select the Edit →

Servers option.
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2. From the Servers window, select the File → Add Server option.
3. In the Server Properties window, fill in the Server Name field with the

symbolic server name, and the Hostname field with either the explicit name of
the server or the server’s dotted decimal notation IP address.
For example, the Server Name field value could be
sage.penn.boulder.ibm.com, while the Hostname field value could be either
sage or 9.99.43.73 .

4. Return to the Main window and either use left mouse button to double-click
on each printer or highlight the printer and press enter to display its output
screens (as displayed below). The Main window displays all printers defined to
the Infoprint server to which you are connected, but only the IPDS printers
contain screens that can be calibrated.
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Figure 3. Main window
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Defining Custom Patch Sets
A patch set is a step wedge file that has patches with different shades of gray. One
patch set has been defined (patches11 ). It has eleven uniformly-stepped grays.

To define additional patch sets, use the following procedure:
1. From the Halftone Management System window, select the Edit → Patch Sets

option.
2. From the Patch Sets window, click on a patch set (such as patches11) and

select the Edit → Properties option.
3. From the Patch Set name window (where name indicates the patch set

highlighted in the previous step), use the left mouse button to select the
patches that you would like to modify.
The screen shows 99 squares representing from 1-to-99 percent dot at one
percent increments. Squares which are dark will be printed. To change a patch
selection, point to the patch desired and click the left mouse button. Each click
selects or deselects a patch. 0 percent and 100 percent dot patches are always
included in each patch set. The example displayed below will print 0, 10, 20,
30, 40, 50, 60, 70, 80, 90, and 100 percent dot patches.

4. Once you have defined the patch set, select the File → Save as option and save
your patch set with a unique name.
Note that the shipped patch set patches11 cannot be modified. However, a
user-created patch set can be modified through the Save option. In the example
below, the Save option is grayed-out because no changes have been made to
the file.
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Calibrating a Halftone
Once you have either selected an existing patch set or created your own
customized patch set, you must print it out, use a densitometer to measure the
density of each gray patch. Then you must enter the calibration values in the
Halftone Calibration Management System to create a calibration curve for the
printer.

Note: Ensure that you use the Halftone Management System to both add and
delete patch files and Calibration files.

Use the following procedure to accomplish these tasks:
1. If desired, define a custom patch set to print from the Halftone Management

System window from the menu bar by selecting EDIT→ PATCH SETS, then
selecting the patch from the list and ACTIONS→ SELECT AS CURRENT,
FILE→CLOSE.

2. From the Halftone Management System window, select a printer and a
halftone screen supported by that printer.

3. From the Halftone Management System window, select the Actions → Print
Patches option.

4. If the actual destination you chose has a logical-destination-assigned
attribute, the patch set will be sent to that logical printer. Otherwise, you will
be prompted for a logical printer.

5. From the pop-up window, select OK.

Figure 4. Patch set name window
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6. Once you retrieve your output from the printer, use the densitometer to
measure the patches. Because the Halftone Management System is designed to
take multiple measurements of each patch and use the average, you could
take three measurements of each patch.

7. Select the same actual destination (printer) and screen that you selected before
you printed the patch set (in 2 on page 8).
Note that the printed patch set identifies the screen, patch set, and printer,
along with a date/time stamp.

8. From the Halftone Management System window, select the Actions →
Calibrate option.

9. From the Enter calibration values window (shown below), set The number of
entries to average field (it defaults to 3) to the number of measurements you
took for each patch.

10. If this is a custom calibration and you want it to replace the default calibration
provided by Infoprint Manager, allow it to retain the default value in the
Calibration name field. If you want to retain the original default, but have
this custom calibration as a second option, type a name for the calibration in
the Calibration name field.

11. To enter your densitometer readings, begin with the 0% field. Enter your first
0% value and press Enter. The statistics of your values will be displayed
under the columns Average, Min, and Max.
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If you specified more than 1 in the number of entries to average field, the
cursor will remain in the field for your next reading. Otherwise, it will move

Figure 5. Enter calibration values window
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on to the next patch field. Continue until all your readings have been entered.
The display below shows a sample customized Calibration named first_run.

Figure 6. First_run calibration
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12. Once you have filled in your calibration values, press the Do button. Your
calibration is saved in the /usr/local/Infoprint/config directory and ready for
use.

Measuring Optical Density with a Densitometer
The following procedure describes how you can measure optical density using the
XRITE 400B Densitometer. While you can use other densitometers, this procedure
has been verified with this particular make and model. Ensure that the density
readings are absolute, not paper reference.
1. Press the FUNCTION key until DEN appears. If DEN-R appears, press the

ZERO key and try again.
2. Center the circle on the base of the densitometer over the area to be measured.
3. Push the head down and release it to measure the Optical Density (OD).

The density reading will appear as X.XXD.
4. Record the X.XX value as it is displayed.

Several measurements should be taken at different representative locations on
each gray patch and averaged to obtain an accurate OD value. Alternately, you
can enter individual measurements into the calibration value screen and have
the averaging performed automatically.

Specifying a Halftone for Printing on the Infoprint AIX Server
You can use a particular halftone for printing a grayscale file through either
Infoprint Submit interface or the AIX command line.

Note: The Halftone Management System does not need to be running when you
print the job.

Printing from Infoprint Submit
You can print using a particular halftone for printing a grayscale file from a job
ticket (name.jtk file) in Infoprint Submit. Through this interface, you can specify a
specific screen and output appearance. Begin by selecting a value in the Screen
Name field of the Look tab. Note that all screen frequencies shipped with the
product have the term ’ibm’ prepended to their identifier. If you are accessing this
interface for the first time, all your previous default calibrations will have ’ibm’
attached to the name.

Infoprint Manager allows you to determine output appearance on a job-by-job
basis by setting a default screen and output appearance in a default document or
job object.

Printing from the AIX Command Line
You can submit a halftone calibration from the AIX command line by using some
variation of the following pdpr Command.

Note that this command is spread across three lines to illustrate each component
more clearly:

Command Printer

pdpr -p sip20-sage
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Customized Calibration file

-x halftone=generic106lpi:highlight-midtones:mycal

File to Be Printed

grayscale.ps

Note: When submitting a pdpr command from the AIX command line, you specify
the halftone attribute, rather than setting both frequency and output
appearance as you do when using the Infoprint Submit interface. The actual
halftone name for this example (generic106lpi:highlight-midtones:mycal)
can be found either by using the Infoprint Manager Administration GUI to
look up the halftone for the actual destination, or enter the following at the
command line: pdls -cp -r halftones-supported ActualDestination name.
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