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Chapter 1. Installing the Alphablox sample databases

Sample data from the Quality Chocolate Company (QCC) is used in the DB2®
Alphablox tutorials, Blox Sampler example applications, and many of the code
samples in the DB2 Alphablox Information Center.

This sample data is available for different databases:

Relational
You must install one of the relational versions of the QCC sample data in
order to follow the first tutorial to build your first application. The QCC
cube created from the relational data is used in tutorials and the Blox
Sampler example applications.

e DB2

* Apache Derby

o Informix®

+ Microsoft® SQL Server
* Oracle
¢ Sybase

Multidimensional
The Blox Sampler example set also runs on the following multidimensional
databases. These are not required for the tutorials. However, if you are
using one of the following databases in your environment, you should
install the QCC sample data to take advantage of the live examples in the
Blox Sampler applications.

« IBM® DB2 OLAP Server" V8.1; Hyperion Essbase V6.5
« IBM DB2 OLAP Server V8.2; Hyperion Essbase V7.1

* Microsoft SQL Server 2000 Analysis Services

* Microsoft SQL Server 2005 Analysis Services

QCC background

Our hypothetical company, Quality Chocolate Company, is a fast growing retail
store chain that sells a small selection of traditional gourmet confections plus a few
seasonal specialty items. QCC started in a small town and has increased both the
size of its product line and in number of locations in just a few years. The
company now wants to be able to do sales analysis, gross margin analysis, and
budget analysis. In addition, QCC also wants to monitor various attributes about
their products, such as type of chocolate (dark, milk, or white) and whether the
product contains nuts, to help them determine and analyze what their customers
prefer.

Building a cube from a sample relational data source

Relational tables for the Quality Chocolate Company (QCC) sample data and a
cube definition property file are provided so that you can create an Alphablox cube
from your relational data.

To build an Alphablox cube from the supplied QCC relational data involves three
general steps:

© Copyright IBM Corp. 1996, 2006 1
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1. |Install the sample datal

2. |Define the data sources|for both the underlying relational data source and the
cube that is going to be built on the relational data source through the DB2
Alphablox Admin Pages.

3. |Create the cube definition|by storing the provided cube definition property file
into your DB2 Alphablox Repository. This property file contains the information
that describes the dimensions, measures, and levels in the cube and where the
data is stored in the underlying relational data source.

Installing the sample data

Before you can build an Alphablox cube with the Quality Chocolate Company
(QCC) sample data you need to install the QCC tables into your database server.

Select the appropriate installation instruction for your database server.

Installing the sample data for DB2
Sample data is provided for DB2 data sources. You must install the sample tables
before you can use them to build an Alphablox cube required for the first tutorial.

To install the Quality Chocolate Company (QCC) sample data for DB2 data
sources:

1. Copy all the files in the sampledata/qcc/db2 directory on the Alphablox
installation CD into a directory on the machine that has the DB2 client
installed.

2. Add your DB2 connection in the Control Center.

3. From a command prompt, go to the directory where you copied the files, and
run the qcc_db2.bat file with the parameters of your DB2 database name, user
name and password. For example: qcc_db2 test db2admin password. This
command logs you into your DB2 database named test as user db2admin with
the password of password and loads the data into the qcc table. Two files are
created:

* A db2_command.txt file that includes the DB2 connection parameter and the
db2_qcc.sql file.

* A gcclog log file for loading the QCC data.

Note: The qcc table will be dropped if it already exists.
4. View the log file for any message.

The tables are now installed.

Continue with [“Defining the data sources” on page 5|to define both the relational
data source and the cube data source to DB2 Alphablox.

Installing the sample data for Derby
Sample data is provided for Derby data sources. You must install the sample tables
before you can use them to build an Alphablox cube required for the first tutorial.

To install the Quality Chocolate Company (QCC) sample data for Derby data
sources:

1. Copy all files in the sampledata/qcc/derby directory on the Alphablox
installation CD into a directory on the machine that has the Derby server
installed.

2. Open the qcc_dby.bat file in a text editor.

IBM DB2 Alphablox: Getting Started



3. Check the DERBY_INSTALL and JAVA_INSTALL paths and change them if
necessary. The default value for DERBY_INSTALL is C:\Program
Files\IBM\Cloudscape_10.0, and the default for JAVA_INSTALL is C:\Program
Files\IBM\Cloudscape_10.0\ibm-jre-n142p\jre\bin.

4. From a command prompt, go to the directory where you copied the files and
run theqcc_dby.bat file with parameters of your DB2 database name, user
name, and password. This creates a Blox database and tables under the user
abx. A log file gcc.log is also created for loading the qcc data.

Note: The QCC table will be dropped if it already exists.
5. View the log file for any messages.

The tables are now installed.

Continue with [‘Defining the data sources” on page 5|to define both the relational
data source and the cube data source to DB2 Alphablox.

Installing the sample data for Informix

Sample data is provided for Informix data sources. You must install the sample
tables before you can use them to build an Alphablox cube required for the first
tutorial.

Make sure that you created environment variables INFORMIXDIR and
INFORMIXSERVER. Please check the IBM Informix DB-Access User’s Manual for
more information about using DB-Access.

To install the QCC sample data for Informix data sources:

1. Create a database where you want to load the sample data in your Informix
server.

2. Copy all files in the sampledata/qcc/informix directory on the Alphablox
installation CD on the machine where the Informix server is installed.

3. From a command prompt, go to the directory where you saved the files and
type dbaccess.

4. Connect to the database where you want to load the sample data.
a. Select DBAccess » Connection.
b. Select Connect.
c. Select the database server.
d. Type the user name for the database administrator.
e. Type the password.
f. Select the database. The database is now connected.
g. Select Exit.

5. Load the SQL files to create tables.

Select DBAccess » Query-language.

Select Choose.

Select the gec_inf.sql file.

Select run. The tables are created.

® a0 oD

Select Exit to return to the command prompt.

6. Load the data. Run the gqcc_inf.bat from a command prompt with the
parameter of the database name. For example: gqcc_info blox.

Note: A log file qcc.log is created after running the batch file.
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The tables are now installed.

Continue with [“Defining the data sources” on page 5|to define both the relational
data source and the cube data source to DB2 Alphablox.

Installing the sample data for Microsoft SQL Server

Sample data is provided for Microsoft SQL Server data sources. You must install
the sample tables before you can use them to build an Alphablox cube required for
the first tutorial.

To install the Quality Chocolate Company (QCC) sample data for Microsoft SQL
Server data sources:

1. Copy all files in the sampledata/qcc/mssql directory on the Alphablox
installation CD into a directory on your machine.

2. From a command prompt, run the qcc_sql.bat file and specify your SQL server
connection parameters (server database table owner user password). For
example, qcc_sql serverl? blox dbo sa. This command runs the batch file and
connects to the SQL server database at the serverl2 server, with database
named blox, table owner of dbo, user named sa, and the password of null.
Running the qcc_sql.bat script creates the following log files:

¢ A qcc.log file for creating the qcc tables.

* A gcc_fact.log file for loading data into the qcc_fact table.

* A gcc_locations.log file for loading data into the qcc_locations table.
* A gcc_products.log file for loading data into the qcc_products table.
* A gcc_scenarios.log file for loading data into the qcc_scenarios table.
* A gcc_time.log file for loading data into the qcc_time table.

Note: The qcc table will be dropped if it already exists.
3. View the log files for any messages.

The tables are now installed.

Continue with [“Defining the data sources” on page 5|to define both the relational
data source and the cube data source to DB2 Alphablox.

Installing the sample data for Oracle
Sample data is provided for Oracle data sources. You must install the sample tables
before you can use them to build an Alphablox cube required for the first tutorial.

To install the Quality Chocolate Company (QCC) sample data for Oracle data
sources:

1. Copy all files in the sampledata/qcc/oracle directory on the Alphablox
installation CD onto the machine where the Oracle client is installed.

2. Run the qcc_ora.bat file with the parameters for your Oracle connection. For
example, in a DOS prompt, type qcc_ora serverl oraadmin tiger. This
command runs the batch file and connects to the serverl Oracle database as
user named oraadmin with the password of tiger. The following log files are
created when you run the batch file:

¢ A qcc.log file for creating the qcc tables.

* A gcc_fact.log file for loading data into the qcc_fact table.

* A gcc_locations.log file for loading data into the qcc_locations table.
* A gcc_products.log file for loading data into the qcc_products table.
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* A qcc_scenarios.log file for loading data into the gcc_scenarios table.
* A qcc_time.log file for loading data into the gcc_time table.
3. View the log files for any messages.

The tables are now installed.

Continue with [“Defining the data sources”| to define both the relational data source
and the cube data source to DB2 Alphablox.

Installing the sample data for Sybase

Sample data is provided for Sybase data sources. You must install the sample
tables before you can use them to build an Alphablox cube required for the first
tutorial.

To install the Quality Chocolate Company (QCC) sample data for Sybase data
sources:

1. Copy all files in the sampledata/qcc/sybase directory on the Alphablox
installation CD into a directory.

2. Run the gcc_syb.bat file with the parameters for your Sybase connection. For
example, in a DOS prompt, type qcc_syb serverl blox dbo sa. This command
runs the batch file and connects to Sybase on the serverl server, to the blox
database as the table owner dbo and user named sa with no password. The
following log files are created when you run the batch file:

* qcclog for creating the qcc tables

* qcc_fact.log for loading data in the qcc_fact table

* qcc_locations.log for loading data in the qcc_locations table
* qcc_products.log for loading data in the gcc_products table
¢ qcc_time.log for loading data in the qcc_time table

3. View the log files for any messages.
The tables are now installed.

Note: The qcc table will be dropped if it already exists.

Continue with ["Defining the data sources”| to define both the relational data source
and the cube data source to DB2 Alphablox.

Defining the data sources

After the relational tables for Quality Chocolate Company (QCC) are installed for
your database, define two data sources, one for the relational data source and the
other for the cube that you are going to create.

To define the data sources:

1. Create the qcc2003-rdb data source. This data source is used as the underlying
relational data source for your QCC cube.

a. Open the DB2 Alphablox home page in a browser window. The URL is
http:/ /your server:port/ AlphabloxAdmin/home.

Select Administration > Data Sources tab.
Click Create to create a data source connection for the QCC tables.
In the Data Source Name field, type qcc2003-rdb.

Specify the appropriate connection parameters to connect to your QCC
tables.

®ao0o0o
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f. Click Save.
2. Create the qcc2003-acs data source. This data source is for the QCC cube.
a. Select Administration > Data Sources on the DB2 Alphablox home page.
b. Click Create to create a data source connection for the DB2 Alphablox Cube.

c. In the Data Source Name field, type qcc2003-acs, and select Alphablox
Cube Server Adapter from the Adapter list.

d. Click Save.

The last step for building a cube from the QCC sample data is to store the
supplied cube definition file into the DB2 Alphablox repository.

« If you are using a file-based repository, follow the steps in [‘Creating the sample|
[cube definition for a file-based repository.”]

 If you are using a database for the repository, follow the steps in [‘Creating the

[sample cube definition for a database-based repository.”|

Creating the cube definition

Choose the instructions for creating the cube definition based on the type of
repository you are using.

Creating the sample cube definition for a file-based repository
After you install the sample Quality Chocolate Company (QCC) data and define
the sample data sources, you must create the cube definition.

Ensure that you installed the QCC sample data, and both the relational data source
and the cube are defined to DB2 Alphablox.

To create the QCC cube definition:
1. In the db2alphablox_dir /repository directory, create a "cubes” directory.

2. In the db2alphablox_dir/repository/cubes directory, create a "qcc_2003"
directory.

3. Copy qcc_2003.properties from the sampledata/qcc/acs directory on the CD
into the alphablox_dir/repository/cubes/qcc_2003 directory.

4. Restart the application server where DB2 Alphablox is running.

The cube definition is now stored in the DB2 Alphablox repository. The cube is
now created and defined to DB2 Alphablox and ready for use with the tutorials
and Blox Sampler.

Creating the sample cube definition for a database-based
repository

After you install the sample Quality Chocolate Company (QCC) data and define
the sample data sources, you must create the cube definition.

Ensure that you installed the QCC sample data, and both the relational data source
and the cube are defined in DB2 Alphablox.

To create the QCC cube definition:
1. Create a temporary directory on your system. For example, c:\temp.

2. Copy qcc_2003.properties from the sampledata/qcc/acs directory on the CD
into the temporary directory that you created in Step 1.

3. Shut down DB2 Alphablox by shutting down the application server where
DB2 Alphablox is running.
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4. Run ConvertRepository.bat (or ConvertRepository.sh) in the
db2alphablox_dir/bin/ directory to add the cube definition that is stored in the
gcc_2003.properties file into your database repository.

5. Choose the option to convert from one repository to another (option 3).
6. Choose the option to convert from file to database (option 1).

7. When asked to provide the repository root, type the path to the temporary
directory where you copied the qcc_2003.properties file in Step 2.

8. Follow the prompts and provide the appropriate connection parameters.

9. When asked to choose the conversion operation, type U to update the
database.

10. After the conversion is complete, restart DB2 Alphablox by starting up the
application server where DB2 Alphablox is running.

The cube is now created and defined in DB2 Alphablox and ready for use with the
tutorials and Blox Sampler.

Installing multidimensional sample data

Multidimensional versions of the Quality Chocolate Company (QCC) sample data
are provided for use with the Blox Sampler.

To install the QCC sample data and get it ready for use with the Blox Sampler
involves two general steps:

1. Install the sample data. Select the installation instruction for your
multidimensional database.

+ IDB2 OLAP Server V8.1 and Hyperion Essbase V6.5
« IDB2 OLAP Server V8.2 and Hyperion Essbase V7.1
+ [Microsoft SQL Server 2000 Analysis Services|
* [Microsoft SQL Server 2005 Analysis Services|

2. |Define the data source to DB2 Alphablox.|

Installing sample data for DB2 OLAP Server V8.1 and
Hyperion Essbase V6.5

Sample data is provided for DB2 OLAP Server V8.1 and Hyperion Essbase V6.5
data sources. This Quality Chocolate Company (QCC) sample data can be used
with the Blox Sampler.

To install the QCC sample data for DB2 OLAP Server V8.1 and Hyperion Essbase
V6.5 data sources:

1. Connect with the DB2 OLAP Server or Essbase Application Manager.
a. Start your DB2 OLAP Server or Hyperion Essbase.
b. Open the Application Manager application.
c. Select Server » Connect, and type your login name and password.
d. Press OK.
2. Create an application.
a. Select File » New » Application.
b. Type Blox as the application name and Server as the location.
c. Click OK.
3. Create a database.

Chapter 1. Installing the Alphablox sample databases 7
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a. Select File » New » Database.

b. Type qcc as the database name.
4. Open and save the gcc outline.

a. Click Open to open the outline.

b. Select File > Open from the Application Manager window.
c. In theLocation field, select Client.
d

. Click the File System button and navigate to the qcc.otl outline file at
sampledata/qcc/essbase6/ on the DB2 Alphablox CD.

Click the Open button to open the outline.

©

f. Close the original Outline Window. The outline window has no hierarchy
displayed.

g. With the New Outlines window opened, select File > Save As from the
Application Manager window.

h. In the Location field, select Server.

i. In the Application field, select blox.

j- In the Database field, select gcc.

k. Click OK.

I. Close the Outline window.

5. Load the qcc data.

a. From the Application Manager window, select Database » Clear Data » All.

b. Select Database » Load Data

c. In the Data Files field, select Find.

d

. In the Open Server Data File Objects window that opens, select the Client
radio button in the Location box.

e. Click the File System button.

f. Navigate to the qcc.txt file under sampledata/qcc/essbase6/ on the DB2
Alphablox CD and click Open to add the file to the list of Data Files.

g. Click OK. The files are loaded.
6. Calculate the cube.
a. Select Database » Calculate.
b. When the operation is complete, exit the Application Manager.

The sample database is now installed.

Next define the data source to DB2 Alphablox by following the steps in
fthe data source” on page 11.|

Installing sample data for DB2 OLAP Server V8.2 and
Hyperion Essbase V7.1

Sample data is provided for DB2 OLAP Server V8.2 and Hyperion Essbase V7.1
data sources. This Quality Chocolate Company (QCC) sample data can be used
with the Blox Sampler.

To install the QCC sample data for DB2 OLAP Server V8.2 and Hyperion Essbase
V7.1 data sources:

1. Connect with DB2 OLAP Server or Essbase Administration Services
a. Start your DB2 OLAP Server or Hyperion Essbase.
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b. Open the Administration Console of your DB2 OLAP Server or Hyperion
Essbase Administration Services.

c. Confirm that your DB2 OLAP Server or Hyperion Essbase appears in the
navigation frame under Analytic Servers.

. Create an application.

a. In the navigation tree under your server, right-click Applications and select
Create Application » Using Block Storage.

b. In the Create Application window, type Blox in the Application Name field.
c. Click OK.

. Create a database.

a. Expand the Blox application that you just created.

b. Right-click Databases, and then select the Create Database option.
c. In the Create Database window, type qcc and press OK.

d. Expand Databases and verify that the new qcc database exists.

. Open and save the gcc outline.

a. On the Administration Console menu bar, select File » Open.

b. In the Open window, click the File System tab, and browse to the
sampledata/qcc/essbase6 directory on the DB2 Alphablox CD.

c. Select the qcc.otl outline file, and click OK button.

d. Confirm that new outline is displayed in the right frame.

e. On the Administration Console menu bar, select File » Save As.
f

. In the Save As window, click the Analytic Server tab, and navigate to the
qcc directory.

g. Select the existing qcc.otl file, and click OK.

h. In the Confirmation window, click Yes to replace the existing file.

i. When prompted to open the outline, click Yes to verify that the new outline
appears.

. Load the qgcc data.

a. In the Administration Console, right-click the qcc database listing and select
the Load Data option.

b. In the Data Load window, click the Find Data File button. The Open
window appears.

c. Click the File System tab, and browse to the sampledata/qcc/essbase6
directory on the DB2 Alphablox CD.

d. Select the qcc.txt data file and then click OK.

e. In the Data Load window, confirm that the data file is listed, and then click

OK. The Data Load Completed window appears, showing that the data file
has loaded with no errors.

f. Click Close.

. Calculate the cube.

a. In the Administration Console, right-click on qcc again, but this time select
the Execute Calculation option.

b. In the Execute Database Calculation window, verify that the default
calculation is highlighted and then click OK. After the calculation script is
finished, you should see a message in the Messages window stating that the
calculation script executed successfully.

c. Close the Administration Console.

Chapter 1. Installing the Alphablox sample databases 9



The sample database is now installed.

Next define the data source to DB2 Alphablox by following the steps in
fthe data source” on page 11.]

Installing sample data for Microsoft SQL Server 2000 Analysis
Services

Sample data is provided for Microsoft SQL Server 2000 Analysis Services data
sources. This Quality Chocolate Company (QCC) sample data can be used with the
Blox Sampler.

To install the QCC sample data for Microsoft SQL Server 2000 Analysis Services:

1. Copy the Blox.CAB and qcc.mdb files from sampledata/qcc/msas on the DB2
Alphablox installation CD to a directory on your system (for example, C:\Blox).

2. Right-click the gcc.mdb file, and ensure that the option Read Only is
unchecked.

3. In Analysis Manager, restore the cube:
a. Right-click the database server and select Restore Database.
b. Navigate to the Blox.CAB file that you copied in Step 1.

c. Select Blox.CAB and click Open. If you are prompted to overwrite the
existing database, click Yes.

d. In the Restore Database window, click Restore.

e. When a message at the end of the window indicates that the database is
successfully restored, click Close.

4. If your qcc.mdb file is not saved in C:\Blox, which is what the CAB file
expects, edit the data source as follows:

a. Expand the Blox database.

Expand Data Source.

Right-click the "C blox qcc mdb” option and select Edit.
Select the Connection tab.

® oo o

Edit the path of your qcc.mdb file in the Select box, or type a database
name in the edit box.

f. Click Test Connection to ensure that you can connect to the data source.
g. Click OK.
5. Check if the writeback functionality is enabled for the qccwb cube.
a. Expand the Blox database.
b. Expand the Cubes folder.

c. Right-click the qccwb cube and select Write-Enable from the menu. If you
see Writeback Options from the right-click menu, that means the writeback
functionality is enabled.

d. Click OK

e. If the writeback functionality is not enabled, right-click the gccwb cube
again. You should see Writeback Options this time.

The sample database is now installed.

Next define the data source to DB2 Alphablox by following the steps in
the data source” on page 11|
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Installing sample data for Microsoft SQL Server 2005 Analysis

Services

Sample data is provided for Microsoft SQL Server 2005 Analysis Services data
sources. This Quality Chocolate Company (QCC) sample data can be used with the
Blox Sampler.

To install the QCC sample data for Microsoft SQL Server 2005 Analysis Services:

1.

6.

Copy the qec_ssas.abf and qcc_ssas.mdb files from sampledata/qcc/ssas2005 on
the DB2 Alphablox installation CD to a directory on your system (for example,
C:\sampledata\qcc\ssas2005).

Right-click the gcc_ssas.mdb file, and ensure that the option Read Only is
unchecked.

In SQL Server Management Studio, restore the cube:

a. Right-click the Databases folder under your database server and select
Restore.

Select the Restore target -> From backup file option.
In the Selected path field, specify the path to the qcc_ssas.abf file.
Type the name qcc_ssas as the file name, and click OK.

® oo o

Type password in the Password encryption field and click OK. This
password is required because the backup file is encrypted.

f. After the restore is finished, right-click the Databases folder and select
Refresh to see the newly create MyBlox database.

g. Right-click the folder and rename the database from MyBlox to Blox.

If your qcc_ssas.mdb file is not saved in C:\sampledata\qcc\msas\ssas2005,
edit the data source as follows:

a. Expand the Blox database.

b. Expand Data Source.

c. Right-click the name of the view and select Properties.
d

. Select the connection string field in the table to bring up the Connection
Manager dialog

e. In the Database file name field, enter the path and the name of the file, and
click OK.

Check if the writeback functionality is enabled for the qccwb cube.
Expand the Blox database.

Expand the Cubes folder.

Expand the gccwb cube

Expand the Measure Groups.

®© o0 T o

Expand the qccwb cube.
f. Right click the Writeback folder and select the Enable Writeback option.
Right click the Blox folder, select Process, and then click OK.

The sample database is now installed.

Next define the data source to DB2 Alphablox by following the steps in

the data source.”|

Defining the data source

After the Quality Chocolate Company (QCC) sample data is installed for your
database, define the data source to DB2 Alphablox.
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Ensure that the QCC sample data is installed before you proceed.

To define the data source:

1. Go to the DB2 Alphablox home page. The URL is http:/ /your
server:port/ AlphabloxAdmin/home.

2. Select Administration > Data Sources.

3. Click Create.

4. Enter the following values for this data source definition:

Table 1. Values for QCC data source definition

Field

DB2 OLAP Server/Hyperion
Essbase

Microsoft SQL Server
Analysis Services

Data Source Name

QCC-Essbhase

QCC-MSAS

Adapter

IBM DB2 OLAP Server or
Hyperion Essbase

OLE DB for OLAP

Server Name

your IBM DB2 OLAP Server or
Hyperion Essbase data server
name

your Microsoft Analysis
Services data server name

Application Blox

Database qcc Blox
Default User Name username loginName
Default Password password password
Use DB2 Alphablox No No
Username and Password

Maximum Rows 1000 1000
Maximum Columns 1000 1000

5. Click Save.

The data source is now ready for use with the Blox Sampler.
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Chapter 2. Tutorial: Building your first application

This tutorial explains important basic concepts about Blox components while you
create a simple DB2 Alphablox analytic application.

To build DB2 Alphablox applications, you will use JavaServer Pages (JSP)
technology, but knowledge of JSP is not required for this tutorial. This tutorial
explains the aspects of JSP that you need to know to begin building DB2
Alphablox analytic applications.

The steps in this tutorial assume that you are using DB2 Alphablox on a
WebSphere® Application Server. If you are using BEA WebLogic or Apache Tomcat
as your application server, you might need to modify a few of the following steps
as needed for the different application server.

Prerequisites

DB2 Alphablox should be installed and accessible to you. You need to have an
Alphablox login with administrator rights. You also need to have the Alphablox
sample databases installed, as described in the [Chapter 1, “Installing the Alphablox|
lsample databases,” on page 1fask.

Defining your application

To create an application using the J2EE development approach, you need to create
a directory structure with a WEB-INF directory that contains an application
descriptor file (web.xml). The simplest way to create this structure in DB2
Alphablox is to create a new application using the Application page within the
DB2 Alphablox Admin Pages.

To create your application and folder:
1. Create a new application, called MyApp, in DB2 Alphablox.

a. Log into the DB2 Alphablox Admin Pages as a user who is a member of the
administrators group.

b. Click the Administration tab.

c. Click the Applications link.

d. Click the Create button. The Create Application page appears.
e. Type MyApp in the Name field.

f

. Type My App (with a space) in the Display Name field, which defines the
label for the application that appears in the list on the Applications page.

g. Click the Save button to define the new application and return to the
Applications page.

Note: If you are running an Apache Tomcat configuration with an external
web server (Apache or IIS), you must perform the steps necessary for
your configuration before the application is available. For details, see
the Administrator’s Guide.

2. Click the top Applications tab at the top left of the page. A list of the available
applications opens.
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3. Click on the name of your newly created application (My App) in the list of
applications. Because you did not create any files yet, the directory is empty.
The new application folder is located on your application server (for a
WebSphere server, the folder is located in the WebSphere installed Apps
directory).

You created a DB2 Alphablox application framework. Next you can add analytic
views to it.

Accessing data

You need to verify that your relational database and the Alphablox Cube Server
are running so that you can access the sample data source for the tutorial. The DB2
Alphablox cube must also be running.

To verify that your required data sources are available and operating:
1. Open your browser to the DB2 Alphablox Administration Pages.
2. Click the Administration tab.

3. Click the Data Sources link.
4

. On the Data Sources page, find the qcc2003-rdb data source in the menu on the
left side of the page.

5. Click on qcc2003-rdb in the list of available data sources and then click the Test
Selected Data Source button. If the database is running and your data source
definition is configured properly, a success message appears. If an error
message appears, you need to check the data source definition by selecting the
data source and clicking the Edit button or you need to check whether the
database is properly configured and includes a user with access rights to the
database.

6. Select the qcc2003-acs data source from the list of data sources and then click
the Test Selected Data Source button. If the Alphablox Cube Server data source
is correctly configured, a success message appears. If an error message appears,
review the data source definition.

You are ready to learn how to build simple DB2 Alphablox analytic views.

Creating your application home page

14

For this lesson, you create a simple home page by using basic web skills. The
home page will contain links for accessing the analytic views that you will create
later in this tutorial.

For the purposes of this tutorial, you only need to create a very simple web
application structure. On the home page, you need to create two links for accessing
the two analytic views you create in this tutorial.

To create a simple home page:

1. Using a text editor or your favorite development tool, create a file called
index.html, for your home page. For the purposes of this tutorial, you can keep
the file very simple.

2. Edit the file to specify an application title (for example, “My DB2 Alphablox
Application”) and two links to the two analytic views that you will create later
in the tutorial.

Copy and paste, or type, the following code into your index.html file.
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<html>
<head>
<title>My DB2 Alphablox Application</title>
</head>
<body>
<h2>My DB2 Alphablox Application</h2>
<p>
<a href="PresentBloxView.jsp">Simple PresentBlox View</a>
</p>
<p>
<a href="ChartBloxView.jsp">Customized ChartBlox View</a>
</p>
</body>
</htm1>
3. Save this file to the MyApp directory that you created when you defined the

application.

4. Open your web browser to the DB2 Alphablox Home page. By default, the
browser displays the Applications page.

5. If DB2 Alphablox is installed on an IBM WebSphere Application Server or a
BEA WebLogic server, directory listings must be enabled before you can
perform the next step. For DB2 Alphablox installations on Apache Tomcat, no
additional steps should be required. If you see an HTTP 403 error (directory
listings are not allowed by default), you can either modify the server to allow
directory listings or just append the file name myapp.html to the end of the
URL (for example, http://localhost:9080/MyApp/myapp.html. The new page
should display.

6. Click the My App link to verify that the file appears in the directory listing.
Click the index.html link to view your home page.

You now have a home page with links to the two analytic views that you will
create next.

Setting a default home page

In previous lessons, you accessed the home page directly by clicking on the file
name link in the MyApp application directory, or by specifying the home page file,
index.html, in the URL. In this lesson, you specify the default home page for the
application.

To set the default application home page:
1. Open your browser to the DB2 Alphablox home page.
2. Click the Administration tab.

3. Click the Applications link.

4. Select MyApp in the applications list and click the Edit button below the list

5. On the Edit Application page for MyApp, type index.html in the Home URL
field.

6. Click the Save button to save the change that you made.

7. Click the main Applications tab, which is the top left folder tab, to return to

the Applications page.

8. Click the My App application name. The application now opens directly to the
defined home page.

Now that the home page is defined, the server will direct the application to open
at this page, even if the users do not specify the home page in the URL address. If
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a user entershttp:/ /yourServerName/MyApp/ into the browser address bar, the
application will automatically open the defined home page, index.html.

In the upcoming lessons, you will begin to create DB2 Alphablox analytic views by
using simple Blox tags that are generated using the DB2 Alphablox Query Builder
application.

Creating your first analytic view

16

In this lesson, you will create a DB2 Alphablox analytic view that displays a grid
and a chart within a PresentBlox component. For the first analytic view that you
will create, you will use the DB2 Alphablox Query Builder application to generate
a JSP custom tag this defines a PresentBlox component.

A PresentBlox component can include grid and chart views, a data layout panel,
toolbars, and other nested components. The grid and chart views represent
synchronized alternative views of the same data.

To create your first analytic view using the DB2 Alphablox Query Builder:

1. Open a browser to the DB2 Alphablox Admin Pages. By default, the
Applications tab is visible.

2. Click DB2 Alphablox Query Builder to open the application.
3. Connect to the database.

a. Click the Connection Settings button. The Database Connection window
opens.

b. Select the qcc2003-acs data source. Press the Connect button. The window
closes, and you should see Connected appear in the Database Status section
of the Query Builder page.

Note: You do not need to fill in the values for the Schema, Catalog,
Username, and Password fields because they are retrieved
automatically from the data source definition for the data source you
select.

c. Ensure that the Execute Default Query check box is cleared.
4. Specify the query.
a. Find the Query section. The Query section is below on the page. Note the
following features:

¢ For this tutorial, you are using a DB2 Alphablox cube (qcc2003-acs). The
Query section contains a list of cubes that are available (currently
running). The qcc2003-acs cube should be listed.

* A default query string that is associated with this data source appears in
the text window. Because the data source is a DB2 Alphablox cube, the
first cube, listed alphabetically, is added into the query statement (for
example, "select from [datasourceName]").

Restriction: When the connection pooling feature in the DB2 Alphablox
Cube Server is enabled, you cannot use the Get Default
Query button to get a default query for a DB2 Alphablox
cube.

* If data appears in the PresentBlox component at the bottom of the page,
you can swap axes, drill up or down, move dimensions between axes,
and so forth.
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* To view the results of the query, click the Execute Query button. The
result set appears in the PresentBlox component at the bottom of the
page.

b. Type qcc2003-acs between the square brackets of the default query (for
example, select from [qcc2003-acs]) and then press the Execute Query
button.

The PresentBlox section should display a default view that is based on the
query.
5. Use the PresentBlox user interface to create a new view and query.
a. Create a new view.

For example, you can drag the Products dimension to the Row axis in the
Data Layout panel on the left. Then, you can drag the Time (Calendar)
dimension to the Column axis. You might then want to drag the Measures
dimension into the Page axis so that a Measures menu appears in the Page
panel. The Page panel displays page filters above the grid and chart display
panel. Pick two other dimensions and add them to the Page axis so that
three page filters appear above the display.

b. Note the query statement that appears in the Query section. If the query is
not being dynamically generated (when the Automatically Update Queries
option is cleared), you can click the Get Current Query button to get the
current query. The text box displays the query statement that is required to
develop the current data view. You can copy and paste query statements
from the Query field to be used in developing DB2 Alphablox applications.

6. Click the Generate Blox Tag button. A window opens that shows the tag (and
nested tags) that are needed to reproduce the PresentBlox layout and result set.

7. Copy the new tag into a new file.
a. Open a new file in your text editor.
b. Add the following text to the file.
<%0 taglib uri="bloxt1d" prefix="blox" %>

//Copy and paste the tag information from the generated Blox tag
//immediately below this Tine. Remove any Tine breaks from the
//query statement. You can also remove this comment after you add
//the code from DB2 Alphablox Query Builder.

<html>

<head>

<blox:header/>

</head>

<body>

<h2>Simple PresentBlox View</h2>
<p>

<blox:display bloxRef="MyPresentBloxView"/>

</p>
</body>
</html>

C. Replace the commented out lines with the code from step 6.
d. Save the file as PresentBloxView.jsp.

8. Copy the saved file (PresentBloxView.jsp) to the MyApp directory on your
server and test your new analytic view by clicking on Simple PresentBlox View
link on your MyApp home page. Alternatively, you can enter the URL directly
into a browser address (for example, http:/ /localhost:9080/MyApp/
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PresentBloxView.jsp). The view that you see should look similar to the
PresentBlox component that you manipulated in the DB2 Alphablox Query
Builder.

A code example of a complete version of the Simple PresentBlox View page
(PresentBloxView.jsp) is shown below:

<%@ taglib uri="bloxt1d" prefix="blox" %>

<blox:present
id="queryBuilder4 present"
height="500"
visible="false"
width="100%">
<blox:grid/>
<blox:chart/>
<blox:page/>
<blox:data
dataSourceName="qcc2003-acs"
onErrorClearResultSet="true"
query=" SELECT DISTINCT({[qcc_2003].[Time (Calendar)].[A11 Time
(Calendar)], [qcc_2003].[Time (Calendar)].[A11 Time (Calendar)].[2000],
[qcc_2003].[Time (Calendar)].[A11 Time (Calendar)].[2001],
[qcc_2003].[Time (Calendar)].[A11 Time (Calendar)].[2002],
[qcc_2003].[Time (Calendar)].[A11 Time (Calendar)].[2003]} )
ON AXIS(0©), DISTINCT( {[qcc_2003].[Products].[A11 Products],
[qcc_2003] . [Products].[A11 Products].[100 Truffles],
[qcc_2003] . [Products].[A11 Products].[200 Chocolate Blocks],
[qcc_2003] . [Products].[A11 Products].[300 Chocolate Nuts],
[qcc_2003] . [Products].[A11 Products].[400 Specialties]} )
ON AXIS(1) FROM [qcc_2003] WHERE ([qcc_2003].[Measures].[Sales],
[qcc_2003].[Time (Fiscal)].[A11 Time (Fiscal)],
[qcc_2003].[Date Opened].[A11 Date Opened],
[qcc_2003].[Has Nuts].[A11 Has Nuts],
[qcc_2003].[Chocolate Type].[A11 Chocolate Type],
[gcc_2003] . [Ounces Per Package].[A11 Ounces Per Package],
[qcc_2003].[Pieces Per Package].[A11 Pieces Per Package],
[qcc_2003].[Date Introduced].[A11 Date Introduced],
[qcc_2003] . [Seasonal].[A11 Seasonal],
[qcc_2003].[Scenario] . [Actual],
[qcc_2003] . [Locations].[A11 Locations])"
selectableSTicerDimensions="[qcc_2003].[Measures],
[qcc_2003] . [Locations], [qcc_2003].[Chocolate Type]"
useAliases="true"/>
<blox:toolbar/>
<blox:datalLayout/>
<bloxui:calculationEditor />
</blox:present>

<html>

<head>

<blox:header/>

</head>

<body>

<h2>Simple PresentBlox View</h2>

<blox:display bloxRef="queryBuilderd present"/>
</p>

</body>
</html>

In the code example above, the query statement has line breaks in it for readability.

To display this page properly, you must remove the line breaks in the attribute
values (like the query and selectableSlicerDimensions attributes above).

18 1BM DB2 Alphablox: Getting Started



In the code that is generated by the DB2 Alphablox Query Builder, many tags that
are included are not necessary. Seeing all of the tags here, though, should give you
insight into how the Blox tags work as parent and nested tags. You can also see the
use of the tag attributes that are added as a result of the manipulations you make
in Query Builder’s PresentBlox component.

The next topic will explain many of the important elements of the code on this
page.

Structure of your first analytic view page

This topic summarizes the structure of the first analytic view (PresentBloxView.jsp)
that you created in the previous lesson.

The most important Blox tags used on this page include: <blox:header/>,
<blox:present>, and <blox:display>. These three tags, and nested tags, specify an
analytic view without requiring any Java" code on the page. The complexity of the
presentation logic is being managed by these Blox tags. By adding nested Blox and
modifying the attribute values, you can customize views based on your business
requirements.

Below is a brief overview of some of the highlights from the page created in the
previous lesson. For a more complete understanding of the code, you will have to
read topics of interest in the DB2 Alphablox Information Center.

The PresentBloxView.jsp file begins with the following line:
<%0 taglib uri="bloxtld" prefix="blox" %>

This line is a JSP taglib directive that informs the server that you intend to use the
Blox tag library. The uri is a pointer to the tag library descriptor file. The prefix
value, defined as blox, tells the server to process the contents of any tags on this
page that begin with blox, by using the Blox tag library as defined in the tag
library descriptor file.

Just below the taglib directive, the PresentBlox component is specified by the
following tags and their tag attributes:

<bTox:present
id="queryBuilder4 present"
height="500"
visible="false"
width="100%">
<blox:grid/>
<blox:chart/>
<blox:page/>
<blox:data
dataSourceName="qcc2003-acs"
onErrorClearResultSet="true"
query="SELECT DISTINCT({[qcc_2003].[Time (Calendar)].[A11 Time
(Calendar)], [qcc_2003].[Time (Calendar)].[A11 Time (Calendar)].[2000],
[qcc_2003].[Time (Calendar)].[A11 Time (Calendar)].[2001],
[qcc_2003].[Time (Calendar)].[A11 Time (Calendar)].[2002],
[gcc_2003].[Time (Calendar)].[A11 Time (Calendar)].[2003]} )
ON AXIS(@), DISTINCT( {[qcc_2003].[Products].[A11 Products],
[qcc_2003] . [Products].[A11 Products].[100 Truffles],
[qcc_2003] . [Products].[A11 Products].[200 Chocolate Blocks],
[qcc_2003] . [Products].[A11 Products].[300 Chocolate Nuts],
[gcc_2003] . [Products].[A11 Products].[400 Specialties]} )
ON AXIS(1) FROM [qcc_2003] WHERE ([qcc_2003].[Measures].[Sales],
[gcc_2003].[Time (Fiscal)].[A11 Time (Fiscal)],
[qcc_2003].[Date Opened].[A11 Date Opened],
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[qcc_2003].[Has Nuts].[A11 Has Nuts],
[qcc_2003].[Chocolate Type].[A11 Chocolate Type],
[qcc_2003] . [Ounces Per Package].[A11 Ounces Per Package],
[qcc_2003] . [Pieces Per Package].[A11 Pieces Per Package],
[qcc_2003].[Date Introduced].[A11 Date Introduced],
[qcc_2003].[Seasonal].[A11 Seasonal],
[qcc_2003].[Scenario].[Actual],
[qcc_2003].[Locations].[A11 Locations])"
selectableSlicerDimensions="[qcc_2003].[Measures],
[qcc_2003].[Locations], [qcc_2003].[Chocolate Type]"
useAliases="true"/>
<blox:toolbar/>
<blox:datalLayout/>
<bloxui:calculationEditor />
</blox:present>

The <bTox:present> tag specifies that you want a PresentBlox to appear here with
an id attribute value of queryBuilder4_present. The id attribute allows you to
identify this particular Blox for scripting purposes. Note that the <blox:present>
tag includes a visible attribute set to false. When set to false, the PresentBlox will
not be rendered until the <blox:display> tag is encountered by the compiler in the

page.

There are many attributes available for each Blox that are defined using tags, but
you need to include them only if you need to specify attributes values that are
different than the default values, you do not need to include them in the tag. In
this example, a height value of 500 and a width value of 100%. Height and width
can be defined in pixels or in percentages.

A nested DataBlox is included, which defines the dataSourceName attribute as
qcc2003-acs. If no data source is specified, you will see a "No data available”
message when the page is displayed. The query attribute includes the MDX query
statement that is generated by DB2 Alphablox Query Builder. When you
understand the MDX query language that is used with the DB2 Alphablox Cube
Server, you can simplify the query to make it much shorter. The query statement
here, though, is complete and will generate the view that you created in the Query
Builder application.

The <head> section of the page contains a special Blox tag for adding important
code to the page before the page is rendered:

<blox:header/>

This tag is used by DB2 Alphablox to automatically add required HTML,
JavaScript™, and CSS code into the head section of the page. When a page is
rendered by the server, this tag adds CSS links to defined HTML themes and a
meta tag for preventing caching. Remember to enter this tag into every JSP page
that uses Blox components. If this tag is not included, the page does not render

properly.

The <body> section of the page contains the following line:
<blox:display bloxRef="MyPresentBloxView"/>

This Blox tag results in the PresentBlox component specified above being rendered
here. Using the <blox:display> tag enables you to make changes to a Blox
component or its nested components in one place, where you can also have other
Blox tags and JSP scriptlets controlling the behavior of the Blox components. You
can elect to have a DataBlox component that separate from the PresentBlox
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component and add JSP scriptlets that modify the Blox components and their
behavior before the Blox component is rendered in the Web browser.

For more complex views and applications, additional JavaBeans" components and
Java code might be required.

Creating a customized analytic view

In this lesson, you will create a customized analytic view that displays just a chart
with page filters.

In many applications data is represented by using just a grid or a chart. The
PresentBlox component combines both the GridBlox and the ChartBlox
components as nested components that display together within the PresentBlox
component, but you can disable or hide the nested components that you do not
want to be seen. To use a PresentBlox component to create a chart view with page
filters, you modify the tag attributes on some of the nested Blox tags.

In this task, you will reuse the PresentBlox tag from the first analytic view to create
a second customized analytic view.

To create an analytic view that displays a chart with page filters:

1. Open the previously created PresentBloxView.jsp file in your editor and save it
as ChartBloxView.jsp.

2. In the nested components of the PresentBlox tag that are listed below, add a
visible attribute and set the values to false. Adding the attribute will cause
the specified nested components to not display, and will leave a chart view
with a page filter bar.
<blox:grid visible="false"/>
<blox:chart/>
<blox:toolbar visible="false"/>
<blox:page/>
<blox:datalLayout visible="false"/>

3. Modify the PageBlox tag (<blox:page>), by adding the TabelPlacement attribute
and setting the value to top. By default, the label for page filters appears to the
left of the menus. Adding this attribute and setting it to top overrides the
default behavior and will place the labels above the page filters.

<blox:page labelPlacement="top" />

4. Modify the name of the id attribute on the <blox:present> tag to the following
value: chartview. Each Blox component that is displayed or rendered to a page
requires a unique ID to prevent errors.

5. Save your changes and add the file to your MyApp directory on the server.

6. Open your browser and test your new page, either by clicking on the link from

your home page or accessing the page directly by using the URL address (for
example, http://localhost:9080/MyApp /ChartBloxView.jsp)

You have now created two analytic views by using the DB2 Alphablox Query
Builder application to help you get started. You also learned that by modifying or
adding attributes on existing tags, you can control the appearance and behavior of
the Blox and their nested components.
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Summary

If you finished all of the tutorial lessons, you learned how to build a basic DB2
Alphablox application by using the DB2 Alphablox Admin Pages, the DB2
Alphablox Query Builder application, and the Blox tag library. Many properties
and methods are available for defining and manipulating Blox components on JSP
pages. So what should you do next?

If you want to see your corporate data in an DB2 Alphablox view, you now know
how to create an application from scratch and add analytic views to your
application. If you want to see something right away, you could make some simple
modifications to the MyApp application.

To display data from your corporate databases instead of using the qcc2003-acs
data source, you can create data sources that point to your corporate databases,
modify the dataSourceName attributes to point to the newly defined data source,
then add an appropriate query attribute. Using the DB2 Alphablox Query Builder,
you can quickly create usable query statements and Blox tags.
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Chapter 3. Tutorial: Building your first portlet with Blox
components

In this tutorial, you will learn how to add Blox components to your portlets. You

will:

1. Install a prebuilt sample portlet. With this step, you can quickly see how a Blox
component is added to a portlet JSP page and how it displays in on a portal
page.

2. Write your own JSP page with a GridBlox.

The tasks in this tutorial do not provide details about general portlet development.

This tutorial focuses on DB2 Alphablox-specific tasks and assumes some familiarity
with the general concepts of the portal environment and portlet development.

Prerequisites

» DB2 Alphablox must be installed under a WebSphere Portal Version 5.1 server.
See the Installation Guide for details about installation.

* Your WebSphere Portal server must be started.
* You must have administrative access to your WebSphere Portal server.

* You must have familiarity with the administrative functions and user interface in
WebSphere Portal.
* You should have basic knowledge of Java and JSP.

* You should have a JSP editor installed.

Although you can use any JSP editor or even a text editor for this tutorial, when
you develop your own portlets, use a development tool recommended by
WebSphere Portal, such as Rational® Application Developer.

This tutorial uses a predefined data source that was installed with DB2 Alphablox.
You can use this data source to quickly develop a basic application. You do not
need to worry about configuring a custom data source for this tutorial.

Installing the sample portlets

The best way to learn how to add a Blox to your portlet is to install the sample
portlets provided in DB2 Alphablox and load them into a portal page. This allows
you to examine the basic structure of the JSP code and match that to the output on
your portal.

Install the sample portlets provided in DB2 Alphablox:

1. Open your browser and log in to your portal as an administrative user (the
URL is in the form of http://<yourPortalServer>:<port>/wps/portal).

2. Click the Administration button.

3. Under the Portlet Management section, click Web Modules. The Manage Web
Modules page appears on the right.

4. Click Install. You are prompted for the Web Module to install.

5. Click the Browse button and navigate to the installableApps directory under
your DB2 Alphablox installation directory.
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6. Choose AlphabloxSamplePortlets.war and click Next. The DB2 Alphablox
Sample Portlets application with a portlet called DB2 Alphablox JSP Page
Sample Portlet is displayed in the Portlet application table.

7. Click Finish.

The DB2 Alphablox Sample Portlets application and the included portlets are now
installed. Check the installedApps directory under your WebSphere Portal
installation. The name for the newly created directory starts with DB2 Alpha and
ends with a dynamically generated portlet ID in the pattern of _PA_x_x_xx.ear.

Running the sample portlets

To run the sample portlets on your portal page:
1. Go to your portal page.

2. Create or edit an existing page. You can create a new page for testing this
sample portlet, or you can click an existing page to edit the page.

3. Click one of the Add Portlets buttons on the portal layout page.

4. Type DB2 in the Search field and press Search. The DB2 Alphablox JSP Page
Sample Portlet check box appears.

5. Select the check box and click OK.

6. Click Done.

When the portal page refreshes, a PresentBlox appears in your portal page. This
PresentBlox has:

* A menu bar on top

* Two toolbar panels underneath the menu bar

* A data layout panel on the left that lets you move dimensions around the
different axes

* A grid that shows the data in tabular format
* A three-dimensional bar chart on the right
This present.jsp file is the default page to load as specified in the

BloxJSPPagePortlet servlet included in the sample. The source code for this sample
servlet is available in the WEB-INF/src/ directory.

You have successfully installed the sample portlets and added a portlet with Blox
to your portal page. The next task is to examine the code structure in this JSP page.

Examining the structure of a portlet JSP page with a Blox
component

In this task, you review the code structure of a JSP page that contains a Blox. All
JSP pages must have the same key elements.

To open a JSP file:

1. Navigate to the installedApps/ directory under your WebSphere Portal
installation, and locate the newly created application folder that starts with DB2
Alpha.

2. Navigate to the PA_x_x_xx.war/jsp/htm1/ directory.
3. Open present.jsp in your JSP or Java editor.
4. Examine the following code and note the key elements:
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<%@ page contentType="text/html"%>

<
<

@ taglib uri="bloxt1d" prefix="blox"%>
@ taglib uri="/WEB-INF/t1d/portlet.t1d" prefix="portletAPI" %>

9
%
9

%

<portletAPI:init/>

<

o°

String bloxName = portletResponse.encodeNamespace("presentBlox");
>

N

<head>
<blox:header />
</head>

<blox:present id="presentBlox" bloxName="<%= bloxName %>" width="800">
<blox:data dataSourceName="canned" />
</blox:present>

This block of code contains six key elements:
1. The first line tells the browser the output is HTML:
<%@ page contentType="text/html"%>
2. The next set of code specifies the two JSP tag libraries used in this page:

<%@ taglib uri="bloxt1d" prefix="blox"%>
<%@ taglib uri="/WEB-INF/t1d/portlet.t1d" prefix="portletAPI" %>

The uri is a pointer to the directory location where the tag library descriptor
file is located. The prefix values, defined as blox and portletAPI, tell the
server to:

* Look for any tags on this page that begin with blox, and then process the
contents using the Blox Tag Library as defined in the tag library descriptor
file.

* Look for any tags on this page that begin with portl1etAPI, and then process
the contents using the Portlet Tag Library as defined in the tag library
descriptor file.

3. Next, a portlet initialization tag is added:
<potletAPI:init/>

This tag provides access to the PortletRequest, PortletResponse, and
PortletConfig objects. With PortletResponse, you can invoke the
encodeNamespace () method to ensure that the name of your Blox does not clash
with other objects on other portlets that run on the same page.

4. The next tag encodes the namespace for the Blox to add to the page:

<

o

String bloxName = portletResponse.encodeNamespace("presentBlox");
>

N

This allows you to later create a Blox and assign this unique name to it.
5. The next block of code adds the Blox header tag that is required for Blox
rendering and server-client communication:

<head>
<blox:header />
</head>

This tag is used by DB2 Alphablox to automatically add the required HTML,

JavaScript, and CSS code into the head section of the page. When a page is
rendered by the server, this tag results in the inclusion of CSS links to defined
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HTML themes and a meta tag to prevent caching. This tag must be added to
every JSP page that contains Blox components, or the components will not
render properly.

6. Add a PresentBlox using tags provided in the Blox Tag Library:

<blox:present id="presentBlox" bloxName="<%= bloxName %>" width="800">
<blox:data dataSourceName="canned" />

</blox:present>

* This code adds a PresentBlox with an id of presentBlox and a bloxName of
XX_X_X_xxx_presentBlox, which is the result of namespace encoding.

* This Blox has a width of 800 pixels and the height of 400 pixels (the default).

* A nested DataBlox is included, with the dataSourceName tag attribute set to
canned.

The id tag attribute of the PresentBlox is required. It specifies the Java scripting
name to use on the JSP page. The bloxName attribute specifies the object name
on the server. An encoded bloxName ensures that the instance is unique on the
server.

Note: If no data source is specified, you will typically see the No data
available message in the grid. The canned data source is predefined
during installation and includes a small amount of sample data. It does
not require installation and configuration of a real external database, and
can be used for troubleshooting and learning. Because we don’t need to
specify a query, there is no query attribute in the code.

This page does not have an outmost <html> tag because this JSP page is displayed
on a portal page with other portlets. No additional <html1> or <body> tag are
needed.

Now that you have examined the JSP structure and learned the essential code to
include in your portlet JSP pages, in the next task, you will create a new JSP page
with a different Blox and specify some common Blox attributes to have the page fit
better on your portal page.

Creating your own portlet JSP page with Blox components

26

In this task, you will create a new JSP page with a GridBlox and set some of its
properties. The purpose is for you to become familiarize with the general Blox tag
construct while creating a GridBlox that fits well in a typical portal page.

A GridBlox has a default size of 400x400 pixels. It also comes with a menubar and
a toolbar. You will set some of the common used GridBlox properties so the grid
only takes up 100 pixels in height, with both its menubar and toolbar turned off.
These are done by setting the following GridBlox properties:

* height : set to 100 pixels
e menubarVisible: set to false
e toolbarVisible: set to false

Make sure you have met the requirements specified in [Chapter 3, “Tutorial:
[Building your first portlet with Blox components,” on page 23[and installed the
sample portlet application as described in the section on [“Installing the sample|
iportlets” on page 23]

Follow the steps below:
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1. In the browser window where the PresentBlox is displayed, click the portlet’s
edit button (the button with a pencil icon). You are presented with a selection
drop list.

2. In the drop list, select "Grid Blox” and click OK.
As the page refreshes, you should see a 400x400 GridBlox. This GridBlox, by

default, has its menubar and toolbar turned on. You will change its size to
400x100, with both the menubar and toolbar turned off.

3. Navigate to the PA_x_x_xx.war/jsp/html/ directory under the DB2 Alphablox
Sample Portlets application installed previously.
4. Open grid.jsp in your JSP editor. This page looks almost identical to
present.jsp, except that:
* the <blox:present> tag now says <blox:grid> and the value for id is
different:

<blox:grid id="gridBlox" bloxName="<%= bloxName %>" width="400">
<blox:data dataSourceName="canned" />
</blox:grid>
* the bloxName value is different:

<

o

String bloxName = portletResponse.encodeNamespace("gridBlox");

>

5. Set the height of this GridBlox to 100 pixels by adding the height attribute and
setting its value to 100:
<blox:grid id="gridBlox" bloxName="<%= bloxName %>" width="400" height="100">

<blox:data dataSourceName="canned" />
</blox:grid>

N

6. Turn off the menubar and toolbar on the top by setting the menubarVisible and
toolbarVisible attributes to false:
<blox:grid id="gridBlox" bloxName="<%= bloxName %>" width="400" height="100"
menubarVisible="false" toolbarVisible="false" >
<blox:data dataSourceName="canned" />
</blox:grid>
Make sure you enter the attribute names correctly, including the cases
(uppercase "V" in both attribute names). Also make sure the attributes are
added before the ending angle bracket (">").

7. Change the namespace to myFirstGrid:

<%
String bloxName = portletResponse.encodeNamespace("myFirstGrid");

%>
Changing the namespace for this GridBlox is to ensure that the changes you
just made will be reflected as you load this JSP into your portal. Since you have
previously loaded this page, there is already an instance of this GridBlox
running on the server for this session. Unless you change the namespace, the
changes you just make will not be reflected even if you refresh the page.
Changing the namespace is a quick way to test your changes in a development
environment. Alternatively, you can also open a new browser window so a new
object is created on the server for the new session.

8. Save the file.

You are now ready to test this file on WebSphere Portal.

To test the changes you just made:
1. Go back to the portal page.
2. Click the browser’s Refresh button to reload the page.
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You should see a 400x100 GridBlox with no menubar or toolbar.

Note: This JSP selection drop list is not a built-in functionality of WebSphere
Portal, but created by this sample portlet. Check the edit.jsp file and the
Java source files in the WEB-INF/src/ directory.

Creating a portlet project to use Blox components

When creating your portlet project in your development tool, make sure the
AlphabloxServer servlet mapping and the tag library references needed for Blox
components are added to your project’s web.xm1 file, and the DB2 Alphablox Tag
Libraries descriptor files are copied over to your project.

1. Modify your project’s web.xml file to include the following lines:
* For servlet definition and servlet mapping:

<servlet>
<servlet-name>AlphabloxServer</servlet-name>
<servlet-class>com.alphablox.server.webapps.server.AlphabloxServer
</servlet-class>
</servlet>

<servlet-mapping>
<servlet-name>AlphabloxServer</servlet-name>
<url-pattern>/abx/*</url-pattern>
</servlet-mapping>

* For tag library references (applies to DB2 Alphablox V8.4 only; for V8.4.1
users, skip to step 2):

Important: Because V8.4.1 supports Servlet 2.4 instead of Servlet 2.2, your
application server will automatically discover the tag library
descriptor files. If you are using V8.4.1, you should not explicitly
reference the tag library descriptor files in your project’s web.xml
file.

<taglib>
<taglib-uri>bloxtld</taglib-uri>
<taglib-Tocation>/WEB-INF/t1ds/blox.t1d</taglib-location>
</taglib>
<taglib>
<taglib-uri>bloxformtld</taglib-uri>
<taglib-Tocation>/WEB-INF/t1ds/bloxform.tld</taglib-location>
</taglib>
<taglib>
<taglib-uri>bloxlogictld</taglib-uri>
<taglib-Tocation>/WEB-INF/t1ds/bloxlogic.t1d</taglib-Tocation>
</taglib>
<taglib>
<taglib-uri>bloxreporttid</taglib-uri>
<taglib-Tocation>/WEB-INF/t1ds/bloxreport.tld</taglib-location>
</taglib>
<taglib>
<taglib-uri>bloxportlettlid</taglib-uri>
<taglib-Tlocation>/WEB-INF/t1ds/bloxportlet.tld</taglib-Tocation>
</taglib>
<taglib>
<taglib-uri>bloxuitld</taglib-uri>
<taglib-Tocation>/WEB-INF/t1ds/bloxui.tld</taglib-Tocation>
</taglib>

2. Copy the DB2 Alphablox Tag Libraries descriptor files into your project.

* For V8.4, copy the DB2 Alphablox Tag Libraries descriptor files (TLD files)
from under db2alphablox_dir /bin into your project’'s WEB-INF/tlds directory.
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For V8.4.1, copy the aastaglibs jar file for the DB2 Alphablox Tag Libraries
from under db2alphablox_dir/lib into your project’'s WEB-INF/lib directory.

Configuring a portlet project using Rational Application

Developer

WebSphere Portal recommends that you use Rational Application Developer for
portlet development. In particular, Rational Application Developer Version 6.0 is
required for WebSphere Portal Version 5.1. Rational Application Developer
provides a wizard that guides you through the setup and creation of a portlet
project. Based on your selection, it sets up the appropriate structure and
deployment descriptor file, and automatically creates the necessary Java classes for
your controller and JSP pages for your portlet view. As you follow along the New
Portlet Project wizard, make sure you have the following configured correctly:

1. Choose "WebSphere Portal v5.1 stub” for your target server. This is specified on

the wizard’s first screen by clicking the Show Advanced >> button.

Add the servlet mapping for DB2 Alphablox to the web.xml file created under
WebContent/WEB-INF/. This is done by entering the following servlet definition
and mapping code in your project’s web.xml:
<servlet>
<servlet-name>AlphabloxServer</servlet-name>
<servlet-class>com.alphablox.server.webapps.server.AlphabloxServer
</servlet-class>
</servlet>

<servlet-mapping>
<servlet-name>AlphabloxServer</servlet-name>
<url-pattern>/abx/*</url-pattern>
</servlet-mapping>
For DB2 Alphablox V8.4 only (for V8.4.1 users, skip to step 4), add the
Alphablox Tag Libraries to your project’s web.xm] file.

Important: Because V8.4.1 supports Servlet 2.4 instead of Servlet 2.2, your
application server will automatically discover the tag library
descriptor files. If you are using V8.4.1, you should not explicitly
reference the tag library descriptor files in your project’s file.

With web.xm1 open, click the Variables tab.
Scroll to the Tag Libraries References section at the bottom.
Click Add.

For URL and Location, enter the values based on the following table:

aoop

URL Location

bToxtld /WEB-INF/t1ds/blox.t1d

bloxformtld /WEB-INF/t1ds/bloxform.t1d

bloxTogictld /WEB-INF/t1ds/bloxlogic.t1d

bloxreporttld /WEB-INF/t1ds/bloxreport.tld

bloxportlettld /WEB-INF/t1ds/bloxportlet.tld

bloxuitld /WEB-INF/t1ds/bloxui.tld

For each pair of URL and Location, you will need to click Finish to add the
tag library reference and then click Add to add the next pair.

4. Copy the DB2 Alphablox Tag Libraries descriptor files into your project.
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* For V8.4, copy the DB2 Alphablox Tag Libraries descriptor files (TLD files)
from under db2alphablox_dir /bin into your project’'s WEB-INF/tlds directory.

* For V8.4.1, copy the aastaglibs.jar file for the DB2 Alphablox Tag Libraries
from under db2alphablox_dir/lib into your project’'s WEB-INF/lib directory.

Next steps

You have learned how to create a portlet with Blox components and the essential
code structure. In order to display data from your databases, you need to:

1. Define a new data source to DB2 Alphablox that points to your data source.

2. Modify the dataSourceName attribute of DataBlox to point to the defined data
source.

3. Add a query attribute with your query string to DataBlox.

For details on creating data sources, see the Administrator’s Guide. To learn how to
create appropriate queries, see Retrieving Data in the Developer’s Guide and the
DataBlox section of the Developer’s Reference.

Once you have your own data appearing in Blox views, you can also begin
exploring the many properties that can be set by using the Blox tags.

Portlet development tips

As you use the information provided in the DB2 Alphablox documentation and
continue your portlet development, there are some portlet-specific topics, concepts,
and general guidelines that you need to be aware of. The following list puts
together these general development guidelines as well as pointers to specific
sections in the documentation that are of interest to you.

* Always encode the name of your Blox using the portlet’s namespace. A
namespace ensures a unique Blox name for the current J2EE session.

* Always set the width and height of a Blox using pixels. Outside of the portal
environment, you can set the width and the height to a percentage value such as
"50%" or "100%". Percentage values do not work in the portal environment
because multiple portlets coexist on the page.

* Do not use relative URLs to invoke resources within a portlet. URLs should be
encoded using the encodeURL() method of the PortletResponse class. In places
where the documentation shows the use of relative URL, you should always
encode the URL.

* To ensure that your Blox portlet uses a theme similar to your portal theme, use
the Portal Theme Utility. This utility is available from two sources:

— The DB2 Alphablox home page.

Under the Administration tab, click the General link. The Utility is listed
under the Portal section. See the Administrator’s Guide and the online help for
details.

— The AlphabloxAdminPortlets.war file.

This is a portlet version of the Portal Theme Utility. You can install this
portlet to run it through your portal without having to log in separately to
the DB2 Alphablox home page.

This utility will combine the styles from your portal environment and the styles
in DB2 Alphablox into one so that Blox will be displayed in similar colors and
fonts as other portlets on the page.
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¢ Check the Blox Portlet Tag Library topic in the Developer’s Guide for issues you
need to take into consideration during the planning phase.

* DB2 Alphablox has a powerful Blox UI Model. The UI Model includes a
ClientLink object that lets you load a specified URL when a Blox component on
the page is clicked. For portlet development, use the Blox Portlet Tag Library to
create the ClientLink. The tags will handle URL formation and handling
dynamically so that the links do not turn stale after the page is refreshed. See
the topic, Planning for portlet development, in the Developer’s Guide for details.

* For portlet and action URIs, use the Blox Portlet Tag Library to create the portlet
link or action link. You can then utilize the portal’s Portlet API to process the
action or portlet link. See the Blox Portlet Tag Library topic in the Developer’s
Guide for details.
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Chapter 4. Tutorial: Building applications using Rational
Developer tools

You can use Rational Developer tools with the DB2 Alphablox Toolkit to more
quickly develop applications using DB2 Alphablox components and the DB2
Alphablox Java APIs.

Rational Developer tools (Rational Application Developer or Rational Web
Developer) can be used with the DB2 Alphablox Toolkit, an Eclipse-based set of
plug-ins, to develop and test applications built using DB2 Alphablox technology.
This tutorial will guide you in configuring your Rational integrated development
environment to enable the use of method and tag completion as well as custom
enhancements added with the DB2 Alphablox Toolkit.

To begin configuring your Rational Developer tool with the DB2 Alphablox Toolkit
to develop and test DB2 Alphablox applications.

Preparing your development environment

Before you can install and begin using the DB2 Alphablox Toolkit, prepare your
development environment by making sure that you have all of the required
software.

To prepare your development environment:
1. Install a Rational Developer tool (either Rational Application Developer or
Rational Web Developer) on your workstation.

2. Install any required updates to ensure that you have at least Rational
Application Developer or Rational Web Developer version 6.0.0.1.

3. If you plan to use WebSphere 5.1 integrated test environments, make sure that
you have updated your Rational Developer version to include this optional
installation.

Note: Default installations of the Rational Developer tools do not include the
WebSphere 5.1 integrated test environments.

You are now ready to perform the tasks in this tutorial.

Installing the DB2 Alphablox Toolkit

Using the DB2 Alphablox Toolkit with the Rational Developer tool will make it
easier for you to begin developing web-based applications with DB2 Alphablox
content.

The DB2 Alphablox Toolkit requires the use of Rational Application Developer or
Rational Web Developer version 6.0.0.1.

Installing the DB2 Alphablox Toolkit into a Rational Developer tool saves
developers from having to perform many manual steps to enable the use of
content completion for Java methods and JSP custom tags. Also, custom wizards
and cheat sheets can be used to guide you in creating applications with DB2
Alphablox content and defining WebSphere server instances.
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To install the DB2 Alphablox Toolkit into Rational Application Developer or
Rational Web Developer:

1. Insert the DB2 Alphablox Installation Disk into the CD drive on your
workstation.

2. In the plugin directory, locate the subdirectory named UpdateSite.

3. Copy the UpdateSite directory to a convenient location on your hard disk. For
example, copy the directory to C:\DB2Alphablox\UpdateSite.

4. Start the Rational Developer tool.
5. On the menu bar, select Help > Software Updates > Find and Install.

6. In the Install window that opens, select the Search for new features to install
option and then click Next.

7. On the Update sites to visit window, click the New Local Site button and
browse to the location of the UpdateSite directory.

8. Click Next, select the DB2 Alphablox Toolkit feature, and click Next again.

9. In the windows that follow, accept the license agreement and select the
location where the DB2 Alphablox Toolkit feature will be installed.

10. After the installation is complete, restart the Rational Developer tool

After you restart the Rational Developer tool, the DB2 Alphablox Toolkit features
will be available.

Installing DB2 Alphablox in WebSphere integrated test environments
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In this task, you install DB2 Alphablox on the WebSphere integrated test
environments in a Rational Developer tool.

Prerequisites: The supported WebSphere integrated test environment must be
installed in the Rational Developer tool. You need access to the DB2 Alphablox
Installation Disk. Review and perform any required preinstallation steps described
in the Preinstallation Tasks section of the DB2 Alphablox Installation Guide.

DB2 Alphablox can be installed on standalone WebSphere application servers or on
the WebSphere integrated test environments available within the Rational
Developer tool. The summary of steps outlined below explain the differences in
installation that must be performed when installing DB2 Alphablox on the
WebSphere runtimes available within the Rational Developer tool.

To install DB2 Alphablox in WebSphere integrated test environments

Install DB2 Alphablox following the steps in the Installation section of the DB2
Alphablox Installation Guide, with the following exceptions:

1. In the Configure WebSphere window of the installer, in the WebSphere Root
Directory field, specify the location of the WebSphere runtime that you want to
use as your integrated test environment server.

For example, to install DB2 Alphablox to the WebSphere 6 integrated test
environment on the default installation, select the path to the base_v6 directory.
For a typical Rational Application Developer installation, the path would be
similar to the following:

C:\Program Files\IBM\Rational\SDP\6.0\runtimes\base v6

2. In the WebSphere Settings window, specify a name and password for the
WebSphere administrator. These entry values are not used in the WebSphere
integrated test environment, but are required by the DB2 Alphablox installer.
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Important: Do not perform the post-installation steps described in the DB2
Alphablox Installation Guide.

After installing DB2 Alphablox into the WebSphere runtime, you can create
WebSphere server instances for testing DB2 Alphablox applications within the
Rational Developer tool.

Creating a WebSphere server instance

To run applications or JSP files that contain DB2 Alphablox content, you need to
create a WebSphere server instance that can access required DB2 Alphablox
services and Java classes.

Prerequisites: Configure the Rational Developer tool. Install the DB2 Alphablox
Toolkit. Install DB2 Alphablox in the WebSphere integrated test environments.

To create a WebSphere server instance for testing applications and JSP files
containing DB2 Alphablox content:

1. Open the Rational Developer tool.

2. Click the Servers tab (if the tab is not visible, select Window > Show View >
Servers).

3. Right-click inside the view window and select New > Server. The New Server
window opens.

4. Enter Tocalhost as the host name and select the server type. Click Next.

o

Enter the server port number and click Next.

6. Add the available projects that you want to run in this server instance to the
list of configured project. Click Finish. Your new server instance opens in the
Servers view.

If you created a WebSphere 5.1 server instance, you need to perform the next step,
"Creating WebSphere 5.1 server substitution variables.” For WebSphere 6 server
instances, proceed to "Adding guest to the DB2 Alphablox Administrators group.”

Creating WebSphere 5.1 server substitution variables

In this task, you will modify server substitution variables for WebSphere 5.1 server
instances to properly run DB2 Alphablox within WebSphere integrated test
environments.

1. Open the Servers view and double-click on the WebSphere 5.1 server instance
you want to modify.

2. Click the Configuration tab for the server instance.
3. Select Enable administration console and deselect Enable universal test client.

4. Click the Variables tab for the server instance. The Substitution Variables
window opens.

5. Add two new variables using the Add button (located next to the Node
Settings list).
a. Add a variable named WS_EAR_AlphabloxPlatform and set the value to
$ (APP_INSTALL_ROOT)/Tocalhost/AlphabloxPlatform.ear.

b. Add a second variable named WS_EAR _AlphabloxStudio and set the value to
$(APP_INSTALL ROOT)/localhost/ApplicationStudio.ear

6. Save your changes.
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For WebSphere 5.1 server instances, you need to follow the steps in "Configuring
WebSphere 5.1 server instances” to finish modifying your server instance.

Configuring WebSphere 5.1 server instances

For WebSphere 5.1 server instances, you need to configure the server instances to
run DB2 Alphablox applications and files.

Prerequisites: Create the required WebSphere 5.1 server substitution variables.

To configure WebSphere 5.1 server instances:

1.

ok~ wpd

—_ -

- o 0 N

Open the Servers view in the Rational Developer tool and start the server
instance that you want to configure.

Right-click the server instance and select Run Administrative Console.
Do not enter a value in the ID field. Click OK.
Click the OK button below the configuration table.

Open the Enterprise Applications navigation view and click the
ApplicationStudio application name.

Set Application Binaries to $ (WS_EAR ApplicationStudio).
Select Use Metadata from Binaries.

Click the OK button below the configuration table.

Click the Save button on the WebSphere Administrative Console.
In the Save to Master Configuration window, click Save.

Start the AlphabloxPlatform and ApplicationStudio applications in the
WebSphere Administrative Console under Applications > Enterprise
Applications.

The server instance is configured. Next you need to do the "Add guest to DB2
Alphablox Administrators group” step.

Adding the guest user to the to DB2 Alphablox Administrators group

Adding the guest user to the DB2 Alphablox Administrators group allows you to
access the DB2 Alphablox Administration Pages while using Rational Developer
tool.
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Prerequisites: Create the WebSphere server instance. Configure the WebSphere
server instance.

To add the guest user to the DB2 Alphablox Administrators group:.

Important: Do not give the guest user administrator rights on your production

1.

3.
4.

WebSphere servers.

Log into the DB2 Alphablox console by using the following telnet command:
telnet Tocalhost portNumber . where portNumber is the port specified during
your DB2 Alphablox installation.

At your telnet console prompt, type the following DB2 Alphablox console
command: set Administrators guest and press Enter.

In the telnet console, type save and then press Enter.
Close the telnet session.

Your WebSphere server instance is now ready for use.
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Creating DB2 Alphablox applications

When you create new applications in Rational Developer, you need to add
required DB2 Alphablox content for the applications to run properly.

Prerequisites: Install the DB2 Alphablox Toolkit on the Rational Developer tool.

1. On the Rational Developer tool menu bar, select File > New Project. The New
Project wizard opens.

2. Expand the Web option, select Dynamic Web Project, and then click Next.

3. Type a name for your project and click the Show Advanced button. Additional
options appear.

4. Select the appropriate servlet version and target server.

5. Click Next. The Features options window opens.

6. Select the DB2 Alphablox Content option and then click Finish.

Your new web application project is now DB2 Alphablox-enabled. DB2 Alphablox
tag libraries and Blox Java API are available, and the application descriptor file

(web.xml) has been modified to include required DB2 Alphablox information. You
can now begin adding JSP files containing DB2 Alphablox content to your project.

Creating JSP files with DB2 Alphablox content

In this task, you create new JSP files with access to Blox tag libraries using the
Rational Developer tool with the DB2 Alphablox Toolkit.

Prerequisites: Install the DB2 Alphablox Toolkit on the Rational Developer tool.
1. In the Rational Developer’s Project Explorer view, select File > New > JSP File.
2. Type a file name in the File Name field.
3. Click Configure advanced options and press Next.
4. Add the DB2 Alphablox tag libraries that you will use in your JSP file.
a. Click the Add button to open the Add Tag Libraries window.
b. Select the DB2 Alphablox tag libraries you plan on using in your JSP file.
c. Click Next.

5. Select ISO 10646/Unicode(UTF-8) from the Encoding list. The UTF-8 encoding
is required for DB2 Alphablox applications to run properly.

6. Click Finish. Your new JSP file appears in the project listing.
7. Double-click the file name to open the file in the JSP editor window.

8. Place your cursor inside the HTML <head> tag, but after the DB2 Alphablox JSP
taglib directives that you added above.

9. Enter the Blox header tag by typing the following on the new line:
<bTox:header/> The Blox header tag is needed to add required DB2 Alphablox
JavaScript and CSS files when you run your JSP file.

Your new JSP file is now enabled to access the DB2 Alphablox tag libraries that

you selected. With the Rational Developer tool’s Content Assist feature, you can
insert Blox tags and tag attributes for the selected tag libraries.
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In order to access DB2 OLAP Server or Essbase data sources in the Rational
Developer tool when using WebSphere 5.1 server instances, you need to create a
startup batch file that loads required client libraries.

Prerequisites: Install the DB2 Alphablox Toolkit. Install DB2 Alphablox to the
WebSphere 5.1 integrated test environments. Configure the WebSphere 5.1 server
instances. Install IBM DB2 OLAP Server or Hyperion Essbase on your development
machine.

Due to limitations in the WebSphere 5.1 integrated test environments in the
Rational Developer tool, you need to create a startup batch file for the Rational
Developer tool to access DB2 OLAP Server or Hyperion Essbase data sources.
When you start the Rational Developer tool using the batch file, required Essbase
client libraries are added to the Java library path.

To create a batch file to enable access to DB2 OLAP Server or Essbase with
WebSphere 5.1 server instances:

1. Using a text editor, create and a new text document.

2. Add a line of code to invoke the DB2 Alphablox aassetup.bat file, located in
your DB2 Alphablox installation directory. For example, the following code will
run the aassetup.bat file located in the specified DB2 Alphablox installation:
call C:\alphablox\analytics\bin\aassetup.bat

3. Add a second line to invoke the RAD rationalsdp.exe file, which will start up
RAD. For example, the following code will run the Rational Developer tool:

call C:\Program Files\IBM\Rational\SDP\6.0\rationalsdp.exe

4. Save this file as startRAD.bat to your workstation desktop (or another
convenient location).

When you double-click on the startRAD.bat file, the DB2 Alphablox aassetup.bat
runs and sets the required paths and environment variables, then Rational
Application Developer is started. The version of the Essbase client libraries used
with DB2 Alphablox needs to match the version of the DB2 OLAP Server (or
Hyperion Essbase) version you are using as a data source. To modify the Essbase
client libraries used with DB2 Alphablox, run the DB2 OLAP Server / Essbase
Client Library Utility (ChangeEssbase.bat), which can be found in the
db2_alphablox\analytics\bin directory, where db2_alphablox is the root directory of
your DB2 Alphablox installation. This utility modifies one of the batch files run
when you start RAD using the startRAD batch file you created.

Below is a complete example startRAD.bat file described above:

call C:\alphablox\analytics\bin\aassetup.bat
call C:\Program Files\IBM\Rational\SDP\6.0\rationalsdp.exe

Whenever you intend to access DB2 OLAP Server or Essbase data sources, the
startupRAD.bat file must be used to start the Rational Developer tool.
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Chapter 5. Tutorial: Building a DB2 Alphablox cube using DB2
Cube Views

The tutorial guides you through the creation of a DB2 Alphablox cube built using a
DB2 Cube Views ' sample database.

The tasks in the tutorial do not provide details about building custom DB2
Alphablox cubes. Instead, the goal is to show you how to quickly create a DB2
Alphablox cube that can be used in exploring the capabilities of DB2 Alphablox
Cube Server. The resulting data source can also be used for testing and building
DB2 Alphablox applications.

Prerequisites:
* Install DB2 Alphablox. See the Installation Guide for details about installation.
* Gain access rights to a supported DB2 Cubes Views implementation which has

the DB2 Cube Views CVSAMPLE sample database installed. See the Installation
Guide for details about supported versions of DB2 Cube Views.

In the tutorial, you will learn how to build a DB2 Alphablox cube based on the
DB2 Cube Views CVSAMPLE sample database. During the tutorial, you will learn
the following tasks:

Defining a DB2 relational data source

In this task, you will define a data source definition in DB2 Alphablox for a DB2
database.

Prerequisites: Required DB2 JDBC drivers must be accessible to DB2 Alphablox.

A DB2 Alphablox cube requires that the underlying relational data source is
predefined as a DB2 Alphablox data source. DB2 Alphablox cubes are generated
using the metadata and data available in relational databases.

To define a DB2 Alphablox data source for a DB2 database:

1. Log into the DB2 Alphablox Administration Pages as the admin user (or as a
user with administrator rights).

Click the Administration tab.

Click the Data Sources link.

Click the Create button.

From the Adapter menu, select the appropriate IBM DB2 JDBC driver for your
database server.

Select IBM DB2 JDBC Type 4 Driver or IBM DB2 UDB on iSeries Driver.

6. In the Data Source Name field, type CVSAMPLE as the name to be used for your
data source.
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7. Enter the appropriate values for the Server Name, Port Number, and the
Database Name (this should be CVSAMPLE).

Note: If you need help determining the correct values for these fields, contact
your database administrator.

8. Enter a Default Username and Default Password.
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The username and password must be valid on the relational database. The
default username and password are always used when a DB2 Alphablox cube
accesses the relational database. The database user you use should have read
access rights to the database.

Note: The value for Use DB2 Alphablox Username and Password is ignored
when the specified relational data source is being used to populate a
DB2 Alphablox cube. Access control lists (ACLs) can be used to restrict
access to DB2 Alphablox cubes. For information about ACLs, see the
Administrator’s Guide.

9. The Maximum Rows and Maximum Columns values are ignored when the
data source is being used to populate a DB2 Alphablox cube. You can still
enter values and they will be used when other applications use the data
source.

10. Set the JDBC Tracing Enabled value to No, unless you want to write JDBC
logging information to the DB2 Alphablox log file. Enable JDBC tracing only if
you are experiencing problems and you need to debug their causes.

11. Click the Save button to save the data source definition.

You have now defined the DB2 Alphablox data source definition for CVSAMPLE.
Now you can now create a DB2 Alphablox cube definition for accessing the Cube
Views cubes metadata in this DB2 data source.

Defining an Alphablox Cube Server Adapter data source

In this task, you will define a DB2 Alphablox data source definition that uses the
Alphablox Cube Server Adapter.

Prerequisites: Create the DB2 Alphablox data source definition for your DB2
CVSAMPLE database.

To define a DB2 Alphablox Cube Server Adapter data source:

1. Log into the DB2 Alphablox Administration Pages as the admin user (or as a
user with administrator rights).

Click the Administration tab.

Click the Data Sources link.

Click the Create button.

From the Adapter menu, select the Alphablox Cube Server Adapter option.
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In the Data Source Name field, enter DB2ATphabloxCubes as the name to be
used for your data source.

7. Click the Save button to save your data source definition.

You have defined a DB2 Alphablox data source that can be used for accessing DB2
Alphablox cubes. Next you need to define a DB2 Alphablox cube that you can
access.

Defining a DB2 Alphablox cube
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In this task, you will define a DB2 Alphablox cube based on the metadata from a
DB2 Cube Views CVSAMPLE cube.

Prerequisites: Define the DB2 relational data source. Define a DB2 Alphablox Cube
Server Adapter data source.
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To define the general properties of a DB2 Alphablox cube:

1. Log into the DB2 Alphablox Administration Pages as the admin user (or as a
user with administrator rights).

Click the Administration tab.
Click the Cubes link.
Click the Create button. The Cube Administration window opens.

ok 0N

Define the new cube:
a. In the DB2 Alphablox Cube Name field, type CVSales.

b. Select the Enabled option, located next to the DB2 Alphablox Cube Name
field. Selecting this option results in your cube starting automatically when
your server restarts.

c. From the Relational Data Source menu, select MyDB2, the relational data
source you created for this tutorial.

d. Leave the Security Role option unselected. This option can be used to limit
the users able to access a particular cube.

6. Enable DB2 Cube Views settings and specify the metadata to be used:
a. Select the Enable DB2 Cube Views Settings option.
b. From the Cube Model menu, select CVSAMPLE.Sales.
c. From the Cube menu, select the General Sales cube,
d

. Select the Use Business Names radio button to specify the names. Selecting
this option uses the typically more meaningful and readable member
names.

e. Click the Import Cube Definition button. Using this option allows you to
import a cube definition and pre-populate measures and dimensions in
your DB2 Alphablox cube. The cube definition that is imported reflects the
DB2 Cube Views cube as closely as DB2 Alphablox can match, based on
support of DB2 Cube Views metadata. When you have more experience in
working with cubes, you can modify measures and dimensions to meet
your needs.

f. Click on the Show Import Log button to see a log specifying information
and debugging messages related to the import operation. For this tutorial,
this step is included just to help familiarize you with this feature.

g. Select the Import cube definition on start, rebuild, and edit option. This
option will result in your DB2 Alphablox cube using the latest DB2 Cube
Views definition each time your DB2 Alphablox cube is started, rebuilt, or
opened for edit. With more familiarity with DB2 Alphablox and DB2 Cube
Views, you can import the cube definition and customize it.

7. Click the Save button to save the DB2 Alphablox cube definition.

You have now created a DB2 Alphablox cube definition. Now you can start up
your new CVSales cube.

Starting your DB2 Alphablox cube

In this task, you start the CVSales cube using the DB2 Alphablox Administration
Pages.

Prerequisites: Define the DB2 relational data source. Define a DB2 Alphablox Cube
Server Adapter data source. Define the DB2 Alphablox cube.

To start the CVSales cube:
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1. Log into the DB2 Alphablox Administration Pages as the admin user (or as a
user with administrator rights).

2. Click the Administration tab.
3. Under the Runtime Management section, click the Cubes link.

4. From the DB2 Alphablox Cubes list, select the DB2 Alphablox cube you want
to start.

5. Click the Start button. When the cube has started, the status field displays
Running.

You now have a sample DB2 Alphablox cube running. Now you can begin
building applications using the DB2 Alphablox cube you have just created. You can
perform a quick check on your new cube by using the Query Builder application,
selecting your cube as the data source and running MDX queries against the cube.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing, IBM Corporation, North Castle Drive, Armonk, NY
10504-1785 U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation, Licensing, 2-31 Roppongi 3-chome, Minato-ku, Tokyo
106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other country
where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS
MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS” WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT
NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT,
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states
do not allow disclaimer of express or implied warranties in certain transactions,
therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:
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IBM Corporation, [46A/G4, 555 Bailey Avenue, San Jose, CA 95141-1003 U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM for the purposes of developing, using, marketing, or distributing application
programs conforming to IBM’s application programming interfaces.

Trademarks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States, other countries, or both:

Cube Views DB2 DB2 OLAP Server
DB2 Universal Database IBM Informix Rational
WebSphere
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Alphablox and Blox are trademarks or registered trademarks of Alphablox
Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Linux® is a trademark of Linus Torvalds in the United States, other countries, or
both.

Other company, product or service names may be trademarks or service marks of
others.
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