
 
Hyperion Solutions Corporation

Essbase® XTD Analytic Services
Release 7.0

Spreadsheet Add-in User’s Guide for Excel 



Copyright 1991–2003 Hyperion Solutions Corporation. All rights reserved.

U.S. Patent Numbers: 5,359,724 and 6,317,750 

Hyperion, Essbase, and the “H” logo are registered trademarks of Hyperion Solutions 
Corporation. Hyperion Solutions and Essbase XTD are trademarks of Hyperion Solutions 
Corporation. All other brand and product names are trademarks or registered trademarks of 
their respective holders.

No portion of this manual may be reproduced or transmitted in any form or by any means, 
electronic or mechanical, including photocopying, recording, or information storage and 
retrieval systems, for any purpose other than the purchaser’s personal use, without the express 
written permission of Hyperion Solutions Corporation.

Notice: The information contained in this document is subject to change without 
notice. Hyperion Solutions Corporation shall not be liable for errors contained herein or 
consequential damages in connection with the furnishing, performance, or use of this material.

Hyperion Solutions Corporation 
1344 Crossman Avenue 
Sunnyvale, CA 94089

Printed in the U.S.A.



■ iiiEssbase XTD Spreadsheet Add-in for Excel

Contents

Preface .........................................................................................................................  vii

Purpose.............................................................................................................................  vii
Audience .........................................................................................................................  viii
Document Structure ........................................................................................................  viii
Where to Find Hyperion Documentation...........................................................................  x
Conventions.......................................................................................................................  xi
Additional Support ...........................................................................................................  xii
Documentation Feedback................................................................................................  xiii

Introduction to Release 7.0 ...............................................................................  xv

Migration to Release 7.0 ..................................................................................................  xv
New Features in Release 7.0 ............................................................................................  xv
New Feature in Release 6.5.1.........................................................................................  xvii

Chapter 1: Introduction to Essbase XTD Analytic Services ............  19

Typical Users of Analytic Services ..................................................................................  20
Components of the Client-Server Environment ...............................................................  20

The Server ................................................................................................................  21
Essbase XTD Spreadsheet Add-in............................................................................  21
The Network.............................................................................................................  22

Analytic Services Application Products...........................................................................  22
Essbase XTD Spreadsheet Toolkit ...........................................................................  22
Essbase XTD Partitioning Option ............................................................................  22
Essbase XTD Structured Query Language Interface................................................  23
Essbase XTD Application Programming Interface ..................................................  23
Essbase Currency Conversion ..................................................................................  23
Essbase XTD Integration Services ...........................................................................  23



Contents

iv ■ Essbase XTD Spreadsheet Add-in for Excel

Hyperion Objects ...................................................................................................... 23
The Multidimensional Database ....................................................................................... 24
Database Outlines ............................................................................................................. 26

Dimensions................................................................................................................ 27
Members.................................................................................................................... 27
Attributes................................................................................................................... 28
Formulas.................................................................................................................... 28
Aliases ....................................................................................................................... 29
Consolidations........................................................................................................... 29

Chapter 2: A Basic Tutorial ................................................................................ 31

Getting Acquainted with Spreadsheet Add-in .................................................................. 32
Adding Spreadsheet Add-in ...................................................................................... 32
Starting Spreadsheet Add-in ..................................................................................... 33
Installing the Essbase Toolbar for Excel ................................................................... 34
Using the Essbase Toolbar ........................................................................................ 35
Accessing Online Help.............................................................................................. 38
Enabling Mouse Actions........................................................................................... 39

Preparing to Begin the Tutorial......................................................................................... 41
Setting Essbase Options ............................................................................................ 41
Following Guidelines During the Tutorial ................................................................ 45
Reviewing the Sample Basic Database ..................................................................... 46

Retrieving Data ................................................................................................................. 47
Connecting to a Database.......................................................................................... 48
Changing a Password ................................................................................................ 50
Retrieving Data from a Database .............................................................................. 50
Canceling a Data Retrieval Request.......................................................................... 52
Restoring the Previous Database View ..................................................................... 52
Drilling Down to More Detail................................................................................... 53
Drilling Up to Less Detail ......................................................................................... 57
Customizing Drill-Down and Drill-Up Behavior...................................................... 58

Pivoting, Retaining, and Suppressing Data....................................................................... 61
Pivoting Rows and Columns ..................................................................................... 62
Retaining a Data Subset ............................................................................................ 66
Removing a Data Subset ........................................................................................... 68



Contents

■ vEssbase XTD Spreadsheet Add-in for Excel

Navigating Through the Worksheet Without Retrieving Data..................................  69
Suppressing Missing Values, Zero Values, and Underscore Characters...................  73

Formatting the Worksheet ................................................................................................  76
Formatting Text and Cells.........................................................................................  76
Displaying Aliases for Member Names....................................................................  85
Displaying Both Member Names and Aliases..........................................................  87
Repeating Member Labels ........................................................................................  88

Creating Queries Using Essbase Query Designer ............................................................  91
About Creating and Changing Queries.....................................................................  93
Creating Queries .......................................................................................................  94
Saving Queries ........................................................................................................  101
Applying Queries....................................................................................................  103
Deleting Queries .....................................................................................................  104
Viewing Messages and Confirmations....................................................................  104
Accessing Help .......................................................................................................  106
Connecting to Multiple Databases from Essbase Query Designer .........................  106
Applying Worksheet Options to Essbase Query Designer Results.........................  107

Selecting Members .........................................................................................................  108
Saving and Disconnecting ..............................................................................................  118

Saving a Worksheet.................................................................................................  119
Disconnecting from Analytic Services ...................................................................  119
Logging Off ............................................................................................................  120

On to Advanced Tasks ....................................................................................................  120

Chapter 3: An Advanced Tutorial..................................................................  121

Preparing to Begin the Tutorial ......................................................................................  122
Connecting to a Database .......................................................................................  122
Setting Essbase Options..........................................................................................  124

Performing Advanced Retrieval Tasks ...........................................................................  128
Filtering Data ..........................................................................................................  129
Sorting Data ............................................................................................................  136
Retrieving Data into Asymmetric Reports..............................................................  139
Drilling Down to a Sample of Members.................................................................  141
Working with Formatted Worksheets .....................................................................  143
Preserving Formulas When Retrieving Data ..........................................................  149



Contents

vi ■ Essbase XTD Spreadsheet Add-in for Excel

Retrieving a Range of Data ..................................................................................... 153
Retrieving Data by Using a Function...................................................................... 156
Retrieving Dynamic Calculation Members............................................................. 160
Specifying the Latest Time Period for Dynamic Time Series................................. 163
Using Free-Form Reporting to Retrieve Data ......................................................... 167

Using Linked Reporting Objects .................................................................................... 177
Linking a File to a Data Cell ................................................................................... 177
Linking a Cell Note to a Data Cell.......................................................................... 181
Linking a URL to a Data Cell ................................................................................. 182
Accessing and Editing Linked Reporting Objects .................................................. 185

Connecting to Multiple Databases.................................................................................. 191
Ways to View Active Database Connections .......................................................... 192

Ways to Access Linked Partitions................................................................................... 192
Updating Data on the Server........................................................................................... 194
Database Calculation ...................................................................................................... 196
Creating Multiple Worksheets from Data ....................................................................... 198
Working with Currency Conversions.............................................................................. 203

Retrieving Currency Conversion Data .................................................................... 204
Connecting to the Sample Currency Databases ...................................................... 205
Performing Ad Hoc Currency Reporting ................................................................ 207

Chapter 4: Using Drill-Through...................................................................... 211

About Drill-Through....................................................................................................... 211
Before You Start ............................................................................................................. 214

Setting Essbase Options .......................................................................................... 216
About the Samples Used in This Tutorial ............................................................... 222

Using Drill-Through ....................................................................................................... 223
Accessing Drill-Through Reports from the Spreadsheet ........................................ 223
Selecting Drill-Through Reports to View or Customize......................................... 230
Selecting and Ordering Columns ............................................................................ 237
Ordering Data.......................................................................................................... 239
Filtering Data .......................................................................................................... 242

Disconnecting from Analytic Services ........................................................................... 250

Index ............................................................................................................................ 251



■ viiEssbase XTD Spreadsheet Add-in for Excel

Preface

Purpose
This guide provides all the information that you need to use Essbase

®
 XTD 

Spreadsheet Add-in (Spreadsheet Add-in) for Microsoft Excel. It explains the 
features and options and discusses the concepts, processes, procedures, formats, 
tasks, and examples that you need to use the software.

Essbase XTD Analytic Services (Analytic Services) is an online analytical 
processing (OLAP) solution that satisfies the complex calculation requirements of 
financial, accounting, and marketing professionals. Analytic Services operates in 
a client-server computing environment on a local area network (LAN). In this 
environment, multiple users can use their desktop computers to retrieve and 
analyze centralized data.

You can create reports from the data residing on the Essbase XTD Analytic Server 
(Analytic Server) in several ways:

● Generate database reports through a spreadsheet interface, called Spreadsheet 
Add-in, as explained in this guide.

● Use the Report Script Editor in Essbase XTD Administration Services to 
create a report script and run a report. For more information on creating and 
running report scripts in Report Script Editor, see the Administration Services 
online help.

● Use Essbase XTD Application Programming Interface (API) to create and run 
database reports. For more information on creating and running reports, see 
the Essbase API Reference.

● Use reporting tools, such as Hyperion Reporting for Essbase XTD Analytic 
Services.
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Audience
This guide is for Analytic Services end users who are responsible for some or all 
of the following tasks:

● Starting Analytic Services and connecting and disconnecting from Analytic 
Services databases

● Retrieving data from a database into a worksheet

● Drilling down, drilling up, and navigating through a worksheet to analyze and 
arrange data from multiple viewpoints

● Working with linked reporting objects and linked partitions

● Updating data on Analytic Server

● Using the worksheet to load and calculate data in the database

● Creating multiple sheets from data

● Working with currency conversions

Document Structure
The main sections of this guide are structured as tutorials that take you 
step-by-step through basic and advanced tasks in Spreadsheet Add-in. This 
document contains the following information: 

● “Introduction to Release 7.0” on page xv provides information on migrating 
from previous versions of Analytic Services to Release 7.0 and lists all new 
features and enhancements.

● Chapter 1, “Introduction to Essbase XTD Analytic Services,” introduces you 
to basic concepts of retrieving and manipulating data through the spreadsheet 
interface.

● Chapter 2, “A Basic Tutorial,” provides a step-by-step tutorial of basic data 
navigation, ad hoc retrieval, and reporting techniques.

● Chapter 3, “An Advanced Tutorial,” describes advanced reporting and 
retrieval techniques for users that need special reports or formatted data views.

● Chapter 4, “Using Drill-Through,” provides a brief overview of the Essbase 
XTD Integration Services drill-through product.



Document Structure

■ ixEssbase XTD Spreadsheet Add-in for Excel

● The Index contains a list of terms and their page numbers. Select or look up 
an index entry to view the page to which the entry refers.

Note: The Spreadsheet Add-in online help provides a comprehensive section on 
Essbase XTD Spreadsheet Toolkit. This section enables you to customize and 
automate your use of Analytic Services by using Excelmacros and Visual Basic for 
Applications (VBA) functions. For more information on the Spreadsheet Add-in online 
help, see “Accessing Online Help” on page 38.

The Essbase XTD Spreadsheet Add-in User’s Guide for Excel is provided in PDF 
format in the \docs\pdf directory of your documentation installation. The.pdf 

file is named Essexcel.pdf for the Excel add-in. Adobe
®

 Acrobat Reader
®

 
(Release 3.0.1 or higher) is required for online viewing and printing of this file. 
You can download Adobe Acrobat Reader from the Analytic Services CD-ROM 
or from http://www.adobe.com. On the CD-ROM, the Acrobat Reader 
executable file is located in the Adobe directory under the appropriate platform 
and language-version subdirectories. To install Adobe Acrobat Reader, launch the 
executable file, follow the prompts, and provide the information requested.

Sample Databases and Files
This book provides tutorial steps that are based on sample databases and files that 
are provided with the Analytic Server software. You use the Sample Basic 
database for most tasks in Chapter 2 and Chapter 3. You use a sample Analytic 
Services currency conversion application to complete the tutorial on currency 
conversion. See Chapter 3, “An Advanced Tutorial.” For information on the 
Sample Basic database, see Chapter 2, “A Basic Tutorial.”

In addition to these sample applications and databases, you also use several sample 
Spreadsheet Add-in files in the advanced tutorial in Chapter 3. The individual at 
your organization who installs the server is responsible for making these 
applications, databases, and files available to you. Contact the Analytic Services 
system administrator for more information.

http://www.adobe.com
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Where to Find Hyperion Documentation
All Analytic Services documentation is accessible from the following locations:

● Essbase XTD Analytic Services Information Map provides access to all 
Analytic Services documentation in both PDF and Windows help formats. The 
Information Map is located at

ARBORPATH/docs/essdocs.htm

● Online help is accessible from the Spreadsheet Add-in. Start the product and 
click the Help button in any dialog box in the Spreadsheet Add-in or select 
Essbase Help from the Help menu.

● The Hyperion Solutions Web site is located at http://www.hyperion.com.

● Access to the Hyperion Download Center is through 
http://hyperion.subscribenet.com.

➤ To access the documentation from the Hyperion Solutions Web site:

1. Log on to http://www.hyperion.com.

2. Select Support from the menu bar.

3. Enter your username and password, and click Login. 

Note: If you do not have a username and password, click Register on the login 
page to request them.

4. Follow the on-screen instructions.

➤ To access documentation from the Hyperion Download Center:

1. Log on to http://hyperion.subscribenet.com.

2. In the Login ID and Password text boxes, enter your assigned login ID name 
and password. Then click Login.

3. If you are a member on multiple Hyperion Download Center accounts, select 
the account that you want to use for the current session.

4. Follow the on-screen instructions.

http://www.hyperion.com
http://hyperion.subscribenet.com
http://www.hyperion.com
http://hyperion.subscribenet.com
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➤ To order printed documentation:

● Visit the Hyperion Solutions Web site at http://www.hyperion.com.

● In the United States, call Hyperion Solutions Customer Support at 
877-901-4975.

● From outside the United States, including Canada, call Hyperion Solutions 
Customer Support at 203-703-3600. Clients who are not serviced by support 
from North America should call their local support centers.

Conventions
The following table shows the conventions that are used in this document:

Table i: Conventions Used in This Document 

Item Meaning

Arrows indicate the beginning of a procedure, which 
consists of one or more sequential steps.

Brackets [] In examples, brackets indicates that the enclosed 
elements are optional.

Bold Bold in procedural steps highlights major interface 
elements.

CAPITAL LETTERS Capital letters denote commands and various IDs. 
(Example: CLEARBLOCK command)

Ctrl + 0 Keystroke combinations shown with the plus symbol 
(+) indicate that you should press the first key and 
hold it while you press the next key. Do not type 
the + symbol.

Example text Courier font indicates that the material shown is a code 
or syntax example.

Courier italics Courier italic text indicates a variable field in command 
syntax. Substitute a value in place of the variable shown 
in Courier italics.

Italics Italics in a product-related term in the body of a book 
indicates that the term is included in the glossary of 
the book.

http://www.hyperion.com
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Additional Support
In addition to providing documentation and online help, Hyperion offers the 
following product information and support. For details on education, consulting, 
or support options, visit Hyperion’s Web site at http://www.hyperion.com.

Education Services
Hyperion offers instructor-led training, custom training, and eTraining covering all 
Hyperion applications and technologies. Training is geared to administrators, end 
users, and information systems (IS) professionals. 

Consulting Services
Experienced Hyperion consultants and partners implement software solutions 
tailored to clients’ particular reporting, analysis, modeling, and planning 
requirements. Hyperion also offers specialized consulting packages, technical 
assessments, and integration solutions.

Ellipses (...) Ellipsis points indicate that text has been omitted from 
an example.

Mouse orientation This document provides examples and procedures using 
a right-handed mouse. If you are using a left-handed 
mouse, adjust the procedures accordingly.

Menu options Options in menus are shown in the following format. 
Substitute the appropriate option names in the 
placeholders, as indicated.

Menu name > Menu command > Extended menu 
command 

For example: 1. Select File > Desktop > Accounts. 

n, x Italic n stands for a variable number; italic x can stand 
for a variable number or an alphabet. These variables 
are sometimes found in formulas.

Table i: Conventions Used in This Document (Continued)

Item Meaning

http://www.hyperion.com
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Technical Support
Hyperion provides enhanced electronic-based and telephone support to clients to 
resolve product issues quickly and accurately. This support is available for all 
Hyperion products at no additional cost to clients with current maintenance 
agreements.

Documentation Feedback
Hyperion strives to provide complete and accurate documentation. We value 
your opinions on this documentation and want to hear from you. Send us your 
comments by clicking the link for the Documentation Survey, which is located on 
the Information Map for your product.
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Introduction to Release 7.0

This chapter provides compatibility information for Essbase XTD Analytic 
Services Release 7.0 and previous releases of Analytic Services, including 
migration information and new feature descriptions and enhancements. It contains 
the following topics:

● “Migration to Release 7.0” on page xv

● “New Features in Release 7.0” on page xv

● “New Feature in Release 6.5.1” on page xvii

Migration to Release 7.0
As you migrate or upgrade from previous releases of Analytic Services to Release 
7.0, keep in mind that Release 7.0 of Essbase XTD Spreadsheet Add-in works with 
Release 7.0 of Essbase XTD Analytic Server. If the Analytic Services system 
administrator upgrades Analytic Server to Release 7.0, earlier releases of 
Spreadsheet Add-in work on only a limited basis. Upgrade to Spreadsheet Add-in 
for Release 7.0 as soon as possible.

Read the Essbase XTD Analytic Services Installation Guide for detailed 
information about migrating from previous releases of Analytic Services.

New Features in Release 7.0
Release 7.0 includes the following new features and enhancements:

● Metadata Sampling

● Currency Changes in the Sample Applications

● Support for Excel XP
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Metadata Sampling
Essbase XTD Analytic Services is a multidimensional database engine that 
provides support for ad hoc analysis. Such analysis is entirely driven by the 
intuition of the analyst and can be time-consuming as data volume increases. Large 
cubes tend to have more dimensions and sometimes more levels, making 
hierarchical navigation very cumbersome.

Metadata sampling enables you to analyze large cubes with a focus on data trends 
or to approximate information in the initial stages. Because you query on a 
“sample” of members, retrieval is quick. Metadata sampling enables you to drill 
down on a portion of the vast amount of members in an Analytic Services database 
in a fraction of the time that it usually takes to analyze the whole database. You can 
view many samples in a small amount of time and make early decisions. Later, you 
can follow with organized data exploration.

With the introduction of Hybrid Analysis, you can store part of an Analytic 
Services cube in a relational database. Metadata sampling enables you to drill 
down on all of the data that you specify, whether it is in Analytic Services or in an 
underlying relational database.

Currency Changes in the Sample Applications
With the introduction of the euro as the official currency of the countries of the 
European Union, several currencies that were used in the Analytic Services sample 
applications no longer exist. In past versions of Analytic Services, portions of the 
sample applications used the currencies of Germany, France, and Spain. 
References to these currencies have been replaced by references to the euro 
(EUR), Swiss franc (CHF), and Swedish Krona (SEK), respectively.

Also, where applicable, the abbreviated  names of the currencies used in the 
sample applications have been changed to reflect international standards for the 
representation of currency units. Table i is a complete list of the currencies used in 
the sample application and their respective abbreviation,

Table i: Currency Names and Their Abbreviations

Currency Name Abbreviation

British Pound GBP

Canadian Dollar CAD

European Union Euro EUR
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Support for Excel XP
Essbase XTD Spreadsheet Add-in is now supported on Excel XP, as well as Excel 
2000 and Excel 97.

New Feature in Release 6.5.1
Release 6.5.1 included the following new feature:

● Drill-Through Filter Persistence

Drill-Through Filter Persistence
Beginning with Essbase 6.5.1, when you customize a drill-through report in 
Essbase XTD Spreadsheet Add-in, you can save the drill-through filters that you 
create in the Select Data Filters dialog box. In prior releases of Analytic Services, 
users could not save filters that they created when customizing a drill-through 
report. Users of 6.5.0 and previous releases had to recreate a filter each time they 
created a drill-through report. 

Swedish Krona SEK

Swiss Franc CHF

United States Dollar USD

Table i: Currency Names and Their Abbreviations

Currency Name Abbreviation
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1

Chapter

1
Introduction to Essbase XTD 
Analytic Services

Essbase XTD Analytic Services is multidimensional database software that is 
optimized for planning, analysis, and management-reporting applications. 
Analytic Services uniquely blends an innovative technical design with an open, 
client-server architecture. The product enables you to extend decision support 
systems beyond ad hoc queries and reports on historical performance to dynamic, 
operational systems that combine historical analysis and future planning. 

By consolidating and staging historical and projected data for detailed analysis, 
you gain perspectives about your business that enable you to take appropriate 
actions.

Analytic Services provides both power and flexibility. Thus, it can be used for a 
broad range of online analytical processing (OLAP) applications, including those 
in the following list:

● Budgeting

● Forecasting and seasonal planning

● Financial consolidations and reporting

● Customer and product profitability analysis

● Price, volume, and mix analysis

● Executive information systems

Analytic Services enables you and others in the organization to share, access, 
update, and analyze enterprise data from any perspective and at any level of detail 
without learning new tools, query languages, or programming skills.
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Typical Users of Analytic Services
Analytic Services can be used in many different applications. Financial analysts 
have found the product to be invaluable in budget analysis, currency conversion, 
and consolidation. Cost accountants apply its powerful capabilities to evaluate 
allocation and elimination scenarios. Product managers and analysts use it to plan 
and analyze multiple product lines and distribution channels. You can also use the 
product as a repository database for spreadsheet data. Anyone who uses a 
spreadsheet is a potential user of Analytic Services.

Because Analytic Services is applicable to such a broad variety of environments, 
individuals using it at an organization may fill one or more roles in implementing 
and running applications. This guide refers to specific roles by three titles. A role 
may be performed, however, by one person or by several people working 
collaboratively.

● System administrator. The Analytic Services system administrator typically 
has experience in networking, installing software packages, and administering 
system functions. In addition to installing the Analytic Services software, the 
Analytic Services system administrator may also set up Analytic Services user 
accounts, set up the security system, and maintain the Essbase XTD Analytic 
Server. 

● Application designer. The application designer sets up the Analytic Services 
database, creates the database outline, and develops calculation and report 
scripts. The responsibilities of the Analytic Services system administrator and 
the application designer may overlap in some areas. The application designer 
has probably developed spreadsheet or database applications and understands 
the operational problems and the tools being employed to solve them.

● User. The user interacts with Analytic Services databases through 
spreadsheets, using Microsoft Excel for Windows. Users are typically analysts 
and managers who use spreadsheet programs as their primary tool for viewing 
and analyzing data. 

Components of the Client-Server Environment
Client-server computing refers to the architecture in which individual PC 
workstations are connected to a powerful server by means of a local area network 
(LAN). The PC workstation acts as a client by requesting data from the server. The 
server processes the request and returns the desired result to the client.
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Analytic Services is built as a client-server system. System performance 
and multiuser capabilities are greatly enhanced in the Analytic Services 
client-server environment. Figure 1 illustrates the Analytic Services components 
and their relationships.

Figure 1: Analytic Services Components

The Server
Analytic Server is a multidimensional database that supports analysis of an 
unlimited number of data dimensions and an unlimited number of members within 
these dimensions, developed using a true client-server architecture,  All data, the 
database outline, the calculations, and the data security controls reside on the 
Analytic Server.

Essbase XTD Spreadsheet Add-in
Essbase XTD Spreadsheet Add-in is a software program that merges seamlessly 
with Microsoft Excel. After Analytic Services is installed, a special menu is added 
to the spreadsheet application. The menu provides enhanced commands such as 

TCP/IP

Excel
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Connect, Pivot, Drill-down, and Calculate. Users can access and analyze data on 
Analytic Server by using simple mouse clicks and drag-and-drop operations. 
Spreadsheet Add-in enables multiple users to access and to update data on 
Analytic Server simultaneously.

The Network
Analytic Services runs on PC-based LANs that support the TCP/IP protocol.

Note: Supported network environments and technical requirements are discussed in 
detail in the Essbase XTD Analytic Services Installation Guide, which is included with 
the Analytic Services package.

Analytic Services Application Products
Several optional products, designed to extend and enhance the scope 
of OLAP applications, can be implemented using Analytic Services. 
The following sections describe these products.

Essbase XTD Spreadsheet Toolkit
Essbase XTD Spreadsheet Toolkit includes over 20 macro and Visual Basic 
for Applications (VBA) functions that enable you to build customized Microsoft 
Excel applications. The applications incorporate Analytic Services commands. 
Commands such as EssCascade, EssConnect, and EssDisconnect provide all 
the functionality of their corresponding Essbase menu commands. For more 
information, see the Essbase XTD Spreadsheet Add-in Online Help.

Essbase XTD Partitioning Option
Essbase XTD Partitioning option enables you to define areas of data that are 
shared or linked between data models. Partitioning can affect the performance and 
scalability of Analytic Services applications. Partitioning provides more effective 
response to organizational demands, reduced calculation time, increased reliability 
and availability, and incorporation of detail and dimensionality. For more 
information on partitions, see “Ways to Access Linked Partitions” on page 192.
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Essbase XTD Structured Query Language Interface 
Essbase XTD SQL Interface enables access to PC and structured query language 
(SQL) relational databases by making Analytic Server operate as an open database 
connectivity client. Using SQL Interface, data can be moved easily from these 
diverse corporate data sources into Analytic Server for user access and analysis. 
For more information SQL Interface, see the Essbase SQL Interface Guide. 

Essbase XTD Application Programming Interface
Essbase XTD Application Programming Interface (API) enables application 
developers to create custom applications quickly by using standard tools while 
taking advantage of the robust data storage, retrieval, and manipulation 
capabilities of Analytic Services. API supports Visual Basic and C. For more 
information on application programming, see the API Reference.

Essbase Currency Conversion
Essbase currency conversion translates, analyzes, and reports on foreign financial 
data. Any exchange rate scenario can be modeled, and you can even perform ad 
hoc currency conversions of data, directly from the spreadsheet. The currency 
conversion product is compliant with Financial Accounting Standards Board 52 
(FASB52). For more information on conversions, see “Working with Currency 
Conversions” on page 203. 

Essbase XTD Integration Services
Essbase XTD Integration Services works with Analytic Services and Microsoft 
Excel. This product is a suite of tools and data integration services that serve as a 
bridge between relational data sources and Analytic Server. Integration Server 
drill-through is one of the tools of Integration Services. Using Integration Server 
drill-through, you can view and customize spreadsheet reports that display data 
retrieved from relational databases. For more information on the drill-through tool, 
see Chapter 4, “Using Drill-Through.”

Hyperion Objects
Hyperion Objects are ActiveX controls that enable you to build application 
programs to access and manipulate data residing in multiple instances of Analytic 
Server. You can combine objects with other controls in a visual design 
environment to construct new programs.
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The Multidimensional Database
The Analytic Services multidimensional database stores and organizes data. It is 
optimized to handle applications that contain large amounts of numeric data and 
that are consolidation-intensive or computation-intensive. In addition, the 
database organizes data in a way that reflects how the user wants to view the data.

Definition of Multidimensional

A dimension is a perspective or view of a specific dataset. A different view of 
the same data is an alternate dimension. A system that supports simultaneous, 
alternate views of datasets is multidimensional. Dimensions are typically 
categories such as time, accounts, product lines, markets, budgets, and so on. 
Each dimension contains additional categories that have various relationships one 
to another. 
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An Analytic Services application contains an unlimited number of dimensions, so 
you can analyze large amounts of data from multiple viewpoints. Figure 2 shows 
four views of multidimensional data. You can retrieve and analyze the 
multidimensional data with the Spreadsheet Add-in software.

Figure 2: Multiple Views from a Five-Dimensional Database

In contrast to the multidimensional view, worksheets stores data in two 
dimensions, usually time and accounts, as shown in Figure 3:

Figure 3: Two-Dimensional Representations of Data in a Worksheet
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Database Outlines
Understanding the database outline is the key to understanding Analytic Services. 
To define a multidimensional database, you design its database outline. The 
database outline contains the database organization (structure), the database 
members, and the database rules, as shown in Figure 4:

Figure 4: Analytic Services Database Outline

The application designer or Analytic Services system administrator usually creates 
the database outline. For more information on creating the database outline, see 
the Essbase XTD Analytic Services Database Administrator’s Guide.

The components of the database outline are as follows:

● Dimensions

● Members

● Attributes

● Formulas

● Aliases
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● Consolidations

Refer to the following topics for descriptions of the outline components.

Dimensions
Dimensions are the most basic categorical definitions of data within the database 
outline. You need at least two dimensions to make any meaningful reference to 
data; for example, a time dimension and an accounts dimension. Other dimensions 
may categorize products, markets, and scenarios. Using dimensional organization, 
you can define any consolidation structure or any slice of data that is relevant to 
the application. Analytic Services supports an unlimited number of dimensions.

Members
Members are the names of the elements within a dimension. A dimension 
can contain an unlimited number of members. The calculation, reporting, and 
dimension-building features in Analytic Services use the following terms to 
describe members.

● Parents. A parent is a member with a consolidation branch below it. 
Figure 5 shows an example of Qtr1 as a parent member because below 
Qtr1 is a branch containing months as members.

Figure 5: Relationships Among Database Members
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● Children. A child is a member with a parent above it. For example, Jan, Feb, 
and Mar are children of the parent Qtr1.

● Siblings. A sibling is a child member of the same parent and on the same 
branch (same level). For example, Jan, Feb, and Mar are siblings. Apr is not a 
sibling of Jan, Feb, or Mar, however, because it has a different parent, Qtr2.

● Descendants. A descendant is a member at any level below a parent. For 
example, each member that falls in the Year branch is a descendant of Year. 
The following members are all descendants of Year: Qtr1, Jan, Feb, Mar; Qtr2, 
Apr, May, Jun; Qtr3, Jul, Aug, Sep; Qtr4, Oct, Nov, Dec.

● Ancestors. An ancestor is a member of a branch above a member. For 
example, Qtr2 and Year are ancestors of Apr.

● Generations. The term generation describes the branch number of a member. 
Generations count from the root of the tree (generation 1, which is the 
dimension name) toward the leaf node.

● Levels. The term level describes the branch number of a member. Levels count 
from the leaf node (level 0) toward the root (the dimension name).

Attributes
Attributes describe characteristics of data, such as the size and color of products. 
Through attributes, you can group and analyze members of dimensions based 
on their characteristics. Attribute dimensions must be associated with base 
dimensions. For more information, see the Essbase XTD Analytic Services 
Database Administrator’s Guide.

Formulas
Each database member can be associated with one or more formulas in the 
database outline. For example, the Variance members of the Scenario dimension, 
as shown in Figure 4 on page 26, contain formulas. Formulas can be simple or 
complex. For more information on formulas, see the Essbase XTD Analytic 
Services Database Administrator’s Guide.
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Aliases
Analytic Services supports alternative names, or aliases, for database members. 
Aliases are useful when various labels are used for the same member in various 
worksheets. One worksheet, for example, may refer to Cost_of_Goods_Sold as 
COGS. Aliases also can be used for reporting in alternative languages or for more 
formal output name sets, such as account numbers.

Consolidations
Consolidations in Analytic Services applications are defined by member branches. 
The database outline determines consolidation paths. The determination is based 
on the location of members within a dimension. Indentation of one member below 
another indicates a consolidation relationship. Indenting members is important for 
the drill-down capabilities in Spreadsheet Add-in. As you navigate through data, 
you can drill down through levels of consolidations. The database outline is the 
roadmap that determines the levels of data navigation.
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2

Chapter

2
A Basic Tutorial

When you add Essbase XTD Spreadsheet Add-in to Microsoft Excel, most 
spreadsheet operations remain unchanged; Spreadsheet Add-in simply adds a 
new menu, an Essbase toolbar, and mouse shortcuts with which you can access 
Essbase XTD Analytic Services.

The tasks described in this tutorial are basic tasks. That is, these are tasks that you 
probably use often when working with Analytic Services. Chapter 3 describes 
more advanced tasks.

This tutorial chapter contains the following topics:

● “Getting Acquainted with Spreadsheet Add-in” on page 32

● “Preparing to Begin the Tutorial” on page 41

● “Retrieving Data” on page 47

● “Pivoting, Retaining, and Suppressing Data” on page 61

● “Formatting the Worksheet” on page 76

● “Creating Queries Using Essbase Query Designer” on page 91

● “Deleting Queries” on page 104

● “Viewing Messages and Confirmations” on page 104

● “Accessing Help” on page 106

● “Selecting Members” on page 108

● “Saving and Disconnecting” on page 118

● “On to Advanced Tasks” on page 120

Notice that each tutorial task builds upon the previous task. Therefore, tasks must 
be completed in succession.
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The examples used in this tutorial are based on the sample database (called Sample 
Basic) that is included with the Analytic Services installation. Contact the Analytic 
Services system administrator for information about accessing the Sample Basic 
database or about accessing other databases on Analytic Server.

Getting Acquainted with Spreadsheet Add-in
This following topics will help you to get acquainted with Spreadsheet Add-in:

● “Adding Spreadsheet Add-in” on page 32

● “Starting Spreadsheet Add-in” on page 33

● “Installing the Essbase Toolbar for Excel” on page 34

● “Using the Essbase Toolbar” on page 35

● “Accessing Online Help” on page 38

● “Enabling Mouse Actions” on page 39

Adding Spreadsheet Add-in
If you manually update your environment settings or if you have removed 
Spreadsheet Add-in from the Microsoft Excel environment, you must use the 
spreadsheet’s add-in tool to add Spreadsheet Add-in to Excel. The Essbase menu 
is added to the spreadsheet’s menu bar and points Excel to the Essbase XTD 
Spreadsheet Add-in file in the \Essbase\bin directory. This file is on the local 
drive of your computer, if that is where you installed Spreadsheet Add-in, or on the 
network drive if that is where you set up your computer operating environment to 
run Spreadsheet Add-in.

➤ To add Spreadsheet Add-in to Excel:

1. In Excel, select Tools > Add-Ins. 

Excel displays the Add-Ins dialog box.

2. Click the Browse button. 

Excel displays the Browse dialog box.

3. Select the essexcln.xll file.
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The file is in the bin directory where you installed Spreadsheet Add-in on 
your PC hard disk drive (if you installed Spreadsheet Add-in there) or in the 
bin directory where the Analytic Services system administrator installed 
Spreadsheet Add-in on a network drive (if you set up your PC operating 
environment to run Spreadsheet Add-in there).

4. Click OK twice to close the dialog boxes.

Adding Essbase XTD Spreadsheet Add-in to Excel modifies the Windows 
Registry to point to where the Spreadsheet Add-in file is installed.

5. Start Spreadsheet Add-in.

After the Excel startup screen goes away, the Essbase XTD Spreadsheet 
Add-in startup screen is displayed.

If you do not see the Essbase XTD startup screen or if your system does not 
list the Essbase Spreadsheet Add-in menu options, see the Essbase XTD 
Analytic Services Installation Guide for troubleshooting information.

Starting Spreadsheet Add-in
You must start Excel to use Spreadsheet Add-in software. 

You must open a worksheet before attempting to connect to an instance of Analytic 
Server. An attempt to connect to the server without opening a worksheet results in 
an error message.

➤ To begin an Analytic Services session:    

1. Start Excel.

After the startup screen goes away, the Essbase XTD Spreadsheet Add-in 
startup screen is displayed. 

The Essbase menu should be displayed in the spreadsheet menu bar. If you do 
not see the Essbase menu, you may need to use the add-in tool to add Essbase 
XTD Spreadsheet Add-in. For more information, see “Adding Spreadsheet 
Add-in” on page 32. 

In Excel, the Essbase toolbar should also be visible. If you do not see the 
Essbase toolbar, see “Installing the Essbase Toolbar for Excel” on page 34 and 
“Using the Essbase Toolbar” on page 35.

2. From the spreadsheet application menu bar, select Essbase. 

The Essbase menu is displayed.
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Installing the Essbase Toolbar for Excel
In Excel, Spreadsheet Add-in provides a convenient toolbar that displays buttons 
for accessing most of the common Analytic Services commands without having to 
open the Essbase menu.

Prior to using the Essbase toolbar for Excel, you must install the toolbar by 
opening an Excel file that is provided as part of the default Analytic Services 
installation. For more information on using the toolbar, see “Using the Essbase 
Toolbar” on page 35.

➤ To install the Essbase toolbar:

1. Start Excel.

2. Select File > Open. 

3. From the\essbase\client\sample directory, open the esstoolb.xls 
file.

A blank worksheet opens.

Depending on how software is installed on your PC, the file may not be 
available or may be located in a different directory. Contact the Analytic 
Services system administrator for more information.

Note: Upon using Excel, two dialog boxes may be displayed warning that the 
esstoolb.xls file may contain macros. If so, click the Enable Macros button on 
the first dialog box, and click OK on the second dialog box. The macros must be 
enabled for the Essbase toolbar to work.

4. Select File > Close to close the esstoolb.xls file. 

You do not need to modify or save the file. 

You should not have to perform the toolbar installation procedure again unless you 
delete the Essbase toolbar from the Toolbars dialog box in Excel. If you delete the 
toolbar, perform the installation procedure again.

Note: If you have toolbars turned off in Excel, you do not see the Essbase toolbar 
immediately. You must first enable toolbars. For information on enabling the Essbase 
toolbar, see “Using the Essbase Toolbar” on page 35.
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Using the Essbase Toolbar
Spreadsheet Add-in for Excel features a convenient toolbar that displays buttons 
for accessing most of the common Analytic Services commands without having to 
open the Essbase menu. You can view a short description of a button in a pop-up 
window on the toolbar by moving your cursor over the button. 

Note: Before you can view the Essbase toolbar, you must install it. See 
“Installing the Essbase Toolbar for Excel” on page 34.

 Table 1 lists the buttons on the toolbar. To view the Essbase toolbar, select 
View > Toolbars > Essbase from the Excel menu bar. A check box must be 
displayed next to Essbase in the menu.

Note: If you select the Essbase check box and click Delete, you must 
reinstall the toolbar. See “Installing the Essbase Toolbar for Excel” on 
page 34 for instructions.

Table 1: Essbase Toolbar Buttons 

Button Purpose Description

Connect Enables you to connect to an instance of Analytic 
Server. Click the Connect button on the toolbar to 
display the Essbase System Login dialog box.

Navigate with or 
without data 

Toggles the Navigate Without Data feature, which 
tells Analytic Services to retrieve or not to retrieve 
data when you perform navigational operations, 
such as pivot, drill down, drill up, keep only, and 
remove only.

This button serves the same function as the 
Navigate Without Data check box in the 
Essbase Options dialog box (Global tab).
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Retrieve Retrieves data into the active worksheet. A 
retrieve request places data at the beginning of 
the active worksheet. When you click the Retrieve 
button, if you are not already connected to an 
instance of Analytic Server, the Essbase System 
Login dialog box is displayed.

Tip: If you have mouse actions enabled, you 
can retrieve data by double-clicking the primary 
mouse button in any empty cell in the worksheet. 
To enable double-click support, select Essbase > 
Options, select the Global tab, and select the 
Enable Double-Clicking option. For more 
information, see “Enabling Mouse Actions” on 
page 39.

Keep only Retains only the selected member (the active cell) 
or member range in the worksheet. When you 
click the Keep Only button, all unselected 
members are removed from the worksheet.

Remove only Removes the selected member (the active cell) 
or member range from the worksheet. When you 
click the Remove Only button, all unselected 
members are retained in the worksheet.

Zoom in Retrieves and expands data from Analytic 
Services according to the options specified in the 
Essbase Options dialog box. 

When sampling is enabled (Essbase > Sample 
Data (Zoom In)), an approximate percentage 
members of the Analytic Services database that 
you specify is queried when you retrieve and 
expand data.

Tip: If you have mouse actions enabled, you 
can drill down on data by double-clicking the 
primary mouse button in the cell that contains 
the member you want to expand. To enable 
double-click support, select Essbase > Options, 
select the Global tab, and select the Enable 
Double-Clicking option. For more information, see 
“Enabling Mouse Actions” on page 39.

Table 1: Essbase Toolbar Buttons (Continued)

Button Purpose Description
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Zoom out Collapses the view according to the options 
specified in the Essbase Options dialog box in the 
cell that contains the member that you want to 
collapse. To enable double-click support for 
drilling up, select Essbase > Options, select the 
Global tab, and select the Enable Double-Clicking 
option.

Open Essbase 
Query Designer 

Opens the Essbase Query Designer, which makes 
it easy to define a page orientation for dimensions 
and selected database members. You can also save 
queries for later use. Essbase Query Designer is 
designed to create report queries, view attributes, 
and perform calculations based on attributes.

FlashBack Restores the previous worksheet view.

Set options Enables you to set display, zoom, mode, style, and 
global options for the active worksheet to 
customize the behavior of Essbase XTD 
Spreadsheet Add-in software. Click the Options 
button to display the Essbase Options dialog box.

Select members Enables you to select members from the 
multidimensional database outline. Click the 
Member Selection button to display the Essbase 
Member Selection dialog box.

Attach linked 
objects

Enables you to attach comments or files to data 
cells. Click the linked objects button to display the 
linked objects browser dialog box. 

Table 1: Essbase Toolbar Buttons (Continued)

Button Purpose Description
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Accessing Online Help
Essbase XTD Spreadsheet Add-in includes a context-sensitive online help system. 
You access the Spreadsheet Add-in online help in one of three ways. Which way 
you choose depends on the type of information that you need.

● Access the entire online help system for browsing or searching for 
information. 

To access the entire help system, select Help > Essbase Help in Excel. After 
you access online help, you can browse or search through the system to view 
general information on Spreadsheet Add-in, Essbase command descriptions, 
procedural information for completing tasks, Spreadsheet Toolkit macros, and 
Visual Basic for Applications (VBA) function descriptions.

● Access context-specific information from dialog boxes in Spreadsheet 
Add-in. 

Each dialog box in Spreadsheet Add-in features a Help button that accesses 
online help topics that are specific to the particular dialog box. The Help 
buttons enable you to find the information that you need without having to 
search through the entire help system. 

Note: The Spreadsheet Add-in online help also provides a comprehensive section 
on Essbase Spreadsheet Toolkit, which enables you to customize and automate 
your use of Analytic Services by using macros and VBA functions.

● Access information on a specific Essbase Query Designer function. 

Click the What’s This? Help button,  in the Essbase Query Designer dialog 
box, and then click an item in the dialog box to access information on that 
item.

You can also click the Help button in the navigation pane, shown in Figure 6, 
to access the Essbase Query Designer tutorial and all online help topics.

Figure 6: EQD Help Button
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Enabling Mouse Actions
The following terms are used throughout this guide to describe mouse operations:

● Primary mouse button and secondary mouse button describe the buttons on a 
two- or three-button mouse. 

Usually, right-handed users configure the left mouse button as the primary 
button and the right mouse button as the secondary mouse button. The primary 
mouse button is the one that you use to start Windows applications, the 
secondary mouse button is used for auxiliary operations. The term click refers 
to use of the primary mouse button. The term right-click refers to use of the 
secondary mouse button.

● Select chooses the object that is under the cursor when you press and release 
the primary mouse button. 

You can select a worksheet cell, for example, by moving the cursor to the cell 
and pressing and releasing the primary mouse button. 

● Click (that is, both click and right-click) describes a quick press-and-release 
action on a command object. 

You can click a button, for example, to execute a command.

● Double-click describes two quick press-and-release actions that are executed 
in rapid succession. 

You can double-click an application icon, for example, to start a Windows 
application.

● Drag describes a press, hold, and move action. 

You place the cursor on an object, press a mouse button, hold the mouse button 
down as you move the object, and release the mouse button when you reach 
your goal. For example, you can highlight a range of cells in a worksheet by 
dragging the cursor over the cells. 

Note: Analytic Services uses a drag operation called a pivot. A pivot requires use 
of the secondary mouse button. To execute a pivot, you must press and hold the 
secondary, rather than the primary, mouse button while dragging the selection.

Analytic Services offers enhanced mouse actions in Excel. You can use the mouse 
to perform any of the following tasks:

● Retrieve data
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● Drill down and drill up on database members

● Pivot (move or transpose) data rows and columns

● Access linked reporting objects

● Access linked partitions

➤ To enable double-clicking to retrieve, drill down, and drill up on Analytic Services 
data:

1. Select Essbase > Options.

2. In the Essbase Options dialog box, select the Global tab.

3. Select the Enable Double-Clicking check box.

When the Enable Double-Clicking check box is selected, as shown in 
Figure 7, you can retrieve and drill down to more detailed data (primary mouse 
button) and drill up to less detailed data (secondary mouse button). When the 
double-clicking option is enabled, the in-cell editing feature is overridden.

Figure 7: Essbase Options Dialog Box—Global Tab

4. Click OK to return to the worksheet.
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For information about setting the primary mouse button to display the Linked 
Objects Browser dialog box when you double-click a data cell, see the Essbase 
XTD Spreadsheet Add-in online help. 

Preparing to Begin the Tutorial
Before you begin the basic tutorial, read the following important topics:

● “Setting Essbase Options” on page 41

● “Following Guidelines During the Tutorial” on page 45

● “Reviewing the Sample Basic Database” on page 46

Setting Essbase Options
Before you begin the tutorial steps, make sure that the worksheet options are set to 
the initial settings as illustrated in Figure 8 through Figure 11. If the option settings 
are different, the illustrations presented in this chapter may not match the 
worksheet view.

Note: For information about each option in the Essbase Options dialog box, see the 
Essbase XTD Spreadsheet Add-in online help.

1. Select Essbase > Options.

2. In the Essbase Options dialog box, select the Display tab.
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3. Select the appropriate check boxes and option buttons so that your display of 
the Display tab matches the illustration shown in Figure 8.

Figure 8: Initial Settings for Display Options

4. Select the Zoom tab.



Preparing to Begin the Tutorial

2

■ 43Essbase XTD Spreadsheet Add-in for Excel

5. Select the appropriate check boxes and option buttons so that your display of 
the Zoom tab matches the illustration shown in Figure 9:

Figure 9: Initial Settings for Zoom Options

6. Select the Mode tab.
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7. Select the appropriate check boxes and option buttons so that your display of 
the Mode tab matches the illustration shown in Figure 10.

Figure 10: Initial Settings for Mode Options

Note: If you are already connected to an Analytic Services database, the Essbase 
Options dialog box also displays a Style tab. You can skip this tab for now.

8. Select the Global tab.
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9. Select the appropriate check boxes and option buttons so that your display of 
the Global tab matches the illustration shown in Figure 11.

Figure 11: Initial Settings for Global Options

Note: You should have already selected the appropriate boxes for Mouse Actions, 
as described in “Enabling Mouse Actions” on page 39.

10. Click OK to save the settings for this session and close the Essbase Options 
dialog box.

Following Guidelines During the Tutorial
Keep in mind the following guidelines during this tutorial:

● Optional tasks that should not be performed as part of the tutorial are 
displayed in light-shaded boxes. These tasks are included only for your future 
reference. You can find more information on these tasks in the Essbase XTD 
Spreadsheet Add-in online help.

● You must be connected to the Sample Basic database during the tutorial. If you 
are not connected to this database, the illustrations presented in this chapter 
will not match the worksheet view.
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● You can access many Essbase commands in any one of these ways:

– By selecting the command from the Essbase menu 

– By clicking the appropriate button on the Essbase toolbar

– For the Zoom In and Zoom Out commands, by double-clicking either the 
primary mouse or the secondary mouse button

● You must set the options in the Essbase Options dialog box as described in 
“Setting Essbase Options” on page 41. If the option settings are different, the 
illustrations presented in this chapter may not match the worksheet view.

● After you change a worksheet option in the Essbase Options dialog box, you 
must perform a retrieval or a drill-down operation to have the new setting take 
effect.

● Be sure to follow each step in the tutorial. Each tutorial task builds upon the 
previous task. Do not skip the final steps at the end of sections, because these 
steps are often necessary to prepare you for the next tutorial task.

● If you make a mistake during the tutorial, you can select Essbase > FlashBack 
to return to the previous worksheet view. 

● The values in the Sample Basic database that represent ratios or percentages 
are calculated to a very high level of precision (for example, 55.26162826). 
You can apply a cell format to control the number of decimal places that are 
displayed in data values. For details on applying cell formats, see the Excel 
documentation.

● The numeric values that are shown in the illustrations used throughout this 
tutorial may not match the values stored in your database. The values shown 
in these illustrations reflect a freshly loaded database.

● Some worksheet columns have been adjusted for clarity in the illustrations. 
You do not need to change the width of columns in the worksheet to follow the 
tutorial steps. The Adjust Columns option in the Display tab of the Essbase 
Options dialog box adjusts columns for you. 

Reviewing the Sample Basic Database
The Sample Basic database that you use for the tutorial is based on a hypothetical 
company in the beverage industry. The major products of the company are various 
kinds of sodas. These products are sold in U.S. markets, which are categorized by 
state and region. Financial data for the company is collected monthly and is 
summarized by quarter and by year. The company uses Analytic Services to 
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calculate financial and accounting data, such as sales, cost of goods sold, and 
payroll. The company tracks both actual and budget data, as well as the variance 
and percent variance between the two.

Retrieving Data
Now that you are more familiar with the Analytic Services environment, you can 
connect to an instance of Analytic Server and start using Analytic Services and 
Essbase XTD Spreadsheet Add-in. The following section guides you through a 
typical Analytic Services session where you connect to a database and retrieve data 
in various ways.

This topic outlines the following basic retrieval tasks:

● “Connecting to a Database” on page 48

● “Changing a Password” on page 50

● “Retrieving Data from a Database” on page 50

● “Canceling a Data Retrieval Request” on page 52

● “Restoring the Previous Database View” on page 52

● “Drilling Down to More Detail” on page 53

● “Drilling Up to Less Detail” on page 57

● “Customizing Drill-Down and Drill-Up Behavior” on page 58

Make sure that you followed the steps in “Setting Essbase Options” on page 41. If 
the settings in the Essbase Options dialog box are different from the settings 
previously illustrated, the worksheet view will differ from the illustrations shown 
in this chapter.

Remember that you can perform common data retrieval tasks in any of the 
following ways:

● Select commands from the Essbase menu on the Excel menu bar

● Double-click the primary or the secondary mouse button in the appropriate 
cell (for Retrieve, Zoom In, and Zoom Out commands)

● In Excel, click the appropriate buttons on the Essbase toolbar
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Connecting to a Database
To access Analytic Services data, you must first connect to a database on an 
instance of Analytic Server. This tutorial assumes that you have the appropriate 
privileges to connect to a server, an application, and a database.

To complete the steps that follow, you need to know the name of the server to 
which you want to connect, your username, and your password. If you do not have 
this information, contact the Analytic Services system administrator.

Note: Analytic Services does not support multiple instances of Excel.

1. Select Essbase > Connect.

The Essbase System Login dialog box is displayed, as shown in Figure 12.

Figure 12: Essbase System Login Dialog Box

2. From the Server list box, select the server that you want to access. 

If the server name that you want is not displayed in the list, you can type in the 
name of the server that you want to access.

3. Press Tab to move to the Username text box; type your username in the 
text box. 

4. Press Tab to move to the Password text box; type your password in the 
text box.

Note: You can change your password when you are connected to a server. 
To change your password, see “Changing a Password” on page 50.
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5.  Click OK to connect to the server.

A list of available application/database pairs is displayed in the 
Application/Database list box. Figure 13 shows an example of a list of 
application/database pairs. A single instance of Analytic Server enables 
simultaneous access to multiple applications. An application can contain 
multiple databases. Only the databases to which you have security access are 
shown in the list.

For this tutorial, you use the Sample Basic database. If the Sample Basic 
database was installed as part of the Analytic Services installation, it is shown 
in the list. If Sample Basic is not shown in the Application/Database list box, 
ask the Analytic Services system administrator to install it.

Figure 13: Available Application and Database Pairs

6. In the Application/Database list box, double-click Sample Basic. You can 
also select Sample Basic from the list box and click OK.

If the application is not already running, Analytic Services automatically starts it. 
There may be a brief pause as the application loads. The time required to start an 
application depends on the number of databases, the sizes of the databases, and the 
sizes of the indexes of the databases contained within the application.
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Changing a Password
You can change your password only if you are connected to a server.

Retrieving Data from a Database
Each time you retrieve information from an instance of Analytic Server, the 
following actions occur: 

● Spreadsheet Add-in requests data from the server.

● The server processes the request and prepares the data.

● The server transmits the data to Spreadsheet Add-in.

● The spreadsheet application receives the data from Analytic Services and 
organizes it in a worksheet.

This task is optional. Optional tasks do not need to be performed as part of the 
tutorial. They are provided for information only.

To change your password:

1. In the Essbase System Login dialog box, select the Change Password button.

2. In the Change Password dialog box in the New Password text box, type your 
new password. 

3. In the Confirm Password text box, type the password again.

The passwords must be identical.

4. Click OK to change your password.

5. Click OK again to close the Essbase System Login dialog box.
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To help you monitor these operations, Analytic Services uses three custom cursors, 
as described in Table 2. 

Note: Small retrieval actions display the cursors very quickly; you may not notice 
changes in the direction of the arrow when retrieving small amounts of data.

➤ To retrieve data into an empty worksheet: 

1. Select File > New or click  to open a new worksheet.

Note: You should be connected to the Sample Basic database. If you are not 
connected, follow the steps in “Connecting to a Database” on page 48.

2. Select Essbase > Retrieve.

Analytic Services retrieves data into the worksheet. 

Figure 14: Initial Data Retrieval from Sample Basic 

Because you selected the Enable Double-Clicking box in the Essbase Options 
dialog box (Global tab) in step 9 on page 45, you can double-click in an empty 
cell to retrieve data. You can also click the Retrieve button on the Essbase 
toolbar.

Table 2: Essbase Custom Cursor 

Cursor When Displayed

Spreadsheet Add-in requests information from Analytic Server.

The server is processing the request.

The server returns the data.
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When you retrieve data into an empty worksheet, Analytic Services returns data 
from the top levels of each database dimension. The top level is used as a starting 
point to navigate, or drill down, into levels of detailed data. In the Sample Basic 
database, the following five dimensions are retrieved: Measures, Product, Market, 
Scenario, and Year.

Tip: You can retrieve data by double-clicking in a data cell, selecting Essbase > 
Retrieve, or by clicking the Retrieve button on the Essbase toolbar.

Canceling a Data Retrieval Request
Occasionally, you may want to cancel a retrieval request. For instance, you may 
want to stop a request if a retrieval is taking longer than expected or if you 
mistakenly double-click.

Because Analytic Services returns data so quickly to the worksheet, you may not 
be able to cancel a retrieval before the retrieval is complete. The cancel feature is 
most useful when you need to stop a large retrieval request.

To cancel data retrievals, press the Esc key during a retrieval action.

Note: You can cancel a retrieval only while Analytic Services is processing in 
Spreadsheet Add-in. You cannot cancel a retrieval when Analytic Services is 
processing from Analytic Server.

Restoring the Previous Database View
The FlashBack command restores the previous database view. A database view is 
what you see in the worksheet after a retrieval or navigation operation. FlashBack 
is similar to the Edit > Undo command, which reverses the last action, with the 
following difference. If you modify member information between retrieves and 
then perform a FlashBack, Essbase still flashes back to the spreadsheet data as it 
was prior to the last retrieve, in spite of any changes you may have made to 
members between retrieves. The FlashBack command uses the memory of your 
computer to store the current view before processing an Analytic Services retrieval 
request. You can use FlashBack to undo only the most recent operation. FlashBack 
cannot undo multiple operations.

Throughout this tutorial, you should follow all steps in the order that they are 
presented. If you make a mistake or find yourself out of step with the tutorial, you 
can use the FlashBack command from the Essbase menu or toolbar to undo the last 
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command and return to the previous database view. If you want to start the tutorial 
over from the beginning, select the entire worksheet and select Edit > Clear > All. 
Then press Enter or click OK to empty the worksheet and start again.

You can disable FlashBack during normal operations to conserve memory on your 
local machine. Do not disable FlashBack for this tutorial.

Drilling Down to More Detail
You can drill down to various levels of multidimensional data in the worksheet. 
For example, if you want to view data for a specific quarter or month rather than 
an aggregate data value for the whole year, you can drill down on the Year 
dimension to see more detailed data.

You have three options for drilling down on a member: 

● Select the member and select Essbase > Zoom In.

● Select the member and double-click the primary mouse button.

● Select the member and click the Zoom In button on the Essbase toolbar.

This task is optional. Optional tasks do not need to be performed as part of the 
tutorial. They are provided for information only.

To disable Flashback:

1. Select Essbase > Options and click the Global tab.

2. Clear the Enable FlashBack check box.
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➤ To drill down to lower levels of the Year dimension:

1. On Year in cell A2, double-click the primary mouse button. 

The drill-down action retrieves data for the level below (the children of) Year: 
Qtr1, Qtr2, Qtr3, and Qtr4, as shown in Figure 15.

Figure 15: Result of Drilling Down on the Year Dimension

Note: For a discussion of the relationships among Analytic Services database 
members, see “Database Outlines” on page 26.

With Analytic Services, you can retrieve members into columns or rows that 
are grouped or nested. Row groups containing more than one level of data are 
nested within single-member row groups. For example, a row group 
containing Qtr1, Qtr2, Qtr3, and Qtr4 may be nested within a single-member 
row for a specific region, such as East (see Figure 16). Drilling down to lower 
levels of database members is one way to retrieve data into nested groups.

2. In cell D1, double-click to drill down on Market and create nested groups of 
rows down the worksheet.

Figure 16: Result of Drilling Down on the Market Dimension (Nested Rows)

Because worksheets can accommodate more rows than columns, Analytic 
Services is preset to retrieve data into rows when you drill down on a member. You 
can change this default behavior and display the results of a drill-down across 
columns. Drilling across columns applies only to the top-level member of a 
dimension (for example, Market or Scenario).
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➤ To drill down on Scenario and retrieve its respective members into columns rather 
than rows:

1. Press and hold down the Alt key.

2. Double-click Scenario (in cell E1).

3. Release the Alt key.

Analytic Services displays the data in columns across the worksheet, as shown 
in Figure 17. 

Figure 17: Result of Drilling-Down on the Scenario Dimension 
(Nested Columns)

4. Keep this worksheet open, but do not save it yet.

You use this worksheet again in “Drilling Up to Less Detail” on page 57.

You will open a new worksheet to complete the steps in “Drilling Down on 
Attribute Members” on page 55 and “About Drilling Down on Level 0 
Attribute Members” on page 56.

Drilling Down on Attribute Members
You can use the Analytic Services attribute feature to retrieve and analyze in terms 
of characteristics, or attributes, of dimensions. For example, you can analyze 
product profitability based on the attributes of size or packaging. Attribute 
dimensions are associated with base dimensions. 

You can use an attribute dimension to drill down on the base dimension with which 
it is associated. In the Sample Basic database, the Product base dimension is 
associated with several attribute dimensions, such as Caffeinated, Ounces, and 
Pkg_Type. Each attribute dimension consists of level 0 attribute members. Level 
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0 attribute members are the lowest level attributes that are associated with 
members of a base dimension. The Pkg_Type attribute dimension, for instance, has 
two level 0 members, Bottle and Can. 

You can extract information on all products sold in a can by entering manually 
the name Can in the worksheet. You can also use Essbase Query Designer or the 
Essbase Member Selection dialog box to select the attribute and display it in the 
worksheet.

➤ To drill down on an attribute dimension:

1. Open a worksheet.

2. Connect to the Sample Basic database. 

3. Select Essbase > Retrieve. 

4. Select Product and replace it with Can by typing Can manually. 

5. Click anywhere outside of cell C1 and select Essbase > Retrieve again. 

Figure 18 displays the results:

Figure 18: An Attribute Member in a Report

6. Drill down to all products sold in a can by double-clicking Can in cell C1.

Cola, Diet Cola, and Diet Cream are the members of Product that have the Can 
attribute. Figure 19 displays the results:

Figure 19: Result of Drilling Down on an Attribute Member

About Drilling Down on Level 0 Attribute Members

The following description is of the general behavior of Spreadsheet Add-in when 
you drill down on a level 0 attribute member:

● If the level 0 attribute member is in a column, a drill-down pivots the attribute 
to the innermost row of the worksheet.
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● If the level 0 attribute member is in a row, a drill-down does not change the 
position of the attribute in the worksheet.

● A drill-down on a level 0 attribute member displays the associated base 
members to the right of the level 0 attribute.

● If there is more than one level 0 attribute member in a worksheet, a drill-down 
on one attribute displays other attributes to the left of the level 0 attribute 
member. Level 0 attribute members in columns pivot to rows, and level 0 
attribute members already in rows remain in rows.

● A drill-down on non-level 0 attribute members is the same as the current drill- 
down behavior for other types of members.

The drill-down behavior for non-level 0 attribute members is the same as the 
current drill-down behavior for other types of members. See the Spreadsheet 
Add-in online help for examples of drilling down on level 0 attribute members. For 
more information on attributes, refer to the Essbase XTD Analytic Services 
Database Administrator’s Guide.

Drilling Up to Less Detail
With Analytic Services, you can drill up to higher levels in the multidimensional 
database outline by collapsing the current member tree. For example, if you 
previously drilled down on a dimension, such as Scenario, to view data for Actual 
and Budget, you may need to drill up to view aggregate data for the Scenario 
dimension.

Three options are available for drilling up on a member:

● Select the member and select Essbase > Zoom Out.

● Select the member and double-click the secondary mouse button.

● Select the member and click the Zoom Out button on the Essbase toolbar.

➤ To drill up on the Scenario dimension in the current worksheet: 

1. Return to the worksheet that you kept open in step 4 on page 55

2. On any member of the Scenario dimension (that is, cell C2, D2, E2, F2, or 
G2), double-click the secondary mouse button. 
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Analytic Services collapses the members of the Scenario dimension. The 
result is shown in Figure 20:

Figure 20: Result of Drilling Up on the Scenario Dimension

3. In cell A3, double-click the secondary mouse button to drill up on East. 

Analytic Services collapses East, West, South, and Central into the single 
Market dimension and keeps the dimension in the A column, as shown in 
Figure 21.

Figure 21: Result of Drilling Up on East

Customizing Drill-Down and Drill-Up Behavior
You can customize the behavior of the Zoom In and Zoom Out commands in the 
Essbase Options dialog box. The following steps illustrate some drill-down and 
drill-up techniques. 
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➤ To retrieve all members of a dimension with a single drill-down operation:

1. Select Essbase > Options and select the Zoom tab.

Analytic Services displays the Zoom Tab. A portion of the Zoom tab is shown 
in Figure 22.

Figure 22: Zoom In and Member Retention Option Settings

The Zoom In option group contains items that enable you to customize drilling 
behavior. You can specify which members are returned to the worksheet 
during a drill-down operation. For example, if you select Bottom Level, 
Analytic Services retrieves data for the lowest level of members in a 
dimension. With this option, a drill-down on Year retrieves Jan, Feb, Mar, Apr, 
May, Jun, Jul, Aug, Sep, Oct, Nov, and Dec. 

The Member Retention option group contains items that enable you to 
customize drilling retention characteristics. The default selection, Include 
Selection, retains the selected member along with the other members retrieved 
as a result of a drill down. For example, if you drill down on Qtr1, Analytic 
Services retrieves data for Jan, Feb, and Mar, as well as for Qtr1. When this 
option is disabled, Analytic Services retrieves data only for Jan, Feb, and Mar; 
Qtr1 is eliminated.

For more information on the Zoom In and Member Retention option groups, 
see the Spreadsheet Add-in online help.

2. In the Zoom In option group, select the All Levels option and click OK to 
save the setting.

3. In cell A3, drill down (double-click) on Market.

4. In cell C2, drill down (double-click) on Scenario.
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Analytic Services retrieves all members of Market and Scenario, as shown in 
Figure 23. For the Market dimension, Analytic Services drilled down two 
levels to get to the bottom-most members, which are individual states. The 
Scenario dimension contains only one member level, so the members of 
Scenario would also be retrieved if you selected Next Level in the Zoom In 
option group.

Figure 23: Result of Drilling Down to All Member Levels

5. Select Essbase > Options and select the Zoom tab.

6. Return the Zoom In option setting to Next Level.

If you want to drill up on only one quarter of the year, select Within Selected Group 
in the Member Retention option group. 

➤ To drill up only on Qtr1:

1. In the Member Retention option group on the Zoom tab, click the Within 
Selected Group check box and click OK.

Make sure that Include Selection is also still checked. 

2. Double-click the secondary mouse button to drill up on Qtr1 in cell B3.
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Figure 24 shows that drilling up to the Year dimension affects only New York. 
All other states show data for all four quarters.

Figure 24: Result of Drilling Up Within a Selected Group

3. Before moving on with the tutorial, disable the Within Selected Group 
option:

a. Select Essbase > Options and select the Zoom tab.

b. In the Member Retention option group, clear the Within Selected 
Group check box, and click OK.

4. Select File > Close to close the worksheet. 

You do not need to save the worksheet.

Pivoting, Retaining, and Suppressing Data
After you retrieve data into the worksheet, you may want to manipulate the data in 
various ways. For example, you may want to move rows and columns to different 
positions in the worksheet, or you may want to tell Analytic Services to suppress 
or to retain specific data during data retrievals. 

To help you manipulate worksheet data, this section steps you through the 
following procedures:

● “Pivoting Rows and Columns” on page 62

● “Retaining a Data Subset” on page 66

● “Removing a Data Subset” on page 68

● “Navigating Through the Worksheet Without Retrieving Data” on page 69

● “Suppressing Missing Values, Zero Values, and Underscore Characters” on 
page 73
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Pivoting Rows and Columns
With the Pivot command, you can change the orientation of worksheet data. Use 
the Pivot command to perform any of the following tasks:        

● Move a row group to a column group

● Move a column group to a row group

● Change the order of row groups

● Change the order of column groups

You can execute the Pivot command in two ways:

● Select the member cell that you want to pivot, and select Essbase > Pivot. This 
method applies only to moving a row group to a column group or a column 
group to a row group.

● Click in the center of the member cell that you want to pivot, press and hold 
down the secondary mouse button, and drag the group to the desired location. 
This method applies to swapping row and column groups and to changing the 
order within groups.

➤ To pivot Year data from a row group to a column group:

1. Select File > New or click  to open a new worksheet.

Note: You should already be connected to the Sample Basic database. If you are 
not connected, follow the steps in “Connecting to a Database” on page 48.

2. Select Essbase > Retrieve.

3. Drill down (double-click) on Measures and Product (in cells B1 and C1, 
respectively).
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4. Press and hold down the Alt key, and, in cell E1, drill down (double-click) on 
Scenario.

Figure 25 shows the spreadsheet view before pivoting.

Figure 25: View Before Pivoting

5. In cell C3, select Year and select Essbase > Pivot.

Analytic Services pivots the Year dimension to a column group next to Market 
(above the Scenario members), as shown in Figure 26.

Figure 26: Result of Pivoting a Row Group to a Column Group

6. As another example, in cell C2, select Actual.

7. Right click and drag Actual to product 100 in cell A3.
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As Figure 27 shows, the member label box is displayed under the cursor 
during the pivot operation, and it displays the names of the members that you 
are pivoting. The orientation of the member label box, however, does not 
determine the orientation of the pivot result. Analytic Services determines the 
data orientation by the location of the destination cell.

Figure 27: Pivoting a Column Group to a Row Group

Figure 28 shows the result of Analytic Services pivoting the Scenario 
members (Actual, Budget, Variance, and Variance%) from a column group to 
a row group that is displayed to the left of the Product members. 

Figure 28: Result of Pivoting a Column Group to a Row Group
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➤ To transpose the order of row groups:

1. In cell A2, select Actual.

2. Right-click and drag Actual to Profit in cell C2.

Figure 29 shows the spreadsheet before the pivot operation.

Figure 29: Pivoting the Order of Row Groups

The pivot changes the order of the row groups. The result is shown in 
Figure 30

Figure 30: Result of Pivoting the Order of Row Groups

In this example, notice that both the source cell and the destination cell 
are now members. Whenever the source cell and the destination cell are 
members of different row groups, Analytic Services exchanges the member 
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groups. You must select a destination cell that contains a member name to 
exchange row members. You can also exchange column members by choosing 
a destination cell in another column that contains a member name. 

Retaining a Data Subset
The Keep Only command retains only selected member rows or columns and 
removes all other data from the worksheet view. This command provides a 
powerful way to remove dimensional slices without having to delete individual 
cells.

➤ To keep only Actual and Budget data in the current worksheet:

1. In cell C2, select Actual, and in cell C3, select Budget, as shown in Figure 31. 

Figure 31: Selecting Members for the Keep Only Command

2. Select Essbase > Keep Only. 
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Analytic Services removes the Variance, Variance%, and Scenario rows from 
the worksheet and retains only Actual and Budget data, as shown in Figure 32.

Figure 32: Result of Retaining a Data Subset (Adjacent Cells)

Occasionally, the data that you want to remove from the worksheet does not lie in 
an adjacent range of cells. 

➤ To select and retain nonadjacent cells:

1. Press and hold down the Alt key, and, in cell D1, zoom in (double-click) on 
Year.

2. Select Qtr2 in cell E2.

3. Press and hold down the Ctrl key and select Qtr4 in cell G2 (see Figure 33).

Figure 33: Selecting Nonadjacent Members for the Keep Only Command
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4. Select Essbase > Keep Only. 

Analytic Services retains only Qtr2 and Qtr4 data and deletes the other Year 
members, as shown in Figure 34.

Figure 34: Result of Retaining a Data Subset (Nonadjacent Cells)

Removing a Data Subset
The Remove Only command is the counterpart to the Keep Only command. With 
Remove Only, you can remove selected member rows or columns and retain all 
other data in the worksheet view.

➤ To remove a data subset from the current worksheet view:

1. In cell B7, select Ratios.

2. Press and hold Ctrl, and, in cell B9, select Measures.

3. Select Essbase > Remove Only.
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Analytic Services removes data for Ratios and Measures but retains data for 
Profit and Inventory. The result is shown in Figure 35.

Figure 35: Result of Removing a Data Subset

Navigating Through the Worksheet Without Retrieving 
Data

With the Navigate Without Data feature, you can perform navigational operations, 
such as pivot, zoom in, zoom out, keep only, and remove only, without retrieving 
any data into the worksheet.         

This feature is especially useful when dealing with dynamic calculation members, 
which are usually specified by the application designer. By activating Navigate 
Without Data, you are effectively telling Analytic Services not to calculate values 
dynamically (that is, calculate the database at retrieval time) while you are creating 
the spreadsheet report. Dynamic calculation is discussed in more detail in 
“Retrieving Dynamic Calculation Members” on page 160.

➤ To navigate through the worksheet without retrieving data:

1. Select Essbase > Navigate Without Data.

Analytic Services displays a check mark next to the menu item.

You can also disable Navigate Without Data by clearing the appropriate option 
in the Global tab of the Essbase Options dialog box or by clicking the Navigate 
Without Data button on the Essbase toolbar.

2. In cell D2, double-click the secondary mouse button to drill up on Qtr2. 
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Analytic Services shows the collapsed Year dimension but withholds 
retrieving any data that is changed as a result of drilling up. The cells where 
data would usually be displayed are blank. The result is shown in Figure 36.

Figure 36: Result of Zooming Out (Navigate Without Data Enabled)

3. In cell D2, drill down (double-click) on Year by pressing and holding down 
the Alt key.

Analytic Services drills down without retrieving data.

4. In cell C3, select Actual and select Essbase > Pivot. 

Analytic Services executes the pivot but does not retrieve data. The result is 
shown in Figure 37. 

Note: You get the same result by pivoting any of the other Scenario members.

Figure 37: Result of Pivoting (Navigate Without Data Enabled)

5. In cell G1, click the secondary mouse button on Market and drag Market to 
product 100 (cell A4).
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Analytic Services executes the pivot without retrieving data. The result is 
shown in Figure 38.

Figure 38: Result of Pivoting (Navigate Without Data Enabled)

Navigating without data also works with the Keep Only and Remove Only 
commands.

➤ To navigate without data when using the Keep Only or Remove Only command:

1. Select Qtr1 (cell D2) and Qtr2 (cell E2) and select Essbase > Keep Only.

Analytic Services retains only the selected members and does not retrieve 
data, as shown in Figure 39.

Figure 39: Result of Keep Only (Navigate Without Data Enabled)

2. Select products 300 (cell B7), 400 (cell B9), and Diet (cell B11) and select 
Essbase > Remove Only.
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Analytic Services executes the Remove Only command without actually 
querying the database for information, as shown in Figure 40.

Figure 40: Result of Remove Only (Navigate Without Data Enabled)

➤ To turn off Navigate Without Data when you are ready to retrieve data:

1. Select Essbase > Navigate Without Data.

Analytic Services removes the check mark next to the menu item.

You can also disable Navigate Without Data by clearing the appropriate option 
in the Essbase Options dialog box (Global tab) or by clicking the Navigate 
Without Data button on the Essbase toolbar.

2. In cell A3, drill down (double-click) on Market.

Analytic Services drills down on the Market dimension and also retrieves data 
into the worksheet. The result is shown in Figure 41.

Figure 41: Result of Drilling down (Navigate Without Data Disabled)

Note that if you want to retrieve data without changing the current worksheet 
view, you can also retrieve data by simply double-clicking in any data cell or 
by selecting Essbase > Retrieve (after disabling Navigate Without Data).
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Suppressing Missing Values, Zero Values, and 
Underscore Characters

Several types of data can be returned to a worksheet view:

● Numeric data values

● #NoAccess strings, which are displayed when you do not have the proper 
security access to view a data value

● #Missing strings, which indicate that no data exists for that member 
intersection

● Zero data values

A missing value is not the same as a zero value that is loaded into the Analytic 
Services database. When data does not exist for a data cell in Analytic Services, a 
value of #Missing is returned to the worksheet. If any cell in a row contains a 
value, that row is not suppressed on a retrieval. 

Using Analytic Services, you can suppress missing and zero values from the 
display in the worksheet. In addition, you can tell Analytic Services to suppress 
underscore characters that are in some member names. 

➤ To suppress rows that contain missing values from being displayed in the 
worksheet:

1. In cell C3, double-click the secondary mouse button to drill up on Profit. 

2. Pivot Measures (in cell C3) to Actual (in cell D1).

3. In cell B4, drill down (double-click) on product 100.
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In the South member group, the product 100-30 row contains all missing 
values, indicating that this product is not sold in the South, as shown in 
Figure 42. You may need to scroll down the worksheet to see this row.

Figure 42: Worksheet View Displaying Missing Data Values

4. Select Essbase > Options, and select the Display tab.

5. In the Suppress option group, select the #Missing Rows check box and 
click OK.

The Suppress #Missing Rows and Zero Rows options are not available when 
any of the Formula Preservation options are selected in the Mode tab of the 
Essbase Options dialog box. 

For more information on Formula Preservation, see “Preserving Formulas 
When Retrieving Data” on page 149.

6. Select Essbase > Retrieve to update the worksheet. 

Note: After you change a worksheet option in the Essbase Options dialog box, you 
must perform a retrieval or drill operation to put the new setting into effect.
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Analytic Services suppresses product 100-30 from the South member group, 
as shown in Figure 43.

Figure 43: Result of Suppressing Missing Data Values

7. Select File > Close to close the worksheet. 

You do not need to save the worksheet.

After you enable the Suppress #Missing Rows feature in the Essbase Options 
dialog box, any missing values suppressed during a data retrieval are not retrieved 
again by disabling the feature. If you disable the feature in the Essbase Options 
dialog box, missing values are retrieved from only that point on. For example, in 
this tutorial task, Analytic Services could not go back and return the missing values 
for product 100-30. To return these missing values to the worksheet, you disable 
the Suppress #Missing Rows feature, drill up on a Product member, and then drill 
down again.

You can also suppress zeros and underscore characters as described in this tutorial 
task by clicking the appropriate options in the Suppress option group in the 
Essbase Options dialog box (Display tab).

In addition to suppressing specific values and characters during retrieval, Analytic 
Services enables you to define a label for missing values (#Missing) or for data to 
which you do not have access (#NoAccess). If you define a replacement label for 
these values, Analytic Services displays the replacement labels instead of the 
default labels. For more information on defining replacement labels for the 
#Missing and #NoAccess labels, see the Spreadsheet Add-in online help. 
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Formatting the Worksheet
Analytic Services provides you with various ways to customize the worksheet 
view. For example, you may want to apply visual cues, or styles, to certain member 
names or to data cells in the worksheet. You may want to display alternative 
names, or aliases, for member names. This topic steps you through the following 
formatting procedures:

● “Formatting Text and Cells” on page 76

● “Displaying Aliases for Member Names” on page 85

● “Displaying Both Member Names and Aliases” on page 87

● “Repeating Member Labels” on page 88

This section of the tutorial starts with a new worksheet.

Formatting Text and Cells
In a spreadsheet report, many hierarchical levels of database information are 
displayed. By defining and applying visual cues, or styles, to the text and cells in 
the worksheet, you can easily keep track of specific database members, 
dimensions, and cell functions. Styles are an effective way of viewing and 
distinguishing data in Spreadsheet Add-in.

Keep in mind that applying styles requires additional processing during a retrieval 
request. If you need to remove styles, see “Removing Styles” on page 84.

This portion of the tutorial describes the following tasks:

● “Applying Styles to Parent Members” on page 77

● “Applying Styles to Dimension Members” on page 80

● “Applying Styles to Data Cells” on page 82

● “Precedence of Overlapping Styles” on page 83

● “Removing Styles” on page 84 

For a discussion of the relationships among Analytic Services database members, 
see “Database Outlines” on page 26.
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Applying Styles to Parent Members
Each dimension in a database may contain a large number of hierarchical levels. 
As you view data in the worksheet, you may not be familiar with all the 
hierarchical levels of the database outline. To indicate which members have 
underlying children, you can apply formatting styles to parent members, including 
those with attributes.

➤ To apply styles to parent members:

1. Select File > New or click  to open a new worksheet.

2. Select Essbase > Retrieve.

Note: You should still be connected to the Sample Basic database. If you are not 
connected, follow the steps in “Connecting to a Database” on page 48.

3. In cell A2, drill down (double-click) on Year.

4. Select Essbase > Options. 

5. In the Essbase Options dialog box, select the Style tab.

The Style tab is available only when you are connected to a database.
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Analytic Services displays the Style tab, as shown in Figure 44.

Figure 44: Essbase Options Dialog Box, Style Tab

In the Members group box, you can define styles for various types of database 
members, such as parent, child, and shared members.

6. In the Members group box, select the Parent check box. 

Clicking this box defines a font and color style for parent member names. 
Analytic Services defines a default color of navy for all parent members. You 
can select a font format by clicking the Format button to the right of the 
Members group box and using the Font dialog box. 

7. Click the Format button that is to the right of the Members group box.

Analytic Services displays the Font dialog box.

8. In the Font style list box, select Bold Italic and then click OK.
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Analytic Services displays an example of the selected style in the Sample box, 
as shown in Figure 45.

Figure 45: Font Dialog Box

9. Click OK again.

Even though you have defined styles, they are not enabled until you select the 
Use Styles check box from the Essbase Options dialog box and refresh the 
worksheet.

10. Select Essbase > Options, and select the Display tab.

11. In the Cells option group, select the Use Styles check box to enable the styles, 
and then click OK.

12. Select Essbase > Retrieve to refresh the worksheet and apply the styles.

Analytic Services displays parent member names in bold, navy font.

13. In cell A2, drill down (double-click) on Qtr1. 
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Analytic Services displays Jan, Feb, and Mar in a regular font, because these 
members do not have underlying children.

Figure 46: Styles Applied to Parent Members

Applying Styles to Dimension Members
In addition to applying styles to parent members, as you did in the previous 
exercise, you can also apply styles to members of a dimension in a database. 
Applying styles to dimensions makes it easy to view the various dimension 
members in Spreadsheet Add-in. 

➤ To apply styles to dimensions:

1. Select Essbase > Options and select the Style tab.

2. In the Dimensions group box, select the Year check box.

3. Select the Cell Border check box to create a border around each cell that 
contains a member from the selected dimension.
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4. From the Background Color drop-down list, select Yellow.

Figure 47: Selecting a Background Color from the Style Tab

5. Click the Format button that is to the right of the Dimensions group box.

Analytic Services displays the Font dialog box.

6. From the Font style list box, select Bold, and then click OK.

Analytic Services displays an example of the selected style in the Sample box.

7. From the list of dimensions, select the Measures dimension, and from the 
Background Color drop-down list, select Fuschia.

8. From the list of dimensions, select Product, and clear the Cell Border check 
box.

9. From the Background Color drop-down list, select Aqua.

10. Scroll down the list of dimensions, and select Market.

11. Select the Cell Border check box, and click the Format button that is to the 
right of the Dimensions list.

12. When the Font dialog box is displayed, from the Font style list box select 
Italic, and then click OK.
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13. From the list of dimensions, select Scenario, and from the Background 
Color drop-down list, select Red.

14. Click the Format button, and from the Background Color list box, select 
White.

15. Click OK twice to return to the worksheet. 

Note: When you define styles, your choices are saved to the Windows Registry on 
your local computer. You can define one set of styles per database.

16. In cell D1, drill down (double-click) on Market.

17. Press and hold down the Alt key and drill down (double-click) on Scenario 
in cell E1.

18. Select Essbase > Retrieve to refresh the worksheet.

Analytic Services redisplays the worksheet and implements the newly defined 
styles. For example, members of the Scenario dimension are displayed with a 
red background.

Figure 48: Dimensions with Styles Applied

Applying Styles to Data Cells
You can apply styles to data cells, such as read-only cells, read/write cells, linked 
object cells, and Essbase XTD Integration Server drill-through cells to distinguish 
them from other cells in the worksheet. The Sample Basic database that you are 
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using for this tutorial does not contain data cells with any of these characteristics. 
In the advanced tutorial presented in Chapter 3, you attach a linked reporting 
object to a data cell and apply a style to the cell.

Precedence of Overlapping Styles
Analytic Services uses the following order of precedence when applying multiple 
text styles:

● Linked object cells

● Integration Server Drill-Through cells

● Read-only cells

This task is optional. Optional tasks do not need to be performed as part of the 
tutorial. They are provided for information only.

In general, to apply styles to data cells, follow these steps:

1. Select Essbase > Options, and select the Style tab.

2. In the Data Cells option group, select the Linked Objects, Integration Server 
Drill-Through, Read Only, or Read/Write check box.

3. Click Format. 

4. In the Font dialog box, specify the font, font size, font style, color, and effects, 
and click OK.

Essbase displays an example of the selected style in the Sample box.

5. Repeat step 2 through step 4 to set styles for other data cells.

6. Select the Display tab and select the Use Styles check box to apply styles to the 
worksheet.

7. Click OK to close the Essbase Options dialog box.

8. Select Essbase > Retrieve to display the new styles in the worksheet.
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● Read/write cells

● Parent member cells

● Child member cells

● Shared member cells

● Cells containing formulas

● Dynamic calculation member cells

● Attribute cells

● Dimension cells

The only way you can apply a background color to data is to define a style for 
dimensions. If dimension styles are defined and the Use Styles setting is turned on, 
a background color is always defined for members of a dimension. 

The text styles that you can apply to members, dimensions, and data cells are 
hierarchical and determine which characteristics are applied. Member styles are at 
the top of the hierarchy. Thus, member styles are always applied if styles are turned 
on. Notice that in Figure 48 on page 82, the Qtr1 label in cell B6 is in bold italic 
navy font, and has a yellow background. The navy font comes from the style 
defined for parent members, and the yellow background comes from the style 
defined for Year. 

If you want to see a child member style, make sure that the parent member style is 
turned off. If you want to see a shared member style, make sure that both parent 
and child member styles are turned off.

Removing Styles
Styles can be very helpful tools for keeping track of data in Spreadsheet Add-in. 
Applying styles, however, involves additional processing time during a retrieval 
request. This additional processing has a slight impact on the speed of Analytic 
Services retrievals.

If you do not want to apply styles to the worksheet view, you can clear them. You 
can also turn off styles so that they are not displayed when you refresh the view 
(by selecting Essbase > Retrieve, for example). So that the worksheet matches the 
illustrations presented in the following tasks, do not remove styles if you are going 
through the tutorial.
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If styles are applied to the worksheet and you execute the FlashBack command, 
these styles are temporarily removed from the current view. The styles are 
reapplied whenever you initiate a retrieval. 

Note: If you turn styles off without clearing them from the worksheet, the styles remain 
in the current worksheet view when you refresh the view. The styles remain to avoid 
removing any styles that you may apply to individual cells using native worksheet 
formatting options. 

Displaying Aliases for Member Names
An alias is alternate name for a database member. You can create reports that use 
the database member name, which is often a stock number or a product code, or an 
alias name, which can be more descriptive. Aliases are defined by the Analytic 
Services application designer. Each database can contain one or more alias tables.

For example, members of Product in the Sample Basic database are defined as 
codes, such as 100 and 200. A descriptive alias for each member of Product, such 
as Colas and Root Beer, is defined in an alias table. In some cases, alias names may 
vary depending on the combination of other database members. For example, a 
Product member may have a different alias for each market in which it is sold. For 
more details about member names and aliases, see the Spreadsheet Add-in online 
help or the Essbase XTD Analytic Services Database Administrator’s Guide.

This task is optional. Optional tasks do not need to be performed as part of the 
tutorial. They are provided for information only.

To remove all styles from a worksheet: 

1. Select all cells in the worksheet.

2. From the Excel menu bar, select Edit > Clear > Formats. 

To turn off styles:

1. Select Essbase > Options and, select the Display tab.

2. In the Cells option group, clear the Use Styles check box, and click OK.
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➤ To display the alias of a member rather than its database name:

1. In cell C2, double-click the secondary mouse button to drill up on Actual.

2. Press and hold down the Alt key and drill down (double-click) on Product in 
cell D1.

3. Select Essbase > Options, and select the Display tab.

4. In the Aliases option group, select the Use Aliases check box to display 
member aliases.

5. Select Default from the Alias drop-down list, as shown in Figure 49.

Figure 49: Enabling Aliases in the Essbase Options Display Tab 

6. Click OK.

7. Select Essbase > Retrieve to refresh the worksheet and display the alias 
names.
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The result is shown in Figure 50. Analytic Services changes the Product codes 
(100, 200, and so forth) to their predefined aliases (Colas, Root Beer, Cream 
Soda, and so forth). In the Sample Basic database, Product is the only 
dimension with predefined aliases.

Figure 50: Result of Displaying Aliases 

Notice that Analytic Services is still displaying the styles that you created and 
applied in the previous sections.

Displaying Both Member Names and Aliases
In addition to displaying aliases for database members, you can also 
configure Analytic Services to display both aliases and database member 
names in Spreadsheet Add-in. 

➤ To display the name and alias of a member:

1. In cell B8, double-click the secondary mouse button to drill up on Qtr2. 

2. In cell C2, select Colas, and then select Essbase > Pivot.

3. In cell C3. select Year, and then select Essbase > Pivot. 

4. Select Essbase > Options, and select the Display tab.

5. In the Aliases option group, select the check box for Use Both Member 
Names and Aliases for Row Dimensions.

Be sure that Use Aliases is already checked.

6. Click OK to return to the worksheet, and select Essbase > Retrieve.
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The result is shown in Figure 51. Analytic Services displays both member 
names and their aliases for row dimensions. Because the only row dimension 
in this example that has preassigned aliases is Product, only the Product 
members display their aliases. Region members simply repeat the member 
name instead of displaying an alias.

Figure 51: Result of Displaying Both Member Names and Aliases

Repeating Member Labels
By default, Analytic Services displays member labels only once for each nested 
row and column group. If you are connected to a large database when using 
Spreadsheet Add-in, you may have to scroll down or across the worksheet to see 
additional data rows and columns.

In some cases, as you scroll down or across, member labels disappear from view. 
Analytic Services provides a feature for repeating member labels in each row or 
column cell that represents a data point, so that you can always see a member label 
in the worksheet view.

➤ To repeat member labels down and across the worksheet:

1. Select Essbase > Options, and select the Display tab.

2. In the Aliases option group, clear the Use Both Member Names and Aliases 
for Row Dimensions check box, as shown in Figure 52.
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3. In the Cells option group, select the Repeat Member Labels check box, and 
then click OK.

Figure 52: Enabling the Repeat Member Labels Option

4. In cell E1, drill down (double-click) on Year. 
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Analytic Services displays a member label in every column and row cell, as 
shown in Figure 53. For the Sample Basic database that you are using for this 
tutorial, repeating member labels is probably not necessary because the 
database is relatively small. This feature is particularly helpful for keeping 
track of member labels when scrolling through large worksheets.

Figure 53: Result of Repeating Member Labels

You may notice that even if you clear the Repeat Member Labels check box 
in the Essbase Options dialog box, Analytic Services retains the repeated 
member labels in the worksheet view. To remove the repeated labels, you need 
to perform one of these tasks: 

● Clear the check box and open a new worksheet

● Clear the check box and pivot the row group to a column group and then 
pivot it back to a row group (or the reverse, from a column group to a row 
group, and back) 

● Select Essbase > FlashBack and clear the check box

5. Before returning to the tutorial, complete the following actions:

a. Select Essbase > Options, and select the Display tab.

b. In the Cells option group, clear the Repeat Member Labels check box, 
and then click OK.

c. Select File > Close to close the worksheet. 

You do not need to save the worksheet.
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Creating Queries Using Essbase Query 
Designer

So far, you have discovered how to retrieve data and navigate through Essbase 
Spreadsheet Add-in in an ad hoc fashion. Analytic Services also provides a query 
designer so that you can define a database query for retrieving dimensions and 
database members into the worksheet. Essbase Query Designer (EQD) replaces is 
used to define queries in previous versions of Spreadsheet Add-in.

Before Analytic Services actually retrieves data, Essbase Query Designer provides 
a series of panels so that you can request the data that you want to view in the 
worksheet. It is particularly helpful when you know exactly which data you want 
to retrieve from the server. In addition, you can save a query and use it again.

The Essbase Query Designer window (shown in Figure 54 on page 94) consists of 
the following panels:

● The navigation panel at the left of the window provides access to the various 
features in Essbase Query Designer. You can display all the dimensions used 
in a particular query and access the various properties of each dimension 
member. 

● The hint panel at the top right of the window provides a brief description of 
the feature that is selected from the navigation panel.

● The properties panel at the bottom right of the window provides access to the 
following functions:

– Layout: Design the layout of the spreadsheet report. To change the default 
layout, select a dimension tile and drag it to one of the other dimension 
boxes. To access the member select panel and to define a member for a 
query, double-click a dimension tile.

– Member Select: Select members that you want to display in the rows of 
the spreadsheet report. To select a member, right-click the member, and 
select Add to Selection Rules. You can also double-click a member to add 
it to the selection rules.



92 ■

A Basic Tutorial

Essbase XTD Spreadsheet Add-in for Excel

– Member Filter: Filter the member selection by attribute, generation name, 
level name, pattern string, or UDA.

– Data Filter: Retrieve rows of data. The retrieval is based on the ranking 
of the rows within certain columns. Use this panel to access the data 
restriction panel. 

– Data Restriction: Filter data by comparing it to a fixed data value 
(including a negative value), a set of data values, or #Missing data values.

– Data Sort: Sort rows in ascending or descending order. The sort is based 
on column data values.

– Messages and Confirmation: Turn on and turn off certain messages from 
Essbase Query Designer.

– Help: Access documentation about Essbase Query Designer.

See “About Creating and Changing Queries” on page 93 for an overview of 
Essbase Query Designer. The portions of the tutorial that follow step you through 
the following query design procedures:

● “Creating Queries” on page 94

● “Saving Queries” on page 101

● “Applying Queries” on page 103

● “Deleting Queries” on page 104

● “Viewing Messages and Confirmations” on page 104

● “Accessing Help” on page 106

Note: Excel query functionality is not supported in Spreadsheet Add-in. Use the 
Essbase Query Designer to define database queries. 
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About Creating and Changing Queries
To access any of the Essbase Query Designer panels, select the appropriate feature 
listed in the navigation panel.

As you create a query or make changes to an existing query, the changes are 
reflected in the navigation panel. To view a dimension or a member of an open 
query, click on the specific dimension or member in the query outline that is 
displayed in the navigation panel. Selected members are displayed in the member 
selection panel on the right. 

You can also revise an existing query in the member selection panel. For example, 
you can delete a member or add a member to the query by selecting a member in 
the navigation panel and making the appropriate changes in the properties panel.

Note: Files created using the obsolete Retrieval Wizard feature can be opened in 
Essbase Query Designer. If, however, a query contains more than two member filters 
per selection rule or more than two data restrictions, the member filters may be out of 
order. To ensure correct results, rearrange the member filters in the navigation panel, if 
necessary.

For complete information on Essbase Query Designer options, see the Spreadsheet 
Add-in online help.

CAUTION: Manipulation of worksheets in VBA such as naming worksheets 
or moving worksheets may not work when EQD is running. 
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Creating Queries

➤ To create a query using Essbase Query Designer:

1. Select Essbase > Query Designer.

Analytic Services displays the Essbase Query Designer welcome panel, as 
shown in Figure 54.

Figure 54: Essbase Query Designer Displaying Welcome Panel

2. In the navigation panel, select [Book1]Sheet1, right-click, and select New > 
Query.
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The layout panel of Essbase Query Designer is displayed, as shown in 
Figure 55.

Figure 55: Essbase Query Designer Displaying Layout Panel

3. Define the worksheet layout by dragging the dimension tiles in the properties 
panel as follows:

a. Drag Market and Product to the Row location. 

b. Drag Measures to the Page location. 

c. Drag Scenario below Year (in the Column location).
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Figure 56 shows the results of dragging the dimension tiles in the properties 
panel.

Figure 56: Changing the Worksheet Layout 

4. In the navigation panel, select the Measures dimension by selecting the 
Measures icon. Alternatively, double-click the Measures tile in the layout 
panel. 

The member select properties panel, where you can select a member from the 
Measures dimension, is displayed.

Note: You can select only one member from the dimension in the Page location. 

5. In the Members list box, select Profit, right-click, and select Add to Selection 
Rules. 

Alternatively, double-click Profit to add it to the selection rules.
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Profit is displayed in the Selection Rules list box. 

Figure 57: Essbase Query Designer Displaying the Member Select Panel

Note: In Essbase Query Designer, after you make your selections, you do not 
need to confirm them; for example, you do not have to click OK. If you do not select 
members from any given dimension, Analytic Services uses the top member of the 
dimension. 

6. Select members of the Year dimension as follows:

a. In the navigation panel, click the Year icon. Alternatively, double-click 
the Year tile in the layout panel.

The member select properties panel for the Year dimension is displayed. 

b. In the Members list box, select Qtr1, right-click, and select Add to 
Selection Rules. 

c. Add Qtr2, Qtr3, and Qtr4 to the selection rules in the same manner. 

Because Year is in a Column location, you can select one or more 
members.

The result is shown in Figure 58.

Figure 58: Adding Members to the Selection Rules 



98 ■

A Basic Tutorial

Essbase XTD Spreadsheet Add-in for Excel

7. Select members of the Scenario dimension as follows:

a. In the navigation panel, select Scenario. Alternatively, double-click the 
Scenario tile in the layout panel.

The members of the Scenario dimension are displayed in the member 
select properties panel. 

b. Select Actual, right-click, and select Add to Selection Rules. 

Actual is added to the Selection Rules list box. 

c. In the same manner, add Budget to the Selection Rules list box. 

8. Select members of the Product dimension as follows:

a. In the navigation panel, select Product. Alternatively, double-click the 
Product tile in the layout panel. 

The members of the Product dimension are displayed in the member 
select properties panel. 

b. Select product code 100, right-click, and select Add to Selection Rules.

c. Repeat the process for product codes 200, 300, and 400. 

d. In the Selection Rules list box, select product code 100, right-click, and 
then, from the popup menu, choose Select > Children. 



Creating Queries Using Essbase Query Designer

2

■ 99Essbase XTD Spreadsheet Add-in for Excel

This action selects all children of 100. Analytic Services displays All 
Children next to 100 in the Selection Rules list box, as shown in Figure 59

e. In the Selection Rules list box, select product code 400, right-click, and 
choose Select > Descendants. 

Analytic Services displays All Descendants next to 400 in the Selection 
Rules list box.

Figure 59: Selecting Members of Product

f. To view the list of all product codes that will be retrieved into the 
worksheet, select any of the entries in the Selection Rules list box 
(for example, 200), right-click, and select Preview.
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Analytic Services displays the Member Selection Preview dialog box, as 
shown in Figure 60, with the selected product dimensions listed.

Figure 60: Selected Members of Product Dimension

g. Click Close to close the Member Selection Preview dialog box. 

9. Select members of the Market dimension as follows:

a. In the navigation panel, select Market. Alternatively, double-click the 
Market tile in the layout panel.

The members of the Market dimension are displayed in the member select 
properties panel. 

b. In the Members list box, select East, right-click, and select View by > 
Generation. 

c. To pick the second generation of the Market dimension, in the Member 
list box, select Region, right-click, and select Add to Selection Rules. 
Alternatively, double-click Region to add it to the selection rules. 

Region is displayed in the Selection Rules list box. 

d. To view the list of members that will be retrieved into the worksheet, in 
the Selection Rules list box, select Region, right-click, and select 
Preview. 
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As shown in Figure 61, Analytic Services displays East, West, South, and 
Central, which are members of generation two in Market, in the Member 
Selection Preview dialog box. 

Figure 61: Generation Name Selection

e. Click Close to close the Member Selection Preview dialog box.

You have now defined a basic query. The outline of the query is displayed in 
the navigation panel. 

The next topic describes how to save this query.

Saving Queries

➤ To save a query in Essbase Query Designer:

1. In the navigation panel, select [Book1]Sheet1, Query1\, and then right-click 
and select Save Query.

The Essbase Query Designer Save As Query dialog box is displayed, as shown 
in Figure 62. You can save your query to the server or to your own client 
machine. To save to the server, you must have a security level of database 
designer or higher. Contact the Analytic Services system administrator for 
more information.
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2. In the Location group box, select Client.

Figure 62: Essbase Query Designer Save As Query Dialog Box

3. Click the File System button.

Analytic Services displays the Save As dialog box, as shown in Figure 63. 

Figure 63: Save As Dialog Box

4. Select a location, in the File name text box, type Basic1 and then click Save. 
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As shown in Figure 64, Essbase Query Designer displays information about 
the query that you just saved. You will use the Basic1 query again in 
Chapter 3. 

Figure 64: Essbase Query Designer Displaying Query Information Panel

The next topic describes how to apply this query.

Applying Queries

➤ To apply a query in Essbase Query Designer:

1. In the navigation panel, select [Book1]Sheet1, Basic1.

2. Right-click the Basic1 query, and select Apply Query. 
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The result of the query is displayed in the worksheet, as shown in Figure 65.

Figure 65: Results of an Essbase Query Designer Query

In the Display tab under Essbase > Options, if you select Use Styles and Use 
Sheet Options with Query Designer, the styles you selected for dimension 
members will be applied to the initial query results. If you do not select Use 
Sheet Options with Query Designer, even if you have selected Use Styles, they 
will not be applied to the initial query results. To apply styles, select Essbase 
> Retrieve. When Analytic Services returns the data to the worksheet, you are 
free to further investigate the data by performing Zoom, Keep Only, Remove 
Only, and Pivot operations.

Deleting Queries
You can delete a query only from the location where you saved that query. For 
example, if you save a query in the /essbase/client/sample directory, you 
can delete the query from within the sample directory. You cannot delete the 
query from within Essbase Query Designer. 

Viewing Messages and Confirmations
Essbase Query Designer displays messages and confirmations about certain 
actions, such as moves and deletes, in the messages and confirmations panel.
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➤ To turn on or turn off messages and confirmations:

1. Select the Messages and Confirmations icon in the navigation panel. 

2. Select the check box that is displayed next to that message to turn on (enable) 
a message.

3. Select the check box again to turn off (make it inaccessible) a message.

This action clears the check box.

Figure 66: Messages and Confirmations Panel
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Accessing Help
Access online help or the tutorial for Essbase Query Designer by using the help 
panel. To access the help panel, in the navigation panel, select Help. For more 
information on a particular topic, click the Online Help button in the properties 
panel. To access the online tutorial, click the Tutorial button in the properties panel 
(shown in Figure 67).

Note: The Tutorial button launches ssxleqd.pdf, which links to the tutorial 
for Essbase Query Designer. The tutorial is part of this guide, Essbase XTD 
Spreadsheet Add-in User’s Guide for Excel, and is located in the essexcel.pdf file. 
To access the ssxleqd.pdf and essexcel.pdf files from Essbase Query 
Designer, they should be installed in $ARBORPATH/docs/pdf and Adobe Acrobat 
Reader must be installed. You can obtain Acrobat Reader at www.adobe.com.

Figure 67: Essbase Query Designer Help Panel

Connecting to Multiple Databases from 
Essbase Query Designer

You can connect to several databases and create separate queries on each database 
from Essbase Query Designer.

http://www.adobe.com
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➤ To connect to multiple databases from Essbase Query Designer:

1. Log on to Analytic Services and connect to the server that you want to access.

2. Select Essbase > Query Designer to open Essbase Query Designer.

3. Select [Book1]Sheet1, right-click, and select Connect.

The Essbase System Login dialog box is displayed. 

Note: The book may be a number other than 1. For example, it may be [Book5], if 
four worksheets are already open.

4. Type your password, and click OK. Select Sample Basic, and click OK.

5. Select [Book1]Sheet2 (or Sheet3), right-click, and select Connect. 

The Essbase System Login dialog box is displayed. 

6. Type your password, and click OK. Select Samppart Company, and click OK. 

Note: You are restricted to one connection per worksheet. The connection 
information is displayed in the query information panel of the Essbase Query 
Designer only when you open an existing query or create a new query.

7. Select [Book1]Sheet1, right click, and select New > Query to create a new 
query based on Sample Basic.

8. Select [Book1]Sheet2, right-click, and select New > Query to create a new 
query based on Samppart Company,

9. To open an existing query, right click, and select Open Query.

You are now ready to create queries or to open existing queries.

Applying Worksheet Options to Essbase Query Designer 
Results

You can apply any of the worksheet options that you previously set from the 
Essbase Options dialog box to the results of a query created in Essbase Query 
Designer. 

➤ To enable Essbase Query Designer to use your previously set worksheet options:

1. Select Essbase > Options.

2. In the Essbase Options dialog box, select the Display tab.
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3. Select the Use Sheet Options with Query Designer check box, and select 
OK.

4. Select Essbase > Retrieve to refresh the worksheet.

Analytic Services displays the results of the query that you created in Essbase 
Query Designer and implements your previously set worksheet options. 
For example, in Figure 68, aliases, instead of the numeric codes, are now 
displayed for the Product dimension.

Figure 68: Results of Query with Options Applied

5. Select File > Close to close the worksheet. 

You do not need to save the worksheet.

Selecting Members
An Analytic Services database may contain hundreds or even thousands of 
members, making it difficult to remember each member name. You can use the 
Essbase Member Selection dialog box to find and select members and to define the 
layout of members in the worksheet. In addition, you can use Boolean operators, 
such as AND, OR, and NOT, or other search parameters to specify criteria and 
conditions that members must meet for the member selection. Member selection 
is an important method of creating a spreadsheet report for the data that you want 
to retrieve.
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For complete information on the Essbase Member Selection dialog box, see the 
Spreadsheet Add-in online help.

➤ To view specific members from the Product dimension:

1. Select File > New or click  to open a new worksheet,

Note: You should be connected to the Sample Basic database. If you are not 
connected, follow the steps in “Connecting to a Database” on page 48.

2. Select Essbase > Retrieve.

3. Select Product and select Essbase > Pivot to display Product as a row, rather 
than a column, dimension.

Figure 69: Initial Worksheet for Member Selection

4. Select Product again, and select Essbase > Member Selection.
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Analytic Services displays the Essbase Member Selection dialog box, as 
shown in Figure 70. In the Essbase Member Selection dialog box, Analytic 
Services displays the Product dimension in the Dimension drop-down list and 
its children, Colas, Root Beer, Cream Soda, Fruit Soda, and Diet Drinks, in the 
Members list box. 

Figure 70: Essbase Member Selection Dialog Box

5. Select Colas and click the Member Information button. 
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Analytic Services displays the Member Information dialog box, as shown in 
Figure 71. The dialog box provides information about the selected member, 
such as dimension, generation, level, storage setting, formula, UDAs, and 
member comments.

Figure 71: Member Information Dialog Box

6. Click OK to close the Member Information dialog box.

7. In the Essbase Member Selection dialog box, click Add to add Colas to the 
Rules list box.

Alternatively, you can double-click an item in the Members list box to add 
the item.

8. Select Product, and click the Find button. 

Analytic Services displays the Find Member dialog box (see Figure 72).   

In the Find Member dialog box, you can do pattern-match searches for 
members in the selected dimension. You can use wildcard patterns—trailing 
asterisk *, and single-character match, ?. Analytic Services locates the 
members that match the text string and groups them in outline order, so that 
they can be selected as a group. 

Note: You can use the trailing asterisk wildcard and single-character wildcard in 
the text string. The * wildcard replaces a string of characters, and the ? wildcard 
replaces a single character. J?n and 100* are examples of valid wildcard strings; 
*-10 and J*n are examples of invalid wildcard strings. 



112 ■

A Basic Tutorial

Essbase XTD Spreadsheet Add-in for Excel

9. In the Find Member dialog box, type D* in the text box, as shown in 
Figure 72.

Figure 72: Find Member Dialog Box

10. Click Find to locate all members that match D*. 

Essbase selects the first descendent in the dimension whose name begins 
with the letter D.

11. Click Find Next.

The next member in the Product dimension whose name begins with the 
letter D is selected.

12. Continue to click Find Next until all members and descents of the Product 
dimension whose names begin with the letter D are selected.

13. Click Close to close the Find Member dialog box.

14. Click Diet Cream once to clear all other selected members and descendants 
and then click Add. 

Analytic Services displays Colas and the new selection, Diet Cream, in the 
Rules list box. 

15. In the Essbase Member Selection dialog box, select Colas in the Rules list 
box, right-click, and from the pop-up menu, select All Children and 
Member. 

Analytic Services displays All Children and Member next to Colas in the 
Selection Rules list box.

16. In the Selection Rules list box, select Colas, All Children and Member, and 
then right-click again. 

17. From the pop-up menu, select Subset. 

Analytic Services displays the Subset Dialog box, where you can further 
define conditions for the selected member (see Figure 73). You can define a 
maximum of 50 conditions in the Subset Dialog box.
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18. In the Subset Dialog box, in the first drop-down list, select Caffeinated. In the 
second drop-down list, select Is. In the third drop-down list, select 
Caffeinated_True. 

19. Click the Add as AND Condition button. 

Analytic Services displays Caffeinated = Caffeinated_True in the Conditions 
list box, as shown in Figure 73. 

Figure 73: Subset Dialog Box (Before Adding Conditions)

When you use Add as AND Condition, the subsetting condition in the 
Conditions list box is evaluated using AND logic. AND logic means that the 
selection must meet the current condition and the condition that follows it in 
the Conditions list box.

20. In the first drop-down list, select Ounces. In the second drop-down list, select 
the logical operator “=”. In the third drop-down list, select Ounces_12.

21. Click the Add as AND Condition button. 

Analytic Services displays Ounces = Ounces_12 in the Conditions box.

22. In the first drop-down list, select Ounces. In the second drop-down list, select 
the logical operator “<=”. In the third drop-down list, select Ounces_32.

23. Click the Add as OR Condition button. 

Analytic Services displays Ounces <= Ounces_32 in the Conditions box.
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When you use Add as OR Condition, the subsetting condition in the 
Conditions list box is evaluated using OR logic. OR logic means that the 
selection must meet the current condition or the condition that follows it in the 
Conditions list box.

24. In the first drop-down list, select Pkg Type. In the second drop-down list, 
select Is. In the third drop-down list, select Bottle.

25. Click the Add as AND Condition button.

Analytic Services displays Pkg Type = Bottle in the Conditions list box.

26. In the Conditions box, select Ounces <= Ounces_32, and then click the 
Add ( button. 

27. Select Pkg Type = Bottle, and click the Add ) button.

The Add ( and Add ) buttons add a left parenthesis and right parenthesis, 
respectively, to selected items. Use parentheses for grouping multiple 
subsetting conditions to determine the order of priority for analyzing the 
conditions. 

Each item in the Conditions list box can have either the left or right 
parenthesis, but not both. In this example, Analytic Services first evaluates 
members that are less than or equal to 32 ounces and are packaged in a bottle. 
Analytic Services then evaluates the results from this condition against 
members that are 12 ounces. 

Note: Use the Remove ( ) button to remove an individual group of parentheses 
from a selected item in the Conditions list box. Use the Remove All ( ) button to 
remove all parenthetical groupings from the Conditions list box.
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The Subset Dialog box is displayed as shown in Figure 74.

Figure 74: Subset Dialog Box (After Adding Conditions)

28. Click Preview to open the Member Preview dialog box. 

In the Member Preview dialog box, as shown in Figure 75, you can view the 
resulting member selection from the conditions that you defined.

Figure 75: Member Selection That Results from Subsetting Conditions

29. Click Close to close the Member Preview dialog box.

30. Click OK to close the Subset dialog box and return to the Essbase Member 
Selection dialog box.
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The conditions that you set in the Subset dialog box are displayed in the Rules 
list box.

31. Select Diet Cream and click the Move Item Up button to change the order in 
which Diet Cream is displayed in the worksheet. 

Each time you click the Move Item Up or Move Item Down button, the 
selected item and its associated subset conditions move up or down one 
position in the Rules list box. You can move only the top-level item (the item 
you added from the Members list box), not the individual subset conditions.

Figure 76: Selecting Members Completed

32. Click Preview to preview the members that will be retrieved in the worksheet.



Selecting Members

2

■ 117Essbase XTD Spreadsheet Add-in for Excel

Analytic Services displays the Member Preview dialog box, as shown in 
Figure 77. 

Figure 77: Members to be Retrieved in the Worksheet

33. After previewing the list, click Close.

34. Click OK to close the Essbase Member Selection dialog box and insert the 
new members into the worksheet (see Figure 78). 

Figure 78: Result of Selecting Members 

Note: The FlashBack command cannot undo a Member Selection action.

35. Starting with Diet Cream, type Year next to each product (see Figure 79). 
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You need to perform this step so that every product has a matching Year 
dimension associated with it in the report.

Figure 79: Worksheet After Adding the Year Dimension to All States

36. Select Essbase > Retrieve to update the values in the worksheet.

Analytic Services retrieves data for the members that you selected and also 
applies the styles that you previously set. The result is shown in Figure 80.

Figure 80: Result After Retrieving with Member Selection

Saving and Disconnecting
After performing basic retrieval, navigation, and formatting tasks, you can save 
worksheets and disconnect from Analytic Services. This section instructs you in 
the following procedures:

● “Saving a Worksheet” on page 119

● “Disconnecting from Analytic Services” on page 119

● “Logging Off” on page 120
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Saving a Worksheet
At any point during the Analytic Services session, you can save the active 
worksheet with the commands, File > Save or File > Save As. Thus, you can keep 
a personal library of database views. You can open the worksheet during a later 
session and retrieve the latest data values to update the view.

Note: To save the Essbase option settings in a worksheet, you must explicitly go to the 
Essbase Options dialog box and set the options prior to saving the worksheet. 
Otherwise, when you open the same worksheet in a new Spreadsheet Add-in session, 
the options settings for the current session will override any previous settings for the 
worksheet. Make sure that the worksheet for which you option settings saved is not a 
protected worksheet. Analytic Services cannot save option settings for a protected 
worksheet.

Disconnecting from Analytic Services
When you finish retrieving and navigating through data, disconnect from the 
server to decrease user count and to make a port available on the server for other 
Spreadsheet Add-in users.

➤ To disconnect from the server:

1. Select Essbase > Disconnect.

Analytic Services displays the Essbase Disconnect dialog box, where you can 
disconnect any worksheet that is connected to a database.

Figure 81:  Essbase Disconnect Dialog Box

2. From the list, select a worksheet name, and then click Disconnect. 

3. Repeat step 2 until you have disconnected all active sheets.
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4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by closing the spreadsheet application. 
An abnormal shutdown of a Spreadsheet Add-in session, such as a power loss or 
system failure, does not disconnect your server connection. 

Logging Off
Analytic Services provides two administrative features that control user 
connections:

● Forced Logout, where an administrator disconnects users at any point in time. 
This logout usually occurs when maintenance operations are performed on 
databases.

● Auto Logout, where Analytic Services automatically disconnects users that are 
inactive for a timed interval specified by an administrator. 

On to Advanced Tasks
Now that you have completed the basic tutorial, you are ready to move on to more 
complex tasks. In the next chapter, you will use the sample spreadsheet files to 
perform advanced tasks in Essbase XTD Spreadsheet Add-in.
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3

Chapter

3
An Advanced Tutorial

The tutorial that you completed in Chapter 2 teaches basic data retrieval and 
navigation concepts for Essbase XTD Spreadsheet Add-in. This chapter builds on 
your basic skills and expands your knowledge of Essbase XTD Analytic Services 
and Spreadsheet Add-in. 

These are the topics covered:

● “Preparing to Begin the Tutorial” on page 122

● “Performing Advanced Retrieval Tasks” on page 128

● “Using Linked Reporting Objects” on page 177

● “Connecting to Multiple Databases” on page 191

● “Ways to Access Linked Partitions” on page 192

● “Updating Data on the Server” on page 194

● “Database Calculation” on page 196

● “Creating Multiple Worksheets from Data” on page 198

● “Working with Currency Conversions” on page 203 

In this advanced tutorial, you use several sample spreadsheet files for Excel that 
were installed as part of the default Analytic Services installation. These files are 
stored in the\Essbase\client\sample directory. You also reconnect to the 
Sample Basic database.
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Preparing to Begin the Tutorial
Before you begin the advanced tutorial, complete the steps in the next two 
sections, “Connecting to a Database” on page 122 and “Setting Essbase Options” 
on page 124. In addition, be sure to read “Following Guidelines During the 
Tutorial” on page 45 and “Reviewing the Sample Basic Database” on page 46 for 
important information about what you should expect as you perform the tutorial 
steps.

Connecting to a Database
To access Analytic Services data for the advanced tutorial, first connect to the 
Sample Basic database on the server. This tutorial assumes that you have the 
appropriate privileges to connect to a server, an application, and a database.

1. Select Essbase > Connect.

The Essbase System Login dialog box is displayed, as shown in Figure 82.

Figure 82: Essbase System Login Dialog Box

Note: To complete the steps that follow, you need to know the name of the Analytic 
Services server, your username, and your password. If you do not have this 
information, contact the Analytic Services system administrator.

2. From the Server drop-down list, select the server that you want to access and 
then press Tab to move to the Username text box.
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If the server name that you want is not shown in the list, type the name of the 
server that you want to access in the Server text box and press Tab.

3. In the Username text box, type your username and then press Tab to move to 
the Password text box. 

4. In the Password text box, type your password.

Note: You can change your password when you are connected to a server. See 
“Changing a Password” on page 50.

5. Click OK to connect to the server. 

Analytic Services displays a list of available application and database pairs in 
the Application/Database list box. An instance of Analytic Server enables 
simultaneous access to multiple applications. An application can contain 
multiple databases. Only the databases to which you have security access are 
displayed in the list.

For this tutorial, you use the Sample Basic database. If the Sample Basic 
database was installed as part of the Analytic Services installation, it is shown 
in the list. If Sample Basic is not shown in the Application/Database list box, 
ask the Analytic Services system administrator to install it.

Figure 83: Available Application and Database Pairs

6. In the Application/Database list box, double-click Sample Basic, or select 
Sample Basic and then click OK.
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If the application is not already running, Analytic Services automatically starts it. 
There may be a brief pause as the application loads; the time required to start an 
application depends on the number of databases, the sizes of the databases, and the 
sizes of the indexes of the databases that are contained within the applications.

Setting Essbase Options
Before you begin the tutorial, make sure that the worksheet options are set to the 
initial settings shown in the Figure 84 through Figure 87. 

Note: For information on each option in the Essbase Options dialog box, see the 
Spreadsheet Add-in online help.

1. Select Essbase > Options.

2. In the Essbase Options dialog box, select the Display tab.

3. Select the appropriate check boxes and option buttons so that your display 
matches Figure 84.

Figure 84: Initial Settings for Display Options

4. Select the Zoom tab.
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5. Select the appropriate check boxes and option buttons so that your display 
matches Figure 85. 

Figure 85: Initial Settings for Zoom Options

6. Select the Mode tab.
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7. Select the appropriate check boxes and option buttons so that your display 
matches Figure 86.

Figure 86: Initial Settings for Mode Options

8. Skip the Style tab and select the Global tab.



Preparing to Begin the Tutorial

3

■ 127Essbase XTD Spreadsheet Add-in for Excel

9. Select the appropriate check boxes and option buttons so that your display 
matches Figure 87.

Figure 87: Initial Settings for Global Options

10. Select OK to save the settings for this session and close the Essbase Options 
dialog box.

The settings in the Essbase Options dialog box may change as you access the 
various sample spreadsheet files as part of the tutorial. Leave the settings as they 
are unless the tutorial advises you to change them. If you have different option 
settings, the illustrations presented in this chapter may not match the worksheet 
view.
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Performing Advanced Retrieval Tasks
The tutorial in Chapter 2 describes how to perform basic data retrieval and 
navigation tasks in Spreadsheet Add-in. These are the advanced retrieval tasks 
discussed in this chapter:

● “Filtering Data” on page 129

● “Sorting Data” on page 136

● “Retrieving Data into Asymmetric Reports” on page 139

● “Drilling Down to a Sample of Members” on page 141

● “Working with Formatted Worksheets” on page 143

● “Preserving Formulas When Retrieving Data” on page 149

● “Retrieving a Range of Data” on page 153

● “Retrieving Data by Using a Function” on page 156

● “Retrieving Dynamic Calculation Members” on page 160

● “Specifying the Latest Time Period for Dynamic Time Series” on page 163

● “Using Free-Form Reporting to Retrieve Data” on page 167

Remember that you can perform common data retrieval tasks in any of the 
following ways:

● Selecting commands from the Essbase menu on the spreadsheet application 
menu bar

● Clicking the appropriate buttons on the Essbase toolbar

● Double-clicking the primary or the right-mouse button in the appropriate cell 
(for Retrieve, Zoom In, and Zoom Out commands only, and the Linked 
Objects command, if you have enabled that option).
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Filtering Data 
Despite the ease and speed with which you can navigate through large Hyperion 
Essbase databases, it is not practical to use the capabilities of the spreadsheet 
application to filter and sort very large databases; however, Analytic Services 
includes powerful data filtering and sorting capabilities. 

In Chapter 2, you learned to use Essbase Query Designer to define a dimensional 
layout and to select members to view. Essbase Query Designer also provides a 
powerful tool to define conditional retrievals.

To become familiar with the capabilities of Essbase Query Designer, work with the 
query, Basic1, that you saved in Chapter 2, and perform the following steps: 

Note: If you skipped the tutorial in Chapter 2, follow the steps in “Creating Queries 
Using Essbase Query Designer” on page 91 to create and save the Basic1 query.

1. Select Essbase > Query Designer. 

The query information panel of Essbase Query Designer is displayed. 

2. In the navigation panel, select [Book1]Sheet1.

3. Right-click and select Open Query.

The Open Query dialog box is displayed.

4. From the location that you specified in Chapter 2, select the Basic1 file.

5. Click OK. 

The member selection, displayed in the properties panel, remains unaltered 
from the last Essbase Query Designer session. 

6. From the navigation panel, select Data Filtering.
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Analytic Services displays the data filter settings in the data filter panel, as 
shown in Figure 88. The filter controls the number of data rows that are 
retrieved. The number is based on the column criteria that you define. You can 
define data filtering criteria on data values that reside in one or more columns 
of the view.

Figure 88: Data Filter Panel 

The data filtering panel contains the following items:

● A check box for ranking a specified number of top rows or a specified 
number of bottom rows of data. 

You can select the highest or lowest rows. Your selection is based on 
previously selected row dimension members. When using the top or 
bottom criterion, you specify the number of rows, such as “top 10.” The 
default is the top 25 rows.

● A “Dimension being ranked” drop-down list box to specify the dimension 
to which ranking should be applied.

● A “Column used for ranking” drop-down list box to specify the data 
column on which data values are based.
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● A “Data Restrictions” list box to specify standard data comparison 
operations, such as greater than, less than, and equal to. 

You can apply the comparison operator to data values, including negative 
data values, in one or more data columns; you can even apply criteria to 
compare values between two columns.

● Buttons for OR and AND operators. 

If you define more than one criterion for a column, you can use these 
operators to link the criteria.

7. Select the Top check box, and enter a value of 30 in the Rows text box.

When you apply the query, Analytic Services retrieves the top thirty rows of 
the dimension.

8. From the Dimension being ranked drop-down list, select Product. 

Product is the dimension to which ranking should be applied.

9. From the Column used for ranking drop-down list, select Qtr1, Actual. 

Qtr1, Actual is the column on which data values are based.

10. In the navigation panel, select the Data Filtering icon. Right-click and select 
Apply Query. 
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Your query results should look like Figure 89. 

Figure 89: Data Filtering Query Results

You can further filter the data output by specifying data comparison operations 
in the Data Restrictions list box. 

11. In the navigation panel, select the Data Filtering icon. 

The data filters that you specified are displayed in the properties panel.

12. In the Data Restrictions list box, double-click. 

The data restriction settings are displayed in the properties panel.

13. Select the A value of option and type 500 in the value text box. 

Observe that the “is” option in the Data drop-down list box changed to =. 

14. Click the down arrow of the Data drop-down list box and select <=. 

15. Click the down arrow of the Column used for filter drop-down list box and 
select Qtr1, Actual.
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16. In the navigation panel, select the Data Filtering icon, right-click, and select 
Apply Query.

Notice that the query results now reflect only Actual and Budget data that are 
less than or equal to 500.

17. In the navigation panel, select the Data Filtering icon to display the data filter 
setting in the properties panel. 

18. In the Data Restrictions list box, select Qtr1, Actual <= 500, right-click, and 
select New Data Restriction.

19. In the Data drop-down list box, click the down arrow and select <.

20. Select the option, the data values in, and from the drop-down list, select 
Qtr2, Actual.

21. Under Combined With Other Restrictions, select the Or option.

22. In the navigation panel, click the Data Filtering icon to access the data filter 
panel.

23. In the Data Restrictions list box, double-click to create a new data restriction.

24. In the Data drop-down list box, click the down arrow and select is not.

25. Click the button for the #Missing Value option. 

This option instructs Analytic Services to discard data that have #Missing 
values.

26. In the Column used for filter drop-down list, select Qtr1, Actual. 

27. Under Combined With Other Restrictions, select the And option. 

28. In the navigation panel, click the Data Filtering icon to access the data filter 
panel.
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The data restrictions should be displayed as shown in Figure 90:

Figure 90: Data Filtering

29. Select the Data Filtering icon, right-click, and select Apply Query. 
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Analytic Services retrieves data for all the quarters. Notice that the retrieved 
data for Qtr1, Actual is less than or equal to 500 or is less than Qtr2, Actual. 
The results should be displayed as shown in Figure 91:

Figure 91: Data Filtering Results

If you wanted to delete all data restrictions, select the Data Filtering icon in the 
navigation panel, right-click, and select Delete All Data Restrictions. 
Alternatively, select any data restriction in the Data Restriction box, right-click, 
and select Delete All Data Restrictions. 

To delete a particular data restriction, select the data restriction in the query 
outline, right-click, and select Delete Data Restriction. Alternatively, select the 
data restriction in the Data Restriction box, right-click, and select Delete Data 
Restriction.
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Sorting Data 
In the data sort panel, you can sort the output from the Basic1 query in ascending 
or descending order.

➤ To sort the query:

1. From the navigation panel, select the Data Sorting icon. 

As shown in Figure 92, the data sorting settings are displayed in the properties 
panel. You can specify data sorting criteria that affect the order in which the 
selected rows are retrieved in the data sorting panel.

The data sorting panel contains the following items:

● A “Dimension being sorted” drop-down list box that lists the dimensions 
specified in row format in the query.

● A “Column used for sort” drop-down list box where you select one or 
more dimensions to be specified in column format in the query.

● An Ordering drop-down list box where you apply an ascending or 
descending sort order for the selected column. 

You can also specify sorting to occur over a specific row dimension 
group. For example, you can sort by Product or by Market. 

Figure 92: Data Sorting Panel
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2. Double-click on the statement (double click to create a new sort rule). 

The selection defaults to Qtr1, Actual. The sort order defaults to Ascending in 
the Ordering list box. 

3. Click Ascending. 

A down arrow is displayed next to Ascending. 

4. Click the down arrow next to Ascending. 

Descending is displayed below Ascending, as shown in the properties panel in 
Figure 93.

5. In the Ordering drop-down list, select Descending.

Figure 93: Specifying Data Sorting Order

6. Double-click on the statement (double click to create a new sort rule).

A new data sorting rule is added. The new selection defaults to “Qtr1, Actual.” 

7. Click the down arrow next to Qtr1, Actual and select Qtr1, Budget. 

Observe that the order in the Ordering list box has defaulted to Ascending.

8. In the navigation panel, under Data Sorting, select Ascending, Qtr1, 
Budget, right-click, and select Delete Sorting Rule. 
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The “Ascending, Qtr1, Budget” sorting rule is deleted from the query. 

9. In the navigation panel, select the Data Sorting icon, right-click, and select 
Apply Query.

Analytic Services returns the results sorted in descending order for each 
quarter, as shown in Figure 94:

Figure 94: Result of Filtering and Sorting Data

Note: The values that you are ranking and sorting must be the same. For example, 
you cannot specify Product in the “Dimension being ranked” drop-down list box and 
Market in the “Dimension being sorted” drop-down list box. If you specify different 
values, Essbase Query Designer automatically changes both values to the last 
specified value.

10. To close the worksheet, select File > Close. 

You do not need to save the worksheet.
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Retrieving Data into Asymmetric Reports
When you retrieve data into a worksheet, the resulting report can be either 
symmetric or asymmetric. Symmetric reports are characterized by repeating 
identical groups of members. For example, Figure 94 on page 138 shows a 
symmetric report that contains Actual and Budget members nested below Year 
members (Qtr1, Qtr2, Qtr3, and Qtr4).

An asymmetric report is characterized by groups of nested members that differ by 
at least one member. There can be a difference in the number of members or in the 
names of members.

You can create asymmetric reports in one of the following ways:

● Enter member names into the worksheet in free-form retrieval mode.

● Use a drill action with the Within Selected Group option selected from the 
Zoom tab of the Essbase Options dialog box.

● Suppress rows that contain missing values, zero values, or underscore 
characters during data retrievals.

If you retrieve data into an asymmetric report, Analytic Services must perform 
additional internal processing to maintain the asymmetric layout. This processing 
may increase the retrieval time on large reports. For more information regarding 
optimizing reports, see the Essbase XTD Analytic Services Database 
Administrator’s Guide.

As part of the default Analytic Services installation, the Asymm.xlsl sample file 
is provided that illustrates how to create asymmetric reports.

➤ To view the sample file, Asymm.xls:

1. Select File > Open.

2. From the\Essbase\client\sample directory, open the Asymm.xls file. 
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Depending on how software is installed on your PC, the file may not be 
available or may be located in a different directory. Contact the Analytic 
Services system administrator for more information.

Figure 95: Asymmetric Report

The sample file row and column dimension groups are asymmetric. Thus, the 
nested member groups from the Product dimension differ in member content 
within respective markets. For example, Colas and Fruit Soda are included in 
East but not in West. In addition, Actual data is displayed for Qtr1, whereas 
Budget data is displayed for Qtr2, Qtr3, and Qtr4. Also notice that the sample 
file displays styles for members of the Scenario and Year dimensions.

3. Leave the sample file open for the next tutorial task.

Pivoting in Asymmetric Reports
When you pivot a group of members in an asymmetric report, Analytic Services 
keeps only unique members from dimensions that are not involved in the pivot.

➤ To use the open Asymm.xls file to illustrate this point:

1. Using the right-mouse button, drag East to the cell below Qtr1.

The result is shown in Figure 96.

Figure 96: Result of Pivoting in an Asymmetric Report



Performing Advanced Retrieval Tasks

3

■ 141Essbase XTD Spreadsheet Add-in for Excel

Analytic Services combines the Product members into all unique members. 
For example, Root Beer, which is displayed twice in Figure 95 on page 140, 
is displayed only once in the current view. Colas, which is displayed in only 
one market in Figure 95, now is displayed in East and West.

Analytic Services also removes the blank line between Product row groups. A 
pivot action always eliminates any rows or columns in which all cells are 
empty.

2. Close the sample file without saving the changes.

Drilling Down to a Sample of Members
Analytic Services is a multidimensional database engine that provides support for 
ad hoc analysis. Such analysis is entirely driven by the intuition of the analyst and 
can be time-consuming as data volume increases. Large cubes tend to have more 
dimensions and sometimes more levels, making hierarchical navigation very 
cumbersome.

By drilling down to a portion of the members in an Analytic Services database, you 
can quickly analyze a large multidimensional database with a focus on data trends. 
This type of drilling down is also called “metadata sampling.”

Metadata sampling enables you to analyze on large cubes with a focus on data 
trends or to approximate information in the initial stages. Because you query on a 
“sample” of the members, retrieval is quick. Metadata sampling enables you to 
drill down to a portion of the vast number of members of an Analytic Services 
database in a fraction of the time that it usually takes to analyze the entire Analytic 
Services database. You can view many samples in a small amount of time and 
make early decisions. Later, you can follow up with organized data exploration.

With the introduction of Hybrid Analysis, you can store part of an Analytic 
Services cube in a relational database. Metadata sampling enables you to drill 
down on all members that you specify, whether they reside in Analytic Services or 
in an underlying relational database.

To drill down to a sample of members, you must to connect to a server, an 
application, and a database. Next, enable sampling in the Spreadsheet Add-in for 
Excel and set a percentage amount of data to query when drilling down to more 
detail (performing a Zoom In operation).
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Notes on Sampling

● When drilling down on Hybrid Analysis, the following limitations apply:

– Sampling with the All Levels option is not supported with Hybrid 
Analysis members.

– Sampling with Same Level and Same Generation options are not 
supported.

This task is optional. Optional tasks do not need to be performed as part of the 
tutorial. They are provided for information only.

In Excel, to drill down to a sample of members:

1. Select Essbase > Sample Data (Zoom In) to enable sampling.

A check mark displayed next to the Sample Data (Zoom In) menu command 
indicates that sampling is enabled.

2. Select Essbase > Options.

3. In the Essbase Options dialog box, select the Zoom tab.

4. In the Sampling Percentage text box, type an integer between 1 and 100 to 
represent the approximate percentage amount of the Analytic Services cube to 
query during a Zoom In operation.

The default value is 100.

Note: If Hybrid Analysis is enabled and in use, the sampling percentage also 
applies to queries on the underlying relational database.

5. Click OK to save the sampling percentage integer that you entered and any 
other Zoom options that you have set.

The Essbase Options dialog box is closed and you are returned to the 
spreadsheet.

6. In the spreadsheet, select the member on which you want to drill down.

7. Select Essbase > Zoom In or double-click the primary mouse button.

For example, if you typed 50 in the Sampling Percentage text box, 
approximately 50 percent of the members from your Analytic Services 
database and, if applicable, from the specified columns of the relational 
database are queried when you select Essbase > Zoom In.
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● When sampling is enabled, a combination of the algorithms used by Analytic 
Services and the sampling percentage you set sometimes makes the following 
scenarios possible:

– During a Zoom In operation, no members are retrieved. This can happen 
in some cases where a dimension is small.

– During a Zoom In operation, all members are retrieved. This can happen 
in some cases where the sampling percentage is very small.

Working with Formatted Worksheets
In addition to providing flexible, ad hoc retrievals, Analytic Services supports 
retrieving data into formatted worksheets. A worksheet can contain the following 
formats:

● Spaces between rows and columns

● Cell values that contain text or data that is not defined in the database outline

● Member names in noncontiguous locations at the top of a worksheet

● Spreadsheet formulas (see also “Preserving Formulas When Retrieving Data” 
on page 149)

● Visual cues (styles)

After you format and save a worksheet, you may want to retrieve and navigate 
through new data in the existing worksheet format. These topics provide the 
following information on working with formatted worksheets:

● “Observing the Rules for Working with Formatted Worksheets” on page 144

● “Retrieving Data into Formatted Worksheets” on page 145

● “Pivoting Data on Formatted Worksheets” on page 147
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Observing the Rules for Working with Formatted 
Worksheets
Observe the following rules when retrieving data into a formatted worksheet:

Rule 1

In the worksheet, no numeric cells can be located before the first Analytic Services 
data cell. For example, in Figure 97 on page 145, the first Analytic Services data 
cell is B6. Neither any cell in rows 1 through 5 nor cell A6 can contain numeric 
values. Also, these cells cannot contain formulas that resolve to numeric values.

Rule 2

A cell that lies within a row or column of Analytic Services data cannot contain 
text or numeric values. For example, in Figure 97 on page 145, the cells in columns 
B, C, D, and F and rows 6 through 9 and 11 through 14 cannot contain any nondata 
text or numbers, for such values may be overwritten, or emptied, by the retrieved 
data. These cells can contain formulas, however, if Formula Preservation options 
are used. For more information on Formula Preservation options, see “Preserving 
Formulas When Retrieving Data” on page 149. 

Tip: If you need to preserve text in a cell, define that text or value as a spreadsheet 
formula, and use the Formula Preservation options. 

Rule 3

The Pivot command is not available when the Retain on Retrieval check box is 
selected in the Mode tab of the Essbase Options dialog box. 

Rule 4

The Pivot command removes all cells that contain text other than database member 
names.
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Retrieving Data into Formatted Worksheets
As part of the default Analytic Services installation, the P&l.xls sample file is 
provided that illustrates how to retrieve data into a formatted worksheet. The 
sample file illustrates how to retrieve data into a worksheet that contains formatted 
text, formulas, and protected cells. 

➤ To view the P&l.xls worksheet:

1. Select File > Open.

2. From the\Essbase\client\sample directory, open the P&l.xls file.

An example of the worksheet is shown in Figure 96.

Note: Depending on how software is installed on your machine, the file may not 
be available or may be located in a different directory. Contact the Analytic Services 
system administrator for more information.

Figure 97: A Sample Formatted Worksheet

3. Select Essbase > Options and select the Display tab.

4. In the Cells option group, make sure that Adjust Columns is checked.

5. Select the Mode tab.

6. In the Formula Preservation group, select the Retain on Retrieval check 
box to enable Formula Preservation mode.

Note: When Retain on Retrieval is selected, there may be a slight delay in retrieval 
time.
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7. Click OK.

By default, an Analytic Services retrieval overwrites the spreadsheet formula 
with data values in the retrieval area of a worksheet. The retrieval process also 
eliminates formulas in cells outside the retrieval area. The Retain on 
Retrieval option, however, enables you to define retrievals that do not 
overwrite formulas in any area of the worksheet.

8. Select Essbase > Retrieve to update the worksheet with the latest data values. 

Analytic Services determines that some text cells in the worksheet do not 
correspond to database member names. When Analytic Services is unable to 
resolve text in the worksheet, the message shown in Figure 98 is displayed:

Figure 98: Essbase Unknown Member Message

In this example, the first unknown member detected is Market: (in cell A1). 
Analytic Services does not recognize the colon (:) that follows Market in the 
cell. If you click Yes, Analytic Services displays the next unknown member; 
if you click No, Analytic Services continues with the retrieval.

Note: If you work with formatted worksheets often, you may want to configure 
Analytic Services so that this message is not displayed. For information on 
configuring to avoid the Essbase message, see “Pivoting Data on Formatted 
Worksheets” on page 147.

9. Click No to close the dialog box and continue with the retrieval.
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Analytic Services retrieves new data but retains the formatting and formulas 
in the worksheet. The result is shown in Figure 99.

Figure 99: Result of Retrieving on a Formatted Worksheet

10. Close the file without saving it.

Note: The section on “Preserving Formulas When Retrieving Data” on page 149 
provides additional tutorial tasks that show you how to take advantage of all the Formula 
Preservation options. 

Pivoting Data on Formatted Worksheets
Using the Pivot command, you can produce ad hoc reports in both formatted and 
unformatted worksheets. A formatted worksheet, however, may contain labels and 
formulas that make the result of a pivot operation ambiguous. The pivot is 
designed to compress and retain only the database elements represented in the 
worksheet. The worksheet also retains labels in areas that are not overwritten by 
pivoted data.

Note: Analytic Services prevents pivot operations on worksheets that contain formulas 
when Formula Preservation mode is active. 

As part of the default Analytic Services installation, the Inv.xls sample file is 
provided which illustrates how to pivot data in a worksheet. The sample file was 
saved with the Retain on Retrieval option disabled so that you can pivot on its 
worksheets.
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➤ To view the Inv.xls worksheet:

1. Select File > Open.

2. From the\Essbase\client\sample directory, open the Inv.xls file.

An example of this worksheet is shown in Figure 100.

Note: Depending on how software is installed on your PC, the file may not be 
available or may be located in a different directory. Contact the Analytic Services 
system administrator for the location of the file.

Figure 100: Formatted Worksheet Before Pivoting

3. Select Essbase > Options and select the Global tab.

4. In the Display Messages group box, clear the Display Unknown Members 
check box to avoid seeing the Essbase messages when working with formatted 
worksheets, and click OK.

5. Using the right-mouse button, drag Sales (in cell A5) to the cell nested below 
Jan (C4). 

Analytic Services pivots the Sales member group so that it is nested below the 
monthly members. During the pivot, however, Analytic Services retains only 
database elements. For example, all data for Stock to Sales and Adjusted for 
Audit is deleted during the pivot. 



Performing Advanced Retrieval Tasks

3

■ 149Essbase XTD Spreadsheet Add-in for Excel

The result is shown in Figure 101.

Figure 101: Result of Pivoting on a Formatted Worksheet

6. Close the file without saving it.

Preserving Formulas When Retrieving Data
In “Retrieving Data into Formatted Worksheets” on page 145, you used the Retain 
on Retrieval option to preserve formatting and formulas in an existing worksheet. 
Collectively, the Formula Preservation options enable you to retain formulas 
during data retrievals, keep and remove only operations, and drill operations. In 
addition, Analytic Services can replicate formulas for additional members 
retrieved into the worksheet as part of a drilling operation. This topic shows you 
how to create a report using all of the Formula Preservation options.

Keep in mind the following guidelines and restrictions when using the Formula 
Preservation options:

● On the Mode tab of the Essbase Options dialog box, you must have the 
Advanced Interpretation option selected to enable Retain on Retrieval. The 
Formula Preservation options do not work with free-form retrieval mode.

● You must enable Retain on Retrieval to enable Retain on Keep and Remove 
Only and Retain on Zooms.

● You must enable Retain on Zooms to enable Formula Fill.
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● When you select the Retain on Retrieval check box, the Suppress #Missing 
Rows and Zero Rows options on the Display tab are not selectable. If you have 
selected either of the Display options, the Formula Preservation options 
become unselectable automatically.

● When you select the Retain on Zooms check box, the Remove Unselected 
Groups option on the Zoom tab is not selectable. When you enable the 
Remove Unrelated Groups option, Retain on Zooms becomes unselectable 
automatically.

● When Retain on Retrieval is selected, retrieval time may be slightly delayed.

● As a general rule, insert a blank row as the last row in the formula range. This 
action ensures that the cell range in the formula expands properly when you 
drill down on members when Retain on Zooms is selected.

● Formula arrays are not supported in Spreadsheet Add-in when the preserve 
formula option is on. If formula arrays are in the worksheet, Analytic Services 
does not preserve these types of formulas.

➤ To preserve formulas when retrieving or retaining data:

1. Select File > New or click  to open a new worksheet.

2. Select Essbase > Retrieve.

3. In cell A2, drill down (double-click) on Year.

4. Press and hold down the Alt key and, in cell E1, drill down (double-click) on 
Scenario.

5. Select cell G3 and enter the following formula in the cell: =B3/B$7*100, as 
shown in Figure 102.

The $ in front of the 7 anchors the formula to the Year member. 

Figure 102: Entering a Formula into a Cell

6. Press Enter. 
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The spreadsheet calculates the formula that you entered in cell G3 and now 
reflects Qtr1 as a percentage of Year. The result is shown in Figure 103.

Figure 103: Result of Calculated Formula with Analytic Services Data

7. Select Essbase > Options and select the Mode tab.

8. In the Formula Preservation group box, select the check boxes for Retain 
on Retrieval and Retain on Keep and Remove Only, and click OK. 

9. In cells D2, E2, and F2, respectively, select Variance, %Variance, and 
Scenario.

10. Select Essbase > Remove Only. 

Analytic Services removes the selected columns but retains the formula that 
you entered, keeping it with the retained dataset. The result is shown in 
Figure 104.

Figure 104: Result of Removing Columns With Retain on Keep and 
Remove Only Selected

11. Select Essbase > Options and select the Mode tab.

12. In the Formula Preservation group box, select the check box for Retain on 
Zooms and click OK. 

13. In cell A3, drill down (double-click) on Qtr1. 
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Analytic Services drills down on Qtr1 and moves the formula down with the 
Qtr1 member. The result is shown in Figure 105.

Figure 105: Result of Drilling Down with Retain on Zooms Enabled

14. Select Essbase > FlashBack.

15. Select Essbase > Options and select the Mode tab.

16. In the Formula Preservation group box, select the Formula Fill check box 
and click OK. 

17.  In cell A3, drill down (double-click) on Qtr1. 

Analytic Services drills down on Qtr1 and replicates the formula for each 
member of Qtr1 (Jan, Feb, and Mar). To view the replicated formulas, click in 
cells D3, D4, D5, and D6 and look at the new syntax in the spreadsheet 
formula bar. The result is shown in Figure 106.

Figure 106: Result of Drilling Down with Formula Fill Enabled

18. Before moving on with the tutorial, complete each of the following tasks:

a. Select Essbase > Options and select the Mode tab.

b. Clear all of the Formula Preservation options.

c. Select File > Close to close the worksheet. 
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You do not need to save the worksheet.

Retrieving a Range of Data 
In a typical worksheet, you can select a range of cells by dragging the mouse across 
the worksheet. You can also select a range of cells and tell Analytic Services to 
restrict the data retrieval to the selected range in the worksheet. Retrieving a range 
of data is particularly useful in the following situations:

● A worksheet contains multiple reports.

● A worksheet contains extraneous information that is not supported in a 
formatted report retrieval.

● You need to retrieve only a small subset of values from the server, thus 
dramatically decreasing retrieval time for large datasets.

● You need to retrieve data to an area of the worksheet other than the first 
column.

As part of the default Analytic Services installation, the Profit.xls sample file 
is provided that illustrates how to retrieve a range of data. 

➤ To view the Profit.xls file: 

1. Select File > Open.

2. From the\Essbase\client\sample directory, open the Profit.xls file.

Note: Depending on how software is installed on your PC, the file may not be 
available or may be located in a different directory. Contact the Analytic Services 
system administrator for the location of the file.
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As shown in Figure 107, when you open Profit.xls, the range of cells from 
B2 through F9 has already been selected for you.

Figure 107: Selected Range of Cells for Retrieval

3. Select Essbase > Retrieve to update the selected range. 

Analytic Services updates only the data in the selected range of cells, as shown 
in Figure 108. 

Figure 108:  Result of Retrieving First Range of Data
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4. Select cells B12 through G16, as shown in Figure 109.

Figure 109: Selecting Cells for Retrieval

5. Select Essbase > Retrieve once again to update the selected range. 

Analytic Services updates the data in the selected range, as shown in 
Figure 110.

Figure 110: Result of Retrieving Second Range of Data

6. Close the file without saving it.
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Retrieving Data by Using a Function
The Analytic Services cell retrieve function, EssCell, retrieves a single database 
value into a worksheet cell. Enter an EssCell function directly into a worksheet or 
select an EssCell function from the spreadsheet menu bar. 

Note: You must be connected to a database to use EssCell.

EssCell retrieves data when you perform an Analytic Services retrieval or when 
you recalculate a worksheet through Excel. As part of the default Analytic 
Services installation, the Summary.xls sample file is provided with EssCell 
functions already set in cells B16 and B17. 

➤ To view the Summary.xls file:

1. Select File > Open.

2. From the\Essbase\client\sample directory, open the Summary.xls 
file. 

Note: Depending on how software is installed on your PC, the file may not be 
available or may be located in a different directory. Contact the Analytic Services 
system administrator for the location of this file.

Figure 111: Worksheet Containing EssCell Functions

In Excel, cells B16 and B17 contain the EssCell function. If you select either 
of these cells, you can view the syntax for the EssCell function in the formula 
bar at the top of the worksheet.

The EssCell function is defined in a cell as follows:
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Table 3: For Excel

In Excel, mbrList is one of the following factors:

● A null value. If the parameters of the function are empty, Analytic 
Services returns the data value from the top of each dimension.

● A comma-delimited list of member names. Member names must be 
enclosed in double quotation marks, with only one member per dimension 
allowed. If you list no members from a particular dimension, the function 
returns the data value from the top member of the unspecified dimension. 
Furthermore, you can include aliases in the member list, subject to the 
same rules as member names.

● A worksheet cell reference. The reference must point to a cell that 
contains a valid member name. Member names, such as 200 and 300-10, 
need to be formatted as text cells, rather than numeric cells.

For example, the syntax for the EssCell function in cell B16 in the 
Summary.xls file for Excel is as follows:

=EssCell("Sales", A1, A2, B4, F5)

When you open the worksheet, the values in these cells are #N/A. To update 
the values with the data in your database, you must perform a retrieval from 
Analytic Services.

3. Select Essbase > Retrieve. 

=EssCell(mbrList)
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Analytic Services calculates the EssCell functions in cells B16 and B17.

Figure 112: Retrieval on a Worksheet Containing the EssCell Function

Now update the EssCell functions to retrieve data for a different state.

4. Change the contents of cell A2 from Texas to Florida. 



Performing Advanced Retrieval Tasks

3

■ 159Essbase XTD Spreadsheet Add-in for Excel

The values in cells B16 and B17 are updated as soon as you update the cell. 
The update occurs because Excel has recalculated the worksheet (if you have 
configured Excel to calculate changes automatically). The remaining data 
cells do not change. To completely update the worksheet, you must retrieve 
data from the server.

Figure 113: Updating the EssCell Function

Tip: If the worksheet contains many EssCell functions, change the spreadsheet to 
manual calculation mode. This change prevents the cells that contain EssCell 
functions from calculating until you retrieve data or calculate the worksheet 
manually. For more information on manual calculation mode, see the Excel 
documentation .

5. Select Essbase > Retrieve to update the report.

Analytic Services returns an error message if EssCell is unsuccessful. Table 4 
lists messages that Analytic Services displays in the EssCell cell and explains 
the conditions that cause the messages: 

Table 4: EssCell Messages

Message Reason

#N/A The worksheet is not connected to a database.

#VALUE! A member name in the list or reference is invalid.

#NAME? A text name in the function does not contain double 
quotation marks.
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6. Close the file without saving it.

EssCell functions are already defined in the sample file that you used for this 
tutorial task. 

Note: For more information on EssCell functions, see the Spreadsheet Add-in online 
help.

Retrieving Dynamic Calculation Members
Dynamic calculation members are database members that are excluded from the 
batch calculation process, thus shortening the regular database calculation time. 

The Analytic Services application designer tags dynamic calculation members in 
the database outline so that Analytic Services knows not to calculate those 
members until a data retrieval requests them. This process is referred to as dynamic 
calculation. Dynamically calculating database members benefits Analytic Server 
in the following ways: 

● Reduced disk usage 

● Reduced database restructuring time

● Reduced time to back up the database

This task is optional. Optional tasks do not need to be performed as part of the 
tutorial. They are provided for information only.

In Excel, to enter your own EssCell function into a worksheet:

1. From the Excel menu bar, select Insert > Function.

2. From the Function Category list, select Essbase Add-in.

The Excel Function Wizard instructs you in defining the EssCell function.
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Database values that Analytic Services calculates dynamically take slightly longer 
to retrieve in Spreadsheet Add-in because calculations must be performed before 
retrieving data into the worksheet. For more information on dynamic calculation, 
see the Essbase XTD Analytic Services Database Administrator’s Guide.

Tip: Enable the Navigate Without Data feature while you arrange the spreadsheet 
report so that Analytic Services does not dynamically calculate the database as the 
report is being created. For more information on the Navigate Without Data feature, see 
“Navigating Through the Worksheet Without Retrieving Data” on page 69.

Because there may be a performance impact on retrieving data for dynamic 
calculation members, define visual cues, or styles, for these members so that you 
can identify them in Spreadsheet Add-in. 

As part of the default Analytic Services installation, the Asymm.xls sample file is 
provided that illustrates how to use Dynamic Calculation members. 

➤ To view the Asymm.xls file:

1. Select File > Open.

2. From the\Essbase\client\sample directory, open the Asymm.xls file.

3. Drill up on Actual by double-clicking the right-mouse button in cell C3.

4. In cell C3, drill down on Scenario to display all members of Scenario.

Analytic Services displays only the Scenario members for Qtr1, as shown in 
Figure 114.

Figure 114: Displaying Scenario Members

5. Select Essbase > Options and select the Style tab.

Note: You must be connected to the Sample Basic database to display the Style 
tab. For more information on connecting to a database, see “Connecting to a 
Database” on page 122.
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6. In the Members group box, scroll down until you see Dynamic Calculations.

7. Select the Dynamic Calculations check box and click the Format button.

8. In the Font style list, select Bold Italic.

9. In the Color list, select Gray.

10. Click OK and then select the Display tab.

11. In the Cells option group, click Use Styles. Click OK.

12. Select Essbase > Retrieve.

Analytic Services displays the data and applies all the visual cues, or styles, 
that you set, including the newly set styles for dynamic calculation members 
and the styles you set in Chapter 2. You know that the columns for Variance 
and Variance% are dynamically calculated because Analytic Services displays 
these members in gray, bold, italicized font. (Variance and Variance% both 
display a red background because that style was previously set for all members 
of the Scenario dimension.)

The result is shown in Figure 115.

Figure 115: Result of Retrieving Dynamic Calculation Members

Note: Occasionally, other styles that you have set will override a style for dynamic 
calculation members. For example, if a parent member is also a dynamic 
calculation member, and if you have set styles for both parent and dynamic 
calculations, the style for the parent member overrides the style for the dynamic 
calculation member. You must remove the style for parent members in order to see 
the style for dynamic calculation members. For more information on the 
precedence of styles, see “Precedence of Overlapping Styles” on page 83.

13. Close the Asymm.xls file without saving it.



Performing Advanced Retrieval Tasks

3

■ 163Essbase XTD Spreadsheet Add-in for Excel

Specifying the Latest Time Period for Dynamic Time 
Series

Dynamic Time Series members are predefined database members that are used in 
dynamic, to-date reporting, such as year-to-date or month-to-date values. Dynamic 
Time Series members are not displayed as individual members in the database 
outline; instead, they correspond to a generation name that uses a key term for 
time, such as year, month, or day.

For example, in the Sample Basic database, a generation name called Quarter was 
created for generation 2 in the Year dimension. Generation 2 includes the members 
for Qtr1, Qtr2, Qtr3, and Qtr4. When the generation name Quarter was created, 
Analytic Services created a Dynamic Time Series member called Q-T-D, or 
quarter-to-date.

To take advantage of Dynamic Time Series in Spreadsheet Add-in, choose the 
latest time period for which you want data in a to-date calculation. The calculated 
value of the Dynamic Time Series member is derived when you define the latest 
time period to be reported. 

In the Sample Basic database, for example, the level 0 members of the Year 
dimension are the months of the year: Jan, Feb, Mar, and so on. If the current 
month is August and you want to know the sales data for the quarter up to the 
current month, a quarter-to-date calculation gives you the sales data for the months 
of July and August. 

➤ To illustrate the concept of Dynamic Time Series: 

1. Select File > New or click  to open a new worksheet.

2. Select Essbase > Options and select the Zoom tab.

3. In the Zoom In option group, select Next Level.

4. Clear the Within Selected Group check box and click OK.

5. Select Essbase > Retrieve.

6. In cell B1, drill down on (double-click) Measures.

7. In cell B2, click Year.

8. Type Q-T-D in cell B2 and press Enter to enter a predefined Dynamic Time 
Series member (Q-T-D).
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The result is shown in Figure 116.

Figure 116: Entering a Dynamic Time Series Member into a Worksheet

Note: For a list of other possible Dynamic Time Series members, see the 
Spreadsheet Add-in online help.

9. Select Essbase > Options and select the Display tab.

10. In the Dynamic Time Series group box, select the Latest Time Period check 
box and from the drop-down list box, select May, as shown in Figure 117.

Figure 117: Specifying Latest Time Period in a Dynamic Time Series

Note: If you do not specify a latest time period, Analytic Services uses the first 
level 0 member (Jan) as the default.
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11. Click OK.

12. Select Essbase > Retrieve.

Note: The Retrieve & Lock, Zoom In, and Zoom Out commands are not supported 
with Dynamic Time Series members.

Analytic Services displays data for the Q-T-D member, as shown in 
Figure 118. The data values in the worksheet are the aggregated values for 
April and May, because May is the month that you specified as the latest 
month in the quarter-to-date Dynamic Time Series.

Figure 118: Result of Specifying Latest Time Period in a 
Dynamic Time Series

13. To close the worksheet, select File > Close. 

You do not need to save the worksheet.

In Advanced Interpretation mode, you can also create a report like the one shown 
Figure 118 by typing the name of the Dynamic Time Series member followed by 
the name of the latest time period in parentheses (for example Q-T-D(May)). If 
you are using Free-Form retrieval mode, you must enter the Dynamic Time Series 
member enclosed in quotation marks (for example, "Q-T-D") and the latest time 
period also enclosed in quotes (for example, ("May")) in separate, adjacent cells. 
You can also select a Dynamic Time Series member and a latest time period 
through Essbase Query Designer or through Member Selection.

For more information on Dynamic Time Series, see the Spreadsheet Add-in online 
help.

Using Substitution Variables
The Analytic Services application designer uses substitution variables to define 
global variables to represent values that are specific to Analytic Services. For 
example, Latest can be a substitution variable representing the latest time period 
in a Dynamic Time Series. 
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Using Essbase XTD Administration Services Console, the application designer 
sets substitution variables and their corresponding values for a specific 
application. Analytic Services stores these variables and their values on the 
Analytic Server. You can take advantage of the predefined substitution variables 
in Spreadsheet Add-in during Dynamic Time Series reporting.

For example, say the application designer sets a substitution variable on the server 
for the current month. The variable is called CurMnth and has a value of August. 
If you use the substitution variable in the worksheet, a retrieval returns values for 
August, because August is set as the current month on the server. If, at a later date, 
the application designer changes the value of the CurMnth substitution variable to 
October, a retrieval returns data for October.

The Sample Basic database that you are using for this tutorial does not contain 
predefined substitution variables. If the application designer had set a substitution 
variable in the database that you are using, you could enter a substitution variable 
directly into a worksheet. 

For example, you could open a blank worksheet and type member names, as 
shown in Figure 119. 

Figure 119: Entering a Substitution Variable in a Worksheet

Notice the substitution variable (CurMnth) in cell A2. When you enter a 
substitution variable directly into a cell, you must precede it with an ampersand 
(&). 

In this example, a retrieval produces the results shown in Figure 120.

Figure 120: Result of Retrieval on a Substitution Variable
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Analytic Services queries the server for the value of the substitution variable 
CurMnth, which is August. Data is returned only for August.

Note: If you save a worksheet containing a substitution variable as a template, make 
sure that you save the worksheet before you retrieve data. For example, if you save the 
worksheet shown in Figure 120 as a template, each time you retrieve the template, 
August rather than the substitution variable CurMnth is displayed.

Using Free-Form Reporting to Retrieve Data
So far, you have been shown how to retrieve Analytic Services data into a 
worksheet through ad hoc retrieval, Essbase Query Designer queries, and Member 
Selection operations. In addition to these retrieval methods, Analytic Services 
supports free-form reporting. 

Free-form reporting enables you to tell Analytic Services specifically what you 
want to retrieve by typing data into the worksheet. This free-form of reporting is 
especially useful when you are familiar with the dimensions and members in the 
database outline.

Analytic Services provides two different retrieval modes for free-form reporting:

● Advanced Interpretation

● Free-Form

In both retrieval modes, enter member names directly into the worksheet. The 
following sections describe the similarities and differences between the two 
modes.

Using Advanced Interpretation Mode
Analytic Server server contains an advanced spreadsheet interpretation engine that 
scans a worksheet and interprets its content when fulfilling retrieval requests. 
When you construct a report by entering names directly into a worksheet in 
Advanced Interpretation retrieval mode, Analytic Services interprets the member 
names and creates a default view that is based on the location of the labels.

Keep in mind the following guidelines when you are working in Advanced 
Interpretation mode:

● Precede all member names that consist of numbers with a single quotation 
mark. For example, for Product dimension member 100, type '100 in the 
worksheet. 
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● If you define a report that does not contain all the database dimensions, you 
may need to enter a dummy value, such as 0, in the first data cell. Analytic 
Services overwrites this value with the contents of the database cell upon 
retrieval. Be sure to use a numeric value as the dummy value.

➤ To construct a free-form report in Advanced Interpretation retrieval mode:

1. Select File > New or click   to open a new worksheet.

2. Select Essbase > Options and select the Mode tab.

3. In the Retrieval option group, select Advanced Interpretation (the default 
setting) and click OK.

4. Enter member names and data as shown in Figure 121.

Note: If a member name consists of a number, such as 100, you must precede the 
member name with a single quotation mark (for example, '100). This rule also 
applies to member names with spaces between words.

Figure 121: Creating a New Free-Form Report

5. Select Essbase > Retrieve or double-click a data cell.

Analytic Services retrieves data for the members that you entered into the 
free-form report and implements the Use Aliases option that you set in the 
Essbase Options dialog box in “Setting Essbase Options” on page 124. 

Figure 122: Retrieving Data into a Free-Form Report
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Now define a free-form report that does not contain all the dimensions from the 
database. In Advanced Interpretation mode, you may need to enter a dummy data 
value, such as 0, into the first data cell to indicate to Analytic Services where the 
data starts in the worksheet. Be sure to use a numeric value as the dummy value. 

For example: 

1. Select Essbase > FlashBack.

2. Delete cells A1, B1, and C1.

3. In cell B4, type 0 to provide Analytic Services with a data cell reference point.

Figure 123: Defining a Free-Form Report Without All Dimensions

4. Select Essbase > Retrieve.

Analytic Services adds the dimensions that were omitted from the free-form 
report to the worksheet and retrieves data.

Figure 124: Retrieval in a Free-Form Report Without All Dimensions

5. Select File > Close to close the worksheet. 

You do not need to save the worksheet. 
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Using Free-Form Mode
Similar to Advanced Interpretation mode, Free-Form mode enables you to 
enter member names into any location in a worksheet and then interprets the 
contents of the worksheet when fulfilling the retrieval request. In addition, with 
Free-Form mode, you can use Analytic Services report script commands to 
retrieve data into a worksheet. 

Report script commands are most useful for defining member references that can 
bring back the most current member information dynamically. For example, if you 
need to create a report that shows every product, including the products added 
since the last retrieval, standard retrieval mode reflects changes only when you 
drill down on the product. 

If you use the report script command <IDESCENDANTS, Analytic Services 
retrieves all descendants of a specified member, as well as the specified member. 
For more information on the syntax of report script commands and on guidelines 
for developing reports, see the Technical Reference and the Essbase XTD Analytic 
Services Database Administrator’s Guide.

Keep in mind the following guidelines when working in Free-Form retrieval 
mode:

● You must precede all member names that consist of numbers with a single 
quotation mark. For example, for the Product dimension member 100, you 
must type '100 in the worksheet. 

● You cannot cancel a retrieve in Free-Form mode.

● You cannot apply Analytic Services styles in Free-Form mode.

● Analytic Services removes blank rows and columns on any retrieval action.

● Excel does not support Report Writer formatting commands, such as 
{BRACKETS}, {DECIMAL}, and {EUROPEAN} in Free-Form mode. They 
are incompatible with the Excel formatting features.

● When you are in Free-Form mode, an Auto Sort Rows option is selectable in 
the Display tab of the Essbase Options dialog box. If you select this feature, 
Analytic Services retrieves data in symmetric rows. The rows are sorted 
according to the order specified in the database outline. 

● Not all Formula Preservation and Modes options (Essbase Options dialog box, 
Mode tab) are available in Free-Form mode.
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● To use Dynamic Time Series in Free-Form mode, do not put the 
Dynamic Time Series member and the latest time period (for example, 
"Q-T-D" ("Feb")) in the same cell. You need to type the Dynamic 
Time Series member, "Q-T-D" in one cell, and the latest time period 
within parentheses, ("Feb"), in a separate, adjacent cell.

➤ To construct a free-form report in Free-Form retrieval mode:

1. Select File > New or click  to open a new worksheet.

2. Select Essbase > Options and select the Mode tab.

3. In the Retrieval option group, select Free Form.

4. Select the Display tab.

5. In the Cells option group, select Auto Sort Rows and click OK.

6. Enter the member names into the worksheet as shown in Figure 125.

Figure 125: Typing Member Names In a Free-Form Report

7. Select Essbase > Retrieve.

Analytic Services retrieves data for the members and creates a default view 
according to the location of the labels. Note that in Figure 126, three members 
were pivoted from row groups to column groups.

Figure 126: Result of Retrieving in Free-Form Retrieval Mode 

8. Select File > Close to close the worksheet. 

You do not need to save the worksheet.
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➤ To create a report by entering member names and a report script command:

1. Selecting File > New or click  to open a new worksheet.

2. Enter the member names into the blank worksheet as shown in Figure 127.

Figure 127: Typing Member Names in a Free-Form Report

3. In cell A3, type <IDESCENDANTS Product and press Enter.

Figure 128: Typing a Report Script Command in a Free-Form Report

4. Select Essbase > Retrieve.

Analytic Services retrieves data into the worksheet for all descendants of 
Product and for the members that you entered in the worksheet. The result is 
shown in Figure 129.

Figure 129: Result of a Retrieve with a Report Script Command

Note: When Analytic Services completes the retrieval, the report script command 
is overwritten by the data it returns. You can use FlashBack to restore the previous 
view in Free-Form mode.

5. Select File > Close to close the worksheet. 
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You do not need to save the worksheet.

Using Attributes in Free-Form Reporting
Analytic Services enables you to retrieve data selectively by specifying attributes 
that are associated with a base dimension. For example, in the Sample Basic 
database, the Product base dimension is associated with attributes such as 
packaging and size. You can enter an attribute name into the worksheet to retrieve 
data that is associated with that attribute.

➤ To use attributes in a free-form report:

1. Select File > New or click  to open a new worksheet.

2. Enter member names as shown in the Figure 130. 

Figure 130: Using Attributes in Free-Form Reports

Caffeinated is an attribute dimension associated with the Product base 
dimension. Bottle is a level 0 member of the Pkg_Type attribute dimension. 
The Pkg_Type dimension is associated with the Product base dimension. A 
level 0 member is the lowest level member in a dimension.

3. Click any empty cell and select Essbase > Retrieve or double-click an empty 
data cell.

Analytic Services retrieves information on profits for the first quarter of the 
year for all members of the Product base dimension that are associated with 
both the level 0 attribute members of the Caffeinated attribute dimension 
(Caffeinated_True and Caffeinated_False) and the level 0 member Bottle of 
the Pkg_Type attribute dimension. The results should look like Figure 131.

Figure 131: Result of Using Attributes in Free-Form Reports
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4. You can drill down to data on the level 0 attribute members of the Caffeinated 
attribute dimension. The results should look like Figure 132.

Figure 132: Drilling Down on Attributes in Free-Form Reports

5. To drill down further for data on profits for the first quarter for all members of 
the East base dimension, double-click cell E1. The results should look like 
Figure 133.

Figure 133: Result of Drilling Down on East

Entering Generation and Level Names
In addition to entering database member names into a free-form report, you can 
enter generation or level names directly into a worksheet to retrieve specific 
members. The Analytic Services application designer defines generation and level 
names for database dimensions in the database outline. Two options enable you to 
determine which generation and level names are defined in the database:

● View generation and level names in the Essbase Member Selection dialog box 
or through Essbase Query Designer. 

● Contact the Analytic Services application designer to see which generation 
and level names are defined in the database outline.
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➤ To enter generation and level names directly into a free-form report:

1. Select File > New or click  to open a new worksheet.

2. Select Essbase > Options and select the Mode tab.

3. In the Retrieval option group, select Advanced Interpretation. Click OK.

4. Enter member names as shown in Figure 134.

Figure 134: Entering Member Names in a Free-Form Report

5. Enter a generation name as shown in Figure 135.

Family is a generation name in the Product dimension. The name is already 
defined in the Sample Basic database.

Figure 135: Entering a Generation Name in a Free-Form Report

6. Select Essbase > Retrieve.

Analytic Services retrieves data for the member and generation names that 
you entered. The Family generation name expands to its individual members. 
The result is shown in Figure 136.

Figure 136: Result of Free-Form Retrieval with Generation Name
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7. Change Year to a level name (Lev0,Year) as shown in Figure 137. 

Figure 137: Entering a Level Name in a Free-Form Report

Note: Do not insert a space between the comma after 0 and the word Year. 
Generation and level names that are entered directly into a worksheet must be 
precise.

8. Select Essbase > Retrieve.

As shown in Figure 138, Analytic Services retrieves data for the level 0 
members of the Year dimension, which are the individual months (Jan, Feb, 
Mar, and so forth).

Figure 138: Result of Free-Form Retrieval with Level Name

9. Select File > Close to close the worksheet. 

You do not need to save the worksheet.
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Using Linked Reporting Objects
A linked reporting object is an external file, cell note, or World Wide Web resource 
that you link to a cell in an Analytic Services database. The file, note, or Web 
resource (indicated by a URL, or Uniform Resource Locator) can then be retrieved 
by the Spreadsheet Add-in users who have access to the database.

Note: If your organization has licensed and implemented the Essbase Partitioning 
option, you can also access linked partitions from cells in Spreadsheet Add-in. For more 
information on linked partitions, see “Ways to Access Linked Partitions” on page 192.

In this topic, the following procedures are discussed:

● “Linking a File to a Data Cell” on page 177

● “Linking a Cell Note to a Data Cell” on page 181

● “Linking a URL to a Data Cell” on page 182

● “Accessing and Editing Linked Reporting Objects” on page 185 

For additional information on using linked reporting objects, see the Spreadsheet 
Add-in online help.

Linking a File to a Data Cell
Using the linked reporting objects feature, you can link an external file to a data 
cell in Spreadsheet Add-in. Analytic Services stores the file on the Analytic 
Server. Users who have access to the database can then retrieve the file and view 
the data contained in the cell. 

The following example uses the Asymm.xls sample worksheet with data from the 
Sample Basic database. It links a sample file, Budasmp.txt, to a cell containing 
the Budget figure. Budasmp.txt details the budgetary assumptions for the 
current year.

➤ To link a file to a data cell:

1. Select File > Open.

2. From the\essbase\client\sample directory, open the Asymm.xls file.

3. Make sure that you are connected to the Sample Basic database. 

If you are not connected, see “Connecting to a Database” on page 122.
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4. Select cell D5, as shown in Figure 139. 

Note: You can link objects only to data cells, not to cells containing member 
names.

Figure 139: Selecting a Data Cell for Linking an External File

5. Select Essbase > Linked Objects.

Analytic Services displays the Linked Objects Browser dialog box, as shown 
in Figure 140.

Figure 140: Linking a File

6. In the Linked Objects Browser dialog box, click the Attach button.

Analytic Services displays the Attach Linked Object dialog box.
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7. Under the Attachment Type group box, select File, as shown in Figure 141.

Figure 141: Linking a File to a Data Cell

8. Click the Browse button located next to the File Name text box. 

Analytic Services displays the Browse Files dialog box.

9. Go to the\Essbase\client\sample directory and select the 
Budasmp.txt file. 

10. Click Open.

11. Under File Description, enter a brief description for the file as indicated in 
Figure 142.

Figure 142: Selecting and Describing a File to Link

Note: Entering text in the File Description text box is optional.
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12. Click OK to close the dialog box and link the file to the cell.

Analytic Services copies the file to the server and establishes a link to the 
current data cell.

13. Click Close to close the Linked Objects Browser dialog box.

Do not close the Asymm.xls file. You use the file in the next tutorial task.

To recognize cells that have linked reporting objects attached to them, you may 
want to apply a visual cue, or style, to the cells. 

➤ To apply styles:

1. Select Essbase > Options and select the Style tab.

2. In the Data Cells area, select Linked Objects.

3. Click Format.

4. From the Font style list box, select Italic. 

5. From the Color list box, select Purple. Click OK.

6. Select the Display tab.

7. In the Cells option group, select the Use Styles box and click OK.

8. Select Essbase > Retrieve to refresh the worksheet and apply the styles.

Cell D5 (the cell to which you just attached the linked file) is now displayed 
in purple, italic font, as shown in Figure 143. Analytic Services also refreshes 
the worksheet with the other options set in the Essbase Options dialog box. 

Figure 143: Result of Applying a Style to a Linked Reporting Object Cell

Leave the file (Asymm.xls) open for the next tutorial task. 
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Linking a Cell Note to a Data Cell
In addition to linking external files to a data cell in Spreadsheet Add-in, you can 
also link individual cell notes that contain information on particular data cells. Cell 
notes can consist of no more than 599 characters. If you need to link information 
to a data cell that is longer than 599 characters, you must create and save an 
external file and then link the file to the data cell. 

➤ To link a cell note to a data cell:

1. In the Asymm.xls file, select cell C5. 

Note: You can link objects only to data cells, not to cells containing member 
names.

2. Select Essbase > Linked Objects.

Analytic Services displays the Linked Objects Browser dialog box. 

3. In the Linked Objects Browser dialog box, click Attach.

Analytic Services displays the Attach Linked Object dialog box.

4. Under the Attachment Type group box, select Cell Note (see Figure 144).

5. In the Cell Note text box, type the note as indicated in Figure 144. 

Figure 144: Creating a Cell Note to Link 

6. Click OK to close the dialog box and link the cell note.

Analytic Services copies the note to the server and establishes a link to the 
current data cell. 
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7. Click Close to close the Linked Objects Browser dialog box.

8. Select Essbase > Retrieve to refresh the worksheet and apply the style that 
you defined for linked objects.

Now Analytic Services displays two data cells (C5 and D5) in purple, italic 
font to represent a cell that contains a linked reporting object. The result is 
shown in Figure 145.

Figure 145: Result of Creating a Linked Cell Note

Leave the Asymm.xls file open for the next tutorial task. 

Linking a URL to a Data Cell
A URL is an address string that identifies resources on the World Wide Web, such 
as documents, images, and downloadable files. With the linked reporting objects 
feature, you can link a URL to a data cell so that users who have access to the 
database can link directly to the specified URL. When you access the cell from 
Spreadsheet Add-in, your default Web browser opens and displays the specified 
URL.

Note: For more information on URL syntax, see the Spreadsheet Add-in online help.

If you have a Web browser and Internet access, follow these steps to link a data cell 
to the Hyperion Web site: 
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1. In the Asymm.xls file, select cell E5, as shown in Figure 146.

Note: You can link objects only to data cells, not to cells containing member 
names.

Figure 146: Selecting a Data Cell for Linking to a URL

2. Select Essbase > Linked Objects.

Analytic Services displays the Linked Objects Browser dialog box.

3. In the Linked Objects Browser dialog box, click Attach.

Analytic Services displays the Attach Linked Object dialog box.

4. Under the Attachment Type option group, select URL, as shown in 
Figure 147.

Figure 147: Linking a URL to a Data Cell
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5. Enter a URL in the Location text box and a brief description in the URL 
Description text box, as shown in Figure 148.

Figure 148: Entering and Describing a URL to Link

Entering text in the URL Description text box is optional. The text field for 
entering the URL location is limited to 512 characters. The text field for 
entering the URL description is limited to 80 characters.

6. Click OK to close the dialog box and link the URL to the cell.

Analytic Services copies the URL string to the server and establishes a link 
to the current data cell.

Note: The syntax for the URL is not checked at the time of creation; Analytic 
Services checks the syntax when the user accesses the URL from the worksheet. 
The default Web browser checks for the existence, or validity, of the URL.

7. Click Close to close the Linked Objects Browser dialog box.

8. Select Essbase > Retrieve to refresh the worksheet and apply the style that 
you defined for linked objects.

Leave the Asymm.xls file open for the next tutorial task.

The following topics explain how to access linked reporting objects from 
Spreadsheet Add-in.
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Accessing and Editing Linked Reporting Objects
Two options are available for accessing and editing a linked reporting object that 
is attached to a data cell:

● Select the cell (as identified by the style applied to it) and select 
Essbase > Linked Objects. 

● Enable double-clicking for linked object browsing.

Note: If you enable double-clicking for linked object browsing, double-clicking behavior 
changes for retrieving data and performing drill actions. For more information on these 
changes, see the Spreadsheet Add-in online help.

For this tutorial, you access the linked reporting objects that you created in the 
previous sections by using the Essbase menu item instead of the double-clicking 
action.

Accessing a Linked File
Sometimes you want to check an external file that is linked to a data cell.

➤ To access the external file that you previously linked to a data cell: 

1. In the Asymm.xls file, select cell D5.

2. Select Essbase > Linked Objects.
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3. In the Linked Objects Browser dialog box, select the Budasmp.txt file, as 
shown in Figure 149. 

Figure 149: Accessing a Linked External File

4. Click View/Launch to view the linked file.

The Budasmp.txt file is opened from the source application, as shown in 
Figure 150.

Figure 150: Viewing the Contents of a Linked External File

Note: You can edit the contents of a file in the source application. After the edits 
are made and the file is saved, you can re-attach the edited file by clicking the Edit 
button in the Linked Objects Browser dialog box. Analytic Services displays the 
Re-attach Linked Object dialog box, which you can use to re-attach, or relink, the 
edited file to the data cell. 
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5. Close the Budasmp.txt file and click Close to close the Linked Objects 
Browser dialog box.

Leave the Asymm.xls file open for the next task.

Accessing a Linked Cell Note
Sometimes you have to edit a cell note that was previously created.

➤ To access and edit the cell note that you previously created: 

1. In the Asymm.xls file, select cell C5. 

2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the cell note that is linked to 
the selected data cell. 

3. In the Linked Objects Browser dialog box, select the cell note, as shown in 
Figure 151.

Figure 151: Accessing a Linked Cell Note

4. Click Edit to edit the contents of the cell note.
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Analytic Services displays the Edit Cell Note dialog box with the selected cell 
note displayed, as shown in Figure 152.

Figure 152: Editing the Contents of a Linked Cell Note

If you simply want to view the contents of the cell note, click the View/Launch 
button instead of the Edit button in the Linked Objects Browser dialog box.

5. Edit the contents of the cell note as indicated in Figure 153.

Figure 153: Result of Editing Cell Note Contents

6. Click OK to close the Edit Cell Note dialog box and save the edits you made 
to the note. 

Analytic Services saves the edits to the cell note on the server.

7. Click Close to close the Linked Objects Browser dialog box.

Leave the file (Asymm.xls) open for the next tutorial task.
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Accessing a Linked URL
If you followed the steps in “Linking a URL to a Data Cell” on page 182, you can 
access and edit the URL that you created.

➤ To access the URL:

1. In the Asymm.xls file, select cell E5. 

2. Select Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the URL that is linked to the 
selected data cell. 

3. In the Linked Objects Browser dialog box, select the URL, as shown in 
Figure 154.

Figure 154: Accessing a Linked URL

4. Click View/Launch to view the linked URL.

Analytic Services checks the syntax of the URL. If there are syntax errors, 
Analytic Services displays an error message. If the URL syntax is correct, the 
default Web browser launches and connects to the specified site. In this case, 
the syntax for the URL is correct, so the default Web browser launches and 
connects to the Hyperion Web site.

5. Close the Web browser.
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➤ To edit the URL: 

1. In the Linked Objects Browser dialog box, select the URL.

2. Click Edit.

Analytic Services displays the Edit URL dialog box with the selected URL 
displayed in the Location text box, as shown in Figure 155.

Figure 155: Preparing to Edit the Contents of a Linked URL

3. Edit the URL location and description as shown in Figure 156.

Figure 156: Editing the Contents of a Linked URL 

4. Click OK to close the Edit URL dialog box and save the edits that you made. 

Analytic Services saves the edits to the URL on the server.

5. Click View/Launch to view the new URL.

The Web browser launches and connects to the new URL.

6. Close the Web browser.

7. Click Close to close the Linked Objects Browser dialog box. 

8. Close the Asymm.xls file without saving it.
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Connecting to Multiple Databases
Analytic Services supports simultaneous access to multiple databases. The 
databases can be in different applications and can be stored on different servers. In 
the spreadsheet application, you can open multiple worksheets, each of which can 
be connected to a different database. An individual worksheet can access only one 
database at a time. Use the Connect command from the Essbase menu to switch the 
connection between databases.

Note: Depending on the status of production applications at your site, you may not 
have access to additional applications or databases. Contact the Analytic Services 
system administrator if you need access to other applications.

For this tutorial, you do not need to connect to another database.

This task is optional. Optional tasks do not need to be performed as part of the 
tutorial. They are provided for information only.

To access multiple databases:

1. Select Essbase > Connect.

2. In the Essbase System Login dialog box, select the server that you want 
to access from the Server list box (or type in the name of the server).

3. Press Tab to move to the Username text box and type your username. 

4. Press Tab to move to the Password text box and type your password. 

5. Click OK to connect to the server.

When the server connection is complete, a list of available application and 
database pairs is displayed in the Application/Database list. 

6. Double-click the Application/Database pair that you want to connect 
to in the Application/Database list. Alternatively, you can select the 
Application/Database pair and click OK.

If the application is not already running, Analytic Services automatically starts 
it. There may be a brief pause as the application loads; the time required to 
start an application depends on the number of databases, the sizes of the 
databases, and the sizes of the indexes of the databases contained within the 
application.

7. Open a new worksheet and repeat the steps to connect to additional databases. 
You can open one database at a time per worksheet.
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For information on connecting to multiple databases from Essbase Query 
Designer, refer to Chapter 2.

Ways to View Active Database Connections
If you frequently connect to multiple databases, you may need to check the active 
database for each worksheet. You can view the database connection status in two 
ways:

● The Style tab of the Essbase Options dialog box contains a Connection 
Information text box. This box displays connection information for the active 
worksheet.

● The Essbase Disconnect dialog box lists all active worksheets and their 
connection information. This dialog box also enables you to disconnect one or 
more worksheets from their respective databases.

Ways to Access Linked Partitions
Linked partitions are part of the Essbase Partitioning product. They provide 
the ability to link Analytic Services databases that contain different dimensions 
without losing access to all dimensions of both databases. If your organization 
has purchased and implemented the partitioning product, you can take advantage 
of its capabilities. The Essbase XTD Analytic Services Database Administrator’s 
Guide describes how to design and implement a linked partition. The Analytic 
Services application designer usually sets up partitioning.

Note: The Partitioning product also enables the Analytic Services application designer 
to set up transparent or remote partitions. For more information on partitioning, see the 
Essbase XTD Analytic Services Database Administrator’s Guide.

You can set visual cues, or styles, for cells tagged as linked objects. These cells 
are access points to the linked partition within the linked database. Two options are 
available for accessing a linked partition from a data cell in Spreadsheet Add-in:

● Select the cell and select Essbase > Linked Objects. 

● Enable double-clicking for linked object browsing.

If you enable double-clicking for linked object browsing, double-clicking 
behavior changes for retrieving data and performing drill actions. For more 
information on these changes, see the Spreadsheet Add-in online help.



Ways to Access Linked Partitions

3

■ 193Essbase XTD Spreadsheet Add-in for Excel

When you select Essbase > Linked Objects from a linked partition cell, Analytic 
Services completes the following actions: 

● Analytic Services displays the Linked Objects Browser dialog box, which 
contains a list of possible partitions which you can access. From this dialog 
box, select the partition to connect to. 

The Linked Objects Browser dialog box may also contain a list of linked 
reporting objects, such as cell notes and external files. For more information 
on linked objects, see “Using Linked Reporting Objects” on page 177.

● After you select a partition, Analytic Services creates a new worksheet that 
contains corresponding members and dimensions for the cell in the linked 
partition.

Note: Analytic Services does not preserve formulas across partitions. 

● Analytic Services retrieves data values from the linked partition.

You can now perform operations such as drill down and drill up to get more 
information on the new worksheet.

Note: The Sample Basic database that you are using for this tutorial does not contain 
a linked partition. However, the instructions for accessing a linked partition are shown 
as an optional task in the light-colored box below.

This task is optional. Optional tasks do not need to be performed as part of the 
tutorial. They are provided for information only.

To access a linked partition in Spreadsheet Add-in if the Analytic Services 
application designer has set up a linked partition:

1. Locate a linked object cell, as indicated by the style applied to the cell.

2. Access the Linked Objects Browser dialog box in either of these ways:

– Select Essbase > Linked Objects to open the Linked Objects Browser 
dialog box.

– In the Essbase Options dialog box, select the Enable Linked Object 
Browsing check box to enable double-clicking to view linked objects.

3. Select the partition that you want to connect to and click View/Launch.

Analytic Services creates a new worksheet that contains the dimensions and 
members for the cell in the linked partition.



194 ■

An Advanced Tutorial

Essbase XTD Spreadsheet Add-in for Excel

You need the proper privileges to access a linked partition. If your user account and 
password match the account information for the linked partition, Analytic Services 
establishes a connection with the linked partition. Otherwise, Analytic Services 
displays the Essbase System Login dialog box for you to enter the user account and 
password manually.

Updating Data on the Server
Data values are changed frequently in applications that involve planning, 
budgeting, and forecasting. After you retrieve data into the worksheet, you 
can use Spreadsheet Add-in to change values, enter formulas, and format 
data. Analytic Services is also designed to permit multiple-user, concurrent 
database access and update. 

Depending on your security privileges, you may be able to modify all data values 
or a certain subset of values. To recognize cells to which you have read/write 
access, apply a visual cue, or style, to the cells. For more information on applying 
styles, see “Applying Styles to Data Cells” on page 82. 

To update data from a worksheet, you must lock the database area that contains the 
values that you want to change. Locking prohibits other users from changing the 
data that you want to update. Other users can retrieve locked data but cannot lock 
or change the data. You have exclusive update rights to that area.

Note: You cannot update attribute-related data on the server because attribute data is 
always calculated dynamically and, hence, is not saved.

You can lock data values in three ways:

● The Retrieve & Lock command retrieves data into the worksheet while 
locking the corresponding data area on the server. When you perform a 
subsequent retrieval, Analytic Services automatically unlocks the previous 
data values.

Note: The Retrieve & Lock command is not supported with Dynamic Time Series 
members.

● The Lock command locks information that you have already retrieved. When 
you perform a subsequent retrieval, Analytic Services automatically unlocks 
the previous data values.

● The Update Mode check box in the Mode tab of the Essbase Options dialog 
box automatically locks the corresponding database area for each retrieval.
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To update the server with data values from the worksheet, use the Send command 
on the Essbase menu. After updating the server, the Send command automatically 
unlocks data (unless you are in Update Mode). You must clear Update Mode to 
stop the automatic locking of blocks.

You can unlock data blocks in two ways:

● The Unlock command unlocks all blocks that you have locked.

● The server automatically unlocks data blocks that have been locked for the 
maximum time allowed as defined by the Analytic Services system 
administrator. Automatic unlock ensures that blocks are not locked for 
extended periods of time.

The P&l.xls file is installed as part of the default Analytic Services installation. 
This file illustrates how to update data on the server. 

➤ To view the P&l.xls worksheet:

1. Select File > Open.

2. From the\Essbase\client\sample directory, open the P&l.xls file.

3. Select Essbase > Retrieve & Lock.

Analytic Services retrieves data and locks the appropriate area of the database, 
as shown in Figure 157.

Figure 157: P&L Worksheet After Retrieve & Lock

4. Change the value for Sales in Jan (cell B12) to 4000 and press Enter.
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Analytic Services changes the affected data values.

5. Select Essbase > Send to update the server with the new values.

Analytic Services updates the server and unlocks the data blocks. 

Figure 158: P&L Worksheet After Sending New Values to the Server

6. Close P&l.xls without saving it.

Analytic Services provides a spreadsheet sheet update logging feature that tracks 
and logs all data updates sent from Spreadsheet Add-in to the server. The Analytic 
Services system administrator enables this feature for extra protection against data 
loss. For more information on spreadsheet update logging, see the Essbase XTD 
Analytic Services Database Administrator’s Guide or contact the Analytic 
Services system administrator. 

Database Calculation
Sending updated data to the server does not automatically recalculate the database. 
If you have the appropriate security privileges to perform database calculations, 
you can calculate the database from Spreadsheet Add-in with the Calculation 
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command. For this tutorial, you will not actually calculate the Sample Basic 
database. For more information on Analytic Services calculations, see the Essbase 
XTD Analytic Services Database Administrator’s Guide.

CAUTION: Do not perform any calculation operations for this tutorial.

When you select Essbase > Calculation, Analytic Services displays the Essbase 
Calculation dialog box, as shown in Figure 159.

Figure 159: Essbase Calculation Dialog Box 

The Essbase Calculation dialog box contains the following items:

● The Connection Information text box displays the active database connection.

● The Select Calc Script list box contains the server-based calculation scripts to 
which you have access.

● The Database State status box indicates the current calculation state of the 
database. The following states are possible:

– Calculating

Indicates that a calculation is currently running on the database.

– Data values have been modified since the last calculation
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Indicates that data values have changed since the database was last 
calculated. The last calculation may have been an entire calculation of the 
database or a calculation of any subset of the database.

– No data values have been changed since the last calculation

Indicates that the data in the database has not changed since it was last 
calculated. The last calculation may have been an entire calculation of the 
database or a calculation of any subset of the database.

CAUTION: If the last calculation was performed on a subset of the data, 
the entire database may not have been calculated since values last 
changed. To ensure that the results of calculations are up-to-date, 
you may want to run a calculation of the entire database. For more 
information, contact the Analytic Services system administrator.

Creating Multiple Worksheets from Data
One frequent requirement of budgeting and planning applications is to send 
worksheets to various functional areas of an organization. After the worksheets 
have been distributed, the recipients can review the contents, make modifications, 
and send updates back to the distributor. 

Using the Essbase Cascade feature, you can create multiple worksheet files based 
on a single database view. You can specify at what level of detail you want to 
replicate the worksheets to tailor the information to each recipient’s needs.

The Sample Basic database contains data for beverage products sold in different 
states across the U.S. For example, assume that you want all product managers to 
review and respond to a proposed budget and to return their changes to the finance 
department. You must create a worksheet for each combination of budget and P&L 
data to distribute to the product managers for their respective products.

➤ To create this set of worksheets:

1. Select File > Open. 

1. From the\Essbase\client\sample directory, open the P&l.xls file. 

This file contains the data that you need to replicate for each worksheet.

2. Select Essbase > Retrieve.
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Notice that the retrieval uses the Use Aliases option, which is already set for 
this file in the Essbase Options dialog box. In this example, product 200 
changes to Root Beer, which is its preassigned alias.

3. Select Central (in cell B1) and Root Beer (in cell B2) as the members to be 
represented in the resulting worksheets. 

4. Select Essbase > Cascade. 

Analytic Services displays the Essbase Cascade Options dialog box.

5. Click the Cascade Information tab.

The Cascade Information page contains the list of members that you selected 
and the options for specifying the level at which the selected members are 
retrieved into the cascaded worksheets.

For more information on each option, see the Spreadsheet Add-in online help.

6. Select Central in the Member list box, and select Same level in the Choose 
Level for Selected Member option group.

7. Select Root Beer in the Member list box, and select Next level (the default 
setting), as shown in Figure 160.

Figure 160: Cascade Information Tab

The replicated, or cascaded, spreadsheet reports now provide data for 
members at the same level as Central (East, West, and South) and for members 
at the level below Root Beer (Old Fashioned, Diet Root Beer, Sarsaparilla, and 
Birch Beer).
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8. Click the Destination Options tab.

9. In the Destination Directory text box, type C:\temp as the name of the 
directory where you want the cascaded worksheets to be stored.

You can also click Browse to select a destination directory from the Browse 
dialog box.

10. In the Destination Types group box, select the Separate Workbooks option 
(the default setting) to create separate spreadsheet files for each cascaded 
worksheet.

You can also choose to create only one workbook with separate worksheets for 
each cascaded report, or you can choose to send the cascaded reports to the 
printer.

11. In the File Information group box, select the Overwrite Existing Files check 
box (the default setting). 

When this check box is selected, Analytic Services overwrites any cascaded 
worksheets with the same file name. 

You can also select the Open Created Files check box to open each cascaded 
file in the spreadsheet as it is created. 

CAUTION: Depending on the number of replicated worksheets that you 
want to create, the Cascade command can create more worksheets than 
can be stored in the memory of your computer. Therefore, the Open 
Created Files option should not be used when you are replicating large 
numbers of worksheets.

12. In the Naming Information group box, type BUD in the Prefix text box.
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The completed Destination Options tab should look like Figure 116.

Figure 161: Destination Options Tab

When you assign a prefix or suffix in the Naming Information group box, the 
worksheet files that are generated as a result of executing the Cascade 
command are named with the prefix or suffix that you specify. The default 
is to generate worksheet names that are numbered 1 through n, where n 
is the total number of worksheets created. 

The syntax for the file names is PrefixnSuffix.xls for Excel. If you do not 
specify a prefix or suffix, Analytic Services creates the worksheets 1.xls, 
2.xls, and so on. If you are creating a single workbook, the same naming 
convention is used for the worksheet tab names within the workbook.

CAUTION: Do not specify a prefix and suffix combination that leaves no 
characters free for Analytic Services to create unique file names. If file 
names are duplicated, Analytic Services overwrites the duplicate file name 
with the last cascaded worksheet.
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13. Click the Format Options tab, as shown in Figure 167. 

Figure 162: Format Options Tab

14.  Select the Copy Formatting check box to copy the formatting of the source 
worksheet into each cascaded worksheet. 

Copy formatting copies only the visual cues set using Analytic Services and 
the cell formatting that you set using the worksheet. It does not copy formulas, 
column formatting, worksheet formatting, or graphs. 

15. In the Header and Footer text boxes, specify a header or footer name to be 
used for all of the cascaded worksheets.

16. In the Sheet Formatting group box, select the Suppress Missing Rows check 
box so that rows containing only #Missing values are not replicated.

17. In the Table of Contents group box, select the Include Table of Contents 
check box.

This creates a Table of Contents text file that lists all replicated worksheets, 
their creation dates, and their member content. By default, Analytic Services 
names the Table of Contents file with the extension .lst.

18. Click OK to create the cascaded worksheets.

Analytic Services rapidly creates the cascaded worksheets. As each worksheet 
is created, it is automatically saved, closed, and logged in the Table of 
Contents. Each individual file is saved in the directory that you specified, 
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named Bud1.xls through Bud10.xls. When the Cascade is completed, 
Analytic Services returns you to the original worksheet view (that is, the 
source file). 

19. Using a text editing application, open the Table of Contents file from the 
destination directory that you specified earlier. This file is named BUD0.LST 
and contains a list of all cascaded worksheets, as shown in Figure 163.

Figure 163:  Table of Contents File for Cascaded Worksheets

20. Select File > Close to close the worksheet. 

You do not need to save the worksheet.

You can create multiple worksheet files based on the attributes of a product. Type 
in the attribute names in the top row of the worksheet. Select the attribute names 
and select Essbase > Cascade. Proceed as previously described.

Working with Currency Conversions
Organizations with offices in different countries generally do business in the 
currency of the host country (known as the local currency). Such organizations 
must convert data entered in local currencies to a common currency for 
consolidation and analysis. 

The Analytic Services currency conversion product can be purchased separately 
for Analytic Services. If your organization purchased this product and 
implemented a currency conversion application, you can take advantage of the 
capabilities of Analytic Services Currency Conversion. The Essbase XTD Analytic 
Services Database Administrator’s Guide describes how to design and implement 
a currency conversion application.
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The following topics provide a brief tutorial for working with currency 
conversions:

● “Retrieving Currency Conversion Data” on page 204

● “Connecting to the Sample Currency Databases” on page 205

● “Performing Ad Hoc Currency Reporting” on page 207 

Retrieving Currency Conversion Data
This topic focuses on basic currency conversion concepts, including the Currency 
Report command. 

A currency conversion application consists of two databases: 

● A main database that contains data in local and converted values 

● A currency rates database that contains exchange rates

Apply exchange rates from the currency rates database to local values from 
the main database to derive converted values. The Analytic Server product 
installation includes a sample currency conversion application (installation 
options) that consists of two sample databases: a main database called Interntl 
and a currency rates database called Xchgrate. 

The Sample Interntl database consists of five dimensions: Year, Measures, 
Product, Market, and Scenario. All but the Market and Scenario dimensions 
are identical to the Sample Basic database. 

The Market dimension includes Toronto, Vancouver, Montreal, Germany, Sweden, 
Switzerland, and the UK. The Scenario dimension handles different currency types 
(such as Actual and Budget) in both local and converted currencies. In this 
database, all local currencies are converted to the common currency of U.S. 
dollars.

The Sample Xchgrate database, which is a subset of the main database, contains 
four dimensions:

● The CurTime dimension accommodates different exchange rates by month.

● The CurName dimension contains names of currencies from their respective 
markets.
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● The CurCategory dimension contains the names of the various currency 
categories that may be applied to the categories of Measures. For example, one 
rate is applied to Profit and Loss items and another rate is applied to Balance 
Sheet items.

● The CurType dimension enables a currency database to contain rates for 
different scenarios, such as Actual and Budget.

Connecting to the Sample Currency Databases
To complete the following exercises, the Sample Interntl and Sample Xchgrate 
databases must be installed on the server. Contact the Analytic Services system 
administrator if these application and database pairs are unavailable.

➤ To retrieve data from the Sample Interntl database:

1. Select Essbase > Connect.

2. Select the Sample Interntl database and click OK to complete the connection.

The Analytic Services installation also includes sample spreadsheet files that 
illustrate currency conversion concepts. 

3. From the\Essbase\client\sample directory, open Local.xls.

The worksheet contains actual (Act) and budget (Bud) data entered in local 
currencies for New York and Germany, as shown in Figure 164.

Figure 164: Retrieving Local Data

4. From the\Essbase\client\sample directory, open Convert.xls. 

5. Select Essbase > Retrieve.
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The worksheet contains values for Actual and Budget as they are displayed 
after conversion.

Figure 165: Retrieving Converted Data Values

The worksheet contains data that is converted to U.S. dollars. Values for New 
York remain the same, but German values are converted. Analytic Services 
converts the values by using the exchange rates from the Sample Xchgrate 
database.

6. From the\Essbase\client\sample directory, open Rates.xls.

7. Connect to the Sample Xchgrate database.

8. Select Essbase > Retrieve.

The portion of the result is shown in Figure 166.

Figure 166: Retrieving Exchange Rates from a Currency Database

The worksheet contains all possible combinations of exchange rate scenarios, 
categories, and types by month. Because this example converts to U.S. dollars 
(USD), the sample file contains a base rate of 1 for USD. Therefore, the local and 
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converted figures remain the same for New York. Analytic Services converts the 
figures for Germany, however, by using data values in the currency database, as 
follows:

● Analytic Services divides data values from Actual by values in the Act xchg 
currency type. 

● Analytic Services divides data values from Actual @ Bud xchg by values in 
the Bud xchg currency type. 

● Analytic Services divides data values from Budget by values in the Bud xchg 
currency type. 

● Analytic Services bases all figures in Convert.xls on the CurCategory of 
P&L and the CurTime of Jan.

Note: A conversion can be defined as a multiplication or division operation on 
exchange rates. The definition is determined by the application designer.

Performing Ad Hoc Currency Reporting
A main database, such as Sample Interntl, usually contains values that are 
converted and stored in the database. You may want to perform currency 
conversions dynamically, as well. Analytic Services provides this capability 
with the Currency Report command. This command enables you to interactively 
change the currency rates and types applied to the retrieval. 

➤ To perform an ad hoc conversion on data in the Convert.xls file:

1. From the\Essbase\client\sample directory, open Convert.xls.

The worksheet contains data that is already converted to U.S. dollars.

2. Select Essbase > Connect and connect to the Sample Interntl database.

3. Select Essbase > Retrieve.

4. Select Essbase > Currency Report. 
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Analytic Services displays the Essbase Currency Report dialog box, as shown 
in Figure 167.

Figure 167: Essbase Currency Report Dialog Box

The Essbase Currency Report dialog box enables you to modify the exchange 
rates applied to the retrieval interactively. The box contains options for 
currency settings, names, categories, and years. For more information on these 
options, see the Spreadsheet Add-in online help.

Note: The dimension names CurName, CurType, and CurCategory are default 
names for a currency database. The application designer can use different names 
for any of these dimensions.

5. Select the currency settings that you want to apply. 

For example, select CAD from the CurName drop-down list and Bud xchg 
from the CurType drop-down list.

6. Click Apply to apply the settings.

7. Select Essbase > Retrieve to refresh the data in the worksheet with the results 
of the ad hoc conversion.
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In the example shown in Figure 168, Analytic Services converted the New 
York and Germany figures to Canadian dollars (CAD).

Figure 168: Performing an Ad Hoc Currency Conversion

8. Click the Clear button in the Essbase Currency Report dialog box to make 
currency reporting unavailable and return to standard retrieval mode.

Performing a currency report retrieval does not change values in the database. 
The process performs a temporary conversion as part of the retrieval. 
Converted data values may not always balance, because the ad hoc conversion 
is performed on values that were previously calculated or previously 
consolidated in another currency.

If values must balance and be verified, they must be converted to the target 
currency in the database, calculated, and retrieved. This procedure differs from the 
ad hoc currency conversion retrievals described in this section.
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4

Chapter

4
Using Drill-Through

Essbase XTD Integration Services is a product that works with Essbase XTD 
Analytic Services and Essbase XTD Spreadsheet Add-in for Microsoft Excel. 
Integration Services is a suite of tools and data integration services that serves as 
a bridge between relational data sources and Analytic Server. Drill-through is one 
of these tools. Drill-through enables you to view and customize spreadsheet 
reports that display data retrieved from relational databases. Your organization 
must license Integration Services for you to use the drill-through tool.

This chapter provides the following information:

● A brief overview of the drill-through feature

● A description of the sample database, spreadsheet file, and drill-through report 
used for the tutorial

● A tutorial that guides you through tasks for using drill-through 

About Drill-Through
Despite the benefits of the multidimensional database for storing analytic data, 
some data elements required for analysis are better suited to the relational structure 
of a relational database. 

The scope of data residing in an Analytic Services database is typically at a 
summary level, where data is summarized and calculated for planning and 
analysis. Detailed, transactional data usually is not examined during the planning 
and analysis of a business. 

For example, you might use Analytic Services to analyze retail sales for the first 
quarter in the Eastern region. Detailed data, such as a list of customers who 
purchased a particular product in a particular size, is unnecessary during the 
normal course of analyzing business performance. As you analyze sales results, 
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however, you may want to view more detailed information. Drill-through enables 
you to drill from the summarized and calculated data stored in Analytic Server of 
your organization into detailed data stored in a relational database.

The database administrator predefines a data mapping for you from Analytic 
Services to the relational source. For example, the Analytic Services members 
East, West, South, and Central might map to a field called Region in a relational 
database. As you navigate through data in the spreadsheet, Analytic Services can 
detect how the current data maps to the relational source. For example, suppose 
you select cell G4 in Figure 169.

Figure 169: Example of a Drill-Through Sheet

The dimensional attributes of the cell are as follows: Actual, Profit, New York, 
Feb, and Product. The combination of one or more of these attributes becomes the 
basis for a drill-through query that returns data from the relational source. 

From Spreadsheet Add-in, you can access a predefined drill-through report that is 
based on the dimension or member intersections of Analytic Services data cells in 
the sheet. Using Essbase XTD Integration Services Console, an administrator at 
your organization sets up drill-through reports for you to access; that is, each 
drill-through report is already defined in terms of what to retrieve from the 
relational source.
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In Spreadsheet Add-in, you can access drill-through reports from the Linked 
Objects Browser dialog box, as shown in Figure 170. When you select a 
drill-through cell in the sheet and select Essbase > Linked Objects, the Linked 
Objects Browser dialog box displays a drill-through entry that you can select and 
launch. 

Figure 170: Linked Objects Browser Dialog Box with Drill-Through Entry

You can define a style for cells tagged as “drill-through” to identify which cells in 
the spreadsheet are associated with drill-through reports. For more information on 
definining styles for drill-through cells, see “Accessing Drill-Through Reports 
from the Spreadsheet” on page 223.

About the Drill-Through Wizard

An administrator at your organization can predefine drill-through reports for you 
to view or to customize. The person who develops a report determines whether the 
report can be customized by drill-through users. If a report can be customized,  you 
use the Drill-Through Wizard to customize it. 

The Drill-Through Wizard is a graphical user interface that steps you through the 
following customization tasks: 

● Selecting columns to retrieve from the relational data source

Decide which columns from the predefined report you need to see.

● Selecting the display order for columns

Change the default display order of columns across the sheet.

● Selecting a sort order for data
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Select an ascending or descending sort order for a particular column; for 
example, sort a list of store managers in alphabetical order.

● Selecting data filters

Define a filter on a column so that only data meeting certain criteria is 
retrieved.

Before You Start
Before starting the tutorial, you should have a working familiarity with the 
Analytic Services product through the use of the Spreadsheet Add-in interface. 
Review in this guide Chapter 2, “A Basic Tutorial” and Chapter 3, “An Advanced 
Tutorial” as prerequisite reading.

A sample Analytic Services database is the basis for the examples in this tutorial. 
The database administrator creates this sample Analytic Services database using 
the sample metaoutline supplied with Integration Services. For information on 
creating the Integration Services sample application, which includes the sample 
metaoutline, see the Integration Services Console online help. A sample 
spreadsheet file, Essdt.xls, contains a sheet with the appropriate member 
intersections for the sample drill-through report. For more information on the 
sample database, spreadsheet file, and drill-through report, see “About the 
Samples Used in This Tutorial” on page 222.

If you plan to follow the examples in a live working session, check with the person 
at your organization who installs the Integration Services product family for 
information on the sample database that you need for drill-through, and to which 
instance of Analytic Server you should connect.

Note: The Essdt.xls file also contains sample results of the drill-through reports 
when you run them without customizing the reports. The results are provided in 
separate sheets in the workbook so that you can see the sample report results without 
working through the tutorial. For more information about the sample reports, see “About 
the Samples Used in This Tutorial” on page 222.

Before starting the tutorial, make sure you meet the following requirements:

● You must install the following components on your client computer:

– A 32-bit version of Excel 

– Essbase XTD Spreadsheet Add-in

– The Drill-through module
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The drill-through module is installed automatically when you install 
Spreadsheet Add-in. This module is transparent until you invoke it from 
the Linked Objects Browser. For more information on installation, contact 
the Analytic Services system administrator.

● The Analytic Services system administrator must install the Analytic Server.

● You must have access to Integration Services and to an instance of Analytic 
Server. For more information, contact the Analytic Services system 
administrator or the person who administers Integration Services at your 
organization.

● You must have access to the underlying relational database (typically using a 
username and password that are different from those that you use for Analytic 
Services). To obtain the appropriate access, contact the Analytic Services 
system administrator or the person who administers Integration Services at 
your organization.

● Make sure that the Essdt.xls sample drill-through report spreadsheet is 
available in the \Essbase\client\sample directory.

● To use the Essdt.xls sample drill-through report spreadsheet,  you need to 
log in to a computer with both Analytic Server and Integration Services 
installed. You must perform a member and data load and calculate the data for 
the sample Analytic Services database that you will access from Spreadsheet 
Add-in.

● The sample database that contains the drill-through report must be set up and 
running. The sample drill-through reports used in this tutorial (called “Market 
Detail,” “Measures Detail,” and “Product Detail”) are available with the 
sample spreadsheet files. Contact the person at your organization who installs 
Integration Services to find out the name of the sample database to use for 
drill-through.

For more information on Integration Services installations, see the Essbase XTD 
Integration Services Installation Guide. For more information on Analytic 
Services installations, see the Essbase XTD Analytic Services Installation Guide.

Keep in mind the following guidelines during the tutorial:

● Each tutorial task builds upon the previous one, and tasks must be followed in 
succession.



216 ■

Using Drill-Through

Essbase XTD Spreadsheet Add-in for Excel

● Optional tasks are displayed in gray boxes. These tasks are included for your 
reference only and should not be performed as part of the tutorial. You can find 
more information on these tasks in the Drill-Through online help.

● The examples used in this tutorial are based on the sample database that is 
included with the Integration Services installation. Contact the person at your 
organization who installs Integration Services for information about accessing 
the sample database.

● Set the options in the Essbase Options dialog box as described in “Setting 
Essbase Options” on page 216. If the option settings are different, the 
illustrations presented in this chapter may not match the spreadsheet view.

● If you make a mistake during the tutorial, select Essbase > FlashBack to return 
to the previous spreadsheet view. 

Setting Essbase Options
Before you begin the tutorial, make sure that the spreadsheet options are set to the 
initial settings, as illustrated in Figure 171 through Figure 175. If your option 
settings are different, the illustrations presented in this chapter may not match the 
spreadsheet view.

For information about each option in the Essbase Options dialog box, click Help 
to see the Spreadsheet Add-in online help.

➤ To set Essbase options:

1. From the spreadsheet menu, select Essbase > Options.

2. In the Essbase Options dialog box, select the Display tab.
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3. Select the appropriate check boxes and option buttons so that your display 
matches Figure 171.

Figure 171: Initial Settings for Display Options

4. Select the Zoom tab.
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5. Select the appropriate check boxes and option buttons so that your display 
matches Figure 172.

Figure 172: Initial Settings for Zoom Options

6. Select the Mode tab.
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7. Select the appropriate check boxes and option buttons so that your display 
matches Figure 173.

Figure 173: Initial Settings for Mode Options

8. Select the Style tab.
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9. Select the appropriate check boxes and option buttons so that your display 
matches Figure 174.

Figure 174: Initial Settings for Style Options

10. Select the Global tab.
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11. Select the appropriate check boxes and option buttons so that your display 
matches Figure 175.

Figure 175: Initial Settings for Global Options

12. Click OK to save the settings for this session and close the Essbase Options 
dialog box.
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About the Samples Used in This Tutorial
The sample database used for this tutorial contains the following dimensions: 
Scenario, Product, Market, Measures, and Year. The sample spreadsheet file 
shown in Figure 176 provides a particular view from the sample database.

Figure 176: View from Sample Database

For this spreadsheet view, detail-level data exists in a relational data source—data 
that is not available from Analytic Services. For example, the relational source 
contains columns of data for market detail, measures detail, and product detail. 
This steps in this tutorial walk you through a sample drill-through session, where 
you will drill down from the data shown in Figure 176 into the detail data from the 
relational source. 

This tutorial uses two sample drill-through reports, “Measures Detail” and 
“Market Detail.” As with all drill-through reports, these reports have been 
predefined to retrieve specific columns from the relational source. You will use the 
Drill-Through Wizard to customize the report, “Measures Detail.”

Note: The sample file also contains two more sample reports called “Product Detail” 
and “Two reports” that you can use for drill-through practice. In “Two reports,” select the 
drill-through cell B3 to select from two drill-through reports, “Product Detail” and Market 
Detail, select cell B6 to view “Market Detail,” and cell G3 to view “Product Detail.”

In addition to the sample drill-through reports, the Essdt.xls file provides 
sample results of the drill-through reports. The following list describes the 
drill-through results that are provided:

● The Market Detail drill tab displays the results for Market Detail when you run 
a drill-through report on cell G4 without customizing the report.
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● The Measures Detail drill1 tab displays the results for Measures Detail when 
you run a drill-through report on cell C4 without customizing the report.

● The Measures Detail drill2 tab displays the results for Measures Detail when 
you run a drill-through report on cell G6 without customizing the report.

● The Product Detail drill tab displays the results for Product Detail when you 
run a drill-through report on cell D5.

Using Drill-Through
Drill-through consists of these tasks as discussed in the following topics:

● “Accessing Drill-Through Reports from the Spreadsheet” on page 223

● “Selecting Drill-Through Reports to View or Customize” on page 230

● “Selecting and Ordering Columns” on page 237

● “Ordering Data” on page 239

● “Filtering Data” on page 242

Accessing Drill-Through Reports from the Spreadsheet
Using Spreadsheet Add-in, you can access detail-level drill-through reports that 
are based on the member intersections of Analytic Services data cells in the sheet. 

Each drill-through report has been predefined by an administrator at your 
organization; that is, each drill-through report is already set up to retrieve specific 
columns from the relational source and to sort and filter data in these columns in 
specific ways. Using the Drill-Through Wizard, you can customize these 
predefined drill-through reports to retrieve only the data that you want, displayed 
in a specific way.

To access the predefined drill-through report, double-click a drill-through cell in 
the spreadsheet (or select a range of cells and select Essbase > Linked Objects). 
You can set styles for cells tagged as “drill-through” to help identify which cells in 
the sheet are associated with drill-through reports. 

When you double-click a drill-through cell, Analytic Services displays the Linked 
Objects Browser dialog box, which displays a drill-through report entry. A single 
cell can be associated with multiple reports. The Linked Objects Browser dialog 
box also displays entries for linked partitions and other linked object types, such 
as cell notes, URLs, and application files. 
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After you view or customize the drill-through report, Integration Services retrieves 
data from the relational source and displays the results in a new spreadsheet.

Before starting the drill-through tutorial, perform the following tasks:

1. Open the sample Essdt.xls file.

The sample spreadsheet file contains the appropriate member intersections 
from the sample database for the drill-through report. This file is provided as 
part of the default Analytic Services installation.

2. Set a style for data cells that are associated with drill-through reports.

➤ To access the sample file and sample database: 

1. Start the spreadsheet application.

2. Select File > Open and open the Essdt.xls file from the 
Essbase\client\sample directory.

The sample file should look like Figure 177. In this example, the Market 
Detail tab is selected. The default tab that is selected when you first open the 
file may be different.

Figure 177: Sample Spreadsheet File for Drill-Through

The sample file shows data for specific members of an Analytic Services 
database. This sample file contains the following three predefined 
drill-through reports, indicated by the tabs of the spreadsheet: “Market 
Detail,” “Measures Detail,” and “Product Detail.” Using drill-through, you 
can access these reports and customize them so that Integration Services 
retrieves only the data that you need and displays it in the desired format.

3. Select the Market Detail tab on the spreadsheet. 
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4. Select Essbase > Connect and connect to the appropriate sample database.

Note: A specific sample database for drill-through is not automatically provided 
with Integration Services or Analytic Services. Contact the person at your 
organization who installs Integration Services to set up a database for you.

5. Select Essbase > Options and select the Style tab.

6. In the Data Cells option group, select the Integration Server Drill-Through 
check box and click Format. 

Analytic Services displays the Font dialog box.

7. Select Bold Italic from the Font style list box. 

8. Select Blue from the Color drop-down list, and click OK to return to the 
Essbase Options dialog box.

Figure 178: Font Dialog Box Selection

In the Essbase Options dialog box, Analytic Services displays an example of 
the selected style in the Sample box.
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Figure 179 shows how the Essbase Options Style tab looks with the style for 
drill-through cells defined.

Figure 179: Sample Style for Drill-Through Data Cells
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9. In the Essbase Options dialog box, select the Display tab, and then select the 
Use Styles check box, as shown in Figure 180.

Figure 180: Setting the Use Styles Option

10. Click OK to close the Essbase Options dialog box.

11. Select Essbase > Retrieve to display the new style in the spreadsheet.
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In Figure 181, the sample drill-through report is associated with the data cells 
for Actual, Profit, and Product at the month and Eastern state levels, so that 
these data cells are displayed in blue, bold, and italic font.

Figure 181: Sample Spreadsheet File with Drill-Through Style Applied

➤ To access the sample drill-through report from Spreadsheet Add-in:

1. Select any drill-through cell; for example, cell G4.

You can also select a continuous range of cells from the same parent in one 
dimension to display all drill-through reports associated with the cells that you 
select. In this example, there is only one drill-through report attached to the 
range of cells.

In order for Integration Server to return a valid drill-through report when 
multiple cells are selected, all members selected for multi-cell drill-through 
must come from:

● The same physical table and column in the relational source database

● The same member level in the underlying OLAP metaoutline

● The same hierarchy

A multi-cell drill-through operation is valid only if all three criteria noted 
above are met. A message is displayed if the combination of cells you select 
is not valid for performing a multi-cell drill-through operation. 

2. Access the Linked Objects Browser in either of these ways:

● Select Essbase > Linked Objects to open the Linked Objects Browser 
dialog box, as shown in Figure 182.
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● In the Essbase Options dialog box (Global tab), select the Enable 
Linked Object Browsing check box.

This process enables you to double-click a linked object cell to open the 
Linked Objects Browser dialog box. 

This option works only with single-cell selection. If you select a range of 
cells, use the Essbase > Linked Objects menu command.

Figure 182: Linked Objects Browser Dialog Box with Drill-Through 
Entry Selected

3. Select the drill-through report entry and click View/Launch. 

4. In the Select Drill-Through Report dialog box, select Market detail and 
click Execute.

The results of the drill-through report are displayed in a spreadsheet. The 
results of the Market Detail report shows that the regional director for the East 
region is John West and that the population for New York is between 
18,000,001-21,000,000.

Figure 183: Results of Market Detail Drill-Through Report

If there is only one report available for the cells that you select in the 
spreadsheet and if that report is not designed to be customized, the 
drill-through process generates the report and immediately displays the results 
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in the spreadsheet. The person at your organization who develops 
drill-through reports specifies whether you can customize a report and 
whether you need to log in to access the drill-through report and the relational 
data source.

5. Follow the steps in “Selecting Drill-Through Reports to View or Customize” 
on page 230 to select a report to customize. 

Selecting Drill-Through Reports to View or Customize
After you launch the drill-through process from the Linked Objects Browser 
dialog box, Integration Services displays the Select Drill-Through Report dialog 
box under one or the other of the following conditions: 

● More than one drill-through report exists for the cell or cell range that you 
select in the spreadsheet.

● Only one report exists, but you have the option of customizing it using the 
Drill-Through Wizard.

The Select Drill-Through Report dialog box displays the list of drill-through 
reports available for the cells that you select in the spreadsheet. Depending on how 
a report is defined in Integration Services Console, you may have access only to 
view, not customize, the report.

Note: Tasks that you should not perform as part of the tutorial are shown in light 
colored boxes.

This task is optional. Optional tasks do not need to be performed as part of the 
tutorial. They are provided for information only.

The sample report used for this tutorial is the Measures Detail report. You will use 
the Drill-Through Wizard to customize this sample report. 

To execute a predefined drill-through report without customizing it, perform these 
tasks: 

1. Select the report that you want to view from the Available Reports list box.

2. Click Execute.

Integration Services retrieves the data from the relational source and displays the 
results in a new spreadsheet. The new sheet is added before the current sheet. 



Using Drill-Through

4

■ 231Essbase XTD Spreadsheet Add-in for Excel

➤ To customize the sample drill-through report:

1. In the Essdt.xls file, select the Measures Detail tab, as shown in 
Figure 184.

Figure 184: Initial Drill-Through Report for Measures Detail

2. Select Essbase > Connect and connect to the appropriate sample database.

Note: A specific sample database for drill-through is not automatically provided 
with Integration Services. Contact the person at your organization who installs 
Integration Services to set up a database for you.

3. Select Essbase > Options and select the Style tab to define styles for this 
sheet.

4. In the Data Cells option group, select the Integration Server Drill-Through 
check box and click Format. 

Analytic Services displays the Font dialog box, as shown in Figure 178 on 
page 225.

Note: The style for drill-through cells may already be set as blue, bold, and italic 
because you set the style in the previous exercise. If this is the case, then go to 
step 7.

5. Select Bold Italic from the Font style list box. 

6. Select Blue from the Color drop-down list, and click OK to return to the 
Essbase Options dialog box.
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In the Essbase Options dialog box, Analytic Services displays an example of 
the selected style in the Sample box, as shown in Figure 185.

Figure 185: Sample Style for Drill-Through Data Cells
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7. In the Essbase Options dialog box, select the Display tab and select the Use 
Styles check box, as shown in the Cells group box in Figure 186.

Figure 186: Setting the Use Styles Option

8. Click OK to close the Essbase Options dialog box.

9. Select Essbase > Retrieve to display the new style in the spreadsheet.

In this example, the sample drill-through report is associated with every 
member intersection at the state level in the East region, so that all data cells 
associated with an Eastern state and children of Cola are now displayed in 
blue, bold, and italic font.

Figure 187: Sample File with Drill-Through Style Applied
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➤ To access the sample drill-through report from Spreadsheet Add-in:

1. Select any drill-through cell; for example, cell G6, as shown in Figure 188.

Figure 188: Selecting the Drill-Through Cell for the Measures Detail Report

If Integration Services is not running, the drill-through process does not 
launch properly. If drill-through is not launching properly, contact the 
Analytic Services system administrator. 

If you are prompted with the Drill-Through Login dialog box to connect to 
Integration Server and the relational data source, enter the appropriate 
connection information. The person at your organization who administers 
Integration Services and develops drill-through reports should provide you 
with this information. 

2. Access the Linked Objects Browser in either of these ways:

● Select Essbase > Linked Objects to open the Linked Objects Browser 
dialog box, as shown in Figure 182.

● In the Essbase Options dialog box (Global tab), select the Enable 
Linked Object Browsing check box.

This process enables you to double-click a linked object cell to open the 
Linked Objects Browser dialog box. 

This option works only with single-cell selection. If you select a range of 
cells, use the Essbase > Linked Objects menu command.

3. Select the drill-through report entry and click View/Launch. 

The Select Drill Through Report dialog box is displayed. 

Note: In the Select Drill Through Report dialog box, if the Customize button is 
selectable, then you can customize the report. If more than one drill-through report 
is displayed, then you can select from the different drill-through reports. In this 
tutorial, only one report, “Measures detail,” is displayed and customizable.
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4. Select the Measures detail report in the Available Reports list, as shown in 
Figure 189. 

Figure 189: Selecting the Sample Drill-Through Report

5. Click Customize. 

Note: The Customize button may or may not be selectable for any given report, 
depending on how the report was defined in Integration Services Console.
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Integration Services displays the first screen of the Drill-Through Wizard, as 
shown in Figure 190.

Figure 190: Drill-Through Wizard Dialog Box, Introductory Screen

6. Click Next to display the Select Columns and Display Order dialog box, as 
shown in Figure 191. 

Figure 191: Select Columns and Display Order Dialog Box
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7. Follow the steps in the topic, “Selecting and Ordering Columns” on page 237, 
to select and order rows for the customized report.

Selecting and Ordering Columns
Using the Drill-Through Wizard, you can customize predefined drill-through 
reports. The first task in using the Drill-Through Wizard is selecting and ordering 
columns to retrieve from the relational database. These columns contain detailed 
information that is not available in the Analytic Services database.

In the Select Columns and Display Order dialog box, you can select which 
columns you want Integration Services to retrieve from the relational data source. 
From this dialog box, you can also specify how the columns are displayed in the 
resulting report. 

The Available Columns list consists of columns available from the relational data 
source for this report (as defined in Integration Services Console). The Selected 
Columns list box consists of the columns from the Available Columns list in 
expanded form. You can remove columns from the Selected Columns list to 
exclude them from the drill-through report. 

In this example, the columns from the Available Columns list are selected for 
inclusion in the sample Measures detail report. These columns are displayed in 
expanded form in the Selected Columns list. 
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➤ To remove one of the selected columns from the drill-through report:

1. From the Selected Columns list, select the MARKET.STATE column., as 
shown in Figure 192. 

Note: To select multiple columns in the list that are not adjacent to each other, hold 
down the Ctrl key and select each column. To select a range of columns, hold down 
the Shift key and click the first and last columns in the list, which also selects all 
columns in between them.

Figure 192: Selecting Columns to Remove from the Drill-Through Report

2. Click  to move the selected column from the Selected Columns list back 
to the Available Columns list.

Note: To move a column from one list to another, click  or . To move all 

columns from one list to another, click  or .

3. Click Next to display the Select Data Sort Order dialog box, and follow the 
steps in the topic, “Ordering Data” on page 239 to further customize the 
report.

Note: When you finish customizing the report, click Finish at any time to generate 
the report and view the results in a new sheet. The new sheet is placed before the 
current sheet.
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Ordering Data 
In the Select Data Sort Order dialog box, you can select an ascending or 
descending sort order for the data in a column. Sort order determines the order in 
which rows will be displayed in the drill-through report. For example, you can sort 
the contents of the Time.TRANSDATE column, which represents the transaction 
dates, in ascending order in the drill-through report. 

➤ To define the sort order of rows in the drill-through report:

1. In the Available Columns list, select the Time.TRANSDATE column. 

The columns in the Available Columns list box are those that you selected in 
“Selecting and Ordering Columns” on page 237. The columns in the Column 
list are those for which a sort order has already been defined in Integration 
Services Console.

If a data sort order was selected when the report was created in Integration 
Services Console, the Order By list displays that selection. Otherwise, the 
default sort order is Ascending.
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2. Click  to move the Time.TRANSDATE column to the Column list, as 
shown in Figure 193, so that you can define a sort order for the column.

Note: To move a column from one list to another, click  or . To move all 

columns from one list to another, click  or .

Figure 193: Moving a Column to the Column List for Sorting
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3. In the Column list, double-click the Time.TRANSDATE column to change 
the data sort order from Ascending to Descending, as shown in Figure 194.

This action causes transaction date values to be displayed in reverse 
chronological order in the drill-through report.

Figure 194: Selecting the Data Sort Order
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4. Click Next to display the Select Data Filters dialog box, and follow the steps 
in the topic, “Filtering Data” on page 242 to customize the report further.

Filtering Data
You can create and apply filters to determine what Integration Services retrieves 
for the drill-through report. You can also save, edit, and delete the filters that you 
create. For any given column, you may want to retrieve only data that meets certain 
conditions. For example, the MEASURES.CHILD column in the sample database 
contains all children of the Measures dimension. 

Note that this task is optional. Optional tasks do not need to be performed as part 
of the tutorial. They are provided for information only.

To change the data sort order for multiple columns at one time, perform these 
tasks:

1. Hold down the Ctrl key and select the desired columns from the Column list. 

2. Click Order By.

Integration Services displays the Order By dialog box.

Figure 195: Order By Dialog Box

3. Select Ascending or Descending and click OK to return to the Select Data 
Sort Order dialog box.
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In the sample drill-through report, if you do not apply a filter to this list of 
measures, Integration Services retrieves all children from the relational source, 
because the sample drill-through report applies to all children of Measures. In this 
section, you will apply a filter to the MEASURES.CHILD column so that all 
children of Measures, except Misc, are included in the report.

Note: When you apply a filter on a non-level 0 member using Integration Services, the 
filter may return more members than expected. To work around this problem, use the 
Drill-Through Wizard.

➤ To define a filter:

1. Select the MEASURES.CHILD column from the Column list. 

As shown in Figure 196, the columns in the Column list box are those that you 
selected in “Selecting and Ordering Columns” on page 237.

Figure 196: Select Data Filters Dialog Box

If there is a filter already attached to the column, it is displayed in the 
Condition column. The full string of the filter is displayed in the lower 
Condition text box.

2. With the MEASURES.CHILD column selected, click Add condition.
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The Set Filter on Column dialog box is displayed, as shown in Figure 197.

Figure 197: Set Filter on Column Dialog Box

3. Select CHILD from the Column drop-down list.

The column displayed in the Column drop-down list is the one that you 
selected in step 1 on page 243.

4. Select the <> operator, which represents not equal to, from the Operator 
drop-down list. 

Note: You can select multiple values at one time only if you have selected In or 
Not In as the filter operator. For more information on filter operators, see the 
Drill-Through online help.

5. Click the Browse  button next to the Condition text box to open the Select 
Filter Values from the List dialog box, which lists all possible values for that 
column. 

The Select Filter Values from the List dialog box is displayed.

Note: Integration Services retrieves these values directly from the relational data 
source. If the relational data source contains many values, Integration Services 
confirms if you want to view them all before it retrieves them from the data source.
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6. In the Select Filter Values from the List dialog box, select Misc, as shown 
in Figure 198, and click OK. 

Figure 198: Selecting Filter Values from the List

The Set Filter On Column dialog box is displayed.

7. In the Set Filter On Column dialog box, click Add to add the condition to the 
Filters list.

Note: For information on using multiple filter conditions, see the Drill-Through 
online help.
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The Set Filter on Column dialog box should look like Figure 199.

Figure 199: Defining a Filter for a Column

The filter defined above causes all children of Measures, except Misc data, to 
show in the drill-through report.

The Add button becomes unselectable after you create the first filter, but 
becomes selectable when you create another filter. In this tutorial, you are 
creating only one filter. The And and Or options are used when combining 
multiple filters. The default value is Or, which means that Integration Services 
applies the filter if any of the conditions that you specify are met. If you select 
And, Integration Services applies the filter only if all the conditions are met. 

8. Click OK to return to the Select Data Filters dialog box. 
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Notice that the filter defined in the Set Filter on Column dialog box is 
displayed in the Condition column and the Condition text box of the Select 
Data Filters dialog box.

Figure 200: Result of Defining a Filter for a Column

You can also create a filter by typing the filter conditions directly into the 
Filters text box of the Set Filter on Column dialog box. For more information, 
see the Drill-Through online help.

To clear a filter for a selected column, select the filter and click Clear. To clear 
all filters for all columns, click Clear All.

You can save the filter that you just created and then apply it to the 
MEASURES.CHILD column, so that all children of Measures, except Misc, 
are included in the report.

➤ To save the filter that you just created:

1. In the Select Data Filters dialog box, click Add new filter. 

The Filter Name dialog box is displayed.

2. In the Name text box of the Filter Name dialog box, type the name for the 
filter that you are creating.
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For this tutorial, type All Children of Measures except Misc, as 
shown in Figure 201.

Figure 201: Naming a Filter in the Filter Name Dialog Box

 

3. Select the Copy definition of current filter check box.

Selecting Copy definition of current filter gives the filter the same description 
and conditions as the filter currently selected in the Select Data Filters dialog 
box.

4. Click OK. 

The filter is added to the list of saved filters in the Filter drop-down list of the 
Select Data Filters dialog box.

Optional: If you want to describe the filter, type a short description for the 
filter in the Description text box. 

5. Click Save Filters.

6. Click Finish to apply the filter to the MEASURES.CHILD column, so that all 
children of Measures, except Misc, are included in the report.

Note: You can also delete or rename filters. See the Spreadsheet Add-in online 
help for information.
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Integration Services generates the customized drill-through report and 
displays the results in a new spreadsheet. The new spreadsheet is added to the 
workbook before the current spreadsheet.

Figure 202: Customized Drill-Through Report

In this sample, the customized drill-through report reflects the specifications that 
you set using the Drill-Through Wizard:

● The Time.TRANSDATE column is sorted in descending order, displaying the 
transaction dates in reverse chronological order.

● All children of Measures, Additions, COGS, Marketing, Payroll, Sales, and 
Opening Inventory, except Misc, are displayed as you specified in the filtering 
part of the Drill-Through Wizard.
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Disconnecting from Analytic Services
When you finish using drill-through, disconnect from Analytic Services to make a 
port available on the server for other Spreadsheet Add-in users.

➤ To disconnect from the server:

1. Select Essbase > Disconnect.

Analytic Services displays the Essbase Disconnect dialog box, where you can 
disconnect any spreadsheet that is connected to a database, as shown in 
Figure 203.

Figure 203: Analytic ServicesDisconnect Dialog Box

Analytic Services may return an error message when you attempt to 
disconnect after using drill-through. If an error message is returned, select 
Essbase > Retrieve from the sheet and then disconnect.

2. Select a sheet name from the list and click Disconnect. 

3. Repeat step 2 until you have disconnected from all active sheets.

4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by closing the spreadsheet 
application. An abnormal shutdown of a Spreadsheet Add-in session, such as a 
power loss or system failure, does not disconnect your server connection.
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In
d

ex

Index

Symbols
#Missing strings, suppressing, 73
#NoAccess strings, suppressing, 73
* wildcard character, 111
? wildcard character, 111

A
access

to Analytic Services data, 48, 122
to databases, 48, 122
to linked partitions, 192
to linked reporting objects, 185
to multiple applications, 49
to multiple databases, 191
to online help, 38
using drill-through reports, 223
using Essbase commands, 46

Acrobat Reader. See Adobe Acrobat Reader
ad hoc reports, 19, 50, 147, 207
Add button, 243
Add-in Manager, 32
adding members. See members, adding
adjusting columns. See columns, adjusting width
administrators, 20
Adobe Acrobat Reader, ix
advanced interpretation engine, 167
Advanced Interpretation mode, 167, 174
aliases

definition of, 85
displaying

process of, 86
with member names, 87
with Query Designer results, 107

in tables, 85
alternate dimensions. See dimensions, alternate
alternate names. See aliases
Analytic Services

architecture, 20
computing environment, vii
connecting to. See connecting
disconnecting from. See disconnecting
intended audience, 20
migration information, xv
Options dialog box, 216
products of, 22
starting a session, 33
System Login dialog box, 48
upgrades, xv

ancestors, definition of, 28
AND operators, 108
API, 23
application designer, 20
application partitions. See linked partitions
application programming interface, 23
applications/databases

Sample Basic, 32, 46, 49, 123
sample for drill-through, 222
Sample Interntl, 204
Sample Xchgrate, 204

applying queries, 103
ascending sort order

in drill-through reports, 239
IN Query Designer, 136

asymmetric reports
definition of, 139
pivoting, 140
retrieving data into, 139

Attach Linked Object dialog box, 178, 181, 183
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attaching reporting objects to cells. See linking
attaching to databases. See connecting
attributes, drill down, 55
auditing updates, 196
auto logouts, 120
Auto Sort Rows option, 170

B
blank

columns, 143
rows, 143

blocks, locking data, 194
Boolean operators, 108, 113

C
Calculation command, 196
Calculation dialog box, 197
calculations

database status, 197
databases, 160, 196
dynamic, 160
reducing calculation time, 160
scripts, 197
specifying latest time period, 163
substitution variables, 166
with Dynamic Time Series, 163
with EssCell, 159

canceling data retrievals, 52
Cascade command, 198
Cascade Information page, 199
Cascade Options dialog box, 199
cascading sheets

creating table of contents, 202
destination, 200
format, 202
level of detail, 199
names, 200
output type, 200

cell notes
accessing linked, 187
linking to cells, 181

cell ranges
keeping, 66
removing, 68

retrieving, 153
selecting nonadjacent, 67
with drill-through, 228

cells
accessing linked partitions, 192
applying styles, 76, 82
attaching reports. See linking
attaching URLs. See linking
EssCell function in, 156
formatting, 76, 82, 180

in data cells, 82
of dimension members, 80
of Dynamic Calculation members, 161
of parent members, 77

formulas in, 143, 146, 149, 156
linked reporting objects, 177, 182
linking files to, 177
linking notes to, 181
linking URLs to, 182
retrieving a range of, 153
retrieving single values, 156
selecting nonadjacent, 67
with nondatabase values, 143

Change Password dialog box, 50
changing

passwords, 50
row and column orientation, 62
spreadsheet format, 76
styles, 76

children (defined), 28
Clear All button, 247
Clear button, 247
Clear command, 53
clearing styles, 84
click (defined), 39
client

components, 20
software, 31
upgrading with server, xv

client-server environment, 20
collapsing data views. See drill
colors, setting, 76
columns

adjusting width, 46, 145
blank, 143
displaying as rows, 62
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displaying selected, 66
filtering by, 130
keeping selected, 66
nested, 54
pivoting, 62
removing selected, 68
retrieving into, 54

columns, drill-through
choosing, 237
selecting display order, 237
selecting for retrieval from relational source, 237
sorting, 239

commands
Calculation, 196
Cascade, 198
Clear, 53
Connect, 48, 122, 191
Currency Report, 204, 208
Disconnect, 119
FlashBack, 52
Keep Only, 66
Linked Objects, 177, 182
Lock, 194
Member Selection, 109
Navigate Without Data, 69, 72
Pivot, 62
Remove Only, 68
Retrieve, 51
Retrieve & Lock, 194
Send, 195
Undo, 52
Unlock, 195
Zoom In, 53
Zoom Out, 57

comparison operators, 108, 131
computing environment, vii
concurrent

database access, 49, 191
updates to server, 194

conditional retrievals, 129
Connect button, 35
Connect command, 48, 122, 191
connecting

to a database, 48, 122
to a relational data source, 211, 223, 234
to Analytic Services, 48, 122

to Essbase XTD Integration Server, 223, 234
to multiple databases, 191
viewing current connections, 192

connecting. See also disconnecting
Connection Information text box, 192, 197
consolidations (defined), 29
consulting services, xii
conversions, currency, 203
creating queries, 94
creating reports. See reports, creating
Currency Conversion product, 23
currency conversions

modifying exchange rates, 208
reporting, 207
sample databases, 205
settings, 208

Currency Report command, 204, 208
Currency Report dialog box, 208
current time period. See Dynamic Time Series
cursors (Essbase), 51
custom applications, 23
Customize button, 235
customizing drill-through reports, 231

D
data

calculating, 196
changing orientation, 62
comparison operators, 131
displaying, 25, 51
dynamically calculating, 160
filtering, 129
filtering, in drill-through reports, 247
formatting, 76
locking, 194
missing, 73
modifying, 194
navigating, 29, 69
pivoting, 62
relational, and drill-through reporting, 211
removing subsets, 68
retaining subsets, 66
retrieving. See retrieving
sorting, 129
unlocking, 195
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updating, 194, 196
data sort order, and drill-through reporting, 239
data source, relational, 234
databases

calculating. See calculations
concurrent access, 49
connecting. See connecting
consolidations, 29
defined, 24
dimensions, 27
disconnecting from, 119
linked. See linked partitions
loading, 49, 124
locking, 194
members, 27
organization, 26
outlines, 29
queries. See queries, 91
restoring previous views, 52
rules, 26
sample, 46, 204, 222
selecting. See connecting
switching, 191
viewing connections, 192

deleting
filters, in drill-through reports, 247
selected members, 68
styles, 84

descendants (defined), 28
descending sort order

in drill-through reports, 239
with Query Designer, 136

Destination Options page, 200
destinations

cascaded sheets, 200
Query Designer queries, 101

detaching. See disconnecting, 119
dialog boxes, Help buttons, 38
dimensions

alternate, 24
applying styles, 80
currency conversion and, 204
described, 24, 27
drilling down on, 53 to 54
drilling up on, 57
naming elements, 27

pivoting, 62
disabling data retrieval. See navigating without data
Disconnect

command, 119
dialog box, 119

disconnecting
forced logouts, 120
from Analytic Services, 119
from Essbase XTD Integration Server, 250

discontinuous rows and columns, 67
disk space, effect on Dynamic Calculation, 160
display

options, 76
order of columns in drill-through reports, 237

Display page (Essbase Options dialog box), 41, 216
Display Unknown Member option, 146, 148
displaying data, 25, 51
distributed sheets. See cascading sheets
documents

feedback, xiii
ordering print documents, xi

documents, accessing
Hyperion Download Center, x
Hyperion Solutions Web site, x

double-clicking
defined, 39
enabling

for drilling, 40
for linked object browsing, 185, 192, 229, 234

downloading Acrobat Reader, ix
drag, defined, 39
drag-and-drop operations, 62
drill

by double-clicking, 40
down on attributes, 55 to 56
down on consolidations, 29
down to sample of members, 141 to 142
Formula Fill, 149
retain formulas during, 149
to less detail, 57

drill-through
accessing, 213, 223
cells, defining styles for, 223
described, 211
installing, 214
multiple cell selection, 228
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multiple reports, 212
sample

database, 222
drill-through report, 222
file, 224

saving filters, 247
styles for cells, 213
tutorial guidelines, 215
tutorial requirements, 214

Drill-Through Wizard
dialog box, 236
introductory screen, 236

duplicating sheets. See cascading sheets, 198
Dynamic Calculation members, applying styles to, 

161
Dynamic Time Series

defined, 163
specifying latest time period, 164 to 165

E
Edit Cell Note dialog box, 188
Edit menu, 53
Edit URL dialog box, 190
editing

cell notes, 187
linked files, 186
URLs, 189 to 190

education services, xii
Enable Hybrid Analysis option in Zoom page 

(Essbase Options dialog box), 43
enabling

Essbase toolbar, 34
FlashBack setting, 53
mouse actions, 39, 185, 192
Navigate Without Data, 69

environment (computing), vii
Essbase

Cascade Options dialog box, 199
Disconnect dialog box, 119
Member Selection dialog box, 110, 116
Member Selection dialog box, from Query 

Designer, 96
menu, 33
Options dialog box, 41, 124
System Login dialog box, 122

toolbar
described, 35
installing, 34

Essbase XTD Analytic Services. See Analytic 
Services

Essbase XTD Application Programming Interface 
(API), 23

Essbase XTD Integration Server, 23, 211
Essbase XTD Integration Server drill-through. See 

drill-through
Essbase XTD Spreadsheet Add-in. See Spreadsheet 

Add-in
EssCell function, 156

error messages, 159
syntax, 157

Excel
clearing formats, 53, 85
mouse actions, 39
sample tutorial files, 121

exchange rates, 204
Execute button, 235
executing drill-through reports, 229 to 230
expanding data views. See drill down
expanding formulas when drilling, 150
external files, 177

F
files

accessing linked, 185
destinations, cascaded sheets, 200
linking to data cells, 177
sample for tutorial, ix, 121

filtering data, 129
filters

in drill-through reports, 247
operators, 244
saving in drill-through reports, 247

Find Member dialog box, 112
finding members, 108, 111
FlashBack button, 37
FlashBack command, 52
font

formats, 78
style list, 78

Font dialog box, 78
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forced logouts, 120
formatted sheets

pivoting in, 147
retrieving data into, 143

formatting
data cells

linked objects, 180, 192
read/write, 82
read-only, 82

dimension members, 80
displaying aliases, 85
displaying aliases and names, 87
Dynamic Calculation members, 161
enabling styles, 79
linked object cells, 180, 192
options for cascaded sheets, 202
parent members, 77
repeating member labels, 88
spreadsheets, 76
text and cell styles, 83

Formula Fill option, 149, 152
Formula Preservation mode

Formula Fill, 149
pivoting in, 147
restrictions with, 147, 149
Retain on Keep and Remove Only, 149
Retain on Retrieval, 145, 149

formulas
EssCell, 156
expanding when drilling, 150
in cells, 143, 149
preservation

effects on other operations, 149
enabling, 145, 149
restrictions with, 147

free-form reporting
entering generation and level names in, 174
in Advanced Interpretation mode, 167
in Free-Form mode, 170
retrieving data, 167

Free-Form retrieval mode, 170
Free-Form retrieval mode guidelines, 170
functions. See macro functions

G
generations

defined, 28
entering names in spreadsheet, 174

Global page (Essbase Options dialog box), 40

H
Help buttons, 38
Help, accessing, 38
Hybrid Analysis, enabling in the Zoom page (Essbase 

Options dialog box), 43
Hyperion Consulting Services, xii
Hyperion Download Center

accessing documents, x
Hyperion Education Services, xii
Hyperion product information, xii
Hyperion Solutions Web Site

accessing documents, x
Hyperion support, xii
Hyperion Technical Support, xiii

I
In, 228
in-cell editing, 39
installation, drill-through, 214
installation, toolbar, 34
Integration Server drill-through. See drill-through
Internet, linking cells to URLs, 182
Interntl sample database, 205

K
Keep Only button, 36
Keep Only command

described, 66
in Formula Preservation mode, 149

L
labels

applying styles, 80
displaying with aliases, 87
entering in spreadsheet, 167, 170
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member names. See member names
repeating, 88

LAN. See networks
Latest Time Period option, 164
latest time period, specifying, 163
levels

cascading by, 199
defined, 28
drilling down, 59
drilling in, 59
entering names, 174

linked objects
partitions. See linked partitions
reporting objects. See linked reporting objects

Linked Objects Browser dialog box, 190, 193, 229, 
234

LROs, 177
Linked Objects command, 178, 181, 183
linked partitions

access privileges, 194
accessing from spreadsheet, 192
cells, applying styles, 192

Linked Reporting Objects
accessing from spreadsheet, 185
applying styles, 180
cell notes, 181
creating, 177
external files, 177
URLs, 182

linking
cell notes, 181
external files, 177
partitions, 192
URLs to data cells, 182

list, cascaded sheets, 202
local area network. See networks
Lock command, 194
locking data blocks, with multiple users, 194
logging

off of Analytic Services. See disconnecting
on to a relational data source, 234
on to Analytic Services. See connecting, 48
on to Essbase XTD Integration Server, 234

logging data updates from spreadsheet, 196
logical operators, 113
logouts, forced or auto, 120

M
macro functions

EssCell, 156
Spreadsheet Toolkit, ix, 22, 38

main menu (Essbase), 33
manual calculation mode, 159
Member Information dialog box, 111
member names

aliases for, 85
alternate. See aliases, 85
applying styles, 77
displaying with aliases, 87
entering in spreadsheet, 167, 170
formatted sheets, 143
indenting, 29
repeating, 88
with EssCell function, 157

Member Preview dialog box, 115
Member Retention option, 59
Member Selection button, 37
Member Selection command, 109
Member Selection dialog box, 110
Member Selection Preview dialog box, 99
Member Selection, with Query Designer, 96
members

adding, 96
aliases for, 85
ancestors, 28
applying styles, 77, 80
children, 28
collapsing, 57
defined, 27
deleting, 68
descendants, 28
deselecting, 117
drilling down on, 54
drilling up on, 57
Dynamic Calculation, 160
Dynamic Time Series, 163
finding, 108, 111
generations, 28
levels, 28
names. See member names
parents, 27
retaining, 66
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selecting, 96, 108
siblings, 28

menu, Essbase, 33
messages (Essbase)

database calculation status, 197
display options, 148
EssCell, 159
unknown member, 146

metadata sampling, 141 to 142
migrating to release 6, xv
missing values, suppressing, 73

disabled, 150
in cascaded sheets, 202
option unavailable, 150

Mode page (Essbase Options dialog box), 43, 126, 
149

money. See currency conversions
mouse actions, enabling, 39
moving

rows and columns. See pivot
through worksheets, 69

multi-cell selection, with drill-through, 228
multidimensional databases. See databases
multiple cell selection, with drill-through, 228
multiple filter conditions, in drill-through reports, 

245

N
names

alternate. See aliases
applying styles, 77
displaying with aliases, 87
entering generation, 174
entering level, 174
repeating, 88

Navigate With or Without Data button, 35
Navigate Without Data command, 69, 72
nested columns or rows, 54
networks, 22
Next Level option, 59, 199
nonadjacent cells, 67
notes, linking to data cells, 181
null values, 157
numeric values, preserving, 144

O
Objects product, 23
ODBC clients, 23
OLAP

defined, 19
server. See server

online analytical processing, 19
online help

displaying for spreadsheet, 38
opening

Spreadsheet Add-in, 33
operators, comparison, 108, 131
options

Cascade, 199
Display, 41, 124, 216
Global, 40, 44, 127, 220
Mode, 43, 126, 149, 218
settings for advanced tutorial, 124
settings for basic tutorial, 41
settings for drill-through tutorial, 216
Style, 78
Zoom, 42, 59, 125, 217

Options button, 37
Options dialog box, 41, 216
OR operators, 108
Order By dialog box, 242
ordering

columns in drill-through reports, 237
rows in drill-through reports, 239

outlines
consolidations, 29
described, 26
dimensions, 27
Dynamic Calculation members, 160
Dynamic Time Series members, 163
members, 27

output, cascaded sheets, 199
overlapping styles, 84

P
parent members

applying styles to, 77
defined, 27

Partitioning product. See linked partitions
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partitions. See linked partitions
passwords

changing, 50
entering, 123

pattern matching, 113
pivot

asymmetric reports and, 140
by dragging, 62
described, 39, 62
effect on text, 144
formatted sheets and, 147
formula preservation and, 147
rows or columns, 62, 141
unavailable, 144
without retrieving data, 70

Pivot command, 62
power loss, effect of abnormal shutdown, 120
preferences. See options, 40
preserving formulas, 145, 153
primary mouse button, 39
printer destination, cascaded sheets, 200
programming interface, 23

Q
queries

applying, 103
applying styles, 104
creating, 94
defining, 91
deleting, 104
retrieving, 91
saving, 101

Query Designer
applying option settings, 107
connecting to multiple databases, 106
creating queries, 94
data filtering panel, 130
data sorting panel, 136
filtering data, 129
hint panel, 91
layout panel, 95
messages, 139
messages and confirmations, 104
navigation panel, 91
properties panel, 91

save as query dialog box, 101
sorting data, 136

Query Designer icon, 37

R
read/write cells, 83
read-only cells, 83
relational data source, 234
relational databases, accessing using drill-through, 

211
remote databases. See linked partitions, 192
Remove Only button, 36
Remove Only command

described, 68
in Formula Preservation mode, 149

Remove Unselected Groups option, 150
removing. See deleting, 68
Repeat Member Labels option, 88
report script commands, 170, 172
reports

ad hoc, 50, 147
ad hoc currency, 207
asymmetric, 139
creating multiple, 198
formatted, 143
free-form, 167
methods of generating, vii
saving, 119

reports, creating
ad hoc, 207
Cascade, 198
Member Selection, 108
methods, vii
Query Designer, 91

reports, drill-through
accessing, 223
customizing, 213, 231
disconnecting from, 250
executing, 229
selecting to view or customize, 230

restoring database views, 52
restrictions, with Formula Preservation, 149
Retain on Keep and Remove Only option, 149
Retain on Retrieval option

disabled, 150
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enabled, 145, 149
Retain on Zooms option, 149, 151
retaining

data subsets, 66
formulas, 143 to 144

when drilling, 149
when retaining data, 149
when retrieving, 145, 149

selected members, 66
Retrieve & Lock command, 194
Retrieve button, 36
Retrieve command, 51
retrieving

Advanced Interpretation mode and, 167
canceling, 52
conditional, 129
currency conversion, 204
cursors, 51
data, 47
Dynamic Calculation members, 160
formula preservation and, 149
Free-Form mode and, 170
functions, 156
increasing speed, 84, 139, 153, 161
into asymmetric reports, 139
into columns, 54
into formatted sheets, 143

rules for, 144
into rows, 54
less detail, 57
modes, 167
more detail, 53
performance impact, 84, 139, 161
range of cells, 153
retaining formulas and, 145, 149
selected cells, 153
starting process and, 50
suppressing data and, 69

reverting to previous database view, 52
rows

blank, 143
deleting during pivot, 141
displaying as columns, 62
displaying selected, 66
filtering by, 130
keeping discontinuous, 67

nested, 54
pivoting, 62
removing selected, 68
retrieving into, 54
sorting within, 136
suppressing values in, 73, 202

S
sample

databases
connecting to, 49, 205
described, ix, 46, 204
in drill-through, 222

files for tutorial, location, 121
Sample Basic

connecting to, 49
described, 46

Sample Data (Zoom In) command, 141 to 142
Sample directory, 121
sampling, 141 to 142
Save As command, 119
Save command, 119
saving

drill-through filters, 247
queries, 101
worksheets, 119

saving queries, 101
secondary mouse button, 39
select (defined), 39
Select Calc Script option, 197
Select Columns and Display Order dialog box, 

237 to 238
Select Data Filters dialog box, 243
Select Data Sort Order dialog box, 239
Select Drill-Through Report dialog box, 230, 235
Select Filter Values from the List dialog box, 

244 to 245
selecting

cells to keep, 66
cells to remove, 68
latest time period, 163
members, 108
multiple cells, with drill-through, 228
nonadjacent cells, 67
range of cells for retrieval, 153
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Send command, 195
sending

data to server, 194
log file, 196

server, 20
Analytic Server, described, 21
changing password, 50
client-server environment, 20
connecting to, 48, 122
described, 21
disconnecting from, 119
Essbase XTD Integration Server, 211
Essbase XTD Integration Services, 23
logging updates to, 194
migrating to release 5, with client, xv
name, 48, 122
on network, 22
sending data to, 194

Set Filter on Column dialog box, 244
shared members, applying styles to, 78
sheet destination, Cascade option, 200
sheets. See worksheets
shortcuts, mouse actions, 39
shortcuts, toolbar buttons, 35
shutdown, abnormal, 120
siblings (defined), 28
sort order

in drill-through, 239
in Query Designer, 136

sorting criteria, 129
Spreadsheet Add-in

accessing drill-through from, 223
installing toolbar, 34
logging data updates, 196
retrieval cursors, 51
starting, 33
users, described, 20

Spreadsheet Toolkit product, 22
spreadsheets

applying styles, 76
cascading, 198
creating multiple, 198
data update log file, 196
described, 25
displaying aliases, 86 to 87
displaying member names, 87

distributing, 198
drilling options, 59
global options, 40, 53, 148
mode options, 149, 167
preserving formulas, 149
repeating member labels, 88
retrieving data, 47
saving, 119
setting options, 41
style options, 76
suppressing missing and zero values, 73
zoom options, 59

SQL Interface, 23
starting

Analytic Services, 33
data retrieval, 51
drill-through, 223
Spreadsheet Add-in, 33

status of database connections, 192
Style page (Essbase Options dialog box), 78
styles

applying
to data cells, 82
to dimension members, 80
to dimensions, 80
to drill-through cells, 223
to linked partition cells, 192
to linked reporting object cells, 180
to members, 77
to parent members, 77
to Query Designer results, 107
to shared members, 78

clearing, 85
defining, 77 to 78
hierarchy of, 84
overlapping, 84
removing, 84
selecting members, 78
stored in ESSBASE.INI, 82
turning off, 85
turning on, 79

Subset dialog box, 112, 115
subsets

defining members, 112
removing, 68
retaining, 66
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substitution variables, 165, 167
suppressing

data retrieval, 69
missing and zero values, 73
option disabled, 150
underscore characters, 73

symmetric reports, 139
system administrator, 20
system failure, 120

T
table of contents, with Cascade, 202
TCP/IP protocol, 22
technical support, xiii
terminating database connections. See disconnecting
termination, abnormal, 120
text

entering free-form, 167
formatting, 78
hierarchy of styles, 84
pivoting. See pivot
preserving formatted, 144

time periods, 163
title members, with drill-down, 54
to-date calculations, specifying, 163
toolbar (Essbase), 37

buttons on, 35
installing, 34

tracking data updates, 196
transaction-level data, accessing with drill-through, 

211
transparent partitions. See linked partitions
transport protocol, 22
tutorial

basic tasks, 31
guidelines, 45
preparing for, 41

U
underscore characters, suppressing, 75
Undo command. See FlashBack command
undoing actions, 52
Unlock command, 195
unlocking data blocks, 195

Update Mode, 195
updating

data, 194
log file, 196

upgrading, xv
up-to-date calculations, 163
URLs

accessing linked, 189
editing, 190
length limits, 184
linking to data cells, 182

Use Aliases option, 86
Use Both Member Names and Aliases option, 87
Use Sheet Options with Query Designer option, 107
Use Styles option, 79
username, entering, 123
users, 20

V
V2.x mode, 170
VBA functions, ix
viewing

active connections, 192
aliases, 85
aliases and names, 87
data in spreadsheet, 50
Dynamic Calculation members, 161
Essbase menu, 33
Essbase toolbar, 34
fewer members. See drill
linked partitions, 192
linked reporting objects, 185
more members. See drill
multidimensional data, 25
online help, 38
repeated member labels, 88
spreadsheet without data, 69
styles, 79
toolbar, 34

views, restoring, 52
Visual Basic for Applications. See VBA functions
visual cues. See styles
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W
Web resources, linking to data cells, 182
wildcard characters, 111
Windows NT Registry, changes to, 33
Within Selected Group option, 60, 139
worksheets

formatting, 76
navigating without data in, 69

World Wide Web, linking to data cells, 182

X
Xchgrate sample database, 205

Z
zero values

suppressing, 73, 75
suppressing options disabled, 150

Zoom commands, customizing, 58
Zoom In button, 36
Zoom In command

drilling down options, 53
selecting levels, 59

Zoom Out button, 37
Zoom Out command, drilling up options, 57
Zoom page (Essbase Options dialog box), 42, 59

Enable Hybrid Analysis option, 43
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