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Introduction

This document is intended for the use with IBM
®

Producer Lifecycle and
Credential Management Version 2.0.5.

Producer Lifecycle and Credential Management provides a single platform that
insurance customers can use for producer and agency onboarding, producer and
agency administration, producer self-service, hierarchy management, credential
management, and credential validation.

Audience

This guide is intended for administrators who are installing and configuring
Producer Lifecycle and Credential Management.

Finding information

To find documentation on the web, including all translated documentation, access
IBM® Knowledge Center (http://www.ibm.com/support/knowledgecenter).

Publication date

This document was published on November 29, 2016.

Accessibility features

Accessibility features help users who have a physical disability, such as restricted
mobility or limited vision, to use information technology products. IBM HTML
documentation has accessibility features. PDF documents are supplemental and, as
such, include no added accessibility features. For information about these features,
see “Accessibility features,” on page 47.

Forward-looking statements

This documentation describes the current functionality of the product. References
to items that are not currently available may be included. No implication of any
future availability should be inferred. Any such references are not a commitment,
promise, or legal obligation to deliver any material, code, or functionality. The
development, release, and timing of features or functionality remain at the sole
discretion of IBM.
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Chapter 1. Installation overview

The IBM
®

Producer Lifecycle and Credential Management installation package
contains the files that you need to install and configure the application as well as
the rules and processes required to run workflows.

Producer Lifecycle and Credential Management is run as a Microsoft Windows
service. After you configure the service to point to your database, you must start
the Producer Lifecycle and Credential Management service.

The workflow rules and processes used by Producer Lifecycle and Credential
Management must be imported into JBoss Drools Guvnor.

Installation preparation
Before you install IBM

®

Producer Lifecycle and Credential Management, you must
download the software that is required to run the application.

You must create an empty database for Producer Lifecycle and Credential
Management by using Microsoft SQL Server. The first time that you log in to the
application, the default tables and reference data are loaded into the database.

To run workflow and business rules in Producer Lifecycle and Credential
Management, you must download and deploy JBoss Drools Guvnor and JBoss
jBPM Designer on your web application server. These two applications work
together as the workflow rules engine for the Producer Lifecycle and Credential
Management application.

To review an up-to-date list of environments supported by Producer Lifecycle and
Credential Management, such as operating systems, browsers, web servers,
database servers, and application servers, see Software Requirements
(http://www.ibm.com/support/docview.wss?uid=swg27047756)

Pre-installation checklist
Before you can open the IBM

®

Producer Lifecycle and Credential Management
application, you must download and install the software that is required to run the
application.

You must install the following products:

JBoss Drools Guvnor 5.5.0
This is required to store workflows and business rules used in Producer
Lifecycle and Credential Management.

JBoss jBPM Designer 2.4
This integrates with the Guvnor application to add and edit workflows
used in Producer Lifecycle and Credential Management.

Web application server
This is used to deploy the Guvnor and Designer WAR files. Some
examples of a web application server include Apache Tomcat, WebSphere®,
and JBoss.

© Copyright IBM Corp. 2014, 2016 1
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Oracle Java™ Software Development Kit or Java Runtime Environment or Java
Development Kit 8.0

This is required to run the web server application.

Microsoft SQL Server 2008 R2 or 2008 SP3 or 2012
This is required to create and store the database used by Producer
Lifecycle and Credential Management.

Installing Java 8
To use Java 8 with IBM

®

Producer Lifecycle and Credential Management and
Guvnor, you must update some configuration settings in both applications.

Procedure
1. Install Java 8 on the server.

Note: If you are running different versions of Java on the server, you can
override the wrapper.conf file to use the absolute path reference to Java 8.
a. Open the wrapper.conf file and change the wrapper.java.command

parameter to the full path of Java 8.
For example, type wrapper.java.command = C:\/Program
Files\/Java\/jre1.8.0_66\/bin\/java.exe

Escape any slashes as in the following example: wrapper.java.classpath.1
= .\/lib\/*.jar

2. Update the Guvnor library by performing the following steps:
a. Download the ecj-4.4.2.jar file from the following link:

http://mvnrepository.com/artifact/org.eclipse.jdt.core.compiler/ecj/4.4.2
b. Stop the Drools service on Tomcat 6.
c. Go to Tomcat 6 on the server.
d. Go to %APACHE_LOCATION%\webapps\drools-guvnor\WEB-INF\lib.
e. Delete the ecj-3.5.1.jar file.
f. Copy the ecj-4.4.2.jar file into the folder.
g. Start the Drools service on Tomcat 6 again.
h. Run Build Package.

3. Change any "switch" statements to "if" statements.
If there are any Drools rules that utilize the "switch" statement, they must be
updated to use an "if" statement. In version 2.0.3, the core rules have been
updated. Make sure any user-defined rules are also updated.

What to do next

For information on upgrading your database with Java 8 installed, see “Upgrading
with Java 8” on page 44.

Installing Microsoft SQL Server
You must install Microsoft SQL Server and create a database for IBM

®

Producer
Lifecycle and Credential Management.
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About this task

Important: If at any time you restart the database server, you must also restart the
IBM PLCM service. If the IBM PLCM service is not restarted, an error message is
displayed in the Producer Lifecycle and Credential Management application.

Procedure
1. Go to the Microsoft website (http://microsoft.com) and download Microsoft

SQL Server 2008 R2.
2. Install the software.
3. In SQL Server Configuration Manager, under SQL Server Network

Configuration > Protocols for MSSQLSERVER, make sure that TCP/IP
protocol is enabled.

4. In SQL Server Configuration Manager, under SQL Server Network
Configuration > SQL Server Services, make sure that the SQL Server Browser
service is running.

5. If you made changes in SQL Server Configuration Manager, restart the server.

What to do next

You must use Microsoft SQL Server Management Studio to create a database for
Producer Lifecycle and Credential Management.

Database creation
You must create a database in Microsoft SQL Server to store data for the IBM

®

Producer Lifecycle and Credential Management application.

When you create the database, you must add a user identifier that is used only by
the Producer Lifecycle and Credential Management application to access the
Producer Lifecycle and Credential Management tables. The application user
identifier must have administrator rights to the Producer Lifecycle and Credential
Management database.

To manage environments when there are multiple Producer Lifecycle and
Credential Management databases on the same database server, you can name each
database PLCM and add a suffix that indicates the type of environment that is
contained in the database. For example, you can name your development database
PLCM_DEV and your production database PLCM_PROD.

There is no initial size required for the Producer Lifecycle and Credential
Management database; however, do not restrict the database to a specific size.

Microsoft SQL Server database permission requirements
IBM

®

Producer Lifecycle and Credential Management does not require
administrative access to the database server, but database ownership rights must
be granted in order to access your database.

When you create a database to be used by Producer Lifecycle and Credential
Management, make sure that Producer Lifecycle and Credential Management is set
up as the database owner (dbo). If it is not possible to grant dbo rights, a user with
the following minimum permission requirements must be added:
v Connect
v Create table
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v Create view
v Execute
v Select
v Delete
v Insert
v Update
v View database state

Important: Granting Producer Lifecycle and Credential Management dbo rights is
preferred.

The migration tool needs the database userID to be added to the BulkAdmin
Server Role for the import to function successfully. The database administrators
must set up this permission.

Installing JBoss Drools Guvnor
JBoss Drools Guvnor must be installed and deployed to configure workflows and
business rules for IBM

®

Producer Lifecycle and Credential Management.

Procedure
1. Go to the JBoss website (http://download.jboss.org/drools/release/5.5.0.Final/

guvnor-distribution-5.5.0.Final.zip).
2. Download JBoss Drools Guvnor 5.5.0.
3. Rename the JBoss Drools Guvnor WAR file that matches your application

server to drools-guvnor.war.
4. Deploy the WAR file on your application server.

What to do next

By default, Guvnor does not enforce a password check. To enforce authentication,
you must configure Guvnor to use an appropriate user directory. For more
information, see the Guvnor documentation at http://docs.jboss.org/drools/
release/5.5.0.Final/drools-guvnor-docs/html/ch14.html.

You must install JBoss jBPM Designer to integrate with JBoss Drools Guvnor.

Installing JBoss jBPM Designer
JBoss jBPM Designer integrates with JBoss Drools Guvnor and is used to add and
edit processes for IBM

®

Producer Lifecycle and Credential Management.

Procedure
1. Go to the JBoss website (http://sourceforge.net/projects/jbpm/files/designer/

designer-2.4/).
2. Install JBoss jBPM Designer 2.4.
3. Rename the WAR file designer.war.
4. Deploy the designer.war file on your application server.

What to do next

Open JBoss Drools Guvnor and create a package to store the workflows and
business rules for Producer Lifecycle and Credential Management. The workflows
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and rules files that are used in Producer Lifecycle and Credential Management
must be imported after you set up JBoss Drools Guvnor and jBPM Designer.

Installing the IBM Producer Lifecycle and Credential Management
software

After you install and configure the required software, you can install IBM
®

Producer Lifecycle and Credential Management.

Procedure
1. Double-click the Producer Lifecycle and Credential Management setup.exe file.
2. Follow the steps in the installation wizard.

Results

The Producer Lifecycle and Credential Management installation files are saved to
your computer.
Related tasks:
“Upgrading the application” on page 45
You must install the new version of the IBM

®

Producer Lifecycle and Credential
Management Windows service to upgrade the application.

Installation files
The IBM

®

Producer Lifecycle and Credential Management application comes with
several installation files.

The release folder contains the files that are necessary to configure and run the
application and to set up rules and workflows in Drools Guvnor. These workflows
and rules are used by Producer Lifecycle and Credential Management.

Table 1. Installation files.

Installation file name Description

installService.bat This service must be started to log into the
application.

PLCMObjects.jar This file contains the objects used by Producer
Lifecycle and Credential Management rules and
processes and must be imported into Drools
Guvnor.

PLCMRules.drl This file contains the rules and processes
required for Producer Lifecycle and Credential
Management workflows and must be imported
into Drools Guvnor.

<plcm workflow>.bpmn2 files These files contain the workflows required by
Producer Lifecycle and Credential Management
and must be imported into Drools Guvnor.

Reinstalling the application
If you must reinstall IBM

®

Producer Lifecycle and Credential Management when
Drools and JBPM are already installed in the environment, then the plcmPkg folder
must be deleted.
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Procedure
1. Open JBoss Drools Guvnor.
2. In the Knowledge Base section, expand Packages.
3. Click the plcmPkg.
4. On the plcmPkg tab, click File > Archive.
5. In the Administration section in the left pane, click Archive.
6. Select the plcmPkg and click Permanently delete package.
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Chapter 2. Service configuration

The IBM
®

Producer Lifecycle and Credential Management service must be
configured to point to your database and Guvnor before you can open the
application.

In addition to configuring access to the database, you can configure the
application.conf file to complete the following tasks:
v set the default language
v configure mail settings
v configure settings for the License Metric report

You can also configure the wrapper.conf to complete the following tasks:
v initiate SSL
v set memory space
Related tasks:
“Upgrading the application” on page 45
You must install the new version of the IBM

®

Producer Lifecycle and Credential
Management Windows service to upgrade the application.

Configuring access to your database
You must configure the IBM

®

Producer Lifecycle and Credential Management
Windows service to point to your Microsoft SQL Server database.

Before you begin

Make sure that you have created a Microsoft SQL Server database.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the application.conf file.
3. Configure the db.sql.url value to point to your database.

Important: If you have special characters in any of the following values, you
must comment out the special characters by using double quotation marks (").
For example, if your password is s3cr*t, type s3cr"*"t as the value.
You must edit the following values:

SERVER_ADDRESS
The host name of the computer where Microsoft SQL Server is
installed.

1433 The default Microsoft SQL Server port. You might need to edit the port
number if you connect to a named instance. Use Microsoft SQL Server
Configuration Manager to check the port number.
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databaseName
The name of the database that you created for Producer Lifecycle and
Credential Management in Microsoft SQL Server.

instance
The name of your Microsoft SQL Server instance.

4. Set the db.sql.user value to the user who has access to the Microsoft SQL
Server account that has appropriate rights to access the database.

5. Set the db.sql.password value to the password of the user who has access to
the Microsoft SQL Server account that has appropriate rights to access the
database.

6. Save the file.

What to do next

You must start the Producer Lifecycle and Credential Management service for the
changes to take effect.

Configuring access to JBoss Drools Guvnor
To store workflows and rule definitions that are used by IBM

®

Producer Lifecycle
and Credential Management, you must configure access to JBoss Drools Guvnor.

Before you begin

You must download and install JBoss Drools Guvnor 5.5.0 and deploy it by using a
web application server. In Guvnor, you must create a package to store the
workflows and rule definitions for Producer Lifecycle and Credential Management.

Procedure
1. Navigate to the following location: C:\Program Files\IBM PLCM\plcmservice\

conf

Important: This is the default location. If you installed the application to
another location, the file path is different.

2. Open the application.conf file.
3. In the Drools configuration section, edit the following values:

rules.packageURL
This value must point to the JBoss Drools Guvnor package binary that
contains the workflows and rule definitions for Producer Lifecycle and
Credential Management. To find the value, in Guvnor, select the
package you created, click the Edit tab, and view the URL next to the
URL for packaging binary link.

rules.PoJoModelURL
This value must point to the URL to download the model set. This
value must be configured to reload rules in Producer Lifecycle and
Credential Management. To find the value, in Guvnor, select the
package you created, click the Edit tab, and view the URL next to the
POJO Model link.

rules.ChangeSetURL
This value must point to the URL for the change set. This value must
be configured to reload rules in Producer Lifecycle and Credential
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Management. To find the value, in Guvnor, select the package you
created, click the Edit tab, and view the URL next to the Change Set
link.

rules.user
This is the user who has access to the package that contains the
workflows and rule definitions for Producer Lifecycle and Credential
Management. By default, this is admin. If you changed the default
authentication of Guvnor, use the user ID that you configured instead.

rules.password
This is the password of the user who has access to the package that
contains the workflows and rule definitions for Producer Lifecycle and
Credential Management. By default, this is admin. If you changed the
default authentication of Guvnor, use the password that you configured
instead.

4. Save the file.

What to do next

You must restart the Producer Lifecycle and Credential Management Windows
service for the changes to take effect.

Configuring the language
You can set the language that is used in the IBM

®

Producer Lifecycle and
Credential Management application.

About this task

If you specify two or more languages in the configuration file, the language that is
used is based on the browser's language. The following languages are available:
v English: en
v German: de-DE
v Spanish: es-ES
v French: fr-FR
v Italian: it-IT
v Japanese: ja-JA
v Brazilian Portuguese: pt-BR
v Chinese Simplified: zh-CN
v Chinese Traditional: zh-TW

To update the reference data that comes with the Producer Lifecycle and Credential
Management application to the specified language, you must run the appropriate
script file.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the application.conf file.
3. Set the application.langs value to the language that you want to display in

the application.
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4. Save the file.

What to do next

To update the reference data that comes with the Producer Lifecycle and Credential
Management application, you must run the appropriate language script. The
language script files can be found on the IBM Client Success Portal
(https://varicent.support.ibmcloud.com). You must restart the Producer Lifecycle
and Credential Management service for the changes to take effect.

Configuring mail settings
For IBM

®

Producer Lifecycle and Credential Management to automatically send
emails to users, mail settings must be configured.

Before you begin

Obtain the details of your company's mail server from your system administrator.

To enable emails in Producer Lifecycle and Credential Management, see “Enabling
email notifications” on page 22.

Procedure
1. Navigate to the following location: C:\Program Files\IBM PLCM\plcmservice\

conf

Important: This is the default location. If you installed the application to
another location, the file path is different.

2. Open the application.conf file.
3. Edit the following section:

# EMAIL configuration
clientName="<name>"
smtp.host="<localhost>"
#All below parameters are optional for Email configuration
smtp.port=<25>
smtp.ssl=<no>
smtp.tls=<no>
smtp.user="<user name>"
smtp.password="<secret>"

4. Save the file.

What to do next

You must restart the Producer Lifecycle and Credential Management service for the
changes to take effect.

Configuring the migration delimiter
You can set the delimiter that is used in exported migration files in the IBM

®

Producer Lifecycle and Credential Management application.conf file.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.
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2. Open the application.conf file.
3. Set the migration.column.delimiter value to the delimiter that you want to use

between columns in exported files.
This can be a character or set of characters. The delimiter must be unique. It
cannot exist in any of the data being exported or imported.

4. Save the file.

What to do next

You must restart the Producer Lifecycle and Credential Management service for the
changes to take effect.

License metric tracking
License metric tracking is enabled by default in IBM

®

Producer Lifecycle and
Credential Management, which tracks metrics relevant to the licensing policy such
as the number of administrator users and the number of active agencies, branches,
and producers. This information helps determine if the current usage of Producer
Lifecycle and Credential Management is within license entitlement levels and can
prevent potential license violations.

License tracking details are gathered by specifying configuration properties in the
application.conf file, and the data that is gathered is displayed in the License
Consumption Report that is saved in the following directory: C:\IBM
PLCM\plcmservice\logs.

Configuring your license tracking details
You can set the configuration properties to gather data that relates to license terms
for the IBM

®

Producer Lifecycle and Credential Management application.

About this task

License metric tracking is enabled by default.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the application.conf file.
3. Navigate to the License Metric Settings section.
4. You can specify the following configuration properties, which enable

administrators to gather the required data:

Configuration property Description

license.metric.enable Set the value to false if you do not want to
collect license metric data.

license.metric.scheduledTime Set the time at which you want the metric
values to be generated everyday. The time
must be set in the following format:
hh:mm:ss

license.metric.plcm.dir Set the absolute source directory.
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Configuration property Description

license.metric.output.dir Set the location (relative directory) to which
the IBM Software License Metric Tag files
are saved.

license.metric.logger.file.size Set the maximum size of the SLMT file.

license.metric.logger.file.number Set the maximum number of SLMT file
outputs per software instance.

5. Save the file.

What to do next

You must start the Producer Lifecycle and Credential Management service for the
changes to take effect.

Integration with IBM License Metric Tool
IBM

®

Producer Lifecycle and Credential Management generates IBM Software
License Metric Tag (SLMT) files. Versions of IBM License Metric Tool that support
IBM Software License Metric Tag can generate License Consumption Reports. Read
this section to interpret these reports for Producer Lifecycle and Credential
Management.

By default, the IBM Software License Tag files are saved in the following directory:
C:\IBM PLCM\plcmservice\logs. For more information about configuring SLMT file
settings, see “Configuring your license tracking details” on page 11.

Each Producer Lifecycle and Credential Management instance generates an IBM
Software License Metric Tag file. The values in the file are refreshed every 24 hrs
by the Batch Processor. The following metrics are monitored:

Connection
The Connection metric can have the following subtypes:

FINRA
This metric displays a value of "1" if the Producer Lifecycle and
Credential Management application is connected to FINRA. If there
is no connection, a value of "0" is displayed.

NIPR This metric displays a value of "1" if the Producer Lifecycle and
Credential Management application is connected to NIPR. If there
is no connection, a value of "0" is displayed.

Authorized User
The number of advanced business users who have security authorizations
to configure reference data, workflow queues, and user-defined fields or
user-defined sections in Producer Lifecycle and Credential Management.

Eligible Participant
The number of distinct PartyIds configured with active eligible product
records that are being tracked on the current system day.

Changing the name of the cookie
You can change the name of the IBM

®

Producer Lifecycle and Credential
Management cookie that is stored in your web browser. This enables you to
connect to multiple Producer Lifecycle and Credential Management instances if
you have given each instance a unique cookie name.
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Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the application.conf file.
3. Set the play.http.session.cookieName value to a unique name for this instance.

Configuring SSL settings
In IBM

®

Producer Lifecycle and Credential Management, you can configure SSL to
establish an encrypted link. This enables Producer Lifecycle and Credential
Management on both HTTP and HTTPS.

About this task

Producer Lifecycle and Credential Management uses Java keys to configure SSL
certificates and keys. After you have created your keystore, you can configure
Producer Lifecycle and Credential Management to use the keystore.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the wrapper.conf file.
3. Navigate to the Configure these parameters for SSL section.
4. Uncomment the following lines:

wrapper.java.additional.7=-Dhttps.port=443
wrapper.java.additional.8=-Dplay.server.https.keyStore.path=
wrapper.java.additional.9=-Dplay.server.https.keyStore.password=

wrapper.java.additional.10=-Djava.security.properties="./conf/security.properties"

5. Configure the following values:

Dhttps.port
The port to which you want Producer Lifecycle and Credential
Management to listen for HTTPS protocol.

-Dplay.server.https.keyStore.path
The path to the keystore containing the private key and certificate.

-Dplay.server.https.keyStore.password
The password to the keystore.

6. Optionally, the following values can be uncommented and configured if the
values are different from the default settings:

-Dplay.server.https.keyStore.type
The key store type. By default, it is set to JKS.

-Dplay.server.https.keyStore.algorithm
The key store algorithm. By default, it is set to the platforms default
algorithm.

7. Save the file.
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What to do next

You must restart the Producer Lifecycle and Credential Management Windows
service for the changes to take effect.

Disabling HTTP protocol
You can disable HTTP access to the IBM

®

Producer Lifecycle and Credential
Management server.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the wrapper.conf file.
3. Navigate to the Listening port number for the service section.
4. Change the wrapper.java.additional.5=-HTTPd.port value to disabled.
5. Save the file.

What to do next

You must restart the Producer Lifecycle and Credential Management Windows
service for the changes to take effect.

Configuring operating time zone
Administrators can configure the operating time zone for IBM

®

Producer Lifecycle
and Credential Management. This is useful when the cloud server time zone differs
from the desired operating system time zone.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the wrapper.conf file.
3. Uncomment the following line: wrapper.java.additional.13=-

Duser.timezone=EST

4. Set the value to the required time zone.

Increasing memory space
If IBM

®

Producer Lifecycle and Credential Management runs out of memory space,
you can increase the space of the permanent generation heap and Java heap size in
the wrapper.conf file.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the wrapper.conf file.
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3. Increase the wrapper.java.additional.6=-XX:MaxPermSize value to 1024m.
4. Increase the value of the wrapper.java.maxmemory parameter.
5. Save the file.

What to do next

You must restart the Producer Lifecycle and Credential Management Windows
service for the changes to take effect.

Configuring a client proxy server
If IBM

®

Producer Lifecycle and Credential Management generates a timeout
exception when trying to invoke the National Insurance Producer Registry (NIPR)
web service, external Background Check web services to initiate a background
check, or other client or external vendor web services, the client may have a proxy
server configured in the environment that Producer Lifecycle and Credential
Management integrates with to invoke web services. The wrapper.conf file must be
modified to add settings for the proxy server.

About this task

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\service

installer

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the wrapper.conf file.
3. Add the following lines to the file:

wrapper.java.additional.11=-Dhttps.proxyHost=<IP address>
wrapper.java.additional.12=-Dhttps.proxyPort=<Port #>

wrapper.java.additional.13=-Dhttp.proxyHost=<IP address>
wrapper.java.additional.14=-Dhttp.proxyPort=<Port #>

4. Save the file.

What to do next

You must restart the Producer Lifecycle and Credential Management Windows
service for the changes to go into effect.

Installing the service
You must install the IBM

®

Producer Lifecycle and Credential Management
Windows service to run the application.

About this task

Important: If at any time you restart the database server, then you must also
restart the IBM PLCM service. If the IBM PLCM service is not restarted, an error
message is displayed in the Producer Lifecycle and Credential Management
application.
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Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\service

installer

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Right-click the installService.bat file and select Run as administrator.

What to do next

The service is installed as IBM PLCM. You must open the Services window and
start the IBM PLCM service.

Setting the service to start automatically
After making the required changes to the IBM

®

Producer Lifecycle and Credential
Management configuration files, you must start the Producer Lifecycle and
Credential Management Windows service.

About this task

You can set the startup type of the Producer Lifecycle and Credential Management
service to automatic.

Procedure
1. Click Control Panel > Administrative Tools > Services.
2. In the Services panel, select IBM PLCM Service.
3. Right-click and select Properties.
4. Select Automatic as the startup type.
5. Start the service.

Viewing the exception log
If there are any exceptions when you run IBM

®

Producer Lifecycle and Credential
Management, you can view them in the plcm.log file.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\logs

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the plcm.log file.

Opening the application
You can log in to the IBM

®

Producer Lifecycle and Credential Management
application after you make changes to the configuration files and start the service.

Procedure
1. Navigate to the following location: http://<localhost>:9000/PLCM/logon

Where localhost is the name or IP address of your server, and 9000 is the port
number configured in the wrapper.conf file. By default, the port number is set
to 9000.
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2. In the User Name field, type admin.
3. In the Password field, type aaaaaaA!.
4. Click Login.
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Chapter 3. System configuration settings

Administrators can configure access to third party applications from IBM
®

Producer Lifecycle and Credential Management as well as customize the
appearance of the application and map any user-defined workflows to default
workflows.

The following third party applications can be configured to work with Producer
Lifecycle and Credential Management:

NIPR integration
If you have a contract with NIPR, Producer Lifecycle and Credential
Management can integrate directly with NIPR. Real-time calls are made
from Producer Lifecycle and Credential Management to the NIPR Producer
Database to obtain license and appointment data. Producer Lifecycle and
Credential Management sends requests for new appointments and
termination of appointments and receives files of license renewals,
revocations, suspensions, alerts, and other license or appointment changes.

FINRA integration
If you subscribe to the FINRA webEFT Form Filing service, Producer
Lifecycle and Credential Management can submit files with U4, U4
Amendment, and U5 forms to FINRA. Data from FINRA, such as exam
results, exam windows, and state registrations, can be uploaded.

DTCC integration
If you subscribe to the DTCC service and receive DTCC Training Update
and Training Expiration records from external firms, Producer Lifecycle
and Credential Management can upload continuing education,
appointment, contract, and producer details received from DTCC.

CMIS integration
If you have a CMIS document management system or other third party
management system, you can configure Producer Lifecycle and Credential
Management to store any uploaded documents in the document
management system.

Customizing the application branding
Home office users can customize the IBM

®

Producer Lifecycle and Credential
Management application banner.

Procedure
1. Click System Operations > System Config Settings.
2. On the Theme tab, click the Edit icon.
3. Click Browse to upload an image that you want to display on the application

banner.
The image must be less than 2 MB and must be in the format of a JPEG or
PNG file.

4. Complete the required fields.
5. Click OK.
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Adding National Insurance Producer Registry configuration settings
You can configure access to the National Insurance Producer Registry (NIPR)
database from IBM

®

Producer Lifecycle and Credential Management.

Procedure
1. Click System Operations > System Config Settings.
2. On the NIPR tab, click the Edit icon.
3. From the NIPR Config Indicator drop-down list, select Yes.
4. Complete the following fields:

Field Description

NIPR Customer Number The customer number that is provided to
you by NIPR.

NIPR Customer PIN The customer PIN that is provided to you
by NIPR.

NIPR Customer ID The customer ID that is provided to you by
NIPR.

NIPR PDB URL The URL of the NIPR database.

NIPR Batch Prefix The batch prefix that is provided to you by
NIPR.

NIPR Email Address The NIPR email address.

Payment Account Identifier The bank account registered with NIPR for
processing state appointments.

Payment Type The payment type that is associated with the
Payment Account Identifier field.

NIPR FTP Server This is required to access the state
appointment files from NIPR.

NIPR FTP Username The user name used to log in to the NIPR
FTP server.

NIPR FTP Password The password used to log in to the NIPR
FTP server.

Inbound File Directory The name of the directory for inbound files.

Outbound File Directory The name of the directory for outbound
files.

Alert Service URL (Host part) URL for alert service. Required to receive
alerts from NIPR.

Appointment Auto Back-Date Set this value to Yes to have Producer
Lifecycle and Credential Management
automatically back date appointments being
sent to NIPR with the grace period allowed
by the state. Set this value to No to have
Producer Lifecycle and Credential
Management send over appointments to be
effective on the current system date.

Subscription Name This is the name of the NIPR alert
subscription.

5. Click OK.
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Adding Financial Industry Regulatory Authority configuration settings
You can configure access to the Financial Industry Regulatory Authority (FINRA)
database from IBM

®

Producer Lifecycle and Credential Management. With the use
of a scheduling tool, Producer Lifecycle and Credential Management can then
import and export data to and from FINRA.

Before you begin

You must be a member of FINRA and subscribe to the FINRA download service or
the form filing service or both.

Procedure
1. Click System Operations > System Config Settings.
2. On the FINRA tab, click the Edit icon.
3. From the FINRA Config Indicator drop-down list, select Yes.
4. Complete the following fields:

Field Description

FINRA User ID The user ID used to access the FINRA
server.

FINRA Password The password used to access the FINRA
server.

FINRA FTP Server The address of the FINRA server.

Download Service Directory The directory where you can access the files.

EFT Download Service Indicator Select Yes if you subscribe to the FINRA
download file service. After a U4 is filed for
a producer, Producer Lifecycle and
Credential Management receives daily feeds
of changes to the FINRA credentials of the
producer. For example, exam windows and
state registrations for a producer is sent to
Producer Lifecycle and Credential
Management from FINRA.

EFT Form Filing Service Indicator Select Yes if you subscribe to the form filing
service. This allows you to terminate or
register a producer to sell securities with
your firm.

5. Click OK.

Adding Depository Trust & Clearing Corporation configuration settings
You can configure access to the Depository Trust & Clearing Corporation (DTCC)
database from IBM

®

Producer Lifecycle and Credential Management. With the use
of a scheduling tool, Producer Lifecycle and Credential Management can then
obtain continuing education, contract, state appointment, and producer details
from DTCC.

Procedure
1. Click System Operations > System Config Settings.
2. On the DTCC tab, click the Edit icon.
3. From the DTCC Config Indicator drop-down list, select Yes.
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4. Complete the following fields:

Field Description

DTCC LNA Indicator If you subscribe to the DTCC LNA service,
select Yes.

DTCC Money Settlement Indicator If you subscribe to the DTCC Money
Settlement service, select Yes. This service
can integrate with Producer Lifecycle and
Credential Management to send commission
and incentive results to the application.

DTCC User ID The user ID required to access the DTCC
services.

DTCC Password The password required to access the DTCC
services.

DTCC FTP Server The URL of the DTCC FTP server.

5. Click OK.

Enabling email notifications
For IBM

®

Producer Lifecycle and Credential Management to automatically send
emails to users, mail settings must be configured in the application.

Procedure
1. Go to System Operations > System Config Settings

2. Click the Email tab.
3. Click Edit.
4. From the Email Configuration Indicator drop-down list, select Yes.
5. From the Enable Emails drop-down list, select Yes.
6. In the From Email field, type the email address from which you want the

emails to be sent.
This value is usually set to the administrator's email address.

7. Click OK.

Producer settings
When configuring IBM

®

Producer Lifecycle and Credential Management, you must
configure settings that are required to create, onboard, and modify producers and
producer details.

The following settings for producers can be configured in the Producer Lifecycle
and Credential Management application:
v liability coverage settings
v generation of multiple appointments for a single product
v credential contract restrictions
v pre-hiring
v onboarding kit cancellation and rejection constraints
v login settings
v currency, percentage, and name formats
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Configuring liability coverage settings
You can configure the liability coverage carrier settings that are available in the
IBM

®

Producer Lifecycle and Credential Management application.

Procedure
1. Go to System Operations > System Config Settings.
2. Click the Party tab.
3. Navigate to the Party Configuration Settings section and click Edit.
4. From the Party Configuration Indicator drop-down list, select Yes.
5. In the Carrier Link field, type the link to the insurance carrier that is providing

liability coverage.
6. In the Carrier Name field, type the name of the insurance carrier that is

providing liability coverage.
7. In the Company Name field, type the name of the company of the insurance

carrier that is providing the liability coverage.
8. Click OK.

Enabling generation of multiple appointments for single
product

In IBM
®

Producer Lifecycle and Credential Management, you can generate multiple
appointments for Life, Variable, Health or Property and Casualty products by
enabling the Default Combined Appointments setting in the application.

Procedure
1. Go to System Operations > System Config Settings.
2. Click the Party tab.
3. Navigate to the Party Configuration Settings section and click Edit.
4. From the Party Configuration Indicator drop-down list, select Yes.

For example, if a producer has LOAs for Life, Health, and variable products for
an LVH state, and the producer only selects Life when adding appointments,
then all three appointments are automatically created. The same applies in
reverse, when removing appointments.
If the Party Configuration Indicator is set to No in the example above, only
the Life appointment is created.

5. From the Default Combined Appointments drop-down list, select Yes.
6. Click OK.

Configuring credential contract restrictions
In the IBM

®

Producer Lifecycle and Credential Management application, you can
set the Credential Contract Restriction indicator to No if you want all
appointments to be created at the producer level.

About this task

By default, the Credential Contract Restriction indicator is set to Yes. This allows
home office users to choose to create appointments at either the producer level or
contract level. You can set this indicator to No to ensure all appointments are
associated with producers only and not a specified producer contract.
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Procedure
1. Go to System Operations > System Config Settings.
2. Click the Party tab.
3. Navigate to the Party Configuration Settings section and click Edit.
4. From the Party Configuration Indicator drop-down list, select Yes.
5. From the Credential Contract Restriction drop-down list, select No.
6. Click OK.

Enabling pre-hiring
To pre-hire producers in IBM

®

Producer Lifecycle and Credential Management, you
must enable pre-hiring in the application.

Procedure
1. Go to System Operations > System Config Settings.
2. Click the Party tab.
3. Navigate to the Contract Configuration Settings section and click Edit.
4. From the Contract Configuration Indicator drop-down list, select Yes.
5. From the Enable Pre-Hire drop-down list, select Yes.
6. Click OK.

Configuring onboarding kit cancellation and rejection
constraints

In the IBM
®

Producer Lifecycle and Credential Management application, you can
set the number of days that an onboarding kit can remain in the pending or
inactive state before it is canceled.

About this task

If the value of any constraint is set to zero, then Producer Lifecycle and Credential
Management ignores that type of onboarding kit cancellation.

Procedure
1. Go to System Operations > System Config Settings.
2. Click the Party tab.
3. Navigate to the Contract Configuration Settings section and click Edit.
4. From the Contract Configuration Indicator drop-down list, select Yes.
5. In the Onboarding Cancellation - Pending Rejection field, type the number of

days that an onboarding kit can remain in the pending state before it is
rejected.

6. In the Onboarding Cancellation - Complete Kit field, type the number of days
that users have to complete their onboarding kits before they are canceled.

7. In the Onboarding Cancellation - Not Active field, type the number of days
that an onboarding kit can remain in the inactive state before it is canceled.

8. Click OK.

Configuring login settings
You can set the authentication options available when creating a new IBM

®

Producer Lifecycle and Credential Management user and you can set the number
of time users can attempt to log in to the application before they are locked out.
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Procedure
1. Go to System Operations > System Config Settings.
2. Click the Party tab.
3. Navigate to the Login Configuration Settings section and click Edit.
4. From the Login Configuration Indicator drop-down list, select Yes.
5. Select Yes in one or all of the following drop-down lists:

Choice Description

Show PLCM This shows the default authentication
method when creating a producer, which is
Producer Lifecycle and Credential
Management.

Show LDAP This shows LDAP as an authentication
method when creating a producer. For more
information on configuring LDAP for use
with Producer Lifecycle and Credential
Management, see “Configuring LDAP
authentication” on page 41.

Show Client Registration If you have a client portal registration
system that adds and tracks user IDs and
passwords, then you can select to display
client registration as an authentication
method when you add a producer.

Show NA This shows "NA" as an authentication option
when creating a new producer.

6. In the Max Login Fail Count field, type the maximum number of times users
can fail to login before they are locked out.

7. Click OK.

Configuring currency, percentage and name formats
You can set the currency and percentage formats and country code used in the
IBM

®

Producer Lifecycle and Credential Management application.

About this task

You can configure a custom currency and percentage format that overrides the
format set by the locale on the client-side server.
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Table 2. Currency and percentage configuration

Field Description Examples

Currency Pattern This defines the way in
which a number is converted
to represent a currency
amount. The value of this
parameter specifies the
number of decimal places
that you want to display in
the currency amount.

If the number to be
converted has more than the
specified number of decimal
places, the number is
rounded in the result string.

If the value remains as the
default value of c, then the
currency format is defined
by the locale set on the
client-side.

If the client-side locale is set
to English-US and the
currencyPattern is set to c0,
then 1234.567 becomes
$1,235.

If the client-side locale is set
to German, and the
currencyPattern is set to c3,
then 1234.567 becomes
1.234,567 €.

Currency Symbol This value replaces the
locale's default currency
symbol.

If the locale is set to German,
where the currency symbol is
displayed after the currency
number, and the
currencySymbol is set to USD,
then 1.23 becomes 1,23 USD.

Percentage Pattern This multiplies a number by
100 and defines the way in
which the percentage is
displayed. The value of this
field specifies the number of
decimal places that you want
to display in the percentage.

If the value remains as the
default value of p, then the
percentage format is defined
by the locale set on the
client-side.

If the client-side locale is set
to English-US and the
percentagePattern is set to
p0, then 0.222 becomes 22 %.

If the client-side locale is set
to German, and the
percentagePattern is set to
p3, then 0.22 becomes 22,000
%.

Configuring your country code sets the format of producer names in Producer
Lifecycle and Credential Management tables. If the country is set to either Japan
(JPN) or China (CHN), then the producer names are displayed with the last name
followed by the first name. Also, when adding or editing producer names on the
Producer Details tab, the middle name and suffix fields are not displayed if the
country is set to Japan or China. Any other language setting results in the default
behavior.

Configuring your country code also sets the available fields when adding an
address for a producer. For example, setting your country to Canada (CAN)
ensures that the Province and Postal Code fields are displayed when adding or
editing an address.
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Procedure
1. Go to System Operations > System Config Settings

2. Click the Party tab.
3. Scroll down to the Format Configuration Settings section and click Edit.
4. From the Format Configuration Indicator drop-down list, select Yes.
5. Set the Currency Pattern to the value that defines the number of decimal places

for the currency.
6. Set the Curreny Symbol to the value that defines the currency type.
7. Set the Perentage Pattern to the value that defines the number of decimal

places for the percentages.
8. Set the Country Code to the code of your country.
9. Click OK.

Configuring background check settings
You can configure the links to the background check vendors that are available in
the IBM

®

Producer Lifecycle and Credential Management application as well as
configure automated background checks.

Procedure
1. Go to System Operations > System Config Settings.
2. Click the BackgroundCheck tab.
3. Click Edit.
4. From the Background Check Configuration Indicator drop-down list, select

Yes.
5. You can configure the following options:

Option Description

Automated Check Indicator When this value is set to Yes, automated
background checks are configured, the Auto
option is displayed in drop-down menus on
the Background Check tab, and the Pass
Pending Auto Approve option is displayed
in the Background Check Status field.

OFAC File Location The file path of the saved import file from
the Office of Foreign Assets Control (OFAC).

Vendor Site The URL of your preferred background
check vendor.

OFAC Site Address The URL of the OFAC site.

eVerify Site Address The URL of the eVerify site.

HR Screening Site Address The URL of the human resources screening
site.

FINRA Gateway Site Access The URL of the Financial Industry
Regulatory Authority (FINRA) site.

Vector One Site Address The URL of the Vector One site.

6. Click OK.
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Mapping user-defined workflows
To run correctly, all user-defined workflows must be mapped to the corresponding
IBM

®

Producer Lifecycle and Credential Management workflow.

About this task

Your Producer Lifecycle and Credential Management release comes with many
prebuilt workflows. The rules in these workflows can be modified to suit your
organization's business processes.

When you modify workflow rules, add a prefix to the rule name to identify the
rule as user-defined, for example, UD_initiateIndividualOrSubProducerDRL

Procedure
1. Go to System Operations > System Config Settings.
2. Click the Workflow tab.
3. Click Add.
4. From the PLCM Workflow ID drop-down list, select the workflow that

corresponds to the new user-defined workflow that you created.
5. In the Replacement Workflow ID field, type the name of the user-defined

workflow that you created.
6. Click OK.

Integration with document management system
IBM

®

Producer Lifecycle and Credential Management can be configured to send
any documents uploaded through the application to a third party document
management system for storage.

Producer Lifecycle and Credential Management can be integrated with Content
Management Interoperability Services (CMIS) or another third party document
management system.

Configuring document management system settings
To store documents in a document management system, you must first configure
settings in IBM

®

Producer Lifecycle and Credential Management.

Procedure
1. Go to System Operations > System Config Settings.
2. Click the DocumentStore tab.
3. Click Edit.
4. In the Document Store Config Indicator field, select Yes.
5. In the Document Store Type field, select the type of document storage you

want to use.

Document Store Type Description

CMIS Select this option if you want to use Content
Management Interoperability Services
(CMIS) to store documents uploaded in
Producer Lifecycle and Credential
Management.
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Document Store Type Description

Other Select this option if you want to a different
document management system to store
documents uploaded in Producer Lifecycle
and Credential Management.

6. If you selected CMIS, type the information into the required fields to connect
to CMIS.

7. If you selected Other, in the Document Store Interface Implementation field,
type the implementation of the IDocumentStore interface that you use to store
documents in another third party document store system.

Operations configuration
In IBM

®

Producer Lifecycle and Credential Management, you must configure
settings to enable the migration, mass changes, and mass onboarding features.

Configuring the migration directory
In IBM

®

Producer Lifecycle and Credential Management, you must configure the
directory from which you want migration files to be imported.

Before you begin

If the application server is not running on the same machine as the database
server, you must create a folder on a shared drive that will contain the migration
files. The shared drive must have a separate folder for migration of each
environment, such as Dev, Test, and Production. Map the shared drive on both the
application server running the PLCM service and the database server running the
PLCM SQL Server database. Make sure that the drives will automatically be
mapped if the server is restarted. You must also grant full control to the migration
folder for the userID that is used to run the PLCM service on the application
server as well as the userID that is executing Microsoft SQL Server on the database
server.

Procedure
1. Go to System Operations > System Config Settings.
2. Click the Operations tab.
3. Click Edit.
4. From the Operations Configuration Indicator drop-down list, select Yes.
5. In the Migration Directory field, type the location of the migration folder.

If an absolute path, such as C:\\plcm\\migration, is not specified, then the
folder is created relative to the Producer Lifecycle and Credential Management
installation location. The Microsoft SQL Server database must have access to
this migration folder during the import process.

6. Click OK.

Configuring import mass change settings
You must configure the batch size and directory for running staging table imports
in IBM

®

Producer Lifecycle and Credential Management.
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Procedure
1. Go to System Operations > System Config Settings.
2. Click the Operations tab.
3. Click Edit.
4. From the Operations Configuration Indicator drop-down list, select Yes.
5. Configure the following values:

Values Description

Import Stage Data Directory The directory where the stage table data
import file is located.

Import Stage Data Batch Size The batch size to be used in a bulk insert of
stage table data. Set this value to 0 or -1 to
disable bulk inserts and insert records into
the database one at a time.

6. Click OK.

Configuring synchronization with IBM Incentive Compensation
Management

You must configure the workspace folder to synchronize uploads from IBM
®

Producer Lifecycle and Credential Management to IBM
®

Incentive Compensation
Management.

Procedure
1. Go to System Operations > System Config Settings.
2. Click the Operations tab.
3. Click Edit.
4. From the Operations Configuration Indicator drop-down list, select Yes.
5. In the Sync Workspace Folder field, type the name of the folder that is used

for synchronization with Incentive Compensation Management.
6. Click OK.
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Chapter 4. Workflow and rule configuration

The workflows and rules that are required to run IBM
®

Producer Lifecycle and
Credential Management must be imported into JBoss Drools Guvnor and
configured to work the Producer Lifecycle and Credential Management application.

Workflows are required to run processes in Producer Lifecycle and Credential
Management, such as the initiation of producer onboarding. The workflows
contain business rules.

Workflow descriptions
Several workflows are included as part of the IBM

®

Producer Lifecycle and
Credential Management release.

The following list outlines the descriptions of the workflows that are included with
your Producer Lifecycle and Credential Management release:

plcm.AgencyTermination
This workflow is invoked when an authorized home office user selects to
terminate an agency or agency contracts. It processes the agency
termination, terminates all active contracts associated with the agency, and
sends email notifications of the agency termination. This workflow can be
modified to send agency termination messages to downstream systems that
require real-time notifications.

plcm.CancelOnboardingKit
This workflow is invoked when an agency manager or home office user
selects to cancel the onboarding of a new agent. It can be modified to send
cancellation messages to downstream systems that require real-time
notifications.

plcm.CompleteContinuingEducation
This workflow is invoked when an active producer submits a continuing
education renewal course, such as general annuity training and long term
care training, that is routed to the home office user for review and
approval. If the producer is pending and submits the course during the
onboarding process, this workflow is not invoked.

plcm.CompleteEOCoverage
This workflow is invoked when an active producer submits an errors and
omissions policy renewal that is routed to the home office user for review
and approval. If the producer is pending and submits the errors and
omissions data during the onboarding process, this workflow is not
invoked.

plcm.CompleteOnboardingKit
This workflow is invoked when a producer submits an onboarding kit. The
workflow determines routings for review and approval, creates workflow
tasks, and sends email notifications to the first reviewer. This workflow can
be modified to send messages of pending producers to downstream
systems that require real-time notifications. If you use the pre-hire feature,
the workflow is modified to call background check web services to initiate
the background check.
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plcm.InitiateOnboardingKit
This workflow is invoked when a home office user or agency manager
creates a new producer or new producer contract. It assigns contract and
producer codes, assembles the onboarding kit, and sends emails and alerts
to the producers to notify them to complete their onboarding kits.

plcm.InitiateOnboardingDualContract
This workflow is invoked when a new contract that requires dual contract
approval is created.

plcm.NodeAssignmentChange
This workflow is invoked whenever a node assignment is added, deleted,
or updated.

plcm.ProducerEndSuspendLOA
This workflow is invoked when a home office user or agency manager
reactivates a producer who has been suspended or was on a leave of
absence. This workflow can be invoked by the manageProducerLifecycle
web service to automatically start when a producer meets production
requirements during the suspension period. This workflow reactivates the
producer and sends email notifications of the reactivation. It can be
modified to send a message of reactivation to downstream systems that
require real-time notifications.

plcm.ProducerReinstate
This workflow is invoked when a home office user selects to reinstate a
terminated producer. It processes the reinstatement and sends email
notifications of the restatement. This workflow can be modified to send
messages of reinstatement to downstream systems that require real-time
notifications.

plcm.ProducerSuspendLOA
This workflow is invoked when a home office user or agency manager
suspends a producer or starts a leave of absence for a producer. It can also
be invoked from the manageProducerLifecycle web service and can be
automatically started when a producer does not meet production
requirements. This workflow processes the suspension or leave of absence
and sends email notifications. It can be modified to send messages of the
suspension or leave of absence to downstream systems that require
real-time notifications.

plcm.ProducerTermination
This workflow is invoked when a home office user or agency manager
terminates a producer or terminates one or more producer contracts. It can
also be invoked from the manageProducerLifecycle web service and can be
automatically started when a producer does not meet production
requirements. This workflow processes the termination and sends email
notifications. It can be modified to send messages of the termination to
downstream systems that require real-time notifications.

plcm.ReviewContinuingEducation
This workflow is invoked when a home office user approves continuing
education renewals or courses submitted by an active producer. It records
the approval of the course, updates the continuing education status and
credential summary of the producer, and sends email notifications of
rejections back to the producer.
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plcm.ReviewDualContractRequest
This workflow is invoked whenever the user submits an action from one of
the following dual contract tasks: Review Dual Contract Request or
Transfer to New Agency.

plcm.ReviewEOCoverage
This workflow is invoked when a home office user approves errors and
omission coverage renewals submitted by an active producer. It records the
approval of the errors and omission coverage and sends emails of
rejections back to the producer.

plcm.ReviewOnboardingKit
This workflow is invoked when an agency manager or home office user
completes a review of an onboarding kit. It updates the status of the
onboarding kit.
v If it is approved, the workflow executes rules to determine the next

reviewer of the onboarding kit, generates workflow tasks, and sends
emails to the reviewers. If there are no additional reviewers, the
workflow activates the onboarding kit.

v If it is pending rejection, the workflow sends email notifications that
include instructions for appealing the rejection based on credit score
information, which is needed for the Fair Credit Reporting Act
compliance.

v If it is rejected, the workflow sends email notifications to the producer.
v If it is canceled, the workflow sends email notifications.
v If it is returned for resubmission, the workflow creates alerts and sends

email notifications to the producer to resubmit the onboarding kit.

This workflow can be modified to send notifications of the activation,
rejection, or cancellation to downstream systems that require real-time
notifications. It can also be modified to call background check vendor web
services to initiate the background check after the agency manager has
completed the review.

plcm.backgroundCheckResults
This workflow is invoked for each background check result that is received
in a file from an external vendor. It sends a notification that the results
have been received to home office analysts so that they can review the
results.

plcm.eAcknowledgment
This workflow is invoked when there is a contract change to an active
contract. It determines whether additional electronic acknowledgments
must be signed and generates alerts and email notifications to the party
who needs to electronically acknowledge the contract change.

Importing rules
After you install JBoss Drools Guvnor and jBPM Designer, you must create a
package in Drools Guvnor. This is required to import the workflows rules for IBM

®

Producer Lifecycle and Credential Management.

Before you begin

Make sure you have installed JBoss Drools Guvnor, JBoss jBPM Designer, and
Producer Lifecycle and Credential Management.
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Procedure
1. Open JBoss Drools Guvnor.
2. In the Knowledge Bases section, click Create New > New Package.
3. Select the Import from drl file option.
4. Click Browse and navigate to the location to which you saved Producer

Lifecycle and Credential Management during the installation.
By default, it is located in the following directory: C:\IBM PLCM\guvnor-
imports\rules.

5. Select the PLCMRules.drl file.
6. Click Import.

By default, this creates a package that is called plcmPkg that contains all the
rules required for Producer Lifecycle and Credential Management workflows.

7. Click File > Save Changes.

What to do next

You must upload the file that contains the business objects that are used in the
workflows for Producer Lifecycle and Credential Management.

Importing workflow objects
Use JBoss Drools Guvnor to upload the objects that are required by IBM

®

Producer
Lifecycle and Credential Management workflows.

Before you begin

Make sure that you have installed JBoss Drools Guvnor, JBoss jBPM Designer, and
Producer Lifecycle and Credential Management.

Procedure
1. Open JBoss Drools Guvnor.
2. In the Knowledge Bases section, click Create New > Upload POJO Model

jar.
3. Leave the Create new option selected.
4. Give the model a name.
5. Leave the Create in Package option selected.
6. Click OK.
7. Click Browse and select the PLCMObjects.jar file located in your installation

folder.
By default, it is located in the following directory: C:\Program Files\IBM
PLCM\guvnor-imports

8. Click Upload.
The objects in the JAR file are imported into Drools Guvnor.

9. Click File > Save and Close.
10. Click Check In.

What to do next

You must import the file that contains the processes that are used in Producer
Lifecycle and Credential Management.
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Importing processes
Use JBoss Drools Guvnor to upload the processes that are required for IBM

®

Producer Lifecycle and Credential Management.

Before you begin

Make sure that you install JBoss Drools Guvnor, JBoss jBPM Designer, and
Producer Lifecycle and Credential Management.

Procedure
1. Open JBoss Drools Guvnor.
2. In the Knowledge Bases section, click Create New > New BPMN2 Process.
3. Leave the Create new option selected.
4. Give the process a name, such as the name of the workflow that you are

importing.
5. Leave the Create in Package option selected.
6. Make sure that the package that you created is selected in the list.
7. Click OK.

This creates an empty process.
8. Click Tools > Import from BPMN2.
9. Click Browse and select the .bpmn2 file that is located in the Producer

Lifecycle and Credential Management installation folder.
By default, the files are located in the following directory: C:\Program
Files\IBM PLCM\guvnor-imports\workflows. Make sure that you select the file
that matches the process name.

10. Click Import.
11. Click File > Save and close.
12. Click Check in.
13. Import each process in the folder in the same way.

Configuring workflows
Use JBoss Drools Guvnor to build a package to create a snap shot that IBM

®

Producer Lifecycle and Credential Management can access.

Before you begin

On the Edit tab, make sure that you save the changes to the package and click the
Validate configuration button.

Procedure
1. Open JBoss Drools Guvnor.
2. Open the package that contains the Producer Lifecycle and Credential

Management rules.
3. Click File > Save.
4. On the Edit tab, click Build package.
5. Note the URL for package binary link.
6. Navigate to the application.conf file.
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By default, it is located in the following directory: C:\Program Files\IBM
PLCM\plcmservice\conf.

7. In the Drools configuration section, edit the following value to match the URL
for package binary link that you noted in step 4:
rules.packageURL="http://localhost:8080/drools-guvnor/rest/packages/
plcmPkg/binary"

8. Save the application.conf file.
9. Restart the Producer Lifecycle and Credential Management Windows service.

Reloading rules
In IBM

®

Producer Lifecycle and Credential Management, you can reload rules and
workflows.

About this task

When you reload rules, the JAR file that has been imported into Guvnor is read
and imported into Producer Lifecycle and Credential Management. If the rules are
reloading while a user requests access to rules, the old rules are run until the
reloading is complete.

You must have the appropriate permissions to perform this task and settings must
be configured in the application.conf file. For more information on configuring
the settings to reload rules, see “Configuring access to JBoss Drools Guvnor” on
page 8.

Note: You must not rename the plcmObjects.jar file when uploading it into
Guvnor. If this file is renamed, the rules cannot be initialized.

Procedure

Go to System Operations > Reload Rules.
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Chapter 5. Authentication and sign-on

Various communication and authentication options are available when you
configure Open SSO or LDAP for IBM

®

Producer Lifecycle and Credential
Management authentication.

Single sign-on configuration
IBM

®

Producer Lifecycle and Credential Management supports single sign-on
authentication through an identity provider. When single sign-on is configured,
users can log in to one system and gain access to multiple systems.

If you are not logged in to Producer Lifecycle and Credential Management and
single sign on (SSO) is configured, then the application checks to see if you are
logged in to the identify provider (IdP). If you are not logged in to the IdP, the IdP
redirects you to the SSO page to log in.

If you are logged into the SSO provider, then your user name is checked against
Producer Lifecycle and Credential Management immediately. If your user name
matches, you are granted access to Producer Lifecycle and Credential Management
without being required to log in.

When you log out of Producer Lifecycle and Credential Management, a log out
request is sent to the IdP that logs you out of the application and invalidates the
Producer Lifecycle and Credential Management session. This also logs you out of
any other application that you are logged in to using the SSO system.

Generating and extracting your own keystore
If the communication between the IdP and IBM

®

Producer Lifecycle and Credential
Management must be encrypted, you must create a keystore and generate private
and public keys for Producer Lifecycle and Credential Management to access the
IdP.

Before you begin

You must create a keystore and a private and public key that Producer Lifecycle
and Credential Management can use to encrypt requests to the IdP. You can create
a keystore with the Java Keytool utility that comes with any standard JDK
distribution.

Procedure
1. Open the command prompt window with administrator rights and switch the

directory to the location of the Java Keytool utility.
For example, type the following text: cd C:\Program Files\Java\jre1.8\bin

2. Generate a keystore file and a public and private key by typing the following
command in the command prompt window: keytool -genkeypair -alias
<alias-name> -keypass <your-password> -keystore <keystore-file>

For example, type keytool -genkeyair -alias ibm-plcm -keypass changeit
-keystore ibmplcm-keys.jks

The keystore file is saved in the same directory as you typed in step 1.

© Copyright IBM Corp. 2014, 2016 37



3. Extract the public key that is used by the IdP to decrypt requests from
Producer Lifecycle and Credential Management by typing the following
command in the command prompt window: keytool -export -keystore
<keystore-file> -alias <alias-name> -file <public-key-file>

For example, type keytool -export -keystore ibmplcm-keys.jks -alias
ibm-plcm -file ibm-plcm-public.cert

The public key is saved in the same directory as you typed in step 1.

Configuring single sign-on
Single sign-on via Security Assertion Markup Language (SAML) can be configured
for use with the IBM

®

Producer Lifecycle and Credential Management application.

Before you begin

Single sign-on is initiated by a Service Provider, which is Producer Lifecycle and
Credential Management. You must have an Identify Provider installed, such as
Siteminder, PingFederate, or OpenAM. A keystore is required for generating digital
signatures. You must set up a keystore and configure it on the Identity Provider
(IdP). Open SSO provides a default test key for testing purposes. This key should
not be used in production.

Procedure
1. Navigate to the following location: C:\IBM PLCM\plcmservice\conf

Important: This is the default location. If you installed Producer Lifecycle and
Credential Management to another location, the file path is different.

2. Open the application.conf file.
3. In the #SAML Settings section, configure the following values :.

Parameter Description

auth.useSAML Set the value to true.

auth.baseUrl Configure the value to point to the URL that
you use to access Producer Lifecycle and
Credential Management. The IdP must be
able to access this link from the IdP server.

Note: OpenAM requires that you use fully
qualified domain names when protecting
web resources.
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Parameter Description

auth.failUrl To redirect users to a login page after a
failed SAML login attempt, you can
configure this value

This parameter is used when a SAML user,
who has successfully authenticated with
their SAML identity provider, attempts to
access Producer Lifecycle and Credential
Management. If there is no matching
security user in Producer Lifecycle and
Credential Management, the user is
redirected to the URL set by the
auth.failUrl value. If no value is
configured for this parameter, the user is
redirected to the Producer Lifecycle and
Credential Management failed login page,
which includes a link to log out of the
SAML SSO system.

auth.idp.type Set this value to the appropriate IdP name,
such as "siteminder" or "openam". This value
is only used for audit table purposes.

auth.idp.url Configure this value to point to the IdP
metadata link.

auth.idp.params.id Do not change this setting.

auth.sp.jks.path Configure this value to point to the directory
where the ibmplcm-keys.jks file is located.
For more information, see “Generating and
extracting your own keystore” on page 37.

auth.sp.jks.pw Set this value to the password for the
keystore. For more information, see
“Generating and extracting your own
keystore” on page 37.

auth.sp.jks.entryid This value is set to ibm-plcm and should not
change.

auth.sp.jks.entrypw Set this value to the password for the
keystore. For more information, see
“Generating and extracting your own
keystore” on page 37.

auth.timeskew Set this value to the maximum allowable
time skew for checking expiring times from
the IdP. This value should be relatively
conservative.

4. Save the file.

What to do next

You must start the Producer Lifecycle and Credential Management service for the
changes to take effect.
Related tasks:
“Setting up access for the Identity Provider” on page 40
To set up access to IBM

®

Producer Lifecycle and Credential Management for the
Identity Provider (IdP), you must generate a metadata export file to import into
the IdP.
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Setting up access for the Identity Provider
To set up access to IBM

®

Producer Lifecycle and Credential Management for the
Identity Provider (IdP), you must generate a metadata export file to import into
the IdP.

Procedure
1. Log in to Producer Lifecycle and Credential Management as the admin user.
2. Generate a metadata export file by typing the following text into your

browser's address field: http://<<PLCM URL>>/PLCM/sso/metadata
3. Provide the IdP team with the following information:
v The generated metadata export file. This file is imported into the IdP tool.
v The ibm-plcm-public.cert public key. This is required if the communication

between Producer Lifecycle and Credential Management and IdP is
encrypted. The public key is imported into the IdP system.

4. The IdP team performs the following steps:
a. Import the Producer Lifecycle and Credential Management metadata export

file into the IdP tool. This sets up everything that is required by the IdP to
access Producer Lifecycle and Credential Management and creates an
adapter that Producer Lifecycle and Credential Management can use to
access the IdP.

b. Provide the URL of the adapter created in the IdP that Producer Lifecycle
and Credential Management can use to verify credentials.

c. If the IdP encrypts the SAML header, a public key that Producer Lifecycle
and Credential Management can use to decrypt the SAML header is
provided.

What to do next

In the application.conf file, set the auth.idp.url value to the URL of the adapter
created in the IdP for Producer Lifecycle and Credential Management. You must
restart the Producer Lifecycle and Credential Management service for the changes
to take effect.
Related tasks:
“Configuring single sign-on” on page 38
Single sign-on via Security Assertion Markup Language (SAML) can be configured
for use with the IBM

®

Producer Lifecycle and Credential Management application.

Importing the public key into the keystore
If the SAML header is encrypted by the IdP, you must import the public key of the
IdP provider into the IBM

®

Producer Lifecycle and Credential Management
keystore. This is used by Producer Lifecycle and Credential Management to
decrypt the SAML header.

Procedure
1. Open the command prompt window with administrator rights and switch the

directory to the location of the Java Keytool utility.
For example, switch to the following directory: C:\Program
Files\Java\jre1.8\bin

2. Import the public key from IdP to the keystore by typing the following
command in the command prompt: keytool -importcert -alias <alias-name>
-file <public-key-file> -keystore <keystore-file>
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For example, if the Siteminder team provided a file called siteminder-
public.cert, then type keytool -importcert -alias siteminder-public -file
siteminder-public.cert -keystore ibmplcm-keys.jks

Configuring LDAP authentication
IBM

®

Producer Lifecycle and Credential Management can use LDAP to define
access to the application. The system calls LDAP with the user identifier and
password and receives a message if the authentication is successful.

Procedure
1. Navigate to the following location: C:\Program Files\IBM PLCM\plcmservice\

conf

Important: This is the default location. If you installed the application to
another location, the file path is different.

2. Open the application.conf file.
3. In the LDAP configuration section, edit the following values:

Parameter Description

ldap.server The location of your LDAP server.

ldap.domain The domain of your LDAP server.

ldap.port The port on which your LDAP server runs.

4. Save the file.

What to do next

You must restart the Producer Lifecycle and Credential Management Windows
service for the changes to take effect.
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Chapter 6. Upgrade

You can update the IBM
®

Producer Lifecycle and Credential Management
application with the latest features.

You must take the following steps to upgrade your application:
1. Back up your database.
2. Save your application.conf and wrapper.conf files.
3. Run the Model Upgrader tool to update your database.
4. Uninstall the previous Producer Lifecycle and Credential Management

Windows service.
5. Install the latest Producer Lifecycle and Credential Management Windows

service.

Microsoft SQL Server database backup and restoration
A database backup duplicates all the data that is contained in the IBM

®

Producer
Lifecycle and Credential Management database and creates a copy of the full
database.

You can then recreate the entire database in one step by using the restore
command. The restored database is an exact match of the database at the time the
backup completed.

Backing up a database
You can use Microsoft SQL Server Enterprise Manager to back up an IBM

®

Producer Lifecycle and Credential Management database.

Procedure
1. Open Microsoft SQL Server Enterprise Manager.
2. Click Tools > Backup Database.
3. Select one of the following Backup Types:

Complete backup
Makes a full backup of your database. You will almost always need to
start your backup strategy with a full backup of your database.

Differential backup
Stores all changes that have occurred to the database since the last full
backup.

4. You can edit the backup file destination.
By default, the backup file is stored in the following location: C:\Program
Files\Microsoft SQL Server\MSSQL\BACKUP\.

Tip: The database can remain online and accessible to users while the backup
is created.

Restoring a database backup
In the backup file, Microsoft SQL Server stores the names and locations of the files
used in the IBM

®

Producer Lifecycle and Credential Management database. After
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the database is restored, SQL Server recreates all the necessary files and the
database is restored to the point in time that the backup finished.

Procedure
1. Open Microsoft SQL Server Enterprise Manager.
2. Click Tools > Restore Database.

The Restore as Database field is the name of your newly restored database.
The name does not have to be identical to the name of the original (backed up)
database.

3. To define your restoration parameters, select the original database name and
the stored backup that you want to restore.

Using backup and restore to transfer databases between
servers

You can restore a backup of an IBM
®

Producer Lifecycle and Credential
Management database on a new server by creating a backup of a database and
saving it to a location that is accessible from the server where you are performing
the restoration.

Procedure
1. From the server that you want the database transferred to, open Microsoft SQL

Server Enterprise Manager.
2. Click Tools > Restore Database.
3. Type the name that you want the database to be restored with in the Restore as

database field.
4. Select the From device option.
5. Select File name and type the location of the backup file.

Upgrading with Java 8
If you have both Java 7 and Java 8 installed on your computer, you must ensure
the upgrader.jar file is associated with Java 8 before upgrading your IBM

®

Producer Lifecycle and Credential Management database.

About this task

The upgrader.jar file is compiled with Java 8 and cannot run with Java 7. If you
have both installed on your computer, you can run the upgrader.jar file from the
command line or associate the upgrader.jar with your Java 8 installation.

Procedure
1. To run the Model Upgrader tool from the command line, first check the Java

version by typing the following command: java -version. Then perform one of
the following steps:
v If the Java version is 1.8, then you can run the Model Upgrader tool by

typing the following command: java -jar "path to upgrader.jar"
v If the Java version is 1.7, then you can run the Model Upgrader tool by

typing the following command: "C:\Program Files\Java\jre1.8.0_66\bin\
javaw.exe" -jar "path to upgrader.jar"

2. To make sure that you can run the Model Upgrader tool by double-clicking the
upgrader.jar file, you must point the following registry keys to you Java 8
installation:
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v HKEY_CLASSES_ROOT\jarfile\shell\open\command
v HKEY_LOCAL_MACHINE\SOFTWARE\Classes\jarfile\shell\open\

command

Upgrading the database
Use the Model Upgrader tool to upgrade your IBM

®

Producer Lifecycle and
Credential Management database so that it is compatible with the upgraded
version of the application.

About this task

If your database and service are not running on the same version of Producer
Lifecycle and Credential Management, a message is displayed on the log in screen
that indicates that an upgrade is required.

Procedure
1. In your release folder, double-click the Upgrader.jar file.
2. In the Database URL field, enter the URL of the database server that contains

the database that you want to upgrade.
3. In the Schema Name field, enter the type of database to which you want to

connect.
4. In the Database Name field, enter the name of the database that you want to

upgrade.
5. In the User Name and Password fields, enter the login credentials of the user

who has permission to alter the database.
6. Click Connect.
7. Select the Roll back all upgrade on failure check box to roll back the version

to the last successful upgrade if the upgrade fails.
8. Click Upgrade.

Upgrading the application
You must install the new version of the IBM

®

Producer Lifecycle and Credential
Management Windows service to upgrade the application.

Before you begin

Run the uninstallService.bat file. By default, it is located in the following
directory: C:\Program Files\IBM PLCM\plcmservice\service installer

Procedure
1. Install the new Producer Lifecycle and Credential Management Windows

service.
2. Edit the application.conf and wrapper.conf files to match the saved files from

the previous version.
Related concepts:
Chapter 2, “Service configuration,” on page 7
The IBM

®

Producer Lifecycle and Credential Management service must be
configured to point to your database and Guvnor before you can open the
application.
Related tasks:
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“Installing the IBM Producer Lifecycle and Credential Management software” on
page 5
After you install and configure the required software, you can install IBM

®

Producer Lifecycle and Credential Management.
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Appendix. Accessibility features

IBM
®

Producer Lifecycle and Credential Management has accessibility features that
help users who have a physical disability to use the product.

Keyboard shortcuts
IBM

®

Producer Lifecycle and Credential Management includes keyboard shortcuts
to help you navigate the product and perform tasks.

The following keyboard shortcuts are based on U.S. standard keyboards.

Table 3. General keyboard shortcuts

Applies to Action Shortcut keys

General Perform the command for an active command
button.

Enter

General Move forward to the next item in the tab
index order. Cycle to the first tab index when
at the end.

Tab

General Move backward to the previous item in the
tab index order. Cycle to the last tab index
when at the beginning.

Shift+Tab

Check boxes Select or clear the checkbox. Spacebar

Menus Navigate down a menu and select a menu
item.

Down arrow and then
Enter

Menus Navigate up a menu and select a menu item. Up arrow and then Enter

Scrolling Scroll down. Down arrow

Scrolling Scroll up. Up arrow

Zooming Zooming in. Ctrl and +, or
Ctrl+Mouse wheel up

Zooming Zooming out. Ctrl and -, or Ctrl+Mouse
wheel down

Zooming Return to default zoom level. Ctrl+0

Navigation Reload the current page. F5

Navigation Move backward to the previously opened
page.

Alt+Left Arrow,
Backspace

Navigation Move forward to the previously opened page. Alt+Right Arrow,
Shift+Backspace

Navigation Stop a page from loading. Escape

Search Open a search box to perform a search on the
current page.

Ctrl+F, F3

Search Find the next match of the searched text on
the current page.

Ctrl+G, F3

Search Find the previous match of the searched text
on the page.

Ctrl+Shift+G, Shift+F3
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IBM and accessibility
See the IBM Accessibility Center for more information about the commitment that
IBM has to accessibility.

The IBM Accessibility Center (http://www.ibm.com/able) is available online.
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Notices

This information was developed for products and services offered worldwide.

This material may be available from IBM in other languages. However, you may be
required to own a copy of the product or product version in that language in order
to access it.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service. This document may
describe products, services, or features that are not included in the Program or
license entitlement that you have purchased.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
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Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Software Group
Attention: Licensing
3755 Riverside Dr.
Ottawa, ON
K1V 1B7
Canada

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.
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This Software Offering does not use cookies or other technologies to collect
personally identifiable information.

Trademarks

IBM, the IBM logo and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “ Copyright and
trademark information ” at www.ibm.com/legal/copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:
v Microsoft, Windows, Windows NT, and the Windows logo are trademarks of

Microsoft Corporation in the United States, other countries, or both.
v Java and all Java-based trademarks and logos are trademarks or registered

trademarks of Oracle and/or its affiliates.
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Glossary

This glossary provides terms and definitions for
the IBM

®

Producer Lifecycle and Credential
Management software and products.

The following cross-references are used in this
glossary:
v See refers you from a nonpreferred term to the

preferred term or from an abbreviation to the
spelled-out form.

v See also refers you to a related or contrasting
term.

For other terms and definitions, see the IBM
Terminology website (opens in new window).

A
appointment

The right to sell or service the products of
a specified insurance carrier in a state.

authorization
The process of granting a user, system, or
process either complete or restricted
access to an object, resource, or function.

C
corporate producer

An external corporation that is contracted
to sell a carrier’s products.

credential
A course, certificate, or regulatory license
that is required by either the insurance
carrier or a government regulator to sell
an insurance product.

D
database (DB)

A collection of interrelated or
independent data items that are stored
together to serve one or more
applications.

DB See database.

H
hierarchy

The organization of a set of entities into a
tree structure, with each entity (except the
root) having one or more parent entities
and an arbitrary number of child entities.

I
individual producer

An independent broker who is contracted
to sell a carrier's products or an employee
of an insurance carrier who is responsible
for selling a carrier's products.

L
license

A certificate of authorization that permits
an individual to sell insurance products in
a state.

line of authority (LOA)
The range of insurance products that a
producer is allowed to sell under a
license.

LOA See line of authority.

N
node Any element in a tree.

O
onboarding

An approach to equipping new
employees and socially integrating them
into an organization.

onboarding kit
The forms that a new employee must
complete in order to set up a contract
with an insurance carrier.
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P
parameter (parm)

A value or reference passed to a function,
command, or program that serves as
input or controls actions. The value is
supplied by a user or by another program
or process.

parm See parameter.

producer
An individual or organization who sells
the products of an insurance carrier.

S
sub-producer

An employee of an external corporation
who is contracted to sell a carrier’s
products.

W
WAR See web archive.

web archive (WAR)
A compressed file format, defined by the
Java EE standard, for storing all the
resources required to install and run a
web application in a single file.

workflow
The sequence of activities performed in
accordance with the business processes of
an enterprise.
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Index

A
alerts

setting up for NIPR 20
application.conf file 45
authentication 37

configuring types of 25

B
background checks

configuring vendors for 27
invoking through workflows 31

backups
database 43
restoring in database 44

banner
customizing 19

business rules
installing 4

C
CMIS

configuring settings for 28
integrating with 28

configuration
background checks 27
cookie name 13
credential contract restrictions 23
currency 25
database 7
IBM Incentive Compensation Management

synchronization 30
IdP 40
import mass change settings 30
JBoss Drools Guvnor 8
language 9
LDAP 41
liability coverage 23
login settings 25
mail settings 10, 22
multiple appointments for single product 23
onboarding kit constraints 24
percentage 25
pre-hiring 24
producer name format 25
producer settings 22
rules 31
single sign on 38
SSL 13
time zone 14
user-defined workflows 28
web services 7
workflows 31, 35

currency
configuration 25

D
databases

backing up 43
backup 43
configuring access to 7
creating 3
installing 3
permissions 3
restoration 43
restoring backups 44
transferring between servers 44
upgrading 45

Depository Trust & Clearing Corporation
See DTCC

document management system
configuring settings for 28
integrating with 28

DTCC
adding configuration settings for 21

E
encrypted links

configuring 13
exception log

viewing 16

F
Financial Industry Regulatory Authority

See FINRA
FINRA

adding configuration settings for 21

G
glossary 53

H
HTTP

disabling 14

I
IBM Incentive Compensation Management

configuring synchronization with 30
IBM License Metric Tool

integration with 12
SLMT files

interpreting 12
IBM PLCM web service

installing 15
Identity Provider

See IdP
IdP

setting up access for 40
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import mass change
configuring settings for 30

installation
database 3
files 5
Java 2
JBoss Drools Guvnor 4
JBoss jBPM Designer 4
overview 1
prerequisites 1
Producer Lifecycle and Credential Management 5
reinstalling 6
service 15

J
Java 8

installing 2
JBoss Drools Guvnor

configuring access to 8
configuring workflows in 35
importing processes into 35
importing rules into 33
importing workflow objects into 34
installing 4
overview 1

JBoss jBPM Designer
installing 4
overview 1

K
keystore

generating 37
importing the public key into 40

L
languages

configuring 9
configuring producer name format 25

LDAP
configuring 41

liability coverage
configuring 23

license metrics
configuring details for 11
interpreting 12
tracking of 11

Lightweight Directory Access Protocol
See LDAP

login 16
configuring settings for 25

M
mail settings

configuring 10, 22
memory

increasing space for 14
Microsoft SQL Server

database backup 43
installing 3
permissions 3

migration
configuring directory for 29
configuring export file delimiter for 10

multiple appointments for single product
enabling 23

N
National Insurance Producer Registry

See NIPR
NIPR

adding configuration settings for 20
setting up alerts for 20

O
onboarding kits

configuring cancellation constraints for 24
configuring rejection constraints for 24

operations
configuring 29

P
payments

NIPR 20
percentage

configuration 25
permanent generation heap 14
permissions

database 3
pre-hired producers

enabling 24
prerequisites

overview 1
pre-installation checklist 1

processes
importing rules into JBoss Drools Guvnor 35
installing 4

producers
configuring settings for 22

R
restoration

database 43
rules

configuring 31
configuring definitions for 8
reloading 36

S
Secure Sockets Layer

See SSL
servers

transferring databases between 44
services

See web services
sign on 37
single sign on 37

configuring 38
generating a keystore for 37
importing the public key 40
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SSL
configuring 13
disabling HTTP protocol 14

system configuration settings
customizing banner 19
DTCC 21
FINRA 21
NIPR 20
overview 19

U
uninstallService.bat file 45
upgrades

databases 45
overview 43
process 45

V
validation

configuration 35

W
WAR files

JBoss Drools Guvnor 4
JBoss jBPM Designer 4
overview 1

web services
configuring 7
installing 15
starting automatically 16

workflow rules
mapping user-defined 28

workflows
configuring 8, 31, 35
descriptions 31
importing objects into JBoss Drools Guvnor 34
importing rules into JBoss Drools Guvnor 33
installing 4

wrapper.conf file 45
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