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Introduction

IBM® Predictive Customer Intelligence gives you the information and insight that
you need to provide proactive service to your customers. The information can help
you to develop a consistent customer contact strategy and improve your
relationship with your customers.

Audience

This guide is intended to provide users with an understanding of how the IBM
Predictive Customer Intelligence solution works. It is designed to help people who
are planning to implement IBM Predictive Customer Intelligence know what tasks
are involved.

Finding information

To find product documentation on the web, including all translated
documentation, access IBM Knowledge Center (http://www.ibm.com/support/
knowledgecenter).

You can also access PDF versions of the documentation from the Predictive
Customer Intelligence web page (www.ibm.com/support/
docview.wss?uid=swg27041723).

Accessibility features

Accessibility features help users who have a physical disability, such as restricted
mobility or limited vision, to use information technology products. Some of the
components included in the IBM Predictive Customer Intelligence have
accessibility features.

IBM Predictive Customer HTML documentation has accessibility features. PDF
documents are supplemental and, as such, include no added accessibility features.

Forward-looking statements

This documentation describes the current functionality of the product. References
to items that are not currently available may be included. No implication of any
future availability should be inferred. Any such references are not a commitment,
promise, or legal obligation to deliver any material, code, or functionality. The
development, release, and timing of features or functionality remain at the sole
discretion of IBM.

Samples disclaimer

Sample files may contain fictional data manually or machine generated, factual
data compiled from academic or public sources, or data used with permission of
the copyright holder, for use as sample data to develop sample applications.
Product names referenced may be the trademarks of their respective owners.
Unauthorized duplication is prohibited.
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Chapter 1. IBM Predictive Customer Intelligence

IBM Predictive Customer Intelligence brings together in a single solution the
ability to do the following tasks:
v Determine the best offer for a customer.
v Retain customers that are likely to churn.
v Segment your customers, for example, by family status and salary.
v Identify the most appropriate channel to deliver an offer, for example, by email,

telephone call, or application.

This solution ensures that all interactions with customers are coordinated and
optimized. Predictive customer intelligence gives you the ability to sift quickly
through millions of subscribers and know who to contact, when, and with what
action.

The following steps define the process:
1. Understand the customer. Predictive modeling helps you to understand what

market segments each customer falls into, what products they are interested in,
and what offers they are most likely to respond to.

2. Define possible actions and the rules and models that determine which
customers are eligible for which offers.

3. After the best action is identified, deliver the recommendation to the customer.

Integration with the IBM Enterprise Marketing Management
(EMM) suite

IBM Predictive Customer Intelligence integrates with the following solutions:
v IBM Campaign, a web-based solution that enables users to design, run, and

analyze direct marketing campaigns.
v IBM Interact, which provides personalized offers and customer profile

information in real time.
v IBM Marketing Platform, which provides security, configuration, and dashboard

features for IBM EMM products.

IBM Predictive Customer Intelligence provides two connectors between IBM
Interact and IBM SPSS® Collaboration and Deployment Scoring Service:
v The External Callout connector calls an IBM SPSS model at run time, and is

contained within the expression of an advanced rule for a marketer score,
overriding the score that is supplied by the EMM campaign.

v The External Learning connector extends IBM Interact's native learning module
to monitor visitor actions and propose optimal offers. It prioritizes IBM
Campaign offers based on an IBM SPSS model's prediction of their final score.
The connector passes specific configurable parameters as input to the IBM SPSS
Scoring Service.

Integration with the IBM Next Best Action Optimizer

IBM Next Best Action Optimizer (NBAOPT) segregates customers by lifetime
value, and then provides recommended actions to retain customers, which are
based on their lifetime value segment.

© Copyright IBM Corp. 2014 1



You can integrate NBAOPT with the IBM Predictive Customer Intelligence
solution. Install the NBAOPT connector to add an NBAOPT item to the IBM SPSS
Modeler Tools menu. You can start the NBAOPT Studio from this menu, and you
can generate a stream from PMML files.

Solution architecture
The IBM Predictive Customer Intelligence solution uses several different nodes,
where each node provides a specific function for the solution. Each node represents
a separate computer or a separate virtual machine image from the other nodes. A
default environment installation of uses four nodes.

The following diagram shows the nodes in the architecture, with the software
installed on each node.

Predictive Analytics node

The Analytics node provides predictive scores and offers recommendations.

This node has the following software installed:
v IBM WebSphere® Application Server Network Deployment
v IBM SPSS Collaboration and Deployment Services
v IBM SPSS Modeler Server
v IBM SPSS Modeler Collaboration and Deployment Services Adapter

Figure 1. Predictive Customer Intelligence nodes
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v IBM SPSS Modeler Server Social Network Analysis
v IBM SPSS Statistics Server
v IBM Analytic Decision Management
v IBM SPSS Text Analytics Server
v IBM SPSS Data Access Pack
v IBM DB2® Client

Optionally, you can distribute the Analytics node components onto additional
computers in your environment. For example, you can add a node on which only
IBM SPSS Collaboration and Deployment Services is installed. Distributing
components can be done only after you complete a default environment
installation.

Business Intelligence node

The BI node provides dashboards and reports.

This node has the following software installed:
v IBM HTTP Server
v IBM Cognos® Business Intelligence
v IBM DB2 Client

Optional components are also available, such as IBM Cognos Mobile and IBM
Cognos Real-time Monitoring.

Integration Bus node

The Integration Bus node processes events, updates the content for IBM Cognos
Business Intelligence, and triggers predictive scoring and decision management. It
also loads master data into the solution.

This node has the following software installed:
v IBM WebSphere MQ
v IBM Integration Bus
v IBM Integration Bus Explorer
v IBM Integration Toolkit
v IBM DB2 Client

data node

The data node provides the database server that contains the databases that are
used by other products in the solution. The database acts as an event store and
holds calculated key performance indicators (KPIs) and profiles. It also contains
supporting master data for the solution.

This node has the following software installed:
v IBM DB2 Enterprise Server Edition

Chapter 1. IBM Predictive Customer Intelligence 3
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Chapter 2. Installation prerequisites and preparation

Before you install IBM Predictive Customer Intelligence, ensure that the computers
that you use meet the minimum requirements for operating systems, prerequisite
software, processing, and disk space.

Supported operating systems and hardware requirements
Review the minimum hardware and operating system requirements before you
install IBM Predictive Customer Intelligence. The requirements apply for all
computers or virtual machines that you use for the installation.

Server computers

The Predictive Customer Intelligence server components must be installed on
computers that run Microsoft Windows 2008 Server (x86_64) operating systems.

Hardware requirements

At a minimum, each computer or virtual machine that hosts a Predictive
Customer Intelligence server component, or node, must have the following
hardware requirements:
v 4 processors
v 32 GB of RAM
v 300 GB of hard disk space

If you are expecting to store large volumes of data, you might need to
increase your disk size.

For best performance, each node should be installed on a separate
computer or on a separate virtual machine image.

User requirements

You must have administrator access to all of the computers on which you
install a Predictive Customer Intelligence node.

Client computers

The Predictive Customer Intelligence client components must be installed on
computers that run Microsoft Windows 7 operating systems.

Clients can be installed on 32-bit or 64-bit computers. 64-bit is recommended.

At a minimum, each Predictive Customer Intelligence client computer and the
computer where you run the Deployment Wizard for the client components, must
have the following hardware requirements:
v 2 processors
v 8 GB of RAM
v 150 GB of hard disk space

© Copyright IBM Corp. 2014 5
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Chapter 3. Installation of the server components

You install each IBM Predictive Customer Intelligence component using the
installation program that is provided with that component.

Starting the Launchpad for the server components
Use the Launchpad to start the IBM Predictive Customer Intelligence installation.

Procedure
1. Go to the folder where you downloaded the installation files.
2. Decompress the installation files.
3. Go to the disk1 directory where you decompressed the files.
4. In the disk1 folder, double-click Launchpad.exe or Launchpad64.exe.
5. Review the information in the Launchpad panels.

Starting the Deployment Wizard for the server components
Use the Launchpad to start the IBM Predictive Customer Intelligence server
Deployment Wizard.

Tip: You might need to adjust your Windows User Access Control (UAC) settings
so that you can run the installation program for the client components.

Procedure
1. In the Launchpad, click Deploy Server.
2. Click Start Deployment Wizard.

Changing the temporary location for installation files
The Deployment Wizard uses a temporary folder for installation source files. You
must ensure that you are using a location that has adequate disk space for the
installation source files. If you do not have enough disk space in the default
location, you can change the location.

For example, the default location is C:\Progam Files (x86)\Common
Files\SL_####\SolutionEnabler. If space is limited on your C drive, you can
change the temporary location to another drive.

The temporary files include jar files that are used during the installation, which
you might want to delete after you complete the installation.

Procedure
1. In the Deployment Wizard, click Edit > Preferences.

The Deployment Preferences window appears.
2. In the Deployment Package Path box, select an existing location.
3. Click OK.
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Specifying the target computers to install the server components
You must specify a different target computer for each IBM Predictive Customer
Intelligence node. A node can be installed on a computer or virtual machine, but
each node must be installed on a separate computer or virtual machine.

To ensure that the server installers are successfully deployed to each node
computer, temporarily turn off each node computer's firewall settings during the
deployment.

Procedure
1. On the Specify Target Computers pages of the Deployment Wizard, enter the

name or IP address of the computer on which you install a node in the Target
Computer box.
The Deployment Wizard prompts you for each node computer.
If you install a node on the computer where you run the Deployment Wizard,
you can enter localhost.

2. Click Add.
When you enter a computer other than localhost, in the Target Computer
Credentials box, do the following steps:
a. When you enter a computer other than localhost, in the Target Computer

Credentials box, enter the User ID and Password for a user with
permissions for that computer.

b. Click Test Login.
c. Click Add.

The computer that you entered appears in the Selected target computers
box.

3. In the Selected target computers box, select the target computer, and click Test
Connections.

Important: Test Connections tests the connection, tests the credentials, and
locates or enables a deployment agent on the target computer. You must have
an active deployment agent on each target computer.

4. Click Next.
5. Repeat the steps for each computer on which you install a node.

Configuring parameters for the server components installation
The Deployment Wizard displays some default values for each component of IBM
Predictive Customer Intelligence. You can accept the default values or change them
to suit your environment.

Important: The Deployment Wizard copies the installers to your computer. You
must run each installer individually after they are copied to your computer.

Procedure

On the Configure Parameters pages, enter the location on the target computer for
where you want to install the server installers. The default is C:\IBM\PCI. The same
path is used on each target computer.
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Starting the installation
After you enter all of the required fields in the Deployment Wizard, you can start
the installation and configuration of the IBM Predictive Customer Intelligence
components.

Procedure

On the Summary Panel of the Deployment Wizard, click Deploy all.
If you choose to deploy the tasks individually, you must click Deploy task for each
task in the order that the tasks appear on the Summary panel.

Note: The time to deploy the software is estimated by the Deployment Wizard.
The actual time required depends on a variety of factors, such as network speed.
In most cases, the deployments will take significantly less time than what is
initially displayed by the Deployment Wizard.

Install IBM DB2 software on the data node computer
You must install IBM DB2 Enterprise Server Edition version 10.1 Fix Pack 3. IBM
DB2 is used for product databases, such as the IBM Cognos Business Intelligence
content store database, the IBM SPSS database, and for client application data.

After you install the database software, you must create a database for the IBM
SPSS components.

Installing IBM DB2 Enterprise Server
You must install IBM DB2 Enterprise Server Edition version 10.1 Fix Pack 3.

Procedure
1. Go to the Server\Database folder where you installed the Predictive Customer

Intelligence server installation files.
2. Double-click v10.1fp3_ntx64_server.exe to decompress the installation files.
3. Go to the SERVER folder where you decompressed the files, and double-click

setup.exe.
4. In the DB2 Setup Launchpad, click Install a Product.
5. Under DB2 Enterprise Server Edition Version 10.1 Fix Pack 3, click Install

New.
6. Select Typical for the installation type.
7. Select Install DB2 Enterprise Server Edition on this computer.
8. Follow the steps in the wizard to install and configure your database server.

For more information about any of the settings, see the IBM DB2
documentation.

Adding the IBM DB2 license
You must add the DB2 license after you install IBM DB2 Enterprise Server for IBM
Predictive Customer Intelligence.

Procedure
1. Go to the Server\Database folder where you installed the Predictive Customer

Intelligence server installation files.
2. Decompress the file that is named DB2_ESE_Restricted_QS_Activation_10.zip.

Chapter 3. Installation of the server components 9



3. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window -
Administrator.

4. Type the following command and press Enter:
db2licm -a decompressed_folder_location\ese_o\db2\license\db2ese_o.lic
For example, if you decompressed the file in the default location, the command
would be: db2licm -a C:\IBM\PCI\Server\Database\
DB2_ESE_Restricted_QS_Activation_10\ese_o\db2\license\db2ese_o.lic

5. Type the following command to validate that the license was added:
db2licm -l

Creating a database for the SPSS components
After you install the IBM DB2 database server for IBM Predictive Customer
Intelligence, you must create a database for the SPSS components.

Procedure
1. Log on to the data node computer as a DB2 instance owner user.
2. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window -

Administrator.
3. Enter the following script to create a database:

DB2 CREATE DATABASE SPSSDB ON path USING CODESET UTF-8
TERRITORY US COLLATE USING SYSTEM

path can be a file path or just a drive letter. For example,
DB2 CREATE DATABASE SPSSDB ON C: USING CODESET UTF-8

TERRITORY US COLLATE USING SYSTEM

4. Connect to the database you created by using the following command:
DB2 CONNECT TO SPSSDB

5. Enter the following commands to create the bufferpools for the database. Enter
each command individually.
DB2 CREATE Bufferpool CDS8K IMMEDIATE SIZE 250 AUTOMATIC PAGESIZE 8 K

DB2 CREATE REGULAR TABLESPACE CDS8K PAGESIZE 8 K MANAGED BY AUTOMATIC
STORAGE EXTENTSIZE 8 OVERHEAD 10.5 PREFETCHSIZE 8 TRANSFERRATE 0.14
BUFFERPOOL CDS8K DROPPED TABLE RECOVERY ON

DB2 CREATE Bufferpool CDSTEMP IMMEDIATE SIZE 250 PAGESIZE 32 K

DB2 CREATE SYSTEM TEMPORARY TABLESPACE CDSTEMP PAGESIZE 32 K MANAGED BY AUTOMATIC
STORAGE EXTENTSIZE 16 OVERHEAD 10.5 PREFETCHSIZE 16 TRANSFERRATE 0.14
BUFFERPOOL "CDSTEMP"

Install software on the Predictive Analytics node computer
For IBM Predictive Customer Intelligence, install SPSS software on the Predictive
Analytics node computer.

Installing IBM DB2 client software on the Analytics node
computer

You must install IBM DB2 client software on the IBM Predictive Customer
Intelligence Predictive Analytics node computer.

Procedure
1. Go to the install_location\Server\Database folder where you installed the

Predictive Customer Intelligence server installation files.
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By default, the install_location is C:\IBM\PCI\.
2. Double-click v10.1fp3_ntx64_rtcl.exe to extract the installation files.
3. Select a Typical installation, and follow the steps in the DB2 Setup wizard to

install the product.

Installing IBM Installation Manager on the Predictive Analytics
node computer

Install IBM Installation Manager before you install other IBM Predictive Customer
Intelligence software.

Procedure
1. Go to the install_location\Server\InstallationManager folder where you

installed the Predictive Customer Intelligence server installation files.
By default, the install_location is C:\IBM\PCI\.

2. Decompress the installation files.
3. Double-click install.exe.
4. Follow the steps to install IBM Installation Manager.

Installing WebSphere Application Server on the Predictive
Analytics node computer

You install WebSphere Application Server by using IBM Installation Manager.

Procedure
1. Go to the install_location\Server\WebSphereApplicationServer folder where

you installed the Predictive Customer Intelligence server installation files.
2. Decompress the installation files.

You must decompress all of the compressed files.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the WAS_ND_V8.5.5_1_OF_3 folder, select repository.config, and click Open,

and OK.
8. In IBM Installation Manager, click Install.
9. Under IBM WebSphere Application Server Network Deployment, select

Version 8.5.5.0.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. When prompted for Which program do you want to start?, select Profile

Management Tool to create a profile, and click Finish.
12. In the WebSphere Customization Toolbox 8.5 window, click Create.
13. Select Application Server, and click Next.
14. Select Typical profile creation, and click Next.
15. Follow the steps in the wizard to configure your application server. For more

information about any of the settings, see the WebSphere Application Server
documentation.
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Installing IBM SPSS Collaboration and Deployment Services
Server

You install IBM SPSS Collaboration and Deployment Services Server on the IBM
Predictive Customer Intelligence Predictive Analytics node computer.

Procedure
1. Go to the install_location\Server\SPSS_CNDS folder where you installed the

Predictive Customer Intelligence server installation files.
2. Decompress the installation files.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the Server_Repository folder, select repository.config, and click Open,

and OK.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select the following components.

v IBM SPSS Collaboration and Deployment Services

v IBM SPSS Collaboration and Deployment Services - Remote Process
Server

v IBM SPSS Collaboration and Deployment Services - Scoring Server

v IBM SPSS PMML Scoring Adapter

10. Click Next, and follow the steps in IBM Installation Manager to install the
products.

11. On the Common Configuration for IBM SPSS Collaboration and
Deployment Services - Remote Process Server pages, enter the following
information:

Database Type
Select IBM DB2.

Database Machine Name or IP
The name or IP address of the computer where you installed IBM DB2
and created the SPSSDB database.

Database Name
Enter SPSSDB.

Port Number
Enter 50000, the default port number for IBM DB2.

User name
Enter the user name of your IBM DB2 administrator user.

Password
Enter the password for your IBM DB2 administrator user.

Remote Process Service Name
Leave the default value RemoteProcessServer.

Port Number
Change the default only if the default value 2211 causes a port
conflict.

12. Leave the Configure Clustering check box clear, and click Next.
13. Select IBM WebSphere Application Server, and click Next.
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14. Click Install.
15. In the Which programs do you want to start box, select IBM SPSS

Collaboration and Deployment Services Configuration Tool 6.0, and click
Finish.

16. In the IBM SPSS Collaboration and Deployment Services Configuration
Tool, click Next.

17. On the Application Server page, enter the information for IBM WebSphere
Application Server, and click Next.
For the WebSphere profile directory value, the default location is C:\Program
Files (x86)\IBM\WebSphere\AppServer\profiles\AppSrv01.

18. On the Database page, enter the information for the SPSSDB database, and
click Next.

19. On the Encryption page, enter a password, and click Next.
20. On the Repository Admin page, enter a password for the SPSS admin user,

and click Next.
21. On the Deployment mode page, select Automatic, and click Next.
22. Click Configure.
23. Click Finish.

Installing IBM SPSS Enterprise View Driver software
Install IBM SPSS Collaboration and Deployment Services Enterprise View Driver
software on the IBM Predictive Customer Intelligence Predictive Analytics node
computer.

Procedure
1. Go to the install_location\Server\EntViewDriver folder where you installed

the Predictive Customer Intelligence server installation files.
2. Decompress the installation files.
3. Go to the Enterprise_View_Driver_64 folder, and double-click

setupWindows64-amd64.exe.
4. Follow the steps in the wizard to install the driver.

Installing IBM SPSS Modeler Server software
Install IBM SPSS Modeler Server software on the IBM Predictive Customer
Intelligence Predictive Analytics node computer.

Procedure
1. Go to the install_location\Server\ModelerServer folder where you installed

the Predictive Customer Intelligence server installation files.
2. Decompress the installation files.
3. Double-click setup.exe.
4. On the Server Mode page, select Production Mode.
5. Follow the steps in the wizard to install the server.

Installing IBM SPSS Collaboration and Deployment Services
Modeler Adapter

Install IBM SPSS Collaboration and Deployment Services Adapter software on the
IBM Predictive Customer Intelligence Predictive Analytics node computer.
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Procedure
1. Go to the install_location\Server\CNDSModelerAdapter folder where you

installed the Predictive Customer Intelligence server installation files.
2. Decompress the installation files.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the disk1 folder, select diskTag.inf, and click Open, and OK.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select IBM SPSS Modeler Adapters for

Collaboration and Deployment Services.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. On the Install Packages page, select Use the existing package group, select

IBM SPSS Collaboration and Deployment Services 6.0, and click Next.
12. On the Common Configurations page, enter the SPSS administrator user and

password, and click Next.
13. Click Install, and click Finish.

Installing IBM Analytical Decision Management software
Install IBM Analytical Decision Management software on the IBM Predictive
Customer Intelligence Predictive Analytics node computer.

A sample Analytical Decision Management application is provided with the
installation files. The sample application is provided in a compressed file that is
named ADM_80_Demo.zip. For more information about the sample file, see the
Analytical Decision Management documentation (www.ibm.com/support/
knowledgecenter/SS6A3P_8.0.0).

Procedure
1. Go to the install_location\Server\ADM folder where you installed the

Predictive Customer Intelligence server installation files.
2. Decompress the installation file that is named ADM_80_Repository_mp.zip.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the adm_repository folder, select repository.config, and click Open and

OK.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select IBM Analytical Decision Management.

10. Click Next, and follow the steps in IBM Installation Manager to install the
product.

11. On the Install Packages page, select Use the existing package group, select
IBM SPSS Collaboration and Deployment Services 6.0, and click Next.

12. On the Install Packages page, select Production for the Installation Type.
Ensure that all of the options under IBM Analytical Decision Management
Applications are selected.
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13. On the Common Configurations page, enter the SPSS administrator user and
password, and click Next.

14. Click Install.
15. Click Finish.

Installing IBM SPSS Data Access Pack
Install the IBM SPSS Data Access Pack software on the IBM Predictive Customer
Intelligence Predictive Analytics node computer.

Before you begin

You must stop the IBM WebSphere Application Server profile where IBM SPSS
products are installed and stop IBM SPSS Modeler Server before you install the
Data Access Pack.

Procedure
1. Click Start > All Programs > IBM WebSphere > Profiles > AppSrv01 > Stop

the server to stop the WebSphere Application Server where the SPSS
components are running.

2. Stop IBM SPSS Modeler Server from the Microsoft Windows Services tool.
For more information, see the IBM SPSS Modeler documentation
(www.ibm.com/support/knowledgecenter/SS3RA7_15.0.0/
com.ibm.spss.modeler.help/admin_startstop_startstop_win.htm?lang=en).

3. Go to the install_location\Server\DataAccessPack folder where you installed
the Predictive Customer Intelligence server installation files.

4. Decompress the installation files.
5. Go to the Win64 folder, and double-click SDAP_7.1_win64.exe.
6. Follow the steps in the wizard to install the Data Access Pack.
7. Click Start > All Programs > IBM WebSphere > Profiles > AppSrv01 > Start

the server to start the WebSphere Application Server where the SPSS
components are running.

8. Start IBM SPSS Modeler Server.

Installing IBM SPSS Text Analytics Server
Install IBM SPSS Text Analytics Server software on the IBM Predictive Customer
Intelligence Predictive Analytics node computer.

Procedure
1. Go to the install_location\Server\TextAnalytics folder where you installed

the Predictive Customer Intelligence server installation files.
2. Decompress the installation files.
3. Double-click setup.exe.
4. Follow the steps in the wizard to install the server software.

Installing IBM SPSS Modeler Server Social Network Analysis
software

Install IBM SPSS Modeler Server Social Network Analysis software on the IBM
Predictive Customer Intelligence Predictive Analytics node computer.
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Procedure
1. Go to the install_location\Server\SocialNetworkAnalytics folder where you

installed the Predictive Customer Intelligence server installation files.
2. Decompress the installation files.
3. Double-click sna_server_installer_win64.exe.
4. Follow the steps in the wizard to install the server software.

Installing IBM SPSS Modeler Solution Publisher
Install IBM SPSS Modeler Solution Publisher and IBM SPSS Modeler Premium
Solution Publisher software on the IBM Predictive Customer Intelligence Predictive
Analytics node computer.

Note: You must install IBM SPSS Modeler Premium Solution Publisher to the same
location where you installed IBM SPSS Modeler Solution Publisher.

Procedure
1. Install IBM SPSS Modeler Solution Publisher.

a. Go to the install_location\Server\ModelerSolnPublisher folder where
you installed the Predictive Customer Intelligence server installation files.

b. Decompress the installation files.
c. Double-click setup.exe.
d. Follow the steps in the wizard to install the software.

2. Install IBM SPSS Modeler Premium Solution Publisher.
a. Go to the Server\ModelerPremiumSolnPub folder where you installed the

Predictive Customer Intelligence server installation files.
b. Decompress the installation files.
c. Double-click spss_mpsp_16.0_64b_win_ml.exe.
d. Follow the steps in the wizard to install the software.

Installing IBM SPSS Statistics Server software
Install IBM SPSS Statistics Server software on the IBM Predictive Customer
Intelligence Predictive Analytics node computer.

Procedure
1. Go to the install_location\Server\StatisticsServer folder where you

installed the Predictive Customer Intelligence server installation files.
2. Double-click SPSS_Statistics_Server_22_win64.exe.
3. Follow the steps in the wizard to install the software.
4. On the Server Mode page, select Production Mode.
5. On the IBM SPSS Statistics - Essentials for Python page, click Yes, and then

click Next.
6. On the Server IP Address page, enter the IP address of the computer where

you are installing IBM SPSS Statistics Server, and set the Port Number to 3022.
7. Click Next.
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Installing IBM SPSS Statistics Collaboration and Deployment
Services Adapter

Install IBM SPSS Statistics Collaboration and Deployment Services Adapter
software on the IBM Predictive Customer Intelligence Predictive Analytics node
computer.

Procedure
1. Go to the install_location\Server\CNDSStatAdapter folder where you

installed the Predictive Customer Intelligence server installation files.
2. Decompress the installation files.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the repository directory, select repository.config, and click Open, and

OK.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select IBM SPSS Collaboration and

Deployment Services - Server Adapter for Statistics.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. On the Install Packages page, select Use the existing package group, select

IBM SPSS Collaboration and Deployment Services 6.0, and click Next.
12. On the Common Configurations page, enter the SPSS administrator user and

password, and click Next.
13. Click Install.
14. Click Finish.

Install software on the Business Intelligence node computer
You must install an IBM DB2 client, IBM HTTP Server, and IBM Cognos Business
Intelligence on the IBM Predictive Customer Intelligence Business Intelligence node
computer.

Installing IBM DB2 client software on the BI node computer
You must install IBM DB2 client software on the Predictive Customer Intelligence
Business Intelligence node computer by using the IBM DB2 Enterprise Server
installer.

Procedure
1. Go to the install_location\Server\Database folder where you installed the

Predictive Customer Intelligence server installation files.
By default, the install_location is C:\IBM\PCI\.

2. Double-click v10.1fp3_ntx64_rtcl.exe to extract the installation files.
3. Select a Typical installation, and follow the steps in the DB2 Setup wizard to

install the product.

Installing IBM Installation Manager on the BI node computer
Install IBM Installation Manager before you install other IBM Predictive Customer
Intelligence software.
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Procedure
1. Go to the install_location\Server\InstallationManager folder where you

installed the Predictive Customer Intelligence server installation files.
By default, the install_location is C:\IBM\PCI\.

2. Decompress the installation files.
3. Double-click install.exe.
4. Follow the steps to install IBM Installation Manager.

Installing IBM HTTP Server on the BI node computer
You install IBM HTTP Server by using IBM Installation Manager.

Procedure
1. Go to the install_location\Server\HTTPServer folder where you installed the

Predictive Customer Intelligence server installation files.
2. Decompress the installation files.

You must decompress all of the compressed files.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you extracted the installation files.
7. Select repository.config, and click Open, and OK.
8. In IBM Installation Manager, click Install.
9. Under IBM HTTP Server for WebSphere Application Server, select Version

8.5.5.0.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
a. On the Configuration for IBM HTTP Server for WebSphere Application

Server 8.5.5.0 page, change the HTTP port value only if you have another
web server that is running on your computer and is already using port 80.

Note: If you use a port other than 80, you must change the port number
in the Gateway URI in IBM Cognos Configuration.

Installing IBM Cognos Business Intelligence
Install IBM Cognos Business Intelligence software on the IBM Predictive Customer
Intelligence Business Intelligence node computer.

For more information about IBM Cognos Business Intelligence, see the product
documentation (www.ibm.com/support/knowledgecenter/SSEP7J_10.2.1).

Important: The IBM Cognos Business Intelligence installation files are provided in
tar.gz compressed format. You may have to use a decompression utility other
than the one provided by Microsoft Windows to decompress the files. For example,
you can use a decompression utility such as 7-Zip or WinZip to decompress the
files.

Procedure
1. Install IBM Cognos BI.

a. Go to the install_location\Server\CognosBIServer folder where you
installed the Predictive Customer Intelligence server installation files.
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b. Decompress bi_svr_64b_10.2.1_win_ml.tar.gz.
Decompressing the IBM Cognos installation files is a two-step process. You
must decompress the tar.gz file, and then decompress the tar file.

c. Go to the folder where you decompressed
bi_svr_64b_10.2.1_win_ml.tar.gz.

d. Decompress bi_svr_64b_10.2.1_win_ml.tar.
e. Go to the win64h folder, and double-click issetup.exe.
f. Follow the steps in the wizard to install the server software.
g. On the Component Selection page, select the following components:

v Application Tier Components

v Gateway

v Content Manager

Note: Do not install the Cognos Content Database component.
h. Clear the Start IBM Cognos Configuration box, and click Finish.

2. Install the IBM Cognos BI fix pack.

Important: Ensure that you decompress the fix pack to a different location than
the IBM Cognos BI installation files. Some directories will be overwritten if you
use the same location.
a. Go to the install_location\Server\CognosBIServer folder where you

installed the Predictive Customer Intelligence server installation files.
b. Decompress up_bisrvr_winx64h_10.2.5001.156_ml.tar.gz, and then

decompress up_bisrvr_winx64h_10.2.5001.156_ml.tar.
c. Go to the win64h folder, and double-click issetup.exe.
d. Follow the steps in the wizard to install the server software.
e. On the Installation Location page, browse to the location where you

installed IBM Cognos BI. For example, C:\Program Files\ibm\cognos\
c10_64.

f. Click Finish.
3. Optional: Install IBM Cognos Mobile and the IBM Cognos Mobile fix pack.

For more information about IBM Cognos Mobile, see the product
documentation (www.ibm.com/support/knowledgecenter/SSEP7J_10.2.1).my
a. Go to the install_location\Server\CognosMobile folder where you

installed the Predictive Customer Intelligence server installation files.
b. Decompress up_bisrvr_winx64h_10.2.5001.1033_ml.tar.gz, and then

decompress up_bisrvr_winx64h_10.2.5001.1033_ml.tar.
c. Go to the win64h folder, and double-click issetup.exe.
d. Follow the steps in the wizard to install the server software.
e. Decompress mobile_10.2.1_mp_ml.tar.gz, and then decompress

mobile_10.2.1_mp_ml.tar.
f. Go to the win64h folder, and double-click issetup.exe.
g. Follow the steps in the wizard to install the server software.

Note: You must install IBM Cognos Mobile to the same folder where you
installed IBM Cognos BI.

h. Decompress up_cogmob_winx64h_10.2.5002.46_ml.tar.gz, and then
decompress up_cogmob_winx64h_10.2.5002.46_ml.tar.

i. Go to the win64h folder, and double-click issetup.exe.
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Configure and start IBM Cognos BI
After you install IBM Cognos Business Intelligence, you must create a content store
database, save your configuration settings, and start the services.

Configuring IBM HTTP Server for IBM Cognos BI
You must configure the IBM Cognos Business Intelligence gateway on your web
server.

Procedure
1. Go to the HTTPServer_installation\conf\ folder. For example, go to the

C:\Program Files (x86)\IBM\HTTPServer\conf folder.
2. Open the httpd.conf file in a text editor.
3. Add the following lines to file:

ScriptAlias /ibmcognos/cgi-bin/ "Cognos_installation/cgi-bin/"
<Directory "Cognos_installation/cgi-bin/">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

Alias /ibmcognos/ "Cognos_installation/webcontent/"
<Directory "Cognos_installation/webcontent/">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

Note: Ensure that you add the /ibmcognos/cgi-bin/ ScriptAlias before the
/ibmcognos/ Alias.
For example, if you use the default installation location, add the following
lines:
ScriptAlias /ibmcognos/cgi-bin/ "C:/Program Files/IBM/cognos/c10_64/cgi-bin/"
<Directory "C:/Program Files/IBM/cognos/c10_64/cgi-bin/">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

Alias /ibmcognos/ "C:/Program Files/IBM/cognos/c10_64/webcontent/"
<Directory "C:/Program Files/IBM/cognos/c10_64/webcontent/">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

4. Save and close the file.
5. Restart the web server.

a. Click Start > All Programs > IBM HTTP Server V8.5 > Stop HTTP Server.
b. Click Start > All Programs > IBM HTTP Server V8.5 > Start HTTP Server.

Copying the JAR files for IBM DB2
You must copy two jar files from your IBM DB2 installation to your IBM Cognos
Business Intelligence installation location.
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Procedure

Copy the following files from the DB2_client_installation\sqllib\java folder to
the Cognos_installation\webapps\p2pd\WEB-INF\lib folder:
v db2jcc.jar

v db2jcc_license_cu.jar

Configuring IBM Cognos BI
You configure IBM Cognos Business Intelligence using IBM Cognos Configuration.

For more information about configuring IBM Cognos BI, see the Business
Intelligence Installation and Configuration Guide on IBM Knowledge Center
(www.ibm.com/support/knowledgecenter/SSEP7J_10.2.1).

Procedure
1. Click Start > All Programs > IBM Cognos 10_64 > IBM Cognos

Configuration.
2. In the Explorer pane, select Environment, and replace localhost with the name

or IP address of your computer in the following fields:
v Gateway URI (If you are using a port number other than 80 for the web

server, ensure that you also change the port number value to the port
number for IBM HTTP Server.)

v Dispatcher URIs for Gateway

v External dispatcher URI

v Internal dispatcher URI

v Dispatcher URI for external applications

v Content Manager URIs

3. Leave IBM Cognos Configuration open.

Creating a content store database for IBM Cognos BI
You create a database script on your IBM Predictive Customer IntelligenceBusiness
Intelligence node computer when you configure IBM Cognos BI. You use the script
to create the content store database on your data node computer.

Procedure
1. In IBM Cognos Configuration, configure a content store database.

Note: The information you enter is used to generate a script that you use to
create the content store database on the data node computer.
a. In the Explorer pane, under Data Access > Content Manager, click Content

Store.
b. In the Database server and port number field, enter the name of the

computer and the port number on which you installed IBM DB2 Enterprise
Server. For example, enter servername:50000, where servername is the name
of the data node computer and 50000 is the default port number that is
used by IBM DB2.

c. Click the Value field next to the User ID and password property, click the
edit icon, and enter the User ID and Password for your IBM DB2 user, and
click OK.

d. In the Properties pane, for the Database name property, enter a name for
your content store database.
The default name is cm.
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Restriction: Do not use a name longer than 8 characters and use only
letters, numbers, underscores, or hyphens in the name.

2. Right-click Content Store, and click Generate DDL.
The DDL file, createDb.sql, is created in the Cognos_installation\
configuration\schemas\content\db2 folder.

3. Copy createDb.sql from the BI node computer to the data node computer.
4. On your data node computer, create the content store database.

a. Log on to the data node computer as a DB2 user with privileges to create a
database.

b. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window
- Administrator.

c. Type db2 -tvf path\createDb.sql, and press Enter.
5. Leave IBM Cognos Configuration open.

Starting the IBM Cognos BI services
You start the IBM Cognos BI services by using IBM Cognos Configuration.

Procedure
1. In IBM Cognos Configuration, click File > Save.
2. Test the connection to the content store database.

a. In IBM Cognos Configuration, in the Explorer pane, under Data Access >
Content Manager, right-click Content Store, and click Test.

Note: If the connection does not succeed, you must correct any issues before
you can start the IBM Cognos BI services.

3. In IBM Cognos Configuration, click Actions > Start.

Results

After the services start, you can access the IBM Cognos BI portal by going to
http://servername/ibmcognos/ in a web browser.

Note: It can take some time for the IBM Cognos BI services to start for the first
time.

If you did not use port 80 when you installed IBM HTTP Server, you must add the
port number. For example, http://servername:port/ibmcognos/, where port is the
number you used for the web server.

Install software on the Integration Bus node computer
You must install WebSphere MQ and IBM Integration Bus on the IBM Predictive
Customer Intelligence Integration Bus node computer.

Installing IBM DB2 client software on the Integration Bus node
computer

You must install IBM DB2 client software on the IBM Predictive Customer
Intelligence Integration Bus node computer.

Procedure
1. Go to the install_location\Server\Database folder where you installed the

Predictive Customer Intelligence server installation files.
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By default, the install_location is C:\IBM\PCI\.
2. Double-click v10.1fp3_ntx64_rtcl.exe to extract the installation files.
3. Select a Typical installation, and follow the steps in the DB2 Setup wizard to

install the product.

Installing WebSphere MQ
Install WebSphere MQ on the IBM Predictive Customer Intelligence Integration Bus
node computer.

Note: If you are installing the software as a domain user account instead of a local
administrator, you must provide a domain user account with authority to query
information about user accounts. For more information, see the WebSphere MQ
documentation (www.ibm.com/support/knowledgecenter/SSFKSJ_7.5.0).

Procedure
1. Log on to the computer where you are installing WebSphere MQ as a local

administrator.
2. Go to the Server\MessageQueue folder where you installed the Predictive

Customer Intelligence server installation files.
3. Decompress the installation files.
4. Double-click Setup.exe.
5. Click Software Requirements, and ensure that you are using a supported

operating system.
6. Click Network Configuration, and select No for Configuring WebSphere MQ

for Windows domain users.
7. Click WebSphere MQ Installation, and click Launch IBM Websphere MQ

Installer.
8. Follow the steps in the wizard to install the server software.
9. When the installation is complete, click Finish.

The Prepare WebSphere MQ Wizard appears.
10. Select a Typical installation, and follow the steps in the wizard.

When you are prompted to identify a domain controller, select No if you are
installing as a local administrator account, and click Next.

11. Click Finish.

Installing IBM Integration Bus
Install IBM Integration Bus and IBM Integration Explorer on the IBM Predictive
Customer Intelligence Integration Bus node computer.

Before you begin

Ensure that you install WebSphere Message Queue before you install IBM
Integration Bus.

Procedure
1. Go to the Server\IntegrationBus folder where you installed the Predictive

Customer Intelligence server installation files.
2. Decompress the installation files.
3. Go to the integrationbus_runtime1 folder, and double-click mqsilaunchpad.exe.
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4. If a message appears stating that the installer is unable to find the correct
version of WebSphere MQ, click Next. WebSphere MQ 7.5.0.2 is provided with
Predictive Customer Intelligence, but the installer is looking for an earlier
version. You can safely ignore this message.

5. Select the following components:
v IBM Integration Bus, V9.0.0.1

v IBM Integration Explorer, V9.0.0.1

Each component is installed sequentially.
6. Click Launch Installation for IBM Integration Bus.
7. Follow the steps in the IBM Integration Bus installation wizard, and click Done.
8. Follow the steps in the IBM Integration Explorer installation wizard, and click

Done.
9. Click Exit Launchpad.

Creating a broker and queue manager
You create a broker for IBM Predictive Customer Intelligence from the command
line. A queue manager is automatically created when you create the broker.

You must assign a user for the broker and queue manager. The user must be a
local administrator user.

Procedure
1. Log on to the Integration Bus node as a local administrator user.
2. In a command prompt, go to the installation_location\mqsi\9.0.0.1\bin

folder. For example, if you installed to the default location, go to the
C:\Program Files\IBM\mqsi\9.0.0.1\bin folder.

3. Enter the following command to start the command console:
mqsiCommandConsole.exe

4. Enter the following command to create and start the broker and queue
manager:
mqsicreatebroker broker_name -i LocalSystem -q queue_manager_name

For example, to create a broker that is named pcibroker and a queue manager
that is named pciqmgr, enter:
mqsicreatebroker pcibroker -i LocalSystem -q pciqmgr

5. Enter the following command to start the broker:
mqsistart broker_name

For example, to start a broker that is named pcibroker, enter:
mqsistart pcibroker

6. Enter the following command to create an execution group:
mqsicreateexecutiongroup broker_name -e executiongroupname

For example, to create an execution group that is named pciegroup, enter:
mqsicreateexecutiongroup pcibroker -e pciegroup

Enabling remote access for the queue manager
For IBM Predictive Customer Intelligence, you must start the queue manager
command line processor to enable remote access to the queue manager.

Procedure
1. In the mqsiCommandConsole, enter the following command to start the queue

manager:
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runmqsc queue_manager_name

For example, if your queue manager is named pciqmgr, enter:
runmqsc pciqmgr

2. Enter the following lines, and press Enter after each line:
START LISTENER

ALTER QMGR CHLAUTH(ENABLED)

SET CHLAUTH(SYSTEM.BKR.CONFIG) TYPE(ADDRESSMAP) ADDRESS('*')
MCAUSER('mqm')

SET CHLAUTH(SYSTEM.BKR.CONFIG) TYPE(BLOCKUSER) USERLIST('*NOACCESS')

END

Important: The ADDRESS(’*’) value in the command allows connections from
any IP address. Consider restricting the access to a single computer. For more
information about these values, see the WebSphere MQ documentation.

3. If you want to use a specific port number for the listener, enter the following
command:
runmqlsr -t tcp -m queue_manager_name -p port_number
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Chapter 4. Distribute Analytics node components

After you complete a default environment installation, you can optionally add
Analytics node components. Adding Analytics node components can improve the
performance of the solution.

Distributing Analytics node components includes adding of SPSS Collaboration
and Deployment Services Server instances on other computers in your
environment.

Creating a database for an additional Collaboration and Deployment
Services instance

You must create a database for each instance of SPSS Collaboration and
Deployment Services Server you add to your environment.

Each instance of SPSS Collaboration and Deployment Services Server requires its
own database. You cannot use the same database for multiple instances of SPSS
Collaboration and Deployment Services Server.

Procedure
1. Log on to the data node computer as a DB2 instance owner user.
2. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window -

Administrator.
3. Enter the following script to create a database:

DB2 CREATE DATABASE SPSSDBxx ON path USING CODESET UTF-8
TERRITORY US COLLATE USING SYSTEM

Important: Ensure that you use a different database name for each SPSS
Collaboration and Deployment Services Server that you are adding to your
environment. For example, change SPSSDBxx to a new name for each SPSS
Collaboration and Deployment Services Server you add.
Do not use a database name that is longer than 8 characters.
path can be a file path or just a drive letter. For example,
DB2 CREATE DATABASE SPSSDB1 ON C: USING CODESET UTF-8
TERRITORY US COLLATE USING SYSTEM

4. Connect to the database you created by using the following command:
DB2 CONNECT TO SPSSDBxx

5. Enter the following commands to create the bufferpools for the database. Enter
each command individually.
DB2 CREATE Bufferpool CDS8K IMMEDIATE SIZE 250 AUTOMATIC PAGESIZE 8 K

DB2 CREATE REGULAR TABLESPACE CDS8K PAGESIZE 8 K MANAGED BY AUTOMATIC
STORAGE EXTENTSIZE 8 OVERHEAD 10.5 PREFETCHSIZE 8 TRANSFERRATE 0.14
BUFFERPOOL CDS8K DROPPED TABLE RECOVERY ON

DB2 CREATE Bufferpool CDSTEMP IMMEDIATE SIZE 250 PAGESIZE 32 K

DB2 CREATE SYSTEM TEMPORARY TABLESPACE CDSTEMP PAGESIZE 32 K MANAGED BY AUTOMATIC
STORAGE EXTENTSIZE 16 OVERHEAD 10.5 PREFETCHSIZE 16 TRANSFERRATE 0.14
BUFFERPOOL "CDSTEMP"
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Copying the installers to the distributed Analytics node computer
Copy the required installers to each computer on which you want to install an
additional SPSS Collaboration and Deployment Services Server.

You can use the installers that were copied to the Analytics node computer you
already set up (Chapter 3, “Installation of the server components,” on page 7).

If you use the Launchpad to install the server components, you have to deploy all
of the installers for all of the nodes.

Procedure
1. If you have access to the installers on your existing Analytics node computer,

copy the following installation file folders to the computer you want to add as
an additional Analytics node computer.
v Database

v InstallationManager

v WebSphereApplicationServer

v SPSS_CNDS

v CNDSModelerAdapter

v ADM

v CNDSStatAdapter

2. If you no longer have the installers on your existing Analytics node computer,
follow the steps in Chapter 3, “Installation of the server components,” on page
7 to deploy the installers to your computers.

Installing IBM DB2 client for SPSS Collaboration and Deployment
Services

You must install IBM DB2 client software on the computer on which you install
SPSS Collaboration and Deployment Services Server components for your IBM
Predictive Customer Intelligence environment.

Procedure
1. Go to the Database folder where you copied the installation files.
2. Double-click v10.1fp3_ntx64_rtcl.exe to extract the installation files.
3. Select a Typical installation, and follow the steps in the DB2 Setup wizard to

install the product.

Installing IBM Installation Manager for SPSS Collaboration and
Deployment Services

You must install IBM Installation Manager on the computer on which you install
SPSS Collaboration and Deployment Services Server components for your IBM
Predictive Customer Intelligence environment.

About this task

Procedure
1. Go to the InstallationManager folder where you copied the installation files.
2. Decompress the installation files.
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3. Double-click install.exe.
4. Follow the steps to install IBM Installation Manager.

Installing IBM WebSphere Application Server for SPSS Collaboration
and Deployment Services

You must install IBM WebSphere Application Server on the computer on which
you install SPSS Collaboration and Deployment Services Server components for
your IBM Predictive Customer Intelligence environment.

About this task

Procedure
1. Go to the WebSphereApplicationServer folder where you copied the

installation files.
2. Decompress the installation files.

You must decompress all of the compressed files.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the WAS_ND_V8.5.5_1_OF_3 folder, select repository.config, and click Open,

and OK.
8. In IBM Installation Manager, click Install.
9. Under IBM WebSphere Application Server Network Deployment, select

Version 8.5.5.0.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. When prompted for Which program do you want to start?, select Profile

Management Tool to create a profile, and click Finish.
12. In the WebSphere Customization Toolbox 8.5 window, click Create.
13. Select Application Server, and click Next.
14. Select Typical profile creation, and click Next.
15. Follow the steps in the wizard to configure your application server. For more

information about any of the settings, see the WebSphere Application Server
documentation.

Installing additional IBM SPSS Collaboration and Deployment Services
Server instances

Each instance of IBM SPSS Collaboration and Deployment Services Server that you
install requires a separate database. The databases can be on the same database
server. The database must exist before you install the server components.

Procedure
1. Go to the SPSS_CNDS folder where you copied the installation files.
2. Decompress the installation files.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
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5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the Server_Repository folder, select repository.config, and click Open,

and OK.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select the following components.

v IBM SPSS Collaboration and Deployment Services

v IBM SPSS Collaboration and Deployment Services - Remote Process
Server

v IBM SPSS Collaboration and Deployment Services - Scoring Server

v IBM SPSS PMML Scoring Adapter

10. Click Next, and follow the steps in IBM Installation Manager to install the
products.

11. On the Common Configuration for IBM SPSS Collaboration and
Deployment Services - Remote Process Server pages, enter the following
information:

Database Type
Select IBM DB2.

Database Machine Name or IP
The name or IP address of the computer where you installed IBM DB2
and created the SPSSDBxx database.

Database Name
Enter the name of the database you created. For example, enter
SPSSDBxx. Each instance of SPSS Collaboration and Deployment
Services must use its own database.

Port Number
Enter 50000, the default port number for IBM DB2.

User name
Enter the user name of your IBM DB2 administrator user.

Password
Enter the password for your IBM DB2 administrator user.

Remote Process Service Name
Leave the default value RemoteProcessServer.

Port Number
Change the default only if the default value 2211 causes a port
conflict.

12. Leave the Configure Clustering check box clear, and click Next.
13. Select IBM WebSphere Application Server, and click Next.
14. Click Install.
15. In the Which programs do you want to start box, select IBM SPSS

Collaboration and Deployment Services Configuration Tool 6.0, and click
Finish.

16. In the IBM SPSS Collaboration and Deployment Services Configuration
Tool, click Next.

17. On the Application Server page, enter the information for IBM WebSphere
Application Server, and click Next.
For the WebSphere profile directory value, the default location is C:\Program
Files (x86)\IBM\WebSphere\AppServer\profiles\AppSrv01.
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18. On the Database page, enter the information for the SPSSDB database, and
click Next.

19. On the Encryption page, enter a password, and click Next.
20. On the Repository Admin page, enter a password for the SPSS admin user,

and click Next.
21. On the Deployment mode page, select Automatic, and click Next.
22. Click Configure.
23. Click Finish.

Installing additional IBM SPSS Collaboration and Deployment Services
Modeler Adapter instances

Install IBM SPSS Collaboration and Deployment Services Adapter software on the
computer where you installed an additional SPSS Collaboration and Deployment
Services Server instance.

Procedure
1. Go to the CNDSModelerAdapter folder where you copied the installation files.
2. Decompress the installation files.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the disk1 folder, select diskTag.inf, and click Open, and OK.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select IBM SPSS Modeler Adapters for

Collaboration and Deployment Services.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. On the Install Packages page, select Use the existing package group, select

IBM SPSS Collaboration and Deployment Services 6.0, and click Next.
12. On the Common Configurations page, enter the SPSS administrator user and

password, and click Next.
13. Click Install, and click Finish.

Installing additional IBM Analytical Decision Management instances
Install IBM Analytical Decision Management software on the computer where you
installed an additional SPSS Collaboration and Deployment Services Server
instance.

A sample Analytical Decision Management application is provided with the
installation files. The sample application is provided in a compressed file that is
named ADM_80_Demo.zip. For more information about the sample file, see the
Analytical Decision Management documentation (www.ibm.com/support/
knowledgecenter/SS6A3P_8.0.0).

Procedure
1. Go to the ADM folder where you copied the installation files.
2. Decompress the installation file that is named ADM_80_Repository_mp.zip.
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3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the adm_repository folder, select repository.config, and click Open and

OK.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select IBM Analytical Decision Management.

10. Click Next, and follow the steps in IBM Installation Manager to install the
product.

11. On the Install Packages page, select Use the existing package group, select
IBM SPSS Collaboration and Deployment Services 6.0, and click Next.

12. On the Install Packages page, select Production for the Installation Type.
Ensure that all of the options under IBM Analytical Decision Management
Applications are selected.

13. On the Common Configurations page, enter the SPSS administrator user and
password, and click Next.

14. Click Install.
15. Click Finish.

Installing additional IBM SPSS Statistics Collaboration and
Deployment Services Adapter instances

Install IBM SPSS Statistics Collaboration and Deployment Services Adapter
softwareon the computer where you installed an additional SPSS Collaboration and
Deployment Services Server instance.

Procedure
1. Go to the CNDSStatAdapter folder where you copied the installation files.
2. Decompress the installation files.
3. Click Start > All Programs > IBM Installation Manager.
4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the repository directory, select repository.config, and click Open, and

OK.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select IBM SPSS Collaboration and

Deployment Services - Server Adapter for Statistics.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. On the Install Packages page, select Use the existing package group, select

IBM SPSS Collaboration and Deployment Services 6.0, and click Next.
12. On the Common Configurations page, enter the SPSS administrator user and

password, and click Next.
13. Click Install.
14. Click Finish.
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Chapter 5. Installation of the client components

There are several client components that are included with IBM Predictive
Customer Intelligence. You can install the components as you require.

Important: Install the client components only after you successfully install the
server components.

Client components
Client components for IBM Predictive Customer Intelligence are available to be
installed.

For more information about installing and using the client components, see the
documentation provided with the component.

Important: After the client installation files are copied to your computer, some
paths for the compressed files can be long. You might need to use a decompression
utility other than the one provided by Microsoft Windows to decompress the files.

Database connectivity

IBM Data Server Runtime Client must be installed to enable connectivity to the
databases.

Predictive modeling and decision management

Install the following components so that you can modify or create predictive
models and so that you can perform decision management tasks:
v IBM SPSS Collaboration and Deployment Services Deployment Manager
v IBM SPSS Modeler Client Premium

Optionally, install the following components:
v IBM SPSS Statistics Client
v IBM SPSS Collaboration and Deployment Services Documentation
v IBM Analytical Decision Management Documentation
v IBM SPSS Modeler Premium Documentation

Business intelligence

Install IBM Cognos Framework Manager so that you can modify the reporting
model metadata.

Note: You must install IBM Data Server Runtime Client before you can use IBM
Cognos Framework Manager. Ensure that you restart the computer after you install
the IBM Data Server Runtime Client, and that you catalog the databases before you
use Framework Manager. Framework Manager is a 32-bit application, and requires
the 32-bit IBM Data Server Runtime Client.

Optionally, install the following components:
v IBM Cognos Business Intelligence Samples
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v IBM Cognos Dynamic Query Analyzer
v IBM Cognos for Microsoft Office
v IBM Cognos Lifecycle Manager
v IBM Cognos Software Development Kit
v IBM Cognos Supplementary Languages Documentation

Integration Bus

Install the following components:
v Integration Bus Toolkit
v WebSphere MQ for Windows

Use the Integration Bus Toolkit to create, manage, deploy, and delete message
flows and associated resources in a development environment.

Starting the Launchpad for the client components
Use the IBM Predictive Customer Intelligence Launchpad to start the Deployment
Wizard.

Procedure
1. Go to the folder where you downloaded the artifacts installation files.
2. Decompress the installation files.
3. Go to the disk1 directory where you decompressed the files.
4. Double-click Launchpad.exe or Launchpad64.exe.

Changing the temporary location for installation files
The Deployment Wizard uses a temporary folder for installation source files. You
must ensure that you are using a location that has adequate disk space for the
installation source files. If you do not have enough disk space in the default
location, you can change the location.

For example, the default location is C:\Progam Files (x86)\Common
Files\SL_####\SolutionEnabler. If space is limited on your C drive, you can
change the temporary location to another drive.

The temporary files include jar files that are used during the installation, which
you might want to delete after you complete the installation.

Procedure
1. In the Deployment Wizard, click Edit > Preferences.

The Deployment Preferences window appears.
2. In the Deployment Package Path box, select an existing location.
3. Click OK.

Starting the Deployment Wizard and installing the client components
Use the IBM Predictive Customer Intelligence Deployment Wizard to copy the
client installation files to your computer. You must run each installation program
individually after the client installation files are copied to your computer.
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Tip: You might need to adjust your Windows User Access Control (UAC) settings
so that you can run the installation program for the client components.

Procedure
1. In the Launchpad, click Deploy Client > Start the Predictive Customer

Intelligence Client Deployment Wizard.
2. On the Select Tasks panel, select whether you want 32- or 64-bit clients

installed, and click Next.
3. Select the clients for which you want to deploy the installation files, and click

Next.
4. Enter a location for each client component installer to be copied to. The default

is C:\IBM\PCI\.
5. On the Summary Panel, click Deploy all.

Note: The time to deploy the software is estimated by the Deployment
Wizard. The actual time required depends on a variety of factors, such as
network speed. In most cases, the deployments will take significantly less time
than what is initially displayed by the Deployment Wizard.

6. After the client installers are copied to your computer, you must install each
client individually by using its installer.

Installing IBM SPSS Collaboration and Deployment Services
Deployment Manager

You must install IBM SPSS Collaboration and Deployment Services Deployment
Manager to complete the configuration of IBM Predictive Customer Intelligence.

Procedure
1. Go to the install_location\Client\Analytics\IBM SPSS Collaboration and

Deployment Services Deployment Manager directory.
By default, the install_location is C:\IBM\PCI\.

2. Decompress the installation files.
3. In the decompressed folder, double-click install.exe to start the IBM SPSS

Collaboration and Deployment Services Deployment Manager installation.
4. Follow the steps in the wizard to install the client component.

For more information about the installation of Deployment Manager, see the
IBM SPSS documentation (www.ibm.com/support/knowledgecenter/
SS69YH_6.0.0).

Adding server connections for IBM SPSS Collaboration and
Deployment Services

You must add a connection to your IBM SPSS Collaboration and Deployment
Services repository in the IBM SPSS Collaboration and Deployment Services
Deployment Manager client.

After you add the connection, the server folder displays in the Content Explorer,
and you can log in to the server.

Procedure
1. Click Start > All Programs > IBM SPSS Collaboration and Deployment

Services > Deployment Manager > Deployment Manager 6.0.
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2. Click File > New > Content Server Connection.
3. In the Connection Name box, enter a name for your Collaboration and

Deployment Services repository. For example, enter SPSS.
4. In the Server URL box, enter the name or IP address of the Predictive

Analytics node computer and the port number, and click Finish.
The default port number that is used by the WebSphere Application Server
instance is 9080.

5. Double-click the connection name that you created.
6. In the User ID box, enter the SPSS admin user that you used when you

installed IBM SPSS Collaboration and Deployment Services Server.
7. In the Password box, enter the SPSS admin user's password.
8. Click OK.
9. Click File > New > Administered Server Connection.

10. In the Name box, enter a name for the repository server, and click Next. For
example, enter SPSS.

11. In the Server URL box, enter the name or IP address of the Predictive
Analytics node computer and the port number, and click Finish.
The default port number that is used by the WebSphere Application Server
instance is 9080.

12. Double-click the server connection name that you created.
13. In the User ID box, enter the SPSS admin user that you used when you

installed IBM SPSS Collaboration and Deployment Services Server.
14. In the Password box, enter the SPSS admin user's password.
15. Click OK.

Adding users and groups and server definitions to IBM SPSS
Collaboration and Deployment Services

You use IBM SPSS Collaboration and Deployment Services Deployment Manager
to manage users and groups. You must add an administrator user and a modeler
user for IBM Predictive Customer Intelligence. You must also add a server
definition.

Procedure
1. In Deployment Manager, on the Content Explorer tab, expand Resource

Definiton.
2. Add an admin user.

a. Right-click Credentials, and click New > Credentials Definition.
b. In the Name box, enter admin, and click Next.
c. In the User ID box, enter admin.
d. In the Password box, enter a password. For example, enter spss.
e. In the Security Provider box, select Local User Repository.
f. Click Finish.

3. Add a modeler user.
a. Right-click Credentials, and click New > Credentials Definition.
b. In the Name box, enter modeler, and click Next.
c. In the User ID box, enter a local user on the Predictive Analytics node

computer.
d. In the Password box, enter a password for that user.
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e. In the Security Provider box, select Local User Repository.
f. Click Finish.

4. Add a localhost server definition.
a. Right-click Servers, and click New > Server Definition.
b. In the Name box, enter localhost.
c. In the Type box, select Content Repository Server.
d. Click Next.
e. In the Server URL box, enter the name or IP address of the Analytics node

computer and the port number, and click Finish.
The default port number that is used by the WebSphere Application Server
instance is 9080.

5. Add a modeler server definition.
a. Right-click Servers, and click New > Server Definition.
b. In the Name box, enter modeler, and click Next.
c. In the Type box, select Modeler Server, and click Next.
d. In the Host box, enter the name or IP address of the Analytics node

computer.
e. In the Port box, enter 28053.
f. In the Default data path box, enter the path to the data folder on Analytics

node computer. For example, enter C:\Program Files\IBM\SPSS\
ModelerServer\16.

g. Click Finish.

Installing IBM SPSS Modeler Client
You must install IBM SPSS Modeler Client to configure the Next Best Action
Optimizer connectors for IBM Predictive Customer Intelligence.

Procedure
1. Go to the install_location\Client\Analytics\IBM SPSS Modeler Client

directory.
By default, the install_location is C:\IBM\PCI\.

2. Decompress the installation files.
3. Double-click setup.exe to start the IBM SPSS Modeler Client installation.
4. Follow the steps in the wizard to install the client component.

Installation of the Integration Bus clients
For IBM Predictive Customer Intelligence, you must install MQ Explorer,
Integration Toolkit, and Integration Explorer.

Installing MQ Explorer
IBM Integration Explorer client application requires that MQ Explorer is installed
on the same computer.

Procedure
1. Go to the install_location\Client\Integration Bus\IBM Integration Bus

folder.
By default, the install_location is C:\IBM\PCI\.
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2. Decompress the installation file that is named
IIB_IBToolkit_WS_MQ_WINDOWS_X86-64.zip.

3. In the decompressed folder, go to the integrationbus\WebSphere_MQ_V7.5.0.1
folder, and double-click MQLaunch.exe.

4. Click Software Requirements, and ensure that you are using a supported
operating system.

5. Click Network Configuration, and select No for Configuring WebSphere MQ
for Windows domain users.

6. Click WebSphere MQ Installation, and click Launch IBM Websphere MQ
Installer.

7. On the Setup Type page, select Custom, and click Next.
8. On the Features page, select only MQ Explorer to be installed.

Ensure that all other features are set to Do not install this feature.
9. Click Next.

10. Click Install, and click Finish.

Installing the Integration Bus client applications
Install the IBM Predictive Customer Intelligence Integration Bus client applications.
The applications include IBM Integration Toolkit and IBM Integration Explorer.

Before you begin

Ensure that MQ Explorer is already installed.

Procedure
1. Go to the folder where you decompressed the Integration Bus client application

installers.
2. In the decompressed folder, in the integrationbus folder, double-click

mqsilaunchpad.exe.
3. Select the check boxes for IBM Integration Toolkit, and IBM Integration

Explorer. Clear the check box for IBM Integration Bus.
If it is not already installed, IBM Installation Manager is installed with IBM
Integration Toolkit.

4. Click Launch Installation for IBM Integration Bus.
IBM Installation Manager appears.

5. Follow the steps in IBM Installation Manager to install IBM Integration Toolkit.
6. When you are prompted to open a product, select None, and click Finish.

The installer for IBM Integration Explorer appears.
7. Follow the steps in the wizard to install IBM Integration Explorer.

Connecting to your WebSphere MQ broker
Connect to the queue manager you created on the IBM Predictive Customer
Intelligence Integration Bus node computer.

Procedure
1. From the Start menu, click All Programs > IBM WebSphere MQ >

WebSphere MQ Explorer.
The first time that you start WebSphere MQ Explorer, you are prompted for a
workspace location.
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2. In the MQ Explorer - Navigator, under IBM WebSphere MQ, right-click
Queue Managers, and select Add Remote Queue Manager.

3. Enter the name of your queue manager, select Connect directly, and click
Next. For example, enter pciqmgr.

4. In the Connection details section, enter the following information, and click
Next.
a. In the Host name or IP address box, enter the information for your

Integration Bus node computer.
b. In the Port number box, enter the listener port number. The default is

1414.
c. In the Server-connection channel box, enter SYSTEM.BKR.CONFIG

5. On the Specify user identification details page, select Enable user
identification.

6. In the Userid box, enter the local administrator user that was used to create
the broker.

7. The first time that you add a user, you must enable password saving. Click
Passwords Preferences Page, and then select Save passwords to file to enable
the feature, and click OK.

8. Click Enter password.
9. Enter the user's password, and click OK.

10. Click Finish. The queue manager appears in the list, and the status appears as
running.

Installing Framework Manager for IBM Predictive Customer Intelligence
Install IBM Cognos Framework Manager to create or edit models and publish
packages for IBM Cognos Business Intelligence.

If you install Framework Manager to the same computer as where you installed
IBM Cognos Business Intelligence, you must install Framework Manager to a
different location. Framework Manager is a 32-bit application and cannot be
installed to the same location as the 64-bit IBM Cognos Business Intelligence server
components.

Procedure
1. Go to the install_location\Client\Business Intelligence\IBM Cognos

Framework Manager folder.
By default, the install_location is C:\IBM\PCI\.

2. Decompress fm_10.2.1_win_ml.tar.gz, and then decompress
fm_10.2.1_win_ml.tar.

Important: Ensure that you decompress the installation files to a different
location than any other IBM Cognos BI installation files. Some directories are
overwritten if you use the same location.

3. Go to the win32 folder, and double-click the issetup.exe file.
4. Follow the steps in the wizard to install the product.
5. When notified with an information message about installing the

Supplementary Languages Documentation, click OK

6. On the last page of the installation wizard, select Start IBM Cognos
Configuration to configure Cognos Framework Manager.

7. Click Finish.
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8. In IBM Cognos Configuration, in the Explorer panel, select Environment.
9. In the Gateway URI value, change localhost to the name or IP address of the

Business Intelligence (BI) node computer.
10. In the Dispatcher URI for external applications value, change localhost to

the name or IP address of the Business Intelligence (BI) node computer.
11. Click File > Save.
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Chapter 6. Installation of the artifacts

The artifacts include report content and workflows for IBM Predictive Customer
Intelligence.

The artifacts are installed on the computer where you are running the Deployment
Wizard. After the installation, you must copy the artifacts to their respective node
computers.

Starting the Deployment Wizard to install the artifacts
Use the Launchpad to start the IBM Predictive Customer Intelligence artifacts
Deployment Wizard.

You must run the Deployment Wizard on a computer that is running a Microsoft
Windows operating system.

Tip: You might need to adjust your Windows User Access Control (UAC) settings
so that you can run the installation program for the client components.

Tip: You can change the temporary location that the Deployment Wizard uses for
the installation files. For more information, see “Changing the temporary location
for installation files” on page 7.

Procedure
1. Go to the folder where you downloaded the artifacts installation files.
2. Decompress the installation files.
3. Go to the disk1 directory where you decompressed the files.
4. Double-click Launchpad.exe or Launchpad64.exe.
5. Click Deploy Artifacts > Start the Predictive Customer Intelligence Artifact

Deployment Wizard.

Important: In some cases, after you accept the license agreement, the
Deployment Wizard might appear behind other open windows. If you do not
see the Deployment Wizard, check for the icon in the taskbar.

Configuring parameters for the artifacts installation
You can select the installation location for the IBM Predictive Customer Intelligence
artifacts.

Procedure
1. On the Select Tasks page, click Next.
2. On the Configure Parameters page, enter the location to install the artifacts on

the computer from where you are running the installation.
The default is C:\IBM\PCI. All of the artifacts are installed to the same location.

3. Click Next.
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Starting the installation of the artifacts
After you enter all of the required fields in the Deployment Wizard, you can start
the installation of the artifacts.

Procedure

On the Summary Panel of the Deployment Wizard, click Deploy all.
If you choose to deploy the tasks individually, you must click Deploy task for each
task in the order that the tasks appear on the Summary panel.

Note: The time to deploy the software is estimated by the Deployment Wizard.
The actual time required depends on a variety of factors, such as network speed.
In most cases, the deployments will take significantly less time than what is
initially displayed by the Deployment Wizard.

Configure IBM Predictive Customer Intelligence artifacts
To configure the Predictive Customer Intelligence artifacts, you must create a
database, publish content to IBM Cognos Business Intelligence, and copy files to
the Predictive Analytics node and to the computer running Enterprise Marketing
Management.

Creating the IBM Predictive Customer Intelligence database
You must run a script to create the Predictive Customer Intelligence database, and
then run another to populate the database.

The scripts create and populate a database that is named PCI on your IBM DB2
database server. The scripts are available in the folder where you installed the
artifacts.

Procedure
1. Copy the artifacts from the computer where you installed them to the data

node computer and decompress the artifact files. For example, decompress the
artifacts to a directory on the data node computer that is named
C:\IBM\PCI\Database.

2. Log on to the data node computer as the DB2 instance owner user.
3. Open a Command Prompt window, and go to the folder where you installed

the artifacts. For example, go to the C:\IBM\PCI\Database folder.
4. Run Install_DB.bat to create the database.
5. Run Load_Data.bat to populate the database.

Configure the BI node artifacts
To configure the IBM Predictive Customer Intelligence artifacts for the Business
Intelligence node, you must move some files to the IBM Cognos BI installation
location, create a connection to the PCI database, and deploy IBM Cognos reports.

Moving content to the IBM Cognos BI installation location
After you install the IBM Predictive Customer Intelligence artifacts, you must
move some files to the IBM Cognos Business Intelligence installation location.

Procedure
1. Log on to the BI node computer.
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2. Go to the Exports folder where you installed the BI artifacts. For example, go
to the C:\IBM\PCI\Business Intelligence\Exports folder.

3. Copy the IBM PCI Cognos Content.zip file to the IBM Cognos BI
installation_location\deployment folder.

4. Go to the Report Images folder where you installed the artifacts. For example,
go to the C:\IBM\PCI\Business Intelligence\Report Images folder.

5. Extract the Report Images.zip file to the IBM Cognos BI
installation_location\webcontent folder.
You should have an installation_location\webcontent\ReportImages folder
that contains the image files.

Important: The ReportImages folder must not have a space in the name after
you copy it to the IBM Cognos BI installation_location\webcontent folder.

Creating a database connection to the PCI database
To connect to the PCI database on your Business Intelligence node computer, you
must first catalog the database server, and then catalog the PCI database. Then, you
must create a database connection in IBM Cognos Administration.

Procedure
1. Log on to the BI node computer.
2. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window -

Administrator.
3. Enter the following command to catalog the database node:

db2 catalog tcpip node NODE_NAME remote data_node_name server PORT_NUMBER

NODE_NAME can be any value. PORT_NUMBER is 50000 by default.
4. Enter the following command to catalog the PCI database:

db2 catalog database PCI at node NODE_NAME authentication server

Creating a data source connection to the PCI database in IBM
Cognos BI
You must create a data source connection to the PCI database in IBM Cognos BI,
and then you must deploy the reports.

Procedure
1. Open a web browser.
2. Go to the IBM Cognos BI portal URL. For example, go to http://bi_node_name/

ibmcognos/.
3. On the Welcome page, click Administer IBM Cognos Content.
4. Create a data source connection to the PCI database.

a. Click the Configuration tab, and click Data Source Connections.
b. Click the New Data Source button.
c. In the Name box, type PCI and then click Next.
d. In the connection page, select IBM DB2, ensure that Configure JDBC

connection is selected, and click Next.
The connection string page for the selected database appears.

e. In the DB2 database name field, enter PCI.
f. Leave DB2 connect string blank.
g. Under Signons, select both Password and Create a signon that the

Everyone group can use, type the user ID and password for the DB2
instance owner user that you used to create the database, and click Next.
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h. In the Server name box, enter the name or IP address of your data node
computer.

i. In the Port number box, enter the DB2 port number. The default is 50000.
j. In Database name, enter PCI.

Tip: To test whether the parameters are correct, click Test the connection.
After you test the connection, click OK to return to the connection page.

k. Click Close, Close, and then Finish.
5. Deploy the IBM Cognos BI reports.

a. On the Configuration tab, click Content Administration.
b. On the toolbar, click the New Import button.
c. In the Deployment Archive pane, select IBM PCI Cognos Content, and

click Next.
d. In the Public Folders Content pane, select IBM Predictive Customer

Intelligence, leave the Options as default, and click Next.
e. In the Specify the general options pane, accept the defaults, and click Next.
f. On the Review the summary page, click Next.
g. On the Select an action page, select Save and run once, and click Finish.
h. On the Run with options page, accept the defaults, and click Run, and then

click OK.
i. Click the Home button in IBM Cognos Administration.

The Predictive Customer Intelligence reports are available from the home
page.

Configuring the Next Best Action Optimizer connectors
Use the Next Best Action Optimizer (NBAOPT) connectors with IBM SPSS Modeler
for IBM Predictive Customer Intelligence. With the NBAOPT connectors installed,
you can run NBAOPT Studio from IBM SPSS Modeler.

You must copy the NBAOPT connectors to the location where IBM SPSS Modeler
Client is installed.

For more information about using the NBAOPT connectors, see the IBM Predictive
Customer Intelligence Solution Guide.

Procedure

Copy the pci.NBAOPT folder where you installed the NBAOPT artifacts to the
ext\lib folder where IBM SPSS Modeler Client is installed. For example, copy the
pci.NBAOPT folder to the C:\Program Files\IBM\SPSS\Modeler\16\ext\lib folder.
After you copy the folder, you should have the following path:
C:\Program Files\IBM\SPSS\Modeler\16\ext\lib\pci.NBAOPT

Configuring the Enterprise Marketing Management connectors
If you are using IBM Enterprise Marketing Management (EMM), IBM Predictive
Customer Intelligence provides two connectors between IBM Interact and IBM
SPSS Collaboration and Deployment Scoring Service. The connectors override the
score that is supplied by the IBM EMM campaign and also extend IBM Interact's
learning module to monitor visitor actions and propose optimal offers.

To configure the connectors, you must copy them to the EMM installation location.
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Do not configure the connectors if you are not using IBM Enterprise Marketing
Management.

Important: The EMM connectors can be used only with IBM Enterprise Marketing
Management version 9.0 or 9.1.

Procedure

Copy the artifacts from the EMMConnectors folder where you installed the EMM
artifacts to the Connectors folder where EMM is installed. For example, copy the
files to the IBM_EMM_Interact_install_location\Connectors folder.
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Chapter 7. Copying the license files to each component
computer

After you install IBM Predictive Customer Intelligence, you must ensure that a
swidtag file and license folder exists on each computer on which you installed a
Predictive Customer Intelligence component.

The swidtag file and license folder must exist on each server node computer and
each computer on which you install a client that is used with Predictive Customer
Intelligence.

Important: Do not rename the folders or files.

Procedure
1. Copy the swidtag file from the iso-swid folder where you installed the artifacts

to each computer where you installed a Predictive Customer Intelligence
component.
For example, copy the file so that you have a C:\IBM\PCI\iso-swid folder that
contains a swidtag file.
If a iso-swid folder exists on the computer, do not overwrite the folder. Add
the swidtag file to the existing folder.

2. Copy the license folder from the folder where you installed the artifacts to
each component computer.
For example, copy the folder and contents so that you have a
C:\IBM\PCI\license folder that contains the license files.
If the license folder exists on the computer, you do not need to replace it.

Results

The following folders must exist on each computer on which you installed a
Predictive Customer Intelligence component:
v On all computers:

C:\IBM\PCI\license (containing the product license files)
C:\IBM\PCI\iso-swid (containing the product swidtag file)
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Chapter 8. Stop and start solution software services

IBM Predictive Customer Intelligence is an integrated solution that includes many
products. If you must stop the services, you must do so in the correct order. The
product services must also be started in the correct order.

Stop solution services
Stop the IBM Predictive Customer Intelligence node services in the following
order:
1. Business Intelligence (BI) node
2. Integration Bus node
3. Predictive Analytics node
4. data node

Stopping services on the BI node computer
You must stop the IBM Cognos Business Intelligence services and IBM HTTP
Server on the IBM Predictive Customer Intelligence Business Intelligence (BI) node
computer.

Procedure
1. Click Start > All Programs > IBM Cognos 10_64 > IBM Cognos

Configuration.
2. Click Actions > Stop.
3. Click Start > All Programs > IBM HTTP Server V8.5 > Stop HTTP Server.

Stopping services on the Integration Bus node computer
You must stop the IBM Integration Bus services on the IBM Predictive Customer
Intelligence Integration Bus node computer.

Procedure
1. Go to the IBM Integration Bus bin folder. For example, go to C:\Program

Files\IBM\MQSI\9.0.0.1\bin.
2. Enter the following command:

mqsistop pcibroker

3. Enter the following command to verify that the services are stopped:
mqsilist pcibroker

Stopping services on the Analytics node computer
You must stop the IBM SPSS services on the IBM Predictive Customer Intelligence
Predictive Analytics node computer.

Procedure
1. Go to the WebSphere Application Server SPSSProfile\bin folder. For example,

go to C:\Program FIles\IBM\WebSphere\AppServer\profiles\SPSSProfile\bin.
2. Enter the following command:

stopserver.bat server1
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3. Click Start > Control Panel > Administrative Tools > Services.
4. Select IBM SPSS Modeler Server 16.0, and click Stop Service.

Stopping services on the data node computer
You must stop the IBM DB2 instance on the IBM Predictive Customer Intelligence
data node computer.

Procedure
1. Log in to the data node computer as the IBM DB2 administrator user.
2. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window -

Administrator.
3. Enter the following command to stop the DB2 administration server:

db2stop

Start solution services
Start the IBM Predictive Customer Intelligence node services in the following
order:
1. data node
2. Predictive Analytics node
3. Integration Bus node
4. Business Intelligence (BI) node

Starting services on the data node computer
You must start the IBM DB2 instance on the IBM Predictive Customer Intelligence
data node computer.

Procedure
1. Log in to the data node computer as the IBM DB2 administrator user.
2. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window -

Administrator.
3. Enter the following command to stop the DB2 administration server:

db2start

Starting services on the Analytics node computer
You must start the IBM SPSS services on the IBM Predictive Customer Intelligence
Predictive Analytics node computer.

Procedure
1. Go to the WebSphere Application Server SPSSProfile\bin folder. For example,

go to C:\Program FIles\IBM\WebSphere\AppServer\profiles\SPSSProfile\bin.
2. Enter the following command:

startserver.bat server1

3. Click Start > Control Panel > Administrative Tools > Services.
4. Select IBM SPSS Modeler Server 16.0, and click Start Service.

Starting services on the Integration Bus node computer
You must start the IBM Integration Bus services on the IBM Predictive Customer
Intelligence Integration Bus node computer.
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Procedure
1. Go to the IBM Integration Bus bin folder. For example, go to C:\Program

Files\IBM\MQSI\9.0.0.1\bin.
2. Enter the following command:

mqsistart pcibroker

3. Enter the following command to verify that the services are started:
mqsilist pcibroker

Starting services on the BI node computer
You must start the IBM Cognos Business Intelligence services and IBM HTTP
Server on the IBM Predictive Customer Intelligence Business Intelligence (BI) node
computer.

Procedure
1. Click Start > All Programs > IBM Cognos 10_64 > IBM Cognos

Configuration.
2. Click Actions > Start.
3. Click Start > All Programs > IBM HTTP Server V8.5 > Start HTTP Server.
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Chapter 9. Switch software tags for your installation

If you change your usage of IBM Predictive Customer Intelligence, such as to a
non-production environment from a production environment, you must switch the
software tags for your installation.

Starting the ILMT Utility to change software tags
Use the artifacts Launchpad to start the IBM Licence Metric Tool (ILMT) Utility to
change IBM Predictive Customer Intelligence software tags.

Procedure
1. Go to the folder where you downloaded the artifacts installation files.
2. Decompress the installation files.
3. Go to the disk1 directory where you decompressed the files.
4. Double-click Launchpad.exe or Launchpad64.exe.
5. Click Switch Software Tags > Start the IBM Predictive Customer Intelligence

ILMT Utility.

Important: If a message directs you to verify that the application was installed
correctly or to reinstall it, you can safely ignore this message. The utility will
function correctly.

Switching software tags
Switch your IBM Predictive Customer Intelligence software tags if your usage
changes. For example, if you installed the solution initially as a non-production
environment but want to move it to a production environment, you must switch
the software tags.

Procedure
1. On the Select Tasks page of the Deployment Wizard, select the option to

switch your tags:
v Select Switch from Production to Non-Production if you initially installed

Predictive Customer Intelligence to a production environment.
v Select Switch from Non-Production to Production if you initially installed

Predictive Customer Intelligence to a non-production environment.
2. Click Next.
3. On the Configuration Parameters page, enter the location to where you want

to deploy the updated software tags, and click Next.
4. Click Deploy all.

After the software tag file is deployed, you must copy it to each computer on
which a Predictive Customer Intelligence node or client is installed.

Updating your software tag file
After you use the ILMT utility to change your IBM Predictive Customer
Intelligence software tag, you must copy the updated file to each computer on
which a component is installed. You must replace the existing file with the
updated file.
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Copy the software tag file to each computer on which a Predictive Customer
Intelligence server or client component is installed.

Procedure
1. Copy the iso-swid folder and contents from the folder where you updated the

license files to each computer on which you install a Predictive Customer
Intelligence component.
For example, copy the folder and contents so that you replace the
C:\IBM\PCI\iso-swid folder. The iso-swid folder should contain a swidtag file.

2. Delete the existing swidtag file.
You should have only one swidtag file in the folder for the IBM Predictive
Customer Intelligence components.
If you deployed the samples, you should also have a swidtag file for the
samples in the folder.

Note: If you run the ILMT Utility on a computer where you installed a
Predictive Customer Intelligence component, and you use the same directory,
the .swidtag is overwritten with the updated file. You must, however, still copy
the new .swidtag file to all of the other computers that have a Predictive
Customer Intelligence component installed.
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Chapter 10. Uninstallation of the server components

Follow the uninstall instructions for each of the IBM Predictive Customer
Intelligence components to uninstall the product.

Uninstalling components from the Predictive Analytics node computer
Follow the uninstall instructions for each component on the IBM Predictive
Customer Intelligence Analytics node computer.

Procedure
1. To uninstall the IBM DB2 client, see the IBM DB2 documentation

(www.ibm.com/support/knowledgecenter/SSEPGG_10.1.0).
2. To uninstall IBM SPSS Collaboration and Deployment Services, see the IBM

SPSS documentation (www.ibm.com/support/knowledgecenter/SS69YH_6.0.0).
a. From the Start menu, click All Programs > IBM Installation Manager >

IBM Installation Manager.
b. Click Uninstall, and follow the steps to uninstall the product.

3. To uninstall WebSphere Application Server, see the WebSphere documentation
(www.ibm.com/support/knowledgecenter/SSEQTP_8.5.5).
a. From the Start menu, click All Programs > IBM Installation Manager >

IBM Installation Manager.
b. Click Uninstall, and follow the steps to uninstall the product.

Note: If WebSphere Application Server processes are running and prevent you
from uninstalling the product, you must stop the server process. Go to the
C:\Program Files (x86)\IBM\WebSphere\AppServer\profiles\profile_name\bin
folder, and type stopServer.sh server1.

4. To uninstall IBM Installation Manager, see the IBM Installation Manager
information center (pic.dhe.ibm.com/infocenter/install/v1r6).
a. From the Microsoft Windows Control Panel, click Programs and Features,

select IBM Installation Manager, and click Uninstall.
b. Follow the steps to uninstall IBM Installation Manager.

5. Remove the licence and iso-swid folders. For example, if you used the default
path, C:\IBM\PCI, remove the C:\IBM\PCI\license and C:\IBM\PCI\iso-swid
folders.

Uninstalling components from the BI node computer
Follow the uninstall instructions for each component on the IBM Predictive
Customer Intelligence Business Intelligence (BI) node computer.

Procedure
1. To uninstall the IBM DB2 client, see the IBM DB2 documentation

(www.ibm.com/support/knowledgecenter/SSEPGG_10.1.0).
2. To uninstall IBM Cognos Business Intelligence, see the IBM Cognos BI

documentation (www.ibm.com/support/knowledgecenter/SSEP7J_10.2.1).
a. From the Start menu, click All Programs > IBM Cognos 10 - 64 > Uninstall

IBM Cognos > Uninstall IBM Cognos.
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b. Follow the steps to uninstall the product.
3. To uninstall IBM HTTP Server, see the IBM HTTP Server for WebSphere

Application Server documentation (www.ibm.com/support/knowledgecenter/
SSEQTJ_8.5.5).
a. From the Start menu, click All Programs > IBM Installation Manager >

IBM Installation Manager.
b. Click Uninstall, and follow the steps to uninstall the product.

4. To uninstall IBM Installation Manager, see the IBM Installation Manager
information center (pic.dhe.ibm.com/infocenter/install/v1r6).
a. From the Microsoft Windows Control Panel, click Programs and Features,

select IBM Installation Manager, and click Uninstall.
b. Follow the steps to uninstall IBM Installation Manager.

5. Remove the licence and iso-swid folders. For example, if you used the default
path, C:\IBM\PCI, remove the C:\IBM\PCI\license and C:\IBM\PCI\iso-swid
folders.

Uninstalling components from the Integration Bus node computer
Follow the uninstall instructions for each component on the IBM Predictive
Customer Intelligence Integration Bus node computer.

Procedure
1. To uninstall the IBM DB2 client, see the IBM DB2 documentation

(www.ibm.com/support/knowledgecenter/SSEPGG_10.1.0).
2. To uninstall IBM Integration Bus, see the IBM Integration Bus documentation

(www.ibm.com/support/knowledgecenter/SSMKHH_9.0.0).
3. To uninstall WebSphere MQ, see the WebSphere MQ documentation

(www.ibm.com/support/knowledgecenter/SSFKSJ_7.5.0).
4. Remove the licence and iso-swid folders. For example, if you used the default

path, C:\IBM\PCI, remove the C:\IBM\PCI\license and C:\IBM\PCI\iso-swid
folders.

Uninstalling components from the data node computer
Follow the uninstall instructions for each component on the IBM Predictive
Customer Intelligence data node computer.

Procedure
1. To uninstall IBM DB2, see the IBM DB2 documentation (www.ibm.com/

support/knowledgecenter/SSEPGG_10.1.0).
2. Remove the licence and iso-swid folders. For example, if you used the default

path, C:\IBM\PCI, remove the C:\IBM\PCI\license and C:\IBM\PCI\iso-swid
folders.
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Appendix A. Troubleshooting

This section contains troubleshooting information for the IBM Predictive Customer
Intelligence installation.

Troubleshooting a problem
Troubleshooting is a systematic approach to solving a problem. The goal of
troubleshooting is to determine why something does not work as expected and
how to resolve the problem.

Review the following table to help you or customer support resolve a problem.

Table 1. Troubleshooting actions and descriptions

Actions Description

A product fix might be available to resolve
your problem.

Apply all known fix packs, or service levels,
or program temporary fixes (PTF).

Look up error messages by selecting the
product from the IBM Support Portal, and
then typing the error message code into the
Search support box (http://www.ibm.com/
support/entry/portal/).

Error messages give important information
to help you identify the component that is
causing the problem.

Reproduce the problem to ensure that it is
not just a simple error.

If samples are available with the product,
you might try to reproduce the problem by
using the sample data.

Ensure that the installation successfully
finished.

The installation location must contain the
appropriate file structure and the file
permissions. For example, if the product
requires write access to log files, ensure that
the directory has the correct permission.

Review all relevant documentation,
including release notes, technotes, and
proven practices documentation.

Search the IBM Knowledge Center to
determine whether your problem is known,
has a workaround, or if it is already
resolved and documented.

Review recent changes in your computing
environment.

Sometimes installing new software might
cause compatibility issues.

If the items in the table did not guide you to a resolution, you might need to
collect diagnostic data. This data is necessary for an IBM technical-support
representative to effectively troubleshoot and assist you in resolving the problem.
You can also collect diagnostic data and analyze it yourself.

Troubleshooting resources
Troubleshooting resources are sources of information that can help you resolve a
problem that you are having with an IBM product.

Support Portal

The IBM Support Portal is a unified, centralized view of all technical support tools
and information for all IBM systems, software, and services.
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The IBM Support Portal lets you access all the IBM support resources from one
place. You can tailor the pages to focus on the information and resources that you
need for problem prevention and faster problem resolution. Familiarize yourself
with the IBM Support Portal by viewing the demo videos (https://www.ibm.com/
blogs/SPNA/entry/the_ibm_support_portal_videos).

Find the content that you need by selecting your products from the IBM Support
Portal (http://www.ibm.com/support/entry/portal).

Before contacting IBM Support, you will need to collect diagnostic data (system
information, symptoms, log files, traces, and so on) that is required to resolve a
problem. Gathering this information will help to familiarize you with the
troubleshooting process and save you time.

Service request

Service requests are also known as Problem Management Reports (PMRs). Several
methods exist to submit diagnostic information to IBM Software Technical Support.

To open a PMR or to exchange information with technical support, view the IBM
Software Support Exchanging information with Technical Support page
(http://www.ibm.com/software/support/exchangeinfo.html).

Fix Central

Fix Central provides fixes and updates for your system's software, hardware, and
operating system.

Use the pull-down menu to navigate to your product fixes on Fix Central
(http://www.ibm.com/systems/support/fixes/en/fixcentral/help/
getstarted.html). You may also want to view Fix Central help.

IBM developerWorks

IBM developerWorks® provides verified technical information in specific
technology environments.

As a troubleshooting resource, developerWorks provides easy access to the most
popular practices, in addition to videos and other information: developerWorks
(http://www.ibm.com/developerworks).

IBM Redbooks

IBM Redbooks® are developed and published by the IBM International Technical
Support Organization, the ITSO.

IBM Redbooks (http://www.redbooks.ibm.com) provide in-depth guidance about
such topics as installation and configuration and solution implementation.

Software support and RSS feeds

IBM Software Support RSS feeds are a quick, easy, and lightweight format for
monitoring new content added to websites.
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After you download an RSS reader or browser plug-in, you can subscribe to IBM
product feeds at IBM Software Support RSS feeds (https://www.ibm.com/
software/support/rss).

Log files

Log files can help you troubleshoot problems by recording the activities that take
place when you work with a product.

Error messages

The first indication of a problem is often an error message. Error messages contain
information that can be helpful in determining the cause of a problem.

Cannot open output file messages when you decompress files
When you decompress installation files for some components, you might receive a
message that the decompression utility cannot open some output files. You can
safely ignore these messages.

Deployment Wizard does not save configurations
If you save your configurations in Deployment Wizard, use Save As instead of
Save.

If you click File > Save, any values that you entered are not saved when you
reopen the Deployment Wizard.

You can resolve this issue by clicking File > Save As to save your configuration.
Ensure that you enter a new name for the saved configuration.

When you open the Deployment Wizard, and open your saved configuration, the
settings you entered appear.

Viewing log files
Log files for the IBM Predictive Customer Intelligence installation can be displayed
in the Deployment Wizard.

If you want to view log files directly, the log files are saved to the C:\Progam Files
(x86)\Common Files\SL_####\SolutionEnabler folder.

Procedure
1. To view log files in the Deployment Wizard, select the message, and click

Detailed messages or Master log.
2. If you clicked Detailed messages, select a message, and click View Details.

Temporary file locations
Temporary files are created during the IBM Predictive Customer Intelligence
installation. You can find the location for the temporary files from the Deployment
Wizard.

The temporary files include jar files that are used during the installation, which
you might want to delete after you complete the installation.
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Procedure

In the Deployment Wizard, click Edit > Preferences.
The path to the location for the temporary files is shown in the Path box.

Modeler Server type not displaying in resource definitions
In IBM Predictive Customer Intelligence, if the Modeler Server type does not
display in resource definitions in IBM SPSS Collaboration and Deployment Services
Deployment Manager, try closing Deployment Manager and opening it again.
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Appendix B. Integration with the IBM Enterprise Marketing
Management suite

IBM Predictive Customer Intelligence integrates with the IBM Enterprise Marketing
Management suite. The components that Predictive Customer Intelligence
integrates with are IBM Campaign, IBM Interact and IBM Marketing Platform.

IBM Campaign
IBM Campaign is a web-based Enterprise Marketing Management (EMM)
solution that enables users to design, run, and analyze direct marketing
campaigns.

IBM Interact
With IBM Interact, users can retrieve personalized offers and customer
profile information in real-time.

IBM Marketing Platform
The IBM Marketing Platform provides security, configuration, and
dashboard features for IBM Enterprise Marketing Management products.

IBM Interact connectors
IBM Interact integrates with customer facing systems (touchpoints) such as web
sites and call centers, and enables users to retrieve personalized offers and visitor
profile information in real time.

IBM Predictive Customer Intelligence provides two connectors between IBM
Interact and IBM SPSS Collaboration and Deployment Scoring Service:
v The External callout connector calls an SPSS model at runtime, and is contained

within the expression of an advanced rule for a Marketer Score, overriding the
score supplied by the IBM Enterprise Marketing Management campaign.

v The External learning connector extends IBM Interact's native learning module
to monitor visitor actions and propose optimal offers. It prioritizes IBM
Campaign offers based on an SPSS model's prediction of their final score. The
connector passes specific configurable parameters as input to the SPSS Scoring
Service.

The External Learning connector
The External Learning connector is used to override the marketer's score in IBM
Interact with a customized score from IBM SPSS Collaboration and Deployment
Services. The customized score is used to prioritize the offers for customers. When
the customer facing touchpoint puts in an offer request to IBM Interact, it triggers
the external learning connector. A touchpoint can be a call center web application,
a mobile application, a batch command, and so on.

The following process is initiated:
1. The connector Java™ class calls the IBM SPSS Collaboration and Deployment

Services scoring service that is based on the configuration setting of the current
channel.

2. If, in the configuration file, the current channel is set to be monitored, the
corresponding channel in the IBM SPSS Scoring Service is configured to update
the channel offers' score number.
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3. The External Learning connector uses IBM Interact runtime session profile data
as SPSS Scoring Service input parameters.

4. The connector gets the scores from the SPSS scoring service and overwrites the
Interact offers scores with the SPSS scores.

5. After the Interact offer's score is updated by the SPSS score, the offer list is
sorted by the new final scoring number in descending order. The offer list is
returned as the final offer list.

Configuring the External Learning connector configuration file
An interactive channel is a touchpoint with your customer, such as a call center or
a website. It is the communication channel with your customers. By using the IBM
Interact API, you integrate IBM Interact with your touchpoints to present offers to
customers based on their action in the touchpoint.

Procedure
1. Stop the IBM Enterprise Marketing Management (EMM) runtime server.
2. Create the following file structure on your IBM EMM server:

For Windows operating systems:
v <EMM Interact Installation Folder>\connectors

v <EMM Interact Installation Folder>\logs

Figure 2. How the external learning connector works
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By default, the installation folder is \IBM\EMM\Interact

For Linux operating systems:
v <EMM Interact Installation Folder>/connectors/

v <EMM Interact Installation Folder>/logs

By default, the installation folder is /opt/IBM/EMM/Interact

3. Copy the LearningConnector_config.properties file and
UnicaSPSSLearningConnector.jar to the Connectors folder.

4. Edit the LearningConnector_config.properties file for your environment. For
more information, see “Sample External Learning connector configuration file.”

5. In the runtime environment for the IBM Marketing Platform tool, select
Settings, Configuration, and expand IBM EMM, Interact, and offerserving.

6. Set optimizationType to ExternalLearning.
7. Configure the External Learning class:

a. Under offerserving, select External Learning Config.
b. Set class to the Java class name. For example:

<com.ibm.unica.connector.>SPSSLearning

c. Set classPath to the Java JAR file location. For example, for Windows:
<Interact_Install_location>\UnicaSPSSLearningConnector.jar, and for
Linux: <Interact_Install_location>/UnicaSPSSLearningConnector.jar

8. Restart the IBM EMM runtime server for these changes to take effect.

Sample External Learning connector configuration file

The following example is a sample External Learning connector configuration file.
Modify this sample for your environment.
CADS_ADDRESS=<Collaboration_deployment_services_server_address>
CADS_PORT=9080
CADS_USER=admin
CADS_PASSWORD=spss
UNICA_INTERACTJSSERVICE_URL=http://<IBM_EMM_URL>:9080/
interact/servlet/InteractJSService
LEARNING_CHANNELS=Mobile,Mob;Telco,Telco Call Center;Insurance,Insurance

SERVICENAME_Telco=ExternalLearning
INPUTTABLE_Telco=db2admin@TELCO
PARAMETERS_Telco=CUSTOMERID,double,CUSTOMERID;CHURN_SCORE,double,CHURN_SCORE;
CUSTOMER_LIFE_TIME_VALUE_RATIO,double,CUSTOMER_LIFE_TIME_VALUE_RATIO;
SENTIMENT_SCORE,double,SENTIMENT_SCORE;NUMBER_OF_CLOSED_COMPLAINTS,integer,
NUMBER_OF_CLOSED_COMPLAINTS;NUMBER_OF_OPEN_COMPLAINTS,integer,
NUMBER_OF_OPEN_COMPLAINTS;GROUP_LEADER_TYPE2,double,GROUP_LEADER_TYPE2;
GROUP_LEADER_CONFIDENCE_TYPE2,DOUBLE,GROUP_LEADER_CONFIDENCE_TYPE2;
INFLUENCER_SCORE,double,INFLUENCER_SCORE;SEGMENT,string,SEGMENT;
RESPONSE,integer,#VALUE#null;OFFER_CATEGORY_NAME,string,#VALUE#null
OUTPUTNAME_Telco=FinalScore
INPUT_OFFERNAMECOL_Telco=OFFER

SERVICENAME_Insurance=INSU_CHURN
INPUTTABLE_Insurance=INSURNC.INSURANCE_VIEW
PARAMETERS_Insurance=POLICYHOLDER_ID,integer,#VALUE#1016091;GENDER,string,#VALUE#F;
EMPLOYMENT_STATUS,string,#VALUE#employed;INCOME,double,#VALUE#144541;
HOUSEHOLD_NUMBER_OF_CHILDREN,integer,#VALUE#2;HOUSEHOLD_NUMBER_OF_INSURED_CARS,integer,
#VALUE#0;NUMBER_OF_POLICIES_IN_HOUSEHOLD,integer,#VALUE#1;HOUSEHOLD_TENURE,double,
#VALUE#5.15;INSURANCE_LINES,integer,#VALUE#1;LATEST_NOTE_ATTITUDE,double,#VALUE#3;
AVERAGE_NOTE_ATTITUDE,double,#VALUE#2;NUMBER_OF_CLAIMS_FILED,double,#VALUE#2;
CUSTOMER_FINANCIAL_SEGMENT,string,#VALUE#Financially Sophisticated;
OUTPUTNAME_Insurance=CHURN_SCORE
INPUT_OFFERNAMECOL_Insurance=#NONE#
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SERVICENAME_Mobile=SequenceAnalysis
INPUTTABLE_Mobile=NBA.CUSTOMER_RELATIONSHIP_HISTORY
PARAMETERS_Mobile=CUSTOMERID,integer,CUSTOMERID;SEQUENCE,integer,#VALUE#1;
PRODUCT,string,LASTOFFER;
OUTPUTNAME_Mobile=RECOMMENDATION
INPUT_OFFERNAMECOL_Mobile=#NONE#

For information on how to modify this file, see “Add a new learning channel,” and
“Add an IBM SPSS Scoring Service to an offer (External Learning connector).”
Also, see IBM Interact Administrator's Guide.

Add a new learning channel
To add a new learning channel, add the learning name and channel name to the
LEARNING_CHANNELS parameter.

For example:

LEARNING_CHANNELS=Mobile,Mob;Telco,Telco Call Center;Insurance,Insurance

Where:
v The first value is the learning channel name (Telco), the second value is the

channel name (Telco Call Center).
v Values are separated by commas and parameters are separated by semi-colons.

Add an IBM SPSS Scoring Service to an offer (External
Learning connector)

To add an IBM SPSS Scoring Service, add the following parameters to the
LearningConnector_config.properties file.
v SERVICENAME_%THE LEARNING NAME%

v INPUTTABLE_%THE LEARNING NAME%

v PARAMETERS_%THE LEARNING NAME%

v OUTPUTNAME_%THE LEARNING NAME%

v INPUT_OFFERNAMECOL_%THE LEARNING NAME%

The parameter name has three elements that are separated by commas:
v The input parameter name.
v The data type and the source column name (profile table column name).
v The direct value that uses #VALUE# to identify it. You can also use the channel

profile table column value as SPSS input parameter values.

You can set the input parameter to null, by using #VALUE# of null, for example:

RESPONSE,integer,#VALUE#null;OFFER_CATEGORY_NAME,string,#VALUE#null

Parameters are separated by semicolons.

The value for OUTPUTNAME_%THE LEARNING NAME% can be "DEFAULT". You do not
need to provide the name of the output column name; the first output parameter is
taken as the output score results.

For example, you can set the output columns with either method that is shown,
and you get the same result:
v OUTPUTNAME_Mobile=RECOMMENDATION
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v OUTPUTNAME_Mobile=DEFAULT

The value of INPUT_OFFERNAMECOL_%THE LEARNING NAME% can be an input parameter
column name or "#NONE#". When the value is set to a specific input parameter
column name, the External Learning connector passes the IBM Interact channel
offer name to the corresponding column for the SPSS scoring service as an input
parameter to get the specific offer name score to update the corresponding offer for
Interact channel final score. When the input offer name column is set to
"#NONE#", only the first IBM Interact channel offer final score is updated with the
IBM SPSS Scoring Service score.

For example, when three offers are requested from a touchpoint, IBM Interact
returns three offers, shown in the following table.

Table 2. Example showing the scores returned from IBM Interact and from the IBM SPSS
Scoring Service

Offer name IBM Interact final score IBM SPSS score

Premium phone 90 85

Premium family plan 80 88

Add a second line free 70 65

The External Learning connector passes all of the configured parameters and the
offer name to the SPSS Scoring Service. It returns three new scores: 85, 88 and 65
from IBM SPSS for these three offers.

The IBM SPSS score is used as the final score and is sorted in descending order,
shown in the following table.

Table 3. Example showing the final score and sort order

Offer name IBM Interact final score

Premium family plan 88

Premium phone 85

Add a second line free 65

The External Callout connector
By using the External Callout connector, you can override a single offer's score by
calling an IBM SPSS Scoring Service. Also, using the External Callout connector,
you can invoke the IBM SPSS score to present eligible offers.

To enable the External Callout connector, perform the following steps:
1. Register the External Callout connector in the IBM Enterprise Marketing

Management (EMM) configuration.
2. Add the IBM SPSS Scoring Service information to the External Callout

connector's configuration file.

Configuring the External Callout connector
IBM Interact helps customers get offers based on user characteristics and history.
The offers are generated by algorithms. You can configure IBM Interact to override
the offer's score by calling an SPSS Model.
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Procedure
1. Stop the IBM Enterprise Marketing Management (EMM) runtime server.
2. Create the following file structure on your IBM EMM server:

v <EMM Interact Installation Folder>\connectors

v <EMM Interact Installation Folder>\logs

By default, the installation folder is \IBM\EMM\Interact

3. Copy the ExternalConnector_config.properties file and
UnicaSPSSExternalConnector.jar to the Connectors folder.

4. Edit the ExternalConnector_config.properties file for your environment. For
more information, see “Sample External Callout connector configuration file”
on page 67.

5. In the runtime environment for the IBM Marketing Platform, select Settings,
Configuration, and expand IBM EMM, Interact, Flowchart, and External
Callouts.

6. To set the configuration properties, click External Callout and configure the
parameters as follows:

Category name
GetSPSSscore

class com.ibm.unica.connector.GetSPSSScore

classpath

v <EMM Interact Installation Folder>\connectors\
UnicaSPSSExternalConnector.jar

By default, the installation folder is \IBM\EMM\Interact

Save the changes.
7. Select the campaign settings, by clicking Campaign, Campaigns.
8. Select the link for the campaign that you are configuring, such as Insurance.
9. Click the <Campaign name> Strategy tab, for example, Insurance Strategy.

10. For each Eligible Segment, such as Insurance High Risk Customer, Insurance
High Value Customer, click Adv Opt.

11. In the Advanced Options window, select Use the following expression as the
marketing score.

12. In the Expression box, type an expression to be used for the marketing score.
You can either use modified versions of the examples shown, or from the
Functions, Variables and Operators list, select Extension Functions,
EXTERNALCALLOUT and click Use. For more information, see "About the
ExternalCallout API" topic in the IBM Interact 9.1 Administrator's Guide.
Example expression for an Insurance campaign:
NUMBER(EXTERNALCALLOUT(’GetSPSSScore’,’GetChurnScore’,db2admin.CUSTOMERID,
db2admin.GENDER,db2admin.EMPLOYMENT_STATUS,db2admin.INCOME,1,
db2admin.NUMBER_OF_INSURED_CARS,db2admin.NUMBER_OF_POLICIES_IN_HOUSEHOLD,
db2admin.HOUSEHOLD_TENURE,db2admin.INSURANCE_LINES,db2admin.LATEST_NOTE_ATTITUDE,
db2admin.AVERAGE_NOTE_ATTITUDE,db2admin.NUMBER_OF_CLAIMS_FILED,
db2admin.CUSTOMER_SEGMENTS,0))*100

The External Callout API has a mandatory number of configurable arguments
that must be provided. The mandatory number of arguments setting in the
configuration file is as set in the value of the property
ExternalConnector_NumberOfArguments. In the example shown, the value is 15.
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When there are fewer SPSS scoring service input parameters than the
configure setting of ExternalConnector_NumberOfArguments, add ",0" to the
expression to ensure that there are the same number of arguments in the
external callout expression.

13. Deploy the changes to the server.
14. Restart the IBM EMM runtime server.

Sample External Callout connector configuration file

The following example is a sample External Callout connector configuration file.
Modify this sample for your environment.
CADS_ADDRESS=<Collaboration_deployment_services_server_address>
CADS_PORT=9080
CADS_USER=admin
CADS_PASSWORD=spss
ExternalConnector_NumberOfArguments=15

SERVICENAME_GetChurnScore=INSU_CHURN
INPUTTABLE_GetChurnScore=INSURNC.INSURANCE_VIEW
PARAMETERS_GetChurnScore=POLICYHOLDER_ID,double;GENDER,string;
EMPLOYMENT_STATUS,string;INCOME,double;HOUSEHOLD_NUMBER_OF_CHILDREN,integer;
HOUSEHOLD_NUMBER_OF_INSURED_CARS,integer;NUMBER_OF_POLICIES_IN_HOUSEHOLD,integer;
HOUSEHOLD_TENURE,double;INSURANCE_LINES,integer;LATEST_NOTE_ATTITUDE,double;
AVERAGE_NOTE_ATTITUDE,double;NUMBER_OF_CLAIMS_FILED,double;
CUSTOMER_FINANCIAL_SEGMENT,string;
OUTPUTNAME_GetChurnScore=CHURN_SCORE

SERVICENAME_GetCreditRating=dWStream
INPUTTABLE_GetCreditRating=trainingdata.csv
PARAMETERS_GetCreditRating=Age,double;Income_level,string;Education,string;
Car_loans,string;
OUTPUTNAME_GetCreditRating=DEFAULT

SERVICENAME_GetReco=SequenceAnalysis
INPUTTABLE_GetReco=NBA.CUSTOMER_RELATIONSHIP_HISTORY
PARAMETERS_GetReco=CUSTOMERID,integer;SEQUENCE,integer;PRODUCT,string;
OUTPUTNAME_GetReco=RECOMMENDATION

SERVICENAME_GetCreditScore=CreditCardDefault
INPUTTABLE_GetCreditScore=NBA.CUSTOMER
PARAMETERS_GetCreditScore=CUSTOMERID,integer;AGE,integer;EDUCATION,string;
YEARSEMPLOYED,integer;INCOME,ineger;CARDDEBT,double;OTHERDEBT,double;
DEFAULTED,integer;ADDRESS,string;
OUTPUTNAME_GetCreditScore=DEFAULTPROPENSITY

For information about how to add an IBM SPSS Scoring Service to this file, see
“Add an IBM SPSS Scoring Service to an offer (External Callout connector).” Also,
see IBM Interact Administrator's Guide.

Add an IBM SPSS Scoring Service to an offer (External
Callout connector)

To add an IBM SPSS Scoring Service, add the following parameters to the
ExternalConnector_config.properties file.
v SERVICENAME_%THE EXTERNAL CONFIG NAME%

v INPUTTABLE_%THE EXTERNAL CONFIG NAME%

v PARAMETERS_%THE EXTERNAL CONFIG NAME%

v OUTPUTNAME_%THE EXTERNAL CONFIG NAME%

The parameter name has two elements that are separated by commas:
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v The input parameter name
v The data type

The parameters are separated by a semicolon.

The value for OUTPUTNAME_%THE SCORING SERVICE FUNCTION% can be "DEFAULT".
You do not need to provide the name of the output column name; the first output
parameter is taken as the output scoring results. For example, the following
methods of setting the output column get the same result:
v OUTPUTNAME_GetReco=RECOMMENDATION

v OUTPUTNAME_GetReco=DEFAULT

Troubleshooting EMM connector deployments
If you run IBM Enterprise Marketing Management version 9.0, there is an error in
the deployment section for IBM Campaign and IBM Interact. The error applies to
deploying WAR files.

About this task

Make the following configuration changes for IBM Campaign and IBM Interact
WAR files.

Procedure
1. On the server where IBM EMM is installed, go to the WebSphere Integrated

Solutions Console.
2. In the server’s Application > Enterprise Applications section, select the WAR

file that you deployed.
3. Select Class loading and update detection and set the following General

Properties on the Configuration tab:
v For Class loader order, select Classes loaded with local class loader first

(parent last).
v For WAR class loader policy, select Class loader for each WAR file in

application.
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Appendix C. Use the Predictive Customer Intelligence
samples

You can install samples for the following industries: Telecommunications, Retail,
Insurance, Banking, and Energy and Utilities.

All samples except for the Banking sample contain the following components:
v IBM DB2 databases.
v IBM Analytical Decision Management templates and applications.
v IBM SPSS project streams, models, and rules.
v IBM Cognos reports and Framework Manager models and packages.

The Banking sample contains IBM DB2 databases and an IBM SPSS project stream.
It does not contain IBM Analytical Decision Management templates and
applications or IBM Cognos reports and Framework Manager packages. Therefore,
you do not need to install the Analytical Decision Management templates and
applications or the IBM Cognos Content if you are using this sample.

The Telecommunications, and Energy and Utilities samples contain report images
that must be installed.

To install the samples, you must perform the following steps for each sample that
you are using.
1. Run the Deployment wizard to deploy the samples on a computer with a

Microsoft Windows operating system installed.
2. Create the sample databases on the Data node.
3. Install the Analytical Decision Management templates and applications on the

Predictive Analytics node.
4. Import the SPSS project streams, models, and rules on the Predictive Analytics

node.
5. Configure the data view for SPSS models on the Predictive Analytics node.
6. Install the IBM Cognos Content on the Business Intelligence node.

Important: There are no touchpoints included with the samples. For example, no
call center applications or web sites are included.

Sample prerequisites
Before you install the samples, you must have a fully configured environment.

You must have administration rights and have the ability to copy files between
servers and platforms.

The IBM Predictive Customer Intelligence Sample Deployment Wizard must be run
on a computer that is running a Microsoft Windows operating system.

The steps to install each sample must be completed in the order shown.
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Installing the samples
The IBM Predictive Customer Intelligence Sample Deployment Wizard copies the
samples to your computer. You must configure each sample individually after it is
copied to your computer.

Use the Predictive Customer Intelligence Sample Deployment Wizard on a
computer that is running a Microsoft Windows operating system.

Procedure
1. Go to the folder where you downloaded the samples installation files.
2. Decompress the installation files.
3. Double-click Launchpad.exe or Launchpad64.exe.
4. Follow the steps in the wizard to copy the samples.

The Deployment wizard prompts you for the location to copy the samples. If
you select the default, the samples are copied to c:\IBM\PCIsamples\
sample_name.

5. Click Deploy All.

Creating the sample databases
The IBM Predictive Customer Intelligence samples include sample databases. You
must run a script to create a database, and then run another to populate the
databases for each sample that you are using.

Procedure
1. Create a folder on the data node computer to contain the samples. For example,

c:\IBM\PCI.
2. Copy the samples files from the computer where you installed them to the data

node computer:
v The Telecommunications sample is in Telco\Database\

IBM_PCI_Telco_Data.zip.
v The Retail sample is in Retail\Database\IBM_PCI_Retail_Data.zip.
v The Insurance sample is in Insurance\Database\IBM_PCI_Insurance_Data.zip

v The Banking sample is in Banking\Database\IBM_PCI_Banking_Data.zip.
v The Energy and Utilities sample is in Energy and Utilities\Database\

IBM_EU_Data.zip.
3. On the data node computer, decompress the files.
4. Log on to the data node computer as the DB2 instance owner user.
5. Open a Command Prompt window, and go to the folder where you

decompressed the sample files.
6. In the uncompressed folder, run Install_DB.bat to create the database.

Note: For the Energy and Utilities sample, two databases are created: EUTIL
and PCI_UTIL.

7. Run Load_Data.bat to populate the database.

What to do next

Verify that the tables are created and the data is successfully loaded into the input
tables by checking the out.log file.
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The log file is in the sample_name folder.

Search for “rows were rejected” in the log file. The value should be zero, if it is
not, there are data load issues.

Installing Analytical Decision Management templates and applications
The following Predictive Customer Intelligence samples include IBM Analytical
Decision Management templates and applications: Telecommunications, Retail,
Insurance, and Energy and Utilities. The Banking sample does not include IBM
Analytical Decision Management templates and applications.

Procedure
1. Log on to the Predictive Analytics node computer.
2. From the computer where you deployed the samples, copy the Analytical

Decision Management applications and templates for the samples that you are
using from the following locations:
v Telecommunications

– Application: Telco\Analytics\Applications\IBM_PCI_Telco_App.zip
– Template: Telco\Analytics\Templates\TelcoCallCenter.xml

v Retail
– Application: Retail\Analytics\Applications\IBM_PCI_Retail_App.zip
– Template: Retail\Analytics\Templates\Retail.xml

v Insurance
– Application: Insurance\Analytics\Applications\

IBM_PCI_Insurance_App.zip

– Template: Insurance\Analytics\Templates\Insurance.xml
v Energy and Utilities

– Application: Energy and Utilities\Analytics\Applications\
IBM_PCI_Energy _and_Utilities_App.zip

– Template: Energy and Utilities\Analytics\Templates\Energy and
Utilities.xml

Copy files to the Applications or Templates folder as appropriate on the
Predictive Analytics node computer.
The default location is C:\Program Files\IBM\SPSS\Collaboration and
Deployment Services\6.0\Server\components\decision-management\
Applications or \Templates.

3. Decompress the files to the Applications folder.
4. In a browser, go to the IBM Analytical Decision Management launch page:

http://SPSS server name:port number/DM

5. Click Add Application, and select the appropriate application. For example,
Telco Call Center.

Importing project streams, models, and rules
Project streams, models, rules and other artifacts are contained in a repository
export file for each sample. Copy the export file to the Predictive Analytic node
where IBM SPSS Collaboration and Deployment Manager is installed.
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Procedure
1. Log on to the Predictive Analytics node computer using an administrator

account.
2. From the computer where you deployed the samples, copy the

IBM_PCI_sample_name.pes file to the Predictive Analytics node computer. For
example, copy the file to a c:\IBM\PCI folder.
The files are located in the following folders:
v Telecommunications: \Telco\Analytics\IBM_PCI_Telco.pes
v Retail: Retail\Analytics\IBM_PCI_Retail.pes
v Insurance: Insurance\Analytics\IBM_PCI_Insurance.pes
v Banking: Banking\Analytics\IBM_PCI_Banking.pes
v Energy and Utilities: Energy and Utilities\Analytics\IBM_PCI_EU.pes

3. In IBM SPSS Collaboration and Deployment Manager, import the
IBM_PCI_sample_name.pes file with the following settings selected:
v Resolve conflicts globally

v Add new version of target item or rename source item, Use labels from
source.

v Continue import even if some objects cannot be imported due to locking
conflicts.

v Resolve Invalid Version Conflicts, Import.
v Resource Definitions, Recommended. Import if there are no duplicate ID

conflicts or duplicate name conflicts.

Results

Content folders and resource definitions are added to the repository alongside any
existing content.

Configuring the data view for SPSS models
To configure the data view, IBM SPSS Modeler must be connected to the samples
databases through an ODBC data source. You must perform extra steps for the
Insurance and Retail samples.

About this task

If your IBM Predictive Customer Intelligence environment uses the IBM SPSS
Modeler client logged in to a Modeler server, perform the steps on the Predictive
Analytics node computer (where IBM SPSS Modeler Server is installed).

If your Predictive Customer Intelligence environment uses the IBM SPSS Modeler
Client in a stand-alone environment, perform the steps on the client computer
where IBM SPSS Modeler client is installed.

Procedure
1. Catalog the database on the client computer.

a. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window
- Administrator.

b. Enter the following command to catalog the database node:
db2 catalog tcpip node NODE_NAME remote data_node_name server PORT_NUMBER

NODE_NAME can be any value. PORT_NUMBER is 50000 by default.

72 IBM Predictive Customer Intelligence Version 1.0.0: Installation Guide for Microsoft Windows Operating Systems



c. Enter the following command to catalog the PCI database:
db2 catalog database DATABASE_NAME at node NODE_NAME authentication server

Where the Database_names are as shown in the following table:

Table 4. Sample DSN names and database names

Sample DSN and database names

Telecommunications TELCO

Retail RETAIL

Insurance INSURNC

Banking BANKING

You must use the same node_name that you used in the db2 catalog
database command.

2. Create an ODBC DSN to point to each sample database listed in the table. The
database account that is provided in the ODBC connection must be the same
user that was used for creating tables.

Tip: On a computer with Microsoft Windows installed, in the Windows Control
Panel, select Administrative Tools and click Data Sources. Click the System
DSN tab.

The following steps are for the Retail and Insurance samples only.

These samples use the Analytic Data View and JDBC source connections for
accessing IBM Analytical Decision Manager. When the Retail or Insurance samples
are imported through IBM SPSS Collaboration and Deployment Services
Deployment Manager, a new version of the Enterprise View is created that contains
only the tables that are related to the samples.
3. In the Deployment Manager client, under Resource Definitions, Credentials,

open the db2admin credentials and update the user ID and password to the
DB2 administrator account of the Data node.

4. In Resource Definitions, Data Sources, open the data source for the sample,
either RETAIL_JDBC, or INSURANCE_JDBC, and update the IP address and
port to point to the IBM Predictive Customer Intelligence Data node. The
default DB2 port is 50000.

5. Open the data source, either RETAIL_ODBC, or INSURANCE_ODBC, and
verify that the data source name corresponds to the ODBC name created for the
sample database.

6. Verify that the Application View and the Data Provider Definition are working
properly. Open the RETAIL_CUSTOMER_ATTRIBUTES_DPD, or
INSURANCE_DPD, and click Validate. To retrieve a previous version of the
Enterprise View, right-click Enterprise View in Deployment Manager and click
Open Version.

7. To create a single view that combines the solution tables with any tables that
existed previously, right-click Enterprise View in Deployment Manager and
click Merge Versions.
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Installing IBM Cognos content
The following IBM Predictive Customer Intelligence samples include IBM Cognos
content: Telecommunications, Retail, Insurance, and Energy and Utilities.

Perform these tasks for each sample that you are using.

There is no IBM Cognos content for the Banking sample.

Procedure
1. Copy the IBM Cognos content from the computer where you installed it to the

locations specified in the following table.

Table 5. IBM Cognos content

Cognos content Copy to

Cognos deployment package:\
<sample_name>\Business Intelligence\IBM
PCI<sample_name> Cognos Content

Business Intelligence node, in the folder
<Cognos_Install_location>\Deployment

Cognos report images: \<sample_name>\
Business Intelligence\IBM
PCI<sample_name> IBM PCI <sample_name>
Report Images
Note: This is for the Telecommunications
and Energy and Utilities sample only. The
Retail, Insurance, and Banking samples do
not include report images.

Business Intelligence node, in the folder
<Cognos_Install_location>\webcontent\
samples

Decompress the files to the following
folders:

For Telecommunications
<Cognos_Install_location>\
webcontent\samples\images\Telco

For Energy and Utilities
<Cognos_Install_location>\
webcontent\samples\images\EU

Tip: To decompress a file on a computer
with a Linux operating system installed,
type "unzip <"zip file name">". The zip
file name must be enclosed by quotation
marks because it contains spaces.

Cognos Framework Manager packages:
\<sample_name>\Business Intelligence\IBM
PCI<sample_name> IBM PCI <sample_name>
Model

The Windows computer where Framework
Manager is installed.

Decompress the files.

2. Catalog the database on the client computer.
a. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command

Window - Administrator.
b. Enter the following command to catalog the database node:

db2 catalog tcpip node NODE_NAME remote data_node_name server PORT_NUMBER

NODE_NAME can be any value. PORT_NUMBER is 50000 by default.
c. Enter the following command to catalog the PCI database:

db2 catalog database DATABASE_NAME at node NODE_NAME authentication server

Where the Database_names are as shown in the following table:

Table 6. Sample DSN names and database names

Sample Database names

Telecommunications TELCO
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Table 6. Sample DSN names and database names (continued)

Sample Database names

Retail RETAIL

Insurance INSURNC

Energy and Utilities EUTIL

PCI_UTIL

You must use the same node_name that you used in the db2 catalog
database command.

Configure IBM Cognos to point to the new databases.
3. Open a web browser.
4. Go to the IBM Cognos BI portal URL. For example, go to

http://bi_node_name/ibmcognos/.
5. On the Welcome page, click Administer IBM Cognos Content.
6. Create a data source connection to the samples database. This step must be

done twice for Energy and Utilities, once for each database in the sample, and
once for each of the other industry samples.
a. Click the Configuration tab, and click Data Source Connections.

b. Click the New Data Source button.
c. In the Name box, type the sample database name, for example TELCO and

then click Next.
d. In the connection page, select IBM DB2, ensure that Configure JDBC

connection is selected, and click Next.
The connection string page for the selected database appears.

e. In the DB2 database name field, type the sample database name. For
example TELCO.

f. Leave DB2 connect string blank.
g. Under Signons, select both Password and Create a signon that the

Everyone group can use, type the user ID and password for the DB2
instance owner user that you used to create the database, and click Next.

Tip: To test whether the parameters are correct, click Test the connection.
After you test the connection, click OK to return to the connection page.

h. In the Server name box, enter the name or IP address of your data node
computer.

i. In the Port number box, enter the DB2 port number. The default is 50000.
j. In Database name, type the sample database name. For example TELCO.

Tip: To test whether the parameters are correct, click Test the connection.
After you test the connection, click OK to return to the connection page.

k. Click Finish.

Import the Cognos content for the sample.
7. Deploy the IBM Cognos BI reports.

a. On the Configuration tab, click Content Administration.
b. On the toolbar, click the New Import button.
c. In the Deployment Archive pane, select IBM PCI < Sample_name>

Content, and click Next.
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d. In the Public Folders Content pane, select IBM PCI < Sample_name>,
leave the Options as default, and click Next.

e. In the Specify the general options pane, accept the defaults, and click
Next.

f. On the Review the summary page, click Next.
g. On the Select an action page, select Save and run once, and click Finish.
h. On the Run with options page, accept the defaults, and click Run, and

then click OK.
i. Select View the details of this import after closing this dialog and click

OK. The next screen displays the status of the import. After a few second,
click Refresh and ensure that the status is "Succeeded".

j. In IBM Cognos Administration, click the Home button.

For the Retail sample only, install the portal pages
8. In IBM Cognos Connections, click the Public Folders tab.
9. Click IBM PCI Retail Portal Pages.

10. For each of the reports, click .

What to do next

You can use the following test customer IDs for samples where a Customer ID is
required. When you run some reports, you are prompted for a customer ID.
v For the Telecommunications, and Energy and Utilities sample, type 21.
v For the Insurance sample, use the following inputs for the specified report:

– CaseReportInsurance, Churn and Sentiment Scores, Churn Propensity,
ClaimsReport, and PolicyDetails: 1001920.

– SMA Insight: AaronBBailey@trashymail.com
– Social and Web Analytics: 1006598

Sample reports and portal pages
A number of Predictive Customer Intelligence reports and portal pages can be
installed with the samples.

The following industry samples include reports: Telecommunications, Retail,
Insurance, and Energy and Utilities. The Banking sample does not include reports.

You can customize the reports and portal pages using IBM Cognos Report Studio.
Cognos Report Studio is a report design and authoring tool. Report authors can
use Report Studio to create, edit, and distribute a wide range of professional
reports. For more information see IBM Cognos Report Studio User Guide
(http://www.ibm.com/support/knowledgecenter/SSEP7J_10.2.1/
com.ibm.swg.ba.cognos.ug_cr_rptstd.10.2.1.doc/c_rs_introduction.html).

The metadata that the report displays comes from the package that is created in
IBM Cognos Framework Manager. The example Framework Manager project folder
contains the compiled project file (.cpf). When you open the .cpf file, Framework
Manager displays the modeled relationships of the data and the package
definitions, which are made available to the reporting studios when published. You
can modify the metadata for the report by using Framework Manager. For more
information, see IBM Cognos Framework Manager User Guide

76 IBM Predictive Customer Intelligence Version 1.0.0: Installation Guide for Microsoft Windows Operating Systems

http://www-01.ibm.com/support/knowledgecenter/SSEP7J_10.2.1/com.ibm.swg.ba.cognos.ug_cr_rptstd.10.2.1.doc/c_rs_introduction.html
http://www-01.ibm.com/support/knowledgecenter/SSEP7J_10.2.1/com.ibm.swg.ba.cognos.ug_fm.10.2.1.doc/c_ug_fm_introduction.html%23ug_fm_Introduction


(http://www-01.ibm.com/support/knowledgecenter/SSEP7J_10.2.1/
com.ibm.swg.ba.cognos.ug_fm.10.2.1.doc/c_ug_fm_introduction.html
%23ug_fm_Introduction).

Reports available in the Telecommunications, and Energy and
Utilities samples

The following Predictive Customer Intelligence reports are available from the home
page for the Telecommunications, and Energy and Utilities samples.

BillingReports
The Billing report displays the customer billing history, calculated bill
amount, and potential savings.

CaseDetailReports
The CaseReport shows the open and closed case history of the customer: a
bar chart that plots the case status per month, a list with detail case
information and a list that shows social media posts.

NetworkReports
The StoresMapReport shows the location of nearest stores for a specified
location, in a map report.

ProfileReports
The Dials report shows the analytics key performance indicators (KPIs) for
a customer.

For the Telecommunications sample only, the SocialNetworkChart report
shows the social network chart for a customer ID.

UsageReports
The Usage report shows the voice and data usage of the customer.

Portal pages available in the Retail sample

The following Predictive Customer Intelligence portal pages are available from the
home page for the Retail sample.

Customer Online Activity Analysis
Shows detailed analysis of the customer's online activities with the
following charts:
v Purchase Activity Analysis (Traditional) shows a distribution of purchase

activities across different product lines.
v All Online Activity Analysis shows a relative comparison of all online

activities for all product lines.
v Relative Activity Conversion Analysis shows a stacked chart to analyze

the conversions between different online activities, such as Page Views,
Products Browsed, Products Carted, Products Abandoned, Products
Purchased, for all product lines.

v Analyzing Online Activities by Customer Segments allows you to
analyze the online activities for different customer segments and
combinations of customer segments.

v Analyzing Online Activities for Demographic Cluster shows a detailed
analysis of online activities for a demographic cluster. For example, for a
selected product line which cluster has highest products browsed
activity.

Customer Response Analysis
Contains two charts that are based on the data available from a customer’s
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response to product satisfaction and various offers that were made through
the IBM Analytical Decision Management application.

Contains a dial chart that shows how the customers rated a particular
product line or a product. It also contains a column chart that shows the
relative comparison of the probability of accepting different offers.

Market Basket Analysis
Shows the products that are likely to be bought together. This report can
also be filtered for individual products.

Understanding the Customer
Shows a distribution of a customer’s online activities across different
product lines, and customer segmentation. Customer segments are shown
by using a customer’s demographic data, online activity data, and their
purchasing behavior.

Reports available in the Insurance sample

The following Predictive Customer Intelligence reports are available from the home
page for the Insurance sample.

CaseReportInsurance
Shows the cases by month for the selected client.

Churn and Sentiment Scores
The Dial report shows churn propensity and sentiment score.

Churn Propensity
Shows the churn propensity ratio (the willingness of the client to leave the
provider) for the selected client.

ClaimsReport
The list report shows customer claims information.

Complaints
The bar chart and list report shows customer complaints information.

PolicyDetails
The list report shows customer policy information.

SMA Insight
Shows the social media activity for the selected client.

Social and Web Analytics
The pie chart and list report show customer social media post and
insurance product browsing summary information.

Copying the samples license files to each computer
After you install the samples, you must copy the swidtag file and license folder to
each computer on which you use an IBM Predictive Customer Intelligence sample.

Important: Do not rename the folders or files.

Procedure
1. Copy the swidtag file from the iso-swid folder where you installed the samples

to each computer on which you install a Predictive Customer Intelligence
component.
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For example, copy the file so that you have a C:\IBM\PCI\iso-swid folder that
contains a swidtag file on each node computer. And a C:\IBM\PCI\iso-swid
folder that contains a swidtag file on each client computer.
If a iso-swid folder already exists on the computer, do not overwrite the folder.
Add the swidtag file to the existing folder.
After you copy the IBM Predictive Customer Intelligence sample software tag
file, your iso-swid folder should have two swidtag files. One swidtag file is for
the product and the other swidtag file is for the samples.

2. Copy the license folder from the folder where you installed the samples to
each computer on which a IBM Predictive Customer Intelligence component is
installed.
For example, copy the folder and contents so that you have a
C:\IBM\PCIsamples\license folder that contains the license files on each node
computer. And a C:\IBM\PCIsamples\license folder that contains the license
files on each client computer.

Results

After you install the samples, the following folders must exist on each computer
on which you installed a Predictive Customer Intelligence component:
v On all computers:

C:\IBM\PCI\license (containing the product license files)
C:\IBM\PCIsamples\license (containing the samples license files)
C:\IBM\PCI\iso-swid (containing a product swidtag file and a samples swidtag
file)
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Appendix D. Products installed with IBM Predictive Customer
Intelligence

The following products are installed with or available to be installed with
Predictive Customer Intelligence.

Server components
v IBM DB2 Enterprise Server Edition 10.1 Fix Pack 3
v IBM Data Server Runtime Client 10.1 Fix Pack 3
v IBM WebSphere Application Server Network Deployment 8.5.5
v IBM Installation Manager 1.6.2
v IBM Cognos Business Intelligence Server 10.2.1 Fix Pack 1
v IBM Integration Bus 9.0 Fix Pack 1
v IBM WebSphere MQ 7.5 Fix Pack 2
v IBM SPSS Collaboration and Deployment Services Server 6.0
v IBM SPSS Collaboration and Deployment Services 6.0 Deployment Manager
v IBM SPSS Collaboration and Deployment Services Enterprise View Driver 6.0
v IBM SPSS Modeler Server 64-bit 16.0
v IBM SPSS Data Access Pack 7.1
v IBM SPSS Text Analytics Server 16.0
v IBM SPSS Modeler Collaboration and Deployment Services Adapter 16.0
v IBM SPSS Analytical Decision Management 8.0
v IBM SPSS Statistics Server 22.0
v IBM SPSS Statistics 22.0 Collaboration and Deployment Services Adapter 6.0
v IBM SPSS Modeler Solution Publisher 16.0
v IBM SPSS Modeler Premium Solution Publisher 16.0

Client and optional components

In the Predictive Customer Intelligence license, these components are referred as
“Supporting Programs - Client Installation”.
v IBM Data Server Runtime Client 10.1 Fix Pack 3
v IBM Cognos Framework Manager 10.2.1
v IBM Cognos Business Intelligence Samples 10.2.1
v IBM Cognos Supplementary Languages Documentation 10.2.1
v IBM Cognos Dynamic Query Analyzer 10.2.1
v IBM Cognos for Microsoft Office 10.2.0
v IBM Cognos Lifecycle Manager 10.2.1
v IBM Cognos Mobile 10.2.1 Fix Pack 2
v IBM Cognos Real-time Monitoring 10.2.1 Fix Pack 1
v IBM Cognos Software Development Kit 10.2.1
v IBM SPSS Collaboration and Deployment Services Deployment Manager 6.0
v IBM SPSS Modeler Client 16.0
v IBM SPSS Text Analytics Client 16.0

© Copyright IBM Corp. 2014 81



v IBM SPSS Data Access Pack 7.1
v IBM SPSS Social Network Analysis 16.0
v IBM SPSS Statistics Client 22.0
v IBM Integration Bus Toolkit 9.0.0.1
v IBM Installation Manager 1.6.2
v IBM WebSphere MQ Client 7.5 Fix Pack 2
v IBM SPSS Concurrent Licensing Tools 9.5.0.1
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Appendix E. Programs not authorized by the IBM Predictive
Customer Intelligence license

The following programs are not installed with IBM Predictive Customer
Intelligence, and the use of these programs is not authorized by the Predictive
Customer Intelligence license.
v IBM Cognos Analysis for Microsoft Excel (IBM Cognos Business Intelligence

Architect 10.2.1)
v IBM Cognos Analysis Studio (of IBM Cognos Business Intelligence Architect

10.2.1)
v IBM Cognos Business Intelligence Transformer (of IBM Cognos Business

Intelligence Architect 10.2.1)
v IBM Cognos Connection Installer for IBM Cognos Insight (of IBM Cognos

Business Intelligence Architect 10.2.1)
v IBM Cognos Cube Designer (of IBM Cognos Business Intelligence Architect

10.2.1)
v IBM Cognos Data Manager Connector (of IBM Cognos Business Intelligence

Architect 10.2.1)
v IBM Cognos Insight (of IBM Cognos Business Intelligence Architect 10.2.1)
v IBM Cognos Metric Designer (of IBM Cognos Business Intelligence Architect

10.2.1)
v IBM Cognos Metric Studio (of IBM Cognos Business Intelligence Architect 10.2.1)
v IBM Cognos Metrics Manager (of IBM Cognos Business Intelligence Architect

10.2.1)
v IBM Cognos Migration Tools (of IBM Cognos Business Intelligence Architect

10.2.1)
v IBM Cognos PowerPlay® Client (of IBM Cognos Business Intelligence Architect

10.2.1)
v IBM Cognos PowerPlay Server (of IBM Cognos Business Intelligence Architect

10.2.1)
v IBM Cognos PowerPlay Studio (of IBM Cognos Business Intelligence Architect

10.2.1)
v IBM Cognos Query Studio (of IBM Cognos Business Intelligence Architect 10.2.1)
v IBM Cognos TM1® Package Connector (of IBM Cognos Business Intelligence

Architect 10.2.1)
v IBM Connections (of IBM Cognos Business Intelligence Architect 10.2.1)
v IBM DB2 Workgroup Server Edition (of IBM Cognos Business Intelligence

Architect 10.2.1, IBM Cognos Real-time Monitoring 10.2.1)
v IBM Tivoli® Directory Integrator Identity Edition (of IBM Cognos Business

Intelligence Architect 10.2.1)
v IBM SPSS Data Collection Survey Reporter Developer Kit 7.x (of IBM SPSS

Modeler Premium 16.0, IBM SPSS Modeler Server Premium 16.0, IBM SPSS
Statistics Standard 22.0, IBM SPSS Statistics Server Standard 22.0)

v IBM SPSS Modeler Client Entity Analytics (of IBM SPSS Modeler Premium 16.0)
v IBM SPSS Modeler Server Entity Analytics (of IBM SPSS Modeler Server

Premium 16.0)

© Copyright IBM Corp. 2014 83



v BM SPSS Data Collection Developer Library 7.x (of IBM SPSS Statistics Standard
22.0, IBM SPSS Statistics Server Standard 22.0)

v IBM SPSS Statistics Data File Drivers 22.x (IBM SPSS Statistics Server Standard
22.0)

v IBM SPSS Statistics Diagnostic Utility 22.x (of IBM SPSS Statistics Standard 22.0)
v IBM SPSS Statistics-.Net Integration Plug-In 22.x (of IBM SPSS Statistics Standard

22.0, IBM SPSS Statistics Server Standard 22.0)
v IBM DB2 Workgroup Server Edition 10.5 (IBM DB2) (of IBM SPSS Modeler

Premium 16.0, IBM SPSS Modeler Server Premium 16.0)
v IBM WebSphere Application Server Developer Tools for Eclipse (of IBM

WebSphere Application Server Network Deployment 8.5.5)
v IBM WebSphere eXtreme Scale (of IBM WebSphere Application Server Network

Deployment 8.5.5)
v IBM Rational® Application Developer for WebSphere Software (of WebSphere

Application Server Network Deployment 8.5.5)
v J2SE Rule Execution Server (of IBM Integration Bus 9.0)
v IBM Data Studio 3.2 (of IBM DB2 Enterprise Server Edition 10.1)
v IBM WebSphere MQ 7.1 (of IBM DB2 Enterprise Server Edition 10.1)
v pureScale® Feature (of IBM DB2 Enterprise Server Edition 10.1)
v IBM General Parallel File System (GPFS™) for AIX® 3.5 (of IBM DB2 Enterprise

Server Edition 10.1)
v IBM General Parallel File System (GPFS) for Linux Multiplatform 3.5 (of IBM

DB2 Enterprise Server Edition 10.1)
v IBM Mobile Database 7.0.1 (of IBM DB2 Enterprise Server Edition 10.1)
v IBM Mobile Database Sync 1.0 (of IBM DB2 Enterprise Server Edition 10.1)
v IBM Tivoli Storage Flashcopy Manager 2.2 (of IBM DB2 Enterprise Server

Edition 10.1)
v Embedded version of IBM WebSphere Application Server ("embedded

WebSphere Application Server") 6.1 (of IBM Tivoli System Automation for
Multiplatforms 3.2 (of IBM DB2 Enterprise Server Edition 10.1))

v IBM Cloudscape 10 (of IBM Tivoli System Automation for Multiplatforms 3.2 (of
IBM DB2 Enterprise Server Edition 10.1))

v Embedded WebSphere Application Server 7.0 (of IBM Tivoli Directory Server 6.3
- Client Only (component) (of IBM DB2 Enterprise Server Edition 10.1)

v IBM InfoSphere® Change Data Capture 6.2 (of IBM InfoSphere Data Replication
10.1 (component) (of IBM DB2 Enterprise Server Edition 10.1))

v IBM InfoSphere Change Data Capture 6.5 (of IBM InfoSphere Data Replication
10.1 (component) (of IBM DB2 Enterprise Server Edition 10.1))

v IBM InfoSphere Replication Server 9.7 (of IBM InfoSphere Data Replication 10.1
(component) (of IBM DB2 Enterprise Server Edition 10.1))

v IBM Tivoli Directory Integrator 7.1 (of IBM Tivoli Directory Server 6.3 - Client
Only (component) (of IBM DB2 Enterprise Server Edition 10.1))

v WebSphere Application Server 7.0 (of IBM Tivoli Directory Server 6.3 - Client
Only (component) (of IBM DB2 Enterprise Server Edition 10.1))

v IBM DB2 Workgroup Server Edition 9.7 (of IBM Tivoli Directory Server 6.3 -
Client Only (component) (of IBM DB2 Enterprise Server Edition 10.1))

v IBM DB2 Enterprise Server Edition 9.7 (of IBM Tivoli Directory Server 6.3 -
Client Only (component) (of IBM DB2 Enterprise Server Edition 10.1))
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v IBM InfoSphere Data Replication 10.1 (component) (of IBM InfoSphere
Federation Server 10.1 (component) (of IBM DB2 Enterprise Server Edition 10.1))

v IBM WebSphere MQ 7.1 (of IBM InfoSphere Federation Server 10.1 (component)
(of IBM DB2 Enterprise Server Edition 10.1))

v IBM DB2 Connect™ 10.1, Application Server Edition (of IBM InfoSphere
Federation Server 10.1 (component) (of IBM DB2 Enterprise Server Edition 10.1))
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Appendix F. Performance tuning for IBM Predictive Customer
Intelligence

The topics in this appendix provide examples of configuration changes that might
help improve performance of your Predictive Customer Intelligence installation.

Tune WebSphere Application Server for Predictive Customer
Intelligence

Performance tuning settings for WebSphere Application Server include JVM tuning,
thread pools, connection pools, web container settings, logging, and web server
monitoring.

JVM tuning
Setting an appropriate Java virtual machine (JVM) heap size can improve
performance for IBM Predictive Customer Intelligence. Also, garbage collection is
an integral Java runtime service. Increasing the JVM heap size can reduce the
number of garbage collection occurrences and provide a 10 percent gain in
performance.

Heap size

The heap size should be set to an optimal value. It should not exceed 80% of the
physical memory available on the computer. Doing so would enable paging and
increase processor usage, which affects the performance of WebSphere Application
Server.

For Predictive Customer Intelligence, use 4096 MB.

The Max Heap Size is the maximum heap size that would be allocated to the
server. It is important that the value is less than the available physical memory.

For Predictive Customer Intelligence, use 7128 MB.

Garbage collection

Parallel garbage collection is a technique that uses several dedicated threads for
garbage collection. This method improves garbage collection pause time, which
increases processor efficiency and improves performance.

This process can be activated by setting the –Xgcthreads value to the number of
processors on the computer. For example, set –Xgcthreads:number_of_processors,
However, this method is not entirely suited for concurrent users.

For concurrent users, use -Xgcpolicy:optavgpause.

Thread pools
Thread pools enable server components to reuse threads. Reusing threads
eliminates the need to create new threads at run time, and creating new threads
expends time and resources.
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Web container thread pool

The web container thread pool is used for HTTP requests that come from the
client. Set the number of threads to double the number of users that might be
expected to access the application concurrently.

For example, for IBM Predictive Customer Intelligence, set the minimum value to
3000 and the maximum to 5000.

Connection pools

Connection pools are associated with data source configuration for web
applications, and it is used to direct JDBC calls within the application.

When a user makes a request over the web to a resource, the resource accesses the
data source. Because users connect and disconnect frequently with applications on
the internet, the application requests for data access can surge to considerable
volume. Consequently, the total data store overhead quickly becomes high for
web-based applications, and performance deteriorates. However, when connection
pooling capabilities are used, the web applications can realize performance
improvements of up to 20 times the normal results.

With data sources, most user requests do not incur the overhead of creating a new
connection because the data source can locate and use an existing connection from
a pool of connections. When the request is satisfied and the response is returned to
the user, the resource returns the connection to the connection pool for reuse.

For example, for IBM Predictive Customer Intelligence, set the minimum value to
1000 and the maximum to 3000.

Web container configuration
Web container configuration settings can improve IBM Predictive Customer
Intelligence performance.

Enable servlet caching

The server caches servlet output during application execution. A cache entry
contains not only the output, but also the side effects of the invocation. These side
effects include calls to other servlets and metadata about the entry, such as timeout
and entry priority information.

Web container custom properties

For the HTTPQueueInboundDefault property, there are two settings:

Maximum pool connections
The number of connections that are expected to be responded to by the
application server. Ideally, this value should be equal to or more than the
number of clients that are expected to use the system. The maximum
number that can be set is 20000.

Maximum persistent requests per connection
Persistent connections specify that an outgoing HTTP response should use
a persistent connection instead of a connection that closes after one request
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or response exchange occurs. A performance boost can be achieved by
increasing the number of persistent connections that are allowed on a
single HTTP connection.

Logging and performance monitoring
For IBM Predictive Customer Intelligence, turning off logging and performance
monitoring in a production environment can improve performance.

Tune IBM Unica for Predictive Customer Intelligence
You can improve performance of IBM Predictive Customer Intelligence by
modifying settings for IBM Unica.

EHCache configuration settings

EHCache is the built-in cache manager for IBM Unica Interact that is used to
improve performance. It is possible to configure the settings that are used by
EHCache to optimize its value for the runtime server group.

The number of sessions in memory depends on the following factors:
v The expected number of sessions per second.
v The total amount of time each session is supposed to last.

For example, if you expect 50 sessions a second, and each session is expected to
last 20 minutes, then modify the settings to support 60,000 sessions at a time.

Java Serialization API rather than SOAP API
For IBM Predictive Customer Intelligence, the Java Serialization API provides
better throughput and a shorter response time than the SOAP API.

Threads for interactive flowcharts
Every interactive flowchart requires at least one thread to run.

IBM Predictive Customer Intelligence, set the MaxNumberOfFlowchartThreads value
to be at least the maximum number of concurrent users that are expected on the
IBM Interact client. And set the MinNumberOfFlowchartThreads value to be the same
as the maximum value. Set the MaxNumberOfProcessThreads value to be at least the
MaxNumberOfFlowchartThreads.

For example, set the MaxNumberOfFlowchartThreads and
MinNumberOfFlowchartThreads to 500. And set MaxNumberOfProcessThreads to 550.
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Notices

This information was developed for products and services offered worldwide.

This material may be available from IBM in other languages. However, you may be
required to own a copy of the product or product version in that language in order
to access it.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service. This document may
describe products, services, or features that are not included in the Program or
license entitlement that you have purchased.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
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Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Software Group
Attention: Licensing
3755 Riverside Dr.
Ottawa, ON
K1V 1B7
Canada

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.
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This Software Offering does not use cookies or other technologies to collect
personally identifiable information.

Trademarks

IBM, the IBM logo and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “ Copyright and
trademark information ” at www.ibm.com/legal/copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:
v Microsoft, Windows, Windows NT, and the Windows logo are trademarks of

Microsoft Corporation in the United States, other countries, or both.
v Java and all Java-based trademarks and logos are trademarks or registered

trademarks of Oracle and/or its affiliates.
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