Network (Concurrent) License
Administrator's Guide

The following instructions are for administrators at sites with a network license for IBM® SPSS®
Amos™ 20. Thislicense alowsyou to install IBM SPSS Amos on any number of computers.
However, only the number of users for which you purchased the license can run the application
concurrently.

Before You Start

You will need your authorization code. This may be on a separate sheet of paper or is available
from http://www.ibm.convsoftware/getspss. The authorization code enables you to get alicense
for the network license manager. The network license manager controls your network license
and allows end users to run IBM® SPSS® Amos™. If you cannot find your authorization code,
contact your sales representative.

To ensure that you set up the network license correctly, follow these steps:

» Install the network license manager. The network license manager is the utility that will serve
up the network licenses to end users. You can install the license manager on any computer on
your network. Thisis typically a server to which desktop computers can connect. For more
information, see the topic Installing the Network License Manager onp. 2.

» License your product. This action will give the license manager the required information for
serving up the licenses. For more information, see the topic Licensing Your Product onp. 5.

» Test the network license manager. You should test license manager to make sure it is serving up
licenses. For more information, see the topic Testing the License Manager onp. 9.

» Install IBM SPSS Amos on the local desktop computers. You or your end users will complete the
full installation on the desktop computers. During an installation, an end user can specify the
computer on which the license manager is running. When an end user triesto launch IBM SPSS
Amos, the product communicates with this license manager to get alicense. If alicenseis
available, IBM SPSS Amos launches. For more information, see the topic Installing the Product
on the Local Desktop Computers on p. 10.

No administration steps are required for the installation, but if any problems arise, see
Administering the Network License on p. 13.

Ghosting

You can ghost the software by installing the license manager and then installing the product on a
local desktop that will be used for creating the ghosting image. Ghost the additional computers
as needed.
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Citrix and Terminal Services

You can install and publish the IBM® SPSS® Amos™ application on your Citrix or Terminal
Services Server the same way that you install and publish other Windows applications.

Installing the Network License Manager

Before end usersinstall IBM® SPSS® Amos™ on their desktop computers, you must install the
network license manager. This utility is a continuously executing service or daemon that you
will typically install on one computer on your network. (You also have the option of installing
on multiple computers, in which case you would set up redundant license managers. For more
information, see the topic Setting Up Redundant License Serverson p. 15.) You do not install the
network license manager on the desktop computers.

Whenever an end user starts a network-licensed IBM SPSS application, the application will
request alicense from the license manager. This utility will deliver licenses up to afixed number
of simultaneous end users, determined by the license that you have purchased. After this number
has been met, any further requests for licenses will be refused. If you find that end users are
often being refused licenses, you can contact your sales representative to purchase a license that
will alow more simultaneous users.

License managers are available on a separate DVD/CD. They can also be downloaded as
an elmage.

Note: The license manager will record the number of active end-user sessions and information
about each session in alog file, which you can use to troubleshoot connection problems. For more
information, see the topic Obtaining Log Information on p. 14.

Multiple Operating Systems

The platform on which the network license manager is running does not have to match the
platform on which the client is running. For example, a Linux license manager can serve up
licenses for Windows clients.

Administering the License Manager

You administer the license manager using the license manager tools, which are available only
for Windows. Therefore, you need at least one Windows machine on which to install the license
manager tools.

System Requirements

The computer on which you install the network license manager must meet the following
requirements:

m 550 Mhz or higher processor
m 128 MB of RAM or more
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Important! If afirewall isrunning on the license server, you must open port 5093 for UDP.
Otherwise, client computers will not be able to retrieve a license from the license manager.
Furthermore, if you are using redundant license servers, you must open port 5099 for UDP to
enable the license servers to communicate with each other.

Upgrading the License Manager

If you have a previous version of the license manager installed, you must perform the following
steps:

» Go to the directory in which you installed the old license manager.
» Copy thelservrc file. On Windows, look in the winnt subdirectory.
» Savethelservrc file to a safe location.

» |f any users have checked out commuter licenses, make sure those users check the licenses back
in. See the topic Configuring Commuter Licenses on p. 17 for information about obtaining a
list of checked out licenses.

» Shutdown the license manager. For more information, see the topic Starting and Stopping the
License Manager on p. 19.

» Uininstall the old license manager. For more information, see the topic Uninstalling the License
Manager on p. 20.

» Install the new license manager. For information about installing on Windows, see the topic
Installing the License Manager on Windows on p. 4. For information about installing on
UNIX/Linux, see the topic Installing the License Manager on UNIX/Linux on p. 4. For
information about installing on Mac OS, see the topic Installing the License Manager on Mac OS
onp. 5.

» Copy the saved Iservrc file to the directory in which you installed the new license manager or
the winnt subdirectory of the installation directory on Windows. If you accepted the default
location on Windows, check the C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\ folder.

Installing the Concurrent Licensing Tools (All Platforms)

Before you can install the license manager and the license manager tools, you must run the
concurrent licensing tools installer. Thisinstaller will copy the installer files for the license
manager and/or the license manager tools to your computer. During installation, you will be able
to choose which installer files you want to copy.

The concurrent licensing tools installer requires Java 1.5 or higher.
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>

Insert the DVD/CD into the DVD/CD drive of the network computer on which you want to
run the license manager and/or license manager tools. Look for the installer for your operating
system and launch it from the DVD/CD.

or

If you downloaded an elmage file, use an archive utility such as WinZip to extract al thefilesin
the appropriate elmage. Launch the installer file for your operating system.

Note: There may be multiple elmages for the concurrent license tools: onefor the license manager,
one for the license manager tools, and one for hardware key drivers. Each elmage installs the
concurrent licensing tools and the installer for the named component.

Follow the instructions that appear on the screen. Be sure to note the installation directory. If you
chose to install the license manager and/or the license manager tools, the installation process for
these will be started automatically.

Installing the License Manager on Windows

Note: On Windows Vista or 7, you must launch the installer as administrator. When instructed to
launch an installer file, right-click the file and choose Run As Administrator.

If you haven't installed the concurrent licensing tools, install them and be sure to select Sentinel
License Manager if prompted. For more information, see the topic Installing the Concurrent
Licensing Tools (All Platforms) onp. 3.

When you install the concurrent licensing tools from the DVD/CD, the installer for the license
manager should start automatically. If it didn’t or you cancelled the installation, browse to the
licensemanager directory in the concurrent licensing tools installation directory.

Launch setup.exe. On Windows Vista or 7, be sure the launch the installer as administrator.

Follow the instructions that appear on the screen.

Installing the License Manager on UNIX/Linux

>

If you haven't installed the concurrent licensing tools, install them and be sure to select Sentinel
License Manager if prompted. For more information, see the topic Installing the Concurrent
Licensing Tools (All Platforms) on p. 3.

Browse to the licensemanager directory in the concurrent licensing tools installation directory.
Untar the license manager file.

Install the license manager tools on a Windows machine. For more information, see the topic
Installing the License Manager Toolsonp. 5.

Refer to Starting and Stopping the License Manager on p. 19 for information about starting
the license manager.
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Installing the License Manager on Mac 0S

>

vV v v v Vv

If you haven't installed the concurrent licensing tools, install them and be sure to select Sentinel
License Manager when prompted. For more information, see the topic Installing the Concurrent
Licensing Tools (All Platforms) onp. 3.

Browse to the licensemanager directory in the concurrent licensing tools installation directory.
Double-click the license manager ZIP file to extract the contents of thefile.

Double-click the extracted license manager installer.

Follow the instructions that appear on the screen.

Install the license manager tools on a Windows machine. For more information, see the topic
Installing the License Manager Toolsonp. 5.

Refer to Starting and Stopping the License Manager on p. 19 for information about starting
the license manager.

Installing the License Manager Tools

The Windows-only license manager tools are used to administer the license manager. Depending
on your operating system, you may need to manually install these tools.

m  Windows. You can instal the license manager tools on the same machine on which you
installed the license manager. You also have the option of installing on another Windows
machine if you want to administer the license manger remotely.

m  Other Operating Systems. If you installed the license manager on a non-Windows machine, you
must install the license manager tools on a Windows machine.

If you haven't installed the concurrent licensing tools, install them and be sure to select Tools
when prompted. For more information, see the topic Installing the Concurrent Licensing Tools
(All Platforms) onp. 3.

Browse to the tools directory in the concurrent licensing tools installation directory.
Launch setup.exe.

Follow the instructions that appear on the screen.

Licensing Your Product

After the main part of the installation is complete on Windows, click Finish to launch the License
Authorization Wizard. The License Authorization Wizard allows you to obtain alicense for IBM®
SPSS® Amos™. On other operating systems, you must install the license from the command
prompt after installing the license manager.

If you do not get alicense now, you can enable IBM SPSS Amos to be used for atemporary usage
period by alimited number of users. After the temporary usage period—which begins when the
product isfirst used—IBM SPSS Amos will no longer run. Therefore, it is recommended that
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you obtain alicense as soon as possible. You must either obtain alicense or enable for temporary
usage to use IBM SPSS Amos.

Note: Licenses aretied to the network computer’s hardware with alock code. If you replace the
network computer or its hardware, you will have a new lock code and will need to contact your
sales representative to obtain a new authorization code.

Warning: The license is sensitive to time changes. If you must change the system time
and then cannot run the product, contact IBM Corp. Technical Support by visiting
http: //Amww.ibm.com/support.

Using the License Authorization Wizard (Windows Only)

The License Authorization Wizard is available only on Windows. If you need to license the
license manager on a different operating system, you must license from the command prompt. For
more information, see the topic Installing a License from the Command Prompt on p. 7.

If you don’t launch the License Authorization Wizard during installation or cancel the License
Authorization Wizard before obtaining alicense, you can launch it by running law.exe, which
can be found the license manager installation directory. On Windows Vista or 7, you must run as
administrator. Right-click law.exe and choose Run As Administrator.

» When prompted, choose License my product now.

» When prompted, enter one or more authorization codes. If you received physical installation

media, your authorization code may be delivered on a separate sheet of paper along with your
software or on the inside cover of the DVD/CD case. You should have received the authorization
code(s) from your administrator.

The License Authorization Wizard sends your authorization code over the Internet to IBM Corp.
and automatically retrieves your license. If your computer is behind a proxy, click Configure
proxy settings and enter the appropriate settings.

If the authorization process fails, you will be prompted to send an e-mail message. Choose
whether you want to send the e-mail message through your desktop e-mail program or through a
Web-based e-mail application.

m If you choose the desktop option, a new message with the appropriate information will be
created automatically.

m If you choose the Web-based option, you must first create a new message in your Web-based
e-mail program. Then copy the message text from the License Authorization Wizard and
paste it into your e-mail application.

Send the e-mail message and respond to the prompt in the License Authorization Wizard. The
e-mail message will be processed almost instantaneously. You can click Enter License Code(s)
to enter any license code(s) that you receive. If you aready closed the License Authorization
Wizard, restart it and select License my product now. On the Enter Codes panel, add the license
code that you received and click Next to complete the process.
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Installing a License from the Command Prompt

You have two options for installing from the command prompt. You can use licenseactivator to
get alicense from the Internet automatically, or you can use echoid to get alicense manually.

Using licenseactivator to Install a License Automatically

The computer on which you are installing the license must be connected to the Internet. If itisn't,
install the license manually. For more information, see the topic Installing a License Manually
onp. 8.

» Login asthe user who installed the license manager.

» Open acommand prompt and change directories to the license manager installation directory. Note
that thisis the directory in which you installed the license manager, not the directory in which you
installed IBM® SPSS® Amos™. If you accepted the default location on Windows, check the
C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\ folder.

» Windows Only. Change directories to the winnt subdirectory.

» You typically have an authorization code. In the simplest case, you enter the following at the
command prompt. See below for more details about the command prompt usage.

licenseactivator <auth-code>

where <auth-code> is your authorization code.

You should see a message that the license was added successfully. If it wasn't, note the error code
and try installing the license manually. For more information, see the topic Installing a License
Manually onp. 8.

When you use licenseactivator, it licenses the product and writes alog file to its directory.
The name of thelog fileis licenseactivator_<month>_<day>_<year>.log. If any errors occur,
you can check the log file for more information. This information is also useful if you contact
IBM Corp. for support.

Using licenseactivator with Authorization Codes

licenseactivator istypically used with one or more authorization codes that you received when
you purchased the product. Enter al of the text on one line.

licenseactivator authcodel[:authcode2:...:authcodeN] [PROXYHOST=proxy-hostname]
[PROXYPORT=proxy-port-number] [PROXYUSER=proxy-userid] [PROXYPASS=proxy-password]

m  Multiple authorization codes are separated by colons ().

m  The proxy settings are optional, but you may need them if your computer is behind a proxy.
Which proxy settings are needed depend on the operating system.

Windows. On Windows, the proxy settings work only when the Local Area Network (LAN)
settings in the Internet Settings control panel reference a specific proxy server (host) address
and port. You do not enter the proxy host and port on the command line. But you do need to
enter values for PROXYUSER and PROXYPASS.
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Other Operating Systems. On other operating systems, you may need to enter all of the proxy
settings on the command line, depending on your specific proxy configuration.

Using licenseactivator with License Codes

In less common scenarios, IBM Corp. may have sent you alicense.

m  Multiple license codes are separated by colons (:).

®  When using license codes, licenseactivator does not connect to the Internet, so you do not
need to specify proxy information.

Installing a License Manually

>

>

Log in as the user who installed the license manager.

Open acommand prompt and change directories to the license manager installation directory. Note
that thisisthe directory in which you installed the license manager, not the directory in which you
installed IBM® SPSS® Amos™. If you accepted the default location on Windows, check the
C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS License Manager\ folder.

Windows Only. Change directories to the winnt subdirectory.

Get the lock code for the server machine. At the command prompt, type echoid (other operating
systems) or ./echoid (UNIX).

Send the lock code and your authorization code to IBM Corp. by calling your local office or
sending an e-mail message to spsscs@us.ibm.com. IBM Corp. will then provide alicense code
or afile containing a license code.

Use licenseactivator to enter the license code or codes.

Enabling for Temporary Usage

>

>

>

If you did not install the license, you can enable IBM® SPSS® Amos™ for temporary usage.

If you have physical installation media, make sure that the DVD/CD isin the DVD/CD drive. If
you downloaded an elmage, open and/or extract the contents of the elmage.

Start the WIimAdmin application. For more information, see the topic Starting the WImAdmin
Application on p. 14.

In the left pane of the WImAdmin application, click the + sign next to Subnet Servers. If the
license manager server is not listed, specify the computer by choosing Defined Server List from
the Edit menu.



9

Network (Concurrent) License Administrator’s Guide

» Right-click the name of the network computer on which the license manager is running and choose:
Add Feature > From a File > To Server and its File

Note: If you select To Server rather than To Server and its File, the temporary usage information is
stored in memory. You will lose this information when the network computer is rebooted.

» In the Open dialog box, type
D:\Windows\Administration\Licensing\NeworkLicenseManagenr\lservrc.temp, where D
is your installation disk drive. If you are not using D for the disk drive,
enter the appropriate drive location. If you downloaded an elmage, type
<elmage>\Administration\Licensing\NeworkLicenseManagenservrc.temp, where <elmage> is
the location where you opened/extracted the elmage files.

» When the application displays your license, click OK. For information about viewing the license's
details, see Viewing Details about a License on p. 15.

Adding a License

You may want to add alicense at alater time. The process for adding alicense is the same as
installing the original license.

Viewing Your License

You can view your network license (including the number of users) in the WImAdmin application.
For information about the WImAdmin application and specifics about viewing the license, see
Administering the Network License on p. 13.

Testing the License Manager

To make sure the license manager is serving up licenses correctly, you should test it.

» If you haven't installed the license manager tools on another machine, install them on a Windows
machine that is not running the license manager you want to test. For more information, see the
topic Installing the License Manager Toolsonp. 5.

» Start the WImAdmin application. For more information, see the topic Starting the WImAdmin
Application on p. 14.

» Add the remote license manager server that you want to test. For more information, see the topic
Adding a Server on p. 14.

» View the licenses on the remote server. For more information, see the topic Viewing Details
about a License on p. 15.

If you are able to view the license, the license manager is ready for local desktop computers to
connect to it. You can proceed with installing the product on local desktop computers. If you are
not able to view the license, review the previous steps to ensure the license manager was installed
correctly.
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Installing the Product on the Local Desktop Computers

Note: We do not officially support connecting to the network license manager through VPN.

You have two options for installing the full product locally on an end user’s computer. You can
manually install on each computer, or you can use an application like Systems Management
Server (SMS) to push the installation to the computers running Windows.

To Manually Install on a Local Desktop

» Make the installation media available. Download the elmage for the product and extract the files
to ashared network drive. If you have physical installation media, make as many copies of the
DVD/CD as you heed or place it on a shared network drive.

» Copy the installation instructions and prepare licensing information. Make as many copies
of the product installation instructions as you need. The installation instructions are
available from the download site or, if you received physical installation media, in the
/Documentation/<language>/InstallationDocuments directory on the DVD/CD. Look for the
instructions that correspond to your license type. You can distribute the full or abbreviated
versions of the instructions. After installation, the end user must enter the IP address or the
name of the network computer on which the network license manager is running. Fill out this
information in the space provided at the beginning of the instructions before copying them.

» Distribute the installation materials to end users. Distribute the installation DVD/CD (or
downloaded file or network location), the installation instructions, and the licensing information to
end users who can manually install on each computer as needed.

To Push to the Local Desktops Running Windows

Because IBM® SPSS® Amos™ installations are compatible with Microsoft Windows Installer
(MSl), you can push an installation to the end-user desktop computers.

Pushing an Installation to Windows Computers

Pushing an installation is a method for remotely distributing software to any number of end users
without any user intervention. You can push the full installation of IBM® SPSS® Amos™ to the
end-user desktop computers running Windows. The technology that you are using for pushing the
installation must support the MSI 3.0 engine or higher.

Uninstalling a Previous Version

If you are going to push to the same directory in which a previous version of IBM® SPSS®
Amos™ was installed, you need to uninstall the old version.You can push the uninstallation as
you push an installation. For more information, see the topic Pushing an Uninstallation on p. 13.
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Properties for Push Installations

Following are the properties that you can use for push installations. All properties are case
sensitive. Values must be quoted if they contain spaces.

Table 1-1
Properties for Push Installations

Property Description Valid value(s)

INSTALLDIR The directory where IBM® A valid path such as C:\Amos.
SPSS® Amos™ should be
installed on the end user’s
desktop computer. This property
is optional. If it is excluded,
the default is C:\Program
Files\| BM\SPSS AMOS\20.

LICENSETYPE The license type. The value is Network
case sensitive.

LSHOST The IP addresses or the names One or more valid IP addresses
of the network computer or or network computer names.
computers on which the network | Multiple addresses or names are
license manager is running. separated by colons (for example,

server 1: server 2; server3).

DISABLE_COMMUTE Disables the commuter license 1, which indicates that commuter
functionality on the end user’s licenses are disabled.

desktop computer. If this property
is specified, no shortcuts for

the commuter license will

be installed on the desktop
computer. For more information
about commuter licenses, see
Configuring Commuter Licenses
onp. 17.

SPSS COMMUTE_MAX_LIFE | The maximum number of days A number between 1 and 30.
for which an end user can check
out a commuter license. For
more information, see the topic
Configuring Commuter Licenses
onp. 17.

COMPANYNAME The name of your company. Any string.

MSI Files

The Amos 20.0.msi file is located under the Windows\Amos directory on the DVD/CD. If you
downloaded the software, you must extract the contents of the elmage to access the M Sl file.

Command Line Example

Following is a command line that you could use to push a product installation. Enter all of the
text on one line.

MsiExec.exe /i "Amos 20.0.msi" /an /L*v logfile.txt
INSTALLDIR="C:\Amos" LICENSETYPE="Network" LSHOST="mylicserver"
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Using SMS to Push the Installation

The basic stepsfor using Systems Management Servers (SMS) to push IBM® SPSS® Amos™ are:

» Copy the appropriate subdirectory under the Windows\Amos directory on the DVD/CD to a
directory on a network computer. If you downloaded the software, you must first extract the
contents of the elmage.

» Edit the Amos 20.0.sms file located in the copied directory. Using atext editor, modify the value
of CommandLine by adding the appropriate properties. For alist of the available properties,
refer to Properties for Push Installations on p. 11. Make sure to specify the correct M Sl file
in the command line.

» Create a package from the Amos 20.0.sms file and distribute the package to the end-user desktop
machines.

Using Group Policy or Related Technology to Push the Installation

The basic steps for using Group Policy or arelated technology to push IBM® SPSS® Amos™ are:

» Copy the appropriate subdirectory under the Windows\Amos directory on the DVD/CD to a
directory on a network computer. If you downloaded the software, you must first extract the
contents of the elmage.

» Using an application like ORCA, edit the Properties table in the appropriate Amos 20.0.msi file
under the copied folder. ORCA is part of the Windows 2003 Server SDK, which you can find at
http: //Amww.mi crosoft.com/downloads by searching for the SDK. For alist of the properties that
you can add to the Properties table, refer to Properties for Push Installations on p. 11. Make sure
to use the correct MS file.

» Create a package using the edited Amos 20.0.msi file and distribute the package to the end-user
desktop computers.

Pushing the Installation to a Non-English System

You can push to a non-English system without additional specification. However, the installer
language (if pushing an interactive installation) will appear in English, the user interface will
appear in English, and the help will appear in English. Users can change the user interface
language after installation, but localized help will not be available.

You can use the TRANSFORMS property to specify one of the MST files available on the DVD/CD
or in the downloaded elmage. The MST file will ensure the installer, user interface, and help
appear in the specified language. M ST files are not available if you downloaded IBM® SPSS®
Amos™. Users will need to manually install the language packs for the localized help and
manually change the user interface language in the product.

The TRANSFORMS property is a parameter for MsiExec.exe. The following example uses the
TRANSFORMS property to push a French installation. Theinstaller will appear in French, the user
interface will appear in French, and French help will be installed. (You can also override the help
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language with the HELPCHOICE property. For more information, see the topic Properties for Push
Installations on p. 11.) Enter al of the text on oneline.

MsiExec.exe /i "Amos 20.0.msi" /agn /L*v logfile.txt
INSTALLDIR="C:\Amos" LICENSETYPE="Network" LSHOST="mylicserver" TRANSFORMS=1036.mst

The following language M ST files are located in the Windows\Amos directory on the DVD/CD. If
you downloaded an elmage, these files are located at the root of the extracted elmage files.

Table 1-2
Language MST Files
Language MST File
English 1033.mst
Japanese 1041.mst

Pushing an Uninstallation

Note: When you push the uninstall command, the end user loses customizations. If specific
users require customizations, you can exclude those users from the distribution and ask them to
install the product manually.

If you push an installation of alater version of IBM® SPSS® Amos™, you may want to uninstall
first. You can do this silently by pushing the following command. Enter all of the text on oneline.

MsiExec.exe /X{58C50F5A-B7E2-4149-8911-B14CEC825F57} /gn /L*v logfile.txt
ALLUSERS=1 REMOVE="ALL"

This command will uninstall IBM SPSS Amos 20. The following table lists the uninstall IDs for
this and previous releases.

Table 1-3

Uninstall IDs for IBM SPSS Amos
Version Uninstall ID
20.* {58C50F5A-B7E2-4149-8911-B14CEC825F57}
19.* {B132EFD2-BF03-48A A-8EC8-404E4C5199C5}
18.* {65D9DA 69-4C22-46CA-B762-A338CAC94599}
17.* {9DB2E18E-2A 1F-4D65-A258-9CB446903C3E}
16.* {4DA782CB-C9A0-462F-9D18-17D301BC507C}

Administering the Network License

The license manager maintains your network license. To administer the license manager itself and
to view information about the network licenses that it is maintaining, you can use the WImAdmin
application, which is the main user interface for the license manager tools. The license manager
tools are installed automatically with the network license manager on Windows. If you are
administering a license manager on a non-Windows machine or a remote Windows machine,
install the license manager tools on a separate Windows machine. For more information, see the
topic Installing the License Manager Toolsonp. 5.
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Note: If you need additional administration information, refer to the SafeNet documentation,
which is installed with the concurrent licensing tools. This documentation is in the
licensemanager/documentation directory in the concurrent licensing tools installation directory.

Starting the WimAdmin Application

From a Windows Computer where the License Manager is Installed

» From the Windows Start menu, choose:
[All] Programs > Sentinel RMS License Manager > Sentinel RMS Server Administration
From a Windows Computer where the License Manager Tools are Installed

» From the Windows Start menu, choose:
[All] Programs > Sentinel RMS Tools > Sentinel RMS License Server Administration

Adding a Server

Before you can administer anetwork license manager, you need to add its server to the WImAdmin
application. You have two options for adding the server.
To Manually Add a Server

» From the WImAdmin application menus, choose:
Edit > Defined Server List

» Inthe Defined Server List dialog, enter the name or | P address of the server on which the license
manager is running.

» Click Add.
» Click OK.
The server now appears in the Defined Serverslistsin the left pane of the WImAdmin application.

To View a List of Servers on the Subnet

» Intheleft pane of the WImAdmin application, click the + sign next to Subnet Servers.

A list of network license manager servers on your subnet appears. If you can’t find a specific
server with this method, manually add it as described above.

Obtaining Log Information

If end users have difficulty checking out licenses, the log files may contain useful information.
You can use the LSERVOPTS environment variable and the -f <trace-log-file> and -1
<usage-log-file> optionsto specify that log files should be created. For more information
about this environment variable and its options, refer to the SafeNet documentation in the
licensemanager/documentation directory in the concurrent licensing tools installation directory.
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Viewing Details about a License

You can view details about licenses that you added either manually or through the License
Authorization Wizard.

» Intheleft pane of the WImAdmin application, click the + sign next to the license manager server
to see the license(s).

» Click the name of the license. The right pane displays details about the license. Codes are used to
identify the licenses. Thefirst part of the code indicates the feature. The second part indicates
the version.

To See the Names Associated with the Feature Codes

» Using acommand prompt, change to the directory in which the license manager or the license
manager tools are installed.

» Typelmshowlic <server> (Windows) or ./Imshowlic <server> (other operating systems), where
<server> isthe name or |P address of the server on which the license manager is running.

The output lists al the features available on the server, grouped by product and version.

Setting Up Redundant License Servers

You can set up multiple, redundant license servers that support the same users. Redundant servers
can help prevent any interruption that may occur when a server crashes. Another redundant server
can take over the management of the license when the first server crashes.

You will need a specia authorization code to enable the redundancy feature. The authorization
code shipped with the software will not enable redundancy. Be advised that by installing the
code that ships with the software, you will forfeit your ability to use the redundancy feature. If
you wish to enable redundancy, complete the preparation steps described below. Then contact
Customer Service at spsscs@us.ibm.com or call (800) 521-1337 between 8:30 A.M. and 5:00 PM.
U.S. Central Time. For customers outside of North America, please contact your local office.

There must be an odd number of servers (at least three of them), and a majority must be
running at the same time. For example, if there are three redundant license servers, two of them
must be running.

To Prepare Each Redundant License Server

» Install the license manager. For more information, see the topic Installing the Network License
Manager onp. 2.

» Using acommand prompt, change to the directory in which you installed the license manager.

» Get thelock code for each server machine. At the command prompt, type echoid (Windows) or
Jechoid (other operating systems).

» Write down the lock code. You will need this when you contact Customer Support or your local
office.
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Repeat these steps for each redundant license server.

To Set Up the Redundant License Server Pool

If alicense manager is running on any of the redundant license servers, stop the license manager
on each compulter.

From the WImAdmin application menus, choose:
Edit > Redundant License File

This action opens the WrlfTool application.

From the WrlfTool application menus, choose:
File > New

For each redundant license server, click Add to specify the hostname and | P address of each server.

Change the order of the serversto indicate the order in which the redundant license servers are
used. Thefirst onein thelist isthe primary server.

Click Add License to add the license(s) that you received from Customer Service or your local
office. If you received multiple licenses, be sure to add every one.

Click OK.

Click Done when you are finished.

To Save the Redundant License File

From the WrlfTool application menus, choose:
File > Save As

Save the redundant license file (Iservrlf) to an easily accessible location. You will need to copy the
file in the next steps.

To Configure the Redundant License Servers

Copy the redundant license file (Iservrlf) to the winnt subfolder of the license manager installation
directory on Windows. If you accepted the default location, check the C:\Program Files\Common
Files\SafeNet Sentinel\Sentinel RMS License Manager\ folder. On other operating systems,

copy thefile directly to the license manager installation directory. There must be at least three
redundant license servers.

Start the license manager on each redundant license server.

To Configure End-User Computers

When the end user installs the product, the user specifies al redundant servers, with the server
names or | P addresses separated by a colon (for example, server1:server2:server3). The setup
program then adds the necessary configuration information to the end user’s computer. If the
product is aready installed on the desktop computers, you can perform the following manual steps
to add the configuration information. You can also push an uninstall followed by a new install
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that defines all the servers. Refer to Pushing an Installation to Windows Computers on p. 10
for information about pushing installations.

» Using atext editor, open spssprod.inf, which is located in the product installation directory on
the desktop computer.

» Comment out the line for DAEMONHOST. For example:

#DAEMONHOST=serverl
» Save spssprod.inf.

» Create an LSHOST environment variable. Set this variable to include all redundant servers, with
the server names or | P addresses separated by a colon (for example, server 1: server2: server3).

Configuring Commuter Licenses

Commuter licenses allow your end users to check out licenses from the license manager, so that
they can use the license when not connected to the network. On Windows, commuter licenses are
not enabled by default. They are enabled by default on other operating systems. Instructions for
actually checking out the commuter license appear in the end user installation instructions.

You can restrict the percentage of licenses that are enabled for commuting on the license
manager server. It'sagood ideato restrict commuter licenses to prevent all the licenses (tokens)
from being used up by commuters. After the specified percentage of licenses have been used by
commuters, no more will be available until the commuter licenses expire or are checked back
in. You can also configure the maximum duration for which an end user can check out alicense.
The default maximum duration is seven days.

To Set the Percentage of Available Commuter Licenses

» Create an LSERVOPTS environment variable on the license manager server. Thisvariableis
created during the license manager installation on Windows, so you need to complete this only for
the other operating systems.

» Edit the value of the LsErRvVOPTS environment variable to include -com <percentage>, where
<percentage> is a numeric value between 0 and 100 indicating the percentage of licenses that are
available for commuting. Specifying 0 disables commuter licenses. This switch isincluded by
default on Windows and is set to 0.

» Restart the computer on which the license manager is running.

To Set the Maximum Duration for Commuter Licenses

The maximum length of time a user can check out a commuter license is specified by the
CommuterMaxLife Setting in the spssprod.inf file on the desktop. computer. Thisfile islocated
in the product installation directory on the desktop computer. Open spssprod.inf and look for
CommuterMaxLife . Set the value of this option to the maximum number of days for which an
end user can check out a commuter license. This should be a number between 1 and 30. You can
also set this value when you push the installation. For more information, see the topic Pushing an
Installation to Windows Computers on p. 10.
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Note: This functionality works off the date, not the time. For example, if you set the
CommuterMaxLife option to one day, then check alicense out at 9 am., this license does not get
checked back in until midnight on the following day. So athough CommuterMaxLife isSet to
one day, the license is actually held for 39 hours.

To Obtain a List of Checked Out Licenses from the Command Line

You can find out which users have checked out licenses.

Using a command prompt, change to the directory in which the license manager or the license
manager tools are installed.

Type Ismon <server> (Windows) or ./lsmon <server> (other operating systems), where <server>
is the name or |P address of the server on which the license manager isrunning. You can omit the
license server name if you want to view checked out licenses for only the localhost server.

To Obtain a List of Checked Out Licenses from the WimAdmin Application

You can aso view checked out licenses in the WImAdmin application:

In the left pane of the WImAdmin application, click the + sign next to the license manager server.

Click the + sign next to Clients. Clients using the network license are listed. If no clients are
listed, no users are using the network license.

Select aparticular Client to view whether the client has a checked out license. Review the Detailed
Information areain the right pane after selection.

Configuring License Reservations

You can create a reservation file, which specifies how many licenses are reserved for specific users
or groups of users. Users are identified by network |Ds or computer names (not | P addresses). For
example, you can set up areservation file that reserves the license for a group of power users.
Licenses will aways be available for these users. You can also use the reservations to prevent
certain users from accessing the license.

To Create a New Reservation File

From the WImAdmin application menus, choose:
Edit > Reservation File

This action opens the WIsgrmgr application.
From the WIisgrmgr application menus, choose:
File > New

To Add Licenses and Users to the Reservation File

From the WIisgrmgr application menus, choose:
Feature > Add
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Click Next on the first screen of the wizard.

Specify the feature code associated with the license that you want to reserve. Refer to Viewing
Details about a License on p. 15 for information about getting the feature codes associated

with licenses. Also define a specific version, which is entered as it appears in the WImAdmin
application (for example, 160). The version is not optional. Ignore the Capacity controls, because
capacity licenses are not supported.

Click Next.

Specify a name for a group of users. The nameis arbitrary, but you should make it descriptive
(for example, Sales).

Specify the number of licenses that are reserved for the group. Group members can still access al
licenses, but the number of licenses you specify will no longer be available for users who are not
included in the group. That is, if you have 10 licenses and you reserve five, members of the group
have 10 licenses available to them, while other users have only five.

On the Members window, click Add to specify a user or computer name associated with the
group (do not use IP addresses). If the user or machine isincluded in the group, that user or
machine can use the reserved license. If the user or machine is excluded from the group, that
user or machine cannot access the license at all. Specify as many users or machines as needed.
Note that groups must be mutually exclusive. Therefore, different groups for the same license
cannot contain common USers or computers.

Click Finish when al users have been added to the group.

Add other groups or licenses as needed. You can aso modify or delete licenses and groups by
right-clicking one and choosing Properties.

To Save the Reservation File

When finished defining the reservation file, from the menus choose:
File > Save As

Save thefileto an easily accessible location. You will need to copy the filein the next step.

To enable the license server to automatically find the Isreserv file at start up, copy the file to the
winnt subfolder of the license manager installation directory on Windows. If you accepted the
default location, check the C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\ folder. On other operating systems, copy the file directly to the license manager
installation directory.

If you want the same reservations to apply for al redundant servers, copy the reservation file
(Isreserv) to each server.

Restart each license manager when finished.

Starting and Stopping the License Manager

The method for starting the license manager depends on your operating system.
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Windows

On Windows machines, the license manager is a System Service. The service is automatically
started by default. However, if you need to start it manually:

In the Windows Control Panel, double-click Administrative Tools.
Double-click Services.
L ocate Sentinel RMS License Manager in the Services list.

Right-click the service and choose Start or Stop.

Other Operating Systems

On other operating systems, the license manager is a daemon service. Complete the following
steps to start it manually. You can also configure the license manager to start automatically
(instructions follow).

Using the command prompt, browse to the directory in which you installed the license manager.
Starting. Asroot, type ./Iserv & at the command prompt and press Enter.

Stopping. Asroot, type ./Isrvdown <hostname> at the command prompt, where <hostname> isthe
network name of the computer on which the license manager is running. Then press Enter.

Configuring the License Manager to Start Automatically

vV v v v v v

>

Windows

In the Windows Control Panel, double-click Administrative Tools.
Double-click Services.

Locate Sentinel RMS License Manager in the Services list.
Right-click the service and choose Properties.

Set the Startup type to Automatic.

Click OK.

Other Operating Systems

Add ./Iserv & to one of the operating system startup files.

Uninstalling the License Manager

>

Windows

From the Windows Start menu, choose:
Settings > Control Panel
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Double-click Add/Remove Programs.
Select Sentinel RMS License Manager and then click Remove.

Click Yes when prompted to remove the license manager.

Other Operating Systems
Using the command prompt, browse to the directory to which you installed the license manager.

As root, stop the license manager by typing ./Isrvdown <hostname> at the command prompt,
where <hostname> is the network name of the computer on which the license manager is running.
Then press Enter.

Remove the directory where the license manager isinstalled.

Uninstalling the Concurrent Licensing Tools

>

Windows

From the Windows Start menu, choose:
Settings > Control Panel

Double-click Add/Remove Programs.
Select IBM SPSS Concurrent Licensing Tools and then click Remove.

Click Yes when prompted to remove the concurrent licensing tools.

Other Operating Systems

Remove the directory where the concurrent licensing tools are installed.

Troubleshooting Desktop Computers

If the end users’ desktop computers are having trouble finding the license manager:

Run 1swhere to verify that the desktop computer can find the network computer on which the
license manager is running. For more information, see the topic Running Iswhere on p. 22.

Make sure the license manager service is running on the network computer.

Check the appropriate spssprod.inf file. Thisfile islocated in the product installation directory
on the desktop computer. Open spssprod.inf and make sure DAEMONHOST is set to the correct
name or | P address of the computer on which the license manager is running. If you are using
redundant servers, this should be blank.

If you are using redundant servers, make sure the .sHOST environment variable defines all of them.
Each name is separated by a colon (:) character. For example, if the license manager computers
are SERVER1, SERVERZ, and SERVER3, LsHOST is set to SERVER1:SERVER2:SERVERS.
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Running Iswhere

You can run Iswhere from an end user’s desktop computer to check which computer is running the
network license manager.

» Using acommand prompt, change the current directory to the IBM® SPSS® Amos™ installation
directory.

» Type Iswhere.

Defining Environment Variables on End Users’ Computers

The following instructions are for defining environment variables on end users' computers.

To Define an Environment Variable on Windows 2000/Windows XP/Windows 2003
In the Windows Control Panel, double-click System.

Click the Advanced tab.

Click Environment Variables.

In the System Variables area of the tab, click New.

In the Variable Name text box, type LSHOST.

vV v v v v Vv

In the Variable Vaue text box, type the name or 1P address of the computer on which the license
manager is running—for example, myserver or 204.171.64.2.

» Click OK.

Service and Support

To contact IBM Corp. Technical Support, visit http://www.ibm.com/support and submit a case.
You will need to register with IBM Corp. Technical Support if you haven't done so previously.

IBM Corp. provides public training seminars for IBM Corp. products on aregular basis. You
can also arrange to have training presented onsite. For information on training seminars, visit
http: //Aww.ibm.comvtr ai ning/spss.


http://www.ibm.com/support
http://www.ibm.com/training/spss
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