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Introduction

IBM® Predictive Customer Intelligence gives you the information and insight that
you need to provide proactive service to your customers. The information can help
you to develop a consistent customer contact strategy and improve your
relationship with your customers.

IBM Predictive Customer Intelligence brings together, in a single solution, the
ability to do the following tasks:
v Determine the best offer for a customer.
v Retain customers that are likely to churn.
v Segment your customers, for example, by family status and salary.
v Identify the most appropriate channel to deliver an offer, for example, by email,

telephone call, or application.

This solution ensures that all interactions with customers are coordinated and
optimized. IBM Predictive Customer Intelligence gives you the ability to sift
quickly through millions of customers and know who to contact, when, and with
what action.

The following steps define the process:
1. Understand the customer. Predictive modeling helps you to understand what

market segments each customer falls into, what products they are interested in,
and what offers they are most likely to respond to.

2. Define possible actions and the rules and models that determine which
customers are eligible for which offers.

3. After the best action is identified, deliver the recommendation to the customer.

Audience

This guide is intended to provide users with an understanding of how the IBM
Predictive Customer Intelligence solution works. It is designed to help people who
are planning to implement IBM Predictive Customer Intelligence know what tasks
are involved.

Finding information

To find product documentation on the web, including all translated
documentation, access IBM Knowledge Center (www.ibm.com/support/
knowledgecenter/SSCJHT_1.1.0).

PDF versions of the documents are available from the Predictive Customer
Intelligence version 1.1 product documentation page (www.ibm.com/support/
docview.wss?uid=swg27046802).

Accessibility features

Accessibility features help users who have a physical disability, such as restricted
mobility or limited vision, to use information technology products. Some of the
components included in the IBM Predictive Customer Intelligence have
accessibility features.

© Copyright IBM Corp. 2014, 2015 vii
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IBM Predictive Customer Intelligence HTML documentation has accessibility
features. PDF documents are supplemental and, as such, include no added
accessibility features.

Forward-looking statements

This documentation describes the current functionality of the product. References
to items that are not currently available may be included. No implication of any
future availability should be inferred. Any such references are not a commitment,
promise, or legal obligation to deliver any material, code, or functionality. The
development, release, and timing of features or functionality remain at the sole
discretion of IBM.

Samples disclaimer

Sample files may contain fictional data manually or machine generated, factual
data compiled from academic or public sources, or data used with permission of
the copyright holder, for use as sample data to develop sample applications.
Product names referenced may be the trademarks of their respective owners.
Unauthorized duplication is prohibited.
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What's new?

The following new features are available in IBM Predictive Customer Intelligence
version 1.1.

Solution installer

A new solution installer is available for installations on Red Hat Enterprise
Linux operating systems. The solution installer provides some common
installation configurations for typical IBM Predictive Customer Intelligence
installations. You can also create your own configurations.

For more information, see Chapter 3, “Install on a Red Hat Linux operating
system,” on page 15.

Installations on SUSE Linux operating systems

Support for SUSE Linux is added in this version. To install IBM Predictive
Customer Intelligence on a SUSE Linux operating system, you must install
the components manually.

For more information, see Chapter 4, “Manually install on Microsoft
Windows or Linux operating systems,” on page 35.

Analytic Solution Foundation

You can use the Analytic Solution Foundation to extend the customer
analytics data model that is provided with IBM Predictive Customer
Intelligence or to create orchestrations that define how data flows from an
event to a customer profile.

For more information, see “Configure the Analytic Solution Foundation”
on page 83.

© Copyright IBM Corp. 2014, 2015 ix
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Chapter 1. Prerequisites and installation preparation

Before you install IBM Predictive Customer Intelligence, ensure that the computers
that you use meet the minimum requirements for operating systems, prerequisite
software, processing, and disk space.

On Linux operating systems, you must also install additional prerequisite software
on some computers, including the Business Intelligence (BI) node and the
Integration Bus node computers.

Important: The computers or virtual machines on which you install IBM Predictive
Customer Intelligence nodes using the solution installer, must not have any of the
included software already installed.

Solution architecture
The IBM Predictive Customer Intelligence solution uses several different nodes,
where each node provides a specific function for the solution. Each node represents
a separate computer or a separate virtual machine image from the other nodes. A
typical production environment uses four nodes.

The following diagram shows the nodes in the architecture, with the software
installed on each node.

Figure 1. IBM Predictive Customer Intelligence nodes
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Predictive Analytics node

The Analytics node provides predictive scores and offers recommendations.

This node has the following software installed:
v IBM WebSphere® Application Server Network Deployment
v IBM SPSS® Collaboration and Deployment Services
v IBM SPSS Modeler Server
v IBM SPSS Modeler Collaboration and Deployment Services Adapter
v IBM SPSS Statistics Server
v IBM Analytic Decision Management
v IBM SPSS Data Access Pack
v IBM Data Server Runtime Client

Optionally, you can distribute the Analytics node components onto other
computers in your environment. For example, you can add a node on which only
IBM SPSS Collaboration and Deployment Services is installed.

Optional server components are also available, such as IBM SPSS Analytic Server,
including Analytic Catalyst, and IBM ILOG® CPLEX® Enterprise Server, including
Optimization Studio. For information about installing these products, see their
respective documentation.

If you install IBM SPSS Analytic Server, do not install it on a computer where
another IBM Predictive Customer Intelligence node is installed.

Business Intelligence node

The BI node provides dashboards and reports.

This node has the following software installed:
v IBM WebSphere Application Server Network Deployment (optional for

installations on Microsoft Windows operating systems)
v IBM HTTP Server
v IBM Cognos® Business Intelligence
v IBM Data Server Runtime Client

Optional components are also available, such as IBM Cognos Software
Development Kit. For information about installing these products, see their
respective documentation.

Integration Bus node

The Integration Bus node processes events, updates the content for IBM Cognos
Business Intelligence, and triggers predictive scoring and decision management. It
also loads master data into the solution.

This node has the following software installed:
v IBM MQ (formerly WebSphere MQ)
v IBM Integration Bus
v IBM Data Server Runtime Client

2 IBM Predictive Customer Intelligence Version 1.1.0: IBM Predictive Customer Intelligence Installation Guide



Data node

The data node provides the database server that contains the databases that are
used by other products in the solution.

This node has the following software installed:
v IBM DB2® Enterprise Server Edition

Supported operating systems and hardware requirements
Review the minimum hardware and operating system requirements before you
install IBM Predictive Customer Intelligence. The requirements apply for all
computers or virtual machines that you use for the installation.

For an up-to-date list of environments that are supported by IBM Predictive
Customer Intelligence, see the IBM Software Product Compatibility Reports
(www.ibm.com/support/docview.wss?uid=swg27044319).

Server computers

To use the solution installer, the IBM Predictive Customer Intelligence server
components must be installed on computers that are running a 64-bit Red Hat
Enterprise Linux Server Edition version 6 (x86_64 with update 5, 6, or 7) operating
system.

Alternatively, you can manually install IBM Predictive Customer Intelligence on
64-bit SUSE Linux, Microsoft Windows 2008 Server (x86_64), or Microsoft Windows
2012 Server (x86_64) operating systems.

Important: If you use the solution installer to install on Red Hat Enterprise Linux
operating systems, the operating system for the computer where you run the
solution installer must be set to use English as the language. The solution installer
does not run on other languages. Also, the client computers must also be using
English as the language.

Hardware requirements

If you are using four or five node configuration, each computer or virtual
machine that hosts an IBM Predictive Customer Intelligence server
component, or node, must have the following hardware requirements:
v 2 processors
v 16 GB of RAM
v 60 GB of hard disk space

Each node must be installed on a separate computer or on a separate
virtual machine image.

The computer on which you run the solution installer should have a
minimum of 80 GB of free hard disk space so that you can decompress the
installation files.

If you are installing on a single node, such as for a test or demonstration
environment, the computer must have:
v 4 processors
v 32 GB of RAM
v 250 GB of hard disk space

Chapter 1. Prerequisites and installation preparation 3
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If you are expecting to store large volumes of data, you might need to
increase your disk size.

User requirements

On Linux operating systems, you must have root or sudo access to all of
the computers on which you install an IBM Predictive Customer
Intelligence node, including the computer from which you run the
installation.

On Microsoft Windows operating systems, you must have administrator
access to all of the computers on which you install an IBM Predictive
Customer Intelligence node.

Client computers

The IBM Predictive Customer Intelligence client components must be installed on
computers that run Microsoft Windows 7 or Microsoft Windows 8 operating
systems.

Clients can be installed on 32-bit or 64-bit computers. 64-bit is recommended.

Installing required operating system packages on the BI node
computer

Specific operating system packages must be installed on the Linux operating
system computer or virtual machine where you install the IBM Predictive
Customer Intelligence Business Intelligence node node.

For a complete list of software requirements for IBM Cognos Business Intelligence,
see the Cognos Business Intelligence 10.2.2 Supported Software Environments page
(www.ibm.com/support/docview.wss?uid=swg27042164).

Ensure that the following 32-bit packages are installed. These are the minimum
versions required:
v libselinux-2.0.94-5.3.el6.i686.rpm

v cracklib-2.8.16-4.el6.i686.rpm

v db4-4.7.25-17.el6.i686.rpm

v audit-libs-2.2-2.el6.i686.rpm

v pam-1.1.1-13.el6.i686.rpm

If you are installing the product manually, you must also install the OpenMotif
library to run the installation wizard for IBM Cognos Business Intelligence. For
more information, see Cannot install Cognos BI using issetup on Linux. libXm.so.4
is missing (www.ibm.com/support/docview.wss?uid=swg21612290).

You can download the packages from a site such as pkgs.org or rpm.pbone.net.

Procedure
1. Log on to the BI node computer as the root user or as a user with sudo

permissions.
2. Type the following command to verify that an operating system package is

installed:
rpm -qi package_name
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For example, to verify that libselinux is installed and what version you have,
type rpm -qi libselinux.

Note: You might have to use sudo to run the command successfully.
For example, enter sudo rpm -qi full_package_name.

3. Install any package that is not already installed.
You must download any missing package, and then install the downloaded
package by typing the following command:
rpm -ihv full_package_name.rpm

For example, to install libselinux-2.0.94-5.3.el6.i686, type rpm -ihv
libselinux-2.0.94-5.3.el6.i686.rpm.
To install pam-1.1.1-13.el6.i686.rpm, use the following command: rpm -ihv
-force full_package_name.rpm.

Tip: If you have yum repositories configured for your Linux operating system
computers, you can use the following command to install all of the
pre-requisite RPMs:
yum -y install libselinux.i686 cracklib.i686 db4.i686 audit-libs.i686
pam.i686

If you are installing IBM Cognos Business Intelligence manually, you can install
the OpenMotif with the following command:
yum -y install openmotif.i686

Installing required operating system packages on the
Integration Bus node computer

Specific operating system packages must be installed on the Linux operating
system computer or virtual machine where you install the IBM Predictive
Customer Intelligence Integration Bus node node.

Ensure that the following 32-bit packages are installed. These are the minimum
versions required:
v gtk2-2.24.23-6.el6.i686.rpm

v libXtst-1.0.99.2-3.el6.i686.rpm

v glibc-2.12-1.80.el6.i686.rpm

v libgcc-4.8.3-9.el7.i686.rpm

You can download the packages from a site such as pkgs.org or rpm.pbone.net.

Procedure
1. Log on to the computer as the root user or as a user with sudo permissions.
2. Type the following command to verify that an operating system package is

installed:
rpm -qi package_name

For example, to verify that gtk2 is installed and what version you have, type
rpm -qi gtk2.

Note: You might have to use sudo to run the command successfully.
For example, enter sudo rpm -qi full_package_name.

3. Install any package that is not already installed.
You must download any missing package, and then install the downloaded
package by typing the following command:
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rpm -ihv full_package_name.rpm

For example, to install gtk2-2.24.23-6.el6.i686, type rpm -ihv
gtk2-2.24.23-6.el6.i686.rpm.

Tip: If you have yum repositories configured for your Linux operating system
computers, you can use the following command to install all of the
pre-requisite RPMs:
yum -y install gtk2.i686 libXtst.i686 glibc.i686 libgcc.i686

Setting ulimit values on the node computers
Before you install IBM Predictive Customer Intelligence on Linux operating
systems, you must ensure that you have appropriate ulimit values on each node.

You must perform these steps on the Business Intelligence node, the Predictive
Analytics node, and the Integration Bus node computers.

Note: IBM MQ requires these minimum settings during installation. If they are not
set an error message is displayed during installation.

Procedure

Log in to the computer as the root user or as a user with sudo permissions.
1. Go to the /etc/security directory.
2. Open the limits.conf file for editing.
3. Add the following lines to the file:

@root soft nofile 10240
@root hard nofile 16384
* soft nofile 10240
* hard nofile 16384

4. Save and close the file.
5. Restart the computer for the changes to take effect.

Adding each node computer to the hosts file on all computers
If you are installing on a Red Hat Enterprise Linux operating system by using the
solution installer, you must ensure that each node computer can communicate
properly. You must add all node computers to the hosts file on each node
computer.

For example, the hosts file on the data node computer must include the Predictive
Analytics node, the Business Intelligence (BI) node, and the Integration Bus node
computers.

Procedure
1. On each node computer, open the /etc/hosts file.
2. Ensure that each node computer is listed in the file. For example, ensure that

your hosts files contain entries in the following pattern:
127.0.0.1 localhost.localdomain localhost
##.##.##.## analytics_node_name.domain.com analytics_node_name
##.##.##.## bi_node_name.domain.com bi_node_name
##.##.##.## data_node_name.domain.com data_node_name
##.##.##.## integrationbus_node_name.domain.com integrationbus_node_name

3. Save and close the file.
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Modifying the sudoers file for the user who runs the installation
To install IBM Predictive Customer Intelligence on a Red Hat Enterprise Linux
operating system by using the solution installer, you must be either the root user
or be a user with sudo permissions on each node computer. To run the installation
as a user with sudo permissions, you must add that user to the sudoers file on
each node computer.

Procedure
1. Log in as root user.
2. Open the sudoers file for editing. For example, enter visudo -f /etc/sudoers.
3. Add the following line for your user:

username ALL=(ALL) ALL

4. Save and close the file.
5. Repeat these steps on each computer on which you install an IBM Predictive

Customer Intelligence node.

Synchronizing the time on each Linux node computer
If you are installing on a Red Hat Enterprise Linux operating system by using the
solution installer, you must ensure that each node computer is synchronized to the
same time.

For more information, see the Red Hat documentation (https://access.redhat.com/
documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/
sect-Date_and_Time_Configuration-Command_Line_Configuration-
Network_Time_Protocol.html).
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Chapter 2. Migrating from IBM Predictive Customer
Intelligence Version 1.0.1 to Version 1.1

There are two supported migration paths on Windows: in-place migration, and
parallel migration.

If your environment supports the bundled software included in IBM Predictive
Customer Intelligence Version 1.1, you can perform an in-place migration and
reuse the existing servers. Otherwise, perform a parallel migration where the
bundled software is installed on different servers and migrate the content
separately.

In-place migration path
If your environment supports the bundled software included in IBM Predictive
Customer Intelligence Version 1.1, you can perform an in-place migration and
reuse the existing servers.

Before you begin

It is important to complete the following migration tasks in the order in which
they are shown to ensure a seamless migration:
1. Common components across nodes
2. Data node
3. Predictive analytics node
4. Business intelligence node
5. Integration bus node

Common components across nodes
All nodes have the same migration path for common components. You must
upgrade the common components before upgrading the individual nodes.

About this task

The two common components across nodes are the IBM DB2 Runtime Client and
IBM Installation Manager.

Procedure
1. Upgrading an existing Runtime Client copy to DB2 Version 10.5 requires that

you install a DB2 Version 10.5 Data Server Runtime Client copy and then
upgrade your client instance. For more information, see Upgrade to DB2
Version 10.5.
a. Create a configuration profile containing only database- and node-relation

information using the db2cfexp command. For instance, db2cfexp
<filename> MAINTAIN.

b. Follow the instructions as you would for a new installation of IBM DB2
Server Runtime Client. See “Installing IBM DB2 client software on the
Analytics node computer” on page 38.
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c. On the DB2 Setup - IBM Data Server Runtime Client - DB2COPY2
window, accept the new copy name, and set this as the default DB2 copy on
this machine. Click Next.

d. Upgrading the DB2 instance. Click Start > All Programs > IBM DB2
DB2COPY2 (Default) > Command Window - Administratorand use the
db2iupgrade command to upgrade the DB2 instance: %DB2PATH%\bin\
db2iupgrade <InstName> /u:<user>,<password>. DB2PATH is the location that
you specified during the DB2 Version 10.5 Data Server Runtime Client
installation and InstName is the name of the instance. For instance,
db2iupgrade DB2 /u:db2admin,password.

e. Import the configuration profile. Click Start > All Programs > IBM DB2
DB2COPY2 (Default) > Command Window - Administrator and use the
db2cfimp command to migrate the connectivity configuration:
%DB2PATH%\bin\db2cfimp <filename>. DB2PATH is the location that you
specified during the DB2 Version 10.5 Data Server Runtime Client
installation and filename is the configuration profile file name.

2. Installing IBM Installation Manager. Upgrading replaces the only installation of
Installation Manager on a server with the latest release. Follow the instructions
as you would for a new installation of IBM Installation Manager. See “Installing
IBM Installation Manager on the Predictive Analytics node computer” on page
38.

Data node
The Data node computer typically consists of a DB2 Enterprise Server.

Before you begin

Back up existing databases on the Data node computer, including the SPSS
repository, content store, and user databases. For more information, see Backup
database command, DB2 Version 10.1 for Linux, UNIX, and Windows.

Procedure
1. Stop the DB2 instance.

a. Log on to the Data node computer as a DB2 administrator, db2admin.
b. Stop the WebSphere Application Server running the SPSS components on

the Predictive Analytics node computer. Click Start > All Programs > IBM
WebSphere > IBM WebSphere Application Server V8.5 > Profiles >
AppSrv01 > Stop the server.

c. Stop the Cognos service on the Business Intelligence node computer. Click
Start > All Programs > IBM Cognos 10 - 64 > IBM Cognos Configuration
> Stop. .

d. Run db2stop to stop the DB2 instance.
2. Installing the DB2 Enterprise Server.

Upgrading your DB2 server requires that you install a DB2 Version 10.5 copy
and then upgrade all the instances and databases to be able to run them under
the DB2 Version 10.5 copy. For more information, see Upgrade to DB2 Version
10.5.
a. Follow the instructions as you would for a new installation of IBM DB2

Enterprise Server “Installing IBM DB2 Enterprise Server” on page 36
b. In the Install a Product window, click Work with Existing under DB2

Version 10.5 Fix Pack 5 Workgroup, Enterprise and Advanced Editions.
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c. In the Work with an Existing DB2 Copy window, select DB2COPY1
(default). Click Launch DB2 Setup wizard.

3. Adding the DB2 License. Follow the instructions described in “Adding the IBM
DB2 license” on page 36

4. Upgrading the DB2 databases. The DB2 instance is automatically upgraded.
The databases must be upgraded manually before they can be used:
a. Click Start > All Programs > IBM DB2 DB2COPY1 (default) > Command

Window - Administrator and run db2 UPGRADE DATABASE <database> USER
db2admin USING <password>. Repeat for each local database.

Predictive analytics node
The Predictive Analytics Node computer typically consists of SPSS server products,
a WebSphere Application Sever, and a DB2 Server Runtime Client.

Before you begin

Backup your existing SPSS repository database. For more information, see Backup
database command, DB2 Version 10.1 for Linux, UNIX, and Windows.

Follow the instructions as you would for a new installation to update the
WebSphere Application Server to WebSphere Application Server Version 8.5.5.6
“Upgrading WebSphere Application Server” on page 39.

Procedure
1. Manually create a profile in the WebSphere Application server.

a. Click Start > All Programs > IBM WebSphere > IBM WebSphere
Application Server V8.5 > Tools > Profile Management Tool.

b. On the WebSphere Customization Toolbox 8.5 window, click Create.
c. On the Environment Selection window, select Application server, and click

Next.
d. On the Profile Creation Options window, select Typical profile creation,

and click Next.
e. Enter the administrator credentials on the Administrative Security window,

and click Next.
f. Note the HTTP transport port on the Profile Creation Summary window,

and click Create.
g. Deselect Launch the First steps console check box on the Profile Creation

Complete window, and click Finish.
2. Installing IBM SPSS Collaboration and Deployment Services Server. Upgrading

SPSS Collaboration and Deployment Services Server requires that you install
IBM SPSS Collaboration and Deployment Services 7.0 in a different location
than the original installation. For more information, see IBM SPSS Collaboration
and Deployment Services Repository Migration.
a. Follow the instructions as you would for a new installation of IBM SPSS

Collaboration and Deployment Services Server “Installing IBM SPSS
Collaboration and Deployment Services Modeler adapters” on page 43.

b. In the Application Server window, click Browse to select the root directory
of the profile you created earlier.

c. In the Existing data window, select Preserve existing data and click Next.
Follow the remaining steps in the wizard.

Chapter 2. Migrating from IBM Predictive Customer Intelligence Version 1.0.1 to Version 1.1 11

http://www-01.ibm.com/support/knowledgecenter/SSEPGG_10.1.0/com.ibm.db2.luw.admin.cmd.doc/doc/r0001933.html?cp=SSEPGG_10.1.0%2F3-6-2-4-8
http://www-01.ibm.com/support/knowledgecenter/SSEPGG_10.1.0/com.ibm.db2.luw.admin.cmd.doc/doc/r0001933.html?cp=SSEPGG_10.1.0%2F3-6-2-4-8
http://www-01.ibm.com/support/knowledgecenter/SS69YH_7.0.0/cads_config_ddita/model_management/thin/repository_migration.dita
http://www-01.ibm.com/support/knowledgecenter/SS69YH_7.0.0/cads_config_ddita/model_management/thin/repository_migration.dita


3. Follow the instructions as you would for a new installation to install the
adapters and packages.

Business intelligence node
The Business Intelligence Node computer typically consists of a WebSphere
Application Server Network Deployment, an HTTP Server, and IBM Cognos
Business Intelligence and an IBM DB2 Runtime Client.

Before you begin

Follow the instructions as you would for a new installation to update IBM HTTP
Server to Version 8.5.5.6 “Upgrading IBM HTTP Server on the BI node computer”
on page 50.

Procedure
1. Follow the instructions as you would for a new installation of IBM Cognos

Business Intelligence Server and IBM Cognos Business Intelligence Server
Updater. See “Installing IBM Cognos Business Intelligence” on page 51.

2. On the Installation Location window, install the product into a different
installation directory. For instance, Files\ibm\cognos\c1022_64, and select
Production for the Server Use Type. Click Next.

3. On the Shortcut Folder window, change the Program folder to IBM Cognos
10.2.2 - 64 and click Next.

4. Configuring the IBM Cognos Business Intelligence Server.
a. Export the IBM Cognos configuration from the original Cognos Business

Intelligence installation and save it as cogstartup.xml.
b. Copy the cogstartup.xml file to /configuration folder in the Cognos

Business Intelligence 10.2.2 installation root folder.
c. Click Start > All Program Files > IBM Cognos 10.2.2 - 64 > IBM Cognos

Configuration.
d. Change the port number and service name.

5. Update the http.conf file to use the Cognos Business Intelligence 10.2.2
installation. For instance:
ScriptAlias /ibmcognos/cgi-bin/ "C:/Program Files/IBM/cognos/c1022_64/cgi-bin/"
<Directory "C:/Program Files/IBM/cognos/c1022_64/cgi-bin/">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

Alias /ibmcognos/ "C:/Program Files/IBM/cognos/c1022_64/webcontent/"
<Directory "C:/Program Files/IBM/cognos/c1022_64/webcontent/">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

6. Stop the original IBM Cognos service.

Integration bus node
The Integration Bus node computer typically consists of IBM WebSphere MQ, IBM
Integration Bus, and the IBM DB2 Server Runtime Client.
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Before you begin
1. Back up your application code.
2. Stop local WebSphere MQ applications.
3. Stop all the queue managers and listeners. Click Start > All Programs > IBM

Integration Console 9.0.0.1 > IBM Integration Console 9.0.0.1 and run
mqsistop -q <broker>.

About this task

Procedure
1. Installing IBM WebSphere MQ. Upgrading (single-stage) replaces the only

installation of WebSphere MQ on a server with the latest release. For further
information, see Migrating and Updating WebSphere MQ 8.0.0.

2. Follow the instructions as you would for a new installation of IBM DB2
Enterprise Server “Installing IBM DB2 Enterprise Server” on page 36.
a. On the WebSphere MQ Setup window, select Upgrade 7.5.0.2 Installation

'Installation1' and click Next.
b. On the WebSphere MQ V8.0.0.2 Setup window, select Update and click

Next.
3. Run the strmqm command to start the queue managers and migrate them to the

latest version of the product.
4. Upgrading the Integration Bus requires installing IBM Integration Bus Version

10.0 on the same computer as the current version and then upgrading your
integration node. For more information, see Migrating IBM Integration Bus
a. Stop the integration node by using the mqsistop command.
b. Follow the instructions as you would for a new installation of IBM

Integration Bus. “Installing IBM Integration Bus” on page 58.
c. Run the mqsimigratecomponents command to migrate the integration node.

For instance, mqsimigratecomponents <component>.
d. Copy all additional custom environment settings from your original

environment into your Version 10.0 environment from the
MQSI_FILENODES_ROOT_DIRECTORY.

e. Start the integration node by using the mqsistart command.

Parallel migration path
Perform a parallel migration if your environment does not support the bundled
software included in IBM Predictive Customer Intelligence Version 1.1.

Important: This is the only supported migration path when using the solution
installer on Linux RedHat.

A parallel migration path requires that you install and configure IBM Predictive
Customer Intelligence Version 1.1. The content must be migrated separately to the
different node computers.
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Chapter 3. Install on a Red Hat Linux operating system

Use the solution installer to deploy the IBM Predictive Customer Intelligence
component programs on computers or virtual machines that are running Red Hat
Enterprise Linux operating systems.

Important: If you are installing IBM Predictive Customer Intelligence from the
USB hard disk drive, download and use the Solution Installer 1.1 Linux Red Hat
English component from IBM Passport Advantage® to ensure that you are using
the latest version of the installer. For more information about downloading
components, see Downloading IBM Predictive Customer Intelligence 1.1
(http://www.ibm.com/support/docview.wss?uid=swg24040382).

The solution installer runs on a Red Hat Enterprise Linux operating system. It
provides a web interface that you use to define, validate, and install your
environment.

You define your environment by identifying node computers, and dragging the
component programs onto the nodes. The solution installer provides guidance for
where you can add components and you can use it to validate the environment
that you define.

If you want to deploy the IBM Predictive Customer Intelligence component
programs on SUSE Linux or Microsoft Windows operating systems, you must use
a manual installation. For more information, see Chapter 4, “Manually install on
Microsoft Windows or Linux operating systems,” on page 35.

Note: If you want to customize the installation of certain components, such as
distributing IBM Cognos Business Intelligence on different computers, you can use
the manual installation instructions. For more information, see the installation
documentation for the component.

Also, if you want to configure multiple nodes of IBM SPSS Collaboration and
Deployment Services, you must use a manual installation of IBM Predictive
Customer Intelligence. The solution installer allows only one instance of IBM SPSS
Collaboration and Deployment Services in a configuration.

For more information about manually installing IBM Predictive Customer
Intelligence, see Chapter 4, “Manually install on Microsoft Windows or Linux
operating systems,” on page 35.

Important: If you use the solution installer to install on Red Hat Enterprise Linux
operating systems, the operating system for the computer where you run the
solution installer must be set to use English as the language. The solution installer
does not run on other languages. Also, the client computers must also be using
English as the language.

Downloading and decompressing the installation files
You must download the IBM Predictive Customer Intelligence solution from IBM
Passport Advantage, and then decompress the files to run the solution installer.
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For more information about the files that you must download, see Downloading
IBM Predictive Customer Intelligence 1.1 (http://www.ibm.com/support/
docview.wss?uid=swg24040382).

Procedure
1. Access the IBM Passport Advantage web site.

Tip: If you receive an error, try using a different web browser to access
Passport Advantage.

2. Sign in and navigate to the software downloads page.
3. Find the eImages for IBM Predictive Customer Intelligence.
4. Download an eImage by selecting the check box beside the name. When the

download is complete, a Download Complete message is displayed. The
location of the downloaded files are displayed in the message window.

5. Decompress the eImage files.
6. Decompress the prd_cust_intel_sol_install_1.1_l86_en.tar.gz file.

The file is decompressed to a directory that is named PCI_1.1_linux. You must
copy the server tar.gz files into the PCI_1.1_linux directory.

7. Copy the 3 other tar.gz files to the PCI_1.1_linux/SolutionInstaller/
NodeRoot/Downloads/Software directory.
The 3 tar.gz files that you need are named
prd_cust_intel_svr_1.1_1_l86_en.tar.gz,
prd_cust_intel_svr_1.1_2_l86_en.tar.gz, and
prd_cust_intel_svr_1.1_3_l86_en.tar.gz.

8. You can manually decompress the files, or run the
PCI1.1_UncompressTarball.sh script to decompress the files.
To run the script, enter sh PCI1.1_UncompressTarball.sh.
To manually decompress the files, enter tar xvf filesname.tar.gz.

Opening firewall ports for the solution installer
You can run the firewall.sh script to open the ports that are required on the
computer on which you are running the IBM Predictive Customer Intelligence
solution installer.

You must also open ports on the target, or client, computers on which you are
installing a IBM Predictive Customer Intelligence node. You can use the
client_firewall.sh script to open the required ports.

The firewall.sh script opens the following ports on the solution installer
computer:
v 8080 incoming
v 443 incoming
v 9683 incoming
v 22 outgoing

On the target, or client computers, the client_firewall.sh script opens the
following ports:
v 8080 outgoing
v 443 incoming
v 9683 outgoing
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v 22 incoming

Procedure
1. Log on to the computer that contains the solution installer node as the root

user or as a user with sudo permissions.
2. Back up your existing firewall settings by typing the following command:

/etc/init.d/iptables save.
3. Go to the directory where you decompressed the solution installer files, and

run the firewall script by typing the following command: sh firewall.sh. For
example, go to the PCI_1.1_linux/SolutionInstaller directory.

4. Copy the client_firewall.sh file onto each computer on which you are going
to install an IBM Predictive Customer Intelligence node.

5. Log on to each computer on which you are going to install an IBM Predictive
Customer Intelligence node as the root user or as a user with sudo permissions.

6. Back up your existing firewall settings by typing the following command:
/etc/init.d/iptables save.

7. Go to the directory where you copied the client_firewall.sh file, and run the
script by typing the following command: sh client_firewall.sh.

Starting the solution installer
You run the IBM Predictive Customer Intelligence solution installer on a Red Hat
Enterprise Linux operating system. Use the solution installer to define the
environment you want to install. After the solution installer is running, you can
access the installer interface from another computer by using a web browser and
start defining the environment.

Note: Ensure that you copy the solution installer files to a directory in which you
have permissions to execute files.

Important: Ensure that the operating system on which you run the solution
installer is set to use English as the language. The solution installer does not run
on other languages. Also, the client computers must also be using English as the
language.

Procedure
1. Log on to the computer where you decompressed the installation files as the

root user or as a user with sudo permissions.
2. Go to the SolutionInstaller directory where you decompressed the solution

installer files.
3. Enter the following command: sh setup.sh.

After the solution installer starts, open a web browser on another computer,
and go to the solution installer URL: https://servername:8080/UI/index.html.

Important: Do not use a web browser on the computer on which you are
running the solution installer or any computer on which a IBM Predictive
Customer Intelligence component is being installed. You must use a web
browser on another computer.
The computer on which you are using the browser to access the solution
installer must have a screen resolution that is greater than 1024 by 760.
The solution installer runs on Google Chrome 44, or later, or Mozilla Firefox 38
or later, web browsers. It does not run on Internet Explorer.
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Ensure that you are using an English language web browser to access the
solution installer URL.

Using the solution installer
You use the solution installer to define your IBM Predictive Customer Intelligence
environment you want to install.

You define the environment by identifying node computers and adding the
software that you want installed on each node. You create an installation
configuration for your solution by dragging nodes onto a canvas and then
dragging components into the nodes.

You can save your configurations. For more information, see “Saving and opening
configurations” on page 24.

You can also load predefined configurations. For more information, see “Using
predefined configurations” on page 24.

Note: You cannot install more than one instance of IBM SPSS Collaboration and
Deployment Services by using the solution installer. If you want to install multiple
IBM SPSS Collaboration and Deployment Services instances, you must install them
manually. For more information, see Chapter 4, “Manually install on Microsoft
Windows or Linux operating systems,” on page 35.

Important: The solution installer runs on Google Chrome 44 or later or Mozilla
Firefox 38 or later. It does not run on Internet Explorer.

For more information about supported software, see the IBM Software Product
Compatibility Reports (www.ibm.com/support/docview.wss?uid=swg27044319).

Procedure
1. Open the solution installer in a web browser.

After the solution installer is running, you can access the URL from any
computer from a Firefox or Chrome web browser.
The URL is https://servername:8080/UI/index.html, where servername is the
name of the computer where you ran the solution installer.

Important: Do not use a web browser on the computer on which you are
running the solution installer or any computer on which a IBM Predictive
Customer Intelligence component is being installed. You must use a web
browser on another computer.
Ensure that you are using an English language web browser to access the
solution installer URL.

2. On the license information page, click Accept.
CAUTION:
Declining the license allows you to uninstall the solution installer and
remove all of the files from the solution installer directory.

3. Select New Configuration, and click OK.
4. From the Mandatory Software List pane, drag a Node object onto the

Configuration Editor pane.
A visual representation of an empty node is displayed.
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If you are installing IBM Predictive Customer Intelligence on four nodes, you
must drag four Node objects onto the Configuration Editor pane.

5. In the Property Editor pane, select the node object, and enter the following
information.
a. Enter a name for the node in Name. For example, enter BI node.
b. Enter the server name in Host Name.

Important: Unless you are using a single node configuration, ensure that
the host names or IP addresses are for different computers. Do not use the
same computer for more than one Node object.

c. Enter the user who has access to install the components in User Name. For
example, enter root or a user with sudo permissions.

d. Enter the user's password in User Password.
e. Repeat these steps for each node object that you add. For example, if you

are installing IBM Predictive Customer Intelligence on four nodes, you
must repeat these steps for each of the four node objects.

Important: You must enter any mandatory information for nodes and other
objects as indicated. Ensure that you review all of the properties to ensure that
the values, both mandatory and optional, are valid.

6. From the Mandatory Software List pane, create your environment by
dragging each object onto the appropriate node in the Configuration Editor
pane.

Tip: Valid drop zones are indicated in the Configuration Editor pane.
Some restrictions are built into the placement of the objects. For example, if
you are adding IBM Cognos BI Server to a node, then you must already have
WebSphere Application Server on that node, and the IBM Cognos BI Server
object must be placed within the WebSphere Application Server object.

Tip: Example environments are provided in the predefined configurations that
are included with the installation files. For more information, see “Using
predefined configurations” on page 24.

Chapter 3. Install on a Red Hat Linux operating system 19



Note: If you add the IBM DB2 Data Server Runtime Client component to
the same node as the IBM DB2 Enterprise Server component, the IBM DB2
Data Server Runtime Client component will not be installed.

7. After you add an object, select it, and modify any values in the Property
Editor pane.
For example, when you add WebSphere Application Server to a node, you
must provide the following information:
v WebSphere Install Directory is the location where WebSphere Application

Server is to be installed.
v WebSphere Application Port is the port number that you want to use for

WebSphere Application Server.
v WAS Profile Admin User Name is the administrator user's user name for

WebSphere Application Server.
v WAS Profile Admin Password is the password for the administrator user.

8. From the Optional Software List, drag the objects to the node on which you
want the installation files copied. The optional software is not installed by the
solution installer. You must install the software manually. The installation files
are copied to the node you drag them to.
The optional software installation files are copied to the /opt/IBM/OptSoftware
directory on the node computer, unless you change the default path.

9. As you build your environment, click Validate to identify errors or incomplete
information.

10. After all nodes are defined and each node is validated, click Run.

Important: If you click Validate before all the mandatory content is added, a
message indicates that the node is not valid. For example, if you validate the
BI Node before you add the IBM DB2 Data Server Runtime Client
component, then a message indicates that the node is not yet valid.

Configuration properties for the solution installer
You must provide some configuration properties for each of the mandatory
software components.
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If you select any components from the Optional Software List, you must provide
a deployment location for the installation files. You must manually install any item
that you select from the Optional Software List.

IBM DB2 Enterprise Server properties

DB2 Server Install Directory
The location where IBM DB2 is to be installed on the data node computer.

Default: /opt/ibm/db2/V10.5

DB2 Database Port Number
The port number that is used by IBM DB2.

Default: 50000

DB2 Server Admin User Name
The user ID that runs the administration server.

Default: dasusr1

This user must not exist on the computer.

DB2 Server Admin Password
The password for the user ID that runs the administration server.

The password cannot contain more than 8 characters and it must be
lowercase.

DB2 Server Admin Home Directory
The home directory for the user ID that runs the administration server.
This directory is on the data node computer's file system.

Default: /home/dasusr1

DB2 Instance Owner User Name
The user ID that controls the DB2 processes and owns the directories that
are used by the database instance.

Default: db2inst1

This user must not exist on the computer.

DB2 Instance Owner Password
The password for the DB2 instance owner user.

The password cannot contain more than 8 characters and it must be
lowercase.

DB2 Instance Owner Home Directory
The home directory for the DB2 instance owner user. This directory is on
the data node computer's file system.

Default: /home/db2inst1

DB2 Fenced User Name
The user ID that can run user-defined functions and store procedures.

Default: db2fenc1

This user must not exist on the computer.

DB2 Fenced User Password
The password for the DB2 fenced user.

The password cannot contain more than 8 characters and it must be
lowercase.
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DB2 Fenced User Home Directory
The home directory for the DB2 fenced user.

Default: /home/db2fenc1

Database: SPSS properties

SPSS Database Name
The SPSS database that is used by the components that are installed on the
Predictive Analytics node computer.

This component must be contained within IBM DB2 Enterprise Server.

Default: SPSSDB

Database: BI Content Manager properties

Content Manager Database Name
The IBM Cognos content store database.

This component must be contained within IBM DB2 Enterprise Server.

Default: COG102CS

IBM DB2 Data Server Runtime Client properties

The IBM DB2 Data Server Runtime Client component must be installed on each
node, except for the data node computer.

Note: If you add the IBM DB2 Data Server Runtime Client component to the
same node as the IBM DB2 Enterprise Server component, the IBM DB2 Data
Server Runtime Client component will not be installed.

DB2 RTC Install Directory
The location where the IBM DB2 client is to be installed.

Default: /opt/ibm/db2/V10.5

DB2 RTC Instance User Name
The user ID for the DB2 client.

Default: db2inst1

This user must not exist on the computer.

DB2 RTC Instance Password
The password for the DB2 client instance owner user.

DB2 Client Instance Home Directory
The home directory for the DB2 client instance owner user.

Default: /home/db2inst1

WebSphere Application Server properties

WebSphere Application Server must be installed on the nodes where you install
IBM Cognos Business Intelligence and IBM SPSS Collaboration and Deployment
Services Server.

WebSphere Install Directory
The location where the WebSphere Application Server is to be installed.

Default: /opt/IBM/WebSphere/AppServer
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WebSphere Application Port
The HTTP port number that is used by the WebSphere Application Server
profile.

Default: 9080

WAS Profile Admin User Name
The administrative user name for the WebSphere Application Server
profile.

WAS Profile Admin Password
The password for the administrative user.

IBM HTTP Server properties

IBM HTTP Server must be installed on the computer where you install IBM
Cognos Business Intelligence.

HTTP Server Install Directory
The location where IBM HTTP Server is to be installed.

Default: /opt/IBM/HTTPServer

HTTP Server Port Number 
The port number that is used by HTTP Server.

Default: 81

IBM Cognos BI Server

IBM Congos BI Server must be contained within WebSphere Application Server
in the Configuration Editor.

IBM Cognos BI Server Install Directory
The location where IBM Cognos BI is to be installed.

Default: /opt/ibm/cognos/c10_64

IBM SPSS Modeler Server properties

SPSS Modeler Server Install Directory
The location where IBM SPSS Modeler Server is to be installed.

Default: /opt/IBM/SPSS/ModelerServer/17.0

IBM SPSS Statistics Server properties

SPSS Statistics Server Install Directory
The location where IBM SPSS Statistics Server is to be installed.

Default: /opt/IBM/SPSS/StatisticsServer23

IBM SPSS Data Access Pack properties

SPSS Data Access Pack Install Directory
The location where IBM SPSS Data Access Pack is to be installed.

Default: /root/SDAP711

IBM SPSS C&DS Server (including ADM) properties

IBM SPSS C&DS Server (including ADM) must be contained within WebSphere
Application Server in the Configuration Editor.
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SPSS C&DS Server Install Directory
The location where IBM SPSS Collaboration and Deployment Services
Server and Analytic Decision Management are to be installed.

Default: /opt/IBM/SPSS/Deployment/7.0/Server

SPSS C&DS Server Admin User Name
The IBM SPSS Collaboration and Deployment Services administrative user.

Default: admin

SPSS C&DS Server Admin Password
The password for the IBM SPSS Collaboration and Deployment Services
administrative user.

Default: admin

WebSphere MQ properties

WebSphere MQ Home Directory
The WebSphere MQ home directory.

Default: /home

WebSphere MQ Account User Name
The WebSphere MQ user.

Default: mqmuser

WebSphere MQ Account Password
The WebSphere MQ user account password.

IBM Integration Bus properties

IBM Integration Bus must be contained within WebSphere MQ in the
Configuration Editor.

Integration Bus Install Directory
The location where IBM Integration Bus is to be installed.

Default: /opt/IBM

Saving and opening configurations
You can save IBM Predictive Customer Intelligence configurations and open
existing configurations in the solution installer.

Procedure
1. To save a configuration:

a. In the solution installer, define your configuration.
b. Enter a name in the Save Configuration box, and click the Save

Configuration icon .
2. To open a saved configuration:

a. Click Open, and browse to the saved configuration file, and click Open.

Using predefined configurations
You can use predefined configurations to help you define your IBM Predictive
Customer Intelligence environment. Predefined configurations are provided for
common IBM Predictive Customer Intelligence environments.
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Procedure
1. Open the solution installer in a web browser.

After the solution installer is running, you can access the URL from any
computer from a Firefox or Chrome web browser.
The URL is https://servername:8080/UI/index.html, where servername is the
name of the computer where you ran the solution installer.

Important: Do not use a web browser on the computer on which you are
running the solution installer or any computer on which a IBM Predictive
Customer Intelligence component is being installed. You must use a web
browser on another computer.
Ensure that you are using an English language web browser to access the
solution installer URL.

2. Select Predefined Configurations, and click OK.
3. Select the configuration that you want to install, and click OK.
v A PCI 4 Node Configuration provides a typical IBM Predictive Customer

Intelligence environment on four nodes: a data node, a Business Intelligence
node, an Analytics node, and an Integration Bus node.

v A PCI Distributed CDS Node Configuration provides an environment on
five nodes, where IBM SPSS Collaboration and Deployment Services is
installed on its own node rather than on the Analytics node computer as in
the PCI 4 Node Configuration.

v A PCI Single Node Configuration provides an environment where all of the
components are installed on a single computer.

Note: A single-node configuration is intended for a demonstration or testing
environment. It should not be used for a production environment.

The configuration is displayed in the Configuration Editor pane.
Icons appear on each component where configuration information is required.
For example, where you must provide user names or passwords.

Important: Ensure that you change the server names to an actual server in
your environment. Default values are provided.

4. Ensure all of the properties are valid for your environment for each of the
components and the nodes in the configuration.
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Starting the installation
The IBM Predictive Customer Intelligence solution installer installs the component
products on each node computer. Before you start the installation, you can validate
the configuration.

Procedure
1. In the solution installer, open the configuration that you want to install.
2. Click Validate.

Any errors or missing information is displayed. You must correct the error or
provide the information before you can run the installation.

3. Click Run.

Computer firewall settings for the server components after installation
Each IBM Predictive Customer Intelligence node that is installed on a Linux
operating system requires certain ports to be opened for the server components to
operate in a multi-computer solution. You must configure your firewall settings for
each specific node.

Opening the firewall ports for a single node configuration
If you installed IBM Predictive Customer Intelligence on a single node, you must
open ports for all of the components.

The following ports must be open:
v 45088
v 58313
v 28054
v tungsten-https
v glrpc
v corbaloc
v 59356
v 9043
v 9044
v 9060
v 9061
v 9080
v 9081
v 9362
v vrace
v 9663
v http
v 81 (if you used the default port number for HTTP Server in the solution

installer)
v boks
v boks_clntd
v boks_servm
v boks_servc
v ibm-mqseries
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v ibm-db2
v db2c_db2inst1

For more information about IBM SPSS Modeler port numbers, see the How many
ports are utilized when a Modeler Client connects to Modeler Server? document
(www.ibm.com/support/docview.wss?uid=swg21488421).

Procedure
1. Log in to the Analytics node computer as the root user or as a user with sudo

permissions.
2. Back up your existing firewall settings by typing the following command:

/etc/init.d/iptables save

3. Add rules for the ports with the following commands:
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 45088 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 58313 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 28054 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport tungsten-https -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport glrpc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport corbaloc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 59356 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9043 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9044 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9060 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9061 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9080 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9081 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9362 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport vrace -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9663 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport http -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 81 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks_clntd -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks_servm -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks_servc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport ibm-mqseries -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport ibm-db2 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport db2c_db2inst1 -j ACCEPT

4. Type the following command to save your firewall settings:
/etc/init.d/iptables save

5. Type the following command to restart your firewall.
/etc/init.d/iptables restart

6. Verify that your changes have been applied with the following command:
iptables -L

The added ports should appear in the list.

Configuring your firewall settings for the Analytics node
computer

You must ensure that certain ports are open on the Predictive Analytics node
computer for IBM Predictive Customer Intelligence.

The following ports must be open:
v 45088
v 58313
v 28054
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v tungsten-https
v glrpc
v corbaloc
v 59356
v 9043
v 9060
v 9080

For more information about IBM SPSS Modeler port numbers, see the How many
ports are utilized when a Modeler Client connects to Modeler Server? document
(www.ibm.com/support/docview.wss?uid=swg21488421).

Procedure
1. Log in to the Analytics node computer as the root user or as a user with sudo

permissions.
2. Back up your existing firewall settings. For example, /etc/init.d/iptables

save.
3. Add rules for the ports with the following commands:

iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 45088 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 58313 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 28054 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport tungsten-https -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport glrpc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport corbaloc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 59356 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9043 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9060 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9080 -j ACCEPT

4. Save your firewall settings. For example, /etc/init.d/iptables save.
5. Restart your firewall. For example, /etc/init.d/iptables restart
6. Verify that your changes have been applied with the following command:

iptables -L.
The added ports should appear in the list.

Configuring your firewall settings for the BI node computer
You must ensure that certain ports are open on the Business Intelligence (BI) node
computer for IBM Predictive Customer Intelligence.

The following ports must be open:
v 9362
v vrace
v 9663
v corbaloc
v 9043
v glrpc
v http
v tungsten-https
v 9060
v 9080
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Procedure
1. Log in to the BI node computer as the root user or as a user with sudo

permissions.
2. Back up your existing firewall settings. For example, /etc/init.d/iptables

save.
3. Add rules for the ports with the following commands:

iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9362 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport vrace -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9663 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport corbaloc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9043 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport glrpc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport http -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport tungsten-https -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9060 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9080 -j ACCEPT

4. Save your firewall settings. For example, /etc/init.d/iptables save.
5. Restart your firewall. For example, /etc/init.d/iptables restart
6. Verify that your changes have been applied with the following command:

iptables -L.
The added ports should appear in the list.

Configuring your firewall settings for the Integration Bus node
computer

You must ensure that certain ports are open on the Integration Bus node computer
for IBM Predictive Customer Intelligence.

The following ports must be open:
v boks
v boks_clntd
v boks_servm
v boks_servc
v ibm-mqseries

Procedure
1. Log in to the Integration Bus node computer as the root user or as a user with

sudo permissions.
2. Back up your existing firewall settings. For example, /etc/init.d/iptables

save.
3. Add rules for the ports with the following commands:

iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks_clntd -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks_servm -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks_servc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport ibm-mqseries -j ACCEPT

4. Save your firewall settings. For example, /etc/init.d/iptables save.
5. Restart your firewall. For example, /etc/init.d/iptables restart
6. Verify that your changes have been applied with the following command:

iptables -L.
The added ports should appear in the list.
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Configuring your firewall settings for the data node computer
You must ensure that certain ports are open on the data node computer for IBM
Predictive Customer Intelligence.

The following ports must be open:
v ibm-db2
v db2c_db2inst1
v 50001

Procedure
1. Log in to the data node computer as the root user or as a user with sudo

permissions.
2. Back up your existing firewall settings. For example, /etc/init.d/iptables

save.
3. Add rules for the ports with the following commands:

iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport ibm-db2 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport db2c_db2inst1 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 50001 -j ACCEPT

4. Save your firewall settings. For example, /etc/init.d/iptables save.
5. Restart your firewall. For example, /etc/init.d/iptables restart
6. Verify that your changes have been applied with the following command:

iptables -L.
The added ports should appear in the list.

Configure the server components and test the installation
After the installation of the IBM Predictive Customer Intelligence server
components is complete, you must perform some additional configuration tasks
and then test the installation.

Testing the database installation and configuration
You can test the database installation and configuration by logging in to the IBM
Predictive Customer Intelligence data node computer and listing the databases on
the server. You can also list the databases available on each node computer where
the IBM DB2 client was installed.

Procedure

Log on to the data node computer.
1. Open a terminal window, and change to the database instance owner user. For

example, su - db2inst1.
2. Enter the following command to list the databases on the computer:

db2 list database directory

For an installation on a Red Hat Linux operating systems that used the solution
installer, the following databases are listed:
v COG102DB

v SPSSDB
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Configuring IBM Cognos BI on a single node installation
If you installed IBM Predictive Customer Intelligence on a single node by using the
solution installer, you must add the IBM Cognos Business Intelligence and DB2
client paths to the LD_LIBRARY_PATH environment variable in WebSphere
Application Server.

Procedure
1. Open a web browser.
2. In the address bar, type the address for the WebSphere Admin Console.

The Admin console address is: http://servername:9060/ibm/console where
servername is the name or IP address for the computer where you installed
the IBM Predictive Customer Intelligence server components.

3. If security is enabled, enter the User ID and Password, and click Log in.
4. Expand Servers > Server Types > WebSphere application servers, and click

server1.
5. Under Server Infrastructure, expand Java and Process Management, and

click Process Definition.
6. Under Additional Properties, click Environment Entries.
7. Click LD_LIBRARY_PATH.
8. In the Value box, add the following value:

/opt/ibm/cognos/c10_64/bin64/:/opt/ibm/db2/V10.5/lib32/

Important: If you did not use the default installation locations, ensure that
you use the appropriate paths.

9. Click Apply, and then click Save.
10. Restart the WebSphere Application Server instance.

Configuring IBM HTTP Server for IBM Cognos BI
You can optionally configure IBM HTTP Server to use as the IBM Cognos Business
Intelligence portal. IBM HTTP Server is installed by the solution installer, but you
must configure it.

Procedure
1. Go to the HTTP Server conf directory. For example, go to the

/opt/IBM/HTTPServer/conf directory.
2. Open the httpd.conf file in a text editor.
3. Add the following lines to file:

ScriptAlias /ibmcognos/cgi-bin "Cognos_installation/cgi-bin"
<Directory "Cognos_installation/cgi-bin">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

Alias /ibmcognos "Cognos_installation/webcontent"
<Directory "Cognos_installation/webcontent">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>
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Note: Ensure that you add the /ibmcognos/cgi-bin ScriptAlias before the
/ibmcognos Alias.
For example, add the following lines:
ScriptAlias /ibmcognos/cgi-bin "/opt/ibm/cognos/c10_64/cgi-bin"
<Directory "/opt/ibm/cognos/c10_64/cgi-bin">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

Alias /ibmcognos "/opt/ibm/cognos/c10_64/webcontent"
<Directory "/opt/ibm/cognos/c10_64/webcontent">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

4. Save and close the file.
5. Go to the HTTP Server bin directory. For example, go to the

/opt/IBM/HTTPServer/bin directory.
6. Enter the following commands: ./apachectl stop.
7. Enter the following commands: ./apachectl start.

Results

After the services start, you can access the IBM Cognos BI portal by going to
http://servername:81/ibmcognos in a web browser.

If you changed the default port number to 80 for IBM HTTP Server, you do not
have to include the port number in the URL. For example, you can enter
http://servername/ibmcognos.

Configure the Integration Bus node components
To configure the Integration Bus node components, you must create a broker, a
queue manager, and an execution group. You must also set authorizations for the
user that runs the broker and queue manager. Authorization is required when the
client is running on a different computer than the server components.

Creating a broker and queue manager
You create a broker for IBM Predictive Customer Intelligence from the command
line.

You must assign a user for the broker and queue manager. The user must be a
local administrator user.

On Linux operating systems, some additional settings might be required to
configure WebSphere MQ. For more information, see the WebSphere MQ
documentation (www.ibm.com/support/knowledgecenter/SSFKSJ_8.0.0/
com.ibm.mq.ins.doc/q008520_.htm).

Procedure
1. Log onto the Integration Bus node and, in a terminal window, change to the

user that you created. For example, su mqmuser.
2. Enter the following command to create the queue manager: crtmqm

queue_manager_name.
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For example, to create a queue manager that is named pciqmgr, enter: crtmqm
pciqmgr.

3. Enter the following command to start the queue manager: strmqm
queue_manager_name.
For example, to start the queue manager that is named pciqmgr, enter: strmqm
pciqmgr.

4. Enter the following command to create an integration node: mqsicreatebroker
broker_name -q queue_manager_name.
For example, to create a broker that is named pcibroker, enter:
mqsicreatebroker pcibroker -q pciqmgr.

5. Enter the following command to start the broker: mqsistart broker_name For
example, to start a broker that is named pcibroker, enter: mqsistart pcibroker.

6. Enter the following command to create an execution group:
mqsicreateexecutiongroup broker_name -e executiongroupname For example,
to create an execution group that is named pciegroup, enter:
mqsicreateexecutiongroup pcibroker -e pciegroup.

Enabling remote access for the queue manager
For IBM Predictive Customer Intelligence, you must start the queue manager
command line processor to enable remote access to the queue manager.

Procedure
1. Log onto the Integration Bus node and, in a terminal window, change to the

user that you created. For example, su mqmuser.
2. Enter the following command to start the queue manager: runmqsc

queue_manager_name

The command line processor is running after you see the message "Starting
MQSC for queue manager queue_manager_name".

3. Enter the following lines, and press Enter after each line:
START LISTENER

ALTER QMGR CHLAUTH(ENABLED)

SET CHLAUTH(SYSTEM.BKR.CONFIG) TYPE(ADDRESSMAP) ADDRESS('*')
MCAUSER('mqmuser')

SET CHLAUTH(SYSTEM.BKR.CONFIG) TYPE(BLOCKUSER) USERLIST('*NOACCESS')

END

Important: The ADDRESS(’*’) value in the command allows connections from
any IP address. Consider restricting the access to a single computer. For more
information about these values, see the WebSphere MQ documentation.

4. If you want to use a specific port number for the listener, enter the following
command:
runmqlsr -t tcp -m queue_manager_name -p port_number

Ensure that you open the listener port number. If you did not specify a port
number, the default port number is 1414 for the first broker you create.

Testing the installation of the server components on a single
node installation

You can test the installation of the IBM Predictive Customer Intelligence server
components by accessing some of the component portals.
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For example, you can open the IBM Cognos BI portal. If the portal opens, IBM
Cognos BI is installed and running. You can also access the SPSS configuration tool
on the Analytics node computer.

Procedure
1. Open a web browser.
2. In the address bar, type the address for the IBM Cognos Content Manager

status page.
The address is http://servername:9080/p2pd/servlet, where bi_node_name is
the name or IP address for the computer where you installed the IBM
Predictive Customer Intelligence server components.
The Content Manager status says Running.

3. In the address bar, type the address for the IBM Cognos BI portal.
Alternatively, if you did not configure IBM HTTP Server, you can access the
IBM Cognos BI portal from the dispatcher URL: http://servername:9080/p2pd/
servlet/dispatch/.
Alternatively, if you configured IBM HTTP Sever, the address is
http://servername:81/ibmcognos.

4. In the address bar, type the address for the SPSS administration console.
The address is http://analytics_node_name:9081/config, where
analytics_node_name is the name or IP address for the Analytics node
computer.
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Chapter 4. Manually install on Microsoft Windows or Linux
operating systems

If you are installing on a Microsoft Windows or SUSE Linux operating system, you
must manually install each IBM Predictive Customer Intelligence component by
using the installation program that is provided with that component.

If you want to install multiple IBM SPSS Collaboration and Deployment Services
instances on a Red Hat Enterprise Linux operating system, you must manually
install the components. The solution installer does not allow you to install more
than one instance, however, you can manually install others if you require.

Downloading and decompressing the installation files
You must download the IBM Predictive Customer Intelligence solution files from
IBM Passport Advantage. For an installation on Microsoft Windows or SUSE Linux
operating systems, you must install each component manually.

For more information about the files that you must download, see Downloading
IBM Predictive Customer Intelligence 1.1 (http://www.ibm.com/support/
docview.wss?uid=swg24040382).

Procedure
1. Access the IBM Passport Advantage web site.

Tip: If you receive an error, try using a different web browser to access
Passport Advantage.

2. Sign in and navigate to the software downloads page.
3. Find the eImages for IBM Predictive Customer Intelligence.
4. Download an eImage by selecting the check box beside the name. When the

download is complete, a Download Complete message is displayed. The
location of the downloaded files is displayed in the message window.

5. Decompress the eImage files.
v For an installation on Microsoft Windows operating systems, decompress the

prd_cust_intel_svr_1.1_1_win_en.tar.gz,
prd_cust_intel_svr_1.1_2_win_en.tar.gz, and
prd_cust_intel_svr_1.1_3_win_en.tar.gz files.

v For an installation on SUSE Linux operating systems, decompress the
prd_cust_intel_svr_1.1_1_l86_en.tar.gz,
prd_cust_intel_svr_1.1_2_l86_en.tar.gz, and
prd_cust_intel_svr_1.1_3_l86_en.tar.gz files.

6. Copy the component installation files to each computer on which you want to
install the component.

Install IBM DB2 software on the data node computer
You must install IBM DB2 Enterprise Server Edition version 10.5 Fix Pack 5. IBM
DB2 is used for product databases, such as the IBM Cognos Business Intelligence
content store database, the IBM SPSS database, and for client application data.
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After you install the database software, you must create a database for the IBM
SPSS components.

Installing IBM DB2 Enterprise Server
You must install IBM DB2 Enterprise Server Edition.

Note: On Linux operating systems, the setup wizard is a graphical installer that
requires an X Windows System (X11) to display the graphical user interface.

Procedure
1. Go to the DB2 directory where you decompressed the IBM Predictive Customer

Intelligence installation files.
2. On Microsoft Windows operating systems:

a. Double-click v10.5fp5_ntx64_server_t.exe to decompress the installation
files.

b. Go to the SERVER_T directory where you decompressed the files, and
double-click setup.exe.

3. On Linux operating systems:
a. Decompress the v10.5fp5_linuxx64_server_t.tar.gz by using the following

command: tar xvf v10.5fp5_linuxx64_server_t.tar.gz.
b. Go to the server_t directory.
c. Start the installer: ./db2setup.

4. In the DB2 Setup Launchpad, click Install a Product.
5. Under DB2 Version 10.5 Fix Pack 5 Workgroup, Enterprise and Advanced

Editions, click Install New.
6. Select Typical for the installation type.
7. On the Select the installation, response file creation, or both page, accept the

default or select Install DB2 Server Edition on this computer.
8. Follow the steps in the wizard to install and configure your database server.

For more information about any of the settings, see the IBM DB2
documentation on IBM Knowledge Center (www.ibm.com/support/
knowledgecenter/SSEPGG_10.5.0/com.ibm.swg.im.dbclient.install.doc/doc/
c0023452.html).

Adding the IBM DB2 license
You must add the DB2 license after you install IBM DB2 Enterprise Server for IBM
Predictive Customer Intelligence.

Procedure
1. Go to the DB2 folder where you decompressed the IBM Predictive Customer

Intelligence installation files.
2. Decompress the file that is named DB2_ESE_AUSI_QS_Activ_10.5.0.5.zip.
3. On Microsoft Windows operating systems:

a. Click Start > IBM DB2 DB2COPY1 (Default) > DB2 Command Window -
Administrator.

b. Type the following command and press Enter:
db2licm -a decompressed_folder_location\ese_u\db2\license\
db2ese_u.lic For example, if you decompressed the file in the default
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location, the command would be: db2licm -a C:\IBM\PCI\
PCI_1.1_Server_SW\DB2\DB2_ESE_AUSI_QS_Activ_10.5.0.5\ese_u\db2\
license\db2ese_u.lic

c. Type the following command to validate that the license was added:
db2licm -l

4. On SUSE Linux operating systems:
a. Change to the database administrator user. For example, su db2inst1.
b. Go to the directory where you decompressed the

DB2_ESE_AUSI_QS_Activ_10.5.0.5.zip file.
c. Type the following command and press Enter:

db2licm -a ese_u/db2/license/db2ese_u.lic

d. Type the following command to validate that the license was added:
db2licm -l

Creating a database for the SPSS components
After you install the IBM DB2 database server for IBM Predictive Customer
Intelligence, you must create a database for the SPSS components.

Procedure
1. On the computer where you installed IBM DB2, do one of the following:
v On Microsoft Windows operating systems, log on as the DB2 instance owner

user, and click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command
Window - Administrator.

v On Linux operating systems, open a terminal window.
2. Enter the following command to create a database:

DB2 CREATE DATABASE SPSSDB ON path USING CODESET UTF-8
TERRITORY US COLLATE USING SYSTEM

path can be a file path or just a drive letter. For example, on Microsoft
Windows operating systems:
DB2 CREATE DATABASE SPSSDB ON C: USING CODESET UTF-8

TERRITORY US COLLATE USING SYSTEM

3. Connect to the database you created by using the following command:
DB2 CONNECT TO SPSSDB

4. Enter the following commands to create the bufferpools for the database. Enter
each command individually.
DB2 CREATE Bufferpool CDS8K IMMEDIATE SIZE 250 AUTOMATIC PAGESIZE 8 K

DB2 CREATE REGULAR TABLESPACE CDS8K PAGESIZE 8 K MANAGED BY AUTOMATIC
STORAGE EXTENTSIZE 8 OVERHEAD 10.5 PREFETCHSIZE 8 TRANSFERRATE 0.14
BUFFERPOOL CDS8K DROPPED TABLE RECOVERY ON

DB2 CREATE Bufferpool CDSTEMP IMMEDIATE SIZE 250 PAGESIZE 32 K

DB2 CREATE SYSTEM TEMPORARY TABLESPACE CDSTEMP PAGESIZE 32 K MANAGED BY AUTOMATIC
STORAGE EXTENTSIZE 16 OVERHEAD 10.5 PREFETCHSIZE 16 TRANSFERRATE 0.14
BUFFERPOOL "CDSTEMP"

Install software on the Predictive Analytics node computer
For IBM Predictive Customer Intelligence, install SPSS software on the Predictive
Analytics node computer.
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Installing IBM DB2 client software on the Analytics node
computer

You must install IBM DB2 client software on the IBM Predictive Customer
Intelligence Predictive Analytics node computer.

Note: On Linux operating systems, the setup wizard is a graphical installer that
requires an X Windows System (X11) to display the graphical user interface.

Procedure
1. Go to the DB2 folder where you decompressed the IBM Predictive Customer

Intelligence installation files.
2. On Microsoft Windows operating systems:

a. Double-click v10.5fp5_ntx64_rtcl.exe and follow the steps in the wizard.
b. Click Install.

3. On Linux operating systems:
a. Decompress the v10.5fp5_linuxx64_rtcl.tar.gz file by using the following

command: tar xvf v10.5fp5_linuxx64_rtcl.tar.gz.
b. Go to the rtcl directory.
c. Start the installer: ./db2setup.
d. In the DB2 Setup Launchpad, click Install a Product.
e. Under IBM Data Server Runtime Client Version 10.5 Fix Pack 5, click

Install New.
f. Select Typical for the installation type.
g. Select Install Data Server Runtime Client on this computer.

Installing IBM Installation Manager on the Predictive Analytics
node computer

Install IBM Installation Manager before you install other IBM Predictive Customer
Intelligence software.

Procedure
1. Go to the InstallationMgr directory where you decompressed the IBM

Predictive Customer Intelligence installation files.
2. Decompress the Installation Manager installation file.
3. Start the installer:
v On Microsoft Windows operating systems, double-click install.exe.
v On Linux operating systems, enter ./install.

4. Follow the steps to install IBM Installation Manager.

Installing WebSphere Application Server on the Predictive
Analytics node computer

You install WebSphere Application Server by using IBM Installation Manager.

Procedure
1. Go to the WAS directory where you decompressed the IBM Predictive

Customer Intelligence installation files.
2. Decompress the WebSphere Application Server installation files.
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You must decompress all of the compressed files: WASND_v8.5.5_1of3.zip,
WASND_v8.5.5_2of3.zip, and WASND_v8.5.5_3of3.zip.

3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the WebSphere Application

Server installation files.
7. In the directory where you decompressed the installation files, select

repository.config, click OK to close the dialog.
8. In IBM Installation Manager, click Install.
9. Under IBM WebSphere Application Server Network Deployment, select

Version 8.5.5.0.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. When prompted for Which program do you want to start?, select Profile

Management Tool to create a profile, and click Finish.
12. In the WebSphere Customization Toolbox 8.5 window, click Create.
13. Select Application Server, and click Next.
14. Select Typical profile creation, and click Next.
15. Follow the steps in the wizard to configure your application server. For more

information about any of the settings, see the WebSphere Application Server
documentation.

Note: After the installation is complete, do not start the WebSphere
Application Server services.

Upgrading WebSphere Application Server
You update the WebSphere Application Server by using IBM Installation Manager.

Procedure
1. Go to the WAS directory where you decompressed the IBM Predictive

Customer Intelligence installation files.
2. Decompress the WebSphere Application Server fix pack installation files.

You must decompress all of the compressed files: 8.5.5-WS-WAS-FP0000006-
part1.zip and 8.5.5-WS-WAS-FP0000006-part2.zip.

3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
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7. In the directory where you decompressed the WebSphere Application Server
fix pack installation files, select repository.config, click OK to close the
dialog.

8. In IBM Installation Manager, click Update.
9. Select IBM WebSphere Application Server V8.5, and click Next.

10. Follow the steps in IBM Installation Manager to install the product.
11. Click Finish.

Installing IBM SPSS Collaboration and Deployment Services
Server

You install IBM SPSS Collaboration and Deployment Services Server on the IBM
Predictive Customer Intelligence Predictive Analytics node computer.

If you want to install multiple IBM SPSS Collaboration and Deployment Services
instances, see the product documentation (www.ibm.com/support/
knowledgecenter/SS69YH_7.0.0/cads_config_ddita/model_management/thin/
pes_clustering.dita).

Procedure
1. Go to the SPSS_CDS directory where you decompressed the IBM Predictive

Customer Intelligence installation files.
2. Decompress the spss_cnds_svr_7.0_mp_ml.zip file.
3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the Server_Repository directory where you decompressed the installation

files, select repository.config, click OK to close the dialog.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select the following components.
v IBM SPSS Collaboration and Deployment Services - Remote Scoring

Server

v IBM SPSS Collaboration and Deployment Services - Repository Server

v IBM SPSS PMML Scoring Adapter

10. Click Next, and follow the steps in IBM Installation Manager to install the
products.

11. On the Common Configurations page, enter the following information:

URL Enter the name or IP address of the Predictive Analytics node
computer and the port number and click Finish. For example, enter
http://servername:9080.

Username
Enter the SPSS admin user name that you used when you installed the
IBM SPSS Collaboration and Deployment Services Server.
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Password
Enter the SPSS admin user's password.

12. Click Install.
13. In the Which programs do you want to start box, select IBM SPSS

Collaboration and Deployment Services Configuration Tool, and click
Finish.

14. In the IBM SPSS Collaboration and Deployment Services Configuration
Tool, click Next.

15. On the Application Server page, enter the information for IBM WebSphere
Application Server, and click Next.
For the WebSphere profile directory value, the default location on Microsoft
Windows operating systems is C:\Program Files (x86)\IBM\WebSphere\
AppServer\profiles\AppSrv01. On Linux operating systems, the default is
/opt/IBM/WebSphere/AppServer/profiles/AppSrv01.

16. On the Database page, enter the information for the SPSSDB database, and
click Next.
The default port number on Microsoft Windows operating systems is 50000.
On Linux operating systems, the default port number is 50001.

17. On the Encryption page, enter a password, and click Next.
18. On the Repository Admin page, enter a password for the SPSS admin user,

and click Next.
19. On the Deployment mode page, select Automatic, and click Next.
20. On the Configuration summary page, click Configure.
21. Click Finish.

Installing IBM SPSS Enterprise View Driver software
Install IBM SPSS Collaboration and Deployment Services Enterprise View Driver
software on the IBM Predictive Customer Intelligence Predictive Analytics node
computer.

Procedure
1. Go to the SPSS_CDS\Drivers directory where you decompressed the IBM

Predictive Customer Intelligence installation files.
2. Decompress the installation files.
3. Go to the Enterprise_View_Driver_64 directory.
4. Start the installer.
v On Microsoft Windows operating systems, double-click setupWindows64-

amd64.exe.
v On SUSE Linux operating systems, enter the following command:

./setupLinux64-amd64.bin.
If you cannot run the executable, change the permissions by entering the
following before you run the command: chmod +x setupLinux64-amd64.bin.

5. Follow the steps in the wizard to install the driver.

Installing IBM SPSS Modeler Server software
Install and update IBM SPSS Modeler Server software on the IBM Predictive
Customer Intelligence Predictive Analytics node computer.
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Procedure
1. Go to the SPSS_Modeler_Server directory where you decompressed the IBM

Predictive Customer Intelligence installation files.
2. Start the installer.
v On Microsoft Windows operating systems, decompress the

spss_mod_svr_17.0_win_ml.zip file, and double-click setup.exe.
v On Linux operating systems, enter the following command:

./spss_mod_svr_17.0_lx86_ml.bin.
If you cannot run the executable, change the permissions by entering the
following before you run the command: chmod +x
spss_mod_svr_17.0_lx86_ml.bin.

3. On the Server Mode page, select Production Mode.
4. Follow the steps in the wizard to install the server.
5. Go to the SPSS_Modeler_Server directory where you decompressed the IBM

Predictive Customer Intelligence installation files.
6. Install the updater.
v On Microsoft Windows operating systems, decompress the

17.0-IM-S17MODELERS-WIN64-FP001.zip file, and double-click setup.exe.
v On Linux operating systems, copy 17.0-IM-S17MODELERS-Linuxx8664-

FP001.bin to the directory where SPSS Modeler Server is installed, and enter
the following command: ./17.0-IM-S17MODELERS-Linuxx8664-FP001.bin.
SPSS Modeler Server is installed to /usr/IBM/SPSS/ModelerServer/17.0 by
default.
If you cannot run the executable, change the permissions by entering the
following before you run the command: chmod +x s17.0-IM-S17MODELERS-
WIN64-FP001.

7. Follow the steps in the wizard to update the server.
8. Click Finish.
9. Install the interim fix.
v On Microsoft Windows operating systems, go to the SPSS_Modeler_Server\

Interim_Fix directory, decompress the 17.0-IM-S17MODELERS-WIN64-FP01-
IF011.zip file, and follow the instructions in 17.0-IM-S17MODELERS-Win64-
FP01-IF011.txt to apply the interim fix.

v On Linux operating systems, go to the SPSS_Modeler_Server/Interim_Fix
directory, decompress the 17.0-IM-S17MODELERS-LINUX8664-FP01-IF011.zip
file, and follow the instructions in 17.0-IM-S17MODELERS-LINUX8664-FP01-
IF011.txt to apply the interim fix.

Installing IBM SPSS Modeler Premium Server software
Install and update IBM SPSS Modeler Premium Server software on the IBM
Predictive Customer Intelligence Predictive Analytics node computer

Before you begin

Ensure that you install IBM SPSS Modeler Server software before you install IBM
SPSS Modeler Premium Server software.

Procedure
1. Go to the SPSS_Modeler_Server directory where you decompressed the IBM

Predictive Customer Intelligence installation files.
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2. Start the installer.
v On Microsoft Windows operating systems, decompress the

spss_mod_prm_svr_17.0_win_ml.zip file, and double-click setup.exe.
v On SUSE Linux operating systems, decompress the

spss_mod_prm_svr_17.0_lx86_ml.zip file, and enter the following command:
./premium_server_linux64.bin.
If you cannot run the executable, change the permissions by entering the
following before you run the command: chmod +x
premium_server_linux64.bin.

3. Follow the steps in the wizard to install the server.
4. Install the fix pack.
v On Microsoft Windows operating systems, decompress the

17.0-IM-S17MODELERPS-WIN64-FP001.zip file, and double-click setup.exe.
v On SUSE Linux operating systems, copy 17.0-IM-S17MODELERPS-Linux8664-

FP001.bin to the directory where SPSS Modeler Server is installed, and enter
the following command: ./17.0-IM-S17MODELERPS-Linux8664-FP001.bin.
SPSS Modeler Server is installed to /usr/IBM/SPSS/ModelerServer/17.0 by
default.
If you cannot run the executable, change the permissions by entering the
following before you run the command: chmod +x 17.0-IM-S17MODELERPS-
Linux8664-FP001.bin.

5. Follow the steps in the wizard to update the server.
6. Click Done.

For more information about any of the settings, see the IBM SPSS Modeler
Premium 17 Installation and Configuration Guide.

Installing IBM SPSS Collaboration and Deployment Services
Modeler adapters

Install IBM SPSS Collaboration and Deployment Services Adapter software on the
IBM Predictive Customer Intelligence Predictive Analytics node computer.

Procedure
1. Go to the SPSS_CDS/Adapters directory where you decompressed the IBM

Predictive Customer Intelligence server installation files.
2. Decompress the installation files.
v On Microsoft Windows operating systems, decompress

spss_mod_17.0_cndsadp_7.0_win_ml.zip.
v On Linux operating systems, decompress

spss_mod_17.0_cndsadp_7.0_lx86ml.zip.
3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the disk1 folder, select diskTag.inf, click OK to close the dialog.
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8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select IBM SPSS Modeler Adapters for

Collaboration and Deployment Services.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. On the Install Packages page, select Use the existing package group, select

IBM SPSS Collaboration and Deployment Services 7.0, and click Next.
12. On the Common Configurations page, enter the SPSS administrator user and

password, and click Next.
13. Click Install, and click Finish.

Upgrading IBM SPSS Collaboration and Deployment Services
Modeler adapters
You update the IBM SPSS Collaboration and Deployment Services Modeler adapter
by using IBM Installation Manager

Procedure
1. Go to the SPSS_CDS/Adapters directory where you decompressed the IBM

Predictive Customer Intelligence server installation files.
2. Decompress the installation files: 17.0-IM-S17MODELERCDS70-MP-FP001.zip.
3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you extracted the installation files.
7. In the repository directory, select repository.config, and click OK to close

the dialog.
8. In IBM Installation Manager, click Update.
9. Select IBM SPSS Collaboration and Deployment Services 7.0, and click Next.

10. Click Next, and follow the steps in IBM Installation Manager to update the
product.

11. On the Common Configurations page, enter the SPSS administrator user and
password, and click Next.

12. Click Update, and then click Finish.

Installing IBM Analytical Decision Management software
Install IBM Analytical Decision Management software on the IBM Predictive
Customer Intelligence Predictive Analytics node computer.

A sample Analytical Decision Management application is provided with the
installation files. The sample application is provided in a compressed file that is
named ADM_80_Demo.zip. For more information about the sample file, see the
Analytical Decision Management documentation (www.ibm.com/support/
knowledgecenter/SS6A3P_8.0.0).
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Procedure
1. Go to the ADM directory where you decompressed the IBM Predictive

Customer Intelligence server installation files.
2. Decompress the installation files: ibm_adm_17.0_mp_ml.zip.
3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the adm_repository folder, select repository.config, and click OK to close

the dialog.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select IBM Analytical Decision Management.

10. Click Next, and follow the steps in IBM Installation Manager to install the
product.

11. On the Install Packages page, select Use the existing package group, select
IBM SPSS Collaboration and Deployment Services 7.0, and click Next.

12. On the Install Packages page, select Production for the Installation Type.
Ensure that all of the options under IBM Analytical Decision Management
Applications are selected.

13. On the Common Configurations page, enter the SPSS administrator user and
password, and click Next.

14. Click Install.
15. Click Finish.

Installing IBM SPSS Data Access Pack
Install the IBM SPSS Data Access Pack software on the IBM Predictive Customer
Intelligence Predictive Analytics node computer.

Before you begin

You must stop the IBM WebSphere Application Server profile where IBM SPSS
products are installed and stop IBM SPSS Modeler Server before you install the
Data Access Pack.

Procedure
1. Stop the WebSphere Application Server instance.
v On Microsoft Windows operating systems, click Start > All Programs > IBM

WebSphere > Profiles > AppSrv01 > Stop the server.
v On Linux operating systems, go to the WebSphere Application Server profile

bin directory, and enter the following command: ./stopServer.sh server1.
The default path to is /opt/IBM/WebSphere/AppServer/profiles/AppSrv01/
bin.

2. Stop IBM SPSS Modeler Server.
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v On Microsoft Windows operating systems, stop the service from Control
Panel > Administrative Tools > Services.

v On Linux operating systems, go to the /usr/IBM/SPSS/ModelerServer/17.0
directory, and enter the following command: ./modelersrv.sh stop.

For more information, see the IBM SPSS Modeler documentation
(www.ibm.com/support/docview.wss?uid=swg27043831).

3. Go to the SPSS_DAP directory where you decompressed the IBM Predictive
Customer Intelligence server installation files.

4. Decompress the installation file SPSS_DATA_ACCESS_PACK_7.1.1_MP_EN.zip.
5. Start the installer.
v On Microsoft Windows operating systems, go to the Win64 directory, and

double-click SDAP_7.1_win64.exe.
v On Linux operating systems, go to the Linux directory, and run the following

command: ./SDAP_7.1_Linux64.bin.
If you cannot run the executable, change the permissions by entering the
following before you run the command: chmod +x SDAP_7.1_Linux64.bin.

6. Follow the steps in the wizard to install the Data Access Pack.
7. Start the WebSphere Application Server instance.
v On Microsoft Windows operating systems, click Start > All Programs > IBM

WebSphere > Profiles > AppSrv01 > Start the server.
v On Linux operating systems, go to the WebSphere Application Server profile

bin directory, and enter the following command: ./startServer.sh server1.
The default path is /opt/IBM/WebSphere/AppServer/profiles/AppSrv01/bin.

8. Start IBM SPSS Modeler Server.
v On Microsoft Windows operating systems, start the service from Control

Panel > Administrative Tools > Services.
v On Linux operating systems, go to the /usr/IBM/SPSS/ModelerServer/17.0

directory, and enter the following command: ./modelersrv.sh start.

Installing IBM SPSS Statistics Server software
Install IBM SPSS Statistics Server software on the IBM Predictive Customer
Intelligence Predictive Analytics node computer.

Procedure
1. Go to the SPSS_Stats_Server directory where you decompress the IBM

Predictive Customer Intelligence server installation files.
2. Start the installer.
v On Microsoft Windows operating systems, decompress

SPSSS_SERVER_23.0_MW_ML.zip, and in the SPSSS_SERVER_23.0_MW_ML directory,
double-click setup.exe.

v On SUSE Linux operating systems, enter the following command:
./SPSSSS23_LINUX_X86-64_ML.bin.
If you cannot run the executable, change the permissions by entering the
following before you run the command: chmod +x SPSSSS23_LINUX_X86-
64_ML.bin.

3. Follow the steps in the wizard to install the software.
4. On the Server Mode page, select Production Mode.
5. On the IBM SPSS Statistics - Essentials for Python page, click Yes, and then

click Next.

46 IBM Predictive Customer Intelligence Version 1.1.0: IBM Predictive Customer Intelligence Installation Guide

http://www.ibm.com/support/docview.wss?uid=swg27043831


Installing IBM SPSS Statistics Collaboration and Deployment
Services adapters

Install IBM SPSS Statistics Collaboration and Deployment Services adapter
software on the IBM Predictive Customer Intelligence Predictive Analytics node
computer.

Procedure
1. Go to the SPSS_CDS\Adapters directory where you decompressed the IBM

Predictive Customer Intelligence server installation files.
2. Decompress SPSSS_23.0_CDSA_7.0_MP_ML.zip.
3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the CnDS70/repository directory, select repository.config, and click OK to

close the dialog.
8. In IBM Installation Manager, click Install.
9. Under Installation Packages, select IBM SPSS Collaboration and

Deployment Services - Server Adapter for Statistics.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. On the Install Packages page, select Use the existing package group, select

IBM SPSS Collaboration and Deployment Services 7.0, and click Next.
12. On the Common Configurations page, enter the SPSS administrator user and

password, and click Next.
13. Click Install.
14. Click Finish.

Install software on the Business Intelligence node computer
You must install an IBM DB2 client, IBM HTTP Server, and IBM Cognos Business
Intelligence on the IBM Predictive Customer Intelligence Business Intelligence node
computer.

If you want to customize the installation of IBM Cognos Business Intelligence, such
as distributing the installation among different computers, see the product
documentation (www.ibm.com/support/knowledgecenter/SSEP7J_10.2.2/
com.ibm.swg.ba.cognos.inst_cr_winux.10.2.2.doc/
c_installservercompsdistributed.html).

Installing IBM DB2 client software on the BI node computer
You must install IBM DB2 client software on the IBM Predictive Customer
Intelligence Business Intelligence node computer.

Note: On Linux operating systems, the setup wizard is a graphical installer that
requires an X Windows System (X11) to display the graphical user interface.
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Procedure
1. Go to the DB2 folder where you decompressed the IBM Predictive Customer

Intelligence installation files.
2. On Microsoft Windows operating systems:

a. Double-click v10.5fp5_ntx64_rtcl.exe and follow the steps in the wizard.
b. Click Install.

3. On Linux operating systems:
a. Decompress the v10.5fp5_linuxx64_rtcl.tar.gz file by using the following

command: tar xvf v10.5fp5_linuxx64_rtcl.tar.gz.
b. Go to the rtcl directory.
c. Start the installer: ./db2setup.
d. In the DB2 Setup Launchpad, click Install a Product.
e. Under IBM Data Server Runtime Client Version 10.5 Fix Pack 5, click

Install New.
f. Select Typical for the installation type.
g. Select Install Data Server Runtime Client on this computer.

Installing IBM Installation Manager on the BI node computer
Install IBM Installation Manager before you install other IBM Predictive Customer
Intelligence software.

Procedure
1. Go to the InstallationMgr directory where you decompressed the IBM

Predictive Customer Intelligence installation files.
2. Decompress the Installation Manager installation file.
3. Start the installer:
v On Microsoft Windows operating systems, double-click install.exe.
v On Linux operating systems, enter ./install.

4. Follow the steps to install IBM Installation Manager.

Installing WebSphere Application Server on the BI node
computer

On Linux operating systems, you deploy IBM Cognos Business Intelligence to
WebSphere Application Server. You install WebSphere Application Server by using
IBM Installation Manager.

On Microsoft Window operating systems, you can use the default application
server that is provided with IBM Cognos Business Intelligence. You can skip this
task.

Procedure
1. Go to the WAS directory where you decompressed the IBM Predictive

Customer Intelligence installation files.
2. Decompress the WebSphere Application Server installation files.

You must decompress all of the compressed files: WASND_v8.5.5_1of3.zip,
WASND_v8.5.5_2of3.zip, and WASND_v8.5.5_3of3.zip.

3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
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v On Linux operating systems, start IBM Installation Manager from the
Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the WebSphere Application

Server installation files.
7. In the directory where you decompressed the installation files, select

repository.config, click OK to close the dialog.
8. In IBM Installation Manager, click Install.
9. Under IBM WebSphere Application Server Network Deployment, select

Version 8.5.5.0.
10. Click Next, and follow the steps in IBM Installation Manager to install the

product.
11. When prompted for Which program do you want to start?, select Profile

Management Tool to create a profile, and click Finish.
12. In the WebSphere Customization Toolbox 8.5 window, click Create.
13. Select Application Server, and click Next.
14. Select Typical profile creation, and click Next.
15. Follow the steps in the wizard to configure your application server. For more

information about any of the settings, see the WebSphere Application Server
documentation.

Note: After the installation is complete, do not start the WebSphere
Application Server services.

Upgrading WebSphere Application Server
You update the WebSphere Application Server by using IBM Installation Manager.

Procedure
1. Go to the WAS directory where you decompressed the IBM Predictive

Customer Intelligence installation files.
2. Decompress the WebSphere Application Server fix pack installation files.

You must decompress all of the compressed files: 8.5.5-WS-WAS-FP0000006-
part1.zip and 8.5.5-WS-WAS-FP0000006-part2.zip.

3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. In the directory where you decompressed the WebSphere Application Server

fix pack installation files, select repository.config, click OK to close the
dialog.

8. In IBM Installation Manager, click Update.
9. Select IBM WebSphere Application Server V8.5, and click Next.

10. Follow the steps in IBM Installation Manager to install the product.
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11. Click Finish.

Installing IBM HTTP Server on the BI node computer
You install IBM HTTP Server by using IBM Installation Manager.

Procedure
1. Go to the WAS_HTTP_Server directory where you decompressed the IBM

Predictive Customer Intelligence server installation files.
2. Decompress the HTTP Server installation files.

You must decompress all of the compressed files:
WAS_v8.5.5_SUPPL_1_of_3.zip, WAS_v8.5.5_SUPPL_2_of_3.zip, and
WAS_v8.5.5_SUPPL_3_of_3.zip.

3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you extracted the installation files.
7. Select repository.config, and click OK to close the dialog box.
8. In IBM Installation Manager, click Install.
9. Select IBM HTTP Server for WebSphere Application Server.

10. Click Next, and follow the steps in IBM Installation Manager to install the
product.
a. On the Configuration for IBM HTTP Server for WebSphere Application

Server 8.5.5.0 page, change the HTTP port value only if you have another
web server that is running on your computer and is already using port 80.

Note: If you use a port other than 80, you must change the port number
in the Gateway URI in IBM Cognos Configuration.

Upgrading IBM HTTP Server on the BI node computer
You update IBM HTTP Server by using IBM Installation Manager.

Procedure
1. Go to the WAS_HTTP_Server directory where you decompressed the IBM

Predictive Customer Intelligence server installation files.
2. Decompress the installation files.

You must decompress 8.5.5-WS-WASSupplements-FP0000006-part1.zip and
8.5.5-WS-WASSupplements-FP0000006-part2.zip.
Ensure that you decompress the files into the same directory.

3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager > IBM Installation Manager.
v On Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
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5. Click Add Repository.
6. Browse to the location where you decompressed the installation files.
7. Select repository.config, and click OK to close the dialog box.
8. In IBM Installation Manager, click Update.
9. Select IBM HTTP Server V8.5, and click Next.

10. Follow the steps in IBM Installation Manager to install the product.
11. Click Finish.

Installing IBM Cognos Business Intelligence
Install IBM Cognos Business Intelligence software on the IBM Predictive Customer
Intelligence Business Intelligence node computer.

For more information about IBM Cognos Business Intelligence, see the product
documentation (www.ibm.com/support/knowledgecenter/SSEP7J_10.2.2).

Before you begin

On Linux operating systems, the setup wizard is a graphical installer that requires
an X Windows System (X11) to display the graphical user interface. And, you must
also install the OpenMotif library to run the installation wizard for IBM Cognos
Business Intelligence. For more information, see Cannot install Cognos BI using
issetup on Linux. libXm.so.4 is missing (www.ibm.com/support/
docview.wss?uid=swg21612290).

Alternatively, you can install IBM Cognos BI by using an unattended installation.
For more information, see the Cognos documentation on IBM Knowledge Center
(www.ibm.com/support/knowledgecenter/SSEP7J_10.2.2/
com.ibm.swg.ba.cognos.inst_cr_winux.10.2.2.doc/
t_inst_settingupanunattendedinstallationandconfiguration.html
%23inst_SettingUpAnUnattendedInstallationandConfiguration).

Procedure
1. Install IBM Cognos BI.

a. Go to the BI directory where you decompressed the IBM Predictive
Customer Intelligence server installation files.

b. On Microsoft Windows operating systems, decompress
bi_svr_64b_10.2.2_win_ml.tar.gz. On Linux operating systems,
decompress bi_svr_10.2.2_l86_ml.tar.gz.
On Microsoft Windows operating systems, decompressing the IBM Cognos
installation files is a two-step process. You must decompress the tar.gz file,
and then decompress the tar file.

c. On Microsoft Windows operating systems, go to the folder where you
decompressed the file, and decompress bi_svr_64b_10.2.2_win_ml.tar.

d. On Microsoft Windows operating systems, go to the win64h directory and
double-click issetup.exe. On Linux operating systems, go to the
linuxi38664h directory, and enter ./issetup.

e. Follow the steps in the wizard to install the server software.
f. On the Component Selection page, select the following components:
v Application Tier Components

v Gateway

v Content Manager
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Note: Do not install the Cognos Content Database component.
g. Clear the Start IBM Cognos Configuration box, and click Finish.

2. Install the IBM Cognos BI fix pack.

Important: Ensure that you decompress the fix pack to a different location than
the IBM Cognos BI installation files. Some directories will be overwritten if you
use the same location.
a. Go to the BI folder where you installed the IBM Predictive Customer

Intelligence server installation files.
b. On Microsoft Windows operating systems, decompress

up_bisrvr_winx64h_10.2.6102.54_ml.tar.gz, and then decompress
up_bisrvr_winx64h_10.2.6102.54_ml.tar.
On Linux operating systems, decompress
up_bisrvr_linuxi38664h_10.2.6102.54_ml.tar.gz.

c. On Microsoft Windows operating systems, go to the win64h directory and
double-click issetup.exe. On Linux operating systems, go to the
linuxi38664h directory, and enter ./issetup.

d. Follow the steps in the wizard to install the server software.
e. On the Installation Location page, browse to the location where you

installed IBM Cognos BI. For example, C:\Program Files\ibm\cognos\
c10_64 or /opt/IBM/cognos/c10_64.

f. Click Finish.

Configure and start IBM Cognos BI
After you install IBM Cognos Business Intelligence, you must create a content store
database, save your configuration settings, and start the services.

Copying the JDBC files for IBM DB2
You must copy two jar files from your IBM DB2 installation to your IBM Cognos
Business Intelligence installation location.

Procedure

Copy the following files from the DB2_client_installation\java directory to the
Cognos_installation\webapps\p2pd\WEB-INF\lib directory:
v db2jcc.jar

v db2jcc_license_cu.jar

Configuring IBM Cognos BI
You configure IBM Cognos Business Intelligence by using IBM Cognos
Configuration.

For more information about configuring IBM Cognos BI, see the IBM Cognos
Business Intelligence Installation and Configuration Guide on IBM Knowledge Center
(www.ibm.com/support/knowledgecenter/SSEP7J_10.2.2).

Before you begin

On Linux operating systems, you must have a JAVA_HOME value set. Set JAVA_HOME
to the Java™ that is provided with WebSphere Application Server. For example, set
your JAVA_HOME environment variable to /opt/IBM/WebSphere/AppServer/java.
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Procedure
1. Start IBM Cognos Configuration.
v On Microsoft Windows operating systems, click Start > All Programs > IBM

Cognos 10_64 > IBM Cognos Configuration.
v On Linux operating systems, go to the Cognos_install_location/bin64

directory, and enter the following command: ./cogconfig.sh.
For example, go to /opt/ibm/cognos/c10_64/bin64.

2. On Microsoft Windows operating systems, in the Explorer pane, select
Environment, and replace localhost with the name or IP address of your
computer in the following fields:
v Gateway URI (If you are using a port number other than 80 for the web

server, ensure that you also change the port number value to the port
number for IBM HTTP Server.)

v Dispatcher URIs for Gateway

v External dispatcher URI

v Internal dispatcher URI

v Dispatcher URI for external applications

v Content Manager URIs

3. On Linux operating systems:
a. In the Explorer window, under IBM Cognos services, right-click IBM

Cognos, and click Delete.
b. Right-click IBM Cognos Service, click New resource > Configuration.
c. Enter a Name, select WebSphere in the Type box, and click OK.
d. In the WebSphere Application Server location box, click the browse icon,

and select the location of your IBM WebSphere Application Server
installation. For example, /opt/IBM/WebSphere/AppServer.

e. In the Profile box, select the name of the profile into which you want IBM
Cognos BI installed.

f. In the Server instance box, select the server instance for your IBM
WebSphere profile.

g. Right-click the name that you gave your IBM WebSphere configuration, and
click Build.
The Build Application Wizard appears. Follow the instructions in the
wizard and click the Help icon for more information for each page. Use the
wizard to build the application and install it to the IBM WebSphere profile.

h. When prompted, select Install the IBM Cognos application, click Finish,
and follow the steps in the wizard.
The application is configured to run. For example, the path values are
added and the correct JVM settings are applied.

i. On the Configure IBM Cognos for WebSphere page, ensure that you enter
the correct port numbers for the IBM WebSphere profile. These values are
applied to the IBM Cognos Configuration Environment settings.
Ensure that you enter the HTTP transport port number in the URLs:
v Internal dispatcher URI

v External dispatcher URI

v Content Manager URIs

v Dispatcher URIs for gateway

v Dispatcher URI for external applications
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For example, change http://localhost:9300/p2pd/servlet/dispatch to
http://servername:9080/p2pd/servlet/dispatch.
For the Content Manager URIs and Dispatcher URIs for Gateway values,
click the edit icon to change the values.
In the Gateway URI box, change localhost to the name or IP address of
your computer, and leave the port number as 80.

j. Click Next, and the click Finish

4. Leave IBM Cognos Configuration open.

Creating a content store database for IBM Cognos BI
You create a database script on your IBM Predictive Customer IntelligenceBusiness
Intelligence node computer when you configure IBM Cognos BI. You use the script
to create the content store database on your data node computer.

Procedure
1. In IBM Cognos Configuration, configure a content store database.

Note: The information that you enter is used to generate a script that you use
to create the content store database on the data node computer.
a. In the Explorer pane, under Data Access > Content Manager, click Content

Store.
b. In the Database server and port number field, enter the name of the

computer and the port number on which you installed IBM DB2 Enterprise
Server. For example, enter servername:50000, where servername is the name
of the data node computer and 50000 is the default port number that is
used by IBM DB2.
On Linux operating systems, the default port number is 50001.

c. Click the Value field next to the User ID and password property, click the
edit icon, and enter the User ID and Password for your IBM DB2 user, and
click OK.

d. In the Properties pane, for the Database name property, enter a name for
your content store database.
The default name is cm.

Restriction: Do not use a name longer than 8 characters and use only
letters, numbers, underscores, or hyphens in the name.

2. Right-click Content Store, and click Generate DDL.
The DDL file, createDb.sql, is created in the Cognos_installation\
configuration\schemas\content\db2 directory.

3. Copy createDb.sql from the BI node computer to the data node computer.
4. On your data node computer, create the content store database.

a. Log on to the data node computer as a DB2 user with privileges to create a
database or change to the database instance owner.

b. On Microsoft Windows operating systems, click Start > IBM DB2 >
DB2COPY1 (Default) > DB2 Command Window - Administrator.

c. On Linux operating systems, open a terminal window.
d. Type db2 -tvf path\createDb.sql, and press Enter.

5. In IBM Cognos Configuration, click File > Save.
6. Test the connection to the content store database. In IBM Cognos Configuration,

in the Explorer pane, under Data Access > Content Manager, right-click
Content Store, and click Test.
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Note: If the connection does not succeed, you must correct any issues before
you can start the IBM Cognos BI services.

7. On Microsoft Windows operating systems, leave IBM Cognos Configuration
open.

Starting the IBM Cognos BI services
On Microsoft Windows operating systems, you start the IBM Cognos BI services by
using IBM Cognos Configuration. On Linux operating systems, you start IBM
Cognos by restarting the WebSphere Application Server profile.

Procedure
1. On Microsoft Windows operating systems, in IBM Cognos Configuration, click

Actions > Start.
2. On Linux operating systems:

a. Log in to the BI node computer as root.
b. Go to the WebSphere Application Server profile directory when IBM Cognos

BI is running. For example, go to /opt/IBM/WebSphere/AppServer/profiles/
AppSrv01/bin.

c. Enter the following command: ./startServer.sh server1

Note: It can take some time for the IBM Cognos BI services to start for the
first time.

Configuring IBM HTTP Server for IBM Cognos BI
If you manually installed IBM Predictive Customer Intelligence, you must
configure the IBM Cognos Business Intelligence gateway on your web server.

Procedure
1. Go to the HTTP Server conf directory. For example, On Microsoft Windows

operating systems, go to the C:\Program Files (x86)\IBM\HTTPServer\conf
directory. On Linux operating systems, go to the /opt/IBM/HTTPServer/conf
directory.

2. Open the httpd.conf file in a text editor.
3. Add the following lines to file:

ScriptAlias /ibmcognos/cgi-bin "Cognos_installation/cgi-bin"
<Directory "Cognos_installation/cgi-bin">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

Alias /ibmcognos "Cognos_installation/webcontent"
<Directory "Cognos_installation/webcontent">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

Note: Ensure that you add the /ibmcognos/cgi-bin ScriptAlias before the
/ibmcognos Alias.
For example, if you use the default installation location on Microsoft Windows
operating systems, add the following lines:
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ScriptAlias /ibmcognos/cgi-bin "C:/Program Files/IBM/cognos/c10_64/cgi-bin"
<Directory "C:/Program Files/IBM/cognos/c10_64/cgi-bin">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

Alias /ibmcognos "C:/Program Files/IBM/cognos/c10_64/webcontent"
<Directory "C:/Program Files/IBM/cognos/c10_64/webcontent">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

If you use the default installation location on Linux operating systems, add the
following lines:
ScriptAlias /ibmcognos/cgi-bin "/opt/ibm/cognos/c10_64/cgi-bin"
<Directory "/opt/ibm/cognos/c10_64/cgi-bin">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>
Alias /ibmcognos "/opt/ibm/cognos/c10_64/webcontent"
<Directory "/opt/ibm/cognos/c10_64/webcontent">

Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all

</Directory>

4. Save and close the file.
5. On Microsoft Windows operating systems:

a. Click Start > All Programs > IBM HTTP Server V8.5 > Stop HTTP Server.
b. Click Start > All Programs > IBM HTTP Server V8.5 > Start HTTP Server.

6. On Linux operating systems:
a. Go to the IBM HTTP Server bin directory, and enter the following

commands: ./apachectl stop.
b. Enter the following commands: ./apachectl start.

Results

After the services start, you can access the IBM Cognos BI portal by going to
http://servername/ibmcognos in a web browser.

If you did not use port 80 when you installed IBM HTTP Server, you must add the
port number. For example, http://servername:port/ibmcognos, where port is the
port number that you used for the web server. For example, if you used the
solution installer, the default port number is 81, and the URL is
http://servername:81/ibmcognos.

Install software on the Integration Bus node computer
You must install WebSphere MQ and IBM Integration Bus on the IBM Predictive
Customer Intelligence Integration Bus node computer.
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Installing IBM DB2 client software on the Integration Bus node
computer

You must install IBM DB2 client software on the IBM Predictive Customer
Intelligence Integration Bus node computer.

Procedure
1. Go to the DB2 folder where you decompressed the IBM Predictive Customer

Intelligence installation files.
2. On Microsoft Windows operating systems:

a. Double-click v10.5fp5_ntx64_rtcl.exe and follow the steps in the wizard.
b. Click Install.

3. On Linux operating systems:
a. Decompress the v10.5fp5_linuxx64_rtcl.tar.gz file by using the following

command: tar xvf v10.5fp5_linuxx64_rtcl.tar.gz.
b. Go to the rtcl directory.
c. Start the installer: ./db2setup.
d. In the DB2 Setup Launchpad, click Install a Product.
e. Under IBM Data Server Runtime Client Version 10.5 Fix Pack 5, click

Install New.
f. Select Typical for the installation type.
g. Select Install Data Server Runtime Client on this computer.

Installing IBM MQ
Install IBM MQ (formerly WebSphere MQ) on the IBM Predictive Customer
Intelligence Integration Bus node computer.

Note: If you are installing the software as a domain user account instead of a local
administrator, you must provide a domain user account with authority to query
information about user accounts. For more information, see the IBM MQ
documentation (www.ibm.com/support/knowledgecenter/SSFKSJ_8.0.0).

Procedure
1. Log on to the computer where you are installing IBM MQ as a local

administrator on Microsoft Windows operating systems, or as root or a user
with sudo permissions on Linux operating systems.

2. Go to the MQ directory where you decompressed the IBM Predictive Customer
Intelligence server installation files.

3. Decompress the installation files.
v On Microsoft Windows operating systems, decompress

WS_MQ_V8.0.0.2_FOR_WINDOWS_EIMAGE.zip.
v On Linux operating systems, decompress

WS_MQ_V8.0.0.2_LINUX_ON_X86_64_I.tar.gz.
4. On Microsoft Windows operating systems:

a. Go to the directory where you decompressed the files, and double-click
Setup.exe.

b. Click Software Requirements, and ensure that you are using a supported
operating system.

c. Click Network Configuration, and select No for Configuring WebSphere
MQ for Windows domain users.
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d. Click WebSphere MQ Installation, and click Launch IBM Websphere MQ
Installer.

e. Select Typical for the Setup Type, and follow the steps in the wizard to
install the server software.

f. When the installation is complete, click Finish.
The Prepare WebSphere MQ Wizard appears.

g. Follow the steps in the wizard.
When you are prompted to identify a domain controller, select No if you
are installing as a local administrator account, and click Next.

h. Click Finish.
5. On Linux operating systems:

a. Go to the server directory where you decompressed the files.
b. Run the mqlicense.sh script, and accept the agreement. For example, enter

./mqlicense.sh.
c. To install all of the components to the default location, /opt/mqm, enter the

following command: rpm -ivh MQSeries*.rpm.
For more information and examples, see the IBM MQ documentation on
IBM Knowledge Center (www.ibm.com/support/knowledgecenter/
SSFKSJ_8.0.0/com.ibm.mq.ins.doc/q008640_.htm).

Updating IBM MQ
Follow these steps to install the IBM MQ Fix Pack.

Procedure
1. Go to the MQ directory where you decompressed the IBM Predictive Customer

Intelligence server installation files.
2. Decompress the IBM MQ fix pack installation files.
v On Microsoft Windows operating systems, decompress 8.0.0-WS-MQ-

Windows-FP0003b.zip.
v On Linux operating systems, decompress 8.0.0-WS-MQ-LinuxX64-

FP0003b.tar.gz.
3. Run the installer:
v On Microsoft Windows operating systems, double-click WS-MQ-8.0.0-

FP0003.exe.
In the Installation type page, select Load files and apply fix pack.

v On Linux operating systems, install the rpm packages.
To install all of the fix pack files, enter the following command: rpm -ivh
MQSeries*.rpm.
For more information, see the IBM MQ documentation on IBM Knowledge
Center (www.ibm.com/support/knowledgecenter/SSFKSJ_8.0.0/
com.ibm.mq.mig.doc/q008050_.htm)

Installing IBM Integration Bus
Install IBM Integration Bus and IBM Integration Explorer on the IBM Predictive
Customer Intelligence Integration Bus node computer.

Before you begin

Ensure that you install WebSphere MQ before you install IBM Integration Bus.
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On Linux operating systems, you must set up the appropriate user security to
install IBM Integration Bus. For more information, see IBM Knowledge Center
(www.ibm.com/support/knowledgecenter/SSMKHH_10.0.0/
com.ibm.etools.mft.doc/bh26031_.htm).

Procedure
1. Go to the IntegrationBus directory where you decompressed the IBM

Predictive Customer Intelligence server installation files.
2. On Microsoft Windows operating systems, double-click 10.0.0-IIB-WINX64-

FP0001.exe, and follow the steps in the IBM Integration Bus installation wizard.
3. On Linux operating systems:

a. Decompress 10.0.0-IIB-LINUXX64-FP0001b.tar.gz.
b. Copy the iib-10.0.0.1 directory where you decompressed the files to the

program directory. For example, copy the iib-10.0.0.1 directory to the
/opt/IBM directory.

c. In the iib-10.0.0.1 directory, enter ./iib make registry global accept
license and click Accept to accept the license agreement and complete the
software installation.

Tip: After the installation is complete, enter the following to verify the
installation: ./iib verify all.

d. Create a user for the software, and add the user to the mqm and mqbrkrs
groups that were created during the installation. For example, create a user
that is named mqmuser.

Creating a broker and queue manager
You create a broker for IBM Predictive Customer Intelligence from the command
line.

You must assign a user for the broker and queue manager. The user must be a
local administrator user.

On Linux operating systems, some additional settings might be required to
configure WebSphere MQ. For more information, see the WebSphere MQ
documentation (www.ibm.com/support/knowledgecenter/SSFKSJ_8.0.0/
com.ibm.mq.ins.doc/q008520_.htm).

Procedure
1. On Microsoft Windows operating systems, log on to the Integration Bus node

as a local administrator user. On Linux operating systems, change to the user
that you created. For example, change to the mqmuser.

2. Enter the following command to create the queue manager: crtmqm
queue_manager_name.
For example, to create a queue manager that is named pciqmgr on Microsoft
Windows operating systems, enter: crtmqm pciqmgr.
On Linux operating systems, depending on your profile, you might have to go
to the /opt/mqm/bin directory and enter ./crtmqm pciqmgr.

3. Enter the following command to start the queue manager: strmqm
queue_manager_name.
For example, to start the queue manager that is named pciqmgr on Microsoft
Windows operating systems, enter: strmqm pciqmgr.

4. Start the mqsi console:
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v On Microsoft Windows operating systems, go to the installation_location\
IIB\10.0.0.1\server\bin directory, and run mqsiCommandConsole.exe.

v On Linux operating systems, go to the server/bin directory were you copied
the IBM Integration Bus files, and source the mqsiprofile file. For example,
go to the /opt/IBM/iib-10.0.0.1/server/bin directory, and enter the
following command: source mqsiprofile.

5. Create a broker or integration node:
v On Microsoft Windows operating systems, enter the following command to

create a broker: mqsicreatebroker broker_name -i LocalSystem -q
queue_manager_name.

v On Linux operating systems, enter the following command to create an
integration node: mqsicreatebroker broker_name -q queue_manager_name.

For example, to create a broker that is named pcibroker on Microsoft Windows
operating systems, enter: mqsicreatebroker pcibroker -i LocalSystem -q
pciqmgr.

6. Enter the following command to start the broker: mqsistart broker_name For
example, to start a broker that is named pcibroker, enter: mqsistart pcibroker.

7. Enter the following command to create an execution group:
mqsicreateexecutiongroup broker_name -e executiongroupname For example,
to create an execution group that is named pciegroup, enter:
mqsicreateexecutiongroup pcibroker -e pciegroup.

Enabling remote access for the queue manager
For IBM Predictive Customer Intelligence, you must start the queue manager
command line processor to enable remote access to the queue manager.

Procedure
1. On Microsoft Windows operating systems, in the mqsiCommandConsole, enter the

following command to start the queue manager: runmqsc queue_manager_name
2. On Linux operating systems, as the user you created, enter the following

command to start the queue manager: runmqsc queue_manager_name
The command line processor is running after you see the message "Starting
MQSC for queue manager queue_manager_name".

3. Enter the following lines, and press Enter after each line:
START LISTENER

ALTER QMGR CHLAUTH(ENABLED)

SET CHLAUTH(SYSTEM.BKR.CONFIG) TYPE(ADDRESSMAP) ADDRESS('*')
MCAUSER('mqmuser')

SET CHLAUTH(SYSTEM.BKR.CONFIG) TYPE(BLOCKUSER) USERLIST('*NOACCESS')

END

Important: The ADDRESS(’*’) value in the command allows connections from
any IP address. Consider restricting the access to a single computer. For more
information about these values, see the WebSphere MQ documentation.

4. If you want to use a specific port number for the listener, enter the following
command:
runmqlsr -t tcp -m queue_manager_name -p port_number

Ensure that you open the listener port number. If you did not specify a port
number, the default port number is 1414 for the first broker you create.
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Computer firewall settings for the server components after installation
Each IBM Predictive Customer Intelligence node that is installed on a Linux
operating system requires certain ports to be opened for the server components to
operate in a multi-computer solution. You must configure your firewall settings for
each specific node.

Configuring your firewall settings for the Analytics node
computer

On Linux operating systems, you must ensure that certain ports are open on the
Predictive Analytics node computer for IBM Predictive Customer Intelligence.

The following ports must be open:
v 45088
v 58313
v 28054
v tungsten-https
v glrpc
v corbaloc
v 59356
v 9043
v 9060
v 9080

For more information about IBM SPSS Modeler port numbers, see the How many
ports are utilized when a Modeler Client connects to Modeler Server? document
(www.ibm.com/support/docview.wss?uid=swg21488421).

Procedure
1. Log in to the Analytics node computer as the root user or as a user with sudo

permissions.
2. Back up your existing firewall settings. For example, on SUSE Linux operating

systems, enter iptables-save. On Red Hat Enterprise Linux operating systems,
enter /etc/init.d/iptables save.

3. Add rules for the ports with the following commands:
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 45088 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 58313 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 28054 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport tungsten-https -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport glrpc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport corbaloc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 59356 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9043 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9060 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9080 -j ACCEPT

4. Save your firewall settings. For example, on SUSE Linux operating systems,
enter iptables-save. On Red Hat Enterprise Linux operating systems, enter
/etc/init.d/iptables save.

5. Restart your firewall. For example, on SUSE Linux operating systems, enter
SuSEfirewall2 start. On Red Hat Enterprise Linux operating systems, enter
/etc/init.d/iptables restart.
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6. Verify that your changes have been applied with the following command:
iptables -L.
The added ports should appear in the list.

Configuring your firewall settings for the BI node computer
On Linux operating systems, you must ensure that certain ports are open on the
Business Intelligence (BI) node computer for IBM Predictive Customer Intelligence.

The following ports must be open:
v 9362
v vrace
v 9663
v corbaloc
v 9043
v glrpc
v http
v tungsten-https
v 9060
v 9080

Procedure
1. Log in to the BI node computer as the root user or as a user with sudo

permissions.
2. Back up your existing firewall settings. For example, on SUSE Linux operating

systems, enter iptables-save. On Red Hat Enterprise Linux operating systems,
enter /etc/init.d/iptables save.

3. Add rules for the ports with the following commands:
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9362 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport vrace -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9663 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport corbaloc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9043 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport glrpc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport http -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport tungsten-https -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9060 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 9080 -j ACCEPT

4. Save your firewall settings. For example, on SUSE Linux operating systems,
enter iptables-save. On Red Hat Enterprise Linux operating systems, enter
/etc/init.d/iptables save.

5. Restart your firewall. For example, on SUSE Linux operating systems, enter
SuSEfirewall2 start. On Red Hat Enterprise Linux operating systems, enter
/etc/init.d/iptables restart.

6. Verify that your changes have been applied with the following command:
iptables -L.
The added ports should appear in the list.

Configuring your firewall settings for the Integration Bus node
computer

On Linux operating systems, you must ensure that certain ports are open on the
Integration Bus node computer for IBM Predictive Customer Intelligence.
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The following ports must be open:
v boks
v boks_clntd
v boks_servm
v boks_servc
v ibm-mqseries

Procedure
1. Log in to the Integration Bus node computer as the root user or as a user with

sudo permissions.
2. Back up your existing firewall settings. For example, on SUSE Linux operating

systems, enter iptables-save. On Red Hat Enterprise Linux operating systems,
enter /etc/init.d/iptables save.

3. Add rules for the ports with the following commands:
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks_clntd -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks_servm -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport boks_servc -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport ibm-mqseries -j ACCEPT

4. Save your firewall settings. For example, on SUSE Linux operating systems,
enter iptables-save. On Red Hat Enterprise Linux operating systems, enter
/etc/init.d/iptables save.

5. Restart your firewall. For example, on SUSE Linux operating systems, enter
SuSEfirewall2 start. On Red Hat Enterprise Linux operating systems, enter
/etc/init.d/iptables restart.

6. Verify that your changes have been applied with the following command:
iptables -L.
The added ports should appear in the list.

Configuring your firewall settings for the data node computer
You must ensure that certain ports are open on the data node computer for IBM
Predictive Customer Intelligence.

The following ports must be open:
v ibm-db2
v db2c_db2inst1
v 50001

Procedure
1. Log in to the data node computer as the root user or as a user with sudo

permissions.
2. Back up your existing firewall settings. For example, on SUSE Linux operating

systems, enter iptables-save. On Red Hat Enterprise Linux operating systems,
enter /etc/init.d/iptables save.

3. Add rules for the ports with the following commands:
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport ibm-db2 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport db2c_db2inst1 -j ACCEPT
iptables -I INPUT -m state --state NEW -m tcp -p tcp --dport 50001 -j ACCEPT

4. Save your firewall settings. For example, on SUSE Linux operating systems,
enter iptables-save. On Red Hat Enterprise Linux operating systems, enter
/etc/init.d/iptables save.
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5. Restart your firewall. For example, on SUSE Linux operating systems, enter
SuSEfirewall2 start. On Red Hat Enterprise Linux operating systems, enter
/etc/init.d/iptables restart.

6. Verify that your changes have been applied with the following command:
iptables -L.
The added ports should appear in the list.
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Chapter 5. Client component installation

There are several client components that are included with IBM Predictive
Customer Intelligence. You can install the components as you require.

Important: The client components must be installed on computers running the
Microsoft Windows 7 64-bit operating system. Install the client components only
after you successfully install the server components.

Client components
Client components for IBM Predictive Customer Intelligence are available to be
installed.

For more information about installing and using the client components, see the
documentation provided with the component.

Database connectivity

IBM Data Server Runtime Client must be installed to enable connectivity to the
databases.

Predictive modeling and decision management

Install the following components so that you can modify or create predictive
models and perform decision management tasks:
v IBM SPSS Collaboration and Deployment Services Deployment Manager
v IBM SPSS Modeler Client Premium

Optionally, install the following components:
v IBM SPSS Statistics Client
v IBM SPSS Collaboration and Deployment Services Documentation
v IBM Analytical Decision Management Documentation
v IBM SPSS Modeler Premium Documentation

Business intelligence

Install IBM Cognos Framework Manager so that you can modify the reporting
model metadata.

Note: You must install IBM Data Server Runtime Client before you can use IBM
Cognos Framework Manager. Ensure that you restart the computer after you install
the IBM Data Server Runtime Client, and that you catalog the databases before you
use Framework Manager. Framework Manager is a 32-bit application, and requires
the 32-bit IBM Data Server Runtime Client.

Optionally, install the following components:
v IBM Cognos Business Intelligence Samples
v IBM Cognos Dynamic Query Analyzer
v IBM Cognos for Microsoft Office
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v IBM Cognos Lifecycle Manager
v IBM Cognos Software Development Kit
v IBM Cognos Supplementary Languages Documentation

Integration Bus

Install the following components:
v Integration Bus Toolkit
v WebSphere MQ for Windows

Use the Integration Bus Toolkit to create, manage, deploy, and delete message
flows and associated resources in a development environment.

Downloading and decompressing the client installation files
You must download the IBM Predictive Customer Intelligence client installation
files from IBM Passport Advantage. You must install each client component
manually.

For more information about the files that you must download, see Downloading
IBM Predictive Customer Intelligence 1.1 (http://www.ibm.com/support/
docview.wss?uid=swg24040382).

Procedure
1. Access the IBM Passport Advantage web site.

Tip: If you receive an error, try using a different web browser to access
Passport Advantage.

2. Sign in and navigate to the software downloads page.
3. Find the eImages for IBM Predictive Customer Intelligence.
4. Download an eImage by selecting the check box beside the name. When the

download is complete, a Download Complete message is displayed. The
location of the downloaded files is displayed in the message window.

5. Decompress the eImage files.
Decompress the prd_cust_intel_clt_1.1_1_win_en.tar.gz and
prd_cust_intel_clt_1.1_2_win_en.tar.gz files.

6. Copy the component installation files to each computer on which you want to
install the component.

Installing IBM SPSS Collaboration and Deployment Services
Deployment Manager

You must install IBM SPSS Collaboration and Deployment Services Deployment
Manager to complete the configuration of IBM Predictive Customer Intelligence.

Procedure
1. Go to the directory where you decompressed the client installation files.
2. In the SPSS_CDS directory, decompress spss_cnds_depmgr_64b_7.0_win_ml.zip.
3. In the Deployment_Manager_64 directory, double-click install.exe.
4. Follow the steps in the wizard to install the client component.
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For more information about the installation of Deployment Manager, see the
IBM SPSS Collaboration and Deployment Services Deployment Manager 7
Installation (www.ibm.com/support/knowledgecenter/SS69YH_7.0.0/
cads_manager_install_ddita/model_management/thick/
thick_install_overview.dita).

Adding server connections for IBM SPSS Collaboration and
Deployment Services

You must add a connection to your IBM SPSS Collaboration and Deployment
Services repository in the IBM SPSS Collaboration and Deployment Services
Deployment Manager client.

After you add the connection, the server folder displays in the Content Explorer,
and you can log in to the server.

Procedure
1. Click Start > All Programs > IBM SPSS Collaboration and Deployment

Services Deployment Manager 7.0 > Deployment Manager 7.0.
2. Click File > New > Content Server Connection.
3. In the Connection Name box, enter a name for your Collaboration and

Deployment Services repository. For example, enter SPSS.
4. In the Server URL box, enter the name or IP address of the Predictive

Analytics node computer and the port number, and click Finish. For example,
enter http://servername:9080.
You can use the servername or the IP address for the Analytics node computer.
The default port number that is used by the WebSphere Application Server
instance is 9080. If another port number was used, ensure that you use the
correct port number.

5. Double-click the connection name that you created.
6. In the User ID box, enter the SPSS admin user that you used when you

installed IBM SPSS Collaboration and Deployment Services Server.
7. In the Password box, enter the SPSS admin user's password.
8. Click OK.
9. Click File > New > Administered Server Connection.

10. In the Name box, enter a name for the repository server, and click Next. For
example, enter SPSS.

11. In the Server URL box, enter the name or IP address of the Predictive
Analytics node computer and the port number, and click Finish. For example,
enter http://servername:9080.
The default port number that is used by the WebSphere Application Server
instance is 9080. If another port number was used, ensure that you use the
correct port number.

12. Double-click the server connection name that you created.
13. In the User ID box, enter the SPSS admin user that you used when you

installed IBM SPSS Collaboration and Deployment Services Server.
14. In the Password box, enter the SPSS admin user's password.
15. Click OK.
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Adding users and groups and server definitions to IBM SPSS
Collaboration and Deployment Services

You use IBM SPSS Collaboration and Deployment Services Deployment Manager
to manage users and groups. You must add an administrator user and a modeler
user for IBM Predictive Customer Intelligence. You must also add a server
definition.

Procedure
1. In Deployment Manager, on the Content Explorer tab, double-click the SPSS

connection that you created. Log in if you are prompted to.
2. Expand Resource Definiton.
3. Add an administrator user.

a. Right-click Credentials, and click New > Credentials Definition.
b. In the Name box, enter admin, and click Next.
c. In the User ID box, enter admin.
d. In the Password box, enter a password.
e. In the Security Provider box, select Local User Repository.
f. Click Finish.

4. Add a modeler user. The user is a local user account on the Predictive
Analytics node computer.
a. Right-click Credentials, and click New > Credentials Definition.
b. In the Name box, enter modeler, and click Next.
c. In the User ID box, enter a local user on the Predictive Analytics node

computer.
d. In the Password box, enter a password for that user.
e. In the Security Provider box, select Local User Repository.
f. Click Finish.

5. Add a Content Repository Server server definition.
a. In Resource Definitions, right-click Servers, and click New > Server

Definition.
b. In the Name box, enter localhost.
c. In the Type box, select Content Repository Server.
d. Click Next.
e. In the Server URL box, enter the name or IP address of the Analytics node

computer and the port number, and click Finish. For example, enter
http://servername:9080

The default port number that is used by the WebSphere Application Server
instance is 9080.

6. Add a Modeler Server definition.
a. Right-click Servers, and click New > Server Definition.
b. In the Name box, enter modeler, and click Next.
c. In the Type box, select Modeler Server, and click Next.
d. In the Host box, enter the name or IP address of the Analytics node

computer.
e. In the Port box, enter 28054.

Note: If the connection is not successful, restart Modeler Server.
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f. In the Default data path box, enter the path to the data folder on Analytics
node computer. For example, enter C:\Program Files\IBM\SPSS\
ModelerServer\17.

g. Click Finish.
7. On the Server Administration tab, expand Users and Groups, and double-click

Local User Repository.
8. Click New Group.

a. In Group Name, enter administrator.
b. Select Show all available users.
c. In Available Users, select admin, and move the user to the Group contains

Users box.
d. Click OK.

Installing IBM SPSS Modeler Client
You must install IBM SPSS Modeler Client to configure the Next Best Action
Optimizer connectors for IBM Predictive Customer Intelligence.

To use SPSS Modeler Client, you must obtain a license. For more information
about obtaining a Modeler Client license, see the Welcome to GetSPSS web site
(www.ibm.com/software/analytics/spss/support/get_spss.html).

Procedure
1. Go to the directory where you decompressed the client installation files.
2. Install SPSS Modeler client.

a. In the SPSS_Modeler_Client directory, decompress
spss_modgld_keyls_64b17.0_win_ml.zip.

b. In the decompressed folder, double-click setup.exe.
c. Follow the steps in the wizard to install the client component.

3. Install the fix pack.
a. In the SPSS_Modeler_Client directory, decompress 17.0-IM-S17MODELERC-

WIN64-FP001.zip.
b. In the decompressed folder, double-click setup.exe.

4. Install the interim fix.
a. In the SPSS_Modeler_Client\Interim_Fix directory, decompress

17.0-IM-S17MODELERC-WIN64-FP01-IF011.zip.
b. In the decompressed folder, follow the steps in 17.0-IM-S17MODELERC-WIN64-

FP01-IF011.txt to apply the fix.

Installing the Integration Bus client
Install the IBM Predictive Customer Intelligence Integration Bus client.

Procedure
1. Go to the directory where you decompressed the client installation files.
2. In the IntegrationBus directory, decompress the installation file that is named

IIB_10.0.0.1_WINDOWS_X86-64.zip.
3. In the decompressed directory, go to the EAsmbl_Image directory and

double-click IIBSetup10.0.0.1.exe.
4. Follow the directions, and click Install.
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Installing Framework Manager for IBM Predictive Customer Intelligence
Install IBM Cognos Framework Manager to create or edit models and publish
packages for IBM Cognos Business Intelligence.

On Microsoft Windows operating systems, if you install Framework Manager to
the same computer as where you installed IBM Cognos Business Intelligence, you
must install Framework Manager to a different location. Framework Manager is a
32-bit application and cannot be installed to the same location as the 64-bit IBM
Cognos Business Intelligence server components.

Procedure
1. Go to the directory where you decompressed the client installation files.
2. In the BI directory, decompress fm_10.2.2_win_ml.tar.gz, and then

decompress fm_10.2.2_win_ml.tar.

Important: Ensure that you decompress the installation files to a different
location than any other IBM Cognos BI installation files. Some directories are
overwritten if you use the same location.

3. Go to the win32 directory, and double-click the issetup.exe file.
4. Follow the steps in the wizard to install the product.
5. When notified with an information message about installing the

Supplementary Languages Documentation, click OK

6. On the last page of the installation wizard, select Start IBM Cognos
Configuration to configure Cognos Framework Manager.

7. Click Finish.
8. In IBM Cognos Configuration, in the Explorer panel, select Environment.
9. In the Gateway URI value, change localhost to the name or IP address of the

Business Intelligence (BI) node computer.
If you installed the server components on Red Hat Enterprise Linux using the
solution installer and you did not configure IBM HTTP Server, the Gateway
URI should be http://servername:9080/p2pd/servlet/dispatch.

10. In the Dispatcher URI for external applications value, change localhost to
the name or IP address of the Business Intelligence (BI) node computer.

11. In the Dispatcher URI for external applications value, change 9300 to 9080.
9080 is the port number that is used by WebSphere Application Server for IBM
Cognos Business Intelligence.

12. Click File > Save.
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Chapter 6. Artifacts installation

The IBM Predictive Customer Intelligence artifacts include Next Best Action
Optimizer (NBAOPT) and IBM Enterprise Marketing Management (EMM)
connectors. You must copy the connectors to the computers on which the
components are installed.

The artifacts also include the Analytic Solution Foundation.

Downloading and decompressing the artifact installation files
The IBM Predictive Customer Intelligence artifact installation files are provided
with the solution installation files. You must deploy the artifact content manually.

For more information about the files that you must download, see Downloading
IBM Predictive Customer Intelligence 1.1 (http://www.ibm.com/support/
docview.wss?uid=swg24040382).

Procedure
1. Access the IBM Passport Advantage web site.

Tip: If you receive an error, try using a different web browser to access
Passport Advantage.

2. Sign in and navigate to the software downloads page.
3. Find the eImages for IBM Predictive Customer Intelligence.
4. Download an eImage by selecting the check box beside the name. When the

download is complete, a Download Complete message is displayed. The
location of the downloaded files is displayed in the message window.

5. Decompress the artifact eImage file prd_cust_intel_art_1.1_win_en.tar.gz.

Integration with Next Best Action Optimizer
You can integrate IBM Next Best Action Optimizer (NBAOPT) with your IBM
Predictive Customer Intelligence solution to further optimize your recommended
actions.

NBAOPT segregates customers by lifetime value, and then provides
recommendations to retain customers.

Next Best Action Optimizer (NBAOPT)

Many companies across many industries (such as telecommunications, retail, and
insurance) classify customers into different groups for marketing campaigns,
targeted actions, and optimized use of resources. Classification helps Customer
Relationship Management (CRM) departments to conduct promotional campaigns
to retain customers, cross-sell, and up sell.

Traditional methods of classifying customers use standard customer and product
segmentation strategies along with manually defined rules on an ad hoc basis.
Often, the processes that govern these methods do not consider the following
factors:
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v Uncertainty in the behavior of the target entities
v Value and response to the prior actions
v The current state of the entity in relation to the organization
v Expected long-term rewards

NBAOPT addresses these problems by using a scalable data analytics and
optimization engine. NBAOPT automatically generates an action allocation policy
that is optimized for long term expected reward, subject to resource, legal and
business constraints. The allocation policy can be used for targeted marketing,
CRM, debt collection, retention, cross-sell, up-sell, and so on.

For more information, see Next Best Action Optimizer (NBAOPT) Lifetime Value
Maximizer & Collections Maximizer User Guide.

How NBAOPT is used in a Predictive Customer Intelligence
solution

NBAOPT works alongside IBM SPSS Modeler. When the NBAOPT connector is
installed, NBAOPT connector items are added to the IBM SPSS Modeler menu so
that you can run the NBAOPT Studio. In NBAOPT Studio, you set up the data for
analysis. Then, you start the analysis, which performs the following actions:
v Segregates customers by lifetime value
v Provides recommended actions to retain customers, which are based on their

lifetime value segment

This analytical process exports model nuggets in PMML format (Predictive Model
Markup Language, an XML-based file format). Model nuggets can be used for
scoring data for prediction, or analyzing data. From the PMML file that is created
in NBAOPT Studio, you create an enhanced SPSS streaming SPSS Modeler that
contains segmentation and recommendations. You can also generate visualizations
of the results.

Configuring the Next Best Action Optimizer connectors
Use the Next Best Action Optimizer (NBAOPT) connectors with IBM SPSS Modeler
for IBM Predictive Customer Intelligence. With the NBAOPT connectors installed,
you can run NBAOPT Studio from IBM SPSS Modeler.

You must copy the NBAOPT connectors to the location where IBM SPSS Modeler
Client is installed.

Procedure

Copy the pci.NBAOPT directory where you decompressed the artifacts to the
ext\lib directory where IBM SPSS Modeler Client is installed. For example, copy
the pci.NBAOPT directory to the C:\Program Files\IBM\SPSS\Modeler\16\ext\lib
directory.
After you copy the folder, you should have the following path:
C:\Program Files\IBM\SPSS\Modeler\16\ext\lib\pci.NBAOPT

Open NBAOPT Studio from IBM SPSS Modeler
You can open IBM Next Best Action Optimizer (NBAOPT) Studio from IBM SPSS
Modeler.
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Before you begin

NBAOPT, and the NBAOPT connector must be installed. For information on
installing the NBAOPT connector, see IBM Predictive Customer Intelligence
Installation Guide.

Procedure
1. In IBM SPSS Modeler, click Tools > NBA Optimizer, and select NBAOPT

Studio.
2. The first time that you start NBAOPT Studio, you are asked to specify the

location of the NBAOPT Studio executable file. Click Browse to locate the file,
and click Select.

What to do next

In NBAOPT Studio, you set up data for analysis and generate the PMML files that
the NBAOPT connector creates the IBM SPSS streams from. For information on
how to use NBAOPT Studio, see the Next Best Action Optimizer (NBAOPT) Lifetime
Value Maximizer & Collections Maximizer User Guide, and the Next Best Action
Optimizer (NBAOPT) Lifetime Value Maximizer & Collections Maximizer Tutorial Guide.

Generating streams from PMML files
IBM Next Best Action Optimizer (NBAOPT) model results are generated in PMML
format, an XML format that can be used by a number of tools, including IBM SPSS
Modeler. The NBAOPT engine generates SPSS-compliant PMML files for scoring.

Procedure
1. In IBM SPSS Modeler, click Tools > NBA Optimizer, and select Generate

Stream from the PMML Files.
2. Browse for the PMML file location, for example: C:\NBAOPT\Configurations\

demo_insurance\Modeling\Model1\SPSS. If multiple PMML files are present in
the folder, multiple streams are generated.
The generated streams can have multiple branches. The number of branches
depends on the number of action groups that are specified for a configuration.
For example, if there are two actions, Channel and Product, two actions are
specified during the scoring process.

3. Click Generate Stream.
In the example, two streams are generated and are named based on the PMML
file names. The number of streams created is dependent on the number of
PMML files.
These files are stored in <model_folder>/SPSS.

What to do next

After the stream is generated, and before you run the stream, configure the stream.
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Example SPSS stream
This is an example of an IBM SPSS stream that is generated from PMML files

Database source node
The database source node is used to import data from ODBC sources.

Model nuggets
A model nugget is a container for a model. It is used for scoring data to
generate predictions or to allow further analysis of the model properties.

The nuggets are imported via PMML files that are generated from the
NBAOPT engine.

Filler nodes
Filler nodes are used to replace field values and change storage.

Filter nodes
Filter nodes are used to filter (discard) fields, rename fields, and map fields
from one source node to another.

Derive node
The derive node gives you the ability to create new fields from existing
fields.

Merge node
The merge node merges multiple action group nugget branches.

For more information, see IBM SPSS Modeler Help (www.ibm.com/support/
knowledgecenter/SS3RA7_17.0.0/modeler_mainhelp_client_ddita-gentopic1.dita).

Figure 2. Example IBM SPSS stream generated from PMML files
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Configuring the IBM SPSS stream
When an IBM SPSS stream is generated from PMML files, you must configure the
stream before you can deploy it.

Procedure
1. In IBM SPSS Modeler, open the stream to configure.
2. Double-click the database source node and add the Data source name and the

Table name to the database source node (mandatory).
3. Verify the database settings by clicking Preview.
4. Double-click the filter nodes to exclude fields that are not to be included in the

stream.
5. Double-click the merge node to set the merge key (mandatory if there is a

merge node). In the Merge tab, move fields into the Keys for merge list.
6. Set the filler node to replace database blank values (optional). For example, you

can replace blank values with an empty string, such as to_string(@FIELD).
7. Add extra nodes to the stream if required.

For example, if a field has a different data type in the database table, and the
NBAOPT Studio Mining Type configuration, you must add a derive node to
convert the character type to numeric.
Check that the derive field name matches the model nugget field name, if it
does not, change the derive field name to match.

8. Run the stream to verify the stream output table. In IBM SPSS Modeler, from
the Tools menu, click Run.
For more information, see IBM SPSS Modeler Help (www.ibm.com/support/
knowledgecenter/SS3RA7_17.0.0/clementine/buildingstreams_container.dita).

What to do next

Add the configured stream to the IBM Collaboration and Deployment Services
repository file, and configure the scoring service. For more information, see IBM
SPSS Collaboration and Deployment Services User Guide (www.ibm.com/support/
knowledgecenter/SS69YH_7.0.0/cads_manager_ddita/model_management/thick/
scoring_configuration_overview.dita).

After the scoring service is configured, the IBM Collaboration and Deployment
Services can access the scoring service, and other applications can use the scoring
service to get the next best action based on the input fields values.

Integration with the IBM Enterprise Marketing Management suite
IBM Predictive Customer Intelligence integrates with the IBM Enterprise Marketing
Management suite. The components that Predictive Customer Intelligence
integrates with are IBM Campaign, IBM Interact and IBM Marketing Platform.

IBM Campaign
IBM Campaign is a web-based Enterprise Marketing Management (EMM)
solution that enables users to design, run, and analyze direct marketing
campaigns.

IBM Interact
With IBM Interact, users can retrieve personalized offers and customer
profile information in real-time.
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IBM Marketing Platform
The IBM Marketing Platform provides security, configuration, and
dashboard features for IBM Enterprise Marketing Management products.

Configuring the Enterprise Marketing Management connectors
If you are using IBM Enterprise Marketing Management (EMM), IBM Predictive
Customer Intelligence provides two connectors between IBM Interact and IBM
SPSS Collaboration and Deployment Scoring Service. The connectors override the
score that is supplied by the IBM EMM campaign and also extend IBM Interact's
learning module to monitor visitor actions and propose optimal offers.

To configure the connectors, you must copy them to the EMM installation location.

Do not configure the connectors if you are not using IBM Enterprise Marketing
Management.

Important: The EMM connectors can be used only with IBM Enterprise Marketing
Management version 9.0 or 9.1.

Procedure

Copy the artifacts from the EMMConnectors directory where you decompressed the
artifacts to the Connectors directory where EMM is installed. For example,
Microsoft Windows operating systems, copy the files to the
IBM_EMM_Interact_install_location\Connectors directory. On Linux operating
systems, copy the files to the /opt/IBM/EMM/Interact/Connectors.

IBM Interact connectors
IBM Interact integrates with customer facing systems (touchpoints) such as web
sites and call centers, and enables users to retrieve personalized offers and visitor
profile information in real time.

IBM Predictive Customer Intelligence provides two connectors between IBM
Interact and IBM SPSS Collaboration and Deployment Scoring Service:
v The External callout connector calls an SPSS model at runtime, and is contained

within the expression of an advanced rule for a Marketer Score, overriding the
score supplied by the IBM Enterprise Marketing Management campaign.

v The External learning connector extends IBM Interact's native learning module
to monitor visitor actions and propose optimal offers. It prioritizes IBM
Campaign offers based on an SPSS model's prediction of their final score. The
connector passes specific configurable parameters as input to the SPSS Scoring
Service.

The External Learning connector
The External Learning connector is used to override the marketer's score in IBM
Interact with a customized score from IBM SPSS Collaboration and Deployment
Services. The customized score is used to prioritize the offers for customers. When
the customer facing touchpoint puts in an offer request to IBM Interact, it triggers
the external learning connector. A touchpoint can be a call center web application,
a mobile application, a batch command, and so on.

The following process is initiated:
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1. The connector Java class calls the IBM SPSS Collaboration and Deployment
Services scoring service that is based on the configuration setting of the current
channel.

2. If, in the configuration file, the current channel is set to be monitored, the
corresponding channel in the IBM SPSS Scoring Service is configured to update
the channel offers' score number.

3. The External Learning connector uses IBM Interact runtime session profile data
as SPSS Scoring Service input parameters.

4. The connector gets the scores from the SPSS scoring service and overwrites the
Interact offers scores with the SPSS scores.

5. After the Interact offer's score is updated by the SPSS score, the offer list is
sorted by the new final scoring number in descending order. The offer list is
returned as the final offer list.

Configuring the External Learning connector configuration file
An interactive channel is a touchpoint with your customer, such as a call center or
a website. It is the communication channel with your customers. By using the IBM
Interact API, you integrate IBM Interact with your touchpoints to present offers to
customers based on their action in the touchpoint.

Figure 3. How the external learning connector works
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Procedure
1. Stop the IBM Enterprise Marketing Management (EMM) runtime server.
2. Create the following file structure on your IBM EMM server:

For Windows operating systems:
v <EMM Interact Installation Folder>\connectors

v <EMM Interact Installation Folder>\logs

By default, the installation folder is \IBM\EMM\Interact
For Linux operating systems:
v <EMM Interact Installation Folder>/connectors/

v <EMM Interact Installation Folder>/logs

By default, the installation folder is /opt/IBM/EMM/Interact
3. Copy the LearningConnector_config.properties file and

UnicaSPSSLearningConnector.jar to the Connectors folder.
4. Edit the LearningConnector_config.properties file for your environment. For

more information, see “Sample External Learning connector configuration file.”
5. In the runtime environment for the IBM Marketing Platform tool, select

Settings, Configuration, and expand IBM EMM, Interact, and offerserving.
6. Set optimizationType to ExternalLearning.
7. Configure the External Learning class:

a. Under offerserving, select External Learning Config.
b. Set class to the Java class name. For example:

<com.ibm.unica.connector.>SPSSLearning

c. Set classPath to the Java JAR file location. For example, for Windows:
<Interact_Install_location>\UnicaSPSSLearningConnector.jar, and for
Linux: <Interact_Install_location>/UnicaSPSSLearningConnector.jar

8. Restart the IBM EMM runtime server for these changes to take effect.

Sample External Learning connector configuration file

The following example is a sample External Learning connector configuration file.
Modify this sample for your environment.
CADS_ADDRESS=<Collaboration_deployment_services_server_address>
CADS_PORT=9080
CADS_USER=admin
CADS_PASSWORD=spss
UNICA_INTERACTJSSERVICE_URL=http://<IBM_EMM_URL>:9080/
interact/servlet/InteractJSService
LEARNING_CHANNELS=Mobile,Mob;Telco,Telco Call Center;Insurance,Insurance

SERVICENAME_Telco=ExternalLearning
INPUTTABLE_Telco=db2admin@TELCO
PARAMETERS_Telco=CUSTOMERID,double,CUSTOMERID;CHURN_SCORE,double,CHURN_SCORE;
CUSTOMER_LIFE_TIME_VALUE_RATIO,double,CUSTOMER_LIFE_TIME_VALUE_RATIO;
SENTIMENT_SCORE,double,SENTIMENT_SCORE;NUMBER_OF_CLOSED_COMPLAINTS,integer,
NUMBER_OF_CLOSED_COMPLAINTS;NUMBER_OF_OPEN_COMPLAINTS,integer,
NUMBER_OF_OPEN_COMPLAINTS;GROUP_LEADER_TYPE2,double,GROUP_LEADER_TYPE2;
GROUP_LEADER_CONFIDENCE_TYPE2,DOUBLE,GROUP_LEADER_CONFIDENCE_TYPE2;
INFLUENCER_SCORE,double,INFLUENCER_SCORE;SEGMENT,string,SEGMENT;
RESPONSE,integer,#VALUE#null;OFFER_CATEGORY_NAME,string,#VALUE#null
OUTPUTNAME_Telco=FinalScore
INPUT_OFFERNAMECOL_Telco=OFFER

SERVICENAME_Insurance=INSU_CHURN
INPUTTABLE_Insurance=INSURNC.INSURANCE_VIEW
PARAMETERS_Insurance=POLICYHOLDER_ID,integer,#VALUE#1016091;GENDER,string,#VALUE#F;
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EMPLOYMENT_STATUS,string,#VALUE#employed;INCOME,double,#VALUE#144541;
HOUSEHOLD_NUMBER_OF_CHILDREN,integer,#VALUE#2;HOUSEHOLD_NUMBER_OF_INSURED_CARS,integer,
#VALUE#0;NUMBER_OF_POLICIES_IN_HOUSEHOLD,integer,#VALUE#1;HOUSEHOLD_TENURE,double,
#VALUE#5.15;INSURANCE_LINES,integer,#VALUE#1;LATEST_NOTE_ATTITUDE,double,#VALUE#3;
AVERAGE_NOTE_ATTITUDE,double,#VALUE#2;NUMBER_OF_CLAIMS_FILED,double,#VALUE#2;
CUSTOMER_FINANCIAL_SEGMENT,string,#VALUE#Financially Sophisticated;
OUTPUTNAME_Insurance=CHURN_SCORE
INPUT_OFFERNAMECOL_Insurance=#NONE#

SERVICENAME_Mobile=SequenceAnalysis
INPUTTABLE_Mobile=NBA.CUSTOMER_RELATIONSHIP_HISTORY
PARAMETERS_Mobile=CUSTOMERID,integer,CUSTOMERID;SEQUENCE,integer,#VALUE#1;
PRODUCT,string,LASTOFFER;
OUTPUTNAME_Mobile=RECOMMENDATION
INPUT_OFFERNAMECOL_Mobile=#NONE#

For information on how to modify this file, see “Add a new learning channel,” and
“Add an IBM SPSS Scoring Service to an offer (External Learning connector).”
Also, see IBM Interact Administrator's Guide.

Add a new learning channel
To add a new learning channel, add the learning name and channel name to the
LEARNING_CHANNELS parameter.

For example:

LEARNING_CHANNELS=Mobile,Mob;Telco,Telco Call Center;Insurance,Insurance

Where:
v The first value is the learning channel name (Telco), the second value is the

channel name (Telco Call Center).
v Values are separated by commas and parameters are separated by semi-colons.

Add an IBM SPSS Scoring Service to an offer (External Learning
connector)
To add an IBM SPSS Scoring Service, add the following parameters to the
LearningConnector_config.properties file.
v SERVICENAME_%THE LEARNING NAME%

v INPUTTABLE_%THE LEARNING NAME%

v PARAMETERS_%THE LEARNING NAME%

v OUTPUTNAME_%THE LEARNING NAME%

v INPUT_OFFERNAMECOL_%THE LEARNING NAME%

The parameter name has three elements that are separated by commas:
v The input parameter name.
v The data type and the source column name (profile table column name).
v The direct value that uses #VALUE# to identify it. You can also use the channel

profile table column value as SPSS input parameter values.

You can set the input parameter to null, by using #VALUE# of null, for example:

RESPONSE,integer,#VALUE#null;OFFER_CATEGORY_NAME,string,#VALUE#null

Parameters are separated by semicolons.
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The value for OUTPUTNAME_%THE LEARNING NAME% can be "DEFAULT". You do not
need to provide the name of the output column name; the first output parameter is
taken as the output score results.

For example, you can set the output columns with either method that is shown,
and you get the same result:
v OUTPUTNAME_Mobile=RECOMMENDATION

v OUTPUTNAME_Mobile=DEFAULT

The value of INPUT_OFFERNAMECOL_%THE LEARNING NAME% can be an input parameter
column name or "#NONE#". When the value is set to a specific input parameter
column name, the External Learning connector passes the IBM Interact channel
offer name to the corresponding column for the SPSS scoring service as an input
parameter to get the specific offer name score to update the corresponding offer for
Interact channel final score. When the input offer name column is set to
"#NONE#", only the first IBM Interact channel offer final score is updated with the
IBM SPSS Scoring Service score.

For example, when three offers are requested from a touchpoint, IBM Interact
returns three offers, shown in the following table.

Table 1. Example showing the scores returned from IBM Interact and from the IBM SPSS
Scoring Service

Offer name IBM Interact final score IBM SPSS score

Premium phone 90 85

Premium family plan 80 88

Add a second line free 70 65

The External Learning connector passes all of the configured parameters and the
offer name to the SPSS Scoring Service. It returns three new scores: 85, 88 and 65
from IBM SPSS for these three offers.

The IBM SPSS score is used as the final score and is sorted in descending order,
shown in the following table.

Table 2. Example showing the final score and sort order

Offer name IBM Interact final score

Premium family plan 88

Premium phone 85

Add a second line free 65

The External Callout connector
By using the External Callout connector, you can override a single offer's score by
calling an IBM SPSS Scoring Service. Also, using the External Callout connector,
you can invoke the IBM SPSS score to present eligible offers.

To enable the External Callout connector, perform the following steps:
1. Register the External Callout connector in the IBM Enterprise Marketing

Management (EMM) configuration.
2. Add the IBM SPSS Scoring Service information to the External Callout

connector's configuration file.
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Configuring the External Callout connector
IBM Interact helps customers get offers based on user characteristics and history.
The offers are generated by algorithms. You can configure IBM Interact to override
the offer's score by calling an SPSS Model.

Procedure
1. Stop the IBM Enterprise Marketing Management (EMM) runtime server.
2. Create the following file structure on your IBM EMM server:
v <EMM Interact Installation Folder>/connectors/

v <EMM Interact Installation Folder>/logs

By default, the installation folder is /opt/IBM/EMM/Interact
3. Copy the ExternalConnector_config.properties file and

UnicaSPSSExternalConnector.jar to the Connectors folder.
4. Edit the ExternalConnector_config.properties file for your environment. For

more information, see “Sample External Callout connector configuration file”
on page 82.

5. In the runtime environment for the IBM Marketing Platform, select Settings,
Configuration, and expand IBM EMM, Interact, Flowchart, and External
Callouts.

6. To set the configuration properties, click External Callout and configure the
parameters as follows:

Category name
GetSPSSScore

class com.ibm.unica.connector.GetSPSSScore

classpath

v <EMM Interact Installation Folder>/connectors/
UnicaSPSSExternalConnector.jar

By default, the installation folder is /opt/IBM/EMM/Interact
Save the changes.

7. Select the campaign settings, by clicking Campaign, Campaigns.
8. Select the link for the campaign that you are configuring, such as Insurance.
9. Click the <Campaign name> Strategy tab, for example, Insurance Strategy.

10. For each Eligible Segment, such as Insurance High Risk Customer, Insurance
High Value Customer, click Adv Opt.

11. In the Advanced Options window, select Use the following expression as the
marketing score.

12. In the Expression box, type an expression to be used for the marketing score.
You can either use modified versions of the examples shown, or from the
Functions, Variables and Operators list, select Extension Functions,
EXTERNALCALLOUT and click Use. For more information, see "About the
ExternalCallout API" topic in the IBM Interact 9.1 Administrator's Guide.
Example expression for an Insurance campaign:
NUMBER(EXTERNALCALLOUT(’GetSPSSScore’,’GetChurnScore’,db2admin.CUSTOMERID,
db2admin.GENDER,db2admin.EMPLOYMENT_STATUS,db2admin.INCOME,1,
db2admin.NUMBER_OF_INSURED_CARS,db2admin.NUMBER_OF_POLICIES_IN_HOUSEHOLD,
db2admin.HOUSEHOLD_TENURE,db2admin.INSURANCE_LINES,db2admin.LATEST_NOTE_ATTITUDE,
db2admin.AVERAGE_NOTE_ATTITUDE,db2admin.NUMBER_OF_CLAIMS_FILED,
db2admin.CUSTOMER_SEGMENTS,0))*100

The External Callout API has a mandatory number of configurable arguments
that must be provided. The mandatory number of arguments setting in the
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configuration file is as set in the value of the property
ExternalConnector_NumberOfArguments. In the example shown, the value is 15.
When there are fewer SPSS scoring service input parameters than the
configure setting of ExternalConnector_NumberOfArguments, add ",0" to the
expression to ensure that there are the same number of arguments in the
external callout expression.

13. Deploy the changes to the server.
14. Restart the IBM EMM runtime server.

Sample External Callout connector configuration file

The following example is a sample External Callout connector configuration file.
Modify this sample for your environment.
CADS_ADDRESS=<Collaboration_deployment_services_server_address>
CADS_PORT=9080
CADS_USER=admin
CADS_PASSWORD=spss
ExternalConnector_NumberOfArguments=15

SERVICENAME_GetChurnScore=INSU_CHURN
INPUTTABLE_GetChurnScore=INSURNC.INSURANCE_VIEW
PARAMETERS_GetChurnScore=POLICYHOLDER_ID,double;GENDER,string;
EMPLOYMENT_STATUS,string;INCOME,double;HOUSEHOLD_NUMBER_OF_CHILDREN,integer;
HOUSEHOLD_NUMBER_OF_INSURED_CARS,integer;NUMBER_OF_POLICIES_IN_HOUSEHOLD,integer;
HOUSEHOLD_TENURE,double;INSURANCE_LINES,integer;LATEST_NOTE_ATTITUDE,double;
AVERAGE_NOTE_ATTITUDE,double;NUMBER_OF_CLAIMS_FILED,double;
CUSTOMER_FINANCIAL_SEGMENT,string;
OUTPUTNAME_GetChurnScore=CHURN_SCORE

SERVICENAME_GetCreditRating=dWStream
INPUTTABLE_GetCreditRating=trainingdata.csv
PARAMETERS_GetCreditRating=Age,double;Income_level,string;Education,string;
Car_loans,string;
OUTPUTNAME_GetCreditRating=DEFAULT

SERVICENAME_GetReco=SequenceAnalysis
INPUTTABLE_GetReco=NBA.CUSTOMER_RELATIONSHIP_HISTORY
PARAMETERS_GetReco=CUSTOMERID,integer;SEQUENCE,integer;PRODUCT,string;
OUTPUTNAME_GetReco=RECOMMENDATION

SERVICENAME_GetCreditScore=CreditCardDefault
INPUTTABLE_GetCreditScore=NBA.CUSTOMER
PARAMETERS_GetCreditScore=CUSTOMERID,integer;AGE,integer;EDUCATION,string;
YEARSEMPLOYED,integer;INCOME,ineger;CARDDEBT,double;OTHERDEBT,double;
DEFAULTED,integer;ADDRESS,string;
OUTPUTNAME_GetCreditScore=DEFAULTPROPENSITY

For information about how to add an IBM SPSS Scoring Service to this file, see
“Add an IBM SPSS Scoring Service to an offer (External Callout connector).” Also,
see IBM Interact Administrator's Guide.

Add an IBM SPSS Scoring Service to an offer (External Callout
connector)
To add an IBM SPSS Scoring Service, add the following parameters to the
ExternalConnector_config.properties file.
v SERVICENAME_%THE EXTERNAL CONFIG NAME%

v INPUTTABLE_%THE EXTERNAL CONFIG NAME%

v PARAMETERS_%THE EXTERNAL CONFIG NAME%

v OUTPUTNAME_%THE EXTERNAL CONFIG NAME%
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The parameter name has two elements that are separated by commas:
v The input parameter name
v The data type

The parameters are separated by a semicolon.

The value for OUTPUTNAME_%THE SCORING SERVICE FUNCTION% can be "DEFAULT".
You do not need to provide the name of the output column name; the first output
parameter is taken as the output scoring results. For example, the following
methods of setting the output column get the same result:
v OUTPUTNAME_GetReco=RECOMMENDATION

v OUTPUTNAME_GetReco=DEFAULT

Troubleshooting EMM connector deployments
If you run IBM Enterprise Marketing Management version 9.0, there is an error in
the deployment section for IBM Campaign and IBM Interact. The error applies to
deploying WAR files.

About this task

Make the following configuration changes for IBM Campaign and IBM Interact
WAR files.

Procedure
1. On the server where IBM EMM is installed, go to the WebSphere Integrated

Solutions Console.
2. In the server’s Application > Enterprise Applications section, select the WAR

file that you deployed.
3. Select Class loading and update detection and set the following General

Properties on the Configuration tab:
v For Class loader order, select Classes loaded with local class loader first

(parent last).
v For WAR class loader policy, select Class loader for each WAR file in

application.

Configure the Analytic Solution Foundation
You can deploy the Analytic Solution Foundation to your IBM Predictive Customer
Intelligence environment.

You can use the Analytic Solution Foundation to extend the customer analytics
database that is provided with IBM Predictive Customer Intelligence or to create
orchestrations that define how data flows from an event to a customer profile.

The Analytic Solution Foundation is composed of a data model and a web
application that must be deployed in WebSphere Application Server with Java SDK
1.7.

A data dictionary is available for the IBM Predictive Customer Intelligence data
model that is provided with the solution. You can download the data dictionary
(PCI1.1_DataModel.xls) from the Predictive Customer Intelligence 1.1.0 product
documentation page (www.ibm.com/support/docview.wss?uid=swg27046802).
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For more information about the Analytic Solution Foundation, see the Analytic
Solution Foundation Developer Guide (www.ibm.com/support/
docview.wss?uid=swg27045826).

Creating the Analytic Solution Foundation database and
loading the data

You must create a database and load the metadata so that you can view the data
model from the Analytic Solution Foundation web application.

Procedure
1. Go to the directory where you decompressed the IBM Predictive Customer

Intelligence artifact files, and in the Analytic_Solution_Foundation_1.5.1.0/
ASF_1.5.1.0 directory, copy create-foundation-ui-schema-for-db2.ddl to the
data node computer.

2. In the PCIDataModel directory, copy the PCI_ASF_metadata.zip file to the data
node computer, and decompress the file.

3. On the computer where you installed IBM DB2, do one of the following:
v On Microsoft Windows operating systems, log on as the DB2 instance owner

user, and click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command
Window - Administrator.

v On Linux operating systems, open a terminal window.
4. Enter the following command to create a database:

DB2 CREATE DATABASE DB_NAME ON path USING CODESET UTF-8
TERRITORY US COLLATE USING SYSTEM PAGESIZE 8 K

DB_NAME is a name for your database. The name must be 8 characters or less.
path can be a file path or just a drive letter.
For example, on Microsoft Windows operating systems if your database name
is FNDTUI:
DB2 CREATE DATABASE FNDTUI ON C: USING CODESET UTF-8

TERRITORY US COLLATE USING SYSTEM PAGESIZE 8 K

5. Connect to the database you created by using the following command:
DB2 CONNECT TO DB_NAME

6. Go to the directory where you copied the create-foundation-ui-schema-for-
db2.ddl file.

7. Enter the following command to create the tables in the database:
db2 –tvf create-foundation-ui-schema-for-db2.ddl

8. Go to the directory where you decompressed the PCI_ASF_metadata.zip file.
9. Enter the following command to create the tables and load the data:
v On Microsoft Windows operating systems, enter Load_Data.bat DB_NAME.
v On Linux operating systems, enter sh Load_Data.sh DB_NAME.

Installing IBM Installation Manager for the Analytic Solution
Foundation

You must install IBM Installation Manager on the computer where you install
WebSphere Application Server with Java SDK 1.7 for the Analytic Solution
Foundation application.

Procedure
1. Go to the InstallationMgr directory where you decompressed the IBM

Predictive Customer Intelligence installation files.
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2. Decompress the Installation Manager installation file.
3. Start the installer:
v On Microsoft Windows operating systems, double-click install.exe.
v On Linux operating systems, enter ./install.

4. Follow the steps to install IBM Installation Manager.

Installing IBM WebSphere SDK Java Technology Edition for
Analytic Solution Foundation

You install IBM WebSphere SDK Java Technology Edition into an existing
WebSphere Application Server instance.

Procedure
1. Go to the WAS_JDK directory where you decompressed the IBM Predictive

Customer Intelligence installation files.
2. Decompress the installation files.

You must decompress 7.1.3.0-WS-IBMWASJAVA-part1.zip and
7.1.3.0-WS-IBMWASJAVA-part2.zip.

3. Start IBM Installation Manager.
v On Microsoft Windows operating systems, click Start > All Programs >

IBM Installation Manager.
v On SUSE Linux operating systems, start IBM Installation Manager from the

Application Browser or go to the /opt/IBM/InstallationManager/eclipse
directory, and run ./IBMIM.

4. Click File > Preferences.
5. Click Add Repository.
6. Browse to the location where you decompressed the Java SDK installation

files.
7. In the directory where you decompressed the installation files, select

repository.config, click OK to close the dialog.
8. In IBM Installation Manager, click Install.
9. Select IBM WebSphere SDK Java Technology Edition (Optional).

10. Click Next, and follow the steps in IBM Installation Manager to install the
product.

Configuring IBM WebSphere SDK Java Technology Edition for
Analytic Solution Foundation

After you install IBM WebSphere SDK Java Technology Edition, you must
configure it for the Analytic Solution Foundation.

Procedure
1. Open a web browser.
2. In the address bar, type the address for the WebSphere Admin Console for the

instance where you installed IBM WebSphere SDK Java Technology Edition.
The Admin console address is http://servername:9060/ibm/console.

3. If security is enabled, enter the User ID and Password, and click Log in.
4. Expand Servers > Server Types > WebSphere application servers, and click

server1.
5. Under Server Infrastructure, expand Administration, and click Java SDKs.
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6. Select 1.7.1_64, and click Make Default.
7. Click Save.
8. Restart the WebSphere Application Server instance.

Installing the Analytic Solution Foundation web application
You must install the Analytic Solution Foundation web application to WebSphere
Application Server.

For more information about installing the web application, see the Analytic
Solution Foundation Developer Guide (www.ibm.com/support/
docview.wss?uid=swg27045826).
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Chapter 7. Product license files

After you manually install IBM Predictive Customer Intelligence, you must ensure
that the appropriate swidtag file and license directory exists on each computer on
which you installed an IBM Predictive Customer Intelligence component.

Copying the component license files to each component computer
The swidtag file and license directory must exist on each server node computer
and each computer on which you install a client that is used with IBM Predictive
Customer Intelligence.

swidtag files are provided for both production and non-production use of IBM
Predictive Customer Intelligence. You must copy the appropriate swidtag file for
your usage.

Note: Do not rename the directory or files

If you installed on a Red Hat Enterprise Linux operating system by using the
solution installer, the license files are automatically copied to each server node
computer.

Procedure
1. On the computer where you decompressed the artifact files, go to the iso-swid

or iso-swid_NonProduction directory, and decompress the file, if applicable.
2. Copy the swidtag file to each computer on which you installed an IBM

Predictive Customer Intelligence component.
For example, on Microsoft Windows operating systems, copy the file so that
you have a C:\IBM\PCI1.1\iso-swid directory that contains a swidtag file. On
Linux operating systems, you would have an /opt/IBM/PCI1.1/iso-swid
directory that contains a swidtag file.

3. From the directory where you decompressed the artifact files, decompress the
license.zip file, and then copy the license directory to each computer where
you installed an IBM Predictive Customer Intelligence component.
For example, On Microsoft Windows operating systems, copy the directory and
contents so that you have a C:\IBM\PCI1.1\license directory that contains the
license files. On Linux operating systems, you would have an
/opt/IBM/PCI1.1/license directory that contains the license files.

Results

The following folders must exist on each computer on which you installed an IBM
Predictive Customer Intelligence component:
v On Microsoft Windows operating systems (both server and client components):

C:\IBM\PCI1.1\license (containing the product license files)
C:\IBM\PCI1.1\iso-swid (containing the product swidtag file)

v On Linux operating systems where a server component is installed:
/opt/IBM/PCI1.1/license (containing the product license files)
/opt/IBM/PCI1.1/iso-swid (containing the product swidtag file)
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Updating your software tag file if you change product usage
If you change your usage of IBM Predictive Customer Intelligence, such as to a
non-production environment from a production environment, you must switch the
software tags for your installation.

You must copy the appropriate software tag file to each computer on which an
IBM Predictive Customer Intelligence server or client component is installed.

Procedure
1. On the computer where you decompressed the artifact files, go to the iso-swid

or iso-swid_NonProduction directory, and decompress the file, if applicable.
2. Copy the swidtag file to each computer on which you installed an IBM

Predictive Customer Intelligence component and replace the existing file.
For example, on Microsoft Windows operating systems, copy the file so that
you have a C:\IBM\PCI1.1\iso-swid directory that contains a swidtag file. On
Linux operating systems, you would have an /opt/IBM/PCI1.1/iso-swid
directory that contains a swidtag file.
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Chapter 8. Use accelerators and industry customer
intelligence solutions

To help you get started with IBM Predictive Customer Intelligence, you can
download and install accelerators. To get started with production ready
applications, you can also download and install industry customer intelligence
solutions.

Downloading and installing accelerators
Accelerators are available to help you apply your IBM Predictive Customer
Intelligence solution to your business needs. You must download the accelerators
from IBM AnalyticsZone.

Procedure
1. Go to IBM AnalyticsZone (www.ibm.com/analyticszone).
2. Click Downloads, and under Predictive Customer Intelligence Accelerators,

click View all PCI downloads.
3. Click More details for the accelerator that you want to download.
4. If you are not signed in, click Sign In to Download.

You must enter your IBM ID. If you do not have an IBM ID, you must register
to create one.

5. Click Download.

What to do next

Information about installing the accelerators is provided in a separate document
for each accelerator. The documents are available from the More detail link for the
accelerator on IBM AnalyticsZone. Each document is also available on IBM
Knowledge Center (www.ibm.com/support/knowledgecenter/SSCJHT_1.1.0),
under the Create and Author section.

Downloading and installing industry customer intelligence solutions
Industry customer intelligence solutions are also available for IBM Predictive
Customer Intelligence. You must download the solutions from IBM Passport
Advantage.

Procedure
1. Go to IBM Passport Advantage (www.ibm.com/software/passportadvantage).
2. Sign in and navigate to the software download page.
3. Find and download the eAssembly for your industry customer intelligence

solution.

What to do next

Information about installing and using the industry customer intelligence solution
is available from IBM Knowledge Center (www.ibm.com/support/
knowledgecenter/SSCJHT_1.0.1).
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Chapter 9. Stop and start solution software services

IBM Predictive Customer Intelligence is an integrated solution that includes many
products. If you must stop the services, you must do so in the correct order. The
product services must also be started in the correct order.

Stop solution services
You must stop the IBM Predictive Customer Intelligence node services in a specific
order.

Stop the node services in the following order:
1. Business Intelligence (BI) node
2. Integration Bus node
3. Predictive Analytics node
4. data node

Stopping services on the BI node computer
You must stop the IBM Cognos Business Intelligence services and IBM HTTP
Server on the IBM Predictive Customer Intelligence Business Intelligence (BI) node
computer.

On Linux operating systems, or if you installed IBM Cognos Business Intelligence
to WebSphere Application Server on Microsoft Windows operating systems, you
stop the IBM Cognos BI services by stopping the WebSphere Application Server
profile where IBM Cognos BI is running.

Procedure
1. On Microsoft Windows operating systems:

a. Click Start > All Programs > IBM Cognos 10_64 > IBM Cognos
Configuration.

b. Click Actions > Stop.
c. Click Start > All Programs > IBM HTTP Server V8.5 > Stop HTTP Server.

Note: If you installed IBM Cognos Business Intelligence to WebSphere
Application Server, click Start > All Programs > IBM WebSphere > IBM
WebSphere Application Server V8.5 > Profiles > AppSrv01 > Stop the server
to stop both the WebSphere Application Server profile and the IBM Cognos
Business Intelligence services.

2. On Linux operating systems:
a. Log in to the BI node computer as root.
b. Go to the WebSphere Application Server profile directory when IBM Cognos

BI is running. For example, go to /opt/IBM/WebSphere/AppServer/profiles/
AppSrv01/bin, if you used the default name, or /opt/IBM/WebSphere/
AppServer/profiles/CustomProfile/bin, if you used the solution installer.

c. Enter the following command:
./stopServer.sh server1

d. Go to the IBM HTTP Server bin directory. For example, go to
/opt/IBM/HTTPServer/bin.
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e. Enter the following command:
./apachectl stop

Stopping services on the Integration Bus node computer
You must stop the IBM Integration Bus services on the IBM Predictive Customer
Intelligence Integration Bus node computer.

Procedure
1. On Microsoft Windows operating systems:

a. Go to the IBM Integration Bus bin directory.
b. Run mqsiCommandConsole.exe.
c. Enter the following command: mqsistop pcibroker.
d. Enter the following command to verify that the services have stopped:

mqsilist pcibroker.
2. On Linux operating systems:

a. Log in to the Integration Bus node computer as root.
b. Change to the mqmuser user. For example, enter the following command: su

- mqmuser.
c. Go to the IBM Integration Bus bin directory.
d. Enter the following command: ./mqsistop pcibroker -i.
e. Enter the following command to verify that the services have stopped:

./mqsilist pcibroker -e pcigroup.

Stopping services on the Analytics node computer
You must stop the IBM SPSS services on the IBM Predictive Customer Intelligence
Predictive Analytics node computer.

Procedure
1. On Microsoft Windows operating systems:

a. Click Start > All Programs > IBM WebSphere > IBM WebSphere
Application Server V8.5 > Profiles > AppSrv01 > Stop the server.

b. Click Start > Control Panel > Administrative Tools > Services.
c. Select IBM SPSS Modeler Server 17.0, and click Stop Service.

2. On Linux operating systems:
a. Log in to the Analytics node computer as root.
b. Go to the WebSphere Application Server profile bin directory. For example,

go to /opt/IBM/WebSphere/AppServer/profiles/AppSrv01/bin, if you used
the default name, or /opt/IBM/WebSphere/AppServer/profiles/
CustomProfile/bin, if you used the solution installer.

c. Enter the following command: ./stopServer.sh server1
d. Go to the IBM SPSS Modeler Server directory. For example, go to

/opt/IBM/SPSS/ModelerServer/17.0.
If you manually installed and accepted the defaults, the path is
/usr/IBM/SPSS/ModelerServer/17.0.

e. Enter the following command: ./modelersrv.sh stop
f. To verify whether any services are still running enter the following

command: ps -ef | grep statisticsd
g. To stop any services that are still running enter the following command:

kill -9 'cat statisticsd.pid'
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Stopping services on the data node computer
You must stop the IBM DB2 instance on the IBM Predictive Customer Intelligence
data node computer.

Procedure
1. On Microsoft Windows operating systems:

a. Log in to the data node computer as the IBM DB2 administrator user.
b. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window

- Administrator.
c. Enter the following command to stop the DB2 administration server:

db2stop

2. On Linux operating systems:
a. Log in to the data node computer as root.
b. In a terminal window, type the following command to change the DB2

instance owner: su - db2inst1
c. Enter the following command to stop the DB2 administration server:

db2stop

Start solution services
You must start the IBM Predictive Customer Intelligence node services in a specific
order.

Start the node services in the following order:
1. data node
2. Predictive Analytics node
3. Integration Bus node
4. Business Intelligence (BI) node

Starting services on the data node computer
You must start the IBM DB2 instance on the IBM Predictive Customer Intelligence
data node computer.

Procedure
1. On Microsoft Windows operating systems:

a. Log in to the data node computer as the IBM DB2 administrator user.
b. Click Start > IBM DB2 > DB2COPY1 (Default) > DB2 Command Window

- Administrator.
c. Enter the following command to stop the DB2 administration server:

db2start

2. On Linux operating systems:
a. Log in to the data node computer as root.
b. In a terminal window, type the following command to change the DB2

instance owner: su - db2inst1
c. Enter the following command to stop the DB2 administration server:

db2start
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Starting services on the Analytics node computer
You must start the IBM SPSS services on the IBM Predictive Customer Intelligence
Predictive Analytics node computer.

Procedure
1. On Microsoft Windows operating systems:

a. Click Start > All Programs > IBM WebSphere > IBM WebSphere
Application Server V8.5 > Profiles > AppSrv01 > Start the server.

b. Click Start > Control Panel > Administrative Tools > Services.
c. Select IBM SPSS Modeler Server 17.0, and click Start Service.

2. On Linux operating systems:
a. Log in to the Analytics node computer as root.
b. Go to the WebSphere Application Server profile bin directory. For example,

go to /opt/IBM/WebSphere/AppServer/profiles/AppSrv01/bin, if you used
the default name, or /opt/IBM/WebSphere/AppServer/profiles/
CustomProfile/bin, if you used the solution installer.

c. Enter the following command: ./startServer.sh server1
d. Go to the IBM SPSS Modeler Server directory. For example, go to

/opt/IBM/SPSS/ModelerServer/17.0.
If you manually installed and accepted the defaults, the path is
/usr/IBM/SPSS/ModelerServer/17.0.

e. Enter the following command: ./modelersrv.sh start

Starting services on the Integration Bus node computer
You must start the IBM Integration Bus services on the IBM Predictive Customer
Intelligence Integration Bus node computer.

Procedure
1. On Microsoft Windows operating systems:

a. Go to the IBM Integration Bus bin directory.
b. Run mqsiCommandConsole.exe.
c. Enter the following command: mqsistart pcibroker.
d. Enter the following command to verify that the services have started:

mqsilist pcibroker.
e. Enter the following commands:

START LISTENER

END

2. On Linux operating systems:
a. Log in to the Integration Bus node computer as root.
b. Change to the mqmuser user. For example, enter the following command: su

- mqmuser.
c. Go to the IBM Integration Bus bin directory.
d. Enter the following command: ./mqsistart pcibroker -i.
e. Enter the following command to verify that the services have started:

./mqsilist pcibroker -e pcigroup.
f. Enter the following commands:

START LISTENER

END
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Starting services on the BI node computer
You must start the IBM Cognos Business Intelligence services and IBM HTTP
Server on the IBM Predictive Customer Intelligence Business Intelligence (BI) node
computer.

On Linux operating systems, or if you installed IBM Cognos Business Intelligence
to WebSphere Application Server on Microsoft Windows operating systems, you
start the IBM Cognos BI services by starting the WebSphere Application Server
profile where IBM Cognos BI is running.

Procedure
1. On Microsoft Windows operating systems:

a. Click Start > All Programs > IBM Cognos 10_64 > IBM Cognos
Configuration.

b. Click Actions > Start.
c. Click Start > All Programs > IBM HTTP Server V8.5 > Start HTTP Server.

Note: If you installed IBM Cognos Business Intelligence to WebSphere
Application Server, click Start > All Programs > IBM WebSphere > IBM
WebSphere Application Server V8.5 > Profiles > AppSrv01 > Start the server
to stop both the WebSphere Application Server profile and the IBM Cognos
Business Intelligence services.

2. On Linux operating systems:
a. Log in to the BI node computer as root.
b. Go to the WebSphere Application Server profile directory when IBM Cognos

BI is running. For example, go to /opt/IBM/WebSphere/AppServer/profiles/
AppSrv01/bin, if you used the default name, or /opt/IBM/WebSphere/
AppServer/profiles/CustomProfile/bin, if you used the solution installer.

c. Enter the following command:
./startServer.sh server1

d. Go to the IBM HTTP Server bin directory. For example, go to
/opt/IBM/HTTPServer/bin.

e. Enter the following command: ./apachectl start
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Chapter 10. Uninstallation of the server components

Follow the uninstall instructions for each of the IBM Predictive Customer
Intelligence components to uninstall the product.

Uninstalling components from the Predictive Analytics node computer
Follow the uninstall instructions for each component on the IBM Predictive
Customer Intelligence Analytics node computer.

Procedure
1. To uninstall IBM DB2, see the IBM DB2 documentation (www.ibm.com/

support/knowledgecenter/SSEPGG_10.5.0/com.ibm.db2.luw.qb.server.doc/
doc/c0059726.html).

2. To uninstall IBM SPSS Collaboration and Deployment Services, see the IBM
SPSS documentation (www.ibm.com/support/knowledgecenter/SS69YH_7.0.0).
a. On Microsoft Windows operating systems, from the Start menu, click All

Programs > IBM Installation Manager > IBM Installation Manager.
b. On Linux operating systems, go to the /opt/IBM/InstallationManager/

eclipse directory, and run ./IBMIM.
c. Click Uninstall, and follow the steps to uninstall the product.

3. To uninstall WebSphere Application Server, see the WebSphere documentation
(www.ibm.com/support/knowledgecenter/SSEQTP_8.5.5).
a. Go to the /opt/IBM/InstallationManager/eclipse directory, and run IBMIM.
b. Click Uninstall, and follow the steps to uninstall the product.

Note: If WebSphere Application Server processes are running and prevent you
from uninstalling the product, you must stop the server process. Go to the
/opt/IBM/WebSphere/AppServer/profiles/profile_name/bin directory, and type
./stopServer.sh server1.

4. To uninstall IBM Installation Manager, see the IBM Installation Manager
information center (www.ibm.com/support/knowledgecenter/SSDV2W_1.8.3/
com.ibm.silentinstall12.doc/topics/r_uninstall_cmd.html).
a. On Microsoft Windows operating systems, in the Control Panel, click

Programs and Features, select IBM Installation Manager, and click
Uninstall.

b. On Linux operating systems, go to the /var/ibm/InstallationManager/
uninstall directory, and run uninstall.

c. Follow the steps to uninstall IBM Installation Manager.
5. Remove the licence and iso-swid directories.

Uninstalling components from the BI node computer
Follow the uninstall instructions for each component on the IBM Predictive
Customer Intelligence Business Intelligence (BI) node computer.
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Procedure
1. To uninstall IBM DB2, see the IBM DB2 documentation (www.ibm.com/

support/knowledgecenter/SSEPGG_10.5.0/com.ibm.db2.luw.qb.server.doc/
doc/c0059726.html).

2. To uninstall IBM Cognos Business Intelligence, see the IBM Cognos BI
documentation (www.ibm.com/support/knowledgecenter/SSEP7J_10.2.2/
com.ibm.swg.ba.cognos.inst_cr_winux.10.2.2.doc/
c_uninstallingcognos8single.html%23UninstallingCognos8Single).
a. On Microsoft Windows operating systems, drom the Start menu, click All

Programs > IBM Cognos 10 - 64 > Uninstall IBM Cognos > Uninstall IBM
Cognos, and follow the steps to uninstall the product.

b. On Linux operating systems, go to the /opt/ibm/cognos/c10_64/uninstall
directory, type ./uninst -u, and press Enter.

3. To uninstall IBM HTTP Server, see the IBM HTTP Server for WebSphere
Application Server documentation (www.ibm.com/support/knowledgecenter/
SSEQTJ_8.5.5).
a. On Microsoft Windows operating systems, from the Start menu, click All

Programs > IBM Installation Manager > IBM Installation Manager.
b. On Linux operating systems, go to the /opt/IBM/InstallationManager/

eclipse directory, and run ./IBMIM.
c. Click Uninstall, and follow the steps to uninstall the product.

4. To uninstall WebSphere Application Server, see the WebSphere documentation
(www.ibm.com/support/knowledgecenter/SSEQTP_8.5.5).
a. Go to the /opt/IBM/InstallationManager/eclipse directory, and run IBMIM.
b. Click Uninstall, and follow the steps to uninstall the product.

Note: If WebSphere Application Server processes are running and prevent you
from uninstalling the product, you must stop the server process. Go to the
/opt/IBM/WebSphere/AppServer/profiles/profile_name/bin directory, and type
./stopServer.sh server1.

5. To uninstall IBM Installation Manager, see the IBM Installation Manager
information center (www.ibm.com/support/knowledgecenter/SSDV2W_1.8.3/
com.ibm.silentinstall12.doc/topics/r_uninstall_cmd.html).
a. On Microsoft Windows operating systems, in the Control Panel, click

Programs and Features, select IBM Installation Manager, and click
Uninstall.

b. On Linux operating systems, go to the /var/ibm/InstallationManager/
uninstall directory, and run uninstall.

c. Follow the steps to uninstall IBM Installation Manager.
6. Remove the licence and iso-swid directories.

Uninstalling components from the Integration Bus node computer
Follow the uninstall instructions for each component on the IBM Predictive
Customer Intelligence Integration Bus node computer.

Procedure
1. To uninstall IBM DB2, see the IBM DB2 documentation (www.ibm.com/

support/knowledgecenter/SSEPGG_10.5.0/com.ibm.db2.luw.qb.server.doc/
doc/c0059726.html).
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2. To uninstall IBM Integration Bus, see the IBM Integration Bus documentation
(www.ibm.com/support/knowledgecenter/SSMKHH_10.0.0/
com.ibm.etools.mft.doc/ah01860_.htm).

3. To uninstall WebSphere MQ, see the WebSphere MQ documentation
(www.ibm.com/support/knowledgecenter/SSFKSJ_8.0.0/com.ibm.mq.ins.doc/
q009410_.htm).

4. Remove the licence and iso-swid directories.

Uninstalling components from the data node computer
Follow the uninstall instructions for each component on the IBM Predictive
Customer Intelligence data node computer.

Procedure
1. To uninstall IBM DB2, see the IBM DB2 documentation (www.ibm.com/

support/knowledgecenter/SSEPGG_10.5.0/com.ibm.db2.luw.qb.server.doc/
doc/c0059726.html).

2. Remove the licence and iso-swid directories.

Uninstalling the solution installer
If you used the solution installer to install the IBM Predictive Customer
Intelligence on Red Hat Enterprise Linux operating systems, you can uninstall the
solution installer by running a script.

When you uninstall the solution installer, the processes that are used by the
solution installer are stopped and removed from your computer. Also, all of the
files in the solution installer directory are removed. This includes the IBM
Predictive Customer Intelligence server component installation files that you
copied into the solution installer directory. If you want to preserve those files, you
must copy them to another directory before you uninstall the solution installer.

Also, you can run a script on each node computer where you installed an IBM
Predictive Customer Intelligence component to remove the solution installer
processes. Ensure that you copy the cleanupClient.sh file before you uninstall the
solution installer.

Note: Uninstalling the solution installer does not uninstall the IBM Predictive
Customer Intelligence component applications. If you want to uninstall those
components, you must use each component's uninstallation programs.

Procedure
1. To remove the solution installer processes on the client node computers, do the

following steps:
a. From the SolutionInstaller directory, copy the cleanupClient.sh file onto

each computer on which you installed an IBM Predictive Customer
Intelligence component.

b. Go to the directory where you copied the file.
c. Enter the following command: sh cleanupClient.sh.

2. To remove the solution installer, do the following steps:
a. Optional: Go to the PCI_1.1_linux/SolutionInstaller/NodeRoot/Downloads/

Software directory, and copy prd_cust_intel_svr_1.1_1_l86_en.tar.gz,
prd_cust_intel_svr_1.1_2_l86_en.tar.gz, and

Chapter 10. Uninstallation of the server components 99

http://www.ibm.com/support/knowledgecenter/SSMKHH_10.0.0/com.ibm.etools.mft.doc/ah01860_.htm
http://www.ibm.com/support/knowledgecenter/SSFKSJ_8.0.0/com.ibm.mq.ins.doc/q009410_.htm
http://www.ibm.com/support/knowledgecenter/SSEPGG_10.5.0/com.ibm.db2.luw.qb.server.doc/doc/c0059726.html


prd_cust_intel_svr_1.1_3_l86_en.tar.gz to another directory, outside of
the PCI_1.1_linux/SolutionInstaller directory.

b. Go to the PCI_1.1_linux/SolutionInstaller directory.
c. Enter the following command: sh cleanup.sh.
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Appendix A. Accessibility features

Accessibility features help users who have a physical disability, such as restricted
mobility or limited vision, to use information technology products.

For information about the commitment that IBM has to accessibility, see the IBM
Accessibility Center (www.ibm.com/able).

IBM Cognos HTML documentation has accessibility features. PDF documents are
supplemental and, as such, include no added accessibility features.

Report output

In IBM Cognos Administration, you can enable system-wide settings to create
accessible report output. For more information, see the IBM Cognos Business
Intelligence Administration and Security Guide. In IBM Cognos Report Studio, you can
enable settings to create accessible output for individual reports. For more
information, see the IBM Cognos Report Studio User Guide. You can access the
previously mentioned documents at IBM Knowledge Center (www.ibm.com/
support/knowledgecenter).
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Appendix B. Troubleshooting

This section contains troubleshooting information for the IBM Predictive Customer
Intelligence installation.

Troubleshooting a problem
Troubleshooting is a systematic approach to solving a problem. The goal of
troubleshooting is to determine why something does not work as expected and
how to resolve the problem.

Review the following table to help you or customer support resolve a problem.

Table 3. Troubleshooting actions and descriptions

Actions Description

A product fix might be available to resolve
your problem.

Apply all known fix packs, or service levels,
or program temporary fixes (PTF).

Look up error messages by selecting the
product from the IBM Support Portal, and
then typing the error message code into the
Search support box (http://www.ibm.com/
support/entry/portal/).

Error messages give important information
to help you identify the component that is
causing the problem.

Reproduce the problem to ensure that it is
not just a simple error.

If samples are available with the product,
you might try to reproduce the problem by
using the sample data.

Ensure that the installation successfully
finished.

The installation location must contain the
appropriate file structure and the file
permissions. For example, if the product
requires write access to log files, ensure that
the directory has the correct permission.

Review all relevant documentation,
including release notes, technotes, and
proven practices documentation.

Search the IBM Knowledge Center to
determine whether your problem is known,
has a workaround, or if it is already
resolved and documented.

Review recent changes in your computing
environment.

Sometimes installing new software might
cause compatibility issues.

If the items in the table did not guide you to a resolution, you might need to
collect diagnostic data. This data is necessary for an IBM technical-support
representative to effectively troubleshoot and assist you in resolving the problem.
You can also collect diagnostic data and analyze it yourself.

Troubleshooting resources
Troubleshooting resources are sources of information that can help you resolve a
problem that you are having with an IBM product.

Support Portal

The IBM Support Portal is a unified, centralized view of all technical support tools
and information for all IBM systems, software, and services.
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The IBM Support Portal lets you access all the IBM support resources from one
place. You can tailor the pages to focus on the information and resources that you
need for problem prevention and faster problem resolution. Familiarize yourself
with the IBM Support Portal by viewing the demo videos (https://www.ibm.com/
blogs/SPNA/entry/the_ibm_support_portal_videos).

Find the content that you need by selecting your products from the IBM Support
Portal (http://www.ibm.com/support/entry/portal).

Before contacting IBM Support, you will need to collect diagnostic data (system
information, symptoms, log files, traces, and so on) that is required to resolve a
problem. Gathering this information will help to familiarize you with the
troubleshooting process and save you time.

Service request

Service requests are also known as Problem Management Reports (PMRs). Several
methods exist to submit diagnostic information to IBM Software Technical Support.

To open a PMR or to exchange information with technical support, view the IBM
Software Support Exchanging information with Technical Support page
(http://www.ibm.com/software/support/exchangeinfo.html).

Fix Central

Fix Central provides fixes and updates for your system's software, hardware, and
operating system.

Use the pull-down menu to navigate to your product fixes on Fix Central
(http://www.ibm.com/systems/support/fixes/en/fixcentral/help/
getstarted.html). You may also want to view Fix Central help.

IBM developerWorks

IBM developerWorks® provides verified technical information in specific
technology environments.

As a troubleshooting resource, developerWorks provides easy access to the most
popular practices, in addition to videos and other information: developerWorks
(http://www.ibm.com/developerworks).

IBM Redbooks

IBM Redbooks® are developed and published by the IBM International Technical
Support Organization, the ITSO.

IBM Redbooks (http://www.redbooks.ibm.com) provide in-depth guidance about
such topics as installation and configuration and solution implementation.

Software support and RSS feeds

IBM Software Support RSS feeds are a quick, easy, and lightweight format for
monitoring new content added to websites.
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After you download an RSS reader or browser plug-in, you can subscribe to IBM
product feeds at IBM Software Support RSS feeds (https://www.ibm.com/
software/support/rss).

Log files

Log files can help you troubleshoot problems by recording the activities that take
place when you work with a product.

Error messages

The first indication of a problem is often an error message. Error messages contain
information that can be helpful in determining the cause of a problem.

Solution installer error “Deployment failed by the error occurred due
to => FATAL;”

You are using the solution installer to install on a Red Hat Enterprise Linux
operating system, and you see the following error message: “Deployment failed by
the error occurred due to => FATAL;”.

This message can occur for several reasons.
1. The operating system is not compatible with the solution installer. You must be

using 64-bit Red Hat Enterprise Linux Server Edition version 6.5 or 6.6 (x86_64)
operating systems.
For more information, see the IBM Software Product Compatibility Reports
(www.ibm.com/support/docview.wss?uid=swg27044319).

2. The required RPMs are not installed on the target computer.
For more information, see “Installing required operating system packages on
the BI node computer” on page 4 and “Installing required operating system
packages on the Integration Bus node computer” on page 5.

3. The required ports are not open in the operating system firewall.
For more information, see “Opening firewall ports for the solution installer” on
page 16.

4. If you are installing to a single-node or four-node architecture, and the log file
indicates that there is a missing database parameter for the IBM SPSS
Collaboration and Deployment Services Server configuration, go back to the
solution installer and click Run again.

Solution installer error “There is no connection to the server”
You are using the solution installer to install on a Red Hat Enterprise Linux
operating system, and you see the following error message: “There is no
connection to the server”.

This message can occur for several reasons.
1. The required ports are not open in the operating system firewall.

For more information, see “Opening firewall ports for the solution installer” on
page 16.

2. NodeJS is not running on the computer where you are running the solution
installer.
Check whether there are any processes still running by running the following
command: ps -elf | grep node.
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Enter the following command to stop the processes: killall node.
Then, restart NodeJS by going to the SolutionInstaller directory, and running
the following command: nohup node NodeJS/server.js > NodeJS/server.log
2>&1 &

Modeler Server type not displaying in resource definitions
In IBM Predictive Customer Intelligence, if the Modeler Server type does not
display in resource definitions in IBM SPSS Collaboration and Deployment Services
Deployment Manager, try closing Deployment Manager and opening it again.

Error installing IBM Cognos BI
The IBM Cognos Business Intelligence installer requires a specific library file in
order to run.

If you encounter this error installing IBM Predictive Customer Intelligence, see the
IBM support page (http://www.ibm.com/support/docview.wss?uid=swg21612290)
for information on how to correct the error.

“The port 9683 is already in use” error when you run the solution
installer after you reinstalled it

You have reinstalled the solution installer after you used the cleanup.sh script, and
when you run the solution installer you get the following error message:

The port 9683 is already in use. You must run the solution installer on a
system where the port 9683 is not in use.

This message occurs because one of the services that is used by the solution
installer is still running.

To resolve this error, restart you machine, and then run the setup.sh script again.

Saving IBM Cognos BI report files to local file system
Use the following procedure to save IBM Predictive Customer Intelligence reports
generated in IBM Cognos Business Intelligence to the local file system. For
example, if you want to save the CSV output for the top 250 subscriber list in the
Telecommunications Customer Management with Mobile Service Insights industry
accelerator, you can configure IBM Cognos BI to save the file each time the report
is run. The report is saved on the BI node computer.

Procedure
1. Log on to the Business Intelligence node computer.
2. Create a directory in which to save your report outputs.
3. Enable saving report output to the file system in IBM Cognos Configuration.

a. Enter the following command to load the profile that is needed for IBM
Cognos BI, and press Enter:
. ~/.bash_profile

The .bash_profile file contains the environment variables that are needed
to start IBM Cognos Configuration.

b. Go to the /opt/ibm/cognos/c10_64/bin64 directory.
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c. Type the following command:
./cogconfig.sh

IBM Cognos Configuration starts.
d. Click Actions > Edit Global Configuration.
e. On the General tab, enter the path to the directory you created in Archive

Location File System Root.
The path must be in the format of file://(file-system-path). For
example, file:///usr/reports.

f. Click OK.
g. In the Explorer window, expand Data Access, and click Content Manager.
h. Set Save report outputs to a file system to True.
i. In the Explorer window, click Environment, and ensure that the server name

or IP address for the BI node computer is used in the URI settings. Using
localhost in the URI settings can cause errors if you are saving the report
output to a shared directory.

j. Click File > Save.
k. Restart the IBM Cognos services.

4. Enable saving reports in IBM Cognos Administration.
a. Open a web browser.
b. Go to the IBM Cognos BI portal URL. For example, go to

http://bi_node_name/ibmcognos/.
c. On the Welcome page, click Administer IBM Cognos Content.
d. On the Configuration tab, click Dispatchers and Services.

e. Click the Define File Systems Locations button .
f. Click New.
g. In Name, enter a name for the location. This name will appear when you

run the reports.
h. In File system location, enter the path to the directory you created. For

example, /usr/reports.
i. Click Finish, and Close.

5. Select the output location for a report.
a. In IBM Cognos Connection, select a report, and click Schedule.
b. In the Options section, select Override the default values.
c. In the Delivery section, enable Save to the file system, and click Edit the

options.
d. On the options page, in Location, select the output location.
e. Click OK.

After the report is run, the output will be available in the file system
directory you configured.
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Appendix C. Supporting programs licensed with IBM
Predictive Customer Intelligence

The following supporting programs are licensed with IBM Predictive Customer
Intelligence.

Supporting programs

IBM Predictive Customer Intelligence Samples

IBM Cognos Business Intelligence Analytics Administrator

IBM Cognos Business Intelligence Software Development Kit

IBM Cognos Cube Designer

IBM Cognos Framework Manager

IBM Cognos Business Intelligence Samples

IBM Cognos Lifecycle Manager

IBM Cognos for Microsoft Office

IBM Cognos Supplementary Languages Documentation

IBM Cognos Dynamic Query Analyzer

IBM SPSS Analytical Decision Management

IBM SPSS Analytical Decision Management Application

IBM SPSS Analytic Server

IBM SPSS Modeler Premium

IBM SPSS Modeler Server Premium

IBM SPSS Modeler Solution Publisher

IBM SPSS Statistics Standard

IBM SPSS Statistics Server Standard

IBM SPSS Statistics - Essentials for Python

IBM SPSS Collaboration and Deployment Services Adapters for Statistics

IBM SPSS Collaboration and Deployment Services

IBM SPSS Collaboration and Deployment Services Deployment Manager
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IBM SPSS Collaboration and Deployment Services - Real Time Scoring

IBM SPSS Collaboration and Deployment Services Deployment Portal

IBM SPSS Data Access Pack

IBM SPSS Concurrent Licensing Tools

IBM DB2 Enterprise Server Edition Version

IBM WebSphere Application Server Network Deployment

IBM WebSphere MQ

IBM Integration Bus

IBM Installation Manager and Packaging Utility for the Rational® Software
Development Platform

IBM ILOG CPLEX Optimization Studio

IBM ILOG CPLEX Enterprise Server
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Appendix D. Programs not authorized by the IBM Predictive
Customer Intelligence license

The following programs are not authorized with the IBM Predictive Customer
Intelligence, and the use of these programs is not authorized by the IBM Predictive
Customer Intelligence license.

IBM Cognos Analysis for Microsoft Excel

IBM Cognos Analysis Studio

IBM Cognos Business Intelligence Transformer

IBM Cognos Connection Installer for IBM Cognos Insight

IBM Cognos Data Manager Connector

IBM Cognos Insight

IBM Cognos Metric Designer

IBM Cognos Metric Studio

IBM Cognos Metrics Manager

IBM Cognos Migration Tools

IBM Cognos PowerPlay® Client

IBM Cognos PowerPlay Server

IBM Cognos PowerPlay Studio

IBM Cognos Query Studio

IBM Cognos TM1® Package Connector

IBM Connections

IBM DB2 Workgroup Server Edition

IBM Tivoli® Directory Integrator Identity Edition

IBM DB2 Workgroup Server Edition Version (IBM DB2) (of IBM SPSS Modeler
Premium, IBM SPSS Modeler Server Premium)

IBM WebSphere Application Server Developer Tools for Eclipse (of IBM WebSphere
Application Server Network Deployment)

J2SE Rule Execution Server (of IBM WebSphere Application Server Network
Deployment)

© Copyright IBM Corp. 2014, 2015 111



IBM Data Studio (of IBM DB2 Enterprise Server Edition)

IBM WebSphere MQ (of IBM DB2 Enterprise Server Edition)

pureScale® Feature (of IBM DB2 Enterprise Server Edition)

IBM General Parallel File System (GPFS™) for AIX® (of IBM DB2 Enterprise Server
Edition)

IBM General Parallel File System (GPFS) for Linux Multiplatform (of IBM DB2
Enterprise Server Edition)

IBM Mobile Database (of IBM DB2 Enterprise Server Edition)

IBM Mobile Database Sync (of IBM DB2 Enterprise Server Edition)

IBM Tivoli Storage Flashcopy Manager (of IBM DB2 Enterprise Server Edition)

Embedded version of IBM WebSphere Application Server ("embedded WebSphere
Application Server") (of IBM Tivoli System Automation for Multiplatforms (of IBM
DB2 Enterprise Server Edition)

IBM Cloudscape V10 (of IBM Tivoli System Automation for Multiplatforms 3.2 (of
IBM DB2 Enterprise Server Edition Version))

Embedded WebSphere Application Server (of IBM Tivoli Directory Server 6.3 -
Client Only (component) (of IBM DB2 Enterprise Server Edition Version))

IBM InfoSphere® Change Data Capture (of IBM InfoSphere Data Replication
(component) (of IBM DB2 Enterprise Server Edition))

IBM InfoSphere Change Data Capture (of IBM InfoSphere Data Replication
(component) (of IBM DB2 Enterprise Server Edition)

IBM InfoSphere Replication Server (of IBM InfoSphere Data Replication
(component) (of IBM DB2 Enterprise Server Edition))

IBM Tivoli Directory Integrator (of IBM Tivoli Directory Server - Client Only
(component) (of IBM DB2 Enterprise Server Edition))

WebSphere Application Server (of IBM Tivoli Directory Server - Client Only
(component) (of IBM DB2 Enterprise Server Edition))

IBM DB2 Workgroup Server Edition Version (of IBM Tivoli Directory Server -
Client Only (component) (of IBM DB2 Enterprise Server Edition Version))

IBM DB2 Enterprise Server Edition Version (of IBM Tivoli Directory Serve - Client
Only (component) (of IBM DB2 Enterprise Server Edition Version))

IBM InfoSphere Data Replication (component) (of IBM InfoSphere Federation
Server (component) (of IBM DB2 Enterprise Server Edition Version))

IBM WebSphere MQ (of IBM InfoSphere Federation Server (component) (of IBM
DB2 Enterprise Server Edition Version))
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IBM DB2 Connect™, Application Server Edition (of IBM InfoSphere Federation
Server (component) (of IBM DB2 Enterprise Server Edition Version))

IBM WebSphere eXtreme Scale (of IBM WebSphere Application Server Network
Deployment)

The Intelligent Management functions (of WebSphere Application Server Network
Deployment): Application Edition Management, Server Health Management, SLA
Based Dynamic Clustering, Intelligent Routing and SLA Enforcement
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Appendix E. Performance tuning for IBM Predictive Customer
Intelligence

The topics in this appendix provide examples of configuration changes that might
help improve performance of your IBM Predictive Customer Intelligence
installation.

Tune WebSphere Application Server for IBM Predictive Customer
Intelligence

Performance tuning settings for WebSphere Application Server include JVM tuning,
thread pools, connection pools, web container settings, logging, and web server
monitoring.

JVM tuning
Setting an appropriate Java virtual machine (JVM) heap size can improve
performance for IBM Predictive Customer Intelligence. Also, garbage collection is
an integral Java runtime service. Increasing the JVM heap size can reduce the
number of garbage collection occurrences and provide a 10 percent gain in
performance.

Heap size

The heap size should be set to an optimal value. It should not exceed 80% of the
physical memory available on the computer. Doing so would enable paging and
increase processor usage, which affects the performance of WebSphere Application
Server.

For IBM Predictive Customer Intelligence, use 4096 MB.

The Max Heap Size is the maximum heap size that would be allocated to the
server. It is important that the value is less than the available physical memory.

For IBM Predictive Customer Intelligence, use 7128 MB.

Garbage collection

Parallel garbage collection is a technique that uses several dedicated threads for
garbage collection. This method improves garbage collection pause time, which
increases processor efficiency and improves performance.

This process can be activated by setting the –Xgcthreads value to the number of
processors on the computer. For example, set –Xgcthreads:number_of_processors,
However, this method is not entirely suited for concurrent users.

For concurrent users, use -Xgcpolicy:optavgpause.

Thread pools
Thread pools enable server components to reuse threads. Reusing threads
eliminates the need to create new threads at run time, and creating new threads
expends time and resources.
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Web container thread pool

The web container thread pool is used for HTTP requests that come from the
client. Set the number of threads to double the number of users that might be
expected to access the application concurrently.

For example, for IBM Predictive Customer Intelligence, set the minimum value to
3000 and the maximum to 5000.

Connection pools

Connection pools are associated with data source configuration for web
applications, and it is used to direct JDBC calls within the application.

When a user makes a request over the web to a resource, the resource accesses the
data source. Because users connect and disconnect frequently with applications on
the internet, the application requests for data access can surge to considerable
volume. Consequently, the total data store overhead quickly becomes high for
web-based applications, and performance deteriorates. However, when connection
pooling capabilities are used, the web applications can realize performance
improvements of up to 20 times the normal results.

With data sources, most user requests do not incur the overhead of creating a new
connection because the data source can locate and use an existing connection from
a pool of connections. When the request is satisfied and the response is returned to
the user, the resource returns the connection to the connection pool for reuse.

For example, for IBM Predictive Customer Intelligence, set the minimum value to
1000 and the maximum to 3000.

Web container configuration
Web container configuration settings can improve IBM Predictive Customer
Intelligence performance.

Enable servlet caching

The server caches servlet output during application execution. A cache entry
contains not only the output, but also the side effects of the invocation. These side
effects include calls to other servlets and metadata about the entry, such as timeout
and entry priority information.

Web container custom properties

For the HTTPQueueInboundDefault property, there are two settings:

Maximum pool connections
The number of connections that are expected to be responded to by the
application server. Ideally, this value should be equal to or more than the
number of clients that are expected to use the system. The maximum
number that can be set is 20000.

Maximum persistent requests per connection
Persistent connections specify that an outgoing HTTP response should use
a persistent connection instead of a connection that closes after one request
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or response exchange occurs. A performance boost can be achieved by
increasing the number of persistent connections that are allowed on a
single HTTP connection.

Logging and performance monitoring
For IBM Predictive Customer Intelligence, turning off logging and performance
monitoring in a production environment can improve performance.

Tune IBM Unica for IBM Predictive Customer Intelligence
You can improve performance of IBM Predictive Customer Intelligence by
modifying settings for IBM Unica.

EHCache configuration settings

EHCache is the built-in cache manager for IBM Unica Interact that is used to
improve performance. It is possible to configure the settings that are used by
EHCache to optimize its value for the runtime server group.

The number of sessions in memory depends on the following factors:
v The expected number of sessions per second.
v The total amount of time each session is supposed to last.

For example, if you expect 50 sessions a second, and each session is expected to
last 20 minutes, then modify the settings to support 60,000 sessions at a time.

Java Serialization API rather than SOAP API
For IBM Predictive Customer Intelligence, the Java Serialization API provides
better throughput and a shorter response time than the SOAP API.

Threads for interactive flowcharts
Every interactive flowchart requires at least one thread to run.

IBM Predictive Customer Intelligence, set the MaxNumberOfFlowchartThreads value
to be at least the maximum number of concurrent users that are expected on the
IBM Interact client. And set the MinNumberOfFlowchartThreads value to be the same
as the maximum value. Set the MaxNumberOfProcessThreads value to be at least the
MaxNumberOfFlowchartThreads.

For example, set the MaxNumberOfFlowchartThreads and
MinNumberOfFlowchartThreads to 500. And set MaxNumberOfProcessThreads to 550.

Tuning IBM Cognos BI for IBM Predictive Customer Intelligence
You can apply settings in IBM Cognos Business Intelligence to improve
performance for IBM Predictive Customer Intelligence reports. The settings are
made in IBM Cognos Administration.

Additionally, if you are using IBM Cognos Business Intelligence 10.2.1 with Fix
Pack 3 or higher, it is recommended that you modify settings in a configuration file
on the BI node computer.

Procedure
1. Open a web browser.
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2. Go to the IBM Cognos BI portal URL. For example, go to
http://bi_node_name/ibmcognos/.

3. On the Welcome page, click Administer IBM Cognos Content.
4. On the Configuration tab, click Dispatchers and Services.
5. Click the name of your IBM Cognos BI dispatcher instance. For example, click

http://bi_node_name:9080/p2pd.
6. Click the Set Properties button for the QueryService.
7. Click the Settings tab.
8. Change the following settings so that the value is 1/3 of the total physical

memory of the BI node computer.
v Initial JVM heap size for the query service (MB)

v JVM heap size limit for the query service (MB)

9. Click OK.
10. If you are using IBM Cognos Business Intelligence 10.2.1 with Fix Pack 3 or

higher installed, do the following steps:
a. On the BI node computer, go to the configuration\xqe directory where

IBM Cognos BI is installed. For example, go to . For example,
/opt/IBM/cognos/c10_64/configuration/xqe.

b. Open dmr.properties in a text editor.
c. Ensure that the following options are set:
v cacheResultSets=false

v pushdownExtAggregatesToRelational=true

v enablePushdownThroughCustomSet=true

v pushdownTopBottomCountToRelational=true

v pushdownTopPercentSumToRelational=true

d. Save and close the file.
11. Restart the IBM Cognos BI services.
12. Additionally, the following options might also provide performance benefits:

v Increasing the Business Intelligence and data node computer hardware
configuration, such as adding memory or CPUs. For example, increasing to
128 GB of RAM for the BI node computer.

v Upgrading IBM Cognos Business Intelligence to the latest fix packs.
v Tuning your database server to have the best query performance.
v When you use Top Count against a large data set, you might want to create

additional data marts that identify and preload the top N dimensions by
the relevant measures. Schedule the loading process for off hours.

v If you develop custom list reports and need to improve performance, use
relational query subjects, rather than the dimensional model. For an
example, see the Subscriber List report in the Telecommunications Customer
Management with Mobile Service Insights industry accelerator.
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Notices

This information was developed for products and services offered worldwide.

This material may be available from IBM in other languages. However, you may be
required to own a copy of the product or product version in that language in order
to access it.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service. This document may
describe products, services, or features that are not included in the Program or
license entitlement that you have purchased.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
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Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Software Group
Attention: Licensing
3755 Riverside Dr.
Ottawa, ON
K1V 1B7
Canada

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.
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This Software Offering does not use cookies or other technologies to collect
personally identifiable information.

Trademarks

IBM, the IBM logo and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “ Copyright and
trademark information ” at www.ibm.com/legal/copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:
v Microsoft, Windows, Windows NT, and the Windows logo are trademarks of

Microsoft Corporation in the United States, other countries, or both.
v Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,

Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

v Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.

v UNIX is a registered trademark of The Open Group in the United States and
other countries.

v Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.
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