
IBM SPSS Statistics - Essentials for
R: Installation Instructions for UNIX
Server

The following instructions are for installing IBM® SPSS® Statistics - Essentials for R on UNIX
Server operating systems.

Overview
IBM® SPSS® Statistics - Essentials for R provides you with tools you need to start developing
custom R applications for use with IBM® SPSS® Statistics. It includes the following:

E The IBM® SPSS® Statistics - Integration Plug-In for R for SPSS Statistics 20

E A set of working examples of R applications for SPSS Statistics

Install the IBM SPSS Statistics application
IBM® SPSS® Statistics - Essentials for R is designed for the following applications:

IBM SPSS Statistics Server for UNIX

There are no additional operating system and hardware requirements. The components installed
with Essentials for R work with any valid IBM® SPSS® Statistics license.

If you have not already done so, follow the instructions provided with the software to install one
of the SPSS Statistics applications on the computer where you will install Essentials for R.

Note for 32-bit version of IBM SPSS Statistics Server for Linux
If you will be using the IBM® SPSS® Statistics - Integration Plug-In for R with the 32-bit version
of IBM® SPSS® Statistics Server for Linux, then you will need to download and install R version
2.12, rather than version 2.8 described below. References to R version 2.8 should be replaced with
R version 2.12 in the remainder of this document.

Download and install R 2.8
Version 20 of IBM® SPSS® Statistics - Essentials for R requires R version 2.8 (version
2.8.1 is recommended). Install R on the computer where you will install Essentials for
R. It is available from http://www.r-project.org/. You can also download it directly from
ftp://ftp.stat.math.ethz.ch/Software/CRAN/src/base/R-2/.

E Create a temporary directory where you will uncompress and unpack the R source. For example,
at a command prompt type:

mkdir ~/Rsource
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E Download the R source file, for example R-2.8.1.tar.gz , from http://www.r-project.org/ (or
ftp://ftp.stat.math.ethz.ch/Software/CRAN/src/base/R-2/) and save it to the temporary directory.

E Change to the temporary directory. For example, at a command prompt type:

cd ~/Rsource

E Uncompress and unpack the R source to the temporary directory. For example, at a command
prompt type:

tar xzf R-2.8.1.tar.gz

E Change to the source directory. For example, at a command prompt type:

cd R-2.8.1

Following are platform-specific instructions for building R. If you need to interrupt the build
process while it is running, follow the instructions in the section To Rerun the R 2.8.1 build
process before you restart the build.

Note: For AIX, HP-UX, and Solaris, proper functioning of the IBM® SPSS® Statistics -
Integration Plug-In for R requires that R is built with the libiconv library. In addition, it is
recommended to also build R with the libpng, ligjpeg, and zlib libraries. Please install these
libraries before starting the build process.

AIX

E Download and install the patch from http://prs.ism.ac.jp/~nakama/AIX/AIX_R-2.8.1_fix.patch.

E To specify necessary compiler settings and ensure the compiler is on the path, execute the
following commands:

export CC="xlc_r -q64"
export CXX="xlC_r -q64"
export CXXFLAGS="-O -qstrict"
export CFLAGS="-O -qstrict"
export F77="xlf_r -q64"
export AR="ar -X64"
export CPPFLAGS="<LIBICONV>/include <LIBPNG>/include <LIBJPEG>/include <LIBZ>/include -I/usr/lpp/X11/include/X11"
export LDFLAGS="<LIBICONV>/lib <LIBPNG>/lib <LIBJPEG>/lib <LIBZ>/lib -L/usr/lib -L/usr/X11R6/lib"
export OBJECT_MODE="64"
export PATH=/usr/java5_64/bin:/opt/gnu/bin:/usr/vacpp/bin:.:$PATH

where <LIBICONV>, <LIBPNG>, <LIBJPEG>, and <LIBZ> are the installation locations of the
libiconv, libpng, ligjpeg, and zlib libraries respectively.

E Configure R using the following command:

./configure –prefix=<R_HOME> –enable-R-shlib –enable-BLAS-shlib –with-x –with-readline=no

where <R_HOME> is the location where R 2.8.1 is to be installed—for example, /usr/local/R-2.8.1.

E Run make and make install to build and install R 2.8.1.

http://www.r-project.org/
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Solaris

E To specify necessary compiler settings and ensure the compiler is on the path, execute the
following commands:

export CC="cc -xarch=v9"
export CFLAGS="-xO5 -xlibmil -dalign"
export F77="f95 -xarch=v9"
export FFLAGS="-xO5 -xlibmil -dalign"
export CXX="CC -xarch=v9"
export CXXFLAGS="-xO5 -xlibmil -dalign"
export FC="f95 -xarch=v9"
export FCFLAGS="-xO5 -xlibmil -dalign"
export CPPFLAGS="<LIBICONV>/include <LIBPNG>/include <LIBJPEG>/include <LIBZ>/include"
export LDFLAGS="-L/usr/local/SUNWspro/lib/v9 -L/usr/SUNWspro/lib/v9 <LIBICONV>/lib <LIBPNG>/lib <LIBJPEG>/lib <LIBZ>/lib"
export LIBnn="lib"
export PATH=/usr/xpg4/bin:/opt/SUNWspro/bin:$PATH

where <LIBICONV>, <LIBPNG>, <LIBJPEG>, and <LIBZ> are the installation locations of the
libiconv, libpng, ligjpeg, and zlib libraries respectively.

E Configure R using the following command:

./configure –prefix=<R_HOME> –enable-R-shlib –with-x –with-readline=no

where <R_HOME> is the location where R 2.8.1 is to be installed—for example, /usr/local/R-2.8.1.

E Run make and make install to build and install R 2.8.1.

Linux and zLinux

E If you will be using the Integration Plug-In for R with the 64-bit version of IBM® SPSS® Statistics
Server for UNIX, then execute the following commands to specify necessary compiler settings:

export CC="gcc -m64"
export CXXFLAGS="-m64 -O2 -g"
export FFLAGS="-m64 -O2 -g"
export FCFLAGS="-m64 -O2 -g"
export LDFLAGS="-L/usr/local/lib64"
export LIBnn=lib

or:

E If you will be using the Integration Plug-In for R with the 32-bit version of SPSS Statistics Server
for UNIX, then execute the following commands to specify necessary compiler settings:

export CC="gcc -m32"
export CXXFLAGS="-m32 -O2 -g"
export FFLAGS="-m32 -O2 -g"
export FCFLAGS="-m32 -O2 -g"
export LDFLAGS="-L/usr/local/lib"
export LIBnn=lib
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E Configure R using the following command:

./configure –prefix=<R_HOME> –enable-R-shlib –with-x

where <R_HOME> is the location where R 2.8.1 is to be installed—for example, /usr/local/R-2.8.1.

E Run make and make install to build and install R 2.8.1.

HP-UX

E To specify necessary compiler settings, execute the following commands:

export SHLIB_PATH=/usr/lib/hpux64:.:$SHLIB_PATH
export CC="cc"
export CFLAGS="-AC99 +DD64"
export CXX="aCC"
export CXXFLAGS="-b +DD64"
export F77="f90"
export FFLAGS="+DD64"
export CPPFLAGS="<LIBICONV>/include <LIBPNG>/include <LIBJPEG>/include <LIBZ>/include"
export LDFLAGS="-L/opt/fortran90/lib -L/usr/lib/hpux64 <LIBICONV>/lib <LIBPNG>/lib <LIBJPEG>/lib <LIBZ>/lib"

where <LIBICONV>, <LIBPNG>, <LIBJPEG>, and <LIBZ> are the installation locations of the
libiconv, libpng, ligjpeg, and zlib libraries respectively.

E Configure R using the following command:

./configure –prefix=<R_HOME> –enable-R-shlib –with-x –with-readline=no

where <R_HOME> is the location where R 2.8.1 is to be installed—for example, /usr/local/R-2.8.1.

E In the file config.h, located in the src/include folder (under the R source folder), change "#define
HAVE_STDBOOL_H 1" to "/*#define HAVE_STDBOOL_H 1*/" . For example:

sed 's/\#define HAVE_STDBOOL_H 1/\/\*\#define HAVE_STDBOOL_H 1\*\//' ./src/include/config.h > ./src/include/tempfile1
rm -f ./src/include/config.h
mv ./src/include/tempfile1 ./src/include/config.h

E In the file lock.c, located in the src/extra/intl folder, change "{PTHREAD_ONCE_INIT}" to
"PTHREAD_ONCE_INIT". For example:

sed 's/{PTHREAD_ONCE_INIT}/PTHREAD_ONCE_INIT/' ./src/extra/intl/lock.c > ./src/extra/intl/tempfile1
rm -f ./src/extra/intl/lock.c
mv ./src/extra/intl/tempfile1 ./src/extra/intl/lock.c

E Run gmake and gmake install to build and install R 2.8.1.

Test R

To test R from the command line, you will need to add the R library to the LD_LIBRARY_PATH
environment variable (or whichever environment variable is appropriate for shared libraries
on your operating system). In the following, <R_HOME> is the location where R 2.8.1 is
installed—for example, /usr/local/R-2.8.1.
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For example, for AIX, at the UNIX prompt type:

export LIBPATH=<R_HOME>/lib/R/lib:.:$LIBPATH

Or, for Linux, zLinux, or Solaris, at the UNIX prompt type:

export LD_LIBRARY_PATH=<R_HOME>/lib/R/lib:.:$LD_LIBRARY_PATH

Or, for HP-UX, at the UNIX prompt type:

export SHLIB_PATH=<R_HOME>/lib/R/lib:.:$SHLIB_PATH

E Test R to make sure that it can run. For example, at the UNIX prompt type:

cd /usr/local/R-2.8.1/bin

./R

You should see a message from R and the R prompt (for example, >). You can end the R session
by typing q(). You may want to remove the R source directory to recover disk space.

Download and install IBM SPSS Statistics - Essentials for R
Be sure to use a version of IBM® SPSS® Statistics - Essentials for R that is compatible with the
version of IBM® SPSS® Statistics on your machine. Within a major version of SPSS Statistics,
such as 20, you must use a version of Essentials for R that has the same major version. It is not
necessary to uninstall earlier versions of Essentials for R before installing a newer version.

For users who are working in distributed mode (with SPSS Statistics Server) please install
Essentials for R on both the client and server machines.

E Download version 20 of Essentials for R, available from the SPSS community at
http://www.ibm.com/developerworks/spssdevcentral. Be sure to download the version of
Essentials for R for the operating system of your SPSS Statistics application.

The following steps document the silent installer using a response file. You can also execute
the installer directly to launch a graphic version of the installer. You will need an X Window
System to do so.

Note: If you did not build R from source, then you may need to install particular compilers before
installing Essentials for R. Following is a list of required compilers by platform:

AIX. xlc_r, xlC_r, and xlf_r
Linux and z-Linux. gcc, gfortran
HP-UX. cc, aCC, f90
Solaris. cc, f95

E Change to the directory where you downloaded Essentials for R.

E Using a text editor, create a response file named installer.properties.

E Add the following properties and associated values to the response file:

INSTALLER_UI=silent
USER_SPSS_HOME=<IBM SPSS Statistics location>

http://www.ibm.com/developerworks/spssdevcentral
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USER_R_HOME=<(R 2.8.1)/lib/R directory>

where <IBM SPSS Statistics location> is the installation location of IBM SPSS Statistics and <(R
2.8.1)/lib/R directory > is the path to the lib/R directory under the location where R 2.8.1 is
installed. For example, if R 2.8.1 is installed in /usr/local/R-2.8.1, then:

USER_SPSS_HOME=/opt/IBM/SPSS/StatisticsServer20
USER_R_HOME=/usr/local/R-2.8.1/lib/R

E Save installer.properties to the directory containing the .bin file for Essentials for R and change
to that directory.

E Run the installer with the following command:

./<installer_name>

where <installer_name> is the name of the .bin file for Essentials for R. Note: You must run the
previous command as root, either by logging in as root or using the sudo command.

As part of the installation, any R packages required by the R examples will be automatically
downloaded over the Internet if possible. This may take a few minutes.

Note: To use a different response file (other than installer.properties), run the installer with the
following command:

./<installer_name> -f <response file name>

Configure the environment for the IBM SPSS Statistics - Integration
Plug-In for R

The IBM® SPSS® Statistics - Integration Plug-In for R requires additions to the
LD_LIBRARY_PATH environment variable (or whichever environment variable is appropriate for
shared libraries on your operating system). For convenience you may want to put these settings in
a profile file so that they will be set upon login. In the following, <SPSS_HOME> is the location
where version 20 of the IBM® SPSS® Statistics application is installed, and <R_HOME> is the
location where R 2.8.1 is installed—for example, /usr/local/R-2.8.1.

E For example, for AIX:

export LIBPATH=<R_HOME>/lib/R/lib:<SPSS_HOME>/lib:/usr/lib:/lib:.:$LIBPATH

For example, for Solaris:

export LD_LIBRARY_PATH=

/usr/local/lib/sparcv9:<R_HOME>/lib/R/lib:<SPSS_HOME>/lib:/opt/SUNWspro/lib:.:$LD_LIBRARY_PATH

For example, for Linux and zLinux:

export LD_LIBRARY_PATH=<R_HOME>/lib/R/lib:<SPSS_HOME>/lib:/lib64:.:$LD_LIBRARY_PATH
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Notes

To support conversions between code page and Unicode, the plug-in uses the iconv library.
You will need to add the path to the iconv library on your machine to the LD_LIBRARY_PATH
environment variable. For example, on Solaris, add the path to the libiconv.so.2 library.
On Solaris, you may need to add the following libraries to the LD_LIBRARY_PATH
environment variable: libgcc_s.so.1, libfui.so.2, libstdc++.so.5.

To Rerun the R 2.8.1 build process

If you have to stop the R build process before it completes, you need to delete the files that were
created by the process before attempting to rerun the process. For example, assuming that the R
2.8.1 source is located in ~/Rsource, from the UNIX prompt type:

cd ~/Rsource

make clean

Before you start using the IBM SPSS Statistics - Integration Plug-In
for R

After you install IBM® SPSS® Statistics - Essentials for R, you will be able to start developing
R applications with the IBM® SPSS® Statistics - Integration Plug-In for R. Documentation for
the plug-in is provided in R Integration Package for IBM SPSS Statistics.pdf, included with the
zip file for Essentials for R. It describes how to use the plug-in and all of the functions available
with the plug-in.

Accessing the R examples

IBM® SPSS® Statistics - Essentials for R includes a set of working examples of custom R
procedures for IBM® SPSS® Statistics. All examples include custom dialogs and all but one
(Rboxplot) also include an extension command. Following are the menu locations of the custom
dialogs for the R examples:

Analyze>Correlate>Heterogeneous Correlations
Analyze>Regression>Quantile Regression
Analyze>Regression>Residual Heteroscedasticity Test
Analyze>Regression>Robust Regression
Analyze>Regression>Tobit Regression
Analyze>Scale>Rasch Model
Graphs>R Boxplot

The Heterogeneous Correlations example requires both the IBM® SPSS® Statistics - Integration
Plug-In for R and the IBM® SPSS® Statistics - Integration Plug-In for Python. The Integration
Plug-In for Python is included with IBM® SPSS® Statistics - Essentials for Python, available
from the SPSS community at http://www.ibm.com/developerworks/spssdevcentral.

http://www.ibm.com/developerworks/spssdevcentral
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If one of the Analyze menu items is not present in your SPSS Statistics product, then please
look on the Custom menu for the Analyze menu dialogs—for example, Custom>Heterogeneous
Correlations.

The implementation code and XML specification files for extension commands associated with
the custom dialogs can be found in the extensions directory under the SPSS Statistics Server
installation directory. The following files are installed:

Heterogeneous Correlations. SPSSINC_HETCOR.py and SPSSINC_HETCOR.xml
Quantile Regression. SPSSINC_QUANTREG.R and SPSSINC_QUANTREG.xml
Residual Heteroscedasticity Test. SPSSINC_BREUSCH_PAGAN.R and
SPSSINC_BREUSCH_PAGAN.xml
Robust Regression. SPSSINC_ROBUST_REGR.R and SPSSINC_ROBUST_REGR.xml
Tobit Regression. SPSSINC_TOBIT_REGR.R and SPSSINC_TOBIT_REGR.xml
Rasch Model. SPSSINC_RASCH.R and SPSSINC_RASCH.xml

Notes

Help for each of the procedures accessible from the menus is available from the Help button
on the associated dialog box. The help is not, however, integrated with the SPSS Statistics
Help system.
Complete syntax help for each of the extension commands associated with the custom dialogs
is available by executing the command and including the /HELP subcommand. The command
name is the name of the associated implementation file without underscores—for example:

SPSSINC HETCOR /HELP.

The command syntax help is not, however, integrated with the SPSS Statistics Help system
and is not included in the Command Syntax Reference.
The dialogs were created with the Custom Dialog Builder in SPSS Statistics. You can view
the design for any of the dialogs and/or customize them using the Custom Dialog Builder,
available from Utilities>Custom Dialogs>Custom Dialog Builder. To view the design for a
dialog, choose File>Open Installed from within the Custom Dialog Builder.
If you have specified alternate locations for extension commands with the
SPSS_EXTENSIONS_PATH environment variable then the implementation and specification
files will be located in the first writable location in that variable instead of in the extensions
directory.
You may need to set your SPSS Statistics locale to match the SPSS Statistics output language
(OLANG) in order to display extended characters properly, even when working in Unicode
mode. For example, if the output language is Japanese then you may need to set your SPSS
Statistics locale to Japanese, as in SET LOCALE='japanese'.
Other extension commands that are not included in Essentials for R are available for download
from the SPSS community.

Uninstalling IBM SPSS Statistics - Essentials for R components
E Start a terminal program.
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E Change the directory to Uninstall_IBM_SPSS_Statistics_Essentials_for_R_20 in the IBM®
SPSS® Statistics installation directory.

E At the command prompt, type:

./Uninstall_IBM_SPSS_Statistics_Essentials_for_R_20

Important: You must have permissions to remove the installation directory, or the uninstallation
process will fail.
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