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IBM SPSS Statistics - Essentials for R: Installation
Instructions for AIX

IBM SPSS Statistics - Essentials for R: Installation Instructions for AIX
The following instructions are for installing IBM® SPSS® Statistics - Essentials for R on AIX® operating
systems.

Overview
IBM SPSS Statistics - Essentials for R provides you with tools you need to start developing custom R
applications for use with IBM SPSS Statistics. It includes the following:
1. The IBM SPSS Statistics - Integration Plug-in for R for IBM SPSS Statistics 24
2. A set of working examples of R applications for IBM SPSS Statistics

Install the IBM SPSS Statistics application
IBM SPSS Statistics - Essentials for R is designed for the following applications:
v IBM SPSS Statistics Server for AIX

The components installed with IBM SPSS Statistics - Essentials for R work with any valid IBM SPSS
Statistics license.

If you have not already done so, follow the instructions provided with the software to install one of the
IBM SPSS Statistics applications on the computer where you will install IBM SPSS Statistics - Essentials
for R.

Download and install R 3.2
Version 24 of IBM SPSS Statistics - Essentials for R requires R version 3.2 (version 3.2.2 is recommended).
Install R on the computer where you will install IBM SPSS Statistics - Essentials for R.

R version 3.2 is available from http://www.r-project.org/. You can also download it directly from
ftp://ftp.stat.math.ethz.ch/Software/CRAN/src/base/R-3/.

Note: An AIX expert with RPM experience is required. The expert is expected to have an advanced skill
set, not limited to but including the following: installing RPM packages; building open source software
using IBM native C and Fortran compilers, as well as GNU make; installing and configuring X11,
including the X Virtual Frame Buffer.

Environment requirements

OS: AIX6.1 or AIX7.1

Compiler: IBM XL C/C++ for AIX, V12 .1 and IBM XL FORTRAN for AIX, V14.1

R-3.2 depends on the 3rd party packages that are listed in the following table. Upload these RPM files to
the AIX server before installing R and run the following command as root to install them:

# rpm -U --nodeps ./*.rpm
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Note: If any warning messages are displayed when the rpm -U command is run, then execute the rpm
-qsi command to check the installation result. For example: # rpm – qsi bash-4.2-9. If "normal" is
returned, the RPM files were installed successfully. For more information, refer to the RPM command
reference.

Table 1. Required RPM files

RPM file URL

bash-4.2-9.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2091

blas-3.4.1-2.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2095

bzip2-1.0.6-2.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1439

cairo-1.12.2-3.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2011

expat-2.1.0-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1639

fontconfig-2.8.0-4.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1412

freetype2-2.4.4-3.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1414

gettext-0.17-8.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2013

glib2-2.31.2-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2017

info-5.0-2.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1918

jbigkit-libs-2.0-3.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1422

libICE-1.0.8-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1718

libSM-1.2.1-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1722

libXft-2.2.0-3.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1423

libXrender-0.9.6-5.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2092

libffi-3.0.11-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1587

libjpeg-8d-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1874

libpng-1.5.10-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1878

libtiff-4.0.1-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1880

libxml2-2.9.1-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1841

pango-1.30.1-2.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2025

pcre-8.12-3.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1460

pixman-0.26.0-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1589

readline-6.2-3.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1464

tcl-8.4.19-1.aix5.3.ppc.rpm http://www-frec.bull.com/affichage.php?id=1047

tk-8.4.19-1.aix5.3.ppc.rpm http://www-frec.bull.com/affichage.php?id=1052

xz-libs-5.0.4-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1890

zlib-1.2.5-6.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1908

gmp-5.1.3-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2046

lapack-3.4.1-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1612

libiconv-1.14-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2024

mpfr-3.1.2-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=2049

pkg-config-0.25-3.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1462

readline-devel-6.2-3.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1465

texinfo-5.0-2.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1920

xz-5.0.4-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1888
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Table 1. Required RPM files (continued)

RPM file URL

xz-devel-5.0.4-1.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1889

zlib-devel-1.2.5-6.aix6.1.ppc.rpm http://www-frec.bull.com/affichage.php?id=1909

make-3.81-1.aix6.1.ppc.rpm ftp://ftp.boulder.ibm.com/aix/freeSoftware/aixtoolbox/

RPMS/ppc/make/make-3.81-1.aix6.1.ppc.rpm

Building and installing R
1. Create a temporary directory where you will uncompress and unpack the R source. For example, at

a command prompt type:
mkdir ~/Rsource

2. Download the source code for building R, for example R-3.2.2.tar.gz, and save it to the temporary
directory.

3. Change to the temporary directory. For example, at a command prompt type:
cd ~/Rsource

4. Uncompress and unpack the R source to the temporary directory. For example, at a command
prompt type:
gzip –d –c R-3.2.2.tar.gz | tar –xvf –

5. Change to the source directory. For example, at a command prompt type:
cd R-3.2.2

Note: To install R to the default directory, you must run the following step as root, either by logging
in as root or using the sudo command. It is recommended that you read the information in
doc/html/R-admin.html (located under the directory where you unpacked the R source) before
proceeding with configuring, building and installing R.

6. Verify that the /tmp directory in your file system has over 200MB of free disk space.
7. Edit ~/Rsource/R-3.2.2/src/extra/tre/tre-internal.h and change the following section (please refer to the

patch at https://r-forge.r-project.org/scm/viewvc.php/patches/aix_R210_tre.patch?view=markup
&root=aix:
---------------------------------------
/* Wide characters. */
typedef wint_t tre_cint_t;
#define TRE_CHAR_MAX WCHAR_MAX
---------------------------------------

to:
---------------------------------------
/* Wide characters. */
typedef wint_t tre_cint_t;
/*
WCHAR_MAX not possible to function for UINT32_MAX on AIX.
AIX 64bit WCHAR_MAX = UINT32_MAX
Solaris-sparcv9 WCHAR_MAX = INT32_MAX
Linux amd64 WCHAR_MAX = INT32_MAX
*/
#if (WCHAR_MAX == UINT32_MAX)
#define TRE_CHAR_MAX INT32_MAX
#else
#define TRE_CHAR_MAX WCHAR_MAX
#endif
---------------------------------------

8. Edit ~/Rsource/R-3.2.2/configure and delete the line: "#define HAVE_STDALIGN_H 1".
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9. To specify necessary compiler settings and ensure the compiler is on the path, execute the following
commands:
export CC="/usr/vacpp/bin/xlc_r -q64"
export CXX="/usr/vacpp/bin/xlC_r -q64"
export CXXFLAGS="-I/opt/freeware/include -I/usr/include -qrtti=all -qarch=auto -qcache=auto

-qtune=auto -qstrict -qmaxmem=16384 -U__STR__ -qnolibansi"
export CFLAGS="-I/opt/freeware/include -I/usr/include -qrtti=all -qarch=auto -qcache=auto

-qtune=auto -qstrict -qmaxmem=16384 -U__STR__ -qnolibansi"
export FC="/usr/bin/xlf_r -q64"
export F77="/usr/bin/xlf_r -q64"
export CPPFLAGS="-I/opt/freeware/include -I/usr/include"
export LDFLAGS="-L/opt/freeware/lib64 -L/opt/freeware/lib -L/usr/lib64 -L/usr/lib"
export FFLAGS="-I/opt/freeware/include -I/usr/include -qarch=auto -qcache=auto -qtune=auto

-qstrict -qmaxmem=16384"
export FCLAGS="-I/opt/freeware/include -I/usr/include -qarch=auto -qcache=auto -qtune=auto

-qstrict -qmaxmem=16384"
export AR="ar -X64"
export OBJECT_MODE="64"

10. Configure, build, and install R. Be sure to configure R with the --enable-R-shlib and --with-x
arguments. For example, at a command prompt type:
./configure --with-ICU=no --with-system-pcre --with-system-zlib --with-system-bzlib
--enable-R-shlib --with-x --enable-BLAS-shlib --without-recommended-packages && gmake && gmake install

11. Add <R_HOME>/bin to the PATH environment variable. For example:
export PATH=<R_HOME>/bin:$PATH

<R_HOME> is the location where R 3.2.2 is to be installed—for example, /usr/local/R-3.2.2.

Install the recommended packages
1. Uncompress ~/Rsource/R-3.2.2/src/library/Recommended/Matrix_1.1-2.tar.gz. Edit ~/Matrix/src/CHOLMOD/

Include/cholmod_blas.h and change the following section:
-----------------------------------------------------
#elif defined (_AIX) || defined (MIBM_RS) || defined (ARCH_IBM_RS)
#define CHOLMOD_AIX
#define CHOLMOD_ARCHITECTURE "IBM AIX"
/* recent reports from IBM AIX seem to indicate that this is not needed: */
/* #define BLAS_NO_UNDERSCORE */
-----------------------------------------------------

to:
-----------------------------------------------------
#elif defined (_AIX) || defined (MIBM_RS) || defined (ARCH_IBM_RS)
#define CHOLMOD_AIX
#define CHOLMOD_ARCHITECTURE "IBM AIX"
/* recent reports from IBM AIX seem to indicate that this is not needed: */
#define BLAS_NO_UNDERSCORE
-----------------------------------------------------

Compress to ~/Rsource/R-3.2.2/src/library/Recommended/Matrix_1.1-2.tar.gz.
2. Change the directory to /R-3.2.2/src/library/Recommended/ and run R.

cd /R-3.2.2/src/library/Recommended/
R

3. Install the recommended R packages.
> install.packages("./KernSmooth_2.23-15.tar.gz", repos=NULL)
> install.packages("./MASS_7.3-43.tar.gz", repos=NULL)
> install.packages("./lattice_0.20-33.tar.gz", repos=NULL)
> install.packages("./Matrix_1.2-2.tar.gz", repos=NULL)
> install.packages("./boot_1.3-17.tar.gz", repos=NULL)
> install.packages("./class_7.3-13.tar.gz", repos=NULL)
> install.packages("./cluster_2.0.3.tar.gz", repos=NULL)
> install.packages("./codetools_0.2-14.tar.gz", repos=NULL)
> install.packages("./foreign_0.8-65.tar.gz", repos=NULL)
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> install.packages("./nlme_3.1-121.tar.gz", repos=NULL)
> install.packages("./nnet_7.3-10.tar.gz", repos=NULL)
> install.packages("./rpart_4.1-10.tar.gz", repos=NULL)
> install.packages("./spatial_7.3-10.tar.gz", repos=NULL)
> install.packages("./survival_2.38-3.tar.gz", repos=NULL)
> install.packages("./mgcv_1.8-7.tar.gz", repos=NULL)

Test R
To test R from the command line, you will need to add the R library to the LIBPATH environment
variable. In the following, <R_HOME> is the location where R 3.2 is installed--for example,
/usr/local/R-3.2.2.

For example, at the UNIX prompt type:

export LIBPATH=<R_HOME>/lib/R/lib:.:$LIBPATH

Test R to make sure that it can run. For example, at the UNIX prompt type:

cd /usr/local/R-3.2.2/bin

./R

You should see a message from R and the R prompt (for example, >). You can end the R session by
typing q(). You may want to remove the R source directory to recover disk space.

Download and install IBM SPSS Statistics - Essentials for R
Be sure to use a version of IBM SPSS Statistics - Essentials for R that is compatible with the version of
IBM SPSS Statistics Server on your machine. Within a major version of IBM SPSS Statistics, such as 24,
you must use a version of IBM SPSS Statistics - Essentials for R that has the same major version. It is not
necessary to uninstall earlier versions of IBM SPSS Statistics - Essentials for R before installing a newer
version.

For users who are working in distributed mode (with IBM SPSS Statistics Server) please install IBM SPSS
Statistics - Essentials for R on both the client and server machines.

Download version 24 of IBM SPSS Statistics - Essentials for R, available from the IBM SPSS Predictive
Analytics community at https://developer.ibm.com/predictiveanalytics/predictive-extensions/. Be sure
to download the version of IBM SPSS Statistics - Essentials for R for the operating system of your IBM
SPSS Statistics application.

Important:

v If you are installing Essentials for R on a computer that does not have internet access and you plan to
use the working R examples included with Essentials for R, then you must obtain any R packages that
are required by those examples and manually install them in R. To determine which R packages are
required for a specific R example, open the Extension Hub (Extensions > Extension Hub), go to the
Installed tab and click More info for the example that you want (each example is installed as a
separate extension). The required R packages are listed in the Dependencies section on the Extension
Details dialog. R packages can be obtained from any of the R CRAN mirror sites, which are accessed
from http://www.r-project.org/. Be sure to obtain the versions of the packages that match your R
version. The version-specific packages are available from links on the "Contributed Packages" page of
the CRAN mirror site.

1. Change to the directory where you downloaded IBM SPSS Statistics - Essentials for R.
The following steps document the silent installer using a response file. You can also execute the
installer directly to launch a graphic version of the installer. You will need an X Window System to do
so.
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2. Using a text editor, create a response file named installer.properties.
3. Add the following properties and associated values to the response file:

INSTALLER_UI=silent
USER_SPSS_HOME=<IBM SPSS Statistics location>
USER_R_HOME=<(R 3.2)/lib/R directory>

where <IBM SPSS Statistics location> is the installation location of IBM SPSS Statistics and <(R
3.2)/lib/R directory > is the path to the lib/R directory under the location where R 3.2 is installed. For
example, if R 3.2 is installed in /usr/local/R-3.2.2, then:

USER_SPSS_HOME=/opt/IBM/SPSS/StatisticsServer24
USER_R_HOME=/usr/local/R-3.2.2/lib/R

4. Save installer.properties to the directory containing the .bin file for IBM SPSS Statistics - Essentials for R
and change to that directory.

5. Run the installer with the following command:
./<installer_name>

where <installer_name> is the name of the .bin file for IBM SPSS Statistics - Essentials for R. Note: You
must run the previous command as root, either by logging in as root or using the sudo command.

As part of the installation, any R packages required by the R examples will be automatically downloaded
over the Internet if possible. This may take a few minutes. If you experience problems with any required
R packages (particularly for AIX), then you might need to download the packages and manually install
them.

Note: To use a different response file (other than installer.properties), run the installer with the following
command:

./<installer_name> -f <response file name>

Configure the environment for the IBM SPSS Statistics - Integration
Plug-in for R
The IBM SPSS Statistics - Integration Plug-in for R requires additions to the LD_LIBRARY_PATH
environment variable (or whichever environment variable is appropriate for shared libraries on your
operating system). Add these settings to the file statsenv.sh, which is under the location where IBM
SPSS Statistics is installed.

For example, at the UNIX prompt type:
export LIBPATH=
<R_HOME>/lib/R/lib:/opt/freeware/lib64:/opt/freeware/lib:/usr/lib64:/usr/lib:<SPSS_HOME>/lib:.:$LIBPATH

In the preceding statement, <SPSS_HOME> is the location where version 24 of the IBM SPSS Statistics
application is installed, and <R_HOME> is the location where R 3.2 is installed--for example,
/usr/local/R-3.2.2.

Note:

v To support conversions between code page and Unicode, the plug-in uses the iconv library. You must
add the path to the iconv, libpng, libjpeg and zlib libraries on your computer to the
LD_LIBRARY_PATH environment variable (or whichever environment variable is appropriate for
shared libraries on your operating system).

v To display R graphs in the IBM SPSS Statistics output viewer when working in distributed mode, you
must configure X11 on the server and set the DISPLAY environment variable.
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To Rerun the R 3.2 build process
If you have to stop the R build process before it completes, you need to delete the files that were created
by the process before attempting to rerun the process. For example, assuming that the R3.2 source is
located in ~/Rsource, from the UNIX prompt type:

cd ~/Rsource

make clean

Before you start using the IBM SPSS Statistics - Integration Plug-in for
R
After you install IBM SPSS Statistics - Essentials for R, you will be able to start developing R applications
with the IBM SPSS Statistics - Integration Plug-in for R. Documentation for the plug-in is provided in R
Integration Package for IBM SPSS Statistics.pdf, which is included with the documentation for your IBM
SPSS Statistics product. It describes how to use the plug-in and all of the functions available with the
plug-in.

Accessing the R examples

IBM SPSS Statistics - Essentials for R includes a set of working examples of R extensions for IBM SPSS
Statistics that provide capabilities beyond what is available with built-in SPSS Statistics procedures. All of
the R extensions include a custom dialog and an extension command. The extension commands can be
run from SPSS Statistics command syntax in the same manner as any built-in command such as
FREQUENCIES. You can generate command syntax for each extension command from the associated custom
dialog.

Table 2. Listing of R extensions.

Menu location Command name Description

Analyze>Reports>Apriori SPSSINC APRIORI Discover frequent itemsets, association rules
using the Apriori algorithm.

Analyze>Correlate>Heterogeneous
Correlations

SPSSINC HETCOR Calculate correlations between nominal,
ordinal, and scale variables.

Analyze>Descriptive
Statistics>Two-Variable or Group
Q-Q Plot

SPSSINC QQPLOT2 Two variable or two group Q-Q plot.

Analyze>Regression>Quantile
Regression

SPSSINC QUANTREG Estimate one or more conditional quantiles
for a linear model.

Analyze>RanFor Estimation SPSSINC RANFOR Estimate random forest.

Analyze>Ranfor Prediction SPSSINC RANPRED Compute predicted values for new data
using forests from SPSSINC RANFOR.

Analyze>Regression>Robust
Regression

SPSSINC ROBUST REGR Estimate a linear regression model by robust
regression, using an M estimator.

Analyze>Regression>Tobit
Regression

SPSSINC TOBIT REGR Estimate a regression model whose
dependent variable has a fixed lower bound,
upper bound, or both.

Analyze>Survival>Cox Regression
Extension

STATS COXREGR Cox (proportional hazards) regression.

Analyze>Classify>Predict Using
Density Cluster

STATS DBPRED Prediction based on density-based clustering.
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Table 2. Listing of R extensions (continued).

Menu location Command name Description

Analyze>Classify>Density-Based
Clustering

STATS DBSCAN Density-based clustering.

Analyze>Regression>Equation
Systems

STATS EQNSYSTEM Estimate system of linear equations.

Analyze>Scale>Extended Rasch STATS EXRASCH Calculate standard and extended Rasch
models.

Analyze>Regression>Firth Logistic
Regression

STATS FIRTHLOG Firth logistic regression.

Analyze>Forecasting>GARCH
Models

STATS GARCH GARCH models.

Analyze>Generalized Linear
Models>Generalized Boosted
Regression

STATS GBM Estimate generalized boosted regression
models.

Analyze>Generalized Linear
Models>Generalized Boosted
Regression Prediction

STATS GBMPRED Calculate predictions for generalized boosted
regression models.

File>Get R Workspace STATS GET R Get information about R workspace contents
and create SPSS datasets.

Analyze>Scale>Graded Response
Model

STATS GRM Fit graded response models to ordinal data.

Analyze>Scale>Item Response
Model

STATS IRM Fit three parameter item response models.

Analyze>Loglinear>Latent Class
Analysis

STATS LATENT CLASS Latent Class Analysis.

Analyze>Descriptive
Statistics>Calculate Adjusted P
Values

STATS PADJUST Calculate p-values adjusted for multiple
testing.

Analyze>Generalized Linear
Models>Proportional Regression

STATS PROPOR REGR Linear models for dependent variables that
are proportions.

Analyze>Generalized Linear
Models>Proportional Regression
Prediction

STATS PROPOR REGRPRED Calculate predicted values for proportional
regression models.

Analyze>Regression>Regression
Discontinuity

STATS RDD Regression discontinuity analysis.

Analyze>Regression>Regression
Relative Importance

STATS RELIMP Relative importance measures for regression.

Analyze>Survival>Parametric
Regression

STATS SURVREG Parametric survival regression.

Analyze>Classify>Support Vector
Machines

STATS SVM Support vector machine.

Analyze>Generalized Linear
Models>Zero-Inflated Count
Models

STATS ZEROINFL Estimate and predict a zero-inflated count
model.

Important:
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The Heterogeneous Correlations extension requires both the IBM SPSS Statistics - Integration Plug-in for
R and the IBM SPSS Statistics - Integration Plug-in for Python. The IBM SPSS Statistics - Integration
Plug-in for Python is included with IBM SPSS Statistics - Essentials for Python, which is installed by
default with your IBM SPSS Statistics product.

Notes
v Help for each of the R extensions is available from the Help button on the associated dialog box. The

help is not, however, integrated with the SPSS Statistics Help system.
v Complete syntax help for each of the extension commands is available by positioning the cursor within

the command (in a syntax window) and pressing the F1 key. It is also available by running the
command and including the /HELP subcommand. For example:

SPSSINC HETCOR /HELP.

The command syntax help is not, however, integrated with the SPSS Statistics Help system and is not
included in the Command Syntax Reference.

Note: The F1 mechanism for displaying help is not supported in distributed mode.
v If the menu location that is specified for an extension command is not present in your IBM SPSS

Statistics product, then look on the Extensions menu for the associated dialog.
v The dialogs were created with the Custom Dialog Builder in IBM SPSS Statistics. You can view the

design for any of the dialogs and you can customize them using the Custom Dialog Builder. It is
available from Extensions>Utilities>Custom Dialog Builder (Compatibility mode).... To view the
design for a dialog, choose File>Open Installed from within the Custom Dialog Builder.

v The implementation code (R source code file) and XML specification files for each of the R extension
commands can be found in the location where extension commands are installed on your computer. To
view the location, run the SHOW EXTPATHS syntax command. The output displays a list of locations
under the heading "Locations for extension commands". The files are installed to the first writable
location in the list.

v You may need to set your SPSS Statistics locale to match the SPSS Statistics output language (OLANG) in
order to display extended characters properly, even when working in Unicode mode. For example, if
the output language is Japanese then you may need to set your SPSS Statistics locale to Japanese, as in
SET LOCALE=’japanese’.

v Other extension commands that are not included in IBM SPSS Statistics - Essentials for R are available
for download from the Extension Hub, accessible from Extensions>Extension Hub. The Extension Hub
also displays any updates that are available for the extension commands included with IBM SPSS
Statistics - Essentials for R in addition to updates for any other extensions that you installed.

Note: Extensions are always installed, or downloaded, to your local computer from the Extension Hub.
If you work in distributed analysis mode, then you must separately install the extensions on the server.
For information, see Core System > Extensions> Installing local extension bundles in the Help
system.

v If you are installing extensions on SPSS Statistics Server, you can use a script to install multiple
extensions at once. For information, see Core System > Extensions> Installing local extension bundles
> Batch installation of extension bundles in the Help system.

Uninstalling IBM SPSS Statistics - Essentials for R components
1. Start a terminal program.
2. Change the directory to Uninstall_IBM_SPSS_Statistics_Essentials_for_R_24 in the IBM SPSS Statistics

installation directory.
3. At the command prompt, type:

./Uninstall_IBM_SPSS_Statistics_Essentials_for_R_24

Important: You must have permissions to remove the installation directory, or the uninstallation
process will fail.
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