
Introduction
Welcome to the Hyperion Essbase OLAP server product 
family! Hyperion Essbase is a multidimensional database 
server that is optimized for planning, analysis, and 
management reporting applications. 

The Hyperion Essbase OLAP server is a 32-bit, multithreaded 
software application that enables multiple users on multiple 
clients to work simultaneously. Hyperion Essbase uses a 
distributed, client-server model. That is, the database engine 
resides on a server and portions of the database software 
reside on each client. The server performs most of the database 
processing, thus enabling the clients to minimize query run 
time.

The Hyperion Essbase OLAP server product family consists of 
the following:

● Hyperion Essbase OLAP server

A multidimensional database management facility for 
storing data and managing analytic-data models, 
calculations, and data security

● Hyperion Essbase Application Manager

A graphical environment for developing and maintaining 
outlines and dimensions, performing data loads, creating 
complex calculations, creating partitions and reports, and 
defining security access

● Hyperion Essbase Spreadsheet Add-in

Desktop software that is integrated with Microsoft Excel 
and Lotus 1-2-3 spreadsheets to analyze data that is stored 
on the Hyperion Essbase server

● Hyperion Essbase application tools and add-ons

Tools and add-ons that are used for extending Hyperion 
Essbase applications, such as Hyperion Essbase Currency 
Conversion, Hyperion Essbase Partitions, Hyperion 
Essbase SQL Interface, Hyperion Essbase Spreadsheet 
Toolkit, and Hyperion Essbase Application Programming 
Interface (API) 

Hyperion produces a variety of additional products, several of 
which support and enhance the operation of Hyperion Essbase 
OLAP server. These products include Hyperion Objects, 
Hyperion Web Gateway, Hyperion Integration Server, 
Hyperion Wired for OLAP, and Hyperion Reporting.

The Hyperion Essbase OLAP server product family contains 
over 100 analytical functions, and offers the opportunity to 
develop effective multidimensional applications quickly. 
Hyperion Essbase is easy to deploy and supports standard 
applications, operating systems, and networking protocols.
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Your Path to Hyperion Essbase ➠ 

Hyperion Essbase Product Family

● Identify business and user requirements.

● Identify source data and determine the scope of the 
database.

● Define standard dimensions and designate sparse and 
dense dimensions.

● Identify relationships between dimensions and members.

● Define attribute dimensions.

● Consider issues such as regional and departmental 
information requirements for partitioning.

● Consider currency conversion requirements to track data in 
various currencies.

● Define the type of calculation that is associated with each 
dimension and each member.

● Calculate the size of the database, check disk space, and 
ensure that the sizes of the index, data files, and data caches 
in memory are adequate.

● Define security access for each user.

For detailed information, see the Hyperion Essbase Database 
Administrator’s Guide, Volumes I and II.

Step 1 Designing Applications and Databases
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● Start Hyperion Essbase Application Manager.

● Connect to the Hyperion Essbase server.

● Create a new application and database from the Hyperion 
Essbase Application Manager desktop window. You can 
create the application and database on the server or on the 
client.

● Double-click the name of the new database in the 
Database Outlines list box to open the database outline. 

You can also open the database outline with the 
File > Open command. In the Open Server Object 
window, ensure that Outlines is selected in the List 
Objects of Type list box.

● Add dimensions and members to the outline.

● Set dimension and member properties, such as labels, 
calculations, and storage properties.

● Check the auto-configuration of dense and sparse 
dimensions. You can turn off auto-configuration and 
choose your sparse and dense dimensions manually. 

● Create attribute dimensions and associate them with the 
appropriate base dimensions.

● Save the database outline and close Outline Editor.

For detailed information, see the Hyperion Essbase Database 
Administrator’s Guide, Volume I.

 

● Create a data source file that contains the dimensions and 
members that are to be added to the database.

● Start Hyperion Essbase Application Manager.

● Connect to the Hyperion Essbase server.

● In the Hyperion Essbase Application Manager desktop 
window, select an application and a database. The database 
must contain at least one dimension.

● To open a new rules file in the Data Prep Editor, select 
New > Data Load Rules from the File menu or click the 

rules button, , and then click the New button. 

● Open the data source file in the Data Prep Editor.

● Associate the rules file with the outline.

● To ensure that Data Prep Editor displays dimension 
building fields, select Dimension Building Fields from 
the View menu.

● In the rules file, specify the names of the new dimensions.

● Specify operations, such as the build type method, that the 
rules file should perform on the data file before loading the 
data file into the database.

● Define dimension build properties for each field in the rules 
file.

● Validate and save the rules file.

● To update the outline, open the outline and select the 
File > Update Outline command.

For detailed information, see the Hyperion Essbase Database 
Administrator’s Guide, Volume I.

Step 2 Creating Applications and Databases

Step 3 Creating a Rules File to Update an Outline
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When loading free-form data:

● Connect to the Hyperion Essbase server.

● Ensure that the data source is valid and correctly formatted 
for the database into which the data is being loaded.

● Select the application and database, and select 
Database > Load Data.

● Select the data file and start loading data.

When using a rules file to load data:

● To create a rules file, select File > New > Data Load Rules. 

● Specify the changes that the rules file should perform on 
the data file before loading the data file into the database.

● Validate and save the rules file.

● Associate the rules file with the database outline.

● Select Database > Load Data and start loading the data.

● Check results to ensure that the data load was successful.

● If the data load fails or completes only partially, check the 
error log file, correct the problem, and reload the data.

● Calculate the database.

When optimizing a data load:

● Group sparse dimensions in the outline.

● Position data in the order that it is presented in the outline.

● Load data from the server instead of the client.

● For free-form data, set up a range of records in the data 
source and minimize the data source. 

For detailed information, see the Hyperion Essbase Database 
Administrator’s Guide, Volume I.

● Decide on a type of calculation: an outline calculation, a 
calc script calculation, or a combination of both.

● Ensure that relationships between members and member 
consolidations in the database outline are correct.

● Consider whether tagging some members as Dynamic Calc 
or whether using Intelligent Calculation will improve 
calculation efficiency. 

● Consider which members you need to tag as two-pass 
calculation to ensure correct calculation results.

● Select the application and database and select 
Database > Calculate. 

● Select a calc script or the default calc and run the 
calculation.

When using a calc script:

● Use calculation commands and formulas in the calc script 
to perform specific calculations on the database.

● Group formulas and dimensions in the calc script to 
improve calculation performance.

● Associate the calc script with the database and run the calc 
script.

Optimizing calculations:

● Run test calculations on various database configurations 
to determine the optimal configuration for calculation 
performance.

● If necessary, change the order of the sparse dimensions in 
the database outline. 

Step 4 Loading Data into a Database

Step 5 Calculating Data
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● Balance data block density and size.

● When loading data incrementally by time, consider making 
the time dimension a sparse dimension.

● If the database outline has two or more flat dimensions 
(few parents but many children), to optimize calculations, 
add intermediate levels to the database outline or use the 
SET CALCHASHTBL command in a calc script.

● To maximize calculation performance, ensure that 
formulas are placed correctly. 

● If you change data in one section of the database, consider 
using Intelligent Calculation to recalculate only data blocks 
that have changed.

● Ensure that memory cache sizes are adequate and that the 
calculator cache is large enough.

● If using transparent partitions, ensure that the calculator 
cache is sufficient for optimal performance.

● Ensure that, when calculating a data block, Hyperion 
Essbase can access the required blocks.

● If necessary, use two-pass calculations.

● If necessary, aggregate #MISSING values.

● Consider loading data at parent levels instead of at level 0.

For detailed information, see the Hyperion Essbase Database 
Administrator’s Guide, Volume I.

Viewing data using Hyperion Essbase Spreadsheet Add-in:

● Add Hyperion Essbase Spreadsheet Add-in to Microsoft 
Excel or Lotus 1-2-3.

● Install the Hyperion Essbase Toolbar (for Excel only).

● Start Hyperion Essbase Spreadsheet Add-in.

● Connect to the database on the server.

● To retrieve data, select Essbase > Retrieve in the 
spreadsheet.

● To drill down to more detailed data for a member, select the 
member and select Essbase > Zoom-in.

● Alternatively, to create a query with Hyperion Essbase 
Query Designer (EQD), select Essbase > Query Designer. 

● To view the results of the query, in the navigation panel, 
click the right-mouse button and select Apply Query.

For more information, see the Hyperion Essbase Spreadsheet 
Add-in User’s Guide for Excel and the Hyperion Essbase 
Spreadsheet Add-in User’s Guide for 1-2-3. 

Viewing data using Hyperion Wired for OLAP Enterprise:

You can also use Hyperion Wired for OLAP Enterprise to view 
data. Hyperion Wired for OLAP Enterprise is designed for 
online analytic processing analysis, presentation, and 
reporting. For more information, refer to Hyperion Wired for 
OLAP Enterprise Guide.

Note: For a list of third party applications that support 
Hyperion Essbase, refer to the Hyperion web site at 
www.hyperion.com.

Step 6 Viewing Data

http://www.hyperion.com
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Hyperion Essbase automatically sets the default Hyperion 
Essbase kernel storage settings. However, you can customize 
the major Hyperion Essbase kernel settings in the Database 
Settings dialog box in Hyperion Essbase Application Manager 
as follows:

● Data compression: To specify data compression on disk 
and the compression scheme, select a value from the Data 
Compression list box of the Storage tab.

● Cache sizes: To specify the index, data file, and data 
cache sizes, enter the desired values in the Storage tab. To 
prevent a slow-down of the operating system, ensure that 
the sum of index and data cache sizes for all the active 
databases on the server is not more than 2/3 of the system’s 
RAM.

● Cache memory locking: To lock the memory that is used 
for the index, data file, and data caches into physical 
memory. Use the Storage tab for this setting.

● Disk volumes: To specify the storage location of Hyperion 
Essbase index files and data files, specify the appropriate 
disk volume names and configuration parameters in the 
Location box in the Storage tab.

● Isolation level: To specify either committed access or 
uncommitted access, set the isolation level for transactions 
in the Transaction tab. Depending on which type of access 
you specify, Hyperion Essbase uses additional parameters.

For more information on database settings and defaults, 
see the Hyperion Essbase Database Administrator’s Guide, 
Volume II.

Generating reports with Hyperion Essbase Report Writer:

● Decide whether you want to create a structured report or a 
free-form report.

● Plan the elements of the report, such as page layout, 
number of columns, identity of members, format of data 
values, and content of titles.

● For a structured report, create page, column, and row 
headings. These headings are not necessary for a free-form 
report.

● To create a report script, use a Report Editor or any other 
text editor.

● From Report Editor, select Report > Run to run the report.

● Save the report on either the Hyperion Essbase server or on 
a desktop machine.

Optimizing generated reports:

● Check the configurable variables that are used in 
conditional retrieval and data sorting commands. For more 
information, see the online Technical Reference in the 
DOCS directory.

● In the General tab under Database > Settings, set the 
retrieval buffer size between 10K and 256K.

● In the ESSBASE.CFG file on both the client and server 
files (located in the essbase\bin directory), set netdelay 
to 200.

● To improve report processing time, make the reports 
symmetric.

● To improve data extraction time, structure the report 
script in the same order as the data extracted by the report 
extractor; group dense dimensions in columns and sparse 
dimensions in rows.

For detailed information, see the Hyperion Essbase Database 
Administrator’s Guide, Volume II.

Step 7 Storing Data

Step 8 Generating Reports
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Use ESSCMD to execute server operations at the command 
line, in either batch or interactive mode.

Consider using script or batch files for commands that are 
frequently used or for completing tasks that require many 
commands. 

● Choose either the interactive mode or the batch processing 
mode to enter commands.

● Enter ESSCMD at the operating system command prompt. 
(Ensure that Hyperion Essbase is running before starting 
ESSCMD.)

● Log on to the Hyperion Essbase server with the LOGIN 
command.

● Enter any valid ESSCMD command and press Enter. For 
a complete listing of commands, type HELP.

● To exit the application, type EXIT.

Note: For more information on using ESSCMD, see the 
Hyperion Essbase Database Administrator’s Guide, Volume 
II, or the online Technical Reference in the DOCS directory.

● Create a security plan for your environment; base the plan 
on database security needs.

● Choose the appropriate security layer and define privileges 
and access at the server, the application, the database, and 
the data cell levels for users or groups.

● Connect to the appropriate server.

● Select Security > Users > Groups and make the necessary 
changes.

To assign database access for individual users:

● Select Security > Users > Group > Edit User > App Access.

● Select Access DBs, and click DB Access.

● Select the appropriate database and access privileges, and 
click OK.

To define global application access:

● Connect to the appropriate server, and select the name of 
the application.

● Select Application > Settings, and define the settings.

To define global database access:

● Connect to the appropriate server, and select the name of 
the application and database.

● Select Database > Settings, and define the settings on the 
General tab.

Note: Higher access settings take precedence, whether they 
are at the application, database, or user level. For example, 
user-assigned settings override all global settings, if the user-
assigned settings are higher.

For detailed information, see the Hyperion Essbase Database 
Administrator’s Guide, Volumes I and II.

Step 9 Using Command-Line Operations

Step 10  Maintaining Security
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● Ensure that block size is not excessively large.

● To achieve optimal database performance, set the correct 
size for the index, data file, data, and calculator caches.

● Validate the database to ensure data integrity.

● Consider using partitioning to distribute data across 
multiple cubes for better scalability and performance.

● Ensure that the disk space is adequate to allow the 
application to grow over time.

● Archive the data on the Hyperion Essbase server on a 
regular basis.

● Enable the logging facility for spreadsheet update to ensure 
that log files are updated after archiving.

● If sorting on retrievals, increase the size of the retrieval sort 
buffer.

For detailed information, see the Hyperion Essbase Database 
Administrator’s Guide, Volume I and Volume II.

Congratulations! You have made the transition to a Hyperion 
Essbase OLAP server!

The Next Step:

● For procedures to install Hyperion Essbase, see the 
Hyperion Essbase Installation Guide.

● For command and function syntax, see the online 
Technical Reference in the DOCS directory.

● For information on using Hyperion Essbase Spreadsheet 
Add-in, see the Hyperion Essbase Spreadsheet Add-in 
User’s Guide for Excel or the Hyperion Essbase 
Spreadsheet Add-in User’s Guide for 1-2-3.

Step 11 Tuning and Maintaining Databases

Step 12 What’s Next?
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