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Preface
he IBM Asset Transformation Workbench (ATW) is a suite of 
PC-based software products for analyzing, re-architecting, and 
transforming legacy applications. The products are deployed in 

an integrated environment with access to a common repository of pro-
gram objects. Repository models serve as the basis for a rich set of dia-
grams, reports, and other documentation.

The ATW suite consists of customizable modules that together address 
the needs of organizations at every stage of legacy application evolution 
— maintenance/enhancement, renovation, and modernization. 

Audience

This guide assumes that you are a corporate Information Technology 
(IT) professional with a working knowledge of the legacy platforms you 
are using the product to analyze. If you are transforming a legacy appli-
cation, you should also have a working knowledge of the target platform.

T
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Organization

This guide contains the following chapters:

• Chapter 1, “Overview,” provides an overview of the ATW project 
analysis tools.

• Chapter 2, “Analyzing Relationship Flows,” describes how to use 
the Diagrammer to perform high-level analysis of applications. 

• Chapter 3, “Analyzing Global Data Flows,” describes how to use the 
Global Data Flow tool to perform low-level analysis of program data 
flows. 

• Chapter 4, “Analyzing Batch Applications,”describes how to use 
the Batch Application Viewer to perform low-level analysis of batch 
processes.

• Chapter 5, “Analyzing PL/I Applications,” describes how to use the 
PL/I Call Diagrammer to perform low-level analysis of PL/I pro-
grams. 

• Chapter 6, “Analyzing Data Operations,” describes the workbench 
CRUD report and IMS port analysis feature.

• Chapter 7, “Estimating Complexity and Effort,” describes how to 
use the legacy estimation tools to estimate project complexity and 
effort. 

• Chapter 8, “Defining an Application Namespace,” describes how to 
use the Application Namespace tool to change identifiers in system 
source code without undermining the system’s consistency. 

• Chapter 9, “Identifying Classes of Data Items,” describes how to
use the Change Analyzer to identify the class of data items used 
to perform a business function in a legacy application. 

• The Glossary defines the names, acronyms, and special terminology 
used in this guide.
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Conventions

This guide uses the following typographic conventions:

• Bold type — Indicates a specific area within the graphical user in-
terface, such as a button on a screen, a window name, or a command 
or function.

• Italic type — Indicates a new term. Also indicates a document title. 
Occasionally, italic type is used for emphasis.

• Monospace type — Indicates computer programming code.

• Bold monospace type — Indicates input you type on the com-
puter keyboard.

• 1A/1B, 2A/2B — In task descriptions, indicates mutually exclusive 
steps: perform step A or step B, but not both.

Related Manuals

This document is part of a complete set of ATW manuals. Together they 
provide all the information you need to get the most out of the system. 

• Getting Started introduces ATW. This guide provides an overview 
of the workbench tools and discusses basic concepts. It describes 
how to install the product and how to manage licenses. It also de-
scribes how to use common product features. 

• Preparing Projects describes how to set up ATW projects. This 
guide describes how to load applications in the repository and how 
to use reports and other tools to ensure that the entire application is 
available for analysis.

• Analyzing Programs describes how to analyze applications at the 
program level. This guide describes how to use HyperView tools to 
view programs interactively and perform program analysis in stages. 
It also describes how to analyze procedure and data flows, search the 
repository, and extract business rules with HyperView.

• Profiling Projects describes how to create and browse Web-generat-
ed views of the repositories in your organization. 
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• Creating Components describes how to extract program components 
from a legacy application.

• Transforming Applications describes how to generate legacy appli-
cation components in modern languages.

• Parser Reference Manual describes legacy constructions supported 
by Application Analyzer in reference format.

• Architecture Reference Manual describes legacy constructions sup-
ported by Application Architect in reference format.

• Transformation Reference Manual describes legacy constructions 
supported by Transformation Assistant in reference format.

Online Help

In addition to the manuals provided with the system, you can learn about 
the product using the integrated online help. All GUI-based tools include 
a standard Windows Help menu.

You can display:

• The entire help system, with table of contents, index, and search 
tool, by selecting Help:Help Topics.

• Help about a particular ATW window by clicking the window and 
pressing the F1 key.

Many ATW tools have guides that you can use to get started quickly in 
the tool. The guides are help-like systems with hyperlinks that you can 
use to access functions otherwise available only in menus and other pro-
gram controls. 

To open the guide for a tool, choose Guide from the View menu. Use the 
table of contents in the Page drop-down to navigate quickly to a topic.
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1
Overview
hen you verify a legacy application, the parser generates a 
model of the application that defines the objects it uses and 
how they interact. The tools described in this guide let you 

analyze the model at the project level. You can view high- and low-level 
process and data flows, estimate project effort and complexity, define an 
application namespace, and identify classes of data items that may be af-
fected by a change in a field.

Analyzing Relationship Flows

ATW offers four related tools for analyzing relationship flows in legacy 
applications. The core Diagrammer tool lets you analyze high-level re-
lationship flows. The other three tools let you drill down deeper into data 
flows, batch processes, and PL/I programs. All the tools let you browse 
source code interactively.

W
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Analyzing Relationships with the Diagrammer

The Diagrammer lets you view the relationships between application 
objects interactively — programs, files, DDL, JCL, screen maps, and 
more. These relationships describe the ways in which application objects 
interact. 

In Figure 1-1, for example, the GSS2 program reads the data file CUST-
MAST. The CUSTMAST file, in turn, is assigned to the CXXCP.CUST-
MAST data store.

Figure 1-1 Relationships in Diagrammatic Form

The Diagrammer’s high-level analysis of relationships lets you quickly 
trace the flow of information in an application. Use the Diagrammer to 
view: 

• Program to program calls 

• Program, transaction, and screen flows

• Program to table or data store flows

• Job, program, and data store flows

Analyzing Data Flows with the Global Data Flow Tool

The Global Data Flow tool lets you perform low-level analysis of pro-
gram data flows. Use it to determine how changes to a variable may 
affect other variables and to trace assignments to and from a variable 
across programs. 

Analyzing Batch Applications with the Batch Application Viewer

The Batch Application Viewer lets you perform low-level analysis of 
batch processes. Use it to determine whether jobs are dependent on one 
another, the programs that use a data store, and the flow of data into or 
out of a data store.
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Analyzing PL/I Applications with the PL/I Call Diagrammer 

The PL/I Call Diagrammer lets you perform low-level analysis of PL/I 
programs. You can use it to examine call flows for external procedures 
as you would in the Diagrammer. But you can also use it to examine call 
flows for internal procedures that the Diagrammer is unable to model. 

Analyzing Data Operations

The workbench parser generates relationships that show the data opera-
tions a program performs — Insert, Read, Update, or Delete — and the 
data objects on which the program operates — files, segments, tables, 
and so forth. 

The workbench CRUD report lets you view these relationships in a con-
venient format. The IMS port analysis feature determines the database 
segments or screens an IMS program operates on by tracing PSB usage 
through an entire application call sequence.

Estimating Complexity and Effort

Suppose you are planning to implement a change request for a program 
and want to know how long it will take to complete the change. ATW 
legacy estimation tools let you compare programs based on weighted 
values for selected complexity metrics. Based on the comparison, you 
can develop a credible estimate of the time required to make the change. 

The complexity metrics used in the calculation are a combination of in-
dustry standard and ATW-generated statistics (Table 7-1 on page 7-8). If 
your own analysis shows that a given program is more or less complex 
than the weighted calculation would suggest, you can use a change mag-
nitude to override the calculated value. 

The program might have thousands of source lines, for example, increas-
ing its calculated complexity, while actually being very easy to modify. 
When you use a change magnitude, your “subjective” estimate of the ef-
fort involved — Small, Medium, Large, Extra-large — becomes an input 
to the effort calculation, along with the weighted values.
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Defining an Application Namespace

The Application Namespace tool creates a conveniently organized dic-
tionary that helps you navigate through your system’s terminology and 
modify it as necessary. You can also use the tool to provide pseudo-code 
versions of application names that are easier for business analysts to un-
derstand.

Namespace mapping lets you change identifiers in system source code 
without undermining the system’s consistency. If your legacy applica-
tion uses the identifiers CUSTMR and CSTMR to refer to a customer, 
you can use the tool to rename both identifiers to CUSTOMER, and 
propagate the change to all the source files that need it.

Identifying Classes of Data Items

Suppose your organization is considering adding support for a new 
currency and that you are going to have to expand the existing exchange 
rate data field from 9(5)V9(3) to 9(5)V9(6) to accommodate the currency. 
You will need to know the data fields that are affected in the database, 
intermediate fields that may contain or use the exchange rate field in 
calculations, and so forth. 

The Change Analyzer identifies the class of data items that may need to 
be modified to support the new currency — not only the exchange rate 
fields themselves, but any fields related to them by assignment. In this 
way it lets you answer the kinds of “What if?” questions posed in the 
recent past by the industry-wide changes for Y2K, Zip+4, and the Euro 
dollar: “What if I change the type of this variable, or the length of this 
field — what other fields will I also have to change?” 

Use change analysis results to prepare project plans and technical spec-
ifications. You can generate reports showing source entities that may re-
quire modification, lines of code affected, and the like. 
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What’s Next?

That’s all you need to know before you begin analyzing ATW projects. 
Now let’s look at how you use the Diagrammer to perform high-level 
analysis of legacy applications.
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Analyzing Relationship Flows 
he Diagrammer lets you view the relationships between appli-
cation objects interactively — programs, files, DDL, JCL, screen 
maps, and more. These relationships describe the ways in which 

program objects interact. In Figure 2-1, for example, the GSS2 program 
reads the file CUSTMAST. The CUSTMAST file, in turn, is assigned 
to the CXXCP.CUSTMAST data store.

Figure 2-1 Relationships in Diagrammatic Form

The Diagrammer’s high-level analysis of relationships lets you quickly 
trace the flow of information in an application. Use the Diagrammer to 
view: 

• Program to program calls 

• Program, transaction, and screen flows

T
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• Program to table or data store flows

• Job, program, and data store flows

Understanding Relationship Flow Diagrams

Relationship flow diagrams use boxes and lines to show the relationships 
between objects in an application. You can display the relationships for 
all the objects in a workspace, or only the objects in the selected project. 

Objects are color-coded, based on a color scheme of your choosing. Hy-
perlinks let you navigate easily through a diagram to objects of interest, 
and browse source code interactively. 

You can use the built-in editor to edit diagrams, cut-and-paste from a di-
agram, and so forth. You can export diagrams to a variety of standard for-
mats and generate printed reports based on your diagrams. 

Diagram Scopes

The scope of a diagram determines the objects and relationships it dis-
plays. Figure 2-2 shows the scope of the Call Map diagram.

Figure 2-2 Scope of Call Map Diagram

Tip: To view the definition of a scope, choose the scope in the 
Scope drop-down, then choose View Scope in the Scope 
menu.

The Diagrammer provides default scopes that you can use for most anal-
ysis tasks, but you can create your own scopes if you like. You might want 
to exclude data stores from a data flow, or include source files in a call 
map. For more information, see “Defining Scopes for Project Diagrams” 
on page 2-9.
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Diagram Views

The Diagrammer offers two views of relationship flows, a compact view 
and an expanded view. Figure 2-3 and Figure 2-4 show the same objects 
in both views. (Note that the diagram in Figure 2-4 has been modified to 
fit the page.)

Compact View

The compact view offers a cyclic representation of the information in a 
diagram. Objects are drawn once. Relationship lines cross. Compact 
views are often easier to understand than expanded views. 

Figure 2-3 Compact View

Expanded View

The expanded view offers a linear representation of the information in a 
diagram. Objects are drawn as many times as necessary. Relationship 
lines do not cross. Use this view if too many intersecting lines make a 
compact view hard to read. 

Figure 2-4 Expanded View
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Using the Diagrammer

You generate relationship flow diagrams for the current project. You can 
include all the objects in the workspace by deselecting Intraproject Re-
lationships in the View menu. 

Generating Project Diagrams

Follow the steps below to generate a relationship flow diagram.

To generate a relationship flow diagram:

1 In the Repository Browser, select the project for the diagram and 
choose Diagram in the Analyze menu. A blank Diagrammer win-
dow opens. Choose the scope of the diagram in the Scope drop-
down. Diagrammer draws the selected diagram (Figure 2-5).

Figure 2-5 Diagrammer Window

choose scope

view source

view list of 
relationships

choose view

slide to zoom
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2 In the View menu, deselect Intraproject Relationships if you want 
to include all related objects in the workspace in the diagram.

Working with Project Diagrams

The Diagrammer window consists of a Diagram pane, List pane, Quick 
View pane, and Activity Log. You can hide a pane by clicking the close 
box in the upper righthand corner. Select the appropriate choice in the 
View menu to show the pane again. 

Diagram Pane

The Diagram pane displays the diagram for the selected scope. Use the 
slider on the tool bar in the lower lefthand corner of the pane to zoom in 
or out on the diagram. Place your cursor over an object for a moment to 
display a tool tip that describes the object in more detail.

Choosing the View  Click the Compact View tab to choose the compact 
view of relationship flows. Click the Expanded View tab to choose the 
expanded view of relationship flows. For background on views, see “Di-
agram Views” on page 2-3.

Tip: Right-click an object in the expanded view and choose Root 
in the pop-up menu to navigate to the first instance of the ob-
ject in the diagram. Select the scope again to redraw the dia-
gram. 

Viewing Source  Select an object in the diagram to view its source in the 
Quick View pane. The object is displayed with a background shadow.

Navigating to an Object   Select the relationship for an object in the List 
pane to navigate to the object in the Diagram pane. 

What If Your Project Is Too Large?

The Diagrammer issues a warning and fails to draw the diagram for 
the selected scope if the diagram requires more than 2500 lines or 
32,000 boxes. (Note that the Diagrammer will still populate the List 
pane with the relationships in the selected scope.) Either reduce the 
size of the project or edit the scope to filter out unnecessary objects. 
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Copying Diagrams   In the File menu, choose Copy Type View to copy 
the diagram to the clipboard in EMF format. You can paste the diagram 
from the clipboard to a document in a third-party tool such as Word.

Printing Diagrams   In the File menu, choose Print Type View to print 
the diagram. The Print Preview window opens, where you can change 
the zoom factor for the diagram to control the number of pages in the 
print job. Click OK.

List Pane

The List pane displays the relationships in the selected scope, as they ap-
pear from left to right in the diagram. Select the relationship for an object 
in the List pane to navigate to the object in the Diagram pane.

Sorting Entries  Click a column heading in the List pane to sort the rela-
tionship entries by that column. 

Sizing Columns  Grab-and-drag the border of a column heading to in-
crease or decrease the width of the column. 

Tip: Even if the Diagrammer is unable to draw a diagram because 
the scope contains too many objects or relationships, it lists 
the relationships in the List pane. For more information, see 
“What If Your Project Is Too Large?” on page 2-5.

Quick View Pane

The Quick View pane lets you browse information about the object se-
lected in the Diagram pane. The information available depends on the 
type of object selected — you see only source code for a copybook, for 
example, but full HyperCode for a program.

Note: “HyperCode” is shorthand for the information displayed in 
the ATW HyperView tool. For HyperView usage information, 
see Analyzing Programs in the ATW document set.

Select an object in the Diagram pane to view it in the Quick View pane. 
Choose the information you want to view for the object from the Source 
drop-down. Use the search facilities to navigate to the source you want 
to view.
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Figure 2-6 Quick View Pane

Note: The Quick View pane shows a view-only copy of application 
source.

Editing the Color Scheme for Project Diagrams

Object types are color-coded in relationship flow diagrams so that you 
can distinguish one type from another — programs from transactions, 
transactions from screens, and so forth. You can use the default color 
scheme or create your own.

To edit the color scheme for diagrams:

1 In the View menu, choose Options. The Options window opens 
(Figure 2-7 on page 2-8).

2 In the Color Scheme pane, click the object type whose color you 
want to edit. The current background color of the type (if any) is dis-
played in the Color drop-down.

choose file 
you want to view

view-only source

choose 
HyperCode view
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Figure 2-7 Options Window

3 Click the arrow beside the Color drop-down and choose ForeColor 
from the pop-up menu if you want to edit the color of the caption for 
the object type, or BackColor if you want to edit the color of the 
background for the object type.

4 A standard Windows color control is displayed. Use the Palette tab 
to select the color of the caption or background from the Windows 
palette. Use the System tab to match the color of the caption or back-
ground with the color of standard Windows elements.

Note: You can restore the default option settings by clicking Dia-
grams Defaults, then choosing Restore Defaults in the drop-
down menu. Choose Save To in the drop-down menu to save 
the option settings to a file. Choose Load From in the menu 
to restore the option settings from a file.

5A Click Apply if you want to save your settings without dismissing the 
Options window. 

5B Click OK if you want to save your settings and dismiss the Options 
window. 

click to display
current color

click to display
color options
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Defining Scopes for Project Diagrams

The scope of a diagram determines the objects and relationships it dis-
plays. Figure 2-2 on page 2-2 shows the scope of the Call Map diagram. 
To view the definition of a scope, choose the scope in the Scope drop-
down, then choose View Scope in the Scope menu.

The Diagrammer provides default scopes that you can use for most anal-
ysis tasks, but you can create your own scopes if you like. You might want 
to exclude data stores from a Data Flow diagram, for example, or include 
Cobol source files in a Call Map diagram. 

You can modify an existing scope, create a new scope based on an exist-
ing scope, or create a new scope from scratch. In each case, you specify 
the relationships you want the diagram to display

Note: Scopes are created or modified in the current workspace only. 

Basic and Composite Relationships

Relationships are of two types, or classes:

• A basic relationship defines the direct interaction of two objects — 
a program and a program entry point, for example.

• A composite relationship defines the indirect interaction of two ob-
jects — if a job runs a program entry point that belongs to a program, 
for example, the relationship between the job and program is said to 
be composite. A composite relationship is indicated by a symbol.

Tip: For convenience, you can create custom composite relation-
ships that define an entire chain of relationships for an object.

Editing Scopes in the Quick Diagrammer

If your project is very large, you will probably want to edit scopes 
in the Quick Diagrammer, which does not automatically redraw a di-
agram each time you select a new scope. For more information, see 
“Using the Quick Diagrammer” on page 2-23. 
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To define the scope of a diagram:

1A To create a new scope from scratch, choose New Scope in the Scope 
menu. The New Scope dialog opens. Enter the name of the new 
scope in the text field and click OK. The Edit Scope window opens 
(Figure 2-8).

1B To modify an existing scope, or create a new scope based on an 
existing scope, choose the existing scope in the Scope drop-down, 
then choose Edit Scope in the Scope menu. The Edit Scope window 
opens (Figure 2-8).

Figure 2-8 Edit Scope Window

2 In the Edit Scope window, select each relationship you want to in-
clude in the scope. The Class column displays the class of the rela-
tionship, basic or composite.

3 To view a composite relationship, select it and choose View rela-
tionship in the Relationship menu. The View Relationship window 
opens (Figure 2-9 on page 2-11).
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Figure 2-9 View Relationship Window

4 To create a composite relationship, choose New relationship in 
the Relationship menu. The New Relationship Wizard opens 
(Figure 2-10).

Figure 2-10 New Relationship Wizard (Screen One)

5 In the Enter relationship name field, enter the name of the compos-
ite relationship. In the Select first entity pane, select the object you 
want to appear on the left side of the relationship chain. Click Next. 
The screen shown in Figure 2-11 on page 2-12 appears.

6 In the Select relationship pane, select the relationship you want to 
appear next in the relationship chain. Click Next. A screen similar to 
the one shown in Figure 2-11 on page 2-12 appears. 
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7 Repeat step 6 on page 2-11 for each relationship you want to include 
in the chain. When you are done, click Finish. The New Relation-
ship Wizard closes and the new composite relationship is added to 
the Edit Scope window.

Figure 2-11 New Relationship Wizard (Screen Two)

8 To delete a composite relationship, select it and choose Delete rela-
tionship in the Relationship menu. You are prompted to confirm the 
deletion. Click Yes. 

Note: You cannot create or delete a basic relationship.

8A Click Save As in the Edit Scope window to create a new scope based 
on an existing scope. The Save Scope window opens. Enter the name 
of the new scope in the text field and click OK. The new scope is 
displayed in the Scope drop-down in the Diagrammer window.

8B Click OK in the Edit Scope window to save a modified scope or a 
new scope created from scratch. The new scope is displayed in the 
Scope drop-down in the Diagrammer window.
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Searching for Objects in Project Diagrams

Use the Diagrammer’s Quick Search facility to navigate quickly to 
objects in a relationship flow diagram. To invoke Quick Search, click 
the  button on the tool bar in the lower lefthand corner of the Diagram 
pane. The Quick Search facility opens at the top of the Diagram pane. 
Enter the text for the search in the Quick Search field. 

Tip: The  button is a toggle. Click the button again to hide the 
Quick Search facility.

Exporting Project Diagrams and Diagram-Based Reports

You can export diagrams to a variety of standard formats and generate 
printed reports based on your diagrams. Choose Save Type View As in 
the File menu to export a diagram to BED, bitmap, JPEG, Visio, Visio 
XML, DOT, or EMF. 

Note: Visio 2002 must be installed to save a diagram to Visio. Visio 
2002 is not required to save to Visio XML. 

Choose Save Diagram Report in the File menu to export a printed re-
port for a diagram to HTML, Excel, RTF, Word, or formatted text.

Note: For more information on exporting diagrams and reports, see 
Getting Started in the ATW document set.

You can also export a diagram to the ATW WebGen tool by clicking 
Create WebGen Page in the File menu. All diagram types are exported 
to the page. The page is stored in the file \Work-
space\Projects\Project\Webgen\Diagrammer\Main.htm. Click the hy-
perlink for a diagram to view it in the browser. 

Deleting a Scope

To delete a scope, select it in the Scope drop-down and choose Delete 
Scope in the Scope menu. You are prompted to confirm the deletion. 
Click Yes.
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Using the Diagram Editor

Use the built-in Diagram Editor to edit diagrams, change the appearance 
of diagrams, cut-and-paste from a diagram, and other tasks. 

Opening a Diagram in the Diagram Editor

You can invoke the Diagram Editor from any tool that displays a dia-
gram, or by double-clicking BEDit.exe in the ATW Bin directory. If 
you open the Diagram Editor from within another tool, the Editor creates 
a copy of the diagram on view in the tool.

To open a diagram in the Diagram Editor:

1A If the Diagram Editor is not open, click the  button on the tool bar 
in the lower lefthand corner of the Diagram pane. The diagram on 
view in the Diagram pane opens in the Diagram Editor (Figure 2-5).

Figure 2-12 Diagram Editor Window

quick search

edit diagram
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1B If the Diagram Editor is already open, choose Open Diagram in the 
File menu. The Open diagram dialog appears. Select the diagram 
you want to open and click Open.

Tip: Choose New Diagram in the File menu to create a new blank 
diagram. You can paste portions of an existing diagram into 
the blank diagram, as described in “Copying Objects” on 
page 2-18.

Searching for Objects in the Diagram Editor

The Diagram Editor offers facilities for navigating to general locations 
in a diagram, or to specific objects. You can use the search and replace 
feature to modify captions or tool tips globally.

Using the Locate Facility

Use the Locate facility to navigate to general locations in a diagram. To 
invoke the Locate facility, click Locate in the View menu. The Locate 
window opens (Figure 2-13).

The Locate window displays the entire diagram on view in the Diagram 
Editor main window. A frame surrounds the portion of the diagram vis-
ible in the main window. 

Drag the frame to the area of the diagram you want to view. The Diagram 
Editor displays the selected area in the main window.

Figure 2-13 Locate Window

drag frame to
area you want 
to view
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Using the Quick Search Facility

Use the Quick Search facility to navigate to objects in a diagram. To in-
voke Quick Search, choose Search pane in the View menu. The Quick 
Search facility opens at the top of the window. 

Enter the text for the search in the Quick Search field. You can use wild-
card patterns allowed in LIKE statements by Visual Basic for Applica-
tions (VBA).

Using the Search and Replace Facility

Use the Search and Replace facility to modify captions or tool tips glo-
bally. The Diagram Editor modifies the diagram only, not the repository. 

To search for and replace text in a diagram:

1 In the Edit menu, choose Replace. The Replace window opens 
(Figure 2-14). 

Figure 2-14 Replace Window

2 Enter the text you want to replace in the Find field. Enter the text 
you want to substitute in the Replace field. 

3 Select Match case if you want to match the case of the entered text.

4 You can apply the change to any combination of object captions, re-
lationship captions, or tool tips by selecting the appropriate choices 
in the Apply to pane. If you apply the change to object captions, se-
lect the appropriate choice in the Scope pane to apply the change to 
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all the objects that contain the text or only the selected objects that 
contain the text.

5 Click Replace to run the operation and dismiss the Replace window.

Selecting Objects in the Diagram Editor

Select an object or relationship in the Diagram Editor by clicking it. De-
select an object by clicking on white space or selecting another object. 
To select all the objects in the diagram, choose Select All in the Edit 
menu. 

To select a range of objects, click in the diagram, hold down the right 
mouse button, drag the selection box over the objects you want to select, 
and release the mouse button. To select objects that are not in a range, 
hold down the Control key, then click each object you want to select. 

Editing the Layout of a Diagram in the Diagram Editor

You can change the layout of a diagram, and copy, add or delete objects 
from the diagram. The Diagram Editor modifies the diagram only, not 
the repository. 

Unlocking the Diagram Layout

When you open a diagram in the Diagram Editor, the diagram layout is 
locked — you cannot move or resize the objects in the diagram. To un-
lock the diagram layout, deselect Lock Layout in the Edit menu.

Autoplacing Objects

To rearrange the objects in a diagram automatically, choose Auto Place 
in the Auto menu. You are prompted to confirm that you want to au-
toplace the objects. Click Yes. 

Splitting Objects

To “split” an object that has multiple relationships into an equal number 
of objects with a single relationship, select the object and choose Split 
in the Edit menu. Rearrange the objects manually or use the autoplace 
feature to rearrange the objects automatically.
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Moving and Resizing Objects

To move an object in a diagram, drag-and-drop the object to the new lo-
cation, or enter the grid coordinates of the location in the fields beside 
the  symbol on the Box tool bar. The Diagram Editor redraws the re-
lationships for the object.

To resize an object in a diagram, grab the border of the object with the 
mouse and drag it to a new location, or enter the grid coordinates for the 
height and width of the resized box in the fields beside the  symbol 
on the Box tool bar.

Copying Objects

To create a copy of an object and all its relationships, select the object 
and choose Clone in the Edit menu. 

To copy an object but not its relationships to the clipboard, select the 
object and choose Copy in the Edit menu. To paste the object from the 
clipboard, choose Paste in the Edit menu.

Tip: Choose Clipboard in the View menu to view the contents of 
the clipboard.

Adding Objects

To add an empty object to a diagram, click New Box in the Edit menu. 
To create a relationship between the new object and another object, hold 
down the Alt key, select either object, and drag-and-drop the relationship 
to the other object.

Deleting Objects

To delete an object from a diagram, select the object and click Delete in 
the Edit menu. To delete an object from the diagram and copy it to the 
clipboard, select the object and choose Cut from the Edit menu. The Di-
agram Editor also deletes the relationships for the object.

Autoattaching Relationships

To redraw a relationship line in a diagram automatically, select the rela-
tionship line and choose Auto Attach in the Auto menu.
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Redrawing Relationships

To redraw a relationship in a diagram, grab the relationship line with the 
mouse and drag it to a new location, or enter the grid coordinates for the 
length and offset of each end of the redrawn line in the fields beside the 

 and  symbols on the Edge tool bar.

Deleting Relationships

To delete a relationship from a diagram, select the relationship and click 
Delete Edge in the Edit menu. 

Editing Objects in the Diagram Editor

You can change the caption, color scheme, and border characteristics of 
an object. The Diagram Editor modifies the diagram only, not the repos-
itory. 

Editing the Captions of an Object and Tool Tip

To edit the caption of an object, select the object and enter the new cap-
tion in the text field on the Box caption tool bar. To edit the caption of 
the tool tip for an object, select the object and enter the new caption in 
the text field on the Box tooltip tool bar. 

Editing the Color Scheme for an Object

You can change the color of the background, border, and caption of an 
object:

• To change the background color of an object, select the object and 
click the arrow beside the  symbol on the Box tool bar. 

• To change the border color of an object, select the object and click 
the arrow beside the  symbol on the Box tool bar. 

• To change the color of the caption for an object, select the object and 
click the arrow beside the  symbol on the Box tool bar.

A standard Windows color control is displayed. Use the Palette tab to 
select the color of the background, border, or caption from the Windows 
palette. Use the System tab to match the color of the background, border, 
or caption with the color of standard Windows elements.
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Editing the Border of an Object

You can change the thickness of the border for an object, specify that the 
border have rounded or square corners, and add a background shadow to 
the border:

• To change the thickness of the border for an object, select the object 
and click the arrow beside the  drop-down on the Box tool bar. In 
the drop-down, choose the thickness you want, where 1 is the thin-
nest border and 4 is the thickest. 

• To specify that the border of an object has rounded corners, select 
the object and click the  button on the Box tool bar. The button is 
a toggle. Click the button again to specify that the border has square 
corners.

• To add a background shadow to the border for an object, select the 
object and click the  button on the Box tool bar. The button is a 
toggle. Click the button again to specify that the border has no shad-
ow.

Editing Relationships in the Diagram Editor

You can add a caption to, or delete a caption from, either end of a rela-
tionship, edit the captions, and edit the cardinality of the relationship. 
The Diagram Editor modifies the diagram only, not the repository. 

Adding, Deleting, or Editing a Caption for a Relationship

There are two text fields for relationship captions on the Edge tool bar. 
The field on the left contains the caption for the left end of the relation-
ship, the field on the right contains the caption for the right end of the 
relationship.

To add a caption to a relationship, select the relationship and enter the 
new caption in the appropriate text field. To delete a caption from a re-
lationship, select the relationship and clear the caption in the appropriate 
text field. To edit the caption for a relationship, select the relationship 
and enter the new caption in the appropriate text field. 
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Editing the Cardinality of a Relationship

There are two drop-downs for relationship cardinalities on the Edge tool 
bar. The drop-down on the left contains the cardinality for the left end of 
the relationship, the drop-down on the right contains the cardinality for 
the right end of the relationship.

To edit the cardinality of a relationship, select the relationship and click 
the appropriate drop-down on the Edge tool bar. In the drop-down, 
choose the cardinality for the relationship.

Editing General Properties of a Diagram in the Diagram Editor

Use the Diagram Properties window to specify general properties of 
a diagram in the Diagram Editor — the font for captions, whether rela-
tionships are displayed as orthogonal (right-angled) lines, and the back-
ground color of the Diagram Editor window.

To edit the general properties of a diagram:

1 In the File menu, choose Properties. The Diagram Properties win-
dow opens (Figure 2-15).

Figure 2-15 Diagram Properties Window
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2 Click the button next to the Font drop-down. A standard Windows 
font control is displayed, where you can choose the font type, style, 
and size for diagram captions. 

3 Select Orthogonal Edges if you want the Diagram Editor to display 
relationships as orthogonal (right-angled) lines.

4 Click the arrow beside the Background color drop-down to specify 
the background color for the Diagram Editor window. A standard 
Windows color control is displayed. Use the Palette tab to select the 
color of the text or background from the Windows palette. Use the 
System tab to match the color of the text or background with the col-
or of standard Windows elements.

5 Click OK to apply your changes and dismiss the Diagram Properties 
window. 

Saving Diagrams in the Diagram Editor

Choose Save in the File menu to save a diagram in the Diagram Editor. 
The Save Diagram dialog opens. In the Save in drop-down, choose the 
folder to save the new diagram in. In the File name field, enter the name 
of the new diagram. Choose a name that describes the diagram as closely 
as possible. Click Save.

Copying Diagrams with a Different Name (Saving As) in the Diagram Editor

Choose Save as in the File menu to copy a diagram with a different name 
in the Diagram Editor. The Save Diagram dialog opens. In the Save in 
drop-down, choose the folder to save the new diagram in. In the File 
name field, enter the name of the new diagram. Choose a name that de-
scribes the diagram as closely as possible. Click Save.

Zooming in the Diagram Editor

Use the slider on the tool bar in the lower lefthand corner of the Dia-
gram Editor window to zoom in or out on the diagram. To display the 
slider, choose Zoom in the View menu.
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Printing Diagrams in the Diagram Editor

Choose Print in the File menu to print a diagram in the Diagram Editor. 
The Print Preview window opens, where you can change the zoom factor 
for the diagram to control the number of pages in the print job. Click 
OK.

Exporting Diagrams in the Diagram Editor

You can export diagrams to a variety of standard formats in the Diagram 
Editor. Choose Export in the File menu to export a diagram to BED, bit-
map, JPEG, Visio, Visio XML, DOT, or EMF. For more information on 
exporting diagrams, see Getting Started in the ATW document set.

Note: Visio 2002 must be installed to save a diagram to Visio. Visio 
2002 is not required to save to Visio XML. 

Using the Quick Diagrammer

The Quick Diagrammer tool lets you view relationships for selected ob-
jects only, rather than an entire project. For that reason, it’s an ideal tool 
for initial program analysis — fast and focused. 

For the most part, tool usage is similar to that for the main Diagrammer 
and Diagram Editor, but there are some handy additional features that 
you may want to explore.

Generating Object Diagrams

The Quick Diagrammer opens in the righthand section of the main ATW 
window. You can open as many Quick Diagrammer windows as you 
need.

To open a diagram in the Quick Diagrammer:

1 In the ATW Analyze menu, choose Quick Diagram. The Quick Di-
agrammer opens in the righthand section of the main ATW window. 

2 Choose the scope of the diagram in the Scope drop-down. 
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3 Drag-and-drop objects in the diagram’s scope from the Repository 
Browser to the Quick Diagrammer window. Quick Diagrammer 
draws the selected diagrams (Figure 2-16).

Tip: Make sure to select objects in the diagram’s scope — most 
scopes include extracted objects rather than source files. 

Figure 2-16 ATW Window with Quick Diagrammer 

Changing the Scope of an Object Diagram

Unlike the main Diagrammer, Quick Diagrammer does not automatical-
ly redraw a diagram after you select a new scope. You must choose 
Rebuild in the Diagram menu to redraw the diagram. This is a consider-
able advantage, of course, if your diagram is very large — you don’t 
have to wait for it to redraw each time you select a scope to edit. 

choose scope

rebuild diagram

drag-and-drop 
objects
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Defining Scopes for Object Diagrams

You can create, edit, view, or delete a scope in the Quick Diagrammer, 
just as you can in the main Diagrammer. Any modifications in either tool 
are reflected in the other.

To define the scope of a diagram:

1A To create a new scope from scratch, choose Scopes:New in the 
Diagram menu. The New Scope dialog opens. Enter the name of the 
new scope in the text field and click OK. The Edit Scope window 
opens (Figure 2-8 on page 2-10).

1B To modify an existing scope, choose the scope you want to modify 
in the Scope drop-down, then choose Scopes:Edit in the Diagram 
menu. The Edit Scope window opens (Figure 2-8 on page 2-10).

Tip: You do not have to draw a diagram in the Quick Diagrammer 
to modify a scope.

2 Follow the instructions in steps 2-8B on pages 2-10-2-12 to define 
the scope.

To view the definition of a scope:

1 To view the definition of a scope, choose the scope in the Scope 
drop-down, then choose Scopes:View in the Diagram menu.

To delete a scope:

1 To delete a scope, select it in the Scope drop-down and choose 
Scopes:Delete in the Diagram menu. You are prompted to confirm 
the deletion. Click Yes.

Mirroring the Scope of an Object Diagram

By default, Quick Diagrammer shows the flow of relationships from a di-
agrammed object rather than to the object. Choose Mirror Scope in the 
Diagram menu to show the flow of relationships to the object. Choose 
Mirror Scope again to return to the original view.
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Exporting Multiple Object Diagrams

Use Quick Diagrammer to export one or more diagrams to the supported 
formats in a single step. 

To export object diagrams:

1 In the Scope drop-down, choose the scope of the diagrams you want 
to export.

Tip: Although the Quick Diagrammer window must be open to ex-
port diagrams, you do not actually have to draw a diagram to 
export it. It’s enough to choose the diagram scope. Of course, 
you can draw the diagrams if you like.

2 In the Repository Browser, select the objects whose diagrams you 
want to export, then click in the Quick Diagrammer window and 
choose Save Multiple in the Diagram menu. A standard Save As 
window opens, where you can export the diagrams to BED, bitmap, 
JPEG, Visio, Visio XML, DOT, or EMF.

Note: You cannot specify the names of the exported diagrams. Dia-
grams are named after the diagrammed object.

Visio 2002 must be installed to save a diagram to Visio. Visio 
2002 is not required to save to Visio XML. 

Moving or Copying Source Files for Diagrammed Objects into Projects

Use Quick Diagrammer to move or copy the source files for the objects 
in a diagram to different projects. 

To move or copy source files for diagrammed objects into projects:

1 In the Diagram menu, choose Include into Project. The Select 
Project window opens (Figure 2-17 on page 2-27).

2 In the Select Project window, select the project you want to move 
or copy source files into. Click New to create a new project.

3 Select the Include All Related Objects check box if you want to 
move or copy the objects in the workspace related to the diagram 
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objects — the Cobol copybooks included in a Cobol program file, 
for example.

4 Choose one of the following:

• Copy to copy the source files to the specified project.
• Move From Current Project to move the source files to the 

specified project.
• Move From All Projects to move the source files from all proj-

ects to the selected project.

5 Click OK to move or copy the selection. 

Figure 2-17 Select Project Window

What’s Next?

Now that you have performed high-level analysis of relationship flows 
in the Diagrammer and Quick Diagrammer, you are ready to drill down 
deeper into your application. The next chapter shows you how to analyze 
program data flows.
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3
Analyzing Global Data Flows 
he Global Data Flow tool lets you analyze incoming and outgo-
ing data flows in a program. You can view the memory alloca-
tion and offset for a variable to determine how changes to the 

variable may affect other variables, and trace assignments to and from 
the variable across programs. 

Note: Projects must have been verified with the Enable Data Ele-
ment Flow option set in the Verification tab of the Project 
Options window. 

How the Global Data Flow Tool Is Implemented

The Global Data Flow tool is implemented as both a standalone and 
HyperView-based tool. This chapter describes the HyperView ver-
sion. Usage is identical for the standalone tool. For Context and Clip-
per pane usage, and for HyperView usage in general, see Analyzing 
Programs in the ATW document set.

T
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Understanding Global Data Flows

Suppose your task is to learn how data flows to and from the variable 
TCB-USER-ID in the GSS5 program in the GSS project. The Global 
Data Flow tool offers four views of a project that together let you 
perform low-level analysis of application data flows. Let’s look at 
how you use these views to analyze the TCB-USER-ID variable. 

Searching for the Variable

When you open the Global Data Flow tool in HyperView, the Source 
pane displays the source code for the selected program. In the text field 
next to the  button on the tool bar, enter TCB-USER-ID to navigate 
to the variable in the source code (Figure 3-1). We can see that a MOVE 
statement assigns the value of the COMM-USER-ID variable to TCB-
USER-ID, and that the Data View pane highlights the variable in red.

Figure 3-1 Global Data Flow Tool — Searching for a Variable

MOVE statement

enter search text 
for variable
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Viewing Memory Usage for the Variable

Although we have located a reference to TCB-USER-ID in the GSS5 
source code, we still don’t know where the variable is declared. Click 
TCB-USER-ID in the Data View pane to display the copybook source 
for the declaration (Figure 3-2). 

Figure 3-2 Global Data Flow Tool — Viewing Copybook Source

We can see from the source that TCB-USER-ID is a structure that 
is redefined by the structures TCB-USER-ID-R and TCB-USER-ID-
NEW. Let’s take a closer look at these structures in the Data View pane 
(Figure 3-3).

Figure 3-3 Global Data Flow Tool — Viewing Memory Usage

redefines
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The Data View pane provides a visual representation of memory usage 
by the redefining structures. We can see which fields in TCB-USER-ID-
NEW (in the fifth column) share memory locations with fields in TCB-
USER-ID-R (in the fourth column). 

Knowing this, we can be alert to the possibility that changing one of 
these variables might affect another variable at the same location. If we 
double-click TCB-USER-ID in the Data View pane, we can pinpoint the 
memory locations in the Origin pane, which shows the offset and size of 
each variable in both structures (Figure 3-4). 

Figure 3-4 Global Data Flow Tool — Viewing Memory Locations

Viewing the Data Flow for the Variable

Double-click TCB-USER-ID in the Data View pane to display a diagram 
that shows how data flows to and from the variable in the GSS5 program 
(Figure 3-5 on page 3-5). The diagram traces the incoming and outgoing 
data flows in the program up to a dataport — an I/O statement or a call 
to or from another program. 

At the dataport for the call from GSS3, for example, we can trace the 
COMM-USER-ID field to an 8-byte variable at memory offset 593 in the 
WS-05-COMMON-AREA structure. When we select the dataport and 
choose Reconstruct in the Diagram menu, the Global Data Flow tool 
displays the data flow diagram for COMM-USER-ID in the GSS3 pro-
gram.
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Figure 3-5 Global Data Flow Tool — Viewing Program Data Flow

Using the Global Data Flow Tool

You can start the Global Data Flow tool as a standalone or HyperView-
based tool. Start the standalone tool by selecting a project in the Repos-
itory Browser and choosing Data Flow in the Analyze menu. Start the 
HyperView-based tool as described below. 

Generating Global Data Flow Information 
Follow the steps below to start the Global Data Flow tool in HyperView.

To generate global data flow information in HyperView:

1 In the Repository Browser, select the program you want to analyze 
and choose Interactive Analysis in the Analyze menu. The Hyper-
View window opens. In the View menu, choose Data Flow. The 
Global Data Flow tool opens (Figure 3-6 on page 3-6).

2 In the Source pane, use the Quick Search field next to the  button 
on the tool bar to navigate to the variable you want to analyze. The 
Global Data Flow tool highlights the variable name in the Source 
pane and displays the name in red in the Data View pane. Click the 
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variable name in the Data View pane to display the source code for 
the variable declaration in the Source pane.

3 The Data View pane shows variable structures, substructures, and 
fields in hierarchical order from left to right. Double-click a variable 
name to generate a data flow diagram for the variable in the Data 
Flow pane, and a list of offsets and memory allocations for the vari-
able and any related variables in the Origin pane. 

4 Select a dataport in the Data Flow pane and choose Reconstruct in 
the Data Flow menu to display the data flow diagram for the vari-
able identified at the dataport. For more information on dataports, 
see “Viewing the Data Flow for the Variable” on page 3-4.

Note: For Context and Clipper pane usage, see Analyzing Programs 
in the ATW document set.

Figure 3-6 Global Data Flow Tool Window

Source Pane

Data Flow Pane

Origin Pane

Context Pane

Data View Pane
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Working with Global Data Flow Information

The window for the Global Data Flow tool consists of a Source pane, 
Data View pane, Data Flow pane (which includes the Origin pane), Con-
text pane, Clipper pane, and Activity Log. You can hide a pane by click-
ing the close box in the upper righthand corner. Select the appropriate 
choice in the View menu to show the pane again. 

Note: For Context and Clipper pane usage, see Analyzing Programs 
in the ATW document set.

Source Pane

The Source pane lets you browse the source code for the program select-
ed in the Global Diagram pane or the variable selected in the Data View 
or Data Flow panes. For usage information, see Analyzing Programs in 
the ATW document set.

Data View Pane

For the program selected in the Source pane, the Data View pane shows 
variable structures, substructures, and fields in hierarchical order from 
left to right. The selected variable is displayed in red.

Double-click a variable name to generate a data flow diagram for the 
variable in the Data Flow pane, and a list of offsets and memory alloca-
tions for the variable and any related variables in the Origin pane. 

Origin Pane

For the variable selected in the Data View or Data Flow panes, the Origin 
pane displays a list of offsets and memory allocations for the variable 
and any related variables. For the relationship selected in the Data Flow 
pane, it lists all the statements that determine the data flow between the 
related variables. For the dataport selected in the Data Flow pane, it dis-
plays related variables.
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Data Flow Pane

The Data Flow pane displays a data flow diagram for the variable select-
ed in the Data View pane. Usage is similar to that for the Diagrammer 
tool described in Chapter 2.

The selected variable is displayed in red, constants in gray, and dataports 
in blue. Place your cursor over a variable for a moment to display a tool 
tip that identifies the memory offset and allocation for the variable. 

Select a dataport in the Data Flow pane and choose Reconstruct in the 
Data Flow menu to display the data flow diagram for the variable iden-
tified at the dataport. For more information on dataports, see “Viewing 
the Data Flow for the Variable” on page 3-4.

Tip: If the Data View pane is closed, you can generate the data 
flow diagram by selecting the variable name in the Source 
pane and choosing Reconstruct in the Data Flow menu. 

Select a variable in the Data Flow pane to view its memory usage in the 
Data View and Origin panes and its source code in the Source pane. Se-
lect a relationship line in the Diagram pane to display all the statements 
that determine the data flow between variables in the Origin pane.

Note: For descriptions of the relationships between data items, see 
Table 6-1 in Analyzing Programs in the ATW document set.

In the Diagram menu, choose any combination of

• Show Causes to show data flows into the selected variable.

• Show Consequences to show data flows from the selected variable.

• Show Self-Dependencies to show recursive data flows for the se-
lected variable.
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Setting Global Data Flow Options 
Use the Global Data Flow User Preferences window to edit the display 
in the Data View pane. Use the Global Data Flow Project Options win-
dow to edit the display in the Data Flow pane. Global Data Flow User 
Preferences apply across workspaces. Global Data Flow Project Options 
apply only in the selected project.

Setting Global Data Flow User Preferences 

Global Data Flow User Preferences determine the order of display of 
variables with the same offset and the colors used in the Data View pane.

To set Global Data Flow User Preferences:

1 In the View menu, choose User Preferences. The User Preferences 
window opens. Click the HyperView tab. In the Preferences pane, 
click Data View. The Global Data Flow User Preferences window 
opens (Figure 3-8).

Figure 3-7 Global Data Flow User Preferences Window
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2 In the Same offset order group box, specify the order you want vari-
ables with the same offset to be displayed in the Data View pane. 
Choose:

• Data item size if you want variables with the same offset to be 
displayed in size order, largest to smallest.

• Appearance in the source code if you want variables with the 
same offset to be displayed in the order they appear in the source 
code.

3 The current default background color of the box representing free 
space in memory is displayed in the Free Space Color drop-down. 
The current background color of the box representing used space in 
memory is displayed in the Used Space Color drop-down. The cur-
rent background color of the box representing filler is displayed in 
the FILLER Color drop-down. 

Click the adjacent  buttons to edit the color of the paragraphs. A 
standard Windows color control is displayed. Use the Palette tab to 
select the color from the Windows palette. Use the System tab to 
match the color with the color of standard Windows elements.

Tip: You can restore the default option settings by clicking 
Data View Defaults, then choosing Restore Defaults in the 
drop-down menu. Choose Save To in the drop-down menu to 
save the option settings to a file. Choose Load From in the 
menu to restore the option settings from a file.

4A Click Apply if you want to save your settings without dismissing the 
User Preferences window. 

4B Click OK if you want to save your settings and dismiss the User 
Preferences window. 

Setting Global Data Flow Project Options

Global Data Flow Project Options determine whether data flow dia-
grams include literals, variable values set at initialization, and Unisys 
Cobol common storage variables; whether they show incoming, outgo-
ing, and recursive data flows; and the number of nodes they display.
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To set Global Data Flow Project Options:

1 In the View menu, choose Project Options. The Project Options 
window opens. Click the Global Data Flow tab. The Global Data 
Flow Options window opens (Figure 3-8).

Figure 3-8 Global Data Flow Options Window

2 In the Relationships pane, choose any combination of:

• Literal Flow to include literals in the data flow diagram for the 
selected variable.

• Initial Values to include variable values set at initialization in the 
data flow diagram for the selected variable.
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• Common Area Transition to include Unisys Cobol common 
storage variables in the data flow diagram for the selected vari-
able. Common storage variables are not explicitly declared in 
CALL statements.

Note: To include Unisys Cobol common storage variables, you must 
have verified the project with the Perform Unisys Common-
Storage Analysis option set in the Verification tab of the 
Project Options window. For more information, see Prepar-
ing Projects in the ATW document set.

3 In the Directions pane, choose any combination of:

• Causes to generate data flows into the selected variable.
• Consequences to generate data flows from the selected variable.
• Self-Dependencies to show recursive data flows for the selected 

variable.

4 In the Node Limit combo box, enter the maximum number of dia-
gram nodes you want to display. You might restrict the number of 
nodes to improve performance or make the diagram easier to read. 
You can also use the slider on the Node Limit tool bar to adjust the 
number of displayed nodes. 

Note: All children of a parent node are displayed even if some of 
them exceed the specified maximum.

5A Click Apply if you want to save your settings without dismissing the 
Options window. 

5B Click OK if you want to save your settings and dismiss the Options 
window. 

Tip: You can restore the default option settings by clicking 
Global Data Flow Defaults, then choosing Restore Defaults 
in the drop-down menu. Choose Save To in the drop-down 
menu to save the option settings to a file. Choose Load From 
in the menu to restore the option settings from a file.
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Copying Global Data Flow Diagrams to the Clipboard 
Choose Copy:Diagram in the Data Flow menu to copy a global data 
flow diagram to the clipboard in EMF format. You can paste the diagram 
from the clipboard to a document in a third-party tool such as Word.

Printing Global Data Flow Diagrams

Choose Print:Diagram in the Data Flow menu to print a global data 
flow diagram. The Print Preview window opens, where you can change 
the zoom factor for the diagram to control the number of pages in the 
print job. Click OK.

Exporting Global Data Flow Diagrams 

You can export global data flow diagrams to a variety of standard for-
mats. Choose Save Diagram in the Data Flow menu to export a diagram 
to BED, bitmap, JPEG, Visio, Visio XML, DOT, or EMF. For more in-
formation on exporting diagrams, see Getting Started in the ATW docu-
ment set.

Note: Visio 2002 must be installed to save a diagram to Visio. Visio 
2002 is not required to save to Visio XML. 

What’s Next?

That’s all you need to know to analyze program data flows in the Global 
Data Flow tool. Now let’s look at how you perform low-level analysis of 
batch programs in the Batch Application Viewer. That’s the subject of 
the next chapter.
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Analyzing Batch Applications
he Batch Application Viewer lets you perform low-level analysis 
of batch processes. Use the Batch Application Viewer’s rich set 
of tables and diagrams to determine whether batch jobs are de-

pendent on one another, the programs that use a data store, and the flow 
of data into or out of a data store. 

Note: Batch Application Viewer analyzes JCL and ECL jobs. Usage 
is identical except for language-specific differences in termi-
nology.

Using the Batch Application Viewer

You generate batch application information for the current project. The 
information is presented in linked table and diagram views. The tables 
cross-reference jobs, steps, procedures and programs, and data stores. 
The diagrams show the relationships between jobs, procedures and pro-
grams, and data stores. 

T
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Generating Batch Application Information 
Follow the steps below to generate batch application information.

To generate batch application information:

1 In the Repository Browser, select the project you want to analyze 
and choose Batch Application in the Analyze menu. The Batch Ap-
plication Viewer window opens (Figure 4-1).

Figure 4-1 Batch Application Viewer Window — Job View

2 In the Job pane, select a job to view the steps the job uses, the pro-
cedure or program each step executes, and the data stores each pro-
cedure or program reads from or writes to. 

Tip: Use the search facility described in “Searching Batch Appli-
cation Table Views” on page 4-7 to locate jobs.

3 Click Procedure View at the bottom of the window to open the pro-
cedure view. In the Procedure/Program pane, select a procedure or 

Search for items 
in lefthand column

Data Set Pane

Procedure/
Program Pane

Job Pane
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program to view the jobs and steps that execute it, and the data stores 
the procedure or program reads from or writes to. For procedures, 
Batch Application Viewer displays data stores referenced by DD 
statements added after the substitution of the procedure.

4 Click Dataset View at the bottom of the window to open the dataset 
view. In the Dataset pane, select a dataset to view the procedure or 
program that reads or writes to it, the step that executes the proce-
dure or program, and the job that contains the step. 

5 When you select the dataset view, Batch Application Viewer dis-
plays the Data Set Flow pane in the bottom right part of the window. 
Select a dataset in the Data Set pane and a step in the Procedure/Pro-
gram pane, then click the  button in the Data Set Flow pane to 
view the flow of data into or out of the selected dataset (Figure 4-2). 

Click the button in the Data Set Flow pane to view the flow of 
data into the dataset, click the button to view the flow of data out 
of the dataset.

Figure 4-2 Batch Application Viewer Window — Data Set Flow
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6 In any view, place a check mark next to one or more objects and click 
Diagram at the bottom of the window to display a diagram of batch 
application objects related to the objects. The diagram shows the re-
lationships between jobs, programs or procedures, and data stores 
(Figure 4-3). Usage is similar to that for the Diagrammer tool de-
scribed in Chapter 2.

Figure 4-3 Batch Application Viewer Window — Diagram View

7 In any table view or diagram, select an object and click HyperView 
at the bottom of the window to view the object in the ATW Hyper-
View tool. For procedures or data stores referenced by procedures, 
HyperView navigates to the object in the source code for the proce-
dure. Otherwise, it navigates to the object in the JCL file. 

Note: The HyperView pane shows a view-only copy of application 
source. For HyperView usage information, see Analyzing 
Programs in the ATW document set.
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Working with Batch Application Table Views 
Batch Application Viewer offers three table views of a batch application:

• The Job View cross-references the selected job with the steps the job 
contains, the procedure or program each step executes, and the DD 
and dataset names of the files each procedure or program reads from 
or writes to. Click Job View at the bottom of the Batch Application 
Viewer window to open the procedure view. 

• The Procedure View cross-references the selected procedure or pro-
gram with the jobs and steps that execute it, and the DD and dataset 
names of the files it reads from or writes to. Click Procedure View 
at the bottom of the Batch Application Viewer window to open the 
procedure view.

Note: For procedures, Batch Application Viewer displays the DD 
and dataset names of files referenced by DD statements added 
after the substitution of the procedure.

• The Dataset View cross-references the selected dataset with the pro-
cedure or program that reads or writes to it, the step that executes the 
procedure or program, and the job that contains the step. Click 
Dataset View at the bottom of the Batch Application Viewer win-
dow to open the dataset view. 

Batch Application table views consist of a Job pane, Program/Procedure 
pane, and Data Set pane. 

Note: For the data set view, Batch Application Viewer also displays 
a Data Set Flow pane, where you can investigate the flow of 
data into or out of a data store. 

You can hide a pane by clicking the close box in the upper righthand cor-
ner. Select the appropriate choice in the View menu to show the pane 
again. 

Sorting Entries  Click a column heading in a table view pane to sort the 
entries by that column. 

Sizing Columns  Grab-and-drag the border of a column heading to in-
crease or decrease the width of the column. 



Analyzing Batch Applications
Using the Batch Application Viewer

4-6
Selecting Objects  Click an object in a table view pane to select it. To se-
lect a range of objects, hold down the Shift key, click the first object in 
the range, then click the last object in the range. To select objects that are 
not in a range, hold down the Control key, then click each object you 
want to select.

Selecting Entries to Diagram  Place a check mark next to an object and 
click Diagram at the bottom of the Batch Application Viewer window 
to display a diagram of batch application objects related to the object. 

To place a check mark next to all the objects in a table view pane, choose 
Check All in the Edit menu. To uncheck all the selected objects, choose 
Uncheck All in the Edit menu.

To place a check mark next to selected objects, select the objects and 
choose Check Selected in the Edit menu. To uncheck all the objects, 
choose Uncheck Selected in the Edit menu.

Viewing the Flow of Data into or out of a Dataset  Select a dataset in 
the Data Set pane and a step in the Procedure/Program pane, then click 
the  button in the Data Set Flow pane to view the flow of data into or 
out of the selected dataset (Figure 4-2 on page 4-3). Click the left arrow 
in the Data Set Flow pane to view the flow of data into the dataset, click 
the right arrow to view the flow of data out of the dataset.

Viewing Properties  Select an object in a table view pane and choose 
Properties in the View menu to display a set of tabs with object proper-
ties. For usage information, see Getting Started in the ATW document 
set.

Exporting a Table View Report   Open a table view and choose Report 
in the File menu to export a printed report on the view to HTML, Excel, 
RTF, Word, or formatted text.

Note: For reports, Excel is usually the best option if you need to ma-
nipulate the report or perform computations. For more infor-
mation on exporting reports, see Getting Started in the ATW 
document set.
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Searching Batch Application Table Views

Use the Batch Application Viewer search facility to locate objects in the 
lefthand column of table views. To use the search facility, enter the text 
for the search in the field next to the  button on the tool bar. Batch Ap-
plication Viewer locates text matches as you type. 

Click the  button or press Enter to navigate to the next matching con-
struct. Click the adjacent  button to view additional choices in a drop-
down menu. Choose:

• Next to find the next matching object. 

• Wild Next to use a wildcard pattern to find the next matching object. 

• Find All to find all matching objects.

• Wild Find All to use a wildcard pattern to find all matching objects.

You can use wildcard patterns allowed in LIKE statements by Visual Ba-
sic for Applications (VBA).

Working with Batch Application Diagrams

Batch application diagrams show the relationships between jobs, proce-
dures and programs, and data stores (Figure 4-3 on page 4-4). Usage is 
similar to that for the Diagrammer tool described in Chapter 2. 

Generating a Batch Application Diagram 
Follow the steps below to generate a batch application diagram.

To generate a batch application diagram:

1 In the appropriate table view pane, place a check mark next to the 
objects you want to diagram, as described in “Selecting Entries to 
Diagram” on page 4-6.

2 In the Diagram menu, choose the relationships you want to view in 
the diagram:

• Job Dependencies show dependencies between jobs. Jobs are 
regarded as dependent if one writes to a dataset and the other 
reads from the same dataset.

• Data Set Usage shows interactions with datasets.
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• JCL Procedures Usage shows interactions with procedures.
• Program Usage shows interactions with programs.

Tip: Use these choices to control the level of detail in the diagram. 
The choice is grayed out with a check mark beside it if the re-
lationship must be displayed in the diagram. You can also set 
these choices after you display the diagram.

3 Edit the color scheme for the relationships if necessary, as described 
in “Editing the Color Scheme for Batch Application Diagrams” on 
page 4-8.

4 Click Diagram at the bottom of the Batch Application Viewer win-
dow. The diagram is displayed in the Diagram pane (Figure 4-3 on 
page 4-4).

Editing the Color Scheme for Batch Application Diagrams 
Diagram objects are color-coded based on the color scheme set in the 
Diagrammer tool described in Chapter 2. Relationship lines are color-
coded based on your settings in the Batch Application View Options 
window.

To edit the color scheme for relationships in batch diagrams:

1 In the View menu, choose Options. The Options window opens 
(Figure 4-4 on page 4-9).

2 In the Diagram Relations pane, click the relationship type whose 
color you want to edit. The current color of the type is displayed in 
the Edge Color drop-down.

3 Click the arrow beside the drop-down to display a standard Win-
dows color control. Use the Palette tab to select the color of the 
relationship type from the Windows palette. Use the System tab to 
match the color of the relationship type with the color of standard 
Windows elements.

Tip: You can restore the default option settings by clicking Batch 
Application Viewer Defaults, then choosing Restore De-
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faults in the drop-down menu. Choose Save To in the drop-
down menu to save the option settings to a file. Choose Load 
From in the menu to restore the option settings from a file.

4A Click Apply if you want to save your settings without dismissing the 
Options window. 

4B Click OK if you want to save your settings and dismiss the Options 
window. 

Figure 4-4 Options Window

Creating Job Dependencies in Batch Application Diagrams 
Batch Application Viewer treats jobs as dependent if one writes to a 
dataset and the other reads from the same dataset. Occasionally, you may 
want to define dependencies between jobs based on other criteria — ad-
ministrative needs such as scheduling, for example. Batch Application 
Viewer modifies the diagram only, not the repository.

Creating Job Dependencies  To create dependencies between jobs in a 
batch application diagram, hold down the Alt key, select either job, and 
drag-and-drop the relationship to the other job. The relationship is dis-
played in red with three plus (+) signs at either end of the relationship 
line.

click to display
current color

click to display
color options
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Exporting and Importing Job Dependencies  To export job dependen-
cies to a file, for import to diagrams for other projects, choose Export 
Dependency Changes in the File menu. A Save As dialog opens, where 
you can specify the name and folder for the export file.

To import job dependencies from a file, choose Import Dependency 
Changes in the File menu. An Open dialog appears, where you can se-
lect the file you want to import.

Removing Job Dependencies  To remove all user-defined dependencies 
from a batch application diagram, choose Clean Up Dependencies in 
the File menu. 

Tip: In certain circumstances — jobs that use cataloged file gener-
ation, for example — Batch Application Viewer may create 
false dependencies. You must remove these relationships 
manually by right-clicking the dependency and choosing 
Remove from the pop-up menu. 

Creating User Names for Objects in Batch Application Diagrams

You can give diagram objects friendlier names — so-called user names. 
Batch Application Viewer modifies the diagram only, not the repository.

Creating and Displaying User Names  To create a user name for an ob-
ject in a batch application diagram, select the object and choose User 
Name in the View menu. The User Name dialog opens (Figure 4-5). En-
ter the user name in the text field and click OK. To display user names 
in a diagram, select User Names in the Batch Application Viewer Op-
tions window (Figure 4-4 on page 4-9).

Figure 4-5 User Name Dialog
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Exporting and Importing User Names  To export user names to a file, 
for import to diagrams for other projects, choose Export User Names in 
the File menu. A Save As dialog opens, where you can specify the name 
and folder for the export file.

To import job dependencies from a file, choose Import User Names in 
the File menu. An Open dialog appears, where you can select the file you 
want to import. 

Removing User Names  To remove all user names from a batch applica-
tion diagram, choose Clean Up User Names in the File menu. 

Copying Batch Application Diagrams to the Clipboard

Choose Copy to Clipboard in the Diagram menu to copy a batch appli-
cation diagram to the clipboard in EMF format. You can paste the dia-
gram from the clipboard to a document in a third-party tool such as 
Word.

Printing Batch Application Diagrams

Choose Print in the Diagram menu to print a batch application diagram. 
The Print Preview window opens, where you can change the zoom factor 
for the diagram to control the number of pages in the print job. Click 
OK.

Exporting Batch Application Diagrams 

You can export batch application diagrams to a variety of standard for-
mats. Choose Save in the File menu to export a diagram to BED, bitmap, 
JPEG, Visio, Visio XML, DOT, or EMF. For more information on ex-
porting diagrams, see Getting Started in the ATW document set.

Note: Visio 2002 must be installed to save a diagram to Visio. Visio 
2002 is not required to save to Visio XML. 

You can also export a batch application diagram to the ATW WebGen 
tool by clicking Create WebGen Page in the File menu. All diagram 
types are exported to the page. The page is stored in the file \Work-
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space\Projects\Project\Webgen\BatchView\Main.htm. Click the hyper-
link for a diagram to view it in the browser. 

Note: Batch Application Viewer exports an additional diagram to 
WebGen showing all dependent jobs in the project.

Working with HyperView in Batch Application Viewer

Select an object in a table view or diagram and click HyperView at the 
bottom of the Batch Application Viewer window to view the object in 
the ATW Hyperview tool. For procedures or data stores referenced by 
procedures, HyperView navigates to the object in the source code for the 
procedure. Otherwise, it navigates to the object in the JCL file. 

Note: The HyperView pane shows a view-only copy of application 
source. For HyperView usage information, see Analyzing 
Programs in the ATW document set.

What’s Next?

Now that you know how to analyze batch applications in the Batch Ap-
plication Viewer, let’s look at how you perform low-level analysis of 
PL/I programs in the PL/I Call Diagrammer. That’s the subject of the 
next chapter.
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Analyzing PL/I Applications
he PL/I Call Diagrammer lets you perform low-level analysis of 
PL/I programs. You can use it to examine call flows for external 
procedures as you would in the Diagrammer. But you can also 

use it to examine call flows for internal procedures that the Diagrammer 
is unable to model. 

Understanding PL/I Call Flow Diagrams

Call flow diagrams show the call relationships between PL/I external 
and internal procedures (Figure 5-1 on page 5-2). The diagrams can 
model any level of nested procedure. Usage is similar to that for the 
Diagrammer tool described in Chapter 2.

In each diagram, the name of the called procedure appears on the rela-
tionship line. External, internal, and system procedures are color-coded 
based on your settings in the PL/I Call Diagrammer User Preferences 
window. For more information, see “Setting PL/I Call Diagram Options” 
on page 5-3.

T
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Figure 5-1 PL/I Call Flow Diagram

Using the PL/I Call Diagrammer

The PL/I Call Diagrammer is implemented in the ATW HyperView tool 
with a full set of HyperView panes. For Source and Clipper pane usage, 
and HyperView usage in general, see Analyzing Programs in the ATW 
document set.

Generating PL/I Call Information 
Follow the steps below to generate PL/I call information.

To generate PL/I call information:

1 In the Repository Browser, select the program you want to analyze 
and choose Interactive Analysis in the Analyze menu. The Hyper-
View window opens. In the View menu, choose PL/I Call Diagram. 
The PL/I Call Diagrammer window opens (Figure 5-2 on page 5-3).

Tip: Use the Clipper pane to select a different program in the 
project without having to exit HyperView.

2 The Context pane displays the procedures in the program in hierar-
chic form. Select the procedure whose relationships you want to 
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view, then choose Reconstruct in the PLI Call Diagrammer menu. 
The PL/I Call Diagram pane displays a diagram that shows each call 
the procedure makes to an external or internal procedure.

Figure 5-2 PL/I Call Diagrammer Window (After Drawing Diagram)

Setting PL/I Call Diagram Options 
Use the PL/I Call Diagrammer User Preferences window to filter out 
unwanted procedures from diagrams and define a color scheme for 
diagrams.

To set PL/I call diagram User Preferences:

1 In the View menu, choose User Preferences. The User Preferences 
window opens. Click the HyperView tab. In the Preferences pane, 
click PL/I Call Diagrammer. The PL/I Call Diagrammer Options 
window opens (Figure 5-3 on page 5-4).

Context Pane

PL/I Call 
Diagram Pane

Clipper Pane

Source Pane
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Figure 5-3 PL/I Call Diagrammer Options Window

2 In the Name Filters pane, select the pattern that matches the names 
of procedures you want to exclude from the diagram. The recog-
nized patterns are listed in the Name Filters pane. 

Right-click in the Name Filters pane and choose Add in the pop-up 
menu to add a pattern to the list. The system displays an empty text 
field next to a selected check box. Enter the name of the new pattern 
in the field and click outside the field. You can use wildcard patterns 
allowed in LIKE statements by Visual Basic for Applications 
(VBA).

You can edit a pattern by right-clicking it and choosing Edit in 
the pop-up menu. You can delete a pattern by right-clicking it and 
choosing Delete in the pop-up menu. 

3 In the Shapes and Colors pane, click the object type whose color you 
want to edit. The current foreground (caption) color of the type is 
displayed in the Colors drop-down.

right-click menu
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Click the arrow beside the drop-down and choose ForeColor from 
the pop-up menu if you want to edit the color of the caption for the 
object type, or BackColor if you want to edit the color of the back-
ground for the object type.

A standard Windows color control is displayed. Use the Palette tab 
to select the color of the caption or background from the Windows 
palette. Use the System tab to match the color of the caption or back-
ground with the color of standard Windows elements.

4 Select Rounded box if you want the border of diagram objects to 
have rounded corners.

Tip: You can restore the default option settings by clicking PL/I 
Call Diagrammer Defaults, then choosing Restore Defaults 
in the drop-down menu. Choose Save To in the drop-down 
menu to save the option settings to a file. Choose Load From 
in the menu to restore the option settings from a file.

5A Click Apply if you want to save your settings without dismissing the 
User Preferences window. 

5B Click OK if you want to save your settings and dismiss the User 
Preferences window. 

Copying PL/I Call Diagrams to the Clipboard

Choose Copy Diagram in the PL/I Call Diagram menu to copy a PL/I 
call diagram to the clipboard in EMF format. You can paste the diagram 
from the clipboard to a document in a third-party tool such as Word.

Printing PL/I Call Diagrams

Choose Print Diagram in the PL/I Call Diagram menu to print a PL/I 
call diagram. The Print Preview window opens, where you can change 
the zoom factor for the diagram to control the number of pages in the 
print job. Click OK.
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Exporting PL/I Call Diagrams 

You can export PL/I call diagrams to a variety of standard formats. 
Choose Save Diagram As in the PL/I Call Diagram menu to export a 
diagram to BED, bitmap, JPEG, Visio, Visio XML, DOT, or EMF. For 
more information on exporting diagrams, see Getting Started in the 
ATW document set.

Note: Visio 2002 must be installed to save a diagram to Visio. Visio 
2002 is not required to save to Visio XML. 

What’s Next?

That completes your tour of ATW program and data flow analysis tools. 
The next chapter shows you how to use the workbench CRUD report and 
IMS port analysis feature to analyze data operations.



6-1
6
Analyzing Data Operations
he workbench parser generates relationships that show the data 
operations a program performs — Insert, Read, Update, or De-
lete — and the data objects on which the program operates — 

files, segments, tables, and so forth. This chapter looks at a report that 
lets you view these relationships in a convenient format, and a mecha-
nism that lets you trace PSB usage through an entire IMS application call 
sequence.

Viewing CRUD Reports

The CRUD report for a project shows the data operations each program 
in the project performs, and the data objects on which the programs op-
erate.

To generate a CRUD report:

1 In the Repository Browser, select a project and choose CRUD 
Report in the Prepare menu. The CRUD Report window opens 
(Figure 6-1 on page 6-2).

T
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Figure 6-1 CRUD Report

Tip: Click a column heading in the Results pane to sort the entries 
by that column. Grab-and-drag the border of a column head-
ing to increase or decrease the width of the column.

2 To select the types of program-to-data object relationships to dis-
play, and the data operations to show for each type, choose Options 
in the View menu. The CRUD Report Options window opens 
(Figure 6-2 on page 6-3).

3 In the CRUD Report Options window:

• Place a check mark next to each type of program-to-data object 
relationship you want to display.

• Place a check mark next to each data operation you want to dis-
play. 

Click Apply if you want to save your settings without dismissing the 
CRUD Report Options window open. Click OK if you want to save 
your settings and dismiss the CRUD Report Options window.

4 Choose Refresh in the File menu to refresh the report.
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5 Choose Report in the File menu to export the report to HTML, Ex-
cel, RTF, Word, or formatted text.

Note: Excel is usually the best option if you need to manipulate the 
report or perform computations. For more information on ex-
porting reports, see Getting Started in the ATW document set.

Figure 6-2 CRUD Report Options Window

Enabling IMS Port Analysis

It is virtually impossible to determine from program code the database 
segments or screens an IMS program operates on. Only an application-
wide analysis can trace PSB usage through the entire application call se-
quence. 

To determine the types of database operation — insert, read, update, 
or delete — an IMS program performs, and to list in the browser each 
of the database segments or screens the operation may be performed on, 
select a project and choose IMS Analysis in the Prepare menu. 

Figure 6-3 shows typical results. The objects marked with the icon 
are abstract decision objects, indicating that the database operation — in 
this case, Deletes — has not been resolved to a database segment.
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Figure 6-3 IMS Port Analysis Results

Setup

The IMS port analysis feature assumes that your application identifies 
IMS “root programs” and corresponding PSBs in a JCL file for a batch 
application or a PCT file for an online application. A root program is di-
rectly invoked by IMS with a list of PCBs as parameters. It can pass 
these PCBs as parameters in calls to other programs.Verify source files 
in the following order: 

Tip: If you verify an entire project, the workbench parses the files 
in appropriate order, taking account of the dependencies be-
tween file types. 

• DBD files (assuming you need full cross-reference information)

• MFS files

• PSB files

• Cobol or PL/I files

database operation

decision object

segment
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Note: For Cobol files, set the Perform Program Analysis and En-
able Data Element Flow project verification options. For 
PL/I files, set the Enable Data Element Flow project verifi-
cation option

• JCL or PCT files

Note: For PCT files, set the Treat as IMS System Definition option 
in the Workspace Verification options Settings tab.

What’s Next? 

That’s all you need to know to use the workbench CRUD report and IMS 
port analysis feature to analyze project data operations. Now let’s look 
at how you use the legacy estimation tools to estimate project complexity 
and effort. 
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Estimating Complexity and 
Effort
uppose you are planning to implement a change request for a 
program and want to know how long it will take to complete the 
change. ATW legacy estimation tools let you compare programs 

based on weighted values for selected complexity metrics. Based on the 
comparison, you can develop a credible estimate of the time required to 
make the requested change. 

The complexity metrics used in the calculation are a combination of in-
dustry standard and ATW-generated statistics (Table 7-1 on page 7-8). If 
your own analysis shows that a given program is more or less complex 
than the weighted calculation would suggest, you can set a change mag-
nitude to override the calculated value for the program.

The program might have thousands of source lines, for example, increas-
ing its calculated complexity, while actually being very easy to modify. 
When you use a change magnitude, your “subjective” estimate of the ef-
fort involved — Small, Medium, Large, Extra Large — becomes an in-
put to the effort calculation, along with the weighted values.

S
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Using the Complexity Metrics Tool 

Use the Complexity Metrics tool to compare raw complexity values for 
the objects in your project. 

To generate complexity metrics:

1 In the Repository Browser, select the project whose complexity 
metrics you want to calculate and choose Complexity in the 
Analyze menu. A blank Complexity Metrics window opens. 

2 In the Entity Type drop-down, choose the type of object you want 
to calculate complexity metrics for. Figure 7-1 shows the results
for the program object. The metrics are described in Table 7-1 on 
page 7-8.

Figure 7-1 Complexity Metrics Window

Tip: Click a column heading to sort the entries by that column. 
Grab-and-drag the border of a column heading to increase 
or decrease the width of the column.

3 To select the metrics to be included in the calculation, choose Col-
umns in the View menu. The Attributes window opens (Figure 7-2 
on page 7-3).
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Figure 7-2 Complexity Metrics — Attributes Window

4 In the Attributes window, place a check mark next to each complex-
ity metric you want to calculate. Click Apply if you want to save 
your settings without dismissing the Attributes window open. Click 
OK if you want to save your settings and dismiss the Attributes win-
dow.

5 Select an object and choose Properties in the View menu to display 
a set of tabs with object properties. For usage information, see Get-
ting Started in the ATW document set.

Using the Effort Estimation Tool 

Use the Effort Estimation tool to compare source files based on weighted 
values for selected complexity metrics. 

To generate effort estimation statistics:

1 In the Repository Browser, select the project whose effort estimation 
you want to calculate and choose Effort in the Analyze menu. A 
blank Effort Estimation window opens. 

2 To select the file types to be included in the calculation, and the com-
plexity metrics for each type, and to set the percentage factor for the 
change magnitudes used in the calculation, choose Options in the 
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View menu. The Effort Estimation Options window opens 
(Figure 7-3).

Figure 7-3 Effort Estimation Options Window

3 In the Effort Estimation Options window:

• Place a check mark next to each source file type you want to in-
clude in the calculation.

• For each source file type to be included in the calculation, place 
a check mark next to each complexity metric you want to use in 
the calculation. The metrics are described in Table 7-1 on 
page 7-8.

• For each complexity metric to be used in the calculation, enter
its weight in the Weighting Factor field. If you want Cyclomatic 
Complexity to have twice the weight of Conditional Complexity, 
for example, set the weighting factor for Cyclomatic Complexity 
to 2 and the weighting factor for Conditional Complexity to 1.

• To set the percentage factor for the change magnitudes used in 
the calculation, enter the percentage you want to be applied in the 
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combo box for each change magnitude value: Small, Medium, 
Large, and Extra Large. The values shown in Figure 7-3 on 
page 7-4 are representative. For background on change magni-
tudes, see “Specifying Change Magnitudes” on page 7-6.

Click Apply if you want to save your settings without dismissing the 
Effort Estimation Options window open. Click OK if you want to 
save your settings and dismiss the Effort Estimation Options win-
dow.

Note: You can restore the default settings by clicking Effort Esti-
mation Defaults, then choosing Restore Defaults in the 
drop-down menu. Choose Save To in the drop-down menu to 
save the option settings to a file. Choose Load From in the 
menu to restore the option settings from a file.

4 Click the  button on the tool bar to generate effort estimation sta-
tistics. The statistics for the selected source file type are displayed. 
Figure 7-4 on page 7-6 shows the results for Cobol source files. 

Tip: Click a column heading to sort the entries by that column. 
Grab-and-drag the border of a column heading to increase 
or decrease the width of the column.

5 Select a source file in the Effort pane to show the effort statistics for 
each extracted object in the file in the Details pane.

6 Select a source file in the Effort pane to view HyperCode for the file 
in the Preview pane. The information available depends on the type 
of object selected — you see only source code for a copybook, for 
example, but full HyperCode for a program.

Note: “HyperCode” is shorthand for the information displayed in 
the ATW HyperView tool. For HyperView usage information, 
see Analyzing Programs in the ATW document set.

7 Select a file and choose Properties in the View menu to display a set 
of tabs with object properties. For usage information, see Getting 
Started in the ATW document set.
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Figure 7-4 Effort Estimation Window

Specifying Change Magnitudes

What if your own analysis of a project shows that a given program will 
actually take much less time to change than the weighted effort estima-
tion would suggest. The program might have thousands of source lines, 
for example, increasing its calculated complexity, while actually being 
very easy to modify. 

A change magnitude is a way of overriding the calculated value for a 
source file. Your “subjective” estimate of the effort involved — Small, 
Medium, Large, Extra Large — becomes an input to the effort calcula-
tion, along with the weighted values.

click to generate 
statistics

extracted objects 
for selected file

total effort for 
listed files

weighted complexity 
value

change magnitude

total effort

source for 
selected file
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You typically set the change magnitude for a file in the HyperView Con-
text pane, but you can also set it (or change it) in the Effort Estimation 
tool. For Hyperview usage, see Analyzing Programs in the ATW docu-
ment set.

In the Effort Estimation window (Figure 7-4 on page 7-6), select the files 
whose change magnitudes you want to set and choose Set Change Mag-
nitude:magnitude in the Edit menu, where magnitude is S for Small, M 
for Medium, L for Large, or XL for Extra Large. The effort calculation 
for the selected files is automatically updated.

Tip: To select a range of files, hold down the Shift key, click the 
first item in the range, then click the last item in the range. To 
select files that are not in a range, hold down the Control key, 
then click each file you want to add. 

Exporting Complexity and Effort Reports 

You can export complexity and effort reports to a variety of standard for-
mats. Choose Report in the File menu to export the report to HTML, Ex-
cel, RTF, Word, or formatted text.

Note: Excel is usually the best option if you need to manipulate the 
report or perform computations. For more information on ex-
porting reports, see Getting Started in the ATW document set.

You can also export a report to the ATW WebGen tool by clicking Cre-
ate WebGen Page in the File menu. 

• The complexity report is stored in the file \Workspace\Projects
\Project\Webgen\Complexity\Main.htm. 

• The effort report is stored in the file \Workspace\Projects\Project
\Webgen\Effort\Main.htm. 

Click the hyperlink for a report to view it in the browser.
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Supported Complexity Metrics 

The following table describes the industry standard and ATW-generated 
complexity metrics supported by the legacy estimation tools. For details 
on language-specific metrics, see the Parser Reference Manual in the 
ATW document set.

Table 7-1 Complexity Metrics

Metric Object Types Description

Absolute Complexity Program Number of Binary Decisions 
divided by the number of state-
ments.

Areas DMS DDL file, IDMS 
Schema file

Number of areas.

Binary Decisions Program Number of branching conditions 
in the flow graph with two possi-
ble outcomes. Includes statements 
with implicit condition evaluation 
(loops, AT END, and so on).

Blank Lines All Number of blank lines of source 
(sequence number area content is 
ignored).

Call Statements Program Number of invocations of external 
modules.

Columns DDL file Number of columns.

Computational Statements Program Number of statements performing 
arithmetic calculations

Conditional Complexity Program Number of Binary Decisions plus 
the number of Unique Operands in 
Conditional Statements.

Conditional Statements Program Number of branching statements 
with nested statements executed 
under certain conditions, not 
including conditional GOTOs.
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Cyclomatic Complexity Program v(G) = e - n + 2, where v(G) is the 
cyclomatic complexity of the flow 
graph (G) for the program in ques-
tion, e is the number of edges in G, 
and n is the number of nodes. 
Quantity of decision logic. The 
number of linearly independent 
paths (minimum number of paths 
to be tested). v(G) = DE + 1, where 
DE is the number of binary deci-
sions made in the program.

Data Elements Copybook file, Program Number of declared data items 
(elementary structures and their 
fields).

Dead Data Elements Program Number of dead data elements. 
Dead data elements are unused 
level-1 structures and their mem-
bers. A level-1 structure is 
regarded as unused if it and all its 
members are unused.

Dead Data Elements from 
Includes

Program Number of dead data elements in 
included files. Dead data elements 
are unused level-1 structures
and their members. A level-1 
structure is regarded as unused if 
it and all its members are unused.

Dead Lines Program Number of dead lines. Dead lines 
are source lines containing dead 
statements or dead data elements.

Dead Lines from Includes Program Number of dead lines in included 
files. Dead lines are source lines 
containing dead statements or 
dead data elements.

Table 7-1 Complexity Metrics (continued)

Metric Object Types Description
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Dead Statements Program Number of dead statements. A 
dead statement is a procedural 
statement that can never be 
reached during program execution.

Dead Statements from Includes Program Number of dead statements in 
included files. A dead statement is 
a procedural statement that can 
never be reached during program 
execution.

Difficulty Program D = (n1 / 2) * (N2 / n2), where n1 is 
the number of Unique Operators, 
N2 is the number of Operands, and 
n2 is the number of Unique Oper-
ands.

Entry Points Program Number of program entry points.

Error Estimate Program B = E**(2/3) / 3000, where E is Pro-
gramming Effort.

Executable Statements Program All Cobol Procedure Division 
statements, plus CONTINUE 
NEXT STATEMENT. All PL/I 
statements, except BEGIN, 
DECLARE, DO (block), END, 
ENTRY, PACKAGE, and PRO-
CEDURE. All Natural statements, 
except DEFINE DATA and 
IGNORE. 

Extended Cyclomatic 
Complexity

Program Cyclomatic Complexity plus the 
number of Logical Operators in 
Conditions. Number of all paths in 
the program.

Fields of Adabas File Number Natural DDM file Number of fields of Adabas file 
number.

Table 7-1 Complexity Metrics (continued)

Metric Object Types Description
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Foreign Keys DDL file Number of foreign keys.

Function Points Program Lines of Code divided by K, 
where K depends on the language: 
Cobol=77, Natural=52, PL/I=67. 
Estimate of the number of end-
user business functions imple-
mented by the program. 

GoTo Statements Program Number of GOTO statements, 
including conditional GOTOs.

Include Statements Cobol file, Natural Sub-
routine file, Natural file, 
PL/I source file

Number of language-specific 
include statements.

Inner Call Statements Program Number of statements that invoke 
Inner Procedures.

Inner Procedures Program Number of structured pieces of 
code that cannot be invoked from 
external programs (Cobol para-
graphs, inner PL/I procedures, 
Natural inline subroutines).

Input Fields Screen Number of input fields.

Intelligent Content Program I = L * V, where L is the Program 
Level and V is the Program Vol-
ume. Complexity of a given algo-
rithm independent of the language 
used to express the algorithm.

IO Statements Program Number of statements performing 
input/output operations.

Lines of Code Program Number of lines of code, including 
copybooks, but not including com-
ments and blank lines.

Table 7-1 Complexity Metrics (continued)

Metric Object Types Description
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Lines with Comments All Number of lines of source contain-
ing comments, including inline 
comments placed on lines with 
statements.

LINK Statements Program Number of CICS LINK state-
ments.

Logical Operators in 
Conditions

Program Number of binary logical opera-
tors used in conditions.

Loop Statements Program Number of repetitively executing 
statements.

Maps Natural Map Number of maps.

Nesting Level Program Maximum nesting of conditional 
statements within conditional 
statements (0 if no conditional 
statements, 1 if no nesting).

Number of Entries CSD file, FCT file, PCT 
file, Valtab file

Number of entries.

Number of Executes ECL file Number of executes.

Number of PCBs PSB file Number of PCBs.

Number of Processor Calls ECL file Number of processor calls.

Number of Steps JCL file Number of steps.

Operands Program Number of operands (N2). Oper-
ands are variables and literals used 
in operators. Uniqueness of literals 
is determined by their notation. 

Operators Program Number of operators (N1). Opera-
tors are executable statements and 
unary and binary operations. 

Output Fields Screen Number of output fields.

Table 7-1 Complexity Metrics (continued)

Metric Object Types Description
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Parameters Program Number of Cobol Procedure Divi-
sion USING...RETURNING 
parameters. Number of PL/I PRO-
CEDURE parameters. Number of 
Natural PARAMETER and 
PARAMETER USING parame-
ters.

Pointers Program Number of data elements declared 
as pointers.

Primary Keys DDL file Number of primary keys.

Program Length Program N = N1 + N2, where N1 is the num-
ber of Operators and N2 is the 
number of Operands.

Program Level Program L = 1 / D, where D is the program 
Difficulty.

Program Volume Program V = N * log2(n), where N is the Pro-
gram Length and n is the program 
Vocabulary. Minimum number of 
bits required to code the program.

Programming Effort Program E = V / L, where V is the Program 
Volume and L is the Program 
Level. Estimated mental effort 
required to develop the program.

Programming Time Program T = E / 18, where E is the Program-
ming Effort and 18 is Stroud’s 
Number. Estimated amount of 
time required to implement the 
algorithm, in seconds. 

Records DMS DDL file, IDMS 
Schema file

Number of records.

Table 7-1 Complexity Metrics (continued)

Metric Object Types Description
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What’s Next?

Now that you know how to estimate project complexity and effort, 
let’s look at how you define an application namespace for your project. 
That’s the subject of the next chapter.

Screens AS400 screen, BMS file, 
DPS file, MFS file

Number of screens.

Segments DBD file Number of segments.

Sets DMS DDL file, IDMS 
Schema file

Number of sets.

Source Lines All Number of lines of source.

Tables DDL file Number of tables.

Unique Operands Program Number of distinct operands (n2). 
Operands are variables and literals 
used in operators. Uniqueness of 
literals is determined by their nota-
tion.

Unique Operands in Conditions Program Number of distinct operands used 
in conditions.

Unique Operators Program Number of distinct operators (n1). 
Operators are statements and 
unary and binary operations.

Vocabulary Program n = n1 + n2, where n1 is the number 
of Unique Operators and n2 is the 
number of Unique Operands.

XCTL Statements Program Number of CICS XCTL state-
ments.

Table 7-1 Complexity Metrics (continued)

Metric Object Types Description
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Defining an Application 
Namespace
he Application Namespace tool creates a conveniently orga-
nized dictionary that helps you navigate through your system’s 
terminology and modify it as necessary. You can also use the 

tool to provide pseudo-code versions of application names that are easier 
for business analysts to understand.

Namespace mapping lets you change identifiers in system source code 
without undermining the system’s consistency. If your legacy applica-
tion uses the identifiers CUSTMR and CSTMR to refer to a customer, 
for example, you can use the tool to rename both identifiers to CUS-
TOMER, and propagate the change to all the source files that need it.

Understanding Application Namespaces

When you open the Application Namespace tool, it displays a dictionary 
that lists every token in the project. A token is an element in a program 
identifier delimited by a hyphen (-) or underscore (_). In the identifier 

T
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WS01-CUST-FIELD, for example, there are three tokens: WS01, CUST, 
and FIELD. 

The dictionary also lists the identifiers that contain each token. To re-
name the identifiers, you simply change one or more of the tokens they 
contain. You can apply changes automatically or manually. You can also 
add business (pseudocode) names for identifiers to the dictionary and 
provide descriptive comments for constants.

Verifying Renamed Identifiers

Before you propagate name changes to source files, you need to verify 
that the renamed identifiers do not conflict with existing identifiers. The 
Application Namespace tool can:

• Verify new identifiers successfully.

• Verify new identifiers with non-fatal conflicts — two fields with the 
same name are members of different structures, for example. The 
tool places a symbol beside identifiers with non-fatal conflicts. 

• Verify the new identifiers with fatal errors — a field and a structure 
have the same name, for example. The tool places a symbol be-
side identifiers with fatal conflicts.

The Application Namespace tool lets you propagate name changes that 
generate non-fatal conflicts, but not name changes that generate fatal 
conflicts. You can select an offending identifier in the Names pane to 
compare its declaration with the declaration for the conflicting identifier 
in the Conflicts pane.

Propagation Output

When you propagate names changes to source files, the Application 
Namespace tool stores copies of the updated files in the folder \Work-
space\Projects\Project\Dictionary\Source File Type. It does not add the 
updated source files to the repository. Instead, it leaves it up to you to 
register and verify the modified files.
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Getting Started in the Application Namespace Tool

Let’s look at a sample use of the Application Namespace tool that shows 
you how to rename identifiers, verify that the renamed identifiers do not 
conflict with existing identifiers, and propagate the name change to 
project source files. Assume that you want to replace the token CUST 
with CUSTOMER in each identifier that uses the token.

To define an application namespace:

1 In the Repository Browser, select the project whose namespace you 
want to define and choose Application Namespace in the Architect 
menu. The Application Namespace window opens, with the dictio-
nary for the project (Figure 8-1).

Figure 8-1 Application Namespace Window (After Propagation)
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2 In the Tokens pane, select the CUST token and choose Edit in the 
right-click menu. In the edit field for the token, enter CUSTOMER 
and press Enter. Application Namespace places a symbol next to 
the token in the Tokens pane.

3 In the File menu, choose Apply Mapping to rename the identifiers 
that contain the token. Application Namespace places a symbol 
next to the identifiers in the Names pane.

Tip: Choose Automatic Mapping in the File menu if you want the 
Application Namespace tool to perform step 3 automatically.

4 In the File menu, choose Verify to verify that the new identifiers do 
not conflict with existing identifiers. For background on verification 
results, see “Verifying Renamed Identifiers” on page 8-2.

5 In the File menu, choose Propagate Changes to propagate the name 
change to source files. For background on propagation output, see 
“Propagation Output” on page 8-2.

Using the Application Namespace Tool

You generate a dictionary for the current project. You can rename iden-
tifiers, add business (pseudocode) names for identifiers, and provide de-
scriptive names for constants. 

Working with a Project Dictionary

The window for the Application Namespace tool consists of a Tokens 
pane, Names pane, Source pane, Modified Source pane, Conflicts pane, 
and Activity Log. You can hide a pane by clicking the close box in the 
upper righthand corner. Select the appropriate choice in the View menu 
to show the pane again. 

Tokens Pane

The Tokens pane displays the tokens in the project in two views:

• The report view shows the original and modified names of tokens 
in a vertically scrolling list. Choose Report in the View menu to dis-
play the report view.
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• The list view shows the current names of tokens in a horizontally 
scrolling list. Choose List in the View menu to display the list view.

Select a token to view the identifiers that contain it in the Names pane 
and its source code in the Source pane. 

Restricting the Views  To limit the scope of the display to tokens in a 
program rather than an entire project, choose the program in the Scope 
drop-down on the Application Namespace tool bar. 

Note: You can also limit the display by applying a token filter. See 
“Setting Application Namespace Options” on page 8-8.

Use the buttons at the top of the Tokens pane to limit the display even 
further. Click:

• All to view all the tokens in the selected project or program.

• Changed to view only the modified tokens in the selected project or 
program.

• Intact to view only the unmodified tokens in the selected project or 
program.

• Link to view only the tokens contained in the identifier selected in 
the Names pane. 

Tip: You can use Link with any of the other three buttons.

Sorting Entries  Click a column heading in the report view to sort the en-
tries by that column. 

Sizing Columns  Grab-and-drag the border of a column heading in the 
report view to increase or decrease the width of the column. 

Renaming a Token  To rename a token, select the token and choose Edit 
in the right-click menu. Enter the new name in the edit field for the token 
and press Enter. Application Namespace places a symbol next to a re-
named token.To restore the original name of a token, select the token and 
choose Restore in the Token menu. 

Adding Comments  To add a comment for a token, select it and enter the 
comment in the comments pane for tokens. 
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Names Pane

The Names pane displays the original, modified, and business names 
of identifiers in the project. Select an identifier to view its declaration 
in the Source pane. Select a renamed identifier to view its modified dec-
laration in the Modified Source pane.

Restricting the View  Use the buttons at the top of the Names pane to 
limit the display of identifiers. Click:

• All to view all the identifiers in the selected project or program.

• Changed to view only the modified identifiers in the selected 
project or program.

• Intact to view only the unmodified identifiers in the selected project 
or program.

• Link to view only the identifiers that contain the token selected in 
the Tokens pane. 

Tip: You can use Link with any of the other three buttons.

Sorting Entries  Click a column heading in the Names pane to sort the 
entries by that column. 

Sizing Columns  Grab-and-drag the border of a column heading to in-
crease or decrease the width of the column. 

Renaming an Identifier  To rename an identifier manually, select the 
identifier and choose Edit in the right-click menu. Enter the new name 
in the edit field for the identifier and press Enter. To map a renamed to-
ken to the identifiers that contain it, choose Apply Mapping in the File 
menu. 

Tip: Choose Automatic Mapping in the File menu if you want 
the Application Namespace tool to perform the mapping 
automatically.

Application Namespace places a symbol next to a manually renamed 
identifier and a symbol next to a mapped identifier. To restore the 
original name of an identifier, select the identifier and choose Restore in 
the Name menu. 
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Verifying Renamed Identifiers  To verify that renamed identifiers do 
not conflict with existing identifiers, choose Verify in the File menu. 
Application Namespace places a symbol next to a renamed identifier 
that generates non-fatal conflicts and a symbol next to a renamed 
identifier that generates fatal conflicts.

Tip: Select an offending identifier in the Names pane to compare 
its declaration with the declaration for the conflicting identi-
fier in the Conflicts pane.

Propagating Identifier Name Changes  To propagate identifier name 
changes to source files, choose Propagate Changes in the File menu. 
The Application Namespace tool lets you propagate name changes that 
generate non-fatal conflicts, but not name changes that generate fatal 
conflicts. For background on propagation output, see “Propagation Out-
put” on page 8-2.

Tip: Choose Files in the View menu to view a list of source files 
that were modified.

Adding Comments  To add a comment for an identifier, select it and en-
ter the comment in the comments pane for identifiers. 

Adding a Business Name for an Identifier  To add a business name for 
an identifier, select the identifier and choose Business Name in the 
right-click menu. Enter the new name in the edit dialog for the identifier 
and click OK.

Source Pane

The Source pane displays the declaration for the identifier selected in the 
Names pane.

Modified Source Pane

The Modified Source pane displays the declaration for the renamed iden-
tifier selected in the Names pane.

Conflicts Pane

The Conflicts pane displays the declarations for the renamed identifier 
selected in the Names pane and any identifiers with which it conflicts.
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Setting Application Namespace Options

Use the Application Namespace Options window to specify a prefix for 
modified lines in source code and define a filter that excludes unwanted 
tokens from the dictionary. By default, the tool defines filters for numer-
ic tokens.

To set application namespace options:

1 In the View menu, choose Options. The Application Namespace 
Options window opens (Figure 8-2).

Figure 8-2 Application Namespace Options Window

2 In the Filter pane, select the pattern that matches the names of tokens 
you want to exclude from the dictionary. The recognized patterns are 
listed in the Filter pane. 

Right-click in the Filter pane and choose Add in the pop-up menu to 
add a pattern to the list. The system displays an empty text field next 
to a selected check box. Enter the name of the new pattern in the 
field and click outside the field. You can use wildcard patterns al-
lowed in LIKE statements by Visual Basic for Applications (VBA).

You can edit a pattern by right-clicking it and choosing Edit in 
the pop-up menu. You can delete a pattern by right-clicking it and 
choosing Delete in the pop-up menu. 

right-click menu
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3 In the Prefix for modified lines field, enter the text you want to 
prepend to modified lines in source code.

4A Click Apply if you want to save your settings without dismissing the 
Options window. 

4B Click OK if you want to save your settings and dismiss the Options 
window. 

Tip: Application Namespace automatically applies the token filter 
when you click Apply or OK. You can delete filtered tokens 
from the application namespace database by choosing Clean 
Up in the File menu.

Refreshing a Project Dictionary

You can refresh a project dictionary with any changes you have made to 
the ATW repository by choosing Refresh in the File menu. You are 
prompted to confirm the refresh. Click Yes. 

Generating and Exporting Application Namespace Reports

The Application Namespace tool offers three reports:

• The Tokens report lists the original and modified names of tokens, 
any comments you have added for the tokens, and the number of 
declarations in which the tokens appear. Choose Tokens in the Re-
port menu to generate the Tokens report.

• The Names report lists the original, modified, and business names 
of identifiers, any comments you have added for the identifiers, and 
the number of declarations in which the identifiers appear. Choose 
Names in the Report menu to generate the Names report.

• The Files report lists original and modified source files in the select-
ed project or program. Choose Files in the View menu to generate 
the Files report.

You can export Application Namespace reports to a variety of standard 
formats. Choose Save on the tool bar for the report to export the report 
to HTML, Excel, RTF, Word, or formatted text.
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Note: Excel is usually the best option if you need to manipulate the 
report or perform computations. For more information on ex-
porting reports, see Getting Started in the ATW document set.

You can also export a report to the ATW WebGen tool by clicking Cre-
ate WebGen Page in the File menu. All reports are exported to the page. 
The page is stored in the file \Workspace\Projects
\Project\Webgen\Dictionary\Main.htm. Click the hyperlink for a report 
to view it in the browser. 

What’s Next?

Now that you know how to create an application namespace for your 
project, let’s look at one final project analysis task — using Change An-
alyzer to understand how a change in the definition or usage of a data 
field might impact the rest of the application. The next chapter shows 
you how to do that.
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9
Identifying Classes of Data 
Items
he Change Analyzer identifies the class of data items used to 
perform a business function in a legacy application. Among 
other uses, it lets you answer the kinds of “What if?” questions 

posed in the recent past by the industry-wide changes for Y2K, Zip+4, 
and the Euro dollar: “What if I change the type of this variable, or the 
length of this field — what other fields will I also have to change?” 

Use change analysis results to prepare project plans and technical spec-
ifications. You can generate reports showing source entities that may re-
quire modification, lines of code affected, and the like. 

Understanding Data Item Classification 

Suppose your organization is considering adding support for a new 
currency and that you are going to have to expand the existing exchange 
rate data field from 9(5)V9(3) to 9(5)V9(6) to accommodate the currency. 
You will need to know the data fields that are affected in the database, 
intermediate fields that may contain or use the exchange rate field in cal-
culations, and so forth. 

T
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Seed Fields

Use Change Analyzer to search for the exchange rate field. The object of 
the search is called a seed field:

• If the application uses field names like EX-RATE, EXCH-RATE, 
EXCHANGE-RATE, and RATE-OF-EXCHG, you would search for 
data names that contain *EXCH* or *RATE*. 

• If you know that some fields already contain the required number 
of decimal positions and are interested only in those that don’t, you 
might further limit the search by filtering on the PICTURE clause 
format of the variable, selecting only data items that have a format 
of 9(5)V9(3). 

• You might limit the search even further by choosing fields that have 
a given initial value.

• If you know there are data fields that will meet the search criteria for 
name, but are not what you are looking for, you might set up a list of 
names to exclude, such as INTEREST-RATE and *PRORATE*.

Synonyms

When you execute the search, Change Analyzer returns not only the 
fields that match the search criteria but any synonyms for the fields. A 
synonym is a data field whose value is related to the value of the matched 
field — a field whose value is assigned by a MOVE or REDEFINE state-
ment, for example. In these cases, if you increase the size of the matched 
field, you probably will have to increase the size of the synonym as well. 

Seed Lists 

As you examine the source code for seed fields and synonyms in Change 
Analyzer and determine whether a field is affected by a proposed change, 
you move the fields between seed lists:

• The Working list contains seed fields or synonyms that you are cur-
rently investigating.

• The Affected list contains seed fields or synonyms that you have 
determined would be affected by the proposed change.
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• The Clean list contains seed fields or synonyms that you have deter-
mined would not be affected by the proposed change.

You can generate reports based on these lists, as well as reports showing 
the affected source code in context.

Getting Started in Change Analyzer 

Change Analyzer is a complex tool that takes some getting used to. This 
section describes a sample use of the tool that should help you get ori-
ented in it. Assume that you want to evaluate the impact of changing the 
YEAR field in your application.

To evaluate change impacts:

1 In the Repository Browser, select the project you want to analyze 
and choose Field Change in the Analyze menu. The Change Ana-
lyzer window opens (Figure 9-2).

Figure 9-1 Change Analyzer Window
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2 In the File menu, choose Apply Filter:To Working. The Search 
window opens (Figure 9-2).

Figure 9-2 Search Window (After Step 4) 

3 In the Search window, click the Change Analyzer tab to view a list 
of recognized search criteria. Select a search criterion to view its def-
inition in the tabs in the righthand portion of the window. Click the 

 button on the tool bar to define a new criterion. The New Search 
Criterion dialog opens (Figure 9-3).

Figure 9-3 New Search Criterion Dialog

4 In the text field, enter YEAR and click OK. The YEAR criterion is 
displayed in the list of recognized criteria in the Change Analyzer 
tab in the Search window. 

list of search 
criteria

definition of 
selected criterion
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5 In the Change Analyzer tab, select the YEAR criterion, enter 
*YEAR* in the Name Like tab, and click Find All. Change Analyz-
er returns the seed fields for the criterion in the Working list and their 
synonyms in the Synonyms pane. Select a program in the Programs 
pane to view its seed fields and their synonyms. 

6 In the Working tab, select a seed field to navigate to its source in the 
Source pane. Examine the source to determine whether the field will 
be affected by the proposed change: 

• If the field will be affected by the change, choose Move to Af-
fected in the Edit menu. Change Analyzer moves the field to the 
Affected tab.

• If the field will not be affected by the change, choose Move to 
Clean in the Edit menu. Change Analyzer moves the field to the 
Clean tab.

7 Repeat step 6 for each seed field in the Working list.

8 Repeat steps 6-7 for each program in the Programs pane. 

9 In the File menu, choose Find Synonyms. The Find Synonyms dia-
log opens (Figure 9-4).

Figure 9-4 Find Synonyms Dialog

10 In the Find In pane, select Affected Lists. In the Add Synonyms To 
pane, select Working Lists. Click OK. Change Analyzer returns the 
synonyms for the affected fields in the Working list. 

11 Repeat step 6 for each synonym in the Working list.

12 In the File menu, choose Remove Unused:From Affected Lists to 
remove fields that are declared but not used from the Affected list.
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13 In the File menu, choose Report:Affected Datanames. Change An-
alyzer generates the Affected Datanames report (Figure 9-5).

Figure 9-5 Affected Datanames Report

14 In the File menu, choose Report:Affected Code. Change Analyzer 
generates the Affected Code report (Figure 9-6).

Figure 9-6 Affected Code Report
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Using Change Analyzer

You generate change impact information for the current project. The 
project must have been verified with the Enable Data Element Flow 
option set in the Verification tab of the Project Options window. 

Note: For more information on verification, see Preparing Projects 
in the ATW document set.

Working with Change Impact Information

The window for the Change Analyzer consists of a Programs pane, Lists 
pane, Synonyms pane, Source pane, and Activity Log. You can hide a 
pane by clicking the close box in the upper righthand corner. Select the 
appropriate choice in the View menu to show the pane again. 

Sorting Entries  Click a column heading in a pane to sort the entries by 
that column. 

Sizing Columns  Grab-and-drag the border of a column heading to in-
crease or decrease the width of the column. 

Programs Pane

The Programs pane displays the programs in the selected project and the 
distribution of their seed fields in the seed lists. Select a program to view 
its seed fields in the List pane and their synonyms in the Synonyms pane. 
You also select a program to view its source in the Source pane.

Lists Pane

The Lists pane displays the Working, Affected, and Clean lists for the 
program selected in the Programs pane. Click the appropriate tab to view 
a list. Create projects from a list as described in “Creating Projects in 
Change Analyzer” on page 9-15, and generate reports as described in 
“Generating and Exporting Change Analyzer Reports” on page 9-16.

Each tab and its corresponding report contains the following columns:

Tip: Use the Report Control option to restrict the columns dis-
played in the tab, as described in step 9 on page 9-12.
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• The Name column lists the seed fields or synonyms on the list.

• The Length column displays the length of the seed fields or syn-
onyms on the list.

• The Normalized Picture column displays the normalized picture of 
the seed fields or synonyms on the list.

• The Picture column displays the format of the seed fields or syn-
onyms on the list.

• The Value column displays the initial value of the seed fields or syn-
onyms on the list.

• The Comment field describes the basis for including the seed field 
or synonym on the list. Select an entry in the Lists or Synonyms pane 
and choose Comment in the Edit menu to open a dialog where you 
can modify the comment.

Applying a Search Filter to a List  To apply a search filter to a list, 
choose Apply Filter:To List in the File menu, then follow the instruc-
tions for performing searches in “Searching for Seed Fields in Change 
Analyzer” on page 9-13. 

Selecting Fields  Click a field on a list to select it. To select all the fields 
on a list, click the tab for the list and choose Select All in the Edit menu. 

To select fields based on search patterns, click the tab for the list and 
choose Select in the Edit menu. A Select dialog opens, where you can 
enter the search patterns. You can use wildcard patterns allowed in LIKE 
statements by Visual Basic for Applications (VBA)

To select a range of fields, hold down the Shift key, click the first field 
in the range, then click the last field in the range. To select fields that are 
not in a range, hold down the Control key, then click each field you want 
to select.

Viewing Source  Select a field to view its source in the Source pane.

Moving Fields between Lists  To move fields between lists, select the 
fields, then choose Move to List in the Edit menu. For background in-
formation, see step 6 on page 9-5.
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Removing Unused Fields from Lists  To remove fields that are declared 
but not used from a list, choose Remove Unused:From List in the File 
menu. 

Deleting Seed Fields from a List  To delete a seed field from a list, se-
lect the field and choose Delete in the Edit menu. You are prompted to 
confirm the deletion. Click Yes. 

Clearing Lists  Search results are added to any previous results in a list. 
To clear the previous results from the list, choose Clear:List in the File 
menu. To clear all the lists, choose Clear:All Lists in the File menu.

Synonyms Pane

The Synonyms pane displays the synonyms for the field selected in the 
Lists pane. Select synonyms as described for list fields in “Selecting 
Fields” on page 9-8. 

Viewing Source  Select a synonym to view its source in the Source pane.

Moving Synonyms to Lists  To move synonyms to a list, choose 
Find Synonyms in the File menu. The Find Synonyms dialog opens 
(Figure 9-4 on page 9-5), where you can select the list of seed fields to 
find synonyms for and the list to move the synonyms to.

Source Pane

The Source pane lets you browse the source code for the program select-
ed in the Programs pane and the field or synonym selected in the Lists or 
Synonyms pane.

Usage is similar to that for the HyperView tool. For HyperView usage 
information, see Analyzing Programs in the ATW document set.
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Setting Change Analyzer Options 
Change Analyzer options control seed field and synonym pattern search-
es and the amount of information displayed in the Affected Code report.

To set Change Analyzer options:

1 In the View menu, choose Options. The Change Analyzer options 
window opens (Figure 9-7).

Figure 9-7 Change Analyzer Options Window

2 In the Pattern Search group box, choose any combination of:

• Override status if you want the search results to override the 
current list assignment of a field. If you do not select this option, 
Change Analyzer applies the search results only to fields not yet 
assigned to a seed list.

• Refresh lists if you want the search results to replace fields in the 
target seed list. If you do not select this option, Change Analyzer 
adds the search results to the fields already assigned to the target 
list.
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3 In the Synonym Search group box, choose Override status if you 
want the search results to override the current list assignment of a 
synonym. If you do not select this option, Change Analyzer applies 
the search results only to synonyms not yet assigned to a seed list.

4 Choose Apply actions to selected programs if you want Change 
Analyzer to act only on the programs selected in the Programs pane.

5 In the Affected Code Report pane, specify in the Neighborhood 
Size combo box the number of lines of unaffected code you want the 
report to display above and below the line of affected code. (The line 
of affected code is displayed in bold in the report.) Then choose 
Show unused datanames if you want the report to include unused 
data fields. 

6 In the Synonyms group box, click Change. The Synonyms Options 
window opens (Figure 9-8).

Figure 9-8 Synonym Options Window

7 Choose any combination of:

• High-Affinity Operations if you want Change Analyzer to iden-
tify as synonyms data fields that have a high affinity to seed 
fields — such as those used in assignment and addition opera-
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tions. Then choose the types of high-affinity operations in the list 
box.

• Low-Affinity Operations if you want Change Analyzer to iden-
tify as synonyms data fields that have a low affinity to seed fields 
— such as those used in multiplication and division operations. 
Then choose the types of low-affinity operations in the list box.

• Same Memory Location if you want Change Analyzer to iden-
tify as synonyms data fields that share a memory location with 
seed fields. Then choose View all redefinitions to identify as 
synonyms all data fields that share a memory location with seed 
fields. If you do not select this option, Change Analyzer identi-
fies as synonyms only data fields that are exact redefinitions of a 
seed field — such as one declared with the same size and offset.

Click OK to dismiss the Synonyms Options window and return to 
the Change Analyzer Options window.

8 In the Report Control group box, click Edit. The Report Control Op-
tions window opens (Figure 9-9).

Figure 9-9 Report Control Options Window

9 In the Report Control group box, select the type of file you are ana-
lyzing in the drop-down, then choose the columns you want to be 
displayed in Change Analyzer lists and their corresponding reports. 
Click OK to dismiss the Report Control Options window and return 
to the Change Analyzer Options window.

Tip: You can restore the default option settings by clicking 
Change Analyzer Defaults, then choosing Restore Defaults 
in the drop-down menu. Choose Save To in the drop-down 
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menu to save the option settings to a file. Choose Load From 
in the menu to restore the option settings from a file.

10A Click Apply if you want to save your settings without dismissing the 
Options window. 

10B Click OK if you want to save your settings and dismiss the Options 
window. 

Searching for Seed Fields in Change Analyzer

The Change Analyzer search facility (Figure 9-2 on page 9-4) contains 
two tabs:

• The General tab opens the HyperView advanced search facility.

• The Change Analyzer tab opens a scoped version of the advanced 
search facility for Change Analyzer.

Ordinarily, the scoped version of the tool should be sufficient for most 
searches. If you are already familiar with the advanced search facility, 
however, you may want to use it instead of the scoped tool. For Hyper-
View usage information, see Analyzing Programs in the ATW document 
set.

Note: Change Analyzer returns only constants and literals found in 
the Procedure section of Cobol programs.

To search for seed fields:

1 In the File menu, choose Apply Filter: To List. The Change Ana-
lyzer Search window opens (Figure 9-2 on page 9-4).

2 In the Search window, click the Change Analyzer tab. The Change 
Analyzer tab displays a list of recognized search criteria. You can 
define a new criterion as described in step 3 on page 9-4. 

3 Select a criterion to edit its definition in the tabs in the righthand 
portion of the window. Each tab specifies a condition in the defini-
tion. The definition can consist of any combination of conditions. 

For each condition, enter a list of patterns you want to match, one 
pattern per line. Select:
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• Name Like to specify patterns that are like the name of the field 
you are searching for. 

• Name Not Like to specify patterns that are unlike the name of the 
field you are searching for. 

• Picture Like to specify patterns that are like the format of the 
field you are searching for. 

• Value Like to specify patterns that are like the initial value of the 
field you are searching for. 

You can use wildcard patterns allowed in LIKE statements by Visual 
Basic for Applications (VBA).

4 Select Use OR Connection Inside List if you want the patterns list-
ed in the tabs to be ORed. If you do not select this option, the patterns 
are ANDed.

5 Select Use OR Connection Between Lists if you want the condi-
tions defined in the tabs to be ORed. If you do not select this option, 
the conditions are ANDed.

6 Select Used Data Items Only if you want the search results to con-
sist only of fields that are used in the selected programs. If you do 
not select this option, search results include fields that are declared 
but not used.

7 In the Search in pane, click Name Like to specify a pattern that 
is like the name of the program or programs you want to limit the 
search to. You can use wildcard patterns allowed in LIKE statements 
by Visual Basic for Applications (VBA).

8 Click Find All to execute the search. Change Analyzer returns the 
seed fields for the selected criterion in the Working list and their syn-
onyms in the Synonyms pane. The results are added to any previous 
results.

Note: Tool bar usage in the Search window is identical to that for the 
HyperView advanced search facility. For HyperView usage 
information, see Analyzing Programs in the ATW document 
set.
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Creating Projects in Change Analyzer

You can create a project directly in Change Analyzer from the results 
of your analysis. The project contains only source files with fields in 
a Working, Affected, or Clean list. 

To create a project from a list:

1 In the File menu, choose Create Project:From List. The New 
Project dialog opens. Enter the name of the new project in the text 
field and click OK. The Change Magnitude window opens 
(Figure 9-10).

Figure 9-10 Change Magnitude Window

2 In the Change Magnitude window, select the Automatically calcu-
late change magnitude check box if you want Change Analyzer to 
set change magnitudes for the listed source files based on the ranges 
specified in the fields below the check box. The Change Analyzer 
settings will override any existing change magnitudes for the files. 

The fields below the check box contain default ranges for the 
available values: Small, Medium, Large, and Extra Large. Compare 
the number of fields in each source file listed in the Programs pane 
with the default ranges, then modify the ranges as necessary.

If you want Cobol source files with 6 to 10 fields in a list to have a 
Large change magnitude, for example, set the range for Medium to 
less than 6 and the range for Large to less than 11. When you are sat-
isfied with your choices, click OK. For more information on change 
magnitudes, see “Specifying the Change Magnitude for a Source 
File” on page 2-4.
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Generating and Exporting Change Analyzer Reports 

In the File menu, choose Report:Report to generate Change Analyzer 
reports:

• The Affected Datanames report (Figure 9-5 on page 9-6) lists the 
fields in the Affected list. In addition to the information displayed in 
the Affected list, the report displays the program that uses the field, 
the source file in which the field is declared, and the line and column 
numbers of the declaration. 

• The Possible Datanames report lists every field in the Working, 
Affected, and Clean lists. In addition to the information displayed 
in the Affected Datanames report, the Possible Datanames report 
displays the disposition of fields in seed lists. 

• The Clean Datanames report lists the fields in the Clean list. The 
report displays the same information as the Affected Datanames 
report. 

• The Affected Code report (Figure 9-6 on page 9-6) displays the 
source code for the fields in the Affected list in both the program
that uses the field and the source file in which the field is declared. 
The line of affected code is displayed in bold, surrounded by the 
number of lines of neighboring code you specified in step 5 on page 
9-11.

• The Metrics report displays the percentage of declarations and uses 
of affected fields in a program.

You can export Change Analyzer reports to a variety of standard formats. 
Choose Save on the report tool bar to export the report to HTML, Excel, 
RTF, Word, or formatted text.

Note: Excel is usually the best option if you need to manipulate the 
report or perform computations. For more information on ex-
porting reports, see Getting Started in the ATW document set.

You can also export a report to the ATW WebGen tool by clicking Cre-
ate WebGen Page in the File menu. All reports are exported to the page. 
The page is stored in the file \Workspace\Projects
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\Project\Webgen\Diagrammer\Main.htm. Click the hyperlink for a re-
port to view it in the browser. 

What’s Next?

That completes your tour of the ATW project analysis tools! Now you’re 
ready to start using the program analysis tools — collectively called Hy-
perView — to view programs interactively and perform program analy-
sis in stages. Analyzing Programs in the workbench documentation set 
describes HyperView.
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Glossary
Activity Log

The Activity Log is a chronological record of your activities in the 
current Asset Transformation Workbench (ATW) session.

ADABAS

ADABAS is a Software AG relational DBMS for large, mission-crit-
ical applications. 

Animator

Animator lets you step through the code displayed in a HyperView 
pane. You can choose program branches yourself, or have the anima-
tor choose them randomly.

API

API stands for application programming interface, a set of routines, 
protocols, and tools for building software applications.

applet

See Java applet.

Application Analyzer

Application Analyzer is a set of non-invasive interactive tools used to 
analyze and document legacy systems.
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Application Architect

Application Architect uses advanced algorithms to partition code into 
new components and perform Dead Code Elimination.

Application Namespace tool

The Application Namespace tool creates a conveniently organized 
dictionary that helps you navigate through your system’s terminology 
and modify it as necessary. 

Application Partitioner

Application Partitioner identifies legacy subsystems and partitions 
them into self-contained projects based on an analysis of repository 
contents.

Application Profiler

Application Profiler, consisting of WebGen and Profiler, generates a 
set of HTML views of a legacy application based on the object model 
created in a previous analysis.

AS/400

The AS/400 is a midrange server designed for small businesses and 
departments in large enterprises.

Asset Transformation Workbench (ATW)

Asset Transformation Workbench (ATW) is a suite of PC-based soft-
ware products for analyzing, re-architecting, and transforming legacy 
applications.

Batch Application Viewer

Batch Application Viewer performs low-level analysis of batch pro-
cesses.

batch refresh

The batch refresh feature lets you register and verify source files in 
batch mode. Other utilities packaged with the feature let you analyze 
application complexity, run WebGen, and, if you are licensed to use 
the Application Architect product, perform Dead Code Elimination. 

Bird’s Eye pane

The Bird’s Eye pane works with the HyperView Source pane to let 
you quickly identify the location of a code construct relative to the 
entire program.
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BMS

BMS stands for Basic Mapping Support, an interface between appli-
cation formats and CICS that formats input and output display data.

BSTR

BSTR is a Microsoft format for transferring binary strings.

business rule

A business rule is a named container that identifies and documents 
code segments according to their business function. Business rules en-
capsulate an application’s business logic, making the application eas-
ier to understand, document, maintain, and test.

Business Rule Manager

Business Rule Manager lets you generate business rules from code 
segments extracted manually from source or autodetected. 

Callie pane

The HyperView Callie pane displays a diagram that shows the flow of 
control between paragraphs or procedures in a program.

CDML

CDML stands for Cobol Data Manipulation Language, an extension 
of the Cobol programming language that enables applications pro-
grammers to code special instructions to manipulate data in a DMS 
database and to compile those instructions for execution. 

Change Analyzer

Change Analyzer identifies the class of data items used to perform a 
business function in a legacy application. Among other uses, it lets 
you answer the kinds of “What if?” questions posed in the recent past 
by the industry-wide changes for Y2K, Zip+4, and the Euro dollar: 
“What if I change the type of this variable, or the length of this field 
— what other fields will I also have to change?”

CICS

CICS stands for Customer Information Control System, a program 
that allows concurrent processing of transactions from multiple termi-
nals.
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Clipper

The HyperView Clipper tool lets you create lists of candidates for 
business rule extraction, event injection, and other tasks. Each list 
captures the results of a different stage of your analysis and serves as 
input for subsequent tasks.

Cobol

Cobol stands for Common Business-Oriented Language, a high-level 
programming language used for business applications.

COM

COM stands for Component Object Model, a software architecture 
developed by Microsoft to build component-based applications. COM 
objects are discrete components, each with a unique identity, which 
expose interfaces that allow applications and other components to ac-
cess their features.

complexity

A project’s complexity is an estimate of how difficult it is to maintain, 
analyze, transform, and so forth.

component

A component is a self-contained program that can be reused with 
other programs in modular fashion. 

Component Maker

The HyperView Component Maker tool lets you “slice out” compo-
nents from legacy applications — not only component executables but 
associated Cobol copybooks, PL/I includes, and Natural data areas as 
well.

computation-based component extraction

Computation-based component extraction lets you build a component 
that contains all the code necessary to calculate the value of a variable 
at a particular point in a program — the value of a DayOfTheWeek 
variable, for example, where it is used to populate a report attribute or 
screen.

Configuration Manager

Configuration Manager is a tool used to enable Asset Transformation 
Workbench (ATW) products and configure your workbench for the 
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tools, programming languages, legacy dialects, and character sets in 
use at your site.

construct

A construct is an item in the parse tree for a source file — a section, 
statement, condition, variable, or the like. A variable, for example, can 
be related in the parse tree to any of three other constructs — a decla-
ration, a dataport, or a condition. You view the parse tree for a source 
file in the HyperView Context pane.

Context pane

The HyperView Context pane displays the parse tree for the selected 
source file. The parse tree displays source code constructs — sections, 
paragraphs, statements, conditions, variables and so forth — in hier-
archical form, making it easy to locate code constructs quickly.

copybook

A copybook is a common piece of source code to be copied into many 
Cobol source programs. Copybooks are functionally equivalent to C 
and C++ include files.

CORBA

CORBA stands for Common Object Request Broker Architecture, an 
architecture that enables distributed objects to communicate with one 
another regardless of the programming language they were written in 
or the operating system they are running on.

CSD file

CSD stands for CICS System Definition. A CSD file is a VSAM data 
set containing a resource definition record for every resource defined 
to CICS.

database schema

A database schema is the structure of a database system, described in 
a formal language supported by the DBMS. In a relational database, 
the schema defines the tables, the fields in each table, and the relation-
ships between fields and tables.

dataport

A dataport is an input/output statement or a call to or from another 
program.
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DB/2

DB/2 stands for Database 2, an IBM system for managing relational 
databases.

DBCS

DBCS stands for double-byte character string, a character set that uses 
two-byte (16-bit) characters rather than one-byte (8-bit) characters.

DBMS

DBMS stands for database management system, a collection of pro-
grams that enable you to store, modify, and extract information from 
a database.

DDL

DDL stands for Data Description Language (DDL), a language that 
describes the structure of data in a database.

Dead Code Elimination

Dead code elimination is a type of component extraction that removes 
unused (“dead”) code from a legacy application.

decision resolution

Decision resolution lets you identify and resolve dynamic calls and 
other relationships that the parser cannot resolve from static sources.

Diagrammer

Diagrammer lets you view the relationships between the objects in a 
project interactively — programs, files, DDL, Java, screen maps, and 
more. These relationships describe the ways in which application 
objects interact. Compare Quick Diagrammer.

DMS

DMS stands for Data Management System, a Unisys database man-
agement software product that conforms to the CODASYL (network) 
data model and enables data definition, manipulation, and mainte-
nance in mass storage database files.

domain-based component extraction

Domain-based component extraction “specializes” a program based 
on the values of one or more variables. The specialized program is 
typically intended for reuse “in place” — in the original application 
but under new external circumstances.
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DPS

DPS stands for Display Processing System, a Unisys product that 
enables users to define forms on a terminal.

ECL

ECL stands for Executive Control Language, the operating system 
language for Unisys OS 2200 systems.

effort

Effort is an estimate of the time it will take to complete a task related 
to a project, based on weighted values for selected complexity met-
rics.

EJB

EJB stands for Enterprise JavaBeans, a Java API developed by Sun 
Microsystems that defines a component architecture for multi-tier 
client/server systems. 

EMF

EMF stands for Enhanced MetaFile, a Windows format for graphic 
images.

entity

An entity is an object in the repository model for a legacy application. 
The relationships between entities describe the ways in which the el-
ements of the application interact.

entry point isolation

Entry point isolation extracts a component that contains only the func-
tionality and data definitions required for invocation from the selected 
entry point. 

event injection

Event injection is a type of component extraction that adapts a legacy 
program to asynchronous, event-based programming models. 

Execution Path pane 

The HyperView Execution Path pane displays a hierarchical view and 
diagram of the conditions that determine the flow of control in a pro-
gram.
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external subroutine extraction

External subroutine extraction is a type of structure-based component 
extraction that replaces a single internal subroutine in a Natural pro-
gram with an external subroutine.

FCT

FCT stands for File Control Table (FCT), a CICS table that contains 
processing requirements for output data streams received via a remote 
job entry session from a host system. Compare PCT.

Flowchart pane

The HyperView Flowchart pane displays a diagram of the flow of 
control between statements in a paragraph or procedure.

Global Data Flow tool

The HyperView Global Data Flow tool performs low-level analysis of 
program data flows. 

HTML

HTML stands for HyperText Markup Language, the authoring lan-
guage used to create documents on the World Wide Web.

HyperView

HyperView is a set of program analysis tools that let you analyze leg-
acy programs interactively, by examining synchronized, complemen-
tary views of the same information — source, context, impacts, and so 
forth. 

IDL

IDL stands for Interface Definition Language (IDL), a generic term 
for a language that lets a program or object written in one language 
communicate with another program written in an unknown language.

IDMS

IDMS stands for Integrated Database Management System, a Com-
puter Associates database management system for the IBM main-
frame and compatible environments. 

Impact pane

The HyperView Impact pane displays a hierarchical view and diagram 
of the impact trace for a program variable. An impact trace describes 
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how data items interact with each other in a program — exchange val-
ues, use each other in computations, and so forth.

Impact Report pane

The HyperView Impact Report pane shows the flow of data from a 
startup item to every data item that would be affected by its modifica-
tion. The report is organized in hierarchical form according to the 
depth of the affected item.

IMS

IMS stands for Information Management System, an IBM program 
product that provides transaction management and database manage-
ment functions for large commercial application systems.

Java

Java is a high-level object-oriented programming language developed 
by Sun Microsystems.

Java applet

A Java applet is a program that can be sent with a Web page. Java ap-
plets perform interactive animations, immediate calculations, and oth-
er simple tasks without having to send a user request back to the 
server.

JavaBeans

JavaBeans is a specification developed by Sun Microsystems that de-
fines how Java objects interact. An object that conforms to this spec-
ification is called a JavaBean. 

JCL

JCL stands for Job Control Language, a language for identifying a job 
to OS/390 and for describing the job’s requirements.

JDBC

JDBC stands for Java Database Connectivity, a standard for accessing 
diverse database systems using the Java programming language. 

job

A job is the unit of work that a computer operator or a program called 
a job scheduler gives to the operating system. In IBM mainframe op-
erating systems, a job is described with job control language (JCL).
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job dependencies

Batch Application Viewer treats jobs as dependent if one writes to a 
dataset and the other reads from the same dataset. Occasionally, you 
may want to define dependencies between jobs based on other criteria 
— administrative needs such as scheduling, for example.

logical component

A logical component is an abstract repository object that gives you ac-
cess to the source files that comprise a component.

MFS

MFS stands for Message Format Service, a method of processing IMS 
input and output messages.

Missing Copybooks Resolution tool

The Missing Copybooks Resolution tool resolves undefined variables 
in missing copybooks for Cobol programs verified with the relaxed 
parsing option.

Model Reference pane 

The HyperView Model Reference pane displays the parse tree meta-
model in text and diagram form. 

name-based partitioning

Name-based partitioning is a partitioning algorithm that assigns 
source files to projects based on text matching of source file names 
with specified patterns.

Natural

Natural is a programming language developed and marketed by Soft-
ware AG for the enterprise environment.

object model

An object model is a representation of an application and its encapsu-
lated data.

object-oriented programming

Object-oriented programming organizes programs in terms of objects 
rather than actions, and data rather than logic.
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ODBC

ODBC stands for Open Database Connectivity, a standard for access-
ing diverse database systems.

orphan

An orphan is an object that does not exist in the reference tree for any 
startup object. Orphans can be removed from a system without alter-
ing its behavior.

Orphan Analysis tool

The Orphan Analysis tool lets you analyze and resolve orphans.

parser

The Asset Transformation Workbench (ATW) parser defines the ob-
ject model and parse tree for a legacy application.

parse tree

A parse tree defines the relationships among the constructs that com-
prise a source file — its sections, paragraphs, statements, conditions, 
variables, and so forth. 

PCT

PCT stands for Program Control Table, a CICS table that defines the 
transactions that the CICS system can process. Compare FCT.

PL/I

PL/I stands for Programming Language One, a third-generation pro-
gramming language developed in the early 1960s as an alternative to 
assembler language, Cobol, and FORTRAN.

PL/I Call Diagrammer

PL/I Call Diagrammer performs low-level analysis of PL/I programs. 
Use it to examine call flows for internal procedures that the 
Diagrammer is unable to model.

profile

Profiles are HTML views into a repository that show all of the analy-
sis you have done on an application. Profiles are convenient ways to 
share information about legacy applications across your organization.
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Profiler

Profiler is a Web server-based tool that offers company-wide access to 
profiles of any repository in your organization. It gives managers, 
business analysts, testers, and customer support personnel convenient, 
browser-based access to analyzed legacy code.

project

A project is a logical subdivision of a workspace. You might have a 
project for the batch portion of your application and another project 
for the online portion, for example. You can also use a project to col-
lect items for discrete tasks — all the source files affected by a change 
request, for example.

QSAM

QSAM stands for Queued Sequential Access Method, a type of 
processing that uses a queue of data records—either input records 
awaiting processing or output records that have been processed and 
are ready for transfer to storage or an output device.

Quick Diagrammer

The Quick Diagrammer tool lets you view relationships for selected 
objects only, rather than an entire project. Compare Diagrammer.

refactoring

Refactoring translates a program into a component with the same 
functionality and control flow, but a simpler syntax structure.

reference reports

Asset Transformation Workbench (ATW) offers three related reports 
that you can use to identify missing or unneeded program elements in 
application source: an unresolved report, an unreferred report, and a 
cross-reference report.

relationship

The relationships between entities in the repository model for a legacy 
application describe the ways in which the elements of the application 
interact. 

relationship-based partitioning

Relationship-based partitioning is a partitioning algorithm that as-
signs source files to projects based on the extent to which the source 
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files are related. If two source files reference the same copybook, for 
example, they can be regarded as “tightly related,” at least as com-
pared with source files that do not reference the same copybook.

relationship weight

A relationship weight determines the importance of that relationship 
in calculating the connection between source files in relationship-
based partitioning.

relaxed parsing

Relaxed parsing lets you verify a source file despite errors. Ordinarily, 
the parser stops at a statement when it encounters an error. Relaxed 
parsing tells the parser to continue to the next statement.

repository

A repository is a database of program objects that comprise the model 
for a workspace.

Repository Browser

The Asset Transformation Workbench (ATW) Repository Browser 
displays the contents of the current workspace.

Resource Retriever

The Resource Retriever tool lets you identify and restore missing 
CICS file connectors and transactions in file control tables (FCT) and 
program control tables (PCT) for Cobol and PL/I programs.

Rules pane 

The HyperView Rules pane lets you create business rules from code 
segments extracted manually from source or autodetected. You can 
also create business rules from candidates listed in Clipper.

schema

See database schema.

scope

The scope of a diagram determines the objects and relationships it dis-
plays. See Diagrammer.

seed field

A seed field is the object of a Change Analyzer search for the class of 
data items that need to be changed.
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Source pane 

The HyperView Source pane displays view-only source code for the 
selected file and included files. 

SQL

SQL stands for Structured Query Language, a standard language for 
relational database operations

structure-based component extraction

Structure-based component extraction is a type of component extrac-
tion that builds a component from a range of inline code — Cobol 
paragraphs, for example. 

synonym

A synonym is a data field whose value is related to the value of the 
matched seed field — a field whose value is assigned by a MOVE or 
REDEFINE statement, for example.

system program

A system program is a generic program — a mainframe sort utility, for 
example — provided by the underlying system and used in unmodi-
fied form in the legacy application.

TIP

TIP stands for Transaction Processing, the Unisys real-time system 
for processing transactions under Exec control.

token

In the Application Namespace tool, a token is an element in a program 
identifier delimited by a hyphen (-) or underscore (_). In the identifier 
WS01-CUST-FIELD, for example, there are three tokens: WS01, 
CUST, and FIELD.

transaction

A transaction is a sequence of information exchange and related work 
(such as database updating) that is treated as a unit for the purposes of 
satisfying a request and for ensuring database integrity.

Unknown Statements Resolution tool

The Unknown Statements Resolution tool resolves incorrect or unsup-
ported statements in Cobol programs verified with the relaxed parsing 
option.
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User Interface tool

The User Interface tool lets you analyze the interaction between lega-
cy screens and program logic, and generate an HTML or Java GUI 
based on the interaction.

VALTAB

VALTAB stands for Validation Table, which contains the information 
the system needs to locate, load, and execute transaction programs. 
See also TIP.

VSAM

VSAM stands for Virtual Storage Access Method, an IBM program 
that controls communication and the flow of data in a Systems Net-
work Architecture network.

WebGen

WebGen generates HTML views of the repositories on your worksta-
tion. You can publish the views to Profiler, where they can be accessed 
by any member of your organization with a browser. 

workspace

A workspace is a named container for an application or a portion of an 
application. Workspaces can be divided into projects.

XML

XML stands for Extensible Markup Language, a specification for cre-
ating common information formats. 
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