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....................................................................................OLAP Retail LAB

Objectives

Create OLAP Models and Metaoutlines including hybrid Dimensions, Attribute Dimensions, Drill 
Through  Reports and load data on OLAP cubes.

Exercises 

ID Exercise Description Required ? Model/Metaoutline Name OLAP 
Application

OLAP 
Database

Estimated
Time 

OLR1 Data Preparation Not Required N/A N/A N/A N/A

OLR2 Create Base Retail Model Required Retail Base Model Retail N/A 15 Minutes

OLR3 Create Base Retail Metaoutline Required Retail Base Metaoutline Retail Basic 12 Minutes

OLR4 Create Retail/Basic OLAP Cube Required Retail Base Metaoutline Retail Basic 3 Minutes

OLR5 Create Drill-Through Reports Optional Retail Drill-Through 
Metaoutline

Retail DrillT 5 Minutes

OLR6 Create Hybrid Cube Optional Retail Hybrid Metaoutline Retail Hybrid 3 Minutes

ITSO iSeries Technical Forum
BL04
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....................................................................................OLAP  Process Flow 

Fact

Product

Star Schema

DB2 OLAP 
Integration 

Server

DB2 OLAP
ServerOLAP 

Cube

Start 
Calculation

Access 
Source

Build 
Model

Build 
Metaoutline

OLAP
Metaoutine

Generate 
ReportsFront End 

Tools

OLAP
Model

Analyze 
the Data

Trans. 
Type

Market

Time

Build  Outline
Load Data

Access 
Cube

Scenario

F03BL04iSeries OIS_OLAP_LabAdvanced.PRZ 2



IBM Copyright 2003Data Management Software DB2

....................................................................................
Files Retail

LAB Components

LAB Table Name Library Description

DB2/400 Product BIDEMO Retail Product Master

Channel BIDEMO Retail Channel - Internet/Store/Call Center ....

Fact_Table BIDEMO Retail Fact Table

Generic_Scenarios BIDEMO Generic Scenarios Table - Actual/Budget/Prior Year

Generic_TIME BIDEMO Generic Time dimension down to months

Generic_Market BIDEMO Generic Market dimension, region/state/city

Note: x below is team number

OIS OLR2x - Retail Base Model DB2OLAP OLAP Base  Model for Retail

OLR3x - Retail Base Metaoutline DB2OLAP OLAP Base Metaoutline  for Retail

OLR5x - Retail Drill-Through Metaoutline DB2OLAP OLAP Drill-Through  Metaoutline  for Retail

OLR6x - Retail Hybrid Metaoutline DB2OLAP OLAP Hybrid  Metaoutline  for Retail

DB2 OLAP Basic RETAILx Basic retail cube without drill through or Hybrid

Drillt RETAILx Basic cube with drill through to DB2/400 retail data

Hybrid RETAILx Basci cube with Hybrid Analysis  to DB2/400 data

F03BL04iSeries OIS_OLAP_LabAdvanced.PRZ 3



IBM Copyright 2003Data Management Software DB2

....................................................................................OLR2 - Starting DB2 Olap Integration Server (OIS)
Click on 
Start —> Programs —> IBM DB2 OLAP Server 8.1 - iSeries—> IBM DB2 OLAP Integration Server —> Desktop.

 The Login window is displayed:

Connection Information

Integration Server Services
Server  =  Computer hostname
Catalog = Computer hostname
User Name = teamx
Password = password

Essbase OLAP Server
Server  = Computer hostname
User Name = teamx
Password = password
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....................................................................................OLR2  - Creating a New OLAP Model 
On Welcome Panel, New Tab,

Select  OLAP Model  and 
Click on Open button and the Data Source window will appear

Note: If the screen above does not appear to you, then do the following:
.From the Main Menu, Select File > New   or,  Press Ctrl+N
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....................................................................................OLR2  - Connecting to Source Database
On Data Source Panel

Select Computer Host Name  from the Data Source drop-down list
Use your team user name and password
Click on OK button and the Integration Services Console will appear.

Note: Data Source points to the iSeries with the relational Source 
Database that contain all sources tables i.e. Fact table, Dimension 
tables.  Libraries available from the data source system are based on the 
job description used to start the Integration Server.
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....................................................................................
Left Panel - Source Data Information

Contain libraries and database objects
 Tables names, views, columns names, schemas

Libraries listed are from the OIS server job description

Right Panel - Work Area to Design Model
Drag and drop tables into this area
Create dimension and accounts
Link  the dimensions to the Fact Table

Define Joins, Hierarchies, Transformations

OLR2  -  OIS Data Model Console Editor
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....................................................................................OLR2  - Base Retail OLAP Model
Sample Final Model to be created
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....................................................................................OLR2  - Creating the Account Dimension (Measures) 

The base table to create the Accounts Dimension is the Fact_Table. 

From the left frame drag the table 
BIDEMO.FACT_TABLE and drop it into the 
right frame 

Click on No to not add the Time Dimension 

Click on Yes to add an Account Dimension

Renaming the Accounts dimension to Measures:
Double Click on the Accounts dimension to open 
the properties dialog box
In the General tab, in the Name field, change 
Accounts to Measures and click on OK

Expanding Column Names 
On empty area on the right side panel 
Click with the Right mouse button

Select View all Columns

Changing Columns Properties on Measures
Select the Accounts table object,
Press Double Click

Follow instructions on next page....
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....................................................................................OLR2  - Changing Columns Properties on Measures
In order to provide a clean dimension for the metaoutline, hide the non-used fields. 

1) Hidding non-used fields on Measures:
In the Table Properties window, go to the Columns tab
Select the following columns:

CHANNEL_ID
MARKET_ID
PRODUCT_KEY
SCENARIO_ID
TIME_ID

Click on Hide button
2) Renaming Members

Select the  member OPENING_INVENTORY
Edit and Rename to  OPENING INVENTORY

Select the  member ENDING_INVENTORY

Edit and Rename  to  ENDING INVENTORY
Click on Close button

       

Go to create time dimension
 on next page....
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....................................................................................OLR2  - Creating the Time Dimension 

From the left frame drag the table GENERIC.TIME and,
 Drop it into the right panel 
Click on OK to add the dimension

Show Columns
Right click on new TIME dimension
Select View Columns

Switch to Joins mode
Click on Joins mode 

Connect TIME table to the FACT_TABLE
Link the  GENERIC.TIME table to the FACT_TABLE
Enter  Time for Name: 
Select the Time for Dimension Type 

Click on OK

Adding a Join key
Select TIME_ID column on both TIME  and  
FACT_TABLE  tables
Click on Add to add a join and, 
Click on Close to accept it
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....................................................................................OLR2  - Defining the Time Hierarchy 
Double click on Generic_Time dimension (to access the dimension Properties).
Select the Hierarchies tab.
Click Add... push button. The Edit Hierarchy window opens.
Type Quarter, Month Hierarchy in the Name field text box
In the left pane, expand the Generic_Time tree.

Double Click on QUARTER
Double Click on MONTH_ABREV

Select Generic_TIME.MONTH_ABREV on the right pane and,
Click Transform push button.

Go to Prefix/Suffix tab.
In the Prefix pane, select None radio button
Click OK.

Click on View Sample push button to preview results
      (not currently working as designed on iSeries)

Click OK and click OK again to close the Dimension Properties window.
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....................................................................................OLR2  - Creating the Product and Product Type Dimension

1) Defining the Product  Dimension
Drag and Drop the  BIDEMO.PRODUCT table to the right frame

C lick on OK to add the dimension
Switch to Joins mode (if not in Joins mode yet)
Join the  PRODUCT table to the FACT_TABLE

Link the PRODUCT  table to the FACT_TABLE
Click on OK

Adding a Join key
Select PRODUCT_KEY  on both PRODUCT and FACT_TABLE  tables
Click on Add to add a join and, 
Click on Close to accept it

2) Defining the Product Type Attribute Dimension

Right click on PRODUCT 
Select View Columns option

Right click  on PRODUCT table and,
Select Properties option

Select the Columns tab
Select the field PRODUCT_TYPE and,

 Click on Attribute
Look on the attribute column to make sure  there is a 'Y' 
Click on Close
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....................................................................................OLR2  - Defining the Product Hierarchy 
Select PRODUCT dimension and, Double click on it (to open the properties panel)
Select the Hierarchies tab and click on Add

Type Product Group, Product Hierarchy in the Name field text box
Double Click on PRODUCT_GROUP_ID
Double Click on PRODUCT_ID

Select PRODUCT.PRODUCT_GROUP_ID on the right pane and,
Click Transform push button.

Go to Prefix/Suffix tab.
In the Custom Prefix field (in the Prefix pane), type PG

Click OK.
 Click on View Sample push button to preview results
Click on OK twice to close the Dimension Properties window.
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....................................................................................OLR2  - Creating the Scenario and Channel Dimensions 

1) Creating the Scenario Dimension
From the left frame drag the table BIDEMO.GENERIC_SCENARIOS and  Drop it into the right frame 

Click on OK to add the dimension
Switch to Joins mode (if not in Joins mode yet)
Link the  SCENARIO  table to the FACT_TABLE

In the Name text box type SCENARIO for the dimension name
Select the Default for Dimension Type 
Click on OK

Select SCENARIO_ID  column on both SCENARIO and  FACT_TABLE  tables
Click on Add to add a join and, 
Click on Close to accept it

2) Creating the Channel Dimension
From the left panel drag the table BIDEMO.CHANNEL and  Drop it into the right panel 

Click on OK to add the dimension
Switch to Joins mode (if not in Joins mode yet)
Link the  CHANNEL  table to the FACT_TABLE

Select the Default for Dimension Type  and Click on OK
Select CHANNEL_ID  column on both CHANNEL and FACT_TABLE  tables

Click on Add to add a join and, 
Click on Close to accept it
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....................................................................................OLR2  - Creating the Market Dimension 
1)Defining the MARKET Dimension

From the left panel drag the table BIDEMO.GENERIC_MARKET and  Drop it into the right panel 
Click on OK to add the dimension

Switch to Joins mode (if not in Joins mode yet)
Link the  MARKET table to the FACT_TABLE

In the Name text box type MARKET for the dimension name
Select the Default for Dimension Type and click on OK

Select MARKET_ID  column on both MARKET and FACT_TABLE  tables
Click on Add to add a join and, Click on Close to accept it

2)Defining the MARKET hierarchy
Double click on MARKET dimension

Select the Hierarchies tab
Click on  Add  to add a new hierarchy
Type Region, State, City Hierarchy on Name field text box
Expand the MARKET tree

Double click on REGION > STATE > CITY
Click on View Sample push button to preview results
Click OK .Click OK again to close the Dimension Properties window.

3) Defining the Market Type Attribute Dimension
Right click on MARKET 

Select View Columns option
Right click  on MARKET  table and Select Properties option
Select the Columns tab
Select the field MARKET_TYPE and, Click on Attribute
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....................................................................................OLR2  - Validate and Save the Model
Verifying errors in your model

From the File Main Menu Bar
Select Verify to check errors on your data model
Click on OK

Saving the model
From the File Main Menu Bar, Select File  > Save As..

Type OLR2xx - Retail Base Model  in the Olap Model Name field
Click on OK
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....................................................................................OLR3  - Creating a New OLAP Metaoutline 
From the File Main Menu Bar

Select  New...  (or press CTRL+N)

On  the  Welcome pane, New Tab
Select OLAP Metaoutline
Select OLR2xx -  Retail Base Model from the drop-down list
Click on Open push button
If required, Login with Database Information (Data Source, Userid and Password) 
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....................................................................................
Left Frame - Dimension Model

Contain Dimensions Objects
 Dimensions, Hierarchies,  Members

Contain Connection Information

Right Frame - Work Area to Design Metaoutline
Drag and drop D imensions Objects on this area

Dimensions, Hierarchies,  Members
Create new objects

Dimensions, Hierarchies,  Members

OLR3  - Metaoutline Console Editor

Menu Bar
Connections to Catalog and DB2 OLAP Server 
Edit Drill-Through Reports
Create Outlines, Member Load, Data Load
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....................................................................................OLR3  - Sample Retail Base Metaoutline

The following is the metaoutline that you need to create:
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....................................................................................OLR3  - Creating the Measures Dimension 
1) Adding the Measures Dimension 

Drag the Measures dimension from the left frame and drop it into 
the right frame
Right click on Measures and select Properties. 

Go to the Member Info tab

Change the Data Storage to (~) Label Only

2) Creating a Profit consolidation member
On the right frame click on Measures and then do the following:
From the Edit menu, select Add Member as Child…
Type Profit for new member's name and press enter.
Right click on Profit and select Properties. 
Go to the Member Info tab
Change the Data Storage to Dynamic Calc
Click OK.
Create two children members for Profit member:
Create a member Margin and,

Define Data Storage: Dynamic Calc
Create a member Total Expenses

Define Data Storage: Dynamic Calc
Define Consolidation: (-) Subtraction

Drag and Drop the COGS member onto Margin

Define Consolidation: (-) Subtraction
Drag and Drop the SALES member onto Margin
Drag and Drop the MARKETING, MISC and PAYROLL members 
onto Total Expenses
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....................................................................................OLR3  - Creating the Measures Dimension   (continued)
3) Creating the Inventory consolidation member

On the right frame click on Profit and then do the following:
From the Edit menu, select Add Member as Sibling…

Type Inventory for new member's name and Click OK.
Right click on Inventory and select Properties. 
Go to the Member Info tab and change:

 Data Storage to Label Only
 Consolidation to ~ (ignore)

On the left frame select  the members (use CTRL key for multiple selections)
ADDITIONS, ENDING INVENTORY, OPENING INVENTORY

Drag and Drop them  onto Inventory ( right frame)
On the right frame select  the members (use CTRL key for multiple selections)

ADDITIONS, ENDING INVENTORY, OPENING INVENTORY
Right click  and select Properties. 

Define Consolidation:  ~ (ignore)

4) Adding a formula to  Open Inventory member

On the right frame select  Properties for the member  Inventory
Go to the Formulas  tab and type the following:

      IF(NOT @ISMBR(Jan))"Opening Inventory" = @PRIOR("Ending Inventory");ENDIF;
"Ending Inventory" = "Opening Inventory" +  Additions - Sales;

Click on  Verify  push button to check syntax
     The member Jan does not exist on the metaoutline yet, so Ignore the message:

         (line 1): unknown member name [Jan] in function [@ISMBR]
Click on  OK
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....................................................................................OLR3  - Creating the Measures Dimension   (continued)
 5) Creating the Ratios consolidation member

On the right frame click on Inventory and from the Edit menu, select Add Member as Sibling…
Type Ratios for new member's name and Click OK.
Right click on Ratios and select Properties. 
Go to the Member Info tab and change:  Data Storage to Label Only

 Consolidation to ~ (ignore)
Create two members  as children  for the  Ratios member. Use the following information:

Member Name: Margin %
        Data Storage: Dynamic Calc 

Two Pass Calculation: Two Pass Calculation
Formula: Margin % Sales;

Member Name: Profit %       
        Data Storage: Dynamic Calc 
        Two Pass Calculation: Two Pass Calculation     
        Formula: Profit % Sales;
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....................................................................................OLR3  - Creating  Time, Scenario and Channel Dimensions

1) Adding the Time Dimension 
On the left frame expand the Time dimension model.
Drag the member  Quarter, Month Hierarchy and drop it into the right frame
On the right frame select  the member Generic_TIME 

Change the Name: to TIME 
Change the Data Storage to Dynamic Calc  

On the right frame select  the members TIME.QUARTER
Change the Data Storage to Dynamic Calc

2) Adding the Scenario Dimension 
On the left frame expand the Generic_Scenarios  dimension model.
Drag  the member SCENARIO_NAME and drop it into the right frame
On the right frame select Properties for the member Generic_Scenarios

Change the Name: to Scenario
Change the Dimension Storage  to Dense

3) Adding the Channel Dimension 
On the left frame expand the Channel  dimension model.
Drag  the member  CHANNEL.CHANNEL_DESCRIPTION
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....................................................................................OLR3  - Creating the Product  and Product Type Dimensions
1) Adding the PRODUCT Dimension 

On the left frame expand the Product dimension model.
Drag the member  Product Group, Product Hierarchy and drop it into the right frame
On the right frame 
Select  the  Properties for the member PRODUCT.PRODUCT_GROUP_ID

Go to the Member Info tab and 
On the  Alias  drop-down list, select  PRODUCT_GROUP_DESC
Click on OK

Select  the  Properties for the member PRODUCT.PRODUCT_ID
Go to the Member Info tab and 
On the  Alias  drop-down list, select PRODUCT_DESC
Click on OK

2) Adding the Product Type  Attribute Dimension 
On the left frame, expand the Product  >  Expand  Attributes

Drag the member  PRODUCT.PRODUCT_TYPE 
Drop it into the right frame On the right frame 
Select  the  Properties for the member PRODUCT_TYPE
On the General tab,  On the Name  text field Type PRODUCT TYPE

 Click on OK
Select  the  Properties for the member PRODUCT.PRODUCT_TYPE

On the General tab, for  Association  
Select the  By Level radio button
Select 0 (zero) on the drop-down list
 Click on OK
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....................................................................................OLR3  - Creating the Market and Market Type Dimensions
1) Adding the MARKET Dimension 

 On the left frame expand the MARKET dimension model.
Drag the member  Region, State, City Hierarchy and drop it into the right frame
Select  the  Properties for the member Generic_Market

On the General tab,  On the Name  text field Type Market,  Click on OK

2) Adding the Market Type  Attribute Dimension 
On the left frame, expand the MARKET  >  Expand  Attributes

Drag the member  GENERIC_MARKET.MARKET_TYPE 
Drop it into the right frame On the right frame 
Select  the  Properties for the member MARKET_TYPE
On the General tab,  On the Name  text field Type Market Type,  Click on OK

Select  the  Properties for the member MARKET.MARKET_TYPE
On the General tab, for  Association  

Select the  By Level radio button
Select 0 (zero) on the drop-down list
 Click on OK

3) Verifying and Saving the Metaoutline
From the File Main Menu Bar

Select Verify to check errors on your data model
Click on OK

From the File Main Menu Bar, Select File  > Save 
Type OLR3xx - Retail Base  Metaoutline  in the Olap Model Name field
Click OK
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....................................................................................OLR4  - Creating the Retail/Basic OLAP Cube
From the Outline menu bar, 

Select Member and Data Load. 
On the Essbase Application and Database window:

Type Retailx on Application Name field
Type Basic on Database Name field

Select the Use Default Calc Script radio button
Leave all other default options and click on Next push button
Accept the defaults values for Schedule options and click on Finish push button
 You should get similar results:
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....................................................................................OLR5  - Creating the  Drill Through Report
1) Creating a new Metaoutline

If not open, then open the OLR3xx - Retail Base Metaoutline
SAVE the metaoutline OLR3xx - Retail Base Metaoutline AS  OLR5xx - 
Retail Drill Through  Metaoutline
Remove ( delete )  the Dimension  Market Type 
On the right  frame, expand the Market   Dimension

Right Click on  GENERIC_MARKET.STATE  member
 Select Build Multidimensional Down to Here

2) Creating the Drill-Through Report
From the Edit menu, Select the  Drill-Through Reports.. 

Click on  Add  push button
Select Report 1 and click on Edit
Type Product Sales  Report on  Name  field,
Click on OK

3) Defining the Intersection Level
Select OLAP Intersection level  for Product  Sales Report 

Click on Add push button
Expand the TIME dimension members

Move  ( > )  to the rigth frame:  GENERIC_TIME.MONTH_ABREV 
Expand the SCENARIO dimension members

Move  ( > )  to the right frame:  
GENERIC_SCENARIOS.SCENARIO_NAME

Expand the MARKET dimension members
Move  ( > )  to the right frame:  GENERIC_MARKET.STATE

Click on OK
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....................................................................................OLR5 - Creating the  Drill Through Report (continued)
4) Defining the Drill-Through Columns

Select Drill-Through Report Columns for Product  Sales Report
Click on Add push button

Expand the MARKET table columns
Move  ( > )  to the rigth frame,   REGION

                                                       STATE
                                                       CITY

Expand the PRODUCT table columns
Move  ( > )  to the rigth frame: PRODUCT_GROUP_DESC 

                                                     PRODUCT_DESC
                                                     PRODUCT_TYPE 

 Expand the FACT_TABLE columns
Move  ( > )  to the rigth frame:  TRANSDATE      

                                                       SALES
                   

Click on OK

5)Defining a Sort Order for the Report 
Click on Sort Order  push button
Move  ( > )  to the rigth frame,  the fields: MARKET.REGION  

                                                                       MARKET.STATE
                                                                       MARKET.CITY
                                                                       PRODUCT.PRODUCT_GROUP_DESC
                                                                       PRODUCT.PRODUCT_DESC
                                                                       FACT_TABLE.TRANSDATE

Click on OK  and Click on Close
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....................................................................................OLR5  - Creating the  Drill Through Report (continued)
6) Creating the Retail/Drill OLAP Cube

Save the metaoutline OLR5xx - Retail Drill-Through Metaoutline
From the Outline menu bar, 

Select Member and Data Load. 
On the Essbase Application and Database window:

Type Retailxx on Application Name field
Type DrillT on Database Name field

Select the Use Default Calc Script radio button
Leave all other default options and click on Next push button
Accept the defaults values for Schedule options and click on Finish push button
 You should get similar results:
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....................................................................................OLR6  - Creating Hybrid OLAP Cubes
1) Creating a new Metaoutline

If not open, then open the OLR3xx - Retail Base Metaoutline
SAVE the metaoutline OLR3xx - Retail Base Metaoutline AS  OLR6xx - Retail Hybrid  Metaoutline
Remove ( delete )  the Dimension  Product Type 
Remove ( delete )  the Dimension  Market Type

2) Creating the Hybrid Dimension
On the right  frame, expand the MARKET   Dimension

Select  the member GENERIC_MARKET.STATE and,
Select the option Build Multidimensional Down to Here

On  the member GENERIC_MARKET.CITY and,
Select the Enable Hybrid Analysis  Down to Here
 Select  the Transformation, and
 On  the Replace tab, Spaces frame
Deselect the Drop Leading/Trailing Spaces
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....................................................................................OLR6  - Creating Hybrid OLAP Cubes (continued)
3) Creating the Retail/Hybrid OLAP Cube

Save the metaoutline OLR6xx - Retail Hybrid Metaoutline
From the Outline menu bar, 

Select Member and Data Load. 
On the Essbase Application and Database window:

Type Retailx on Application Name field
Type Hybrid on Database Name field

Select the Use Default Calc Script radio button
Leave all other default options and click on Next push button
Accept the defaults values for Schedule options and click on Finish push button
 You should get similar results:
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