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Lab Objective
In this lab you will learn how to use some of the features available in the iSeries Access for
Web customization function.  In particular, you will learn how to manage different homepage
content for different users.  The labs will customize home pages for a make-believe boat
company called Access for Water.

Before starting the lab exercises, make sure you have read the Lab Instructions
document.  Information contained in that document will be used in the lab tasks.
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Task 1: Changing the home page and template files
ISeries Access for Web provides the following default home page and template files:

/QIBM/ProdData/Access/Web2/html/homepage.html
/QIBM/ProdData/Access/Web2/html/template.html

NOTE:  You should not modify the files in ProdData or create new files in this directory tree.
The /QIBM/ProdData tree is intended for product files only.

The home page file is the page that is displayed when you access
http://<system>/webaccess/iWAHome.  The template file contains the header and footer
displayed on every page.   The header is displayed before the iSeries Access for Web
content and the footer is displayed after the content.  A customized template file must
include the tag %%CONTENT%%.  When the page is displayed, this tag is replaced with
the iSeries Access for Web content.  

Follow these steps to copy the new home page file and template file to a new directory.

1. Open a browser session.  Open the iSeries Access for Web Home URL from
the Lab worksheet section of the lab instructions package.  Sign on to the
iSeries using the iSeries User ID and iSeries Password from the lab
instructions.

2. You should see the default iSeries Access for Web home page.  Click on the
Main Page link.

3. Click the Files navigation tab on the left side of your browser window.
4. Click the Browse files link.  A new browser window will be opened displaying a

tree view of the IFS directory structure.
5. The left pane of the window contains a list of directories.  Scroll down and click

the twisty (arrow) next to the walab directory to expand its contents.
6. Click on the homepage directory that is displayed under the walab directory.
7. The right pane of the window is updated with the contents of the home page

directory.  Scroll down until you find homepage.html.  Click the Copy link for
homepage.html.

8. In the Copy to field, enter /walab/homepage/waxxdir/homepage.html, and
click the Copy File button. (where xx is your team number)  

9. Scroll down the right pane again until you find template.html.  Click the Copy link
for template.html.

10. In the Copy to field, enter /walab/homepage/waxxdir/template.html, and
click the Copy File button.  (where xx is your team number)

11. Close the Browse Files window.
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In this section, you will change the customization settings for WAxxGROUP to use the
Access for Water template file.  The group WAxxGROUP contains the users WAxx
and WAxxADM.

1. In the iSeries Access for Web browser window, click the Customize navigation
tab on the left side of the window.

2. Click the Selected profile link.
3. Enter a group profile of WAxxGROUP (where xx is your team number) and click

the Customize Profile button.
4. Click on the General category.
5. In the Template HTML file policy field setting, enter

/walab/homepage/waxxdir/template.html (where xx is your team number) into
the setting field.

6. To prevent WAxxGROUP from accessing the Navigation bar, select Hide from
the dropdown list in the Setting column of the Navigation bar policy field setting.

7. Click the Save button.
8. You should now see the new look provided by the template file.

Follow the next steps to change the default home page to a new page that has been
tailored for our boat company.

1. Click on the General category.
2. In the Home page HTML file policy field setting, enter

/walab/homepage/waxxdir/homepage.html (where xx is your team number)
into the setting field.

3. To allow us to navigate for the rest of this lab, we need to turn the Navigation bar
back on temporarily.  Select Show from the dropdown list in the Setting column
of the Navigation bar policy field setting.

4. Click the Save button.

Follow the steps below to see the new home page.

1. Open a new browser session.  Open the iSeries Access for Web Home URL
from the lab worksheet section of the lab instructions.  Sign on to the iSeries
using either WAxx or WAxxADM, and the iSeries Password value from the lab
worksheet.

2. You should now see the Access for Water home page. 
3. We have put a Main Page link at the top of the page to allow for navigation

during the lab.  This typically would not be done in a real world environment
where you are trying to restrict the functions a user sees.

4. Close this browser window. 
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Task 2:  Adding a Boats database request to the home
page

As you can see the boat home page isn’t complete.  Right now, WAxx and WAxxADM
cannot do anything on the home page.  In this task, and the following tasks, we will be
adding useful links to the home page called Access for Water. 

    
The first section we will complete is the Service section.  In the Service section, there
are three links that point to invalid resources.  In this section you will update the home
page file to include the correct URLs to allow the users access to certain functions.  You
will also add another group of links that will only be allowed by specified users.

The first link you will update will allow the customer to see all the boats listed in the boat
table.  Follow the steps below to create an iSeries Access for Web database request,
and add the URL for that request to the “Access for Water” home page.

1. In the browser session that is running the default iSeries Access for Web home
page, click the iSeries Access for Web Main Page link (upper left side of page).

2. Click the Database tab in the iSeries Access for Web navigation bar.
3. Click the Run SQL link.
4. In the SQL Statement text box, enter SELECT * FROM BOATS.BOATS
5. In the SQL Output --> Type dropdown dialog, select Hypertext Markup

Language (.html).
6. Click the Run SQL button.  If the SQL request runs successfully, click the Back

button in the browser session window to return to the Run SQL page.
7. Click the Save Request button.
8. In the Request name field, type waxx_request (where xx is your team number).
9. In the Description field, type waxx All Boats.
10. Select the Replace if already exists checkbox.
11. Click the Save Request button.
12. Click the My requests link.
13. Click the Create Shortcut link for the waxx_request request.
14. In the Shortcut name field, type waxx_public (where xx is your team number).
15. Click the Create Shortcut button.
16. Click the Back link.
17. Click the Run link for the waxx_public request.
18. The request will run and the boat data will be displayed in the browser session.  
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19. Now highlight (select) part of the URL request.  Just highlight (select) everything after
http://<server name>.  Don’t highlight (select) http://<server name>.  Now select
the Edit pulldown, and select the Copy option.  Or just hit Ctrl+C keys with part of
the URL request highlighted (selected).  The URL will look similar to
this:
/webaccess/iWADbExec/sqlOutput.html?request=waxx_public&access=*PUBLIC

20. Click the browser Back button.
21. Now we need to modify the home page to include a link to the request that was just

created and run.  Click the Windows Start button, select the Run... Option.  In the
Open field, type...

WORDPAD  C:\WALAB\HOMEPAGE\WADIR\HOMEPAGE.HTML

22. Search for text similar to...
<!-- ***************************  -->
<!-- Add list of Services here    -->
<!-- ***************************  -->

23. Underneath this text, there are a couple of html statements.  In the first statement
listed you will need to replace the ServiceLink1 with the URL address that was
copied above in step 19.  Highlight (select) the ServiceLink1, select the Edit
pulldown menu, and select the Paste option to paste in the URL address.  Do not
remove the double quotes.  You should have a line that looks like this:

<a
href="/webaccess/iWADbExec/sqlOutput.html?request=waxx_public&access=*PU
BLIC">View available boats</a>

          Note: Parameter order may be different than what is shown above.  This is OK.

24. If you want to add the title Available Boats to the web page, add the parameter
&caption=Available%20Boats to the end of the URL address.  If you add the title
then your html statement should look like this

<a
href="/webaccess/iWADbExec/sqlOutput.html?request=waxx_public&access=*PU
BLIC&caption=Available%20Boats">View available boats</a>

25. Click the File pulldown menu and select the Save option to save the changes.
Close the Wordpad window.

26.  In the browser session, click the Files tab in the navigation bar.  Click the Browse
files link. 

27. In the left pane of the Browse files window, expand the walab directory, expand the
homepage directory, select the waxxdir directory (where xx is your team number).
The right pane should be updated with the files that exist in the waxxdir directory.
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28. Scroll down the right pane to the Copy Files to Server section.  In the File field, type
C:\WALAB\homepage\wadir\homepage.html, select the Replace file checkbox,
click the Copy File button.

29.  Close the Browse Files window.
30.  In the upper left, at the top of the Access for Web navigation bar, select the My

Home Page link.  
31. You should now have a View available boats link under the Services section.

Click the link which will run the iSeries Access for Web database request that you
saved earlier.  The output will be displayed in the session window.

32. The WAxxGROUP may not like how the data is displayed.  You as an administrator
could change the look by changing the saved database request to output in a
different format.  

33.  Click the Main page link at the top of the page.
34.  Click the Database tab.
35.  Click the My requests link.
36. Click the Edit link for the waxx_request request.  Change the SQL Output -->  

Type field to Preview.
37. Click the Save Request button.
38. Select the Replace if already exists checkbox, click the Save Request button.
39.  In the upper left, at the top of the Access for Web navigation bar, select the My

Home Page link.  
40.  The database output should be updated to display differently.
41.  This is one example of how an administrator can manage how their users are

accessing the iSeries server.
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Task 3:  Adding a 5250 Boats application to the home
page

The second link you will update will start a 5250 application called boats.  You will be
using a parameter called initmac.  This parameter identifies a macro to run after a
session is started.  Follow the steps below to create a macro called startboats, and add
the link to the “Access for Water” home page.

In order to create a macro you will need to sign on as the users that will be using the
“Access for Water” home page.  This is because a macro can only be accessed by the
user that creates it and since we want to use a macro on this home page, we will need
to have each user create it.  Follow the next steps to change the home page back to the
default homepage for WAxxGROUP.  You need to do this so WAxxGROUP has
access to the functions needed to create the macro.

1. Click the Main page link at the top of the page.

We now need to create a macro for WAxx and WAxxADM.  (where xx is your team
number)

1. Click the 5250 tab in the iSeries Access for Web navigation bar.
2. Click the Start Session link.
3. Leave the field defaults as they are displayed.  Click the Start Session button.
4. Select the Start Recording button to begin recording the macro.
5. Signon to the 5250 session as WAxx.  (where xx is your team number)  Hit enter

until you get to a command screen.  
6. Type boats on the command line and hit enter to run the boats application.
7. Click the Stop Recording button.
8. In the Macro field, enter startboats, and click the Save Macro button.
9. Press the F3 key until you get to a screen with a command line.  Type the command

SIGNOFF and press the Enter key or select the Enter button in the keypad below
the session window.

10. Click the Active sessions link in the 5250 tab on the iSeries Access for navigation
bar.

11. Click the Stop link to stop the currently active session.
12. Repeat the steps 1-11 above, except use WAxxADM instead of WAxx. (where xx

is your team number)
13. Now we need to modify the home page to include a link to the 5250 application that

was just created and run.  Click the Windows Start button, select the Run... Option.
In the Open field, type...

WORDPAD  C:\WALAB\HOMEPAGE\WADIR\HOMEPAGE.HTML
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14. Search for text similar to...

<!-- ***************************  -->
<!-- Add list of Services here    -->
<!-- ***************************  -->

15. Underneath this text, there are a couple of html statements.  In the second statement
listed you will need to replace the ServiceLink2 with the URL address that will start
a session and run your macro.  The URL that will start the session is 

    /webaccess/iWA5250

and the parameter initmac=startboats will run the macro. The URL address that
you will add will look like this

/webaccess/iWA5250?initmac=startboats

16. Click the File pulldown menu and select the Save option to save the changes.
Close the Wordpad window.

17. In the browser session, click the Files tab in the navigation bar.  Click the Browse
files link. 

18. In the left pane of the Browse files window, expand the walab directory, expand the
homepage directory, select the waxxdir directory (where xx is your team number).
The right pane should be updated with the files that exist in the waxxdir directory.

19. Scroll down the right pane to the Copy Files to Server section.  In the File field, type
C:\WALAB\homepage\wadir\homepage.html, select the Replace file checkbox,
click the Copy File button.

20.  Close the Browse Files window.
21.  In the upper left, at the top of the Access for Web navigation bar, select the My

Home Page link.  
22. The See boat details link under the Services section should now run the 5250

boats application.  
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Task 4:  Adding administrator specific tasks to the
home page

You can add a group of links in the Service section that can only be viewed by
administrators.  You won’t need to create separate home pages for customers and
administrators.  You can do this by using the iSeries Access for Web include list support.
The home page can contain an include list replacement flag.  The format of the tag is
%%include list=file%% where file identifies a file containing list items to include as links in
a table.  Follow the steps below to use this feature.

1. There is a policy file already set up for you to use.  To open it, click the Windows
Start button, select the Run... Option.  In the Open field, type...

WORDPAD  C:\WALAB\HOMEPAGE\WADIR\ADMINSERV.POLICIES

2. Search for text that is similar to 

 <profile name=”WAxxADM”>

3. Replace xx with your team number.  This will allow WAxxADM access to the links
4. Click the File pulldown menu and select the Save option to save the changes.

Close the Wordpad window.
5. In the browser session, click the Files tab in the navigation bar.  Click the Browse

files link. 
6. In the left pane of the Browse files window, expand the walab directory, expand

the homepage directory, select the waxxdir directory (where xx is your team
number).  The right pane should be updated with the files that exist in the waxxdir
directory.

7. Scroll down the right pane to the Copy Files to Server section.  In the File field,
type or browse for C:\WALAB\homepage\wadir\adminserv.policies, select the
Replace file checkbox, click the Copy File button.

8.  Close the Browse Files window.
9. Now you will need to include the policy file into the home page that will be

displayed.  Click the Windows Start button, select the Run... Option.  In the Open
field, type...

WORDPAD  C:\WALAB\HOMEPAGE\WADIR\HOMEPAGE.HTML

10.Search for text similar to...

<!-- ***************************  -->
<!-- Add Adminserv.policies here   -->
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<!-- ***************************  -->

11.Directly after this text, add the following statement…

<td>%%include list=/walab/homepage/waxxdir/adminserv.policies%%</td>

Make sure to replace the xx with your team number

12.Click the File pulldown menu and select the Save option to save the changes.
Save the file as HOMEPAGE.HTML.  Close the Wordpad window.

13.In the browser session, click the Files tab in the navigation bar.  Click the Browse
files link. 

14.In the left pane of the Browse files window, expand the walab directory, expand
the homepage directory, select the waxxdir directory (where xx is your team
number).  The right pane should be updated with the files that exist in the waxxdir
directory.

15.Scroll down the right pane to the Copy Files to Server section.  In the File field,
type C:\WALAB\homepage\wadir\homepage.html, select the Replace file
checkbox, click the Copy File button.

16. Close the Browse Files window.
17. Open a new browser session signing on as WAxxADM.
18.You should now have additional links under the links that you added earlier.  If you

open a new browser session and sign on as WAxx you won’t see the links.  The
list of items that you included can also be tailored to a group of users or all users
(*PUBLIC).  You can also add additional profile sections to adminserv.policies if,
for instance, you want to have special links that only customers can use.

NOTE:  You need to use character references for characters that can be
included in an XML document. For example, if you have a link with multiple
parameters, you need to replaces & with &amp.

19.Close the WAxxADM “Access for Water” browser windows.
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Task 5:  Adding an image and movie to the home page

Under the “This Week’s Special” section, a picture of the boat special should be displayed
along with a description.  You will also show an Mpeg movie of the boat.  To do this, you will
need to update the home page to include this information.  Open up the latest copy of the
home page that you created.

1. Click the Windows Start button, select the Run... Option.  In the Open field, type...

WORDPAD  C:\WALAB\HOMEPAGE\WADIR\HOMEPAGE.HTML

2. Search for text similar to...
<!--  ****************************  -->
<!--  Add This Week's Special here  -->
<!--  ****************************  -->

3. Remove the comment, 

<!--  Add text to display carver.jpg here -->

and add the following text.

<img SRC="/walab/homepage/images/carver.jpg" height=153 width=252>

This will add the image of the boat to your home page.
4. Remove the comment, 

<!--  Add description and link to mpeg here -->

and add the following text.

<br><br>Beautifully maintained 28 foot 1978 Carver Santa Cruz for
only $23,900.  Head and galley refurbished in 2001.  Only 31 hours on
completely rebuilt motor.  Click <a
href="/webaccess/iWAFileDownload/carver.mpg?filepath=/walab/homepage/
images/carver.mpg">here</a> to see this boat cruising the
seas.<br><br><br>

This will add the description and link to run the Mpeg movie of the boat.
5. Click the File pulldown menu and select the Save option to save the changes.

Save the file as HOMEPAGE.HTML.  Close the Wordpad window. 
6. In the browser session, click the Files tab in the navigation bar.  Click the Browse

files link. 
7. In the left pane of the Browse files window, expand the walab directory, expand

the homepage directory, select the waxxdir directory (where xx is your team
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number).  The right pane should be updated with the files that exist in the waxxdir
directory.

8. Scroll down the right pane to the Copy Files to Server section.  In the File field,
type C:\WALAB\homepage\wadir\homepage.html, select the Replace file
checkbox, click the Copy File button.

9.  Close the Browse Files window.
10. Open a new browser session signing on as user WAxxADM or WAxx.
11.You should see an image of a boat and a link to run the mpeg movie.
12.Close the new “Access for Water” browser window.
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Task 6:  Adding a Contact Us function to the home
page

Now we will add a section of the home page that provides customers with a way to send
their comments and questions to the boat company.

1. Click the Messages tab in the iSeries Access for Web navigation bar.
2. Click the Send Message link.
3. Now highlight (select) part of the URL request.  Just highlight (select) everything after

http://<server name>.  Don’t highlight (select) http://<server.  Now select the Edit
pulldown, and select the Copy option.  Or just hit Ctrl+C keys with part of the URL
request highlighted (selected).  The part that you highlight should look like this…

/webaccess/iWASendMessage

4. Now we need to modify the home page to include a link to the request that was just
created and run.  Click the Windows Start button, select the Run... Option.  In the
Open field, type... 

WORDPAD C:\WALAB\HOMEPAGE\WADIR\HOMEPAGE.HTML   

5. Search for text similar to:
<!-- ***************************  -->
<!-- Add Site Support here        -->
<!-- ***************************  -->

6. Underneath this text, there is an html statement.  In the first statement listed you will
need to replace SiteSupport with the URL address that was copied above in step
19.  Highlight (select) the SiteSupport, select the Edit pulldown menu, and select
the Paste option to paste in the URL address.  Do not remove the double quotes.
You should have a line that looks like this…

Your comments are important to us.  Please let us know if you have
any questions or if we can help you in any way.  Address your
message to user BOATHELP.&nbsp; <a
href="/webaccess/iWASendMessage">Send us a message</a><br><br><br>

7. Click the File pulldown menu and select the Save option to save the changes.    
Close the Wordpad window.

8. In the browser session, click the Files tab in the navigation bar.  Click the Browse
files link. 

9. In the left pane of the Browse files window, expand the walab directory, expand the
homepage directory, select the waxxdir directory (where xx is your team number).
The right pane should be updated with the files that exist in the waxxdir directory.
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10.Scroll down the right pane to the Copy Files to Server section.  In the File field, type
C:\WALAB\homepage\wadir\homepage.html, select the Replace file checkbox,
click the Copy File button.

11. Close the Browse Files window.
12. In the browser session that is running “Access for Water”, refresh the session or

close it and open a new browser session signing on as either WAxx or WAxxADM.
13.You should now see the new link under the Site Support section.  Click the link which

will run the iSeries Access for Web send message support.  The Send Message
screen should be displayed in the session window.

14.Close the browser window.
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Task 7:  Adding an external weather site to the home
page 

Note: Skip this lab if you do not have access to the Internet.  To determine if you
have external access, try going to www.ibm.com in tghe browser session. 

This task does not include adding access to any iSeries Access for web support, but
shows you are not restricted to iSeries Access for Web functions on your home page.    
Follow the steps below to add this section.  We are going to add a link to access the
www.weathercenter.com if you click anywhere on the image.

1. Click the Windows Start button, select the Run... Option.  In the Open field, type...

WORDPAD  C:\WALAB\HOMEPAGE\WADIR\HOMEPAGE.HTML

2. Search for text similar to...

<!--  ****************************************  -->
<!--  Add Weather Conditions text here          -->
<!--  ****************************************  -->

3. Underneath this text, add the following statement.  

Is it a great day for boating?  Check out today's forecast.<br><br>

4. Search for text similar to...

<!--  ****************************************  -->
<!--  Add Weather Conditions link here          -->
<!--  ****************************************  -->

5. Underneath this text, add the following statement.

<a
href="http://www.theweathercenter.com/bin/index.cgi?theme=default&user
=default&forecast=dayly&country=us&zipcode=&icao="><img
src="http://www.theweathercenter.com/bin/hwimage.cgi?theme=default&use
r=default&forecast=dayly&icao=&country=us&bgc=white&tc=black&t=1&metri
c=0&ampdisplay=" border="0" width="303" height="210"></a>

6. Click the File pulldown menu and select the Save option to save the changes.
Close the Wordpad window.

7. In the browser session, click the Files tab in the navigation bar.  Click the Browse
files link. 
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8. In the left pane of the Browse files window, expand the walab directory, expand the
homepage directory, select the waxxdir directory (where xx is your team number).
The right pane should be updated with the files that exist in the waxxdir directory.

9. Scroll down the right pane to the Copy Files to Server section.  In the File field, type
C:\WALAB\homepage\wadir\homepage.html, select the Replace file checkbox,
click the Copy File button.

10. Close the Browse Files window.
11. Open a new browser session signing on as either WAxx or WAxxADM.
12.You should now see the image under the Weather Conditions section that you can

click to view www.weathercenter.com.  Click on the image to check out the weather.
13.Close the browser.
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Task 8:  Adding additional replacement tags to the
home page

iSeries Access for Web supports some additional replacement tags in the home page
files.  Please feel free to try them out now that you know how to update the home page.
Here are the replacement tags:

• %%TITLE%% is replaced with the page title.

• %%USER%% is replaced with the authenticated user name.

• %%SYSTEM%% is replaced with the name of the iSeries server being accessed.

• %%VERSION%% is replaced with the version of iSeries Access for Web installed.
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Task 9: Resetting Preference and Policy settings to their
default values
This task shows you how to reset policy settings to their default values.  The following steps
will reset the preference and policy settings you updated the tasks above. 

1. Click the Customize navigation tab on the left side of your browser window.
2. Click the User profiles link to display the list of user profiles on the system.
3. Find the iSeries User ID you logged on as in list.  You may have to change pages to

find the ID in the list.  Select the Reset action for the ID
4. Select the Reset Settings button to confirm that you want to reset the settings to the

shipped default values.
5. Verify the homepage is now the default iSeries Access for Web homepage.
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Congratulations!

You have completed this iSeries Access for Web
lab!
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TRADEMARKS

The following are trademarks or registered trademarks of the IBM Corporation in the United States, other
countries, or both:

IBM AS/400 OS/400 iSeries DB2

Java and all Java-based trademarks and logos are trademarks of Sun Microsystems, Inc. in the United States, other
countries, or both. 

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the United States, other
countries, or both.

Lotus is a registered trademarks of Lotus Development Corporation and/or IBM Corporation.

Other company, product, and service names may be trademarks or service marks of others.
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