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Overview

IBM Problem Determination Tools Studio is a standalone Eclipse-based environment that provides workstation users
with easy access to the power of the IBM Problem Determination Tools for z/OS family of products:

IBM Debug Tool for z/OS
IBM Fault Analyzer for z/OS
IBM File Manager for z/OS

Hardware Requirements

The following minimum hardware levels are required:

CPU - 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor, dual or quad core recommended
RAM - 2.0 GB minimum, 3.0 GB recommended
Hard disk - at least 500 MB available space

Supported Platforms

One of the following levels of the Microsoft Windows operating system:

Microsoft Windows XP 32-bit
Microsoft Windows Vista 32-bit
Microsoft Windows 7 32-bit
Microsoft Windows 7 64-bit
Microsoft Windows Server 2008 32-bit
Red Hat Enterprise Linux v5 or v6
SUSE Linux Enterprise Server v10 or v11

Software Requirements

Any combination of one or more of the following IBM Problem Determination Tools for z/OS products:

IBM Debug Tool for z/OS V13.1, or later
IBM Fault Analyzer for z/OS, V12.1, or later
IBM File Manager for z/OS V12.1, or later

Installing IBM Problem Determination Tools Studio

To install Problem Determination Tools Studio:

Download the installation zip or tar file ( ) from the IBM ProblemPD_Tools_Studio_v  .32bit.zip xxxxxx
Determination Tools Studio .download page 
Extract the contents of the archive into a folder of your choice. Ensure that the directory you choose does not
contain any other files

Getting Started With IBM Problem Determination Tools Studio

http://www.ibm.com/legal/copytrade.shtml
http://www-01.ibm.com/support/docview.wss?uid=swg24033351
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The following are some steps to get you started once you have installed the Problem Determination Tools Studio.

Double-click the  executable file from where you extracted the archivePD_Tools
Specify a workspace location for the Problem Determination Tools Studio. We recommend a new folder on your
system
The Problem Determination Tools Studio product will appear displaying its Welcome page. The Welcome page
includes links to a basic overview and first steps to creating and managing your connections to host systems

Click Overview
Click any of the links on the left column to open any of the IBM Problem Determination Tools for z/OS
plug-ins overview help content
Click any of the links on the right column to open any of the IBM Problem Determination Tools for z/OS
plug-ins
The Problem Determination Tools Studio help documentation is integrated with the product. To display the
help documentation, from the main menu bar, click . The help contents provideHelp > Help Contents 
detailed help for all components of the offering, along with help for using Problem Determination Tools
Studio with each of the individual Problem Determination Tools products. There is also basic help for:

Eclipse (Workbench User Guide) - this is useful if you are new to using an Eclipse environment
offering
Problem Determination Tools for z/OS Common Component - contains help details on setting up
your host connections
z/OS Explorer User Guide - Contains details on the included z/OS perspectives and views as well
as further information on managing your configuration and working with host data sets, JCL files,
and submitting batch jobs to the host and viewing output

Each of the IBM Problem Determination Tools for z/OS plug-in perspectives can be opened from Window
; their views can be opened from .> Open Perspective > Other... Window > Show View > Other... 

If you are using Application Performance Analyzer with Problem Determination Tools Studio, there is some
connections/credentials setup that is unique to Application Performance Analyzer that must be performed
because Application Performance Analyzer uses its own listener.

Start the Problem Determination Tools Studio
Click Window > Manage Connections
Under Connections select  , then click Application Performance Analyzer Add...
In Add APA Connection enter the  and of the APA listener, then click Host name Port number Save and
Connect
Once a connection is established, you will be asked to select the APA started task (STC) that you desire
to connect to. Enter that started task.
Create a credentials entry for yourself, with your user name and password (or it can be a passphrase if
used on the machine).

If you are using the Debug Tool DTCN function, you will need to establish a connection between the DTCN
Profiles view for CICS and your z/OS system by following the steps described in  .DTCN tips

Updating IBM Problem Determination Tools Studio
Click Help > Check for Updates
If there are any updates found, Available Updates will appear, click Select All
Click Next
In Install Details click Next
Review and accept the terms in the license agreements, and then click Finish
If the Security Warning dialog appears click OK
Click  to successfully complete the updateRestart Now

Technical support

IBM Problem Determination Tools Studio is available at no charge to all licensed users of any of the following five IBM
Problem Determination Tools for z/OS products:

IBM Application Performance Analyzer for z/OS V13.1, or later
IBM Debug Tool for z/OS V13.1, or later
IBM Fault Analyzer for z/OS, V12.1, or later
IBM File Manager for z/OS V13.1, or later
IBM Workload Simulator for z/OS & OS/390 V1.1, or later

IBM Problem Determination Tools Studio is supplied under the standard terms and conditions of the IBM International
Program License Agreement (IPLA) and of the associated License Information and other documentation, and provides a
defect correction entitlement for those licensed users entitled to service for any of the IBM Problem Determination Tools
for z/OS products listed above. Service is available for IBM Problem Determination Tools Studio for as long as the IBM
Problem Determination Tools for z/OS product which IBM Problem Determination Tools Studio is to be used with is
generally supported by IBM. In addition, IBM reserves the right to discontinue service on IBM Problem Determination
Tools Studio when it is withdrawn from marketing by IBM. Please reference the IBM Problem Determination Tool for
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z/OS product that you are using as the entitled product when contacting IBM and requesting support for IBM Problem
Determination Tools Studio.

Establishing a connection between the DTCN Profiles view for CICS and your z/OS system

Specify the settings needed to establish a connection between the DTCN profiles view and your z/OS system by doing
the following steps:

Click Window > Show view > Other
Type "DTCN" in the text box at the top of the window. Select DTCN profiles and click OK
Click Window > Show view > Other
Type "Host Connections" in the text box at the top of the window. Select Host Connections and click OK
In the Host Connections view, select DTCN and click Add to create a connection to DTCN.
Specify the settings in the following fields and click Save and Close:

Name
The name of the connection. If left blank will be auto-filled by combining the host name and port number
entered separated by ":"

Host name
The TCP/IP name or address of the z/OS system as described in "Defining the CICS TCPIPSERVICE
resource" in the Debug Tool Customization Guide

Port number
The port number of the z/OS system as described in "Defining the CICS TCPIPSERVICE resource" in the
Debug Tool Customization Guide

Select the DTCN connection you created, and click Connect.
In the DTCN Signon window, specify the settings in the following fields, or select "Use existing Credentials" if you
have at least one credential defined, and click OK.

Credentials Name
The name of the credential

User ID
The ID that you use to log on to the CICS system

Password or Passphrase
The password or passphrase that you use to log on to the CICS system

A successful connection is indicated through a green icon for the DTCN connection. Otherwise, review the values you
entered, correct any mistakes, and try the connection test again. You can also review the trace file (as described in
Debug Tool User's Guide Appendix I section "Locating the trace file of the DTCN Profiles or DTSP Profile view") for
diagnostic information that can help identify the cause of the connection error. In the DTCN Profiles view, you can right
click anywhere to see a list of actions available. 

 If you want require a secured connection, you will need to follow the steps in the section, Note: Establishing a secured
communication between the DTCN profile view for CICS and your z/OS system

Establishing a secured communication between the DTCN profile view for CICS and your
z/OS system

These steps help you enable secure communication via Secure Sockets Layer (SSL) between DTCN profile view and
your z/OS system. The communication between the client and server uses the HTTP protocol.

Client side setup

To enable SSL communication, complete the following tasks for the client side:
Install server certificate: 
Because the certificate server generated is not from an authorized certificate authority (CA), to solve this issue,
you need to install the certificate to your JDKs keystore.

Download copy of the certificate in text mode that the server has exported into your workstation directory
Import the downloaded certificate into your JREs keystore. The following is an example how to import the
certificate into keystore using keytool provided by java

        Keytool import alias myprivateroot keystore ..\lib\security\cacerts file dtcnplg.cer
        dtcnplg.cer is the downloaded copy of the server certificate.
        The initial password for the cacerts keystore is changeit.
       

 If you are using CICS Explorer, the keytool utility can be found in the Java installation bin directory, Note:
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<CICS Explorer Install Directory>\jre\bin. 
If you are using PD Tools Studio, the keytool utility can be found in the Java installation bin directory, <PD
Tools Studio Install Directory>\jre\jre\bin

Server side setup

To enable SSL communication, do the following tasks for Server side:
Generate key pair and self-signed certificate using Rexx RACF command.

Use RACF GENCERT command to create a key entry for the CICS region owner. The key entry contains
the key pair and self-signed certificate. 
Example (Create a key entry for user USERID with label: USERID-DTCNPLG-CERT):

        
         /* generate key entry                                  */

         "RACDCERT ID(USERID) GENCERT",

         " SUBJECTSDN(CN(

         'your_host_name.com'

         ) ",

         "            T ('USERID-DTCNPLG-CERT'                 ) ",

         "            OU('IBM'                                 ) ",

         "            O ('IBM'                                 ) ",

         "            L ('San Jose'                            ) ",

         "            SP('CA'                                  ) ",

         "            C ('US'                                  ))",

         " NOTBEFORE(DATE(2011-02-28)  TIME(20:00:00)     )",

         " NOTAFTER (DATE(2031-12-31)  TIME(19:59:59)     )",

         " WITHLABEL(

         USERID-DTCNPLG-CERT

         )",

         " SIZE     (1024                                 )"

        

       

Connect the key entry to a key ring that belongs to the CICS region owner ID. The common name of the
subject DSN must be the host name of the server that the client uses to connect to host. 
Example (Connect it to a key ring named USERID):

        
         /* connect key entry to key ring                       */

         " RACDCERT ID(

         USERID

         ) ",

         "  CONNECT( RING (

         USERID

         ) ",

         "           LABEL(

         USERID-DTCNPLG-CERT

         ))"

        

       

Export the certificate and store it in a data set using the printable encoding format defined by the internet
RFC 1421 standard 
Example (Export the certificate to a data set: USERID.DTCNPLG.CERT)

        
         /* export certificate to a data set                    */

         "RACDCERT EXPORT(LABEL('USERID-DTCNPLG-CERT'          ) ",

         " ID(

         USERID

         ) ",

         " DSN(

         'USERID.DTCNPLG.CERT'

         ) ",

         " FORMAT(CERTB64                                      ))"

        

       

Initialize parameters in CICS region
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Add the KEYRING parameter in the CICS region start up job and point to the key ring created for the
region owner ID.
The following example adds SYSIN DD data set of CICS region startup job:

        KEYRING=USERID
       

Define TCPIPSERVICE resource
Add a TCPIPSERVICE resource definitions, see example below in bold texts. Change the SSL and
Certificate attributes.

        
         TCpipservice    : EQAHTP8S

         GROup          : GROUP_NAME

         DEscription    :

         Urm            : EQADPAN0           no Analyzer program is used

         POrtnumber     : 30009              1-65535

         STatus         : Open               Open | Closed

         PROtocol       : HTTP               Iiop | Http | Eci | User

         TRansaction    : CWXN

         Backlog        : 00030              max backlog requests allowed

         TSqprefix      :

         Host           : ANY

         (Mixed Case)   :

         Ipaddress      :

         SOcketclose    : No                 No | 0-240000 (HHMMSS)

         Maxdatalen     : 008192             3-524288

         SECURITY

         SSl            :

         Yes

         Yes | No | Clientauth

         CErtificate    :

         USERID-DTCNPLG-CERT

         (Mixed Case)

         PRIvacy        : Supported          Notsupported|Required|Supported

         CIphers        : 050435363738392F303132330A1613100D0915120F0C03060201

         AUthenticate   : Basic              No|Basic|Certificate|AUTORegister | AUTOMatic | ASserted

         :I a Realm          :

         (Mixed Case)

         ATtachsec      :                    Local | Verify

         DNS CONNECTION BALANCING

         DNsgroup       :

         GRPcritical    : No                 No | Yes

         DEFINITION SIGNATURE

         DEFinetime     : 02/14/11 18:56:32

         CHANGETime     : 03/16/11 14:04:57

         CHANGEUsrid    : USERID

         CHANGEAGEnt    : CSDApi             CSDApi | CSDBatch

         CHANGEAGRel    : 0660

        

       


