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IBM® Lotus ® Expeditor Toolkit Version 6.1

Installation

Welcome to this presentation on how to install the IBM Lotus Expeditor Toolkit Version 6.1
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Goals

�Understand how to install the IBM Lotus Expeditor 
Toolkit Version 6.1

The goal of this presentation is to explain how to install Lotus Expeditor Toolkit Version 6.1.
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Lotus Expeditor Toolkit Install

� Eclipse Update site
�Available on CD in Expeditor_Toolkit_install directory

� Two separate features
Lotus Expeditor Toolkit
Lotus Expeditor Toolkit for Devices

� Toolkit installs include
�Tools

�Documentation
� Developing applications for Lotus Expeditor

� Assembling and Deploying Lotus Expeditor Applications

�Samples
� Installed into the samples gallery

�Lotus Expeditor test environment

This slide describes contents of the Lotus Expeditor Toolkit CD.

The CD provides an Eclipse Update site, which is available in the Expeditor_Toolkit_install  
directory.

There are two features that you can install: You can install either the Lotus Expeditor 
Toolkit or the Lotus Expeditor Toolkit for Devices.  Note that  the Lotus Expeditor Toolkit 
for Devices requires that you first install the Lotus Expeditor Toolkit .

Toolkit install includes tools for creating Client Services applications and documentation 
describing how to use the tools and sample applications to get you started. The toolkit also 
provides a Lotus Expeditor Client test environment required to test and debug your 
applications.
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Install process
� Standard Eclipse update site 

process

Note: Not part of the Rational’s 
IBM Installation Manager

� Documented in the Installation 
Guide (index.html)

� Takes approximately 10 
minutes to complete

� After restart the toolkit will 
make a few configuration 
changes
� User is prompted

Review the Lotus Expeditor Toolkit Installation Guide for additional information.  To 
manually open the Installation Guide, open the index.html file in the root directory of the 
install CD.
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Feature selection

� Select which features to install. 

Use the dialog box depicted in this slide to select the two features to install: the Lotus 
Expeditor Toolkit and the Lotus Expeditor Toolkit for Devices.

Select the features then click Next .
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License agreements
� Read the licensing information for each feature that you are installing by 

selecting the feature on the left.

� If you agree with the license select that option, then click Next .

Read the license agreements. If you agree with them select that option, then click Next .
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Installation location
� Use the default installation location, or chose a different one by clicking 

Change Location .

Note: If installing both features, they must be installed in the same location.

� Click Finish .

The features can be installed in the “default” location, or you can select a different location 
by clicking the Change Location button.

If you’re installing both features, be sure that the Installation Directory is the same for 
both.

Then click the Finish button.
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Configuration process

� The toolkit will ask you to set the preferences for 
development.

� If you click Cancel and do not check the “Don’t ask me 
again” checkbox, the system will ask each time until you 
click OK.

� This is a per workspace 
configuration, so each 
new workspace will require 
a separate answer

� Clicking OK will:
�Change the target platform
�Change the workspace JRE

For the Lotus Expeditor Toolkit to work correctly it must be configured. To help configure 
the toolkit, this message box is displayed that allows users to configure multiple settings in 
just one click. Click the OK button to make the configuration change.
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From the Installation Guide (index.html)
To install the IBM Lotus Expeditor Toolkit Version 6.1, follow these steps:
1. Review release notes for system requirements and product information, such as software limitations at the time of this release. 

2. Log on to your system with an administrator ID that has write permission to the installation location and start your Eclipse/Rational SDP platform. 

3. From the main menu, click Help > Software Updates > Find and Install . The Install/Update wizard is displayed. 

4. Select Search for new features to install and click Next . 

5. In the "Update sites to visit" window, select the New Local Site button. 

6. Browse to select the drive and directory where the IBM Lotus Expeditor feature is located and click OK. For example, if installing from the 
product CD, select the Lotus_Expeditor_install directory and click OK. 

7. Select the check box next to the site name and click Next . Note : Selection of the Ignore features not applicable to this environment check 
box does not affect toolkit installation.

8. In the Search Results window, select the Lotus Expeditor Toolkit feature, or Lotus Expeditor Toolkit for Devices feature, or both, and click 
Next . 
Note : Selection of the Filter features included in other features on the l ist check box does not affect toolkit installation. 

9. In the Feature License window, read the licensing information for each feature that you are installing, and if you agree with the license, select to 
accept the license and click Next.

10. In the Install Location window, the directory location where this feature will be installed is displayed. You can select a different directory by 
clicking the Change Location button. 
Note: If you are installing both the Lotus Expeditor Toolkit and the Lotus Expeditor Toolkit for Devices you must choose the same location to 

install both. 

11. Click Finish to begin the installation. 

12. In the Feature verification window, verify that the feature information is correct and click Install . 
Note : When warned about installing an unsigned feature, click Install to continue. This does not cause problems during installation. 

13. When installation completes, you are prompted to restart your Platform for changes to take effect. Click Yes to continue. Note : Clicking Apply 
Changes does not properly configure the environment.

This slides shows the installation instructions, which you can also find in the Installation 
Guide on the CD. Take a moment to read these instructions. 
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Verifying the installation
� To confirm that the installation was successful, start the Eclipse Platform and do the 

following:

�Click Help > Software Updates > Manage Configuration…

�The Product Configuration window is displayed. Verify that the features you installed 
are displayed in the list, either:

Lotus Expeditor Toolkit 6.1.0

Lotus Expeditor Toolkit for Devices 6.1.0

You can verify the installation of the toolkit was successful by opening the Product 
Configuration wizard. To do so, start the Eclipse Platform and click Help and Manage 
Configuration .

Verify that the features you selected to install are in the list.
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Uninstall

To uninstall the toolkit, perform the following procedure: 

� Select Window > Preferences > Java™ > Installed JREs . The Installed Java 
Runtime Environments panel displays, showing all installed JREs. Unselect the 
jclDesktop (to remove it as the default JRE), and check the JRE that was originally 
provided/used.

� Select Window > Preferences > Plug-in Development > Target  Platform and 
change the Location field to the original default location by selecting it from the drop 
down list. 

� Select Help > Software Updates > Manage Configuration . The Product 
Configuration menu displays. From the Navigator window select the feature you want 
to uninstall. The information for the feature displays in the window to the right. Select 
Disable .1

� Restart the platform when prompted.1 

� Select Help > Software Updates > Manage Configuration . The Product 
Configuration menu displays. From the Navigator window select feature to uninstall. 
The information for the feature displays in the window to the right. Select Uninstall . 

� Select OK in the next dialog. Restart the platform when prompted.

Note: Steps 3 and 4 are only required on Windows®. Linux® users can step directly from step 3 to step 5. 

You can uninstall features using the Product Configuration wizard.

Note that you need  to return the platform configuration back to the “default” JRE and 
Target Platform prior to uninstalling the toolkit.
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Trademarks, copyrights, and disclaimers
The following terms are trademarks or registered trademarks of International Business Machines Corporation in the United States, other countries, or both:

IBM Lotus

Windows and the Windows logo are registered trademarks of Microsoft Corporation in the United States, other countries, or both.

Java, JRE, and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Product data has been reviewed for accuracy as of the date of initial publication.  Product data is subject to change without notice.  This document could include 
technical inaccuracies or typographical errors.  IBM may make improvements or changes in the products or programs described herein at any time without notice. Any 
statements regarding IBM's future direction and intent are subject to change or withdrawal without notice, and represent goals and objectives only.  References in this 
document to IBM products, programs, or services does not imply that IBM intends to make such products, programs or services available in all countries in which IBM 
operates or does business.  Any reference to an IBM Program Product in this document is not intended to state or imply that only that program product may be used.  
Any functionally equivalent program, that does not infringe IBM's intellectual property rights, may be used instead.

Information is provided "AS IS" without warranty of any kind.  THE INFORMATION PROVIDED IN THIS DOCUMENT IS DISTRIBUTED "AS IS" WITHOUT ANY 
WARRANTY, EITHER EXPRESS OR IMPLIED.  IBM EXPRESSLY DISCLAIMS ANY WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 
PURPOSE OR NONINFRINGEMENT. IBM shall have no responsibility to update this information.   IBM products are warranted, if at all, according to the terms and 
conditions of the agreements (for example, IBM Customer Agreement, Statement of Limited Warranty, International Program License Agreement, etc.) under which 
they are provided. Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly 
available sources.  IBM has not tested those products in connection with this publication and cannot confirm the accuracy of performance, compatibility or any other 
claims related to non-IBM products.

IBM makes no representations or warranties, express or implied, regarding non-IBM products and services.

The provision of the information contained herein is not intended to, and does not, grant any right or license under any IBM patents or copyrights.  Inquiries regarding 
patent or copyright licenses should be made, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY  10504-1785
U.S.A.

Performance is based on measurements and projections using standard IBM benchmarks in a controlled environment.  All customer examples described are presented 
as illustrations of how those customers have used IBM products and the results they may have achieved.  The actual throughput or performance that any user will 
experience will vary depending upon considerations such as the amount of multiprogramming in the user's job stream, the I/O configuration, the storage configuration, 
and the workload processed.  Therefore, no assurance can be given that an individual user will achieve throughput or performance improvements equivalent to the 
ratios stated here.

© Copyright International Business Machines Corporation 2006.  All rights reserved.

Note to U.S. Government Users - Documentation related to restricted rights-Use, duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule 
Contract and IBM Corp.

This concludes the presentation.


