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What this exercise is about 

In this lab, you will build a portlet in Rational Application Developer v6.0 using the Struts Portlet 
Framework.  After you have finished designing and implementing your portlet, you will test it using the 
WebSphere Portal v5.0 Test Environment in Rational Application Developer. 

Lab Requirements 

List of system and software required for the student to complete the lab. 

• IBM Rational Application Developer v6.0 with the Portal Tools Additional Feature selected 

• WebSphere Portal Server v5.0.2.2 Test Environment 

• The lab source files LabFiles60.zip must be extracted to the root directory C:\ 

What you should be able to do 

At the end of this lab you should be able to: 

• Build a portlet application using the Struts Portlet Framework included by the WebSphere Portal 
Server 

• Test a portlet application in the Portal Test Environment 
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Introduction 

In this lab, you will design a portlet that displays basic contact information; you can think of it as an 
address book.  The main page of the View Mode is simply a list of contacts.  When the user clicks on the 
name of a specific contact, the portlet displays detailed information about that contact.  The Edit mode 
works mostly the same way, but clicking on a specific contact allows the user to modify that contact’s 
information. 

 

Exercise Instructions 

Some instructions in this lab may be Windows operating-system specific.  If you plan on running the lab on 
an operating-system other than Windows, you will need to execute the appropriate commands, and use 
appropriate files ( .sh vs. .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references, as follows: 

Reference Variable Windows Location AIX/UNIX Location 

<WAS_HOME> C:\WebSphere\AppServer /usr/WebSphere/AppServer 

/opt/WebSphere60/AppServer 

<IRAD_HOME> C:\Program Files\IBM\Rational\SDP\6.0  

<LAB_FILES> C:\Labfiles60 /tmp/Labfiles60 

<TEMP> C:\temp /tmp 

<LAB_NAME> IRAD_Portal  

Windows users please note: When directory locations are passed as parameters to a Java program 
such as EJBdeploy or wsadmin, it is necessary to replace the backslashes with forward slashes to follow 
the Java convention. For example, C:\LabFiles60\ would be replaced by C:/LabFiles60/ 
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Part 1: Creating a New Portal Project 

____ 1. Start Rational Application Developer. 

__ a. Select Start > Programs > IBM Rational > IBM Rational Application Developer V6.0 > 
Rational Application Developer. 

__ b. A dialog box will be displayed allowing you to select the location where you would like the 
workspace directory to be stored.  Enter <LAB_FILES>\<LAB_NAME>\workspace for the 
location and select OK.  Application Developer will start with an empty workspace.  An empty 
workspace will leave your existing workspace untouched and help avoid name conflicts between 
what you may already have in your workspace and what you will be creating in this lab. 

NOTE: If the Auto Launch Configuration Change Alert window appears click the Yes button to 
change the auto launch eclipse instance to use when opening IBM Rational Software 
Development Platform in the future. 

____ 2. When Rational Application Developer v6.0 opens, close the welcome page. 

____ 3. Create a new portal project. The portal project contains resources that affect the structural (portal 
site layout) and stylistic (themes and skins) framework of a portal. 

__ a. Click File > New > Project….  The New Project wizard opens. 

__ b. In the Select a wizard panel, select Portal Project and click Next >. 

 

__ c. In the Confirm Enablement window, read the message and click OK. Creating a Portlet project 
requires that advanced Web Development capabilities be enabled within Application Developer. 
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__ d. On the Portal Project panel, enter MyPortal in the Name field. Click Show Advanced >> to 
show the advanced properties of the portal project wizard. Verify that the Target server field is 
set to WebSphere Portal v5.0. Click Next >. 

 

__ e. In the Select Theme panel, ensure that the WebSphere theme is selected (see the screen shot 
below) and click Next >. 

NOTE: Later in the lab, you will use Portal Designer to modify your portal’s theme. 
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__ f. In the Select Skin panel, ensure that the Outline skin is selected (see the screen capture below) 
and click Finish. 

NOTE: Later in this lab, you will use Portal Designer to modify the skins used in your portal. 

 

__ g. In the Confirm Perspective Switch window, read the message and click Yes. Portal projects are 
associated with the Web Perspective within Application Developer. 

__ h. The portal project will be created and the portal’s configuration file will be opened in the Portal 
Designer editor (see the screen capture below). 

 

__ i. Close the Portal Designer editor. 

____ 4. Observe the default settings of the new Portal project. 

__ a. In the Project Explorer view, expand Dynamic Web Projects > MyPortal. Use the table below 
as a reference for the different entries under the MyPortal project. 

Entry Name Description 

Portal Configuration Shortcut to the portal configuration file (ibm-portal-topology.xml). The 
actual portal configuration file can be found by expanding MyPortal > 
Portal Configuration. 

Themes Shortcut to the themes within the PortalContent folder. 

Skins Shortcut to the skins within the PortalContent folder. 

Portal Configuration Expand the Portal Configuration folder to see the portal configuration file 
(ibm-portal-topology.xml). 

PortalContent Folder contains the resources that affect a portal’s structure and style. 
Access files from this folder if you can not access them through the use of 
the shortcuts above. 
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Part 2: Import Pre-created Portlet Applications 

In this part, you will import pre-created portlet applications. The portlet applications will be used in creating 
your portal. 

____ 1. Import an EAR that contains the completed portlet. 

__ a. Select File > Import….  The Import wizard will open up. 

__ b. In the Select panel, select EAR file and click Next >. 

__ c. In the Enterprise Application Import panel, for the EAR file field enter 
<LAB_FILES>\<LAB_NAME>\PortletsEAR.ear. Change the Target server field to WebSphere 
Portal v5.0. Click Finish. 

__ d. In the Confirm Perspective Switch window, read the message and click No. 

____ 2. Explore the portlet applications that were imported. 

__ a. In the Project Explorer view, expand Dynamic Web Projects. The table below describes the 
portlets that are included in each of the dynamic web projects. 

Entry Name Description 

Calculator Calculator portlet displays a simple calculator. Contains view, edit 
and help modes. 

ContactList Contains two portlets: 

• Welcome portlet – Displays welcome portlet 

• ContactList portlet – Displays an address book with contact 
information. Contains view and edit modes. 

PortalLogViewer Portal Log Viewer portlet displays the portal server’s logs within the 
portal. Contains view, edit and help modes. 
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Part 3: Create Portal Using Portal Designer 

In this part, you will use Portal Designer to create a portal using the portlets imported in the previous part. 

____ 3. Open the portal configuration. 

__ a. Ensure that you are in the Web perspective. Click Window > Open Perspective > Web. 

__ b. In the Project Explorer view, ensure Dynamic Web Projects > MyPortal is expanded. Double-
click on Portal Configuration to open the portal configuration file in Portal Designer. 

 

__ c. The portal’s configuration file is opened in the Portal Designer editor. 

____ 4. Change the title of “Label1” to My Portal. 

__ a. In Portal Designer, select “Label1” by left-clicking on it (see the screen capture below). 

 

__ b. Switch to the Properties view by selecting Window > Show View > Properties. 

__ c. In the Properties view, select the Title tab (see the screen capture below). 
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__ d. Edit the label’s title. In the Title field change the text to be “My Portal” (see the screen capture 
below) and press Enter. Note that the label’s title in Portal Designer has changed. 

 

__ e. The end result will look like the screen capture below. 

 

____ 5. Change the title of “Page1” to Personal. 

__ a. In Portal Designer, select “Page1” by left-clicking on it. 

__ b. In the Properties view, select the Title tab (see the screen capture below). 

__ c. Edit the page’s title. In the Title field change the text to be Personal and press Enter. Note that 
the page’s title in Portal Designer has changed. 

__ d. The end result will look like the screen capture below. 

 

____ 6. Add the “Welcome” portlet to the portal. 
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__ a. In the Palette view, ensure that the Portal drawer is open.  Drag-and-drop a Portlet onto the 
“Place portlet here” text in Portal Designer. See the screen capture below for an illustration. 

NOTE: When dragging-and-dropping, a valid spot to place the portlet in the page is highlighted by a “+” 
sign under the mouse cursor. 

 

__ b. In the Insert Portlet window, select Welcome (see the screen capture below) and click OK. 

 

__ c. The Welcome portlet is added to the Personal page. The end result will look like the screen 
capture below. 

 

____ 7. Add the “Calculator” portlet to the portal. 
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__ a. In the Palette view, drag-and-drop a Portlet below the Welcome portlet in Portal Designer. 
See the screen capture below for an illustration. 

NOTE: When dragging-and-dropping, a valid spot to place the portlet in the page is highlighted by a “+” 
sign under the mouse cursor. 

 

__ b. In the Insert Portlet window, select Calculator portlet (see the screen capture below) and click 
OK. 
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__ c. The Calculator portlet is added to the Personal page. The end result will look like the screen 
capture below. 
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____ 8. Add a column to the portal to hold the ContactList portlet. 

__ a. In the Palette view, drag-and-drop a Column to the right of the Welcome and Calculator 
portlets in Portal Designer. See the screen capture below for an illustration. 

NOTE: When dragging-and-dropping, a valid spot to place the portlet in the page is highlighted by a “+” 
sign under the mouse cursor. 
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__ b. A column is added to the Personal page. The end result will look like the screen capture below. 

 

____ 9. Add the “ContactList” portlet to the portal. 

__ a. In the Palette view, drag-and-drop a Portlet onto the “Place portlet here” text in the new 
column that was just created. See the screen capture below for an illustration. 

NOTE: When dragging-and-dropping, a valid spot to place the portlet in the page is highlighted by a “+” 
sign under the mouse cursor. 

 

__ b. In the Insert Portlet window, select ContactList portlet (see the screen capture below) and click 
OK. 
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__ c. The ContactList portlet is added to the Personal page. The end result will look like the screen 
capture below. 

 

____ 10. Add a new page under the My Portal label. 

__ a. In the Palette view, drag-and-drop a Page to the right of the “Personal” page. See the 
screen capture below for an illustration. 

NOTE: When dragging-and-dropping, a valid spot to place the portlet in the page is highlighted by a “+” 
sign under the mouse cursor. 
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__ b. A page is added under the My Portal label. The end result will look like the screen capture below. 

 

____ 11. Change the title of “New Page” to Log Viewer. 

__ a. In Portal Designer, select “New Page” by left-clicking on it. 

__ b. In the Properties view, select the Title tab (see the screen capture below). 

__ c. Edit the page’s title. In the Title field change the text to be Log Viewer and press Enter. Note that 
the page’s title in Portal Designer has changed. 

__ d. The end result will look like the screen capture below. 

 

____ 12. Add the “PortalLogViewer” portlet to the portal. 

__ a. In the Palette view, drag-and-drop a Portlet onto the “Place portlet here” text that is in the 
new page that was just created. See the screen capture below for an illustration. 

NOTE: When dragging-and-dropping, a valid spot to place the portlet in the page is highlighted by a “+” 
sign under the mouse cursor. 
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__ b. In the Insert Portlet window, select PortalLogViewer portlet (see the screen capture below) and 
click OK. 

 

__ c. The PortalLogViewer portlet is added to the Log Viewer page. The end result will look like the 
screen capture below. 

 

____ 13. Save the portal configuration. Ensure that the Portal Designer tab is selected and click File > Save. 

____ 14. View the structure of the portal that you just created using the Outline view. The Outline view can be 
used to select and edit items in the portal configuration. 
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__ a. Switch to the Outline view by selecting Window > Show View > Outline (see the screen capture 
below). 

 

__ b. Use the Outline view to explore the items that you created above in Portal Designer. 

____ 15. Change the MyPortal theme from “WebSphere” to Corporate. The Thumbnails view can be used to 
easily change a portal’s theme. 

__ a. Switch to the Thumbnails view by selecting Window > Show View > Thumbnails. 

__ b. In the Project Explorer view, ensure that Dynamic Web Projects > My Portal is expanded and 
select Themes. The Themes that are available in the MyPortal portal project will be displayed in 
the Thumbnails view (see the screen capture below). 
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__ c. Apply the “Corporate” theme to the MyPortal portal. In the Thumbnails view, select the 
Corporate thumbnail. Drag-and-drop the thumbnail onto the Portal Designer window (see 
the screen capture below for an illustration). 

 

__ d. The “Corporate” theme will be applied to the MyPortal portal. The end result will look like the 
screen capture below.  

 

____ 16. Change the Welcome portlet’s skin from “Outline” to NoSkin. The Thumbnails view can additionally 
be used to easily change a portlet’s skin. 

__ a. In the Portal Designer, select the Personal page. 

__ b. Switch to the Thumbnails view by selecting Window > Show View > Thumbnails. 
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__ c. In the Project Explorer view, ensure that Dynamic Web Projects > My Portal is expanded and 
select Skins. The Skins that are available in the MyPortal portal project will be displayed in the 
Thumbnails view (see the screen capture below). 

 

__ d. Apply the “NoSkin” theme to the Welcome portlet. In the Thumbnails view, select the No Skin 
thumbnail (you will have to scroll the view down). Drag-and-drop the thumbnail onto the 
Welcome portlet in Portal Designer (see the screen capture below for an illustration). 

 

__ e. The “NoSkin” skin will be applied to the Welcome portlet. The end result will look like the screen 
capture below.  

 

__ f. Optionally use the steps above to apply different skins to the different portlets within the MyPortal 
portal. 
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____ 17. Save the portal configuration. Click File > Save. 
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Part 4: Test the Portal on the Portal Test Environment 

In this part, you will use the Portal Test Environment to run and test the portal that was created above. 

____ 18. Run the portal on a new server configuration. 

__ a. In the Project Explorer view, expand Dynamic Web Projects.  Right-click on MyPortal and 
select Run > Run on Server…. 

__ b. In the Server Selection window, select Manually define a server.  In the Select the server type 
box, select WebSphere Portal v5.0 Test Environment. Click Finish. 

 

__ c. A new server and server configuration will be automatically generated, and the Portal Project will 
be added to this server.  The server will then start, and a web browser will open to display your 
portal. 

NOTE: Depending on the size of the system on which you are working, the starting of the Portal server 
may take up to ~5 minutes. 

____ 19. Test the MyPortal portal that was created above. 
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__ a. When the MyPortal portal comes up, the Personal page is displayed. The Personal page 
contains the Welcome, Calculator and ContactList portlet. 

 

__ b. Explore the different portlets on the Personal page. 
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__ c. Click the Log Viewer page (see the screen capture below). The Log Viewer page contains the 
PortalLogViewer portlet. 

 

__ d. Explore the portlet on the Log Viewer page. 

__ e. Continue to explore the application until you are satisfied with what you have seen. 

____ 20. Stop the test server. 

__ a. Switch to the Servers view by selecting Window > Show View > Servers. 

__ b. Right-click on WebSphere Portal v5.0 Test Environment @ localhost and select Stop. 

__ c. Watch the Console view and wait for the server to come to a complete stop. 

____ 21. Exit Application Developer. Select File > Exit. 
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 What you did in this exercise 

In this exercise, you used the portal development tools within Rational Application Developer v6.0 to build 
a portal.  
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Trademarks and Disclaimers 

The following terms are trademarks or registered trademarks of International Business Machines Corporation in the United States, 
other countries, or both: 

IBM   iSeries  OS/400  Informix   WebSphere 
IBM(logo)  pSeries  AIX  Cloudscape  MQSeries 
e(logo)business xSeries  CICS   DB2 Universal Database DB2 
Tivoli  zSeries  OS/390  IMS   Lotus 

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both. 
Microsoft, Windows, Windows NT, and 

the Windows logo are registered trademarks of Microsoft Corporation in the United States, other countries, or both. Intel, 
ActionMedia, LANDesk, MMX, Pentium and ProShare are 

trademarks of Intel Corporation in the United States, other countries, or both.  UNIX is a registered trademark of The Open Group in 
the United States and other countries. Linux is a registered trademark of Linus Torvalds.  Other company, product and service names 
may be trademarks or service marks of others. 

Product data has been reviewed for accuracy as of the date of initial publication.  Product data is subject to change without notice.  
This document could include technical inaccuracies or typographical errors.  IBM may make improvements and/or changes in the 
product(s) and/or program(s) described herein at any time without notice.   Any statements regarding IBM's future direction and intent 
are subject to change or withdrawal without notice, and represent goals and objectives only.  References in this document to IBM 
products, programs, or services does not imply that IBM intends to make such products, programs or services available in all 
countries in which IBM operates or does business.  Any reference to an IBM Program Product in this document is not intended to 
state or imply that only that program product may be used.  Any functionally equivalent program, that does not infringe IBM's 
intellectual property rights, may be used instead. 

Information is provided "AS IS" without warranty of any kind.  THE INFORMATION PROVIDED IN THIS DOCUMENT IS 
DISTRIBUTED "AS IS" WITHOUT ANY WARRANTY, EITHER EXPRESS OR IMPLIED.  IBM EXPRESSLY DISCLAIMS ANY 
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT. IBM shall have no 
responsibility to update this information.   IBM products are warranted, if at all, according to the terms and conditions of the 
agreements (e.g., IBM Customer Agreement, Statement of Limited Warranty, International Program License Agreement, etc.) under 
which they are provided. Information concerning non-IBM products was obtained from the suppliers of those products, their published 
announcements or other publicly available sources.  IBM has not tested those products in connection with this publication and cannot 
confirm the accuracy of performance, compatibility or any other claims related to non-IBM products.  IBM makes no representations 
or warranties, express or implied, regarding non-IBM products and services. 

The provision of the information contained herein is not intended to, and does not, grant any right or license under any IBM patents or 
copyrights.  Inquiries regarding patent or copyright licenses should be made, in writing, to: 

IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY  10504-1785 
U.S.A. 

Performance is based on measurements and projections using standard IBM benchmarks in a controlled environment.  All customer 
examples described are presented as illustrations of how those customers have used IBM products and the results they may have 
achieved.  The actual throughput or performance that any user will experience will vary depending upon considerations such as the 
amount of multiprogramming in the user's job stream, the I/O configuration, the storage configuration, and the workload processed.  
Therefore, no assurance can be given that an individual user will achieve throughput or performance improvements equivalent to the 
ratios stated here. 

Note to U.S. Government Users - Documentation related to restricted rights-Use, duplication or disclosure is subject to restrictions set 
forth in GSA ADP Schedule Contract and IBM Corp. 
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