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IBM RATIONAL APPLICATION DEVELOPER 6.0 — LAB EXERCISE

Profiling WebSphereBank
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What this exercise is about

The objective of this lab is to provide you with an understanding ...

Lab Requirements
List of system and software required for the student to complete the lab.

e |IBM Rational Application Developer v6.0 with embedded WebSphere Application Server v6.0 Test
Environment.

e Rational Agent Controller installed and configured

e Lab source files (Labfiles60.zip) must be extracted to the local system (preferably C:\)

What you should be able to do
At the end of this lab you should be able to:
e Import an existing EAR file
e Start the WebSphere Application Server v6 test environment in profile mode
e Analyze memory usage profiling data

e Analyze Execution Time Analysis data
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Introduction

The profiling capabilities included with IBM Rational Application Developer v6 are aimed at helping
developers recognize and isolate a variety of performance problems before these issues become critical in
a production environment. The types of problems IBM Rational Application Developer v6.0 can help
identify are things such as memory leaks, performance bottlenecks, excessive object creation, and
exceeding system resource limits. .

This exercise will highlight how to profile an application running on WebSphere Application Server v6 using
the profiling capabilities in IBM Rational Application Developer v6. Specifically, you will use these features
to profile the WebSphereBank enterprise application, and analyze this application for possible memory
leaks and performance problems.

WebSphere Application Server

WebSphereBank Application

Web Browser . Serviet

Servlet A

Transfer Funds
Serviet

Transfer
Session
EJB

Java Bean

J2EE Client

Exercise Instructions

Some instructions in this lab may be Windows operating-system specific. If you plan on running the lab on
an operating-system other than Windows, you will need to execute the appropriate commands, and use
appropriate files ( .sh vs. .bat) for your operating system. The directory locations are specified in the lab
instructions using symbolic references, as follows:
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<WAS_HOME> C:\WebSphere60\AppServer /usr/WebSphere60/AppServer
/opt/WebSphere60/AppServer

<IRAD_HOME> C:\Program Files\IBM\Rationa\SDP\6.0

<LAB_FILES> C:\Labfiles60 /tmp/Labfiles60

<TEMP> C:\temp /tmp

<LAB_NAME> IRAD_Profiling

Windows users please note: When directory locations are passed as parameters to a Java program
such as EJBdeploy or wsadmin, it is necessary to replace the backslashes with forward slashes to follow
the Java convention. For example, C:\LabFiles60\ would be replaced by C:/LabFiles60/
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Part 1: Import the WebSphereBank EAR file

1. Start IBM Rational Application Developer.

__a. Select Start > Programs > IBM Rational > Rational Software Development Platform.

__b. For the workspace, specify <LAB_FILES>\IRAD_Profiling\workspace.
2. When IBM Rational Application Developer v6 opens, close the welcome page.

NOTE: If the Auto Launch Configuration Change Alert window appears click the Yes button to change
the auto launch eclipse instance to use when opening IBM Rational Software Development Platform in
the future.

3. Import the WebSphereBank application into Rational Application Developer for testing.

__a. Select File > Import...
___b. Select EAR file and click Next.

__c. Select Browse... and navigate to <LAB_FILES>\IRAD_Profiling\WebSphereBanklnitial.ear
and click Open.

__d. Change the EAR project to WebSphereBank.

___e. Click Finish.

Note: If you receive a Confirm Perspective Switch window, click on the Yes option to continue.

4.  When the import is complete, you will notice several errors in the Problems view. These errors arise
because the WebSphereBankWeb Dynamic Web Project does not include the WebSphereBankEJB
EJB project in the build path. Resolve these errors before you start working with the EJB Mediator
support.

__a. Inthe Project Explorer view, expand Dynamic Web Projects and right click on
WebSphereBankWeb. From the context menu select Properties.

__b. Select Java Build Path on the left, and click the Projects tab. Select the checkbox next to

WebSphereBankEJB.
__c. Click OK.
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__d. Verify that there are no errors in the Problems view. Your Problems view should look like the
following screen capture:

'y "
[ problems 52 . Tasks ‘ Properties ‘ SErvers ‘ = ow =0
0 errors, 0 warnings, 1 info
| Description | REsource | In Folder | Location |
1 CHKIZS00L: java.util.Collection must be seriglizable at ... | Customer.java \WebsphereBankEJB/ejbModulefcomfib... line 53
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Part 2: Application and Cloudscape Setup

1. Backup your server configuration. This will preserve your current server configuration. You will
restore your server configuration at the end of the lab exercise.

__a. Open a Windows Command Prompt and navigate to the following directory:
<RAD_ HOME>\runtimes\base_ v6\bin

__b. Backup the server configuration by issuing the following command:
backupConfig <LAB_FILES>\<LAB_NAME>\backupconfig.zip

2. Start the server with the WebSphereBank project while initializing the database and datasource.

__a. Inthe Project Explorer view, navigate to Dynamic Web Projects > WebSphereBankWeb >
WebContent and right click on index.html.
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__b. Select the Run > Run on Server option to open the Server Selection window.

=

__ . On the Define a New Server page of the Server Selection window make sure the Choose an
existing server option is selected as well as the server WebSphere Application Server v6.0.

Then click on the Next button.
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__d. On the Add and Remove Projects page, make sure that WebSphereBank is added to the
Configured projects list on the right side of the window. Then click on the Next button.

:@;:Eerver Selection

Add and Remove Projects

Modify the projects that are configured on the server

Maove projecks ba the right ta configure therm an the server

fvailable projects; Configured projects;

% WebsphereBank

add |

< Bemove |

Add 8l > |

<< Remove Al |

':: Eal:k _. ........ m Ex'::b ......... I IWI Canl:e|
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__e. Onthe Select Tasks page, click on the Create tables and data sources checkbox. Then click
the Finish button.

@i server selection

Select Tasks

Select the tasks to perform on the server,

Tasks for: WebSphere Application Server wa,0

[V Create tables and data sources:

Create database tables and data sources for current backends configured on the application server

< Back exk = | Eirish I Cancel
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__f. You should see a window like the one below if the database has been setup successfully.

iﬁ:Tahle and Data Source Creator

Database vendor: Cloudscape «5.1
Backend ID used: CLOUDSCAPE_WS1 1

@ Projeck name: WiebSphereBankEJE :l

Data source creation skatus: Mo new data sources were added,

Table creation stakus: Generated From the top-down maps without errors,

Cperations performed for table creation:

CREATE TABLE ACCOUMT:PASS [Successful]
ALTER. TABLE ACCOUNT:PASS [Successful]
CREATE TAELE CUSTOMER:PASS [Successful]
ALTER TABLE CUSTOMER:PASS [Successful]
ALTER. TABLE ACCOUNT:PASS [Successful]

__g. Click OK.

3. Populate the WebSphereBank database with Customer and Account data. For your convenience,
and Application Client Project called CreateAccounts has been included with the WebSphereBank
EAR file you imported at the beginning of this lab exercise.

__a. From the Project Explorer view, expand Application Client Projects > CreateAccounts >
com.ibm.websphere.samples.bank.client.

__b. Right click on CreateAccounts.java, and select Run > Run from the context menu.

__c. Inthe Configurations list, select WebSphere v6.0 Application Client and click the New button at
the bottom of the list.

___d. Enter CreateAccounts for the Name and click Run.
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___e. When the process has completed you should see the following message in the Console view.
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WebSphereBank
WebkSphereBank
WebkSphereBank
WebSphereBank
WebSphereBank
WebkSphereBank
WebSphereBank
WebSphereBank
WebSphereBank
WebkSphereBank
WebSphereBank
WebSphereBank
WebSphereBank
WebkSphereBank
WebSphereBank
WebSphereBank
WebkSphereBank
WebSphereBank
WebSphereBank
WebSphereBank

Createficcounts
Createlccounts
Createlccounts
Createlccounts
Createficcounts
Createlccounts
Createlccounts
Createlccounts
Createficcounts
Createlccounts
Createlccounts
Createficcounts
Createlccounts
Createlccounts
Createlccounts
Createficcounts
Createlccounts
Createlccounts
Createlccounts
Createficcounts
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———————————————————— Begqin ---———————————————
Mary 1 11111

Create customer Mills,
Create sawvings account 101,
Create checking account 100,

Create customer Klein,
Create savings account 201,
Create checking account 200,

Create customer Klein,
Create sawvings account 301,
Create checking account 300,

Create customer Smith,
Create sawvings account 401,
Create checking account 400,

Create customer Anderson, Mary 5
Create sawvings account 501,
Create checking account 500,

Create customer Jones,
Create savings account &01,
Create checking account 600,

———————————————————— Done

Catherine
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Part 3: Memory Leak Analysis

1. Restart the Server in Profile mode.

__a. From the Server view right click on WebSphere Application Server v6.0 and select Restart >
Profile from the context menu.

NOTE: If your server status is indicated as “Stopped”, right click on WebSphere Application Server v6.0
and select Profile from the context menu.

__b. If a Confirm Enablement dialog appears to enable the Profiling and Logging capabilities, click
OK.

__c. You will see a Profile on server configuration window appear. The first step in the configuration
process is to select the appropriate agent. From the Agents tab, expand the agent listed under
unknown[PID:xxxxx]. Select the Java Profiling Agent and click the Add button, circled below, to

add this agent to the selected agents list.

@ Agents | [E] Pruﬁlingl

Agents Selected agents
El--- unknown[PID: 1492] EI--' unknown[PID: 1437]
“-E_ 12EE Request Profiler ~-E_ Java Profiing Agent

)

__d. Click on the Profiling tab. On the Overview sub tab, check the box next to Memory Leak
Analysis — Manual heap dumps from the list of profiling sets.
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__e. To modify the contents of the profiling set, select Automatic Leak Detection from the lower list
under Profiling Type and click Edit.

@»‘ Profile on server ]

Profile on server

= e

E agents (U Profiing |

Overview |E:j Limits | [/ Destination
Select a profiling set:

:.*'=:5>Memnry Leak Analysis - Manual heap dumps
O :,"—‘:bMemu:ur\,-' Leak Analysis - Timed heap dumps
O :,,"'—‘:i‘«‘Meﬂ'uud Coverage Information

O :,,’=:1>Meﬂ'|ud and Line Coverage Information

O ?‘,F:%Probe Example

L+

Add...

Rename,..

e |
Remove |
CGa?

B

Analyze the application for memaory leaks. Automatically identify leak
candidates, See the object reference graph.

Maodify the contents of the profiling set:

Profiling Type |
Automatic Leak Detection

Finish I Cancel

__f. Highlight Automatic leak detection from the list of profile sets in the left. This item should
already have a check mark next to it. Review the values specified for this profiling set. Verify
that the threshold for leak candidates is set to 20. Accept the defaults and click Finish.

__g. Click Finish on the Profile on server configuration dialog.

__h. Notice that the Profiling and Logging perspective opens. A Dialog will appear reminding you to
start Monitoring by selecting “Start Monitoring” from the pop-up menu of the agent in the Profiling
Monitor view. Click OK for this message. You will perform this task in the next step.
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__i. From the Profiling Monitor view, right click on the agent and select Start Monitoring from the
context menu.

Elﬁg_s unknown at IBM-GISSUSPKF 1% [ PID: 39584 ]
El---@f-” «<attached = Profiling (11/15/04 1:34:33 A& :
oo i Automatic Leak Detection Open With

[ Terminate

Reset Data

ftkach bo Agent
Detach from Agent

»= Collect Object References

U Start Monitoring

M Fause Monitaring

2. Access the WebSphereBank application and exercise the Get Balance function

__a. Open a web browser and enter the following URL:
http://localhost:9080/WebSphereBankWeb/index.html

NOTE: You can add the web browser icon to the toolbar for any perspective by selecting Window >
Customize Perspective from the menu. From the Customize Perspective window click on the Commands
tab and scroll down in the Available command groups window and place a check box next to Web

Browser. You should see the @ icon added to the toolbar. To open a web browser, click this icon on the
toolbar.

__b. From your web browser click on the Get Balance link listed on the left.
__c. Enter 100 for the Account Number and click the Balance button.

__d. Repeat the above step and get the balance for accounts 101, 200, 201, 300, 301, 400, 401, 500,
and 501. The purpose for this step is to exercise the GetBalanceServlet before collecting the
first heap dump for our analysis.

3. Manually collect the first Heap Dump

£
4

__a. From the Leak Candidates view click the ( +

L

) icon on the toolbar.

NOTE: If the Leak Candidates view did not automatically open for you when the Profiling and Logging
perspective opened, you can open it by right clicking on the Automatic Leak Detection item underneath the
appropriate agent in the Profiling Monitor view.

__b. After collecting the initial heap dump, you should notice the heap dump listed underneath the
appropriate agent in the Profiling Monitor view.

E-fip unknown at IBM-GIS9USPKF 1X [ PID:3184]
El@'-'-I «<attached = Profiling (11/19/04 10:26: 56 AM)
P & Automatic Leak Detectinn
= Heap dump: id: 1, Name: optHeap, 20041119, 102519,0000003184.00.01.trchoh_—>>

2005 January, 20 IBM Rational Application Developer 6.0 — Lab Exercise Page 13 of 16

IRADv6_ProfilingLab.doc



© Copyright IBM Corporation 2005. All rights reserved

4. The memory leak analysis requires at least 2 heap dumps in order to perform an analysis. Access
the WebSphereBank application once again and repeat step 2 above.

5. Manually collect a second Heap Dump.

e

___a. From the Leak Candidates view, click the == icon on the toolbar.

__b. After collecting the second heap dump you should notice a another heap dump list underneath
the appropriate agent in the Profiling Monitor view.

Bl unknown at IBM-GISSUSPXF 1X [ PID:3184]
El@J <attached > Profiling (11/12/04 10:25:55 AM)
i b Automatic Leak Detedtion

eap dump: id: 1, Mame: optHeap. 20041119, 102519.0000003184.00.01. trcho
=" Heap dump: id: 2, Name: optHeap. 20041119, 102512,0000003184.00.03. trchoh
6. Before doing the memory leak analysis, pause monitoring for the appropriate agent listed in the
Profiling and Monitor view.

__a. From the Profiling Monitor view, right click on the agent and select Pause Monitoring from the
context menu.

7. Analyze heap dumps to identify possible memory leaks.

___a. From the Leak Candidates view, click on the 2 icon on the toolbar.

__b. From the Select Leak Analysis Options dialog select heap dump 1 and 2 from the list and accept
the default threshold of 20. Click OK.

:@:&Im Leak Analysis Options il

Choose two heap dumps from the list below.

Heap dump: id: 1, Name: optHeap. 20041119, 102819.0000003184.00.01.trchoh
[¥lHeap dump: id: 2, Name: optHeap. 2004111%, 102319,0000003134.00,03. trchoh

Threshold

Enter threshold value between 1 and 99 (indusive): I 20 j

The Leak Candidates view displays only leaks with a likelihood value higher than the threshold value.

OK I Cancel
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__c. It may take several minutes to complete the memory leak analysis. When the process completes
you should see one item listed in the Leak Candidates view.

NOTE: If no candidates are found in the first try, turn monitoring back on and try again. The more
attempts to get the balance that are made, the more likely the leak will be spotted.

— s e~

Leak Candidates - unknown at IBM-GISSUEPXF 1X [ PID:4008 ]

Heap dump: id: 3, Mame: optHeap. 20041119.053233.0000004008. 00.05. trchoh
Heap dump: id: 4, Name: optHeap. 20041119.093233.0000004008,00,07. trchoh

<Likelihood | Root of leak | Container type | What's leaking | Mumber of leaks | Bytes leaked I Objects leaked I
100  GetBalanceServlet. 33933296 Vector, 33952596 AccountData 2,100 33,600 2,100

__d. (OPTIONAL) Double click on the GetBalanceServlet item. You will see the Object Reference
Graph and the Object Details views open. The Object Reference Graph should look like the
following. Notice that this graph shows the allocation path for the object leak.

EOEa

Object Referen: aph

Object Reference Graph [Heap : 4] - unknown at IBM-GISSUSPYF 1% [ PID: 4008 ]

Zoom: il Highlight: |GC Roots j

String [F—————————— [char

(________,-/'" AccountData
[Object =

Vector |=

|visible: &6 |Highlighted: 5/5 |iava.lang. GetBalanceserviet. 33933298

NOTE: The previous step can take a very long time to complete. You can monitor the progress or cancel
the process by opening the progress view. To open the Progress view select Window > Show View >
Other from the menu bar. The Progress view can be found under the Basic category.

__e. (OPTIONAL) Click on the Object node in the Object reference graph. Notice that the data
displayed in the Object Details view is updated based upon the item selected in the Object
Reference Graph. The Object Details view provides information about the size, referrers, and

references associated with a particular object in the graph.

8. From the leak analysis we have found that there is a potential object leak in the GetBalanceServlet.
Specifically, there is a static Vector type data member in this class that gets AccountData objects
added to it each time the GetBalanceServlet is invoked. Since this is a static member of the class,
these objects are not garbage collected during the lifetime of the GetBalanceServlet class. To
understand this problem, open the GetBalanceServlet and locate the code that creates this issue.

NOTE: You can find the GetBalanceServlet from the Project Explorer view (J2EE perspective) by
expanding Dynamic Web Projects > WebSphereBankWeb > Java Resources > JavaSource >

com.ibm.websphere.samples.bank.web.
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What you did in this exercise

In this exercise you used the Profiling features available in IBM Rational Application Developer v6 to
analyze the WebSphereBank application for memory leaks and performance problems. This exercise
highlighted how to start the WebSphere Application Server v6 test environment in profiling mode, and
configure profiling sets for memory analysis and execution time analysis.
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