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What this exercise is about 

The objective of this lab is to provide you with an understanding of the tooling support for the EJB 
Mediator.  This lab also demonstrates how to use this technology in association with the JavaServer Faces 
(JSF) support. 

Lab Requirements 

List of system and software required for the student to complete the lab. 

• IBM Rational Application Developer v6.0 with embedded WebSphere Application Server v6.0 Test 
Environment installed. 

• Lab source files (Labfiles60.zip) must be extracted to the local system (preferably C:\). 

What you should be able to do 

At the end of this lab you should be able to: 

• Create a web a new EJB Session Bean Façade  

• Add an EJB Session Bean to the page data of a JSF resource 
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• Add and configure a selection column on a JSF data table  

• Use generated Session Façade methods to query and delete back end data 

 

Introduction 

The EJB Mediator provides an Service Data Object (SDO) data mediator service for applications 
developed using CMP Entity EJBs.  This technology is available to application developers by the create 
session bean façade feature.  This feature allows developers to automatically develop a session bean 
façade to access Entity EJBs.  The methods that are exposed on the session bean façade return SDO 
DataObjects.  This technology can easily be incorporated with JSF technology by adding the Session 
Bean Façade to the page data of a JSF page by an EJB Session Bean data item. 

 

Exercise Instructions 

Some instructions in this lab may be Windows operating-system specific.  If you plan on running the lab on 
an operating-system other than Windows, you will need to execute the appropriate commands, and use 
appropriate files ( .sh vs. .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references, as follows: 

Reference Variable Windows Location AIX/UNIX Location 

<LAB_FILES> C:\Labfiles60 /tmp/Labfiles60 

<LAB_NAME> IRAD_EJBMediator  

Windows users please note: When directory locations are passed as parameters to a Java program 
such as EJBdeploy or wsadmin, it is necessary to replace the backslashes with forward slashes to follow 
the Java convention. For example, C:\LabFiles60\ would be replaced by C:/LabFiles60/ 
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Part 1: Import the WebSphereBank EAR file 

____ 1. Start IBM Rational Application Developer v6.0 with a new workspace. 

__ a. Select Start > Programs > IBM Rational > IBM Rational Application Developer V6.0 > 
Rational Application Developer. 

__ b. When prompted enter <LAB_FILES>\IRAD_EJBMediator\workspace for your workspace. 

__ c. Click OK. 

__ d. When IBM Rational Application Developer v6.0 opens, close the Welcome page 

NOTE: If the Auto Launch Configuration Change Alert window appears click the Yes button to change 
the auto launch eclipse instance to use when opening IBM Rational Software Development Platform in 
the future. 

____ 2. Import the WebSphereBank application into Rational Application Developer for testing. 

__ a. Select File > Import... 

__ b. Select EAR file and click Next. 

__ c. Select Browse... and navigate to 
<LAB_FILES>\IRAD_EJBMediator\WebSphereBankInitial.ear and click Open. 

__ d. Change the EAR project to WebSphereBank. 

__ e. Click Finish. 

____ 3. When the import is complete, you will notice several errors in the Problems view.  These errors arise 
because the WebSphereBankWeb Dynamic Web Project does not include the WebSphereBankEJB 
EJB project in the build path.  Resolve these errors before you start working with the EJB Mediator 
support. 

__ a. In the Project Explorer view, expand Dynamic Web Projects and right click on 
WebSphereBankWeb.  From the context menu select Properties. 

__ b. Select Java Build Path on the left, and click the Projects tab.  Select the checkbox next to 
WebSphereBankEJB. 

__ c. Click OK. 

__ d. Verify that there are no errors in the Problems view.  The Problems view should look like the 
following screen capture: 
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Part 2: Create a Customer Session Bean Façade 

____ 1. Create a new Session Bean Façade for the Customer Entity Bean. 

__ a. From the Project Explorer view, expand EJB Projects > WebSphereBankEJB > Deployment 
Descriptor: WebSphereBankEJB > Entity Beans. 

__ b. Right-click on Customer and select Create Session Bean Facade from the context menu. 

__ c. From the Create Session Bean Facade wizard select Customer from the list of available CMP 
Beans and click Next. 

__ d. From the SDO Creation page click the Show Advanced… button. 

__ e. From the list of customer attributes in the right area, check the box next to [0..*] accounts : 
Account and then check the box next to contained for the accounts : Account CMR Entity. 

 

__ f. Click Next and uncheck the option to add this session bean to a class diagram. 

__ g. Click Finish. 

____ 4. Explore generated code. 

__ a. From the Project Explorer view expand EJB Projects > WebSphereBankEJB > gen/src > 
com.ibm.websphere.samples.ejb.  Explore the CustomerFacadeBean java class and become 
familiar with the methods in this class. 
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__ b. From the Project Explorer view expand EJB Projects > WebSphereBankEJB > gen/src > 
com.ibm.websphere.samples.ejb.sdo.  Explore the static SDO classes included in this 
package. 
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Part 3: Create an Administration Page 

____ 1. Open the Web perspective if it is not already open. 

__ a. From the menu bar select Window > Open Perspective > Web. 

____ 5. Open the admin.jsp file. 

__ a. From the Project Explorer view, expand Dynamic Web Project > WebSphereBankWeb > 
WebContent. 

__ b. Double click on the file admin.jsp. 

____ 6. Add a new EJB Session Bean to the admin.jsp page. 

__ a. From the Page Data view click on the Create new data component… button. 

 

__ b. Select EJB Session Bean from the New Data Component dialog and click OK. 

__ c. On the Select Reference page, click the New EJB Reference… button. 

__ d. Expand WebSphereBank > WebSphereBankEJB and select CustomerFacade and click 
Finish. 
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__ e. From the Select Reference page, select ejb/CustomerFacade and click Next. 

__ f. On the Select Method page, select the getAllCustomerObjects() method and click Finish. 

__ g. Verify that the following item has been added to the Page Data view for the admin.jsp page. 

 

____ 7. Open the Admin.java page code file and review the code that has been generated for this data item. 

__ a. Expand Dynamic Web Project > WebSphereBankWeb > Java Resources > JavaSource > 
pagecode. 

__ b. Double click on Admin.java. 

__ c. Become familiar with the methods and code generated in the Admin.java page code file.  The 
following screen capture lists the methods you should be aware of. 

 

__ d. Enter the following code into the getCustomerFacadeLocalGetAllCustomerObjectsResultBean () 
method.  For your convenience, this code can be found in 
<LAB_FILES>\IRADv6_EJBMediator\snippets\snippet0.txt. 

if (customerFacadeLocalGetAllCustomerObjectsResultBean == null) { 
    try { 
        customerFacadeLocalGetAllCustomerObjectsResultBean = 
getCustomerFacadeLocal().getAllCustomerObjects(); 
    } catch (Exception e) { 
        logException(e); 
    } 
}  
return customerFacadeLocalGetAllCustomerObjectsResultBean; 

__ e. Save and close the file. 
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____ 8. Insert controls for the customerFacadeLocalGetAllCustomerObjectsResultBean data item. 

__ a. From the Page Data view for the admin.jsp page, expand customerFacadeLocal > 
getAllCustomerObjects(). 

__ b. Right click on customerFacadeLocalGetAllCustomerObjectsResultBean and select Insert 
New Controls for… from the context menu. 

__ c. When the Object Type dialog comes up for the accounts collection, accept java.lang.Object as 
the default type by clicking OK. 

__ d. On the Results Form page click the None button to deselect all attributes. 

__ e. Select the check boxes next to the items indicated below.  Use the arrow buttons to the right of 
the list box to arrange the order of items as indicated below. 

 

__ f. Change the Labels for the selected items as indicated above in the screen capture. 

__ g. Click the … button to the right of the accountsAsArray item. 

__ h. On the Configure Data Controls page click the None button to deselect all attributes. 
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__ i. Select the check boxes next to items indicated below.  Use the arrow buttons to the right of the 
list box to arrange the order of items as indicated below. 

 

__ j. Change the Labels for the selected items as indicated above in the screen capture 

__ k. Click Finish on the Configure Data Controls page for the accountsAsArray item 

__ l. Click Finish again to complete the Insert New Controls for 
customerFacadeLocalGetAllCustomerObjectsResultBean process 
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____ 9. Verify that your admin.jsp page looks like the following screen capture. 

 

____ 10. Configure the Customer data table to include: paging support, a selection column to the Customer 
table, and a delete button on the table header to delete selected items 

__ a. Go to the Properties view for the data table component on the admin.jsp page.  To do this, select 
the data table component and go the Properties view.  If you are having trouble selecting the 
data table component, select a column from the table and then go to the Properties view and 
click on the h:dataTable tab. 

 

__ b. Click the Display Options tab underneath h:dataTable. 

__ c. Click the button next to Add a simple pager and enter 5 in the Rows per page field. 

__ d. Click the Row actions tab underneath h:dataTable. 

__ e. Click the Add button next to Add selection column to the table. 

__ f. Remain on the Row actions tab under h:dataTable and click on the Add button next to Add 
action that manipulates selection to header. 

Note:  After adding the selection column to the table in the previous steps you may be taken to the 
hx:inputRowSelect tab.  To complete the previous step you will need to return to the Row actions tab 
under h:dataTable. 

____ 11. Format the balance output text so that it will display a currency type data field. 
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__ a. Click on the balance output component in the table that is highlighted below. 

 

__ b. In the properties view for the h:outputText component select Number for the format and 
Currency for the type. 

____ 12. Create and bind boolean [] data to table selection component. 

__ a. Open the Admin.java file 

__ b. Add the following code right before the closing bracket of the class definition.  For your 
convenience, this code can be found in 
<LAB_FILES>\IRADv6_EJBMediator\snippets\snippet1.txt 

private boolean [] selected; 
public boolean [] getSelected() { 
    if (selected == null) { 
        selected = new 
boolean[customerFacadeLocalGetAllCustomerObjectsResultBean.length]; 
    } 
    return selected; 
} 
 
public void setSelected(boolean [] selected) { 
    this.selected = selected; 
} 

__ c. Save and close the Admin.java file. 

__ d. From the Page Data view for the admin.jsp page, verify that the following item shows up as 
available data. 
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__ e. Drag the selected(boolean[]) data item onto the selection box in the admin.jsp page.  You will 
know this positioned correctly when you see a fly over message as indicated below. 

 

__ f. Verify that the selection component has been bound correctly in the Properties view.  From the 
hx:inputRowSelect tab find the value field and verify that the selection component is 
#{pc_Admin.selected}. 

____ 13. Rename the submit button, and add the action method that will handle deleting the Customer 
records selected from the selection component 

__ a. Select the Submit button that was added to the top of the admin.jsp page in an earlier step. 

__ b. In the Properties view select the Display options tab under hx:commandExButton, then change 
the value of the field Button label to Delete. 

__ c. Switch to the Quick Edit view. 

__ d. Select the Command item in the left frame and click in the editor frame of the Quick Edit view. 

__ e. Add the following code right above the return statement.  For your convenience, this code can be 
found in <LAB_FILES>\IRADv6_EJBMediator\snippets\snippet2.txt. 

String result = "success"; 
for (int i = 0; i < selected.length; i++) { 
    if (selected[i]) { 
        System.out 
        .print("WebSphereBank >> Deleting customer: " 
               + 
customerFacadeLocalGetAllCustomerObjectsResultBean[i]); 
        try { 
            customerFacadeLocal 
            
.deleteCustomer(customerFacadeLocalGetAllCustomerObjectsResultBean[i]
); 
        } catch (Exception e) { 
            result = "failure"; 
            e.printStackTrace(); 
        } 
    } 
} 
customerFacadeLocalGetAllCustomerObjectsResultBean = null; 
selected = null; 
return result; 

__ f. Delete the original return “”; statement. 

____ 14. Align the Delete button to the left of the data table. 

__ a. Select the Delete button and locate the hx:panelBox tab in the Properties view. 

__ b. For the Size specify the Width as 100%. 

__ c. For the Alignment select Left for Horizontal and Middle for Vertical. 
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____ 15. Save the admin.jsp file. 
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Part 4: Application and Cloudscape Setup  

____ 1. Backup your server configuration.  This will preserve your current server configuration. You will 
restore your server configuration at the end of the lab exercise. 

__ a. Open a Windows Command Prompt and navigate to the following directory: 

<RAD_HOME>\runtimes\base_v6\bin 

__ b. Backup the server configuration by issuing the following command: 

backupConfig “C:\Program Files\IBM\Backup.zip” 

____ 2. Start the server with the WebSphereBank project while initializing the database and datasource. 

__ a. In the Project Explorer view, navigate to Dynamic Web Projects > WebSphereBankWeb > 
WebContent and right click on index.html. 

 

__ b. Select the Run > Run on Server option to open the Server Selection window. 

__ c. On the Define a New Server page of the Server Selection window make sure the Choose an 
existing server option  is selected as well as the server WebSphere Application Server v6.0.  
Then click on the Next button. 
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__ d. On the Add and Remove Projects page, make sure that WebSphereBank is added to the 
Configured projects list on the right side of the window.  Then click on the Next button. 

 

__ e. On the Select Tasks page, click on the Create tables and data sources checkbox.  Then click 
the Finish button. 
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__ f. You should see a window like the one below if the database has been setup successfully. 

 

__ g. Click OK. 

____ 3. Go to the administrative console and wait for WebSphereBank application to show up. 

__ a. Open a Web Browser and navigate to the following URL: 

http://localhost:9060/ibm/console 

__ b. When prompted for a User ID, enter wsdemo to log in. 
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__ c. Select Applications -> Enterprise Applications.  Watch for WebSphereBank to appear in the list of 
applications. 
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Part 5: Test Application  

____ 1. Populate the WebSphereBank database with Customer and Account data.   For your convenience, 
and Application Client Project called CreateAccounts has been included with the WebSphereBank 
EAR file you imported at the beginning of this lab exercise.  

__ a. From the Project Explorer view, expand Application Client Projects > CreateAccounts > 
appClientModule > com.ibm.websphere.samples.bank.clients. 

__ b. Right click on CreateAccounts.java, and select Run > Run… from the context menu. 

__ c. In the Configurations list, select WebSphere v6.0 Application Client and click the New button at 
the bottom of the list. 

 

__ d. Enter CreateAccounts for the Name and click Run. 
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__ e. When the process has completed you should see the following message in the Console view. 

 

____ 4. Access the admin.jsp page. 

__ a. Open a web browser and navigate to the following URL. 

http://localhost:9080/WebSphereBankWeb/index.html 
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__ b. Click on Customer Administration at the bottom of the menu bar and make sure that you Verify 
that you see the following page in your browser 

 

____ 5. Select the check box next to Mills and Smith and click the Delete button at the top of the table. 

____ 6. Verify that the customers have been deleted. 

____ 7. Remove the WebSphereBank bank application from the application server 

__ a. From the Server view right click on the server and select Add and Remove projects  

__ b. In the Configured projects list select WebSphereBank and click the Remove button 

__ c. Click Finish 

____ 8. Stop the server 

__ a. From the Server view, right click on the server and select Stop from the context menu 
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Part 6: Restore the Server Configuration 

____ 1. Restore your server configuration.  This will return your server configuration to its original state. 

__ a. Open a Windows Command Prompt and navigate to the following directory: 

<RAD_HOME>\runtimes\base_v6\bin 

Restore the server configuration by issuing the following command: 

restoreConfig “C:\Program Files\IBM\Backup.zip” 

__ b. Using explorer navigate to the following directory 

<RAD_HOME>\runtimes\base_v6\cloudscape 

__ c. Delete the topDownDB folder.  This will remove the database files generated during the lab. 
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What you did in this exercise 

In this lab exercise you built and tested an administrative customer interface for the WebSphereBank 
application.  The application you built in this lab demonstrates how to configure and use the Create 
Session Bean Façade capabilities (SDO and EJB Mediator technology).  Additionally, this lab 
demonstrates how to add an EJB Session Bean as a data source to a JSF page. 
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Solution Instructions 

If you are unable to get this lab to work, and would like to see the results, you can follow these steps to 
import the solution to this lab.  You will then be able to browse the solution for examples of how the data 
components look and function in the final application. 

____ 1. Start IBM Rational Application Developer. 

__ d. Select Start > Programs > IBM Rational Software Development Platform > Rational 
Software Development Platform. 

__ e. For the workspace, specify <LAB_FILES\IRAD_EJBMediator\workspace. 

____ 9. When IBM Rational Application Developer v6 opens, close the welcome page. 

____ 10. Import the WebSphereBank Application into Rational Application Developer for testing. 

__ f. Select File > Import... 

__ g. Select Project Interchange and select Next. 

__ h. Select Browse... and navigate to 
<LAB_FILES>\IRAD_EJBMediator\solution\EJBMediator.zip and select Open. 

__ i. Click Select All. 

__ j. Click Finish. 

____ 11. Now you can test the solution following the steps outlined in Part 5. 
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