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This presentation will provide an overview of Rational® Unified Process
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The goal is to provide a general overview of new features in the Rational Unified Process 

(RUP) product that is packaged with IBM Rational Application Developer V6.0.  

Prerequisite:

IBM Rational Application Developer V6.0 with RUP plug-ins (installed by default 

with IBM Rational Application Developer V6.0)

IBM Rational Application Developer V6.0 Topology and Terminology
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Agenda

What is RUP? 

Features

Process Browser

Process Advisor

Process Search

developerWorks Search

RUP Configuration

Process Preferences

How to start using RUP?

L2 Support Information

Summary / References / Glossary
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Rational Unified Process is software that provides a company or team with robust 
processes in order to produce high quality software.  The goal is to structure processes in 
order to create a high quality product. A process enables successful practices to be 
repeated, and unsuccessful practices to be eliminated or improved upon. RUP in particular 
provides: 

Guidance on best practices 

A set of activities, roles, and artifacts your process might need to consider with guidance 
on when these are needed in your process

Detailed information to help you effectively apply the techniques that you decide are 
appropriate for your project. 

Guidance to help you tailor the process to address specific process-related problems. 

RUP comes with predefined roles that you can assign to people on your team along with 
the responsibilities and activities that these roles will perform.  To help these roles fulfill 
these responsibilities and activities, RUP provides a great deal of helpful information, 
including Guidelines, Tool Mentors, White Papers, Concepts, and labeled Artifacts for each 
role.

RUP is meant to be used from the planning stages of a project.  When you get to the 
code, you would be deep into the processes that have already been set up.  Therefore, as 
a developer, you would not start with some code and then try to incorporate RUP.
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Process Browser (RUP Browser) 

Provides browser functionality for viewing RUP information, including 

personalization of process views.

Allows advanced search filtering on topics, and page type (new after the SR3 

update) 

Includes a Glossary and a link to IBM Rational Application Developer V6.0 to help 

you get instant help on the page you are viewing.
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Shown here is the IBM Rational Application Developer V6.0 Process Browser. In this 

graphic, the Process View is displayed in the browser, in which RUP content is organized 

into categories.  Notice the MyRUP view on the 3rd tab.  You create this view by clicking 

the blue Save As icon, which is the blue disk with … underneath, just above and to the 

right of the MyRUP tab.  Once you have your View created, you can drag and drop 

pertinent objects by clicking the Customize View icon, which is the second from the end, 

next to red X. This shows you the objects from the Getting Started view that can be 

dragged and dropped on your MyRUP view.
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Here again is the IBM Rational Application Developer V6.0 Process Browser showing the 

objects from the Developer view that can be dragged and dropped on your MyRUP view.
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The Process Advisor or RUP Advisor

Is an IBM Rational Application Developer V6.0 View.

Provides easy access to Process Browser content

Provides real-time dynamic RUP process guidance based on user context when 

viewing a class diagram or UML visualization.
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The Process Advisor attaches as a view inside IBM Rational Application Developer V6.0, 

unlike the Process Browser that undocks itself from IBM Rational Application Developer 

V6.0.
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Process Search

Provides search with advanced filtering and tight integration with Eclipse search.

Advanced search not available with pre-Atlantic versions of RUP.

Access Process Search from top menu in IBM Rational Application Developer V6.0.

Search > Search…
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DeveloperWorks Search

Allows you to search DeveloperWorks Web contents from within IBM Rational 

Application Developer V6.0 with seamless integration with Eclipse searching. 

DeveloperWorks Search is not associated with RUP, but the RUP development 

team did create this functionality.

Access developerWorks Search from top menu in IBM Rational Application Developer 

V6.0.

Search > Search…
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The RUP(r) Configuration for Java (tm) Developers is built on top of the RUP Small Projects 
template configuration. It includes the User-Experience Modeling Plug-In and the 

RUP for J2EE v1.3 Plug-In. It also includes tool mentors for Rational XDE Developer - Java 
Platform Edition, but not for Rational XDE Developer - .NET Edition. It 

also does not include tool mentors for Rational Rose, Rational Rose RealTime, Rational SoDA, or 
Rational Quality Architect.

The RUP(r) Configuration for Java (tm) Developers was built to provide users of Rational XDE 
Developer - Java Platform Edition with a process they can use to do their job 

as efficiently and effectively as possible when the assumption cannot be made that they have 
installed and are using RUP on their projects. It is intended for use by individual developers whose 

team has not yet adopted a version of RUP that has been right-sized for their project. For XDE 
users that are part of a team that is using a customized version of the RUP, 

the customized version should be used instead of this configuration.

Focus is on the implementer role, all based on the RUP configuration you are pointing to. It can 
Recognize older configurations (SR2), so you might use 

the RUP in IBM Rational Application Developer to migrate.  Only provides checklists and 
guidelines to follow, with no verification that a process is being followed.

IBM Rational Application Developer V6.0 provides:

The RUP(r) Configuration for Java (tm) Developers

IRSAv6.0 provides:

The RUP(r) Configuration for Java (tm) Developers + process guidelines, more UML diagrams, a 
little more due to a larger scope, but still not full RUP.

RUP full product provides:

Business modeling, lifecycle modeling, and the ability to tailor a process
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RUP Configuration directory is under your IBM Rational Application Developer V6.0 install 

directory.  Clicking on the index.htm will start the Process Browser.  The Process Browser 

can run outside of IBM Rational Application Developer V6.0.  However the Process 

Advisor is built into IBM Rational Application Developer V6.0.  You will need Java version 

1.4.1 to run the Process Browser, since the menu tree is an applet that requires Java 

1.4.1.
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Process Preferences

Access by clicking Window > Preferences > Process.

From the Process Preferences, you can…

Point to the RUP configuration of your choice

Select advanced search filtering based on role, topics and page type (new to SR3, 

the latest level, of RUP)
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Use the Process Preferences screen to start sizing down your roles, then topics that you 

would want the Process Advisor to display.
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To start  using RUP

1. Set Role filter

Open Window > Preferences > Process

Deselect any Roles you will not use.

2. Build a MyRUP page in Process Browser

Open Process Browser

Select Process View

Select Save As and then save as MyRUP

A view will be created where you drag and drop the desired items for your role from 

the Developer and Getting Started views.  Delete unnecessary objects.
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To start using RUP in IBM Rational Application Developer V6.0 (cont.)

3. Begin Browsing through the Getting Started section of the Process Browser Process 

View.

3.5  Hidden functionality

Open the file system and navigate to 

<<IRAD_HOME>>\rad\eclipse\plugins\com.ibm.rup_6.0.0

Change rup.displaySearchInAdvisor from false to true in rup.properties file in order 

to turn on Search bar for Process Advisor.  Save file.

4. In IBM Rational Application Developer V6.0, create a class diagram for a Java or Web 

project. Add some objects (for example: existing session bean or class).



IRADv6_Using_RUP.ppt Page 18 of 26

To start using RUP in IBM Rational Application Developer V6.0 (cont.)

5. Open Process Advisor (Help > Process Advisor, in IBM Rational Application Developer 

V6.0) 

The search text and Process Advisor contents will change with the object you are 

clicking on in the class diagram. Process Advisor becomes dynamic when working 

with a class diagram (UML).

RUP is meant to be used beginning during the planning stages of a project. By the time 

a developer would use it, management would have already formulated a plan.  

RUP has an enormous amount of guidance information.  The trick is to deselect 

anything you will not use and focus on just what you need for your role.
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To start using RUP in IBM Rational Application Developer V6.0 (cont.)

Begin Browsing through the Getting Started section of the Process Browser Process View.

Open the file system and navigate to 

<<IRAD_HOME>>\rad\eclipse\plugins\com.ibm.rup_6.0.0 

Change rup.displaySearchInAdvisor from false to true in rup.properties file in order to turn 

on Search bar for Process Advisor.  Save file.

In IBM Rational Application Developer V6.0, create a class diagram for a java or web 

project. Add some objects (ex: existing session bean or class).
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In order to perform problem determination, you should collect:

An archive file containing the RUP Configuration directory (located under IBM 

Rational Application Developer V6.0 root directory)

A Copy of the .log file from the \.METADATA folder of the workspace in error
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Location of RUP files and directories in IBM Rational Application Developer V6.0?

rup.properties and plugin.properties files are located in:

<<IRAD_HOME>>\rad\eclipse\plugins\com.ibm.rup.context_6.0.0

<<IRAD_HOME>>\rad\eclipse\plugins\com.ibm.rup.core_6.0.0

<<IRAD_HOME>>\rad\eclipse\plugins\com.ibm.rup_6.0.0

Change rup.displaySearchInAdvisor from false to true in rup.properties file in order to turn 

on Search bar for Process Advisor.  False by default.  Turning this to true is the only way 

to truly view the Process Advisor dynamic capabilities when working in a class diagram.

RUP Configuration home is located in:

<<IRAD_HOME>>\RUP Configuration\application developer

Contains all content displayed by the Process Browser and Process Advisor.  Content is 

static, however the Process Browser will dynamically organize this content with every 

request.



Process Advisor Search Filters and RUP Configuration pointer are located in:

Windows > Preferences > Process.  
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Where is RUP in IBM Rational Application Developer V6.0?

<<IRAD_HOME>>\eclipse\plugins\com.ibm.rup.rationalzone_1.0.0

holds the Resources.properties file which controls the developerWorks search 
attributes.

<<your workspace>>\.METADATA\.log

Any errors produced by RUP are written to the .log file.  Check this .log file for 
process or RUP errors.

Windows > Preferences > Process.  

Location of Process Advisor Search Filters, where you choose your roles and limit 
any Topics to be shown in the Process Advisor.

Location of RUP Configuration you are using.  This is where you could point to a full 
version of RUP while still using IBM Rational Application Developer V6.0



IRADv6_Using_RUP.ppt Page 23 of 26

Summary

RUP helps your company or team to use robust processes in order to produce a high 

quality product

RUP has many new functional enhancements…

Process Browser

Process Advisor

Process Search

developerWorks Search

RUP Configuration

Process Preferences

Support information
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References

DeveloperWorks website for RUP

http://www-136.ibm.com/developerworks/rational/products/rup

Can find more RUP plug-ins like the RUP Plug-in for IBM WebSphere 

Application Server here.

RUP Product Website

http://www-306.ibm.com/software/awdtools/rup/

IBM Rational Application Developer V6.0 Help (Help > Help Contents)

In the help app, under “Introduction to Rational Application Developer”, click 

to open “Accessing Rational Unified Process guidance”.
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Where can I learn more about…

Introducing the RUP into an organization

http://www-128.ibm.com/developerworks/rational/library/916.html

Introducing the RUP buffet (great way to learn RUP)

http://www-128.ibm.com/developerworks/rational/library/975.html

Book review — The Rational Unified Process Made Easy: A Practitioner's Guide to 

the RUP

http://www-128.ibm.com/developerworks/rational/library/2069.html

True Confessions of a RUPPIE 

http://www-128.ibm.com/developerworks/rational/library/2249.html


