
  

  

      

   

             
            

          

© 2012 IBM Corporation 

IBM Tivoli Service Automation Manager Version 7.2 

Troubleshooting self-service user interface 

In this training module you will learn how to troubleshoot the Tivoli® Service Automation 
Manager self-service web 2.0 user interface. The training module also demonstrates how 
to run debug tools on both server-side code and browser code. 
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Objectives 

When you have completed this training module, you can accomplish these tasks: 

� Describe the system components connected to the Tivoli Service Automation Manager V7.2 
self-service user interface 

� Determine whether a specific type and revision of internet browser is recommended for 
usage with Tivoli Service Automation Manager V7.2 

� Check Tivoli Service Automation Manager V7.2 self-service user interface browser settings 

� Check workstation screen resolution settings 

� Use the TPAE WebSphere® Application Server diagnostic trace feature to capture log 
messages relevant to TSAM V7.2 self-service user interface operation 
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When you have completed this training module, you can accomplish these tasks: 

- Describe components connected to the self-service user interface 

- Determine whether the internet browser is recommended 

- Check browser settings 

- Check for acceptable screen resolution settings 

- Use the WebSphere Application Server diagnostic trace and check for relevant log 
messages 
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Tivoli service automation manager V7.2 self-service user interface 
components and interfaces 

� System components and interfaces (simplified) 

3 Troubleshooting self-service user interface © 2012 IBM Corporation 

The self-service web 2.0 user interface is a Tivoli Process Automation Engine REST-
based application interface. This interface is part of Tivoli Service Automation Manager 
deployments. Not all data goes through a Tivoli Service Automation Manager element. 
Some data is retrieved directly from other IBM Tivoli products such as Tivoli Service 
Request Manager® or Tivoli Provisioning Manager. All of these IBM Tivoli products are 
based on data models that can be accessed through the interface. For security reasons 
Maximo® Business Object database tables are not directly accessible. Using the REST-
based interface exposes only the data that a user is authorized to access. 
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Supported browsers 

� IBM Tivoli Service Automation Manager V7.2 self-service user interface supports these 
browsers 

– Internet Explorer 8 
• Requires Silverlight 
• Requires Ajax 

– Mozilla firefox 
• 3.5 

� 3.6 
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Firefox 3.5, 3.6, and Internet Explorer 8 are the supported browsers. Internet Explorer 7 is 
no longer officially supported. Internet Explorer browsers require Silverlight and Ajax 
enablement. 
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Recommended browser settings 

These browser settings are recommended: 

� Minimum resolution: 1024x768 

� JavaScript: enabled 

� CSS: enabled 

� SSL: enabled 

� Cookies: enabled 
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When self-service user interface problems occur the first thing to check are the internet 
browser settings. The minimum resolution setting is 1024x768. JavaScript, CSS, SSL, and 
cookies should be enabled. 

tsing_ss_web_ui.ppt Page 5 of 22 



  

     

    

         

      

       
     

   

              
   

Checking workstation screen resolution (example) 

Checking the workstation screen resolution in a Windows OS environment: 

� Self-service user interface minimum recommended setting is 1024x768 

� Go to Control Panel and click Adjust Screen Resolution 
– View the existing screen resolution setting 
– Adjust if needed 
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Remember that the screen resolution should be set at or higher than the recommended 
minimum setting of 1024x768. 
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© 2012 IBM Corporation 7 Troubleshooting self-service user interface 

Check firefox javascript enabled 

Check firefox JavaScript enabled 

Check that JavaScript is enabled for Firefox browsers by going to Tools > Options > 
Content. The Enable JavaScript check box should be checked. Advanced JavaScript 
Settings should allow scripts to Move or resize existing windows and Disable or 
replace context menus. 
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Check internet explorer eight javascript enabled 

Check internet explorer eight JavaScript enabled 
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Check that JavaScript is enabled for Internet Explorer eight browsers by going to Tools > 
Internet Options > Security and click Custom level. On the popup window scroll to 
Scripting. Active scripting should be set to Enable. 
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Check firefox css enabled 

Check firefox CSS enabled 

From the Firefox toolbar click View > Page Style. CSS is enabled when Basic Page 
Style is checked. 
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Check internet explorer css enabled 

Check internet explorer eight CSS enabled 
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For Internet Explorer 8 the CSS functionality is enabled when CSS is not checked in the 
Disable menu. 
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Check firefox secure socket layer enabled 

Check firefox SSL enabled 
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Firefox SSL is enabled by going to Options > Advanced > Encryption > Protocols and 
checking the Use SSL 3.0 check box. 
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Check internet explorer eight secure socket layer enabled 

Check internet explorer eight SSL enabled 
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For Internet Explorer 8 check that SSL is enabled by going to Tools > Internet Options > 
Advanced > Settings and checking the Use SSL 3.0 check box. 
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Check firefox cookies enabled 

Check firefox cookies settings 

Check the cookie settings for the Mozilla Firefox web browsers by going to Tools > 
Options > Privacy. The check boxes for Accept cookies from sites and Accept vendor 
cookies should be checked. 
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Check internet explorer eight cookies settings (1 of 2) 

Internet options 

To check Internet Explorer 8 web browser cookie settings start out by going to Internet 
Options. 
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Check internet explorer eight cookies settings (2 of 2) 

Privacy tab 

Once at Internet Options go to the Privacy Tab. Change the Settings to an Internet 
zone that allows enablement of the required cookies. 
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Server-side code debugging 

Server-side code debugging: 

� Server side uses the WebSphere Application Server log 
– Activate log level for package com.ibm.tivoli.SimpleSRM to FINEST 
– WebSphere Application Server administrative console > Logging and Tracing > MX 

Server > Diagnostic Trace > Change Log Level Details 

� The server side log comprises logs from SimpleSRM servlets 
– User exceptions typically sent 
– Non-caught errors from user interface 
– Offering icons, some authentication, help redirection, … 
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The standard WebSphere log is used for debugging server-side code. Activate the log for 
the package com.ibm.tivoli.simplesrm and set the log level to FINEST. To accomplish this 
go to the WebSphere Application Server administrative console. From the Logging and 
Tracing menu follow the path through MXServer to Diagnostic Trace. Finally, go to 
Change Log Level Details. The server-side log includes the logs from the SimpleSRM 
servlets (offering icons, some of the authentication, help redirection...). User interface 
exceptions are typically sent to the server log. 
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Browser code debugging 

Browser code debugging: 

� The browser client code consists of HTML, CSS, and JavaScript code 

� The main part of the code is written with JavaScript using the DoJo library 

� On the client side there are different tools for analyzing web pages and the JavaScript 
console: 

– For Firefox use Firebug 
– IE8 includes the Developer Tools window 
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The biggest part of debugging happens on the browser code. Firebug is used for viewing 
the Mozilla Firefox browser logs. The Developer tools window is used for viewing Internet 
Explorer 8 browser logs. 
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Internet explorer eight developer tools 

Internet explorer eight developer tools 

� Initiated by pressing F12 

� Can be used to perform code debugging of these: 
– HTML 
– JavaScript 
– CSS 

18 Troubleshooting self-service user interface © 2012 IBM Corporation 

Internet Explorer 8 comes with an integrated debugging tool. This tool can be initiated by 
pressing the F12 key. It comes with many JavaScript debugging tools and tools for 
debugging HTML and CSS coding. 
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Firebug 

To install Firebug: 

� Click Tools > Add-ons > Get add-ons > 
search for Firebug 

� Restart your browser window 

� To start Firebug, in the browser status bar 
click the bug icon 

This window displays 

19 Troubleshooting self-service user interface	 © 2012 IBM Corporation 

Firebug is the reference tool for debugging Mozilla Firefox. Activate Firebug only when 
needed because it consumes a lot of memory and processor capacity. The console Net 
tabs should be activated. The console log shows the “standard output” for JavaScript, and 
the Net tab shows the requests (GET, PUT, POST). When the Net tab is activated, 
requests also show up in the Console tab. 

To facilitate JavaScript debugging, include the debug parameter in 
theURL:http://hostname:9080/SimpleSRM/index.jsp?debug=2. 
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Summary 

Now that you have completed this training module, you can accomplish these tasks: 

� Describe the system components connected to the Tivoli Service Automation Manager V7.2 
self-service user interface 

� Determine whether a specific type and revision of internet browser is recommended for 
usage with Tivoli Service Automation Manager V7.2 

� Check Tivoli Service Automation Manager V7.2 self-service user interface browser settings 

� Check workstation screen resolution settings 

� Use the TPAE WebSphere Application Server diagnostic trace feature to capture log 
messages relevant to Tivoli Service Automation Manager V7.2 self-service user interface 
operation 
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Now that you have completed this training module, you can accomplish these tasks: 

- Describe components connected to the self-service user interface 

- Determine whether the internet browser is recommended 

- Check browser settings 

- Check for acceptable screen resolution settings 

- Use the WebSphere Application Server diagnostic trace and check for relevant log 
messages 
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Feedback 

Your feedback is valuable 

You can help improve the quality of IBM Education Assistant content to better meet your 
needs by providing feedback. 

� Did you find this module useful? 

� Did it help you solve a problem or answer a question? 

� Do you have suggestions for improvements? 

Click to send email feedback: 

mailto:iea@us.ibm.com?subject=Feedback_about_tsing_ss_web_ui.ppt 

This module is also available in PDF format at: ../tsing_ss_web_ui.pdf 
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You can help improve the quality of IBM Education Assistant content by providing 
feedback. 
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