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IBM® WebSphere® Application Server V7 — LAB EXERCISE

Developing a basic Java EE 5 application with Rational
Application Developer
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What this exercise is about

The objective of this lab is to provide you with an understanding of the new tools in Rational Application
Developer V7.5 that enable you to create Java EE 5 applications and deploy them to WebSphere
Application Server V7.

You will create a basic Java EE5 application that uses EJB 3.0, JPA, JSP, and JSF components, and
deploy that application to WebSphere Application Server V7.

The application is a basic banking application. It supports creating new customers, creating new accounts,
and transferring funds between accounts.

This exercise is designed to teach you how to use the new tools in Rational Application Developer, and is
not a primer on coding Java EE 5 applications. The majority of the code in this exercise is generated
automatically by Rational Application Developer. The session bean logic is provided for you in code
snippets, which you can examine to see how they work.

The primary purpose of this exercise is to demonstrate the use of the new Java EE 5 tools in Rational
Application Developer V7.5. It is not necessarily intended to demonstrate "best practices" for overall
application design.

This lab is provided AS-1S, with no formal IBM support.
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Lab requirements
List of system and software required for the student to complete the lab.
e WebSphere Application Server V7
< Rational Application Developer for WebSphere Software V7.5

e The “Labfiles70” directory, which can be downloaded from the IBM Education Assistant Web site
(http://lwww.ibm.com/software/info/education/assistant/)

What you should be able to do
At the end of this lab you should be able to:

e Configure Rational Application Developer for WebSphere Software to work with an existing installation
of WebSphere Application Server.

e Create and configure a Derby database instance using Rational Application Developer’s data tools.

« Use the new JPA tools in Rational Application Developer to create JPA Entities from a set of database
tables.

e Use the EJB wizard to create EJB 3.0 session beans.
e Build a Web application to access and modify the database using the Web tools and JSF components.

« Deploy an application to WebSphere Application Server.

Exercise instructions

Some instructions in this lab are Windows® operating-system specific. If you plan on running the lab on an
operating-system other than Windows, you will need to run the appropriate commands and use
appropriate files (.sh or .bat) for your operating system. The directory locations are specified in the lab
instructions using symbolic references, as follows:

Reference variable Windows location UNIX® or Linux™ locations

<WAS_HOME> C:\WebSphere\AppServer lusr/\WebSphere/AppServer

lopt/WebSphere/AppServer

<RAD_HOME> C:\Program Files\IBM\SDP
<LAB_FILES> C:\Labfiles70 /tmp/Labfiles60
<TEMP> C:\temp ftmp
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Part 1: Prepare Rational Application Developer

In this section you will create a new Rational Application Developer workspace, and configure Rational
Application Developer to work with an existing local installation of WebSphere Application Server V7.

1. Launch Rational Application Developer

___a. Open Rational Application Developer from the “IBM Software Delivery Platform” program group
in the Start menu.

2. When prompted for a workspace, as shown in the screen capture below, enter
C:\LabFiles70\workspace, and click OK.

#@® workspace Launcher |

Select a workspace

R.ational Application Developer stores waour projects in a folder called a warkspace,
Choose a workspace folder to use for this session,

Workspace: IC:'I,LaI:uFiIes?D'I,wnrkspace| j Browse, ., |

[ Use this as the default and do not ask again

Ik I Zancel

3. When the workspace has been created, you will be presented with the “Welcome” tab. Note a lot of
useful information is available from this tab, including several sample applications. These samples
will not be used in this exercise, but you may want to return to them later by selecting “Welcome”
from the Help menu. For now, close the Welcome tab by clicking the “x” on the tab header.

4. Configure the local installation of WebSphere Application Server as a test server in Rational
Application Developer.

___a. Click the Servers tab on the bottom panel.
__b. Right-click in the empty pane, and select New > Server.

___c. Click Add... in the “Define a new server” window.
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___d. Enter C:\WebSphere\AppServer (or the location of your WebSphere Application Server
installation, if different) in the “Installation directory” field, as shown below.

a Mew Server Runtime Environment =]

YWebSphere Runtime =
Specify the WebSphere Application Server installation directory,

MName:

I WebSphere Application Server «7.0

Installation directory:

| c:websphereldppSerer| Browse, ., |

(For example, fopk/\ebSphere/dppServer)

(7 = Back Mesxk = | Finish I Cancel

___e. Click Finish.

___f. The window will close, returning you to the “Define a new server” window. Click Next.

___g- Uncheck the Run server with resources in the workspace check box, so that all application
resources will run on the defined server.
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___h. Enter wsdemo in the “Password” field. The window should be configured as shown below.

Iﬁ New Server !IEI E

WebSphere Server Settings

Input setkings For connecking ko an existing WebSphere Application Server,

@

—

WebSphere profile name: AppSrvll

j Configure profiles. ..

—Server connection bypes and administrative porks
¥ autamatically determine connection setkings

" Manually provide connection settings

Conneckion Tyvpe | Port | Default port | Descripkion

I 1P A3 633 Recommended For local servers
¥ R 2809 2809 Cesigned ko improwve communicak
¥ soap a0 a5a0 Designed ko be mare Firewall conm
1| |

™ Run server with resources within the workspace;

W Security is enabled on this server

Current ackive authentication setkings:

ser I I wademo
Password: I T
WebSphere server name: I server]
Test Connection
(7) < Back ek = | Finish I Cancel
___i. Click Finish.
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Part 2: Create a Java EE 5 project

In this section you will create a Java EE 5 project, which will contain Web and EJB modules. Your project
will contain neither an application deployment descriptor nor an EJB deployment descriptor, as they are
not required parts of a Java EE 5 application. You will also see how to add JSF and JPA support to a
project.

5. Rational Application Server starts new workspaces in the Java EE perspective. In this perspective,
the rightmost panel is titled “Project Explorer”. Use this perspective to create a new Java EE 5
project.

__a. Right-click in the Project Explorer panel and select New > Enterprise Application Project.

___b. Inthe “New application EAR project” window, enter the project name EE5Bank.

___c. Ensure the “Target Runtime” is WebSphere Application Server v7.0.

__d. Ensure that the “EAR version” field is set to 5.0. The window should resemble the image below.
@ New EAR Application Project H=]

EAR Application Project
Create a EAR application,

Project name: | EESEank:.

—Project contents:
¥ Use default

Direchmry | ZiLabFiles70hwiorkspace\EESEank Browse, ., |

— Targek Runtime
I'-.-'-.-'el:uSphere Application Server «7.0 j Mew. .. |

—EAR wersion

J5.0 =l
— Configuration
Maodify. .. |

& good skarking point For waorking with WebSphere spplication Server «7.0 runkime.
Additional Facets can later be installed to add new Functionality ko the project.

Cefault Configuration For WebSphere Spplication Server w7.0

(7) = Back Mext = | Finish I Cancel

___e. Click Next.
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___f. Note that on the next panel, the “Generate Deployment Descriptor” check box is unchecked by
default. This is because application deployment descriptors are optional in Java EE5. Leave the
box unchecked, as you will not be using the deployment descriptor in this exercise.

___g. Click New Module...
__h. Uncheck the boxes next to Application client module and Connector module.
___i. Keep the default names for the modules as shown below, and click Finish.

New J2EE Module

Create a new JZEE module for the selected module tvpe

¥ cCreate defaulk modules

[ application client moduls |EESBankCIient

W EJB module | EESBankEE
v wWeb module | EESBankiweb
I Connector module; [ EESBankonnector

(7) = Back Next = | Finish I Cancel

___j. Click Finish again to complete the wizard.
6. Add Java Persistence API support to the EJB project.

___a. Right-click EE5BankEJB in the Project Explorer, and select Properties from the contextual
menu.

__b. Click Project facets in the left panel.

___¢. Check the box next to Java Persistence.

___d. Click OK to close the properties window.
7. AddJavaServer Faces support to the Web project.

___a. Right-click EE5BankWeb in the Project Explorer, and select Properties from the contextual
menu.

___b. Click Project facets in the left panel.
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___c. Click Modify Project.

___d. Check the boxes next to Faces support (base), Faces support (enhanced components),
JavaServer Faces, and JSTL as shown below.
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Project Facets i
Configurations: I{custum> ;] Save fs,., Delete
Wersion Details IRuntimes |
i = 6.1
[ Bl Defaul style sheat (€55 file) e |IEE Add Websphere XDoclet support 6.1
‘O = Default synchronization policy for O3 repository 1.0 WebSphere Doclet annatations suppork
D | Design-Time Page Template support 1.0
: = Requi f the Following Facets:
= =| Dynamic Page Template support (Struks Tiles) 1.1 TR S BT e
i Dynamic Web Module 2.5 [¥] Java1.3
|=| Faces support (base) 7.0 |1| Java 1.4
‘0 =l Faces support {compaonent development) 1.0 [J] Javasa
[ = Faces suppart (enhanced components) 7.0 |1| 1ava O
S = [T 6.0
] ¢ Java Persistence 1.0 Requites one of the Following Facets:
0 &I Javascript Toolkic 1.0 (s Dynamic Web Module 2,2
.. = JavaServer Faces 1.1 ._"J. Dyriamic Web Moduls 2,3
§ T IS Lil --_.,. Dwvnamic Web Module 2.4
~OR st rodule 1.0
#-[1'25 web 2.0
[ = web Site Navigation 7.0
[ 5 webDaclet (XDoclet) 1.2.3
¢l = Websphere Web (Co-existence) 7.0
L[] = websphere Web (Extended) 7.0
1 |

3 Further configuration required. ..

___e. Click the Further configuration required... link.

Revert I Ay
of I Cancel |

___f. Accept the default values in the “JSF configuration” window, and click OK.
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8. Add the EJB project as a reference to the Web project
___a. With the properties window still open, click Project References.
___b. Check the box next to EE5BankEJB.

___C. Click OK to apply the change and close the properties window
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Part 3: Configure the sample database

In this section you will use Rational Application Server’s data tools to create a Derby database, and run a DDL
file to create tables in that database.

9. Switch to the Data perspective
___a. Select Window > Open perspective > Other...
___b. Select Data and click OK.

10. Create a new derby database connection.

___a. Click the New Connection Profile o

button in the Data Source Explorer panel.
___b. Select Derby from the “Select a database manager” list.
___c. Select Derby 10.2 — Embedded JDBC Driver Default from the “JDBC Driver” menu.

___d. Enter C:\LabFiles70\database\BANKDB in the “Database location” field. The configuration
should look the same as the picture below.

ﬁ New Connection !EI ﬂ

Connection Parameters

Select the database manager, JOBC driver, and required connection parameters,

- Connection identification

v Use default naming convention

Connection Mame: | EAMNEDE

gelect a database manager: IDBC driver: IDerby 10,2 - Embedded JDBC Driver Default j My
Cloudscape
DEZ for i5/05  Properties

DEZ For Linux, UNIE, and Windows

DEZ For 2‘05 General |Optinnal |
j Erowse. ., |

Generic JDEC Database location: I ciiLabfiles70database\BANKDE|

HSQLD-B User name: I

InFormiz

MaxDB Password: |

MySoL

Oracle ; — = - - —
SOl Server LRL: | jdbc:derbey ot Labfiles 70t dat abase\BANKDE; create=true
ST IV Create database (if required)

Websphere

[ Upgrade database to current version

[™ save password

Test Connection |

(7 < Back Mext = | Firish I Cancel
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___e. Click the Test connection button.

___f. Wait for the message “Connection succeeded” to appear, and click OK. If the connection fails,
ensure that your settings match the above picture and try again.

___@. Click Finish.
11. Create the tables defined in Bank.ddl
__a. Import Bank.ddl into your EJB project.

&
*a JavaEE button at the top right.

1) Switch back to the Java EE perspective by clicking the
2) Right-click EE5BankEJB and click Import > Import...
3) Expand General and select Filesystem.
4) Click Next.
5) Click the Browse button and navigate to C:\LabFiles70\database and click OK.
6) Check the box next to Bank.ddl and click Finish.
__b. Run Bank.ddI to create database tables.
1) Double-click Bank.ddl in the Project Explorer to open the file.
2) From the Run menu, select Run SQL.
3) Select BANKDB from the “Connections” list.
4) Click Finish.

5) A blue check mark and the word “Succeeded” will appear in the bottom panel to confirm
that the tables were created.

___c. Close Bank.ddl. If prompted to save your changes, click Save.
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Part 4: Create entities and session beans in the EJB project

In this section, you will be using the Java persistence tools to auto-generate JPA entities based on the tables
that you previously created in the Derby database. You will also create session beans that manipulate the
entities using the “New EJB” wizard, and paste code snippets into the session beans to add business logic.
Finally, you will use a wizard to create JPA manager beans. These will be used later when you are building a
Web interface to your application — JPA manager beans utility classes for accessing JPA entities, and are
required if you want to use Rational Application Developer’s built in JSF components for accessing JPA data.

__12. Configure the EE5BankEJB project to use the “BANKDB” connection that you created.
__a. Right-click EE5BankEJB and select Properties.
__b. Click JPA.
___ . Select BANKDB from the “Connection” menu.
___d. Check the box next to Override default schema from connection.
___e. Select BANKSCHEMA from the “Schema” menu.
__f. Click OK.

13. Use the Java persistence tools to create entities that represent the Customer and Account database
tables.

___a. Right click EE5BankEJB in the Project Explorer and select JPA Tools > Generate Entities...
___b. Select BANKDB from the “Connection” menu.
___C. Select BANKSCHEMA from the “Schema” menu.
___d. Click Next.
___e. Enter com.ibm.websphere.beta.ee5bank in the “Package” field.
___f. Check the boxes next to ACCOUNT and CUSTOMER.
__g. Click Finish.
_____14. Create a stateless session bean called Create that will be used to create customers and accounts.
___a. Right-click EE5BankEJB in the Project Explorer and select New > Session bean.
___b. Enter com.ibm.websphere.beta.ee5bank in the “Package” field.
___c. Enter Create in the “Class name” field.

___d. Check the box next to Remote, so that both local and remote interfaces are created.
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___e. The window should reflect the settings shown in the screen capture below.

ﬁ Create EJB 3.0 Session Bean

Create EJB 3.0 Session Bean

Specify class file deskination. |_®

EJB praject:  |EESBankEJE =]

Source Folder: I'I,EEEBankEJB'I,eijDduIe Browse. .. |
Jawva package: |cnm.ibm.websphere.beta.eeSI:uank Browse, .. |
Class name: I Create

Superclass: | Browse, ., |
Skate bype: IStateIess j

Create business interface

¥ Local Iu:u:-m.il:um.wehsphere.beta.eeSbank.CreateLDcal

(7 = Back Mexk = | Finish I Cancel

___f. Click Finish.

___g. Ifa“Confirm enablement” screen appears, click Cancel.

___h. Open :\LabFiles70\RADLab\snippets\snippetl_create.txt with Notepad. This file contains the
business logic for the “Create” EJB.

Note: The EJB contains two methods, createAccount and createCustomer. Each method creates an
object, sets some properties, and then persists it to the database using the JPA Entity Manager.

___i. Select Edit > Select All, then select Edit > Copy

__j. Return to Rational Application Developer and place the cursor on line 11 of Create.java (below
the line that reads “Public class Create implements...”

___k. Select Edit > Paste to paste the code into the editor.

___|. Some errors will appear in the code. To correct these errors, right-click in the source code editor,
and select Source > Organize Imports.

___m. A*“choose type to import” window will appear. Select javax.persistence.EntityManager and
click Finish.

___n. Promote the business methods to the local interface
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1) Right-click Create in the Outline panel (far right) and select Refactor > Pull up.

2) Select com.ibm.websphere.beta.ee5bank.CreateLocal from the “Target business
interface” menu.

3) Check the boxes next to createCustomer and createAccount.
4) Click Next.
5) Click Finish to accept the modifications to your code.
___ 0. Promote the business methods to the remote interface.
1) Right-click Create in the Outline panel (far right) and select Refactor > Pull up.

2) Select com.ibm.websphere.beta.ee5bank.CreateRemote from the “Target business
interface” menu.

3) Check the boxes next to createCustomer and createAccount.
4) Click Finish.

___p. Save and close Create.java

___ Q. Save and Close Classdiagram.dnx

15. Create a stateless session bean called Transfer that will be used to transfer funds between
accounts.

___a. Right-click EE5BankEJB in the Project Explorer and select New > Session bean.
___b. Enter com.ibm.websphere.beta.ee5bank in the “Package” field.
___c. Enter Transfer in the “Class name” field.

__d. Check the box next to Remote, so that both local and remote interfaces are created.
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___e. The window should reflect the settings shown in the screen capture below.

@ Create EIB 3.0 Session Bean M=l E3

Create EJB 3.0 Session Bean

apecify class file deskination, |_®
EJB project:  |EESBankEJe |

Source Folder; | 'EESEankE I8 eibModule Browse, .. |
Java package: |u:u:um.iI:um.websphere.beta.eeSl:uank Browse. .. |
Class name: | Transfer

Superclass: I Browse. .. |
Skate type: IStaI:eIess j

Create business interface

¥ Local |u:u:um.iI:um.websphere.I:ueta.eeSbank.TransFerLDcal

(7) = Back Mext = | Firish I Cancel

___f. Click Finish.

___g. Open :\LabFiles70\RADLab\snippets\snippet2_transfer.txt with Notepad. This file contains the
business logic for the “Create” EJB.

Note: The EJB contains one method, transferFunds. This method uses the JPA Entity Manager to get the
balances from two accounts, performs the necessary arithmetic, and then sets the new values for the
balance of each account.

___h. Select Edit > Select All, then select Edit > Copy

___i. Return to Rational Application Developer and place the cursor on line 11 of Transfer.java (below
the line that reads “Public class Transfer implements...”

___j. Select Edit > Paste to paste the code into the editor.

___k. Some errors will appear in the code. To correct these errors, right-click in the source code editor,
and select Source > Organize Imports.

___l. A*choose type to import” window will appear. Select javax.persistence.EntityManager and click
Finish.

___m. Promote the business methods to the local interface
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1) Right-click Create in the Outline panel (far right) and select Refactor > Pull up.

2) Select com.ibm.websphere.beta.ee5bank.TransferLocal from the “Target business
interface” menu.

3) Check the box next to transferFunds.
4) Click Next.
5) Click Finish to accept the modifications to your code.
___n. Promote the business methods to the remote interface.
1) Right-click Transfer in the Outline panel (far right) and select Refactor > Pull up.

2) Select com.ibm.websphere.beta.ee5bank.TransferRemote from the “Target business
interface” menu.

3) Check the boxes next to transferFunds.
4) Click Finish.

___ 0. Save and close Transfer.java

___p. Save and Close Classdiagram.dnx

16. Create JPA manager beans for your Entities. A JPA manager is a facade class that makes it easy
for the Web tools to access the JPA Entities in your project.

___a. Right-click EESBankEJB and select JPA Tools > Add JPA manager beans...
__b. Check the boxes next to both Account and Customer.

___c. Click Finish.
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Part 5: Create a Web interface to the application

In this section, you will create several Web pages using Rational Application Developer’'s Web tools. These
pages will be built using JavaServer Faces technology, and will use the built-in JSF components to work with
session beans and JPA Entities.

_____17. Open the Web perspective
___a. Navigate to Window > Open perspective > Web.
____18. Ensure that the classes in the EESBankEJB project are available to the Web project.
___a. Right-click EE5BankWeb and select Properties.
___b. Click Java Build Path.
___c. Click Add...
___d. Check the box next to EE5BankEJB and click OK.
___e. Click Java EE Module Dependencies, in the left menu of the Properties window.
___f. Click the Web Libraries tab.
__ 0. Check the box next to EESBankEJB and click OK. The Properties window will close.
_____19. Create new pages by updating the Web Site Navigation.
__a. Expand EE5BankWeb in the Project Explorer.
___b. Double-click Web Site Navigation to open it in the editor.

___c. Click the Palette tab at the far right to activate the Web palette. (Or select Window > Show view
> Palette)

___d. Create home.jsp
1) Click-and-drag the New page component from the palette into the editor.
2) Type home.jsp in the component’s text field to name it.
3) Double-click home.jsp to edit it.
4) Ensure that the “File name” field reads home.jsp.
5) Expand Sample Templates > Family A and select A-01_blue.htpl.
6) Click Finish.

7) A Web page editor will open. Type “Welcome to EE5Bank” and type enter three times to
add carriage returns, where you see “place your page content here”.

8) Save and Close home.jsp
___e. Create newCustomer.jsp

1) Click-and-drag the New page component from the palette into the editor, beneath home.jsp
(you will see a black horizontal line appear below home.jsp)

2008 November, 18 IBM WebSphere Application Server V7 — Lab Exercise Page 17 of 34



© Copyright IBM Corporation 2008. All rights reserved

2) Type newCustomer.jsp in the component’s text field to name it.
3) Double-click newCustomer.jsp to edit it.

4) Ensure that the “File name” field reads newCustomer.jsp.

5) Ensure that A-01_blue.htpl is selected as the template.

6) Click Finish.

7) A Web page editor will open. Type “Add a new customer”, and type enter three times to
add carriage returns, where you see “place your page content here”.
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___f. Add a JPA Data element to the page to create customers in the database.
1) Click Data and Services in the palette.
2) Drag the JPA Data element onto the page, below the text you entered.
3) Highlight the CustomerManager bean, and select Create a new record as shown below.

a Add JPA data to page [_ O
Add JFPA data to page -

Select the P& Manager bean o use in your page. 4 | I
To add a new JPA Manager ko vour project click the Create Mew JP& Manager button. '

Select a IPA Manader ko use in wour page:

E AccountManager Create new JPA Managet... |
& CustomeriManager

—Select how you would fike to use wour data
" Retrieve a list of data

" Retrieve a single record

¥ ¥reate a new record;

" Update an existing record

(7) = Back Mext = | Firish I Carcel

4) Click Next.

5) Highlight firstname and click the “up” arrow to move it above lasthname. This order
determines how the form will appear on your Web page.
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6) Edit the “Label” fields to give each item a suitable name for display on the Web page. When
finished, the window should resemble the example below.

a Add JPA data to page [_ O

Configure data controls
Specify the columns to display and how bo display them,

Fields to display

| Field name | Label | Control Type |
custamernumber (long) Cuskarmet number: Inpuk Texk

firstname (java.lang. String) First name: Inpuk Text ;l
lastname (java.lang. String) Last name: Inpuk Texk -

73 § baxid (java.lang. String) Input Texk

all Mone Cpkians. .,

(7) = Back ext = | Firish I Cancel

7) Click Finish. The form that has been added to the Web page will create a new JPA Entity
based on the information provided. You will test this later when the application is complete.

8) Save and Close newCustomer.jsp.

___g. Create a similar page, newAccount.jsp

1) Click-and-drag the New page component from the palette into the editor, next to
newCustomer.jsp (you will see a black vertical line appear next to newCustomer.jsp)

2) Type newAccount.jsp in the component’s text field to name it.

3) Double-click newAccount.jsp to edit it.
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4) Ensure that the “File name” field reads newAccount.jsp.
5) Ensure that A-01_blue.htpl is selected as the template.
6) Click Finish.

7) A Web page editor will open. Type “Add a new account”, and type enter three times to
add carriage returns, where you see “place your page content here”.

__h. Add a session bean element to the page. This element will use a JSF form and the “Create”
bean to add an account to the database. This is an alternative to using JPA manager beans as
was shown in the previous createCustomer example.

1) Click Data and Services in the palette.

2) Drag the EJB Session bean element onto the page, below the text you entered.
3) Click Add... in the “Add session bean” window.

4) Expand EE5Bank and EE5Bank.jar, and select Create.

5) Click Finish.
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6) Ensure that createAccount(long,int,int) is selected in the “Select a method” menu as shown
below, and click Next.

© Add Session Bean (O]
Session Bean
Select a Session Bean and a method E@

Select a Service:

Marme | Class |
eib/Create com.ibm.websphere, beta.eesbank, Createlocal
add..

Select a method;

akepccountilong,ink, ink)

I¥ Create input form and resulks display (configure details on Following pages)

(7 = Back Mext = | Firish I Cancel
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7) Edit the values in the “Label” column to give the fields acceptable display names, as shown

below.

Iﬁ Add Session Bean _ O]

Input Form

Configure the data controls For the inpuk Form

Fields to display:

| Field Mame | Label | Contral Type

cuskomernumber {long) Cuskomer number:  Input Text =
accountnumber {int) Account number; Input Text =]
balance (ink)

Balance: Input Texk

Mone Cpkions. ..

8) Click Next.
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9) Change the “Label” field to Result: as shown below.

© Add Session Bean =]

Results Form

Configure hiow the resulks will be displayed

T ‘@

7
Fields to display:
| Field Mame | Label | Conkral Type
createlocal_Createdccount.re Result: | Display Ted
1
b
1| | )

Al | Mone Cptians. .,

(7) = Back Mext = | Firish I Carcel

10) Click Finish. The form that you just defined in the wizard will be added to the Web page.
Note that the field names are the same as the “Label” column from the wizard.

11) Save and Close newAccount.jsp.

___i. Create a page called transferFunds.jsp. This page will call the Transfer EJB to transfer money
between two accounts.

1) Click-and-drag the New page component from the palette into the editor, next to
newAccount.jsp (you will see a black vertical line appear next to newAccount.jsp)

2) Type transferFunds.jsp in the component’s text field to name it.
3) Double-click transferFunds.jsp to edit it.

4) Ensure that the “File name” field reads transferFunds.jsp.

5) Ensure that A-01_blue.htpl is selected as the template.

6) Click Finish.
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7) A Web page editor will open. Type “Transfer funds between two accounts”, and type
enter three times to add carriage returns, where you see “place your page content here”.

___j. Add a session bean element to the page. This element will use a JSF form and the “Transfer”
bean to transfer money from one account to another.

1) Click Data and Services in the palette.

2) Drag the EJB Session bean element onto the page, below the text you entered.
3) Click Add... in the “Add session bean” window.

4) Expand EE5Bank and EE5Bank.jar, and select Transfer.

5) Click Finish.

6) Ensure that transferFunds(int,int,float) is selected in the “Select a method” menu as shown
below, and click Next.

 Add session Bean _ O]

Session Bean
Select a Session Bean and a method W@

Select a Service:

E= | Class |
eib/Create com.ibrm.websphere.beta, eeShank, Createlocal

&ib Transfer com.ibm.websphere.beta. eeShank, TransferLocal
add..

Select a method;

¥ Create input form and resulks display (configure details on Following pages)

)] = Back Mexk = | Firiish I Cancel
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7) Edit the values in the “Label” column to give the fields acceptable display names, as shown
below.

Iﬁ Add Session Bean H=]

Input Form ®
Configure the daka contrals For the input Form =
S

Fields to display:

| Field Mame | Label | Conkrol Type

acckl {int) From account; [nput Text =

acck? {ink) To account: Inpuk Texk =]

arnounk: {Float) Amount: Inpuk Texk =l

Al Mone COptions. ..

(7) = Back Mext = | Firish I Cancel

8) Click Next.
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9) Change the “Label” field to Result: as shown below.

© Add Session Bean =]

Results Form

Configure hiows the resules will be displaved

FirLL ’@

7
Fields to display:
| Field hame | Label | Conkral Type
transferLocal_TransferFunds.r Result:| Display Text e
Al Mone Cptians. ..

(7 < Back Mexk = | Firish I Cancel

10) Click Finish. The form that you just defined in the wizard will be added to the Web page.
Note that the field names are the same as the “Label” column from the wizard.

11) Save and Close transferFunds.jsp.

20. The navigation links in the template currently show the file names for each Web page you have
created. Edit the navigation labels to give the pages more suitable display names.

___a. Inthe “Web site navigation” tab, click home.jsp.
___b. The “Properties” panel will be displayed below. Enter Home in the “Navigation label” field.
___c. Click newCustomer.jsp.

___d. The “Properties” panel will be displayed below. Enter Add customer in the “Navigation label”
field.

___e. Click newAccount.jsp.
__f. The “Properties” panel will be displayed below. Enter Add account in the “Navigation label” field.
___ 0. Click transferFunds.jsp.

2008 November, 18 IBM WebSphere Application Server V7 — Lab Exercise Page 27 of 34



© Copyright IBM Corporation 2008. All rights reserved

__h. The “Properties” panel will be displayed below. Enter Transfer funds in the “Navigation label”
field.

___i. Select File > Save to save the current Web site navigation.

__j. Double-click transferFunds.jsp to view the new labels applied to the Web site template.
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Part 6: Deploy the application to the server

In this section you will associate your enterprise application project with the local installation of WebSphere
Application Server, and deploy the application for testing. This process will be familiar to you if you have used
previous versions of Rational Application Developer or the Application Server Toolkit.

21. Associate the EE5Bank application with the server you defined in Part 1.
___a. Click Servers in the lower panel to display the Servers tab.

__b. Right click on WebSphere Application Server v7.0 at localhost and select Add and remove
projects...

___C. Select EE5Bank and click Add > to move it to the right-side panel, as shown below.

Iﬁ Add and Removye Projects H=]

Add and Remove Projects ‘ ‘

Modify the projects that are configured on the server

| S

Mowve projects ko the right o configure them on the server

fyvailable projects: Configured projects;
B £EoBank
Add » |
< Remove |
addal>> |
<< Bemaove Al |

'3:':’:3' = Back ext = | Finish I Cancel |

___d. Click Finish.

___e. Wait for the server’s “Status” column to change from “Publishing” to “Synchronized”. (Log data
will be displayed in the Console tab between these two states)
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Part 7: Test the application

In this section you will use the application that you have developed in the previous parts of this exercise. You
will create a customer, and then create two accounts that belong to that customer. After the accounts have
been created, you will transfer money from one account to the other.

22. Launch the application in a Web browser.

___a. The “Web site navigation” tab should still be displayed. Right-click home.jsp and select Run on
server.

__b. Inthe window that is displayed, ensure that WebSphere Application Server v7.0 at localhost
is highlighted, and click Finish.

___c. If security alerts are displayed by the browser, click Yes to proceed.
23. Create a customer.
___a. Click Add customer in the navigation area of the Web page.

___b. Enter the following values in the form:

Customer number: 1

First name: John

Last name: Doe

Tax ID: 5678
___C. Click Submit.

__d. Note that when the form has been submitted, the console panel will show JPA loading, and the
page will refresh. The page will appear the same. The customer has been created, though there
is no displayed status to indicate this.

24. Create an account.
___a. Click Add account in the navigation area of the Web page.

___b. Enter the following values in the form:

Customer number: 1

Account number: 1

Balance: 300
___c. Click Submit.

___d. Note that when the form has been submitted, the “Result” field will update, displaying “Account 1
created successfully”. This is because the session bean JSF component allows you to display a
string as the result of an operation. This is one advantage of using a session bean facade to
manipulate JPA Entities, rather than working with them directly from the Web container. Examine
the Java source code for Transfer.java if you want to see how this is achieved.

25. Create another account.
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___a. Enter the following values in the form:

Customer number: 1
Account number: 2
Balance: 100

__b. Note that the “Result” field now reads “Account 2 created successfully”
26. Transfer $50.00 from account 1 to account 2.
___a. Click Transfer funds in the navigation area of the Web page.

___b. Enter the following values in the form:

From account: 1

To account: 2

Amount: 50.00
___c. Click Submit.

___d. Note that the “Result” field now shows that 50.00 dollars have been transferred, and displays the
current balances of both accounts.
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Part 8: Clean up

In this section you will stop the WebSphere Application Server process and then exit Rational Application
Developer.

____27. Stop the running instance of WebSphere Application Server.
___a. Click the Servers tab in the bottom panel.
__b. Right-click the running server and select Stop.
__¢. Wait for the server’s “State” field to change to “Stopped”.
____28. Close Rational Application Developer for WebSphere Software.

___a. Select File > Exit.
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What you did in this exercise

In this exercise you developed, deployed, and tested a simple Java EE 5 application using Rational
Application developer. In doing so you gained exposure to the new Java EE 5 development tools in
Rational Application Developer, and updated versions of existing tools. You used the server tools to
connect to WebSphere Application Server, the data tools to create and configure a Derby database, EJB
tools to create session beans using a wizard, JPA tools to create Entities based on database tables, and
Web tools to create JSF-based Web pages that communicated with the session beans and JPA Entities.
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