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IBM WebSphere Application Server 
Feature Pack for XML 

Installation troubleshooting 

This presentation describes resources available for troubleshooting installation problems. 
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© 2010 IBM Corporation 2 Installation troubleshooting 

Agenda 

� Logs and traces 

� Common questions 

The first section of this presentation describes logs and traces that are available with the 
Installation Manager. The second section addresses common questions that might come 
up when using the Installation Manager. 
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Logs and tracesLogs and traces 

Section 

The Installation Manager provides logs and traces that can be useful when analyzing a 
failure or debugging problems. This section describes some of these logs and traces. 
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Installation log files 

� Log files are located under the /logs directory of the Installation Manager’s application data 
location 

� Main log files are time-stamped XML files 

Platform Installation type Typical data location, referred to as <IM_DATA> 

Windows® 2003 Administrator C:\Documents and Settings\All Users\ Application Data\IBM\Installation Manager 

Windows 2003 Non-administrator C:\Documents and Settings\<user _name>\ Application Data\IBM\Installation Manager 

Windows 2008 and Vista Administrator C:\ProgramData\IBM\Installation Manager 

Windows 2008 and Vista Non-administrator C:\Users\<user name>\AppData\Roaming\ IBM\Installation Manager 

Linux®, AIX®, HP-UX, Solaris Root /var/ibm/InstallationManager 

Linux, AIX, HP-UX, Solaris Non-root <user_home>/var/ibm/InstallationManager 

4 Installation troubleshooting	 © 2010 IBM Corporation 

Installation log files are located in the /logs directory of the Installation Manager’s 
application data location. The data location varies by platform and the user authority of the 
ID under which Installation Manager was installed on the system. Default data locations 
for administrative and non-administrative users are provided on this slide for your 
reference. The main log files produced by Installation Manager are time-stamped XML 
files. 
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Installation log file 

See a graphical view of the main 
installation log file using the Installation 
Manager’s File > View Log menu 

5 Installation troubleshooting © 2010 IBM Corporation 

The main installation log file is visible from the Installation Manager GUI. To see a 
graphical view of the log file, open the File > View Log menu. This brings up a panel 
similar to the one shown here, allowing you to browse through and examine the actions 
that the Installation Manager has performed. The buttons near the top of the panel allow 
you to adjust from a horizontal to a vertical view. You can also import or export a log file, 
configure the filters for viewing the log file entries, and open the log directly in a browser 
from this panel. 
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Installation history 

A history of the actions performed by
 
the Installation Manager is available in
 
the File > Installation History menu
 

6 Installation troubleshooting © 2010 IBM Corporation 

The Installation Manager maintains a history of the actions it has performed installing, 
modifying, and uninstalling packages. Get a quick view of this history by opening the File > 
Installation History menu. You can modify the view orientation from this panel and directly 
open up the installation history file in a browser. 
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Installed packages 

See a list of all of the packages and fixes 
installed by your Installation Manager using 
the File > View Installed Packages menu 

7 Installation troubleshooting © 2010 IBM Corporation 

If you are having a problem with the Installation Manager, it can be very helpful to go take 
a look and see what packages have been installed by or imported into the Installation 
Manager. To see the package list, go to File > View Installed Packages in the Installation 
Manager interface. If you have a WebSphere® Application Server installation imported into 
the application server, that package group is displayed here, along with the fix pack level 
that is recognized by the Installation Manager. If you have installed the feature pack for 
XML, that will also show up here. 
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Enabling traces 

� To troubleshoot problems with installing a feature pack, gather traces for WebSphere 
Application Server plug-ins 

� The log.properties file under <IM_DATA>/logs specifies the level of logging and tracing that 
Installation Manager uses 

� To turn on tracing for WebSphere Application Server plug-ins, create a log.properties file 
with the content below: 

� Restart Installation Manager, and it outputs traces for the plug-ins 

� Tracing for the plug-ins normally goes into the main log files 
– Except for PAK engine traces, which go under <IM_DATA>/logs/PAKEngine 

com.ibm.ws=DEBUG 
PakInstallOperation=DEBUG 

To troubleshoot problems with installing a feature pack, you need to gather traces for 
WebSphere Application Server plug-ins for the Installation Manager. The log.properties file 
in the Installation Manager’s logs directory specifies the level of logging and tracing that 
the Installation Manager uses. To turn on tracing for WebSphere Application Server plug-
ins, create a log.properties file with the two lines of content shown here on this slide. 
When you restart Installation Manager, it outputs traces for the plug-ins. Tracing for the 
plug-ins normally goes into the main log files, except for PAK engine traces, which go 
under the PAKEngine directory. 
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Sending debugging information to IBM 

� Use the Installation Manager to export installation data to send to IBM 

� Open the Help > Export Data for Problem Analysis menu 

� Provide the name of the .zip file to hold the data 

� Send the .zip file to IBM support for analysis 

9 Installation troubleshooting © 2010 IBM Corporation 

If you need to send debugging information to IBM for analysis, you can export installation 
data using the Installation Manager interface. Open the Help > Export Data for Problem 
Analysis menu, then provide the name of the .zip file that you want to hold the data in the 
dialog box. When you have the .zip file, send it to IBM support for analysis. 
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Common questionsCommon questions 

Section 

This section addresses common questions you might have when using the Installation 
Manager to install the feature pack for XML. 
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No installation packages are visible 

� Question: Why aren’t there any packages available for me to install from the Installation 
Manager? 
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If you open the Install wizard in the Installation manager and you do not see any packages 
available to install, what should you do? 
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Check repository configuration 

� Open the File > Preferences > Repositories menu in Installation Manager to see your 
repository configuration 
– You must have a repository configured that contains the product you are trying to install 

� If you are using the Web repository provided by IBM, make sure you have the correct re 
–	 Make sure you have these two repositories configured in your settings 

•	 http://public.dhe.ibm.com/software/websphere/repositories/repository.config 
•	 https://www.ibm.com/software/rational/repositorymanager/repositories/websphere/repo 

sitory.config 
–	 Verify that your proxy and firewall settings allow you to connect to the Web repository 
–	 Verify that you have authentication credentials to access the repository (an IBM ID) 

� If you are using a local or internal repository, configure Installation Manager to point to the 
appropriate file system location 
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Read through the messages that are displayed on the installation packages panel – they 
recommend that you check your repository configuration, proxy and firewall settings, and 
authentication credentials. To check your repository configuration, open the File > 
Preferences > Repositories menu in the Installation Manager. You need to have a 
repository configured that contains the product you are trying to install. If you are using the 
Web repository provided by IBM, you need to make sure that you have the two repository 
URLs shown on this page in your repository list. You need to know your IBM ID to be able 
to access the Web repository. If you are using a local or internal repository, configure 
Installation Manager to point to the appropriate file system or internal network location for 
your repository. 
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Required application package not available 

� Question: What does it mean that the feature pack for XML requires components that 
might be supplied by WebSphere Application Server 7.0.0.7? 
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While trying to install the feature pack for XML, what should you do if you see an error 
message saying that the feature pack requires components that might be supplied by 
WebSphere Application Server 7.0.0.7? 
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Verify that application server is imported 

� In Installation Manager, open File > View Installed Packages 
–	 Check that you have at least one WebSphere Application Server 7.0.0.7 package in your 

installed packages list 

� If you do not have WebSphere Application Server 7.0.0.7 (or later) in your package list, 
either: 
–	 Use Installation Manager to import an installation of WebSphere Application Server 

7.0.0.7 (or later) 
–	 Update a package you already have imported to Fix Pack 7, then re-import it 

� If you are applying newer service than Fix Pack 7 with the Update Installer and using a local 
repositories with the Installation Manager: 
–	 You need to download new local repositories that support importing WebSphere
 

Application Server at the newer fix pack level
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You typically see a message like this because you do not have any instances of 
WebSphere Application Server imported into the Installation Manager. To check which 
packages you have configured in your Installation Manager, open the File > View Installed 
Packages menu. If you do not see at least one WebSphere Application Server 7.0.0.7 
package in the list, then you need to import one. Do this by either using the Installation 
Manager to import an installation of WebSphere Application Server 7.0.0.7 or updating an 
instance of the application server that you already have imported to fix pack 7, then re-
importing it into Installation Manager. If you are applying newer service than fix pack 7 with 
the Update Installer and using a local repositories with the Installation Manager, you need 
to download new local repositories that support importing WebSphere Application Server 
at the newer fix pack level. 
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SDK fixes are missing 

� Question: During application server import, what do you do if you get a message telling you 
that the application server’s Software Development Kit package is not at the required level? 

15 Installation troubleshooting © 2010 IBM Corporation 

When you are trying to import the application server into the Installation Manager, what 
does it mean if you get a message telling you that the application server’s Software 
Development Kit package is not at the required level? 
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Install SDK fixes 

� To be able to import WebSphere Application Server installation into the Installation Manager: 
– Both the application server maintenance package and the Java™ SDK maintenance 

package must be at the same level 

� Follow the instructions for applying the WebSphere Application Server fix pack 
– Use the Update Installer to apply application server maintenance 
– Install both the application server and SDK fix packages 

� Re-import the application server after applying maintenance 

16 Installation troubleshooting © 2010 IBM Corporation 

To be able to import WebSphere Application Server into the Installation Manager, both the 
application server maintenance package and the Java SDK maintenance package for the 
server must be at the same level. For example, if you have installed the application server 
package for fix pack 7, you must also install the SDK package for fix pack 7. Use the 
update installer to apply the appropriate level of the SDK fix package, and then re-import 
the application server after applying maintenance. 
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Sample fix pack download 

� Download the fix pack packages you need from the WebSphere Application Server support 
site 

� For example, for 32-bit Linux on AMD or Intel®, you must apply at least these two packages: 
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You can download application server and SDK fix packages from the WebSphere 
Application Server support site. This page shows a sample screen capture for the 32-bit 
Linux downloads for fix pack 7 for WebSphere Application Server. In this example, you 
need to download and install both of the fix packages that are highlighted in red – 
AppServer and Java SDK. 
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Server maintenance levels are out of date 

� Question: When I see a message telling me that the feature pack for XML requires 
WebSphere Application Server 7.0.0.7, what should I do? 
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When you are trying to install the feature pack for XML, what should you do if you see a 
message telling you that the feature pack requires WebSphere Application Server 7.0.0.7? 
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Install the appropriate fix pack 

� If the Installation Manager indicates that your WebSphere Application Server needs to be at 
a particular fix pack, that means that your application server maintenance is out of date 

� Apply WebSphere Application Server V7 maintenance using the WebSphere Update 
Installer 

– The feature pack for XML requires Fix Pack 7 or later 
– Install both the application server and the SDK fix packages 

� After applying application server maintenance, re-import the application server into 
Installation Manager 
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If the Installation Manager indicates that your WebSphere Application Server needs to be 
at a particular fix pack, that means that your application server maintenance is out of date. 
The feature pack for XML requires fix pack 7 or later, including both the application server 
and the SDK fix packages. Install the required WebSphere Application Server fix pack 
packages using the WebSphere Updating Installer, then re-import the application server 
into the Installation Manager. 
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SummarySummary 

Section 

This section provides a summary of the content covered in this presentation. 
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Summary 

� Installation manager logs and traces are available to help debug problems 

� Use the resources provided here to quickly work through your installation questions 

21 Installation troubleshooting © 2010 IBM Corporation 

The Installation Manager provides logs and traces to help debug problems. You can 
display some of the log file content directly in the Installation Manager interface. The other 
resources provided in this presentation are available to help you quickly work through your 
installation questions. 
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Feedback 

Your feedback is valuable 

You can help improve the quality of IBM Education Assistant content to better meet your 
needs by providing feedback. 

� Did you find this module useful? 

� Did it help you solve a problem or answer a question? 

� Do you have suggestions for improvements? 

Click to send e-mail feedback: 

mailto:iea@us.ibm.com?subject=Feedback_about_XMLFEP_InstallTroubleshooting.ppt 

This module is also available in PDF format at: ../XMLFEP_InstallTroubleshooting.pdf 

22 Installation troubleshooting © 2010 IBM Corporation 

You can help improve the quality of IBM Education Assistant content by providing 
feedback. 
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