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IBM WEBSPHERE BUSINESS MONITOR 7.0 — LAB EXERCISE

WebSphere Business Monitor V7.0
KPI history and prediction lab
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What this exercise is about
The objective of this lab is to show you how to use the KPI history and prediction widget. Since the KPI
history service runs once per hour, it could take some time to build up enough history records for testing
the widget. In this lab, you will preload the database with history records, then use the widget to view those
records. You will create a KPI prediction model using the KPI Manager widget, then view the prediction

data. Also, you will configure a business user alert using the Alert Manager widget, and the alert will be
based on data that exceeds a threshold which is defined on the prediction model.

Lab requirements
List of system and software required for the student to complete the lab:
< Rational Application Developer V7.5 or WebSphere Integration Developer V7.0.

e WebSphere Business Monitor V7.0 — Toolkit Installation including the Monitor Model editor and
Monitor Server

What you should be able to do

At the end of this lab you should be able to:
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« Use the KPI history and prediction widget to view KPI historical information and KPI prediction
information.

Introduction

In this lab you will load the KPI history table with approximately 52,000 records, approximately 3 years of
data for each of two KPIs. You will load the records into the Derby database for use with the Monitor
toolkit.

After loading the database with the history records, you will deploy the monitor model. Then you will create
a dashboard and use the KPI history and prediction widget.

You will also create a prediction model and view the prediction values in the dashboard.

Finally, you will create a business user alert when the KPI prediction values exceed a predefined
threshold.

URL Cheat sheet

The following URLs may be helpful to you as you exercise this lab. Note that the port numbers in the URL
of your installation may be different depending on your configuration.

e Server administrative console

https://localhost:9043/ibm/console

e Business space dashboard

https://localhost:9443/BusinessSpace
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Part 1: Load the KPI history table with data

To load the history data into Derby, use the following procedure.

2. Stop the Monitor server in the servers view

3. Open the Data perspective using the icon in the upper right corner of the window

T | Bl Business Moni,..

| E': Busingess Monikaring

4. Create a new connection to the MONITOR database
___a. Inthe Data Source Explorer view, right click Databases, then click New
___b. Select Derby as the database manager
___c. For JDBC driver, select 'Derby 10.2 - Embedded JDBC Driver Default'

___d. For database location, browse to
<WID_WTE_PATH>\runtimes\bi_v7\profiles\gmwps\databases\MONITOR

___e. For user name, enter 'user'
___f. Leave the password field empty

__ 0. De-select 'Create database'
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= New Connection H[=]

Connection Parameters

Select the database manager, JDEC driver, and required connection parameters,

- Connection identification

v Wse default naming corvention

Connection Marne: | MOMITOR

Select a database manager: IDBC driver: IDerby 10,2 - Embedded JDBC Driver Default j Fiy
Cloudscape
DBZ For i5)03  Broperties

DEZ For Linwx, UMNIX, and Windows

DEZ For 2‘05 General | optianal |

Generic DBC Database location: ITE'l,runtimes'l,bi_v?'l,pr0FiIes'l,qmwps'|,databases'|,MONITOR| j Browse. .. |
HSQLD_B User name: |

Informix

MaxDB Password: [

Py SOL

Oracle Default schema: |

S0L Server

Sybase URL: | jdbcsderbey D wid7 _w TE runtimestbi_v 7 profilesigmwpsidatabase s MOMI
Websphere

[ Create database (if required)
[ Upgrade database ko current version

[ Save password

Test Connection |

___h. Click 'Test Connection' button to verify the connection

4= New Connection |
\ij) Connection succeeded,

__i. Click OK
___j. Click Finish

___k. You should see the Monitor database in the data source explorer

ﬁ Data Source Explorer &3

SRE FVONITOR |
B[ monIToR
[:I Authorization IDs
- Schemas
5. Load the supplied data into the Monitor KPI History table

___a. Inthe data source explorer, navigate to Databases > MONITOR > MONITOR > Schemas >
MONITOR > Tables > KPI_HISTORY_T

___b. Right click KPI_HISTORY_T and select Data > Load...
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___c. Forimport file, browse to the supplied file load-KPI-history.data
1) For example, browse to c:\Labfiles70\KPIHistory\load-KPI-history.data

___d. Use column delimiter Comma and character string delimiter ". De-select 'Replace existing data’,
which will preserve history data for any other models, such as the showcase model.

&= Load Data M=l B3

Select the location and the format of the file

Input File: k:'|,LabFiIes?El'l,KF‘IHistnry'l,load-KPI-history.data

File: Farmak

Colurnn delimiter: I Camma

Characker string delimiter: I !

¥ Replace existing data

___e. Click Finish

___f. After a few minutes, in the SQL Results view you should see that the rows were loaded

£ Properties (\/— Tasks ﬂg_ Problems (@ Error Log (E__\EI MModel Report (: SOl Results 23 Eﬂ] Bookmarkq

Twpe query expression here Skatus [Messagel ]

Status Qperation Dake Connection. .. Loading "MONMITOR","KPI_HISTORY _T"...
Data loading was successful,

235 rowis) deleted,

52547 roves) loaded,

WOMITOR" ... 1711010 1:0.,, MONITOR

6. Disconnect the connection to the MONITOR database

___a. Inthe data source explorer view, right click the MONITOR connection and select Disconnect
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Part 2: Import the monitor model
Import the supplied monitor model to the monitor toolkit.
1. Open the Business Monitoring perspective using the icon in the upper right corner of the window.
2. Ifitis not started, start the monitor server in the servers view.
3. Import the supplied project interchange file
___a. Inthe Project Explorer view, right click then select Import...

___b. Navigate to Other > Project Interchange then click Next.

___c. For the .zip file, browse to the supplied file, for example, c:\Labfiles70\KPIHistory\Orderltem-
Pl.zip

___d. You should see two projects listed, so click Select All.

___e. Click Finish.

___f. You should see two projects listed in the project explorer.
-T2 orderltem

12 orderTtemUDR

___g. Check for any errors in the Problems view. You should resolve any errors before continuing.
Warnings and informational messages may be present but these will not be a problem.

4. Review the two KPIs in the model.

___a. Inthe Project Explorer, navigate to Orderltem > Monitor Models. Double click Orderltem.mm to
open the monitor model editor.

b. Click the KPI Model tab.
c. In the editor, navigate to Order Item > FunctionKPlIs, then click Avg Order Price.

d. You see that the check box is selected for keeping track of KPI history.
Keep track of histarical values For this KPT

e. It has a target and ranges, and colors have been selected for the ranges. These colors will show
up on the KPI history widget in the dashboard.

Target: 20000

Ranges: *l Ackual value

Range name | Start walue | End value | Calar

= Low u] < 10000 W ccoooo
= Mediurn 10000 < 20000 FFFFO0
= High 20000 < 40000 B z39900

___f. Notice also that the metric is Item Price and the function is Average, and no time period is
selected.

___@g. Inthe editor, navigate to Order Item > TimePeriodKPlIs, then click Sum Price Today.
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___h. You see that the check box is selected for keeping track of KPI history. It has a target and
ranges, and colors have been selected for the ranges. These colors will show up on the KPI
history widget in the dashboard. Notice also that the metric is Item Price and the function is Sum.
The time period metric is set to Date Ordered, and the time period is set to a repeating daily
period.
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Part 3: Publish the model to the server

In this section you will use the toolkit to publish the monitor model to the monitor server.

10.

11.

12.

13.

14.

15.

2010 April,

In Project Explorer, expand Orderltem - Monitor models - Orderltem.mm. Right click over
Orderltem.mm and then select Generate Monitor JEE Projects from the pop-up menu

Select Finish.

A progress dialog shows the status of the operation and it closes when the operation is complete.
Check for errors in the Problems view. There may be warnings, but there should not be any errors. If
you see errors, then try to perform a clean to see if the errors can be removed: Project > Clean... >
select 'Clean all projects', then click OK.

If your server is not started, in the Servers tab, right click and select the Start option to start the
server. This may take a few minutes to complete.

| . Manitaring Flow (: Properties ﬂ"_ Problems ('5% SEervers i :g} Server Lngs} = Eunsule} Fﬁ: Bsset Repnsitories}

W0 ®
Server o State Skatus
ﬂ,ﬂ, WebSphere Business Monitor Server v7.0 on WebSphere Process Server EL. Started Synchronized

Right click in the servers view, then select Add and Remove Projects....

Click Add to move the OrderltemApplication from the list of available projects to the list of
configured projects.

Click Finish.
A progress message is displayed in the lower right corner of the window.

Check the messages in the console view. You should see the following message when the
application has been started:

Application started: OrderltemApplication

In the servers view, right click, then select Administration > Run administrative console. You
should see it open in a separate tab.

It will prompt you for user ID and password. Enter 'admin’ without the quotation marks for user ID,
then enter 'admin’ without the quotation marks for password. Click Log in

Click Applications > Monitor Models. The application should show green status if it started
successfully.

If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the
right of Status in the last column of the table. You should see green (started) for the model. If it does
not show green, be patient and keep refreshing until it does show green.

Check the server log to ensure there are no problems. You can check this in the console view.

If you are using the integrated server within WebSphere Integration Developer or Rational
Application Developer, then you do not need to setup Monitor data security, since the administrative
user is automatically authorized to all models. If you are using a different server, then you should
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open the administrative console, navigate to Security > Monitor Data Security, then add the
model, role and user information to a resource group.
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Part 4: Create a dashboard in business space

In this section you will build a dashboard in business space. You will add views to the dashboard and
configure them.

1. Create the dashboard.

___a. The default browser is 'Internal Web Browser', but you should not use this one since some
standard functions are not provided that you may need. Select Window > Preferences > General
> Web browser > select 'Use external Web browser'. Select an external browser. Click OK.

__b. InWebSphere Integration Developer, in the servers view, right click and select Launch >
Business Space

___¢. When prompted, enter admin for the user ID and enter admin for the password. You must log in
with ‘admin’ so that you can view the alerts which were setup in action manager to be sent to this
particular user ID. Also, in the toolkit environment, this is the user ID that is automatically defined
on the secured server.

__d. Click in the Actions menu to create a new space

Haorme Goto Bpaces Manage Spaces | Actions
Y i Create Space..

@ Welcome to Business Spa (rutuassiantlyiy
Getting Started '~ 1 Gatas Hnia

Manage Templates

___e. Enter a name such as Dashboard, and select the Business Monitoring template.

Create Space

*= Bpace name:
Dashhoard|

Space description:

% Create anew space using a template

| Business Monitoring i

__f. Click Save.
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Home ° GotoSpace s Manage Spaces Actions =
B Dashboard

Cperational

KPIs Exportalues Alert Manager KPI Manager
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Part 5: View KPI history information
In this section you will use the KPI history widget to view KPI historical information.
1. Configure the KPI history and prediction widget.

___a. On the new space, click the Analysis tab.

__b. Click the 'Edit Page' link to enter edit mode.

___c. To configure the KPI history and prediction widget, hover the mouse over the right corner of the

| ="

and then click the down arrow. Select 'Edit Settings...".

. Edit Settings...
0 Rename.. {b

___d. On the KPI tab, select 'Latest version', 'KPI ranges', 'KPI target'

KPI History and Prediction Edit

KFI Histary and Prediction

Selectthe models forwhich you wwant to retrieve the KPS,
(@ Latestwersion () Allversions

Display aptions

v| Pl ranges |v| KPIl target

___e. For the monitor model, navigate to Orderltem <timestamp> > Avg Order Price, then select it.

Selectthe KPIto display.

+ GlobalProcessManitor 2009-11-10 20:00:00
+ Order Handling 2008-06-27 14:14.44

+ ClipsAndTacks 2007-09-11 12:07:30

=] Order ltern 2006-08-03 00:00:00

() 5um Price Today

The * symbol indicates that historical data collection is not active faor this KPIL

__f. Click OK.

___g. You can adjust the granularity and the date window on the widget. The default display is two
months with daily data points. Initially the data display may be empty because historical data has
been loaded for this KPI only from years 2008 through 2010. You should adjust the dates to
display historical data within this date window. To change the date period, you can use the pre-
set date windows such as 1D or YTD, or you can click the blue From and To dates to open a
calendar picker to select specific dates.
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___h. The graph shows a line for the KPI value in blue. The black line is the target value. The three
bands of color represent the three ranges defined in the KPI.

KPI History and Prediction
1D 7D M 3M  6M  MTD YTD 1Y |08/02/200800:00 | — [10/28/2008 23:00]

Show data points Show data table

Avg Order Price

F40,000

F20,000

F20,000

F10,000

F0
Sep 1,2005  Sepf, 2005 Sep 1, 2003 Sep 16, 2005  Sep 21, 2005 Sep 26,2005 Oetd, 2003 OctG, 20058 Oct 11,2005  Oct 16,2005  Oct21, 2008 Oct 26, 2003

___i. To see the values in tabular format, click 'Show data table'.

KPI History and Prediction

1D 7D M 34 BM MTD YTD 1Y |080%200800:00| - |10/28/200823:00
Show data points Time Value
Sep 1, 2008 $34,402.65 =
Aug Order Frice Sep 2, 2008 $34,433.79
LAty Sep 3, 2008 $34,465.00 s
Sep 4, 2008 $34,496.28
Sep g, 2008 $34,527 63 |
$20,000 Sep B, 2008 $34,559.04
Sep 7, 2008 F34,58052
Sep 8, 2008 $34,622.07
F20,000 Sep 9, 2008 $34 65369
Sep 10,2008 $34,685.39
Sep 11, 2008 F34.71713
$10.000 Sep 12, 2008 $34,748.96
Sep 13, 2008 $34,780.85
Sep 14, 2002 Fadmz2m
0 Sep 14, 2008 $34,844 .84
Sepd, 2008 Sep ®, 2008 Sep 15, 2008 Sep 22, 2008 Sep 20, 2008  Ootf, 2008  Oet13, 2008  Oect20,2008 Oet27, 2008 SEp 16, 2008 $34,876.04 =

___j. To see specific values in the graph, hover your mouse pointer over the blue KPI value line.

Sep 11, ZOO2
$34,717.13

e
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___k. To see specific targets in the graph, hover your mouse pointer over the black target line. Since
the target coincides with the top of a range, you also see the range values.

Madiurm Target
$10,000,00 - $20,000,00 I$2D,DDD.DD

&

__|. To see ranges in the graph, hover your mouse pointer over the top of the range.

Low
$0.00 - $10,000,00

0

___m. There are hourly records loaded in KPI history and so you can experiment with various
granularities and date windows. To change the date window, you can use the pre-set date
windows such as 1D or YTD, or you can click the blue From and To dates to open a calendar
picker to select specific dates.

10 Fin. ™ am EM  MTD  5TD 1 09022008 00000 | -— [ 10028/2008 2300
I Finish Editing & I
L , o Save
___n. Click 'Save' to save your changes. H
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Part 6: Create a prediction model and view KPI prediction data

In this section you will create a prediction model, then view the prediction data in the KPI history and prediction
widget.

1. Configure and view KPI prediction for KPI Avg Order Price.
__a. On the KPI history and prediction widget, click the Edit Settings... menu option.

___b. Previously you configured the widget for the KPI Avg Order Price, so now click the tab History
and Prediction.

___c. Notice that it says that prediction is not enabled for this KPI, but that you can use the KPI
Manager to enable it.

A Qrder Price

KFI Prediction
Prediction is not enahled for this KPI. Use KPI Manager to enahle this feature.
Show predictions hased on the following prediction model

|N0ne v|

Show prediction data on graph by default

___d. Click the Cancel button to exit the configuration.

___e. Click the KPI Manager tab on the dashboard.

KPl Manager

Model: | Select a model.... ~ | Wersion: |Latest

___f. For model, select Order Item.

___g. Select Avg Order Price.

KPIl Manager
tadel: | Qrder ltem | Version: |Latest
KPl Hame Created Owner Type Access
@ Mg Order Price Modeled - Aggregate Shared
) Surn Price Today Modeled - Aggregate Shared

___h. Click Actions, and select History and Prediction.
___i. Click New Model to create a new prediction model.

KPI Prediction
_| Enahle KPI Prediction hased on the historical data for this KPI

Mew Madel

Model Hame Interval Period Cyclical Pattern ‘h

___j. Enter a prediction model name such as Daily. Select 'Once a day' for prediction data points. Enter
‘30" for the prediction period.
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Prediction Model Definition

mModel name

[Daind
Frediction data points

IOnce aday 'I

Predictian
period

« I? Diays

' Tothe end ofthe KPI time period

™ Include a repeating business pattern

I Cays
___ k. Click OK.

___ L. You will receive a message indicating that you need a time period to be set on this KPI.

The page at https:/ /localhost:9444 says:

1 CWMKPS36EE: Prediction models far KPIs with na kime period or with a fixed time period are nat
[ =\ supporked for aggregation functions AYG, MIM and MAY, AYG, MIN, and M&¥ predictions waould be
inaccurate since each time inkerval within the £PI period does not contribute ko the KPT equally. In
order ko create a KPI Prediction Madel with a prediction inkerval of daily, a KPT with a
repeating/rolling duration of daily should be created.

___m. You could update the model with a daily time period, but this would also delete the KPI history
when you re-deployed the changed model. To show you the prediction capability for a KPI with a

daily time period, another KPI 'Sum Price Today' is available which is already setup in the model.
Proceed to the next section to see how to setup prediction for this KPI.

___n. Click OK. Click Cancel. Click Cancel.

2. Configure and view KPI history for KPlI Sum Price Today.

___a. Onthe Analysis tab, click the 'Edit Page' link to enter edit mode.

___b. On the KPI history and prediction widget, click Edit Settings... on the widget menu.
___¢. Onthe KPI tab, select 'Latest version', 'KPI ranges', 'KPI target'

KPI History and Prediction Edit
KFI Histary and Prediction
Selectthe models forwhich you want to retrieve the KPIs.
(@ Latestwersion () Allversions
Display aptions

| KPlranges |»| KPItarget
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___d. For the monitor model, navigate to Orderltem <timestamp> > Sum Price Today, then select it.

Selectthe KPIto display. You can choase anly one at atime.

=1 Orderltern 2006-08-03 00:00:00
™ awg Order Price

___e. Click OK.

___f. You can adjust the granularity and the date window on the widget. The default display is two
months with daily data points. Initially the data display may be empty because historical data has
been loaded for this KPI only from years 2008 through 2010. You should adjust the dates to
display historical data within this date window. To change the date window, you can use the pre-
set date windows such as 1D or YTD, or you can click the blue From and To dates to open a
calendar picker to select specific dates.

__g. Notice that there is a repeating business pattern or business cycle such that there is a
significant drop in values on the weekends, so there is a seven day business cycle. You will use
this information when you create the prediction model.

KPI History and Prediction ¥ =0
1D 7D M 3w BM  MTD  YTD 1Y [1101/200800:00| — [12i0212008 0000
Show data points Show data table

Surn Price Today

$30,000
F22,000

F26,000

F24,000

F2z.000 /\ M

F20,000 £

F12,000
F16,000
F14,000
F12.000
F10,000

F2,000

FE,000
F4.000
$2,000
0
Mow 1, 2002 Mow 3, 2002 Mow S, 20028 Mov 7, 2002 Mowd, 2002 Mow 14, 2002 Mow 12, 2008 Hov 15, 2002 Mow 17, 2002 Mow 19, 2002 Mow 21, 20028 Mew 22, 2008 Mow 25, 20028 Mow 27, 2002 Moy 20, 2008 Dec 1, 2002

I Finish Editing = I

. oo | s
___h. Click 'Save' to save your changes. H

3. Create a prediction model for KPI Sum Price Today.
___a. Click the KPI Manager tab on the dashboard.
___b. For model, select Order Item.

__C. Select Sum Price Today.
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KPI Manager

model: | Qrder lterm

| Yersion: |Latest

KPI Name

Created Owner Type ACcess
) Awg Order Price Modeled - Angregate Shared
@ Sum Price Today Modeled - Angregate Shared

___d. Click Actions, and select History and Prediction.
___e. Select 'Enable KPI Prediction based on the historical data for this KPI'.

KFI Frediction
¥l Enable KPI Prediction baged on the historical data for this kP

___f. Click Apply. If you forget this step, then the predictions will not be displayed and you may have to
wait up to an hour for the KPI prediction service to run.

___g. Click New Model to create a new prediction model.

___h. Enter a prediction model name such as Daily. Select '‘Once a day' for prediction data points.
Enter '30' for the prediction period. As you saw in the KPI history graph, there is a seven day
business cycle. To provide a more accurate prediction, select 'Include a repeating business
pattern’, and enter 7 Days for the pattern. If you did not know there was a repeating 7 day pattern

or if you forgot to enter it here, the prediction will still be created, however it will not be as
accurate.

Prediction Model Definition

mModel name
[Daily

Frediction data poaints

I Once a day 'I

Prediction
period

& 120 Days
' Tothe end ofthe KPI time period

M Include a repeating husiness pattern

I?— Days

___i. Click OK. The KPI prediction service runs immediately, so this dialog may take a few moments to
close while the service is invoked. Do not click the OK button twice, since this will create a
duplicate model. You should see the prediction model listed as follows:

KPP Prediction
Iw} Enable KPI Prediction based on the historical data for this KPI

Mew Madel
Model Hame Interval Period Cyclical Pattern
Daily Once a day 30 7 days 7 K
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__j. Click OK.

4. Configure and view prediction data for KPI Sum Price Today.

___a. On the Analysis tab, click the 'Edit Page' link to enter edit mode.

___b. On the KPI history and prediction widget, click Edit Settings... on the widget menu.

___ €. Onthe KPI tab, insure that you have selected KPI 'Sum Price Today'.

___d. On the History and Prediction tab, select 'Show predictions based on the following prediction
model. Select Daily. Select 'Show prediction data on graph by default'. Take the defaults for the

remaining fields.
History and Prediction
Sum Price Today
KPI Prediction
| Show predictions based on the following prediction model
| Daily v
ivE Show prediction data on graph by default

___e. Click OK.

___f. Notice the orange diamonds that represent the prediction points in the graph. If you do not see
the orange diamonds, then the KPI prediction service has not completed, so wait a few moments

then refresh the widget display by clicking the down arrow in the upper right corner of the widget,
and selecting the refresh option.

KPI History and Prediction

Prediction | 1L 70 1™ am M MTDE  5TD itk 1012008 00:00 | - | 010172008 00:00 |

Show data points | Draily |¢| Showe data table
Sum Price Today

F30.000
§28,000
F26.000

$24,000 / /‘\\ / \_’ A
$22,000 V/\ I\ \ [\ /\A
$20,000 { ! I' \ - \'.

| :I ‘I |J |
$15.000 ! \ / I"‘ [ l'l, |
$14.000 [ ];' ‘\‘ f A1 \ /
F12.000 ( 1| | \ ||

J \
{ | \
F10.000 | \J
8,000 \/ \J \] \}
$G,000

F49.000

F2,000
0

F18.000

|

MNow1, 2008 Mow$, 2008 MNov3, 2005 Mov 13 2003 Mow 17,2003 Mo 21, 2008 Now 25, 2005 MNow 29, 2003 Dec3 2008 [ec?, 2008 Dec11,2008 Dec 15, 2008 Dec19, 2008 Dec23, 2008 Dec27 2008 Dec3d, 2008

___g. Click 'Show data table', and you can see the specific prediction values at the end of the table.
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| Pre ]

Show data paintg | Daily [

10 7O 1ht 3hd it MTD YD i 10152008 00:00 | |U1JO1.I’2009 0o:00

Sum Price Today

$30,000
F28.000
F26,000
F24.000
F22,000
F20.000

& & & &
L3 o2 L] L <
/\/\ /\/\ [\/\/\ /\/\ RS R R oo 5
|

Hide data tahle

F15.000
$16.000
F14.000
$12 000
$10,000
§2,000
5,000
F4000
2000
0

Mov 1, 2003 Nov G, 2005 Now 11, 2008 Nov 16, 2008 How 21, 2003 Nov 26, 2008 Dec 1, 2008 Dec, 2005 Dec 11, 2005 Dec 15, 2003 DecZ1, 2008 Dec 2D, 2005 Dec31, 2008

___h. Click 'Save' to save your changes.
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Time

Dec 16,2008
Dec 17, 2008
Dec 18,2008
Dec 13, 2008
Cec 20, 2008
Diec 21, 2008
Diec 22, 2008
Dec 23, 2008
Dec 24, 2008
Diec 25, 2008
Dec 26, 2008
Dec 27, 2008
Dec 28, 2008
Dec 29, 2008
Dec 20, 2008
Dec 31, 2008

Value
§22,370.47
§23743.29
§2z2.6576.18
2319247
§10,399.74
§7,833.24
§24,425.51
§22,370.47
§23,743.29
F2z2516.18
§23,192.47
§10,399.75
§7B3324
52442551
§22,370.47
§23,743.29
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Part 7: Create a business user alert based on the KPI prediction model

In this section you will configure a business user alert that will fire when the KPI prediction data exceeds a
predefined threshold.

1. Create a business user alert when the KPI prediction values exceed a predefined threshold.
__a. Click the Alert Manager tab in the dashboard.
___b. Click the New Alert button.

__c. Enter an alert name and optionally a description. Also, for the model, select 'Order Item 2006-08-
03 00:00:00' from the drop down.

alert

Conditions | Alert Content  Matification

Alertname | Prediction low

Diescription
Model | COrder lterm 2008-08-03 00:00:00
Owener admin

___d. In the Conditions section, click Add, which will add a row to the conditions table.

Conditions

Motify when all of the following conditions apply
KPI Name Prediction Model Condition Value
Clickto choose KPI Mone (Use actual data) Click to choose condition Clickto choose value

___e. For KPI Name, click to choose Sum Price Today.

___f. For Prediction Model, click to choose Daily (Anytime). You could also choose Daily (End) which
would only compare to end of day values.

___g. For Condition, click to choose 'Below range'.

___h. For Value, click to choose range Medium.

KPI Hame Prediction Model Condition Value

Sum Price Today DrailyiAnytime) Below range Medidm

___i. In the timing section, set the timing to 5 minutes, and set the notification frequency to 'Only once
during the KPI time period when the condition applies'. So this means that the condition will be
checked every 5 minutes, but the alert will be created at most once per day since the KPI period
is daily.
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Timing

How often to check conditions | Minutes |v| | g |v|

Yhen to start notifications | | GMT-05:00 [ne| [ americamiew_rork ||
Motification frequency | Cnly once during the KPR time period when the condition applies | v| | Surm Price Today | v|

___j. Click the Alert Content tab, and view the default message that is created. You could customize
the alert message if the generated content did not meet your needs.
Conditions | Alert Content | Motification

(® Generated content () Define your own content

Subject

Body

___k. Click the Notification tab, and you see that the administrative user is notified using a dashboard
alert.

Conditions  Alert Cantent | Notification

Recipients ¥| pashboard Alert || Cell Phone | E-mail | Pager
adrin | = = =
___ | Click OK.

___m. Click OK. You should see the new alert in the list.

Alert Manager

Alerts to Display | Al alerts [~]
Alert Name Description Owner _| Dashboard Alert _| cellPhone | E-mail _| pager
admin v = = =
Print 72 hours exceeded Alert v = = =]
NTB Failure Alert = =] = =
Invalid Loan Application Alert = = = =
Fee Compliance Alert ¥ = = =

2. In Business Space, click the Operational tab. You should see the new alert listed in the Alerts
widget. If you remember, the prediction values that you saw earlier included values that were in the
low range, so the alert should have been created since the condition on the alert was based on the
predicted value being below the medium range. If you do not see the alert, then wait a few moments
then refresh the widget display by clicking the down arrow in the upper right corner of the widget,
and selecting the refresh option.
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Alerts

| Mark Read || Mark Unread || Foraard Alert || Remave

-

Subject
|o FPrediction Iow |

¢ Feecompliance: Loan 091220

___a. To see the details of the alert, click the alert.

=)
=
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Suhject
e Prediction low

Declined ¢~ = *"
January 11, 2010 5:20:13 PM
Suhject
FPrediction Iow
Business situation name
FPrediction Iow
Comments
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Date and Time
January 11, 2010 5:20:13 PM

fremmeemeneea 50810 PM
X

Sum Price Today Daily Below range Medium
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What you did in this exercise

In the lab, you loaded the KPI history table with data, deployed a monitor model, and used the KPI history
and prediction widget to view the KPI historical information. You created a prediction model and viewed
KPI prediction information. You defined a business user alert based on the prediction model exceeding a

certain threshold.
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