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IBM WEBSPHERE BUSINESS MONITOR 7.0 — LAB EXERCISE

WebSphere Business Monitor V7.0 - Clips And Tacks -
Business process monitoring lab
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What this exercise is about

The objective of this lab is to show you how to monitor a business process which was developed in
WebSphere Business Modeler, implemented in WebSphere Integration Developer and deployed to
WebSphere Process Server.

This lab will provide solutions that you can import into Modeler and WebSphere Integration Developer, so
then you can concentrate on building the monitor model, deploying it, running tests and viewing monitored
data in the dashboards.
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Changes from the previous version
This lab has been modified for the 7.0 release. Here are the major changes:

Updated the dashboard section to show how to use the new business space which is based on Lotus
Mashups.

Lab requirements
List of system and software required for the student to complete the lab:
e WebSphere Business Modeler V7.0.
e WebSphere Integration Developer V7.0.

e WebSphere Business Monitor V7.0 — Toolkit Installation including the Monitor Model editor and
Monitor Server

0 DB2 Alphablox is an option during the installation of the Monitor toolkit. If you choose not to
install it, then you will not be able to use the report and dimension widgets in the dashboard.

What you should be able to do
At the end of this lab you should be able to:
 Use Modeler to export the business measures model and process model.

 Use WebSphere Integration Developer to implement the monitor model, and deploy it to the server.

« Define a business space dashboard to view monitored data.

Introduction

In this lab you will learn how to deploy a monitor model from end to end using WebSphere Business
Modeler, WebSphere Integration Developer and WebSphere Business Monitor. This lab will show you the
basic procedure for creating and implementing a simple model.

The model used in this lab is the ClipsAndTacks model which is also used in IBM Redbook SG247148 —
Business Process Management: Modeling through Monitoring Using WebSphere V6.0.2 Products.

In the Redbook, there are several models that are referenced, but in this lab you will be using the Future 1
Process.

In this lab you will build a monitor model that has the same basic elements as the one that is defined in the
Redbook. Namely you will create monitoring constructs in support of two KPIs:

e Average order fulfilment is three days or less

e Percentage of shipped orders is greater than 90%
You will also create situation events when the average order fulfillment time is greater than three days, and
when the percentage of orders shipped is less than 85%.

For dimensional analysis, you will create a Location dimension which allows you to drill down on country
and city. You will also add an Order Status metric, which shows orders as 'New', '‘Cancelled’ or 'Shipped’,
and you will create a dimension based on order status so that you can drill down on this value. And you
will add measures for average order price, sum of order price for all orders, and order count.
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Here is a diagram of the ClipsAndTacks process model:
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This is the ordering process for the Clips And Tacks company. In this process, orders are received and
optionally submitted to a review process. Orders which pass all checks are shipped to the customer. Other
orders may be cancelled.

In this lab you will use Modeler and import a process model which was created for you. You will select
processing time and decision percentage monitored values in the business measures model in Modeler.
Then you will export the process model and monitor model to WebSphere Integration Developer. You will
import a solution file that contains the process implementation. Then you will complete the implementation
of the monitor model. You will deploy the monitor model, run process instances and view results in the
business space dashboard. Finally, you will export monitored values back to Modeler.

URL cheat sheet

These URLs might be helpful to you as you exercise this lab. Note that the port numbers in the URL of
your installation may be different depending on your configuration.

e Server administrative console

https://localhost:9044/ibm/console

e Business space dashboard

https://localhost:9444/BusinessSpace
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Part 1: Import the model into Modeler

Instead of building the process model from scratch, you will import the model into WebSphere Business
Modeler. You will review the process model and the business measures model.

1. Start WebSphere Business Modeler and setup the environment.

___a. Start WebSphere Business Modeler, and when prompted point to a new workspace such as
c:\workspaces\clipsmodel

___b. Close the Getting Started tab.
___C. Click Modeling > Mode > WebSphere Process Server.

[DEIJC:-

___d. Click the icon in the toolbar to apply the four pane layout. =

2. Import the supplied Modeler project.
___a. Right click in the Project Tree, then select Import...
__b. Select WebSphere Business Modeler project (.mar, .zip)

___c. For source directory, browse to the folder containing the supplied mar file, for example,
c:\Labfiles70\ClipsAndTacksBPM

___d. For files, select CATOrderMgmt.mar.
___e. Click Finish.
3.  Review the process.

___a. Inthe Project Tree, navigate to CATOrderMgmt > Processes > Order Handling, then double
click the process to open the editor. In the editor, you can review the diagram which represents
the process model. Notice that there are various tasks, decisions, human tasks, and a business

rule.
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___b. For each task in the diagram, click the task, then click the Attributes tab and review the
information. For implementation details, click the Technical Attributes View tab. You will see
these implementations:

1) Check Order Handling Policy for Automatic Approval — rule group. Click the Business Rules
tab and you will find that a business rule is used to check the order price and require
manual approval if it is greater than or equal to $750.

2) Review Order — human task

3) Ship Order to Customer — human task

4) Check Customer Account Status — java

5) Cancel Order and Send Notification — java

6) Update Order Database — java
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Part 2: Create the business measures model in Modeler

In this section you will create the business measures model in Modeler. You will select monitored values
for decision percentages and processing times. You will also add aggregate measures, dimensions and
KPIs.

If you want to skip this section, a solution has been provided. You can import the supplied Modeler MAR
file and then proceed to the next section. Refer to Appendix 1, and then proceed to the next section.

_ 1. Select monitored values
__a. In Modeler, to open the business measures tab, select Windows > Business Measures
__b. Click the white background of the process diagram.
___C. Click the Business Measures tab, then click the Monitored Values tab.

___d. Onthis tab is a list of all the elements in the process, including the decisions and tasks. If you
select any of these items, then the corresponding business metrics are created automatically in
the Business Performance Indicators tab. Select '% Per Branch' for the three decisions. Also
select 'Processing Time' for the process and the six tasks.

Business Performance Indicators | Monitored values

Monitored values

This section indicates which values vou want returned from WebSphere Business Monitar after the process has been maonitored,

Process Elament Processing Time Processing Cosk Startup Cosk Resenue %= Per Branch
# Acceptable Credi
Q Account in Good Standing? od
<Z Approve Withouk Resiew? wdl

Cancel Order and Send Matification ~"| dverage Can...

Check Cuskomer Account Status | Average Che...

£ Check Order Handling Palicy For Automatic Approval || Average Che...

L order Handling ~"| Awerage Ord. ..

./3.:) Review Order ~"| Average Revi...

.@ Ship Crder bo Customer | Average Ship. ..

Update Order Database | Awerage Upd...

___e. On the Business Performance Indicators tab, review the metrics that were created based on your
monitored values selections.
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Business measures summary

This section provides information about business measures such as metrics and KPIs,

[ame

= LE- Instance Metrics
'_'ﬁ Acceptable Credit Risk? Yes Bre
'_'ﬁ Acceptable Credit Risk? Mo Eran
i Account in Goad Standing? Yes
i Account in Good Standing? Mo |
';ﬁ Approve Without Review? Yes
';ﬁ Approve Without Review? Mo E
ﬁ Cancel Order and Send Motificz
ﬁ Check Customer Account Statu
ﬁ Check Order Handling Policy for
I‘éﬁ Order Handling Processing Time
ﬁ Review Order Pracessing Time
ﬁ Ship Order ko Custamer Proces
ﬁ Update Order Database Proces
[ (= Aggregate Metrics

2! Dimensions

ﬁ Average Acceptable Credit Risl
j Average Acceptable Credit Risl
j Average Account in Good Starn
_j Average Account in Good Star
_j Average Approve Without Rey
_j Average Approve Without Rey
_j Average Cancel Order and Sen
_j Average Check Customer Acco
_j Average Check Order Handling
_:'] Average Crder Handling Proces
__f': Average Review Order Process
__f'] Average Ship Crdar o Custaor
__f'] Average Update Order Databa

E- Unspecified Metrics

Time Period | Description

This metric measures whether the Yes branch For Acceptable Credit Risk? was taken.
This metric measures whether the Mo branch For Acceptable Credit Risk? was taken.
This metric measures whether the Yes branch For Account in Good Standing? was taken.
This metric measures whether the Mo branch For Account in Good Standing? was taken.
This metric measures whether the Yes branch For &pprove Without Review? was taken.
This metric measures whether the Mo branch For Approve Without Review? was taken.
This metric measures the processing time of Cancel Order and Send Motification,

This metric measures the processing time of Check Customer Account Status,

This metric measures the processing time of Check Order Handling Policy For Automatic Approval,
This metric measures the processing time of Order Handling,

This metric measures the processing time of Review Order,

This metric measures the processing time of Ship Order to Customer,

This metric measures the processing time of Update Order Database,

This metric measures the average decision branch percentage for Acceptable Credit Risk? Yes.
This metric measures the average decision branch percentage for Acceptable Credit Risk? Mo,
This metric measures the average decision branch percentage for Account in Good Standing? Yes.
This metric measures the average decision branch percentage for Account in Good Standing? Ma.
This metric measures the average decision branch percentage for Approwve Without Review? Yes.
This metric measures the average decision branch percentage for Approve Without Resiew? Mo,
This metric measures the average processing time of Cancel Grder and Send Motification.

This metric measures the average processing time of Check Customer Account Status.

This metric measures the average processing time of Check Order Handling Policy For Automatic Approval,
This metric measures the average processing time of Order Handling,

This metric measures the average processing time of Review Order,

This metric measures the average processing time of Ship Order to Customer,

This metric measures the average processing time of Update Order Database,

Create a dimension for location. Since you want to perform dimensional analysis by country and
city, then you need to add the Location dimension. You cannot specify a two level dimension in
Modeler, so you will just create a single level here and then you will complete the implementation in

the Monitor toolkit.

__a. On the Business Performance Indicators tab, double click the first aggregate metric in the list.
This opens the Business Measures Details window.

___b. On the Business Measure Detalils tab, select the check box to specify the dimensions that will be

available.

___C. Click the Add button, then highlight the default name of the dimension and change it to Location.

Dimensions for Analysis

‘fou can provide an inskance metric as the implementation For each dimension. For example, an instance metric that holds the name of a city

can be the implementation for the city dimension,

Specify the dimensions that will be available in the dashboards for analvsis of this metric

Dimension

| Inskance Mekric |

Rermone

___d. Leave the Business Measures Details window open. You will be adding metrics using this

window.
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3. Create a KPI for average process duration.

___a. Inthe Business Measures navigator on the left of the Business Measure Details window, click
the Add button.

Gl Average Ship Crder ko Customer Pro
1 Awerage Update Order Database Pr
B Dimensions

[P Unspecified Metrics

1 | 0|

| Add | | Remove | | Add From KPI Library... |

___b. Change the name to Average Process Duration KPI

___c. Fortype, select KPI.

Business Measure Information

Marmne | fAverage Process Duration KPI

Type & kPT O Instance metric 3 Aggregate metric O Unspecifisd

___d. On the Business Measure Details tab set the following values: type duration, target 3 days, range
Good 1 to 3 days, range Too long 3 to 5 days, time period repeating yearly, specify an alert with
default name

1) Select the check box to specify a target
2) Target type — Duration

3) Target value — 3 Days

Business Measure Details ] Dashboard Samples

Target Type and Yalue

The barget is an exact value that the KPI should achieve,

apecify a target type and value

Type: | Duration E“

Days Hours Minukes Seconds Milliseconds

Target value: |3 }%' |D }%' |D }%' |u }%' |D }%'

4) Select the check box to specify a range
5) Select button for range Actual Value
6) Add range 'Good' with start value 1 day and end value < 3 days

7) Add range 'Too long' with start value 3 days and end value < 5 days
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Ranges
Specify range details:

Ranges can be defined as percentages of the target value or as fixed, actual values,
O Percentage of karget value (karget value = 100%)
@ fctual value

Specify ranges
A range is a set of values, such as allowable margins or lower and upper limits, against which to track your KPT.

F.ange Mame | Skark Walue | End Walue |
Good 1 Dy 0 Seconds < 3 Days 0 5Seconds add
Too long 3 Davs O Seconds < 5 Days 0 Seconds

Domauo

8) Select the check box to specify an alert

9) Add an alert and take the default name 'Average Process Duration KPI Alert'

Alerts

‘o can specify instruckions For notification when specific conditions oocur, For example, when this measure exceeds a certain value, send an
e-mail,

Specify when to send an alert and the action to take as a result

Alert Description |

Average Process Duration KPT Alert
Remove

10) Select the check box to specify how to calculate the KPI
11) Select the button to based the KPI on a metric and aggregation function
12) Set the instance metric to aggregate to 'Order Handling Processing Time'

13) Set the aggregation function to Average.

KPI Calculation Details

Specify the method used to calculate this KPIL IF vou choose to calculate the KPI based on an instance metric, you will also be able o specify
the time period and data filkers For use with the £PLL

Specify how ko calculate this KPT

() Based on an instance metric and an aggregation Funckion

Instance metric to aggregate: | Order Handling Pracessing Time E“ Mew...

Aggregation funckion: | Average E“

O Using an expression invakving other KPIs

| < Click the Edit. .. button bo enter an expression > :|| Edit..,
14) Select the check box to specify a time period
15) Select button for time period Repeating

16) Set period type to Yearly, and base period on 'Period in progress'
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Time Period for Data Collection

Specify a time period over which the business measure will be monitored

(%) Repeating ) Rolling O Fixed
Period type: lLast: Shart date:
| Yearly |z” | 30 H: | darys E“ |
Time zone: End date:
| GMT-6 =] |
Base period on: Tjirre zome:
O Last full period | GMT-5 E“

{®) Period in progress

4. Create a KPI for percentage of orders shipped.

___a. Inthe Business Measures navigator on the left of the Business Measure Details window, click
the Add button.

b. Change the name to Percentage of Orders Shipped KPI
c. For type, select KPI.

d. On the Business Measure Details tab set the following values: type number, target 90, range
Low 0 to 85, range Good 85 to 90, range Great 90 to 100, specify an alert with default name

e. You would normally select how to calculate the KPI, but for this KPI you will leave this to the
developer to determine

__f. No time period is required.
5. Create a measure to track the total order count.

a. In the Business Measures navigator on the left of the Business Measure Details window, click
the Add button.

b. Change the name to Order Count
c. For type, select Aggregate metric.

d. On the Business Measure Details tab set the following values: function count, instance metric
'‘Order Handling Processing Time'. Note that you could select any instance metric in the model to
count and this aggregation will work fine.

6. Create a measure to count shipments.

a. In the Business Measures navigator on the left of the Business Measure Details window, click
the Add button.

b. Change the name to Ship Count
c. For type, select Aggregate metric.

d. On the Business Measure Details tab set the following values: function average, do not specify
an instance metric since you are not sure how to calculate this so just leave it up to the
developer.

7. Create a measure to count declined orders.
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a. In the Business Measures navigator on the left of the Business Measure Details window, click
the Add button.

b. Change the name to Decline Count
c. For type, select Aggregate metric.

d. On the Business Measure Details tab set the following values: function average, do not specify
an instance metric since you are not sure how to calculate this so just leave it up to the
developer.

8. Create a metric for price so that you can use that metric as a source for aggregations that will
average the order prices and total the order prices.

___a. Inthe Business Measures navigator on the left of the Business Measure Details window, click
the Add button.

___b. Change the name to Price
___c. For type, select Instance metric.

___d. On the Business Measure Details tab set the following values: template 'Business Item Input',
process element 'Order Handling', attribute ‘Order.TotalPrice(Input)

9. Create a measure to sum order price.

a. In the Business Measures navigator on the left of the Business Measure Details window, click
the Add button.

b. Change the name to Sum Order Price
c. For type, select Aggregate metric.

d. On the Business Measure Details tab set the following values: function sum, instance metric
'Price’, take the default dimension 'Location’.

10. Create a measure to average order price.

a. In the Business Measures navigator on the left of the Business Measure Details window, click
the Add button.

b. Change the name to Average Order Price
c. For type, select Aggregate metric.

d. On the Business Measure Details tab set the following values: function average, instance metric
'Price’

11. Click OK.

12. Press Ctrl-S to save your work.
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Part 3: Export to WebSphere Integration Developer

In this section you will export the business process and the business measures model to WebSphere
Integration Developer.

1. Export to WebSphere Integration Developer.

___a. Right click in the Project Tree on CATOrderMgmt, then select Export > WebSphere Integration
Developer.

___b. Click Next.
___c. Browse to a target directory. Select 'Export entire project and related projects'.
___d. Click Next.
___e. Use the recommended export option.
___f. Click Next.
___ 0. Select 'Export business measures as a monitor model or models'.
___h. Select 'Export to a single monitor model...".
__i. Click Finish.
2. This creates two project interchange files
___a. Process file - CATOrderMgmt_<timestamp>.zip
___b. Business measures file — CATOrderMgmt_Monitor_<timestamp>.zip

3. Close WebSphere Business Modeler.
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Part 4: Import the process into WebSphere Integration Developer and
iImplement the activities

In this section you will import the process from Modeler into WebSphere Integration Developer. Normally,
then you would implement the various activities in the process, but to save some time you will import a
solution which already has the implementation for the activities. Using the best practice approach, Modeler
has automatically created three separate projects, one for the process (CATOrderMgmt), one for the
implementation (CATOrderMgmt_impl) and one for a library of common elements (CATOrderMgmt_lib).

1. Start WebSphere Integration Developer and setup the environment.

___a. Start WebSphere Integration Developer, and when prompted point to a new workspace such as
c:\workspaces\clipsbpm

___b. Close the Welcome tab.

___c. By default, you are in the Business Integration perspective.
_ 2. Import the process.
a. In the Business Integration view, right click then select Import...
b. Navigate to Other > Project Interchange then click Next.

c. For the .zip file, browse to the process output file from Modeler, for example,
'CATOrderMgmt_2008-06-15T10.12.26.zip'. Note that the timestamp in your file name will be
different.

d. You should see three projects listed, so click Select All.

e. Click Finish.

___f. You should see three projects listed in the Business Integration view, one for the process
(CATOrderMgmt), one for the implementation (CATOrderMgmt _impl) and one for a library of
common elements (CATOrderMgmt _lib):

Projects

®-F2) CATOrderMgmt
‘@ CATOrderMagrnt_impl
BB CaTorderMgrt_lib

3. Atthis point, you could add the implementations for the human tasks, business rule and Java code.
However, to save some time, you will import the solution which has already been updated with the
implementations.

___a. Inthe Business Integration view, right click then select Import...
__b. Navigate to Other > Project Interchange then click Next.

__c. For the .zip file, browse to the supplied file, for example,
c:\Labfiles70\ClipsAndTacksBPM\CATOrderMgmt_ProcessSolution_Pl.zip
___d. Select all projects.
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___e. Click Finish. Click OK to confirm overwrite.

___f. If you see errors, then try to clean the workspace by selecting Project > Clean ... > select 'Clean
all projects', then click OK.

___g. If you want to review the implementation, in the Business Integration view, navigate to
CATOrderMgmt_impl > Integration Logic. You will find three Java implementations.

1) CheckCustomerAccountStatusimpl — Java is used to calculate the credit amount for the
customer. When you run an instance of the business process, you will enter the old credit
rating and old credit amount. This routine calculates a new credit rating which is a random
number between 500 and 800. It calculates a new credit amount which is based on an
adjustment to the old credit amount, using this formula: newAvailCredit = oldAvailCredit
+((newRating-oldRating)*0.1).

2) The other two Java implementations just print messages to the log.
___h. If you want to review the BPEL process, in the Business Integration view, navigate to
CATOrderMgmt > Integration Logic > Processes > processes\orderhandling, then double

click OrderHandling to open the BPEL editor. You may get a warning about a generated file, but
you can click Yes to view the flow. This is a summary of the flow:

1) Check Order Handling Policy for Automatic Approval. Implemented as a business rule. If
Order.totalPrice < 750, go to Check Customer Account Status, else go to Review Order

2) Check Customer Account Status. Implemented as Java to calculate a new credit amount. If
Order.totalPrice > new credit amount, go to Review Order else go to Ship Order to
Customer.

3) Review Order. Implemented as a human task. If ReviewOrder.OrderStatus is APPROVED
then go to Ship Order to Customer else if ReviewOrder.OrderStatus is DECLINED go to
Cancel Order and Send Noaotification.

4) Ship Order to Customer. Implemented as a human task. Goes to Update Order Database.

5) Cancel Order and Send Notification. Implemented as Java to print messages to the log.
This is the end of the flow.

6) Update Order Database. Implemented as Java to print messages to the log. This is the end
of the flow.
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Part 5: Verify that the BPEL process emits monitor events

When you export the process from Modeler, the events that are required for monitoring are already
selected to be emitted. Monitor will need events for the process and the invokes in the process. Modeler

decisions become links in BPEL, so Monitor also needs events for the flow element in BPEL.

1.

In the Business Integration view, navigate to CATOrderMgmt > Integration Logic > Processes >
processes\orderhandling, then double click OrderHandlingFuturel to open the BPEL editor.

Click the white backbround of the process. Make sure that you click outside of the flow element
which is the large rectangle that contains the receive, reply and invoke elements . Then click the
Properties tab, then click the Event Monitor tab. Note that all process events are selected.

Click inside the flow element OrderHandlingFuturel Flow, and note on the Event Montor tab that
all the events are selected.

Select each invoke in the BPEL diagram and note on the Event Monitor tab that all the events are

selected.

Here is a screen print that shows the small yellow flags that indicate that the events are selected for
the components. There are flags on the receive and each of the six invokes. The flag in the upper
left represents the flow. The flag in the upper right represents the process. So there are nine flags in

total.

5 orderHanding 2
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Part 6: Import the business measures into WebSphere Integration
Developer and implement the monitor model

In this section you will import the business measures from Modeler into WebSphere Integration Developer.
This section shows you how to complete the implementation of the monitor model.

If you want to skip this section, a solution has been provided. You can import the supplied project
interchange file and then proceed to the next section. Refer to Appendix 2, and then proceed to the next
section.

1. Switch to the Business Monitoring Perspective

___a. Inthe upper right corner, click the perspective icon and select Business Monitoring.

5 | E5 Business Inte. ..
I

| E?S Busingss Inkedgration =

= Business Maonitoring k

T Profiling and Logaing

Other, ..

2. Import the business measures from Modeler.
a. In the Project Explorer view, right click then select Import...
b. Navigate to Other > Project Interchange then click Next.

c. For the .zip file, browse to the business measures output file from Modeler, for example,
'CATOrderMgmt_Monitor_2008-06-15T10.12.26.zip". Note that the timestamp in your file name
will be different.

d. You should see one project listed, so select it.

e. Click Finish.

___f. You should see the new project CATOrderMgmt_Monitor listed in the Business Integration view.
Note that it has a red X’ marker because there are errors due to missing elements in the monitor
model.

5. Praject Explarer 53 = O |
B

ig CATOrderMart §

1% CATOrderMgrt_Monitor

3. Open the Order Handling Monitor monitor model.

___a. Inthe Project Explorer navigate to CATOrderMgmt_Monitor > Monitor Models and double click
Order Handling Monitor.mm

4. Review the monitor model. In the Monitor Details Model tab, you see there is a monitoring context
for the process and one monitoring context for each activity in the process. On the inbound events
for the process and activities, the correlation information is already setup. There are also termination
triggers setup for you. And notice the metrics and stopwatches that are in the model for calculation
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of the processing times and decision percentages. On the KPI Model tab, you see the two KPI's
along with triggers for alerts. One of the KPI's needs implementation details so it has a red marker.
In the dimensional model tab, you see the measures in the Order Handling Cube. Several
dimensions have red markers because they need implementation details. On the Visual Model tab,
you see there are two SVG diagrams installed, one for the process and one for the KPI context
(Order Handling and Order Handling KC). On the Event Model tab, expand the listing for
/CATOrderMgmt_lib/businessitems/businessitems.xsd, and you will see the business item schema
definitions which are located in the process library CATOrderMgmt_lib.

5. Click the KPI Model tab.

6. Inthe KPI model, update Average Process Duration KPI Trigger 1. This trigger is used to fire the
situation event when the process duration is too long.

___a. For Trigger condition, enter this expression:

Average_Process_Duration_KPI ge dayTimeDuration('P3DT1H")

+ Trigger Condition
Specify the condition that determines whether the trigger will fire,

Average_Process_Duration_KPT ge dayTimeDuration{ P30DT1H?

7. Inthe KPI model, update Percentage of Orders Shipped KPI Trigger 1. This trigger is used to fire
the situation event when the percentage of shipped orders is too small.

___a. Inthe trigger source table, click Add
__b. Select Recurring wait time, then click OK. This will default to 1 minute.
__c. For Trigger condition, enter this expression:

Percentage_of Orders_Shipped_KPI < 85

+ Trigger Condition
Specify the condition that determines whether the trigaer will Fire.

Percentage_of _Orders_Shipped_KPI < 85

8. Press Ctrl-S to save your work.

9. Inthe KPI model, update the KPI Percentage of Orders Shipped KPI. In order to calcuate the
percentage of orders shipped you will create a KPI for the number of shipped orders, and you will
create another KPI for the total number of orders, then you can determine the percentage by
dividing the shipped orders by the total orders.

___a. Inthe details model, create a new trigger Shipped Order Trigger

1) Right click in the Monitor Details Model navigator on the Order Handling monitoring
context, and select New > Trigger

2) Enter name: Shipped Order Trigger, click OK
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3) In trigger sources, click Add, then select Other source type, navigate to Order Handling >
Ship Order to Customer > Ship Order to CustomerEXIT, click OK

* Trigger Sources
Specify the source of this trigger,

Source Type | Source
Event e Ship Crder to CustomerEXIT

___b. In the details model, create a new trigger Cancelled Order Trigger

1) Right click in the Monitor Details Model navigator on the Order Handling monitoring
context, and select New > Trigger

2) Enter name: Cancelled Order Trigger, click OK

3) In trigger sources, click Add, then select Other source type, navigate to Order Handling >
Cancel Order and Send Notification > Cancel Order and Send NotificationEXIT, click OK

+ Trigger Sources
Specify the source of this trigger,

Source Type | Source
Event g Cancel Order and Send MotificationERIT

___C. Inthe details model, create a new metric Order Status

1) Right click in the Monitor Details Model navigator on the Order Handling monitoring
context, and select New > Metric

2) Enter name: Order Status, enter type: String, click OK

3) Select 'A value is required for this metric', since a dimension will use this metric and that
requires a value for dimensional analysis.

4) For Default value, enter 'New' with the quotation marks.

5) In Metric value expressions, click Add. In the trigger cell, enter trigger type Cancelled Order
Trigger. In the expression cell, enter 'Cancelled’ with the quotation marks.

6) In Metric value expressions, click Add. In the trigger cell, enter trigger type Shipped Order
Trigger. In the expression cell, enter 'Shipped' with the quotation marks.

+ Metric ¥alue Expressions

Specify the expressions that set the value of the metric,
trigger fires,

Trigger | Expression
£ Cancelled Order Trigger ' 'Cancelled!
=4 Shipped Order Trigger %" shipped

___d. In the KPI model, create a new KPI Shipped Orders. You will use the key metric to count all
incoming instances, then filter it by the order status so you only count shipped orders. You will
also filter it by the process state, so only completed process instances are counted.

1) In the KPI model navigator, right click Order Handling KC and select New > KPI.
2) Enter name Shipped Orders, click OK.

2010 October, 05 IBM WebSphere Business Monitor 7.0 — Lab exercise Page 19 of 46

ClipsAndTacks



© Copyright IBM Corporation 2010. All rights reserved

3) Set the type to decimal.

4) Select 'Keep track of historical values for this KPI'

5) For KPI value, select 'Base this KPI on a metric and an aggregation function'
6) For monitoring context, browse to Order Handling

7) For metric, browse to Order Handling Instance ID.

8) For aggregation function, select Count

9) For data filter, click Add, then browse to Order Handling > Order Status, then click OK. In
the values cell, enter 'Shipped’ with the quotation marks.

Data Filter
Select the metrics thak wou wank £o use to determing what values to use in the caloulation, For example, if wou hawve a KPI
called Average Price in Londan, wou only want ko use monitaring contexts where the value of the City metric is Londan,
Metric | Cperakar | Walues | Case-sensitive |
A Order Skatus equals =+-3Y ‘Shipped'

___e. Inthe KPI model, create a new KPI Total Orders. You will use the key metric to count all
incoming instances.

1) In the KPI model navigator, right click Order Handling KC and select New > KPI.
2) Enter name Total Orders, click OK.
3) Set the type to decimal.
4) Select 'Keep track of historical values for this KPI'
5) For KPI value, select 'Base this KPI on a metric and an aggregation function’
6) For monitoring context, browse to Order Handling
7) For metric, browse to Order Handling Instance ID.
8) For aggregation function, select Count
__f. Finalize the KPI, Percentage of Orders Shipped KPI
1) In the KPI model navigator, select the KPI Percentage of Orders Shipped KPI
2) For KPI Value, select "Write an expression to calculate this KPI based on existing KPIs'
3) For KPI Calculation, enter:

(Shipped_Orders div Total_Orders) * 100

KPI Calculation

For example, vou could have a Tokal Profit KPT that subtracks the Total Cost KPT From the Tokal Revenue KPTL

(shipped_COrders div Total_Crders) * 100

10. Press Ctrl-S to save your work.
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_____11. Create the shipped percentage situation event which will use the built-in ActionServicesEvent
definition. This event contains a field called BusinessSituationName which is a required field for the
outbound situation event. Then you will define an outbound event which is fired by the trigger. In this
outbound event, you will provide a value for the field BusinessSituationName which will be used
later when configuring action manager in the server administrative console.

_a

b

Click the KPI Model tab

Right click in the navigator on Order Handling KC, select New > Outbound Event

__c. For name, enter Shipped Percentage Event

_d.

-

Select the check box for 'Configure this event to generate an alert in the dashboards'

For trigger, browse to Order Handling KC > Percentage of Orders Shipped KPI Trigger 1

__f. Click OK

_g
_h

12. Pre

Notice that the extension name defaults to the ActionServicesEvent.

In the Outbound Event Content, navigate to Percentage of Orders Shipped KPI Trigger 1 >
Extended Data > BusinessSituationName, and notice that the expression is already set.

* Outhound Event Content
Specify the triggers that cause the event ko be sent, Use the Expression column to specify the value for each e
the event is sent,
Marmne | Tvpe | Expression
= 3=:9 Percentage of Orders Shipped KPI Trigger 1
L:_:. Property Daka
B (& Extended Data
= Businesssituationtiame A string >§+?Y ‘Shipped Percentage Event'

ss Ctrl-S to save your work.

13. Create the order processing time situtation event. You will create an event definition containing a
field called BusinessSituationName which is a required field for the outbound situation event. You

will

also create a field to store the average processing time to display in the alert. Then you will

define an outbound event which is fired by the trigger. In this outbound event, you will provide a
value for the field BusinessSituationName which will be used later when configuring action manager
in the server administrative console, and you will supply the data source for the average processing
time in the event.

__a. Create an event definition for average order processing time.

2010 October, 05

1) In Project Explorer, right click CATOrderMgmt_Monitor and select New > Event
Definition...(cbe)

2) For file name, enter LateAverageOrderShippedEvent.cbe

3) Click Finish

4) The Event Definition Editor for LateAverageOrderShippedEvent opens.
5) Double click the hierarchical icon next to the label Parent.

6) On the Select Event Definition Dialog double click event.

7) Event is now shown as the parent of LateAverageOrderShippedEvent
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8) On the event definition, click the icon for Add Extended Data . This adds a row to the
Extended Data table.

9) For the new data element, change the Extended Data name from 'datal’ to
'‘BusinessSituationName' by clicking on datal and typing the new name.

10) For the new element, change the type to string. Do this by clicking on 'noValue' and then
you are given a drop down box.

11) On the event definition, click the icon for Add Extended Data. This adds a second row to
the Extended Data table.

12) For the second data element, change the Extended Data name to
AverageOrderProcessingTime

13) For the second element, change the type to string.
14) Press Ctrl-S to save your work.
___b. Create the outbound event Order Fulfillment Event
1) Click the KPI Model tab
2) Right click in the navigator on Order Handling KC, select New > Outbound Event
3) For name, enter Order Fulfillment Event
4) Select the check box for 'Configure this event to generate an alert in the dashboards'
5) For trigger, browse to Order Handling KC > Average Process Duration KPI Trigger 1
6) Click OK

7) In Event Type Details, for extension name, browse to CATOrderMgmt_Monitor >
LateAverageOrderShippedEvent.cbhe > LateAverageOrderShippedEvent, then click OK.

8) In the Outbound Event Content, navigate to Average Process Duration KPI Trigger 1 >
Extended Data > BusinessSituationName, and notice that the expression is already set.
For AverageOrderProcessingTime, set the expression to

xs:string(Average_Process_Duration_KPI div xs:dayTimeDuration('P1D"))

This will display the average process duration in day units.

w Dutbound Event Content
Specify the triggers that cause the event to be sent, Use the Expression column bo specify the value for each event attribute when the event is sent.

Marme | Type | Expression

E=l :‘=:=> Average Process Duration KPT Trigger 1
L?_:. Property Data
=] ﬁg Extended Data
[E BusinesssituationMame A skring X$Y ‘order Fulfillment Event’
= AverageCrderProcessingTime A string ﬁ* wsistring{Average_Process_Duration_KPI div xs:day TimeDuration('P10'))

14. Press Ctrl-S to save your work.

15. Click the Dimensional Model tab.
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16. In the navigator, locate Order Handling > Order Handling Cube. All of the dimensional work will be
performed in this cube.

17. Delete Decline Count, Order Count, and Ship Count. You can get this information using the built-
in function Instances Count in the Dimensional view of the dashboard, and then creating a
dimension on order status which is a metric which identifies new orders, shipped orders and
cancelled orders.

18. Create dimension Order Status. This will be useful for drilling down in the Dimensional view of the
dashboard to aggregate instances by their order status.

a. Right click in the Dimensional Model navigator on Order Handling Cube, then select New >
Dimension.

b. Name it Order Status and click OK.
c. Right click Order Status in the navigator, then select New > Dimension Level

d. Name it Order Status, then click Browse next to Source Metric, and navigate to Order Handling >
Order Status, then click OK.

e. Click OK.

19. You want a multi-level dimension called Location which will allow you to drill down on country and
then city within country. To enable Location, you need to create metrics for country and city, then
you can complete the Location dimension to reference the metrics.

___a. In the monitor details model, create metric Country

1) Right click in the Monitor Details Model navigator on Order Handling, and select New >
Metric

2) Enter name: Country, enter type: String, click OK

3) Select 'A value is required for this metric’, since a dimension will use this metric and that
requires a value for dimensional analysis.

4) For default value, enter an empty string (two single quotation marks)

5) In Metric Value Expressions, click Add. In the expression cell, use content assist to navigate
to the event ‘Check Order Handling Policy for Automatic Approval ENTRY’ and select
Country in the Input data in the Customer record.

Check_Order_Handling_Policy for_Automatic_Approval/Check_Order_Handling_Policy for A
utomatic_ApprovalENTRY/Input/Customer/Country

w Metric Yalue Expressions
Specify the expressions that set the value of the metric, IF a trigger is specified, the expression is evaluated when the trigger Fires,

Expression
= ;%” der Handling Policy

for_Aukomatic_Approval/Check Crder Handling Policy For automatic_ApprovalEMTRY Input)/Cuskomerf{Country

___b. In the monitor details model, create metric City

1) Right click in the Monitor Details Model navigator on Order Handling, and select New >
Metric

2) Enter name: City, enter type: String, click OK
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3) Select 'A value is required for this metric', since a dimension will use this metric and that
requires a value for dimensional analysis.

4) For default value, enter an empty string (two single quotation marks)

5) In Metric Value Expressions, click Add. In the expression cell, use content assist to navigate
to the event ‘Check Order Handling Policy for Automatic Approval ENTRY’ and select City
in the Input data in the Customer record.

Check_Order_Handling_Policy for_Automatic_Approval/Check_Order_Handling_Policy for_A
utomatic_ApprovalENTRY/Input/Customer/City

+ Metric ¥alue Expressions
Specify the expressions that sek the value of the metric, If a trigger is specified, the expression is evaluated when the krigger fires,

Trig. .. | Expression

3=:9‘ 5" Check_order_Handling_Palicy_For_futomatic_Approval/Check_Order_Handling_Palicy_for_futamatic_spprovalENTRY Input)Custamer | City

__c. Inthe Dimensional model, update the Location dimension using the two metrics.

1) In the Dimensional Model, navigate to the Order Handling Cube > Location. Notice that
there is a dimension level called Location underneath the dimension Location.

2) Right click the dimension level underneath the Location dimension and select delete. This
will delete the dimension level, but the dimension will remain.

3) Right click dimension Location, then select New > Dimension Level

4) Name it Country, then click Browse next to Source Metric, and navigate to Order Handling >
Country, then click OK.

5) Click OK.

6) Right click Location in the Dimensional Model navigator, then select New > Dimension
Level

7) Name it City, then click Browse next to Source Metric, and navigate to Order Handling >
City, then click OK.

8) Click OK.
9) In the navigator you should see Location listed with two sub-levels as follows:

EIQ Location

20. Press Ctrl-S to save your work.
21. Select Project > Clean..., then select 'Clean all projects’, then click OK.

22. Check for any errors in the Problems view. You should resolve any errors before continuing.
Warnings and informational messages may be present but these will not be a problem.
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Part 7: Generate and publish the model to the server

In this section you will use WebSphere Integration Developer to publish the monitor model to the monitor
server.
1. You should first verify that the 'valid from date' in the process matches the monitor model. This can
be a problem if you imported the process solution but did not import the monitor solution. But it is a
good practice to verify the 'valid from date' in any case.

___a. In Project Explorer, expand CATOrderMgmt_Monitor > Monitor models > Order Handling
Monitor.mm and open it by double clicking on it.

__b. Inthe monitor details model, navigate to Order Handling > Order Handling, then scroll to find
the first inbound event that is in the list. Then click it to select it.

Shipped Crder Trigger
@ CrderHanding_Flow Check Cusk
------ &" OrderHandling_Flow Check Cush

___c. Inthe details page, check the filter condition and look for 'processTemplateValidFrom' and note
the exact date and time that is listed.

w Filter Condition (Read only, managed by application)
Define a condition based on the event attribukes to identify whether to accept

___d. Switch to the Business Integration perspective.

___e. Inthe Business Integration view, navigate to CATOrderMgmt > Integration Logic > Processes
> processes\orderhandling, then double click OrderHandling to open the BPEL editor.

__f. Click the white background canvas outside of the box that surrounds the flow.

———"

CATCOrderMgmt = ,QOrderHandIing

<] 5F Palette

=S @ O
@ Basic Actions

v 1| OrderHandling_Flow

<§’ Invoke

= #Assign

___g. Click Properties > Details, then verify that the date and time listed is the same as the
processTemplateValidFrom date and time in the monitor model.

7 Build Activities | ] Propertiss 53 = Prnblems} Server Logs | &1L SErversw [ Asset Repositories}

% Process - Order Handling

e ST TS

Description O Bind the life cycle to the invoking business process
Details Select date {UTC) when the process becomes walid
5 -
ETVEr walid From: | Jun 3, 2008 B | Time: (19 =) : |39 |57 &
Administration
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___h. If the date or time is different, then update it to match the one in the monitor model.
___i. Press Ctrl-S to save your work.
2. Open the Business Monitoring perspective.

3. In Project Explorer, expand CATOrderMgmt_Monitor > Monitor models > Order Handling
Monitor.mm. Right click and then select Generate Monitor JEE Projects from the pop-up menu

4, Select Finish.

5. A progress dialog shows the status of the operation and it closes when the operation is complete.
Check for errors in the Problems view. There may be warnings, but there should not be any errors. If
you see errors, then try to perform a clean to see if the errors can be removed: Project > Clean... >
select 'Clean all projects', then click OK.

6. Click the Servers tab, then right click and select the Start option to start the server WebSphere
Business Monitor Server v7.0. This may take a few minutes to complete.

|§.': Monitaring Flow (:. Propetties ﬂ"_ Froblems (43?& Seryers oA i) Server Logs} = Consnle}

Server = State Status

Sphere Business Manitar Server «7.0 on webSphere Proc erver ? Started Synchronized

F#l websphere Process Server v7.0 at localhost @ Stopped

7. Right click in the servers view, then select Add and Remove Projects....

8. Click to move CATOrderMgmt_implApp, CATOrderMgmtApp and Order Handling
MonitorApplication, from the list of available projects to the list of configured projects.

9. Click Finish.
10. A progress message is displayed in the lower right corner of the window.

11. When the publishing is complete, the applications should show started in the Servers view:

&l Monitoring Flow (:. Propetties ﬂ"_ Froblems (43?& Seryers oA i) Server Logs} = Ennsnle}

Saerver - Shate Skatus
= i Sphere Business Manitar Server «7.0 on webSphere Proc erver ? Started Synchronized

IE CATOrderMgmt_implapp Cp= Started Synchronized
IF CATOrdetMgmtapp .r:fi;. Started Synchronized
I8 ©rder Handling Monitorapplication ::fb Started Synchronized
B4 webSphere Process Server v7.0 at localhast E@ Stopped

12. If you are using the integrated server within WebSphere Integration Developer, then you do not
need to setup Monitor data security, since the administrative user is automatically authorized to all
models. If you are using a different server, then you should open the administrative console,
navigate to Security > Monitor Data Security, then add the model, role and user information to a
resource group.
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Part 8: Configure action manager for business situation events

This section shows you how to configure action manager to create alerts based on business situation
events defined in the monitor model. The alerts will be visible in the Alert view on your dashboard.

You do not need an LDAP server to test the situation events. When you configure the notification template,
you can specify a dashboard login rather than a user registry.

In this section, you will use the administrative console to configure the alerts. However, you could also
create business user alerts using the Alert Manager widget in the dashboard. In a production environment,
an end user could use the alert manager widget to manage the business user alerts; however, an IT
administrator would manage the modeled alerts in the administrative console.

_ 1. startthe administrative console.
__a. Inthe Servers view, right click the Monitor server and select Run administrative console.
___b. Enter 'admin’ without the quotation marks for both user ID and password.

2. Verify the federated repository service provider URL.

___a. Inthe administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Configuration > Federated Repositories.

b. In the Service provider URL field, type the URL of the federated repositories server that is used
to connect to the user registry. For a stand-alone server, this value might be localhost:2809.
For a network deployment environment, this field must be set to the deployment manager host
name plus the deployment manager BOOTSTRAP_ADDRESS port (separated by a colon). To
determine the bootstrap port, in the WebSphere Application Server administrative console, click
Servers > Server Types > WebSphere application servers > serverl. Under Communications,
click Ports.

___a. To save the settings you entered, click Apply or OK.
___b. To make these changes effective, stop and restart the WebSphere Business Monitor server.
3. Add a template for shipped percentage alerts.

___a. Inthe administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Template Definitions > Notifications.

___b. Click New.

___c. Enter AlertShip as Template name and a description.
___d. Select Dashboard Alert.

___e. Select User id.

___f. For the To field, enter admin. This user ID is the one that will receive the alert, so you must log
into the dashboard with this user ID.

___g. Enter a subject, such as 'Percentage of shipped orders'
___h. Enter the body, such as 'Percentage of shipped orders is less than 85.'

__i. Click OK.
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4. Add a template for order processing time alerts.

___a. In the administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Template Definitions > Notifications.

___b. Click New.

__c. Enter AlertTime as Template name and a description.
___d. Select Dashboard Alert.

___e. Select User id.

___f. For the To field, enter admin. This user ID is the one that will receive the alert, so you must log
into the dashboard with this user ID.

___g. Enter a subject, such as 'Order processing time'.

__h. Enter the body, and you can optionally enter a substitution variable as shown below. For the
actual alert that is sent, the average order processing time from the event payload will be
substituted for %AverageOrderProcessingTime% in the body. For example:

The average order processing time is %AverageOrderProcessingTime% days.
___i. Click OK.
5. Add the binding from the situation event to the action type for shipped percentage.

__a. Inthe administrativeconsole, navigate to Applications > Monitor Services > Monitor Action
Services > Installed Situation Event Bindings.

___b. Click New.

___c. Enter the situation event name that you defined in the model. In this lab, you created a business
situation name as follows:

Shipped Percentage Event

___d. This must match exactly the value in the BusinessSituationName field in the outbound event.
You may want to copy/paste from the model, but do not copy the quotation marks. Here is a
screen capture from the model showing the Shipped Percentage Event attributes:

* Outbound Event Content
Specify the triggers that cause the event to be sent, Use the Expression column bo specify the value For each ey
the event is sent.

Marne | Tvpe | Expression

E=l :‘=:=> Percentage of Orders Shipped KPT Trigger 1

L?_:. Property Data
=] ﬁg Extended Data
[= BusinessSituationMame A skring X$Y 'Shipped Percentage Event'

___e. Enter a description, then click Apply.
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Mew Situation Event Binding

General Propertes

# Situation event name

|Shipped Percentage Event

Dezcriptian
Shipped percantags |:|

=

Apply | ﬂ Resetl Cancel |

__f. Click Add.

___g. Enter a binding name such as AlertShip, then select the template AlertShip.
__h. Click OK.

___i. Notice that you now have one action defined for this situation event. If you had other action
templates defined then you could add more actions to this event. So then you could send a
notification for this situation to multiple destinations including email, alerts, and web services.

Mew Situstion Event Binding

General Properties

# Situation event name
|Shipped Parcentage Event

Crescription
Shipped percentage I:‘

=

Apply | ﬂ Reset Cancel |

Preferences

Add Rermave

Select| Binding Mame X Category Marme O Template Mame Action Service Type O
- AlertShip AlertShip AlertHandler

Total 1

j. Click OK.

6. Add the binding from the situation event to the action type for order processing time.

__a. Inthe administrativeconsole, navigate to Applications > Monitor Services > Monitor Action
Services > Installed Situation Event Bindings.

___b. Click New.
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___c. Enter the situation event name that you defined in the model. In this lab, you created a business
situation name as follows:

Order Fulfillment Event

___d.. This must match exactly the value in the BusinessSituationName field in the outbound event.
You may want to copy/paste from the model, but do not copy the quotation marks. Here is a
screen capture from the model showing the Order Fulfillment Event attributes:

* Outhound Event Content

Specify the kriggers that cause the event to be sent, Use the Expression calumn to specify the value For each event attribute when the event is sent,

Mame | Tvpe

| Expression
= :':4?‘ Average Process Duration £ Trigger 1

= Property Data
= = Extended Data

EE BusinessSituationkanme

A string Y,
= fverageCrderProcessingTime

-2 'Order Fulfilment Event’
A skring ;%Y wsskring{Awerage _Process_Duration_KKPI div xs:davTimeDuration{ P10

___e. Enter a description, then click Apply.
__f. Click Add.

___g. Enter a binding name, then select the template AlertTime, then click OK.

Mew Situation Event Binding

General Properties

#* Situation event name

|Order Fulfillrment Evant

Description

Crder fulfillment l:‘

=

Apply | ﬂ Reset Cancel |

Preferences

Add Rermaove

Select| Binding Marme

o Category Marne Template Mame O Action Service Type
AlertTirme AlertTirme AlertHandler
r
Taotal 1
h. Click OK.

7. Inthe administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Installed Situation Event Bindings. You should see the two bindings that you created
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Installed Situation Event Bindings
Use this page to manage situation event bindings.
Preferences

Mew | Delete
El=lczlE

Select| Situation Event Name Situation Event Description
You can administer the following resources:
- | Eee Compliance slert

| Invalid Loan Application
[~ | MTB Failure
[~ | Print 72 hours exceeded
[~ | Shipped Percentage Event | Shipped percentage
- | Srder Fulfillment Event Order fulfillment
Total &
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Part 9: Run events to exercise the model

In this section you will use the business process choreographer explorer to run process instances.

There are five different paths to take through the model. For each path, here are sample data elements that
will invoke the listed path:

a. Approve without review, account in good standing, ship
i. Start instance: rating — 800, available credit — 800, total price — 20
ii. Ship task: no required elements
b. Approve without review, account not in good standing, approve the order, ship
i. Start instance: rating — 800, available credit — 100, total price — 200
ii. Review task: order status — APPROVED
iii. Ship task: no required elements
c. Approve without review, account not in good standing, decline the order
i. Start instance: rating — 800, available credit — 100, total price — 200
ii. Review task: order status — DECLINED
d. Do not approve without review, approve the order, ship
i. Start instance: rating — 10, available credit — 10, total price — 900
ii. Review task: order status — APPROVED
iii. Ship task: no required elements
e. Do not approve without review, decline the order
i. Start instance: rating — 10, available credit — 10, total price — 900
ii. Review task: order status — DECLINED

In order to see an alert in the alerts view of the dashboard, you will need the number of shipped orders to be
less than 85 percent of the total number of orders. An easy way to achieve this is to process one DECLINED
order, then before you add any other process instances, go to the dashboard section of this document and
create a dashboard to view the alerts.

1. Inthe Servers view, right click server WebSphere Business Monitor Server v7.0 > Launch >
Business Process Choreographer Explorer

2. Click Process Templates > Currently Valid

Views Currently Valid Process Templates

Use this page to view process termplates on which you can work, [
Process Templates

Currently Yalid

all Wersions IStart Instance |Instances |View Structure |Refresh
Procass Instances B |_ Process Template Mame 3 Valid From & Long Running = State ¥ Description 2
Started By Me [T Order Handling 6/3/2008 3:39:57 PM EDT yes Started
Administered By Me
Critical Processes Items found: 1 Items selected: 0 e Page 1 of 1 i Items per page: IED 'l

Terminated Processes
Falled Compensations

3. Select Order Handling, then click Start Instance

4. Inthe following data entry page, enter a unique value for the process name, then enter values for
the fields in the various business objects listed. You can use just one line item for Orderltems, The
values for Rating, AvailableCredit, and TotalPrice determine which paths the process will take. See
the introduction to this section for more information.
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Process Input Message

Use this page to provide the input that is needed to start an instance of a business process, [

Process Template Mame
Process Description
Process Documentation

Crder Handling

Operation InputCriterion

Process |process1

Mame

Process

Input Form Yiew

Message

Input
R Customer CustomerMumber |111
CompanyMarne |Campan\,r 1
ContactFirstMame |E.Db
ContactLastMame |Smith
Streetaddress |111 Way
City |Car\,r
Country us
PostalCode [27882
Email |abc@aaa.com
Rating [10
AvailableCredit [10.0
Orderltems ProductMarme ProductNumber
|p1 PM 200.0
Add
TotalPrice |EIDD.D
I

5. Click the Submit button.

6. Select Task Instances > My To-do's. Here you will find either the Review Order task or the Ship

Order to Customer task, depending on the values that you entered when you started the process

instance.

My To-dos

Use this page ta wark an tasks that are assigned to you, [

|W0rk on |Re|ease Transfer |Start |Change Business Category |Refresh

Kind & Owner %

To-do Task

Priority = Task Mame & State o

M s Review Order Ready admin

Items found: 1 Items selected: O
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7. To complete a task, select the check-box for it, then click ‘Work on'. You will be given a page to
enter values for the task. You should enter the values in the section for the task output message.

___a. For the ship task, you can just press the Complete button, since the data elements are not
required values for this process.

___b. For the review task, you should enter 'APPROVED' or 'DECLINED' (without the quotation marks)
into the OrderStatus field. The other fields are optional for this process, so you can choose to not
enter them to save time. Then press the Complete button.

___C. This screen capture shows the review task and the string 'APPROVED' (without the quotation
marks) has been entered in the OrderStatus field.

Task
Cutput
Message

2010 October, 05

Form Yiew

Output| Customer

Orderltems

TotalPrice
Orderfumber

OrderStatus

CustomeriNumber
CormpanyMame
ContactFirsthlarme
ContactLastMarne
Streetaddrass
City

Country
PostalCode

Ernail

Rating
AvailableCredit

ProductMare Productiumber

Description

Quantity

I I 0.0

Add

[0
o
[&PPROVED]

ProcessingPreference sutomaticapproval

Edit Source
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Part 10: Create a dashboard in business space

In this section you will configure a dashboard in business space.
1. Create the dashboard.

__a. The default browser is 'Internal Web Browser', but you should not use this one since some
standard functions are not provided that you may need. Select Window > Preferences > General
> Web browser > select 'Use external Web browser'. Select an external browser. Click OK.

___b. InWebSphere Integration Developer, in the servers view, right click and select Launch >
Business Space

___¢. When prompted, enter admin for the user ID and enter admin for the password. You must log in
with 'admin’ so that you can view the alerts which were setup in action manager to be sent to this
particular user ID. Also, in the toolkit environment, this is the user that is automatically defined on
the secured server.

___d. Click in the Actions menu to create a new space

Home Gotod BS Mana G Actions
5 - Create Space..
1 Welcome to Business Spa Emmpacesemﬁ,_._

Getting Started -

Setas Home

Manage Templates

==

[ T
__e. Enter a name such as Dashboard, and select the Business Monitoring template.

Create Space

*= Bpace name:
Dashhoard|

Space description:

% Create anew space using a template

| Business Monitoring i

__f. Click Save.

Home Goto s S anag 5 Actions -

ExpoartValues Alert Manager < anager WViewers

2010 October, 05 IBM WebSphere Business Monitor 7.0 — Lab exercise Page 35 of 46

ClipsAndTacks



© Copyright IBM Corporation 2010. All rights reserved

___g. On the new space, click the Operational tab.

2. Usethe Alerts widget to view the alerts. There are two alerts defined in the model, one for shipped
percentage and one for order processing time. The latter is based on a processing time greater that
3 days, so it will be difficult to test here, unless you use the KPI Manager widget to reduce the
target. The former can be tested easily by ensuring that the number of shipped orders is less than
85 percent of the number of total orders.

___a. You can click an alert in the list, then you will see a pop-up showing the details of the alert.

Alerts
| tark Read || Mark Unread || Forward Alert || Rermave |
Subject Date and Time
# Percentage of ghipped orders January &, 2009 4:55:21 PM
| ——

January 5, 2009 4:55:21 PM
Suhject

Fercentage of shipped orders
Business situation name
Shipped Percentage Event
Comments

Percentage of shipped orders is less than 85.

Close

___b. On the widget menu you can select 'Send Widget...' to send a screen capture of the alerts as an
attachment to a human task.

3.  Use the Instances widget to view the monitored instances.

IE'tF'a e¥|

___a. Click the 'Edit Page' link to enter edit mode.
___b. To configure the Instances widget, hover the mouse over the right corner of the widget

{I:']:EI

and then click the down arrow. Select 'Edit Settings...".

| Edit Seftings. | &
0 Rename...

___C. Click the Show/Hide tab, and select monitoring context '‘Order Handling'.
—r~order HandlingiAcrass all wersions)

Click button >> to move all the fields to the Selected box. Also,
click button 'Set as default' which will make this the default monitoring context to display.

___d. Then click OK. You should see a list of monitoring context instances for the events that you just
processed.

2010 October, 05 IBM WebSphere Business Monitor 7.0 — Lab exercise Page 36 of 46

ClipsAndTacks



© Copyright IBM Corporation 2010. All rights reserved

Order Han

_P190030125. 7501 a02d.6cd0fcf6. 20240039 6 m, 18,37

_PL90030125.75d2cedf 6od0ficfe 2024009 3 m, 34.25

_PL90030125. 75d4117 7 Ged0fcfB.802400ec 2 m, 0.953

_PL90030125.75d534ee God0fcfE.20240139 46.797 5

i

Instances
@

Search far; |
City COMPLETED Country CreationTime Order Handling Instance ID
Cary % s December 4,

2009 6:24:02 PM
Cary % s December 4,
2009 64247 PM
Raleigh % s December 4,
2009 64413 PM
London % LK December 4,
2009 64525 PM
A 1
1-4 4

4. Use the human tasks widget to view task information.

___a. To configure the Human Tasks widget, hover the mouse over the right corner of the widget and
then click the down arrow. Select 'Edit Settings...".

___b. Click the Show/Hide tab.

___C. Click >> to copy all the metrics from the available list to the selected list.

__d. Click OK.

Human Tasks

_ | Completed Completion Time Creation Time
Movemnber 18, 20048 Movember 18,

* 2:44:08 FM 2009 2:43:45 PM
Mowember 18,

2009 3:33:18 PM
Movemnber 18, 20048 Movember 18,

* 4:02:44 P 2009 4:02:33 PM

Mowember 18,
2008 4:03:42 PM

December 9, 2009

e s

December 9,

___e. Click 'Finish Editing' to save your changes and close the edit menus.

CreationTime

Movember 18,
2009 2:43:45 PM

Mowember 18,
2008 3:33:18 PM

Movember 18,
2009 4:02:33 PM

Mowember 18,
2008 4:03:42 PM

December 9,

Lifetime
22407 =

Description Escale

false

21d, 3h, 41 falze
m,28 s
1M1= false

21d, 3h, 11 falze
m, 4 s

am, 44 578 falze LI

I Finish Editing & I
%

5. Use the dimensions widget to show aggregated human task information.

___a. Click Analysis tab in the business space.

___b. To configure the dimensions widget, hover the mouse over the right corner of the widget and
then click the down arrow. Select 'Edit Settings...".

__ . Select the following values:

1) Monitoring Model: Global HT MM (All Versions)
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2) Note that this is the global human task monitor model which is automatically installed when

you install the toolkit.

3) Monitoring Context : Global Human Task

4) Select Task Name Dimension from the Available Dimensions list and click the right

direction arrow ) next to Row Dimensions text area.

5) Now select Task Owner Dimension from the Available Dimensions list and click the right
directional arrow () next to Column Dimensions text area

6) Now select Measures from the Available Dimensions list and click the right direction

arrow ) next to Page Dimensions

Dimensions Edit

Select Dimensions Wiring

Monitoring Model:

Global HT M (Al Versions) |v|

Available dimensions

Task Btatus Dimension ;l
Task Kind Dimension

Task Expiry Dimension

Task Suspended Dimension

Task Escalated Dimensian

Task Parent ID Dimensian

Task'Waiting For Subtask Dimension
CreationTime

TerminationTime

_ | Hide menu har
_ | Hide toolbar

___d. Click the OK button.

II

II

Monitoring context:

|Glnbal HumanTask

Row dimensions

Task Mame Dimension

Column dimensions

Task Owner Dimension

Page dimensions

Measures

___e. The Dimensions view displays the instances count based on task name and task owner.
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Dimensions
File Edit ‘“iew Bookmarks Data  Chart Tools  Help
D@ @R Qe
- 1% BB 4 B
Measures |InstancesCuunt j
€ Task Mame Dimension 1, All Task Owner Dimension T}
= 20—
§ All Task Name Dimension T} 8
@ 10 '
2 I
m
E i T

Al Task Crvner Dimension
Task Owner Dimension

4 All Task Hame Dimension

___f. You can double click All Task Name Dimension to drill down on task name. Then double click
All Task Owner Dimension to drill down on task owner.

Dimensions
File Edit View Bookmarks Data Chart Tools  Help
m@-v- @8 ale
- % 1 B 4 B E
Measures | InstancesCount j
E 10 All Task
8 Task Name Dimension H Owner 1T, Unassignedtl admint}
% 5 Dimension
o
=
5 | 4 All Task Name Dimension T} 8 2 B
Ea =
- Unassigned admin ReviewOrder_InputCriterion T4 3 2 1
o=k Cumenbimension ShipOrdertaCustaomer_InputCriterion T4 5] 5
J ReviewOrder_InputCriterion @ ShipOrdertoCustomer _InputCriterion

___g. Click 'Finish Editing' to save your changes and close the edit menus.

I Finish Editing % I
%

6. Use the KPIs widget to show key performance indicators.

__a.

Click KPlIs tab in the business space.

___b. To configure the KPIs widget, hover the mouse over the right corner of the widget and then click
the down arrow. Select 'Edit Settings...".

___¢. Onthe tab 'KPIs', select the KPIs to display for the Order Handling model.
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KPIs Edit X
KFIs Layout  Wiring

Selectthe models forwhich you want to retrieve the KPIs.

(@ Latestwersion () Allversions

[ Global_Process_Manitor 2009-11-08 18:00:00

O MartgagelendingBAMShowease 2008-09-18
08:00:00

S15 Order_Handling_CATOrdertgmt.Processes
2008-06-27 14:14:44

2 Average Pracess Duration KPI

Iy FPercentage of Orders Shipped KFI
2 Shipped Orders

¥ Total Orders

__d. Click OK.
KPIs
KPI Hame Status Yalue Target Actions Walue in Range
Average 3m, id,0oh 0 = |_:'
Frocess 10101 s m, 0= .E_i; - L
Duration KPI #1
Fercentage of 75 S0 ) >
Orders \ﬁ - =
Shipped KP| #1 W
Shipped 3 ] L:'E! [
Orders o =
#1
Total Orders 4 =
= = B
#1
4| | i

&= 2] e 25/ =5

___e. Inthe lower left corner, you can select different display formats for the KPI.

__f. The Status column displays icons which represent the value of the KPI relative to the target and
ranges. Initially this is blank, but you can use the KPI Manager widget to configure them.

I Finish Editing = I
. - " . oo | s
___g. Click 'Finish Editing' to save your changes and close the edit menus. H

___h. On the widget menu you can select 'Send Widget...' to send a screen capture of the KPIs as an
attachment to a human task.

7. Export values to Modeler. Note that you must have some completed monitoring context instances
for this, so make sure that you have started and completed some process instances before
exporting the values.

__a. Click Export Values tab in the business space.

__b. Select the Order Handling model.

___C. Click Preview Data to see the data that will be exported.
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Export Values

Select a model:
Order Handling  2008-06-27 14:14:44 |v|

Specifywhere the data should bhe exported from:
® Allversions ofthe selected model
() Only the selected model

Time range {filters the data to export by the time range you specify);
® Mone

() Specify the time range

InstancesCount
BLM-BE47c2d7h35fabThafe2e2272db98ealiBLM-552a4 c4 B850 3226 3ce0d0E0 3 afef7 44dioutputS etProb ahility
BLM-B647c2dTh38fabThafe2e2272db98ealiBLM-54728a2d595bfedf33848abb493d08ab/outputSetPrabability
BLM-B647c2d7h3afab7hafe2e2272db98ealiBLM-dcSb 47 ad 3008591 eYe 7 2hafBf3dd 3facioutputs etProbability
BLM-6647c2d7h35fabThsfB2e2272db98ealiBLM-02ecfdafa 3285264586397 82 c0e 329k/outputSetP rob ability
BLM-G6647c2d7h35fabThsfB2e2272db98ea0iBLM-e3daf6c08h 497 3bb43ch 320804 77T 85 2ioutputS etProbability

o o O O = I

___d. Click Export.

__e. The XML is displayed in a browser window, click File > Save page as... or Save as..., then
select your destination folder and click Save. The file is stored by default as exportvalues.xml.

__f. Open WebSphere Business Modeler, and point to the workspace containing your model.
___@g. Inthe project tree, navigate to CATOrderMgmt > Processes > Order Handling, and select it
___h. Right click Order Handling, then select Import...

__i. Select WebSphere Business Monitor results (.xml), then click Next.

___j. Browse to the folder containing the exportvalues.xml file.

__ k. Select exportvalues.xml, then click Next.

___|. Click 'Display Possible Updates' to see the update summary.
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&% webSphere Business Modeler Import

Monitoring results import

Select the processes Far which ko impaort the values from WebSphere Business Maonitar,

Processes with returned resulks

= iz caTOrderMgnit
E-[# 5= Processes
g.’?‘ Order Handling

iDisplay Possible Updates:

Entries in resdlt file that can be updated

Process I | # elements to be updated | # total elements | % to be updated |
Order Handling ke 13 13 100
___m. Click Finish.

___n. Double click the process in the project tree to open the process diagram. Browse the process
diagram to see the updated values for the six decision percentages.

S0.0% Yes Order

|:| Crrder

20.0%: Mo

Acceptable
Credit Risk?

___ 0. To check the updated process duration time, click the background of the diagram, then click the
Attributes tab, then click the More tab, select the check box for Duration, click Apply.

55 attributes - Order Handling 53 “¢ Errors (Filker matched & of & itemsﬂ 7 Technical Attributes -1

General | Inputs | Qutputs | Input Logic | Output Logic | Forms | Correlation keys | More
Select the element attributes that vou want bo display, Then, click Apply,

 Aktribukes

General O cost and Revenue Apply
Inputs Select all

Oukput: Input Logi

b Outputs B4 tnput Logic Clear &l

Oubput Logic D Organizations

O classifiers Forms

Correlation Kevs

___p- Select the Duration tab and note the new processing time.
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55 attributes - order Handling 532 ¢ Errors (|

General | Duration | Inputs | Outputs | Input

Processing Lime

The length of time required to finish this process,

fic duration

Days
Hours
Minutes

Seconds

Milliseconds

Clear

___ Q. To check the updated task duration times, click one of the tasks in the diagram, then click the
Attributes tab, then click the Duration tab.

55 Attributes - Check Customer Account Status 52 1
General | Duration | Inputs | Outputs | Input Logic

Processing Lime

The length of time required to finish this bask,
| Specific duration E“

Days
Hours
Minukes
Seconds

152

Milliseconds

Clear
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What you did in this exercise

In the lab, you imported the model into WebSphere Business Modeler and reviewed the process model.
You created the business measures model.

You exported the process model and business measures model to WebSphere Integration Developer, and
imported the implemented process solution.

You completed the implementation of the monitor model.
You deployed the process and the monitor model, and ran process instances.

Finally, you created a dashboard in business space and exported monitored values back to Modeler.
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Appendix 1 — Import the solution into Modeler

A solution has been provided so that you do not have to build the business measures model from scratch.
This section shows you how to import the MAR project into WebSphere Business Modeler. After importing
the project then you can review the business measures model and then proceed to the section to export
the projects to WebSphere Integration Developer.

1. Import the supplied Modeler project.
a. In Modeler, right click in the Project Tree, then select Import...
b. Select WebSphere Business Modeler project (.mar, .zip)

c. For source directory, browse to the folder containing the supplied mar file, for example,
c:\Labfiles70\ClipsAndTacksBPM

d. For files, select CATOrderMgmt_Solution.mar.

e. Click Finish.

___f. If you have the original project previously loaded, then you need to select the option to replace
elements

&5 Conflicts Were Detected E3

Some of the elements that wou are importing conflick with or
': contain changes ko existing model elements. How do you want
to proceed?

{~ Open the Compare Merge editar ko review and select the changes ko apply

{*' Replace existing elements with the elements in the imported model;

" Do not replace existing model elements

2. To open the business measures tab, select Windows > Business Measures

3. Open the Order Handling process, click the process diagram background, then select the Business
Measures tab. On this tab you can review the business measures that have been previously
created.

4. Now you can proceed to the section to export the projects from Modeler to WebSphere Integration
Developer.
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Appendix 2 — Import the solution into the monitor model editor

A solution has been provided so that you do not have to build the monitor model from scratch. This section
shows you how to import the monitor model project into WebSphere Integration Developer. After importing
the model then you can proceed to the section to publish the model to the server.

1. Import the monitor model project into WebSphere Integration Developer.
___a. Inthe Business Integration view, right click then select Import...
___b. Navigate to Other > Project Interchange then click Next.
___c. For the .zip file, browse to the supplied file, for example,
___d. c:\Labfiles70\ClipsAndTacksBPM\CATOrderMgmt_MonitorSolution_Pl.zip
___e. You should see one project listed, so select it.
___f. Click Finish.

2.  Expand the project in the Project Explorer view, then expand the Event Definitions and you will see
the events listed. Expand Monitor Models and you will see the model listed.

Now you can proceed to the section to generate and publish the model to the server.
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