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IBM WEBSPHERE BUSINESS MONITOR 7.0 — LAB EXERCISE

WebSphere Business Monitor V7.0 - Clips and Tacks

business activity monitoring using XSD style events
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What this exercise is about

The objective of this lab is to show you how to build a monitor model using XSD event definitions in Rational
Application Developer or WebSphere Integration Developer, deploy it to WebSphere Business Monitor and
then view your monitored data on the Monitor dashboards.

This lab will show you business activity monitoring (BAM) which involves event based monitoring. With BAM,
your monitored application can run anywhere, and submit events to the Monitor server so that you can view

monitored data in the dashboard. Typically, you identify the events that will be created by the application, and
then create a monitor model that represents the monitored data that you want to collect from the events.

Changes from the previous version
This lab has been modified for the 7.0 release. Here are the major changes:

e Updated the dashboard section to show how to use the new business space which is based on
Lotus Mashups.

Lab requirements
List of system and software required for the student to complete the lab:
« Rational Application Developer V7.5 or WebSphere Integration Developer V7.0.

e WebSphere Business Monitor V7.0 — Toolkit Installation including the monitor model editor and
embedded monitor server

What you should be able to do
At the end of this lab you should be able to:

e Use Rational Application Developer or WebSphere Integration Developer to create the monitor model,
and deploy it to the server.

= Use a sample program to create events that represent events from your process.

e Define a dashboard to view monitored data.
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Introduction

In this lab you will learn how to develop and deploy a model from end to end using Rational Application
Developer or WebSphere Integration Developer and WebSphere Business Monitor. This lab will show you the
basic procedure for creating and implementing a simple model.

The model used in this lab is ClipsAndTacks model which is also used in IBM Redbook SG247148 —
Business Process Management: Modeling through Monitoring Using WebSphere V6.0.2 Products. In
the Redbook, there are several models that are referenced, but in this lab you will be using the Future 1
Process. In the Redbook, the process is implemented as a BPEL process running in WebSphere Process
Server. However this lab will demonstrate Business Activity Monitoring which can monitor events from any
source. So, the lab will simulate the running of the process, by creating events that could have been sourced
from anywhere, a J2EE application or BPEL, or any other source. These events are in the form of Common
Base Events, which is an OASIS standard for common event format, and these are used by the Common
Event Infrastructure (CEI) in WebSphere Process Server.

In this lab you will build a monitor model that has the same basic elements as the one that is defined in the
Redbook. Namely you will create monitoring constructs in support of two KPIs:
* Average order fulfillment is three days or less

* Percentage of shipped orders is greater than 90%

You will also create situation events if declined orders are greater than or equal to three and if the order
fulfillment time is greater than three days.

For dimensional analysis, you will create a Location dimension which allows you to drill down on country and
city. You will also add an Order Status metric, which shows orders as ‘New’, ‘Cancelled’ or ‘Shipped’. And you
will add measures for average order price, sum of order price for all orders, and order count.

Here is a diagram of the ClipsAndTacks process model:
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This is the ordering process for the Clips And Tacks Company. In this process, orders are received and

optionally submitted to a review process. Orders which pass all checks are shipped to the customer. Other
orders may be cancelled.

In the monitor model, you will create one monitoring context for each customer order. You will identify the
inbound event that represents the receipt of the order, and this is marked so that it will create a new
monitoring context instance for the order. You will also identify the inbound event that represents shipping
the order, and this is marked so that it will trigger the termination of the monitoring context instance for the
order. Since an order may also be cancelled, you will identify the inbound event that represents

cancellation of the order, and this is also marked so that it will trigger the termination of the monitoring
context instance.

Useful URLs

The following URLs may be helpful to you as you exercise this lab. Note that the port numbers in the URL
of your installation may be different depending on your configuration.

e Server administrative console

https://localhost:9044/ibm/console

e Business space dashboard

https://localhost:9444/BusinessSpace
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Part 1: Create the monitor model

To create the monitor model, you will use the monitor model editor in Rational Application Developer or
WebSphere Integration Developer. Note that the screen captures in this lab are based on WebSphere
Integration Developer, so they may differ slightly from yours if you are using Rational Application Developer.

Note that there is a ‘Problems’ tab that displays errors concerning the model. Periodically, you should check
this view to see if you have any problems that need to be addressed. Normally, warnings and informational
messages are not a problem, but errors should be addressed.

If you want to skip this section, then a solution has been provided. You can import the supplied monitor model
into Rational Application Developer or WebSphere Integration Developer, and then proceed to the next
section. Refer to Appendix 1, and then proceed to the next section.

1. Start Rational Application Developer or WebSphere Integration Developer and setup the
environment.

a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted
point to a new workspace such as C:\workspaces\ClipsAndTacksXSD

b. Close the Welcome tab

c. By default, you are in the Business Integration perspective. But you need to open the Business
Monitoring perspective. From the main menu, select Window - Open Perspective - Other.
The ‘Open Perspective’ dialog opens

d. Select ‘Business Monitoring’ from the ‘Open Perspective’ dialog and click OK

2. Create a new monitoring project. A project is a container for your monitor models and event
definitions.

___a. Right-click inside Business Monitoring project explorer (top left view in the Business Monitoring
Perspective) and select New - Business Monitoring Project... from the pop-up menu. The
‘New Business Monitoring Project’ panel opens

___b. Inthe ‘New Business Monitoring Project’, enter the ‘Project name:’ as ClipsAndTacks
___c. Click the Finish button.

___d. Anew project named ClipsAndTacks is created as shown below:

3. Create a new XSD event definition named, ActivityEvent

___a. Inthe Business Monitoring project explorer view, expand ClipsAndTacks, right-click Event
Definitions and select New - Event Definition... (xsd) from the pop-up menu
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5 Froject Explorer X W T oo0
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___b. The ‘New XSD Schema’ panel opens as shown below:

4= New ZML Schema
Create an XML Schema

—
Create a new XML schema. | r:

Enter or seleck the parent Folder:

| ClipsandTacks

iy

------ 1=F ClipsAndTacks

File name: | Jeaiyeisa papes ==

Advanced :=-:=-|
(7 Einish I Cancel

___c. Enter ‘ActivityEvent.xsd’ as ‘File name:’ and click Finish

___d. The schema you created is listed under the event definitions category and the schema is opened
in the XSD editor.

___e. There are several view modes that you can use on the XSD editor. Change the XSD editor view
to Detailed by clicking on the pull down menu icon (+) located in the top right corner.

wiew: Detaled = ()

‘Dekailed
Shupified V3]
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[S] ActivibyEvent.xsd 53

A=

=08

-

Yiew: Detaled < (2)

@ achema : httpe/fClipsAndT acks AckivibvEvent, xsd

(A= Directives

(&) Elements

Types

Design | Source |

4. Review and update the <schema> element, which is the root element of the schema

___a. Inthe XSD editor, select the schema element and then select the ‘Details’ tab of the ‘Properties’

view

lf =3
Manikoring Flawe | = Properties 23 Problems | Servers | Console
|

[ General

Docurnmentakion

Extensions

-,

VEE

5] schema

Prefix: kns __t—

Target namespace: | http: )i iClipsandTacks) ActivikyEvent, xsd

> []

___b. Update the ‘Prefix:’ from tns to ae (where ae stands for activity event and the prefix resembles
the name of the schema)

___C. Click the Advanced button to edit the schema information (attributes)
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| SttpefiClipsandTacks) ActivicyEvent, xsd

Mamespace Declarakions

Prefix | Marmespace Marme

wesd hikkps e w3, orgf 2001 f¥MLSchema
ae  wEe—  httpf | ClipsandTacks) ActivityEvent, xsd

Edit. ..

Delete

Prefix qualification of local elements:

Prefix qualification of attributes:

qualified

qualified

Ik I Cancel |

Jo L

___d. Ensure that the prefix qualification of local elements and the attributes is set to ‘qualified’

Note: Prefix qualification indicates whether locally declared elements or attributes must be qualified by the
target namespace in an instance document. If the value of this attribute is 'unqualified’, then locally
declared elements should not be qualified by the target namespace. If the value of this attribute is
‘qualified’, then locally declared elements must be qualified by the target namespace. Using 'qualified'
helps to ensure that expressions written to access pieces of information within a type are unambiguous.

__e. Click OK. The ‘General’ properties view of the ‘ActivityEvent’ schema should look like the picture

below:

- j—
Manikoting Flawe | =] Properties 23 Problems | Servers | Console

-,

- = H

|
[General S| schema
Documentation )
Prefix; ae
Extensions

-—

Target namespace: | http: i /ClipsandTacks) ActivikyEvent, xsd

> [GE]

__f. Save the changes. File > Save or Ctrl + S

5. Add a complex element type named, ActivityEventData and the following sequence of elements to

the complex type

The following are the elements including the data types you will be adding:

2010 April, 20 IBM WebSphere Business Monitor 7.0 — Lab exercise Page 8 of 69

ClipsAndTacks (XSD event definitions)



© Copyright IBM Corporation 2010. All rights reserved

Name of the Element Type
businessUnit string
processName string
mclD string
activityName string
eventType string
startTime dateTime
endTime dateTime

___a. Right click in the Types section of the XSD editor and select ‘Add Complex Type’ from the pop-
up menu

Tvpes

Add Complex Type

add Simple Type

| Shaw properties

Refactar ¥

Feferences L

___b. Name the complex type as ActivityEventData and save the changes. You should see the new
complex type element added, as shown below:

| Types |
ActivityEventDats  sE—

___c. Right click the complex type ‘ActivityEventData’ again and select ‘Add Element’ from the pop-
up menu. By default the new element is created with a default name ‘NewElement’ and xsd type
‘string’ as shown below:

|S] *tctivityEvent,zsd &3 =08

@I? wiew: Detaled = ()

ActivityEventData

-

le] JERNSENERY  string

|

Design | Source |
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___d. Modify the element name from ‘NewElement’ to ‘businessUnit’ and accept the default xsd type

as ‘string’

___e. Repeat the above instructions to add the remaining elements mentioned in the table. The final

___f. Now click the icon (

___ 0. Save the changes. File > Save or Ctrl + S

‘ActivityEventData’ complex type should look like the picture below:

editor view.

[S] *activityEvent, xsd £2 =0
Y
BEII & Yiew: Detaled < (2)
ActivityEventData
[&] businessUnit skring
€] processkame skring
[&] mcID skring
[&] activityhanme skring
|e] eventType skring
[&] startTime dateTime
[&] endTime dateTime b
=
Design Source|
=
ER

) located in the upper left corner. This leads you back to the full schema

6. Add another complex element type named OrderBOData and the following sequence of elements
to the complex type

The following are the elements including the data types you will be adding:

Name of the Element Type
orderNumber string
customerNumber string
orderState string
city string
country string
productNumber string
guantity int
totalPrice float

___a. Right click in the Types section of the XSD editor and select ‘Add Complex Type’ from the pop-
up menu and name it OrderBOData
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| Twpes

fitivityEventData
OrdetBODats aE——————————

___b. Right click the complex type ‘OrderBOData’ again and use ‘Add Element’ as required to create
all the elements required for this complex type. The final ‘OrderBOData’ complex type should
look like the picture below:

|5| *ackivibyEvent, xsd 24 =0

[
@IE_E View: Detaled = (2)

OrderBOData

|&] ordermumber skring

8] customertumber  string

|&] orderstate skring
[&] ciky skring
[&] country skring

|&] productMumber skring
|&] quantity ink
|&] totalPrice Float

Design | Source |

=
___c¢. Now click the icon (@,) located in the upper left corner. This leads you back to the full schema
editor view.

__d. Save the changes. File > Save or Ctrl + S
7. You can click the source tab to view the source XSD of the ActivityEvent schema you created.

8. WebSphere Business Monitor 7.0 has support for concurrent versions of monitor models. In order to
take advantage of the Monitor server's version handling capabilities, each monitoring context should
have a unique event definition that is the single inbound event that has the setting ‘If no instances
are found: Create new instance’. One can think of this as one inbound event carrying ‘create
monitor context’ semantics, and all others as ‘update monitor context’ semantics. Clips And Tacks is
a simple sample and could use a single event definition for the process. However, to satisfy the
requirement of a unique event definition for version handling, you will create a new event definition
that will create new instances of the monitor model.

__a. Inthe project explorer, right click Event Definitions and select New - Event Definition... (xsd)
from the pop-up menu. The ‘New’ event definition panel opens.

___b. In the New event definition panel, select ClipsAndTacks as the parent folder and enter the ‘File
name:’ as NewOrderEvent.xsd and click Finish.

9. Review and update the <schema> element, which is the root element of the schema

___a.Inthe XSD editor, select the schema element and then select the ‘General’ tab of the
‘Properties’ view
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%
Manitaring Flow Problems | Servers | Console ¥~ =0

|
[ zeneral 5| schema

Documentation

Prefix: tns —Ee———

Extensions

Target namespace: | http:ff iClipsandTacks MewOrderEvent, xsd

___b. Update the ‘Prefix:’ from tns to noe (short for NewOrderEvent)
___c. Click the Advanced button to edit the schema information (attributes)

+= Edit Schema Information | x|

Targek Mamespace

| SttpiClipsandT acks MewOrderEvent, xsd

Mamespace Declarakions

=

Prefix | Marnespace Marme | add...
wed hikkpsf e, w3, orgf 2001 fMLSchema
noe  =&=—  http: )l ClipsandTacks MewOrderEvent, xsd Edit

[elete

qualified

Prefix qualification of local elements:

Prefix gqualification of attributes: qualified

Jul L

Ok I Cancel |

___d. Click the Add button to add the ActivityEvent namespace so the ‘ActivityEvent’ schema can be
imported to the current ‘NewOrderEvent’ schema. The ‘Add Namespace Declarations’ panel
opens

__e. Enter the following parameters:
e Select the radio button for ‘Specify New Namespace’
e Prefix: ae

e Namespace Name : http:///ClipsAndTacks/ActivityEvent.xsd
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+4= Add Namespace Declarations

i~ sSelect From Registered Namespaces

[ = Specify Mew Mamespace ]

Enter the required prefix and namespace LRI Far the namespace declaration.

Prefix: | ae —
Mamespace Mame:; | http: /fiClipsandTacksactivitvEvent, xsd  =ig—

Location Hink: | Erowse, .., |
Cancel |

__f. Click OK

4= Edit Schema Information

Target Namespace

| htkp: /i lipsandT acks MeworderEvent, xsd

Mamespace Declarations

Prefisx | Marmespace Marme |
hikkps e w3, org 2001 f¥MLSchema
noe htkp: i ClipsandTacks/MewOrderEvent, xsd =i — Edit. ., |
ae http: /i lipsandTacks activibvEvent. xsd -
Delete |
Prefix qualification of local elements I qualified j
Prefix qualification of attributes: I qualified j

(0] 4 | Cancel

___g. Ensure that the prefix qualification of local elements and the attributes is set to ‘qualified’

___h. Click OK. The ‘General’ properties view of the ‘ActivityEvent’ schema should look like the picture

below:
. . —— O )
Maonitaring Flow Problems | Servers | Console B
|
[General S| schema

Documentation :
Prefix: nog wEe—————

Extensions

Target namespace: | http:ff iClipsandTacks MewOrderEvent, xsd

___i. Save the changes. File > Save or Ctrl + S
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___j- Right click any where in the ‘Directives’ section of the XSD editor and select ‘Add Import’ from
the pop-up menu to import the ‘ActivityEvent’ schema. An empty XSD <import> element is added

(2= Directives

4 (Mo Location Specified) #——— Select here

___k. Inthe XSD editor, select the empty XSD <import> element and then select the ‘Properties’
General panel

3
Monitaring Flow Problems | Servers | Console ¥~ =0

[General “~ import
Documentation
MNamespace:
Extensions
Prefizx;
Schema location:

1) Click the button for ‘Schema Location’. The ‘Select XML Schema file’ panel opens

4& select XML schema file

Include Another Schema B
Select another schema From workbench projects or from HTTP. r_:“*

Select schema From:

£+ Warkbench projects
" HTTP

Einish Zancel

2) Ensure the radio button next to ‘Workbench projects’ is selected and click Next

3) In the following panel, expand the ‘ClipsAndTacks’ folder and then select ‘ActivityEvent.xsd’

2010 April, 20 IBM WebSphere Business Monitor 7.0 — Lab exercise Page 14 of 69

ClipsAndTacks (XSD event definitions)



2010 April, 20

© Copyright IBM Corporation 2010. All rights reserved

+4= select XML schema File
Select XML schema file e
Select an XML schema file From the \Waorkbench projects r:_“
Warkbench Files +i—
= E ClipsandTacks
] it Event. sd

Impoart Files. . |
(7 < Back | Mk = | Eirish I Cancel

4) Click Finish. The Properties General panel should look the picture below:

%
Maonitaring Flow Problems | Servers ¥~ =0

[General “~ import
) Mamespace; hittp: /i ClipsandTacks) ActivityEvent, xsd
Extensions

Prefix: ae

Schema location: | AckivityEvent, xsd

5) Save the configuration. File - Save or Ctrl + S

___|. Now right click in the ‘Types’ section and select the ‘Add Complex Type’ from the pop-up menu.

An XSD <complexType> element is added with a default name, which you should change to
‘NewOrderEvent’ .

| Types |
MewdrderEvent

___m. Save the configuration. File - Save or Ctrl + S

___n. Right click the ‘NewOrderEvent’ complex type element again and select ‘Add Element’ from the
pop-up menu. A new element of type string is added with a default name as shown below:

MewOrderEvent

BN Element

skring

___ 0. Rename the name of the element to ‘NEWActivityEventData’

___p- For the ‘Type:’ select ‘Browse’ from the drop down list. The ‘Set Type’ panel opens
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MewrderEvent

wos €] MEWACkivicyEventData | 5tHing -

Mew, .. ]
boolean
date
dateTime
dauble
Float
hexBinary
ink

string
Lirne

4= Set Type

Mame {7 = any character, * = any string):

Twpes:

[=] arysimplaType
= anylRI
[=] hacatdPinaem. LI

Ceclaration Location:

Seatch Scope
& Workspace & Enclosing Project ¥ Current Resource

" Working Sets I Choose, .. |
OF I Cancel |

___ Q. Select ‘ActivityEventData’ from the ‘Types’ text area and click OK. The NEWActivityEventData
element should look like the picture below. You can click the + next to ActivityEventData to see
the details of the element.

MewOrderEvent

seal €] MEMWACkvibyEventData ActivityEventData T

___r. Save the configuration. File - Save or Ctrl + S

___s. Now right click the ‘NewOrderEvent’ complex type element and select ‘Add Element’ from the
pop-up menu. A new element of type string is added with a default name as shown below:

Mew(rderEvent

[&] MEW AckivityEventData activicvEventData

[8] MewElement: skring
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___t. Rename the name of the element to ‘NEWOrderBOData'. For the ‘Type:’ select ‘Browse’ from
the drop down list. The ‘Set Type’ panel opens. Select ‘OrderBOData’ from the ‘Types’ text area

and click OK. The NEWOrderBOData element should look like the picture below.

MewOrderEvent

___U. Click the + icons to see the details.

MewOrderEvent

|| NEWACtivityEventData ActivityEventData
(8] NEWOrderBOData OrderBOData

|| NEWACtivityEventData ActivibyEventData [+
“|[2] NEwordsrBoData OrderBODat s ,!,
AckivityEventData
businessUnit skring
processMame skring
eIl skring
ackivityMarne skring
eventType skring
skartTirme dateTime
endTinme dateTime
T OrderBOData
1 orderMumber string
customerMurmber skring
orderstate string
city skring
counkey skring
produckhumber string
quankity int
kokalPrice Float

___v. Save the configuration. File - Save or Ctrl + S

___w. Click the source tab to see the XSD source.

___X. Close the XSD schema editor

10. Create a new monitor model ClipsAndTacks. The monitor model contains the metrics and KPIs that
you want to monitor and it will be the source for creating the deployment code for the monitor
server.

___a. Right click in the ‘Business Monitoring’ project explorer view and select New - Monitor
Model... from the pop-up menu. The Monitor Model panel opens

2010 April, 20
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Create a monitor model

Create a new manitaor madel.
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Enter or select the parent Folder:

| ClipsandTacks

it

------ == ClipsandTacks

File name: I ClipsandTacks

: ancel |

2) Click Finish. The model editor is opened as follows:

Note: When the model editor first opens you will have errors in the model. This is normal and is signaling
that required elements are missing or incomplete. Next you will complete these required elements.

B Project Explarer 52 =08

5, CipsandTacks X Wi

|5 MeworderEvent.xsd
=L Manitor Models

fu El. ClipsandTacks,mm
(a8 WG Files

=8
= 5| Monitor Details Model
= Tf_‘-} ClipsandTacks
EI]_,T’ Evert Definitions = Bk = Monitor Details
© - [F actionServicesEvent, che El-g3-2 ClipsandTacks MC Edit the details of the model,
8] ActivityEvent xsd - ClistindTacks key The timestamp is required to identify the version of the model,
- D + ClipsandTacks
Mame: ClipsAndTacks
Descripkion: ;I
=

Tirne Stamp (UTC): ,/2007-10-15T16:07:552

w User-Defined XPath Functions

apecify and assign a prefix ka the user-defined function libraries
that are available For use within this monitor rmodel,

Monitor Details MndeIJ KPI Model | Dimensional Model | Wisal Model | Ewent Model | ClipsandTacks. mm |

_____11. Notice in the Monitor Details Model navigator that a new model is created (ClipsAndTacks) along
with a monitoring context (ClipsAndTacks MC). Now you need to specify the inbound events that will
be processed by this model. You need to indicate which event will create a new monitoring context
instance and which event will terminate the monitoring context instance. You also need to identify
the correlation information for the monitoring context so that Monitor knows which monitoring
context instance should receive the events. The ClipsAndTacks model uses one event definition,
ActivityEvent, to represent the layout of all of the events to be processed. NewOrderEvent derives
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from ActivityEvent but does not add additional event elements. In ActivityEvent, ActivityName is a
field used to identify specific activities in the ClipsAndTacks process. ActivityName is used to
determine when to terminate the monitoring context. You will create correlation that is based on
orderNumber, which is another field defined in ActivityEvent.

12. In the Monitor Details Model, expand ClipsAndTacks in the navigation view. Then expand
ClipsAndTacks MC. You will see that a key has been created for you automatically when you
created the model.

B H
=i ClipsAndTacks MC
efw ClipsandTacks Key

13. In the model navigation view, right click ClipsAndTacks MC, then select New - Inbound Event
from the pop-up menu

___a. For the name, type Activity Event. Notice that the ID will automatically be set for you to the
same name with underscores (Activity Event)

4= Create New Inbound Event

Create an inbound event
() Type the name and ID.

Mame: |Activity Event

I Ackivity _Event

Zancel |

___b. Click OK. The inbound ‘ActivityEvent’ opens in an editor

___c. Inthe inbound ‘ActivityEvent’ editor, click the ‘Add’ button for ‘Event Parts’ to create a new event
part type in the ‘Event Type Details’ section. The ‘Create New Event part Type’ panel opens

___d. Inthe ‘Create New Event part Type’ panel, enter the following:
1) Name : My Event Partl
2)ID : My_Event_Partl

3) Click the ‘Select Type’ button for the ‘Type’ field. The ‘Select Event Part Data Type’ panel
opens

a) Select the check box for ‘Choose the data type from XML schemas accessible from
this monitor project’

b) Expand ClipsAndTacks - ActivityEventData and select ‘ae:ActivityEventData’
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#4= Select Eyent Part Data Type
Select event part data type

Choose the %ML schema data bype that defines the skructure of this
event park,

" Mo data byvpe specified For this event park

¥ Choose the data bype from the %ML schemas accessible from this monitor project

SRE= ClipsAndTacks

aka
#- 5] MeworderEvent,xsd

™ Choose from the list of predefined XML schema simple data types

Twpe: I j

" Choose the bype From the predefined data bypes in the ¥ML catalog

Twpe: I Browse, .. |

< Back: Mext = | Einish I Cancel |

¢) Click Finish

4) Path : cbe:CommonBaseEvent/ae:ActivityEventData

Note: The path is an XML Path Language (XPath) expression that identifies the location in the event
definition of the structure defined by the event part type. The expression is based on the structure of the
actual event instance to be received at run time. It always starts with cbe: ConmonBaseEvent and
navigates into content that is placed in the xs: any slot of the Common Base Event. In general, if an XML
Schema Definition (XSD) used to define an event structure contains an <xsd:any> or <xsd:anyType> slot,
you should use an event part to specify the actual structure of the content that will fill that slot at run time.
In this event part, you use cbe:CommonBaseEvent/ae: ActivityEventData as the path. Refer to
‘alIXSDevents.xml’ located in the Labfiles70.zip file, to see how the XSD based events are being sent
during runtime.

2010 April, 20

4= Create New Event Part Type
Create an event part type

=
Specify the details of the event part. Together, all the event parts describe the S
struckure of the event at run time.,

Mame: | My Event Partl

ID: | My_Evert_Part1

Tvpe: | e ActivikyEventData Select Tvpe... |

Path: [l che:CommonBaseEventfae: AckivityEventData

(71 = Back MExt =

Cancel |
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5) Click Finish

14. In the inbound ‘ActivityEvent’ editor, click the ‘Add’ button ‘Event Parts’ again to create another
event part type in the ‘Event Type Details’ section. The ‘Create New Event part Type’ panel opens

___a. Inthe ‘Create New Event part Type’ panel, enter the following:
1) Name : My Event Part2

2)ID : My_Event_Part2

3) Click the ‘Select Type’ button for the ‘Type’ field. The ‘Select Event Part Data Type’ panel
opens

a) Select the check box for ‘Choose the data type from XML accessible from this
monitor project’

b) Expand ClipsAndTacks - ActivityEventData.xsd and select ‘ae:OrderBOData’

4= Select Event Part Data Type
Select event part data type

hoose the ®ML schema data tvpe that defines the struckure of this
event park,

" Mo data bype specified For this event park
¥ Choose the data type From the XML schemas accessible Fram this monitor project

Bl TB ClipsandTacks
= |S] ActivityEvent.xsd

- ae AckivityEventData

- ae:OrderBOData
#-|5| MeworderEvent,xsd

i~ Choose from the list of predefined XML schema simple data kypes

Twpe: I ll

"~ Choose the bype From the predefined data bypes in the ¥ML catalog

Twpe: | Erawse., . |
= Back Hext = | Einish I Cancel |

¢) Click Finish

4) Path : cbhe:CommonBaseEvent/ae:OrderBOData
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+4= Create New Event Part Type
Create an event part type

Specify the details of the event part, Together, all the event parts
describe the struckure of the event at run kime,

Marme: | My Event Partz

ID: | My_Event_Part2

Type: | ae:OrderBODaka

Select Tvpe... |

Path: [I che:CommonBaseEvent)as OrderBOData |

() = Back | flext = |

Cancel |

5) Click Finish

___b. The final ‘Event Type Details’ section with the two ‘Event parts’ should look like the picture

below:

+ Event Type Details

Specify the event bype ar the ¥ML schemas that together describe the struckure of this inbound event,

¥ou can specify an extension name, event parts, or both,

Extension name: |

Event parts: ID | Mame | Tvpe | Path

| Browse, ., | | Clear |

My Event_P... MwEventP...  ae:ActivitvEventData cbe:CommonBaseEventae: ActivitvEventData
My _Ewent_P... My EventP... aeiOrderBOData che: CommonBaseEvent/ae: OrderBODaka

__C. Save the configuration. File > Save or Ctrl + S

___d. To enter the Filter Condition, you can use Content Assist with the keys Ctrl-Space, or you can
type the expression directly into the expression window. When completed the expression should
be as follows. Note the single quotation marks used for string handling.

Activity Event/My_Event Partl/ae:businessUnit = 'Clips And Tacks' and
Activity Event/My_Event Partl/ae:processName = 'Order Handling'

___e. To enter the Correlation Expression, you can use Content Assist with the keys Ctrl-Space, or
you can type the expression directly into the expression window. When complete the expression

should be

ClipsAndTacks_Key =Activity _Event/My_Event_Part2/ae:orderNumber

__f. For ‘If no instances are found’, select ‘Treat as error’
___g. For ‘If one instance is found’, select ‘Deliver to the instance’
__h. For ‘If multiple instances are found’, select ‘Treat as error’

__i. Here is a sample of a portion of the definition:
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+ Filter Condition
Define a condition based on the event atkributes to identify whether bo accept an event of this bype,

Activity_Event/My_Event_Partl)ae;businessinit = 'Clips And Tacks' and ;I
Activiby_Event/My_Event_Partl)ae:processhlame = 'Order Handling'
[ -

+ Correlation Expression

Define an expression ko identify the monitaring conkext instance or instances that receive the event at
runkime.

ClipsandTacks_Key = Activity_Event/My_Ewent_Part2/ae:orderfumber

If nao instances are found Treak as error

If ane inskance is found Celiver to the instance

[ [ = 2

If mulkiple instances are found | Treat as ervor

___j. Save the configuration. File - Save or Ctrl + S

15. In the model navigation view, right click ClipsAndTacks MC, then select New - Inbound Event
from the pop-up menu

___a. For the name, type New Order Event. Notice that the ID will automatically be set for you to the
same name with underscores (New_Order_Event)

__b. Click OK. The inbound ‘NewOrderEvent’ opens in an editor
___c. Inthe inbound ‘NewOrderEvent’ editor, click the ‘Add’ button for ‘Event Parts’ to create a new
event part type in the ‘Event Type Details’ section. The ‘Create New Event part Type’ panel
opens
___d. Inthe ‘Create New Event part Type’ panel, enter the following:
1) Name : My Event Part
2) ID : My_Event_Part

3) Click the ‘Select Type’ button for the ‘Type’ field. The ‘Select Event Part Data Type’ panel
opens

a) Select the check box for ‘Choose the data type from XML accessible from this
monitor project’

b) Expand ClipsAndTacks - NewOrderEvent.xsd and select
‘noe:NewOrderEvent’
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+= Select Event Part Data Type
Select event part data type

Choose the ¥ML schema data tyvpe that defines the structure of this
event park,

i~ mo data tvpe specified for this event park

{* Choose the data bype From the %ML schemas accessible from this maonitor project

= 2 ClipsandTacks
- [5] ActivityEvent. xsd
= [5] MewOrderEvent.xsd
Lo .

& MewdrderEvent

" Choose from the list of predefined %ML schema simple data types

Tvpe: I j

" Choose the type From the predefined data bypes in the 2ML cakalog

Tvpe: I Browse,.. |
< Back: Mexk = | Einish I Cancel |

¢) Click Finish

4) Path : cbe:CommonBaseEvent/noe:NewOrderEvent

Note: The path is an XML Path Language (XPath) expression that identifies the location in the event
definition of the structure defined by the event part type. The expression is based on the structure of the
actual event instance to be received at run time. It always starts with cbe: CormbonBaseEvent and
navigates into content that is placed in the xs: any slot of the Common Base Event. In general, if an XML
Schema Definition (XSD) used to define an event structure contains an <xsd:any> or <xsd:anyType> slot,
you should use an event part to specify the actual structure of the content that will fill that slot at run time.
In this event part, you use cbe:CommonBaseEvent/ noe:NewOrderEvent as the path. Refer to
‘alIXSDevents.xml’ part of the Labfiles70.zip to see how the XSD based events are being sent during
runtime.
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4= Create New Event Part Type
Create an event part type

Specify the details of the event part. Together, all the event parts
describe the structure of the event at run time,

Mame: I My Evenk Park

I | My_Event_Part

Twpe: Inne:NewOrderEvent

Select Type. .. |

Path: [Icbe:CDmmDnBaseEventJ‘nDe:NewOrderEvent

(7) = Back Mext =

Cancel |

5) Click Finish

___e. The final ‘Event Type Details’ section with the ‘Event part’ should look like the picture below:

+ Event Type Details

Specify the event bype ar the ¥ML schemas that together describe the struckure of this inbound event,

¥ou can specify an extension name, event parts, or both,

Extension name: |

Event parts: ID | Mame | Tvpe | Path

| Browse, ., | | Clear |

Mw_Ewent_Part Mw Event Part  noe:MewOrderEvent cbe:CommonBaseEvent/noe: MewOrderEvent

__f. Save the configuration. File - Save or Ctrl + S

___g. To enter the Filter Condition, you can use Content Assist with the keys Ctrl-Space, or you can
type the expression directly into the expression window. When complete, the expression should
be as follows. Note the single quotation marks used for string handling.

New_Order_Event/My_Event_Part/noe:NEW ActivityEventData/ae:businessUnit = 'Clips And
Tacks' and New_Order_Event/My_Event_Part/noe:NEWActivityEventData/ae:processName

='Order Handling'

___h. To enter the Correlation Expression, you can use Content Assist or you can type the expression
directly into the expression window. When complete the expression should be

ClipsAndTacks_Key =

New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:orderNumber

__i. For ‘If no instances are found’, select ‘Create new instance’
___j. For ‘If one instance is found’, select ‘Treat as error’
___k. For ‘If multiple instances are found’, select ‘Treat as error’

__l. Here is a sample of a portion of the definition:
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= Filter Condition
Define a condition based on the event attributes to identify whether bo accept an event of this bvpe.

Mew_Order_Event/My_Ewent_Part/noe:MEW ActivityEventDatalae:businessUnit = 'Clips And Tacks' and ﬂ
Mew_Crder_Ewvent/My_FEvent_Part/noe:MEW ActivityEventData)ae: processMame = "Order Handling'
[

+ Correlation Expression
Cefine an expression to identify the monitoring context inskance or instances that receive the event at runtime.

ClipsfndTacks_Key = New_Order_Event/My_Ewvent_Park/nog:MEWOrderBODaka)ae orderMurnber

If noinstances are found Creake new inskance

If one instance is Found Treak as error

FEE R

If rulkiple instances are Found | Treak as error

___m. Save the configuration. File & Save or Ctrl + S
16. In the model navigation view, double click ClipsAndTacks Key, to open the key in the editor

___a. For Key Value Expressions, click ‘Add..." Note that double clicking in the table will produce the
same results.

___b. Arow is added to the table and in the expression cell it shows << No expression specified >>.
Click this cell of the table, then a button is displayed. Click this button and the expression editor
is displayed. You can use Content Assist, or type this expression directly into the window:

New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:orderNumber
___c. Click OK.

___d. Here is a sample of the key:
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10 4 ClipsandTacks_Keyw

ame: ClipsandTacks Key

Description: ;I
[

Type: *l String ka3

Maximum Skring Length: | 256

O allocate additional space in database ko accommodate Unicode string For globalization

O & value is required For this metric

Default Value: Edit. ..
[ This key can be used for sorting

+ Key ¥Yalue EXpressions
Specify the expressions that set the walue of the ke,

| Add | | Remoyve |

__e. Save the configuration. File > Save or Ctrl + S

Note: At this point there should not be any errors remaining in the model. The errors shown initially were
the result of the monitoring context key not being complete.

17. Create triggers that indicate the end of the monitoring context. The first trigger is based on an order
being shipped, and the second trigger is based on an order being cancelled.

__a. Inthe model navigation view, right click ClipsAndTacks MC, then select New - Trigger. Enter
the following values:

1) Name : Ship Order to Customer Trigger
2)ID  :Ship_Order_to_Customer_Trigger
3) Select the check box next to ‘Terminate monitoring context’

4) For Trigger Sources, click Add, then select Other source type - Activity Event and then
click OK

5) For Trigger Condition, enter

Activity Event/My_Event_Partl/ae:activityName = 'Ship Order to Customer' and
Activity Event/My_Event_Partl/ae:eventType = 'completed'

___b. Save the configuration. File - Save or Ctrl + S

__C. Here is a sample of this trigger:
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+ Trigger Details
Edit the detalls of the trigger, which detects an occurrence and initlates an ackion in response.

10 + 3hip_Order_to_Cuskomer_Trigger

farme: Ship Order to Customer Trigger

Description: ||

R L

[ Trigger is repeatable
Terminats monitaring context  seE————

+ Trigger Sources
Specify the source of this krigger,

Source Tvpe Source
Event ogf Bckivity Event

| Add | | Remove |

+ Trigger Condition
Specify the condition that determines whether the trigger will Fire,

Activity_Ewventfiy_Ewent_Partl/ae:activityMame = 'Ship Order to Cuskomer' and ﬂ
Ackivity EwventfMy_Fwent_PartlfaeeventType = ‘completed’

___d. In the model navigation view, right click ClipsAndTacks MC, then select New > Trigger. Enter
these values:

1) Name : Cancel Trigger
2)ID : Cancel_Trigger
3) Select the check box next to ‘Terminate monitoring context’

4) For Trigger Sources, click Add, then select Other source type > Activity Event, then click
OK.

5) For Trigger Condition, enter

Activity_Event/My_Event_Partl/ae:activityName = ‘Cancel Order and Send Notification' and
Activity Event/My_Event Partl/ae:eventType = 'completed'

___e. Save the configuration. File > Save or Ctrl + S

___18. Create a KPI for Average fulfillment three days or less. First you will create a trigger which fires
when a new order is started. Metrics are created to hold the order start time and order end time. The
values of the metrics are set when the new order trigger fires. You create a duration metric which is
calculated based on subtracting the order end time metric from the order start time metric. You will
create a KPI context which is a container to hold the KPIs. Then you create a KPI which is based on
the duration metric and you apply an average function to it.

___a. Inthe model navigation view, right click ClipsAndTacks MC, then select New - Trigger. Enter
these values:
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1) Name : New Order Trigger
2)ID : New_Order_Trigger

3) For Trigger Sources, click Add, then select Other source type > New Order Event, then click
OK.

4) For Trigger condition, enter

New_Order_Event/My_Event_Part/noe:NEW ActivityEventData/ae:activityName = 'Check
Order Handling Policy for Automatic Approval' and
New_Order_Event/My_Event_Part/noe:NEW ActivityEventData/ae:eventType = 'started'

5) Save the configuration. File & Save or Ctrl + S

___b. Inthe model navigation view, right click ClipsAndTacks MC, then select New - Metric. Enter

2010 April, 20

these values:

1) Name : Order Start Time

2)ID : Order_Start_Time

3) Type :DateTime

4) For Metric Value Expressions, click Add

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

6) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

New_Order_Event/My_Event_Part/noe:NEW ActivityEventData/ae:startTime
7) Click OK.

8) Save the configuration. File - Save or Ctrl + S
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- Metric Details
Edit the details of the metric, which is a holding spat For information used in other calculations,

j (nH « Order_Start_Time

Marme: Order Start Time

Descripkion: ;I
[

Twpe: - DateTime El

O & walue is required For this metric

Default YWalue:

[ This metric can be used for sorting

w Metric ¥alue Expressions
Specify the expressions that set the value of the metric, IF a trigger is specified, the map is evaluated when the trigger fires,

__c¢. Inthe model navigation view, right click ClipsAndTacks MC, then select New > Metric. Enter
these values:

1) Name : Order End Time

2) ID : Order_End_Time

3) Type :DateTime

4) For Metric Value Expressions, click Add

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> Ship Order to Customer Trigger, click OK

6) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

Activity_Event/My_Event_Partl/ae:endTime
7) Click OK.
8) For Metric Value Expressions, click Add
9) In the second row of the Metric Value Expressions table, select the cell under column
Trigger, then a button is shown, then click the button and select Trigger type >
ClipsAndTacks MC > Cancel Trigger, click OK
10) In the second row of the Metric Value Expressions table, select the cell under column

Expression, then a button is shown, then click the button and enter this text:
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Activity Event/My_Event Partl/ae:endTime
11) Click OK.

__d. Save the configuration. File - Save or Ctrl + S

+ Metric Details
Edit the details of the metric, which is a holding spat Far information used in other calculations,

10 « Order_End_Time
Marme; Crder End Time
Descripkion:

Type: *I-M

O & walue is required for this mekric

Default Yalue: Edit...

I K1 R ]

O This metric can be used For sorting

= Metric ¥alue EXpressions
Specify the expressions that set the walue of the metric, IF a trigger is specified, the map is evaluated when the trigaer fires,

Trigger | Expression |
?5=:3>5hi|:| Crder to Customer Trigoer xﬂ Ackivity _Event/My_Event_Partlae:endTime
?5=:-'>Can|:el Trigaer x-;v Ackivity _Event/My_Event_Partlfae:endTime

___e. Inthe model navigation view, right click ClipsAndTacks MC, then select New > Metric. Enter
these values:

1) Name : Order Fulfillment Duration

2)ID : Order_Fulfillment_Duration

3) Type : Duration

4) For Default Value, click Edit...

5) On the Select Duration dialog, click OK, and this will set the default duration to zero
6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> Ship Order to Customer Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

xs:dayTimeDuration(Order_End_Time - Order_Start_Time)
9) Click OK
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10) For Metric Value Expressions, click Add

11) In the second row of the Metric Value Expressions table, select the cell under column
Trigger, then a button is shown, then click the button and select Trigger type >
ClipsAndTacks MC > Cancel Trigger, click OK

12) In the second row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

xs:dayTimeDuration (Order_End_Time - Order_Start_Time)
13) Click OK.

__f. Press Ctrl-S to save your work.

w Metric Details
Edit the details of the metric, which is a holding spok For information used in other calculations.

O & walue is required For this metric

10 « Drder_Fulfillment_Duoration

Mame: Order Fulfillment Duration

Drescription: | ;I
=

Type: *l Duration IE'

Defaulk Yalue: | dayTimeDuration PODTOHOMO, 0005 Edit...
[ This metric can be used For sorting

+ Metric ¥alue Expressions
Specify the expressions that set the value of the metric, IF a trigger is specified, the map is evaluated when the trigger fires,

Trigger | Expression |
55=:'t>5hip Order bo Customer Trigger ﬁv waidayTimeDuration (Order_End_Time - Order_Sktart_Time)
?5=:5>Cann:el Trigger x—:f;v wsrdayTimeDuration (Order_End_Time - Order_Skark_Time)

| Add | | Remove |

___g. Click the KPI Model tab.
___h. Create a KPI context to store the KPlIs.

1) In the navigation view of the KPI Model, right click ClipsAndTacks, then select New > KPI
Context

a) Name :- My KPI Context
b) ID .- My_KPI_Context

___i. Create the average order fulfillment KPI.
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Note that you will create the KPI based on events for August 2006. This will work for you no matter what
month or year that you run this lab because the timestamps in the test data are based on August 2006, so
your results will be the same as in these lab instructions.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name :- Average Order Fulfillment KPI August 2006
b) ID .- Average_Order_Fulfillment_KPIl_August_2006
2) Enter these values:
a) Type — Duration
b) Select 'Keep track of historical values for this KPI'

c) In KPI Target and Ranges, for Target click Details..., then change the value to 3
Days, then click OK

d) In KPI Target and Ranges, for Ranges select Actual value
e) In the Range table,
(1) Click Add, or double click anywhere in the table
(2) Change the Name to Day 1, and the ID to Day_1
(3) Arow is created in the Range table with a range name Day 1.

(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change all values to 0, then click OK.

(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change Days to 1 and the other values
to 0, then click OK.

f) Now you have created one range called Day 1. Repeat the above step to create four
more ranges:

(1) Day 2 with start values 1 Days and end value 2 Days
(2) Day 3 with start values 2 Days and end value 3 Days
(3) Day 4 with start values 3 Days and end value 4 Days
(4) Day 5 with start values 4 Days and end value 5 Days
g) KPI Value — select ‘Base this KPI on a metric and an aggregation function’

h) Under KPI Details, for Monitoring context, click Browse..., then select
‘ClipsAndTacks MC’, then click OK

i) Metric — click Browse..., then select Order Fulfillment Duration, then click OK
j) Aggregation function — select Average.

k) Under Time Filter, for Metric, click Browse..., then select Order Start Time, then
click OK
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[) Specify time period — Fixed
m) Start date — click Edit... then select date 2006-08-01, time 00:00:00, click OK
n) End date — click Edit..., then select 2006-08-31, time 23:59:59, click OK

3) Press Ctrl-S to save your work.

+ KPI Details
Edit the details of the KPI, which is a performance measurement used to track business objectives,

I 4 Bwerage_order_Fulfillment _KPI_August_z00&

Marme: Average Order Fulfillment KPT August 2006

Description: ;I
[

Type: " Duration E‘

Keep track of histarical values For this KPT

w KPI Target and Ranges
Specify a target, which is an exact value For the KPI to achieve, or ranges against which to krack the KPI, or bath,

Target: 3 Days

Ranges: Ackual value Iz‘
Range name | Start value | End walue | Calar |
= Davl 0 Milliseconds < 1 Days
= Dav 2 1 Days < 2 Days
= Dav 3 2 Days < 3 Davs
= Dav 4 3 Days < 4 Days
= Day s 4 Days = 5 Days

| Add ||Remnve|| Sort |

2010 April, 20 IBM WebSphere Business Monitor 7.0 — Lab exercise Page 34 of 69

ClipsAndTacks (XSD event definitions)



© Copyright IBM Corporation 2010. All rights reserved

= KPI Definition
Specify how the value of the KPT is set,

KPI ¥alue

Choose how the KPT will get its value:
{® Base this KPT on a metric and an aggregation Function,

O Write an expression to calculate this KPI based on existing KPIs

KPI Details

Monitoring contexts 4 ClipsandTacks MC
Metric: 4 order Fulfillment Curation

Aggregation funckion: *l Average Iz‘
IJse values From: ® all madel versions ) Only this version of the maodel
Time Filter

Select a time period aver which the KPT should be calculated,

Metric: | Order Start Time

Time period:
) Mone O repeating Q) Rolling {® Fixed

Start date:; | 2006-08-01T00:00:00 End date:; | 2006-05-31T23:59:59
Time zone; *IGMT-UE-:UU : Location {davlight sawing: I E‘

___j. Note that this KPI as it stands averages order fulfillment time for shipped orders and cancelled

orders, but you probably are not interested in the cancelled orders to be included in this KPI. So
update the average order fulfillment KPI to show the values for shipped orders only. First you will
create a new metric to hold the order status. Then you will add this metric as a data filter on the
KPI.

__ k. Click the Monitor Details Model tab.

__l. In the Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >

2010 April, 20

Metric. Enter these values:

1) Name :- Order Status

2)ID .- Order_Status

3) Type :- String

4) Select the check box for ‘A value is required for this metric’

5) Default Value (enter this text with single quotation marks) — ‘New’
6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> Cancel Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text with the
guotation marks:
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‘Cancelled’
9) Click OK.
10) For Metric Value Expressions, click Add
11) In the second row of the Metric Value Expressions table, select the cell under column
Trigger, then a button is shown, then click the button and select Trigger type >
ClipsAndTacks MC > Ship Order to Customer Trigger, click OK
12) In the second row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text with the
guotation marks:
‘Shipped’

13) Press Ctrl-S to save your work

~ Metric Details
Edit the details of the metric, which is a holding spot For information used in other calculations.

10 4 Order_Skatus

Marne: Order Skatus

Description: ;I
=

Type: *l String =]

Mazimurn Skring Length: | 256

O allocate additional space in database bo accommodate Unicode string For globalization

i value is required For this metric,  sgE——

Default value: ) MNew'

[ This metric can be used For sarting

~ Metric Value Expressions

Specify the expressions that set the walue of the metric, IF a trigger is specified, the map is evaluated when the trigger fires,

Edit .,

Trigger | Expression |
:~=:{> Zancel Trigger ﬁ\" ‘Cancelled

5€*=:'t>5hip Order to Cuskomer Trigger ﬁ\" 'Shipped'

___m. Update the order fulfillment KPI to use the order status as a filter.

1) Click the KPI Model tab.

2) In the KPI Model navigation view, navigate to ClipsAndTacks > My KPI Context > Average

Order Fulfillment KPI August 2006
3) In the Data Filter section for this KPI, click Add

4) In the dialog, navigate to ClipsAndTacks MC - Order Status, then click OK
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5) In the row containing metric Order Status, make sure the operation defaults to ‘equals’.
Also, click the cell in the column Values, then enter this text (with quotation marks):

‘Shipped’

6) Press Ctrl-S to save your work.

Case-sensitive

____19. Create a KPI for number of approved orders greater than 90%. First you will create a KPI to count
the number of total orders. Then you will create a KPI to count the number of shipped orders.
Finally, you will create a KPI that calculates the approval percentage as this formula: (ship count /
order count) * 100.

___a. Click the KPI Model tab then create the order count KPI.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name :- Order Count KPI
b) ID .- Order_Count_KPI

2) Enter these values:
a) Type :- Decimal
b) Select 'Keep track of historical values for this KPI'
¢) Do not specify targets nor ranges
d) KPI Value — select ‘Base this KPI on a metric and an aggregation function’

e) Under KPI Details, for Monitoring context, click Browse..., then select
‘ClipsAndTacks MC’, then click OK

f) Metric — click Browse..., then select ClipsAndTacks Key, then click OK
g) Aggregation function — select Count

3) Press Ctrl-S to save your work.

___b. Create the ship count KPI.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name :- Ship Count KPI
b) ID .- Ship_Count_KPI

2) Enter these values:
a) Type :- Decimal
b) Do not specify targets nor ranges

c¢) KPI Value — select ‘Base this KPIl on a metric and an aggregation function’
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d) Under KPI Details, for Monitoring context, click Browse..., then select
‘ClipsAndTacks MC’, then click OK

e) Metric — click Browse..., then select ClipsAndTacks Key, then click OK
f) Aggregation function — select Count
g) In the Data Filter section for this KPI, click Add
h) In the dialog, navigate to ClipsAndTacks MC - Order Status, then click OK
i) In the row containing metric Order Status, make sure the operation defaults to
‘equals’. Also, click the cell in the column Values, then enter this text (with
guotation marks):
‘Shipped’
3) Press Ctrl-S to save your work.
__c. Create the percent of orders approved KPI.
1) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name :- Percent of Orders Approved KPI
b) ID .- Percent_of_Orders_Approved_KPI
2) Enter these values:
a) Type :- Decimal
b) Select 'Keep track of historical values for this KPI'

c¢) In KPI Target and Ranges, for Target click Details..., then change the value to 90,
then click OK

d) In KPI Target and Ranges, for Ranges select Actual value
e) In the Range table,
(1) Click Add
(2) Change the Name to Low Range, and the ID to Low_Range
(3) Arow is created in the Range table with a range name Low Range.

(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change the value to 0 and then click OK.

(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change the value to 90 and then click
OK.
f) Repeat the above step to create one more range:

(1) High Range with start value 90 and end value 100

g) KPI Value — select ‘Write an expression to calculate this KPI based on existing
KPIs’
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h) For KPI Calculation, enter this text:
fn:round((Ship_Count_KPI div Order_Count_KPI) * 100)

3) Press Ctrl-S to save your work.

« KPl Target and Ranges

Specify a karget, which is an exact value For the KPI to achieve, or ranges against which to track the KPI, or both,

Targek: an

Ranges: *l Ackual value IE'
R.ange name | Start walue | End walue |
= Low Range ] < 90
= High Range an < 100

| add ||Remu:uve|| Sork |

~ KPI Definition
Specify how the value of the KPT is set,

KPIl ¥alue

Choose how the KPT will get its value:
{2 Base this KPI on a metric and an aggregation Funckion,

{2 wWrite an expression to calculake this KPI based on existing KPIs
KPI Calculation

For example, you could have a Total Profit KPI that subtracts the Total Cost KPI from the Total Revenue KPIL

¥ Frsround((sShip_Count_EPI div Order_Count_KPT) * 1000 N

_____20. Inthe dashboards, you might like to see the total order price, the average order price and the total
number of orders. And you might be interested in seeing this information by country and city, and by
order status. So now you will create dimensions and measures that allow you to see this
information. For aggregated numeric information like total order price, you will create a measure in
the dimensional model. For textual attributes like order status, you will create a dimension in the
dimensional model. In order to see the country and city information, you will create a multi-level
location dimension containing country as the first level and city as the second level. Each measure
and dimension needs a metric as a source, so you will also need to create metrics for country, city
and total price.

__a. Click the Dimensional Model tab.
___b. Add order status as a dimension to the Dimensional Model.
1) In the navigation view, click ClipsAndTacks MC Cube
2) In the dimensions table, click New Dimension...
a) Name :- Order Status Dimension
b) ID :- Order_Status_Dimension
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¢) Click OK

3) Click New Level...
a) Name :- Order Status
b) ID :- Order_Status

¢) Source metric — Click Browse..., then select ClipsAndTacks MC - Order Status.
Then click OK.

d) Click OK.

4) Press Ctrl-S to save your work.

* Dimensions
Work with the dimensions and dimension levels of this cube, Dimensions are data cateqories made up of hierarchical dimension levels.

Dimension [ Dimension Leyvel | Source Metric | Mew Dimension. ..
= B' order Status Dimension
|5 order Status [ Crder Skakus

Mew Level, .,
Remove
Mave

Move Down

il

___C. Click the Monitor Details Model tab.

___d. In the Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >
Metric. Enter these values:

1) Name :- country

2)ID ;- country

3) Type :- String

4) Select the check box for ‘A value is required for this metric’

5) Default value : *  (Note: Empty single quotation marks)
6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:country
9) Click OK.

10) Press Ctrl-S to save your work
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___e. In the Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >
Metric. Enter these values:

1) Name :- city

2)ID - city

3) Type :- String

4) Select the check box for ‘A value is required for this metric’
5) Default value : ©*  (Note: Empty single quotation marks)

6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:city
9) Click OK.
10) Press Ctrl-S to save your work

__f. In the Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >
Metric. Enter these values:

1) Name :- totalPrice

2)ID .- totalPrice

3) Type :- Decimal

4) For Metric Value Expressions, click Add

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

6) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:totalPrice
7) Click OK.
8) Press Ctrl-S to save your work
___@. Click the Dimensional Model tab.
___h. Add location as a dimension to the Dimensional Model.
1) In the navigation view, click ClipsAndTacks MC Cube

2) In the dimensions table, click New Dimension...
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a) Name :- Location
b) ID .- Location
c) Click OK

3) Click New Level...

a) Name :- Country

b) ID :- Country

c¢) Source metric — Click Browse..., then select ClipsAndTacks MC - country. Then
click OK.

d) Click OK.

4) Click New Level...
a) Name :- City
b) ID :- City

c) Source metric — Click Browse..., then select ClipsAndTacks MC = city. Then click
OK.

d) Click OK.

5) Press Ctrl-S to save your work.

+* Dimensions
wWork, with the dimensions and dimension levels of this cube, Dimensions are data categories made up of hierarchical dimension levels,

[Mowe Do

Dimension [ Dimension Lewvel | Source Metric | Mew Dimension. ..
= B order Status Dimension
|5 crder Status [ Order Status
= B Location I
= |5 country [ counkry
T i

___i. Ensure that the Dimensional Model tab is selected.
___j. Inthe Dimensional Model, add a measure for average order price.
1) In the navigation view, click ClipsAndTacks MC Cube
2) In the Measures table, click New ...
a) Name :- Average Order Price
b) ID .- Average_Order_Price
¢) Source metric - Click Browse..., then select ClipsAndTacks MC - totalPrice.

d) Aggregation function: - select Average.
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e) Then click OK.

3) Press Ctrl-S to save your work.

- Measures
Work with the measures For this cube, Measures are calculations based on a metric, key, counker, or stopwatch,

Measure | Source Mekric | Aggregation Funckion

i [=T-
[iiAverage Order Price [ okalPrice Average

___k. Inthe Dimensional Model, add a measure for sum of order price.
1) In the navigation view, click ClipsAndTacks MC Cube
2) In the Measures table, click New ...
a) Name :- Sum Order Price
b)ID  :- Sum_Order_Price
¢) Source metric - Click Browse..., then select ClipsAndTacks MC - totalPrice.
d) Aggregation function — select Sum.
e) Then click OK.
3) Press Ctrl-S to save your work.
___|. In the Dimensional Model, add a measure for order count.
1) In the navigation view, click ClipsAndTacks MC Cube
2) In the Measures table, click New ...
a) Name :- Order Count
b) ID :- Order_Count

¢) Source metric - Click Browse..., then select ClipsAndTacks MC 2>
ClipsAndTacks Key.

d) Aggregation function — select Count.
e) Then click OK.

3) Press Ctrl-S to save your work.

w Measures
Work, with the measures For this cube, Measures are calculations based on a metric, kew, counter, or stopwatch,

Measure | Source Mekric | Agaregation Function [ty
[rEAverage Order Price [0 kokalPrice Average
[ Surn Order Price [ katalPrice Sum
ey icrder Counk = ClipsAndTacks Key Count:
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____21. Inthe dashboards you might like to see the average order price and track that relative to a target.
___a. Create a KPI for the average order price.

1) Click the KPI Model tab.

2) In the navigation view of the KPI Model, right click My KPI Context, then select New - KPI
a) Name :- Average Order Price KPI (Dollars)
b) ID :- Average_Order_Price_KPI__x0028_Dollars_x0029 _

3) Enter these values:
a) Type :- Decimal
b) Select 'Keep track of historical values for this KPI'

c¢) In KPI Target and Ranges, for Target click Detalils..., then change the value to 300,
then click OK

d) In KPI Target and Ranges, for Ranges select Actual value
e) In the Range table,
(1) Click Add
(2) Change the Name to Low Range, and the ID to Low_Range
(3) A row is created in the Range table with a range name Low Range.
(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change the value to 0, and then click
OK.
(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change the value to 300, and then click
OK.

f) Now you have created one range called Low Range. Repeat the above step to
create one more range:

(1) High Range with start value 300 and end value 1000
g) KPI Value — select ‘Base this KPI on a metric and an aggregation function’

h) Under KPI Details, for Monitoring context, click Browse..., then select
‘ClipsAndTacks MC’, then click OK

i) Metric — click Browse..., then select totalPrice, then click OK
j) Aggregation function — select Average.

4) Press Ctrl-S to save your work.
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= KPI Target and Ranges

Specify a karget, which is an exact value For the KPI to achieve, or ranges againsk which ta track the KPI, or bath,

Target: 300

Ranges: Actual value Iz‘
F.ange name | Start value | End walue |
= Low Range 0 < 300
= High Range 300 = 1000

= KPI Definition
Specify how the value of the KPI is set,

KPI ¥alue
Choose how the KPT will et its walue:

{2 EBase this KPI on a metric and an aggregation funckion,

) Write an expression to calculate this KPI based on existing KPIs

KPPl Details

Monitoring context: . ClipsAndTacks RC
PMetric: + botalPrice
Aggreqation function: *I-m E

___22. (Optional) To demonstrate the use of a counter, you can optionally use this section to create a
counter which will be incremented if you ship the order (versus canceling the order). For every
monitoring context, this counter will either be zero or one depending on whether the order is
cancelled or shipped. Counters would be more useful in other scenarios — perhaps to count the
number of times an iterated activity is executed.

__a. Inthe Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >
Counter. Enter these values:

1) Name :- Ship Counter
2)ID :- Ship_Counter

3) For Counter Controls, click Add, then select ClipsAndTacks MC - Ship Order to
Customer Trigger, click OK

4) Note that the Resulting Action defaults to Add One, which is correct.

___b. Press Ctrl-S to save your work
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* Counter Details
Edit the details af the counter, which counts the number of occurrences of some situation or event,

j(xR  Ship_Counker

Mame: Ship Counter

Descripkion: ;I

O This counter can be used for sorting

* Counter Controls
Specify what causes the counter ko change and what ackion is taken,

Trigger | Inbound Exvent | Resulting Ackion |
?5=:€>Shi|:u Order to Customer Trigger Add Cne

23. (Optional) ) To demonstrate the use of a stopwatch, you can optionally use this section to create a
timer which will measure the duration of the monitoring context. You might find this useful in the
dashboard instances view to quickly see which monitoring contexts have not been terminated.

__a. Inthe model navigation view, right click ClipsAndTacks MC, then select New - Stopwatch.
Enter these values:

1) Name :- Monitoring Context Timer
2)ID :- Monitoring_Context_Timer

3) For Stopwatch Controls, click Add, then select ClipsAndTacks MC - New Order Trigger
and then click OK.

4) Note that the default Resulting Action is Start

5) For Stopwatch Controls, click Add, then select ClipsAndTacks MC - Ship Order to
Customer Trigger and then click OK.

6) Note that the default Resulting Action is Start, but you need to change it to Stop for this
trigger. So click the second row in column Resulting Action. A drop down box is shown, so
pick Stop in the list.

7) For Stopwatch Controls, click Add, then select ClipsAndTacks MC - Cancel Trigger and
then click OK.

8) Note that the default Resulting Action is Start, but you need to change it to Stop for this
trigger. So click the second row in column Resulting Action. A drop down box is shown, so
pick Stop in the list.

___b. Press Ctrl-S to save your work.
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w Stopwatch Details

Edit the details of the stoowatch, which keeps track of elapsed time, IF an accumolating stopwatch is given
bwo or more stark and skop times, the durations are added together to produce an accumulated time.

IC: | Monitoring_Conkext_Timer

Mame: Monitoring Conkext Timer

Descripkion: ;I

[ This stopwatch is an accumulating stopwatch
[ This stopwatch can be used for sorking

+ Stopwatch Controls
Specify what causes the stopwatch ko change and what action is kaken,

Trigger [ Inbound Event | Resulting Ackion
55=:'>New Crder Trigger Skark
?5=:'t>5hip Crder to Cuskomer Trigoer Skop
:*=:=> Cancel Trigger Skop

24. Create a business situation event when the number of declined orders is greater than or equal to 3.
You will use the built-in event definition ActionServicesEvent. This event contains a field called
BusinessSituationName which is a required field for the outbound situation event. You will create a
KPI that will track the total number of declined orders. Then you will create a trigger which is fired
when the number of declined orders is greater than or equal to 3. Then you will define an outbound
event which is fired by the trigger. In this outbound event, you will provide a value for the field
BusinessSituationName which will be used later when configuring action manager in the server
administrative console.

___a. Create a KPI for declined orders.

1) Click the KPI Model tab for the ClipsAndTacks model.

2) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name — Declined Order KPI
b) ID - Declined_Order_KPI

3) Enter these values:
a) Type — Decimal
b) Select 'Keep track of historical values for this KPI'

c¢) In KPI Target and Ranges, for Target click Detalils..., then change the value to 3,
then click OK

d) In KPI Target and Ranges, for Ranges select Actual value
e) In the Range table,

(1) Click Add
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(2) Change the Name to Low Range, and the ID to Low_Range

(3) Arow is created in the Range table with a range name Low Range.

(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change the value to 0, and then click
OK.

(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change the value to 3, and then click
OK.

f) Now you have created one range called Low Range. Repeat the above step to
create one more range:

(1) High Range with start value 3 and end value 10
g) KPI Value — select 'Base this KPI on a metric and an aggregation function.’

h) Under KPI Details, for Monitoring context, click Browse..., then select
'ClipsAndTacks MC', then click OK

i) Metric — click Browse..., then select 'ClipsAndTacks Key', then click OK

i) Aggregation function — select Count.

k) In the Data Filter section for this KPI, click Add

) In the dialog, navigate to ClipsAndTacks MC > Order Status, then click OK

m) In the row containing metric Order Status, make sure the operation defaults to
‘equals'. Also, click the cell in the column Values, then enter this text (with
guotation marks):

'Cancelled’

4) Press Ctrl-S to save your work.
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w KPI Definition
Specify how the value of the KPT is set,

KPI ¥alue
Choose how the KPT will get its walue:
() EBase this KPI on a metric and an aggregation function,
(O Write an expression ko calculate this KPI based on existing KPIs

KPI Details

Manitoring conkext: | ClipsAndTacks MC

Metric: « ClipsandTacks Key

Aggreqgation Function: *|C0unt

Use values From: & all model versions ) Only this version of the modsl

Time Filter
Select a time period over which the KPT should be calculated,

-
Time period;

{® Mone O Repeating Q Roling O Fixed

Data Filter

Select the metrics that wou wank to use to determine what values to use in the caloulation, For example, i wou hawve a KPI called Average Price in London,
wou only want ko use maonikoring contexts where the value of the Ciky metric is Londaon,

Metric | Cperakar |\p'a|ues | Case-sensitive |
A Order Skakus equals =+-3Y ‘Cancellad

___b. Create a trigger to fire the outbound situation event.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New >
Trigger

a) Name — Declined Order Trigger
b) ID - Declined_Order_Trigger
2) Enter these values:
a) Under Trigger Sources, click Add.
b) Select Recurring wait time, then click OK
¢) In the Source column you see the default wait time is 1 minute.
d) In Trigger Condition, enter this text:
Declined_Order_KPI >=3

3) Press Ctrl-S to save your work.
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w Trigger Details
Edit: the details of the trigger, which detects an occurrence and initiabes an ackion in response,

(o} « Declined_Order_Trigger
Tame: Declined Crder Trigger
Descripkion:

O Trigger is repeatable

= Trigger Sources
Specify the source of this trigger.

Source Type | Source
Recurring vaaik time it 0 davs 0 hours 1 minukes

+ Trigger Condition
Specify the condition that determines whether the trigger will Fire,

Declined_Order _KPL == 3

___c. Create an outbound situation event for declined orders.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New >
Outbound Event

a) Name — Declined Order Outbound Event
b) ID - Declined_Order_Outbound_Event
c¢) Select 'Configure this event to generate an alert in the dashboards'

d) For trigger, click Browse..., then select My KPI Context > Declined Order Trigger,
then click OK

2) Enter these values:
a) Notice that the extension name defaults to ActionServicesEvent
b) In the Outbound Event Content table, expand Declined Order Trigger, expand
Extended Data, then on the same row as BusinessSituationName, set Expression
to (include the quotation marks):

'Too many orders have been declined'

3) Press Ctrl-S to save your work.
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* Outhound Event Details
Edit the details of the outhound event, which is sent by the monitaring conkesxt, The bvpe must be an event definition,

(o} « Declined_Order_Outbound_Ewent

Mame: Declined Srder Outbound Event

Description: d

[~

w Event Type Details

Specify the event bvpe or the XML schemas that kogether describe the skructure of this outbound event, You can
specify an extension name, event parts, or both,

Extension name: | ActionServicesEvent Browse. .. | | Clear

Event parts: s} | mame | Type | Path

w Dutbound Event Content

Specify the triggers that cause the event to be sent, Use the Expression column bo specify the value for each event
attribuke when the event is sent,

Mame Type Expression

B = Declined Order Trigger
L.?_:. Property Data
=] lE Extended Data
[ BusinessSituationMame A~ string ﬁv 'Too many orders have been declined'

____25. Create a business situation event when the order fulfillment duration is greater than 3 days. First
you will create an event definition for the outbound situation event. You will create a field called
BusinessSituationName which is a required field for the outbound situation event, and you will
create another field for the average order processing time which will eventually be placed into the
alert body. You do not need to create a KPI since there is already a KPI containing the average
processing time. You will create a trigger which is fired when the average processing time is greater
than 3 days. Then you will define an outbound event which is fired by the trigger. In this outbound
event, you will provide a value for the field BusinessSituationName which will be used later when
configuring action manager in the server administrative console, and you will populate the field on
the event containing the average order processing time.

__a. Create an event definition for average order processing time.
1) In Project Explorer, right click ClipsAndTacks and select New > Event Definition...(cbe)
2) For file name, enter LateAverageOrderShippedEvent.cbe
3) Click Finish
4) The Event Definition Editor for LateAverageOrderShippedEvent opens.

5) Double click the hierarchical icon next to the label Parent.
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6) On the Select Event Definition Dialog double click event.

7) Event is now shown as the parent of LateAverageOrderShippedEvent

8) On the event definition, click the icon for Add Extended Data +_ This adds a row to the
Extended Data table.

9) For the new data element, change the Extended Data name from 'datal’ to
'‘BusinessSituationName' by clicking on datal and typing the new name.

10) For the new element, change the type to string. Do this by clicking on 'noValue' and then
you are given a drop down box.

11) On the event definition, click the icon for Add Extended Data. This adds a second row to
the Extended Data table.

12) For the second data element, change the Extended Data name to
AverageOrderProcessingTime

13) For the second element, change the type to string.

14) Press Ctrl-S to save your work.

Tame® LatedverageCrdershippedEvent
Parent*® event
Property
Extended Data Type
BusinessSituationMarne skring
AverageCrderProcessingTime skring

___b. Create a trigger to fire the outbound situation event.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New >
Trigger

a) Name — Order Fulfillment Timer Trigger
b) ID - Order_Fulfillment_Timer_Trigger
2) Enter these values:
a) Under Trigger Sources, click Add.
b) Select Recurring wait time, then click OK
¢) In the Source column you see the default wait time is one minute.
d) In Trigger Condition, enter this text:

Average_Order_Fulfillment_KPI_August_2006 ge dayTimeDuration
('P3DT1H")

3) Press Ctrl-S to save your work.

2010 April, 20 IBM WebSphere Business Monitor 7.0 — Lab exercise Page 52 of 69

ClipsAndTacks (XSD event definitions)



© Copyright IBM Corporation 2010. All rights reserved

+ Trigger Details
Edit the details of the trigger, which detects an occurrence and initiakes an action in response,

(s} « Crder _Fulfillment_Timer_Trigger
Marne; Order Fulfillment Timer Trigger
Description:

O Trigger is repeatable

+ Trigger Sources
Specify the source of this trigger,

Source Type | Source
Recurring wait tine L) 0 davs 0 hours 1 minukes

w Trigger Condition
Specify the condition that determines whether the trigger will fire,

Average_Order_Fulfillment_KPI_August_2006 ge dayTimeDurationP30T1H)

___c. Create an outbound situation event for average order processing time.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New >
Outbound Event

a) Name — Order Fulfillment Outbound Event
b) ID - Order_Fulfillment_Outbound_Event
c¢) Select 'Configure this event to generate an alert in the dashboards'

d) For trigger, click Browse..., then select My KPI Context > Order Fulfillment Timer
Trigger, then click OK

2) Enter these values:

a) For extension name, click Browse..., then select ClipsAndTacks >

LateAverageOrderShippedEvent.che > LateAverageOrderShippedEvent, then click
OK

b) In the Outbound Event Content table, expand Order Fulfillment Timer Trigger,
expand Extended Data, then on the same row as BusinessSituationName, set
Expression to (include the quotation marks):

'‘Average shipment is too late'
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c) In the Outbound Event Content table, on the same row as
AverageOrderProcessingTime, set Expression to:

xs:string(Average_Order_Fulfillment_KPI_August_2006 div
xs:dayTimeDuration('P1D"))

Note: This results in a time unit of days, since you are dividing the order fulfillment duration by a constant
duration of one day.

3) Press Ctrl-S to save your work.

* Outhound Event Details

Edit the details of the outhound event, which is sent by the monitaring conkesxt, The bvpe must be an event definition,

(s} « Crder _Fulfillment_outbound_Ewent

Marme: Order Fulfillnent Outbound Event

Descripkion: ;I
=

+ Event Type Details

Specify the event bvpe or the “ML schemas that together describe the structure of this outbound event, ¥ou can specify
an extension name, event parts, or bath,

Extension name: |LatedwverageCrderShippedEvent

Ewent parts: s} | marne | Type [ Path

* Outbound Event Content

Specify the triggers that cause the event to be sent,

|Jse the Expression colunin ko specify the value For each event
attribute when the event is sent.

Tarme Type Expression

ot Fulfillment Timer Trigger

L= Property Data

= & Extended Data
&= BusinesssituationMame A-'string o' 'Awverage shipment is koo lake’
E‘é'- AverageCrderProcessing A skring

X,

X$Y xsstringlAverage_Order _Fulfillment_KPI_August_2006 div xs:0

26. Check for any errors in the Problems view. You should resolve any errors before continuing.
Warnings and informational messages may be present but these will not be a problem.
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Part 2: Publish the model to the server

In this section you will use Rational Application Developer or WebSphere Integration Developer to publish the
monitor model to the monitor server.

27. In Project Explorer, expand ClipsAndTacks - Monitor models - ClipsAndTacks.mm. Right
click over ClipsAndTacks.mm and then select Generate Monitor JEE Projects from the pop-up
menu

28. Select Finish.

29. A progress dialog shows the status of the operation and it closes when the operation is complete.
Check for errors in the Problems view. There may be warnings, but there should not be any errors. If
you see errors, then try to perform a clean to see if the errors can be removed: Project > Clean... >
select 'Clean all projects', then click OK.

30. Click the Servers tab, then right click and select the Start option to start the server WebSphere
Business Monitor Server v7.0. This may take a few minutes to complete.

(E.'._u Monitating Flow I/E Froperties ﬂ_;_ Problems |/$?$ Servers £3 Server Lngs\l E Ennsnle\l & Progress\l

Server - | State | Skakus
E& web3phere Business Monitor Server +7.0 on Web3phere Process Server E‘p Skarked Synchronized
Wweb3phere Process Server w7.0 at localhost E!@ Stopped

31. Right click in the servers view, then select Add and Remove Projects....

32. Click Add to move the ClipsAndTacksApplication from the list of available projects to the list of
configured projects.

4= Add and Remove Projects x|

Add and Remove Projects "

Madify the projects that are configured on the server

Maowve projects ko the right to configure them on the server

Available projects: Configured projects:

Add = |
= Remove |

(A ClipsandTacksapplication

Add Al = |
<« Remove Al |

(7) < Back Mext = | Finish I Cancel
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Click Finish.

A progress message is displayed in the lower right corner of the window.

J Publishing ko WebSph......: (14%) [l (N

35. Check the messages in the console view. You should see the following message when the

application has been started:
Application started: ClipsAndTacksApplication

36. Inthe servers view, right click, then select Administration > Run administrative console. You
should see it open in a separate tab.

37. It will prompt you for user ID and password. Enter '‘admin' without the quotation marks for user ID,
then enter 'admin' without the quotation marks for password. Click Log in

38. Click Applications > Monitor Models. The application should show green status if it started
successfully.

Monitor Models w

Monitor Models

Use this page to manage all versions of monitor models and their associated applications. To start or stop a version of a manitor model, you must start or stop
the associated application. All models are initially added to the root resource group and may not be visible by its intended dashboard users, Use the Monitar
data security panel to assign permission to the models,

Preferences

Start || Stop || Install

el

Select| Model & Warsion Deployment & | Application & Data Security | Status &

I ClipsandTacks 2007-12- oK ClipsandTacksapplication Members L4
07T12:16:40 assigned

| GlobalHTrM 2007 -06- Ok IBM WEM HUMAN TASK MONITOR MODEL | Members E
18709:54:38 assigned

- =lakal Drarace Manitar pelulnln i by [nl's TR WEM S ARAL DROCECSS MAORTTOR Marmbare -]

39. If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the

40.

41.

right of Status in the last column of the table. You should see green (started) for the model. If it does
not show green, be patient and keep refreshing until it does show green.

Check the server log to ensure there are no problems. You can check this in the console view.

If you are using the integrated server within WebSphere Integration Developer or Rational
Application Developer, then you do not need to setup Monitor data security, since the administrative
user is automatically authorized to all models. If you are using a different server, then you should
open the administrative console, navigate to Security > Monitor Data Security, then add the
model, role and user information to a resource group.
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Part 3: Configure action manager for business situation events

This section shows you how to configure action manager to create alerts based on business situation
events defined in the monitor model. The alerts will be visible in the Alert view on your dashboard.

You do not need an LDAP server to test the situation events. When you configure the notification template,
you can specify a dashboard login rather than a user registry.

In this section, you will use the administrative console to configure the alerts. However, you could also
create business user alerts using the Alert Manager widget in the dashboard. In a production environment,
an end user could use the alert manager widget to manage the business user alerts, however, an IT
administrator would manage the modeled alerts in the administrative console.

1. Verify the federated repository service provider URL.

__a. Inthe administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Configuration > Federated Repositories.

b. In the Service provider URL field, type the URL of the federated repositories server that is used
to connect to the user registry. For a stand-alone server, this value might be | ocal host : 2809.
For a network deployment environment, this field must be set to the deployment manager host
name plus the deployment manager BOOTSTRAP_ADDRESS port (separated by a colon). To
determine the bootstrap port, in the WebSphere Application Server administrative console, click
Servers > Server Types > WebSphere application servers > serverl. Under Communications,
click Ports.

__c. To save the settings you entered, click Apply or OK.
___d. To make these changes effective, stop and restart the WebSphere Business Monitor server.
2. Add a template for declined order alerts.

___a. In the administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Template Definitions > Notifications

___b. Click New.

___c. Enter AlertDeclined as Template name and a description.
___d. Select Dashboard Alert.

___e. Select User id.

__f. For the To field, enter admin. This ‘User id’ is the one that will receive the alert, so you should log
into the dashboard with this ‘User id'.

Note: The user admin is the default username configured for Monitor Test Environment profile
___g. Enter a subject.

___h. Enter the body.
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* Template name
[alertDedined

Description

Default action service type

% Dashboard &lert
= cell phone

" Email

" pager

"To' query type

" Federated repositories query
i LDAP query

" Email address

& User id

To
[admin

Query base

Subject
Declined Orders |:|

Body
Too many orders have been declined | |:|

__i. Click OK.
3. Add a template for order processing time alerts.

__a. Inthe administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Template Definitions > Notifications

___b. Click New.

___c. Enter AlertLate as Template name and a description.
___d. Select Dashboard Alert

___e. Select User id

___f. For the To field, enter admin. This ‘User id’ is the one that will receive the alert, so you should log
into the dashboard with this ‘User id'.

Note: The user admin is the default username configured for Monitor Test Environment profile

___ 0. Enter a subject.

2010 April, 20 IBM WebSphere Business Monitor 7.0 — Lab exercise Page 58 of 69

ClipsAndTacks (XSD event definitions)



© Copyright IBM Corporation 2010. All rights reserved

___h. Enter the body, and you may optionally enter a substitution variable as shown below. For the
actual alert that is sent, the average order processing time from the event payload will be
substituted for %AverageOrderProcessingTime% in the body. For example:

The average order processing time is %AverageOrderProcessingTime% days.

#* Template name
[alertlate

Description

Default action service type

@ Dashboard alert
= Cell phone

" Email

i pager

'To' query type

" Federated repositories query
 LDAP query

" Email address

& Userid

To
[admin

Query base

Subject
Order processing time |:|

Body

The average order processing time is % |:|
AverageOrderProcessingTime® days |

__i. Click OK.
4. Add the binding from the situation event to the action type for declined orders.

___a. Inthe admin console, navigate to Applications > Monitor Services > Monitor Action Services
> Installed Situation Event Bindings

___b. Click New.

__c. Enter the situation event name that you defined in the model. In this lab, you created a business
situation name as follows:

Too many orders have been declined
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Mew Situation Event Binding

General Properties

# Situation event name

Too many orders have been

Description

Ceclined orders |:|

]
Appll,'l ﬂ Reset| Cancel |

___d. This should match exactly the value in the BusinessSituationName field in the outbound event.

You may want to copy/paste from the model. Here is a screen capture from the model showing
the Declined Order Outbound Event:

w Dutbound Event Details

Edit the details of the outbound event, which is sent by the monitoring context, The type must be an event definition.

10: 4 Declined_Order_Outbound_Event

Mame: Declined Order Sutbound Event

Descripkion:

=

w Event Type Details
Specify the event type or the XML schemas that together describe the struckure of this outbound event, You can

specify an extension name, event parts, or both,
Extension name: |ActionServicesEvent Browse, Clear

Event parts: D | Marme | Type I Path

1 | »

w Dutbound Event Content

Specify the kriggers that cause the event ko be sent, Use the Expression column to specify the value for each event
attribute when the event is sent,

Mame Type

Expression

"= Property Data
=l &= Extended Data

[&= BusinessSituationtame A~ string X$Y ‘Too many orders hawve been dedlined'

___e. Enter a description, then click Apply.

__f. Click Add.
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___g. Enter a binding name, then select the template AlertDeclined

Add termplate to situation event binding

General Properties

#* Binding narme

Cecined

Ce=scription

[ [

Categaory

Ternplate name
Iﬂler‘tDeclined ;I

Reset | Cancel

Apply |

__h. Click OK.

___i. Notice that you now have one action defined for this situation event. If you had other action
templates defined then you could add more actions to this event. So then you could send a
notification for this situation to multiple destinations including e-mail, alerts and Web services.

General Properties

* Situation event narne

|Tnn riany orders have been

Cescription

Declined orders I:'
=
Apply | ﬂ Reset| Cancel |

Preferences

Add| Rerove |

ElwlE

Select| Binding Mame

s
e

s
e

s
et

s

Termplate Mame o

Categary Mame Ackion Service Type

|— Decdined AlertDeclined AlertHandler

Total 1

__J- Click OK.
5. Add the binding from the situation event to the action type for order processing time.

___a. Inthe admin console, navigate to Applications > Monitor Services > Monitor Action Services
> Installed Situation Event Bindings

___b. Click New.
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___c. Enter the situation event name that you defined in the model. In this lab, you created a business
situation name as follows:

Average shipment is too late

___d.. This should match exactly the value in the BusinessSituationName field in the outbound event.
You may want to copy/paste from the model

___e. Enter a description, then click Apply.

__f. Click Add.

__ 0. Enter a binding name, then select the template AlertLate, then click OK.
__h. Click OK.

6. Inthe admin console, navigate to Applications > Monitor Services > Monitor Action Services >
Installed Situation Event Bindings. You should see two bindings as follows:

Installed Situation Event Bindings

Installed Situation Event Bindings
Use this page to manage situation event bindings.

Freferences

Mew || Delete
Gl

Select| Situation Event Mame Situation Event Description
You can administer the following resources:
[~ | Print 72 hours exceeded

[ || Average shipment is too late
[~ | MTB Failure
[~ | Toomany orders have been declined
[~ | Invalid Loan Application
[ | Eee Compliance &lert
Total &
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Part 4: Run events to exercise the model

Rather than installing a application to actually create the events that you want to monitor, you are going to use
a program to simulate the submission of events from the application. The supplied program is

‘BatchCBEWTiter61’ and it will submit the events to the Common Event Infrastructure. Look for the program in
\Labfiles70\BatchCBEWriter. This program reads XML files which represent the Common Base Events for the

model.

1. Update BatchCBEWr riter61.bat to point WAS_HOME to the monitor server home, for example ‘set
WAS_HOME=C:\IBM\WebSphere\MonServer'. If you are using the integrated monitor server in
WebSphere Integration Developer, the path would be <WID_WTE_HOME>\runtimes\bi_v7. If you
are using the integrated monitor server in Rational Application Developer, the path would be
<RAD_WTE_HOME>\runtimes\base_v7.

2. Update config.properties, setting the serverName and portNumber. You can find the port number by
browsing the server log and finding ‘bootstrap port’. For example, check for the log at
C:\IBM\WebSphere\MonServer\profiles\WBMon01\logs\server1\SystemOut.log. For the integrated
server in WebSphere Integration Developer, the path would be
<WID_WTE_HOME>\runtimes\bi_v7\profiles\gmwps\logs\server1\SystemOut.log. For the integrated
server in Rational Application Developer, the path would be
<RAD_WTE_HOME>\runtimes\base_v7\profiles\WBMonSrwlogs\serverl\SystemOut.log. Here is an
example of the config.properties settings:

__a.connect.serverNane = | ocal host
___b.connect. port Nunber = 2809
3. Open a command window, then change directory to the folder containing BatchCBEWTriter61, for
example, type this command
___a. cd\Labfiles70\BatchCBEWTriter
__ 4. Runcommands to load the common base events to the server.
___a. batchchewriter61 -Dsource.filename=allXSDevents.xml
___b. Enter the user and password for the server.

5. When you run BatchCBEWriter61, you should see results such as:

2010 April, 20 IBM WebSphere Business Monitor 7.0 — Lab exercise Page 63 of 69

ClipsAndTacks (XSD event definitions)



© Copyright IBM Corporation 2010. All rights reserved

mmand Prompt

C:\Labfiles70\BatchCEEWriter>batchcbewritertl -Dsource.filename=allxSDewvents.xml

Getting CBEs.

Getting Emitter.

Removing GlobalInstanceIds.
Setting missing values.
Changing Instance Ids.
Updating timestamps.
wvalidating CBEs.

Sending CBEs.
START=18:40:03.671

Sending cbe[10].

Sending cbe[20].

Sending cbe[30].

Sending cbe[40].

Sending cbe[50].

Sending cbe[60].
END=18:40:07.140
TotalTime=3469 milliseconds.

C:\Labfiles70\BatchCBEWriter:>
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Part 5: Create a dashboard

In this section you will configure a dashboard in business space.
1. Create the dashboard.

__a. The default browser is 'Internal Web Browser', but you should not use this one since some
standard functions are not provided that you may need. Select Window > Preferences > General
> Web browser > select 'Use external Web browser'. Select an external browser. Click OK.

___b. InWebSphere Integration Developer, in the servers view, right click and select Launch >
Business Space

___¢. When prompted, enter admin for the user ID and enter admin for the password. You must log in
with 'admin’ so that you can view the alerts which were setup in action manager to be sent to this
particular user ID. Also, in the toolkit environment, this is the user that is automatically defined on
the secured server.

___d. Click in the Actions menu to create a new space

Haorme (50 5 g 1 Actions
5 - Create Space..
1 Welcome to Business Spa Emmpacesemﬁ,_._

Getting Started -

Setas Home

Manage Templates

==

[ T
__e. Enter a name such as Dashboard, and select the Business Monitoring template.

Create Space

*= Bpace name:
Dashhoard|

Space description:

% Create anew space using a template

| Business Monitoring i

__f. Click Save.

Home

Operational KPls Expoart Values Alert Manager KPI Manager
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___g. On the new space, click the Operational tab.
2. Use the Alerts widget to view the alerts.

___a. On this page, you see the Alerts widget, and you should see alerts listed since the model
processed 3 or more cancelled orders, and the average order processing time is greater than 3

days.
Alerts
| Mark Read | | Mark Unread | | Forward Alert | | Remove
Subject Date and Time
s Crderprocessing time December 7, 2009 10:53:16 Ak
s Declined Orders December 7, 2009 10:53:16 Ak
Foa ramanliancra | aan 0017790 hMrvarahar1& 000 AE2- A0 Phd

___b. You can click on an alert in the list, then you will see a pop-up showing the details of the alert.

Subject Dal
Orderprc%essingtime Del
Declined COrders Ten
B3 ®
Fee compliance December 7, 2009 10:53:16 AM ™
= Subject
Fee campliance o o
Cirder processing time
Fee campliance . , . do

Business situation name

Average shipment is toa late

Comments

The average arder processing time is 4. 346026226351 85 days.

3.  Use the Instances widget to view the monitored instances.

IE'tF'a e¥|

___a. Click the 'Edit Page' link to enter edit mode.

___b. To configure the Instances widget, hover the mouse over the right corner of the widget

{I:']:EI

and then click the down arrow. Select 'Edit Settings...".

j_l. EdltSettmgs
0 Rename...

b

___c. Click the Show/Hide tab, and select monitoring context 'ClipsAndTacks MC'.
- CIipsAndTacks(Acrusg all versions)

Click button >> to move all the fields to the Selected box. Also,
click button 'Set as default which will make this the default monitoring context to display.

___d. Then click OK. You should see a list of monitoring context instances for the events that you just
processed.
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Instances

¥ [ooor |

city ClipsAndTacks Key

Raleigh o2
Mexico 03
City
Raleigh o4
Toronto o4
Raleigh ob
Toronto o7
Mexico o8
City
Raleigh o9
Toronto o100

Raleigh 011

i

COMPLETED

*
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__e. Click 'Finish Editing' to save your changes and close the edit menus.

2010 April, 20

country
IISA

Mexico

LISA

Canada

LISA

Canada

Mexico

LISA

Canada

LISA

CreationTime

December T, s
2009 10:53:03 A
December T,
2009 10:53:03 A
December T,
2009 10:53:03 A
December T,
2009 10:53:03 A
December T, s
2009 10:53:03 A
December T, s
2009 10:53:03 A
December T,
2009 10:53:03 A
December T,
2009 10:53:03 A
December T,
2009 10:53:03 A

December T, s
2009 10:53:03 A

a1m, 37 s

a1m, 37 s

a1m, 37 s

a1m, 37 s

a1m, 37 s

a1m, 37 s
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Monitoring Context Timer Orde

Al
4:14

Al
*20
Al
4:14

Al
320

o

W Fivish Edting |
o
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What you did in this exercise

In the lab, you created a monitor model using Rational Application Developer or WebSphere Integration
Developer.

Then you published the model to the monitor server.
You also configured action manager to create alerts based on business situation events.
You used the supplied program to simulate the submission of events from the monitored application.

You configured dashboards and viewed monitored data.
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Appendix 1 — Import the solution into the monitor model editor

A solution has been provided so that you do not have to build the model from scratch. This section shows you
how to import the project interchange file into Rational Application Developer or WebSphere Integration
Developer. After importing the project then you can proceed to the section to publish the model to the server.

1. Start Rational Application Developer or WebSphere Integration Developer and setup the

environment.

__a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted
point to a new workspace such as C:\workspaces\ClipsAndTacksXSD

___b. Close the Welcome tab

__c. By default, you are in the Business Integration perspective. Open the Business Monitoring
perspective. Select Window > Open Perspective > Other > Show all > Business Monitoring.

___d. Ifit asks you to Confirm Enablement, then click OK.

2. Import the project interchange file.

___a. Right click in the Project Explorer view, and then select Import...

___b. Select Other > Project interchange, click Next.

___c. Browse to the location containing the files, for example, C:\Labfiles70\ClipsAndTacksXSD
__d. Select ClipsAndTacksXSD_Solution_Pl.zip

___e. Click Select All

___f. Click Finish.

3. Expand the project in the Project Explorer view, then expand the Event Definitions and you will see

the new events listed. Expand Monitor Models and you will see the new ClipsAndTacks model
listed.

4. Now you may proceed to the section to publish the model to the server.
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