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Samples preparation wizard

This session discusses the sample applications that are provided with the Message Broker 
product. There are a significant number of samples, and this presentation has attempted 
to provide examples of many of the common functions that you are likely to require in your 
own Broker applications. These applications are intended to be complete in their own right, 
but also that they can be easily extended to suit your own requirements.
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Agenda

�Overview

� Toolkit Launch Points

�Wizard Demonstration

�Wizard Activities

�Debugging

This session will look at the key requirements for these samples, how to launch them, and 
how to debug them in the event of problems.
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Overview

Samples Preparation Wizard objectives
�This Eclipse wizard provides a method for manipulating samples, 

allowing you to import, deploy and remove samples in an automated 
“one-click” fashion. 

Possible tasks performed by the wizard
�Import a sample to the workspace in one step

�Import to the workspace and deploy a sample to the broker in one
step

�Remove a sample from the broker, but leave it in the workspace

�Remove a sample from the broker and from the workspace, leaving 
the system in a state as if the sample had never been imported

The samples are provided through the Message Broker Toolkit, and are intended to be 
installed in a single “one-click” operation.

The process can be simply an installation of the message flows and message sets to the 
Toolkit, or can include a full deployment to the broker created by the Default 
Configuration Wizard as well. In the latter case, this will include the automated 
definition of all required MQ queues and databases.

The samples can also be removed from the system. Again, this can just be restricted to 
the runtime components, or can include removal from the Toolkit workspace. Note that 
most of the samples create their own runtime execution group. Since all execution 
groups are started up automatically when the Broker starts, deployment of all samples 
can result in a large overhead because of a large number of execution groups. This will 
use a significant amount of memory, so you should plan to use the samples carefully. If 
you need to have several samples available in the runtime broker, it may be worth 
considering redeploying the sample bar files to a single execution group. Deployment 
will be discussed in a later lecture.
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Launch points

Samples Preparation Wizard can be launched from within Message 
Broker Toolkit from:
�Samples Gallery

�Accessed from Welcome page (Toolkit menu option: Help->Samples 
Gallery)

�Accessed from Help Information Center (Toolkit menu option: Help->Help 
Contents)

�New wizard dialog

�Located under the category 'Broker Administration - Getting Started‘
(Toolkit key stroke 'Alt+Shift+N' followed by menu option 'Other‘).

�Default Configuration Wizard (option on the final page)

�Live Help Extension

�The wizard adopts this interface so it can be used as live help extension. 
When a user clicks on a live help link in a help document, the wizard will be 
launched.

There are a number of places where the installation of the Samples can be launched from. 
The most common launch point is the “Samples Gallery”, which is opened directly from 
the Broker Toolkit. Use the Toolkit menu option “Help”, and select “Samples Gallery”. 

Alternative ways of opening the Samples are from the Information Center, and from other 
options in the Toolkit, as shown. Finally, there are a number of places in the Toolkit 
Help documentation where live links to the samples are provided.
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This slide shows the Message Broker Welcome Page, immediately after installation of the 
Toolkit on a Windows® platform. If you hover your mouse over the various icons, you will 
see that one of them will take you straight to the Sample Gallery, as shown here.
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Clicking on the Samples icon will take you to this screen. Here you can install two very 
simple applications, the Pager and the Scribble applications, which will verify the Broker 
installation.

The Application and Technology samples contain the more sophisticated types of Broker 
applications, and are used to illustrate various application techniques.
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Clicking on “Pager samples” will take you to this screen. Here, you can set up the Pager 
sample, and run the Pager sample from a script. This sample will serve as an installation 
verification check for the Message Broker.

After running this sample, you should remove it from the workspace and the runtime 
broker.
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This slide shows the home screen in the Information Center. As mentioned earlier, you will 
see that you can access the samples from here.
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If you click on “Explore the Samples” in the Information Center, you will be taken to this 
screen. From here, you can get details of each of the samples.
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This screen shows how to access the samples from the Broker Toolkit, by selecting “File, 
New, Other” on the main menu. Selecting “Other” will take you to the wizard shown on the 
next slide.
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Select “Prepare the Samples” from this wizard, which will take you through a simple 
sequence of panels where you can select the sample to install, and whether you want to 
deploy this to the runtime broker.
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Samples wizard

� The collection of pages displayed by the wizard is dependant upon the 
state of the local environment at time of launch and launch point used

� This wizard is always enabled, if launched from File->New. You can 
always import a sample into the Toolkit’s workspace

� Pages from the default configuration wizard are embedded into this 
wizard and used, if a default configuration is not present in the 
environment

� The wizard will only offer these pages with the “Create the Default 
Configuration” option if:
�On Windows: The account under which the wizard is invoked is a member of the 

Administrators group. Note: The account is automatically added to the ‘mqm’ and 
‘mqbrkrs’ groups

�Linux®:  One or more instances of DB2® are available. Note: The creation of a default 
configuration is halted If on examination of the account, it is not a member of ‘mqm’
and ‘mqbrkrs’

� A sample’s removal activities simply roll-back its import activities

The operation of the wizard is dependent on the local environment in which it is invoked. It 
will always be possible to import a sample into the Toolkit workspace. If the sample is 
already present, then it can be over-written by the installation process. 

The Samples require the Default Configuration to be present. Therefore, if this is not 
present, installation of any particular sample will automatically start the creation of the 
Default Configuration. If this is required, the user account which invoked this process 
must have certain privileges. On Windows, it must be a member of the Administrators 
group, in addition to having the normal MQ and Broker authorizations. On Linux, the 
process further requires that an instance of DB2 is available.
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Select the pager sample

As an example, the next few slides show how the Pager Sample would be installed and 
deployed to the Broker.

Selecting the Pager Sample, and clicking on “Import and Deploy” is shown on this screen. 
Now click Next.
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Pager sample
status page

This screen shows the artifacts that will be created when the Pager Sample is installed 
and deployed. Here, you see that a number of MQ queues will be created, a message set 
and a message flow will be imported into the Toolkit workspace, and a broker execution 
group will be created. The pager sample will be deployed to this execution group.
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Pager sample creation status messages

This screen shows the progress of the Pager Sample creation. This process ends 
successfully, and shows the start of the Queue Manager, the Configuration Manager, and 
the Broker. 

It shows the Toolkit connecting to the Configuration Manager, and the creation of the new 
execution group called PagerExecutionGroup. This can be seen in the Domains view, on 
the bottom left hand side of this screen capture.
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Run the pager sample - 1

At the end of the installation process for the Pager Sample, you will be taken to this 
screen, where you can run the sample.  Click on “Run the Pager Sample”, which will take 
you to the next screen.
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Run the pager sample - 2

You have two ways to run the Pager sample. The above screen shows the first of these, 
where a text Messenger application will send a message to a pager device. Click on “Start 
the Text Messenger application”, which will take you to the next screen.
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Run the pager sample - 3

At this point, type some text into the text Messenger window, and click Send. This data will 
be sent to the Broker, and will then be forwarded to the Pager device, simulated by the 
Pager application shown above. 

If the Broker has been installed correctly, you should see the text appear on the Pager 
almost immediately.
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Debugging – relevant documentation

SamplePreparationWizard.log
�This log file contains detailed trace information 

concerning each and every activity performed by the 
Wizard.

�Found in file system under 

�<workspace>\.metadata

�User-specific <workspace> location is outlined in the 
wizard’s summary page, however you can determine this 
by selecting the toolkit menu option:

�File->Switch Workspace…

In case of problems with the creation or removals of the samples, all status is recorded in 
the “SamplePreparationWizard.log” file. This is located in the “.metadata” directory 
under the active workspace. If you do not know where the workspace directory is, you 
can get this from the Toolkit by opening the “Switch Workspace” option , as shown on 
the slide.
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Debugging – how to interpret the documentation

Trace output concerning each activity is provided in the 
following format:
� ++++++++++++++task trace++++++++++++++
� TIMESTAMP [Day Month Date HH:MM:SS BST YYYY]
�

� Activity description as outlined in the summary page
� Statement indicating success or failure of task 
� Collected output from task >
� Stdout: [ All task output written to standard out ]
� Stderr: [ All task output written to standard error ]

To determine the reason behind an activity failure, search 
from the bottom of the log upwards looking for match on 
activity description, where a statement of failure follows.

The log file will have contents similar to that shown on this slide. Information is added to 
the end of this file, so you should always start looking for failure information at the end 
of the file, working backwards until you locate the appropriate error message.
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Debugging – additional information - 1

CommonBaseEvents.log
�This log file contains extra trace information not present in the 

SamplePreparationWizard.log and can be imported and viewed 
through the Log Navigator View.

�Only present if logging switch on prior to using the wizard.

�Select toolkit menu option Windows->Preferences->Capabilities-
>Tester and tick ‘Profiling and Logging’ option. Click ‘OK’ button 
and close dialog.

�Select toolkit menu option Windows->Preferences->Profiling and 
Logging and tick ‘Enable logging’ option. 

�Select toolkit menu option Windows->Preferences->Logging and 
select Loggers tab, then set Logging level to INFO for logger 
named: com.ibm.etools.mft.util. Click ‘OK’ button and close dialog.

�Can also be found in user’s <workspace>\.metadata directory.

Finally, there are two additional sources of information for resolving problems with the 
samples installation. First, the CommonBaseEvents.log file contains additional 
information. Note that this is only used if logging through the Eclipse Toolkit is activated 
prior to using the Samples Wizard. To do this, follow the instructions shown on this 
slide.
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Debugging – additional information - 2

To use tracing in the production environment:
�Copy the file: <installLocation>\evtoolkit\eclipse\plugins\

com.ibm.etools.mft.eou_6.0.0\.options to 
<installLocation>. Same folder as the wmbt.exe file.

�Start the Toolkit in debug mode using the –debug 
option

The .log file may contain:
�Exceptions not written to SamplePreparationWizard.log

�Runtime trace statements used to highlight resource 
bundle failings associated with the EOU plug-in

�Found in user’s <workspace>\.metadata directory

And finally, the “.log” file contains a record of low-level errors that may occur. To invoke 
this, you will need to start the Message Broker Toolkit in debug mode. To do this, you 
must invoke the “wmbt.exe” command with the –debug option. This can be done from 
a Message Broker Command Console, or by changing the properties in the Toolkit icon 
in a Windows environment.
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