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What this exercise is about 

This exercise demonstrates using IBM WebSphere® Integration Developer to update the DB2® Emitter 
source code to customize it to emit specific user defined events using the CEI SDK that will be monitored 
using WebSphere Business Monitor.  You will customize the supplied DB2 emitter source code, export the 
EAR, and deploy the EAR to WebSphere Process Server V6.0.2.  You will configure WebSphere Process 
Server V6.0.2 with a Data Source for the new JDBC Provider, and a scheduler.  Finally you will conduct a 
simple test to see if the events are being emitted.  

Lab requirements 

List of system and software required for the student to complete the lab. 

• WebSphere Integration Developer V6.0.2 

• WebSphere Process Server V6.0.2 or WebSphere Application Server V6.1 with CEI API SDK 

What you should be able to do 

At the end of this lab you should be able to: 

• Use WebSphere Integration Developer to import the DB2 Emitter source with CEI SDK emitter 
transport and perform necessary modifications to it, build the DB2 Emitter project and finally export an 
EAR file for deployment 

• Use the DB2 Command Line Window to create a new database which will be accessed by the DB2 
Emitter Application, run the DDL scripts to create the necessary tables and triggers. 

• Use the WebSphere Process Server administrative console to configure the JDBC Provider, a Data 
source, a cloudscape database for the scheduler and finally the Scheduler itself 

• Use the WebSphere Process Server administrative console to install the EAR 

• Run a simple test to view successful events emitted 

• View the events emitted using the Common Event Browser (CBE Browser) 
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Introduction 

The Sample DB2 Event Emitter is a sample program written in Java™ that demonstrates how an enterprise 
information system (EIS) resource (an IBM DB2 database in this sample) which stores data pertaining to the 
state of a business can be instrumented to contribute to the overall monitoring of the activities of a business. 

The main goal of the Sample DB2 Event Emitter is to introduce the use of the libraries and APIs provided by 
the Common Event Infrastructure (CEI) to generate and emit business events in the form of Common Base 
Events (CBEs).  Common Base Events are the data packaging and format used by the WebSphere Business 
Monitor (WBM) Server to propagate business events. 
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Exercise instructions 

Some instructions in this lab may be Windows® operating-system specific.  If you plan on running the lab on an 
operating-system other than Windows, you will need to run the appropriate commands, and use appropriate 
files (.sh vs. .bat) for your operating system.  The directory locations are specified in the lab instructions using 
symbolic references, as follows: 

Reference variable Windows location AIX®/UNIX® location 

<WID_HOME> C:\WID602  

<WPS_HOME> C:\IBM\WebSphere\ProcServer  

<WPS_PROFILE_DIR> <WPS_HOME>\profiles\<profile_name>  

<LABFILES> C:\Labfiles602 /tmp/Labfiles602 

Important: This LAB does not cover the Customer Order  Monitor Model deployment to the WebSphere 
Business Monitor Server. You should have first hand experience deploying and running a Monitor Model on 
the Monitor Server. 

Important: You can either use WebSphere Process Server V6.0.2 (at times designated as Process Server) or 
a WebSphere Application Server V6.1 with CEI API SDK installed. This LAB uses WebSphere Process Server 
V6.0.2. 

Important:  The source code modification is a demonstration on how the events emitted will be correlated with 
the Monitor Model. Each event to be consumed by WebSphere Business Monitor needs to be matched to the 
Monitor Model. 
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Part 1: Modify code to handle CustomerOrder event u sing the CEI API 
SDK and export the DBEmitter application (EAR) 

____ 1. Start WebSphere Integration Developer, creating a new workspace in the folder C:\ 
C:\LabFiles602\DB2Emitter\workspace , and turn off the auto-build feature 

__ a. The workspace Launcher window will be displayed. Click the Browse…  button and select your 
workspace directory. 

 

__ b. Click OK 

__ c. Close the welcome window by clicking the arrow in the top right corner of the welcome window 

____ 2. Switch to the J2EE perspective and turn off automatic builds 

__ a. By default WebSphere Integration Developer opens in Business Integration  perspective. You 

need to change it to J2EE perspective. To do this click  on the top 
right corner of the WebSphere Integration Developer and choose Other  if J2EE is not listed 
here.  

 

__ b. From the Select Perspective  dialog select J2EE and click OK 
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Note:  Select the Show all check box if J2EE perspective does not show up. 

__ c. Click OK on the confirm enablement warning. 

 

__ d. Select Project > Build Automatically , to turn off automatic builds. 
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____ 3. Import the DB2Emitter  Projects 

In this step, import all DB2 Emitter projects; make necessary build configurations based on the 
intended emitter transport (CEI API). Also import the necessary jars to support CEI API. Following is a 
description of the projects that will be imported (part of the Project Interchange DB2Emitter.zip ): 

• DBEmitter : Project to package artifacts into EAR 

• EmitterFW : Common emitter framework source 

• CEIEmitter : CEI emitter source 

• DBEmitterEJB : DB2 Emitter specific source 

• DBEmitterImpl : DB2 Emitter specific source. Implementation classes specific to retrieving 
and formatting events 
 

__ a. Select File > Import  from the main menu. 

__ b. From the Import  window, select Project Interchange  as the source and click Next  

__ c. The Import Project Interchange Contents  window will be opened. 

__ d. Now click the first Browse…  button and select <LABFILES>\DB2Emitter\DB2Emitter_PI.zip as 
the source .zip file 

 For example: C:\LabFiles602\DB2Emitter\DB2Emitter.zip 
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__ e. Select all the projects and then click Finish  

____ 4. Review the imported artifacts 

__ a. Expand Enterprise Applications, EJB Projects  and Other Projects  to view the projects as 
shown below  

 

__ b. At this time there will be some errors noticed. Click on the Problems tab to view the problems as 
shown below 
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____ 5. Working towards avoiding the build path errors 

__ a. It clearly states that the CEIEmitter project is missing a required library events-client.jar . Import 
it as J2EE Utility JAR by right-clicking on the DBEmitter project from the project explorer as 
shown below 

 

__ b. In the Utility Jar Import  dialog select the type of Import as Copy Utility Jars into an existing 
EAR from an external location as shown below 
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__ c. Click Next  

__ d. In the next dialog click Browse  to locate the events-client.jar  and make sure you select the jar 
as shown below 
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Note: You can find these libraries in WebSphere Process Server or WebSphere Integration Developer as 
follows: 

 <WID_HOME>\runtimes\bi_V6\CEI\client or  

 <WPS_HOME>\CEI\client 

If CEI SDK is not installed on your machine local to the WebSphere Integration Developer, copy the 
necessary libraries from a remote WebSphere Process Server installation.  

__ e. Click Finish  

__ f. In the Project Explorer, right-click on the CEIEmitter project under Other Projects  and select 
properties 

__ g. In the Properties for CEIEmitter  window, select Java Build Path in the left frame, select 
Libraries tab in the right frame 
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__ h. Select the events-client.jar  from the JARs  listed and click the Remove  button to remove build 
path. 

__ i. Now click the Add JARs  button and select the events-client.jar (DBEmitter � events-client.jar) 

 

__ j. Click OK over the JAR Selection pop-up window 

__ k. Now click OK over the Properties for CEIEmitter  window 

__ l. There must not be any errors reflected in the Problems tab at this time 
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____ 6. Now modify the DB2 Emitter specific code.  The sample code that is provided is based on a 
CUSTOMER event to show you how to modify it to handle a different event type, CustomerOrder.  
You will update the CUSTOMERFormatterImpl.java which implements the EventFormatter class 
and the CUSTOMEREventRetrieverImpl.java  which extends AbstractEventRetriever.  

Note: Two text files named CUSTOMEREventRetrieverImpl.txt  and CUSTOMERFormatterImpl.txt  with 
lines of code that are to be modified are under <LABFILES>\DB2Emitter\src. It is easy to copy these lines of 
code and paste at the appropriate location. 

__ a. In the Project Explorer expand Other Projects > DBEmitterImpl > src > 
com.ibm.wbimonitor.samples.db2emitter.formatter and double click on 
CUSTOMERFormatterImpl.java  

__ b. Set an extension name for the CommonBaseEvent that is being returned. Add the line 
event.setExtensionName("CustomerOrder"); after the Event factory is created. 

 

__ c. Search for the following code segment         

   ExtendedDataElement id = event.addExtendedDataElement( "ID" ); 

               id.setValuesAsInt( Integer.parseInt( (String)retrieved ) );  

              And replace them with the following 

                     ExtendedDataElement ordernumber = event.addExtendedDataElement( "OrderNumber" ); 

            ordernumber.setValuesAsInt( Integer.parseInt( (String)retrieved ) ); 

__ d. Search for the following code segment  

   ExtendedDataElement id = event.addExtendedDataElement("ID"); 

   id.setValuesAsInt(((ResultSet) retrieved).getInt("ID")); 

   ExtendedDataElement name = event.addExtendedDataElement("NAME"); 
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   name.setValuesAsString(((ResultSet) retrieved).getString("NAME")); 

   ExtendedDataElement address = event.addExtendedDataElement("ADDRESS"); 

  address.setValuesAsString(((ResultSet) retrieved).getString("ADDRESS")); 

   ExtendedDataElement tel = event.addExtendedDataElement("TEL"); 

   tel.setValuesAsString(((ResultSet) retrieved).getString("TEL")); 

   ExtendedDataElement email = event.addExtendedDataElement("EMAIL"); 

   email.setValuesAsString(((ResultSet) retrieved).getString("EMAIL")); 

     And replace them with the following  

      ExtendedDataElement ordernumber = event.addExtendedDataElement("OrderNumber"); 

      ordernumber.setValuesAsInt(((ResultSet) retrieved).getInt("OrderNumber")); 

     ExtendedDataElement customername = event.addExtendedDataElement("CustomerName"); 

     customername.setValuesAsString(((ResultSet) retrieved).getString("CustomerName")); 

     ExtendedDataElement country = event.addExtendedDataElement("Country"); 

     country.setValuesAsString(((ResultSet) retrieved).getString("Country")); 

     ExtendedDataElement city = event.addExtendedDataElement("City"); 

     city.setValuesAsString(((ResultSet) retrieved).getString("City")); 

    ExtendedDataElement productnumber = event.addExtendedDataElement("ProductNumber"); 

    productnumber.setValuesAsString(((ResultSet) retrieved).getString("ProductNumber")); 

    ExtendedDataElement quantity= event.addExtendedDataElement("Quantity"); 

    quantity.setValuesAsInt(((ResultSet) retrieved).getInt("Quantity")); 

    ExtendedDataElement orderprice= event.addExtendedDataElement("OrderPrice"); 

       orderprice.setValuesAsFloat(((ResultSet) retrieved).getFloat("OrderPrice")); 
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__ e. Save (Ctrl+S)  and close the editor 

__ f. In the Project Explorer expand Other Projects > DBEmitterImpl > src > 
com.ibm.wbimonitor.samples.db2emitter.retriever and double click on 
CUSTOMEREventRetrieverImpl.java  

__ g. Search for the following code segment 

private static String CREATE_EVENT_SQL = "SELECT * FROM CUSTOMER WHERE ID = ?"; 

private static String UPDATE_EVENT_SQL = "SELECT * FROM CUSTOMER WHERE ID = ?"; 

And replace them with the following  

 private static String CREATE_EVENT_SQL = "SELECT * FROM CUSTOMERORDER WHERE     
ORDERNUMBER = ?"; 

private static String UPDATE_EVENT_SQL = "SELECT * FROM CUSTOMERORDER WHERE 
ORDERNUMBER = ?"; 

__ h. Save (Ctrl+S)  and close the editor 

__ i. Modify DB2EventFormatter.properties.  In the Project Explorer expand Other Projects > 
DBEmitterImpl > src  and double click to open DB2EventFormatter.properties  

__ j. The relationship between an event type and the EventFormatter class for the type is specified in 
this property file so that the Event Formatter registers to the Event Type CustomerOrderTEST . 
For example specify the event type as CustomerOrderTEST  to be more specific to this scenario 
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__ k. Modify the event type from CUSTOMER to CustomerOrderTEST  and leave the EventFormatter 
class 
(com.ibm.wbimonitor.samples.db2emitter.formatter.CUSTOMERFormatterImpl) 
as it is. 

__ l. Save (Ctrl+S)  and close the file 

__ m. If workspace errors are not removed, it may be necessary to Refresh the projects and clean by 
clicking on the Project  > Clean and then choose “Clean All Projects” in the dialog 

 

__ n. At this time the following error might show up in the Problems tab 

 

__ o. As the DBEmitterImpl project is dependent on DBEmitterEJB, build the DBEmitterEJB project by 
right clicking on it then selecting Build Project  

__ p. Select Project > Build All  

____ 7. Review the EJB Deployment Descriptor 

__ a. In the Project Explorer, expand EJB Projects > DBEmitterEJB  and double click on the 
Deployment Descriptor : DBEmitterEJB  to open it in an editor 



© Copyright IBM Corporation 2007. All rights reserved 

2007 June, 15 IBM WebSphere Business Monitor 6.0.2 – Lab Exercise Page 17 of 42 

 DB2 Emitter 

__ b. In the EJB Deployment Descriptor Editor, ensure that the Source  tab is selected 

 

__ c. The following are the default values specified in the EJB deployment descriptor. These can be 
customized by editing the source projects and exporting a new EAR archive. 

<env-entry-name>emitterFactoryJNDI</env-entry-name> 
<env-entry-value>iiop://localhost:2809/com/ibm/events/configuration/emitter/Default</env-entry-value> 
 

Note: The default emitter factory specified for the “emitterFactoryJNDI ” environment entry uses port 2809.  
Check your server’s BOOTSTRAP_ADDRESS to ensure that is the correct port to use. Otherwise, import the 
source projects into WebSphere Integration Developer and make the necessary modifications to the EJB 
deployment descriptor. 

            <env-entry-name>dataSourceJNDI</env-entry-name> 
            <env-entry-value>jdbc/db2emitter</env-entry-value>  

Note: The JNDI name for the data source “dataSourceJNDI ” environment entry is jdbc/db2emitter . Configure 
the DB2 Emitter data source with this JNDI name. 

  <env-entry-name>schedulerJNDI</env-entry-name>   
  <env-entry-value>sched/DB2Poller</env-entry-value> 

Note: The JNDI name for the scheduler “schedulerJNDI ” environment entry is sched/DB2Poller . Configure 
the Scheduler with this JNDI name. 
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__ d. Close the EJB Deployment Descriptor Editor.  

____ 8. Export the DBEmitter  ear file. 

__ a. Select DBEmitter  project in the Enterprise Applications. 

__ b. Right-click on the DBEmitter  project to open the context menu. Select Export > EAR file  

 

__ c. In the Export  dialog, select DBEmitter  for EAR Project and Browse to choose a Destination for 
the EAR. 
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__ d. Press Finish  button 
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Part 2: Create a DB2 emitter database 

In this part, the DB2 Emitter database (For example:  DBEMITT) is created, and three DDL scripts are ran 
to create an Application Table (For example: CustomerOrder), the Event and Log Tables, a procedure 
and three TRIGGER statements for CREATE, DELETE & UPDATE for the Application table (For 
example: CustomerOrder). 

____ 1. Creating Application, Event and Log tables 

Table 1:  Application Table (CustomerOrder ) 

ORDERNUMBER INT  PRIMARY KEY GENERATED ALWAYS AS 
IDENTITY (START WITH 1 INCREMENT BY 1) 

CUSTOMERNAME VARCHAR   

COUNTRY VARCHAR   

CITY VARCHAR  . 

PRODUCTNUMBER VARCHAR   

QUANTITY INT            

ORDERPRICE FLOAT       

Events happen here in the Application Table (CustomerOrder ) with a record created, updated or deleted 
(C/U/D). Based on the state (C/U/D) of this record a trigger is invoked 

Table 2: EVENTTABLE 

SID BIGINT PRIMARY KEY GENERATED ALWAYS 
AS IDENTITY (START WITH 1 
INCREMENT BY 1 

TYPE VARCHAR The type of event which the 
EventFormatterFactory  knows.  

TRIGGER CHAR The kind of trigger. (Create / Update / 
Delete) 

KEYTYPE VARCHAR The type of key which the 
EventFormatter  knows. 

KEYVALUE VARCHAR The value of key which the 
EventFormatter  knows 

CREATETIMESTAMP TIMESTAMP Time when an event posted. 

Events on the Application Table (CustomerOrder ) are stored as records in the EVENTTABLE by 
triggers. The trigger inserts a record with the primary key and additional information to the EVENTTABLE. 
The additional information includes the trigger type (C/U/D), and event type, and the creation timestamp.  
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Table 3:  LOGTABLE 

SID BIGINT The primary key. 

TYPE VARCHAR The kind of event which the EventFormatterFactory 
knows.  

TRIGGER CHAR The kind of trigger. (Create / Update / Delete) 

KEYTYPE VARCHAR The type of key which the EventFormatter knows. 

KEYVALUE VARCHAR The value of key which the EventFormatter knows 

CREATETIMESTAMP TIMESTAMP Time when an event posted. 

RESULT CHAR The result of emission (Success / Fail) 

LOGTIMESTAMP TIMESTAMP Time when an event logged. 

The results of the event emission are logged into the Log Table. 

____ 2. Creating the TRIGGER Statement 

In the TRIGGER Statement, a statement for copying necessary data from the Application Table 
(CUSTOMERORDER) and inserting a record populated by using the data into the EVENTTABLE is 
needed. The Type of the key column of the Application Table should be specified. 

 

In this case, the TRIGGER statements for Create/Update/Delete would be as follows: 

Example1. TRIGGER statement for CUSTOMERORDER table 

-- CREATE TRIGGER statement 

CREATE TRIGGER CUSTOMERCREATE AFTER INSERT ON CUSTOMERORDER REFERENCING 
NEW AS NEWROW FOR EACH ROW MODE DB2SQL BEGIN ATOMIC INSERT INTO 
EVENTTABLE(TYPE, TRIGGER, KEYTYPE, KEYVALUE, CREATETIMESTAMP) 
VALUES('CustomerOrderTEST' , 'C' , 'INT' , RTRIM(CHAR(NEWROW. ORDERNUMBER)), CURRENT 
TIMESTAMP); END; 

-- UPDATE TRIGGER statement 

CREATE TRIGGER CUSTOMERUPDATE AFTER UPDATE ON CUSTOMERORDER REFERENCING 
OLD AS OLDROW FOR EACH ROW MODE DB2SQL BEGIN ATOMIC INSERT INTO 
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EVENTTABLE(TYPE, TRIGGER, KEYTYPE, KEYVALUE, CREATETIMESTAMP) 
VALUES('CustomerOrderTEST' , 'U' , 'INT' , RTRIM(CHAR(OLDROW.  ORDERNUMBER)), CURRENT 
TIMESTAMP); END; 

-- DELETE TRIGGER statement 

CREATE TRIGGER CUSTOMERDELETE AFTER DELETE ON CUSTOMERORDER REFERENCING 
OLD AS OLDROW FOR EACH ROW MODE DB2SQL BEGIN ATOMIC INSERT INTO 
EVENTTABLE(TYPE, TRIGGER, KEYTYPE, KEYVALUE, CREATETIMESTAMP) 
VALUES('CustomerOrderTEST' , 'D' , 'INT' , RTRIM(CHAR(OLDROW.  ORDERNUMBER)), CURRENT 
TIMESTAMP); END; 

The bold  description above represents customization points for you to implement your own triggers. 

CUTOMERORDER        :  The Application table Name 

CustomerOrderTEST   :  The event type which is registered to the EmitterFactory or known by 
EventFormatterFactory  

C/U/D                             : The Trigger type (For example:  For Creation event set ‘C’) 

INT                                 :  The key type. In this case, ORDERNUMBER column is INT 

RTRIM (CHAR (NEWROW. ORDERNUMBER):  The key value. If the type of key column is not 
‘CHAR’, you need to cast the key value to CHAR. 

Note: The DDL scripts for creating the CUSTOMERORDER tables and the triggers are provided in 
<LABFILES>\DB2Emitter\SetUpFiles 

____ 3. Creating the DB2Emitter Database 

__ a. Open DB2 CommandLine Processor (Open start > Programs > IBM DB2 > Command Line 
Tools > CommandLine Processor ) 

__ b. Create new database using the CommandLine Processor   

 For example:  create database DBEMITT 
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Note:  If the DB2Emitter database is created on a remote machine, then catalog the database: 

catalog tcpip node ${DB_NODE} remote ${DB_HOST} server 50000 

catalog db DBEMITT as DBEMITT at node ${DB_NODE} 

__ c. Close the CommandLine Processor 

__ d. Open DB2 Command Window (Open start > Programs > IBM DB2 > Command Line Tool s > 
Command Window ) 

__ e. Connect to DBEMITT database using the db2 administrator username and password 

 For example:  db2 connect to DBEMITT user db2admin using xxxxxx (password) 

 

__ f. Run createCustomerTable.ddl  

 For example:  db2 -tf C:\Labfiles602\DB2Emitter\SetUpFiles\createCustomerTable.ddl 

 

Note:  If the DDL scripts are being run for the first time, an error preceding every create table command will 
be seen. This is due to the DROP statements being run before the create statements. You can safely 
ignore these errors. 

__ g. Run createEventAndLogTable.ddl 

 For example:  db2 -tf C:\Labfiles602\DB2Emitter\SetUpFiles\createEventAndLogTable.ddl 
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__ h. Run createCustomerTrigger.ddl 

 For example:  db2 -tf C:\Labfiles602\DB2Emitter\SetUpFiles\createCustomerTrigger.ddl 

 

__ i. Close the DB2 Command Window 
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Part 3: Configure data source for  DB2 emitter data base 

In this part, the Process Server is configured with a data source for the DBEmitter application to do the 
database transactions with the DBEMITT database, configure J2C Authentication data for the data source to 
authenticate with the DBEMITT database.      

____ 1. Configure J2C Authentication 

__ a. Log on to the Administrative Console 

__ b. In the left pane locate Security > Global security  and in the right pane expand JAAS 
Configuration  and click on J2C Authentication data under the Authentication  category. 

__ c. In the following screen click New to create a new Authentication Alias 

__ d. Enter the following General properties: 

1) Alias : DB2EmitAlias  

2) User ID : db2admin (or the db2 user you are using) 

3) Password : xxxxxx (DB2 password you are using) 

__ e. Click OK and Save to the Master Configuration. 

____ 2. Create a new JDBC Provider 

__ a. Locate Resources > JDBC Providers  and select the radio button next to Server to ensure that 
the JDBC Provider is created at the server scope 

__ b. Click New to create new JDBC Provider 

__ c. Set the following for the General Properties: 

1) Database type: DB2 

2) Provider type: DB2 Universal JDBC Driver Provider  

3) Implementation type: XA data source  
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__ d. Click Next   

__ e. In the following screen enter DB2Emitter Provider (XA)  in Name field. Click OK and Save to the 
master configuration 

 

____ 3. Create a new Data source. Now that a JDBC provider had been created, a data source data will be 
created 

__ a. Locate Resources > JDBC Providers > DB2Emitter Provider (X A) and click on Data sources  
under Additional properties category 
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__ b. Click on the New button to create a new data source 

__ c. Enter the following General Properties: 

1) Name: DB2 Emitter DataSource  

2) JNDI name: jdbc/db2emitter  (Note, this is the default JNDI name specified as an 
environment entry in the EJB deployment descriptor) 

3) Disable "Use this Data Source in container managed persistence (CMP)" 

4) Description: JDBC DataSource for DB2 Sample Event Emitter  

5) Component-managed authentication alias: {NodeName}/DB2EmitterAlias (the name of 
the authentication alias previously created in Step 1) 

6) Database name: DBEMITT (the name of the database previously created in Step 5) 

__ d. Click OK and Save to the master configuration 

__ e. Test the Connection to the DBEMITT database 

Note:  If test connection fails as follows then you must set a WebSphere variable: 

 

Locate WebSphere variables in the administrative console under the Environment section. 

Set DB2UNIVERSAL_JDBC_DRIVER_PATH  in the name field and the DB2 library path in the value field 
(For example:  C:\IBM\SQLLIB\java), then click Apply 

The scope of this variable depends on the scope of the JDBC Provider you configured to. 

____ 4.  The DataSource configuration for the DBEMITT database is complete 
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Part 4: Configure a scheduler service and deploy th e DB2Emitter EAR 

In this part, a Scheduler Service is created for the DB2Emitter to invoke the EmissonController at a specified 
interval.  

Follow the steps below to create a cloudscape database for the scheduler service; configure a DataSource for 
the same and finally a scheduler for the DB2Emitter 

____ 1. Create a Cloudscape database for the Scheduler Service 

__ a. Launch cview.bat 

__ b.  Explore to <WPS_HOME>/cloudscape/bin/embedded and double-click cview.bat  to launch the 
Cview window 

 

__ c. From the main menu, select File ���� New ���� Database  

__ d. In the name field, enter <WPS_HOME>/cloudscape/databases/SKDLR 

Where as <WPS_HOME> is C:\IBM\WebSphere\ProcServer 

For example: - C:\IBM\WebSphere\ProcServer\cloudsca pe\databases\SKDLR  
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__ e. Click OK 

__ f. Verify that the database is created and is listed on the left pane of the Cview window 

 

__ g. Close the Cview window (File ���� Exit ) 

____ 2. Create a DataSource for the Scheduler Service 

__ a. Launch the WebSphere Process Server Administrative Console and logon to it 

For example: - http://localhost:9060/ibm/console/  
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__ b. In the left pane, locate Resources � JDBC Providers, set the scope to Servers  and click Apply  

 

__ c. Click the New button to create a new JDBC Provider 

1) Set Cloudscape  in database type 

2) Set Cloudscape JDBC Provider  in provider type 

3) Set XA data source  in implementation type 

 

__ d. Click Next  
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__ e. In the following screen, enter the Name filed to Scheduler Cloudscape JDBC Provider (XA) , 
Click OK and Save to the master configuration 

__ f. You must the new the Cloudscape JDBC Provider listed as shown below: 

 

__ g. Now that a JDBC provider had been created, create a data source 

__ h. Locate Resources > JDBC Providers > Scheduler Cloudscape J DBC Provider (XA)  and click 
on Data sources  under Additional properties  

 

__ i. In the following screen, click the New button to create a new data source 

__ j. Under General properties, enter the following: 

1) Name : SKDLR DataSource  

2)  JNDI name: jdbc/skdlr   

3) Disable "Use this Data Source in container managed persistence (CMP)" 

4) Description: JDBC DataSource for SKDLR Database  

5) Database name: C:\IBM\WebSphere\ProcServer\cloudscape\databases\SK DLR 

 (<WPS_HOME>\cloudscape\databases\SKDLR)  

__ k. Click OK and Save to the master configuration 

__ l. Test the connection to the scheduler database and ensure that a successful message is resulted 

____ 3. Create a scheduler for the DB2 Emitter: 

__ a. Locate Resources > Schedulers  and the set the scope to Servers  
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__ b. Click New to create a new Scheduler configuration 

__ c. In the Scheduler > New screen, enter the following information: 

1) Name: DB2Poller  

2) JNDI name: sched/DB2Poller  (This is the default specified as an environment entry in the 
EJB deployment descriptor) 

3) Description: Scheduler for DB2 Sample Emitter's Event Table Poll er 

4) Data source JNDI name: jdbc/skdlr  (select from the drop down list) 

5) Table prefix: DB2EMTR_ 

6) Poll interval: 30 

7) Work managers: DefaultWorkManager  
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__ d. Click OK and Save to the master configuration 

__ e. Select check box next to DB2Poller  and click the Create Tables  button 

 

__ f. Ensure that the tables are created successfully 

____ 4. The Scheduler configuration is complete 

____ 5. Deploy the DB2Emitter EAR file. 
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Note: Ensure that the EAR is copied to the file system local to the application server where you would like 
to deploy 

__ a. Logon to the Administration console. In the left pane, select Applications >Install New 
Application  

__ b. Click Browse  to Specify Path  on the Local file system in the right panel and click Next  

 

__ c. Progress through all the 6 steps of “Install New Application” screens, accepting the defaults 

__ d. In Step 6, the Summary  screen, click the Finish  button. The install will take several moments 

__ e. After the installation is complete, ensure that the message “Application DBEmitter installed 
successfully” is displayed. 
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__ f. Click “Save to Master Configuration ”, and finally click Save on the “Save” screen. 

 

____ 6. Restart  the Process Server 
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Part 5: Testing DB2 emitter 

____ 1. Now that the Process Server configuration is complete and DB2Emitter application is deployed, it is 
time to do a simple test for CEI event emissions. 

__ a. Ensure that the Process Server and the DB2Emitter application are running. 

__ b. Open the DB2 Command Line Processor. (Start > Programs > IBM DB2 > Command Line 
Tools > Command Line Processor ) 

__ c. Run connect to DBEMITT  using the DB2 administrator user and password 

 For example:  connect to DBEMITT user db2admin using xxxxxx (or the user/password being 
used) 

__ d. Run an insert statement for the CUSTOMERORDER table.                                                      For 
example:  insert into CUSTOMERORDER(CUSTOMERNAME, COUNTRY , CITY, 
PRODUCTNUMBER, QUANTITY, ORDERPRICE) values(‘Jane Doe', 'USA', 'Austin', 'P123', 2 , 
2999.50) 

 

Note:  Immediately after the insert statement is run, the inserted data is moved to 'EVENTTABLE' by the 
trigger. DB2Emitter refers to the 'EVENTTABLE' at regular intervals using the Scheduler. 

The following is the CUSTOMERORDER table with a record inserted (created) 

 

The result of the event emission is logged to the LOGTABLE  as shown below: 
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Note:  If emission is successful, a successful record (RESULT='S') is inserted to 'LOGTABLE' 

If an Exception occurs, a failed record (RESULT='F') is inserted to 'LOGTABLE' 

If a Runtime Exception or an Error occurred, the record is rolled back 

__ e. Run an update statement for the CUSTOMERORDER table.                                                      
(For example:  update CUSTOMERORDER SET ORDERPRICE = 9999.90 where 
ORDERNUMBER = 1 ) 

 

The following is the representation of data in CUSTOMERORDER and LOGTABLE after an update 
statement is processed. 

 

 
__ f. Run a delete statement for the CUSTOMERORDER table.                                                      (For 

example:  delete from CUSTOMERORDER where ORDERNUMBER = 1 ) 
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The following is the representation of data updated in the CUSTOMERORDER and LOGTABLE after a 
delete statement is issued.  

 

 
__ g. To view the events emitted in a CBE browser, logon to the Process Server’s Administrative 

console, Locate Integration Applications > Common Base Event Browse r click on the Get 
Events  and then All Events.  
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Part 6: Solution 

If you would prefer not to create the emitter from scratch, then you can follow this section to import a project 
interchange file which has the updated source. Using the project interchange that is provided, you can import it 
to WebSphere Integration Developer, then Build All projects and export the EAR.   

If using the solution, skip Part 1, complete this section, and then continue with Part 2. 

____ 1. Open WebSphere Integration Developer 

__ a. Select Start > Programs > IBM WebSphere > Integration Deve loper V6.0.2 > WebSphere 
Integration Developer V6.0.2  

__ b. Workspace Launcher window will be displayed. Click the Browse…  button and select your 
workspace directory. (For example:  C:\LabFiles602\DB2Emitter\workspace) 

__ c. Click OK. 

__ d. Close the welcome window by clicking the arrow in the top right corner of the welcome window 

__ e. By default WebSphere Integration Developer opens in Business Integration  perspective. You 
need to change it to J2EE perspective. To do this click on the top right corner of the WebSphere 
Integration Developer and choose Other  if J2EE is not listed here. 

__ f. Select Project > Build Automatically , to turn off automatic builds 

____ 2. Import the solution DB2Emitter project interchange into WebSphere Integration Developer 

__ a. Select File > Import  from the main menu. 

__ b. From the Import  window select Project Interchange  and click Next  

__ c. The Import Project Interchange Contents  window will be opened. 

__ d. Click Browse…  and select <LABFILES>\DB2Emitter\DB2Emitter_Solution_PI.zip as the 
source .zip file. 

 For example:  C:\LabFilesCEM61\DB2Emitter\DB2Emitter_Solution_PI.zip  

__ e. Click Select All  then click Finish  
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__ f. Refresh the projects and clean by clicking on Project  > Clean and then choose “Clean All 
Projects” in the dialog 

__ g. Click Project > Build All to build all the projects 

__ h. At this point you might see an error in the Problems tab 

__ i. As the DBEmitterImpl project is dependent on DBEmitterEJB, build the DBEmitterEJB project by 
right clicking on it. 

__ j.  Finally in the Project Explorer, right click on DBEmitter under Enterprise Applications to choose 
Export > EAR  file . 

__ k. Provide the Destination you would like to save the EAR. 

__ l. Close WebSphere Integration Developer. 

__ m. Continue the lab with Part 2  of this document. 
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What you did in this exercise 

You imported the sample DB2 Emitter source into WebSphere Integration Developer and modified it to 
match the DB2 Emitter’s CUSTOMERORDER data.  Then you exported the DBEmitter EAR to 
WebSphere Process Server V6.0.2 that has a CEI SDK installed. 

You Deployed the Application to WebSphere Process Server V6.0.2 

You created a new DataSource for the Db2 Emitter database. 

You created a cloudscape database for the Scheduler, created a DataSource for it and then created a 
Scheduler service.   

You updated records in the Application Table (CUSTOMERORDER) to test for the Event Emissions to the 
CEI server 

Finally you used the Process Server’s Common Event Browser to view the emitted events. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


