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What this exercise is about 

The objective of this lab is to show you how to take a model from WebSphere Business Modeler and 
deploy it to WebSphere Process Server and WebSphere Business Monitor, then view your process data 
on the Monitor Dashboards, and export actual values from WebSphere Business Monitor back to the 
model. 

Lab Requirements 

List of system and software required for the student to complete the lab. 

• WebSphere Business Modeler v6 

• WebSphere Integration Developer v6.0.1 

• WebSphere Process Server v6.0.0 for Monitor Server 

• WebSphere Process Server v6.0.1 for Runtime Server 

• WebSphere Business Monitor v6 – Dashboard Client Server and Monitor Server 
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What you should be able to do 

At the end of this lab you should be able to: 

• Use WebSphere Business Modeler to import a project, create the default business measures model, 
apply default implementation values, export the process model and business measures model 

• Use WebSphere Integration Developer to import the process model, implement the Java and Human 
tasks, export an EAR file for deployment 

• Use the WebSphere Process Server admin console to install the EAR 

• Use the WebSphere Process Server admin console to run Monitor schema generation 

• Run Monitor scripts to create the Monitor Server tables, replication manager artifacts, and start 
replication manager daemons 

• Use the WebSphere Process Server admin console to import the business measures model 

• Use the WebSphere Business Process Choreography Explorer to run process instances 

• Use Cube Views OLAP Center on the Dashboard Client Server to import the cubes 

• Use Alphablox on the Dashboard Client Server to define the cubes 

• Use Portal to define a Dashboard and to view process data 

• Use the Actual Values view on the Dashboard Client Server to export actual values 

• Import actual values into your model 

 

Introduction 

In this lab you will learn how to deploy a model from end to end using WebSphere Business Modeler and 
WebSphere Business Monitor.  This is a complex process, but note that you will be performing many 
different roles during this lab – user analyst, process architect, process developer, database administrator, 
dashboard architect and user.  This lab will show you the basic procedure for implementing a simple 
model.  To keep things as simple as possible, this lab will not attempt to cover the creation of metrics, KPIs 
and other components of the business measures model.  It will simply import a process model that already 
contains a business measures model.  Both models were created using WebSphere Business Modeler 
and the Business Measures editor. 

Also, this lab shows you best practice deployment procedures for process implementation in WebSphere 
Integration Developer.  This is especially important when re-deploying a process model to limit the amount 
of rework that will be necessary in WebSphere Integration Developer.  To understand more about best 
practices for deployments in WebSphere Integration Developer, please refer to the lab ‘Preparing a 
Process with WebSphere Business Modeler for WebSphere Integration Developer’. 

 

Exercise Instructions 

Some instructions in this lab may be Windows operating-system specific.  If you plan on running the lab on 
an operating-system other than Windows, you will need to execute the appropriate commands, and use 
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appropriate files ( .sh vs. .bat) for your operating system.  The directory locations are specified in the lab 
instructions using symbolic references, as follows: 

Reference Variable Windows Location AIX/UNIX Location 

<LAB_FILES> C:\Labfiles60 /tmp/Labfiles60 
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Part 1: Create the Business Measures Model 

____ 1. Start WebSphere Business Modeler with a new workspace to hold the work you will do in this lab. 
Set the layout to 4-pane layout, and set the modeling mode to WebSphere Process Server. 

__ a. Start WebSphere Business Modeler. 

__ b. Enter the following to start a new folder ProjectScenario that will hold all of our artifacts in this 
lab:   C:\ProjectScenario\ModelerWs 

 

__ c. Click OK. 

__ d. The following window will appear: 

Note: If the Quick start wizard opens, de-select the ‘Always show this wizard on startup’ option and click 
Cancel. 
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__ e. Close the welcome window by clicking the arrow in the top right corner of the welcome window. 

__ f. Also, apply the 4-pane layout by clicking on the icon near the top:  

__ g. Change the modeling mode by selecting Modeling > Mode > WebSphere Process Server. 

____ 2. Create a new project and import the pre-created ProjectScenario model. 

__ a. Right click in the Project Tree view, and then select New > Business Modeling Project. Enter 
the project name ‘ProjectScenario’ and uncheck ‘Create process’. 
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__ b. Click Finish. 

__ c. Right click in the Project Tree view, then Import.  Select ‘WebSphere Business Modeler 
project (.zip)’, then click Next 

__ d. On the following window, navigate to 
‘<LAB_FILES>\Scenario\ProjectScenarioWithBMModel.zip’.  
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__ e. Click Finish. 

__ f. You should see a confirmation window as follows.  

 

__ g. Click OK. 
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Review the model and business object. 

__ h. In the Project Tree, expand ProjectScenario, then Processes.  Double click on 
ProcessScenario to bring up the Process editor. 

 

__ i. In this process, there are three tasks ‘Receive Order’, ‘Approve Order’ and ‘Package and Ship 
Order’.  Also, there is a Decision based on the OrderPrice of the CustomerOrder that determines 
whether the order must be approved.  If the order price is greater than or equal to $500 then the 
order must be approved. Orders with a price less than $500 require no approval. 

__ j. Expand ProcessScenario in the project tree.  Double click on ProcessScenario Business 
Measures, and the business measures editor opens up.  These business measures have already 
been created for you. 
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__ k. Expand Business Items in the Project Tree, and double click on CustomerOrder to view the 
attributes of this business item. 
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____ 3. Export the model to WebSphere Business Monitor and WebSphere Process Server. 

__ a. At this point, you may want to click on the Errors tab and check to make sure there are not any 
errors.   There might be some warnings but these should be okay. 

__ b. Right click in the Project Tree, select Export.   
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__ c. Select ‘WebSphere Business Monitor and development tool’ from Types and click Next.  On 
the following window, for the target directory browse to C:\ProjectScenario.  For the project, 
select ‘ProjectScenario’.   
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Note: This export will generate two files in the ProjectScenario directory, Monitor.zip file and 
WebSphere Process Server folder, which contains ProjectScenario.zip. 

 

__ d. Click Next. 

__ e. Select Module project name and enter ProjectScenario in the WebSphere Process Server 
export details window. 

__ f. Select Library project name and enter ProjectScenarioLibrary.  All interfaces for the process 
and global tasks will be placed in the library and available for use by other components not in the 
module containing the process. 

__ g. Select Project interchange name and enter ProjectScenario. 
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__ h. Click Finish 

__ i. You should see a confirmation window as follows.  
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__ j. Click OK. 

____ 4. Close WebSphere Business Modeler. (Select File > Exit )  

__ a. If you take a look at our folder C:\ProjectScenario, you will see that the export created 2 artifacts 
– Monitor.zip and folder ‘WebSphere Process Server’. 

 

Note: The ‘ModelerWs’ folder contains the Modeler workspace and was created earlier when you started 
WebSphere Business Modeler. 
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Part 2: Implement and Deploy the Process Model 

In this part, the Process Model will be implemented using WebSphere Integration Developer and then 
deployed onto the Runtime Server. 

____ 1. Start WebSphere Integration Developer creating a new workspace in the folder C:\ProjectScenario, 
and turn off the auto-build feature. 

__ a. Start WebSphere Integration Developer.  For the Workspace, enter C:\ProjectScenario\WidWs, 
so we will create a new workspace in our project folder. 

 

 

__ b. Click OK. 

__ c. Close the welcome window by clicking the arrow in the top right corner of the welcome window. 

__ d. Select Project > Build Automatically, to turn off automatic builds. 

____ 2. Import the Model into WebSphere Integration Developer 

__ a. Select File > Import from the main menu. 

__ b. From the Import window, select Project Interchange as the source and click Next. 
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__ c. The Import Project Interchange Contents window will be opened. 

__ d. Now click the first Browse… button and select C:\ProjectScenario\WebSphere Process 
Server\ProjectScenario.zip as the source zip file. 
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__ e. Click Select All and then click Finish. 

____ 3. Review the imported artifacts 

__ a. In the Business Integration view, notice the two projects.  ProjectScenario is the module 
containing the process and ProjectScenarioLibrary is the library.   

__ b. Expand ProjectScenarioLibrary > Interfaces.  Notice there are 4 interfaces in the library, one 
for the process (ProcessScenario) and one for each task in the process.  With the interfaces in 
the library, they can be used for components defined in other modules. 
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__ c. In the Business Integration view, expand ProjectScenario and then double-click 
ProjectScenario. 

 

 

 

 

__ d. The assembly editor will be opened.  Notice how the different tasks of the process are exposed 
as Java components.  The Approve Order task is not exposed as a Java component since it 
was a local task and it had a resource assigned to it that was a Role (Account Manager).  Even 
though the Receive Order and Package and Ship Order tasks are Java components, they are 
in the same module as the process.  This packaging structure is simple and fine for the testing 
and deployment of small applications.  However, when processes become larger and iterative 
development of the process occurs, it becomes problematic to keep the components updated 
when they are in the same module. When a process is changed, the implementation of the 
component may not change.  For this reason, it is better to move these components and their 
implementation to a different module and use an SCA Import/Export to connect the components 
to the process.  In the future, when changes are made to the process, the task implementation 
which is a separate component in a separate module can be left unchanged. 
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Double-click on the ProcessScenario component to open the process editor.    

 

__ e. Close the process editor and the assembly editor 

____ 4. In order for the Receive Order, Package and Ship Order and Approve Order component 
implementations to be isolated from changes in the process, separate modules for each component 
should be created. 

__ a. Select File > New > Project from the main menu 

__ b. Select Module from the New Project window and click Next 
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__ c. From New Module window enter ReceiveOrder as Module Name and click Finish 
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__ d. Repeat the above steps to create two more modules, PackageandShipOrder and 
ApproveOrder. 

____ 5. In order for components in the new modules to be able to provide the implementation for the 
different tasks, the appropriate interfaces in the ProjectScenarioLibrary task must be used.  A 
dependency between the module and the library must be established before the interface can be 
used for a component.  Create the dependencies and add the library to the modules. 

__ a. From the Business Integration view right click on PackageandShipOrder and select Open 
Dependency Editor 

 

__ b. Click Add under the Libraries text area 
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__ c. Select ProjectScenarioLibrary from the Library Selection window and click OK 

 

__ d. Save (Ctrl+S) and close the Dependency Editor 

__ e. Repeat the above steps for the ReceiveOrder module and the ApproveOrder module 
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____ 6. Generate Java Implementation and Binding 

__ a. In the Business Integration view, expand PackageandShipOrder and double-click the 
PackageandShipOrder module and you will see an Assembly diagram view for 
PackageandShipOrder opened on the right side window 

 

__ b. Drag the PackageandShipOrder interface from ProjectScenarioLibrary > Interfaces and drop 
it onto the Assembly diagram 

 

__ c. Select Component with no Implementation Type from the Component Creation window and 
click OK 
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__ d. An unimplemented component will be created 

 

__ e. Click on the Component1 and rename it to PackageandShipOrder 

NOTE: You can also change the name by changing the Display name (Name field will automatically be 
changed filling Display name field) under the Description tab from Properties view of the Component1. If 
you change the name from the Assembly Diagram you should see the Display name and Name changed 
from Component1 to PackageandShipOrder in the Description tab of Properties View. 
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__ f. The component can be implemented any way as long as it uses the PackageandShipOrder 
interface.  You could implement the component as a human task, business state machine, 
business rule or even a business process.  For simplicity, right click on the 
PackageandShipOrder and select Generate Implementation > Java. 

 

__ g. Accept the default package from Generate Implementation and click OK 
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__ h. PackageandShipOrderImpl.java will be opened in the assembly editor.  Change the return 
value from ‘null’ to ‘input’ within the method InputCriterion: 

 

__ i. Save your work (Ctrl+S).  Close the Java editor for PackageandShipOrderImpl.java 

__ j. Right click on PackageandShipOrder in the PackageandShipOrder assembly diagram and 
select Export > SCA Binding.  This will make the component available to be called from outside 
of the module.   

 

__ k. Your PackageandShipOrder Assembly diagram will now look like this: 
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__ l. Save your work (Ctrl+S) and close the PackageandShipOrder Assembly diagram 

__ m. Repeat the above steps for the ReceiveOrder module 

__ n. Your ReceiveOrder Assembly diagram will now look like this: 

 

____ 7. Generate Human Task Implementation and Binding 

__ a. In the Business Integration view, expand ApproveOrder and double-click the ApproveOrder 
module and you will see an assembly diagram view for ApproveOrder opened on the right side 
window 

__ b. Drag the ApproveOrder interface from ProjectScenarioLibrary > Interfaces and drop it onto 
the assembly diagram 
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__ c. Select Component with no Implementation Type from the Component Creation window and 
click OK 

__ d. An unimplemented component will be created 

 

__ e. Click on the Component1 and rename it to ApproveOrder 

__ f. The component can be implemented any way as long as it uses the ApproveOrder interface.  You 
could implement the component as a human task, business state machine, business rule or even 
a business process.  For now, right click on the ApproveOrder and select Generate 
Implementation > Human Task 

 

__ g. Accept the ApproveOrder component from Generate Implementation and click OK 
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__ h. Enter the Human Task name as MyHumanTask 

 

__ i. Click OK. The human task editor opens. 

__ j. Click the button MyHumanTask at the top of the human task editor, then click tab Details and 
pick bpe/staff/everybodyconfiguration for the JNDI name of staff plug-in configuration as 
follows: 
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__ k. In the human task editor, click the Administrator icon in Receiver Settings (first icon on the 
left). This will add Administrator to the list of staff under Receiver Settings. Then press Ctrl-S to 
save it. You will see this: 
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__ l. Close the human task editor 

__ m. Right click on the ApproveOrder component in the Assembly Diagram view and select Export 
> SCA Binding.  This will make the component available to be called from outside of the 
module.  

 

__ n. Your ApproveOrder Assembly diagram will now look like this: 
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__ o. Save your work (Ctrl+S) and close the ApproveOrder assembly diagram 

____ 8. Rewire process to components 

__ a. Open the Assembly editor for ProjectScenario again by double-clicking on ProjectScenario > 
ProjectScenario in the Business Integration view.   

 

__ b. Delete Receive Order, Receive Order Export, Package and Ship Order, Package and Ship 
Order Export, Approve Order, Approve Order Export  components by right clicking on each of 
these 

 

__ c. Save (Ctrl+S) your work 

Note: You should save your assembly diagram after deleting the above elements. Otherwise, you will see 
these exports while selecting SCA exports. 

__ d. In the ProjectScenario assembly diagram right click on ProcessScenario and select Wire 
References to New > Imports 
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__ e. Imports which match ReceiveOrder, PackageandShipOrder and ApproveOrder interfaces will 
be created 

 

__ f. Right click on ReceiveOrderPartner and select Generate Binding > SCA Binding 
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__ g. Right click on PackageandShipOrderPartner and select Generate Binding > SCA Binding 

__ h. Right click on ApproveOrderPartner and select Generate Binding > SCA Binding  

__ i. Select ReceiveOrderPartner and then from the Properties view at the bottom, select Binding 

 

__ j. Click Browse…. SCA Export Selection window will be opened 

__ k. Select ReceiveOrderExport under Matches and click OK 
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__ l. Select PackageandShipOrderPartner and select Binding from the Properties view. 

__ m. Select Browse…. 

__ n. Select Package and Ship Order Export under Matches 
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__ o. Click OK. 

__ p. Select ApproveOrderPartner and select Binding from the Properties view. 

__ q. Select Browse…. 

__ r. Select Approve Order Export under Matches 
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__ s. Click OK 

__ t. Save your work (Ctrl+S). 

__ u. The process is complete and ready for deployment 

 

____ 9. Build the project  

__ a. From the main menu, select Project > Clean… and then click OK 

__ b. At this point, you may want to click on the Problems tab and check to make sure there are not 
any errors.  There might be some warnings but these should be okay. 

____ 10. Export the EAR files. 

__ a. From the main menu, select File > Export … > EAR file  then click Next 
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__ b. If you see the ‘Confirm Enablement’ window, click OK 

__ c. On the following window, set the EAR project to ProjectScenarioApp, and set the destination to 
C:\ProjectScenario\ProjectScenarioApp.ear 

 

__ d. Click Finish 

__ e. Repeat the above steps to  

1) export ApproveOrderApp to C:\ProjectScenario\ApproveOrderApp.ear 

2) export PackageandShipOrderApp to C:\ProjectScenario\PackageandShipOrderApp.ear 

3) export ReceiveOrderApp to C:\ProjectScenario\ReceiveOrderApp.ear 

__ f. Close WebSphere Integration Developer 

__ g. Now you can take a look at the project folder, and you will see the new WID workspace and the 
new EAR files. 
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____ 11. Copy the EAR files to the Runtime Server (the Business Process Server, not the Monitor Server) 

__ a. Copy the four EAR files to the Runtime Server  

1) C:\ProjectScenario\ProjectScenarioApp.ear 

2) C:\ProjectScenario\ApproveOrderApp.ear 

3) C:\ProjectScenario\PackageandShipOrderApp.ear 

4) C:\ProjectScenario\ReceiveOrderApp.ear 

__ b. If necessary, start Process Server using Start > All Programs > IBM WebSphere > Process 
Server 6.0 > profiles > ProcSrv01 > Start the server. 

Note: Your profile may have a different name than ‘ProcSrv01’. Choose the correct one for you. 

____ 12. Deploy the EAR files to the Runtime Server 

__ a. Start the admin console (Start > All Programs > IBM WebSphere > Process Server 6.0 > 
profiles > ProcSrv01 > Administrative console) and log in. Then, select Applications > 
Install New Application.  Browse to the EAR file: ProjectScenarioApp.ear.   
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__ b. Click Next, then continue installing the application, accepting all the defaults. 

__ c. This window shows a successful install. 
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__ d. Save the configuration by clicking Save to Master Configuration and then clicking Save. 

__ e. Navigate to Applications > Enterprise Applications, and then start application 
ProjectScenarioApp. 

__ f. Repeat the above steps for the rest of the EAR files 

1) C:\ProjectScenario\ApproveOrderApp.ear 

2) C:\ProjectScenario\PackageandShipOrderApp.ear 

3) C:\ProjectScenario\ReceiveOrderApp.ear 

 

 



© Copyright IBM Corporation 2006. All rights reserved 

2006 February, 15 IBM WebSphere Business Monitor 6.0  – Lab Exercise Page 42 of 103 

 End-to-end Scenario 

Part 3: Run Schema Generator and execute the generated scripts 

____ 1. Run the schema generator on the Monitor Server (not the Runtime Server) 

__ a. Copy c:\ProjectScenario\monitor.zip (created in Part 1) to the Monitor Server  

__ b. If necessary, start Monitor Server using Start > All Programs > IBM WebSphere > Process 
Server 6.0 > profiles > monitor > Start the server. 

__ c. Start the admin console (Start > All Programs > IBM WebSphere > Process Server 6.0 > 
profiles > monitor > Administrative console) and log in. 

__ d. In the Monitor Server admin console, navigate to WebSphere Business Monitor > Schema 
Generator > Configuration.  For the Business Measures Model, enter 
C:\ProjectScenario\monitor.zip.  For the output directory, enter C:\ProjectScenario.  When you 
run schema generator, it will create a folder called ‘schemagen’ in this output directory, and it will 
place the generated artifacts there. 

 

__ e. Click Apply. 

__ f. Click tab ‘State to Runtime Configuration’, and set your ‘Runtime database population interval’ 
to 2.  This sets the replication interval to 2 minutes. 
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__ g. Click Apply. 

__ h. Click tab ‘Runtime to Historical Configuration’, and set your ‘Historical database population 
interval’ to 2.  This sets the replication interval to 2 minutes. 
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__ i. Click Apply. 

__ j. Save the configuration by clicking on Save near the top of the admin console, and then click the 
Save button when it appears. 

__ k. Navigate to WebSphere Business Monitor > Schema Generator > Generate. Click the 
Generate button.  Messages in the window indicate the result:  
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____ 2. Extract the script files to the Monitor Server and Dashboard Client Server. 

__ a. On the Monitor Server, open the Windows File Explorer, and navigate to 
C:\ProjectScenario\schemagen. 
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Note: The schema generation has created scripts to add your model to the STATE, HISTORY and 
RUNTIME databases. The STATE database scripts will be unzipped and executed on the Monitor Server 
because that is where the STATE database was created. The RUNTIME and HISTORY databases exist 
on the Dashboard Client Server so you will first need to copy the scripts for these databases to that server. 
Then you will unzip and later execute them on that server.  

__ b. Copy the C:\ProjectScenario\schemagen directory to the same location on Dashboard Client 
machine 

__ c. On the Monitor Server machine, unzip DS_State_setup.zip to 
C:\ProjectScenario\schemagen\State\ 

__ d. Your Monitor Server directory should look like this: 
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__ e. On the Dashboard Client machine, unzip DS_Runtime_setup.zip to  
C:\ProjectScenario\schemagen\Runtime\ 

__ f. On the Dashboard Client machine, unzip DS_Datamart_setup.zip to  
C:\ProjectScenario\schemagen\History\ 

__ g. Your Dashboard Client directory should look like this: 
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____ 3. Create the dynamic database tables for the STATE table on the Monitor Server 

The schema generation creates database scripts for updating the STATE, RUNTIME and HISTORY 
databases with tables that specifically correspond to the business measures model you have used for 
schema generation. You must execute these scripts for each database. Because the STATE database 
exists on the Monitor Server but the RUNTIME and HISTORY exist on the Dashboard Client server, 
you will execute each script on the appropriate server. 

__ a. On the Monitor Server, open a DB2 Command Window, Start > All Program > IBM DB2 > 
Command Line Tools > Command Window 

__ b. Change directory to C:\ProjectScenario\schemagen\ 

cd C:\ProjectScenario\schemagen\ 

__ c. Execute the following commands 

db2 terminate 
set DB2CODEPAGE=1208 
db2 connect to STATE 
db2 +c -svtf state.ddl > state.log 

__ d. Check the log file (state.log). If there are no errors then execute this additional command 

db2 commit 

 

Note: If there are errors, enter ‘db2 rollback’ instead 

____ 4. Create the dynamic database tables for the RUNTIME table 

__ a. Switch to the Dashboard Client machine 

__ b. On the Dashboard Client, open a DB2 Command Window, Start > All Program > IBM DB2 > 
Command Line Tools > Command Window 

__ c. Change directory into C:\ProjectScenario\schemagen\ 

cd C:\ProjectScenario\schemagen\ 
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__ d. Execute the following commands 

db2 terminate 
set DB2CODEPAGE=1208 
db2 connect to RUNTIME 
db2 +c -svtf runtime.ddl > runtime.log 

__ e. Check the log file (runtime.log). If there are no errors then execute this additional command 

db2 commit 

 

Note: If there are errors, enter ‘db2 rollback’ instead 

____ 5. Create the dynamic database tables for the HISTORY table 

__ a. Continue working on the Dashboard Client machine 

__ b. On the Dashboard Client, open a DB2 Command Window, Start > All Program > IBM DB2 > 
Command Line Tools > Command Window 

__ c. Change directory into C:\ProjectScenario\schemagen\ 

cd C:\ProjectScenario\schemagen\ 

__ d. Execute the following commands 

db2 terminate 
set DB2CODEPAGE=1208 
db2 connect to HISTORY 
db2 +c -svtf datamart.ddl > datamart.log 

__ e. Check the log file (datamart.log). If there are no errors then execute this additional command 

db2 commit 
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Note: If there are errors, enter ‘db2 rollback’ instead 

____ 6. Execute the database replication setup scripts 

Now that the dynamic tables have been added to the databases, you must configure the data 
replication between each database. This requires you to run the generated data movement replication 
scripts for each database.  

Note: You will execute some scripts on the Monitor Server and some on the Dashboard Client server so 
please pay careful attention to which server is being used at each point 

__ a. Switch to the Monitor Server 

__ b. On the Monitor Server, open a DB2 Command Window, Start > All Program > IBM DB2 > 
Command Line Tools > Command Window 

__ c. Change directory into C:\ProjectScenario\schemagen\State\ 

cd C:\ProjectScenario\schemagen\State\ 

__ d. Execute the following command 

State_to_Runtime_setup_source.bat 

Note: You will require a Java Runtime Environment to execute this script. If you do not have one installed 
on your Monitor Server then you will receive an error similar to this: 'java' is not recognized as an internal 
or external command,operable program or batch file. You should install a JRE 1.4.2 environment, close all 
windows, and try the script again. 
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__ e. When prompted enter the user ID and password for the STATE database. The default values are 
‘db2admin’ and ‘monPa55w0rd’ 

__ f. The script must end in SUCCESS for the replication to be deployed correctly. Inspect the 
generated log file State_to_Runtime_setup_source.bat.log for any warning or error messages. 
You will see some WARNING responses but you should see no ERROR responses. 

 

 

__ g. Important: Switch to the Dashboard Client server 

__ h. On the Dashboard Client, open a DB2 Command Window, Start > All Program > IBM DB2 > 
Command Line Tools > Command Window 

__ i. Change directory into C:\ProjectScenario\schemagen\Runtime\ 

cd C:\ProjectScenario\schemagen\Runtime\ 

__ j. Execute the following command 

State_to_Runtime_setup_target.bat 

Note: Again you will require a Java Runtime Environment to execute this script. If you do not have one 
installed on your Dashboard Client then you will receive an error similar to this: 'java' is not recognized as 



© Copyright IBM Corporation 2006. All rights reserved 

2006 February, 15 IBM WebSphere Business Monitor 6.0  – Lab Exercise Page 52 of 103 

 End-to-end Scenario 

an internal or external command,operable program or batch file. You should install a JRE 1.4.2 
environment, close all windows, and try the script again. 

 

__ k. When prompted enter the user ID and password for the RUNTIME database, hosted locally on 
the Dashboard Client. Also when prompted, enter the User ID and password to connect to the 
remote STATE database, hosted remotely on the Monitor Server. In both cases, the default 
values are ‘db2admin’ and ‘monPa55w0rd’. 

__ l. The script must end in SUCCESS for the replication to be deployed correctly. Inspect the 
generated log file State_to_Runtime_setup_target.bat.log for any warning or error messages. 
You will see some WARNING responses but you should see no ERROR responses. 

 

__ m. Continue working on the Dashboard Client server, open a new DB2 Command Window, Start 
> All Program > IBM DB2 > Command Line Tools > Command Window 

__ n. Change directory into C:\ProjectScenario\schemagen\Runtime\ 

cd C:\ProjectScenario\schemagen\Runtime\ 

__ o. Execute the following command 

Runtime_to_Historical_setup_source.bat 
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__ p. When prompted enter the user ID and password for the RUNTIME database, hosted locally on 
the Dashboard Client. When prompted, enter the User ID and password to connect to the remote 
STATE database, hosted remotely on the Monitor Server. In both cases, the default values are 
‘db2admin’ and ‘monPa55w0rd’. 

__ q. The script must end in SUCCESS for the replication to be deployed correctly. Inspect the 
generated log file Runtime_to_Historical_setup_source.bat.log for any warning or error 
messages. You will see some WARNING responses but you should see no ERROR responses. 

 

__ r. Continue working on the Dashboard Client, open a new DB2 Command Window, Start > All 
Program > IBM DB2 > Command Line Tools > Command Window 

__ s. Change directory into C:\ProjectScenario\schemagen\History\ 

cd C:\ProjectScenario\schemagen\History\ 

__ t. Execute the following command 

Runtime_to_Historical_setup_target.bat 
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__ u. When prompted enter the user ID and password for the HISTORY database, hosted locally on 
the Dashboard Client. Also when prompted, enter the User ID and password to connect to the 
RUNTIME database, also hosted locally on the Dashboard Client. In both cases, the default 
values are ‘db2admin’ and ‘monPa55w0rd’. 

__ v. The script must end in SUCCESS for the replication to be deployed correctly. Inspect the 
generated log file Runtime_to_Historical_setup_target.bat.log for any warning or error messages. 
You will see some WARNING responses but you should see no ERROR responses. 

 

____ 7. Start the State to Runtime capture daemons on the Monitor Server 

Now that the data movement replication has been configured, you must start the replication daemons 
so that data will be copied between STATE, RUNTIME and HISTORY databases. The capture 
daemons should be run on the same server as the database for which they are capturing changes. 
The apply daemons should be run on the same server as the database for which they are applying 
changes. 

This means that the State to Runtime capture daemon will be executed on the Monitor Server (where 
the STATE database is). All of the other daemons will be run on the Dashboard Client (State to 
Runtime apply, Runtime to History capture, Runtime to History apply). 

__ a. Switch to the Monitor Server 
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__ b. Open a Command Prompt and enter the following commands 

cd C:\ProjectScenario\schemagen\State\State_to_Runtime\source\ 
StartCapture_<number>.bat 

Note: You must execute all StartApply scripts – there should be only one for this lab 

 

__ c. The Capture daemon for the State to Runtime replication will be started in a new window. You 
can close the other windows but you must leave this one open: 

 

__ d. At this stage you should have one daemon running on the Monitor Server 
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____ 8. Start the State to Runtime apply daemons on the Dashboard Client server 

Note: Because the STATE database is remote from where this Apply daemon will be running, it is 
necessary to perform additional steps to provide connection credentials to the daemon so that it can 
access the remotely cataloged database. 

__ a. Important: Switch to the Dashboard Client 

__ b. Open a new DB2 Command Window, Start > All Program > IBM DB2 > Command Line Tools 
> Command Window 

__ c. Execute the following commands 

mkdir C:\IBM\WebSphere\Monitor\rm\logs\s2r\apply 
cd C:\IBM\WebSphere\Monitor\rm\logs\s2r\apply 
asnpwd INIT encrypt all using password.aut 
asnpwd ADD alias STATE id db2admin password monPa55w0rd using 
password.aut 

 

__ d. Close the DB2 Command Window 

__ e. Now you must change any StartApply scripts to use the password credentials that you have 
saved in the password.aut file. Open a File Explorer window and locate all StartApply script in 
C:\ProjectScenario\schemagen\Runtime\State_to_Runtime\target\. There should be only one for 
this lab. Open this file in Notepad and amend the final line to add: 

pwdfile="password.aut" 
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__ f. Save and close the Notepad window.  

__ g. Open a Command Prompt and enter the following commands 

cd C:\ProjectScenario\schemagen\Runtime\State_to_Runtime\target 
StartApply_<number>.bat 

Note: You must execute all StartApply scripts – there should be only one for this lab 

 

__ h. The Apply daemon for the State to Runtime replication will be started in a new window. You can 
close the other windows but you must leave this one running: 
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____ 9. Start the Runtime to History capture daemons on the Dashboard Client server 

__ a. Continue working on the Dashboard Client 

__ b. Open a Command Prompt and enter the following commands 

mkdir C:\IBM\WebSphere\Monitor\rm\logs\r2h\capture 
cd C:\ProjectScenario\schemagen\Runtime\Runtime_to_Historical\source 
StartCapture_<number>.bat 

Note: You must execute all StartCapture scripts – there should be only one for this lab 
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__ c. The Capture daemon for the Runtime to Historical replication will be started in a new window. 
You can close the other windows but you must leave this one open. Be careful to not close the 
State to Runtime Apply daemon that you started previously. 

 

____ 10. Start the Runtime to History apply daemons on the Dashboard Client server 

__ a. Continue working on the Dashboard Client server 

__ b. Open a Command Prompt and enter the following commands 

mkdir C:\IBM\WebSphere\Monitor\rm\logs\r2h\apply 
cd C:\ProjectScenario\schemagen\History\Runtime_to_Historical\target 
StartApply_<number>.bat 

Note: You must execute all StartApply scripts – there should be only one for this lab 
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__ c. The Apply daemon for the Runtime to Historical replication will be started in a new window. You 
can close the other windows but you must leave this one open. Be careful to not close the two 
daemons that you started previously. 

 

__ d. At this stage you should have three daemons running on the Dashboard Client 
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Part 4: Import the Model and Run Process Instances 

____ 1. Import the business measures model into the Monitor Server 

__ a. In the Monitor Server admin console, navigate to WebSphere Business Monitor > Server > 
Business Measures Model > Model Import.  Navigate to 
C:\ProjectScenario\schemagen\Monitor.zip   

Note: You must specify the path to the Monitor.zip file in the schemagen folder, not the one in the parent 
folder (C:\ProjectScenario) that you specified earlier. 

 

 

__ b. Click Import. 

Note: This may take some time. 

__ c. You should see a successful message when it completes: 
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____ 2. Run some process instances on the Runtime Server. 

__ a. Start the BPC Explorer on the Runtime Server (by default this is accessible at 
http://localhost:9080/bpc), and run several instances of the ProcessScenario template.  This 
shows the process template: 

 



© Copyright IBM Corporation 2006. All rights reserved 

2006 February, 15 IBM WebSphere Business Monitor 6.0  – Lab Exercise Page 64 of 103 

 End-to-end Scenario 

 

__ b. You should run several processes with an OrderPrice less than 500.  The processes will run and 
complete immediately.  You should run at least one with an OrderPrice greater than or equal to 
500.  This instance will stop, waiting for human task interaction (the Order Approval task).  Do 
not complete the human task, so that this instance will display in the Active Instances view in the 
Dashboard Server.  Note that the process instances are deleted when they are complete, so you 
will not see them listed in the Process Instances list after completion.  This shows the window for 
entering data for a process instance: 
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____ 3. Verify that the process instance data is being stored in the Monitor State database and the Monitor 
Runtime database.  Note that the process instance data is deleted from the State database after it 
has been moved to the Runtime database.  So, if you delay in checking this, then the tables may 
show empty in the State database, but then there should be data in the Runtime database. 

__ a. Start the DB2 Control Center on the Monitor Server.  Select Start > Programs > IBM DB2 > 
General Administration Tools > Control Center.  In the State database look for a table name 
like CTX_*, and the comment ProcessScenario.  This is the process instance data for our 
process.   
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__ b.   Double click on this table and you should see several rows showing process instance data: 

 

 

 

__ c. In the State database look for a table name like AI_*, and the comment ‘Task instance table for 
business measure grouop ProcessScenario’.  This is the task instance data for our process.  
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__ d. In the Runtime database look for a table name like CTR_*, and the comment ProcessScenario.  
This is the process instance data for completed instances.   

 

 

__ e. You should see some rows in this table.  But note that we set the replication frequency to 2 
minutes, so this information will not show up in this table until the time period has elapsed 
following the completion of the process instance.  You may need to wait a few minutes, and then 
click View > Refresh in the DB2 Control Center before checking the table again. 
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__ f. If you do not see data in the State database nor the Runtime database, then something is wrong. 

1) Ensure that CEI logging is turned on in the Runtime Server -- Admin Console > Servers > 
Application servers > server1 > Business process container settings > Business 
process container > Enable Common Event Infrastructure logging. 

2) Turn on the Monitor trace in the Monitor Server, run a few more process instances and 
check for errors in the trace log.  To get trace details, Monitor Server Admin Console > 
Troubleshooting > Logs and Trace > server1 > Change Log Detail Levels.  Specify log 
level for sub-components of com.ibm.wbimonitor .  Then the trace is stored with the 
Process Server logs as trace.log. 
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Part 5: Import Cubes in the Dashboard Server 

____ 1. Import the cube models into DB2 Cube Views.  Note that the remainder of the lab will happen on the 
Dashboard Server. 

__ a. Copy the file C:\Project\Scenario\schemagen\model_cv.xml from the Monitor Server to the 
Dashboard server. 

 

 

__ b. On the Dashboard Server, select Start > Programs > IBM DB2 > Business Intelligence Tools 
> OLAP Center. 

__ c. When prompted, use userid: db2admin, password: monPa55w0rd. 

 

__ d. The first time you connect to the database, you will get this message.  
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__ e. Click Yes. 

__ f. The window should look like this. 

 

__ g. Select OLAP Center > Import.  For file name, browse (the … button) to the file model_cv.xml.  

 

__ h. Click Next. 

__ i. You should see a window like this.   
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__ j. Click Finish. 

__ k. Now you will see three models listed in the OLAP Center as follows.   

 

 

__ l. Close the OLAP Center. 
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____ 2. Define the cubes to Alphablox. 

__ a. If the WebSphere Portal server is not running, start it using Start > IBM WebSphere > 
WebSphere Portal v5.1 > Start the Server. 

__ b. Start Alphablox in a browser Start > All Programs > IBM DB2 Alphablox 8.3 > 
AlphabloxAnalytics > DB2 Alphablox Administrative Pages.   

Note: You may find that Windows will block your attempt to access the page and you should see this in the 
Internet Explorer window in a yellow information bar at the top. Click on this bar and select Allow Blocked 
Content… to continue: 

 

__ c. When it prompts for it, enter userid: admin, password: password.  You should see a window like 
this: 
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__ d. Click on tab ‘Cubes’ at the top of the Alphablox window. Click Create.  You should see a window 
like this: 
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__ e. Click the checkbox ‘Enabled’ next to the DB2 Alphablox Cube Name. 

__ f. Select HISTORY for the Relational Data Source. 

__ g. Click the checkbox ‘Enable DB2 Cube Views Settings’. 

__ h. Select ‘WBI.ProcessScenario’ for the Cube Model, then click button ‘Import Cube Definition’. 

__ i. Type ProcessScenario for the DB2 Alphablox Cube Name (do not include the WBI).  You 
should have a screen like this: 
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__ j. Click OK to save the definition.  Then you will see it added to the list as follows: 
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__ k. You will repeat this for each cube in the model.  In this case there are three cubes, and they are 
listed in the pulldown for Cube Model.   

__ l. We have defined ProcessScenario, now we will define ProcessScenario aggregates. 

__ m. Click create to create the cube definition.  

__ n. Click the checkbox ‘Enabled’ next to the DB2 Alphablox Cube Name. 

__ o. Select HISTORY for the Relational Data Source. 

__ p. Click the checkbox ‘Enable DB2 Cube Views Settings’. 

__ q. Select ‘WBI.ProcessScenario aggregates’ for the Cube Model, then click button ‘Import Cube 
Definition’.  
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__ r. Type ProcessScenario aggregates for the DB2 Alphablox Cube Name (do not include the 
WBI.)  You should have a screen like this: 

 

 

__ s. We have defined ProcessScenario and ProcessScenario aggregates, now we will define 
ProcessScenario_Tasks. 

__ t. Click create to create the cube definition.  

__ u. Click the checkbox ‘Enabled’ next to the DB2 Alphablox Cube Name. 

__ v. Select HISTORY for the Relational Data Source. 

__ w. Click the checkbox ‘Enable DB2 Cube Views Settings’. 

__ x. Select ‘WBI.ProcessScenario_Tasks’ for the Cube Model, then click button ‘Import Cube 
Definition’.  

__ y. Type ProcessScenario_Tasks for the DB2 Alphablox Cube Name (do not include the WBI.)  
You should have a screen like this: 
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__ z. Click OK. Then you will see a window showing all three cubes in the list. 

__ aa. Click on the General tab at the top of the Alphablox window.  Then click Runtime 
Management > DB2 Alphablox Cubes.   



© Copyright IBM Corporation 2006. All rights reserved 

2006 February, 15 IBM WebSphere Business Monitor 6.0  – Lab Exercise Page 79 of 103 

 End-to-end Scenario 

 

__ bb. For each of the cubes listed, click the Start button.  The status should show as ‘Running’ for 
each cube.  Here is an example: 
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Part 6: Configure Dashboards 

____ 1. Make copies of the portlets that we want to use: Active Instances and Reports.  You should not 
configure the original portlets, since the configuration cannot be removed once it is applied.  So we 
will make copies of the portlets, then we will configure the copies. 

__ a. Start Portal: http://localhost:9081/wps/portal. 

 

__ b. Click ‘Log in’ in the upper right-hand corner.  When prompted, enter userid: wpsadmin 
password: wpsadmin. 

__ c. Click on Administration at the top of the page, and then click Portlet Management > Portlets. 
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__ d. Browse to page 11 by clicking on the arrow icons.  This page should show the portlets for Active 
Instances and Reports. 

__ e. On the row containing Active Instances, click the icon for Copy portlet ( )  You should see 
this window: 
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__ f. Click OK. 

__ g. On the row containing Reports, click the icon for Copy portlet ( ).  On the next window, click 
OK. 

__ h. Now Browse to page 12 by clicking on the arrow icons.  This page should show the copies of 
the portlets for Active Instances and Reports. 



© Copyright IBM Corporation 2006. All rights reserved 

2006 February, 15 IBM WebSphere Business Monitor 6.0  – Lab Exercise Page 84 of 103 

 End-to-end Scenario 

 

 

 

____ 2. Create a page containing two views: Active Instances and Reports. 

__ a. Click on Administration at the top of the page, and then click Portal User Interface > Manage 
Pages. 
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__ b. Click My Portal, then click the button ‘New Page’.  Enter a page title ‘NewPage’, click OK, click 
OK.  Now you should see the new page in the list as follows: 
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__ c. Click on the ‘Edit Page Layout’ icon for NewPage. You will find it to the right side of the row for 

NewPage: .  This will open the editor for this page. 
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__ d. Click button ‘Add portlets’ on the left side of the screen.  You will see a list of portlets.  There 
are multiple pages of these and you can use the navigation at the bottom of the list to look at 
them. Find ‘Copy of Active Instances’ (it is on the last page), check it. 
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__ e. Click OK. 

__ f. This shows that the Copy of Active Instances view has been added to the page: 
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__ g. Click button ‘Add portlets’ on the right side of the screen.  Find ‘Copy of Reports’ on the last 
page, check it.  

__ h. Click OK. 

__ i. This shows that both views have been configured on the page: 
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__ j. Click Done. 

__ k. Click My Portal at the top of the page.  This window opens and you see that there is now a tab 
for NewPage. 
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____ 3. Configure the two views on our new page. 

__ a. Click on the tab for NewPage.  This window shows the two views, but they need to be 
configured: 
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__ b. Click on the Configure icon for the Copy of Active Instances view.  
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__ c. Click Business Measures Model > ProjectScenario > Processes. 

__ d. Click Business Measures Groups > ProcessScenario. 

__ e. Click the checkbox next to Business Measures to select all of the measures. 

__ f. Click Next, Next, Next, Finish. 

__ g. Here is the window showing one active process instance in the view: 
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Note: You will only see instances in here if you ran an order process with a value of over $500 and then 
you did not complete the approval task. This results in an active instance. 

__ h. Click the Configure icon on the Copy of Reports view.  
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__ i. Click Subject area and select ProcessScenario on the left side of the window. 

__ j. Click all of the Modeled measures on the right side of the window. 

__ k. Click Next. 

__ l. Click Finish.  

__ m. This windows shows both views configured and showing process data: 
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Part 7: Export Actual Values from Monitor and Import into Modeler 

____ 1. Make a copy of the portlet Export Values. 

__ a. Click on Administration at the top of the page, and then click Portlet Management > Portlets. 

__ b. Browse to page 11 by clicking on the arrow icons.  This page should show the portlet for Export 
Values. 

__ c. On the row containing Export Values, click the icon for Copy portlet.  

__ d. Click OK. 

____ 2. Add the view Copy of Export Values to our existing Portal page ‘NewPage’. 

__ a. Click on Administration at the top of the page, and then click Portal User Interface > Manage 
Pages. 

__ b. You should see a list of pages.  Click on the ‘Edit Page Layout’ icon for NewPage. You will find 

it to the right side of the row for NewPage: .  This will open the editor for this page. 

 

 

__ c. Click the button ‘+ Add portlets’ on the left side of the screen. 
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__ d. Navigate to page 12, select Copy of Export Values, and then click OK. 

__ e.  Now, you should see the Copy of Export Values view has been added to the page: 

 

__ f. Click Done. 

____ 3. Export Actual Values to a file. 

__ a. Click on ‘My Portal’ at the top of the window. 

__ b. Click on the tab ‘New Page’ and you will see the new view Copy of Export Values. 
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__ c. Set the dates for ‘From’ and ‘To’ to valid dates for your process instances. 

__ d. Expand Business Measures Model, then ProcessScenario and select Processes. 

__ e. Click Export Link, you should see a dialog for File Download.  Click Save and it will store the 
file on your disk as ‘exportedFile.xml’. 

____ 4. Import the Actual Values to Modeler. 

__ a. Start WebSphere Business Modeler pointing to workspace C:\ProjectScenario\ModelerWs. 

__ b. If it is open, close the editor for the process ProcessScenario. 

__ c. Right click on ProjectScenario in the project tree, and then click Import. 

__ d. Select import type ‘Monitoring result (.xml)’ then click Next. 



© Copyright IBM Corporation 2006. All rights reserved 

2006 February, 15 IBM WebSphere Business Monitor 6.0  – Lab Exercise Page 100 of 103 

 End-to-end Scenario 

__ e. Browse to the directory containing ‘exportedFile.xml’, then select the file in the list then click 
Next.  You should see this window: 

 

__ f. If you would like to see a list of matching elements, click ‘display matching elements’. 

__ g. Click Finish. 

__ h. After the import completes, you should see a dialog box indicating that it finished successfully; 
click OK. 

__ i.  Double click on ProcessScenario > Processes > ProcessScenario in the Project Tree to open 
the editor for the process and then click the tab Diagram. 

__ j. In the process diagram, you will see that the decision percentages have been updated with actual 
values on the decision ‘Is order less than $500?’.  Originally they were set to 50% each. 
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__ k. Click on the white background in the process diagram, under the tab ‘Attributes – 
ProcessScenario’, click on sub-tab Duration.  Here you see that the estimated duration of the 
process has been updated with actual values. 

 

__ l. Also, you can click on any of the three tasks, and then under the tab ‘Attributes – <taskName>’, 
click on sub-tab Duration.  Here you see that the estimated duration of the task has been 
updated with actual values.  
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What you did in this exercise 

In the lab, you imported a model into WebSphere Business Modeler, created business measures and 
exported it to Monitor and WebSphere Process Server. 

Then you imported the process model into WebSphere Integration Developer and implemented the 
process model.  Then you deployed the process to WebSphere Process Server. 

You ran schema generation, created Monitor database and replication manager artifacts.  You started the 
replication manager daemons. 

You imported the cubes to Cube Views and Alphablox. 

You configured Dashboards and viewed process data in two different types of views. 

Finally, you exported actual values from WebSphere Business Monitor and imported them into WebSphere 
Business Modeler. 
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