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What this exercise is about 

The objective of this lab is to show you how to build a monitor model in Rational Application Developer or 
WebSphere Integration Developer, deploy it to WebSphere Business Monitor, and then view your 
monitored data on the Monitor dashboards. 

This lab will show you Business Activity Monitoring (BAM) which involves event based monitoring.  With 
BAM, you can have your monitored application running anywhere, and submitting events to the Monitor 
server so that you can view monitored data.  Typically, you identify the events that are created by the 
application, and then create a monitor model that represents the monitored data that you want to collect 
from the events. 

Changes from the previous version 

This lab has been modified significantly from the previous 6.0.2 release.  Here are the major changes: 

• In the monitor model, you can reference other KPIs when defining the calculation for a given KPI. 

• KPIs are now based on a metric and aggregation function, and not based on cube measures, so 
the dimensional model is now simplified. 

• Deploying the model has been dramatically simplified, so this is a very short process now. 

• LDAP is not required, so now you can test alerts without installing LDAP. 
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• Portal is no longer a requirement, so configuration of a dashboard is simplified. 

Lab requirements 

List of system and software required for the student to complete the lab: 

• Rational Application Developer V7.0 or WebSphere Integration Developer V6.1. 

• WebSphere Business Monitor V6.1 – Toolkit Installation including the Monitor Model editor and  
Monitor Server 

o DB2 Alphablox is an optional prerequisite for the installation of the Monitor toolkit.  If you 
choose not to install it, then you will not be able to use the report and dimension views in the 
Web dashboard. 

What you should be able to do 

At the end of this lab you should be able to: 

• Use Rational Application Developer or WebSphere Integration Developer to create the monitor model, 
and deploy it to the server. 

• Use a sample program to create events that represent events from your process. 

• Define a dashboard to view monitored data. 

 

Introduction 

In this lab you will learn how to deploy a model from end to end using Rational Application Developer or 
WebSphere Integration Developer and WebSphere Business Monitor.  This lab will show you the basic 
procedure for creating and implementing a simple model.   

The model used in this lab is the ClipsAndTacks  model which is also used in IBM Redbook SG247148 – 
Business Process Management: Modeling through Monit oring Using WebSphere V6.0.2 Products .  
In the Redbook, there are several models that are referenced, but in this lab you will be using the Future 1 
Process.  In the Redbook, the process is implemented as a BPEL process running in WebSphere Process 
Server.  However this lab will demonstrate Business Activity Monitoring  which can monitor events from 
any source.  So, the lab will simulate the running of the process, by creating events that could have been 
sourced from anywhere, a Java EE application or BPEL, or any other source.  These events are in the 
form of Common Base Events, which is an OASIS standard for common event format. These events are 
used by the Common Event Infrastructure (CEI) in WebSphere Process Server. 

In this lab you will build a monitor model that has the same basic elements as the one that is defined in the 
Redbook.  Namely you will create monitoring constructs in support of two KPIs: 

• Average order fulfillment is 3 days or less 

• Percentage of shipped orders is greater than 90% 
 
You will also create situation events if declined orders are greater than or equal to 3 and if the order 
fulfillment time is greater than 3 days. 

For dimensional analysis, you will create a Location dimension which allows you to drill down on country 
and city.  You will also add an Order Status metric, which shows orders as 'New', 'Cancelled' or 'Shipped'.  
And you will add measures for average order price, sum of order price for all orders, and order count. 
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Here is a diagram of the ClipsAndTacks process model: 

 

This is the ordering process for the Clips And Tacks company.  In this process, orders are received and 
optionally submitted to a review process.  Orders which pass all checks are shipped to the customer.  
Other orders may be cancelled. 

In the monitor model, you will create one monitoring context for each customer order.  You will identify the 
inbound event that represents the receipt of the order, and this is marked so that it will create a new 
monitoring context instance for the order.  You will also identify the inbound event that represents shipping 
the order, and this is marked so that it will trigger the termination of the monitoring context instance for the 
order.  Since an order might also be cancelled, you will identify the inbound event that represents 
cancellation of the order, and this is also marked so that it will trigger the termination of the monitoring 
context instance. 

URL Cheat sheet  

These URLs might be helpful to you as you do this exercise.  Note that the port numbers in the URL of 
your installation might be different depending on your configuration.  

• Server administrative console 

http://localhost:9061/ibm/console/ 

• Web dashboard 

http://localhost:9081/BusinessDashboard/ 
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Part 1: Create the monitor model 

To create the monitor model, you will use the monitor model editor in Rational Application Developer or 
WebSphere Integration Developer.  Note that the screen captures in this lab are based on WebSphere 
Integration Developer, so they may differ slightly from yours if you are using Rational Application 
Developer. 

Note that there is a 'Problems' tab that displays errors concerning the model.  Periodically, you should 
check this view to see if you have any problems that need to be addressed.  Normally, warnings and 
informational messages are not a problem, but errors should be addressed. 

If you want to skip this section, a solution has been provided.  You can import the supplied monitor model 
into Rational Application Developer or WebSphere Integration Developer, and then proceed to the next 
section.  Refer to Appendix 1, and then proceed to the next section. 

 

____ 1. Start Rational Application Developer or WebSphere Integration Developer and setup the 
environment. 

__ a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted 
point to a new workspace such as c:\workspaces\ClipsAndTacks 

__ b. Close the Welcome tab. 

__ c. By default, you are in the Business Integration perspective but you need to open the Business 
Monitoring perspective.   

1) Select Window > Close Perspective  

2) Select Window > Open Perspective > Business Monitoring .   

3) If it asks you to Confirm Enablement, then click OK. 

__ d. You should close the help view by clicking the 'x' in the 'Help' tab. 

__ e. You should see this Business Monitoring perspective: 
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____ 2. Create a new monitoring project.  A project is a container for your monitor models and event 
definitions. 

__ a. Right click the Project Explorer, then select New > Business Monitoring Project…  

__ b. For Project name, enter ClipsAndTacks  

__ c. Click Finish.  You will see the new project in the Project Explorer view. 

 

____ 3. There is a predefined common base event definition for you that represents the event layout for 
events processed in this model.  Import the supplied common base event for ActivityEvent. 

__ a. From the Project Explorer view, right-click on ClipsAndTacks  and select Import…  

__ b. Select General > File system , click Next  
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__ c. Browse to the location containing the ActivityEvent cbe , for example, 
c:\Labfiles61\ClipsAndTacks 

__ d. Select ActivityEvent.cbe  as follows: 

 

 

 

 

 

 

 

 

 

 

 

 

 

__ e. Click Finish . 

__ f. Expand the project in the Project Explorer view, then expand the Event Definitions and you will 
see the new event listed. 

 

__ g. Double click ActivityEvent.cbe  to open the event editor.  Browse the extended data elements to 
familiarize yourself with the event data for this model.   

1) ActivityEventData contains data elements that relate to the activities in the process.  The 
fields, businessUnit and processName, are used to filter out unwanted events that do not 
relate to this particular model.  The field activityName is used to associate an event with a 
specific activity in the process.  The field eventType is used to identify the state of the 
activity, either starting or completing.  



© Copyright IBM Corporation 2008. All rights reserved 

2008 February, 25 IBM WebSphere Business Monitor 6.1 – Lab exercise Page 7 of 58 

 ClipsAndTacks 

2) OrderBOData contains data elements that relate to the specifics of a customer order, such 
as orderNumber, country, city, totalPrice, and so on. 

 

__ h. WebSphere Business Monitor has support for concurrent versions of monitor models. In order to 
take advantage of the Monitor server's version handling capabilities, each monitoring context 
must have a unique inbound event that has the setting 'If no instances are found: Create new 
instance'.  One can think of this as one inbound event carrying 'create monitor context' 
semantics, and all other inbound events as 'update monitor context' semantics. The inbound 
event for creating monitoring context instances can be identified in two ways.  It can have a 
unique event definition name with a separate event definition, or it can use an existing event 
defintion but be identified by unique filter condition information.  For Clips And Tacks, there is a 
unique inbound event name, New Order Event, that should create new monitoring context 
instances, so now you will create the event definition for it. 

1) Right click on Event Definitions and select New > Event Definition… (cbe).  

2) Enter NewOrderEvent.cbe  for the file name 
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3) Click Finish . 

4) The Event Definition Editor for NewOrderEvent opens. 

 

5) The NewOrderEvent has the same data elements as the Activity Event, so you can just 
show ActivityEvent as the parent, then NewOrderEvent will inherit that data element layout.  
Double click the hierarchical icon next to the label Parent .  

6) On the Select Event Definition  Dialog double click on ActivityEvent . 

 

7) ActivityEvent  is now shown as the parent of NewOrderEvent  
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8) Press Ctrl-S  to save your work. 

____ 4. Create a new monitor model ClipsAndTacks.  The monitor model contains the metrics and KPIs that 
you want to monitor and it is the source for creating the deployment code for the monitor server. 

__ a. Right click in the Project Explorer view, then select New > Monitor Model…  

__ b. For File name, enter ClipsAndTacks . 

 

__ c. Click Finish .  The model editor is opened as follows: 

Note: When the model editor first opens you will have errors in the model. This is normal and is signaling 
that required elements are missing or incomplete. Next you will complete these required elements. 
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____ 5. Notice in the Monitor Details Model navigator that a new model is created (ClipsAndTacks) along 
with a monitoring context (ClipsAndTacks MC).  Now you need to specify the inbound events that 
are processed by this model.  You need to indicate which event creates a new monitoring context 
instance and which event terminates the monitoring context instance.  You also need to identify the 
correlation information for the monitoring context so that Monitor knows which monitoring context 
instance should receive the events.  The ClipsAndTacks model uses one event definition, 
ActivityEvent, to represent the layout of all of the events to be processed. NewOrderEvent derives 
from ActivityEvent but does not add additional event elements.  In ActivityEvent, ActivityName is a 
field used to identify specific activities in the ClipsAndTacks process.  ActivityName is used to 
determine when to terminate the monitoring context.  You will create correlation that is based on 
orderNumber, which is another field defined in ActivityEvent.  

__ a. In the Monitor Details Model, expand ClipsAndTacks in the navigation view.  Then expand 
ClipsAndTacks MC.  You will see that a key has been created for you automatically when you 
created the model. 

 

__ b. In the model navigation view, right click on ClipsAndTacks MC, then select New > Inbound 
Event.  
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__ c. For the name, type Activity Event .  Notice that the ID will automatically be set for you to the 
same name with underscores (Activity_Event ). 

 

__ d. Click OK. 

__ e. On the window for Event Type Details , you need to enter the extension name, so click on 
Browse…  and navigate to ClipsAndTacks > ActivityEvent.cbe > ActivityEvent 

__ f. To enter the Filter  Condition , you can use Content Assist with ctrl-space, or you can type the 
expression directly into the expression window.  When completed, the expression should be as 
follows.  Note the single quotation marks used for string handling. 

Activity_Event/extendedData/ActivityEventData/businessUnit = 'Clips And Tacks' and 
Activity_Event/extendedData/ActivityEventData/processName = 'Order Handling' 

__ g. To enter the Correlation  Expression , you can use Content Assist (ctrl-space), or you can type 
the expression directly into the expression window.  When complete, the expression should be  

ClipsAndTacks_Key=Activity_Event/extendedData/OrderBOData/orderNumber 

__ h. For 'If no instances are found', select 'Treat as error' 

__ i. For 'If one instance is found', select 'Deliver to the instance' 

__ j. For 'If multiple instances are found', select 'Treat as error' 

__ k. Here is a sample of a portion of the definition: 
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__ l. Press Ctrl-S  to save your work. 

__ m. In the model navigation view, right click on ClipsAndTacks MC, then select New > Inbound 
Event.  Note that you can also right click on any child element within the monitoring context and 
you will have access to the same menu. 

__ n. For the name, type New Order Event .  Notice that the ID will automatically be set for you to the 
same name with underscores (New_Order_Event ). 

__ o. Click OK. 

__ p. For Event Type Details, navigate to ClipsAndTacks > NewOrderEvent.cbe > NewOrderEvent 

__ q. To enter the Filter Condition, you can use Content Assist (ctrl-space), or you can type the 
expression directly into the expression window.  When complete, the expression should be as 
follows.  Note the single quotation marks used for string handling. 

New_Order_Event/extendedData/ActivityEventData/businessUnit='Clips And Tacks' and 
New_Order_Event/extendedData/ActivityEventData/processName='Order Handling' 

__ r. To enter the Correlation Expression, use Content Assist or type the expression directly into the 
expression window.  When complete, the expression should be  

ClipsAndTacks_Key=New_Order_Event/extendedData/OrderBOData/orderNumber 

__ s. For 'If no instances are found', select 'Create new instance' 

__ t. For 'If one instance is found', select 'Treat as error' 

__ u. For 'If multiple instances are found', select 'Treat as error' 

__ v. Press Ctrl-S  to save your work. 

__ w. In the model navigation view, double click ClipsAndTacks Key , to open the key in the editor. 

__ x. For Key Value Expressions, click 'Add…'.  Note that double clicking in the table will produce the 
same results. 

__ y. A row is added to the table and in the expression cell it shows << No expression specified >>.  
Click on this cell of the table, then a button is displayed.  Click on this button and the expression 
editor is displayed.  You can use Content Assist, or type this expression directly into the window: 

New_Order_Event/extendedData/OrderBOData/orderNumber 

__ z. Click OK. 

__ aa. Here is a sample of the key: 
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__ bb. Press Ctrl-S  to save your work. 

Note: At this point there should not be any errors remaining in the model. The errors shown initially were 
the result of the monitoring context key not being complete. 

____ 6. Create triggers that indicate the end of the monitoring context.  The first trigger is based on an order 
being shipped, and the second trigger is based on an order being cancelled. 

__ a. In the model navigation view, right click on ClipsAndTacks MC , then select New > Trigger .  
Enter these values: 

1) Name - Ship Order to Customer Trigger 

2) ID - Ship_Order_to_Customer_Trigger 

3) Select the check box next to 'Terminate monitoring context' 

4) For Trigger Sources, click Add, then select Other source type > Activity Event, then click 
OK. 

5) For Trigger Condition, enter 
Activity_Event/extendedData/ActivityEventData/activityName='Ship Order to Customer' and 
Activity_Event/extendedData/ActivityEventData/eventType='completed' 

__ b. Press Ctrl-S  to save your work. 

__ c. Here is a sample of this trigger: 
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__ d. In the model navigation view, right click on ClipsAndTacks MC, then select New > Trigger .  
Enter these values: 

1) Name - Cancel Trigger 

2) ID - Cancel_Trigger 

3) Select the check box next to 'Terminate monitoring context' 

4) For Trigger Sources, click Add, then select Other source type > Activity Event, then click 
OK. 

5) For Trigger Condition, enter 
Activity_Event/extendedData/ActivityEventData/activityName='Cancel Order and Send 
Notification' and Activity_Event/extendedData/ActivityEventData/eventType='completed' 

__ e. Press Ctrl-S  to save your work. 

____ 7. Create a KPI for Average fulfillment 3 days or less.  First you will create a trigger which fires when a 
new order is started.  Metrics are created to hold the order start time and order end time.  The 
values of the metrics are set when the new order trigger fires.  You create a duration metric which is 
calculated based on subtracting the order end time metric from the order start time metric.  You will 
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create a KPI context which is a container to hold your KPIs.  Then you create a KPI which is based 
on the duration metric and you apply an average function to it. 

__ a. In the model navigation view, right click on ClipsAndTacks MC, then select New > Trigger .  
Enter these values: 

1) Name – New Order Trigger 

2) ID – New_Order_Trigger 

3) For Trigger Sources, click Add, then select Other source type > New Order Event, then click 
OK. 

4) For Trigger condition, enter 
New_Order_Event/extendedData/ActivityEventData/activityName='Check Order Handling 
Policy for Automatic Approval' and 
New_Order_Event/extendedData/ActivityEventData/eventType='started' 

5) Press Ctrl-S  to save your work. 

__ b. In the model navigation view, right click on ClipsAndTacks MC, then select New > Metric .  Enter 
these values: 

1) Name – Order Start Time 

2) ID – Order_Start_Time 

3) Type – DateTime 

4) For Metric Value Expressions, click Add 

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger. 
A button is shown; click the button and select Trigger type > ClipsAndTacks MC > New 
Order Trigger, click OK 

6) In the first row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text:  

New_Order_Event/extendedData/ActivityEventData/startTime  

7) Click OK. 

8) Press Ctrl-S  to save your work. 
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__ c. In the model navigation view, right click on ClipsAndTacks MC, then select New > Metric .  Enter 
these values: 

1) Name – Order End Time 

2) ID – Order_End_Time 

3) Type - DateTime 

4) For Metric Value Expressions, click Add 

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC 
> Ship Order to Customer Trigger, click OK 

6) In the first row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text:  

Activity_Event/extendedData/ActivityEventData/endTime  

7) Click OK. 

8) For Metric Value Expressions, click Add 

9) In the second row of the Metric Value Expressions table, select the cell under column 
Trigger, then a button is shown, then click the button and select Trigger type > 
ClipsAndTacks MC > Cancel Trigger, click OK 

10) In the second row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text:  

Activity_Event/extendedData/ActivityEventData/endTime  
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11) Click OK. 

__ d. Press Ctrl-S  to save your work. 

  

__ e. In the model navigation view, right click on ClipsAndTacks MC, then select New > Metric .  Enter 
these values: 

1) Name – Order Fulfillment Duration 

2) ID – Order_Fulfillment_Duration 

3) Type - Duration 

4) For Default Value, click Edit… 

5) On the Select Duration dialog, click OK, and this will set the default duration to zero. 

6) For Metric Value Expressions, click Add 

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC 
> Ship Order to Customer Trigger, click OK 

8) In the first row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text:  

xs:dayTimeDuration (Order_End_Time - Order_Start_Time)  

9) Click OK. 

10) For Metric Value Expressions, click Add 
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11) In the second row of the Metric Value Expressions table, select the cell under column 
Trigger, then a button is shown, then click the button and select Trigger type > 
ClipsAndTacks MC > Cancel Trigger, click OK 

12) In the second row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text:  

xs:dayTimeDuration (Order_End_Time - Order_Start_Time)  

13) Click OK. 

__ f. Press Ctrl-S  to save your work. 

 

__ g. Click the KPI Model tab . 

__ h. Create a KPI context to store the KPIs. 

1) In the navigation view of the KPI Model, right click on ClipsAndTacks, then select New > 
KPI Context  

a) Name – My KPI Context 

b) ID -  My_KPI_Context 

__ i. Create the average order fulfillment KPI.   

Note that you will create the KPI based on events for August 2006.  This will work for you no matter what 
month or year that you run this lab because the timestamps in the test data are based on August 2006, so 
your results will be the same as in these lab instructions. 
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1) In the navigation view of the KPI Model, right click on My KPI Context , then select New > 
KPI 

a) Name – Average Order Fulfillment KPI August 2006 

b) ID -  Average_Order_Fulfillment_KPI_August_2006 

2) Enter these values: 

a) Type – Duration 

b) In KPI Target and Ranges, for Target click Details…, then change the value to 3 
Days, then click OK 

c) In KPI Target and Ranges, for Ranges select Actual value 

d) In the Range table,  

(1) Click Add, or double click anywhere in the table 

(2) Change the Name to Day 1, and the ID to Day_1 

(3) A row is created in the Range table with a range name Day 1.   

(4) For this row, the default in the Start column is 0 milliseconds, which is what 
you want. 

(5) For this row, select the cell in the End value column and a button is 
displayed.  Click this button, then change Days to 1 and the other values 
to 0, then click OK. 

e) Now you have created one range called Day 1.  Repeat the above step to create 
four more ranges: 

(1) Day 2 with start values 1 Days and end value 2 Days 

(2) Day 3 with start values 2 Days and end value 3 Days 

(3) Day 4 with start values 3 Days and end value 4 Days 

(4) Day 5 with start values 4 Days and end value 5 Days 

f) KPI Value – select 'Base this KPI on a metric and an aggregation function.' 

g) Under KPI Details, for Monitoring context, click Browse…, then select 
'ClipsAndTacks MC', then click OK 

h) Metric – click Browse…, then select Order Fulfillment Duration, then click OK 

i) Aggregation function – select Average. 

j) Under Time Filter, for Metric, click Browse…, then select Order Start Time, then click 
OK 

k) Specify time period – Fixed 

l) Start date – click Edit... then select date 2006-08-01, time 00:00:00, click OK 

m) End date – click Edit…, then select 2006-08-31, time 23:59:59, click OK 
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3) Press Ctrl-S  to save your work. 
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__ j. Note that this KPI as it stands averages order fulfillment time for shipped orders and cancelled 
orders, but you probably are not interested in the cancelled orders to be included in this KPI.  So 
update the average order fulfillment KPI to show the values for shipped orders only.  First, create 
a new metric to hold the order status.  Then add this metric as a data filter on the KPI. 

__ k. Click the Monitor Details Model tab . 

__ l. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New > 
Metric .  Enter these values: 

1) Name – Order Status 

2) ID – Order_Status 

3) Type – String 

4) 4) Select 'A value is required for this metric'.  The editor requires that you select this 
whenever you use a metric as a source for a dimension in the dimensional model. 

5) Default Value (enter this text with single quotation marks) – 'New' 

6) For Metric Value Expressions, click Add 

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC 
> Cancel Trigger, click OK 

8) In the first row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text with the 
quotation marks: 

'Cancelled' 

9) Click OK. 

10) For Metric Value Expressions, click Add 

11) In the second row of the Metric Value Expressions table, select the cell under column 
Trigger, then a button is shown, then click the button and select Trigger type > 
ClipsAndTacks MC > Ship Order to Customer Trigger, click OK 

12) In the second row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text with the 
quotation marks: 

'Shipped' 

13) Press Ctrl-S  to save your work 
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__ m. Update the order fulfillment KPI to use the order status as a filter. 

1) Click the KPI Model tab . 

2) In the KPI Model navigation view, navigate to ClipsAndTacks > My KPI Context > Average 
Order Fulfillment KPI August 2006 

3) In the Data Filter section for this KPI, click Add 

4) In the dialog, navigate to ClipsAndTacks MC > Order Status, then click OK 

5) In the row containing metric Order Status, make sure the operation defaults to 'equals'.  
Also, click the cell in the column Values, then enter this text (with quotation marks): 

'Shipped' 

6) Press Ctrl-S  to save your work. 

 

____ 8. Create a KPI for number of approved orders greater than 90%.  First you will create a KPI to count 
the number of total orders.  Then you will create a KPI to count the number of shipped orders.  
Finally, you will create a KPI that calculates the approval percentage as this formula: (ship count / 
order count) * 100. 
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__ a. Click the KPI Model tab  then create the order count KPI. 

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
KPI 

a) Name – Order Count KPI 

b) ID -  Order_Count_KPI 

2) Enter these values: 

a) Type – Decimal 

b) Do not specify targets nor ranges 

c) KPI Value – select 'Base this KPI on a metric and an aggregation function.' 

d) Under KPI Details, for Monitoring context, click Browse…, then select 
'ClipsAndTacks MC', then click OK 

e) Metric – click Browse…, then select ClipsAndTacks Key, then click OK 

f) Aggregation function – select Count. 

3) Press Ctrl-S  to save your work. 

__ b. Create the ship count KPI. 

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
KPI 

a) Name – Ship Count KPI 

b) ID -  Ship_Count_KPI 

2) Enter these values: 

a) Type – Decimal 

b) Do not specify targets nor ranges 

c) KPI Value – select 'Base this KPI on a metric and an aggregation function.' 

d) Under KPI Details, for Monitoring context, click Browse…, then select 
'ClipsAndTacks MC', then click OK 

e) Metric – click Browse…, then select ClipsAndTacks Key, then click OK 

f) Aggregation function – select Count. 

g) In the Data Filter section for this KPI, click Add 

h) In the dialog, navigate to ClipsAndTacks MC > Order Status, then click OK 

i) In the row containing metric Order Status, make sure the operation defaults to 
'equals'.  Also, click the cell in the column Values, then enter this text (with 
quotation marks): 

'Shipped' 
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3) Press Ctrl-S  to save your work. 

__ c. Create the percent of orders approved KPI. 

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
KPI 

a) Name – Percent of Orders Approved KPI 

b) ID -  Percent_of_Orders_Approved_KPI 

2) Enter these values: 

a) Type – Decimal 

b) In KPI Target and Ranges, for Target click Details…, then change the value to 90, 
then click OK 

c) In KPI Target and Ranges, for Ranges select Actual value 

d) In the Range table,  

(1) Click Add 

(2) Change the Name to Low Range, and the ID to Low_Range 

(3) A row is created in the Range table with a range name Low Range.   

(4) For this row, select the cell in the Start value column and a button is 
displayed.  Click this button, then change the value to 0, then click OK. 

(5) For this row, select the cell in the End value column and a button is 
displayed.  Click this button, then change the value to 90, then click OK. 

e) Repeat the above step to create one more range: 

(1) High Range with start value 90 and end value 100 

f) KPI Value – select 'Write an expression to calculate this KPI based on existing KPIs' 

g) For KPI Calculation, enter this text: 

 fn:round((Ship_Count_KPI div Order_Count_KPI) * 100) 

3) Press Ctrl-S  to save your work. 
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____ 9. In the dashboards, you might like to see the total order price, the average order price and the total 
number of orders.  And you might be interested in seeing this information by country and city, and 
by order status.  So now you will create dimensions and measures that allow you to see this 
information.  For aggregated numeric information like total order price, you will create a measure in 
the dimensional model.  For textual attributes like order status, you will create a dimension in the 
dimensional model.  In order to see the country and city information, you will create a multi-level 
location dimension containing country as the first level and city as the second level.  Each measure 
and dimension needs a metric as a source, so you will also need to create metrics for country, city 
and total price. 

__ a. Click on the Dimensional Model tab . 

__ b. Add order status as a dimension to the Dimensional Model.   

1) In the navigation view, click on ClipsAndTacks MC Cube 

2) In the dimensions table, click New Dimension…  

a) Name – Order Status Dimension 

b) ID – Order_Status_Dimension 

c) Click OK 

3) Click New Level…  

a) Name – Order Status 

b) ID – Order_Status 
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c) Source metric – Click Browse…, then select ClipsAndTacks MC > Order Status.  
Then click OK. 

d) Click OK. 

4) Press Ctrl-S  to save your work. 

  

__ c. Click the Monitor Details Model tab . 

__ d. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New 
> Metric .  Enter these values: 

1) Name – country 

2) ID – country 

3) Type –  String 

4) Select 'A value is required for this metric'.  The editor requires that you select this whenever 
you use a metric as a source for a dimension in the dimensional model. 

5) For default value, enter an empty string (two single quotation marks) 

6) For Metric Value Expressions, click Add 

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC 
> New Order Trigger, click OK 

8) In the first row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text: 

a) New_Order_Event/extendedData/OrderBOData/country 

9) Click OK. 

10) Press Ctrl-S  to save your work 

 

__ e. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New 
> Metric .  Enter these values: 

1) Name – city 

2) ID – city 

3) Type –  String 

4) Select 'A value is required for this metric'.  The editor requires that you select this whenever 
you use a metric as a source for a dimension in the dimensional model. 

5) For default value, enter an empty string (two single quotation marks) 
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6) For Metric Value Expressions, click Add 

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC 
> New Order Trigger, click OK 

8) In the first row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text: 

a) New_Order_Event/extendedData/OrderBOData/city 

9) Click OK. 

10) Press Ctrl-S  to save your work 

__ f. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New > 
Metric .  Enter these values: 

1) Name – totalPrice 

2) ID – totalPrice 

3) Type –  Decimal 

4) For Metric Value Expressions, click Add 

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC 
> New Order Trigger, click OK 

6) In the first row of the Metric Value Expressions table, select the cell under column 
Expression, then a button is shown, then click the button and enter this text: 

a) New_Order_Event/extendedData/OrderBOData/totalPrice 

7) Click OK. 

8) Press Ctrl-S  to save your work 

__ g. Click on the Dimensional Model tab . 

__ h. Add location as a dimension to the Dimensional Model.   

1) In the navigation view, click on ClipsAndTacks MC Cube 

2) In the dimensions table, click New Dimension…  

a) Name – Location 

b) ID – Location 

c) Click OK 

3) Click New Level…  

a) Name – Country 

b) ID – Country 



© Copyright IBM Corporation 2008. All rights reserved 

2008 February, 25 IBM WebSphere Business Monitor 6.1 – Lab exercise Page 28 of 58 

 ClipsAndTacks 

c) Source metric – Click Browse…, then select ClipsAndTacks MC > country.  Then 
click OK. 

d) Click OK. 

4) Click New Level…  

a) Name – City 

b) ID – City 

c) Source metric – Click Browse…, then select ClipsAndTacks MC > city.  Then click 
OK. 

d) Click OK. 

5) Press Ctrl-S  to save your work. 

 

__ i. Ensure that the Dimensional Model tab  is selected. 

__ j. In the Dimensional Model, add a measure for average order price. 

1) In the navigation view, click on ClipsAndTacks MC Cube  

2) In the Measures table, click New … 

a) Name – Average Order Price 

b) ID – Average_Order_Price 

c) Source metric - Click Browse…, then select ClipsAndTacks MC > totalPrice. 

d) Aggregation function – select Average.   

e) Then click OK. 

3) Press Ctrl-S  to save your work. 

  

__ k. In the Dimensional Model, add a measure for sum of order price. 

1) In the navigation view, click on ClipsAndTacks MC Cube  

2) In the Measures table, click New … 

a) Name – Sum Order Price 
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b) ID – Sum_Order_Price 

c) Source metric - Click Browse…, then select ClipsAndTacks MC > totalPrice. 

d) Aggregation function – select Sum.   

e) Then click OK. 

3) Press Ctrl-S  to save your work. 

__ l. In the Dimensional Model, add a measure for order count. 

1) In the navigation view, click on ClipsAndTacks MC Cube  

2) In the Measures table, click New … 

a) Name – Order Count 

b) ID – Order_Count 

c) Source metric - Click Browse…, then select ClipsAndTacks MC > ClipsAndTacks 
Key. 

d) Aggregation function – select Count.   

e) Then click OK. 

3) Press Ctrl-S  to save your work. 

 

____ 10. In the dashboards you might like to see the average order price and track that relative to a target. 

__ a. Create a KPI for the average order price. 

1) Click the KPI Model tab . 

2) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
KPI 

a) Name – Average Order Price KPI (Dollars) 

b) ID -  Average_Order_Price_KPI__x0028_Dollars_x0029_ 

3) Enter these values: 

a) Type – Decimal 

b) In KPI Target and Ranges, for Target click Details…, then change the value to 300, 
then click OK 

c) In KPI Target and Ranges, for Ranges select Actual value 

d) In the Range table,  
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(1) Click Add 

(2) Change the Name to Low Range, and the ID to Low_Range 

(3) A row is created in the Range table with a range name Low Range.   

(4) For this row, select the cell in the Start value column and a button is 
displayed.  Click this button,  then change the value to 0, and then click 
OK. 

(5) For this row, select the cell in the End value column and a button is 
displayed.  Click this button, then change the value to 300, and then click 
OK. 

e) Now you have created one range called Low Range.  Repeat the above step to 
create one more range: 

(1) High Range with start value 300 and end value 1000 

f) KPI Value – select 'Base this KPI on a metric and an aggregation function.' 

g) Under KPI Details, for Monitoring context, click Browse…, then select 
'ClipsAndTacks MC', then click OK 

h) Metric – click Browse…, then select totalPrice, then click OK 

i) Aggregation function – select Average. 

4) Press Ctrl-S  to save your work. 
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____ 11.  (Optional)  To demonstrate the use of a counter, you can optionally use this section to create a 
counter which is incremented if you ship the order (rather than canceling the order).  For every 
monitoring context, this counter is either zero or one, depending on whether the order is cancelled 
or shipped.  Counters would be more useful in other scenarios – perhaps to count the number of 
times an iterated activity is run.  

__ a.  In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New 
> Counter .  Enter these values: 

1) Name – Ship Counter 

2) ID – Ship_Counter 

3) For Counter Controls, click Add, then select ClipsAndTacks MC > Ship Order to Customer 
Trigger, click OK 

4) Note that the Resulting Action defaults to Add One, which is correct. 

__ b. Press Ctrl-S  to save your work 
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____ 12.  (Optional) )  To demonstrate the use of a stopwatch, you can optionally use this section to create a 
timer which will measure the duration of the monitoring context.  You might find this useful in the 
dashboard instances view to quickly see which monitoring contexts have not been terminated. 

__ a. In the model navigation view, right click on ClipsAndTacks MC, then select New > Stopwatch .  
Enter these values: 

1) Name – Monitoring Context Timer 

2) ID – Monitoring_Context_Timer 

3) For Stopwatch Controls, click Add, then select ClipsAndTacks MC > New Order Trigger,  
then click OK. 

4) Note that the default Resulting Action is Start 

5) For Stopwatch Controls, click Add, then select ClipsAndTacks MC > Ship Order to 
Customer Trigger,  then click OK. 

6) Note that the default Resulting Action is Start, but you need to change it to Stop for this 
trigger.  So click on the second row in column Resulting Action.  A drop down box is 
shown, so pick Stop in the list. 

7) For Stopwatch Controls, click Add, then select ClipsAndTacks MC > Cancel Trigger,  then 
click OK. 

8) Note that the default Resulting Action is Start, but you need to change it to Stop for this 
trigger.  So click on the second row in column Resulting Action.  A drop down box is 
shown, so pick Stop in the list. 

__ b. Press Ctrl-S  to save your work.  
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____ 13. Create a business situation event when the number of declined orders is greater than or equal to 3.  
First you will create an event defintion for the outbound situation event.  You will create a field called 
BusinessSituationName which is a required field for the outbound situation event.  You will create a 
KPI that will track the total number of declined orders.  Then you will create a trigger which is fired 
when the number of declined orders is greater than or equal to 3.  Then you define an outbound 
event that is fired by the trigger.  In this outbound event, you provide a value for the field 
BusinessSituationName, which is used later when configuring action manager in the server 
administrative console. 

__ a. Create an event definition for declined orders. 

1) In Project Explorer, right click on ClipsAndTacks and select New > Event Definition… (cbe)  

2) For file name, enter DeclinedOrderEvent.cbe 

3) Click Finish 

4) The Event Definition Editor for DeclinedOrderEvent opens. 

5) Double click the hierarchical icon next to the label Parent .  

6) On the Select Event Definition  Dialog double click on event  under Matching events. 

7) Event  is now shown as the parent of DeclinedOrderEvent  

8) On the event definition, click the icon for Add Extended Data .  This adds a row to the 
Extended Data table. 

9) For the new data element, change the Extended Data name from 'data1' to 
'BusinessSituationName' by clicking on data1 and typing the new name. 

10) For the new element, change the type to string.  Do this by clicking on 'noValue' and then 
you are given a drop down box. 
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11) Press Ctrl-S  to save your work. 

  

__ b. Create a KPI for declined orders. 

1) Click the KPI Model tab  for the ClipsAndTacks model. 

2) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
KPI 

a) Name – Declined Order KPI 

b) ID -  Declined_Order_KPI 

3) Enter these values: 

a) Type – Decimal 

b) In KPI Target and Ranges, for Target click Details…, then change the value to 3, 
then click OK 

c) In KPI Target and Ranges, for Ranges select Actual value 

d) In the Range table,  

(1) Click Add 

(2) Change the Name to Low Range, and the ID to Low_Range 

(3) A row is created in the Range table with a range name Low Range.   

(4) For this row, select the cell in the Start value column and a button is 
displayed.  Click this button, then change the value to 0, and then click 
OK. 

(5) For this row, select the cell in the End value column and a button is 
displayed.  Click this button, then change the value to 3, and then click 
OK. 

e) Now you have created one range called Low Range.  Repeat the above step to 
create one more range: 

(1) High Range with start value 3 and end value 10 

f) KPI Value – select 'Base this KPI on a metric and an aggregation function.' 

g) Under KPI Details, for Monitoring context, click Browse…, then select 
'ClipsAndTacks MC', then click OK 

h) Metric – click Browse…, then select 'ClipsAndTacks Key', then click OK 
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i) Aggregation function – select Count. 

j) In the Data Filter section for this KPI, click Add 

k) In the dialog, navigate to ClipsAndTacks MC > Order Status, then click OK 

l) In the row containing metric Order Status, make sure the operation defaults to 
'equals'.  Also, click the cell in the column Values, then enter this text (with 
quotation marks): 

'Cancelled' 

4) Press Ctrl-S  to save your work. 

 

__ c. Create a trigger to fire the outbound situation event. 

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
Trigger   

a) Name – Declined Order Trigger 

b) ID -  Declined_Order_Trigger 

2) Enter these values: 

a) Under Trigger Sources, click Add. 

b) Select Recurring wait time, then click OK 
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c) In the Source column you see the default wait time is 1 minute.  

d) In Trigger Condition, enter this text: 

Declined_Order_KPI >= 3 

3) Press Ctrl-S  to save your work. 

  

__ d. Create an outbound situation event for declined orders. 

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
Outbound Event  

a) Name – Declined Order Outbound Event 

b) ID -  Declined_Order_Outbound_Event 

c) Select 'Configure this event to generate an alert in the dashboards' 

d) For trigger, click Browse…, then select My KPI Context > Declined Order Trigger, 
then click OK 

2) Enter these values: 
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a) For extension name, click Browse…, then select ClipsAndTacks > 
DeclinedOrderEvent.cbe > DeclinedOrderEvent, then click OK 

b) Under Event Attributes Details, click Add 

c) Select My KPI Context > Declined Order Trigger, then click OK 

d) In the table, expand Extended Data, then on the same row as 
BusinessSituationName, set Expression to (include the quotation marks): 

'Too many orders have been declined' 

3) Press Ctrl-S  to save your work. 

 

 

____ 14. Create a business situation event when the order fulfillment duration is greater than 3 days.  First 
you will create an event defintion for the outbound situation event.  You will create a field called 
BusinessSituationName which is a required field for the outbound situation event, and you will 
create another field for the average order processing time which will eventually be placed into the 
alert body.  You do not need to create a KPI since there is already a KPI containing the average 
processing time.  You will create a trigger which is fired when the average processing time is greater 
than 3 days.  Then you will define an outbound event which is fired by the trigger.  In this outbound 
event, you will provide a value for the field BusinessSituationName which is used later when 



© Copyright IBM Corporation 2008. All rights reserved 

2008 February, 25 IBM WebSphere Business Monitor 6.1 – Lab exercise Page 38 of 58 

 ClipsAndTacks 

configuring action manager in the server administrative console, and you will populate the field on 
the event containing the average order processing time. 

__ a. Create an event definition for average order processing time. 

1) In Project Explorer, right click on ClipsAndTacks and select New > Event Definition… (cbe)  

2) For file name, enter LateAverageOrderShippedEvent.cbe 

3) Click Finish 

4) The Event Definition Editor for LateAverageOrderShippedEvent opens. 

5) Double click the hierarchical icon next to the label Parent .  

6) On the Select Event Definition  Dialog double click on event . 

7) Event  is now shown as the parent of LateAverageOrderShippedEvent  

8) On the event definition, click the icon for Add Extended Data .  This adds a row to the 
Extended Data table. 

9) For the new data element, change the Extended Data name from 'data1' to 
'BusinessSituationName' by clicking on data1 and typing the new name. 

10) For the new element, change the type to string.  Do this by clicking on 'noValue' and then 
you are given a drop down box. 

11) On the event definition, click the icon for Add Extended Data.  This adds a second row to 
the Extended Data table. 

12) For the second data element, change the Extended Data name to 
AverageOrderProcessingTime 

13) For the second element, change the type to string. 

14) Press Ctrl-S  to save your work. 

  

__ b. Create a trigger to fire the outbound situation event. 

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
Trigger   

a) Name – Order Fulfillment Timer Trigger 

b) ID -  Order_Fulfillment_Timer_Trigger 

2) Enter these values: 
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a) Under Trigger Sources, click Add. 

b) Select Recurring wait time, then click OK 

c) In the Source column you see the default wait time is 1 minute.  

d) In Trigger Condition, enter this text: 

Average_Order_Fulfillment_KPI_August_2006 ge dayTimeDuration 
('P3DT1H') 

3) Press Ctrl-S  to save your work. 

  

__ c. Create an outbound situation event for average order processing time. 

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New > 
Outbound Event  

a) Name – Order Fulfillment Outbound Event 

b) ID -  Order_Fulfillment_Outbound_Event 

c) Select 'Configure this event to generate an alert in the dashboards' 

d) For trigger, click Browse…, then select My KPI Context > Order Fulfillment Timer 
Trigger, then click OK 
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2) Enter these values: 

a) For extension name, click Browse…, then select ClipsAndTacks > 
LateAverageOrderShippedEvent.cbe > LateAverageOrderShippedEvent, then click 
OK 

b) Under Event Attributes Details, click Add 

c) Select My KPI Context > Order Fulfillment Timer Trigger, then click OK 

d) In the table, expand Extended Data, then on the same row as 
BusinessSituationName, set Expression to (include the quotation marks): 

'Average shipment is too late' 

e) In the table, expand Extended Data, then on the same row as 
AverageOrderProcessingTime, set Expression to: 

xs:string(xs:decimal(Average_Order_Fulfillment_KPI_August_2006) div 86400) 

 

Note: Here the decimal function converts the duration to seconds, so then it can be divided by 86400 
which will give you the number of days. 

3) Press Ctrl-S  to save your work. 
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____ 15. Check for any errors in the Problems view.  You should resolve any errors before continuing.  
Warnings and informational messages might be present but these are not a problem. 
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Part 2: Publish the model to the server 

 

In this section you will use Rational Application Developer or WebSphere Integration Developer to publish 
the monitor model to the monitor server. 

____ 1. In Project Explorer, expand ClipsAndTacks ���� Monitor models ���� ClipsAndTacks.mm . Right 
click over ClipsAndTacks.mm  and then select Generate Monitor J2EE Projects  from the context 
menu 

____ 2. Select Finish . 

____ 3. A progress dialog shows the status of the operation and it closes when the operation is complete.  
Check for errors in the Problems view.  There may be warnings, but there should not be any errors.  
If you see errors, then try to perform a clean to see if the errors can be removed:  Project > Clean… 
> select 'Clean all projects', then click OK. 

____ 4. Click the Servers tab, then right click and select the Start  option to start the server WebSphere 
Business Monitor V6.1.  This may take a few minutes to complete. 

  

____ 5. Right click in the servers view, then select Add and Remove Projects….  

____ 6. Click Add  to move the ClipsAndTacksApplication from the list of available projects to the list of 
configured projects. 
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____ 7. Click Finish . 

____ 8. A progress message is displayed in the lower right corner of the window. 

  

____ 9. Check the messages in the console view.  You should see this message when the application has 
been started:   

  Application started: ClipsAndTacksApplication 

____ 10. In the servers view, right click, then select Run administrative console .  You should see it open in 
a separate tab.  It will prompt you for user ID and password.  Enter 'admin' without the quotation 
marks for user ID, then enter 'admin' without the quotes for password. 

____ 11. Click Log in  

____ 12. Click Applications > Monitor Models .  The application should show green status if it started 
successfully. 
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____ 13. If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the 
right of Status in the last column of the table. You should see green (started) for the model.  If it 
does not show green, be patient and keep refreshing until it does show green. 

____ 14. Check the server log to ensure there are no problems. You can check this in the console view. 

____ 15. If you are using the integrated server within WebSphere Integration Developer or Rational 
Application Developer, then you do not need to setup Monitor data security, since the administrator 
is automatically authorized to all models.  If you are using a different server, then you should open 
the administrative console, navigate to Security > Monitor Data Security , and then add the model, 
role and user information to a resource group. 
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Part 3: Configure action manager for business situa tion events 

This section shows you how to configure action manager to create alerts based on business situation 
events defined in the monitor model.  The alerts will be visible in the Alert view on your dashboard. 

You do not need an LDAP server to test the situation events. 

____ 1. Add a template for declined order alerts. 

__ a. In the administrative console, navigate to Applications > Monitor Action Services > Template 
Definitions > Notifications.   

__ b. Click New. 

__ c. Enter AlertDeclined  as Template name and a description. 

__ d. Select Dashboard Alert.  

__ e. Select User id.  

__ f. For the To field, enter admin.  This user ID is the one that will receive the alert, so you must log 
into the dashboard with this user ID. 

__ g. Enter a subject. 

__ h. Enter the body. 
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__ i. Click OK. 

____ 2. Add a template for order processing time alerts. 

__ a. In the administrative console, navigate to Applications > Monitor Action Services > Template 
Definitions > Notifications.  

__ b. Click New. 

__ c. Enter AlertLate  as Template name and a description. 

__ d. Select Dashboard Alert.  

__ e. Select User id.  

__ f. For the To field, enter admin.  This user ID is the one that will receive the alert, so you must log 
into the dashboard with this user ID. 

__ g. Enter a subject. 

__ h. Enter the body, and you can optionally enter a substitution variable as shown below.  For the 
alert that is sent, the average order processing time from the event payload is substituted for 
%AverageOrderProcessingTime% in the body.  For example: 

 The average order processing time is %AverageOrderProcessingTime% days. 



© Copyright IBM Corporation 2008. All rights reserved 

2008 February, 25 IBM WebSphere Business Monitor 6.1 – Lab exercise Page 47 of 58 

 ClipsAndTacks 

  

__ i. Click OK. 

____ 3. Add the binding from the situation event to the action type for declined orders. 

__ a. In the administrative console, navigate to Applications > Monitor Action Services > Installed 
Situation Event Bindings.  

__ b. Click New. 

__ c. Enter the situation event name that you defined in the model.  In this lab, you created a business 
situation name as follows:  

  Too many orders have been declined  
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__ d. This must match exactly the value in the BusinessSituationName field in the outbound event.  
You might want to copy/paste from the model.  Here is a screen capture from the model showing 
the Declined Order Outbound Event attributes: 

  

__ e. Enter a description, then click Apply . 

__ f. Click Add . 

__ g. Enter a binding name, then select the template AlertDeclined.  

 

__ h. Click OK. 

__ i. Notice that you now have one action defined for this situation event.  If you had other action 
templates defined, you could add more actions to this event.  So then you could send a 
notification for this situation to multiple destinations including e-mail, alerts and Web services. 
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__ j. Click OK. 

____ 4. Add the binding from the situation event to the action type for order processing time. 

__ a. In the administrative console, navigate to Applications > Monitor Action Services > Installed 
Situation Event Bindings.  

__ b. Click New. 

__ c. Enter the situation event name that you defined in the model.  In this lab, you created a business 
situation name as follows: 

 Average shipment is too late  

__ d. .  This must match exactly the value in the BusinessSituationName field in the outbound event.  
You might want to copy/paste from the model 

__ e. Enter a description, then click Apply . 

__ f. Click Add . 

__ g. Enter a binding name, then select the template AlertLate , then click OK. 

__ h. Click OK. 

____ 5. In the administrative console, navigate to Applications > Monitor Action Services > Installed 
Situation Event Bindings.  You should see two bindings as follows: 
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Part 4: Run events to exercise the model 

 

Rather than installing a Java EE application to create the events that you want to monitor, you are going to use 
a program to simulate the submission of events from the application.   

The supplied program is 'BatchCBEWriter61' and it will submit the events to the Common Event Infrastructure.  
Look for the program in \Labfiles61\ClipsAndTacks\BatchCBEWriter.  This program reads XML files which 
represent the Common Base Events for the model. 

____ 1. Update BatchCBEWriter61.bat to point WAS_HOME to the monitor server home, for example 'set 
WAS_HOME=C:\IBM\WebSphere\AppServer'.  If you are using the integrated monitor server in 
WebSphere Integration Developer, the path is <WID-Install-Path>\pf\WBMonSrv_wps.  If you are 
using the integrated monitor server in Rational Application Developer, the path is <RAD-Install-
Path>\pf\WBMonSrv. 

____ 2. Update config.properties, setting the serverName and portNumber.  You can find the port number 
by browsing the server log and finding 'bootstrap port'.  For example, check for the log at 
C:\IBM\WebSphere\AppServer\profiles\WBMon01\logs\server1\SystemOut.log . For the integrated 
server in WebSphere Integration Developer, the path is <WID-Install-
Path>\pf\WBMonSrv_wps\logs\server1\SystemOut.log and the portNumber is 2810.  For the 
integrated server in Rational Application Developer, the path is <RAD-Install-
Path>\pf\WBMonSrv\logs\server1\SystemOut.log and the portNumber is 2810.  Here is an example 
of the config.properties settings: 

__ a. connect.serverName = localhost 

__ b. connect.portNumber = 2810 

____ 3. Open a command window, then change directory to the folder containing BatchCBEWriter61, for 
example, type this command 

__ a. cd \Labfiles61\ClipsAndTacks\BatchCBEWriter 

____ 4. Run commands to load the common base events to the server. 

__ a. batchcbewriter61 -Dsource.filename="c:/labfiles61/clipsandtacks/cbe/allevents.xml" 

__ b. When it prompts you for user identity and password, enter 'admin' for both (without the quotation 
marks) 

____ 5. When you run BatchCBEWriter61, you should see results such as: 
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Part 5: Create a dashboard 

In this section you will build a dashboard.  You will add views to the dashboard and configure them. 

____ 1. Open the dashboard. 

__ a. In Rational Application Developer or WebSphere Integration Developer, click Window > Web 
Browser.  The default browser is 'Internal Web Browser', but you should not use this one since 
some standard functions that you might need are not provided.  Select 'Default system Web 
browser' or any other listed browser other than the internal browser. 

__ b. In Rational Application Developer or WebSphere Integration Developer, in the servers view, right 
click and select WebSphere Business Monitor Dashboard  

__ c. When prompted, enter admin  for the user ID and enter admin  for the password.  You must log in 
with 'admin' so that you can view the alerts which were setup in action manager to be sent to this 
particular user ID.  Also, in the toolkit environment, this is the user that is automatically defined 
on the secured server. 

__ d. Click the Dashboards  tab. 

 

__ e. Click New, then enter a name for the dashboard, then click OK. 

 

__ f. Click Add to Dashboard , then select Instances , then click OK.  Note that you can also add a 
view by dragging the view from the palette on the right and dropping it onto the dashboard. 

  

__ g. Click Personalize . 
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__ h. Click the Advanced  tab, and select model 'ClipsAndTacks (All Versions)' 

 

__ i. Click the Show/Hide  tab. 

__ j. Click >> to copy all the metrics from the available list to the selected list.   

 

__ k. Then click OK.  You should see a list of monitoring context instances for the events that you just 
processed. 

 

__ l. There are two pages of results, so if you browse through these instances, you see that there are 
4 cancelled orders.  Since you setup an alert if declined orders is greater than or equal to 3, then 
an alert should be displayed in the alert view. 
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__ m. Click Add to Dashboard , then select Alerts , then click OK.  The alerts view is added to your 
dashboard, and you should see alerts listed since the model processed 3 or more cancelled 
orders, and the average order processing time is greater than 3 days. 

 

__ n. You can click on an alert in the list, then you will get a pop-up showing the details of the alert. 
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What you did in this exercise 

In the lab, you created a monitor model using Rational Application Developer or WebSphere Integration 
Developer. 

Then you published the model to the monitor server. 

You also configured action manager to create alerts based on business situation events. 

You used the supplied program to simulate the submission of events from the monitored application. 

You configured dashboards and viewed monitored data in several different types of views. 
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Appendix 1 – Import the solution into the monitor m odel editor 

A solution has been provided so that you do not have to build the model from scratch.  This section shows 
you how to import the monitor model into Rational Application Developer or WebSphere Integration 
Developer.  After importing the model then you can proceed to the section to publish the model to the 
server. 

 

____ 1. Start Rational Application Developer or WebSphere Integration Developer and setup the 
environment. 

__ a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted 
point to a new workspace such as c:\workspaces\ClipsAndTacks 

__ b. Close the Welcome tab. 

__ c. You want to open the Business Monitoring perspective.  Select Window > Open Perspective > 
Business Monitoring .   

__ d. If it asks you to Confirm Enablement, then click OK. 

____ 2. Create a new monitoring project. 

__ a. Right click the Project Explorer, then select New > Business Monitoring Project…  

__ b. For Project name, enter ClipsAndTacks  

__ c. Click Finish.  You will see the new project in the Project Explorer view. 

____ 3. Import the supplied mm and cbe files. 

__ a. Right click in the Project Explorer view, and then select Import…  

__ b. Select General > File system , click Next . 

__ c. Browse to the location containing the files, for example, c:\Labfiles61\ClipsAndTacks 

__ d. Select ActivityEvent.cbe  

__ e. Select ClipsAndTacks.mm  

__ f. Select DeclinedOrderEvent.cbe  

__ g. Select LateAverageOrderShippedEvent.cbe  

__ h. Select NewOrderEvent.cbe  

__ i. Click Finish .  

____ 4. Expand the project in the Project Explorer view, then expand the Event Definitions and you will see 
the new events listed.  Expand Monitor Models and you will see the new ClipsAndTacks model 
listed. 

____ 5. Now you can proceed to the section to publish the model to the server. 
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