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What this exercise is about 

The objective of this lab is to show you how to monitor a business process which was developed in 
WebSphere Business Modeler, implemented in WebSphere Integration Developer and deployed to 
WebSphere Process Server. 

This lab will provide solutions that you can import into Modeler and WebSphere Integration Developer, so 
then you can concentrate on building the monitor model, deploying it, running tests and viewing monitored 
data in the dashboards. 

Lab requirements 

List of system and software required for the student to complete the lab: 

• WebSphere Business Modeler V6.1. 

• WebSphere Integration Developer V6.1. 

• WebSphere Business Monitor V6.1 – Toolkit Installation including the Monitor Model editor and  
Monitor Server 
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o DB2 Alphablox is an optional prerequisite for the installation of the Monitor toolkit.  If you 
choose not to install it, then you will not be able to use the report and dimension views in the 
Web dashboard. 

What you should be able to do 

At the end of this lab you should be able to: 

• Use Modeler to export the business measures model and process model. 

• Use WebSphere Integration Developer to implement the monitor model, and deploy it to the server. 

• Define a dashboard to view monitored data. 

 

Introduction 

In this lab you will learn how to deploy a monitor model from end to end using WebSphere Business 
Modeler, WebSphere Integration Developer and WebSphere Business Monitor.  This lab will show you the 
basic procedure for creating and implementing a simple model.   

The model used in this lab is the ClipsAndTacks  model which is also used in IBM Redbook SG247148 – 
Business Process Management: Modeling through Monit oring Using WebSphere V6.0.2 Products .  
In the Redbook, there are several models that are referenced, but in this lab you will be using the Future 1 
Process.   

In this lab you will build a monitor model that has the same basic elements as the one that is defined in the 
Redbook.  Namely you will create monitoring constructs in support of two KPIs: 

• Average order fulfillment is 3 days or less 

• Percentage of shipped orders is greater than 90% 
 
You will also create situation events when the average order fulfillment time is greater than 3 days, and 
when the percentage of orders shipped is less than 85%. 

For dimensional analysis, you will create a Location dimension which allows you to drill down on country 
and city.  You will also add an Order Status metric, which shows orders as 'New', 'Cancelled' or 'Shipped'.  
And you will add measures for average order price, sum of order price for all orders, and order count. 

Here is a diagram of the ClipsAndTacks process model: 
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This is the ordering process for the Clips And Tacks company.  In this process, orders are received and 
optionally submitted to a review process.  Orders which pass all checks are shipped to the customer.  
Other orders may be cancelled. 

When you build the monitor model, first you will auto-generate a monitor model from the BPEL process.  
This monitor model will have the necessary monitor elements to create and terminate monitoring context 
instances, and to correlate BPEL events with the monitoring context instances.  You will also import the 
business measures model that was created in Modeler.  This model contains the high level business 
measures and KPI's that you want to create in the final monitor model.  So then you will merge the 
business measures model from Modeler with the auto-generated monitor model. 

URL cheat sheet  

The following URLs may be helpful to you as you exercise this lab.  Note that the port numbers in the URL 
of your installation may be different depending on your configuration.  

• Server administrative console 

http://localhost:9061/ibm/console/ 

• Web dashboard 

http://localhost:9081/BusinessDashboard/ 
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Part 1: Import the model into Modeler 

Instead of building the process model from scratch, you will import the model into WebSphere Business 
Modeler.  You will review the process model and the business measures model. 

____ 1. Start WebSphere Business Modeler and setup the environment. 

__ a. Start WebSphere Business Modeler, and when prompted point to a new workspace such as 
c:\workspaces\clipsmodel 

__ b. A quickstart wizard will pop up, click the Cancel button. 

__ c. Close the Welcome tab. 

__ d. Click Modeling  > Mode  > WebSphere Process Server . 

____ 2. Import the supplied Modeler project. 

__ a. Right click in the Project Tree, then select Import … 

__ b. Select WebSphere Business Modeler project (.mar, .zip)  

__ c. Browse  to the supplied mar file, for example, 
c:\Labfiles61\ClipsAndTacksBPM\CATOrderMgmt.mar 

__ d. For target project , click New to create a new project.  You can take the defaults to create the 
project. 

__ e. On the import dialog, click Finish . 

____ 3. Review the process. 

__ a. In the Project Tree, navigate to CATOrderMgmt > Processes > Order Handling (Future 1 ), 
then double click on the process to open the editor.  In the editor, you can review the diagram 
which represents the process model.  Notice that there are various tasks, decisions, human 
tasks, plus one business rule. 
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__ b. For each task in the diagram, click the task, then click the Attributes tab and review the 
information.  For implementation details, click the Technical Attributes View tab.  You will see 
these implementations: 

1) Check Order Handling Policy for Automatic Approval – rule group.  Click the Business 
Rules tab and you will find that a business rule is used to check the order price and require 
manual approval if it is greater than or equal to $750. 

2) Review Order – human task 

3) Ship Order to Customer – human task 

4) Check Customer Account Status – java 

5) Cancel Order and Send Notification – java 

6) Update Order Database – java 

____ 4. Review the business measures. 

__ a. Click the Business Measures tab. 

__ b. On the Business Performance Indicators tab, review the listed KPIs and aggregate metrics.  For 
each item, you can click the Edit Details button to see more information. 

 

__ c. On the Monitored Values tab, review the values that will be returned to Modeler from the 
monitored data. 
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____ 5. Export to WebSphere Business Monitor. 

__ a. Right click in the Project Tree on CATOrderMgmt, then select Export > WebSphere Business 
Monitor Development Toolkit (.mm). 

__ b. Click Next. 

__ c. Browse to a target directory, then click Finish . 

____ 6. Export to WebSphere Integration Developer. 

__ a. Right click in the Project Tree on CATOrderMgmt, then select Export > WebSphere Integration 
Developer.  

__ b. Click Next . 

__ c. Browse to a target directory.   Do not select Enable default events. 

__ d. Click Next . 

__ e. Click Finish . 

____ 7. Close WebSphere Business Modeler. 
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Part 2: Import the process into WebSphere Integrati on Developer 

In this section you will import the process from Modeler into WebSphere Integration Developer.  Normally, 
then you would implement the various tasks in the process, but to save some time you will import a 
solution which already has the implementions for the tasks.  Using the best practice approach, Modeler 
has automatically created three separate projects, one for the process (CATOrderMgmt), one for the 
implementation (CATOrderMgmt_impl) and one for a library of common elements (CATOrderMgmt_lib). 

 

____ 1. Start WebSphere Integration Developer and setup the environment. 

__ a. Start WebSphere Integration Developer, and when prompted point to a new workspace such as 
c:\workspaces\clipsbpm 

__ b. Close the Welcome tab. 

__ c. By default, you are in the Business Integration perspective. 

____ 2. Import the process. 

__ a. In the Business Integration view, right click then select Import … 

__ b. Navigate to Other > Project Interchange  then click Next . 

__ c. For the .zip file, browse to the output file from Modeler, for example, 'CATOrderMgmt_2007-10-
15T10.12.26.zip'.  Note that the timestamp in your file name will be different. 

__ d. You should see three projects listed, so click Select All . 

__ e. Click Finish . 

__ f. You should see three projects listed in the Business Integration view, one for the process 
(CATOrderMgmt), one for the implementation (CATOrderMgmt _impl) and one for a library of 
common elements (CATOrderMgmt _lib): 

 

____ 3. Import the implementation solution. 

__ a. In the Business Integration view, right click then select Import … 

__ b. Navigate to Other > Project Interchange  then click Next . 

__ c. For the zip file, browse to the supplied file, for example,  

c:\Labfiles61\ClipsAndTacksBPM\CATOrderMgmt-PI.zip 

__ d. Select all projects. 

__ e. Click Finish .  Click OK to confirm overwrite. 
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__ f. If you see errors, then try to clean the workspace by selecting Project > Clean … > select 'Clean 
all projects' , then click OK. 

__ g. If you would like to review the implementation, in the Business Integration view, navigate to 
CATOrderMgmt_impl > Business Logic .  You will find three Java implementations. 

1) CheckCustomerAccountStatus – Java is used to calculate the credit amount for the 
customer.  When you run an instance of the business process, you will enter the old credit 
rating and old credit amount.  This routine calculates a new credit rating which is a random 
number between 500 and 800.  It calculates a new credit amount which is based on an 
adjustment to the old credit amount, using this formula: newAvailCredit = oldAvailCredit 
+((newRating-oldRating)*0.1).  

2) The other two Java implementations just print messages to the log. 

__ h. If you would like to review the BPEL process, in the Business Integration view, navigate to 
CATOrderMgmt > Business Logic > Processes > process es\orderhandlingfuture1 , then 
double click on OrderHandlingFuture1  to open the BPEL editor.  This is a summary of the flow: 

1) Check Order Handling Policy for Automatic Approval.  Implemented as a business rule.  If 
Order.totalPrice < 750, go to Check Customer Account Status, else go to Review Order 

2) Check Customer Account Status.  Implemented as Java to calculate a new credit amount.  
If Order.totalPrice > new credit amount, go to Review Order else go to Ship Order to 
Customer. 

3) Review Order.  Implemented as a human task.  If ReviewOrder.OrderStatus is APPROVED 
then go to Ship Order to Customer else if ReviewOrder.OrderStatus is DECLINED go to 
Cancel Order and Send Notification. 

4) Ship Order to Customer.  Implemented as a human task.  Goes to Update Order Database. 

5) Cancel Order and Send Notification. Implemented as Java to print messages to the log.  
This is the end of the flow. 

6) Update Order Database.  Implemented as Java to print messages to the log.  This is the 
end of the flow. 
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Part 3: Update the BPEL process to emit monitor eve nts 

Before you create the monitor model, you should select the events to be generated by Process Server for 
Monitor to use.  You will need to emit events for the process and the invokes in the process.  Modeler 
decisions become links in BPEL, so to emit events for the links you need to emit events for the flow 
element in BPEL.   

You can access the payload from several events including the SCA ENTRY events, receive activity EXIT 
events or the invoke activity ENTRY events.  If you use the SCA events, then the auto-generated monitor 
model will not have a termination trigger so this option requires extra effort to add the termination trigger.  
You could use the receive activity EXIT event, but in this lab you will use the first invoke in the process to 
access the payload.   

____ 1. In the Business Integration view, navigate to CATOrderMgmt > Business Logic > Processes > 
processes\orderhandlingfuture1 , then double click on OrderHandlingFuture1  to open the BPEL 
editor.   

____ 2. Click on the white backbround of the process.  Make sure that you click outside of the flow element 
which is the large rectangle that contains the receive, reply and invoke elements .  Then click the 
Properties  tab, then click the Event  Monitor  tab.  For a production application, you would want to 
select the individual events to emit, but for simplicity, select All . 

____ 3. Click inside the flow element OrderHandlingFuture1_Flow , and then click All  on the Event Montor 
tab. 

____ 4. Similarly, select All  events for each of the six invokes.  You will select each invoke in the BPEL 
diagram then update the Event Monitor tab.  Update these invokes: 

__ a. Check Order Handling Policy for Automatic Approval 

__ b. Check Customer Account Status 

__ c. Review Order 

__ d. Ship order to Customer 

__ e. Cancel Order and Send Notification 

__ f. Update Order Database 

____ 5. Press Ctrl-S  to save your work. 

____ 6. Here is a screen print that shows the small yellow flags that indicate that the events are selected for 
the components.  There are flags on each of the six invokes.  The flag in the upper left represents 
the flow.  The flag in the upper right represents the process.  So there are eight flags in total. 
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Part 4: Create the monitor model 

To create the monitor model, you will use the wizard to auto-generate the monitor model from the process.   

You will then have two monitor models, the business measures model from Modeler (the high level model) 
and the monitor model generated from the process (the low level model).  The high level model contains 
the monitor elements that you need to implement in the final monitor model.  The low level model contains 
the monitoring context instance creation, termination and correlation information based on the events 
generated from WebSphere Process Server.   

You have three options with regard to using these two monitor models: 

1. Keep both models intact and create outbound events from the low level model to feed metric 
information to the high level model.  This options supports synchronization support for both models 
to easily handle changes made to the process or changes made to the business measures model.  
But this option also requires extra work to build the event definitions and the monitor elements to 
support it. 

2. Keep the high level model intact, and add important inbound events to the high level model using 
‘New > Create from Application’, and then copy / paste them into the monitoring context for the 
high level model.  This option is simple, and may be useful when the low-level application is stable, 
but the business measure requirements are churning.  But this option does not support 
synchronization support with the process application. 

3. Keep the low level model intact, and add business measures information to the low level model 
from the high level model using copy / paste.  This option is simple, and may be useful when the 
low-level application is churning, but the business measure requirements are stable.  But this 
option does not support synchronization support with the business measures from Modeler. 

For this lab, you will use option three.  So you will need to merge the two models into one monitor model.  
Then you will add the implementation details for the KPI's and other monitor elements. 

If you would like to skip this section, then a solution has been provided.  You can import the supplied 
monitor model into WebSphere Integration Developer, and then proceed to the next section.  Refer to 
Appendix 1, and then proceed to the next section. 

____ 1. Generate the monitor model from the process. 

__ a. In the Business Integration view, right click on the folder CATOrderMgmt , then select Monitor 
Tools > Generate Monitor Model.  

__ b. For target monitor project, enter clips  

__ c. Click New Project…  , then click Finish  

__ d. For target monitor model name, enter clipsbpm  

__ e. Click Next  

__ f. In Event Source, navigate to CATOrderMgmt > CATOrderMgmtModule > Order Handling 
(Future 1) > Order Handling (Future 1)  and select the latter as follows: 
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__ g. On the Monitoring Templates  tab, click Select All.  The generated monitor model will contain 
monitoring elements to track all of these items.  One of these is the average process duration 
which will satisfy the requirement in the business measures model to track processing time. 

__ h. In Event Source, navigate to CATOrderMgmt > CATOrderMgmtModule > Order Handling 
(Future 1) > Order Handling (Future 1) > OrderHandl ingFuture1_Flow and select it as 
follows: 

 

__ i. On the Emitted Events  tab, click Select All.  The generated monitor model will subscribe to 
events for the flow which includes events for the decisions which are represented in BPEL by 
links in the flow. 

__ j. In the business measures model, it was specified to track processing time for the tasks, so click 
the monitoring template for elapsed duration for each activity.  To do this, select Cancel Order 
and Send Notification, as in the following screen print.  Then on the Monitoring Templates  tab, 
select Average Elapsed Duration - Measure  

 

1) Repeat this for the remaining three invokes and the two human tasks.  It is not necessary to 
do it for the receive element, Order Handling (Future 1)Receive.  Nor is it necessary to do it 
for the empty element, Acceptable Credit Risk?. 

__ k. Click Next  

__ l. On the next page, you should simplify the monitor model by flattening the structure of the monitor 
model so that there is only one monitoring context.  You will create event groups to organize the 
events and provide some structure in the monitor model. 
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1) For each of the six invokes change the implementation to Event group . 

2) Here is a sample: 

 

3) Click Next.  You can preview the model here. 

4) Click Finish .  When prompted, click yes to switch to the Business Monitoring perspective.  
When prompted, do not launch getting started. 

5) The monitor model is opened in the monitor model editor. 

6) You should check the Problems view.  If you have forgotten to emit monitor events in the 
module that the monitor model requires based on your configuration, then warnings will 
appear to indicate that the events are missing.  If you see these messages, you should 
update the monitor event settings in the module and then synchronize the model with the 
application (in the project explorer, right click on the model > Synchronize with 
Application…). 

 

____ 2. Import the business measures model from Modeler 

__ a. In the Project Explorer, right click on the clips  project, then select Import … 

__ b. Select General > File system , click Next  

__ c. Browse to the location containing the business measures model from Modeler, then select the 
two svg files and the monitor model as follows: 

 

__ d. Make sure the into folder is clips, then click Finish .  
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__ e. There will be many errors in the Problems view because the metrics for the business measures 
model have not been implemented yet. 

__ f. Now you should have the auto-generated model (clipsbpm.mm) and the business measures 
model (Order Handling(Future 1).mm) in your clips project: 

 

____ 3. You need to merge these two monitor models together.  You have several options.  You could use 
the menu options Combine Monitor Models or Compare With > Each Other.  Since the names of 
the monitoring contexts, KPI contexts and cubes are different between the two models, using the 
merge tools will result in a monitor model containing two monitoring contexts, two KPI contexts and 
two cubes.  The merge options work better if both models start from a common base, so that these 
containers have the same name.  In this example, it is easier to just copy the monitor elements 
using copy/paste functions from one model to the other. 

__ a. Open the editor for both monitor models, clipsbpm.mm  and Order Handling(Future 1).mm , by 
double clicking on each of them in the Project Explorer. 

__ b. Copy the elements from the Order Handling to clipsbpm. 

1) Click the Monitor Details Model tab for Order Handling.  Select all six percentage metrics,  
and click to copy: 

a) Acceptable Credit Risk? No Percentage 

b) Acceptable Credit Risk? Yes Percentage 

c) Account in Good Standing? No Percentage 

d) Account in Good Standing? Yes Percentage 

e) Approve Without Review? No Percentage 

f) Approve Without Review? Yes Percentage 
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2) Click the Monitor Details Model tab in clipsbpm, then right click on Order Handling (Future 
1) and paste the metrics that you copied. 

3) Press Ctrl-S  to save your work. 

4) There are several additional metrics in the details model for Order Handling.  These are for 
processing time, but you will not need them since they were created automatically in 
clipsbpm, because you selected the duration monitoring templates in the generation 
wizard. 

5) Click the KPI Model tab for Order Handling.  Select all four elements, the 2 KPI's and the 2 
triggers.  Click to copy. 

 

6) Click the KPI Model tab in clipsbpm, then right click on Template KPI Context and paste the 
elements that you copied. 

7) Press Ctrl-S  to save your work. 

8) Click the Dimensional Model tab for Order Handling.  Select all elements, except for the 7 
measures whose names end with _Processing_Time.  These 7 measures are already in 
the clipsbpm model.  Click to copy. 
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9) Click the Dimensional Model tab in clipsbpm, then right click on  Order Handling (Future 1) 
Cube and paste the elements that you copied. 

10) Press Ctrl-S  to save your work. 

11) For the 7 processing time measures that you did not copy, you will need to copy the 
tracking keys from Order Handling to clipsbpm.  The tracking keys are needed by Modeler 
when you export Monitor data back to Modeler.  For example, in the dimensional model of 
Order Handling, click the measure Average Cancel Order and Send Notification 
Processing Time , then you will see the tracking key in the editor as in the following screen 
capture.  Select the text for the tracking key, then copy it to the corresponding measure of 
the dimensional model in clipsbpm, Cancel Order and Send Notification Average 
Elapsed Duration .  Repeat this for the other six processing time measures.  Note that for 
Order Handling in clipsbpm, there is a working duration measure and an elaspsed duration 
measure, so make sure you update the tracking key for the elapsed duration only.  Here is 
a list of the tracking keys to copy: 

a) From : Average Cancel Order and Send Notification Processing Time to : Cancel 
Order and Send Notification Average Elapsed Duration 

b) From : Average Check Customer Account Status Processing Time to : Check 
Customer Account Status Average Elapsed Duration 

c) From : Average Check Order Handling Policy for Automatic Approval Processing 
Time to : Check Order Handling Policy for Automatic Approval Average Elapsed 
Duration 

d) From : Average Order Handling (Future 1) Processing Time to : Order Handling 
(Future 1) Average Elapsed Duration 

e) From : Average Review Order Processing Time to : Review Order Average Elapsed 
Duration 
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f) From : Average Ship Order to Customer Processing Time to : Ship Order to 
Customer Average Elapsed Duration 

g) From : Average Update Order Database Processing Time to : Update Order 
Database Average Elapsed Duration 

 

12) Click on the Visual Model tab in clipsbpm.  For context Order Handling (Future 1)  click 
Browse .  Navigate to clips  and select 
Order_Handling__x0028_Future_1_x0029__MDM_Order_Handling__x0028_Future_1_x0
029__MC.svg, click OK.  When prompted, click to create shape sets. 

13) Change the context to Template KPI Context , then click Browse .  Navigate to clips  and 
select 
Order_Handling__x0028_Future_1_x0029__KM_Order_Handling__x0028_Future_1_x002
9__KC.svg, click OK.  When prompted, click to create shape sets. 

14) Press Ctrl-S  to save your work. 

15) You can close the Order Handling monitor model since you have copied everything that 
you will need.  You should delete it from the workspace since there are many errors 
associated with this model that will continue to show in the Problems view. 

16) The rest of the work will be done in the clipsbpm model. 

17) There still are many errors, which will go away after you specify more implementation 
details. 

____ 4. Click on the Monitor Details model  tab of the clipsbpm model.  

____ 5. Complete the expressions for the six decision percentage metrics in the monitor details model.  
There are three decisions in the process model, so in the monitor model there is a 'yes' metric and a 
'no' metric for each decision.  There will be a measure in the dimensional model that averages each 
metric, so the measure will show the percentage of the time that the branch was taken.  If a decision 
branch has not been traversed then you do not want to include it in the averaging calculation, so if 
the value is null then it will not be included.   Therefore you will set the default value to null for each 
metric.  You will also create a trigger for each decision that determines when the 'yes' path is taken, 
then sets the value of the 'yes' metric to 100, and sets the value of the 'no' metric to 0.  You will also 
create a trigger for each decision that determines when the 'no' path is taken, then sets the value of 
the 'no' metric to 100, and sets the value of the 'yes' metric to 0. Then, when the measure averages 
each metric for the instances, the values will be null, 0 or 100, and therefore the average represents 
the percentage of the time that the branch was taken.  In the following expressions, the names of 
the links were obtained from the BPEL editor for the process. 

__ a. Create a new trigger Acceptable Credit Risk Yes Trigger 
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1) Right click in the Monitor Details Model  navigator, and select New > Trigger  

2) Enter name: Acceptable Credit Risk Yes Trigger, click OK 

3) In trigger sources, click Add, then select Other source type, navigate to Order Handling 
(Future 1) > OrderHandlingFuture1_FlowCONDTRUE, click OK 

4) In trigger condition, enter 

OrderHandlingFuture1_FlowCONDTRUE/BPELData/bpc:elementName eq 
'AcceptableCreditRiskOutput_to_Merge2Input2' 

 

__ b. Create a new trigger Acceptable Credit Risk No Trigger 

1) Right click in the Monitor Details Model  navigator, and select New > Trigger  

2) Enter name: Acceptable Credit Risk No Trigger, click OK 

3) In trigger sources, click Add, then select Other source type, navigate to Order Handling 
(Future 1) > OrderHandlingFuture1_FlowCONDTRUE, click OK 

4) In trigger condition, enter 

5) OrderHandlingFuture1_FlowCONDTRUE/BPELData/bpc:elementName eq 
'AcceptableCreditRiskOutput2_to_CancelOrderandSendNotificationInput' 
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__ c. Create a new trigger Account in Good Standing Yes Trigger 

1) Right click in the Monitor Details Model  navigator, and select New > Trigger  

2) Enter name: Account in Good Standing Yes Trigger, click OK 

3) In trigger sources, click Add, then select Other source type, navigate to Order Handling 
(Future 1) > OrderHandlingFuture1_FlowCONDTRUE, click OK 

4) In trigger condition, enter 

OrderHandlingFuture1_FlowCONDTRUE/BPELData/bpc:elementName eq 
'AccountinGoodStandingOutput_to_Merge2Input' 

 

__ d. Create a new trigger Account in Good Standing No Trigger 

1) Right click in the Monitor Details Model  navigator, and select New > Trigger  

2) Enter name: Account in Good Standing No Trigger, click OK 
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3) In trigger sources, click Add, then select Other source type, navigate to Order Handling 
(Future 1) > OrderHandlingFuture1_FlowCONDTRUE, click OK 

4) In trigger condition, enter 

OrderHandlingFuture1_FlowCONDTRUE/BPELData/bpc:elementName eq 
'AccountinGoodStandingOutput2_to_MergeInput' 

 

__ e. Create a new trigger Approve Without Review Yes Trigger 

1) Right click in the Monitor Details Model  navigator, and select New > Trigger  

2) Enter name: Approve Without Review Yes Trigger, click OK 

3) In trigger sources, click Add, then select Other source type, navigate to Order Handling 
(Future 1) > OrderHandlingFuture1_FlowCONDTRUE, click OK 

4) In trigger condition, enter 

OrderHandlingFuture1_FlowCONDTRUE/BPELData/bpc:elementName eq 
'ApproveWithoutReviewOutput_to_CheckCustomerAccountStatusInput' 
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__ f. Create a new trigger Approve Without Review No Trigger 

1) Right click in the Monitor Details Model  navigator, and select New > Trigger  

2) Enter name: Approve Without Review No Trigger, click OK 

3) In trigger sources, click Add, then select Other source type, navigate to Order Handling 
(Future 1) > OrderHandlingFuture1_FlowCONDTRUE, click OK 

4) In trigger condition, enter 

OrderHandlingFuture1_FlowCONDTRUE/BPELData/bpc:elementName eq 
'ApproveWithoutReviewOutput2_to_MergeInput2' 

 

__ g. In the Monitor details model, select Acceptable Credit Risk? No Percentage . 

1) Remove the default value of 0 by backspacing over it.  

2) In the expression table click Add .   

3) For trigger, specify: Acceptable Credit Risk Yes Trigger  

4) For expression, specify: 0  

5) In the expression table click Add .   

6) For trigger, specify: Acceptable Credit Risk No Trigger  

7) For expression, specify: 100 

 

__ h. In the Monitor details model, select Acceptable Credit Risk? Yes Percentage  

1) Remove the default value of 0 by backspacing over it.  

2) In the expression table click Add .   
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3) For trigger, specify: Acceptable Credit Risk Yes Trigger 

4) For expression, specify: 100 

5) In the expression table click Add .   

6) For trigger, specify: Acceptable Credit Risk No Trigger 

7) For expression, specify: 0 

 

__ i. In the Monitor details model, select Account in Good Standing? No Percentage  

1) Remove the default value of 0 by backspacing over it.  

2) In the expression table click Add .   

3) For trigger, specify: Account in Good Standing Yes Trigger 

4) For expression, specify: 0 

5) In the expression table click Add .   

6) For trigger, specify: Account in Good Standing No Trigger 

7) For expression, specify: 100 

 

__ j. In the Monitor details model, select Account in Good Standing? Yes Percentage  

1) Remove the default value of 0 by backspacing over it.  

2) In the expression table click Add .   

3) For trigger, specify: Account in Good Standing Yes Trigger 

4) For expression, specify: 100 

5) In the expression table click Add .   

6) For trigger, specify: Account in Good Standing No Trigger 

7) For expression, specify: 0 

 

__ k. In the Monitor details model, select Approve Without Review? No Percentage  

1) Remove the default value of 0 by backspacing over it.  
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2) In the expression table click Add .   

3) For trigger, specify: Approve Without Review Yes Trigger 

4) For expression, specify: 0 

5) In the expression table click Add .   

6) For trigger, specify: Approve Without Review No Trigger 

7) For expression, specify: 100 

 

__ l. In the Monitor details model, select Approve Without Review? Yes Percentage  

1) Remove the default value of 0 by backspacing over it.  

2) In the expression table click Add .   

3) For trigger, specify: Approve Without Review Yes Trigger 

4) For expression, specify: 100 

5) In the expression table click Add .   

6) For trigger, specify: Approve Without Review No Trigger 

7) For expression, specify: 0 

 

____ 6. Press Ctrl-S  to save your work. 

____ 7. Click on the KPI Model  tab. 

____ 8. In the KPI model, update Average Process Duration Trigger 1.  This trigger is used to fire the 
situation event when the process duration is too long. 

__ a. In the trigger source table, click Add  

__ b. Select Recurring wait time , then click OK.  This will default to 1 minute. 

__ c. For Trigger condition, enter this expression: 

Average_Process_Duration ge dayTimeDuration('P3DT1H') 
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____ 9. In the KPI model, update Percentage of Orders Shipped Trigger 1.  This trigger is used to fire the 
situation event when the percentage of shipped orders is too small. 

__ a. In the trigger source table, click Add  

__ b. Select Recurring wait time , then click OK.  This will default to 1 minute. 

__ c. For Trigger condition, enter this expression: 

 Percentage_of_Orders_Shipped < 85 

  

____ 10. In the KPI model, update the KPI Average Process Duration.   

__ a. Since this was copied from another model, you need to update the monitoring context , so click 
Browse  next to the monitoring context, then navigate to clipsbpm > Order Handling (Future 
1), then click OK. 

__ b. The metric value is blank.  Note that there is another KPI, Order Handling (Future 1) Average 
Elapsed Duration,  which has the same function as Average Process Duration.  The former was 
auto-generated.  You can view it to see which metric should be used. 
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__ c. Next to metric , click Browse , then navigate to Order Handling (Future 1) > Order Handling 
(Future 1) Elapsed Duration for KPI , then click OK 

__ d. Set the aggregation function to Average . 

 

____ 11. Delete  KPI Order Handling (Future 1) Average Elapsed Duration , since it is a duplicate of 
'Average Process Duration'. 

____ 12. Press Ctrl-S  to save your work. 

____ 13. In the KPI model, update the KPI Percentage of Orders Shipped.  In order to calcuate the 
percentage of orders shipped you will create a KPI for the number of shipped orders, and you will 
create another KPI for the total number of orders, then you can determine the percentage by 
dividing the shipped orders by the total orders. 

__ a. In the details model, create a new trigger Shipped Order Trigger  

1) Right click in the Monitor Details Model  navigator, and select New > Trigger  

2) Enter name: Shipped Order Trigger, click OK 

3) In trigger sources, click Add, then select Other source type, navigate to Order Handling 
(Future 1) > Ship Order to CustomerEXIT, click OK 

 

__ b. In the details model, create a new trigger Cancelled Order Trigger  

1) Right click in the Monitor Details Model  navigator, and select New > Trigger  

2) Enter name: Cancelled Order Trigger, click OK 

3) In trigger sources, click Add, then select Other source type, navigate to Order Handling 
(Future 1) > Cancel Order and Send NotificationEXIT, click OK 

 

__ c. In the details model, create a new metric Order Status  

1) Right click in the Monitor Details Model  navigator, and select New > Metric  
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2) Enter name: Order Status, enter type: String, click OK 

3) Select 'A value is required for this metric', since a dimension will use this metric and that 
requires a value for dimensional analysis. 

4) For Default value, enter 'New' with the quotes. 

5) In Metric value expressions, click Add.  In the trigger cell, enter trigger type Cancelled Order 
Trigger. In the expression cell, enter 'Cancelled' with the quotes. 

6) In Metric value expressions, click Add.  In the trigger cell, enter trigger type Shipped Order 
Trigger. In the expression cell, enter 'Shipped' with the quotes. 

 

__ d. In the KPI model, create a new KPI Shipped Orders.  You will use the key metric to count all 
incoming instances, then filter it by the order status so you only count shipped orders.  You will 
also filter it by the process state, so only completed process instances are counted. 

1) In the KPI model navigator, right click and select New > KPI. 

2) Set the type to decimal. 

3) For KPI value, select 'Base this KPI on a metric and an aggregation function' 

4) For monitoring context, browse to Order Handling (Future 1) 

5) For metric, browse to Order Handling (Future 1) Instance ID. 

6) For aggregation function, select Count 

7) For data filter, click Add, then browse to Order Handling (Future 1) > Order Status, then 
click OK.  In the values cell, enter 'Shipped' with the quotes. 

8) For data filter, click Add, then browse to Order Handling (Future 1) > Order Handling 
(Future 1) State, then click OK.  In the values cell, enter '3 - STATE_FINISHED' with the 
quotes. 

 

__ e. In the KPI model, create a new KPI Total Orders.  You will use the key metric to count all 
incoming instances.  You will also filter it by the process state, so only completed process 
instances are counted. 

1) In the KPI model navigator, right click and select New > KPI. 

2) Set the type to decimal. 
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3) For KPI value, select 'Base this KPI on a metric and an aggregation function' 

4) For monitoring context, browse to Order Handling (Future 1) 

5) For metric, browse to Order Handling (Future 1) Instance ID. 

6) For aggregation function, select Count 

7) For data filter, click Add, then browse to Order Handling (Future 1) > Order Handling 
(Future 1) State, then click OK.  In the values cell, enter '3 - STATE_FINISHED' with the 
quotes. 

 

 

__ f. Finalize the KPI, Percentage of Orders Shipped  

1) In the KPI model navigator, select the KPI Percentage of Orders Shipped 

2) Set the type to Decimal 

3) For KPI Value, select 'Write an expression to calculate this KPI based on existing KPIs' 

4) For KPI Calculation, enter: 

(Shipped_Orders div Total_Orders) * 100 

 

____ 14. Press Ctrl-S  to save your work. 

____ 15. Create an event definition to use for the shipped percentage situation event. 

__ a. Create the event definition ShippedPercentage.cbe  

1) Right click in the project explorer on Event Definitions, then select New > Event Definition 
… (cbe) 

2) For file name, enter ShippedPercentage.cbe, then click Finish. 

3) The Event Definition Editor opens. 

4) Double click the hierarchical icon next to the label Parent .  

5) On the Select Event Definition  Dialog double click on ActionServicesEvent . 

6) ActionServicesEvent  is now shown as the parent of ShippedPercentage  
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7) Press Ctrl-S  to save your work. 

__ b. Create the outbound event Shipped Percentage Event  

1) In the clipsbpm model, click the KPI Model tab 

2) Right click in the navigator, select New > Outbound Event 

3) For name, enter Shipped Percentage Event 

4) Select the check box for 'Configure this event to generate an alert in the dashboards' 

5) For trigger, browse to Template KPI Context > Percentage of Orders Shipped Trigger 1 

6) Click OK 

7) In Event Type Details, for extension name, browse to clips > ShippedPercentage.cbe > 
Shipped Percentage, then click OK 

8) In the Event Attributes Details, navigate to BusinessSituationName, and you will see that 
the value of the situation name has been set for you to 'Shipped Percentage Event'. 

 

____ 16. Press Ctrl-S  to save your work. 

____ 17. Create the outbound event for the order processing time situtation. 

__ a. Create the event definition OrderFulfillmentTime.cbe  

1) Right click in the project explorer on Event Definitions, then select New > Event Definition 
… (cbe) 

2) For file name, enter OrderFulfillmentTime.cbe, then click Finish. 

3) The Event Definition Editor opens. 

4) Double click the hierarchical icon next to the label Parent .  

5) On the Select Event Definition  Dialog double click on ActionServicesEvent . 

6) ActionServicesEvent  is now shown as the parent of OrderFulfillmentTime  
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7) In the extended data section, click the icon to add an extended data element 

8) Change the name to OrderDuration  

9) Change the type to string  

 

10) Press Ctrl-S  to save your work. 

__ b. Create the outbound event Order Fulfillment Event  

1) In the clipsbpm model, click the KPI Model tab 

2) Right click in the navigator, select New > Outbound Event 

3) For name, enter Order Fulfillment Event 

4) Select the check box for 'Configure this event to generate an alert in the dashboards' 

5) For trigger, browse to Template KPI Context > Average Process Duration Trigger 1 

6) Click OK 

7) In Event Type Details, for extension name, browse to clips > OrderFulfillmentTime.cbe > 
OrderFulfillmentTime, then click OK 

8) In the Event Attributes Details, navigate to BusinessSituationName, and you will see that 
the value of the situation name has been set for you to 'Order Fulfillment Event'. 

a) Set the expression for OrderDuration to  

    xs:string(Average_Process_Duration) 

 

____ 18. Press Ctrl-S  to save your work. 

____ 19. Click on the Dimension Model  tab. 

____ 20. Delete  Declined Order Count, Order Count , and Shipped Order Count .  You can get this 
information using the builtin function Instances Count in the Dimensional view of the dashboard, and 
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then creating a dimension on order status which is a metric which identifies new orders, shipped 
orders and cancelled orders. 

____ 21. Create  dimension  Order Status .  This will be useful for drilling down in the Dimensional view of the 
dashboard to aggregate instances by their order status. 

__ a. Right click in the Dimensional Model navigator on Order Handling (Future 1) Cube, then select 
New > Dimension. 

__ b. Name it Order Status 

__ c. Right click on Order Status in the Dimensional Model navigator, then select New > Dimension 
Level 

__ d. Name it Order Status, then click Browse next to Source Metric, and navigate to Order Handling 
(Future 1) > Order Status, then click OK. 

 

__ e. Click OK. 

____ 22. Create  dimension  State .  This will be useful for drilling down in the Dimensional view of the 
dashboard to aggregate instances by their process completion state. 

__ a. Right click in the Dimensional Model navigator on Order Handling (Future 1) Cube, then select 
New > Dimension. 

__ b. Name it State 

__ c. Right click on State in the Dimensional Model navigator, then select New > Dimension Level 

__ d. Name it State, then click Browse next to Source Metric, and navigate to Order Handling (Future 
1) > Order Handling (Future 1) State, then click OK. 

 

__ e. Click OK. 

__ f. Notice that you see an error on this dimension since the state metric is not initialized when the 
monitoring context is created.  To solve this problem, in the Monitor Details Model tab, update 
the metric Order Handling (Future 1) State.  Select 'A value is required for this metric'.  Change 
the default value from empty to 'New', including the quotes.  

 

____ 23. There is a dimension called Location  which you can see in the Dimensional Model, but there are 
errors associated with it.  This element came from the business measures model, and it should 
contain two levels, first the country and then the city.  To enable Location, you need to create 
metrics for country and city, then you can update the Location dimension to reference the metrics. 
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__ a. In the monitor details model, create  metric  Country  

1) Right click in the Monitor Details Model  navigator, and select New > Metric  

2) Enter name: Country, enter type: String, click OK 

3) Select 'A value is required for this metric', since a dimension will use this metric and that 
requires a value for dimensional analysis. 

4) For default value, enter an empty string (two single quotes) 

5) In Metric value expressions, click Add.  In the expression cell, use content assist to navigate 
to the following inbound event field for country.   

Check_Order_Handling_Policy_for_Automatic_ApprovalENTRY/Input/Customer/Country 

 

__ b. In the monitor details model, create  metric  City  

1) Right click in the Monitor Details Model  navigator, and select New > Metric  

2) Enter name: City, enter type: String, click OK 

3) Select 'A value is required for this metric', since a dimension will use this metric and that 
requires a value for dimensional analysis. 

4) For default value, enter an empty string (two single quotes) 

5) In Metric value expressions, click Add.  In the expression cell, use content assist to navigate 
to the following inbound event field for city.   

Check_Order_Handling_Policy_for_Automatic_ApprovalENTRY/Input/Customer/City 

 

__ c. In the Dimensional  model, update  the Location  dimension for the two metrics. 

1) In the KPI model, delete the Location level underneath the Location dimension. 

2) Right click on Location in the Dimensional Model navigator, then select New > Dimension 
Level 

3) Name it Country, then click Browse next to Source Metric, and navigate to Order Handling 
(Future 1) > Country, then click OK. 

4) Click OK. 

5) Right click on Location in the Dimensional Model navigator, then select New > Dimension 
Level 
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6) Name it City, then click Browse next to Source Metric, and navigate to Order Handling 
(Future 1) > City, then click OK. 

7) Click OK.   

8) In the navigator you should see Location listed with two sub-levels as follows: 

 

____ 24. In the Dimensional model, update  measure Order Price Average.  You will need to create a metric 
for the price to use as a source for this measure. 

__ a. In the Monitor Details Model, create  metric Total Price  

1) Right click in the Monitor Details Model  navigator, and select New > Metric  

2) Enter name: Total Price, enter type: Decimal, click OK 

3) In Metric value expressions, click Add.  In the expression cell, use content assist to navigate 
to the following inbound event field for total price.   

Check_Order_Handling_Policy_for_Automatic_ApprovalENTRY/Input/TotalPrice 

 

__ b. In the dimensional model, update measure Order Price Average with the new metric. 

1) Click on the Dimensional Model tab and select measure Order Price Average. 

2) For source metric, browse to Order Handling (Future 1) > Total Price, click OK. 

 

__ c. In the dimensional model, update measure Order Price Total with the new metric. 

1) Click on the Dimensional Model tab and select measure Order Price Total. 

2) For source metric, browse to Order Handling (Future 1) > Total Price, click OK. 

 

____ 25. Press Ctrl-S  to save your work. 

____ 26. Select Project > Clean…, then select 'Clean all projects', then click OK. 

____ 27. Check for any errors in the Problems view.  You should resolve any errors before continuing.  
Warnings and informational messages may be present but these will not be a problem. 
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Part 5: Generate and publish the model to the serve r 

In this section you will use WebSphere Integration Developer to publish the monitor model to the monitor 
server. 

____ 1. In Project Explorer, expand clips ���� Monitor models ���� clipsbpm.mm . Right click over 
clipsbpm.mm  and then select Generate Monitor J2EE Projects  from the context menu 

____ 2. Select Finish . 

____ 3. A progress dialog shows the status of the operation and it closes when the operation is complete.  
Check for errors in the Problems view.  There may be warnings, but there should not be any errors.  
If you see errors, then try to perform a clean to see if the errors can be removed:  Project > Clean… 
> select 'Clean all projects', then click OK. 

____ 4. Click the Servers tab, then right click and select the Start  option to start the server WebSphere 
Business Monitor V6.1.  This may take a few minutes to complete. 

  

____ 5. Right click in the servers view, then select Add and Remove Projects….  

____ 6. Click to move clipsbpmApplication, CATOrderMgmt_implApp, and CATO rderMgmtApp  from 
the list of available projects to the list of configured projects. 

____ 7. Click Finish . 

____ 8. A progress message is displayed in the lower right hand corner of the window. 

____ 9. Check the messages in the console view.  You should see the following messages when the 
applications have been started 

____ 10. In the servers view, right click, then select Run administrative console .  You should see it open in 
a separate tab.  It will prompt you for userid and password.  Enter 'admin' without the quotes for 
userid, then enter 'admin' without the quotes for password. 

____ 11. Click Log in  

____ 12. Click Applications > Monitor Models .  The application should show green status if it started 
successfully. 

____ 13. If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the 
right of Status in the last column of the table. You should see green (started) for the model.  If it 
does not show green, be patient and keep refreshing until it does show green. 

____ 14. Check the server log to ensure there are no problems. You can check this in the console view. 

____ 15. If you are using the integrated server within WebSphere Integration Developer, then you do not 
need to setup Monitor data security, since the ‘Admin’ user is automatically authorized to all models.  
If you are using a different server, then you should open the administrative console, navigate to 
Security > Monitor Data Security, then add the model, role and user information to a resource 
group. 



© Copyright IBM Corporation 2008. All rights reserved 

2008 February, 22 IBM WebSphere Business Monitor 6.1 – Lab exercise Page 35 of 51 

 ClipsAndTacks 

Part 6: Configure action manager for business situa tion events 

This section shows you how to configure action manager to create alerts based on business situation 
events defined in the monitor model.  The alerts will be visible in the Alert view on your dashboard. 

You do not need an LDAP server to test the situation events. 

____ 1. Add a template for shipped percentage alerts. 

__ a. In the administrative console, navigate to Applications > Monitor Action Services > Template 
Definitions > Notifications.   

__ b. Click New. 

__ c. Enter AlertShip  as Template name and a description. 

__ d. Select Dashboard Alert.  

__ e. Select User id.  

__ f. For the To field, enter admin.  This userid is the one that will receive the alert, so you must log 
into the dashboard with this userid. 

__ g. Enter a subject, such as 'Percentage of shipped orders' 

__ h. Enter the body, such as 'Percentage of shipped orders is less than 85.' 

 

__ i. Click OK. 

____ 2. Add a template for order processing time alerts. 

__ a. In the administrative console, navigate to Applications > Monitor Action Services > Template 
Definitions > Notifications.  

__ b. Click New. 

__ c. Enter AlertTime  as Template name and a description. 

__ d. Select Dashboard Alert.  

__ e. Select User id.  

__ f. For the To field, enter admin.  This userid is the one that will receive the alert, so you must log 
into the dashboard with this userid. 
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__ g. Enter a subject, such as 'Order processing time'. 

__ h. Enter the body, and you may optionally enter a substitution variable as shown below.  For the 
actual alert that is sent, the average order processing time from the event payload will be 
substituted for %OrderDuration% in the body.  For example: 

 The average order processing time is %OrderDuration% days. 

  

__ i. Click OK. 

____ 3. Add the binding from the situation event to the action type for shipped percentage. 

__ a. In the administrativeconsole, navigate to Applications > Monitor Action Services > Installed 
Situation Event Bindings.  

__ b. Click New. 

__ c. Enter the situation event name that you defined in the model.  In this lab, you created a business 
situation name as follows:  

  Shipped Percentage Event  

__ d. This must match exactly the value in the BusinessSituationName field in the outbound event.  
You may want to copy/paste from the model.  Here is a screen capture from the model showing 
the Shipped Percentage Event attributes: 

  

__ e. Enter a description, then click Apply . 

__ f. Click Add . 

__ g. Enter a binding name, then select the template AlertShip.  

__ h. Click OK. 

__ i. Notice that you now have one action defined for this situation event.  If you had other action 
templates defined then you could add more actions to this event.  So then you could send a 
notification for this situation to multiple destinations including e-mail, alerts and Web services. 
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__ j. Click OK. 

____ 4. Add the binding from the situation event to the action type for order processing time. 

__ a. In the administrativeconsole, navigate to Applications > Monitor Action Services > Installed 
Situation Event Bindings.  

__ b. Click New. 

__ c. Enter the situation event name that you defined in the model.  In this lab, you created a business 
situation name as follows: 

 Order Fulfillment Event  

__ d. .  This must match exactly the value in the BusinessSituationName field in the outbound event.  
You may want to copy/paste from the model 

__ e. Enter a description, then click Apply . 

__ f. Click Add . 

__ g. Enter a binding name, then select the template AlertTime , then click OK. 
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__ h. Click OK. 

____ 5. In the administrativeconsole, navigate to Applications > Monitor Action Services > Installed 
Situation Event Bindings.  You should see the two bindings that you created. 

 

  



© Copyright IBM Corporation 2008. All rights reserved 

2008 February, 22 IBM WebSphere Business Monitor 6.1 – Lab exercise Page 39 of 51 

 ClipsAndTacks 

Part 7: Run events to exercise the model 

 

In this section you will use the business process choreographer explorer to run process instances.   

There are five different paths to take through the model.  For each path, here are sample data elements that 
will invoke the listed path: 

a. Approve without review, account in good standing, ship 
i. Start instance: rating – 800, available credit – 800, total price – 20 
ii. Ship task: no required elements 

b. Approve without review, account not in good standing, approve the order, ship 
i. Start instance: rating – 800, available credit – 100, total price – 200 
ii. Review task: order status – APPROVED 
iii. Ship task: no required elements 

c. Approve without  review, account not in good standing, decline the order 
i. Start instance: rating – 800, available credit – 100, total price – 200 
ii. Review task: order status – DECLINED  

d. Do not approve without review, approve the order, ship 
i. Start instance: rating – 10, available credit – 10, total price – 900 
ii. Review task: order status – APPROVED 
iii. Ship task: no required elements 

e. Do not approve without review, decline the order 
i. Start instance: rating – 10, available credit – 10, total price – 900 
ii. Review task: order status – DECLINED 

 
In order to see an alert in the alerts view of the dashboard, you will need the number of shipped orders to be 
less than 85 percent of the total number of orders.  An easy way to achieve this is to process one DECLINED 
order, then before you add any other process instances, go to the dashboard section of this document and 
create a dashboard to view the alerts. 

 

____ 1. In the Servers view, right click on server WebSphere Business Monitor v6.1 > Launch > Business 
Process Choreographer Explorer 

____ 2. Click My Process Templates 

 

____ 3. Select OrderHandlingFuture1, then click Start Instance  

____ 4. In the following data entry page, enter a unique value for the process name, then enter values for 
the fields in the various business objects listed.  You can use just one line item for OrderItems, or 
you can enter additional ones if you like by clicking on the Add button.  The values for Rating, 
AvailableCredit, and TotalPrice determine which paths the process will take.  See the introduction to 
this section for more information. 
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____ 5. Click the Submit button. 

____ 6. Select Task Instances > My To-do's.  Here you will find either the ReviewOrder task or the 
ShipOrdertoCustomer task, depending on the values that you entered when you started the process 
instance. 

 

____ 7. To complete a task, select the check-box for it, then click 'Work on'.  You will be given a page to 
enter values for the task.  You should enter the values in the section for the task output message. 

__ a. For the ship task, you can just press the Complete button, since the data elements are not 
required values for this process. 
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__ b. For the review task, you should enter 'APPROVED' or 'DECLINED' (without the quotes) into the 
OrderStatus field.  The other fields are optional for this process, so you can choose to not enter 
them to save time. Then press the Complete button.   

__ c. This screen capture shows the review task and the string 'APPROVED' (without the quotes) has 
been entered in the OrderStatus field. 
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Part 8: Create a dashboard 

In this section you will build a dashboard.  You will add views to the dashboard and configure them. 

____ 1. Create the dashboard. 

__ a. In WebSphere Integration Developer, click Window > Web Browser.  The default browser is 
'Internal Web Browser', but you should not use this one since some standard functions are not 
provided that you may need.  Select 'Default system Web browser' or any other listed browser 
other than the internal browser. 

__ b. In WebSphere Integration Developer, in the servers view, right click and select WebSphere 
Business Monitor Dashboard  

__ c. When prompted, enter admin  for the user ID and enter admin  for the password.  You must log in 
with 'admin' so that you can view the alerts which were setup in action manager to be sent to this 
particular userid.  Also, in the toolkit environment, this is the user that is automatically defined on 
the secured server. 

__ d. Click the Dashboards  tab. 

 

__ e. Click New, then enter a name for the dashboard, then click OK. 

 

____ 2. Add the instances view to see monitored instances. 

__ a. Click Add to Dashboard , then select Instances , then click OK.  Note that you can also add a 
view by dragging the view from the palette on the right and dropping it onto the dashboard. 

__ b. Click Personalize . 

__ c. Click the Advanced  tab, and select model 'clipsbpm (All Versions)' 
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__ d. Click the Show/Hide  tab. 

__ e. Click >> to copy all the metrics from the available list to the selected list.   

 

__ f. Then click Save.  You should see a list of monitoring context instances for the events that you 
just processed.   

 

____ 3. Add the human tasks view. 

__ a. Click Add to Dashboard , then select Human Tasks , then click OK.  Note that you can also add 
a view by dragging the view from the palette on the right and dropping it onto the dashboard. 

__ b. Click Personalize . 

__ c. Click the Show/Hide  tab. 

__ d. Click >> to copy all the metrics from the available list to the selected list. 
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__ e. Click OK. 

 

____ 4. Add the dimensions view and configure it to show aggregated human task information. 

__ a. Click Add to Dashboard , then select Dimensions , then click OK. 

__ b. Click Personalize . 

__ c. In the Dimensions view's personalize screen, select the following values: 

1. Monitoring Model: Global HT MM (All Versions)  

• Note that this is the global human task monitor model which is automatically 
installed when you install the toolkit. 

2. Monitoring Context : Global Human Task  

3. Select Task Name Dimension  from the Available Dimensions  list and click the right 

direction arrow ( ) next to Row Dimensions  text area. 

4. Now select Task Owner Dimension  from the Available Dimensions  list and click the 

right directional arrow ( ) next to Column Dimensions  text area 

5. Now select Measures  from the Available Dimensions  list and click the right direction 

arrow ( ) next to Page Dimensions  
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__ b. Click the Save button. 

__ c. The Dimensions view displays the instances count based on task name and task owner. 

 

__ d. You can double click on All Task Name Dimension  to drill down on task name.  Then double 
click on All Task Owner Dimension  to drill down on task owner. 
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____ 5. Add the alerts view.  There are two alerts defined in the model, one for shipped percentage and one 
for order processing time.  The latter is based on a processing time greater that 3 days, so it will be 
difficult to test here.  The former can be tested easily by ensuring that the number of shipped orders 
is less than 85 percent of the number of total orders. 

__ a. Click Add to Dashboard , then select Alerts , then click OK.   

 

____ 6. Export values to Modeler.  Note that you must have some completed monitoring context instances 
for this, so make sure that you have started and completed some process instances before 
exporting the values. 

__ a. Click the Utilities  tab. 

__ b. Click the Export Values  tab. 

__ c. Select the correct model, then click Export . 
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__ d. The XML is displayed in a browser window, click File > Save page as…  or   Save as…, then 
select your destination folder and click Save.  The file is stored by default as exportvalues.xml. 

__ e. Open WebSphere Business Modeler , and point to the workspace containing your model. 

__ f. In the project tree, navigate to CATOrderMgmt > Processes > Order Handling (Future 1 ), and 
select it 

__ g. Right click on Order Handling (Future 1), then select Import…  

__ h. Select Monitoring result (.xml) , then click Next.  

__ i. Browse  to the folder containing the exportvalues.xml file. 

__ j. Select exportvalues.xml, then click Next.  

 

__ k. Click Finish . 

__ l. Double click on the process in the project tree to open the process diagram.  Browse the process 
diagram to see the updated values for the six decision percentages.   
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__ m. To check the updated process duration time, click on the background of the diagram, then click 
the Attributes tab, then click the Duration tab. 

 

__ n. To check the updated task duration times, click on one of the tasks in the diagram, then click the 
Attributes tab, then click the Duration tab, then click the icon in front of 'Processing time'. 
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What you did in this exercise 

In the lab, you imported the model into WebSphere Business Modeler and reviewed the process model 
and business measures model. 

You exported the process model and business measures model to WebSphere Integration Developer, and 
imported the implemented process solution.   

You generated the BPEL monitor model, and merged that with the business measures model. 

You completed the implementation of the merged monitor model. 

You deployed the process and the monitor model, and ran process instances. 

Finally, you created a dashboard and exported monitored values back to Modeler. 

 



© Copyright IBM Corporation 2008. All rights reserved 

2008 February, 22 IBM WebSphere Business Monitor 6.1 – Lab exercise Page 50 of 51 

 ClipsAndTacks 

Appendix 1 – Import the solution into the monitor m odel editor 

A solution has been provided so that you do not have to build the model from scratch.  This section shows 
you how to import the monitor model project into WebSphere Integration Developer.  After importing the 
model then you can proceed to the section to publish the model to the server. 

 

____ 1. Import the monitor model project into WebSphere Integration Developer. 

__ a. In the Business Integration view, right click then select Import … 

__ b. Navigate to Other > Project Interchange  then click Next . 

__ c. For the zip file, browse to the supplied file, for example,  

__ d. c:\Labfiles61\ClipsAndTacksBPM\CATOrderMgmt-PI-withMM.zip 

__ e. You should see four projects listed, but select only project clips . 

__ f. Click Finish . 

____ 2. Expand the project in the Project Explorer view, then expand the Event Definitions and you will see 
the events listed.  Expand Monitor Models and you will see the model listed. 

____ 3. Now you may proceed to the section to generate and publish the model to the server. 
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