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What this exercise is about

The objective of this lab is to show you how to build a monitor model using XSD event definitions in Rational
Application Developer or WebSphere Integration Developer, deploy it to WebSphere Business Monitor and
then view your monitored data on the Monitor dashboards.

This lab will show you Business Activity Monitoring (BAM) which involves event based monitoring. With BAM,
you can have your monitored application running anywhere, and submitting events to the Monitor server so
that you can view monitored data. Typically, you identify the events that are created by the application, and
then create a monitor model that represents the monitored data that you want to collect from the events.

Changes from the previous version

This lab has been maodified significantly from the previous 6.0.2 release. Here are the major changes:

In the monitor model, you can reference other KPIs when defining the calculation for a given KPI.

KPIs are now based on a metric and aggregation function, and not based on cube measures, so the
dimensional model is now simplified.

Deploying the model has been dramatically simplified, so this is a very short process now.
LDAP is not required, so now you can test alerts without installing LDAP.

Portal is no longer a requirement, so configuration of a dashboard is simplified.

Lab requirements

List of system and software required for the student to complete the lab:

Rational Application Developer V7.0 or WebSphere Integration Developer V6.1.

WebSphere Business Monitor V6.1 — Toolkit Installation including the Monitor Model editor and

Monitor Server

What you should be able to do

At the end of this lab you should be able to:

Use Rational Application Developer or WebSphere Integration Developer to create the monitor model,
and deploy it to the server.

Use a sample program to create events that represent events from your process.

Define a dashboard to view monitored data.
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Introduction

In this lab you will learn how to develop and deploy a model from end to end using Rational Application
Developer or WebSphere Integration Developer and WebSphere Business Monitor. This lab will show you the
basic procedure for creating and implementing a simple model.

The model used in this lab is ClipsAndTacks model which is also used in IBM Redbook SG247148 —
Business Process Management: Modeling through Monit oring Using WebSphere V6.0.2 Products . In
the Redbook, there are several models that are referenced, but in this lab you will be using the Future 1
Process. In the Redbook, the process is implemented as a BPEL process running in WebSphere Process
Server. However this lab will demonstrate Business Activity Monitoring ~ which can monitor events from any
source. So, the lab will simulate the running of the process, by creating events that could have been sourced
from anywhere, a Java EE application or BPEL, or any other source. These events are in the form of Common
Base Events, which is an OASIS standard for common event format. These events are used by the Common
Event Infrastructure (CEIl) in WebSphere Process Server.

In this lab you will build a monitor model that has the same basic elements as the one that is defined in the
Redbook. Namely you will create monitoring constructs in support of two KPIs:

» Average order fulfillment is 3 days or less

» Percentage of shipped orders is greater than 90%
You will also create situation events if declined orders are greater than or equal to 3 and if the order fulfillment
time is greater than 3 days.

For dimensional analysis, you will create a Location dimension which allows you to drill down on country and
city. You will also add an Order Status metric, which shows orders as ‘New’, ‘Cancelled’ or ‘Shipped’. And
you will add measures for average order price, sum of order price for all orders, and order count.

Here is a diagram of the ClipsAndTacks process model:
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This is the ordering process for the Clips And Tacks company. In this process, orders are received and
optionally submitted to a review process. Orders which pass all checks are shipped to the customer.
Other orders may be cancelled.

In the monitor model, you will create one monitoring context for each customer order. You will identify the
inbound event that represents the receipt of the order, and this is marked so that it will create a new
monitoring context instance for the order. You will also identify the inbound event that represents shipping
the order, and this is marked so that it will trigger the termination of the monitoring context instance for the
order. Since an order might also be cancelled, you will identify the inbound event that represents
cancellation of the order, and this is also marked so that it will trigger the termination of the monitoring
context instance.

URL Cheatsheet

The following URLs may be helpful to you as you exercise this lab. Note that the port numbers in the URL
of your installation may be different depending on your configuration.

* Server administrative console

http://localhost:9061/ibm/console/

* Web dashboard

http://localhost:9081/BusinessDashboard/
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Part 1: Create the monitor model

To create the monitor model, you will use the monitor model editor in Rational Application Developer or
WebSphere Integration Developer. Note that the screen captures in this lab are based on WebSphere
Integration Developer, so they may differ slightly from yours if you are using Rational Application Developer.

Note that there is a ‘Problems’ tab that displays errors concerning the model. Periodically, you should check
this view to see if you have any problems that need to be addressed. Normally, warnings and informational
messages are not a problem, but errors should be addressed.

If you want to skip this section, then a solution has been provided. You can import the supplied monitor model
into Rational Application Developer or WebSphere Integration Developer, and then proceed to the next
section. Refer to Appendix 1, and then proceed to the next section.

1. Start Rational Application Developer or WebSphere Integration Developer and setup the
environment.

___a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted
point to a new workspace such as C:\workspaces\ClipsAndTacksXSD

___b. Close the Welcome tab

___c. By default, you are in the Business Integration perspective. But you need to open the Business
Monitoring perspective. From the main menu, select Window -> Open Perspective - Other.

The ‘Open Perspective’ dialog opens

4% Dpen Perspective
-% Business Inteqgration {default) -
‘._ Business Monitoring

%C'-.-‘S Repository Exploring

Fﬁ Daka

ﬁ Cebug

[ @ Generic Log Adapter LI

Ok I Cancel |

___d. Select ‘Business Monitoring '’ from the ‘Open Perspective’ dialog and click OK

2. Create a new monitoring project. A project is a container for your monitor models and event
definitions.

___a. Right-click inside Business Monitoring  project explorer (top left view in the Business Monitoring
Perspective) and select New - Business Monitoring Project...  from the pop-up menu. The
‘New Business Monitoring Project’ panel opens
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___b. In the ‘New Business Monitoring Project’, enter the ‘Project name:’ as ClipsAndTacks

4= New Business Monitoring Project
Create a business monitoring project —
|
Creakte a new project resource,
CIE
Project name: | ClipsandTacks
¥ Use default location
Location: | C: fwiorkspaces) ClipsandTacksssD)ClipsandT acks Browse. .. |
(7) Cancel

___C. Click the Finish button. A question dialog pops up asking if you want to launch the Getting
Started information

= Launch Getting Started?

monitar madel editar, Wauld vau like ko launch Ehe Getting Started

\l}/ The inkteractive Getting Started information can help introduce you to the
L]
information?

[ Remember my decision |

___d. Click the Yes button to if you want to launch the Getting Started information

___e. Anew project named ClipsAndTacks is created as shown below:
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3.

___a. Inthe Business Monitoring project explorer view, expand ClipsAndTacks
Definitions and select New - Event Definition..

Create a new XSD event definition named, ActivityEvent

, right-click on Event

. (xsd) from the pop-up menu

& o = 0]

Business Monitoring Praject., ..

X Dclete

Maonitar Madel, ..

Event Definitian. ,

I:-:I:ue]l

Event Definitian.

Euy Import...

___b. The ‘New XSD Schema’

4= New XML Schema

Create an XML Schema

Create a new XML schema,

panel opens as shown below:

Enter or select the parent Folder:

| ClipsandTacks

iy

------ = ClipsAndTacks

File name:

fdvanced > |

Einish I

Cancel

___c. Enter ‘ActivityEvent.xsd

" as ‘File name:’ and click Finish

___d. The schema you created is listed under the event definitions category and the schema is opened

in a simplified XSD editor
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B O
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L} Manitor Models

------ 88 svG Files

e
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o

= O

Wigw: Simplified - (7)

[5] Schema : http:iClipsandT acks/ AckivityEvent, xsd

(€] Elements

Types

Design] Source |

___e. You can use two views to edit an XML schema file, ‘Simplified’ or ‘Detailed’ view. Use the
Simplified view if you are new to XML schemas. Use the Detailed view if you are familiar with
XML schemas and their more complicated constructs (for example, groups, choices, attribute
references, and directives). To change the XSD editor view from ‘Simplified ' to ‘Detailed ’ click
on the pull down menu icon (=) located on the top right corner

___f. Click OK to confirm switching the XSD editor from simplified to detailed view mode

Wiew: Simplified = (7

Simplified

___g. The detailed view mode of the XSD editor is as shown below:

— View: Detaled = (7

== |5] Schema : http: )}/ ClipsAndTacks! ActivityEvent xsd

(== Directives

@ Elements

Tvpes

(& attributes

(1= Groups

Design | Source |

4. Review and update the <schema> element, which is the root element of the schema

___a. Inthe XSD editor, select the schema element and then select the ‘Details ' tab of the ‘Properties ’

view
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- —
Monitaring Flow | E=| Properties &3 Problems | Servers | Consaole ¥ =0

[General S| schema
Documentation Frefis: s <
Extensions

Target namespace: | http: )/ iClipsandTacks dctivibyEvent, xsd

> [GE]

___b. Update the ‘Prefix: ' from tns to ae (where ae stands for activity event and the prefix resembles
the name of the schema)

__c. Click the Advanced button to edit the schema information (attributes)
= Edit Schema Information

Targek Mamespace
| SttpefiClipsandTacks) ActivicyEvent, xsd

Mamespace Declarakions

Prefix | Marmespace Marme | add. ..
wesd hikkps e w3, orgf 2001 f¥MLSchema
ae  wEe—  httpf | ClipsandTacks) ActivityEvent, xsd Edit. .,

Delete

Prefix qualification of local elements) | qualified

Jo L

Prefix qualification of attributes: qualified

Ik I Cancel |

___d. Ensure that the prefix qualification of local elements and the attributes is set to ‘qualified ’

Note: Prefix qualification indicates whether locally declared elements or attributes must be qualified by the
target namespace in an instance document. If the value of this attribute is 'unqualified’, then locally
declared elements should not be qualified by the target namespace. If the value of this attribute is
‘qualified’, then locally declared elements must be qualified by the target namespace. Using 'qualified’
helps to ensure that expressions written to access pieces of information within a type are unambiguous.

___e. Click OK. The ‘General’ properties view of the ‘ActivityEvent’ schema should look like the picture
below:
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i - 5
Monitaring Flow | E=| Properties &5 Problems | Servers | Console ¥ =0

|
[General 5| schema
Documentation :
Prefix; ae B
Extensions

Target namespace: | http: )/ {ClipsandTacksActivibvEvent, xsd

> [EE]

__f. Save the changes. File - Save or Ctrl + S

5. Add a complex element type named, ActivityEventData and this sequence of elements to the
complex type

These are the elements - including the data types - that you are adding:

Name of the Element Type
businessUnit string
processName string
mclD string
activityName string
eventType string
startTime dateTime
endTime dateTime

___a. Right click in the Types section of the XSD editor and select ‘Add Complex Type ' from the pop-
up menu

Types

Add Complex Type

add simple Type

| Show properties

Refacktor »

References L

___b. Name the complex type as ActivityEventData and save the changes. You should see the new
complex type element added, as shown below:

| Types |
pctivityEventDats  sE——
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___c. Right click on the complex type ‘ActivityEventData ' again and select ‘Add Element ’ from the
pop-up menu. By default the new element is created with a default name ‘NewElement ' and xsd

type ‘string * as shown below:

B #activitvEvent ccsd

= O

-,

ActivityEwentData

ssc| [8] MewElement  string

Wiew: Detaled = (7

Design | Source |

___d. Modify the element name from ‘NewElement’ to ‘businessUnit ' and accept the default xsd type

as ‘string ’

B *activityEy

= O

-,

&ctivityEventData

sacl[€] businesslnit  skring

Wiew: Detaled = (7

Design | Source |

___e. Repeat the above instructions to add the remaining elements mentioned in the table. The final
‘ActivityEventData ' complex type should look like the picture below:

= O

-,

D‘:lla we—  Click here

AckivityEventData

[#] businessnit
[8] processMame
[&] mclIl

sasl 8] ackivityMarne
[8] evertType
[8] startTime
[2] endTime

skring
skring
string
string
skring
dateTime

dateTime

Wiew: Detailed = (7)

De=sign | Source |

=
___f. Now click the icon (%) located on the left corner. This leads you back to the full schema editor

view as shown below:
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— View: Detaled = (7

== |5] Schema : http: )}/ ClipsAndTacks! ActivityEvent xsd

(== Directives

(&) Elements Types
fitivityEventData -
(& attributes [ Groups

Design | Source |

__ 0. Save the changes. File - Save or Ctrl + S

6. Add another complex element type named OrderBOData and this sequence of elements to the

complex type

These are the elements - including the data types - that you are adding:

Name of the Element Type
orderNumber string
customerNumber string
orderState string
City string
Country string
productNumber string
Quantity int
totalPrice float

___a. Right click in the Types section of the XSD editor and select ‘Add Complex Type ' from the pop-

up menu

@ Tvpes

ActivibyEventData
OrderBOData

-
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___b. Now right click on the complex type ‘OrderBOData ' and select ‘Add Sequence ’ from the pop-up
menu. Note that a sequence is automatically added when you add an element to the complex

type.

___c. Right click on the complex type ‘OrderBOData ' again and select ‘Add Element ' from the pop-up
menu. By default the new element is created with a default name ‘NewElement ' and xsd type
‘string " as shown below:

B *activityEy

enk, xsd

"

x =8

Wigw: Detaled + (7)

OrderBOData

[8] MewElerment  string

Design | Source |

___d. Modify the element name form ‘NewElement’ to ‘orderNumber ' and accept the default xsd type
as ‘string ’

B *activityEy

enk, xsd

"

x =8

Wigw: Detaled + (7)

CrderBOData

[2] orderbumber  string

Design | Source |

___e. Repeat the above instructions to add the remaining elements mentioned in the table. The final
‘OrderBOData ’ complex type should look like the picture below:
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=0

-

View: Detailed <= (%)

OrderBCData

sss|—[8] orderMumber

[2] arderstate
[B] city
[8] country

[2] quarkiry
[2] ratalPrice

[2] customerMurber skring

[2] produckhumber skring

skring

skring
skring

skring

ik

Floak

Design | Source |

=
___f. Now click the icon (©%) located on the left corner. This leads you back to the full schema editor

view as shown below:

— View: Detaled = (7

=T [5] Schema : http:/}ClipsandTacks)ActivityEvent, xsd

(== Directives

@ Elements

Tvpes

fictivityEventData
OrderBCData =5

(& attributes

(1= Groups

Design | Source |

___ 0. Save the changes. File - Save or Ctrl + S

7. The following is the source of the ActivityEvent schema you created:
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<?uml wverzion="1.0" encoding="UTF-57"2> ;I
<xad:schema targetamespace="http:///ClipsindTacks/ ActivityEvent . x=4"
xmwlns:xsd="http: /S fvww. w3 .org/ 2001/ XML chema™

"http S fClipsindTacks AetivityEvent . xsd™

[ElementFDrmDefault="qualified" attrihuteFDrmDefault="qualified"‘}
cusdicomplexType napne="AcCivitYEVERTDATA ™ S—

<xzd:sequence:
<xad:element name="businessUnit" type="xsd:string"></x=sd:elements

<x=sd:element name="processName"™ type="xsd:string":r</x=d:elements
<xsdielement namwe="wcID" type="xsd:istring®r<Sxsd:elements
<xadielement nae="activityName" type="xsd:string"></wsd:elements>
<x=sd:element name="eventType™ type="xsd:string"></x=d:element>
cxsdielement name="startTime” type="xsd:dateTime"™:></x=d:ielements>
<usd:element name="endTime"™ type="xsd:dateTime"></x=d:element >
</ wad: sequence:
</fwad:icomplexTypex
<usdicomplexType nawe="0rderBOData’: E—
<xad:sequence:
<x=sd:element name="orderNumber™ type="xsd:string":></x=d:elements
<xad:ielement name="custowerMNumber®™ type="xsd:string"></w=ad:elements>
<xadielement namwe="order3tate” type="uxsd:string™r</xsdielement
<xadielement nawe="city"™ type="xsd:istring"r</x=sd:elements
cxsdielement name="country® type="xsd:stringtr<Sxadielementr
<usd:element name="productiumer™ type="xsd:string"></xsd:element>
<xad:element name="quantiry™ type="xsd:int"r</xsdielement
<x=sd:element name="totalPrice” type="xsd:float":></x=d:elements>
<fuad:sequencer
<fHsd:icomplexTypes
<fxad: achemas
Kl |

Designl Source | -ws—

8. WebSphere Business Monitor 6.1 has support for concurrent versions of monitor models. In order to
take advantage of the Monitor server's version handling capabilities, each monitoring context should
have a unique event definition that is the single inbound event that has the setting ‘If no instances
are found: Create new instance’. One can think of this as one inbound event carrying ‘create
monitor context’ semantics, and all others as ‘update monitor context’ semantics. Clips And Tacks is
a simple sample and could use a single event definition for the process. However, to satisfy the
requirement of a unique event definition for version handling, you will create a new event definition
that will create new instances of the monitor model.

__a. Inthe project explorer, right click on Event Definitions and select New - Event Definition...
(xsd) from the pop-up menu. The ‘New’ event definition panel opens
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% o =8

Business Maonitoring Project. ..

Ca I'E oy Monitor Model, .,
. i
.3 - Il Paste Event Definition. . (che)
X Delete Event Definition. .
2 Import. .,
£ Expart. ..
o Refrest

___b. Inthe New event definition panel, select ClipsAndTacks as the parent folder and enter the ‘File
name:’ as NewOrderEvent.xsd and click Finish

___C. Click ‘Yes’ aver the question dialog if it appears
9. Review and update the <schema> element, which is the root element of the schema

___a. Inthe XSD editor, select the schema element and then select the ‘General’ tab of the
‘Properties ' view

%
Manitaring Flow Problems | Servers | Console ¥~ =0

|
[ zeneral S| schema

Documentation

Prefix: tns —Ee———

Extensions

Target namespace: | http:ff iClipsandTacks MewOrderEvent, xsd

___b. Update the ‘Prefix: ' from tns to noe

Note: The ‘Target NameSpace Prefix ' hamespace can be given of your choice. 'noe’ is short for
‘NewOrderEvent’

___c. Click the Advanced button to edit the schema information (attributes)
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#= Edit Schema Information | x|

Targek Mamespace

| Sttp: i ClipsandTacks MewOrderEvent, xsd

Mamespace Declarakions

Prefisx | Mamespace Mame | add
xsd hitkp: / fenans w3, orgf2001 f5MLSchema
noe  =E— | htkp:/ifClipsandTacks/MewOrderEvent, xsd Edit

[elete

Prefix gualification of local elements:| | qualified

Jo L

Prefix qualification of attributes: qualified

Ik I Cancel

___d. Click the Add button to add the ActivityEvent namespace so the ‘ActivityEvent’ schema can be
imported to the current ‘NewOrderEvent’ schema. The ‘Add Namespace Declarations ' panel
opens

__e. Enter these parameters:
» Select the radio button for ‘Specify New Namespace ’
+ Prefix: ae
» Namespace Name : http:///ClipsAndTacks/ActivityEvent.xsd

+4= Add Namespace Declarations

i~ sSelect From Registered Namespaces

[ = Specify Mew Mamespace ]

Enter the required prefix and namespace LRI Far the namespace declaration.

Prefix: | ae —
Mamespace Mame:; | http: /fiClipsandTacksactivitvEvent, xsd  =ig—

Location Hink: | Erowse, .., |

Cancel

__f. Click OK
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4= Edit Schema Information
Target Namespace
| kkkps i iClipsAndT acksMewOrderEvent, xsd
Mamespace Declarations
Prefix | Mamespace Mame |
hikkp s f e w3, org 2001 f¥MLSchema
noe http: /i ClipsandTacksMewOrderEvent xsd  E— Edit... |
ae htkp: I ClipsAndTacks) ActivitvEvent, xsd -
Delete |
Prefix qualification of local elements I gualified j
Prefix qualification of attributes: I qualified j
(04 | Cancel |

___g. Ensure that the prefix qualification of local elements and the attributes is set to ‘qualified ’

___h. Click OK. The ‘General’ properties view of the ‘ActivityEvent’ schema should look like the picture

below:
. . = = )
Monitoring Flow Problems | Servers | Console i
|
[General S| schema

Docurmentation )
Prefix: nog sE—

Extensions

Target namespace: | http: ) iClipsAndTacks MewOrderEvent, xsd

__i. Save the changes. File > Save or Ctrl + S

___j. Ifthe ‘NewOrderEvent.xsd’ schema opens in a ‘Simplified ' XSD schema editor. Click on the pull-
down button (=) located on the top right corner of the XSD schema editor and select ‘Detailed’
from the drop down list.
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o

= 0O

=]

=3 Yiew: Detailed - (7)

@ Schema : http: fClipsandTacksMewdrderEvent, xsd
(A= Directives
(&) Elements Types
@ Attributes (I Groups

=]

Design | Source |

___ k. Right click any where in the ‘Directives ’ section and select ‘Add Import ’ from the pop-up menu
to import the ‘ActivityEvent’ schema. An empty XSD <import> element is added

[*=Directives

4 {No Location Specified) =s——— Select here

___ L. Inthe XSD editor, select the empty XSD <import> element and then select the ‘Properties’
General panel

>
rMonitoring Flow Problems | Servers | Console ¥ =0

[General “~ import
Daocurnmenkation
Marespace:
Extensions
Prefisx:
Schema location;

1) Click the button for ‘Schema Location '. The ‘Select XML Schema file ' panel opens

2008 February, 25 IBM WebSphere Business Monitor 6.1 — Lab exercise Page 19 of 84

ClipsAndTacks (XSD event definitions)



© Copyright IBM Corporation 2008. All rights reserved

4& select XML schema file

Include Another Schema B
Select another schema From workbench projects or from HTTP. r_:“*

Select schema From:

£+ Warkbench projects
" HTTP

Einish Zancel

2) Ensure the radio button next to ‘Workbench projects ' is selected and click Next

3) In this panel, expand the ‘ClipsAndTacks’ folder and then select ‘ActivityEvent.xsd’

4+ select XML schema file
Select XML schema file B
Select an %ML schema file From the Waorkbench projects r:“
Wiorkbench Files +| 4
= T& ClipsandTacks
AW ity Event vsd

Import Files. ., |
(7) < Barck | Mk = | Einish I Cancel

4) Click Finish . The Properties General panel should look the picture below:

Maonitaring Flow Problems | Servers

[General “~ import
) Mamespace; hittp: /i ClipsandTacks) ActivityEvent, xsd
Extensions
Prefix: ae

Schema location: | AckivityEvent, xsd

5) Save the configuration. File - Save or Ctrl + S

___m. Now right click in the ‘Types’ section and select the ‘Add Complex Type '’ from the pop-up

menu. An XSD <complexType> element is added with a default name
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Types
MewHSDComplexType = Select here

___n. Inthe XSD schema editor, select the empty XSD <complexType> element and then select the
‘Properties’ General panel.

1) Rename the name of the complexType element to ‘NewOrderEvent ’
2) Save the configuration. File - Save or Ctrl + S

___ 0. Now right click on the ‘NewOrderEvent ' complex type element and select ‘Add Sequence ’ from
the pop-up menu

___p- Right click on the ‘NewOQrderEvent ' complex type element again and select ‘Add Element ’ from
the pop-up menu. A new element of type string is added with a default name as shown below:

o

=0

&a View: Detaled « (2)

MewOrderEvent
e |&] MewElement  string we— Select here

Design | Source |

___ Q. Inthe XSD schema editor, select the XSD <element> and then select the ‘Properties’ General
panel

1) Rename the name of the element to ‘NEWActivityEventData

2) For the ‘Type:’ select ‘Browse ' from the drop down list. The ‘Set Type ' panel opens

MewOrderEvent

coa| 8] MEWACkivityEventData | 5tring -

Mew. .. ]
boolean
date
dateTime
double
Floak
hexBinary
ink

skring
Lirne
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4= Set Type

Mame (7 = any character, * = any string):

Twpes:

[=] arvsimpleType
= anyURI
|_=| hacafdRinaru ;I

Declaration Location:

Search Scope
i~ wiorkspace  © Enclosing Project £ Current Resource

" Working Sets | Choose. .. |
(0] 4 I Cancel |

3) Select ‘ActivityEventData’ from the ‘Types’ text area and click OK. The XSD schema
diagram and the properties view of the new ‘NEWActivityEventData ' element should look
like the picture below:

-

K@ AckivityEvent, xsd = B
D:la Wiew: Detaled = (7
MewCrderEvent / AckivityEventData
san [8] MEW AckivityEventData ActivivEventData 2| businessUnit skring
e| processhame skring
e| mcIh skring
2| ackivitvMarne skring
e| eventTvpe skring
&/ skarkTime dateTime
| endTime dateTime

Design 5:::uru:e|
' — - O ~
Monitoring Flow | = Properties 23 Praoblems | Servers | Consale 8

|
[General [¢] element
B Mame: MNEW ActivityEventData g
Extensions T p——— E
Twoe: aeifckivityEventData
Advanced e
Minimum Cccurrence: |E|
Maimurm Qcourrence: |E|
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___r. Now right click over the ‘NewOrderEvent ' complex type element and select ‘Add Element ’ from

2008 February, 25

the pop-up menu. A new element of type string is added with a default name as shown below:

Mew(rderEvent

[&] MEW AckivityEventData

[8] MewElement: skring

activicvEventData

1) Rename the name of the element to ‘NEWOrderBOData ’

2) For the ‘Type:’ select ‘Browse ' from the drop down list. The ‘Set Type ' panel opens

4= Set Type

Mame (? = anv character, * = any string):

Twpes:

= nonMegativelnteger
= nonPositivelnteger
[=] normalizedstring
[EINOTATION

[=] positivelnteger

Declaration Location:

[ESEOrderBOData - http:)) i ClipsandTacks ActivibyEvent, xsd

|5| MClipsAndTacksjactivityEvent. xsd

—Search Scope
" Workspace

8 Enclosing Project ¥ Current Resource

™ Working Sets |

Choose, ., |

o]

Zancel |

3) Select ‘OrderBOData’ from the ‘Types’ text area and click OK. The XSD schema diagram of
‘NEWOrderBOData ' element should look like the picture below:
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' “
@ *FhackivityEvent. xed = B
D‘:l.a Wigw: Detailed + (7)
MewOrderEvent I= | AckivityEventData
[B] MEMaCtivibyEventData ActivikyEventData 2| businessLnit string
[e] MEWOrderBOData OrderBOData £ processhame  string
e| mclD string
T e/ ackivitvMName string
e| eventType skring
| skartTime dateTime
2| endTime dateTime
r
= | OrderBOData
e | orderfumber skring
& | customerMurnber skring
e orderskate skrimg
el citw skring
&| country skring
& praductMurmber skring
B quantiry ink
e/ totalPrice Floak
Cesign | Source |
4) Save the configuration. File > Save or Ctrl + S
___s. The following is the source of the NewOrderEvent schema you created:

- O
<Fuml wersion="1.0" encoding="UTF-3"2:> AI
<xzd:schems targetNamwespace="http:///ClipsindTacks/NewOrderEvent . x=d™

xmlns:xsd="http://vww. w3 .org/ 2001/ EML3chema™
=3 ymlnz:noe="http: /S ClipzindTacks/NewlrderEvent . xa2d"
—a xmlnsiae="http:///ClipsindTacks/ Aot ivit¥Event . xsd”
[elementFormbefault="gqualified" attributeFormbefault="gqualified":|
—tge CxEd:import namespace="http:// ClipsindTacks/ ActivityEvent . xad™
achemalocation="ActivityEvent.xa3d"></ xad: imports
<xsd:complexType name="NewOrderEwvent "> -
<xsd:sequencex
<xsd:element name="NEWictivityEventData®
type=fae: ictivityEventDhata™>
</xadielenents
<xgd:element name="NEWOrderBQOData™ type="ae:OrderBOData"></xsd:element
</ wsd: sequencesr
<fxsdicomplexTypes
</ ®=d: schemas b
4
Design | Source | ap———
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__t. Close the XSD schema editor

10. Create a new monitor model ClipsAndTacks. The monitor model contains the metrics and KPIs that
you want to monitor and it is the source for creating the deployment code for the monitor server.

__a. Right click in the ‘Business Monitoring’ project explorer view and select New - Monitor
Model... from the pop-up menu. The Monitor Model panel opens

1) For the ‘File name:’, enter ClipsAndTacks

= Monitor Model

Create a monitor model

Create a new manitor model.

Enter or seleck the parent folder:
| ClipsandTacks

iy

------ 1= ClipsAandTacks

File name: | ClipsandTacks

Zancel |

2) Click Finish . Click Yes over the question dialog if you want to launch the ‘Getting Started’
information center. The model editor is opened as follows:

Note: When the model editor first opens you will have errors in the model. This is normal and is signaling
that required elements are missing or incomplete. Next you will complete these required elements.
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EL. Project Explorer 52 = O m = H

= 5| Monitor Details Model
H 25 ClipsandTacks
EI ¥ Evert Definitions = E,': w Monitor Details
. @ &ckionServicesEvent, che E}':"‘]’ ClipsandTacks MC Edit the details of the model,
[S] activityEvent, xsd Lof= ClipstndTacks Key The timestamp is required to identify the version of the model.

Eltm, Monitar Models

£...(888 SWG Files

|5] MeworderEvent,xsd I #| ClipsAndTacks

B, ClipsandTacks. mm Marme: ClipsandTacks

Descripkion:

B
=l
Tire Stamp (UTC): | 2007-10-15T16:07:552

w User-Defined XPath Functions

apecify and assign a prefix ka the user-defined function libraries
that are available For use within this monitor rmodel,

Monitor Details MndeIJ KPI Model | Dimensional Model | Wisal Model | Ewent Model | ClipsandTacks. mm |

11.

12.

13.

Natice in the Monitor Details Model navigator that a new model is created (ClipsAndTacks) along
with a monitoring context (ClipsAndTacks MC). Now you need to specify the inbound events that
are processed by this model. You need to indicate which event creates a new monitoring context
instance and which event terminates the monitoring context instance. You also need to identify the
correlation information for the monitoring context so that Monitor knows which monitoring context
instance should receive the events. The ClipsAndTacks model uses one event definition,
ActivityEvent, to represent the layout of all of the events to be processed. NewOrderEvent derives
from ActivityEvent but does not add additional event elements. In ActivityEvent, ActivityName is a
field used to identify specific activities in the ClipsAndTacks process. ActivityName is used to
determine when to terminate the monitoring context. You will create correlation that is based on
orderNumber, which is another field defined in ActivityEvent.

In the Monitor Details Model, expand ClipsAndTacks in the navigation view. Then expand
ClipsAndTacks MC. You will see that a key has been created for you automatically when you
created the model.

B H
=g ClipsAndTacks MC
i ClipsandTacks Key

In the model navigation view, right click on ClipsAndTacks MC, then select New - Inbound Event
from the pop-up menu

a. For the name, type Activity Event . Notice that the ID will automatically be set for you to the
same name with underscores (Activity Event )
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4= Create New Inbound Event

Create an inbound event

() Type the name and ID.

Mame: |Activity Event

I Ackivity _Event

L

: Zancel |

___b. Click OK. The inbound *‘ActivityEvent’ opens in an editor

___c. Inthe inbound ‘ActivityEvent’ editor, click the ‘Add’ button for ‘Event Parts ’ to create a new event
part type in the ‘Event Type Details’ section. The ‘Create New Event part Type’ panel opens

___d. Inthe ‘Create New Event part Type’ panel, enter the following:

1) Name : My Event Partl

2)ID : My_Event_Partl

3) Click the ‘Select Type ’ button for the ‘Type’ field. The ‘Select Event Part Data Type’ panel

opens

2008 February, 25

a) Select the check box for ‘Choose the data type from XML accessible from this
monitor project’

b) Expand ClipsAndTacks - ActivityEventData and select ‘ae:ActivityEventData '’

4% Select Event Part Data Type
Select event part data type

Choose the %ML schema data bype that defines the structure of this
event part,

"~ Mo data bype specified For this event park
¥ Choose the data bype from the %ML schemas accessible from this monitor project
= TB ClipsAndTacks
E||£| ActivitvEvent.xsd
I U E - .. o, ctivvityEvventDiaka
. -] aeOrderBOData
#- 5] MeworderEvent,xsd

™ Choose from the list of predefined XML schema simple data types
Twpe: I

=
Erawse. .. |

" Choose the bype From the predefined data bypes in the ¥ML catalog

Twpe: I

< Back:

Mext = | Einish I

Cancel |
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¢) Click Finish

4) Path : cbe:CommonBaseEvent/ae:ActivityEventData

Note: The path is an XML Path Language (XPath) expression that identifies the location in the event
definition of the structure defined by the event part type. The expression is based on the structure of the
actual event instance to be received at run time. It always starts with cbe: CormbnBaseEvent and
navigates into content that is placed in the xs: any slot of the Common Base Event. In general, if an XML
Schema Definition (XSD) used to define an event structure contains an <xsd:any> or <xsd:anyType> slot,
you should use an event part to specify the actual structure of the content that will fill that slot at run time.
In this event part, you use cbe:CommonBaseEvent/ae:ActivityEventData  as the path. Refer to
‘allXSDevents.xml ' located in the Labfiles61.zip file, to see how the XSD based events are being sent
during runtime.

4= Create New Event Part Type
Create an event part type
=

Specify the details of the event part. Together, all the event parts describe the S
struckure of the event at run time.,

Mame: | My Event Partl

ID: | My_Evert_Part1

Tvpe: | e ActivikyEventData Select Tvpe... |

Path: [l che:CommonBaseEventfae: AckivityEventData

(71 = Back MExt =

5) Click Finish

14. In the inbound *‘ActivityEvent’ editor, click the ‘Add’ button ‘Event Parts ’ again to create another
event part type in the ‘Event Type Details’ section. The ‘Create New Event part Type’ panel opens

___a. Inthe ‘Create New Event part Type’ panel, enter the following:
1) Name : My Event Part2
2)ID : My_Event_Part2

3) Click the ‘Select Type ' button for the ‘Type’ field. The ‘Select Event Part Data Type’ panel
opens

a) Select the check box for ‘Choose the data type from XML accessible from this
monitor project’

b) Expand ClipsAndTacks -> ActivityEventData.xsd and select ‘ae:OrderBOData ’
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4% Select Event Part Data Type
Select event part data type

Choose the %ML schema data bype that defines the structure of this
event part,

"~ Mo data bype specified For this event park
¥ Choose the data bype from the %ML schemas accessible from this monitor project

= TB ClipsAndTacks
E||£| ActivitvEvent.xsd

= ae:ActivityEventData

- ae:OrderBCOData
#-|5] MeworderEvent,:sd

™ Choose from the list of predefined XML schema simple data types

Twpe: I j

" Choose the bype From the predefined data bypes in the ¥ML catalog

Twpe: I Browse, .. |
< Back: Mext = | Einish I Cancel |

¢) Click Finish
4) Path : cbe:CommonBaseEvent/ae:OrderBOData

4% Create New Event Part Type
Create an event part type

Specify the details of the event part, Together, all the event parks I::ﬁ
describe the struckure of the event at run kime,

Marne: | My Event Partz

ID: | My_Event_Part2

Twpe: | ae:OrderBODaka Select Tvpe... |

Path;: [I cbe:CommonBaseEvent)ae: OrderB0Data |

(7 < Back: | [exh = |

Cancel |

5) Click Finish

___b. The final ‘Event Type Details’ section with the two ‘Event parts’ should look like the picture
below:
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+ Event Type Details

Specify the event bype ar the ¥ML schemas that together describe the struckure of this inbound event,
¥ou can specify an extension name, event parts, or both,

Extension name: | | Erowse, .., | | Clear |
Event parts: ID | Marne | Tvpe | Path
My Event_P... MwEventP...  ae:ActivitvEventData cbe:CommonBaseEventae: ActivitvEventData
My _Ewent_P... My EventP... aeiOrderBOData che: CommonBaseEvent/ae: OrderBODaka

___C. Save the configuration. File - Save or Ctrl + S

___d. To enter the Filter Condition , use Content Assist (ctrl-space), or type the expression directly
into the expression window. When completed the expression should be as follows. Note the
single quotation marks used for string handling.

Activity Event/My_Event_Partl/ae:businessUnit = 'Clips And Tacks' and
Activity Event/My_Event Partl/ae:processName = 'Order Handling'

___e. To enter the Correlation Expression , use Content Assist (ctrl-space), or type the expression
directly into the expression window. When complete the expression should be

ClipsAndTacks_Key =Activity Event/My Event Part2/ae:orderNumber
___f. For ‘If no instances are found’, select ‘Treat as error’
___g. For ‘If one instance is found’, select ‘Deliver to the instance’
___h. For ‘If multiple instances are found’, select ‘Treat as error’

___i. Here is a sample of a portion of the definition:

+ Filter Condition

Define a condition based on the event attributes to identify whether to accept an event of this bvpe.

Ackiviey_Ewvent/My_Event_Partl)ae:businessnit = 'Clips And Tacks' and ;I
Ackivity_Ewvent/My_Event_Partljae:processMame = 'Order Handling'
hd

+ Correlation Expression

Define an expression ko identify the monitoring context instance or instances that receive the event at
runkirme,

ClipsandTacks_Kew = Activity _Event/My_Event_Part2/ae:orderMumber

If no instances are found Treak as error

If ane inskance is Found Deliver ko the instance

FEEE E

If multiple inskances are found | Treat as error

___j. Save the configuration. File - Save or Ctrl + S
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15. In the model navigation view, right click on ClipsAndTacks MC, then select New - Inbound Event
from the pop-up menu

___a. For the name, type New Order Event . Notice that the ID will automatically be set for you to the
same name with underscores (New_Order_Event )

___b. Click OK. The inbound ‘NewOrderEvent’ opens in an editor

___¢. Inthe inbound ‘NewOrderEvent’ editor, click the ‘Add’ button for ‘Event Parts ' to create a new
event part type in the ‘Event Type Details’ section. The ‘Create New Event part Type’ panel
opens

___d. Inthe ‘Create New Event part Type’ panel, enter the following:
1) Name : My Event Part
2)ID : My_Event_Part

3) Click the ‘Select Type ’ button for the ‘Type’ field. The ‘Select Event Part Data Type’ panel
opens

a) Select the check box for ‘Choose the data type from XML accessible from this
monitor project’

b) Expand ClipsAndTacks - NewOrderEvent.xsd and select
‘noe:NewOrderEvent '

+4= Select Event Part Data Type
Select event part data type

Choose the %ML schema data bype that defines the structure of this
event park,

™ Mo data bvpe specified for this event part

% Choose the data bype From the %ML schemas accessible from this monitor project

== ClipsandTacks
- [5] AckivityEvent.xsd
B [5] MeworderEvent,xsd
L[] .

& MewOrderEvent

™ Choose from the lisk of predefined XML schema simple data kvpes

Tvpe: I ;I

" Choose the type From the predefined data bypes in the %ML cakalog

Tvpe: | Erowse, .. |
= Back Fext = | Einish I Cancel |

¢) Click Finish

4) Path : cbe:CommonBaseEvent/noe:NewOrderEvent
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Note: The path is an XML Path Language (XPath) expression that identifies the location in the event
definition of the structure defined by the event part type. The expression is based on the structure of the
actual event instance to be received at run time. It always starts with cbe: CormbnBaseEvent and
navigates into content that is placed in the xs: any slot of the Common Base Event. In general, if an XML
Schema Definition (XSD) used to define an event structure contains an <xsd:any> or <xsd:anyType> slot,
you should use an event part to specify the actual structure of the content that will fill that slot at run time.
In this event part, you use cbe:CommonBaseEvent/ noe:NewOrderEvent  as the path. Refer to
‘allXSDevents.xml ' part of the Labfiles61.zip to see how the XSD based events are being sent during
runtime.

4= Create New Event Part Type
Create an event part type

.
Specify the details of the event part. Together, all the event parts | Sl
describe the structure of the event at run time,

Mame: I My Evenk Park

I | My_Event_Part

Type: Inne:NewOrderEvent Select Type. .. |

Path: [Icbe:CDmmDnBaseEventJ‘nDe:NewOrderEvent

(71 = Back Mexk =

] Zancel |

5) Click Finish
___e. The final ‘Event Type Details’ section with the ‘Event part’ should look like the picture below:

+ Event Type Details

Specify the event type or the XML schemas that together describe the structure of this inbound event,
¥ou can specify an extension name, event parks, or bath,

Extension narme: | | Erowse, .., | | Clear |

Evert parts: I | rarme | Tvpe | Path
My_Ewent_Part My Event Part  noe:MewOrderEvent che: CommonBaseEvent/noe: MewlrderEvent

__f. Save the configuration. File - Save or Ctrl + S

___g. To enter the Filter Condition, use Content Assist (ctrl-space), or type the expression directly into
the expression window. When complete, the expression should be as follows. Note the single
guotation marks used for string handling.

New_Order_Event/My_Event_Part/noe:NEW ActivityEventData/ae:businessUnit = 'Clips And
Tacks' and New_Order_Event/My_Event_Part/noe:NEWActivityEventData/ae:processName
='Order Handling'

___h. To enter the Correlation Expression, use Content Assist (ctrl-space), or type the expression
directly into the expression window. When complete the expression should be
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ClipsAndTacks_Key =
New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:orderNumber

___i. For ‘If no instances are found’, select ‘Create new instance’
___j. For ‘If one instance is found’, select ‘Treat as error’
___ k. For ‘If multiple instances are found’, select ‘Treat as error’

___|. Here is a sample of a portion of the definition:

= Filter Condition
Define a condition based on the event attributes to identify whether bo accept an event of this bvpe.

Mew_Order_Event/My_Ewent_Part/noe:MEW ActivityEventDatalae:businessUnit = 'Clips And Tacks' and
Mew_Crder_Ewvent/My_FEvent_Part/noe:MEW ActivityEventData)ae: processMame = "Order Handling'

N I

+ Correlation Expression
Cefine an expression to identify the monitoring context inskance or instances that receive the event at runtime.

ClipsfndTacks_Key = New_Order_Event/My_Ewvent_Park/nog:MEWOrderBODaka)ae orderMurnber

If noinstances are found Creake new inskance
If one instance is Found Treak as error

If rulkiple instances are Found | Treak as error

FEE R

___m. Save the configuration. File - Save or Ctrl + S
16. In the model navigation view, double click ClipsAndTacks Key , to open the key in the editor

___a. For Key Value Expressions, click ‘Add..." Note that double clicking in the table will produce the
same results.

__b. Arow is added to the table and in the expression cell it shows << No expression specified >>.
Click on this cell of the table, then a button is displayed. Click on this button and the expression
editor is displayed. You can use Content Assist, or type this expression directly into the window:

New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:orderNumber
___c. Click OK.

___d. Here is a sample of the key:
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10 4 ClipsandTacks_Keyw

ame: ClipsandTacks Key

Description: ;I
[

Type: *l String ka3

Maximum Skring Length: | 256

O allocate additional space in database ko accommodate Unicode string For globalization

O & value is required For this metric

Default Value: Edit. ..
[ This key can be used for sorting

+ Key ¥Yalue EXpressions
Specify the expressions that set the walue of the ke,

| Add | | Remoyve |

__e. Save the configuration. File > Save or Ctrl + S

Note: At this point there should not be any errors remaining in the model. The errors shown initially were
the result of the monitoring context key not being complete.

17. Create triggers that indicate the end of the monitoring context. The first trigger is based on an order
being shipped, and the second trigger is based on an order being cancelled.

__a. Inthe model navigation view, right click on ClipsAndTacks MC , then select New -> Trigger .
Enter the following values:

1) Name : Ship Order to Customer Trigger
2)ID  :Ship_Order_to_Customer_Trigger

3) Select the check box next to ‘Terminate monitoring context

4) For Trigger Sources, click Add, then select Other source type -> Activity Event and then
click OK

5) For Trigger Condition, enter

Activity Event/My_Event_Partl/ae:activityName = 'Ship Order to Customer' and
Activity Event/My_Event_Partl/ae:eventType = 'completed'

__b. Save the configuration. File > Save or Ctrl + S

___c. Here is a sample of this trigger:

2008 February, 25 IBM WebSphere Business Monitor 6.1 — Lab exercise Page 34 of 84

ClipsAndTacks (XSD event definitions)



© Copyright IBM Corporation 2008. All rights reserved

+ Trigger Details

Edit the detalls of the trigger, which detects an occurrence and initlates an ackion in response.

10 + 3hip_Order_to_Cuskomer_Trigger
farme: Ship Order to Customer Trigger
Description: ||

[ Trigger is repeatable
Terminats monitaring context  seE————

+ Trigger Sources
Specify the source of this krigger,

Source Tvpe Source

R L

Event ogf Bckivity Event

| Add

| | Remave |

+ Trigger Condition
Specify the condition that determines whether the trigger will Fire,

Activity_Ewventfiy_Ewent_Partl/ae:activityMame = 'Ship Order to Cuskomer' and
Ackivity EwventfMy_Fwent_PartlfaeeventType = ‘completed’

E
i

___d. In the model navigation view, right click on ClipsAndTacks MC, then select New > Trigger .

18.

Enter these values:
1) Name : Cancel Trigger
2)ID : Cancel_Trigger

3) Select the check box next to ‘Terminate monitoring context

4) For Trigger Sources, click Add, then select Other source type > Activity Event, then click

OK.

5) For Trigger Condition, enter

Activity Event/My_Event_Partl/ae:activityName = '‘Cancel Order and Send Notification' and

Activity Event/My_Event_Partl/ae:eventType = 'completed'

e. Save the configuration. File - Save or Ctrl + S

Create a KPI for Average fulfillment 3 days or less. First you will create a trigger which fires when a
new order is started. Metrics are created to hold the order start time and order end time. The
values of the metrics are set when the new order trigger fires. You create a duration metric which is
calculated based on subtracting the order end time metric from the order start time metric. You will
create a KPI context which is a container to hold the KPIs. Then you create a KPI which is based

on the duration metric and you apply an average function to it.

Enter these values:
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1) Name : New Order Trigger
2)ID : New_Order_Trigger

3) For Trigger Sources, click Add, then select Other source type > New Order Event, then click
OK.

4) For Trigger condition, enter

New_Order_Event/My_Event_Part/noe:NEW ActivityEventData/ae:activityName = 'Check
Order Handling Policy for Automatic Approval' and
New_Order_Event/My_Event_Part/noe:NEW ActivityEventData/ae:eventType = 'started'

5) Save the configuration. File - Save or Ctrl + S

__b. Inthe model navigation view, right click on ClipsAndTacks MC, then select New - Metric .
Enter these values:

2008 February, 25

1) Name : Order Start Time

2)ID : Order_Start_Time

3) Type :DateTime

4) For Metric Value Expressions, click Add

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

6) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

New_Order_Event/My_Event_Part/noe:NEW ActivityEventData/ae:startTime
7) Click OK.

8) Save the configuration. File > Save or Ctrl + S
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- Metric Details
Edit the details of the metric, which is a holding spat For information used in other calculations,

j (nH « Order_Start_Time

Marme: Order Start Time

Descripkion: ;I
[

Twpe: - DateTime El

O & walue is required For this metric

Default YWalue:

[ This metric can be used for sorting

w Metric ¥alue Expressions
Specify the expressions that set the value of the metric, IF a trigger is specified, the map is evaluated when the trigger fires,

__c¢. Inthe model navigation view, right click on ClipsAndTacks MC, then select New - Metric. Enter
these values:

1) Name : Order End Time

2) ID : Order_End_Time

3) Type :DateTime

4) For Metric Value Expressions, click Add

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> Ship Order to Customer Trigger, click OK

6) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

Activity Event/My_Event_Partl/ae:endTime
7) Click OK.
8) For Metric Value Expressions, click Add
9) In the second row of the Metric Value Expressions table, select the cell under column
Trigger, then a button is shown, then click the button and select Trigger type >
ClipsAndTacks MC > Cancel Trigger, click OK
10) In the second row of the Metric Value Expressions table, select the cell under column

Expression, then a button is shown, then click the button and enter this text:
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Activity Event/My_Event Partl/ae:endTime
11) Click OK.

__d. Save the configuration. File - Save or Ctrl + S

+ Metric Details
Edit the details of the metric, which is a holding spat Far information used in other calculations,

10 « Order_End_Time
Marme; Crder End Time
Descripkion:

Type: *I-M

O & walue is required for this mekric

Default Yalue: Edit...

I K1 R ]

O This metric can be used For sorting

= Metric ¥alue EXpressions
Specify the expressions that set the walue of the metric, IF a trigger is specified, the map is evaluated when the trigaer fires,

Trigger | Expression |
?5=:3>5hi|:| Crder to Customer Trigoer xﬂ Ackivity _Event/My_Event_Partlae:endTime
?5=:-'>Can|:el Trigaer x-;v Ackivity _Event/My_Event_Partlfae:endTime

___e. Inthe model navigation view, right click on ClipsAndTacks MC, then select New > Metric . Enter
these values:

1) Name : Order Fulfillment Duration

2)ID : Order_Fulfillment_Duration

3) Type : Duration

4) For Default Value, click Edit...

5) On the Select Duration dialog, click OK, and this will set the default duration to zero

6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> Ship Order to Customer Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

xs:dayTimeDuration(Order_End_Time - Order_Start_Time)
9) Click OK
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10) For Metric Value Expressions, click Add

11) In the second row of the Metric Value Expressions table, select the cell under column
Trigger, then a button is shown, then click the button and select Trigger type >
ClipsAndTacks MC > Cancel Trigger, click OK

12) In the second row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

xs:dayTimeDuration (Order_End_Time - Order_Start_Time)
13) Click OK.

___f. Press Ctrl-S to save your work.

w Metric Details
Edit the details of the metric, which is a holding spok For information used in other calculations.

O & walue is required For this metric

10 « Drder_Fulfillment_Duoration

Mame: Order Fulfillment Duration

Drescription: | ;I
=

Type: *l Duration IE'

Defaulk Yalue: | dayTimeDuration PODTOHOMO, 0005 Edit...
[ This metric can be used For sorting

+ Metric ¥alue Expressions
Specify the expressions that set the value of the metric, IF a trigger is specified, the map is evaluated when the trigger fires,

Trigger | Expression |
55=:'t>5hip Order bo Customer Trigger ﬁv waidayTimeDuration (Order_End_Time - Order_Sktart_Time)
?5=:5>Cann:el Trigger x—:f;v wsrdayTimeDuration (Order_End_Time - Order_Skark_Time)

| Add | | Remove |

___g. Click the KPI Model tab .
___h. Create a KPI context to store the KPlIs.

1) In the navigation view of the KPI Model, right click on ClipsAndTacks, then select New >
KPI Context

a) Name :- My KPI Context
b) ID .- My_KPI_Context

___i. Create the average order fulfillment KPI.
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Note that you will create the KPI based on events for August 2006. This will work for you no matter what
month or year that you run this lab because the timestamps in the test data are based on August 2006, so
your results will be the same as in these lab instructions.

1) In the navigation view of the KPI Model, right click on My KPI Context , then select New >
KPI

a) Name :- Average Order Fulfillment KPI August 2006

b) ID .- Average_Order_Fulfillment_KPI_August_2006
2) Enter these values:

a) Type — Duration

b) In KPI Target and Ranges, for Target click Detalils ..., then change the value to 3
Days, then click OK

c¢) In KPI Target and Ranges, for Ranges select Actual value
d) In the Range table,
(1) Click Add, or double click anywhere in the table
(2) Change the Name to Day 1, and the ID to Day_1
(3) Arow is created in the Range table with a range name Day 1.

(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change all values to 0, then click OK.

(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change Days to 1 and the other values
to 0, then click OK.

e) Now you have created one range called Day 1. Repeat the above step to create
four more ranges:

(1) Day 2 with start values 1 Days and end value 2 Days
(2) Day 3 with start values 2 Days and end value 3 Days
(3) Day 4 with start values 3 Days and end value 4 Days
(4) Day 5 with start values 4 Days and end value 5 Days
f) KPI Value — select ‘Base this KPI on a metric and an aggregation functi  on’

g) Under KPI Details, for Monitoring context, click Browse..., then select
‘ClipsAndTacks MC ’, then click OK

h) Metric — click Browse..., then select Order Fulfillment Duration , then click OK
i) Aggregation function — select Average .

j) Under Time Filter, for Metric, click Browse..., then select Order Start Time , then
click OK
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k) Specify time period — Fixed
[) Start date — click Edit... then select date 2006-08-01, time 00:00:00, click OK
m) End date — click Edit..., then select 2006-08-31, time 23:59:59, click OK

3) Press Ctrl-S to save your work.

= KPI Details
Edit the details of the KPI, which is a performance measurement used to track business objectives,

10: ¢ dverage_Order_Fulfillment_KPI_August_2006

Mame: fverage Order Fulfillment KPT August 2006

Descripkion: ;I
=

Tvpe: N Duration Iz‘

+ KPI Target and Ranges

Specify a karget, which is an exact walue for the KPI ko achieve, or ranges against which bo krack the KPT,
ar bakh,

Targetk: 3 Days
Ranges: *l Actual value E
Range name | Skark value | End value |
= Day 1 0 Milliseconds < 1Days
= Day 2 1 Days < 2 Days
E Day 3 2 Days < 3 Days
= Dav 4 3 Days < 4 Days
= Day S 4 Days = 5 Days
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+ KPI Definition
Specify how the value of the EPT is set,

KPl Value

Choose how the KPT will get its walue:

{2} Base this KPI on a metric and an aggregation function,

) Write an expression to calculate this KPI based on existing KPIs

K.Pl Details

Monitoring context: . ClipsAndTacks mC Browse, .,

Metric: 4 Crder Fulfillment Duration

Aggreqation funckion: *l Average

IJse values from; & all model versions € Only this version of the model

Time Filter
Select a time period over which the KPI should be calculated,

Metric: | Order Start Time

Time period;
) Mone O Repeating Q) Rolling &) Fixed

Start date: |2006-05-01T0O0:00:00 End date: | 2006-05-31T723:59:59

Time zone; *IGMT-UE:UU :l Location: I |:

___j. Note that this KPI as it stands averages order fulfillment time for shipped orders and cancelled
orders, but you probably are not interested in the cancelled orders to be included in this KPI. So
update the average order fulfillment KPI to show the values for shipped orders only. First you
will create a new metric to hold the order status. Then you will add this metric as a data filter on
the KPI.

___k. Click the Monitor Details Model tab

___ L. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New
- Metric. Enter these values:

1) Name :- Order Status

2) ID :- Order_Status

3) Type :- String

4) Select the check box for ‘A value is required for this metric ’

5) Default Value (enter this text with single quotation marks) — ‘New’

6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> Cancel Trigger, click OK
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8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text with the
guotation marks:

‘Cancelled’
9) Click OK.
10) For Metric Value Expressions, click Add

11) In the second row of the Metric Value Expressions table, select the cell under column
Trigger, then a button is shown, then click the button and select Trigger type >
ClipsAndTacks MC > Ship Order to Customer Trigger, click OK

12) In the second row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text with the
guotation marks:

‘Shipped’
13) Press Ctrl-S to save your work

- Metric Details

Edit the details of the metric, which is a holding spot For information used in other calculations.

10 4 Order_Skatus

Marne: Order Skatus

Description: ﬂ
=

Type: *l String K

Mazimurn Skring Length: | 256

O allocate additional space in database bo accommodate Unicode string For globalization

i value is required For this metric,  sgE——

Default value: ) MNew'

[ This metric can be used For sorting

~ Metric Yalue Expressions
Specify the expressions that set the value of the metric, IF a krigger is specified, the map is evaluated when the trigger fires,

Trigger | Expression

Edit .,

=2 Cancel Trigger =5 'Cancelled
5€*=:'t>5hip Order to Cuskomer Trigger DE?" 'Shipped'

___m. Update the order fulfilment KPI to use the order status as a filter.

1) Click the KPI Model tab .

2) In the KPI Model navigation view, navigate to ClipsAndTacks > My KPI Context > Average

Order Fulfillment KPI August 2006

3) In the Data Filter section for this KPI, click Add
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4) In the dialog, navigate to ClipsAndTacks MC -> Order Status , then click OK

5) In the row containing metric Order Status, make sure the operation defaults to ‘equals’.
Also, click the cell in the column Values, then enter this text (with quotation marks):

‘Shipped’

6) Press Ctrl-S to save your work.

Case-sensitive

____19. Create a KPI for number of approved orders greater than 90%. First you will create a KPI to count
the number of total orders. Then you will create a KPI to count the number of shipped orders.
Finally, you will create a KPI that calculates the approval percentage as this formula: (ship count /
order count) * 100.

___a. Click the KPI Model tab then create the order count KPI.

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New >
KPI

a) Name :- Order Count KPI
b) ID :- Order_Count_KPI
2) Enter these values:
a) Type :- Decimal
b) Do not specify targets nor ranges

c) KPI Value — select ‘Base this KPI on a metric and an aggregation functi  on

d) Under KPI Details, for Monitoring context, click Browse..., then select
‘ClipsAndTacks MC ’, then click OK

e) Metric — click Browse..., then select ClipsAndTacks Key , then click OK
f) Aggregation function — select Count
3) Press Ctrl-S to save your work.
___b. Create the ship count KPI.

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New >
KPI

a) Name :- Ship Count KPI
b) ID :- Ship_Count_KPI
2) Enter these values:
a) Type :- Decimal
b) Do not specify targets nor ranges
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c¢) KPI Value — select ‘Base this KPI on a metric and an aggregation functi  on’

d) Under KPI Details, for Monitoring context, click Browse..., then select
‘ClipsAndTacks MC ’, then click OK

e) Metric — click Browse..., then select ClipsAndTacks Key, then click OK
f) Aggregation function — select Count
g) In the Data Filter section for this KPI, click Add
h) In the dialog, navigate to ClipsAndTacks MC -> Order Status , then click OK
i) In the row containing metric Order Status, make sure the operation defaults to
‘equals’. Also, click the cell in the column Values, then enter this text (with
guotation marks):
‘Shipped’
3) Press Ctrl-S to save your work.

___c. Create the percent of orders approved KPI.

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New >
KPI

a) Name :- Percent of Orders Approved KPI

b) ID :- Percent_of_Orders_Approved_KPI
2) Enter these values:

a) Type :- Decimal

b) In KPI Target and Ranges, for Target click Details..., then change the value to 90,
then click OK

c¢) In KPI Target and Ranges, for Ranges select Actual value
d) In the Range table,
(1) Click Add
(2) Change the Name to Low Range , and the ID to Low_Range
(3) Arow is created in the Range table with a range name Low Range.
(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change the value to 0 and then click
OK.
(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change the value to 90 and then click
OK.

e) Repeat the above step to create one more range:

(1) High Range with start value 90 and end value 100
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f) KPI Value — select ‘Write an expression to calculate this KPI based on existing
KPIs’

g) For KPI Calculation, enter this text:
fn:round((Ship_Count_KPI div Order_Count_KPI) * 100)

3) Press Ctrl-S to save your work.

+ KPI Target and Ranges

Specify a karget, which is an exact value For the KPI to achieve, or ranges against which to track the KPI, or both,

Target: N

Ranges: *I Actual value IE'
R.ange name | Start walue | End walue |
= Low Range 1] < 90
= High Range ag < 100

| Add ||Rem|:uve|| Sork |

= KPI Definition
Specify how the value of the KPT is set,

KPI Yalue

Chaose how the KPT will get its value:
{2} Base this KPI on a metric and an aggregation Function,
(2} Write an expression ko calculate this KPI based on existing KPIs
KPI Calculation
For example, vou could hawe a Total Profit KPT that subtracts the Tokal Cost KPI From the Total Revenue EPLL

Y Friround{{Ship_Count_EPT div Order_Count_KPI) * 1007 ;I

____20. Inthe dashboards, you might like to see the total order price, the average order price and the total
number of orders. And you might be interested in seeing this information by country and city, and
by order status. So now you will create dimensions and measures that allow you to see this
information. For aggregated numeric information like total order price, you will create a measure in
the dimensional model. For textual attributes like order status, you will create a dimension in the
dimensional model. In order to see the country and city information, you will create a multi-level
location dimension containing country as the first level and city as the second level. Each measure
and dimension needs a metric as a source, so you will also need to create metrics for country, city

and total price.
___a. Click on the Dimensional Model tab
___b. Add order status as a dimension to the Dimensional Model.

1) In the navigation view, click on ClipsAndTacks MC Cube

2) In the dimensions table, click New Dimension...
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a) Name :- Order Status Dimension
b) ID .- Order_Status_Dimension
c) Click OK

3) Click New Level...
a) Name :- Order Status
b) ID :- Order_Status

¢) Source metric — Click Browse..., then select ClipsAndTacks MC - Order Status .
Then click OK.

d) Click OK.

4) Press Ctrl-S to save your work.

+ Dimensions
Work with the dimensions and dimension levels of this cube, Dimensions are data cateqories made up of hierarchical dimension lewvels,

Dimension [ Dimension Leyvel | Source Metric | Mew Dimension. ..
= H' crder Status Dimensian
=" Order Status [ Order Status Mew Lewvel, .,

Remove
Mave

Move Down

]

___c. Click the Monitor Details Model tab

___d. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New
> Metric . Enter these values:

1) Name :- country
2)ID ;- country
3) Type :- String

4) Select the check box for ‘A value is required for this metric

5) Default value : " (Note: Empty single quotation marks)
6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:country
9) Click OK.
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10) Press Ctrl-S to save your work

___e. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New
> Metric . Enter these values:

1) Name :- city
2)ID - city
3) Type :- String

4) Select the check box for ‘A value is required for this metric

5) Default value : * (Note: Empty single quotation marks)
6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:city
9) Click OK.
10) Press Ctrl-S to save your work

___f. In the Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New >
Metric . Enter these values:

1) Name :- totalPrice

2)ID :- totalPrice

3) Type :- Decimal

4) For Metric Value Expressions, click Add

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

6) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

New_Order_Event/My_Event_Part/noe:NEWOrderBOData/ae:totalPrice
7) Click OK.
8) Press Ctrl-S to save your work
___g. Click on the Dimensional Model tab .
___h. Add location as a dimension to the Dimensional Model.

1) In the navigation view, click on ClipsAndTacks MC Cube
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2) In the dimensions table, click New Dimension...
a) Name :- Location
b) ID .- Location
c) Click OK

3) Click New Level...

a) Name :- Country

b) ID :- Country

¢) Source metric — Click Browse..., then select ClipsAndTacks MC - country . Then
click OK.

d) Click OK.

4) Click New Level...
a) Name :- City
b) ID .- City

¢) Source metric — Click Browse..., then select ClipsAndTacks MC - city. Then
click OK.

d) Click OK.

5) Press Ctrl-S to save your work.

 Dimensions
W'ark with the dimensions and dimension levels of this cube, Dimensions are data categories made up of hierarchical dimension levels.

[ae Do

Dimension | Dimension Level | Source Mekric | Mew Dirnension, ..
= ' order Status Dimensian
|5 Order Status [ Order Skatus
2 % ocsior ¢
= 5" Country [ conkey
= o =t

___i. Ensure that the Dimensional Model tab is selected.
___j- Inthe Dimensional Model, add a measure for average order price.
1) In the navigation view, click on ClipsAndTacks MC Cube
2) In the Measures table, click New ...
a) Name :- Average Order Price
b) ID :- Average_Order_Price

c¢) Source metric - Click Browse..., then select ClipsAndTacks MC - totalPrice .
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d) Aggregation function: - select Average .

3) Press Ctrl-S to save your work.

+ Measures

Waork with the measures For this cube, Measures are calculations based on a metric, key, counker, or skopwatch,

Measure

| Source Metric

| Aggregation Function

rritaverage Order Price

I katalPrice

Average

___k. Inthe Dimensional Model, add a measure for sum of order price.

1) In the navigation view, click on ClipsAndTacks MC Cube

2) In the Measures table, click New ...

b) ID

e) Then click OK.

a) Name :- Sum Order Price

:- Sum_Order_Price

d) Aggregation function — select Sum.

3) Press Ctrl-S to save your work.

___|. In the Dimensional Model, add a measure for order count.

1) In the navigation view, click on ClipsAndTacks MC Cube

2) In the Measures table, click New ...

b) ID

a) Name :- Order Count
:- Order_Count

¢) Source metric - Click Browse..., then select ClipsAndTacks MC >

ClipsAndTacks Key .

e) Then click OK.

d) Aggregation function — select Count.

3) Press Ctrl-S to save your work.
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c¢) Source metric - Click Browse..., then select ClipsAndTacks MC - totalPrice .
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- Measures
‘hark, with the measures Faor this cube, Measures are caloulations based on a metric, key, counter, or stopwatch,

Measure | Source Mekric | Aggregakion Funckion Mew
riAverage Order Price [ kotalPrice Average

[ Sum Order Price [ totalPrice Sum
r Order Counk = ClipsAndTacks Key Counk

21. Inthe dashboards you might like to see the average order price and track that relative to a target.
___a. Create a KPI for the average order price.
1) Click the KPI Model tab .

2) In the navigation view of the KPI Model, right click on My KPI Context, then select New -
KPI

a) Name :- Average Order Price KPI (Dollars)

b) ID .- Average_Order_Price_KPIl__x0028_Dollars_x0029
3) Enter these values:

a) Type :- Decimal

b) In KPI Target and Ranges, for Target click Detalils..., then change the value to 300,
then click OK

c¢) In KPI Target and Ranges, for Ranges select Actual value
d) In the Range table,
(1) Click Add
(2) Change the Name to Low Range , and the ID to Low_Range
(3) Arow is created in the Range table with a range name Low Range.
(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change the value to 0, and then click
OK.
(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change the value to 300, and then click
OK.

e) Now you have created one range called Low Range. Repeat the above step to
create one more range:

(1) High Range with start value 300 and end value 1000

f) KPI Value — select ‘Base this KPI on a metric and an aggregation functi  on

g) Under KPI Details, for Monitoring context, click Browse..., then select
‘ClipsAndTacks MC ’, then click OK

h) Metric — click Browse..., then select totalPrice , then click OK
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i) Aggregation function — select Average .

4) Press Ctrl-S to save your work.

= KPIl Target and Ranges

Specify a karget, which is an exact value For the KPI to achieve, or ranges against which to track the KPI, or baoth,

Target: 300

Ranges: N Actual value IE‘
Range name | Skart value | End «walue |
= Low Range 0 < 300
& High Range 300 = 1000

+ KPI Definition
Specify how the value of the KPI is set,

KPPl Yalue
Choose how the EPT will get its value:

(¥} Base this KPI on & metric and an aggregation Funckion,

O write an expression to calculate this KPI based on exisking KPIs

KPPl Details

Monitoring contexk: ) ClipsAandTacks MC
Mekric: + bokalPrice
Aggregation function; *I-m |z|

____22. (Optional) To demonstrate the use of a counter, you can optionally use this section to create a
counter which is incremented if you ship the order (rather than canceling the order). For every
monitoring context, this counter is either zero or one depending on whether the order is cancelled or
shipped. Counters would be more useful in other scenarios — perhaps to count the number of times
an iterated activity is executed.

___a. Inthe Monitor Details Model navigation view, right click on ClipsAndTacks MC, then select New
> Counter . Enter these values:

1) Name :- Ship Counter
2)ID :- Ship_Counter

3) For Counter Controls, click Add, then select ClipsAndTacks MC - Ship Order to
Customer Trigger , click OK

4) Note that the Resulting Action defaults to Add One, which is correct.

___b. Press Ctrl-S to save your work
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* Counter Details
Edit the details af the counter, which counts the number of occurrences of some situation or event,

j(xR  Ship_Counker

Mame: Ship Counter
Descripkion: ;I
=
O This counter can be used for sorting

* Counter Controls
Specify what causes the counter ko change and what ackion is taken,

Trigger | Inbound Exvent | Resulting Ackion |
?5=:€>Shi|:u Order to Customer Trigger Add Cne

23. (Optional) ) To demonstrate the use of a stopwatch, you can optionally use this section to create a
timer which will measure the duration of the monitoring context. You might find this useful in the
dashboard instances view to quickly see which monitoring contexts have not been terminated.

__a. Inthe model navigation view, right click on ClipsAndTacks MC, then select New - Stopwatch .
Enter these values:

1) Name :- Monitoring Context Timer
2)ID :- Monitoring_Context_Timer

3) For Stopwatch Controls, click Add, then select ClipsAndTacks MC - New Order Trigger
and then click OK.

4) Note that the default Resulting Action is Start

5) For Stopwatch Controls, click Add, then select ClipsAndTacks MC -> Ship Order to
Customer Trigger and then click OK.

6) Note that the default Resulting Action is Start, but you need to change it to Stop for this
trigger. So click on the second row in column Resulting Action. A drop down box is
shown, so pick Stop in the list.

7) For Stopwatch Controls, click Add, then select ClipsAndTacks MC -> Cancel Trigger and
then click OK.

8) Note that the default Resulting Action is Start, but you need to change it to Stop for this
trigger. So click on the second row in column Resulting Action. A drop down box is
shown, so pick Stop in the list.

___b. Press Ctrl-S to save your work.
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w Stopwatch Details

Edit the details of the stoowatch, which keeps track of elapsed time, IF an accumolating stopwatch is given
bwo or more stark and skop times, the durations are added together to produce an accumulated time.

10

Mame:

Descripkion:

| Monitoring_Conkext_Timer

Monitoring Conkext Timer

[ This stopwatch is an accumulating stopwatch

[ This stopwatch can be used for sorking

+ Stopwatch Controls
Specify what causes the stopwatch ko change and what action is kaken,

Trigger [ Inbound Event | Resulting Ackion
55=:'>New Crder Trigger Skark
?5=:'t>5hip Crder to Cuskomer Trigoer Skop
:*=:=> Cancel Trigger Skop

24, Create a business situation event when the number of declined orders is greater than or equal to 3.
First you will create an event definition for the outbound situation event. You will create a field
called BusinessSituationName which is a required field for the outbound situation event. You will
create a KPI that will track the total number of declined orders. Then you will create a trigger which
is fired when the number of declined orders is greater than or equal to 3. Then you will define an
outbound event which is fired by the trigger. In this outbound event, you will provide a value for the
field BusinessSituationName which is used later when configuring action manager in the server
administrative console. Create an new XSD event definition for declined orders

___a. Inthe Business Monitoring project explorer view, expand ClipsAndTacks , right-click on Event
Definitions and select New - Event Definition... (xsd) from the pop-up menu

___b. Inthe New XML Schema panel, select ClipsAndTacks as the parent folder and enter the ‘File
name:’ as DeclinedOrderEvent.xsd and click Finish

___C. Click ‘Yes’ in the question dialog if it appears

25. Review and update the <schema> element, which is the root element of the schema

___a. Inthe XSD editor, select the schema element and then select the ‘General’ tab of the
‘Properties ' view

Maonitaring Flow Problems | Servers | Console ¥ =0
|

[ General

Documentation

Extensions

"

|5] schema

Prefizx: tns

Target namespace: | http: )/ {ClipsAndTacks/DeclinedOrderEvent. xsd

2008 February, 25

IBM WebSphere Business Monitor 6.1 — Lab exercise Page 54 of 84

ClipsAndTacks (XSD event definitions)



© Copyright IBM Corporation 2008. All rights reserved

___b. Update the ‘Prefix: ' from tns to doe (where as doe stands for declined order event and the
prefix resembles the name of the schema)

___C. Click the Advanced button to edit the schema information (attributes)

4= Edit Schema Information

Target Namespace

| htkp: /i lipsandT acks)DeclinedQrderEvent, xsd

Mamespace Declarations

Prefisx | Marmespace Marme | |
xsd htbp: ) e w3, orgf200 1 MLS chemna
doe hitkp s ClipsandTacks/DeclinedOrderEvent. xsd I

Prefiz qualification of local elements:| | qualified

Prefix qualification of attributes: qualified

(4 | Cancel |

___d. Ensure that the prefix qualification of local elements and the attributes is set to ‘qualified ’

___e. Click OK. The ‘General’ properties view of the ‘ActivityEvent’ schema should look like the picture

below:

. . = O N

Maonitaring Flow Problems | Servers | Consaole B
|
[General 5| schema
Crocumentation Prafic: dos  E=—
Exktensions
Target namespace: | http: )/ {ClipsAndTacks/DeclinedOrderEvent. xsd

__f. Save the changes. File - Save or Ctrl + S

26. The ‘DeclinedOrderEvent.xsd’ schema opens in a ‘Simplified * XSD schema editor. Click on the pull-
down button (=) located on the top right corner of the XSD schema editor to select ‘Detailed ’ from
the drop down list

27. Add a complex element type named, DeclinedOrderEvent .

___a. Right click in the Types section of the XSD editor and select ‘Add Complex Type ' from the pop-
up menu
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Tvpes

Add Complex Type

add Simple Type

| Shaw properties

Refactar ¥

Feferences L

___b. Name the complex type as DeclinedOrderEvent and save the changes. You must see the new
complex type element added as shown below:

@ Tvpes

DeclinedOrderEvent

___¢. Now, right click the DeclinedOrderEvent , complex type from the Types section and select Add
Element from the pop-up menu. An new element named ‘NewElement’ of type ‘string’ is created

___d. Rename the element as ‘BusinessSituationName ' and accept ‘string ’ as the type

=
([}

DeclinedorderEvent

BusinessSituationMame skring

___e. Save the changes. File - Save or Ctrl + S.

___f. The following is the source of the DeclinedOrderEvent schema you created:

<?dml wersion="1.0" encoding="UTF-37"2> ;I
<wsd:achema targetNamespace="http:///ClipsindTacks/DeclinedorderEvent . xsd™
xmlns:xsd="http://vww. w3 .org/ 2001/ XHL3chema™
="http:,-‘.f',-‘Clipsﬁ.ndTacksf'DeclinedOIderEvent.xsd"
lementFormbefault="gqualified™ atcributeFormbefaultc="qualified"™
<Hasd:complexType hamwme="DeclinedOrderEwvent >
<Hsd:sequence
<xzsd:element namwe="EBusinessI3ituationiame™ type="xad:string":>«</xsd:element>
</ xad:sequence:
</ Hsd:comp lexTypes
</ x=d: schemasr
g Ll

Design |Source | e

28. Create a KPI for declined orders.

1) Click the KPI Model tab for the ClipsAndTacks model.
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2) In the navigation view of the KPI Model, right click on My KPI Context, then select New >
KPI

a) Name :- Declined Order KPI

b) ID :- Declined_Order_KPI
3) Enter these values:

a) Type :- Decimal

b) In KPI Target and Ranges, for Target click Detalils ..., then change the value to 3,
then click OK

c) In KPI Target and Ranges, for Ranges select Actual value
d) In the Range table,
(1) Click Add
(2) Change the Name to Low Range , and the ID to Low_Range
(3) Arow is created in the Range table with a range name Low Range.

(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change the value to 0, and then click
OK.

(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change the value to 3, and then click
OK.

e) Now you have created one range called Low Range. Repeat the above step to
create one more range:

(1) High Range with start value 3 and end value 10

f) KPI Value — select 'Base this KPI on a metric and an aggregation funct  ion

g) Under KPI Details, for Monitoring context, click Browse..., then select
'ClipsAndTacks MC ', then click OK

h) Metric — click Browse..., then select 'ClipsAndTacks Key ', then click OK

i) Aggregation function — select Count .

j) In the Data Filter section for this KPI, click Add

k) In the dialog, navigate to ClipsAndTacks MC -> Order Status , then click OK

[) In the row containing metric Order Status, make sure the operation defaults to
‘equals’. Also, click the cell in the column Values, then enter this text (with
guotation marks):

'Cancelled'

4) Press Ctrl-S to save your work.
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- KPI Definition
apecify how the value of the KPI is set,

KPI ¥alue
Zhoose how the EPT will get its walue:
{2 Base this kKPI on a metric and an aggregation function,

O Write an expression to calculate this KPT based on exisking KPIs

KPPl Details

Monitoring context: . ClipsAndTacks pC

Metric: 4 ClipspndTacks Key

Browse, ..

Aggreqation function: *l Count

Ise values from; & all model versions €2 Only this version of the model

Time Filter
Select a time period over which the KPI should be calculated,

Metric:
Time petiod;
& Mone O repeating @ Ralling 3 Fixed

Data Filter

=]

Browse, ..

Select the metrics that wou want o use to determing what walues to use in the calculation. For example, if vou have a KPI called
Average Price in London, wou only wank to use monikoring contexks where the value of the Ciky metric is London,

___b. Create a trigger to fire the outbound situation event.

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New >

Trigger
a) Name :- Declined Order Trigger
b) ID  :- Declined_Order_Trigger
2) Enter these values:
a) Under Trigger Sources, click Add.

b) Select Recurring wait time , then click OK

¢) In the Source column you see the default wait time is 1 minute .

d) In Trigger Condition, enter this text:
Declined_Order_KPI >= 3

3) Press Ctrl-S to save your work.
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+ Trigger Details
Edit the details of the trigger, which detects an occurrence and initiakes an ackion in response,

10 w Declined_Crder_Trigger

=R Dedined Order Trigoer

Description:

E

Trigger is repeatable

* Trigger Sources
Specify the source of this trigger,

Source Type | Source
Recurring wait kime 1) 0 days 0 hours 1 minukes

| add | | R emove |

+ Trigger Condition
Specify the condition that determines whether the trigger will fire,

¥ Declined_Order KPI == 3 N

___c. Create an outbound situation event for declined orders.

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New >
Outbound Event

a) Name :- Declined Order Outbound Event
b) ID .- Declined_Order_Outbound_Event

c) For trigger, click Browse..., then select My KPI Context - Declined Order
Trigger , then click OK

2) Click the ‘Add’ button for ‘Event Parts ' to create a new event part type in the ‘Event Type
Details’ section. The ‘Create New Event part Type’ panel opens

3) In the ‘Create New Event part Type’ panel, enter the following:
a) Name : My Event Part
b) ID : My_Event_Part

¢) Click the ‘Select Type ' button for the ‘Type’ field. The ‘Select Event Part Data Type’
panel opens

» Select the radio button for ‘Choose the data type from XML accessible
from this monitor project’

* Expand ClipsAndTacks -> DeclinedOrderEvent.xsd and select
‘doe:DeclinedOrderEventType '
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#4% Select Eyent Part Data Type

Select event part data type

Choose the %ML schema data bype that defines the struckure of this event park,

£~ Mo data bype specified For this event park

' Choose the data tvpe from the XML schemas accessible From Ehis monitor projeck

= IB ClipsandTacks

- [8] ActivityEvent.sd

El@ CeclinedOrderEvent. xsd
: doe: DeclinedOrderEvent
|ﬂ LatefwveragerdershippedEvent. xsd
|£I MewOrderEvent, xsd

" Choose from the list of predefined XML schema simple data kypes

Twpe: I ;I

" Choose the bype From the predefined daka bypes in the ZML catalog

Twpe: | Browse, .. |
= Back hext = | | Einish I ancel |

e Click Finish

d) Path : cbhe:CommonBaseEvent/doe:DeclinedOrderEventType

4= Create New Event Part Type E
Create an event part type
="
Specify the details of the event part, Together, all the event parks describe l::ﬁ
the structure of the event at run time.

Marne: I My Event Park

10 | Mw_Event_Part

Type: | doe:DeclineCrderEventType Select Tvpe. .. |

Path: |cbe:CnmmnnEﬂaseEvent,l’dDe:DeclineOrderEventType

(7] = Back Mk =

Cancel |

e) Click Finish
4) In the Event Attributes Details table, expand Declined Order Trigger > My Event Part, then
on the same row as BusinessSituationName , set Expression to (include the quotation
marks):

‘Too many orders have been declined'

5) Press Ctrl-S to save your work.
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+ Outbound Event Details
Edit the details of the outbound event, which is sent by the monitaring conkext, The bype must be an event definikion,

10 « Declined_Order_Outhound_Event

Mame:; Declined Order Qutbound Event

Descripkion; d

+ Event Type Details

Specify the event type or the XML schemas that kogether describe the structure of this outbound event, You can specify an extension
name, event parts, ar both,

Extension narme: | Browse, .. | | Zleat |

Event parts: ID | Mame | Tyvpe | Path
My Ewent_Part My Event Part  doe:DecineCrderEventType  che:CommonBaseEvent/doe: DeclineCrderEven. . .

| add | | Remove |

= Event Attributes Details
Specify the triggers that cause the event to be sent, Use the Expression column to specify the walue For each event attribute when the
event is sent.
Marne | Twpe | Expression |
= :*=:f> Declined Order Trigoer
'-:_=. Property Data
té Extended Data
= FQ My Event Part doe:DeclineCrderEvent Type

Licnl

____29. Create a business situation event when the order fulfillment duration is greater than 3 days. First
you will create an event definition for the outbound situation event. You will create a field called
BusinessSituationName which is a required field for the outbound situation event, and you will
create another field for the average order processing time which will eventually be placed into the
alert body. You do not need to create a KPI since there is already a KPI containing the average
processing time. You will create a trigger which is fired when the average processing time is greater
than 3 days. Then you will define an outbound event which is fired by the trigger. In this outbound
event, you will provide a value for the field BusinessSituationName which is used later when
configuring action manager in the server administrative console, and you will populate the field on

the event containing the average order processing time. Create an event definition for average order
processing time

___a. Inthe Business Monitoring project explorer view, expand ClipsAndTacks , right-click on Event
Definitions and select New - Event Definition... (xsd) from the pop-up menu

___b. Inthe New XML Schema panel, select ClipsAndTacks as the parent folder and enter the ‘File
name:’ as LateAverageOrderShippedEvent.xsd and click Finish

___C. Click ‘Yes’ in the question dialog if it appears

30. Review and update the <schema> element, which is the root element of the schema
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___a.Inthe XSD editor, select the schema element and then select the ‘General’ tab of the
‘Properties ' view

- —
Manikoting Flawe | =] Properties 23 Problems | Servers | Console

-,

= = E
[General S| schema
Documentation Prefix: s =
Extensions

Target namespace: | http: ) (ClipsandTacks(LatedverageOrderShippedEvent, xsd

___b. Update the ‘Prefix: ' from tns to laose (where as laose stands for late average order shipped
event and the prefix resembles the name of the schema)

___c. Click the Advanced button to edit the schema information (attributes)

#= Edit Schema Information
Target Mamespace

| htkp: ffClipsandTacks/LatedyverageCrdershippedEvent, xsd

Mamespace Declarations

Prefix I Mamespace Mame | |

htkp: /e w3, orgf2001 f=MLSchema
tkp: ff (ClipsandT acks)LakedverageOrderShippedEvent, xsd

Add...

Edit...

Delete

Prefix qualification of local elements I qualified

Prefix qualification of attributes: I qualified

Ju HE

Ik I Cancel

___d. Ensure that the prefix qualification of local elements and the attributes is set to ‘qualified ’

___e. Click OK. The ‘General’ properties view of the ‘ActivityEvent’ schema should look like the picture

below:
e — = = N
Manikoting Flawe | =] Properties 23 Problems | Servers | Console i
[General S| schema
Dacurentation Prefix: lanss =
Extensions
Target namespace: | http: ) (ClipsandTacks(LatedverageOrderShippedEvent, xsd

__f. Save the changes. File - Save or Ctrl + S
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31. The ‘DeclinedOrderEvent.xsd’ schema opens in a ‘Simplified * XSD schema editor. Click on the pull-
down button (=) located on the top right corner of the XSD schema editor to select ‘Detailed ’ from
the drop down list

32. Add a complex element type named, LateAverageOrderShippedEvent

___a. Right click in the Types section of the XSD editor and select ‘Add Complex Type ' from the pop-
up menu

Types

Add Complex Type

add simple Type

| Show properties

Refacktor »

References L

___b. Name the complex type as LateAverageOrderShippedEvent and save the changes. You
should see the new complex type element added as shown below:

Types
LateAverageCrderShippedEvent

___c¢. Now, right click the LateAverageOrderShippedEvent , complex type from the Types section
and select Add Element from the pop-up menu. An new element named ‘NewElement’ of type
‘string’ is created

___d. Rename the element as ‘BusinessSituationName ' and accept ‘string ' as the type

=
B

LatedverageOrdershippedEvent

BusinessSituationManme skring

___e. Right click the LateAverageOrderShippedEvent , complex type again from and select Add
Element from the pop-up menu. An new element named ‘NewElement’ of type ‘string’ is created

___f. Rename the element as ‘AverageOrderProcessingTime ’'and accept ‘string ' as the type

=
[E[F
LatedveragedrdershippedEvent
BusinessSituationMarne skring
AverageOrderProcessingTime skring
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__ 0. Save the changes. File - Save or Ctrl + S.

__h. The following is the source of the DeclinedOrderEvent schema you created:

<?rml wersion="1.0" encoding="UTF-5'"7> ;I_
<wad:schema targetMNawespace="http:///ClipsindTacks/Lateiveragedrder3hippedEvent . xad™
xmlns:xad="http://vww. w3 .org/Z2001/ ZML3chema"™
"ht.t.p:fffClipSAndTacks,"LateAverageOrderShippedEvent.xsd"
[elementFormbefault="gqualified" attributeFormbefault="gualified":]
<xsdicomplexType name="lLatelverageldrder3hippedEvent ™
<xsd: sequence
<xsd:elerment name="BusinessIituationMamwe" type="xsd:string™:>
<fxadielement>
<uad:element hnawe="AverageOrderProcezssingTime™ type="wad:string"r</x=d:elemants
</ ®ad:sequences
</ xsd:complexTypes>
</ wsd: schemar

Design | Source | me—nr -
__33. Create atrigger to fire the outbound situation event.
__a. Inthe navigation view of the KPI Model, right click on My KPI Context, then select New >
Trigger
1) Name :- Order Fulfillment Timer Trigger
2)ID  :- Order_Fulfillment_Timer_Trigger
___b. Enter these values:
a) Under Trigger Sources, click Add.
b) Select Recurring wait time , then click OK
¢) In the Source column you see the default wait time is 1 minute .
d) In Trigger Condition, enter this text:
Average_Order_Fulfillment_KPI_August_2006 ge xs:dayTimeDuration
(P3DT1H)
___c. Press Ctrl-S to save your work.
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+ Trigger Details
Edit the details of the trigger, which detects an occurrence and initiates an action in response.

10 4 order_FulFillment_Timer_Trigger

Mame; Crder Fulfillment Timer Trigger

Descripkion: ~ |

Trigger is repeatable
- Trigger Sources
Specify the source of this trigger.

Source Tvpe I Source
Recurring waik time i1 0 days 0 hours 1 minutes

| Add | | Remove |

+ Trigger Condition
Specify the condition that determines whether the trigger will fire,

¥ average_Order Fulfilment_KPI_August 2006 ge dayTimeDuration (P30T IHY| N
=

___d. Create an outbound situation event for average order processing time.

1) In the navigation view of the KPI Model, right click on My KPI Context, then select New >
Outbound Event

a) Name :- Order Fulfillment Outbound Event
b) ID :- Order_Fulfillment_Outbound_Event

c) For trigger, click Browse..., then select My KPI Context - Order Fulfillment
Timer Trigger , then click OK

2) Click the ‘Add’ button for ‘Event Parts ' to create a new event part type in the ‘Event Type
Detalls’ section. The ‘Create New Event part Type’ panel opens

3) In the ‘Create New Event part Type’ panel, enter the following:
a) Name : My Event Part
b) ID : My_Event_Part

c) Click the ‘Select Type ' button for the ‘Type’ field. The ‘Select Event Part Data Type’
panel opens

» Select the radio button for ‘Choose the data type from XML accessible
from this monitor project’

» Expand ClipsAndTacks -» LateAverageOrderShippedEvent.xsd and
select ‘laose: LateAverageOrderShippedEventType '’
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4= Select Event Part Data Type
Select event part data type
Choose the ¥ML schema data tvpe that defines the struckure of this event part,

{” Mo data bype specified for this event park

% Choose the data kvpe From the XML schemas accessible Fram this monitor project

= @ ClipsandTacks

- [8] ActivityEvent. xsd

|5| DeclinedCrderEvent, xsd

El |5 LateAveragetrdershippedEvent. xsd
- lanse;Latedveragerder ShippedEvent
- [8] MeworderEvent,xsd

i~ Choose from the list of predefined XML schema simple data kvpes

Tvpe: I ll

" Choose the type From the predefined data bypes in the ML catalog

Tvpe: | Erawse., . |
= Back Mext = | Einish I Cancel |

e Click Finish

d) Path : cbhe:CommonBaseEvent/laose:LateAverageOrderShippedEv ~ entType

4= Create New Event Part Type E
Create an event part type

=
Specify the details of the event park, Together, all the event parts describe the struckure of the event at run I:':F;"—f:
kirne,

Mame: | My Event Part

IC: I My _Ewenk_Part

Type: | laose:LatedyverageOrderShippedEvent Type Select Type... |

Path: |u:I:ue:CDmmDnBaseEvent,l'Ianse:Late.ﬁ.verageDrderShippedEventType

(7 = Back [exk =

E Cancel |

e) Click Finish
4) In the Event Attributes Details table, expand Order Fulfillment Timer Trigger > My Event
Part and then on the same row as BusinessSituationName , set Expression to (include
the quotation marks):

‘Average shipment is too late’
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5) In the Event Attributes Details table, expand Order Fulfillment Timer Trigger > My Event
Part, then on the same row as AverageOrderProcessingTime , set Expression to (include
the quotation marks):

xs:string(xs:decimal(Average_Order_Fulfilment_KPI_August_2006) div 86400)

Note: Here the decimal function converts the duration to seconds, so then it can be divided by 86400
which will give you the number of days.

6) Press Ctrl-S to save your work

* Outbound Event Details

Edit the details of the outbound event, which is sent by the monitoring conkext, The type must be an event definition,

(oY « Order_Fulfilment_outbound_Event

Mame: Order Fulfillment Outbound Event

Description:

+ Event Type Details

Specify the event bype or the ¥ML schemas that bogether describe the struckure of this outbound event, You can specify an extension
name, event parks, aor baoth,

Extension name: | Browse, . | | Zleat |

Event parts:

| Add | | Remove |

+ Event Attributes Details
Specify the triggers thak cause the event ko be sent, Use the Expression column to specify the walue For each event attribute when the
event is sent.,

Marme | Tvpe | Expression
=l :':1> Order Fulfillment Timer Trigger

= Property Data
t@, Exkended Data
=l Fﬁ My Event Park laose;LatefverageOrderShippedEy...
[8] BusinesssituationMame #siskring ﬁ\"'.ﬁ.verage shipment is oo lake'

a AverageCrderProcessingTime

rdecimal{ Average_Order_FulFillm

| Add | | Remoyve |

34. Check for any errors in the Problems view. You should resolve any errors before continuing.
Warnings and informational messages may be present but these are not a problem.
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Part 2: Publish the model to the server

In this section you will use Rational Application Developer or WebSphere Integration Developer to publish the
monitor model to the monitor server.

1. In Project Explorer, expand ClipsAndTacks -> Monitor models - ClipsAndTacks.mm . Right

click over ClipsAndTacks.mm and then select Generate Monitor J2EE Projects from the pop-up
menu

4= Generate Monitor J2EE Projects

Target project names For the generated code

— JZEE Projects
Model Logic Project Mame I ClipsandTacksModellogic
Maoderatar Project Mame I ClipsandTacksModerator

J2EE Application Praject Marme I ClipsandTacksApplication

[ ovenarite exisking projecks

Zancel |

2. A progress dialog shows the status of the operation and it closes when the operation is complete.
Check for errors in the Problems view. There may be warnings, but there should not be any errors.

3. If you are using the Monitor Toolkit, ensure that the correct Monitor server profile is setup in the
Servers view.

___a. Click the Servers tab.
___b. Double click the listed server to open the server editor.
___c. If you are using Rational Application Developer, ensure WBMonSrv is selected for the

WebSphere profile name. If you are using WebSphere Integration Developer, ensure
WBMonSrv_wps is selected for the WebSphere profile name.

* General
Specify the host name and ather commaon sektings,

Server name: | WebSphere Business Maonitor Server wa, 1 on WebSphere Process Server

Hosk name: localhost
Funkime: WebSphere Process Server vwi, 1 j Edit
¥ Server

Enter setkings For the server,

WebSphere profile name: I'-.-'-.-'E!Mu:unSrv_wps j

IJpdate server status interval (in miliseconds): | 5000
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___d. Press Ctrl-S to save your work.

4. Click the Servers tab, then right click and select the Start option to start the server. This may take a
few minutes to complete

5. Right click in the servers view, then select Add and Remove Projects....

6. Click Add to move the ClipsAndTacksApplication from the list of available projects to the list of
configured projects.

= Add and Remove Projects | x|
Add and Remove Projects ‘ ‘

Modify the projects that are configured on the server

Move projects ta the right to configure them on the server

fvailable projects: Configured projecks:
A ClipsandTacksapplication
add > |
= Bemove |
eddelss |
<< Remove ol |

(7) = Back | ek = | Finish I Cancel

7. Click Finish .

8. A progress message is displayed in the lower right corner of the window

9. Check the messages in the console view. You should see the following message when the
application has been started:

Application started: ClipsAndTacksApplication

10. In the servers view, right click, then select Run administrative console . Enter the user name as
admin and password as admin when prompted. You should see it open in a separate tab:
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" : "0, -
Integrated Solutions Console Welcome admin Help | Logout - |i |:::

| View: IAII tasks walcome

Welcarme

Guided Activities

Integrated Solutions Console, 6,1,0,13

Serers Integrated Solutions Console Build Mumber: cFl30745.06
provides a comrmon administration Build Date: 1:i.f'13,|‘tl? '
applications consale for rultiple products, The 0 27 7 7777 T
table lists the product suites that can
Resources be adrministered through this II_é'.thENSED MATERIALS PROPERTY OF
natlistion, Sala a product et 720163, 57247180, 565501 (0
* ' Copyright International Business E

Environment

Inteqration Applications SR DT Eersion
WwebSphere Application 5.1.0.13

Swstem administration Seryer

Users and Groups WwebSphere Process &.1.0.0
Server

B Menitoring and Tuning websphere Business &.1,0.0
Monitor

Troubleshooting
Service inteqration

uooI

11. Click Applications > Monitor Models . The application should show green status if it started
successfully.

‘ view: [All tazhs = Monitar Models

AR Monitor Models VE
Guided Activities pMonitor Models
Servers Usze this page to manage all versions of monitor models and their associated applications, To start or stop 2
R version of a monitar riodel, you most start or stop the assaociated application, All riodels are initially added to the
E applications root resource group and rmay not be visible by its intended dashboard users, Use the Monitor data security panel to

assign permizzion to the models.

Enterprize Applications
Install Mew Application Preferences
SCA modules

= Start| Stop| Install Update

Drata Movement Service
Rl
Monitor Action Services
Select| Model & Viersiem Deployment > | Application Status ()
Resources —
ClipsAndTacks 2007-12- o] 4 ClipsAndTacksapplication ]
Security [ r 02T15:14:19
[ Enwironment O GlobalHTMM Z007-06- (8128 IBEM WBM HUMAN TASK MONITOR MODEL | S
12T09:54:32
Integration Applications
Tatal 2

Svstem administration

12. If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the
right of Status in the last column of the table. You should see green (started) for the model. If it
does not show green, be patient and keep refreshing until it does show green.

13. Check the server log to ensure there are no problems. You can check this in the console view.
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Part 3: Configure action manager for business situa  tion events

This section shows you how to configure action manager to create alerts based on business situation events
defined in the monitor model. The alerts will be visible in the Alert view on your dashboard.

You do not need an LDAP server to test the situation events.
1. Add atemplate for declined order alerts.

__a. Inthe administrative console, navigate to Applications > Monitor Action Services > Template
Definitions > Notifications

___b. Click New.

___c. Enter AlertDeclined as Template name and a description.
___d. Select Dashboard Alert.

___e. Select User id.

__f. For the To field, enter admin. This ‘User id’ is the one that will receive the alert, so you should
log into the dashboard with this ‘User id’.

Note: The user admin is the default username configured for Monitor Test Environment profile
___g. Enter a subject.

___h. Enter the body.
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General Properties

* Termplate name
|A|er‘tDec|ined

Crescription

Decined Orders

Default action service type
% Lazhboard Alert

T ceall phone
 Ernail
r Pager

"To' query type
" Federated repositaries query

C LEAP query
" Ermail address
® Uzerid

Ta
|admin

-—

Query baze

Subject
|Dec|ined Orders

Baody

1 [

Too many orders have been
declined.

2. Add a template for order processing time alerts.

___a. In the administrative console, navigate to Applications

Template Definitions

___b. Click New.

- Notifications

___c. Enter AlertLate as Template name and a description.

___d. Select Dashboard Alert

___e. Select Userid

L]
L]

- Monitor Action Services

>

__f. For the To field, enter admin. This ‘User id’ is the one that will receive the alert, so you should
log into the dashboard with this ‘User id’.

Note: The user admin is the default username configured for Monitor Test Environment profile

___g. Enter a subject.
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___h. Enter the body, and you may optionally enter a substitution variable as shown below. For the
actual alert that is sent, the average order processing time from the event payload will be
substituted for %AverageOrderProcessingTime% in the body. For example:

The average order processing time is %AverageOrderProcessingTime% days.

General Properbes

* Template name
Alertlate

Creszcription

order Processing time

[ [

Default action service type
¥ Dazhboard alert

i ceall phone
 Ermail
i Pager

"To" query type
" Federated repositories query

L LOAP query
” Ernail address
& User id

To
|adrnin -

Query base

Subject
|Order processing time
Baody

The average order processing I:'
tirne is %
AverageCrderProcessingTime %
days,

[]

__i. Click OK.
3. Add the binding from the situation event to the action type for declined orders.

__a. Inthe administrative console, navigate to Applications -> Monitor Action Services ->
Installed Situation Event Bindings

___b. Click New.

___c. Enter the situation event name that you defined in the model. In this lab, you created a business
situation name as follows:

Too many orders have been declined
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Mew Situation Event Binding

General Properties

# Situation event name

Too many orders have been

Description

Ceclined orders |:|

]
Appll,'l ﬂ Reset| Cancel |

___d. This should match exactly the value in the BusinessSituationName field in the outbound event.

You may want to copy/paste from the model. Here is a screen capture from the model showing
the Declined Order Outbound Event:

* Outhound Event Details

Edit: the details of the outbound event, which is sent by the monitoring contesxt, The bvpe must be an event definition,

(o} « Declined_Order_Outbound_Event
Mame: Declined Order Qutbound Event
Descripkion:

Specify the event bvpe or the “ML schemas that together describe the structure of this inbound event,

Extension name:  DeclinedOrderEvent

Ewent parks: D | rame | Type | Path

w Event Attributes Details

Specify the triggers that cause the event to be sent, Use the Expression column ko specify the value For each event attrit

Marne | Tvpe | Expression
E=l :':4> Declined Order Trigger
Property Data
=] Extended Data
BusinessSituationMarne A skring xﬁ ‘Too many orders have been declined'

___e. Enter a description, then click Apply .

__f. Click Add.
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___g. Enter a binding name, then select the template AlertDeclined

Add termplate to situation event binding

General Properties

#* Binding narme

Cecined

Ce=scription

[ [

Categaory

Ternplate name
Iﬂler‘tDeclined ;I

Reset | Cancel

Apply |

__h. Click OK.

___i. Notice that you now have one action defined for this situation event. If you had other action
templates defined then you could add more actions to this event. So then you could send a
notification for this situation to multiple destinations including e-mail, alerts and Web services.

General Properties

* Situation event narme

|Tnn riany orders have been

Cescription

Declined orders I:'
=
Apply | ﬂ Reset| Cancel |

Preferences

Add| Rerove |

ElwlE

Select| Binding Mame

s
e

s
e

s
et

s

Termplate Mame o

Categary Mame Ackion Service Type

|— Decdined AlertDeclined AlertHandler

Total 1

__J- Click OK.
4. Add the binding from the situation event to the action type for order processing time.

___a. In the administrative console, navigate to Applications > Monitor Action Services > Installed
Situation Event Bindings

___b. Click New.
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___c. Enter the situation event name that you defined in the model. In this lab, you created a business

situation name as follows:

Average shipment is too late

___d.. This should match exactly the value in the BusinessSituationName field in the outbound event.
You may want to copy/paste from the model

___e. Enter a description, then click Apply .

__f. Click Add..

___g. Enter a binding name, then select the template AlertLate , then click OK.

__h. Click OK.

In the administrative console, navigate to Applications -> Monitor Action Services
Situation Event Bindings.  You should see two bindings as follows:

Installed Situation Event Bindings

Installed Situation Event Bindings

Situation event bindings that are already installed.

Preferences

Mew Delete
®@E

Select| Situation Event Mame X

I- fverage shipment is too late
I- Too many orders have been declined
Total 2

Situation Event Description

Too late

Cecined orders

IBM WebSphere Business Monitor 6.1 — Lab exercise
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Part 4: Run events to exercise the model

Rather than installing a J2EE application to actually create the events that you want to monitor, you are going
to use a program to simulate the submission of events from the application. The supplied program is
‘BatchCBEWTiter61’ and it will submit the events to the Common Event Infrastructure. Look for the program in
\Labfiles61\ClipsAndTacks\BatchCBEWr iter. This program reads XML files which represent the Common
Base Events for the model.

1. Update BatchCBEWTiter61.bat to point WAS_HOME to the monitor server home, for example ‘set
WAS_HOME=C:\IBM\WebSphere\MonServer ’. If you are using the integrated monitor server in
WebSphere Integration Developer, the path would be <WID_HOME>\runtimes\bi_v61 . If you are
using the integrated monitor server in Rational Application Developer, the path would be
<RAD_HOME>\runtimes\base_v61 .

2. Update config.properties , setting the serverName and portNumber . You can find the port
number by browsing the server log and finding ‘bootstrap port ’. For example, check for the log at
C:\IBM\WebSphere\MonServer\profiles\WBMon01\logs\server1\SystemOut.log. For the integrated
server in WebSphere Integration Developer, the path would be
<WID_HOME>\pAAWBMonSrv_wps\logs\server1\SystemOut.log and the portNumber should be
2810. For the integrated server in Rational Application Developer, the path would be
<RAD_HOME>\runtimes\base_v61\profiles\WBMonSrv\logs\server1\SystemOut.log and the
portNumber should be 2810. Here is an example of the config.properties settings:

__a.connect.serverNane = | ocal host
___b.connect. port Nunber = 2810

3. Open a command window, then change directory to the folder containing BatchCBEWTriter61, for
example, type this command

___a. cd\Labfiles61\ClipsAndTacksXSD\BatchCBEW iter
4. Run commands to load the common base events to the server.
___a. batchcbewriter61 -Dsource.filename="C:/Labfiles61/ClipsAndTacksXSD/che/allXSDevents.xml"

5. When you run BatchCBEWriter61, you should see results such as:

" WINDOWS system3 2, cmd.exe

C:xLabfiles6l~ClipsAndTacks¥SDsBatchCBEWriter*hatchchewriterbl —Dsource.filename
="C:rLabfilesbl ClipsAndTacksiED chealliSDevents .xml"
Getting CBEs.
Getting Emitter.
Removing Globallnstancelds.
Setting missing values.
Changing Instance Ids.
Updating timestamps.
VJalidating CBEs.
Sending CBEs.
START=16:31:43.812
i chel181.
chel28].
chel381.
che[481.
chel[5A].
g chela@]l.
END=16:31:58_283
TotalTime=14391 millizeconds.

C:xLabfiles6lsClipsAndTacks¥SDuBatchCBEWriter >
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Part 5: Create a dashboard
In this section you will build a dashboard. You will add views to the dashboard and configure them.
1. Open the dashboard.

___a. In Rational Application Developer or WebSphere Integration Developer, in the servers view, right
click and select WebSphere Business Monitor Dashboard

___b. The dashboard should open as follows:

WebSphere ~BUSINEss Monitor

User ID

Password !

___c. Enter admin as the username and admin as password and then click Login . You should use
‘admin ’ so that you can view the alerts which were setup in action manager to be sent to this
particular ‘User id'.
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WehSphere “BUSINESS Monitor

Welcome admin  wE— Help Logout

Getting Started | Dashboards Utilities
Home KPIs 4+ KPI Manager | Instances Human Tasks Export Values Reports Dirnensions Alerts + Subse

————

can use to measure business performance, monitor in-
report on business operations. It provides information to identify bus
exceptions, and change processes to achieve a more efficient and {:ﬂﬂmeﬂiﬁr & blls

g

View your business data using the WebSphere Business Monitor dashboards.
Your business dafa can be dispayed in multiple formats depending on how
you lay out your dashboard.

analyze and work with KPIs Analyze reports _
Analyze the target and status of key % Analyze business performance data, and
petformance indicators (KPIs) by adding Il drill down to zee details about its

FPIs to your dazhboard, Define, copy, and perfarmance,

update KPIs using KPI Manager,

Analyze instances &ralyze dimensional reports
Analyze the available ronitoring context 4 Analyze multidimensional business

‘in either individual instances or llIIII performance data, and drill down to see
user-defined groups of context instances. details about its performance.

analyze and manage human tasks Analyze and subscribe: to alerts
Analyze and perform actions on hurman i Subscribe or unsubscrlbe tD predeflned

___d. Click the Dashboards tab.

WebSphere ~BUsiness Monitor

Welcorme adrin Help Logout

Getting Started | Dashboards | Utilities

Manage

Mew I Copy I F.enamea I Share I Delete I Import I Export I

Select Dashboard + Dwner Access w

IE E Page 0O of O IE‘ IE‘ Go to page: I Reszults 0 to O of O

__e. Click New, then enter a name for the dashboard for example MyDashbaord , then click OK.
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WebSphere "BUSiness Monitor

Welcorme admin Layout assistance Cashboard Layout Help Logout

Getting Started | Dashboards | Utilities
Manage MyDashbaord x

__f. Click Add to Dashboard , then select Instances , then click OK. Note that you can also add a
view by dragging the view from the palette on the right and dropping it onto the dashboard.

Instances

To select which instances to display, click Personalize.

Personalize |

__g. Click Personalize

Instances
Show/Hide Filter Sort Format Advanced Cooperative

Selactthe columns to display,
Available: * Selected:
city ;E

ClipsAndTacks Key
COMPLETED
country
Maonitaring Contest Timer
Crder End Time =
Order Fulfillment Duration
Order Start Time
Order Status

-

Ship Counter
totalPrice LE
* Mumber of rows to display:

e

* Refrezh rate [in seconds)

IF

___h. Click >> to copy all the metrics from the available list to the selected list. Then click Save. You
should see a list of monitoring context instances for the events that you just processed.

2008 February, 25 IBM WebSphere Business Monitor 6.1 — Lab exercise Page 80 of 84

ClipsAndTacks (XSD event definitions)
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Model: ClipsAndTacks

Version: All Wersions

+| Search far

Monitoring Context: ClipsAndTacks MC
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Reset I

city

Toronto

Toronto

Toronto

Mexico City

Raleigh

Taoronto

|E| |1—| |£| |L—I| Go to page: I |£| Results 11 to 16 of 16

Clips AndTacks
Key

o0ld

ol

oz20

COMPLETED country

Canada

Canada

Canada

Mexico

(NE=T0S

Canada

Order End Time

August 26,
2006 3:14:55
AM

August 28,
2006 3:14:55
AM

Order
Fullfillment
Duration

2d,0h,0m, 0
=

0=

4d, 0k 0m, 0
H

0=

Order Start
Time

August 23,
2006 3:14:55
Al

August 23,
2006 6:12:22
Al

August 24,
2006 3:14:55
A

August 24,
2006 4:01:22
A

August 24,
2006 5:01:34
A

August 24,
2006 6112122
A

Order Status

Shipped

Cancelled

totalPrice

5350

200

S00

950

1.000

1,050

Personalize I

___i. There are two pages of results, so if you browse through these instances, you see that there are
4 cancelled orders. Since you setup an alert if declined orders is greater than or equal to 3, then
an alert should be displayed in the alert view.

__j. Click Add to Dashboard

Alerts

Ma

, then select Alerts , then click OK. The alerts view is added to your

dashboard, and you should see alerts listed since the model processed 3 or more cancelled
orders, and the average order processing time is greater than 3 days.

rk Read Mark Unread I

Farward Alert I Remaove I

A
e
[ ]

‘|‘|‘|‘|‘|‘|‘|‘|‘|‘|‘l

Subject pos
Order processing tirme
Declined Crders
Order processing time
Declined Crders
Order processing tirme
Declined Crders
Order processing time
Declined Crders
Order processing tirme

Decined Orders

December 7,
Decermber 7,
Decermber 7,
Decermber 7,
December 7,
Decermber 7,
Decermber 7,
Decermber 7,
December 7,

Decermnber 7,

|1—| |1—| Page 1 of 2 |_—| |_—| Go to page: I |_—| Results 1 to 10 of 15

2007

2007

2007

2007

2007

2007

2007

2007

2007

2007

s
413903
4:39:03
4:38:03
4:38:03
diEATI0Z
413702
413602
413602
13302

4:35:02

P

P

P

FM

P

P

P

FM

PM

P

___k. You can click on an alert in the list and then you will get a pop-up showing the details of the alert.

2008 February, 25

IBM WebSphere Business Monitor 6.1 — Lab exercise

ClipsAndTacks (XSD event definitions)

Page 81 of 84



© Copyright IBM Corporation 2008. All rights reserved

7

" saturday, September 15, 2007 7:41:09 AM
Subject
| late

Business situation name

Auerage shipment is too late

Comments

The average order proceszing tirne is 3,750 days,

Clase |
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What you did in this exercise

In the lab, you created a monitor model using Rational Application Developer or WebSphere Integration
Developer.

Then you published the model to the monitor server.
You also configured action manager to create alerts based on business situation events.
You used the supplied program to simulate the submission of events from the monitored application.

You configured dashboards and viewed monitored data in several different types of views.
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Appendix 1 — Import the solution into the monitor m odel editor

A solution has been provided so that you do not have to build the model from scratch. This section shows you
how to import the monitor model into Rational Application Developer or WebSphere Integration Developer.
After importing the model then you can proceed to the section to publish the model to the server.

1. Start Rational Application Developer or WebSphere Integration Developer and setup the
environment.

a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted
point to a new workspace such as C:\workspaces\ClipsAndTacksXSD

b. Close the Welcome tab

c. By default, you are in the Business Integration perspective. You want to open the Business
Monitoring perspective. Select Window -» Open Perspective -> Other - Show all >
Business Monitoring

___d. Ifit asks you to Confirm Enablement, then click OK.
2. Create a new monitoring project.
___a. Right click the Project Explorer and then select New - Business Monitoring Project...
___b. For Project name, enter ClipsAndTacks
___c. Click Finish. You will see the new project in the Project Explorer view.
3. Import the supplied mm and cbe files.
___a. Right click in the Project Explorer view, and then select Import...
__b. Select General - File system , click Next.
___c. Browse to the location containing the files, for example, C:\Labfiles61\ClipsAndTacksXSD
___d. Select ActivityEvent.xsd
___e. Select ClipsAndTacks.mm
___f. Select DeclinedOrderEvent.che
___g. Select LateAverageOrderShippedEvent.cbe
___h. Select NewOrderEvent.xsd
___i. Click Finish .
4. Expand the project in the Project Explorer view, then expand the Event Definitions and you will see
the new events listed. Expand Monitor Models and you will see the new ClipsAndTacks model

listed.

5.  Now you may proceed to the section to publish the model to the server.
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