
        

               

    

        

     

    

     

  

       

 

         

        

            

           

         

        

        

     

      

 

     

                     
                  

                 
    

  

             

          

               
  

       

           

© Copyright IBM Corporation 2009 All rights reserved 

IBM WEBSPHERE BUSINESS MONITOR 6.2 – LAB EXERCISE 

WebSphere Business Monitor V6.2
 

User defined functions lab
 

What this exercise is about ................................................................................................................................... 1
 

Lab requirements .................................................................................................................................................. 1
 

What you should be able to do ............................................................................................................................. 1
 

Introduction ........................................................................................................................................................... 2
 

Part 1: Import the Clips And Tacks monitor model ............................................................................................... 3
 

Part 2: Import the user defined function project .................................................................................................... 5
 

Part 3: Review the user defined functions and create the jar file ......................................................................... 6
 

Part 4: Import the user defined functions into the monitor model ......................................................................... 8
 

Part 5: Add expressions that reference user defined functions .......................................................................... 11
 

Part 6: Publish the model to the server............................................................................................................... 13
 

Part 7: Run events to exercise the model ........................................................................................................... 15
 

Part 8: Create a dashboard................................................................................................................................. 17
 

What you did in this exercise .............................................................................................................................. 19
 

What this exercise is about 

The objective of this lab is to show you how to use user defined functions in the monitor model. You will 
review the Java project that contains the user defined functions. You will edit the monitor model and add 
expressions which reference the user defined functions. You will also use the instances view to see the 
results in the dashboard. 

Lab requirements 

List of system and software required for the student to complete the lab. 

•	 Rational Application Developer 7.5 or WebSphere Integration Developer V6.2. 

•	 WebSphere Business Monitor V6.2 – Toolkit installation including the monitor model editor and 
Monitor server 

What you should be able to do 

At the end of this lab you should be able to: 
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•	 Use Rational Application Developer or WebSphere Integration Developer to edit the monitor model to 
add references to user defined functions. 

•	 Define a dashboard to view monitoring context instances. 

Introduction 

In this lab you will build on the Clips And Tacks model which is described in another lab document titled 
'WebSphere Business Monitor V6.2 Clips And Tacks business activity monitoring lab'. You will import the 
full Clips And Tacks model, then update the monitor model, deploy the changed model and submit events 
to the monitor model. 

The user defined functions have been created for you so you can just import them into the workspace. 

In the monitor model, you will define a new metric to track the cost of the ordering process. You will use an 
existing metric 'Order Fulfillment Duration' which is the duration of the order process. You will use a user 
defined function to calculate the cost of the process using the order fulfillment duration as an input 
parameter. The cost function could retrieve the average unit cost from a database or another system, but 
for simplicity in this lab, the Java function is implemented using a random number generator. 

Useful URLs 

The following URLs may be helpful to you as you exercise this lab. Note that the port numbers in the URL 
of your installation may be different depending on your configuration. 

•	 Server administrative console 

https://localhost:9044/ibm/console 

•	 Business space dashboard 

https://localhost:9444/BusinessSpace 
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Part 1: Import the Clips And Tacks monitor model 

In this section, you will import the Clips And Tacks monitor model into the workspace. If you already have 
the ClipsAndTacks model in your workspace after completing the Clips And Tacks lab, then you may skip 
this section. 

____ 1.	 Start Rational Application Developer or WebSphere Integration Developer and setup the 
environment. 

__ a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted 
point to a new workspace such as c:\workspaces\ClipsAndTacks 

__ b. Close the Welcome tab. 

__ c. Open the Business Monitoring perspective. Select Window > Open Perspective > Business 
Monitoring. 

__ d. If it asks you to Confirm Enablement, then click OK. 

____ 2. Create a new monitoring project. 

__ a. Right click the Project Explorer, then select New > Business Monitoring Project… 

__ b. For Project name, enter ClipsAndTacks 

__ c. Click Finish. You will see the new project in the Project Explorer view. 

____ 3. Import the supplied mm and cbe files. 

__ a. Right click ClipsAndTacks in the Project Explorer view, and then select Import… 

__ b. Select General > File system, click Next. 

__ c. Browse to the location containing the files, for example, c:\Labfiles62\ClipsAndTacks 

__ d. Select ActivityEvent.cbe 

__ e. Select ClipsAndTacks.mm 

__ f. Select DeclinedOrderEvent.cbe 

__ g. Select LateAverageOrderShippedEvent.cbe
 

__ h. Select NewOrderEvent.cbe
 

__ i. Click Finish.
 

____ 4.	 Expand the project in the Project Explorer view, then expand the Event Definitions and you will see 
the new events listed. Expand Monitor Models and you will see the new ClipsAndTacks model 
listed. 
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Part 2: Import the user defined function project 

In this section you will use Rational Application Developer or WebSphere Integration Developer to import 
the project interchange containing the cost functions. 

____ 1. Switch to the Java EE perspective. 

__ a. Click Window > Open Perspective > Other… 

__ b. Click Show all, then select Java EE 

__ c. Click OK 

____ 2. Import the cost function project interchange file. 

__ a. Right click in the Project Explorer view, and then select Import > Import… 

__ b. Select Other > Project Interchange, click Next. 

__ c. For the .zip file, browse to the location containing the file, for example,
 
c:\Labfiles62\UDF\CostFunctionPI.zip
 

__ d. Click Select All
 

__ e. Click Finish.
 

__ f. You will see the costFunctions project in the Enterprise Explorer. 

____ 3. Check for any errors in the Problems view. You should resolve any errors before continuing. 
Warnings and informational messages may be present but these will not be a problem. 
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Part 3: Review the user defined functions and create the jar file 

In this section you will review the user defined functions that you imported in the previous section. Then 
you will export a jar file which will be imported into the monitor model. 

____ 1.	 Expand the costFunctions project in the Enterprise Explorer. 

____ 2. Double click CostFunctions.java to open the Java editor.
 

____ 3. Notice the annotations in the file to specify the user defined functions to Monitor.
 

____ 4. You will use the cost1 function in the monitor model. 

____ 5. Take a look at the code in the cost1 function. It receives a parameter which is the number of days 
duration for order fulfillment. It multiplies the duration by a random number between 0 and 1, then 
multiplies that by 10. It returns this number as a decimal number, which is the calculated cost for the 
supplied duration. This is a simple example for the lab, but you could easily reference a database or 
Web service to retrieve the cost. Notice the Java types which are used for the function, argument 
and return types. Since you are implementing a Java method that will be used as an XPath function, 
you need to be aware of the mappings from Java to XML data types. Refer to the Information 
Center for all the available data types and mappings. 

____ 6.	 There is another function cost2 which is defined in this file, but it will not be used in the monitor 
model. There is also another file MoreCostFunctions.java which contains other cost functions. This 
file will be imported into the model to show how multiple files can be referenced in the workspace. 

____ 7.	 Export the user defined functions to a jar file. 

__ a. Right click the costFunctions folder (not the CostFunctions.java) in the Enterprise Explorer, and 
select Export… 

__ b. Select Java > Jar file, and click Next. 
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__ c. For the JAR file, click Browse… and navigate to a destination such as c:\temp.
 

__ d. Then specify a name for the jar file, such as costFunctions.jar, and click Save.
 

__ e. Click Finish.
 

__ f. You may get a popup indicating warnings, but this is fine, so just click OK.
 

____ 8. Check for any errors in the Problems view. You should resolve any errors before continuing. 
Warnings and informational messages may be present but these will not be a problem. 
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Part 4: Import the user defined functions into the monitor model 

In this section you will import the user defined functions jar into the monitor model. 

____ 1. Switch to the Business Monitoring perspective. 

__ a. Click Window > Open Perspective > Business Monitoring 

__ b. Click OK 

____ 2. Define an external function library. 

__ a. Right click the ClipsAndTacks project in the project explorer, then select External Function 
Libraries… 

__ b. Click Add External JARs… 

__ c. Navigate to the location of your function jar, for example, c:\temp\costFunctions.jar, then click 
Open 

__ d. Click OK. 

____ 3. Define the cost functions to the monitor model. 

__ a. Double click ClipsAndTacks > Monitor Models > ClipsAndTacks.mm in the project explorer. 

__ b. The monitor model editor opens. 

__ c. On the Monitor Model Details tab, notice the area for user defined functions: 
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__ d. Click Edit…
 

__ e. You should see a list of the function files in the library.
 

__ f. You need to assign a prefix to each namespace. 

__ g. Check the box for the first one in the list, then type a name for the function prefix down below, for 
example, costMain. 
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__ h. Check the box for the second one in the list, then type a name for the function prefix down below, 
for example, costOther. 

__ i. Click Finish, then you should see the two listings on the Monitor Model Details tab in the user 
defined functions list. 

__ j. Now the functions are available for use in the monitor model.
 

__ k. Press Ctrl-S to save your work.
 

__ l. Check for any errors in the Problems view. You should resolve any errors before continuing.
 
Warnings and informational messages may be present but these will not be a problem. 
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Part 5: Add expressions that reference user defined functions 

In this section you will use Rational Application Developer or WebSphere Integration Developer to edit the 
monitor model. You will create a new metric and add expressions which use the cost functions. You will be 
calculating the cost based on the order fulfillment duration metric which is already defined in the model. 
Since the order fulfillment duration metric is calculated based on two triggers, one for the order shipment 
and one for the order cancellation, you will use the same triggers to fire the calculation of this cost metric. 

____ 1. If not already open, switch to the Business Monitoring perspective. 

____ 2. Double click the monitor model ClipsAndTacks.mm in the project explorer to open the model 
editor. 

____ 3. Create a new metric in the monitor model for order fulfillment cost. 

__ a. In the model navigator in the model editor, right click 'ClipsAndTacks MC', then select New > 
Metric. 

__ b. For name, enter: Order Fulfillment Cost 

__ c. For ID, accept default: Order_Fulfillment_Cost 

__ d. For type, select: Decimal 

__ e. Click OK 

__ f. For Metric Value Expressions, click Add 

__ g. In the first row of the Metric Value Expressions table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > Ship Order 
to Customer Trigger, click OK 

__ h. In the first row of the Metric Value Expressions table, select the cell under column Expression, 
then bring up content assist by pressing Ctrl-space. Expand Functions and notice that your cost 
user defined functions are listed here with the prefixes costMain and costOther that you defined 
earlier: 

__ i. Select costMain:cost1 and it is added to the expression. 
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__ j. Now you need to define the integer duration input to the function. There is a metric in the model, 
Order Fulfillment Duration, that you can use, but it is type duration so you will also need to use a 
function to convert the duration to an integer number of days. Use content assist, or type the 
expression manually so that it looks like this: 

costMain:cost1(fn:days-from-duration(Order_Fulfillment_Duration)) 

__ k. Press Ctrl-S to save your work. 

__ l. For Metric Value Expressions, click Add 

__ m. In the second row of the Metric Value Expressions table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC > 
Cancel Trigger, click OK 

__ n. In the second row of the Metric Value Expressions table, select the cell under column 
Expression. Use content assist, or type the same expression as above so that it looks like this: 

costMain:cost1(fn:days-from-duration(Order_Fulfillment_Duration)) 

__ o. Press Ctrl-S to save your work. 

____ 4. Check for any errors in the Problems view. You should resolve any errors before continuing. 
Warnings and informational messages may be present but these will not be a problem. 

25 February 2009 IBM WebSphere Business Monitor 6.2 – Lab exercise Page 12 of 20 

User defined functions 



        

               

    

        

 

               
        

              
             

                  
       

                   
                   

                      
       

                   
           

  

              

                  
                 

                 
            

               

                 
      

     

                   
                   

         

     

                
 

© Copyright IBM Corporation 2009. All rights reserved 

Part 6: Publish the model to the server 

In this section you will use Rational Application Developer or WebSphere Integration Developer to publish 
the monitor model to the monitor server. 

____ 1. In Project Explorer, expand ClipsAndTacks � Monitor models � ClipsAndTacks.mm. Right click 
over ClipsAndTacks.mm and then select Generate Monitor J2EE Projects from the context menu 

____ 2. If you have already generated the ClipsAndTacks model for another lab, then you may need to 
select 'overwrite existing projects'. Then click Finish. 

____ 3. A progress dialog shows the status of the operation and it closes when the operation is complete. 
Check for errors in the Problems view. There may be warnings, but there should not be any errors. If 
you see errors, then try to perform a clean to see if the errors can be removed: Project > Clean… > 
select 'Clean all projects', then click OK. 

____ 4. Click the Servers tab, then right click and select the Start option to start the server WebSphere 
Business Monitor v6.2. This may take a few minutes to complete. 

____ 5.	 Right click in the servers view, then select 'Add and Remove Projects…'. 

____ 6.	 Click Add to move the ClipsAndTacksApplication from the list of available projects to the list of 
configured projects. Click Finish. Note: If the application is already in the list of configured projects, 
then you may have run another lab and published this application already, so in that case, cancel 
this window and select the 'Publish' option from the server menu. 

____ 7.	 A progress message is displayed in the lower right corner of the window. 

____ 8.	 Check the messages in the console view. You should see the following message when the 
application has been started: 

Application started: ClipsAndTacksApplication 

____ 9.	 In the servers view, right click, then select Run administrative console. You should see it open in 
a separate tab. It will prompt you for user ID and password. Enter 'admin' without the quotes for user 
ID, then enter 'admin' without the quotes for password. 

____ 10.	 Click Log in 

____ 11.	 Click Applications > Monitor Models. The application should show green status if it started 
successfully. 
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____ 12.	 If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the 
right of Status in the last column of the table. You should see green (started) for the model. If it does 
not show green, be patient and keep refreshing until it does show green. 

____ 13.	 Check the server log to ensure there are no problems. You can check this in the console view. 

____ 14.	 If you are using the integrated server within WebSphere Integration Developer or Rational 
Application Developer, then you do not need to setup Monitor data security, since the administrative 
user is automatically authorized to all models. If you are using a different server, then you should 
open the administrative console, navigate to Security > Monitor Data Security, then add the 
model, role and user information to a resource group. 
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Part 7: Run events to exercise the model 

Rather than installing a J2EE application to actually create the events that you want to monitor, you are going 
to use a program to simulate the submission of events from the application. 

The supplied program is 'BatchCBEWriter61' and it will submit the events to the Common Event Infrastructure. 
Look for the program in \Labfiles62\ClipsAndTacks\BatchCBEWriter. This program reads XML files which 
represent the Common Base Events for the model. 

____ 1.	 Update BatchCBEWriter61.bat to point WAS_HOME to the monitor server home, for example 'set 
WAS_HOME=C:\IBM\WebSphere\AppServer'. If you are using the integrated monitor server in 
WebSphere Integration Developer, the path would be <WID-Install-Path>\pf\WBMonSrv_wps. If you 
are using the integrated monitor server in Rational Application Developer, the path would be <RAD-
Install-Path>\pf\WBMonSrv. 

____ 2.	 Update config.properties, setting the serverName and portNumber. You can find the port number by 
browsing the server log and finding 'bootstrap port'. For example, check for the log at 
C:\IBM\WebSphere\AppServer\profiles\WBMon01\logs\server1\SystemOut.log . For the integrated 
server in WebSphere Integration Developer, the path would be <WID-Install­
Path>\pf\WBMonSrv_wps\logs\server1\SystemOut.log and the portNumber should be 2810. For the 
integrated server in Rational Application Developer, the path would be <RAD-Install­
Path>\pf\WBMonSrv\logs\server1\SystemOut.log and the portNumber should be 2810. Here is an 
example of the config.properties settings: 

__ a. connect.serverName = localhost 

__ b. connect.portNumber = 2810 

____ 3.	 Open a command window, then change directory to the folder containing BatchCBEWriter61, for 
example, type this command 

__ a. cd \Labfiles62\ClipsAndTacks\BatchCBEWriter 

____ 4.	 Run commands to load the common base events to the server. 

__ a. batchcbewriter61 -Dsource.filename="c:/labfiles62/clipsandtacks/cbe/allevents.xml" 

__ b. When it prompts you for user identity and password, enter 'admin' for both (without the quotation 
marks) 

____ 5.	 When you run BatchCBEWriter61, you should see results such as: 
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Part 8: Create a dashboard 

In this section you will build a dashboard in business space. You will add widgets to the dashboard and 
configure them. 

____ 6. Create the dashboard. 

__ a. The default browser is 'Internal Web Browser', but you should not use this one since some 
standard functions are not provided that you may need. Select Window > Preferences > General 
> Web browser > select 'Use external Web browser'. Select an external browser. Click OK. 

__ b. In WebSphere Integration Developer, in the servers view, right click and select Business Space 

__ c. When prompted, enter admin for the user ID and enter admin for the password. You must log in 
with 'admin' so that you can view the alerts which were setup in action manager to be sent to this 
particular user ID. Also, in the toolkit environment, this is the user that is automatically defined on 
the secured server. 

__ d. Click the icon to create a new space. 

__ e. Enter a name such as Dashboard, select Empty, then click OK. 

__ f. Click the icon to create a new page in the Dashboard space. 

__ g. Enter a name such as Page1, select Empty, then click OK. 

__ h. Click Page1 to open it. 
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__ i. Now you can add widgets to the page by clicking on 'Add widgets' in the upper right corner 

, then dragging a widget to the page. If you want to rename the page, change the 
layout or remove the page from display, use the icons to the right of the page name on the tab 

. To return to the business space list, click 'Manage Business Spaces' in the upper 

. 

____ 7. Add the instances widget to the dashboard. 

__ a. Click Add widgets, then select Instances and drag it to the page. 

__ b. Click Configure on the widget menu. 

right corner 

and 1) To Access the menu, hover the mouse over the right corner of the widget 
then click the down arrow. On this menu you can configure the widget, refresh the widget 
and delete the widget. 

__ c. Click the Show/Hide tab, and select monitoring context 'ClipsAndTacks MC'. 

Click button >> to move all the fields to the Selected box. Also, 
click button 'Set as default' which will make this the default monitoring context to display. 

__ d. Then click OK. You should see a list of monitoring context instances for the events that you just 
processed. 

__ e. Notice the new metric Order Fulfillment Cost. For shipped or cancelled orders, you see that the 
cost1 function has been used to calculate the cost based on the Order Fulfillment Duration. 
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What you did in this exercise 

In the lab, you imported user defined functions into a monitor model, and you created a cost metric which 
referenced the functions in expressions. 

Then you published the model to the monitor server. 

You used the supplied program to simulate the submission of events from the monitored application. 

You configured dashboards to view the new cost metric in the instances widget. 
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