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IBM WEBSPHERE BUSINESS MONITOR 6.2 — LAB EXERCISE

WebSphere Business Monitor V6.2 Clips and Tacks
Business activity monitoring lab
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What this exercise is about

The objective of this lab is to show you how to build a monitor model in Rational Application Developer or
WebSphere Integration Developer, deploy it to WebSphere Business Monitor, then view your monitored
data on the Monitor dashboards.

This lab will show you Business Activity Monitoring (BAM) which involves event based monitoring. With
BAM, you can have your monitored application running anywhere, and submitting events to the Monitor
server so that you can view monitored data. Typically, you identify the events that will be created by the
application, and then create a monitor model that represents the monitored data that you want to collect
from the events.

Changes from the previous version

This lab has been modified for the 6.2 release. This includes user interface changes to the administrative
console and the business space.

This lab has been maodified for the 6.1.2 release. Here are the major changes:
e Updated the dashboard section to show how to use business space.
This lab has been maodified for the 6.1 release. Here are the major changes:
« In the monitor model, you can reference other KPIs when defining the calculation for a given KPI.
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 KPIs are now based on a metric and aggregation function, and not based on cube measures, so
the dimensional model is now simplified.

e Deploying the model has been dramatically simplified, so this is a very short process now.
e LDAP is not required, so now you can test alerts without installing LDAP.

« Portal is no longer a requirement, so configuration of a dashboard is simplified.

Lab requirements
List of system and software required for the student to complete the lab:
< Rational Application Developer V7.5 or WebSphere Integration Developer V6.2.

e WebSphere Business Monitor V6.2 — Toolkit Installation including the Monitor Model editor and
Monitor Server

o0 DB2 Alphablox is an optional prerequisite for the installation of the Monitor toolkit. If you

choose not to install it, then you will not be able to use the report and dimension views in the
dashboard.

What you should be able to do
At the end of this lab you should be able to:

« Use Rational Application Developer or WebSphere Integration Developer to create the monitor model,
and deploy it to the server.

= Use a sample program to create events that represent events from your process.

e Define a dashboard to view monitored data.

Introduction

In this lab you will learn how to deploy a model from end to end using Rational Application Developer or
WebSphere Integration Developer and WebSphere Business Monitor. This lab will show you the basic
procedure for creating and implementing a simple model.

The model used in this lab is the ClipsAndTacks model which is also used in IBM Redbook SG247148 —
Business Process Management: Modeling through Monitoring Using WebSphere V6.0.2 Products.
In the Redbook, there are several models that are referenced, but in this lab you will be using the Future 1
Process. In the Redbook, the process is implemented as a BPEL process running in WebSphere Process
Server. However this lab will demonstrate Business Activity Monitoring which can monitor events from
any source. So, the lab will simulate the running of the process, by creating events that could have been
sourced from anywhere, a J2EE application or BPEL, or any other source. These events are in the form of
Common Base Events, which is an OASIS standard for common event format, and these are used by the
Common Event Infrastructure (CEI) in WebSphere Process Server.

In this lab you will build a monitor model that has the same basic elements as the one that is defined in the
Redbook. Namely you will create monitoring constructs in support of two KPIs:

e Average order fulfillment is three days or less

* Percentage of shipped orders is greater than 90%
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You will also create situation events if declined orders are greater than or equal to three and if the order
fulfillment time is greater than three days.

For dimensional analysis, you will create a Location dimension which allows you to drill down on country
and city. You will also add an Order Status metric, which shows orders as '‘New', 'Cancelled' or 'Shipped'.
And you will add measures for average order price, sum of order price for all orders, and order count.

Here is a diagram of the ClipsAndTacks process model:
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This is the ordering process for the Clips And Tacks Company. In this process, orders are received and
optionally submitted to a review process. Orders which pass all checks are shipped to the customer. Other
orders may be cancelled.

In the monitor model, you will create one monitoring context for each customer order. You will identify the
inbound event that represents the receipt of the order, and this is marked so that it will create a new
monitoring context instance for the order. You will also identify the inbound event that represents shipping
the order, and this is marked so that it will trigger the termination of the monitoring context instance for the
order. Since an order may also be cancelled, you will identify the inbound event that represents
cancellation of the order, and this is also marked so that it will trigger the termination of the monitoring
context instance.

Useful URLs

The following URLs may be helpful to you as you exercise this lab. Note that the port numbers in the URL
of your installation may be different depending on your configuration.

e Server administrative console

https://localhost:9044/ibm/console

e Business space dashboard

https://localhost:9444/BusinessSpace
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Part 1: Create the monitor model

To create the monitor model, you will use the monitor model editor in Rational Application Developer or
WebSphere Integration Developer. Note that the screen captures in this lab are based on WebSphere
Integration Developer, so they may differ slightly from yours if you are using Rational Application
Developer.

Note that there is a 'Problems' tab that displays errors concerning the model. Periodically, you should
check this view to see if you have any problems that need to be addressed. Normally, warnings and
informational messages are not a problem, but errors should be addressed.

If you want to skip this section, then a solution has been provided. You can import the supplied monitor

model into Rational Application Developer or WebSphere Integration Developer, and then proceed to the
next section. Refer to Appendix 1, and then proceed to the next section.

1. Start Rational Application Developer or WebSphere Integration Developer and setup the
environment.

___a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted
point to a new workspace such as c:\workspaces\ClipsAndTacks

___b. Close the Welcome tab.

___c. By default, you are in the Business Integration perspective but you need to open the Business
Monitoring perspective.

1) Select Window > Close Perspective
2) Select Window > Open Perspective > Business Monitoring.
3) If it asks you to Confirm Enablement, then click OK.
___d. You should close the help view by clicking the 'x' in the 'Help' tab.
___e. You should see the Business Monitoring perspective.

2. Create a new monitoring project. A project is a container for your monitor models and event
definitions.

___a. Rignht click the Project Explorer, then select New > Business Monitoring Project...
___b. For Project name, enter ClipsAndTacks

__c. Click Finish. If you see the getting started prompt, click No. You will see the new project in the
Project Explorer view.

ET_&"5

¥ Event Definitions
i) Monitor Models
83 G Files

3. There is a predefined Common Base Event definition for you that represents the event layout for
events processed in this model. Import the supplied common base event for ActivityEvent.
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___a. From the Project Explorer view, right-click ClipsAndTacks and select Import...
___b. Select General > File system, click Next

___c. Browse to the location containing the ActivityEvent cbe, for example,
c:\Labfiles62\ClipsAndTacks

__d. Select ActivityEvent.cbe as follows:

4= Import |

File system F
Import resources from the local file syskem, f .-_’
Fram directary: IC:'I,LabFiIessl'l,CIipsP.ndTacks ﬂ Browse, ., |

E ActivityEvent.che
Ef, clipsandTacks.mm

------ = ClipsAndTacks

E DeclinedOrderEvent.che
E LatefverageCrdershippedEvent.che
E MevadrderEvent che

O
O
O
O

Filter Types. .. | Select All Deselect All
Into Folder: |CIipsAndTacks Bromse, .. |
Options

[ Overwrite existing resources without warning
"~ Create complete Folder struckure

%' Create selected folders only

___e. Click Finish.

___f. Expand the project in the Project Explorer view, then expand the Event Definitions and you will
see the new event listed.

EE Ewvent Definitions

i E ActionServicesEvent.che
- [E ActivityEvent.che
[ Cﬂ Manitar Models

------ (&8 svi Files

___g. Double click ActivityEvent.cbe to open the event editor. Browse the extended data elements to
familiarize yourself with the event data for this model.

1) ActivityEventData contains data elements that relate to the activities in the process. The
fields, businessUnit and processName, are used to filter out unwanted events that do not
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relate to this particular model. The field activityName is used to associate an event with a
specific activity in the process. The field eventType is used to identify the state of the
activity, either starting or completing.

2) OrderBOData contains data elements that relate to the specifics of a customer order, such
as orderNumber, country, city, totalPrice, and so on.

Tare AckivityEvent
Parent envent
Property
Extended Data Twpe

= ActivityEventData noValue
businessUnit string
processiame skring
mcll skring
activityMame skring
eventType skring
startTime dateTime
endTime dateTime

= OrderBOData noitalue
arderhiumber skring
customerhumber skring
arderstate string
City skring
counkry skring
producttumber skring
quankity int
tatalPrice double

___h. WebSphere Business Monitor has support for concurrent versions of monitor models. In order to
take advantage of the Monitor server's version handling capabilities, each monitoring context
must have a unique inbound event that has the setting 'If no instances are found: Create new
instance’. One can think of this as one inbound event carrying ‘create monitor context' semantics,
and all other inbound events as 'update monitor context' semantics. The inbound event for
creating monitoring context instances can be identified in two ways. It can have a unique event
definition name with a separate event definition, or it can use an existing event defintion but be
identified by unique filter condition information. For Clips And Tacks, there is a unique inbound
event name, New Order Event, that should create new monitoring context instances, so now you
will create the event definition for it.

1) Right click Event Definitions and select New > Event Definition...(cbe).

2) Enter NewOrderEvent.cbe for the file name
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|
Event Definition

Create a new Event Definition

Enter or select the parent folder:
| ClipsandTacks

it

------ 1= ClipsandTacks

File: narne: | MewOrderEvent.che

Advanced = |

3) Click Finish.

4) The Event Definition Editor for NewOrderEvent opens.

Event Definition

Mame* MewOrderEvent
Parent* event
Property

Extended Data

5) The NewOrderEvent has the same data elements as the Activity Event, so you can just
show ActivityEvent as the parent, then NewOrderEvent will inherit that data element layout.

Double click the hierarchical icon next to the label Parent.

6) On the Select Event Definition Dialog double click ActivityEvent.

4= Select Event Definition |

Select Event Definition

Select an event definition to be the parent event, | %f/

Seleck an event to open;

MMatching Events:

ActionServicesEvent

WEL MonitaringEwent
event

Files:

IClipsAndTack: vent.che

7) ActivityEvent is now shown as the parent of NewOrderEvent
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wEvent Definition

Mame* MNewCrderEvent
Parent* AckivityEvent
Property
Extended Data

8) Press Ctrl-S to save your work.

4. Create a new monitor model ClipsAndTacks. The monitor model contains the metrics and KPIs that

you want to monitor and it will be the source for creating the deployment code for the monitor
server.

___a. Right click in the Project Explorer view, then select New > Monitor Model...

___b. For File name, enter ClipsAndTacks.

4= Monitor Model |

Create a monitor model e

Create a new monitor model,

Enter or select the parent Folder:

| ClipsandTacks

iy

""" 1= ClipsandTacks

File name: | ClipsandTacks

___C. Click Finish. The model editor is opened as follows:

Note: When the model editor first opens you will have errors in the model. This is normal and is signaling
that required elements are missing or incomplete. Next you will complete these required elements.

5. Notice in the Monitor Details Model navigator that a new model is created (ClipsAndTacks) along
with a monitoring context (ClipsAndTacks MC). Now you need to specify the inbound events that will
be processed by this model. You need to indicate which event will create a new monitoring context
instance and which event will terminate the monitoring context instance. You also need to identify
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the correlation information for the monitoring context so that Monitor knows which monitoring
context instance should receive the events. The ClipsAndTacks model uses one event definition,
ActivityEvent, to represent the layout of all of the events to be processed. NewOrderEvent derives
from ActivityEvent but does not add additional event elements. In ActivityEvent, ActivityName is a
field used to identify specific activities in the ClipsAndTacks process. ActivityName is used to
determine when to terminate the monitoring context. You will create correlation that is based on
orderNumber, which is another field defined in ActivityEvent.

___a. In the Monitor Details Model, expand ClipsAndTacks in the navigation view. Then expand

ClipsAndTacks MC. You will see that a key has been created for you automatically when you
created the model.

= E‘_ ClipsAndTacks
g5 ClipsAndTacks MC
i ClipsandTacks Key

___b. In the model navigation view, right click ClipsAndTacks MC, then select New > Inbound Event.

___c. For the name, type Activity Event. Notice that the ID will automatically be set for you to the
same name with underscores (Activity Event).

#= Create Mew Inbound Event

Create an inbound event
() T¥pe the name and 1D,

Marme: | Ackivity Event

I Ackivity _Event

Cancel

d

__d. Click OK.

___e. On the window for Event Type Details, you need to enter the extension name, so click
Browse... and navigate to ClipsAndTacks > ActivityEvent.cbe > ActivityEvent

___f. To enter the Filter Condition, you can use Content Assist with the keys Ctrl-Space, or you can
type the expression directly into the expression window. When completed the expression should
be as follows. Note the single quotation marks used for string handling. You should be careful
that you enter uppercase and lowercase exactly as shown.

Activity Event/extendedData/ActivityEventData/businessUnit = 'Clips And Tacks' and
Activity_Event/extendedData/ActivityEventData/processName = 'Order Handling'

___g. To enter the Correlation Expression, you can use Content Assist, or you can type the
expression directly into the expression window. When complete, the expression should be:

ClipsAndTacks_Key=Activity Event/extendedData/OrderBOData/orderNumber
__h. For'lf no instances are found', select 'Treat as error’

___i. For'If one instance is found', select 'Deliver to the instance'
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___j. For 'If multiple instances are found', select 'Treat as error’

___k. Here is a sample of a portion of the definition:

+ Filter Condition
Define a condition based on the event attributes to identify whether ko accept an event of this type.

Ackivity_EventlextendedData) dctivibyEventData/businessUnit = 'Clips And Tacks' and ;I
Activity_Event/extendedData) ActivityEventData/processhlame = "Order Handling'

=
+ Correlation Expression
Define an expression to identify the monitoring context inskance or inskances that receive the event at runtine.
ClipsandTacks_kew = Activity_Event/extendedData)CrderBODataorderumber ;I
=
If na instances are found Treat as ercor E‘
IF one instance is Found Deliver to the instance E‘
IF multiple instances are found E‘

___|. Press Ctrl-S to save your work.

___m. In the model navigation view, right click ClipsAndTacks MC, then select New > Inbound Event.
Note that you can also right click any child element within the monitoring context and you wiill
have access to the same menu.

___n. For the name, type New Order Event. Notice that the ID will automatically be set for you to the
same name with underscores (New_Order_Event).

__ 0. Click OK.
___p. For Event Type Details, navigate to ClipsAndTacks > NewOrderEvent.cbe > NewOrderEvent

___ Q. To enter the Filter Condition, you can use Content Assist, or you can type the expression directly
into the expression window. When complete, the expression should be as follows. Note the
single quotation marks used for string handling. You should be careful that you enter uppercase
and lowercase exactly as shown.

New_Order_Event/extendedData/ActivityEventData/businessUnit="Clips And Tacks' and
New_Order_Event/extendedData/ActivityEventData/processName='Order Handling'

___r. To enter the Correlation Expression, you can use Content Assist, or you can type the expression
directly into the expression window. When complete, the expression should be:

ClipsAndTacks_Key=New_Order_Event/extendedData/OrderBOData/orderNumber
___s. For'If no instances are found', select 'Create new instance'
___t. For 'If one instance is found', select 'Treat as error'
___u. For 'If multiple instances are found', select 'Treat as error'

___ V. Press Ctrl-S to save your work.
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___w. In the model navigation view, double click ClipsAndTacks Key, to open the key in the editor.

___X. For Key Value Expressions, click 'Add...". Note that double clicking in the table will produce the
same results.

___y. Arow is added to the table and in the expression cell it shows << No expression specified >>.
Click this cell of the table, then a button is displayed. Click this button and the expression editor
is displayed. You can use Content Assist, or type this expression directly into the window:

New_Order_Event/extendedData/OrderBOData/orderNumber
__ z. Click OK.

___aa. Here is a sample of the key:

« Key Details
Edit the details of the key. Each monitoring context requires at least one key,

(s} 4 ClipsandTacks_Kew
Marne; ClipsandTacks Key
Description:

Type: *lString

Maximumm 3kring Length: | 256

O allocate additional space in database to accommodate Unicode string for globalization
O & value is required For this key
Default value:

O this ke can be used For sorting

w Key Yalue Expressions
Specify the expressions that set the value of the key.,

Expression |
;%Y Mevs_Order _Event/extendedData/OrderBoDataforderMumber

___bb. Press Ctrl-S to save your work.

Note: At this point there should not be any errors remaining in the model. The errors shown initially were
the result of the monitoring context key not being complete.

6. Create triggers that indicate the end of the monitoring context. The first trigger is based on an order
being shipped, and the second trigger is based on an order being cancelled.

___a. In the model navigation view, right click ClipsAndTacks MC, then select New > Trigger. Enter
these values:

1) Name - Ship Order to Customer Trigger

2) ID - Ship_Order_to_Customer_Trigger
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3) Select the check box next to 'Terminate monitoring context'

4) For Trigger Sources, click Add, then select Other source type > Activity Event, then click
OK.

5) For Trigger Condition, enter

Activity Event/extendedData/ActivityEventData/activityName='Ship Order to Customer' and
Activity Event/extendedData/ActivityEventData/eventType='completed'

___b. Press Ctrl-S to save your work.

___c. Here is a sample of this trigger:

w Trigger Details

Edit: the details of the trigger, which detects an occurrence and initiabes an ackion in response,

(o} « Ship_Crder_to_Customer_Trigger
Tame: Ship Order bo Customer Trigger
Descripkion:

O Trigger is repeatable

Terminate manitaring conkext

= Trigger Sources
Specify the source of this trigger.

Source Type | Source
Event g Activity Event

+ Trigger Condition
Specify the condition that determines whether the trigger will Fire,

Ackivity_EventlextendedDatal ActivibyEventData/activibyMame="ship Order bo Customer' and
Activity_Event/extendedData)ActivityEventData/event Type="completed’

___d. In the model navigation view, right click ClipsAndTacks MC, then select New > Trigger. Enter
these values:

1) Name - Cancel Trigger
2) ID - Cancel_Trigger
3) Select the check box next to 'Terminate monitoring context'

4) For Trigger Sources, click Add, then select Other source type > Activity Event, then click
OK.

2009 February, 20 IBM WebSphere Business Monitor 6.2 — Lab exercise Page 12 of 56

ClipsAndTacks



© Copyright IBM Corporation 2009. All rights reserved

5) For Trigger Condition, enter
Activity Event/extendedData/ActivityEventData/activityName='Cancel Order and Send
Noatification' and Activity Event/extendedData/ActivityEventData/eventType="completed’

___e. Press Ctrl-S to save your work.

7. Create a KPI for Average fulfillment three days or less. First you will create a trigger which fires
when a new order is started. Metrics are created to hold the order start time and order end time. The
values of the metrics are set when the new order trigger fires. You create a duration metric which is
calculated based on subtracting the order end time metric from the order start time metric. You will
create a KPI context which is a container to hold your KPIs. Then you create a KPI which is based
on the duration metric and you apply an average function to it.

___a. Inthe model navigation view, right click ClipsAndTacks MC, then select New > Trigger. Enter
these values:

1) Name — New Order Trigger
2) ID — New_Order_Trigger

3) For Trigger Sources, click Add, then select Other source type > New Order Event, then click
OK.

4) For Trigger condition, enter
New_Order_Event/extendedData/ActivityEventData/activityName="Check Order Handling

Policy for Automatic Approval' and
New_Order_Event/extendedData/ActivityEventData/eventType='"started’

5) Press Ctrl-S to save your work.

__b. In the model navigation view, right click ClipsAndTacks MC, then select New > Metric. Enter
these values:

1) Name — Order Start Time

2) ID — Order_Start_Time

3) Type — DateTime

4) For Metric Value Expressions, click Add

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

6) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

New_Order_Event/extendedData/ActivityEventData/startTime
7) Click OK.

8) Press Ctrl-S to save your work.
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w Metric Details
Edit: the details of the metric, which is a holding spot for information used in other caloulations.

(s} 4 order _Skart_Time
Marme: Order Skart Tine
Description:

Type: " DateTime

O & walue is required For this metric
Defaulk Yalue:

O This metric can be used For sorting

+ Metric ¥alue Expressions
Specify the expressions that set the value of the metric, IF a trigaer is specified, the map is evaluated when the trigger fires,

Trigger | Expression
§€‘=:=>§New Order Trigger ' Mew_Order_Event/extendedDatafActivityEventData/start Time

___c¢. Inthe model navigation view, right click ClipsAndTacks MC, then select New > Metric. Enter
these values:

1) Name — Order End Time

2) ID — Order_End_Time

3) Type - DateTime

4) For Metric Value Expressions, click Add

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> Ship Order to Customer Trigger, click OK

6) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

Activity Event/extendedData/ActivityEventData/endTime
7) Click OK.
8) For Metric Value Expressions, click Add

9) In the second row of the Metric Value Expressions table, select the cell under column
Trigger, then a button is shown, then click the button and select Trigger type >
ClipsAndTacks MC > Cancel Trigger, click OK

10) In the second row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

Activity_Event/extendedData/ActivityEventData/endTime
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11) Click OK.

___d. Press Ctrl-S to save your work.

w Metric Details
Edit: the details of the metric, which is a holding spot for information used in other caloulations.

(o} 4 Order_End_Time
Mame: Order End Time
Descripkion:

Twpe: N DakeTime

O & value is required For this metric
Default value:

O This metric can be used For sorting

w Metric ¥alue Expressions
Specify the expressions that set the value of the metric, IF a trigger is specified, the map is evaluated when the trigger fires,

Trigger | Expression
E5=:=>Shi|: Order to Customer Trigger =$Y Activity_Event/extendedDataf ActivityEventData/endTime
§€‘=:=>Cancel Trigger ﬁ* Ackivity_Event/extendedDatal ActivityEventData/endTime

___e. Inthe model navigation view, right click ClipsAndTacks MC, then select New > Metric. Enter
these values:

1) Name — Order Fulfillment Duration

2) ID — Order_Fulfilment_Duration

3) Type - Duration

4) For Default Value, click Edit...

5) On the Select Duration dialog, click OK, and this will set the default duration to zero.

6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> Ship Order to Customer Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

xs:dayTimeDuration (Order_End_Time - Order_Start_Time)
9) Click OK.

10) For Metric Value Expressions, click Add
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11) In the second row of the Metric Value Expressions table, select the cell under column
Trigger, then a button is shown, then click the button and select Trigger type >
ClipsAndTacks MC > Cancel Trigger, click OK

12) In the second row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

xs:dayTimeDuration (Order_End_Time - Order_Start_Time)
13) Click OK.

__f. Press Ctrl-S to save your work.

w Metric Details
Edit: the details of the metric, which is a holding spot For information used in other caloulations.

(o} 4 Order_Fulfillment_Duration
Mame: Order Fulfillment Duration
Descripkion:

Twpe: N D ation

O & value is required For this metric
Defaulk walue: | dayTimelur ation{' PODTOHOMO,0005"

O This metric can be used For sorting

w Metric ¥alue Expressions
Specify the expressions that set the value of the metric, IF a trigger is specified, the map is evaluated when the trigger fires,

Trigger | Expression
i w5 :day TimeDuration{Order _End_Time - Order_Skart_Time)

E5=:=>Shi|: Order to Cuskomer Trigger =7
:‘=:=> Cancel Trigger ﬁ* xs:day TimeDuration{Order_End_Time - Order_Start_Time)

___@. Click the KPI Model tab.
___h. Create a KPI context to store the KPls.

1) In the navigation view of the KPI Model, right click ClipsAndTacks, then select New > KPI
Context

a) Name — My KPI Context
b) ID - My_KPI_Context

__i. Create the average order fulfillment KPI.

Note that you will create the KPI based on events for August 2006. This will work for you no matter what
month or year that you run this lab because the timestamps in the test data are based on August 2006, so
your results will be the same as in these lab instructions.
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1) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name — Average Order Fulfillment KPI August 2006
b) ID - Average_Order_Fulfilment_KPI_August_2006
2) Enter these values:
a) Type — Duration
b) Select 'Keep track of historical values for this KPI'

c) In KPI Target and Ranges, for Target click Details..., then change the value to 3
Days, then click OK

d) In KPI Target and Ranges, for Ranges select Actual value
e) In the Range table,
(1) Click Add, or double click anywhere in the table
(2) Change the Name to Day 1, and the ID to Day_1
(3) Arow is created in the Range table with a range name Day 1.

(4) For this row, the default in the Start column is 0 milliseconds, which is what
you want.

(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change Days to 1 and the other values
to 0, then click OK.

f) Now you have created one range called Day 1. Repeat the above step to create four
more ranges:

(1) Day 2 with start values 1 Days and end value 2 Days
(2) Day 3 with start values 2 Days and end value 3 Days
(3) Day 4 with start values 3 Days and end value 4 Days
(4) Day 5 with start values 4 Days and end value 5 Days
g) KPI Value — select 'Base this KPIl on a metric and an aggregation function.'

h) Under KPI Details, for Monitoring context, click Browse..., then select
'ClipsAndTacks MC', then click OK

i) Metric — click Browse..., then select Order Fulfillment Duration, then click OK
j) Aggregation function — select Average.

k) Under Time Filter, for Metric, click Browse..., then select Order Start Time, then
click OK

l) Specify time period — Fixed

m) Start date — click Edit... then select date 2006-08-01, time 00:00:00, click OK
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n) End date — click Edit..., then select 2006-08-31, time 23:59:59, click OK
3) Press Ctrl-S to save your work.

= KPI Details
Edit the details of the KPI, which is a performance measurement used to krack business objectives,

10: 4 Pwerage_Order_Fulfilment_KPI_August_2006

Mame: Average Order Fulfillment KPT August 2006

Description: d
[~

Type: | pration =]

Keep track of historical values For this £PI

w KPI Target and Ranges
Specify a target, which is an exact value for the KPI ko achieve, or ranges against which ta track the KPI, or bath,

Tarqget: 3 Days

Ranges: Actual value E|
Range name | Start value | End value |
= Day 1 0 Milliseconds < 1Days
= Day 2 1 Days % 2 Days
= Day 3 2 Days < 3Days
= Day 4 3 Days < 4 Days
= Day 5 4 Days < 5Days
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= KPI Definition
Specify how the value of the KPT is set,

KPI ¥alue

Choose how the £PT will get its walue:
{®) Base this KPI on a metric and an aggregation Function,

O Write an expression to caloulate this KPT based on existing KPIs
KPI Details

Monitoring contexts 4 ClipsandTacks MC

Metric: 4 order Fulfillment Curation

Aggregation funckion: *l Ayverage

IJse values From: ® all madel versions ) Only this version of the maodel

Time Filter
Select a time period over which the KPI should be calculated,

Metric: | Order Start Time
Tine period:

O None O Repeating O Rolling @ Fixed

Skart date: | 2006-05-01T00:00:00 End date: | 2006-05-31T23:59:59
Tire zone: *IGMT—EI&:DD : Location: I :

___j. Note that this KPI as it stands averages order fulfillment time for shipped orders and cancelled
orders, but you probably are not interested in the cancelled orders to be included in this KPI. So
update the average order fulfillment KPI to show the values for shipped orders only. First you will
create a new metric to hold the order status. Then you will add this metric as a data filter on the
KPI.

___k. Click the Monitor Details Model tab.

__l. In the Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >
Metric. Enter these values:

1) Name — Order Status
2) ID — Order_Status
3) Type — String

4) 4) Select 'A value is required for this metric'. The editor requires that you select this
whenever you use a metric as a source for a dimension in the dimensional model.

5) Default Value (enter this text with single quotation marks) — 'New'
6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> Cancel Trigger, click OK

2009 February, 20 IBM WebSphere Business Monitor 6.2 — Lab exercise Page 19 of 56

ClipsAndTacks



© Copyright IBM Corporation 2009. All rights reserved

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text with the
guotation marks:

'‘Cancelled’
9) Click OK.
10) For Metric Value Expressions, click Add

11) In the second row of the Metric Value Expressions table, select the cell under column
Trigger, then a button is shown, then click the button and select Trigger type >
ClipsAndTacks MC > Ship Order to Customer Trigger, click OK

12) In the second row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text with the
guotation marks:

'‘Shipped’

13) Press Ctrl-S to save your work

w Metric Details
Edit: the details of the metric, which is a holding spot for information used in other caloulations.

j(nY 4 Order_Skakus
Marme: Order Skakus
Description:

Type: *lString

Maximumm 3kring Length: | 256

O allocate additional space in database to accommodate Unicode string for globalization

A walue is required For this metric

Default walue: | 'Mew

O This metric can be used For sorting

w Metric ¥alue Expressions

Specify the expressions that set the value of the metric, IF a trigger is specified, the map is evaluated when the trigger fires,
Trigger | Expression
:‘=:b Zancel Trigger =$Y ‘Cancelled'
éi‘=:=>5hi|: Order to Customer Trigger ﬁ* ‘Shipped

___m. Update the order fulfillment KPI to use the order status as a filter.
1) Click the KPI Model tab.

2) In the KPI Model navigation view, navigate to ClipsAndTacks > My KPI Context > Average
Order Fulfillment KPI August 2006

3) In the Data Filter section for this KPI, click Add
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4) In the dialog, navigate to ClipsAndTacks MC > Order Status, then click OK

5) In the row containing metric Order Status, make sure the operation defaults to 'equals'.
Also, click the cell in the column Values, then enter this text (with quotation marks):

'Shipped'

6) Press Ctrl-S to save your work.

Data Filter
Seleck the metrics that vou want ko use to determing what values bo use in the calculation, Far exanple, if vou have a KPI called Average Price in Londan,
wou only wank bo use monitoring contexts where the value of the City metric is Londaon,

[etric | Operator | Values | Case-sensitive |

A~ Order Status equals =$Y *Shipped

8. Create a KPI for number of approved orders greater than 90%. First you will create a KPI to count
the number of total orders. Then you will create a KPI to count the number of shipped orders.
Finally, you will create a KPI that calculates the approval percentage as this formula: (ship count /
order count) * 100.

___a. Click the KPI Model tab then create the order count KPI.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name — Order Count KPI
b) ID - Order_Count_KPI

2) Enter these values:
a) Type — Decimal
b) Select 'Keep track of historical values for this KPI'
c¢) Do not specify targets nor ranges
d) KPI Value — select 'Base this KPI on a metric and an aggregation function.'

e) Under KPI Details, for Monitoring context, click Browse..., then select
'ClipsAndTacks MC', then click OK

f) Metric — click Browse..., then select ClipsAndTacks Key, then click OK
g) Aggregation function — select Count.

3) Press Ctrl-S to save your work.

___b. Create the ship count KPI.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name — Ship Count KPI
b) ID - Ship_Count_KPI

2) Enter these values:
a) Type — Decimal

2009 February, 20 IBM WebSphere Business Monitor 6.2 — Lab exercise Page 21 of 56

ClipsAndTacks



© Copyright IBM Corporation 2009. All rights reserved

b) Select 'Keep track of historical values for this KPI'
¢) Do not specify targets nor ranges
d) KPI Value — select 'Base this KPIl on a metric and an aggregation function.'

e) Under KPI Details, for Monitoring context, click Browse..., then select
'ClipsAndTacks MC', then click OK

f) Metric — click Browse..., then select ClipsAndTacks Key, then click OK
g) Aggregation function — select Count.
h) In the Data Filter section for this KPI, click Add
i) In the dialog, navigate to ClipsAndTacks MC > Order Status, then click OK
j) In the row containing metric Order Status, make sure the operation defaults to
‘equals’. Also, click the cell in the column Values, then enter this text (with
guotation marks):
'Shipped’
3) Press Ctrl-S to save your work.
___c. Create the percent of orders approved KPI.
1) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name — Percent of Orders Approved KPI
b) ID - Percent_of Orders_Approved_KPI
2) Enter these values:
a) Type — Decimal
b) Select 'Keep track of historical values for this KPI'

c¢) In KPI Target and Ranges, for Target click Details..., then change the value to 90,
then click OK

d) In KPI Target and Ranges, for Ranges select Actual value
e) In the Range table,
(1) Click Add
(2) Change the Name to Low Range, and the ID to Low_Range
(3) Arow is created in the Range table with a range name Low Range.

(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change the value to 0, then click OK.

(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change the value to 90, then click OK.

f) Repeat the above step to create one more range:
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(1) High Range with start value 90 and end value 100

g) KPI Value — select 'Write an expression to calculate this KPI based on existing
KPIs'

h) For KPI Calculation, enter this text:

fn:round((Ship_Count_KPI div Order_Count_KPI) * 100)

3) Press Ctrl-S to save your work.

+ KPI Target and Ranges
Specify a target, which is an exact value For the KPI to achieve, or ranges against which to track the KPI, or bath,

Target: a0

Ranges: Ackual value

Range name | Start value | End walue
= Low Range 0 = a0
= High Range a0 < 100

w KPI Definition
Specify how the value of the KPT is set,

KPI ¥alue

Choose how the KPT will get its walue:
O Ease this KPI on a metric and an aggregation function,

(%) Wyrite an expression ko calculate this KPI based on existing KPIs

kPI Calculation
For example, yvou could hawve a Tokal Profit KPI that subtracks the Total Cost £PI From the Tokal Revenue KPI

Friround({Ship_Count_KPI div Order_Count_KPT) * 100)

_____ 9. Inthe dashboards, you might like to see the total order price, the average order price, and the total
number of orders. And you might be interested in seeing this information by country and city, and by
order status. So now you will create dimensions and measures that allow you to see this
information. For aggregated numeric information like total order price, you will create a measure in
the dimensional model. For textual attributes like order status, you will create a dimension in the
dimensional model. In order to see the country and city information, you will create a multi-level
location dimension containing country as the first level and city as the second level. Each measure
and dimension needs a metric as a source, so you will also need to create metrics for country, city
and total price.

__a. Click the Dimensional Model tab.
___b. Add order status as a dimension to the Dimensional Model.
1) In the navigation view, click ClipsAndTacks MC Cube

2) In the dimensions table, click New Dimension...
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a) Name — Order Status Dimension
b) ID — Order_Status_Dimension
c) Click OK
3) Click New Level...
a) Name — Order Status
b) ID — Order_Status

¢) Source metric — Click Browse..., then select ClipsAndTacks MC > Order Status.
Then click OK.

d) Click OK.

4) Press Ctrl-S to save your work.

+ Dimensions
wark with the dirensions and dimension levels of this cube, Dimensions are data categaries made up of hierarchical dinension levels,

Dimension [ Dimension Level Siource Metric

= !I Order Status Dimension
5" order Status [ Srder Skakus

___c. Click the Monitor Details Model tab.

___d. In the Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >
Metric. Enter these values:

1) Name — country
2) ID — country
3) Type — String

4) Select 'A value is required for this metric'. The editor requires that you select this whenever
you use a metric as a source for a dimension in the dimensional model.

5) For default value, enter an empty string (two single quotation marks)

6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

a) New_Order_Event/extendedData/OrderBOData/country
9) Click OK.

10) Press Ctrl-S to save your work
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___e. In the Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >
Metric. Enter these values:

1) Name — city
2) ID — city
3) Type — String

4) Select 'A value is required for this metric'. The editor requires that you select this whenever
you use a metric as a source for a dimension in the dimensional model.

5) For default value, enter an empty string (two single quotation marks)
6) For Metric Value Expressions, click Add

7) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

8) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

a) New_Order_Event/extendedData/OrderBOData/city
9) Click OK.
10) Press Ctrl-S to save your work

___f. In the Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >
Metric. Enter these values:

1) Name — totalPrice

2) ID — totalPrice

3) Type — Decimal

4) For Metric Value Expressions, click Add

5) In the first row of the Metric Value Expressions table, select the cell under column Trigger,
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC
> New Order Trigger, click OK

6) In the first row of the Metric Value Expressions table, select the cell under column
Expression, then a button is shown, then click the button and enter this text:

a) New_Order_Event/extendedData/OrderBOData/totalPrice
7) Click OK.
8) Press Ctrl-S to save your work
___@. Click the Dimensional Model tab.
___h. Add location as a dimension to the Dimensional Model.

1) In the navigation view, click ClipsAndTacks MC Cube
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2) In the dimensions table, click New Dimension...
a) Name — Location
b) ID — Location
c) Click OK
3) Click New Level...
a) Name — Country
b) ID — Country

¢) Source metric — Click Browse..., then select ClipsAndTacks MC > country. Then
click OK.

d) Click OK.

4) Click New Level...
a) Name — City
b) ID — City

¢) Source metric — Click Browse..., then select ClipsAndTacks MC > city. Then click
OK.

d) Click OK.

5) Press Ctrl-S to save your work.

+ Dimensions
Wark with the dimensions and dimension levels of this cube. Dimensions are data categories made up of hierarchical dimension levels,

Dimension [ Dimension Level Siource Metric
= !I Order Status Dimension
5" order Status [ Srder Skakus
B B Lacation
= 5 Country [ caunkry
—* . ' [
o City [ ciky

___i. Ensure that the Dimensional Model tab is selected.

___j- In the Dimensional Model, add a measure for average order price.

2009 February, 20

1) In the navigation view, click ClipsAndTacks MC Cube
2) In the Measures table, click New ...
a) Name — Average Order Price
b) ID — Average_Order_Price
¢) Source metric - Click Browse..., then select ClipsAndTacks MC > totalPrice.
d) Aggregation function — select Average.

e) Then click OK.
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3) Press Ctrl-S to save your work.

* Measures
Work with the measures For this cube, Measures are calculations based on a metric, key, counter, or stopwatch,

Measure | Source Mekric | Aggregation Funckion |
[ Average Order Price [ kotalPrice Average

___k. Inthe Dimensional Model, add a measure for sum of order price.
1) In the navigation view, click ClipsAndTacks MC Cube
2) In the Measures table, click New ...
a) Name — Sum Order Price
b) ID — Sum_Order_Price
c) Source metric - Click Browse..., then select ClipsAndTacks MC > totalPrice.
d) Aggregation function — select Sum.
e) Then click OK.
3) Press Ctrl-S to save your work.
___I. Inthe Dimensional Model, add a measure for order count.
1) In the navigation view, click ClipsAndTacks MC Cube
2) In the Measures table, click New ...
a) Name — Order Count
b) ID — Order_Count

¢) Source metric - Click Browse..., then select ClipsAndTacks MC > ClipsAndTacks
Key.

d) Aggregation function — select Count.
e) Then click OK.

3) Press Ctrl-S to save your work.

 Measures
WWork with the measures for this cube, Measures are caloulations based on a metric, key, counter, or stopratch,

Measure | Source Mektric | Aggregation Function |
[ Average Order Price [ tatalPrice Average

[ 3um Crder Price i totalPrice 3um

[ Order Counk = ClipsandTacks Key Count

10. Inthe dashboards you might like to see the average order price and track that relative to a target.
___a. Create a KPI for the average order price.
1) Click the KPI Model tab.

2) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
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a) Name — Average Order Price KPI (Dollars)

b) ID - Average_Order_Price_KPIl__x0028_Dollars_x0029
3) Enter these values:

a) Type — Decimal

b) Select 'Keep track of historical values for this KPI'

¢) In KPI Target and Ranges, for Target click Details..., then change the value to 300,
then click OK

d) In KPI Target and Ranges, for Ranges select Actual value
e) In the Range table,
(1) Click Add
(2) Change the Name to Low Range, and the ID to Low_Range
(3) A row is created in the Range table with a range name Low Range.
(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change the value to 0, and then click
OK.
(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change the value to 300, and then click
OK.

f) Now you have created one range called Low Range. Repeat the above step to
create one more range:

(1) High Range with start value 300 and end value 1000
g) KPI Value — select 'Base this KPIl on a metric and an aggregation function.'

h) Under KPI Details, for Monitoring context, click Browse..., then select
'ClipsAndTacks MC', then click OK

i) Metric — click Browse..., then select totalPrice, then click OK
j) Aggregation function — select Average.

4) Press Ctrl-S to save your work.
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+ KPI Target and Ranges
Specify a target, which is an exact value for the KPI ko achieve, or ranges against which ta track the KPI, or bath,

Tarqget: 300

Ranges: Actual value

Range name | Skark walue | End value
= Low Range i] < 300
= High Range 300 = 1000

= KPI Definition
Specify how the value of the KPT is set,

KPI ¥alue

Choose how the £PT will get its walue:
{®) Base this KPI on a metric and an aggregation Function,

O Write an expression to caloulate this KPT based on existing KPIs

KPI Details

Monitoring contexts 4 ClipsandTacks MC

Metric: 4 bokalPrice

Aggregation funckion: *l Ayverage

IJse values From: ® all madel versions ) Only this version of the maodel

____11. (Optional) To demonstrate the use of a counter, you can optionally use this section to create a
counter which will be incremented if you ship the order (versus canceling the order). For every
monitoring context, this counter will either be zero or one depending on whether the order is
cancelled or shipped. Counters would be more useful in other scenarios — perhaps to count the
number of times an iterated activity is executed.

__a. Inthe Monitor Details Model navigation view, right click ClipsAndTacks MC, then select New >
Counter. Enter these values:

1) Name — Ship Counter
2) ID — Ship_Counter

3) For Counter Controls, click Add, then select ClipsAndTacks MC > Ship Order to Customer
Trigger, click OK

4) Note that the Resulting Action defaults to Add One, which is correct.

___b. Press Ctrl-S to save your work
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+ Counter Details
Edit the details of the counter, which counts the number of occurrences of some situation or event,

I + Ship_Counter
Marme: Ship Counter
Description:

[ This counter can be used for sorting

+ Counter Controls
Specify what causes the counter to change and what action is taken,

Trigger { Inbound Event | Resulking Action
?i‘=:4>5hi|:| Order ko Customer Trigger Add One

12. (Optional) ) To demonstrate the use of a stopwatch, you can optionally use this section to create a
timer which will measure the duration of the monitoring context. You might find this useful in the
dashboard instances view to quickly see which monitoring contexts have not been terminated.

__a. Inthe model navigation view, right click ClipsAndTacks MC, then select New > Stopwatch.
Enter these values:

1) Name — Monitoring Context Timer
2) ID — Monitoring_Context_Timer

3) For Stopwatch Controls, click Add, then select ClipsAndTacks MC > New Order Trigger,
then click OK.

4) Note that the default Resulting Action is Start

5) For Stopwatch Controls, click Add, then select ClipsAndTacks MC > Ship Order to
Customer Trigger, then click OK.

6) Note that the default Resulting Action is Start, but you need to change it to Stop for this
trigger. So click the second row in column Resulting Action. A drop down box is shown, so
pick Stop in the list.

7) For Stopwatch Controls, click Add, then select ClipsAndTacks MC > Cancel Trigger, then
click OK.

8) Note that the default Resulting Action is Start, but you need to change it to Stop for this
trigger. So click the second row in column Resulting Action. A drop down box is shown, so
pick Stop in the list.

__b. Press Ctrl-S to save your work.
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w Stopwatch Details

Edit: the details of the stopwatch, which keeps track of elapsed time, IF an accumualating stopwatch is given bwo or more skart and stop bimes, the durations are
added together to produce an accumulated time,

10 | Monitaring_Conkext_Timer

Marne: Monitaring Conbext Timer

Descripkion: ;I

O This stopwatch is an accumulating stopwatch

[ This stopwatch can be used For sorting

+ Stopwatch Controls
Specify what causes the stopwatch to change and what action is baken.

Trigget [ Inbound Event | Resulting Action I
3% Mews Order Trigger Start
§€=:DShip Order to Cuskomer Trigger Stop
3% Cancel Trigger Stop

____13. Create a business situation event when the number of declined orders is greater than or equal to 3.
First you will create an event definition for the outbound situation event. You will create a field called
BusinessSituationName which is a required field for the outbound situation event. You will create a
KPI that will track the total number of declined orders. Then you will create a trigger which is fired
when the number of declined orders is greater than or equal to 3. Then you will define an outbound
event which is fired by the trigger. In this outbound event, you will provide a value for the field
BusinessSituationName which will be used later when configuring action manager in the server
administrative console.

___a. Create an event definition for declined orders.
1) In Project Explorer, right click ClipsAndTacks and select New > Event Definition...(cbe)
2) For file name, enter DeclinedOrderEvent.cbe
3) Click Finish
4) The Event Definition Editor for DeclinedOrderEvent opens.
5) Double click the hierarchical icon next to the label Parent.
6) On the Select Event Definition Dialog double click event under Matching events.

7) Event is now shown as the parent of DeclinedOrderEvent

8) On the event definition, click the icon for Add Extended Data . This adds a row to the
Extended Data table.

9) For the new data element, change the Extended Data name from 'datal’ to
'‘BusinessSituationName' by clicking on datal and typing the new name.

10) For the new element, change the type to string. Do this by clicking on 'noValue' and then
you are given a drop down box.
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11) Press Ctrl-S to save your work.

Marne® DeclinedCrderEvent
Parent® event
Property
Extended Data Twpe
BusinessSituationkame skring

___b. Create a KPI for declined orders.

1) Click the KPI Model tab for the ClipsAndTacks model.

2) In the navigation view of the KPI Model, right click My KPI Context, then select New > KPI
a) Name — Declined Order KPI
b) ID - Declined_Order_KPI

3) Enter these values:
a) Type — Decimal
b) Select 'Keep track of historical values for this KPI'

c¢) In KPI Target and Ranges, for Target click Details..., then change the value to 3,
then click OK

d) In KPI Target and Ranges, for Ranges select Actual value
e) In the Range table,
(1) Click Add
(2) Change the Name to Low Range, and the ID to Low_Range
(3) Arow is created in the Range table with a range name Low Range.
(4) For this row, select the cell in the Start value column and a button is
displayed. Click this button, then change the value to 0, and then click
OK.
(5) For this row, select the cell in the End value column and a button is
displayed. Click this button, then change the value to 3, and then click

OK.

f) Now you have created one range called Low Range. Repeat the above step to
create one more range:

(1) High Range with start value 3 and end value 10
0) KPI Value — select 'Base this KPI on a metric and an aggregation function.'

h) Under KPI Details, for Monitoring context, click Browse..., then select
'ClipsAndTacks MC', then click OK

i) Metric — click Browse..., then select 'ClipsAndTacks Key', then click OK
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j) Aggregation function — select Count.

k) In the Data Filter section for this KPI, click Add
) In the dialog, navigate to ClipsAndTacks MC > Order Status, then click OK

m) In the row containing metric Order Status, make sure the operation defaults to

‘equals’. Also, click the cell in the column Values, then enter this text (with
guotation marks):

'‘Cancelled'

4) Press Ctrl-S to save your work.

« KPI Definition
Specify how the value of the £PLis set,

KPI Yalue
hoose how the KPT will get its value:
(%) Base this KPI on a metric and an aggregation Funckion,
O Wirite an expression ko calculate this KPT based on existing KPIs

KPI Details

Monitoring context: . ClipsandTacks MC

IMekric: « ClipsandTacks Key

Aggregation Function: *|C0unt

Use walues from: @ all model versions € Only this wersion of the model

Time Filter

Select a time period over which the £PI should be calculated,

-

Tirme period:

@ Mone O Repeating O Roling O Fixed

Data Filter

Select the metrics that wou want to use ko determing what values ko use in the calculation, Far example, if vou have a KPI called Average Price in Londan,
wou only wank to use monitoring conkexts where the value of the Ciky metric is London,
Mekric | Operakor | Values

| Case-sensitive |
A Order Skatus equals ;%Y ‘Cancelled'

__c. Create a trigger to fire the outbound situation event.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New >
Trigger

a) Name — Declined Order Trigger
b) ID - Declined_Order_Trigger

2) Enter these values:
a) Under Trigger Sources, click Add.

b) Select Recurring wait time, then click OK
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¢) In the Source column you see the default wait time is 1 minute.
d) In Trigger Condition, enter this text:
Declined_Order_KPI >=3

3) Press Ctrl-S to save your work.

+ Trigger Details
Edit the details of the trigger, which detects an occurrence and initiakes an action in response,

(s} « Declined_order_Trigger
Marne; Declined Order Trigger
Description:

O Trigger is repeatable

+ Trigger Sources
Specify the source of this trigger,

Source Type | Source
Recurring wait tine L) 0 davs 0 hours 1 minukes

w Trigger Condition
Specify the condition that determines whether the trigger will fire,

Declined_Order_KPI =3

___d. Create an outbound situation event for declined orders.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New >
Outbound Event

a) Name — Declined Order Outbound Event
b) ID - Declined_Order_Outbound_Event
c¢) Select 'Configure this event to generate an alert in the dashboards'

d) For trigger, click Browse..., then select My KPI Context > Declined Order Trigger,
then click OK

2) Enter these values:
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a) For extension name, click Browse..., then select ClipsAndTacks >
DeclinedOrderEvent.cbe > DeclinedOrderEvent, then click OK

b) Under Event Attributes Details, click Add
c) Select My KPI Context > Declined Order Trigger, then click OK

d) In the table, expand Extended Data, then on the same row as
BusinessSituationName, set Expression to (include the quotation marks):

"Too many orders have been declined'

3) Press Ctrl-S to save your work.

* Outhound Event Details
Edit the details of the outbound event, which is sent by the monitoring context. The type must be an event definition,

10: 4 Declined_Order_Outbound_Event

MName: Declined Order Sutbound Event

Descripkion:

s o

w Event Type Details
Specify the event type or the XML schemas that together describe the structure of this outbound ewvent, You can specify an extension name, event parts, or

bath,
Extension name: | DedinedOrderEvent
Event parts: 1D | Marne | Type I Path I

= Event Attributes Details
Specify the triggers that cause the event bo be sent, Use the Expression column to specify the walue for each event attribute when the event is sent,

Mame Type Expression
B = Declined Order Trigger

= Property Data
H = Etended Daka
= BusinessSituationharne A string

Gl

Too mary orders have been declined

_____14. Create a business situation event when the order fulfillment duration is greater than 3 days. First
you will create an event definition for the outbound situation event. You will create a field called
BusinessSituationName which is a required field for the outbound situation event, and you will
create another field for the average order processing time which will eventually be placed into the
alert body. You do not need to create a KPI since there is already a KPI containing the average
processing time. You will create a trigger which is fired when the average processing time is greater
than 3 days. Then you will define an outbound event which is fired by the trigger. In this outbound
event, you will provide a value for the field BusinessSituationName which will be used later when
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configuring action manager in the server administrative console, and you will populate the field on
the event containing the average order processing time.

___a. Create an event definition for average order processing time.
1) In Project Explorer, right click ClipsAndTacks and select New > Event Definition...(cbe)
2) For file name, enter LateAverageOrderShippedEvent.cbe
3) Click Finish
4) The Event Definition Editor for LateAverageOrderShippedEvent opens.
5) Double click the hierarchical icon next to the label Parent.
6) On the Select Event Definition Dialog double click event.

7) Event is now shown as the parent of LateAverageOrderShippedEvent

8) On the event definition, click the icon for Add Extended Data + This adds a row to the
Extended Data table.

9) For the new data element, change the Extended Data name from 'datal’ to
'‘BusinessSituationName' by clicking on datal and typing the new name.

10) For the new element, change the type to string. Do this by clicking on 'noValue' and then
you are given a drop down box.

11) On the event definition, click the icon for Add Extended Data. This adds a second row to
the Extended Data table.

12) For the second data element, change the Extended Data name to
AverageOrderProcessingTime

13) For the second element, change the type to string.

14) Press Ctrl-S to save your work.

Tame® LatedverageCrdershippedEvent
Parent* event
Property
Extended Data Type
BusinessSituationMarne skring
AverageCrderProcessingTime skring

___b. Create a trigger to fire the outbound situation event.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New >
Trigger

a) Name — Order Fulfillment Timer Trigger
b) ID - Order_Fulfillment_Timer_Trigger

2) Enter these values:
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a) Under Trigger Sources, click Add.

b) Select Recurring wait time, then click OK

¢) In the Source column you see the default wait time is one minute.
d) In Trigger Condition, enter this text:

Average_Order_Fulfillment_KPI_August_2006 ge dayTimeDuration
('P3DT1HY)

3) Press Ctrl-S to save your work.

+ Trigger Details
Edit: the details of the trigger, which detects an occurrence and initiabes an ackion in response,

(o} « Order_Fulfillment_Timer_Trigger
Tame: Order Fulfillment Timer Trigger
Descripkion:

O Trigger is repeatable

= Trigger Sources
Specify the source of this trigger.

Source Type | Source
Recurring vaaik time it 0 davs 0 hours 1 minukes

+ Trigger Condition
Specify the condition that determines whether the trigger will Fire,

Average_Crder _Fulfilment _tPI_August_2006 ge dayTimeDurationPS0T1HY

___c. Create an outbound situation event for average order processing time.

1) In the navigation view of the KPI Model, right click My KPI Context, then select New >
Outbound Event

a) Name — Order Fulfillment Outbound Event
b) ID - Order_Fulfillment_Outbound_Event
c¢) Select 'Configure this event to generate an alert in the dashboards'

d) For trigger, click Browse..., then select My KPI Context > Order Fulfillment Timer
Trigger, then click OK
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2) Enter these values:

a) For extension name, click Browse..., then select ClipsAndTacks >
LateAverageOrderShippedEvent.cbe > LateAverageOrderShippedEvent, then click
OK

b) Under Event Attributes Details, click Add
c) Select My KPI Context > Order Fulfillment Timer Trigger, then click OK

d) In the table, expand Extended Data, then on the same row as
BusinessSituationName, set Expression to (include the quotation marks):

'Average shipment is too late'

e) In the table, expand Extended Data, then on the same row as
AverageOrderProcessingTime, set Expression to:

xs:string(xs:decimal(Average_Order_Fulfillment_KPI_August_2006) div 86400)

Note: Here the decimal function converts the duration to seconds, so then it can be divided by 86400
which will give you the number of days.

3) Press Ctrl-S to save your work.
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w Dutbound Event Details

Edit the details of the outhound event, which is sent by the monitaring conkesxt, The bvpe must be an event definition,

(s} « Crder _Fulfillment_outbound_Ewent
Marme: Order Fulfillnent Outbound Event
Description:

+ Event Type Details

Specify the event bvpe or the XML schemas that kogether describe the skructure of this outbound event, You can specify an extension name, event parts, ar
bokh,

Extension name: | LatedweragedrdershippedEwvent

Event parts: bs) | Mame | Tvpe | Path |

w Event Attributes Details
Specify the triggers that cause the event to be sent, Use the Expression column ko specify the value For each event attribuke when the event is sent,

Mame Type Expression

s+ Fulfillment Timer Trigger

= Property Data
=] lE Extended Data
[ BusinesssituationMame A string ﬁv ‘Average shipment is koo late'
= AverageOrderProcessingTime A string >§+-3Y string{decimal{average_Crder _Fulfillment_KPI_August_2006) div 86400}

15. Check for any errors in the Problems view. You should resolve any errors before continuing.
Warnings and informational messages may be present but these will not be a problem.
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Part 2: Publish the model to the server

In this section you will use Rational Application Developer or WebSphere Integration Developer to publish
the monitor model to the monitor server.

1. In Project Explorer, expand ClipsAndTacks - Monitor models - ClipsAndTacks.mm. Right
click over ClipsAndTacks.mm and then select Generate Monitor J2EE Projects from the pop-up
menu

2. Select Finish.

3. A progress dialog shows the status of the operation and it closes when the operation is complete.
Check for errors in the Problems view. There may be warnings, but there should not be any errors. If
you see errors, then try to perform a clean to see if the errors can be removed: Project > Clean... >
select 'Clean all projects’, then click OK.

4. Click the Servers tab, then right click and select the Start option to start the server WebSphere
Business Monitor v6.2. This may take a few minutes to complete.

|§.': Monitoring Flow (: Properties ﬂg_ Problems (43?4: Servers El Cnnsole} Fﬁ: Bsset Repnsitories}
Server = State Skatus
o we = U E Started Synchronized
B ‘WebSphere Process Server w62 at localhost F@ Stopped

5. Right click in the servers view, then select Add and Remove Projects....

6. Click Add to move the ClipsAndTacksApplication from the list of available projects to the list of
configured projects.
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4+ Add and Remove Projects ﬂ

Add and Remove Projects "

Modify the projects that are configured on the server

Mowe projects to the right to configure them on the server

Available projects: Configured projects:

fidd| = |
= Remove |

I8 ClipsandTacksapplication

Add All =5 |
<< Remove All |

(7) < Back Mext = | Finish I Cancel

7. Click Finish.
8. A progress message is displayed in the lower right corner of the window.
|

| Publisting to websph......: (14%) W &

9. Check the messages in the console view. You should see the following message when the
application has been started:

Application started: ClipsAndTacksApplication

10. In the servers view, right click, then select Administration > Run administrative console. You
should see it open in a separate tab.

11. It will prompt you for user ID and password. Enter 'admin’ without the quotation marks for user ID,
then enter 'admin' without the quotation marks for password. Click Log in

12. Click Applications > Monitor Models. The application should show green status if it started
successfully.

2009 February, 20 IBM WebSphere Business Monitor 6.2 — Lab exercise Page 41 of 56

ClipsAndTacks



Integrated Solutions Console

| Viev: IAII tasks

elcome
Guided Activities
Servers

B applications

Enterprise Applications

Install Mew application
SCA madules

owement Service

ata

Manitor Action Services
Rezources
Security
Enviranment
Integration Applications
System administration

Users and Groups
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W -
Welcome admin el Legaut - z:zﬁ

Cloze page

Monitor Models wE

Monitor Models

Use this page to manage all versions of monitar models and their associated applications. To start or stop a
version of a monitor rmodel, you rmust start or stop the associated application. All models are initially added to the
root resource group and may not be visible by its intended dashboard users, Use the Monitor data security panel to
assign permisszion to the models,

Preferences

Start| Stop| Install Update
| |4
FllclE
Select| Model & Wrarsiamn Ceployrnent & | Application Status ()
O ClipsandTacks Z2007-03- OK ClipsandTacksApplication 3
11T12:07:30
l- GlobalHTMM 2007-06&- (=] 4 IBM WEM HUMAN TASK MOMNITOR MODEL | S
18T0>:54:38
Total 2

13. If the model shows red (stopped), then wait a moment, then refresh by clicking on the icon to the

right of Status in the last column of the table. You should see green (started) for the model. If it does
not show green, be patient and keep refreshing until it does show green.

14. Check the server log to ensure there are no problems. You can check this in the console view.

15. If you are using the integrated server within WebSphere Integration Developer or Rational

Application Developer, then you do not need to setup Monitor data security, since the administrative
user is automatically authorized to all models. If you are using a different server, then you should
open the administrative console, navigate to Security > Monitor Data Security, then add the
model, role and user information to a resource group.
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Part 3: Configure action manager for business situation events

This section shows you how to configure action manager to create alerts based on business situation
events defined in the monitor model. The alerts will be visible in the Alert view on your dashboard.

You do not need an LDAP server to test the situation events. When you configure the notification template,
you can specify a dashboard login rather than a user registry.

In this section, you will use the administrative console to configure the alerts. However, you could also
create business user alerts using the Alert Manager widget in the dashboard. In a production environment,

an end user could use the alert manager widget to manage the business user alerts, however, an IT
administrator would manage the modeled alerts in the administrative console.

1. Add atemplate for declined order alerts.

___a. Inthe administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Template Definitions > Notifications.

___b. Click New.

___c. Enter AlertDeclined as Template name and a description.
___d. Select Dashboard Alert.

___e. Select User id.

__f. For the To field, enter admin. This user ID is the one that will receive the alert, so you must log
into the dashboard with this user ID.

__ 0. Enter a subject.

___h. Enter the body.
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* Template name
|AIertDecIined

Dezcription

Default action service type
% Dashboard Alert
 call phane

" Ernail

@ Pager

"To' query type

" Federated repositaries query
@ LCAP query

" Email address

* Userid

To
|admin

Query base

Subject
|Dec|ined arders

Body

Too rmany orders have been l:'
declined.

=

__i. Click OK.
2. Add a template for order processing time alerts.

___a. In the administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Template Definitions > Notifications.

___b. Click New.

___c. Enter AlertLate as Template name and a description.
___d. Select Dashboard Alert.

___e. Select User id.

___f. For the To field, enter admin. This user ID is the one that will receive the alert, so you must log
into the dashboard with this user ID.

___g. Enter a subject.

__h. Enter the body, and you can optionally enter a substitution variable as shown below. For the
actual alert that is sent, the average order processing time from the event payload will be
substituted for %0AverageOrderProcessingTime% in the body. For example:

The average order processing time is %AverageOrderProcessingTime% days.
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# Termplate name
[arertate

Description

Default action service type

¥ Dashboard Alert
 call phore

" Ermnail

@ Pager

"To' query type

" Federated repositories query
@ LDAP query

" Ernail address

& Uzerid

To
|admin

Query base

Subject
|Order processing time

Body

The average order processing l:‘
tirme is %
AveragelrderProcessingTime %
days.|

=
__i. Click OK.
3. Add the binding from the situation event to the action type for declined orders.

__a. Inthe administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Installed Situation Event Bindings.

___b. Click New.

__c. Enter the situation event name that you defined in the model. In this lab, you created a business
situation name as follows:

Too many orders have been declined
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Mew Situation Event Binding

General Propertes

# Situation event name
|1~,l orders have been declined

Dezcriptian
Dedined| arders |:|

=

___d. This must match exactly the value in the BusinessSituationName field in the outbound event.
You might want to copy and paste from the model. Here is a screen capture from the model
showing the Declined Order Outbound Event attributes:

+ Event Attributes Details

Specify the triggers that cause the event to be sent, Use the Expression column ko specify the value For each event
attribute when the event is sent.

Tarme Type Expression

B = Declined Crder Trigger
L:T_:. Property Data
= & Extended Data
= BusinessSituationMame A string =5 'Too many orders have been declined'

X

___e. Enter a description, then click Apply.
__f. Click Add.

___g. Enter a binding name, then select the template AlertDeclined.

Add ternplate to situation event binding

General Properties

* Binding name
|Declined

Crescription

Category

Termplate name

IAIertDecIined 'I
__h. Click OK.

___i. Notice that you now have one action defined for this situation event. If you had other action
templates defined then you could add more actions to this event. So then you could send a
notification for this situation to multiple destinations including e-mail, alerts, and Web services.
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Mew Situstion Event Binding

General Properties

# Situation event name

|T00 rmany orders have been

Dezcriptian
Declined arders |:|

=

Appll,ll ﬂ Reset Cancell

Preferences

Add Rermoave
B (0 e

Select| Binding Mame 2 Category Mame Template Mame Action Service Type [

r Ceclined AlertDedined AlertHandler

Total 1

__j. Click OK.

4. Add the binding from the situation event to the action type for order processing time.

___a. Inthe administrative console, navigate to Applications > Monitor Services > Monitor Action
Services > Installed Situation Event Bindings.

___b. Click New.

__c. Enter the situation event name that you defined in the model. In this lab, you created a business
situation name as follows:

Average shipment is too late

___d.. This must match exactly the value in the BusinessSituationName field in the outbound event.
You may want to copy and paste from the model

__e. Enter a description, then click Apply.
__f. Click Add.

___g. Enter a binding name, then select the template AlertLate, then click OK.

__h. Click OK.

5. In the administrative console, navigate to Applications > Monitor Action Services > Installed
Situation Event Bindings. You should see two bindings as follows:
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Installed Situation Event Bindings

Installed Situation Event Bindings

Situation event bindings that are already installed.

Preferences

)

Select| Situation Event Marne [ Situation Event Description
- Average shiprment is too |ate Taoao late

- Too rmany orders have been dedined Decined orders

Taotal 2
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Part 4: Run events to exercise the model

Rather than installing a J2EE application to actually create the events that you want to monitor, you are going
to use a program to simulate the submission of events from the application.

The supplied program is '‘BatchCBEWTriter61' and it will submit the events to the Common Event Infrastructure.
Look for the program in \Labfiles62\ClipsAndTacks\BatchCBEW iter. This program reads XML files which
represent the Common Base Events for the model.

1. Update BatchCBEWTriter61.bat to point WAS_HOME to the monitor server home, for example 'set
WAS_HOME=C:\IBM\WebSphere\AppServer'. If you are using the integrated monitor server in
WebSphere Integration Developer, the path would be <WID-Install-Path>\pA\WBMonSrv_wps. If you
are using the integrated monitor server in Rational Application Developer, the path would be <RAD-
Install-Path>\pfAWBMonSrv.

2. Update config.properties, setting the serverName and portNumber. You can find the port number by
browsing the server log and finding 'bootstrap port'. For example, check for the log at
C:AIBM\WebSphere\AppServer\profiles\WBMon01\logs\serverl\SystemOut.log . For the integrated
server in WebSphere Integration Developer, the path would be <WID-Install-
Path>\pA\WBMonSrv_wps\logs\server1\SystemOut.log and the portNumber should be 2810. For the
integrated server in Rational Application Developer, the path would be <RAD-Install-
Path>\p\WBMonSrwlogs\server1\SystemOut.log and the portNumber should be 2810. Here is an
example of the config.properties settings:

__a.connect.serverName = localhost
___b. connect._portNumber = 2810
3. Open a command window, then change directory to the folder containing BatchCBEWTriter61, for
example, type this command
__a. cd \Labfiles62\ClipsAndTacks\BatchCBEWTriter
4. Run commands to load the common base events to the server.
___a. batchcbewriter61 -Dsource.filename="c:/Labfiles62/clipsandtacks/cbe/allevents.xml"
___b. When it prompts you for user identity and password, enter ‘admin’ for both (without the quotation
marks)

5. When you run BatchCBEWTriter61, you should see results such as:
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C:swdriverssevents*batchchewritertl —Dzource.filename=""c:- drivers-events-clipsand

tacksrsallevents.xml"

Removing Glohallnstancelds.
Setting missing values.
hanging Instance Ids.
pdating timestamp

s

chel181]1.
chelZ8]1.
chel381]1.
chel481.
chel581.
chel6B]1.
chel781]1.
g chel8A1.
:14:24.398
otalTime=13515 milliseconds.
BEs/second=6.215316315285327
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Part 5: Create a dashboard in business space

In this section you will build a dashboard in business space. You will add widgets to the dashboard and
configure them.

1. Create the dashboard.
___a. The default browser is 'Internal Web Browser', but you should not use this one since some
standard functions are not provided that you may need. Select Window > Preferences > General
> Web browser > select 'Use external Web browser'. Select an external browser. Click OK.

__b. InWebSphere Integration Developer, in the servers view, right click and select Business Space

___¢. When prompted, enter admin for the user ID and enter admin for the password. You must log in
with 'admin’ so that you can view the alerts which were setup in action manager to be sent to this
particular user ID. Also, in the toolkit environment, this is the user that is automatically defined on
the secured server.

___d. Click the icon to create a new space.

a= Your Business Space

% L0 Groupby | Busiress Space - || Search

Better Lender Space | Owned by admin admin | Pages: 6
o The Getting Started module of IB WebSphere Business Monitor W62 uses Better Lendarzpace
widgets. By following the instructions described in Get..

» J@ Welcome | Dwned by System Administrater | Pages: 1
|_' Faorlearning about Business Space

___e. Enter a name such as Dashboard, select Empty, then click OK.

___f. Click the icon to create a new page in the Dashboard space.

a= Your Business Space

B %u T Bl oroup by | Busiress Space || Sesrch

Better Lender Space | Owned by admin admin | Pages: &
= The Fetting Started module of IBMW WebSphere Business Monitor V5.2 uses Better Lenderspace
widgets, By following the instructions deseribed in Get...

4

bt I;' Dashboard | Dwned by admin admin | Pages: 0

» @ Welcome | Dwned by System Administrator | Fages: 1
Faorlzarning about Buziness Space

___g. Enter a name such as Pagel, select Empty, then click OK.

___h. Click Pagel to open it.

s I;' Dashboard | Dwned by admin admin | Pages: 1

| P%ﬁe1 | Cwwned by admin admin
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___i. Now you can add widgets to the page by clicking on 'Add widgets' in the upper right corner

g Add YWidgets - . .
o _— , then dragging a widget to the page. If you want to rename the page, change the

layout or remove the page from display, use the icons to the right of the page name on the tab
Page1l = X . . . \ . .
. To return to the business space list, click '"Manage Business Spaces' in the upper

right corner
2. Add the instances widget to see monitored instances.
___a. Click Add widgets, then select Instances and drag it to the page.

___b. Click Configure on the widget menu.

=0

1) To Access the menu, hover the mouse over the right corner of the widget {n} and
then click the down arrow. On this menu you can configure the widget, refresh the widget
and delete the widget.

3¢ Delete
() Help

___c. Click the Show/Hide tab, and select monitoring context 'ClipsAndTacks MC'.
—FClipsAndTacks(Across all versions)

Click button >> to move all the fields to the Selected box. Also,
click button 'Set as default' which will make this the default monitoring context to display.

___d. Then click OK. You should see a list of monitoring context instances for the events that you just

processed.

Instances

city ClipsAndTacks Key COMPLETED country CreationTime Monitoring Context Timer Order End Time Order Fulfilliment Duration Order Start Time Order Status Sh

Raleigh o1 * UgA January g, 2009 05 August 9, 2006 2d,0h 0m,0s August 7, 2006 Shipped 1
1:44:41 PM 3:20:05 AM 3:20:05 AM

Taronto 02 * Canada January 5, 2008 0= August11, 2006 4d 0h0m0s August 7, 2006 Shipped 1
1:44:41 PW 4:14:55 AW 4:14:55 AW

Mexico 03 hiexico January 5, 2008 17 m, 24 s Os August 7, 2006 I ey 1]

City 1:44:41 PW A:01:22 AW

Raleigh 04 UsA Jaruarg s, 2008 17 m, 24 & 0s August 10, 2006 Mew i
1:44:41 PM B:01:34 A

Taronta 05 Canada  Januargs, 2008 17 m, 24 5 0s August12, 2006 New i
1:44:41 PM TA2:22 AM

Raleigh of * USA January s, 2008 0= August 26, 2006 4d 0h0m0s August 22, 2006 Cancelled 1]
1:44:41 PM 3:20:05 AM 3:20:05 AM

Taronto o7 * Canada January 5, 2008 0= August 37, 2006 Ad 0h 0m,0s August 22, 2006 Cancelled 1]
1:44:41 PW 4:14:55 AW 4:14:55 AW

Mexico of hiexico January 5, 2008 17 m, 24 s Os August 22, 2006 I ey 1]

City 1:44:41 PW A:01:22 AW

Raleigh 08 UsA Januarg s, 2008 17 m, 24 & 0s August 22, 2006 Mew i
1:44:41 PM B:01:34 A

Toronto 010 Canada January 5, 2009 17 m, 24 5 0s August 22, 2008 RE 1}
1:44:41 PM TA2:22 AW

4 i

1-10 20 bk

___e. There are two pages of results, so if you browse through these instances, you see that there are
four cancelled orders. Since you setup an alert if declined orders is greater than or equal to
three, then an alert should be displayed in the alert view.
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___f. Add the alerts widget to see business alerts.

1) Click Add widgets, then select Alerts and drag it to the page. The alerts view is added to
your dashboard, and you should see alerts listed since the model processed three or more
cancelled orders, and the average order processing time is greater than three days.

Alerts
| Mark Read | | Wark Unread | | Forward Alert | | Remuove |
= Subject Date and Time
e Order processing time Januarg 5, 2009 2:45:20 P
e Declined orders January 5, 2009 2:49:20 P
1-2 2
2) You can click an alert in the list, then you will get a pop-up showing the details of the alert.
= Subject Date ar
=

& Order processing time Januar,
. Declimr anuan
January 5, 2009 2:49:20 PM
Subject

Order processing time
Business situation name

Average shipment is too late
Comments

The awverage order processing time i=s 3.750 davys.

Close
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What you did in this exercise

In the lab, you created a monitor model using Rational Application Developer or WebSphere Integration
Developer.

Then you published the model to the monitor server.
You also configured action manager to create alerts based on business situation events.
You used the supplied program to simulate the submission of events from the monitored application.

You configured dashboards and viewed monitored data in several different types of views.
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Appendix 1 — Import the solution into the monitor model editor

A solution has been provided so that you do not have to build the model from scratch. This section shows
you how to import the monitor model into Rational Application Developer or WebSphere Integration
Developer. After importing the model then you can proceed to the section to publish the model to the
server.

1. Start Rational Application Developer or WebSphere Integration Developer and setup the
environment.

___a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted
point to a new workspace such as c:\workspaces\ClipsAndTacks

___b. Close the Welcome tab.

__C. You want to open the Business Monitoring perspective. Select Window > Open Perspective >
Business Monitoring.

___d. Ifit asks you to Confirm Enablement, then click OK.
2. Create a new monitoring project.
___a. Right click the Project Explorer, then select New > Business Monitoring Project...
___b. For Project name, enter ClipsAndTacks
___c. Click Finish. You will see the new project in the Project Explorer view.
3. Import the supplied mm and cbe files.
___a. Right click in the Project Explorer view, and then select Import...
__b. Select General > File system, click Next.
__c. Browse to the location containing the files, for example, c:\Labfiles62\ClipsAndTacks
__d. Select ActivityEvent.cbe
___e. Select ClipsAndTacks.mm
__f. Select DeclinedOrderEvent.cbe
___g. Select LateAverageOrderShippedEvent.cbe
__h. Select NewOrderEvent.cbe
__i. Click Finish.
4. Expand the project in the Project Explorer view, then expand the Event Definitions and you will see

the new events listed. Expand Monitor Models and you will see the new ClipsAndTacks model
listed.

5.  Now you can proceed to the section to publish the model to the server.
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