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IBM WebSphere® 6.0.2 — Lab Exercise

Business objects and Service Component Architecture
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What this exercise is about

The objective of this lab is to provide you with an understanding how to use WebSphere Integration
Developer V6.0.2 tools to build an SCA based application that uses business objects.

Lab requirements
List of system and software required for the student to complete the lab.
* WebSphere Integration Developer V6.0.2 installed

 WebSphere Process Server V6 test environment installed

What you should be able to do
At the end of this lab you should be able to:
» Create a business integration library

e Create and build a business integration module
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» Create a business object using WebSphere Integration Developer V6.0.2
» Define a component interface that uses a business object
» Define a service export component

» Define a service import component

Introduction

One of the primary objectives of the business object framework is to provide a data abstraction for the
service component architecture (SCA). In this exercise you will define 2 business objects for a simple
SCA-based financial application. The primary service in this application is a Portfolio service that includes
an operation for determining the portfolio value for a particular customer. The top-level business object in
this application is the Customer business object. Each customer has a firstName, lastName, customerID,
and an array of stocks. All properties defined on the Customer business object are strings, with the
exception of the array of stocks which is a collection of Stock business objects. The Stock business object
consists of 2 properties, numberOfShares and symbol.

In addition to providing an introduction to basic business object usage with the SCA architecture, this
exercise will also demonstrate how to define and use import and export SCA components. The following
is a diagram of the application in this exercise: Figurel
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The PortfolioManager Module includes the primary service used in this application. This service is called
PortfolioService, and allows the caller to query the total worth of a customer’s portfolio given the customer
identification number. When invoked, the PortfolioService makes a call to the service CustomerService to
query the customer information based upon the customer ID provided. Included in this customer
information is a list of stocks that are owned by the customer. The next step in the process is to invoke the
StockQuote Service to get the current price on each stock held by the customer. In order to illustrate the
use of import and export components in SCA, the StockQuote service is included in a module outside of
the PortfolioManager module. In addition to this, both the PortfolioManager and StockQuoteManager
modules need access to the StockQuotelnterface WSDL interface, so this artifact has been placed in a
library.

Exercise instructions

Some instructions in this lab might be specific for Windows® platforms. If you run the lab on a platform
other than Windows, you will need to run the appropriate commands, and use appropriate files (for
example .sh in place of .bat) for your operating system. The directory locations are specified in the lab
instructions using symbolic references as follows:

Reference Variable Windows Location Linux © Location
<LAB_NAME> Brokerage Brokerage
<WID_HOME> C:\Program Files\IBM\WebSphere\ID\6.0 | /opt/IBM/WebSphere/ID/6.0

<WPS HOME> <WID_HOME >\runtimes\bi_v6 <WID_HOME>/runtimes/bi_v6

<LAB_FILES> C:\Labfiles602 tmp/Labfiles602/

<WORKSPACE> C:\Labfiles602\Brokerage\workspace /tmp/Labfiles602/Brokerage/works
pace

<TEMP> C:\temp ftmp

<SOLUTION> C:\Labfiles602\SCA\Brokerage\solution /tmp/Labfiles602/SCA/Brokerage/

solution

Windows users’ note : When directory locations are passed as parameters to a Java  program such as
EJBdeploy or wsadmin, you must replace the backslashes with forward slashes to follow the Java
convention. For example, C:\LabFiles602\ would be replaced by C:/LabFiles602/

Note that the previous table is relative to where you are running WebSphere Integration Developer. The

following table is related to where you are running remote test environment:
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<SERVER_NAME> serverl clisr0l

<WAS_HOME> C:\Program [etc/cllcell/AppServerNodel
Files\IBM\WebSphere\AppServ
er

<HOSTNAME> localhost mvsxxx.rtp.raleigh.ibm.com

<BOOTSTRAP_PORT> 2809 2809

<TELNET_PORT> N/A 1023

<PROFILE_NAME> AppSrv0l default

<USERID> N/A clladmin

<PASSWORD> N/A frlday

Instructions for using a remote testing environment, such as z/0S®, AIX® or Solaris, can be found at the

end of this document, in the section “Task: Adding Remote Server to WebSphere Integration

Developer Test Environment .
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Part 1. Set up development environment

1. Start WebSphere Integration Developer V6.0.2 with a new workspace.

___a. Select Start > Programs > IBM WebSphere > Integration Deve

loper V6.0.2 > WebSphere
Integration Developer V6.0.2 from the start menu.

___b. Enter <LAB_FILES>\Brokerage\workspace for your workspace and click OK when prompted.

#4= Workspace Launcher

Select a workzpace

IEM WebSphere Inkegration Developer stores wour projects in a directory called a workspace,
Select the workspace directory o use for this session,

Warkspace: I CiiLabFilesa02Brokerageiworkspace j Browse, .. |

E Carcel |

___c. Close the Welcome page after WebSphere Integration Developer V6.0.2 opens.

- lcome x 0 fi =e)

L5 Integration Developer Go to the Business Integration perspective
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Part 2: Setup the PortfolioLibrary library project

A library project is a business integration project type in WebSphere Integration Developer V6.0.2 that is used
to store artifacts that are shared between multiple modules. In this part of the exercise you will create a library
project that contains the StockQuotelnterface WSDL definition. This interface is used by both the
PortfolioManager and the StockQuoteManager modules. In this exercise you will not be creating the

StockQuotelnterface ; instead you will be importing it into the library.
1. Create anew Library called PortfolioLibrary

___a. Select File > New > Other.

___b. Expand Business Integration and select Library .

___C. Click Next.

___d. Enter PortfolioLibrary for the library name and click Finish .
2. Import the StockQuotelnterface WSDL file.

___a. Select File > Import from the menu.

___b. Select File System for the import source and click Next

___¢. Use the Browse button to select <LAB_FILES>\SCA\Brokerage\import\PortfolioLibrary
From directory.

___d. Check the box next to StockQuotelnterface.wsdl

___e. Use the Browse button to select PortfolioLibrary for the Into folder .

File spstem o
Import resources From the local file syskem, ’,—l—/
-

Fram directory: IC:'|,LabFiIes6DZ'l,SC.ﬂ.'l,Brokerage'l,import'l,PortFoIioLibrary j Browse. .. |

""" (= Portfalialibrary @StnckQuoteInterFace.wsdI

Filter Iypes...l Select All Deselect All |

Into Folder: I PartfalioLibrary Browse. .. |
Options:

[ Qverwrite existing resources without warning
" Create complete Folder struckure

¢ Create selected Folders only

< Back Tk =

Cancel |
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__f. Click Finish .
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3. Open the StockQuotelnterface WSDL file in the WSDL editor and examine the getStockPrice

operation.

__a. Expand PortfolioLibrary - Interfaces and double click on StockQuotelnterface from the
business integration perspective.

___b. Verify and examine the contents of the WSDL file.

=Dperations

-

Cperations and their parameters

|

| farne Type
v%@getﬁtnckﬁice
L Inpukis) syrbol skring
[E» Cutpukis) price Floak

___C. Close the StockQuotelnterface WSDL file.
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Part 3: Build the StockQuoteManager module

The StockQuoteManager module is an SCA module that provides the implementation for the
StockQuote service component. This service component is exported to make this functionality available
to other modules, such as the PortfolioManager module you will build in the next part of this lab. The
StockQuote service is a simple service that provides the ability to obtain the current stock price for a
particular stock, given the stock symbol. This part of the exercise will guide you through creating the
StockQuoteManager module and the service component and export component in the SCA assembly
diagram.

1. Create a new Module called StockQuoteManager .
___a. Select File > New > Other .
__b. Select Module and click Next.

Select a wizard

Creates a new business integration module,

Wizards:

[=]-[2= Business Integration LI
----- [ Business Object

----- 5] Business Cbjeck Map

----- Business Process

----- = Business State Machine

----- % Custom Yisual Snippet

----- g Decision Table

----- %] Emulator

----- ['frl.;r; Enterprise Data Discovery —
----- 5 Enterprise Service Discavery

----- 5z Human Task,

[ shaw all Wizards, 7

= Bach I Mexk = I Eimist Cancel

___c. Enter StockQuoteManager for the Module name and click Finish .

2. Because the StockQuoteService component you defined in this part of the exercise implements
the StockQuotelnterface ; you will need to specify that the StockQuoteManager module is
dependent on the PortfolioLibrary project.
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o

T i e
__a. Expand StockQuoteManager and double-click on Dependencies (= Saswhnhei
Dependency Editor

) to open the

___b. Click the Add button under the Library section for the dependency editor.

___C. Select PortfolioLibrary and click OK.

Libranes
Configure the required libraries,

"”EF'I:Ir'tFn:nlin:nLiI:-rar":.-'

Advanced;

Deploy with Maodule

| add. .. | | Remove |

NOTE: If you click on the PortfolioLibrary in the libraries list you will notice that the ‘Deploy With Module’
box is checked. By default dependent projects that are added in the dependency editor are deployed with
the module.

___d. Save and close the dependency editor.

3. Open the assembly editor for the StockQuoteManager module.

___a. Expand StockQuoteManager in the Business Integration view and double click on Assembly

Diagram ('T';j =

s=embl

I+ Diagram )

4. Add the StockQuotelnterface to the assembly diagram.

__a. Expand PortfolioLibrary -> Interfaces in the Business Integration view, drag the
StockQuotelnterface onto the assembly diagram.
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___b. Select Component with No Implementation Type  and click OK.

= Component Creation |

Select the tvpe to create:

L L _omponent with Mo Implementation Type
* Excport with Mo Binding
lﬁ;"Expu:urt with Web Service Binding
= Impart with Mo Binding
l;;l:)lmpcurt with Web Service Binding

(0] 4 I Zancel

___c. Click on Componentl in the assembly editor and change the Display name and Name to
StockQuoteService in the properties view.

5. Provide an implementation for the StockQuoteService component.

___a. From the assembly editor, right click on StockQuoteService and select Generate
Implementation - Java from the context menu.

___b. Select default package as package where the Java Implementation will be generated and click
OK.

___¢. The Java editor will open in your work area with a Java file called StockQuoteServicelmpl.java

__d. Locate the getStockPrice method definition in the class file and enter the following code in the
body of the method.

float result = 0.00f;

if (synbol.equals("IBM)) {
result = 90. 00f;

} else {
result = 50.00f;

return new Fl oat (result);

NOTE: For your convenience, this code can be found in <LAB_FILES>\SCA\Brokerage
\snippets\snippetl.txt.

___e. Save and close the file.

6. Add an Export component for the StockQuotelnterface .

: . 4k
___a. Locate and click on the export icon ().
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___b. Click anywhere on the canvas of the assembly diagram.
7. Add the StockQuotelnterface to the Exportl component.

___a. Click on the Exportl component in the assembly diagram.

___b. Hover your mouse over the Exportl component until you see the Add interface icon (@’) and
click this icon.

NOTE: If you do not see the hover over icon, you can also add an interface from the Interfaces tab of the
properties view while the Export component is selected in the assembly diagram.

___c¢. From the Add Interface dialog, click on StockQuotelnterface from the Matching interfaces list
and click OK.

8. Set the SCA export binding.

__a. Right click on the Exportl component in the assembly diagram and select Generate Binding ->
SCA Binding .

9. Create a wire between the Exportl component and the StockQuoteService component.

___a. Select the wire tool (c1-=') and then click on Exportl .

___b. Click on the StockQuoteService component.

___c. Click on the selection tool ( %) from the palette.

Right click on the canvas and select Arrange Contents Automatically — and verify that your diagram
looks like the following.

@ Exportl (T '-_'é,j StockQuoteservice

10. Save and close the assembly diagram.
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Part 4: Build the PortfolioManager module

The PortfolioManager module is the primary SCA module in this exercise. The key service component in
the module is the called PortfolioService . This service provides the ability to return the total value of a
customer’s portfolio given the customer ID. The PortfolioService component references another service
component in the same module called CustomerService . The CustomerService component provides
information about the customer, including what stocks the customer owns. The data exchanged between
the PortfolioService and the CustomerService is a top level business object called Customer and you
will build in this business object in this part of the exercise. Once the customer information is obtained the
PortfolioService  utilizes a reference to an import component that provides service access to
StockQuoteService defined in the previous section.

1. Create the PortfolioManager Module.
___a. Select File - New - Other.
___b. Select Module and click Next.
___c. Enter PortfolioManager for the Module name and click Finish .
2. Because the import component you will define in this part of the exercise utilizes the

StockQuotelnterface , you will need to specify that the PortfolioManager module is dependent on
the PortfolioLibrary project.

T i e
__a. Expand PortfolioManager and double-click on Dependencies (2 s

) to open the
Dependency Editor
___b. Click the Add button under the Library section for the dependency editor.

__c. Select PortfolioLibrary and click OK.

___d. Click on the PortfolioLibrary in the libraries list, and verify that the box Deploy With Module is
checked

T *PortfolioManager Dependendies &2

Libraries
Configure reguired libraries,

Deploy With Module

Java

___e. Save and close the dependency editor.

3. Create the Stock business object.
___a. Expand PortfolioManager from the Business Integration view.
__b. Right click on Data Types and select New - Business Object .

___c. Enter Stock for the name of the business object and click Finish .
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__d. The business object editor will open in your workspace. To begin defining the Stock business
object, select the Stock object in the diagram.

NOTE: You can edit the properties of the business object from the properties view or within the business
object editor. Within the business object editor hover over icons are available that allow you to add and
remove attributes associated with the business object.

___e. Right click on the Stock object and select Add attribute .

___f. Select the newly added attribute. The attribute name and type can be edited from either the
properties view or directly within the business object editor. Change the attribute name to
numberOfShares and the type to int.

NOTE: The names of the business object attributes are case sensitive.

___g. Create another attribute on the Stock business object. Enter symbol for the attribute name and
leave the type as string .

__h. Verify that the Stock business object looks like the following.

(=] Stock

numberfshares ink
syrbol skring

___i. Save and close the file.
4. Create the Customer business object.
___a. Expand PortfolioManager from the business integration view.
__b. Right click on Data Types and select New - Business Object .
__c. Enter Customer for the name of the business object and click Finish .

__d. Create the following attributes with the types specified in the table below.

customerlID string
firstName string
lastName string
stocks Stock http://PortfolioManager
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___e. Note that the stocks attribute type is the Stock business object you created in the previous step.
Also note that this should be specified as an array. Use the properties view to set this attribute
type to array.

[ propeiic: % W -
Description Attribute - stocks

Diocumentation bocks |
Application Infa Type: |5t0ck 1 http://PartfolioManager + |E|

O Required

___f. Verify that the Customer business object looks like the following.

[£] Customer + [_] Skock

cuskomerID skring
firskhame  skring
lastMame  string
shocks Stock [ ]

___g. Save and close the file.

5. Import the CustomerService and PortfolioService Java interfaces and implementations.
__a. Select File > Import from the menu.
___b. Select File System for the import source and click Next.

___C. Use the Browse button and select
<LAB_FILES>\SCA\Brokerage\import\PortfolioManager\s = ample for the From directory.

___d. Check the box next to the sample folder.
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___e. Specify the ‘Into folder ’ as PortfolioManager\sample

4= Import E3
File system o
Import resources From the local file swstem. ;—I_,’
-

Frarn direckary: IC:'l,LabFiIesﬁD2'|,SCP.'I,Brokerage'l,import'l,PDrtFoIiDManager'l,sampIe j Browse. ., |

- [ (= sample [ customerService java
m CuskomerServicelmpl.java
1] PartfalioService.java
m PortfolioServiceImpl.java

Filter Tvpes... | Select all Deselect Al |
Irka Falder: I PortfolioManagerisample Browse, ., |
Options:

[ Drverwrite existing resources withouk warning
" Create complete Folder struchure

¥ Create selected folders anly

< Back ext =

Cancel |

___f. Click Finish .

NOTE: For both the PortfolioService and CustomerService components the interfaces have been
specified as Java Interfaces and were imported into the project in the previous step along with Java
implementations for these interfaces. In the following steps you will build the assembly diagram for the
PortfolioManager Module. An easy way to build this diagram is to drag and drop the Java
implementation files onto the assembly editor.

6. Open the assembly editor for the PortfolioManager module.

___a. Expand PortfolioManager in the Business Integration view and double click on Assembly
Diagram ('IE_;I Assembly Diagram ).

7. Add the PortfolioService component to the assembly diagram.

___a. Add a Java component to the canvas of the assembly diagram. To do this, locate and click on

the (@) icon on the palette of the assembly diagram and then click anywhere on the canvas of
the assembly diagram.
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NOTE: Click the gray > symbol next to (L_&) on the palette to locate the Java component icon (@).

___b. In the assembly diagram, select the component added in the previous step.

___c. Change the Display Name and Name of the component from Componentl to PortfolioService
from the properties view.

___d. Hover your mouse over the PortfolioService component until you see the Add interface icon
(Dy and click this icon.

NOTE: If you do not see the hover over icon, you can also add an interface from the Interfaces tab of the
properties view while the PortfolioService component is selected in the assembly diagram.

___e. From the Add Interface dialog, begin typing PortfolioService into the “Filter by interface or
qualifiers...” (Defaulted to *) box. Select the PortfolioService interface from the “Matching
types” lists and when it appears and click OK.

4= Add Interface M=l B

Filter by interface or qualifier (7 = any character, * = any String):

I PortFolio T,

Matching interfaces:

O S ——

{* Show WSDL and Java
" Show WsOL
" Show Jawva

Qualifier:

4 sample - {PartfolioManager

1 | i

oK I Cancel |
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__f. Specify the implementation for the PortfolioService component. Right click on the
PortfolioService component and choose Select Implementation from the context menu. When
the Pick Implementation dialog pops up, type in PortfolioServicelmpl into the “Select
entries” . Select the PortfolioServicelmpl listed under “Matching types:” when it appears and
click OK.

8. Add the CustomerService component to the assembly diagram

___a. Repeat the previous steps outlined in Step 7 to add the interface and implementation for the
CustomerService as specified in the table below

Name Type
CustomerService Interface
CustomerServicelmpl Implementation class

___b. Change the Display name and Name of the component from Componentl to
CustomerService from the properties view.

9. Add the Import component for the StockQuoteService.

__a. Locate and click on the Import icon (' ¥).
___b. Click anywhere on the canvas of the assembly diagram.
10. Add the StockQuotelnterface to the Importl component.

___a. Click on the Importl component in the assembly diagram.

___b. Hover your mouse over the Importl component until you see the Add interface icon (@’) and
click this icon.

NOTE: If you do not see the hover over icon, you can also add an interface from the Interfaces tab of the
properties view while the Export component is selected in the assembly diagram.

___c¢. From the Add Interface dialog, click on StockQuotelnterface from the Matching interfaces list
and click OK.

11. Setthe import binding type for Import1 .

___a. Right click on the Importl component in the assembly diagram and select Generate Binding ->
SCA Binding .

___b. With the Importl component still selected, go to the Binding tab of the Properties view.
___c. Enter StockQuoteManager for the module name.
___d. Click the Browse button and select Exportl from the list of matches for the Export name field.

12. Create a wire between the PorfolioService component and the CustomerService component.

i
___a. Select the wire tool ( 1-=') and then click on the PorfolioService .

___b. Click on the CustomerService component.
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__c. Click OK when you see the message appear indicating that a matching reference will be created
on the source node.

13. Create a wire between the PorfolioService component and the Importl component.

___a. Select the wire tool (c1-=') and then click on the PorfolioService .
___b. Click on the Importl component.

___¢. Click OK when you see the message appear indicating that a matching reference will be created
on the source node.

___d. Click No when prompted if you would like to convert the WSDL interface to a Java interfaces.

£ add Reference |

WaDL interfaces, It is simpler to develop Java clients if they use component
references that are described as Java interfaces. Would vou like ko conwvert
khe WSDL inkerfaces used by this component's references so that they use
Java inkerfaces?

@ There are one of more references on this companent that are described by

[ Remember my decision and do not ask me again

Help

14. Add a stand-alone reference to the diagram.

___a. Locate and click on the stand-alone reference icon ().
___b. Click anywhere on the canvas of the assembly diagram.

15. Add a reference to the stand-alone reference component from the previous step.

g
___a. Inthe assembly diagram select the stand-alone reference and click the Add Reference icon (l———‘l)
from the hover over menu.

___b. Select the radio button next to Show Java .

___c. Begin typing PortfolioService in the ‘Filter by interface ... ' (Defaulted to *) box and select the
PortfolioService from the ‘Matching Interfaces ' list when it appears.

___d. Enter PortfolioServicePartner for the name of the reference and click OK.

16. Create a wire between the stand-alone reference and the PortfolioService component.

. = .
___a. Select the wire tool ( 1-=') and then click on the reference box on the stand-alone reference ('**).

___b. Next, click on the PortfolioService component.
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___c. Verify that your diagram looks like the following.

@ 2 customerservice

1.1
Stand-alone References 1.1 (1 @ PortFolioService

1.1
@ = Importl
17. Save and Close the assembly editor file.

18. Create a dynamic Web project to hold the JSP that provides the user interface for the
PortfolioManager application. (Step 18 is required for 6.0.1 and beyond but is not required for
version 6.0)

___a. If you are in Business Integration perspective, switch to the J2EE Perspective by selecting
Window -> Open Perspective -> Other and check the box next to Show all. Select J2EE and
click OK

___b. Expand Enterprise Applications.

__c. Right click on PortfolioManagerApp and select New - Other...

___d. From the Select Wizard dialog, expand Web and select Dynamic Web Project from the list.
___e. Enter PortfolioManagerClient  for the name of the Dynamic Web project.

___f. Click Finish .

___g. Click Yes to confirm a switch to the Web Perspective.

NOTE: This will enable the Web Development capability within WebSphere Integration Developer for this
workspace.

19. Import the client JSP file.
___a. Select File = Import from the menu.
___b. Select ‘File System’ and click Next.

___¢. From the File system import dialog click the Browse button and choose the following From
directory: <LAB_FILES>\SCA\Brokerage\import\PortfolioManager

___d. Check the box next to the index.jsp file and click the Browse button to select
PortfolioManagerClient/WebContent  as the Into folder.

___e. Click Finish .
20. Add PortfolioManagerClient Web project as a J2EE dependency

___a. Inthe Business Integration view's tree, expand PortfolioManager and double-click on
T i e
Dependencies (o s

) to open the Dependency Editor
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O
Libraries
Configure the required libraries,
@PDrtFDIiDLibrary advanced:
O peploy with Module
Java
"} J2EE [Web, EJB, Connector, ED
Predefined Rezources
Ordering
Unrezolved Projects
___b. In the Dependency Editor, expand J2EE and click the Add button to add
PortfolioManagerClient as J2EE dependent project
___c¢. From the J2EE Project Selection panel, select PortfolioManagerClient listed and click OK
___d. Ensure that the check box next to Deploy with Module is selected by selecting the
PortfolioManagerClient module
1 J2EE [Web, EJB, Connector, etc]
Zonfigure the dependent JZEE projects such as web, EJB, and Connector modules, The selected
projects wi ploved as part of the module,
PortfolioManagerClien Advanced:
©n Build Path
Q] Deploy with Module
| add... | | Rernowe |
___e. Save and Close the Dependency Editor
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Part 5: Test the application

1. Start the server.

___a. If using a remote testing environment, follow the directions provided in TASK: Adding Remote
Server to WebSphere Integration Developer Test Envi _ronment at the end of this document to
add a server to the WebSphere Integration Developer test environment and start it. This is
especially true for z/OS, AlX, Solaris remote test environment, where the WebSphere Integration
Developer will be remote to the test environment.

If using a local testing environment, right click on WebSphere Process Server V6.0 from the
Server view and select Start from the context menu.

___b. Wait for the server to start.
2. Add the StockManager and PortfolioManager projects to the configured projects on the server.

___a. Right click on the WebSphere Process Server V6.0 from the Server view and select Add and
remove projects... from the context menu.

___b. Select StockQuoteManagerApp from the available projects list and click Add .
___c. Select PortfolioManagerApp from the available projects list and click Add .
___d. Click Finish .

3. Test the PortfolioService service component.

___a. Open a Web browser and enter the following URL.
http://<HOSTNAME>: 9080/ Port f ol i oManagerCient/i ndex.jsp

NOTE: To open the embedded browser within WebSphere Integration Developer V6.0.2, select Window
- Customize Perspective from the menu. In the Customize Perspective dialog click on the Commands
tab and scroll down to the bottom of the available command groups list until you find Web Browser. Check

the box next to Web Browser and click OK. Click the Web browser icon (";) now in your toolbar to open
the embedded Web browser.

___b. Verify that you see the following page displayed in the browser.

Portfolio Application

Enter Customer T |

Subirmit |

___c. Enter 123-45-6789 for the Customer ID and click Submit.
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___d. Verify that you see the following output.

Portfolio Application

Enter Customer 1D |

submit |

The walue 15: 115000
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Part 6: Restore server configuration
1. Remove the StockManager and PortfolioManager project from the configured projects on the server.

From the Servers view right click on the WebSphere Process Server V6.0 and select Add and
remove projects... from the context menu.

Select PortfolioManager from the configured projects list and click Remove.
Select StockManager from the configured projects list and click Remove .
Click Finish .

Stop the server. Right click on WebSphere Process Server V6.0 server from the Servers view and
select Stop from the context menu.
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What you did in this exercise

In this exercise you saw how to use WebSphere Integration Developer V6.0.2 tools to do the following
tasks:

» Create a business integration library

e Create and build a business integration module

» Create a business object

» Define a component interface that uses a business object
» Define a service export component

» Define a service import component
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Solution instructions
1. Start WebSphere Integration Developer V6.0.2 with a new workspace.
___a. Follow the instructions outlined in Part 1 of this exercise.

2. Import the project interchange file Brokerage_Pl.zip from <LAB_FILES>\SCA\Brokerage\solution
directory.

___a. Select File = Import from the menu.
___b. Select Project Interchange in the Import dialog and click Next.

r Import

Select

Import a project and its dependent projects from a Zip file. ™,

Select an import source:

®, Probe i
g‘.i:i'_EF‘rl:uﬁIing file

,% Project Interchange

& RAR file

'i'_—flﬁecuritv Certificate

B2 Server Cnnfiniration

| Mext = | Cancel

___c. For the From zip file , click on the Browse button and select the Brokerage Pl.zip in the
<LAB_FILES>>\SCA\Brokerage\solution director.

___d. Enter <LAB_FILES>\Brokerage\workspace for the Project location root and click Next.

___e. Select the check boxes next to PortfolioLibrary, PortfolioManager, PortfolioManag erClient
and StockQuoteManager

___f. Click the Select All button and click Finish .

3. Continue with Part 5 of this exercise.
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Task: Adding remote server to WebSphere Integration Developer test
environment

This task describes how to add a remote server to the WebSphere Integration Developer Test
environment. The sample will use a z/OS machine.

4. Create a new remote server.
___a. Right click on the background of the Servers view to access the pop-up menu.

___b. Select New > Server.

i ]
Properties ‘ Problems Mnmh| o o A =g

Server | Host name | Status | State

ﬁ\*ﬂehﬂphere ESE Server v6.0 localhost E@ Stopped Synchronized
WebSpherE Process Server ve.0 localhost E& Stopped Synchronized

New ¥ ﬁ}Server I

___c. Specify hostname to the remote server, <HOSTNAME>.
___d. Ensure that ‘WebSphere Process v6.0 Server ’is highlighted in the server type list.

X

Define a New Server
Choose the type of server to create.

Specify the host where you want to publish

L

Host name: I mvexxy. rtp.raleigh.ibm, com|

Select the server type:
. L. webSphere ESB Server v6.0

il WebSphere Express v5.0 Server

ﬁ WebSphere Express w5, 1 Server

- WebSphere Process wa.0 Server
LM \ehSnhers wh Server Attach

L]

Led Lo

View By: |Vendor

Description: WebSphere Process v6.0 Server

___e. Click Next.

__f. On the WebSphere Server Settings page, select the radio button for RMI and change the ORB
bootstrap port to the correct setting (<BOOTSTRAP_PORT>).
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4= New Server

Websphere Server Settings
Input settings for the new WebSphere senra]:

WebSphere profile mame:

SOAR conmeckar park:

I | Run server with resaurces within the WOr kSR ATE:
]

 authentication s

__g. Click Finish .

__h. The new server should be seen in the Server view.
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-,

a

WebSphere Process v6.0 Server @ mvswoocrtp.ral...

mvsxxx.rip.raleigh.ibm.com

Synchronized

Properties | Problems Ccnsnle| 15 O L =0
Server | Host name | Status | State

EWEbSphEFE ESBE Server va.0 localhost E‘@ Stopped Synchronized
'v'u'ebSphere Process Server va.0 localhost E‘g Stopped Synchronized

5. Start the remote server if it is not already started. WebSphere Integration Developer does not
support starting remote servers from the Server View.

___a. From a command prompt, telnet to the remote system if needed:

‘telnet <HOSTNAME> <TELNET_PORT>"

userid : <USERID>

pw: <PASSWORD>

___b. Navigate to the bin directory for the profile being used:

cd <WAS_HOME>/profiles/<PROFILE_NAME>/bin

___c. Run the command file to start the server: ./startServer.sh <SERVER_NAME>

___d. Wait for status message indicating server has started:

ADMU3200I1 : Server launched. Waiting for initialization status.
ADMU3000I : Server cl1sr0l1 open for e-business; process id is 0000012000000002
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