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IBM WebSphere® 6.0.2 — Lab Exercise

SCA and Web services
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What this exercise is about

This exercise will demonstrate the steps necessary to expose an SCA component as a Web service and
invoke that Web service from another SCA module.

Lab requirements
List of system and software required for the student to complete the lab.
* WebSphere Integration Developer V6.0.2 installed

» WebSphere Process Server V6.0 test environment installed

What you should be able to do
At the end of this lab you should be able to:
» Import a project using the Project Interchange feature
» Export an SCA component using a Web Services binding
» Use the Web Service Explorer to test a Web Service

* Invoke a Web Service using a service import
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Introduction

The following is an overview of the modules in this exercise:

@ 5 customerservice

[+ Stand-alone References 1.1 @ 5 partfalinservice :

(T %Impnrtl B _|

. PortfolioManager Module :
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___________________________ |

.............. e
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|_>® %StuckQtheServiceExpDrt ':?" @StDEkQUDtESEWiEE Il

StockQuoteManager Module

Exercise instructions

Some instructions in this lab might be specific for Windows® platforms. If you run the lab on a platform other
than Windows, you will need to run the appropriate commands, and use appropriate files (for example .sh in
place of .bat) for your operating system. The directory locations are specified in the lab instructions using

symbolic references as follows:
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<LAB_NAME> BrokerageWithWS BrokerageWithWs

<WID_HOME> C:\Program Files\IBM\WebSphere\lD\6.0 /opt/IBM/WebSphere/ID/6.0

<WPS_HOME> <WID_HOME >\runtimes\bi_v6 <WID_HOME>/runtimes/bi_v6

<LAB_FILES> C:\Labfiles602\ /tmp/Labfiles602

<WORKSPACE> | C:\Labfiles602\BrokerageWithWS\workspac | /tmp/Labfiles602/BrokerageWithW S\works
e pace

<TEMP> C:\temp tmp

<SOLUTION> (_::\LabfilesﬁOZ\SCA\BrokerageWithWS\squ /tlmp/LabfiIesﬁOZ/SCA/BrokerageWithWS/s
tion olution

Windows users : When directory locations are passed as parameters to a Java" program such as EJBdeploy
or wsadmin, you must replace the backslashes with forward slashes to follow the Java convention. For
example, C:\LabFiles602\ would be replaced by C:/LabFiles602/

Note that the previous table is relative to where you are running WebSphere Integration Developer. The
following table is related to where you are running remote test environment:

<SERVER_NAME> serverl clisr01

<WAS_HOME> C:\Program letc/cl1cell/AppServerNodel
Files\IBM\WebSphere\AppServer

<HOSTNAME> localhost mvsxxx.rtp.raleigh.ibm.com

<BOOTSTRAP_PORT> 2809 2809

<TELNET_PORT> N/A 1023

<PROFILE_NAME> AppSrv0l default

<USERID> N/A clladmin

<PASSWORD> N/A frlday

Instructions for using a remote testing environment, such as z/OS, AIX® or Solaris, can be found at the end of

this document, in the section “Task: Adding remote server to WebSphere Integration

environment ”.
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Part 1. Setup development environment
1. Start WebSphere Integration Developer V6.0.2 with a new workspace.

___a. Select Start > Programs > IBM WebSphere > Integration Deve loper V6.0.2 > WebSphere
Integration Developer V6.0.2 from the start menu.

___b. Enter <LAB_FILES>\BrokerageWithWS\workspace for your workspace and click OK when
prompted

+4= Workspace Launcher |

Select a workspace

1EM WebSphere Integration Developer stores wour projects in a directory called a workspace,
Select the workspace directary ko use Far this session,

Wiorkspace: I L abFilesc02Brokerageitithi S workspace j Browse, ., |

Cancel |

___c. Close the Welcome page after WebSphere Integration Developer V6.0.2 opens...

[ - wskcoe x N fi =e)

L5 Integration Developer Go to the Business Integration perspective
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Part 2: Import PortfolioManager and StockQuoteManag  er projects

1. Import the project interchange file containing the initial code for the PortfolioManager and StockQuote
applications.

__a. Select File > Import .
___b. Select Project Interchange from the Import dialog as the import source and click Next

___¢. Use the Browse button to specify the following zipped file:
<LAB_FILES>\SCA\BrokerageWithwS\import\Brokeragelni tial.zip .

___d. Enter <LAB_FILES>\SCA\BrokerageWithWS\workspace for the Project location root.

___e. Click the Select All button to select all projects included in the project exchange .zip file.

= Import Project Interchange Contents

Import Projects

h

Import Projects From a zip file.

-.I'-' N

1=
Fram zip File: IC:'I,LabFiIesﬁDE'l,SC.ﬁ.'l,BrnkErage'-.-'-.-'ith'-.-'-.-'S'I,impu:urt'l,EierﬂrageInitial.zip j Browse, ., |
Project lacation rook: I CtiLabFiless02Brokerage Withw Shworkspace| Browse, ., |

= Portfolioanager
I=F StockQuoterManager

Select .ﬁ.lll Deselect all | Select Referenced

< Back Mewxt = | Einish I Cancel

___f. Click Finish .
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Part 3: Export the StockQuoteService as a Web servi  ce
1. Open the assembly diagram for StockQuoteManager .

___a. Expand StockQuoteManager in the Business Integration view and double click on Assembly
zsembl

Diagram ("_41._\:| -

I+ Diagram ).
2. Export the StockQuoteService as a Web Service.

___a. Inthe assembly diagram, right click on the StockQuoteService component and select Generate
Export > Web Service Binding .

___b. Select soap/http on the Select Transport dialog and click OK.

c. Verify that the assembly diagram looks like the following.

o PaT :
@ & stackquatelnterfaceExpart1 (D) 85 StockQuoteService

___d. Save and close the assembly diagram.

___e. Go to the Window = Show View - Other...

___f. Expand Basic to select Navigator from the Show View dialog and click OK.

___g. In the Navigator view, expand the StockQuoteManager module

___h. Select the StockQuotelnterfaceExportl_StockQuotelnterfaceHttp Service.wsdl file

___i. Right click and select Open with > XML Source Page Editor

___j. Review the soap/address binding in the following line and ensure the hostname and port being
used are correct. If using a remote WebSphere Process Server machine replace localhost and
port 9080 with the correct hosthame and port number
Example:
If using integrated WebSphere Process Server Test Environment:
<soap:address

location="http://localhost:<http_port>/StockQuoteManagerWeb/sca/StockQuotelnterfaceExportl"/
>

Where as <http_port> is the default WebSphere Process Server http port number. Ex:- 9080

If using remote WebSphere Process Server:

<soap:address location=
"http://<remote_hostname>:<http_port>/StockQuoteManagerWeb/sca/StockQuotelnterfaceExport
1"/>

Where as <remote_hostname> is the hostname of the remote Process Server machine (Ex:-
mvsxxx.rtp.raleigh.ibm.com) and <http_port> is the default WebSphere Process Server http port
number. (Ex:- 9080)

Save and Close the XML Source Page Editor.
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Part 4: Test the StockQuoteService using the Web Se  rvices Explorer

1. Start the server.

___a. If using a remote testing environment, follow the directions provided in Task: Adding remote
rerver to WebSphere Integration Developer test envi___ronment_(at the end of this document) to
add a server to the WebSphere Integration Developer test environment and start it. This is
especially true for z/OS, AlX, Solaris remote test environment, where the WebSphere Integration
Developer will be remote to the test environment.

If using a local testing environment, right click on the WebSphere Process Server V6.0 from the
Server view and select Start from the context menu.

___b. Wait for the server to start.
2. Add the StockManager project to the configured projects on the server.

___a. Right click on the WebSphere Process Server V6.0 from the Server view and select Add and
remove projects... from the context menu.

___b. Select StockQuoteManagerApp from the available projects list and click Add .
___c. Click Finish .
3. Enable the Web Services Development capability.
___a. Select Window -» Preferences from the menu.
___b. Expand Workbench and click on Capabilities .
___¢. Check the box next to Web Service Developer in the capabilities list and click OK.
3. Launch the Web Services Explorer for the StockQuoteService Web service.

___a. Open the Physical Resources view by selecting Window -> Show View -» Others and then
expand the Business Integration and select Physical Resources from the menu. Click OK.

___b. Expand StockQuoteManager and right click on the file
StockQuotelnterfaceExportl_StockQuotelnterfaceHttp_  Service.wsdl and select Web
Services -> Test with Web Service Explorer from the context menu.

___c. Verify that the Web Service Explorer opens in your work area.
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Weh Ejhttp:Hloca\host:55068iwsexnlorar,l’wsaxp\orer.]sp?com.lbm‘etools.webserwce.explorer=u\

S Mavigataor 5 Actions

4 WSDL Main 3 o ]
=22 file: 0 /Labifilest0) Test2 fworkspace)S tock 8 wSDL Binding Details
E-39 StockQuoteServiceExport_StockQuotel
(@) S .

Showen below are the details for this SOAP <hinding= elernent. Cick on an operation ta fil in its parameters and invoke
it or specify additional endpaints.

= Operations

I

getStockPrice

= Endpoints 2dd Remove

~ I

[~ | httpejflocalhost 19080/ StockQuateManagerWeb/sca) StockQuoteServiceExport

Go Reset

i Status

W AB03B1I file: /i jLabfiesa0) Test2 fworkspace/StockQuateManager/StockQuateServiceExport_StockQuotelnterfacel |

-
] v 4] | 3

———

___d. Click on the getStockPrice link to test this operation.

27 wsDL Binding Details

Shiown below are the details for this SOAP <binding:= element. Click on an operation to fil in its pararmeters and invoke
it or specify additional endpaoints.

« Operations

qetSkockPricy -
N

___e. Enter IBM for the symbol and click Go.

= getStockPrice
syrohal string [ nil?
[E] <

Reset
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___f. Verify that you see the following result in the status window at the bottom of the Web Service
Explorer.

i Status

Source
= getStockPriceResponse

price (float): 0.0 (-

__ 0. Switch back to Business Integration view by selecting Window -> Show View -> Business
Integration .
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Part 5: Import StockQuoteService into PortfolioMana  ger as a Web service

1.

2.

Open the assembly diagram for PortfolioManager .

a. Expand PortfolioManager in the Business Integration view and double click on Assembly
Diagram (955 Assemb

I+ Diagram ).
Import the StockQuoteService using a Web service binding.

a. Locate the StockQuotelnterface in the Business Integration view under PortfolioManager ->
Interfaces .

b. Drag and drop the StockQuotelnterface on the PortfolioManager assembly diagram.

c. Select Import with Web Service Binding  when the component creation dialog appears and
click OK.

= Component Creation |

Select the tvpe to create:

%Cumpunent with Mo Implementation Type
* Export with Mo Binding

lf;!'Expl:urt with wweb Service Binding
= Impaort with Mo Binding

£Irmport with YWeb Service Binding

O I Zancel

__d. Click OK.

___e. Select the radio button next to Do not specify a Web service port at this time over the
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4= StockQuoteInterfaceImport1 Web Service Import Details E I

(" Use an existing weh service pork

Port: I <no port specified = Browse: |

" Generate a new web service definition and implementation

This will launch J2EE bools to help build and configure vour service,
This opkion is only recommended for advanced users,

% Do ot specify a web service port at this tme:

[o]'4 I Cancel

__f. Click OK

3. Create a wire between the PorfolioService component and the StockQuotelnterfacelmportl
component.

___a. Select the wire tool (clﬂ) and then click on the PorfolioService.
___b. Click on the StockQuotelnterfacelmportl component.

___c. Click OK when you see the message appear indicating that a matching reference will be created
on the source node.

___d. Click No when prompted if you would like to convert the WSDL interface to a Java interfaces.

£ add Reference

There are one of more references on this component that are described by
WD interfaces, It is simplet to develop Java clients if they use compaonent
references that are described as Java interfaces. Would vou like to convert
the 'WsDL interfaces used by this compaonent's references so that they use
Java interfaces?

[~ Remember my decision and do not ask me again

Mo Help

4.  Verify that your diagram looks like the following:

(I L—'ﬂ CuskomerService
1.1
Stand-alone References 1.1 (T @PDFtFD"DSEI’\-‘iEE L

(T -sf_f StockQuateInterfaceImnport 1
5.  Copy the StockQuotelnterfaceExportl_StockQuotelnterfaceHttp  Service.wsdl file into the
PortfolioManager project.

___a. Locate the StockQuotelnterfaceExportl_StockQuotelnterfaceHttp_ Service.wsdl file in the
Physical Resources view under StockQuoteManager.

___b. Right click and select Copy from the context menu.
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6.

7.

8.
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c. Remain in the Physical Resources view and right click on the PortfolioManager project and
select Paste from the context menu.

Update the bindings for StockQuotelnterfacelmportl.

a. Click on StockQuotelnterfacelmportl in the assembly editor and go to the binding tab in the
Properties view.

b. Click the Browse button Next to Service and select
StockQuotelnterfaceExportl_StockQuotelnterfaceHttp Service.wsdl from the list.

c. Select StockQuotelnterfaceExportl_StockQuotelnterfaceHttpP  ort on the select a port dialog
and click OK.

Save and Close the assembly editor file.
Import the client JSP file.

a. Select File > Import from the menu.
b. Select ‘File System’ and click Next.

c. Click the Browse button from the File system import dialog and choose the following for the From
directory: <LAB_FILES>\SCA\BrokerageWithWS\import\PortfolioMan  ager.

d. Check the box next to the index.jsp file and click the Browse button to select
PortfolioManagerWeb\WebContent  as the Into folder.

4= Import E
File system .
Impart resaurces From the lacal file system, ;—‘?
-l
From direckory: | Zi\LabFilesa02,SCAlBrokerageithiw S\ importPorkfolictManager j Browse, ., |
#-[A = PartfalioManager indes sp
Filter Types... | Select all Deselect Al |
Inkao Folder: I PortfolioManagerweb/WwebContent Browse, .. |
Options:

|l Owerwrite existing resources without warning

" Create complete Folder struckure

¥ Create selected folders only

« Back [dext =

Cancel |

e. Click Finish .
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Part 6: Test the PortfolioManager application
1. Add the PortfolioManager project to the configured projects on the server.

___a. Right click on the WebSphere Process Server V6.0 from the Server view and select Add and
remove projects... from the context menu.

___b. Select PortfolioManagerApp from the available projects list and click Add .
___c. Click Finish .
2. Test the PortfolioService service component.

___a. Open a Web browser and enter the following URL.
htt p: / / <HOSTNAME>: 9080/ Por t f ol i oManager Web/ i ndex. j sp

NOTE: To open the embedded browser within WebSphere Integration Developer V6, select Window -
Customize Perspective from the menu. Click on the Commands tab in the Customize Perspective dialog and
scroll to the bottom of the available command groups list until you find Web Browser. Check the box next to

Web Browser and click OK. Click the Web browser icon (@) now in your toolbar to open the embedded Web
browser.

___b. Verify that you see the following page displayed in the browser.

Portfolio Application

Enter Customer I |

Submit |

___c. Enter 123-45-6789 for the Customer ID and click Submit .

___d. Verify that you see the following output.

Portfolio Application

Enter Customer 1D |

Submit

The walue 15: 115000
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Part 7: Restore server configuration
1. Remove the StockManager and PortfolioManager project from the configured projects on the server

___a. Right click on the WebSphere Business Integration Server V6.0 from the Server view and select
Add and remove projects... from the context menu.

___b. Select PortfolioManager from the configured projects list and click Remove.
___c. Select StockManager from the configured projects list and click Remove .
___d. Click Finish .

2. Stopthe server.

___a. Right click on WebSphere Process Server V6.0 server from the Servers view and select Stop
from the context menu.
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What you did in this exercise
In this exercise you used WebSphere Integration Developer V6 tools to do the following tasks:
[0 Import a project using the Project Interchange feature
[0 Export an SCA component using a Web Services binding
[0 Use the Web Service Explorer to test a Web Service

[0 Invoke a Web Service using a service import
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Solution instructions
1. Start WebSphere Integration Developer V6.0.2 with a new workspace.
___a. Follow the instructions outlined in Part 1 of this exercise.

2. Import the project interchange file BrokerageWithwS_Pl.zip from
<LAB_FILES>\SCA\BrokerageWithWS\solution  directory.

___a. Select File = Import from the menu.
___b. Select Project Interchange in the Import dialog and click Next.
4= Import

Select

Import a project and its dependent projects from a Zip File. ™,

Select an import source;

() J2EE Ukility Jar ﬂ
B, 15P Tag Library
J|TﬂJLIniI: test inko component tesk project
=, Log File
=28 Performance Call Graph
f.ii', Praobe
&y Profiling File
S profiling Filker

AProject Inkerchange

@ RAR file

GE] Securit iFi

o= v Certificate

I A hd

= Barck I Mexk = I Eimish Zancel

___C. Click on the Browse button and select the BrokerageWithWS_Pl.zip in the
<LAB_FILES>\SCA\BrokerageWithWS\solution  directory for the “From zip file ”.

___d. Enter <LAB_FILES>\BrokerageWithWS\workspace for the Project location root and click
Next

___e. Click the Select All button and click Finish .

3. Continue with the lab and do Part 4, 6, and 7 of this lab.
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Task: Adding remote server to WebSphere Integration
Developer test environment

This task describes how to add a remote server to the WebSphere Integration Developer Test environment.
The sample will use a z/OS machine.

1. Create a new remote server.
2. Right click on the background of the Servers view to access the pop-up menu.

3. Select New > Server.

i =
Properties | Problems m\tmﬁnle| o o =8

Server | Host name | Status I State

ﬁiﬁfehSphere ESE Server v&.0 localhost E‘E\ Stopped Synchronized
'n"'.n'el:uSphere Process Server v6,0 localhost E_|E‘ Stopped Synchronized

" server |

4.  Specify hostname to the remote server, <HOSTNAME>.

5.  Ensure that ‘WebSphere Process v6.0 Server ' is highlighted in the server type list.

X

Define a New Server

Choose the type of server to create,

Specify the host where you want to publish

Host name: Imvs:-:xx.rtp.raleigh.il:lm.cc.ml

Le

Select the server type:

E‘[E? IEM
[ websphere ESB Server va.0

ko) WebSphere Express v5.0 Server
WebSphere Express w5, 1 Server

o WebSphere Process va.0 Server
. \ehSnhere wE Server AHach

LI+

5]

i

Ledle

View By: | Vendor

Description: WebSphere Process v&.0 Server

6. Click Next.
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. Onthe WebSphere Server Settings page, select the radio button for RMI and change the ORB
bootstrap port to the correct setting (<BOOTSTRAP_PORT>).

x|
WebSphere Server Settings
Input settings for the new WebSphere serverI 9
YWebSphere profile mame: I j

—Server connection type and admin port
{*' RMI (Better performance)

ORE bootstrap port: | 9131
" S0AP (More firewall compatible)

SOAP conmeckar pork: I 8880

[T Rum server with resources within the workspace
[~ Security is enabled on this server

Zurrent active authentication settings:

[sep IO I
Passward; I
Server name: I serverl
—Server type

{*' BASE, Express or unmanaged Metwork Deployment server
™ Metwork Deployment server

metwaork Deplaynient server nanme: I

The server name is in Ehe form af:
=eell mame = =node name =/ =server name =
For example, localfmstocalhostiserver]

Detect | Click this button to detect the server type,

< Back Mext = | | Finish I Cancel

8. Click Finish .

9. The new server should be seen in the Server view.
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-
Properties | Problems Ccnsnle| £ O el =0
Server | Host name | Status | State
ﬁ'ﬂ’u’ehSphere ESE Server va.0 localhost E‘@ Stopped Synchronized
WehSphere Process Server va.0 localhost E‘g Stopped Synchronized
Sphere Process v6.0 Server @ mysxodriporal...

mvsxxx.rip.raleigh.ibm.com

....... Synchronized

| B
10. Start the remote server if it is not already started. WebSphere Integration Developer does not
support starting remote servers from the Server View.
11. From a command prompt, telnet to the remote system if needed:
‘telnet <HOSTNAME> <TELNET_PORT>"
userid : <USERID>
pw: <PASSWORD>
_____12. Navigate to the bin directory for the profile being used:
cd <WAS_HOME>/profiles/<PROFILE_NAME>/bin
13. Runthe command file to start the server: ./startServer.sh <SERVER_NAME>
14. Wait for status message indicating server has started:
ADMU3200I1 : Server |launched. Waiting for initialization status.
ADMU3000I : Server cl1sr01 open for e-business; process id is 0000012000000002
2007 April, 04
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