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IBM WebSphere® 6.0 — Lab Exercise

Business Objects and Service Component Architecture
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What this exercise is about

The objective of this lab is to provide you with an understanding how to use WebSphere Integration
Developer V6 tools to build an SCA based application that uses Business Objects.

Lab Requirements
List of system and software required for the student to complete the lab.
e WebSphere Integration Developer V6 installed

e WebSphere Process Server V6 test environment installed

What you should be able to do
At the end of this lab you should be able to:
e Create a business integration library

e Create and build a business integration module
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e Create a business object using WebSphere Integration Developer V6
e Define a component interface that uses a business object
¢ Define a service export component

e Define a service import component

Introduction

One of the primary objectives of the business object framework is to provide a data abstraction for the
service component architecture (SCA). In this exercise you will define 2 business objects for a simple
SCA-based financial application. The primary service in this application is a Portfolio service that includes
an operation for determining the portfolio value for a particular customer. The top-level business object in
this application is the Customer business object. Each customer has a firstName, lastName, customerID,
and an array of stocks. All properties defined on the Customer business object are strings, with the
exception of the array of stocks which is a collection of Stock business objects. The Stock business object
consists of 2 properties, numberOfShares and symbol.

In addition to providing an introduction to basic business object usage with the SCA architecture, this
exercise will also demonstrate how to define and use import and export SCA components. The following
is a diagram of the application in this exercise:
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Figure 1

The PortfolioManager Module includes the primary service used in this application. This service is called
PortfolioService, and allows the caller to query the total worth of a customer’s portfolio given the customer
identification number. When invoked, the PortfolioService makes a call to the service CustomerService to
query the customer information based upon the customer ID provided. Included in this customer
information is a list of stocks that are owned by the customer. The next step in the process is to invoke the
StockQuote Service to get the current price on each stock held by the customer. In order to illustrate the
use of import and export components in SCA, the StockQuote service is included in a module outside of
the PortfolioManager module. In addition to this, both the PortfolioManager and StockQuoteManager
modules need access to the StockQuotelnterface WSDL interface, so this artifact has been placed in a
library.

Exercise Instructions

Some instructions in this lab might be specific for Windows® platforms. If you run the lab on a platform
other than Windows, you will need to run the appropriate commands, and use appropriate files (for
example .sh in place of .bat) for your operating system. The directory locations are specified in the lab
instructions using symbolic references as follows:

Reference Variable Windows Location Linux® Location
<LAB_NAME> Brokerage Brokerage
<WID_HOME> C:\Program Files\IBM\WebSphere\ID\6.0 | /opt/IBM/WebSphere/ID/6.0
<WPS HOME> <WID HOME >\runtimes\bi_v6 <WID_HOME>/runtimes/bi_v6
<LAB_FILES> C:\Labfiles60 tmp/Labfiles60/
<WORKSPACE> C:\Labfiles60\Brokerage\workspace /tmp/Labfiles60/Brokerage/worksp

ace

<TEMP> C:\temp tmp
<SOLUTION> C:\Labfiles60\Brokerage\solution /tmp/Labfiles60/Brokerage/solutio

n

Windows users’ note: When directory locations are passed as parameters to a Java' program such as
EJBdeploy or wsadmin, you must replace the backslashes with forward slashes to follow the Java
convention. For example, C:\LabFiles60\ would be replaced by C:/LabFiles60/

Note that the previous table is relative to where you are running WebSphere Integration Developer. The

following table is related to where you are running remote test environment:
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<SERVER_NAME> serveri cl1sr01

<WAS_HOME> C:\Program /etc/cl1cell/AppServerNodet
Files\IBM\WebSphere\AppServ
er

<HOSTNAME> localhost mvsxxx.rtp.raleigh.ibm.com

<BOOTSTRAP_PORT> 2809 2809

<TELNET_PORT> N/A 1023

<PROFILE_NAME> AppSrv01 default

<USERID> N/A cltadmin

<PASSWORD> N/A friday

Instructions for using a remote testing environment, such as z/OS®, AIX® or Solaris, can be found at the
end of this document, in the section “Task: Adding Remote Server to WebSphere Integration
Developer Test Environment”.
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Part 1: Set up Development Environment
1. Start WebSphere Integration Developer V6 with a new workspace.

__a. Select Start > Programs > IBM WebSphere > Integration Developer V6.0.1 > WebSphere
Integration Developer V6.0.1 from the start menu.

__b. Enter <LAB_FILES>\<LAB_NAME=>\workspace for your workspace and click OK when
prompted.

Workspace Launcher
Select a workspace

1EM WebSphere Integration Developer stores wour projects in a directory called a workspace,
Select the workspace direckory to use For this session,

Warkspace: I C:\Labfilesa0iErokerageiworkspace j Browse... |

[ Use this as the defaul and do not ask again

oK I Zancel |

__c. Close the Welcome page after WebSphere Integration Developer V6.0 opens.
[ = oo & =e

[ISTE Integration Developer (1= )

SNO" . B 4 e
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Part 2: Setup the PortfolioLibrary Library Project
A library project is a business integration project type in WebSphere Integration Developer V6 that is used
to store artifacts that are shared between multiple modules. In this part of the exercise you will create a
library project that contains the StockQuotelnterface WSDL definition. This interface is used by both the

PortfolioManager and the StockQuoteManager modules. In this exercise you will not be creating the
StockQuotelnterface, instead you will be importing it into the library.

__ 1. Create a new Library called PortfolioLibrary.

__a. Select File > New > Other.

__b. Expand Business Integration and select Library.

___c. Click Next.

__d. Enter PortfolioLibrary for the library name and click Finish.
__ 2. Import the StockQuotelnterface WSDL file.

__a. Select File > Import from the menu.

__b. Select File System for the import source and click Next.

__c¢. Use the Browse button to select <LAB_FILES>\<LAB_NAME>\import\PortfolioLibrary for the
from directory.

___d. Check the box next to StockQuotelnterface.wsdl.

__e. Use the Browse button to select PortfolioLibrary for the Into folder.

4= Import B
File system .
Import resources from the local file syskem, .v‘—l_7
-
From directory; IC:'tLabFi\esﬁD'tBrUksragelimDUrt'(PUrtFUIiULibrary j Browse. .. |
(= PortfolioLibrary (T stockquotelnterface. wsdl
Filter Types... | Select All Deselect Al

Into Folder: I PortfoliaLibrary

Options:
] Qverwrite existing resources without warning

" Create camplete Folder structure

¥ Create selected Folders only

< Back [t = | Eimish I Cancel

__f. Click Finish.
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3. Open the StockQuotelnterface WSDL file in the WSDL editor and examine the getStockPrice
operation.

__a. Expand PortfolioLibrary > Interfaces and double click on StockQuotelnterface from the
business integration perspective.

__b. Verify and examine the contents of the WSDL file.

O
~Define Operation(s) 8Bk Iy
Define Operations and their corresponding parameters
| Mame Type |

fe] " getShodkPrice |

L1 Inputis) symbal skring

G Cukpukls) price Floak
___c. Close the StockQuotelnterface WSDL file.
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Part 3: Build the StockQuoteManager Module

The StockQuoteManager module is an SCA module that provides the implementation for the
StockQuote service component. This service component is exported to make this functionality available
to other modules, such as the PortfolioManager module you will build in the next part of this lab. The
StockQuote service is a simple service that provides the ability to obtain the current stock price for a
particular stock, given the stock symbol. This part of the exercise will guide you through creating the
StockQuoteManager module and the service component and export component in the SCA assembly
diagram.

1. Create a new Module called StockQuoteManager.
__a. Select File > New > Other.
___b. Select Module and click Next.

Select a wizard

Creates a new business integration module,

Wizards:

[=]-[2= Business Integration LI
----- [ Business Object

----- =) Business Cbjeck Map

----- EQ: Business Process

----- “E Business State Maching

----- % Custom Yisual Snippet

----- g Decision Table

----- %] Emulator

----- G‘.‘E‘E Enterprise Daka Discovery -
----- IT=V Enterprise Service Discovery

----- 5z Human Task,

[ shaw all Wizards, 7

= Bach I Mexk = I Eimist Cancel

__c. Enter StockQuoteManager for the Module name and click Finish.

2. Because the StockQuoteService component you defined in this part of the exercise implements
the StockQuotelnterface; you will need to specify that the StockQuoteManager module is
dependent on the PortfolioLibrary project.
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__a. Right click on StockQuoteManager in the Business Integration view and select Open
dependency Editor.

__b. Click the Add button under the Library section for the dependency editor.
__c. Select PortfolioLibrary and click OK.
T *stockQuoteManager Dependendies &2

Libraries
Configure required libraries.

TEh PortfolioLibrary

[

Java

NOTE: If you click on the PortfolioLibary in the libraries list you will notice that the ‘Deploy With Module’
box is checked. By default dependent projects that are added in the dependency editor are deployed with

the module.

__d. Save and close the dependency editor.
3. Open the assembly editor for the StockQuoteManager module.

__a. Expand StockQuoteManager in the Business Integration view and double click on
StockQuoteManager.

4. Add the StockQuotelnterface to the assembly diagram.

__a. Expand PortfolioLibrary > Interfaces in the Business Integration view, drag and drop the
StockQuotelnterface onto the assembly diagram.

2006 August, 02 IBM WebSphere 6.0 — Lab Exercise Page 9 of 28

WPSWIDv6_SCAandBOLab.doc



© Copyright IBM Corporation 2006. All rights reserved

__b. Select Component with No Implementation Type and click OK.

= Component Creation |

Select the tvpe to create:

L L _omponent with Mo Implementation Type
* Excport with Mo Binding
lﬁ;"Expu:urt with Web Service Binding

= Impart with Mo Binding

l;;l:)lmpcurt with Web Service Binding

(0] 4 I Zancel

__c. Click on Component1 in the assembly editor and change the Display nhame and Name to
StockQuoteService in the properties view.

5. Provide an implementation for the StockQuoteService component.

__a. From the assembily editor, right click on StockQuoteService and select Generate
Implementation > Java from the context menu.

__b. Select default package as package where the Java Implementation will be generated and click
OK.

__ . The Java editor will open in your work area with a Java file called StockQuoteServicelmpl.java.

__d. Locate the getStockPrice method definition in the class file and enter the following code in the
body of the method.

float result = 0.00f;

if (symbol.equals("IBM")) {
result = 90.00f;
} else {

result = 50.00f;
}

return new Float (result);

NOTE: For your convenience, this code can be found in <LAB_FILES>\Brokerage
\shippets\snhippet1.txt.

___e. Save and close the file.

6. Add an Export component for the StockQuotelnterface.

. . b
__a. Locate and click on the export icon ().
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___b. Click anywhere on the canvas of the assembly diagram.
7. Add the StockQuotelnterface to the Export1 component.

__a. Click on the Export1 component in the assembly diagram.

___b. Hover your mouse over the Export1 component until you see the Add interface icon (@’) and
click this icon.

NOTE: If you do not see the hover over icon, you can also add an interface from the Interfaces tab of the
properties view while the Export component is selected in the assembly diagram.

__c. From the Add Interface dialog, click on StockQuotelnterface from the Matching interfaces list
and click OK.

8. Set the SCA export binding.

___a. Right click on the Export1 component in the assembly diagram and select Generate Binding >
SCA Binding.

9. Create a wire between the Export1 component and the StockQuoteService component.

__a. Select the wire tool (c1-=') and then click on Export1.

__b. Click on the StockQuoteService component.

__c. Click on the selection tool ( %) from the palette.

Right click on the canvas and select Arrange Contents Automatically and verify that your diagram
looks like the following.

@ Exportl (T '-_&,J StockQuoteservice

10. Save and close the assembly diagram.
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Part 4: Build the PortfolioManager Module

The PortfolioManager module is the primary SCA module in this exercise. The key service component in
the module is the called PortfolioService. This service provides the ability to return the total value of a
customer’s portfolio given the customer ID. The PortfolioService component references another service
component in the same module called CustomerService. The CustomerService component provides
information about the customer, including what stocks the customer owns. The data exchanged between
the PortfolioService and the CustomerService is a top level business object called Customer and you
will build in this business object in this part of the exercise. Once the customer information is obtained the
PortfolioService utilizes a reference to an import component that provides service access to
StockQuoteService defined in the previous section.

__ 1. Create the PortfolioManager Module.
__a. Select File > New > Other.
___b. Select Module and click Next.
__c. Enter PortfolioManager for the Module name and click Finish.

2. Because the import component you will define in this part of the exercise utilizes the
StockQuotelnterface, you will need to specify that the PortfolioManager module is dependent on
the PortfolioLibrary project.

__a. Right click on PortfolioManager in the Business Integration view and select Open Dependency
Editor.

__b. Click the Add button under the Library section for the dependency editor.
__c. Select PortfolioLibrary and click OK.

__d. Click on the PortfolioLibrary in the libraries list, and verify that the box Deploy With Module is
checked

T *PortfolioManager Dependendies &2

Libraries
Configure reguired libraries,

Deploy With Module

Java

__e. Save and close the dependency editor.

__ 3. Create the Stock business object.
__a. Expand PortfolioManager from the Business Integration view.
__b. Right click on Data Types and select New > Business Object.

__c. Enter Stock for the name of the business object and click Finish.
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__d. The business object editor will open in your workspace. To begin defining the Stock business

object, select the Stock object in the diagram.

NOTE: You can edit the properties of the business object from the properties view or within the business
object editor. Within the business object editor hover over icons are available that allow you to add and

remove attributes associated with the business object.

__e. Right click on the Stock object and select Add attribute.

__f. Select the newly added attribute. The attribute name and type can be edited from either the
properties view or directly within the business object editor. Change the attribute name to

numberOfShares and the type to int.

NOTE: The names of the business object attributes are case sensitive.

__g. Create another attribute on the Stock business object. Enter symbol for the attribute name and

leave the type as string.

__h. Verify that the Stock business object looks like the following.

=[] Stock

rumberJfshares ink

symbol skring

___i. Save and close the file.
__ 4. Create the Customer business object.
__a. Expand PortfolioManager from the business integration view.
__b. Right click on Data Types and select New > Business Object.
__c. Enter Customer for the name of the business object and click Finish.

__d. Create the following attributes with the types specified in the table below.

Attribute Name Type
customerlID string
firstName string
lastName string
stocks Stock http://PortfolioManager
2006 August, 02 IBM WebSphere 6.0 — Lab Exercise
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__e. Note that the stocks attribute type is the Stock business object you created in the previous step.
Also note that this should be specified as an array. Use the properties view to set this attribute

type to array.

Cr—

Description Attribute - stocks

Dacurmentation stacks |

Application Infa Twpe: |5t0ck { http:f/PortfolioManager } |E|

O Required

__f. Verify that the Customer business object looks like the following.

= [Z] Custamer

lastMame  skring
firstMarme  string
customerID string
shocks Skock [ ]

__g. Save and close the file.

5. Import the CustomerService and PortfolioService Java interfaces and implementations.

__a. Select File > Import from the menu.
__b. Select File System for the import source and click Next.

__C. Use the Browse button and select

<LAB_FILES>\<LAB_NAME>\import\PortfolioManager\sample for the from directory.

__d. Check the box next to the sample folder.
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__e. Specify the ‘Into folder’ as PortfolioManager\sample.

Q Import
File system .
Import resources from the local file system. ,—‘7
-
From directory: | C:\ abFiless0'BrokeragejmportiPortfolioManagerisample ﬂ Browse...

+-[#] = sample [3] CustomerService java

m CustomerServicelmpl.java
m PortfolioService. java
m PortfolioServiceImpl. java

Filter Types... | Select All Deselect All

Into folder: | PortfolioManager\sample Browse. ..

Options:

™ Overwrite existing resources without warning
" Create complete folder structure
& Create selected folders only

< Back Cancel

__f. Click Finish.

NOTE: For both the PortfolioService and CustomerService components the interfaces have been
specified as Java Interfaces and were imported into the project in the previous step along with Java
implementations for these interfaces. In the following steps you will build the assembly diagram for the

PortfolioManager Module. An easy way to build this diagram is to drag and drop the Java
implementation files onto the assembly editor.

6. Open the assembly editor for the PortfolioManager module.

__a. Expand PortfolioManager in the Business Integration view and double click on
PortfolioManager.

7. Add the PortfolioService component to the assembly diagram.

__a. Add a java component to the canvas of the assembly diagram. To do this, locate and click on

the (L—F'_L-) icon on the palette of the assembly diagram and then click anywhere on the canvas of
the assembly diagram.
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&)

NOTE: Click the gray > symbol next to ("_&) on the palette to locate the Java component icon (

__b. Inthe assembly diagram, select the component added in the previous step.

__c. Change the Display Name and Name of the component from Component1 to PortfolioService
from the properties view.

__d. Hover your mouse over the PortfolioService component until you see the Add interface icon
(D) and click this icon.

NOTE: If you do not see the hover over icon, you can also add an interface from the Interfaces tab of the
properties view while the PortfolioService component is selected in the assembly diagram.

__e. From the Add Interface dialog, begin typing PorfolioService into the “Filter by interface or
qualifiers...” (Defaulted to *) box. Select the PortfolioService interface from the “Matching
types” lists and when it appears and click OK.

4= Add Interface M=l B

Filter by interface or qualifier (7 = any character, * = any String):

I PortFolio e, .,

Matching interfaces:

O T ——

{* Show WSDL and Java
" Show WsDL
" Show Java

Qualifier:

£ sample - fPortfolioManager

1 | i

oK I Cancel |
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__f. Specify the implementation for the PortfolioService component. Right click on the
PortfolioService component and select Select Implementation from the context menu. When
the Pick Implementation dialog pops up, type in PortfolioServicelmpl into the “Select
entries”. Select the PortfolioServicelmpl from the “Matching types:” list when it appears and

click OK.
8. Add the CustomerService component to the assembly diagram

___a. Repeat the previous steps outlined in Step 7 to add the interface and implementation for the
CustomerService as specified in the table below

Name Type
CustomerService Interface
CustomerServicelmpl Implementation class

___b. Change the Display hame and Name of the component from Component1 to
CustomerService from the properties view.

9. Add the Import component for the StockQuoteService.

__a. Locate and click on the Import icon ('=).
___b. Click anywhere on the canvas of the assembly diagram.
10. Add the StockQuotelnterface to the Import1 component.

__a. Click on the Import1 component in the assembly diagram.

___b. Hover your mouse over the Import1 component until you see the Add interface icon (@’) and
click this icon.

NOTE: If you do not see the hover over icon, you can also add an interface from the Interfaces tab of the
properties view while the Export component is selected in the assembly diagram.

__c. From the Add Interface dialog, click on StockQuotelnterface from the Matching interfaces list
and click OK.

11. Set the import binding type for Importi.

__a. Right click on the Import1 component in the assembly diagram and select Generate Binding >
SCA Binding.

___b. With the Import1 component still selected, go to the Binding tab of the Properties view.
__c. Enter StockQuoteManager for the module name.
__d. Click the Browse button and select Export1 from the list of matches for the Export name field.

12. Create a wire between the PorfolioService component and the CustomerService component.

__a. Select the wire tool ( E ) and then click on the PorfolioService.

__b. Click on the CustomerService component.
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__c. Click OK when you see the message appear indicating that a matching reference will be created
on the source node.

13. Create a wire between the PorfolioService component and the Import1 component.

__a. Select the wire tool ( & ) and then click on the PorfolioService.
__b. Click on the Import1 component.

__c. Click OK when you see the message appear indicating that a matching reference will be created
on the source node.

__d. Click No when prompted if you would like to convert the WSDL interface to a Java interfaces.

£ add Reference |

WaDL interfaces, It is simpler to develop Java clients if they use component
references that are described as Java interfaces. Would vou like ko conwvert
khe WSDL inkerfaces used by this component's references so that they use
Java inkerfaces?

@ There are one of more references on this companent that are described by

[ Remember my decision and do not ask me again

Help

14. Add a stand-alone reference to the diagram.

___a. Locate and click on the stand-alone reference icon ( ).

___b. Click anywhere on the canvas of the assembly diagram.

15. Add a reference to the stand-alone reference component from the previous step.

£
__a. Inthe assembly diagram select the stand-alone reference and click the Add Reference icon (l———‘l)
from the hover over menu.

___b. Select the radio button next to Show Java.

__c. Begin typing PortfolioService in the ‘Filter by interface ..." (Defaulted to *) box and select the
PortfolioService from the ‘Matching Interfaces’ list when it appears.

___d. Enter PortfolioServicePartner for the name of the reference and click OK.

16. Create a wire between the stand-alone reference and the PortfolioService component.

__a. Select the wire tool ( E ) and then click on the reference box on the stand-alone reference ().

__b. Next, click on the PortfolioService component.
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__c. Verify that your diagram looks like the following.

@ 2 customerservice

1.1
Stand-alone References 1.1 (1 @ PortFolioService

1.1

o R
L [&=2

Importl

17. Save and Close the assembly editor file.

18. Create a dynamic web project to hold the JSP that provides the user interface for the
PortfolioManager application. (Step 18 is required for 6.0.1 and beyond but is not required for
version 6.0)

__a. Select the J2EE Perspective and expand Enterprise Applications.
__b. Right click on HelloWorldApp and select New > Dynamic Web Project from the list.
__c. Enter HelloWorldClient for the name of the Dynamic Web project.

___d. Click Finish.

__e. Click Yes to confirm a switch to the Web Perspective.

NOTE: This will enable the Web Development capability within WebSphere Integration Developer for this
workspace.

19. Import the client JSP file.
a. Select File > Import from the menu.
b. Select ‘File System’ and click Next.

c. From the File system import dialog click the Browse button and choose the following From
directory: <LAB_FILES>\<LAB_NAME>\import\PortfolioManager.

d. Check the box next to the index.jsp file and click the Browse button to select
PortfolioManagerClient/WebContent as the Into folder.

e. Click Finish.
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Part 5: Test the Application

1. Start the server.

__a. If using a remote testing environment, follow the directions provided in TASK: Adding Remote
Server to WebSphere Integration Developer Test Environment at the end of this document to
add a server to the WebSphere Integration Developer test environment and start it. This is
especially true for z/OS, AlX, Solaris remote test environment, where the WebSphere Integration
Developer will be remote to the test environment.

If using a local testing environment, right click on WebSphere Process Server V6.0 from the
Server view and select Start from the context menu.

___b. Wait for the server to start.
2. Add the StockManager and PortfolioManager project to the configured projects on the server.

__a. Right click on the WebSphere Process Server V6.0 from the Server view and select Add and
remove projects... from the context menu.

__b. Select StockQuoteManagerApp from the available projects list and click Add.
__c. Select PortfolioManagerApp from the available projects list and click Add.
__d. Click Finish.

__ 3. Testthe PortfolioService service component.

__a. Open a web browser and enter the following URL.
http://<HOSTNAME>:9080/PortfolioManagerClient/index. jsp

NOTE: To open the embedded browser within WebSphere Integration Developer V6 select Window >
Customize Perspective from the menu. In the Customize Perspective dialog click on the Commands tab
and scroll down to the bottom of the available command groups list until you find Web Browser. Check the
box next to Web Browser and click OK. Click the Web browser icon (’3) now in your toolbar to open the
embedded Web browser.

__b. Verify that you see the following page displayed in the browser.

Portfolio Application

Enter Customer T |

Subirmit |

__c. Enter 123-45-6789 for the Customer ID and click Submit.
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__d. Verify that you see the following output.

Portfolio Application

Enter Customer 1D |

submit |

The walue 15: 115000
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Part 6: Restore Server Configuration
1.  Remove the StockManager and PortfolioManager project from the configured projects on the server.

From the Servers view right click on the WebSphere Process Server V6.0 and select Add and
remove projects... from the context menu.

Select PortfolioManager from the configured projects list and click Remove.
Select StockManager from the configured projects list and click Remove.

Click Finish.

Stop the server. Right click on WebSphere Process Server V6.0 server from the Servers view and
select Stop from the context menu.
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What you did in this exercise
In this exercise you saw how to use WebSphere Integration Developer V6 tools to do the following tasks:
e Create a business integration library
e Create and build a business integration module
e Create a business object
e Define a component interface that uses a business object
¢ Define a service export component

e Define a service import component
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Solution Instructions
1.  Start WebSphere Integration Developer V6 with a new workspace.
__a. Follow the instructions outlined in Part 1 of this exercise.

2. Import the project interchange file Brokerage_Pl.zip from <LAB_FILES>\<LAB_NAME>\solution
directory.

__a. Select File > Import from the menu.

__b. Select Project Interchange in the Import dialog and click Next.

r Import

Select

Import a project and its dependent projects from a Zip file. E\\"‘ ﬂ

Select an import source:

#, Probe

g‘.i:i'EF‘rl:uﬁIing file

,% Project Interchange
& | RAR file
'i'_—flﬁecurit*,' Certificate

B2 Server Cnnfiniration

| Mext = | Cancel

__c. For the From zip file, click on the Browse button and select the Brokerage_Pl.zip in the
<LAB_FILES>\<LAB_NAME=>\solution director.

__d. Enter <LAB_FILES>\<LAB_NAME>\workspace for the Project location root.
___e. Click the Select All button and click Finish.

3. Continue with Part 5 of this exercise.
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Task: Adding Remote Server to WebSphere Integration Developer Test
Environment

This task describes how to add a remote server to the WebSphere Integration Developer Test
environment. The sample will use a z/OS machine.

4. Create a new remote server.
__a. Right click on the background of the Servers view to access the pop-up menu.

___b. Select New > Server.

-
Properties ‘ Problems m\ﬁmﬁnh | o o =g

Server | Host name | Status | State

ﬁ\*ﬂehﬂphere ESE Server v6.0 localhost E@ Stopped Synchronized
WebSpherE Process Server ve.0 localhost E& Stopped Synchronized

ﬁ} Server |

__c. Specify hostname to the remote server, <HOSTNAME>.

__d. Ensure that ‘WebSphere Process v6.0 Server’ is highlighted in the server type list.

X

Define a New Server
Choose the type of server to create, D

Specify the host where you want to publish

L

Host name: I mvexxy. rtp.raleigh.ibm, com|

Select the server type:
E‘[E? IEM
- =H WebSphere ESB Server v6.0
o] WebSphere Express v5.0 Server
ﬁ WebSphere Express w5, 1 Server

i WebSphere Process wa.0 Server
LM \ehSnhers wh Server Attach

L]

Led Lo

View By: |Vendor

Description: WebSphere Process v6.0 Server

___e. Click Next.

__f. On the WebSphere Server Settings page, select the radio button for RMI and change the ORB
bootstrap port to the correct setting (<BOOTSTRAP_PORT>).
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4= New Server

Websphere Server Settings
Input settings for the new WebSphere senra]:

WebSphere profile mame:

SOAR conmeckar park:

I | Run server with resaurces within the WOr kSR ATE:
]

 authentication s

__g. Click Finish.

__h. The new server should be seen in the Server view.
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Properties | Problems Ccnsnle| T 0 ‘?p L =0

-,

Server | Host name | Status | State
EWEbSphEFE ESBE Server va.0 localhost E‘@ Stopped Synchronized
'v'u'ebSphere Process Server va.0 localhost E‘g Stopped Synchronized

ebSphere Process v6.0 Server @ mysxocrtporal...  mvsioocrtp.raleigh.ibm. com Started Synchronized

a

5. Start the remote server if it is not already started. WebSphere Integration Developer does not
support starting remote servers from the Server View.

__a. From a command prompt, telnet to the remote system if needed:
‘telnet <HOSTNAME> <TELNET_PORT>’
userid : <USERID>
pw: <PASSWORD>
__b. Navigate to the bin directory for the profile being used:
cd <WAS_HOME->/profiles/<PROFILE_NAME>/bin
__c. Run the command file to start the server: ./startServer.sh <SERVER_NAME>

__d. Wait for status message indicating server has started:

ADMU3200I: Server launched. Waiting for initialization status.

ADMU3000I: Server cllsr0Ol open for e-business; process id is 0000012000000002
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