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This presentation provides an overview of the client test tools available in the Telecom

Enablement feature of the IBM WebSphere® Telecom Toolkit V 7.0. To get a better

understanding on the content of this presentation, first review the overview presentation
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Goals

* Provide an overview of the XML configuration

access protocol, session initiation protocol and
diameter client test tools

= Explain the usage of these test client tools in the
telecom enablement feature

Client tools © 2009 IBM Corporation

The goal of this presentation is to provide an overview of the client test tools available in
the Telecom Enablement Feature of the WebSphere Telecom Toolkit V 7.0. These client
test tools are for the XML Configuration Access Protocol, Session Initiation Protocol, and
Diameter protocols. The presentation also explains the usage of these tools to test the
protocol specific applications to which the tools are geared.
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Agenda

= Telecom application enablement batched script
= XML configuration access protocol client

= Session initiation protocol client

= Diameter Rf client

= Diameter Sh client

Client tools © 2009 IBM Corporation

The agenda of this presentation covers the various client test tools which include:
- The Telecom Application Enablement Batched Request Script creation wizard.

- The XML Configuration Access Protocol Client used to test applications based on the
XML Configuration Access Protocol

- The Session Initiation Protocol Client used to test applications based on the Session
Initiation Protocol.

- The Diameter Rf and Sh clients used as Web services clients for the offline charging Rf
and subscriber profile Sh Web services protocols.
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Telecom application enablement batched script

» Wizard to create the telecom application
enablement batched script (NewScript.ims file)

» Launched using File -> Other -> Telecom Application
Enablement — Telecom Application Enablement Batched
Script

» Upon script creation, the client test tools editor is shown
= Editor has four pages, one page for each of the
clients
» History maintained in all the client pages

= Batched scripts are stored in the .ims file
» Can be added to repository and shared

© 2009 IBM Corporation

All four test client tools are driven and managed by a Telecom Application Enablement
batched request script. The tools provide a wizard to create a new Telecom Application
Enablement Batched Request Script. The wizard can be launched by following the menu
actions File -> Other -> Telecom Application Enablement -> Telecom Application
Enablement Batched Request Script

The wizard creates a script file with an .ims extension and launches the editor. The editor
has four pages, one for each client. Tests performed from the four test clients can be run
as single or batched tests. All test clients maintain history of the information entered and
the history size is configurable (refer to slide 20 for this information). The batched tests are
stored in the script file for reuse, for instance the script file can also be stored in a
repository and can be shared and used by multiple users.
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XCAP client

= Tool to manage XML documents using XML
Configuration Access Protocol (XCAP)

» Ideal client to manage documents in IBM XML Document
Management Server (XDMS).

» XDMS provides network accessible storage, retrieval,
and management of XML documents owned by entities

= |s built using Open Mobile Alliance (OMA) standards - OMA XDM v1.0.1
specification

= An editor page to configure and run XCAP
requests

» Provides user interface controls to build valid requests

» Run requests as single or in batch

The XCAP client is built based on XML Configuration Access Protocol (XCAP) standards
and is used to manage XML documents using the XCAP protocol. XCAP is a specification
defined by Internet Engineering Task Force (IETF) that defines how XML documents are
transported and managed over Hyper Text Transfer Protocol (HTTP). The XCAP client is
the client test tool well suited for managing documents in the IBM XML document
management server (XDMS) that uses XCAP over HTTP for managing its XML
documents. The XDMS is a group list management server from IBM that is built using
Open Mobile Alliance (OMA) standards. It provides network accessible storage, retrieval,
and management of XML documents owned by various entities or users on a network. You
can learn more about the IBM XDMS by visiting this URL:
http://publib.boulder.ibm.com/infocenter/wtelecom/v6r2mO0/index.jsp.

The XCAP client, built as an editor page, provides the user interface controls to build and
validate the XCAP requests as described in the following slides. The requests can be run
as single or batched requests.
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XCAP client requests format

e http//myhost.ibm.com:9080/services/resource-lists/ /~—Iresource-lists/list[1]
XCAP ROOT l | AUID | | Document Seledor | | Node Seledtor |

= XCAP Root: identifies the HTTP request host, port,
and context root.

= AUID: Application Unique ID identifies the type of
XML document

= Document Selector: Portion of the URI which
identifies the specific document to be stored or
accessed

* Node Selector: XPath expression to identify a
specific XML element or attribute

' @RS -

Client tools © 2009 IBM Corporation
The figure in this slide shows the general format of an XCAP request to access XML
documents. The XCAP request is made up of these elements:

- The XCAP Root that identifies the HTTP request host, port, and context root of the
services

- The AUID which is the application unique ID that identifies the type of XML document
being accessed. AUID’s can be predefined IDs defined by the XCAP specification or user
defined AUID’s. For example resource-lists in the figure is a user defined AUID.

- The Document Selector portion of the URI identifies the specific document to be stored
or accessed in the users or global space. Global space documents are only accessible to
users with administrative access.

- The Node Selector is a limited XPath expression that can be used to identify a specific
XML element or attribute which is to be updated, retrieved, or deleted.
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XCAP client request creation

= URI information ->Configure Parameters ->Optionally
adding it to the Batched Requests

= Recently used values saved in history, Input validation

21X xcap | 3P stp | 2R DismeterRf | 3D Diametersh A Batched Requests
- w X0 ool
User: | superadmin | Password: XCap Root: | hitp:/}vibims01..rtp.raleigh.ibm.com: 9081 /services v 2% XCAP PUT - hitp:/jvkbims01..1tp.r
PN
: | resource-ist ;| imsuser| Name: | sample1.xml
A | o = e o . b 2% XCAP GET - hetp: {vibimsO1rtp.re
Node Selector: v 3
v Parameters
Request: PUT w | Content Type: | applicationfresource-ists+xml v File: v
D&ta: | <ouml versions"1.0" encoding="UTF-8"7>
<resource-lists xmins="urn:ietf: lists™ "http:/fwwaw.w3.0rg/2001 /XMLSchema-instance”>

<list name="test_group™>
<entry uri="imsuser2@example. ibm.com’/>
<fist>
<jresource-ists>

The figure in the slide shows the screen capture of the XCAP requests section and the
various user interface controls available to configure XCAP requests. Building an XCAP
request involves three steps as follows:

- Entering the URI information involved to build the XCAP URI with the XCAP Root, AUID
and XUl values. The User and Password information are used for authenticating the
request. The doc name is the name of the document to add, delete or modify

- Configuring the Parameters as follows:
> Selecting the type of operation to be performed using the Request field, and

> Selecting the Content Type for the request and populating the Data from a pre-existing
file using the Browse button for the File field or manually entering the data in the Data
field.

- Running the request after filling in the URI and Parameter sections as a single request or
adding it to the Batch list using the Add button and running it as a Batched request. More
details about the Batched requests is explained in slide 19 of this presentation.
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XCAP client results

= Results displayed in the common Results section
» Figure shows results of XCAP PUT request

= Can be displayed with or without request

fil
parameters Savertofie
hmm— / Clear
[CJDisplay Request Parameters| R esults

2009-03-23 16:43:46 JOB (1 of 3) STARTED: XCAP PUT -

http://vkbims01.rtp. ra.l.eiqh.ﬂ-.cm:9081/.:rvicel/re'ource—lutl/uter'/muserleexq.le
ibm.com/samplel .sanl.

XCAP Response is as follows:
HTTP/1.1 200 OK
headers:
Last-Modified: Mon, 23 Mar 2009 21:15:33 GMT
Cache-Control: no-cache="set-cookie, set-cookie2”
Server: UebSphere Application Server/6.1
Expires: Thu, 01 Dec 1994 16:00:00 GNT
ETag: 1237842933666
Transfer-Encoding: chunked
Content-Language: en-US
Date: Mon, 23 Mar 2009 21:15:33 GNMT v

Client tools © 2009 IBM Corporation

The result of running single or batched XCAP requests is displayed in the common
Results section. The figure in the slide shows the results of an XCAP PUT request of a
sample.xml file as resource-lists document for imsuserl. The XCAP response shows the
HTTP response code of 200 OK which means the document was inserted successfully.

The Results section is common for all the test clients and displays the results of all the
client requests. The Results can be displayed with or without the request parameters. By
default the Display Request Parameters check box is checked. The results displayed can

be saved to an external file using the save to file button and the contents can be cleared
using the clear button.
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SIP client

= Provides user interface to configure SIP requests
= Based on SIPp open source SIP traffic generation
tool
» Requires SIPp installed on the client machine

= Executes pre-built SIPp scenarios XML files

» Supports all Request for Comments (RFC) supported by
SIPp

» All user options supported by SIPp also supported by the
client

= Can run single or batched SIP requests

Client tools © 2009 IBM Corporation

The SIP Client provides a user interface for configuring and running SIP requests. The
client is based on the SIPp open source SIP traffic generation tool and requires SIPp
installation on the client machine where the SIP client is installed. The client is capable of
executing all pre-built SIPp scenario XML files. The client supports all the SIP Request for
Comments (RFCs) supported by the SIPp, such as RFC 3261, 2823, 3725 and so on. The
client supports all the configuration options provided by SIPp, and supports running SIP
requests as single or batched requests.
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SIP client for WebSphere Presence Server

= [deal SIP client for IBM WebSphere Presence
Server

= IBM WebSphere Presence Server

» Built on SIP for Instant Messaging and Presence
Leveraging Extensions (SIMPLE) open standards
» Collects and distributes rich presence information
through SIP protocol

» Provide awareness of presence through SIP PUBLISH
and SUBSCRIBE requests and responses

= Can be used to test various SIP PUBLISH and

SUBSCRIBE request and responses
b OMAT ~ N

Client tools © 2009 IBM Corporation

The SIP Client is a client tool that can act as a SIP user agent for the IBM WebSphere
Presence Server. The IBM WebSphere Presence Server is built on SIP for Instant
Messaging and Presence Leveraging Extensions (SIMPLE) open standards. It collects
and distributes rich presence information using the SIP protocol. It uses the SIP PUBLISH
and SUBSCRIBE requests and responses to provide and distribute the presence
information of a presentity on the network. The SIP client can be used to test various SIP
PUBLISH and SUBSCRIBE scenarios by building SIPp scenarios following the SIPp
document type definition.
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SIP client request creation

= Select SIPp Executable -> Define SIP server
host:port -> Select SIPp scenario -> Increment no.
of calls -> Define SIPp options

= Remote host in figure is a WebSphere Presence
Server
2X xcap 3P sip | 2R DiameterRf | 2SN Diametersh

Settings

Executable: C:\Program Files\Sipp_3.1\sipp.exe v

Remote Host: 9.42,136.57:5068

Scenario File: C:\IEA\PresenceXDMSTest\sub_pub_imsuser1_imsuser2_working_test.xml

i |

Number of Calls: | 1

< |42 €€

Options: -inf C:\IEA\PresenceXDMSTest\sub_pub_imsuser1_imsuser2_working_inf.csv

I @R ~ L%

Client tools © 2009 IBM Corporation
Building a SIP request using the SIP Client involves these steps:

- Selecting the SIPp executable file from the location where SIPp is installed on the local
machine where the client is running.

- Defining the Remote SIP Server host followed by a colon and its SIP listening port,

- Defining the SIPp scenario file, which is a prebuilt scenario file built following the
Sipp.dtd,

- Incrementing the number of SIP calls to generate, the client defaults to one call,

- Providing any SIPp options that need to be fed along with the SIP request. By default
some SIPp options like -trace_err, -trace_msg, -trace_screen are provided by the client
and need not be explicitly mentioned in the Options.

To demonstrate the use of the client, the values in the figure depict one SIP call using a
PUBLISH and SUBSCRIBE request response SIPp scenario against a WebSphere
Presence Server. WebSphere Presence Server is installed on the host with IP address
9.42.136.57 with its SIP listening port as 5068. An injection file is passed as an option to
run the scenario across two SIP user agents. The results are presented in the next slide.
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SIP client results

= SIP Scenario execution results

BEGIN - Statistics Log
Scenario Screen =------- [1-9]: Change Screen --
Timestamp: Tue Mar 24 15:43:23 2009

Call-rate(length) Port Total-time Total-calls Remote-host
10.0(0 ms)/1.000s 5060 1.48 = 1 9.42.136.57:5068(UDP)

Call limit reached (-m 1), 0.479 s period 3 ms scheduler resolution

0 calls (limit 30) Peak vas 1 calls, after 0 s
0 Running, 1 Paused, O VWoken up
0 dead call msg (discarded) 0 out-of-call msg (discarded)

3 open sockets

Messages Retrans Timeout Unexpected-MNsg
1 o

o 1] 0 0

r o 0 o

1 1] 0 o

1 o

1 o

1 o 0 0

1 o o 0o

1 o

Client tools

Results
[ Display Request Parameters B &
2009-03-24 15:43:21 JOB (1 of 1) STARTED: SIP - sub_pub 1 2 | test.aml. A

IEM

© 2009 IBM Corporation

The results of the SIP scenario run are displayed in the common Results section. The
figure shows the results of the SIP PUBLISH and SUBSCRIBE scenario run in the
previous slide. The Results section also displays the complete set of SIP messages sent

and received between the SIP client and SIP server.

ClientTools.ppt
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SIP client results

= SIPp Screen log displayed

7] Tasks | & Console £3

in Console view

" X % | i 58S &

Statistics Screen -----

e S N
<terminated> sub_pub_imsuser1_imsuser2_working_test.xml [SIP Script] C:\Program Files\Sipp_3. 1\sipp.exe

-- [1-9]: Change Screen --

Test Terminated

Start Time | 2009-03-24 15:43:22:049 1237923802 .049500
Last Reset Time | 2009-03-24 15:43:23:106 1237923803.106500
Current Time | 2009-03-24 15:43:23:587 1237923803.587500
Counter Name | Periodic value | Cumulative value
Elapsed Time | 0D0:00:00:481 | 00:00:01:538

Call Rate I 0.000 cps | 0.650 cps
Incoming call created | o | 0

OutGoing call created | ] | 1

Total Call created | | 1

Current Call | o

Successful call | : | 1

Failed call ] o | [e]

Call Length | 00:00:01:379 | 00:00:01:379

IEM

Client tools
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In addition to the Results view, the SIPp screen log of the SIPp Scenario is displayed in
the Console view of Rational® Application Developer where the toolkit is installed. The
Figure shows the success or failure of the SIP call from the end of the screen log in the

Console view.

ClientTools.ppt
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Diameter Rf and Sh clients

= Clients to test the individual object methods of the

offline charging Rf and subscriber profile Sh Web
services

* In an IP Multimedia Subsystems Environment

» Rf Web service used to update data in the Charging
Collection Function

» Sh Web service used to access data from a Home
Subscriber Server

= Code snippet generated through Batched requests
can be used for developing client applications

OMAR ~ %

Client tools © 2009 IBM Corporation
The Diameter Rf and Sh client tools provide a user interface driven way to test the
individual object methods of the Web services description language (WSDLSs) of the offline
charging Rf and subscriber profile Sh Web services. In an IP Multimedia Subsystem
environment the Rf Web service is used to update offline charging data in the Charging
Collection Function and the Sh Web service is to access subscriber profile data from the
Home Subscriber Server. Just like the other client tools, the Batch request tool provides a
feature to copy the code snippet from the test that can be reused in developing client

applications. A more detailed description about the Batch requests tool is provided on slide
19.
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Diameter Rf client request creation

W D f' 33 xcap | BE s1P | N Dismeterhf | S Diametersh
erine e

Endpont Specfications

Endpoint -> o mereme e - '
Select Web oo

Parameters

»
Sewlce Session ID HCCessPONt7. acme.com; 1876543210;523;mob v Record Number 0 v
Destination Realm  LAB210Test] v Acct Interim Interval 0 v
Method -> @ TLlms - :
f' User Name testuser v
Define s
Method S

1&11%1&;

Parameters

The figure in the slide shows the screen capture of the Diameter Rf offline charging
request section and the various user interface controls available to configure Rf requests.
Creating a Rf Web service request involves three steps that include:

- Defining the Endpoint Specification for the Rf service which is the URL of the Diameter
server where the Rf service endpoint is configured. The User and Password information
are used for authenticating the request.

- Selecting a method from the Web service Methods drop down.

- Defining all the parameters of the method. The common parameters for all the Rf Web
service methods include:

Session ID — Is a globally unique identifier that indentifies a user session. For example
aaa://host.example.com;protocol=diameter;-117302099;1

Destination Realm — Is the realm the subscriber belongs to. The destination realm is a
required parameter and must be a fully qualified domain name. The value specified must
match the specific realmName property that is defined in the Diameter_Rf.properties file.

Event Time Stamp — Is the timestamp to record the time the event occurred.
User Name — Is the private user identity if available in the node.

Record Number — Is zero for a single session and increments by one for follow on
messages.

Acct Interim Interval — Is the start time for the session, in seconds.

Origin State ID — holds the value to track the incremented value of possible times the
client has lost the state or a possible reboot has occurred.
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Diameter Rf client results

= Results displayed in the common Results section
» Figure shows results of startRfAccounting() method

= Can be displayed with or without request
parameters

Results
["] Display Request Parameters B &4

2009-03-26 14:04:18 JOB (1 of 1) STARTED: DiameterRf - startRfAccounting.
===> Response Object:

Result Code: 2001 Origin State ID: null Event Time Stamp:
8000000 Acct Interim Interval: O

2009-03-26 14:04:20 JOB (1 of 1) FINISHED: DiameterRf - startRfAccounting.

Client tools © 2009 IBM Corporation

The results of running single or batched Diameter Rf request are displayed in the common
Results section. The figure in the slide shows the results of a Diameter Rf request. The
Response Object shows the service data returned for the startRfAccounting method.

The Results section is common for all the test clients and displays the results of all the
client requests. The Results can be displayed with or without the request parameters. By
default the Display Request Parameters check box is checked. The results displayed can
be saved to an external file using the save to file button and the contents can be cleared
using the Clear button. You can change the font or color of the text by right clicking and
selecting the Font menu item.
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Diameter Sh client request creation
* Define Endpoint -> Select Web service Method ->
Define Method Parameters
2X xcap (3P sip | 2 DiameterRF | 3N Diametersh
Endpoint Specifications
Sh Service | http://9.22.95.25:9080/DHADiameter ShWebService/services/DiameterShService v
User: root Password:  eesssese
Web Service Methods
getRepositoryData v
Parameters
Session ID aaa: /fhost.example.com;protocol=diameter;-11 v Destination Host | sipintel15. city.company.com v
Destination Realm | LAB210Test1 v Public Identity sip:alice;day=tuesday@atlanta.com v
Parameter Value
serviceIndication IBM-Diameter-5H-1234567
;' @B~ %
Client tools © 2009 IBM Corporation

The figure in the slide shows the Diameter Sh subscriber profile request section and the
various user interface controls available to configure Sh requests. Creating a Sh Web
service request involves three steps that include:

- Defining the Endpoint Specification for the Sh service which is the URL of the Diameter
server where the Sh service endpoint is configured. The User and Password information
are used for authenticating the user initiating the request.

- Selecting a method from the Web service Methods drop down.

- Defining all the parameters to the method. The common parameters for all the Sh Web
service methods include:

Session ID — Is a globally unique identifier that indentifies a user session. For example
aaa://host.example.com;protocol=diameter;-117302099;1

Destination Realm — Is the realm the subscriber belongs to. The destination realm is a
required parameter and must be a fully qualified domain name. The value specified must
match the specific realmName property that is defined in the Diameter_Sh.properties file.

Destination Host — Is the qualified domain name of the HSS that the Sh subscriber profile
Web service will send this request to. This input parameter is optional. For example:
sipintel15.city.example.com or diameter.example.com

Public Identity - Specifies the public user identity or public service identity. This can be
either a SIP URL or a TEL URL. Example: sip:alice;day=tuesday@example.com

The figure shows the getRepositoryData method selected and its parameters which
include:

servicelndication — Is a unique identifier for the requested service data. Example: IBM-
Diameter-SH-1234567
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Diameter Sh client results

= Results displayed in the common Results section
» Figure shows results of getRepositoryData() method

= Can be displayed with or without request
parameters

Results
[[] Display Request Parameters B &

2009-03-26 12:54:07 JOB (1 of 1) STARTED: Sh - getRepositoryData:
Session ID = aaa://host.example.com:protocol=diameter;-117302099:1.

===3 Response Object:

getSequenceNumber = 0 getServicelndication = IBM-Diameter-SH-
1234567

getServiceData = email joeuserfus.ibm.com ibm.com/directory/4321
2159591680 55579821 1580656576 29758194 *
2009-03-26 12:54:13 JOB (1 of 1) FINISHED: Sh - getRepositoryData:
Session ID = aaa://host.example.com:protocol=diameter:-117302099:1.

Client tools © 2009 IBM Corporation

The results of running single or batched Diameter Sh request are displayed in the common
Results section. The figure in the slide shows the results of a Diameter Sh request. The
Response Object shows the service data returned for the getRepositoryDate method
along with the service identification information passed in with the request from the
Diameter Sh service endpoint as shown in the previous slide.

The Results section is common for all the test clients and displays the results of all the
client requests. The Results can be displayed with or without the request parameters. By
default the Display Request Parameters check box is checked. The results displayed can
be saved to an external file using the save to file button and the contents can be cleared
using the Clear button.
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Batched requests Add delay button Ry button

Deleto requests ____ & -%a / Number of
utton T Times to run the
f23:cap PUT - http: /jvkbimsO1.rtp.rald
@DELAY ZSE(nd(s = requeSt
X XCAP GET - hitp:/jvkbims01.rtp.rale

Show code snippet button \
@ XCAP Client Request Snippet x|

| -~

i
* the HTTP METHOD ot
Doy ApCorants HTTP HETHOO,_JUT; Reorder

T requests

String userld = "superadmin

=

11 Disward uummwm *t
String pw =

lﬂ-emcwwﬁl
String xcapRoot = “hetp:/jvikbims01.rtp.r slesgh. bm.com: 9081 jservices”;

J* AUID -
summ - ncncmm AUID_RESOURCE _LISTS;

J* The 3ML User Identifier, n.lfcltfudubddoc o |
String xul = "nsuser | Pexangie.bm.com’;

1* The name used ta identiy the XML document */
String xmibiame = “samplel xil;

1* node selector *f -

© 2009 IBM Corporation

The Batched Request section of the client editor is common to all client test tools. Multiple
client requests from different clients can be run together through the Bathed Requests
section. The Bathed Requests section provides some additional useful features that are
explained through the figure in the slide. These additional features include:

- Performing validation on request parameters in the request before adding to the request
batch

- Reorder Requests button for reordering requests already added to the batch

- Number of Execution Iterations field to increase or decrease the number of times the
requests need to be run

- Execute button to run the batched requests
- Add delay button to add time delay in seconds between requests

- Show Code Snippet button which shows the Java™ code that is built and used to run the
request using the parameter values entered by the user. The code in this dialog can be
copied using the Copy button and pasted in a Java class and reused for building a Java
client for the request.

- Delete Requests button to delete any requests already in the batch.

Upon running the tests, moving the mouse up and down and selecting different requests
shows the corresponding output in the results window. This is a useful feature, especially if
the batch consists of a number of requests.
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Telecom application enablement preferences

= Launched by selecting Window -> Preferences ->
Telecom Application Enablement

Telecom Application Enablement Preferences - - -
= General i ’
History Size:
Preferences T  _——. e

™ Aways update request without prompt?

= XCAP Client = .

HTTP Headers: ‘

Preferences == ——JM |
: ,

ETag

¥-Match

¥-None-Match

Last-Modfied

X-3GPP-Asserted-identity

X-3GPP-Intended-identtty

X-XCAP-Asserted-identty

The Telecom Application Enablement feature in the toolkit provides two sets of
preferences in the Telecom Application Enablement Preferences page. These preferences
can be launched from Rational Application Developer by selecting Window -> Preferences
-> Telecom Application Enablement or by way of the pop-up menu of the results window.
The two sets of preferences include General and XCAP preferences.

The General preferences include the following:

- The History Size field provides the number of previous user entries entered in all user
interface controls of the toolkit that need to be stored so that previously entered values
can be viewed and selected.

- The Always delete requests without prompt check box provides the option to delete the
requests from the Batched requests section without a prompt

- The Always update request without prompt check box provides the option to update a
request from the Batched request section without a prompt.

The XCAP Preferences page provides a way to configure existing HTTP Header values for
XCAP requests in addition to adding new headers and deleting existing headers. The list
of existing HTTP headers are listed under the Name column of the HTTP Headers table of
the preference page.
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