L[] Ly [T (-B WebSphere Business Monitor SAP Sample Adapter SupportPac

Version 6.0.2

s W
o0

Ml
or Y

WebSphere Business Monitor SAP Sample Adapter SupportPac



First Edition (June 2007)

This edition applies to IBM WebSphere Business Monitor SAP Sample Adapter SupportPac, Version 6.0.2 and to all
subsequent releases and modifications until otherwise indicated in new editions.

© Copyright International Business Machines Corporation 2007. All rights reserved.
US Government Users Restricted Rights — Use, duplication or disclosure restricted by GSA ADP Schedule Contract
with IBM Corp.



Contents

SAP Sample Adapter SupportPac. . . . 1 Configuring the WebSphere Business Integration

SAP Sample Adapter install . . . | Station to process business events
Prerequisites for the SAP Sample Adapter Deploying the WBM_SAPApp.ear file .
SupportPac . Deploying the SAP adapter monitor model .

Installing the WebSphere Busmess Integrahon

station .

Getting the SAP SupportPac . .

Installing the WebSphere Business Integratlon

Adapter Framework . .

Installing the WebSphere Busmess Integratlon

Adapter for mySAP.com .
Configuring the WebSphere Busmess Momtor

Server and CEI Server with BPC.

Configuring the WebSphere Business Integratlon

Adapter connection .

Configuring the SAP busmess workflow to emlt

business objects

© Copyright IBM Corp. 2007

Testing the WebSphere Business Monitor for SAP
scenario S
Displaying the busmess measure in the
WebSphere Business Monitor dashboard.

Troubleshooting the SAP adapter .

No business events arrive in the WebSphere
Business Monitor Server .

Error: Project WBM_SAPApp is m1ssmg requ1red
Java project
‘websphere_default_messaging_provider’

Error: Missing the trigger sources .

N

.13

. 16

. 16

.17
.17

iii



iV WebSphere Business Monitor SAP Sample Adapter SupportPac



SAP Sample Adapter SupportPac

The IBM® WebSphere® Business Monitor SAP Sample Adapter SupportPac™ is a
sample solution provided by IBM for monitoring SAP enterprise resource planning
(ERP) systems with WebSphere Business Monitor. The solution uses an adapter to
convert business events from an SAP system to Common Base Events that are
processed by WebSphere Business Monitor.

This solution uses the WebSphere Business Integrator Adapter for SAP to collect
the business events from the SAP ERP system. Using the Java message service
(JMS), the events are transmitted to the Common Event Infrastructure (CEI) server
with Business Process Container (BPC). A BPEL application (WBM_SAPApp)
resides on the CEI server with BPC that transform the events to Common Base
Events and sends them to the WebSphere Business Monitor server. The WebSphere
Business Monitor server has a dedicated monitor model module (SO_MMEAR)
that processes the incoming Common Base Events. From this point these events are
handled by the WebSphere Business Monitor Server.

The SAP Sample Adapter uses the SAP Java Connector (JCo) to connect to the SAP
system and poll for new events. The events are then sent through the WebSphere
Business Integration Adapter and delivered to a JMS queue that is installed on the
CEI server with BPC. A BPEL application picks these events from the queue and
transforms them to suitable Common Base Events. Because this is an asynchronous
task, events that are emitted while the adapter is not connected to the SAP system
are kept as business objects in the SAP ERP system until the adapter is connected
to the SAP ERP system. Once the adapter connects to the system, the events are
delivered to the WebSphere Business Monitor.

This SupportPac sample uses the creation of a sales order as the business event to
monitor. To view the business data gathered from the SAP ERP system, use the
standard WebSphere Business Monitor portlets. The definitions of the key
performance indicators (KPIs) and the design of the portlets in this sample adapter
are provided to you as an example only. The provided files are examples only and
do not represent an IBM recommendation.

SAP Sample Adapter install

The SAP Sample Adapter SupportPac consists of several files that demonstrates the
ability to connect WebSphere Business Monitor with an SAP system and monitor
SAP business events. The SupportPac also contains a Project Interchange file that
you can edit and configure for your own purposes.

The basic steps to installing and configuring the WebSphere Business Integration
Adapter for mySAP.com are presented in the following steps:

Prerequisites for the SAP Sample Adapter SupportPac

Before you can use the SAP Sample Adapter SupportPac files, you must ensure
that the required products are installed and that you have the required skills.

To use this SupportPac, you must have a licensed installation of IBM WebSphere

Business Monitor v6.0.2.1 on your system. If you have not upgraded to v6.0.2.1,
you do must upgrade before using the SupportPac. To upgrade to WebSphere
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Business Monitor v6.0.2.1, see the Release Notes (http://publib.boulder.ibm.com /|
infocenter /dmndhelp /v6rxmx/index.jsp?topic=/com.ibm.btools.help.monitor.doc /|
Doc/concepts/release_readme/rn_aboutthisrelease.html) on the WebSphere
Business Monitor Information Center for information on upgrading. You must also
have a working knowledge of the WebSphere Business Monitor programming
model and have used the product as well as the WebSphere Business Monitor
Development Toolkit, the WebSphere Business Monitor Server, and dashboards.

For the latest updates to the documentation, see the WebSphere Business Monitor

Support Web site (http://www.ibm.com /support/search.wss?rs=802&tc=SSSRR3|
h q=6.0.2.1).

Ensure that the following software is installed.

* WebSphere Business Monitor v6.0.2.1

* WebSphere Business Integration Adapter Framework v2.6.0

* WebSphere Business Integration Adapter for mySAP.com v6.0.0
* WebSphere Business Monitor Development Toolkit v6.0.2 (IDE)
* The MQ Client libraries

Refer to the Architecture section for information about the recommended topology.

In addition to the software listed, the SAP system must be configured to deliver
business events whenever an SAP sales order is created within the SAP ERP
system. The WebSphere Business Integration station is a subcomponent of the
WebSphere Business Integration Adapter for mySAP.com and is shipped as an
Advanced Business Application Programming (ABAP) transport that must be
applied and configured in the target SAP system. The SAP Business workflow
component which is an integral part of any SAP ERP system must be configured to
send the corresponding business event to the WebSphere Business Integration
station.

For more details on setting up the SAP Business Workflow to send business events
and deliver them using the WebSphere Business Integration Adapter for
mySAP.com and incorporating the resulting SCA JMS export, see the section in the
IBM Redbook Connect WebSphere Service Oriented Middleware to SAP about invoking
WebSphere Process Server and WebSphere Enterprise Service Bus using JMS.

Related concepts

[Architecture of the SAP Sample Adapter|
The WebSphere Business Monitor for SAP uses a simple architecture to monitor
SAP systems for events.

Related tasks

[ [Connect WebSphere Service Oriented Middleware to SAP Redbook|
Related reference

Skills Required

To use this sample adapter, it is required that you must have already acquired
some skills.

To use this sample adapter, you must:
* Be familiar with using an SAP system
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* Have an existing installation of WebSphere Business Monitor Server 6.0.2.1
(server, dashboard and databases)

¢ Have a modest to excellent understanding and/or experience with WebSphere
Business Monitor V6.0.2 including the monitor programming model

* Have some experience with Monitor Dashboard configuration

* Be familiar with WebSphere Business Integration Adapter and Java Message
Service

* Have an understanding, and preferably some experience, with WebSphere
Process Server V6.0.2 including Business Process Container for BPEL

* Be familiar with setting up a WebSphere Process Server V6.0.2 so that it can be
monitored by WebSphere Business Monitor

* Have some experience with WebSphere Integration Developer V6.0.2 (optional)

Installing the WebSphere Business Integration station

A detailed description of how to install the relevant ABAP transports for the
WebSphere Business Integration Adapter for mySAP.com is described in the
redbook WebSphere Business Integration for SAP. See the section about configuring
the SAP R/3 to work with the ABAP Extension Module of the Adapter.

Getting the SAP SupportPac
The SAP SupportPac is available as a Web download.

1. Go to |http://www.ibm.com/support/docview.wss?rs=171&uid=swg| and
download the SAP SupportPac.

2. Extract the files into a working directory. Verify that your working directory
contains the following files:
* ProjectInterchange files (monitor4sap.zip and BO2CBEconverter.zip)
¢ EAR files (SO_MMEAR.ear and WBM_SAPApp.ear)
* SAP Adapter config file and business objects definitions
* Conversion Logic file (SAPrules.xml)
* Installation doc (PDF file)

3. Copy the SAPrules.xml file to the root folder of your CEI with BPC server
profile.

Installing the WebSphere Business Integration Adapter
Framework

Before you can use the WebSphere Business Monitor for SAP monitor model, you
must install the WebSphere Business Integration Adapter Framework if you have
not already done so.

During the installation of the WebSphere Business Integrator Adapter Framework
the setup procedure asks for the location of the MQSeries® class libraries. These
libraries are available as a MQSeries SupportPac MASS.

To install the WebSphere Business Integration Adapter Framework:
1. Install the MQSeries classes for Java and Java Messaging:

a. Download the MQSeries classes for Java and Java Messaging SupportPac
from |http: / /www.ibm.com/ support/ docview.wss?rs:203&uid:swg24011226|
[&loc=en_US&cs=utf-8&lang=en|

b. Go to the download packages list and download ma88_win.zip.

c. Extract the contents of the file to a working directory.
d. If you have a previous SupportPac installed, uninstall it.
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e. Run setup.exe from the working directory

2. Install the WebSphere Business Integration Adapter framework 2.6.0 (base
install):

a. Locate and copy %WINDOWS%\system32\msvcr71.dll and
%WINDOWS% \system32\msvcp71.dll to a backup directory.

b. Open a Windows® command window by clicking Start » Run. Type cmd and
click OK.

c. Use the cd command to change to the directory where the Adapter
Framework v2.6.0 installer is located, for example, cd D:\SAP_ADAPTER\
adapter_build\AF2.6.0\260\.

Enter setupwin32.exe -W ICSSequence.active=false.

Select a language and click OK.
Click Next, accept the Software License Agreement, and then click Next.
Clear the IBM WebSphere InterChange Server check box and click Next.
Select both IBM WebSphere Business Integration Adapter Runtime and
IBM WebSphere Business Integration Toolset and click Next.

i. Click Browse and locate the directory for the IBM WebSphere MQ 5.3 Java

Library, for example, C:\Program Files\IBM\MQSeries\Java\lib.

j. Accept all the defaults by clicking Next, Next, Next, Next, and Finish.
3. Install the WebSphere Business Integration Adapter framework fix pack:

a. Install the fix pack for Adapter Framework v2.6.0.5 You can find the fix

pack at: [ftp:/ /ftp.software.ibm.com /software /ts/cw /adapters /|
[AdapterFramework /|

Se "o o

b. Download the .zip file, and extract the file to a location on your system.

c. Locate the directory where you extracted the files and double-click
setupwin32.exe.

d. Click OK and then Next.

e. Accept the Software License Agreement and then continue by clicking Next,
Next, Next, and Finish.

f. Check your %WINDOWS%\system32 directory and verify that msvcr71.dll
and msvcp71.dll are still there. If those files no longer exist, copy them from
the location where you saved the earlier.

Installing the WebSphere Business Integration Adapter for
mySAP.com

After installing the Adapter Framework, you can install the mySap.com v6.0.0.

The WebSphere Business Integration Adapter for mySAP.com must be installed
into the Adapter Framework.

To install the mySAP.com v6.0.0 adapter:

Browse to the directory where you saved the mySAP.com adapter.
Double-click setupwin32.exe.

Click OK and then click Next.

Accept the Software License Agreement, and click Next, Next, and Next.
Leave the InterChange Server field blank, and click Next.

Click Next and then click Finish.

oo kN~
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Configuring the WebSphere Business Monitor Server and CEl
Server with BPC

After installing the mySap.com adpater, you must configure the WebSphere
Business Monitor Server to run the SAP monitor model (SO_MMEAR.ear) and the
CEI Server with BPC to run the Business Object to Common Base Events converter
module (WBM_SAPApp.ear).

To configure the BPEL container (BPC) in the WebSphere Process Server where the
WBM_SAPApp.ear is going to be installed, see |http:/ /publib.boulder.ibm.com/ |
infocenter/dmndhelp / v6rxmx/topic/com.ibm.wsps.602.bpc.doc/doc/bpc/|
t2configovr.html|.

Configuring the WebSphere Business Integration Adapter
connection

After configuring the WebSphere Business Monitor Server and CEI Server with
BPC, you must configure the WebSphere Business Integration Adapter for SAP to
connect to your SAP ERP system.

To configure the sample WebSphere Business Monitor SAP adapter:

1. Save the adapter configuration (.cfg) file and the business-object definition
(.xsd) files to a folder. These files are located in the config directory of the
extracted SupportPac.

2. Open the SAP adapter configurator file and edit the configuration file.
3. Configure the standard properties for the adapter:
a. Click the Standard Properties tab.

b. Locate the jms.MessageBrokerName property, and set the value to
WBIA_QM:WBIA.JMS.SVRCONN:localhost:port where localhost and port are the
address and port of your WebSphere Process Server.

c. Locate the RepositoryDirectory property, and set the value to the location
where you saved the business-object definition (.xsd) files.

4. Configure the connector-specific properties for the adapter by completing the
following steps:

a. Click Connector-Specific Properties tab.

b. Set the values for the following properties based on the information in your
SAP system: ApplicationPassword, ApplicationUserName, Sysnr, Client,
and Hostname.

5. Select File » Save - To file to save the modifications.

6. Download the sapjco-ntintel-2.1.8.zip file from |http:/ /service.sap.com /|
and extract the file to a working directory. Copy sapijco.jar,
librfc32.dll, and sapjcorfc.dll to the SAP connectors directory for
WebSphereAdapters, for example, C:\IBM\ WebSphereAdapters\connectors\
SAP.

Note: You must have an SAPNet account to access the SAP JCo (if you do not
already have one, contact your local SAP Basis administrator).

7. Start the SAP adapter by completing the following steps:
a. From Windows, select Start » Run.
b. Type cmd in the Open field, and click OK.

c. Enter the following command: C:\IBM\WebSphereAdapters\connectors\SAP\
start_sap.bat WBM WAS -cD:\WBM_SAP\WBMConnector.cfg
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Note: C:\IBM\WebSphereAdapters\connectors\SAP\ is the folder where you
installed the adapter. WBM is the name of the adapter. WebSphere
Application Server is required by the Process Server.
-cD:\WBM_SAP\WBMConnector.cfg points to the configuration file for
your adapter.

Note: You must deploy the WBM_SAPApp.ear file successfully before starting the
WebSphere Business Integrator Adapter Framework. The deployed EAR file
creates the Queue Manager and Queues in the WebSphere Process Server
that WebSphere Business Integrator Adapter Framework connects to when
starting.

Configuring the SAP business workflow to emit business
objects

This procedure configures your SAP business workflow component to emit certain
business events whenever a particular business situation occurs. The SAP business
workflow and the event manager are core components of each SAP ERP system.

Configure the SAP system:
1. Find the SAP name of the business object:
a. Log on to the SAPGUL
b. Open the Business Object Browser using the SW02 shortcut.

c. Navigate through the Application Components tree until you find the
correct business object.

d. Double-click the business object, and select BO Data Model to get the data
model name of the object, for example, BUS2032 (SalesOrder).

2. Configure the SAP event manager to send business events to the WebSphere
Business Integration station:

a. Open the Event Type Linkages using the SWETYPV shortcut.

Click New Entries to add an entry for your object.

For the Object Category, select BOR Object Type.

For Object Type, specify the business object name, for example, BUS2032.

® oo o

Specify the event you want to catch from this business object, for example,
CREATED.

For Receiver Call, specify Function ModuTe.
For the Receiver Function Module, specify /CWLD/ADD_TO_QUEUE_DUMMY_47.

For the Receiver Type Function Module, specify /CWLD/
ADD_TO_QUEUE_WF_47.

i. Select Linkage Activated.

—h

S @

Configuring the WebSphere Business Integration Station to
process business events

The WebSphere Business Integration station is a part of the WebSphere Business
Integration Adapter for mySAP.com. It is the ABAP based portion which resides
within the SAP target system the adapter is communicating. The central
administration and configuration point for this component is the WebSphere
Business Integration station which can be reached by using shortcut
/CWLD/HOME.

Use the WebSphere Business Integration station to configure how business events
are collected and distributed to the external connector component.
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Configure the SAP event manager to send business events to the WebSphere
Business Integration station:

1.

2.

Navigate to the WebSphere Business Integration station using the /CWLD/HOME
shortcut.

Go to Tools » Config Objects to create an entry for the business event
configured in the event type linkage section, for example, SalesOrder.CREATED.

Note: This entry is case sensitive.

Go to Tools » Maintain Objects to create an entry for the business object the
adapter is going to process, for example, SO_CREATED_SAP47_vbak.

Go to Configuration » Configuration Values to connect the two entries created.
This connection maps which business event correlates to which adapter
business object.

a. For the Configuration name, specify SalesOrder.CREATED.
b. For the Counter, specify 0.
c. For the Configuration value, specify SO_CREATED_SAP47_vbak.Retrieve

Note: Append the verb .Retrieve to the connection configuration value.
Go to Configuration » Event Distribution and configure the event distribution

a. Define a new entry with the object name and the Websphere Business
Integrator Adapter name (connector name).

b. Verify that the server is WAS.

Note: You must use this name for the business object which is picked up by
the adapter because the SupportPac looks for a created business
object XSD that uses this name.

Deploying the WBM_SAPApp.ear file

Use the Administrative Console of the WebSphere Process Server containing the
BPEL Container (BPC) to install the WBM_SAPApp.ear file.

To install the WBM_SAPApp.ear file:

1.

Start the Monitor server and open the administrative console by completing the
following steps:

a. In Windows, select Start » All Programs » IBM WebSphere > Process
Server 6.0 » Profiles > wbmonitor » Start the server .

b. In Windows, select Start > All Programs > IBM WebSphere » Process
Server 6.0 »> Profiles > wbmonitor > Administrative console .

c. Click Log in to login.
Install the EAR file by completing the following steps:

a. From the left menu of admin console, click Applications » Enterprise
Applications .

Click Install.

Browse to WBM_SAPApp.ear.
Click Next.

Click Step 9 Summary.

Click Finish.

Click Save to Master Configuration .

S@ "m0 ao0CT

When a confirmation dialogue opens, click Save.
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i. Click Start to start the application.

Deploying the SAP adapter monitor model

You can use the Administrative Console of the WebSphere Monitor Server to
deploy the SO_MMEAR .ear file for the SAP adapter.

If the CEI server is located in a different cell than the WebSphere Business Monitor
server, a service integration link must be created prior to completing this task. For
information on setting up the CEI server, see the following URLs:

¢ |http:/ /publib.boulder.ibm.com/infocenter/dmndhelp /v6rxmx/topic/ |
com.ibm.btools.help.monitor.doc/Doc/ tasks/administration /ad_crosscellcfg.html|

+ |http:/ /publib.boulder.ibm.com/infocenter /dmndhelp /v6rxmx/topic/|
com.ibm.btools.help.monitor.doc/Doc/tasks/administration /|
ad_cei_cfg_destqueue.html|

Complete the following steps to deploy the SO_MMEAR .ear file using the Setup

Wizard:
1. Log in to the WebSphere Administration Console by completing the following
steps:
a. Open a browser and navigate to the following URL: http://host_name:port/
ibm/console
where:

host_name is the fully qualified host name of the server where the
Monitor server is installed

port is the port used to access the console. (The default port is 9060.)
b. Enter your user ID and password. The user ID is required. A password is
required only if security is enabled.

c. Click Log in.

2. In navigation pane, click Applications > Monitor Models. The table lists all
currently installed monitor models.

3. Click monitor_model_version_link to display the Version Details page for the
selected monitor model.

4. Under Version Properties, click Setup Wizard to complete the monitor model
deployment. The Setup Wizard automatically advances to the next incomplete
step. If this is a new version of a monitor model, the Run Data Services
Generation step is the first step.

5. On the Run Data Services Generation step:

a. Specify the tablespace_file_path in the Table space properties file field.
This value defines the file where database TABLESPACE values are stored.
A default file is located in the following directory:

/Monitor_Home/install/mondb/default minimum_tablespace.properties
b. Specify the directory_path in the Output directory field. This value

defines the directory where Data Services Generation output is stored. The
default directory is:

/Monitor_Home/generation

C. Specify the capture_log_path in the Replication capture log path field.
This value specifies the location for the log files that are created by the
Data Movement Services start and stop capture server scripts. At the time
of script usage, the directory must exist on the same physical server where
the Monitor database exists.
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d. Specify the apply_log path in the Replication apply log path field. This
value specifies the location for the log files that are created by the Data
Movement Services start and stop apply server scripts. At the time of
script usage, the directory must exist on the same physical server where
the Data Mart database exists.

e. Specify the number_of minutes in the Database population interval field.
This value defines the number of minutes between data replication cycles
of the Data Movement Services.

f. Click Run to complete the Data Services Generation step. A message
displays at the top of the panel indicating the step is complete.

g. Click Next.

. On the Run Schema Create Scripts step, you must issue commands using the
DB2 command-line environment. To update the databases as a single
transaction, complete the following steps:

a. Open a DB2 command window, and change to the directory where Data
Services Generation output is stored. For example:

/Monitor Home/generation/schemagen/timestamp

b. Type the following commands:
db2 connect to monitor user dbZ2admin using password
db2 +c -stvf state.ddl

where:

monitor is the name of the Monitor database
db2admin is the user ID for the DB2 administrator
password is the password for the DB2 administrator

c. Open a second DB2 command window, and change to the directory where
Data Services Generation output is stored. For example:

/Monitor_Home/generation/schemagen/timestamp
d. Type the following commands:
db2 connect to datamart user dbZadmin using password
db2 +c -stvf datamart.ddl
where:
datamart is the name of the Monitor database
db2admin is the user ID for the DB2 administrator
password is the password for the DB2 administrator

. Choose one of the following options based on the outcome of the previous
steps:
* If the commands are successful, complete the following steps:

a. In the DB2 command window that is connected to the Data Mart
database, type the following commands:

db2 commit
db2 disconnect datamart
where datamart is the name of the Data Mart database

b. In the DB2 Command Window that is connected to the Monitor
database, type the following commands:

db2 commit
db2 disconnect monitor
where monitor is the name of the Monitor database
* If either of commands is not successful, complete the following steps:
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a. In the DB2 Command Window that is connected to the Data Mart
database, type the following commands:

db2 rollback
db2 disconnect datamart
where datamart is the name of the Data Mart database

b. In the DB2 Command Window that is connected to the Monitor
database, type the following commands:

db2 rollback
db2 disconnect monitor
where monitor is the name of the Monitor database

8. In the WebSphere Administrative Console, click Refresh. A message displays
at the top of the window indicating the step is complete.

9. Click Next.

10. On the Run DMS Create Scripts step, you must issue commands using the
DB2 command line environment.

a. Open a DB2 Command Window, and change to the directory where Data
Services Generation output is stored. For example:

[Monitor_Home/generation/schemagen/timestamp

b. Unzip DS_DMS_setup.zip file. The DS_DMS_setup.zip file contains the
start and stop scripts for capture server (in the source directory) and the
start and stop scripts for apply server (in the target directory).

c. Enter State_to_Datamart_setup_source. Provide the user ID and password
for the data sources and wait until the script finishes.

d. Enter State_to_Datamart_setup_target. Provide the user ID and password
for the data sources and wait until the script finishes.

e. Check the following logs for errors:
State_to_Datamart_setup_source.bat.log
State_to_Datamart_setup_target.bat.log

You can search the logs for keywords to determine if the commands were

successful or if they failed. Use the following keywords and phrases to
determine success or failure:

Success: Command returned status 0 to the command line.

Failure: ERROR; An error has occurred; Failed to connect to database;
An internal error has occurred; An error has occurred while processing
file

f. Change to the following directory:

/Monitor_home/generation/schemagen/timestamp/State to Datamart/
source

g. Open a db2cmd window and run the StartCapture_xx.bat file, where xx is
the number.

Note: You can stop the replication by running the StopCapture_yy.bat file.
h. Change to the following directory:

/Monitor_home/generation/schemagen/timestamp/State_to Datamart/
target
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i. Open a db2cmd window and run the StartApply_yy.bat file, where yy is
the number.

Note: You can stop the apply by running the StopApply_xx.bat file.

j. In the WebSphere Administrative Console, click Confirm. A message
displays at the top of the panel indicating the step is complete.

k. Click Next.

11. On the Import DB2 Cube Definition step, you must issue commands using the
DB2 command line environment.

a. Open a DB2 Command Window, and change to the directory where Data
Services Generation output is stored. For example:

/Monitor Home/generation/schemagen/timestamp

b. Optional: If this is the first time DB2 Cube Views is being initialized,
change to the /ibm/db2/sqillib/misc directory and format the Data Mart
database by typing the following commands:

db2 connect to datamart
db2 -tvf db2mdapi.sql
db2 disconnect datamart
where datamart is the name of the Data Mart database.

Note: After completing this command change back to the directory where
Data Services Generation output is stored.

c. Configure DB2 Cube Views by typing the following command:

db2mdapiclient -d datamart -u user ID -p password -i import_model.xml -m model _cv.xml -o import_response.xml
where:

datamart is the name of the Data Mart database

user_ID is the user ID for the DB2 administrator

password is the password associated with user_ID

d. In the WebSphere Administrative Console, click Confirm. A message
displays at the top of the panel indicating the step is complete.

e. Click Next.
12. On the Manage Alphablox Cube step:

Note: If the step fails, see the related link at the end of this topic for
information about troubleshooting.

a. Specify host_name in the Host name field. This value represents the host
name of the remote server where DB2® Alphablox is installed. For
example, hostname:Tocalhost.

b. Specify port_number in the RMI port field. This value represents the RMI
port of the remote server where DB2 Alphablox is installed. The RMI port
is listed in the SystemOut.log for WebSphere Portal. For example, Port
number:2810.

C. Select one of the following options based on the WebSphere Application
Server global security settings for WebSphere Portal:

* Disabled: Select this option if WebSphere Application Server global
security is disabled.

* Enabled: Select this option if WebSphere Application Server and
Monitor server global security is enabled.

d. Optional: If global security is enabled, specify theuser_ID in the User ID
field.
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e.

f.

g.

h.

Optional: If global security is enabled, specify the password in the
Password field. This value represents the password associated with the ID
in the User ID field.WebSphere Portal user with administrator authority.

Verify that the Portal Server is started. If the server is not started, you will
get CWMAX4204E error stating that the Manage Alphablox Cube step
failed.

Click Create to create the DB2 Alphablox cube. A message displays at the
top of the panel indicating the step is complete.

Click Next.

13. On the Configure CEI Distribution step:

a.
b.

Expand CEI Server Configuration.

Specify the event_group_lists in the Event group profile list name field.
This value represents the name of the event group profile list that is
associated with this monitor model. The default value is Event groups
Tist.

Select one of the following options for the Location based on the location
of the CEI server:

* Local: Choose this option if the CEI server is in the same cell as the
Monitor server.

* Remote: Choose this option if the CEI server is in a different cell than
the Monitor server.

Optional: If the CEI server is remote, specify the host_name in the Host
name field. This value represents the host name for the physical server
where the CEI server is configured.

Optional: If the CEI server is remote, specify the port_number in the RMI
port field. This value represents the RMI port for the physical server where
the CEI server is configured. The RMI port is listed in the SystemOut.log
for the CEI server.

Specify the cell_name in the Cell field. This value indicates the cell name in
which the event group profile list resource is configured.

Optional: If the scope is defined for the node or server level, select
node_name from the Nodes list. This value indicates the node name in
which the event group profile list resource is configured.

Optional: If the scope is defined for the server level, select server_name
from the Servers list. This value indicates the server name in which the
event group profile list resource is configured.

Select one of the following options based on the WebSphere Application
Server global security settings for the CEI server:

* Disabled: Select this option if WebSphere Application Server global
security is disabled.

* Enabled: Select this option if WebSphere Application Server and Monitor
server global security is enabled.

Optional: If global security is enabled, specify the user_ID in the User ID
field.

Optional: If global security is enabled, specify the password in the
Password field. This value represents the password associated with the ID
in the User ID field. WebSphere Application Server user with administrator
authority.

Select one of the following options for the Distribution mode value of the
monitor model after the Configure CEI Distribution is complete. The value
in the Current field indicates the current distribution mode for the model.
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14.

15.
16.

17.

* Inactive: Choose this option if you do not want the model to receive
events on the event queue.

* Inactive (event queue recoverable): Choose this option if you want the
model to receive, but not process, events on the event queue.

* Active: Choose this option if you want the model to receive events on
the event queue and process the events when started. This is the default
option for a new monitor model.

* Active (no new MC instances): Choose this option if you want the
model to receive events on the event queue and process the events when
started, but you do not want to create any new monitoring context
instances.

m. Click Apply to update the CEI server configuration. A message displays
at the top of the panel indicating the step is complete and the CEI
configuration has been initiated.

n. Click Next.

On the Confirm CEI Server Reboot step:

a. Reboot the CEI server.

b. Click Confirm. If the button is not available, wait for the CEI configuration
to finishing processing, refresh the page, and then click Confirm.

Click Finish.

Click Save, and then click Save to save all changes to the master
configuration.

Log out of the WebSphere Administrative Console.

Testing the WebSphere Business Monitor for SAP scenario

After setting up all components correctly it is possible to test the whole scenario.
This can be done by creating a new sales order document in the SAP ERP system —
to create a new sales order follow following steps:

To use this procedure, you must have an SAP IDES system installed and you must
include the SAPrules.xml file from the SupportPac in the root folder of your CEI
with BPC server profile.

Note: Custom SAP systems might require that you use different values in the

some of the fields described in the procedure.

Create a new Sales Order.

1.
2.
3.

Log on to the SAPGUL

Navigate to the Create Sales Order screen using the VAO01 shortcut.
Specify the following values:

* For Order Type, specify OR.

¢ For Sales Organization, specify 1000.

* For Distribution Channel, specify 10.

 For Division, specify 00.

Press Enter and specify the following values:

* For Sold-to party and Ship-to party, specify 1000.
¢ For PO Number, specify Monitor Test Order.

* For Distribution Channel, specify 10.

 For Material, specify P-100.
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¢ For Order Quantity, specify 2.
5. Click Save to store the sales order.
6. Repeat these steps to create another order.

Note: Check the status bar at the bottom of the SAPGUI to see which Sales Order
number has been given to the new sales order.

Displaying the business measure in the WebSphere Business
Monitor dashboard

You can use the standard portlets shipped with WebSphere Business Monitor to
visualize the business measure model included in the SO_MMEAR .ear file. To
display the business measures you need to create a dashboard and add portlets to
the dashboard.

To create a dashboard and add portlets:
1. Copy of the Instances portlet.

Note: Do not configure the original portlets because the configuration cannot
be removed once it is applied.

a. Click Administration at the top of the page, and then select Portal
Management > Portlets

For Search, select Title Contains and enter Instance in the Search text box.
Click Search.
Find the Instances portlet.

®ao0o

On the row containing the Instances portlet, click the icon for Copy portlet (

=)

f. Rename the copy portlet to My Instances.
g. Click OK.
2. Copy of the Key Performance Indicator portlet.

Note: Do not configure the original portlets because the configuration cannot
be removed once it is applied.

a. Click Administration at the top of the page, and then select Portal
Management - Portlets

b. For Search, select Title Contains and enter Key Performance Indicator in
the Search text box.

c. Click Search.
d. Find the Instances portlet.
e. On the row containing the Key Performance Indicator portlet, click the icon

for Copy portlet ()

f. Rename the copy portlet to My Key Performance Indicator.
g. Click OK.
3. 1. Copy of the Dimensional portlet.

Note: Do not configure the original portlets because the configuration cannot
be removed once it is applied.

a. Click Administration at the top of the page, and then select Portal
Management - Portlets
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b. For Search, select Title Contains and enter Dimensional in the Search text
box.

c. Click Search.
d. Find the Instances portlet.

e. On the row containing the Dimensional portlet, click the icon for Copy

portlet ( )

f. Rename the copy portlet to My Dimensional.
g. Click OK.
. Copy of the Gauge portlet.

Note: Do not configure the original portlets because the configuration cannot
be removed once it is applied.

a. Click Administration at the top of the page, and then select Portal
Management > Portlets

For Search, select Title Contains and enter Gauge in the Search text box.
Click Search.
Find the Instances portlet.

®aoo

On the row containing the Gauge portlet, click the icon for Copy portlet (

@)

f. Rename the copy portlet to My Gauge.

g. Click OK.

. Create new pages.

Click Administration » Portal User InterfaceManage Pages.

Click My Portal, and then click New Page.

In the Title field, type WBM_SAP and then select the one column layout.
Click OK and then OK again on the successful message page.

Click WBM_SAP, and then click New Page.

In the Title field, type Overview and then select the one column layout.
. Click OK and then OK again on the successful message page.

. Click New Page.

In the Title field, type Key Performance Indicators and then select the one
column layout.

S@ 0o o0 oy

j. Click OK and then OK again on the successful message page.

k. Click New Page.

[. In the Title field, type Dimensions and then select the one column layout.
m. Click OK and then OK again on the successful message page.

. Add portlets to the pages.

a. Locate the Overview page and click on the
b. Click Add portlets. Select My Instances, click OK, and then click Done.
c. Locate the Key Performance Indicators page and click on the Edit Page icon

(O
d. Click Add portlets. Select My Key Performance Indicator and My Gauge,
click OK, and then click Done.
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e. Locate the Dimensions page and click on the Edit Page icon (
f. Click Add portlets. Select My Dimensional, click OK, and then click Done.
g. Click My Portal to see the WBM_SAP tab.

7. Configure the views.

a. Click WBM_SAP » Overview, and then click the Configure icon ( ) for
My Instances view.

b. For Monitor model, select SO_MM, and for Monitoring context, select
SO_MM MC.

c. For Metrics, select SO_MM Key, Currency, TotalCountOfChanges,
NetValue and CreationDate, and then click Next, Next, Next and Finish.

d. Click WBM_SAP » Key Performance Indicators, and then click the

Configure icon ( ) for My Key Performance Indicators view.
e. Select MaxNetValue, MinNetValue, and TotalNetValue, and then click OK.

f. Click the Configure icon ( ) for My Guage view, select
AverageNetValue, and then click OK.

g. Click WBM_SAP » Dimensions, and then click the Configure icon ( )
for My Dimensional view.

h. Select MaxNetValue, MinNetValue, and TotalNetValue, and then click OK.

i. For Monitor model, select SO_MM, and for Cube, select SO_MM MC
CUBE.

j- In Available dimensions, select Measures, and then click Add next to
Column dimensions.

k. In Available dimensions, select Time, and then click Add next to Row
dimension.

I. Click Next and then OK
m. View the business data using the dashboard.

Troubleshooting the SAP adapter

Using the procedures in this section, you can troubleshoot some common problem
you might encounter with the SAP adapter.

For the latest updates to the documentation, see the WebSphere Business Monitor

Support Web site (http://www.ibm.com /support/search.wss?rs=802&tc=SSSRR3|
h q=6.0.2.1).

No business events arrive in the WebSphere Business Monitor

Server

Verify that the version of WebSphere Integration Developer is consistent with the
WebSphere Business Monitor where the model is deployed, for example, use
WebSphere Integration Developer v6.0.2.x and WebSphere Business Monitor
v6.0.2.x. The Common Base Event definitions generated from WebSphere
Integration Developer might not be consistent with the Common Base Events
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generated from the WebSphere Process Server if use v6.0.1.x with v6.0.2.x versions
together. That inconsistency causes monitoring to fail.

Error: Project WBM_SAPApp is missing required Java project
‘websphere_default_messaging_provider’

Problem: This error occurs after using WebSphere Integration Developer problem
to import the Project Interchange file.

Solution: Delete the adapter export and recreate it with Enterprise Service
Discovery Wizard.

1. In the Java perspective, right-click WBM_SAPApp, and select Properties.

2. Click Java Build Path, and clear websphere_default_messaging_provider both
on the Order and Export page and the Projects page.

3. Rebuild the project.

Error: Missing the trigger sources

Problem: In some cases, the information about the trigger source is not included
when the Project Interchange file is used to import the source code.

Solution: Verify the conversion logic of mapping the business object to the
common base event in the XML file.

You must place the SAPrules.xml file from the SupportPac in the root folder of
your server’s profile.

Tips

In the SAP system, the targeted name events for the connector must end with
Connector. When starting the WebSphere Business Integration Adapter, name the
connector without Connector. For example: define WBMConnector in the SAP system,
and then start the WebSphere Business Integrator Adapter with the WBM name. The
WebSphere Business Integration Adapter configuration sets the name to
WBMConnector

The conversion logic must be in the same module as the code to export the
adapter. Creating a Service Component Architecture reference to another module
results in problems with the org.eclipse.emf.ecore.xml.type.impl. AnyTypelmpl class
that cannot be resolved. When defining interface maps, use Web Services
Description Language (WSDL) interfaces as source and target interfaces. You
cannot mix WSDL and Java interfaces.
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