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JDBC Sample Adapter SupportPac

The JDBC Sample Adapter SupportPac contains a sample demonstrating how to
use the WebSphere® JDBC adapter from a monitor model.

The WebSphere JDBC adapter processes information and delivers it to the
WebSphere Business Monitor to be viewed using a dashboard. The sample JDBC
adapter (called MonitorAdapter) shipped in the SupportPac has two components:

JDBCInboundInterface
The JDBC inbound interface invokes the mediation with the payload when
a record is inserted into the database.

MediationFilter
The MediationFilter resides within the mediation flow and filters the
records by customer type (gold customer or normal customer).

The monitor model for this sample contains metrics to monitor the data issued

from the JDBC adapter and display them in a dashboard. The following figure
illustrates the business-level diagram of the MonitorAdapter module.
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Based on the Service Component Architecture (SCA) operation and the mediation
flow, a monitor model is generated. The metrics are added using the Monitor
Model Editor. These metrics are then used to monitor the data from the adapter
and mediation flow.

The results are then shown in the Instances and Dimensional views on a
dashboard.

© Copyright IBM Corp. 2007 1



JDBC Sample Adapter SupportPac install

Install the JDBC Sample Adapter monitor model provided with the SupportPac
using these procedures.

For the latest updates to the documentation, see the WebSphere Business Monitor

Support Web site (http://www.ibm.com /support/search.wss?rs=802&tc=SSSRR3)
&q=6.0.2.1)).

Prerequisites for a WebSphere adapter

This section identifies the products required to install, configure, and deploy the
WebSphere adapter.

To use this SupportPac, you must have a licensed installation of IBM WebSphere
Business Monitor v6.0.2.1 on your system. If you have not upgraded to v6.0.2.1,
you do must upgrade before using the SupportPac. To upgrade to WebSphere
Business Monitor v6.0.2.1, see the Release Notes (http:/ /publib.boulder.ibm.com /|
infocenter/dmndhelp /v6rxmx/index.jsp?topic=/com.ibm.btools.help.monitor.doc/|
Doc/concepts/release_readme/rn_aboutthisrelease.html) on the WebSphere
Business Monitor Information Center for information on upgrading. You must also
have a working knowledge of the WebSphere Business Monitor programming
model and have used the product as well as the WebSphere Business Monitor
Development Toolkit, the WebSphere Business Monitor Server, and dashboards.

For the latest updates to the documentation, see the WebSphere Business Monitor

Support Web site (http:/ /www.ibm.com /support/search.wss?rs=802&tc=SSSRR3|
&q=6.0.2.1)).

Verify that the following software is installed on the system along with WebSphere
Business Monitor:

* WebSphere Business Monitor v6.0.2.1 (all components: server, dashboard and
databases)
* WebSphere Integration Developer v6.0.2

* WebSphere Monitor Development Toolkit V6.0.2 (IDE)

Getting the JDBC SupportPac
The JDBC SupportPac is available as a Web download.

1. Go to http:/ /www.ibm.com/support/docview.wss?rs=171&uid=swg] and
download the JDBC SupportPac.

2. Extract the files into a working directory. Verify that your working directory
contains the following files:
* ProjectInterchange file (MonitorAdapter.zip)
* EAR files (MonitorAdapter.ear and MonitorAdapterApp.ear)
 Installation doc (PDF file)

Deploying the sample adapter and mediation application

Use the WebSphere Process Server administrative console to install the
MonitorAdapterApp.ear file.

Note: Use the WebSphere Process Server where the Monitor server resides to
deploy the MonitorAdapterApp.ear file.

To install the MonitorAdapterApp.ear file:
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. Start the Monitor server and open the administrative console by completing the
following steps:

a. In Windows®, select Start > All Programs > IBM WebSphere > Process
Server 6.0 » Profiles > wbmonitor » Start the server .

b. In Windows, select Start > All Programs » IBM WebSphere > Process
Server 6.0 » Profiles > wbmonitor » Administrative console .

c. Click Log in to login.

. Configure the J2C Authentication Data by completing the following steps:

a. From the left menu, click Security > Global Security .

b. Select Authentication » JAAS Configuration » J2C Authentication Data .
c. Click New.
d

. Specify the Alias as JDBCAdapter/inbound. Note: This should be consistent
with the value set in Partl and does not contain Node name.

e. Specify db2dmin as the UserID.
Type the password for the db2admin.

—n

Click Apply. Two messages might display at this point, one indicating that
changes have been made and the other might indicate that the server needs
to be restarted.

@

h. Click Save. A Global security window might open, click Save again.

i. Verify that the new entry is in the list. The entry will have <NodeName>/
added to the beginning of the name.

. Install the EAR file by completing the following steps:

a. From the left menu of admin console, click Applications » Enterprise
Applications .

Click Install.

Browse to MonitorAdapterApp.ear.
Click Next.

Click Step 9 Summary.

Click Finish.

Click Save to Master Configuration .

Se "o 00T

When a confirmation dialogue opens, click Save.
. Start the JDBC monitor adapter by completing the following steps:

a. From the welcome page, select Applications » Enterprise Application . The
newly installed MonitorAdaterApp application is in the list.

b. Select MonitorAdapterApp , and click Start. If the application did not start,
see Troubleshooting.

. Test the application to verify that it is working properly by performing the
following steps:

a. Run the following commands in db2cmd console:
db2 connect to ADAPTER user db2admin using <db2admin password="">
db2 insert into customer values ('1', 'Yi', 'Che', 'Regular')

b. From the left menu of the Administrative console, select Integration
Application » Common Base Event Browser and wait for CBE browser to
initialize.

c. From the left menu of CBE browser, select All Events. Locate the events
related with the record you inserted in the previous step.

d. Run the following commands in db2 cmd console to add a customer who is
a Gold one.
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db2 insert into customer values ('2', 'James', 'Bond', 'Gold')
db2 disconnect ADAPTER

e. From the top menu of the CBE browser, select Get Events. Wait while the
browser updates.

f. Select All Events again. Locate the
MonitorAdapter_MediationFilter_Req_After event that demonstrates the
filter works and recognizes the customer is classified as Gold.

Deploying a monitor model

You can use the WebSphere Administrative Console to deploy an installed version
of a monitor model.

If the CEI server is located in a different cell than the WebSphere Business Monitor
server, a service integration link must be created prior to completing this task. For
information on setting up the CEI server, see the following URLs:

* |http:/ /publib.boulder.ibm.com/infocenter /dmndhelp /v6rxmx/topic/|
com.ibm.btools.help.monitor.doc/Doc/ tasks/administration/ad_crosscellcfe. html|

« |http:/ /publib.boulder.ibm.com/infocenter /dmndhelp /v6rxmx/topic/|
com.ibm.btools.help.monitor.doc/Doc/tasks/administration /| |
ad_cei_cfg_destqueue.html|

Complete the following steps to deploy the monitor model using the Setup Wizard:
1. Log in to the WebSphere Administration Console by completing the following

steps:

a. Open a browser and navigate to the following URL: http://host_name:port/
ibm/console
where:

host_name is the fully qualified host name of the server where the
Monitor server is installed

port is the port used to access the console. (The default port is 9060.)

b. Enter your user ID and password. The user ID is required. A password is
required only if security is enabled.

c. Click Log in.

2. In navigation pane, click Applications » Monitor Models. The table lists all
currently installed monitor models.

3. Click monitor_model_version_link to display the Version Details page for the
selected monitor model.

4. Under Version Properties, click Setup Wizard to complete the monitor model
deployment. The Setup Wizard automatically advances to the next incomplete
step. If this is a new version of a monitor model, the Run Data Services
Generation step is the first step.

5. On the Run Data Services Generation step:

a. Specify the tablespace_file_path in the Table space properties file field.
This value defines the file where database TABLESPACE values are stored.
A default file is located in the following directory:

[Monitor_Home/install/mondb/default_minimum_tablespace.properties

b. Specify the directory_path in the Output directory field. This value
defines the directory where Data Services Generation output is stored. The
default directory is:

/Monitor_Home/generation
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C. Specify the capture_log_path in the Replication capture log path field.
This value specifies the location for the log files that are created by the
Data Movement Services start and stop capture server scripts. At the time
of script usage, the directory must exist on the same physical server where
the Monitor database exists.

d. Specify the apply_log path in the Replication apply log path field. This
value specifies the location for the log files that are created by the Data
Movement Services start and stop apply server scripts. At the time of
script usage, the directory must exist on the same physical server where
the Data Mart database exists.

e. Specify the number_of minutes in the Database population interval field.
This value defines the number of minutes between data replication cycles
of the Data Movement Services.

f. Click Run to complete the Data Services Generation step. A message
displays at the top of the panel indicating the step is complete.

g. Click Next.

6. On the Run Schema Create Scripts step, you must issue commands using the
DB2 command-line environment. To update the databases as a single
transaction, complete the following steps:

a. Open a DB2 command window, and change to the directory where Data
Services Generation output is stored. For example:

/Monitor Home/generation/schemagen/timestamp

b. Type the following commands:
db2 connect to monitor user dbZ2admin using password
db2 +c -stvf state.ddl

where:

monitor is the name of the Monitor database
db2admin is the user ID for the DB2 administrator
password is the password for the DB2 administrator

c. Open a second DB2 command window, and change to the directory where
Data Services Generation output is stored. For example:

/Monitor Home/generation/schemagen/timestamp

d. Type the following commands:
db2 connect to datamart user dbZadmin using password
db2 +c -stvf datamart.ddl

where:

datamart is the name of the Monitor database
db2admin is the user ID for the DB2 administrator
password is the password for the DB2 administrator

7. Choose one of the following options based on the outcome of the previous
steps:

¢ If the commands are successful, complete the following steps:

a. In the DB2 command window that is connected to the Data Mart
database, type the following commands:

db2 commit
db2 disconnect datamart

where datamart is the name of the Data Mart database
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b. In the DB2 Command Window that is connected to the Monitor
database, type the following commands:

db2 commit
db2 disconnect monitor
where monitor is the name of the Monitor database
* If either of commands is not successful, complete the following steps:

a. In the DB2 Command Window that is connected to the Data Mart
database, type the following commands:

db2 rollback
db2 disconnect datamart
where datamart is the name of the Data Mart database

b. In the DB2 Command Window that is connected to the Monitor
database, type the following commands:

db2 rollback
db2 disconnect monitor
where monitor is the name of the Monitor database

8. In the WebSphere Administrative Console, click Refresh. A message displays
at the top of the window indicating the step is complete.

9. Click Next.

10. On the Run DMS Create Scripts step, you must issue commands using the
DB2 command line environment.

a. Open a DB2 Command Window, and change to the directory where Data
Services Generation output is stored. For example:

[Monitor_Home/generation/schemagen/timestamp

b. Unzip DS_DMS_setup.zip file. The DS_DMS_setup.zip file contains the
start and stop scripts for capture server (in the source directory) and the
start and stop scripts for apply server (in the target directory).

c. Enter State_to_Datamart_setup_source. Provide the user ID and password
for the data sources and wait until the script finishes.

d. Enter State_to_Datamart_setup_target. Provide the user ID and password
for the data sources and wait until the script finishes.

e. Check the following logs for errors:
State_to_Datamart_setup_source.bat.log
State_to_Datamart_setup_target.bat.log

You can search the logs for keywords to determine if the commands were

successful or if they failed. Use the following keywords and phrases to
determine success or failure:

Success: Command returned status 0 to the command line.

Failure: ERROR; An error has occurred; Failed to connect to database;
An internal error has occurred; An error has occurred while processing

file
f. Change to the following directory:

/Monitor_home/generation/schemagen/timestamp/State_to_Datamart/
source

g. Open a db2cmd window and run the StartCapture_xx.bat file, where xx is
the number.
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Note: You can stop the replication by running the StopCapture_yy.bat file.
h. Change to the following directory:

/Monitor_home/generation/schemagen/timestamp/State_to_Datamart/
target

i. Open a db2cmd window and run the StartApply_yy.bat file, where yy is
the number.

Note: You can stop the apply by running the StopApply_xx.bat file.

j. In the WebSphere Administrative Console, click Confirm. A message
displays at the top of the panel indicating the step is complete.

k. Click Next.

11. On the Import DB2 Cube Definition step, you must issue commands using the
DB2 command line environment.

a. Open a DB2 Command Window, and change to the directory where Data
Services Generation output is stored. For example:

/Monitor Home/generation/schemagen/timestamp

b. Optional: If this is the first time DB2 Cube Views is being initialized,
change to the /ibm/db2/sqil1ib/misc directory and format the Data Mart
database by typing the following commands:

db2 connect to datamart
db2 -tvf db2mdapi.sql
db2 disconnect datamart
where datamart is the name of the Data Mart database.

Note: After completing this command change back to the directory where
Data Services Generation output is stored.

c. Configure DB2 Cube Views by typing the following command:

db2mdapiclient -d datamart -u user_ID -p password -i import_model.xml -m model_cv.xml -o import_response.xml
where:

datamart is the name of the Data Mart database

user_ID is the user ID for the DB2 administrator

password is the password associated with user_ID

d. In the WebSphere Administrative Console, click Confirm. A message
displays at the top of the panel indicating the step is complete.

e. Click Next.
12. On the Manage Alphablox Cube step:

Note: If the step fails, see the related link at the end of this topic for
information about troubleshooting.

a. Specify host_name in the Host name field. This value represents the host
name of the remote server where DB2® Alphablox is installed. For
example, hostname:Tocalhost.

b. Specify port_number in the RMI port field. This value represents the RMI
port of the remote server where DB2 Alphablox is installed. The RMI port
is listed in the SystemOut.log for WebSphere Portal. For example, Port
number:2810.

C. Select one of the following options based on the WebSphere Application
Server global security settings for WebSphere Portal:

* Disabled: Select this option if WebSphere Application Server global
security is disabled.
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d.

e.

f.

g.

h.

* Enabled: Select this option if WebSphere Application Server and
Monitor server global security is enabled.

Optional: If global security is enabled, specify theuser_ID in the User ID
field.

Optional: If global security is enabled, specify the password in the
Password field. This value represents the password associated with the ID
in the User ID field. WebSphere Portal user with administrator authority.

Verify that the Portal Server is started. If the server is not started, you will
get CWMAX4204E error stating that the Manage Alphablox Cube step
failed.

Click Create to create the DB2 Alphablox cube. A message displays at the
top of the panel indicating the step is complete.

Click Next.

13. On the Configure CEI Distribution step:

a.
b.

Expand CEI Server Configuration.

Specify the event_group_lists in the Event group profile list name field.
This value represents the name of the event group profile list that is
associated with this monitor model. The default value is Event groups
Tist.

Select one of the following options for the Location based on the location
of the CEI server:

* Local: Choose this option if the CEI server is in the same cell as the
Monitor server.

* Remote: Choose this option if the CEI server is in a different cell than
the Monitor server.

Optional: If the CEI server is remote, specify the host_name in the Host
name field. This value represents the host name for the physical server
where the CEI server is configured.

Optional: If the CEI server is remote, specify the port_number in the RMI
port field. This value represents the RMI port for the physical server where
the CEI server is configured. The RMI port is listed in the SystemOut.log
for the CEI server.

Specify the cell_name in the Cell field. This value indicates the cell name in
which the event group profile list resource is configured.

Optional: If the scope is defined for the node or server level, select
node_name from the Nodes list. This value indicates the node name in
which the event group profile list resource is configured.

Optional: If the scope is defined for the server level, select server_name
from the Servers list. This value indicates the server name in which the
event group profile list resource is configured.

. Select one of the following options based on the WebSphere Application

Server global security settings for the CEI server:

* Disabled: Select this option if WebSphere Application Server global
security is disabled.

* Enabled: Select this option if WebSphere Application Server and Monitor
server global security is enabled.

Optional: If global security is enabled, specify the user_ID in the User ID
field.
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14.

15.
16.

17.

k. Optional: If global security is enabled, specify the password in the
Password field. This value represents the password associated with the ID
in the User ID field.WebSphere Application Server user with administrator
authority.

I. Select one of the following options for the Distribution mode value of the
monitor model after the Configure CEI Distribution is complete. The value
in the Current field indicates the current distribution mode for the model.

Inactive: Choose this option if you do not want the model to receive
events on the event queue.

Inactive (event queue recoverable): Choose this option if you want the
model to receive, but not process, events on the event queue.

Active: Choose this option if you want the model to receive events on
the event queue and process the events when started. This is the default
option for a new monitor model.

Active (no new MC instances): Choose this option if you want the
model to receive events on the event queue and process the events when
started, but you do not want to create any new monitoring context
instances.

Click Apply to update the CEI server configuration. A message displays
at the top of the panel indicating the step is complete and the CEI
configuration has been initiated.

n. Click Next.
On the Confirm CEI Server Reboot step:
a. Reboot the CEI server.

b. Click Confirm. If the button is not available, wait for the CEI configuration

to finishing processing, refresh the page, and then click Confirm.

Click Finish.

Click Save, and then click Save to save all changes to the master
configuration.

Log out of the WebSphere Administrative Console.
Related tasks

[‘Troubleshooting the JDBC Sample Adapter” on page 11|

Using the procedures in this section you can troubleshoot some common
problems that you might encounter with the JDBC adapter.

Running events to exercise the model

This procedure tests the monitor model.

1. Run the following commands in the db2cmd console:

L

b
c
d.
e

f.

db2 connect to ADAPTER user db2admin using <db2admin password>

db2 insert into customer values ('3', 'Michael', 'Davis', 'Regular')
db2 insert into customer values ('4', 'Paul', 'Smith', 'Silver')

db2 insert into customer values ('5', 'Joe', 'Williams', 'Gold'")

db2 insert into customer values ('6', 'Daniel', 'Johnson', 'Regular')

db2 insert into customer values ('7', 'Tim', 'Ross', 'Gold')
g. db2 disconnect ADAPTER
2. Wait for the monitor model to process the events.

3. Verify that the Monitor is processing the events properly.

a. Open the DB2 Control Center. In Windows, select Start » All Programs -
IBM DB2 » General Administrative Tools > Control Center
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b.

d.

In the MONITOR database, open the CTX_MONITORADAPTERMM_MC
table.

Note: The Replication Manager daemons are running, so do not be alarmed
if you do not see records. Some records might have already been
moved to the DATAMART database and deleted from the MONITOR
database. If this is the case, proceed to the next step to check the
DATAMART database.

In the DATAMART database, open the FCT_MONITORADAPTERMM_MC
table. You might have to wait a few minutes for the Replication Manager
daemons to run. If so, wait a few minutes, then select View > Refresh in the
Control Center.

Close the DB2 Control Center.

Creating an adapter dashboard to display data from the JDBC
adapter monitor model

Using the WebSphere Portal Server build and configure dashboards with portlets
for the adapter. This dashboard example uses the Dimensional View and Instances
portlet.

To create an adapter dashboard for the sample:

1. Log into WebSphere Portal Server:

a.

b.

Open the Portal page in a browser using http://localhost:<port>/wps/
portal.

Click Log in, and enter your Portal administrative user ID and password.

2. Create copies of the Dimensional View and Instances portlets:

a.

Click Administration at the top of the page, and then click Portlet
Management > Portlets.

Browse to page 10. You can get to this page by clicking the arrow icons or
by entering the page number in the Jump to page navigation box and then
clicking the arrow icon. This page shows the portlets for Dimensional View
and Instances.

C. On the row containing Dimensional View, click the Copy portlet icon.
d. Specify MonitorAdapter_Dimensional as the new name, and click OK.
e.
f.
g

On the row containing Instances, click the Copy portlet icon.
Specify MonitorAdapter_Instances as the new name, and click OK.

. Browse to page 11 by clicking the arrow icons. This page shows the KPI

view portlet as well as the copies of the Dimensional and Instances portlets

3. Create a new portal page:

a.

a oo

e.

Click Administration at the top of the page, and click Portal User Interface
» Manage Pages.

Click My Portal, and click New Page.

Enter MonitorAdapter for the title.

For Type of Page, select one-column layout.

Click OK twice to see the new page in the list of portal pages.

4. Edit the new portal page:

a.
b.

Click the Edit Page Layout icon for the dashboard.
Click Add portlets.
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c. Navigate to the bottom of the list to select the
MonitorAdapter_Dimensional and MonitorAdapter_Instances portlets.

d. Click OK. Confirm that the views have been added to the page.
e. Click Done.

f. Click My Portal at the top of the page. Confirm that the MonitorAdpater tab
appears on the Welcome page.

5. Configure the Dimensional view on the MonitorAdapter page:
a. Select the MonitorAdapter tab.
Click the Configure icon on the MonitorAdapter_Dimensional view.
Select MonitorAdapterMM for the monitor model.
Select MONITORADAPTERMM MC CUBE <timestamp> for the Cube.

In Available dimensions, select Measures, and then click Add next to
Column dimensions.

® oo 0o

f. In Available dimensions, select CCode Dimension, and then click Add next
to Row dimensions.

g. Click Next
h. Right-click InstancesCount and select Member Filter.
i. In the Member Filter window, select FName Count Measure, and click Add.
j. Click OK.
k. Right-click All, and select Drill Down.
[. Click OK.
6. Configure the Instances view on the MonitorAdapter page:
a. Click the Configure icon for the MonitorAdapter_Instances view.
Select MonitorAdapterMM for the monitor model.
Select MonitorAdapterMM MC for the Monitoring context
Select Select All for the Metrics, and clearMonitorAdapterMM Key.
Accept all the other settings, and click Finish.

®oouo

Troubleshooting the JDBC Sample Adapter

Using the procedures in this section you can troubleshoot some common problems
that you might encounter with the JDBC adapter.

For the latest updates to the documentation, see the WebSphere Business Monitor

Support Web site (http:/ /www.ibm.com/support/search.wss?rs=802&tc=SSSRR3

q=6.0.2.1).
Related tasks
[‘“Deploying a monitor model” on page 4
You can use the WebSphere Administrative Console to deploy an installed
version of a monitor model.

No business events arrive in the WebSphere Business Monitor
Server

Verify that the version of WebSphere Integration Developer is consistent with the
WebSphere Business Monitor where the model is deployed, for example, use
WebSphere Integration Developer v6.0.2.x and WebSphere Business Monitor
v6.0.2.x. The Common Base Event definitions generated from WebSphere
Integration Developer might not be consistent with the Common Base Events
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generated from the WebSphere Process Server if use v6.0.1.x with v6.0.2.x versions
together. That inconsistency causes monitoring to fail.

Application does not start when deploying the JDBC sample
adapter EAR file

If the application does not start after the adapter is insatlled, the reason might be
that the database IP address has changed. If your database is remote and the IP
has been changed or is different from the one used when creating the module,
reconfigure the database IP address using the following procedure:

1.

2.
3.
4.

In the WebSphere Administrative Console, click Applications > Enterprise
Applications » MonitorAdapterApp » Connector Modules -
CWYBC_JDBC.rar » Resource Adapter » J2C Activation specifications -
MonitorAdapter.JDBCInboundInterface_ASJ2C activation specification
custom properties.

Click databaseURL, and modify the database IP.

Click OK.

Click Save twice to save and finish the configuration.

Error occurs when cubes are imported

If you receive an error while importing the cubes, you must format the database
for OLAP. Use the following procedure to format the database:

1.

ook~ 0D

Open a command window.

Enter cd %DB2 Home%\SQLLIB\MISC.
Enter db2 connect to datamart.

Enter db2 -tvf db2mdapi.sql.

Enter db2 disconnect datamart.
Import the cubes into DB2 OLAP again.

Connection error

If you receive a connection error when running Step 5 of the life-cycle steps, use
the following procedure as a workaround. In this procedure, you manually import
the cube in Alphablox, and then mark the step as complete in the life-cycle table.

1.

2.

Copy the cube name from OLAP Center by completing the following steps:
a. In Windows, select Start » All Programs » IBM DB2 ~» Business
Intelligence Tools > OLAP Center.

b. Enter your DB2 user ID and password. The ODLAP Center opens listing the
Cube Models.

c. Right-click the cube model, and select Properties.

d. Select the text in the Name field, and press Ctrl+C to copy the text to the
clipboard.

e. Click Cancel, and close the OLAP Center.
Define the cube to Alphablox:

a. If the WebSphere Portal server is not running, start it by selecting Start ~»
All Programs » IBM WebSphere » WebSphere Portal v5.1 » Start the
Server.

b. Start Alphablox in a browser by selecting Start > All Programs » IBM DB2
Alphablox 8.4 > AlphabloxAnalytics » DB2 Alphablox Administrative
Pages. Note: The DB2 Alphablox Cube name must match the Cube Model
name exactly, but without the WBI prefix.
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When prompted, enter the user ID and password.

Click the Cubes page, and click Create.

Next to the DB2 Alphablox Cube Name, select Enabled.

Press Ctrl+V to replace New Cube with the correct cube name.

For the Relational Data Source, select DATAMART , and then select Enable
DB2 Cube Views Settings.

h. From the Cube Model, select the model, and then click Import Cube
Definition.

@ m o oo

Note: The DB2 Alphablox Cube Name must match the Cube Model name
exactly except for the WBI prefix.

i. Click OK to save the definition. Confirm that is was added to the list.

j. Click the General page and click Runtime Management » DB2 Alphablox
Cubes.

k. Select the cube in the list, and click Start. The status for the cube is now
Running.

. Find the Model ID and version number:

a. Find the ModelID value. Click Select Applications »+ Monitor Models and
locate the ID. ModelID is the name listed in the Model column.

b. Locate the WebSphere Process Server log. The log might be found in a
directory such as C:\wps602\profiles\wbmonitor\logs\server1\
SystemOut.log.

c. Search for "/ModelID" version in the log file. Where ModellD is the name
of the model.

d. The versionDate follows the word version and looks similar to 1170240826.
. Update the life cycle using an MBean method:

a. Open a command prompt window by selecting Start » Run , entering cmd,
and clicking OK.

b. Enter cd %WAS_HOME%\profiles\wbmonitor\bin to change to the monitor
directory.

c. Enter wsadmin to connect to the server.
d. Enter the following command to set the Lifecycle services:
set 1s [$AdminControl completeObjectName type=LifecycleServices,=]

e. Enter the following commands to confirm the Alphablox cubes were
created:

$AdminControl invoke $1s confirmCreateAlphabloxCube { "model ID", version date, “user ID" ]
Where:

model_ID
Represents the name of the monitor model.

version_date
Represents the timestamp of the version of the monitor model and
is defined by the number of seconds since 1970

user_ID
The user ID of the command originator
For example:
$1s confirmCreateAlphabloxCube { "MonitorModelSampleMM" 1170240826 "administrator"}
f. Return to the Process Server Administrative Console.
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g. If the Administrative Console Step 5 of the lifecycle is still displaying,
reload the page in the browser. Step 5 is then marked complete.

h. Return to the instructions for the life-cycle steps starting at Step 6.

Cleaning out the message queue

Events that are not processing properly generate messages that get caught in the
message queues. Clean the message queues:

1.
2.

N o o s

Login to the Monitor Server Administration Console.

Select Service Integration > Buses > MONITOR..Bus » Messaging Engines -
serverl. MONITOR..Bus » Queue Points

Note: Queue Points is located under the Message points heading.

Locate your monitor model. There are two queues, a Model/version_Q and a
Model/Version_Q_A queue.

Click Model/Version_Q queue.

Click the Runtime tab.

Click Messages under Additional Properties.

You can:

* Delete the message that is in error.

* Delete the messages one at a time until the queue is unclogged.
* Delete them all.

Save your changes.
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