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IS02: WebSphere Message Broker Explorer plug-in for  
WebSphere MQ Explorer 
 

Abstract 
WebSphere MQ Explorer is an Eclipse-based graphical configuration tool that is 
provided with WebSphere MQ V6. In WebSphere MQ Explorer you can configure 
your queue managers and other objects. You can extend WebSphere MQ Explorer to 
manage other resources as well. 
 
This plug-in enhances WebSphere MQ Explorer so that you can administer a 
WebSphere Message Broker network. After installing the plug-in, the following 
features are available in the Navigator view: 
 

• Display remote and local brokers in MQExplorer Navigator view. 
• View information and help in the Content view for each configuration 

manager, broker, execution group, flow. 
• Create and delete local brokers without using the command line. 
• Start, stop, create, and delete brokers, execution groups and message flows. 
• Display and delete message flow resources in the Navigator view. 
• Connect to local and remote Configuration Managers with optional 

WebSphere MQ security. 
• Import and export Configuration Manager connection files. 
• Associate a local broker with a local Configuration Manager. All WebSphere 

MQ channels and listeners are automatically created between the local broker 
and local Configuration Manager’s queue managers. 

• Associate a local or remote Configuration Manager with a named broker. 
• Determine which queue managers are associated with brokers, and the name 

of the queue manager that is associated with each broker. 
• Deploy a broker archive (bar) file to multiple execution groups in a single 

step. 
• Display event log events from the selected Configuration Manager or broker 

in the Event Log view. 
• Automatically restore connection parameters when you restart WebSphere 

MQ Explorer (the Broker Explorer state is saved between sessions). 
• Customize Broker Explorer in the Preference pages. 
• Get full service tracing. 
• Get WebSphere Message Broker accounting and statistics information. 
• Configure DataPower appliance to handle WS Security 
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Screenshot of IS02 
 

 
 
 



 - 3 - 

Table of Contents 
 
IS02: WebSphere Message Broker Explorer plug-in for WebSphere MQ Explorer .... 1 

Abstract................................................................................................................. 1 
Screenshot of IS02................................................................................................. 2 
Prerequisites .......................................................................................................... 5 
Migrating from a previous version of IS02 ............................................................ 5 

V1 ..................................................................................................................... 5 
V2 ..................................................................................................................... 5 

Installation Instructions ......................................................................................... 6 
First Steps.............................................................................................................. 7 

Creating the Default Configuration ....................................................................7 
Using the Samples ............................................................................................. 8 

Importing existing bar files, server projects and connection files ........................... 9 
Importing a WebSphere Message Broker V6 connection file ............................10 

Creating an Execution Group................................................................................11 
Deleting an Execution Group................................................................................11 
Deploying to an Execution Group.........................................................................11 
Connecting to a Configuration Manager ...............................................................12 
Removing a Configuration Manager .....................................................................13 
Exporting a WebSphere Message Broker V6 connection file ................................13 
Importing a WebSphere Message Broker V6 connection file ................................13 
Adopting a Broker ................................................................................................14 
Event Log viewer .................................................................................................16 
Preference Pages ..................................................................................................17 

Main Preferences..............................................................................................17 
Service Trace....................................................................................................18 

Accounting and Statistics......................................................................................20 
Starting the Accounting and Statistics plugin ....................................................20 
Controlling Accounting and Stats .....................................................................20 
Viewing Statistics Data.....................................................................................20 

Shell Sharing with Message Broker Tooling v601 and v602 .................................21 
DataPower Security Wizard..................................................................................22 

An example of an XML Firewall Policy created by Broker Explorer.................23 
Starting the wizard............................................................................................23 
Policy Set Editor...............................................................................................24 
Connection Profiles Wizard ..............................................................................25 
Naming your XML Firewall .............................................................................26 
Crypto Profiles .................................................................................................26 
Final Steps........................................................................................................26 

Setting up JMS for use with IS02..........................................................................28 
Resolutions to problems .......................................................................................28 

No Brokers directory is displayed after installation ...........................................28 
Deployment problems.......................................................................................28 
“Cannot find MQSeries JMS libraries. You must install MQSeries classes for 
Java Message Service on this machine” and related JMS Errors........................29 
Stats and Accounting gives a JMS error and asks me to set up JMS ..................30 
No graph view appears for the Broker Statistics................................................30 



 - 4 - 

Other JMS related errors (While using Accounting and Statistics or the 
DataPower wizard) ...........................................................................................30 
Connecting to a remote Configuration Manager................................................30 

Known Restrictions ..............................................................................................31 
Accounting and Statistics..................................................................................31 

Uninstallation instructions ....................................................................................31 
Appendix A: setup jms mqsc ....................................................................................32 



 - 5 - 

Prerequisites 
Before you install this plug-in, you must install: 
 

• WebSphere Message Broker Runtime v6.0.0.1 or above 
• WebSphere MQ Explorer (upgraded to Eclipse 3.0.2) v6.0.2.0 or above 

 
The Broker Explorer plug-in is supported on Windows XP and Linux (x86 platform). 
 
Upgrading WebSphere MQ Explorer to Eclipse 3.0.2 
To upgrade WebSphere MQ Explorer to Eclipse 3.0.2: 
 

1. Start WebSphere MQ Explorer. 
2. From the Window menu, click Preferences. The Preferences dialog opens. 
3. On the WebSphere MQ Explorer page of the Preferences dialog, in the Startup 

section, click in an Eclipse Workbench (as shown in more detail in the 
Installation Instructions below). 

4. Close and restart WebSphere MQ Explorer. 
5. In WebSphere MQ Explorer, click Help > Software Updates > Find and 

Install . The Install/Update wizard opens 
6. Click search for Updates of the currently installed features, then click 

Next. Wait for the list of available updates to be displayed. 
7. Click Eclipse 3.0.2 to highlight it, then click Finish. 

 
The Broker Explorer plug-in does not work on versions of Eclipse before Eclipse 
3.0.2. 

Migrating from a previous version of IS02 

V1 
Previous versions of IS02 had no state information saved and so there is no user data 
to migrate. However, to migrate the plug-in code from an earlier version of IS02 to 
this version: 
 

1. Close any open WebSphere MQ Explorer in which IS02 is installed. 
2. Delete the entire directory in which you originally installed IS02. 

3. Follow the Installation Instructions below to install the new version of IS02. 

 

V2 
To migrate from IS02v2 you need to: 
 

1. Export your configuration managers to individual files. (See Exporting a 
WebSphere Message Broker V6 connection file) 

2. Close any open WebSphere MQ Explorer in which IS02 is installed. 
3. Delete the entire directory in which you originally installed IS02. 
 
4. Follow the Installation Instructions below to install the new version of IS02. 
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5. Import your configuration managers using the connection files in your 
workspace to recreate your configuration manager connections. 

 

Installation Instructions 
 
To install into an existing WebSphere MQ Explorer using the .links method: 
 

1. Download IS02.zip. 
2. Using an unzip utility that supports large file names, unzip the file to any 

location, for example, C:\MBAdmin  or /usr/opt/MBAdmin . This location 
will be the installation location of the plug-in. 

3. Close WebSphere MQ Explorer. 
4. From your unzipped location edit the file: 

com.ibm.etools.wmadmin.broker.explorer.link so that the location points to 
your unzipped directory. (In this case path=C:/MBAdmin  or 
path=/usr/opt/MBAdmin ). 

5. Move this file to your MQExplorer eclipse location, default location is: 
C:\Program Files\IBM\Eclipse SDK30\eclipse\links 

6. Restart your MQExplorer 
 

  The following figure shows the main Eclipse SDK installation and the 
WebSphere MQ Explorer extension. 

 
You can now view and connect to all local brokers from WebSphere MQ Explorer. 
You can also connect to remote Configuration Managers to display brokers in other 
domains. 
 
Tip: 
You can deactivate the Broker Explorer plug-in on the  WebSphere MQ Explorer > 
Enable Plug-ins page of the Preferences dialog by clearing the Broker Explorer plug-
in as shown in the following figure. 
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First Steps 

Creating the Default Configuration 
If you are new to WebSphere Message Broker, you can create the Default 
Configuration which creates the basic components that you need to explore 
WebSphere Message Broker. 
 
To create the Default Configuration: 
 

In the Navigator view, right-click the Brokers folder, then click  Create 
Default Configuration. 

 
The Default Configuration creates a working broker, Configuration Manager, and 
queue manager on your local system so that you can run the WebSphere Message 
Broker samples. 
 
The following components are created by the Default Configuration: 
 
Broker:   WBRK6_DEFAULT_BROKER 
Configuration Manager:  WBRK6_DEFAULT_CONFIGURATION_MANAGER 
Queue manager:  WBRK6_DEFAULT_QUEUE_MANAGER 
Database:   WBRK6DB6 
 
You can later create other brokers to use with the default Configuration Manager. 
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Using the Samples 
There are several samples available for you to test the system provided with this 
SupportPac. 
 
To use the samples: 
 

1. Click Help > Samples Gallery. The Samples Gallery opens in a new window. 
2. In the Samples Gallery, expand Application samples. 
3. Expand Message Broker - Getting Started samples. 
4. Run the Pager and Scribble samples. The Samples Gallery provides 

instructions about how to setup and run the samples. 
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Importing existing bar files, server projects and connection files 
 
To import existing bar files (*.bar) and connection files (*.configmgr), you must 
import the server projects that contain the bar files from your development 
environment. 
 
To import the server project: 
 

1. Click File > Import . The Eclipse Import wizard opens. 
2. Click Existing Project into Workspace then click Next. 

 
 

 
 

3. Browse to the server project location, then click Import . 
 
The server project is displayed under the Broker Resources directory in WebSphere 
MQ Explorer, along with the bar files and connection files in the server project, as 
shown in the following figure. 
 

 
 
You can also create a new server project in WebSphere MQ Explorer and import 
individual bar files into the server project (in the Import wizard, click the File system 
option). 
Server projects have the Eclipse project nature “com.ibm.wtp.server.core.nature” and 
are created with this nature by the Broker Explorer plug-in. 
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Importing a WebSphere Message Broker V6 connection file 
To import a remote Configuration Manager connection definition: 

1. In the server project, right-click the .configmgr file. 
2. Click Import . 

 

 
 
A remote queue manager definition is created in WebSphere MQ Explorer and the 
Configuration Manager is displayed under the queue manager, as shown in the 
following figure. 
 

 
 
All the brokers in the Configuration Manger's domain are then added under the 
Brokers directory and WebSphere MQ Explorer tries to connect to them.
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Creating an Execution Group  
 
On creating an execution group you can select 32 or 64 bit architecture. 
 

 
 

Deleting an Execution Group  
 
To delete an execution group you must first stop all the message flows in the 
execution group and then remove all the message flows from the execution group. 

Deploying to an Execution Group 
 
Before you can deploy to a broker you must first make sure that it is started and has at 
least one execution group: 
 

1. Under the Brokers folder, right-click the broker, then click Start. An Eclipse 
background job starts, which starts the broker. 
You can start and stop only local brokers with this SupportPac. 

2. After the broker has started, if you need to create an execution group, right-
click the broker, then click New Execution Group. You can create execution 
groups on both local and remote brokers. 

3. To deploy a bar file, right-click the bar file, then click the name of the 
execution group to which you want to deploy the bar file. If you select 
multiple execution group, the bar file is deployed to each of the execution 
groups in sequence. 
 

 
 
When the deployment has completed successfully, the message flows and other 
resources are displayed under the execution group. 
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Connecting to a Configuration Manager 
 
To connect to a remote Configuration Manager: 

1. Right-click the Brokers directory, then click Connect. 
2. Enter the connection details in the wizard that opens. 

The value of the Host field can be the dotted decimal IP address or the host 
name. 

 

 
 

3. Click Next. 
4. If you want to connect to the Configuration Manager using WebSphere MQ 

security settings, specify the security connection parameters. Use the special 
location “localhost” to define security settings for local Configuration 
Manager connections. 
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A remote queue manager definition is created in WebSphere MQ Explorer and the 
Configuration Manager is displayed under the queue manager. 
 

 
 
All the brokers in the Configuration Manger's domain are then added under the 
Brokers directory and WebSphere MQ Explorer tries to connect to them. 
 

Removing a Configuration Manager 
To remove a Configuration Manager and its brokers from the Navigator view: 

1. In the Navigator view, right-click the Configuration Manager. 
2. If WebSphere MQ Explorer is connected to the Configuration Manager, click 

Disconnect. 
3. Right-click the Configuration Manager, then click Remove. 

 

 
 
The Configuration Manager and its brokers are removed from the Navigator view. 
 

Exporting a WebSphere Message Broker V6 connection file 
To export a .configmgr file so that it can be used in the Message Brokers Toolkit: 

At any time, right–click the Configuration Manager, then click Export 
*.configmgr file 

 

Importing a WebSphere Message Broker V6 connection file 
To import a .configmgr file that has previously been exported, you must first create a 
server project: 

Right-click the Broker Resources folder, then click New > ServerProject. 
 
You can then import individual bar files into the server project using the File system 
option in the Import wizard. 
 
Server projects have the Eclipse project nature “com.ibm.wtp.server.core.nature” and 
are created with this nature by the Broker Explorer plug-in. 
 
You can then follow the instructions for “Importing a WebSphere Message Broker V6 
connection file” in the “Importing existing BAR files, Server Projects and Connection 
Files” section. 
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Adopting a Broker 
A Configuration Manager can adopt a newly created broker using the “Adopt a newly 
created broker” wizard. The Configuration Manager cannot adopt a broker that is 
already associated with another Configuration Manager. 
 
To adopt a broker: 
 

1. Right-click the connected Configuration Manager, then click Adopt a Broker. 
 

 
 
If the broker is on the localhost, the channels, transmission queues, and listeners are 
created automatically. The broker and broker queue manager pair are also added to 
the Configuration Manager’s repository. 
 
If the broker is on a remote system, you must create the following WebSphere MQ 
resources: 
 
On the Configuration Manager’s queue manager: 
 

Object Name Other details 

Transmission queue broker_queue_manager_n
ame 

 

Sender channel definition CONFIG.TO.broker_queu
e_manager_name 

Set the Connection Name 
property to the host name 
and port of the broker 
queue manager. 
 
Set the Transmission 
Queue property to the 
name of the transmission 
queue that you just created. 

Receiver channel definition broker_queue_manager_n
ame.TO.CONFIG 

 

 
On the broker's queue manager: 
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Object Name Other details 

Sender channel broker_queue_manager_n
ame.TO.CONFIG 

Set the Connection Name 
property to the host name 
and port of the 
Configuration Manager's 
queue manager. 

Receiver channel CONFIG.TO.broker_queu
e_manager_name 

 

Listener Use the port number that 
the Connection Name uses. 

 

 
The broker name and broker queue manager pair are automatically added to the 
Configuration Manager’s repository.
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Event Log viewer 
 
You can view the broker and Configuration Manager event log for your user ID by 
opening the Event Log view: 

Click Window > Show View > Event Log 
 

 
 
 
Double-click an entry to see the full log entry. 
 

 
 
 
You can clear the log, and you can export the log for audit purpose. 
 

 
 
The Event Log view is updated in real-time and reflects the entity that is currently 
selected in the Navigator view: 
 

• If a Configuration Manager is selected, all the events of its brokers are 
displayed. 

• If an individual broker is selected, the log is filtered to show just the log events 
of that broker.
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Preference Pages 
 

Main Preferences 
You can alter the default behavior of the Broker Explorer plug-in using the preference 
pages. 
 

 
 
The following table describes the options in the Preferences: 
 

Option Behavior when selected 

Ask before switching perspectives on 
double clicking a bar file 

When you double-click a bar file, a 
dialog asks whether you want to switch to 
the Resource perspective to open the bar 
file. 

Warn before deleting Log Events When you delete a log event, a dialog is 
displayed to ask if you are sure that you 
want to delete the log. (When not 
selected, the log event is deleted without 
any prompt.) 

Display resources in Broker Explorer Message flow resources are displayed in 
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View the Navigator view. (When not selected, 
the message flow resources are hidden 
from the Navigator view.) 

Display configuration manager in Broker 
Explorer view 

Displays the Configuration Manager. 
(When not selected, the Configuration 
Manager is hidden from all views.) 

Tidy Configuration Manager on 
connecting 

This is an advanced feature that enables 
you to tidy up your Configuration 
Manager repository.  
 
On connection to a Configuration 
Manager a series of checks are run on the 
Configuration Manager’s queue manager 
to make sure that the Configuration 
Manager can communicate with all the 
brokers defined on it. If communication 
channels or transmission queues cannot 
be found, message boxes are displayed so 
that you can remove broker entries. 
 
By default, this option is not selected. If 
you do not want to tidy up a 
Configuration Managers internal 
configuration this can be left turned off.  

Remove all Broker Explorer saved state Resets the persisted model to the initial 
installed state, removing all remote 
connection information and local security 
information. 

 

Service Trace 
You can set various levels of trace for Broker Explorer: 
 

• Warnings and Errors: Warnings or extra alert information and all exceptions 
output. This mode is safe to run in and provides no performance degradation. 

• Full Trace: complete method call stack. This slows down Broker Explorer 
considerably and produces large log files. Only select this option if you are 
asked to do so by IBM service to investigate a problem in Broker Explorer. 

 
NB. The Broker Explorer trace is batched internally up to 2KB before being written to 
disk when you turn off tracing this buffer is flushed to the disk. 
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There is only one level of trace for the Configuration Manger Proxy and the 
WebSphere MQ Java Client and all trace output is written to file.
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Accounting and Statistics 
 
Important: To use the Accounting and Statistics functionality you must have 
JMS setup on your broker’s queue manager. Follow the instructions in the 
“Setting up JMS for use in IS02” section below. 

Starting the Accounting and Statistics plugin 
To display the two accounting and statistics views 
necessary to view your statistics: 

Click Window > Show View > Broker 
Statistics  

 
The Message Broker Statistics view displays the 
statistics table and the Message Broker Statistics 
Graph view displays the corresponding graph.  
The Message Brokers Statistics Graph view uses the table view and so requires this 
view to be populated. 
 
When these views are initially opened they connect to all available brokers that you 
have in your workspace and try to collect statistics data from them. If the Statistics 
Graph title shows “Waiting for data” then no statistics data has arrived. On receiving 
data the Graph will update whenever new data is available. 

Controlling Accounting and Stats 
To turn on collection of data for a message flow: 

In the Navigator view, right-click the message flow, then click Start 
Statistics. 

 

 
 
In about 30 seconds your system starts receiving some data. When you click a broker, 
execution group, or message flow in the Navigator view, the table and graph are 
refreshed to show the statistics of that selection. If no data is available, the views are 
solid gray.  
 

Viewing Statistics Data 
The data is refreshed when new data arrives. But you can click pause on the Graph on 
the title bar to hold the current data in memory. This allows you to examine that 
snapshot of data as a moment in time. Clicking on play causes the data to revert to the 
newest received data. 
 
The Message Broker Statistics view shows the currently selected broker, execution 
group or message flow data. The Message Brokers Statistics Graph view shows the 
currently selected rows in the table view. This defaults to the top 3 rows every time 
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you change selection. The table can be sorted by clicking on the column header; rows 
can be added and removed by pressing CTRL+left click on the row. You can also 
select several rows by holding down the CTRL key and selecting the rows you wish 
to graph. 
 
The metrics that are shown in the graph can be changed by clicking filter  and 
selecting the metrics you want to see (available metrics depend on what type of broker 
object is selected). This selection is saved between sessions. 
 
The graph has 3 types of view: linear, logarithmic, and stacked. 
 
NB. Within logarithmic view “0” values are converted to “0.1” due to scaling. 
 
 

Shell Sharing with Message Broker Tooling v601 and v602 
You can shell share MQExplorer and IS02 with the Message Broker Tooling. You 
must use the purpose built shell sharing package called is02shellshare from the 
support pac website. 
 
1. Copy the MQExplorer link file C:/Program Files/IBM/Eclipse 
SDK30/eclipse/links/com.ibm.mq.explorer.link to your Message Broker Toolkit 
links location C:\Program Files\IBM\MessageBrokersToolkit\6.0\eclipse\links. 
This will install the MQExplorer within your Message Broker Toolkit. 
2. Download the shell sharing IS02 package. 
3. Using an unzip utility that supports large file names, unzip the file to any location, 
for example, C:\MBAdminShare  or /usr/opt/MBAdminShare This location will be 
the installation location of the plug-in. 
4. From your unzipped location edit the file: 
com.ibm.etools.wmadmin.broker.explorer.link so that the location points to your 
unzipped directory. (In this case path=C:/MBAdminShare  or 
path=/usr/opt/MBAdminShare). 
5. Move this file to your Message Broker Toolkit links location, default location is: 
C:\Program Files\IBM\MessageBrokersToolkit\6.0\eclipse\links. 
 
You should now be able to see your Brokers within the MQExplorer within the 
Message Broker Tooling. 
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DataPower Security Wizard 
 
Important: To use the DataPower Security Wizard you must have JMS setup on 
your broker’s queue manager. Follow the instructions in the “Setting up JMS for 
use in IS02” section below. 
 
The DataPower1 security wizard gives you the facility to completely configure an 
external DataPower appliance to handle the WS-Security Policy for your 
HTTP(S)Input nodes within your flow. Once you have completed the wizard your 
DataPower box will be able to decrypt incoming messages to your flow and encrypt 
outgoing messages from your flow. No changes are made to your broker flows or 
broker configuration. The only change will be for your clients to send their messages 
direct to the DataPower appliance on a Client port you specify. 
 
Configuring your DataPower appliance is performed in 4 steps. 
 

• Select which HTTP(S)Input nodes you wish to configure your security for. 
• Create a new DataPower connection profile or edit an existing profile. 
• Use or alter the default Policy Sets to specify your encryption and decryption 

WS- Security parameters. 
• Specify which specific Crypto Keys to use from the DataPower box 

 
 
The DataPower Configuration created on your appliance consists of the following: 
 
An XML Firewall with optionally Back (for HTTPSInput Nodes) and Front (Client)  
SSL connection. 
 
An XML Firewall Policy consisting of a list of inbound/ request rules and an 
outbound/ response rule per HTTP Input Node. 
 
Each inbound/ request rule consists of a decryption action with parameters specified 
from the Policy Set. 
 
Each outbound/ response rule consists of an encryption action with parameters 
specified from the Policy Set. 
 
                                                
1 This Wizard has been tested using DataPower Firmware level 3.6.0.5 & 3.6.0.16 
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An example of an XML Firewall Policy created by Bro ker Explorer 

 
 

Starting the wizard 
You can access the DataPower wizard by selecting the flow which contains the 
HTTPInput nodes you wish to enable security handling on or you can select an 
execution group to enable security handling for all of the HTTPInput nodes in the 
flows in the execution group.  
 
 

 
 
 
After starting the wizard all your HTTPInput nodes are collected and you are 
presented with the main configuration wizard as shown below. All the HTTPInput 
nodes are selected by default. Only the selected HTTPInput node lines in the Flow 
Details table are configured in the DataPower appliance. 
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If you select “No Policy Set Bindings” in the WS-Security section then no encryption 
or decryption nodes are specified in your policy rules. This is good initial test to make 
sure that your communication channels work before applying the Policy Set Binding 
for real later. 
 
You need to specify a Policy Set Binding to create your encryption and decryption 
rules. A default Policy Set Binding and associated Policy Set are provided. This 
binding supports “KeyIdentifier” encryption and decryption. If you want to change 
this you need to use the Policy Set Editor. 
 

Policy Set Editor 
The Policy Set Editor allows you to alter your Policy Set Binding and associated 
Policy Set parameters. 
 
Within the Policy Set Binding your decrypt/ inbound key and encrypt/ outbound key 
details are specified. This is limited to one encrypt key and one decrypt key for the 
purpose of this support pac. (This is an early release of the Policy Set standard and so 
the Policy Set Editor shown here is a cut down version specific to this support pac 
which allows full message body encryption/ decryption only) Each encryption and 
decryption action takes further settings from the associated Policy Set and the Policy 
Set Bindings parameters. You associate the Policy Set and Policy Set Binding by 
selecting the Policy Set Binding (WSS10-Default-FRESH_1 in the Policy Set Binding 
below) and altering the combo box. 
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Policy Sets are stored on a per broker basis within the Broker Explorer support pac. 
They cannot be imported or exported at present as this standard has yet to be 
finalized. 
 

Connection Profiles Wizard 
After selecting your WS- Security you then need to create a connection to your 
DataPower appliance. 
 

 
 
Within this connection profile wizard you will need to add a valid username, domain 
and your DataPower appliance ip address. After clicking finish the combo box will be 
filled in the wizard allowing you to select and use this connection profile. Profiles can 
also be exported and imported into different Broker Explorer clients. 
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Naming your XML Firewall 
On returning to the main wizard you must then select whether or not you want to 
create a new Policy or merge with an existing Policy. If you attempt to merge with a 
policy that doesn’t exist a new one will be created. Essentially a merge adds request 
and response rules to your policy. It does not overwrite any preexisting rules. A merge 
also does not alter your existing firewall settings. 
 
You now can fill in the name of your XML Firewall(s) and the Client ports on which 
your HTTP clients will connect to your DataPower box. 

Crypto Profiles 
On clicking Next an attempt will be made to connect to your domain on your 
DataPower box to retrieve your Crypto Profiles. 
 

 
 
This step can also be used to check that your connection profile and password is valid. 
 

Final Steps 
On clicking Finish the DataPower box will be configured to handle the WS- Security 
Profile for your HTTPInput nodes. 
 
If any errors during configuration of your DataPower device you can use the Broker 
Explorer tracing to see the messages going backwards and forwards to the DataPower 
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appliance and you can also examine the logs on your DataPower device to determine 
the fault. 
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Setting up JMS for use with IS02 
 
Firstly your tooling machine must have WebSphere MQ 602 (WebSphere MQ 
Explorer 602 or above) installed as this tooling has the JMS classes installed. 
 
You must then perform the following steps on your Broker’s Queue Manager to 
enable JMS for that Queue Manager. 
 
1) In the directory in which you unzipped IS02 there is a supplied runmqsc script: 
eclipse\plugins\com.ibm.etools.wmadmin.broker.stats_6.0.2.0\setup_jms.mqsc 
 
To enable JMS on your broker’s Queue Manager, run the following command (with 
no line breaks): 

runmqsc queuemanager < 
C:\MBAdmin\ eclipse\plugins\com.ibm.etools.wmadmin.broker.stats_6.0.2
.0\setup_jms.mqsc 

 
Alternatively you can paste in the commands from the Appendix A. 
 
2) Broker Explorer then uses the SYSTEM.DEF.SVRCONN channel to connect to 
the broker for all JMS activity. This includes retrieving HTTPInput nodes within the 
DataPower wizard as well as starting statistics, stopping statistics and receiving the 
statistics data back from the broker. You must have access to use this channel on the 
broker queue manager. 
 
This command allows any user to run with the permissions of <broker user> who is a user on 
your Brokers machine in the mqm and mqbrkrs groups. 
 
alter chl(SYSTEM.DEF.SVRCONN) CHLTYPE(SVRCONN) MCAU SER(<broker user>) 
 
JMS is now enabled for your Broker’s Queue Manager. 
 

Resolutions to problems 
Broker Explorer Trace can be set to “Warnings and Errors” to provide additional 
detailed information on failures without any performance impact. So to identify a 
problem always use this setting and examine the trace log. 

No Brokers directory is displayed after installatio n 
Upgrade WebSphere MQ Explorer to use Eclipse 3.0.2; follow the instructions 
described in the Prerequisites section. 

Deployment problems 
For more information on resolving deployment problems, see to the WebSphere 
Message Broker documentation online. 
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� WebSphere MQ Explorer must be connected to a broker before deploying to 
it. When connected, the available execution groups are shown in the Navigator 
view. 

� If a broker gets out of step with the Configuration Manager, reset the 
communication between them by canceling previous deployments: right-click 
the broker, then click Stop > Cancel Deploy. 

See 
http://publib.boulder.ibm.com/infocenter/wmbhelp/v6r0m0/index.jsp?topic=/com.ibm
.etools.mft.doc/af03940_.htm for more information. 
 

� If a deployment seems to 'hang' check that: 
� The broker’s Configuration Manager is running. 
� All channels are started and active between the broker queue manager 

and the Configuration Manager's queue manager. 
� All listeners are running. 

 
Cancel previous deployments by cancelling the Deploy Job and selecting 
Stop > Cancel Deploy. 

 
If all these steps fail to resolve the problem, start and stop the listeners on the 
Configuration Manager’s queue manager and the broker's queue manager. 
 

� If you are deploying a large bar file you might need to increase the maximum 
message size that can be sent through the WebSphere MQ channels: 

1. In the channel's properties dialog, on the Extended page, set the Max 
Message Size property to a larger value. 

2. Check that the channels are well named “<Broker>.TO.CONFIG” and 
have a sender-receiver pair for each end of the communication.  

You might also need to increase the primary and secondary logs from their default 
sizes on the queue managers. Stop and restart the queue managers to get the log 
values to reload. 
 

“Cannot find MQSeries JMS libraries. You must insta ll MQSeries classes 
for Java Message Service on this machine” and relat ed JMS Errors 
 

 
 
This message and related messages state that there is a problem finding or using JMS 
either on your host machine or your broker machines. 
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Follow the section “Setting up JMS for use with IS02” 
 

Stats and Accounting gives a JMS error and asks me to set up JMS 
JMS is required on the queue manager of each broker that you want to receive data 
from. Follow the section “Setting up JMS for use with IS02”  
 
If you do not want to see Accounting and Statistics information for other brokers, you 
can ignore this message (it is displayed once for each broker in the Navigator view 
that does not have JMS enabled). 
 

No graph view appears for the Broker Statistics 
Close the graph view and reopen. This reregisters the view with the table.  
 

Other JMS related errors (While using Accounting an d Statistics or the 
DataPower wizard) 
Use the trace settings to determine the exact error. Common errors are caused by 
permission problems for either the SYSTEM.DEF.SVRCONN channel or not having 
the rights to connect to the broker’s queue manager. You must connect to the broker 
using a username that exists on the broker server and is in the mq and broker groups 
defined on that server. 
 

Connecting to a remote Configuration Manager 
Most problems connecting to a remote configuration manager relate to permissions 
problems on the SYSTEM.BKR.CONFIG channel or access permissions to the 
Configuration Managers topology. 
 
1) The following PCF command can be used to configure your configuration 
managers queue manager to allow the Broker Explorer to connect. 
 
alter chl(SYSTEM.BKR.CONFIG) CHLTYPE(SVRCONN) MCAUS ER(<broker user>) 
 
(replace <broker user> with a user in the mqm group on your Broker machine) 
 
2) This command allows your tooling user complete access to the Configuration Manager (in 
this case CFGMGR) topology 
 
mqsicreateaclentry CFGMGR -u <tooling user> -a -x F  -p 
 
(replace <tooling user> with the tooling user on your Broker Explorer machine) 
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Known Restrictions 

Accounting and Statistics 
If you add a new broker to the workspace, you must close both accounting and 
statistics views then reopen them to retrieve statistics data from them. You must also 
do this after you enable JMS on any broker that did not have it before. 

 

Uninstallation instructions 
 
To uninstall this SupportPac: 
 

1. Close WebSphere MQ Explorer. 
2. Delete the entire directory into which you unzipped is02.zip. 
3. Restart WebSphere MQ Explorer. 
4. Click Window > Reset Perspective. 
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Appendix A: setup jms mqsc 
*************************************************** *****************/ 
* IBM WebSphere MQ Support for Java Message Service                 */                                             
*/ 
* Sample MQSC source defining JMS Publish/Subscribe  queues.        */ 
* Installation Verification Test - Setup script                    */ 
*                                                                  */ 
* Licensed Materials - Property of IBM                             */  
*                                                                  */ 
* 5724-H72 5655-L82 5724-L26                                       */ 
*                                                                  */ 
* (c) Copyright IBM Corp. 1999, 2006. All Rights Re served.         */ 
*                                                                  */ 
* US Government Users Restricted Rights - Use, dupl ication or      */ 
* disclosure restricted by GSA ADP Schedule Contrac t with IBM Corp.*/ 
*************************************************** *****************/ 
 
*************************************************** *****************/ 
*                                                                  */ 
*   JMS Publish/Subscribe Administration Queue                     */ 
*                                                                  */ 
*************************************************** *****************/ 
**   Create a local queue 
    DEFINE QLOCAL('SYSTEM.JMS.ADMIN.QUEUE') REPLACE  + 
        DESCR('Websphere MQ - JMS Classes - admin q ueue') + 
*   Persistent messages OK 
        DEFPSIST(YES)  + 
*   Non-Shareable 
        NOSHARE 
 
*************************************************** *****************/ 
*                                                                  */ 
*   JMS Publish/Subscribe Subscriber Status Queue                  */ 
*                                                                  */ 
*************************************************** *****************/ 
**   Create a local queue 
    DEFINE QLOCAL('SYSTEM.JMS.PS.STATUS.QUEUE') REP LACE + 
        DESCR('Websphere MQ - JMS Classes - PS stat us queue') + 
*   Persistent messages OK 
        DEFPSIST(YES)  + 
*   Shareable 
        SHARE DEFSOPT(SHARED) 
 
*************************************************** *****************/ 
*                                                                  */ 
*   JMS Publish/Subscribe Report Queue                             */ 
*                                                                  */ 
*************************************************** *****************/ 
**   Create a local queue 
    DEFINE QLOCAL('SYSTEM.JMS.REPORT.QUEUE') REPLAC E + 
        DESCR('Websphere MQ - JMS Classes - Report queue') + 
*   Persistent messages OK 
        DEFPSIST(YES)  + 
*   Shareable 
        SHARE DEFSOPT(SHARED) 
 
*************************************************** *****************/ 
*                                                                  */ 
*   JMS Publish/Subscribe Subscribers Model Queue                  */ 
*                                                                  */ 
*   Create model queue used by subscribers to creat e a permanent   */ 
*   queue for subsciptions                                         */ 
*                                                                  */ 
*************************************************** *****************/ 
*   General reply queue                                            */ 
    DEFINE QMODEL('SYSTEM.JMS.MODEL.QUEUE') REPLACE  + 
        DESCR('Websphere MQ - JMS Classes - Model q ueue') + 
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*   Queue Definition Type 
        DEFTYPE(PERMDYN) + 
*   Shareable 
        SHARE DEFSOPT(SHARED) 
 
*************************************************** *****************/ 
*                                                                  */ 
*   JMS Publish/Subscribe Default Non-Durable Share d Queue         */ 
*                                                                  */ 
*   Create local queue used as the default shared q ueue by         */ 
*   non-durable subscribers                                        */ 
*                                                                  */ 
*************************************************** *****************/ 
**   Create a local queue 
    DEFINE QLOCAL('SYSTEM.JMS.ND.SUBSCRIBER.QUEUE')  REPLACE + 
        DESCR('Websphere MQ - JMS Classes - PS ND s hared queue') + 
*   Persistent messages OK 
        DEFPSIST(YES)  + 
*   Shareable 
        SHARE DEFSOPT(SHARED) + 
*   Maximum queue depth 
        MAXDEPTH(100000) 
 
*************************************************** *****************/ 
*                                                                  */ 
*   JMS Publish/Subscribe Default Non-Durable Share d Queue for     */ 
*   ConnectionConsumer functionality                               */ 
*                                                                  */ 
*   Create local queue used as the default shared q ueue by         */ 
*   non-durable connection consumers                               */ 
*                                                                  */ 
*************************************************** *****************/ 
**   Create a local queue 
    DEFINE QLOCAL('SYSTEM.JMS.ND.CC.SUBSCRIBER.QUEU E') REPLACE + 
        DESCR('Websphere MQ - JMS Classes - PS ND C C shared q') + 
*   Persistent messages OK 
        DEFPSIST(YES)  + 
*   Shareable 
        SHARE DEFSOPT(SHARED)  + 
*   Maximum queue depth 
        MAXDEPTH(100000) 
 
*************************************************** *****************/ 
*                                                                  */ 
*   JMS Publish/Subscribe Default Durable Shared Qu eue             */ 
*                                                                  */ 
*   Create local queue used as the default shared q ueue by durable */ 
*   subscribers                                                    */ 
*                                                                  */ 
*************************************************** *****************/ 
**   Create a local queue 
    DEFINE QLOCAL('SYSTEM.JMS.D.SUBSCRIBER.QUEUE') REPLACE + 
        DESCR('Websphere MQ - JMS Classes - PS D sh ared queue') + 
*   Persistent messages OK 
        DEFPSIST(YES)  + 
*   Shareable 
        SHARE DEFSOPT(SHARED)  + 
*   Maximum queue depth 
        MAXDEPTH(100000) 
 
*************************************************** *****************/ 
*                                                                  */ 
*   JMS Publish/Subscribe Default Durable Shared Qu eue for         */ 
*   ConnectionConsumer functionality                               */ 
*                                                                  */ 
*   Create local queue used as the default shared q ueue by durable */ 
*   connection consumers                                           */ 
*                                                                  */ 
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*************************************************** *****************/ 
**   Create a local queue 
    DEFINE QLOCAL('SYSTEM.JMS.D.CC.SUBSCRIBER.QUEUE ') REPLACE + 
        DESCR('Websphere MQ - JMS Classes - PS D CC  shared q') + 
*   Persistent messages OK 
        DEFPSIST(YES)  + 
*   Shareable 
        SHARE DEFSOPT(SHARED)  + 
*   Maximum queue depth 
        MAXDEPTH(100000) 
 


