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Installing and configuring the Eclipse user interface

The WebSphere® Service Registry and Repository (WSRR) Eclipse user interface
(UI) is supplied as a plug-in. The following instructions describe how to install,
and configure the Eclipse UI in an Eclipse workbench; for example, in Rational®

Software Architect.

Before you begin

The details in this section refer to the latest version of the Eclipse plug-in, which is
available for download as SupportPac SA02 from the WSRR SupportPac Web site.
If you have installed a previous version of the Eclipse plug-in, uninstall it before
installing the latest version; see “Uninstalling the Eclipse user interface” on page 6
for information about how to uninstall the Eclipse plug-in.

About this task

The underlying Java™ Runtime Environment (JRE) for your Eclipse environment
can be either of the following:
v IBM® JRE.
v Sun JRE; the JRE level must be Version 6 or above.

A separate WSRR Eclipse plug-in is provided for each JRE; ensure that you install
the correct plug-in for the JRE you are using.

Installing and configuring the Eclipse user interface is described in the following
subtopics:
Related information

The WebSphere Service Registry and Repository Eclipse user interface

Installing the Eclipse user interface
You install the plug-in using Update Manager in your Eclipse workbench.

Before you begin

Before you start, you must have installed an Eclipse workbench on your local
computer; for example, Rational Software Architect. The minimum level is Eclipse
3.1.

The Eclipse installation must include the org.apache.xerces feature. You can
download the Eclipse Web Tools Platform, containing the org.apache.xerces feature,
from http://www.eclipse.org/webtools. Copy the following jar files, or the latest
equivalent versions, from the plugins directory of the download to the plugins
directory of your Eclipse installation:
v javax.xml_1.3.4.v200806030440.jar
v org.apache.xerces_2.9.0.v200805270400.jar
v org.apache.xml.resolver_1.2.0.v200806030312.jar
v org.apache.xml.serializer_2.7.1.v200806030322.jar
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Note: Due to a class conflict, the plug-in does not work with IBM JRE 6 on Eclipse
3.2; if you want to use IBM JRE 6, use Eclipse 3.4.

What to do next

The steps you must perform to install the Eclipse user interface are described in
the following subtopics:

Installing the Eclipse user interface with Eclipse 3.4
This topic describes the steps you must perform to install the WSRR Eclipse user
interface with Eclipse 3.4.

About this task

To install the Eclipse user interface with Eclipse 3.4, perform the following steps:
1. Start the Eclipse 3.4 workbench.
2. Click Help → Software Updates → Available Software → Add Site. The Add

Site dialog opens.
3. Click Archive. The Repository archive dialog opens.
4. Browse to the location of the WSRR archive and select the archive name. If

you are using an IBM JRE for your Eclipse installation, the archive name is
sa02_IBM_JRE.zip. If you are using a Sun JRE, the archive name is
sa02_non_IBM_JRE.zip.

5. Click Open. The WSRR archive name is added to the Location field in the
Add Site dialog.

6. Click OK. The WSRR archive name is added to the list of items on the
Available Software tab.

7. Select the check box alongside the WSRR archive name, ensure that the check
boxes for all sub-items are also selected, and click Install.

8. Ensure that the com.ibm.serviceregistry.core.feature item is selected and click
Next. The Review Licenses dialog opens.

9. Read the license agreement, select I accept the terms in the license
agreements to accept the terms, then click Finish.

10. When prompted, click Yes to restart the Eclipse workbench, which completes
the installation. The WSRR plug-in is now installed in your Eclipse 3.4
workbench.

11. Open the Service Registry view:
a. From the Window menu, click Show View... → Other... The Show View

dialog opens.
b. Expand Service Registry folder.

Note: If this folder is not present, it is probably because your Eclipse
installation does not have the org.apache.xerces feature installed.
Eclipse does not provide this warning during the installation of the
WSRR feature. See “Installing the Eclipse user interface” on page 1
for information about how to install the org.apache.xerces feature.

c. Click Service Registry, then click OK. The Service Registry view opens in
the bottom-right of the workbench.
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Installing the Eclipse user interface with versions of Eclipse
earlier than 3.4

This topic describes the steps you must perform to install the WSRR Eclipse user
interface with versions of Eclipse earlier than 3.4.

About this task

To install the Eclipse user interface with versions of Eclipse earlier than 3.4,
perform the following steps:
1. Start the Eclipse workbench.
2. In the workbench, from the Help menu, click Software Updates → Find and

Install.... The Install/Update wizard opens.

Note: If you are using WebSphere Integration Developer Version 6.1.2, the
Find and Install... menu option is available only in the Resource
perspective.

3. In the wizard, click Search for new features to install, then click Next. The
wizard lists the locations that are searched when searching for new features.

4. Add a new location to search.
a. Click New Archived Site. The Select Local Site Archive dialog opens.
b. Choose the WSRR Eclipse plug-in archive .zip file. If you are using an IBM

JRE for your Eclipse installation, the archive name is sa02_IBM_JRE.zip. If
you are using a Sun JRE, the archive name is sa02_non_IBM_JRE.zip.

c. Click OK.

The new location is added to the list in the wizard.
5. Select the check box for the new location or archived site, then click Finish. If

the location is secured, enter your user name and password. Eclipse searches
the selected location or locations for new features. When the search is
complete, the available features that are relevant to your installation are
displayed in the wizard.

6. Select the check box for the WSRR plug-in feature, which contains the WSRR
plug-in, then click Next.

7. Read the license agreements and click I accept the terms in the license
agreements to accept the terms, then click Next.

8. Select the location on your local computer where you want to install the
WSRR plug-in. To add a new location, click Add Site... or Change Location ...
then browse to the location where you want to install the WSRR plug-in.

9. Click Finish.
10. You might be prompted with a Feature Verification dialog. As this plug-in

feature is unsigned you must accept the warning by clicking Install.
11. When prompted, click Yes to restart the Eclipse workbench, which completes

the installation. The WSRR plug-in is now installed in your Eclipse
workbench.

12. Open the Service Registry view:
a. From the Window menu, click Show View... → Other... The Show View

dialog opens.
b. Expand Service Registry folder.

Note: If this folder is not present, it is probably because your Eclipse
installation does not have the org.apache.xerces feature installed.
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Eclipse does not provide this warning during the installation of the
WSRR feature. See “Installing the Eclipse user interface” on page 1
for information about how to install the org.apache.xerces feature.

c. Click Service Registry, then click OK. The Service Registry view opens in
the bottom-right of the workbench.

Configuring the Eclipse user interface
Before you can use the Eclipse user interface (UI) to access the objects in
WebSphere Service Registry and Repository (WSRR), you must configure the UI
with the connection details that it needs, including any security details for making
a secure connection.

Before you begin

Before you start, you must have completed the following tasks:
1. Install: “Installing the Eclipse user interface” on page 1
2. Ensure that your default installed Java Runtime Environment (JRE) for your

Eclipse environment is set correctly, according to the JRE that you are using.
If your underlying JRE is an IBM JRE, ensure that your default installed JRE for
your Eclipse environment is set to a WebSphere Application Server Version 6
JRE (WAS6 JRE) or equivalent. This JRE has IBM specific security handshaking
JAR files that let the plug-in communicate with an instance of WSRR running
on a secured WebSphere Application Server.

The WebSphere Application Server JRE location is:
<WebSphere Application Server installation directory>\java\jre

If your underlying JRE is a Sun JRE, ensure that your default installed JRE is
set accordingly.

About this task

To configure the Eclipse UI to connect to WSRR, perform the following actions:
1. Start the Eclipse workbench and ensure that the Service Registry view is open.
2. Select Window → Preferences. The Preferences dialog opens.
3. In the Preferences dialog, expand Service Registry, then click WSRR Locations.

The WSRR Locations page is displayed.

Note: If you are using WebSphere Integration Developer (WID) V6.0.2 or later,
you will also see an entry for WebSphere Service Registry and
Repository under Window → Preferences. This relates to the WSRR
plug-in installed with WID; this plug-in provides a subset of the
functionality provided by the WSRR Eclipse UI plug-in.

4. On the WSRR Locations page, click Add. The Add a new WSRR location alias
dialog opens.

5. In the dialog, enter your connection details:
a. In the Alias field, type a meaningful name for the connection. For example,

type the name of the remote computer to which you are connecting.
b. In the Protocol field choose the appropriate HTTP protocol (for a

non-secured WSRR choose http or for a secure WSRR choose https).
c. In the Host field, type the fully-qualified name or IP address (IPv4 or IPv6)

of the remote computer to which you are connecting. For example,
jiffy.hursley.ibm.com or 192.168.0.3
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Note: If the WebSphere Application Server node name is different from the
computer name that it is running on, the Eclipse plug-in fails to
resolve the IP address given to it. To check this compare the
computer name to the name of the node in WebSphere Application
Server, using the WebSphere Application Server administrative
console.

The solution is to edit the hosts file (/etc/hosts or
C:\windows\system32\drivers\etc\hosts) on the computer running
the Eclipse plug-in, to map the IP address of the WSRR server to the
WebSphere Application Server node name.

For example:
IP address of WSRR server is 9.20.198.52
WebSphere Application Server node name is wasserver
Append to the hosts file 9.20.198.52 wasserver

d. In the Port field, type the port number of the WSRR listening port on the
host machine for your WSRR (by default, this is 9080 for an non-secured
WSRR and 9443 for a secure WSRR).

e. If security is enabled, you must provide security credentials so that the
plug-in can communicate with a secure WSRR. To do this, perform the
following actions:
1) Select the Connect to server with security check box.
2) Provide the user ID and password with which to log in.
3) Provide keystore and truststore details according to your underlying

JRE.
If you are using an IBM JRE, provide the keystore and truststore files,
with their passwords. An example trust store file directory location is
D:/IBMRAD/Rational/SDP/6.0/runtimes/base_v6_stub/profiles/
default/etc/.
If you are using a Sun JRE, provide the location of the ssl.client.props
file containing the security connection settings. Ensure that the
ssl.client.props file contains the following settings:
com.ibm.ssl.trustManager=SunX509
com.ibm.ssl.keyManager=SunX509
com.ibm.ssl.contextProvider=SunJSSE
com.ibm.ssl.keyStoreProvider=SUN
com.ibm.ssl.trustStoreProvider=SUN

Note: The default keystore and truststore type for WebSphere
Application Server is PCKS12, but the SUN JRE’s implementation
of PCKS12 is not compatible with the IBM implementation, so
you must convert these to a different type, JKS for example,
before using them in the SUN 6 JRE version of the Eclipse plugin.

f. Click OK. The new connection is listed on the WSRR Locations page of the
Preferences dialog.

6. Select the new location, checking the appropriate location, then click OK.

What to do next

When configuring the Eclipse plug-in with security enabled you must ensure that
the key and trust files that you use contain the signer part of the personal
certificate from the WebSphere Application Server where WSRR has been installed.
The signer part of the personal certificate should be exported from your
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WebSphere Application Server to a file. See Extracting a signer certificate from a
personal certificate in the WebSphere Application Server Information Center.

The file created contains the signer part of the certificate and should be added to
the key and trust store files on the client (where eclipse is installed). This can be
achieved using a key management utility such as iKeyman. If these steps are not
followed you will receive the following error message when attempting to use the
plug-in:
WSWS3713E: Connection to the remote host {hostname} failed.
Received the following error: Handshake terminated SSL engine: CLOSED

Related information

Managing services using the Eclipse user interface

Uninstalling the Eclipse user interface
Uninstalling the Eclipse user interface removes it completely from your Eclipse
workbench.

About this task

The steps you must perform to uninstall the Eclipse user interface are described in
the following subtopics:

Uninstalling the Eclipse user interface with Eclipse 3.4
This topic describes the steps you must perform to uninstall the WSRR Eclipse
user interface with Eclipse 3.4

About this task

To uninstall the Eclipse user interface with Eclipse 3.4, perform the following steps:
1. Start the Eclipse workbench.
2. Click Help → Software Updates → Installed Software.
3. Select the com.ibm.serviceregistry.core.feature item and click Uninstall. The

Uninstall dialog opens.
4. Ensure that the com.ibm.serviceregistry.core.feature item is selected and click

Finish.
5. When prompted, click Yes to restart the Eclipse workbench.

Results

You have now uninstalled the Eclipse user interface from your Eclipse workbench.

Uninstalling the Eclipse user interface with versions of
Eclipse earlier than 3.4

This topic describes the steps you must perform to uninstall the WSRR Eclipse
user interface with versions of Eclipse earlier than 3.4.

About this task

To uninstall the Eclipse user interface with versions of Eclipse earlier than 3.4,
perform the following steps:
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1. From within the Eclipse workbench, click Help → Software Updates → Manage
Configuration.

2. click the com.ibm.serviceregistry.core.feature 6.1.0 feature and select Disable
from the Available Tasks menu in the right-hand panel.

3. Click OK to disable this WSRR feature.
4. When prompted, restart the Eclipse workbench. You might receive warnings

when you restart if you have previously opened the Service Registry view.
5. After Eclipse has restarted, click Help → Software Updates → Manage

Configuration.
6. From the menu toolbar, select the Show Disabled Features option.
7. Select the disabled WSRR feature and select Uninstall from the Available Tasks

menu in the right-hand panel.
8. Click OK to uninstall this WSRR feature.
9. When prompted, restart the Eclipse workbench.

Results

You have now uninstalled the Eclipse user interface from your Eclipse workbench.
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Appendix. Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Software Interoperability Coordinator, Department 49XA
3605 Highway 52 N
Rochester, MN 55901
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Trademarks
The following terms are trademarks of International Business Machines
Corporation in the United States, other countries, or both:

IBM
SupportPac
WebSphere

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Linux is a trademark of Linus Torvalds in the United States, other countries, or
both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Other company, product, or service names may be trademarks or service marks of
others.
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