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Take Note!  
 
Before using this User's Guide and the product it supports, be sure to read the general 
information under "Notices”  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
First Edition, January 2009 
 
This edition applies to Version 1.0 of WebSphere Business Events / Event Flow Monitor and to all 
subsequent releases and modifications until otherwise indicated in new editions.  
 
(c) Copyright International Business Machines Corporation 2005, 2009. All rights reserved.  
 
Note to U.S. Government Users - Documentation related to restricted rights - Use, 
duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule Contract 
with IBM Corporation. 
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Notices  

 
The following paragraph does not apply in any country where such provisions are inconsistent 
with local law.  
 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION 
"AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, 
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE.  
 
Some states do not allow disclaimer of express or implied warranties in certain transactions, 
therefore this statement may not apply to you.  
 
References in this publication to IBM products, programs, or services do not imply that IBM 
intends to make these available in all countries in which IBM operates.  
 
Any reference to an IBM licensed program or other IBM product in this publication is not intended 
to state or imply that only IBM's program or other product may be used. Any functionally 
equivalent program that does not infringe any of the intellectual property rights may be used 
instead of the IBM product. Evaluation and verification of operation in conjunction with other 
products, except those expressly designated by IBM, is the user's responsibility.  
 
IBM may have patents or pending patent applications covering subject matter in this document. 
The furnishing of this document does not give you any license to these patents. You can send 
license inquiries, in writing, to the IBM Director of Licensing, IBM Corporation, 500 Columbus 
Avenue, Thornwood, New York 10594, USA.  
 
The information contained in this document has not been submitted to any formal IBM test and is 
distributed AS IS. The use of the information or the implementation of any of these techniques is 
a customer responsibility and depends on the customer's ability to evaluate and integrate them 
into the customer's operational environment. While each item has been reviewed by IBM for 
accuracy in a specific situation, there is no guarantee that the same or similar results will be 
obtained elsewhere. Customers attempting to adapt these techniques to their own environments 
do so at their own risk.  
 
The following terms are trademarks of the International Business Machines Corporation in the 
United States and/or other countries:  
 
WebSphere Business Events 
IBM 
 
The following terms are trademarks of the Microsoft Corporation in the United States and/or other 
countries:  
 
Windows 95, 98, Me 
Windows NT, 2000, XP 
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Preface 

 
The current Event Flow capabilities of WebSphere Business Events 6.2 or earlier does not allow 
for graphical representation of the running application other than in the form of charts, graphs and 
reports. This Support Pac is intended to extend an application’s visibility and allow users to not 
only model current Event Flows but to also display statistics both globally and by a particular 
context (stream or thread) of activity. 
 
Any comments (good and bad) are welcome. 
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Chapter 1 – Event Flow Monitor 

 
This document describes the functions and capabilities of the Event Flow Monitor SupportPac for 
WebSphere Business Events (“WBE”). 

 
 
Overview 
 
The Event Flow Monitor allows for the visualization of run-time activity currently being processed 
by WebSphere Business Events. This is useful for debugging, simulation and monitoring a run-
time application. The current version operates against the historical and correlation data stored in 
the WebSphere Business Events database and as such is not true real-time, rather “near” real-
time. The refresh rate is configurable within the application which can be as low as once every 
second. 
 

 

Installation 
 
The Event Flow Monitor is distributed with a self-contained installer. To install the application, run 
the installer and follow the on-screen prompts. 
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To confirm that the application has been installed successfully, check the programs menu. In 
Windows XP this can be done by navigating to Start > Programs > IBM WebSphere Business 
Events 6.2 and clicking on the Event Flow Monitor item. 
 
 
Enable History in WebSphere Business Events 
 
In order for run-time information to be viewed in the Event Flow Monitor, the history module 
needs to be enabled within WebSphere Business Events. To do this, first start WebSphere 
Business Events Properties:  
 

Navigate to Start > Programs > IBM WebSphere Business Events 6.2 and click on the 
Properties item. 

 
Within the welcome screen, enter appropriate login information (the default is username: admin, 
password: admin).  
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The next screen may take a few moments to load. Once it appears, click the Next button until the 
Enable History? property is visible. This value needs to be set to true. Then click the Save and 
Exit button. 
 

 
 
If history was not previously enabled, the WebSphere Business Events application will need to be 
restarted before the setting will take effect. 
 
 
ODBC Configuration 
 
Because the Event Flow Monitor operates against the WebSphere Business Events database, a 
connection to this database needs to be established. Since multiple databases are supported, the 
current version of the Event Flow Monitor utilizes a Windows ODBC connection. In order to 
configure an ODBC connection to the WBE database, the following steps should be taken: 
 

1. Open the control panel. In Windows XP, this is done by navigating to Start > Settings > 
Control Panel. 

 
2. Open the Administrative Tools folder within the control panel. 

 
3. Open Data Sources (ODBC). 
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4. Click the System DSN tab, then click the Add… button. 

 

 
 

5. Select the appropriate driver depending on the host database (typically one of the 
following: IBM DB2 ODBC Driver, Oracle ODBC Driver or SQL Server). Click the Finish 
button. 

 
Note: If the correct driver does not appear in this list the database client may 
need to be installed on this machine. 

 
6. Select the correct database and optionally enter the valid log-in information for the given 

data source (depending on the hosted system). If the source is a DB2 database the 
window may look like this: 
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Chapter 2 – Getting Started 
  
The Event Flow Monitor can be used in multiple roles to view run-time information of a 
WebSphere Business Events application. This information is retrieved from the Business Events 
database via an ODBC connection (which needs to be configured separately – see the previous 
section for details).  
 

 
Start the Application 
 

To start the application, navigate to Start > Programs > IBM WebSphere Business Events 6.2 
and clicking on the Event Flow Monitor item. After the splash screen, the initial window should 
look like this: 
 

 
 

There are multiple file menu and toolbar options. These will be further described in Chapter 5. 

 

 

Configuration 
 

In order successfully view the repository and run-time information, the connection to the server 
database needs to be configured. Navigate to Tools > Settings… 
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Verify that the server name and port are correct within the WBE URL and enter the repository and 
history database information (check the Same as Repository checkbox if these are the same – it 
would be unusual if they are different).  

 

 

 

When the correct information has been entered, click the Save button. These settings will be 
saved for future use of the application. 
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Chapter 3 – Creating Event Flow Schemes 
  
The flows created in the Event Flow Monitor are called “schemes” because the current application 
is only a read-only view of the existing environment so the flows are not pushed back into the 
server (so they are not true “event flows” in terms of the engine execution).  
 
 

Importing a WebSphere Business Events project 
 
There are two ways to load a project into the application. The first is to load the project directly 
from the repository database. This is the most common method as the project contained within 
the repository is typically the one which the user wishes to monitor. To import the project, either 
click the Import WBE Project from Repository button, select File > Import WBE Project from 
Repository… or click CTRL-R: 
 

   
 
OR 
 

 
 
Once the WebSphere Business Events project is loaded, each of the Interaction Sets in that 
project will be visible in the tree. 
 



WebSphere Business Events / Event Flow Monitor 

8 

 
The other, less common way to import a project into the application is to click the Import WBE 
Project from File button, select File > Import Project from File… or click CTRL-I. 
 

 
 

OR 
 

 
 
 

Create a Monitor Scheme 
 
Once a WebSphere Business Events project is successfully imported into the current application, 
multiple event flow schemes can be created. To create a new scheme, either click the Create 
New Event Flow Scheme, select File > New > Event Flow Monitor Scheme… or click CTRL-
N.  
 
A new tab will appear which will be the drawing space for the new flow. 
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Interaction Sets from the tree may now be dragged into this new drawing space to start creating 
the new flow. An event flow scheme can potentially contain only a single Interaction Set, or can 
have as many as are necessary. An Interaction Block is represented by a blue rectangle which 
can contain filters represented as yellow diamonds. Events and Actions should be represented 
with the appropriate icon depending on the connection properties as set in Design Data. 
Interaction Sets with more than one Interaction Block will be represented as multiple blocks with 
the same triggering events. Finally, any correlation filters (context functions) will depict related 
events with a dashed red arrow. 
 
In this example, a single Interaction Set has been dragged into the scheme and it contains two 
Interaction Blocks. Each of the Interaction Blocks contains two filters, one of which referenced the 
event “Purchase Order” (note the dashed red arrow). 
 

 
 
Additional Interaction Sets may be added to the flow by dragging in from the tree. 
 

Note: An Interaction Set may not be used more than once within a single flow.  
 
In this example, two new Interaction Sets have been dragged into the flow. Notice that the 
connections within the flow are not automatically created. In general, this is because the 
application will not assume any connections based on what the user wants to do.  
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In order to connect the flow, the event in the following Interaction Set can be dragged onto the 
outbound action or synthetic event of the previous step. If the event is connecting to another 
event (such as with a synthetic event) then this will simply create a single event. If the next event 
is connected to an outbound action, then a business step is created.  
 
In this example, the synthetic events are combined within this flow. 
 

 
 
To illustrate the business step, two new Interaction Sets are added to the flow. 
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Now the objects are connected, and because the second connection has both an event and an 
action, connecting these will create a business step.  
 
Business steps are key concepts within WebSphere Business Events. These represent logic that 
is taking place outside the system, and can be immediate or last an indeterminate amount of 
time. An example of an immediate business step would be if the action was performing a 
database update and the event was the result event from that transaction. Another type of 
business step would be where the action was sending an email with a discount to a customer and 
the next expected event is that the customer makes a purchase. Days, weeks or months could 
elapse before the next event returns to the system. Also note that the outbound system and the 
inbound system can be completely different. This does not matter as far as the engine or the 
event flow is concerned.  
 
In this example, the business step is representing a BPM process to create a purchase order. 
The outbound and inbound systems are the same (“BPM”), but the amount of time is unknown 
because the process may involve manual steps. 
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Saving an Event Flow Monitor Project 
 
In the current version of the Event Flow Monitor, any new objects (specifically the event flow 
schemes) are NOT checked into the Business Events repository. Instead, the current project 
(called an “Event Flow Monitor Project”) can be saved locally. The current project can be saved 
by either clicking the Save Event Flow Monitor Project button, selecting File > Save Event 
Flow Monitor Project, selecting File > Save Event Flow Monitor Project As… or clicking 
CTRL-S.  
 
These files are saved with the extension “.wbe” so as to not confuse them with the standard 
WebSphere Business Events project file. 
 
 

Loading an Event Flow Monitor Project 
 
An existing project may be loaded by clicking the Open Event Flow Monitor Project, selecing 
File > Open Event Flow Monitor Project or clicking CTRL-O.  
 
 
IMPORTANT: Because the Event Flow Monitor projects are not linked with the run-time system, it 
is possible that the scheme will no longer function if the WebSphere Business Events project is 
modified in any way. Because of this, it may be necessary to re-create the schemes in order to 
successfully view the run-time information. 
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Chapter 4 – Monitoring Event Flow Schemes 
  
Once one or more event flow schemes have been drawn the visualization of the run-time can 
take place.  
 
 

Enable Run Time Mode 
 
To start monitoring the scheme, click the Run Time Mode button 
 

 
 
There will be an immediate difference in the view of the application. Most notably a new toolbar 
will appear (1), run-time statistics will immediately be visible in the monitor scheme (2) and an 
event “heartbeat” view will appear at the bottom left (3). 
 

 
 
 
Simulating Events 
 

Because the application is connected to a live system, if there is already event data flowing then 
statistics will be immediately be visible in this window. However, if the environment is used for 
development, testing or demoing then events may need to be simulated. This can be done either 
via the WebSphere Business Events User Console Send Events function, or events can be sent 
directly from the Event Flow Monitor. 
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To send events from the Event Flow Monitor, right click on an event in the scheme and select 
Send Simulated Event. 
 

 
 
Alternatively, the Send Simulated Event button may be clicked. 
 

 
 
If the context menu is used, or if an event is selected, the event to fire will default to that which is 
selected in the scheme. Either way, any event defined in the current WebSphere Business 
Events project may be simulated. The event data can be entered here and the event will be sent 
to the run-time server. 
 

Note: The sending event functionality does not currently support sending arrays of data. 
If this is necessary, it is recommended to configure a connector to do this or to send the 
event via the cmdline routine from the director folder. 

  

 
 
Once the Send button is clicked, a confirmation window should appear.  
 

Note: The first time the event is sent from the application since the server restarted, this 
may take a few moments. 
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When returning to the screen, the view should be updated based on the Interaction Sets within 
the flow. Note that the event heartbeat (at the bottom left) has also updated.  
 

 
 
The current view is the “global” view. This means it is showing all of the possible data within the 
current environment. This is indicated by the Current Context ID selection of All. 
 

 
 
This list will be updated dynamically based on the data within the current system. In this case, 
there is a single context ABC123 since there has been only a single event.  
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If a second event is simulated with a different context (DEF456), the event flow scheme will show 
both contexts because the Current Context ID is still set to All. Note there are two original events 
(“Low Inventory”), however they each split to a different branch, so the rest of the events and 
actions have only a single occurrence. 
 

 
 
To drill down on or view a specific context, select a context other than “All”. In this example, the 
context ABC123 is selected. 
 

 
 
The resulting view will update with a few changes. First, only events and actions for this context 
will be shown. Second, the filters will change colors depending on what the evaluation was for the 
last correlation (so if a filter for a given context evaluated true three times and then the last was 
false, the filter will be displayed as red even though the filter had evaluated true in the past). This 
allows a user to determine why a flow took the path that it did. In this case, the product ABC123 
does not have an open purchase order (note the red filter in the first Interaction Set) so it took the 
right-hand branch. Since this product was not discontinued, it triggered the action Low Inventory 
Replenish Unknown. 
 

Note: Actions with a dotted connection arrow represent the default action (the “else” 
condition) of the Interaction Set. 
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By selecting the other context ID DEF456, the details on that flow can be seen as well. In this 
example, the product does have an open purchase order and the ETA is within bounds, so it 
triggered the action Shipment Delay 7 to 10 Days. 
 

 
 
Because the context list may become very large, it is also possible to filter the list by entering text 
into the Context ID Filter. For example, if only context IDs containing ABC should be available, 
the text “ABC” should be entered into the filter. 
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Chapter 5 – Toolbar Functions 
  
There are many other functions available within the application and this section is intended to 
briefly describe each of these. 
 
 

Main Toolbar 
 
The main toolbar is always visible, although some options may not be enabled in certain cases 
(for example, the delete option will not be enabled if there is nothing to delete). 
 

 
 

1. New Event Flow Monitor Project 
 

Clear the current Event Flow Monitor Project and start a new one 
 
2. Open Event Flow Monitor Project 
 

Open an Event Flow Monitor project from file 
 

3. Save Event Flow Monitor Project 
 

Save the current Event Flow Monitor project to a local file 
 

4. Import WBE Project from File 
 

Import a WebSphere Business Events project from a local project file 
 

5. Import WBE Project from Repository 
 

Import a WebSphere Business Events project directly from the current repository 
 

6. Create New Event Flow Monitor Scheme 
 

Start a new flow to monitor 
 

7. Delete Selected Event Flow Monitor Scheme 
 

Delete the selected monitor scheme from the current project and the tree 
 

8. Run Time Mode 

 
Enable the run-time visualization and simulation mode of the application 

 
 

Monitor Scheme Toolbar 
 
The monitor scheme toolbar is visible on all monitor scheme tabs. 
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1. Expand All Rules 
 

Expands all of the Interaction Sets and Business Steps to be fully visible 
 
2. Collapse All Rules 
 

Collapses all of the Interaction Sets and Business Steps so that only a single icon is 
visible which represents that object 

 
3. Zoom In 

 
Zoom in on the current flow 

 
4. Zoom Out 

 
Zoom out of the current flow 

 
5. Zoom All 

 
Zoom out so that all objects within the flow are visible within the window 

 
6. Reset Zoom 

 
Reset the zoom to where it was when the monitor scheme was originally created 

 
7. Pan Drawing Space 

 
Toggles a “panning” mode where the drawing space can be dragged to  
 
Note: Panning can always be done by clicking and holding the middle mouse button. 

 
8. View Grid 

 
Toggle a background grid for reference 

 
9. Snap to Grid 

 
Snap objects to the grid while dragging within the flow 

 
10. View Preview Window 

 
Toggle a preview window that displays the entire flow 

 
11. Show Hidden Objects 

 
Toggle the visibility of “hidden” objects 

 
12. Save Snapshot 

 
Allows a user to save the current view to a local image file 
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Run Time Toolbar 
 
The run-time toolbar is only visible when the application is in run-time mode. 

 

 
 

1. Send Simulated Event 
 

Send an event to the WebSphere Business Events engine from the current 
application 

 
2. Current Context ID List 
 

Select the context ID to view or select “All” for global 
 

3. Context ID Filter 
 

Filter the Current Context ID list by certain text 
 

4. Refresh Rate 
 

Set how often to contact the server for data updates 
 

5. Refresh Statistics Now 
 

Issue a manual refresh of all of the data (if refresh rate is set to a large interval) 
 


