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About this topic collection

This PDF has been created from the WebSphere Message Broker Version 6.1
(November 2008) information center topics. Always refer to the WebSphere
Message Broker online information center to access the most current information.
The information center is periodically updated on the [document update]site and
this PDF and others that you can download from that Web site might not contain
the most current information.

The topic content included in the PDF does not include the "Related Links”
sections provided in the online topics. Links within the topic content itself are
included, but are active only if they link to another topic in the same PDF
collection. Links to topics outside this topic collection are also shown, but these
attempt to link to a PDF that is called after the topic identifier (for example,
ac12340_.pdf) and therefore fail. Use the online information to navigate freely
between topics.

Feedback: do not provide feedback on this PDF. Refer to the online information to
ensure that you have access to the most current information, and use the Feedback
link that appears at the end of each topic to report any errors or suggestions for
improvement. Using the Feedback link provides precise information about the
location of your comment.

The content of these topics is created for viewing online; you might find that the
formatting and presentation of some figures, tables, examples, and so on are not
optimized for the printed page. Text highlighting might also have a different
appearance.

© Copyright IBM Corp. 2000, 2008 \%
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Developing message models

This topic area describes the concepts behind message modeling, and the tasks that
are involved in working with message models.

If you are unfamiliar with message models, read the topics that describe the
concepts, starting with [“Message modeling.”| These topics explain why you need to
model messages, and describe the message modeling objects that you will use,
such as message sets and message definition files.

The WebSphere® Message Broker message model is based on XML Schema. For
more information about XML Schema, see [XML Schema Part 0: Primer]

The tasks that are involved in developing message models are:

+ [“Working with a message set project” on page 81|

* [“Working with a message set” on page 82|

+ [“Working with a message definition file” on page 93|

+ [“Working with message model objects” on page 96|

* |“Creating a multipart message” on page 121|

[“Linking from one message definition file to another” on page 122|

* [“Working with a message category file” on page 123|

* [“Importing data structures” on page 127

* [“Generating documentation from message sets and message flows” on page 141]

Tip: The workbench provides a set of toolbar icons that invoke wizards that you
can use to create many of the resources that are associated with message
models; for example, a new message set. Hover your mouse pointer over a
toolbar icon to see its function.

Notice that the workbench lets you open resource files with other editors.
However, use only the workbench to edit resource files that are associated with
message models because this editor correctly validates all changes that you make
to these files.

Message modeling

Much of the business world relies on the exchange of information between
applications. The information is contained in messages that have a defined
structure that is known and agreed by the sender and the receiver.

Applications typically use a combination of messages, including those that are
defined by the following structures or standards:

¢ C and COBOL data structures
* Industry standards such as SWIFT or EDIFACT
e XML DTD or Schema

You can model a wide variety of message formats so that they can be understood
by WebSphere Message Broker message flows.

© Copyright IBM Corp. 2000, 2008 3
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When the message format is known, the broker can parse an incoming message bit
stream and convert it into a logical message tree for manipulation by a message
flow. After the message has been processed by the message flow, the broker
converts the message tree back into a message bit stream.

The following topics together give an overview of Message modeling:

+ [“Message modeling concepts”|

* [“Why model messages?” on page 6|

+ ["Message domains and parsers” on page 7|

* [“The message model” on page 7|

* [“Physical formats in the MRM domain” on page 38|

* [“Ways to create message definitions” on page 66|

+ |“Generate model representations” on page 77|

You can import either of the following samples to explore message set projects to
understand how the sample’s messages are modeled in different formats.

+ |Video Rental sample|

+ |Comma Separated Value (CSV) sample|

The following samples from the Samples Gallery also have message sets supplied:
+ [EDIFACT sample|

'

'

-

You can view samples only when you use the information center that is integrated
with the Message Broker Toolkit.

Message modeling concepts
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Message modeling is a way of predefining the message formats that are used by
your applications.

When you have modeled your messages, WebSphere Message Broker can use your
message models to automatically parse and write your message formats.

When you model messages, you need to understand the following concepts:
* Message set projects

* Message sets

* Message definition files

* Web Services Description Language (WSDL) files
* Message categories

* Model importers

* Model editors

* Model generators

* Model validator

* Domains and parsers


/help/livehelp/?pluginID=com.ibm.samplegallery&class=com.ibm.samplegallery.SampleGalleryAction&arg=com.ibm.etools.mft.samples.video.doc/doc/overview.htm
/help/livehelp/?pluginID=com.ibm.samplegallery&class=com.ibm.samplegallery.SampleGalleryAction&arg=com.ibm.etools.mft.samples.csv.doc/doc/overview.htm
/help/livehelp/?pluginID=com.ibm.samplegallery&class=com.ibm.samplegallery.SampleGalleryAction&arg=com.ibm.etools.mft.samples.edifact.doc/doc/overview.htm
/help/livehelp/?pluginID=com.ibm.samplegallery&class=com.ibm.samplegallery.SampleGalleryAction&arg=com.ibm.etools.mft.samples.fix.doc/doc/overview.htm
/help/livehelp/?pluginID=com.ibm.samplegallery&class=com.ibm.samplegallery.SampleGalleryAction&arg=com.ibm.etools.mft.samples.swift.doc/doc/overview.htm
/help/livehelp/?pluginID=com.ibm.samplegallery&class=com.ibm.samplegallery.SampleGalleryAction&arg=com.ibm.etools.mft.samples.x12.doc/doc/overview.htm
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A message set project is a specialized project (container) in which you create and
maintain all the resources that are associated with exactly one message set.

A message set is a logical grouping of your messages and the objects that comprise
them (elements, types, groups). A message set contains the following files:

* Exactly one message set file

* Zero or more message definition files

Zero or more WSDL files

e Zero or more message category files

Developing message models
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The message set file provides message model information that is common to all the
messages in the message set. You can create this information using the message set
editor.

When you have created a message set, you typically import application message
formats described by XML DTD, XML Schema, WSDL files, C structures, COBOL
structures, or EIS systems, creating and populating message definition files. You can
then edit the logical structure of your messages, and create and edit physical
formats that describe the precise appearance of your message bit stream during
transmission, using the message definition editor. Alternatively, you can create an
empty message definition file and create your messages using just the editor.

When your message definition files are complete, you can then generate the
message set in a form that can be used by a broker, parser, or application. This
might be in one of the following forms:

* A message dictionary for deployment to a broker

¢ An XML Schema for use by an application to validate XML messages, or for
deployment to a broker

* Web Services Description Language (WSDL) for a Web services client, or for
deployment to a broker

* Documentation to give to programmers or business analysts

Messages can be optionally grouped into message categories for convenience . You
can add messages to message categories using the message category editor.

Each time you save a message set file, message definition file, or message category
file, the content is validated to ensure that the message model that you are creating
follows certain rules. There are rules for both the logical structure and the physical
formats. This ‘model validation” ensures the integrity of your model, but does not

necessarily prevent you from saving a message model file that is not valid.

WebSphere Message Broker supplies a range of parsers to parse and write message
formats. Each parser is suited to a particular class of messages (for example,
fixed-length binary, delimited text, or XML) known as a message domain. When you
create a message set, you specify which domains the message set supports. This
determines which parsers can be used when you parse and write messages that are
defined within that message set.

Why model messages?

6 Message Models

WebSphere Message Broker supplies a range of parsers to parse and write message
formats. Some message formats are self-defining and can be parsed without
reference to a model. Most message formats, however, are not self-defining, and
the parser must have access to a predefined model that describes the message, if it
is to parse it correctly.

An example of a self-defining message format is XML. In XML the message itself
contains metadata as well as data values, enabling an XML parser to understand
an XML message even if no model is available.

Examples of messages that do not have a self-defining format are binary messages
that originate from a COBOL program, and from SWIFT formatted text messages.
Neither contain sufficient metadata to enable a parser to understand the messages.



Even if your messages are self-defining and do not require modeling, there are still
advantages in modeling them:

¢ Runtime validation of messages. Without a model, a parser cannot check
whether input and output messages have the correct structure and data values.

* Enhanced parsing of XML messages. Although XML is self-defining, without a
model, all data values are treated as strings. If a model is used, the parser
knows the data type of data values, and can cast the data accordingly.

* Improved productivity when writing ESQL. When you are creating ESQL
programs for WebSphere Message Broker message flows, the ESQL editor can
use message models to provide code completion assistance.

¢ Drag-and-drop message maps. When you are creating message maps for
WebSphere Message Broker message flows, the Mapping editor uses the message
model to populate its source and target views. Without message models, you
cannot use the Mapping editor.

* Reuse of message models, in whole or in part, by creating new messages that
are based on existing messages.

e Generation of documentation.

* Provision of version control and access control for message models by storing
them in a central repository.

To make full use of the facilities that are offered by WebSphere Message Broker,
model your message formats.

To speed up the creation of message models, importers are provided that take
metadata such as C header files, COBOL copybooks, XML Schema and DTDs,
WSDL files, and EIS metadata, and create message models from that metadata.
Alternatively, IBM has predefined models for common industry standard message
formats such as SWIFT, EDIFACT, X12, FIX, HL7 and TLOG.

Message domains and parsers

WebSphere Message Broker supplies a range of parsers to parse and write message
formats.

A parser is invoked when the bit stream that represents an input message is
converted to the internal form that can be handled by the broker. The internal
form, a logical tree structure, is described in [Logical tree structure} Similarly, a
parser is invoked to convert a logical tree back into a bit stream.

Each parser is suited to a particular class of messages (for example, fixed-length
binary, delimited text, or XML) known as a message domain.

When you create a message set, you specify which message domains the message
set supports. This determines which parsers are used when you parse and write
messages that are defined within that message set.

The parsers that are supplied with WebSphere Message Broker are described in

The message model
The message model consists of the following components.
* Message set projects
* Message sets

Developing message models 7
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* Message definition files
* WSDL files

* Message categories

See ["Message modeling concepts” on page 4| for a summary of these components,
and the relationship between them. See Related Concepts below for a detailed
description of each component.

The majority of your model content is described by message definition files. These
files use XML Schema to represent your messages. XML Schema is an international
standard that defines a language for describing the structure of XML documents. It
is ideally suited to describing the messages that flow between business
applications, and it is widely used in the business community for this purpose.
WebSphere Message Broker uses XML Schema to describe the structure of all kinds
of message format, not just XML.

Each message definition file describes both the logical structure of your messages,
and the physical formats that describe the appearance of your message bit stream
during transmission. If you are using the MRM or IDOC domains, you must
provide physical format information. This tells the parser exactly how to parse the
message bit stream. If you are not using the MRM or IDOC domains, physical
format information is not needed

To understand the different ways that you create and populate message definition
files, see [“Ways to create message definitions” on page 66)See [“Physical formats in|
[the MRM domain” on page 38| for a description of the physical formats that are
available to you.

Message set projects
A message set project is a specialized container in which you create and maintain all
the resources associated with one message set.

The content of a message set project is a single message set folder, the name of
which provides the name of the message set, and optionally, a single Adapters
folder, if the message set is modeling messages from EIS systems. You can create a
message set project using the following methods:

* The New Message Set wizard.
e The Quick Start wizards.

These restrictions apply to message set projects:
* A message set project must contain just one message set.

* A message set project cannot refer to any other message set.

Import either of the following samples from the Samples Gallery to see how
message set resources are stored in a message set project. The sample’s message
flow resources are stored separately in a Message Flow project.

+ [Video Rental sample]

* |Comma Separated Value (CSV) sample|

You can view samples only when you use the information center that is integrated
with the Message Broker Toolkit.

Message sets overview
A message set is a container for grouping messages and associated message
resources (elements, types, groups).


/help/livehelp/?pluginID=com.ibm.samplegallery&class=com.ibm.samplegallery.SampleGalleryAction&arg=com.ibm.etools.mft.samples.video.doc/doc/overview.htm
/help/livehelp/?pluginID=com.ibm.samplegallery&class=com.ibm.samplegallery.SampleGalleryAction&arg=com.ibm.etools.mft.samples.csv.doc/doc/overview.htm

A message set is a folder in a message set project that contains a messageSet.mset
file. The name of the folder is the name of the message set. A message set project
can contain just one message set.

When you create a new message set, a new message set project is automatically
created with a name that is the same as that of the message set.

You can base your new message set on an existing message set. In this case, all the
definitions in the existing message set are copied into the new message set.

When you have created your message set, you must specify the following key
properties:

Supported message domains
The message domains that are supported by the message set. The
supported domains determine what is generated for deployment to a
broker, and are used when parsing and writing the messages that are
defined within the message set.

Default message domain
The default domain of the message set.

Use namespaces
Indicates whether the message definitions that you create within the
message set are XML namespace aware.

Message set resources:

Resources within a message set are created as files, and are displayed under the
message set folder in the Broker Development view.

* Message set file messageSet.mset

There is always one, and only one, messageSet.mset file in a message set. This
file contains message model properties that are common to all the content of the
message set. It is also where you define the physical formats that you want for
this message set. These can be Custom Wire Format (CWF), Tagged Delimited
String Format (TDS), and XML Wire Format (XML).

The file is created for you when a new message set is created, and you
manipulate its content with the Message Set Editor.

* Message definition files that have the suffix .mxsd
You can have many message definition files in a message set. Each file contains

the logical model and the associated physical model, in XML Schema form, for a
group of related messages.

 WSDL files that have the suffix .wsd]l

These files are used by the SOAP domain. You can have many WSDL files in a
message set.

* Message category files that have the suffix .category

These files are optional. You can have many message category files in a message
set. A message category provides another way of grouping your messages,
perhaps for documentation purposes, or to assist with generating Web Services
Description Language (WSDL) files.

When you have completed the resources in your message set, you can generate the
content of the message set in a form that can be used by a broker parser or an
application. This might be:

* a message dictionary for deployment to a broker

Developing message models 9



10  Message Models

* XML Schema for use by an application building XML messages, or for
deployment to a broker

* Web Services Description Language (WSDL) for a web services client, or for
deployment to a broker

* documentation to give to programmers or business analysts
Message set identification:

A message set is identified by the name of the message set folder in the message
set.

When you need to refer to a message set from a message flow (for example, when
setting the Message Set property of an input node), use the message set name.

A message set also has a 13-character identifier that is guaranteed to be unique.
You can use this identifier, instead of the message set name, to refer to a message
set, but only if you are using the MRM or IDOC domains. Other domains do not
recognize the identifier.

A message set also has an alias. An alias can only be used with MRM multipart
messages.

Message set recommendations:

You can have as many message definition files as you want within one message
set, but you should limit your message sets to a few related message definition
files that share the same physical formats.

There are several reasons for this:

* Generation of a message dictionary and other representations is quicker.
* Generated documentation is more manageable.

* MRM physical formats apply to all objects within the message set.

Therefore, for example, if you are using the MRM domain and have an XML
message and an unrelated CWF message modeled in the same message set, CWF
physical format properties are present for all objects. But the CWF properties are
of no interest to the XML message and therefore take default values in those
objects. This can result in unwanted task list warnings.

* Recursion is not permitted for MRM CWF and TDS physical formats.

Therefore, if you are modeling XML messages that have a recursive structure,
you must ensure that recursive XML messages do not share a message set with
MRM CWF or TDS physical formats.

Message set version and keywords:

When you are developing a message set, you can define the version of the message
set and any other key information that must be associated with it.

After the message set has been deployed, the Configuration Manager can be used
to display the properties of the message set. These include the deployment and
modification dates and times (the default information that is displayed) and any
additional version or keyword information that you have set.

You can define information to give details of the message set that has been
deployed; therefore, you can check that it is the message set that you expect.



Version

You can set the version of the message set in the Version property.

You can also define a default message set version in the Default version tag of the
message set preferences. All new message sets that are created after this has been

set have this default applied to the Version property at the message set level.

Keywords

Keywords must be defined in the Documentation property of the message set.
These follow certain rules to ensure that the information can be parsed. The
following is an example of what you can define in the Documentation property:

$MQSI Author=John Smith MQSI$

The following table contains the information that the Configuration Manager
shows:

Message set name

Deployment Time 28-Aug-2004 15:04
Modification Time 28-Aug-2004 14:27
Version v1.0

Author John Smith

In this display, the version information has been defined using the Version
property of the object. If the version information has not been defined using the
Version property, it is omitted from this display.

Restrictions within keywords

Do not use the following characters within keywords because they cause
unpredictable behavior:

~$. | \<>24+%=8[]

You can use these characters in the values that are associated with keywords; for
example:

* $MQSI RCSVER=$id$ MQSI$ is acceptable

* $MQSI $name=Fred MQSI$ is not acceptable

Message definition files

A message definition file contains the messages, elements, types and groups which
make up a message set.

Every message set requires at least one message definition file to describe its
messages. Message definition files use the XML Schema language to describe the
logical format of one or more messages. Extra information in the form of XML
Schema annotations is used to describe any physical formats that you define for the
messages.

Large message sets can contain several message definition files. This keeps the
individual files to a manageable size, making them faster and easier to work with.

Developing message models 11
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Message definition files can be created using the Message Definition Editor, or can
be imported from a range of different file formats as described in [“Importing from|
fother model representations to create message definitions” on page 66|

A message definition file can be associated with a namespace, so that all message
model objects that are declared within the file belong to that namespace.
Namespaces provide a means of avoiding name clashes among similarly named

global objects. They are described in detail in [“Namespaces in the message model”]

One message definition file can reuse message model objects that are defined in
another message definition file. XML Schema provides two mechanisms to do this:

import and include. For more information, see [“Reusing message definition files”|
on page 37.

XML Schema and the message model:

XML Schema is an international standard that defines a language for describing the
structure of XML documents.

The XML Schema language is ideally suited to describing the messages that flow
between business applications, and it is widely used in the business community for
this purpose.

WebSphere Message Broker uses XML Schema 1.0 to describe the logical structure
of messages. At a simple level, the types and elements in the message are modeled
using XML Schema types and elements. However, when the need arises, most of
the advanced modeling features of XML Schema are available for modeling
messages.

Some important restrictions and extensions of XML Schema exist. These are
documented in [Schema restrictions in the message model”| and [’Schema|
fextensions in the message model.”

Further information about XML Schema: For details about XML Schema, see
[Schema Part 0: Primer{ on the [World Wide Web Consortium (W3C)| Web site.

Schema restrictions in the message model:
Some XML Schema 1.0 features are not supported in the message model.

Unsupported XML Schema features: The following feature is accepted, but not
supported, and causes validation errors if it is used in your message model:

¢ Redefines

Further information about XML Schema: For details about XML Schema, see
[Schema Part 0: Primer] on the [World Wide Web Consortium (W3C)| Web site.

Schema extensions in the message model:

The message model provides some facilities that are not specified in the XML
Schema 1.0 specification.


http://www.w3.org/TR/xmlschema-0/
http://www.w3.org/TR/xmlschema-0/
http://www.w3.org/
http://www.w3.org/TR/xmlschema-0/
http://www.w3.org/TR/xmlschema-0/
http://www.w3.org/

Messages: A message is a global element that represents an entire message (rather
than a structure within a message). Within a message definition file, a message is
represented by a special global element that carries the extra information required
by WebSphere Message Broker.

Composition: The message model adds the following compositions that are beyond
the XML Schema 1.0 specification:

message
A refinement of choice that is allowed to contain only a set of references to
messages within the same message set. Groups and complex types with
composition of message are used when modeling multipart messages.

orderedSet
A set of elements that must appear in the order that they are listed. Groups
are not allowed within an orderedSet. Elements can repeat, but duplicate
elements are not allowed.

unorderedSet
A set of elements that can appear in any order. Groups are not allowed
within an unorderedSet. Unlike an all group, elements within an
unorderedSet are allowed to repeat. However, duplicate elements are not
allowed.

Compositions orderedSet and unorderedSet allow message models that were
produced in earlier versions of the product to be supported.

Physical format information: If one or more physical formats are defined for a
message set, the XML Schema objects within the message set can hold extra
information about how they should be parsed and serialized.

Further information about XML Schema: For details about XML Schema, see m
[Schema Part 0: Primer| on the [World Wide Web Consortium (W3C)| Web site.

Message model objects:

This is an introduction to the objects that make up a message model.

Message
A message describes the structure and content of a set of data that is
exchanged between applications that send and receive the data. A message
is a special kind of complex element.

Simple element
A simple element describes one or more named data fields in a message. It
is based on a simple type (for example, string, integer or float). A simple
element can repeat, and it can define a default or a fixed value.

Simple type
A simple type describes a class of data within a message. It describes the
type of data (for example, string, integer or float) and it can have value
constraints which place limits on the values of any simple elements based
on that simple type.

Complex element
A complex element describes a named complex structure within the message.
The content of a complex element is defined by a complex type. A complex
element can repeat.

Developing message models 13
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Complex type
A complex type describes a complex structure within a message. It contains
elements (simple or complex), attributes, and groups that are organized into a
tree-like hierarchy.

Group A group describes a list of elements with information about how those
elements can appear in a message. Groups can be ordered (sequence or
orderedSet), unordered (all or unorderedSet), or selective (choice or
message). A group can repeat.

Attribute
An attribute describes an XML attribute. Attributes are very similar to
simple elements, but they require special treatment when used with XML
messages. In messages that are not XML messages, attributes are typically
not used, but if they do appear they are treated exactly like a simple
element based on the same simple type.

Global and local objects: Most objects in the message model can be either global or
local. A global object must have a unique name, which is used to refer to the object
from one or more places in the message model. Local objects are defined and used
in only one place in the message model.

Make objects local unless they need to be used in more than one place. This
reduces the probability of name clashes among the global objects in the message
model, and makes the message set easier to work with.

Properties of message model objects: The properties of all message model objects are
listed on the "properties” pane of the message definition editor. The properties fall
into three categories:

Logical
The logical properties of an object relate to the format-independent
description of the object called the 'logical model’. Logical properties
describe what data the object contains without saying anything about how it
is written down.

Physical
The physical properties of an object describe how the object is written
down. These properties control the parsing and writing of the object. There
is one set of physical properties for an object for each physical format in
your message set.

Documentation
This field is present for all message model objects. It provides a standard
place for any description of the object that you might require. Text entered
here does not affect the processing of messages in any way.

Message model objects: messages:

A message describes the structure and content of a set of data that is passed from
one application to another.

A message consists of elements that are organized into a logical structure agreed
by the sending and receiving applications. This logical structure can be modeled
using the Message Definition editor, so that message data can be parsed into a
logical tree and manipulated easily by the broker.



In the message model, a message is always based on a global element. The global
element’s complex type describes the contents of the global element, and therefore
describes all of the content of the message.

Multipart messages: If necessary, a message can contain other messages. This is
necessary for modeling certain large and complex messaging standards such as
SWIFT and EDIFACT. Such a message is known as a multipart message. The
contained messages are known as embedded messages.

Message identification: Messages are identified by their name or an alias. The alias
is an optional user-specified string that identifies the (multipart) message. The
name and alias of a message must be unique within a message set.

XML Schema model: In the message definition file, a message is modeled as an
XML Schema global element declaration. Extra information is provided by XML
Schema annotations on the element declaration.

Message model objects: elements:

An element is a named piece of information (a field) within a message, with a
meaning that is agreed by the applications that create and process the message.

An element has a specific meaning that is agreed by the applications that create
and process the message. For example, a message might include a string that your
applications have agreed is a ‘Customer Name’. An element is always based on a
type, either simple or complex.

An element:

* Has a business meaning.

* Is an instantiation of a simple or complex type.

* Can be accessed by name from ESQL or Java in a message flow node.

¢ Is further defined by its type; for example, the type defines the range of values
that an element can have.

* Can be defined globally or locally.

Simple and complex elements: Elements can be simple or complex. A simple element
is a single, named piece of information such as "Age” or ‘Customer Name’. A
simple element is based on a simple type that defines its content.

A complex element is a named structure that contains other elements. A complex
element named 'Customer Details’ might contain the simple elements "Age” and
‘Customer Name’. A complex element can also contain other complex elements. A
complex element is based on a complex type that defines its content and structure.

Global and local elements: Elements can be global or local. A global element can be
used in several different messages, or even in several places within the same
message. It must be given a unique name by which it can be referenced. A local
element is defined in one position within one complex type or group, and is not
available for reuse elsewhere in the message model.

Optional and repeating elements: Elements can be defined as optional, mandatory,
and repeating, using the properties Min Occurs and Max Occurs. For further
information, see [“Cardinality: optional, repeating and mandatory elements” on|
-ae 30.
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Default and fixed values: An element can be given a default value, so that if no
value is supplied by the message, the default value is used. Alternatively, a fixed
value can be defined, and the element always takes that value. The precise use of
default and fixed values is dependent on the message domain.

Value constraints: An element’s value can be constrained using value constraints
which define the range of legal values for the element. The value constraints are
actually associated with the simple type on which the element is based. For further
information, see [“Message model objects: simple types” on page 17| The XML
Schema term for a value constraint is a facet.

Defining substitution groups: If you are modeling XML messages, an element can be
marked as a valid substitute for another element by using the substitution group
property on the element. In this way, groups of elements can be assembled where
any of the elements in the group can substitute for one element, the head element.
For further information, see [“Substitution groups in the message model” on page

Message model objects: types:

Types describe the data content of elements.

Simple types describe simple elements with data types such as string, integer or
dateTime.

Complex types describe complex elements - elements that contain a hierarchy of
other elements.

For more information, see:

+ [“Message model objects: simple types” on page 17

* [“Message model objects: complex types”|

+ ["Message model objects: type inheritance” on page 19|

Message model objects: complex types:
A complex type describes the structure of one or more complex elements.

Complex types are an essential part of every message model because they define
the logical structure of the messages and elements in the model.

What is a complex type for?: Complex types define the structure of the messages
and elements in the message model. By combining elements, attributes, groups and
wild cards, almost any message structure can be modeled.

Contents of a complex type:
Elements

Most complex types contain some elements, and some contain a large
hierarchy of complex elements. The elements within a complex type are
always contained within a group. This group can be local to the complex
type, in which case the Message Definition Editor hides it from view. This
is the usual case.

Alternatively, the group that contains the elements can be a global group,
and this group defines the element content, the composition, and the
content validation for the complex type.



If a complex type is derived from a simple type, it is not allowed to
contain any element content.

Attributes
If you are modeling XML messages, your complex types can contain
attributes. The attributes for a complex type can be local or global, and
they can be contained within an attribute group.

Groups
Groups allow sets of elements to be included in a complex type. The
members of the group are included as peers of the other elements. For
more information about their use, see ["Message model objects: groups” on|

Wild cards
Complex types can contain wildcard elements, which allow unmodeled
elements to appear within any elements that are based on the complex
type. Any such elements must appear at the same position within the
message as the wild card. Complex types can also contain wildcard
attributes, which allow unmodeled attributes to appear within any
elements that are based on the complex type.

Global and local complex types: Complex types can be global or local. A global
complex type can be used as the basis for more than one complex element. It must
be given a unique name by which it can be referenced. A local complex type is
associated with a single complex element, and is not available for reuse elsewhere
in the message model. Local types do not have a name, and are displayed as
{Local complexType} by the message definition editor.

Composition: The composition of a complex type describes how the members of
the tiie are organized. For more information, see [“Message model objects: groups”]

Controlling validation of type content: The Content validation parameter on a complex
type specifies how strictly the contents of the type should be validated. For more
information, see [“Message model objects: groups” on page 20

Substitution settings: A complex type has parameters that control whether other
types can be derived from it (final) and whether other types can substitute for it
(block). For more information, see [“Substitution groups in the message model” on|
[page 31| and ["Message model objects: type inheritance” on page 19

Message model objects: simple types:

A simple type is an abstract definition of an item of data such as a number, a string
or a date.

The purpose of a simple type is to define the content of one or more simple
elements. Simple types (and any elements that are based on simple types) cannot
contain attributes or child elements. Simple types stand in contrast to complex
types, which define the structure of an element, but typically do not define any
simple data.

Global and local simple types
Simple types can be global or local. A global simple type can be used as the basis
for more than one element. It must be given a unique name by which it can be

referenced. A local simple type is associated with a single element, and is not
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available for reuse elsewhere in the message model. Local types do not have a
name.

Variations of simple types
Built-in

XML Schema defines a large number of simple types for you to use,
covering all the standard data types such as strings, integers, decimals, and
floats.

Restriction

You can define your own simple types by deriving from another simple
type (the base type) by restriction. A restriction type can have value
constraints applied to it.

A restriction type can derive from a built-in simple type or a user-defined
simple type.

List

A list type is a way of rendering a repeating simple value. The notation is
more compact than the notation for a repeating element, and offers a way
to have multi-valued attributes.

A list type can be based on a union type (see below). This can describe a
space-separated list of items in which each item can be based on any of the
simple types in the union.

A list of lists is not legal. The item type of a list cannot be a list itself, or
derived at any level from another list type, and results in a task list error
in the editor.

A list type can have the facets of minLength, maxLength and length
applied to it. These facets restrict the number of items in the list. To restrict
the values of each item in the list, facets should be applied to the item type
and not to the list itself. The message definition editor provides additional
support for enumeration and pattern facets directly on a List type, to
enable the import of any schema that uses them, but issues a warning that
enumeration and pattern facets are ignored by the broker.

Union
A union type is a union of two or more other simple types.

A union type allows a value to conform to any one of several different
simple types. The simple types that comprise a union type are known as
its member types. There is no upper limit on how many member types can
exist, but there must be at least one. A member type can be defined as a
built-in simple type, a user defined simple type, or a local simple type
defined anonymously within the union type.

A union type can also include list, union, and restricted simple types,
among its members.

MRM domain

The MRM parser does not apply value constraints until the data is in the logical
tree. This means that it is not possible to choose between two simple types that are
derived from the same fundamental type, but have different value constraints (for
example, an integer in the range 1-10 and an integer in the range 11-20). A warning
appears in the task list if this is attempted, and the parser ignores the value



constraints when it resolves the union. The message definition editor provides
additional support for enumeration and pattern facets directly on a Union type, to
enable the import of any schema that uses them, but the editor issues a warning
that enumeration and pattern facets are ignored by the MRM parser.

Value constraints

Any value constraints that are applied to the derived type must further restrict the
base type (and any elements based on it). It is not valid for a derived type to
weaken or remove a value constraint that its base type has defined. If no value
constraints are applied to the derived type, the derived type is almost identical to
its base type, but it is treated as a restriction of the base type in situations where
that is relevant (type inheritance and element substitution).

Message model objects: type inheritance:

The XML Schema language allows a type definition to be based on another type
definition. In this way, a hierarchy of types can be constructed.

This topic outlines the concepts of type inheritance, and highlights some important
issues relating to substitution.

A full discussion of XML Schema type inheritance can be found on the World Wide
[Web Consortium (W3C)| Web site, or in numerous books about XML Schema.

Restriction and extension: A type is a restriction of its base type, if elements of the
derived type have a smaller range of valid values (or valid type members) than
elements of the base type.

For example, a restriction of a complex type might reduce the number of
occurrences of one of its type members, or might omit that type member
completely.

Similarly, a restriction of a simple type might lower the Max Inclusive facet
value, or raise the Min Inclusive facet value.

A type is an extension of its base type if elements of the derived type have a wider
range of valid values (or valid type members) than elements of the base type.

For example, an extension of a complex type might add type members that were
not present in the base type, or might allow a type member to repeat.

Similarly, an extension of a simple type must always be a complex type that is
based on the simple type; you cannot extend a simple type by widening its
range of valid values.

Special rules apply to the derivation of simple types. A simple type cannot extend
another simple type. This ensures that restrictions that are imposed by a simple
type cannot be removed by deriving another simple type from it.

However, a complex type can extend a simple type. This does not affect the range
of valid values of the simple type, but it does allow attributes to be added. The
result of extending a simple type is always a complex type that contains zero or
more attributes.
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Controlling type inheritance: The final attribute on a complex type can take three
values, with the following effects:

* restriction: It is not valid to derive another complex type from this type by
restriction.

* extension: It is not valid to derive another complex type from this type by
extension.

e all: It is not valid to derive another complex type from this type by either
extension or restriction

Type inheritance and substitution: XML Schema provides two different substitution
mechanisms, both of which use type inheritance information to allow or disallow
substitutions.

Element substitution is controlled by substitution groups, and element substitution
can be blocked or allowed for extension and restriction by settings on either the
element itself or the element’s type.

Type substitution allows the type of the element to be defined within the instance
document, using the xsi:type attribute on the element, so that the element’s real
type is not known until the element has been partly parsed. This mechanism can
also be blocked or allowed based on the derivation method of the types involved.

Message model objects: groups:

A group is a list of elements that defines how those elements can appear in a
message.

Groups can be ordered (sequence or orderedSet) unordered (all or unorderedSet),
or selective (choice or message). Groups define the composition and content
validation of a set of type members.

What are groups for?: Groups can be used for any of the following purposes:
* To define the entire content of a complex type.

A complex type can refer to a global group that completely defines its content.
(If it does not, the content of the complex type is defined by an anonymous local
group, which is hidden within the Message Definition Editor.)

* To represent a common substructure within more than one type.
Two or more complex types can refer to the same global group, if they both
contain the same subset of elements.

* To change the composition midway through a complex type.

You might have a complex type that is a sequence of three members, but the
second member is a choice of two elements. To model this, a group with
composition set to choice can be inserted as the second member of the sequence.

Contents of a group: Groups can contain complex elements, simple elements,
wildcard elements and groups.

By combining these components, the structure of any message can be modelled.
Wildcard elements can be included to allow unmodelled elements to appear, thus

making the message model robust and flexible.

Global and local groups: Groups can be global or local.



A global group can be used in more than one place in the message model. It
represents a structure that appears in more than one place in the message model. A
global group must be given a unique name by which it can be referenced.

A local group is defined in one position within one group, and is not available for
reuse elsewhere in the message model. Local groups do not have a name, and are
displayed using the group’s composition by the message definition editor.

Composition: In XML Schema, a group can have its composition set to sequence,
all, or choice.

* A sequence is a set of elements that must appear in the same order as they are
listed.

* An all group is a set of elements that can appear in any order, and cannot
repeat.

* A choice is a set of elements, only one of which can appear in any given
message.

The message model also allows other compositions: orderedSet, unorderedSet, and
message. For more information, see [“Schema extensions in the message model” on|

Content validation: The Content validation property is applied only if the domain
is MRM or IDOC, and if validation is enabled.

Content validation determines how strictly the content of the group should be
validated. See ['MRM content validation” on page 191| for more details.

Allowable values of the Content validation property are:

Closed
The contents of the group are validated strictly against the model. Only
elements that are defined as children of the group can appear as children.

Open Defined
Elements that are declared within the same message set can appear as
children of the group, even if they are not defined as children.

Open Any elements can appear as children of the group.

The Content validation property does not affect validation in the XMLNSC or
SOAP domains. Validation in these domains follows the rules of XML Schema 1.0.

Message model objects: attributes:
An attribute describes an XML attribute.

Attributes are provided to simplify the modeling of XML messages; if none of your
messages use the XML physical format, use simple elements instead.

Attributes and XML: The most common use for an attribute is to model an XML
attribute within an XML message. In this scenario, each attribute that can appear in
the XML message has a corresponding attribute in the logical message definition.

Attributes in other physical formats: Sometimes a message needs to be parsed as
XML, but written in another physical format (Custom Wire Format or Tagged
Delimited String Format). In this case, any attributes in the message are treated in
exactly the same way as simple elements with the same properties.

Developing message models 21



22 Message Models

Global and local attributes: Attributes can be global or local.

A global attribute can be used in more than one place in the message model. It must
be given a unique name by which it can be referenced.

A local attribute is defined in one position within one complex type, and cannot be
used elsewhere in the message model.

Optional attributes: Attributes can be defined as optional, required or prohibited.
Attributes are not allowed to repeat. For further information, see |”Cardinality:|
[optional, repeating and mandatory elements” on page 30|

Default and fixed values: An attribute can be given a default value so that, if the
attribute is missing from the message, the default is used. Alternatively, a fixed
value can be defined, and the attribute always takes that value. The precise use of
default and fixed values is domain dependent.

Value constraints: An attribute’s value can be constrained by using value constraints,
which define the range of legal values for the attribute. Value constraints are
associated with the simple type on which the attribute is based. For more details,
see [“Message model objects: simple types” on page 17)In XML Schema, the term
for value constraint is facet.

Message model objects: wildcard elements:

A wildcard element represents an element that does not appear in the message
model, but which could appear at the same position as the wildcard element in the
message.

Wildcard elements provide a means of adding flexibility to the message model, so
that messages can be parsed even if they do not exactly match the message model.

Wildcard elements can only appear within a complex type or group with
Composition of sequence and Content Validation of closed. Wildcard elements
provide a similar capability to setting the Content Validation property of a complex
type or group to Open or Open Defined.

The Process Content and Namespace properties control the namespace to which
elements appearing in place of the wildcard element must belong.

MRM domain

If you enable validation in your message flow, and your message is in the
MRM domain, wildcard elements are validated against the model
according to the following rules:

* If Process Content is set to strict, only elements that are declared in the
same message set are allowed to appear in place of the wildcard
element.

* If Process Content is set to lax or skip, any element is allowed to appear
in place of the wildcard element.

If the broker is prior to WebSphere Message Broker Version 6.0, the
number of elements permitted to match against the wildcard element is
unpredictable (Min Occurs and Max Occurs are ignored).

Message model objects: wildcard attributes:



A wildcard attribute allows unmodelled attributes to appear in a message.

The Process Content and Namespace properties control the namespace to which
attributes that appear in place of the wild card must belong.

MRM domain

If you enable validation in your message flow, and your message is in the
MRM domain, wildcard attributes are validated against the model
according to the following rules:

* If Process Content is set to strict, only attributes which are declared in
the same message set will be allowed to appear in place of the wildcard
attribute.

* If Process Content is set to lax or skip, any attribute will be allowed to
appear in place of the wildcard attribute.

Tip: If the namespace property is set to the namespace of the message set,
these rules are then similar to the behavior of the XMLNSC domain in
validating mode.

Message model objects: attribute groups:
An attribute group defines a set of attributes that can appear in a complex type.

An attribute group provides a way to include the same set of attributes in more
than one complex type, without duplicating the definitions.

For example, if most of the elements in your message model have the attributes
‘amount’, ‘currency’ and ‘date’, these could be put into a single attribute group,
which is referenced by all the complex types that use them.

Message model objects: simple type value constraints:

Value constraints refine a simple type by defining limits on the values that it can
represent.

It is often useful to be able to constrain the values that an element can take,
perhaps to ensure that messages conform to business rules. This topic describes
how value constraints can be added to a simple type in order to constrain the
values of all elements that are based on the simple type.

The value constraints that are discussed here are modeled by XML Schema facets,
and are associated with a simple type.

Tip: If the message set is deployed to WebSphere Message Broker, all value
constraints can be validated, so that any violations will be reported as errors
Or warnings.

Types of value constraint:

Length Constraints : Length, Min Length, Max Length
Using length constraints, the length of all elements based on the simple
type can be constrained, or even limited to a single value.

Length constraints can be applied to simple types that are derived from
xsd:hexBinary, xsd:base64Binary or xsd:string (including built in schema
types such as xsd:normalisedString).
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Length constraints are inherited from ancestor types, and any length
constraints that are defined for a simple type must not relax the constraints
that are imposed by any of its ancestor types. For example, a type
"longString” (Max Length=100) cannot be derived from a type ‘shortString’
(Max Length=10).

Note: For the MRM domain, by default, Length value constraints are
converted to Max Length constraints when a message set is added
to a BAR file. This avoids WebSphere Message Broker raising
spurious validation errors for fixed-length data structures, where the
strings tend to be padded to fit a fixed-width field. If strict length
validation is required, this default can be changed in the message set
properties by changing the flag Broker treats Length facet as
MaxLength.

Range constraints : Min Inclusive, Max Inclusive, Min Exclusive, Max Exclusive

Range constraints specify the allowable range of values for all elements
that are based on the simple type. Inclusive constraints include the
specified endpoints in the allowed range, whereas exclusive constraints do
not. Range constraints can be applied to simple types that are numerical,
or that relate to calendar and time values. They cannot be applied to
strings, because the ordering of string values depends on the character set
that is used.

Range constraints are inherited from ancestor types, and any range
constraints that are defined for a simple type must not relax the constraints
that are imposed by any of its ancestor types. For example, a type
"largeNumber” (Max Inclusive=100) cannot be derived from a type
‘smallNumber’ (Max Inclusive=10).

The message model does not allow exclusive constraints to be applied to
non-integral types (float, decimal, double, dateTime, and so on).

Enumeration constraints

An enumeration constraint specifies a single allowed value for all elements
that are based on the simple type. A list of allowed values can be specified
by defining more than one enumeration constraint for the same simple
type. Enumeration constraints can be applied to all simple types.

Enumeration constraints are inherited from ancestor types, and any set of
enumeration constraints that are defined for a simple type must not
increase the range of allowed values. For example, a type "AllColors” (with
enumerations for all colors of the rainbow) cannot be derived from a type
"MonoColors” (with enumerations for ‘black” and ‘white” only).

Precision constraints : Total Digits and Fraction Digits

Precision constraints relate only to decimal values. They limit the number
of significant digits (total digits) and the number of decimal places
(fraction digits) for all elements that are based on the simple type.
Precision constraints can be applied to simple types that are derived from
xsd:decimal, but note that, at run time, the broker applies these constraints
only to xsd:decimal and user types that are derived from it; any precision
constraint that is applied to an integer simple type is ignored.

Precision constraints are inherited from ancestor types, and any precision
constraints that are defined for a simple type must not relax the constraints
that are imposed by any of its ancestor types. For example, a type
'veryPrecise’ (Fraction Digits=10) cannot be derived from a type
notVeryPrecise” (Fraction Digits=1).



Pattern constraints
A pattern constraint is a regular expression that specifies a set of allowed
values for all elements that are based on the simple type. Multiple patterns
can be defined for the same simple type, allowing complex validation rules
to be expressed in logically separate parts. Each pattern constraint on a
simple type contributes to the set of allowed values for elements that are
based on the simple type. In other words, all the patterns are combined
using Boolean OR.

As with all value constraints, a simple type can inherit pattern constraints
from the simple type on which it is based. In this case, the set of pattern
constraints that are contributed by each ancestor type must be satisfied, as
well as the set that is contributed by the simple type itself. In other words,
the sets of pattern constraints from each level in the type hierarchy are
combined using Boolean AND.

Pattern constraints can only be applied to simple types that are derived
from xsd:string.

Whitespace constraints
A whitespace constraint specifies how a parser should treat whitespace for
all elements that are based on the simple type.

Note: For the MRM domain, the MRM physical formats allow whitespace
to be controlled very precisely for each physical format that is
defined for the message, but these physical properties are separate
from the whitespace constraint in the logical model.

Message model object identification:

Objects in the message model (elements, attributes, types, groups) are identified by
their name only.

This means that no two objects in the same scope are allowed to have the same
name. Name clashes can be avoided more easily if global objects are used only

when necessary. Local objects are not visible outside of the scope of their parent
object, so their names can be re-used without causing a name clash.

Namespaces
If namespaces are enabled for a message set, each message definition file
within the message set can specify a namespace. Namespaces are an XML
Schema mechanism for organizing groups of related objects into a named
‘module’.

Global objects in different namespaces are allowed to share the same name.
Therefore, namespaces offer another means of avoiding name clashes
among global objects.

Valid names
Since the message model is based on the XML Schema language, the name
of every message model object must be a valid XML Schema identifier. For
information on what constitutes a valid XML Schema identifier, see
ISchema Part 0: Primer]|

For details about XML Schema, see XML Schema Part 0: Primer on the [World Wide
[Web Consortium (W3C)| Web site.

Multipart messages:
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A multipart message contains one or more other messages within its structure. The
contained message is sometimes referred to as an embedded message .

A multipart message must contain a group, or a complex type, with its
Composition property set to Message. This group or complex type can contain a
list of references to messages that are allowed to appear at that location in the
message structure, or it might be empty, allowing any message to appear. When a
message is parsed, only one message can appear in that position as an embedded
message.

Message envelopes: A common use of multipart messages is to define an outer
message with a fixed structure. This outer message is called the message envelope.
Within the message envelope a group or complex type is included, as described
above. Examples of message standards that can be modeled using this technique
are EDIFACT, X12, SWIFT, SOAP XML, SAP ALE IDoc, multipart MIME, and
RosettaNet.

Identifying the embedded message: When a multipart message is parsed, the parser
must be able to identify the embedded message; it might be any of the messages
that are referenced by the group or complex type, or it might be a message that is
not referenced by the group or complex type, perhaps from a different message set.
This is achieved using one of four techniques, Automatic, Message Identity, Message
Path, or Manual.

Automatic
Used when parsing XML messages, such as SOAP. The parser
automatically identifies and parses embedded messages using the tag in
the XML document.

Message Identity
Used by the MRM parser. See [‘Identifying an embedded message using al
[Message Identity.”]

Message Path
Used by the MRM parser. See [“Identifying an embedded message using a|
[Message Path” on page 29

Manual
Used by the MIME parser. The parser treats embedded messages as
BLOBs. If you want to parse the BLOB using another parser, you must do
so manually using ESQL, or Java, or a ResetContentDescriptor node.

Restrictions: Unless using the Manual identification technique, all embedded
messages must be of the same physical format as the outermost message, and have
the same character set and encoding.

When using the Automatic or Message Path identification techniques, all embedded
messages must be from the same message set as the multipart message.

Identifying an embedded message using a Message Identity:

This describes how you can identify an embedded message using the Message
Identity. Using the Message Identity to identify an embedded message is the
technique that replaces the use of the Message Key.

This technique is used by the MRM domain.



The Message Identity technique for identifying embedded messages is useful when
a multipart message has a format such as that shown in the diagram:

Message |dentity
Message Body
Message Trailer

In this example, the Message Header and Message Trailer act as an envelope for
the message body. They typically have a fixed structure, although the Message
Body can be defined with many different structures.

A place holder for an embedded message is created by setting the Composition
property of the complex type or group of the Message Body element to Message.
This allows an embedded message to be added at this point within the outer
Message, creating a multipart message.

When using the Message Identity technique to parse such a multipart message, the
embedded message must be identified earlier in the Message Header using a
Message Identity element. This is a string element (or attribute) that precedes the
embedded message in the model and whose Interpret Value As property is set to
Message Identity.

When a multipart message is input to a message flow, the Message Identity
element should have a value that corresponds to either the Name or the Message
Alias of the next embedded message in the bit stream. This enables the MRM
parser to correctly identify the embedded message in the model.

For cases where the Message Identity element value does not match the Name of
the message, use the Message Alias property to specify this value. The MRM
parser tries to match on Name first, and if that fails, it tries to match on Message
Alias.

Once the MRM parser has encountered a Message Identity element, its value
applies to all embedded messages that are contained immediately within the
current message. This does not apply to embedded messages within embedded
messages; any embedded message must have its identity provided by a Message
Identity element within its immediate parent message.

If a second Message Identity element is encountered within the current message,
its value overrides any previously held. This enables different peer embedded
messages to exist within a given message.

Message Identity takes priority over Message Path. If both are specified then
Message Identity is used. You should only use one of these techniques for a given
multipart message.

Embedded messages defined in different message sets

By default, an embedded message is assumed to be defined within the same

message set as the current message. This can be overridden using a Message Set
Identity, which works in a very similar manner to a Message Identity.

Developing message models 27



28  Message Models

An embedded message that is defined within a different message set must have its
message set identified earlier in the message using a Message Set Identity element.
This is a string element (or attribute) that precedes the embedded message in the
model and whose Interpret Value As property is set to Message Set Identity.

When a multipart message is input to a message flow, the Message Set Identity
element should have a value that corresponds to either the Identifier, Name, or
Message Set Alias of the message set that defines the next embedded message in
the bit stream. This enables the MRM parser to correctly identify the message set
to use.

If the Message Set Identity element value does not match the Identifier or Name of
the message set, use the Message Set Alias property to specify this value. The
MRM parser tries to match on Identifier first, then on Name, and finally on
Message Set Alias.

Once the MRM parser has encountered a Message Set Identity element, its value
applies to all embedded messages that are contained within the current message. It
also applies to embedded messages within embedded messages, unless an
embedded message also contains a Message Set Identity element.

If a second Message Set Identity element is encountered within the current
message, its value overrides any previously held. This enables peer embedded
messages to reside within different message sets.

The following example of an X12 message shows the use of both Message Identity
and Message Set Identity. The field that contains 004010X092 within the GS
segment on line 0002 holds the Message Set Identity as a Message Set Alias. The
207 on line 0003 in the ST segment is the Message Identity held as a Message
Alias. The embedded message is from line 0004 to 0015 inclusive.

Note: The line numbers and spaces at the beginning of each line are for illustrative
purposes only and do not exist in the actual message.

0001 ISA*00= *00%* *30+12-3456789 *77
*x9876543-21 *000104+1820*U*00401+000000001*0*T~*:!

0002 GS*HS*HOSP CLAIM*PAYER ADJDEPT+20000104%1820+1*X+004010X092!

0003 ST*270+1234!

0004 BHT*0022+13%10001234%19990501%1319!

0005 HLx1%%20*1!

0006 NM1%PR*2+ABCCOMPANY*x*+*PI+842610001!

0007 HL*2%1%21*1!

0008 NM1%1P%2+«BONE AND JOINT CINICx#%+xSV+<2000035!REF*N7+%234899!

0009 N3x55«HIGH STREET!

0010 N4xSEATTLE*WA%98123!

0011 HL*3%2%22+0!TRN+1%93175-12547%9877281234!

0012 NM1#IL*1+SMITH*ROBERT#B***MI*11122333301!

0013 REF*1L%599119!

0014 DMG*D8+19430519+M!

0015 DTP%472+RD8+19990501-19990515!EQ*30+*FAM!SEx17+1234!

0016 GEx1+1!IEA*1+000000001!

Physical format considerations

Both Message Identity and Message Set Identity are applicable to all physical
formats. Versions of the TDS physical format prior to Version 6.0 included
embedded message identification by Message Key, which worked in a similar
manner to Message Identity. Message Key has been deprecated and is superseded
by Message Identity.



Identifying an embedded message using a Message Path:

The Message Path technique for identifying embedded messages is useful when
the multipart message contains no information about the identity of an embedded
message.

This technique is used by the MRM domain.
In the diagram, the Message Header and Message Trailer act as an envelope for the

message body. Typically, they have a fixed structure, but the Message Body can be
defined with many different structures.

Message Body
Message Trailer

A place holder for an embedded message is created by setting the Composition
property of the complex type or group of the Message Body element to Message.
This allows an embedded message to be added at this point within the outer
message, creating a multipart message.

When using the Message Path technique to parse such a multipart message, the
embedded message must be identified by a fixed path to the innermost message
from the outermost message. For this example, this would be:

Message/Message Body

If the path to the innermost message contains intermediate elements, these
intermediate elements must also be included in the path. In the following example,
these elements are shown in bold:

Message/Datal/Datal2/Message Body

This technique can be used to identify nested embedded messages as well, by
simply extending the path. For example:

Message/Datal/Datal2/Message Body/Data2/Inner Message

The path is specified using one or both of two properties, the Message Type
property of a WebSphere Message Broker input node (or MQRFH2 header) and the
Message Type Prefix property of the containing message set. These two properties
are combined to produce a final path that is used to locate embedded messages.

Message Identity takes priority over Message Path. If both are specified, Message
Identity is used. Use only one of these techniques for a given multipart message.

You cannot use the Message Path technique to identify multiple peer embedded
messages.

Embedded messages defined in different message sets

This option is not supported by the Message Path technique.
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Physical format considerations
The Message Path technique is applicable to all physical formats.
Cardinality: optional, repeating and mandatory elements:

The number of occurrences of an element can be controlled using the properties
Min Occurs and Max Occurs. Using these properties, an element can be defined as
mandatory, optional or repeating.

Elements: A mandatory element has Min Occurs>= 1. A mandatory element must
occur at least once in an input message.

An optional element has Min Occurs = 0. An optional element can be omitted from
the input message.

A repeating element has Max Occurs> 1 or Max Occurs=-1, which indicates that an
unlimited number of repeats are allowed. A repeating element can occur more than
once in the input message, and all the occurrences must appear together without
any other elements between them.

If a complex type or a group contains two, or more, members that refer to the
same element, the second reference is a duplicate. This is different from a repeating
element, because the two references are typically separated by other members of
the type or group. In the input message, the second occurrence typically does not
appear immediately after the first occurrence. Duplicate element references are not
allowed within types and groups that have compositions of Choice, OrderedSet, or
UnorderedSet.

Attributes: The number of occurrences of an attribute can be controlled by setting
it to required, optional or prohibited.

A required attribute is similar to a mandatory element - it must occur in the input
message.

An optional attribute is similar to an optional element - it can be omitted from the
input message.

A prohibited attribute must not appear in the input message.

An attribute is not allowed to repeat, and duplicate attribute references are not
allowed within an attribute group.

Predefined and self-defining elements and messages:

An instance element is predefined if it is possible for the parser to find a matching
element definition in the message model with an appropriate set of properties and
in the correct context. Otherwise, it is self-defining. Similarly, an entire message is
self-defining if no corresponding message is present in the message model.

Self-defining elements can only be used when the physical format of the message
is a tagged format such as XML or TDS. If your physical format is fixed-length (C
or COBOL records) or untagged delimited (for example, comma separated), you
must ensure that your message model defines every message and every element
that needs to be parsed.



If you have chosen not to model your messages, or if no message sets have been
deployed to the broker, all messages and elements are self-defining. In this
situation, you cannot use message definitions to influence the parsing and writing
of elements; the self-defining elements are parsed and written according to the
default behavior of the parser and writer.

Self-defining elements, and all elements within a self-defining message, are not
validated against value constraints, and any missing fields are not assigned default
or fixed values, and all data is assumed to be string type.

However, if an element can be matched against the message model, the parsing
and the writing of the element is guided by the logical and physical formats that
have been defined. This provides a range of benefits, all of which arise from the
information that is provided to the broker through the message model.

Substitution groups in the message model:

Substitution groups are an XML Schema feature that provides a way of substituting
one element for another in an XML message.

A substitution group is a list of global elements that can appear in place of another
global element, called the head element.

A substitution group is defined by setting the substitution group property on one
global element (the member element) to point at another global element (the head
element). This adds the member element to the substitution group of the head
element.

Tip: If your messages are never rendered as XML, or if you have a simple message
model, use a complex type or a group with Composition set to Choice,
instead of using substitution groups.

Elements

Head elements
A head element is simply an element that can be substituted. When a
message is parsed, one of its member elements can appear in place of the
head element without causing a validation error.

Abstract elements
An abstract element is a head element which must be substituted. The
"abstract” attribute on the element indicates this. Typically, abstract
elements have other elements in their substitution group - otherwise they
are of little use. Wherever an abstract element appears in a message
definition, a member of its substitution group must appear instead.

Attributes

The block attribute on elements
The block attribute on an element limits the set of global elements that can
substitute for the element. The block attribute can take any subset of the
values restriction, extension, substitution, or all.

» If the block attribute contains restriction, an element that is based on a
restriction of the element’s type cannot substitute for the element.

* If the block attribute contains extension, an element that is based on an
extension of the element’s type cannot substitute for the element.
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o If the block attribute contains substitution, an element that is a member
of the element’s substitution group cannot substitute for the element.

¢ If the block attribute contains all, all of the above limits apply.

The final attribute on elements
The final attribute on an element limits the set of global elements that can
be a member of the element’s substitution group. The final attribute can
take any subset of the values restriction, extension, or all.

o If the final attribute contains restriction, an element that is based on a
restriction of the element’s type cannot be in the substitution group of
the element.

 If the final attribute contains extension, an element that is based on an
extension of the element’s type cannot be in the substitution group of
the element.

* If the final attribute contains all, both of the above limits apply.

The block attribute on complex types
The block attribute on a complex type limits the set of other types that can
substitute for that type. The block attribute can take values restriction,
extension, or all. The meanings for these values are the same as those
shown for the block attribute on an element above. An element that is a
member of a substitution group can only substitute for the head element if
its type is compatible with the block attribute on the type of the head
element.

Default block and final attributes
A default for the block and final attributes can be set at the message
definition file level. If a default for one or both of these attributes has been
set and the relevant block or final attribute has not been set at the object
level, the default setting is used for that object. You can override the
default setting at the object level.

Message categories
Message category files have the suffix .category. These files are optional. You can
have many message category files in a message set.

A message category provides another way of grouping your messages, perhaps for
documentation or convenience purposes, or for assisting in the generation of Web
Services Description Language (WSDL) files.

A message set category file is created using the New Message Category File
wizard.

When you have created your message category file, you must specify one key
property.
Message Category Kind

This indicates whether the message category is to participate in the
generation of WSDL files. See |“Generate WSDL” on page 79

You can then add messages to the message category file. If the message category is
to participate in WSDL generation, you should assign appropriate values to the
Role Name and Role Type properties of each member message.

Message category identification: The name of a message category is provided by
the name of the .category file. You can change the message category name by
renaming the file.



Namespaces in the message model
Namespaces provide a method to qualify object names.

XML instance documents and XML Schemas can use namespaces.

A single XML instance document can contain elements and attributes that are
defined for, and possibly used by, multiple applications. Two different elements or
attributes within the same document might require the same name. Individual
applications need to be able to recognize the elements and attributes that they are
designed to process. In circumstances such as this, the definitions can be
distinguished from each other by qualifying each element with a different
namespace. This avoids problems of name collision and mistaken recognition.

XML Schemas can define a target namespace. Global elements, attributes, groups
and types that are defined within an XML Schema are qualified by the target
namespace, if it has been defined. Optionally, local elements and attributes can also
be qualified by the target namespace. Therefore, namespaces assist in the
development of a library of XML Schemas that can be developed independently. If
the namespace name that is used for an XML Schema is unique, you do not have
to be concerned about name clashes with objects that are defined within other
XML Schemas.

The scope of a namespace extends beyond that of its containing document and is
identified by a Uniform Resource Identifier (URI). In order to serve its purpose, a
URI must be unique. You might be more familiar with the concept of a Universal
Resource Locator (URL). URIs often use the same syntax as URLs, but the URI
definition is broader than the specification of a URL. This is an example of a URL
http://mycompany.com/xml_schema

A namespace prefix is declared as a shorthand for the full URI name and this is
used to qualify all elements that belong to that namespace. The prefix to be
substituted for a namespace in an XML instance document or XML Schema is
specified using an xmlns attribute. A default namespace can also be defined using
an xmlns attribute. If a default namespace is defined, any element or attribute with
no prefix is qualified with the default namespace. If no default namespace is
defined, any element or attribute with no prefix is not qualified by a namespace.

The message model
The message model provides the ability to support namespaces within
message sets. However, you can choose whether you want to enable or
disable namespaces for your message set. If you choose to disable
namespaces when you create your message set, you can enable namespaces
later. However, when you have enabled namespaces for a message set you
cannot disable namespaces.

A single message set which has namespaces enabled can contain a number
of different namespaces. Each namespace is represented by a different
Message Definition File. When you create a Message Definition File, you
can choose whether it is to have an associated namespace, or whether it is
be in the notarget namespace. If you choose to associate a namespace with
a Message Definition File, you must also choose a prefix.

If the Message Definition File has an associated namespace, the following
global objects are qualified with the namespace:

* Elements

* Attributes

* Simple Types
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¢ Complex Types
* Groups
* Attribute Groups

Optionally, local elements and attributes can be qualified with the
namespace.

Objects that are defined within a Message Definition File can reference
objects in other Message Definition Files within the same message set. To
do this, import or include one Message Definition file within another
Message Definition File.

Message parsing and message flows
WebSphere Message Broker parsers that are namespace aware recognize
prefixed names in the XML messages that they parse, and internally map
these to the correct namespace. Elements and attributes can be either
qualified or not qualified with a namespace, as discussed in the message
model section.

If you are using XML format in the MRM domain, elements or attributes
are matched, based on the namespace in the dictionary when the parsed
message is matched against the dictionary that is generated from the
message model. Therefore, for an element or attribute in a message to
match with the dictionary, both its name and its namespace must match.

If you are using the DataObject domain, the SOAP domain, or the
XMLNSC domain (in validating mode), elements or attributes are matched,
based on the namespace in the XML Schema when the parsed message is
matched against the XML Schema that is generated from the message
model. Therefore, for an element or attribute in a message to match the
XML Schema, both its name and its namespace must match.

Support is provided that allows you to specify namespaces when writing
ESQL or Java. It is not necessary to write ESQL or Java that is namespace
aware if you are not using namespaces. However, if you decide to use
namespaces, your message definition files can target any namespace that
you choose, and it is necessary to write namespace-aware ESQL or Java.
The namespace in which an element resides is stored in the message tree
when parsed. This is a logical property and it is held regardless of the
physical wire format in which messages are parsed and written. Syntax has
been added to ESQL to make it easy to reference element’s namespaces
using defined prefixes. In Java, XPath expressions are used to reference
elements.

Importing from other formats
The message model allows you to create Message Definition files from
other formats by importing them into the Message Broker Toolkit.

* If you import an XML DTD file, the Message Definition File that is
created is in the notarget namespace.
* If you import an XML Schema file, the target namespace of the created

Message Definition File depends on whether namespaces have been
enabled for the message set.

— If namespaces are enabled, the target namespace of the Message
Definition File that is created is the target namespace of the XML
Schema that is being imported.

— If namespaces are disabled for the message set, the created Message
Definition File is in the notarget namespace. This type of import does
not provide full namespace support. If you are using WebSphere
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Message Broker, you do not have to write namespace-aware ESQL or
Java to process an XML message that is parsed against the dictionary
that is generated from this message model. For reasons why you
might want to do this, see [“Importing XML Schema into message sets|
fwith namespaces disabled” on page 69|

* If you import a COBOL Copybook or a C Header file, the target

namespace of the created Message Definition File depends on whether
namespaces have been enabled for the message set.

— If namespaces are enabled, the target namespace of the Message
Definition File that is created is the notarget namespace. This default
namespace can be overridden by specifying a target namespace in the
New Message Definition File wizard. For reasons why you might
want to do this, see [“Namespaces with MRM non-XML messages” on|
|o age 36.

— If namespaces are disabled for the message set, the Message
Definition File that is created is in the notarget namespace

Further information about XML: On the [World Wide Web Consortium (W3C)|
Web site, see:

» [Extensible Markup Language (XML)|
+ XML Schema Part 0: Primer]
+ [Namespaces in XML]

Namespaces with MRM XML messages:

The namespace that is associated with a message definition file is part of the
logical layer of the message model.

Therefore, it is not dependent on an XML Wire Format being present. However, if
you have an XML Wire Format, the namespace information from the logical layer
is used to populate some of the properties of the XML Wire Format. If namespaces
are enabled for a Message Set, in the XML Wire Format, a table of namespace
URI/prefix pairs is maintained. This table is initially populated with the
namespaces of all of the Message Definition Files with their prefixes when they
were created.

If your message set has namespaces enabled, the broker does not store the values
of any xmlns attributes in the tree when it parses an XML instance document. It
also does not store the values of any Schema Location and No Namespace Schema
Location attributes. When an XML document is written out, the broker regenerates
this information from the properties of the XML Wire Format of the message set.

The table of namespace URI/prefix pairs is used by the MRM Domain when it
outputs an XML message. Elements and attributes that are qualified by a
namespace are prefixed with the corresponding prefix from the table. The broker
also manages the output of the corresponding xmlns attributes that map the
prefixes to namespaces. You can choose whether xmlns attributes for all of the
entries in the namespace URI/prefix table are output at the start of the document,
or whether they are only output in the document when required.

If namespaces are enabled for a Message Set, in the XML Wire Format there is a
table of schema locations that map namespace URIs to file names. You can add
entries to this table and you can map a file name to the notarget namespace. If you
are using WebSphere Message Broker, this table is used to output schemalocation
and No Namespace Schema Location attributes at the start of the XML document.
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Namespaces with MRM non-XML messages:

The use of namespaces by WebSphere Message Broker is not necessarily limited to
XML message models.

There is one scenario where the use of namespaces by non-XML message models
can simplify the ESQL or Java code that you write. But before describing this
scenario, it is important to understand that the MRM parser, when parsing
messages that are defined in a Message Definition File that has a target namespace,
produces a logical message tree that contains both name and namespace
information. It does this regardless of the physical format of the message. For
non-XML (CWF or TDS) messages, the namespace is obtained from the Message
Definition file.

Consider a transformation scenario where a message from a COBOL application
requires to be transformed into namespace-aware XML; for example, a SOAP XML
message. The transform must map the logical message tree that was created for the
COBOL message to a logical message tree that matches the XML message. If the
COBOL message tree does not contain namespace information, each mapping from
a COBOL field to an XML element must set the namespace for the XML element.
However, if the COBOL message tree already contains the required namespace
information, this mapping is much simpler.

To enable the MRM parser to create namespace information in a message tree that
was created from a CWF or TDS message, you need to specify a target namespace
for the Message Definition File. This must be done as part of the Message
Definition File creation process; you cannot do this after the file has been created.
There are two ways to specify a target namespace. For each of these, make the
target namespace of the Message Definition File the same as the target namespace
of the XML message into which the non-XML message is being transformed.

* If you are creating your non-XML message model by hand in the message editor,
use the New Message Definition File wizard to specify a target namespace.

* If you are importing from COBOL or C, use the New Message Definition File
wizard, or the mgsicreatemsgdefs command options file, to specify a target
namespace.

When dealing with both the message tree for the non-XML message and the
message tree for the XML message, the ESQL or Java code that you write to
perform the transformation must be namespace aware.

Specifying namespaces in the Message Type property:

When using the MRM domain, the Message Type property is used to specify the
name of the message.

The format of a simple message type is {namespace-uri}:name where name is the
name of the message, and namespace-uri. identifies the namespace. The namespace
must be the full URI specification and must be enclosed in braces.

The format {namespace-uri}name (that is, with no colon) is also valid. This
maintains compatibility with previous versions of the broker product.

If you omit {namespace-uri}, the first match for the name that is found in the
model is used. You can do this if namespaces are not enabled for the message set,
or if a name is unique within a message set. However, if a name is not unique, you
must specify the namespace to be sure that the correct match is made in the model.



The following are examples of message types:

* A simple message type for a message in a real target namespace:
{http://www.ibm.com/space}:name

* A simple message type for a message in the notarget namespace: {}:name

* A simple message type for a message in a message set that does not support
namespaces: name

When identifying an embedded message using a message path, a message type
path would be entered as A simple message type for a message in a real target
namespace: {http://www.ibm.com/space}:name

The same name can occur in more than one namespace. To specify that a name is
to be qualified with a specific namespace, the name must be prefixed with the
namespace within the Message Type.

For example a Message Type with a single name would be entered as:
{http://www.ibm.com/space}:id/.../{http://www.ibm.com/space}:name

Reusing message definition files:

One Message Definition File can reuse message model objects defined in another
Message Definition File.

There are two mechanisms that XML Schema provides to do this: import and
include. The namespaces of the two files determine which of import or include
should be used:

Target file has a target Target file has notarget
namespace namespace

Parent file has a target xsd:import xsd:include'

namespace

Parent file has notarget xsd:import xsd:include

namespace

Note: When a target namespace file includes a notarget namespace file, referencing
an object in the target file from the parent file causes the object to appear in
the namespace of the parent file.

When import or include are used, global objects from the target file can be used in
the parent file. For example, an element in the parent file can be given a complex
type defined in the target file.

The namespace of objects in the target file is preserved in the parent file, with the
exception noted in the previous table of a target namespace file that includes a
notarget namespace file. This exception is sometimes called the chameleon
namespace effect.

Chameleon namespaces have limited support when used with the MRM domain.
When referenced in the parent file, the objects in the target file appear in the
namespace of the parent file, but they are assigned default physical format
information. In other words, physical format information defined in the target file
is not available for use in the parent file. Only use Chameleon Namespaces in the
MRM domain to model XML messages if physical format information has not
changed from the default.
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XML Schema provides a variation of xsd:include called xsd:redefine, which is not
supported by WebSphere Message Broker. Using xsd:redefine gives a task list error.
A Quick Fix is offered to convert occurrences of xsd:redefine into xsd:include.

Message model integrity

When you create your model, it is important that it is internally consistent and is
capable of being generated into the form that you want; for example, a message
dictionary or an XML Schema document.

To assist with this, whenever you save a message set file, it is validated as follows:

Logical validation
This validation ensures that the logical model is correct. For message
definition files, this involves ensuring that the rules of XML Schema have
been correctly followed.

Physical validation
This validation ensures that any physical formats that you have specified
for your model have been correctly populated. There is a set of checks for
each of the MRM domain physical formats - CWF, XML and TDS. This
ensures that the MRM parser can parse and write messages that conform
to your model.

Once validation has taken place, any errors or warnings are shown in the
task list. Double clicking on a task list entry opens the file and positions
the editor at the object in error. Organize the task list so that errors are
shown before warnings. In this way, errors are not hidden. The task list
provides a comprehensive filtering capability if you want to hide low
priority warnings, or warnings that you are know about and are
comfortable with.

The generation of a message dictionary or an XML Schema is prevented if
any errors are present. The presence of warnings alone does not prevent
generation, but high priority warnings must be reviewed because a model
that generates such warnings might be incomplete.

Where task list warnings or errors occur, these are listed in the Problems view of
the Broker Application Development perspective. While a majority of these require
you to manually investigate and resolve them, a number of warnings and errors
that meet specific criteria can be repaired using a quick fix process.

Physical formats in the MRM domain
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Each message definition file describes both the logical structure of your messages,
and the physical formats that describe the precise appearance of your message bit
stream during transmission.

If you are using the MRM domain or the IDOC domain, physical format
information must be provided, as it tells the parser exactly how to parse the
message bit stream.

You can think of a message as a packet of data that is sent from one place to
another. The sender and receiver of the message will have agreed the structure of
the message and what each field in the message means. This is the platform and
protocol independent logical structure.

The sender and receiver will have also agreed on the physical representation of the
message, how the data is physically laid out on the wire. For example, if you
define a message that conveys information about a debit of an individual’s bank



account, it can be represented in different physical forms (examples are XML, or a
fixed structure such as a COBOL copybook). The meaning and data is the same in
both cases: only the physical layout has changed.

If you are using the MRM domain, you can model a variety of different physical
representations using named physical formats.

¢ Use the Custom Wire Format (CWF) physical format to model fixed format
messages from applications that are written in C, COBOL, PL/1 and other
languages. This support includes the ability to create a message model directly
from a C header file or COBOL copybook.

* Use the Tagged Delimited String Format (TDS) physical format to model
formatted text messages, perhaps with field content identified by tags or
separated by specific delimiters or both. This support is rich enough to model
industry standards such as SWIFT, EDIFACT and X12.

¢ Use the XML physical format to model XML messages, including those that
exploit XML namespaces. This support includes the ability to create a message
model directly from an XML DTD or XML Schema file.

Different physical representations
The following example shows how a very simple logical message can have
different physical representations.

The logical model defines the structure and order of the message. In the following
example, the three fields are simple integers, and C follows B, which follows A:

int A;
int B
int C;

* A typical Custom Wire Format representation for this logical message would be
12 bytes of data, with each of A, B and C occupying 4 bytes. Alternatively,
perhaps A is 4 bytes long, but B and C are only 2 bytes long. You supply the
precise physical information for each field in the message as CWF properties.

* TDS allows several different representations to be modeled. Each integer could
be preceded by a tag to identify it and a delimiter to terminate it, as follows:

{A_tag:xxxxxxxx;B_tag:xxxxxxxx;C_tag:Xxxxxxxx}

An alternative might rely on the data being ordered so only the terminating
delimiter needs to be specified, as follows:

[XXXXXXXX 3 XXXXXXXX 3 XXXXXXXX]

You supply the precise identification regime as TDS properties.
* A typical XML representation of this model is as follows:

<Msg><A>XXXXXXXX</A><B>XXXXXXXX</B><C>Xxxxxxxxx</C></Msg>

where xxxxxxxx is the value of the integer represented as a string (XML deals
only with strings). An alternative representation might be:

<Msg A="XXXXXXXX" B="XXXXXXXX" C="XXXXXXXX"/>

where the values of the integers are stored as XML attributes rather than XML
elements. You supply the precise XML rendering for each field in the message as
XML properties.

This shows that the logical model is unchanged. It is constant, regardless of the
physical representation that you choose to model on top of it, using the physical

format support provided by the MRM domain. The MRM parser is able to
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transform the message from the input physical representation to any number of
output representations, based on the physical format layers that you have defined.

Creating physical formats

When you have created your message set, you can create physical formats. You do
this using the Message Set Editor. When you next save the messageSet.mset file,
any new physical formats are added to all the objects in all the message definition
files in that message set.

The next time you edit an object in a message definition file, you see the physical
formats in the properties hierarchy pane of the Properties tab. If you click on a
physical format for an object, you are presented with a property sheet where you
can enter the information for that physical format for that object.

Not all objects have properties in all physical formats. For example:

* CWF properties only apply to local elements and attributes, and element and
attribute references.

* Complex types and groups only have TDS properties.

* Messages only have XML properties.

These differences occur because of the different nature of each physical format, and
are explained in more detail in the section for each physical format.

There is no limit to the number of physical formats you can create in a given
message set. However there are some recommendations that apply if you want to
mix physical formats of different kinds in the same message set.

Physical formats can be deleted if no longer required.

MRM Custom Wire Format

Custom Wire Format (CWF) is the physical representation of a message that is
composed of a number of fixed format data structures or elements, which are not
separated by delimiters.

Within a CWF messaging environment, it is not possible to distinguish one element
from the next without knowledge of the message structure. To correctly determine
the values of individual elements, the following information must be made
available to the message parser:

* The order (this is defined in the logical properties)
* The length (can be specified in bytes, characters or character units)
* The cardinality (that is, the number of repeats)

* The type of data contained in each element (this is partly defined in the logical
properties but can be further qualified in the CWF physical format)

* A number of characteristics based upon the logical type of the data

A CWEF physical format is typically used to describe messages which are mapped
to a C structure, a COBOL copybook or other programming language data
structure definition.

You can add more than one CWF physical format to a message set, but within that
message set, each physical format must have a unique name. When parsing a CWF
message using the MRM parser, the physical format name specifies the physical
properties that are to be used by the parser.



Adding a CWF physical format to a message set allows you to process input
messages and construct output messages in this format. Messages can be
transformed between CWF and the other physical representations (for example
TDS or XML). Note that while the other physical representations support
self-defining elements (that is elements which do not have a definition in the
logical model) within the MRM domain, the parsing of a CWF message does not.
Consequently, any such self-defining elements are discarded during the output of
messages in CWF format.

Custom wire format: Message model integrity:

When you save a message definition file, the definitions that it contains are
checked to ensure that they make sense and provide sufficient information about
the message. This action is called model validation.

The CWF physical format depends on fixed format data structures. Therefore, the
majority of tests that are applied to a CWF message confirm that each fragment of
a message - and therefore, the message as a whole - has a well-defined length.
Therefore, these tests examine properties such as Length, Length Reference and
Length Units.

Typically, one or other of Length and Length Reference must be set. If Length
Reference is set, it must refer to an element that is of simple type integer and that
appears earlier in the message than the current item.

Tests other than these tend to be both simple and obvious so that, for example, the
message set property First Day of Week has to be the name of a day in the week.

The fact that CWF relies on fixed format data structures also imposes some
limitations on the messages that can be represented:

¢ CWF cannot represent a message that includes the use of XML Schema wild
cards; this is a consequence of its inability to handle undefined content.

¢ CWF cannot represent a message that includes recursive definitions.

* CWEF cannot represent a message that includes the use of substitution groups,
because there is no way to recognize the substituted element.

Custom wire format: NULL handling:

CWEF supports the handling of explicit NULL values within messages, provided
that the logical nillable property of the element is set.

An explicit null is identified by a specific value that identifies an element as being
null.

The Boolean Null Value can be specified at the message set level, and applies to
the Boolean elements of all messages that are defined in that message set. The null
value of all other element types can be specified individually for each element.

CWEF supports the representation of null values using the Encoding Null and
Encoding Null Value element properties. Together, this information controls how

null values are handled by the MRM parser.

The Encoding Null property can be set to one of four values:

NullLogical Value
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The Encoding Null Value property is interpreted as a logical value.
Therefore, if its value is set to 0, for example, both 0 and 0.00 are
interpreted as null values.

NullLiteral Value

The Encoding Null Value property is interpreted as a string value.
Therefore, the value of the element in the bit stream must match exactly
the value that is specified to be interpreted as a null value.

NullPadFill

This should be used for fixed length elements. On output, any element
with a null value is padded to the appropriate length with the specified
padding character.

NullLiteralFill

The Encoding Null Value property is interpreted as a single character
string value. Therefore, each character of the value of the element in the bit
stream must match exactly the character value specified to be interpreted
as a null value.

Custom wire format: Multipart messages:

The Custom Wire Format (CWF) supports both the Message Identity technique and
the Message Path technique of identifying embedded messages within a multipart
message.

Alternatively, you can resolve an embedded message by using ESQL or Java to
identify the message. The first message that you reference in this way is assumed
to be the selected message. This technique works in an identical manner to
unresolved choice handling.

Custom wire format: Data Conversion: The Custom Wire Format supports the
conversion of data to a different code page (for string simple types) or encoding
(for numeric simple types), or both.

A message set contains properties to enable the character (CCSID) and numeric
encoding (Byte Order / Float Format) information to be specified. If you generate a
message dictionary for deployment to a WebSphere Message Broker, then this
information can be overridden using the appropriate fields of the WebSphere MQ
message header, or other transport header.

Custom wire format: relationship to the logical model:

There are some restrictions in relation to the logical model for messages that are
defined using the CWFE.

Composition: A CWF message is always written with the elements in the sequence
that is specified in the logical message model definition. However, you do not
always have to specify the ESQL or Java that builds the elements in that sequence.
The following rules for coding ESQL are given for each value of the type
Composition property.

Sequence
You must build the output message to match the sequence of the elements
or groups in the message. You can normally do this using ESQL SET
statements to assign a value to each element or type. The first SET
statement sets the value of the first element or type in the message, the



second SET statement sets the value for the second element or type, and so
on. You can vary this sequence of statements using ESQL ATTACH,
CREATE, and MOVE statements.

If the elements or types have default values, and you do not build the
message in the correct sequence, those elements that are built out of
sequence contain their default values, not the values that you set. This is
because elements that are built out of sequence are assumed to be
self-defining and, for CWE, these are discarded when the message is
written to the bit stream.

Ordered Set
You must build the output message to match the sequence of the elements
in the message. You can normally do this using ESQL SET statements to
assign a value to each element. The first SET statement sets the value of
the first element in the message, the next SET statement sets the value for
the second element, and so on. You can vary this sequence of statements
using ESQL ATTACH, CREATE, and MOVE statements.

If the elements have default values, and you do not build the message in
the correct sequence, those elements that are built out of sequence contain
their default values, not the values that you set. This is because elements
that are built out of sequence are assumed to be self-defining and, for
CWE, these are discarded when the message is written to the bit stream.

Unordered Set
You can build elements of the output message in any sequence. On output,
the elements are written in the order that is specified in the logical
message model definition.

All You can build elements of the output message in any sequence. Each
element must only be present once (that is, it must not repeat). On output,
the elements are written in the order that is specified in the logical
message model definition.

Choice
A choice cannot be resolved purely from the data. The receiving program
must interpret the data and decide which option of the choice the message
instance contains. This process is known as unresolved choice handling. The
first reference in the application to any one of the choice elements resolves
the choice to the option that contains that element.

Message
Mechanisms for the resolution of embedded messages are discussed in the
|“Custom wire format: Multipart messages” on page 42| topic.

Content validation: CWEF is a fixed format, and all elements must be present in a
message. Therefore, content validation is ignored. On output, all elements must be
set explicitly (for example, using ESQL SET), set implicitly (using a tree copy
function), or must have a default value defined.

Default values: On output of a CWF message in the MRM domain, any element, or
occurrence of an element for which a value has not been set (either explicitly or
implicitly), inherits the element’s specified default value. If no default value has
been specified then an exception is thrown.

Min Occurs and Max Occurs: The logical properties Min Occurs and Max Occurs
specify the permitted number of occurrences of an element, or group, in a message.
These properties are used when parsing and writing messages, and when
validating the content of a message.
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In CWE, Max Occurs occurrences are expected when parsing, and Max Occurs
occurrences are output when writing. Default values are used for missing elements,
and any excess elements are discarded.

* A varying number of occurrences (Min Occurs <> Max Occurs) is ignored, Max
Occurs is assumed.

* Optional occurrence (Min Occurs = 0) is ignored, Max Occurs is assumed.
* Always absent (Max Occurs = 0) is allowed.

* An unbounded number of occurrences (Max Occurs = -1) is allowed if the
element or group is the last child in its parent group, and the group is
terminated by the end of the message bit stream. On writing, the writer outputs
all occurrences in the message tree, if this number is less than Min Occurs then
additional default values are written.

These rules arise because, in a CWF message format, there are no tags or other
markup that can be used to determine the end of a variable number of repeats.

However this behavior is overridden if the CWF property Repeat Reference is set,
which indicates that the number of occurrences is given instead by an integer
element that occurs earlier in the message. In this case Max Occurs is ignored.

When validating, Min Occurs and Max Occurs are both used to check that the
content of the message tree matches the model.

Simple types — lists and unions: Lists and unions are XML-specific concepts. An
element or attribute of a simple type that is a list or a union will cause a task list
warning if a CWF physical format is present in the message set. The user can
choose whether to make this an error, warning, or information by editing the
Validation preferences. The dictionary generator will omit messages defined to
contain such elements or attributes from the CWF section of the dictionary.

MRM TDS format

The Tagged/Delimited String format (TDS) is the physical representation of a
message that has a number of data elements separated by tags and delimiters.

The TDS physical format is designed to model messages that consist of text strings,
but it can also handle binary data. Examples of TDS messages are those that
conform to the ACORD AL3, EDIFACT, HL7, SWIFT, or X12 standards. The TDS
physical format allows a high degree of flexibility when defining message formats,
and is not restricted to modeling specific industry standards; therefore, you can use
the TDS format to model your own messages.

TDS message characteristics: There are a number of features of text string
messages that are common to many formats. This is an overview of the main
features that are supported by the TDS physical format:

Tags  The text strings in the message can have a tag or a label preceding the data
value. The tag is a string that uniquely identifies the data value. The TDS
format allows you to associate a tag with each element when you define
the element.

Delimiters and tagged data separators
The message can contain various special characters or strings in addition to
the tags and text string data values. The TDS format supports a number of
different types of special characters or strings.

Some messages have a special character or string that separates each data
value from the next. In the TDS format this is a known as a delimiter.



In formats that have a tag before each data value, the tag can be separated
from its data value by a special character or string. In the TDS format this
is known as a tag data separator.

Group indicators and terminators
A message can be split into a number of substructures in a similar manner
to a COBOL or C structure. You can model each of these substructures
separately by defining groups, complex types or elements for each one.

A substructure can have a special character or string that indicates its start
within the data. This is known in the TDS format as a group indicator.

A substructure can also have a special character or string that indicates its
end in the data. In the TDS format, this is known as a group terminator.

A group indicator and group terminator can also be defined for the whole
message. Group indicators and group terminators are optional for the
message and each substructure.

Fixed length strings
Some text strings within a message can be of fixed length; therefore, a
delimiter between each data value is not necessary. This is supported by
the TDS format.

Fixed length tags
Some tags can be defined as fixed length; therefore, a tag data separator is
not necessary.

Separation types
The TDS property that controls the way text strings are separated is Data
Element Separation. It has several options that let you choose, for example,
whether tags are used, whether strings lengths are fixed or variable, and
what types of text strings are permitted.

The substructures within a message can use different types of data element
separation and use different special characters. Therefore the TDS format
allows you to define different types of data element separation and special
characters for each complex type within the message.

Regular Expressions
If you choose the Use data pattern option for Data Element Separation,
you can use regular expressions to identify parts of the message data to be
assigned to sub-fields. This is done by setting the regular expression in the
Data Pattern property.

The diagram below shows an example data message with each of its components
labeled.
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At the top level, each data value has a tag associated with it, each tag is
separated from its data value using a tag data separator of colon (:), and the data
values are separated from each other using the asterisk delimiter (*).

* The group indicator for the message is the left brace ({) and the group terminator is
the right brace (}).

* The data values Data2 and Data3 are in a substructure in which there are no
tags, and each data element is separated from the next using the plus delimiter
(+). The group indicator for this substructure is the left bracket ([) and the group
terminator is the right bracket (]).

* The data values Data4 and Data5 are in a substructure in which the values are
fixed length, and are therefore not separated by a delimiter. The group indicator
for this substructure is the less than symbol (<) and the group terminator is the
greater than symbol (>).

TDS format: Determining the length of simple data values:

The TDS format supports two categories of simple data types: textual and
non-textual.

The Physical Type of an element determines whether it is categorized as textual or
non-textual.

Textual data
Physical Type is either Text or TLOG Specific. For textual data, the Data
Element Separation of the parent complex type or group determines how
the length of the data is determined. See [“TDS format: Data element|
lseparation” on page 47| and its subtopics.

Non-textual data
Elements of all other Physical Types are non-textual. The length of
non-textual data is determined by the Physical Type of the element. For
non-textual data, the Data Element Separation property of the parent
complex type or group does not determine the length, unless Data Element
Separation is Use Data Pattern. See [“TDS format: Data pattern separation|
[types” on page 56 for more information.

The following table describes how the length of data is determined for
each Physical Type.



Physical Type

Determination of Length

Text
TLOG Specific

The Data Element Separation of the parent
complex type or group determines how the

length of the data is determined.

External Decimal Uses the value of the Length property of the
Integer element.

Packed Decimal

Float If Physical Type is Time Seconds, the Length
Time Seconds property is set to 4. If Physical Type is Time

Time Milliseconds Milliseconds, the Length property is set to 8.

In neither case can this value be changed.

Length Encoded String 1
Length Encoded String 2

Uses the encoded length value in the data.

Uses the null terminator at the end of the
data.

Null Terminated String

Binary Uses the value of the Length Reference or
Length property of the element.

TDS format: Data element separation:
Data element separation defines how a TDS message is to be parsed.

Data element separation defines which method of identifying data elements is to
be used and how the data elements are constructed. The different methods vary
from full flexibility to fixed format, depending on how they are defined.

The four main types of data element separation are:

Fixed length types
Fixed length types are dependent on each element having a length. See
[“TDS format: Fixed length separation types.”]

Tagged separation types
Tagged separation types are dependent on each element having tag prefix
to identify it. See [‘TDS format: Tagged separation types” on page 49

Delimited separation types
Delimited separation types use delimiters to identify the end of one data
elements and the beginning of the next. See ["TDS format: Delimited|
lseparation types” on page 51,

Data pattern types
Data pattern types use a regular expression to identify each element. See
[“TDS format: Data pattern separation types” on page 56

There is a fifth category, which is different from the four described above:

Undefined separation types
Undefined separation types contain no data elements. They are applicable
to embedded messages only, and should not be used for anything else.
They use none of the TDS type-specific parameters other than Data
Element Separation. See [“Multipart messages” on page 25/

TDS format: Fixed length separation types:

For fixed length separation types, each data value is a fixed length.
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For fixed length data element separation types, all textual elements have a length
or length reference, and are padded out to their full length in the bit stream. No
tags or delimiters are used, and each data value directly follows the preceding data
value.

For example:
dataldata200data30

The first element is length 5, the second is length 7 and the third is length 6. The
padding character is "0".

For non-textual elements, the length is determined by the Physical Type of the
element. See [“TDS format: Determining the length of simple data values” on page]

Fixed length type: In fixed length type, all textual elements must have a length or
length reference, and must be written out to that full length. The elements must be
presented in the correct order, and all elements must be written in the bit stream.
This includes all repeats of any repeating element (that is, the Maximum
Occurrences must be written out for each element).

For non-textual elements, the length is determined by the Physical Type of the
element. See [“TDS format: Determining the length of simple data values” on page|

For example:
datalOdata2data2data2data3e0

The first element is length 6, the second is length 5 and repeats three times, and
the third element is length 7. The padding character is "0".

Applicable parameters: The main parameters for this format are the Length or
Length Reference of the element. All fields must be padded out to their full length
for the bit stream to be correctly specified to the parser.

Tag and delimiter parameters are ignored. Group indicators and terminators are
observed, because they are of fixed length.

Default values are required for each field that might not be set, because then every
field can be output, even if it is not filled with data from the message.

Fixed length AL3 type (Deprecated): This separation type has been deprecated.
ACORD AL3 support will be provided by a different method in a future release, at
which time this separation type will be removed from service.

Fixed length AL3 types are similar to fixed length types, but follow extra rules that
are specified by the ACORD AL3 format regarding truncation and missing
elements. If elements are missing from the end of an AL3 type, they can be
truncated. They cannot be omitted from the middle of a bit stream. If a field is
missing from the middle of the bit stream, that field is output as the appropriate
length string of the "?” character.

Applicable parameters: The main parameters for this format are the Length or
Length Reference of the element. All fields must be padded out to their full length
for the bit stream to be correctly specified to a parser.



Tag and delimiter parameters are ignored. Group Indicators and Terminators are
observed, because they are of fixed length.

TDS format: Tagged separation types:

For tagged separation types, each data value is preceded by a tag that is specified
as an element property.

The Tag Data Separator, or specific Length of Tag parameter is used to determine
where the tag ends and the data starts. Different methods are used by each
separation type to determine the end of the data.

After considering these two parameters, this topic describes the following
supported tagged separation types:

+ [“Tagged Delimited separation”]

* |“Tagged Fixed Length separation” on page 50|

* |"Tagged Encoded Length separation” on page 50|

Tagged separation is a flexible format. The elements do not have to occur in a
specific order. They do not all need to be present, and can be absent from any
point in the message.

Tag Data Separator and Tag Lengths: Either Tag Data Separator and Length of Tag
are used by all tagged separation types. But only one of these parameters can be
set at the same time.

The point at which a tag ends and data starts can be determined by one of two
methods. If the Tag Data Separator is set, then this character indicates where the
data ends. For example, the string might be:

tagl:datal
where Tag Data Separator is :

However if the Tag Data Separator is not set and the Length of Tag field is set,
then the tag is the specified length, and is immediately followed by the data. No
separating character is required. For example, the string might be:

tagldatal
where Length of Tag is 4

Tagged Delimited separation: Tagged Delimited separation is a completely flexible
format. Elements are separated by a predefined delimiter. The textual elements are
not of specific lengths. For non-textual elements, the length is determined by the
Physical Type of the element. See [“TDS format: Determining the length of simple|
[data values” on page 46

Applicable parameters: These parameters are used:

* Group Indicator indicates the start of a group or complex type.

* Group Terminator indicates the end of a group or complex type.

* Delimiter separates the data elements within a group or complex type.

* Tag for each element, indicates the tag needed to precede the data in that field.
* Either Tag Data Separator or Tag Length as described above.

Examples: If Tag Data Separator is set to :
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{tagl:datal*tag2222222:data2*tag333:data3}

where:

* Group Indicator is {.

* Group Terminator is }.

* Delimiter is *.

* Tag defined for each element, is tagl (for datal), tag2222222 (for data2), and
tag333 (for data3).

or, for example, if Length of Tag is set to 5

{taglldatal*tag22data2*tag33data3}

where parameters are as above, except:

* Tag, defined for each element (fixed at 5 characters), is tagll (for datal), tag22
(for data2), and tag33 (for data3).

Tagged Fixed Length separation: Although Tagged Fixed Length separation is a
flexible format, the data must be a specific length. This means that a delimiter is
not needed to determine the end of each element.

Applicable parameters: These parameters are used:

* Group Indicator indicates the start of a group or complex type.

* Group Terminator indicates the end of a group or complex type.

* Tag for each element, indicates the tag needed to precede the data in that field.

* For each textual element, Length or Length Reference indicates the length of the
data (this value does not include the length of the tag). For non-textual elements,

the length is determined by the Physical Type of the element. See [“TDS format:
[Determining the length of simple data values” on page 46,

* Either Tag Data Separator or Tag Length as described above.

Examples: 1f Tag Data Separator is set to :
{tagl:dataltag22222222:data2000tag333:data300}

where:

* Group Indicator is {.

* Group Terminator is }.

* Delimiter is *.

* Tag, defined for each element, is tagl (for datal), tag22222222 (for data2000), and
tag333 (for data300).

* Length, defined for each element, is 5 (datal), 8 (data2000), and 7 (data300).

or, for example, if Length of Tag is set to 5
{taglldataltag22data2000tag33data300}

where parameters are as above, except:

* Tag, defined for each element (fixed at 5 characters), is tagll (datal), tag22
(data2000), and tag33 (data300).

Tagged Encoded Length separation: This method has both a tag and a length field
before the data. The length field indicates to the parser the length of the data
following it.



The length of this length field is itself defined in the Length of Encoded Length
parameter. Extra lengths to be added in this, such as the length of the field itself, is
set in the Extra Chars in Encoded Length parameter.

Only textual elements and elements with a Binary logical and physical type are
supported within a Tagged Encoded Length separation.

These examples show how the values set in these parameters are applied:

tagA007dataAAAtagBO06dataBBtagC009dataCCCCC

If Length of Tag is 4, Length of Encoded Length is 3, Extra Chars in Encoded
Length is 0, then in this bit stream, TagA is followed by the 3 character long
length field. This indicates that the following data (dataAAA) is 7 characters long.
The next field, tagB is then considered, and so on.

tagA0l2dataAAAAAtagBO10dataBBBtagCOl6dataCCCCCCCCC

If Length of Tag is 4, Length of Encoded Length is 3, Extra Chars in Encoded
Length is 3, then in this bit stream, TagA is followed by the 3-character length
field. This indicates that the following data, plus extra characters, is 12
characters long: length of the length field (3) + length of data (9) = 12. Therefore
the length of the actual data is only 12-3 = 9. The next field, tagB is then
considered, and so on. In each case the length given in the bit stream is 3 greater
than the actual length of the data.

Applicable parameters: These parameters are used:

Group Indicator indicates the start of a group or complex type.
Group Terminator indicates the end of a group or complex type.
Tag for each element, indicates the tag needed to precede the data in that field.

Length of Encoded Length indicates the length of the length field in the bit
stream.

Extra Chars in Encoded Length indicates how many extra characters should be
included in calculating the value for the length field in the bit stream.

Either Tag Data Separator or Tag Length as described above.

Examples: If Tag Data Separator is set to :
{taglll1:008dataltag222222222:010data2AAtag3333:009data3A}

where:

Group Indicator is {

Group Terminator is }

Length of Encoded Length is 3

Extra Chars in Encoded Length is 3

Tag, defined for each element, is tag1111, tag222222222, tag3333 respectively

or, for example, if Length of Tag is set to 5
{tagl1008dataltag22010data2AAtag33009data3A}

where parameters are as above, except:

Tag, defined for each element (fixed at 5 characters), is tagll, tag22, tag33
respectively

TDS format: Delimited separation types:
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For delimited separation types, a delimiter is used to separate data fields, but there
are no tags present. The data fields need to be given in the correct order in the bit
stream and elements cannot be omitted from the middle of the bit stream.

The All Elements Delimited separation type means that data fields are delimited by
a pre-specified character or string. In this example, four data fields are separated
by an asterisk (*) delimiter:

datal*data2xdata3*datad

Delimited separation types are restrictive in the ordering and presence of elements:
* The elements must be given in the order specified.

* No element can be omitted in the middle of a group or complex type, because
the parser cannot determine this from the resulting bit stream.

* Elements can sometimes be absent from the end of a complex type or group.

After considering [“Delimiter suppression and truncation rules,”| this topic describes
the following delimited separation types:

+ [“All Elements Delimited” on page 53|

* [“Variable Length Elements Delimited” on page 54|

Delimiter suppression and truncation rules:

* Elements cannot be omitted from the middle of a group or complex type. An
absent element results in the inclusion of a zero-length string.
For example, with all elements present, the string might be:
datalxdataz2+~data3~data4

where Delimiter is *
If data?2 is missing, then the string would read:
datalxxdata3~datad
* It is possible to suppress the delimiters at the end of a string for absent
elements. The Suppress Absent Element Delimiter property determines whether

this is done. If this property is set to End of Type, this can be done (with one
exception, shown below).

In this case, for the above example with data3 and data4 missing, the string
would read:

datalxdata?

That is, the delimiters have been suppressed from the end of this group or
complex type.

* If the Suppress Absent Element Delimiter property is set to Never, delimiter
suppression never takes place. The string would read:
datalxdata2+=

That is, the delimiters have to be present to indicate absent (zero-length)
elements.

An exception to the above rule occurs in the case where the same delimiters are
used at multiple levels in the model.

For example, you have a complex type or group with delimiter * and this
contains an element of another complex type (indicated by the element3 prefix
on data fields in the example below), which also has delimiter *. If both types
use a delimited separation type, with all elements present, you might have:

datal*data2relement3Datal*element3Data2*element3Data3*datasd
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If element3Data2 and element3Data3 are missing, and the delimiters are
suppressed, it is not possible for the parser to determine which elements are
missing.

Therefore, in this case, you must override the Suppress Absent Element
Delimiter property, and write out all the delimiters to clearly define the message
to the parser. Therefore, the string must be:

datal+~data2~element3Datalx»+data4

This restriction also applies where Group Indicators and Group Terminators use
the same character strings as delimiters; otherwise, the bit stream is not clear to
the parser.

All Elements Delimited: In an All Elements Delimited separation type, all elements
are separated by a delimiter; for example:

datalxdata2*data3*datad*datab
where Delimiter is *.

An All Elements Delimited separation type does not use tags or their associated
parameters.

For textual elements, the length is determined by the delimiter, and the Length
property is ignored unless the Observe Element Length property is set.

For non-textual elements, the length is determined by the Physical Type of the
element. See [“TDS format: Determining the length of simple data values” on page

Applicable properties: These properties are used:

* Group Indicator indicates the start of a group or complex type.
* Group Terminator indicates the end of a group or complex type.

* Delimiter indicates the separator between the data elements within a group or
complex type.

* Suppress Absent Element Delimiters indicates whether delimiter suppression is
permitted (see below).

For example:
{datal*data22222*data3}

where:

* Group Indicator is {

* Group Terminator is }
* Delimiter is *

Repeating element rules: If an element needs to be repeated when the separation
type is All Elements Delimited, the Repeating Element Delimiter (RED), is used to
separate the repeated elements.

For example if data2 repeats 5 times:
datalxdata2:data2:data2:data2:data2+*data3*data4

where:
* Delimiter is *
* Repeating Element Delimiter is :
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If the Suppress Absent Element Delimiters property is set to End of Type, you can
use delimiter suppression. Therefore, if only the first data2 element was present in
the previous example, the bit stream reads:

datal*data2*data3*data4d

However, if the Suppress Absent Element Delimiters property is set to Never, the
bit stream reads:

datal*data2::::+*data3*data4

If Delimiter and RED match, two delimiters are output to indicate that the repeat is
ending. Therefore, if the delimiter and RED are *, the bit stream reads:

datal*data2*+data3*datad

Variable Length Elements Delimited: In a complex type with Variable Length
Elements Delimited separation, some elements are determined by their length, and
other elements are delimited. This combination of a delimited and a fixed length
format follows rules that are associated with both formats. Lengths can be given
and used, but they are not mandatory.

* If a length is present for a textual element, it is used, and a delimiter is not
needed to terminate that element. The element must be padded to the correct
length, and cannot exceed that length.

* If no length is given for a textual element, the delimiter is required.

* For non-textual elements, the length is determined by the Physical Type of the
element. See [“TDS format: Determining the length of simple data values” on|

lpage 46

A complex type with Variable Length Elements Delimited separation that contains
only variable length elements resembles a acomplex type with All Elements
Delimited separation. If it contains only fixed length elements, it resembles a Fixed
Length type.

For example:
datal*data2*data3*datad4000datab

where:
e Delimiter is *
 data4 has a length of 8

Applicable properties: The following properties are used:
* Group Indicator indicates the start of a group or complex type.
* Group Terminator indicates the end of a group or complex type.

* Delimiter indicates the separator between the data elements within a group or
complex type.

* Suppress Absent Element Delimiters indicates whether delimiter suppression is
permitted.

* (Optionally) Length or Length Reference indicates the length of a textual
element. If a textual element has a length, this length is used. Because the length
of this element is known, it is not necessary to output a delimiter after it. If the
length is not known, a delimiter is required. A delimiter is never required for a
non-textual element.

In this example, the fourth field (containing data4) is of fixed length 8 and its
padding character is 0:



{datal*data22222*data3*data4000data5}

where:
* Group Indicator is {
* Group Terminator is }

¢ Delimiter is *

Repeating element rules: The action of a repeating element in a Variable Length
Elements Delimited environment is dependent on the minimum and maximum
number of repeats and whether the element has a length.

Delimited Element Repeating: If a delimited element (that is, an element with no
length) is repeated, then a Repeating Element Delimiter (RED) is required and the
rules for All Elements Delimited are followed. A delimiter is therefore required
after the last repeat. Delimiter suppression of this repeat can also occur.

For example, if data? is repeating:
datal*data2:data2:data2:data2:data2:data2*data3*data4000datab

where:

* Delimiter is *

* Repeating Element Delimiter is :
* data4 has a fixed length of 8

If the Suppress Absent Element Delimiters field is set to End of Type then you can
use delimiter suppression.

If in the above example only the first data2 is present:
datal+data2~data3xdata4000datab

However, if Suppress Absent Element Delimiters is set to Never, then the bit
stream reads:

datalxdata2:::::+xdata3*datad000datab

If the delimiter and RED match, then two delimiters are output to indicate that the
repeat is ending. So if the delimiter and RED are both *, then the bit stream reads:

datal*data2*xdata3*datasd

This also applies for a non-fixed length complex type or group inside a Variable
Length Elements Delimited environment.

Fixed Length Element Repeating: If an element with a defined length (a fixed length
element) is repeating and the minimum occurrences is not the same as maximum
occurrences, then an RED is not required, but a delimiter is required after the last
repeat. Delimiter suppression of this repeat can occur.

For example, if data4 (with a fixed length of 8) is repeating, and its minimum
occurrences is 2, maximum occurrences is 4:

datal*data2*data3+datad00datad00datad00datad00+datab
where Delimiter is *

Or, if there are only two occurrences of data4:
datalxdata2xdata3*data4000data4000+datab
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If an element with a defined length (a fixed length element) is repeated, and the
minimum occurrences is the same as maximum occurrences, then an RED is not
required. A delimiter is also not required after the last repeat. Truncation of this
repeat cannot occur and all elements need to be present.

For example, if data4 (with a fixed length of 8) repeats four times:
datal~dataz+data3rdatad000data4000datad000datad000datab

where Delimiter is *

Or, if there are only two occurrences of dataé4:
datal*data2rdata3*data4000data40000000000000000000datab

This also applies for a non-fixed length complex type or group inside a Variable
Length Elements Delimited environment.

If a complex type has Variable Length Elements Delimited separation, a delimiter
is always output between an included ('child’) complex element and the next
element even if the separation of the ‘child” complex element is Fixed Length. On
input, the parser accepts the bit stream with or without such a delimiter.

TDS format: Data pattern separation types:

For a data pattern separation type, each data value is matched with a regular
expression that is specified as a property of each element.

The length of both textual and non-textual data is determined by the Data Pattern
property of the element. If the Physical Type of the element is Length Encoded
String 1 or Length Encoded String 2, the regular expression must match both the
encoded length and the following data. The length in the encoded length must be
consistent with the length matched by the regular expression. If the Physical Type
of the element is Null Terminated String, the regular expression must match both
the data and the following null terminator.

The Data Pattern separation type uses a regular expression that is specified for
each element to match the data. The parser matches the data with the regular
expression in the Data Pattern property for that element. TDS parsing in the MRM
parser uses the regular expression in Data Pattern to determine the length of the
element, whether it is repeating, and whether it is present in the bit stream.

No delimiters or tags, other than those coded as part of the regular expression
pattern, are used in the bit stream. See [“Using regular expressions to parse datal
felements” on page 759 for an explanation of pattern matching.

For example, if the first three Data Pattern properties are, respectively:
* [A-Z]{1,3}

* [0-9]+

* [a-z]*

and the message data is:

DT31758934information for you

Then, in this example:
e First data element = DT
¢ Second data element = 31758934



e Third data element = information

The first data pattern means "from one to three characters in the range A to Z”, the
second means "one or more characters in the range 0 to 9", and the third means
"zero or more characters in the range a to z". Note how each element’s data was
terminated by the first character that did not match the element’s Data Pattern.

If the TDS message that is being parsed is encoded in a single-byte code page, the
Data Pattern property can include hexadecimal values. A hexidecimal value is
specified as \xNN, where N is a hexadecimal digit in the range 0 to F. Note,
however, that the value \x00 is not valid.

Performance issues

The parsing required in Data Pattern separation type is the slowest of all the
different separation types because of its complexity.

Therefore, use Data Pattern separation type only when no other separation type
models the message. Do not use it, for example, when you can use Fixed Length
separation type.

Applicable parameters: Only one parameter is used:

Data Pattern for each element, indicates the regular expression that is used for
string matching.

TDS format: Message model integrity: When you use the TDS wire format, you
must conform to a number of rules that apply to the setting of values of properties.
This is necessary to avoid any discrepancies when processing a message within the
specified model.

Rules of TDS physical format properties: Restrictions to message formats are checked.
These will follow the rules specified in [“TDS message model integrity” on page|
The majority of rules are applied for at least one of these reasons:

Rules for message definition
Some rules are necessary for the message to be completely defined.

For example, in a Fixed Length separation type all elements must have
some length defined, either directly or by using a Length Reference.
Without this information, it is impossible to tell in the message bit stream
where one data element ends and the next starts.

Rules for nesting
Nesting rules relate to which separation types can be nested inside each
other.

Such rules are applied when an element of a complex type is present
inside another complex type. An example of this would be that it is not
possible to have a Tagged Delimited separation type inside a Fixed Length
type. Since a Tagged Delimited separation type is of variable length, the
parent Fixed Length type would be unable to tell where that particular
element ended, as there would be no length provided. Therefore the
message could not be processed.

Rules linking to the logical model
There are also rules linking TDS to the logical model.
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These occur where a group composition or group content validation cannot
be used in conjunction with a particular separation type. Again this is for
message integrity. For example, a separation type of All Elements
Delimited cannot have a group composition of Open, as there is no
information as to what the extra elements represent and where they are in
the bit stream.

TDS format: NULL handling:

NULL handling dictates the way in which the MRM parser for TDS messages
handles elements that have been set to Null.

Null handling only takes place if the logical Nillable property of the element is set.
The rules for whether nulls are permitted are described in [“TDS Null handling]
[options” on page 753 |

Null properties: The element properties Encoding Null and Encoding Null Value
control how null handling is represented for individual elements.

You can select the Encoding Null property from the enumerated values
NULLPadFill, NULLLogicalValue, NULLLiteralValue, and NULLLiteralFill. The use
of the Encoding Null Value property is dependent on the value that you select for
the Encoding Null property.

NULL values are not defined for schema xsd:hexBinary simple types. The
properties Encoding Null and Encoding Null Value are therefore not set for
xsd:hexBinary types.

NULL values for schema Boolean simple types are defined at the message set level.
The message set property Boolean Null Representation specifies the value to be
used for Boolean Null representation.

TDS format: Multipart messages:

The Tagged/Delimited String Format (TDS) supports both the Message Identity
technique and the Message Path technique of identifying embedded messages
within a multipart message.

The SWIFT, X12 and EDIFACT messaging standards can all be modeled using the
Message Identity technique.

Versions of the TDS physical format prior to Version 6.0 included embedded
message identification by Message Key which worked in a similar manner to
Message Identity, but which applied to TDS only. The Message Key technique has
been deprecated and is superseded by Message Identity. Warning task list
messages are issued if the use of Message Key is detected, and a task list Quick Fix
may be selected to create the equivalent Message Identity automatically. You must
continue to use Message Key if the MRM parser that you are deploying to is
Version 5.0.

TDS format: Data conversion: All TDS message data apart from binary types are
handled as strings. All string data is therefore subject to CCSID conversion only.

This includes the special characters used as delimiters, data separators, and so on.

TDS format: Relationship to the logical model:



There are some restrictions between TDS separation types and logical model
properties such as group composition and group content validation.

The rules that govern these options are explained in [“Restrictions for nesting|
[complex types” on page 757

These rules exist to ensure the integrity of the message. A combination of
separation type and group composition or group content validation must not lead
to a message that is unclear to a TDS parser.

Default values

In TDS, Default values are only observed by fixed length elements:

Separation Type

Use of Default values

Tagged Delimited
Tagged Fixed Length

Tagged Encoded Length

All Elements Delimited
Data Pattern

Default values are never observed.

Fixed Length
Fixed Length AL3

Default values are observed on output by all elements.
An absent element that has no Default value defined,
will cause an error on writing.

Variable Length Elements Delimited Default values are only observed by fixed length

elements on output. Absent fixed length values must
have a Default value available to them. An absent
element that has no Default value defined, will cause an
error on writing.

Simple types - lists and unions

Lists and unions are XML-specific concepts. An element or attribute of a simple
type that is a list or a union will cause a task list warning if a TDS physical format
is present in the message set. The user can choose whether to make this an error,
warning, or information by editing the Validation preferences. If a dictionary is
generated from the message set, and an attempt is made to parse a TDS message
defined to contain such elements or attributes, a runtime error will occur.

Min Occurs and Max Occurs

The logical properties Min Occurs and Max Occurs specify the permitted number
of occurrences of an element or group in a message. They are used when parsing
and writing messages, and when validating the content of a message.

When parsing and writing, the exact interpretation of these properties depends on
the Data Element Separation property of the parent complex type or group as
shown in the table below.

However, this behavior is overridden if the TDS Repeat Reference property is set,
which indicates that the number of occurrences is given instead by an integer
element that occurs earlier in the message. See [“Repeat reference” on page 61| for
more information.

When validating, Min Occurs and Max Occurs are both used to check that the
content of the message tree matches the model.
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Separation type

Interpretation of Min Occurs and Max Occurs

Tagged Delimited
Tagged Fixed Length
Tagged Encoded Length

Min Occurs and Max Occurs are effectively ignored when parsing and writing. When
parsing, the number of occurrences is identified by the tags in the message. When
writing, the writer outputs all occurrences in the message tree.

* A varying number of occurrences (Min Occurs <> Max Occurs) is allowed.
¢ Optional occurrence (Min Occurs = 0) is allowed.
¢ Always absent (Max Occurs = 0) is allowed.

* An unbounded number of occurrences (Max Occurs = -1) is allowed.

All Elements Delimited

Max Occurs only is used when parsing and writing, in conjunction with the element’s
Repeating Element Delimiter property, and the parent type’s Suppress Absent Element
Delimiters property.

A varying number of occurrences (Min Occurs <> Max Occurs) is allowed if Suppress
Absent Element Delimiters is set to End of Type.

s If the Delimiter is different to the Repeating Element Delimiter then the Delimiter
will signify the end of the occurrences.

* If the Delimiter is the same as the Repeating Element Delimiter then an empty
repeat signifies the end of the occurrences.

¢ In both these cases, Max Occurs is the maximum number of repeats that are
expected.

If Suppress Absent Element Delimiters is Never, then all occurrences are expected
when parsing, and output when writing, although parsing will accept elements being
absent.

Optional occurrence (Min Occurs = 0) is ignored and a delimiter is still expected
when parsing, and output when writing.

Always absent (Max Occurs = 0) is allowed. No delimiter is expected when parsing,
nor output when writing.

An unbounded number of occurrences (Max Occurs = -1) is only allowed if the
Repeating Element Delimiter is different from the Delimiter. The repeats must be
terminated by the delimiter, or a containing group’s Group Terminator or Delimiter,
or by the end of the message bit stream. On writing, the writer outputs all
occurrences in the message tree.

Fixed Length
Fixed Length AL3

Max Occurs only is used when parsing and writing. In general, Max Occurs
occurrences are expected when parsing, and Max Occurs occurrences are output when
writing; default values are used for missing elements, and any excess elements are
discarded.

A varying number of occurrences (Min Occurs <> Max Occurs) is ignored, Max
Occurs is assumed.

Optional occurrence (Min Occurs = 0) is ignored, Max Occurs is assumed.
Always absent (Max Occurs = 0) is allowed.

Fixed Length only. An unbounded number of occurrences (Max Occurs = -1) is
allowed if the element or group is the last child in its parent group, and the group is
terminated by a Group Terminator or a containing group’s Group Terminator or
Delimiter or by the end of the message bit stream. On writing, the writer outputs all
occurrences in the message tree, if this number is less than Min Occurs then
additional default values are written.
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Separation type

Interpretation of Min Occurs and Max Occurs

Variable Length Elements
Delimited

For fixed length simple elements, the rules for Fixed Length separation above are
followed with two differences.

1. A varying number of occurrences (Min Occurs <> Max Occurs) is allowed, the
end of the occurrences being signified by an extra delimiter.

2. An unbounded number of occurrences (Max Occurs = -1) is allowed, the end of
the occurrences being signified by an extra delimiter. On writing, the writer
outputs all occurrences in the message tree, followed by an extra delimiter.

For variable length simple elements, all complex elements and groups, the rules for
All Elements Delimited above are followed.

Data Pattern

Min Occurs and Max Occurs are effectively ignored when parsing and writing. When
parsing, the pattern is matched as many times as possible. When writing, the writer
outputs all occurrences in the message tree. Note that on parsing, if the data pattern
permits a zero length match, and a zero length match occurs, an element is added to
the message tree and the matching terminates to prevent an infinite loop.

A varying number of occurrences (Min Occurs <> Max Occurs) is allowed.

Optional occurrence (Min Occurs = 0) is allowed. Always absent (Max Occurs = 0) is
allowed.

An unbounded number of occurrences (Max Occurs = -1) is allowed.

Repeat reference

The TDS property Repeat reference specifies a field that holds the number of
repeats of an object (Element or Group) within a message. The field that holds the
number of repeats must be within the message before the object that it refers to.

From a parsing perspective, the Repeat reference property replaces the role of the
minOccurs and maxOccurs properties.

If a value for the Repeat reference property is specified for an object, values that
are specified for minOccurs and maxOccurs are ignored when parsing and writing.
However, values that are specified for minOccurs and maxOccurs are used by
logical validation.

When parsing and writing, the exact interpretation of the Repeat reference
property depends on the Data Element Separation property of the parent complex
type or group as shown in the table below.

Separation type

Interpretation of Repeat reference

Tagged Delimited
Tagged Fixed Length
Tagged Encoded Length

Repeat reference is effectively ignored when parsing and writing. When parsing, the
number of occurrences is identified by the tags in the message. When writing, the
writer outputs all occurrences in the message tree.
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Separation type

Interpretation of Repeat reference

All Elements Delimited

Repeat reference is used when parsing and writing, in conjunction with the element’s
Repeating Element Delimiter property, and the parent type’s Suppress Absent Element
Delimiters property.

A Repeat reference is allowed only if the parent complex type or group has Suppress
Absent Element Delimiters set to Never. All Repeat reference occurrences are expected
when parsing, and output when writing. However, parsing accepts elements being
absent.

Repeat reference = 0 is allowed. No delimiter is expected when parsing, nor output
when writing.

Fixed Length
Fixed Length AL3

Repeat reference is used when parsing and writing. Repeat reference occurrences are
expected when parsing, and are output when writing, with default values used for
missing elements.

Repeat reference = 0 is allowed.

Delimited

Variable Length Elements For fixed length simple elements, the rules for Fixed Length separation above are

followed.

For variable length simple elements, all complex elements and groups, the rules for
All Elements Delimited that are listed above are followed.

Data Pattern

Repeat reference is effectively ignored when parsing and writing. When parsing, the
pattern is matched as many times as possible. When writing, the writer outputs all
occurrences in the message tree. Note that, on parsing, if the data pattern permits a
zero length match, and a zero length match occurs, an element is added to the
message tree and the matching terminates to prevent an infinite loop.
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MRM XML physical format
The MRM XML physical format describes the physical representation of an XML
message for use by the MRM parser.

An XML wire format describes the physical representation of a message that is
written according to the standards given in the W3C [Extensible Markup Language|
specification. The wire format defines information that is used to parse or
write XML messages in a runtime environment such as a broker. XML versions 1.0
and 1.1 are both supported.

You can add more than one XML physical format to a message set, but within that
message set, each physical format must have a unique name. The default name for
an XML wire format is XML1. The physical format name identifies the definitions
that are to be used by the message broker at runtime.

After adding an XML physical format, all XML properties for all existing objects in
the message set are set to default values. Therefore, immediately after adding the
format and deploying the message set to a runtime environment, you can process
XML messages using MRM features.

You can configure XML properties for the message set, and for objects within the
message set. Objects that can have XML properties are messages, elements, and
attributes. For example, a message object can be customized to define a specific
DTD declaration on output; an element can have a tag name assigned to it which
is different from its element name in the model.



http://www.w3.org/TR/REC-xml
http://www.w3.org/TR/REC-xml

Adding an XML wire format to a message set allows you to both process input
messages, and to construct output messages in this format. You can also transform
messages between XML and either CWF or TDS.

XML messages are, by their nature, self-describing: each piece of data is prefixed
by a tag name or an attribute name. Therefore, it is possible for an XML message
instance to contain elements that are not in the definition for that message.

* If such an element exists in the message set, the model objects for that element
are used in parsing or writing the message.

* If the element does not exist in the message set, it is treated as a self-defining
element, and its data type is set to string.

Although it is possible to define an XML message 'by hand’, using the Message
Definition Editor, WebSphere Message Broker also provides importers for both
XML Schema and DTD, and these are often quicker and easier than manual
definition.

XML wire format: Message model integrity: When you save a message definition
file, the definitions that it contains are checked to ensure that they make sense and
provide sufficient information about the message. This action is called model
validation.

For XML, these checks mostly concern the uniqueness and validity of XML names
in global elements and attributes, and also for elements and attributes within
complex types or groups.

Tests other than these tend to be both simple and obvious so that, for example, the
message set property First Day of Week has to be the name of a day in the week.

MRM XML physical format: NULL handling;:

The purpose of null handling is to specify how messages will deal with null
values; that is, the absence of a meaningful value for an element.

Null properties for the MRM XML physical format are set for the message set only,
and apply to all the defined objects within the message set, using the four
properties Encoding Null Num, Encoding Null Non-Num, Encoding Null Num Val
and Encoding Null Non-Num Val.

Null handling only takes place if the logical Nillable property of the element is set.

The purpose of these parameters is to specify how messages deal with null values.
In an XML message there are several options. Most obviously an element could
simply omit a value, for example:

<elementl></elementl>

Or, the element could include a distinctive value that means that no real value is
present, for example.

<elementl>null</elementl>

Or, the element could follow XML Schema instance rules:
<elementl xsi:nil="true"/>

The properties Encoding Null Num and Encoding Null Non-Num specify the style
of null handling, for example, that null is represented by an empty element.
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The properties Encoding Null Num Val and Encoding Null Non-Num Val provide
a value (if needed) to represent a null value. For an element of type string, this
might be null or unspecified while for a number it might be 0 or 0.0.

MRM XML physical format: Multipart messages: If you are using the MRM
XML physical format, an embedded message can be identified in any of the
following ways:

* Message Identity

See [“Identifying an embedded message using a Message Identity” on page 26|

* Message Path

See |“Identifying an embedded message using a Message Path” on page 29|

e Automatic

The MRM parser identifies the message by matching the next XML tag in the bit
stream against the XML Name of a message definition.

If you choose the Message Identity or Message Path technique, the MRM parser
still checks that the next XML tag name matches the XML Name of the message
that was identified. If the XML Name does not match, an exception is thrown.

Where you have defined the embedded message in a different message set, you
need to use a Message Set Identity element or attribute value to specify the target
message set.Note that the message sets within which the root and subsequent
embedded messages are defined must be consistent in their use of the "Use
Namespace’ property of the message set. That is, embedded messages that are
defined in a namespace-aware message set and that are contained within a parent
message that is defined in a message set that is not namespace-aware, are not
supported. Similarly, embedded messages that are defined in a message set that is
not namespace-aware and that are contained within a parent message that is
defined in a namespace-aware message set, are not supported.

If the embedded message definition is a complex type, the message definition will
contain a complex element based on that complex type. This complex element will
have its own tag, which will appear in the bit stream before the tag for the
embedded message. If you want to avoid this extra tag, you can create the
embedded message definition from a group, and insert the group at the
appropriate position in the message model.

Tip: Note that the root tag property of an embedded message is not applicable.

MRM XML physical format: relationship to the logical model: The MRM XML
physical format generally respects all of the setting in the logical model, but shares
certain restrictions in common with the other physical formats. These restrictions
are documented in [“MRM restrictions” on page 729

Default values

The MRM XML physical format ignores default and fixed values on elements and
attributes. If validation is enabled in WebSphere Message Broker, this can lead to
unexpected validation errors for missing elements, even though they have default
or fixed values.

Simple types — unions and lists

The XML properties of an element or attribute of a simple type that is a union or
list vary depending on the members of the union or the itemType of the list. If the



union or list includes a dateTime type (or other date/time related type) the Date
Format field will be displayed. If the union includes a binary type, the Encoding
field will be displayed.

Min Occurs and Max Occurs

The logical properties Min Occurs and Max Occurs specify the permitted number
of occurrences of an element or group in a message. They are used when
validating the content of a message.

When parsing and writing, using the MRM XML physical format, Min Occurs and
Max Occurs are effectively ignored. When parsing, the number of occurrences is
identified by the tags in the message. When writing, the writer outputs all
occurrences in the message tree.

* A varying number of occurrences (Min Occurs <> Max Occurs) is allowed.

* Optional occurrence (Min Occurs = 0) is allowed.

* Always absent (Max Occurs = 0) is allowed

* An unbounded number of occurrences (Max Occurs = -1) is allowed.

When validating, Min Occurs and Max Occurs are both used to check that the
content of the message tree matches the model.

MRM XML physical format: Handling xsi:type attributes: The prefix "xsi" is the
namespace prefix used by convention for the XML Schema instance namespace}
XML documents can contain elements that have an xsi:type attribute. This provides
an explicit data type for the element.

The MRM XML parser in sensitive to xsi:type attributes in the XML document. It
modifies the data type of the element accordingly and adds the xsi:type attribute
into the message tree.

The MRM XML writer is sensitive to xsi:type attributes in the message tree. It
outputs xsi:type attributes according to XML Wire Format message set property
Output policy for xsi:type attributes. For example, xsi:type attributes can be
removed, output on all elements or output according to rules specified in the
SOAP standard.

If validation is enabled for a WebSphere Message Broker message flow, the
validation logic is sensitive to xsi:type attributes and uses them to modify the
validation of the element. It will also validate the values of xsi:type attributes
using the rules described in [XML Schema Part 1: Structures| on the World Wide
Web Consortium (W3C) Web site.

There are several important points to remember when parsing and writing XML
documents that contain xsi:type attributes.

* In order to detect and use xsi:type attributes, the message set must be
namespace-enabled. To make a message set namespace-enabled, check the
message set property Use namespaces.

* If the value of the xsi:type attribute contains a namespace prefix, the prefix will
be expanded into a fully-qualified URI by the MRM XML parser. If the same
xsi:type attribute is output later by the MRM XML writer, the same prefix will
not automatically be used for the value. You can control the prefixes used on
output using the Namespace settings list in the XML Wire Format message set
properties. If no prefix is supplied, the XML writer will assign a default prefix.

Developing message models 65


http://www.w3.org/2001/XMLSchema-instance
http://www.w3.org/TR/xmlschema-1/

If the xsi:type attribute of an element does not resolve to a type in the model,
then the behaviour depends on whether MRM validation is enabled. If not
validating, the MRM will assume the type of the element is that declared in the
model, and continue. If validating, a validation exception will be thrown.

If MRM validation is enabled, any required xsi:type attributes must be present in
the message tree at the point when validation is performed. An xsi:type attribute
is required when its value is different from the data type of the element as
defined in the message model (this most commonly occurs when using XML
Schema type derivation).

— If validation is being performed on an input message, then the MRM XML
parser ensures that xsi:type attributes appear in the message tree, as described
above.

— If validation is being performed on an output message you must ensure that
the correct xsi:type attributes appear in the message tree. You should ensure
that any required xsi:type attributes are copied from input message tree to
output message tree, or are explicitly created in the output message tree.

If you are using simple types that are xsd:unions then an xsi:type attribute can
be used to direct the MRM XML parser when resolving the union.

If you have migrated from an earlier version of WebSphere Message Broker that
was not sensitive to xsi:type attributes, you might notice some changes of
behavior. For example, xsi:type attributes are no longer treated as self-defining
attributes, so they appear in the message tree with the name ‘type’” instead of
‘@type’. If your message flow logic is sensitive to xsi:type attributes in the
message tree, change your message flow to comply with the current behavior. If
you want to retain logic from an earlier version of WebSphere Message Broker in
your message flows, this is described in [Message flow migration notes}

For more information about xsi:type attributes, see XML Schema Part 0: Primer| on
the World Wide Web Consortium (W3C) Web site.

Ways to create message definitions

When you have created a message set, you must populate the message set with
message definitions.

66 Message Models

You can populate the message set in one of the following ways:

By importing application message formats that are described by XML Schemas,
IBM supplied messages, XML DTD, C structures, COBOL structures, or WSDL
definitions; use the wizards that are started from the New Message Definition
File From wizard.

By creating empty message definition files and then creating your messages by
using the Message Definition Editor; use the New Message Definition File
wizard.

By using the Adapter Connection wizard to import EIS metadata.

Additionally, you can import application message formats by busing the
mgsicreatemsgdefs or mgsicreatemsgdefsfromwsdl command line utilities.

The mgsicreatemsgdefs command has a bulk import capability, but
mgsicreatemsgdefsfromwsdl imports only one WSDL definition at a time.

Importing from other model representations to create message
definitions

You can add message definitions to your message set by importing application
message formats that already exist.
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You can import the following message formats into your message set:
* XML Schema files

* IBM supplied messages

¢ XML DTD files

* C header files

¢ COBOL copybooks

¢ WSDL definitions

* EIS metadata

When you import one of these formats, a new message model is created that
consists of the elements, attributes, groups, and types that are required to represent
your message format. You can choose the name of the message definition file; if it
already exists, the content is deleted and recreated as part of the import operation.

The new message model that is created can consist of both logical and physical
information, if appropriate physical formats exist in the message set at the time of
the import.

To find out which wizards you can use to import message formats, see m
[create message definitions” on page 66

You can also import C header files, COBOL copybooks, XML DTD files, or XML
Schema files by using the mgsicreatemsgdefs command line utility. The
mgsicreatemsgdefs command allows you to import several message format files in
a single operation, and allows you to create a new message set (based on an
existing message set) into which the message definition files are placed.

WSDL definitions can be imported by using the mgsicreatemsgdefsfromwsdl
command line utility. This utility imports only one WSDL definition at a time.

Client application access to messages: Client applications must have access to
message definitions to be able to construct the messages that they send, and to
interpret the messages that they receive.

* If the message formats have been imported from C or COBOL structures by
using the workbench, your applications can continue to use the same C and
COBOL data structures that were imported to create the message dictionary that
is used by the brokers.

* If the messages are self-defining XML, the client applications must construct
valid messages by using the structures that can be understood by the recipients
of the message.

Importing from XML Schemas to create message definitions: You can populate a
message set with message definitions by importing XML Schema files, using the
New Message Definition File From XML Schema file wizard, the Start from
WSDL and/or XSD files quick start wizard, or the mgsicreatemsgdefs command
line utility.

Each XML Schema file that you import results in a new message definition file
within the message set. The root name of the message definition file defaults to the
root name of the XML Schema file, but the New Message Definition File From
XML Schema file wizard allows you to choose a different root file name.

Developing message models 67



68 Message Models

If the message definition file already exists, you must have permitted overwriting
to occur for the import to proceed, in which case the existing content is deleted
and recreated.

The namespace to which the message definition file created belongs depends on
whether namespaces have been enabled for the message set.

* If namespaces have been enabled, the message definition file belongs to the
target namespace of the XML Schema file that is imported.

* If namespaces have not been enabled for the message set, the message definition
file belongs to the noTarget XML namespace irrespective of the target namespace
of the imported XML Schema file and therefore resides in the (default) location
in your workspace. The implications of importing into a message set with
namespaces disabled are described in [“Importing XML Schema into message sets|
[with namespaces disabled” on page 69

A report file is created during the import operation. This is located by default in
the log folder of the message set. By default it takes the name of the message
definition file, with .report.txt appended.

Import using the New Message Definition File From XML Schema file wizard: When
you import using the New Message Definition File From XML Schema file
wizard, you can specify which of the global elements or global complex types
within the imported XML Schema file are to be messages within the message
definition file.

You can only import one XML Schema file with each import operation. If your
XML Schema file references other XML Schema files, with import or include
elements, these XML Schema files must be imported into the same message set
using a separate import operation.

Import using the command line: 'When you import using the command line you
have the option of either creating no messages or creating a message for each
global element and global complex type within the imported XML Schema file. The
import operation creates a message and corresponding global element in the
message definition file for each global element you specify. If you do not specify
that messages are to be created, you must create them manually using the message
definition editor after the import has completed.

You can import several XML Schema files in each import operation.

Physical information: As well as creating logical information, the import can also
create physical information. If the message set contains any XML wire format
physical formats, then the physical format properties for all XML Wire Format
layers is populated. If the message set does not contain any XML physical formats,
only logical information is created. Also, if you import from the command line,
only logical information is created in the new message set by default. If you want

physical information created as well, see [“Importing from the command line” on|
for details.

MRM CWF and TDS physical format properties are not populated and so take
default values.

If you have one or more CWF or TDS layers, the import can cause entries in the
task list, warning you that certain CWF or TDS properties must be set if the XML
structures you have imported are to appear in a CWF or TDS message.



If the CWF or TDS physical formats are not applicable to your XML structures, you
can ignore these task list entries because they are just warnings, they do not
prevent your model being generated in another form; for example, as a message
dictionary.

Command line invocation: The mqsicreatemsgdefs command line utility allows you
to import several XML Schema files in a single operation. All the XML Schema files
must be in single directory, and the directory location must be passed as a
parameter to the utility.

When you import into a message set for which namespaces are not enabled, the
action to take for unsupported constructs can be specified using an XML options
file. This must contain an XML element called <XSD_NO_NS> that holds a set of
information that applies to all XML Schema files that are imported during an
invocation of the utility. A default XML options file, called mqsicreatemsgdefs.xml,
is supplied. If you want to apply different sets of information to different XML
Schema files, you must create multiple XML files and run the utility multiple
times.

When you are importing into a message set for which namespaces are not enabled,
there are two other options that you can specify in the <XSD_NO_NS> element in the
XML options file:

* The prefix to use for the http://www.w3.0rg/2001/XMLSchema-instance
namespace; the default is xsi.

* Additional namespace URI and prefix pairs.

The mgsicreatemsgdefs utility also allows you to create a new message set into
which the message definition files are placed, as part of the import operation. You
can also choose to base the message set created on an existing message set. This
facility enables you to prepare an empty message set that contains a XML physical
format and pre-populated message set level XML properties, which are then copied
into the message set that is created by the import.

Further information about XML Schema: For details about XML Schema, see
[Schema Part 0: Primer{ on the [World Wide Web Consortium (W3C)| Web site.

Importing XML Schema into message sets with namespaces disabled:

You can import an XML Schema file with a target namespace even if the message
set does not have namespaces enabled.

When you import an XML Schema file with a target namespace into a message set
for which namespaces have not been enabled, the created message definition file is
placed in the XML no target namespace. In some cases, this action can lead to
name conflicts if global constructs have the same name in different namespaces in
the XML Schema files imported into the same message set. These conflicts cause
error entries in the task list that you must resolve before generating the model in
another format, such as a message dictionary.

Because all the message definition files are in the XML no target namespace, the
namespace information associated with the XML Schema file is lost. However, the
importer provides a limited form of namespace support by prefixing the XML
names in the XML Wire Format layers with a namespace prefix. To allow this
namespace support to work, an imported XML Schema file must specify an xmlns
attribute with a non-empty prefix for the target namespace of the XML Schema file.
This prefix is used in the XML names in the XML Wire Format layers.
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Therefore you cannot specify the target namespace of the XML file as the default
namespace. Each namespace in the XML Schema files must use a unique prefix
and the same namespace must always use the same prefix. Any XML instance
documents against which you match any of the forms generated from the model,
must also use the same prefixes for the namespaces.

The XML Schema importer creates a number of optional attributes in an attribute
group to represent namespace information. This attribute group is referenced by
the type of any message. An attribute is created to represent the location of the
XML Schema file, and an attribute is created to represent the mapping of the prefix
to the http://www.w3.0rg/2001/XMLSchema-instance namespace. An attribute is
also created for each xmlns attribute in the XML Schema document.

When importing using the Message Definition File wizard the prefix
http://www.w3.0rg/2001/XMLSchema-instance namespace can be changed and
additional namespace URI/prefix pairs added using the last panel of the Message
Definition File wizard. When you use the mgsicreatemsgdefs command line utility,
the same modifications can be made using the XML options file.

Further information about XML Schema: For details about XML Schema, see
[Schema Part 0: Primer] on the [World Wide Web Consortium (W3C)| Web site.

Importing from IBM supplied messages to create message definitions:

You can add messages to a message set by importing IBM supplied messages
using the New Message Definition File From IBM supplied messages wizard.

Each IBM supplied message that you import results in a new message definition
file within the message set. The name of the message definition file defaults to the
name of the IBM supplied message, but the New Message Definition File From
IBM supplied messages wizard allows you to choose a different file name.

See [“Importing from the command line” on page 130| for information about what
IBM supplied messages can be imported.

When you import using the New Message Definition File From IBM supplied
messages wizard, you can specify only one IBM supplied message definition for
each import operation.

If the message definition file already exists, you must have permitted overwriting
to occur for the import to proceed, in which case the existing content is deleted
and recreated.

A report file is generated during the import operation that allows you to examine
what occurred during the import process and check any errors that resulted.

Importing from DTDs to create message definitions: You can populate a
message set with message definitions by importing DTD files, using either the
New Message Definition File From XML DTD file wizard or the
mgsicreatemsgdefs command line utility.

Each XML DTD file that you import results in a new message definition file within
the message set. The root name of the message definition file defaults to the root
name of the XML DTD file, but the New Message Definition File From XML
DTD file wizard allows you to choose a different root file name.
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If the message definition file already exists, you must have permitted overwriting
to occur for the import to proceed, in which case the existing content is deleted
and recreated.

All message definition files that are created as a result of DTD file import belong
to the noTarget XML namespace and so reside in the (default) location in your
workspace.

A report file is created during the import operation. This is located by default in
the log folder of the message set. By default, it takes the name of the message
definition file, with .report.txt appended.

Import using the New Message Definition File From XML DTD file wizard: When you
import using the New Message Definition File From XML DTD file wizard, you
can specify which of the elements within the imported XML DTD file are to be
messages within the message definition file.

You can import only one XML DTD file with each import operation.

Import using the command line: When you import using the command line you
have the option of either creating no messages or creating a message for each
element within the imported XML DTD file. The import operation creates a
message and a corresponding element in the message definition file for each
element that you specify. If you do not specify that messages are to be created, you
must create them manually using the message definition editor after the import
has completed.

You can import several XML DTD files in each import operation.

Physical information: As well as creating logical information, the import can also
create physical information. If the message set contains any XML wire format
physical formats, the physical format properties for all XML Wire Format layers is
populated. If the message set does not contain any XML physical formats, only
logical information is created. Also, if you import from the command line, only
logical information is created in the new message set by default. If you want

physical information created as well, see [“Importing from the command line” on|
page 130| for details.

MRM CWEF and TDS physical format properties are not populated and therefore
take default values.

If you have one or more CWF or TDS layers, the import can cause entries in the
task list, warning you that certain CWF or TDS properties must be set if the XML
structures that you have imported are to appear in a CWF or TDS message.

If the CWF or TDS physical formats are not applicable to your XML structures, you
can ignore these task list entries because they are just warnings; they do not
prevent your model being generated in another form, such as a message dictionary.

Command line invocation: The mgqsicreatemsgdefs command line utility allows you
to import several XML DTD files in a single operation. All the XML DTD files
must be in single directory, and the directory location must be passed as a
parameter to the utility.

The mgsicreatemsgdefs utility also allows you to create a new message set into
which the message definition files are placed, as part of the import operation. You
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can also choose to base the message set created on an existing message set. This
facility enables you to prepare an empty message set that contains a XML physical
format and pre-populated message set level XML properties, which are then copied
into the message set that is created by the import.

Further information about XML DTDs: For details about XML DTDs, see the
[Wide Web Consortium (W3C)| Web site.

Importing from C header files to create message definitions:

You can populate your message set with message definitions by importing C
header files, using either the New Message Definition File From C header file
wizard or the mgsicreatemsgdefs command line utility.

Each C header file that you import results in a new message definition file. The
root name of the message definition file defaults to the root name of the C header
file, but the New Message Definition File From C header file wizard allows you
to choose a different root file name.

If the message definition file already exists, you must have permitted overwriting
to occur for the import to proceed, in which case the existing content is deleted
and recreated.

By default, all message definition files that are created as a result of an import
from a C header file belong to the noTarget XML namespace and therefore reside
in the (default) location in your workspace. This default namespace can be
overridden by specifying a target namespace. See [“Namespaces with MRM|
[non-XML messages” on page 36| for reasons why you might want to do this.

In your C header file there are typically one or more C structures. You can select
which of these structures to import. The import operation then imports those
structures, plus any others that they require. All imported structures are converted
into the equivalent elements, groups and types in the message definition file.

You can also specify which of the selected structures are to be messages in the
message definition file. The import operation creates a message and a
corresponding global element in the message definition file for each structure that
you specify. If you do not specify that messages are to be created, you must create
them manually using the Message Definition editor after the import has
completed.

If you import using the New Message Definition File From C header file wizard
you can import only one C header file with each import operation. But, if you
import using the command line utility, you can import several C header files in
each import operation.

If your C header file needs any other header files for a successful compilation, you
must provide these and specify their location, because a compilation of your
header file is performed as part of the import operation.

A report file is created during the import operation. This is located by default in
the log folder of the message set. By default, it takes the name of the message
definition file, with .report.txt appended.

Physical information: As well as creating logical information, the import can also
create physical information.
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If the message set contains any Custom Wire Format (CWF) physical formats, the
physical format properties for all CWF layers are populated.

If the message set does not contain any CWF physical formats, only logical
information is created. Also, if you import from the command line, only logical
information is created in the new message set by default.

XML and TDS physical format properties are not populated and so take default
values.

If you have one or more TDS layers, the import can cause entries in the task list,
warning you that certain TDS properties must be set if the C structures you have
imported were to appear in a TDS message.

If the TDS physical format is not applicable to your C structures, you can ignore
these task list entries because they are just warnings; they will not prevent your
model being generated in another form, such as a message dictionary.

Because physical information is created, the application target environment
(platform and compiler) is important because it governs the way that, for example,
integers appear in the message. You can specify environment specific information
as part of the import operation, and the necessary properties will be set
accordingly. There is a range of environments supported; if your environment is
not shown, choose the closest match and review the created physical information
using the Message Definition Editor after the import has completed.

Command line invocation: The mgqsicreatemsgdefs command line utility allows you
to import several C header files in a single operation. All the C header files must
be placed in the same directory and the directory location passed as a parameter to
the utility.

You provide the necessary environment-specific information, and include file
location information using an XML file. This must contain an XML element called
<C> which holds one set of information that applies to all C header files imported
during an invocation of the utility. A default XML file called
mgsicreatemsgdefs.xml is supplied. If you want to apply different sets of
information to different header files, you must create multiple XML files and run
the utility multiple times.

The mgsicreatemsgdefs utility also allows you to create a new message set into
which the message definition files are placed, as part of the import operation. You
can also choose to base this new message set on an existing message set. This
facility enables you to prepare an empty message set containing a CWF physical
format and message set level CWF properties already populated, which then gets
copied into the message set created by the import.

Importing from COBOL copybooks to create message definitions:

You can populate your message set with message definitions by importing COBOL
copybook files, using either the New Message Definition File From COBOL file
wizard or the mgsicreatemsgdefs command line utility.

Each COBOL copybook that you import results in a new message definition file.
The root name of the message definition file defaults to the root name of the
COBOL copybook file, but the New Message Definition File From COBOL file
wizard allows you to choose a different root file name.
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If the message definition file already exists, you must have permitted overwriting
to occur for the import to proceed, in which case the existing content is deleted
and recreated.

By default, all message definition files that are created as a result of COBOL
copybook file import belong to the noTarget XML namespace and therefore reside
in the (default) location in your workspace. This default namespace can be
overridden by specifying a target namespace. See [“Namespaces with MRM|
[non-XML messages” on page 36| for reasons why you might want to do this.

In your COBOL copybook file there are typically one or more level 01 structures.
You can select which of these structures to import. The import operation then
imports those structures, plus any others that they require. All imported structures
are converted into the equivalent elements, groups and types in the message
definition file.

You can also specify which of the selected level 01 structures are to be messages in
the message definition file. The import operation creates a message and
corresponding global element in the message definition file for each structure that
you specify. If you do not specify that messages are to be created, you must create
them manually using the Message Definition Editor after the import has
completed.

If you import using the New Message Definition File From COBOL file wizard,
you can only import one COBOL copybook file with each import operation. If you
use the command line utility, you can import several COBOL copybook files in
each import operation.

If your COBOL copybook file needs any other copybooks in order to compile
successfully, you must provide these in the same directory, because a compilation
of your copybook is performed as part of the import operation.

A report file is created during the import operation. This is located by default in
the log folder of the message set. By default it takes the name of the message
definition file, with .report.txt appended.

Physical information: As well as creating logical information, the import can also
create physical information. If the message set contains any Custom Wire Format
(CWF) physical formats, the physical format properties for all CWF layers are
populated. If the message set does not contain any CWF physical formats, only
logical information is created. If you import from the command line, only logical
information is created in the new message set by default. If you want physical
information created as well, see [“Importing from the command line” on page 130
for details.

XML and TDS physical format properties are not populated and therefore take
default values.

If you have one or more TDS layers, the import can cause entries in the task list,
warning you that certain TDS properties must be set if the COBOL structures that
you have imported were to appear in a TDS message.

If the TDS physical format is not applicable to your COBOL structures, you can
ignore these task list entries because they are just warnings, they will not prevent
your model being generated in another form, such as a message dictionary.



Because physical information is created, the application target environment
(platform and compiler) is important because it governs the way that, for example,
integers appear in the message. You can specify environment specific information
as part of the import operation, and the necessary properties are set accordingly.
There is a range of environments supported; if your environment is not shown,
choose the closest match and review the created physical information using the
Message Definition Editor after the import has completed.

Command line invocation: The mgqsicreatemsgdefs command line utility allows you
to import several COBOL files in a single operation. All the COBOL copybook files
must be in single directory, and the directory location passed as a parameter to the
utility.

You provide the necessary environment specific information using an XML file.
This must contain an XML element called <COBOL> that holds one set of
environment specific information that applies to all COBOL copybook files that are
imported during an invocation of the utility. A default XML file called
mgsicreatemsgdefs.xml is supplied. If you want to apply different sets of
information to different copybooks, you must create multiple XML files and run
the utility multiple times.

The mgsicreatemsgdefs utility also allows you to create a new message set into
which the message definition files are placed, as part of the import operation. You
can also choose to base the message set created on an existing message set. This
facility enables you to prepare an empty message set that contains a CWF physical
format and pre-populated message set level CWF properties, which are then
copied into the message set that is created by the import.

Importing from WSDL files to create message definitions: You can add
messages to a message set by importing WSDL files, using the New Message
Definition File From WSDL file wizard, the Start from WSDL and/or XSD files
Quick Start wizard, or the mgsicreatemsgdefsfromwsdl command line utility.

Each WSDL file that you import results in one or more new message definition
files within the message set. A new message definition file is created for each
namespace that is defined for the message set. The name of the message definition
file defaults to the name of the WSDL file, but the New Message Definition File
From WSDL file wizard allows you to choose a different file name.

If the message definition file already exists, you must have permitted overwriting
to occur for the import to proceed, in which case the existing content is deleted
and recreated.

The message set that you are importing the WSDL file into must be namespace
enabled and, if it uses the MRM domain, must have an XML physical format so
that the message set is suitable for the runtime parsing of XML messages such as
SOAP.

A report file is generated during the import operation which allows you to
examine what occurred during the import process and to check any errors that

have resulted.

You specify a single WSDL definition for each import operation. If the WSDL
definition consists of a hierarchy of files, you must supply the name of the file that
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contains the WSDL service or binding definitions. The WSDL definition that is
being imported must contain one or more WSDL bindings for the import to
proceed.

Importing using the New Message Definition File wizard

When you import using the New Message Definition File wizard, you can specify
only one WSDL definition for each import operation. A WSDL definition could be
held as one or more WSDL files and these will all be imported as a result of
importing the definition. The WSDL definition being imported must contain one or
more WSDL bindings for the import to proceed.

Importing using the command line

The WSDL command line importer (mgsicreatemsgdefsfromwsdl) can create a new
message set or update an existing one. If the message set project exists, it must be
namespace-enabled and have an XML physical format layer. If the project does not
exist, a new namespace-enabled project is created. If the import succeeds, new
message definition files are added to the message set.

The mgsicreatemsgdefsfromwsdl command allows you to import one WSDL
definition in a single operation.

The mgsicreatemsgdefsfromwsdl command copies the WSDL files it needs into the
workspace before the import runs. These are the top level WSDL files and any
imports are resolved using an absolute or relative location. The files are copied
under the specified message set in a folder called importFiles and are not removed
after the import, allowing the user to subsequently update or run validation on
them in the workbench.

Physical information

An XML physical format layer is required for the MRM domain, and must be
added to an existing message set prior to importing the WSDL definition.

Relationship of WSDL to Message Model:

If a broker is to communicate with an existing web service, it typically needs to
send and receive SOAP messages. To use this approach you should use the MRM
domain. You will need to ensure that the broker’s message model and the WSDL
definition used by the web service describe the same messages. In general this is
achieved by importing the WSDL for the existing web service using the broker
tooling. Currently only WSDL version 1.1 is supported.

Only the WSDL operation, message and part definitions will be represented in the
resulting broker model. Starting with the lowest level, a WSDL definition describes:

* a number of logical messages and their constituent parts which are themselves
defined in terms of XML Schema. The part definitions are imported directly into
the message model to create the corresponding element and type definitions.
The definitions are allocated to message definition files according to the target
namespace of their schema definition. If there is no targetNamespace defined on
the <xsd:schema> element, then the resulting elements and types have no
namespace.

* a number of operations comprising the WSDL portType or interface. The
operations define the business payload for the SOAP messages at runtime.
Broker messages are created for each possible payload. In the case of rpc-style



WSDL this means that the message model needs message definitions
corresponding to the WSDL operations themselves. The names of these message
definitions are derived from the WSDL operation name and their namespace is
given by the namespace attribute on the WSDL <soap:body> definition.

¢ a SOAP version and encoding style. Message definitions for the SOAP envelope
and if necessary the SOAP encoding scheme are imported into the message set.
Currently the WSDL importer assumes the use of SOAP version 1.1. There is no
reason that WSDL version 1.1 cannot define a web service that uses SOAP
version 1.2 - it is simply that there isn’t a standard way of doing this. If your
web service does use SOAP version 1.2 then you may need to manually remove
the SOAP version 1.1 definitions and import the SOAP version 1.2 definitions.

Resulting message model

The resulting model allows the user to parse incoming SOAP messages using the
MRM XML parser where the message type would be Envelope. The message
model for the SOAP envelope defines the outer SOAP wrapper with its constituent
Header and Body sections and a number of attachment points where the various
business payloads can appear. These attachment points are defined with
composition message, allowing the broker messages created by the WSDL importer
to appear at these points.

The allowed attachment points are Envelope.Body, Envelope.Header and
Envelope.Body.Fault.detail. A message from the user’s message model may appear
at each point (in the case of the Envelope.Header, multiple messages may appear).
In the case of rpc-style WSDL, the message expected at Envelope.Body is the
automatically generated message corresponding to the WSDL operation. In all
other cases the messages expected are those defined by the WSDL message parts
for each operation.

Generate model representations

After you have created and populated a message set, you can generate a message
model in several different representations for use by a broker, a parser, or your
applications.

The following representations are supported:
* A message dictionary, for deployment to a broker.

* A W3C XML Schema, for use by an application building or processing XML
messages, or for deployment to a broker.

* Web Services Description Language (WSDL), for a Web services client
application, or for deployment to a broker.

¢ Documentation, to give to programmers or business analysts.

Generation for deployment to a broker takes place automatically when you add
your message set to a Broker Archive (BAR) file.

Generation for other purposes is achieved using the Generate menu actions.

Generate message dictionaries
A message dictionary is data structure that describes all of the messages in a
message set in a form suitable for deployment to the MRM parser.

Purpose of a message dictionary: A dictionary describes the logical structure and
content of a set of messages, and typically contains one or more physical formats
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that describe how those messages are serialized in a bit stream. The MRM parser
within WebSphere Message Broker uses this information to parse an incoming
message bit stream into a message tree, or to write a message tree into a physical
bit stream.

Contents of a message dictionary: A message dictionary contains the same
information as the message set from which it was created, but in a compressed
form that the MRM parser within WebSphere Message Broker can understand and
use. A message dictionary contains all the elements in the message set, the
structure of the messages, and all the value constraints. A message dictionary also
contains any physical formats that were defined in the message set.

Generating a message dictionary: Before a message dictionary can be used, it
must be deployed to WebSphere Message Broker. To do this, add the message set
to a BAR file, and then deploy the BAR file to a message broker. The generation of
the message dictionary is performed automatically when a message set is added to
a BAR file, if the message set supports the MRM domain.

Before adding a message set to a BAR file, the Message Broker Toolkit performs a
full validation of the message set. If this validation finds any errors, the message
set is not added to the BAR file, and therefore no message dictionary is generated.

Dictionary generation report files:

Whenever a message dictionary is generated, a user log file is also generated and
added to the same BAR file. This file contains informational messages and
warnings that relate to the use of the generated dictionary. Always check this file
after generating a message dictionary.

Generate XML Schema
XML Schema is a standard way of describing complex message models.

You can generate a schema file from a message definition file. You can do this for
an individual message definition file, or for all message definition files in a
message set. If any XML physical formats have been defined for the message set,
you can select which of these XML wire formats are to be applied.

e If an XML format has been selected, the physical format information will also be
included.

* If no XML format is selected, the generated schema file only contains
information about the logical message model.

You can choose whether “strict’ or lax” schema generation is to be performed. This
is necessary because the logical extensions to the XML Schema model provided by
the message definition file cannot be represented in XML Schema. So you can
choose either to generate a Schema with more strict or more lax validation than the
equivalent validation performed by the message model parser. The affected model
extensions are:

* Content Validation = open
* Content Validation = open defined
* Composition = unordered set

Further information about XML Schema: For details about XML Schema, see
[XML Schema Part 0: Primer] on the [World Wide Web Consortium (W3C)| Web site.

Validating an XML message against a schema:


http://www.w3.org/TR/xmlschema-0/
http://www.w3.org/

The XMLNSC parser can validate an XML message against any deployed XML
schema.

You can validate an XML message against an XML schema when the message is
parsed, when the message is serialized, or at any point within a message flow.

To construct a message flow for schema validation, you must perform the
following tasks:

1. Enable validation at the appropriate point within the message flow. See
[Validating messages}

2. Ensure that you have deployed all XML Schema files that are required. See
[‘Deploying an XML Schema.”|

3. Specify the message set in which the schema was deployed; this is done using
the MessageSet property of the message. See|Accessing the Properties tree}

Schemas are deployed within a message set, and are identified by supplying the
message set name in the message properties.

Deploying an XML Schema:

XML Schemas are created as Message Definition Files within a message set that is
then deployed.

To create and deploy a message set for schema validation you must:
1. Create or locate a message set that will contain the schemas.
2. Set the Message Domain property of the message set to XMLNSC.

3. Use the New Message Definition File wizard to create a message definition file
(mxsd) from the XML Schema file (.xsd).

4. Add the message set to a BAR file and deploy the BAR file.
Repeat step 3 for each XML Schema file that you want to deploy.

If your XML Schema imports or includes other XML Schema files, you can use the
mgsicreatemsgdefs command to create all the message definition files in a single
operation.

Generate WSDL

A Web Services Description Language (WSDL) document specifies the interface to a
Web service, and enables a Web service client to invoke it. A WSDL document that
is generated from a message set defines Web service requests and responses in
terms of the messages that you have defined in that message set.

Use message definition files with target namespaces when you generate WSDL. If
you do not, WebSphere Message Broker defaults the target namespace to the
WSDL target namespace.

If the WSDL uses a message from the message definition file, one XML Schema file
is generated for each message definition file in the message set. Within the main
WSDL document, operations are defined in terms of logical messages, which are
themselves defined in terms of the elements and types that are defined in these
XML Schema files.
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WSDL operations are grouped into a logical interface or portType, and are then
associated with a binding which defines the physical format of the messages. You
can select only one of the following bindings when you generate WSDL:

* SOAP (over JMS)

* SOAP (over HTTP)

A WSDL service definition specifies the endpoint where the service is available.
You can elect to have the service, binding, and portType definitions generated as a
single file or as separate files, but the XML Schema files are always generated
separately. Tools that consume WSDL are typically more tolerant of the single-file
format.

Relationship to the message model when generating WSDL: If a broker is to
communicate with a web service client, it typically needs to accept SOAP
messages. Using this approach you should use the MRM domain, in which case
the broker’s message model and the WSDL definition used by the web service
client must describe the same messages.

If the broker has an existing message model (possibly created by importing a C
header file or COBOL copybook), this can be exported to create a corresponding
WSDL definition for use by the client. At the same time, your message model
needs to be enhanced with appropriate definitions for the SOAP envelope and (for
rpc-style) the WSDL operations. Currently only WSDL version 1.1 is supported.

In order to generate WSDL you need:

1. a way of representing the WSDL operations. This is the role of the message
category.

2. a way of representing the data for these operations. This is the message model.

3. a way of soliciting the web service end-point and binding details. This is the
role of the WSDL Generator wizard.

A message category is required for each WSDL operation. The category specifies a
set of messages from the broker model and associates them with the required
WSDL qualifiers for the specified WSDL operation type.

At runtime, the format of the SOAP messages depends on the WSDL style
specified in the wizard. If the user selects rpc-style then the SOAP Envelope will
contain a message corresponding to a WSDL operation. The WSDL generator will
then add an appropriate message definition that corresponds to the WSDL
operation to your message set. If you select document-style then the SOAP
envelope will simply contain messages specified in the category, so no additional
message definitions need to be added to your message set.

Message definitions for the SOAP envelope and (if necessary) the SOAP encoding
scheme are imported into the message set.

Resulting message model

The resulting model allows you to parse incoming SOAP messages using the MRM
XML parser where the message type would be Envelope. The message model for
the SOAP envelope defines the outer SOAP wrapper with its constituent header
and body sections and a number of attachment points where the various business
payloads can appear. These attachment points are defined with composition of
type message, allowing broker messages to appear at these points.



The allowed attachment points are Envelope.Body, Envelope.Header and
Envelope.Body.Fault.detail. A message from your message model may appear at
each point (in the case of the Envelope.Header, multiple messages may appear). In
the case of rpc-style WSDL, the message expected at Envelope.Body is the
automatically generated message corresponding to the WSDL operation (for
example, the message category). In all other cases the messages expected are those
referenced by the message categories.

Generating message set documentation
Message set documentation describes, in a human-readable format, message
definitions which you have created.

When you have created one or more message definitions, it can be useful to
generate message set documentation for business analysis and for developers who

are involved with the messages.

Message definition files contain both logical and physical definitions for the
message model. The generated documentation describes the logical format only.

The documentation exists as a self-consistent set of HTML pages.

Working with a message set project

Before you begin to develop your message model, you must create a message set.
A message set project is automatically created when you create a message set.

This topic area describes the tasks that are involved in working with a message set.

+ [“Creating a message set” on page 83|

+ [“Deleting a message set project”|

Deleting a message set project

Before you start:

You must have completed the following task:

* [“Creating a message set” on page 83

Tip: Close all open windows within the workbench that relate to the message set
project or associated files that you want to delete. If you do not do this, errors
might occur when you try to process objects that no longer exist your
workspace.

This task topic describes how to delete a message set project and, optionally, the
contents of the associated project directory.

To delete a message set project:
1. Switch to the Broker Application Development perspective.

2. In the Broker Development view, right-click the message set project that you
want to delete, then click Delete on the pop-up menu. The Confirm Project
Delete window opens.

3. Choose whether to delete or retain the contents of the project directory. By
default, project directory contents are not deleted. To delete the contents of the
project directory, click Also delete contents; all files and directories that are
associated with the project are deleted.
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4. Click Yes to delete the message set project. Alternatively, click No or press Esc
to cancel the deletion.

Working with a message set

This topic area describes the tasks that are involved in working with a message set:

+ [“Configuring message set preferences’]

* |“Opening an existing message set”

+ [“Creating a message set” on page 83|

« |“Configuring logical properties: Message sets” on page 85|

» |“Working with physical formats” on page 86|

+ [“Configuring documentation properties: Message sets” on page 92|

* |“Deleting a message set” on page 92

* |“Applying a Quick Fix to a task list error” on page 93|

Configuring message set preferences

This task topic explains how to make changes to preferences that relate to message
set processing. These preferences are for message set editors, message set model
validation, and importing XML Schema.

To configure message set preferences:
1. Open the Preferences window by clicking Window > Preferences.

2. In the left hand pane, expand Broker Development > Message Sets by clicking
+. This displays the following options:

* Editors
* Validation
* XML Schema Importer

3. View or make any necessary changes to the preferences for message set
processing. These preferences are shown in the right hand area of the window.

4. When you have finished, click Apply. Alternatively, click Restore Defaults to
return to the default settings for the displayed fields.

5. Close the Preferences window by clicking OK.

Opening an existing message set
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Open an existing message set in the Message Set editor so that you can view or
edit its contents.

Before you start:

Create a message set by following the instructions in [’Creating a message set” on|

Tip: Although you can open resource files with other editors you are advised to
only use the workbench Message Set editor to work with message set files
because this editor correctly validates changes made to the messageSet.mset
files when they are saved. Other editors might not do this.

To open a message set so that you can view or edit its contents:
1. Switch to the Broker Application Development perspective.



2. In the Broker Development view, right-click the messageSet.mset file of the
message set that you are opening then click Open on the pop-up menu. This
launches the Message Set editor for the selected file.

You can now view or edit the file as required.

Creating a message set

Use the New Message Set wizard to create a message set.
The New Message Set wizard also creates a new message set project.

Note: You can also use a Quick Start wizard to create a message set, a message set
project, and other resource files that you need to create a new application.

The New Message Set wizard allows you to select what kinds of message format
you want to model in your message set. The message domain and the physical
format created is inferred from the selection that you make. Note, however, that
you can change the inferred domain using the message set editor.

The options are:

¢ XML documents (general)

* Web services (SOAP)

* Binary data (for example, C or COBOL structures)
» Text data (for example, CSV, SWIFT, or HL?)

* MIME documents other than Web services

e Data for WebSphere Adapters

The default value is XML documents (general).

Below the list of message formats there are check boxes corresponding to each of
the message formats. The check box corresponding to the message format that you
selected is not available, but you can select any of the other check boxes to add
other message formats to your message set.

If you later select a different default message domain, the checked state for the
domain that you originally selected as the default does not change, but the check
box is enabled.

As you can now select more than one message domain you can, for example, use
the default value of XML documents (general) together with Binary data (for
example, C or COBOL structures) and Text data (for example, CSV, SWIFT or
HL7). This results in the selection of the XMLNSC and MRM domains (to handle
non-XML documents) within the same message set if you require this functionality.

The mapping between the selection, the domain, and the wire format created is
described in the following table:

Selection

Inferred message domain

Physical format created

XML documents (general)

XMLNSC

XML

Web services (SOAP)

SOAP and XMLNSC

XML

Binary data (for example, C
or COBOL structures)

MRM

CWF
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Selection Inferred message domain Physical format created
Text data (for example, CSV, | MRM TDS

SWIFT, or HL?)

MIME documents other than | MIME None

Web services

Data for WebSphere DataObject None

Adapters

Depending on your selection, an appropriate IBM supplied message will be
imported into the message set.

Note: The XML physical format is created only in case the user switches to MRM
XML.

If you click Finish on the second page of the New Message Set wizard, the
message set that is created has the following default property values:

Property Default value

Message Domain XML documents (general)
Physical Format XML Wire Format (XML1)
Namespace support Enabled

To create a new message set:
1. Switch to the Broker Application Development perspective.

2. Open the New Message Set wizard. To do this, right-click anywhere in the
Broker Development view then click New> Message Set on the pop-up menu.

3. Type the Message set name for the message set that you are creating. The
name that you type is also displayed in the Message set project name field.

4. Optional: You can choose a different message set project name; to do this, type
this name into the Message set project name field.

5. Optional: You can specify a directory in which you want to store the project
contents. If you do not specify a directory, the default workspace is used. To
specify a directory, first clear the Use default check box and then either type
into the Directory field the location of the directory, or click Browse to see a
list of the folders that you can choose from for the location of the directory.

6. Optional: If you want to create a new message set whose definition is based on
existing message set, click Message Set in the Copy message set contents from
another message set pane and choose from the list of message set definitions
that are shown; then click Finish. The new message set (and the message set
project that contains it) is created immediately and the New Message Set
wizard automatically closes.

7. Optional: If you want to create a message set whose definition is not based on
an existing message set, click Next>. You are presented with the next pane
which allows you to choose the type of message data that you want to process.

a. Expand the list shown under Select the type of message data that you will
be working with most often and choose a value from the list shown. The
value that you choose determines the default message domain of the
message set. If you choose XML Documents (general), the default message
domain XMLNSC is used.



b. Optional: You can now select additional types of message data. Under
Select any other types of message data that you will be working with
there are check boxes for each of the following message data types:

¢ XML documents (general)

* Web services SOAP

* Binary data (for example, C or COBOL structures)
* Text data (for example, CSV, SWIFT or HL7?)

* MIME documents other than Web services

¢ Data for WebSphere Adapters

Note: These check boxes correspond to the list of data types from which
you chose the data type that you will be working with most often,
but the check box that corresponds to the data type that you chose
from that list is not available.

By default, all these check boxes are cleared. You can select any, or all of

these check boxes, to add the corresponding data types to your message set.

If you select the check box for text data, either for the type of message data
that you will be working with most often or as another type of message
data that you will be working with, you can additionally choose from the
displayed list of text messaging standards. This list is the same as that given
in the description of the Messaging Standard property in
[message set properties” on page 160 |

c. Click Next A new panel is displayed that summarizes some information
about the message set that you have created. Specifically, it lists:

Supported message domains
Physical formats to be created
IBM supplied messages to be imported

8. Click Finish on this page to create the message set, and the message set project
that contains it. The New Message Set wizard closes.

After the New Message Set wizard finishes, the message set editor is opened.
You can now create some message definitions in the new message set. You can
either create new message definitions from scratch, or create them based on
existing artifacts such as WSDL, XSD, DTD, C, COBOL files, or EIS metadata. Use

the Message Definition File wizard and the Message Definition File From wizard to
help you with this.

Configuring logical properties: Message sets

Before you start:

You must have completed the following task:

+ [“Creating a message set” on page 83|

If the messageSet.mset file for the appropriate message set is not already open in
the Message Set editor, you must first open it as described in [“Opening an existing]
[message set” on page 82

This task topic describes how to configure the logical properties of a message set
using the Message Set editor.
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To configure the logical properties of a message set:

1. Switch to the Broker Application Development perspective.

2. In the Message Set editor, in the Properties Hierarchy, click Message Set. This
displays the logical properties of the selected message set in the Details view.

3. Configure to your requirements the logical properties that are shown in the
Details view.

Note: Property fields that are disabled cannot be altered. For example, the
Message Set ID field is disabled because the message set ID is generated
automatically when the message set is created; the Message Set ID must
not then be altered.

4. Save your changes by clicking File> Save or by pressing Ctrl+S. Alternatively
click File> Save All or press Ctrl+Shift+S.

Working with physical formats

86  Message Models

Before you start:

You must have completed the following tasks:

+ |“Creating a message set” on page 83|

* [“Opening an existing message set” on page 82|

If you are using the MRM domain to parse and write your messages, when you
are developing your message model you might want to add one or more physical
format layers to a message set and then configure the properties of these physical
formats. This topic area covers the following tasks that relate to working with the
physical properties of a message set:

+ “Adding a Custom Wire Format (CWF)”|
+ |“Configuring Custom Wire Format (CWF) properties: Message sets” on page 87|

+ |“Adding a TDS physical format” on page 87|

+ [“Configuring TDS properties: Message sets” on page 88|

+ [“Adding an XML wire format” on page 89|

+ [“Configuring XML Wire Format properties: Message sets” on page 89|

* [“Renaming a physical format” on page 90|

* |“Applying default physical format settings: Message sets” on page 90|

* [“Removing a physical format” on page 91]

* [“Observing 2007 U.S. changes to Daylight Savings Time” on page 91|
Adding a Custom Wire Format (CWF)

Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83|

* [“Opening an existing message set” on page 82|

This task topic describes how to add a Custom Wire Format (CWF) physical format
layer to a message set using the Message Set editor.

To add a CWF physical format layer to a message set:
1. Switch to the Broker Application Development perspective.



2. In the Message Set editor, in the Properties Hierarchy, open the Add Custom
Wire Format window by right-clicking Custom Wire Formats and then clicking
Add Custom Wire Format on the pop-up menu.

3. On the Add Custom Wire Format window, specify the name that you want to
use for the new CWF physical format. The default name is ‘Binary1’.

Tip: Physical format names must be unique across a message set. You are
recommended to start the name of your new CWF physical format with
"CWF’ or 'Binary’, because this clearly identifies the type of the physical
format that you are adding in relation to any of the other types.
4. Click OK to add the physical format layer to the message set. Alternatively, if
you decide to cancel the process, click Cancel or press Esc on the keyboard.

Tip: The new physical format layer is added with the relevant default property
values. You can configure the message set properties according to your
requirements, using the appropriate editor.

5. Save your changes either by clicking File> Save or by pressing Ctrl+S.

Configuring Custom Wire Format (CWF) properties: Message
sets

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Opening an existing message set” on page 82|
+ [“Adding a Custom Wire Format (CWF)” on page 86|

This task topic describes how to configure the Custom Wire Format (CWF)
properties of a message set using the Message Set editor.

To configure the CWF properties of a message set:
1. Switch to the Broker Application Development perspective.

2. In the Message Set editor, the Custom Wire Formats node of the Properties
Hierarchy shows the name of each of the CWF physical formats that have been
added to the message set. If the physical format names are not in view, expand
Custom Wire Formats by clicking +.

3. Click the chosen CWF physical format so that the properties of this format
appear in the Details view of the Message Set editor.

4. Configure the CWF properties shown in the Details view according to your
requirements.

5. Save your changes either by clicking File> Save or by pressing Ctrl+S.
Alternatively click File> Save All or press Ctrl+Shift+S.

Adding a TDS physical format
Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83

+ [“Opening an existing message set” on page 82|
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This task topic describes how to add a Tagged/Delimited String (TDS) physical
format layer to a message set using the Message Set editor.

To add a TDS physical format layer to a message set:
1. Switch to the Broker Application Development perspective.

2. In the Message Set editor, in the Properties Hierarchy, open the Add
Tagged/Delimited String Format window by right-clicking Tagged/Delimited
String Formats then clicking Add Tagged/Delimited String Format on the
pop-up menu.

3. In the Add Tagged/Delimited String Format window, specify the name that
you want to use for the new TDS format. The default name is "Textl’.

Tip: Physical format names must be unique across a message set. You are
recommended to start the name of your new TDS physical format with
"TDS’ or "Text’, because this clearly identifies the type of the physical
format that you are adding in relation to any of the other types.

4. Click OK to add the physical format to the message set. Alternatively, if you
decide to cancel the process, click Cancel or press Esc on the keyboard.

Tip: The new physical format layer is added with the relevant default property
values. You can configure the message set properties according to your
requirements, using the Message Set editor.

5. Save your changes either by clicking File> Save or by pressing Ctrl+S.
Configuring TDS properties: Message sets
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

+ [“Opening an existing message set” on page 82|

+ “Adding a TDS physical format” on page 87|

This task topic describes how to use the Message Set editor to configure the TDS
physical format properties of a message set.

To configure the TDS physical format properties of a message set, do the following:

1. Switch to the Broker Application Development perspective.

2. In the Message Set editor, the Tagged/Delimited String Formats node of the
Properties Hierarchy shows the name of each of the TDS physical formats that

have been added to the message set. If the physical format names are not in
view, expand Tagged/Delimited String Formats by clicking +.

3. Click the chosen TDS physical format so that the properties of this format
appear in the Details view of the Message Set editor.

4. Configure the TDS properties shown in the Details view according to your
requirements.

5. Save your changes either by clicking File> Save or by pressing Ctrl+S.
Alternatively click File> Save All or press Ctrl+Shift+S.



Adding an XML wire format

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Opening an existing message set” on page 82|

This task topic describes how to add an XML wire format physical format layer to
a message set using the Message Set editor.

To add an XML physical format layer to a message set:

1.
2.

5.

Switch to the Broker Application Development perspective.

In the Message Set editor, in the Properties Hierarchy, open the Add XML Wire
Format window by right-clicking XML Wire Formats and then clicking Add
XML Wire Format on the pop-up menu.

On the Add XML Wire Format window, specify the name that you want to use
for the new XML wire format. The default name is "XML1".

Tip: Physical format names must be unique across a message set. You are
recommended to start the name of your new XML physical format with
"XML', because this clearly identifies the type of the physical format that
you are adding in relation to any of the other types.

Click OK to add the physical format layer. Alternatively, if you decide to cancel
the process, click Cancel or press Esc on the keyboard.

Tip: The new physical format layer is added with the relevant default property
values. You can configure the message set properties according to your
requirements, using the appropriate editor.

Save your changes either by clicking File> Save or by pressing Ctrl+S.

Configuring XML Wire Format properties: Message sets

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83

* [“Opening an existing message set” on page 82|
* [“Adding an XML wire format”|

This task topic describes how to configure the XML Wire Format properties of a
message set using the Message Set editor.

To configure the XML wire format properties of a message set:

1.
2.

Switch to the Broker Application Development perspective.

In the Message Set editor, the XML Wire Formats node of the Properties
Hierarchy shows the name of each of the XML physical formats that have been
added to the message set. If the physical format names are not in view, expand
XML Wire Formats by clicking +.

Click the chosen XML physical format so that the properties of this format
appear in the Details view of the Message Set editor.

Configure the XML wire format properties shown in the Details view according
to your requirements.
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5. Save your changes either by clicking File> Save or by pressing Ctrl+S.
Alternatively click File> Save All or press Ctrl+Shift+S.

Renaming a physical format
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Opening an existing message set” on page 82|

This task assumes that you have added one or more physical formats to the
message set that you are working with. For further information see |”Adding a

Custom Wire Format (CWF)” on page 86| or [“Adding an XML wire format” on|

page 89| or [“Adding a TDS physical format” on page 87/

This task topic describes how to rename a physical format using the Message Set
editor.

To rename a physical format previously added to the message model:

1. Close all message definition (.mxsd) files that are currently open in the Message
Definition editor, otherwise you will not be able to rename the physical format.

2. Switch to the Broker Application Development perspective.

3. In the Message Set editor, the Properties Hierarchy shows the name of each of
the physical formats that have been added to the message set. If the physical
format names are not in view, expand XML Wire Formats, Custom Wire
Formats, or Tagged/Delimited String Formats by clicking +.

4. Right-click the physical format that you want to rename then click Rename on
the pop-up menu to open the “Rename wire format” window.

5. In the “Rename wire format” window, type the new name for the physical
format. The renaming operation modifies all of the message definition files in
the message set and saves the amended message set file.

6. Click Finish to rename the physical format and save the message set file.
Applying default physical format settings: Message sets

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Opening an existing message set” on page 82|

The tasks in this topic area assume that you have added one or more physical
formats to the relevant message set. For further information see [“Adding a Custom|

Wire Format (CWF)” on page 86| or [“Adding an XML wire format” on page 89| or

“Adding a TDS physical format” on page 87

To apply the default settings to a physical format that has previously been added
to a message set:

1. Switch to the Broker Application Development perspective.

2. In the Message Set editor, in the Properties Hierarchy, right-click the physical
format to which you want to apply the default settings then click Apply
default physical format settings on the pop-up menu.



The default settings are applied to the physical format that you have selected. No
warning appears beforehand.

Removing a physical format
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Opening an existing message set” on page 82|

The tasks in this topic area assume that you have added one or more physical
formats to a message set. For further information see [“Adding a Custom Wire|
Format (CWF)” on page 86| or[“Adding an XML wire format” on page 89 or
“Adding a TDS physical format” on page 87

To remove a physical format layer from your message set:

1. Close any message definition files that are currently open in the Message
Definition editor, otherwise you will not be able to remove the physical format.

2. Switch to the Broker Application Development perspective.

3. In the Message Set editor, the Properties Hierarchy shows the name of each of
the physical formats that have been added to the message set. If the physical
format names are not in view, expand XML Wire Formats, Custom Wire
Formats, or Tagged/Delimited Wire Formats, by clicking +.

4. Right-click the physical format that you want to remove, and then click Delete
on the pop-up menu.

Tip: If you decide to proceed with deleting the physical format, all of the
message definition files under the current message set are modified and
the amended message set file is saved.

5. Click Finish to remove the physical format, or click Cancel to return to the
Broker Application Development perspective without making any changes.
Pressing Esc also returns you to the Broker Application Development
perspective without making any changes.

Observing 2007 U.S. changes to Daylight Savings Time
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

+ [“Opening an existing message set” on page 82|

This task assumes that you have added and configured one or more physical
formats to existing message sets. For further information see:

[physical formats” on page 86.

This task describes how to ensure that the message sets observe daylight savings
time (DST) in line with the 2007 U.S. changes.

If your message sets use a named time zone that is not changing DST in line with
the 2007 U.S. changes, you do not need to do anything.
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If you are using a GMT-04:00, GMT-05:00, GMT-06:00, GMT-07:00, or GMT-08:00
named time zone with DST, that must observe DST in line with the 2007 U.S.
changes, do the following on every computer on which the broker is running:

1. Set the environment variable MQSI_USE_NEW_US_DST to an initial value: Y,
for example.

2. Restart the broker to use the changed DST.
Configuring documentation properties: Message sets

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Opening an existing message set” on page 82|

This task topic describes how to document a message set within the workbench.

To configure the documentation for a message set:
1. Switch to the Broker Application Development perspective.

2. In the Message Set editor Properties Hierarchy, click Message set. The
documentation text field appears in the Details view along with all the other
logical properties of the message set.

3. Configure the documentation properties shown in the Details view to your
requirements.

Tip: The Documentation property can be used to set user defined keywords
and their value. These are propagated to the Configuration Manager when
the message set is deployed to the broker. These keywords are used to
give additional information about the message set when the Configuration
Manager is used to display deployed message set properties. See
[“Message set version and keywords” on page 10| for more information.

4. Save your changes either by clicking File> Save, or by pressing Ctrl+S.
Alternatively click File> Save All, or press Ctrl+Shift+S.

Deleting a message set

If you want to delete a message set from your message model, you must delete the
message set project that contains the message set.

1. Switch to the Broker Application Development perspective.

2. In the Broker Development view, right-click the message set project folder that
contains the message set that you want to delete and click Delete on the
pop-up menu. This opens the Confirm Project Delete window, which asks
whether you want to delete the message set project that you have specified.

3. Click Also delete contents ..... to delete the contents of the message set project,
or click Do not delete contents to cancel the deletion of the message set
project. Pressing the Esc key on your keyboard also cancels the deletion of the
message set project.

Important: When you delete a message set project, the action cannot be undone

after you have confirmed the deletion. All folders and associated files
for the message set project are deleted.
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Applying a Quick Fix to a task list error

During the creation, migration and manipulation of message definition files,
warnings or errors might occur; these are listed in the Problems view of the Broker
Application Development perspective. Some of these warnings or errors can be
cleared by applying a Quick Fix.

Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83

+ [“Creating a message definition file” on page 94|

The types of warnings or errors that can be cleared using a Quick Fix are those
where the construct has a broken link, where the construct has a facet that is not
legal, or where the construct has been imported, and where a warning or error has
occurred, but has been kept to ensure the integrity of structure that is being
imported. This allows you to fix the problem in the most appropriate way.

To apply a Quick Fix:
1. Switch to the Broker Application Development perspective.
2. Ensure that the Problems view is visible in the Broker Application

Development perspective of the workbench. If the Problems view is not visible,
from the workbench menu, click Window » Show View > Problems.

3. In the Problems view, right-click the task list warning or error that you want to
apply the Quick Fix to, and then click Quick Fix. Note that Quick Fix might
not be available for the problem that you are trying to fix.

4. Step through the windows that are displayed, making the selections that are
required to ensure that the fix is applied in the appropriate way.

When the Quick Fix has successfully been applied to the task list warning or error,
it is removed from the Problems view.

Working with a message definition file

Before you start:

You must have completed the following task:

* [“Creating a message set” on page 83

This topic area describes the tasks that are involved in working with a message
definition file:

* |“Opening an existing message definition file”]

+ [“Creating a message definition file” on page 94|

* |“Deleting a message definition file” on page 95|

Opening an existing message definition file

This task topic describes how to open an existing message definition file in the
Message Definition editor; you can then view and edit the contents of the file.

To open an existing message definition file:

1. Switch to the Broker Application Development perspective.
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2. In the Broker Development view, right-click the message definition file (file
extension *.mxsd) that you want to open, and select Open. This launches the
Message Definition editor for the message definition file that you have
specified.

Tip: The Eclipse framework lets you open resource files with other editors.
However, you are advised to use only the workbench Message Definition
editor to work with message definition files, because this editor correctly
validates any changes that are made to the message definition files. Other
editors might not do this.

3. View or edit the data in the file as required.

Creating a message definition file
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Before you start:

You must have completed the following task:

+ [“Creating a message set” on page 83|

You must create a message definition file before you can create the message model
objects. The message definition file contains the logical and physical model
definitions of the objects in XML Schema form.

Either create the message definition file from scratch, or base your message
definition file on an existing resource (an XML Schema file, an IBM-supplied

message, an XML DTD file, a C header file, a COBOL file, or a WSDL file).

How to do this is described in:

+ [“Creating a message definition file from scratch”]

* [“Creating a message definition file from an existing resource” on page 95|

Creating a message definition file from scratch
Before you start:

You must have completed the following task:

+ [“Creating a message set” on page 83|

You must create a message definition file before you can create the message model
objects. The message definition file contains the logical and physical model
definitions of the objects in XML Schema form.

To create an empty message definition file from scratch:
1. Switch to the Broker Application Development perspective.
2. Open the New Message Definition File wizard.

To do this, right-click on the message set project in the Broker Development
view that you are adding the message definition file to, and click New>
Message Definition File on the pop-up menu. The Message Definition File
panel of the wizard is displayed. The target message set list is filtered to only
show artifacts in the active working set.

3. Click on the message set, type a name into the File name field, and click Next.
4. Step through the remainder of the wizard, filling in the details as required.



The new empty message definition file, with the name that you have specified and
a file extension of *.mxsd, opens in the Message Definition editor; you can use the
editor to create your own message definitions. If you have chosen to use a target
namespace, a directory structure that is based on the URI that you have supplied is
created. The new message definition file is placed within this directory structure,
which appears in the Broker Development view.

Creating a message definition file from an existing resource

You must create a message definition file before you can create the message model
objects. The message definition file contains the logical and physical model
definitions of the objects in XML schema form.

You must have completed the following task:

+ [“Creating a message set” on page 83|

To create a new message definition file that is based on an existing resource:
1. Switch to the Broker Application Development perspective.
2. Open the appropriate New Message Definition File From wizard.

To do this, right-click on the message set project in the Broker Development
view that you are adding the message definition file to, and click New>
Message Definition File From. A submenu shows the list of resources that you
can choose from.

3. Choose the resource on which you want to base your new message definition.
Click XML Schema File, IBM Supplied Message, XML DTD File, C Header
File, COBOL File, or WSDL File. The first panel of the corresponding wizard
is displayed.

4. Step through the remainder of the wizard filling in the details as required.

The new message definition file, with the name that you have specified and a file
extension of *.mxsd, opens in the Message Definition editor; you can use the editor
to create your own message definitions. If you have chosen to use a target
namespace, a directory structure that is based on the URI that you have supplied is
created. The new message definition file is placed within this directory structure,
which appears in the Broker Development view.

Deleting a message definition file

To delete a message definition file from your message model:
1. Switch to the Broker Application Development perspective.

2. In the Broker Development view, right-click the message definition file (file
extension *.mxsd) that you want to delete, then click Delete on the pop-up
menu. Alternatively, select the message definition file that you want to delete in
the Broker Development view, then, from the menu bar, click Edit> Delete, or
press the Delete key.

3. In the Confirm Resource Delete window, click Yes to delete the message
definition file. Click No, or press the Esc key, to cancel the deletion of the
message definition file.

Important: All files and objects that are associated with the message definition file
are deleted. This action cannot be undone.
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Working with message model objects

Before you start:

You must have completed the following tasks:

* |“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

This topic area describes the tasks that are involved in working with message
model objects:

+ [“Adding message model objects”]

» [“Configuring message model objects” on page 10
guring

* |“Deleting objects” on page 120

Adding message model objects
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Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Creating a message definition file” on page 9
g g

Before starting any of the tasks in this topic area, you must first open the message
definition file to which you want to add message model objects in the Message
Definition editor. See [“Opening an existing message definition file” on page 93| for
further details.

This topic area describes the tasks that are involved in adding message model
objects to a message definition file:

+ |“Adding a message” on page 97|

+ “Adding a message from a global element” on page 97|

* |“Adding a global element” on page 98|

+ [“Adding a local element” on page 99|

* [“Adding an element reference” on page 99
g

[‘Adding a wildcard element” on page 100|
+ [“Adding a global attribute” on page 100|
+ “Adding a local attribute” on page 101

* [“Adding an attribute reference” on page 101
g

+ [“Adding a wildcard attribute” on page 102|

+ [“Adding a simple type” on page 102|

+ “Adding a complex type” on page 104|

+ [“Adding a simple type to an element or attribute” on page 111|

* |[“Adding a complex type to an element” on page 111|

[“Adding a global group” on page 104|

[“Adding an attribute group” on page 105|

* |“Adding a group reference” on page 106|




Adding a message

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93]

To add a message to your message definition file:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click Messages then click Add Message on the
pop-up menu. A simple message is immediately added to your message model
and is assigned a default name.

4. Either type a new name for the message or press Enter to accept the default.

Tip: When you add a message to your message model, an associated complex
type and global element with the same name as the message are also
created. The global element and the message cannot have different names
and changing the name of one changes the names of both. The complex
type can be renamed.

You can now configure the properties of the message to your exact requirements.
For further information on configuring message model objects see

[message model objects” on page 107

Adding a message from a global element
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

* |“Opening an existing message definition file” on page 93|

+ [“Adding a global element” on page 98| (This must be a global element of
complex type)

To add a message from a global element to your message model:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click Messages then click Add Message From Global
Element on the pop-up menu to open the Add Message From Global Element
window. This window lists all the global elements of a complex type that are
not already associated with a message.

4. In the Select a global element of complex type that is not already used for a
message list, click the global element that you want to use to create your
message.
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5. Click OK. This immediately adds a message with the same name as the
selected global element to your message model.

You can now configure the properties of the message to your exact requirements.
For further information on configuring message model objects see

[message model objects” on page 107

Adding a message from a global type
Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

+ |“Opening an existing message definition file” on page 93|

* [“Adding a global element”] (This must be a global element of complex type)

To add a message from a global type to your message model:
1. Switch to the Broker Application Development perspective.
2. Ensure that the Outline view is visible in the Broker Application Development

perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click Messages then click Add Message From Global
Type on the pop-up menu to open the Add Message From Global Type
window. This window lists all the global complex types that are not already
associated with a message.

4. In the Select a global complex type list, click the global complex type that you
want to use to create your message.

5. Click OK. This immediately adds a message with the same name as the
selected global complex type to your message model.

You can now configure the properties of the message to your exact requirements.
For further information on configuring message model objects see

[message model objects” on page 107

Adding a global element
Before you start:

You must have completed the following tasks:

* |“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

* [“Opening an existing message definition file” on page 93

To add a global element to your message model:
1. Switch to the Broker Application Development perspective.
2. Ensure that the Outline view is visible in the Broker Application Development

perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click Elements and Attributes then click Add Global
Element on the pop-up menu. This adds a global element of type string to
your message model, and assigns a default name.



4. Either type a new name for the global element or press Enter to accept the
default.

You can now configure the global element to your requirements. For further
information on configuring message model objects see [“Configuring message|
fmodel objects” on page 107

Adding a local element
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

+ |“Creating a message definition file” on page 94|

* |“Opening an existing message definition file” on page 93|

This task assumes that you have previously added the relevant message, type,
group or complex element to your message model.

To add a local element to a message, type, group or complex element:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click the object (message, complex type, group or
complex element) to which you are adding a local element then click Add
Local Element on the pop-up menu. A local element of type string is added to
the message model and is assigned a default name.

4. Either type a new name for the local element or press Enter to accept the
default.

You can now configure the local element to your exact requirements. For further
information on configuring message model objects see [‘Configuring message|
[model objects” on page 107

Adding an element reference
Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83

+ [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93

This task assumes that you have previously added the relevant message, type,
global group or complex element to your message model.

To add an element reference to a message, type, global group or complex element:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.
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3. In the Outline view, right-click the object (message, complex type, group or
complex element) to which you are adding the element reference, then click
Add Element Reference on the pop-up menu. This adds a default element
reference to the message model object that points to an existing global element.
This existing global element may be in the current message definition file or in
a message definition file defined under Includes or Imports for the current
message definition file. For further information on Imports and Includes see
[‘Linking from one message definition file to another” on page 122

You can now configure the element reference to your exact requirements. For
further information on configuring message model objects see ”Configurina
[message model objects” on page 107 |

Adding a wildcard element
Before you start:

You must have completed the following tasks:

+ |“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93]

You can add a wildcard element to a message, type, group or complex element.
This task assumes that you have previously added the relevant message, type,
group or complex element to your message model.

To add a wildcard element to a message, type, group or complex element:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click the message model object (message, complex
type, group or complex element) to which you are adding the wildcard element
then click Add Wildcard Element on the pop-up menu. A wildcard element is
added and appears in the Outline view.

You can now configure the wildcard element to your exact requirements. For
further information on configuring message model objects see ”Conﬁéurina
[message model objects” on page 107

Adding a global attribute
Before you start:

You must have completed the following tasks:

* |“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93

To add a global attribute to your message model:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.



3. In the Outline view, right-click Elements and attributes then click Add Global
Attribute on the pop-up menu. A global attribute of type string is immediately
added and is assigned a default name.

4. Either type a new name for the global attribute or press Enter to accept the
default.

You can now configure the global attribute to your requirements. For more
information on configuring message model objects see [“Configuring message|
[model objects” on page 107

Adding a local attribute

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93]

You can add a local attribute to a message, complex type or complex element. This
task assumes that you have previously added the relevant message, complex type
or complex element to your message model.

To add a local attribute to a message, complex type or complex element:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click the object (message, complex type, complex
element, or attribute group) to which you are adding the local attribute then
click Add Local Attribute on the pop-up menu. A local attribute of type string
is immediately added to the message model object and is assigned a default
name.

4. Either type a new name for the local attribute or press Enter to accept the
default.

You can now configure the local attribute to your requirements. For further
information on configuring message model objects see [“Configuring message]
[model objects” on page 107

Adding an attribute reference
Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83

+ [“Creating a message definition file” on page 94|

* [“Opening an existing message definition file” on page 93]

You can add an attribute reference to a message, complex type or complex element.
This task assumes that you have previously added the relevant message, complex
type or complex element to your message model.

To add an attribute reference to a message, complex type or complex element:
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1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click the message model object (message, complex
type, complex element, or attribute group) to which you are adding the
attribute reference then click Add Attribute Reference on the pop-up menu.
This adds a default attribute reference to the message model object that points
to an existing global attribute.

You can now configure the attribute reference to your exact requirements. For
further information on configuring message model objects see|“Configuring]

[message model objects” on page 107

Adding a wildcard attribute

Before you start:

You must have completed the following tasks:

+ |“Creating a message set” on page 83|

* |“Creating a message definition file” on page 94|

+ ["Opening an existing message definition file” on page 93

You can add a wildcard attribute to a message, complex type or complex element.
This task assumes that you have previously added the relevant message, complex
type or complex element to your message model.

To add a wildcard attribute to a message, complex type or complex element:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click the object (message, complex type, complex
element, or attribute group) to which you are adding the wildcard attribute
then click Add Wildcard Attribute on the pop-up menu. A wildcard attribute
of type string is immediately added to the message model object and is
assigned a default name.

4. Either type a new name for the wildcard attribute or press Enter to accept the
default.

You can now configure the wildcard attribute to your requirements. For further
information on configuring message model objects see [“Configuring message|
[model objects” on page 107

Adding a simple type
Before you start:

You must have completed the following tasks:

* |“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

* [“Opening an existing message definition file” on page 9
p g g




To add a simple type to your message model:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click Types then click either Add Simple Type
Restriction, Add Simple Type List, or Add Simple Type Union on the pop-up
menu.

* For a restriction, a simple type of base type string is added, and assigned a
default name.

* For a list, a simple type of item type string is added, and assigned a default
name.

* For a union, a simple type with a single member type of string is added, and
assigned a default name.

4. Either type a new name for the simple type or press Enter to accept the default.
You can now configure the simple type to your exact requirements.

If the simple type is a restriction:
* You can change the base type using the editor Properties view.

* You can set the value constraints associated with the simple type. See
[value constraints” on page 112

* You can replace the base type with a new local simple type. In the Outline view
right-click on the simple type and click one of:

— Add Simple Type Restriction. This replaces the base type with a new simple
type restriction, with a base type of string. You can configure the restriction as
described in ‘If the simple type is a restriction’. The result is that the original
simple type becomes a restriction of a restriction.

— Add Simple Type List. This replaces the base type with a new simple type
list, with an item type of string. You can configure the list as described in “If
the simple type is a list’. The result is that the original simple type becomes a
restriction of a list. Note that this appears as a list in the editor, because a
restriction of a list is itself a list, but you can also set certain value constraints.

If the simple type is a list:

* You can change the item type using the editor Properties view.

* You can replace the item type with a new local simple type. In the Outline view
right-click on the simple type and click one of:

— Add Simple Type Restriction. This replaces the item type with a new simple
type restriction, with a base type of string. You can configure the restriction as
described in ‘If the simple type is a restriction’. The result is that the original
simple type becomes a list of a restriction.

— Add Simple Type Union. This replaces the item type with a new simple type
union, with a single member type of string. You can configure the union as
described in ‘If the simple type is a union’. The result is that the original
simple type becomes a list of a union.

If the simple type is a union:

* If the member type of string is not required, in the Outline view right-click on
the string and click Delete.
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* You can add further members to the union. In the Outline view right-click on
the simple type and click one of:

- Add Union Member Type. This adds a union member that is an existing
simple type. Use the type selection dialog to select the simple type required.

— Add Local Member Type Restriction. This adds a union member that is a
new simple type restriction, with a base type of string. You can configure the
restriction as described in ‘If the simple type is a restriction” above.

— Add Local Member Type List. This adds a union member that is a new
simple type list, with an item type of string. You can configure the list as
described in ‘If the simple type is a list" above.

— Add Local Member Type Union. This adds a union member that is a new
simple type union, with a single member type of string. You can configure the
new union as described in “If the simple type is a union’.

¢ New members are added to the end of the union. To change the order of a
member, in the Outline view select the member and drag it to the desired
position within the union. Note that all union members that are existing simple
types must occur ahead of all members that are local restrictions, lists and
unions, so reordering is subject to this rule.

For further information on configuring message model objects see
[message model objects” on page 107

Adding a complex type
Before you start:

You must already have completed the following tasks:

* |“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

* [“Opening an existing message definition file” on page 93

To add a complex type to your message model:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click Types then click Add Complex Type on the
pop-up menu. A complex type is added and is assigned a default name.

4. Either type a new name for the complex type or press Enter to accept the
default.

You can now configure the complex type to your requirements. For further
information on configuring message model objects see [“Configuring message|
[model objects” on page 107

Adding a global group
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

+ |“Opening an existing message definition file” on page 93|




To add a global group to your message model:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click Groups then click Add Group on the pop-up
menu. A global group is added to your message model and is assigned a
default name.

4. Either type a new name for the global group or press Enter to accept the
default.

You can now configure the global group to your requirements. For further
information on configuring the properties of message model objects see
[‘Configuring message model objects” on page 107

Adding a local group
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

* |“Opening an existing message definition file” on page 93|

You can add a local group to a message, complex type, group, or complex element.
This task assumes that you have previously added the relevant message, complex
type, group, or complex element to your message model.

To add a local group to a message, complex type, group, or complex element:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click the object (message, complex type, group, or
complex element) to which you are adding the local group then click Add
Local Group on the pop-up menu. A local group is immediately added to the
message model with type composition set to sequence by default.

You can now configure the local group to your requirements. For further
information on configuring message model objects see [“Configuring message
[model objects” on page 107

Adding an attribute group
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93|

To add an attribute group to your message model:
1. Switch to the Broker Application Development perspective.
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2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click Groups then click Add Attribute Group on the
pop-up menu. A global attribute group is added to your message model and is
assigned a default name.

4. Either type a new name for the attribute group or press Enter to accept the
default.

You can now configure the attribute group to your requirements. For further
information on configuring the properties of message model objects see
[“Configuring message model objects” on page 107

Adding a group reference

Before you start:

You must have completed the following tasks:

+ |“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ ["Opening an existing message definition file” on page 93]

You can add a group reference to a message, complex type, group, or complex
element. This task assumes that you have previously added the relevant message,
complex type, group, or complex element to your message model.

To add a group reference to a message, complex type, group or complex element:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right click the object (message, complex type, group, or
complex element) to which you want to add a group reference then click Add
Group Reference on the pop-up menu. A group reference is immediately
added to your message model.

You can now configure the group reference to your requirements. For further
information on configuring the properties of message model objects see
[‘Configuring message model objects” on page 107

Adding an attribute group
Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

* [“Opening an existing message definition file” on page 93

To add an attribute group to your message model:
1. Switch to the Broker Application Development perspective.



2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click Groups then click Add Attribute Group on the
pop-up menu. An attribute group is added to your message model and is
assigned a default name.

4. Either type a new name for the attribute group reference or press Enter to
accept the default.

You can now configure the attribute group to your requirements using the Message
Definition editor. For further information on configuring the properties of message
model objects see [“Configuring message model objects.”|

Configuring message model objects

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ |“Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

Before starting any of the tasks in this topic area, you must first open the message
definition file for which you want to configure message model objects in the
Message Definition editor. See [“Opening an existing message definition file” on|

for further details.

This topic area describes the tasks that are involved in configuring message model
objects:

* [“Renaming objects” on page 108|

+ [“Reordering objects” on page 108|

+ [“Copying objects” on page 109

* |“Pasting objects” on page 109|

+ [“Changing the type of an element or attribute” on page 110|

[“Setting value constraints” on page 112|

[‘Configuring logical properties: Message model objects” on page 114|

+ [“Configuring documentation properties: Message model objects” on page 115

+ |[“Configuring physical properties” on page 116|

- [“Configuring Custom Wire Format (CWF) properties: Message model objects”]

on page 11§|

- [“Configuring XML Wire Format properties: Message model objects” on page|
118

— [“Configuring TDS properties: Message model objects” on page 11
guring

— |“Applying default physical format settings: Message model objects” on page]
119

* [“Deleting objects” on page 120|
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Renaming objects

Before you start:

You must have completed the following tasks:

+ |“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93

+ “Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

Objects in the workbench such as files, messages and elements can have different
physical representations. Eclipse handles renaming differently depending on the
object.

Tip: Not all objects can be renamed. For example, you cannot rename wildcards,
local groups, or local types, because they do not have a name.

If an object can be renamed the usual way to do it is as follows:
1. Switch to the Broker Application Development perspective.

2. In the Outline view, right-click the object that you want to rename then click
Rename on the pop-up menu. Alternatively, right-click the object in the
Message Definition editor Overview tab then click Rename on the pop-up
menu. In both cases, depending on the object, either a renaming dialog opens
or you will now be able to edit the name of the object directly.

3. Type the new name for the object.

4. If the renaming dialog is open, either press Enter or click OK.
Reordering objects
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* |“Creating a message definition file” on page 94|

+ “Opening an existing message definition file” on page 93|

+ |“Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

To reorder objects within a message definition file:

1. Switch to the Broker Application Development perspective.

2. Click the object that you want to move. For example, you could select a local
element within a message in either the Outline view or Properties Hierarchy.

3. Use the mouse to drag the object to its new location.

Tip: As you drag the object and the mouse cursor passes between objects, a
black line appears, showing where the current focus is. If you try to drag
the object to a location that it cannot be moved to (including objects that
are highlighted as the cursor passes over them), the object remains in its
original position when you release it.



Copying objects
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93]

+ “Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

You can copy an object within a message definition file, such as a message for a
local element object, or types for a complex type object. To copy an object:

1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective. If the Outline view is not visible, from the workbench menu click
Window> Show View> Outline.

3. In the Outline view, right-click the message model object that you want to copy
then click Copy on the pop-up menu. Alternatively, right-click the object in the
Message Definition editor Overview tab then click Copy on the pop-up menu.

The object is now copied.

Pasting objects

Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83

+ [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93|

[“Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

+ [“Copying objects”]

You can paste objects that you have previously copied within the same message
definition file.

You can only copy and paste an object within the same message definition. You
cannot copy an object and paste it into another message definition, either within
the same message set or in a different message set.

To paste an object in the message definition from which you copied it:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, right-click the location where you are going to paste the
object then click Paste on the pop-up menu. Alternatively, right-click the object
in the Message Definition editor Overview tab then click Paste on the pop-up
menu. The object appears in the new location with a default name which you
can change if you want to.
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4. Either type a new name for the object or press Enter to accept the default.

Note: When you copy and paste objects within the message set, where physical
properties exist for that object, these settings are not pasted, but are set to
default values.

Tip: If you cannot select Paste from either menu, this indicates that you are
attempting to paste the object into a location that is not valid; for example, if
you try to paste a complex type into a local element.

Changing the type of an element or attribute
You can change the type to a local element, global element, local attribute, or
global attribute.

Before you start:

You must already completed the following tasks:

* |“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93

+ [“Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

You can change the type of an element or attribute in your message model to
another existing type, or you can create a new simple type or a new complex type.

To change the type of an element or attribute to an existing type:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, click the element for which you want to change the type.

4. Display the Properties tab of the Message Definition editor by clicking
Properties in the bottom left corner of the editor area.

5. In the Properties Hierarchy click Logical Properties > Global Element ( or
Logical Properties > Local Element, Logical Properties > Global Attribute, or
Logical Properties > Local Attribute). If necessary, expand Logical Properties
by clicking +.

6. In the Details view, in the Type property, click the new type that you require.

Tip: If the type you require is not displayed, you can find it by clicking
(More...) in the list. This displays the Type Selection window with
additional options. If you know which type you require, specify the first
letter in the text box at the top of the Type Selection window. Matching
types are then displayed, making the selection process easier.

7. When you have selected the type that you require, click OK.
The change to the type is applied wherever the element or attribute occurs.

The task above explains how to switch to an existing type. If you want to create a
new simple type or a new complex type, select (New Simple Type Restriction),
(New Simple Type List), (New Simple Type Union), or (New Complex Type) in
the Type list (see step 6 above). For information on how to create a new simple



type or a new complex type see|“Adding a simple type to an element or attribute”|
or [“Adding a complex type to an element.”|

Adding a simple type to an element or attribute:

You can add a simple type to a local element, global element, local attribute, or
global attribute.

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93|

This task assumes that you have previously added the relevant element or attribute
to your message model.

To add a new simple type:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, click the element to which you want to add a new simple
type.

4. In the Message Definition editor, click the Properties tab.

5. In the Properties Hierarchy, click Logical Properties > Global Element ( or
Logical Properties > Local ElementLogical Properties > Global Attribute, or
Logical Properties > Local Attribute).

6. In the Details view, in the Type property, select (New Simple Type
Restriction), (New Simple Type List), or (New Simple Type Union) to open
the relevant New Simple Type window to create a simple type of the type that
you specify.

7. In the New Simple Type window, in the Base Type list, click the type that you
want to use.

8. Optional: If you want to add the new simple type as a global simple type,
select the Create as Global Simple Type check box and specify the name for
your new simple type in the Name field.

9. Click OK. A simple type is immediately added to your message model.

Any changes that you make are reflected throughout where the element to which
you have added a new simple type occurs.

Adding a complex type to an element:

You can add a complex type to a local element, global element, local attribute, or
global attribute.

Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83

+ [“Creating a message definition file” on page 94|
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+ “Opening an existing message definition file” on page 93|

This task assumes that you have previously added the relevant element or attribute
to your message model.

When you add a complex type to an element or attribute, you can either create a
new complex type or derive a new complex type from an existing base type.

To add a new complex type:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, click the element to which you want to add a new
complex type.

4. In the Message Definition editor, click the Properties tab.

5. In the Properties Hierarchy, click Logical Properties > Global Element ( or
Logical Properties > Local ElementLogical Properties > Global Attribute, or
Logical Properties > Local Attribute).

6. In the Details view, in the Type list, click (New Complex Type) to display the
New Complex Type window.

7. If you want to create a new local complex type, click Create a Local Complex
Type then, in the Composition list, click the option that you require.

8. If you want to derive a new local complex type from an existing base type:
a. Click Derive a new Local Complex Type from existing base type.

b. In the Base Type list, click the base type that you want to use. Depending
on the base type you select, the Composition and Derived By lists might
become active.

c. If the Composition and Derived By lists are active, click the options that
you require in both lists.

9. If you want to add the new complex type as a global complex type, select the
Create as Global Complex Type check box, and specify a name for your new
complex type in the Name field.

10. Click OK to close the New Complex Type window and add the new complex
type to your message model.

Any changes that you make are reflected throughout where the element to which
you are adding the complex type occurs.

Setting value constraints

Before you start:

You must have completed the following tasks:

* |“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

+ “Opening an existing message definition file” on page 93|

+ |“Adding a simple type” on page 102| or [’Adding a simple type to an element o1
attribute” on page 111| (You must have added one or more global or local simple
types to your message model)




Value constraints are usually associated with a simple type; they refine a simple
type by defining limits on the values which the simple type can represent. To set
the value constraints associated with a simple type:

1. Switch to the Broker Application Development perspective.

2. In the Outline view, click the simple type you are updating. If the Outline view
is not visible, from the workbench menu, click Window> Show View> Outline.

3. Display the Properties tab of the Message Definition Editor by clicking
Properties in the bottom left corner of the editor area. The Properties Hierarchy
displays the following nodes:

* Logical Properties
* Physical Properties
* Documentation

4. In the Properties Hierarchy under Logical Properties click Value Constraints.
This displays the current value constraints settings for the selected simple type
in the Details pane.

Tip: If Value Constraints is not in view, expand Logical Properties by clicking
+.

5. Set the value constraints for the selected simple type by making the appropriate
changes to the information shown in the Details pane.

Setting an enumeration:

An enumeration restricts which values can be set for the value constraint. For
example, "ABC" and "123". Use this section to create a list of fixed values that the
associated type must match.

To set an enumeration:

1. Click Add to the right of the Enumerations field. This adds an enumeration
that has a default enumeration (for example enumerationl).

2. Type the data that you want to set for this value constraint.
3. Press Enter on your keyboard.

4. Repeat the above steps for each enumeration that you are adding.
Setting a pattern:
Set a pattern to indicate that the value constraint defines a string used as a regular

expression that must be matched by the data in the associated type. The regular
expression syntax supported is XML Schema regular expressions.

See|“Regular expression syntax” on page 761|for a list of supported regular
expression syntax elements.

To set a pattern:

1. Select Add to the right of the Patterns field. This adds a pattern that has a
default pattern (for example patternl) and is in update mode.

2. Type the data that you want to set for this value constraint.
3. Press Enter on your keyboard.
4. Repeat the above steps for each pattern that you are adding.
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Configuring logical properties: Message model objects

Before you start:

You must have completed the following tasks:

+ |“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93

+ “Adding message model objects” on page 96| (You must have added one or more

objects to your message model)

To configure the logical properties of an object that is part of the message model:

1.
2.

Switch to the Broker Application Development perspective.

Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench and is displaying the following information:

* The name of the message definition file
* Messages

¢ Types

* Groups

 Elements and Attributes

If the Outline view is not visible, from the workbench menu, click Window>
Show View> Outline. If the information listed above is not displayed, ensure
that the message definition file is open in the Message Definition editor.
Message definition files have an .mxsd file extension.

In the Outline view, select the message model object for which you want to

configure the logical properties:

a. Depending on the type of the object that you are selecting, expand
Messages, Types, Groups or Elements and Attributes as appropriate by
clicking +.

b. Click the object that you want to select within the expanded node.

Display the Properties tab of the Message Definition editor by clicking

Properties in the bottom left corner of the editor area. The Properties Hierarchy

displays the following nodes:

* Logical Properties

* Physical Properties

¢ Documentation

The type (for example, Local Element or Global Element) of the message model

object that you selected in the Outline view is displayed under each of these

nodes.

If the items under Logical Properties are not in view, expand Logical

Properties by clicking +.

Display the logical properties of the selected object in the Details view of the

Message Definition editor, by clicking the appropriate item under Logical

Properties.

Configure the logical properties of the selected item to your requirements by

making the appropriate changes to the information shown in the Details view.

Save your changes by clicking File> Save message_definition_file.mxsd or by
pressing Ctrl+S. Alternatively click File> Save All or press Ctrl+Shift+S.



Configuring documentation properties: Message model objects

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93]

+ “Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

To configure the documentation properties of an object contained within a message
definition file:

1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench and is displaying the following information:

* The name of the message definition file
* Messages

e Types

* Groups

* Elements and Attributes

If the Outline view is not visible, from the workbench menu, click Window>
Show View> Outline. If the information listed above is not displayed, ensure
that the message definition file is open in the Message Definition editor.
Message definition files have an .mxsd file extension.

3. In the Outline view, select the message model object for which you want to
configure the documentation properties by doing the following:

a. Depending on the type of the object that you are selecting, expand
Messages, Types, Groups or Elements and Attributes as appropriate by
clicking +.

b. Click the object you want to select within the expanded node.

4. Display the Properties tab of the Message Definition editor by clicking
Properties in the bottom left corner of the editor area. The Properties Hierarchy
displays the following nodes:

* Logical Properties

* Physical Properties

¢ Documentation

The type (for example, Local Element or Global Element) of the message model

object that you selected in the Outline view is displayed under each of these
nodes.

Tip: If the items under Documentation are not in view, expand
Documentation by clicking +.

5. Display the logical properties of the selected object in the Details view by
clicking the appropriate item under Documentation.

6. Configure the documentation properties of the selected item to your
requirements by typing text into the Documentation text field. Right-clicking in
the text field allows you to select options for undoing changes you have made,
cutting or copying text from the text field, pasting text into the text field,
deleting highlighted text or selecting all text in the field.
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7. Save your changes by clicking File> Save message_definition_file.mxsd from
the menu or pressing Ctrl+S. Alternatively, from the menu, click File > Save
All or press Ctrl+Shift+S.

Configuring physical properties

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* |“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93]

* [“Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

The tasks in this topic area assume that you have added one or more physical
formats to a message set. For further information see [“Adding a Custom Wire|

Format (CWF)” on page 86| or|[’Adding an XML wire format” on page 89| or

“Adding a TDS physical format” on page 87

When you have added objects to your message model it is likely that you will
want to configure the physical properties of these objects. The following tasks
relate to configuring the physical properties of message model objects:

* |“Configuring Custom Wire Format (CWF) properties: Message model objects”|

+ [“Configuring XML Wire Format properties: Message model objects” on page 118§|

+ [“Configuring TDS properties: Message model objects” on page 117]

* |“Applying default physical format settings: Message model objects” on page 119|

Configuring Custom Wire Format (CWF) properties: Message model objects:
Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93]
+ [“Adding a Custom Wire Format (CWF)” on page 86|

+ |“Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

To configure the CWF properties of a message model object:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench and is displaying the following information:

¢ The name of the message definition file
* Messages

* Types

* Groups

* Elements and Attributes

If the Outline view is not visible, from the workbench menu, click Window>
Show View> Outline. If the above hierarchy is not displayed, ensure that the



message definition file is open in the Message Definition editor. Message
definition files have an .mxsd file extension.

In the Outline view, select the object for which you want to configure the CWF
properties by doing the following.

a. Depending on the type of the object that you are selecting, expand
Messages, Types, Groups or Elements and Attributes by clicking +.

b. Click the object you that want to select within the expanded node.

Display the Properties tab of the Message Definition editor by clicking
Properties in the bottom left corner of the editor area. In the Message
Definition editor, in the Properties Hierarchy, the name of each of the physical
formats that have been added to the message set appears under Physical
Properties. The object type (for example, Local Element or Global Element) of
the message model object that you selected in the Outline view is displayed
under each physical format shown.

Tip: If the physical formats are not in view in the Properties Hierarchy, expand
Physical Properties by clicking +. By default the CWF physical format is
called Binaryl but could have a user defined name instead.

Under Physical Properties, click the object type for the message model object
that you have chosen to configure under the CWF physical format. The CWF
properties of your selected message model object appear in the Details view.

Configure the CWF properties of the selected object to your requirements by
making the appropriate changes to the information shown in the Details view.

Note: It is not possible to configure disabled fields.

Save your changes by clicking File> Save message_definition_file.mxsd or
pressing Ctrl+S. Alternatively click File> Save All or press Ctrl+Shift+S.

Configuring TDS properties: Message model objects:

Before you start:

You must have completed the following tasks:

[‘Creating a message set” on page 83|

[‘Creating a message definition file” on page 94|

[“Opening an existing message definition file” on page 93|

[“Adding a TDS physical format” on page 87|

[‘Adding message model objects” on page 96| (Adding one or more objects to
your message model)

To configure the TDS properties of a message model object:

1.

Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development

perspective of the workbench and is displaying the following information:
¢ The name of the message definition file

* Messages

¢ Types

* Groups

* Elements and Attributes

If the Outline view is not visible, from the workbench menu, click Window>
Show View> Outline. If the above hierarchy is not displayed, ensure that the
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message definition file is open in the Message Definition editor. Message
definition files have an .mxsd file extension.

In the Outline view, select the object for which you want to configure the TDS
properties by doing the following:

a. Depending on the type of the object that you are selecting, expand
Messages, Types, Groups or Elements and Attributes by clicking +.

b. Click the object that you want to select within the expanded node.

Display the Properties tab of the Message Definition editor by clicking
Properties in the bottom left corner of the editor area. In the Message
Definition editor, in the Properties Hierarchy, the name of each of the physical
formats that have been added to the message set appears under Physical
Properties. The object type (for example, Local Element or Global Element) of
the message model object that you selected in the Outline view is displayed
under each physical format shown.

Tip: If the physical formats are not in view in the Properties Hierarchy, expand
Physical Properties by clicking +. By default the TDS physical format is
called Textl but could have a user defined name instead.

Select the Properties tab located in the bottom left corner of the Message
Definition editor.

Under Physical Properties, under the TDS physical format, click the object type
for the message model object that you have chosen to configure. The TDS
physical format properties of your selected message model object appear in the
Details view.

Configure the TDS physical format properties of the selected object to your
requirements by making the appropriate changes to the information shown in
the Details view.

Note: It is not possible to configure disabled fields.

Save your changes by selecting File> Save message_definition_file.mxsd from
the menu or press Ctrl+S. Alternatively, from the menu, select File > Save All,
or press Ctrl+Shift+S.

Configuring XML Wire Format properties: Message model objects:

Before you start:

You must have completed the following tasks:

[‘Creating a message set” on page 83|

[‘Creating a message definition file” on page 94|

[“Opening an existing message definition file” on page 93|

[“Adding an XML wire format” on page 89|

[“Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

To configure the XML Wire Format properties of a message model object:

1.

Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
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perspective of the workbench and is displaying the following information:
¢ The name of the message definition file

* Messages

* Types



* Groups
¢ Elements and Attributes

If the Outline view is not visible, from the workbench menu, click Window>
Show View> Outline. If the above hierarchy is not displayed, ensure that the
message definition file is open in the Message Definition Editor. Message
definition files have an .mxsd file extension.

3. In the Outline view, select the object for which you want to configure the XML
Wire Format properties by doing the following;:

a. Depending on the type of the object that you are selecting, expand
Messages, Types, Groups or Elements and Attributes by clicking +.

b. Click the object that you want to select within the expanded node.

4. Display the Properties tab of the Message Definition editor by clicking
Properties in the bottom left corner of the editor area. In the Message
Definition editor, in the Properties Hierarchy, the name of each of the physical
formats that have been added to the message set appears under Physical
Properties. The object type (for example, Local Element or Global Element) of
the message model object that you selected in the Outline view is displayed
under each physical format shown.

Tip: If the physical formats are not in view in the Properties Hierarchy, expand
Physical Properties by clicking +. By default the XML Wire Format is
called XML1 but could have a user defined name instead.

5. Under Physical Properties, under the XML Wire Format, click the object type
for the message model object that you have chosen to configure. The XML Wire
Format properties of your selected message model object appear in the Details
view of the Message Definition editor.

6. Configure the XML Wire Format properties of the selected object to your
requirements by making the appropriate changes to the information shown in
the Details view.

Note: It is not possible to configure disabled fields.

7. Save your changes by clicking File> Save message_definition_file.mxsd or
pressing Ctrl+S. Alternatively select File> Save All from the menu or press
Ctrl+Shift+S.

Applying default physical format settings: Message model objects:

Before you start:

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93|

+ |“Adding message model objects” on page 96| (You must have added one or more
objects to your message model)

This task assumes that you have added one or more physical formats to the
relevant message set. For further information see [“Adding a Custom Wire Format]
(CWF)” on page 86| or|“Adding an XML wire format” on page 89 or[“Adding a
TDS physical format” on page 87

To apply the default physical format setting to a message model object previously
added to a message definition file:
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. Switch to the Broker Application Development perspective.

In the Outline view, click the object to which you want to apply default
physical format settings.

Click the Properties tab located in the bottom left corner of the Message
Definition editor.

Check that the Message Definition editor Properties Hierarchy displays the
following information:

* Logical Properties

* Physical Properties (For each of the physical formats that have been added to
the message set, the name of the physical format appears under Physical
Properties. Under each physical format the type of message model object
that you selected is displayed as a child.)

* Documentation

Ensure that Physical Properties in the Properties Hierarchy is fully expanded
by clicking +.

Right click on the message model object type underneath the physical format to
which you want to apply the default settings then click Apply default physical
format settings. The default physical format settings for the message model
object that you selected are applied without warning.

Save your changes by clicking File> Save message_definition_file.mxsd from
the menu or pressing Ctrl+S. Alternatively, from the menu, click File > Save
All, or press Ctrl+Shift+S.

Deleting objects
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Before you start:

You must have completed the following tasks:

* |“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

+ “Opening an existing message definition file” on page 93|

+ |“Adding message model objects” on page 96| (You must have added one or more

objects to your message model)

To remove objects contained within a message definition file:

1.

Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development

perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

In the Outline view, right-click the object that you wish to remove then click
Delete on the pop-up menu. Alternatively right-click the object in the Message
Definition editor Overview tab then click Delete on the pop-up menu.

The type of object and the relationship that it has with other objects determines
whether the object is now deleted without a confirmation window appearing,
or whether a confirmation window opens with a list of all the objects that will
be deleted along with the one that you have selected.

If a confirmation window opens, click OK to delete the objects.

Tip: You can undo a deletion by selecting Edit> Undo, as long as you have not
saved the changes that you have made.



Creating a multipart message

Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83

+ [“Creating a message definition file” on page 94|

+ [“Opening an existing message definition file” on page 93|

A multipart message occurs when you embed a message within another message.
To create a multipart (embedded) message:

1.
2.

Switch to the Broker Application Development perspective.

Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

In the Outline view, add one of the following objects to your message model:

* A complex type (for further information on completing this task see
[a complex type” on page 104)

* A global group (for further information on completing this task see
la global group” on page 104)

* Alocal group (for further information on completing this task see
[local group” on page 105)

Tip: You can also use a local ANONYMOUS complex type when creating a
multipart message. For further information see [“Adding a complex type to]
fan element” on page 111]

Display the Properties tab of the Message Definition editor by clicking

Properties in the bottom left corner of the editor area.

In the Properties Hierarchy, under Logical properties, click one of the
following, depending on which of these you added in step 3:

¢ Complex Type

* Global Group

* Local Group

In the Details view, make the following changes to the displayed logical
properties:

a. In the Composition drop-down list, click message.

b. In the Content validation drop-down list, click Open, Closed or Open
Defined, depending on your requirements. Note that if the embedded

message is defined in a different message set, then you must click Open.
For further information about using these three options see ["MRM content

fvalidation” on page 191

Note: There are a number of different ways for the parser to identify an embedded

message within a message bit stream. For further information on identifying
a message within another message see the concept topics listed below.
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Linking from one message definition file to another

Before you start:

You must have completed the following tasks:

* |“Creating a message set” on page 83|

+ [“Creating a message definition file” on page 94|

+ “Opening an existing message definition file” on page 93|

There are two ways to link one message definition file to another: either you can
add an “include’, or you can add an ‘import’, for the file that you want to
reference.

When you are working with a message definition file, you can check which other
message definition files this file currently includes or imports by carrying out the
steps listed below:

1. Open the message definition file in the Message Definition editor.

2. In the Outline view, in the displayed hierarchy, select the .mxsd file.

3. In the Properties Hierarchy, expand Imports or Includes as appropriate to

display a list of the other files that the currently selected file includes or
imports.

Include
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You use the include option if you want to link to a message definition file with the
same namespace, or if you want to link to a message definition file with no target
namespace from a message definition file with a target namespace (chameleon
behavior). You must also choose to add an include rather than an import if you
want to link a message definition file with no target namespace to another message
definition file that also has no target namespace.

Note: A message definition file can only reference objects in another message
definition file if this other file has been included directly, so you might have
a problem if you try to use the include option to include message definition
files that are themselves included within other message definition files. For
information about ways of resolving this situation, see [Resolving problems|
fwhen developing message models|

This task assumes that you have opened an existing message definition file.

To add an include to a message definition file:
1. Switch to the Broker Application Development perspective.

2. Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

3. In the Outline view, click the message definition (.mxsd) file name.

4. Display the Properties tab of the Message Definition Editor by clicking
Properties in the bottom left corner of the editor area.

5. In the Properties Hierarchy, right-click Includes then click Add Include on the
pop-up menu. The “Select Message Definition file to include” window opens.



6.

Import

In the Message Sets pane, select the message definition file that you want to
include. If the message definition files within your project are not visible in this
pane, expand the project hierarchy by clicking +.

Click Finish. The message definition file that you selected in step 4 is included
within the message definition file that you opened before beginning this task.

You use the import option if you want to link a message definition file to another
message definition file in a different namespace. You cannot add an import from

the same namespace; this includes linking from a message definition file with no

target namespace to another message definition file with no target namespace.

To add an import to a message definition file:

1.
2.

Switch to the Broker Application Development perspective.

Ensure that the Outline view is visible in the Broker Application Development
perspective of the workbench. If the Outline view is not visible, from the
workbench menu, click Window > Show View> Outline.

In the Outline view, click the message definition (.mxsd) file name.
Display the Properties tab of the Message Definition editor by clicking
Properties in the bottom left corner of the editor area.

In the Properties Hierarchy, right-click Imports then click Add Import on the
pop-up menu. The “Select Message Definition file to import” window opens.

In the Message Sets pane, select the message definition file that you want to
import from the workspace. If the message definition files within your project
are not visible in this pane, expand the project hierarchy by clicking +.

Click Finish. The message definition file that you selected in step 4 is imported

into the schema of the message definition file that you opened before beginning
this task.

Working with a message category file

This topic area lists the tasks that are involved when working with a message
category file.

[‘Creating a message category file”|

[“Opening an existing message category file” on page 124

[“Adding a message to a message category” on page 125|

[‘Deleting a message from a message category” on page 126|

[“Viewing or configuring message category file properties” on page 126|

[‘Deleting a message category file” on page 126|

Creating a message category file

This topic describes how you would create a message category file.

Before you start:

You must have completed the following task:

[‘Creating a message set” on page 83|

To create a new message category file:

1.

Switch to the Broker Application Development perspective.
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2. Open the New Message Category File wizard by right-clicking in the Broker
Development view then clicking New> Message Category File on the pop-up
menu.

Tip: To preselect the message set when the wizard opens, either right-click the
message set to which you are adding the message category file, or select
the message set, before opening the wizard as just described.

3. In the first pane, select the Category Kind for the type of category that you are
creating.

¢ other. Indicates that this Message Category represents a generic grouping of

messages. The Category Usage field is disabled.

¢ wsdl. Indicates that this Message Category represents a WSDL operation. The
specified Category Name will become the WSDL operation name.

Note: This use of categories is only for compatibility with WebSphere
Message Broker Version 6.0.

4. If the Category Kind has been set to wsdl, specify the WSDL operation type by
selecting one of the following values for the Category Usage field:

* wsdl:request-response
* wsdl:solicit-response
* wsdl:one-way
* wsdlnotification
5. Click Next. In the Message Set Folder field, select a folder under the target

message set for the new message category file to be saved. The message set
folder view is filtered to only show artifacts in the active working set.

6. In the File name field, type a name for the new message category file (It will
automatically be given the file extension of .category).

7. Click Next. Select any messages that you want to add to the new category. Use
Shift-click to select a range of messages and Ctrl-click to select or deselect
individual messages. You cannot complete the creation of the category file
without adding one or more messages and setting the Role Type and Role
Usage values of each message correctly.

8. Click Finish. A message category file is created within the message set folder
that you selected, with the name that you specified and a file extension of
.category.

The new message category file opens in the Message Category editor so that you
can view and edit it as required.

Opening an existing message category file
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This describes how to open an existing message category file in the Message
Category editor so that you can view or edit it.

Before you start:

To complete this task, you must have completed the following task:

+ |“Creating a message category file” on page 123|

To open an existing message category file:
1. Switch to the Broker Application Development perspective.



2. In the Broker Development view, right-click the message category file (with a
file extension of .category) that you want to open, then click Open on the
pop-up menu. This opens the message category file that you have selected in
the Message Category editor.

3. View and edit the message category file as required.
Tip: The Eclipse framework lets you open resource files with other editors. You are
advised to only use the workbench Message Category editor to work with the

message category files because this editor correctly validates changes made to
the files. Other editors might not do this.

Adding a message to a message category

Before you start:

You must have completed the following tasks:

+ [“Creating a message category file” on page 123|

* [“Opening an existing message category file” on page 124|

Important: This topic assumes that you have already added one or more messages
to your message model.

To add a message to a message category file:

1. Switch to the Message Category editor, in the Broker Application Development
perspective.

2. In the Properties Hierarchy, open the Add Messages window by right-clicking
Message Category and then clicking Add Messages on the pop-up menu. The
Add Messages window lists all the messages that are available for adding to
the message category file. Any message that is in the message set but has not
already been added to the category is displayed.

3. Select the message or messages that you would like to add. Use Shift-click to
select a range of messages and Ctrl-click to select or deselect individual
messages.

4. Click OK. The selected message or messages are added to the message category
and now appear in the Properties Hierarchy.

Tip: Until you save the message category file, you can undo any additions that
you make. To undo a change, right-click Message Category in the
Properties Hierarchy then click Undo on the pop-up menu. If you have
added multiple messages, this removes all the messages that you have
added. If you want to remove a single message, right click this message
then click Undo. To redo an addition after undoing it, use the Redo
option.

5. Save and validate the additions that you have made to the message category
file by clicking File> Save or pressing Ctrl+S.

Note: When you have saved the message category file after adding a message, you
can no longer undo the addition of this message using the Undo option. To
remove a message after saving your changes, you can do so by deleting the
message from the message category file.

When you have added a message to a message category file, you can configure its
properties according to your requirements in the Message Category editor Details
view.
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Deleting a message from a message category
Before you start:

To complete this task, you must have completed the following tasks:

* |“Creating a message category file” on page 123|

+ [“Opening an existing message category file” on page 124|

+ |“Adding a message to a message category” on page 125

To delete a message from a message category file:
1. Switch to the Broker Application Development perspective.

2. In the Message Category editor, in the Properties Hierarchy, right-click the
message that you want to delete, then click Delete on the pop-up menu.

Tip: The message is deleted from the message category file immediately,
without a warning appearing first.

Viewing or configuring message category file properties

This topic describes how to view or configure the properties of a message category
file and associated messages using the Message Category editor.

Before you start:

To complete this task, you must have completed the following tasks:

+ [“Creating a message category file” on page 123|

* [“Opening an existing message category file” on page 124|

* |[“Adding a message to a message category” on page 125|(You must have added
one or more messages to your message category file)

To configure the properties of a message category file:

1. Switch to the Message Category editor in the Broker Application Development
perspective.

2. To view or configure the properties of a message category, click Message
Category in the Properties Hierarchy. From the Details section of the Message
Category editor you can now view the properties of the message category and
make any changes to the properties that are necessary.

3. To view or configure the properties of a message in the message category file,
click the name of the message in the Properties Hierarchy. From the Details
section of the Message Category editor you can now view the properties of the
message and make any changes to the properties that are necessary.

4. If you have changed any of the properties in the message category or messages,
you can save those changes by selecting File » Save from the menu.

Note: Note that some combinations of Message Category Usage, Role Type and

Role Usage are not valid for WSDL and will result in task list errors being
generated.

Deleting a message category file
Before you start:

To complete this task, you must have completed the following task:
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+ |“Creating a message category file” on page 123|

To delete a message category file:
1. Switch to the Broker Application Development perspective.

2. In the Broker Development view, right-click the message category file
(x.category file extension) that you want to delete, then click Delete on the
pop-up menu. Alternatively select the message category file in the Broker
Development view and then either click Edit> Delete, or press the Delete key
on your keyboard.

3. On the Confirm Resource Delete window, click Yes to delete the message
category file. Alternatively, to cancel the message category file deletion, either
click No or press the Esc key.

Tip: Once you have deleted a message category file, the action cannot be undone.

Importing data structures

This describes how to create a message definition file by importing from a number
of different data structures.

You can create a message definition file in a message set by importing from XML
Schema, XML DTD, IBM supplied messages, WSDL definitions, C header files, and
COBOL copybooks. This topic area describes how to import from these data
structures using the command line or the workbench.

Before you attempt to create a message definition from a data structure, using the
workbench, you advised to read [“Importing file systems into the workbench.”|

The following tasks topics relate to importing using the workbench:

* [“Importing from C” on page 129

* [“Importing from COBOL copybooks” on page 131

* [“Importing from IBM supplied messages” on page 133|

+ [“Importing from WSDL” on page 134|
* [“Importing from XML DTD” on page 136|
+ [“Importing from XML Schema” on page 13§|

The following tasks relate to importing using the command line:

* [“Importing from the command line” on page 130| for C header files, COBOL
Copybooks, XML DTDs and XML Schemas.

* |“Importing WSDL definitions from the command line” on page 135

Importing file systems into the workbench

Before the workbench can use files to create a message definition that is based on a
WSDL definition, XML Schema, XML DTD, C header file, or COBOL copybook, the
files must be imported or copied into the workbench’s file structure. This topic
explains the three ways in which you can do this:

* [“Using the Import wizard” on page 128|

+ ["“Dragging and dropping” on page 129

+ [“Copying and pasting” on page 129|
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Use any of these import methods to ensure that a file is available for use by your
selected message set project. You can then select the imported file in the New
Message Definition File wizard to create a message definition that is based on this

file.

Using the Import wizard

Use the Import wizard to import all the files, or a selection of files, from the
specified source.

To import files using the Import wizard:

1.
2.

Switch to the Broker Application Development perspective.

In the Broker Development view, click the project folder into which you are
going to import the files.

Open the Import wizard by clicking File » Import on the workbench menu.

On the Select page of the Import wizard, click either File System or Zip file,
depending on the type of resource that you are importing.

Click Next.

On the File System page, in the Directory field, specify the import source.
Either type the source name in the field, or click Browse and select the parent
directory, or compressed file that contains the file or files that you want to
import; then click OK (directory) or Open (compressed file).

Tip: Directories from which you have recently imported files, are shown in
the drop-down list in the Directory field.

Using the left and right panes that appear under the Directory field, specify
the folders or files, or both, that you want to import. Note the following
points when you are making your selections:

* To import the entire contents of a folder into the workbench, select the
check box for this folder in the left pane. To view any secondary folders
within a folder, expand the folder by clicking the plus sign (+).

* To import a specific file or files within a folder, use the right pane to select
the individual files that you want to import. If you select a file or files in
the right pane, the check box for the folder containing these files is greyed
in the left pane to indicate that only some of the files in the folder will be
imported into the workbench.

¢ To restrict the type of files that you are importing, click Filter Types and
then, on the Select Types window, select the check boxes for the file types
that you want to include, and click OK. If you want to include files with
extensions that are not shown in the list, type these extensions in the Other
Extensions field.

* To select all the folders and files that are shown on the File System page,
click Select All.

* To deselect all the folders and files that are currently selected on the File
System page, click Deselect All.

Note: The Select the destination for imported resources field should already
be filled in with the name of the project folder that you selected in step
2.

Optional: To change the destination project or folder, click Browse to open the
Folder Selection window. Select an alternative project folder by clicking the
folder then clicking OK.



9. Optional: To overwrite existing resources and not have a warning displayed,
select the Overwrite existing resources without warning check box. This
check box applies to both compressed files and file systems.

10. File system import only: Select one of the following options, depending on the
folder structure that you want to create:

* Create complete folder structure
* Create selected folders only
11. Click Finish.

The files that you selected are imported and are shown in the Broker Development
view under the project folder that you selected.

Dragging and dropping

You can use the drag-and-drop method to import files from your file system into
the workbench. Drag the resources that you are importing to the exact location in
the Broker Development view where you want the resources to be. Do not drag
them onto a blank area in the Broker Development view.

To import files by dragging and dropping;:
1. In your file system, locate the file or folder that you want to import into the
workbench.

2. Drag the file or folder to a specific location in the Broker Development view.
When you are dragging resources into the Broker Development view, the
project or folder into which you are trying to drop the resource is selected.

3. Ensure that the file or folder is copied into the workbench.
Copying and pasting

You can use your operating system’s copy and paste function as a method of
importing a file system into the workbench.

To import files by copying and pasting:
1. Locate the file or directory that you want to import into the workbench.

2. Using your operating system’s copy and paste function, copy the file or
directory to your system’s clipboard.

3. Select the destination for the file or directory in the Broker Development view.

4. From the workbench menu, click Edit » Paste.

The files or directories are copied into the workbench and placed into the location
that you selected.

Importing from C

This topic describes how to create a new message definition from a C header file
using the New Message Definition File wizard in the workbench.

Before you start:

Complete the following tasks:

* [“Creating a message set” on page 83

+ “Importing file systems into the workbench” on page 127]

Be aware of the following points:
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* To create a new message definition file from a C header file, the header file must
already be present in the workbench, for example in your message set project.
This allows you to select the header file in the New Message Definition File
wizard.

* The wizard can import C header files with .h, .c and .css extensions. If your
source file has a different extension you must rename it before attempting to
import it.

¢ If the message set to which you are adding the new message definition file does
not have an Custom Wire Format (CWF) layer only the logical information
appears in the model. You can add the physical layer to the message set before
or after importing a C header file, but you should add the physical layer before
importing it to ensure that it is populated with settings from the C header file.

* You can import a C header file from the command line using
mgsicreatemsgdefs.

The following steps cover both creating a completely new message definition file
and overwriting the contents of an existing file.

To create a message definition file from a C header file:
1. Switch to the Broker Application Development perspective.

2. Open the New Message Definition File wizard by clicking File > New -
Message Definition File from the workbench menu. Alternatively, you can
open the wizard by right-clicking a C header file previously imported into the
workbench and clicking New » Message Definition File on the menu.

3. In the displayed list of options, click C header file then click Next.

4. Step through the remainder of the wizard filling in the details as required.

When you have completed importing the C header file using the wizard:

* Carefully check for any errors in the report that is created when the file is
imported. You can find this report in the log directory within the project
containing the message definition that you have attempted to create. The report
has a .c.report.txt file extension, prefixed with the name that you specified for
the new message definition file.

* Review the messages shown in the workbench task list to check whether any
new warnings or errors have appeared.

Importing from the command line

This describes how to use the command line importer mqsicreatemsgdefs to
import C, COBOL copybooks, XML DTD or XML Schema in order to populate a
message set with message definitions.

Before you start:

Before you attempt this task, you should read the following information:

* Imgsicreatemsgdefs command|

The command line importer allows you to create a new message set, into which
the message definition files will be placed. When you create a new message set
from the command line, only the logical information is created by default.
However, the command line importer allows you to create a new message set
based on an existing message set. The physical format information from the base
message set is also created in the new message set. If you want physical format
information to be created as well, you must do the following before you invoke the
mgqsicreatemsgdefs command:



1. Using the workbench, create a message set in your workspace that is to be used
as a base message set.

2. To this base message set, add the physical formats that you want to be created
in your new message set.

To import C, COBOL copybooks, XML DTD or XML Schema using the command

line:

1. Close the workbench. This must not be running when you use the command
line importer.

2. Invoke the mqsicreatemsgdefs command from a command prompt specifying
the message set project name, path name of the source files folder, and any
other optional parameters that you require. If you want to add physical formats
to the new message set that the mqsicreatemsgdefs command creates, specify
the base message set that contains these physical formats as the -base
parameter on the import command line.

3. When the command has completed, open mqsicreatemsgdefs.report.txt. This
report is created when you invoke the mqsicreatemsgdefs command and by
default is written to the directory from which you invoked the command. The
report provides you with the following information:

* Details of the parameters that were used when mqsicreatemsgdefs was
invoked.

* The message set level action.
¢ The name of the file or files that have been imported.

¢ Details of the import process (for example, any warnings that have been
generated and message model objects that have been created).

* The number of files imported.

4. Start the workbench and switch to the Broker Application Development
perspective. The message definition file that was created when you invoked
mgqsicreatemsgdefs is visible in the project that you specified.

If an error occurs during the import of a C, COBOL copybook, XML DTD, or XML
Schema file, carefully check any errors that the importer reports. By default, all
errors are written to the screen and to the log file described above. To gather
additional information about the import, specify the -v (Verbose) command line
parameter. This parameter displays more detailed information as the import
proceeds.

Importing from COBOL copybooks

This topic describes how to create a new message definition from a COBOL data
structure using the New Message Definition File wizard in the workbench.

Before you start:

Complete the following tasks:

* [“Creating a message set” on page 83

+ |“Importing file systems into the workbench” on page 127]

Be aware of the following points:

* To create a new message definition file from a COBOL data structure, the
COBOL file must already be present in the workbench, for example in your
message set project. This allows you to select the file in the New Message
Definition File wizard.
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* The wizard can import COBOL files with .cbl, .ccp, .cob and .cpy extensions. If
your source file has a different extension, you must rename it before attempting
to import it.

* If the message set to which you are adding the new message definition file does
not have an Custom Wire Format (CWF) layer, only the logical information
appears in the model. You can add the physical layer to the message set before
or after importing a COBOL data structure but you should add the physical
layer before you import the data structure to ensure that it is populated with
settings from the COBOL copybook.

* You can import a COBOL data structure from the command line using
mgsicreatemsgdefs.

The steps below cover creating a completely new message definition file and
overwriting the contents of an existing file.

To create a message definition file from a COBOL data structure:
1. Switch to the Broker Application Development perspective.

2. Open the New Message Definition File wizard by clicking File > New -
Message Definition File from the workbench menu. Alternatively, you can
open the wizard by right-clicking a COBOL copybook previously imported into
the workbench and clicking New » Message Definition File on the menu.

3. In the displayed list of options, click COBOL file then click Next.

4. Step through the remainder of the wizard filling in the details as required.

When you have completed importing the COBOL file using the wizard:

* Carefully check for any errors in the report that is created when the file is
imported. You can find this report in the log directory within the project
containing the message definition that you have attempted to create. The report
has a .cobol.report.txt file extension, prefixed with the name that you specified
for the new message definition file.

* Review the messages shown in the workbench task list to check whether any
new warnings or errors have appeared.

Importing from the command line

This describes how to use the command line importer mqsicreatemsgdefs to
import C, COBOL copybooks, XML DTD or XML Schema in order to populate a
message set with message definitions.

Before you start:

Before you attempt this task, you should read the following information:

+ Imgsicreatemsgdefs command|

The command line importer allows you to create a new message set, into which
the message definition files will be placed. When you create a new message set
from the command line, only the logical information is created by default.
However, the command line importer allows you to create a new message set
based on an existing message set. The physical format information from the base
message set is also created in the new message set. If you want physical format
information to be created as well, you must do the following before you invoke the
mgqsicreatemsgdefs command:

1. Using the workbench, create a message set in your workspace that is to be used
as a base message set.



2. To this base message set, add the physical formats that you want to be created
in your new message set.

To import C, COBOL copybooks, XML DTD or XML Schema using the command

line:

1. Close the workbench. This must not be running when you use the command
line importer.

2. Invoke the mgqsicreatemsgdefs command from a command prompt specifying
the message set project name, path name of the source files folder, and any
other optional parameters that you require. If you want to add physical formats
to the new message set that the mqsicreatemsgdefs command creates, specify
the base message set that contains these physical formats as the -base
parameter on the import command line.

3. When the command has completed, open mqsicreatemsgdefs.report.txt. This
report is created when you invoke the mqsicreatemsgdefs command and by
default is written to the directory from which you invoked the command. The
report provides you with the following information:

* Details of the parameters that were used when mgqsicreatemsgdefs was
invoked.

* The message set level action.
¢ The name of the file or files that have been imported.

¢ Details of the import process (for example, any warnings that have been
generated and message model objects that have been created).

* The number of files imported.

4. Start the workbench and switch to the Broker Application Development
perspective. The message definition file that was created when you invoked
mgsicreatemsgdefs is visible in the project that you specified.

If an error occurs during the import of a C, COBOL copybook, XML DTD, or XML
Schema file, carefully check any errors that the importer reports. By default, all
errors are written to the screen and to the log file described above. To gather
additional information about the import, specify the -v (Verbose) command line
parameter. This parameter displays more detailed information as the import
proceeds.

Importing from IBM supplied messages

You can create a new message definition file from an IBM supplied message.
Before you start:

You must have completed the following task:

+ [“Creating a message set” on page 83|

The following steps describe how to create a new message definition file, and how
to overwrite the contents of an existing file.

To create a message definition from an IBM supplied message:
1. Switch to the Broker Application Development perspective.

2. Open the New Message Definition File wizard by clicking File > New »
Message Definition File From on the workbench menu.

3. In the displayed list of options, select IBM supplied message and click Next.
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4. Complete the fields of the panel that is displayed by the wizard. See |”Ne@|
[message definition file wizard: IBM supplied message” on page 802

When you have finished the import of the IBM-supplied message:

* Carefully check for any errors in the report that is created when the file is
imported. You can find this report in the 1og directory within the project that
contains the message definition that you have created. The report has a
.xsd.report.txt file extension, prefixed with the name that you specified for the
new message definition file.

* Review the messages shown in the workbench task list to check whether any
new warnings or errors have appeared.

Importing from WSDL
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You can use the New Message Definition File wizard in the workbench to create a
new message definition from WSDL.

There are two methods for importing from WSDL.:

* Create a message set and use the New Message Definition File wizard. This
method is described here.

e Use the Start from WSDL and/or XSD files Quick Start wizard. See
[application based on WSDL or XSD files]

If you choose the first of these options, before you start you must have completed
the following tasks:

+ [“Creating a message set” on page 83|

+ [“Importing file systems into the workbench” on page 127]

The following steps are required to create a completely new message definition
file, or to overwrite the contents of an existing file.

To create a message definition from a WSDL file (or files):
1. Switch to the Broker Application Development perspective.

2. Open the New Message Definition File From ... wizard by clicking File> New>
Message Definition File From ... on the workbench menu.

3. In the displayed list of options, select WSDL file and click Next. Alternatively,
open the wizard by right-clicking a .wsd1 file that was previously imported
into the workbench and clicking New> Message Definition File From ... on the
menu.

4. Step through the remainder of the wizard filling in the details as required.

You must choose whether the WSDL file, or files, that you want to import are
in the current workspace in the workbench or are outside the workspace.

Check boxes provide options to:

* Copy the source file (or files) into a directory of the message set project. By
default, this check box is cleared.

¢ Add the SOAP and XMLNSC domains to your message set so that you can
use the SOAP nodes. By default, this check box is selected.

Note:

* The panels and options available in the wizard are dependant on the
settings that you select.



* Some fields in the wizard might not be available. This might be
because the field has a mandatory setting, or because the field has
only one possible value, or because the field is not being used as a
result of other settings that have been made.

When you have finished importing the WSDL file (or files) using the wizard:

¢ Check carefully for any errors in the report that is created when the file is
imported. You can find this report in the 1og directory within the project that
contains the message definition that you have tried to create. The report has a
<wsdl-file-name>.wsdl.report.txt file descriptor, where <wsdl-file-name> is the
name of the WSDL definition that you are importing.

* Review the messages that are shown in the workbench task list to check whether
any new warnings or errors have appeared.

Note: Any required SOAP Envelope and SOAP encoding message definitions are
automatically added to your message set during the import. If required, you
can also import these manually using the New Message Definition File
wizard by selecting the new option IBM supplied message.

Importing WSDL definitions from the command line
WSDL definitions can be imported using the (mgsicreatemsgdefsfromwsdl)
command.

Before you start:

Before you attempt this task, read the following information:

+ Imgsicreatemsgdefsfromwsdl command|

The WSDL command line importer allows you to create a new namespace enabled
message set into which the message definition files will be placed. It also allows
you to add message definition files to an existing message set that is namespace
enabled.

If you are adding new message definition files to an existing message set, the
message set must have an XML physical format layer. To improve web services
interoperability, avoid unnecessary customization of the XML physical format layer
for messages that participate in web services processes.

When you create a new message set from the command line, only the logical
information is created by default. If you require physical formats in the message
set you have two options:

¢ Create a new message set based on an existing message set. The physical format
information from the base message set is also created in the new message set.

* Use the workbench to create or open the message set and directly add the
physical formats to the message set prior to importing the WSDL definitions into
it.

Before starting the import, the mqsicreatemsgdefsfromwsdl command copies the
WSDL files that it needs into the workspace. These are the top level WSDL file and
any further files that might be imported by it. The files are copied under the
specified message set in a folder called importFiles and are not removed after the
import finishes. This allows you to update them, or run validation on them, in the
workbench at a later time.

To import WSDL definitions using the command line:
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1. Close the workbench. The workbench must not be running when you use the
command line importer.

2. Invoke the mgqsicreatemsgdefsfromwsdl command from a command prompt;
you must specify the message set project name, the path name of the directory
where the top level WSDL file is located, the name of that file, the location of
the workspace, and any other optional parameters that you require. If you want
to add physical formats to the new message set that the
mgqsicreatemsgdefsfromwsdl command creates, specify the base message set
that contains these physical formats as the -base parameter on the import
command line.

3. When the command has completed, check the log file. The name of the log file
is the name that you specified in the command, and it has the file extension
*.wsd1.report.txt. This report is created when you invoke the
mgqsicreatemsgdefsfromwsdl command and, by default, it is written to the
directory from which you invoked the command. The report provides you with
the following information:

* Details of the parameters that were used when mgqsicreatemsgdefsfromwsdl
was invoked.

¢ The name of the file that has been imported.

¢ Details of the import process (for example, any warnings that have been
generated and message model objects that have been created).

4. Start the workbench and switch to the Broker Application Development
perspective. The message definition file that was created by the
mgsicreatemsgdefsfromwsdl command is visible in the project that you
specified.

If an error occurs during the import of a WSDL definition, carefully check any
errors that are reported. By default, all errors are written both to the screen and to
the file described above. To gather additional information about the import, specify
the -v (Verbose) command line parameter. This parameter displays more detailed
information as the import proceeds.

Importing from XML DTD
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This describes how to create a new message definition from an XML DTD using
the New Message Definition File wizard in the workbench.

Before you start:

You must have completed the following tasks:

+ |“Creating a message set” on page 83|

+ [“Importing file systems into the workbench” on page 127]

Before you begin this task, you should be aware of the points listed below:

* To create a new message definition file from an XML DTD, the DTD file must
already be present in the workbench, for example in your message set project.
This allows you to select the DTD file in the New Message Definition File
wizard.

* If the message set to which you are adding the new message definition file does
not have an XML wire format (XML) layer only the logical information appears
in the model. You can add the physical layer to the message set before or after
importing from a XML DTD, but you should add the physical layer before
importing it to ensure that it is populated with settings from the XML DTD.



* It is also possible to import an XML DTD from the command line using
mgsicreatemsgdefs.

e The file extension must be .dtd in lower case.

The following steps cover both creating a completely new message definition file
and overwriting the contents of an existing file.

To create a message definition from an XML DTD:
1. Switch to the Broker Application Development perspective.

2. Open the New Message Definition File wizard by clicking File> New>
Message Definition File from the workbench menu.

3. In the displayed list of options, click XML DTD file to select it then click Next.
4. Step through the remainder of the wizard filling in the details as required.

When you have completed importing the XML DTD using the wizard:

¢ Carefully check for any errors in the report that is created when the file is
imported. You can find this report in the 1og directory within the project
containing the message definition that you have attempted to create. The report
has a .dtd.report.txt file extension, prefixed with the name that you specified
for the new message definition file.

* Review the messages shown in the workbench task list to check whether any
new warnings or errors have appeared.

The message definition file is created from the XML DTD and is opened in the
Message Definition editor so that you can check the imported information and
make any required changes. While you are checking the newly created message
definition file, review any messages that appear in the workbench task list to see

whether you need to make any corrections to resolve errors or warnings relating to

the new file.

Importing from the command line

This describes how to use the command line importer mqsicreatemsgdefs to
import C, COBOL copybooks, XML DTD or XML Schema in order to populate a
message set with message definitions.

Before you start:

Before you attempt this task, you should read the following information:

+ Imgsicreatemsgdefs command|

The command line importer allows you to create a new message set, into which
the message definition files will be placed. When you create a new message set
from the command line, only the logical information is created by default.
However, the command line importer allows you to create a new message set
based on an existing message set. The physical format information from the base
message set is also created in the new message set. If you want physical format

information to be created as well, you must do the following before you invoke the

mgsicreatemsgdefs command:

1. Using the workbench, create a message set in your workspace that is to be used

as a base message set.

2. To this base message set, add the physical formats that you want to be created
in your new message set.
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To import C, COBOL copybooks, XML DTD or XML Schema using the command

line:

1. Close the workbench. This must not be running when you use the command
line importer.

2. Invoke the mqsicreatemsgdefs command from a command prompt specifying
the message set project name, path name of the source files folder, and any
other optional parameters that you require. If you want to add physical formats
to the new message set that the mqsicreatemsgdefs command creates, specify
the base message set that contains these physical formats as the -base
parameter on the import command line.

3. When the command has completed, open mqsicreatemsgdefs.report.txt. This
report is created when you invoke the mgsicreatemsgdefs command and by
default is written to the directory from which you invoked the command. The
report provides you with the following information:

* Details of the parameters that were used when mgqsicreatemsgdefs was
invoked.

* The message set level action.
¢ The name of the file or files that have been imported.

* Details of the import process (for example, any warnings that have been
generated and message model objects that have been created).

¢ The number of files imported.

4. Start the workbench and switch to the Broker Application Development
perspective. The message definition file that was created when you invoked
mgsicreatemsgdefs is visible in the project that you specified.

If an error occurs during the import of a C, COBOL copybook, XML DTD, or XML
Schema file, carefully check any errors that the importer reports. By default, all
errors are written to the screen and to the log file described above. To gather
additional information about the import, specify the -v (Verbose) command line
parameter. This parameter displays more detailed information as the import
proceeds.

Importing from XML Schema
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You can use the New Message Definition File wizard in the workbench to create a
new message definition from an XML Schema

Before you start you must have completed the following tasks:

+ [“Creating a message set” on page 83|

+ [“Importing file systems into the workbench” on page 127]

Before you begin this task, you should be aware of the following points:

* To create a new message definition file from an XML Schema, the schema file
must already exist in the workbench; for example, in your message set project.
This allows you to select the schema file in the New Message Definition File
wizard.

* If the message set to which you are adding the new message definition file does
have an XML wire format layer, but no namespace support, the imported schema
is modified to remove namespaces. For this reason, you should enable
namespace support before importing a schema.

* If the message set to which you are adding the new message definition file does
not have an XML wire format layer, but does have namespace support, only the
logical information appears in the model. For this reason, you should add the



physical layer to the message set before importing the schema. This ensures that
the message set is populated with the settings and values from the schema. The
XML Schema is not modified to remove namespaces.

* If the message set to which you are adding the new message definition file does
not have an XML wire format layer, and does not have namespace support, only
the logical information appears in the model and the imported schema is
modified to remove namespaces.

* If you are working with a message set that does not have namespace support,
you must specify the preferences that apply when you import a schema into the
message set. These preferences allow you to specify how the importer treats
certain individual schema constructs. You can either reject the schema if any
occurrences of the construct are encountered or modify occurrences of the
construct. If you choose modify, the importer modifies all occurrences of the
construct.

e The extension to the XML Schema file must be .xsd in lower case.

The following steps create a completely new message definition file or overwrite
the contents of an existing file.

To create a message definition from an XML Schema file:
1. Switch to the Broker Application Development perspective.

2. Open the New Message Definition File wizard by clicking File> New>
Message Definition File on the workbench menu. Alternatively, you can open
the wizard by right-clicking an *.xsd file that was previously imported into the
workbench and clicking New> Message Definition File on the menu.

3. In the displayed list of options, click XML Schema file to select it, and then
click Next.

4. Step through the remainder of the wizard, filling in the details as required. The
processing time for importing the XML Schema varies according to the size and
complexity of that schema. In a large and complex schema, it can take some
time to import the file, generate the log file and display any task list warnings
or errors.

When you have finished importing the XML Schema using the wizard:

 Carefully check the log file for any warnings or errors in the report that is
created when the file is imported. These warnings and error messages give
information about whether the schema failed to import or needed to be modified
to enable it to be successfully imported. You can find this report in the Tog
directory structure within the project that contains the message definition that
you have tried to create. The report has a .xsd.report.txt file extension,
prefixed with the name that you specified for the new message definition file.

* Review the messages that are shown in the workbench task list to check whether
any new warnings or error messages have appeared. Although you might have
imported a perfectly valid schema, the task list will display warnings or error
messages for any errors that exist in the message definition file. Some examples
of situations where messages appear are given below:

— If the XML Schema that you are importing contains xsd:key, xsd:keyref and
xsd:unique constructs, warning messages appear in the task list to tell you
that these constructs are unsupported and will be ignored by the broker. If
you prefer to delete these constructs, open the message definition file in the
Message Definition editor, and delete the constructs as described in
[objects” on page 120, Deleting the constructs also removes the warning
messages from the task list. If you decide not to delete the constructs, they
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remain in the message model but are not be deployed to the broker, or used
for any other purpose. The warning messages remain in the task list, but you
can use the message model normally.

— If the XML Schema that you are importing contains xsd:redefine constructs,
error messages appear in the task list to tell you that this construct is
unsupported. If you right-click on the error messages and select Quick Fix,
you can choose to convert the xsd:redefine constructs into xsd:include
constructs. This also removes the error messages.

— If the XML Schema that you are importing contains xsd:attribute constructs
that contain both a fixed value and a default value, error messages appear in
the task list to tell you that this construct is unsupported. However, the
schema is still imported and the fixed value is used, not the default value.
The error messages can be ignored.

— If you are importing a collection of related XML Schema files and the
Message Definition Editor cannot resolve the links between two of the
imported files, messages appear in the task list to say that referenced types or
other objects cannot be found. If this occurs, refer to [Resolving problems|
[when developing message models| for more information.

Importing from the command line

This describes how to use the command line importer mqsicreatemsgdefs to
import C, COBOL copybooks, XML DTD or XML Schema in order to populate a
message set with message definitions.

Before you start:

Before you attempt this task, you should read the following information:

+ Imgsicreatemsgdefs command|

The command line importer allows you to create a new message set, into which
the message definition files will be placed. When you create a new message set
from the command line, only the logical information is created by default.
However, the command line importer allows you to create a new message set
based on an existing message set. The physical format information from the base
message set is also created in the new message set. If you want physical format
information to be created as well, you must do the following before you invoke the
mgqsicreatemsgdefs command:

1. Using the workbench, create a message set in your workspace that is to be used
as a base message set.

2. To this base message set, add the physical formats that you want to be created
in your new message set.

To import C, COBOL copybooks, XML DTD or XML Schema using the command

line:

1. Close the workbench. This must not be running when you use the command
line importer.

2. Invoke the mqsicreatemsgdefs command from a command prompt specifying
the message set project name, path name of the source files folder, and any
other optional parameters that you require. If you want to add physical formats
to the new message set that the mqsicreatemsgdefs command creates, specify
the base message set that contains these physical formats as the -base
parameter on the import command line.

3. When the command has completed, open mgsicreatemsgdefs.report.txt. This
report is created when you invoke the mqsicreatemsgdefs command and by



default is written to the directory from which you invoked the command. The
report provides you with the following information:

* Details of the parameters that were used when mgqsicreatemsgdefs was
invoked.

* The message set level action.
¢ The name of the file or files that have been imported.

¢ Details of the import process (for example, any warnings that have been
generated and message model objects that have been created).

* The number of files imported.

4. Start the workbench and switch to the Broker Application Development
perspective. The message definition file that was created when you invoked
mgqsicreatemsgdefs is visible in the project that you specified.

If an error occurs during the import of a C, COBOL copybook, XML DTD, or XML
Schema file, carefully check any errors that the importer reports. By default, all
errors are written to the screen and to the log file described above. To gather
additional information about the import, specify the -v (Verbose) command line
parameter. This parameter displays more detailed information as the import
proceeds.

Generating documentation from message sets and message flows

You can generate documentation from your message sets, message flows, message
definition files, message maps, Java  files, ESQL files, and deployable WSDL files.

To generate documentation that describes your message sets, message flows,
message definition files, message maps, Java files, ESQL files, and deployable
WSDL files:

1. Switch to the Broker Application Development perspective.

2. In the context menu of the Broker Development view, right-click a message set
project, a message set, a message flow, a message definition file, a Java file, an
ESQL file, or a deployable WSDL file, and select the action Generate
Documentation. The Documentation Generation wizard opens.

3. Provide the information that is requested to describe the documentation report
that you want, and click Next to move to the next panel of the wizard.

4. Step through the wizard, clicking Next to move to a new panel, and clicking
Finish when you have described all the information that you want your report
to document.

| Generating XML Schemas

| You can generate either a single XML Schema from a message definition file, or
[ multiple XML Schemas from a message set.

| To generate a single XML Schema from a message definition file, see
I [an XML Schema” on page 143 |

| To generate multiple XML Schemas (one from each message definition file in a
I message set) see [“Generating XML Schemas” on page 142
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Generating XML Schemas

142 Message Models

You can generate an XML Schema for each message definition file in a message set.

You must have completed the following tasks:

+ [“Creating a message set” on page 83|

* [“Working with a message definition file” on page 93|

+ ["Working with message model objects” on page 96|

Note: WebSphere Message Broker uses XML Schema 1.0 to describe the logical

structure of messages.

Tip: You should replace any deprecated constructs before you generate XML

Schema representations of your models.

. Switch to the Broker Application Development perspective.

. In the Broker Development view, right-click the message set folder from which

you want to generate XML Schemas, and click Generate> XML Schemas.

. The Generate XML Schemas window is displayed, and you must put into the

Zip file name field the name of the compressed file (*.zip file extension) that
you want to contain the generated XML Schemas.

. Select a destination folder for this compressed file. You can choose a location

either inside or outside the workspace:

* Click Create in a workspace directory and select the required destination
folder from the expanded workspace directory. The contents of the folder
that you select are overwritten.

If you want to create a new folder:
a. Click on the desired location.
b. Click Create New Folder.

c. Click OK

* Click Export to an external directory and click Browse to expand the
directory. Select a folder from the expanded directory. The contents of the
folder that you select are overwritten.

If you want to create a new folder:
a. Click on the desired location.

b. Click Make New Folder and type the name of the new folder into the
directory tree.

c. Click OK

. Optional: Choose from the list given in the XML Wire Format field an XML

wire format that you want to use to generate the XML Schemas.

Tip: You must have previously added one or more XML Wire Format layers to
the message set if you want to use an XML physical format when you
generate XML Schemas. For further information see [“Adding an XML wire]
[format” on page 89

. If you do not want strict generation of an XML Schema, clear the Strict

generation check box at the bottom of the Generate XML Schemas page. By
default, this check box is selected.

Tip: For further information on strict and lax generation of an XML Schema,
see [“Generate XML Schema” on page 78




7. Click Finish. The compressed file that contains your generated XML Schemas is
created.

Generating an XML Schema

Before you start:

You must have completed the following tasks:

* [“Creating a message set” on page 83

+ [“Working with a message definition file” on page 93|

* [“Working with message model objects” on page 96
g

Note: WebSphere Message Broker uses XML Schema 1.0 to describe the logical
structure of messages.

Tip: You should replace any deprecated constructs before generating XML Schema
representations of your models.

This task topic describes how to generate an XML Schema from a message
definition file:

1. Switch to the Broker Application Development perspective.

2. In the Broker Development view, right-click the message definition file (*.msxd
file extension) from which you want to generate an XML Schema, and then
click Generate> XML Schema on the menu.

3. The Generate XML Schema window is displayed, and the message definition
file that you selected is highlighted. The message definition file list is filtered to
only show artifacts in the active working set. If this is not the message
definition file from which you want to generate an XML Schema, select the
correct message definition file.

4. Optional: From the drop down list at the bottom of the Generate XML Schema
window, select the XML Wire Format that you want to use to generate the XML
Schema.

Tip: You must have previously added one or more XML Wire Format layers to
a message set if you want to use an XML physical format when you
generate XML Schema. For further information see [“Adding an XML wire]
[format” on page 89

5. If you do not want strict generation of an XML Schema, clear the Strict
generation check box at the bottom of the Generate XML Schema page. By
default, this check box is selected.

Tip: For further information on strict and lax generation of XML Schema, see
[‘Generate XML Schema” on page 78

6. Click Next to move to the next page of the wizard.

7. Select a destination folder for the XML Schema. You can choose a location
either inside or outside the workspace:

* Click Create in a workspace directory and select the required destination
folder from the expanded workspace directory. The contents of the folder
that you select are overwritten.

If you want to create a new folder:
a. Click on the desired location.
b. Click Create New Folder.
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c. Click OK

* Click Export to an external directory and click Browse to expand the
directory. Select a folder from the expanded directory. The contents of the
folder that you select are overwritten.

If you want to create a new folder:
a. Click on the desired location.

b. Click Make New Folder and type the name of the new folder into the
directory tree.

c. Click OK
8. Click Finish. Your XML Schema is generated.

9. Use the Broker Development view to locate the destination folder that you
specified for the generated XML Schema. This folder contains a file with exactly
the same name as your message definition file with the file extension *.xsd.
This is the generated XML Schema. To view this file, right-click it then click
Open on the menu. This launches the schema editor.

Tip: The Design, Source or Graph tabs located in bottom left corner of the
schema editor provide you with different views of generated XML
Schema.

Generating a WSDL definition from a message set
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Before you start you must already have completed the following tasks:

+ [“Creating a message set” on page 83|

To ensure the highest interoperability of your web services, use the document style
of WSDL whenever possible. If rpc style WSDL is necessary, use literal encoding.

Replace any deprecated constructs before generating WSDL representations of your
message models.

To generate a WSDL definition:
1. Switch to the Broker Application Development perspective.

2. In the Broker Development view, right-click the folder that contains the
message set file from which you want to generate a web service definition, and
select Generate > WSDL Definition. This starts the Generate WSDL wizard.

3. Step through the wizard filling in the details as required. Some of the panels
and options are subject to settings that you make within the wizard and might
not always be shown. Also, some fields in the wizard might be greyed out. This
happens when a field has a mandatory setting, or when the field is not used
because of settings that have already been made in other fields.

By default, the wizard creates the WSDL in the message set project. If you are
going to use the WSDL to configure a SOAP node, create the WSDL in the
message set, not the message set project.

On completion of the Generate WSDL wizard, you have generated a WSDL
definition. The file extension for WSDL files is .wsdl, and the file extension for any
imported schema files in multi-file mode (where the WSDL definition is split over
a number of files) is .xsd.

This following is an example of the WSDL that is generated for a JMS binding:



<wsdl:service name='HTTP'>
<wsdl:port binding='tns:JMSSoapBinding' name='HTTP'>

<wsdlsoap:address
location="'jms:/queue?destination=jms/MyQueue&amp;

connectionFactory=jms/MyCF&amp;
priority=5&amp;
targetService=GetQuote'/>

</wsd1:port>
</wsdl:service>

Note: The various parts of the location string are broken over separate lines for
clarity, but are actually generated as a continuous string without additional

white space.

Developing message models
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Message model reference information

Reference information in this section can help you develop and configure message
models.

Message model reference information is available for:

+ ["“Message set preferences”]

* ["“Message set properties” on page 151]

* ["Message definition file properties” on page 183|

+ [“Message category properties” on page 185|

* ["“Message model object properties” on page 186|

* ["“Deprecated message model object properties” on page 600

[“Additional MRM domain information” on page 729
[“Additional MIME domain information” on page 774|

[‘Generated model representations” on page 784|

* [“Import formats” on page 789

* ["Message model wizards” on page 800

Message set preferences

Property

Type

Meaning

Default version
tag

String

Provide the default version information you would like to be set in the message
set Version property when you create a new message set.

You can alter a number of the preferences that affect the way certain areas of
message set processing are handled. The areas are:

* ["Message Set Editor and Message Definition Editor preferences”|

+ [“Validation of the message model” on page 150|

* XML Schema Importer” on page 151

Message Set Editor and Message Definition Editor preferences

Message set editor settings

While looking at a large message set that contains a number of message definition
files that have different namespaces, or multiple message definition files that have
the same namespace, you might want to view the information in alternative ways
to make it easier for you to visualize the structure of the message set. If you
double click on the global construct, you open the message definition file in which
the global construct is defined.

Property Type Meaning

Group by Button Selecting this view groups the global constructs by namespace and then by
namespace and collection (for example, Messages, Types, Groups, or Elements and Attributes).
then by Using this view you can visualize all of the constructs that belong to each of the
collections defined namespaces.

© Copyright IBM Corp. 2000, 2008
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Property Type Meaning
Group by Button Selecting this view groups the global constructs by collection (for example,
collections and Messages, Types, Groups, or Elements and Attributes) and then by namespace.
then by Using this view you can visualize which global construct in the message set is
namespace defined in which namespace.

Message definition editor settings
Property Type Meaning
Show base Check box Where your complex type is based on another complex type that is derived by
complex types an extension, selecting this will display the base complex type in the outline

view.

Prefix for String This property allows you to specify a prefix to precede the name of the initial
created complex type in the name of the created message. This prefix applies only to
messages messages created from C or COBOL files. The default value is msg_.

Note, however, that no prefix is applied when a message is created from a C file,
and the selected preprocessing option is SAP ALE IDoc or SAP File IDoc.

Tab Extensions

Click Tab Extensions to display check boxes that allow you to determine what tabs
are enabled for the Message Set Editor, the Message Definition Editor, and the
Message Category Editor. All these check boxes are always selected and cannot be
cleared.

Editor Tab Extensions
Message Set Editor Properties
Message Definition Editor Overview
Properties
Message Category Editor Properties

A control is provided that allows you to choose the order in which the tab
extensions for each of the editors are displayed.

Validation of the message model
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You can customize some of the warning messages that are generated by message
set validation. Use the Message Set Validation Preference page to do this.

Any warning or error that falls into any of the categories that are listed below can
be customized according to the relevant category. The customization can affect
both severity and priority.

The severity can be one of the following values:
e Error

* Warning

* Info

¢ Ignore

If the severity is not Ignore, the priority can be one of the following values:



High
Normal

Low

If the severity is Ignore, you cannot change the priority.

Message set validation settings

The following is a list of the categories that you can customize:

Use of deprecated constructs

Messages with abstract global elements

Facet runtime validation differences

Type/Element substitution runtime validation differences

Mixed content runtime validation differences

Wildcard runtime validation differences

Unique Particle Attribution checks

Tagged/Delimited String group content

Zero Custom Wire Format length count

Zero Tagged/Delimited String Format length count

Empty Tagged/Delimited String Format tag

List or Union with Custom Wire Format

List or Union with Tagged/Delimited String Format

Unbounded max occurs with Custom Wire Format

Unbounded max occurs with Tagged /Delimited String Format

XML Schema Importer

You can customize the following categories that affect the way in which an XML
Schema is imported into a message set that does not support namespaces.

Category Modify Reject Accept
Import Converts Import to Include |Import fails if it sees an Not applicable
Import
Redefine Removes the Redefine Import fails if it sees a Redefine imported (gives
statements Redefine task list error)
List Changes type base to Import fails if it sees a List |List imported
xsd:string
Union Changes type base to Import fails if it sees a Union imported

xsd:string

Union

Abstract Complex Type

Sets abstract to false

Import fails if it sees an
Abstract Complex Type

Abstract Complex Type
imported

Abstract Element

Sets abstract to false

Import fails if it sees an
Abstract Element

Abstract Element imported

Message set properties

Message sets have properties that you can set to define their characteristics and the
way in which they are processed.
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General message set properties

The table below defines the properties that you can set to customize the message

set.
Property Type Meaning
Default String and The message parser name must match the Message Domain property of any input
message check boxes node that processes messages from the message set, or the <Msd> element value
domain and of any MQRFH2 header that precedes a message from the message set.
Supported
message Choose a value from the list offered for the Default Message Domain property, and
domains select check boxes (from Supported Message Domains) to choose other domains.

You can select as many of these check boxes as you want.

Use the message parser name when you write ESQL field references for

messages in the message set; for example, InputRoot.MRM.Document. The

Mapping editor and the content assist feature of the ESQL editor use the
message parser name when they generate ESQL field references.

You can choose from the following names:

* XMLNSC (the default if you select Finish from page two of the New Message
Set wizard). Choose this domain if you want to model XML messages. You
can deploy the message set to brokers if you want, because the XMLNSC
parser optionally uses the message set at run time.

* MRM. Choose this domain for binary or text messages. You can also use this
domain for XML messages. You must deploy the message set to the brokers
that receive these messages. The deploy action creates a runtime dictionary
against which the MRM parser checks the received message.

* SOAP. Choose this domain for SOAP Web Services.
* DataObject. Choose this domain for data from WebSphere Adapters.

* XMLNS. You might need to choose this domain for some kinds of XML
messages. You do not have to deploy the message set to brokers, because the
XMLNS parser does not use the message set at run time.

* JMSMap. Choose this domain if you want to model a JMS MapMessage
message. You do not have to deploy the message set to brokers, because this
parser does not use the message set at run time.

* JMSStream. Choose this domain if you want to model a JMS StreamMessage
message. You do not have to deploy the message set to brokers, because this
parser does not use the message set at run time.

* MIME. Choose this domain if you want to model a MIME message. You do
not have to deploy the message set to brokers, because the MIME parser does
not use the message set at run time.

* XML. This domain is deprecated. Use the XMLNSC domain instead.
* IDOC. This domain is deprecated. Use the MRM domain instead.
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Property

Type

Meaning

Use namespaces

Check box

Select this property if you want to use namespaces within the message set.
Namespaces provide a method of avoiding naming conflicts where different
document definitions have elements of the same name. For further information

see [INamespaces

By default, this check box is selected.

Using namespaces affects how elements are created in the logical message tree.
Each element in the message tree has both a name and a namespace, so an ESQL
or Java reference to one of these elements has to specify both name and
namespace. Therefore, using namespaces has an effect on the ESQL or the Java
that you write.

Always select this property if you want to use the message set to model XML
messages.

MRM domain

Property

Type

Meaning

Default wire
format

String

(Optional) Specify the default wire format used, only if you select MRM as the
default message domain, or MRM is selected in the list of supported message
domains. The default value is <no default specified>.

If you do not select MRM, either as the default message domain or as one of the
supported message domains, the Default Wire Format property is unavailable.

Message set ID

String

This property is a unique identifier that is automatically generated for you when
you create the message set. You cannot change this property.

Message set
alias

String

Specify an alternative unique value that identifies the message set. This property
is only required if you are using the Message Identity technique to identify
embedded messages. Using this technique, the embedded messages are defined
in this message set but the parent message is defined in a different message set,
and the bit stream does not contain the actual message set name or identifier.

Message type
prefix

String

This property is used when you define multipart messages, specifically when
using the Message Path technique to identify embedded messages.

The value that you specify is used as an absolute or relative path to the
innermost message from the outermost, and is used as a prefix to the value of
the Message Type property that is specified for the outermost message (specified
either in the MQRFH2 header of the message, or in the input node of the
message flow).

If you set a value, it must be in the form id1/id2/.../idnu where id1 is the
identifier of the outermost message, id2 is the identifier of the next element or
message, and idn is the identifier of the innermost message. The default value is
blank (not set).

The table below, describing the use of the message set property Message Type
Prefix, shows how this value is combined with the Message Type property of an
input message.

Broker will treat
Length facet as
MaxLength

Check box

Select this property if you want the COBOL importer to create a maxLength
facet, rather than a length facet, for a fixed length string element.

By default, this check box is selected.
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Use of the Message type prefix property

The table below shows the implications of using the property Message type prefix.
The message type or message prefix can describe either elements or messages.

Message Type property example Message type prefix not set Message type prefix set
Simple Message Type:msg_type Results in the simple Message Results in the path Message Type:
Typemsg_type /msg_prefix_1/.../msg_prefix_n/

msg_type

Path Message Type:msg_type_1/.../ |Results in the path Message Results in the combined path

msg_type m Type:/msg_type _1/.../msg_type m Message Type: /msg_prefix_1.../
msg_prefix_n /msg_type 1/.../
msg_type_m

Simple absolute Message Results in the simple Message Results in the simple Message

Type:/msg_type Typemsg_type Typemsg_type

An error is raised if Message Type
Prefix is set to any value other than

msg_type.

Path absolute Message
Type:/msg_type_1/.../msg_type_m Type:/msg_type_1/.../msg_type_m Type:/msg_type_1/.../msg_type_m

Results in the path Message Results in the path Message

An error is raised if all identifiers in
Message Type Prefix do not match
the corresponding identifiers in the
resulting path.

If you are using MRM or IDOC domains, in addition to the main message set
properties, you can update message set properties that are specific to each of the
physical formats. Links to reference topics that describe these properties are given
below.

Custom Wire Format message set properties

The tables define the properties that you can set for a Custom Wire Format
message set.

Some of the message set properties (marked with an asterisk (*)) are relevant only
if the message being processed is not using WebSphere MQ as the transport

protocol.

If the transport protocol is WebSphere MQ), values are derived from the message
headers (for example, MQMD), and the message set properties, if set, are ignored.

Binary representation of boolean values

Property

Type

Meaning

Boolean True
Value

String

Enter up to eight hexadecimal digits. Do not include the hexadecimal indicator
(0x) preceding this number. Each digit is a half byte. The maximum length is 4
bytes. You must enter an even number of digits (a whole number of bytes). This
value must be different from, but the same length as, the Boolean False Value.
The default value is 00000001.
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Property

Type

Meaning

Boolean False
Value

String

Enter up to eight hexadecimal digits. Do not include the hexadecimal indicator
(0x) preceding this number. Each digit is a half byte. The maximum length is 4
bytes. You must enter an even number of digits (a whole number of bytes). This
value must be different from, but the same length as, the Boolean True Value.
The default value is 00000000.

Boolean Null
Value

String

Enter up to eight hexadecimal digits. Do not include the hexadecimal indicator
(0x) preceding this number. Each digit is a half byte. The maximum length is 4
bytes. You must enter an even number of digits (a whole number of bytes). This
value can be the same as either Boolean True Value or Boolean False Value, or
different. The default value is 00000000.

Output settings

Use these settings when messages are being output.

Property

Type

Meaning

Byte Alignment
Pad

String

If the xsd:element Custom Wire Format properties Byte Alignment, Leading Skip
Count, and Trailing Skip Count cause bytes to be skipped in the bit stream
when the message is serialized, this property supplies the character to be used in
the skipped positions. Set this character in one of the following ways:

* Select SPACE, NUL, or 0 (the default) from the list of values shown.

"

* Enter a character between quotation marks, for example "¢” or 'c’, where c is
any alphanumeric character.
¢ Enter a decimal character code in the form YY where YY is a decimal value.

e Enter a hexadecimal character code in the form 0xYY where YY is a
hexadecimal value.

e Enter a Unicode value in the form U+xxxx where xxxx is a Unicode value
specified in hexadecimal format.

Policy for
Missing
Elements

Enumerated

This property determines the action that is taken by the broker when fields are
missing from the message tree when the message is serialized (for output):

* Use Default Value (the default). If a Default Value exists for the element, output
it; otherwise, throw an exception.

* Use Null Value. If the Nillable property of the element is selected, and an
Encoding Null Value is specified for the element, output the Encoding Null Value
according to the rules that are defined by the Encoding Null property;
otherwise, throw an exception.
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Property

Type

Meaning

Truncate fixed
length strings

Check box

This property applies only to output strings.

If this check box is selected, and the element or attribute is a fixed length string
(that is, the logical type is xsd:string and the physical type is Fixed Length
String) that is longer than either the length that is specified in the model or the
length reference, the string is truncated to this length. No exception is raised on
output, unless validation (see [Validating messages) is active.

The end from which data is truncated is determined by the value of the
Justification property. If the value of the Justification property is Left justify, data
is truncated from the right; if the value of the Justification property is Right
justify, data is truncated from the left. However, if the value of the Justification
property is Not applicable, truncation does not occur and an exception occurs if
the string is too long.

If this check box is cleared, an exception occurs if the element or attribute is a
fixed length string (that is, the logical type is xsd:string and the physical type is
Fixed Length String) that is longer than either the length that is specified in the
model, or the length reference. This behavior occurs in releases of the WebSphere
Message Broker earlier than Version 6.1.

By default, this check box is cleared.

Binary representation of decimal values

Property

Type

Meaning

Packed Decimal
Positive Code

Enumerated

Select, from the list, the positive sign that is used for packed decimal numbers.
The default value is C, which indicates that 0x0C is used as the positive sign; this
value is used in most systems. You can also select F, which indicates that 0x0F is
used as the positive sign; this value is used in some systems.

Datetime settings

for 2 digit years

Property Type Meaning
Derive default |Button Select this option if you want the default dateTime format to be determined by
dateTime the logical type of the element or attribute.
format from
logical type You can override this property for an element or attribute within a complex
type.
Use default Button and Select this option if you want to specify a default dateTime format that is fixed
dateTime String for all elements or attributes of logical type dateTime, date, time, gYear,
format gYearMonth, gMonth, gMonthDay, and gDay.
You can override this property for an element or attribute within a complex
type.
For more information, see ["DateTime formats” on page 765.|
Start of century |Integer This property determines how two-digit years are interpreted. Specify the two

digits that start a 100-year window that contains the current year. For example, if
you specify 89, and the current year is 2002, all two-digit dates are interpreted as
being in the range 1989 to 2088.
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Property Type Meaning

Days in First Enumerated Specify the number of days of the new year that must fall within the first week.

Week of Year
The start of a year typically falls in the middle of a week. If the number of days
in that week is less than the value specified here, the week is considered to be
the last week of the previous year; therefore, week 1 starts some days into the
new year. Otherwise, it is considered to be the first week of the new year; in this
case, week 1 starts some days before the new year.
Select Use Broker Locale, which causes the broker to get the information from
the underlying platform, or select a number from the list that is displayed.

First Day Of Enumerated Specify the day on which each new week starts.

Week

Select Use Broker Locale, which causes the broker to get the information from
the underlying platform, or select a value from the list that is displayed.
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Property

Type

Meaning

Strict DateTime
Checking

Check box

Select this option if you want to restrict dateTimes to a valid dateTime format. If
Strict DateTime Checking is selected, receiving an incorrect dateTime causes an
error.

Strict dateTime checking
Examples of strict dateTime checking are:

* DateTimes are restricted to valid dateTimes only. When you use this
option, a date such as the 35th March is not processed as 4th April,
and 10:79 is not processed as 11:19. Receiving an out-of-band
dateTime, such as these examples, causes an error to occur.

e The number of characters for a numeric dateTime component must
be within the bounds of the corresponding formatting symbols.
Repeat the symbol to specify the minimum number of digits that you
require. The maximum number of digits that are permitted becomes
the upper bound for a particular symbol. For example, day in month
has an upper bound of 31; therefore, a format string of ‘d” allows the
values 2 and 21 to be parsed, but does not allow the values 32 and
210. On output, numbers are padded with zeros to the specified
length. A year is a special case; see the message set property Start of
century for 2 digit years. For fractional seconds, the length must
implicitly match the number of format symbols on input. The output
is rounded to the specified length.

* White space is not skipped over. The white space in the input string
must correspond with the same number and position of white space
in the formatting string.

e If there is still data to be parsed in the input string after all of the
symbols in the formatting string have been matched, an error occurs.

Lenient dateTime checking
Examples of lenient dateTime checking are:

* The parser converts out-of-band dateTime values to the appropriate
in-band value. For example, a date of 2005-05-32 is converted to
2005-06-01.

* Output of dateTimes always adheres to the symbol count. For
example, a formatting string of yyyy-MM-dd (where ’-" is the field
separator) allows one or more characters to be parsed against MM
and dd. Therefore, dates that are not valid - for example, 2005-1-123
and 2005-011-12 - can be input. The first value of 2005-1-123 is output
as the date 2005-05-03, and the second value of 2005-011-12 is output
as the date 2005-11-12.

¢ The number of the timezone formatting symbol Z is only applicable
to the output dateTime format.

¢ White space is skipped over.

Time Zone

Enumerated

The value that you set for this property is used if the value that you specified
for the Default DateTime Format property does not include Time Zone
information.

The initial value is Use Broker Locale, which causes the broker to get the
information from the underlying platform.

You can change this property by selecting from the list of values.

Daylight
Savings Time

Check box

Select this option if the area in the Time Zone property observes Daylight Saving
Time. If it does not observe Daylight Saving Time, do not select this option.

For example, if an area is selected in Time Zone and this option is not selected,
the value passed represents the time zone without the Daylight Saving Time.

158 Message Models




Property

Type

Meaning

Use input UTC
format on
output

Check box

This property applies to elements and attributes of logical type xsd:dateTime or
xsd:time that contain a dateTime as a string and that have a dateTime format of
I, IU, T, or TU, or that include ZZZ or ZZZU.

Such elements and attributes can specify Coordinated Universal Time (UTC) by
using either the Z character or timezone +00:00 in the value. On input, the MRM
parser remembers the way that UTC was specified.

If this property is selected, and the element or attribute is copied to an output
message, the UTC format is preserved into the output message and overrides the
format that is implied by the dateTime format property.

If this property is cleared, or if the element or attribute was not copied from an
input message, the UTC format in the output message is controlled solely by the
dateTime format property.

Character and numeric encoding for non-WebSphere MQ
messages

Use these settings only for messages with no MQMD.

Property

Type

Meaning

Default CCSID*

Integer

Enter a numeric value for the default Coded Character Set Identifier. The default
is 500.

If the input message is a WebSphere MQ message, the equivalent attribute that
is set for the queue manager is used, and this property is ignored.

Default Byte
Order*

Enumerated

Select either Big Endian (the default) or Little Endian from the list to specify the
byte order of numbers that are represented as binary integers.

In C, this is equivalent to data type short or long. In COBOL, this is equivalent
to a PIC 9, COMP, COMP-4, COMP-5, or BINARY data type.

Your choice must match the encoding with which messages are created.
Typically, Big Endian is the correct option for messages that are created on
UNIX® or z/OS® Little Endian is the correct option for messages that are created
on Windows®.

Do not use this property if the message is received across the WebSphere MQ
transport protocol; in this case, the property is deduced from the MQMD of the
message, or from the encoding of the broker queue manager.

Default Packed
Decimal Byte
Order*

Enumerated

Select Big Endian (the default) or Little Endian from the displayed list to specify
the byte order of numbers that are represented as packed decimal. In COBOL,
this is equivalent to PIC 9 COMP-3 data type. There is no equivalent data type
in C.

Your choice must match the encoding with which messages are created.
Typically, Big Endian is the correct option for messages that are created on UNIX
or z/OS; Little Endian is the correct option for messages that are created on
Windows.

Default Float
Format*

Enumerated

Select one of S390 (the default), IEEE, or Reverse IEEE from the displayed list to
specify the byte order of numbers in the message that are represented as floating
point.
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TDS Format message set properties

The following tables show the properties that you can set for a TDS format
message set.

See [“Default TDS message set properties” on page 170| for the default settings of

these properties for each of the industry standards.

Messaging Standard

Property Type Meaning
Messaging Enumerated Specify the standard to be used for this wire format. Select one of the following
Standard values:
* User Defined Text - for text data not based on a standard
s SWIFT
* ACORD AL3
* EDIFACT
» X12
* TLOG
* HL7
* CSV - Comma Separated Values
* User Defined Mixed - for mixed text and binary data
If you are defining your own tagged/delimited messages, or are using a
standard that is not included in the list of values shown, select either User
Defined Text, if all your data is text, or User Defined Mixed, if not all your data
is text.
The value that you select for this property determines the default values of some
of the other properties.
The default is User Defined Text.
Data element separation settings
Property Type Meaning
Group Indicator | String Specify the default value of a special character or string that precedes the data
that belongs to a group or complex type within the bit stream.
Group String Specify the default value of a special character or string that terminates data that
Terminator belongs to a group or a complex type within the bit stream.
Delimiter String Specify the default value of a special character or string that specifies the

delimiter that is used between data elements.

This property applies only to the delimited Data Element Separation methods
(Tagged Delimited, All Elements Delimited, and Variable Length Elements
Delimited).
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Property

Type

Meaning

Suppress
Absent Element
Delimiters

Enumerated

Use this property to select whether you want delimiters to be suppressed for
elements that are missing within a message. Select from:

* End Of Type. Use this option to suppress the delimiter when an element is
missing. For example, if the model has been defined to have up to three
elements and only two are present, the last delimiter can be omitted from the
message.

* Never. Use this option to ensure that even if optional elements are not
present, all delimiters are written out. This option must be used when the
same delimiter is used to delimit parent objects and child objects. For
example, if an optional child element is missing and all the delimiters are the
same, message processing applications cannot tell where the child elements in
a message ends and where the next parent element starts.

Tag Data
Separator

String

Specify the default value of a special character or string that separates the tag
from the data.

If you set the property Tag Data Separator, the Length of Tag property is
ignored.

This property applies only to the tagged Data Element Separation methods
(Tagged Delimited, Tagged Fixed Length, and Tagged Encoded Length).

Length of Tag

Integer

Specify the default length of a tag value. When the message is parsed, this
property allows tags to be extracted from the bit stream.

The Tag Data Separator and Length of Tag properties are mutually exclusive. If
you set the property Tag Data Separator, the Length of Tag property is ignored.

This property applies only to the tagged Data Element Separation methods
(Tagged Delimited, Tagged Fixed Length, and Tagged Encoded Length).

Note: Any value that you set for a group or complex type property overrides the

value that you set for the corresponding message set property.

Character data settings

Property

Type

Meaning

Default CCSID

Integer

CCSID (Coded Character Set Identification) specifies the mapping between
character codes and symbols. You must specify a code set that is supported by
WebSphere Message Broker.

This property stores the default CCSID for the message bit stream, but this value
can be overridden when the message is processed (for example, by the CCSID in
the header of a WebSphere MQ input message).
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Property

Type

Meaning

Trim on input

Enumerated

This property applies only to elements and attributes with a physical type of
Text. This property specifies whether a simple element or attribute value is to be
trimmed when it is parsed. The property does not apply to a simple element, or
attribute, with a logical type of Boolean or Binary. All trimming is applied to
element or attribute values before the conversion of the value to its logical type.
This property does not apply when writing elements or attributes.

This property only applies to a simple element, or attribute, that is contained
within a complex type or group that has the Justification property set to Left
Justify or Right Justify, and that satisfies one of the following conditions:

* The Data Element Separation property is set to Fixed Length, Fixed Length
AL3, Tagged Fixed Length, Use Data Pattern, or Tagged Encoded Length.

* The Data Element Separation property is set to Variable Length Elements
Delimited, and the element or attribute has a value set for its model length or
length reference.

* The Data Element Separation property is set to Tagged Delimited or All
Elements Delimited, and the Observe Element Length property is set. The
element or attribute has a model length or length reference value set.

This property can be set to one of the following values:
* No Trim. No characters are trimmed from the element or attribute value.

* Leading White Spaces. White space characters are trimmed from the left of the
element or attribute value.

* Trailing White Spaces. White space characters are trimmed from the right of
the element or attribute value.

* Trim Both. White space characters are trimmed from both the left and the
right of the element or attribute value.

* Trim Padding Chars. Padding characters are trimmed from the element or
attribute value. The padding character is set by the Padding Character
property of the element or attribute. If the Justification property of the element
or attribute is set to Left Justify, the padding characters are trimmed from the
right. If the Justification property of the element or attribute is set to Right
Justify, the padding characters are trimmed from the left. If the Justification
property of the element or attribute is set to Not Applicable, no trimming
takes place.

White space characters include control characters that are in the range from
U+0000 to U+001f and from U+007f to U+009f.

You might need to use this property if you have data input that is mapped to a
numeric simple type. For example, if the input data has leading spaces, you can
set this property to Leading White Spaces to avoid data conversion problems
when you process these fields.
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Property

Type

Meaning

Truncate on
output

Check box

This property applies only to output strings that have a physical type of Text.

The property applies to elements or attributes that have a logical type of
xsd:string and that are contained within a structure with a Data Element
Separation of Fixed Length, Fixed Length AL3, Tagged Fixed Length, Use Data
Pattern, or Variable Length Elements Delimited where a length has been
specified.

If this check box is selected, and the element or attribute has a length that is
longer than the length that is specified in the model or the length reference, the
string is truncated to this length. No exception is raised on output, unless
validation (see [Validating messages) is active.

The end from which data is truncated is determined by the value of the
Justification property. If the value of the Justification property is Left justify, data
is truncated from the right; if the value of the Justification property is Right
justify, data is truncated from the left. However, if the value of the Justification
property is Not applicable, truncation does not occur and an exception occurs if
the string is too long.

If this check box is cleared, an exception occurs if the element or attribute is a
fixed length string (that is, the physical type is Text and a length has been
specified) that is longer than either the length that is specified in the model or
the length reference. This behavior occurs in releases of the WebSphere Message
Broker earlier than Version 6.1.

Escape
Character

Button and
String

Specify the escape character that is used to allow special reserved characters
(such as delimiters) to be included as part of data. You must specify a single
character only, or a mnemonic that represents a single character.

Escape characters apply only in variable length fields.

Escape characters, on parsing, always escape the next character, and are always
removed.

Escape characters, on writing, are inserted in front of all the characters that are
listed in Reserved Characters.

You can specify either an escape character or a quote character, but not both, for
a given message set.

Quote
Character

Button and
String

Specify the quote character that is used to allow special reserved characters
(such as delimiters) to be included as part of data. You must specify a single
character only, or a mnemonic that represents a single character.

Quote characters apply only to variable length fields.

Quote characters, on parsing, must be present at both the start and the end of
the data, and are always removed.

Quote characters, on writing, are added to both the start and end of the data, if
the data contains any character that is listed in the Reserved Characters property.

You can specify either an Escape Character or a Quote Character, but not both,
for a given message set.
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Property

Type

Meaning

Reserved
Characters

String

Specify any special reserved characters. Either these reserve characters must be
preceded by the Escape Character, or the data field that contains them must be
delimited by a pair of Quote Characters, if they are to be included as part of the
data. The Escape Character, Quote Character, delimiters, and group indicators
must be included in this list.

If the set of reserved characters is to be updated dynamically (in the case of
EDIFACT and X12 when reserved characters, such as delimiters, are specified in
service strings), you must use the supplied mnemonics to specify characters in
this list.

If you have specified Reserved Characters, an Escape Character or a Quote
Character must also be specified.

Reserved characters apply only in variable length fields.

Reserved characters are not used when parsing.

Numeric settings

Property

Type

Meaning

Decimal Point

String

Specify the character that is used to separate the whole part of a number from
its fraction.

Packed decimal
positive code

String

Controls the positive sign that is used for packed decimal fields.

Valid values are C or E.Specify the character that is used to separate the whole
part of a number from its fraction.

Strict Numeric
Checking

Check box

Use this property in conjunction with the Messaging Standard property, the
Virtual Decimal Point property and the Precision property of an element. Using
this property allows you to apply stricter rules for the checking of numbers.

The rules for Strict Numeric Checking are:

* If the Precision property of an element is set to All Significant Digits , a
decimal separator is present only if the value has a fractional part.

* If the Precision property of an element is set to Explicit Decimal Point, the
decimal separator must always be present, even if the fractional part is
missing.

* If the Precision property of an element is set to Exponential Notation, the
incoming value must be in exponential notation. Exponential notation is only
allowed for floating numbers.

* If the Precision property of an element is set to a specific value, the specific
number of digits after the decimal separator must be present.

+ All values must contain at least one digit in the integer part of the number.

e If a Virtual Decimal Point of an element has been set, the number must not
have a decimal point.

* Except for EDIFACT, the decimal separator can be only the specified value,
and ' is not permitted. For EDIFACT, both . and the specified separator are
permitted. In this case, the decimal separator must be specified as ’,” and the
code permits ".” to be used.

* Except for exponential functions, only digits 0-9, the decimal separator, the
positive sign, and the negative sign are permitted. For exponential functions
the characters ‘e’ and 'E’ are also permitted. Padding characters are permitted
only if they are in a position to be stripped from the number.

164 Message Models




Property Type Meaning
Derive sign Check box If this property is selected, an unset TDS Signed property attempts to derive its
from logical value from the simple type of the element (integer and decimal simple logical
type types only). For these logical types it applies only to the Integer, External
Decimal, and Packed Decimal physical types.
Default byte Enumerated Controls the byte order of numbers that are represented as binary integers for
order messages with no MQMD.
Valid values are Big Endian or Little Endian.
This property stores the default byte order for numbers that are represented as
binary integers for messages with no MQMD, but this value can be overridden
when the message is processed.
Default packed |Enumerated Controls the byte order of numbers that are represented as packed decimal for
decimal byte messages with no MQMD.
order
Valid values are Big Endian or Little Endian.
This property stores the default byte order of numbers that are represented as
packed decimal for messages with no MQMD, but this value can be overridden
when the message is processed.
Default float Enumerated Controls the format of numbers that are represented as float for messages with
format no MQMD.
Valid values are S390, IEEE, or Reverse IEEE.
This property stores the default format of numbers that are represented as float
for messages with no MQMD, but this value can be overridden when the
message is processed.
Representation of boolean values
Property Type Meaning
Text boolean String Specifies the character that represents the text Boolean true value.
true value
Text boolean String Specifies the character that represents the text Boolean false value.
false value
Text boolean String Specifies the character that represents the text Boolean null value.
null value
Binary boolean |String Specifies a hexadecimal value that represents the binary Boolean true value.
true value
Binary boolean |String Specifies a hexadecimal value that represents the binary Boolean false value.
false value
Binary boolean |String Specifies a hexadecimal value that represents the binary Boolean null value.
null value
Datetime settings
Property Type Meaning
Derive default |Button Select this option if you want the default dateTime format to be determined by

dateTime
format from
logical type

the logical type of the element or attribute.

You can override this property for an element or attribute within a complex
type.
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for 2 digit years

Property Type Meaning
Use default Button and Select this option if you want to specify a default dateTime format that is fixed
dateTime String for all elements or attributes of logical type dateTime, date, time, gYear,
format gYearMonth, gMonth, gMonthDay, and gDay.
You can override this property for an element or attribute within a complex
type.
For more information, see [“DateTime formats” on page 765.|
Start of century |Integer This property determines how two-digit years are interpreted. Specify the two

digits that start a 100-year window that contains the current year. For example, if
you specify 89, and the current year is 2002, all two-digit dates are interpreted as
being in the range 1989 to 2088.

Days in First
Week of Year

Enumerated

Specify the number of days of the new year that must fall within the first week.

The start of a year typically falls in the middle of a week. If the number of days
in that week is less than the value specified here, the week is considered to be
the last week of the previous year; therefore, week 1 starts some days into the
new year. Otherwise, it is considered to be the first week of the new year; in this
case, week 1 starts some days before the new year.

Select Use Broker Locale, which causes the broker to get the information from
the underlying platform, or select a number from the list that is displayed.

First Day Of
Week

Enumerated

Specify the day on which each new week starts.

Select Use Broker Locale, which causes the broker to get the information from
the underlying platform, or select a value from the list that is displayed.
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Property

Type

Meaning

Strict DateTime
Checking

Check box

Select this option if you want to restrict dateTimes to a valid dateTime format. If
Strict DateTime Checking is selected, receiving an incorrect dateTime causes an
error.

Strict dateTime checking
Examples of strict dateTime checking are:

* DateTimes are restricted to valid dateTimes only. When you use this
option, a date such as the 35th March is not processed as 4th April,
and 10:79 is not processed as 11:19. Receiving an out-of-band
dateTime, such as these examples, causes an error to occur.

e The number of characters for a numeric dateTime component must
be within the bounds of the corresponding formatting symbols.
Repeat the symbol to specify the minimum number of digits that you
require. The maximum number of digits that are permitted becomes
the upper bound for a particular symbol. For example, day in month
has an upper bound of 31; therefore, a format string of ‘d” allows the
values 2 and 21 to be parsed, but does not allow the values 32 and
210. On output, numbers are padded with zeros to the specified
length. A year is a special case; see the message set property Start of
century for 2 digit years. For fractional seconds, the length must
implicitly match the number of format symbols on input. The output
is rounded to the specified length.

* White space is not skipped over. The white space in the input string
must correspond with the same number and position of white space
in the formatting string.

e If there is still data to be parsed in the input string after all of the
symbols in the formatting string have been matched, an error occurs.

Lenient dateTime checking
Examples of lenient dateTime checking are:

* The parser converts out-of-band dateTime values to the appropriate
in-band value. For example, a date of 2005-05-32 is converted to
2005-06-01.

* Output of dateTimes always adheres to the symbol count. For
example, a formatting string of yyyy-MM-dd (where ’-" is the field
separator) allows one or more characters to be parsed against MM
and dd. Therefore, dates that are not valid - for example, 2005-1-123
and 2005-011-12 - can be input. The first value of 2005-1-123 is output
as the date 2005-05-03, and the second value of 2005-011-12 is output
as the date 2005-11-12.

¢ The number of the timezone formatting symbol Z is only applicable
to the output dateTime format.

¢ White space is skipped over.

Time Zone

Enumerated

The value that you set for this property is used if the value that you specified
for the Default DateTime Format property does not include Time Zone
information.

The initial value is Use Broker Locale, which causes the broker to get the
information from the underlying platform.

You can change this property by selecting from the list of values.

Daylight
Savings Time

Check box

Select this option if the area in the Time Zone property observes Daylight Saving
Time. If it does not observe Daylight Saving Time, do not select this option.

For example, if an area is selected in Time Zone and this option is not selected,
the value passed represents the time zone without the Daylight Saving Time.
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Property Type Meaning
Use input UTC | Check box This property applies to elements and attributes of logical type xsd:dateTime or
format on xsd:time that have a dateTime format of I, IU, T, or TU, or that include ZZZ or
output Z77U.
Such elements and attributes can specify Coordinated Universal Time (UTC) by
using either the Z character or timezone +00:00 in the value. On input, the MRM
parser remembers the way that UTC was specified.
If this property is selected, and the element or attribute is copied to an output
message, the UTC format is preserved into the output message and overrides the
format that is implied by the dateTime format property.
If this property is cleared, or the element or attribute was not copied from an
input message, the UTC format in the output message is controlled solely by the
dateTime format property.
General settings
Property Type Meaning
Output policy | Enumerated Controls whether the default value or null value is used on output for missing
for missing elements.
elements
Valid values are UseDefaultValue or UseNullValue.
Derive default |Check box If this property is selected, an unset TDS Length property attempts to derive its
length from default value from the simple type of the element (string, binary, integer, and
logical type decimal simple logical types only). For these logical types, it applies only to the
Binary, Text, Integer, External Decimal, and Packed Decimal physical types.

TDS Mnemonics

The Tagged/Delimited String Format (TDS) uses mnemonics for a number of
properties for a message set, complex type, or both. These TDS mnemonics and
their associated properties are listed in the following table.

Mnemonic string

Meaning Default value | Associated property

<EDIFACT_CS>

Component separator in Message set and complex type

EDIFACT or group, Delimiter
<EDIFACT_DS> Data element separator in + Message set and complex type
EDIFACT or group, Delimiter

<EDIFACT_TAGDATA_SEP>

Tag data separator in EDIFACT |+ Message set and complex type

or group, Tug Data Separator
This is overridden with the

same value as that which
overrides <EDIFACT_DS>

<EDIFACT_DEC_NOTATION>

Decimal notation in EDIFACT Message set, Decimal Point

<EDIFACT_ESC_CHAR>

Escape character in EDIFACT  |? Message set, Escape Character

<EDIFACT_GROUP_TERM>

~

Tag terminator in EDIFACT Message set, Group Terminator

<X12_GROUP_TERM>

Tag terminator in X12 ! Message set level, Group

Terminator

<X12_DS> Data element separator for X12 |* Message set and complex type
or group, Delimiter

<X12_CS> Component separator for X12 Message set and complex type

or group, Delimiter
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Mnemonic string

Meaning

Default value

Associated property

<HL7_CS> Component separator in HL7 |~ Message set and complex type
or group, Delimiter

<HL7_FS> Data element separator in HL7 | | Message set and complex type
or group, Delimiter

<HL7_RS> Repeating element delimiter in Local element and element

HL7 reference, Repeating Element

Delimiter

<HL7_SCS> Sub-component separator in Message set and complex type

HL7 or group, Delimiter
Mnemonics for control characters are shown in the following table.
Mnemonic Hex Unicode Description
value

<ACK> X'06’ <U+0006> Acknowledge

<BEL> X'07’ <U+0007> Bell

<BS> X'08’ <U+0008> Backspace

<CAN> X'18 <U+0018> Cancel

<CR> X'0D’ <U+000D> Carriage Return

<DC1> X1 <U+0011> Device Control One

<DC2> X12 <U+0012> Device Control Two

<DC3> X138’ <U+0013> Device Control Three

<DC4> X114 <U+0014> Device Control Four

<DLE> X"10 <U+0010> Data Link Escape

<EM> X'19’ <U+0019> End of Medium

<ENQ> X'05’ <U+0005> Enquiry

<EOT> X'04 <U+0004> End of Transmission

<ESC> X"1B’ <U+001B> Escape

<ETB> X117’ <U+0017> End of Transmission Block

<ETX> X'03’ <U+0003> End of Text

<FF> X'oc <U+000C> Form Feed

<FS> X1 <U+001C> File Separator

<GS> X1D’ <U+001D> Group Separator

<GT> X'3E’ <U+003E> Greater Than

<HT> X'09 <U+0009> Horizontal Tabulation

<LF> X'0A’ <U+000A> Line Feed

<LT> X'3C” <U+003C> Less Than

<NAK> X'15 <U+0015> Negative Acknowledge

<NUL> X'00 <U+0000> Null-

<RS> X'1E’ <U+001E> Record Separator

<SI> X'0F <U+000F> Locking Shift Zero (Shift In)

<SO> X'0E’ <U+000E> Locking Shift One (Shift Out)

<SOH> X'01 <U+0001> Start of Heading
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Mnemonic Hex Unicode Description
value

<SP> X220 <U+0020> Space

<STX> X'02 <U+0002> Start of Text

<SUB> X'1A’ <U+001A> Substitute

<SYN> X'16’ <U+0016> Synchronous Idle

<US> X'1F <U+001F> Unit Separator

<VT> X'0B’ <U+000B> Vertical Tabulation
These mnemonics were created for characters that cannot be entered into the
message editor.
You can enter a mnemonic in the form <U+NNNN>, where NNNN are hexadecimal
digits. None of the characters in this structure are case-sensitive. Do not enclose
spaces inside the angle brackets. These numbers represent a Unicode character, not
a character in the code page of the input message.
You can enter a mnemonic in the form <0xNN>, where NN are hexadecimal digits.
None of the characters in this structure are case-sensitive. Do not enclose spaces
inside the angle brackets. These numbers represent a raw hexadecimal byte value,
not a character in the code page of the input message.
If a mnemonic is of the form <0xNN>, it is applied directly to the input data, and no
code page conversion takes place. Otherwise, a mnemonic is applied to the data
after the data has been converted into Unicode from the code page of the input
data.
Default TDS message set properties
The following tables define the defaults for the message set properties for the TDS
Format for each of the industry standard messages that you can define.
For more information about the TDS Format, see [“TDS Format message set|
[properties” on page 160|and [“TDS Mnemonics” on page 168
Default message set property values for TDS (part 1 of 3)

Property Messaging standard = User | Messaging Standard = Messaging standard =

Defined Text SWIFT ACORD AL3

Group Indicator Empty <CR><LF>: Empty

Group Terminator | Empty <CR><LF>- Empty

Delimiter Empty <CR><LF>: Empty

Suppress Absent End of Type End of Type End of Type

Element Delimiters

Tag Data Separator |Empty Empty

Length of Tag Empty Empty Empty

Default CCSID 367 37 367

Trim on input No Trim Trim Both No Trim

Truncate on output |Cleared Cleared Cleared

Escape Character Chosen - empty Chosen - empty Chosen - empty
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Property

Messaging standard = User
Defined Text

Messaging Standard =
SWIFT

Messaging standard =
ACORD AL3

Quote character Not chosen Not chosen Not chosen
Reserved Characters | Empty Empty Empty
Decimal Point ,

Packed decimal C Not applicable Not applicable
positive code

Strict Numeric Cleared Selected Selected
Checking

Derive sign from Selected Not applicable Not applicable
logical type

Default byte order |Big Endian Not applicable Not applicable
Default packed Big Endian Not applicable Not applicable
decimal byte order

Default float format |S390 Not applicable Not applicable
Text boolean true 1 1 Y

value

Text boolean false |0 0 N

value

Text boolean null 0 0 N

value

Binary boolean true | 00000001 Not applicable Not applicable
value

Binary boolean false | 00000000 Not applicable Not applicable
value

Binary boolean null | 00000000 Not applicable Not applicable
value

Derive default Chosen Chosen Chosen

dateTime format
from logical type

Use default
DateTime Format'

Not chosen, but

yyyy-MM-
dd’'T"HH:mm:ssZZZ if chosen

Not chosen, but

yyyy-MM-
dd’'T"HH:mm:ssZZZ if chosen

Not chosen, but

yyyy-MM-
dd’'T"HH:mm:ssZZZ if chosen

Start of century for
2 digit years

53

80

53

Days in First Week
of Year

Use Broker Locale

Use Broker Locale

Use Broker Locale

First Day of Week

Use Broker Locale

Use Broker Locale

Use Broker Locale

Strict Datetime Selected Selected Selected
Checking

Time Zone Use Broker Locale Use Broker Locale Use Broker Locale
Daylight Savings Cleared Cleared Cleared

Time

Use input UTC Cleared Cleared Cleared

format on output

Output policy for | UseDefaultValue UseDefaultValue UseDefaultValue

missing elements
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Property Messaging standard = User | Messaging Standard = Messaging standard =
Defined Text SWIFT ACORD AL3
Derive default Selected Selected Selected

length from logical

type

Default message set property values for TDS (part 2 of 3)

<EDIFACT_ESC_CHAR>

Property Messaging standard = Messaging Standard = X12 Messaging standard = TLOG
EDIFACT

Group Indicator Empty Empty Empty

Group Terminator | <EDIFACT_GROUP_TERM> | <X12_GROUP_TERM> Empty

Delimiter <EDIFACT_CS> <X12_CS>

Suppress Absent End of Type End of Type End of Type

Element Delimiters

Tag Data Separator | <EDIFACT_TAGDATA_SEP> |Empty Empty

Length of Tag Empty Empty Empty

Default CCSID 367 367 367

Trim on input Trim Both Trim Both No Trim

Truncate on output |Cleared Cleared Cleared

Escape Character Chosen - Chosen - empty Chosen - empty

Quote character

Not chosen

Not chosen

Not chosen

Reserved Characters

<EDIFACT_ESC_CHAR>
<EDIFACT_TAGDATA_SEP>
<EDIFACT_GROUP_TERM>
<EDIFACT_CS>

Empty

Empty

Decimal Point

<EDIFACT_DEC_NOTATION>| .

Packed decimal
positive code

Not applicable

Not applicable

Not applicable

Strict Numeric
Checking

Selected

Selected

Cleared

Derive sign from
logical type

Not applicable

Not applicable

Not applicable

Default byte order

Not applicable

Not applicable

Not applicable

Default packed
decimal byte order

Not applicable

Not applicable

Not applicable

Default float format

Not applicable

Not applicable

Not applicable

value

Text boolean true 1 1 1
value
Text boolean false 0 0 0
value
Text boolean null 0 0 0

Binary boolean true
value

Not applicable

Not applicable

Not applicable

Binary boolean false

value

Not applicable

Not applicable

Not applicable
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Property Messaging standard = Messaging Standard = X12 Messaging standard = TLOG
EDIFACT

Binary boolean null |Not applicable Not applicable Not applicable

value

Derive default Chosen Chosen Chosen

dateTime format
from logical type

Use default
DateTime Format'

Not chosen, but

yyyy-MM-
dd’'T’"HH:mm:ssZZZ if chosen

Not chosen, but
yyyy-MM-
dd’'T’"HH:mm:ssZZZ if chosen

Not chosen, but
yyyy-MM-

dd’'T"HH:mm:ssZZZ if chosen

Start of century for
2 digit years

53

53

53

Days in First Week
of Year

Use Broker Locale

Use Broker Locale

Use Broker Locale

First Day of Week

Use Broker Locale

Use Broker Locale

Use Broker Locale

Strict Datetime Selected Selected Selected
Checking

Time Zone Use Broker Locale Use Broker Locale Use Broker Locale
Daylight Savings Cleared Cleared Cleared

Time

Use input UTC Cleared Cleared Cleared

format on output

Output policy for | UseDefaultValue UseDefaultValue UseDefaultValue
missing elements

Derive default Selected Selected Selected

length from logical
type

Default message set property values for TDS (part 3 of 3)

Property Messaging standard = HL7 Messaging Standard = CSV | Messaging standard = User
Defined Mixed

Group Indicator Empty Empty Empty
Group Terminator | <CR> Empty Empty
Delimiter <HL7_FS> , Empty
Suppress Absent End of Type Never End of Type
Element Delimiters
Tag Data Separator |<HL7_FS> Empty Empty
Length of Tag Empty Empty Empty
Default CCSID 367 367 850
Trim on input No Trim No Trim Trim Padding Chars
Truncate on output |Cleared Cleared Cleared
Escape Character Chosen - empty Not chosen Chosen - empty
Quote character Not chosen Chosen - " Not chosen
Reserved Characters | Empty , Empty

<CR>

<LF>

"
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Property

Messaging standard = HL7

Messaging Standard = CSV

Messaging standard = User
Defined Mixed

Decimal Point

dateTime format
from logical type

Packed decimal Not applicable C C
positive code

Strict Numeric Cleared Cleared Cleared
Checking

Derive sign from Not applicable Selected Selected
logical type

Default byte order |Not applicable Big Endian Big Endian
Default packed Not applicable Big Endian Big Endian
decimal byte order

Default float format | Not applicable 5390 5390
Text boolean true 1 1 1

value

Text boolean false |0 0 0

value

Text boolean null 0 0 0

value

Binary boolean true |Not applicable 00000001 00000001
value

Binary boolean false | Not applicable 00000000 00000000
value

Binary boolean null |Not applicable 00000000 00000000
value

Derive default Not chosen Chosen Chosen

Use default

Chosen - yyyy-MM-

Not chosen - but

Not chosen - but

2 digit years

DateTime Format' | dd'T'HH:mm:ssZZZ yyyy-MM- yyyy-MM-
dd’'T"HH:mm:ssZZZ if chosen |dd'T"HH:mm:ssZZZ if chosen
Start of century for |53 53 53

Days in First Week
of Year

Use Broker Locale

Use Broker Locale

Use Broker Locale

First Day of Week

Use Broker Locale

Use Broker Locale

Use Broker Locale

length from logical
type

Strict Datetime Selected Selected Selected

Checking

Time Zone Use Broker Locale Use Broker Locale Use Broker Locale
Daylight Savings Cleared Cleared Cleared

Time

Use input UTC Cleared Cleared Cleared

format on output

Output policy for | UseDefaultValue UseDefaultValue UseDefaultValue
missing elements

Derive default Selected Selected Selected
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Default complex type/group property values for TDS (part 1 of 3)

Property

Messaging standard = User
Defined Text

Messaging standard = SWIFT

Messaging standard =
ACORD AL3

Data Element

Fixed Length

Tagged Delimited

Fixed Length AL3

Separation

Group Indicator Empty <CR><LF>: Empty

Group Terminator | Empty <CR><LF>- Empty
Delimiter Empty <CR><LF>: not applicable
Suppress Absent End of Type End of Type End of Type
Element Delimiters

Observe Element Selected Cleared Selected
Length

Tag Data Separator |Empty Empty
Length of Tag Empty Empty Empty

Length of Encoded
Length

not applicable

not applicable

not applicable

Extra Chars in
Encoded Length

not applicable

not applicable

not applicable

Default complex type/group property values for TDS (part 2 of 3)

Property

Messaging standard =
EDIFACT

Messaging standard = X12

Messaging standard = TLOG

Data Element

All Elements Delimited

All Elements Delimited

Fixed length

Separation

Group Indicator Empty Empty Empty
Group Terminator | <EDIFACT_GROUP_TERM> | <X12_GROUP_TERM> Empty
Delimiter <EDIFACT_CS> <X12_CS>

Suppress Absent End of Type End of Type End of Type
Element Delimiters

Observe Element Cleared Cleared Cleared
Length

Tag Data Separator | <EDIFACT_TAGDATA_SEP> |Empty Empty
Length of Tag Empty Empty Empty

Length of Encoded
Length

not applicable

not applicable

not applicable

Extra Chars in
Encoded Length

not applicable

not applicable

not applicable

Default complex type/group property values for TDS (part 3 of 3)

Property

Messaging standard = HL7

Messaging standard = CSV

Messaging standard = User
Defined Mixed

Data Element

All Elements Delimited

All Elements Delimited

Fixed Length

Separation
Group Indicator Empty Empty Empty
Group Terminator | <CR> Empty Empty
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Property Messaging standard = HL7 Messaging standard = CSV | Messaging standard = User
Defined Mixed

Delimiter <HL7_FS> p Empty

Suppress Absent End of Type Never End of Type

Element Delimiters

Observe Element Cleared Cleared Selected

Length

Tag Data Separator |<HL7_FS> not applicable Empty

Length of Tag Empty not applicable Empty

Length of Encoded
Length

not applicable

not applicable

not applicable

Extra Chars in
Encoded Length

not applicable

not applicable

not applicable

XML Wire Format message set properties
The following tables define the properties for the XML Wire Format for the

message set.

Namespace settings

Property

Type

Meaning

Namespace URI | String

Enter the name of the namespace that you are using for the associated prefix.

Prefix String Enter the prefix to associate the element and attribute names that you use it with
to the namespace name.
Namespace schema locations
Property Type Meaning

Namespace URI | String

Enter the namespace name that identifies which namespace you are using.

Schema location | String

Enter the location of the schema for the associated namespace name that is used
to validate objects within the namespace.

XML declaration

Property Type Meaning
Suppress XML | Check box Select the check box to suppress the XML declaration. If selected, the declaration
Declaration (for example, <?xm1 version="1.0">) is suppressed.

By default, the check box is cleared.
XML Version Enumerated This controls the value of the version in the generated XML declaration.

type ,
The default is 1.0.
If you set Suppress XML Declaration to Yes, this property is ignored.
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Property

Type

Meaning

XML Encoding

Enumerated

type

This controls whether an encoding attribute is written in the generated XML
declaration.

If Null is selected, no encoding attribute is written in the XML declaration of the
output XML document.

If As document text is selected, an encoding attribute is generated that is
consistent with the text in the XML document.

The default is Null.

If the Suppress XML Declaration check box is selected, this property is ignored.

Standalone
Document

Enumerated

type

Select Yes, No, or Null from the list of values. If you select Nul1, no standalone
declaration is present in the XML declaration. If you select Yes or No, the
declaration standalone = "yes” or standalone = "no” is added to the XML
declaration when the output message is written. The default value is Nul1.

The setting of this property does not determine whether an external DTD subset
is loaded; external DTD subsets are never loaded in this release.

If the Suppress XML Declaration check box is selected, this property is ignored.

Output
Namespace
Declaration

Enumerated

type

The Output Namespace Declaration property controls where the namespace
declarations are placed in the output XML document. Select from:

e At start of document. Declarations for all of the entries in the Namespace
schema locations table above are output as attributes of the message in the
output XML document. The disadvantage of this option is that, in some cases,
unnecessary declarations might be output.

* As required. Declarations are output only when required by an element or
attribute that is in that namespace. The disadvantage of this option is that the
same namespace declaration might need to be output more than once in the
output XML document.

The default option is At start of document.

This property is active only if namespaces are enabled for this message set.

XML document type settings

Property

Type

Meaning

Suppress
DOCTYPE

Check box

If you select the check box, the DOCTYPE (DTD) declaration is suppressed.

By default, the check box is selected.

DOCTYPE
System 1D

String

Specify the System ID for DOCTYPE external DTD subset (if DOCTYPE is
present). This is typically set to the name of the generated (or imported) DTD
for a message set.

If Suppress DOCTYPE is set, this property is ignored and cannot be changed (the
field is disabled). The default value is www.mrmnames.net/, followed by the
message set identifier.

DOCTYPE
Public ID

String

Specify the Public ID for DOCTYPE external DTD subset (if DOCTYPE is
present, and System ID is specified).

If Suppress DOCTYPE is set, this property is ignored and cannot be changed (the
field is disabled). The default value is the message set identifier.
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Property Type Meaning
DOCTYPE Text |String Use this property to add additional DTD declarations. It is not parsed by the
XML parser and, therefore, it might not be valid XML. You can include ENTITY
definitions or internal DTD declarations. It is a string (up to 32 KB) in which
new line and tab characters are replaced by \n and \t respectively.
The content is not parsed, and appears in the output message. If there is an
in-line DTD, the content of this property takes precedence.
If you have set Suppress DOCTYPE, this property is ignored and cannot be
changed (the field is disabled).
For more information, see [“MRM XML: In-line DTDs and the DOCTYPE text]
[property” on page 182
The default value is empty (not set).
XML representation of Boolean values
Property Type Meaning
Boolean True String Specify the string that is used to encode and recognize BOOLEAN true values.
Value When an XML document is parsed, the string 1 is always accepted as true for a
BOOLEAN element. Enter a string of up to 254 characters.
The default is true. 1 is also valid.
Boolean False |String Specify the string that is used to encode and recognize BOOLEAN false values.
Value When an XML document is parsed, the string 0 is always accepted as false for a
BOOLEAN element. Enter a string of up to 254 characters.
The default is false. 0 is also valid.
XML representation of null values
Property Type Meaning
Encoding Enumerated Specify the null encoding for numeric XML elements. This provides a method of
Numeric Null | type assigning a logical null meaning to such elements. You must select one of the

following values from the list shown:

* NULLEmpty. If the element value is the empty string, the element is null. This is
the default value.

* NULLValue. If the element value matches that provided by associated property
Encoding Numeric Null Value, the element is null.

* NULLXMLSchema. If the element contains an xsi:nil attribute that evaluates to
true, the element is null.

* NULLValueAttribute. This option is valid only for elements that have XML
Wire Format property Render set to either XMLElementAttrVal or
XMLETementAttrIDVal. See["XML Null handling options” on page 733 for
details.

* NULLAttribute (deprecated). If the element contains an attribute with a name
that matches that provided by associated property Encoding Numeric Null
Value, and the attribute evaluates to true, the element is null.

* NULLETement (deprecated). If the element contains a child element with a name
that matches that provided by associated property Encoding Numeric Null
Value, the element is null.

See ["XML Null handling options” on page 733| for full details.
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Property Type Meaning
Encoding String Specify the value to qualify the Encoding Numeric Null property, if you have set
Numeric Null that to NULLValue, NULLAttribute, or NULLE]ement. Refer to|“XML Null handling|
Value [options” on page 733 for further information.
Encoding Enumerated Specify the null encoding for non-numeric XML elements. This provides a
Non-Numeric |type method of assigning a logical null meaning to such elements. The options are
Null identical to those available for property Encoding Numeric Null.
Encoding String Specify the value to qualify the Encoding Non-Numeric Null property. Refer to
Non-Numeric [“XML Null handling options” on page 733| for further information.
Null Value
DateTime settings
Property Type Meaning
Derive default |Button Select this option if you want the default dateTime format to be determined by
dateTime the logical type of the element or attribute.
format from
logical type You can override this property for an element or attribute within a complex
type.
Use default Button and Select this option if you want to specify a default dateTime format that is fixed
dateTime String for all elements or attributes of logical type dateTime, date, time, gYear,
format gYearMonth, gMonth, gMonthDay, and gDay.
You can override this property for an element or attribute within a complex
type.
For more information, see ["DateTime formats” on page 765
Start of century |Integer This property determines how two-digit years are interpreted. Specify the two
for 2 digit years digits that start a 100-year window that contains the current year. For example, if
you specify 89, and the current year is 2002, all two-digit dates are interpreted as
being in the range 1989 to 2088.
Days in First Enumerated Specify the number of days of the new year that must fall within the first week.
Week of Year
The start of a year typically falls in the middle of a week. If the number of days
in that week is less than the value specified here, the week is considered to be
the last week of the previous year; therefore, week 1 starts some days into the
new year. Otherwise, it is considered to be the first week of the new year; in this
case, week 1 starts some days before the new year.
Select Use Broker Locale, which causes the broker to get the information from
the underlying platform, or select a number from the list that is displayed.
First Day Of Enumerated Specify the day on which each new week starts.

Week

Select Use Broker Locale, which causes the broker to get the information from
the underlying platform, or select a value from the list that is displayed.
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Property

Type

Meaning

Strict DateTime
Checking

Check box

Select this option if you want to restrict dateTimes to a valid dateTime format. If
Strict DateTime Checking is selected, receiving an incorrect dateTime causes an
error.

Strict dateTime checking
Examples of strict dateTime checking are:

* DateTimes are restricted to valid dateTimes only. When you use this
option, a date such as the 35th March is not processed as 4th April,
and 10:79 is not processed as 11:19. Receiving an out-of-band
dateTime, such as these examples, causes an error to occur.

e The number of characters for a numeric dateTime component must
be within the bounds of the corresponding formatting symbols.
Repeat the symbol to specify the minimum number of digits that you
require. The maximum number of digits that are permitted becomes
the upper bound for a particular symbol. For example, day in month
has an upper bound of 31; therefore, a format string of ‘d” allows the
values 2 and 21 to be parsed, but does not allow the values 32 and
210. On output, numbers are padded with zeros to the specified
length. A year is a special case; see the message set property Start of
century for 2 digit years. For fractional seconds, the length must
implicitly match the number of format symbols on input. The output
is rounded to the specified length.

* White space is not skipped over. The white space in the input string
must correspond with the same number and position of white space
in the formatting string.

e If there is still data to be parsed in the input string after all of the
symbols in the formatting string have been matched, an error occurs.

Lenient dateTime checking
Examples of lenient dateTime checking are:

* The parser converts out-of-band dateTime values to the appropriate
in-band value. For example, a date of 2005-05-32 is converted to
2005-06-01.

* Output of dateTimes always adheres to the symbol count. For
example, a formatting string of yyyy-MM-dd (where ’-" is the field
separator) allows one or more characters to be parsed against MM
and dd. Therefore, dates that are not valid - for example, 2005-1-123
and 2005-011-12 - can be input. The first value of 2005-1-123 is output
as the date 2005-05-03, and the second value of 2005-011-12 is output
as the date 2005-11-12.

¢ The number of the timezone formatting symbol Z is only applicable
to the output dateTime format.

¢ White space is skipped over.

Time Zone

Enumerated

The value that you set for this property is used if the value that you specified
for the Default DateTime Format property does not include Time Zone
information.

The initial value is Use Broker Locale, which causes the broker to get the
information from the underlying platform.

You can change this property by selecting from the list of values.

Daylight
Savings Time

Check box

Select this option if the area in the Time Zone property observes Daylight Saving
Time. If it does not observe Daylight Saving Time, do not select this option.

For example, if an area is selected in Time Zone and this option is not selected,
the value passed represents the time zone without the Daylight Saving Time.
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Property Type Meaning
Use input UTC | Check box This property applies to elements and attributes of logical type xsd:dateTime or
format on xsd:time that have a dateTime format of I, IU, T, or TU, or that include ZZZ or
output Z77U.
Such elements and attributes can specify Coordinated Universal Time (UTC) by
using either the Z character or timezone +00:00 in the value. On input, the MRM
parser remembers the way that UTC was specified.
If this property is selected, and the element or attribute is copied to an output
message, the UTC format is preserved into the output message and overrides the
format that is implied by the dateTime format property.
If this property is cleared, or the element or attribute was not copied from an
input message, the UTC format in the output message is controlled solely by the
dateTime format property.
xsi:type settings
Property Type Meaning
Output policy | Enumerated When writing XML documents, this property allows you to specify the
for xsi:type type circumstances under which the xsi:type attribute of elements will be output.
attributes

Never Do not output xsi:type attributes for elements, even if xsi:type attributes

appear in the message tree.

When present
Output xsi:type attributes for elements only when xsi:type attributes
appear in the message tree. This is the default value.

Always (Simple elements only)
Ensure that all simple elements are output with an xsi:type attribute. If
a simple element already has an xsi:type attribute in the message tree it
will be used, otherwise an xsi:type attribute will be generated using the
rules in the table below.

Always (All elements)
Ensure that all elements are output with an xsi:type attribute if possible
to do so. If an element already has an xsi:type attribute in the message
tree it will be used, otherwise an xsi:type attribute will be generated
using the rules in the table below.

Follow SOAP Encoding rules
Follow the same behaviour as for Always (Simple elements only).
Additionally, output a SOAP encoding-style attribute within the root tag
of all messages.

If an xsi:type attribute needs to be output, but does not appear in the message tree,
its value will be generated as follows:

Element type

Value generated when element is
defined in model

Value generated when element is
self-defining

Simple type

If the type is global or is a built-in
type, use it.

If the type is local, use the global or
built-in type from which it is derived.

Use the built-in type which best
matches the data type of the element
in the message tree.
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Element type

Value generated when element is
defined in model

Value generated when element is
self-defining

Complex type with simple content

If the type is global use it.

If the type is local, use the global or
built-in type from which it is derived.

Use the built-in type which best
matches the data type of the element
in the message tree.

Complex type with complex content

If the type is global use it.

If the type is local, no xsi:type
attribute is output.

No xsi:type attribute is output.

Deprecated

Note: The following properties are used to control behavior of the MRM parser;
they should not be changed from their default settings. These properties will
be withdrawn in a future release.

Property Type

Meaning

Root Tag Name | String

The default value is blank.

Specify the name of the message set root tag. You can leave this property blank,
in which case no wrapper tags are used for messages (that is, the message tag is
the root of the document). The name can be followed by a space and additional
text for attribute/value pairs to appear with the root tag.

Suppress Check box
Timestamp

Comment

If selected, the timestamp comment string in the XML output is suppressed.

If not selected, the comment is not suppressed, and a comment of the form
<!--MRM Generated XML Output on: Tue Apr 23 09:34:42 2002--> is included in
the output message.

The default is for the check box to be selected.

Enable Check box
Versioning

Support

If this is selected, versioning support is enabled. This property specifies whether
XML namespace definitions are coded for the root tag in the message, together
with namespace qualifiers for any elements that do not belong to the default
namespace. These namespace definitions are used to represent the message set
dependency information, which is used to support the exchange of messages
between applications that are based on different customizations of the same
message set.

The default is for the check box to be selected, for compatibility with MRM XML
messages in earlier releases. If you did not use MRM XML messages in earlier
releases, you should ensure that this check box is not selected.

MRM XML: In-line DTDs and the DOCTYPE text property

You can include in-line DTDs in your messages, and you can specify additional
information by setting the property DOCTYPE Text, but you must be aware of the
action taken by the parser when it constructs an output message:

1. If you take any action that causes the output message to be regenerated, for
example if you configure a Compute node to create a new output message by
coding ESQL statements like SET OutputRoot.MRM.Fieldl = xxx:

 If you have set the property Suppress DOCTYPE for the message set in which
you have defined this message to Yes, both DOCTYPE information (specified
in the DOCTYPE Text property for the message set or message) and in-line
DTD are excluded from the output message.
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 If you have set the property Suppress DOCTYPE for the message set in which
you have defined this message to No.

— The in-line DTD is preserved if possible.

— Otherwise, if the message is self-defining, the message set DOCTYPE Text
property information is included in the output message.

— Otherwise (the message is not self-defining), the message level DOCTYPE
Text property information is included in the output message.

2. If you do not take any action that causes the output message to be regenerated,
the parser generates an output message that is a direct copy of the input
message. This occurs if you have configured a Compute node in the message
flow to copy the message using SET OutputRoot = InputRoot (explicitly, or by
checking the Copy entire message check box), and you do not modify the
message in any way in this or any other node. In this case the in-line DTD is
retained in the output message but any information that you specify in the
DOCTYPE Text property for the message set or message is not included.

Documentation properties for a message set

Property Type Meaning

Version String This field allows you to enter a version for the message set. This allows the
version of the message set to be displayed using the Eclipse properties view.
A default for this field can be set in the message set preferences.

Documentation | String The documentation property of a message set is where you can add information

to enhance the understanding of the message set’s function.
It is a string field and any standard alphanumeric characters can be used.

You can also use this field to define a keyword and its value that will display for
the deployed message set in the properties view of Eclipse. An example is:

$MQSI Author=Fred MQSI$

When the properties of the deployed message set are displayed, this will add a
row to the display showing Author as the property name and ‘Fred’ as its value.

Message definition file properties

Namespace
Property Type Meaning
Prefix String The namespace prefix for the target namespace of this file. This field cannot be
changed after the message definition file has been created.
Target String The target namespace for the message definition file. All global objects created
Namespace within the file will have this namespace by default. This field cannot be changed
after the message definition file has been created.
Default namespaces for local objects
Property Type Meaning
Elements String The default namespace for all local elements within this message definition file.
Attributes String The default namespace for all local attributes within this message definition file.
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Property Type Meaning
Default block | String and The default value for the block attribute for all complex types and elements
Enumerated within this message definition file.
type
Default final String and The default value for the final attribute for all complex types and elements
Enumerated within this message definition file.
type
Property Type Meaning
Use xml.xsd Check box Select this check box if you need to use the xml.xsd schema. When you select
schema this check box, the http:/ /www.w3.0rg/2001/xml.xsd schema is imported and
you can use any of the constructs in that schema.
Note: The full text that describes this check box is Use http://www.w3.0rg/2001/
xml.xsd schema.
Message definition file includes properties
Property Type Meaning
Schema String For each message definition file that has been included in this message
Location definition file, this field displays its location. The location is displayed as a
relative path from the message definition file to the included file.
Message definition file imports properties
Property Type Meaning
Schema String For each message definition file that has been imported into this message
Location definition file, this field displays its location. The location is displayed as a
relative path from the message definition file to the imported file.
Prefix String Displays the namespace prefix for each imported message definition file.
Namespace String Displays the namespace URI for each imported message definition file.
Message definition file redefines properties
This provides details of the properties associated with message definition redefines.
Property Type Meaning
Schema String For each message definition file that has been redefined in this message
Location definition file, this field displays its location. The location is displayed as a

relative path from the message definition file to the included file.

Note: Redefines are not supported and will result in a validation error. If you
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Documentation properties for all message set objects

Use the documentation property of an object to add information to enhance the
understanding of the function of that object. The documentation property is
available on all objects except Key, Keyref, and Unique objects.

The property is a string field and you can use any standard alphanumeric
characters.

Message category properties

A message category provides a way of grouping your messages.

The following table describes the properties that are associated with a message

category:
Property Type Meaning
Category Kind | Enumerated This property describes the purpose of the message category.
type

Choose from:

* wsdl. This is the default. Choose this value if the message category is to
participate in the generation of WSDL documents. When the WSDL document
is generated, the name of the message category provides the name for the
<wsdl:operation> element that is generated for eligible messages in the
message category.

Note: Message categories are no longer necessary for the generation of WSDL
documents; they were necessary in Version 6.0.

 other. This value ndicates that the category represents a generic grouping of
messages as an aid to organizing them in your workspace.

Category Usage | Enumerated Use this property to describe the operation type for a WSDL operation.
type

Choose from:

* wsdlirequest-response. This is the default if Category Kind is wsdl.

* wsdl:solicit-response.

* wsdl:one-way.

* wsdlnotification.

* empty string. This is the default if Category Kind is other.

Documentation |String Use this property to add information to enhance the understanding of an object’s
function.

This property is a string field; any standard alphanumeric characters can be

used.

If Category Kind is wsdl, the value of the field is included in any generated

WSDL as the wsdl:documentation child of the operation element in the WSDL

portType.

If Category Kind is other, the value of the field merely documents the Message

Category within your workspace.

Message category member properties
This describes the properties that are associated with a message category member.
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Property Type Meaning

Role Name String If Category Kind is wsdl, the value of the property becomes the WSDL message
part name and must be unique within the category. It always defaults to the
message name.
If Category Kind is other, the value of the property has no particular
significance.

Role Type Enumerated This property determines the role that the message plays in the message

type category.

Select from:
e wsdl:input
e wsdl:output
e wsdl:return
e wsdl:fault
e empty string
If Category Kind is wsdl, the default value is wsdl:input. This property dictates
the role within a WSDL operation. The value wsdl:return implies wsdl:output,
but for rpc-style WSDL generation it also identifies the message part that is used
as the return value and in this instance can be omitted from the parameterOrder
attribute. No more than one message can have Role Type of wsdl:return.
If Category Kind is other, the value defaults to an empty string and this
property has no role in the message category.

Role Usage Enumerated This property determines the role that the message plays in the SOAP binding.

type

Select from:
* soap:body
e soap:header
* soap:fault
* soap:headerfault
* empty string
If Category Kind is wsdl, this property defaults to soap:body and dictates the
SOAP-binding child of the WSDL input, output, or fault element.
If Category Kind is other, this property is deactivated.

Documentation |String This is a string property; any standard alphanumeric characters can be used.

If Category Kind is wsdl, the value of the property is included in any generated
WSDL as the wsdl:documentation child of the WSDL input, output, or fault
element under the WSDL portType.

If Category Kind is other, the value merely documents the Message Category
within your workspace.

Message model object properties

There are two ways of accessing the reference information for the properties of
message model objects. The following topics allow you to access the property
information by property kind:

+ [“Logical properties for message model objects” on page 187

* |“Physical properties for message model objects” on page 216|
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+ [“Documentation properties for all message set objects” on page 185|

Alternatively, you can access the property information by object, starting from:

+ [“Message model object properties by object” on page 247

Deprecated objects are dealt with separately. For further information, see

eprecated message model object properties” on page
"“Dep d g del object properties” on page 600

Logical properties for message model objects

Logical property information is available for the following objects:

+ [“Attribute group reference logical properties”|

[“Attribute reference logical properties”]

+ [“Complex type logical properties” on page 188

[“Element reference logical properties” on page 192|

[Global attribute logical properties” on page 193|

[‘Global attribute group logical properties” on page 196|

[‘Global element logical properties” on page 197]

[“Global group logical properties” on page 200|

[‘Group reference logical properties” on page 202|

+ [“Key logical properties” on page 202|

[‘Keyref logical properties” on page 202|

[‘Local element logical properties” on page 206|

* [“Local group logical properties” on page 210)|

* ["Message logical properties” on page 212

+ [“Simple type logical properties” on page 213|

* [“Unique logical properties” on page 214|

[“Wildcard attribute logical properties” on page 214|

[“Wildcard element logical properties” on page 215|

Attribute group reference logical properties

Property

Type

Meaning

Reference Name | Enumerated The Reference Name is the name of the object that this object is referring to. The
type objects available to reference can be selected from the drop-down list.
Attribute reference logical properties
Property Type Meaning

Reference Name

Enumerated

type

The Reference Name is the name of the object that this object is referring to. The
objects available to reference can be selected from the drop-down list.
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Property

Type

Meaning

Usage

Enumerated

type

The usage property is used in conjunction with the Value property found in an
attribute object. The default for the Usage property is optional.

Select from;
e optional.

— Where the Value property is set to default and no data has been entered in
the Value property, the attribute can appear once and can have any value.

— Where the Value property is set to default, the attribute can appear once. If
it does not appear, its value is the data that has been entered in the Value
property. If it does appear it is the value given.

— Where the Value property is set to fixed, the attribute can appear once. If it
does appear, its value must match the data that has been entered in the
Value property. If it does not appear its value is the data that has been
entered in the Value property.

* prohibited. The attribute must not appear.
* required.

— Where the Value property is set to default and no data has been entered in
the Value property, the attribute must appear once and can have any value.

— Where the Value property is set to fixed, the attribute must appear once
and it must match the data that has been entered in the Value property.

Complex type logical properties

Property

Type

Meaning

Name

String

Specify a name for the object when you create it.

Names can consist of virtually any alphanumeric character including the letters
A through Z, a through z and the digits 0 through 9.

They may also include the following punctuation characters;
* - the hyphen

* _ the underscore

* . the period

Names can only start with a letter or the underscore character and not with a
number, hyphen or period.

Names beginning with xml or any variant (for example XmL) are reserved by the
XML standards specification.

Further details of naming conventions and allowable characters can be found in
the [Extensible Markup Language (XML)| specification that can be found on the
[World Wide Web Consortium (W3C)| Web site.

Base Type

Enumerated

type

You can use this property to select a type (simple or complex) that is used as the
starting point to define a new complex type that is derived by restriction or
extension.

Derived By

Enumerated

type

If this property is active, select from;

e restriction. If a complex type is derived by restriction, the content model of
the complex type is a subset of the base type.

* extension. If the complex type is derived by extension, the content model of
the complex type is the content model of the base type plus the content model
specified in the type derivation.

Derivation by list or union is not supported.
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Content

The table

below shows the valid settings for Composition and Content Validation.

These properties are actually located on the group which defines the content of this
type. They can only be edited if the Local group button is selected. If the Global
group button is selected, these properties are taken from the global group identified
by the Group name field.

Valid children in a complex type that depend on both Composition and Content

Validation are shown in [“MRM content validation” on page 191}
Property Type Meaning
Local Group Button You should select this if the content of your complex type is a local group.
Composition Enumerated Define the order, and the number of occurrences, of the elements and groups in
type your messages. Composition does not affect the attributes in a complex type.

Select from:

* Empty

* sequence. If you select this option, you can define members that are elements
or groups. These members, if present, must appear in the specified order in

the message. They can repeat, and the same element or group can appear
more than once.

* choice. If you select this option, you can define members that are elements or
groups. Exactly one of the defined members must be present in the message,
and can repeat.

Use this option if you want to model C unions and COBOL REDEFINES in a
Custom Wire Format, or an XML DTD element that uses choice in an XML
Wire Format, or a SWIFT field that has more than one option.

+ all. If you select this option, you can define members that are elements;
groups are not allowed. The elements in an all group can appear in any
order. Each element can appear once, or not at all. An all group can only be
used at the top level of a complex type - it cannot be a member of another
group within a type.

* unorderedSet.

This option is supported only by the MRM domain.If you select this option,
you can define members that are elements. The elements can repeat but the
same element cannot appear twice in the list of members. The elements can
appear in any order in the message.

¢ orderedSet.

This option is supported only by the MRM domain.If you select this option,
you can define members that are elements. The elements can repeat, but the
same element cannot appear twice in the list of members. The elements must
appear in the specified order in the message.

* message.

This option is supported only by the MRM domain.If you select this option,
you can define only messages as members. Each member can repeat, but the
same message cannot appear twice in the list of members. Like choice, only
one of the defined members can be present in a message.

Unlike choice, when writing a message, if the complex type or group has
more than one member, the bit stream is not padded to the length of the
longest member.

Use this option to model multipart messages, which are used in some
industry standards, for example, SWIFT. For more information, see the section
on multipart messages in [“Multipart messages” on page 25
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Property

Type

Meaning

Content
Validation

Enumerated

type

Content Validation is used only by the MRM domain. If validation is enabled in
your message flow, Content Validation specifies the strictness of the MRM
validation for members of a complex type or group. See
[validation” on page 191 for further details.

Options:
* Closed. The complex type can only contain the child elements that you have
added to it.

* Open Defined. The complex type can contain any valid element defined within
the message set.

* Open. The complex type can contain any valid element, not just those that you
have added to this complex type.

See [“Combinations of Composition and Content Validation” on page 295| for
further details of these options.

Group
Reference

Button

You should select this if the content of your complex type is a reference to a
group object

Group Name

Enumerated

type

The Group Name is the name of the group that this complex type is referring to.
The groups available to be referenced can be selected from the drop down list.

Min Occurs

Integer

Specify the minimum number of times that the object can repeat. The default is
1.

If the value is set to 0, then the object is optional.

With the exception of Max Occurs being set to -1, if a value is set for Min Occurs,
it must be less than or equal to the value in Max Occurs.

Max Occurs

Integer

Specify the maximum number of times that the object can repeat. The default is
1.

If this property is not set, then the object can not occur more than once.

If this property is set to 0, it is interpreted as if the object does not exist in the
message.

It can also be set to -1 to indicate that the limit is unbounded and there is no
maximum to the number of occurrences.

Mixed

Check box

Select this where the complex type has mixed content and contains character
data alongside sub-elements.

Substitution settings

Property

Type

Meaning

Final

Multiple
selection
enumerated

type

The final attribute on a complex type controls whether other types may be
derived from it. Valid values are extension/restriction/all. You can select from
one or more of the following;:

* Empty
* restriction. Prohibit type substitution by elements whose types are
restrictions of the head element’s type.

» extension. Prohibit type substitution by elements whose types are extensions
of the head element’s type.

* #all. Prohibit substitution by any method.

To select more than one, you will need to type the selection into the property
field.
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Property Type Meaning
Block Multiple The block attribute on a complex type restricts the types of substitutions which
selection are allowed for elements based on that type. In the WebSphere Message Broker
enumerated its effect is the same as if the block attribute were copied from the complex type
type onto every element based on the complex type. You can select from one or more
of the following;:
* Empty
* restriction. Prohibit type substitution by elements whose types are
restrictions of the head element’s type.
+ extension. Prohibit type substitution by elements whose types are extensions
of the head element’s type.
+ #all. Prohibit substitution by any method.
To select more than one, you will need to type the selection into the property
field.
Abstract Check box If selected, no elements based on this type can appear in the message.
MRM content validation:
Content Validation is applied when the domain is MRM and validation is enabled.
The Content Validation property specifies how strictly the MRM parser validates the
members of a complex type or group.
The first table below shows the valid settings for Content Validation if Composition is
set to Message, and the second table shows the valid settings for Content Validation
if Composition is not set to Message.
Content Validation options if Composition is set to Message
Option Meaning
Open When a message is parsed, this complex type or group can contain any message, not just those
that you have defined in this message set. You can use this option for sparse messages (see
[‘Predefined and self-defining elements and messages” on page 30| for a definition of sparse
messages).
Closed When a message is parsed, this complex type or group can only contain the messages that are

members of this complex type or group. This is always the case for messages represented in
CWF format.

Open Defined

When a message is parsed, this complex type or group can contain any message defined within
the message set.

Content Validation options if Composition is not set to Message

Option Meaning

Open When a message is parsed, this complex type or group can contain any elements and not just
those that you have defined in this message set (see [“Predefined and self-defining elements and|
[messages” on page 30| for a definition of sparse messages).

Closed When a message is parsed, this complex type or group can only contain the elements that are

members of this complex type or group.

Open Defined

When a message is parsed, this complex type or group can contain any element that you have
defined within the message set.
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When you are using Content Validation set to open or open defined, you can not
specify the precise position where the content that is not modeled is permitted to
occur. If you wish to do this, you should consider using a wildcard element as an
alternative. Note that wildcard elements can only appear within a complex type or
group with Composition of sequence and Content Validation of closed.

Element reference logical properties

Property Type Meaning
Reference Name | Enumerated The Reference Name is the name of the object that this object is referring to. The
type objects available to reference can be selected from the drop-down list.
Occurrences

Property Type Meaning

Min Occurs Integer Specify the minimum number of times that the object can repeat. The default is
L.
If the value is set to 0, then t