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1 Introduction

The Sample File Event Emitter is a sample program written in Java™ that
demonstrates how an enterprise information system (ELS) resource storing data
pertaining to the state of a business can be instrumented to contribute to the

overall monitoring of the activities of a business.

The main goal of the Sample File Event Emitter is to introduce the use of the
libraries and application programming interfaces (APIs) provided by the
Common Event Infrastructure (CEI) to generate and emit business events in
the form of Common Base Events (CBEs). Common Base Events are the data
packaging and format used by the IBM WebSphere® Business Monitor

(Monitor) Server to propagate business events.

The Sample File Event Emitter is made available in two forms of packaging.
One is the binary archive, which contains the precompiled Java 2 Platform,
Enterprise Edition (J2EE) enterprise application, ready to be deployed to the
Monitor Server. It also includes the accompanying documentation. The second
is the source archive, which also includes the documentation and,
additionally, contains the source code projects that can be imported into the
IBM WebSphere Integration Developer (WID) integrated development
environment (IDE) for browsing through the source code and making custom

changes to the emitter and its configuration options.

The Sample File Event Emitter was developed and tested using the

following environment:

. Microsoft® Windows® XP Professional SP2

 IBM DB2® Universal Database™ (UDB) Enterprise Server Edition v8.1.13.193
+  WebSphere Business Monitor (Monitor) Server v6.0.2

« WebSphere Integration Developer (WID) v6.0.2

Note: The configuration and deployment information in this document
describes the Sample File Event Emitter being deployed to the Monitor Server
itself (that is, to the same application server on which Monitor runs). The
emitter can also be deployed to a separate application server and configured to
emit its events to the Monitor Server’s CEI Server (see section 3, “Configuring

and deploying the Emitter application”, for more information on this).
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Figure 1
Event Emitter Framework

2 Design Overview

2.1 Event framework

The Sample DB2 Event Emitter, along with the other sample event emitters
made available, is implemented around a common, simple emitter framework.
Figure 1 depicts a class diagram of this framework. When an eventin the enter-
prise back-end system is detected, the following flow is regulated by this

common framework:

1. Retrieve, from the EmitterFormatterFactory, an EventFormatter specific for

the type of data being processed.
2. Invoke the EventFormatter to convert the input data to a CBE object.

3. Retrieve an emitter from an EmitterFactory to be used to send the event to the

CEI Server.

4. Emit the CBE to the CEI Server.
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2.2 File Event Emitter
The Sample File Event Emitter is a J2EE enterprise application, which also

implements the WebSphere TaskHandler interface, allowing it to handle invo-

cations from a WebSphere Application Server Scheduler.The overall event

retrieval and event emission flow is explained below (see Figure 2 for a graph-

ical depiction of this flow):

1.

A file encapsulating information about a create, update, or delete event is placed
in the inbound directory. This file contains information about what data type the
event pertains to, the actual event type (that is, create, delete, or update) and the

attributes and their associated values.

The Scheduler service in the Monitor Server invokes the EmissionController at

a specified interval. The EmissionController calls EventFolderPoller. If any files
are found in the inbound directory, EventFolderPoller populates and returns a
collection of FventFileBean objects. If the collection of EventFileBean objects is not
empty, EmissionController invokes the handle() method of EventHandler for each

EventFileBean object to handle the emission steps.

EventHandler calls the EventFormatterFactory, which returns an
EventFormatter object according to the application data type specified in the
event file. The EventlFormatter object transforms the EventFileBean object into a
CommonBaseEvent object. Finally, the CEIEmitter sends the CommonBaseFvent

object to CEI Event Server.

The Sample File Event Emitter is designed so that it can be extended to handle

processing of additional application data types. This is done by creating new

classes that implement the EventFormatter interface (in the EmitterF'W project)

and “registering” application data type to event formatter associations by

updating the FileEventFormatter.properties (in the FileEmitterImpl project).
For more-extensive details on this see Section 6: Design details —creating a

new event formatter to handle additional application data types.
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Figure
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DB2EventFormatter.properties
CUSTOMER=com.ibm.whimonitor.samples.db2emitter.formatter. CUSTOMERFormatterimpl
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3 Configuring and deploying the Emitter application

This section describes how to configure the Monitor Server to host the Sample
File Event Emitter application. The following section, “Importing and working
with the source code,” describes how to import the source code into the WID

IDE and introduce modifications, if needed.

The following default are values specified in the File Emitter’s EJB deployment

descriptor. These can be customized by editing the source projects in WID and

exporting a new enterprise archive (EAR) file.
<env-entry-name>inboundEventsDirectory</env-entry-name>

<env-entry-value>C:\FileEmitter\inbound</env-entry-value>

<env-entry-name>archivedEventsDirectory</env-entry-name>
<env-entry-value>C:\FileEmitter\archive</env-entry-value>

<env-entry-name>faultDirectory</env-entry-name>
<env-entry-value>C:\FileEmitter\fault</env-entry-value>

<env-entry-name>emitterFactoryJNDI</env-entry-name>
<env-entry-value>iiop://localhost:2809/com/ibm/events/configura-
tion/emitter/Default</env-entry-value>

<env-entry-name>schedulerJNDI</env-entry-name>
<env-entry-value>sched/FolderPoller</env-entry-value>

Notes:

* The default emitter factory specified in the “emitterFactoryJNDI” environment entry refers
to “localhost” because the emitter is being deployed to the same application server as
the Monitor Server. If the emitter is deployed to its own application server, ensure that the
hostname is that of the Monitor Server (where the CEl Server resides and to where the
events will be emitted).

» The default emitter factory specified in the “emitterFactoryJNDI” environment entry uses
port 2809. Check the Monitor Server's BOOTSTRAP_ADDRESS setting to ensure that is
the correct port to use.

If any of these environment entries need to be modified, import the source
projects into WID and make the necessary modifications to the EJB deploy-
ment descriptor. (See Section 5: Importing and working with the source code

projects for instructions on how to import the source projects).

3.1 Create an IBM Cloudscape™ database for the Monitor Server Scheduler:
1. Inthe ${WBI_INSTALL_ROOT}/cloudscape/bin/embedded directory, open the

cview.bat file.
2. Select File-> New -> Database.

3. Inthe Namefield, type ${WBI _ INSTALL _ROOT}/cloudscape/
databases/SKDLR.

4. Click OK to create the new database and then exit from the cview.bat file.
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3.2 Create a data source for the Monitor Server Scheduler:

1.

2.

Open the Administrative Console.
Open the Resources-> JDBC Providers page, and set the scope to Server.

By default, there should be a Java Database Connectivity (JDBC) provider named
Cloudscape JDBC Provider (XA). Click it then select Data sources under the

Additional Properties section.

Click New to create a new data source with the following properties:

Name: SKDLR Datasource

Java Naming and Directory Interface (JNDI) name: jdbc/skdlr
Disable “Use this Data Source in container managed persistence
(CMP)”

Description: JDBC Datasource for SKDLR Database

Database name: ${WBI _INSTALL ROOT}/cloudscape/databases/SKDLR

Click OK and Save.

3.3. Create a scheduler for the File Emitter:

1.

2.

Open the Administrative Console.
Go to Resources-> Schedulers and set the scope to Server.

Click New to create a new scheduler with the following properties:

Name: FolderPoller

JNDI name: sched/FolderPoller (This is the default name specified
as an environment entry in the EJB deployment descriptor.)
Description: Scheduler for File Sample Emitter’s Inbound Folder
Poller

Data source JNDI name: jdbc/skdlr

Table prefix: FILEEMTR _

Poll interval: 30

Work managers: DefaultWorkManager

Click OK and Save.

On the Schedulers page, select the newly created FolderPoller scheduler and click

Create tables.

3.4 Deploy the File Emitter enterprise application using the
Administrative Console.

Accept all default values and save the configuration when deployment is

completed.

3.5 Create the inbound, fault and archive folders to be used for event management.

The default folder locations that are specified as environment entries in the
EJB deployment descriptor are: C:\FileEmitter\inbound, C:\FileEmitter\fault,
and C:\FileEmitter\archive.

3.6. Restart the Monitor Server.
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4 Verifying the configuration and deployment of the Emitter application

1. Ensure that the Monitor Server is started.

2. Create a file with the following contents (see Listing 1) and save it into the inbound
events directory:
EVENTTYPE=CUSTOMER
EVENTACTION=CREATE

ID=0123456789
NAME=JOHN DOE
ADDRESS=3039 CORNWALLIS ROAD
TEL=919-123-4567
EMAIL=JDOE@US.IBM.COM
3. Open a command prompt and change the directory to <MONITOR _ PROFILE _

DIR>/bin (for example, C:\IBM\WebSphere\ProcServer\prqfiles\wbmonitor\bin).

4. Run the script eventquery.jacl.
For example: wsadmin -f .\event\bin\eventquery.jacl -group “All events”
All the CBEs categorized under that group are displayed. Among them should be
one or more representing the file containing the event information that was saved in

the inbounds event folder.
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5 Importing and working with the source code projects

The source code for the Sample File Event Emitter is available in the source
archive package in the form of WID projects. The following projects need to be
imported into the workspace: EmitterFW, CEIEmitter, FileEmitterEAR,
FileEmitterE)B, and FileEmitterlmpl.

To import a project perform the following steps:

1. Open WebSphere Integration Developer.

2. From the menu bar, select File-> Import.

3. Inthe Import dialog box, select Existing Project into Workspace... then click Next.
4

. Select the project to be imported into the workspace then click Finish.
Perform these four steps for each of the five projects listed previously.

You can expect build errors to be raised until the classpath reference to the
events-client.jar library in the CEIEmitter project is corrected. The events-cli-

ent.jar library includes classes used for creating CBEs and emitting them.

Perform these additional steps:

5. Right-click the CEIEmitter project and select Properties.
6. Go to Java Build Path-> Libraries.

7. Select the events-client.jar entry then click Edit...

8. Browse to the folder in your file system where the events-client.jar file is located (for

example, <WPS_INSTALL_DIR>/CEl/client).
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5.1 Projects overview
The Sample File Event Emitter source code is split out across five logical proj-

ects as follows:

*  Emitterl’'W: The common emitter framework that is used by all the sample event

emitters made available.

* CEIEmitter: The CEIl emitter code. Thisis also common code share by all the

sample event emitters
* FileEmitterEAR: The enterprise application package that is deployed to the server.
* FileEmitterEJB: File Emitter specific EJB code.

* FileEmitterImpl: File Emitter specific code. This project contains implementation
code for retrieving records from the database and formatting events into CBEs.
Additional formatters can be implemented and added here to extend the number of
application data types that the emitter can process. (See the next section, “Design
details—creating a new event formatter to handle additional application data

types”, for more information on formatters.)
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Listing 2
FileEventFormatter.properties mapping file

6 Design details—creating a new event formatter to handle additional
application data types

The Sample File Event Emitter is designed so that it can be extended to handle
processing of additional application data types by creating new classes that
implement the EventFormatter interface (in the EmitterE'W project), and by
“registering” the event formatter associated with an application data type by

updating the FileEventFormatter.properties (in the FileEmitterlmpl project).

The inbound events folder is periodically polled by the EmissionController,
using the EventFolderPoller, for the presence of new event files. When new files
are present in the inbound events folder, the file emitter will obtain the appro-
priate formatter and retriever based on the data type recorded and based on the

mapping specified in the FileEventFormatter.properties file.

6.1 FileEmitterFormatter.properties file
The FileEmitterFormatter.properties file is a typical properties resource file
containing entries in the form of “name equals value”. Listing 2 shows the one
used by this sample.

#

# This properties file defines the formatter to use for a given data

type.

# The accepted format is:

# EventType=EventFormatter

# Where the EventFormatter is provided as the fully qualified Java
class.

#
CUSTOMER=com.ibm.wbimonitor.samples.fileemitter.formatter.
CUSTOMERFormatterImpl
ORDER=com.ibm.wbimonitor.samples.fileemitter.formatter.
ORDERFormatterImpl
CLAIM=com.ibm.wbimonitor.samples.fileemitter.formatter.
CLAIMFormatterImpl

To introduce support for a new application data type, a new entry mapping the
event name to the fully qualified event formatter implementation class needs to

be added to this file.

6.2 EventFormatter implementation

After an EventFormatter is obtained (based on the mapping in the
FileEmitterFormatter.properties file), it will be invoked to handle the transfor-
mation of the event from its “native format” to the CBE format that is expected

by the Monitor Server.
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A new EventFormatter will need to implement the EventFormatter interface
defined in the com.ibm.wbimonitor.samples.emitterframework package in the
EmitterF'W project.

public CommonBaseEvent format( Object o ) throws EventFormatFailed

Exception;

Inspect the EventFormatter classes implemented by this sample emitter for an
idea on how this format() interface can be implemented. They can be found in
the com.ibm.wbimonitor.samples.db2emitter.formatter package in the

FileEmitterImpl project.
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7 Working with CBEs and CEl-key concepts

This section outlines the key concepts related to CEl and CBEs used in the

Sample File Event Emitter.

7.1. Creating a new or obtaining an existing EventFactory

IR

Creating a new one from scratch (with and without a ContentHandler):

EventFactory eventFactory =
(EventFactory) EventFactoryFactory.createEventFactory();
EventFactory eventFactory =
(EventFactory) EventFactoryFactory.createEventFactory
(ContentHandler);

Obtaining an existing one through JNDI (inherits ContentHandler, if one exists):

Context context = new InitialContext();
EventFactory eventFactory = (EventFactory) context.lookup(“com/
ibm/events/EventFactory”);

7.2 Creating the new CommonBaseEvent:

CommonBaseEvent event = eventFactory.createCommonBaseEvent
(“ActivityEvent”);

7.3 Setting mandatory fields:

event.setVersion( “1.0.1” );

event.setCreationTimeAsLong( System.currentTimeMillis( ) );
event.setGlobalInstanceld( eventFactory.createGlobalInstanceId( )
)i

ComponentIdentification componentId = eventFactory.createCompo-
nentIdentification( );

componentId.setApplication( “DB2” ); // Additional setters avail-
able

event.setSourceComponentId( componentId );

Situation situation = eventFactory.createSituation( );
situation.setStopSituation( “EXTERNAL”, “STOP COMPLETED”,
“SUCCESSFUL” ); event.setSituation( situation );

7.4 Creating an ExtendedDataElement and its children:

ExtendedDataElement activityEventData =
event.addExtendedDataElementWithNovValue
( “ActivityEventData” );
activityEventData.addChild( “activityName”, activityName );
activityEventData.addChild( “eventType”, “completed” );
activityEventData.addChild( “activityDisplayState”, “Completed” );
activityEventData.addChildWithDateAsLongValue( “startTime”, efb.
getLastModifiedDate( ) );
activityEventData.addChildWithDateAsLongValue( “endTime”, efb.

getLastModifiedDate( ) );
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7.5 Obtaining the EmitterFactory:
import javax.naming.*
import com.ibm.events.*
Context context = new InitialContext();
EmitterFactory emitterFactory =

(EmitterFactory) context.lookup(“com/ibm/events/configuration/
emitter/Default”);

7.6 Obtaining the Emitter from the EmitterFactory:

Emitter emitter = emitterFactory.getEmitter();

7.7 Sending an Event:

emitter.sendEvent ((CommonsBaseEvent)event);
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